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Introduction

The documentation covers the following Steinberg product: Nuendo.

Platform-Independent Documentation
The documentation applies to the operating systems Windows and macOS.
Features and settings that are specific to one of these platforms are clearly indicated. In all other
cases, the descriptions and procedures in the documentation are valid for Windows and macOS.
Some points to consider:
●

The screenshots are taken from Windows.

●

Some functions that are available on the File menu on Windows can be found in the
program name menu on macOS.

About the Documentation
The documentation consists of several documents. You can read them online or download them
from steinberg.help. To visit steinberg.help, do one of the following:
●

Enter www.steinberg.help in the address bar of your web browser.

●

In the program, select Help > Nuendo Help.

Quick Start Guide
Covers the following areas without going into details:
●

System requirements, installation procedure, and license activation.

●

Setting up your system for audio and MIDI work.

Operation Manual
The main Nuendo reference documentation, with detailed descriptions of
operations, parameters, functions, and techniques.
Score Layout and Printing
Describes the professional music notation, score editing, and printing features
included in the Score Editor.
Remote Control Devices
Lists the supported MIDI remote control devices.
Plug-in Reference
Describes the features and parameters of the included VST plug-ins, VST
instruments, and MIDI effects.
HALion Sonic SE
Describes the features and parameters of the included VST instrument HALion Sonic
SE.
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Conventions
Groove Agent SE
Describes the features and parameters of the included VST instrument Groove Agent
SE.
Retrologue
Describes the features and parameters of the included VST instrument Retrologue.
MIDI Devices
Describes how to manage MIDI Devices and device panels.
VST Connect SE
Describes how to work with the VST Connect SE features.

Conventions
In our documentation, we use typographical and markup elements to structure information.

Typographical Elements
The following typographical elements mark the following purposes.
PREREQUISITE
Requires you to complete an action or to fulfill a condition before starting a
procedure.
PROCEDURE
Lists the steps that you must take to achieve a specific result.
IMPORTANT
Informs you about issues that might affect the system, the connected hardware, or
that might bring a risk of data loss.
NOTE
Informs you about issues that you should consider.
EXAMPLE
Provides you with an example.
RESULT
Shows the result of the procedure.
AFTER COMPLETING THIS TASK
Informs you about actions or tasks that you can perform after completing the
procedure.
RELATED LINKS
Lists related topics that you can find in this documentation.

Markup
Bold text indicates the name of a menu, option, function, dialog, window, etc.
EXAMPLE
To open the Functions menu, click Functions Menu in the top right corner of the MixConsole.
If bold text is separated by a greater-than symbol, this indicates a sequence of different menus
to open.
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EXAMPLE
Select Project > Add Track.

Key Commands
Many of the default key commands, also known as keyboard shortcuts, use modifier keys, some
of which are different depending on the operating system.
When key commands with modifier keys are described in this manual, they are shown with the
Windows modifier key first followed by the macOS and the key:
●

Windows modifier key/macOS modifier key-Z

EXAMPLE
Ctrl/Cmd-Z means: press Ctrl on Windows or Cmd on macOS, then press Z.
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Setting Up Your System

To use Nuendo, you must set up your audio, and if required, your MIDI system.

Setting Up Audio
IMPORTANT
Make sure that all equipment is turned off before making any connections.

Simple Stereo Input and Output Setup
If you only use a stereo input and output from Nuendo, you can connect your audio hardware,
for example, the inputs of your audio card or your audio interface, directly to the input source
and the outputs to a power amplifier and speaker.

Audio Connections
Your system setup depends on many different factors, for example, on the kind of project that
you want to create, on the external equipment that you want to use, or on the computer
hardware that is available to you. Therefore, the following sections can only serve as examples.
How to connect your equipment, that is, whether to use digital or analog connections also
depends on your setup.
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About Recording Levels and Inputs
When you connect your equipment, make sure that the impedance and levels of the audio
sources and inputs are matched. Using the correct type of input is important to avoid distortion
or noisy recordings. For example, different inputs can be used, such as consumer line level (-10
dBV) or professional line level (+4 dBu).
Sometimes, you can adjust input characteristics on the audio interface or on its control panel. For
details, refer to the documentation that came with the audio hardware.
IMPORTANT
Nuendo does not provide any input level adjustments for the signals that are coming into your
audio hardware, since these are handled differently for each card. Adjusting input levels is either
done in a special application that is included with the hardware or its control panel.

Word Clock Connections
If you are using a digital audio connection, you may also need a word clock connection between
the audio hardware and external devices. For details, refer to the documentation that came with
the audio hardware.
IMPORTANT
Set up word clock synchronization correctly, or you may experience clicks and crackles in your
recordings.

Selecting an Audio Driver
By selecting an audio driver, you allow Nuendo to communicate with the audio hardware.
Normally, when you start Nuendo, a dialog opens that prompts you to select a driver, but you
can also select your audio hardware driver as described below.
NOTE
On Windows operating systems, we recommend that you access your hardware via an ASIO
driver developed specifically for the hardware. If no ASIO driver is installed, contact the
manufacturer of your audio hardware for information on available ASIO drivers. If no specific
ASIO driver is available, you can use the Generic Low Latency ASIO driver.

PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select VST Audio System.

3.

Open the ASIO Driver pop-up menu and select your audio hardware driver.

4.

Click OK.

Setting Up Audio Hardware
PREREQUISITE
You have selected a driver for your audio hardware.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select your audio hardware driver.
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3.

Do one of the following to open the control panel for your audio hardware:
●
●

On Windows, click Control Panel.
On macOS, click Open Config App.
This button is available only for some hardware products. If it is not available in your
setup, refer to the documentation of your audio hardware.

NOTE
The control panel is provided by the manufacturer of your audio hardware and is different
for each audio interface brand and model. However, control panels for the Generic Low
Latency ASIO Driver (Windows only) are provided by Steinberg.
4.

Set up your audio hardware as recommended by the manufacturer.

VST Audio System
In the VST Audio System section you can select an ASIO driver for your audio hardware.
●

To open the VST Audio System section, select Studio > Studio Setup and select VST Audio
System in the Devices list.

The following options are available:
ASIO Driver
Allows you to select a driver.
Release Driver when Application is in Background
Releases the driver and allows other applications to play back via your audio
hardware even though Nuendo is running.
Input Latency
Shows the input latency of the audio hardware.
Output Latency
Shows the output latency of the audio hardware.
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ASIO-Guard Latency
Shows the ASIO-Guard latency.
HW Sample Rate
Shows the sample rate of your audio hardware.
HW Pull Up/Down
Shows the pull up/down status of the audio hardware.
Set to Defaults
Allows you to restore the default settings.
Processing Precision
Allows you to set the audio processing precision to 32 bit float or 64 bit float.
Depending on this setting, all channels are processed and mixed in 32-bit floatingpoint or 64-bit floating-point format.
NOTE
A processing precision of 64 bit float can increase CPU load and memory
consumption.
To show all plug-ins that support 64-bit float processing, open the VST Plug-in
Manager and activate Show Plug-ins That Support 64-Bit Processing in the
Display Options pop-up menu.
NOTE
VST2 plug-ins and instruments are always processed with 32-bit precision.
Activate Multi Processing
Allows you to distribute the processing load evenly to all available CPUs. This way,
Nuendo can make full use of the combined power of multiple processors.
Activate ASIO-Guard
Activates the ASIO-Guard. This is only available if Activate Multi Processing is
activated too.
ASIO-Guard Level
Allows you to set the ASIO-Guard level. The higher the level, the higher the
processing stability and audio processing performance. However, higher levels also
lead to an increased ASIO-Guard latency and memory usage.
Audio Priority (Windows only)
This setting should be set to Normal if you work with audio and MIDI. If you do not
use MIDI at all, you can set this to Boost.
Activate Steinberg Audio Power Scheme
If this option is activated, all power safe modes that have an impact on realtime
processing are deactivated. Note that this is only effective for very low latencies, and
that it increases the power consumption.
Disk Preload
Allows you to specify how many seconds of audio are preloaded into RAM prior to
starting playback. This allows for smooth playback.
Adjust for Record Latency
If this is activated, the plug-in latencies are taken to account during recording.
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Record Shift
Allows you to shift the recordings by the specified value.
RELATED LINKS
VST Plug-In Manager Window on page 737

ASIO Driver Setup
This section allows you to set up your ASIO driver.
●

To open the section where you can set up the ASIO driver, select Studio > Studio Setup
and select the audio driver in the Devices list.

The following options are available:
Control Panel
Opens the control panel for the audio hardware.
Input Latency
Shows the input latency of the audio driver.
Output Latency
Shows the output latency of the audio driver.
Clock Source
Allows you to select a clock source.
Externally Clocked
Activate this option if you use an external clock source.
Direct Monitoring
Activate this option to monitor via your audio hardware and to control it from
Nuendo.
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Ports Reset
Allows you to reset all port names and visibilities.
I/O
The port input/output status.
Port System Name
The system name of the port.
Show As
Allows you to rename the port. This name is used in the Input Routing and Output
Routing pop-up menus.
Visible
Allows you to activate/deactivate audio ports.
State
The state of the audio port.

Using External Clock Sources
If you are using an external clock source, Nuendo must be notified that it receives external clock
signals and derives its speed from that source.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select your audio hardware driver.

3.

Activate Externally clocked.

RESULT
Nuendo now derives its speed from the external source.
NOTE
For proper audio playback and recording, you must set the sample rate of the project to the
sample rate of the incoming clock signals.
When a sample rate mismatch occurs, the Record Format field on the status line is highlighted
in a different color. Nuendo accepts a sample rate mismatch, and playback is therefore faster or
slower.

Using Several Audio Applications Simultaneously
You can allow other applications to play back via your audio hardware even though Nuendo is
running.
PREREQUISITE
Other audio applications accessing the audio hardware are set to release the audio driver.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select VST Audio System.

3.

Activate Release Driver when Application is in Background.
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RESULT
The application that has the focus gets access to the audio hardware.

Audio Hardware Configuration
Most audio cards provide one or more small applications that allow you to customize your
hardware.
The settings are normally gathered on a control panel that can be opened from within Nuendo or
separately, when Nuendo is not running. For details, refer to the audio hardware documentation.
Settings include:
●

Selecting which inputs/outputs are active.

●

Setting up word clock synchronization.

●

Turning on/off monitoring via the hardware.

●

Setting levels for each input.

●

Setting levels for the outputs so that they match the equipment that you use for
monitoring.

●

Selecting digital input and output formats.

●

Making settings for the audio buffers.

Setting Up Input and Output Ports
Once you have selected the driver for your audio hardware and have set it up, you must specify
which inputs and outputs to use.
PREREQUISITE
You have selected a driver for your audio hardware.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select your audio hardware driver.

3.

Make your settings.

4.

Click OK.

RELATED LINKS
ASIO Driver Setup on page 16

Audio Bus Setup
Nuendo uses a system of input and output busses to transfer audio between the program and
the audio hardware.
●

Input busses let you route audio from the inputs of your audio hardware into Nuendo. This
means that audio is always recorded through one or several input busses.

●

Output busses let you route audio from Nuendo to the outputs of your audio hardware.
This means that audio is always played back through one or several output busses.

Once you have set up the internal input and output busses, you can connect your audio source,
for example a microphone, to your audio interface and start recording, playing back, and mixing.
RELATED LINKS
Audio Connections on page 22
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Monitoring
In Nuendo, monitoring means listening to the input signal while recording.
The following ways of monitoring are available.
●

Externally by listening to the signal before it reaches Nuendo.

●

Via Nuendo.

●

By using ASIO Direct Monitoring.
This is a combination of the other methods.

RELATED LINKS
External Monitoring on page 263
Monitoring via Nuendo on page 263
ASIO Direct Monitoring on page 263

Setting Up MIDI
IMPORTANT
Turn off all equipment before making any connections.

PROCEDURE
1.

Connect your MIDI equipment (keyboard, MIDI interface, etc.) to your computer.

2.

Install the drivers for your MIDI equipment.

RESULT
You can use your MIDI equipment in Nuendo.

MIDI Connections
To play back and record MIDI data from your MIDI device, for example, a MIDI keyboard, you
need to connect the MIDI ports.
Connect the MIDI output port of your MIDI device to the MIDI input port of your audio hardware.
This way, the MIDI device sends MIDI data to be played back or recorded inside your computer.
Connect the MIDI input port of your MIDI device to the MIDI output port of your audio hardware.
This way, you can send MIDI data from Nuendo to the MIDI device. For example, you can record
your own playing, edit the MIDI data in Nuendo, and then play it back on the keyboard and
record the audio that is coming out of the keyboard for a better edited performance.

Showing or Hiding MIDI Ports
You can specify if a MIDI port is listed on the MIDI pop-up menus in the program.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select MIDI Port Setup.

3.

To hide a MIDI port, deactivate its Visible column.

4.

Click OK.
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Setting Up All MIDI Inputs
When you record MIDI, you can specify which MIDI input each recording MIDI track should use.
However, you can also record any MIDI data from any MIDI input. You can specify which inputs
are included when you select All MIDI Inputs for a MIDI track.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select MIDI Port Setup.

3.

Activate In ‘All MIDI Inputs’ for a port.
NOTE
If you have a MIDI remote control unit connected, make sure to deactivate the In ‘All MIDI
Inputs’ option for that MIDI input. This avoids accidental recording of data from the
remote control when All MIDI Inputs is selected as input for a MIDI track.

4.

Click OK.

RESULT
When you select All MIDI Inputs on the Input Routing menu of a MIDI track in the Inspector,
the MIDI track uses all MIDI inputs that you specified in the MIDI Port Setup.

MIDI Port Setup
The MIDI Port Setup page in the Studio Setup dialog displays the connected MIDI devices and
allows you to set up their ports.
●

To open the MIDI Port Setup page, select Studio > Studio Setup and activate MIDI Port
Setup in the Devices list.

The following colums are displayed:
Device
The connected MIDI devices.
I/O
The port input/output status.
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Port System Name
The system name of the port.
Show As
Allows you to rename the port. This name is used in the Input Routing and Output
Routing pop-up menus.
Visible
Allows you to activate/deactivate MIDI ports.
State
The state of the MIDI port.
In 'All MIDI Inputs'
Allows you to record MIDI data from all MIDI inputs.
NOTE
Deactivate this option if you use remote control devices.
The following options are available:
Use System Timestamp for 'Windows MIDI' Inputs
Activate this option if you have persistent timing problems such as shifted notes. If
this is activated, the system timestamp is used as a time reference.
Use Device 'DirectMusic'
This option is activated by default. This allows you to use devices with a DirectMusic
device driver.
Use System Timestamp for 'DirectMusic' Inputs
Activate this option if you have persistent timing problems such as shifted notes. If
this is activated, the system timestamp is used as a time reference.

Plug and Play Support for USB MIDI Devices
Nuendo supports plug and play of USB MIDI devices. These devices can be plugged in and
switched on while the application is running.

Connecting a Synchronizer
When using Nuendo with external tape transports, you most likely must add a synchronizer to
your system.
IMPORTANT
Make sure that all equipment is turned off before making any connections.
For information on how to connect and set up your synchronizer, refer to the documentation of
your synchronizer.
RELATED LINKS
Synchronization on page 1044
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To play back and record in Nuendo, you must set up input and output busses in the Audio
Connections window. Here, you can also set up group and FX channels, external effects, external
instruments, and the Control Room.
The bus types that you need depend on your audio hardware, on your general audio setup, for
example your surround speaker setup, and on the projects that you use.

Audio Connections Window
The Audio Connections window allows you to set up input and output busses, group and FX
channels, external effects, and external instruments. Furthermore, you can use this window to
access and configure the Control Room.
●

To open the Audio Connections window, select Studio > Audio Connections.

Inputs/Outputs Tab
The Input and Output tabs allow you to set up and configure input and output busses.

The following options are available above the bus list:
+- All
Expands/Collapses all busses in the bus list.
Add Bus
Opens the Add Input Bus dialog, where you can create a new bus configuration.
Presets
Opens the Presets menu, where you can select bus configuration presets. Store
allows you to save a bus configuration as preset. Delete
deletes the selected
preset.
The following columns are available for the bus list:
Bus Name
Lists the busses. Click the name of a bus to select or rename it.
Speakers
Indicates the speaker configuration (mono, stereo, surround formats) of each bus.
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Audio Device
Shows the selected ASIO driver.
Device Port
Shows which physical inputs/outputs on your audio hardware are used by the bus.
Expand the bus entry to show all speaker channels. If the bus entry is collapsed, only
the first port that is used by this bus is visible.
The Device Port pop-up menu displays how many busses are connected to a given
port. The busses are shown in square brackets next to the port name.
Up to 3 bus assignments can be displayed in this way. If more connections have been
made, this is indicated by a number at the end of the port name.
For example, “Adat 1 [Stereo1] [Stereo2] [Stereo3] (+2)” means that the Adat1 port is
already assigned to 3 stereo busses plus 2 additional busses.

Group/FX Tab
This tab allows you to create group and FX channels/tracks and to make output assignments for
these.

The following options are available above the bus list:
+- All
Expands/Collapses all busses in the bus list.
Add Group
Opens the Add Group Channel Track dialog, where you can create a new group
channel track.
Add FX
Opens the Add FX Channel Track dialog, where you can create a new FX channel
track.
The following columns are available for the bus list:
Bus Name
Lists the busses. Click the name of a bus to select or rename it.
Speakers
Indicates the speaker configuration (mono, stereo, surround formats) of each bus.
Output Routing
Lets you select the output routing for the corresponding bus.

External FX Tab
This tab allows you to create send effect or return busses. You can use these to connect external
effects which can then be selected via the effect pop-up menus from inside the program.
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The following options are available above the bus list:
+- All
Expands/Collapses all busses in the bus list.
Add External FX
Opens the Add External FX dialog, where you can configure a new external FX.
Favorites
Lets you store external effect configurations as favorites that you can recall.
The following columns are available for the bus list:
Bus Name
Lists the busses. Click the name of a bus to select or rename it.
Speakers
Indicates the speaker configuration (mono, stereo, surround formats) of each bus.
Audio Device
Shows the selected ASIO driver.
Device Port
Shows which physical inputs/outputs on your audio hardware are used by the bus.
Expand the bus entry to show all speaker channels. If the bus entry is collapsed, only
the first port that is used by this bus is visible.
The Device Port pop-up menu displays how many busses are connected to a given
port. The busses are shown in square brackets next to the port name.
Up to 3 bus assignments can be displayed in this way. If more connections have been
made, this is indicated by a number at the end of the port name.
For example, “Adat 1 [Stereo1] [Stereo2] [Stereo3] (+2)” means that the Adat1 port is
already assigned to 3 stereo busses plus 2 additional busses.
Delay
Allows you to enter a value to compensate for an inherent delay (latency) of your
hardware effect device during playback. You can right-click the Delay column for the
effect and select Check User Delay to automatically determine the delay value.
NOTE
The latency of the audio hardware is handled automatically by Nuendo.
Send Gain
Allows you to adjust the level of the signal that is sent to the external effect.
Return Gain
Allows you to adjust the level of the signal that the external effect sends.
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NOTE
Excessive output levels from an external effect device can cause clipping in the audio
hardware. You cannot use the Return Gain setting to compensate for this. You must
lower the output level on the effect device instead.
MIDI Device
When you click in this column, a pop-up menu opens where you can disconnect the
effect from the associated MIDI device, select a MIDI device, create a new device, or
open the MIDI Device Manager to edit the MIDI device.
Used
Whenever you insert an external effect into an audio track, this column shows a
checkmark (x) to indicate that the effect is being used.

External Instruments Tab
This tab allows you to create input/output busses that can be used to connect external
instruments.

The following options are available above the bus list:
+- All
Expands/Collapses all busses in the bus list.
Add External Instrument
Opens the Add External Instrument dialog, where you can configure a new external
instrument.
Favorites
Lets you store external instrument configurations as favorites that you can recall.
The following columns are available for the bus list:
Bus Name
Lists the busses. Click the name of a bus to select or rename it.
Speakers
Indicates the speaker configuration (mono, stereo, surround formats) of each bus.
Audio Device
Shows the selected ASIO driver.
Device Port
Shows which physical inputs/outputs on your audio hardware are used by the bus.
Expand the bus entry to show all speaker channels. If the bus entry is collapsed, only
the first port that is used by this bus is visible.
The Device Port pop-up menu displays how many busses are connected to a given
port. The busses are shown in square brackets next to the port name.
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Up to 3 bus assignments can be displayed in this way. If more connections have been
made, this is indicated by a number at the end of the port name.
For example, “Adat 1 [Stereo1] [Stereo2] [Stereo3] (+2)” means that the Adat1 port is
already assigned to 3 stereo busses plus 2 additional busses.
Delay
Allows you to enter a value to compensate for an inherent delay (latency) of your
hardware effect device during playback. You can right-click the Delay column for the
instrument and select Check User Delay to automatically determine the delay value
that is used for delay compensation.
NOTE
The latency of the audio hardware is handled automatically by Nuendo.
Return Gain
Allows you to adjust the level of the signal coming in from the external instrument.
NOTE
Excessive output levels from an external effect device can cause clipping in the audio
hardware. The Return Gain setting cannot be used to compensate for this. You must
lower the output level on the effect device instead.
MIDI Device
When you click in this column, a pop-up menu opens where you can disconnect the
instrument from the associated MIDI device, select a MIDI device, create a new
device, or open the MIDI Device Manager to edit the MIDI device.
Used
Whenever you insert the external instrument into a VST instrument slot, this column
shows a checkmark (x) to indicate that the instrument is being used.

Control Room Tab
This tab allows you to enable and configure the Control Room.

The following options are available above the bus list:
+- All
Expands/Collapses all busses in the bus list.
Add Channel
Opens a menu where you can select the type of channel that you want to add. You
can add the following channels:
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●

External Input

●

Talkback

●

Cue

●

Headphone

●

Monitor

●

Monitor Source

Presets
Opens the Presets menu, where you can select bus configuration presets. Store
allows you to save a bus configuration as preset. Delete
deletes the selected
preset.
Enable/Disable Control Room
Enables/Disables the Control Room.
Open Control Room
Opens the Control Room window.
Configuration
Displays the selected channel configuration.
The following columns are available for the bus list:
Bus Name
Lists the busses. Click the name of a bus to select or rename it.
Speakers
Indicates the speaker configuration (mono, stereo, surround formats) of each bus.
Audio Device
Shows the selected ASIO driver.
Device Port
Shows which physical inputs/outputs on your audio hardware are used by the bus.
Expand the bus entry to show all speaker channels. If the bus entry is collapsed, only
the first port that is used by this bus is visible.
The Device Port pop-up menu displays how many busses are connected to a given
port. The busses are shown in square brackets next to the port name.
Up to 3 bus assignments can be displayed in this way. If more connections have been
made, this is indicated by a number at the end of the port name.
For example, “Adat 1 [Stereo1] [Stereo2] [Stereo3] (+2)” means that the Adat1 port is
already assigned to 3 stereo busses plus 2 additional busses.
RELATED LINKS
Control Room on page 420

Renaming the Hardware Inputs and Outputs
Before you set up busses, you should rename the default inputs and outputs of your audio
hardware. This allows transferring projects between different computers and setups.
For example, if you move your project to another studio, the audio hardware may be of a
different model. But if you and the other studio owner have agreed on identical names for your
inputs and outputs, Nuendo corrects inputs and outputs for your busses.
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NOTE
If you open a project that was created on another computer and the port names do not match or
the port configuration is not the same, the Missing Ports dialog appears. This allows you to
manually re-route ports that are used in the project to ports that are available on your computer.

PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select VST Audio System.

3.

Open the ASIO Driver pop-up menu and select your audio hardware driver.

4.

In the Devices list, select your audio hardware driver.

5.

In the Show As column, click on a port name and enter a new name.

6.

Repeat the previous step until you have renamed all required ports.

7.

Click OK.

RELATED LINKS
Re-Routing Missing Ports on page 94

Hiding Ports
You can hide ports that you are not using. Hidden ports are not displayed in the Audio
Connections window.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select your audio hardware driver.

3.

In the Visible column, deactivate the ports that you want to hide.

4.

Click OK.

Activating and Deactivating Ports (macOS only)
On macOS you can specify which input and output ports are active. This allows you to use the
microphone input instead of the line input or to deactivate the audio card input or output.
NOTE
This function is only available for built-in audio, standard USB audio devices, and a certain
number of other audio cards.

PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select your audio hardware driver.

3.

Click Control Panel.

4.

Activate/Deactivate ports.

5.

Click OK.
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Adding Input and Output Busses
PROCEDURE
1.

In the Audio Connections dialog, click the Inputs or Outputs tab.

2.

Click Add Bus.

3.

In the Add Input Bus dialog, configure the bus.

4.

Optional: Enter a name for the bus.
If you do not specify a name, the bus is named according to the channel configuration.

5.

Click Add Bus.
The new bus is added to the bus list.

6.

For each of the speaker channels in the bus, click in the Device Port column and select a
port of your audio hardware.

Setting the Default Output Bus (Main Mix)
The Main Mix is the default output bus to which each new audio, group, or FX channel is
automatically routed. If only one bus is available, this bus is automatically used as the default
output bus.
PREREQUISITE
Add an output bus.
PROCEDURE
1.

In the Audio Connections dialog, right-click the output bus that you want to use as default
output bus.

2.

Select Set <bus name> as Main Mix.

RESULT
The selected bus is used as default bus. The Main Mix is indicated by a speaker icon next to its
name.
RELATED LINKS
Inputs/Outputs Tab on page 22

Adding Child Busses
Child busses allow you to route tracks to particular channels within a bus.
For example, you can route a stereo track to a stereo channel pair within a surround bus. Or you
can record a stereo channel pair in the surround bus to a separate stereo track.
PROCEDURE
1.

On the Inputs tab, Outputs tab, or Group/FX tab, right-click a surround bus.

2.

Click Add Child Bus and select a channel configuration.

RESULT
The child bus is created and can be used for routing.
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Presets for Input and Output Busses
For input and output bus configurations, you can use different kinds of presets.
●

A number of standard bus configurations.

●

Automatically created presets tailored to your specific hardware configuration.
On startup, Nuendo analyzes the physical inputs and outputs that are provided by your
audio hardware and creates a number of hardware-dependent presets.

●

Your own presets.

NOTE
You can create default presets for input and output bus configurations. If you create a new
empty project, these default presets are applied. To create default presets, save your preferred
input and output bus configurations under the name Default. If you have not defined default
presets, the last used input and output bus configuration is applied when creating a new empty
project.

Saving a Bus Configuration Preset
You can save your own input and output bus configuration and the studio configuration as
presets.
PROCEDURE
1.

Select Studio > Audio Connections.

2.

Set up your bus configuration.

3.

Click Store

4.

In the Type in Preset Name dialog, enter a name.

5.

Click OK.

.

RESULT
The preset is available in the Presets menu.

Deleting a Bus Configuration Preset
PROCEDURE
1.

Select Studio > Audio Connections.

2.

From the Presets menu, select the preset that you want to delete.

3.

Click Delete

.

RESULT
The preset is deleted.

Adding Group and FX Channels
Group channels and FX channels allow you to group bus configurations.
Adding group and FX channels in the Audio Connections window is identical to creating group
channel tracks or FX channel tracks in the Project window.
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PROCEDURE
1.

In the Audio Connections dialog, click the Group/FX tab.

2.

Do one of the following:
●

To create a group channel, click Add Group.

●

To create an FX channel, click Add FX.

3.

Configure the channel.

4.

Optional: Enter a name for the group channel track.

5.

Click Add Track.
The group channel or FX channel is added to the bus list.

6.

For each of the speaker channels in the bus, click in the Output Routing column and
select a port of your audio hardware.

RELATED LINKS
Audio Effects on page 441

About Monitoring
In the Audio Connections window, you can set up the busses that are used for monitoring,
activate/deactivate and open the Control Room.
When the Control Room is disabled on the Control Room tab of the Audio Connections
window, the Main Mix bus is used for monitoring. In this case, you can adjust the monitoring
level in the MixConsole.
RELATED LINKS
Control Room on page 420
MixConsole on page 366

External Instruments and Effects
You can integrate external effect devices and external instruments, for example, hardware
synthesizers, into the sequencer signal flow.

Requirements
●

To use external effects, you need audio hardware with multiple inputs and outputs.
An external effect requires at least one input and one output or input/output pairs for
stereo effects in addition to the input/output ports that you use for recording and
monitoring.

●

To use external instruments, a MIDI interface must be connected to your computer.

●

Audio hardware with low-latency drivers.
Nuendo compensates for the input/output latency and ensures that the audio that is
processed through external effects is not shifted in time.

Connecting an External Instrument/Effect
PREREQUISITE
The hardware device has stereo inputs and outputs.
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PROCEDURE
1.

Connect an unused output pair on your audio hardware to the input pair on your external
hardware device.

2.

Connect an unused input pair on your audio hardware to the output pair on your
hardware device.
IMPORTANT
If you select input/output ports for external instruments/effects that are already used, the
existing port assignment breaks without warning.

AFTER COMPLETING THIS TASK
Once the external device is connected to the audio hardware of your computer, you must set up
the input/output busses in Nuendo.

Setting Up External Effects
PROCEDURE
1.

In the Audio Connections window, click the External FX tab.

2.

Click Add External FX.

3.

In the Add External FX dialog, enter a name for the external effect and specify the send
and return configurations.
Depending on the type of effect, you can specify mono, stereo, or surround configurations.

4.

Click Associate MIDI Device and select a MIDI device.

You can also select MIDI Devices > Create Device and create a new MIDI device
association.
NOTE
Delay compensation is only applied for the effect when you use MIDI devices.
5.

Click OK.
This adds a new external FX bus.

6.

Click in the Device Port column for the left and right ports of the send bus and select the
outputs of your audio hardware that you want to use.

7.

Click in the Device Port column for the left and right ports of the return bus and select the
inputs of your audio hardware that you want to use.

8.

Make additional settings for the bus.
You can also adjust the settings while using the external effect. This allows you to hear the
result.
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RELATED LINKS
Using MIDI devices on page 775
Delay Compensation on page 732

Adding External Effects
You can use the external FX bus as an insert effect or as a send effect, which is an insert effect on
an FX channel track.
PREREQUISITE
Set up your external effects in the Audio Connections window.
PROCEDURE
1.

In the Inspector, open the Inserts panel.

2.

Open the Select Insert menu.

3.

Select an external effect from the External Plug-ins submenu.
External effects are indicated by an x icon in the list next to their names in the Select
Insert pop-up menu.

RESULT
The external FX bus is loaded into the effect slot.
A parameter window opens, showing the Delay, Send Gain, and Return Gain settings for the
external FX bus. You can adjust these settings while playing back.
The audio signal from the channel is sent to the outputs on the audio hardware, through your
external effect device, and back to the program via the inputs on the audio hardware.
RELATED LINKS
Setting Up External Effects on page 32

External Effect Parameter Window
This window allows you to make delay and gain settings for the selected external effect.
When you select an external effect from the Select Insert menu in the Inspector, the External
Effect Parameter window opens.

Activate Effect
Activates/Deactivates the external effect.
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Bypass Effect
Allows you to bypass the external effect.
Measure Effect’s Loop Delay for Delay Compensation
If this option is activated, Nuendo automatically determines the delay value that is
used for delay compensation. This is the same function as the Check User Delay
option in the Audio Connections window.
When you have defined a MIDI device for the effect, the corresponding device
window opens.
Delay
Allows you to adjust the delay for the external effect.
Send Gain
Allows you to adjust the send gain for the external effect.
Return Gain
Allows you to adjust the return gain for the external effect.

Setting Up External Instruments
PROCEDURE
1.

In the Audio Connections window, click the External Instruments tab.

2.

Click Add External Instrument.

3.

In the Add External Instrument dialog, enter a name for the external instrument and
specify the number of required mono and/or stereo returns.
Depending on the type of instrument, a specific number of mono and/or stereo return
channels is required.

4.

Click Associate MIDI Device and select a MIDI device.

5.

Click OK.
This adds a new external instrument bus.

6.

Click in the Device Port column for the left and right ports of the return bus and select the
inputs of your audio hardware to which you connected the external instrument.

7.

Make additional settings for the bus.
You can also adjust the settings while using the external instrument. This allows you to
hear the result.

RELATED LINKS
Using MIDI devices on page 775

Adding External Instruments
PREREQUISITE
Set up your external instruments in the Audio Connections window.
PROCEDURE
1.

Select Studio > VST Instruments.
The VST Instruments window opens.

2.

Click Add Track Instrument

.
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The Add Instrument Track window opens.
3.

Select an external instrument from the Instrument pop-up menu.
External instruments are indicated by an x icon in the list next to their names in the
Instrument pop-up menu.

4.

Click Add Track.

RESULT
The external instrument is added to the VST instruments list.

A parameter window for the external instrument opens. This can either be the device window
that allows you to create a generic device panel, an OPT editor window, or a default editor.

External Instruments Parameter Window
This window allows you to make delay and gain settings for the selected external instrument.
When you select an external instrument in the VST Instruments window, the External
Instrument Parameter Window opens.

Activate External Instrument
Activates/Deactivates the external instrument.
Bypass External Instrument
Allows you to bypass the external instrument.
Delay
Allows you to adjust the delay for the external instrument.
Return Gain
Allows you to adjust the return gain for the external instrument.

Sending MIDI Notes to External Instruments
PREREQUISITE
Set up your external instruments in the Audio Connections window and add a MIDI track.

35

Audio Connections
External Instruments and Effects

PROCEDURE
1.

In the Inspector, open the Output Routing pop-up menu for the corresponding MIDI
track.

2.

Select the MIDI device to which the external instrument is connected.

RESULT
The instrument plays any MIDI notes that it receives from the track and returns them to Nuendo
through the return channels that you have set up. Delay compensation is used.
The external instrument behaves like any other VST instrument in Nuendo.
RELATED LINKS
Delay Compensation on page 732

Saving External Instrument and Effect Configurations as Favorites
You can save external instruments and external effects as favorites. Favorites are device
configurations that you can recall. They also allow you to save different configurations for the
same device, for example, a multi-effect board or an effect that provides both a mono and a
stereo mode.
You can save and restore the favorites in the External Instruments and External FX tabs of the
Audio Connections window.
●

To save an external instrument or effect configuration as a favorite, select the Bus Name,
click Favorites, and select Add Selected Effect <effect name> to Favorites.

●

To recall a favorite, click Favorites and select the configuration that you want to recall.

Freezing External Instruments/Effects
You can freeze external instruments and effects to save processing power.
NOTE
You must perform the freeze function in realtime. Otherwise external effects are not taken into
account.
When freezing external instruments or effects, you can adjust the corresponding Tail Size value
in the Freeze Channel Options dialog.
When the Tail Size is set to 0 s, freezing only takes into account the data within the part
boundaries.

RELATED LINKS
VST Instruments on page 724
Audio Effects on page 441
Freezing Instruments on page 730
Freezing Insert Effects on page 447

Missing Plug-ins
The “Plug-in could not be found” message appears in the following situations:
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●

When you remove an external device from the Audio Connections window although it is
used in a saved project.

●

When you transfer a project to another computer on which the external device is not
defined.

●

When you open a project that is created with an earlier version of Nuendo.

In the Audio Connections window, the broken connection to the external device is indicated by
an icon in the Bus Name column.
●

To reestablish the broken connection to the external device, right-click the entry for the
device in the Bus Name column and select Connect External Effect.

NOTE
Busses that are set up for external instruments or external effects are saved globally, that is, for
your particular computer setup.

Editing the Bus Configurations
After you have set up all the required busses for a project you can edit the names and change
port assignments. The bus configuration is saved with the project.

Removing Busses
PROCEDURE
●

In the Audio Connections window, right-click a bus in the list and select Remove Bus.
You can also select the bus and press Backspace.

Changing Port Assignments
You can change the port assignment of busses in the Audio Connections window.
●

To change a port assignment, click in the Device Port column of a bus and select a new
port.

●

To assign different ports to the selected busses, open the Device Port pop-up menu for
the first selected entry, press Shift, and select a device port.
All subsequent busses are automatically connected to the next available port.
NOTE
Exclusive ports, for example, ports that are already assigned to Control Room channels,
are skipped.

●

To assign the same port to all selected busses, open the Device Port pop-up menu for the
first selected entry, press Shift-Alt, and select a device port.

Renaming Multiple Busses
You can rename all the selected busses at once using incrementing numbers or letters.
●

To use incrementing numbers, select the busses that you want to rename and enter a new
name for one of the busses, followed by a number.
For example, if you have 8 inputs that you want to be named “In 1, In 2, …, In 8”, you select
all the busses and enter the name In 1 for the first bus. All other busses are then renamed
automatically.
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●

To use letters from the alphabet, select the busses that you want to rename and enter a
new name for one of the busses, followed by a space and a capital letter.
For example, if you have 3 FX channels that you want to be named “FX A, FX B, and FX C”,
you select all the channels and enter the name FX A for the first. All other channels are
renamed automatically. The last letter that can be used is Z. If you have more selected
entries than there are letters available, the remaining entries are skipped.

NOTE
You can begin renaming from any position in the list. The renaming starts from the bus where
you edit the name, goes down the list to the bottom, and then continues from the top until all
selected busses have been renamed.

Identifying Exclusive Port Assignments
For certain channel types, the port assignment is exclusive.
Once a port has been assigned to such a bus or channel, it must not be assigned to another bus,
otherwise the connection to the first bus will be broken.
The corresponding ports are marked in the Audio Connections window on the Device Port popup menu.
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The Project window provides an overview of the project, and allows you to navigate and perform
large scale editing.
Each project has one Project window. The Project window is displayed whenever you open or
create a new project.
●

To open a project, select File > Open.

●

To create a new project, select File > New Project.

The Project window is divided into several zones:
1

Left Zone
The left zone shows the Track Inspector for the selected track or the Editor Inspector for
the editor in the lower zone.
The Visibility Inspector allows you to show or hide individual tracks from the track list.

2

Project Zone
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The project zone shows the toolbar, the track list with the tracks, the event display with the
parts and events of the project, and the Project window ruler.
On the toolbar, you can activate/deactivate the status line, the info line, the overview line,
and the transport.
3

Lower Zone
The lower zone shows the Chord Pads, the Editor, the Sampler Control, and the
MixConsole.

4

Right Zone
The right zone shows the VSTi rack, the Media rack, the Control Room rack, and the
Meter rack.

RELATED LINKS
Project Zone on page 40
Left Zone on page 53
Lower Zone on page 62
Right Zone on page 68
Toolbar on page 41

Showing/Hiding Zones
You can show/hide the zones in the Project window according to your needs.
PROCEDURE
●

Do one of the following:
●

To show/hide the left zone, click Show/Hide Left Zone
toolbar.

on the Project window

●

To show/hide the lower zone, click Show/Hide Lower Zone
toolbar.

●

To show/hide the right zone, click Show/Hide Right Zone
toolbar.

on the Project window
on the Project window

NOTE
The project zone is always shown.

Project Zone
The project zone is the heart of the Project window and cannot be hidden.
The project zone features the track list and the event display with the ruler. Furthermore, you can
activate/deactivate the status line, the info line, the overview line, and the transport for the
project zone.
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RELATED LINKS
Track List on page 45
Event Display on page 46
Global Track Controls on page 46
Ruler on page 47
Status Line on page 49
Info Line on page 50
Overview Line on page 50
Transport on page 51

Toolbar
The toolbar contains tools and shortcuts for opening other windows and various project settings
and functions.
●

To show/hide tools, open the toolbar context menu by right-clicking in an empty area of
the toolbar and activate the tools that you want to display. To show all tools, select Show
All.
NOTE
The number of elements that are shown also depends on the size of the Project window
and the screen resolution.

The following options are available:
Activate Project

NOTE
This button is only available if more than one project is open.
Allows you to activate a project.
Project History
Allows you to undo/redo actions in the Project window.
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Constrain Delay Compensation
Allows you to minimize the latency effects of the delay compensation.
Left Divider

Allows you to use the left divider. Tools that are placed to the left of the divider are
always shown.
Media & MixConsole Windows
These buttons allow you to open or close the MediaBay, the Pool, the MixConsole,
the Control Room, and the Direct Offline Processing.
Track Visibility Configurations
Allows you to create configurations that are useful for switching between different
visibility setups.
State Buttons
These buttons show the mute, solo, listen, and automation states.
Network Controls
These buttons allow you to share or sync your project or to commit changes when
using the network functions.
Automation Mode
Shows the automation mode and allows you to open the Automation Panel.
Activate Automation Follows Events if you want your automation events to follow
automatically when you move an event or part on a track.
Auto-Scroll
Allows you to keep the project cursor visible during playback.
Locators
Allows you to go to the left or right locator position, and to set the left and right
locator position numerically.
Shows the left and right locator positions.
Transport Buttons
Shows the main transport controls.
External Sync State
Allows you to activate/deactivate external synchronization and to open the Project
Synchronization Setup dialog.
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Arranger Controls
Shows the controls for the arranger track.
Time Display

Shows the position of the project cursor in the selected time format.
Markers

Allows you to set and locate marker positions.
Tool Buttons

Shows the buttons for editing in the project zone.
Color Menu
Allows you to define the project colors.
Nudge Palette
Allows you to nudge or trim events or parts.
Project Root Key
Allows you to change the root key of the project.
Snap to Zero Crossing
If this option is activated, it finds zero crossings when you split and size audio events.
Snap On/Off
Allows you to activate/deactivate snap to restrict horizontal movement and
positioning to certain positions.
Snap Type
Allows you to specify to what positions you want events to snap.
Grid Type
Allows you to specify a grid type for the snap function. This setting only has effect if
Snap Type is set to one of the grid options.
Quantize
Allows you to move recorded audio or MIDI to musical relevant positions.
Audio Alignment

43

Project Window
Project Zone
Allows you to match the timing of audio events or selection ranges.
System Performance Meter

Shows the meters for ASIO time usage and hard disk transfer load.
Right Divider

Allows you to use the right divider. Tools that are placed to the right of the divider
are always shown.
Window Zone Controls
Allows you to show or hide the left zone, the lower zone, and the right zone of the
Project window. The Setup Window Layout pop-up menu allows you to show or
hide the status line, the info line, the overview line, and the Transport.
Set Up Toolbar
Opens a pop-up menu where you can set up which toolbar elements are visible.
RELATED LINKS
Left/Right Toolbar Divider on page 44
Snap Types on page 80
Arranger Track on page 317
Markers on page 334
Automation on page 695
Synchronization on page 1044
Audio Alignment on page 539

Left/Right Toolbar Divider
The left and right toolbar dividers allow you to lock the position of specific tools at the left or at
the right side of the toolbar, so that they are always shown.
All other items are shown in the center of the toolbar. When you reduce the width of the Project
window, these toolbar items are hidden successively. When you increase the width, they are
shown again.

Toolbox
The toolbox makes the editing tools from the toolbar available at the mouse pointer position. It
can be opened instead of the standard context menus in the event display and editors.

●

To activate the toolbox function, activate Pop-up Toolbox on Right-Click in the
Preferences dialog (Editing—Tools page).

●

To open the toolbox, right-click in the event display or editor.
If Pop-up Toolbox on Right-Click is deactivated, the context menu opens.

●

To open the context menu instead of the toolbox, press any modifier key and right-click in
the event display or editor.
If Pop-up Toolbox on Right-Click is deactivated, press any modifier key to open the
toolbox instead of the context menu.
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●

To change the number of rows in which the tools are arranged on the toolbox, keep the
right mouse button pressed on the toolbox until the mouse pointer changes to a double
arrow, and drag to the bottom or right.

Track List
The track list shows the tracks that are used in the project. When a track is added and selected, it
contains name fields and settings for this track.

●

To decide which controls are visible for each track type, right-click the track list and open
the Track Controls Settings dialog.

RELATED LINKS
Track Control Settings on page 99

Dividing the Track List
You can divide the track list into an upper track list and a lower track list. These track lists can
have independent zoom and scroll controls.
Dividing the track list is useful if you are working with a video track and multi-track audio, for
example. It allows you to place the video track in the upper track list and to scroll the audio tracks
separately in the lower track list, so that they can be arranged with the video.
●

To divide the track list, select Project > Divide Track List.
You can also click Divide Track List in the top right corner of the Project window below
the ruler.

Video, marker, or arranger tracks are automatically moved to the upper track list. All other track
types are moved to the lower track list.
●

To move any type of track from the lower track list to the upper and vice versa, right-click it
in the track list and select Toggle Track List from the context menu.

●

To resize the upper part of the track list, click and drag the divider between the track list
sections.

●

To revert to a single track list, click Divide Track List again.
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Event Display
The event display shows the parts and events that are used in the project. They are positioned
along the timeline.

Global Track Controls
The global track controls above the track list allows you to manage the tracks in the track list.

1

Filter Track Types
Allows you to determine which track types are shown in the track list.

2

Number of Visible Tracks
Displays how many tracks are hidden. Click this, to show all tracks that are filtered out with
the Track Visibility.
NOTE
If the track was outside the view or hidden, it is now shown. Tracks that are hidden using
Filter Track Types are not shown.

3

Add Track
Allows you to add tracks to the track list.

4

Find Tracks
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Allows you to find and select a specific track in the track list.
RELATED LINKS
Opening the Track Visibility on page 59

Filtering Track Types
PROCEDURE
1.

Click Filter Track Types above the track list.
This opens the track types filter.

2.

Uncheck a track type to hide it.

RESULT
Tracks of the filtered type are removed from the track list and the color of the Filter Track Types
button changes to indicate that a track type is hidden.

Finding Tracks
The Find Tracks function allows you to find specific tracks. This is useful if you have a large
project with many tracks or if you have hidden tracks using the track visibility features.
PROCEDURE
1.
2.

Click Find Tracks above the track list, to open a selector that lists all tracks.
In the search field, enter the name of the track.
As you type, the selector updates automatically.

3.

In the selector, select the track and press Return.

RESULT
The selector closes and the track is selected in the track list.
NOTE
If the track was outside the view or hidden, it is now shown. Tracks that are hidden using Filter
Track Types are not shown.

Ruler
The ruler shows the timeline and the display format of the project.
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Initially, the Project window ruler uses the display format that is specified in the Project Setup
dialog.
●

To select an independent display format for the ruler, click the arrow button to the right of
the ruler and select an option from the pop-up menu.

●

To set the display format globally for all windows, use the primary display format pop-up
on the Transport panel, or hold down Ctrl/Cmd and select a display format in any ruler.

RELATED LINKS
Project Setup Dialog on page 89

Ruler Display Formats
You can select a display format for the ruler.
●

To select a new display format for the ruler, click the arrow button to the right of the ruler
and select an option from the pop-up menu.

The selection that you make affects the time display formats in the following areas:
●

Ruler

●

Info line

●

Tooltip position values

The following options are available:
Bars+Beats
Bars, beats, sixteenth notes, and ticks. By default, there are 120 ticks per sixteenth
note. To change this, adjust the MIDI Display Resolution setting in the Preferences
dialog (MIDI page).
Seconds
Hours, minutes, seconds, and milliseconds.
Timecode
Hours, minutes, seconds, and frames. The number of frames per second (fps) is set
in the Project Setup dialog with the Frame Rate pop-up menu. To display
subframes, activate Show Timecode Subframes in the Preferences dialog
(Transport page).
Feet+Frames 16 mm
Feet and frames, with 40 frames per foot. To let the beginning of a project always
start at 0’00, regardless of any Start offset settings in the Project Setup dialog,
activate Feet’n’Frames Count from Project Start in the Preferences dialog
(Transport page).
Feet+Frames 35 mm
Feet, frames, and 1/4 frames, with 16 frames per foot. To let the beginning of a
project always start at 0’00, regardless of any Start offset settings in the Project
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Setup dialog, activate Feet’n’Frames Count from Project Start in the Preferences
dialog (Transport page).
Samples
Samples.
fps (User)
Hours, minutes, seconds, and frames, with a user-definable number of frames per
second. To display subframes, activate Show Timecode Subframes in the
Preferences dialog (Transport page). You can also set the number of fps.
Time Linear
Sets the ruler linear to time.
Bars+Beats Linear
Sets the ruler linear to bars and beats.

Status Line
The status line shows the most important project settings.
To activate the status line, click Set up Window Layout on the toolbar and activate Status Line.

The following information is shown on the status line:

Audio Inputs/Audio Outputs
These fields are shown if the audio device ports are not connected. Click to open the
Audio Connections dialog and connect the ports.
Max. Record Time
Displays the remaining time for recording, depending on your project settings and
the available hard disk space. Click in this field to display the remaining record time
in a separate window.
Record Format
Displays the sample rate and the bit depth used for recording. Click in this field to
open the Project Setup dialog.
Project Frame Rate
Displays the frame rate used in the project. Click in this field to open the Project
Setup dialog.
Project Audio Pull
Displays the audio pull setting used in the project. Click in this field to open the
Project Setup dialog.
Project Pan Law
Displays the current pan law setting. Click in this field to open the Project Setup
dialog.

49

Project Window
Project Zone

Info Line
The info line shows information about the event or part that you selected in the project zone.

To activate the info line, click Set up Window Layout on the toolbar and activate Info Line.

Editing on the Info Line
You can edit almost all event or part data on the info line using regular value editing.
If you select several events or parts, the info line is shown in another color and only the
information about the first item in the selection is displayed. The following rules apply:
●

Value changes are applied to all selected elements, relatively to the current values.
For example, you have selected two audio events. The first event has a length of 1 bar, the
second of 2 bars. If you change the info line value to 3, the first event is resized to 3 bars
and the second event to 4 bars.

●

Value changes are applied absolutely to the current values if you press Ctrl/Cmd while
modifying the value on the info line.
In the example above, both events are resized to 3 bars.
NOTE
To change the modifier, select a new modifier in the Info Line category of the Preferences
dialog (Editing—Tool Modifiers page).

Overview Line
The overview line allows you to zoom and navigate to other sections in the project.

To activate the overview line, click Set up Window Layout on the toolbar and activate Overview
Line.

In the overview line, events and parts are displayed as boxes. A rectangle indicates the section of
the project that is displayed in the event display.
●

To zoom the event display in or out horizontally, resize the rectangle by dragging the
edges.

●

To navigate to another section of the event display, drag the rectangle to the left or right,
or click in the upper part of the overview.
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Transport
The Transport allows display the transport functions in an integrated and fixed zone of the
Project window.

●

To activate the Transport, click Set up Window Layout on the Project window toolbar and
activate Transport.

●

To show/hide tools, open the Transport context menu by right-clicking in an empty area of
the Transport and activate the tools that you want to display. To show all tools, select
Show All.

The following options are available:
Constrain Delay Compensation
Allows you to minimize the latency effects of the delay compensation.
Common Record Modes
Allow you to determine what happens if you click Record during an audio or MIDI
recording.
Audio Record Modes
Allow you to select what happens when you record over existing audio events.
MIDI Record Modes
Allow you to select what happens when you record over existing MIDI parts.
Left Divider

Allows you to use the left divider. Tools that are placed to the left of the divider are
always shown.
System Performance Meter

Shows the meters for ASIO time usage and hard disk transfer load.
Locators

Allows you to go to the left or right locator position, and to set the left and right
locator position numerically.
Punch Points
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Allows you to activate/deactivate Punch In and Punch Out. These points determine
the record start and stop positions.
The section to the right of the punch buttons allows you to set up the punch
positions numerically. For this to work, Lock Punch Points to Locators must be
deactivated. You can hide/show that section by clicking the points on the divider.
Main Transport

Shows the main transport controls.
Time Displays

Shows the time display options.
Pre-roll & Post-roll

Allows you to activate/deactivate pre-roll and post-roll, and to set the values
numerically.
Tempo & Time Signature

Allows you to activate/deactivate the tempo track, and to set the tempo value and
the first time signature value numerically.
External Sync State
Allows you to activate/deactivate external synchronization and to open the Project
Synchronization Setup dialog.
Click & Count-In & Click Pattern
Allows you to activate/deactivate the metronome click, the metronome click in countin, and the click pattern.
Right Divider

Allows you to use the right divider. Tools that are placed to the right of the divider
are always shown.
Input/Output Activity

Allows you to monitor the MIDI input/output signals, the audio input/output signals,
and allows you to control the output level.
RELATED LINKS
Common Record Modes on page 262
Audio Record Modes on page 267
MIDI Record Modes on page 273
Left/Right Toolbar Divider on page 44
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Left Zone
The left zone of the Project window allows you to display the Inspector and the Visibility.
To show/hide the left zone, click Show/Hide Left Zone on the Project window toolbar.

The top of the left zone features two tabs: Inspector and Visibility.

RELATED LINKS
Inspector on page 53
Visibility on page 59

Inspector
The Inspector allows you to show controls and parameters for either the selected track in the
track list or the event or part that is shown in the editor in the lower zone.
If the Inspector tab is activated at the top of the left zone, the bottom of the left zone features
two tabs: Track and Editor.
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●

Click the Track tab to open the Track Inspector for the selected track.

●

Click the Editor tab to open the Editor Inspector for the event or part that is shown in the
editor in the lower zone.

RELATED LINKS
Opening the Track Inspector on page 54
Opening the Editor Inspector on page 55
Opening the Editor in the Lower Zone on page 66

Opening the Track Inspector
The Track Inspector shows controls and parameters for the selected track in the track list.
PROCEDURE
1.

Click Show/Hide Left Zone

on the Project window toolbar to activate the Left Zone.

2.

At the bottom of the left zone, click the Track tab.
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RESULT
The Track Inspector for the selected track in the track list is opened. If more than one track is
selected, the controls and parameters for the topmost selected track are shown.

Opening the Editor Inspector
The Editor Inspector shows controls and parameters for the event or part that is shown in the
editor in the lower zone.
PREREQUISITE
The Sample Editor, the Key Editor, the Drum Editor or the Score Editor is shown in the lower
zone.
PROCEDURE
1.

Click Show/Hide Left Zone

on the Project window toolbar to activate the Left Zone.

2.

At the bottom of the left zone, click the Editor tab.
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RESULT
The Editor Inspector for the event or part that is shown in the editor in the lower zone is
opened.
NOTE
The Editor Inspector only contains information if the lower zone shows an editor. Otherwise, it is
empty.

RELATED LINKS
Opening the Editor in the Lower Zone on page 66

Selecting a different Inspector for the Score Editor
The Score Editor Inspector allows you to select the following tabs: Inspector and Symbols.
PREREQUISITE
The Score Editor is shown in the lower zone.
PROCEDURE
1.

At the bottom of the left zone, click the Editor tab.

2.

Select an option from the Switch Score Editor Inspector Content pop-up menu.
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RESULT
The selected Inspector is shown.
RELATED LINKS
Key Editor Inspector on page 812

Inspector Sections
The Track Inspector and the Editor Inspector are divided into a number of sections that each
contain different controls for the track, event or part.
Not all Inspector sections are shown by default. The available sections depend on the type of the
selected track, event, or part, and on the settings in the setup dialog for the Track Inspector/
Editor Inspector.
●

To open/close sections, click their names.
Opening one section closes the other sections.

●

To open a section without closing the other sections, Ctrl/Cmd-click the section name.

RELATED LINKS
Inspector Settings Dialog on page 57
Audio Track Inspector on page 101
Instrument Track Inspector on page 109
MIDI Track Inspector on page 116
Sampler Track Inspector on page 123
Arranger Track Inspector on page 129
Marker Track Inspector on page 146
Signature Track Inspector on page 148
Tempo Track Inspector on page 150
Transpose Track Inspector on page 151
VCA Fader Track Inspector on page 152
Video Track Inspector on page 154
Loudness Track Inspector on page 156
Key Editor Inspector on page 812
Drum Editor Inspector on page 842
Sample Editor Inspector on page 510

Inspector Settings Dialog
The Inspector settings dialogs allow you to set up the sections that are available in the Track
Inspector and the Editor Inspector.
●

To open the Setup dialog for the Track Inspector settings, click Setup Inspector
Track Inspector, and from the pop-up menu select Setup.
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●

To open the Setup dialog for the Editor Inspector settings, click Setup Inspector
Editor Inspector, and from the pop-up menu select Setup.
NOTE
This is only available for the Key Editor, the Drum Editor and the Score Editor.

Hidden Items
Displays sections that are hidden in the Inspector.
Visible Items
Displays sections that are visible in the Inspector.
Pin
If you activate Pin by clicking the column for a section the open/close status of the
selected Inspector section is pinned.
Add
Allows you to move an item selected in the hidden sections list to the list of visible
sections.
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Remove
Allows you to move an item selected in the visible sections list to the list of hidden
sections.
Move Up/Move Down
Allows you to change the order of an item in the list of visible sections.
Presets
Allows you to save Inspector section settings as presets.
Reset All
Allows you to restore the default Inspector section settings.

Visibility
The Visibility Inspector allows you to show or hide individual tracks from the track list and to
determine the position of certain MixConsole channels in the lower zone.
If the Visibility tab is activated at the top of the left zone, the bottom of the left zone features
two tabs: Track and Zones.
●

Activate the Track tab to open the Track Visibility that allows you to show or hide
individual tracks from the track list.

●

Activate the Zones tab to open the Zones Visibility that allows you to determine and lock
the position of certain MixConsole channels in the lower zone.

RELATED LINKS
Opening MixConsole in the Lower Zone on page 64

Opening the Track Visibility
The Track Visibility allows you to show or hide individual tracks from the track list.
PROCEDURE
1.

Click Show/Hide Left Zone on the Project window toolbar to activate the Left Zone.

2.

At the top of the left zone, click the Visibility tab.

3.

At the bottom of the left zone, click the Track tab.
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RESULT
The Track Visibility for your project is shown.
RELATED LINKS
Showing/Hiding Individual Tracks on page 60

Showing/Hiding Individual Tracks
The Track Visibility shows a list of all tracks of your project. This list allows you to show and hide
individual tracks.

●

To show/hide a track in the track list, check/uncheck it by clicking to the left of the track
name.

●

To activate/deactivate several tracks at the same time, select them and press Return.

●

To show a hidden track exclusively, check it by Shift-clicking to the left of the track name.

●

To expand or collapse a folder, click the triangle to the left of a folder track.

NOTE
●

The channels of the MixConsole in the lower zone are updated accordingly. This means
that if you hide a track with the Track Visibility, the channel corresponding to that track is
also hidden in the MixConsole in the lower zone.

●

If you want to synchronize the track and the channel visibility in a separate MixConsole
window, you must use the Sync Track/Channel Visibility function.

RELATED LINKS
Synchronizing Track and Channel Visibility on page 61
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Synchronizing Track and Channel Visibility
You can synchronize the track visibility in the Project window with the channel visibility in a
separate MixConsole window.
PROCEDURE
1.

At the top of the left zone, open the Visibility tab.

2.

At the bottom of the left zone, open the Track tab.

3.

Click the equals sign to open the Sync Visibility of Project and MixConsole: On/Off
menu.

4.

Select Sync Project and MixConsole to synchronize the track visibility with the channel
visibility.

RESULT
The track and channel visibility are synchronized.
NOTE
●

You can only synchronize the track visibility in the Project window with the channel
visibility of one MixConsole. If you enable Sync Visibility of Project and MixConsole:
On/Off for a second MixConsole, the first link is lost.

●

If you divide the track list, the top part of the list is not affected. Likewise, channels in the
left or right zones of the MixConsole are not synchronized.

RELATED LINKS
Synchronizing Channel and Track Visibility on page 372

Opening the Zones Visibility
The Zones Visibility allows to determine and lock the position of certain MixConsole channels in
the lower zone.
PROCEDURE
1.

At the top of the left zone, click the Visibility tab.

2.

At the bottom of the left zone, click the Zones tab.
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RESULT
The MixConsole is opened in the lower zone, and the Zones Visibility for the MixConsole in the
lower zone is shown in the left zone.
RELATED LINKS
Opening MixConsole in the Lower Zone on page 64

Lower Zone
The lower zone of the Project window allows you to display specific windows and editors in an
integrated and fixed zone of the Project window. This is useful if you work on single screen
systems and notebooks, for example.
To show/hide the lower zone, click Show/Hide Lower Zone on the Project window toolbar.

The lower zone features the following tabs: Chord Pads, MixConsole, Sampler Control, and
Editor.

To close the lower zone, click Close Lower Zone to the left of the tabs.
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RELATED LINKS
Opening Chord Pads on page 63
Opening MixConsole in the Lower Zone on page 64
Opening Sampler Control on page 65
Opening the Editor in the Lower Zone on page 66

Setting up the Lower Zone
In the lower zone, the tabs MixConsole, Editor, Sampler Control, and Chord Pads are shown.
You can change the order of these tabs, and you can hide tabs that you do not need.
PROCEDURE
1.

Click Set up Lower Zone in the bottom right of the lower zone.

2.

Do one of the following:
●

Activate/Deactivate the options in the pop-up menu to show/hide tabs from the
lower zone.

●

Select Setup to open a dialog where you can activate/deactivate the tabs and
change their position.
NOTE
In the Presets section of this dialog you can also save a preset of your tab
configuration.

RESULT
The tabs in the lower zone are shown according to your configuration.

Opening Chord Pads
Chord Pads allow you to play with chords, and to change their voicings and tensions.
PREREQUISITE
The Chord Pads tab is activated in the Lower Zone Setup.
PROCEDURE
1.

Click Show/Hide Lower Zone

on the Project window toolbar to activate the lower zone.

2.

At the bottom of the lower zone, click the Chord Pads tab.
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RESULT
The Chord Pads are opened.
RELATED LINKS
Chord Pads on page 920
Setting up the Lower Zone on page 63

Opening MixConsole in the Lower Zone
The MixConsole in the lower zone allows you to perform all basic mixing procedures from within
the lower zone of the Project window, and at the same time to see the context of your tracks and
events.
PROCEDURE
1.

Click Show/Hide Lower Zone

on the Project window toolbar to activate the lower zone.

2.

At the bottom of the lower zone, click the MixConsole tab.
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RESULT
The MixConsole is opened in the lower zone.
RELATED LINKS
MixConsole in Lower Zone on page 366

Opening Sampler Control
Sampler Control allows you display and edit the waveform of an audio sample on a sampler
track.
PROCEDURE
1.

Click Show/Hide Lower Zone

on the Project window toolbar to activate the lower zone.

2.

At the bottom of the lower zone, click the Sampler Control tab.

RESULT
Sampler Control is opened.
RELATED LINKS
Controlling Sample Playback with Sampler Tracks on page 573
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Opening the Editor in the Lower Zone
The Editor in the lower zone allows you to perform event editing procedures from within the
lower zone of the Project window, and at the same time to see the context of your tracks and
events.
NOTE
By default, double-clicking an audio event/part or a MIDI part in the event display or selecting it
and pressing Return opens the corresponding editor in the lower zone of the Project window.
Using a menu command opens a separate editor window. You can change this in the
Preferences dialog (Editors page).

PROCEDURE
1.

Click Show/Hide Lower Zone

2.

At the bottom of the lower zone, click the Editor tab.

3.

In the event display, do one of the following:
●

Select a MIDI part.

●

Select an audio event.

●

Select an audio part.

on the Project window toolbar to activate the lower zone.

RESULT
Depending on your event or part selection the lower zone shows either the Audio Part Editor,
the Sample Editor or one of the MIDI Editors.
NOTE
To change the default MIDI editor, select MIDI > Set up Editor Preferences, and select an option
from the Default MIDI Editor pop-up menu.
NOTE
If you open the editor and no event or part is selected, the editor in the lower zone is empty.
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RELATED LINKS
Selecting a different MIDI Editor on page 67

Selecting a different MIDI Editor
You can display the MIDI part that is opened in the editor in the lower zone in a different MIDI
editor. To do this, you do not necessarily need to change the default MIDI editor.
PROCEDURE
1.

On the Editor tab in the editor in the lower zone, click Select MIDI Editor.

2.

Select an editor from the pop-up menu.

RESULT
The MIDI part is displayed in the selected editor.
NOTE
This selection is temporary. Next time you open the MIDI part, the default MIDI editor is used.

Link Project and Lower Zone Editor Cursors
You can link cursors and zoom factors of the project zone and the Key Editor, Drum Editor, and
the Audio Part Editor in the lower zone.
NOTE
The ruler display format setting is not affected by this function. You can still select different ruler
display formats for the project zone and the editor in the lower zone.
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If you activate Link Project and Lower Zone Editor Cursors, the cursors and zoom factors are
linked in the event displays of the project zone and the lower zone. This is useful if you edit in
both zones and you want to keep the same position in view.
NOTE
In the Key Commands dialog in the Edit category, you can assign a key command for this.

RELATED LINKS
Ruler on page 47
Ruler Display Formats on page 48
Zooming in the Project Window on page 75

Right Zone
The right zone of the Project window allows you to display the VSTi rack, the Media rack, the
Control Room rack, and the Meter rack.
To show/hide the right zone, click Show/Hide Right Zone on the Project window toolbar.

The top of the right zone features the following tabs: VSTi, Media, CR, and Meter.
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NOTE
You can show/hide specific tabs from the right zone by right-clicking a tab header and activating/
deactivating the options in the context menu.

RELATED LINKS
VSTi Rack in the Right Zone on page 70
Media Rack in the Right Zone on page 72

Opening the VSTi Rack in the Right Zone
You can show the VSTi rack in the right zone of the Project window. This allows you to add and
edit VST instruments, and at the same time to see the context of your tracks and events.
PROCEDURE
1.

Click Show/Hide Right Zone

on the Project window toolbar to activate the Right Zone.

2.

At the top of the right zone, click the VSTi tab.

RESULT
The VSTi rack is opened in the right zone of the Project window.
RELATED LINKS
VSTi Rack in the Right Zone on page 70
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VST Instruments on page 724

VSTi Rack in the Right Zone
The VSTi rack in the right zone of the Project window allow you to add and edit VST instruments
in the context of the Project window.
The following sections are available:

●

Track
Shows the associated VST instrument for an instrument track.

●

Rack
Shows a VST instrument.

The following controls are available:

1

Add Track Instrument
Opens the Add Instrument Track dialog that allows you to select an instrument and add
an instrument track that is associated to this instrument.

2

Find Instruments
Opens a selector that allows you to find a loaded instrument.

3

Set Remote-Control Focus for VST Quick Controls to Previous/Next Instrument
Allows you to set the remote-control focus to the next/previous instrument.

4

Show/Hide all VST Quick Controls
Shows/Hides the default quick controls for all loaded instruments.

5

Settings
Opens the Settings menu where you can activate/deactivate the following modes:
●

Show VST Quick Controls for One Slot Only shows the VST Quick Controls
exclusively for the selected instrument.

●

MIDI Channel follows track selection ensures that the Channel selector follows
the MIDI track selection in the Project window. Use this mode if you work with
multitimbral instruments.

●

Remote-Control Focus for VST Quick Controls follows track selection ensures
that the VST Quick Control remote-control focus follows the track selection.

RELATED LINKS
VST Instruments Window on page 726
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Opening the Media Rack in the Right Zone
You can show the Media rack in the right zone of the Project window. This allows you to see the
context of your tracks and events when you drag audio events, MIDI parts, presets, or
instruments into the Project window.
PROCEDURE
1.

Click Show/Hide Right Zone

on the Project window toolbar to activate the Right Zone.

2.

At the top of the right zone, click the Media tab.

RESULT
The Media rack is opened in the right zone of the Project window.
RELATED LINKS
Media Rack in the Right Zone on page 72
MediaBay on page 607
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Media Rack in the Right Zone
The Media rack in the right zone of the Project window allows you to drag audio events, MIDI
parts, or instrument presets into the event display. It lists Steinberg factory content and any
installed Steinberg content sets.

The Media rack Home page

shows the following tiles:

Instruments
Shows all included VST instruments.
Loops & Samples
Shows audio loops, MIDI loops, or instrument sounds ordered by content set.
Presets
Shows track presets, strip presets, pattern banks, FX chain presets, and VST FX
presets.
User Presets
Shows track presets, strip presets, pattern banks, FX chain presets, VST FX presets,
and instrument presets that are listed in the User Content folder.
Favorites
Shows your favorite folders and allows you to add new favorites. The folder content
is automatically added to the MediaBay database.
File Browser
Shows your file system and the pre-defined folders Favorites, This Computer, VST
Sound, Factory Content, and User Content where you can search for media files
and access them immediately.
RELATED LINKS
Favorites Section on page 617
Media Rack in Right Zone on page 607
MediaBay on page 607
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Opening the Control Room in the Right Zone
You can show the Control Room in the right zone of the Project window.
PROCEDURE
1.

Click Show/Hide Right Zone

on the Project window toolbar to activate the Right Zone.

2.

At the top of the right zone, click the CR tab.

RESULT
The Control Room is opened in the right zone of the Project window. It has exactly the same
features as the Control Room that you open from the Studio menu as a separate window.
RELATED LINKS
Control Room on page 420

Opening the Meter in the Right Zone
You can show the Meter in the right zone of the Project window.
PROCEDURE
1.

Click Show/Hide Right Zone

on the Project window toolbar to activate the Right Zone.

2.

At the top of the right zone, click the Meter tab.
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RESULT
The Meter is opened in the right zone of the Project window. It has exactly the same features as
the Meter that you open in the right zone of the MixConsole.
RELATED LINKS
Metering and Loudness on page 434

Keyboard Focus in the Project Window
The different zones in the Project window can be controlled by using key commands. To make
sure that a key command has effect on a specific zone, you must make sure that this zone has
the keyboard focus.
The following Project window zones can have the keyboard focus:
●

Project zone

●

Left zone

●

Lower zone

●

Right zone

If a zone has the keyboard focus, the border that surrounds it is highlighted in a specific color.
NOTE
You can change the focus color in the Preferences dialog (User Interface—Custom Colors
page).

RELATED LINKS
Project Zone on page 40
Left Zone on page 53
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Lower Zone on page 62
Right Zone on page 68
Project Window on page 39

Activating Keyboard Focus for a Zone
You can activate the keyboard focus for a zone by clicking with the mouse and by using key
commands.

PROCEDURE
●

Do one of the following:
●

To activate any zone, click in it.

●

To activate the next zone, press Tab. This allows you to cycle forward through the
zones.

●

To activate the previous zone, press Shift-Tab.

NOTE
The editor in the lower zone automatically gets the keyboard focus if you double-click an
event or part in the event display, if you select an event or part and press Return, or if you
use key commands to open the zone.

RESULT
The keyboard focus is activated for this zone and the border of the zone is highlighted.
NOTE
The project zone and the lower zone have separate toolbars and info lines. If you use the toolbar
or the info line for one of these zones, the corresponding zone automatically gets the focus.

RELATED LINKS
Customizing the User Interface Colors on page 1165

Zooming in the Project Window
You can zoom in the Project window according to the standard zoom techniques.
NOTE
If screen redraws are slow on your system, consider activating Quick Zoom in the Preferences
dialog (Editing page).

Zooming Horizontally
●

Select the Zoom tool and click in the event display to zoom in. To zoom out, hold down Alt
and click.

●

Use the horizontal zoom sliders to zoom in and out.

●

Click the lower half of the ruler and drag down to zoom in horizontally. Click the lower half
of the ruler and drag up to zoom out horizontally.

●

Click H to zoom in horizontally. Click G to zoom out horizontally.
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NOTE
If the Grid Type in the Project window toolbar is set to Adapt to Zoom, the horizontal zoom
level affects the grid and snap resolution in the event display.

Zooming Vertically
●

Select the Zoom tool, click in the event display, and drag a selection rectangle to zoom in
vertically and horizontally.
NOTE
For this to work, you must deactivate the Zoom Tool Standard Mode: Horizontal
Zooming Only option in the Preferences dialog (Editing—Tools page).

●

Use the vertical zoom sliders to zoom in and out. If you have made any individual track
height adjustments, the relative height differences are maintained.

●

Click Shift-H to zoom in vertically. Click Shift-G to zoom out vertically.

RELATED LINKS
Zoom Submenu on page 76
Zoom Presets on page 77
Zooming In On Cycle Markers on page 78
Zoom History on page 79
Link Project and Lower Zone Editor Cursors on page 67
Grid Types on page 81

Zooming in on Audio Contents
You can zoom in vertically on the contents of audio parts and events. This is useful when viewing
quiet audio passages.
PROCEDURE
●

Click the waveform zoom slider in the top right corner of the event display and drag up.

RESULT
The contents of audio parts and events in your project are zoomed in vertically.
AFTER COMPLETING THIS TASK
To get an approximate reading on the level of the audio events by viewing the waveforms, zoom
out by dragging the slider is all the way down again. Otherwise, zoomed waveforms may be
mistaken for clipped audio.

Zoom Submenu
The Zoom submenu contains options for zooming in the Project window.
●

To open the Zoom submenu, select Edit > Zoom.

The following options are available:
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Zoom In/Out
Zooms in/out one step, centering on the project cursor.
Zoom Full
Zooms out so that the whole project is visible. The whole project means the timeline
from the project start to the length set in the Project Setup dialog.
Zoom to Selection
Zooms in horizontally and vertically so that the current selection fills the screen.
Zoom to Selection (Horiz.)
Zooms in horizontally so that the current selection fills the screen.
Zoom to Event
This option is available in the Sample Editor and in some MIDI editors.
Zoom In/Out Vertically
Zooms in/out one step vertically.
Zoom In/Out Tracks
Zooms the selected tracks in/out one step vertically.
Zoom Selected Tracks
This zooms in vertically on the selected tracks and minimizes the height of all other
tracks.
Undo/Redo Zoom
These options allow you to undo/redo the last zoom operation.
RELATED LINKS
Zoom Submenu on page 514

Zoom Presets
You can create zoom presets that allow you to set up different zoom settings. For example, one
where the whole project is displayed in the Project window and another with a high zoom factor
for detailed editing. The Zoom Presets pop-up menu allows you to select, create, and organize
zoom presets.
●

To open the Zoom Presets pop-up menu, click the button to the left of the horizontal
zoom control.

The upper part of the menu lists the zoom presets.

77

Project Window
Zooming in the Project Window

●

To save the current zoom setting as a preset, open the Zoom Presets pop-up menu and
select Add. In the Type In Preset Name dialog that opens, type in a name for the preset
and click OK.

●

To select and apply a preset, select it from the Zoom Presets pop-up menu.

●

To zoom out so that the whole project is visible, open the Zoom Presets pop-up menu and
select Zoom Full.
This displays the project from the project start to the length that is set in the Project Setup
dialog.

●

To delete a preset, open the Zoom Presets pop-up menu and select Organize. In the
dialog that opens, select the preset in the list and click Delete.

●

To rename a preset, open the Zoom Presets pop-up menu and select Organize. In the
dialog that opens, select a preset in the list and click Rename. In the dialog that opens,
type in a new name for the preset. Click OK to close the dialogs.

IMPORTANT
Zoom presets are global for all projects. They are available in all projects that you open or create.

Zooming In On Cycle Markers
You can zoom in on the area between cycle markers in the project.
●

To zoom in on a cycle marker, click the button to the left of the horizontal zoom control to
open the Zoom Presets pop-up menu and select a cycle marker.

The middle part of the Zoom Presets pop-up menu lists any cycle markers that you have added
to the project.
NOTE
Only the cycle markers that you create in the current project are available on the menu.
If you select a cycle marker, the event display is zoomed in to encompass the marker area.
You cannot edit the cycle markers in the Zoom Presets pop-up menu.
RELATED LINKS
Markers Window on page 335
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Zoom History
You can undo and redo zoom operations. This way you can zoom in several steps and then easily
go back to the zoom stage at which you started.
You can undo and redo zoom operations in the following ways:
●

To undo zoom, select Edit > Zoom > Undo Zoom or double-click with the zoom tool.

●

To redo zoom, select Edit > Zoom > Redo Zoom or press Alt and double-click with the
zoom tool.

Snap Function
The Snap function helps you to find exact positions when editing in the Project window. It does
this by restricting horizontal movement and positioning to certain positions. Operations affected
by Snap include moving, copying, drawing, sizing, splitting, range selection, etc.
●

To activate/deactivate Snap, activate/deactivate the Snap icon on the toolbar.

Setting the Snap Point
You can set the snap point at any position of the audio event.
PROCEDURE
1.

Select an event.

2.

Place the project cursor at a position within the selected audio event.

3.

Select Audio > Snap Point To Cursor.

RESULT
The snap point is set at the cursor position. The snap point for an event is displayed as a vertical
line in the Project window.

NOTE
You can also set the snap point in the Sample Editor.

RELATED LINKS
Adjusting the Snap Point on page 522

Snap to Zero Crossing
When splitting and sizing audio events, sudden amplitude changes can cause pops and clicks. To
avoid this, you can activate Snap to Zero Crossing to snap to points where the amplitude is zero.
●

To activate Snap to Zero Crossing, activate Snap to Zero Crossing
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Snap Types
You can select between different snap types to determine the snap point.
●

To select a snap type, open the Snap Type pop-up menu.

The following snap types are available:
Grid
If this option is activated, the snap points are set with the Grid Type pop-up menu.
The options depend on the display format that is selected for the ruler.
If you select Seconds as ruler format, time-based grid options are available.

If you select Bars+Beats as a ruler format, musical grid options are available.

Grid Relative
If this option is activated, events and parts are not magnetic to the grid. Rather, the
grid determines the step size for moving the events. This means that a moved event
keeps its original position relative to the grid.
For example, if an event starts at the position 3.04.01, snap is set to Grid Relative
and the Grid Type pop-up menu is set to Bar, you can move the event in steps of one
bar to the positions 4.04.01, 5.04.01, and so on.
NOTE
This only applies when dragging existing events or parts. When you create new
events or parts this snap type works like Grid.
Events
If this option is activated, the start and end positions of other events and parts
become magnetic. This means that if you drag an event to a position near the start
or end of another event, it is automatically aligned with the start or end of the other
event.
For audio events, the position of the snap point is also magnetic. This includes
marker events on the marker track.
Shuffle
Shuffle is useful when you want to change the order of adjacent events. If you have
two adjacent events and drag the first one to the right, past the second event, the
two events will change places.
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The same principle works when changing the order of more than two events.
Magnetic Cursor
This grid type lets the project cursor become magnetic. Dragging an event near the
cursor causes the event to be aligned with the cursor position.
Grid + Cursor
This is a combination of Grid and Magnetic Cursor.
Events + Cursor
This is a combination of Events and Magnetic Cursor.
Events + Grid + Cursor
This is a combination of Events, Grid, and Magnetic Cursor.

Grid Types
Allows you to specify a grid type that determines the grid and snap resolution in the event
display.
NOTE
This setting only has an effect if Snap Type is set to one of the grid options.
●

To select a grid type, open the Grid Type pop-up menu.

If you select Bars+Beats as a ruler format, the following grid types are available:
Bar
Sets the grid and snap resolution to bars.
Beat
Sets the grid and snap resolution to beats.
Use Quantize
Sets the grid and snap resolution to the value that is activated in the Quantize
Preset pop-up menu.
Adapt to Zoom
Sets the grid and snap resolution to the horizontal zoom level. The more you zoom in
on the event display, the finer the resolution. High zoom levels allow you to snap to
64th notes, low zoom levels allow you to snap to bars.
NOTE
Adapt to Zoom is only available if Bars+Beats is set as a ruler display format.
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If you activate Time Linear in the ruler context menu, the distances between the grid lines are
still constant but based on musical values such as bars and beats.
If you select Seconds as ruler format, the following grid types are available:
1 ms
Sets the grid and snap resolution to 1 ms.
10 ms
Sets the grid and snap resolution to 10 ms.
100 ms
Sets the grid and snap resolution to 100 ms.
1000 ms
Sets the grid and snap resolution to 1000 ms.
RELATED LINKS
Snap Types on page 80
Zooming in the Project Window on page 75
Ruler Display Formats on page 48

Cross-Hair Cursor
The cross-hair cursor is displayed when working in the Project window and in the editors,
facilitating navigation and editing, especially when arranging large projects.
●

You can set up the cross-hair cursor in the Preferences dialog (Editing—Tools page).
You can set up the colors for the line and the mask of the cross-hair cursor, and define its
width.

The cross-hair cursor works as follows:
●

When the Object Selection tool or one of its subtools is selected, the cross-hair cursor
appears when you start moving/copying a part/event, or when using the event trim
handles.

Cross-hair cursor when moving an event.

●

When the Object Selection tool, the Cut tool, or any other tool that makes use of this
function is selected, the cross-hair cursor appears as soon as you move the mouse over
the event display.

●

The cross-hair cursor is only available for tools where such a function is of any use. The
Mute tool, for example, does not use a cross-hair cursor, as you have to click directly on an
event to mute it.

NOTE
If the Key Editor, Drum Editor or the Audio Part Editor is open in the lower zone of the Project
window and Link Project and Lower Zone Cursors is activated, the cross-hair cursor is shown in
the editor in the lower zone and in the Project window.
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Edit History Dialog
The Edit History dialog contains a list of all your edits. This allows you to undo all actions in the
Project window as well as in the editors.
●

To open the Edit History dialog, select Edit > History.

The Action column displays the name of the action while the Time column tells you when this
action was performed. In the Details column further details are shown. Here you can enter new
text by double-clicking in the column.
●

To undo your actions, move the horizontal, colored line upwards to the desired position.
You can only undo your actions in reverse order, for example, the last performed action is
the first action to be undone.

●

To redo an action that was undone previously, move the line down the list again.

NOTE
●

You can also undo applied plug-in effects or audio processes. However, we recommend to
modify or delete these using the Direct Offline Processing window.

●

All offline processing that you have applied permanently to the audio using the Make
Direct Offline Processing Permanent function cannot be undone. Therefore, it is not
shown in the Edit History dialog.

RELATED LINKS
Direct Offline Processing on page 467
Applying Offline Processing Permanently on page 477

Setting the Number of Maximum Undo Steps
You can limit the number of maximum undo steps. This is useful if you run out of memory, for
example.
PROCEDURE
1.

In the Preferences dialog, select General.

2.

Set the number in the Maximum Undo Steps field.
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Working with Branches
You can gather actions in branches. This way you can undo whole branches instead of every
single action that you performed.
A branch is created when you have undone at least one action. All following actions you perform
are then gathered in a new branch.
●

To activate branches, activate Use Undo Branches in the Preferences dialog (General
page).

●

To see and edit the branches, select Edit > Edit History.

Undoing Edits of Separate Branches
If you have two or more branches, you can choose to undo edits of the separate branches.
PROCEDURE
1.

Select Edit > Edit History.

2.

In the lower part of the Edit History dialog, click on a branch to select it.
The corresponding actions are listed in the upper part of the dialog.

3.

Click Activate Selected or click a second time on the branch to activate it.

RESULT
All actions from the subsequent branches are undone while all actions of the now active branch
are redone.
If you undo some of the actions and then perform new edit operations, a new child branch is
created at that position in the tree.

Removing Branches
You can remove inactivate branches that you no longer need.
IMPORTANT
Removing inactive branches cannot be undone.

PROCEDURE
1.

Select Edit > Edit History.

2.

In the lower part of the Edit History dialog, click Remove Inactive.

RESULT
All inactive branches are removed, leaving only the active actions on a single, linear branch.
AFTER COMPLETING THIS TASK
You can now undo separate actions of the branch as usual in the upper part of the dialog.
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In Nuendo, projects are the central documents. You must create and set up a project to work
with the program.

Creating New Projects
You can create empty projects or projects that are based on a template.
PROCEDURE
1.

Select File > New Project.
Depending on your settings, either the Hub or the New Project dialog opens.

2.

3.

Hub only: In the location options section, select where to store the new project.
●

To use the default location, select Use default location.

●

To choose another location, select Prompt for project location.

Do one of the following:
●

To create an empty new project via the Hub, click Create Empty.

●

To create an empty new project via the New Project dialog, select Empty and click
OK.

●

To create a new project from a template via the Hub, select a template and click
Create.

●

To create a new project from a template via the New Project dialog, select a
template and click OK.

RESULT
A new, untitled project is created. If you selected a template, the new project is based on this
template and includes the corresponding tracks, events, and settings.
NOTE
If you create an empty project, your default presets for the input and output bus configurations
are applied. If you have not defined default presets, the last used configurations are applied.

RELATED LINKS
Presets for Input and Output Busses on page 30
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Hub
When you start Nuendo or create new projects using the File menu, the Hub opens. The Hub
keeps you up to date with the latest information and assists you with organizing your projects. It
consists of the News and Tutorials section and the Projects section.

News and Tutorials section
The News and Tutorials section displays Steinberg news, tutorial videos as well as links to the
user forum, downloads, and the Help Center.
NOTE
Ensure that you have an active Internet connection to access this material.

Projects section
The Projects section lets you create new projects, which can either be empty or based on a
template. It lets you specify where to save the projects. It also allows you to access recently
opened projects or projects that are stored in other locations.
Category bar
The Recent category contains a list of the recently opened projects.
The Location categories are user defined locations that contain projects.
The Templates category contains the available factory templates.
Template list
When you click on one of the category items, the list below the category bar shows
the available templates for this category. Any new templates that you create are
added at the top of the corresponding list.
Location options
This section allows you to specify where the project is stored.
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Open other
This button allows you to open any project file on your system. This is identical to
using the Open command on the File menu.

Deactivating the Hub
To start Nuendo or to create new projects without the Hub, you can deactivate it.
PROCEDURE
1.

In the Preferences dialog, select General.

2.

Deactivate Use Hub.

RESULT
Nuendo starts without opening a project and opens the New Project dialog when you create a
new project using the File menu. However, you can still open the Hub through the Hub menu.

New Project Dialog
When you deactivate the Hub and create new projects, the New Project dialog opens. This
dialog allows you to create new projects which can either be empty or based on a template.

About Project Files
A project file (extension *.npr) is the central document in Nuendo. A project file contains
references to media data that can be saved in the project folder.
NOTE
We recommend to save files only in the project folder, even though you can save them in any
other location to which you have access.
The project folder contains the project file and the following folders that Nuendo automatically
creates when necessary:
●

Audio

●

Clip Packages

●

Edits

●

Images

●

Network

●

Track Pictures
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About Template Files
Templates can be a good starting point for new projects. Templates are projects where you can
save all settings that you regularly use, such as bus configurations, sample rates, record formats,
basic track layouts, VSTi setups, drum map setups, etc.
Template projects are not saved in project folders and therefore contain no subfolders and no
media files.
●

To open the location of a specific template, right-click a template in the template list and
select Show in Explorer (Windows only) or Reveal in Finder (macOS only).

Saving a Project Template File
You can save the current project as a template. When you create a new project, you can select
this template as a starting point for your new project.
PREREQUISITE
Remove all clips from the Pool before you save the project as a template. This ensures that
references to media data from the original project folder are deleted.
PROCEDURE
1.

Set up a project.

2.

Select File > Save as Template.

3.

In the New Preset section of the Save as Template dialog, enter a name for the new
project template.

4.

In the Attribute Inspector section, double-click the Value field of the Content Summary
attribute to enter a description for the template.

5.

Click the Value field of the Template Category attribute and select a template category
from the pop-up menu.
If you do not select a category, the new template will be listed in the Hub in the Templates
category.

6.

Click OK to save the template.
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Renaming Templates
PROCEDURE
1.

In the Hub, right-click a template and select Rename.

2.

In the Rename dialog, enter a new name and click OK.

Project Setup Dialog
You can perform general settings for your project in the Project Setup dialog.
●

To open the Project Setup dialog, select Project > Project Setup.

●

To open the Project Setup dialog automatically when you create a new project, activate
the Run Setup on Create New Project option in the Preferences dialog (General page).

IMPORTANT
While most Project Setup settings can be changed at any time, you must set the sample rate
directly after creating a new project. If you change the sample rate at a later stage, you must
convert all audio files in the project to the new sample rate to make them play back properly.
The following options are available:
Author
Allows you to specify a project author that is written into the file, when you export
audio files and activate the Insert iXML chunk option. You can specify a default
author in the Default Author Name field in the Preferences dialog (General—
Personalization page).
Company
Allows you to specify a company name that is written into the file, when you export
audio files and activate the Insert iXML chunk option. You can specify a default
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company in the Default Company Name field in the Preferences dialog (General—
Personalization page).
Start
Allows you to specify the start time of the project in timecode format. This also
determines the sync start position when synchronizing to external devices.
Length
Allows you to specify the length of the project.
Frame Rate
Allows you to specify the timecode standard and frame rate for the project. When
synchronizing to an external device, this setting must correspond to the frame rate
of any incoming timecode.
Get From Video
Allows you to set the project frame rate to the frame rate of an imported video file.
Audio Pull-up/Pull-down
Allows you to adjust audio playback speed to match the video. If you select a pull
factor that is not supported by your hardware, this is indicated by a different color.
Display Format
Allows you to specify the global display format that is used for all rulers and position
displays in the program, except the ruler tracks. However, you can make
independent display format selections for the individual rulers and displays.
Display Offset
Allows you to specify an offset for the time positions that are displayed in the rulers
and position displays to compensate for the Start position setting.
Bar Offset
This setting is only used, when you select the Bars+Beats display format. Allows you
to specify an offset for the time positions that are displayed in the rulers and position
displays to compensate for the Start position setting.
Sample Rate
Allows you to specify the sample rate at which records and plays back audio.
●

If your audio hardware generates the sample rate internally and you select a
non-supported sample rate, this is indicated by a different color. In this case,
you must set a different sample rate to make your audio files play back
properly.

●

If you select a sample rate that your audio hardware supports, but that differs
from its current sample rate setting, it is automatically changed to the project
sample rate.

●

If your audio hardware is externally clocked and receives external clock
signals, sample rate mismatches are accepted.

Bit Depth
Allows you to specify the bit depth of the audio files that you record in Nuendo.
Select the record format according to the bit depth that is delivered by your audio
hardware. The available options are 16 bit, 24 bit, 32 bit, 32 bit float, and 64 bit float.
NOTE
●

If your audio interface supports a bit depth of 32 bit, and you want to maintain
this precision in your recordings, you must select a Processing Precision of
64 bit float in the Studio Setup dialog.
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●

When you record with effects, consider setting the bit depth to 32 bit float or
64 bit float. This prevents clipping (digital distortion) in the recorded files and
keeps the audio quality very high. Effect processing and level or EQ changes in
the input channel are done in 32-bit float or 64-bit float format, depending on
the Processing Precision setting in the Studio Setup dialog. If you record at
16 bit or 24 bit, the audio will be converted to this lower bit depth when it is
written to a file. As a result, the signal may degrade. This is independent of the
actual bit depth of your audio hardware. Even if the signal from the audio
hardware has a bit depth of 16 bit, the signal will be 32 bit float or 64 bit float
after the effects are added to the input channel.

●

The higher the bit depth value, the larger the files and the more strain is put
on the disk system. If this is an issue, you can lower the record format setting.

Record File Type
Allows you to specify the file type of the audio files that you record in Nuendo. The
following file types are available:
●

Wave File
This is the most common file format on the PC platform. Wave files have the
extension .wav.

●

Wave 64 File
This is a proprietary format developed by Sonic Foundry Inc. Wave 64 files
offer the same quality as Wave files, but they can be considerably larger than
standard Wave files. They are especially suited for long recordings with file
sizes over 2 GB. The files have the extension .w64.

●

Broadcast Wave Files
This format is, in terms of audio content, identical with regular Wave files.
Broadcast Wave files can contain embedded text strings. The files have the
extension .wav.

●

AIFF Files
This is an audio file format standard defined by Apple Inc. AIFF files are used
on most computer platforms. The files can contain embedded text strings.
AIFF files have the extension .aif.

●

MXF File
This is a container format for digital video and audio. MXF files are used on
most computer platforms. The files are often part of AAF projects and have the
extension .mxf.

●

FLAC File
This is an open source format that reduces the size of audio files by 50 to 60 %
compared to regular Wave files. The files have the extension .flac.

NOTE
●

For wave file recordings larger than 4 GB, the EBU RIFF standard is used. If a
FAT 32 disk is used (not recommended), audio files are split automatically. In
the Preferences dialog, you can specify what happens, when your recorded
Wave file is larger than 4 GB.

●

You can set up embedded strings in the Preferences dialog.

Stereo Pan Law
If you pan a channel left or right, the sum of the left and right side is higher (louder),
than if this channel is panned center. These modes allow you to attenuate signals
panned center. 0 dB turns off constant-power panning. Equal Power means that the
power of the signal remains the same regardless of the pan setting.
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Volume Max
Allows you to specify the maximum fader level. By default, this is set to +12 dB. If you
load projects that were created with Nuendo versions older than 5.5, this value is set
to the old default value of +6 dB.
HMT Type (MIDI only)
Allows you to specify a mode for Hermode tuning of MIDI notes.
HMT Depth (MIDI only)
Allows you to specify the overall degree of retuning.
RELATED LINKS
VST Audio System on page 14
Record - Audio on page 1201

Opening Project Files
You can open one or several saved project files at the same time.
IMPORTANT
If you open a project saved with a different program version that contains data for functions that
are not available in your version, this data may be lost when you save the project with your
version.
NOTE
●

If you open an external project, the last used view that was saved on your computer is
used. You can change this setting in the Preferences dialog (General page).

●

External projects are automatically connected to the input and output busses. If you open
a project that was created on a computer with an ASIO port configuration different from
the configuration of your computer, this can result in unwanted audio connections. You
can deactivate the automatic connection of input and output busses in the Preferences
dialog (VST page).

PROCEDURE
1.

Select File > Open.

2.

In the Hub, click Recent or select a Location.

3.

Select the project from the projects list, and click Open.

4.

If there already is an open project, you are asked if you want to activate the new project.
Do one of the following:
●
●

To activate the project, click Activate.
To open the project without activating it, click No.
This reduces load times for projects.

RELATED LINKS
Workspaces for External Projects on page 1158
Do not Connect Input/Output Busses When Loading External Projects on page 1208
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Activating Projects
If you have several projects opened at the same time in Nuendo, only one project can be active.
The active project is indicated by the lit Activate Project button in the upper left corner of the
Project window. If you want to work on another project, you have to activate the other project.
PROCEDURE
●

To activate a project, click Activate Project

.

Opening Project Files from Locations
You can open project files from specific locations. This is especially useful in situations where
different users work on different projects on the same computer.
PROCEDURE
1.

Do one of the following:
●

Select File > Open.

●

Select Hub > Open Hub.

2.

In the Hub, right-click a Location icon on the category bar.

3.

In the Locations pop-up menu, select Assign User Location.

4.

In the file dialog, select a location and click OK.
All projects that are saved in this location are listed in the projects list. Depending on the
size of the files, this may take a while.
NOTE
You can add the location to the MediaBay to speed up the displaying of results.

5.

In the projects list, select the project that you want to open.

6.

Click Open.

Locations Menu
The Locations menu allows you to manage the user locations.
●

To open the Locations menu, open the Hub and right-click a Location icon on the
category bar.

The following options are available:
Assign User Location
Allows you to select a location on your computer.
Reset User Location Assignment
Deletes the assignment.

93

Project Handling
Saving Project Files
Rename
Allows you to rename the name of the location in the Hub. The name of the original
location will not be changed.
Reset to Default Name
Resets the name of the location in the Hub to the original location name.
RELATED LINKS
Hub on page 86

Opening Recent Projects
To open a recently opened project, do one of the following:
●

In the category bar of the Hub, click Recent, select a project from the projects list, and
click Open.

●

Select File > Recent Projects and select a recently opened project.

Re-Routing Missing Ports
If you open a Nuendo project that was created on a different system with other audio hardware,
Nuendo tries to find matching audio inputs and outputs for the input/output busses. If Nuendo
cannot resolve all audio/MIDI inputs and outputs that are used in the project, the Missing Ports
dialog opens.
This allows you to manually re-route any ports specified in the project to ports that are available
in your system.
NOTE
To improve the search for matching audio inputs and outputs for the input/output busses, you
should use descriptive, generic names for your input and output ports.

RELATED LINKS
Renaming the Hardware Inputs and Outputs on page 27

Saving Project Files
You can save the active project as a project file. To keep your projects as manageable as possible,
make sure that you save project files and all related files in the respective project folders.
●

To save the project and specify a file name and location, open the File menu and select
Save As.

●

To save the project with its current name and location, open the File menu and select
Save.

About the Auto Save Option
Nuendo can automatically save backup copies of all open project files with unsaved changes.
NOTE
Only the project files are backed up. If you want to include the files from the Pool and save your
project in a different location, you must use the Back up Project function.
Nuendo can automatically save backup copies of all open projects with unsaved changes. To set
this up, activate the Auto Save option in the Preferences dialog (General page). The backup

94

Project Handling
Reverting to the Last Saved Version
copies are named “<project name>-xx.bak” where xx is an incremental number. Unsaved projects
are backed up in a similar way as “UntitledX-xx.bak”, with X being the incremental number for
unsaved projects. All backup files are saved in the project folder.
●

To specify the time intervals in which a backup copy is created, use the Auto Save Interval
setting.

●

To specify how many backup files are created with the Auto Save function, use the
Maximum Backup Files option. When the maximum number of backup files is reached,
the existing files are overwritten, starting with the oldest file.

Saving Project Files As a New Version
You can create and activate a new version of an active project file. This is useful if you are
experimenting with edits and arrangements and want to be able to go back to a previous version
at any time.
To save a new version of the active project, do one of the following:
●

Select File > Save New Version.

●

Press Ctrl/Cmd-Alt-S.

The new file is saved with the same name as the original project and an attached incremental
number. For example, if your project is called “My Project,” new versions are called “My
Project-01”, “My Project-02”, and so on.

Reverting to the Last Saved Version
You can return to the last saved version and discard all changes that have been introduced.
PROCEDURE
1.

Select File > Revert.

2.

In the warning message, click Revert.
If you have recorded or created new audio files since the last version was saved, you are
prompted to delete or keep the files.

Choosing a Project Location
In the Hub, you can specify where to save a project.

●

To create a project in the default project location, select Use default location.
In the Project folder field, you can specify a name for the project folder. If you do not
specify a project folder here, the project is saved in a folder named Untitled.

●

To change the default project location, click in the path field.
A file dialog opens that allows you to specify a new default location.

●

To create the project in a different location, select Prompt for project location.
In the dialog that opens, specify a location and a project folder.
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Creating Self-Contained Projects
If you want to share your work or transfer it to another computer, your project must be selfcontained.
The following functions facilitate this task:
●

Select Media > Prepare Archive to verify that every clip that is referenced in the project is
located in the project folder, and to take actions if that is not the case.

●

Select File > Back up Project to create a new project folder where you can save the project
file and the necessary work data. The original project remains unchanged.

Preparing Archives
The Prepare Archive function allows you to gather all files that are referenced by your project to
ensure that these are in the project folder. This is useful if you want to move or archive your
project.
PROCEDURE
1.

Select Media > Prepare Archive.
If your project references external files, you are prompted if you want to copy them to
your working directory. If any processing has been applied, you must decide if you want to
flatten edits.

2.

Click Proceed.

RESULT
Your project is ready to be archived. You can move or copy the project folder to another location.
AFTER COMPLETING THIS TASK
You must copy audio files that reside within the project folder to the Audio folder or save them
separately. You must also move your video clips manually, as videos are only referenced and not
saved in the project folder.

Backing Up Projects
You can create a backup copy of your project. Backups only contain the necessary work data. All
media files except the files from VST Sound archives are included as a copy.
PROCEDURE
1.

Select File > Back up Project.

2.

Select an empty folder or create a new one.

3.

Make your settings in the Back up Project Options dialog and click OK.

RESULT
A copy of the project is saved in the new folder. The original project remains unaffected.
NOTE
VST Sound content provided by Steinberg is copy-protected and will not be included in the
backup project. If you want to use a backup copy that uses VST Sound content on a different
computer, make sure that the corresponding content is also available on that computer.
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Back up Project Options Dialog
This dialog allows you to create a backup copy of your project.
●

To open the Back up Project Options dialog, select File > Back up Project.

Project Name
Allows you to change the name of the backed up project.
Keep Current Project Active
Allows you to keep the current project active after clicking OK.
Minimize Audio Files
Allows you to include only the audio file portions that are actually used in the project.
This can significantly reduce the size of the project folder if you are using small
sections of large files. It also means that you cannot use other parts of the audio files
if you continue working with the project in its new folder.
Freeze Direct Offline Processing
Allows you to flatten all edits and make all processing and applied effects permanent
to each clip in the Pool.
Remove Unused Files
Allows you to remove unused files and to back up only the files that are actually
used.
Do Not Back up Video
Allows you to exclude video clips on the video track or in the Pool of the current
project.
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Tracks are the building blocks of your project. They allow you to import, add, record, and edit
data (parts and events). Tracks are listed from top to bottom in the Track list and extend
horizontally across the Project window. Each track is assigned to a particular channel strip in the
MixConsole.
If you select a track in the Project window, the controls, settings, and parameters displayed in
the Inspector and the track list allow you to control the track.

Track Inspector Settings
For each track type you can configure which Inspector sections are shown. You can also specify
the order of the sections.
●

To open the Track Inspector Settings dialog, click Setup Inspector, and select Setup
from the pop-up menu.

●
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Hidden Items
Displays sections that are hidden in the Inspector.
Visible Items
Displays sections that are visible in the Inspector.
Pin
If you activate Pin by clicking the column for a section the open/close status of the
selected Inspector section is pinned.
Add
Allows you to move an item selected in the hidden sections list to the list of visible
sections.
Remove
Allows you to move an item selected in the visible sections list to the list of hidden
sections.
Move Up/Move Down
Allows you to change the order of an item in the list of visible sections.
Presets
Allows you to save Inspector section settings as presets.
Reset All
Allows you to restore the default Inspector section settings.

Track Control Settings
For each track type you can configure which track controls are shown in the track list. You can
also specify the order of controls and group controls so that they are always shown adjacent to
each other.
●

To open the Track Controls Settings dialog, right-click a track in the track list and select
Track Controls Settings from the context menu, or click Open Track Controls Settings
Dialog in the bottom right corner of the track list.
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Track Type
Allows you to select the track type to which your settings are applied.
Hidden Controls
Displays controls that are hidden in the track list.
Visible Controls
Displays controls that are visible in the track list.
Width
If you click in this column, you can set the maximum length for the track name.
Group
Displays the group number.
Add
Allows you to move an item selected in the hidden controls list to the list of visible
controls.
Remove
Allows you to move an item selected in the visible controls list to the list of hidden
controls. All controls can be removed except Mute and Solo.
Move Up/Move Down
Allows you to change the order of an item in the list of visible controls.
Group
Allows you to group two or more controls selected in the visible controls list that are
adjacent to each other. This ensures that they are always positioned side by side in
the track list.
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Ungroup
Allows you to ungroup grouped controls in the visible controls list. To remove an
entire group, select the first (topmost) element belonging to this group and click
Ungroup.
Reset
Allows you to restore all default track controls settings for the selected track type.
Controls Area Preview
Shows a preview of the customized track controls.
Controls Area Width
Allows you to determine the width of the track control area for the selected track
type. In the Controls Area Preview, this area is shown with a frame.
Presets
Allows you to save track controls settings as presets. To recall a preset, click Switch
Presets in the bottom right corner of the track list. The name of the selected preset
is shown in the left corner.
Track Name Width (global)
Allows you to determine the global name width for all track types.
Apply
Applies your settings.
Reset All
Allows you to restore all default track controls settings for all track types.

Audio Tracks
You can use audio tracks for recording and playing back audio events and audio parts. Each
audio track has a corresponding audio channel in the MixConsole. An audio track can have any
number of automation tracks for automating channel parameters, effect settings, etc.
●

To add an audio track to your project, select Project > Add Track > Audio.

RELATED LINKS
Adding Tracks on page 158

Audio Track Inspector
The Inspector for audio tracks contains controls and parameters that allow you to edit your
audio track.

The top section of the audio track Inspector contains the following basic track settings:
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Track name
Click once to show/hide the basic track settings section. Double-click to rename the
track.
Edit
Opens the Channel Settings window for the track.
Mute
Mutes the track.
Solo
Solos the track.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Open Device Panels
Allows you to create a device panel for the plug-in and device parameters of your
track.
Auto Fades Settings
Opens a dialog where you can make separate audio fade settings for the track.
Record enable
Activates the track for recording.
Monitor
Routes incoming signals to the selected output.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Show Lanes
Divides the tracks in lanes.
Freeze Audio Channel
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Allows you to freeze the audio channel.
Volume
Allows you to adjust the level for the track.
Pan
Allows you to adjust the panning of the track.
Delay
Allows you to adjust the playback timing of the track.
Load/Save/Reload Track Preset
Loads or saves a track preset or reverts the default presets.
Input Routing
Allows you to specify the input bus for the track.
Output Routing
Allows you to specify the output bus for the track.
Track Automation Mode
Allows you to set the automation mode of the track.

Audio Track Inspector sections
Apart from the basic track settings that are always shown, audio tracks provide other Inspector
sections. These are described in the following sections.

TrackVersions

Allows you to create and edit TrackVersions.
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Chords

Allows you to specify how the track follows the chord track.

Inserts

Allows you to add insert effects to the track.

Strip

Allows you to set up the channel strip modules.

Equalizers

Allows you to adjust the EQs for the track. You can have up to four bands of EQ for each track.
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Sends

Allows you to route the track to one or several FX channels.

Cue Sends

Allows you to route cue mixes to Control Room cues.

Direct Routing

Allows you to set up direct routing.

Surround Pan

Shows the panner for a track.
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Fader

Shows a duplicate of the corresponding MixConsole channel.

Notepad

Allows you to enter notes about the track.

Network

Shows the network connection of the track.

Device Panel

Allows you to display and use device panels.

Quick Controls

Allows you to configure quick controls to use remote devices, for example.
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Audio Track Controls
The Track List for audio tracks contains controls and parameters that allow you to edit your audio
track.

Track name
Double-click to rename the track.
Edit
Opens the Channel Settings window for the track.
Mute
Mutes the track.
Solo
Solos the track.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Record enable
Activates the track for recording.
Monitor
Routes incoming signals to the selected output.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Show Lanes
Divides the tracks in lanes.
Bypass Inserts
Bypasses the inserts for the track.
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Bypass EQs
Bypasses the equalizers for the track.
Bypass Sends
Bypasses the sends for the track.
Channel Configuration
Shows the channel configuration of the track.
Listen
The listen indicator is lit if the track is in listen mode.
Freeze Channel
Opens the Freeze Channel Options dialog that allows you to set the Tail Size time in
seconds.
Load available update
This button lights up when other users have made changes to a track and committed
them over the network to indicate that you can load the changes and update the
project.
Automatically apply updates
If this button is activated, all changes that are committed to the tracks by other users
are automatically applied.
Get exclusive access
If this button is activated, you have exclusive access to the track. To unlock a track,
click the Get exclusive access button again.
Commit changes on this track
Commits the changes on this track to the network.

Instrument Tracks
You can use instrument tracks for dedicated VST instruments. Each instrument track has a
corresponding instrument channel in the MixConsole. An instrument track can have any number
of automation tracks.
●

To add an instrument track to your project, select Project > Add Track > Instrument.

108

Tracks
Instrument Tracks

Instrument Track Inspector
The Inspector for instrument tracks contains controls and parameters that allow you to control
your instrument track. It shows some of the sections from VST instrument channels and MIDI
tracks.

The top section of the instrument track Inspector contains the following basic track settings:
Track name
Click once to show/hide the basic track settings section. Double-click to rename the
track.
Edit
Opens the Channel Settings window for the track.
Mute
Mutes the track.
Solo
Solos the track.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Open Device Panels
Allows you to open the instrument panel.
Input Transformer
Opens the Input Transformer dialog that allows you to transform incoming MIDI
events in realtime.
Record enable
Activates the track for recording.
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Monitor
Routes incoming MIDI to the selected MIDI output. For this to work, activate MIDI
Thru Active in the Preferences dialog (MIDI page).
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Freeze Instrument Channel
Allows you to freeze the instrument.
Volume
Allows you to adjust the level of the track.
Pan
Allows you to adjust the panning of the track.
Delay
Allows you to adjust the playback timing of the track.
Show Lanes
Divides the tracks in lanes.
Load/Save/Reload Track Preset
Loads or saves a track preset or reverts the default presets.
Input Routing
Allows you to specify the input bus for the track.
Activate Outputs
This control is only available if the instrument provides more than one output. It
allows you to activate one or more outputs for the instrument.
Edit Instrument
Allows you to open the instrument panel.
Programs
Allows you to select a program.
Drum Map
Allows you to select a drum map for the track.
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Instrument Track Inspector Sections
Apart from the basic track settings that are always shown, instrument tracks provide other
Inspector sections. These are described in the following sections.

TrackVersions

Allows you to create and edit TrackVersions.

Chords

Allows you to specify how the track follows the chord track.

Expression Map

Allows you to use the Expression Map features.
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Note Expression

Allows you to work with the Note Expression features.

MIDI Modifiers

Allows you to transpose or adjust the velocity of the MIDI track events in realtime during
playback.

MIDI Inserts

Allows you to add MIDI insert effects.
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Instrument Section

Shows the audio-related controls for the instrument.

Notepad

Allows you to enter notes about the track.

Network

Shows the network connection of the track.

Device Panel

Allows you to display and use device panels.

Quick Controls

Allows you to configure quick controls to use remote devices, for example.
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Instrument Track Controls
The Track List for instrument tracks contains controls and parameters that allow you to edit your
instrument track.

Mute
Mutes the track.
Solo
Solos the track.
Track name
Double-click to rename the track.
Record enable
Activates the track for recording.
Monitor
Allows you to route incoming MIDI signals to the selected MIDI output. For this to
work, activate MIDI Thru Active in the Preferences dialog (MIDI page).
Edit
Opens the Channel Settings window for the track.
Edit Instrument
Allows you to open the instrument panel.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Show Lanes
Divides the tracks in lanes.
ASIO Latency Compensation
Moves all recorded events on the track by the current latency.
Programs
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Allows you to select a program.
Bypass Inserts
Bypasses the inserts for the track.
Bypass EQs
Bypasses the equalizers for the track.
Bypass Sends
Bypasses the sends for the track.
Instrument
Allows you to select an instrument.
Listen
The listen indicator is lit if the track is in listen mode.
Edit In-Place
Allows you to edit MIDI events and parts on the track in the Project window.
Lock
Disables all editing of all events on the track.
Channel Configuration
Shows the channel configuration of the track.
Drum Map
Allows you to select a drum map for the track.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Freeze Channel
Opens the Freeze Channel Options dialog that allows you to set the Tail Size time in
seconds.
Load available update
This button lights up when other users have made changes to a track and committed
them over the network to indicate that you can load the changes and update the
project.
Automatically apply updates
If this button is activated, all changes that are committed to the tracks by other users
are automatically applied.
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Get exclusive access
If this button is activated, you have exclusive access to the track. To unlock a track,
click the Get exclusive access button again.
Commit changes on this track
Commits the changes on this track to the network.

MIDI Tracks
You can use MIDI tracks for recording and playing back MIDI parts. Each MIDI track has a
corresponding MIDI channel in the MixConsole. A MIDI track can have any number of
automation tracks.
●

To add a MIDI track to your project, select Project > Add Track > MIDI.

MIDI Track Inspector
The Inspector for MIDI tracks contains controls and parameters that allow you to control your
MIDI track. These affect MIDI events in realtime, on playback, for example.

The top section of the MIDI track Inspector contains the following basic track settings:
Track name
Click once to show/hide the basic track settings section. Double-click to rename the
track.
Edit
Opens the Channel Settings window for the track.
Mute
Mutes the track.
Solo
Solos the track.
Read Automation
Allows you to read track automation.
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Write Automation
Allows you to write track automation.
Open Device Panels
Allows you to open the instrument panel.
Input Transformer
Opens the Input Transformer dialog that allows you to transform incoming MIDI
events in realtime.
Record enable
Activates the track for recording.
Monitor
Routes incoming MIDI to the selected MIDI output. For this to work, activate MIDI
Thru Active in the Preferences dialog (MIDI page).
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Show Lanes
Divides the tracks in lanes.
MIDI Volume
Allows you to adjust the MIDI volume for the track.
MIDI Pan
Allows you to adjust the MIDI pan for the track.
Delay
Allows you to adjust the playback timing of the track.
Load/Save/Reload Track Preset
Loads or saves a track preset or reverts the default presets.
Input Routing
Allows you to specify the input bus for the track.
Output Routing
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Allows you to specify the output bus for the track.
Channel
Allows you to specify the MIDI channel.
Edit Instrument
Allows you to open the instrument panel.
Bank Selector
Allows you to set a bank select message that is sent to your MIDI device.
Program Selector
Allows you to set a program change message that is sent to your MIDI device.
Drum Map
Allows you to select a drum map for the track.

MIDI Track Inspector Sections
Apart from the basic track settings that are always shown, MIDI tracks provide other Inspector
sections. These are described in the following sections.

TrackVersions

Allows you to create and edit TrackVersions.

Chords
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Allows you to specify how the track follows the chord track.

Expression Map

Allows you to use the Expression Map features.

Note Expression

Allows you to work with the Note Expression features.

MIDI Modifiers

Allows you to transpose or adjust the velocity of the MIDI track events in realtime during
playback.
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MIDI Inserts

Allows you to add MIDI insert effects.

MIDI Sends Section

Allows you to add MIDI send effects.

MIDI Fader Section

Shows a duplicate of the corresponding MixConsole channel.
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Notepad

Allows you to enter notes about the track.

Network

Shows the network connection of the track.

Device Panel

Allows you to display and use device panels.

Quick Controls

Allows you to configure quick controls to use remote devices, for example.

MIDI Track Controls
The Track List for MIDI tracks contains controls and parameters that allow you to edit your MIDI
track.

The track list for MIDI tracks contains the following controls:
Mute
Mutes the track.
Solo
Solos the track.
Track name
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Click once to show/hide the basic track settings section. Double-click to rename the
track.
Record enable
Activates the track for recording.
Monitor
Allows you to route incoming MIDI signals to the selected MIDI output. For this to
work, activate MIDI Thru Active in the Preferences dialog (MIDI page).
Channel
Allows you to specify the MIDI channel.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Show Lanes
Divides the tracks in lanes.
Output
Allows you to specify the output for the track.
Programs
Allows you to select a program.
Edit In-Place
Allows you to edit MIDI events and parts on the track in the Project window.
Bypass Inserts
Bypasses the inserts for the track.
Bypass Sends
Bypasses the sends for the track.
Lock
Disables all editing of all events on the track.
Edit
Opens the Channel Settings window for the track.
Drum Map
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Allows you to select a drum map for the track.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Load available update
This button lights up when other users have made changes to a track and committed
them over the network to indicate that you can load the changes and update the
project.
Automatically apply updates
If this button is activated, all changes that are committed to the tracks by other users
are automatically applied.
Get exclusive access
If this button is activated, you have exclusive access to the track. To unlock a track,
click the Get exclusive access button again.
Commit changes on this track
Commits the changes on this track to the network.
ASIO Latency Compensation
Moves all recorded events on the track by the current latency.

Sampler Tracks
You can use sampler tracks for controlling the playback of audio samples via MIDI. Each sampler
track has a corresponding channel in the MixConsole. A sampler track can have any number of
automation tracks.
●

To add a sampler track, select Project > Add Track > Sampler.

RELATED LINKS
Creating Sampler Tracks on page 574

Sampler Track Inspector
The Inspector for sampler tracks contains controls and parameters that allow you to edit your
sampler track.

The top section of the sampler track Inspector contains the following basic track settings:
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Track name
Click once to show/hide the basic track settings section. Double-click to rename the
track.
Edit
Opens the Channel Settings window for the track.
Mute
Mutes the track.
Solo
Solos the track.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Input Transformer
Opens the Input Transformer dialog that allows you to transform incoming MIDI
events in realtime.
Record enable
Activates the track for recording.
Monitor
Routes incoming MIDI to the selected MIDI output. For this to work, activate MIDI
Thru Active in the Preferences dialog (MIDI page).
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Show Lanes
Divides the tracks in lanes.
Freeze Sampler Channel
Allows you to freeze the sampler track.
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Volume
Allows you to adjust the level of the track.
Pan
Allows you to adjust the panning of the track.
Delay
Allows you to adjust the playback timing of the track.
Load/Save/Reload Track Preset
Loads or saves a track preset or reverts the default presets.
Input Routing
Allows you to specify the input bus for the track.

Sampler Track Inspector Sections
Apart from the basic track settings that are always shown, sampler tracks provide other
Inspector sections. These are described in the following sections.

TrackVersions

Allows you to create and edit TrackVersions.

Chords

Allows you to specify how the track follows the chord track.
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Expression Map

Allows you to use the Expression Map features.

Note Expression

Allows you to work with the Note Expression features.

MIDI Modifiers

Allows you to transpose or adjust the velocity of the MIDI track events in realtime during
playback.

MIDI Inserts
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Allows you to add MIDI insert effects.

Instrument Section

Shows the audio-related controls for the sampler track.

Notepad

Allows you to enter notes about the track.

Device Panel

Allows you to display and use device panels.

Quick Controls

Allows you to configure quick controls to use remote devices, for example.

Sampler Track Controls
The track list for sampler tracks contains controls and parameters that allow you to edit your
sampler track.

Mute
Mutes the track.
Solo
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Solos the track.
Track name
Double-click to rename the track.
Record enable
Activates the track for recording.
Monitor
Allows you to route incoming MIDI signals to the selected MIDI output. For this to
work, activate MIDI Thru Active in the Preferences dialog (MIDI page).
Edit
Opens the Channel Settings window for the track.
Open/Close Sampler
Opens/Closes the Sampler Control in the lower zone.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Show Lanes
Divides the tracks in lanes.
ASIO Latency Compensation
Moves all recorded events on the track by the current latency.
Bypass Inserts
Bypasses the inserts for the track.
Bypass EQs
Bypasses the equalizers for the track.
Bypass Sends
Bypasses the sends for the track.
Listen
The listen indicator is lit if the track is in listen mode.
Edit In-Place
Allows you to edit MIDI events and parts on the track in the Project window.
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Lock
Disables all editing of all events on the track.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Freeze Channel
Opens the Freeze Channel Options dialog that allows you to set the Tail Size time in
seconds.

Arranger Track
You can use the arranger track for arranging your project by marking out sections and
determining in which order they are to be played back.
●

To add the arranger track to your project, select Project > Add Track > Arranger.

Arranger Track Inspector
The arranger track Inspector displays the lists of available arranger chains and arranger events.

The arranger track Inspector contains the following settings:
Track Name
Double-click to rename the track.
Edit
Opens the Arranger Editor.
Select Active Arranger Chain + Function
Allows you to select the active arranger chain, to rename it, to create a new one, to
duplicate or to flatten it.
Current Arranger Chain
Shows the active arranger chain.
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Arranger Events
Lists all arranger events in your project. Click the arrow for an arranger event to play
it back and start the live mode.
Stop
Allows you to stop the live mode.
Jump mode
Allows you to define how long the active arranger event is played before jumping to
the next one.

Arranger Track Controls
The track list for the arranger track contains controls and parameters that allow you to edit the
arranger track.

Select Active Arranger Chain
Allows you to select the active arranger chain.
Current Item/Current Repeat
Displays which arranger event and which repeat is active.
Activate Arranger Mode
Allows you to activate and deactivate the arranger mode.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Edit
Opens the Arranger Editor for the track.

Chord Track
You can use the chord track for adding chord and scale events to your project. These can
transform the pitches of other events.
●

To add the chord track to your project, select Project > Add Track > Chord.
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Chord Track Inspector
The chord track Inspector contains a number of settings for the chord events.

The top section of the chord track Inspector contains the following settings:
Track name
Click to show/hide the basic track settings section.
Mute
Mutes the track.
Record enable
Activates the track for recording.
Acoustic Feedback
Allows you to audition the events on the chord track. For this to work, you need to
select a track for auditioning in the track list.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Voicing library
Allows you to set up a voicing library for the track.
Voicing library subset
Allows you to select a library subset.
Configure voicing parameters
Allows you to configure your own voicing parameters for a specific voicing scheme.
Adaptive Voicings
If this option is activated the voicings will be set automatically.
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Automatic Scales
If this option is activated the program creates scale events automatically.
Mapping Offset
Allows you to specify an offset value to make sure that chord events also affect the
MIDI notes that have been triggered too early (enter a negative value) or too late
(enter a positive value).

Chord Track Inspector Sections
Apart from the basic track settings that are always shown, the chord track provides other
Inspector sections. These are described in the following sections.

TrackVersions

Allows you to create and edit TrackVersions.

Notepad

Allows you to enter notes about the track.

Chord Track Controls
The Track List for the chord track contains controls and parameters that allow you to edit the
chord track.

The track list for chord tracks contains the following controls:
Mute
Mutes the track.
Select Track for Auditioning
Allows you to select a track for auditioning the chord events.
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Record Enable
Allows you to record chord events.
Resolve Display Conflicts
Allows you to show all chord events on the track properly, even at low horizontal
zoom levels.
Show Scales
Allows you to show the scale lane in the lower part of the chord track.
Lock
Disables all editing of all events on the track.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.

FX Channel Tracks
You can use FX channel tracks for adding send effects. Each FX channel can contain up to eight
effect processors. By routing sends from an audio channel to an FX channel, you send audio from
the audio channel to the effects on the FX channel. You can place FX channel tracks in a special FX
channel folder, or in the track list, outside a FX channel folder. Each FX channel has a
corresponding channel in the MixConsole. An FX channel track can have any number of
automation tracks.
●

To add an FX channel track to your project, select Project > Add Track > FX Channel.

FX Channel Track Inspector
The Inspector for FX channel tracks shows the settings for the FX channel. When you select the
folder track instead, the Inspector shows the folder and the FX channels it contains. You can click
one of the FX channels shown in the folder to have the Inspector show the settings for that FX
channel.

Track name
Click once to show/hide the basic track settings section. Double-click to rename the
track.
Edit
Opens the Channel Settings window for the track.
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Mute
Mutes the track.
Solo
Solos the track.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Volume
Allows you to adjust the level of the track.
Pan
Allows you to adjust the panning of the track.
Output Routing
Allows you to specify the output bus for the track.

FX Channel Track Inspector Sections
Apart from the basic track settings that are always shown, FX channel tracks provide other
Inspector sections. These are described in the following sections.

Inserts

Allows you to add insert effects to the track.
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Strip

Allows you to set up the channel strip modules.

Equalizers

Allows you to adjust the EQs for the track. You can have up to four bands of EQ for each track.

Sends

Allows you to route the track to one or several FX channels.
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Cue Sends

Allows you to route cue mixes to Control Room cues.

Direct Routing

Allows you to set up direct routing.

Surround Pan

Shows the panner for a track.

136

Tracks
FX Channel Tracks

Fader

Shows a duplicate of the corresponding MixConsole channel.

Notepad

Allows you to enter notes about the track.

Quick Controls

Allows you to configure quick controls to use remote devices, for example.

FX Channel Track Controls
The Track List for FX channel tracks contains controls and parameters that allow you to edit the
settings for the effect.

Track name
Click once to show/hide the basic track settings section. Double-click to rename the
track.
Edit
Opens the Channel Settings window for the track.
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Mute
Mutes the track.
Solo
Solos the track.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Mute Automation
Deactivates the automation read function for the selected parameter.
Automation parameter
Allows you to select a parameter for automation.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Bypass Inserts
Bypasses the inserts for the track.
Bypass EQs
Bypasses the equalizers for the track.
Bypass Sends
Bypasses the sends for the track.
Channel Configuration
Shows the channel configuration of the track.
RELATED LINKS
Click Pattern Editor on page 247
Creating a Click Track on page 255
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Folder Tracks
Folder tracks function as containers for other tracks, making it easier to organize and manage
the track structure. They also allow you to edit several tracks at the same time.
●

To add a folder track to your project, select Project > Add Track > Folder.

Folder Track Inspector
The Inspector for folder tracks shows the folder and its underlying track, much like a folder
structure in the File Explorer/macOS Finder. When you select the one of the tracks shown under
the folder, the Inspector shows the settings for that track.

Track name
Double-click to rename the track.
Mute
Mutes the track.
Solo
Solos the track.
Record enable
Activates the track for recording.
Monitor
Routes incoming signals to the selected output.
Group Editing
Allows you to activate the group editing mode.
Lock
Disables all editing of all events on the track.

Folder Track Controls
The Track List for folder tracks contains controls and parameters that allow you to edit all tracks
in the folder.
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Expand/Collapse
Shows/hides the tracks in the folder. Hidden tracks are played back as usual.
Track name
Double-click to rename the track.
Mute
Mutes the track.
Solo
Solos the track.
Record enable
Activates the track for recording.
Monitor
Routes incoming signals to the selected output.
Group Editing
Allows you to activate the group editing mode.
Lock
Disables all editing of all events on the track.

Group Channel Tracks
You can use group channel tracks to create a submix of several audio channels and apply the
same effects to them. A group channel track contains no events as such, but displays settings
and automation for the corresponding group channel.
All group channel tracks are automatically placed in a special group track folder in the track list,
for easy management. Each group channel track has a corresponding channel in the MixConsole.
A group channel track can have any number of automation tracks.
●

To add a group channel track to your project, select Project > Add Track > Group
Channel.

Group Channel Track Inspector
The Inspector for group channel tracks shows the settings for the group channel.

Track name
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Click once to show/hide the basic track settings section. Double-click to rename the
track.
Edit
Opens the Channel Settings window for the track.
Mute Automation
Deactivates the automation read function for the selected parameter.
Solo
Solos the track.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Volume
Allows you to adjust the level for the track.
Pan
Allows you to adjust the panning of the track.
Output Routing
Allows you to specify the output bus for the track.
NOTE
When you select the group folder track instead, the Inspector shows the folder and the group
channels it contains. You can click one of the group channels shown in the folder, to have the
Inspector show the settings for that group channel.
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Group Channel Track Inspector sections
Apart from the basic track settings that are always shown, group channel tracks provide other
Inspector sections. These are described in the following sections.

Inserts

Allows you to add insert effects to the track.

Strip

Allows you to set up the channel strip modules.

Equalizers

Allows you to adjust the EQs for the track. You can have up to four bands of EQ for each track.
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Sends

Allows you to route the track to one or several FX channels.

Cue Sends

Allows you to route cue mixes to Control Room cues.

Direct Routing

Allows you to set up direct routing.

Surround Pan

Shows the panner for a track.
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Fader

Shows a duplicate of the corresponding MixConsole channel.

Notepad

Allows you to enter notes about the track.

Quick Controls

Allows you to configure quick controls to use remote devices, for example.

Group Channel Track Controls
The Track List for group channel tracks contains controls and parameters that allow you to edit
the settings for the group.

Track name
Double-click to rename the track.
Edit
Opens the Channel Settings window for the track.
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Mute
Mutes the track.
Solo
Solos the track.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Mute Automation
Deactivates the automation read function for the selected parameter.
Automation parameter
Allows you to select a parameter for automation.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Bypass Inserts
Bypasses the inserts for the track.
Bypass EQs
Bypasses the equalizers for the track.
Bypass Sends
Bypasses the sends for the track.
Channel Configuration
Shows the channel configuration of the track.

Marker Track
You can use marker tracks to add and edit markers that help you to locate certain positions
quickly.
●

To add the marker track to your project, select Project > Add Track > Marker.
You can add up to 32 marker tracks in a project.
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Marker Track Inspector
The marker track Inspector displays the marker list.

Track name
Double-click to rename the track.
Edit
Opens the Markers window.
Marker attributes
Shows the markers, their IDs, and time positions. Click in the leftmost column for a
marker to move the project cursor to the marker position.

Marker Track Controls
The track list for the marker track contains controls and parameters that allow you to edit the
marker track.

Track name
Double-click to rename the track.
Locate
Allows you to move the project cursor to the selected marker position.
Cycle
Allows you to select a cycle marker.
Zoom
Allows you to zoom in a cycle marker.
Add Marker
Allows you to add a position marker at the project cursor position.
Add Cycle Marker
Allows you to add a cycle marker at the project cursor position.
Toggle Time Base
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Switches between musical (tempo related) and linear (time related) time base for the
track.
Load available update
This button lights up when other users have made changes to a track and committed
them over the network to indicate that you can load the changes and update the
project.
Automatically apply updates
If this button is activated, all changes that are committed to the tracks by other users
are automatically applied.
Get exclusive access
If this button is activated, you have exclusive access to the track. To unlock a track,
click the Get exclusive access button again.
Commit changes on this track
Commits the changes on this track to the network.
Lock
Disables all editing of all events on the track.

Ruler Track
You can use ruler tracks to show several rulers with different display formats for the timeline.
This is completely independent from the main ruler, as well as rulers and position displays in
other windows.
●

To add a ruler track to your project, select Project > Add Track > Ruler.

Ruler Track Controls
In the track list for ruler tracks you can change the display format for the ruler.
Right-click the ruler to open the display format pop-up menu.

The following display formats are available:
Bars+Beats
Activates a display format of bars, beats, sixteenth notes, and ticks. By default there
are 120 ticks per sixteenth note. To adjust this, set the MIDI Display Resolution in
the Preferences dialog (MIDI page).
Seconds
Activates a display format of hours, minutes, seconds, and milliseconds.
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Timecode
Activates a display format of hours, minutes, seconds, and frames. The number of
frames per second (fps) is set in the Project Setup dialog with the Frame Rate popup menu. To display subframes, activate Show Timecode Subframes in the
Preferences dialog (Transport page).
Feet+Frames 16 mm
Feet and frames, with 40 frames per foot. To let the beginning of a project always
start at 0’00, regardless of any Start offset settings in the Project Setup dialog,
activate Feet’n’Frames Count from Project Start in the Preferences dialog
(Transport page).
Feet+Frames 35 mm
Feet, frames, and 1/4 frames, with 16 frames per foot. To let the beginning of a
project always start at 0’00, regardless of any Start offset settings in the Project
Setup dialog, activate Feet’n’Frames Count from Project Start in the Preferences
dialog (Transport page).
Samples
Activates a display format of samples.
fps (User)
Activates a display format of hours, minutes, seconds, and frames, with a userdefinable number of frames per second. To display subframes, activate Show
Timecode Subframes in the Preferences dialog (Transport page). On the Transport
page, you can also set the frame rate.
NOTE
Ruler tracks are not affected by the display format setting in the Project Setup dialog.

Signature Track
You can use the signature track to add and edit signature events, and to set up click patterns for
them. The signature track’s background always shows bars. This is independent of the ruler
display format setting.
●

To add the signature track to your project, select Project > Add Track > Signature.

RELATED LINKS
Time Signature Events on page 991
Click Patterns Page on page 253

Signature Track Inspector
The signature track Inspector displays a list of all time signature events.

Bar
Shows the number of the bar where the signature event is positioned. Double-click
the field and enter a new value to change the position of the signature event.
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NOTE
The first signature event is always positioned at bar 1. You cannot change this.
Sign.
Shows the value of the signature event. Double-click the field and enter a new value
to change the time signature.
Pattern
Shows the click pattern that is used. Double-click the field to open the Click Pattern
Editor where you can change the pattern.
RELATED LINKS
Click Pattern Editor on page 247

Signature Track Controls
The track list for the signature track contains controls and parameters that allow you to edit the
signature track.

Lock
Disables all editing of all events on the track.
Signature Track Options
●

Copy Click Pattern to Clipboard
Copies the click pattern of the selected signature event to the clipboard.

●

Paste Click Pattern to Selected Signatures
Pastes the click pattern from the clipboard to selected signature events.
NOTE
This only works if the selected signature events are equal.

●

Apply Click Pattern to Equal Signatures
Pastes the click pattern from the clipboard to signature events that are equal.
NOTE
For this you do not have to select the signature events first.

●

Reset Click Pattern to Default
Sets the click pattern of the selected signature event to default. If no signature
event is selected, the click patterns of all signature events are set to default.

●

Show Click Patterns
Allows you to show/hide the click patterns for the signature events.

●

Render MIDI Click between Locators
Adds a MIDI track to your project and creates a MIDI part containing the click
pattern between the left and right locator.

●

Render Audio Click between Locators
Adds an audio track to your project and creates an audio event containing the
click pattern between the left and right locator.
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●

Process Bars Dialog
Opens the Process Bars dialog.

RELATED LINKS
Click Patterns Page on page 253
Process Bars on page 989

Tempo Track
You can use the tempo track to create tempo changes within a project.
●

To add a tempo track to your project, select Project > Add Track > Tempo.

Tempo Track Inspector
The tempo track Inspector displays a list of all tempo events.

Edit
Opens the Tempo Track Editor.
Tempo event list
Shows a list of all tempo events that allows you to edit tempo events and their
positions.

Tempo Track Controls
The track list for the tempo track contains controls and parameters that allow you to edit the
tempo track.

Activate Tempo Track
Allows you to activate the tempo track. In this mode, the tempo cannot be changed
on the Transport panel.
Lock
Disables all editing of all events on the track.
Current Tempo
Allows you to change the tempo at the project cursor position.
Open Process Tempo Dialog

150

Tracks
Transpose Track
Allows you to open the Process Tempo dialog.
New Tempo Points Type
Allows you to specify whether the tempo should change gradually (Ramp) or
instantly (Jump) from the previous curve point to the new one.
Visible Tempo Upper/Lower Limit
Allows you to specify the display range. This changes the display scale of the tempo
track, but not the tempo setting.

Transpose Track
You can use the transpose track to set global key changes.
●

To add the transpose track to your project, select Project > Add Track > Transpose.

Transpose Track Inspector
The transpose track Inspector contains a number of parameters to control the transpose track.

Keep Transpose in Octave Range
Allows you to keep the transposition in the octave range and ensures that nothing is
transposed by more than seven semitones.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.

Transpose Track Inspector sections
Apart from the basic track settings that are always shown, the transpose track provides other
Inspector sections. These are described in the following sections.

Notepad

Allows you to enter notes about the track.

Network

Shows the network connection of the track.
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Transpose Track Controls
The track list for the transpose track contains parameters that allow you to control the transpose
track.

Mute Transpose Events
Mutes the track.
Keep Transpose in Octave Range
Allows you to keep the transposition in the octave range and ensures that nothing is
transposed by more than seven semitones.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.

VCA Fader Track
You can use a VCA fader track to add VCA faders to your project.
●

To add a VCA fader track to your project, select Project > Add Track > VCA Fader.

RELATED LINKS
VCA Faders on page 414
VCA Fader Automation on page 416
Automation on page 695

VCA Fader Track Inspector
The Inspector for VCA fader tracks shows the settings for the VCA faders.

Track name
Click once to show/hide the basic track settings section. Double-click to rename the
track.
Read Automation
Allows you to read track automation.
Write Automation
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Allows you to write track automation.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.
Lock
Disables all editing of all events on the track.
Volume
Allows you to adjust the level of the track.

Fader Section

Shows a duplicate of the corresponding MixConsole channel.

Notepad

Allows you to enter notes about the track.

Quick Controls

Allows you to configure quick controls to use remote devices, for example.
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VCA Fader Track Controls
The track list for VCA fader tracks contains controls and parameters that allow you to edit the
settings for the VCA fader.

Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Lock
Disables all editing of all events on the track.
Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the
track.

Video Track
You can use the video track to play back video events. Video files are displayed as events/clips on
the video track, with thumbnails representing the frames in the film.
●

To add a video track to your project, select Project > Add Track > Video.

Video Track Inspector
The video track Inspector contains a number of parameters to control the video track.

Reveal Video Window
Opens the Video Player window.
Mute Video Track
Mutes the track.
Lock
Disables all editing of all events on the track.
Show Frame Numbers
Allows you to show each thumbnail with the corresponding video frame number.
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Show Thumbnails
Allows you to activate/deactivate the thumbnails of a video track.

Video Track Inspector Sections
Apart from the basic track settings that are always shown, the video track provides an other
Inspector section. This is described in the following section.

Notepad

Allows you to enter notes about the track.

Network

Shows the network connection of the track.

Video Track Controls
The track list for the video track contains a number of parameters to control the video track.

Mute Video Track
Mutes the track.
Lock
Disables all editing of all events on the track.
Show Thumbnails
Allows you to activate/deactivate the thumbnails of a video track.
Show Frame Numbers
Allows you to show each thumbnail with the corresponding video frame number.
Load available update
This button lights up when other users have made changes to a track and committed
them over the network to indicate that you can load the changes and update the
project.
Automatically apply updates
If this button is activated, all changes that are committed to the tracks by other users
are automatically applied.
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Get exclusive access
If this button is activated, you have exclusive access to the track. To unlock a track,
click the Get exclusive access button again.
Commit changes on this track
Commits the changes on this track to the network.

Loudness Track
You can use the loudness track to record and display the loudness of your whole project or of
specific sections.
●

To add the loudness track to your project, select Project > Add Track > Loudness.

Loudness Track Inspector
The loudness track Inspector shows the most important loudness meter displays.

The loudness track Inspector shows the following values:
Short Term
Shows the loudness measured over a duration of 3 s.
Integrated
Shows the average loudness that is measured from start to stop. The period of
measurement is shown in the Time display. The recommended value for the
integrated loudness is -23 LUFS. This absolute value is the reference point for the
relative LU scale where -23 LUFS equals 0 LU.
Range
Shows the dynamic range of the audio that is measured from start to stop. This value
helps you to decide how much dynamic compression you can apply. The range that is
recommended for highly dynamic audio like film music, for example, is 20 LU.
True Peak
Shows the true peak level of the audio. The maximum permitted true peak level in
production is -1 dB.

Notepad
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Allows you to enter notes about the track.

Loudness Track Controls
The track list for the loudness track contains a number of parameters to control the loudness
track.

The track list for the loudness track contains the following settings:
Activate Loudness Calculation
Activates the loudness calculation.
Enable Recording of Loudness Curve
Enables the creation of a loudness curve in real-time at the cursor position during
playback.
Short Term
Shows the loudness measured over a duration of 3 s.
LUFS/LU
Allows you to switch the loudness unit from LUFS (Loudness Unit, absolute values) to
LU (relative values).
Clear Loudness Curve
Allows you to clear the loudness curve on the loudness track.
Quick Analysis
Enables the creation of a loudness curve for a defined section in off-line processing.
Count of true peak values exceeding reference level
Shows the count of true peak values that are exceeding the reference level.
True peak level at cursor
Shows the true peak level at the cursor position.
Jump to previous/next true peak value exceeding reference level
Moves the cursor to the previous/next true peak position that exceeds the reference
level.
Visible Loudness - Upper/Lower limit
Allows you to specify the display range. Note that this does not change the measured
loudness, but changes the display scale of the loudness track.
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Adding Tracks
You can add tracks via the Project menu, the context menu, or by dragging files from the
MediaBay. Tracks can be added with or without track presets.

Add Track Dialog
The Add Track dialog opens when you add audio, MIDI, group/FX/VCA channels, or instrument
tracks. The available options depend on the track type.
Browse
Expands the dialog and allows you to select a track preset for the track.
Count
Allows you to enter the number of tracks that you want to add.
Effect
Allows you to add a send effect to the track.
Configuration
Allows you to set the channel configuration. Audio-related tracks can be configured
as mono, stereo, or surround tracks, with almost any combination of channels.
Speakers
Shows the speaker names according to the track configuration.
Track Name
Allows you to specify a track name.
Output Routing
Allows you to set the output routing for audio, instrument, FX, and group tracks.
Channels Folder
Allows you to determine whether the track will be added inside or outside the
dedicated FX, group, or VCA Fader channels folder. If you select Create Outside
Folder, the new track will be added below the selected track.
Add Track
Adds the track and closes the dialog.

Adding Tracks via the Project Menu
PROCEDURE
1.

Select Project > Add Track.
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2.

Select a track of a specific type.

3.

In the Add Track dialog, edit the add track options.

4.

Click Add Track.

RESULT
The new tracks are added to the project below the selected track.
RELATED LINKS
Add Track Dialog on page 158

Adding Tracks based on Track Presets
You can add tracks based on track presets. Track presets contain sound and channel settings.
PROCEDURE
1.

Select Project > Add Track.

2.

Select Using Track Preset.
You can also right-click the track list and select Add Track Using Track Preset.

3.

In the Choose Track Preset dialog, select a track preset.
The number and type of the added tracks depend on the selected track preset.

4.

Click Add Track.

RESULT
The new tracks are added to the project below the selected track.
RELATED LINKS
Add Track Dialog on page 158
Track Presets on page 188

Adding Tracks by Dragging Files from the MediaBay
PREREQUISITE
One of the following prerequisites must apply:
●

The MediaBay is open. To open the MediaBay press F5.

●

The Media rack in the right zone of the Project window is open. Click Show/Hide Right
Zone and click the Media tab to open it.

PROCEDURE
1.

In the MediaBay, select the files that you want to add tracks for.

2.

Drag the files into the track list.
●

The indicator highlights the position at which the new tracks will be added.

●

If you drag multiple audio files into the track list, choose if you want to place all files
on one track or on different tracks.

●

If you drag multiple audio files into the track list, the Import Options dialog opens
that allows you to edit the import options.

RESULT
The new tracks are added at the position that was highlighted by the indicator in the track list.
The audio files are inserted at the cursor position.
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RELATED LINKS
MediaBay on page 607
Media Rack in Right Zone on page 607
Import Options Dialog on page 160

Import Options Dialog

Copy Files to Working Directory
Copies the audio file to the Audio folder of the project, and has the clip refer to the
copy.
Deactivate this option to have the clip refer to the original file in the original location.
In this case, it is marked as “external” in the Pool.
Convert and Copy to Project if Needed
Converts the imported file if the sample rate or the bit depth differ from the settings
in the Project Setup dialog.
Split Channels/Split Multi Channel Files
Splits stereo or multi channel audio files into a corresponding number of mono files,
one for each channel, and copies the imported files to the Audio folder of the
project.
Inserts the split files into the project and into the Pool as separate mono tracks.
The Split File Name Format pop-up menu allows you to specify how the split files
are named. This allows for compatibility with other products when exchanging audio
files.
Please, don’t ask again
Always imports files according to the settings, without opening the dialog again. You
can reset this option in the Preferences dialog (Editing—Audio page).

Importing Tracks
You can import audio, instrument, sampler, MIDI, chord, marker, and video tracks from other
Nuendo or Cubase projects.
Audio, instrument, MIDI, sampler tracks
A new track is created in your project and all events, channel settings, and
TrackVersions are imported.
The following mixer settings are not imported: the channel visibility and zone
settings, the record-enable status, the send destination, and the device panel
settings. The routing settings are imported only if the active project contains the
same routing sources and destinations as the imported track.
NOTE
You can also import a track as a new TrackVersion of an existing track. This new
TrackVersion gets the name of the imported track and contains all its events. The
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channel settings of the existing track remain unchanged. If the imported track
contains more than one TrackVersion, only its active TrackVersion is imported.
Imported TrackVersions must be of the same type as the track in your active project.
Marker tracks
NOTE
A new marker track is created. If your project already contains 30 marker tracks, you
cannot import a marker track from another project. In this case, you must remove an
existing marker track first.
Chord tracks
A chord track is created. If your project already contains a chord track, it is replaced
by the imported chord track.
Video tracks
A video track is created. If your project already contains video tracks, you cannot
import a video track from another project. In this case, you must remove an existing
video track first.

Importing Tracks from Project
You can import tracks from other Nuendo or Cubase projects.
PROCEDURE
1.

Select File > Import > Tracks from Project.

2.

In the file dialog, select a the project file that contains the tracks that you want to import,
and click Open.

3.

In the Import column of the Import Options dialog, select the tracks that you want to
import or click Select All.

4.

Optional: In the Destination column, select a destination for the track.

5.

Click OK.

RESULT
The tracks are imported in your active project.
RELATED LINKS
Import Options for Tracks on page 162
TrackVersions on page 181

Importing Tracks from Track Archive
You can import tracks from track archives.
PREREQUISITE
You have created at least one track archive by exporting selected tracks from a project.
PROCEDURE
1.

Select File > Import > Track Archive.

2.

In the file dialog, select the .xml file of the track archive and click Open.

3.

In the Import column of the Import Options dialog, select the tracks that you want to
import or click Select All.
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4.

Optional: In the Destination column, select a destination for the track.

5.

Click OK.

RESULT
The tracks are imported into your active project.
RELATED LINKS
Import Options for Tracks on page 162
TrackVersions on page 181

Import Options for Tracks
The Import Options dialog allows you to activate tracks for import, to specify a destination track,
and to set up several import options.

Import
Allows you to select the tracks that you want to import into your project.
Type
Shows the track type.
Track Name
Shows the track name.
Destination
Opens a pop-up menu that allows you to select the destination track for the
imported track.
Select All
Selects all tracks.
Select None
Deselects all tracks.
Project Settings
Shows the sample rate, the frame rate, and the project start time for both the
imported tracks and your active project.
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NOTE
Imported tracks may contain media files with a sample rate that differs from the
sample rate of your destination project. Files with a sample rate different from the
one that is used in the destination project play back at the wrong speed and pitch.
Copy to Active Project Folder
Copies the media files of the imported tracks to your active project folder. If this
option is deactivated, the media file path of the original project is referenced.
Perform Sample Rate Conversion
Converts the sample rate of the imported tracks is to the sample rate of your active
project.
NOTE
This option is available only if the sample rates of the imported tracks and your
active project differ and Copy To Active Project Folder is activated.

RELATED LINKS
TrackVersions on page 181

Exporting Tracks as Track Archive
Track archives contain information that is associated with the tracks such as channel settings,
parts and events, and automation.
NOTE
Project-specific settings such as the tempo, are not exported to track archives.
Track archives are saved as .xml files.
When exporting audio and video tracks, you can either reference the media files or copy them to
a separate folder.
RELATED LINKS
Track Presets on page 188
Exporting Audio or Video Tracks as Track Archives on page 164

Exporting Tracks as Track Archives
PROCEDURE
1.

Select the tracks you want to export.

2.

Select File > Export > Selected Tracks.

3.

In the file dialog that opens, select or create a folder for saving the track archive as
single .xml file.

4.

Enter a file name and click Save.

RELATED LINKS
Exporting Audio or Video Tracks as Track Archives on page 164
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Exporting Audio or Video Tracks as Track Archives
PROCEDURE
1.

Select the audio or video tracks and any other tracks that you want to export.

2.

Select File > Export > Selected Tracks.

3.

In the dialog that opens, choose between the following options:
●

Click Copy to include copies of the media files in the export.
In the file dialog that opens, select an empty folder or create a new folder for saving
the track archive as .xml file and its media subfolder.
Click OK to save the track archive.

●

Click Reference to include a reference to the files in the export.
In the file dialog that opens, select or create a folder for saving the track archive as
single .xml file.

4.

Enter a name for the track archive and click Save.

Exporting MIDI Tracks as Standard MIDI File
You can export MIDI tracks as standard MIDI files. This allows you to transfer MIDI material to
virtually any MIDI application on any platform.
PROCEDURE
1.

Select File > Export > MIDI File.

2.

In the file dialog that opens, specify a location and name for the file.

3.

Click Save.

4.

In the Export Options dialog, activate the options for the settings that you want to export,
and click OK.

RESULT
The MIDI file is exported. It includes the tempo and time signature events of the Tempo Track
Editor or, if the tempo track is deactivated on the Transport panel, the current tempo and time
signature.
NOTE
If you want to include other Inspector settings than those specified in the Export Options, use
Merge MIDI in Loop to convert these settings to real MIDI events.

RELATED LINKS
Export Options for MIDI Files on page 165
Merging MIDI Events into a New Part on page 786
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Export Options for MIDI Files
The Export Options for MIDI files allow you to specify what data is included in the exported MIDI
files.

Export Inspector Patch
If this option is activated, the MIDI patch settings in the Inspector - Bank Select and
Program Select (used for selecting sounds in the connected MIDI instrument) are
included as MIDI Bank Select and Program Change events in the MIDI file.
Export Inspector Volume/Pan
If this option is activated, Volume and Pan settings made in the Inspector are
included as MIDI Volume and Pan events in the MIDI file.
Export Automation
If this option is activated, the automation data (just as it is heard during playback) is
converted to MIDI controller events and included in the MIDI file. This also includes
automation recorded with the MIDI Control plug-in.
Note that if a continuous controller (CC7, for example) has been recorded but the
Read button is deactivated for the automation track (that is the automation is
effectively switched off for this parameter), only the part data for this controller will
be exported.
If this option is deactivated and the Read Automation button is activated, no
continuous controllers will be exported. If the Read button is deactivated, the
controller data of the MIDI part are exported (these will now be handled like
“regular” part data).
It is recommended to activate the “Export Automation” option.
Export Inserts
If this option is activated and you are using MIDI modifiers or any MIDI plug-ins as
insert effects, the modifications to the original MIDI notes that occur as a result of
the effects will be included in the MIDI file. A MIDI delay, for example, will produce a
number of repeats to a MIDI note by actually adding additional, “echoing” notes at
rhythmic intervals - these notes will be included in the MIDI file if the option is
activated.
Export Sends
If this option is activated and you are using any MIDI plug-ins as send effects, the
modifications to the original MIDI notes that occur as a result of the effects will be
included in the MIDI file.
Export Markers
If this option is activated, any markers you have added will be included in the MIDI
file as Standard MIDI File Marker events.

165

Track Handling
Splitting Multi-Channel Audio Tracks
Export as Type 0
If this option is activated, the MIDI file will be of Type 0 (all data on a single track, but
on different MIDI channels). If you do not check this option, the MIDI file will be of
Type 1 (data on separate tracks). Which type to choose depends on what you want to
do with the MIDI file (in which application or sequencer it is to be used).
Export Resolution
You can specify a MIDI resolution between 24 and 960 for the MIDI file. The
resolution is the number of pulses, or ticks, per quarter note (PPQ) and determines
the precision with which you will be able to view and edit the MIDI data. The higher
the resolution, the higher the precision. The resolution should be chosen depending
on the application or sequencer with which the MIDI file will be used though,
because certain applications and sequencers may not be able to handle certain
resolutions.
Export Locator Range
If this option is activated, only the range between the left and right locator will be
exported.
Export includes Delay
If this option is activated, any delay settings you have made in the Inspector will be
included in the MIDI file.
RELATED LINKS
Automation on page 695
Markers on page 334
MIDI Track Parameters on page 764
Merging MIDI Events into a New Part on page 786
Export Options on page 1197

Splitting Multi-Channel Audio Tracks
You can split multi-channel tracks such as stereo or surround into several mono tracks. This is
useful if you want to use the tracks in an application that only supports mono tracks, or if you
want to edit individual channels of a multi-channel file.
PROCEDURE
1.

Optional: Select the track that you want to split in the Project window.

2.

Select Project > Convert Tracks > Multi-Channel to Mono.

3.

In the Split Multi-Channel to Mono dialog, make your settings and click OK.

RESULT
●

The tracks are split into as many mono tracks as corresponds to the channel configuration
of the source track.

●

All channel settings of the source tracks are copied to the tracks created by the split
operation.

●

The multi-channel audio material of the source track is split into mono events which are
inserted on the new tracks.

●

In the Audio folder of the project, a subfolder called Split is created which contains the
new mono files.

NOTE
If the channel configurations of the source track and the source file do not match because the
multi-channel source track contains a mono file, for example, this mono file is copied onto the
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first 2 destination tracks. However, since panning information is not considered during the split,
the volume of the new mono file may not correspond to that of the file on the original track.

Split Multi-Channel to Mono
●

To open the Split Multi-Channel to Mono dialog, select Project > Convert Tracks > MultiChannel to Mono.

Source Tracks
Allows you to select whether you want to split all multi-channel tracks or only the
selected.
Options
Allows you to specify what happens when the multi-channel file is split:
●

Keep Source Tracks
Inserts new mono tracks below the source tracks.

●

Mute Source Tracks
Inserts new mono tracks below the source tracks and mutes the source tracks.

●

Delete Source Tracks
Inserts new mono tracks and deletes the source tracks.

●

Create New Project
Creates a new project containing only the resulting split tracks.

Split File Name Format
Tracks and files get the name of the source track. By selecting one of the options,
you can specify if the name is followed by a number, by letters that denote the
corresponding speaker channel or by both.

Merging Mono Audio Tracks to Multi-Channel Tracks
You can convert mono tracks into multi-channel tracks to make editing and mixing more
convenient.
PREREQUISITE
●

You project contains tracks with audio events that are not in Musical Mode.

●

The tracks fit evenly into a number of multi-channel files of the destination format.

●

The tracks reside on the same level in the track list, that is, either on the top level or within
the same folder track.

●

The tracks match in terms of channel settings and automation.
If the settings differ the settings of the topmost track of each group are used.
If the separate audio events have different volume envelopes, these are calculated into the
new clip.

●

The level of the source events should not exceed 0 dB, otherwise clipping occurs in the
created files. The only exception to this are files in 32-bit-float format.
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PROCEDURE
1.

Optional: Select the tracks that you want to convert in the Project window.

2.

Select Project > Convert Tracks > Mono to Multi-Channel.

3.

In the Merge Mono to Multi-Channel dialog, make your settings and click OK.

RESULT
●

The tracks are converted into as many multi-channel tracks as corresponds to the
destination format.

●

Events that have the same timeline position are converted into a multi-channel event on
the new track.

●

If the lengths of the source events do not match exactly, the overlap is included in the new
events.

●

In the Audio folder of the project, a subfolder called Merge is created which contains the
new multi-channel files.

NOTE
If the outputs of the mono tracks are routed to separate channels within one output bus, this bus
is selected as output for the multi-channel track.

RELATED LINKS
Merge Mono to Multi-Channel on page 168
Export Audio Mixdown on page 1007

Merge Mono to Multi-Channel
●

To open the Merge Mono to Multi-Channel dialog, select Project > Convert Tracks >
Merge Mono to Multi-Channel.

Source Tracks
Allows you to select whether you want to split all multi-channel tracks or only the
selected.
Options
Allows you to specify what happens when the multi-channel file is split:
●

Keep Source Tracks
Inserts new mono tracks below the source tracks.

●

Mute Source Tracks
Inserts new mono tracks below the source tracks and mutes the source tracks.

●

Delete Source Tracks
Inserts new mono tracks and deletes the source tracks.

●

Create New Project
Creates a new project containing only the resulting split tracks.
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Destination Format
Allows you to select the format for the multi-channel file or files.
NOTE
The number of selected tracks must match this format. If you have selected 14 mono
tracks, for example, you can select Stereo or one of the 7-channel surround formats.
The tracks are combined according to their order in the track list.

Removing Tracks
You can remove selected or empty tracks from the track list.
●

To remove selected tracks, select Project > Remove Selected Tracks or right-click the
track that you want to remove, and from the context menu select Remove Selected
Tracks.
NOTE
If you delete tracks that are not empty, a warning message is displayed. You can deactivate
this message. To reactivate the message, activate Display Warning before Deleting NonEmpty Tracks in the Preferences dialog (Editing page).

●

To remove empty tracks, select Project > Remove Empty Tracks.

Moving Tracks in the Track List
You can move tracks up or down in the track list.
PROCEDURE
●

Select a track and drag it up or down in the track list.

Renaming Tracks
PROCEDURE
1.

Double-click the track name and type in a new name for the track.

2.

Press Return.
If you want all events on the track to get the same name, hold down any modifier key and
press Return.

AFTER COMPLETING THIS TASK
If the Parts Get Track Names option is activated in the Preferences dialog (Editing page), and
you move an event from one track to another, the moved event will automatically be named
according to its new track.

Coloring Tracks
All new tracks are automatically assigned a color according to the Auto Track Color Mode
settings. However, you can change the track color manually.
●

To change the color for the selected track, use the Select Colors pop-up menu on the
toolbar.
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●

You can also use the Track Color Selector. In the Inspector, click the arrow to the right of
the track name and select a color.

In the track list, Ctrl/Cmd-click in the left area and select a color.

●

To control which colors are used for new tracks, edit the Auto Track Color Mode settings
in the Preferences dialog (Event Display—Tracks page).

RELATED LINKS
Auto Track Color Mode on page 1167

Showing Track Pictures
You can add pictures to tracks to recognize your tracks easily. Track pictures are available for
audio, instrument, MIDI, FX channel and group channel tracks.
PREREQUISITE
Adjust the track height to at least 2 rows.
PROCEDURE
1.

Right-click any track in the track list.

2.

From the track list context menu, select Show Track Pictures.

If you move the mouse to the left on a track, a highlighted rectangle appears.
AFTER COMPLETING THIS TASK
Double-click the rectangle to open the Track Pictures Browser and set up a track picture.
RELATED LINKS
Track Pictures Browser on page 171
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Track Pictures Browser
The Track Pictures Browser allows you to set up and select pictures that can be shown in the
track list and in the MixConsole. Track pictures are useful to recognize tracks and channels easily.
You can select pictures from the factory content or add new ones to the user library.
●

To open the Track Pictures Browser for a track, double-click in the lower left side of the
track list.

Factory
Shows the factory content in the pictures browser.
Pictures Browser
Shows the pictures that you can assign to the selected track/channel.
User
Shows your user content in the pictures browser.
Import
Opens a file dialog that allows you to select pictures in bmp, jpeg, or png format and
add them to the user library.
Remove Selected Pictures from User Library
Removes the selected picture from the user library.
Reset Current Picture
Removes the picture from the selected track/channel.
Show/Hide Preview
Opens/Closes a section with further color and zoom settings.
Track Picture Preview
Shows the current track picture. When you zoom in the picture, you can drag it with
the mouse to change its visible part.
Track Color
Opens the Track Color Selector. Click the rectangle to change the track color.
Intensity
Allows you to apply the track color to the track picture and set the color intensity.
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Zoom
Allows you to change the size of the track picture.
Rotate
Allows you to rotate the track picture.

Setting the Track Height
You can enlarge the track height to show the events on the track in detail, or you can decrease
the height of several tracks to get a better overview of your project.
●

To change the height of an individual track, click its lower border in the track list and drag
up or down.

●

To change the height of all tracks simultaneously, hold down Ctrl/Cmd, click the lower
border of one track, and drag up or down.

●

To set the number of tracks to view in the Project window, use the track zoom menu.

●

To set the track height automatically when you select a track, click Edit > Enlarge Selected
Track.

RELATED LINKS
Track Zoom Menu on page 172
Track Control Settings on page 99

Track Zoom Menu
The track zoom menu allows you to set the number of tracks and the track height in the Project
window.
●

To open the track zoom menu in the lower right of the Project window, click the arrow
button above the vertical zoom control.

The following options are available:
Zoom Tracks x Rows
Zooms all track heights to show the specified number of rows.
Zoom Tracks Full
Zooms all tracks to fit in the active Project window.
Zoom x Tracks
Zooms the specified number of tracks to fit in the active Project window.
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Zoom N Tracks
Allows you to set the number of tracks to fit in the active Project window.
Zoom Tracks Minimal
Zooms all track heights to the minimum size.
Snap Track Heights
Changes the track height in fixed increments when you resize it.

Selecting Tracks
●

To select a track, click on it in the track list.

●

To select several tracks, Ctrl/Cmd-click several tracks.

●

To select a continuous range of tracks, Shift-click the first and last track in a continuous
range of tracks.

Selected tracks are highlighted in the track list.
RELATED LINKS
Track Selection follows Event Selection on page 1184
Scroll to selected Track on page 1188
Select Channel/Track on Solo on page 1188
Select Channel/Track on Edit Settings on page 1188

Selecting Tracks with Arrow Keys
You can select tracks and events with the Up Arrow key or the Down Arrow key on the computer
keyboard. However, you can make the Up Arrow key and the Down Arrow key exclusively
available for selecting tracks.
●

To make the Up Arrow key and the Down Arrow key exclusively available for selecting
tracks, activate Use Up/Down Navigation Commands for selecting Tracks only in the
Preferences dialog (Editing page).

The following applies:
●

If this option is deactivated and no event/part is selected in the Project window, the Up
Arrow key and the Down Arrow key are used to step through the tracks in the track list.

●

If this option is deactivated and an event/part is selected in the Project window, the Up
Arrow key and the Down Arrow key still step through the tracks in the track list – but on
the selected track, the first event/part will automatically be selected as well.

●

If this option is activated, the Up Arrow key and the Down Arrow key are only used to
change the track selection – the current event/part selection in the Project window will not
be altered.

Duplicating Tracks
You can duplicate a track with all contents and channel settings.
PROCEDURE
●

Select Project > Duplicate Tracks.

RESULT
The duplicated track appears below the original track.
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Disabling Tracks
You can disable audio, instrument, MIDI, and sampler tracks that you do not want to play back or
process at the moment. Disabling a track zeroes its output volume and shuts down all disk
activity and processing for the track.
PROCEDURE
●

Right-click in the track list and select Disable Track from the context menu.

RESULT
The track color changes and the corresponding channel in the MixConsole is hidden.
To enable a disabled track and restore all channel settings, right-click in the track list and select
Enable Track.

Organizing Tracks in Folder Tracks
You can organize your tracks in folders by moving tracks into folder tracks. This allows you to
perform editing on several tracks as one entity. Folder tracks can contain any type of track
including other folder tracks.
●

To create a folder track, open the Project menu and in the Add Track submenu select
Folder.

●

To create new folder track and move all selected tracks into it, open the Project menu and
from the Track folding submenu select Move Selected Tracks To New Folder.

●

To move tracks into a folder, select them and drag them into the folder track.

●

To remove tracks from a folder, select them and drag them out of the folder.

●

To hide/show tracks in a folder, click the Expand/Collapse Folder button of the folder
track.

●

To hide/show data on a folder track, open the context menu for the folder track and select
an option from the Show Data on Folder Tracks submenu.

●

To mute/solo all tracks in a folder track, click the Mute or Solo button for the folder track.

NOTE
Hidden tracks are played back as usual.

RELATED LINKS
Group Editing Mode on page 216

Moving Tracks to Folder Tracks
You can move your tracks to folder tracks to organize them and to perform editing on several
tracks as one entity. You can move any type of track including other folder tracks to folder tracks.
PROCEDURE
●

Select Project > Track Folding > Move Selected Tracks to New Folder.

RESULT
This creates a new folder and moves all selected tracks into it.
NOTE
You can also drag and drop tracks into or out of a folder track.
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RELATED LINKS
Folder Tracks on page 139
Folder Track Controls on page 139

Handling Overlapping Audio
The basic rule for audio tracks is that each track can only play back a single audio event at a time.
If two or more events overlap, you will only hear one of them: the one that is actually visible.
If you have a track with overlapping (stacked) events/regions, use one of the following methods
to select the event/region that is played back:
●

Open the context menu for the audio event in the event display and select the desired
event or region from the To Front or Set to Region submenu.
The available options depend on whether you performed a linear or a cycle recording and
the record mode you used. When recording audio in cycle mode, the recorded event is
divided in regions, one for each take.

●

Use the handle in the middle of a stacked event and select an entry from the pop-up menu
that appears.

●

Activate Show Lanes and click the desired take.

RELATED LINKS
Working with Lanes on page 177

Track Folding
You can show, hide, or invert tracks that are displayed in the Project window event display. This
allows you to divide the project into several parts by creating several folder tracks for the
different project elements and showing/hiding their contents by selecting a menu function or
using a key command. You can also fold in automation tracks this way.
●

To open the Track Folding menu, select Project > Track Folding.

The following options are available:
Toggle Selected Track
Reverses the fold state of the selected track.
Fold Tracks
Folds in all open folder tracks in the Project window.
NOTE
The behavior of this function depends on the Deep Track Folding setting in the
Preferences dialog.
Unfold Tracks
Unfolds all folder tracks in the Project window.
NOTE
The behavior of this function depends on the Deep Track Folding setting in the
Preferences dialog.
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Flip Fold States
Flips the fold states of the tracks in the Project window. This means that all tracks
that were folded in will be unfolded and all unfolded tracks will be folded in,
respectively.
Move Selected Tracks to New Folder
Moves all selected tracks to the folder track. This menu option is available if at least
one folder track is available.
NOTE
You can assign key commands for these menu options in the Key Commands dialog in the
Project category.
The following option also affects the track folding behavior:
Deep Track Folding
You can activate this option in the Preferences dialog (Editing—Project &
MixConsole page).
If this option is activated, any folding settings that you make on the Track Folding
submenu of the Project menu also affect the subelements of the tracks. For
example, if you fold in a folder track that contains 10 audio tracks, of which 5 have
several open automation tracks, all these audio tracks within the folder track will also
be folded in.

How Events are Displayed on Folder Tracks
Closed folder tracks can display data of the contained audio, MIDI, and instrument tracks as data
blocks or as events.
When you close folder tracks, the contents of the contained tracks are displayed as data blocks or
events. Depending on the folder track height, the display of the events can be more or less
detailed.

Modifying Event Display on Folder Tracks
You can modify the event display on folder tracks.
PROCEDURE
1.

Right-click the folder track.

2.

On the context menu, select Show Data on Folder Tracks.
You have the following options:
●

Always Show Data
If this option is activated, data blocks or event details are always displayed.

●

Never Show Data
If this option is activated, nothing is displayed.

●

Hide Data When Expanded
If this option is activated, the display of events is hidden when you open folder
tracks.

●

Show Event Details
If this option is activated, event details are displayed. If this option is deactivated,
data blocks are displayed.

176

Track Handling
Working with Lanes
NOTE
You can change these settings in the Preferences dialog (Event Display—Folders page).

RELATED LINKS
Event Display - Folders on page 1193

Working with Lanes
The descriptions in the following paragraphs focus on cycle recordings with takes. However, you
can also apply lane operations and comping methods on overlapping events or parts that you
assemble on one track.
If you perform a cycle recording in the Keep History or Cycle History + Replace modes (audio)
or in the Stacked or Mix-Stacked modes (MIDI), the recorded cycle laps are shown on the track
with the last recorded take active and on top.

The Show Lanes mode gives you a good overview of all your takes. If you activate the Show
Lanes button, the recorded takes are shown on separate lanes.

Show Lanes button

Lanes are handled differently, depending on whether you work with audio or MIDI:
Audio
As each audio track can only play back one single audio event at a time, you only
hear the take that is activated for playback, for example, the last lap of a cycle
recording.
MIDI
Overlapping MIDI takes (parts) can be played back simultaneously. If you recorded in
Mix-Stacked mode, you hear all takes from all cycle laps.
Lanes can be reordered, sized, and zoomed like regular tracks.
To solo a lane, you can activate the Solo button for it. This allows you to hear the lane in the
project context. If you want to hear the take without the project context, you also have to activate
the main track’s Solo button.

Assembling a Perfect Take
You can play back, cut, and activate takes to combine the best parts of your recording in a final
take.
PROCEDURE
1.

Select the Comp tool or the Object Selection tool.

2.

Bring a take to front to select it for playback, and listen to it.

3.

Audition different takes to compare them in more detail.
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4.

If necessary, cut your takes into smaller sections, create new ranges, and bring them to
front.

5.

Proceed until you are satisfied with the result.

AFTER COMPLETING THIS TASK
After assembling your perfect take, you can improve your take.
●

To automatically resolve overlaps and remove empty lanes, right-click the track and select
Clean Up Lanes.

For audio, proceed as follows:
●

Apply auto fades and crossfades to the comped takes.

●

To put all takes on a single lane, and remove all takes in the background, select all takes
and select Audio > Advanced > Delete Overlaps.

●

To create a new and continuous event of all selected takes, select Audio > Bounce
Selection.

For MIDI, proceed as follows:
●

Open your takes in a MIDI editor to perform fine adjustments like removing or editing
notes.

●

To create a new and continuous part of all selected takes that is placed on a single lane,
select all takes and select MIDI > Bounce MIDI.

●

To create a new part and place it on a new track, select MIDI > Merge MIDI in Loop.

Finally, clean up the lanes as follows:
●

Right-click a track and select Create Tracks from Lanes.
The lane is converted into a new track.

Assembling Operations
Unless it is clearly stated, all operations can be performed in the Project window and in the
Audio Part Editor. Snap is taken into account, and all operations can be undone.
To assemble a perfect take, you can use the Comp tool, the Object Selection tool, or the Range
Selection tool.
●

The Comp tool modifies all takes on all lanes simultaneously.
This is useful if the recorded takes have the same start and end positions.

●

The Object Selection tool and the Range Selection tool affect single takes on individual
lanes.
If this is not what you want, you can either perform your edits on the main track or use the
Comp tool.

NOTE
If you assemble stacked events on an audio track, deactivate Treat Muted Audio Events like
Deleted in the Preferences dialog (Editing—Audio page).
The following operations can be performed:
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Operation

Comp tool

Select

Hold down Shift and click on a Click on a take.
take.

(Project window only)
Bring to front

Click on a take. Click twice to
toggle.

Object Selection/Range
Selection tool

Position the mouse pointer
over the middle of the lower
border of a take until it
changes to a Comp symbol,
and click. Click twice to toggle.
For MIDI this mutes/unmutes
a take.

Comp
(create a new range and bring
it to front, Project window
only)

Click and drag on a lane. All
takes are cut at the range start
and end.
If the audio takes are adjacent
without gaps or fades and the
material itself matches, the
takes are merged within the
range.

Audition

Press Ctrl/Cmd to activate the See left.
Speaker tool and click at the
position where you want
playback to start.

Move

Click and drag on the main
track.

Click and drag on any lane.

Resize

Drag the resize handles. All
takes with the same start and
end positions are affected.
Resizing is constrained to the
end or start of the adjacent
takes. This ensures that you
do not create overlaps
accidentally.

Drag the resize handles.

Correct timing

See left.
Select a take, hold down AltShift (the tool modifier for Slip
Event) and drag with the
mouse.

(Slip Event)
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Operation

Comp tool

Object Selection/Range
Selection tool

Cut

Alt-click on a take. If you cut a
MIDI part and the cut position
intersects one or several MIDI
notes, the result depends on
the Split MIDI Events option
in the Preferences dialog
(Editing—MIDI page).

See left.

Adjust cuts

Position the mouse pointer
over a cut and drag to the left
or to the right.

See left.

Glueing cuts

Bring a new range to front.

Select a range spanning all the
cuts that you want to glue,
and double-click.

RELATED LINKS
Splitting Events on page 212

Defining the Track Time Base
The time base of a track determines if the events on a track are positioned to bars and beats
(musical time base) or to the timeline (linear time base). Changing the playback tempo affects
only the time position of events on tracks with a musical time base.
PROCEDURE
●

In the track list, click Toggle Timebase

to change the time base.

RESULT
Musical time base is indicated by a note symbol:

Linear time base is indicated by a clock symbol:

NOTE
Switching between linear and musical time base results in a very small loss of positioning
precision. Therefore you should avoid switching repeatedly between the two modes.

RELATED LINKS
Editing Tempo and Time Signature on page 975
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Defining the Default Track Time Base
You can specify the default track time type for new tracks (audio, group/FX, MIDI, and marker
tracks).
PROCEDURE
1.

In the Preferences dialog, select Editing.

2.

Open the Default Track Time Type pop-up menu and select a default track time type.

RESULT
If you selected Follow Transport Main Display, the primary time format setting on the
Transport panel is used. When this is set to Bars+Beats, tracks with musical time base are added.
When this is set to any of the other options (Seconds, Timecode, Samples, etc.), all new tracks use
linear time base.
RELATED LINKS
Default Track Time Type on page 1182

TrackVersions
TrackVersions allow you to create and manage multiple versions of events and parts on the same
track.
TrackVersions are available for audio, MIDI, and instrument tracks. You can also have
TrackVersions of the chord track, the signature track, and the tempo track.
TrackVersions are useful for the following tasks:
●

Starting new recordings from scratch.

●

Comparing different takes and comps.

●

Managing takes that were recorded in a multi-track recording.

NOTE
TrackVersions are not available for automation tracks.
TrackVersions are included in track archives and project backups. When you work with the
networking feature, only the active TrackVersion is committed.
The TrackVersion key commands can be found in the TrackVersions category of the Key
Commands dialog.

TrackVersions Pop-Up Menu
The TrackVersions pop-up menu is available for all track types that support TrackVersions. It
contains the most important functions for managing TrackVersions and a TrackVersions list.
To open the TrackVersions pop-up menu for a track, click the arrow to the right of the track
name.
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The following options are available:
TrackVersion List
Lists all TrackVersions of the track for which you opened the TrackVersions pop-up
menu and allows you to activate a TrackVersion.
New Version
Creates a new, empty TrackVersion for the selected tracks.
Duplicate Version
Creates a copy of the active TrackVersion for the selected tracks.
Rename Version
Opens a dialog that allows you to change the TrackVersion name for the selected
tracks.
Delete Version
Deletes the active TrackVersion for the selected tracks.
Select Tracks with Same Version ID
Selects all tracks that have a TrackVersion with the same ID.

TrackVersions Section
The TrackVersions section in the Inspector allows you to view and manage TrackVersions for a
selected track. It is available for audio tracks, MIDI tracks, instrument tracks, and the chord track.

To open the TrackVersions section for a track, select the track, and in the Inspector, click the
TrackVersions section.
1

Name column
Shows the version name. Double-click to change it. The name will be changed for all
selected tracks.

2

ID column
Shows the TrackVersion ID.

3

Track Version Indicator
Indicates that more than one TrackVersion exists.

4

Track Version list
Lists all TrackVersions and allows you to activate one of them for all selected tracks.

5

New Version
Creates a new, empty TrackVersion for all selected tracks.

6

Duplicate Version
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Creates a copy of the active TrackVersion for all selected tracks.
7

Delete Version
Deletes the active TrackVersion for all selected tracks. This function is only available if the
track has more than one TrackVersion.

Creating New TrackVersions
You can create new, empty TrackVersions for selected tracks.
PROCEDURE
1.

In the track list, select the tracks for which you want to create a new TrackVersion.

2.

Select Project > TrackVersions > New Version.
NOTE
You can also use the TrackVersions section in the Inspector (only available for audio
tracks, MIDI tracks, instrument tracks, and the chord track) or the TrackVersions pop-up
menu in the track list to create a new TrackVersion.

RESULT
The event display shows a new, empty TrackVersion. Events of previous TrackVersions are
hidden. The track list shows a default version name.

TrackVersion IDs
All TrackVersions are automatically assigned an ID. TrackVersions that are created together get
the same TrackVersion ID and can be selected together.
In the TrackVersions section in the Inspector, the TrackVersion ID is shown in the ID column of
the TrackVersion list.
In the track list, you can open the TrackVersions pop-up menu to see the TrackVersion ID.

Selecting Tracks by TrackVersion ID
You can simultaneously select all tracks that share the same TrackVersion ID.
PROCEDURE
1.

Activate the TrackVersion.

2.

Select Project > TrackVersions > Select Tracks with same Version ID.

RESULT
All tracks that have TrackVersions with the same ID are selected.

Assigning a Common ID
TrackVersions on different tracks that were not created together have different TrackVersion IDs.
TrackVersions with different IDs cannot be activated together. To do this, you must assign a new
version ID to these tracks.
PROCEDURE
1.

Select the tracks and activate the TrackVersions to which you want to assign a common
version ID.

2.

Select Project > TrackVersions > Assign Common Version ID.
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RESULT
A new ID is assigned to all active TrackVersions on the selected tracks. The tracks are now
marked as belonging together. You can now activate them together.

Active TrackVersion
If you created more than one TrackVersion for a track, you can show the events of a specific
TrackVersion in the event display. This process is referred to as activating TrackVersions.

Activating TrackVersions
PROCEDURE
1.

Click the arrow to the right of the track name to open the TrackVersions pop-up menu.

2.

Select the TrackVersion that you want to activate.

RESULT
The selected version is activated and its events are shown in the event display.
NOTE
If you work with audio tracks, MIDI tracks, instrument tracks, or the chord track, you can also use
the TrackVersions Inspector to activate a TrackVersion.

Activating TrackVersions on Multiple Tracks
You can simultaneously activate TrackVersions on multiple tracks if these TrackVersions share the
same ID.
PROCEDURE
1.

Select all tracks for which you want to activate a specific TrackVersion.

2.

Click the arrow to the right of the track name to open the TrackVersions pop-up menu.

3.

Select the TrackVersion that you want to activate from the list.

RESULT
The selected TrackVersion is activated for all selected tracks, and the corresponding events are
shown in the event display.
NOTE
If you work with audio tracks, MIDI tracks, instrument tracks, or the chord track, you can also use
the TrackVersions Inspector to activate a TrackVersion.
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Duplicating TrackVersions
You can duplicate a TrackVersion by creating a new TrackVersion that contains a copy of the
active TrackVersion.
PROCEDURE
1.

In the track list, select the tracks and activate the TrackVersion that you want to duplicate.

2.

Select Project > TrackVersions > Duplicate Version.
In the event display, a duplicate TrackVersion is displayed. In the track list, a default
version name for the duplicate is shown.
NOTE
You can also use the TrackVersions Inspector for audio tracks, MIDI tracks, instrument
tracks, and chord tracks or the TrackVersions pop-up menu in the track list to duplicate a
TrackVersion.

Deleting TrackVersions
PROCEDURE
1.

Select the tracks and activate the TrackVersions that you want to delete.

2.

Select Project > TrackVersions > Delete Version.
NOTE
You can also use the TrackVersions Inspector for audio tracks, MIDI tracks, instrument
tracks, and chord tracks or the TrackVersions pop-up menu in the track list to delete the
active TrackVersion for selected tracks.

Copying and Pasting Selection Ranges Between TrackVersions
You can copy and paste ranges between different TrackVersions, even across multiple tracks.
PREREQUISITE
You have at least 2 TrackVersions.
PROCEDURE
1.

Select the Range Selection tool.

2.

Select a range of the TrackVersion that you want to copy.

3.

Select Edit > Copy.

4.

Activate the TrackVersion into which you want to insert the copied range.

5.

Select Edit > Paste.

RESULT
The copied range from the first TrackVersion is pasted to the second TrackVersion at the exact
same position.
NOTE
If you want to perform more complicated comping tasks, we recommend to select Project >
TrackVersions > Create Lanes from Versions and proceed with the Comp tool.
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Copying and Pasting Selected Events between TrackVersions
You can copy and paste selected events between different TrackVersions, even across multiple
tracks.
PREREQUISITE
You have at least 2 TrackVersions, and you have split the corresponding events with the Cut tool,
for example.
PROCEDURE
1.

Select the Object Selection tool.

2.

Select the events that you want to copy.

3.

Select Edit > Copy.

4.

Activate the TrackVersion into which you want to insert the copied events.

5.

Select Edit > Functions > Paste at Origin.
This ensures that the events are inserted at the exact same position.

RESULT
The copied events from the first TrackVersion are pasted to the second TrackVersion at the exact
same position.

TrackVersion Names
Each TrackVersion has a default TrackVersion name.
If more than one version is available for the track, the TrackVersion name is shown in the track
list and in the TrackVersions section in the Inspector. By default, TrackVersions are named v1,
v2, etc. However, you can rename each TrackVersion to your liking.

Renaming a TrackVersion
PROCEDURE
●

In the TrackVersions section in the Inspector, double-click the TrackVersion name and
enter a new name.
The name is changed. If the available space in the track list is too small, the name is
abbreviated automatically.
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Renaming TrackVersions on Multiple Tracks
PROCEDURE
1.

Activate all TrackVersions that you want to rename, and select the corresponding tracks.

2.

Select Project > TrackVersions > Rename Version.

3.

Enter a new TrackVersion name and click OK.

RESULT
In the track list, the new TrackVersion name is shown.

NOTE
If you want to assign the same ID to TrackVersions, select Project > TrackVersions > Assign
Common Version ID.

TrackVersions vs. Lanes
TrackVersions and lanes are individual features that complement each other. Every TrackVersion
can have its own set of lanes.

Creating Lanes from TrackVersions
If your project contains TrackVersions and you want to continue working with lanes, using the
Comp tool, for example, you can create lanes from TrackVersions.
PROCEDURE
1.

Select the tracks for which you want to create lanes.

2.

Select Project > TrackVersions > Create Lanes from Versions.
A new TrackVersion named Lanes from Version is added. This TrackVersion contains all
TrackVersions on separate lanes. The original TrackVersions are kept. Lanes that you
create from MIDI TrackVersions are muted.

3.

In the track list or in the Inspector, activate the Show Lanes button for the track.

4.

On the Project window toolbar, activate the Comp tool and continue as usual.
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Creating TrackVersions from Lanes
If your project contains lanes and you want to continue working with the TrackVersion functions,
you can create TrackVersions from lanes.
PROCEDURE
1.

Select the tracks for which you want to create TrackVersions.
If you only want to convert specific lanes, select these lanes.

2.

Select Project > TrackVersions > Create Versions from Lanes.

RESULT
New TrackVersions are added, one for each separate lane. The original lanes are kept. Any
crossfades that you have created between different lanes are discarded.

Track Presets
Track presets are templates that can be applied to newly created or existing tracks of the same
type.
You can create them from virtually all track types (audio, MIDI, instrument, sampler, group, FX,
VST instument return, input, and output channels). They contain sound and channel settings, and
allow you to quickly browse, preview, select, and change sounds, or reuse channel settings
across projects.
Track presets are organized in the MediaBay. There, you can categorize them with attributes.

Audio Track Presets
Track presets for audio tracks, group tracks, FX tracks, VST instrument channels, input channels,
and output channels include all settings that define the sound.
You can use the factory presets as a starting point for your own editing and save the audio
settings that you optimized for an artist that you often work with as a preset for future
recordings.
The following data is saved in audio track presets:
●

Insert effects settings (including VST effect presets)

●

EQ settings

●

Volume and pan

●

Input gain and phase

NOTE
To access the track presets functions for input and output channels, activate the Write buttons
for input and output channels in the MixConsole. This creates input and output channel tracks in
the track list.

Instrument Track Presets
Instrument track presets offer both MIDI and audio features and are the best choice when
handling sounds of simple, mono-timbral VST instruments.
Use instrument track presets for auditioning your tracks or saving your preferred sound settings,
for example. You can also extract sounds from instrument track presets for use in instrument
tracks.
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The following data is saved in instrument track presets:
●

Audio insert effects

●

Audio EQ

●

Audio volume and pan

●

Audio input gain and phase

●

MIDI insert effects

●

MIDI track parameters

●

Input Transformer settings

●

The VST instrument used for the track

●

Staff settings

●

Color settings

●

Drum map settings

MIDI Track Presets
You can use MIDI track presets for multi-timbral VST instruments. You can also use them for
external instruments.
When creating MIDI track presets you can either include the channel or the patch.
●

To ensure that saved MIDI track presets for external instruments will work again with the
same instrument, install the instrument as a MIDI device, see the separate document MIDI
Devices.

The following data is saved in MIDI track presets:
●

MIDI modifiers (Transpose, etc.)

●

MIDI insert effects

●

Output and Channel or Program Change

●

Input Transformer settings

●

Volume and pan

●

Staff settings

●

Color settings

●

Drum map settings

Multi-Track Presets
You can use multi-track presets, for example, when recording setups that require several
microphones (a drum set or a choir, where you always record under the same conditions) and
you have to edit the resulting tracks in a similar way. Furthermore, they can be used when
working with layered tracks, where you use several tracks to generate a certain sound instead of
manipulating only one track.
If you select more than one track when creating a track preset, the settings of all selected tracks
are saved as one multi-track preset. Multi-track presets can only be applied if the target tracks
are of the same type, number, and sequence as the tracks in the track preset, therefore, they
should be used in recurring situations with similar tracks and settings.
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Sampler Track Presets
You can use sampler track presets to re-use created sounds in later projects or newly created
sampler tracks.
The following data is saved in sampler track presets:
●

Audio insert effects

●

Audio EQ

●

Audio volume and pan

●

Audio input gain and phase

●

MIDI insert effects

●

MIDI track parameters

●

Input Transformer settings

●

Color settings

VST Presets
VST instrument presets behave like instrument track presets. You can extract sounds from VST
presets for use in instrument tracks.
The following data is saved in VST instrument presets:
●

VST instrument

●

VST instrument settings

NOTE
Modifiers, inserts, and EQ settings are not saved.
VST effect plug-ins are available in VST 3 and VST 2 format.
NOTE
In this manual, VST presets stands for VST 3 instrument presets, unless stated otherwise.

Pattern Banks
Pattern banks are presets that are created for the Beat Designer MIDI effect.
They behave much like track presets.
RELATED LINKS
Previewing Pattern Banks on page 627
Track Presets on page 188

Creating a Track Preset
You can create a track preset from a single track or from a combination of tracks.
PROCEDURE
1.

In the Project window, select one or more tracks.

2.

In the track list, right-click one of the selected tracks and select Save Track Preset.

3.

In the New Preset section, enter a name for the new preset.
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NOTE
You can also define attributes for the preset.
4.

Click OK to save the preset and exit the dialog.

RESULT
Track presets are saved within the application folder in the Track Presets folder. They are saved in
default subfolders named according to their track type: audio, MIDI, instrument, and multi.
RELATED LINKS
Attribute Inspector on page 632

Creating a Sampler Track Preset
You can create a sampler track preset from a sampler track or you can use the Sampler Control
toolbar.
PROCEDURE
1.

In the Sampler Control toolbar, click Preset Management

.

2.

Click Save Track Preset.

3.

In the Save Track Preset dialog, type in a name for the new preset.

4.

Click OK to save the preset and exit the dialog.

RESULT
The new sampler track preset is saved. It is displayed in the Preset Name field on the info line.
Sampler track presets are saved within the application folder in the sampler track presets folder.
RELATED LINKS
Creating a Track Preset on page 190

Applying Track Presets
When you apply a track preset, all the settings that are saved in the preset are applied.
Track presets can be applied to tracks of their own type only. The only exception are instrument
tracks: for these, VST presets are also available.
NOTE
●

Once a track preset is applied, you cannot undo the changes. It is not possible to remove
an applied preset from a track and return to the previous state. If you are not satisfied with
the track settings, you have to either edit the settings manually or apply another preset.

●

Applying VST presets to instrument tracks leads to removal of modifiers, MIDI inserts,
inserts, or EQs. These settings are not stored in VST presets.

Loading Track, VST, or Sampler Track Presets
PROCEDURE
1.

In the Project window, select a track.

2.

Do one of the following:
●

In the Inspector, click Load Track Preset.

●

In the track list, right-click the track and select Load Track Preset.
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●

In the Sampler Control toolbar, click the preset management button next to the
preset name field and select Load Track Preset.

3.

In the preset browser, select a track, VST, or sampler track preset.

4.

Double-click the preset to load it.

RESULT
The preset is applied.
NOTE
You can also drag and drop track presets from the MediaBay, the File Explorer/macOS Finder
onto a track of the same type.

RELATED LINKS
Filters Section on page 628

Loading Multi-Track Presets
PROCEDURE
1.

In the Project window, select several tracks.
NOTE
Multi-track presets can only be applied if track type, number, and sequence are identical
for the selected tracks and the track preset.

2.

In the track list, right-click the track and select Load Track Preset.

3.

In the preset browser, select a multi-track preset.

4.

Double-click the preset to load it.

RESULT
The preset is applied.

Loading Inserts and EQ from Track Presets
Instead of loading complete track presets, you can also apply insert or equalizer settings from
track presets.
PROCEDURE
1.

Select a track, open the Inspector or the Channel Settings window, and click the VST
Sound button on the Inserts or Equalizers section.

2.

Select From Track Preset.

3.

In the preset browser, select a track preset.

4.

Double-click the preset to load the settings.

Extracting the Sound from an Instrument Track or VST Preset
For instrument tracks, you can extract the sound of an instrument track preset or VST preset.
PROCEDURE
1.

Select the instrument track to which you want to apply a sound.

2.

In the Inspector, click VST Sound.
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3.

In the preset browser, select an instrument track preset or VST preset.

4.

Double-click the preset to load the settings.

RESULT
The VST instrument and its settings (but no inserts, EQs, or modifiers) on the existing track are
overwritten with the data of the track preset. The previous VST instrument for this instrument
track is removed and the new VST instrument with its settings is set up for the instrument track.

Track Quick Control Presets
For audio, instrument, MIDI, FX, and group tracks, you can save and load your own Quick Control
assignments as presets or use the factory presets.

Saving/Loading Track Quick Control Assignments as Presets
PROCEDURE
1.

In the Inspector for your track, open the Quick Controls section.
For instrument tracks, the track quick controls are set to the 8 default VST quick controls of
the loaded instrument by default.

2.

Click Preset Management in the top right corner of the Quick Controls section and select
one of the presets.

The Track Quick Control assignment changes and gives you access to the channel
parameters.
NOTE
You can also make your own assignments and save them as presets and delete, rename,
or reset the presets to the default assignments.
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Parts and events are the basic building blocks in Nuendo.

Events
In Nuendo, most event types can be viewed and edited on their specific tracks in the Project
window.
Events can be added by importing or recording.
RELATED LINKS
Audio Events on page 194
MIDI Events on page 197

Audio Events
Audio events are created automatically when you record or import audio in the Project window.
You can view and edit audio events in the Project window and in the Sample Editor.
An audio event triggers the playback of the corresponding audio clip. By adjusting the Offset
and the Length values of the event, you can determine which section of the audio clip is played
back. The audio clip itself remains unchanged.
RELATED LINKS
Project Window on page 39
Sample Editor on page 503
Audio Files and Audio Clips on page 195
Basic Recording Methods on page 259

Creating Audio Events
PROCEDURE
●

Do one of the following:
●

Record some audio.

●

Select File > Import > Audio File to import an audio file from your hard disk or any
external storage device.

●

Select File > Import > Audio CD to import an audio file from an audio CD.

●

Select File > Import > Audio from Video File to import the audio from a video file
on your hard disk or any external storage device.

●

Drag an audio file from the MediaBay, the Audio Part Editor, the Sample Editor or
the Find Media window, and drop it in the event display.

●

Copy an event from a different Nuendo project and paste it in the event display.
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RELATED LINKS
Basic Recording Methods on page 259
Importing Audio Files on page 277
Importing Audio CD Tracks on page 280
Importing Audio from Video Files on page 282
MediaBay on page 607
Audio Part Editor on page 562
Sample Editor on page 503
Find Media Window on page 597

Creating New Files From Events
An audio event plays a section of an audio clip, which in turn refers to one or more audio files on
the hard disk. However, you can create a new file that consists only of the section that is played
by the event.
PROCEDURE
1.

Select one or several audio events.

2.

Set up fade in, fade out, and event volume.
These settings will be applied to the new file.

3.

Select Audio > Bounce Selection.
You are asked whether you want to replace the selected event or not.

4.

Do one of the following:
●

To create a new file that only contains the audio in the original event, click Replace.

●

To create a new file and add a clip for the new file to the Pool, click No.

RESULT
If you clicked Replace, a clip for the new file is added to the Pool, and the original event is
replaced by a new event playing the new clip.
If you clicked No, the original event is not replaced.
NOTE
You can also apply the Bounce Selection function to audio parts. In that case, the audio from all
events in the part is combined to a single audio file. If you select Replace when asked, the part is
replaced with a single audio event playing a clip of the new file.

RELATED LINKS
Event-Based Fades on page 301

Audio Files and Audio Clips
In Nuendo, audio editing and processing are non-destructive.
When you edit or process audio in the Project window, the audio file on the hard disk remains
untouched. Instead, your changes are saved to an audio clip that is automatically created on
import or during recording, and that refers to the audio file. This allows you to undo changes or
revert to the original version.
If you apply processing to a specific section of an audio clip, a new audio file that contains only
this section is created. The processing is applied to the new audio file only and the audio clip is
automatically adjusted, so that it refers both to the original file and to the new, processed file.
During playback, the program will switch between the original file and the processed file at the
correct positions. You will hear this as a single recording, with processing applied to one section
only.
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This allows you to undo processing at a later stage, and to apply different processing to different
audio clips that refer to the same original file.
You can view and edit audio clips in the Pool.
RELATED LINKS
Pool on page 586
Audio Regions on page 197
Replacing Clips in Events on page 196

Clip Packages
Clip packages are sound combinations that you create by arranging, editing, and grouping
several audio events or parts in the Project window and saving them as clip packages.
Clip packages are shown in the Pool and in the MediaBay from where you can import them into
several projects.
Clip packages are container files that include all the selected audio material as opposed to mere
file references. This is useful for layered sounds such as explosions, background atmospheres, or
effect sounds.
●

Clip packages contain copies of the audio files. Any offline processes you applied to the
audio are saved in the file and cannot be modified or undone later.

●

Clip packages contain volume and pan automation of the audio, as well as any fades,
crossfades and volume envelopes. Insert or send effects or EQ settings of the
corresponding tracks are not included.

●

Clip packages contain only the portion of an audio clip that is actually used by an event.
This section is extended by 2 seconds at the beginning and the end of the event so that
you are still able to adjust the event borders.
NOTE
●

Audio clips set to musical time base are copied in entirety into the clip package.

●

If a clip package contains audio material from VST Sound archives, this is not copied
into the clip package. In this case, a reference to the original VST Sound archive is
saved. If you want to use these clip packages in another project, you must copy the
referred VST Sound files.

RELATED LINKS
Importing Clip Packages on page 283
Exporting Audio Parts and Events as Clip Packages on page 223
Defining the Track Time Base on page 180
Pool Window on page 586

Replacing Clips in Events
You can replace the clips in audio events.
PROCEDURE
●

Do one of the following:
●

Hold down Shift, drag an audio file from the File Explorer/macOS Finder, and drop it
on the event.

●

Click a clip in the Pool, hold down Shift, and drop it on the event.
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RESULT
The clip in the event is replaced. However, the event edits remain unchanged. If the new clip is
shorter than the replaced clip, the length of the event is adapted. If the new clip is longer than
the replaced clip, the length of the event stays the same.
RELATED LINKS
Inserting Clips into a Project Via Drag and Drop on page 593

Audio Regions
Nuendo allows you to create audio regions within audio clips to mark important sections in the
audio.
You can view audio regions in the Pool. You can create and edit them in the Sample Editor.
NOTE
If you want to use one audio file in different contexts, or if you want to create several loops from
one audio file, convert the corresponding regions of the audio clip to events and bounce them
into separate audio files. This is necessary since different events that refer to the same clip
access the same clip information.

RELATED LINKS
Pool on page 586
Audio Regions on page 197
Regions List on page 519

Region Operations
Regions are sections within a clip.
Regions are best created and edited in the Sample Editor. However, to access the following
options, select Audio > Advanced.
Event or Range as Region
This function is available when one or several audio events or selection ranges are
selected. It creates a region in the corresponding clip, with the start and end position
of the region determined by the start and end position of the event or selection
range within the clip.
Events from Regions
This function is available if you have selected an audio event whose clip contains
regions within the boundaries of the event. The function will remove the original
event and replace it with events positioned and sized according to the regions.
RELATED LINKS
Creating Audio Events from Regions on page 521

MIDI Events
MIDI events are created automatically when you record or import MIDI in the Project window.
The In-Place Editor allows you to view and edit MIDI events in the Project window. You can also
view and edit MIDI events in the Key Editor, the Drum Editor, List Editor, or the Score Editor.
RELATED LINKS
Project Window on page 39
In-Place Editor on page 868
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Key Editor on page 804
Drum Editor on page 833
Basic Recording Methods on page 259

Creating MIDI Events
PROCEDURE
●

Do one of the following:
●

Record MIDI.

●

Select File > Import > MIDI File to import a MIDI file from your hard disk.

●

Drag a MIDI file from the File Explorer/macOS Finder, from one of the MIDI editors,
or from the MediaBay, and drop it in the event display.

●

Copy an event from a different Nuendo project and paste it in the event display.

RELATED LINKS
Basic Recording Methods on page 259
Importing MIDI Files on page 285
MIDI Editors on page 797
MediaBay on page 607

Parts
Parts are containers for MIDI or audio events, and for tracks.
RELATED LINKS
Audio Parts on page 198
MIDI Parts on page 199
Folder Parts on page 199

Audio Parts
Audio parts are containers for audio events. If you want to treat several audio events as one unit
in the Project window, you can convert them to a part.
You can create audio parts in the following ways:
●

Select the Draw tool and draw on the audio track.

●

Press Alt, select the Object Selection tool, and draw on the audio track.

●

Select the Object Selection tool and double-click on the audio track, between the left and
right locator.

●

Select several audio events on an audio track and select Audio > Events to Part.

NOTE
To make the events appear as independent objects on the track again, select the part and select
Audio > Dissolve Part.

RELATED LINKS
Audio Part Editor on page 562
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MIDI Parts
A MIDI part is automatically created when you record. It contains the recorded events.
However, you can also create empty MIDI parts in the following ways:
●

Select the Draw tool and draw on the MIDI track.

●

Press Alt, select the Object Selection tool and draw on the MIDI track.

●

Select the Object Selection tool, and double-click on the MIDI track, between the left and
right locator.

Folder Parts
A folder part is a graphic representation of events and parts on the tracks in the folder.
Folder parts indicate the time position as well as the vertical track position. If part colors are
used, these are also shown in the folder part.
Any editing that you perform to a folder part affects all the events and parts it contains. Tracks
inside a folder can be edited as one entity.
NOTE
If you want to edit the individual tracks within the folder, you can double-click the folder part.
This opens the editors for the events and parts that are present on the tracks.

RELATED LINKS
Coloring Notes and Events on page 798
Group Editing Mode on page 216

Editing Techniques for Parts and Events
This section describes techniques for editing in the Project window. If not explicitly stated, all
descriptions apply to both events and parts, even though we use the term event for convenience.
In the Project window, you can edit events using the following techniques:
●

By selecting and using one of the tools in the Project window toolbar.
NOTE
Some editing tools feature additional functions if you press modifier keys. You can
customize the default modifier keys in the Preferences dialog (Editing—Tool Modifiers
page).

●

By opening the Edit menu and selecting one of the functions.

●

By editing in the info line.

●

By using a key command.

NOTE
Snap is taken into account.

RELATED LINKS
Editing - Tool Modifiers on page 1189

199

Parts and Events
Editing Techniques for Parts and Events

Auditioning Audio Parts and Events
You can audition audio parts and events in the Project window by using the Play tool.
PROCEDURE
1.

Click Play .

2.

Click where you want playback to start, and keep the mouse button pressed.

RESULT
The track on which you click is played back, starting at the click position. Playback is stopped
when you release the mouse button.
NOTE
When auditioning, audio will be routed directly to the Control Room if the Control Room is
activated. If the Control Room is deactivated, the audio is routed to the default output bus,
bypassing the audio channel’s settings, effects and EQs.

Scrubbing
The Scrub tool allows you to locate positions in events by playing back, forwards or backwards.
PROCEDURE
1.

Click Play .

2.

Click Play again to open a pop-up menu.

3.

Select Scrub

4.

Click the event and keep the mouse button pressed.

5.

Drag to the left or right.

.

RESULT
The project cursor moves correspondingly and the event is played back. The speed and the pitch
of the playback depend on how fast you move the mouse.
NOTE
Insert effects are bypassed when scrubbing with the mouse.

Scrub Tool
Scrubbing can be quite a burden on your system. If playback problems occur, open the
Preferences dialog (Transport—Scrub page), and deactivate Use High Quality Scrub Mode.
This lowers the resampling quality, but makes scrubbing less demanding on the processor,
especially in large projects.
In the Preferences dialog (Transport—Scrub page), you can also adjust the Scrub volume.

Selecting with the Object Selection Tool
PROCEDURE
1.

Click Object Selection

2.

In the event display, click the events that you want to select.

.
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NOTE
You can also use the Up Arrow, Down Arrow, Left Arrow, Right Arrow keys on the
computer keyboard to select the event on the upper or lower track or the previous or next
event on the same track.

Select Submenu
If the Object Selection tool is selected, the Select submenu features specific options for
selecting events in the Project window.
●

To open the Select submenu, select Edit > Select.

All
Selects all events in the Project window.
None
Deselects all events.
Invert
Inverts the selection. All selected events are deselected and all events that were not
selected are selected instead.
In Loop
Selects all events that are partly or wholly between the left and right locator.
From Start to Cursor
Selects all events that begin to the left of the project cursor.
From Cursor to End
Selects all events that end to the right of the project cursor.
Equal Pitch all Octaves/same Octave
These functions are available in the MIDI editors and the Sample Editor.
Select Controllers in Note Range
This function is available in the MIDI editors.
All on Selected Tracks
Selects all events on the selected track.
Events under Cursor
Automatically selects all events on the selected tracks that are touched by the project
cursor.
Select Event
This function is available in the Sample Editor.
Left/Right Selection Side to Cursor
These functions are only used for range selection editing.
NOTE
When the Range Selection tool is selected, the Select submenu features different functions.

RELATED LINKS
Selection Range Options on page 225
Range Editing on page 515
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Removing Events
PROCEDURE
●

To remove an event from the Project window, do one of the following:
●

Select Erase

and click the event.

●

Select the events and select Edit > Delete.

●

Select the events and press Backspace.

Move Events
You can move events using any of the following methods:
●

Use the Object Selection tool.

●

Use Nudge tool.

●

Select Edit > Move to and select one of the options.

●

Select the event and edit the start position on the info line.

RELATED LINKS
Moving with the Object Selection Tool on page 202
Moving with the Nudge Buttons on page 202
Move to Submenu on page 203
Moving via the Info Line on page 203

Moving with the Object Selection Tool
PROCEDURE
1.

Select Object Selection

.

2.

Click the events that you want to move and drag them to a new position.
NOTE
You can only drag events to tracks of the same type. If you hold down Ctrl/Cmd while
dragging, you can restrict the movement either horizontally or vertically.

RESULT
The events are moved. If you moved several events, their relative positions are kept.
NOTE
To avoid accidentally moving events when you click them in the Project window, the response
when you move an event by dragging is slightly delayed. You can adjust this delay with the Drag
Delay setting in the Preferences dialog (Editing page).

Moving with the Nudge Buttons
PROCEDURE
1.

Right-click the Project window toolbar and activate Nudge Palette.
The nudge buttons become available on the toolbar.

2.

Select the events that you want to move, and click Move Left
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The selected events or parts are moved.

Move to Submenu
If the Object Selection tool is selected, the Move to submenu features options for moving
events to specific positions in the Project window.
●

To open the Move to submenu, select Edit > Move to.

The following options are available:
Cursor
Moves the selected event to the project cursor position. If you selected several
events on the same track, the following events keep their relative position.
Origin
Moves the selected events to the positions at which they were originally recorded.
Front/Back
Moves the selected events to the front or back, respectively. This is useful if you have
overlapping audio events and you want to play back an other event.

Moving via the Info Line
PROCEDURE
1.

Select the event that you want to move.

2.

On the info line, double-click the Start field and enter a new value for the event start.

RESULT
The event is moved by the set value.

Modifiers for Aligning to Parts, Events, and Selection Ranges
For aligning audio events or parts to events, parts or ranges, the following modifiers are
available:

Use Ctrl/Cmd to align the start of the audio event/part to the start of the selected
event, part or range.
This function is available when you move the mouse to the beginning of the nonselected event.

Use Ctrl/Cmd-Alt to copy the audio event/part and align its start to the start of the
selected event, part or range.
This function is available when you move the mouse to the beginning of the nonselected event.

Use Ctrl/Cmd to align the end of the audio event/part to the start of the selected
event, part or range.
This function is available when you move the mouse to the end of the non-selected
event.
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Use Ctrl/Cmd-Alt to copy the audio event/part and align its end to the start of the
selected event, part or range.
This function is available when you move the mouse to the end of the non-selected
event.

Use Ctrl/Cmd-Shift to align the start of the audio event/part to the end of the
selected event, part or range.
This function is available when you move the mouse to the beginning of the nonselected event.

Use Ctrl/Cmd-Shift-Alt to copy the audio event/part and align its start to the end of
the selected event, part or range.
This function is available when you move the mouse to the beginning of the nonselected event.

Use Ctrl/Cmd-Shift to align the end of the audio event/part to the end of the
selected event, part or range.
This function is available when you move the mouse to the end of the non-selected
event.

Use Ctrl/Cmd-Shift-Alt to copy the audio event/part and align its end to the end of
the selected event, part or range.
This function is available when you move the mouse to the end of the non-selected
event.
For aligning audio events or parts to the cursor, the following modifiers are available:

Use Ctrl/Cmd to align the start of the audio event/part to the cursor.
This function is available when you move the mouse to the beginning of the nonselected event.

Use Ctrl/Cmd-Alt to copy the audio event/part and align its start to the cursor.
This function is available when you move the mouse to the beginning of the nonselected event.

Use Ctrl/Cmd to align the end of the audio event/part to the cursor.
This function is available when you move the mouse to the end of the non-selected
event.

Use Ctrl/Cmd-Alt to copy the audio event/part and align its end to the cursor.
This function is available when you move the mouse to the end of the non-selected
event.
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NOTE
You can change the modifiers in the Preferences dialog (Editing–Tool Modifiers page).

Aligning Audio Events or Parts to other Audio Events or Parts
PROCEDURE
1.

Select an event or part that you want to take as a reference for aligning.

2.

Point on the audio event or part you want to move, press one of the modifiers and click.

RESULT
The mouse pointer changes its shape and the audio event or part is aligned with the selected
part or event.
NOTE
If the snap point is set, it is used as a reference when you align events.

RELATED LINKS
Modifiers for Aligning to Parts, Events, and Selection Ranges on page 203
Audio Alignment on page 539

Aligning Audio Events or Parts to Selection Ranges
PROCEDURE
1.

Make a selection range on any track.
The selection is taken as a reference for aligning.

2.

Point on an audio event or part, press one of the modifiers and click.
The mouse pointer changes its shape and the audio event or part is aligned with the
selection range.
NOTE
If the snap point is set, it is used as a reference when you align events.

RELATED LINKS
Modifiers for Aligning to Parts, Events, and Selection Ranges on page 203

Aligning Audio Events or Parts to the Cursor
PROCEDURE
1.

Set the cursor to the position where you want to move the audio part or event.
This will be taken as a reference for aligning.

2.

Deselect everything in your project.

3.

Select the Object Selection tool and point on an audio event or part, press one of the
modifiers and click.
The mouse pointer changes its shape and the audio event or part is aligned with the
cursor.
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NOTE
If the snap point is set, it is used as a reference when you align events.

RELATED LINKS
Modifiers for Aligning to Parts, Events, and Selection Ranges on page 203

Renaming Events
PROCEDURE
●

Do one of the following:
●

Select the events, select Edit > Rename Objects, and select one of the renaming
options.

●

Select the events and type in a new name in the File field on the info line.

●

Change the track name, hold down a modifier key, and press Return to rename all
events after the track.

●

Use the Rename Events from List dialog to rename parts and events that are
selected in the Project window.

RELATED LINKS
Renaming Clips or Regions in the Pool on page 591
Renaming Events from List on page 206

Renaming Events from List
You can rename audio events, audio parts, and MIDI parts that you recorded in Nuendo so that
they match the names of a list, created with an external text editor. This way, you can also
rename markers.
PREREQUISITE
You have a list in .csv or .txt file format, for example, a script list that allows you to match the
dialog with the recorded events or parts. You have recorded audio events or MIDI parts and
arranged them so that they match the order of the script list.
PROCEDURE
1.

In the Project window, select the events or parts that you want to rename.

2.

Select Edit > Rename Events from List.
The Rename Events from List dialog opens, and the names of the selected events or
parts are listed in the left column.

3.

Click Load List, and in the file dialog, navigate to the script list, select it, and click Open.
NOTE
Alternatively, you can copy content from a text editor and paste it in the Rename Events
from List dialog.
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4.

Locate the column that shows the file names that you want to use, and click the column
header.
The column header is highlighted.

5.

Optional: Modify, rearrange, or add list content.

6.

Optional: In the Rename Events from List dialog, click Locate Event to the left of an
event, and on the Transport panel, click Start.
This plays back the event and allows you to verify if it matches the name in the script list.

7.

Click Rename.

RESULT
The recorded audio events are renamed according to the imported script list.
AFTER COMPLETING THIS TASK
Export the audio events and select a naming scheme that uses the event names. Apply offline
processing to the exported events, if required.
RELATED LINKS
Rename Events from List Dialog on page 208
Export Audio Assets to a Game Audio Engine on page 501
Direct Offline Processing on page 467
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Rename Events from List Dialog
The Rename Events from List dialog allows you to rename events and parts that are selected in
the Project window.

1

Track

2

Load List

Displays the name of the track of the selected events/parts.
Allows you to load a .csv or a .txt file that contains a dialog list.
3

Clear List
Removes the loaded list.

4

Selection Mode
Allows you to select list entries for editing.

5

●

Press Delete to delete entries.

●

Double-click an entry to change its text.

Mapping Mode
Allows you to slide the list content up or down in relation to the list of the selected events/
parts in the project. This changes the mapping.

6

Locate Event
Moves the project cursor to the start of the event/part in the Project window.
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7

Selected Event
Displays the names of the events/parts that you selected in the Project window.

8

List Content
Shows the content of the imported file.

9

●

Drag to rearrange the order of the columns.

●

Right-click a column header and deactivate the corresponding column in the pop-up
menu to hide columns.

●

Double-click to modify the list content.

●

Copy content from a text editor, for example, Microsoft Excel or Apache OpenOffice,
to add list content.

Open Rename Settings
Opens the rename settings.

10

Rename
Applies the names of the list to the selected events/parts.

RELATED LINKS
Rename Settings on page 209

Rename Settings
Allows you to set how selected events/parts should be renamed.

●

Ignore File Extension
Activate this if you do not want the file extension to be shown.

●

Interprete First Row as Header
Activate this if you want the first row of the loaded script list to be interpreted as a header.

●

Ignore Snippets Shorter Than
Activate this to specify a minimum length that the events/parts must have to be shown in
the list.

●

Handle Adjacent or Overlapping Events as One
Activate this if adjacent or overlapping events should be considered as one event and thus
receive the same name.

Resize Events
You can resize events by moving their start or end positions individually.
To resize events, you can use the Object Selection, the Trim, or the Scrub tools.
IMPORTANT
When resizing events, automation data is not taken into account.
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RELATED LINKS
Resizing Events with the Object Selection Tool - Normal Sizing on page 210
Resizing Events with the Object Selection Tool - Sizing Moves Contents on page 210
Resizing Events with the Object Selection Tool - Sizing Applies Time Stretch on page 210
Resizing Events with the Trim Tool on page 211
Resizing Events with the Scrub Tool on page 211
Snap Function on page 79

Resizing Events with the Object Selection Tool - Normal Sizing
You can move the start or end point of the event without changing the content of the event.
PROCEDURE
1.

Select Object Selection

.

2.

Click the Object Selection tool again, and select Normal Sizing from the pop-up menu.

3.

Click and drag the lower left or right corner of the event.

RESULT
The event is resized and according to where you dragged, more or less of the content is revealed.
If several events are selected, they are all resized in the same way.

Resizing Events with the Object Selection Tool - Sizing Moves Contents
You can move the start or end point of the event and move the content.
PROCEDURE
1.

Select Object Selection

.

2.

Click the Object Selection tool again, and select Sizing Moves Contents from the pop-up
menu.

3.

Click and drag the lower left or right corner of the event.

RESULT
The event is resized and the content follows. If several events are selected, they are all resized in
the same way.

Resizing Events with the Object Selection Tool - Sizing Applies Time Stretch
You can move the start or end point of the event and time stretch the content to fit the new
event length.
PROCEDURE
1.

Select Object Selection

.

2.

Click the Object Selection tool again, and select Sizing Applies Time Stretch from the
pop-up menu.
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3.

Click and drag the lower left or right corner of the event.

RESULT
The part is stretched or compressed to fit the new length.
●

If you resize MIDI parts, the note events are stretched (moved and resized).

●

If you resize audio parts, the events are moved, and the referenced audio files are time
stretched to fit the new length.

Controller data and Note Expression data are stretched, too.

If several events are selected, they are all resized in the same way.
RELATED LINKS
Time Stretch on page 485

Resizing Events with the Trim Tool
You can move the start or end point of the event by the amount set on the Grid Type pop-up
menu.
PREREQUISITE
The Object Selection tool is set to Normal Sizing or to Sizing Moves Contents.
PROCEDURE
1.

Right-click the Project window toolbar and activate Nudge Palette.
The nudge buttons become available on the toolbar.

2.

Select the event.

3.

Do one of the following:
●

Click Trim Start Left

.

●

Click Trim Start Right

●

Click Trim End Left

●

Click Trim End Right

.

.
.

RESULT
The start or end position of the selected events are moved by the amount set on the Grid Type
pop-up menu.

Resizing Events with the Scrub Tool
You can scrub the event when moving the start or end point of the event.
PROCEDURE
1.

Click Play .

2.

Click Play again to open a pop-up menu.

3.

Select Scrub

4.

Click and drag the lower left or right corner of the event.

.

RESULT
The event is resized and you get an acoustic feedback while dragging.
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Splitting Events
PROCEDURE
●

Do one of the following:
●

Select Split

and click the event that you want to split.

●

Select Object Selection

●

Move the project cursor to the position where you want to split the events, and
select Edit > Functions > Split at Cursor.

, hold down Alt and click the event.

NOTE
This splits the selected events at the position of the project cursor. If no events are
selected, all events on all tracks that are intersected by the project cursor are split.
●

Set up the left and right locators at the position where you want to split the events,
and select Edit > Functions > Split Loop.
NOTE
This splits the selected events at the left and right locator positions. If no events are
selected, all events on all tracks that are intersected by the locators are split.

RESULT
The events are split.
NOTE
If you split a MIDI part so that the split position intersects one or several MIDI notes and Split
MIDI Events is activated in the Preferences dialog (Editing—MIDI page), the intersected notes
are split and new notes are created at the beginning of the second part. If it is deactivated, the
notes remain in the first part, but stick out after the end of the part.

RELATED LINKS
Splitting Events Repeatedly on page 212

Splitting Events Repeatedly
You can split events repeatedly into multiple equal-sized events.
PROCEDURE
●

Select Split

, hold down Alt and click the event where you want to split it first.

RESULT
The event is automatically split into as many equal events as the length of the original event
allows.

Using Cut Head and Cut Tail
You can cut everything to the left or right of the cursor or a selected range.
PROCEDURE
●

Do one of the following:
●

Select Edit > Range > Cut Head to delete everything to the left of the cursor/
selection range.
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●

Select Edit > Range > Cut Tail to delete everything to the right of the cursor/
selection range.

Gluing Events
In the Project window, you can glue two or more events that are situated on the same track.
PROCEDURE
●

Do one of the following:
●

Select Glue

●

Select Glue , hold down Alt, and click the event that you want to glue to all
following events.

and click the event that you want to glue to the next event.

RESULT
The events are glued together.
NOTE
If you first split an audio event and then glue the parts together again, an event is created, in any
other case, a part is created.

Pasting Events
You can paste events from the clipboard.
PROCEDURE
●

Do one of the following:
●

Select the events and select Edit > Functions > Paste at Origin to paste the event at
the same position from which you cut or copied it.

●

Select the events, select the track where you want to paste them, and select Edit >
Functions > Paste Relative to Cursor to paste the event while keeping its relative
position to the project cursor.

RESULT
If you paste an audio event, it is inserted on the selected track, positioned so that its snap point is
aligned with the cursor position.
If the selected track is of the wrong type, the event is inserted on its original track.

Pasting Events To Matching Track Names
You can copy events in one project and paste them at the first track that matches the exact track
name in another project.
PROCEDURE
1.

Copy the events in one project.

2.

Activate the project where you want to paste the events.

3.

Select Edit > Functions > Paste to Matching Track Name.

RESULT
The events are inserted on the track with the name that exactly matches the original track name.
For all events that have no matching track name, new tracks are created.
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Duplicating Events
In the Project window, you can duplicate selected events.
PROCEDURE
●

Select the event and do one of the following:
●

Select Edit > Functions > Duplicate.

●

Hold down Alt and drag the event to a new position.
NOTE
If you hold down Ctrl/Cmd as well, movement direction is restricted to either
horizontal or vertical.

RESULT
A copy of the selected event is created and placed after the original. If several events are
selected, all of these are copied as one unit, maintaining the relative distance between the
events.
NOTE
If you duplicate audio events, the copies always refer to the same audio clip.

Repeating Events
PROCEDURE
●

Do one of the following:
●

Select the events and select Edit > Functions > Repeat to open the Repeat Events
dialog, that allows you to create a number of real or shared copies of the selected
events.

●

Select the events, hold down Alt, click the handle in the lower right corner of the last
selected event, and drag to the right to create a real copy.

●

Move the mouse pointer over the middle of the right event border so that it
becomes a pointing hand symbol, click and drag to the right to create a real copy.

●

Select the events, hold down Alt-Shift, and drag to the right to create a shared copy.

●

Move the mouse pointer over the middle of the right event border so that it
becomes a pointing hand symbol, hold down Shift, click and drag to the right to
create a shared copy.

NOTE
Repeating by dragging only works if the track has a height of at least 2 rows.

Repeat Events Dialog
The Repeat Events dialog allows you to create a number of real or shared copies of the selected
events.
●

To open the Repeat Events dialog, select Edit > Functions > Repeat.
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Count
Allows you to specify how many times you want the event to be repeated.
Shared Copies
Activate this to create a shared copy.
RELATED LINKS
Shared Copies on page 215

Shared Copies
Shared copies are useful if you want to create copies that are automatically edited in the same
way as the original event.
You can convert a shared copy to a real copy by selecting Edit > Functions > Convert to Real
Copy. This creates a new version of the clip that you can edit independently. The new clip is
automatically added to the Pool.
RELATED LINKS
Repeating Events on page 214
Repeat Events Dialog on page 214

Fill Loop
You can create a number of copies between the right and left locators.
●

Select Edit > Functions > Fill Loop to create a number of copies starting at the left locator
and ending at the right locator.
The last copy is automatically shortened to end at the right locator position.

Sliding the Contents of Events
You can move the contents of an event without changing its position in the Project window.
PROCEDURE
●

Hold down Alt-Shift, click the event, and drag to the left or right.

RESULT
The content of the event is moved.
NOTE
You cannot slide an audio event past the start or end of the actual audio clip. If the event plays
the whole clip, you cannot slide the audio at all.
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Grouping Events
You can treat several events on the same or different tracks as one unit by grouping them.
PROCEDURE
●

Select the events and select Edit > Group.

RESULT
The events are grouped. This is indicated by an icon.

Grouped Events
If you edit one of the grouped events in the Project window, all other events in the same group
are affected too.
Group editing operations include:
●

Selecting events.

●

Moving and duplicating events.

●

Resizing events.

●

Adjusting fade-in and fade-out (audio events only).

●

Splitting events.

●

Locking events.

●

Muting events.

●

Deleting events.

RELATED LINKS
Fades, Crossfades, and Envelopes on page 301

Group Editing Mode
The Group Editing mode for folder tracks allows you to edit parts and events in a folder as a
group.
If Group Editing
is activated and you select an event, a part or a range on a track inside the
folder track, other events, parts, or ranges that have the same start and end time and the same
playback priority, are also selected and temporarily grouped. This allows you to edit together
different drum tracks for bass drum, snare, toms, for example.
Temporarily means that on every new selection with the Object Selection or the Range
Selection tool, Nuendo looks for corresponding events or parts inside the folder and groups
them. If you edit the start or end point of a single event or part before activating the Group
Editing mode, the event or part is excluded from the group.
Edit actions in Group Editing mode affect all grouped events, parts, or ranges. If you select
another take by using the small To Front arrow at the right side of one event of an edit group,
for example, all other tracks inside the edit group also switch to the corresponding take. This is
useful for comparing takes of a multi-track recording.
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NOTE
Group Editing overwrites any regular group settings in the edit group.

RELATED LINKS
Muting Events on page 218
Organizing Tracks in Folder Tracks on page 174

Group Editing
You can group events and parts on multiple tracks that have the same start and end time and the
same playback priority to edit them together.
PREREQUISITE
PROCEDURE
1.

Select Project > Add Track > Folder to add a folder track.

2.

Move the tracks that contain the events that you want to edit as a group into the folder
track.

3.

In the track list for the folder track, click Group Editing

.

RESULT
All events, parts, or ranges inside the folder that have the same start and end time and the same
playback priority are temporarily grouped.

Locking Events
If you want to make sure that you do not edit or move an event by accident, you can lock it.
PROCEDURE
●

Do one of the following:
●

Select the events and select Edit > Lock to lock the selected events.

●

Click the padlock symbol in the track list or in the Inspector to lock all events on a
track.

RESULT
The events are locked. This is indicated by a padlock symbol.

To unlock an event, select the event and select Edit > Unlock.
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Lock Event Attributes
The Lock Event Attributes dialog allows you to lock specific event attributes.
●

To open the Lock Event Attributes dialog, select a locked event and select Edit > Lock.

●

Position Locked
Activate this to prevent the event from being moved.

●

Size Locked
Activate this to prevent the event from being resized.

●

Others Locked
Activate this to prevent the event from being edited. This includes adjusting the fades and
event volume, processing, etc.

NOTE
You can also set these attributes in the Preferences dialog (Editing page).

RELATED LINKS
Lock Event Attributes on page 1183

Muting Events
You can mute events in the Project window. Muted events can be edited as usual (with the
exception of adjusting fades), but are not played back.
PROCEDURE
●

Do one of the following:
●

Select Mute

and click the events or drag a selection rectangle around them.

●

Select the events and select Edit > Mute.

RESULT
The events are muted and grayed out.

You can unmute events by selecting them and selecting Edit > Unmute. You can change the
mute status of selected events by Shift-clicking them.

Exporting Selected Events
You can render selections or range selections of audio events and/or MIDI parts and export the
rendered material as .wav files.
PROCEDURE
1.

Select one or more audio events and/or MIDI parts or make a range selection.

2.

Select File > Export > Selected Events.
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3.

In the Export Selected Events dialog, specify the render options.

4.

Click Export.

RESULT
All selected source material is processed according to your render settings. Your render options
are saved and used for all further render operations.

Export Selected Events
You can render selections or range selections of audio events and/or MIDI parts and export the
rendered material as .wav files.

The following settings are available:
As Separate Events
One or more tracks are created. These contain separate events or parts that are
saved as separate audio files.
As Block Events
One or more tracks are created. These contain adjacent events/parts that are
combined to blocks. Every block is saved as a separate audio file.
As One Event
One or more tracks are created. These contain the events/parts that are combined to
one event/part. Every combination is saved as a separate audio file.
Dry
If this option is activated, all effects and panner settings are copied to new audio
tracks. The resulting audio tracks keep the formats of their source tracks. A mono
track results in a mono track, for example.
Channel Settings
If this option is activated, all effects are rendered into the resulting audio files. This
includes insert effects, channel strip settings, group channel settings, and FX send
channel settings. Panner settings are transferred to the new audio tracks. The
resulting audio tracks keep the formats of their source tracks. A mono track results in
a mono track, for example.
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Complete Signal Path
If this option is activated, the complete signal path is rendered into the new audio
files, including all channel settings, group channel settings, FX send channel settings,
and panner settings. The new audio track is created without effects. Stereo balance
panner settings are activated. The resulting audio file format is determined by the
output channel of the source track. A mono track that is routed to a stereo bus
results in a stereo audio file.
Complete Signal Path + Master FX
If this option is activated, the complete signal path and the master bus settings are
rendered into the resulting audio files. This includes all channel settings, group
channel settings, FX send channel settings, and panner settings. The resulting audio
file format is determined by the output channel of the source track. A mono track
that is routed to a stereo bus results in a stereo audio file.
Mix Down to One Track
By default, rendering multiple tracks or selections from multiple tracks at once
results in multiple new audio tracks. To create one resulting audio track from all your
source material, activate Mix Down to One Track.
Mix Down to One Track is only available if several tracks are selected and Dry
(Transfer Channel Settings) is deactivated.
Tail Size
Allows you to set a tail size in seconds or bars and beats for the rendered files. This
adds time at the end of the rendered file to allow reverb and delay tails to fully fade
out.
Bit Depth
Allows you to set the bit depth for the resulting material to 16 bit, 24 bit, 32 bit,
32 bit float, or 64 bit float.
Name
Allows you to enter a custom name for the rendered files. To do this, unlock this
option by clicking the lock icon.
Scheme
Click Open Naming Scheme Window to define naming schemes.
Preview
Shows the name with the current naming scheme settings.
Path
Allows you to select a custom folder to which the resulting .wav files are rendered.
RELATED LINKS
Naming Scheme on page 221
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Naming Scheme

1

Scheme
Allows you to save and delete naming schemes.

2

Attributes
Holds the following naming scheme attributes:
●

Name
Adds the text you entered on the Export Selected Events dialog in the Name field
to the resulting file name.
NOTE
The resulting file name only contains the text in the Name field of the File Name
Settings in the Export Selected Events dialog if no naming scheme defined. The
file name corresponds to the naming scheme if the naming scheme contains
attributes.

●

Project Name
Adds the project name to the resulting file name.

●

Free Text
Adds free text to the file name.

●

Folder Path
Adds the folder path of the events from the track list to the resulting file name.

●

Track Name
Adds the track name of the audio event or MIDI part to the resulting file name.

●

Event Name
Adds the event name of the audio event or MIDI part to the resulting file name.

●

Counter
Adds a number to the resulting file name.

3

Result
Allows you to drop attributes and rearrange them by dragging.

4

Settings
Allows you to select separator and counter settings.
●

Separator
Divides attributes from each other.

221

Parts and Events
Editing Techniques for Parts and Events
●

Counter
The value from which the counter starts counting.

●

Digits
The number of number of digits prior to the counter value.

5

Preview
Displays a preview of your current settings.

Defining Naming Schemes
You can define naming schemes by setting up attributes which build the structure of the file
name of the exported audio files.
PREREQUISITE
The Export Selected Events dialog is open and Mix Down to One Track is deactivated.
PROCEDURE
1.

In the Export Selected Events dialog, click Open Naming Scheme Window

.

The Naming Scheme dialog opens.

2.

Open the Scheme pop-up menu and select New Scheme.

3.

Optional: Double-click the name in the field and enter a name.

4.

Double-click an attribute in the Attributes field to add it to the Result field.
You can also drag an attribute and drop it in the Result field.
NOTE
Each attribute is available only once, except the Free Text attribute. You can set up a
maximum of seven attributes.
To remove an attribute, click its x icon.

5.

Optional: Drag an attribute to the left/right in the Result field to change its order.

6.

Click OK.

RESULT
The naming scheme is saved and will be applied on export.
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Saving Naming Schemes
You can save several naming schemes in the Naming Scheme window. Saved naming schemes
are displayed on the Scheme pop-up menu. Every change that is made to the active naming
scheme is saved immediately.
PROCEDURE
1.

Define a naming scheme by adding attributes to the Result field.

2.

Make separator and counter settings.

3.

To rename the naming scheme, double-click its name in the field, type in the new name,
and press Enter.

Exporting Audio Parts and Events as Clip Packages
You can select audio parts and events in the Project window and export them as a clip package.
PROCEDURE
1.

Select the audio events of parts that makes up the sound or create a selection range.
NOTE
Only audio material will be part of the clip package. Any other selected material is ignored.
Any empty space before the audio is included in the clip package.

2.

Optional: Read-enable the corresponding tracks to include automation data in the clip
package.

3.

Select File > Export > Clip Package.

4.

In the upper section of the Export Clip Package dialog, specify the folder where you want
to save the clip package.

5.

Enter a name in the name field.

6.

Click OK.

RESULT
The clip package is saved in the specified folder with the specified name.
RELATED LINKS
Clip Packages on page 196
Attribute Inspector on page 632
Export Clip Package on page 224
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Export Clip Package

1

Select Folder
Allows you to select a folder where the clip packages are saved. You can use the clip
packages folder of the project or choose another folder.

2

Create New Folder
Creates a new folder for your clip packages.

3

Attribute Inspector
Allows you to show and edit the attributes for the clip package.

4

Name field
Allows you to enter the name for the clip package.

5

Show Attribute Inspector
Opens/Closes the Attributes Inspector.
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Editing in the Project window is not restricted to handling whole events and parts. You can also
work with selection ranges, which are independent from the event/part and track boundaries.

Creating a Selection Range
●

To make a selection range, drag with the Range Selection tool.

When the Range Selection tool is selected, you can select selection ranges options via
Edit > Select.
●

To create a selection range that encompasses an event, double-click on an event with the
Range Selection tool.

●

To create a selection range that encompasses several events, hold down Shift and doubleclick several events in a row.

●

To open an encompassed event for editing in the Sample Editor, double-click it.

RELATED LINKS
Selection Range Options on page 225

Selection Range Options
If the Range Selection tool is selected, the Select submenu features specific options for
selecting ranges in the Project window.
●

To open the range selection options menu, select the Range Selection tool and select
Edit > Select.

All
Makes a selection that covers all tracks, from the start of the project to the end. You
can define the track length with the Length setting in the Project Setup dialog.
None
Removes the current selection range.
Invert
Inverts the selection. All selected events are deselected, and all events that were not
selected are selected. Only used for event selection.
In Loop
Makes a selection between the left and right locator on all tracks.
From Start to Cursor
Makes a selection on all tracks, from the start of the project to the project cursor.
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From Cursor to End
Makes a selection on all tracks, from the project cursor to the end of the project.
Equal Pitch - all Octaves
This function requires that a single note is selected. It selects all notes of this part
that have the same pitch in any octave as the selected note.
Equal Pitch - same Octave
This function requires that a single note is selected. It selects all notes of this part
that have the same pitch and the same octave as the selected note.
Select Controllers in Note Range
Selects the controllers within the note range.
All on Selected Tracks
Selects all events on the selected track. Only used for event selection.
Events under Cursor
Selects all events on the selected tracks that are touched by the project cursor.
Select Event
This is available in the Sample Editor.
Left Selection Side to Cursor
Moves the left side of the current selection range to the project cursor position.
Right Selection Side to Cursor
Moves the right side of the current selection range to the project cursor position.
Range to Next Event
Moves the selection range to the next event head or tail on the selected tracks and
turns the selection range to a zero selection.
Range to Previous Event
Moves the selection range to the previous event head or tail on the selected tracks
and turns selection range to a zero selection.
Enlarge Range to Next Event
Moves the right side of the current selection range to the next event head or tail on
the selected tracks.
Enlarge Range to Previous Event
Moves the left side of the current selection range to the previous event head or tail
on the selected tracks.
RELATED LINKS
Project Setup Dialog on page 89
Selecting with the Object Selection Tool on page 200
Select Submenu on page 201

Selecting Ranges for Several Tracks
You can create selection ranges that cover several tracks. It is also possible to exclude tracks
from a selection range.
PROCEDURE
1.

Create a selection range from the first to the last track.
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2.

Press Alt and click in the selection range on the tracks that you want to exclude from the
selection.
If you press Shift-Alt while creating a selection range, the range will encompass all tracks
in the track list.

Creating Different Selection Ranges
You can create 2 different selection ranges (selection A and selection B) and switch between
these. Activating one of the options selects the corresponding selection and causes the event
display to switch between the two locations.
PROCEDURE
1.

Use the Range Selection tool to define a destination range for your selection.
By default, the first selection you perform will be Selection A. The letter displayed on the
tool icon shows which selection range you are to define.

2.

Click on the Range Selection tool again and select Selection B from the pop-up menu.

This switches the selection ranges.
3.

Define the destination range for Selection B.

RESULT
You can now switch between Selection A and Selection B with the Range Selection pop-up
menu.
AFTER COMPLETING THIS TASK
Deactivate the Range Selection tool. Otherwise, you might accidentally overwrite your defined
selections.

Editing Selection Ranges
Adjusting the Size of Selection Ranges
You can adjust the size of a selection range in the following ways:
●

By dragging its edges.
The pointer takes the shape of a double arrow when you move it over an edge of the
selection range.

●

By holding down Shift and clicking.
The closest selection range edge will be moved to the position at which you clicked.

●

By adjusting the selection range start or end position on the info line.

●

By using the trim buttons on the toolbar.
The left trim buttons move the start of the selection range and the right buttons move the
end. The edges are moved by the amount specified on the Grid pop-up menu.
NOTE
The trim buttons are located on the Nudge Palette, which is not visible on the toolbar by
default.
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●

By using Move Left and Move Right on the toolbar.
These move the whole selection range to the left or the right. The amount of movement
depends on the selected display format and the value specified on the Grid pop-up menu.
IMPORTANT
The contents of the selection are not moved. Using Move Left/Move Right is the same as
adjusting the start and end of the selection range at the same time by the same amount.
NOTE
The move buttons are located on the Nudge Palette, which is not visible on the toolbar by
default.

●

To crop all events or parts that are partially within the selection range, select Edit >
Range > Crop.
Events that are fully inside or outside the selection range are not affected.

RELATED LINKS
Setup Context Menus on page 1161

Moving and Duplicating Selection Ranges
●

To move a selection range, click and drag it to a new position.
This will move the contents of the selection range to the new position. If the range
intersected events or parts, these are split before moving, so that only the sections within
the selection range are affected.

●

To duplicate a selection range, hold down Alt and drag.
You can also use the duplicate, repeat, and fill loop functions that are available for
duplicating events.

RELATED LINKS
Duplicating Events on page 214

Cutting, Copying, and Pasting Selection Ranges
You can cut or copy and paste selection ranges, using the functions on the Edit menu. You can
also use the Cut Time and Paste Time options.
Cut
Cuts out the data in the selection range and moves it to the clipboard. The selection
range is replaced by empty track space in the Project window, meaning that events
to the right of the range keep their positions.
Copy
Copies the data in the selection range to the clipboard.
Paste
Pastes the clipboard data to the start position and track of the current selection.
Existing events on the tracks remain at their original position.
Paste at Origin
Pastes the clipboard data back at its original position. Existing events on the tracks
remain at their original position.
This option is available in Edit > Functions.
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Cut Time
Cuts out the selection range and moves it to the clipboard. Events to the right of the
removed range are moved to the left to fill the gap.
This option is available in Edit > Range.
Paste Time
Pastes the selection range from the clipboard to the start position and track of the
current selection. Existing events are moved to make room for the pasted data.
This option is available in Edit > Range.
Paste Time at Origin
Pastes the selection range from the clipboard to its original position. Existing events
are moved to make room for the pasted data.
This option is available in Edit > Range.
Global Copy
Copies everything between the left and right locator.
This option is available in Edit > Range.

Deleting Data in Selection Ranges
●

To replace data within the deleted selection range with empty track space, select Edit >
Delete or press Backspace.
Events to the right of the range keep their position.

●

To remove the selection range and make the events to the right move to the left to fill the
gap, select Edit > Range > Delete Time.

Splitting Selection Ranges
●

To split any events or parts that are intersected by the selection range, at the positions of
the selection range edges, select Edit > Range > Split.

Inserting Silence
You can insert empty track space from the start of the selection range. The length of the silence
equals the length of the selection range.
●

To insert silence, select Edit > Range > Insert Silence.
Events to the right of the selection range start are moved to the right to make room.
Events that are intersected by the selection range start are split, and the right section is
moved to the right.
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Nuendo offers multiple methods and functions to control playback and transport.
RELATED LINKS
Transport on page 1205

Transport Panel
The Transport panel contains the main transport functions as well as many other options related
to playback and recording.
●

To show the transport panel, select Transport > Transport Panel or press F2.

Transport Panel Sections
The Transport panel has different sections that you can show or hide by activating the
corresponding options on the transport panel context menu.
●

To show all Transport panel sections, right-click anywhere on the Transport panel and
select Show All.

The following sections are available:
Performance

Shows the audio processing load and the hard disk transfer rate.
Record Mode

Determines what happens to your recordings and to any existing events on the track
when you are recording. This section also contains the automatic MIDI record
quantize function.
Locators

Allows you to go to the left or right locator position, and to set the left and right
locator position numerically.
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Punch Points

Allows you to activate/deactivate Punch In and Punch Out.
The section to the right of the punch buttons allows you to set up the punch
positions numerically. For this to work, Lock Punch Points to Locators must be
deactivated. You can hide/show that section by clicking the points on the divider.
Main Transport

Shows the basic transport controls as well as the time display options.
Arranger

Shows the arranger functions.
Pre-roll & Post-roll

Allows you to activate/deactivate pre-roll and post-roll.
The section to the right of the pre-roll buttons allows you to set the pre-roll values
numerically. You can hide/show that section by clicking the points on the divider.
Tempo & Time Signature

Allows you to activate/deactivate the tempo track and the metronome click, and to
set the tempo value and the first time signature value numerically.
The section to the right of the value fields allows you to activate/deactivate external
sychronization and metronome click in count-in. You can hide/show that section by
clicking the points on the divider.
Marker

Shows the basic marker functions.
MIDI Activity

Allows you to monitor the MIDI input and the MIDI output signals.
Audio Activity

Allows you to monitor the audio input and output signals.
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Audio Level Control

Shows clipping indicators and allows you to control the output level.
RELATED LINKS
Transport on page 1205
Transport - Scrub on page 1207

Transport Menu
The Transport menu contains several transport functions as well as many other options related
to playback and recording.

Transport Panel
Opens the Transport panel.

Transport
Start
Starts playback.
Stop
Stops playback.
Start/Stop
Starts/Stops playback.
Cycle
Activates/Deactivates cycle mode.
Record
Activates/Deactivates record mode.
Rewind
Moves backward.
Forward
Moves forward.
Fast Rewind
Moves backward at a faster speed.
Fast Forward
Moves forward at a faster speed.
Nudge Cursor Left
Moves the project cursor position to the left.
Nudge Cursor Right
Moves the project cursor position to the right.
Enter Project Cursor Position
Allows you to enter the project cursor position manually.
Enter Tempo
Allows you to enter the tempo manually.
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Enter Time Signature
Allows you to enter the time signature manually.
Go to Project Start
Moves the project cursor position to the start of the project.
Go to Project End
Moves the project cursor position to the end of the project.
Exchange Time Formats
Switches the primary and the secondary time display.

Locators
Go to Left Locator Position
Moves the project cursor position to the left locator.
Go to Right Locator Position
Moves the project cursor position to the right locator.
Set Left Locator to Project Cursor Position
Sets the left locator to the project cursor position.
Set Right Locator to Project Cursor Position
Sets the right locator to the project cursor position.
Enter Left Locator Position
Allows you to enter the position of the left locator manually.
Enter Right Locator Position
Allows you to enter the position of the right locator manually.
Set Locators to Selection Range
Sets the locators to encompass the selection.
Exchange Left & Right Locator Positions
Switches the positions of the left and right locator.
Loop Selection Range
Activates playback from the start of the current selection and keeps starting over
again when reaching the selection end.

Punch Points
Lock Punch Points to Locators
Allows you to unlock/lock the punch in and punch out position to the left and the
right locator.
Activate Punch In
Activates/Deactivates punch in.
Activate Punch Out
Activates/Deactivates punch out.
Go to Punch In Position
Moves the project cursor position to the punch in position.
Go to Punch Out Position
Moves the project cursor position to the punch out position.
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Set Punch In to Project Cursor Position
Moves the punch in position to the project cursor position.
Set Punch Out to Project Cursor Position
Moves the punch out position to the project cursor position.
Enter Punch In Position
Allows you to enter the punch in position manually.
Enter Punch Out Position
Allows you to enter the punch out position manually.
Set Punch Points to Selection Range
Sets the punch in and the punch out position to the selected event range.

Set Project Cursor Position
Locate Selection Start
Moves the project cursor to the beginning of the selection.
Locate Selection End
Moves the project cursor to the end of the selection.
Locate Next Marker
Moves the project cursor to the next marker.
Locate Previous Marker
Moves the project cursor to the previous marker.
Locate Next Hitpoint
Moves the project cursor to the next hitpoint on the selected track.
Locate Previous Hitpoint
Moves the project cursor to the previous hitpoint on the selected track.
Locate Next Event
Moves the project cursor to the next event on the selected track.
Locate Previous Event
Moves the project cursor to the previous event on the selected track.

Play Project Range
Play from Selection Start
Activates playback from the start of the current selection.
Play from Selection End
Activates playback from the end of the current selection.
Play until Selection Start
Activates playback two seconds before the start of the current selection and stops at
the selection start.
Play until Selection End
Activates playback two seconds before the end of the current selection and stops at
the selection end.
Play until Next Marker
Activates playback from the project cursor and stops at the next marker.

234

Playback and Transport
Transport Menu
Play Selection Range
Activates playback from the start of the current selection and stops at the selection
end.

Pre-roll & Post-roll
Use Pre-roll
Activates/Deactivates the pre-roll.
Use Post-roll
Activates/Deactivates the post-roll.
Post-roll from Selection Start
Starts playback from the beginning of the selected range and stops after the time set
in the post-roll field on the Transport panel.
Post-roll from Selection End
Starts playback from the end of the selected range and stops after the time set in the
post-roll field on the Transport panel.
Pre-roll to Selection Start
Stops playback at the selection start. The playback start position is set in the pre-roll
field on the Transport panel.
Pre-roll to Selection End
Stops playback at the selection end. The playback start position is set in the pre-roll
field on the Transport panel.

Use Tempo Track
Activates/Deactivates the tempo track.

Common Record Modes
Punch In/Out
Activates/Deactivates punch in/out.
Re-Record
Activates/Deactivates the re-record mode.
Start Recording at Project Cursor Position
Activates/Deactivates the start of the recording at the project cursor position.
Start Recording at Left Locator/Punch In Position
Activates/Deactivates the start of the recording at the left locator.

Audio Record Mode
These options allow you to select what happens when you record over existing events.
Keep History
Keeps existing events or portions of events.
Cycle History + Replace
Replaces existing events or portions of events by the new recording. In cycle mode,
all takes from the current cycle recording are kept.
Replace
Replaces existing events or portions of events by the last take.
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MIDI Record Mode
These options allow you to select what happens when you record over existing parts.
New Parts
Keeps existing parts and saves the new recording as a new part.
Merge
Keeps existing events in parts and adds the newly recorded events.
Replace
Replaces existing events in parts by the new recording.
Auto Quantize in Record
Activates automatic quantizing during record.

MIDI Cycle Record Mode
Mix
Adds everything you record to what was previously recorded.
Overwrite
Overwrites all MIDI that you have recorded on previous laps as soon as you play a
MIDI note or send any MIDI message.
Keep Last
Replaces previously recorded laps only if the new lap is completed.
Stacked
Turns each recorded cycle lap into a separate MIDI part, and divides the track into
lanes for each cycle lap. The parts are stacked above each other, each on a different
lane. All takes but the last one are muted.
Mix-Stacked (No Mute)
Same as Stacked, but parts are not muted.
Auto Quantize in Record
Activates automatic quantizing during record.

Retrospective MIDI Record
Allows you to capture MIDI notes that you play in stop mode or during playback. For this to work,
you need to enable the Retrospective Record option in the Preferences dialog (Record—MIDI
page).

Use Video Follows Edit Mode
If this option is activated, the project cursor automatically follows when you make selections or
when you perform editing operations.
In Stop mode, the project cursor is hidden from the event display. However, it is always visible in
the ruler.

Metronome Setup
Opens the Metronome Setup dialog.

Activate Metronome
Activates/Deactivates the metronome click.
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Project Synchronization Setup
Opens the Project Synchronization Setup dialog.

Use External Synchronization
Sets Nuendo to be synchronized externally.
RELATED LINKS
Left and Right Locators on page 241
Punch In and Punch Out on page 245
Pre-Roll and Post-Roll on page 244
Common Record Modes on page 262
Audio Record Modes on page 267
MIDI Record Modes on page 273
Enabling Retrospective MIDI Record on page 275
Metronome Click on page 246

Transport
The Transport contains all transport functions in an integrated and fixed zone of the Project
window.
●

To activate the transport, click Setup Window Layout on the Project window toolbar and
activate Transport.

●

To display all transport elements, right-click in an empty area of the transport and select
Show All.

●

To show all controls of a section, click the points to the right of the section and drag all the
way to the right. To hide the controls again, drag to the left.

RELATED LINKS
Transport on page 51

Transport Sections
The Transport has different sections that you can show or hide by activating the corresponding
options on the context menu.

●

To activate the Transport, click Set up Window Layout on the Project window toolbar and
activate Transport.

●

To show/hide tools, open the Transport context menu by right-clicking in an empty area of
the Transport and activate the tools that you want to display. To show all tools, select
Show All.
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The following options are available:
Constrain Delay Compensation
Allows you to minimize the latency effects of the delay compensation.
Common Record Modes
Allow you to determine what happens if you click Record during an audio or MIDI
recording.
Audio Record Modes
Allow you to select what happens when you record over existing audio events.
MIDI Record Modes
Allow you to select what happens when you record over existing MIDI parts.
Left Divider

Allows you to use the left divider. Tools that are placed to the left of the divider are
always shown.
System Performance Meter

Shows the meters for ASIO time usage and hard disk transfer load.
Locators

Allows you to go to the left or right locator position, and to set the left and right
locator position numerically.
Punch Points

Allows you to activate/deactivate Punch In and Punch Out. These points determine
the record start and stop positions.
The section to the right of the punch buttons allows you to set up the punch
positions numerically. For this to work, Lock Punch Points to Locators must be
deactivated. You can hide/show that section by clicking the points on the divider.
Main Transport

Shows the main transport controls.
Time Displays

Shows the time display options.
Pre-roll & Post-roll
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Allows you to activate/deactivate pre-roll and post-roll, and to set the values
numerically.
Tempo & Time Signature

Allows you to activate/deactivate the tempo track, and to set the tempo value and
the first time signature value numerically.
External Sync State
Allows you to activate/deactivate external synchronization and to open the Project
Synchronization Setup dialog.
Click & Count-In & Click Pattern
Allows you to activate/deactivate the metronome click, the metronome click in countin, and the click pattern.
Right Divider

Allows you to use the right divider. Tools that are placed to the right of the divider
are always shown.
Input/Output Activity

Allows you to monitor the MIDI input/output signals, the audio input/output signals,
and allows you to control the output level.

Transport Pop-Up Window
The Transport pop-up window allows you to access specific transport commands if the
Transport panel and the Transport are closed.
The following default key commands open the Transport pop-up window:
●

Enter Left Locator
Shift-L

●

Enter Right Locator
Shift-R

●

Enter Project Cursor Position
Shift-P

●

Enter Tempo
Shift-T

●

Enter Time Signature
Shift-C

●

Enter Punch In Position
Shift-I

●

Enter Punch Out Position
Shift-O

●

Go to Left Locator
Num1
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●

Go to Right Locator
Num2

Using a specific key command opens the corresponding section of the Transport pop-up
window:

Transport pop-up window for entering the left Locator position.

NOTE
To close the Transport pop-up window, press Esc.

Time Display Window
The Time Display window allows you to view the current time position in a separate window. You
can adjust its size and specify the time format that you want to display.
●

To show the Time Display window, select Studio > More Options > Time Display.

●

You can set up the time format by right-clicking the window and selecting an option from
the context menu.
The Show Beat Count Only option allows you to show the beat counts. This is useful if you
want to use the Time Display window as a visual metronome.

●

To adjust the window size to the size of the displayed values, double-click the window. To
adjust the size of the displayed values step by step, you can also right-click and select
Increase Window Size or Decrease Window Size from the context menu.
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●

To set the transparency of the window, adjust the Window Transparency slider in the
Studio Setup dialog (Time Display page).

RELATED LINKS
Time Signature Events on page 991

Left and Right Locators
The left and right locators are a pair of markers that you can use to set up cycle boundaries. Left
and right locators are available in the Project window as well as in the editors.

Locators are indicated by the flags in the ruler. The area between the left and the right locator is
the locator range. The locator range is highlighted in the ruler and the event display.
NOTE
The event display in the MIDI editors is only highlighted if Show Part Borders is deactivated.
●

To activate/deactivate the cycle mode, click the locator range in the upper part of the ruler.

●

NOTE
If you activate cycle mode, and the right locator is positioned before the left locator, the
locator range is skipped during playback.

RELATED LINKS
Cycle Recording on page 261
Toolbar on page 806

Setting Locator Ranges
There are several ways to set locator ranges.
To set the locator range, do one of the following:
●

Click in the upper part of the ruler and drag to the right.

●

Select a range or an event and select Transport > Locators > Set Locators to Selection
Range.

●

Double-click a cycle marker.

●

Press P.

To move the locator range, do the following:
●

Click, keep the mouse button pressed, and then drag left or right in the upper part of the
ruler.

To create a new locator range in a range, do the following:
●

Press Ctrl/Cmd-Alt and drag left or right in the upper part of the ruler.

To set both locators to the nearest snap position, do the following:
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●

Press Ctrl/Cmd-Alt and click at a position in the upper part of the ruler.

Setting Locator Positions
There are several ways to set the locator positions.
To set locator positions, do one of the following:
●

Drag the left handle in the upper part of the ruler.

●

Drag the right handle in the upper part of the ruler.

●

Press Ctrl/Cmd and click at the position in the upper part of the ruler to set the left
locator.

●

Press Alt and click at the position in the ruler to set the right locator.

●

Adjust the Left/Right Locator Position value on the Transport panel.

To set locator positions to the project cursor position, do one of the following:
●

Press Ctrl/Cmd, and on the numeric keypad press 1 to set the left locator.

●

Press Ctrl/Cmd, and on the numeric keypad press 2 to set the right locator.

●

Press Alt and click Go to Left/Right Locator Position on the Transport panel.

Setting the Project Cursor Position
You have several possibilities to set the project cursor position, that is, to locate to specific time
positions in the Project window.
●

By using the main transport functions.

●

By holding down Shift-Alt and clicking in the event display.

●

By clicking or dragging in the lower part of the ruler.

●

By using the functions in the Set Project Cursor Position submenu of the Transport
menu.

●

By clicking in an empty section in the event display.
NOTE
For this to work you must activate Locate when Clicked in Empty Space in the
Preferences dialog (Transport page).

●

By using locators.
NOTE
You can use Num1 to set the project cursor to the left locator position, and Num2 to set
the project cursor to the right locator position.

●

By using markers.

●

By using the arranger functions.

●

By using key commands.

RELATED LINKS
Transport Panel Sections on page 230
Ruler on page 47
Transport Menu on page 232
Transport on page 1205
Left and Right Locators on page 241
Markers on page 334
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Arranger Track on page 317
Key Commands on page 1137

Auto-Scroll
Auto-Scroll allows you to keep the project cursor visible in the window during playback.
If you activate Auto-Scroll on the toolbar of the Project window or one of the editors, the
following modes are available in the Switch Auto-Scroll Settings pop-up menu:
Page Scroll

The project cursor moves from the left side to the right side of the window. When the
project cursor reaches the right side of the window, the ruler and the project cursor
jump to the left side of the window and start over again. This behavior can be
compared to turning a page of a book.
Stationary Cursor

The project cursor is kept in the middle of the window and the ruler scrolls
continuously to the left.
RELATED LINKS
Toolbar on page 41

Suspend Auto-Scroll When Editing
If you do not want the Project window display to change when editing during playback, activate
Suspend Auto-Scroll when Editing.
Suspend Auto-Scroll when Editing is available as an option in the Switch Auto-Scroll Settings
pop-up menu to the right of the Auto-Scroll button.
If this option is activated, auto-scrolling is suspended as soon as you click anywhere in the event
display during playback until playback stops or you click Auto-Scroll again.
As a visual feedback, the Auto-Scroll button changes its color.

Time Formats
You can set up different time formats.

Selecting the Primary Time Format
On the Transport panel, you can select the primary time format. This is the global display format
that is used for all rulers and position displays in the program, except the ruler tracks.
PROCEDURE
1.

In the main transport section on the Transport panel, click Select Primary Time Format.
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2.

Select a time format from the pop-up menu.

You can also select Project > Project Setup > Display Format to select the primary time
format.
RESULT
The time format on the Transport panel and all rulers and position displays are updated.

Independent Time Displays
You can show time displays that are independent from the global display format.
To select an independent time display, do one of the following:
●

In the ruler of the Project window or any editor, click the arrow button to the right of the
ruler.

●

Select Project > Add Track > Ruler to add a ruler track, and right-click the ruler.

●

In the Main Transport section of the Transport panel, click Select Secondary Time
Format.

RELATED LINKS
Ruler on page 47
Ruler Track on page 147

Pre-Roll and Post-Roll
You can activate pre-roll and post-roll with the corresponding buttons in the Pre-roll & Post-roll
section on the Transport panel or by selecting Transport > Pre-roll & Post-roll > Use Preroll/Use Post-roll.
●

By setting a pre-roll value you instruct Nuendo to roll back a short section whenever
playback is activated.

●

By setting a post-roll value you instruct Nuendo to play back a short section after
automatic punch out before stopping.

NOTE
This only works if Punch Out is activated on the Transport panel, and if Stop after
Automatic Punch Out is activated in the Preferences dialog (Record page).

Using Pre-Roll and Post-Roll
PREREQUISITE
On the Transport panel, Lock Punch Points to Locators is activated.
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PROCEDURE
1.

Set the locators to where you want to start and end recording.

2.

On the Transport panel, activate Punch In and Punch Out.

3.

In the Preferences dialog, select Record.

4.

Activate Stop after Automatic Punch Out.

5.

On the Transport panel, activate Pre-roll and Post-roll.

6.

In the Pre-roll Amount and Post-roll Amount fields, enter the pre-roll and post-roll
values.

7.

Activate Record.

RESULT
The project cursor rolls back by the time specified pre-roll value and playback starts. When the
cursor reaches the left locator, recording is automatically activated. When the cursor reaches the
right locator, recording is deactivated, but playback continues for the specified post-roll value
before stopping.

Punch In and Punch Out
The punch in and the punch out points are a pair of markers that you can use for punch in and
punch out recordings. The punch in position determines the record start position whereas the
punch out position determines the record stop position.
You can activate punch in and punch out by activating the corresponding buttons on the
Transport panel.
The punch in position is locked to the left locator position and the punch out position to the right
locator position. The punch position fields are unavailable.
However, you can detach the punch points from the locators by deactivating Lock Punch Points
to Locators.

If you do so, the value fields become available and you can use them to set up the punch
positions independently from the locator positions.
You can also drag the punch in and punch out handles in the ruler to set the punch positions.

RELATED LINKS
Activating Recording Automatically on page 260
Stopping Recording on page 260
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Metronome Click
You can use the metronome click as a timing reference for playing along and recording. The two
parameters that govern the timing of the metronome are project tempo and the time signature
that you can set up in the Transport panel.
●

To activate the metronome click, activate Activate Metronome Click on the Transport
panel.
You can also select Transport > Activate Metronome or use the corresponding key
command.

●

To define if the metronome click is played during playback, recording or count-in, select
Transport > Metronome Setup and open the General page.

●

To set up the sounds for the metronome click, select Transport > Metronome Setup and
open the Click Sounds page.

RELATED LINKS
Transport Panel Sections on page 230
Project Tempo Modes on page 975

Click Patterns
Click patterns allow you to create a custom metronome click.
By default, the metronome click in Nuendo has a 4/4 pattern with a fixed number of 4 clicks. The
click level of the first click is high, while the level of the other beats is low.

The default metronome click pattern with 4 clicks at a 4/4 time signature

A metronome click pattern with 3 clicks at a 3/4 time signature

By setting up click patterns for the metronome at the current time signature, you can create a
custom metronome click. You can determine the number of clicks and the level of the clicks to
your liking.
If you have different project parts with different time signatures or tempos, and you want to set
up different click patterns to match the rhythm and feel of these parts, you can set up a
metronome click pattern for each signature event in your project.
You can also add the same time signature for different sections and set up different patterns for
them.
NOTE
●

If you want to visualize the current click pattern in the Project window, Key Editor or
Drum Editor event display, activate Use Metronome Click Pattern Level for Grid Line
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Emphasis in the corresponding ruler context menu. This is useful if Snap is activated and
the Snap Type is set to Grid.
●

Grid lines are only emphasized, if they are shown. If you want to visualize a click pattern
that is set to 6 Clicks and a 4/4 Time Signature, you must set the Grid Type to a triplet
value.

The Click Patterns page in the Metronome Setup dialog allows you to manage the available
click patterns. You can remove and rename them or create new click patterns for specific time
signatures.
RELATED LINKS
Click Pattern Editor on page 247
Setting Up a Metronome Click Pattern on page 248
Setting Up Metronome Click Patterns for Signature Events on page 248
Toolbar on page 41

Click Pattern Editor
The Click Pattern Editor allows you to set up a click pattern for your project to create new
grooves and feels for the metronome click. This is useful if you want to create a triplet pattern for
a 4/4 signature, for example.
The Click Pattern Editor is available on the Transport. If you add a signature track, it is available
in the Inspector and on the info line.
●

To open the Click Pattern Editor on the Transport, click the points to the right of the
Click & Count-In & Click Pattern section and drag all the way to the right. Click the
pattern field to open the Click Pattern Editor.

Clicks
Allows you to define the number of clicks that are used in the pattern.
Pattern
Allows you to select a pattern preset or to save your own ones. Which patterns are
available depends on the current time signature, and on the settings in the
Metronome Setup dialog on the Click Patterns page.
NOTE
To view, edit and rename the pattern presets, open the Click Patterns page in the
Metronome Setup dialog.
Event Display
Shows the defined number of beats for the selected pattern.
You can change the accent level for a beat by changing its vertical position in the
event display. There are 4 different settings. These correspond to the settings in the
Metronome Setup dialog on the Click Sounds page. You can mute a beat by clicking
the lowest vertical position.
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RELATED LINKS
Transport Sections on page 237
Signature Track on page 148

Setting Up a Metronome Click Pattern
You can set up a different metronome click pattern for your project.
PROCEDURE
1.

In the Transport, click the points to the right on the Click & Count-in & Click Pattern
section and drag all the way to the right to show the click pattern section.

2.

Click the pattern field to open the Click Pattern Editor.

3.

Do one of the following:
●

Open the Pattern pop-up menu and select one of the presets.

●

Use the Clicks setting to define the number of clicks that you want to hear, and click
in the event display to set up a new click pattern.

4.

When you are done, click outside the Click Pattern Editor to close it.

5.

Activate the metronome click.

RESULT
The metronome click is played back with the defined click pattern.
RELATED LINKS
Click Pattern Editor on page 247

Setting Up Metronome Click Patterns for Signature Events
You can set up a metronome click pattern for each signature event in your project. This is useful
if you have different project parts with different time signatures, and you want to customize click
patterns to the rhythm and feel of these parts. You can also add the same time signature for
different sections and set up different patterns for them.
PROCEDURE
1.

Double-click the plus sign or the pattern to the right of the time signature value to open
the Click Pattern Editor.

2.

Do one of the following:
●

Open the Pattern pop-up menu and select one of the presets.

●

Use the Clicks setting to define the number of clicks that you want to hear, and click
in the event display to set up a new click pattern.

3.

When you are done, click outside the Click Pattern Editor to close it.

4.

Repeat this for each signature event for which you want to set up a click pattern.

RESULT
If you play back the project and activate the metronome click, the different project parts use the
defined click patterns. The Click Pattern Editor in the Transport shows the pattern at the
project cursor position.
RELATED LINKS
Click Pattern Editor on page 247
Signature Track on page 148
Time Signature Events on page 991
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Metronome Setup
You can make settings for the metronome in the Metronome Setup dialog.
To open the Metronome Setup dialog, do one of the following:
●

Select Transport > Metronome Setup.

●

On the Transport, open the Click & Count-In & Click Pattern section, and click Open
Metronome Setup.

RELATED LINKS
General Page on page 250
Click Sounds Page on page 251
Click Patterns Page on page 253
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General Page
The General page allows you to make basic metronome settings.

In the topmost section, the following options are available:
Activate Metronome Click
Activates/Deactivates the metronome click.
In the Click Destinations section, the following options are available:
Use MIDI Click
Activates a MIDI click for the metronome.
Use Audio Click
Activates an audio click for the metronome that is output via the audio hardware.
Select Audio Click Outputs
If you use multiple output busses, this allows you to activate the output bus where
you want to route the metronome click.
In the Click Options section, the following options are available:
Click while Recording
Activates the metronome click during recording.
Click while Playing
Activates the metronome click during playback.
Click during Count-In
Activates a musical count-in that is played when you start recording from stop mode.
In the Count-In section, the following options are available:
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Use Musical Count-In
If you activate a musical count-in, the following options are available:
●

Number of Bars in Count-In
Allows you to set the number of bars that the metronome counts in before
recording starts.

●

Time Signature at Record Start Position
Activate this to let the count-in automatically use the time signature and
tempo set at the position where recording starts.

●

Time Signature at Project Position
Activate this to let the count-in use the time signature at the project position.

●

Use Custom Time Signature
Allows you to set a time signature for the count-in. In this mode, signature
changes in the project do not affect the count-in.

Use Time-Linear Count-In
If you activate a time-linear count-in, the following options are available:
●

Count-In Click Count
This allows you to set the number of clicks you hear before playback or
recording starts.

●

Interval in Seconds
This allows you to define a time interval for the clicks. You can calculate the
position of the first click by multiplying the count-in click value with the
specified interval and subtracting this value from the position of the left
locator.

●

Emphasis
This allows you to select an emphasized click. This is useful if you want to have
an audible difference between the first and/or last click and the other clicks.

Click Sounds Page
The Click Sounds page allows you to set up and audition the MIDI click and the audio click. You
can use the default audio or MIDI click, choose from a list of factory preset sounds, or assign
your own custom sounds.
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The MIDI Click Settings section allows you to set up the MIDI click that sounds if you activate
MIDI Click in the Click Destinations section on the General page.
MIDI Output Port
Allows you to select a MIDI output port for the MIDI click. You can also select a VST
instrument previously set up in the VST Instruments window.
MIDI Output Channel
Allows you to select a MIDI output channel for the MIDI click.
Note
Allows you to set the MIDI note number, that is, the pitch from C-2 to G8. Set the
note number for the first beat in a bar in the top row, and the note numbers for the
other beats in the rows below.
Velocity
Allows you to set the velocity of the MIDI click sound. Set the velocity for the first
beat in a bar in the top row, and the velocities for the other beats in the rows below.
The Audio Click Settings section allows you to set up the audio click that sounds if you activate
Audio Click in the Click Destinations section on the General page.
Use Steinberg Click Sound
Activates the default sounds for the metronome click.
Pitch
Allows you to set the pitch for the default sounds. Set the pitch for the first beat in a
bar in the top row, and the pitches for the other beats in the rows below.
Level
Allows you to set the level for the default sounds. Set the level for the first beat in a
bar in the top row, and the levels for the other beats in the rows below.
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Use Custom Sounds
Activates custom sounds for the metronome click. For this to work, you must select
an audio file for the custom sounds by clicking in the Sound column.
Sound
Allows you to select an audio file for the custom sounds. Select an audio file for the
first beat in a bar in the top row, and the audio files for the other beats in the rows
below.
Level
Allows you to set the level for the custom sounds. Set the level for the first beat in a
bar in the top row, and the levels for the other beats in the rows below.
Audio Click Level
Allows you to adjust the level of the audio click.
Click Sound Presets
Allows you to load one of the click sound presets that supports up to 4 accents.
Amongst other click sounds that are suited for a broad range of applications, you can
also select Steinberg Click Sound, the default click sound of Nuendo.
You can also create your own presets and save them.
Audition Click Sounds
Click Play to audition the activated click sounds.

Setting Up a Custom Audio Click Sound
PREREQUISITE
In the Metronome Setup dialog on the General page, Activate Metronome is activated. In the
Click Destinations section, Use Audio Click is activated.
PROCEDURE
1.

Open the Click Sounds page, and in the Audio Click Settings section, activate Use
Custom Sounds.

2.

In the Sound column click the top row.

3.

In the file dialog, navigate to the audio file that you want to use as a custom sound for the
first beat and select it.

4.

Click Open.

5.

Click the other rows to select audio files for the other beats.

6.

Set the level of the sounds by clicking the respective rows in the Audio Click Level column
and adjusting the value.

7.

Optional: Click Play to audition the custom sounds.

RESULT
The metronome uses the defined custom sounds for the audio click.
AFTER COMPLETING THIS TASK
Open the Click Sound Presets pop-up menu and save your custom sounds as a preset.

Click Patterns Page
The Click Patterns page allows you to manage click patterns. Click patterns allow you to edit the
default metronome click.
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The following options are available:
1

Add New Signature
Click and enter a time signature value to add a new time signature.

2

Available Time Signatures
Shows the available time signatures.

3

Available Patterns
Shows the available click patterns.

4

Add New Pattern
Double-click to add a new click pattern for the time signature.

5

Clicks
Allows you to change the number of clicks used in the click pattern.

6

Click Pattern
Shows the click pattern. You can open the Click Pattern Editor by clicking the pattern.

7

Remove Click Pattern
Removes the click pattern from the list of available patterns.

8

Add New Pattern
Adds a new default click pattern for the time signature.

NOTE
If you scroll all the way down, you can reset all click patterns to the factory settings by clicking
Reset to Factory Patterns.
You can double-click the name of a pattern and enter a new one to rename a click pattern.
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Setting Up a Time-Based Count-In
You can set up a time-linear count-in as a timing reference for your recordings. This is useful for
postproduction scenarios where projects are rather time based than referencing to bars and
beats.
A typical use case would be the synchronization of voice-overs or dubbing versions. In these
scenarios, you find yourself frequently jumping to positions from which you want the recording
to start. By setting the locators to the sections that you want to record and defining a time-linear
count-in, you can quickly assign, locate, and hear the record start position in your project.
PROCEDURE
1.

Select Transport > Activate Metronome to activate the metronome click.

2.

Set up a suitable pre-roll value and activate Pre-roll.

3.

Select Transport > Common Record Modes and activate Start Recording at Left
Locator/Punch In Position.

4.

Select Transport > Metronome Setup, and open the General page.

5.

In the Click Options section, activate Click While Recording.

6.

Activate Use Time-Linear Count-In and set it up according to your needs.

7.

Click OK to save your settings and close the dialog.

8.

Set the locators to the section that you want to record and activate recording.
If you want to record several sections, set up cycle markers for all sections that you want to
record.

RESULT
Your project is played back from the current project cursor position and at the given position, the
count-in is triggered. When the cursor reaches the left locator, the count-in stops and recording
starts.
NOTE
You can also set the left locator to the position where you want recording to start, set the project
cursor to a position before the left locator, activate Punch In on the Transport panel and start
playback. The defined time-linear count-in is triggered as the project cursor moves towards the
left locator. When it reaches the left locator, recording is automatically activated.

Creating a Click Track
PROCEDURE
●

Do one of the following:
●

Select Project > Signature Track > Render Audio Click between Locators.

●

Select Project > Signature Track > Render MIDI Click between Locators.

RESULT
●

An audio track containing an audio event with the click is added to your project. The level
corresponds to the Audio Click Level setting on the Click Sounds page of the Metronome
Setup dialog.

●

A MIDI track containing a MIDI part with the click is added to your project. The output of
the MIDI track is routed to the MIDI output port that you set up on the Click Sounds page
of the Metronome Setup dialog.
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Chase
Chase is a function that makes sure your MIDI instruments sound as they should when you
locate to a new position and start playback. This is accomplished by the program transmitting a
number of MIDI messages to your instruments each time that you move to a new position in the
project, making sure all MIDI devices are set up correctly with regard to program change,
controller messages (such as MIDI Volume), etc.
EXAMPLE
You have a MIDI track with a program change event inserted at the beginning. This event makes
a synth switch to a piano sound.
At the beginning of the first chorus you have another program change event which makes the
same synth switch to a string sound.
You now play back the song. It begins with the piano sound and then switches to the string
sound. In the middle of the chorus you stop and rewind to some point between the beginning
and the second program change. The synth now still plays the string sound although in this
section it really should be a piano.
The Chase function takes care of that. If program change events are set to be chased, Nuendo
tracks the music back to the beginning, finds the first program change, and transmits it to your
synth, setting it to the correct sound.
The same thing can apply to other event types as well. In the Preferences dialog (MIDI page),
the Chase Events settings determine which event types are chased when you locate to a new
position and start playback.

RELATED LINKS
Chase Events on page 1196
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The On-Screen Keyboard allows you to play and record MIDI notes by using your computer
keyboard or mouse. This is useful if you have no external MIDI instrument at hand and you do
not want to draw in notes with the Draw tool.
When the On-Screen Keyboard is displayed, the usual key commands are blocked because they
are reserved for the On-Screen Keyboard. The only exceptions are:
●

Save: Ctrl/Cmd-S

●

Start/Stop Record: Num *

●

Start/Stop Playback: Space

●

Jump to left locator: Num 1

●

Delete: Delete or Backspace

●

Cycle on/off: Num /

●

Show/Hide Transport panel: F2

●

Show/Hide On-Screen Keyboard: Alt-K

Recording MIDI With the On-Screen Keyboard
PREREQUISITE
You have selected a MIDI or instrument track and activated Record Enable.
PROCEDURE
1.

Select Studio > On-Screen Keyboard.

2.

Activate Record.

3.

Perform one of the following actions to enter some notes:
●

Click on the keys of the On-Screen Keyboard.

●

Press the corresponding key on your computer keyboard.

NOTE
Press several keys simultaneously to enter polyphonic parts. The maximum number of
notes that can be played at one time varies between the different operating systems and
hardware configurations.

AFTER COMPLETING THIS TASK
Close the On-Screen Keyboard to make all key commands available again.
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On-Screen Keyboard Options

1

Note Velocity Level
This slider allows you to adjust the volume of the On-Screen Keyboard. You can also use
the Up Arrow key or the Down Arrow key for this.

2

Change On-Screen Keyboard Type
This button allows you to switch between computer keyboard and piano keyboard display
mode.
The computer keyboard mode, you can use the two rows of keys that are displayed on the
On-Screen Keyboard to enter notes.
The piano keyboard has a wider range of keys. It allows you to enter more than one voice
simultaneously. You can also use the Tab key for this.

3

Octave Offset
These buttons allow you to switch the keyboard range to a lower or higher octave. You
have seven full octaves at your disposal. You can also use the Left Arrow key or the Right
Arrow key for this.

4

Pitchbend/Modulation Sliders
These sliders are only available in piano keyboard mode. The left slider displays pitchbend,
the right slider shows modulation changes. To introduce modulation, click on a key and
drag upwards or downwards. To introduce pitchbend drag left or right.
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In Nuendo, you can record audio and MIDI.
Make the following initial preparations:
●

Set up, connect, and calibrate your audio hardware.

●

Open a project and set up the project setup parameters according to your specifications.
Project setup parameters determine the record format, sample rate, project length, etc.
that affect the audio recordings that you make during the course of the project.

●

If you plan to record MIDI, set up and connect your MIDI equipment.

RELATED LINKS
Setting Up Audio on page 12
Setting Up MIDI on page 19
Setting Up a Metronome Click Pattern on page 248

Basic Recording Methods
The basic recording methods apply to audio and MIDI recordings.

Record Enabling Tracks
To be able to record, you must record-enable the tracks on which you want to record.
●

To record-enable a track, activate Record Enable in the track list, in the Inspector, or in the
MixConsole.

●

To record-enable all audio tracks simultaneously, set up a key command for Activate
Record Enable for all Audio Tracks in the Mixer category of the Key Commands dialog
and use it.

●

To record-enable audio or MIDI tracks on selection, activate the Enable Record on
Selected Audio Track or the Enable Record on Selected MIDI Track option in the
Preferences dialog (Editing—Project & MixConsole page).

NOTE
The exact number of audio tracks that you can record simultaneously depends on your computer
CPU and hard disk performance. Activate the Warn on Processing Overloads option in the
Preferences dialog (VST page) to show a warning message as soon as the CPU overload
indicator lights up during recording.

RELATED LINKS
Editing - Project & MixConsole on page 1188
VST on page 1207
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Activating Recording
You can activate recording manually or automatically.

Activating Recording Manually
●

To activate recording, click Record on the Transport panel or on the toolbar. You can also
use the corresponding key command, by default Num-*.

Recording starts from the current cursor position.
NOTE
When you start recording in Stop mode, you can start recording from the left locator by
activating Start Record at Left Locator/Punch In Position on the Transport menu. The pre-roll
setting or the metronome count-in will be applied.

Activating Recording Automatically
Nuendo can automatically switch from playback to recording at a given position. This is useful if
you must replace a section of a recording and want to listen to what is already recorded up to the
recording start position.
PROCEDURE
1.

Set the left locator to the position where you want to start recording.
If you want to set up the punch points independently from the locators, deactivate Lock
Punch Points to Locators on the Transport panel, and set up the punch in and punch out
positions in the value fields to the right.

2.

Activate Punch In on the Transport panel.

3.

Activate playback from any position before the left locator.

RESULT
If you have unlocked the punch positions from the locator positions, recording is automatically
activated when the project cursor reaches the punch in position.
If cycle mode is activated, the punch in point corresponds to the position of the left locator, and
the punch out point is set before the right locator, recording is stopped at the punch out position
and resumed at the punch in position.

If the punch positions are locked to the locators, recording is automatically activated when the
project cursor reaches the left locator.
RELATED LINKS
Punch In and Punch Out on page 245

Stopping Recording
●

To stop recording and playback, click Stop on the Transport panel or use the
corresponding key command, by default Num-0.

●

To stop recording and continue playback, click Record or use the corresponding key
command, by default Num-*.

●

To stop recording automatically when the project cursor reaches the punch out position
and continue playback, activate Punch Out on the Transport panel.
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NOTE
If you have unlocked the punch positions from the locator positions, recording is
automatically stopped when the project cursor reaches the punch out position.
NOTE
If cycle mode is activated, the punch in point is set after the left locator, and the punch out
point corresponds to the right locator, recording is started at the punch in position,
stopped at the punch out position, and resumed at the punch in position.

RELATED LINKS
Punch In and Punch Out on page 245

Cycle Recording
You can record in a cycle, that is, you can record a selected section repeatedly and seamlessly.
PREREQUISITE
A cycle is set up with the left and right locators.
PROCEDURE
1.

Click the Cycle on the Transport panel to activate cycle mode.

2.

Activate recording from the left locator, before or within the cycle.
As soon as the project cursor reaches the right locator, it jumps back to the left locator and
continues recording a new lap.

RESULT
The results of cycle recording depend on the selected record mode. They also differ for audio and
MIDI.
RELATED LINKS
Left and Right Locators on page 241
Recording MIDI on page 271
Recording Audio on page 266

Using Pre-Roll and Post-Roll
You can set up a pre-roll and a post-roll for recording.
PREREQUISITE
Activate Stop after Automatic Punch Out in the Preferences dialog (Record page).
PROCEDURE
1.

Set the locators to where you want to start and end recording.

2.

On the Transport panel, activate Punch In and Punch Out.

3.

Activate Pre-roll and Post-roll.

4.

Specify a Pre-roll Amount and a Post-roll Amount.

5.

Click Record.
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RESULT
The project cursor rolls back and starts playback at the time that has been set as pre-roll amount.
When the cursor reaches the left locator, recording is automatically activated. When the cursor
reaches the right locator, recording is deactivated, and the playback continues as long as the
time that has been set as post-roll amount.

Common Record Modes
The Common Record Modes determine what happens if you click Record during an audio or
MIDI recording.
●

To access the record modes, select Transport > Common Record Modes.
You can also access the Common Record Modes by clicking the upper part of the Record
Modes section in the Transport panel.

Punch In/Out
In this mode, the recording is stopped.
Re-Record
In this mode, the recording is reinitiated, the events are removed and recording is
restarted from the exact same position.
Start Recording at Cursor
In this mode, recording starts from the cursor position.
Start Recording at Left Locator/Punch In Position
In this mode, recording starts from the left locator.
RELATED LINKS
Transport Menu on page 232
Transport Panel Sections on page 230

Re-Recording
PROCEDURE
1.

Activate Transport > Common Record Modes > Re-Record.

2.

Activate recording.

3.

Hit Record again to restart recording.

RESULT
The project cursor jumps back to the record start position and recording is reinitiated. Pre-roll
and count-in settings are taken into account.
NOTE
The previous recordings are removed from the project and cannot be retrieved using Undo.
However, they remain in the Pool.

Monitoring
In Nuendo, monitoring means listening to the input signal while preparing to record or while
recording.
The following ways of monitoring are available.
●

Via Nuendo.
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●

Externally by listening to the signal before it reaches Nuendo.

●

By using ASIO Direct Monitoring.
This is a combination of both other methods.

Monitoring via Nuendo
If you use monitoring via Nuendo, the input signal is mixed with the audio playback. This
requires an audio hardware configuration with a low latency value.
PROCEDURE
1.

In the track list, activate Monitor.

2.

In the MixConsole, adjust the monitoring level and the panning.
You can add effects and EQ to the monitor signal using the track’s channel. If you are using
plug-in effects with large inherent delays, the automatic delay compensation function in
Nuendo will increase the latency. If this is a problem, you can use the Constrain Delay
Compensation function while recording.

3.

In the Preferences dialog, select VST.

4.

Open the Auto Monitoring pop-up menu and select a monitoring mode.

RESULT
The monitored signal will be delayed according to the latency value which depends on your
audio hardware and drivers. You can check the latency of your hardware in the Studio Setup
dialog (VST Audio System page).
RELATED LINKS
VST on page 1207

External Monitoring
External monitoring means listening to the input signal before it is sent into Nuendo. It requires
an external mixer for mixing the audio playback with the input signal. The latency value of the
audio hardware configuration does not affect the monitor signal. When using external
monitoring, you cannot control the level of the monitor signal from within Nuendo or add VST
effects or EQ to the monitor signal.
PROCEDURE
1.

In the Preferences dialog, select VST.

2.

Open the Auto Monitoring pop-up menu and select Manual.

3.

Deactivate Monitor in Nuendo.

4.

On your mixing desk or mixer application for your audio hardware, activate the Thru or
Direct Thru mode to send the input audio back out again.

ASIO Direct Monitoring
If your audio hardware is ASIO 2.0 compatible, it may support ASIO Direct Monitoring. This
feature may also be available for audio hardware with macOS drivers. In ASIO Direct Monitoring
mode, the monitoring is done in the audio hardware, and monitoring is controlled from Nuendo.
The latency value of the audio hardware configuration does not affect the monitor signal when
using ASIO Direct Monitoring.
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PROCEDURE
1.

In the track list, activate Monitor.

2.

Select Studio > Studio Setup.

3.

In the Devices list, select your audio hardware driver, and activate Direct Monitoring.
If the checkbox is grayed out, your audio hardware (or its driver) does not support ASIO
Direct Monitoring. Consult the audio hardware manufacturer for details.

4.

In the Preferences dialog, select VST.

5.

Open the Auto Monitoring pop-up menu and select a monitoring mode.

6.

In the MixConsole, adjust the monitoring level and panning.
Depending on the audio hardware, this might not be possible.

AFTER COMPLETING THIS TASK
You can monitor the input levels of audio tracks, that is, you can map the input bus metering to
monitor-enabled audio tracks and watch the input levels of your audio tracks when working in
the Project window.
●

Activate Map Input Bus Metering to Audio Track (in Direct Monitoring) in the
Preferences dialog (Metering page).
As the tracks are mirroring the input bus signal you will see the same signal in both places.
When using mapped metering, any functions that you apply to the audio track are not
reflected in its meters.

NOTE
With Direct Monitoring activated, Direct Routing cannot be used for routing destinations 2-8.
Only the first bus can be used for Direct Monitoring.

RELATED LINKS
VST on page 1207

Monitoring MIDI Tracks
You can monitor everything you play and record though the MIDI output and channel that are
selected for the MIDI track.
PREREQUISITE
Local Off is activated on your MIDI instrument.
PROCEDURE
1.

In the Preferences dialog, select MIDI.

2.

Make sure MIDI Thru Active is activated.

3.

In the track list, activate Monitor.

RESULT
Incoming MIDI is echoed back out again.
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RELATED LINKS
MIDI on page 1195

Audio Recording Specifics
Preparations
Selecting a Record File Format
You can set up the record file format, that is, the sample rate, bit depth, and record file type for
new audio files.
PROCEDURE
1.

Select Project > Project Setup.

2.

Set up the settings for Sample Rate, Bit Depth, and Record File Type.
IMPORTANT
The bit depth and file type can be changed at any time while the sample rate of a project
cannot be changed at a later stage.

RELATED LINKS
Creating New Projects on page 85

Setting the Audio Record Folder
Each Nuendo project has a project folder containing an Audio folder. By default, this is where
recorded audio files are stored. However, you can select record folders independently for each
audio track if needed.
PROCEDURE
1.

In the track list, select all tracks that you want to assign the same record folder.

2.

Right-click one of the tracks to open the context menu.

3.

Select Set Record Folder.

4.

In the file dialog, navigate to the folder that you want to use as record folder or create a
new folder by clicking New Folder.
If you want to have separate folders for different types of material (speech, ambient
sounds, music, etc.), you can create subfolders within the project Audio folder and assign
different tracks to different subfolders. This way, all audio files will still reside within the
project folder, which will make managing the project easier.

Getting the Track Ready for Recording
Creating a Track and Setting the Channel Configuration
PROCEDURE
1.

Select Project > Add Track > Audio.

2.

In the Count field, enter the number of tracks that you want to add.

3.

Open the Configuration pop-up menu and select a channel configuration.

4.

Optional: Enter a track name.
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5.

Click Add Track.

RELATED LINKS
Add Track Dialog on page 158

RAM Requirements for Recording
Each track on which you record requires a certain amount of RAM, and the memory usage
increases the longer the recording lasts. For each audio channel, 2.4 MB of RAM are required for
MixConsole settings, etc. The memory usage increases with the length of the recording, the
sample rate, and the number of tracks you record. Consider the RAM limitation of your operating
system when setting up your project for recording.

Selecting an Input Bus for the Track
Before you can record on your track, you must add and set up the required input busses and
specify from which input bus the track will record.
PROCEDURE
1.

In the Inspector for the audio track, open the Input Routing pop-up menu.

2.

Select an input bus.

RELATED LINKS
Setting Up Input and Output Ports on page 18
Audio Bus Setup on page 18
Audio Track Inspector on page 101

Recording Audio
You can record audio using any of the basic recording methods.
When you finish recording, an audio file is created in the Audio folder within the project folder.
In the Pool, an audio clip is created for the audio file, and an audio event that plays the whole clip
appears on the recording track. Finally, a waveform image is calculated for the audio event. If the
recording was very long, this may take a while.
NOTE
The waveform image will be calculated and displayed during the actual recording process. This
realtime calculation uses some processing power. If your processor is slow or if you are working
on a CPU-intensive project, deactivate Create Audio Images During Record in the Preferences
dialog (Record—Audio page).

RELATED LINKS
Basic Recording Methods on page 259
Cycle Recording on page 261
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Audio Record Modes
By selecting an Audio Record Mode you decide what happens to your recording and to any
existing events on the track where you are recording. This is necessary because you will not
always record on an empty track. There may be situations where you record over existing events,
especially in cycle mode.
●

To access the record modes, select Transport > Audio Record Mode.
You can also access the Audio Record Modes by clicking to the right of the audio symbol
in the Record Modes section in the Transport panel.

Keep History
Existing events or portions of events that are overlapped by a new recording are
kept.
Cycle History + Replace
Existing events or portions of events that are overlapped by a new recording are
replaced by the new recording. However, if you record in cycle mode, all takes from
the current cycle recording are kept.
Replace
Existing events or portions of events that are overlapped by a new recording are
replaced by the last recorded take.
RELATED LINKS
Transport Menu on page 232
Transport Panel Sections on page 230

Recording with Effects
Nuendo allows you to add effects and/or EQ directly while recording. This is done by adding
insert effects and/or making EQ settings for the input channel in the MixConsole.
IMPORTANT
If you record with effects, the effects become part of the audio file itself. You cannot change the
effect settings after recording.
When you are recording with effects, consider using 32-bit float or 64-bit float format. This way,
the bit depth will not be reduced, which means there is no risk of clipping at this stage. Also, this
preserves the signal quality perfectly. If you record in 16-bit or 24-bit format, the available
headroom is lower, which means clipping can occur if the signal is too loud.

Recording a Mix of Separate Tracks
You can create a downmix of separate tracks, bass drum, hi-hats, or snare, for example. This is
done by selecting an output bus, a group bus, or an FX channel bus as an input for your
recording.
PROCEDURE
1.

Set up your separate tracks and add a group track.

2.

For each of the drum tracks, open the Output Routing pop-up menu and select the group
track as output.

3.

Create a new audio track, open the Input Routing pop-up menu for it and select the
group track as input for this audio track.

4.

Record-enable this audio track and start recording.
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RESULT
The output of the group track will be recorded on the new track and you will get a mix of your
separate tracks.
NOTE
You can also select an FX channel as recording source. In this case, only the output of the FX
channel will be recorded.

RELATED LINKS
Routing on page 393

Undoing Recording
If you decide that you do not like what you just recorded, you can delete it.
●

Select Edit > Undo.

This removes the events that you just recorded from the Project window and moves the audio
clips in the Pool to the trash folder. To remove the recorded audio files from the hard disk, open
the Pool, right-click the Trash icon and select Empty Trash.
RELATED LINKS
Pool Window on page 586

Recovering Audio Recordings
Nuendo allows you to recover audio recordings in two situations: if you specified an audio prerecord time when you hit Record too late and after a system failure during recording.

Specifying an Audio Pre-Record Time
You can capture up to 1 minute of any incoming audio that you play in Stop mode or during
playback. This is possible because Nuendo can capture audio input in buffer memory, even when
not recording.
PROCEDURE
1.

In the Preferences dialog, select Record > Audio.

2.

Specify a time (up to 60 seconds) in the Audio Pre-Record Seconds field.
This activates the buffering of audio input, making pre-record possible.

3.

Make sure that an audio track is record-enabled and receives audio from the signal source.

4.

When you have played some audio material that you want to capture (either in Stop mode
or during playback), click Record.

5.

Stop the recording after a few seconds.
This creates an audio event that starts where the cursor position was when you activated
recording. If you were in stop mode, and the cursor was at the beginning of the project,
you may have to move the event to the right in the next step. If you were playing along to
a project, you leave the event where it is.

6.

Select the Object Selection tool and place the cursor on the bottom left edge of the event
so that a double arrow appears. Then click and drag to the left.

RESULT
The event is now extended, and the audio that you played before activating the recording is
inserted. This means that if you played along during playback, the captured notes end up exactly
where you played them in relation to the project.
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RELATED LINKS
Record - Audio on page 1201

Recovering Audio Recordings after System Failure
Nuendo allows you to recover audio recordings after a system failure, because of a power cut or
other mishap, for example.
When you experience a computer crash during a recording, relaunch the system and check the
project record folder. By default, this is the Audio subfolder inside the project folder. It should
contain the audio file that you recorded, from the moment when you started recording to the
time when your computer crashed.
NOTE
●

This feature does not constitute an overall guarantee by Steinberg. While the program
itself was improved in such a way that audio recordings can be recovered after a system
failure, it is always possible that a computer crash, power cut, etc. might have damaged
another component of the computer, making it impossible to save or recover any of the
data.

●

Do not try to actively bring about this kind of situation to test this feature. Although the
internal program processes have been improved to cope with such situations, Steinberg
cannot guarantee that other parts of the computer are not damaged as a consequence.

MIDI Recording Specifics
Preparations
The preparations described in the following sections mainly focus on external MIDI devices.

MIDI Instruments and Channels
Most MIDI synthesizers can play several sounds at the same time, each on a different MIDI
channel. This allows you to play back several sounds (bass, piano, etc.) from the same
instrument.
Some devices, such as General MIDI compatible sound modules, always receive on all 16 MIDI
channels. If you have such an instrument, there is no specific setting to make in the instrument.
On other instruments, you must use the front panel controls to set up a number of parts,
timbres, or similar so that they all receive on one MIDI channel.
For more information, refer to the manual that came with your instrument.

Naming MIDI Ports
MIDI inputs and outputs are often displayed with long and complicated names. In Nuendo, you
can rename your MIDI ports to more descriptive names.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select MIDI Port Setup.
The available MIDI inputs and outputs are listed. On Windows, the device to choose
depends on your system.

3.

Click in the Show As column and type in a new name.

4.

Click OK.
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RESULT
The new port names appear on the MIDI Input and Output Routing pop-up menus.

Setting the MIDI Input
In the Inspector, you set the MIDI input for the track.
PROCEDURE
1.

In the track list, select the track to which you want to assign a MIDI input.

2.

In the topmost Inspector section, open the Input Routing pop-up menu and select an
input.
The available inputs on the menu depend on the type of MIDI interface that you are using.
If you hold down Shift-Alt, the selected MIDI input is used for all selected MIDI tracks.
NOTE
If you select All MIDI Inputs, the track will receive MIDI data from all available MIDI
inputs.

Setting the MIDI Channel and Output
The MIDI channel and output settings determine where the recorded MIDI is routed during
playback. They are also relevant for monitoring MIDI in Nuendo. You can select the channel and
output in the track list or in the Inspector.
PROCEDURE
1.

In the track list, select the track to which you want to assign a MIDI channel and output.

2.

In the topmost Inspector section, open the Output Routing pop-up menu and select an
output.
The available outputs on the menu depend on the type of MIDI interface that you are
using. If you hold down Shift-Alt, the selected MIDI output is used for all selected MIDI
tracks.

3.

Open the Channel pop-up menu and select a MIDI channel.
NOTE
If you select the Any MIDI channel, the MIDI material is routed to the channels that are
used by your MIDI instrument.

Selecting a Sound
You can select sounds from within Nuendo by instructing the program to send Program Change
and Bank Select messages to your MIDI device.
PROCEDURE
1.

In the track list, select the track to which you want to assign a sound.

2.

In the track list or the Inspector, open the Program Selector pop-up menu and select a
program.
Program Change messages give access to 128 different program locations.

3.

If your MIDI instruments have more than 128 programs, you can open the Bank Selector
pop-up menu and select different banks, each containing 128 programs.
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NOTE
Bank Select messages are recognized differently by different MIDI instruments. The
structure and numbering of banks and programs may also vary. Refer to the
documentation of your MIDI instruments for details.

RELATED LINKS
MIDI Track Inspector on page 116

Recording in MIDI Editors
You can record MIDI data into the MIDI part that is opened in a MIDI editor.
PREREQUISITE
You have selected Merge or Replace as a MIDI Record Mode.
PROCEDURE
1.

Click in the MIDI editor so that it gets the focus.

2.

In the MIDI editor toolbar, activate Record in Editor.

3.

Do one of the following to activate recording:
●

Click Record on the Transport panel.

●

Click Record on the toolbar.

RESULT
The MIDI data is recorded into the MIDI part that is opened in the MIDI editor. If you record
outside the part borders, the part is automatically enlarged.
RELATED LINKS
Toolbar on page 806

Recording MIDI
You can record MIDI using any of the basic recording methods.
When you finish recording, a part that contains MIDI events is created in the Project window.
NOTE
If you perform a live recording on a VST instrument, you usually compensate the latency of the
audio card by playing earlier. In consequence, the timestamps are recorded too early. If you
activate ASIO Latency Compensation on the track list, all recorded events are moved by the
current latency setting.
The following preferences affect MIDI recording:
●

Length Adjustment

●

Snap MIDI Parts to Bars

●

MIDI Record Catch Range in ms

●

ASIO Latency Compensation Active by Default

You can find them in the Preferences dialog on the MIDI and on the Record—MIDI page.
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RELATED LINKS
Basic Recording Methods on page 259
MIDI on page 1195
Record - MIDI on page 1202

Recording Different Types of MIDI Messages
You can record different types of MIDI messages.
●

To specify which event types are recorded, deactivate the options for the type of MIDI
message that you want to record in the Preferences dialog (MIDI—MIDI Filter page).

RELATED LINKS
MIDI - MIDI Filter on page 1199

Recording MIDI Notes
If you press and release a key on your synthesizer or on another MIDI keyboard, the following
messages are recorded:
●

Note On (key down)

●

Note Off (key up)

●

MIDI channel

NOTE
Normally, the MIDI channel information is overridden by the MIDI channel setting for the track.
However, if you set the track to the Any MIDI channel, the notes will be played back on their
original channels.

Recording Continuous Messages
Pitchbend, aftertouch, and controllers, such as modulation wheel, sustain pedal, volume, etc. are
considered as MIDI continuous events, as opposed to the momentary key down and key up
messages.
You can record continuous messages together or independently from the notes, that is,
afterwards or before.
You can record continuous messages on their own tracks, separately from the notes to which
they belong. As long as you set the two tracks to the same output and MIDI channel, it will
appear to the MIDI instrument as if you made the two recordings at the same time.

Recording Program Change Messages
When you switch from one program to another on your synthesizer or on another MIDI
keyboard, a number corresponding to that program is sent out via MIDI as a Program Change
message.
You can record Program Change Messages together or independently from the notes, that is,
afterwards or before.
You can record Program Change Messages on their own tracks, separately from the notes to
which they belong. As long as you set the two tracks to the same output and MIDI channel, it will
appear to the MIDI instrument as if you made the two recordings at the same time.
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Recording System Exclusive Messages
System Exclusive (SysEx) messages are special types of MIDI messages that are used to send
data that only makes sense to a unit of a certain make and type.
SysEx can be used to transmit a list of the numbers that make up the settings of one or more
sounds in a synth.

Reset Function
The Reset function sends out note-off messages and resets controllers on all MIDI channels. This
is sometimes necessary if you experience hanging notes, constant vibrato, etc. when punching in
and out on MIDI recordings with pitchbend or controller data.
●

To perform a MIDI reset manually, select MIDI > Reset.

●

If you want Nuendo to perform a MIDI reset on stop, activate Reset on Stop in the
Preferences dialog (MIDI page).

●

If you want Nuendo to insert a reset event at the end of a recorded part, activate Insert
Reset Events after Record in the Preferences dialog (MIDI page).
This resets controller data such as sustain, aftertouch, pitchbend, modulation, and breath
control. This is useful if a MIDI part is recorded and the sustain pedal is still held after
stopping recording. Usually, this would cause all following parts to be played with sustain,
as the pedal off command was not recorded.

RELATED LINKS
MIDI on page 1195

MIDI Record Modes
By selecting a MIDI Record Mode you decide what happens to any existing parts on the track
where you are recording. MIDI tracks can play back all events in overlapping parts. If you record
several parts in the same locations or move parts so that they overlap, you will hear the events in
all parts.
●

To access the record modes, select Transport > MIDI Record Mode.
You can also access the MIDI Record Modes by clicking to the right of the MIDI symbol in
the Record Modes section in the Transport panel.

MIDI Record Mode
New Parts
Existing parts that are overlapped by a new recording are kept. The new recording is
saved as a new part.
Merge
Existing events in parts that are overlapped by a new recording are kept. The newly
recorded events are added to the existing part.
Replace
Existing events in parts that are overlapped by a new recording are replaced.
NOTE
In Merge or Replace mode you can activate Record in Editor to record MIDI data in the editor.
For this to work, the editor must have the focus. Otherwise, the data is recorded on the MIDI
track in the Project window.
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MIDI Cycle Record Mode
When you record MIDI in cycle mode, the result not only depends on the MIDI record mode, but
also on the cycle record mode that is selected in the MIDI Cycle Record Mode section.
Mix
For each completed lap, everything you record is added to what was previously
recorded. This is useful for building up rhythm patterns. Record a hi-hat part on the
first lap, the bass drum part on the second lap, etc.
Overwrite
As soon as you play a MIDI note or send any MIDI message, all MIDI that you have
recorded on previous laps is overwritten from that point. Make sure that you stop
playing before the next lap begins. Otherwise, you will overwrite the entire take.
Keep Last
Each completed lap replaces the previously recorded lap. If you deactivate recording
or press Stop before the cursor reaches the right locator, the previous take will be
kept. If you do not play or input any MIDI during a lap, nothing happens, and the
previous take will be kept.
Stacked
Each recorded cycle lap is turned into a separate MIDI part, and the track is divided
into lanes, one for each cycle lap. The parts are stacked above each other, each on a
different lane. All takes but the last one are muted.
Mix Stacked
Same as Stacked, but parts are not muted.
RELATED LINKS
Transport Menu on page 232
Transport Panel Sections on page 230

Quantizing MIDI Recordings
Nuendo can automatically quantize MIDI notes on recording.

●

To enable automatic quantizing, open the Transport panel and in the Record Mode
section, click in the MIDI Record Modes field, and activate Auto Quantize.
The notes that you record are automatically quantized according to the quantize settings.

RELATED LINKS
Quantizing MIDI and Audio on page 287
Quantize Panel on page 291
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Recovering MIDI Recordings
Nuendo allows you to recover MIDI recordings.

Enabling Retrospective MIDI Record
The Retrospective MIDI Record setting allows you to capture any MIDI notes that you play in
Stop mode or during playback and turn them into a MIDI part after the fact. This is possible
because Nuendo can capture MIDI input in buffer memory, even when not recording.
PROCEDURE
1.

In the Preferences dialog, select Record > MIDI.

2.

Enable Retrospective Record and specify a Retrospective Record Buffer Size.
This activates the buffering of MIDI input.

3.

In the MIDI track list, activate Record Enable.

4.

Play some MIDI material either in Stop mode or during playback.

5.

Select Transport > Retrospective MIDI Record.

RESULT
The content of the MIDI buffer is turned into a MIDI part on the record-enabled track, and the
captured notes end up exactly where you played them in relation to the project.
RELATED LINKS
Record - MIDI on page 1202

Remaining Record Time
The Max. Record Time display lets you see how much time you have left for recording.

The available time depends on the current setup, for example, on the amount of tracks that are
record-enabled, the sample rate for your project, and the available hard disk space.
●

To open the display, select Studio > More Options > Max. Record Time.

NOTE
The remaining record time is also shown in the status line above the track list.
If you use individual record folders to store your tracks on different drives, the time display refers
to the medium with the least storage space available.

Lock Record
The Lock Record function prevents you from accidentally deactivating the record mode.
●

Select File > Key Commands and in the Transport category, assign key commands to the
Lock Record and Unlock Record commands.

If Lock Record is activated and you want to enter Stop mode, a dialog opens in which you need
to confirm that you want to stop recording. You can also use the Unlock Record key command
first and then enter Stop mode as usual.
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NOTE
An automatic punch out at the right locator position will be ignored in Lock Record mode.
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You can add audio and MIDI files to your project by importing them.

Importing Audio Files
You can import compressed and uncompressed audio files in a variety of different formats. You
can also import audio from audio CDs or extract the audio of video files.
RELATED LINKS
Importing Media on page 599

Setting Up Audio File Import Options
You can specify how audio files should be handled on import.
PROCEDURE
1.

In the Preferences dialog, select Editing > Audio.

2.

Select an option from the On Import Audio Files pop-up menu.

3.

Click OK.

RESULT
The import settings are saved and will take effect when you import audio. If you selected Open
Options Dialog, the Import Options dialog opens on every import and allows you to make your
settings. If you selected Use Settings, the settings specified in the On Import Audio Files
section of the Preferences dialog are used.
RELATED LINKS
Import Options for Audio Files on page 277
On Import Audio Files Settings on page 278

Import Options for Audio Files
The Import Options dialog allows you to make specific settings for the audio import.
●

When you import audio files and Open Options Dialog is activated in the On Import
Audio Files section of the Preferences dialog (Editing—Audio page), the Import Options
dialog opens.
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Copy Files to Working Directory
Copies the audio file to the Audio folder of the project, and has the clip refer to the
copy.
Deactivate this option to have the clip refer to the original file in the original location.
In this case, it is marked as “external” in the Pool.
Convert and Copy to Project if Needed
Converts the imported file if the sample rate or the bit depth differ from the settings
in the Project Setup dialog.
Split Channels/Split Multi Channel Files
Splits stereo or multi channel audio files into a corresponding number of mono files,
one for each channel, and copies the imported files to the Audio folder of the
project.
Inserts the split files into the project and into the Pool as separate mono tracks.
The Split File Name Format pop-up menu allows you to specify how the split files
are named. This allows for compatibility with other products when exchanging audio
files.
Please, don’t ask again
Always imports files according to the settings, without opening the dialog again. You
can reset this option in the Preferences dialog (Editing—Audio page).
RELATED LINKS
Setting Up Audio File Import Options on page 277

On Import Audio Files Settings
You can set up standard settings that are performed automatically each time you import audio
files.

●

If you import audio files and Use Settings is activated in the On Import Audio Files
section of the Preferences dialog (Editing—Audio page), the following settings are used
for importing audio:

Copy Files to Working Directory
Copies the audio file to the Audio folder of the project, and has the clip refer to the
copy.
Deactivate this option to have the clip refer to the original file in the original location.
In this case, it is marked as “external” in the Pool.
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Convert and Copy to Project if Needed
Converts the imported file if the sample rate or the bit depth differ from the settings
in the Project Setup dialog.
Split Channels/Split Multi Channel Files
Splits stereo or multi channel audio files into a corresponding number of mono files,
one for each channel, and copies the imported files to the Audio folder of the
project.
Inserts the split files into the project and into the Pool as separate mono tracks.
The Split File Name Format pop-up menu allows you to specify how the split files
are named. This allows for compatibility with other products when exchanging audio
files.

Importing Audio Files
You can import uncompressed audio and compressed audio in several formats.
PROCEDURE
1.

Select File > Import > Audio File.

2.

In the file dialog that opens, locate and select the audio file and click Open.

3.

Make your settings in the Import Options dialog.
NOTE
If Use Settings is activated in the Preferences dialog (Editing—Audio page), the
corresponding import settings are used.

RESULT
In the Project window, an event referencing the audio file is inserted on the selected track at the
project cursor position. If no track was selected, a new track is created.
A new audio clip is created and added to the Pool.
If you chose a compressed audio file other than FLAC, Nuendo copies the original compressed
file and converts it to wave format (Windows) or AIFF format (macOS).
NOTE
The resulting Wave/AIFF file is significantly larger than the original compressed file.
The imported file is placed in the Audio folder of the project.
RELATED LINKS
Setting Up Audio File Import Options on page 277

Supported Compressed Audio File Formats
EXAMPLE
The following compressed audio file formats are supported:
●

FLAC File
This is an open source format that reduces the size of audio files by 50 to 60 % compared
to regular Wave files. The files have the extension .flac.

●

MPEG
This is a family of standards used for encoding audio-visual information such as movies,
video, and music in a digital compressed format. Nuendo can read MPEG Layer 2 and
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MPEG Layer 3. MP3 files are highly compressed files that still provide good audio quality.
The files have the extension .mp3.
●

Ogg Vorbis File
This is an open source, patent-free audio encoding and streaming technology. The Ogg
Vorbis encoder uses variable bit rate encoding. It offers compressed audio files of small
size, but with comparatively high audio quality. The files have the extension .ogg.

●

Windows Media Audio File (Windows only)
This is an audio file format defined by Microsoft Inc. WMA files can be decreased in size
with no loss of audio quality. WMA Pro features the possibility of mixing down to 5.1
surround sound. The files have the extension .wma.

Importing Audio CD Tracks
You can import audio from audio CDs into Nuendo projects.
PROCEDURE
1.

Select File > Import > Audio CD to import the CD tracks into the Project window.

2.

Activate the Copy column for every audio file you want to import.

3.

Optional: Set a Default Name and a Destination Folder for the imported audio files.

4.

Click the Copy button to create a local copy of the audio files or sections.

5.

Click OK.

RESULT
The copied audio files are imported into the Project window and inserted on new tracks at the
project cursor position. By default, imported audio CD tracks are saved as wave files (Windows)
or AIFF files (macOS) in the Audio folder of the current project.
New audio clips are created and added to the Pool.
NOTE
You can also import audio files to the Pool only without importing them into the Project window.

RELATED LINKS
Importing Media on page 599
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Import From Audio CD
The Import from Audio CD dialog allows you to specify how the CD tracks are imported.

Drive
Opens a pop-up menu that allows you to select the correct CD drive.
Speed
Allows you to select the data transfer speed (Windows only).
NOTE
While you normally want to use the fastest possible speed, you may have to select a
slower speed for flawless audio extraction.
Eject CD
Opens the CD drive.
Secure Mode
Activates error checking and correction when reading the CD (Windows only).

Columns
The columns in the dialog have the following functions:
Copy
Activate this option for the tracks that you want to copy/import.
#
Shows the track number.
CD Track
The name of the CD track. On import, this is used as file name. It is provided
automatically from CDDB, if available.
To rename a track, click the track name and type in a new name.
Length
The length of the audio CD track in minutes and seconds.
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Size
The file size of the audio CD track in MB.
Copy Start
The start of the section that is imported. On the ruler, drag to the right to adjust this.
Copy End
The end of the section that is imported. On the ruler, drag to the left to adjust this.

The Ruler
The ruler has the following functions:

1

Play Tracks
Plays back the selected track from the start to the end or from the left marker to the right
marker.

2

Stop Playback
Stops playback.

3

Play from Left Marker
Starts playback at the left marker.

4

Play to Right Marker
Starts playback some moments before the right marker and stops at the right marker.

5

Left Marker
Allows you to set the copy start manually.

6

Right Marker
Allows you to set the copy end manually.

Destination Folder
Allows you to select a folder for the imported files.
Copy
Copies the files.
Copied Files
Lists the files that you copied for import.

Importing Audio from Video Files
You can import the audio from a video file without importing the video itself.
PROCEDURE
1.

Select File > Import > Audio from Video File.

2.

In the file dialog that opens, locate and select the video file, and click Open.

RESULT
The audio of the selected video file is extracted and converted to a wave file that is saved in the
Audio folder.
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A new audio clip is created and added to the Pool. In the Project window, an event referencing
the audio file is inserted on the selected track at the project cursor position. If no track was
selected, a new track is created.
RELATED LINKS
Extract Audio from Video on page 1083
Importing Video Files on page 1078

Importing ReCycle Files
You can import REX and REX 2 audio files created by ReCycle from Propellerhead Software.
ReCycle slices a loop and creates separate samples of each beat, so that you can tempo match
and edit a loop as if it was built of individual sounds.
PREREQUISITE
REX Shared Library is installed on your system.
PROCEDURE
1.

Select an audio track and move the project cursor to where you want the imported file to
start.
You probably want to import REX files to audio tracks that are set to musical time base,
because this will allow you to change the tempo later on (having the imported REX file
automatically adjust).

2.

Select File > Import > Audio File.

3.

In the file dialog, open the file type pop-up menu and select REX File or REX 2 File.

4.

Select the file you want to import, and click Open.

RESULT
The file is imported and automatically adjusted to the current Nuendo tempo.
The imported REX file consists of several events, one for each slice in the loop. The events are
automatically placed in an audio part on the selected track and positioned so that the original
internal timing of the loop is preserved.
AFTER COMPLETING THIS TASK
Open the part in the Audio Part Editor to edit each slice separately by muting, moving, and
resizing events, adding effects and processing, for example.
You can also adjust the tempo and have the REX file automatically follow, provided that its track
is set to a musical time base.
NOTE
You can achieve similar results by using Nuendo’s own loop slicing features.

RELATED LINKS
Slices on page 526

Importing Clip Packages
You can import clip packages. Clip packages are sound combinations that you create by
arranging, editing, and grouping audio events or parts in the Project window.
PROCEDURE
1.

Select File > Import > Clip Package.
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2.

In the file dialog that opens, locate and select the clip package and click Open.

3.

In the dialog that appears, select if you want to import automation data of the clip
package.

RESULT
In the Project window, the events of the clip package are inserted and grouped. The first event is
inserted on the selected track. If no track is selected, new tracks are added below the existing
tracks and the events are inserted on these.
The audio parts and events are copied to the project folder.
If the sample rate of the audio files within the clip package does not correspond to the sample
rate of the project into which it is inserted, the files are automatically converted to the project
sample rate.
If automation data for volume and pan was saved in the clip package, a corresponding
automation curve is created together with the event.
Automation data for the VST MultiPanner is only applied correctly on import if a target track with
the correct surround format is selected.
RELATED LINKS
Clip Packages on page 196
Importing Media on page 599
Show Media Types Selector on page 620
Previewing Clip Packages on page 627
Pool Window on page 586
VST MultiPanner on page 654

Importing MIDI Files
Nuendo can import standard MIDI files. This allows you to transfer MIDI material to and from
virtually any MIDI application on any platform.

Import Options for MIDI Files
The Import Options for MIDI files allow you to specify what data is included in imported MIDI
files.

Extract First Patch
Converts the first Program Change and Bank Select events for each track to
Inspector settings for the track.
Extract First Volume/Pan
Converts the first MIDI Volume and Pan events for each track to Inspector settings
for the track.
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Import Controller as Automation Tracks
Converts MIDI Controller events in the MIDI file to automation data for the MIDI
tracks. If this option is deactivated, controller data for the MIDI parts will be
imported.
Import to Left Locator
Aligns the imported MIDI file at the position of the left locator. If this option is
deactivated, MIDI files start at the project start position. If you choose to have a new
project created automatically, the MIDI file always starts at the project start position.
Import Markers
Imports Standard MIDI File Markers in the file and converts them to Nuendo
markers.
Import Dropped File as Single Part
Places the file on one track if you drag and drop a MIDI file into the project.
Ignore Master Track Events on Merge
Ignores tempo track data if you import a MIDI file into the current project. The
imported MIDI file will play according to the current Tempo track in the project.
If this option is deactivated, the Tempo Track Editor will be adjusted according to
the tempo information in the MIDI file.
Auto Dissolve Format 0
Automatically dissolves imported MIDI files of type 0. Each embedded MIDI channel
in the file is placed on a separate track in the Project window.
If this option is deactivated, only one MIDI track is created. This track is set to MIDI
channel Any, allowing all MIDI events to play back on their original channels. You can
also use the Dissolve Part function on the MIDI menu to distribute the events onto
different tracks (or lanes) with different MIDI channels at a later stage.
Destination
Allows you to specify what happens when you drag a MIDI file into the project:
●

MIDI Tracks creates MIDI tracks for the imported file.

●

Instrument Tracks creates instrument tracks for each MIDI channel in the
MIDI file and lets the program automatically load appropriate presets.

●

HALion Sonic SE multi-timbral creates several MIDI tracks, each routed to a
separate instance of HALion Sonic SE in the VST Instruments window, and
loads the appropriate presets.

Import Karaoke Lyrics as Text
Converts karaoke lyrics in the MIDI file to text that can be displayed in the Score
Editor. If this option is deactivated, lyrics are only shown in the List Editor.

Importing MIDI Files
PROCEDURE
1.

Select File > Import > MIDI File.

2.

Optional: If a project is open, choose if you want to create a new project.
If you select No, the MIDI file is imported into the current project.

3.

In the file dialog that opens, locate and select the MIDI file and click Open.

RESULT
The MIDI file is imported. The result depends on the contents of the MIDI file and the setting you
made in the Import Options section in the Preferences dialog (MIDI—MIDI File page).
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It is also possible to import a MIDI file from disk by dragging and dropping it from the File
Explorer/macOS Finder into the Project window. The Import Options apply as well.
RELATED LINKS
Import Options for MIDI Files on page 284
Markers on page 334

Yamaha XF Format
Nuendo supports the Yamaha XF format. XF is an extension of the standard MIDI file format that
allows you to save song-specific data with a MIDI file of type 0.
When importing a MIDI file containing XF data, this data is placed in parts on separate tracks
called XF Data, Chord Data, or SysEx Data. You can edit such a part in the List Editor to add or
change lyrics, for example.
IMPORTANT
Do not change the order of events within the XF data or the event data itself, unless you have a
lot of experience with XF data.
Nuendo can also export XF data as part of a MIDI file of type 0. If you do not want to export the
XF data together with the MIDI data, mute or delete the tracks containing the XF data.

MIDI Loops
In Nuendo, you can import MIDI loops.
To import MIDI loops, use the MediaBay. MIDI loops have the file extension .midiloop.
RELATED LINKS
Importing MIDI Loops on page 732
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Quantizing means moving recorded audio or MIDI and positioning it on the nearest grid position
that is musically relevant. Quantizing is designed to correct errors, but you can also use it in a
creative way.
You can quantize audio and MIDI to a grid or to a groove. You can also quantize multiple audio
tracks simultaneously.
Audio and MIDI can be quantized at the same time. However, what exactly happens during
quantizing differs for audio and MIDI:
●

Audio quantizing affects the audio event starts or the content of your audio.

●

MIDI quantizing can affect the starts of MIDI events in a part, the MIDI event lengths, or
the MIDI event ends.

NOTE
Quantizing is based on the original position of the events. Therefore, you can freely try out
different quantize settings without the risk of destroying anything.

RELATED LINKS
Quantizing Audio Event Starts on page 289
Quantizing Audio Event Lengths (AudioWarp Quantizing) on page 290
Quantizing MIDI Event Starts on page 288
Quantizing MIDI Event Lengths on page 289
Quantizing MIDI Event Ends on page 289

Quantize Functions
The quantize functions are available in the Edit menu and in the Snap/Quantize section of the
Project window toolbar.

Quantize Functions on the Edit Menu
Quantize
Quantizes audio or MIDI event starts.
Reset Quantize
Reverts your audio or MIDI to its original, unquantized state, and resets any length
changes that you performed using the Scale Length/Legato slider in the Quantize
Panel.
Quantize Panel
Opens the Quantize Panel.
Advanced Quantize
From this submenu you can select the following functions:
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●

Quantize MIDI Event Lengths
Cuts off the ends of selected MIDI events so that the events match the length
quantize value. The start positions are kept.

●

Quantize MIDI Event Ends
Moves the ends of MIDI events to the nearest grid positions.

●

Freeze MIDI Quantize
Makes the start and end positions of MIDI events permanent. This function is
useful in situations where you want to quantize a second time, based on the
current quantized positions rather than the original positions.

●

Create Groove Quantize Preset
Creates a groove quantize map based on hitpoints that you have created in
the Sample Editor.

Quantize Functions on the Project Window Toolbar

1

Iterative Quantize On/Off
Activates/Deactivates iterative quantize.

2

AudioWarp Quantize On/Off
Activates AudioWarp quantizing.

3

Quantize Presets
Allows you to select a quantize or a groove preset.

4

Apply Quantize
Applies the quantize settings.

5

Open Quantize Panel
Opens the Quantize Panel.

Quantizing MIDI Event Starts
PREREQUISITE
You have set up a quantize grid on the Quantize Presets pop-up menu on the Project window
toolbar.
PROCEDURE
1.

2.

Perform one of the following actions:
●

In the Key Editor, select the MIDI events that you want to quantize.

●

In the Project window, select a MIDI part.

Select Edit > Quantize.

RESULT
The starts of the selected MIDI events or all events of the selected MIDI part are quantized.
Events that do not match exact note positions are moved to the closest grid position. The note
lengths are maintained.
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Quantizing MIDI Event Lengths
PREREQUISITE
You have set up a length quantize value on the Length Quantize pop-up menu on the Key
Editor toolbar.
PROCEDURE
1.

2.

Perform one of the following actions:
●

In the Key Editor, select the MIDI events that you want to quantize.

●

In the Project window, select a MIDI part.

Select Edit > Advanced Quantize > Quantize MIDI Event Lengths.

RESULT
The ends of the selected MIDI events are cut off so that the events match the length quantize
value. The start positions are kept.
NOTE
If you have selected Quantize Link, the events are resized according to the grid that is set up in
the Quantize Presets pop-up menu. The Swing, Tuplet, and Catch Range settings on the
Quantize Panel are taken into account.

Quantizing MIDI Event Ends
PREREQUISITE
You have set up a quantize grid on the Quantize Presets pop-up menu on the Project window
toolbar.
PROCEDURE
1.

2.

Perform one of the following actions:
●

In the Key Editor, select the MIDI events that you want to quantize.

●

In the Project window, select a MIDI part.

Select Edit > Advanced Quantize > Quantize MIDI Event Ends.

RESULT
The ends of the MIDI events are moved to the nearest grid positions.

Quantizing Audio Event Starts
PREREQUISITE
You have set up a quantize grid on the Quantize Presets pop-up menu on the Project window
toolbar.
PROCEDURE
1.

In the Project window, select an audio event, a sliced loop, or an audio part.

2.

Select Edit > Quantize.
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RESULT
The event snap point, or, if not available, the start of the audio event, is quantized. Event starts
that do not match exact note positions are moved to the closest grid positions.
NOTE
If you use the Quantize function on an audio part, the starts of the events inside the part are
quantized.

Quantizing Audio Event Lengths (AudioWarp Quantizing)
You can quantize an audio event or an audio selection range by applying time stretch to the
content of the audio event.
PROCEDURE
1.

Perform one of the following actions:
●

Select the audio event that you want to quantize.

●

Select a range of the event that you want to quantize.

2.

On the toolbar, activate AudioWarp Quantize.

3.

Perform one of the following actions:

4.

●

Click Quantize Presets, and select a quantize grid preset from the pop-up menu.

●

Click Open Quantize Panel, and define the quantize grid with the available
parameters.

Select Edit > Quantize.

RESULT
The audio event is quantized, that is, its warp markers are aligned with the quantize grid by
applying time stretch, and the audio sections between the warp markers are stretched or
compressed to fit into the time interval that you set up on the Quantize Presets pop-up menu.
NOTE
If you use a quantize value of 1/4 on audio that is based on 16th notes, the warp markers at the
1/4 note positions are quantized to the grid, and the remaining warp markers are moved,
keeping the relative distances between the warp markers.

RELATED LINKS
Quantize Panel on page 291
Slices on page 526

Quantizing Multiple Audio Tracks
You can quantize multiple audio tracks at the same time.
PROCEDURE
1.

Select Project > Add Track > Folder.

2.

Move all audio tracks that you want to quantize into the folder track.
NOTE
The audio on all tracks must have the same start and end positions.
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3.

Select the folder track and activate Group Editing in the track list.

4.

On the Project window toolbar, click Open Quantize Panel to open the Quantize Panel.

5.

Make your settings in the Slice Rules section of the Quantize Panel, and click Slice.
The audio events in the edit group are sliced.

6.

Make your settings in the quantize section of the Quantize Panel, and click Quantize.
The sliced events are quantized.

7.

Optional: to correct overlaps or gaps in the quantized audio, make your settings in the
Crossfades section of the Quantize Panel, and click Crossfade.

RESULT
The audio events are quantized.
RELATED LINKS
Quantize Panel on page 291
Group Editing Mode on page 216

AudioWarp Quantizing Multiple Audio Tracks
You can use warp markers for quantizing multiple audio tracks. However, AudioWarp quantizing
does not maintain phase coherence.
PROCEDURE
1.

Select Project > Add Track > Folder.

2.

Move all audio tracks that you want to quantize into the folder track.
NOTE
The audio on all tracks must have the same start and end positions.

3.

Select the folder track and activate Group Editing in the track list.

4.

On the Project window toolbar, activate AudioWarp Quantize On/Off.

5.

Click Open Quantize Panel to open the Quantize Panel.

6.

Make your settings in the Warp Marker Creation Rules section of the Quantize Panel,
and click Create.

7.

Make your settings in the quantize section of the Quantize Panel, and click Quantize.

RESULT
AudioWarp quantizing is applied to all tracks in the edit group.
RELATED LINKS
Quantize Panel on page 291
Group Editing Mode on page 216

Quantize Panel
The Quantize Panel allows you to define how to quantize audio or MIDI to the grid or to a
groove. Depending on what method you choose, different parameters are shown.
To open the Quantize Panel, perform one of the following actions:
●

Click Open Quantize Panel on the toolbar.

●

Select Edit > Quantize Panel.
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Quantize Presets
To the top of the Quantize Panel the quantize presets are shown. Here, you can load and save
presets that include all settings for quantizing.

Select Preset
Allows you to select a preset.
Save Preset
Allows you to save the current settings as a preset, so that they become available on
all Quantize Presets pop-up menus.
Remove Preset
Allows you to remove the selected preset.
Rename Preset
Opens a dialog where you can rename the selected preset.
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Restore Factory Presets
Allows you to restore the factory presets.

Creating Groove Quantize Presets
You can create a groove quantize map based on hitpoints that you have created in the Sample
Editor.
PROCEDURE
1.

In the Project window, double-click the audio event from which you want to extract the
timing.
The Sample Editor opens.

2.

Open the Hitpoints section.
The hitpoints for the audio event are detected and displayed automatically.

3.

Click Create Groove.
The groove is extracted.

RESULT
The groove is extracted from the audio event and made available in the Quantize Presets popup menu on the Project window toolbar.
AFTER COMPLETING THIS TASK
Open the Quantize Panel and save the groove as a preset.
RELATED LINKS
Creating a Groove Quantize Map on page 528
Quantize Presets on page 292

Options For Quantizing to a Musical Grid
You can use the musical grid to quantize your recorded music.
●

To access the options for quantizing to a musical grid, select a musical time format from
the Select Preset pop-up menu.
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●
The following options become available:
Grid
Allows you to select the basic value for the quantize grid.
Swing
Offsets every second position in the grid, creating a swing or shuffle feel.
NOTE
Swing is only available if Grid is set to a straight value and Tuplet is deactivated.
Catch Range
Allows you to set a value that determines that quantizing affects only audio or MIDI
within the set distance from the grid lines. This is reflected in the grid display.
Non-Quantize
Creates a safe zone before and after the quantize positions. If you specify a distance
in ticks (120 ticks = one 16th note), events that lie within this zone are not quantized.
This way, slight variations are kept.
Grid Display
Shows the quantize grid. Quantized audio or MIDI is moved to the positions
indicated by the vertical grid lines.
Tuplet
Creates rhythmically more complex grids by dividing the grid into smaller steps, and
thereby creating n-tuplets.
Randomize
Allows you to set a distance in ticks, so that your audio or MIDI is quantized to
random positions within the specified distance from the quantize grid. This allows for
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slight variations and, at the same time, prevents your audio or MIDI from ending up
too far away from the grid.
iQ Mode
Applies a loose quantization so that your audio or MIDI moves only part of the way
to the closest quantize grid position. The Iterative Strength value to the right
determines how close your audio or MIDI moves towards the grid.
NOTE
Iterative quantizing is based on the current, quantized positions and not on the
original event positions. You can repeatedly use the iQ mode to gradually move your
audio or MIDI closer to the quantize grid until you have found the right timing.
AudioWarp
Quantizes the content of your audio event by applying time stretch. The warp
markers are aligned with the defined quantize grid.
MIDI CC
Moves controllers related to MIDI notes (pitchbend, etc.) automatically with the notes
when these are quantized.
Reset Quantize
Resets your audio or MIDI to its original, unquantized state.
IMPORTANT
This function has no effect on an event that was moved manually.
Auto
Applies any changes immediately to the selected parts or events. A way of using this
feature is to set up a playback loop and adjust the settings until you are satisfied with
the result.
Quantize
Applies your settings.

Options for Quantizing to a Groove
You can generate a timing grid from a MIDI part or an audio loop, and use this groove to
quantize your recorded music. This way, you can recreate the rhythmic feel of this specific event
or part.
To access the options for quantizing to a groove, select a MIDI part, from an audio loop, an audio
event with hitpoints, or sliced audio, and perform one of the following actions:
●

Drag the part or event and drop it on the grid display in the middle of the Quantize Panel.

●

Select Edit > Advanced Quantize > Create Groove Quantize Preset.
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The following options become available:
Position
Determines how much the timing of the groove affects the music.
Velocity (MIDI Only)
Determines how much the velocity values within the groove affect the music.
NOTE
Not all grooves contain velocity information.
Length (MIDI Only)
Allows you to specify how much the lengths of the notes are affected by the groove.
NOTE
For drums, the Length setting is ignored.
Non-Q
Allows you to create a safe zone before and after the quantize positions. If you
specify a distance in ticks (120 ticks = one 16th note), events that lie within this zone
are not quantized. This way, slight variations are kept.
Grid Display
Shows the quantize grid. Quantized audio or MIDI is moved to the positions
indicated by the vertical grid lines.
Pre-Q
Allows you to select a musical grid to which you can quantize your audio or MIDI
first. This gets the notes closer to their groove destination.
NOTE
If you apply a shuffle groove to a 16th-note pattern, for example, set up a prequantize value of 16 to straighten up the timing before applying the groove
quantizing.
Max. Move
Allows you to select a note value to specify a maximum distance that the audio or
MIDI is moved.
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Orig. Position
Sets the original starting position of the quantized material as starting point of the
quantizing. This allows you to synchronize material that does not start from bar 1 of
the project.
Randomize
Allows you to set a distance in ticks so that your audio or MIDI is quantized to
random positions within the specified distance from the quantize grid. This allows for
slight variations and, at the same time, prevents your audio or MIDI from ending up
too far away from the grid.
iQ Mode
Applies a loose quantization so that your audio or MIDI moves only part of the way
to the closest quantize grid position. The Iterative Strength value to the right
determines how close your audio or MIDI moves towards the grid.
NOTE
Iterative quantizing is based on the current, quantized positions and not on the
original event positions. You can repeatedly use the iQ mode to gradually move your
audio or MIDI closer to the quantize grid until you have found the right timing.
AudioWarp
Quantizes the content of your audio event by applying time stretch. The warp
markers are aligned with the defined quantize grid.
MIDI CC
Moves controllers related to MIDI notes (pitchbend, etc.) automatically with the notes
when these are quantized.
Reset Quantize
Resets your audio or MIDI to its original, unquantized state.
IMPORTANT
This function has no effect on an event that was moved manually.
Auto
Applies any changes immediately to the selected parts or events. A way of using this
feature is to set up a playback loop and adjust the settings until you are satisfied with
the result.
Quantize
Applies your settings.
RELATED LINKS
Creating Groove Quantize Presets on page 293

Options for Quantizing Multiple Audio Tracks
If you quantize multiple audio tracks, the Slice Rules section becomes available in the Quantize
Panel. Here, you determine how the audio events are sliced at the hitpoints.
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●

To access the Slice Rules section, move your audio tracks to a folder track, activate Group
Editing, and open the Quantize Panel.

Hitpoint Tracks
Lists all audio tracks of your edit group that have hitpoints.
Priority
Click and drag to the right or to the left to specify a priority. The hitpoints of the track
with the highest priority determine slice positions for the audio on all tracks. If the
zoom factor is high enough, cutting positions are marked in the Project window by
vertical lines.
Range
Allows you to specify the distance in which two hitpoints on different tracks are
considered to mark the same beat.
Offset
Allows you to set an offset that determines how far before the actual hitpoint
position an audio event is sliced. This allows for slight variations of the cutting
position and is useful if you want to create crossfades at the slice positions.
Furthermore, it helps to avoid cutting off signals on tracks that do not contain any
hitpoints.
AudioWarp Quantize On/Off
Activate this button to quantize the content of your audio event by applying time
stretch. This enables the Warp Marker Creation Rules section that allows you to
specify a priority. The hitpoints of the track with the highest priority determines warp
marker positions for the audio on all tracks.
Slice
Slices all audio events of the edit group, and sets the event snap points to the
position of the hitpoint with the highest priority.
Reset
Undoes the slicing and restores the original state of the audio events.
RELATED LINKS
Options for AudioWarp Quantizing Multiple Audio Tracks on page 299
Crossfades Section on page 299
AudioWarp Quantizing Multiple Audio Tracks on page 291
Group Editing Mode on page 216
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Crossfades Section
The Crossfades section becomes available after you have sliced the audio events. The functions
in this section allow you to correct the overlaps or the gaps that might appear due to the repositioning of your audio.

Clicking Crossfade cuts the end of the first event at the start position of the following event (in
case of overlaps), and stretches the second event until it starts at the end of the previous event
(in case of gaps).
In some cases, you might want to achieve seamless transitions, applying crossfades after closing
the gaps. For this purpose, use the following parameters:
Open Crossfade Editor
Opens the Crossfade editor, where you can specify curve kind, length, and other
parameters for your crossfades.
Nudge Crossfade Left/Right
Moves the fade area in the audio event to the left or to the right in steps of one
millisecond. This is useful if the Offset value in the Slice Rules section was not high
enough, and you want to avoid that the crossfade cuts an attack.
Length
Specifies the length of the crossfade area.
RELATED LINKS
Crossfade Editor on page 307

Options for AudioWarp Quantizing Multiple Audio Tracks
The Warp Marker Creation Rules section becomes available when you activate AudioWarp
quantizing for multiple audio tracks.

Priority
In this column, you can define a priority for each track. The track with the highest
priority defines where the warp markers are created.
If you set up the same priority for several tracks, the warp marker position is defined
by the track that contains the first hitpoint within the specified range. This is decided
for each warp marker position anew.
●

To specify a priority, click and drag to the right or to the left.
If no star is shown, the hitpoints on the corresponding track are not taken into
account.
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Range
Two hitpoints on different tracks are considered to mark the same beat if they are
located within a certain distance from each other. The Range parameter specifies
this distance. The following rules apply:
●

If one of the tracks has a higher priority, its hitpoint is used to create the warp
marker.

●

If the tracks have the same priority, the first hitpoint in the range is used.

Reset
Undoes the creation of warp markers.
AudioWarp Quantize On/Off
Activates/deactivates AudioWarp quantizing. This enables the Slice Rules section.
Create
Creates warp markers for all the tracks.
RELATED LINKS
Options for Quantizing Multiple Audio Tracks on page 297
AudioWarp Quantizing Multiple Audio Tracks on page 291
Group Editing Mode on page 216
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Fades allow you to gradually increase or decrease the volume at the start or end of audio events
or audio clips, and to create smooth transitions.
You can create the following fades:
●

Fade ins/fade outs
Fade ins and fade outs allow you to gradually increase or decrease the volume of audio
events or audio clips. Fade ins and fade outs can be either event-based or clip-based.
Event-based fades are calculated in real time when you play back audio events. You can
create different fade curves for several events, even if they refer to the same audio clip.
NOTE
The more event-based fades you apply, the more processing power is used.
Clip-based fades are applied to the audio clip. Events that refer to the same clip will have
the same fades.

●

Crossfades
Crossfades allow you to create smooth transitions for consecutive audio events on the
same track. Crossfades are always event-based.

●

Auto fades
Auto fades allow you to automatically apply short fade ins and fade outs to the events on
specific audio tracks. You can also apply them globally on all audio tracks. This creates
smooth transitions between events.

●

Event envelopes
Event envelopes are volume curves for audio events or audio clips. They allow for volume
changes not only at the start or the end, but also within the audio or clip. They can be
either event-based or clip-based.

RELATED LINKS
Event-Based Fades on page 301
Creating Clip-Based Fades on page 305
Crossfades on page 306
Auto Fades and Crossfades on page 313
Event Envelopes on page 315

Event-Based Fades
You can create event-based fade ins and fade outs. These are calculated in real time when you
play back audio events. You can create different fade curves for several events, even if they refer
to the same audio clip.
There are several ways to create event-based fades:
●

By using the event handles

301

Fades, Crossfades, and Envelopes
Event-Based Fades
●

By using range selections

You can edit event-based fades in the Fade dialogs.
RELATED LINKS
Creating and Editing Fades with the Handles on page 302
Creating and Editing Fades with the Range Selection Tool on page 303
Fade Dialog for Event-Based Fades on page 304

Creating and Editing Fades with the Handles
You can create and edit event-based fade ins and fade outs using the event handles. This gives
you a visual feedback and allows you to apply the same fade type to several selected events.
PROCEDURE
1.

Select the audio events for which you want to create fades and point at one of them with
the mouse.
Triangular fade handles become visible in the upper left and right corners.

2.

Perform one of the following actions:
●

Drag the left fade handle to the right to create a fade in.

●

Drag the right fade handle to the left to create a fade out.

RESULT
The fade is applied and shown in the event waveform. If you select multiple events, the same
fade is applied to all selected events.
NOTE
You can change the length of the fades at any time by dragging the handles.

Event Handles
Audio events have a fade-in and a fade-out handle, as well as a volume handle. These handles
provide a quick way to change the fade length or the volume of events in the Project window.
Event handles become visible if you point the mouse at an event or if you select events.
NOTE
To show event handles and fade curves always and not only when you point at events, activate
Show Event Volume Curves Always in the Preferences dialog (Event Display—Audio page).
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In the upper left and right corners you find triangular fade handles that allow you to change the
fade-in or fade-out length. In the top middle you find a square handle that allows you to change
the volume.
●

To change the fade-in length, drag the fade handle in the upper left to the right or to the
left.

●

To change the fade-out length, drag the fade handle in the upper right to the left or to the
right.

●

To change the volume, drag the volume handle in the top middle up or down.

Fade and volume changes are reflected in the event waveform and on the info line.
NOTE
To change the event volume and the fades with the mouse wheel, activate Use Mouse Wheel for
Event Volume and Fades in the Preferences dialog (Editing—Audio page). When you press
Shift while moving the mouse wheel, and position the mouse pointer somewhere in the left half
of the event, the fade in end point is moved. When the mouse pointer is in the right half of the
event, the fade out start point is moved.

Creating and Editing Fades with the Range Selection Tool
You can create and edit event-based fades with the Range Selection tool. This allows you to
apply a fade in and a fade out at the same time. Using the Range Selection tool is also useful if
you want to create fades for multiple audio events on separate tracks.
PROCEDURE
1.

On the Project window toolbar, select the Range Selection tool.

2.

Perform one of the following actions:

3.

●

To create a fade in that starts at the event start, select a range that starts at the
event start.

●

To create a fade out that ends at the event end, select a range that ends at the event
end.

●

To create a fade in and a fade out, select a range in the middle of the event.

●

To create fades on multiple tracks, select a range that spans multiple audio events
on multiple audio tracks.

Select Audio > Adjust Fades to Range.

Applying Default Fades
You can use default fades to create event-based fade ins and fade outs.
PROCEDURE
1.

Select one or more audio events in the Project window.

2.

Perform one of the following actions:
●

To create a fade in, select Audio > Apply Standard Fade In.
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●

To create a fade out, select Audio > Apply Standard Fade Out.

RESULT
An event-based fade of the same length and shape as the default fade is applied.
NOTE
To change the default fade, select Audio > Open Fade Editor(s), set up the fade and click As
Default.

RELATED LINKS
Fade Dialog for Event-Based Fades on page 304

Removing Event-Based Fades
You can remove event-based fades for a whole event or for a range.
PROCEDURE
1.

2.

Perform one of the following actions:
●

To remove the fades for an event, select the event with the Object Selection tool.

●

To remove the fades for a range, select the fade area with the Range Selection tool.

Select Audio > Remove Fades.

Fade Dialog for Event-Based Fades

●

To open the dialog for event-based fades, create a fade for one or more audio events,
select the events and select Audio > Open Fade Editor(s).
NOTE
If you select several events, you can adjust the fade curves for all selected events at the
same time. This is useful if you want to apply the same type of fade in to more than one
event, etc.

The available options are:
1

Spline Interpolation
Applies a spline interpolation to the curve.

2

Damped Spline Interpolation
Applies a damped spline interpolation to the curve.
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3

Linear Interpolation
Applies a linear interpolation to the curve.

4

Fade display
Shows the shape of the fade curve. The resulting waveform shape is shown darker, the
current waveform shape is shown lighter.

5

●

To add points, click the curve.

●

To change the curve shape, click and drag existing points.

●

To remove a point from the curve, drag it outside the display.

Restore
Click this button to cancel any changes you have made since opening the dialog.

6

Fade Length field
Use this field to enter fade lengths numerically. The format of values displayed here is
determined by the time display in the Transport panel.

7

●

If you activate Apply Length, the value entered in the Fade Length value field is
used when clicking Apply or OK.

●

If you set the current fade as the default fade, the length value is included as part of
the default settings.

Presets
Allows you to set up presets for fade-in or fade-out curves.

8

●

To apply a stored preset, select it from the pop-up menu.

●

To remove a stored preset, select it from the pop-up menu and click Remove.

As Default
Click this button to save the current settings as default fade.

9

Shape buttons
Give you quick access to some common curve shapes.

Creating Clip-Based Fades
You can create and edit clip-based fade ins and fade outs using Direct Offline Processing. These
fades are applied to the audio clip. Events that refer to the same clip get the same fades.
PREREQUISITE
In the Direct Offline Processing window, Auto Apply is activated.
PROCEDURE
1.

In the Project window, select one or more audio events or a range for which you want to
create a fade.
The length of your selection determines the length of the fade area.

2.

Perform one of the following actions:
●

To create a fade in, select Audio > Processes > Fade In.

●

To create a fade out, select Audio > Processes > Fade Out.

3.

On the Direct Offline Processing process panel, click the Curve Kind buttons to specify a
fade curve, or click and drag with the mouse in the curve display to draw in a curve.

4.

Optional: Activate Audition to hear the effect of the specified fade on the selected audio
event.
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RESULT
The fade is applied to the audio. You can remove or modify the fades at any time using the
Direct Offline Processing window.
RELATED LINKS
Direct Offline Processing on page 467
Fade In/Fade Out on page 479
On Processing Shared Clips on page 306

On Processing Shared Clips
If several events refer to the same audio clip, this clip is a shared clip. If you edit one of the
events that refer to a shared clip, you can decide if you want to apply the processing to all events
referring to this clip.

Continue
Click Continue to apply the processing to all events that refer to the audio clip.
New Version
Click New Version to create a separate, new version of the audio clip for the selected
event.

Crossfades
Crossfades allow you to create smooth transitions for consecutive audio events on the same
track. Crossfades are always event-based.
You can only create crossfades if the consecutive events or their respective clips overlap.
●

If the audio events overlap, a crossfade of the default shape (linear, symmetric) is applied
in the overlapping area.

NOTE
You can edit the default crossfade length and shape in the Crossfade editor.
●

If the respective audio clips overlap, the two events are resized so that they overlap, and a
crossfade of the default length and shape is applied in the overlapping area.

●

If neither the audio events nor the clips do overlap, a crossfade cannot be created.

RELATED LINKS
Crossfade Editor on page 307
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Creating Crossfades
PROCEDURE
1.

2.

Perform one of the following actions:
●

To create a crossfade between two events, select the Object Selection tool, and
select two consecutive audio events.

●

To create a crossfade to a selected range between two events, select the Range
Selection tool, and select a range covering the area where you want to apply a
crossfade.

Select Audio > Crossfade or use the key command X.

RESULT
The crossfade is applied.

Changing the Crossfade Length
PROCEDURE
1.

Select the Range Selection tool.

2.

Select a range between two events that covers the length of the crossfade you want to
apply.

3.

Select Audio > Adjust Fades to Range.

RESULT
The crossfade length is adjusted to the selected range.

Crossfade Editor
The Crossfade editor allows you to edit crossfades. It shows a fade display of the selected audio
and the fade curves together with fade-in and fade-out curve settings, and common settings.

●

To open the Crossfade editor, select one or both crossfaded events, and select Audio >
Crossfade, or double-click the crossfade zone.
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NOTE
You can activate a simplified Crossfade editor in the Preferences dialog. Select Editing >
Audio and activate the Simple Crossfade Editor option.
Nudge Range
Specifies the range that is moved when using Nudge.
Nudge Mode
Determines what is moved when you use Nudge.
●

To move the audio, activate Move Audio.

●

To move the fade, activate Move Fade.

Chaining Mode
Determines how the audio to the right of the crossfade on the track behaves when
you move the crossfade for an event.
●

To move all following events on the track, activate Until End.

●

To move all following events on the track up to the next gap, activate Until
Gap.

●

To move none of the following events on the track, activate None.

NOTE
The behavior is different depending on whether the next audio event on the track
follows seamlessly or with a gap.
Splice Point Offset
The dotted vertical line in the fade-in and fade-out curves marks the splice point. If
you work with asymmetric crossfades, you can set a splice point offset. This means
that the splice points for the fade-in and the fade-out event are different.
Symmetric Fades
Activate this to link the editing controls of the fade-out and fade-in curves. This
allows you to use the fade-out or fade-in controls to move both fade curves by the
same amount.
Length
Specifies the length of the crossfade area.
Overlap
Defines the position of the splice point in the crossfade area.
Volume
Changes the volume of the crossfaded events. This is the same as using the volume
handles in the event display.
Nudge
Nudges the fade area or the audio in the desired direction.
Fade curve displays
Shows the shape of the fade-out and fade-in curve, respectively.
●

To add points, click a curve.

●

To change the fade shape, click and drag existing points.

●

To remove a point, drag a point outside the display.
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Curve Kind and Shape buttons
Determine whether the corresponding fade curve uses Spline Interpolation (left
button), Damped Spline Interpolation (middle button) or Linear Interpolation
(right button).
The curve shape buttons give you quick access to some common curve shapes.

Equal Gain
Adjusts the fade curves so that the summed fade-in and fade-out amplitudes are the
same all along the crossfade region. This is often suitable for short crossfades.
Equal Power
Adjusts the fade curves so that the energy (power) of the crossfade is constant all
along the crossfade region.
Equal Power curves have only one editable curve point. You cannot change the
curve shape if this mode is selected.
Play buttons
●

To audition the whole crossfade, click Play Crossfade.

●

To audition the fade-out part of the crossfade, click Play Fade Out.

●

To audition the fade-in part of the crossfade, click Play Fade In.

You can set up key commands for this in the following categories of the Key
Commands dialog.
Pre-roll and Post-roll
●

To start playback before the fade area, activate Use pre-roll.

●

To stop playback after the fade area, activate Use post-roll.

●

To adjust the pre-roll time, use the Pre-roll Amount value field.

●

To adjust the post-roll time, use the Post-roll Amount value field.

Audition Level
Allows you to set the audition level.
Auto-Scroll
Scrolls the crossfade display during playback, so that the position cursor is always
visible. This only applies when using the Transport panel and it works like the
corresponding function in the Project window.
Zoom to Fade
Zooms and centers the display on the selected crossfade area.
Auto Zoom
Zooms and centers the display automatically on the current crossfade when you
resize it. This also works when you select the next crossfade using Select Crossfade.
Presets
Click Store to the right of the Presets pop-up menu to store the crossfade settings
so that you can apply them to other events.
●

To remove a preset, select it on the pop-up menu and click Delete.

Default buttons
Click As Default to store the current settings as default. Default settings are used
whenever you create new crossfades.
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Click Recall Default to apply the curves and settings of the default crossfade to the
Crossfade editor.
Project selection follows
If this option is activated, selecting another crossfade automatically changes the
event selection in the Project window.
Select Crossfade buttons
Allow you to select the previous/next crossfade area, provided that the current track
contains more than one crossfade.
RELATED LINKS
Moving the Crossfade Area with the Nudge buttons on page 311
Moving the Crossfade Area with the Overlap Controls on page 310
Resizing the Crossfade Area on page 311
Key Commands on page 1137
Event Handles on page 302
Auto-Scroll on page 243

Moving the Crossfade Area
You can edit crossfades by moving the crossfade area, that is, the overlapping area between two
audio events or clips.
In the Crossfade editor, you have the following options to move the crossfade area:
●

You can use the Overlap controls to determine how much of the fade-out and how much
of the fade-in event is included in the crossfade area.

●

You can use the Nudge buttons in Move Fade mode to move the crossfade area. The
audio events or clips keep their positions.

●

You can use the Nudge buttons in Move Audio mode to move the audio of the fade-in
event. The size of the crossfade area is kept.

Moving the Crossfade Area with the Overlap Controls
The Overlap controls allow you to determine how much of the fade-out and how much of the
fade-in event are included in the crossfade area. By moving the Overlap controls, you move the
overlapping area between two audio events or clips. The audio events or clips keep their
positions.

●

If you activate the Symmetric Fades option, the splice point for the fade out and the fade
in is initially situated in the center of the crossfade. If you move the Overlap control for the
fade in, the fade out control moves accordingly.

●

If you deactivate the Symmetric Fades option, you can move the Overlap controls
separately to set up different overlap values for the fade-in and fade-out curves. This is
indicated in the Splice Point Offset field.
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Moving the Crossfade Area with the Nudge buttons
You can use the Nudge buttons in Move Fade mode to move the crossfade area. You can use the
Nudge buttons in Move Audio mode to move the audio of the fade-in event. Each time you click
Nudge, the crossfade area or audio clip is moved in the corresponding direction by the amount
specified on the Nudge Range pop-up menu.
●

To move the fade area, activate Move Fade in the Nudge Mode section.

●

To move the audio clip, activate Move Audio in the Nudge Mode section.

●

If you activate Symmetric Fades, and the Nudge Mode is set to Move Fade, the fade out
area and the fade in area are moved by the same amount.
You can also move the fade by using the middle handle of the fade out or the fade in
curve.

●

If you activate Symmetric Fades, and the Nudge Mode is set to Move Audio, the Nudge
buttons in the fade in display move the audio event.
You can also move the audio by clicking the fade in event and dragging with the hand
symbol that appears.

NOTE
You cannot move the audio of the fade out event.

Resizing the Crossfade Area
You can edit crossfades by resizing the crossfade area, that is, the overlapping area between two
audio events or clips.
In the Crossfade editor, you have the following options to resize the crossfade area:
●

You can use the Length controls to resize the crossfade areas between two audio events
or clips without moving the splice points.

●

You can use the fade in curve and fade out curve handles to resize the crossfade area
between two audio events or clips and move the splice points at the same time.

IMPORTANT
To be able to resize a crossfade, it must be possible to resize the corresponding event. If the fade
out event already plays its audio clip to the end, its end point cannot be moved any further to the
right.
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Changing the Crossfade Length Without Moving the Splice Points
You can resize the crossfade area between two audio events or clips without moving the splice
points.
●

To resize the crossfade area, use the Length controls or the Length fields.
You can also resize the crossfade area by clicking and dragging the length handles for the
fade out and the fade in curve in the crossfade display.

●

If you activate Symmetric Fades, the fade out and the fade in lengths are changed by the
same amount.

●

If you deactivate Symmetric Fades, you can use the upper Length controls to change the
length of the fade out curve, and the lower controls to change the length of the fade in
curve.

Changing the Crossfade Length and Moving the Splice Points
You can resize the crossfade area between two audio events or clips and move the splice points
at the same time.
●

To resize the crossfade area together with the splice points, drag the right handle of the
fade out curve to the left or drag the left handle of the fade in curve to the right.

●

If Symmetric Fades is activated, the length and splice points of both the fade out curve
and the fade in curve are changed.

●

If Symmetric Fades is deactivated, the right handle of the fade out curve changes the
length and splice point of the fade out curve, and the left handle of the fade in curve
changes the length and splice point of the fade in curve.

Removing Crossfades
PROCEDURE
1.

2.

Perform one of the following actions:
●

Select the Object Selection tool and select one of the crossfaded events.

●

Select the Range Selection tool and select the crossfades you want to remove.

Select Audio > Remove Fades.

RESULT
The selected crossfades are removed.
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NOTE
You can also remove a crossfade by clicking and dragging it outside the track.

Auto Fades and Crossfades
Nuendo features an Auto Fade function that can be set both globally and separately for each
audio track. Auto fades allow you to create smoother transitions between events by applying
fade ins and fade outs with a length between 1 and 500 ms.
IMPORTANT
As event-based fades are calculated in real time during playback, applying auto fades to a higher
number of audio events results in a higher demand on the processor.
NOTE
Auto fades are not indicated by fade lines.

Auto Fades Dialog
The Auto Fades dialog allows you to set up auto fades and crossfades for the whole project, or
separately for each audio track.

●

To open the global Auto Fades dialog, select Project > Auto Fades Settings.

●

To open the Auto Fades dialog for a track, right-click in the track list and select Auto
Fades Settings.

1

Fades
Click this tab to show the settings for auto fades.
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The Curve Kind buttons allow you to determine whether the corresponding fade curve
uses Spline Interpolation (left button), Damped Spline Interpolation (middle button) or
Linear Interpolation (right button).
The curve shape buttons give you quick access to common curve shapes.
2

Crossfades
Click this tab to show the settings for auto crossfades.

Equal Gain allows you to adjust the fade curves so that the summed fade in and fade out
amplitudes are the same all along the crossfade region.
Equal Power allows you to adjust the fade curves so that the energy (power) of the
crossfade is constant all along the crossfade region.
3

Length
Allows you to specify the length of the auto fades or crossfades.

4

Auto Fade In
Allows you to activate auto fade ins.

5

Auto Fade Out
Allows you to activate auto fade outs.

6

Auto Crossfades
Allows you to activate auto crossfades.

7

As Default
Allows you to save your settings as default.

8

Use Project Settings
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This is only available if you opened the Auto Fades dialog for individual tracks. Deactivate
this to set up and apply the settings to individual tracks only. If you want a track with
individual auto fade settings to use the global settings again, activate Use Project
Settings.

Making Global Auto Fade Settings
PROCEDURE
1.

Select Project > Auto Fades Settings.
This opens the Auto Fades dialog for the project.

2.

Set up the auto fades as desired.

3.

Click OK.

RELATED LINKS
Fade Dialog for Event-Based Fades on page 304
Crossfade Editor on page 307

Making Auto Fade Settings for Individual Tracks
As auto fades use computing power, you might consider to turn auto fades off globally and
activate them only for individual tracks.
PROCEDURE
1.

Perform one of the following actions:
●

Right-click the track in the track list, and from the context menu, select Auto Fades
Settings.

●

Select the track, and in the Inspector, click Auto Fades Settings.

The Auto Fades dialog for the track opens.
2.

Deactivate Use Project Settings.
Any settings you now make are applied to the track only.

3.

Set up the auto fades.

4.

Click OK.

Event Envelopes
Event envelopes are volume curves for audio events. They allow you to create volume changes
within the event, not only at the start or end.
On the event envelopes, you can create volume changes by adding curve points with the Draw
tool.

The envelope curve is a part of the audio event. If you move or copy the event, the event
envelope follows.
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Creating Event-Based Volume Changes
PROCEDURE
1.

Zoom in on the event so that you can view its waveform properly.

2.

Select the Draw tool and click at the position in the event where you want to change the
volume.

3.

Click with the Draw tool.

A curve point is added to the envelope curve.
4.

Drag the curve point to adjust the volume curve.

RESULT
The volume change is created. The waveform image of the event changes according to the
volume change.

Removing Event Envelopes
PROCEDURE
●

Perform one of the following actions:
●

To remove a curve point from the envelope, click on it and drag it outside the event.

●

To remove an event envelope curve from a selected event, select Audio > Remove
Volume Curve.

Creating Clip-Based Volume Changes
PROCEDURE
1.

In the Project window, select the event.

2.

Select Audio > Process > Envelope.

3.

In the Envelope dialog, make your settings, and click Process.

RESULT
The volume change is created. The waveform image of the event changes according to the
volume change.
RELATED LINKS
Envelope on page 478
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The arranger functions in Nuendo allow you to work in a non-linear fashion. Using an arranger
track allows you to specify how and when specific sections are played back, even in live
performances. This way, you do not need to move, copy, and paste events in the Project window.
NOTE
There can be only one arranger track in a project.
To use the arranger functions, you must add an arranger track and define arranger events.
Arranger events can be of any length. They can overlap and are not bound to the start or end of
existing events and parts. You can order them in a list, and add repeats as desired.

You can edit arranger events using the standard techniques. Copies from arranger events are
independent from the original event.
You can create several arranger chains that allow you to save different versions of a song within
the project.
You can flatten arranger chains to convert them into a linear project.
RELATED LINKS
Adding Arranger Events on the Arranger Track on page 317
Setting up an Arranger Chain and Adding Events on page 321
Flattening the Arranger Chain on page 322

Adding Arranger Events on the Arranger Track
On the arranger track, you can add arranger events that define specific sections of the project.
PREREQUISITE
Snap is activated, and Snap Type is set to Events.

317

Arranger Track
Arranger Editor

PROCEDURE
1.

Select Project > Add Track > Arranger.
The arranger track is added.

2.

Select the Draw tool and draw an arranger event on the arranger track.
An arranger event is added.

3.

Draw as many events as you need.

RESULT
The arranger events are added to your project.
AFTER COMPLETING THIS TASK
Use the functions of the Arranger Editor to arrange the events.
RELATED LINKS
Setting up an Arranger Chain and Adding Events on page 321
Snap Function on page 79
Snap Types on page 80

Renaming Arranger Events
When you add arranger events, they are automatically named in alphabetical order. You can
change the names so that they reflect the structure of your project, such as Intro, Chorus, Bridge,
for example.
PROCEDURE
1.

Select the arranger event that you want to rename.

2.

Perform one of the following actions:

3.

●

Select the event name on the info line.

●

Hold down Alt and double-click the name in the arranger chain.

Enter a new name.

Arranger Editor
The Arranger Editor allows you to set up arranger chains.
To open the Arranger Editor, click e in the Inspector or in the track list.
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1

Arranger Controls
Shows the transport buttons, the arranger transport buttons, and the arranger tools.

2

Current Arranger Chain
NOTE
Initially, the arranger chain is empty. To fill it up, you must add events from the Arranger
Events list.
Shows the order in which the events are played back, from top to bottom, and how many
times they are repeated.

3

Arranger Events
Lists the available arranger events in the order they appear on the timeline.

Arranger Controls
The Arranger Controls are shown in the Arranger Editor.
NOTE
Some of these controls are also available in the Arranger Controls section of the Project
window toolbar, and on the Transport panel.

1

Stop/Play
Stops/Starts playback.

2

Previous Chain Step
Navigates to the previous entry in the current arranger chain list.

3

Next Chain Step
Navigates to the next entry in the current arranger chain list.

4

First Repeat of Current Chain Step
Navigates to the first repeat of the current entry in the current arranger chain list.

5

Last Repeat of Current Chain Step
Navigates to the last repeat of the current entry in the current arranger chain list.

6

Activate Arranger Mode
Activates playback in arranger mode.

7

Select Active Chain
Allows you to select and activate an arranger chain.

8

Rename Current Chain
Allows you to rename the current arranger chain.

9

Create New Chain
Creates a new, empty arranger chain.

10

Duplicate Current Chain
Creates a duplicate of the current arranger chain, containing the same events.

11

Remove Current Chain
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Removes the selected arranger chain. This is only available if you have created more than
one arranger chain.
12

Flatten
Converts the current arranger chain into a linear project.

13

Flatten (with Options & Preferences)
Allows you to set up the flatten options.

Arranger Chain Repeat Modes
The Arranger Editor features a function that allows you to repeat and loop your arranger events.
This way, you can create a sketch of a song structure.
To select one of the repeat modes, click the Mode column in the Current Arranger Chain list.
1

Normal
Plays back the arranger chain exactly the way you set it up.

2

Repeat forever
Repeats the current arranger event in a loop until you click another event in the Arranger
Editor or until you click Play once again.

3

Pause after Repeats
Pauses playback after all repeats of the current arranger event have been played back.

NOTE
During playback, the Counter column indicates which repetition of the event is playing.

Flattening Options & Preferences
To activate the flattening options, click Flatten (with Options & Preferences).

In the Source section, you can specify which arranger chains are flattened.
Current Chain
Flattens the current chain only.
Checked Chains
Opens a list of the available arranger chains where you can activate the arranger
tracks that you want to flatten.
All Chains
Flattens all arranger chains of the current project.
The Destination section allows you to choose where the result of the flattening is saved.
Current Project
This is only available if Source is set to Current Chain. Activate this option if you
want to save the flattened chain in the current project.
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New Project
Allows you to flatten one or more chains in a new project with the following naming
options:
●

Append Chain Name
Appends the chain names to the project name.

●

Use Chain Name
Names the new projects after the current arranger chains.

●

Add Number
Names the new projects after the old ones and adds a number.

The Options section contains further settings.
Keep Arranger Track
Keeps the arranger track after flattening. Activate Rename Arranger Events to
append numbers to the events.
Make Real Event Copies
Allows you to create real copies of the arranger track instead of shared copies.
Don‘t Split Events
Excludes MIDI notes that start before or are longer than the arranger event. Only
MIDI notes that begin and end inside the arranger event are taken into account.
Open New Projects
Creates a new project for every flattened arranger chain. If you activate Cascade
New Projects, the opened projects are cascaded.
RELATED LINKS
Flattening the Arranger Chain on page 322

Setting up an Arranger Chain and Adding Events
In the Arranger Editor you can set up arranger chains and add events to them.
PROCEDURE
1.

Click e to open the Arranger Editor.

2.

Activate Activate Arranger Mode.

3.

Perform one of the following actions to add arranger events to the arranger chain:

4.

●

Double-click an event in the Arranger Events list.

●

Select one or more events in the Arranger Events list, right-click, and select Append
Selected In Arranger Chain.

●

Drag an arranger event from the Arranger Events list and drop it in the Current
Arranger Chain list.

●

Drag an arranger event from the Project window and drop it in the Current
Arranger Chain list.

Click Play.

RESULT
The arranger events are played back in the order that you specified in the arranger chain.
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RELATED LINKS
Arranger Chain Repeat Modes on page 320

Adding a New Arranger Chain
You can create several arranger chains in order to set up alternative versions for playback.
PREREQUISITE
Arranger Mode is activated.
PROCEDURE
1.

Open the Arranger Editor.

2.

Click Create New Chain.

RESULT
A new, empty arranger chain is activated. This is reflected by a new name in the Select Active
Chain pop-up menu and a new, empty Current Arranger Chain list.

Editing Arranger Events in the Arranger Chain
In the Current Arranger Chain list, you can edit your arranger events.
You can perform the following actions:
●

To select multiple events, Ctrl/Cmd-click or Shift-click them.

●

To move events in the list, drag them up or down.

●

To copy events, select them, hold Alt and drag.

●

To repeat events, click in the Repeats column and enter the number of repeats.

●

To specify how the event is repeated, click in the Mode column and select a Repeat Mode
from the pop-up menu.

●

To move the playback position to the start of an event, click the arrow to the left of the
event.

●

To remove an event from the list, right-click on it, and from the context menu, select
Remove Touched.

●

To remove several events, select them, right-click, and from the context menu, select
Remove Selected.

RELATED LINKS
Arranger Chain Repeat Modes on page 320

Flattening the Arranger Chain
When you have set up an arranger chain that you like, and you are sure that you do not want to
edit it any more, you can convert it to a linear project.
PREREQUISITE
You have saved a copy of the project before flattening the arranger chain.
NOTE
Flattening the arranger chain may remove events and parts from the project. Only use Flatten
when you know you do not want to edit the arranger track/chain any more. If in doubt, save a
copy of the project before flattening the arranger chain.
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PROCEDURE
1.

Select the arranger chain that you want to convert into a linear project.

2.

Optional: Click Flatten (with Options & Preferences)

3.

Optional: Activate the desired flattening options.

NOTE
If you realize that you want to do further adjustments, click Go Back. The activated flatten
options are kept.
4.

Click Flatten.

RESULT
The events and parts in the project are reordered, repeated, resized, moved and/or deleted, so
that they correspond exactly to the arranger chain.

Jump Mode
If you have set up an arranger track and play it back, you have live access to the playback order.
This way, you can loop your arranger events with more flexibility regarding the length of the
playback.
PREREQUISITE
An arranger chain is set up and the arranger mode is activated.
PROCEDURE
1.

Click Play to play back your project.

2.

In the lower part of the Inspector, open the Jump Mode pop-up menu, and select an
option from the pop-up menu.

This determines how long the active arranger event is played, before jumping to the next
one.
3.

In the Arranger Events list of the Inspector, click the arrow to the left of the arranger
event that you want to trigger.
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RESULT
The arranger event is looped according to your settings, until you click another arranger event.
NOTE
You can assign key commands to trigger arranger events in the Arranger category of the Key
Commands dialog.
AFTER COMPLETING THIS TASK
●

To stop Jump Mode, click Stop.

●

To continue playback from a specific arranger event, click the arranger event in the
Current Arranger Chain list.

RELATED LINKS
Jump Mode Options on page 324

Jump Mode Options
The Jump Mode pop-up menu allows you to define how long the active arranger event is played
before jumping to the next one.

The following options are available:
None
Jumps to the next section immediately.
4 bars, 2 bars
Jumps to the next arranger event after 2 or 4 bars. If the current arranger event is
shorter than 2 or 4 bars, playback jumps to the next arranger event at the event end.
1 bar
Jumps to the next section at the next barline.
1 beat
Jumps to the next section at the next beat.

324

Arranger Track
Arranging Music to Video
End
Plays the current section to the end, then jumps to the next section.

Arranging Music to Video
When you compose music for video, you can use arranger events to fill a specific video section
with music. Here comes an example on how you could do that.
PREREQUISITE
You have connected and set up an external sync master device to your computer. You have
created a new, empty project and added a MIDI track.
PROCEDURE
1.

Create a MIDI part that starts at position 00:00:00:00 and ends at position 00:01:00:00.

2.

Create a MIDI part that starts at position 00:01:00:00 and ends at position 00:02:00:00.

3.

Create a MIDI part that starts at position 00:02:00:00 and ends at position 00:03:00:00.

4.

On the Transport panel, activate Sync.

5.

Select Project > Add Track > Arranger.

6.

Add arranger events at the positions of the MIDI parts.

7.

Set up the arranger chain A-A-B-B-C-C.

8.

Activate Arranger mode and click Play.

9.

On your external sync master device, start external timecode at position 00:00:10:00.
In your project, the position 00:00:10:00 is located, and arranger part A is played back.

10.

Start your external sync master device at a position that does not match the Project Start
time, for example, 00:01:10:00.
In your project, the position 00:01:10:00 is located, and arranger part A is played back.

RESULT
If you position the external sync master device to a position that does not match the project start
time, Nuendo automatically jumps to the right position in the arranger track.
NOTE
The reference for the external timecode can be MIDI or any other timecode that can be
interpreted by Nuendo.
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The transpose functions for audio and MIDI in Nuendo allow you to change the pitches of audio
and MIDI for playback without changing the actual MIDI notes or the audio.
You can transpose the following:
●

An entire project by changing the Project Root Key on the Project window toolbar.

●

Specific sections of your project by creating a transpose track and adding transpose
events.

●

Individual parts or events by changing their transpose value on the Project window info
line.

IMPORTANT
As a general rule, always set the root key first when you work with content with a defined root
key.
NOTE
To transpose MIDI notes on a selected track, you can also use MIDI modifiers. If you want to
change the actual notes, use the MIDI transpose functions in the Transpose Setup dialog and in
the MIDI effects (see the separate document Plug-in Reference).

RELATED LINKS
Transposing with the Project Root Key on page 327
Transposing Sections of a Project with Transpose Events on page 330
Transposing Individual Parts or Events using the Info Line on page 332
MIDI Modifiers on page 766
Transpose and Velocity on the Info Line on page 774
Transpose Setup on page 785

Project Root Key
The Project Root Key allows you to transpose your project. Audio or MIDI events in your project
use it as a reference.
To change the Project Root Key, use the Project Root Key pop-up menu on the Project window
toolbar.

If you change the project root key, loops that already contain root key information will follow
automatically.
RELATED LINKS
Transposing with the Project Root Key on page 327
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Transposing with the Project Root Key
The loops included in Nuendo already contain root key information. If you change the project
root key, these loops will follow automatically.
PREREQUISITE
You have opened a project that contains audio loops with different root keys.
PROCEDURE
1.

Optional: Select the drum and percussion loops in your project and set the Global
Transpose setting on the info line to Independent.
This setting excludes the loops from being transposed.

2.

On the Project window toolbar, open the Project Root Key pop-up menu and set a root
key for the project.

This changes the root key for the entire project and transposes the loops to match this key.

RESULT
The loops follow the project root key.
AFTER COMPLETING THIS TASK
Record audio or MIDI. The newly recorded events get the project root key. Change the project
root key. The events with root key information follow.
RELATED LINKS
Excluding Individual Parts or Events from Global Transpose on page 333
Transpose Track and Recording on page 332

Assigning the Project Root Key to Parts or Events
Some audio or MIDI events that you have created by recording, for example, might not contain
root key information. If you want them to follow the transposition changes, you must set them to
the Project Root Key.
PROCEDURE
1.

On the Project window toolbar, open the Project Root Key pop-up menu and set a root
key for the project.
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2.

Optional: Select the drum and percussion loops in your project and set the Global
Transpose setting on the info line to Independent.
This setting excludes the loops from being transposed.

3.

Select Project > Add Track > Transpose.
A transpose track is created. You can only have one transpose track in a project.

4.

In the track list, right-click the transpose track, and from the context menu select Set root
key for unassigned events.

RESULT
All parts or events that do not contain any root key information are set to the project root key.
RELATED LINKS
Excluding Individual Parts or Events from Global Transpose on page 333

Recording with a Project Root Key
If you record with a project root key, the recorded events follow this root key automatically. This
function is useful if you want to change the root key later and you want the events to follow.
PROCEDURE
1.

Optional: Select the drum and percussion loops in your project and set the Global
Transpose setting on the info line to Independent.
This setting excludes the loops from being transposed.

2.

On the Project window toolbar, open the Project Root Key pop-up menu and set the root
key.
All parts and events are transposed in order to match the root key.

3.

Record your music.

RESULT
All recorded audio events and MIDI parts get the project root key information. On the info line,
the Global Transpose setting for recorded events is set to Follow.
AFTER COMPLETING THIS TASK
Change the project root key. Your events will follow.

Changing the Root Key of Individual Audio Events
You can change or set the root key information for individual audio events or parts in the Pool.
PROCEDURE
1.

Select Media > Open Pool Window.

2.

Open the View/Attributes pop-up menu, and activate the Root Key option.
The Key column is displayed in the Pool window.
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3.

Click the Key column for the audio event or part that you want to assign a different root
key to, and select a key from the pop-up menu.

RESULT
The root key of the audio event or part is changed. The corresponding audio file however,
remains unchanged. If you change the project root key, the audio events or parts keep their own
root key settings, and are transposed to match the Project Root Key.
NOTE
You can also assign root keys in the MediaBay.
NOTE
Save the root key in the audio file by selecting the audio event in the event display, and by
selecting Audio > Bounce Selection.

Changing the Root Key of Individual MIDI Parts
You can change the root key information for individual MIDI parts in the Project window info
line.
PROCEDURE
1.

In the event display, select the MIDI part.

2.

In the Project window info line, click Root Key and select a key from the pop-up menu.

RESULT
The root key of the MIDI part is changed. If you change the project root key, the MIDI parts keep
their own root key settings, and are transposed to match the Project Root Key.

Transpose Track
The transpose track allows you to transpose the entire project or sections of it. This function is
useful if you want to create harmonic variations.
For this function to work, you must add transpose events. These transpose events allow you to
transpose specific sections of your project in semitones.
EXAMPLE
If your singer does not reach a certain pitch, you can transpose the entire project by adding a
transpose track and creating a transpose event with the value -2 semitones. After recording, set
the transpose event back to 0.
EXAMPLE
If you want to brighten up your loops in C major, you can transpose them by adding a transpose
track and creating a transpose event with the value 5. This transposes them by 5 semitones, so
that the subdominant on F major is played back.
EXAMPLE
If you want to turn your song more interesting, you can transpose the last chorus of your project
by adding a transpose track and creating a transpose event with the value 1.
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Transposing Sections of a Project with Transpose Events
You can transpose specific sections of your project by creating transpose events on the transpose
track.
PROCEDURE
1.

Select Project > Add Track > Transpose.
A transpose track is created. You can only have one transpose track in a project.

2.

Select the Draw tool and click on the transpose track.
A transpose event is created from the point where you clicked until the end of the project.

3.

Click at a new position to add another transpose event.

4.

Click the value in the lower left corner of the event, and enter a transpose value between
-24 and 24 semitones.

5.

Play back your project.

RESULT
The sections of your project that are situated at the same time positions as the transpose events
are transposed.
RELATED LINKS
Excluding Individual Parts or Events from Global Transpose on page 333

Muting the Transpose Track
You can mute the transpose track. This is useful if you want to compare the effect of the
transposition with the original sound, for example.
PROCEDURE
●

In the track list of the transpose track, click Mute Transpose Events.

RESULT
The transpose events are not taken into account during playback.

Transpose Lock
The lock function on the transpose track allows you to prevent your transpose events from being
moved or changed by mistake.
To lock the transpose track, activate Lock in the track list.
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Keep Transpose in Octave Range
Keep Transpose in Octave Range on the transpose track keeps the transposition in the octave
range.
This ensures that nothing is transposed by more than seven semitones, and that your music
never sounds unnatural because the pitch was raised too high or too low. We also recommend
activating this function, when you work with audio loops.
EXAMPLE
You have opened the Key Editor and activated Indicate Transpositions

.

You have added a transpose track and activated Transpose in Octave Range

.

If you add a transpose event with a value of 8 semitones or higher, the chord is transposed to the
nearest interval or pitch.

Indicate Transpositions
For MIDI parts, you can get a visual feedback that allows you to compare the original sounds and
the music transposed for playback.
To activate this, open the part in the Key Editor, and activate Indicate Transpositions.
●

If Indicate Transpositions is activated, the transposed note pitches are shown.

●

If Indicate Transpositions is deactivated, the original pitches of the notes in the MIDI part
are shown.
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Transpose Track and Recording
The transpose track affects the result of the recorded parts or events.
If your project contains a transpose track with transpose events, and you record audio or MIDI,
the following happens:
●

Global Transpose is automatically set to Independent for the recorded parts or events.

●

The project root key is not taken into account.

If your project does not contain a transpose track or if no transpose events are added, the
following happens:
●

Global Transpose is automatically set to Follow for the recorded parts or events.

●

The recorded parts or events get the project root key.

Transpose on the Info Line
In the Project window info line, you can change the transpose value for individual parts or
events.
To do this, change the transpose value in the Transpose field on the info line.

The Transpose field also indicates transpositions introduced by changing the Project Root Key.

Transposing Individual Parts or Events using the Info Line
You can transpose individual audio events and MIDI parts on the info line Transpose field.
PROCEDURE
1.

Select the event or part that you want to transpose.

2.

On the Project window info line, click the Transpose field and enter a transpose value in
semitones.
NOTE
If the project already contains global transpose changes, it might be useful to activate
Keep Transpose in Octave Range.

RESULT
The event is transposed accordingly. The transpose value is added to any global transpose
change that you have created by using the root key or the transpose track.
RELATED LINKS
Keep Transpose in Octave Range on page 331
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Excluding Individual Parts or Events from Global Transpose
If you add global transposition, for example, by changing the root key or by creating transpose
events, you can exclude specific events from being transposed. This is useful for drum and
percussion loops or special effects (FX) loops.
PROCEDURE
1.

Select the event or part that you want to exclude from being transposed.

2.

On the info line, click the Global Transpose field to set the value to Independent.
Events that are excluded from Global Transpose show a symbol in the upper right corner.

RESULT
If you change the project root key or add transpose events, the Independent parts or events are
not affected.
NOTE
Ready-made parts or events that are tagged as drums or FX, are automatically set to
Independent.
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Markers are used to locate certain positions quickly. There are two types of markers: position
markers and cycle markers.
If you often find yourself jumping to a specific position within a project, you should insert a
marker at this position. You can also use markers to make range selections or for zooming.
Markers are located on marker tracks. For postproduction purposes, you can set up multiple
marker tracks. This is useful for viewing and working with Edit Decision Lists and CSV files.

Position Markers
Position markers allow you to save a specific position.
Position markers on the marker track are shown as marker events: vertical lines with the marker
description (if assigned) and number beside it. If you select a marker track, all its markers are
shown in the Inspector.

Cycle Markers
By creating cycle markers you can save any number of left and right locator positions as start
and end positions of a range and recall them by double-clicking on the corresponding marker.
Cycle markers are shown on a marker track as two markers bridged by a horizontal line. Cycle
markers are ideal for saving sections of a project.
By defining cycle markers for different actors when post-synchronizing a film project, you can
quickly navigate to the sections and repeat or record them again by activating Cycle on the
Transport panel.

Setting the Locators Using Cycle Markers
Cycle markers represent ranges in your project. You can use them for moving the left and right
locators.
PROCEDURE
●

To set the left locator to the cycle marker start and the right locator to the cycle marker
end, perform one of the following actions:
●

Double-click on a cycle marker.

●

From the Cycle pop-up menu in the track list, select a cycle marker.

RESULT
The left and right locators are moved to encompass the cycle marker.
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AFTER COMPLETING THIS TASK
Now you can move the project cursor position to the start or the end of the cycle marker by
moving it to the corresponding locator or use cycle markers to export specific ranges of your
project with the Export Audio Mixdown dialog.

Editing Cycle Markers
When editing cycle markers on a marker track, snap is taken into account.
●

To add a cycle marker, press Ctrl/Cmd click and drag on the marker track.

●

To change the start/end position of a cycle marker, drag the start/end handle.

●

To move a cycle marker to another position, drag the upper border.

●

To delete a cycle marker, click with the Erase tool.
If you hold down Alt when you click, all consecutive markers are deleted.

●

To cut a range in a cycle marker, select a range in the cycle marker and press Ctrl/Cmd-X.

●

To set the marker start/end of the selected cycle marker to the cursor position, select
Project > Markers to open the Markers window, and select Functions > Set Marker
Start/End to Cursor.

●

To set the left and right locators, double-click a cycle marker.

●

To zoom in on a cycle marker, press Alt and double-click the cycle marker.

Markers Window
In the Markers window, you can view and edit markers. The markers on the active marker track
are displayed in the marker list in the order in which they occur in the project.
To open the Markers window, you have the following possibilities:
●

Select Project > Markers.

●

On the Transport panel in the marker section, click Show.

●

Use a key command (by default Ctrl/Cmd-M).

1

Locate arrow
Indicates which marker is at the project cursor position.

2

Set focus to marker track
Allows you to select the marker track that has the focus.

3

Functions menu
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Lists all functions available in the Marker window.
4

Set up Attribute Columns
Allows you to set up the attribute columns.

5

Set up Attribute Columns for Details
Allows you to set up the attribute columns for the details.

6

Reset Filters
Allows you to remove all filters for all columns.

7

Marker type
Allows you to specify which marker type is shown in the marker list.

8

Auto-Scroll with Project Cursor
Allows you to keep track of the locate arrow, even if your project contains a large number
of markers. If this option is activated, the Marker window is automatically scrolled to keep
the locate arrow visible.

9

Markers list
Shows the markers in the order in which they occur in the project.

10

ADR Panel
Shows the ADR functions.

11

Marker Settings
Shows the marker settings.

12

Show ADR Panel
Shows the ADR panel.

13

Show Details View
Shows the details view.

Editing in the Markers Window
In the Markers window, you can select, edit, add, move, and remove markers.
●

To select or edit a marker, click on it.
Select multiple markers by Shift or Ctrl/Cmd-clicking them.

●

To add a position marker at the cursor position, select Functions > Insert Marker.
A position marker is added at the current project cursor position on the active marker
track.

●

To add a cycle marker at the cursor position, select Functions > Insert Cycle Marker.
This adds a cycle marker between the left and right locators on the active marker track.

●

To move a marker to the cursor position, select the marker and select Functions > Move
Markers to Cursor.
You can also enter the new position numerically in the Position column. If a cycle marker
is selected, the move operation affects the cycle marker start position.

●

To move markers to another track, select the markers, select Functions > Move Markers
to Track, and select the marker track.

●

To remove a marker, select it and select Functions > Remove Marker.

Navigating in the Marker List
You can navigate in the marker list using your computer keyboard and select entries by pressing
Enter. This is a quick and easy way to jump to markers during playback or recording.
●

To move to the previous/next marker in the list, press the Up Arrow/Down Arrow keys.
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●

To jump to the first/last marker, press the Page Up/Page Down keys.

●

To step through the attributes of a marker, select a marker, then click again and press Tab.

●

To step back, press Shift-Tab.

NOTE
When working with video, you can use the Markers window as a spotting list (a list of timecode
values) to position your audio events according to the video events.

RELATED LINKS
Locating to Markers on page 1089

Sorting and Reordering the Marker List
You can customize the display of the marker attributes in the marker list by sorting or reordering
the columns.
●

To sort the marker list by a specific attribute (except Row Count), click on the
corresponding column header.

●

To reorder the marker attributes, drag and drop the corresponding column headers.

●

To adjust the width of a column, place the mouse pointer between two column headers
and drag left or right.

NOTE
No matter by which attribute you sort, the second sort criterion will always be the position
attribute.

Marker Settings
You can access the marker settings by clicking the corresponding button in the bottom left
corner of the Markers window.

Cycle follows when locating to Markers
This sets the left and right locators automatically to a position or cycle marker, when
locating to this marker. This is useful if you need to set the locators on the fly during
recording for Punch In/Punch Out, for example.
Show marker IDs on marker track
If this option is activated, the marker IDs are shown on the marker track.
Sync Selection
If this option is activated, the Markers window selection is linked to the selection in
the Project window.

Marker Attributes
The following marker attributes are shown in the marker list of the Marker window by default:
Locate
An arrow indicates which marker is at the project cursor position (or closest to the
project cursor). If you click in this column, the project cursor is moved to the
corresponding marker position. This column cannot be hidden.
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ID
This column shows the marker ID numbers.
Position
In this column, you can view and edit the markers’ time positions (or start positions
for cycle markers). This column cannot be hidden.
End
In this column, you can view and edit the end positions of cycle markers.
Length
In this column, you can view and edit the length of cycle markers.
Description
Here you can enter names or descriptions for markers.
RELATED LINKS
Marker IDs on page 341
Cycle Markers on page 334
Filtering Attributes on page 339

Setting Up Attribute Columns
If you want to show different attributes in the Markers window, you can set up the attribute
columns.
●

To show other attributes, click Set up Attribute Columns, and select other attributes from
the pop-up menu.
The most common attributes for postproduction are listed in categories according to their
usage.
The number in brackets following the category name helps to get a quick overview of how
many attributes of a certain category are displayed as columns in the Marker window.

●

To show all attributes in the Marker window, select Set up Attribute Columns > Show all.

●

To hide all attributes in the Marker window, select Set up Attribute Columns > Hide all.
This hides all attributes except for Locate and Position.

●

To show only the columns that are used for at least one marker, select Set up Attribute
Columns > Show only used attributes.

●

To consecutively number the rows in the marker list, select Set up Attribute Columns >
Row Count.
This can be useful when using filters for certain attributes.

Editing Attributes
There are 3 different types of attributes: Text, Number, and Yes/No switch. Depending on the
type, you can enter text or numerical values, or activate/deactivate the corresponding checkbox.
●

To edit a marker attribute, select the corresponding marker, click in the desired attribute
column, and make your settings.

●

To change the attributes of several markers, select the markers and click the checkbox for
the desired attribute.
All selected markers will change their attributes accordingly. Note that this does not work
when clicking on a timecode value or a text field.
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NOTE
To navigate in the list of marker attributes, you can also use the Tab key and the Up Arrow,
Down Arrow, Left Arrow, and Right Arrow keys.

Sorting and Reordering Columns
You can customize the display of the marker attributes in the marker list by sorting or reordering
the columns.
●

To sort the marker list by a specific attribute, click on the corresponding column header.
NOTE
No matter by which attribute you sort, the second sort criterion will always be the position
attribute.

●

To reorder the marker attributes, drag and drop the corresponding column headers.

●

To adjust the width of a column, place the mouse pointer between two column headers
and drag left or right.

Filtering Attributes
When you are working with many markers so that the list is very long, you may want to filter the
list to show only markers with a certain attribute value, such as the name of a character. Filter
settings are not saved in the project or defaults.
PROCEDURE
1.

Right-click on the column header of the attribute that you want to use for the filter.

2.

From the Filter <Attribute Title> submenu, select the desired attribute value.

RESULT
The marker list is filtered according to your settings, and the column header changes its color to
indicate that a filter is applied.
●
●

To remove the filter, right-click the column header and select Reset <Attribute Title>
Filter.
To remove all filters for all columns, click Reset Filters.
The filters are also reset if you change the displayed marker track or hide a filtered
attribute.
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Setting Up the Details View
The Details view shows the details for the marker that is selected in the marker list. The Details
view supports line breaks, which is useful for attributes with long texts. If more than one marker
is selected, only the details for the first marker of the selection are shown.
PROCEDURE
1.

Click Show Details View.

2.

Click Set up Attributes Columns for Details and select the options from the pop-up
menu.
Set up Attribute Columns for Details is displayed next to Set up Attribute Columns.

RESULT
The attributes are shown in the details view. You can edit the marker details in the same way as
in the marker list.
To hide the details view, click Show Details View again.

Setting up User Attributes
PROCEDURE
1.

Click Set up Attribute Columns and select Define User Attributes.

2.

In the User Attributes dialog, click Add User Attribute +.
A new attribute is added to the attributes list.
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NOTE
To remove a user attribute, select it and click Remove User Attribute -. The attribute is
removed from the list and the pop-up menu.
3.

Enter a name for the new attribute and define its type.

4.

Optional: Click Store as Defaults to save your user attributes as default.
New projects will contain these attributes in the User Defined category of the Set up
Attribute Columns pop-up menu.

5.

Click OK.

RESULT
The new attribute is added to the list of available attributes and can be displayed in the Marker
window.
NOTE
To restore your previously saved user attributes, click Restore Defaults. This removes any
attributes that are not saved as defaults.

Marker IDs
Each time you add a marker, it is automatically and sequentially assigned an ID number, starting
from 1.
IDs for cycle markers are shown in brackets and start from 1. ID numbers can be changed at any
time – this allows you to assign specific markers to key commands.
NOTE
If you move a marker from one marker track to another by drag and drop in the Project window,
and the marker ID is already used on this track, the inserted marker automatically gets a new ID.

Reassigning Marker IDs
Sometimes, especially when setting markers on the fly, you may forget or miss to set a marker.
When added later, this marker’s ID will not correspond to its position on the marker track.
Therefore, it is possible to reassign the IDs for all markers on a track.
PROCEDURE
1.

Open the Markers window.

2.

Select the marker track whose ID numbers you want to reassign.

3.

Open the Functions pop-up menu and select either Reassign Position Marker IDs or
Reassign Cycle Marker IDs.

RESULT
The marker IDs of the selected type are reassigned to match the order of markers on the marker
track.

Marker Track
Marker tracks are used for adding and editing markers.
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1

Add Marker
Adds a position marker at the cursor position.

2

Add Cycle Marker
Adds a cycle marker at the cursor position.

3

Locate pop-up menu
If you select a position or a cycle marker in this pop-up menu, the corresponding marker in
the event display or in the Markers window is selected.

4

Cycle pop-up menu
If you select a cycle marker in this pop-up menu, the left and right locators are set to the
corresponding cycle marker.

5

Zoom pop-up menu
If you select a cycle marker in this pop-up menu, the view zooms to the corresponding
cycle marker.

6

Lock
Locks the marker track. When a marker track is locked, you cannot edit the track and its
markers. However, you can still rename the track or change its status (active/inactive).

7

Toggle Time Base
Sets the track time base.

8

Network Controls

9

Marker event (inactive)
Shows an inactive marker event.

10

Marker event (active)
Shows an active marker event.

11

Cycle marker event (inactive)
Shows an inactive cycle marker event.

12

Cycle marker event (active)
Shows an active cycle marker event.

Adding, Moving, and Removing the Marker Track
●

To add a marker track to the project, select Project > Add Track > Marker.

●

To move a marker track to another position in the track list, click and drag it up or down.

●

To remove one or more marker tracks, right-click them in the track list and select Remove
Selected Tracks.

●

To remove an empty marker track, select Project > Remove Empty Tracks.
This also removes any other tracks that are empty.

NOTE
When you remove all marker tracks, the marker track that you removed last (including all its
markers) is moved to the clipboard. If you later insert a new marker track, this track is pasted
from the clipboard into the track list.
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Multiple Marker Tracks
You can create up to 32 marker tracks. Multiple marker tracks are useful when working in a
postproduction context. For example, they can be used to import Edit Decision Lists (EDLs) or
import/export CSV files for Automated Dialogue Replacement (ADR).
A possible scenario would be to create a marker track with cycle markers for sections of the
audio, and another marker track with important sync points in the video. You can also use
multiple marker tracks to insert markers for different users in a network or different narrators in
a movie.

Naming Marker Tracks
By default, the first marker track you create is called “Markers”, the second “Marker 01”, and so
on. If you work with multiple marker tracks, we recommend you to name marker tracks
according to their purposes.
You can name marker tracks by double-clicking on the marker track name in the track list or the
Inspector and entering a new name.

The Active Marker Track
When you are working with multiple marker tracks, only one track is active. All editing functions
affect the markers on the active track only. You activate a track by clicking Activate this track in
the track list.
The following rules apply:
●

When you add a new marker track, this track is automatically active.

●

When you remove an active track, the topmost marker track in the track list is activated.
When using cycle markers for zooming, only the cycle markers of the active track are
displayed on the Zoom pop-up menu.

●

When exporting an audio mixdown of the audio between the cycle markers, only the cycle
markers of the active track are displayed in the Export Audio Mixdown dialog.

●

Most marker key commands affect the active track.

Locking Marker Tracks
You can lock one or more marker tracks by clicking the corresponding lock button of the track.
When a marker track is locked, you cannot edit the track and its markers. However, you can still
rename the track or change its status (active/inactive). In the Markers window and the Project
Browser, the unavailable features of a locked track are grayed out.
RELATED LINKS
Editing Cycle Markers on page 335
Importing and Exporting Markers on page 345

Working with Multiple Marker Tracks
Let’s say you have a video project where the dialogue of two narrators is to be replaced. All you
have to do is create different marker tracks for the individual narrators and set up the markers
according to the video sections that need to be dubbed.
PREREQUISITE
You have added at least two marker tracks to the project and named them.
PROCEDURE
1.

Select File > Key Commands.

2.

In the Marker category, set up a key command for Insert and name Marker.
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This command adds a position marker, opens the Markers window and activates the
Description column.
3.

Set up key commands for Activate next Marker Track and Activate previous Marker
Track.

4.

Activate the marker track for the first narrator, and play back the video file.

5.

At the position where the first dialogue section should be replaced, trigger Insert and
name Marker.
The Marker window opens with the Description column active, so that you can insert a
name for the new marker.

6.

Enter a name or description for the section, and press Return to confirm.
A new marker is created on the active track in the Project window.

7.

Activate the track on which you want to insert the next marker using the Activate next/
previous Marker Track key command.
A message informs you that a different marker track is now active.

8.

Trigger the Insert and name Marker key command at the position where the next
dialogue section should be replaced.
Repeat this procedure for all markers that you want to insert.

Editing Markers on the Marker Track
●

To add a position marker, click Add Marker

●

To add a cycle marker, click Add Cycle Marker

●

To select a marker, use the standard techniques.

●

To resize a cycle marker, select it and drag the handles. You can also do this numerically on
the info line.
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or use the Draw tool.
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●

To move a marker, select it and drag it. You can also edit marker positions on the info line.
If you move markers from one track to another, the marker gets the numbering of the first
free marker ID on the track where it is dropped.

●

To remove a marker, select it and press Delete or use the Erase tool.

RELATED LINKS
Marker IDs on page 341

Using Markers to Select Ranges
Markers can be used in conjunction with the Range Selection tool to make range selections in
the Project window. This is useful if you quickly want to make a selection that spans all tracks in
the project.
PROCEDURE
1.

Set markers at the start and end of the section that you want to move or copy.

2.

Select the Range Selection tool and double-click on the marker track between the
markers.
Everything in the project within the marker boundaries is selected. Any functions or
processing you perform now affect the selection only.

3.

Click on the marker track in the selected range and drag the range to a new position.
If you hold down Alt while you drag the range, the selection in the Project window is
copied instead.

Importing and Exporting Markers
Markers and marker tracks can be imported and exported.
The following files can contain markers:
●

EDL files (edit decision lists)

●

CSV files (comma separated values)

●

MIDI files

●

Track archives

Edit Decision Lists
You can import Edit Decision Lists (EDLs) in CMX3600 format.
EDLs are cut lists or representations of video edits that can be used to align audio events to a
reference video file. They contain reel and timecode data that help you to detect the exact
position of each video clip. Most EDLs are simple ASCII files created by offline editing systems,
but you can also create, open, and edit them manually with a text editor.
The information contained in an EDL can be used in Nuendo to place audio events in the Project
window at the specific timecode positions that correspond to the edits made in the video editing
suite.
EDLs allow you to edit your audio according to the cuts of a video. When you import an EDL in
Nuendo together with the cut video file, each cut described in the EDL is indicated by a marker.
NOTE
Every track in the EDL results in a new marker track in Nuendo. 1 video track and up to 4 audio
tracks of the EDL can be imported.
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Importing an EDL
PROCEDURE
1.

Optional: Create a new project.
This is not strictly necessary, but helps you keep track of things.

2.

Set up the project frame rate according to the frame rate of the EDL that you want to
import.
For EDL import, Nuendo supports the frame rates 24 fps, 25 fps, 29.97 fps, 29.97 dfps, 30
fps, and 30 dfps.

3.

Select File > Import > EDL CMX3600.

4.

Select the file that you want to import and click Open.

5.

In the Import Options dialog in the Import column, activate the marker tracks that you
want to import.
You can also select all tracks by clicking Select All Tracks.

6.

In the sections Marker Options - Video and Marker Options - Audio, select whether you
want to import position or cycle markers.

7.

Click OK to import the EDL file.
If there are EDL edits outside the current project range, you are asked if you want the
range to be automatically adjusted.

Scene Detection with EDL files
EDL CMX3600 files can also be used for scene detection. Scene detection can be useful if you
want to fill specific sections of your project with a certain background atmosphere. To do so, set
the locators to the cycle marker and select Edit > Functions > Fill Loop. On import, each scene is
indicated by a colored cycle marker.
Nuendo supports the following ways of scene naming:
●

Number scene naming (25-3-5) where the first number signifies the scene, the second the
setting or shooting angle, and the third the take number.
As separators, the following characters can be used:

●

●

comma ,

●

semicolon ;

●

full stop .

●

hyphen -

●

underscore _

●

slash /

●

backslash \

Clip scene naming
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Recommendations
When exporting EDLs from your offline editing system, keep the following rules in mind in order
to achieve the best import results in Nuendo:
●

Export your EDL in CMX3600 format.
Nuendo only supports the CMX3600 format.

●

Add clip names as comments to the EDL and use a consistent naming scheme.
These names are used for naming markers and detecting scenes.

NOTE
Make sure that you set the correct export options in your video editing application when creating
the EDL.

CSV Files
In Nuendo, you can import CSV (Comma Separated Values) files that were created with an
additional program (taker program, etc.) or manually (text editor, Excel, Open Office, etc.). The
values in the file should be separated by comma, semicolon, or tab and must contain at least the
timecode information. Make sure that the CSV file uses the file extension .csv.
On import, the data in the CSV file will be interpreted as markers. For example, these help you to
detect the exact timecode position of each audio or video clip. This is extremely useful if you
want to create dubbed or synchronized audio versions of your video.

Importing a CSV File
PROCEDURE
1.

Optional: Create a new project.
This is not strictly necessary, but helps you keep track of things.

2.

Set up the project frame rate according to the frame rate of the CSV file that you want to
import.
For CSV import, Nuendo supports the frame rates 24 fps, 25 fps, 29.97 fps, 29.97 dfps, 30
fps, and 30 dfps.

3.

Select File > Import > CSV Marker.

4.

Select the file that you want to import and click Open.

5.

In the CSV Import - Encoding dialog, make your settings and click OK to apply them.
If you are not sure which encoding method was used, select the Autodetect option.
NOTE
The Preview section gives you visual feedback of how Nuendo interprets the data
contained in the CSV file. If the data is not displayed correctly, try another encoding
method.
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6.

In the CSV Import - Attribute Selection dialog, make your settings and click OK to apply
them.
NOTE
At least the attribute for Timecode in has to be assigned.

7.

In the Import Options dialog, select the tracks that you want to import by activating the
corresponding tracks in the Import column to the left, or select all tracks by clicking Select
All Tracks.

8.

Click OK to import the CSV file and close the dialog.

RESULT
The data contained in the CSV file is imported into marker tracks in Nuendo.
RELATED LINKS
CSV Import - Encoding on page 349
CSV Import - Attribute Selection on page 349
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CSV Import - Encoding
The Encoding page of the CSV Import dialog allows you to select the encoding method and the
separators.

1

Encoding
Allows you to select the encoding method of the file that you want to import. If you are not
sure which encoding method was used, select Autodetect.

2

Separator
Allows you to select the separator type of the CSV file that you want to import.

3

Preview
Gives you visual feedback of how Nuendo interprets the data contained in the CSV file.
NOTE
If the data is not displayed correctly, try another encoding method.

CSV Import - Attribute Selection
The Attribute Selection page of the CSV Import dialog allows you to assign marker attributes to
the columns.
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1

Column pop-up menus
These menus allow you to assign marker attributes. You must assign at least Timecode In.

2

Ignore first rows
Allows you to specify how many lines you want to exclude from import. Use this if your CSV
file contains column headers that you want to exclude from import.

3

Append numbers to a marker attribute
Allows you to add a counter to a marker attribute. This is useful if you later sort the marker
list by this attribute in the Markers window.
NOTE
Do not use this attribute to split your CSV file.

4

Generate multiple marker tracks
Activate this if you want the markers to be placed on different tracks.

5

Split using Column
Allows you to specify by what column the markers are sorted. This specifies that all lines
with the same value in the split column are imported into the same marker track in
Nuendo.

Exporting Markers as CSV File
You can export the markers you set up in Nuendo as CSV (Comma Separated Values) files to use
them as dispositions. These are useful in recording studios, as they allow you to determine for
how long a specific narrator is needed, etc. This makes it easier to calculate time and costs of a
synchronization project.
PROCEDURE
1.

Set up the markers for your project.

2.

Select File > Export > CSV Marker.

3.

In the Export Options dialog, activate the marker tracks that you want to export in the
Export column.
To select all marker tracks, click Select All.

4.

On the right of the dialog, make your settings.

5.

Optional: To specify which marker attributes you want to export, click Select Attributes,
and in the CSV Export - Attribute Selection dialog, make your settings.
Click OK to confirm your attribute selection and close the Select Attributes dialog.

6.

Click OK to export your markers as a CSV file.
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Export Options
The Export Options dialog allows you to specify which marker tracks are exported and how the
files are encoded.

Export column
Allows you to activate the tracks that you want to export.
Select All
Allows you to activate all tracks for export.
Encoding pop-up menu
Allows you to select an encoding format for your CSV file. The available formats are:
UTF8, UTF16, Win-1252/Win Latin1, MacRoman, Mac Central European, and Shift JIS.
Separator
Activate one of the options to specify the kind of separator used in your file. The
available options are: Comma (default setting), Semicolon, and Tab.
Sort rows chronologically
Activate this if you want to sort the markers according to their position on the
timeline.
Sort track after track
Activate this if you want to sort the markers by their track name.
Generate Column Headings
Activate this if you want to generate column headings.
Export Marker ID
Activate this if you want to export the marker ID.
Select Attributes
Allows you to open the CSV Export - Attribute Selection dialog where you can
specify which marker attributes you want to export.
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Attribute Selection
The Attribute Selection section of the Export Options dialog allows you to specify which
attributes should be exported.

Export all used attributes
Allows you to export all used attributes, that is attributes where at least one marker
has a value.
Export used attributes of these categories
Allows you to select specific attribute categories only.
RELATED LINKS
Marker Attributes on page 337

Importing Markers via MIDI
You can import position markers by importing MIDI files containing markers. This is useful if you
want to use your marker tracks in other projects or if you want to share them with other Nuendo
users. Any markers you have added are included in the MIDI file as standard MIDI file marker
events.
●

Activate Import Markers in the Preferences dialog (MIDI—MIDI File page).

The following settings are imported:
●

The start position of position markers and cycle markers

●

The track assignment of markers

●

All marker tracks

NOTE
If you import a standard MIDI file created in other applications, all markers are merged on one
marker track.

RELATED LINKS
Importing MIDI Files on page 285

Exporting Markers via MIDI
You can export your markers as part of a MIDI file.
●

To include any markers in the MIDI file, activate Export Markers in the Export Options
dialog.

The following settings are exported:
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●

The start position of position markers and cycle markers

●

The track assignment of markers

●

All marker tracks

NOTE
To be able to export markers via MIDI export, your project must contain at least one marker
track.

RELATED LINKS
Exporting MIDI Tracks as Standard MIDI File on page 164

Importing Markers as Part of a Track Archive
You can import position markers and cycle markers by importing track archives containing
marker tracks. Select the tracks that you want to import in the Import Options dialog.
The following settings are imported:
●

The start and end positions of cycle markers

●

The track assignment of markers

●

The marker IDs

●

The attributes

●

All marker tracks

RELATED LINKS
Importing Tracks from Track Archive on page 161

Exporting Markers as Part of a Track Archive
If you want to use your marker tracks in other projects, for example to share them with other
users, you can export them as part of a track archive. To do so, select the marker tracks that you
want to export. Then select File > Export > Selected Tracks.
The following settings are exported:
●

The start and end positions of cycle markers

●

The track assignment of markers

●

The marker IDs

●

The attributes

●

All marker tracks

RELATED LINKS
Exporting Tracks as Track Archive on page 163
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The ADR panel allows you to perform ADR (Automated Dialogue Replacement) and language
dubbing tasks.
Sometimes, it is necessary to re-record dialogue from production tracks or dub them in a
different language. When you do this, the original takes are played back to allow the dubbing
actor to listen to the original production track as a guide. The actor can then rehearse the
dialogue and re-record it. These tasks can be performed with the ADR functions that are located
in the ADR panel.
●

To open the ADR panel, select Project > ADR Panel.

To get the most out of the ADR functions, it is important that you understand the following
concepts:
●

ADR and selecting markers

●

ADR statuses

●

ADR modes

ADR and Marker Selection
The ADR functionality makes extensive use of markers.
In the marker list, you can select cycle markers to set the start and end position for Rehearse,
Record, and Review.
If you select position markers, only the start position is set.
If no marker is selected and Free Run is deactivated, the start position for any ADR status is
determined by the left locator. If Free Run is activated, the start position is determined by the
project cursor position.

354

ADR
ADR Statuses
NOTE
You can also select multiple markers, for example, to combine multiple takes.

RELATED LINKS
ADR Statuses on page 355
ADR Modes on page 355

ADR Statuses
The ADR statuses Rehearse, Record, and Review are transport functions that were designed
specifically for ADR tasks.

1

Rehearse
Allows you to play back the take, so that the artist can rehearse it.

2

Record
Allows you to record the take on the record-enabled track.

3

Review
Allows you to play back the recorded take for review.

NOTE
The ADR statuses take into account all settings in the ADR Setup window.

RELATED LINKS
ADR Setup on page 357

ADR Modes
You can activate or deactivate Free Run mode.
NOTE
The ADR modes take into account all settings in the ADR Setup window.
Free Run Off (Automatic)
This mode allows you to record a take according to the position and length of the
selected marker. In the different ADR statuses, the following happens:
●

If you click Rehearse, a locator range according to the position and length of the selected
markers is selected in the Project window ruler. The project cursor jumps to the start of
the Pre-roll phase and playback starts. At the end, the project cursor automatically jumps
back to the start position.

●

If you click Record, the project cursor jumps to the start of the Pre-roll phase and playback
starts. When the left locator is reached, recording starts. At the end of the Post-roll phase,
recording stops automatically and the project cursor jumps back to the left locator. The
recorded event is automatically resized to this position.

●

If you click Review, the project cursor jumps to the start of the Pre-roll phase and
playback starts. At the end of the Post-roll phase, playback stops automatically and the
project cursor jumps back to the take start position.

355

ADR
ADR Panel
Free Run On
Activate Free Run for more flexibility. It allows you to use the project cursor position
as the ADR start position. You can set the project cursor position manually or using a
marker in the marker list. Free Run works as follows:
●

If you click Rehearse, the left locator is set to the project cursor position and playback
starts from there. If Pre is enabled, playback starts with the pre-roll that you defined in the
ADR Setup window. Playback stops when you click Stop.

●

If you click Record, the project cursor jumps to the take start position and recording starts.
If Pre is enabled, playback starts at the beginning of the pre-roll phase and recording
starts when the take start position is reached. Recording stops when you click Stop.

●

If you click Review, the project cursor jumps to the take start position and playback starts.
If Pre is enabled, playback starts at the beginning of the pre-roll phase. Playback stops
when you click Stop.
NOTE
If Return to Start Position on Stop is activated in the Preferences dialog (Transport
page), the project cursor returns to the take start position.

ADR Panel
The ADR panel is located in the lower part of the Markers window.
●

To open the ADR panel, select Project > ADR Panel.

1

Locate Previous/Next Marker in Markers Window
Allows you to select the previous/next marker in the marker list. If Cycle follows when
locating to Markers is activated in the Marker Settings, the corresponding locator range
is also selected in the Project window ruler.

2

Pre-Roll On/Off
Allows you to activate/deactivate a pre-roll for the Free Run Mode.

3

Free Run Mode On/Off
Activate this mode to start from the project cursor position. On stop, the cursor returns to
the start position by default. You can change this by deactivating Return to Start Position
on Stop in the Preferences dialog (Transport page).
Deactivate this mode to use the selected cycle marker. Pre-roll and post-roll are
determined by the settings on the General tab in the ADR Setup window.

4

Rehearse
Plays back the selected take so that the artist can rehearse it.

5

Record
Records the selected take on the record-enabled track.

6

Review
Plays back the take for review. To enable this, on the Signal Switchboard tab, activate
Take in Review mode for Other Audio for the Control Room and Cue 1.
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7

Guide Track for Cue 1 On/Off
Allows you to mute the guide track for cue 1.

8

Guide Track for Control Room On/Off
Allows you to mute the guide track for the Control Room.

9

Setup
Allows you to open the ADR Setup window.

10

Marker Settings
Allows you to show the marker settings.

11

Show ADR Panel
Allows you to show/hide the ADR panel.

12

Show Details View
Allows you to show/hide the details view.

RELATED LINKS
ADR Modes on page 355
ADR Setup - Signal Switchboard on page 359
ADR Setup on page 357

ADR Setup
The ADR Setup dialog allows you to set up your ADR project.
The following tabs are available:
●

General

●

Video

●

Signal Switchboard

ADR Setup - General
The General tab allows you to define the ADR track assignment.

1

Pre-roll/Post-roll
Allows you to enter a Pre-roll/Post-roll value.
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NOTE
You can set a value for Audio Pre-Record Seconds in the Preferences dialog (Record—
Audio page). The post-record time corresponds to the post-roll time.
2

ADR Track Assignment
Allows you to specify which tracks you want to use as guide, M&E, and mic signal.

3

Record-Enable Target Track
Allows you to automatically record-enable the target track. To enable this, you must set up
the Target Track marker attribute.

4

Record File Naming Scheme
Allows you to specify a naming scheme for the recorded files that is added to the track
name as a suffix.

ADR Setup - Video
The Video tab allows you to define the video overlays.

1

Pre-roll/Post-roll
Allows you to enter a Pre-roll/Post-roll value.
NOTE
You can set a value for Audio Pre-Record Seconds in the Preferences dialog (Record—
Audio page). The post-record time corresponds to the post-roll time.

2

Primary Swipe
Activate this to display a bar that swipes from the left to the right side of the Video Player
window as a take start indicator. The Pre-roll value defines the duration of the swipe.
Activate Swipe to Center to display two bars that swipe from the left and right sides to the
center of the Video Player window.

3

Counter
Activate this to display a count-in by numbers as a take start indicator in the Video Player
window. Specify a start number in the value field to the right. The interval between each
count is one second. The metronome is automatically synchronized with the counter.
Activate Invert Counter to invert the order of the displayed numbers.
Activate Show Black during Pre-/Post-roll to show a black picture during pre-roll and
post-roll.

4

Show Dialogue during ADR/Always Show Dialogue
These options allow you to show the dialogue attribute of the selected marker.
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Activate Show Dialogue during ADR to display the Dialogue marker attribute as a video
overlay in the Video Player window during one of the ADR modes.
Activate Always Show Dialogue to always display the dialogue marker attribute.
5

Take Length Indicator
Activate this to show a take length indicator at the bottom of the Video Player window.

6

ADR Status Indicator
Rehearse status is indicated with a yellow indicator, record status with a red indicator, and
review with a green indicator.
Activate this to show an ADR status indicator at the top left corner of the Video Player
window.

7

Secondary Swipe
If you selected multiple markers, activating this option displays a swipe as a pre-roll for
every take.

8

Marker Pre-roll
Allows you to define a pre-roll for the secondary swipes.

ADR Setup - Signal Switchboard
The Signal Switchboard tab allows you to define which signals are heard during the different
ADR phases. This helps you to set up different schemes for the dubbing artist and the ADR
operator, for example.

1

Control Room section
Allows you to specify the track that you hear in the Control Room channel during
rehearse, record, and review. Furthermore, you can determine if you want to hear the
signal during the pre-roll, take, and post-roll phases.

2

Cue selectors
Allow you to switch to another Cue channel.

3

Cue section
Allows you to specify the track that you hear in the selected Cue channel during rehearse,
record, and review. Furthermore, you can determine if you hear the signal during the preroll, take, and post-roll phases.

NOTE
In the MixConsole, make sure that the Control Room and Cue channels are set up correctly.
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Setting Up ADR Tracks
To use the available functions in the ADR panel, you must set up your project first.

Creating a Guide Track
The guide track is to play back the original dialogue that you want to replace.
PROCEDURE
1.

Create an audio track or a group and name it so that you can recognize it as the guide
track.

2.

Set the Output Routing pop-up menu to the stereo output bus that is set as the Main
Mix.

Creating an M&E (Music and Effects) Track
The M&E track is designed to play back music and effects.
PROCEDURE
1.

Create an audio track or group and name it so that you can recognize it as the M&E track.

2.

Set the Output Routing pop-up menu to the stereo output bus that is set as the Main
Mix.

Creating a Mic Signal Track
The Mic Signal track is designed to lead the signal that is to be recorded. For this to work, you
must activate Monitor.
PROCEDURE
1.

Create an audio track for the Mic Signal.

2.

In the Inspector, set the Input Routing pop-up menu to your microphone input bus.

3.

Set the Output Routing pop-up menu to the output bus that is set as the Main Mix.

4.

Activate Monitor for the mic signal track.
NOTE
If you use a mic signal track, set the Auto Monitoring mode to Manual in the Preferences
dialog (VST page) . Otherwise, select Tapemachine Style.

Creating Other Tracks
The other tracks are designed for recording and for playback of your recordings.
PROCEDURE
1.

Create as many other audio tracks as you need.

2.

In the Inspector of each track, set the Input Routing pop-up menu to your microphone
bus.

3.

Set the Output Routing pop-up menu to the output bus that is set as the Main Mix.
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Creating Cue Channels
Cue channels are used for sending cue mixes, also known as headphone mixes, to performers in
the studio during recording.
PROCEDURE
1.

Select Studio > Audio Connections > Control Room.

2.

Activate Enable/Disable Control Room.

3.

Click Add Channel and add at least one Cue channel.

Setting Up the ADR Environment
Setting up your ADR environment includes importing files and defining takes, assigning ADR
tracks, setting up the routing, configuring video overlays, and enabling automatic record for
target tracks.

Importing Files and Defining Takes
Import your files and define the takes that you want to record by creating cycle markers.
PROCEDURE
1.

Select File > Import > Video File and navigate to the video file that you want to import.

2.

Select the guide track, select File > Import > Audio File, and import the audio file for the
dialogue that you want to replace.

3.

Select the M&E track, select File > Import > Audio File, and import the music and effect
sounds.

4.

Play back the guide track and set up cycle markers for all dialogue that you want to rerecord.
NOTE
If you have a take list from a dedicated ADR taker application or an Excel sheet, you can
also import this.

Assigning ADR Tracks
You must define which of your tracks or groups correspond to a specific ADR track. This is useful
for setting up the signal switchboard. The track assignment is stored with the project.
PROCEDURE
1.

Select Project > ADR Panel.

2.

Click Setup

.

The ADR Setup window opens.
3.

Click General.

4.

In the ADR Track Assignment section, use the Guide, M&E, and Mic Signal pop-up menus
to select the tracks that you want to use as guide, M&E, and mic signal tracks.
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Setting Up the Routing for Individual Mixes
You can define which signals are heard during the different ADR phases and set up different
schemes for the dubbing artist and the ADR operator, for example. The routing that you set up is
automatically applied when you use the ADR modes. The settings are saved globally.
PROCEDURE
1.

On the ADR panel, click Setup.

2.

In the ADR Setup window, click Signal Switchboard.
The signal switchboard shows all ADR tracks (sources) for the Control Room (destination)
in the upper section and the cues 1 to 4 (destinations) in the lower section.

3.

Activate the checkboxes for the signals that you want to hear on each ADR track.
To hear the source signal of a specific ADR track during pre-roll, activate the Pre option for
that track. To hear the signal during the take, activate Take. To hear the signal during postroll, activate Post.
NOTE
In the MixConsole, make sure that the Control Room and Cue channels are set up
correctly.

RELATED LINKS
ADR Setup - Signal Switchboard on page 359

Configuring Video Overlays
You can set up different video overlays that may be helpful for the dubbing artist.
PROCEDURE
1.

On the ADR panel, click Setup.

2.

Select the General tab and enter values for Pre-roll and Post-roll.
NOTE
You can set a value for Audio Pre-Record Seconds in the Preferences dialog (Record—
Audio page). The post-record time corresponds to the post-roll time.

3.

Select the Video tab.

4.

In the Video Overlays section, configure which overlays are displayed in the Video Player
window.
●

To enable the timecode display as an overlay in the Video Player window, in the
Studio Setup dialog (Video Player page), activate Show Timecode.

●

To adjust the display position, use the Position pop-up menu.

RELATED LINKS
ADR Setup - General on page 357
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Enabling Dialogue Display in the Video Player
You can display the dialogue that must be replaced or dubbed in the Video Player window or on
a dedicated video output device.
PREREQUISITE
The Dialogue attribute is assigned manually or has been imported via a CSV file.
PROCEDURE
1.

In the Markers window, click Set up Attribute Columns, and activate ADR > Dialogue.
The Dialogue column is displayed in the Markers window.

2.

On the ADR panel, click Setup.

3.

In the ADR Setup window, click Video.

4.

In the Video Overlays section, activate Show Dialogue during ADR.

RESULT
The dialogue of the selected marker is shown in the Video Player window during rehearse,
record, and review.
NOTE
You can activate Always Show Dialogue if you want to see the dialogue always, not only during
ADR.

Enabling Automatic Record-Enabling for Target Tracks
You can automatically record-enable a track when clicking Rehearse, Record, or Review.
PROCEDURE
1.

In the Markers window, click Set up Attribute Columns, and activate General > Target
Track.
The Target Track column is displayed in the Markers window.

2.

On the ADR panel, click Setup.

3.

In the ADR Setup window, click General.

4.

In the Recording section, activate Record-Enable Target Track.

RESULT
You can now use the Target Track column of the Markers window to type in the number of the
track. If you have imported this attribute with the take list, it is shown automatically.
NOTE
Only numbers are allowed as values for the target track attribute.

Rehearsing Takes
PREREQUISITE
Define takes by creating cycle markers and set up the Signal Switchboard as required.
PROCEDURE
1.

In the markers list, select the marker for the take that you want to record.
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2.

On the ADR panel, click Rehearse.

Switching from Rehearse to Record
You can switch from Rehearse to Record without stopping playback. This is useful if you realize
during rehearsing that you want to record straight away.
PREREQUISITE
You are rehearsing a take.
PROCEDURE
●

On the ADR panel, click Record.
●

If you click Record during the pre-roll phase, playback continues and recording
starts only at the take start position.

●

If you click Record during the take phase, recording starts directly at the cursor
position.

Recording Takes
PREREQUISITE
The dubbing artist has rehearsed the take and is ready to record. You have record-enabled the
track on which you want to record.
NOTE
To combine track selection and record-enabling, activate Enable Record on Selected Audio
Track in the Preferences dialog (Editing—Project & MixConsole page).

PROCEDURE
●

On the ADR panel, click Record.

RESULT
The take is recorded.

Reviewing Takes
PROCEDURE
●

On the ADR panel, click Review.

RESULT
The take is played back so that the director and the artist can review it.
NOTE
If you cannot hear the recorded take, open the Signal Switchboard tab and make sure that Take
is activated in Review mode for Other Audio for the Control Room and Cue 1.
AFTER COMPLETING THIS TASK
If you are satisfied with the recording, proceed with the next take.
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NOTE
You can select the next marker in the marker list by clicking Locate Next Marker in Markers
Window on the ADR panel. If Sync Selection is activated in the Marker Settings, the
corresponding take is also selected in the Project window. Make sure that Track Selection
Follows Event Selection is deactivated in the Preferences dialog (Editing page).

365

MixConsole

The MixConsole provides a common environment for producing mixes in stereo or surround. It
allows you to control level, pan, solo/mute status, etc. for audio and MIDI channels. Furthermore,
you can set up the input and output routing for multiple tracks or channels at the same time. You
can undo/redo MixConsole parameter changes for an open project at any time.
You can open the MixConsole in a separate window or in the lower zone of the Project window.
While the MixConsole in the lower zone of the Project window features the key functions for
mixing, the separate MixConsole window gives you access to additional functions and settings.
RELATED LINKS
MixConsole in Lower Zone on page 366
MixConsole Window on page 368

MixConsole in Lower Zone
You can show a MixConsole in the lower zone of the Project window. This is useful if you want to
access the most important MixConsole functions from within a fixed zone of the Project
window. The MixConsole in the lower zone of the Project window is a separate MixConsole that
does not follow any visibility changes you perform in the MixConsole window.
Do one of the following to open a MixConsole in the lower zone of the Project window:
●

Press Alt+F3.

●

Select Studio > MixConsole in Project Window.

The MixConsole in the lower zone of the Project window is divided into the following sections:
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1

Toolbar
The toolbar shows tools and shortcuts for settings and functions in the MixConsole.

2

Fader Section
The fader section is always visible and shows all channels in the same order as in the track
list.

3

Page Selector
Allows you to select what page is displayed in the fader section: the channel faders, the
insert effects for a channel, or the send effects. The top button allows you to show/hide
the toolbar.

RELATED LINKS
Fader Section on page 385
Inserts on page 396
Sends on page 408
Filtering Channel Types on page 375
Undoing/Redoing MixConsole Parameter Changes on page 375
Linking Channels on page 379
Functions Menu on page 383

Showing/Hiding MixConsole Channels in the Lower Zone
To determine what channels are visible in the MixConsole in the lower zone of the Project
window, you must use the Track Visibility in the left zone of the Project window.
PROCEDURE
1.

Click Show/Hide Left Zone on the Project window toolbar to activate the Left Zone.

2.

At the top of the left zone, click the Visibility tab.

3.

At the bottom of the left zone, click the Track tab.

4.

Click to the left of a track name to activate/deactivate the visibility for a channel.

RESULT
The track in the track list and the corresponding MixConsole channel are shown/hidden in the
lower zone of the Project window.
RELATED LINKS
Opening the Track Visibility on page 59
Showing/Hiding Individual Tracks on page 60
Visibility on page 59
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Determining the MixConsole Channel Order in the Lower Zone
You can determine and lock the position of MixConsole channels in the lower zone of the
Project window.
PROCEDURE
1.

At the top of the left zone, click the Visibility tab.

2.

At the bottom of the left zone, click the Zones tab.

3.

Do one of the following:
●

To lock a channel on the left of the fader section, drag the dot next to the channel
name to the left.

●

To lock a channel on the right of the fader section, drag the dot next to the channel
name to the right.

RESULT
The channel is locked. Locked channels are always displayed.
RELATED LINKS
Opening the Zones Visibility on page 61

MixConsole Window
You can open the MixConsole in a separate window.
Do one of the following to open the MixConsole:
●

Press F3.

●

Select Studio > MixConsole.

●

On the Project window toolbar, click Open MixConsole .
NOTE
This is only visible on the toolbar if the section Media & MixConsole Windows is activated.
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The main MixConsole sections are:
1

Toolbar
The toolbar shows tools and shortcuts for settings and functions in the MixConsole.

2

Channel Selector (Left Zone)
Allows you to set up the visibility and positions of channels in the fader section.

3

Channel Racks (Upper Zone)
Allows you to show additional channel controls as needed.

4

Fader Section
The fader section is always visible and shows all channels in the same order as in the track
list.
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Apart from the main sections, you can also access the following sections from within the
MixConsole window:
1

Channel Overview
Displays all channels as boxes. If you have more channels than can be displayed in the
window, you can use the channel overview to navigate to other channels and select them.

2

Meter Bridge
Allows you to monitor the levels of your channels.
To select a meter type, open the meter bridge context menu and select either PPM or
Wave.

3

Equalizer Curve
Allows you to draw an EQ curve. Click in the curve display to open a larger view where you
can edit the curve points.

4

Pictures
Opens the Pictures section that allows you to add a picture to the selected channel.
Pictures can help you identify your MixConsole channels quickly.

5

Notepad
In the Notepad section, you can enter notes and comments about a channel. Each channel
has its own notepad.

6

Control Room/Meter (Right Zone)
Opens the Control Room/Meter section.

RELATED LINKS
Channel Selector on page 371
MixConsole Toolbar on page 372
Fader Section on page 385
Channel Racks on page 378
Track Pictures Browser on page 171
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Adding Notes to a MixConsole Channel on page 412
Control Room on page 420

Channel Selector
The channel selector contains the following tabs: Visibility and Zones that list all channels
contained in your project, and History that lists all MixConsole parameter changes.

Visibility Tab
The Visibility tab allows you to determine which channels are shown in the MixConsole. This is
particularly helpful if you organize your tracks in folder or group tracks.

●

To show/hide channels, check/uncheck them by clicking to the left of the channel name.

●

To collapse/expand groups and folders, click the group or folder name.

NOTE
The MixConsole in the lower zone of the Project window does not follow any visibility changes
you perform in the MixConsole window and vice versa.

Zones Tab
The Zones tab allows you to determine and lock the position of certain channels.

●

To lock channels on the left/right of the fader section, drag the dots next to the channel
names to the left or to the right.
Locked channels are excluded from scrolling and are always visible.
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NOTE
The MixConsole in the lower zone of the Project window does not follow any visibility changes
you perform in the MixConsole window and vice versa.

History Tab
The History tab allows you to view and undo/redo MixConsole parameter changes. All
MixConsole parameter changes are shown in a list.

●

To undo MixConsole parameter actions, click Undo . You can also click the orange line in
the history list and drag it up.

●

To redo MixConsole parameter actions, click Redo
the history list and drag it down.

. You can also click the orange line in

RELATED LINKS
Undoing/Redoing MixConsole Parameter Changes on page 375

Synchronizing Channel and Track Visibility
You can synchronize the channel visibility in the MixConsole with the track visibility in the
Project window.
PROCEDURE
1.

In the Channel Selector, open the Visibility tab.

2.

Click Sync Visibility of Project and MixConsole: On/Off

3.

Select Sync MixConsole and Project to synchronize the channel visibility with the track
visibility.

.

RESULT
The track and channel visibility are synchronized.
NOTE
Channels that are locked in the Zones tab are not synchronized.

RELATED LINKS
Synchronizing Track and Channel Visibility on page 61

MixConsole Toolbar
The toolbar contains tools and shortcuts for settings and functions in the MixConsole.
NOTE
The MixConsole toolbar contains a limited set of tools in the lower zone of the Project window.
This includes: MixConsole History, Channel Filter Types, Search, Link Group, Zoom Palette,
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Mixer Functions Menu, and Window Zone Controls. You can show/hide the toolbar by clicking
Show/Hide MixConsole Toolbar.
MixConsole History
These buttons allow you to undo/redo MixConsole parameter changes.
Left Divider

Allows you to use the left divider. Tools that are placed to the left of the divider are
always shown.
Search
Opens a selector that lists all tracks/channels.
Channel Filter Types
Opens the channel filter that allows you to show/hide all channels of a certain
channel type.
Channel Visibility Configurations
Allows you to create configurations that are useful for switching quickly between
different visibility setups.
Channel Visibility Agents
Allows you to select channels with specific properties.
Select Rack Types
Opens the rack selector that allows you to show/hide specific racks.
Rack Settings
Opens a pop-up menu with settings for the racks.
Go to Left/Right Locator Position
Allows you to go to the left/right locator positions.
Left/Right Locator Position
Shows the left/right locator positions.
Transport Buttons

Shows the transport controls.
Time Display
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Shows the position of the project cursor in the selected time format.
Markers
Allows you to set and locate marker positions.
State Buttons
Allows you to set mute, solo, listen, and automation states. Here you can also bypass
inserts, EQs, channel strips, and sends.
Link Group
Allows you to link channels.
Zoom Palette
Allows you to increase/reduce the channel width and the rack height. You can
change the width for all channels from viewable (narrow) to editable (wide) by using
the default key commands G and H.
System Performance Meter

Shows the meters for ASIO time usage and hard disk transfer load.
Right Divider

Allows you to use the right divider. Tools that are placed to the right of the divider
are always shown.
Mixer Functions Menu
Opens the Functions Menu that allows you to make settings in the MixConsole.
Window Zone Controls
Allow you to show or hide the left zone, the upper zone, and the right zone of the
MixConsole. The Setup Window Layout pop-up menu allows you to show or hide
the status line, the info line, and the overview line.

Finding Channels
The Find Track/Channel function allows you to find specific channels. This is useful if you have a
large project with many channels or if you have hidden channels using the visibility features.
PROCEDURE
1.

Click Find Track/Channel on the MixConsole toolbar to open a selector that lists all
channels.

2.

In the search field, enter the name of the channel.
As you type, the selector filters automatically.

3.

In the selector, select the channel and press Return.
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RESULT
The channel is selected in the channel list.
NOTE
If the channel was outside the view or hidden, it is now shown. Channels that are hidden using
Filter Channel Types are not shown.

Undoing/Redoing MixConsole Parameter Changes
You can undo/redo MixConsole parameter changes and experiment with different MixConsole
settings.
NOTE
MixConsole parameters that change due to read automation actions are not part of the
MixConsole history.
To undo/redo a MixConsole parameter, do one of the following:
●

On the MixConsole toolbar in the MixConsole window or in the lower zone of the Project
window, click Undo or Redo .

●

Press Alt-Z to undo MixConsole parameter changes or press Alt-Shift-Z to redo
parameter changes.

The following MixConsole parameter changes can be undone/redone:
●

Volume changes

●

Panorama changes

●

Changes on the Routing rack

●

Filter, gain, and phase changes in the Pre rack

●

Plug-in changes in the Inserts rack

●

EQ changes

●

Changes on the Channel Strip rack

●

Changes on the Sends rack

●

Changes on the Cue Sends rack

●

Changes on the Direct Routing rack

IMPORTANT
The MixConsole history is not saved with the project.

Filtering Channel Types
The channel types filter on the MixConsole toolbar allows you to determine which channel types
are shown.
PROCEDURE
1.

Click Filter Channel Types.
This opens the channel types filter.
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2.

Click to the left of a channel type to uncheck it and hide all channels of that type.

RESULT
Channels of the filtered type are removed from the fader section and the color of the Filter
Channel Types button changes to indicate that a channel type is hidden.

Channel Visibility Configurations
The Channel Visibility Configurations button on the MixConsole toolbar allows you to create
configurations that are useful for switching quickly between different visibility setups.
The button displays the name of the active configuration. A list of configurations is shown as
soon as you create at least one configuration. To load a configuration, select it from this list.
Channel visibility configurations are saved with the project.
Add Configuration
Opens the Add Configuration dialog that allows you to save the configuration and
enter a name for it.
Update Configuration
If you change the active configuration, this is indicated by an asterisk after the
configuration name. Use this function to save changes to the active configuration.
Rename Configuration
Opens the Rename Configuration dialog that allows you to rename the active
configuration.
Delete Configuration
Allows you to delete the active configuration.
Move Configuration to Position
This function becomes available if 2 or more configurations exist. It allows you to
change the position of the active configuration on the menu. This is useful as you can
assign key commands to the first 8 configurations in the Channel & Track Visibility
category of the Key Commands dialog.

Saving Configurations
To quickly switch between different channel setups, you can save configurations. The
configurations contain visibility and zone settings as well as the show/hide status of channel
types and racks.
PROCEDURE
1.

Set up the configuration that you want to save.

2.

On the toolbar, click Configurations.
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3.

From the pop-up menu, select Add Configuration.

4.

In the Add Configuration dialog, enter a name for the configuration.

5.

Click OK.

RESULT
The configuration is saved and you can return to it at any time.

Channel Visibility Agents
Channel visibility agents allow you to show or hide all channels, selected channels, or channels
with certain properties.
To open the Channel Visibility Agents pop-up menu, do one of the following:
●

Click Channel Visibility Agents on the toolbar.

●

In the Channel Selector, open the Visibility tab and right-click to open the context menu.

Showing Channels with Specific Properties
●

To open the Channel Visibility Agents pop-up menu, click Channel Visibility Agents on
the toolbar.

Show all Channels
Shows all channels of your project.
Show Only Selected Channels
Shows only channels that are selected.
Hide Selected Channels
Hides all channels that are selected.
Show Channels for Tracks with Data
Shows all channels for tracks with events or parts.
Show Channels for Tracks with Data at the Cursor Position
Shows all channels for tracks with events or parts at the cursor position.
Show Channels for Tracks with Data between the Locators
Shows all channels for tracks with events or parts between the locators.
Show Channels that are Connected to the First Selected Channel
Shows all channels that are connected to the channel you first selected.
NOTE
You can assign key commands for the channel visibility agents in the Channel & Track Visibility
category of the Key Commands dialog.

Undoing/Redoing Visibility Changes
You can undo/redo up to 10 visibility changes.
PROCEDURE
1.

On the MixConsole toolbar, click Channel Visibility Agents.

2.

Select Undo Visibility Change or Redo Visibility Change.
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Rack Selector
The rack selector allows you to activate specific MixConsole functions that are organized in
racks, such as routing, insert, or send handling.

Channel Racks
You can activate and deactivate the different channel racks in the MixConsole.
●

To open the rack selector, click Select Racks.

Depending on the channel type, you can activate/deactivate the following racks:
Hardware
Allows you to control your audio hardware effects. This rack is only available if
supported by your hardware.
Routing
Allows you to set up the input and output routing. For MIDI, you can also select the
MIDI channel.
Pre (Filters/Gain/Phase)
For audio-related channels, it contains input filter and gain controls along with Phase
and Gain controls. For MIDI channels, it contains an Input Transformer control.
Inserts
Allows you to select insert effects for your channel.
Equalizers (audio-related channels only)
Allows you to set the channel EQ.
Channel Strip (audio-related channels only)
Allows you to integrate channel strip modules, such as Gate, Compressor, EQ,
Transformer, Saturator, and Limiter that allow you to enhance your sound.
Sends
Allows you to select send effects for your channel.
Cue Sends (audio-related channels only)
Allows you to activate and control the level and pan for up to 4 cue sends.
Direct Routing
Allows you to set and activate outputs for all selected channels at once.
Track Quick Controls
Allows you to add quick controls for instant access.
Device Panels
Allows you to view the available device panels.
VCA
Allows you to view and set connections to VCA faders.

Rack Settings
The Rack Settings pop-up menu allows you to make settings for the racks.
●

To open the Rack Settings pop-up menu, click Rack Settings.
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Exclusive Expanded Rack
Shows the selected rack exclusively and collapses the other racks.
Fixed Number of Slots
Shows all available slots for the Inserts, Sends, Cues, and Quick Controls racks.
Link Racks to Configurations
If this option is activated, the rack status is taken into account when you save and
load a configuration.
Show Pre/Filters as <Combined Label & Setting>
Select Combined Label & Setting if you want to show the label and the setting in
one line.
Select Separate Label & Setting if you want to show the label and the setting in
separate lines.
Show Inserts as <Plug-in & Preset Names>
Select Plug-in Names if you want to show the plug-in names only.
Select Plug-in & Preset Names if you want to show the plug-in and the preset
names.
Show All Channel Strip Controls
Shows all available controls on the Channel Strip rack.
Show One Channel Strip Type
Shows only one channel strip type at a time.
Show Sends as <Combined Destination & Gain>
Select Combined Destination & Gain if you want to show the destination and the
gain in one line.
Select Separate Destination & Gain if you want to show the destination and the
gain in separate lines.
Show Quick Controls as <Combined Destination & Value>
Select Combined Destination & Value if you want to show the destination and the
value in one line.
Select Separate Destination & Value if you want to show the destination and the
value in separate lines.

Linking Channels
You can link selected channels in the MixConsole to form a link group. Any change that is
applied to one channel is mirrored by all linked channels, depending on which settings are
activated in the link group settings.
The Link Group options on the MixConsole toolbar allow you to link channels and to edit links
and linking configuration.
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Link Group Settings
The Link Group Settings dialog allows you to specify the channel settings that are linked.

●

To open the Link Group Settings dialog, click Link on the MixConsole toolbar.

The following options are available:
Name
Allows you to enter a name for the link group.
Volume
Activate this to link the volume of the linked channels.
Pan
Activate this to link the panorama of the linked channels.
EQ
Activate this to link the equalizers of the linked channels.
Dynamics (Compressor, Gate, etc.)
Activate this to link the dynamics of the linked channels.
Sends
Activate this to link the sends of the linked channels.
Inserts
Activate this to link the inserts of the linked channels.
Mute/Solo/Listen
Activate this to link the mute, solo, and listen states of the linked channels.
Automation Read/Write
Activate this to link the automation read/write states of the linked channels.
Routing
Activate this to link the routing of the linked channels.
Selection
Activate this to link the selection of the linked channels.
Record Enable/Monitor
Activate this to link the record enable/monitor states of the linked channels.
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NOTE
By default the volume, sends, routing, and selection settings are activated.

Display Line
Whenever you create a link group, a display line is added on top of the fader section in the
MixConsole.

The display line shows the number and the name of the created link group and provides a Link
Settings pop-up menu that allows you to edit the link group settings.
On the display line, you can change the name of the link group by double-clicking and entering a
different name. If you hold down a modifier key and double-click the name, the Link Group
Settings dialog opens.
The pop-up menu provides the following options:
Unlink Selected Channels
Only available for a selected link group. Select this option to remove the link between
the channels. This removes the link group.
Edit Link Group Settings
Allows you to change the link group settings.
Included in Link Group: <name of link group>
Shows the link group to which the selected channel belongs. You can assign the
selected channel to a different link group. This removes the channel from the current
group. If you only want to remove the selected channel from the link group, select
None.
Linked Channels
Shows which channels are linked in the link group.
RELATED LINKS
Changing the Link Group Settings on page 382
Adding Channels to Link Groups on page 382
Removing Channels from Link Groups on page 382
VCA Faders on page 414

Creating Link Groups
You can link several channels to form a link group.
PROCEDURE
1.

Select the channels that you want to link.

2.

On the MixConsole toolbar, click Link.

3.

In the Link Group Settings dialog, activate the parameters that you want to link.

4.

Click OK.

RESULT
The number and name of the link group is indicated above the channel name in the display line.
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NOTE
●

If you link groups, insert and channel strip module linking is applied at the slot level. For
example, if you change the settings for insert slot 3 on one channel, these changes are
also applied to slot 3 on the other channels. Insert effects in other slots remain unaffected.

●

If you select a channel that belongs to a link group, all channels in this link group are
selected by default. To prevent the multiple selection of all channels that belong to a link
group, deactivate Selection in the Link Group Settings dialog.

RELATED LINKS
Link Group Settings on page 380

Changing the Link Group Settings
If you change a setting for a channel of a link group, the change is applied to the whole group.
●

To change the link settings for an existing link group, select the group, on the MixConsole
toolbar, click Edit Link Group Settings, and change the settings in the Link Group
Settings dialog.

●

To unlink channels, select one of the linked channels and click Link on the MixConsole
toolbar.

●

To prevent the multiple selection of all channels that belong to a link group, deactivate
Selection in the Link Group Settings dialog.

●

To make individual settings and changes for a channel in a link group, activate Sus on the
MixConsole toolbar or press Alt.

●

To make absolute instead of relative value changes, activate Abs on the MixConsole
toolbar.

NOTE
The automation tracks for linked channels are not affected by the Link function.

RELATED LINKS
Link Group Settings on page 380

Adding Channels to Link Groups
You can add a channel to an existing link group.
PROCEDURE
1.

On the display line of the channel that you want to add, open the pop-up menu.

2.

Select Included in Link Group: <None> and select the link group.

RESULT
The channel is added to the link group.

Removing Channels from Link Groups
You can remove a channel from an existing link group.
PROCEDURE
1.

On the display line of the channel that you want to remove, open the pop-up menu.

2.

Select Included in Link Group: <link group name>, and from the link group list, select
None.
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RESULT
The channel is removed from the link group.

Using Quick Link
You can activate the Temporary Link Mode to synchronize all touched parameters of selected
channels.
PROCEDURE
1.

Select the channels that you want to link.

2.

On the MixConsole toolbar, activate Q-Link.
NOTE
You can also press Shift-Alt to temporarily link channels. In that case, the link is only active
as long as you press the keys.

3.

Change the parameters for one of the selected channels.

RESULT
The changes are applied to all selected channels until you deactivate Q-Link.

Functions Menu
The Functions Menu contains tools and shortcuts for settings and functions in the MixConsole.
●

To open the Functions Menu, click Functions Menu in the top right corner of the
MixConsole.

Scroll to Selected Channel
If this option is activated and you select a channel in the Visibility tab, the selected
channel is automatically displayed in the Fader section.
Copy First Selected Channel’s Settings
Copies the settings of the first selected channel.
Paste Settings to Selected Channels
Pastes the settings to the selected channels.
Zoom
Opens a submenu where you can increase or reduce the channel width and the rack
height.
Open Audio Connections
Opens the Audio Connections window.
Control Room Cue Channels
Opens a submenu where you can activate/deactivate cue channels and change level
and panning settings.
Constrain Delay Compensation
Allows you to activate/deactivate the Constrain Delay Compensation that keeps all
channels in perfect sync and automatically compensates any delay inherent in VST
plug-ins during playback.

383

MixConsole
MixConsole Window
Direct Routing: Summing Mode On/Off
Allows you to feed your signals to several outputs at the same time.
After Fader Listen Mode
Allows you to enable/disable that the signal of a listen-enabled channel is routed to
the MixConsole channel after applying the fader and pan settings.
EQ/Filter Transition
Allows you to change the EQ/Filter Transition mode from Soft to Quick.
Save Selected Channels
Saves the settings for the selected channels.
Load Selected Channels
Loads the settings for the selected channels.
Global Meter Settings
Opens a submenu where you can set up the global meter settings.
Reset MixConsole Channels
Allows you to reset EQ, insert, and send effect settings for all or selected channels.
Solo and mute buttons are deactivated, the volume fader is set to 0 dB, and pan is set
to the center position.
Link MixConsoles
If you opened more than one MixConsole, you can link them.

Saving MixConsole Settings
You can save MixConsole settings for selected audio-related channels in the MixConsole and
load them into any project.
PROCEDURE
1.

Select the channels with the settings that you want to save.

2.

Select Functions > Save Selected Channels.

3.

In the file dialog, specify the file name and location.

4.

Click Save.

RESULT
The settings for the selected channels are saved with the file extension .vmx. The input/output
routing is not saved.

Loading MixConsole Settings
You can load MixConsole settings that have been saved for selected channels.
PROCEDURE
1.

Select the same number of channels that you selected when you saved your MixConsole
settings.
The loaded MixConsole settings are applied in the same order as originally saved. For
example, if you have saved the settings for channels 4, 6, and 8, and apply these settings
to channels 1, 2, and 3, the settings saved for channel 4 are applied to channel 1, the
settings saved for channel 6 to channel 2, and so on.

2.

Select Functions > Load Selected Channels.

3.

In the Load Selected Channels dialog, select the .vmx settings file and click Open.
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RESULT
The channel settings are applied to the selected channels.
NOTE
When you apply loaded MixConsole settings to fewer channels, some of the saved settings are
not applied. Since the saved settings are applied from left to right as shown in the MixConsole,
the settings for the channels furthest to the right are not applied to any channels.

Fader Section
The fader section is the heart of the MixConsole. It shows input and output channels together
with audio, instrument, MIDI, group, FX, VCA fader, and ReWire channels.

NOTE
If a channel is deactivated in the channel selector or if its channel type is deactivated, it is not
shown in the fader section. The MixConsole in the lower zone of the Project window does not
follow any visibility changes you perform in the MixConsole window and vice versa. It is linked to
the track visibility of the Project window.
The fader section allows you to do the following:
●

Edit link group settings

●

Set panorama

●

Activate mute and solo

●

Enable Listen mode

●

Open channel settings

●

Set volume

●

Enable automation

●

Set input levels
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NOTE
All fader section functions and settings are also available in the MixConsole in the lower zone of
the Project window.

RELATED LINKS
Changing the Link Group Settings on page 382
Using Channel Settings on page 387
Write/Read Automation on page 695
Showing/Hiding MixConsole Channels in the Lower Zone on page 367

Setting Pan
For each audio-related channel with at least a stereo output configuration, you can find a pan
control at the top of the fader section. For MIDI channels, the pan control sends out MIDI pan
messages. The result depends on how your MIDI instrument is set to respond to pan.
The pan control allows you to position a channel in the stereo spectrum. This control is different
for stereo and surround configurations. Channels with a multi-channel output configuration
feature a miniature VST MultiPanner control.
●

To make fine adjustments, hold down Shift when you move the pan control.

●

To select the default center pan position, hold down Ctrl/Cmd, and click the pan control.

●

To edit the value numerically, double-click the pan control.

RELATED LINKS
Creating New Projects on page 85
Surround Sound on page 647

Stereo Balance Panner
The stereo balance panner allows you to control the balance between the left and right channels.
It is activated by default.

Stereo Combined Panner
With the stereo combined panner, the left and right pan controls are linked and keep their
relative distance if you move them. It is available for channels with a stereo input and output
configuration.
●

To activate this panner, open the context menu for a pan control and select Stereo
Combined Panner.

●

To set the pan independently for the left and right channels, hold down Alt and drag left
or right.

●

To reverse the left and right channels, pan the left channel to the right and the right to the
left.
The area between the pan controls changes the color to indicate that the channels are
reversed.

●

To sum two channels, set them to the same pan position (mono).
Note that this increases the volume of the signal.
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●

To specify the default stereo panner mode for new audio tracks, set the Default Stereo
Panner Mode in the Preferences dialog (VST page).

Panning Bypass
You can bypass the panning for all audio-related channels.
●

To activate panning bypass, click the button to the left or press Ctrl/Cmd-Alt-Shift and
click the pan control.

●

To deactivate panning bypass, press Ctrl/Cmd-Alt-Shift and click again.

When panning is bypassed for a channel, the following happens:
●

Mono channels are panned center.

●

Stereo channels are panned hard left and right.

●

Surround channels are panned center.

Using Solo and Mute
You can silence one or several channels using Solo and Mute.
●

To silence a channel, click Mute.
Click again to deactivate the mute state for the channel.

●

To mute all other channels, click Solo for a channel.
Click again to deactivate the solo state.

●

To deactivate the mute or solo states for all channels simultaneously, click Deactivate All
Mute States or Deactivate All Solo States.

●

To activate exclusive solo mode, hold down Ctrl/Cmd and click Solo for the channel.
The Solo buttons of all other channels are deactivated.

●

To activate solo defeat for a channel, Alt-click Solo.

You can also click and hold Solo to activate solo defeat. In this mode, the channel is not
muted when you solo another channel. Alt-click again to deactivate solo defeat.

Listen Mode
The listen mode allows you to quickly check the signal that is coming from selected channels
without interrupting and interfering with the actual mix. During a recording session it allows the
sound engineer in the control room to attenuate the signal that is coming from one of the
musicians while the recording continues undisturbed, for example.
NOTE
To enable the listen mode, you need to enable the Control Room.
●

To enable the listen mode, click Listen for a channel.
This routes the channel to the Control Room without interrupting the signal flow.

●

To turn off listen mode for all channels simultaneously, click Deactivate All Listen States
on the MixConsole toolbar.

Using Channel Settings
You can open each MixConsole channel in a separate Channel Settings window. This allows for
better overview and editing of the channel settings.
●

To open the channel settings for a specific channel, click E in the fader section.
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The Channel Settings window for audio-related channels is divided into several sections:
●

Channel Inserts

●

Channel Faders

●

Direct Routing

●

Channel Sends

The Channel Strip and Equalizer are always available.
The sections are arranged in zones at the left and right of the Channel Settings window.
●

To show a pane with options to open or close the sections, position the mouse pointer at
one of the edges of the Channel Settings window.

The channel settings are especially suitable for the following actions:
●

Routing inserts
This is done on the Routing tab in the Inserts section.

●

Moving the channel strip to Pre/Post-Inserts position
By default, the inserts are positioned before the channel strip in the signal flow. In the
Inserts section, you can change this by clicking the arrow at the top of the Strip tab. The
tabs are swapped.

●

Making EQ settings
The channel settings feature a large EQ curve display with several modes. By default, the
equalizer controls are hidden, but you can click the little button at the top right corner to
show the equalizer controls or the equalizer knob controls below the EQ curve.
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●

Panning sends
This is done on the Panning tab in the Sends section.

●

Showing the output chain
If you click Show Output Chain
on the toolbar, the output chain is shown in the
Channel Faders section. This allows you to keep track of more complicated output
routings.

●

Browsing through channels

RELATED LINKS
Equalizer Settings on page 398
Routing Editor on page 449
Direct Routing on page 409

Browsing through Channels
Every channel has its own Channel Settings window, but you can view any channel’s settings
from a single window. This allows you to have a single Channel Settings window open in a
convenient position on the screen and use it for all your EQ and channel effect settings.
To select a channel in the Channel Settings window, proceed as follows:
●

To show the previous/next channel, click Go to Previous/Next Channel.

●

To browse through the edited channels, click Go to Last/Next Edited Channel.
The buttons are only available if at least 2 channels have been edited.

●

Click the channel name or the Search tool on the toolbar and select a channel.

●

Select a channel in the MixConsole to select the corresponding channel in the Channel
Settings window.
This is the default behavior. If this is not what you want, open the Functions menu and
deactivate Follow ‘e’ buttons or selection changes.

●

Select a track in the Project window to select the corresponding channel in the
MixConsole and the Channel Settings window.
This is the default behavior. If this is not what you want, deactivate Sync Selection in
Project Window and MixConsole in the Preferences dialog (Editing—Project &
MixConsole page).
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Setting Volume
Each channel in the fader section of the MixConsole has a volume fader. The fader levels are
displayed below the fader, in dB for audio-related channels and as MIDI volume (0 to 127) for
MIDI channels.
●

To change the volume, move the fader up or down.

●

To make fine volume adjustments, press Shift while moving the faders.

●

To reset the volume to its default value, press Ctrl/Cmd and click a fader.

For audio channels, the volume fader controls the volume of the channel before it is routed to an
output bus, directly or via a group channel. For output channels, the volume fader controls the
master output level of all audio channels that are routed to an output bus. For MIDI channels,
the volume fader controls the volume changes in the MixConsole by sending out MIDI volume
messages to the connected instruments that are set to respond to MIDI messages.

Global Meter Setting
You can change the meter characteristics for audio channels using the context menu of the
channel meter.
Right-click the channel meter and select one of the following options from the Global Meter
Settings menu:
Meter Peak Options - Hold Peaks
The highest registered levels are held and shown as static horizontal lines in the
meter.
Meter Peak Options - Hold Forever
If this option is activated, the peak levels are shown until you reset the meters. If this
option is deactivated, you can use the Meters’ Peak Hold Time parameter in the
Preferences dialog (Metering page) to specify for how long the peak levels are held.
The peak hold time can be between 500 and 30000 ms.
Meter Position - Input
If this option is activated, the meters show input levels for all audio channels and
input/output channels. The input meters are post input gain.
Meter Position - Post-Fader
If this option is activated, the meters show post-fader levels.
Meter Position - Post-Panner
If this option is activated, the meters show post-fader levels and also reflect pan
settings.
Reset Meters
Resets the meters.

Level Meters
The channel meters show the level when you play back audio or MIDI. The Meter Peak Level
indicator shows the highest registered level.
●

To reset the peak level, Alt-click the Meter Peak Level value.

NOTE
Input and output channels have clipping indicators. When they light up, lower the gain or the
levels until the indicator is no longer lit.
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Input Levels
When recording digital sound, it is important to set the input levels high enough to ensure low
noise and high audio quality. At the same time, you must avoid clipping (digital distortion).

Setting Input Levels
PROCEDURE
1.

Select Functions > Global Meter Settings > Meter Position and activate Input.
In this mode, the input channel level meters show the level of the signal at the input of the
bus, before any adjustments, such as input gain, EQ, effects, level, or pan are made. This
allows you to check the level of the unprocessed signal coming into the audio hardware.

2.

Play back the audio and check the level meter for the input channel.
The signal should be as loud as possible without exceeding 0 dB, that is, the clipping
indicator for the input bus should not light up.

3.

4.

If necessary, adjust the input level in one of the following ways:
●

Adjust the output level of the sound source or the external mixer.

●

If possible, use the audio hardware’s own application program to set the input
levels. Refer to the documentation for the audio hardware.

●

If your audio hardware supports the ASIO control panel function, it may be possible
to make input level settings. To open the ASIO control panel, select Studio > Studio
Setup and in the Devices list, select your audio card. When this is selected, you can
open the control panel by clicking Control Panel in the settings section to the right.

Optional: Select Functions > Global Meter Settings > Meter Position and activate PostFader.
NOTE
This allows you to check the level of the audio being written to a file on your hard disk,
which is only necessary if you make any adjustments to the input channel.

5.

Optional: In the Channel Racks section, in the Inserts rack, click a slot and select an
effect, or in the Equalizers rack, make your EQ settings.
For some effects you may want to adjust the level of the signal going into the effect. Use
the input gain function for this. Press Shift or Alt to adjust the input gain.

6.

Play back the audio and check the level meter of the input channel.
The signal should be reasonably loud without exceeding 0 dB, that is, the clipping indicator
for the input bus should not light up.

7.

If necessary, use the input channel fader to adjust the signal level.

Clipping
Clipping typically occurs in the audio hardware when an analog signal is too loud and therefore
converted to digital in the hardware’s A/D converters.
Clipping can also occur when the signal from the input bus is written to a file on your hard disk.
The reason for this is that you can make settings for the input bus, adding EQ, effects, etc. to the
signal while it is being recorded. This may raise the level of the signal, which causes clipping in
the recorded audio file.
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Working with Channel Racks
The Channel Racks section contains specific MixConsole functions, such as routing, insert, or
send handling. These are organized in racks.

NOTE
The MixConsole in the lower zone of the Project window features the Inserts and the Sends
rack only.

RELATED LINKS
Routing on page 393
Pre (Filters/Gain/Phase) on page 395
Inserts on page 396
Equalizers (EQ) on page 398
Channel Strips on page 400
Sends on page 408
Cue Sends on page 408
Direct Routing on page 409
Track Quick Controls on page 411
Device Panels on page 412

Copying and Moving Rack and Channel Settings
You can use drag and drop to copy or move rack and channel settings.
NOTE
This function is only available in the MixConsole window.
Drag and drop works between different channels or different rack slots on the same channel.
When you drag, a visual feedback indicates the sections where you can drop your settings.
The following applies:
●

To move the rack settings from one rack to another, drag the rack and drop it on the rack
to which you want to move the settings.

●

To copy the rack settings from one rack to another, press Alt, drag the rack, and drop it on
the rack to which you want to copy the settings.

●

To copy the channel settings from one channel to another, drag the channel and drop it on
the channel to which you want to copy the settings.
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You can copy rack and channel settings between different types of channels, provided that the
target channels have corresponding settings.
●

For example, copying from input/output channels leaves the sends settings in the target
channel unaffected.

●

For projects with surround sound, any insert effects that are routed to surround speaker
channels become muted when the settings are pasted to a mono or stereo channel.

Routing
The Routing rack allows you to configure input and output routing, that is, setting up input and
output busses.
NOTE
This channel rack is only available in the MixConsole window.
Input busses are used when you record on an audio track. In this case, you must select from
which input bus the audio is received.
NOTE
The settings that you make for the input channel will be a permanent part of the recorded audio
file.
Output busses are used when you play back an audio, group, or FX channel. In this case, you
must route the channel to an output bus.
You can route the outputs from multiple audio channels to a group. For example, to control the
channel levels using one fader, and to apply the same effects and equalization to all the
channels.

Setting up Routing
PREREQUISITE
Set up busses and group channels in the Audio Connections window.
PROCEDURE
1.

On the MixConsole toolbar, click Racks and activate Routing to show the Routing rack
above the fader section.

2.

Click one of the slots of the Routing rack to open the input or the output routing pop-up
menu for a channel.

3.

In the routing selector, select an entry.
●

To set up the routing for multiple selected channels simultaneously, press Shift-Alt
and select a bus.

●

To set several selected channels to incrementing busses (the second selected
channel to the second bus, the third to the third bus, etc.), press Shift and select a
bus.

●

To disconnect input or output bus assignments, select No Bus.
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Input Busses
The input routing selector only lists busses that correspond to the channel configuration.
NOTE
If you select a group channel as input for an audio channel, you can record a downmix.
Input Routing Configurations for Mono Channels
●

Mono input busses or individual channels within a stereo or surround input bus.

●

External inputs configured on the Control Room tab of the Audio Connections window.
These can be mono or individual channels within a stereo or surround bus. They can also
be routed to the Talkback input.

●

Mono output busses, mono group output busses, or mono FX channel output busses.
These should not lead to feedback.

RELATED LINKS
Routing on page 393
Input Routing Configurations for Stereo Channels
●

Mono or stereo input busses or stereo child busses within a surround bus.

●

External inputs that are configured on the Control Room tab of the Audio Connections
window.
These can be mono input busses or stereo input busses. They can also be routed to the
Talkback input.

●

Mono or stereo output busses, mono or stereo group output busses, and mono or stereo
FX channel output busses.
These should not lead to feedback.

RELATED LINKS
Routing on page 393
Input Routing Configurations for Surround Channels
●

Surround input busses.

●

External inputs that are configured on the Control Room tab of the Audio Connections
window.
These must have the same input configuration.

●

Output busses.
These must have the same input configuration and should not lead to feedback.

RELATED LINKS
Routing on page 393

Output Busses
For output busses any assignment is possible.

Using Group Channels
You can route the outputs from multiple audio channels to a group. This enables you to control
the channel levels using one fader, apply the same effects and EQ to all channels, etc. You can
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also select a group channel as input for an audio track, to record a downmix of separate tracks,
for example.
PREREQUISITE
You have created and set up a group channel track in stereo.
PROCEDURE
1.

Route the group channel track to an output bus.

2.

Add effects to the group channel as insert effects.

3.

Route the mono audio track to the group channel.

RESULT
The signal from the mono audio track is sent directly to the group, where it passes through the
insert effect, in stereo.

Pre (Filters/Gain/Phase)
The Pre rack for audio-related channels features a high-cut and a low-cut filter as well as gain
and phase settings.
NOTE
This channel rack is only available in the MixConsole window.
For MIDI channels the Pre rack allows you to open the Input Transformer.
NOTE
You cannot edit the Pre rack settings in the EQ curve display.

RELATED LINKS
Input Transformer Window on page 765
Equalizer Settings on page 398

Making Filter Settings
Each audio-related channel has separate high-cut and low-cut filters that allow you to attenuate
signals with frequencies that are higher or lower than the cutoff frequency.
PROCEDURE
1.

On the MixConsole toolbar, click Racks and activate Pre (Filters/Gain/Phase) to show the
Pre rack above the fader section.

2.

Click to the left of the high-cut filter to activate the high-cut filter. You have the following
options:
●

Drag the slider to adjust the cutoff frequency.
The available range spans from 20 kHz to 50 Hz.

●

Click Select Filter Slope on the right of the high-cut filter to select a filter slope.
You can choose between 6, 12, 24, 36, and 48 dB. The default value is 12 dB.

3.

Click to the left of the low-cut filter to activate the low-cut filter. You have the following
options:
●

Drag the slider to adjust the cutoff frequency.

●

Click Select Filter Slope on the right of the low-cut filter to select a filter slope.

The available range spans from 20 Hz to 20 kHz.
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You can choose between 6, 12, 24, 36, and 48 dB. The default value is 12 dB.
RESULT
The changed settings are visible in the curve display. If you deactivate the high-cut and low-cut
filters, the filter curves are removed from the display. Bypassed high-cut and low-cut filters are
displayed in a different color.

Making Input Gain Settings
The Pre-Gain slider allows you to change the level of a signal before it reaches the EQ and the
effects section. This is useful as the level going into certain effects can change the way the signal
is affected. A compressor, for example, can be driven harder by raising the input gain. Gain can
also be used to boost the level of poorly recorded signals.
PROCEDURE
1.

On the MixConsole toolbar, click Racks and activate Pre (Filters/Gain/Phase) to show the
Pre rack above the fader section.

2.

Drag the Gain slider to the left or to the right to cut or boost the gain.

Making Phase Settings
Each audio-related channel and input/output channel has a Phase button that allows you to
correct the phase for balanced lines and microphones that are wired backwards or that are out
of phase due to their positioning.
PROCEDURE
1.

On the MixConsole toolbar, click Racks and activate Pre (Filters/Gain/Phase) to show the
Pre rack above the fader section.

2.

Activate Phase to invert the phase polarity for the signal.

Inserts
The Inserts rack for audio-related channels features insert effect slots that allow you to load
insert effects for a channel. For MIDI channels you can load MIDI inserts.
For further information, see the separate document Plug-in Reference.
RELATED LINKS
Audio Effects on page 441

Adding Insert Effects
PROCEDURE
1.

On the MixConsole toolbar, click Racks and activate Inserts to show the Inserts rack
above the fader section.

2.

Click one of the insert slots to open the insert selector.

3.

Click an insert effect to select it.

RESULT
The selected insert effect is loaded and automatically activated. Its plug-in panel opens.
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Moving Inserts to Post-Fader or Pre-Fader Position
For each audio-related channel, you can add pre-fader and post-fader inserts.
PROCEDURE
●

Do one of the following:
●

Right-click an insert effect in a pre-fader position, and from the context menu, select
Set as last Pre-Fader Slot.

●

Click and drag the separator for pre-/post-fader slots up or down.

RESULT
The number of pre-fader and post-fader slots is adjusted. The color and the separator line show
which effect is pre-fader and which is post-fader.

Bypassing Insert Effects
●

To bypass all inserts, click Bypass at the top of the Inserts rack.

●

To bypass a single insert, click the button on the left of the inserts slot.

●

To deactivate bypass, click the button again.

Activating Side-Chain for Inserts
Some of the inserts feature side-chain functionality.
PROCEDURE
1.

Right-click an insert effect.

2.

From the context menu, select Activate Side-Chain.

Saving/Loading FX Chain Presets
You can save and load all insert rack settings using FX chain presets. FX chain presets have the
file name extension .fxchainpreset.
PROCEDURE
●

In the top right corner of the Inserts rack, open the Presets pop-up menu and perform
one of the following actions:
●

To save the current settings as a preset, select Save FX Chain Preset and name your
preset.

●

To load a preset, select Load FX Chain Preset and select a preset.

NOTE
You can also apply inserts together with EQ and channel strip settings from track presets.
You can load, tag, and save FX chain presets in the MediaBay.
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RELATED LINKS
Applying FX Chains on page 475

Equalizers (EQ)
The Equalizers (EQ) rack is only available for audio-related channels. It features a built-in
parametric equalizer with up to 4 bands for each audio channel.
NOTE
This channel rack is only available in the MixConsole window.

Activating Equalizer Bands
PROCEDURE
1.

On the MixConsole toolbar, click Racks and activate Equalizers to show the EQ rack above
the fader section.

2.

Click Activate Band to activate an EQ band.

Equalizer Settings
You can make equalizer settings for the 4 bands. These have different default frequency values
and different Q names. However, they all have the same frequency range (20 Hz to 20 kHz). You
can specify different filter types for each individual module.

1

Bypass EQ
Click to bypass all EQ bands.

2

Curve Display
Click on the display in a channel to show a larger version. The display is also available in
the Equalizers section of the Inspector and in the Channel Settings dialog.
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Hovering with the mouse over the display shows a cross-hair cursor. The current mouse
position shows the frequency, note value, offset, and level at the top or bottom of the
display.
●

Click and hold to add a curve point and activate the corresponding EQ band.

●

Double-click the curve point to deactivate it.

●

Drag the curve point up or down to adjust the gain.

●

Press Ctrl/Cmd to edit only the gain.

●

Drag left or right to adjust the frequency.

●

Press Alt to edit only the frequency.

●

Press Shift while dragging to set the Q-factor.

●

To invert the EQ curve, open the context menu and select Invert EQ Settings.

The final curve shows the EQ settings as well as active high-cut and low-cut filters of the
Pre rack settings. Bypassed filter settings are shown in a different color than the active
settings. Disabled filter settings are hidden from the display.
NOTE
You cannot edit the high-cut and low-cut filters in the curve display. To edit the filters, open
the Pre rack.
3

Select Preset
Opens a pop-up menu where you can load/save a preset.

4

Activate Band
Click to activate/deactivate an EQ band.

Band Settings

1

Activate Band
Activates the equalizer band.

2

Gain
Set the amount of cut or boost. The range is ±24 dB.

3

Frequency
Sets the center frequency of the frequency range to be cut or boosted. You can set the
frequency either in Hz or as a note value. If you enter a note value, the frequency is
automatically displayed in Hz. For example, a note value of A3 sets the frequency to 440
Hz. When you enter a note value, you can also enter a cent offset. For example, enter A5
-23 or C4 +49.
NOTE
Ensure that you enter a space between the note and the cent offset. Only in this case, the
cent offsets are taken into account.

4

Q-Factor
Determines the width of the affected frequency range. Higher values give narrower
frequency ranges.

5

Type
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Opens a pop-up menu where you can select an EQ type for the band. Bands 1 and 4 can
act as parametric, shelving, or high/low-cut filters. EQ bands 2 and 3 are always parametric
filters.
RELATED LINKS
Making Filter Settings on page 395

Saving/Loading EQ Presets
You can save and load EQ presets.
PROCEDURE
●

In the top right corner of the EQ rack, open the presets pop-up menu and perform one of
the following actions:
●

To save the current settings as a preset, select Save Preset and name your preset.

●

To load a preset, select Load Preset and select a preset.

NOTE
You can also apply EQ together with insert and channel strip settings from track presets.
You can load, tag, and save EQ presets in the MediaBay.

Channel Strips
The Channel Strip rack is only available for audio-related channels. It allows you to load built-in
processing modules for separate channels.
NOTE
This channel rack is only available in the MixConsole window.

Channel Strip Modules
The channel strips allow you to apply modules directly to specific channels. You can change the
position of specific modules in the signal flow via drag and drop.
Gate
Allows you to silence audio signals below a set threshold level. As soon as the signal
level exceeds the set threshold, the gate opens to let the signal through.
Compressor
Allows you to create smooth compression effects. Drag the compressor up or down
to change its position in the signal flow.
EQ
Allows you to make EQ settings.
Tools
Provides various tools.
Sat
Allows you to add warmth to the sound.
Limit
Allows you to avoid clipping even at high levels.
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Noise Gate
Noise gating silences audio signals below a set threshold. As soon as the signal level exceeds the
threshold, the gate opens to let the signal through.
Threshold (-60 to 0 dB)
Determines the level at which Gate is activated. Signal levels above the set threshold
trigger the gate to open, and signal levels below the set threshold close the gate.
Side-Chain
Activates the external side-chain.
Release (10 to 1000 ms or Auto mode)
Sets the time after which the gate closes (after the set Hold time). If Auto Release is
activated, Gate automatically finds the best release setting for the audio material.
State LED
Indicates whether the gate is open (LED lights up in green), closed (LED lights up in
red), or in an intermediate state (LED lights up in yellow).
Attack (0.1 to 1000 ms)
Sets the time after which the gate opens when it is triggered.
Range
Adjusts the attenuation of the gate when it is shut. If Range is set to
, the gate is
completely shut. The higher the value, the higher the level of the signal that passes
through the shut gate.
Activate Filter
Activates/Deactivates the internal side-chain and allows you to set up a filter to
modify the signal detection.
Filter Frequency (50 to 20000 Hz)
If the internal side-chain is activated, this parameter sets the filter frequency for the
signal detection.
Q-Factor (0.01 to 10000)
If the internal side-chain is activated, this parameter sets the resonance of the filter
for the signal detection.
Listen Filter
Allows you to monitor the filtered signal.
Compressor
This channel strip module reduces the dynamic range of the audio, making softer sounds louder
or louder sounds softer, or both. Open the pop-up menu to select between Standard
Compressor, Tube Compressor, and Vintage Compressor.

Standard Compressor
Allows you to create smooth compression effects. Drag the compressor up or down to change its
position in the signal flow.
Threshold (-60 to 0 dB)
Determines the level where the compressor kicks in. Only signal levels above the set
threshold are processed.
Side-Chain
Activates the external side-chain.
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Ratio (1:1 to 8:1)
Sets the amount of gain reduction that is applied to signals above the set threshold.
A ratio of 3:1 means that for every 3 dB the input level increases, the output level
increases by 1 dB.
Gain Reduction LED
Indicates the amount of compression of the signal.
Attack (0.1 to 100 ms)
Determines how fast the compressor responds to signals above the set threshold. If
the attack time is long, more of the early part of the signal passes through
unprocessed.
Release (10 to 1000 ms or Auto mode)
Sets the time after which the gain returns to the original level when the signal drops
below the threshold. If Auto is activated, the compressor automatically finds the best
release setting for the audio material.
Make-up (0 to 24 dB or Auto mode)
Compensates for output gain loss that is caused by compression. If Auto is activated,
the knob becomes dark and the output is automatically adjusted for gain loss.

Tube Compressor
This versatile compressor with integrated tube-simulation allows you to achieve smooth and
warm compression effects. The VU meter shows the amount of gain reduction. Tube
Compressor features an internal side-chain section that lets you filter the trigger signal.
Input (-24.0 to 48.0 dB)
Determines the compression amount. The higher the input gain, the more
compression is applied.
Side-chain
Activates the external side-chain.
Output (-12.0 to 12.0 dB)
Sets the output gain.
Gain Reduction LED
Indicates the amount of compression of the signal.
Attack (0.1 to 100.0 ms)
Determines how fast the compressor responds. If the attack time is long, more of the
initial part of the signal passes through unprocessed.
Release (10 to 1000 ms or Auto mode)
Sets the time after which the gain returns to the original level. If Auto is activated,
Tube Compressor automatically finds the best release setting for the audio material.
Drive (1.0 to 6.0)
Controls the amount of tube saturation.
Mix (0 to 100)
Sets the level balance between the dry signal and the wet signal.

VintageCompressor
VintageCompressor is modeled after vintage type compressors.
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Input (-24 to 48 dB)
In combination with the Output setting, this parameter determines the compression
amount. The higher the input gain setting and the lower the output gain setting, the
more compression is applied.
Side-chain
Activates the external side-chain.
Output (-48 to 24 dB)
Sets the output gain.
Gain Reduction LED
Indicates the amount of compression of the signal.
Attack (0.1 to 100 ms)
Determines how fast the compressor responds. If the attack time is long, more of the
early part of the signal passes through unprocessed.
Punch (On/Off)
If this option is activated, the early attack phase of the signal is preserved, retaining
the original punch in the audio material, even with short Attack settings.
Release (10 to 1000 ms or Auto mode)
Sets the time after which the gain returns to its original level. If Auto is activated,
Vintage Compressor automatically finds the best release setting for the audio
material.
EQ
You can make equalizer settings for the 4 bands. These have different default frequency values
and different Q names. However, they all have the same frequency range (20 Hz to 20 kHz). You
can specify different filter types for each individual module.

1

Activate Band x
Activates the equalizer band.

2

Select EQ Band x Type
Opens a pop-up menu where you can select an EQ type for the band. Bands 1 and 4 can
act as parametric, shelving, or high/low-cut filters. EQ bands 2 and 3 are always parametric
filters.

3

Gain
Sets the amount of cut or boost.

4

Freq
Sets the center frequency of the frequency range to be cut or boosted.

5

Q
Determines the width of the affected frequency range. Higher values give narrower
frequency ranges.
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Tools
Provides various tools.

DeEsser
This channel strip module reduces excessive sibilance, primarily for vocal and speech recordings.
Basically, it is a special type of compressor that is tuned to be sensitive to the frequencies
produced by the s-sound. Close proximity microphone placement and equalizing can lead to
situations where the overall sound is just right, but there is a problem with sibilants.
Reduction
Controls the intensity of the de-essing effect.
Side-Chain
Activates the internal side-chain filter. The input signal can then be shaped according
to the filter parameters. Internal side-chaining can be useful for tailoring how the
gate operates.
Release
Sets the time after which the de-essing effect returns to zero when the signal drops
below the threshold.
Gain Reduction LED
Indicates the amount of compression of the signal.
Threshold
If Auto is deactivated, you can use this control to set a threshold for the incoming
signal level above which the plug-in starts to reduce the sibilants.
Auto
Automatically and continually chooses an optimum threshold setting independent of
the input signal. The Auto option does not work for low-level signals (<-30 db peak
level). To reduce the sibilants in such a signal, set the threshold manually.
Low-Frequency
Allows you to set the low frequency band.
High-Frequency
Allows you to set the high frequency band.
Solo
Allows you to solo the frequency band to find the appropriate position and width of
that band.
Diff
Allows you to listen to the sounds that the de-esser removes from the signal.

EnvelopeShaper
This channel strip module can be used to attenuate or boost the gain of the attack and release
phase of audio material. You can use the knobs to change parameter values. Be careful with
levels when boosting the gain and if needed reduce the output level to avoid clipping.
Attack (-20 to 20 dB)
Changes the gain of the attack phase of the signal.
SC (Side-Chain)
Activates the external side-chain.
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Release (-20 to 20 dB)
Changes the gain of the release phase of the signal.
Length (5 to 200 ms)
Determines the length of the attack phase.
Output (-24 to 12 dB)
Sets the output level.
Sat
Allows you to add warmth to the sound. Open the pop-up menu to select between Magneto II,
Tape Saturation, and Tube Saturation.

Magneto II
This channel strip module simulates the saturation and compression of recording on analog tape
machines.
Saturation
Determines the amount of saturation and the generation of overtones. This leads to
a small increase in input gain.
Dual Mode
Simulates the use of two tape machines.
Saturation On/Off
Activates/Deactivates the saturation effect.
Output
Allows you to adjust the output level.
Saturation Amount LED
Indicates the amount of saturation of the signal.
Low-Frequency
Sets the frequency range of the spectrum band to which the tape effect is applied.
To avoid the saturation of lower frequencies, set the value to 200 Hz or 300 Hz.
High-Frequency
Sets the frequency range of the spectrum band to which the tape effect is applied.
To avoid the saturation of very high frequencies, set the Freq Hi parameter to values
below 10 kHz.
Solo
Allows you to hear only the set frequency range including the tape simulation effect.
This helps you to determine the appropriate frequency range.
HF-Adjust
Sets the amount of high frequency content of the saturated signal.
HF-Adjust On/Off
Activates/Deactivates the HF-Adjust filter.

Tape Saturation
This channel strip module simulates the saturation and compression of recording on analog tape
machines.
Drive
Controls the amount of tape saturation.
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Dual Mode
Simulates the use of two tape machines.
Auto Gain
Adjusts the gain automatically.
Output
Sets the output gain.
Drive Amount LED
Indicates the amount of drive of the signal.
Low-Frequency
This is a low shelving filter with fixed frequency.
High-Frequency
This is a Hi Cut filter. Use the frequency fader to reduce harshness of the output
signal.

Tube Saturation
This channel strip module simulates the saturation and compression of recording of analogue
tube compressors.
Drive
Controls the amount of tube saturation.
Output Gain
Sets the output gain.
Drive Amount LED
Indicates the amount of drive of the signal.
Low-Frequency
This is a low shelving filter with fixed frequency.
High-Frequency
This is a Hi Cut filter. Use the frequency fader to reduce harshness.
Limit
Allows you to avoid clipping even at high levels. Open the pop-up menu to select between
Brickwall Limiter, Maximizer, and Standard Limiter.

Brickwall Limiter
Brickwall Limiter ensures that the output level never exceeds a set limit.
Due to its fast attack time, Brickwall Limiter can reduce even short audio level peaks without
creating audible artifacts. However, this channel strip module creates a latency of 1 ms.
Threshold (-20 to 0 dB)
Determines the level where the limiter kicks in. Only signal levels above the set
threshold are processed.
Release (ms)
Sets the time after which the gain returns to the original level when the signal drops
below the threshold. If Auto is activated, Brickwall Limiter automatically finds the
best release setting for the audio material.
Gain Reduction LED
Displays the amount of gain reduction.
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Maximizer
This channel strip module raises the loudness of audio material without the risk of clipping.
Optimize
Determines the loudness of the signal.
Output (-24 to 6 dB)
Determines the maximum output level. Set this to 0 dB to avoid clipping.
Gain Reduction LED
Displays the amount of gain reduction.
Mix (0 to 100)
Sets the level balance between the dry signal and the wet signal.

Standard Limiter
This channel strip module is designed to ensure that the output level does not exceed a set
output level, to avoid clipping in following devices. Limiter can adjust and optimize the Release
parameter automatically according to the audio material, or it can be set manually.
Input (-24 to 24 dB)
Adjusts the input gain.
Output (-24 to 6 dB)
Determines the maximum output level.
Gain Reduction LED
Displays the amount of gain reduction.
Release (0.1 to 1000 ms or Auto mode)
Sets the amount of time it takes for the gain to return to its original level. If Auto is
activated, Limiter automatically finds the best release setting for the audio material.

Saving/Loading Strip Presets
You can save and load strip presets. Strip presets have the file name extension .strippreset.
PROCEDURE
●

In the top right corner of the Channel Strip rack, open the Presets pop-up menu and
perform one of the following actions:
●

To save the current settings as a preset, select Save Strip Preset and name your
preset.

●

To load a preset, select Load Strip Preset and select a preset.

NOTE
You can also apply channel strip settings together with insert and EQ settings from track
presets. You can load, tag, and save strip presets in the MediaBay.

RELATED LINKS
Loading Strip Presets on page 639
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Sends
The Sends rack for audio-related channels features send effect slots that allow you to load send
effects and value sliders that allow you to determine the send level for a channel. For MIDI
channels the Sends rack features send effect slots that allow you to load send effects.

Adding Send Effects
PROCEDURE
1.

On the MixConsole toolbar, click Racks and activate Sends to show the rack above the
fader section.

2.

Click one of the send slots to open the send selector.

3.

Click a send effect to select it.
The selected send effect is loaded.

4.

Click on the left of the slot to activate the send.

Bypassing Send Effects
●

To bypass all sends, click the bypass button at the top of the Sends rack.

●

To deactivate bypass, click the button again.

Adding FX Channels to a Send
PROCEDURE
1.

Right-click on the send slot to open the context menu.

2.

Select Add FX Channel to <send name>.

3.

In the Add FX Channel Track window, select the effect and configuration.

4.

Click Add Track.

RESULT
The FX channel track is added in the Project window, and the send is automatically routed to it.

Cue Sends
Cue sends allow you to create discrete cue mixes that performers can listen to during recording.
Essentially, cue sends are stereo aux sends that are routed to cue channel outputs in the Control
Room.
NOTE
This channel rack is only available in the MixConsole window.
For every cue channel defined in the Audio Connections window, each channel in the
MixConsole has a cue send, with level, pan, and pre/post-fader selection.

Adding Cue Sends
PREREQUISITE
Create a cue channel in the Audio Connections window and activate the Control Room.
PROCEDURE
1.

On the MixConsole toolbar, click Racks and activate Cue Sends to show the rack above
the fader section.
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2.

Click one of the slots to open the send selector.
The cue sends are displayed.

3.

Click on the left of the slot to activate the cue send.

RESULT
You can now change the level and pan settings.

Direct Routing
In addition to the main output, the Direct Routing rack allows you to set up 7 routing
destinations that are positioned post-fader and post-panner in the signal path. This way, you can
switch the destination of channels and create different mix versions in one go.
In the Direct Routing rack, the first routing slot mirrors the routing of the main output.
NOTE
The Direct Routing rack is not available in the Channel Settings window.
Direct routing is available for audio, instrument, sampler, FX channel tracks, groups, and output
busses. You can also set and activate outputs for several selected channels at once.
RELATED LINKS
Setting Up Direct Routing on page 409
Automatic Downmixing on page 410

Setting Up Direct Routing
In the Direct Routing rack you can assign up to 8 routing destinations to each channel.
PROCEDURE
1.

On the MixConsole toolbar, click Racks and activate Direct Routing.
The Direct Routing rack is shown above the fader section.

2.

Select all channels for which you want to set up the same destinations, press Shift-Alt and
click in the first slot of the Direct Routing rack.

3.

In the routing selector, select the main output for the selected channels.
NOTE
We recommend that you choose the same set of destinations for all channels that belong
together. The main output should also have the widest channel configuration, since it is
used as a reference for all additional output destinations.
IMPORTANT
The routing of the main output in the first Direct Routing slot defines the channel width.
For several functions in Nuendo, for example, Export Audio Mixdown or surround
panning, to work as expected, the main output routing must be set correctly.

4.

Click in the next destination slot and select another output.

5.

Do this for as many destination slots as required (up to 8).
After routing your audio tracks to groups, you can route the groups to output busses.

6.

For each channel, you can now activate the appropriate routing destination by clicking on
the corresponding slot.
The active routing destination lights up.
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Automating Destination Switches
Especially in larger postproduction scenarios you often need to switch the output destinations
for audio-related tracks. Automating these switches is especially useful for FX channel tracks that
carry insert effects such as reverb that you want to apply to different stems. You can also
automate switches if a certain type of sound is sometimes part of the ambience stem and at
other times needs to be fed to the SFX stem.
PROCEDURE
1.

Play back your project and take note of the positions where routing changes are
necessary.

2.

Write-enable the corresponding track.

3.

At the right moment, click on the routing destination to which you want to switch.
The new destination is now active, and the switch has been recorded as automation data.

4.

Continue to record destination changes for your project.
NOTE
To switch destinations for multiple channels simultaneously, select these channels and
keep Shift-Alt pressed when activating a different destination.

Feeding Signals to Multiple Destinations
Direct routing offers a summing mode, allowing you to feed your signals to several outputs at
the same time. This is useful if you want to apply an effect to several stems at the same time, for
example.
PROCEDURE
1.

Set up your output busses as routing destinations.

2.

In the Direct Routing rack, open the context menu and activate Summing Mode for all
channels that you want to sum.

NOTE
To activate this setting for all channels at once use the Link function.
3.

Activate all outputs to which you want to route the selected channels.

RELATED LINKS
Setting up Routing on page 393

Automatic Downmixing
The output in the first Direct Routing slot defines the channel width. Since the other
destinations are positioned post-panner in the signal path, they have the same channel width to
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start with, and the signal needs to be converted accordingly by downmixing. Nuendo does that
automatically.
NOTE
Always select the output with the widest channel configuration in the first slot. It is not
recommended to use a setup where the main output has less channels than the direct routing
destination even though it is technically possible. Upmixing might lead to unexpected side
effects.
When performing an automatic downmix from 5.1 to stereo, the levels are adjusted as follows:
Automatic Downmixing from 5.1 to stereo
L
L

R

0.0

R

0.0

C

Lfe

Ls

-3.01

-3.01

-6.02

-3.01

-3.01

Rs

-6.02

Center and Lfe signals are split to L and R channels, Ls and Rs are sent to L and R respectively,
but reduced in volume.
When performing an automatic downmix from 7.1 Music (Dolby) to 5.1 the levels are adjusted as
follows:
Automatic Downmixing from 7.1 Music (Dolby) to 5.1
L
L

R

C

Lfe

Ls

Rs

0.0

R
C

Sl

Sr

-3.01
0.0

-3.01
0.0

Lfe

0.0

Ls

0.0

Rs

-3.01
0.0

-3.01

Sl and Sr signals are split to L/R and Ls/Rs respectively, but reduced in volume.

Track Quick Controls
Track Quick Controls give you instant access to up to 8 different parameters, for example, track,
effect, or instrument controls.
This saves you from having to click your way through the various windows and sections
pertaining to your track.
NOTE
This channel rack is only available in the MixConsole window.
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Adding Track Quick Controls in the MixConsole
PROCEDURE
1.

On the MixConsole toolbar, click Racks and activate Track Quick Controls to show the
rack above the fader section.

2.

Click one of the slots to open a selector.

3.

Select a parameter from the list.

RESULT
The selected parameter is loaded and automatically activated as Track Quick Control.
RELATED LINKS
Assigning MixConsole Parameters to Quick Controls on page 744

Device Panels
You can display device panels, for example, for external MIDI devices, audio track panels, or VST
insert effect panels.
NOTE
This channel rack is only available in the MixConsole window.
For information on how to create or import MIDI device panels, see the separate document MIDI
Devices.
RELATED LINKS
About Device panels on page 782

Adding Notes to a MixConsole Channel
PROCEDURE
1.

Position the mouse pointer at the top edge of the MixConsole, and activate Notepad.
The Notepad section is shown above the fader section.

2.

Select the channel for which you want to add notes, click in the notepad section and type
in your notes.

3.

To close the notepad, press Esc, or click in another section of the MixConsole.

Keyboard Focus in the MixConsole
The channel selector section, the channel rack section, and the fader section can be controlled
with the computer keyboard.
For this to work, the section must have the focus. If a section has the keyboard focus, the border
that surrounds it is highlighted in a specific color.

Activating Keyboard Focus
PROCEDURE
1.

Click in an empty area of the section to activate the keyboard focus.

2.

Press Tab to activate the next section. This allows you to cycle forward through the
sections.
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3.

Press Shift-Tab to activate the previous section.

Navigating in a Section
Once you have activated the focus for a section, you can control it with the computer keyboard.
In the channel racks section and in the fader section, controls that are selected for keyboard
control are indicated by a red border.
●

To navigate through the controls, use the Up Arrow, Down Arrow, Left Arrow, Right
Arrow keys.

●

To activate or deactivate a switch, press Return.

●

To expand or collapse an active rack, to open or close a value field in a slot, or to open the
plug-in panel for a loaded plug-in, press Return.

●

To access the controls in the left zone, press Ctrl/Cmd-Return.

●

To access the controls in the middle zone, press Return.

●

To access the controls in the right zone, press Alt-Return.

●

To close a pop-up menu or a plug-in panel, press Esc.

●

To enable or disable the loaded plug-in, press Ctrl/Cmd-Alt-Return.
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VCA faders serve as remote controls for channel faders in the MixConsole.
VCA stands for Voltage-Controlled Amplifier. VCA faders were originally found on hardware
mixing desks. They allowed the user to control the volume levels of several mixer channels with
only one fader. To assign channel faders to a VCA fader, the respective channels must be
physically connected with the VCA fader.
In Nuendo, the VCA fader function is based on the same concept. VCA faders can be connected
with different types of audio-related channels. This allows the VCA faders to control the volume
of the connected channels. A channel can be connected to only one VCA fader.
From a technical perspective, moving a VCA fader to a different dB level adds or subtracts the
new value to or from the original values of the connected channels.
EXAMPLE
A channel has a level of -6 dB, the VCA fader is at the 0 position. If you move the VCA fader to a
level of +3 dB, this value is added to the level of the connected channel. The connected channel
now has a level of -3 dB.

VCA Fader Settings
VCA fader channels are different from the default fader channels.
VCA faders have no panner. Their fader caps have a color different from the other fader
channels. If you change the name and the color of the VCA fader, this is reflected in the
connected channels on the VCA rack.

1

Peak meter that displays the summed up level of the meters of all connected channels

2

Fader cap
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3

Fader name and color

The VCA channel rack provides the following options:
Disconnect All Channels
Disconnects the VCA fader from all connected channels.
Combine Automation of VCA and Connected Channels
Combines the automation of VCA fader and connected channels. This has the effect
that the original automation settings of the connected channels are replaced by the
combined automation and that the automation of the VCA fader is reset to its
original position. In the Project window, the automation curve of the VCA fader is
reset to the static value line. In the MixConsole, the VCA fader is reset to the 0
position.
RELATED LINKS
VCA Fader Automation on page 416
Creating Smooth Transitions Between Automation Events (Bézier Automation Curves) on page
699
Link Group Settings on page 380

Creating VCA Faders
You can create VCA faders in several ways.
VCA faders can be created in the MixConsole and in the Project window.
In the MixConsole, you have the following options:
●

You can create unassigned VCA faders in the fader section. They are placed at the right
end of the fader section in front of the output channels. You can connect the VCA faders to
channels using the VCA rack at a later stage.To create unassigned VCA faders in the
MixConsole, right-click in the fader section and select Add VCA Fader.

●

You can create VCA faders and automatically connect them to selected channels.

In the Project window, you can create VCA fader tracks in the track list. The VCA faders are
placed in a VCA Tracks folder at the end of the track list. The VCA faders can be connected to
channels using the VCA rack in the MixConsole at a later stage.
NOTE
You can delete VCA faders only in the Project window.

RELATED LINKS
VCA Rack on page 417
Creating VCA Faders for a Selection of Channels on page 415
VCA Fader Track on page 152
Adding Tracks on page 158

Creating VCA Faders for a Selection of Channels
You can select several channels and automatically create and connect a VCA fader.
NOTE
You can also connect VCA faders to a selection of channels using the VCA rack.
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PROCEDURE
1.

Select several channels in the MixConsole.

2.

Right-click one of the selected channels.

3.

In the context menu, select Add VCA Fader to Selected Channels.

RESULT
A VCA fader is created and placed to the right of the selected faders. In the Project window, the
VCA track is placed below the selected tracks.
RELATED LINKS
Connecting Several Channels with VCA Faders on page 418

Nested VCA Faders
VCA faders can control other VCA faders.
If you use several VCA faders that control different channels, you can create another VCA fader
that controls the VCA faders. This allows you to control the volume level of more than one
selection of connected channels at the same time.
Technically, a VCA fader that controls other VCA faders affects the volume level of all VCA faders
and all connected channels.
EXAMPLE
A VCA fader (main fader) controls a nested VCA fader that has been set to -10 dB. The latter VCA
fader controls a connected channel that had an original level of -3 dB and that is set to -13 dB. If
you change the main fader level from 0 to +4 dB, the controlled VCA fader is set to a level of -6 dB,
and the connected channel is set to a level of -9 dB.

VCA Fader Automation
VCA fader automation affects the volume automation of the connected channels.
VCA faders have their own, independent automation track. Whenever you write automation for a
VCA fader, it affects the volume automation of the connected channels. The automation of the
connected channels and the VCA fader are combined, which you can hear and see. On the
automation tracks of the connected channels, this is visualized as follows:
●

If the VCA fader and its connected channel have volume automation, the VCA fader
automation influences the existing volume automation of the connected channel. The
automation tracks show the original automation and the combined automation of VCA
fader and its connected channels.

●

If the VCA fader and its connected channels have volume automation and you select
Combine Automation of VCA and Connected Channel in the context menu of the VCA
fader, the automation of the connected channels takes over the combined automation.
The automation of the VCA fader is reset to its default position. The automation tracks of
the connected channels show the combined automation. The automation tracks of the VCA
fader show the default static value line.

EXAMPLE
The following illustration shows how the VCA fader automation affects the automation of the
connected channels.
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1

Automation curve of the VCA fader

2

Automation curve of the connected channel

3

Combined automation of VCA fader and connected channel. This is what you hear.

RELATED LINKS
VCA Fader Settings on page 414
Creating Smooth Transitions Between Automation Events (Bézier Automation Curves) on page
699

VCA Rack
The VCA rack allows you to connect channels to VCA faders. You can also let VCA faders control
other VCA faders.
The VCA rack is divided into 2 slots. The top slot shows the name and color of the VCA fader that
controls the connected channel.

You can select the VCA fader that you want to connect to the channel and activate/deactivate an
existing connection to the VCA fader. The top slot is available for channels and VCA faders.

1

Activate/Deactivate VCA connections

2

VCA selector

The bottom slot shows the number of channels that are connected to a VCA fader. You can
activate/deactivate the connection between the VCA fader and the connected channels. The
bottom slot is only available for VCA faders.

1

Activate/Deactivate VCA connections
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Activating the VCA Rack
PROCEDURE
1.

On the MixConsole toolbar, activate Show Channel Racks.

2.

Click Racks and activate VCA to show the VCA rack above the fader section.

Connecting Channels with VCA Faders
PROCEDURE
1.

In the fader section of the MixConsole, create an unassigned VCA fader.

2.

In the VCA rack of the channel that you want to connect to the VCA fader, click the top slot.

3.

In the VCA selector, select the name of the unassigned VCA fader.

RESULT
The channel is connected to the VCA fader. The VCA rack slot of the channel displays the name
and the color of the VCA fader. The VCA rack slot of the VCA fader displays the number of
connected channels.
RELATED LINKS
Creating VCA Faders on page 415

Connecting Several Channels with VCA Faders
You can connect several channels to VCA faders at once using Q-Link.
PROCEDURE
1.

Select several channels in the MixConsole and activate Q-Link.

2.

In the VCA rack of one of the selected channels, click the top slot.

3.

In the VCA selector, select the name of the VCA fader.

RESULT
All channels are connected to the VCA fader. The VCA rack slots of the channels display the name
and the color of the VCA fader. The VCA rack slot of the VCA fader displays the number of
connected channels.
RELATED LINKS
Using Quick Link on page 383

Disconnecting Channels from VCA Faders
PROCEDURE
1.

In the MixConsole, in the VCA rack of the channel that you want to disconnect, click the
slot that displays the connected VCA fader.
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2.

In the VCA selector, select Not Connected.

3.

Specify if the connected channels keep the combined automation.

RELATED LINKS
VCA Fader Automation on page 416

Deactivating VCA Connections
You can deactivate the connection between VCA faders and channels temporarily.
Instead of breaking the connection between VCA fader and channels, the connection and
automation are suspended until you reactivate the connection. You can deactivate the
connection either for a channel or for a VCA fader.
PROCEDURE
●

In the VCA rack in the top slot of a VCA fader or a channel, click Activate/Deactivate VCA
Connection.

RESULT
If you deactivate the connection for a channel, only the channel loses the connection temporarily.
The connection between the VCA fader and the other channels remains intact.
If you deactivate the connection for a VCA fader, the connection to all connected channels is
suspended.
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The Control Room allows you to divide the studio environment into the performing area (studio)
and the engineer/producer area (control room).
To open the Control Room you have the following options:
●

To open the Control Room in a separate window, select Studio > Control Room.

●

To open the Control Room section in the MixConsole window, click Show/Hide Right
Zone in the MixConsole toolbar.

●

To open the Control Room section in the Project window, click Show/Hide Right Zone
in the Project window toolbar.

The Control Room is divided into 2 sections.
●

The Main tab contains all controls that you use regularly during recording, mixing, and
mastering, for example.

●

The Inserts tab contains settings that you most probably use only once for a project.

Adding Channels to the Control Room
To be able to use the Control Room, you must add the channels that you need first.
PROCEDURE
1.

Select Studio > Audio Connections.

2.

Click Control Room.

3.

Click Add Channel.
A pop-up menu lists all available channel types and shows how many instances of each
type are available.

4.

Select a channel type.
For most channel types, a dialog opens that allows you to choose the channel
configuration.

5.

Click the Audio Device column to set an audio device for the channel type.

6.

Click the Device Port column to assign a port for the channel.
IMPORTANT
You cannot assign the same device port to a bus or channel and a Control Room channel
at the same time.

RESULT
The Control Room functions are available for use. If you disable the Control Room, the
configuration is saved and will be restored when you reenable the Control Room.
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Output Routing
For the Control Room to function correctly, you must assign the Main Mix bus to the set of
outputs that contains the mix that you want to hear.
If you only have one output bus, it automatically becomes the Main Mix. All other outputs are not
routed through the Control Room.
The channel width of the Control Room can only be as wide as the Main Mix bus.
All other outputs are not routed through the Control Room.
However, they can be added as additional monitor sources in the Audio Connections window.
When the Control Room is enabled, the Main Mix bus is automatically shown on the Control
Room tab. The reason is that the Main Mix is always available as a monitor source in the Control
Room.

Exclusive Assignment of Monitor Channels
Generally, the port assignment to the Control Room channels is exclusive. However, it can be
useful to create monitor channels that share device ports with each other as well as inputs and
outputs. This can be helpful if you use the same speakers as a stereo pair and also as the left and
right channels of a surround speaker configuration, for example.
Switching between monitors that share device ports is seamless, multi channel audio is mixed
down to stereo as needed. Only one monitor set can be active at a time.
If your scenario does not require you to assign ports to several monitor channels, it is
recommended to activate the Exclusive Device Ports for Monitor Channels option in the
Preferences dialog (VST—Control Room page). This way, you make sure that you do not
accidentally assign ports to inputs/outputs and monitor channels at the same time.
IMPORTANT
The state of the Exclusive Device Ports for Monitor Channels preference is saved together with
the Control Room presets. Therefore, if you recall a preset, your current setting in the
Preferences dialog might be overwritten.

Control Room Channels
Each Control Room channel type that you create defines an input or output of the Control Room.

Monitor Channels
A monitor channel represents a set of outputs that are connected to monitor speakers in the
Control Room.
You can create up to 4 monitor channels for a mono, stereo, or surround speaker configuration.
Each monitor can have its own custom downmix settings, input gain, and input phase settings.
NOTE
Monitor channels can share hardware inputs or outputs with another bus or channel. When you
create the connections for the monitor channels, device ports that are already used for other
busses or channels are shown in red on the Device Port pop-up menu. If you select a used port,
its previous connection is lost.
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Monitor Sources
You can set up different monitor sources and use the Control Room Mixer to select the mix
sources that you want to listen to. Different monitor sources for dialogue, sound effects, and
music are useful in post production setups that require more than one mix bus.
You can create up to 8 monitor sources for a mono, stereo, or surround speaker configuration.
These can be input or output busses that you set up in the Inputs/Outputs tab of the Audio
Connections window, or a group channel.
IMPORTANT
If you select a monitor source with a wider configuration than the Main Mix bus, automatic
downmixing occurs.

Phones Channel
You can use the phones channel in the Control Room to listen to cue mixes.
You can create 1 phones channel for a stereo configuration. It allows you to listen to the main
mix or cue mixes or to external inputs on a pair of headphones. You can also use it for
previewing.

Cue Channels
You can use cue channels for sending cue mixes, also known as headphone mixes, to performers
in the studio during recording.
You can create up to 4 cue channels in mono or stereo for 4 discrete cue mixes. Cue channels
have talkback and click functions. They allow you to monitor the main mix, external inputs, or a
dedicated cue mix.
EXAMPLE
If you have 2 available headphone amplifiers for performers, you can create 1 cue channel for
each cue mix and name them according to their function: vocalist mix, bass player mix, etc.

Cue Channels and Cue Sends
For every cue channel that you define in the Audio Connections window, each channel in the
MixConsole has a cue send with level, pan, and pre/post-fader selection. These cue sends can be
used to create discrete cue mixes that performers can listen to.
●

To show the cue sends, open the MixConsole and activate Racks > Cue Sends.

External Inputs
You can use external inputs for monitoring external devices, such as CD players, multi-channel
recorders, or any other audio source.
You can create up to 6 external inputs for a mono, stereo, or surround speaker configuration.
NOTE
If you select external inputs as input source of an audio channel, you can record them. In this
case, you do not need to assign the device ports to the input channel.
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Talkback Channels
You can use talkback channels for communication between the Control Room and performers in
the studio.
You can create up to 4 talkback channels and assign a mono input channel to each one of them.
You can also use talkback channels as input source for audio tracks and record them. You can
route them to each cue channel and use different levels.
You can insert effects like a compressor or limiter on talkback channels. This ensures that erratic
levels do not disturb performers and that clear communication with everyone is possible.
NOTE
The Auto Disable Talkback Mode option in the Preferences dialog (VST—Control Room page)
allows you to specify how talkback works during playback and recording.

Metering Channel
You can use a metering channel for connecting a hardware metering device.
The metering channel allows you to meter monitoring sources without having the listening
volume affect the meter. This channel is a physical ASIO output which feeds the same signal that
goes through the meter channel.
NOTE
The metering channel does not appear in the project.

Control Room - Main Tab
The Control Room Main tab displays information and controls for the channels that you define
on the Control Room tab in the Audio Connections window.
The Control Room Main tab is divided into a number of sections that you open by clicking their
header. To open several sections simultaneously, use Ctrl/Cmd-click.

423

Control Room
Control Room - Main Tab

External
The External section allows you to use external inputs for monitoring external devices. It is only
shown if you have added more than one external input in the Audio Connections window.

To switch to another external input, click the input name and select a new external input from
the pop-up menu.

Monitor Sources
The Monitor Sources section allows you to select which monitor sources are routed to the
Control Room.

1

Multiple Monitor Sources
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Allows you to listen to several submixes at the same time. For this to work, you must
activate the monitor sources that you want to include.
2

Monitor Sources
Allows you to listen to a monitor source. If you want to listen to only one source, deactivate
Multiple Monitor Sources.
To listen to a monitor source exclusively, even if Multiple Monitor Sources is activated,
Alt-click a monitor source.
To deactivate several monitor sources, even if Multiple Monitor Sources is activated,
Shift-click the monitor source buttons.

Cue Channel
The Cue Channel section allows you to set up cue channels for sending cue mixes.

1

Activate Cue Channel
Allows you to activate/deactivate the cue channel.

2

Source Selectors
Allow you to select the source for the cue channel: monitor mix (Mix), external inputs (Ext),
or the cue sends (Cues). The signal presence indicators in the upper left corner light up
when the source channel is sending data to the cue channel.

3

Enable Talkback to Cue Channel
Allows you to activate talkback for communication between the Control Room and the
performers in the studio. You can set the level of the talkback signal with the slider.

4

Activate Metronome Click
Activates the metronome click. Use the Click Level and Click Pan controls to set the
volume and the pan position of the metronome click.

5

Signal Level
Allows you to set the signal level.

Channels
The Channels section shows the speaker arrangement of the Main Mix bus.
You can use the solo functions to listen to individual channels of the Main Mix. You can also use
this to test your multi channel speaker system and make sure that the correct channels are
routed to the speakers.
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1

Solo Left and Right Channels
Allows you to solo the left and right channels.

2

Solo Front Channels

3

Solo Surround Channels

Allows you to solo the front channels.
Allows you to solo the surround channels.
4

Listen to Solo Channels on Center Channel
Allows you to listen to all soloed speakers in the center channel. If the center channel is
not available, the channels are distributed equally to the left and right.

5

Listen to Surround Channels on Front Channels
Allows you to solo the surround channels and route them to the front speakers.

6

Solo LFE Channel
Allows you to solo the LFE channel.

To open the Main Mix bus in the MixConvert V6 plug-in, double-click the channel display.
RELATED LINKS
MixConvert V6 on page 671

Monitors
The Monitors section allows you to select and configure the monitor sets.
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Downmix Presets
The Downmix Presets section allows you to configure downmix presets.

1

Assign Downmix Preset
Allows you to configure a downmix preset for the monitor that is selected in the Monitors
section.

2

Select Output Configuration
Allows you to select an output channel configuration. You can also select Open/Close
MixConvert or Open/Close Ambisonics Decoder to open MixConvert V6 or VST
AmbiDecoder.

RELATED LINKS
MixConvert V6 on page 671
VST AmbiDecoder Panel on page 686

Phones
The Phones section allows you to use the phones channel in the Control Room to listen to cue
mixes.

1

Activate Phones Channel
Allows you to activate/deactivate the phones channel.

2

Activate Metronome Click
Activates the metronome click.

3

Source Selectors
Allow you to select the source for the phones channel: monitor mix (Mix), external inputs
(Ext), or the cue sends (Cues). The signal presence indicators in the upper left corner light
up when the source channel is sending data to the Phones channel.

4

Phones Level
Allows you to set the phones level. Ctrl/Cmd-click to set the level to the reference level
specified in the Preferences dialog (VST—Control Room page).

5

Click Level and Click Panning
Use the Click Level and Click Panning controls to set the volume and the pan position of
the metronome click.
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6

Enable Listen for Output
Enables the listen bus function.

7

Listen Level
Allows you to set the listen level.

Control Room Channel
The Control Room channel is the representation of the bus that is set up as the Main Mix bus on
the Outputs tab in the Audio Connections window or the one that is selected as monitor source.

The following section contains a description of the individual controls.

1

Activate Control Room Channel
Allows you to activate/deactivate the Control Room channel.

2

Signal Level
Allows you to set the volume for the Control Room output. This does not affect the
recording input level or the Main Mix level for exporting mixdowns. Ctrl/Cmd-click to set
the level to the reference level specified in the Preferences dialog (VST—Control Room
page).

3

Signal Meter
Shows the volume for the Control Room output.

1

Source Selectors
Allow you to select the source for the Control Room channel. The available sources depend
on the channels that you added to the Control Room. The signal presence indicators in the
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upper left corner light up when the source channel is sending data to the Control Room
channel.
2

Dim Signal
Activate this to lower the Control Room level by a fixed amount. This allows a quick
reduction in monitor volume without disturbing the current monitor level. Clicking DIM
again returns the monitor level to the previous setting.

3

Use Reference Level
Enable this button to set the Control Room level to the reference level specified in the
Preferences dialog (VST—Control Room page). The reference level is the level that is used
in calibrated mixing environments, such as film dubbing stages.

4

Activate Metronome Click
Activates the metronome click.

1

Monitor Selectors
Allow you to select another monitor source.

2

Downmix Preset Selectors
Allow you to select another downmix preset.

3

Activate Talkback
Allows you to activate talkback for communication between the Control Room and the
performers in the studio. Click to activate, click and hold for momentary mode.

4

Talk Off
If you add more than 1 talkback channel, Talk Off becomes available. This allows you to
deactivate all activated talkback channels.

1

Click Level and Click Pan
Use the Click Level and Click Pan controls to set the volume and the pan position of the
metronome click for the Control Room channel.

2

AFL/PFL
Allows you to determine whether the signal of a listen-enabled channel is routed to the
Control Room channel after applying the fader and pan settings (AFL) or before applying
the fader and pan settings (PFL).

3

Enable Listen for Output
Enables the listen bus function for the Control Room output.

4

Listen Level
Allows you to adjust the volume of listen bus signals that are routed to the Control Room
output.

5

Listen Dim
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Allows you to adjust the volume of the Main Mix or monitor source when channels are in
listen mode. This keeps listen-enabled channels in context with the Main Mix. If the Listen
DIM level is set to the minimum value, you only hear the listen-enabled channels.
6

Talk Dim
When Talkback is active, this slider controls how much the output of all the channels in
the Control Room is reduced, to prevent unwanted feedback.

Control Room - Inserts Tab
The Control Room Inserts tab contains additional settings for the channels.
The Control Room Inserts tab is divided into a number of sections that you open by clicking
their headers.
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Input Gain

Setting up the input gain can be useful in the following situations:
●

To balance the level of external inputs, for example, CD players and other sources to the
Main Mix level, for A/B comparisons.

●

To balance the level of your monitor systems, so that switching between sets of speakers
does not change the playback volume.

Input Phase

Reversing the input phase can be useful for external inputs and monitor speaker outputs.

Insert Effects

Each Control Room channel has a set of insert effect slots.
●

Use the inserts on the Control Room channel for metering and spectral analysis plug-ins.
All solos including the Listen bus will come through the Control Room channel and allow
analysis of individual sounds. A brickwall limiter in the last insert slot of the Control Room
channel can prevent accidental overloads and damage to speaker systems.

●

Use the inserts for the talkback channel to control the dynamics of the talkback
microphone.
This helps protect performers’ hearing and ensures that everyone can be heard over the
talkback microphone.

●

Use the monitor inserts for surround decoding or brickwall limiting to protect sensitive
monitor speakers.
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Each monitor channel has a set of eight inserts, all of which are post Control Room fader.

Setting Up a Cue Mix
You can create a cue mix from the fader and pan levels that are used in the MixConsole and
change them to meet the needs of the individual performers.
PROCEDURE
1.

In the MixConsole, select the channels from which you want to copy the settings.

2.

In the Control Room, do one of the following:

3.

●

To apply the function only to this cue channel, right-click on a cue channel to open
the context menu.

●

To apply the function to all cue channels, click anywhere but on a cue channel to
open the context menu.

Select From selected mixer channels and select one of the functions.

Cue Mix Context Menu
Change Cue Sends Levels
Allows you to adjust multiple send levels at the same time.
Use Current Mix Levels
Allows you to copy the fader levels of the selected tracks to the cue sends. This sets
all cue send levels for the selected tracks to the level of the main channel fader. It
also changes the cue send status to pre-fader, so that changes in the main mix do
not affect the cue sends.
Use Current Pan Settings
Allows you to copy pan information from the main mix to the cue sends of the
selected tracks. If the cue send is mono, the pan setting is copied, but the output of
the cue send is the sum of the left and right channels.
Enable Cue Sends
Allows you to activate the cue sends of the selected channels. To be able to hear the
cue mix for a cue channel, the cue sends must be enabled.
Disable Cue Sends
Allows you to disable the cue sends of the selected channels.
Reset Cue Sends
Allows you to deactivate the cue sends, to change the send level of all selected
channels to 0 dB, and to set the signal source to post-fader. This way, any changes to
the main mix also change the cue mix. To raise the level of individual cue channels,
raise the level on that channel.
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Adjusting the Overall Cue Send Level
You can adjust multiple send levels at the same time for the cue send mix, keeping the blend
intact while lowering the overall volume. This is sometimes necessary, because the levels in the
main mix are often optimized for the loudest possible signal level without clipping.
This means that when you create a “more me” mix, you may find that there is not enough
headroom available in the cue send to raise levels without introducing clipping.
PROCEDURE
1.

In the MixConsole, select the channels that you want to modify.

2.

In the Control Room, right-click a cue channel to open the context menu.

3.

Select From selected mixer channels > Change Cue Sends Levels.

4.

Activate Relative Mode.
This way, you adjust the existing levels. By deactivating Relative Mode, all cue sends are
set to the same absolute level.

5.

Adjust the level as necessary.
The level of all selected cue sends is adjusted by the set amount.

6.

Click OK.
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Nuendo provides a master meter that works as a multichannel true peak meter, and a loudness
meter that allows you to measure the loudness in compliance with the loudness
recommendation R 128 of the European Broadcasting Union (EBU).

Metering
Nuendo provides a master meter and a loudness meter that can be shown in the right zone of
the Project window and the MixConsole, or in a separate window in the Control Room.

Master Meter
The master meter is a multichannel true peak meter.

1

Activate Control Room View
Shows/Hides the Control Room section.

2

Scales
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Allows you to select a scale according to different broadcast standards (Digital, DIN, EBU,
British, Nordic, K-20, K-14, or K-12). The headroom is indicated by red lines in the meter
scale.
3

Alignment level standards
Allows you to select an alignment level (offset) for your scale. This is unavailable for digital
and K-System scales. The broadcast meter scales DIN, EBU, Nordic, and British have a
default alignment level of -18 dBFS.

4

Reset RMS and PPM Max
Resets the measurement.

5

AES17 standard
Activates the AES17 standard that adds an offset of 3 dB to the RMS value.

6

RMS/Peak meter
Shows the RMS and peak hold values as blue lines and the peak values as gray lines.

7

RMS Max
Shows the maximum RMS value.

8

Peak Max
Shows the maximum peak value.

RELATED LINKS
Control Room on page 420

Displaying Meters
PROCEDURE
1.

In the Project window or in the MixConsole, click Show/Hide Right Zone to show the
right zone with the Control Room/Meter.

2.

Click the Meter tab at the top of the Control Room/Meter section.
By default, the master meter is displayed.

Loudness Measurement
Loudness measurements that correspond to the recommendation R 128 of the European
Broadcasting Union (EBU) consider loudness, loudness range, and maximum true peak level
values.

Loudness Measurement
The following measurements are performed:
●

Integrated Loudness
Average loudness that is measured over the whole track in LUFS (Loudness Unit,
referenced to Full Scale).
According to the loudness recommendation R 128, audio should be normalized at -23 LUFS
(±1 LU).

●

Short-Term Loudness
Loudness that is measured every second on an audio block of 3 seconds. This gives
information about the loudest audio passages.

●

Momentary Loudness
Maximum value of all momentary loudness values that are measured every 100 ms in an
audio range of 400 ms.
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Loudness Range
The loudness range measures the dynamic range over the whole title in LU (Loudness Units). It
reports the ratio between the loudest and the quietest non-silent sections. The audio is divided
into small blocks. Every second there is one audio block, and each block lasts 3 seconds so that
the analyzed blocks overlap.
The top 10 % of the quiet blocks and the top 5 % of the loud blocks are excluded from the final
analysis. The calculated loudness range is the ratio between the loudest and quietest remaining
audio blocks. This measurement helps you to decide if and how much compression or expansion
you can or should apply to the audio.

True Peaks
When a digital signal is converted to an analog signal, EBU R 128 recommends that you rather
measure an estimation of the real peaks instead of relying on digital peaks. This avoids clipping
and distortion.

Naming and Units
EBU R 128 proposes the following naming and units conventions:
●

A relative measurement, such as a value that is relative to a reference level, LU as
Loudness Unit (1 LU is 1 dB).

●

An absolute measurement, LUFS as loudness unit referenced to full scale. 1 LUFS can be
understood as 1 dB in the AES-17 scaling.

Scales
The loudness meter offers two different scales:
●

The EBU +9 scale has a range from -18.0 LU to +9.0 LU (-41.0 LUFS to -14.0 LUFS).

●

The EBU +18 scale has a range from -36.0 LU to +18 LU (-59.0 LUFS to -5.0 LUFS).

Loudness Meter
The Loudness meter allows you to analyze, measure, and monitor the loudness of your project in
real time during playback or mixing.
●

To open the loudness meter, select the Loudness tab at the bottom of the meter display in
the right zone of the Project window or the MixConsole, or in the Control Room.
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1

Activate Control Room View
Shows/Hides the Control Room section.

2

Loudness meter
Shows the Integrated value as a triangle in the left meter scale and the Short-Term value
as a triangle in the right meter scale.

3

Measure Loudness
Activates the loudness measurement.

4

Switch between LU and LUFS
Switches the meter scale between LUFS (absolute values) and LU (relative values).

5

Configure Loudness Settings
Allows you to specify a threshold value for the Momentary Max, the Short-Term, the
Integrated, and the True Peak clipping indicators. If values above the set thresholds are
detected, the corresponding indicators turn red.
You can switch the loudness meter between the EBU +9 scale and the EBU +18 scale.
To reset all values on playback start, activate the Reset on Start option.

6

Reset Loudness
Resets all loudness values.

7

Momentary Max
Shows the maximum loudness measured over a duration of 400 ms.

8

Short-Term
Shows the loudness measured over a duration of 3 s.

9

Integrated
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Shows the average loudness measured from start to stop. The period of measurement is
shown in the Time display. The recommended value for the integrated loudness is -23
LUFS. This absolute value is the reference point for the relative LU scale where -23 LUFS
equals 0 LU.
10

Range
Shows the dynamic range of the audio measured from start to stop. This value helps you
to decide how much dynamic compression you can apply. The range that is recommended
for highly dynamic audio such as film music is 20 LU.

11

True Peak
Shows the true peak level of the audio. The maximum permitted true peak level in
production is -1 dB.

12

Time
Shows the duration of the integrated loudness measurement.

RELATED LINKS
Displaying Meters on page 435
Control Room on page 420
Metering and Loudness on page 434
Loudness Settings on page 438

Loudness Settings
●

To open the Loudness Settings dialog, click Configure Loudness Settings on the
Loudness tab.

The following parameters are available:
1

Select Preset
Allows you to create, load, and remove loudness presets.

2

Momentary Max
Allows you to specify a reference value and a tolerance value for the maximum momentary
loudness. If higher values are detected, the clipping indicator in the loudness meter turns
red.

3

Short-Term
Allows you to specify a reference value and a tolerance value for the short-term loudness.
If higher values are detected, the clipping indicator in the loudness meter turns red.

4

Integrated
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Allows you to specify a reference value and a tolerance value for the integrated loudness.
If higher values are detected, the clipping indicator in the loudness meter turns red.
5

True Peak
Allows you to specify a reference value and a tolerance value for the true peak level. If
higher values are detected, the clipping indicator in the loudness meter turns red.

6

Switch between LU and LUFS
Allows you to switch the meter scale between LUFS (absolute values) and LU (relative
values).

7

Switch between EBU +9 Scale and EBU +18 Scale
Allows you to switch the meter between the EBU +9 scale and the EBU +18 scale.

8

Reset on Start
Activate this option to reset all values on playback start.

RELATED LINKS
Loudness Meter on page 436

Loudness Track
The loudness track allows you to record the loudness of your whole project or of specific
sections.
●

To add a loudness track, select Project > Add Track > Loudness.

1

Loudness curve
Shows the loudness values that were detected during the loudness measurement.

2

Reference loudness level
Shows the EBU R 128 reference loudness level of -23 LUFS (0 LU).

3

True peaks
Shows the detected true peaks that exceed the reference value that you can set up in the
Loudness Settings dialog.

RELATED LINKS
Loudness Track Controls on page 157
Loudness Track Inspector on page 156

Measuring Short-Term Loudness during Playback
You can record and display the short-term loudness during playback as a curve on the loudness
track.
PROCEDURE
1.

Select Project > Add Track > Loudness.
A loudness track is added, and the EBU 128 reference loudness level of -23 LUFS (0 LU) is
displayed as a horizontal line in the event display.

2.

In the track list for the loudness track, activate Activate Loudness Calculation.
By default, loudness calculation is deactivated for performance reasons.
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3.

Activate Enable Recording of Loudness Curve.

4.

Play back your project.

RESULT
The short-term loudness level is measured in real time at the cursor position. The corresponding
loudness curve is written to the loudness track.
RELATED LINKS
Loudness Track Controls on page 157

Measuring Short-Term Loudness Offline
You can record and display the short-term loudness for a defined section only on the loudness
track using offline analysis.
PROCEDURE
1.

Select Project > Add Track > Loudness.
A loudness track is added, and the EBU 128 reference loudness level of -23 LUFS (0 LU) is
displayed as a horizontal line in the event display.

2.

Set up the left and right locators to encompass the section that you want to analyze.

3.

In the track list for the loudness track, activate Activate Loudness Calculation.
By default, loudness calculation is deactivated for performance reasons.

4.

Set up the left and right locators to encompass the section that you want to analyze.

5.

Click Quick Analysis.

RESULT
The loudness curve is created for the defined section and displayed on the loudness track.
RELATED LINKS
Loudness Track Controls on page 157

Normalizing Loudness on Export
You can normalize your audio to the integrated loudness on export. However, this is only suited
for small level deviations and does not compensate for proper mixing.

●

Normalize to Integrated Loudness
Activate this to normalize your audio to the integrated loudness value that is specified in
the field to the right.

●

Max. True Peak Level
Activate this to limit the peak levels to the value that is specified in the field to the right.
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Nuendo comes with a number included of effect plug-ins that you can use to process audio,
group, instrument, and ReWire channels.
This chapter contains general details about how to assign, use, and organize effect plug-ins. The
effects and their parameters are described in the separate document Plug-in Reference.

Insert Effects and Send Effects
You can apply effects to audio channels by using insert effects or send effects.
NOTE
To apply audio effects to individual audio events, use Direct Offline Processing .

Insert Effects
Insert effects are inserted in the signal chain of an audio channel. This way, the whole channel
signal passes through the effect.
You can add up to 16 different insert effects per channel.
Use insert effects for effects such as distortion, filters, or other effects that change the tonal or
dynamic characteristics of the sound.
To add and edit insert effects, you can use the following inserts sections:
●

The Inserts rack in the MixConsole.

●

The Inserts section in the Channel Settings window.

●

The Inserts section in the Inspector.
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Send Effects
Send effects can be added to FX channel tracks, and the audio data to be processed can be
routed to the effect. This way, the send effects remain outside the audio channel’s signal path.
Each audio channel has 8 sends, each of which can be freely routed to an effect (or to a chain of
effects).
Use send effects in the following cases:
●

To control the balance between the dry and wet sound individually for each channel.

●

To use the same effect for several different audio channels.

To edit send effects, you can use the following sends sections:
●

The Sends rack in the MixConsole.

●

The Sends section in the Channel Settings window.

●

The Sends section in the Inspector.

RELATED LINKS
Direct Offline Processing on page 467

VST Standard
Audio effects can be integrated in Nuendo thanks to the VST standard. At the moment, the VST 3
and VST 2 standards are supported.
The VST 3 plug-in standard offers improvements like smart plug-in processing and side-chain
inputs. Yet, it retains full backwards compatibility to VST 2.

Smart Plug-In Processing
Smart plug-in processing is a technology that allows to disengage the processing for plug-ins
when no signal is present. This reduces the CPU load on silent passages and allows you to load
more effects.
To activate smart plug-in processing, activate Suspend VST 3 plug-in processing when no audio
signals are received in the Preferences dialog (VST—Plug-ins page).
NOTE
Check the processor for the passage with the largest number of events playing simultaneously to
make sure that your system offers the required performance at every time position.
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Side-Chain Inputs
Several VST 3 effects feature side-chain inputs. These allow you to control the operation of the
effect via external signals that are routed to the side-chain input.
The effect processing is still applied to the main audio signal.
RELATED LINKS
Side-Chain Input on page 455

Plug-In Delay Compensation
Some audio effects, especially dynamics processors that feature a look-ahead functionality, may
take a brief time to process the audio fed into it. As a result, the output audio will be slightly
delayed. To compensate for this, Nuendo provides plug-in delay compensation.
Plug-in delay compensation is featured throughout the entire audio path maintaining the sync
and timing of all audio channels.
VST 3 dynamics plug-ins with look-ahead functionality feature a Live button that allows you to
disengage the look-ahead. This minimizes latency during real-time recording. For details, see the
separate document Plug-in Reference.
To avoid latency during realtime recording or realtime playback of VST instruments, you can also
use Constrain Delay Compensation.
RELATED LINKS
Constrain Delay Compensation on page 732

Tempo Sync
Plug-ins can receive timing and tempo information from Nuendo. This is useful to synchronize
plug-in parameters, such as modulation rates or delay times, to the project tempo.
Timing and tempo information is provided to plug-ins of the standard VST 2.0 or later.
To set up tempo sync you must specify a base note value. Straight, triplet or dotted note values
(1/1 to 1/32) are supported.
For details about the included effects, see the separate document Plug-in Reference.

Insert Effects
Insert effects can be inserted in the signal chain of an audio channel. This way, the whole channel
signal passes through the effect.
You can add up to 16 different insert effects independently for each audio-related channel (audio
track, group channel track, FX channel track, instrument channel, or ReWire channel) or output
bus.
The signal passes through the insert effects corresponding to their slot position from top to
bottom.
You can define post-fader insert slots for any channel. Post-fader insert slots are always post-EQ
and post-fader.
NOTE
To show all post-fader slots in the MixConsole, open the Rack Settings and activate Fixed
Number of Slots.
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Use post-fader slots for insert effects where you want the level to remain unchanged after the
effect. Dithering and maximizers are typically used as post-fader insert effects for output busses,
for example.
NOTE
If you want to use an effect with identical settings on several channels, set up a group channel
and apply your effect as a single insert for this group.

RELATED LINKS
Dither Effects on page 457
Moving Inserts to Post-Fader or Pre-Fader Position on page 397
Adding Insert Effects to Group Channels on page 445
Rack Settings on page 378

Adding Insert Effects
If you add insert effects to audio channels, the audio is routed through the insert effects.
PROCEDURE
1.
2.

Select the audio track.
In the track list, click Edit Channel Settings

.

The Channel Settings window for the audio channel opens.
3.

In the Inserts section, click the first insert slot on the Inserts tab, and select an effect from
the selector.

RESULT
The selected insert effect is loaded and activated, and the audio is routed through it. The effect
control panel is opened.
RELATED LINKS
Effect Control Panel on page 458

Adding Insert Effects to Busses
If you add insert effects to input busses, the effects become a permanent part of the recorded
audio file. If you add insert effects to output busses, all audio routed to that bus is affected.
Insert effects that are added to output busses are sometimes referred to as master effects.
PROCEDURE
1.

Select Studio > MixConsole to open the MixConsole.

2.

In the fader section, perform one of the following actions:
●

Locate the input channel and click Edit Channel Settings to edit the input bus.

●

Locate the output channel and click Edit Channel Settings to edit the output bus.

The Channel Settings window for the selected channel opens.
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3.

In the Inserts section, click the first insert slot on the Inserts tab, and select an effect from
the selector.

RESULT
The selected insert effect is added to the bus and activated. The effect control panel is opened.

Adding Insert Effects to Group Channels
If you add insert effects to group channels, you can process several audio tracks through the
same effect.
PROCEDURE
1.

Select Project > Add Track > Group Channel to add a group channel track.

2.

In the Inspector for the group track, open the Output Routing pop-up menu, and select
the desired output bus.

3.

In the Inspector for the group track, open the Inserts section.

4.

Click the first effect slot and select an effect from the selector.

5.

In the Inspector for the audio tracks, open the Output Routing pop-up menus and select
the group.

RESULT
The signal from the audio track is routed through the group channel and passes through the
insert effect.

Copying Insert Effects
You can add insert effects to audio channels by copying them from other audio channels or from
other slots of the same audio channel.
PREREQUISITE
You have added at least one insert effect to an audio channel.
PROCEDURE
1.

Select Studio > MixConsole.

2.

In the Inserts rack, locate the insert effect that you want to copy.

3.

Hold down Alt, drag the insert effect, and drop it on an insert slot.

RESULT
The insert effect is copied. If the destination slot already contains an insert effect, it is replaced.

Rearranging Insert Effects
You can change the position of an insert effect in the signal chain of the audio channel by moving
it to a different slot of the same channel. You can also move an insert effect to another audio
channel.
PREREQUISITE
You have added at least one insert effect to an audio channel.
PROCEDURE
1.

Select Studio > MixConsole.
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2.

In the Inserts rack, locate the insert effect that you want to rearrange.

3.

Drag the insert effect and drop it on an insert slot.

RESULT
The insert effect is removed from the source slot and placed on the destination slot. If the
destination slot already contains an insert effect, this effect is moved to the next insert slot.

Deactivating Insert Effects
If you want to listen to a track without having it processed by an effect, but do not want to
remove this effect completely from the insert slot, you can deactivate it.
PREREQUISITE
You have added an insert effect to an audio channel.
PROCEDURE
1.

In the track list, select the audio track with the insert effect that you want to deactivate.

2.

In the Inspector, open the Inserts section, and Alt-click Bypass Insert.

RESULT
The effect is deactivated and all processing is terminated, but the effect is still loaded.

Bypassing Insert Effects
If you want to listen to the track without having it processed by a particular effect, but do not
want to remove this effect completely from the insert slot, you can bypass it. A bypassed effect is
still processing in the background. This allows for crackle-free comparison of the original and the
processed signal.
PREREQUISITE
You have added an insert effect to an audio channel.
PROCEDURE
1.

In the track list, select the audio track with the insert effect that you want to bypass.

2.

In the Inspector, open the Inserts section, and click Bypass Insert.

RESULT
The effect is bypassed, but still processing in the background.
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Removing Insert Effects
PROCEDURE
1.

Select the audio track that contains the insert effect that you want to remove.

2.

In the Inspector, click Select Insert.

3.

In the effect selector, select No Effect.

RESULT
The insert effect is removed from the audio channel.

Freezing Insert Effects
Freezing an audio track and its insert effects allows you to reduce processor power. However,
frozen tracks are locked for editing. You cannot edit, remove or add insert effects for the frozen
track.
PREREQUISITE
You have made all settings for the track and you are sure that you do not need to edit it
anymore.
PROCEDURE
1.

In the Inspector for the audio track that you want to freeze, click Freeze Audio Channel.

2.

In the Freeze Channel Options dialog, specify a Tail Size in seconds.
This adds time at the end of the rendered file. This way, reverb and delay tails can fully
fade out.

RESULT
The output of the track including all pre-fader insert effects is rendered to an audio file.
NOTE
Post-fader inserts cannot be frozen.
The frozen audio track is saved in the Freeze folder that can be found in the following location:
●

Windows: within the Project folder

●

macOS: User/Documents

In the MixConsole, the frozen audio channel is indicated by a snow flake symbol above the
channel name. You can still adjust the level and panning, make EQ settings and adjust the effect
sends.
AFTER COMPLETING THIS TASK
To unfreeze a frozen track, click Freeze again.
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Insert Effects in Multi-Channel Configurations
You can insert VST 2 and VST 3 effects on tracks with a multi-channel configuration. However, not
all effect plug-ins support multi-channel processing.
Mono or stereo effects can only process 1 or 2 channels, whereas surround-capable plug-ins are
applied to all speaker channels, or to a subset of these.
●

To set up to what speaker channels the insert effect is applied, use the Routing Editor.

RELATED LINKS
Routing Editor on page 449

Selecting a Plug-In Input Configuration
For plug-ins that support multi-channel processing, you can select the input configuration.
PROCEDURE
1.

Open the control panel.

2.

Click Select requested input configuration, and from the pop-up menu, select an input
configuration.

The first entry is always identical with the channel configuration of the track. Below this, all
possible channel subsets of the default configuration that are supported by Nuendo are
shown.
RESULT
The selected input configuration is applied.
NOTE
Not all plug-ins support all channel configurations.

Routing Insert Effects through Specific Audio Channels
If you insert a stereo insert effect on a multi channel track, the first speaker channels of the track
are routed through the available effect channels. The other channels remain unprocessed.
However, you can route the effect through different speaker channels.
PROCEDURE
1.

In the track list, click Edit Channel Settings to open the Channel Settings window for the
track on which the effect is inserted.

2.

On the Inserts section, click Routing to open the Routing tab.

3.

Double-click the signal diagram for the insert effect to open the Routing Editor.
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The first speaker channels of the track are routed through the available effect channels.
4.

Optional: Activate Link to link the input and output channel assignment.

5.

Click the arrow buttons to route different speaker channels through the effect.

RESULT
The effect is routed through different channels of the audio.
NOTE
To route a stereo plug-in through all 6 channels of a 5.1 track, add 3 instances of it and use
different speaker channels for each instance.

RELATED LINKS
Routing Editor on page 449

Routing Editor
The Routing Editor allows you to set up, to what speaker channels the effect is applied to.
The Routing Editor shows the channels in the current configuration, with signals passing from
top to bottom.

1

Outputs
The lower squares represent the outputs from the effect plug-in.

2

Effect plug-in
The field in the middle represents the effect plug-in.

3

Inputs
The upper squares represent the inputs to the effect plug-in.

4

Connections
The lines represent the connections.
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5

Input channel assignment
These buttons allow you to assign the input channels.

6

Link
Activate this to link the input and output channel assignment.

7

Output channel assignment
These buttons allow you to assign the output channels.

8

Reset
This button allows you to reset the original channel setup.

Routing Connections
In the Routing Editor, you can set up the routing connections.
NOTE
You can only make settings in the Routing Editor if you route multi channel audio through an
effect that supports fewer channels.
The following connections are possible:
Routing Connection

The audio on the speaker channel is routed through the effect channel and
processed by the effect.
Bypass Connection

The audio on the speaker channel passes the effect without being processed.
Broken Connection

The audio on the speaker channel is not sent to the output.
Cross Connection

The audio on the specific channels is processed by the effect and output on other
channels.
In this example, the audio on the Ls-Rs channels is output on the L-R channels. Since
the L-R channels are bypassed, the final L-R output contains both the original L-R
signals and the processed Ls-Rs signals.
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Send Effects
Send effects are outside the signal path of an audio channel. The audio data that is to be
processed must be sent to the effect.
●

You can select an FX channel track as routing destination for a send.

●

You can route different sends to different FX channels.

●

You can control the amount of signals sent to the FX channel by adjusting the effect send
level.

To do this, you must create FX channel tracks.
RELATED LINKS
FX Channel Tracks on page 451

FX Channel Tracks
You can use FX channel tracks as routing destinations for audio sends. The audio is sent to the FX
channel and through any insert effects set up for it.
●

You can add several insert effects to an FX channel.
The signal passes through the effects in series, from the top downward.

●

You can rename FX channel tracks as any other tracks.

●

You can add automation tracks to FX channel tracks.
This allows for automating various effect parameters.

●

You can route the effect return to any output bus.

●

You can adjust the FX channel in the MixConsole.
This includes adjusting the effect return level, the balance, and the EQ.

When you add an FX channel track, you can select if FX channel tracks are created inside or
outside a dedicated folder. If you select Create Inside Folder, FX channel tracks are shown in a
dedicated folder.

This allows for better overview and editing of the FX channel tracks.
NOTE
By folding FX channel folders, you can save screen space.

RELATED LINKS
Adding FX Channel Tracks on page 451

Adding FX Channel Tracks
PROCEDURE
1.

Select Project > Add Track > FX Channel.

2.

Open the Configuration pop-up menu to select a channel configuration for the FX channel
track.
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3.

Open the Effect pop-up menu and select an effect from the selector.

4.

Open the FX Channels Folder pop-up menu and select if you want to create fx channel
tracks inside or outside a dedicated folder.

5.

Click Add Track.

RESULT
An FX channel track is added to the track list and the selected effect is loaded into the first insert
effect slot of the FX channel.

Adding Insert Effects to FX Channel Tracks
You can add insert effects to FX channel tracks.
PREREQUISITE
You have added an FX channel track and set up the correct output bus in the Output Routing
pop-up menu.
PROCEDURE
1.

In the track list for the FX channel track, click Edit Channel Settings.
The Channel Settings window for the FX channel track opens.

2.

In the Inserts section, click an insert slot on the Inserts tab, and select an effect from the
selector.

RESULT
The selected effect is added as an insert effect to the FX channel track.

Routing Audio Channels to FX Channels
If you route an audio channel send to an FX channel, the audio is routed through the insert
effects that you have set up for the FX channel.
PROCEDURE
1.

Select the audio track.

2.

In the track list, click Edit Channel Settings to open the Channel Settings window.

3.

In the Sends section on the Destinations tab, click Select Destination for an effect slot,
and select the FX channel track from the selector.

4.

On the send slot, click Activate/Deactivate Send.
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RESULT
The audio is routed through the FX channel.
AFTER COMPLETING THIS TASK
In the Channel Settings window for the audio channel, you can hold down Alt and double-click
to show the send destination. If you have routed the send to an FX channel, the effect control
panel is opened.
RELATED LINKS
Adding FX Channel Tracks on page 451

Pre/Post Fader Sends
You can send the signal from the audio channel to the FX channel before or after the audio
channel volume fader.
●

Pre-fader sends
The audio channel signal is sent to the FX channel before the audio channel volume fader.

●

Post-fader sends
The audio channel signal is sent to the FX channel after the audio channel volume fader.

●

To move a send to pre-fader position, open the Channel Settings window for the audio
channel, right-click a send and select Move to Pre-Fader.

The Pre-/Post-Fader button indicates that the send is in pre-fader position.

●

To move a send to post-fader position, open the Channel Settings window for the audio
channel, right-click a send and select Move to Post-Fader.

The Pre-/Post-Fader button indicates that the send is in post-fader position.

NOTE
If you activate Mute Pre-Send when Mute in the Preferences dialog (VST page), sends in prefader mode are muted if you mute their channels.
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Setting Pan for the Sends
PROCEDURE
1.

Select the audio track.

2.

In the track list, click Edit Channel Settings to open the Channel Settings window.

3.

On the Sends tab, click Panning.
For each send, a pan fader is shown.
NOTE
Depending on the routing, different pan controls are available for the sends.

4.

Optional: Open the Functions Menu and activate Link Panners.

The send panners will then follow the pan for the channel, making the stereo imaging as
clear and true as possible.
NOTE
In the Preferences dialog (VST page), you can set this as a default behavior for all
channels.
5.

Click and drag the pan control for the send.

NOTE
You can reset the pan control to the center position by Ctrl/Cmd-clicking on the pan
control.

RELATED LINKS
Surround Sound on page 647
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Setting Level for the Sends
PROCEDURE
1.

In the track list, select the FX channel track that contains the effect for which you want to
set the level.

2.

Open the Inserts section of the Inspector and click the effect slot to open the effect
control panel.

3.

In the effect control panel, set the Mix control to 100.
This allows for full control of the effect level when you use the effect sends to control the
signal balance later.

4.

In the track list, select the audio track that is routed through the effect for which you want
to set the level.

5.

Click Edit Channel Settings to open the Channel Settings window for the audio track.

6.

In the Sends section on the Destinations tab, locate the effect slot and drag to the left or
right to set the send level.

This determines how much of the signal from the audio channel is routed to the FX
channel.
RESULT
The effect level is adjusted according to your settings.
NOTE
To determine how much of the signal from the FX channel is sent to the output bus, open the
Channel Settings window for the FX channel track and adjust the effect return level.

Side-Chain Input
Many VST 3 effects feature a side-chain input. Side-chaining allows you to use the output of one
track to control the action of an effect on another track.
Effects from the following categories feature side-chain:
●

Modulation

●

Delay

●

Filter

By activating the side-chain input you can:
●

Use the side-chain signal as a modulation source.

●

Apply ducking to the instrument, that is, reduce the volume of the instrument track when a
signal is present on the audio track.

●

Compress the signals on one audio track when a second audio track starts.
This is typically used to add compression on a bass sound when the drums are hit.

NOTE
For detailed descriptions of the plug-ins that feature side-chaining, see the separate document
Plug-in Reference.
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NOTE
●

Certain combinations of tracks and side-chain inputs may lead to feedback loops and
added latency. If this is the case, the side-chain options are not available.

●

Side-chain connections are only kept when you move an effect within a channel. When you
drag and drop an effect between channels, or when you copy an effect into another effect
slot, the side-chain connections are lost.

Side-Chain and Modulation
Side-chain signals bypass the built-in LFO modulation and apply modulation according to the
envelope of the side-chain signal. Since each channel is analyzed and modulated separately, this
allows for creating astonishing spatial modulation effects.

Triggering a Delay Effect with Side-Chain Signals
You can use side-chain signals to create a ducking delay effect. This is useful if you want to apply
a delay effect that is audible only when no signal is present on a track.
PROCEDURE
1.

Select the audio track that contains the audio you want to delay.

2.

Select Project > Duplicate Tracks.
The events on the duplicated track are only used to reduce the volume of the effect that is
added to the original track.

3.

Select the original track.

4.

In the Inspector, open the Inserts section and select Delay > PingPongDelay, for
example.
The control panel for the effect opens.

5.

Make the desired effect settings for the effect, and activate Activate Side-Chain.

6.

In the track list, select the duplicated track.

7.

In the Inspector, click Output Routing and select the side-chain node for the
PingPongDelay effect that you set up.

RESULT
The signals from the duplicated track are routed to the effect. Every time the audio signals on the
track set in, the delay effect is deactivated.
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NOTE
To ensure that audio signals of low or middle volume also silence the delay effect, you can adjust
the volume of the duplicated track.

Triggering a Compressor with Side-Chain Signals
Compression, expansion, or gating can be triggered by side-chain signals exceeding a specified
threshold. This allows you to lower the volume of one audio signal every time another audio
signal sets in.
PREREQUISITE
You have set up a project with a bass guitar and a bass drum track, for example, and you want to
lower the bass guitar volume each time the bass drum hits.
PROCEDURE
1.

Select the bass guitar track.

2.

In the Inspector, open the Inserts section.

3.

Click the first effect slot, and from the selector, select Dynamics > Compressor.
The effect is loaded and the effect control panel opens.

4.

Make the desired effect settings for the effect and activate Activate Side-Chain.

5.

Select the bass drum track.

6.

In the Inspector, open the Sends section.

7.

Click the first effect slot and select the side-chain node for the Compressor effect that you
set up for the bass guitar track.

8.

Click Activate Send and adjust the Send level.

RESULT
The bass drum signal triggers the Compressor on the bass guitar track. When you now play back
the project, the bass guitar will be compressed whenever the signals on the bass drum track
exceed the set threshold.

Dither Effects
Dither effects allow you to control the noise that is produced by quantization errors that can
occur when you mix down to a lower bit depth.
Dithering adds a special kind of noise at an extremely low level to minimize the effect of
quantization errors. This is hardly noticeable and preferable to the distortion that otherwise
occurs.

Applying Dither Effects
PROCEDURE
1.

Select Studio > MixConsole.

2.

Open the Rack Settings and activate Fixed Number of Slots.

3.

Click Edit Channel Settings for the output channel.

4.

In the Inserts section, click a post-fader effect slot, and select Mastering > UV22HR.

5.

On the plug-in panel, select a bit depth for the mixdown file you want to create.
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RELATED LINKS
Export Audio Mixdown on page 1007
Rack Settings on page 378

External Effects
You can integrate external effect devices into the sequencer signal flow by setting up external FX
busses.
An external FX bus is a combination of outputs (sends) and inputs (returns) on your audio
hardware, along with a few additional settings.
All external FX busses you have created are available on the effect pop-up menus. If you select an
external effect as an insert effect for an audio track, the audio is sent to the corresponding audio
output, processed in your hardware effect and returned via the specified audio input.
RELATED LINKS
Audio Connections on page 22
External Instruments and Effects on page 31

Effect Control Panel
The effect control panel allows you to set up the parameters of the selected effect. The contents,
design, and layout of the control panel depend on the selected effect.
●

To open the control panel for a plug-in, double-click the effect slot.

The following controls are available for all effects:

1

Activate Effect

2

Bypass Effect

Activates/Deactivates the effect.
Allows you to bypass the effect.
3

Read/Write Automation
Allows you to read/write automation for the effect parameter settings.

4

Switch between A/B Settings
Switches to setting B when setting A is active, and to setting A when setting B is active.

5

Copy A to B
Copies the effect parameters of effect setting A to effect setting B.

6

Activate Side-Chain

7

Preset browser

Activates the side-chain functionality.
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Opens the preset browser where you can select another preset.
8

Preset Management
Opens a pop-up menu that allows you to save, rename, or remove a preset.

9

Routing selector
Allows you to select an input configuration for the effect.

10

Functions menu
Opens a menu with specific functions and settings.

NOTE
For detailed information about the included effects and their parameters, see the separate
document Plug-in Reference.

Fine-Tuning Effect Settings
You can take your effect parameter settings as a starting point for further fine-tuning and then
compare the new settings with the original settings.
PREREQUISITE
You have adjusted the parameters for an effect.
PROCEDURE
1.

On the control panel for the effect, click Switch between A/B Settings.
This copies the initial parameter setting A to setting B.

2.

Fine-tune the effect parameters.
These parameter settings are now saved as setting B.

RESULT
You can now switch between both settings by clicking Switch between A/B Settings. You can
compare them, make further adjustments or just go back to setting A. Settings A and B are saved
with the project.
AFTER COMPLETING THIS TASK
You can copy the settings between A and B by clicking Copy A to B. You can take these settings
as a starting point for further fine-tuning.

Effect Presets
Effects presets store the parameter settings of an effect. The included effects come with a
number of presets that you can load, adjust, and save.
The following effect preset types are available:
●

VST presets for a plug-in.
These are plug-in parameter settings for a specific effect.

●

Inserts presets that contain insert effect combinations.
These can contain the whole insert effects rack with settings for each effect.

Effect presets are saved in the following location:
●

Windows: \Users\<user name>\My Documents\VST 3 Presets\<company>\<plug-in name>

●

macOS: /Users/<user name>/Library/Audio/Presets/<company>/<plug-in name>
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RELATED LINKS
Loading Effect Presets on page 460
Loading Insert Presets on page 463

Preset Browser
The preset browser allows you to select a VST preset for the loaded effect.
●

To open the preset browser, click the preset browser field in the effect control panel.

NOTE
The preset browser contains the Results and the Previewer sections. To open the Filters and the
Location Tree sections, click Set up Window Layout and activate the corresponding options.

1

Location Tree
Shows the folder that is searched for preset files.

2

Filters
Shows the available preset attributes for the selected effect.

3

Results
Lists the available presets for the selected effect.

4

Previewer
Allows you to preview the files shown in the results list.

Loading Effect Presets
Most VST effect plug-ins come with a number of useful presets that you can instantly select.
PREREQUISITE
You have loaded an effect, either as a channel insert or into an FX channel, and the effect control
panel is open.
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PROCEDURE
1.

Perform one of the following actions:
●

Click the preset browser field at the top of the control panel.

●

In the Inspector or the Channel Settings window, open the Inserts section and
click Select Preset for the loaded effect.

2.

In the Results section, select a preset from the list.

3.

Optional: Activate playback to audition the selected preset and step through the presets
until you find the right sound.
NOTE
You can set up cycle playback of a section to make comparisons between different preset
settings easier.

4.

Double-click to load the preset that you want to apply.

RESULT
The preset is loaded.
AFTER COMPLETING THIS TASK
You can return to the preset that was selected when you opened the preset browser by clicking
Revert to Last Setting.

Saving Effect Presets
You can save your effect settings as presets for further use.
PROCEDURE
1.

Open the Preset Management pop-up menu.
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2.

Select Save Preset
The Save <plug-in name> Preset pane opens.

3.

In the New Preset section, enter a name for the new preset.

4.

Optional: Click New Folder to add a subfolder inside the effect preset folder.

5.

Optional: Click Show Attribute Inspector in the bottom left corner of the pane and define
attributes for the preset.

6.

Click OK.

RESULT
The effect preset is saved.
RELATED LINKS
Attribute Inspector on page 632

Saving Default Effect Presets
You can save your effect parameter settings as default effect preset. This allows you to load your
parameter settings automatically, every time you select the effect.
PROCEDURE
1.

Open the Preset Management pop-up menu.

2.

Select Save as Default Preset.
You are asked if you want to save the current settings as default preset.

3.

Click Yes.

RESULT
The effect settings are saved as default preset. Every time you load the effect, the default preset
is loaded automatically.

Copying and Pasting Presets Between Effects
You can copy and paste effect presets between different instances of the same plug-in.
PROCEDURE
1.

Open the control panel for the effect that you want to copy.

2.

Right-click the control panel and select Copy <plug-in name> Setting from the context
menu.

3.

Open another instance of the same effect.
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4.

Right-click the control panel and select Paste <plug-in name> Setting from the context
menu.

Saving Insert Presets
You can save the inserts of the inserts effect rack for a channel, together with all parameter
settings as an inserts preset. Insert presets can be applied to audio, instrument, FX channel, or
group tracks.
PREREQUISITE
You have loaded a combination of insert effects and the effect parameters are set up for each
effect.
PROCEDURE
1.

Select the track.

2.

In the Inspector, open the Inserts section.

3.

On the Inserts tab, click Preset Management and select Save FX Chain Preset.

4.

In the Save FX Chain Preset pane, enter a name for the new preset in the New Preset
section.

5.

Click OK.

RESULT
The insert effects and their effect parameters are saved as insert preset.
RELATED LINKS
Applying FX Chains on page 475

Loading Insert Presets
You can load insert presets to audio, group, instrument, and FX channels.
PREREQUISITE
You have saved a combination of insert effects as insert presets.
PROCEDURE
1.

Select the track to which you want to apply the new preset.

2.

In the Inspector, open the Inserts section.

3.

On the Inserts tab, click Preset Management and select Load FX Chain Preset.

4.

Select an insert preset.
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5.

Double-click to apply the preset and close the pane.

RESULT
The effects of the insert effect preset are loaded and any plug-ins that were previously loaded for
the track are removed.

Loading Insert Effect Settings from Track Presets
You can extract the effects that are used in a track preset and load them into your inserts rack.
PROCEDURE
1.

Select the track to which you want to apply the new preset.

2.

In the Inspector, open the Inserts section.

3.

On the Inserts tab, click Preset Management and select From Track Preset.

4.

In the track preset pane, select the preset that contains the insert effects you want to load.

5.

Double-click to load the effects and close the pane.

RESULT
The effects used in the track preset are loaded.
RELATED LINKS
Track Presets on page 188

System Component Information Window
The System Component Information window lists all the available MIDI plug-ins, audio-codec
plug-ins, program plug-ins, project import-export plug-ins, and the virtual file system plug-ins.
●

To open the System Component Information window, select Studio > More Options >
System Component Information.
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Update (only available for MIDI Plug-ins)
Re-scans the designated plug-in folders for updated system component information.
The following columns are available:
Active
Allows you to activate or deactivate a plug-in.
Instances
The number of plug-in instances that are used in Nuendo.
Name
The name of the plug-in.
Vendor
The manufacturer of the plug-in.
File
The name of the plug-in, including its file name extension.
Path
The path in which the plug-in file is located.
Category
The category of each plug-in.
Version
The version of the plug-in.
SDK
The version of the VST protocol with which the plug-in is compatible.

Managing System Components in the System Component
Information Window
●

To make a plug-in available for selection, activate the checkbox in the left column.
Only the activated plug-ins appear in the effect selectors.

●

To see where a plug-in is used, click in the Instances column.
NOTE
A plug-in may be in use even if it is not activated in the left column. The left column only
determines whether or not the plug-in is visible on the effect selectors.

Exporting System Component Information Files
You can save system component information as an XML file, for example, for archiving purposes
or troubleshooting.
●

The system component information file contains information on the installed/available
plug-ins, their version, vendor, etc.

●

The XML file can then be opened in any editor application supporting the XML format.

NOTE
The export function is not available for program plug-ins.
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PROCEDURE
1.

In the System Component Information window, right-click in the middle of the window
and select Export.

2.

In the dialog, specify a name and location for the system component information export
file.

3.

Click Save to export the file.
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Direct Offline Processing allows you to instantly add plug-in effects and audio processes to the
selected audio events, clips, or ranges, without destructing the original audio.
Applying offline effects is common practice in dialogue editing and sound design. Offline
processing has several advantages over applying realtime mixer effects:
●

The workflow is clip-based. This allows you to apply different effects to events on the same
track.

●

The MixConsole can be kept clean from insert effects and parameter changes. This
facilitates later mixing by another person, on a different system.

●

Less CPU load is used.

Direct Offline Processing allows you to undo any changes regarding plug-in effects and audio
processes, at any point and in any order. You can always revert to the original version. This is
possible because processing does not affect the actual audio files.
If you process an event, a clip, or a selection range, the following happens:
●

A new audio file is created in the Edits folder within your project folder.
This file contains the processed audio, and the processed section of the audio clip refers to
it.

●

The original file remains unaffected.
The unprocessed sections still refer to it.

All applied offline processing is saved with the project and can still be modified after reopening
the project. Direct Offline Processing operations on the selected audio are persistent in track
archives and project backups, and when using network collaboration or copying processes
between projects
NOTE
If you export audio via Game Audio Connect or as an AAF file, all offline processing is
automatically made permanent.
Processing is always applied to the selection. This can be one or multiple events in the Project
window or in the Audio Part Editor, an audio clip in the Pool, or a selection range on one or
multiple events in the Project window or in the Sample Editor. If a selection is shorter than the
audio file, only the selected range is processed.
If you select an event that is a shared copy, and therefore refers to a clip that is used by other
events in the project, you can decide how to proceed:
●

Select Continue to process all shared copies.

●

Select New Version to process the selected event only.
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NOTE
This only works if Open Options Dialog is selected for the On Processing Shared Clips setting in
the Preferences dialog (Editing—Audio page).

RELATED LINKS
Modifying Processes on page 476
Applying Offline Processing Permanently on page 477
Game Audio Connect on page 498
Exporting AAF Files on page 1125
Editing - Audio on page 1184
Direct Offline Processing Workflow on page 468
Direct Offline Processing Window on page 469

Direct Offline Processing Workflow
You can perform offline processing operations in the Direct Offline Processing window. The
window always shows the processing of the selected audio.
For the Direct Offline Processing window, the following applies:
●

Only one instance of the window can be open.

●

The window size is determined by the displayed plug-in or process.

●

The window is non-modal and remains open, even if you edit in the Project window.

●

The window is always on top of your application. You can change this by activating/
deactivating the Always on Top option in the context menu.

●

If Auto Apply is activated, you can use offline processing even if the Direct Offline
Processing window is in the background or minimized.

When you add or modify offline processing, the following applies:
●

All changes are instantly applied to the audio.
NOTE
You can change this by deactivating Auto Apply in the Direct Offline Processing window.
This can be necessary if you work with long events or if you use plug-ins that have a
learning function.

●

If you modify parameters or remove processing, these changes are instantly applied to the
audio.

●

You get a visual feedback while a process is running.
NOTE
You can add, modify, or delete plug-in effects or audio processes at any time, even if a
process is running. A new rendering process is instantly started.

●

You can undo and redo all Direct Offline Processing operations by using Ctrl/Cmd-Z or
Shift-Ctrl/Cmd-Z.

●

If you load a project with offline processing of plug-in effects or audio processes that are
not available on your computer, these processes are shown as Not available in the Direct
Offline Processing window.

RELATED LINKS
Direct Offline Processing Window on page 469
Deactivating Auto Apply on page 472
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Applying Direct Offline Processing Using Key Commands on page 486
Applying Offline Processing Permanently on page 477

Direct Offline Processing Window
The Direct Offline Processing window allows you to add, modify, or delete audio processing
instantly for one or multiple events, clips, or selection ranges in one window. Furthermore, you
can undo any audio processing, at any point and in any order.
To open the Direct Offline Processing window, do one of the following:
●

Select Audio > Direct Offline Processing.

●

Use a key command, by default F7.

●

On the Project window toolbar, click Open Direct Offline Processing Window.

●

Select Audio > Processes, and from the submenu, select a process.
NOTE
Processes without adjustable parameter settings, for example, Silence, do not open the
Direct Offline Processing window.

In the Direct Offline Processing window, the following options and settings are available:
1

Process list
Lists all plug-in effects and built-in audio processes that you add to the selected event, clip,
or range. You can bypass items in this list. An icon at the right of each process shows the
status.
If only a range of a selected event is processed, this is indicated by a waveform icon in the
Range column.
If more than one processed event or clip is selected, the Count column shows how many
instances of each process are used on the whole selection.
You can copy or cut processes with all settings and paste them to other events, clips, or
ranges, delete them, and make offline processing permanent by using the context menu.
If a process is not available on your computer, it is shown as Not available.

2

Favorites
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Allow you to add and manage single processes or process batches with dedicated
parameter settings. You can create up to 36 favorites that are available on 4 banks.
3

Process panel
Allows you to modify or delete the selected plug-in effect or audio process.
The Apply and Discard buttons allow you to apply a new plug-in effect or audio process or
a parameter change manually to the audio or to discard it. They become available if you
deactivate Auto Apply.
NOTE

4

●

If Auto Apply is activated, the Apply and Discard buttons are not available.

●

The effect parameters for plug-ins are described in the separate document Plug-in
Reference.

Toolbar
Allows you to add audio processing, to audition the audio with the current edits, and to
make global settings for offline processing.

RELATED LINKS
Applying Processing on page 471
Bypass Processes on page 477
Copying and Pasting Processes on page 477
Favorites on page 473
Batch Processing on page 474
Applying Offline Processing Permanently on page 477
Applying Processing to Multiple Events on page 472
Deactivating Auto Apply on page 472
Direct Offline Processing Toolbar on page 470

Direct Offline Processing Toolbar
The Direct Offline Processing toolbar allows you to add audio processing, to audition the audio
with the current edits, and to make global settings for offline processing.
On the toolbar, the following options and settings are available:
Add Plug-in
Allows you to add a plug-in effect to the selected event or clip.
Add Process
Allows you to add a built-in audio process to the selected event or clip.
Auto Apply
If this option is activated and you add or modify a plug-in effect or an audio process,
it is instantly rendered into the audio and added to the process list in the left zone of
the Direct Offline Processing window.
If this option is deactivated, you can make your settings on the process panel
without rendering your changes instantly into the audio. To add the plug-in effect or
the audio process to the process list, or to apply parameter changes of a process that
you already added, click Apply. To discard a plug-in effect, an audio process, or a
parameter change, click Discard.
NOTE
The Auto Apply function for instant rendering is suited for most workflows.
However, if you work with long events or if you use plug-ins that have a learning
function, you might want to deactivate it.
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Audition
Allows you to audition the selected audio with all processing from the top of the
process list up to the selected process in the list. All processes below are ignored
during playback.
Audition Loop loops the playback until you deactivate the Audition button. The
Audition Volume slider allows you to adjust the volume.
Extend Process Range in ms
Allows you to extend the process range over the left and right of the event borders.
This allows you to enlarge the event at a later stage with all applied processing.
Tail in ms
Allows you to add time at the end of the rendered files. This way, reverb and delay
effects can fully fade out.
Show/Hide Left Zone
Shows/Hides the left zone of the Direct Offline Processing window that contains the
process list.
NOTE
This setting is saved globally.

RELATED LINKS
Deactivating Auto Apply on page 472
Extend the Process Range on page 475
Tail on page 475

Applying Processing
You can add processing to one or multiple events, clips, or ranges in the Direct Offline
Processing window. This includes plug-in effects, audio processes, and Sample Editor
operations, such as Cut, Paste, Delete, and using the Draw tool.
The Auto Apply function for instant rendering is suited for most workflows. However, if you work
with long events or if you use plug-ins that have a learning function, you might want to
deactivate it.
PROCEDURE
1.

Do one of the following:
●

Select an event or a range in the Project window.

●

Select a clip in the Pool.

●

Select a range in the Sample Editor.

●

Select an event or a range in the Audio Part Editor.

2.

Select Audio > Direct Offline Processing.

3.

On the Direct Offline Processing toolbar, click Add Plug-in or Add Process and select a
plug-in effect or an audio process.
IMPORTANT
●

You can select all installed VST plug-ins for offline processing. However, not every
plug-in is suited for offline processing.

●

If you apply a stereo effect to mono audio material, the left side of the effect’s stereo
output is used.
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The selected plug-in effect or audio process is added to the process list in the left zone.
4.

Activate Audition and make your settings on the process panel.
You get a visual feedback while a process is running. However, even if the processing is
not finished, you can activate Audition at any time.

5.

Optional: If Auto Apply is deactivated, choose whether you want to apply the processing
to the audio or to discard it.
●

Click Apply to add the plug-in effect or audio process to the process list and render
it into the audio.

●

Click Discard to discard the plug-in effect or audio process. The process panel is
emptied.

RESULT
The plug-in effect or audio process is rendered into the audio.
In the Project window, the Pool or the Audio Part Editor, the processed events show a
waveform symbol.

Applying Processing to Multiple Events
Direct Offline Processing allows you to add plug-in effects or built-in audio processes to
multiple events at once. You can also modify or delete processing on multiple events
simultaneously.
●

To apply plug-ins or audio processes to multiple events at once, select the audio and add,
modify, or delete the processing.

If you select multiple events, the Count column of the process list shows how many instances of
each process are used on the whole audio selection. The processes in the process list are ordered
alphabetically.
NOTE
Applying plug-in effects to multiple events that have different channel configurations may lead to
unwanted results depending on the plug-in used.
NOTE
In the Direct Offline Processing window, you can also edit the audio processing of multiple clips
in the Pool simultaneously.

RELATED LINKS
Built-In Audio Processes on page 478
Direct Offline Processing Window on page 469

Deactivating Auto Apply
When you add or modify plug-in effects or audio processes, the processing is by default
automatically applied to the audio. If you work with long events or if you use plug-ins with
learning function, you can deactivate Auto Apply.
If Auto Apply is deactivated, the following applies:
●

You must click Add to apply processing to the audio.

●

You must click Discard to cancel processing.

RELATED LINKS
Applying Plug-in Effects with Learning Function on page 473
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Applying Plug-in Effects with Learning Function
You can train a plug-in effect that has a learning function, for example a plug-in for noise
reduction.
PROCEDURE
1.

Select an audio range that you want to use for training the plug-in about the noise
spectrum. For example, you can use a pause that only contains noise and no dialog.

2.

In the Direct Offline Processing window, deactivate Auto Apply.

3.

Add the noise reduction plug-in and activate its learning mode.

4.

On the Direct Offline Processing window toolbar, activate Audition in loop mode.

5.

When you have trained the plug-in, deactivate its learning mode.

6.

Deactivate Audition.

7.

Click Discard.
Noise reduction is not applied at this point but the plug-in keeps the parameter settings
for the learned noise spectrum.

8.

Select the whole event.

9.

In the Direct Offline Processing window, add the noise reduction plug-in and click Apply.
Noise reduction is applied with the current parameter settings.

RESULT
Noise reduction is applied to the whole event.

Favorites
For plug-ins or audio processes that you use frequently you can create favorites in the Direct
Offline Processing window.
Favorites allow you to instantly apply single or multiple plug-ins and audio processes with
dedicated parameter settings to the selected audio. You can create up to 36 favorites on 4 banks
by dragging plug-ins and audio processes to the favorites section below the process list.
RELATED LINKS
Creating Favorites on page 473
Applying Processing via Favorites on page 474
Batch Processing on page 474

Creating Favorites
In the Direct Offline Processing window you can create favorites for frequently used plug-ins or
processes with dedicated parameter settings.
PREREQUISITE
The process list contains plug-ins or audio processes with parameter settings that you want to
save as favorites.
PROCEDURE
1.

Optional: In the favorites section, select a bank.

2.

In the process list, select one or multiple processes, and drag them to the favorites section.

3.

Optional: If you selected multiple processes, enter a batch name in the New Batch
window.
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RESULT
A favorite is created on the selected bank in the favorites section.
AFTER COMPLETING THIS TASK
You can rename or delete the favorite by using the context menu.
RELATED LINKS
Batch Processing on page 474

Applying Processing via Favorites
Favorites allow you to instantly apply processing to one or multiple events, clips, or ranges.
NOTE
If you apply plug-in effects or audio processes by clicking a favorite, the processing is instantly
rendered to the audio, even if Auto Apply is deactivated.

PROCEDURE
1.

Select one or multiple events.

2.

In the Direct Offline Processing window, click a favorite.

RESULT
The corresponding plug-in, audio process, or process batch is instantly applied to the audio.
RELATED LINKS
Favorites on page 473
Deactivating Auto Apply on page 472
Batch Processing on page 474

Batch Processing
Direct Offline Processing allows you to save multiple plug-in effects or audio processes with
dedicated settings as batches in the Favorites section, and to apply these batches with one click.
You can also apply FX chain presets or insert effects of track presets as batches.
●

You can create batches by dragging multiple processes from the process list to the
favorites section.

●

You can apply a batch to the audio by clicking the corresponding favorite.

●

You can apply FX chain presets or insert effects of track presets as batches by clicking
Select Preset in the Direct Offline Processing toolbar.

NOTE
●

Batches are instantly applied to the audio, even if Auto Apply is deactivated.

●

Batches are saved globally.

●

If batches contain plug-in effects that are not available on your computer, these batches
are applied without the plug-ins.

RELATED LINKS
Creating Favorites on page 473
Applying Processing via Favorites on page 474
Applying FX Chains on page 475
Deactivating Auto Apply on page 472
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Applying FX Chains
You can import FX chain presets or insert effects of track presets and apply them as batch
processes.
NOTE
Batches are instantly applied to the audio, even if Auto Apply is deactivated.

PROCEDURE
1.

In the Direct Offline Processing toolbar, click Select Preset and choose an FX chain
preset or insert effects from a track preset for import.

2.

From the selector, select an FX chain preset or a track preset.

RESULT
The effects of the FX chain preset or track preset are instantly applied to the audio.
RELATED LINKS
Deactivating Auto Apply on page 472
Saving Insert Presets on page 463
Track Presets on page 188

Extend the Process Range
You can extend the process range over the left and right borders of the audio event.
This setting allows you to enlarge the event even after applying the processing.
●

To extend the process range, click Extend Process Range in ms on the Direct Offline
Processing toolbar and specify a value in milliseconds.

NOTE
●

For this to work, audio must be available outside the event borders.

●

This setting works globally for all events.

Tail
You can add time at the end of the rendered audio when applying plug-in effects.
Adding tail avoids that a reverb tail or a delay effect is cut off. Tail is added at the end of the event
and the event is automatically resized.
●

To add tail when applying a plug-in effect, click Tail in ms on the Direct Offline
Processing toolbar and specify a value in milliseconds.

NOTE
●

This setting works globally for all events.

●

Tail is added only if you add plug-in effects. If you add audio processes, for example Gain,
no tail is added.

●

If you add tail to an event that you have manually resized before, the tail is added but the
event length is not adjusted automatically. Therefore, you must adjust the event manually.
In this case, the tail is mixed with the underlying audio clip.

RELATED LINKS
Resize Events on page 209
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Modifying Processes
You can delete or modify some or all processing from a clip in the Direct Offline Processing
window. This includes the audio processes on the Processes menu, any applied plug-in effects,
and Sample Editor operations, such as Cut, Paste, Delete, and drawing with the Draw tool.
The Auto Apply function for instant rendering is suited for most workflows. However, if you work
with long events or if you use plug-ins that have a learning function, you might want to
deactivate it.
PROCEDURE
1.

Do one of the following:
●

Select the processed event in the Project window or in the Audio Part Editor.
NOTE
In the Project window or in the Audio Part Editor, processed events are indicated
by a waveform symbol in the upper right corner.

●

Select the processed clip in the Pool.
NOTE
In the Pool, processed clips are indicated by a waveform symbol in the Status
column.

●

Select the processed range in the Sample Editor.

2.

Select Audio > Direct Offline Processing.

3.

In the process list, select the process that you want to edit by clicking on it.

4.

Do one of the following:
●

Activate Audition and modify the settings of the process.

●

Delete the process by clicking Delete

on the process panel.

NOTE
Alternatively, you can right-click the process list and select Delete.
●
5.

To delete all processing applied to the event, right-click the process list and select
Delete All.

Optional: If Auto Apply is deactivated, choose whether you want to apply your parameter
changes to the audio or to discard them.
●

Click Apply to apply the parameter changes to the audio.

●

Click Discard to discard the parameter changes.

RELATED LINKS
Direct Offline Processing Window on page 469
Pool Window Columns on page 588

Reordering the Process List
You can reorder the operations in the Direct Offline Processing process list by dragging.
PROCEDURE
●

Click a plug-in effect or an audio process and move it by dragging.
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RESULT
The offline processing operations are rendered into the audio in the specified order.

Bypass Processes
In the Direct Offline Processing window, you can bypass processes. This allows you to hear the
audio without the processes.
●

To activate/deactivate bypass for a process, click the Bypass Process button on the left of
the process.

NOTE
●

If you activate/deactivate Bypass Process, the complete process chain is recalculated.
Depending on the length of the audio and number of processes, this may take some time.
In the process list, you get a visual feedback while a process is running.

●

The bypass status is saved with the project.

Copying and Pasting Processes
You can copy and paste plug-in effects and audio processes together with their parameter
settings between events, clips, and ranges.
PROCEDURE
1.

Select a processed audio event, clip, or range.
NOTE
Processing on selections of multiple events cannot be copied.

2.

In the Direct Offline Processing window, select one or multiple items in the process list.

3.

Right-click the process in the process list and select Copy from the context menu.

4.

Select the events or clips where you want to paste the process.

5.

In the Direct Offline Processing window, right-click the process in the process list and
select Paste.

RESULT
The copied processes and all parameter settings are added to the process list of the selected
audio.

Applying Offline Processing Permanently
You can apply all offline processing permanently to the audio.
PREREQUISITE
You have applied plug-in effects or audio processes to an event, clip, or range and you are sure
that you do not need to edit the processing anymore.
IMPORTANT
Making offline processing permanent cannot be undone.

PROCEDURE
1.

Select the processed event, clip, or range.

2.

Select Audio > Make Direct Offline Processing Permanent.
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NOTE
Alternatively, select Make All Permanent in the context menu of the Direct Offline
Processing process list.
3.

In the dialog that opens, select OK.

RESULT
●

All processing and applied effects are permanently added to the selected event, clip, or
range.

●

The process list is emptied.

●

The event or clip is no longer marked as offline-processed by a waveform symbol.

Built-In Audio Processes
Nuendo provides several built-in audio processes that can be used for Direct Offline Processing.

Envelope
Envelope allows you to apply a volume envelope to the selected audio.

Curve Kind buttons
Determine whether the corresponding envelope uses Spline Interpolation,
Damped Spline Interpolation, or Linear Interpolation.
Envelope display
Shows the shape of the envelope. The resulting waveform shape is shown in a dark
tone, with the current waveform shape in a light tone.
●

To add a curve point, click the curve.

●

To move a curve point, click and drag.

●

To remove a curve point, click and drag it outside the display.

Presets
Allow you to set up presets that you want to apply to other events or clips.
●

To save a preset, click Store, type in a name, and click OK.

●

To apply a preset, select it from the pop-up menu.

●

To remove a preset, select it from the pop-up menu, and click Remove.
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Fade In/Fade Out
Fade In and Fade Out allow you to apply a fade to the selected audio.

Curve Kind buttons
Determine whether the corresponding envelope uses Spline Interpolation,
Damped Spline Interpolation, or Linear Interpolation.
Fade display
Shows the shape of the fade curve. The resulting waveform shape is shown in a dark
tone, with the current waveform shape in a light tone.
Click the curve to add points, and click and drag existing points to change the shape.
To remove a point from the curve, drag it outside the display.
Presets
Allow you to set up presets that you want to apply to other events or clips.
●

To save a preset, click Store, type in a name, and click OK.

●

To apply a preset, select it from the pop-up menu.

●

To remove a preset, select it from the pop-up menu, and click Remove.

Shape buttons
These buttons give you quick access to some common curve shapes.

Gain
Gain allows you to change the gain, that is, the level of the selected audio.

Gain
Allows you to set a gain value between -50 dB and +20 dB.
Clipping Detection text
This text is displayed if you use Audition and the gain setting results in audio levels
above 0 dB.
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NOTE
In case of clipping, lower the Gain value and use the Normalize audio process
instead. This allows you to increase the level of the audio as much as possible
without causing clipping.

RELATED LINKS
Normalize on page 480

Normalize
Normalize allows you to raise the level of audio that was recorded at too low an input level.

Normalize
Allows you to set a maximum level for the audio, between -50 dB and 0 dB.
From this maximum level, the current maximum level of the selected audio is
subtracted, and the gain is raised or lowered by the resulting amount.

Phase Reverse
Phase Reverse allows you to reverse the phase of the selected audio.
For stereo audio files, a pop-up menu is available. It allows you to specify which channels are
phase-reversed: the left channel, the right channel, or both.
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Pitch Shift
Pitch Shift allows you to change the pitch of the audio with or without affecting its length. You
can also create harmonies by specifying several pitches or apply pitch shift based on an envelope
curve.

On the Transpose tab, the following options are available:
Keyboard display
Shows a graphic overview of the transposition where the root note is indicated in red
and the transposed key is indicated in blue.
NOTE
The indicated root note has nothing to do with the key or pitch of the original audio,
it just provides a way to display transpose intervals.
●

To change the root note, use the settings in the Pitch Shift Base section, or
hold Alt, and click the keyboard display.

●

To specify a transpose interval, click one of the keys.

●

To specify a chord, activate Multi Shift and click several keys.
To remove a transpose interval, click a blue key.

Pitch Shift Settings
Transpose
Allows you to specify the amount of pitch shift in semitones.
Fine-Tune
Allows you to specify the amount of pitch shift in cents.
Volume
Allows you to lower the volume of the pitch-shifted sound. This is not available if
Time Correction is activated.
Listen Key Level
Allows you to adjust the level of the pitch-shifted sound. Click Listen Key/Listen
Chord to play a test tone of the pitch-shifted sound.
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Pitch Shift Base
Root Note/Pitch
Allows you to set the root note.
NOTE
The indicated root note has nothing to do with the key or pitch of the original audio,
it just provides a way to display transpose intervals.
Multi Shift
Activate this to specify several transpose keys and create multi-part harmonies. If the
intervals you add make up a standard chord, this chord is displayed to the right.
●

To include the original, untransposed sound, click the root key in the keyboard
display so that it is displayed in blue.

NOTE
In Multi Shift mode, Audition is not available.

Algorithm Settings
Time Correction
Activate this option to shift the pitch without affecting the length of the audio. If this
is deactivated and you raise the pitch, the audio section is shortened.
MPEX 4 Preset
Allows you to select an MPEX 4 algorithm.
RELATED LINKS
Time Stretch and Pitch Shift Algorithms on page 488

Envelope-Based Pitch Shift
On the Envelope tab, you can specify an envelope curve as a base for the pitch shift.

Curve Kind buttons
Determine whether the corresponding envelope uses Spline Interpolation,
Damped Spline Interpolation, or Linear Interpolation.
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Envelope display
Shows the shape of the envelope curve over the waveform image of the audio
selected for processing. Envelope curve points above the center line indicate a
positive pitch shift, curve points below the center line indicate a negative pitch shift.
Initially, the envelope curve is a horizontal, centered line, indicating zero pitch shift.
●

To add a curve point, click the curve.

●

To move a curve point, click and drag.

●

To remove a curve point, click and drag it outside the display.

●

To remove all curve points, click Reset above the envelope display.

Pitch Shift Settings
Range
Allows you to determine the vertical pitch range of the envelope. Moving a curve
point to the top of the display shifts the pitch by this value.
Transpose
Allows you to specify the amount of pitch shift in semitones.
Fine-Tune
Allows you to specify the amount of pitch shift in cents.

Algorithm Settings
Time Correction
Activate this option to shift the pitch without affecting the length of the audio. If this
is deactivated, raising the pitch will shorten the audio section and vice versa, much
like changing the playback speed on a tape recorder.
MPEX 4 Preset
Allows you to select an MPEX 4 algorithm.
RELATED LINKS
MPEX on page 489

Remove DC Offset
Remove DC Offset allows you to remove any DC offset in the audio selection.
If your audio signal contains too large a component of direct current, you may notice that it is
not centered around the zero level axis. This is called DC offset.
●

To verify if your audio contains DC offsets, select the audio and select Audio > Statistics.

IMPORTANT
DC offset is normally present throughout the entire recording. Therefore, always apply Remove
DC Offset to complete audio clips.
There are no adjustable parameters for this audio process.
RELATED LINKS
Statistics on page 496
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Resample
Resample allows you to change the length, tempo, and pitch of an event.
If you resample to a higher sample rate, the event gets longer and the audio plays back at a
slower speed with a lower pitch. If you resample to a lower sample rate, the event gets shorter
and the audio plays back at a faster speed with a higher pitch.

File Sample Rate
Shows the original sample rate of the event.
New Sample Rate
Allows you to resample the event by specifying a sample rate.
Difference
Allows you to resample the event by specifying the difference between the original
sample rate and the new sample rate.

Reverse
Reverse allows you to reverse the audio selection so that it sounds as if you play back a tape
backwards. There are no adjustable parameters for this audio process.

Silence
Silence allows you to replace the selection with silence. There are no adjustable parameters for
this audio process.

Stereo Flip
Stereo Flip allows you to manipulate the left and right channels of stereo audio selections.
In the Mode pop-up menu, the available options are:
Flip Left-Right
Swaps the left and right channel.
Left to Stereo
Copies the left channel sound to the right channel.
Right to Stereo
Copies the right channel sound to the left channel.
Merge
Merges both channels on each side for mono sound.
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Subtract
Subtracts the left channel information from the right. This function is typically used
for karaoke background as it removes the centered mono material from a stereo
signal.

Time Stretch
Time Stretch allows you to change the length and tempo of the selected audio without affecting
the pitch.

Define Bars
You can set the length of the selected audio and the time signature in this section.
Bars
Allows you to set the length of the selected audio in bars.
Beats
Allows you to set the length of the selected audio in beats.
Signature
Allows you to set the time signature.

Original Length
This section contains information and settings regarding the audio that is selected for
processing.
Length in Samples
Shows the length of the selected audio in samples.
Length in Seconds
Shows the length of the selected audio in seconds.
Tempo in BPM
Allows you to enter the actual tempo of the audio in beats per minute. This option
allows you to time-stretch the audio to another tempo, without having to compute
the actual time stretch amount.

Resulting Length
These values change automatically if you adjust the Time Stretch Ratio to stretch the audio so
that it fits within a specific time span or tempo.
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Samples
Shows the resulting length in samples.
Seconds
Shows the resulting length in seconds.
BPM
Shows the resulting tempo in beats per minute. For this to work, the Original
Length must be specified.

Seconds Range
These settings allow you to set a range for the time stretch.
Arbitrary Range Start Time
Allows you to set a start position for the range.
Arbitrary Range End Time
Allows you to set an end position for the range.
Use Locators
Allows you to set the Range values to the left and right Locator positions,
respectively.

Algorithm
Allows you to select a time stretch algorithm.

Time Stretch Ratio
Allows you to set the amount of time stretch as a percentage of the original length. If you use the
settings in the Resulting Length section to specify the amount of time stretch, this value
changes automatically.
RELATED LINKS
Time Stretch and Pitch Shift Algorithms on page 488

Applying Direct Offline Processing Using Key Commands
You can apply offline processing by using key commands.
If you add plug-in effects or audio processes using key commands, the following applies:
●

If you add plug ins or audio processes directly, their current settings are used.

●

If you add plug ins or audio processes via favorites or batches, the dedicated settings of
the favorites or batches are used.

●

The Direct Offline Processing window opens. This does not apply if the selected process
does not feature any adjustable parameters, or if the window is in the background or
minimized.

NOTE
The Direct Offline Processing window is only effective in background or minimized if Auto
Apply is activated.

RELATED LINKS
Key Commands for Direct Offline Processing on page 487
Favorites on page 473
Batch Processing on page 474
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Key Commands for Direct Offline Processing
If the corresponding section in the Direct Offline Processing window has the focus, the
following default key commands apply:
Option

Key command

Open/Close Direct Offline Processing window F7
Set focus within Direct Offline Processing
window

Tab

Navigate in the process list

Up Arrow/Down Arrow

Activate/Deactivate Audition (Playback Toggle Space
triggers Local Preview must be activated in
the Preferences dialog)
Apply process in process panel (only available
if Auto Apply is deactivated)

Enter

Discard process in process panel (only
available if Auto Apply is deactivated)

Delete

Delete selected item from process list

Delete

Select all items in process list

Ctrl/Cmd-A

Cut selected items from process list

Ctrl/Cmd-X

Copy selected items in process list

Ctrl/Cmd-C

Paste items to process list

Ctrl/Cmd-V

Undo

Ctrl/Cmd-Z

To define key commands for further Direct Offline Processing operations, and for directly
adding particular plug-in effects, audio processes, favorites, or batches use the Key Commands
dialog.
RELATED LINKS
Direct Offline Processing Window on page 469
Transport on page 1205
Deactivating Auto Apply on page 472
Key Commands on page 1137
Favorites on page 473
Batch Processing on page 474
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Algorithms

In Nuendo, time-stretching and pitch-shifting algorithms are used for offline processes, in the
Sample Editor, or for the Flattening Realtime Processing function. Depending on the feature,
élastique, MPEX, or Standard algorithm presets are available.
RELATED LINKS
Time Stretch on page 485
Pitch Shift on page 481
Sample Editor on page 503
Flattening Realtime Processing on page 541
élastique on page 488
MPEX on page 489
Standard on page 489
Limitations on page 490

élastique
The élastique algorithm is suited for polyphonic and monophonic material.
The following modes are available:
élastique Pro
For best audio quality, without formant preservation.
élastique Pro Formant
For best audio quality, but including formant preservation.
élastique efficient
Requires less computing power, but has a lower audio quality than the Pro modes.
The modes support the following variants:
Time
Favors timing accuracy over pitch accuracy.
Pitch
Favors pitch accuracy over timing accuracy.
Tape
Locks the pitch shift to the time stretch as if playing back a tape with varying speed.
If you stretch the audio material, the pitch decreases automatically. This variant has
no effect if you use it with event transpose or the transpose track.
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MPEX
MPEX is an alternative high-quality algorithm.
You can choose between the following quality settings:
MPEX – Preview Quality
For preview purposes.
MPEX – Mix Fast
A very fast mode for preview. This mode works best with composite music signals
(mono or stereo material).
MPEX – Solo Fast
For single instruments (monophonic material) and voice.
MPEX – Solo Musical
Higher quality for single instruments (monophonic material) and voice.
MPEX – Poly Fast
For monophonic and polyphonic material. This is the fastest setting that still gives
very good results. You can use this for drum loops, mixes, and chords.
MPEX – Poly Musical
For monophonic and polyphonic material. This is the recommended MPEX quality
setting. You can use this for drum loops, mixes, or chords.
MPEX – Poly Complex
For complex material or for stretch factors above 1.3. This high-quality setting is
quite CPU-intensive.
NOTE
If you apply Pitch Shift as an offline process, you can choose between the regular setting and a
setting where the formants are preserved for each quality setting.

Standard
The Standard algorithm is optimized for CPU-efficient realtime processing.
The following presets are available:
Standard – Drums
For percussive sounds. This mode does not change the timing of your audio. If you
use it with certain tuned percussion instruments, you may experience audible
artifacts. In this case, try the Mix mode as an alternative.
Standard – Plucked
For audio with transients and a relatively stable spectral sound character like plucked
instruments.
Standard – Pads
For pitched audio with slower rhythm and a stable spectral sound character. This
minimizes sound artifacts, but the rhythmic accuracy is not preserved.
Standard – Vocals
For slower signals with transients and a prominent tonal character like vocals.
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Standard – Mix
For pitched material with a less homogenous sound character. This mode preserves
the rhythm and minimizes the artifacts.
Standard – Custom
Allows you to set the time-stretching parameters manually.
Standard – Solo
For monophonic material like solo woodwind/brass instruments or solo vocals,
monophonic synths or string instruments that do not play harmonies. This mode
preserves the timbre of the audio.

Custom Warp Settings
If you select the Standard – Custom mode, a dialog opens where you can manually adjust the
parameters that govern the sound quality of the time stretching:
Grain Size
Allows you to determine the size of the grains in which the standard time-stretching
algorithm splits the audio. Low grain size values lead to good results for material
that has many transients.
Overlap
This is the percentage of the whole grain that will overlap with other grains. Use
higher values for material with a stable sound character.
Variance
This is a percentage of the whole length of the grains, and sets a variation in
positioning, so that the overlapping area sounds smooth. A variance setting of 0
produces a sound akin to time stretching used in early samplers, whereas higher
settings produce more rhythmic smearing effects but fewer audio artifacts.

Limitations
Applying time stretching or pitch shifting to audio material can lead to a degradation in audio
quality and to audible artifacts. The result depends on the source material, the particular stretch
and pitch operations applied, and the selected audio algorithm preset.
As a rule of thumb, smaller changes in pitch or duration cause less degradation. However, there
are additional issues one should be aware of when working with time stretching and pitch
shifting algorithms.
NOTE
In rare cases, editing warped audio events may cause discontinuities at the edit points. You can
then try to move the edit point to a different position or bounce the audio event prior to editing.

Reverse Playback and Scrubbing
Most of the algorithms used for time stretching and pitch shifting only support forward playback.
Reverse playback or scrubbing of warped audio events can lead to recurring artifacts in playback.

Pitch and Stretch Factor
Some algorithms may put limitations on the maximum degree of time stretching or pitch shifting
supported. However, with élastique there are no limitations.
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Nuendo offers particular functions for analyzing the audio in your project.
RELATED LINKS
Detect Silence on page 491
Spectrum Analyzer on page 493
Statistics on page 496

Detect Silence
Detect Silence allows you to search for silent sections in events.
You can split events and remove the silent parts from the project, or create regions
corresponding to the non-silent sections.

●

To open the Detect Silence dialog, select one or multiple audio events or a range in the
Project window or the Audio Part Editor, and select Audio > Advanced > Detect Silence.
NOTE
If you select multiple events, you can process the selected events successively with
individual settings or apply the same settings to all selected events simultaneously.

The following options are available:
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Waveform Display
Allows you to zoom in on and out of the waveform by using the zoom slider to the
right, by clicking in the waveform, and moving the mouse up or down.
You can scroll the waveform by using the scrollbar, or by using the mouse wheel.
You can adjust the Open Threshold and Close Threshold values by moving the
squares at the beginning and at the end of the audio file.
Open Threshold
When the audio level exceeds this value, the function opens and lets the sound pass.
Audio material below the set level is detected as silence.
Close Threshold
When the audio level drops below this value, the function closes and detects sounds
below this level as silence. This value cannot be higher than the Open Threshold
value.
Linked
Activate this option to set the same values for Open Threshold and Close
Threshold.
Min. Time Open
Determines the minimum time that the function remains open after the audio level
has exceeded the Open Threshold value.
NOTE
If your audio contains repeated short sounds, and this results in too many short
open sections, try raising this value.
Min. Time Closed
Determines the minimum time that the function remains closed after the audio level
has dropped below the Close Threshold value. Set this to a low value to make sure
that you do not remove sounds.
Pre-Roll
Causes the function to open slightly before the audio level exceeds the Open
Threshold value. Use this option to avoid removing the attack of sounds.
Post-Roll
Causes the function to close slightly after the audio level drops below the Close
Threshold value. Use this option to avoid removing the natural decay of sounds.
Add as Regions
Creates regions of the non-silent sections, and allows you to specify a name for them
in the Region Name field. A number is appended on each region name, starting with
the number specified in the Auto Number Start field.
Strip Silence
Splits the event at the beginning and end of each non-silent section, and removes
the silent sections in between.
Process All Selected Events
Applies the same settings to all selected events. This option is only available if you
selected more than one event.
Compute
Analyzes the audio event and redraws the waveform display to indicate which
sections are considered silent. The number of detected regions is displayed above
the Compute button.
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Auto
Activate this option to analyze the audio event and update the display automatically
every time you change the settings.
NOTE
If you are working with very long files, consider deactivating the Auto option as this
may slow down the process.

Removing Silent Sections
The Detect Silence dialog allows you to detect and remove silent sections of your audio.
PROCEDURE
1.

Select one or multiple audio events with silent sections in the Project window.

2.

Select Audio > Advanced > Detect Silence.

3.

In the Detect Silence dialog, make your settings.

4.

Click Compute to analyze the audio.
The audio is analyzed and the waveform redrawn to indicate which sections are
considered silent according to your settings. The number of detected regions is displayed.

5.

Optional: Click Preview to listen to the result.
The event is played back and the sections are silenced according to your settings.

6.

Optional: In the Detection section, readjust the settings until you are satisfied with the
result.

7.

Optional: In the Output section, activate Add as Regions.

8.

In the Output section, activate Strip Silence.

9.

Click Process.

RESULT
The event is split and the silent sections are removed.

AFTER COMPLETING THIS TASK
If you have selected more than one event and did not activate Process all selected Events, the
Detect Silence dialog opens again after processing, allowing you to make separate settings for
the next event.

Spectrum Analyzer
The Spectrum Analyzer analyzes the selected audio, computes the average spectrum, and
displays it in a two-dimensional graph, with frequency range on the x-axis and level distribution
on the y-axis.
●

To open the Spectrum Analyzer, select Audio > Spectrum Analyzer.

Spectrum Analyzer Settings
The Spectrum Analyzer shows the following settings:
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Size in Samples
Allows you to set a size for the analysis blocks of the audio. The higher this value, the
higher the frequency resolution of the resulting spectrum.
Size of Overlap
Allows you to set the overlap between each analysis block.
Window Used
Allows you to select which window type is used for the fast Fourier transform, the
mathematical method used for computing the spectrum.
Normalized Values
Activate this option to scale the resulting level values, so that the highest level is
displayed as 1. This corresponds to 0 dB.
From Stereo
Allows you to specify which channel is analyzed.
Process
Starts the analysis of the spectrum and opens the spectrum display.

Spectrum Display
The Spectrum Display shows the following settings:

Frequency Display
Allows you to compare the levels between frequencies. Move the pointer to one of
the frequencies, right-click and move the pointer to the second frequency. The
difference in level between the positions is displayed and labeled D in the upper right
corner.
NOTE
For stereo audio, the display in the upper right corner shows the values for the left
channel. To show the right channel values, hold down Shift.
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dB
Activate this option to show dB values on the vertical axis. Deactivate this option to
show values between 0 and 1.
Freq. Log
Activate this option to display the frequencies on the horizontal axis on a logarithmic
scale. Deactivate this option to show a linear frequency axis.
Precision
Indicates the frequency resolution of the graph. This value is governed by the Size in
Samples setting in the spectrum analyzer settings.
Frequency (Hz)/Note (C)
Allows you to select if frequencies are displayed in Hertz or with note names.
Min.
Allows you to set the lowest frequency shown in the graph.
Max.
Allows you to set the highest frequency shown in the graph.
Active
Activate this option to open the next Spectrum Analysis dialog in the same window.
Deactivate this option to show the next dialog in a separate window.

Analyzing the Audio Spectrum
PROCEDURE
1.

Select an audio event, clip, or a selection range.

2.

Select Audio > Spectrum Analyzer.

3.

Adjust the settings or use the default values.
The default values give good results in most situations.

4.

Click Process.

RESULT
The spectrum is computed and displayed as a graph.
AFTER COMPLETING THIS TASK
Adjust the settings in the spectrum display and move the mouse pointer over the graph to
display the frequency/note and level at the current position in the upper right corner.
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Statistics
The Statistics function analyzes the selected audio events, clips, or selection ranges.

The Statistics window shows the following information:
Channel
Shows the name of the analyzed channel.
Min. Sample Value
Shows the lowest sample value in dB.
Max. Sample Value
Shows the highest sample value in dB.
Peak Amplitude
Shows the largest amplitude in dB.
True Peak
Shows the maximum absolute level of the audio signal waveform in the continuous
time domain.
DC Offset
Shows the amount of DC offset as a percentage and in dB.
Bit Depth
Shows the current calculated bit depth.
Estimated Pitch
Shows the estimated pitch.
Sample Rate
Shows the sample rate.
Average RMS (AES-17)
Shows the average loudness in accordance with the AES-17 standard.
Max. RMS
Shows the highest RMS value.
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Max. RMS All Channels
Shows the highest RMS value of all channels.
Max. Momentary Loudness
Shows the maximum value of all momentary loudness values, based on a time
window of 400 ms. The measurement is not gated.
Max. Short-Term Loudness
Shows the maximum value of all short-term loudness values, based on a time
window of 3 s. The measurement is not gated.
Integrated Loudness
Shows the average loudness over the whole title in LUFS (Loudness Unit, referenced
to Full Scale) in accordance with EBU R-128 that recommends to normalize audio at
-23 LUFS (±1 LU).
Loudness Range
Shows the dynamic range over the whole title in LU (Loudness Units). This value
allows you to see if dynamic processing is needed.
Max. True Peak Level
Shows the maximum value of the audio signal waveform in the continuous time
domain.
RELATED LINKS
Remove DC Offset on page 483
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Game Audio Connect makes it easy to transfer game audio assets to game audio engines or
middleware, such as Audiokinetic Wwise. As a sound designer, you create and edit game audio
assets in Nuendo and directly transfer them to your game audio engine.
An audio engine that is enabled for Game Audio Connect is able to locate your audio parts, either
on a local hard disk, in a network, or in a version control system. From your game audio engine,
you can select an audio asset and make Nuendo open the project that contains it.

Game Audio Connect Window
The Game Audio Connect window is the interface between the game audio engine and Nuendo.
It displays the connected game audio engine and the selected audio asset. The Game Audio
Connect window is a drop zone for drag and drop, render, and export operations.
To open the Game Audio Connect window, select Project > Game Audio Connect.

1

Activate Game Audio Connect
Activates Game Audio Connect.

2

Open Game Audio Connect Settings
Allows you to open the Game Audio Connect Settings dialog.

3

Game Audio Engine
Displays the connected game audio engine.

4

Audio Asset
Displays the audio asset that is selected in the game audio engine.

5

Drop Zone
Drag audio assets in this area to export them to the game audio engine.

6

Connection Status
Displays the connection status of the version control system.

7

Version Control System
Displays the connected version control system.

498

Game Audio Connect
Game Audio Connect Settings Dialog

Game Audio Connect Settings Dialog
The Game Audio Connect Settings dialog allows you to connect your game audio engine to
Nuendo.
To open the Game Audio Connect Settings dialog, select Project > Game Audio Connect and
click the Settings button.

The following settings are available:
Enable Game Engine Network Connection
Allows your game audio engine to connect to Nuendo.
Local Game Audio Connect TCP Port
Sets the port for the game audio engine to connect to.
Metadata
Sets the type of metadata storage. Metadata is used to locate audio assets in
Nuendo projects. By default, metadata is embedded in the rendered audio file.
If the metadata is stored in a separate file, this file has the extension .amd.
Use Perforce
Activates the Perforce feature.
Perforce Server Address
Allows you to set the Perforce server address.
User Name
Allows you to enter your Perforce user name.
Password
Allows you to enter your Perforce password.
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Setting Up Game Audio Connect for Network
Communication
If Nuendo and your game audio engine run on different computers, you can use the Game
Engine Connection settings to establish a network connection. In such a network connection,
Nuendo serves as host.
PREREQUISITE
The network address in your game audio engine is set to the IP address of the computer that is
running Nuendo.
PROCEDURE
1.

In Nuendo, open the Game Audio Connect Settings dialog.

2.

In the Game Engine Connection section, activate the Enable Game Engine Network
Connection option.

3.

Specify the Local Game Audio Connect TCP Port.
The default port may be in use by another software on your system. In this case, specify
another port to establish a network connection.

RESULT
Nuendo and your game audio engine are connected.
RELATED LINKS
Game Audio Connect Settings Dialog on page 499

Perforce Integration
Game Audio Connect provides a Perforce integration that allows version control for Nuendo
projects.

Perforce Settings
The Perforce settings in the Game Audio Connect Settings dialog allow you to enable Perforce.
The following settings are available:
Use Perforce
Activates Perforce.
Server
Allows you to set the Perforce server address.
User
Allows you to enter your Perforce user name.
Password
Allows you to enter your Perforce password.
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Rename Audio Assets
You can rename audio events, audio parts, and MIDI parts that you recorded in Nuendo, so that
they match the names of a script list, for example. This is useful if you produce dialogue assets
for games.
To rename your assets, use the Rename Events from List dialog to load a script list in .csv
or .txt file format that allows you to match the dialog with the recorded events or parts. You
can also copy and paste content from a text editor directly to the Rename Events from List
dialog.
RELATED LINKS
Renaming Events from List on page 206

Export Audio Assets to a Game Audio Engine
In Nuendo, you can render and export audio assets to your game audio engine.
To render and export audio assets you have the following possibilities:
●

Drag audio events from the Project window and drop them in the drop zone of the Game
Audio Connect window.

●

Use the Export Selected Events dialog.

●

Use the Export Audio Mixdown dialog.
NOTE
If you export audio assets for use in your game audio engine, you must activate the Insert
iXML Chunk option.

RELATED LINKS
Game Audio Connect Window on page 498
Exporting Selected Events on page 218
File Format on page 1013

Exporting Audio Assets Using Drag and Drop
Using drag and drop is the quickest way to render and export audio material from Nuendo to
your game audio engine.
PROCEDURE
1.

Select a sound effect in your game audio engine.

2.

Drag the corresponding audio events from the Project window and drop them in the drop
zone of the Game Audio Connect window.

RESULT
The render operation is triggered for the dragged events. The rendered audio files are
automatically exported to the connected game audio engine.
RELATED LINKS
Render Selection on page 1004
Setting Up Game Audio Connect for Network Communication on page 500
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Exporting Music Segments Using Drag and Drop
The music that you use for video can consist of music segments that contain audio events, audio/
MIDI parts, or markers on several tracks. These can be controlled dynamically using the game
audio engine.
PREREQUISITE
You have composed several audio events, audio/MIDI parts, or markers for a music segment.
PROCEDURE
1.

In your game audio engine, select the music segment option.
In Wwise, for example, open the project explorer, and select the root node Interactive
Music Hierarchy.

2.

Select the audio events, audio/MIDI parts, and the position and cycle markers that make
up the music segment in the Project window.

3.

Drag the music segment to the drop zone of the Game Audio Connect window.

RESULT
The render operation is triggered for the dragged events using the current settings. The
rendered files are automatically transferred to the connected game audio engine. The tempo
and time signature are exported for the music segment.
AFTER COMPLETING THIS TASK
After exporting the music segments, an import dialog opens in Wwise that contains all tracks and
events of the music segment. The cycle marker start defines the pre-entry and post-exit range for
the segment, position markers are interpreted as cue markers.
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The Sample Editor provides an overview of the selected audio event. It allows you to view and
edit audio by cutting and pasting, removing, or drawing audio data, and by processing audio.
Editing is non-destructive so that you can undo modifications at any time.
You can open the Sample Editor in a separate window or in the lower zone of the Project
window. This is useful if you want to access the Sample Editor functions from within a fixed zone
of the Project window.
To open an audio event in the Sample Editor, do one of the following:
●

Double-click an event in the Project window.

●

Select an event in the Project window and press Return or Ctrl/Cmd-E.

●

Select an event in the Project window and select Audio > Open Sample Editor.

●

In the Key Commands dialog in the Editors category, assign a key command for Open
Sample Editor. Select an event in the Project window and use the key command.

NOTE
If you select Audio > Set up Editor Preferences, the Preferences dialog opens on the Editors
page. Make your settings to specify if you want the Sample Editor to open in a separate window
or in the lower zone of the Project window.
The Sample Editor window:

The Sample Editor in the lower zone of the Project window:
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The Sample Editor is divided into several sections:
1

Toolbar
Contains tools for selecting, manipulating, and playing back audio.

2

Info Line
Shows information about the audio.

3

Overview Line
Shows an overview of the whole audio clip and indicates which part of the clip is shown in
the waveform display.

4

Inspector
Contains audio editing tools and functions.
NOTE
The Editor Inspector for the lower zone editor is shown in the left zone of the Project
window.

5

Ruler
Shows the timeline and the display format of the project.

6

Waveform Display
Shows the waveform image of the edited audio clip.

7

Regions
Allows you to add and edit regions.

NOTE
The info line, the overview line, and the regions can be activated/deactivated by clicking Set up
Window Layout on the toolbar and activating/deactivating the corresponding options.
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RELATED LINKS
Opening the Editor in the Lower Zone on page 66
Opening the Editor Inspector on page 55
Toolbar on page 505
Info Line on page 509
Overview Line on page 509
Sample Editor Inspector on page 510
Ruler on page 513
Waveform Display on page 513
Regions List on page 519

Toolbar
The toolbar contains tools for selecting, editing, and playing back audio.
●

To show or hide the toolbar elements, right-click the toolbar and activate or deactivate the
elements.

The following options are available:

Static Buttons
Solo Editor
Solos the selected audio during playback.

Left Divider
Left Divider

Allows you to use the left divider. Tools that are placed to the left of the divider are
always shown.

View Options
Show Audio Event
Highlights the section corresponding to the edited event in the waveform display
and the overview line.
NOTE
This button is not available if you opened the audio event from the Pool. You can
adjust the start and end of the event in the clip by dragging the event handles in the
waveform display.
Show Regions
Opens a section where you can view and edit regions.
Edit Active Audio Event Only
Restricts editing operations to the active audio event.
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Toolbar
Show All Selected Audio Events
Shows the waveform images of multiple selected audio events at once.
Currently Edited Audio Event

Lists all audio events that are opened in the Sample Editor, and allows you to
activate an audio event for editing.

Auto-Scroll
Auto-Scroll
Keeps the project cursor visible during playback. The Switch Auto-Scroll Settings
pop-up menu allows you to activate Page Scroll or Stationary Cursor and to activate
Suspend Auto-Scroll When Editing.

Preview
Audition
Plays back the edited audio. Audition Loop loops the playback until you deactivate
the Audition icon. The Audition Volume slider allows you to adjust the volume.

Tool Buttons
Range Selection
Allows you to select ranges.
Zoom
Allows you to zoom in the waveform display. To zoom out, hold Alt while clicking.
Draw
Allows you to edit audio.
Play
Allows you to play back the clip from the position where you click until you release
the mouse button.
Scrub
Allows you to locate positions.
Time Warp
Allows you to drag a musical position to a certain position in time.
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Acoustic Feedback
Acoustic Pitch Feedback
Automatically plays back a VariAudio segment when you modify the pitch.

Snap
Snap to Zero Crossings
Restricts editing to zero crossings, that is, positions where the amplitude is zero.
Snap
Restricts horizontal movement and positioning to certain positions.

Musical Information
Musical Mode
Locks audio clips to the project tempo by using realtime time stretching.
Musical Information
Displays the estimated length of your audio file, the estimated tempo, the time
signature, and the warp algorithm. These values are important for using Musical
Mode.

VariAudio Segment Colors
VariAudio Segment Colors
Allows you to select a color scheme for VariAudio segments. This makes it easier to
see which segments belong to which event when working with several audio events.

Right Divider
Right Divider

Allows you to use the right divider. Tools that are placed to the right of the divider
are always shown.

Window Zone Controls
Open in Separate Window
This button is available in the lower zone editor. It opens the editor in a separate
window.
Open in Lower Zone
This button is available in the editor window. It opens the editor in the lower zone of
the Project window.
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Toolbar
Set up Window Layout
Allows you to activate/deactivate the info line, the overview line, and the regions.
Set up Toolbar
Opens a pop-up menu where you can set up which toolbar elements are visible.
RELATED LINKS
Auto-Scroll on page 243
Suspend Auto-Scroll When Editing on page 243

Locating Positions with the Scrub Tool
The Scrub tool allows you to locate positions in the audio.
PROCEDURE
1.

On the toolbar, activate the Scrub tool.

2.

Click in the waveform display and keep the mouse button pressed.
The project cursor moves to the position where you clicked.

3.

Drag to the left or right.

RESULT
The audio is played back, and you can hear at which position the cursor is located.
NOTE
You can determine the speed and pitch of the playback by dragging faster or slower.

Editing Audio Samples with the Draw Tool
You can edit the audio clip at sample level with the Draw tool. This way, you can remove audio
clicks manually, for example.
PROCEDURE
1.

On the audio waveform, locate the sample position that you want to edit and zoom in to
the lowest zoom level.

2.

Select the Draw tool.
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3.

Click at the beginning of the section that you want to correct and draw in the new curve.

RESULT
A range selection covering the edited section is automatically applied.

NOTE
The Draw tool cannot be used when the VariAudio section is open.

Info Line
The info line shows information about the audio clip, such as the audio format and the selection
range.

●

To show or hide the info line, click Set up Window Layout on the toolbar and activate or
deactivate the Info Line option.
The on/off status of the info line in the Sample Editor window and in the lower zone editor
are independent of each other.

NOTE
Initially, length and position values are displayed in the format specified in the Project Setup
dialog.

Overview Line
The overview line displays the whole clip, and indicates which part of the clip is shown in the
waveform display.

●

To show or hide the overview line, click Set up Window Layout on the toolbar and activate
or deactivate the Overview Line option.
The on/off status of the overview line in the Sample Editor window and in the lower zone
editor are independent of each other.
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1

Event Start
Shows the start of the audio event if Show Audio Event is activated on the toolbar.

2

Selection
Shows which section is selected in the waveform display.

3

Event End
Shows the end of the audio event if Show Audio Event is activated on the toolbar.

4

Waveform display
Shows the section of the audio that is displayed in the waveform display.

5

●

You can specify which section of the audio is shown by clicking in the lower half of
this display and dragging to the left or right.

●

You can zoom in or out horizontally by dragging the left or right edge of this display.

●

You can show a different section of the audio by clicking in the upper half of this
display and dragging a rectangle.

Snap Point
Shows the start of the audio event if Show Audio Event is activated on the toolbar.

Sample Editor Inspector
The Inspector shows controls and parameters that allow you to edit the audio event that is
opened in the Sample Editor.
●

In the Sample Editor window you can show or hide the Inspector by clicking Set up
Window Layout on the toolbar and activating or deactivating Inspector.
NOTE
In the lower zone editor, the Inspector is always shown in the left zone of the Project
window.

●

To open or close the Inspector sections, click their names.

RELATED LINKS
Opening the Editor Inspector on page 55

Definition
The Definition section allows you to adjust the audio grid and define the musical context of your
audio. You can use the available functions to match an audio file or audio loop to the project
tempo.
●

To open the Definition section, click its tab in the Inspector.
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AudioWarp
The AudioWarp section allows you to perform timing settings for your audio. This includes
applying Swing and manually changing the rhythm of the audio by dragging beats to time
positions on the grid.
●

To open the AudioWarp section, click its tab in the Inspector.

VariAudio
The VariAudio section allows you to edit single notes of your audio file and change their pitch or
timing. Furthermore, you can extract MIDI from your audio.
●

To open the VariAudio section, click its tab in the Inspector.

Hitpoints
The Hitpoints section allows you to edit hitpoints to slice your audio. Here you can create groove
quantize maps, markers, regions, events, and warp markers based on hitpoints.
●

To open the Hitpoints section, click its tab in the Inspector.
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Range
The Range section allows you to edit ranges and selections or create a sampler track from the
selected range.
●

To open the Range section, click its tab in the Inspector.

Select
Opens a menu with functions to select ranges.
Start
Shows the start position of the selection range.
End
Shows the end position of the selection range.
Length
Shows the length of the selection range.
Zoom
Opens a menu with the zoom functions for ranges.
Create Sampler Track
Allows you to create a sampler track from the range selection.

Process
The Process section regroups the most important audio editing commands from the Audio and
Edit menus.
●

To open the Process section, click its tab in the Inspector.
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Ruler
The ruler shows the timeline and display format of the project, the project tempo grid.
The ruler is located above the waveform display. It is always shown.

When the Definition section is open, an additional ruler is shown below the project tempo grid.
It displays the musical structure of the audio file, the audio tempo grid.

Waveform Display
The waveform display shows the waveform image of the edited audio clip.

1

Level Scale
Indicates the amplitude of the audio.

2

Level Scale options
Allow you to select whether the level is shown as percentage or in dB.
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3

Ruler
Shows the project tempo grid.

4

Audio waveform
Shows the waveform image of the selected audio.
NOTE
You can show the waveform images of multiple selected audio events at once by activating
Show All Selected Audio Events on the Sample Editor toolbar.

5

Half Level Axis
To show the half level axis, open the audio waveform context menu and select Show Half
Level Axis.

NOTE
You can set up a wave image style in the Preferences dialog (Event Display—Audio page).

Zooming in the Waveform
You can zoom in the waveform according to the standard zoom techniques.
The following applies:
●

The vertical zoom slider changes the vertical scale relative to the height of the Sample
Editor.

●

The vertical zoom is also affected if Zoom Tool Standard Mode: Horizontal Zooming only
is deactivated in the Preferences dialog (Editing—Tools page) and you drag a rectangle
with the Zoom tool.

●

You can zoom in by holding down Alt while drawing a selection rectangle around the
segments that you want to zoom in on. You can zoom out by holding down Alt and clicking
in an empty area of the waveform.

●

The current zoom setting is shown on the info line as samples per pixel.
NOTE
You can zoom in horizontally to a scale of less than one sample per pixel. This is required
for drawing with the Draw tool.

●

If you have zoomed in to one sample per pixel or less, the appearance of the samples
depends on the Interpolate Audio Waveforms option in the Preferences dialog (Event
Display—Audio page).

Zoom Submenu
The Zoom submenu of the Edit menu contains options for zooming in the Sample Editor.
●

To open the Zoom submenu, select Edit > Zoom.

The following options are available:
Zoom In
Zooms in one step, centering on the project cursor.
Zoom Out
Zooms out one step, centering on the project cursor.
Zoom Full
Zooms out so that the whole clip is visible in the waveform display.
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Zoom to Selection
Zooms in horizontally and vertically so that the current selection fills the waveform
display.
Zoom to Selection (Horiz.)
Zooms in horizontally so that the current selection fills the waveform display.
Zoom to Event
Zooms in so that the waveform display shows the section of the clip corresponding
to the edited audio event. This is not available if you have opened the Sample Editor
from the Pool.
Zoom In Vertically
Zooms in one step vertically.
Zoom Out Vertically
Zooms out one step vertically.
Undo/Redo Zoom
Allows you to undo/redo the last zoom operation.

Range Editing
In the Sample Editor you can edit selection ranges. This option is useful if you want to quickly
edit or process a specific section in the audio waveform, or if you want to create a new event or
clip.
You can only select one range at a time. The selection is indicated in the Selection field on the
Info Line.
The Range section in the Inspector contains functions for working with regions.
RELATED LINKS
Range on page 512
Shared Copies on page 215

Selecting a Range
PREREQUISITE
Snap to Zero Crossings is activated on the toolbar. This option ensures that the start and the
end of the selection are always at zero crossings.
PROCEDURE
1.

On the toolbar, activate the Range Selection tool.

2.

Click at the position in the waveform display where you want the range to start and drag to
the position, where you want the range to end.

3.

Optional: Perform one of the following actions to resize the selection range:
●

Drag the left or the right edge of the selection to a new position.

●

Hold down Shift and click at a new position.

RESULT
The selected range is highlighted in the waveform display.
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NOTE
You can also use the functions in the Select menu to select ranges.

RELATED LINKS
Select Menu on page 516

Select Menu
Select Menu in the Range Section
On the Select menu in the Range section in the Sample Editor Inspector, the following functions
are available:
Select All
Selects the whole clip.
Select None
Deselects everything.
Select in Loop
Selects the audio between the left and the right locator.
Select Event
Selects only the audio that is included in the edited event. If the VariAudio section is
open and you segmented the audio, all segments that start or end within the event
boundaries are selected.
Locators to Selection
Sets the locators to encompass the current selection. This option is available if you
have selected one or several events or made a selection range.
Locate Selection
Moves the project cursor to the beginning or end of the current selection. This
option is available if you have selected one or several events or made a selection
range.
Loop Selection
Activates playback from the start of the selection and keeps starting over again at
the selection end.

Select Menu on the Edit Menu
If you select Edit > Select, the following functions are available:
All
Selects the whole clip.
None
Deselects everything.
In Loop
Sets the audio between the left and the right locators.
From Start to Cursor
Selects the audio between the clips start and the project cursor.
From Cursor to End
Selects the audio between the project cursor and the end of the clip. This option is
available if the project cursor is positioned between the clip boundaries.
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Equal Pitch - all Octaves/same Octave
Selects all notes that have the same pitch as the selected note, in any octave or in the
current octave. This option is available if the VariAudio section is open and the Pitch
& Warp tool is activated.
Left Selection Side to Cursor
Moves the left side of the selection range to the project cursor position. This option is
available if the project cursor is positioned between the clip boundaries.
Right Selection Side to Cursor
Moves the right side of the selection range to the project cursor position or the end
of the clip if the project cursor is positioned to the right of the clip.

Creating Events from Selection Ranges
You can create a new event that contains only the selected range.
PROCEDURE
1.

Select a range.

2.

Drag the selection range to an audio track in the Project window.

RELATED LINKS
Selecting a Range on page 515

Creating Clips from Selection Ranges
You can create a new clip that contains only the selected range.
PROCEDURE
1.

Select a range.

2.

Right-click the selected range and select Audio > Bounce Selection.

3.

Perform one of the following actions:
●

Click Replace if you want to replace the original.

●

Click No if you want to keep the original.

RESULT
A new Sample Editor window opens with the new clip. It refers to the same audio file as the
original clip, but it contains the audio corresponding to the selection range only.

Creating Sampler Tracks from Selection Ranges
You can create a sampler track that contains only the selected range.
PROCEDURE
1.

Select a range.
If you select no range, the event Start/End is used.

2.

Open the Range inspector tab.

3.

Click Create Sampler Track

.
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RESULT
A new Sampler Track is created and added to the track list. The new sampler track contains your
range selection.

Edit Functions for Ranges
You can edit selection ranges.
●

To edit a selection range, open the Process section in the Sample Editor Inspector, and
select one of the Edit menu functions.

NOTE
If you edit ranges of events that are shared copies, you are asked whether you want to create a
new version of the clip. Select New Version if you want to edit the event, select Continue if all
shared copies should be edited.
The following options are available:
Cut
Cuts the selected range from the clip and saves it in the clipboard. The section to the
right of the range is moved to the left to fill the gap.
Copy
Copies the selected range to the clipboard.
Paste
Replaces the selected range with the data from the clipboard.
Delete
Removes the selected range from the clip. The section to the right of the range is
moved to the left to fill the gap.
Insert Silence
Inserts a silent section with the same length as the current range selection at the
selection start. The selected range is not replaced, but moved to the right.
Event or Range as Region
Creates a region from the selected range.
Make Direct Offline Processing Permanent
Allows you to apply all offline processing permanently to the audio.
RELATED LINKS
Shared Copies on page 215
Applying Offline Processing Permanently on page 477

Direct Offline Processing for Ranges
You can apply plug-in effects and audio processes to selection ranges.
●

To apply a plug-in effect or an audio process to a selection range, open the Process
section in the Sample Editor, and select one of the functions in the Add Plug-in menu or
in the Add Process menu.
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NOTE
If you apply offline processing to ranges of events that are shared copies, you are asked whether
you want to create a new version of the clip. Select New Version if you want to edit the event,
select Continue if all shared copies should be edited.

RELATED LINKS
Direct Offline Processing on page 467
Applying Processing on page 471
Shared Copies on page 215

Regions List
Regions are sections within an audio clip that allow you to mark important sections in the audio.
You can add and edit regions for the selected audio clip in the regions zone.
●

To show or hide the Regions, click Set up Window Layout on the toolbar and activate or
deactivate Regions.

The following controls are available:
1

Region Start/Region End
Shows the start and end of the region in the audio waveform.

2

Add Region
Allows you to create a region of the current range selection.

3

Remove Region
Allows you to remove the selected region.

4

Select Region
If you select a region in the list and click this button above, the corresponding section of
the audio clip is selected (as if you had selected it with the Range Selection tool) and
zoomed. This is useful if you want to apply processing to the region only.

5

Play Region
Plays back the selected region.

6

Regions list
Allows you to select and display regions in the audio waveform.

Creating Regions
PREREQUISITE
You have clicked Set up Window Layout on the toolbar and activated the Regions option.
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PROCEDURE
1.

On the Sample Editor toolbar, activate the Range Selection tool and in the waveform
display, select the range that you want to convert into a region.

2.

Perform one of the following actions:
●

Above the regions list, click Add Region.

●

Select Audio > Advanced > Event or Range as Region.

A region is created, corresponding to the selected range.
3.

Optional: Double-click the region name in the list and enter a new name.

RESULT
The region is added to the regions list.
AFTER COMPLETING THIS TASK
Click the region in the regions list to instantly display it in the Sample Editor.
RELATED LINKS
Creating Regions on page 529

Creating Regions from Hitpoints
You can create regions from hitpoints. This is useful to isolate specific sounds.
PREREQUISITE
The audio event from which you want to create regions is opened in the Sample Editor and the
hitpoints are set at the correct positions.
PROCEDURE
●

In the Hitpoints section, click Create Regions.

RESULT
Regions are created between two hitpoint positions and shown in the Sample Editor.

Adjusting Start and End Positions of Regions
PREREQUISITE
You have clicked Set up Window Layout on the toolbar and activated the Regions option. You
have created regions.
PROCEDURE
●

Perform one of the following actions:
●

Drag the Region Start or Region End handle in the waveform display.

●

Double-click the Start or End field in the regions list and enter a new value.

NOTE
The positions are shown in the display format selected for the ruler and info line, but are
relative to the start of the audio clip.
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Removing Regions
PREREQUISITE
You have clicked Set up Window Layout on the toolbar and activated the Regions option. You
have created regions.
PROCEDURE
1.

In the regions list, select the region that you want to remove.

2.

Above the regions list, click Remove Region.

RESULT
The region is removed from the regions list.

Creating Audio Events from Regions
You can create new audio events from regions using drag and drop.
PREREQUISITE
You have clicked Set up Window Layout on the toolbar and activated the Regions option. You
have created regions.
PROCEDURE
1.

Select the region in the regions list.

2.

Drag the region to the desired position in the Project window.

RESULT
An event is created from the region.

Snap Point
The snap point is a marker within an audio event that can be used as a reference position.
●

To show the snap point, activate Show Audio Event on the toolbar.

The snap point is set at the audio event start. But you can move it to another relevant position in
the audio.
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The snap point is used when Snap is activated on the Project window toolbar and you insert a
clip from the Sample Editor in the event display. It is also used when you move or copy events in
the event display.
In the Sample Editor, you can edit the following snap points:
●

Event Snap Point
This is shown in the Sample Editor if you open a clip from within the Project window.

●

Clip Snap point
This is shown in the Sample Editor if you open a clip from the Pool.

NOTE
The clip snap point serves as a template for the event snap point. However, it is the event snap
point that is taken into account when snapping.
IMPORTANT
When you set the grid start in the Definition section, the snap point is moved to the grid start.

Adjusting the Snap Point
PREREQUISITE
The audio event is opened in the Sample Editor and Show Audio Event is activated on the
toolbar.
PROCEDURE
1.

Optional: On the Sample Editor toolbar, select the Scrub tool.
This allows you to audition the audio while setting the snap point.

2.

Move the mouse pointer over the snap point, and drag it to the desired position in the
audio event.
The mouse pointer becomes a hand symbol and a tooltip indicates that you can set the
snap point.

RESULT
The event snap point is adjusted to the position where you dragged it.

NOTE
You can also adjust the snap point by setting the project cursor at the desired position and
selecting Audio > Snap Point To Cursor.
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Hitpoints mark musically relevant positions in audio files. Nuendo can detect these positions and
create hitpoints automatically by analyzing onsets and melodic changes of the audio.
NOTE
All hitpoint operations can be performed in the Sample Editor window and in the lower zone
editor.
When you add an audio file to your project by recording or by importing, Nuendo automatically
detects hitpoints. In the Project window, hitpoints are shown for the selected event, provided
that the zoom factor is high enough.
The hitpoint functions are available in the Hitpoints section of the Sample Editor.
You can use hitpoints for the following purposes:
●

Create slices of the audio
Slices allow you to change tempo and timing of the audio without affecting its pitch and
quality, or to replace or extract individual sounds from loops.

●

Quantize audio

●

Extract the groove from the audio
The timing is extracted from the audio and a groove map is created. You can use this
groove map to quantize other events.

●

Create markers from the audio

●

Create regions from the audio

●

Create events from the audio

●

Create warp markers from the audio

●

Create MIDI notes from the audio

NOTE
Hitpoints work best with drums, rhythmic recordings, or loops.

Calculating Hitpoints
When you add an audio file to your project by recording or by importing, Nuendo automatically
detects hitpoints.
PROCEDURE
1.

Import or record an audio file.
Nuendo automatically detects hitpoints.
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NOTE
If your audio file is very long, this may take a while.
2.

Select the audio event in the Project window and make sure the zoom factor is high
enough.

RESULT
The calculated hitpoints for the selected event are shown in the Project window.
NOTE
You can disable automatic hitpoint detection by deactivating Enable Automatic Hitpoint
Detection in the Preferences dialog (Editing—Audio page).

Hitpoint Filters
Nuendo automatically detects and filters hitpoints. However, you can filter hitpoints manually if
the result does not meet your expectations.
●

To filter hitpoints, open the audio event in the Sample Editor and open the Hitpoints
section.

Threshold
Filters hitpoints by their peaks. This option allows you to discard hitpoints of quieter
crosstalk signals, for example.
Minimum Length
Filters hitpoints by their distance between two hitpoints. This option allows you to
avoid creating slices that are too short.
Beats
Filters hitpoints by their musical position. This option allows you to discard hitpoints
that do not fit within a certain range of a defined beat value.

Editing Hitpoints Manually
It is absolutely crucial for any further editing that the hitpoints are set at the correct positions.
Therefore, if the automatic hitpoint detection does not meet your expectations, you can edit
hitpoints manually.
PREREQUISITE
The audio event is opened in the Sample Editor and in the Hitpoints section hitpoints are
filtered by their peaks, by their distance, or by their musical position.
PROCEDURE
1.

In the Hitpoints section, activate the Edit Hitpoints tool.
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2.

Move the mouse to the waveform display and click between two hitpoints.
The mouse pointer changes to a speaker icon and the tooltip Play back Slice is shown. The
slice is played back from the beginning to the end.

3.

To disable a hitpoint that you do not need, press Shift and click on the line that represents
the hitpoint.
The mouse pointer changes to a cross icon and the tooltip Disable Hitpoint is shown.
Disabled hitpoints are not taken into account for further operations.

4.

Press Tab to navigate to the next slice.

5.

To insert a hitpoint, press Alt and click at the position where you want to insert the
hitpoint.
The mouse pointer changes to a draw icon and the tooltip Insert Hitpoint is shown.

6.

To move a hitpoint, move the mouse pointer on the vertical line that represents the
hitpoint, and drag to the left or to the right.
The mouse pointer changes to a double arrow and the tooltip Move Hitpoint is shown.
Moved hitpoints are locked by default.

7.

To make sure that a hitpoint is not accidentally filtered out, lock it by pointing at it and
clicking.
The tooltip Lock Hitpoint is shown.

RESULT
The hitpoints are edited according to your settings.
NOTE
To reset a hitpoint to its original state, press Ctrl/Cmd-Alt until the tooltip Enable/Unlock
Hitpoints is shown and click.
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RELATED LINKS
Hitpoint Filters on page 524

Locating to Hitpoints in the Project Window
You can navigate through the hitpoints of an audio event in the Project window.
PREREQUISITE
Enable Automatic Hitpoint Detection is activated in the Preferences dialog (Editing—Audio
page).
PROCEDURE
1.

Select the audio track that contains the audio event for which you want to locate hitpoints.

2.

Perform one of the following actions:
●

Press Alt-N to navigate to the next hitpoint.

●

Press Alt-B to navigate to the previous hitpoint.

RESULT
The project cursor jumps to the respective hitpoint.

Slices
You can create slices from hitpoints, where each slice ideally represents an individual sound or
beat of the audio.
You can use these slices to change tempo and timing of the audio without affecting its pitch and
quality.
NOTE
Slices are created in the Sample Editor and edited in the Audio Part Editor.
Audio that meets the following characteristics is suitable:
●

Individual sounds have a noticeable attack.

●

The recording quality is good.

●

The recording is free of crosstalk signals.

●

The audio is free of smearing effects like delays, for example.

Slicing Audio
Slicing audio is useful if you want to change tempo and timing of the audio without affecting its
pitch and quality.
PREREQUISITE
The audio event is opened in the Sample Editor and the hitpoints are set at the correct positions.
NOTE
When slicing audio, all events referring to the edited clip are also replaced.

PROCEDURE
●

Perform one of the following actions:
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●

In the Hitpoints section, click Create Slices.

●

Select Audio > Hitpoints > Create Audio Slices from Hitpoints.

RESULT
The areas between the hitpoints are sliced and become separate events. The original audio event
is replaced by an audio part containing the slices.

On playback, the audio plays back seamlessly at the project tempo.
AFTER COMPLETING THIS TASK
Change the project tempo. The slices are moved accordingly, keeping their relative positions
within the part.
Double-click the sliced audio part and replace or extract individual slices in the Audio Part
Editor.
RELATED LINKS
Slices and the Project Tempo on page 527
Audio Part Editor on page 562

Slicing Multi-Track Drum Recordings
You can slice all tracks of a multi-track drum recording at once.
PREREQUISITE
You have created a multi-track drum recording and set up an edit group for all the tracks.
PROCEDURE
●

Select the folder track, and select Audio > Hitpoints > Divide Audio Events at Hitpoints.

RESULT
The audio of all tracks in the folder track is sliced.
RELATED LINKS
Quantizing Multiple Audio Tracks on page 290
Group Editing Mode on page 216

Slices and the Project Tempo
The project tempo affects how the sliced audio is played back.
NOTE
To ensure that the loop follows any further tempo changes, activate Musical Mode.

Project Tempo Is Slower Than the Original Audio
If the project tempo is slower than the tempo of the original audio event, there may be audible
gaps between the slice events in the part. If this is the case, you have the following options:
●

Select Audio > Advanced > Close Gaps (Timestretch).
This applies time stretch to each slice and closes the gaps. Consider activating auto fades
for the corresponding audio track. Fade-outs set to 10 ms help eliminate clicks.
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●

Select Audio > Advanced > Close Gaps (Crossfade).
This applies crossfades to the slices and closes the gaps.

NOTE
If you decide to change the tempo again, undo your actions and use the original, unstretched
file.

Project Tempo Is Higher Than the Original Audio
If the project tempo is higher than the tempo of the original audio event, the slice events in the
part may overlap.
If this is the case, right-click the track in the track list and from the context menu, select Auto
Fades Settings to smooth out the sound.
Furthermore, you can select the overlapping events in the part and select Audio > Advanced >
Delete Overlaps.
RELATED LINKS
Musical Mode on page 533
Making Global Auto Fade Settings on page 315
Making Auto Fade Settings for Individual Tracks on page 315

Creating a Groove Quantize Map
You can use hitpoints to create a groove quantize map.
PREREQUISITE
The audio event from which you want to extract the timing is opened in the Sample Editor, and
the hitpoints are set at the correct positions.
PROCEDURE
●

In the Hitpoints section, click Create Groove.

RESULT
The groove is extracted from the audio event and automatically selected in the Quantize Presets
pop-up menu on the Project window toolbar.
AFTER COMPLETING THIS TASK
Open the Quantize Panel and save the groove as a preset.

Creating Markers
You can create markers at hitpoint positions. This allows you to snap to hitpoint positions.
PREREQUISITE
The audio event from which you want to create markers is opened in the Sample Editor, and the
hitpoints are set at the correct positions.
PROCEDURE
●

In the Hitpoints section, click Create Markers.
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RESULT
If your project has no marker track, a marker track is added and activated automatically, and a
marker is created at every hitpoint position.
RELATED LINKS
Markers on page 334

Creating Regions
You can create regions at hitpoint positions. This allows you to isolate recorded sounds.
PREREQUISITE
The audio event from which you want to create regions is opened in the Sample Editor, and the
hitpoints are set at the correct positions.
PROCEDURE
●

In the Hitpoints section, click Create Regions.

RESULT
Regions are created between two hitpoint positions and shown in the Sample Editor.
RELATED LINKS
Creating Regions on page 519

Creating Events
You can create events at hitpoint positions.
PREREQUISITE
The audio event from which you want to create events is opened in the Sample Editor, and the
hitpoints are set at the correct positions.
PROCEDURE
●

In the Hitpoints section, click Create Events.

RESULT
Events are created between two hitpoint positions.

Creating Warp Markers
You can create warp markers at hitpoint positions. This allows you to quantize audio based on
hitpoint positions.
PREREQUISITE
The audio event from which you want to create warp markers is opened in the Sample Editor,
and the hitpoints are set at the correct positions.
PROCEDURE
●

In the Hitpoints section, click Create Warp Markers.
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RESULT
Warp markers are created at every hitpoint position.
AFTER COMPLETING THIS TASK
Open the AudioWarp section to show and edit the warp markers.
RELATED LINKS
Tempo Matching Audio on page 532

Creating MIDI Notes
You can export hitpoints to a MIDI part containing a MIDI note for each hitpoint. This allows you
to double, replace, or enrich drum hits by triggering sounds of a VST instrument.
PREREQUISITE
The audio event from which you want to create MIDI notes is opened in the Sample Editor, and
the hitpoints are set at the correct positions.
PROCEDURE
1.

In the Hitpoints section, click Create MIDI Notes.

2.

In the Convert Hitpoints to MIDI Notes dialog, set up the parameters.

3.

Click OK.

RESULT
A MIDI track is added to your project, and MIDI notes are created at every hitpoint position.
AFTER COMPLETING THIS TASK
Assign a VST instrument to the MIDI track, and select a sound to enrich the audio.

Convert Hitpoints to MIDI Notes
When exporting hitpoints to MIDI notes, you can specify, how the hitpoints are converted.

The following options are available:
Velocity Mode
Allows you to select a velocity mode:
●

If you want the velocity values of the created MIDI notes to vary according to
the peak levels of the corresponding hitpoints, select Dynamic Velocity Value.

●

If you want to assign the same velocity value to all created MIDI notes, select
Fixed Velocity Value.

Velocity
Sets the Fixed Velocity Value.
Pitch
Sets a note pitch for all created MIDI notes.
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Length
Sets a note length for all created MIDI notes.
Destination
Allows you to select a destination:
●

To place the MIDI part on the first selected MIDI or instrument track, select
First Selected Track.
NOTE
Any MIDI parts from previous conversions on this track will be deleted.

●

To create a new MIDI track for the MIDI part, select New MIDI Track.

●

To copy the MIDI part to the clipboard, select Project Clipboard.
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You can tempo match audio to adapt its tempo to the project tempo, for example.
NOTE
All tempo matching operations can be performed in the Sample Editor window and in the lower
zone editor.
The following functions are described:
●

Stretch to Project Tempo
Stretches the selected event to match the project tempo.

●

Musical Mode
Applies realtime time stretching to audio clips, so that they match the project tempo.

●

Auto Adjust
Extracts a definition grid from your audio. After that, you can match the audio with the
project tempo by using Musical Mode.

●

Manual Adjust
Allows you to manually modify the grid and tempo of your audio file. After that, you can
match the audio with the project tempo by using Musical Mode.

●

Free Warp
Allows you to change the timing of individual positions in your audio.

●

Audio Alignment
Allows you to automatically match the timing of audio events on different tracks that you
want to play back simultaneously.

Algorithm Presets
You can select an algorithm preset that is applied for realtime playback and time stretching.
The Algorithm pop-up menu on the Sample Editor toolbar contains various presets that
determine the audio quality of the realtime time stretching.
These presets are sorted into the categories élastique and Standard according to the
technology used.
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The algorithm preset affects warp changes in Musical Mode, FreeWarp, Swing, and Audio
Alignment. For the VariAudio warping and pitching features Standard – Solo is applied
automatically.
RELATED LINKS
Time Stretch and Pitch Shift Algorithms on page 488
Audio Alignment on page 539

Stretching Audio Events to the Project Tempo
You can stretch audio loops to the project tempo.
PROCEDURE
1.

Select File > Import > Audio File, select the audio loop that you want to import, and click
OK.

2.

Select the audio loop in the project.

3.

Select Audio > Advanced > Stretch to Project Tempo.

RESULT
The audio loop is stretched to match the project tempo.

Musical Mode
The Musical Mode allows you to tempo-match audio loops to the project tempo.
If you activate Musical Mode for an audio clip, realtime time stretching is applied to the clip so
that it matches the project tempo. The audio events adapt to any tempo changes in Nuendo, just
like MIDI events.
In the Sample Editor, you can activate Musical Mode
Definition section, and the toolbar.

in the AudioWarp section, the

NOTE
●

You can also activate/deactivate Musical Mode from within the Pool by clicking the
corresponding checkbox in the Musical Mode column.

●

Nuendo supports ACID® loops. These loops are standard audio files but with embedded
tempo/length information. When ACID® files are imported into Nuendo, Musical Mode is
automatically activated and the loops will adapt to the project tempo.

Matching Audio to the Project Tempo
You can use Musical Mode to adjust audio loops. Loops are short audio files containing a
defined number of bars with straight beats, to the project tempo.
PROCEDURE
1.

Select File > Import > Audio File, and select an audio loop in the file dialog.

2.

In the Project window, double-click the imported audio loop to open it in the Sample
Editor.

3.

Open the Definition section and verify the rulers.
The project tempo grid shown in the upper ruler and the grid of your audio shown in the
lower ruler do not match.
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4.

On the toolbar, verify that the length in bars corresponds to the length of the imported
audio file. If necessary, listen to your audio and enter the correct length in bars and beats.

5.

On the toolbar, open the Algorithm pop-up menu, and select a preset.

6.

Listen to the loop and if necessary correct the Bars and Beats values on the toolbar.

7.

Activate Musical Mode.

RESULT
The loop is warped and stretched to the project tempo. The rulers reflect the change.
In the Project window, the audio event shows a note symbol and a warp symbol. This indicates
that time stretching has been applied.

Applying Swing
The Swing function allows you to add swing to audio that sounds too straight.
PREREQUISITE
You have opened your audio in the Sample Editor and Musical Mode is activated.
PROCEDURE
1.

On the toolbar, open the Algorithm pop-up menu, and select a preset.

2.

Open the AudioWarp section, and from the Resolution pop-up menu select a grid
resolution.
This defines the positions that the swing is applied to. If you select 1/2, the swing is
applied in steps of half notes, for example.

3.

Move the Swing fader to the right.

RESULT
This offsets the grid positions and creates a swing or shuffle feel. If you selected 1/2, every
second position in the grid is offset.
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Auto Adjust
The Auto Adjust function is useful if you do not know the tempo of your audio file, or if its beat is
not straight. It allows you to extract a definition grid from your audio before tempo matching it
to the project tempo with the Musical Mode.
The Auto Adjust function extracts a local definition grid that you can match with the project
tempo using Musical Mode.
RELATED LINKS
Musical Mode on page 533

Extracting a Tempo Definition Grid from Audio
If you want to match audio with an unknown tempo or a beat that is not straight to the project
tempo, you need to extract its tempo definition grid first. This is done with the Auto Adjust
function in the Definition section of the Sample Editor.
PREREQUISITE
You have defined a range in your audio clip or event that starts and ends at a barline.
PROCEDURE
1.

Double-click the audio clip or event in the Project window to open it in the Sample Editor.

2.

Open the Definition section, and select a value from the Grid pop-up menu.
This determines the grid resolution for your audio.

3.

With the Range Selection tool, select the section that you want to use in your project, and
that covers one or several bars.
NOTE
If you do not select a range, the grid is calculated for the audio event. If no audio event is
defined, the grid is calculated for the clip. Make sure that the event or clip starts and ends
on a barline.

4.

Click Auto Adjust.

RESULT
The definition grid is calculated for the selected section. The snap point moves to the start of the
selected range. The audio tempo definition ruler changes to reflect your edits, and bars and
beats positions are marked with vertical lines.

Manual Adjust
The Manual Adjust function is useful if you need to manually modify the grid and tempo of your
audio file. This is the case if the extraction of a definition grid with the Auto Adjust function did
not bring satisfying results, for example.
The Manual Adjust function allows you to correct the local definition grid. After this, you can
match it with the project tempo using Musical Mode.
RELATED LINKS
Musical Mode on page 533
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Correcting the Audio Definition Grid
If the extraction of a definition grid with the Auto Adjust function did not bring satisfying results,
you can correct the grid and tempo of your audio file with the Manual Adjust function.
PROCEDURE
1.

Double-click the audio clip or event in the Project window to open it in the Sample Editor.

2.

Open the Definition section, and activate Manual Adjust.

3.

Move the mouse pointer to the beginning of the audio clip.
The tooltip Set Grid Start is shown, and the mouse pointer turns into a double arrow.

4.

Click and drag to the right until the first downbeat and release the mouse button.
This matches the grid start and the snap point with the first main beat. The audio tempo
definition ruler changes to reflect your edits.

5.

In the upper part of the waveform, move the mouse pointer to the vertical line nearest to
the second bar.
The tooltip Stretch Grid and a blue vertical line are shown.

6.

Click and drag to the position of the first downbeat in the second bar and release the
mouse button.
This sets the beginning of the next bar. All following bar positions in the grid are stretched
or compressed so that all bars have the same length.

7.

In the lower part of the waveform, move the mouse pointer over the grid lines.
The tooltip Set Bar Position (Move Following Bars) and a green vertical line are shown.

8.

For incorrect bar positions, click and drag the green vertical line to the position of the first
downbeat of the following bar and release the mouse button.
This also moves the bars to the right. The area to the left remains unaffected.

9.

Move the mouse pointer over the grid lines for single beats.
The tooltip Set Beat Position and a blue vertical line are shown.

10.

Click and drag the grid line to align single, incorrect beat positions and release the mouse
button.
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NOTE
You can remove misplaced beat edits by pressing any modifier key and clicking with the
Erase tool.

RESULT
The definition grid is corrected, the audio tempo definition ruler reflects your edits.
AFTER COMPLETING THIS TASK
Activate Musical Mode.

Free Warp
The Free Warp tool allows you to correct the timing of individual positions in the audio material.
This is useful if you want to synchronize audio to video.
You can create and edit warp markers and drag them to musically relevant time positions in an
audio event. This way, the audio before and after the warp marker is stretched. The amount of
stretch is shown next to the warp marker handle.

A stretch factor higher than 1.0 indicates that the audio preceding the warp marker is stretched,
a stretch factor lower than 1.0 indicates that the audio is compressed.
NOTE
The Free Warp tool snaps to hitpoint positions and warp markers.
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Correcting the Timing with the Free Warp Tool
PROCEDURE
1.

Double-click the audio clip or event in the Project window to open it in the Sample Editor.

2.

On the toolbar, activate Snap to Zero Crossing.
If this button is activated, warp markers snap to zero crossings.

3.

Optional: If you want to correct the timing of individual positions in the audio, define the
local definition with the Auto Adjust or the Manual Adjust function, and activate Musical
Mode.

4.

On the Transport panel, activate Click, and play back the audio to determine positions
where the beat is not on time with the click.

5.

In the AudioWarp section, activate Free Warp, place the mouse pointer at the position of
the beat that you want to adjust, click, and hold.
The mouse pointer changes to a clock with arrows, and a warp marker is inserted.

6.

Drag the warp marker to the new position, and release the mouse button.

RESULT
The beat is now aligned with the corresponding position in the project.
RELATED LINKS
Auto Adjust on page 535
Manual Adjust on page 535
Musical Mode on page 533

Correcting Warp Marker Positions
PROCEDURE
1.

In the AudioWarp section, activate Free Warp.

2.

In the Sample Editor, click the warp marker handle and drag it to a new position.

A tooltip is shown to indicate that you can drag to correct the warp marker position.
RESULT
The warp marker moves to the new position and the audio is stretched or compressed
accordingly.

Deleting Warp Markers
PROCEDURE
1.

In the AudioWarp section, activate Free Warp.

2.

Hold down Alt and click the warp marker you want to delete.
NOTE
To delete several markers, draw a selection rectangle.
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RESULT
The warp marker is removed from the waveform.

Resetting Warp Markers
PROCEDURE
●

In the AudioWarp section, click Reset Warp Changes.

RESULT
The warp markers are removed from the waveform, and the warp edits of the waveform are
reset.
NOTE
If Musical Mode is activated, only Free Warp edits are reset.

Audio Alignment
The Audio Alignment tool allows you to automatically match the timing of audio events that you
want to play back simultaneously.
You can match the timing of a voice recording take or an alternative take to the production
sound, for example. You can also solve phasing problems that occur when using different
microphones on the same take. In music production contexts, the Audio Alignment tool allows
you to match the timing of different instrument or vocal tracks.
The Audio Alignment tool analyzes the audio that you want to align and either shifts the audio
or uses the warping function of the Sample Editor for time stretching.
NOTE
●

If the events result from the same recording, for example, in case of a multiple
microphone recording, only time shifting is used for the alignment.

●

If time stretching is necessary, Audio Alignment uses the warping algorithm that is
selected in the Sample Editor.

Audio Alignment features the following analyzing modes that use different algorithms:
●

Standard mode can be used for all kinds of sound or music.

●

Voice mode is optimized for detecting and aligning speech or vocals.
NOTE
This mode only works if the words on the aligned tracks are identical.

RELATED LINKS
Algorithm Presets on page 532
Aligning the Audio of Events on page 540
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Aligning the Audio of Events
You can automatically align the audio of different audio events.
PREREQUISITE
Your project contains two or more audio events, located on different tracks and overlapping in
time. The audio that you want to align with the reference is not modified by VariAudio or
AudioWarp operations.
PROCEDURE
1.

Select the event that you want to use as alignment reference.

2.

On the Project window toolbar, click Enable Audio Alignment.
The Audio Alignment tool shows the file name of the reference event.
NOTE
Alternatively, you can set an event as reference for alignment by selecting Audio > Set
Event as Alignment Reference, or by using a key command.

3.

Optional: Click Alignment Mode and from the pop-up menu select Standard or Voice.

4.

Select one or multiple events that you want to align with the reference.
NOTE
To select multiple events, you must draw a selection rectangle.
The target events are processed.

RESULT
The audio of the target events is aligned with the reference event within the time range where
the events overlap.
To visualize the result of the aligning in the Sample Editor, select reference and target events
and activate Show All Selected Audio Events in the Sample Editor toolbar.
AFTER COMPLETING THIS TASK
If the result of the time stretching does not meet your expectations, you can change the warping
algorithm on the Sample Editor toolbar. This algorithm change is instantly applied to the audio.
Alternatively, you can use the Free Warp tool to align the audio events.
RELATED LINKS
Toolbar on page 505
Algorithm Presets on page 532
Time Stretch and Pitch Shift Algorithms on page 488
Free Warp on page 537
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Flattening Realtime Processing
You can flatten warp modifications. This is useful if you want to reduce the CPU load, optimize
the sound quality of the processing, or apply any offline processing.
PROCEDURE
1.

Select the audio events that you want to process.

2.

Perform one of the following actions:
●

Select Audio > Realtime Processing > Flatten Realtime Processing.

●

In the Process section of the Sample Editor, click Flatten.

In the dialog that opens, you can select an algorithm preset. If the time stretching factor is
not outside the range of 0.5 and 2, you can choose between Realtime and MPEX.
3.

Select an algorithm preset and click OK.

RESULT
Any loop that was previously stretched in realtime plays back exactly the same, but the warp
markers discarded.
RELATED LINKS
MPEX on page 489

Unstretching Audio Files
PREREQUISITE
You have stretched an audio event in the Sample Editor with the Free Warp tool, or in the
Project window with the Object Selection tool in Sizing Applies Timestretch mode.
PROCEDURE
1.

Select the audio event that you want to unstretch.

2.

Select Audio > Realtime Processing > Unstretch Audio.

RESULT
All realtime time stretching is removed.
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The VariAudio features in Nuendo allow you to edit pitch, correct timing and intonation of
individual notes in monophonic vocal recordings. Any modifications to the audio material can be
undone.
NOTE
All VariAudio operations can be performed in the Sample Editor window and in the lower zone
editor.
NOTE
The VariAudio features are optimized for monophonic recordings of vocals. Other monophonic
recordings, such as saxophone, may work well. However, the quality of the result depends
greatly on the recording.
Before you can edit the pitch and correct the timing of monophonic recordings, Nuendo must
analyze the audio and split it into segments. These segments are graphic representations of the
notes sung.
As the quality of the segmentation is crucial for any further editing, we recommend you to verify
the automatic segmentation and to edit it if necessary.
NOTE
●

Due to the data gained during segmentation, the audio and thus the size of your project
can increase.

●

If you load projects with VariAudio files in Cubase Artist, VariAudio modifications are
ignored. If you want to hear your modifications in Cubase Artist, you will have to bounce
the audio files that have been edited with the Nuendo VariAudio features.

RELATED LINKS
Segmenting Monophonic Audio on page 543
Manual Editing of Segments on page 544
Segments and Gaps on page 544

VariAudio and Offline Processes
If you apply offline processes and edits that affect the length on audio files that contain
VariAudio data, existing VariAudio data becomes invalid. We therefore recommend to apply
offline processing or edits before using the VariAudio features.
The following processes and edits may lead to the reanalysis of the audio material:
●

All offline processes in the Process submenu of the Audio menu, except Envelope, Fade
In Fade Out, Normalize, and Silence.

●

Effect processes in the submenu Audio > Plug-ins.
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●

Cutting, pasting, deleting or drawing in the Sample Editor.

Segmenting Monophonic Audio
To be able to edit the pitch and correct the timing of monophonic recordings, Nuendo must
analyze the audio and split it into segments.
PROCEDURE
1.

In the Project window, double-click the monophonic vocal recording to open the Sample
Editor.

2.

In the Sample Editor Inspector, click VariAudio to open the VariAudio section.
A waveform image of the audio is shown.

3.

Activate the Segments tool.

RESULT
Nuendo automatically analyzes the audio and splits it into segments that are shown in the
waveform image. The segmentation allows you to associate the audio with the sung notes.

NOTE
The analysis of long audio files may take some time.
AFTER COMPLETING THIS TASK
Verify the automatic segmentation and edit it manually.
RELATED LINKS
Segments and Gaps on page 544
Manual Editing of Segments on page 544
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Segments and Gaps
Nuendo automatically analyzes the audio and splits it into segments that are shown in the
waveform image.

To understand and edit the segmentation, the following concepts are crucial:
1

Pitch Position
The pitch position of the segments is indicated by the piano keyboard to the left of the
waveform. Pitches represent the perceived fundamental frequency of the sound. The
average pitch of a segment is calculated from its micro-pitch curve.

2

Time Position
The time position and the length of the segments are indicated by the timeline.

3

Audio Waveform
The audio waveform is always shown as mono, even if you have opened a stereo or multichannel file.

4

Segment
The segments represent the tonal portions of the analyzed audio. The pitch and time
position of the segments allow you to associate the segments to the original audio.

5

Gap
The gaps in between segments represent the non-tonal portions of the analyzed audio.
These can be caused by breath sounds or rests, for example.
NOTE
Gaps, caused by weak audio signals or audio sections with unclear pitch information, such
as consonants or effect sounds, must be included in the segments manually. Otherwise,
later pitch modifications affect only the tonal portions.

6

Micro-Pitch Curves
The micro-pitch curves that are shown in the segments represent the progression of the
pitch.

Manual Editing of Segments
As the quality of the segmentation is crucial for any further editing, we recommend you to verify
the automatic segmentation and to edit it if necessary.
Verify the start and end positions of the segments and try to match them with the waveform
envelope for each word. You have the following possibilities to edit segments:
●

Changing the start and end points of segments by resizing segments.

●

Changing the length of segments by cutting or glueing segments.
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●

Moving segments on the timeline by dragging them to the left or right.

●

Deleting segments.

Navigating and Zooming
You can navigate through the segments and zoom in on them. This makes manual editing more
comfortable.
●

To navigate through the segments, use the Left Arrow key or the Right Arrow key on
your computer keyboard.

●

To zoom in on segments, hold down Alt and draw a selection rectangle.

●

To zoom out, hold down Alt and click in an empty area of the waveform.

●

To zoom out to show all segments, hold down Alt and double-click in an empty area of the
waveform.

Auditioning Segments
You can audition the segments one by one, loop them, or play them back from the beginning to
the end. This makes segmentation as well as pitch and warp editing more comfortable.
To audition segments use one of the following methods:
●

To play back selected segments, select the segments and activate Audition.

●

To play back selected segments in a loop, select the segments, activate Audition Loop,
and activate Audition.

●

To play back segments at a specific position, activate the Play tool, click at the position.

●

To audition pitch modifications while editing, activate Acoustic Pitch Feedback.

●

To compare your pitch changes to the original audio pitches, activate Disable Pitch
Changes in the VariAudio section.

●

To compare your warp changes to the original timing of the audio, activate Disable Warp
Changes in the AudioWarp section.
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Changing the Start and End Point of Segments
If the start and end points of the segments do not match with the waveform envelope, you can
change them.
PREREQUISITE
You have opened the audio in the Sample Editor and activated the Segments tool in the
VariAudio section.
PROCEDURE
1.

Compare the start and end positions of the segments with the waveform envelope for
each note.

2.

Optional: Select one or several segments and on the Sample Editor toolbar, activate
Audition to audition the segments.

3.

Perform one of the following actions:
●

If a segment starts too early, move the mouse pointer over the start of the segment,
click and drag to the right.

●

If a segment ends too late, move the mouse pointer over the end of the segment,
click and drag to the left.

NOTE
You can only drag the segment start or end until the boundaries of the next segment.
Segments cannot overlap.

RESULT
The start and end positions of the segments are changed according to your edits. The average
pitch of the segment is recalculated.
NOTE
Changing the length of a segment may lead to a different average pitch and therefore to a pitch
change. If the non-tonal portions of the audio increase, the segment may be deleted.

RELATED LINKS
Segmenting Monophonic Audio on page 543

Changing the Length of Segments
If a segment includes more than a note, or if a single note is spread over multiple segments, you
can change them.
PREREQUISITE
You have opened the audio in the Sample Editor and activated the Segments tool in the
VariAudio section.
PROCEDURE
1.

Compare the segments with the waveform envelope for each note.
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2.

Optional: Select one or several segments and on the Sample Editor toolbar, activate the
Audition to audition the segments.

3.

Perform one of the following actions:
●

If a segment includes more than a note, move the mouse pointer over the lower
border of the segment and click to cut the segment.

●

If a single note is spread over several segments, hold down Alt and move the mouse
pointer over the segment, and click to glue the segment to the next segment.

NOTE
If the segment is already very short, it cannot be cut.

RESULT
The segments are changed according to your edits. The average pitch of the segment is
recalculated.
NOTE
Changing the length of a segment may lead to a different average pitch and therefore to a pitch
change. If the non-tonal portions of the audio increase, the segment may be deleted.
AFTER COMPLETING THIS TASK
If a note is at the wrong position after cutting the segment, move it horizontally.
RELATED LINKS
Segmenting Monophonic Audio on page 543
Moving Segments on the Timeline on page 547

Moving Segments on the Timeline
If a note is at the wrong position after cutting the segment, you can move it horizontally.
PREREQUISITE
You have opened the audio in the Sample Editor and activated the Segments tool in the
VariAudio section.
PROCEDURE
1.

Compare the segments with the waveform envelope for each note.

2.

Optional: Select one or several segments and on the Sample Editor toolbar, activate the
Audition to audition the segments.

3.

Move the mouse pointer over the upper border of the segment, click and drag to the left
or to the right.

547

VariAudio
Manual Editing of Segments
NOTE
You can only move the segment until the boundaries of the next segment. Segments
cannot overlap.

RESULT
The segment is moved. The average pitch of the segment is recalculated.
NOTE
Changing the length of a segment may lead to different average pitch and therefore to a pitch
change. If the non-tonal portions of the audio increase, the segment may be deleted.

RELATED LINKS
Segmenting Monophonic Audio on page 543

Deleting Segments
Sometimes it might be useful to delete segments, for example for non-tonal portions of the
audio.
PREREQUISITE
You have opened the audio in the Sample Editor and activated the Segments tool in the
VariAudio section.
PROCEDURE
1.

Compare the segments with the waveform envelope for each note.

2.

Optional: Select one or several segments and on the Sample Editor toolbar, activate the
Audition to audition the segments.

3.

Select the segment that you want to delete, and press Backspace.

RESULT
The segment is deleted.
RELATED LINKS
Segmenting Monophonic Audio on page 543

Muting Segments
You can mute individual segments.
PREREQUISITE
You have opened the audio in the Sample Editor and activated the Pitch & Warp tool in the
VariAudio section.
PROCEDURE
1.

Move the mouse pointer over the lower border of a segment.
An x symbol is shown in the segment.
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2.

Click the x symbol.

RESULT
The segment is grayed out to indicate that it is muted.
AFTER COMPLETING THIS TASK
You can unmute the segment by clicking the x symbol again.

Segment Colors
You can select a color scheme for VariAudio segments. If you work with several audio events, this
makes it easier to see which segments belong to which event.

The following options are available:
Auto
Segments that belong to the same audio event get the same color.
Event
Segments get the same color as the corresponding event in the Project window.
Pitch
Segments get colors depending on their pitches.
Chord Track
Segments that match the corresponding chord or scale events on the chord track get
a specific color.

Pitch Changes
The VariAudio features allow you to change the pitch of audio segments for corrective purposes
but also creatively. By changing note pitches you can change the melody of the original audio
with or without preserving a natural sound.
Pitch changes include the following:
●

Raising or lowering pitches.

●

Quantizing pitches.
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●

Changing the micro-pitch curve.

●

Straightening pitches.

Pitch Snapping
There are 3 different modes that affect the way in which a note will snap to a certain pitch.
●

Absolute Pitch Snapping
To snap the segment to the next semitone, hold down Ctrl/Cmd.

●

Relative Pitch Snapping
To snap the segment and keep its current deviation in cents, just drag.

●

No Pitch Snapping
To edit the pitch freely, hold down Shift.

NOTE
You can change the modifier in the Preferences dialog (Editing—Tool Modifier page).

Raising or Lowering Pitches
PREREQUISITE
The audio file is segmented and the segments are correct. You have opened the audio in the
Sample Editor and activated the Pitch & Warp tool in the VariAudio section.
PROCEDURE
1.

Select one or several segments, and move the mouse pointer over it.
The mouse pointer becomes a hand symbol.

2.

Perform one of the following actions to raise or lower the pitch:
●

Drag the segment up or down and release the mouse.

●

Use the Up Arrow/Down Arrow to change the pitch in semitone steps.

●

Hold down Shift and use Up Arrow/Down Arrow to change the pitch in cent steps.

NOTE
The more the pitch deviates from the original pitch, the less likely it is that your audio
sounds natural. You cannot choose note pitches above C5 and below E0.

RESULT
The Solo algorithm is selected automatically and the segment pitch is raised or lowered
according to your settings.

Changing Pitches by MIDI Input
You can change segment pitches by pressing a key on your MIDI keyboard or by using the OnScreen Keyboard.
PREREQUISITE
The audio file is segmented and the segments are correct. You have opened the audio in the
Sample Editor and activated the Pitch & Warp tool in the VariAudio section. You have
connected and set up a MIDI keyboard.
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PROCEDURE
1.

Select one or several segments.

2.

In the VariAudio section, activate MIDI Input.

3.

Perform one of the following actions to change the pitch:
●

Press a key on your MIDI keyboard.

●

Use the On-Screen Keyboard to change the pitch.

NOTE
The more the pitch deviates from the original pitch, the less likely it is that your audio
sounds natural. You cannot choose note pitches above C5 and below E0.

RESULT
The Solo algorithm is selected automatically, and the segment pitch is raised or lowered
according to the note you play. If you select several segments, the pitch of the first selected
segment is changed to the pitch of the MIDI note you play and the pitches of the other segments
are changed by the same amount.
NOTE
The MIDI Input only affects the pitches of the segments. MIDI controller data are ignored.
AFTER COMPLETING THIS TASK
Deactivate MIDI Input.
RELATED LINKS
On-Screen Keyboard on page 257

MIDI Input Modes
The MIDI Input function allows you to assign MIDI notes in Still mode or in Step mode.
●

To switch between Still mode and Step mode, Alt-click MIDI Input.

Still mode
Use this mode if you want to change the pitches of individual segments or selections.
Step mode
Use this mode if you want to step through the segments while changing their
pitches. This allows you to work in a more creative way, for example, to develop
completely new melody lines via MIDI.
After you have assigned a MIDI note to a segment, the next segment is automatically
selected.
RELATED LINKS
Step Input on page 822
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Quantizing Pitches
You can quantize the audio pitch to the nearest semitone position.
PREREQUISITE
The audio file is segmented and the segments are correct. You have opened the audio in the
Sample Editor and activated the Pitch & Warp tool in the VariAudio section.
PROCEDURE
1.

Select one or several segments.

2.

In the VariAudio section, move the Quantize Pitch slider to the right.

RESULT
The Solo algorithm is selected automatically, and the segment pitch is quantized iteratively.
NOTE
In the Sample Editor category of the Key Commands dialog, you can set up a key command for
Quantize Pitch. If you use the key command, the segments are immediately quantized to the
next semitone position.

RELATED LINKS
Key Commands on page 1137

Micro-Pitch Changes
Sometimes changing the pitch of the whole note segment is not enough. In these cases, you can
modify the micro-pitch curves inside the segments.
IMPORTANT
The micro-pitch curve displays the progression of the pitch for the tonal portion of the audio
segment. For non-tonal portions of the audio, micro-pitch curves cannot be shown.
You have the following options to change the micro-pitch curve:
●

Tilting an entire micro-pitch curve.

●

Tilting a micro-pitch curve from a segment border to an anchor.
This is useful if you want to adjust only the start or the end of a segment.

Tilting an Entire Micro-Pitch Curve
PREREQUISITE
The audio file is segmented and the segments are correct. You have opened the audio in the
Sample Editor and activated the Pitch & Warp tool in the VariAudio section.
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PROCEDURE
1.

Move the mouse pointer over the upper left or right border of the segment.
The mouse pointer becomes an up/down arrow.

2.

To tilt the micro-pitch curve, drag the curve up or down, and release the mouse.

RESULT
The Solo algorithm is selected automatically, and the micro-pitch curve is tilted according to your
settings.

Tilting a Micro-Pitch Curve from a Segment Border to an Anchor
You can set an anchor point to specify which part of the segment is affected when tilting a micropitch curve.
PREREQUISITE
The audio file is segmented and the segments are correct. You have opened the audio in the
Sample Editor and activated the Pitch & Warp tool in the VariAudio section.
PROCEDURE
1.

Move the mouse pointer over the upper border of the segment.
The mouse pointer becomes an I-beam symbol.

2.

Click at the position where you want to set an anchor point.
A vertical line appears at the position where you clicked.

3.

Move the mouse pointer over the upper left or right border of the segment.
The mouse pointer becomes an up/down arrow.

4.

To tilt the micro-pitch curve, drag the curve up or down, and release the mouse.

RESULT
The Solo algorithm is selected automatically, and the micro-pitch curve is tilted from the segment
border to the anchor.
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RELATED LINKS
Removing Anchors on page 554
Rotating a Micro-Pitch Curve around an Anchor on page 554

Removing Anchors
PROCEDURE
1.

Hold down Alt and move the mouse pointer over the position of the anchor at the upper
border of the segment.
The mouse pointer becomes a glue tube.

2.

Click at the position of the anchor point.

RESULT
The tilt anchor is removed.

Rotating a Micro-Pitch Curve around an Anchor
PREREQUISITE
The audio file is segmented and the segments are correct. You have opened the audio in the
Sample Editor and activated the Pitch & Warp tool in the VariAudio section.
PROCEDURE
1.

Move the mouse pointer over the upper border of the segment.
The mouse pointer becomes an I-beam symbol.

2.

Click at the position where you want to set an anchor point.
A vertical line appears at the position where you clicked.

3.

Move the mouse pointer over the upper left or right border of the segment.
The mouse pointer becomes an up/down arrow.

4.

To rotate the micro-pitch curve, press Alt drag the curve up or down, and release the
mouse.
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RESULT
The Solo algorithm is selected automatically, and the micro-pitch curve is rotated around the
anchor.

RELATED LINKS
Removing Anchors on page 554
Tilting a Micro-Pitch Curve from a Segment Border to an Anchor on page 553

Straightening Micro-Pitch Curves
You can straighten micro-pitch curves to compensate for the rise and fall of notes, that is, the
deviation from a representative pitch.
PREREQUISITE
The audio file is segmented and the segments are correct. You have opened the audio in the
Sample Editor and activated the Pitch & Warp tool in the VariAudio section.
PROCEDURE
1.

Select one or several segments.

2.

In the VariAudio section, move the Straighten Pitch slider to the right.

RESULT
The Solo algorithm is selected automatically, and the micro-pitch curves of the selected
segments are straightened according to your settings.
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Timing Modifications
Modifying the timing of segments, or warping, is useful if you want to align a musical accent to a
certain time position or change the timing of segments in monophonic vocal recordings.
If you warp audio segments, warp markers are created. These are shown in the VariAudio and
the AudioWarp sections of the Sample Editor Inspector.

Warping Segments
PREREQUISITE
The audio file is segmented and the segments are correct. You have opened the audio in the
Sample Editor and activated the Pitch & Warp tool in the VariAudio section. Snap is activated.
PROCEDURE
1.

Move the mouse pointer over the start or end of a segment.
The mouse pointer becomes a double arrow and warp markers are displayed below the
ruler.

2.

Drag the start or end of the segment to the desired time position.

RESULT
The Solo algorithm is selected automatically. If Snap is activated, the segment border snaps to
the grid. The timing of the segment and the adjacent segments is changed according to your
settings. Warp markers are shown to indicate which portions of the audio are stretched.
NOTE
Timing modifications introduced this way do not adapt to the project tempo. If this is what you
want, use Musical Mode.

Editing Warp Markers
You can change the insert position of a warp marker in the audio. This is useful if the beginning
of the waveform does not correspond to the beginning of a segment because the audio starts
with non-tonal portions like breath sounds, for example.
PREREQUISITE
The audio file is segmented and the segments are correct. You have opened the audio in the
Sample Editor and activated the Pitch & Warp tool in the VariAudio section. Snap is activated.
PROCEDURE
1.

Move the mouse pointer over the start of the segment and drag to the beginning of the
bar.
The mouse pointer becomes a double arrow and segment border snaps to the grid at the
exact bar position.
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2.

Move the mouse pointer over the warp handle and drag it to the beginning of the
waveform.

The mouse pointer becomes a double arrow and the background is highlighted to indicate
which part of the waveform is affected by the change.
RESULT
Now the beginning of the waveform matches the beginning of the bar.

Deleting Warp Markers
You can delete warp markers.
PREREQUISITE
The audio file is segmented and the segments are correct. You have opened the audio in the
Sample Editor and activated the Pitch & Warp tool in the VariAudio section.
PROCEDURE
●

Hold down Shift, move the mouse pointer over the warp handle and click.
The mouse pointer becomes an eraser.

RESULT
The warp marker is deleted.

Reset Functions
The Reset pop-up menu provides functions that allow you to reset all VariAudio changes that
you performed.
To open the Reset functions, open the VariAudio section of the Sample Editor Inspector and
click Reset.
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Pitch Changes
Resets pitch changes including micro-pitch modifications with the Tilt Micro Pitches
tool either for the selected segments (if available) or for the whole file.
Warp Changes
Resets warp changes.
Pitch + Warp Changes
Resets pitch, micro-pitch, and warp changes either for the selected segments (if
available) or for the whole file.
Reanalyze Audio
Resets the segmentation and reanalyzes the audio.
NOTE
You can set up key commands for the reset and the reanalyze function in the Sample Editor
category of the Key Commands dialog.

RELATED LINKS
Key Commands on page 1137

Extracting MIDI from Audio
You can extract a MIDI part from your audio. This is useful if you want to copy the tune and
sound of your audio with a MIDI instrument or VST instrument.
PREREQUISITE
The audio file is segmented and the segments are correct. All pitch and timing changes are
completed. You have opened the audio in the Sample Editor and activated the Segments tool in
the VariAudio section.
PROCEDURE
1.

In the VariAudio section, click Extract MIDI.

2.

In the Extract MIDI dialog that opens, make your settings and click OK.

RESULT
A MIDI part is created according to your settings.
RELATED LINKS
Segmenting Monophonic Audio on page 543
Extract MIDI Dialog on page 559
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Extract MIDI Dialog
The Extract MIDI dialog allows you to specify which audio data is used when creating a MIDI
part with the Extract MIDI function.
To open the Extract MIDI dialog, open the VariAudio section of the Sample Editor Inspector,
activate the Segments tool, and click Extract MIDI.

The following pop-up menus are available:

Pitch Mode
Allows you to specify which data is included if you extract MIDI. The following options are
available:
Just Notes and No Pitchbend Data
Extracts notes only.
Notes and Static Pitchbend Data
Extracts pitchbend events for each segment. In the Pitchbend Range field you can
specify a pitchbend value from 1 to 24.
NOTE
If you work with an external MIDI device, set it to the same Pitchbend Range value.
Notes and Continuous Pitchbend Data
Extracts pitchbend events that correspond to the micro-pitch curve. In the Pitchbend
Range field you can specify a pitchbend value from 1 to 24.
NOTE
If you work with an external MIDI device, set it to the same Pitchbend Range value.
Notes and NoteExp Pitchbend Curve
Extracts pitchbend events that correspond to the micro-pitch curve. These are saved
as Note Expression data for the resulting MIDI notes.
Notes and NoteExp VST 3 Tuning Curve
Extracts VST 3 events for the Tuning parameter. These are created as Note
Expression data for the resulting MIDI notes.
NOTE
This works only with a connected VST instrument that is compatible with Note
Expression.

Volume Mode
Allows you to specify how volume information from the audio is extracted. The following options
are available:
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Fixed Velocity
Assigns the same velocity to all created MIDI notes. In the Velocity field you can
specify a velocity value.
Dynamic Velocity
Assigns an individual velocity value to each created MIDI note according to the
amplitude of the audio signal.
Volume Controller Curve
Creates a continuous volume controller curve within the MIDI part. In the MIDI
Controller field you can specify the MIDI controller.
NoteExp Volume Controller Curve
Extracts MIDI volume controller events. These are created as Note Expression data
for the resulting MIDI notes.
NoteExp VST 3 Volume Curve
Extracts a VST 3 volume curve. This is created as Note Expression data for the
resulting MIDI notes.
NOTE
This option works only with a connected VST instrument that is compatible with Note
Expression.

Destination
Allows you to specify where the MIDI part is placed. The following options are available:
First Selected Track
Places the MIDI part on the first selected MIDI or instrument track. Note that any
MIDI parts from previous extractions that are on this track are deleted.
New MIDI Track
Creates a new MIDI track for the MIDI part.
Project Clipboard
Copies the MIDI part into the clipboard. This option allows you to insert it at the
desired position on a MIDI or instrument track in the Project window.
NOTE
If you opened the Sample Editor from the Pool and the audio file is not part of your project, the
MIDI part is inserted at the beginning of the project.

Flattening Realtime Processing
You can flatten VariAudio modifications. This is useful if you want to reduce the CPU load,
optimize the sound quality of the processing, or apply any offline processing.
PROCEDURE
1.

Select the audio events that you want to process.

2.

Perform one of the following actions:

3.

●

Select Audio > Realtime Processing > Flatten Realtime Processing.

●

In the Process section of the Sample Editor, click Flatten.

Click OK.
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RESULT
Any loop that was previously pitch shifted plays back exactly the same, but Musical Mode is
deactivated, and VariAudio data is lost.

Harmony Voices for Audio
Nuendo allows you to quickly create harmonies for monophonic audio material.
You have the following options:
●

You can have Nuendo create default harmony voices for your audio.

●

You can create a chord track with some chords first, and then create harmony voices for
your audio based on that track.

In both cases, a VariAudio analysis is performed for the selected audio event, and up to 4 copies
of the corresponding track are created. These new tracks that are named Soprano, Alto, Tenor,
and Bass contain independent copies of the selected audio event.
If you use the function without a chord track, the voices are distributed by default. If you create a
chord track with some chords and set the original track to follow the chord track in Single Voice
mode, the harmony voices are distributed according to the chord voicing.

Generating Harmony Voices for Monophonic Audio
You can automatically generate harmony voices for monophonic audio.
PROCEDURE
1.

Optional: Add a chord track to your project and set it up.

2.

Select File > Import > Audio File and import a monophonic audio file.

3.

In the Project window, select the audio event.

4.

Select Audio > Generate Harmony Voices.

5.

Specify the number of voices that you want to create, enter a value for the vibrato
reduction, and click OK.

RESULT
The audio event is analyzed and VariAudio segments are created automatically. A copy of the
event with altered pitches is created for every voice and placed on a newly created track.
NOTE
●

If you added a chord track, the pitches of the resulting voices follow the soprano, alto,
tenor, and bass voices from the chord track voicing.

●

If you work without the chord track, the generated VariAudio segments of voice number 1
(soprano) are transposed 3 semitones upwards in relation to the original audio. The
segments of voice numbers 2, 3, and 4 (alto, tenor, and bass) are transposed 3, 6, and 9
semitones downwards.

RELATED LINKS
Adding the Chord Track on page 902
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The Audio Part Editor provides an overview of the selected audio parts. It allows you to view,
audition and edit parts by cutting and pasting, crossfading, drawing level curves, or by
processing parts. Editing is non-destructive so that you can undo modifications at any time.
You can open the Audio Part Editor in a separate window or in the lower zone of the Project
window. Opening the Audio Part Editor in the lower zone of the Project window is useful if you
want to access the Audio Part Editor functions from within a fixed zone of the Project window.
To open an audio part in the Audio Part Editor, do one of the following:
●

Double-click an audio part in the Project.

●

Select an audio part in the Project window and press Return or Ctrl/Cmd-E.

●

Select an audio part in the Project window and select Audio > Open Audio Part Editor.

●

In the Key Commands dialog in the Editors category, assign a key command for Open
Audio Part Editor. Select an audio part in the Project window and use the key command.

NOTE
If you select Audio > Set up Editor Preferences, the Preferences dialog opens on the Editors
page. Make your settings to specify if you want the Audio Part Editor to open in a separate
window or in the lower zone of the Project window.
The Audio Part Editor window:
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The Audio Part Editor in the lower zone of the Project window:

1

Toolbar
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Toolbar
Contains tools for selecting, editing, and playing back audio parts.
2

Info Line
Displays information on the audio parts.

3

Ruler
Displays the timeline and the display format of the project.

RELATED LINKS
Opening the Editor in the Lower Zone on page 66
Opening the Editor Inspector on page 55
Ruler on page 47
Info Line on page 50
Toolbar on page 564

Toolbar
The toolbar contains tools for selecting, editing, and playing back audio parts.
●

To show or hide the toolbar elements, right-click the toolbar and activate or deactivate the
elements.

The following options are available:

Info/Solo
Solo Editor
Solos the selected audio during playback.

Left Divider
Left Divider

Allows you to use the left divider. Tools that are placed to the left of the divider are
always shown.

Auto-Scroll
Link Project and Lower Zone Editor Cursors
Links timelines, cursors and zoom factors of the lower zone editor and the Project
window.
NOTE
You cannot activate Link Project and Lower Zone Editor Cursors if Independent
Track Loop is active.
Auto-Scroll
Keeps the project cursor visible during playback. The Switch Auto-Scroll Settings
pop-up menu allows you to activate Page Scroll or Stationary Cursor and to activate
Suspend Auto-Scroll When Editing.
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Preview
Audition
Plays back the edited audio. Audition Loop loops the playback until you deactivate
the Audition icon. The Audition Volume slider allows you to adjust the volume.

Tool Buttons
Object Selection
Allows you to select audio parts.
Range Selection
Allows you to select ranges.
Zoom
Allows you to zoom in the waveform display. To zoom out, hold Alt while clicking.
Erase
Allows you to erase events from audio parts.
Split
Allows you to split audio parts.
Mute
Allows you to mute/unmute audio parts.
Comp
Allows you to assemble takes.
Draw
Allows you to edit audio.
Play
Allows you to play back the clip from the position where you click until you release
the mouse button.
Scrub
Allows you to locate positions.
Time Warp
Allows you to drag a musical position to a certain position in time.
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Multiple Part Controls
Show Part Borders
Shows/Hides part borders for the active audio part, within the left and right locators.
Edit Active Part Only
Restricts editing operations to the active part.
Currently Edited Part
Lists all parts that were selected when you opened the editor, and allows you to
activate a part.

Nudge Palette
Trim Start Left
Increases the length of the selected element by moving its start to the left.
Trim Start Right
Decreases the length of the selected element by moving its start to the right.
Move Left
Moves the selected element to the left.
Move Right
Moves the selected element to the right.
Trim End Left
Decreases the length of the selected element by moving its end to the left.
Trim End Right
Increases the length of the selected element by moving its end to the right.

Snap/Quantize
Snap to Zero Crossings
Restricts editing to zero crossings, that is, positions where the amplitude is zero.
Snap On/Off
Activates/Deactivates the snap function.
Snap Type
Allows you to select one of the following snap types:
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●

Grid snaps events to the grid that is selected in the Quantize Presets popup menu.

●

Grid Relative

●

Events

●

Shuffle changes the order of events if you drag one event to the left or right
of other events.

●

Magnetic Cursor

●

Grid + Cursor
snaps events to the quantize grid that is selected in the
Quantize Presets pop-up menu or to the cursor position.

●

Events + Cursor
cursor position.

●

Grid + Events + Cursor
snaps events to the quantize grid that is
selected in the Quantize Presets pop-up menu, to the start or end of other
events or to the cursor position.

keeps the relative positions when snapping events to the grid.

snaps events to the start or end of other events.

snaps events to the cursor position.

snaps events to the start or end of other events or to the

Iterative Quantize On/Off
Activates/Deactivates iterative quantize.
Quantize Presets
Allows you to select a quantize or a groove preset.
Apply Quantize
Applies the quantize settings.
Open Quantize Panel
Opens the Quantize Panel.

Event Colors
Color Menu
Allows you to define audio part colors.

Independent Track Loop
Independent Track Loop

Activates/Deactivates the independent track loop for the edited part.
NOTE
If you activate Independent Track Loop, the Link Project and Lower Zone Editor
Cursors function is automatically deactivated in the lower zone editor.

Right Divider
Right Divider
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Info Line
Allows you to use the right divider. Tools that are placed to the right of the divider
are always shown.

Window Zone Controls
Open in Separate Window
This button is available in the lower zone editor. It opens the editor in a separate
window.
Open in Lower Zone
This button is available in the editor window. It opens the editor in the lower zone of
the Project window.
Show/Hide Info
Allows you to activate/deactivate the info line.
Set up Toolbar
Opens a pop-up menu where you can set up which toolbar elements are visible.
RELATED LINKS
Link Project and Lower Zone Editor Cursors on page 67
Auto-Scroll on page 243
Suspend Auto-Scroll When Editing on page 243

Info Line
The info line shows information about the audio part, such as the start, end, length, or the time
stretch algorithm.

●

To show or hide the info line, activate Show/Hide Info

on the toolbar.

The on/off status of the info line in the Audio Part Editor window and in the lower zone
editor are independent of each other.

The Ruler
The ruler shows the timeline and the display format of the project.
You can select a separate display format by clicking on the arrow button on the right. Select an
option from the pop-up menu.
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About Lanes
Lanes can make it easier to work with several audio events in a part. Moving some of the events
to another lane can make selecting and editing much easier.

If Snap is deactivated and you want to move an event to another lane without accidentally
moving it horizontally, press Ctrl/Cmd while dragging it up or down.
RELATED LINKS
Track Handling on page 158

Operations
All operations can be performed in the Audio Part Editor window and in the lower zone editor.
Zooming, selecting and editing in the Audio Part Editor is done just as in the Project window.
NOTE
If a part is a shared copy, any editing you perform will affect all shared copies of this part.

RELATED LINKS
Project Window on page 39
Shared Copies on page 215

Auditioning in the Audio Part Editor
To audition audio parts, you can use one of the following methods:

Auditioning Using the Audition Tool
You can use the audition tool to directly start a single audition of a selection or loop an audition
using the Audition Loop function.
Clicking Audition on the toolbar plays back the edited audio, according to the following rules:
●

If you have selected events in the part, only the section between the first and last selected
event will be played back.

●

If you have made a range selection, only this section will be played back.
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●

If there is no selection, the whole part will be played back. If the project cursor is within the
part, playback starts from the current cursor position. If the cursor is outside the part,
playback starts from the beginning of the part.

●

If Audition Loop is activated, playback will continue until you deactivate Audition.
Otherwise, the section will be played back once.

When auditioning with the Speaker tool or Audition icon, audio will be routed directly to the
Control Room or to the main mix (the default output bus) if the Control Room is disabled.

Auditioning Using the Speaker Tool
PROCEDURE
1.

Select Speaker on the toolbar.

2.

On an audio part, click and hold at the position you want to begin auditioning from.

RESULT
You are auditioning the audio part. The audition will stop at the end of the part you clicked on.

Auditioning Using Regular Playback
To audition from the cursor position, you can use the regular playback controls on the Transport
panel. If you activate Solo Editor on the toolbar, only the events in the edited part will be played
back.

Setting Up the Independent Track Loop
The independent track loop is a sort of mini-cycle, affecting only the edited part. When the loop is
activated, the events in the parts that are within the loop will be repeated continuously and
completely independent – other events (on other tracks) are played back as usual. The only
interaction between the loop and the regular playback is that the loop starts every time the cycle
starts over again.
PROCEDURE
1.

Activate Independent Track Loop on the toolbar.
NOTE
If you activate Independent Track Loop, the Link Project and Lower Zone Editor
Cursors function is automatically deactivated in the lower zone editor.
If it is not visible, right-click the toolbar and add the Independent Track Loop Settings
section.

2.

Ctrl/Cmd-click in the ruler to set the start and Alt-click to set the end of the loop.
NOTE
You can also edit the loop start and end positions numerically in the fields next to the Loop
button.

RESULT
The loop is indicated in blue in the ruler.
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NOTE
The events are looped as long as the Loop button is activated and the Audio Part Editor is open.

RELATED LINKS
Using the Setup Options on page 1161

Scrubbing
In the Audio Part Editor, the Scrub tool has a separate icon on the toolbar. Apart from that,
scrubbing works exactly as in the Project window.
RELATED LINKS
Scrubbing on page 200

Handling Several Parts
When you open the Audio Part Editor with several parts selected – all on the same track or on
different tracks – they might not all fit in the editor window, which can make it hard to get an
overview of the different parts when editing.
Therefore, the toolbar features a few functions to make working with multiple parts easier and
more comprehensive:
●

The Currently Edited Part pop-up menu lists all parts that were selected when you
opened the editor, and lets you select which part is active for editing.
When you select a part from the list, it is automatically made active and centered in the
display.

NOTE
You can also activate a part by clicking on it with the Object Selection tool.
●

Edit Active Part Only lets you restrict editing operations to the active part only.
If you select Edit > Select > All with this option activated, all events in the active part are
selected, but not the events in other parts.

●

You can zoom in on an active part so that it is displayed in its entirety in the window by
selecting Edit > Zoom > Zoom to Event.

●

Show Part Borders can be used if you want to see clearly defined borders for the active
part.
If this option is activated, all parts except the active one are grayed out, making the
borders easily discernible. There are also two markers in the ruler with the name of the
active part, marking its beginning and end. These can be moved freely to change the part
borders.

●

It is possible to cycle between parts, making them active using key commands. In the Key
Commands dialog – Edit category, there are two functions: Activate Next Part and
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Activate Previous Part. If you assign key commands to these, you can use them to cycle
between parts.
RELATED LINKS
Key Commands on page 1137
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Controlling Sample Playback
with Sampler Tracks

The sampler track features allow you to chromatically play back any audio from your audio
sample library via MIDI. You can create and edit new sounds based on specific samples, and
integrate them into an existing project.
The sampler track features include:
●

A sampler track that allows you to control the playback of the audio sample that is loaded
in Sampler Control.

●

Sampler Control that allows you load and edit audio samples.

Loading Audio Samples into Sampler Control
You can load audio samples into Sampler Control by dragging.
Nuendo allows you to load mono or stereo samples in .wav or .aiff file format into Sampler
Control.
●

To load an audio sample, drag it from the MediaBay, the Project window event display, or
the File Explorer/macOS Finder and drop it in Sampler Control.
IMPORTANT
If Sampler Control already contains an audio sample, this sample and all its settings are
overwritten.

NOTE
●

Audio samples that you load into Sampler Control are not copied to the project audio
folder. If you want to archive or share your project including all audio samples that you
have loaded into Sampler Control, you must create a self-contained project.

●

In the Pool, all audio samples that you have loaded into Sampler Control are listed in a
dedicated sampler track subfolder in the main audio folder.

RELATED LINKS
Creating Self-Contained Projects on page 96
Pool on page 586

Loading MIDI Parts into Sampler Control
You can load MIDI parts from instrument tracks or MIDI tracks, into Sampler Control by
dragging.
NOTE
For this to work, the instrument track or the MIDI track must be routed to a VST instrument.
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●

To load a MIDI part, drag it from the MediaBay, the Project window event display, or the
File Explorer/macOS Finder and drop it in Sampler Control.
IMPORTANT
If Sampler Control already contains MIDI, it is overwritten.

Nuendo creates an audio file from the MIDI part. This includes the instrument sound and the
channel settings from the VST instrument or the return channel. The audio file is copied to the
project audio folder.
RELATED LINKS
VST Instruments on page 724
Instrument Track Inspector on page 109
MIDI Track Inspector on page 116

Creating Sampler Tracks
To create a sampler track, do one of the following:
●

In the Project window, select an audio event and select Audio > Create Sampler Track.

●

In the MediaBay, right-click an audio file and select Create Sampler Track.

●

In the Inspector of the Sample Editor, open the Range section and click Create Sampler
Track .
This creates a sampler track from the selected range. If no range is selected, the entire
event is used.

●

On the context menu of the track list, select Add Sampler Track.
In this case, Sampler Control is empty and you must load an audio sample by dragging.

Sampler Control
If the sampler track is selected, Sampler Control is available in the lower zone of the Project
window. Sampler Control allows you to view, edit, and play back samples or specific sections of
the samples.

1

Toolbar
Contains tools that allow you to select and edit the audio sample, to organize track
presets, and to transfer the sample with its settings to an instrument.

2

Waveform Display/Envelope Editor
Shows the waveform image of the sample and allows you to define the playback range for
the sample and to set a loop.
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If the envelope editors for the pitch, filter, or amp section are shown, you can adjust their
envelope curve settings here.
3

Sound Parameter Section
Allows you to make settings for time stretching and formant shifting (AudioWarp section),
tuning and pitch modulation (Pitch section), filtering (Filter section), or level and
panorama (Amp section).

4

Keyboard Section
Allows you to set the key range of the sample, its root key, and the modulation range of
the pitchbend wheel. These settings are used if you work with an external MIDI device.

RELATED LINKS
Creating Sampler Tracks on page 574
Waveform Display on page 577
Envelope Editors on page 581
Sound Parameter Section on page 578
Keyboard Section on page 583

Sampler Control Toolbar
The Sampler Control toolbar contains various settings and functions.
Read Automation
Allows you to read track automation.
Write Automation
Allows you to write track automation.
Switch between A/B Settings
Allows you to switch between different parameter settings.
Event Received Indicator
This LED indicates incoming MIDI messages via the selected MIDI input. The LED
lights up on receiving note-on and controller messages. This way, you can check if
Nuendo and your MIDI keyboard are connected to the same MIDI device input.
Snap to Zero Crossing
Restricts sample editing to zero crossings, that is, to positions where the amplitude is
zero.
Auto-Scroll
Keeps the project cursor visible during playback.
Preset section
Shows the name of the track preset that is loaded for the sampler track. You can also
save and load presets.
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Import Audio File
Opens the Import Audio dialog that allows you to load an audio file into Sampler
Control.
NOTE
If Sampler Control already contains an audio file, the original file is replaced by the
new file.
File Name
Shows the file name of the sample.
Tempo
Shows the tempo of the sample.
Root Key
Shows the root key that determines the pitch of the sample. You can change the root
key by entering a new value in the value field or by dragging the root key handle on
the Sampler Control keyboard.
Loop Mode
Allows you to select a loop mode for playback via MIDI.
●

If this is set to No Loop, the sample is played once.

●

If this is set to Continuous, the sample is played in a continuous loop.

●

If this is set to Alternate, the sample is played back in a loop that alternates
forward and backward.

●

If this is set to Once, the sample is looped once.

●

If this is set to Until Release, the sample is looped repeatedly until you release
the key on the keyboard.

●

If this is set to Alternate Until Release, the loop alternates forward and
backward for as long as you hold the key.

One Shot
The sample is played back once from beginning to end, regardless of any loop
settings.
MIDI Reset
Stops playback and resets all MIDI controllers to their default values.
This is useful, for example, if you want to stop playback of a long audio sample in
One Shot mode.
Fixed Pitch
If a sample is triggered by a MIDI note other than the one defined by the Root Key
setting, the sample is pitched accordingly. If Fixed Pitch is activated, the relation
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between played note and root key is disregarded and all keys play the sample just as
it was recorded.
Reverse Sample
Reverses the sample. This allows you to play back the sample backwards.
Monophonic Mode
Activates monophonic playback. For solo instruments, this usually results in a more
naturally sounding performance. If monophonic playback is activated, a note that
was stolen by another note is retriggered if you still hold the stolen note when you
release the new one. This way, you can play trills by holding one note and quickly and
repeatedly pressing and releasing another note, for example.
If this option is deactivated, you can play up to 128 notes simultaneously.
Transfer to New Instrument
Allows you to transfer the audio sample with all its Sampler Control settings to an
instrument that is loaded to a new instrument track.
Open in Separate Window
Opens Sampler Control in a separate window.
To close the separate window and open Sampler Control in the lower zone, click
Open in Lower Zone .
RELATED LINKS
Setting the Root Key Manually on page 584
Setting up Loops for Audio Samples on page 583
Transferring Samples from Sampler Control to VST Instruments on page 585

Waveform Display
The waveform display shows the waveform of your audio sample. It allows you to define the start
and end of the audio sample, of the loop, and of the fade-in/-out.

Sample Start
Defines the sample start. On playback, all audio before the sample start is ignored.
Sample End
Defines the sample stop. On playback, all audio after the sample end is ignored.
Sustain Loop Start
Defines where the sustain loop starts.
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Sustain Loop End
Defines where the sustain loop ends. When this marker is reached, playback jumps
back to the sustain loop start.
Fade-In Length
Defines the fade-in length.
Fade-Out Length
Defines the fade-out length.
Sustain Loop Crossfade Length
Loop crossfades allow for smoother loops. This marker defines the length for the
loop crossfade.

Ruler
The ruler shows the timeline in the specified display format.
●

To select the format, click the arrow button to the right of the ruler and select an option
from the pop-up menu.
You can display bars and beats, seconds, or samples.

Zooming
●

To zoom in/out on the time and level axes, use the horizontal and vertical zoom sliders or
the corresponding key commands.

RELATED LINKS
Key Commands on page 1137

Sound Parameter Section
In the sound parameter section you can make settings for time stretching and formant shifting
(AudioWarp section), tuning and pitch modulation (Pitch section), filtering (Filter section), or
level and panorama (Amp section).

AudioWarp
In the AudioWarp section, you can apply time stretching and formant shifting to your samples.

●

To activate the AudioWarp settings, click Activate/Deactivate AudioWarp

.

AudioWarp Mode
●

Solo mode offers parameters for time stretching and formant shifting.
This mode is suitable for loops and samples of solo instruments or vocals.

●

Music mode offers parameters for time stretching.
This mode is suitable for complex material like drum loops and samples of
mixed music. It uses considerably more CPU time than Solo mode.
NOTE
The more the sample is stretched, the higher the CPU load.
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AudioWarp Sync Mode
Allows you to match the playback speed of the sample to the project tempo.
●

If Off is selected, the playback speed is specified manually, in percent.

●

If Tempo is selected, the playback speed is calculated using the ratio between
the original tempo of the sample and the tempo of the host.

Legato
If this option is deactivated, each note that is played via MIDI starts playback from
the Sampler Control position cursor.
If this option is activated, the first note starts playback from the position cursor, and
any following notes start from the current playback position for as long as the first
note is held.
Speed
If AudioWarp Sync Mode is set to Off, you can adjust the playback speed of the
sample.
In Music mode, the minimum playback speed adjustment is 12.5 %. Values below
this limit have no effect.
Original BPM
If AudioWarp Sync Mode is set to Tempo, you can enter the original tempo of the
sample in beats per minute. The playback speed of the sample is adjusted to match
the tempo of the host application.
NOTE
This parameter is only available in Solo and in Music mode. In Music mode, the
lower limit of the playback speed adjustment is 12.5 %. Values below this limit have
no further effect.
Formant
Allows you to adjust formant shifting. Formant shifting allows you to avoid so-called
Mickey Mouse effects when pitch shifting a sample. This is especially useful with
samples of human voices or acoustic instruments.
This parameter is only available in Solo mode.

Pitch
In the Pitch section, you can adjust the tuning and pitch of your audio sample. The pitch
envelope allows you to modulate the pitch over time.

Coarse
Sets the pitch of the audio sample in semitone steps.
Fine
Fine-tunes the pitch of the audio sample in cents (hundredths of a semitone).
Glide
Specifies the time that is needed to bend the pitch of the audio sample from one
note to the following note. If you move this control all the way to the left, Glide is
deactivated.
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Show/Hide Pitch Envelope
Shows the pitch envelope editor.
RELATED LINKS
Envelope Editors on page 581

Filter
In the Filter section, you can adjust the tone color of the sample sound. The filter envelope
allows you to control the cutoff frequency to shape the harmonic content over time.

●

To activate the filter settings, click Activate/Deactivate Filter

.

Cutoff
Controls the cutoff frequency of the filter.
Resonance
Sets the filter resonance.
Drive
Determines the level of the input signal and thus the amount of saturation.
Show/Hide Filter Envelope
Shows the filter envelope editor.
RELATED LINKS
Envelope Editors on page 581

Amp
In the Amp section, you can set volume and pan of the sample. The amplifier envelope allows
you to shape the volume over time.

Volume
Sets the level of the sample.
Pan
Sets the position of the sample in the stereo panorama.
Show/Hide Amp Envelope
Shows the amplifier envelope editor.
RELATED LINKS
Envelope Editors on page 581
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Envelope Editors
You can adjust the Pitch, Filter, and Amp envelope curves. Each of these envelopes can contain
up to 128 nodes.
●

Click Show/Hide Envelope
envelope editor.

at the top right of a section to show the corresponding

Pitch Envelope

Envelope Amount
Determines how much the selected envelope affects the audio. This parameter
allows for positive and negative values. If the Envelope Amount is set to 0, the
envelope has no effect.
NOTE
This parameter is only available for Filter and Pitch.
Envelope display
Shows the envelope curve. You can adjust it by adding, moving, and deleting nodes.
The nodes for attack (A), sustain (S), and release (R) are always shown and cannot be
deleted. Next to the release node, the release time of the envelope is shown.
Mode
Determines how the envelope is played back when it is triggered.
●

Select Sustain to play the envelope from the first node to the sustain node.
The sustain level is held for as long as you play the note. When you release the
note, the envelope continues with the stages following the sustain. This mode
is suited for looped samples.

●

Select Loop to play back the envelope from the first node to the loop nodes.
Then, the loop is repeated for as long as the key is held. When you release the
note, the envelope continues playing the stages that follow the sustain. This
mode is suited for adding motion to the sustain of the envelope.

●

Select One Shot to play the envelope from the first to the last node, even if
you release the key. The envelope has no sustain stage. This mode is suited for
drum samples.

●

Select Sample Loop to preserve the natural attack of the sample. The decay of
the envelope does not start until the sample has reached the sample loop
start.
If you set the second node to the maximum level and use the following nodes
to shape the decay during the loop phase of the sample, the envelope only
affects the loop phase. The attack of the envelope is still executed.

Velocity
Determines how the velocity affects the level of the envelope.
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The level of the envelope depends on the velocity setting and on how hard you hit a
key. Higher values increase the level of the envelope the harder you hit a key.
RELATED LINKS
Selecting Nodes on page 582
Adding and Removing Nodes on page 582
Adjusting the Envelope Curve on page 582
Zoom Functions in the Envelope Editors on page 582

Selecting Nodes
You can select single nodes or multiple nodes. Selected nodes are edited together.
●

To select a node, click on it in the graphical editor.
The Time field at the top of the graphical envelope editor shows the parameters of the
selected node.

●

To add a node to a selection, Shift-click the node.

●

To select multiple nodes, draw a rectangle around them with the mouse.
If multiple nodes are selected, the Time field shows the parameters of the node that is
indicated by a white border.

●

To select all envelope nodes, press Ctrl/Cmd-A.

●

If the envelope editor has the keyboard focus, you can select the next or the previous node
with the left and right arrow keys.

RELATED LINKS
Keyboard Focus in the Project Window on page 74

Adding and Removing Nodes
You can add up to 128 nodes to an envelope curve.
●

To add a node, double-click at the position where you want to add the node.

●

To remove a node, double-click it.

●

To delete several selected nodes, press Delete or Backspace.

NOTE
●

You cannot remove the attack (A), the sustain (S), or the release node (R).

●

All nodes added after the sustain node always affect the release phase of the envelope.

Adjusting the Envelope Curve
The envelope editor allows you to adjust the envelope curve by dragging.
●

To move a node horizontally or vertically, click and drag it.

●

To move the envelope curve vertically between two nodes, click and drag it.

Zoom Functions in the Envelope Editors
The vertical axis of the envelope editor displays the level. The horizontal axis displays the time.
●

To zoom in or out, click the + or - buttons to the right of the scrollbar below the envelope
editor or use the corresponding key commands.

●

To zoom in or out at the current position, click in the timeline and drag up or down.

●

To zoom to a specific region, hold Alt, click and drag the mouse over the region.
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RELATED LINKS
Key Commands on page 1137

Keyboard Section
In the keyboard section of Sampler Control you can set the root key and the key range of the
sample, and the modulation range of the pitchbend wheel on your MIDI keyboard.

Pitchbend
Determines the maximal modulation that is applied when you move the pitchbend
wheel on your MIDI keyboard. You can set the pitchbend range in semitone steps up
to 12 semitones.
Keyboard
Determines the root key and the key range of the sample.
RELATED LINKS
Setting the Root Key Manually on page 584
Setting the Key Range on page 584

Sample Editing and Playback Functions
All sample editing in Sampler Control is non destructive.

Setting Sample Start and End
By setting the sample start and end, you can define what range of the sample is played back
when you press a key on your MIDI keyboard.
PROCEDURE
1.

Drag the Set Sample Start handle to the right to adjust the sample start point.

2.

Drag the Set Sample End handle to the left to adjust the sample end point.

Setting up Loops for Audio Samples
You can set up a loop that is played back when the sample is triggered.
PROCEDURE
1.

On the toolbar, click Loop Mode and select a loop mode from the pop-up menu.
The Sustain Loop Start/End handles and the green loop range overlay are shown.

2.

Drag the Set Sustain Loop Start/End handles to adjust the loop start and end points.
To create a smooth loop transition, try to match the shape of the green loop range overlay
with the shape of the gray sample waveform.
NOTE
You cannot drag the loop start and end points outside the defined sample range.
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RELATED LINKS
Setting Sample Start and End on page 583

Setting the Root Key Manually
The Root Key shows the original pitch of the sample. Sometimes, if the sample does not contain
any root key information or if you want the sample to play at a different pitch you must set the
root key manually.
NOTE
If you load a sample that does not contain any root key information, the root key is automatically
set to C3.
To set the root key manually, do one of the following:
●

In the keyboard section of Sampler Control, click and drag the root key handle.

●

On the toolbar of Sampler Control, double-click in the Root Key field and enter the new
root key using your computer keyboard, your mouse wheel, or your MIDI keyboard.

RELATED LINKS
Keyboard Section on page 583
Setting the Key Range on page 584

Setting the Key Range
You can determine the key range for the sample. This is useful for samples that only sound good
within a certain key range.
PROCEDURE
●

In the keyboard section, adjust the key range by dragging the range handles above the
keyboard display.

RESULT
Only keys within the determined key range play a sound when triggered.
RELATED LINKS
Keyboard Section on page 583

Playing Back Samples
After you have loaded an audio sample into Sampler Control, you can play back the sample
using an external MIDI keyboard or the On-Screen Keyboard.
PREREQUISITE
You have loaded a sample into Sampler Control and made all sample editing and settings. You
have installed and set up your MIDI keyboard.
PROCEDURE
1.

In the track list, activate Monitor for the sampler track.

2.

Optional: On the Sampler Control toolbar, activate Fixed Pitch.
This allows you to play back the sample in its original pitch and speed.

3.

Hit some notes on your keyboard or use the On-Screen Keyboard to play back the sample.
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RESULT
If Fixed Pitch is deactivated, the sample is played back and the pitch is defined by the notes you
play. If you hit lower keys, the sample is played back with a low pitch. If you hit higher keys, the
sample is played back with a high pitch.
If Fixed Pitch is activated, the sample is played back in its original pitch.
AFTER COMPLETING THIS TASK
To use the sound of the edited sample in your project, create or record a MIDI event on the
sampler track.
RELATED LINKS
On-Screen Keyboard on page 257
Monitoring via Nuendo on page 263
MIDI Events on page 197
Basic Recording Methods on page 259
MIDI Editors on page 797

Transferring Samples from Sampler Control to VST
Instruments
You can transfer audio samples with all settings that you have made in Sampler Control to
specific Steinberg VST instruments.
Transferring audio samples from Sampler Control to a VST instrument creates a new instrument
track in the track list. This new track is added below the sampler track. The audio sample and all
its settings are loaded in the VST instrument.
You can transfer audio samples from Sampler Control to the following Steinberg VST
instruments:
●

Groove Agent

●

Groove Agent SE

●

HALion

●

Padshop Pro

Transferring a Sample
PREREQUISITE
You have installed Groove Agent, Groove Agent SE, or HALion. You have loaded an audio sample
in Sampler Control.
PROCEDURE
1.

In the Sampler Control toolbar, click Transfer to New Instrument.

2.

In the pop-up menu, select the instrument to which you want to transfer the sample.

RESULT
In the track list, a new instrument track is created below the sampler track. The instrument track
has the same name as the sampler track. The audio sample and all its settings are loaded in the
selected VST instrument.
RELATED LINKS
Transferring a Sample on page 585

585

Pool

Every time that you record on an audio track, a file is created on your hard disk. A reference to
this file, a clip, is added to the Pool.
The following rules apply to the Pool:
●

All audio and video clips that belong to a project are listed in the Pool.

●

Every project has a separate Pool.

The way the Pool displays folders and their contents is similar to the way the File Explorer/macOS
Finder displays folders and file lists. In the Pool, you can perform operations that affect files on
disk and operations that only affect clips.

Operations That Affect Files
●

Importing clips (audio files can automatically be copied and/or converted)

●

Converting file formats

●

Renaming clips (this also renames the referenced files on disk) and regions

●

Deleting clips

●

Preparing file archives for backup

●

Minimizing files

Operations That Affect Clips
●

Copying clips

●

Auditioning clips

●

Organizing clips

●

Applying audio processing to clips

●

Saving or importing complete Pool files

Pool Window
The Pool window allows you to manage the media files of the active project.
You can open the Pool in the following ways:
●

On the Project window toolbar, click Open Pool Window. If this icon is not visible, you
must activate the Media & MixConsole Windows option on the toolbar context menu.

●

Select Project > Pool.

●

Select Media > Open Pool Window.
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The content of the Pool is divided into the following folders:
Audio Folder
Contains all audio clips and regions that are in the project.
If the projects contains one or more sampler tracks, a dedicated Sampler Track
subfolder is created in the audio folder. This subfolder contains all clips of samples
that you have loaded into Sampler Control.
Clip Packages Folder
Contains all imported or created clip packages.
Video Folder
Contains all video clips that are in the project.
Trash Folder
Contains unused clips that have been moved here for later permanent removal from
the hard disk.
NOTE
You cannot rename or delete these folders, but you can add any number of subfolders.
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Pool Window Columns
The Pool window columns display information about the clips and regions.

The following columns are available:
Media
Contains the Audio, Video, and Trash folders. If the folders are opened, the clip or
region names are shown and can be edited.
Used
Displays how many times a clip is used in the project. If there is no entry in this
column, the corresponding clip is not used.
Status
Displays various icons that relate to the current Pool and clip status. The following
symbols can be displayed:
●

Record folder
Indicates the Record folder.

●

Process
Indicates that a clip has been processed.

●

Missing
Indicates that a clip is referenced in the project but missing from the Pool.

●

External
Indicates that the file the clip related to is external, for example, located
outside the current Audio folder for the project.

●

Recorded
Indicates that the clip has been recorded in the open version of the project.
This is useful for finding recently recorded clips quickly.

Musical Mode
You can use Musical Mode to tempo-match audio loops to the project tempo. The
checkbox in this column allows you to activate or deactivate musical mode. If the
Tempo column displays “???”, you must enter the correct tempo before you can
activate Musical Mode.
Tempo
Displays the tempo of audio files if available. If no tempo has been specified, the
column displays “???”.
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Sign
Displays the time signature, for example, “4/4”.
Key
Displays the root key if one has been specified for the file.
Algorithm
Displays the algorithm preset that is used if the audio file is processed.
●

To change the default preset, click the preset name and select another preset
from the pop-up menu.

Info
For audio clips, this column displays the sample rate, bit depth, number of channels,
and length.
For regions, it displays start and end times in frames.
For video clips, it displays the frame rate, resolution, number of frames, and length.
Type
Displays the file format of the clip.
Date
Displays the date when the audio file was last changed.
Origin Time
Displays the original start position where a clip was recorded in the project. As this
value can be used as a basis for the Insert into Project option in the Media or
context menu, you can change it if the Origin Time value is independent (for
example, not for regions).
You can change the value by editing the value in the column, or by selecting the
corresponding clip in the Pool, moving the project cursor to the new position and
selecting Audio > Update Origin.
Image
Displays waveform images of audio clips or regions.
Path
Displays the path to the location of a clip on the hard disk.
Reel Name
If you have imported an OMF file, it may include this attribute, which is then shown
in this column. It describes the reel or tape from which the media was originally
captured.
NOTE
You can rearrange the order of the columns by clicking a header and dragging left or right.

Toolbar
The toolbar contains tools and settings for working in the Pool.

1

Show Info
Activates/Deactivates the info line.

2

Audition
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If this option is activated and you select a clip in the Pool, it is played back.
3

Audition Loop
If this option is activated, the playback of the selected clip is looped.

4

Volume
Lets you specify the playback volume.

5

View/Attributes
Lets you activate/deactivate which attributes are displayed in the Pool window. You can
also define custom user attributes.

6

Open/Close all folders
Opens/Closes all folders.

7

Import
Lets you import media files to the Pool.

8

Search
Lets you search the Pool and connected disks for media files.

9

Project Folder
Displays the path to the folder of the active project.

10

Pool Record Folder
Displays the path to the Record folder of the active project. By default, this is the Audio
folder. However, you can create a new Audio subfolder and designate this as your Pool
record folder.

Info Line
The info line shows information about the event or part that you selected in the Pool.
The info line displays additional information regarding the files in the Pool.
●

To activate the info line, click Show Info at the left of the toolbar.

The info line shows the following information:
Audio Files
The number of audio files in the Pool.
Used
The number of audio files in use.
Total Size
The total size of all audio files in the Pool.
External Files
The number of files in the Pool that do not reside in the project folder (for example,
video files).

Working with the Pool
NOTE
Most of the Pool-related main menu functions are also available on the Pool context menu.
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Renaming Clips or Regions in the Pool
IMPORTANT
Renaming clips or regions in the Pool also renames the referenced files on disk. It is
recommended to rename clips or regions in the Pool. Otherwise, the reference from the clip to
the file may get lost.

PROCEDURE
1.

In the Pool window, select a clip or region, and click the existing name.

2.

Type in a new name and press Return.

RELATED LINKS
About Missing Files on page 597

Renaming Multiple Clips or Regions in the Pool
PROCEDURE
1.

In the Pool window, select the clips or regions that you want to rename.
You can only select one type of object at a time.

2.

Select Edit > Rename Objects.
A dialog with several renaming options opens.

3.

In the dialog, set the parameters for renaming object and click OK.

Rename Objects Dialog
The Rename Objects dialog allows you to add prefixes, suffixes, and incremental numbers to
names. You can also remove certain characters, include timestamp information, and more.
In the Pool window, right-click a clip and select Edit - Rename Objects, or select a clip and select
Edit > Rename Objects.

Each of the fields found in the left section of the Rename Objects dialog can be used to add an
element to the name for each object.
Depending on the selected element, different renaming options are available on the right side of
the dialog. The following elements are available:
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Free Text
Any text that you want to include in the name.
Original Name
The original name given to the object. There are options to remove all numbers, nonalpha numerics, or only numbers at the beginning or end of the name.
Number
An increasing or decreasing number starting with a minimum amount of digits and a
starting number (for example, 001, 002, etc.).
Project Time
The current location of the clip in the project window using any of the seven ruler
formats (Bars+Beats, Timecode, etc.).
Date
Creation date of the file in several formats.
File Extension
The file type.
Audio Bitsize
The bit depth of the audio file.
Sample Rate
The sample rate of the audio file.
Audio Tempo
The audio tempo for the clip if it has been assigned.
User Attribute
Any of the custom attributes created in the Setup User Attributes dialog.
NOTE
●

You can use a prefix to create a space that separates items in the generated name.

●

An example of the result is displayed at the bottom of the window. You can also save all of
these parameters as a preset.

Duplicating Clips in the Pool
You can create duplicates of clips and apply different processing methods to them.
NOTE
Duplicating a clip does not create a new file on disk, but a new edit version of the clip that refers
to the same audio file.

PROCEDURE
1.

In the Pool window, select the clip that you want to duplicate.

2.

Select Media > New Version.

RESULT
A new version of the clip appears in the same Pool folder. The duplicated clip has the same name
as the original but with a version number after it. Regions within a clip are also copied, but keep
their name.
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Inserting Clips into a Project
To insert a clip into a project, you can either use the insert commands on the Media menu or use
drag and drop.

Inserting Clips into a Project Via Menu Commands
PROCEDURE
1.

In the Pool window, select the clips that you want to insert into the project.

2.

Select Media > Insert into Project and select one of the insert options.
If several clips are selected, choose whether to insert them on one track or each on a
different track.
NOTE
The clips are positioned so that their snap points are aligned with the selected insert
position. If you want to adjust the snap point before inserting a clip, double-click a clip to
open the Sample Editor. Here, you can adjust the snap position and then perform the
insert options.

RESULT
The clip is inserted on the selected track or on a new audio track. If several tracks are selected,
the clip will be inserted on the first selected track.
RELATED LINKS
Adjusting the Snap Point on page 522

Inserting Clips into a Project Via Drag and Drop
You can drag a clip from the Pool into the Project window.
Snap is taken into account if Snap is activated.
If you drag the clip into the Project window, the cross-hair cursor and a tooltip are shown. The
tooltip indicates the timeline position where the snap point of the clip is aligned.
If you position the clip in an empty area of the track list, that is, where no track exists, a new track
is created for the inserted event.
NOTE
If you press and hold Shift while dragging the clip from the Pool on an event, the clip in this
event is replaced.

RELATED LINKS
Adjusting the Snap Point on page 522
Replacing Clips in Events on page 196
Cross-Hair Cursor on page 82
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Deleting Clips from the Pool
You can delete clips from the Pool with or without deleting the corresponding file from the hard
disk.

Removing Clips from the Pool
PROCEDURE
1.

In the Pool window, select the clips that you want to remove, and select Edit > Delete
You can also press Backspace or Delete.

2.

Depending on whether the clips are used by an event, you have the following options:
●

If the clips are used by an event, click Remove and then click Remove from Pool.

●

If the clips are not used by an event, click Remove from Pool.

RESULT
The clips are no longer available in the Pool for this project, but the files still exist on the hard
disk and can be used in other projects, etc. This operation can be undone.

Deleting Files from the Hard Disk
To delete a file permanently from the hard disk, you must first move the corresponding clips to
the Trash folder in the Pool.
IMPORTANT
Make sure that the audio files that you want to delete are not used in other projects.

PROCEDURE
1.

In the Pool window, select the clips that you want to delete from the hard disk, and select
Edit > Delete.
You can also press Backspace or Delete, or drag the clips into the Trash folder.
NOTE
You can retrieve a clip or region from the Trash folder by dragging it back into an Audio or
Video folder.

2.

Depending on whether the clips are used by an event, you have the following options:
●

If the clips are used by an event, click Remove and then click Trash.

●

If the clips are not used by an event, click Trash.

3.

Select Media > Empty Trash.

4.

Click Erase.

RESULT
The files are deleted from the hard disk.

Removing Unused Clips from the Pool
You can find all clips in the Pool that are not used in the project. This allows you to quickly
remove all unused clips.
PROCEDURE
1.

In the Pool, select Media > Remove Unused Media.
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2.

Do one of the following:
●

To move the clips to the Trash folder, select Trash.

●

To remove the clips from the Pool, select Remove from Pool.

Removing Regions from the Pool
PROCEDURE
●

In the Pool, select a region and select Edit > Delete.
You can also press Backspace or Delete.
IMPORTANT
You are not warned if the region is still in use.

Locating Events and Clips
You can quickly display to which clips the selected events belong and to which events the
selected clips belong.

Locating Events via Clips in the Pool
You can find out which events in the project refer to a particular clip in the Pool.
PROCEDURE
1.

In the Pool window, select one or more clips.

2.

Select Media > Select in Project.

RESULT
All events that refer to the selected clips are now selected in the Project window.

Locating Clips via Events in the Project Window
You can find out which clip belongs to a particular event in the Project window.
PROCEDURE
1.

In the Project window, select one or more events.

2.

Select Audio > Find Selected in Pool.

RESULT
The corresponding clips are located and highlighted in the Pool.

Searching for Audio Files
The search functions help you locate audio files in the Pool, on your hard disk, or on other media.
This works much like the regular file search, but with extra features.
PROCEDURE
1.

In the Pool window, click Search on the toolbar.
A search pane appears at the bottom of the window, displaying the search functions.
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2.

Specify the files that you search for in the Name field.
You can use partial names or wildcards (*).
NOTE
Only audio files of the supported formats will be found.

3.

Use the Location pop-up menu to specify where to search.
The pop-up menu lists all your local drives and removable media.
●

To limit the search to certain folders, select Select Search Path, and in the dialog
that opens, select the folder in which you want to search.

The search will include the selected folder and all subfolders.
NOTE
Folders that you have recently selected using the Select Search Path function appear on
the pop-up menu, so that you can quickly select them again.
4.

Click Search.
The search is started and Search is labeled Stop.
●

To cancel the search, click Stop.

When the search is finished, the files that are found are listed on the right.

5.

●

To audition a file, select it in the list and use the playback controls to the left (Play,
Stop, Pause, and Loop). If Auto Play is activated, selected files are automatically
played back.

●

To import a file into the Pool, double-click the file in the list or select it and click
Import.

To close the search pane, click Search on the toolbar again.

Using the Extended Search Functionality
Apart from the search criterion Name, additional search filters and user attributes are available.
The extended search options allow for a detailed search, helping you to master even the largest
sound database.
PROCEDURE
1.

Optional: Create user attributes.

2.

In the Pool window, click Search on the toolbar.
The search pane is displayed in the lower part of the Pool window.

3.

Click the Name text to open the extended search pop-up menu where you can select and
define a search criterion.

The menu also contains the user attributes that you specified, as well as the Add Filter
and Presets submenus.
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The search criteria have the following parameters:

4.

●

Name: partial names or wildcards (*)

●

Size: less than, more than, equal, between (two values), in seconds, minutes, hours,
and bytes

●

Bit Depth: 8 bit, 16 bit, 24 bit, 32 bit, 32 bit float, 64 bit float

●

Channels: mono, stereo, and from 3 to 16

●

Sample Rate: various values, choose Other for free setting

●

Date: various search ranges

Select one of the search criteria in the pop-up menu.
The search criterion changes to the selected criteria.

5.

Optional: To display more search options, open the extended search pop-up menu, select
the Add filter submenu, and select an element.

6.

Optional: To save your search filter settings as a preset, open the extended search pop-up
menu, select Presets > Save Preset, and enter a name for the preset.
Saved presets are added to the Presets submenu.

7.

Optional: To remove a search filter settings preset, open the extended search pop-up
menu, select the preset, and then select Remove Preset.

RELATED LINKS
User Attributes on page 602

Find Media Window
The Find Media window is a stand-alone window that offers the same functionality as the Search
Media option in the Pool.
●

To open the Find Media window, select Media > Search Media.

●

To insert a clip or region into the project from the Find Media window, select it in the list,
select Media > Insert into Project, and select one of the insert options.

●

To refine the search options, you can include your user attributes in the search criteria.
All attributes that have been defined appear on the pop-up menu.

RELATED LINKS
Inserting Clips into a Project on page 593
User Attributes on page 602

About Missing Files
When you open a project and one or more files are missing, the Resolve Missing Files dialog
opens. If you click Close, the project opens without the missing files.
In the Pool, you can check which files are considered missing. This is indicated by a question
mark in the Status column.
A file is considered missing under one of the following conditions:
●

The file has been moved or renamed outside the program since you last worked with the
project, and you ignored the Resolve Missing Files dialog when you opened the project
for the current session.

●

You have moved or renamed the file outside the program during the current session.

●

You have moved or renamed the folder in which the missing files are located.
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Locating Missing Files
PROCEDURE
1.

Select Media > Find Missing Files.

2.

In the Resolve Missing Files dialog, decide if you want the program to find the file for you
(Search) if you want to find it yourself (Locate), or if you want to specify in which directory
the program will search for the file (Folder).
●

If you select Search, a dialog opens to let you specify which folder or disk will be
scanned by the program. Click Search Folder, select a directory or a disk, and click
Start. If found, select the file from the list and click Accept. Afterwards Nuendo tries
to map all other missing files automatically.

●

If you select Locate, a file dialog opens, allowing you to locate the file manually.
Select the file and click Open.

●

If you select Folder, a dialog opens to let you specify the directory in which the
missing file can be found. This might be the preferred method if you have renamed
or moved the folder containing the missing file, but the file still has the same name.
Once you select the correct folder, the program finds the file and you can close the
dialog.

Reconstructing Missing Edit Files
If a missing file cannot be found, this is normally indicated with a question mark in the Status
column in the Pool. However, if the missing file is an edit file (a file that is created when you
process audio and stored in the Edits folder within the project folder), it may be possible for the
program to reconstruct it by recreating the editing to the original audio file.
PROCEDURE
1.

In the Pool window, locate the clips for which files are missing.

2.

Check the Status column. If the status of the files is “Reconstructible”, the files can be
reconstructed by Nuendo.

3.

Select the reconstructible clips and select Media > Reconstruct.

RESULT
The editing is performed and the edit files are recreated.

Removing Missing Files from the Pool
If the Pool contains audio files that cannot be found or reconstructed, you may want to remove
these.
PROCEDURE
●

In the Pool window, select Media > Remove Missing Files.

RESULT
All missing files from the Pool and the corresponding events from the Project window are
removed.

Auditioning Clips in the Pool
You can audition clips in the Pool using key commands, the Audition button, or by clicking in the
waveform image for a clip.
●

Use key commands.
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If you activate the Playback Toggle Triggers Local Preview option in the Preferences
dialog (Transport page), you can use Space to audition. This is the same as activating
Audition on the toolbar.
●

Select a clip and activate Audition.
The whole clip plays back. To stop playback, click Audition again.

●

Click in the waveform image for a clip.
The clip plays back from the selected position in the waveform until the end. To stop
playback, click Audition or anywhere else in the Pool window.

The audio is routed directly to the Control Room if activated. When the Control Room is
deactivated, the audio is routed to the Main Mix (the default output) bus, bypassing the settings
of the audio channel, effects, and EQs.
NOTE
You can adjust the auditioning level with the miniature level fader on the toolbar. This does not
affect the regular playback level.
If you have activated Audition Loop before you audition, the following happens:
●

When you click Audition to audition a clip, the clip is repeated indefinitely until you stop
playback by clicking Audition or Audition Loop again.

●

When you click in the waveform image to audition, the section from the selected point to
the end of the clip is repeated indefinitely until you stop playback.

Opening Clips in the Sample Editor
The Sample Editor allows you to perform detailed editing on the clip.
●
●

To open a clip in the Sample Editor, double-click a clip waveform icon or a clip name in the
Media column.
To open a certain region of a clip in the Sample Editor, double-click a region in the Pool.
You can use this to set a snap point for a clip, for example. When you later insert the clip
from the Pool into the project, the defined snap point allows it to be properly aligned.

RELATED LINKS
Adjusting the Snap Point on page 522
Sample Editor on page 503

Importing Media
The Import Medium dialog lets you import files directly into the Pool.
To open the dialog, select Media > Import Medium, or click Import on the Pool toolbar.
This opens a standard file dialog, where you can navigate to other folders, audition files, etc. The
following audio file formats can be imported:
●

Wave (Normal or Broadcast)

●

AIFF and AIFC (Compressed AIFF)

●

MXF (Material Exchange Format)

●

REX or REX 2

●

FLAC (Free Lossless Audio Codec)

●

SD2 (Sound Designer II) (macOS only)

●

MPEG Layer 2 and Layer 3 (MP2 and MP3 files)
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●

Ogg Vorbis (OGG files)

●

Windows Media Audio (Windows only)

●

Wave 64 (W64 files)

The following characteristics are possible:
●

Stereo or mono

●

Any sample rate
NOTE
Files that have a different sample rate than the project sample rate are played back at the
wrong speed and pitch.

●

8 bit, 16 bit, 24 bit, 32 bit, 32 bit float, or 64 bit float

●

Various video formats

NOTE
You can also use the commands on the Import submenu of the File menu to import audio or
video files into the Pool.

RELATED LINKS
Wave Files on page 1013
Importing ReCycle Files on page 283
Supported Compressed Audio File Formats on page 279
Video File Compatibility on page 1076
MXF Files on page 1125

Importing Audio CDs into the Pool
You can import tracks or sections of tracks from an audio CD directly into the Pool. This opens a
dialog in which you can specify which tracks are copied from the CD, converted to audio files, and
added to the Pool.
●

To import an audio CD to the Pool, select Media > Import Audio CD.

RELATED LINKS
Importing Audio CD Tracks on page 280

Import Options Dialog
The Import Options dialog allows you to specify how audio files are imported into the Pool.
●

If you select a file in the Import Medium dialog and click Open, the Import Options
dialog opens.
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Copy Files to Working Directory
Copies the audio file to the Audio folder of the project, and has the clip refer to the
copy.
Deactivate this option to have the clip refer to the original file in the original location.
In this case, it is marked as “external” in the Pool.
Convert and Copy to Project if Needed
Converts the imported file if the sample rate or the bit depth differ from the settings
in the Project Setup dialog.
Split Channels/Split Multi Channel Files
Splits stereo or multi channel audio files into a corresponding number of mono files,
one for each channel, and copies the imported files to the Audio folder of the
project.
Inserts the split files into the Pool.
The Split File Name Format pop-up menu allows you to select a naming format for
the split files. This allows for compatibility with other products when exchanging
audio files.
Please, don’t ask again
Always imports files according to the settings, without opening the dialog again. You
can reset this option in the Preferences dialog (Editing—Audio page).
RELATED LINKS
Pool Window Columns on page 588
Converting Files on page 605
Conforming Files on page 606

Exporting Regions as Audio Files
If you have created regions within an audio clip, these can be exported as separate audio files. If
you have two clips that refer to the same audio file, you can create a separate audio file for each
clip.
PROCEDURE
1.

In the Pool window, select the region that you want to export.

2.

Select Audio > Bounce Selection.

3.

Select the folder in which you want the new file to be created and click OK.

4.

If you are using the Bounce Selection option to create a separate audio file for a clip that
refers to the same audio file as another clip, enter a name for the new audio file.

RESULT
A new audio file is created in the specified folder. The file has the name of the region and is
automatically added to the Pool.
RELATED LINKS
Creating Audio Events from Regions on page 521
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User Attributes
You can define your own attributes for elements in the Pool. This is useful if you have a large
number of audio files in the Pool. You can use the attributes, for example, to sort items in the
Pool.
User attributes have their own columns in the Pool. Each attribute can be defined as checkbox,
text field, or number. You can then specify the user attributes for each file, thus categorizing
them further.
All user attributes that you create are automatically available as search criteria in the Pool. In the
search pane, you can search for values in the user attributes. This allows for a very detailed
search and helps you master even the largest sound database.

Creating User Attributes
PROCEDURE
1.
2.

In the Pool window, open the View/Attributes pop-up menu, and select Define User
Attributes.
In the Set up User Attributes dialog, click Add.
A new attribute is added to the attributes list.

3.

In the attributes list, enter a name and select an attribute type for the new attribute.

4.

Add as many user attributes as you need.

5.

Click OK.

RESULT
The user attributes get their own columns in the Pool.

Changing the Pool Record Folder
All audio clips that you record in the project will end up in the Pool Record folder. The Pool
Record folder is indicated by the text Record in the Status column and by a dot on the folder
itself.
By default, this is the main Audio folder. However, you can create a new Audio subfolder and
designate this as your Pool Record folder.
NOTE
The folders that you create in the Pool are only for organizing your files in the Pool. All files are
recorded to the folder that you specified as the Pool Record Folder.

PROCEDURE
1.

In the Pool, select the Audio folder or any audio clip.
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NOTE
You cannot designate the Video folder or any of its subfolders as the Pool Record folder.
2.

Select Media > Create Folder.

3.

Rename the new folder.

4.

Select the new folder and select Media > Set Pool Record Folder, or click in the Status
column of the new folder.

RESULT
The new folder becomes the Pool Record folder. Any audio recorded in the project will be saved
in this folder.

Organizing Clips and Folders
If you accumulate a large number of clips in the Pool, it can be difficult to quickly find specific
items. Organizing clips in new subfolders with names that reflect the content can be a solution.
For example, you could put all sound effects in one folder, all lead vocals in another, etc.
PROCEDURE
1.

In the Pool window, select the type of folder, audio, or video for which you want to create
a subfolder.
NOTE
You cannot put audio clips in a video folder and vice versa.

2.

Select Media > Create Folder.

3.

Rename the folder.

4.

Drag the clips to the new folder.

Applying Processing to Clips in the Pool
You can apply audio processing to clips from within the Pool in the same way as to events in the
Project window.
PROCEDURE
1.

In the Pool window, select the clips that you want to process.

2.

Select Audio > Direct Offline Processing and select a processing method.

RESULT
A waveform symbol indicates that the clips have been processed.
RELATED LINKS
Direct Offline Processing on page 467

Undoing Processing
You can undo processing that has been applied to clips.
PROCEDURE
1.

In the Pool window, select the clip from which you want to remove the processing.

2.

Select Audio > Direct Offline Processing.
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3.

Select the action that you want to remove, and click Delete.

Minimizing Files
You can minimize the audio files according to the size of the audio clips referenced in the project.
The files that are produced using this option only contain the audio file portions that are actually
used in the project.
This can significantly reduce the size of the project if large portions of the audio files are unused.
Therefore, the option is useful for archiving purposes after you have completed a project.
IMPORTANT
This operation will permanently change the selected audio files in the Pool. This cannot be
undone. If you only want to create the minimized audio files as a copy, leaving the original
project untouched, you can use the Back up Project option.
NOTE
Minimizing files clears the entire edit history.

PROCEDURE
1.

In the Pool window, select the files that you want to minimize.

2.

Select Media > Minimize File.

3.

Click Minimize.
After the minimizing is finished, the file references in the stored project have become
invalid.

4.

Do one of the following:
●

To save the updated project, click Save Now.

●

To proceed with the unsaved project, click Later.

RESULT
Only the audio portions that are actually used in the project remain in the corresponding audio
files in the Pool Record folder.
RELATED LINKS
Backing Up Projects on page 96

Importing and Exporting Pool Files
You can import or export a Pool as a separate file (file extension “.npl”).
●

To import a Pool file, select Media > Import Pool.
When you import a Pool file, its file references are added to the current Pool.
NOTE
Since the audio and video files are only referenced but not saved in the Pool file, the Pool
import is only useful if you have access to all referenced files. These files have preferably
the same file paths as when the Pool was saved.

●

To export a Pool file, select Media > Export Pool.
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You can also save and open libraries, that is, stand-alone Pool files that are not associated with a
project.
RELATED LINKS
Working with Libraries on page 605

Working with Libraries
You can use libraries to save sound effects, loops, video clips, etc., and transfer media from a
library into a project by using drag and drop.
●

To create a new library, select File > New Library.
You must specify a project folder for the new library in which media files will be stored. The
library appears as a separate Pool window.

●

To open a library, select File > Open Library.

●

To save a library, select File > Save Library.

Converting Files
In the Pool, you can convert files to another format.
PROCEDURE
1.

In the Pool window, select the files that you want to convert.

2.

Select Media > Convert Files.

3.

In the Convert Options dialog, make your settings and click OK.

Convert Options Dialog
In this dialog, you can convert audio files in the Pool.
To open the Convert Options dialog, select a clip in the Pool window, and select Media >
Convert Files.

Sample Rate
Allows you to convert to another sample rate.
Bit Depth
Allows you to convert to 16 bit, 24 bit, 32 bit, 32 bit float, or 64 bit float.
Channels
Allows you to convert to mono or stereo interleaved.
File Format
Allows you to convert to Wave, AIFF, MXF, FLAC, Wave 64, or Broadcast Wave format.
Options
You can use the Options pop-up menu to set one of the following options:
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●

New Files
Creates a copy of the file in the audio folder and converts this new file
according to the chosen attributes. The new file is added to the Pool, but all
clip references still point to the original, unconverted file.

●

Replace Files
Converts the original file without changing clip references. However, the
references are saved with the next save action.

●

New + Replace in Pool
Creates a new copy with the chosen attributes, replaces the original file with
the new one in the Pool and redirects the current clip references from the
original file to the new file. Select the latter option if you want your audio clips
to refer to the converted file, but want to keep the original file on disk, for
example, if the file is used in other projects.

Conforming Files
You can align the file attributes with the project attributes. This is useful if the attributes of the
selected files are different from the project attributes.
PROCEDURE
1.

In the Pool window, select the clips that you want to conform.

2.

Select Media > Conform Files.

3.

Select whether to keep or replace the original unconverted files in the Pool.
●

If you select the Replace option, files in the Pool and in the Audio folder of the
project are replaced.

●

If any Keep option is selected, original files remain in the Audio folder of the project
and new files are created.

RESULT
The files are conformed. Clip or event references in the Pool are redirected to the conformed
files.

Extracting Audio from Video File
You can extract audio from video files. This automatically generates a new audio clip that
appears in the Pool Record folder.
NOTE
This function is not available for MPEG-1 and MPEG-2 video files.

PROCEDURE
1.

In the Pool window, select Media > Extract Audio from Video File.

2.

Select the video file from which you want to extract audio and click Open.

RESULT
The audio is extracted from the video file. The audio file gets the same file format and sample
rate/width as in the current project, and the same name as the video file.
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The MediaBay allows you to manage all your media files and presets from multiple sources.

Media Rack in Right Zone
The Media rack in the right zone of the Project window allows you to access the MediaBay
functions from within a fixed zone of the Project window.
To open the Media rack in the right zone, do the following:
●

Click Show/Hide Right Zone
zone, click the Media tab.

on the Project window toolbar, and at the top of the right

The Media rack opens on the Home page that features different tiles that correspond to the
available media types.
●

Click a tile to show the corresponding media type or preset.

RELATED LINKS
Showing/Hiding Zones on page 40
Home Page on page 607

Home Page
The Home page gives you access to the tiles that correspond to the available media types, to
the Favorite, and to the File Browser.
Click one of the tiles to open the corresponding page in the Media rack:
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Instruments
Shows the included VST instruments and instrument presets.
Loops & Samples
Shows audio loops, MIDI loops, or instrument sounds ordered by content set.
Presets
Shows track presets, strip presets, pattern banks, FX chain presets, and VST FX
presets.
User Presets
Shows track presets, strip presets, pattern banks, FX chain presets, VST FX presets,
and instrument presets that are listed in the User Content folder.
Favorites
Shows your favorite folders and to add new favorites. The folder content is
automatically added to the MediaBay database.
File Browser
Shows your file system and the pre-defined folders Favorites, This Computer, VST
Sound, Factory Content, and User Content where you can search for media files
and access them immediately.
RELATED LINKS
Loading Instrument Presets on page 638
Loading Loops and Samples on page 637
Loading Track Presets on page 638
Loading Effect Plug-In Presets on page 639
Loading FX Chain Presets on page 639
Loading Strip Presets on page 639
Loading Pattern Banks on page 640
Adding Favorites Using the Favorites Page on page 613
Adding Favorites Using the File Browser Page on page 613
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Favorites Page
The Favorites page allows you to add your own favorite folders to the Media rack.

1

Add Favorite
Opens a file dialog where you can navigate to the location of a folder and add it as a
favorite folder.

2

Favorite Folders
The folders that you added as favorites, are shown as tiles on the Favorites page.
●

To show the content of a folder, click it.

●

To delete a folder from the Favorites page, click its close button.

RELATED LINKS
Adding Favorites Using the Favorites Page on page 613

Results Page
The Results page shows all media files that are found in the selected folder.
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1

Media Rack Navigation Controls
Allow you to navigate to specific folders and filter the Results list.

2

Attribute Filter
Allows you to view and edit some of the standard file attributes found in your media files.

3

Results List
Shows all media files that are found in the selected location and allows you to select a
media file.

4

Previewer
Allows you to preview the selected media file.

RELATED LINKS
Media Rack Navigation Controls on page 611
Setting Up the Results List Columns on page 618
Attribute Inspector on page 632
Results Section on page 618
Previewer Section on page 623

Results Page for the File Browser
The Results page for the File Browser shows all media files that are found in the File Browser.

1

Media Rack Navigation Controls
Allow you to navigate to specific folders and filter the Results list.

2

File Browser
Allows you to browse and select folders.

3

Results List
Shows all supported media files that are found in the selected folder and allows you to
select a media file.

4

Previewer
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Allows you to preview the selected media file.
RELATED LINKS
Media Rack Navigation Controls on page 611
File Browser Section on page 615
Results Section on page 618
Previewer Section on page 623

Media Rack Navigation Controls
The navigation controls allow you to navigate to files and folders in the Media rack.
The following navigation controls are always available:

1

Search
Allows you to search media files by name or by attribute.

2

Back
Allows you to navigate back to the previous page.

3

Home
Allows you to navigate back to the Home page.

4

Show All Items
Shows the Results page for a selected tile. If no tile is selected, all media files are shown.

The following navigation controls are available on the Results page for all tiles, except File
Browser.

1

Select Media Types
Allows you to select the media types that are displayed in the Results list.

2

Shuffle Results
Shuffles the Results list.

3

Reset Attribute Filter
Lights up if an attribute filter is set. Click this button to reset the attribute filter.

4

Set up Result Columns
Allows you to specify which attribute columns are displayed in the Results list.

5

Show/Hide Attribute Filters
Shows/Hides the Attribute Filters section.

The following navigation controls are only available, if you click Show All Items.

1

Back/Forward/Up
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Up navigates to the parent folder. Back navigates to the previously used folder. Forward
navigates to the most recent folder.
2

Select Defined Favorite
Allows you to select a different Favorite to quickly browse to the files you are looking for.

3

Include Folders and Subfolders
Activate this to show the content of folders and subfolders.

RELATED LINKS
Home Page on page 607
Adding Favorites Using the Favorites Page on page 613
Media File Attributes on page 630

Working with the Media Rack
The Media rack in the right zone of the Project window allows you to search for supported
media files and included VST instruments, and add them to your project.
The controls on the different pages of the Media rack allow you to browse, to filter, select, and to
preview you media files.
The Favorites page and the File Browser page allow you to add folders where your media files
are located as Favorites. This helps you to quickly browse to these media files.
The tiles and controls on the different pages of the Media rack allow you to browse, to filter,
select, and preview the content.
Once you have located the media file, the instrument, or the preset that you want to use, and
selected it in the Results list, you can insert it into your project by using drag & drop, by using
the context menu options, or by double-clicking.
RELATED LINKS
Media Rack in Right Zone on page 607
Results Page on page 609

Adding Instruments to Projects
You can use the Media rack to add VST instruments to your project. This works only for VST
instruments contained in Nuendo.
PROCEDURE
1.

In the Media rack, click the Instruments tile.

2.

Drag the instrument that you want to load and drop it on the track list.
NOTE
You can also drag a specific instrument preset and drop it on the track list or in the event
display.

RESULT
A new instrument track with the selected instrument is added to the track list.
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Adding Favorites Using the Favorites Page
You can add favorite folders to the Favorites page. This allows you to directly access media files
in specific folders.
PROCEDURE
1.

In the Media rack, click the Favorites tile.

2.

At the top left of the page, click Add Favorite

3.

Select the folder that you want to add as a Favorite.

4.

Click OK.

.

RESULT
On the Favorites page, a new tile with the specified name is added.
In the File Browser, a new folder with the specified name is added to the Favorites folder.

Adding Favorites Using the File Browser Page
You can add favorite folders using the File Browser page. This allows you to directly access
media files in specific folders.
PROCEDURE
1.

In the Media rack, click the File Browser tile.

2.

In the File Browser, navigate to the folder that you want to add as a favorite and select it.

3.

Do one of the following:
●

At the top left of the page, click Add Favorite

.

●

Right-click the folder, and from the context menu, select Add Favorite.

4.

In the Set Name dialog that opens, enter a name for the folder.

5.

Click OK.

RESULT
In the File Browser, a new folder with the specified name is added to the Favorites folder.
On the Favorites page, a new tile with the specified name is added.

MediaBay Window
To open the MediaBay in a separate window, do one of the following:
●

Select Media > MediaBay.

●

Press F5.
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MediaBay

The MediaBay is divided into the following sections:
1

File Browser
Allows you to scan specific folders in your file system, and to add favorites.

2

Favorites
Allows you to switch between the previously defined favorite locations.

3

Filters
Allows you to filter the results list using a logical or an attribute filter.

4

Results
Displays all supported media files. You can filter the list and perform text searches.

5

Previewer
Allows you to preview the files shown in the results list.

6

Attribute Inspector
Allows you to view, edit, and add media file attributes or tags.

RELATED LINKS
File Browser Section on page 615
Favorites Section on page 617
Filters Section on page 628
Results Section on page 618
Previewer Section on page 623
Attribute Inspector on page 632
Setting Up the MediaBay on page 615
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Setting Up the MediaBay
You can show and hide the different sections of the MediaBay. This saves screen space and
enables you to display only the information that you need.
PROCEDURE
1.

Click Set up Window Layout in the lower left corner of the MediaBay.

2.

Activate/Deactivate the checkboxes for the sections that you want to show/hide.

3.

Click outside the pane to exit the setup mode.

MediaBay Navigation Controls
The MediaBay window features controls that allow you to navigate to files and folders. These
controls are always visible, even if you deactivate specific sections of the MediaBay.
The following navigation controls are always available in the MediaBay window:

1

Back/Forward/Up
Up navigates to the parent folder. Back navigates to the previously used folder. Forward
navigates to the most recent folder.

2

Include Folders and Subfolders
Activate this to show the content of folders and subfolders.

3

Select Defined Favorite
Allows you to select a different Favorite to quickly browse to the files you are looking for.

By default, the Back/Forward/Up controls are shown in the File Browser section of the
MediaBay window. If you also hide that section, they are shown in the Favorites section. If you
hide that section, they are shown in the Results section.
Accordingly, the Include Folders and Subfolders button is shown in the Favorites section, and if
you hide that section, it is shown in the Results section.
This allows you to navigate to files and folders at any time.

File Browser Section
The File Browser section allows you, to scan specific folders in your file system and to add
favorites.
To show the supported media files in the Results section of the MediaBay, you must scan all
folders that you want to include in the search.
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You can also add favorite folders. All media files contained in a Favorite are automatically
scanned.
RELATED LINKS
Scanning Folders on page 616
Adding Favorites on page 616

Scanning Folders
To include specific folders in the MediaBay search, you must scan them.
PROCEDURE
1.

In the File Browser section of the MediaBay, navigate to the folder that you want to
include in the scan.

2.

Click the checkbox for the folder to activate the scan.

RESULT
All files that are found in the scanned folder are shown in the Results list. The color of the
checkmark helps you to identify which folders and subfolders are scanned:
●

Red indicates that a folder is currently being scanned.

●

White indicates that all subfolders have been scanned.

●

Orange indicates that at least one subfolder is excluded from the scan.

The scan result is saved in a database file.

Adding Favorites
You can add favorite folders using the File Browser section. This allows you to access media files
in specific folders.
PROCEDURE
1.

In the File Browser section, navigate to the folder that you want to add as a favorite, and
select it.

2.

Do one of the following:
●

At the top right of the page, click Add Favorite

●

Right-click the folder, and from the context menu, select Add Favorite.
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3.

In the Set Name dialog that opens, enter a name for the folder.

4.

Click OK.

RESULT
In the File Browser section, a new folder with the specified name is added to the Favorites
folder.
In the Favorites section, the added favorite is available in the Select Defined Favorite pop-up
menu.
In the Media rack in the right zone of the Project window, a new tile with the specified name is
added on the Favorites page.
NOTE
All media files that a Favorite contains are automatically scanned. If you change the files when
Nuendo is closed, you must update the favorite later by right-clicking the favorite and selecting
Update Favorite from the context menu.
AFTER COMPLETING THIS TASK
To remove a Favorite, select it in the Favorites tree of the File Browser section, open the
context menu and select Remove Favorite.

Refresh Views
If you added or removed files when Nuendo was closed, you must refresh the views. This also
applies if you modified attributes of your user content using another program.
If you have made changes to your content and want the changes to be displayed in the
MediaBay, you must rescan the corresponding media folders.
●

To refresh a folder, in the File Browser section of the MediaBay, right-click a folder, and
select Refresh Views.

●

To display a new network drive, in the File Browser section of the MediaBay, right-click
the parent node, and select Refresh Views. You can then scan the drive for media files.

Favorites Section
In the Favorites section, you can select the Favorites that you specified in the File Browser
section. The contents of a Favorite are shown in the Results list.

1

Select Defined Favorite
Allows you to select a different Favorite to quickly browse to the files you are looking for.

2

Include Folders and Subfolders
Activate this to show the content of folders and subfolders.

RELATED LINKS
Adding Favorites on page 616
Favorites Page on page 609
File Browser Section on page 615
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Results Section
The Results list shows all media files that are found in the selected folder in the File Browser.
NOTE
To show media files in the Results section, you must select a scanned folder in the File Browser
section of the MediaBay.

NOTE
You can set the maximum number of files that are displayed in the Results list in the MediaBay
Settings.

Setting Up the Results List Columns
For each media type, or for combinations of media types, you can specify the attribute columns
that are displayed in the Results list.
PROCEDURE
1.

In the Results section, select the media types for which you want to make settings.

2.

Click Set up Result Columns and activate or deactivate the options on the submenus.

To exclude a particular category, select Select None on the corresponding submenu.
If Allow Editing in Results List is activated in the MediaBay Settings, you can also edit
attributes in the Results list. Otherwise, this is only possible in the Attribute Inspector.

RELATED LINKS
Setting Up the MediaBay on page 615
Attribute Inspector on page 632
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Managing Media Files in the Results List
●

To move or copy a file from the Results list to another location, drag it to another folder in
the File Browser section.

●

To change the order of the columns in the Results list, click a column header and drag that
header to another position.

●

To delete a file, right-click it in the list and select Delete. The file is permanently deleted
from your computer.

IMPORTANT
If you delete a file using the File Explorer/macOS Finder, it is still displayed in the Results list,
although it is no longer available to the program. To remedy this, rescan the corresponding
folder.

Shuffling the Results List
You can display the Results list entries in a random order.
●

To shuffle the Results list, click Shuffle Results

in the MediaBay.

Finding the Location of a File
You can show the location of a file on your system in the File Explorer/macOS Finder.
NOTE
This function is not available for files which are part of a VST Sound archive.

PROCEDURE
●

In the Results list, right-click a file, and select Show in Explorer/Reveal in Finder.

RESULT
The File Explorer/macOS Finder opens and the corresponding file is highlighted.

Filtering According to Media Type
You can set up the Results list to display only a particular media type or a combination of media
types.
PROCEDURE
1.

In the Results section, click Select Media Types.

2.

Activate the media types that you want to be displayed in the Results list.

RESULT
The files are filtered by the selected media type.
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Show Media Types Selector
You can activate the media types that you want to be displayed in the Results list.

The following media types are available:
Audio Files
If this option is activated, the list shows all audio files. The supported formats
are .wav, .w64, .aiff, .aifc, .rex, .rx2, .mp3, .mp2, .ogg, .sd2 (macOS
only), .wma (Windows only).
Clip Packages
If this option is activated, the list shows all clip packages (file name
extension .package). Clip packages contain a number of audio parts and events,
which make up a special sound.
MIDI Files
If this option is activated, the list shows all MIDI files (file name extension .mid).
MIDI Loops
If this option is activated, the list shows all MIDI loops (file name
extension .midiloop).
Pattern Banks
If this option is activated, the list shows all pattern banks (file name
extension .patternbank). Pattern banks are generated via the MIDI plug-in Beat
Designer. For more information, see the separate document Plug-in Reference.
Track Presets
If this option is activated, the list shows all track presets for audio, MIDI, and
instrument tracks (file name extension .trackpreset). Track presets are a
combination of track settings, effects, and MixConsole settings that can be applied
to new tracks of various types.
Plug-in Presets
If this option is activated, the list shows all VST presets for instrument and effect
plug-ins. Furthermore, EQ presets that you save in the MixConsole are listed. These
presets contain all parameter settings for a particular plug-in. They can be used to
apply sounds to instrument tracks and effects to audio tracks.
Strip Presets
If this option is activated, the list shows all strip presets (file name
extension .strippreset). These presets contain channel strip effect chains.

620

MediaBay
MediaBay Window
FX Chain Presets
If this option is activated, the list shows all effect chain presets (file name
extension .fxchainpreset). These presets contain insert effect chains.
Video Files
If this option is activated, the list shows all video files.
Projects
If this option is activated, the list shows all project files (from Cubase,
Nuendo): .cpr, .npr.
RELATED LINKS
Clip Packages on page 196
Previewing Pattern Banks on page 627
Track Presets on page 188
Saving/Loading Strip Presets on page 407
Saving/Loading EQ Presets on page 400
Saving/Loading FX Chain Presets on page 397
Video File Compatibility on page 1076

Filtering According to Rating
With the Rating Filter, you can filter files according to their rating.
NOTE
The Rating Filter is not available in the Media rack in the right zone.

PROCEDURE
●

In the Results section of the MediaBay, drag the Rating Filter to the left or right, or click
the asterisk to display all media files regardless of their rating.

Performing a Text Search
You can perform a text search in the Results list. If you enter text in the text search field, only
media files whose attributes match the entered text are displayed.
NOTE
The Search field has the same function as the matches operator of the logical filter. However,
the search is applied to all file attributes.
●

Click the field and enter the text that you want to find.
For example, if you are looking for all audio loops relating to drum sounds, enter “drum” in
the search field. The search results will contain loops called “Drums 01”, “Drumloop”,
“Snare Drum”, etc. In addition, all media files with the Drum&Percussion category
attribute or any other attribute that contains “drum” are found. You can also add
apostrophes to find exact matches for the entered words and use boolean operators.
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●

To reset the text search, delete the text.

RELATED LINKS
Logical Filter on page 628

Boolean Text Search
You can perform advanced searches, using boolean operators or wildcards.
The following elements can be used:
And [+]
[a and b]
When entering strings separated by “and” (or a plus sign), all files are found that
contain both a and b.
[And] is the default setting when no boolean operator is used, for example, you can
also enter [a b].
Or [,]
[a or b]
When entering strings separated by “or” (or a comma), files are found that contain
either a or b, or both.
Not [-]
[not b]
When entering text preceded by “not” (or a minus sign), all files not containing b are
found.
Parentheses [()]
[(a or b) + c]
Using parentheses, you can group text strings. In this example, files are found that
contain c and either a or b.
Quotation marks [“”]
[“example text”]
With quotation marks, you can define sequences of several words. Files are found if
they contain this sequence of words.
IMPORTANT
When you are searching for files whose names contain a hyphen, put the search text in quotation
marks. Otherwise the program treats the hyphen as the boolean operator “not”.
NOTE
These operators can also be used for logical filtering.
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RELATED LINKS
Applying a Logical Filter on page 629

Resetting the Results List
You can reset all filter settings and filter results.
●

To reset the Results list, click Reset Result Filters

in the MediaBay.

Previewer Section
You can preview individual files in the Previewer section to find out which one to use in your
project.
The elements visible in this section and their functions depend on the media type.
IMPORTANT
The Previewer section is not available for video files, project files, and audio track presets.

RELATED LINKS
MediaBay Settings on page 645

Previewing Audio Files

1

Transport Controls

2

Preview Level Fader

Allow you to start, stop, pause, and cycle the preview.
Allow you to specify the preview level.
3

Auto Play New Results Selection
If this option is activated, the selected file is automatically played back.

4

Align Beats to Project
If this option is activated, the selected file is played back in sync with the project, starting
at the project cursor position. Note that this can apply realtime time stretching to your
audio file.
NOTE
If you import an audio file into your project for which Align Beats to Project is activated in
the Previewer, Musical Mode is automatically activated for the corresponding event.

5

Wait for Project Play
If this option is activated, the play and stop functions from the Transport panel are
synchronized with the play and stop buttons in the Previewer section.
To use this option to its full extent, set the left locator at the beginning of a bar, then start
playing back the project using the Transport panel. The loops that you now select in the
Results list start together with the project in perfect sync.
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RELATED LINKS
Musical Mode on page 533

Using Selection Ranges
You can specify selection ranges to preview a particular section of an audio file and insert it into
the project.
NOTE
Selection ranges cannot be used when the Align Beats to Project option is activated in the
Previewer.
●

To select a range, move the mouse over the upper part of the waveform, so that it turns
into a pencil, click and drag.

●

To adjust the borders of the selection range, drag the handles.

●

To deselect the range, drag both handles all the way to the left.

Previewing MIDI Files
IMPORTANT
To preview a MIDI file, you must load a VST instrument and select it as output device from the
Output pop-up menu.

1

Transport Controls
Allow you to start and stop the preview.

2

Preview Level Fader
Allows you to specify the preview level.

3

Output
Allows you to select the output device.

4

Auto Play New Results Selection
If this option is activated, the selected file is automatically played back.

5

Align Beats to Project
If this option is activated, the selected file is played back in sync with the project, starting
at the project cursor position. Note that this can apply realtime time stretching to your
MIDI file.
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RELATED LINKS
VST Instruments on page 724

Previewing MIDI Loops
NOTE
MIDI loops are always played back in sync with the project.

1

Transport Controls
Allows you to start and stop the preview.

2

Preview Level Fader
Allows you to specify the preview level.

3

Auto Play New Results Selection
If this option is activated, the selected file is automatically played back.

4

Link Playback to Chord Track
If this option is activated, the events of the MIDI loop are transposed to play back in
context with the chord track. Note that you need a chord track with chord events for this.
If this option is activated, and you insert a MIDI loop into the project, Follow Chord Track
is automatically activated for the track.

RELATED LINKS
Using Follow Chord Track on page 914

Previewing VST Presets and Track Presets for MIDI and Instrument Tracks
To preview track presets for MIDI or instrument tracks and VST presets, you need some MIDI
notes. These notes can be sent to the track preset via MIDI Input, using a MIDI file, the Memo
Recorder mode, or via the computer keyboard.

On-Screen keyboard in keyboard display mode

1

Transport Controls
Allows you to start and stop the preview.

2

Previewer Sequence Mode Menu
Allows you to load a MIDI file to apply the selected preset to the MIDI file. You can also
select the Memo Recorder mode that continually repeats a given sequence of notes as a
loop.

3

Preview Level Fader
Allows you to specify the preview level.

4

On-Screen Keyboard
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You can display the On-Screen Keyboard in the keyboard display mode or in the piano
display mode.
5

Computer Keyboard Input
If this option is activated, you can use your computer keyboard to preview the presets.

RELATED LINKS
Previewing Presets Using the Memo Recorder Mode on page 626
On-Screen Keyboard on page 257

Previewing Presets Via MIDI Input
MIDI input is always active, for example, when a MIDI keyboard is connected to your computer
and set up properly, you can directly start playing the notes to preview the selected preset.

Previewing Presets Using a MIDI File
PROCEDURE
1.

On the Previewer Sequence Mode pop-up menu, select Load MIDI File.

2.

In the file dialog that opens, select a MIDI file and click Open.
The name of the MIDI file is displayed on the pop-up menu.

3.

Click Play to the left of the pop-up menu.

RESULT
The notes received from the MIDI file are played back with the settings of the track preset
applied.
NOTE
The recently used MIDI files are kept on the menu for quick access. To remove an entry from this
list, select it on the menu and then select Remove MIDI File.

Previewing Presets Using the Memo Recorder Mode
The Memo Recorder mode continually repeats a given sequence of notes as a loop.
NOTE
You cannot use the Memo Recorder mode when previewing presets using a MIDI file.

PROCEDURE
1.

On the Previewer Sequence Mode pop-up menu, select Memo Recorder.

2.

Activate Play.

3.

Play some notes on the MIDI keyboard or on the computer keyboard.

RESULT
The notes are played back with the instrument preset that is selected in the Results section.
When you stop playing notes and wait for 2 seconds, the note sequence that you played until this
moment is played back in a continuous loop.
To use another sequence, start entering notes again.
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Previewing Presets Via the Computer Keyboard
NOTE
If you activate Computer-Keyboard Input, the computer keyboard is used exclusively for the
Previewer section. However, you can still use the following key commands: Ctrl/Cmd-S (Save),
Num * (Start/Stop Record), Space (Start/Stop Playback), Num 1 (Jump to left locator), Delete or
Backspace, Num / (Cycle on/off), and F2 (Show/Hide Transport panel).

PROCEDURE
1.

Activate Computer-Keyboard Input.

2.

Play some notes on the computer keyboard.

Previewing Pattern Banks
Pattern banks containing drum patterns can be created with the MIDI plug-in Beat Designer.

1

Transport Controls
Allow you to start and stop the preview.

2

Preview Level Fader
Allows you to specify the preview level.

3

Keyboard
The keyboard allows you to preview the selected pattern bank. In the Previewer section,
choose a subbank (the number at the top) and pattern (a key), and click Play.
One pattern bank contains 4 subbanks which in turn contain 12 patterns each.
Subbanks can contain empty patterns. Selecting an empty pattern in the Previewer
section has no effect. Patterns containing data are indicated by a circle in the upper part of
the key in the display.

4

Auto Play New Results Selection
If this option is activated, the selected file is automatically played back.

NOTE
You can find detailed information on the Beat Designer and its functions in the separate
document Plug-in Reference in the MIDI Effects chapter.

Previewing Clip Packages
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1

Transport Controls
Allows you to start, stop, pause, and cycle the preview.

2

Preview Level Fader
Allows you to specify the preview level.

3

Auto Play New Results Selection
If this option is activated, any file that you select in the Results list is automatically played
back.

4

Align Beats to Project
If this option is activated, the selected file is played back in sync with the project, starting
at the project cursor position. Note that this can apply real-time time stretching to your
audio file.
NOTE
If you import an audio file into your project for which Align Beats to Project is activated in
the Previewer, Musical Mode is automatically activated for the corresponding track.

5

Wait for Project Play
If this option is activated, the play and stop functions from the Transport panel are
synchronized with the play and stop buttons in the Previewer section.
To use this option to its full extent, set the left locator at the beginning of a bar, then start
playing back the project using the Transport panel. The loops that you now select in the
Results list will start together with the project in perfect sync.

RELATED LINKS
Clip Packages on page 196

Filters Section
The MediaBay allows you to refine your file searches. You have two possibilities: Logical or
Attribute filtering. You can also save your filter settings in a MediaBay Aspect, which allows for a
quick recall of particular searches.
RELATED LINKS
MediaBay Aspects on page 642

Logical Filter
The logical filter allows you to set up complex search conditions that must be met to find files.
NOTE
The Logical Filter is not available in the Media rack in the right zone.

contains
The search result must contain the text or number specified in the text field to the
right.
matches words
The search result must match the words specified in the text field to the right.
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omits
The search result must not contain the text or number specified in the text field to
the right.
equals
The search result must correspond exactly to the text or number specified in the text
field to the right, including any file extension. Text searches are not case-sensitive.
>=
The search result must be higher than or equal to the number specified in the field
to the right.
<=
The search result must be lower than or equal to the number specified in the field to
the right.
is empty
Use this option to find files for which certain attributes have not been specified yet.
matches
The search result must include the text or number entered in the text field to the
right. You can also use boolean operators. Add apostrophes to find exact matches
for the entered words, for example, ‘drum’ AND ‘funky’. This option allows for a very
advanced text search.
range
If this option is selected, you can specify a lower and an upper limit for the search
result in the fields to the right.

Applying a Logical Filter
To quickly find certain audio files, you can search for a specific file attribute value, for example.
PREREQUISITE
In the Favorites section, select the defined Favorite in which you want to search for files.
PROCEDURE
1.

In the Filters section, activate Logical.

2.

Click Search in these Attributes to open the Select Filter Attributes dialog.

3.

Select the attributes that you want to use.
If you select more than one attribute, the files found match either one or the other
attribute.

4.

Click OK.

5.

On the condition pop-up menu, select one of the search operators.

6.

Enter the text or number that you want to find in the field to the right.
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NOTE
If you enter 2 or more strings or filter lines, the files that are found match all strings or
filter lines.
●

To add more than one string in the text field, enter a Space between them.

●

To add another filter line, click + to the right of the text field. You can add up to
seven filter lines in which you can define further search conditions.

●

To remove a filter line, click -.

●

To reset all search fields to their default settings, click Reset Filter in the top right
corner of the Filters section.

RESULT
The Results list is automatically updated, showing only the files that correspond to your search
conditions.

Advanced Text Search
You can perform advanced text searches using boolean operators.
PREREQUISITE
In the Favorites section, select the defined Favorite in which you want to search for files.
PROCEDURE
1.

In the Filters section, activate Logical.

2.

Select an attribute on the Select Filter Attributes pop-up menu or keep the Any
Attribute setting on.

3.

Set the condition to matches.

4.

Specify the text that you want to search for in the field to the right using boolean
operators.

RELATED LINKS
Performing a Text Search on page 621

Media File Attributes
Media file attributes are sets of meta data providing additional information on the file.
The different types of media files have different attributes. For example, .wav audio files have
attributes, such as name, length, size, sample rate, content set, etc., while .mp3 files have
additional attributes, such as artist or genre. In postproduction contexts, you would use
attributes like actor’s text, episode, pull factor, etc.
RELATED LINKS
Attribute Inspector on page 632

Attribute Filter
Assigning attribute values to your files facilitates organizing your media files. The Attribute filter
allows you to view and edit some of the standard file attributes that are found in your media files.
If you click Attribute, the Filters section displays all values that have been specified for the
displayed attribute categories. Selecting one of these values displays only the files to which this
attribute value is assigned.
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1

Attribute column titles
Allow you to select different attribute categories. If the columns are wide enough, the
number of files that match this criteria is displayed to the right of the value.

2

Attribute values
Displays the attribute values and how often a certain attribute value is available among
your media files.

NOTE
●

Some attributes are directly linked to each other. For example, for each category value,
there are certain sub-category values available. Changing the value in one of these
attribute columns displays different values in the other column.

●

Each attribute column displays only the attribute values that are found in the selected
location.

RELATED LINKS
Attribute Inspector on page 632

Applying an Attribute Filter
With the Attribute filter, you can quickly find tagged media files with certain attributes.
●

To apply an Attribute filter, select an attribute value.
The Results list is filtered accordingly. Apply more attribute filters to narrow down the
result even more.

●

To find files that match either one or the other attribute, Ctrl/Cmd-click different attribute
values in the same column.

●

To change the displayed attribute values of a column, click the attribute column title and
select another attribute.

NOTE
Character attributes always form an AND condition.

Performing a Context Menu Search
You can search for other files that have the same attribute as the selected file. This allows you to
find all the files that have a value in common, for example, if you want to view all the files that
were created on the same day.
●

In the Results list or the Attribute Inspector, right-click a file and select the attribute
value for which you want to search from the Search for submenu.
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The Filters section automatically switches to Logical filtering and the corresponding filter
condition line is displayed.
●

To reset the filter, click Reset Result Filters.

Resetting the Filter
PROCEDURE
●

To reset the filter, click Reset Filter at the top of the Filters section.

This also resets the Results list.

Attribute Inspector
When you have selected one or more files in the Results list, the Attribute Inspector shows a
list of attributes and their values.
NOTE
The Attribute Inspector is not available in the Media rack in the right zone.
In the Attribute Inspector, you can also edit and add new attribute values.
The available attributes are divided into several groups (Media, Musical, Preset, etc.), to keep the
list manageable and to facilitate finding items.

Dynamic
Displays all available values for the selected files.
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Defined
Displays a configured set of attributes for the selected media type regardless of
whether corresponding values are available for the selected files.
Configure Defined Attributes
Activates the configuration mode, in which you can set up the attributes that are
displayed in the Attribute Inspector.

Configuration Mode
When you click Configure Defined Attributes, the configuration mode is enabled.

Select Media Types
Allows you to select one or several media types. You can then manage which
attributes are displayed in the Attribute Inspector for the selected media types.
+/Opens the Add User Attribute dialog, where you can add or remove custom user
attributes. You can select the Attribute Type and the Display Name.
Reset to Default
Resets the attribute list to the default settings.
Attribute
Shows the attribute name.
Select
Shows whether an attribute is activated or deactivated.
Type
Shows whether the value for an attribute is a number, text, or a Yes/No switch.
Precision
Shows the number of decimals displayed for number attributes.
RELATED LINKS
Media File Attributes on page 630
Managing Attribute Lists on page 636

Color Legend in the Attribute Inspector
The color of an attribute value indicates if and in which form you can edit an attribute.
White
One or more files are selected in the Results list, and they have the same values.
Yellow
Multiple files are selected in the Results list, and their values differ.
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Orange
Multiple files are selected in the Results list, with differing values, and they cannot
be edited.
Red
One or more files are selected in the Results list, and their values cannot be edited.

Information on the meaning of the colors that are used in the Attribute Inspector is also
displayed in a tooltip when you move the mouse pointer over one of the color icons below the
Attribute Inspector.

Editing Attributes
The search functions, especially the attribute filter, are a powerful media management tool when
making extensive use of tagging, that is, when adding and editing attributes.
Media files are usually organized in complex folder structures to provide a logical way of guiding
the user to certain files, with the folder and/or file names indicating the sound, recording
location, etc.
Tags help you to find a particular sound or loop in such a folder structure.

Editing Attributes in the Attribute Inspector
In the Attribute Inspector, you can edit attribute values of the various media files. Attribute
values can be chosen from pop-up lists, entered as text or numbers, or set to Yes or No.
NOTE
●

Changing an attribute value in the Attribute Inspector permanently changes the
corresponding file unless the file is write-protected or part of a VST Sound archive.

●

Some attributes cannot be edited. In this case, the file format probably does not permit
changing this value, or changing a particular value makes no sense. For example, you
cannot change the file size in the MediaBay.

PROCEDURE
1.

In the Results list, select the file for which you want to make settings.
The corresponding attribute values are displayed in the Attribute Inspector.
You can also select several files and make settings for them simultaneously. The only
exception is the name attribute, which must be unique for every file.

2.

In the Attribute Inspector, click in the Value column for an attribute.
Depending on the selected attribute, the following happens:

3.

●

For most of the attributes, a pop-up menu opens from which you can choose a
value. Some of the pop-up menus also have a “more…” entry to open a window with
more attribute values.

●

For the Rating attribute, you can click in the Value column and drag left or right to
modify the setting.

●

For the Character attribute (Musical group), the Edit Character dialog opens. To
define values, click a radio button on the left or the right side and then click OK.

Set the attribute value.
To remove the attribute value from the selected files, right-click in the corresponding
Value column and select Remove Attribute from the context menu.
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Editing Attributes in the Results List
You can edit attributes directly in the Results list. This allows you to assign attributes to a
number of loop files, for example.
PREREQUISITE
Allow Editing in Results List must be activated in the MediaBay Settings.
PROCEDURE
1.

In the Results list, select the files for which you want to make settings.
You can make settings for several files simultaneously, except for the attribute name,
which must be unique for every file.

2.

Click in the column for the value that you want to change and make the settings.

RELATED LINKS
MediaBay Settings on page 645

Editing Attributes of Multiple Files Simultaneously
You can edit attributes for multiple files at the same time.
NOTE
If you edit a large number of files simultaneously, the processing of your edits may take some
time.
Editing attributes is executed in the background so that you can continue with your work as
usual. The Attribute Counter above the Results list displays how many files are still being
updated.

Editing Attributes of Write-Protected Files
Media files can be write-protected due to a number of reasons: the content could have been
provided by someone who write-protected the files, the file format could restrict write operations
by the MediaBay, etc.
In the MediaBay, the write protection status of files is shown as an attribute in the Attribute
Inspector and in the Write Protection column in the Results list.

IMPORTANT
You can define attribute values of write-protected files in the MediaBay. These changes are only
saved in the MediaBay database file, they are not saved to disk. This means that if you delete
your program preferences, these changes are lost.
NOTE
If the Write Protection and/or the Pending Tags columns are not visible, activate the
corresponding attributes for the file type in the Attribute Inspector.
●

To set or remove the write protection attribute for a file, right-click the file in the Results
list and select Set/Remove Write Protection.

635

MediaBay
MediaBay Window
This is only possible if the file type allows write operations and if you have the necessary
operating system permission.
●

When you specify attribute values for a file that is write-protected, this is reflected in the
Pending Tags column next to the Write Protection column in the Results list.
If you rescan the MediaBay content and a media file on your hard disk has changed since
the last scan, the pending tags for this file will be lost.

●

If a file has pending tags, and you want to write the corresponding attributes to the file,
you must remove the write protection, then right-click the file, and select Write Tags to
File.

NOTE
If you use other programs than Nuendo to change the write-protection status of files, you must
rescan the files in the MediaBay to reflect these changes.

RELATED LINKS
Disabling the Preferences on page 1174
Editing Attributes on page 634

Managing Attribute Lists
In the Attribute Inspector, you can define which attributes are displayed in the Results list and
in the Attribute Inspector itself. For different media types, you can configure individual attribute
sets.
PROCEDURE
1.

In the Attribute Inspector, click Defined.

2.

Click Configure Defined Attributes to enter configuration mode.

3.

Open the Show pop-up menu, activate the media types that you want to display, and click
anywhere in the MediaBay.

The Attribute Inspector now shows a list of all attributes available for these media types.

4.

●

If you have activated more than one media type, your settings affect all selected
types. An orange checkmark indicates that the current display settings for an
attribute differ for the selected media types.

●

The display settings made for the Mixed Media Types option are applied if you
select files of different media types in the Results list or in the Attribute Inspector.

Activate the attributes that you want to be displayed.
You can edit several attributes simultaneously.

5.

Click Configure Defined Attributes again to exit the configuration mode.
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Defining User Attributes
You can define your own attributes and save these in the MediaBay database and the
corresponding media files. Nuendo recognizes all user attributes that are included in media files.
PROCEDURE
1.

In the Attribute Inspector, activate Defined.

2.

Click Configure Defined Attributes to enter configuration mode.

3.

Click +.

4.

In the Add User Attribute dialog, specify the Attribute Type and the Display Name.
The display name must be unique in the attribute list. The Database Name field indicates
if a certain name is valid or not.

5.

Click OK.

RESULT
The new attribute is added to the list of available attributes and is displayed in the Attribute
Inspector and the Results list.

Working with the MediaBay
When you work with many music files, the MediaBay helps you to find and organize your
content. After scanning your folders, all found media files of the supported formats are listed in
the Results section.
You can set up Favorites, that is, folders or directories on your system that contain media files.
Usually, files are organized in a specific way on your computer. You might have folders reserved
for audio content, folders for special effects, folders for combinations of sounds making up the
ambience noise that you need for a certain film take, etc. These can all be set as different
Favorites in the MediaBay, allowing you to limit the files available in the Results list according
to context.
By using the search and filter options, you can narrow down the results.
You can insert the files into your project by using drag & drop, by double-clicking, or by using the
context menu options.

Using Media Files
The MediaBay window and the Media rack in the right zone of the Project window offer you
multiple possibilities to search for specific files, loops, samples, presets, and patterns that you
can use in your project.
Once you have found the media files that you were looking for, you can load them into your
project.

Loading Loops and Samples
PROCEDURE
1.

Do one of the following:
●

In the MediaBay, open the media types selector, click MIDI Files, Audio Files, or
MIDI Loops, and select a media file.
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●
2.

In the Media rack in the right zone, click the Loops & Samples tile, and click the
following tiles until you can select the media files in the Results list.

Do one of the following:
●

Double-click a media file to create a new instrument or an audio track with the
loaded file.

●

Drag the media file and insert it on a track in the event display.

RESULT
The media file is inserted on the new track or at the insert position.
RELATED LINKS
Show Media Types Selector on page 620

Loading Track Presets
PROCEDURE
1.

2.

Do one of the following:
●

In the MediaBay, open the media types selector, click Track Presets, and select a
preset.

●

In the Media rack in the right zone, click Presets > Track Presets, and click the
following tiles until you can select the preset in the Results list.

Do one of the following:
●

Double-click the track preset to create a new track with the loaded preset.

●

Drag the track preset and insert it on a track to apply the preset to the track.

RESULT
The preset is applied to the track, and all settings of the preset are loaded.
RELATED LINKS
Show Media Types Selector on page 620

Loading Instrument Presets
PROCEDURE
1.

2.

Do one of the following:
●

In the MediaBay, open the media types selector, click Plug-in Presets, and select a
preset for an instrument plug-in.

●

In the Media rack in the right zone, click the Instruments tile, and click the
following tiles until you can select the preset in the Results list.

Do one of the following:
●

Double-click the instrument preset to create a new instrument track with the loaded
instrument preset.

●

Drag the instrument preset and drop it on the track list to create a new instrument
track with the loaded instrument preset.

●

Drag the instrument preset and drop it in the event display to create a new
instrument track with the loaded instrument preset.

●

Drag the instrument preset and drop it on an instrument track to apply the preset to
the track.
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RESULT
The instrument is loaded as a track instrument, and the preset is applied to the instrument track.
RELATED LINKS
Show Media Types Selector on page 620

Loading Effect Plug-In Presets
PROCEDURE
1.

Do one of the following:
●

In the MediaBay, open the media types selector, click Plug-in Presets, and select a
preset.

●

In the Media rack in the right zone, click Presets > VST FX Presets, and click the
following tiles until you can select the preset in the Results list.

2.

In the Project window, select an audio track.

3.

Drag the plug-in preset from the MediaBay and insert it on the open Inserts section of
the Inspector.

RESULT
The effect plug-in preset is applied to the audio track and the settings are loaded.
RELATED LINKS
Show Media Types Selector on page 620

Loading FX Chain Presets
PROCEDURE
1.

Do one of the following:
●

In the MediaBay, open the media types selector, click FX Chain Presets, and select
a preset.

●

In the Media rack in the right zone, click Presets > FX Chain Presets, and click the
following tiles until you can select the preset in the Results list.

2.

In the Project window, select an audio track.

3.

Drag the preset from the MediaBay and drop it on the open Inserts section of the
Inspector.

RESULT
The FX Chain Preset is applied to the track, and all settings of the preset are loaded. Any inserts
that have previously been loaded are overwritten.
RELATED LINKS
Show Media Types Selector on page 620

Loading Strip Presets
PROCEDURE
1.

Do one of the following:
●

In the MediaBay, open the media types selector, click Strip Presets, and select a
preset.
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●

In the Media rack in the right zone, click Presets > Strip Presets, and click the
following tiles until you can select the preset in the Results list.

2.

In the Project window, select an audio track.

3.

Drag the preset from the MediaBay and drop it on the open Strip section of the
Inspector.

RESULT
The strip preset is applied to the track, and all settings of the preset are loaded.
RELATED LINKS
Show Media Types Selector on page 620
Saving/Loading Strip Presets on page 407

Loading Pattern Banks
PROCEDURE
1.

2.

Do one of the following:
●

In the MediaBay, open the media types selector, click Pattern Banks, and select a
preset.

●

In the Media rack in the right zone, click Presets > Pattern Banks, and click the
following tiles until you can select the preset in the Results list.

Do one of the following:
●

Double-click the pattern bank to create a new instrument track with the loaded
preset.

●

Drag the pattern bank and drop it on an instrument track to apply the pattern bank
to the track.

●

Drag the pattern bank and drop it on the track list to create a new instrument track
with the loaded pattern bank.

RESULT
Groove Agent is loaded as a track instrument. A drum map is loaded for the instrument track,
and an instance of the Beat Designer is loaded as an insert effect.
RELATED LINKS
Show Media Types Selector on page 620

Working with MediaBay-Related Windows
The MediaBay concept can be found throughout the program, for example, when you add new
tracks or when you choose presets for VST instruments or effects. The workflow in all MediaBayrelated windows is the same as in the MediaBay.

Adding Tracks
If you add a track by selecting Project > Add Track, the following dialog opens:

Click Browse to expand the dialog to show the Results list. Only file types that can be used in this
context are shown.
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Applying Track Presets
You can choose from a variety of track presets.
PROCEDURE
1.

In the Inspector, click the Preset Management icon on the right of the Inserts section.

2.

Select From Track Preset.

3.

In the Results browser, double-click a track preset to apply it.

RELATED LINKS
Track Presets on page 188

Applying Instrument Presets
When working with VST instruments, you can choose from a variety of presets via the Results
browser.
PROCEDURE
1.

In the track list, right-click the instrument track and select Load Track Preset.

2.

In the Results browser, double-click a preset to apply it.

Instrument Presets Results Browser
The Results browser for instrument track presets allows you to preview VST presets and apply
them to your instrument track.
To open the Results browser, right-click an instrument track, and select Load Track Preset.
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VST presets for instruments can be divided into the following groups:
Presets
Presets contain the settings of the entire plug-in. For multi-timbral instruments, this
includes the settings for all sound slots as well as the global settings.
Programs
Programs contain only the settings for one program. For multi-timbral instruments,
this includes only the settings for one sound slot.

MediaBay Aspects
You can create configurations of the MediaBay window and save them as aspects. These can be
recalled via the Media menu.
This is helpful if you only want to work with certain sound effect files that reside in a particular
location, for example. Every item in the MediaBay that can be configured can be part of a
MediaBay aspect. You can specify which sections are visible, which media types are browsed for,
which locations are being scanned, and so on. You can also enter a search string and save it with
the aspect.

Creating a New Aspect
PROCEDURE
1.
2.

Select Media > MediaBay Aspects > New Aspect.
In the Add MediaBay Aspect dialog, enter the name for the new aspect and click OK.
The new MediaBay aspect window opens.

3.

Configure the MediaBay window to your liking.

RESULT
The MediaBay aspect is automatically saved when you close the window or the program. Once
the aspect is created, you can access it via the Media menu.
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Creating a New Aspect Based on an Existing Aspect
You can create a new MediaBay aspect that is based on an existing aspect.
PROCEDURE
1.
2.

Select Media > MediaBay Aspects > Duplicate Aspect and select the aspect that you want
to duplicate.
In the Add MediaBay Aspect dialog, enter the name for the new aspect and click OK.
The new MediaBay aspect window opens.

3.

Configure the MediaBay window to your liking.

RESULT
The MediaBay aspect is automatically saved when you close the window or the program. Once
the aspect is created, you can access it via the Media menu.

Removing MediaBay Aspects
PROCEDURE
●

Select Media > MediaBay Aspects > Remove Aspect.

Working with Volume Databases
Nuendo saves all media file information that is used in the MediaBay, such as paths and
attributes, in a local database file on your computer. However, in some cases, it might be
necessary to browse and manage this kind of metadata on an external volume.
For example, a sound editor might have to work both at home and in a studio, on two different
computers. Therefore, the sound effects are stored on an external storage medium. To be able to
connect the external device and directly browse its contents in the MediaBay without having to
scan the device, you have to create a volume database for the external device.
Volume databases can be created for your computer drives or for external storage media. They
contain the same kind of information about the media files on these drives as the regular
MediaBay database.
NOTE
When you launch Nuendo, all available volume databases are automatically mounted. Databases
that are made available while the program is running have to be mounted manually.

Rescanning Volume Databases
If you have modified the data on your external volume on a different system, you must rescan
the MediaBay.
RELATED LINKS
Refresh Views on page 617

Creating a Volume Database
PROCEDURE
●

In the File Browser section, right-click the external storage medium, drive, or partition of
your computer system for which you want to create a database, and select Create Volume
Database.
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IMPORTANT
You must select the topmost directory level for this. You cannot create a database file for a
lower-level folder.

RESULT
The file information for this drive is written into a new database file. When the new database file
is available, this is reflected by the symbol to the left of the drive name.

NOTE
If the drive contains a large amount of data, this process may take some time.
Volume databases are automatically mounted when Nuendo is launched. They are shown in the
File Browser section and their data can be viewed and edited in the Results list.

Removing a Volume Database
If you have worked on another computer using an external hard disk and return to your own
computer and connect the external device again as part of your system setup, you no longer
need a separate volume database for it. Any data on this drive can be included in the local
database file again, by removing the extra database file.
PROCEDURE
●

In the File Browser section, right-click the volume database and select Remove Volume
Database.

RESULT
The metadata is integrated in the local MediaBay database file, and the volume database file is
deleted.
NOTE
If the drive contains a large amount of data, this process may take some time.
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Mounting and Unmounting Volume Databases
Volume databases that are made available while Nuendo is running must be mounted manually.
●

To mount a volume database manually, right-click the external storage medium, drive, or
partition of your computer system that you want to mount and select Mount Volume
Database.

●

To unmount a volume database, right-click it and select Unmount Volume Database.

MediaBay Settings
●

To open a pane with settings for the MediaBay, click MediaBay Settings in the lower left
corner of the MediaBay.

Hide Folders That Are Not Scanned
If this option is activated, all folders that are not scanned for files are hidden. This
keeps the tree view in the File Browser less cluttered.
Show Only Selected Folder
If this option is activated, only the selected folder and its subfolders are shown.
Scan Folders Only When MediaBay Is Open
If this option is activated, Nuendo only scans for media files when the MediaBay
window is open.
If this option is deactivated, the folders are scanned in the background even when
the MediaBay window is closed. However, Nuendo never scans folders while playing
back or recording.
Maximum Items in Results List
Specifies the maximum number of files that are displayed in the Results list. This
avoids unmanageably long lists of files.
NOTE
The MediaBay does not warn you if the maximum number of files has been reached.
There might be situations where a certain file cannot be found because the
maximum number of files was reached.
Allow Editing in Results List
If this option is activated, you can edit attributes in the Results list. If this option is
deactivated, attributes can only be edited in the Attribute Inspector.
Show File Extensions in Results List
If this option is activated, file name extensions are displayed in the Results list.
Scan Unknown File Types
When scanning for media files, the MediaBay ignores files with an unknown file
extension. If this option is activated, the MediaBay tries to open and scan any file in
the search location and ignores those files that cannot be recognized.
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MediaBay Key Commands
You can display the available MediaBay key commands from within the MediaBay window. This
is useful if you want to get a quick overview over the assigned and the available MediaBay key
commands.
●

To open the key commands pane, click Key Commands in the lower left corner of the
MediaBay.

●

To close the key commands pane, click anywhere outside of the pane.

●

To assign or modify a key command, click the corresponding key command.

RELATED LINKS
Key Commands on page 1137
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Nuendo provides integrated surround sound features with support for several formats. All audiorelated channels and busses can handle multi-channel speaker configurations. A channel in the
MixConsole can contain either complete surround mixes or an individual speaker channel which
is part of a surround setup.
Nuendo offers the following surround-related features:
●

You can route audio-related tracks, that is audio, instrument, and sampler tracks, to
surround channels.

●

The VST MultiPanner plug-in is automatically applied to audio-related tracks with a
supported surround configuration, and to output channels with any kind of multi-channel
configuration other than stereo. The VST MultiPanner plug-in is available in the Inspector
and MixConsole and can be used to position channels in the surround field.

●

Support for 3D surround format mixing.
For Dolby Atmos®, you can create channel-based 9.1 bed mixes as well as object-based
mixes.
NOTE
Object-based mixing for Dolby Atmos requires a connection to a Dolby Rendering and
Mastering Unit (RMU).
For virtual reality (VR) or augmented reality (AR) productions, you can create mixes in firstorder, second-order, and third-order Ambisonics format. Nuendo allows you to monitor
Ambisonics mixes on headphones or multi-channel speaker setups, and supports VR
controllers and head-mounted displays when working with 360° video.

●

Third-party panner plug-ins are supported.

●

The IOSONO Anymix Pro plug-in can be used as an alternative to the default surround
panner, the VST MultiPanner. For detailed information about Anymix Pro, see the
separate document Plug-in Reference.

●

The MixConvert V6 plug-in is used to convert a surround channel into a different format if
the corresponding input/output configuration is not handled by VST MultiPanner.
Nuendo places MixConvert V6 automatically where needed.

●

Plug-ins with multi-channel support specifically designed for surround sound mixing tasks
are supported, for example, the Mix6to2 plug-in. Furthermore, any VST 3 plug-in features
multi-channel support and can therefore be used in a surround configuration, even if it
was not specifically designed for surround. For detailed information about all included
plug-ins, see the separate document Plug-in Reference.

●

You can export surround mixes in different formats using the Export Audio Mixdown
function.

RELATED LINKS
Preparations for Creating Surround Mixes on page 651
VST MultiPanner on page 654
3D Mixes for Dolby Atmos on page 676
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3D Mixes for Ambisonics on page 683
Switching the Channel Panner on page 671
MixConvert V6 on page 671
Insert Effects in Multi-Channel Configurations on page 448
Surround Mix Export on page 676

Deliverables
A surround mix in Nuendo can be sent as multi-channel audio from the surround output bus to a
recorder, or can be exported to audio files on your hard disk.
Exported surround mixes can either be split to one mono file per speaker channel, or interleaved
to a single file containing all the surround channels.
RELATED LINKS
Export Audio Mixdown on page 1007

Available Surround Channel Configurations
Nuendo supports several 2D and 3D surround channel configurations.
The following surround channel configurations are supported:
LRC
This format uses the channels left, right, and center.
Quadro
This is the original quadraphonic format for music, with one speaker in each corner.
This format was intended for vinyl record players.
5.1
This format, also referred to as Dolby Digital, AC-3, DTS and MPEG 2 Multichannel,
uses the front channels left, center, and right, the surround channels left and right,
and an additional LFE (Low Frequency Effects) channel.
The center channel is mainly used for speech, the front and surround channels left
and right for music and sound effects, and the LFE channel for boosting lowfrequency content.
7.1 Music (Dolby)
This format, also referred to as Dolby 7.1, uses the front channels left, center, and
right, the side channels left and right, the surround channels left and right, and an
LFE channel.
9.1 Dolby Atmos
This format, also referred to as Dolby Atmos 7.1.2, is used for channel-based bed
mixes for 3D Dolby Atmos® mixes. In addition to the front channels left, center, and
right, the side channels left and right, the surround channels left and right, and an
LFE channel, the 9.1 Dolby Atmos speaker setup provides top channels left and right.
10.0 to 13.1 Auro – 3D
The Auro formats are surround formats, in which the channels are arranged on 2
levels, thereby creating a 3D effect. The Auro formats are available with and without
LFE channels.
7.1.4
This format is used for channel-based bed mixes for 3D mixes. In addition to the
front channels left, center, and right, the side channels left and right, the surround
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channels left and right, and an LFE channel, this speaker setup provides top front
channels left and right and top back channels left and right.
5.0.4
This format is used for channel-based bed mixes for 3D mixes. In addition to the
front channels left, center, and right, and the surround channels left and right, this
speaker setup provides top front channels left and right and top back channels left
and right.
5.1.4
This format is used for channel-based bed mixes for 3D mixes. In addition to the
front channels left, center, and right, the surround channels left and right, and an
LFE channel, this speaker setup provides top front channels left and right and top
back channels left and right.
5.0
This format uses the front channels left, center, and right, and the surround
channels left and right.
7.1 Cine (SDDS)
This format uses the front channels left, left center, center, right center, and right,
the surround channels left and right, and an LFE channel. This arrangement is used
in the Sony Dynamic Digital Sound (SDDS) format.
7.0 Cine (SDDS)
This format uses the front channels left, left center, center, right center, and right,
and the surround channels left and right. This arrangement is used in the Sony
Dynamic Digital Sound (SDDS) format.
7.0 Music (Dolby)
This format uses the front channels left, center, and right, the surround channels left
and right, and the side channels left and right.
7.1 Proximity (IOSONO)
This format uses the front channels left, center, and right, the surround channels left
and right, an LFE channel, and additional Proximity channels left and right.
NOTE
For detailed information about the Proximity format, see the chapter “Anymix Pro” in
the separate document Plug-in Reference.
6.0 Cine
This format uses the front channels left, center, and right, and the surround
channels left, center, and right.
6.0 Music
This format uses the front channels left and right, the surround channels left and
right, and the side channels left and right.
6.1 Cine
This is the same format as 6.0 Cine but with an LFE channel added. This channel
configuration is used in the Dolby Digital EX and DTS-ES formats.
6.1 Music
This is the same format as 6.0 Music but including an LFE channel.
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22.2
This format allows for creating 3D mixes for ultra-high-definition television formats.
It uses 22 channels arranged in 3 layers (9 upper layer channels, 10 middle layer
channels, 3 lower layer channels) plus 2 LFE channels.
1st Order Ambisonics/2nd Order Ambisonics/3rd Order Ambisonics
These 3D formats allow for creating a spherical sound field. They use an encoded
bundle of audio signals to position sound sources at any place in the sound sphere.
The available Ambisonics formats differ in the number of audio signals that are used.
Higher-order Ambisonics provide more signals and allow for a higher precision of
positioning.
LRCS
This format uses the channels left, right, center, and surround. The surround channel
is center-rear positioned. This is the original surround format that first appeared as
Dolby Stereo in cinema and later as the home cinema format Dolby ProLogic.
LRCS+LFE
This is the same format as LRCS but with an additional LFE channel.
Quadro+LFE
This is the same format as Quadro but with an additional LFE channel.
LRS
This format uses the channels left, right, and surround. The surround channel is
positioned at center-rear.
LRC+LFE
This is the same format as LRC but with an additional LFE channel.
LRS+LFE
This is the same format as LRS but with an additional LFE channel.
8.0 Cine
This is the same format as 7.0 Cine but including a center surround channel.
8.0 Music
This is the same format as 7.0 Music but including a center surround channel.
8.1 Cine
This is the same format as 8.0 Cine but including an LFE channel.
8.1 Music
This is the same format as 8.0 Music but including an LFE channel.
10.2 Experimental
This is an experimental format with 10 surrounding speakers and 2 LFE channels (2
combined 5.1 setups, 1 at the top and 1 at the bottom of the room).
IMPORTANT
In Nuendo, the order of surround busses and side busses follows the specification of Microsoft
Inc. To meet the Dolby specification for side surround busses and surround rear busses, swap
the device ports of surround busses and side busses.

RELATED LINKS
3D Mixes for Dolby Atmos on page 676
3D Mixes for Ambisonics on page 683
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Preparations for Creating Surround Mixes
You must prepare Nuendo for surround sound by defining input and output busses in a
surround format and specifying which audio inputs and outputs are used for the different
channels in the busses.

Output Bus Configuration
Before you can start working with surround sound, you must configure a surround output bus
through which all the speaker channels of the selected surround format are routed.

Output bus in 5.1 channel configuration

RELATED LINKS
Adding Input and Output Busses on page 29

Child Busses
Child busses allow you to route tracks to particular channels within a surround bus. Creating
stereo busses within your surround bus allows you to route stereo tracks directly to a pair of
stereo speakers. You can also add child busses in other surround formats with fewer channels
than the parent bus.
●

Once you have created a surround bus, you can add one or several child busses to it by
right-clicking the bus and selecting Add Child Bus.

651

Surround Sound
Preparations for Creating Surround Mixes

Output bus in 5.1 channel configuration with stereo child bus

RELATED LINKS
Adding Child Busses on page 29

Surround Routing
The processing format of VST MultiPanner depends on the channel routing. You can use the
Routing and the Direct Routing racks in the MixConsole to route audio-related tracks to output
busses or group channels with a surround configuration.

For example, if a mono source channel is routed to a 5.1 bus, the panner works in 5.1 mode. For
channel-based 3D mixing, the source channel must be routed to an output bus that provides top
channel speakers.
RELATED LINKS
VST MultiPanner on page 654
Routing on page 393
Setting Up Direct Routing on page 409
Routing Channels for 9.1 Dolby Atmos Bed Mixing on page 676
Setup for Object Mixing on page 678
Channel Routing for Ambisonics Mixes on page 684
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Routing Channels to Individual Surround Channels
If you want to place an audio source in one separate speaker channel, you can route it directly to
that speaker channel. This is useful for premixed material or multi-channel recordings that do
not require panning.
●

To route a channel to an individual surround channel, select the corresponding output bus
of that speaker channel in the Routing rack.

NOTE
If a stereo audio channel is routed directly to a speaker channel, the left and the right channels
are mixed to mono. The pan control for the audio channel determines the balance between the
left and the right channel in the resulting mono mix. Center pan produces a mix of equal
proportion.

Routing Channels to Child Busses
If you add a child bus within a surround bus, it appears as a subentry of the surround bus on the
routing selector. Select this option to route a stereo audio channel directly to that stereo speaker
pair of the surround bus, for example, to route a music track directly to the left and right front
speakers in a surround channel.

RELATED LINKS
Child Busses on page 651
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Input Bus Configuration
In most cases you do not need to configure a surround format input bus in order to work with
surround sound in Nuendo. You can record audio files via standard inputs, and easily route the
resulting audio channels to surround outputs at any stage. You can also directly import multichannel files of a specific surround format to audio tracks of the same format.
However, you must add a surround input bus in the following cases:
●

You have existing audio material in a specific surround format, and you want to transfer
this material to Nuendo as a single, multi-channel file.

●

You want to make a live recording with a surround setup.

●

You have prepared surround premixes, for example, stems, that you want to record on a
new audio track with a surround configuration.

RELATED LINKS
Importing Audio Files on page 277
Adding Input and Output Busses on page 29

VST MultiPanner
The VST MultiPanner plug-in allows you to position a sound source in the surround field or to
modify existing premixes. The plug-in distributes the incoming audio in various proportions to
the output surround channels.
In the pan area, the sound sources are shown as blue panning balls. In stereo or multi-channel
configurations, the left and right front channels are shown as a yellow and a red ball. You can
position the sound sources within the room by dragging the panning balls.
To perform rotating movements that you cannot achieve by dragging, you can use the rotation
and orbit controls below the pan area. To adjust the size of the sound source, use the controls for
distributing the signal to the different speaker channels and for advanced scaling.
For 3D channel configurations and Ambisonics audio, VST MultiPanner offers additional settings
and an additional 3D pan area.
NOTE
Whether you can use VST MultiPanner for a specific input/output configuration depends on
whether this configuration can be mapped by the panner.

RELATED LINKS
VST MultiPanner Plug-in Panel on page 655
Position of the Sound Source on page 662
VST MultiPanner Plug-in Panel for 3D Channel Configurations on page 658
VST MultiPanner Plug-in Panel in Ambisonics Mode on page 685
MixConvert V6 on page 671

Constant Power Panning
VST MultiPanner uses constant power panning laws. This means that the power of a source
channel is identical to the power of the corresponding output signal.
Constant power laws ensure that the overall volume as perceived by the listener is always the
same, regardless of the signal panning, This allows you to move the sound source in the pan
area, disable specific speaker channels, or use the divergence controls without experiencing any
volume changes.
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VST MultiPanner Plug-in Panel
The VST MultiPanner plug-in panel allows you to position any supported mono, stereo, or multichannel sound source.

●

To open the VST MultiPanner plug-in panel in a separate window, double-click a miniature
view of VST MultiPanner in the Inspector or the MixConsole.

The following settings and options are available:
Bed Mode
Sets the panner to bed mode. This mode allows you to create the channel-based bed
mix.
Object Mode
Sets the panner to object mode. This mode allows you to create mixes for audio
objects when working with a Dolby RMU.
NOTE
If VST MultiPanner is used as an insert plug-in, Object Mode is not available.
Movement restriction buttons
Allow you to restrict the movement to one axis when moving the sound source with
the mouse.
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NOTE
●

The movement restrictions only affect the graphic presentation in the two pan
areas. This means, activating Vertical Movements Only allows movements
only on the y-axis in the Top View area, and movements only on the z-axis in
the Rear View area.

●

The movement restriction buttons do not affect the controls in the positioning
section below the pan area.

Reset Parameters
Alt-click this button to reset all panner parameters to their default values.
Input level meter
Shows the input level for all speaker channels. The numeric values above the meters
indicate the peak levels registered for the channels.
Position Left/Right Channels Independently
Activate this option to adjust the front left and right input channels independently by
dragging.
Top View
Shows the room from the top and allows you to position the sound source by
dragging the panning balls.
To zoom out of the pan area, activate Overview Mode.
Speaker channel buttons
The speaker buttons around the pan area represent the output configuration. The
buttons allow you to solo, mute, and disable the corresponding channels.
NOTE
You cannot automate the soloing of output channels.
Output level meter
Shows the output level for all speaker channels. The numeric values above the
meters indicate the peak levels registered for the channels.
Left-Right Pan
Sets the position of the signal on the x-axis.
Rear-Front Pan
Sets the position of the signal on the y-axis.
Rotate Signal around Z-Axis
Rotates the sound source around its positioning handle. This option is only available
for stereo and multi-channel signals.
Orbit Center
Rotates the sound source including all input channels and the positioning handle
signal around the center of the room.
Click Counter Shot to rotate the sound source by exactly 180 degrees.
Radius
Sets the distance of the sound source from the center of the room when using Orbit
Center.
Center Distribution
Distributes part or all of the center signal to the left and right front speakers.
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NOTE
If Front Divergence is set to 100 %, Center Distribution has no effect.
Front Divergence
Determines the attenuation curve that is used when positioning the sound source on
the front x-axis.
Front/Rear Divergence
Determines the attenuation curve that is used when positioning the sound source on
the y-axis.
Rear Divergence
Determines the attenuation curve that is used when positioning the sound source on
the rear x-axis.
Signal Width
Sets the expansion of the sound source on the x-axis. This parameter is only
available for channels with stereo or multi-channel output configurations.
Signal Depth
Sets the expansion of the sound source on the y-axis. This parameter is only available
for channels with multi-channel output configurations.
LFE Level
Sets the signal amount that is sent to the LFE (Low Frequency Effects) channel.
●

If the selected input already contains an LFE channel (x.1 configuration), it is
routed through VST MultiPanner, and LFE Level is used to control the volume
of this channel.

●

If the selected input does not contain an LFE channel (x.0 configuration), all
input channels are distributed evenly to the output LFE channel. In this case, it
might be useful to raise the volume of this downmix using LFE Level.

NOTE
The LFE channel is used as a full range channel, no low-pass filtering is applied.

RELATED LINKS
Movement Restriction Modes on page 663
Overview Mode on page 665
Soloed, Muted, and Disabled Speaker Channels on page 669
Pan Controls on page 665
Rotate and Tilt Controls on page 666
Orbit Controls on page 666
Center Distribution on page 667
Divergence Controls on page 667
Scale Controls on page 668
VST MultiPanner Plug-in Panel for 3D Channel Configurations on page 658
VST MultiPanner Plug-in Panel in Ambisonics Mode on page 685
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VST MultiPanner Plug-in Panel for 3D Channel Configurations
The VST MultiPanner plug-in panel offers additional settings and a 3D pan area for channels
that are routed to an output bus or group channel with a 3D channel configuration such as 9.1
Dolby Atmos.

●

To access these settings, click Show/Hide Extended Display .

Elevation Pattern buttons
Allow you to activate/deactivate predefined elevation patterns for the height
parameter.
If no elevation pattern is active, you can adjust Bottom-Top Pan manually.
Top View
Shows the room from the top. The position on the z-axis is represented by the size of
the panning balls: the bigger the panning ball, the higher the sound source is
positioned in the room. To adjust the position on the z-axis, middle-click and drag.
Rear View
Shows the room from the rear and allows you to position the sound source on the xaxis and z-axis by dragging the panning balls. The position on the y-axis is
represented by the size of the panning balls: the bigger the panning ball, the nearer
the sound source is positioned to the rear of the room. To adjust the position on the
y-axis, middle-click and drag.
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Bottom-Top Pan
Sets the position of the signal on the z-axis. If you move this control all the way to the
right, the sound comes from the top speakers only.
Elevation On/Off
Activates/Deactivates the height parameter.
NOTE
If elevation is deactivated, Bottom-Top Pan is set to bottom, even if automation for
bottom-top panning is present. Elevation On/Off can also be automated.
Tilt Signal around Y-Axis
Tilts the sound source around its own y-axis. This option is only available for stereo
and multi-channel signals.
Tilt Signal around X-Axis
Tilts the sound source around its own x-axis. This option is only available for stereo
and multi-channel signals.
Height Divergence
Determines the attenuation curve that is used when positioning sound sources on
the z-axis.
RELATED LINKS
VST MultiPanner Plug-in Panel on page 655
3D Mixes for Dolby Atmos on page 676
Elevation Patterns for 3D Mixing on page 668
Pan Laws for 3D Mixing on page 669
Divergence Controls on page 667

Miniature Views
In the MixConsole, in the Channel Settings window, and in the Inspector, miniature views of
VST MultiPanner allow basic panning operations.
While you must open the plug-in panel to access all of the panner features, you can perform
basic panning operations also in the following areas:
●

In the MixConsole and in the Channel Settings window, a miniature view of the panner is
displayed at the top of the fader section.

●

In the Inspector, a miniature view of the panner is displayed in the Surround Pan section.
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In the miniature views, the following applies:
●

To move the signal source in the surround field, click and drag.

●

To adjust the position of the panning balls on the z-axis, middle-click and drag.

●

In the Inspector miniature view, you can also solo, mute, and disable channels.

NOTE
In all miniature panner views, you can hold Shift while moving the sound source to allow for
more accurate positioning.

RELATED LINKS
Soloed, Muted, and Disabled Speaker Channels on page 669
Movement Restriction Modes on page 663

Pinned Panner Window
When you pin the panner window, you can select individual channels and display their panning
settings in that window.
●

To show the VST MultiPanner, the Standard Panner, or the MixConvert V6 plug-in panel
of the selected channel or bus in one single instance of the panner window, activate
Pinned window follows VST channel selection at the top of the panner plug-in panel.

If Pinned window follows VST channel selection is activated, the following applies:
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●

If you select a channel for which no panner view is available, the pinned window continues
to show the last available panner view. In this case the panner view is not consistent with
the selected channel.

●

You can still open additional panner windows by double-clicking the corresponding
miniature panner view in the MixConsole, in the Channel Settings window, or in the
Inspector.
NOTE
You can only open one panner instance for each channel.

RELATED LINKS
Miniature Views on page 659

General Plug-in Controls
Bypass Effect
The Bypass Effect button at the top left of the plug-in panel allows you to bypass
VST MultiPanner.
The following applies:
●

If the input and output configurations are identical, the input signals are
directly routed to the output channels.

●

If the input and output configurations differ, the panner attempts to route the
input signals to the appropriate output channels. For example, if you pan a
stereo signal to a 5.1 configuration, the left and right front speakers are used.

NOTE
If you use VST MultiPanner as an insert effect, the Bypass Effect button works in
the same way it does for audio plug-ins.

Bypass Effect button

Mute/Solo
The Mute and Solo buttons at the top of the plug-in panel are identical to the Mute
and Solo controls of the channel.
IMPORTANT
These buttons are not available if VST MultiPanner is used as an insert effect.
Read/Write
The Read and Write buttons at the top of the VST MultiPanner window allow you to
apply and record automation data. If the panner is used on an output channel, these
buttons are identical to the Read and Write buttons of the channel. If used as an
insert effect, automation data for this insert is written separately.
RELATED LINKS
Bypassing Insert Effects on page 446
Using Solo and Mute on page 387
Automation Parameters in VST MultiPanner on page 662
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Automation Parameters in VST MultiPanner
Most of the parameters in the VST MultiPanner plug-in can be automated just like any other
channel or insert parameter.
Recording automation for the orbit controls and the independent positioning mode, however, is
handled differently. Automation data for these parameters is written as a combination of the
front-rear panning, left-right panning, and the Rotate Signal parameters. For the independent
positioning mode, scaling is added. Therefore, modifying existing automation data is quite
troublesome, since it involves changing many different parameters. If an automation pass does
not meet your expectations, we recommend to start from scratch.
RELATED LINKS
Orbit Controls on page 666
Movement Restriction Modes on page 663
Writing Automation Data on page 696

Position of the Sound Source
The pan area of the VST MultiPanner plug-in shows you the position of the sound source and
allows you to move it.
In the pan area, the virtual position of the sound source is shown as a circle. The left and right
front channels are shown in yellow and red. All other input channels are shown in blue.

The pan area showing a 5.1 sound source

1

Left and right front channels

2

Center channel

3

The virtual position of the sound source

4

Left and right rear channels

You can position the sound source anywhere inside the room and even move it out of the pan
area. This can be useful for extreme panning positions, such as panning all channels hard right.
To show the position outside the pan area, activate Overview Mode.
NOTE
If you work with mono channels, the sound source corresponds to the mono channel.

RELATED LINKS
Positioning a Sound Source in the Pan Area on page 663

662

Surround Sound
VST MultiPanner
Overview Mode on page 665

Positioning a Sound Source in the Pan Area
The pan area of the VST MultiPanner plug-in allows you to use the mouse for positioning the
sound source.
PROCEDURE
●

To position the sound source, do one of the following:
●

Click at the exact position where you want the sound source to be placed.

●

Click and drag the positioning handle to the exact position where you want the
sound source to be placed.

RELATED LINKS
Position of the Sound Source on page 662
Movement Restriction Modes on page 663

Movement Restriction Modes
VST MultiPanner allows you to restrict the movement within the pan area. This way, you can
move the sound source along a specific axis, for example, from bottom left to top right.
The following positioning modes and modifier keys are available:
Standard Positioning Mode
Mouse movements are not restricted.
Fine-Scaled Positioning Mode
Mouse movements are scaled to allow very fine movements. This is useful when
panning in one of the miniature displays, for example.
Modifier key: Shift
Horizontal Movements Only
Mouse movements are restricted to horizontal.
Modifier key: Ctrl/Cmd
Vertical Movements Only
Mouse movements are restricted to vertical.
Modifier key: Ctrl/Cmd-Shift
Diagonal Movements Only - Bottom Left to Top Right
Mouse movements are restricted to diagonal from bottom left to top right.
Modifier key: Alt
Diagonal Movements Only - Bottom Right to Top Left
Mouse movements are restricted to diagonal from bottom right to top left.
Modifier key: Alt-Shift
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Jump to Positioning Handle
In this mode, the mouse pointer jumps immediately to the positioning handle, even
it is located outside the pan area.
Modifier key: Ctrl/Cmd-Alt-Shift
NOTE
If Position Left/Right Channels Independently is activated, clicking anywhere in
the pan area always moves the mouse pointer to the closest panning ball.
Position Left/Right Channels Independently
Mouse movements are restricted to left channels or right channels only.
IMPORTANT
●

If Position Left/Right Channels Independently is activated, automation data
is written for several parameters. Due to this, specific automation rules apply.

●

Automation data for the independent positioning mode is always written for
the complete sound source, not for individual channels. This means it is not
possible to record automation for one stereo channel and then add
automation for the other stereo channel in a second go, for example.

NOTE
The movement restriction buttons do not affect the controls in the positioning section below.

RELATED LINKS
Restricting Movements When Dragging the Sound Source on page 664

Restricting Movements When Dragging the Sound Source
When dragging the sound source within the pan area, different movement restriction modes
allow you to limit the movement to a specific axis, allowing for very accurate positioning.
PROCEDURE
●

To restrict the movement within the pan area, do one of the following:
●

Press the corresponding modifier key. The corresponding movement restriction
button is highlighted, indicating that this mode is active.
As soon as you release the modifier key, you return to Standard Positioning Mode.

●

Click the corresponding button to activate a positioning mode permanently.
To deactivate the selected positioning mode, click Standard Positioning Mode.

RELATED LINKS
Movement Restriction Modes on page 663
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Overview Mode
Overview Mode visualizes panning movements outside the pan area. However, the actual
panning is done in the standard view.
If you have moved the sound source to outside of the pan area, Overview Mode allows you to
see where the positioning handle and the panning balls are located. A thin line connects these
theoretical positions with their acoustically effective positions.
●

To activate/deactivate overview mode, click Overview Mode

below the pan area.

1

Acoustically effective positions of the left and right channel within the pan area

2

Theoretical positions of the left and right panning ball outside the pan area

3

Positioning handle outside the pan area

Pan Controls
Left-Right Pan and Rear-Front Pan allow you to pan the sound source on the x-axis and on the
y-axis. For 3D channel configurations, Bottom-Top Pan allows you to pan the sound source on
the z-axis.

NOTE
The panning controls are not affected by the movement restriction buttons.

RELATED LINKS
Movement Restriction Modes on page 663
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Rotate and Tilt Controls
The Rotate Signal around Z-Axis control allows you to rotate the sound source. For 3D channel
configurations, Tilt Signal around Y-Axis and Tilt Signal around X-Axis allow you to tilt the
sound source around its own axes.

Rotating and tilting the sound source is useful if you work with premixed surround stems. You
can rotate the surround sound source within the surround field of the output bus, and use this
for a scene where the camera turns around, for example.

Orbit Controls
The orbit controls allow you to rotate the sound source, including all input channels, around the
center of the surround field.

1

Orbit Center

2

Counter Shot

3

Radius

Orbit Center
This is the main control that allows you to perform the rotation. You can use this for
a scene where a person moves around and can still be heard when behind the
audience.
Counter Shot
This button allows you to rotate the sound source by exactly 180°, so that all
positions in the surround image change sides.
You can use this for a close-up scene with people sitting face to face, and a lot of
reverse shots. With Counter Shot you can flip the surround field each time that the
camera switches from perspective A to perspective B and back.
NOTE
●

Counter Shot is useful if you work with premixes, for example, the ambience
stem, so that you only have to click the button once for each cut.

●

If you pan a scene with reverse shots with less than 180°, so that you cannot
use the Counter Shot button, make the adjustments for the first perspective
of the reverse shot manually, write this as automation and use the Punch Log
function to save this setup. Repeat this for the second perspective, and
afterwards use the Punch Log entries to switch between the 2 perspectives
with just one click.

Radius
If you use Orbit Center, Radius allows you to control the distance of the sound
source from the center of the surround field without changing the angle.
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IMPORTANT
In terms of automation, Orbit Center, Counter Shot, and Radius are not
independent parameters as such. Instead, a combination of different automation
parameters is used.

RELATED LINKS
Punch Log on page 718
Automation Parameters in VST MultiPanner on page 662

Center Distribution
The Center Distribution dial distributes part or all of the center signal to the left and right front
speakers.

If you pan the center signal directly to the center speaker and set Center Distribution to 0 %,
you may get a signal that is too discrete. In this case you can add part of the signal to the left and
right front speakers to widen it. By raising the Center Distribution value you can distribute the
signal to the 3 speakers. At 100 %, the center source is provided entirely by the phantom image
created by the left and right speakers.
A line at the top of the surround field indicates the distance up to which a phantom signal is
added:

If you position the source signal inside this range, the signal is sent to all 3 channels.

Divergence Controls
Front Divergence, Front/Rear Divergence, and Rear Divergence determine the attenuation
curves used when positioning sound sources for x-axis front, y-axis front/rear, and x-axis rear.
For 3D channel configurations, Height Divergence allows you to determine the attenuation
curve when positioning on the z-axis.

If all divergence controls are set to 0 %, positioning a sound source on a speaker sets all other
speakers to level zero. With higher values, the other speakers receive a percentage of the sound
source.
Horizontal and vertical lines show the effect of changing the divergence settings:
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●

At 0 %, a moving sound source is concentrated in one spot. You can use this to create the
impression that something is taking place right in front of the spectator.

●

At 100 %, a moving sound source is very diffuse and hard to locate. You can use this to
create the impression that something is taking place far away from the spectator.

NOTE
●

Center Distribution and Front Divergence are combined. If the front divergence is set to
100 %, the center distribution has no effect.

●

The setting of the Height Divergence is not shown in the pan areas.

Scale Controls
The scale controls allow you to control the horizontal (Signal Width) and vertical (Signal Depth)
expansion of the sound source.

The scale controls influence the perception of spatiality and ambience, as well as the traceability
of signals.
●

100 % corresponds to the complete width or depth of the surround field.

●

If you reduce both values to 0 %, the distance is reduced to zero and all source channels
are centered in one spot.

NOTE
Signal Depth is only available for configurations with front and rear channels.

Elevation Patterns for 3D Mixing
You can use elevation patterns to let the height parameter automatically follow a predefined
curve while positioning a sound in the 2D pan area. The active pattern is shown in the Rear View
pan area.
●

To activate/deactivate an elevation pattern, click one of the Elevation Pattern buttons.

NOTE
If an elevation pattern is active, Bottom-Top Pan cannot be adjusted manually.
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The following elevation patterns are available:
Wedge, Ceiling, Sphere
These patterns correspond to the elevation modes that are defined by Dolby for
Dolby Atmos authoring.
Cup, Tunnel, Half-Pipe
These patterns make use of the bottom of the 3D room.
NOTE
This might not have the expected effect in a small room speaker setup with close
distance between side and top speakers.
Ridge
This pattern is similar to Wedge but more suitable for 9.1 bed-only mixes without an
additional object mix.

Automation Rules for Elevation Patterns
●

An active elevation pattern overrides any automation for Bottom-Top Pan, however, the
automation remains intact.

●

If elevation is deactivated, Bottom-Top Pan is set to bottom, even if automation for
bottom-top panning is present. Elevation On/Off can also be automated.

Pan Laws for 3D Mixing
When an audio signal is moving through the room at a changing height, Nuendo makes use of a
complex set of pan laws that ensures smooth and gapless transitions.
The following applies:
●

The pan laws can cause a difference between the graphical position of a panning ball and
the audible position of the sound source. If the graphical position of the sound source
differs from the audible position, in the Top View pan area, the audible position is shown
as a gray circle and the distance between both positions as a gray line.

●

If you move the Bottom-Top Pan control all the way to the right, the sound comes from
the top speakers only.

Soloed, Muted, and Disabled Speaker Channels
The speaker buttons around the Top View and the Rear View represent the output configuration
and allow you to disable, solo, or mute channels.
Enabled speaker
This channel is enabled.
Disabled speaker
This channel is disabled. Its signal is distributed to the other channels instead.
Soloed speaker
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This channel is soloed.
Muted speaker
This channel is muted.
Disabled and muted speaker
This channel is disabled and muted.
●

To disable a channel, Alt-click on the corresponding speaker button. That way, no audio is
routed to this channel. The signal that would otherwise be sent to this channel is
distributed to the other channels instead. For example, you can disable the center
channels for all stems of a film mix except the dialogue stem to make sure that only
dialogue is sent to the center speaker.
NOTE
If the signal of a disabled channel is distributed to other channels, the power level stays
constant.

●

To solo a channel, click the corresponding speaker button. That way, you only hear the
signal sent to this channel while all other channels are muted. This can be useful for
testing purposes, for example, to make sure that a signal is sent to a specific channel as
intended.
NOTE
You can solo several channels at the same time by clicking on the corresponding speaker
buttons one after the other. If you Ctrl/Cmd-click a speaker button, this channel is soloed
exclusively and all other channels are muted.

IMPORTANT
Solo and Mute cannot be automated.

RELATED LINKS
Constant Power Panning on page 654

Remote Controlling VST MultiPanner
You can control the VST MultiPanner plug-in remotely with several control devices. To control all
panner functions, you may need updated software for your device.

Yamaha Nuage
To control 3D sound mixing functions of VST MultiPanner remotely on a Nuage system, you
must install “Tools for Nuage V1.8” or later.

Avid
The parameters of VST MultiPanner are mapped on the following devices:
●

System 5-MC

●

S6

●

Artist Series
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Panning with a Joystick
You can use a joystick to remote-control Rear-Front Pan and Left-Right Pan in VST
MultiPanner.
PREREQUISITE
You have connected a joystick to your computer and restarted Nuendo.
PROCEDURE
●

To position the sound source in the room, pull the joystick trigger and move the joystick.

RELATED LINKS
Joysticks on page 761

Switching the Channel Panner
VST MultiPanner is the default panner plug-in for audio channels in Nuendo. Depending on the
channel configuration, you can also use other panner plug-ins.
PROCEDURE
●

In the MixConsole, in the Channel Settings window, or in the Inspector, right-click the
miniature view of the panner plug-in VST MultiPanner, and from the context menu select
a panner plug-in.

RELATED LINKS
Miniature Views on page 659

MixConvert V6
MixConvert V6 is a plug-in that converts one multi-channel audio source into another multichannel destination. It is most frequently used to downmix a multi-channel surround mix into a
format with fewer channels, for example, a 5.1 surround mix into a stereo mix.
MixConvert V6 can be used as an insert effect in the MixConsole like other plug-ins, but it also
has special functions.
Nuendo automatically inserts MixConvert V6 instead of VST MultiPanner if the channel, for
example, an audio track or a group channel, is routed to a destination with fewer audio channels.
MixConvert V6 is also inserted in place of any cue send panner if the destination has a different
channel configuration than the source.
NOTE
There is one exception to this behavior. If a stereo channel is routed to a mono destination
through the channel routing or a cue send routing, a normal stereo panner is inserted. However,
this stereo panner controls the balance of the left and right channels as they are blended into the
mono destination. The center position blends both channels together by equal amounts. With
the pan set all the way to the left, only the left channel can be heard, and vice versa.
The following table gives you an overview of which plug-in is used in a specific configuration:
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Mono Tracks
Routing Destination

Surround Pan Option

Mono

●

n.a.

Stereo

●

Mono - Standard Panner

Surround

●

VST MultiPanner

●

MixConvert V6

●

VST MultiPanner

●

MixConvert V6

3D

Stereo Tracks
Routing Destination

Surround Pan Option

Mono

●

Stereo - Standard Panner

Stereo

●

Stereo - Balance Panner

●

Stereo - Combined Panner

●

VST MultiPanner

●

MixConvert V6

●

VST MultiPanner

●

MixConvert V6

Surround

3D

Surround Tracks
Routing Destination

Surround Pan Option

Mono

●

MixConvert V6

Stereo

●

MixConvert V6

Surround

●

VST MultiPanner

●

MixConvert V6

●

VST MultiPanner

●

MixConvert V6

Surround with smaller channel width

●

MixConvert V6

3D

●

VST MultiPanner

●

MixConvert V6

Surround with larger channel width
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3D Tracks
Routing Destination

Surround Pan Option

Mono

●

MixConvert V6

Stereo

●

MixConvert V6

Surround

●

MixConvert V6

Surround with larger channel width

●

MixConvert V6

Surround with smaller channel width

●

MixConvert V6

3D

●

MixConvert V6

You can select the surround pan option in the context menu of the panner miniature views in the
MixConsole, in the Channel Settings window, and in the Inspector.
RELATED LINKS
MixConvert V6 Plug-in Panel on page 673
VST MultiPanner on page 654
Input and Output Channel Configurations on page 675
Miniature Views on page 659

MixConvert V6 Plug-in Panel
The MixConvert V6 plug-in panel allows you to set the levels of the surround channels, and to
solo or mute channels for input and output channels.

The plug-in panel is divided into three sections: the Input section, the Output section, and the
center section. The Input and Output sections are hidden by default.
●

To show/hide the Input or Output sections, click the corresponding arrow button.
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Input section
Shows all input channels and allows you to solo or mute channels.
Output section
Shows all output channels and allows you to solo or mute channels.
The center section contains the main plug-in parameters as well as buttons for soloing several
speaker channels in one go.
Input Channel Configuration
Shows the input channel configuration.
Output Channel Configuration/Select Output Channel Configuration
Shows the output channel configuration.
If MixConvert V6 is used as an insert effect, the pop-up menu allows you to set the
output channel configuration.
Solo Channel buttons
Solos all front channels, the LFE channel, or all surround channels in the input or
output display. All other channels are muted.
Listen to Solo Channels on Center Channel
Routes all soloed channels to the center channel. If no center channel is present, the
signal from the soloed channels is distributed equally to the left and right speakers.
Listen to Surround Channels on Front Channels
Solos all surround channels, including the side channels, and routes or downmixes
them to the front speakers.
Center Level
Sets the level of the front center channel.
LFE fader
Sets the level of the LFE channel.
Surround Level
Sets the level of the surround channels. The level of the surround channels cannot be
adjusted individually.
Side Level
Sets the level of the side channels. The level of the side channels cannot be adjusted
individually.
Top Level
Sets the level of the top channels. The level of the top channels cannot be adjusted
individually.
Global Gain
Sets the level of all output channels.
Activate/Deactivate Low-Pass Filter
Activates/Deactivates the low-pass filter that is applied to the LFE channel.
RELATED LINKS
Input and Output Channel Configurations on page 675
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Input and Output Channel Configurations
The input channel configuration is determined by the channel width of the track, group, or
output bus on which MixConvert V6 is inserted. The output channel configuration depends on
whether MixConvert V6 is used.
●

If MixConvert V6 replaces the panner, the output configuration is determined by the
destination of the channel or cue send.

●

If MixConvert V6 is used as an insert effect, the output configuration can be modified
using the Select Output Channel Configuration pop-up menu. You can select any
configuration from the VST 3 specification that contains speakers that are also present in
the input configuration.

NOTE
You can also modify the output configuration by loading a preset.

Soloing Channels
You can click the speaker icons in the input and output channel displays or the solo channel
buttons in the center section to solo or mute channels.
Soloing an input channel allows you to hear the influence of the soloed channel on the downmix.
Soloing an output channel allows you to hear only the soloed channel in the downmix.
To solo channels, do one of the following:
●

To solo a channel, click the corresponding speaker icon.
You can solo several channels at the same time. All other channels are muted.
To deactivate the solo state of a channel, click the corresponding speaker icon again.

●

To solo a channel exclusively, Ctrl/Cmd-click the corresponding speaker icon.

●

To solo all front channels, all surround channels, all side channels, or all top channels, click
the corresponding button in the center section.

●

To solo the LFE channel, click the corresponding cross-hair icon in the center of the
channel display.
NOTE
Alternatively, click the Solo Input/Output LFE Channel button in the center section.

●

To mute a channel, Shift-click the corresponding speaker icon.

RELATED LINKS
MixConvert V6 Plug-in Panel on page 673

MixConvert 3D Downmix Rules
The downmix function in Nuendo supports channel-based 3D mixing. If the Control Room mix is
different from the main mix output bus, or if the signal is routed to an output bus with a lower
number of channels, the signal is converted automatically using the MixConvert V6 plug-in.
MixConvert V6 allows you to solo or mute the top and side channels, and to adjust the top and
side channel level.
For Dolby Atmos 3D mixing, the following downmix rule applies:
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●

If a 9.1 mix is converted to a 7.1 mix, the top channel signals are attenuated by 1.5 dB and
added to the side channel signals.

RELATED LINKS
3D Mixes for Dolby Atmos on page 676

Surround Mix Export
Nuendo allows you to export a surround mix using the Export Audio Mixdown function.
You have the following export options when working with a surround configuration:
●

Split channels, resulting in one mono audio file for each surround channel.

●

Export to interleaved format, resulting in a single multi-channel audio file, for example, a
5.1 file containing all 6 surround channels.

RELATED LINKS
Export Audio Mixdown on page 1007
Wave Files on page 1013

3D Mixes for Dolby Atmos®
You can use the VST MultiPanner plug-in to create 3D mixes for Dolby Atmos.
VST MultiPanner allows the following:
●

Creating a channel-based bed mix in 9.1 Dolby Atmos format.
NOTE
This speaker configuration is also known as Dolby Atmos 7.1.2 speaker setup.

●

Creating an object-based Dolby Atmos mix with up to 118 audio objects when using a
Dolby Rendering and Mastering Unit (RMU).

RELATED LINKS
Routing Channels for 9.1 Dolby Atmos Bed Mixing on page 676
Bed Mixes for 9.1 Dolby Atmos with VST MultiPanner on page 677
Object-Based Mixes for Dolby Atmos on page 677

Routing Channels for 9.1 Dolby Atmos® Bed Mixing
Mixing for a 9.1 Dolby Atmos audio bed requires a signal routing to a 9.1 Dolby Atmos output
bus.
When mixing for a 9.1 Dolby Atmos audio bed, the following applies:
●

You must route the source channel to a 9.1 Dolby Atmos output bus or a 9.1 Dolby Atmos
group channel.
To ensure the correct routing for the Dolby Atmos mix, we recommend to route the first 10
device ports of your audio interface to the 9.1 Dolby Atmos bus. You can select the device
ports in the Audio Connections window.
IMPORTANT
In Nuendo, the order of surround busses and side busses differs from the Dolby
specification for side surround busses (Lss, Rss) and surround rear busses (Lsr, Rsr). To
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meet the specification for the Dolby RMU, swap the device ports of surround busses and
side busses.

●

You can route mono, stereo, or surround channels to a 9.1 Dolby Atmos bus. If you route a
9.1 Dolby Atmos channel to a 9.1 Dolby Atmos bus, MixConvert V6 is used for panning.

●

Plug-ins that are used in a 3D bus or group channel must support a corresponding
number of channels.

RELATED LINKS
MixConvert 3D Downmix Rules on page 675
Bed Mixes for 9.1 Dolby Atmos with VST MultiPanner on page 677
Available Surround Channel Configurations on page 648

Bed Mixes for 9.1 Dolby Atmos® with VST MultiPanner
The VST MultiPanner plug-in allows you to create channel-based 9.1 Dolby Atmos bed mixes.
VST MultiPanner offers additional settings and a 3D pan area for creating 3D mixes for Dolby
Atmos.
●

To access these settings, click Show/Hide Extended Display .

NOTE
The processing mode of the panner is determined by the routing of the audio channels. If an
audio channel is routed to a 9.1 Dolby Atmos output bus or group channel, the panner operates
in 9.1 Dolby Atmos bed mode. Otherwise, the 3D panning functions are disabled.

RELATED LINKS
VST MultiPanner Plug-in Panel for 3D Channel Configurations on page 658
Elevation Patterns for 3D Mixing on page 668
Pan Laws for 3D Mixing on page 669
Remote Controlling VST MultiPanner on page 670

Object-Based Mixes for Dolby Atmos®
Nuendo allows you to connect your system to a Dolby Rendering and Mastering Unit (RMU) and
to create object-based Dolby Atmos mixes.
For object-based mixing, Nuendo provides the following functions:
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●

The Object Mapping dialog allows you to establish a connection to a Dolby RMU and to
define your audio objects by mapping audio outputs to object IDs. Mapped audio outputs
that are connected to output busses in the Audio Connections window serve as your
object busses.

●

The additional Object Mode of the VST MultiPanner plug-in allows you to pan audio
objects and to route the signal through object busses to the Dolby RMU.

Setup for Object Mixing
To be able to create an object-based Dolby Atmos mix with VST MultiPanner, you must first
connect your system to the Dolby RMU, define objects, and create object busses.

Connection to a Dolby RMU
Your system must be connected to the Dolby RMU. The last used connection to an RMU persists
and is restored when you start the application.
Set up the connection between your system and the Dolby RMU as follows:
●

In the Object Mapping dialog, enter the IP address of the Dolby RMU into the RMU field.

Definition of Objects
If you want to use an audio stream as a Dolby Atmos object, you must map an object ID to this
audio stream first.
A Dolby Atmos object consists of an audio stream that is sent to the Dolby RMU plus a metadata
stream transporting the panning information. Objects are always sent in real time, and they are
monitored and recorded in the RMU. For this to work, you must define which of the audio
streams that are sent to the RMU are objects. This is done in the Object Mapping dialog.
NOTE
You can use up to 118 objects. However, the first 10 objects are reserved for the 9.1 Dolby Atmos
bed and are excluded from mapping. Therefore, it is recommended that the 9.1 Dolby Atmos bus
uses the first 10 device ports of your audio interface.
●

To open the Object Mapping dialog, select Studio > Object Mapping.
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You can map objects to audio outputs either manually or automatically:
●

To map an object to an audio output manually, click the corresponding Objects pop-up
menu and select an object ID.
NOTE

●

●

Manual mapping of objects is necessary if the 9.1 Dolby Atmos bus does not use the
first 10 device ports of your audio interface.

●

Objects that are already mapped to an audio output are shown as in use in the popup menu. If you select an object that is already in use, the previous mapping is lost.

To map objects to all available audio outputs automatically, click Map All.
NOTE

●

●

The first 10 audio outputs are reserved for the 9.1 bed and are therefore excluded
from automatic mapping.

●

Objects that are already mapped remain unchanged.

To discard the mappings between all device ports and objects, click Unmap All.

RELATED LINKS
Routing Channels for 9.1 Dolby Atmos Bed Mixing on page 676

Object Busses
If you want to use a channel in object mode, you must connect it to an object bus in the VST
MultiPanner plug-in. An object bus is defined as an output bus that is connected to a device port
which in turn is mapped to an object ID.
●

To connect a channel to an object bus, open VST MultiPanner in Object Mode, click on
Select Object Bus, and select a bus from the pop-up menu.

If the LED to the left of the name field lights up in green, this indicates that a valid object bus is
selected. If the LED lights up in red, at least one output bus of a selected multi-object bus is
unmapped.
The following applies:
●

Only object busses with a matching channel configuration can be selected. For example, if
you want to pan a stereo channel as an object, you can only connect the channel to a
stereo object bus.

●

Each object bus can only be used by the panner of one channel in object mode at the same
time. The connection between panner and object bus is broken if the object bus is selected
in the panner of another channel.

IMPORTANT
To avoid unwanted results when working with object audio, we recommend the following:
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●

Do not use object busses as routing destinations for normal audio channels.

●

The object audio stream is automatically routed through send slot 8 to the object bus. For
channels that are in object mode, do not use send slot 8 for other purposes.

RELATED LINKS
Definition of Objects on page 678
Creating Object Busses on page 680
Multi-Object Busses on page 680
Creating Object Busses
This example shows you how to create 16 object busses for an object-based Dolby Atmos mix.
PROCEDURE
1.

In the Object Mapping dialog, map 16 of 64 available output streams to object IDs.

2.

In the Audio Connections window, create 16 mono output busses.

3.

Connect the 16 mono output busses one by one to the 16 mapped output streams.

RESULT
The 16 mono output busses are defined as your object busses. In the VST MultiPanner plug-in,
you can select these 16 object busses in the Select Object Bus pop-up menu for mono channels.
RELATED LINKS
Object Busses on page 679
Multi-Object Busses
You can make stereo and multi-channel busses available as multi-object busses.
Normally, objects are meant to be mono, but you can also create stereo or multi-channel busses
and make them available as multi-object busses. This allows you to tilt and rotate pre-panned
multi-channel signals in the Dolby Atmos surround field, for example, a 5.0 channel background
mix.
NOTE
●

Due to the close distance between side and top speakers in a Dolby Atmos system, tilting
of multi-channel signals allows for a signal panning that may not always be perfectly
reproducible.

●

In Object Mode, there is no LFE channel. If you want to use a surround bus with an LFE
channel, for example 5.1, as multi-object bus, it is recommended to downmix the LFE
channel first.

RELATED LINKS
Object Busses on page 679
Creating Multi-Object Busses on page 681
Setup for Object Mixing on page 678
Object Mixes with VST MultiPanner on page 681
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Creating Multi-Object Busses
This example shows you how to create a multi-object bus for a pre-panned 5.0 channel
background mix in your Dolby Atmos project.
PROCEDURE
1.

In the Audio Connections window, create a 5.0 output bus and connect it to audio
streams that are defined as objects in the Object Mapping dialog.

2.

In the VST MultiPanner plug-in, click Select Object Bus and select the 5.0 output bus.

RESULT
VST MultiPanner now sends 5 objects to the Dolby RMU.
RELATED LINKS
Multi-Object Busses on page 680

Object Mixes with VST MultiPanner
The Object Mode of the VST MultiPanner plug-in allows you to create object-based mixes for
Dolby Atmos.
The following applies:
●

In Object Mode, 3D panning functions are always provided, regardless of the audio
routing.

●

If a switch between Object Mode and Bed Mode is automated, the bypass of send 8 is
automated accordingly, using its own automation track.
Furthermore, if the parameter settings differ between both modes, existing automation of
a parameter that is not available due to the mode change remains.

●

If VST MultiPanner is used as an insert plug-in, Object Mode is not available.

NOTE
Objects cannot be monitored within the Control Room of Nuendo. However, if you want to
monitor the result of your object mix, you can route a 7.1 downmix from the Dolby RMU to an
external input of the Control Room.

RELATED LINKS
VST MultiPanner on page 654
Bed Mixes for 9.1 Dolby Atmos with VST MultiPanner on page 677
Setup for Object Mixing on page 678
Control Room on page 420
MixConvert 3D Downmix Rules on page 675
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VST MultiPanner Plug-in Panel in Object Mode
The VST MultiPanner plug-in panel offers additional settings and parameters for object-based
mixing.

Select Object Bus
Connects the channel to an object bus. If the LED lights up in green, a valid object
bus is selected. If the LED lights up in red, at least one output bus of a selected multiobject bus is unmapped. To display a tooltip that shows which output busses are
unmapped, move the mouse pointer over the LED.
RMU LED
If the LED lights up in green, a Dolby RMU is connected to the system. If the LED
lights up in red, no RMU is connected.
Select Object Zone
Determines which speaker zones are active for the object. Active speaker zones are
shown as small blue squares around the Top View pan field.
Active speaker zones are also shown in the miniature view in the Inspector.
Speaker Snap
Moves the object audio to the active speaker that is nearest to its established
location during playback.
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Object Size
Spreads the audio for an object in the room, based on the object position and the
active speakers. This parameter is deactivated if Speaker Snap is activated.
NOTE
For details about object-based mixing for Dolby Atmos refer to the documentation provided with
your Dolby RMU.

RELATED LINKS
VST MultiPanner on page 654
Connection to a Dolby RMU on page 678

3D Mixes for Ambisonics
Nuendo allows you to create 3D mixes in Ambisonics format for virtual reality (VR) or augmented
reality (AR) productions. You can use the integrated functions and plug-ins for spatial mixing or
head-tracking monitoring, or use dedicated third-party plug-ins.
Ambisonics is a technology that creates a spherical sound field. In contrast to traditional
immersive sound formats, it is not channel-based but utilizes an encoded bundle of multiple
audio signals that allows you to place sound sources at any position in the sound sphere.
Nuendo supports first-order, second-order, and third-order Ambisonics. These formats differ in
the number of audio signals that are used. Higher-order Ambisonics provide more signals and
allow for a higher positioning precision.
To play back the sound sphere, the signals of an Ambisonics file must be decoded. You can play
back the sound sphere in the following ways:
●

Using headphones and binaural decoding.
Using a properly matched head-related transfer function (HRTF) configuration creates a
realistic, full spherical 360° sound field. The sound is perceived even more realistically if
the binaural encoding takes the head movements of the listener into account using head
tracking technology.

●

Using a 3D multi-channel speaker setup.
The more spherical the speaker setup, the more precise the positioning. However, the
sphere can be projected on a 5.1.4 channel configuration, for example.

When working with Ambisonics audio in Nuendo, the following applies:
●

You can record from an Ambisonics-capable microphone system.

●

You can import pre-produced Ambisonics files in WAV format.

●

You can edit Ambisonics events like any other audio in the Project window, the Sample
Editor, or the Direct Offline Processing window, for example. All signals of an Ambisonics
file are edited simultaneously.
NOTE
Not every editing operation is suited for Ambisonics audio. For example, avoid operations
that change the phase and levels of the audio signals against each other.

●

You can use VST MultiPanner to create Ambisonics mixes from mono, stereo, or multichannel sources. To use VST MultiPanner in Ambisonics mode, you must set an output
bus in Ambisonics format as Main Mix.

●

The VST AmbiDecoder plug-in decodes Ambisonics audio for monitoring on your
headphones or loudspeaker system. When monitoring via the Phones channel,
Ambisonics audio is automatically decoded for binaural stereo.
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●

Nuendo can use tracking data from external VR controller devices like head-mounted
displays or 3D mouse devices to change the listening direction. This allows for realistic
monitoring of 360° mixes.
For background music tracks that must not be affected by head movements, you can
bypass the tracking by sending a head-locked signal via side-chain.

●

Nuendo only supports AmbiX format. You can use the VST AmbiConverter insert plug-in
to convert between Furse-Malham (FuMa) and AmbiX format.

●

You can use dedicated third-party Ambisonics plug-ins for mixing, converting, head
tracking, or binauralization.
NOTE

●

●

If you use an Ambisonics panner that is only suited as insert plug-in, all audio
channels in the mix must be in Ambisonics format, even if they only contain mono
or stereo audio.

●

For details on how to use a third-party plug-in, refer to the documentation that
comes with it.

You can preview Ambisonics audio in the MediaBay, the Pool, in the Direct Offline
Processing window, or the file import dialog if your project is set up for playing back
Ambisonics audio.

RELATED LINKS
Channel Routing for Ambisonics Mixes on page 684
Playback of Ambisonics Audio on page 686
VST AmbiDecoder Panel on page 686
Monitoring a Head-Locked Signal in VST AmbiDecoder on page 691
VST AmbiConverter Panel on page 694

Channel Routing for Ambisonics Mixes
You can route any channel to an Ambisonics channel.
Which channel configurations are allowed in an Ambisonics mix depends on the position of the
Ambisonics panner plug-in in the signal path:
●

If you use the panner plug-in as a channel panner in the MixConsole, you can use any
audio channel format.

●

If you use the panner as an insert plug-in, all audio channels in the mix must be in
Ambisonics format, even if they only contain mono or stereo audio.

RELATED LINKS
Available Surround Channel Configurations on page 648
Switching the Channel Panner on page 671
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VST MultiPanner Plug-in Panel in Ambisonics Mode
The VST MultiPanner plug-in panel offers additional settings and parameters for Ambisonics
mixing.

●

To use VST MultiPanner in Ambisonics mode for an audio channel, you must route the
channel to an output bus in Ambisonics format.

Top View/Rear View
Shows the sound field from the top and the rear, and allows you to position the
sound source by dragging the panning balls. The orientation is bound to the headtracking viewing angle. This means, what you see in front of you when using a VR
display is also in front of the head symbol in both views.
Field Size
Sets the perceived size of the sound field. It is indicated by the size of the head
symbol in Top View and Rear View. The smaller the size, the bigger the distance
between listener and sound source. The volume of the sound is attenuated
accordingly. Moving the mouse pointer over the scale knob displays the simulated
distance in meters in both panning views.
Source Size
Spreads the source audio in the sound field by making it more diffuse.
RELATED LINKS
VST MultiPanner Plug-in Panel on page 655
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Playback of Ambisonics Audio
Nuendo allows you to decode Ambisonics audio for monitoring via headphones or 3D multichannel speaker setups. For decoding, you can use VST AmbiDecoder or suited third-party
decoder plug-ins.
The following applies:
●

In the Control Room Phones channel, you can use VST AmbiDecoder or suited third-party
decoder plug-ins.

●

In the Control Room Main channel, VST AmbiDecoder is automatically used for decoding
Ambisonics audio.

●

You can use third-party Ambisonics decoders as insert plug-ins in the Control Room Main
channel.

●

VST AmbiDecoder allows you to send a head-locked signal into your monitor mix via sidechain.

NOTE
To monitor your Ambisonics project, an output bus in Ambisonics format must be set as Main
Mix.

RELATED LINKS
Setting the Default Output Bus (Main Mix) on page 29
Monitoring Ambisonics Audio Binaurally via the Phones Channel on page 689
Monitoring Ambisonics Audio Binaurally Using Third-Party Insert Plug-ins on page 689
Monitoring Ambisonics Audio via a 3D Multi-Channel Speaker Configuration on page 690
Monitoring a Head-Locked Signal in VST AmbiDecoder on page 691

VST AmbiDecoder Panel
The VST AmbiDecoder plug-in converts Ambisonics audio for playback on headphones or multichannel speaker setups. It is used automatically in the Control Room Phones and Control
RoomMain channels, and can also be used as an insert plug-in.
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Input Format > Output Format
Shows the audio formats of the input and output signals.
HRTF Mode
Allows you to set the head-related transfer function (HRTF) mode for binaural
playback. The following HRTF modes are available:
●

Standard mode uses the standard HRTF algorithm of Nuendo.

●

SOFA mode allows you to use an HRTF saved in SOFA file format.
This mode is only available if you have loaded a SOFA file.

●

Facebook mode uses the same HRTF algorithm that is used for VR video
playback at www.facebook.com.

●

YouTube mode uses the same HRTF algorithm that is used for VR video
playback at www.youtube.com.

NOTE
●

The HRTF settings are only available if VST AmbiDecoder is used in the
Phones channel of the Control Room or as an insert plug-in.

●

The availability of Facebook and YouTube HRTF modes depends on the
Ambisonics order of the Main Mix bus.

Head Tracking
If this button is enabled, VST AmbiDecoder receives head-tracking data from the
Head Tracking window. If this button is disabled, you can use the Yaw, Pitch, and
Roll controls on the VST AmbiDecoder panel for setting the rotation angles.
Yaw
Sets the yaw rotation angle.
Pitch
Sets the pitch rotation angle.
Roll
Sets the roll rotation angle.
Head-Locked Signal
Sets the gain of the head-locked signal that is sent into the side-chain input of VST
AmbiDecoder.
RELATED LINKS
Head Tracking Window on page 688
Monitoring a Head-Locked Signal in VST AmbiDecoder on page 691

Head-Tracking Data from VR Controller Devices
Nuendo can receive tracking data from external VR controller devices like head-mounted displays
or 3D mouse devices.
When using head-tracking data while monitoring an Ambisonics mix, the following applies:
●

Movements of the head or with a 3D mouse are acoustically replicated in real time.

●

In VST MultiPanner, the Ambisonics mode pan views rotate in sync with the audible front.

●

The tracking data is transmitted to the VR video player and the 360° video is panned
accordingly.
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NOTE
For this to work, you must connect the VR player to Nuendo and activate Send HeadTracking Data in the GoPro VR Player Remote window.

RELATED LINKS
Head Tracking Window on page 688
VST MultiPanner Plug-in Panel in Ambisonics Mode on page 685
360° Video Playback on page 691
GoPro VR Player Remote Window on page 692

Head Tracking Window
In the Head Tracking window, you can set up Nuendo for receiving positioning data from an
external VR controller device. Alternatively, you can control the rotation angles manually.

●

To open the Head Tracking window, select Project > Head Tracking.

Yaw
Sets the yaw rotation angle.
Pitch
Sets the pitch rotation angle.
Roll
Sets the roll rotation angle.
Reset
Resets all rotation angles.
Tracking Source
Allows you to select a source for positioning data. Select Manual to control headtracking via the Yaw, Pitch, and Roll controls. Select VR Controller to receive data
from an external VR device.
VR Controller Type
Allows you to select the type of the connected VR controller device.
VR controller device information
Moving the mouse pointer over this field provides information about the connected
VR controller device.
Tracking
Enables/Disables the transmission of head tracking data to the VR player.
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Calibrate Yaw
Defines the current yaw rotation angle as center.

Monitoring Ambisonics Audio Binaurally via the Phones Channel
The Control Room Phones channel allows you to listen to Ambisonics audio binaurally via
headphones, automatically using VST AmbiDecoder for decoding.
PREREQUISITE
●

In the Audio Connections window, you have set an Ambisonics output bus as main mix,
and enabled the Control Room.

●

For the audio preview function to work, you must activate Use Phones Channel as
Preview Channel in the Preferences dialog on the VST - Control Room page.

PROCEDURE
1.

In the MixConsole, route your audio tracks to the Ambisonics output bus.

2.

Click Open/Close Ambisonics Decoder.

3.

On the decoder plug-in panel, make your binaural settings.

RESULT
You can play back Ambisonics audio binaurally via headphones.
NOTE
Instead of VST AmbiDecoder, you can also use third-party binaural decoding plug-ins that are
suited for use within the Control Room Phones channel. Select the decoder from the pop-up
menu in the Control Room Phones section.

RELATED LINKS
Inputs/Outputs Tab on page 22
Setting the Default Output Bus (Main Mix) on page 29
Control Room Tab on page 26
VST - Control Room on page 1210
VST AmbiDecoder Panel on page 686

Monitoring Ambisonics Audio Binaurally Using Third-Party Insert Plug-ins
Third-party Ambisonics plug-ins for binaural decoding that are not suited for use within the
Control Room Phones channel can be used as insert plug-ins in the Main channel instead.
PREREQUISITE
In the Audio Connections window, you have done the following:
●

You have set an Ambisonics output bus as main mix.

●

You have enabled the Control Room.

●

For the Control Room Monitor channel, you have selected the correct device port to send
the signal to your headphones.

NOTE
For details on how to use a third-party Ambisonics decoder plug-in, refer to the documentation
that comes with it.
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PROCEDURE
1.

In the MixConsole, route your audio tracks to the Ambisonics output bus.

2.

In the Downmix Presets section of the Control Room, select a preset with the same
Ambisonics format as the main mix.

3.

In the Channels section, disable Head Tracking on the miniature view of VST
AmbiDecoder.

4.

In the Main channel of the Control Room, insert the Ambisonics decoder plug-in.

RESULT
You can play back Ambisonics audio binaurally via the Control Room Main channel.
RELATED LINKS
Available Surround Channel Configurations on page 648
Control Room Tab on page 26
Inputs/Outputs Tab on page 22
Setting the Default Output Bus (Main Mix) on page 29
Insert Effects on page 431

Monitoring Ambisonics Audio via a 3D Multi-Channel Speaker Configuration
The Control Room Main channel allows you to listen to Ambisonics audio via a 3D multi-channel
speaker setup. For decoding Ambisonics audio to a multi-channel format, the Main channel
automatically uses VST AmbiDecoder.
PREREQUISITE
●

You use a studio monitor system that supports 3D speaker configurations, for example,
5.1.4.

●

In the Audio Connections window, you have set an Ambisonics output bus as main mix,
and enabled the Control Room.

PROCEDURE
1.

In the MixConsole, route your audio tracks to the Ambisonics output bus.

2.

In the Downmix Presets section of the Control Room, select the preset that matches your
speaker setup.

3.

In the Channels section, make your settings on the miniature view of VST AmbiDecoder
or double-click it to open the plug-in panel.

RESULT
You can listen to Ambisonics audio via your multi-channel speaker setup.
RELATED LINKS
Inputs/Outputs Tab on page 22
Setting the Default Output Bus (Main Mix) on page 29
Control Room Tab on page 26
Downmix Presets on page 427
Control Room Channel on page 428
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Monitoring a Head-Locked Signal in VST AmbiDecoder
You may not want some audio, for example, background music tracks, to be affected by head
movements. VST AmbiDecoder allows you to bypass tracking by sending a head-locked signal
via side-chain.
PREREQUISITE
In the Audio Connections window, you have set an Ambisonics output bus as main mix, and
enabled the Control Room.
PROCEDURE
1.

In your project, create a stereo or multi-channel group track and route your background
music tracks to this group.

2.

Route the output of the group track to the side-chain input of VST AmbiDecoder.

3.

On the VST AmbiDecoder panel, right-click and select Activate Side-Chain.

4.

Set Head-Locked Signal to the required gain.

RESULT
You can listen to decoded Ambisonics audio and your music tracks via the Control Room. The
music tracks are not affected by head-tracking data that Nuendo receives from a VR controller.
NOTE
When listening to Ambisonics audio via speakers, the head-locked signal is added after the
Control Room volume control. Use Control Room Level and Head-Locked Signal to retain a
proper balance between Ambisonics mix and head-locked signal.

RELATED LINKS
Head Tracking Window on page 688
VST AmbiDecoder Panel on page 686

360° Video Playback
For playing back 360° videos, Nuendo can use the Kolor GoPro VR player. The player can run
locally or on another computer connected via network.
You can remote-control GoPro VR Player with Nuendo using the GoPro VR Player Remote
function. It allows you to control the GoPro VR Player transport and to send head-tracking data to
the player.
NOTE
●

The minimum required version of GoPro VR Player is version 3.0. You can download the
latest version at http://www.kolor.com/gopro-vr-player/download/.

●

For details on how to use GoPro VR Player, refer to the documentation that comes with it.

RELATED LINKS
GoPro VR Player Remote Window on page 692
Connecting Nuendo to GoPro VR Player on page 692

691

Surround Sound
3D Mixes for Ambisonics

GoPro VR Player Remote Window
GoPro VR Player Remote allows Nuendo to control the transport and viewing angle of GoPro VR
Player.

●

To open the GoPro VR Player Remote window, select Project > GoPro VR Player Remote.

Video File
Shows the selected video file for playback in GoPro VR Player.
Select Video File
Allows you to select a video file.
Video Stereoscopy
Allows you to select the stereoscopy format of the selected video file.
IP Address/Port
Allows you to enter the IP address of the host computer running GoPro VR Player
and the UDP port GoPro VR Player is listening to.
Send Head-Tracking Data
Enables Nuendo to transmit head-tracking data from an external VR controller device
to GoPro VR Player.
Connect
Connects Nuendo to GoPro VR Player.

Connecting Nuendo to GoPro VR Player
This example shows you how to connect Nuendo to GoPro VR Player version 3.0.5.
PREREQUISITE
You have downloaded GoPro VR Player version 3.0.5 from http://www.kolor.com/gopro-vr-player/
download/, and installed it on your local computer or on another computer in your network.
PROCEDURE
1.

In GoPro VR Player, select File > Preferences.

2.

On the Video Decoding page, select Windows Media Foundation as Backend.

3.

On the Primary/Secondary page, select Secondary as Communication Mode.

4.

On the Controllers page, select Off for Head-Mounted Display SDK.

5.

Close the GoPro VR Player preferences menu.

6.

In Nuendo, select Project > GoPro VR Player Remote.

7.

In the GoPro VR Player Remote window, click Select Video File, and select the video file in
the file dialog.
This allows Nuendo to remote-control GoPro VR Player. The file selection is saved in your
Nuendo project.
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8.

Select the Video Stereoscopy format of the selected video file.

9.

Enter the IP Address/Port of the computer where the GoPro VR Player is running.
By default, IP Address/Port is set to the local computer.

10.

Enable Send Head-Tracking Data.
This sends the head tracking information of a connected VR controller to GoPro VR Player.

11.

Activate Connect to sync the transport of GoPro VR Player with Nuendo.

RESULT
GoPro VR Player is controlled by the transport of Nuendo and head tracking data that is sent
from a VR controller connected to your system.

Export Ambisonics Audio
You can create Ambisonics files from Ambisonics tracks using the Export Audio Mixdown
function.
The following applies:
●

Use only file formats that are suited for Ambisonics audio. We recommend that you only
create Ambisonics files in WAV format.

●

Before exporting, make sure that you only use Ambisonics decoding plug-ins in the
Control Room but not in the channel inserts.

●

Even though the resulting files look like multi-channel WAV files, they must be played back
with a dedicated Ambisonics player or converted into another platform-specific format
using an external application.

●

Head-locked signals must be exported from a separate output bus. You can export from
multiple busses at once.

RELATED LINKS
Export Audio Mixdown on page 1007
Mixing Down to Audio Files on page 1008
Monitoring a Head-Locked Signal in VST AmbiDecoder on page 691
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VST AmbiConverter Panel
When working with Ambisonics audio, Nuendo supports AmbiX format only. The VST
AmbiConverter plug-in allows you to convert Ambisonics audio between Furse-Malham (FuMa)
and AmbiX format.

Input level meter
Shows the input level for all speaker channels.
Ambisonics format display
Shows the order of the Ambisonics audio format.
Output level meter
Shows the output level for all speaker channels.
FuMa > AmbiX
Converts audio from FuMa to AmbiX format.
AmbiX > FuMA
Converts audio from AmbiX to FuMa format.
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In essence, automation means recording the values for a particular MixConsole or effect
parameter. When you create your final mix, Nuendo can adjust this particular parameter control.

Automation Curves
Within a Nuendo project, the changes in a parameter value over time are reflected as curves on
automation tracks.
There are different kinds of automation curves:

1

Ramp curves
Ramp curves are created for any parameter that generates continuous multiple values,
such as fader or encoder movements.

2

Jump curves
Jump curves are created for on/off parameters, such as mute.

Static Value Line
When you open an automation track for the first time, it does not contain any automation events.
This is reflected in the event display as a dotted horizontal line, the static value line. This line
represents the current parameter setting.
If you manually added any automation events or used write automation for the corresponding
parameter and then disable the reading of automation data, the automation curve is grayed out
in the event display and the static value line is used instead.
As soon as Read is enabled, the automation curve is used.

Write/Read Automation
You can automation-enable tracks and MixConsole channels by activating their automation write
W and read R buttons.
●

If you activate W for a channel, virtually all MixConsole parameters that you adjust during
playback for that specific channel are recorded as automation events.

●

If R is activated for a channel, all your recorded MixConsole actions for that channel are
performed during playback.

The R and W buttons for a track in the track list are the same as the R and W buttons in the
MixConsole.

695

Automation
Writing Automation Data
NOTE
R is automatically enabled when you enable W. This allows Nuendo to read existing automation
data at any time. You can separately deactivate W if you only want to read existing data.
There are also global read and write indicator buttons Activate/Deactivate Read/Write for All
Tracks on the MixConsole toolbar and at the top of the track list. These buttons light up as soon
as there is an enabled R or W button on any channel/track within your project. Furthermore, they
can be clicked to activate or deactivate R/W of all tracks simultaneously.
NOTE
R/W are also available on the Automation Panel.

RELATED LINKS
Read/Write Buttons on page 705

Writing Automation Data
You can create automation curves manually or automatically.
●

Manual writing makes it easy to quickly change parameter values at specific points without
having to activate playback.

●

Automatic writing lets you work almost as if you were using a real mixer.

With both methods, any applied automation data is reflected in both the MixConsole (a fader will
move for example) and in the corresponding automation track curve.
RELATED LINKS
Manual Writing of Automation Data on page 697

Automatic Writing of Automation Data
Every action that you perform is automatically recorded on automation tracks which you can
later open for viewing and editing.
PROCEDURE
1.

In the track list, click Show/Hide Automation for a track to open its automation track.

2.

Click W to enable the writing of automation data on this track.

3.

Start playback.

4.

Adjust the parameters in the MixConsole, in the Channel Settings window, or in the
effect control panel.
The value settings are recorded and displayed as a curve on the automation tracks. When
automation data is being written, the color of the automation track changes and the delta
indicator in the automation track shows the relative amount by which the new parameter
setting deviates from any previously automated value.

5.

Stop playback and return to the position where you started playback.

6.

Click W to disable the writing of automation data.

7.

Start playback.
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RESULT
All actions that you recorded are reproduced exactly. When you drag a plug-in to a different
insert slot on the same channel, any existing automation data moves with the plug-in. When you
drag it to an insert slot on a different channel, any existing automation data is not transferred to
the new channel.

Manual Writing of Automation Data
You can add automation events manually by drawing automation curves on an automation track.
PROCEDURE
1.

In the track list, click Show/Hide Automation for a track to open its automation track.

2.

Click the automation parameter name and select the parameter from the pop-up menu.

3.

Select the Draw tool.

4.

Click on the static value line.
An automation event is added, read automation mode is automatically activated, and the
static value line changes to a colored automation curve.

5.

Click and hold to draw a curve by adding many automation events.
When you release the mouse button, the number of automation events is reduced.
NOTE
To adjust the thinning out of events, open the Automation Panel, click Automation
Settings and enter a value for Reduction Level.

6.

Start playback.

RESULT
The automated parameter changes with the automation curve, and the corresponding fader in
the MixConsole moves accordingly.
AFTER COMPLETING THIS TASK
Repeat the procedure if you are not happy with the result. If you draw over existing events, a new
curve is created.

Tools for Drawing Automation Data
Apart from the Draw tool, you can use the Object Selection tool and the Line tool to draw
automation events. If you click with any of these tools on the automation track, R is activated
automatically.
●

Object Selection
If you click on an automation track with the Object Selection tool, an automation event is
added. If you hold down Alt, you can draw several automation events.
NOTE
Events that are introduced between existing events and do not deviate from the existing
curve are removed as soon as you release the mouse button.

To activate the Line tool in any other available mode, click the Line tool and click again to open a
pop-up menu where you can select the Line tool mode.
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The following Line tool modes are available:
Line mode
If you click on the automation track and drag with the Line tool in Line mode, you
can create automation events in a line. This is a quick way to create linear fades, etc.
Parabola mode
If you click and drag on the automation track with the Line tool in Parabola mode,
you can create more natural curves and fades.
NOTE
The result depends on the direction from which you draw the parabolic curve.
Sine, Triangle, or Square mode
If you click and drag on the automation track with the Line tool in Sine, Triangle, or
Square mode and the Snap Type is set to Grid, the period of the curve (the length of
one curve cycle) is determined by the grid setting. If you press Shift and drag, you
can set the period length manually, in multiples of the grid value.
NOTE
The Line tool can only be used for ramp type automation curves.

Editing Automation Events
Automation events can be edited much like other events.
NOTE
If you move an event or part on a track and you want the automation events to follow
automatically, select Edit > Automation Follows Events. Any automation events at the new
position are overwritten.
●

You can use the tools on the Project window toolbar to edit automation events.

●

You can use the automation event editor to edit selected automation events on ramp
automation curves.

RELATED LINKS
Toolbar on page 41
Automation Event Editor on page 700
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Creating Smooth Transitions Between Automation Events (Bézier
Automation Curves)
Nuendo supports bézier automation curves that allow you to create smooth transitions between
automation events. This way, you can edit linear ramp curves with much more precision,
flexibility, and intuition.
PREREQUISITE
The Object Selection tool is active.
PROCEDURE
1.

Move the mouse pointer on the linear ramp curve segment that you want to edit.
A handle is shown on the curve segment.

NOTE
If the automation events are next to each other on an almost horizontal or vertical line, or
if they are too close to each other, the handle is not available.
2.

Click and drag with the mouse button pressed to modify the shape of the curve segment.

3.

When you are satisfied with the result, release the mouse button.

RESULT
A smooth transition curve according to your edits is created.
If you are not satisfied with the result and want to start over again from the original linear curve
segment, double-click the handle.
You can use bézier automation curves with tracks that are connected to VCA faders.
AFTER COMPLETING THIS TASK
For even more precise editing, add new automation events to your bézier curve segment.

This creates new segments that you can smoothen as described above.

RELATED LINKS
VCA Fader Settings on page 414
VCA Fader Automation on page 416

Selecting Automation Events
●

To select an automation event, click it with the Object Selection tool.

●

To select multiple events, drag a selection rectangle with the Object Selection tool or
Shift-click the events.
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●

To select multiple events, select a range with the Range Selection tool or Shift-click the
events.

●

To select all automation events on an automation track, right-click the automation track
and select Select All Events from the context menu.

Selected events are indicated by a dark color.
NOTE
If you select several events of a ramp automation curve, the automation event editor becomes
available.

RELATED LINKS
Automation Event Editor on page 700

Automation Event Editor
The automation event editor allows you to edit selected events on the automation track. The
automation event editor is only available for automation ramp curves.
NOTE
All editing in the automation event editor only affects the automation events that are part of the
selection.
To open the automation event editor, do one of the following:
●

Activate the Object Selection tool and drag a selection rectangle on a ramp type
automation track.

●

Activate the Range Selection tool and select a range on a ramp type automation track.
NOTE
If you work with the Range Selection tool, the smart control for Stretch is not available.

The automation event editor features the following smart controls for specific editing modes:

1

Tilt Left
If you click in the upper left corner of the editor, you can tilt the left part of the curve. This
allows you to tilt the event values at the start of the curve upwards or downwards.

2

Compress Left
If you Alt-click in the upper left corner of the editor, you can compress or expand the left
part of the curve. This allows you to compress or expand the event values at the start of
the curve.

3

Scale Vertically
If you click in the middle of the upper border of the editor, you can scale the curve
vertically. This allows you to raise or lower the event values of the curve in percent.

4

Move Vertically
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If you click on the upper border of the editor, you can move the entire curve vertically. This
allows you to raise or lower the values of the event values of the curve.
5

Compress Right
If you Alt-click in the upper right corner of the editor, you can compress or expand the
right part of the curve. This allows you to compress or expand the event values at the end
of the curve.

6

Tilt Right
If you click in the upper right corner of the editor, you can tilt the right part of the curve.
This allows you to tilt the event values at the end of the curve upwards or downwards.

7

Scale Around Relative Center
If you Alt-click in the middle right border of the editor, you can scale the curve relative to
its center. This allows you to raise or lower the event values horizontally around the center
of the editor.

8

Scale Around Absolute Center
If you click in the middle right corner of the editor, you can scale the curve absolute to its
center. This allows you to raise or lower the event values horizontally around the center of
the editor.

9

Stretch
If you click on the lower border of the editor, you can stretch the curve horizontally. This
allows you to move the event values of the curve to the left or to the right.

NOTE
To edit the automation curves on several tracks simultaneously, select the automation events
using the Object Selection tool or the Range Selection tool on the corresponding automation
tracks, and hold down Ctrl/Cmd while using the smart controls.
NOTE
If you select automation events using the Range Selection tool, additional automation events
are automatically created at the start and the end of the selection. This ensures that the entire
selection is edited.

RELATED LINKS
Automation Curves on page 695

Quick Vertical Scaling of Automation Events
You can scale the curve segment between two automation events vertically without any need to
select the events first.
PROCEDURE
1.

Move the mouse pointer to the upper border of the automation track above the linear
ramp curve segment that you want to scale.
A handle is shown.

2.

Click and drag up or down with the mouse button pressed.

3.

When you are satisfied with the result, release the mouse button.
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RESULT
The curve segment between the two automation events is scaled.

Moving Automation Events
Moving Single Automation Events
●

To move a selected automation event, click it and drag to the left or to the right.

●

To restrict the direction of the movement, press Ctrl/Cmd and drag.
NOTE
Snap is taken into account when you move automation curves horizontally. To turn it off
temporarily, hold down Ctrl/Cmd and any other modifier, and drag.

Moving Multiple Automation Events
●

To move a selection of automation events, click inside the selection rectangle and drag to
the left or to the right.
If you made a continuous selection of automation events, events at the destination range
are overwritten. However, if you move the same selection range past already existing
events, they appear again. If a selection range contains automation events that are
deselected, dragging is restricted. You cannot move this selection past existing events.

●

To copy a continuous selection of automation events, click inside the selection rectangle,
hold down Alt, and drag to the left or to the right.

NOTE
If you press Esc while dragging the selection rectangle, the selection jumps back to its original
position.

RELATED LINKS
Selecting Automation Events on page 699

Removing Automation Events
●

To remove an automation event, click on it with the Erase tool.

●

To remove multiple automation events, select them and press Backspace or Delete or
select Edit > Delete.

●

When Use Virgin Territory is enabled, this creates a gap. When disabled, the events
within the range are removed.

●

To remove all automation events from the automation track and close the automation
track, click the automation parameter name in the track list and select Remove Parameter
from the pop-up menu.

NOTE
When removing automation events, the curve is redrawn to connect the remaining events.

RELATED LINKS
Virgin Territory vs. Initial Value on page 704
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Automation Tracks
Most of the tracks in your project have automation tracks, one for each automated parameter.
To show automation tracks, you must open them.

Showing/Hiding Automation Tracks
●

Position the mouse pointer over the lower left corner of the track and click the arrow icon
(Show/Hide Automation) that appears.

●

Right-click the track in the track list and select Show/Hide Automation from the context
menu.

●

To open another automation track, position the mouse pointer over the lower left corner
of an automation track and click + (Append Automation Track).

●

To show all used automation tracks in the track list, right-click any track and select Show
All Used Automation from the context menu.

●

To open the corresponding automation track on writing automation parameters, select
Project > Automation Panel > Automation Settings > Reveal Parameter on Write.

Removing Automation Tracks
●

To remove an automation track together with all automation events, click the parameter
name, and from the pop-up menu, select Remove Parameter.

●

To remove all automation tracks from a track that do not contain automation events, select
Remove Unused Parameters from any of its automation parameter name pop-up menus.

●

To remove automation tracks, you can also select Project > Automation Panel >
Functions and select one of the options to delete automation.

Assigning a Parameter to an Automation Track
Parameters are already assigned to automation tracks when you open them, according to their
order in the parameter list.
PROCEDURE
1.

Open an automation track and click on the automation parameter name.
A parameter list is shown. The content depends on the track type.

2.

From the pop-up menu, select the parameter or select More to open the Add Parameter
dialog that lists all parameters that can be automated, and select the parameter there.

RESULT
The parameter replaces the current parameter in the automation track.
NOTE
The replacement of the automation parameter is non-destructive. If the automation track
contains any automation data for the parameter that you just replaced, this data is there,
although it is not visible. By clicking on the automation parameter name in the track list, you can
switch back to the replaced parameter. On the pop-up menu, an asterisk (*) is shown after the
parameter name for hidden automation tracks.
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Muting Automation Tracks
By muting an automation track, you turn off automation for a single parameter.
●

To mute individual automation tracks, click Mute Automation in the track list.

Virgin Territory vs. Initial Value
For parameter automation, Nuendo works either with an initial value or with virgin territory.
When no automation data exists for a particular parameter, the starting point of an automation
pass is saved as the initial value. When you punch out of the automation pass, it is this initial
value to which the parameter will return. This has one important consequence: As soon as the
initial value is set, the corresponding parameter is fully automated for the complete track, at any
given timecode position of the project – even if your automation pass lasted only 2 seconds.
When you release a control, it returns to the value that is defined by the automation curve – even
when in stop mode.
When you enable Use Virgin Territory, no automation curve is displayed on the automation
track, and you find automation data only where you actually perform an automation pass. After
an automation pass, you will find virgin territory only to the right of the last automation event.

Creating Gaps
Gaps are empty sections between automation curves. You can create gaps inside a section with
automated values.
PROCEDURE
1.

Select Project > Automation Panel.

2.

Click Automation Settings and activate Use Virgin Territory.

3.

With the Range Selection tool, select a range on an automation track with existing
automation data and press Delete or Backspace.

RESULT
A gap is created and new events at the beginning and the end of the selection range are created.
These mark the end point of the automation curve to the left and the start of the next
automation curve to the right of the gap.

Defining a Terminator Point
You can define any automation event on the automation curve as the terminator point of this
part of the curve. This will automatically delete the line between this event and the next one,
creating a gap.
PROCEDURE
1.

In the automation curve, click the event that you want to define as the last point to select
it.

2.

In the Project window info line, set Terminator to Yes.
The line between this event and the next one is deleted and a gap is created.
NOTE
If you define the last automation event of an automation curve as terminator point, any
automation data to the right of this event (as defined by an initial value) is deleted.
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Automation Panel
The Automation panel is a floating window, similar to the MixConsole and Transport panel, and
can be left open while you work.

To show the Automation panel, do one of the following:
●

Select Project > Automation Panel.

●

On the Project window toolbar, click Open Automation Panel.

●

Press F6.

Read/Write Buttons
In the upper part of the Automation Panel, you will find the Read and Write buttons. These are
used to globally enable or disable Read and Write on all tracks.

●

To enable all Read buttons on all tracks/channels of your project, click Activate Read for
all tracks.

●

To disable all Read buttons, click Deactivate Read for all tracks.

●

To enable all Write buttons and, at the same time, all Read buttons on all tracks/channels
of your project, click Activate Write for all tracks.

●

To disable all Write buttons, click Deactivate Write for all tracks. The Read buttons will
remain enabled.

Automation Modes
Nuendo provides different punch out modes for automation: Touch, Auto-Latch, and CrossOver. In all modes, automation data will be written as soon as a parameter control is touched in
play mode. They differ in their punch out behavior.
The automation modes are available on the upper part of the Automation Panel and on the
Project window toolbar on the Global Automation Mode pop-up menu.

NOTE
The automation mode set on the Automation Panel or the Project window toolbar is used
globally for all tracks of your project. If you want to select a different automation mode for
individual tracks, select the track, and on the Track Automation Mode pop-up menu in the
Inspector, select the corresponding option.
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You can change the automation mode at any time, for example, in play or stop mode or during
an automation pass. You can also assign key commands to the automation modes.
The current automation pass will always punch out as soon as one of the following conditions is
met, independent of which automation mode is selected:
●

If you disable Write.

●

If you stop playback.

●

If you activate Fast Forward/Rewind.

●

If the project cursor reaches the right locator in Cycle mode.

●

If you click in the ruler to move the project cursor. This is user-definable and can be
controlled via the Automation Panel.

RELATED LINKS
Automation Settings on page 720

Touch
Touch mode is useful in situations where you want to make a change lasting only a few seconds
to an already set up parameter.

●

Touch writes automation data only for as long as you actually touch a parameter control.
Punch out occurs as soon as you release the control.

●

After punch out, the control returns to the previously set value.

NOTE
You can set the time it takes for the parameter to reach the previously set value with the Return
Time setting in the Automation Settings.

RELATED LINKS
Automation Settings on page 720
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Auto-Latch
Auto-Latch is useful in situations where you want to keep a value over a longer period of time –
for example when making EQ settings for a particular scene. In Auto-Latch mode, there is no
specific punch out condition other than those that are valid in all modes.

●

Once your pass has started, the writing of automation data continues for as long as
playback lasts or Write is enabled.

●

When you release the control, the last value is kept until you punch out.

NOTE
The automation mode for On/Off switches is always Auto-Latch even if another mode is selected
globally or for the track.

Cross-Over
Cross-Over mode allows you to perform a manual return to ensure smooth transitions between
new and existing automation settings. For Cross-Over, the punch out condition is crossing over
an already existing automation curve after touching the parameter for a second time. The CrossOver mode can be used in situations where you are not satisfied with an automation curve or
with the automatically applied return settings.

●

Once your pass has started, the writing of automation data continues for as long as
playback lasts or Write is enabled.

●

When you release the control, the automation pass continues, with the value setting
remaining the same.
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●

When you re-touch the fader and move it towards the original value, punch out occurs
automatically as soon as you cross the original curve.

RELATED LINKS
Automation Settings on page 720

Trim
Trim allows you to modify the automation curve from a previous pass. If you activate Trim, a
trim curve is positioned in the middle of the automation track.

NOTE
Trim works for channel volume and cue send level adjustments.
If you activate Trim, all editing and recording affects the trim curve. If you deactivate Trim, it
affects the original automation curve instead.
You can edit trim data like any other automation data. It is stored with the project.
●

Drag the trim curve up or down and add automation events to it.
These increase or decrease the values of the original automation curve, but allow you to
preserve the original data.

You can use Trim either in stop or in play mode:
●

In stop mode, you can select one of the Fill options and edit the trim curve manually by
clicking on it and moving it up or down. The original automation curve is displayed in a
lighter color and its values are merged with the trim curve. The resulting automation curve
is displayed in a darker color.

●

In play mode, the events of the original automation curve are trimmed as the project
cursor passes over them.

NOTE
Trim also works with bézier automation curves.

RELATED LINKS
Creating Smooth Transitions Between Automation Events (Bézier Automation Curves) on page
699
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Freeze Trim
You can freeze your trim curve automatically or manually. This renders all trim data into a single
automation curve.
●

To freeze your trim curve automatically whenever a write operation is finished, open the
Automation Settings and select On Pass End in the Freeze Trim pop-up menu.

●

To freeze your trim curve automatically when Trim mode is switched off, open the
Automation Settings and select On Leaving Trim Mode in the Freeze Trim pop-up
menu.

●

To freeze your trim curve manually, open the Automation Settings and select Manually
in the Freeze Trim pop-up menu. To freeze a specific parameter for the track, click the
parameter name, and from the pop-up menu, select Freeze Trim.

●

To freeze the trim automation for all tracks in the project, open the Automation Panel,
and in the Functions pop-up menu, select Freeze All Trim Automation in Project.
To freeze the trim automation of all selected tracks, open the Automation Panel, and in
the Functions pop-up menu, select Freeze Trim Automation of Selected Tracks.

Cleaning Automation
You can delete redundant automation points or unwanted automation spikes that are caused by
editing automation points or inaccurate writing of automation data.

Reducing Automation Events
Editing automation points can result in redundant automation points. The Reduce Automation
Events function allows you to reduce the number of redundant points and to smoothen the
automation curve.
NOTE
In the Automation Settings, you can set the Reduction Level.

PROCEDURE
1.

On the toolbar, click Open Automation Panel.

2.

On the Automation Panel, click Functions.

3.

On the pop-up menu, select one of the following options:
●

To reduce the number of automation points for all tracks in the active project, select
Reduce Automation Events.

●

To reduce the number of automation points for selected tracks only, select Reduce
Automation Events of Selected Tracks.

RELATED LINKS
Reduction Level on page 721
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Deleting Automation Spikes
The Delete Automation Spikes function allows you to delete unwanted spikes in the automation
curve.
Editing automation points or inaccurate writing of automation data can provoke short sections
where the automation values return to their initial level. These situations are visible as spikes in
the automation curve or as jumping faders.
NOTE
In the Automation Settings, you can set a Spike Detection Range from 0 to 200 ms.

PROCEDURE
1.

On the toolbar, click Open Automation Panel.

2.

On the Automation Panel, click Functions.

3.

On the pop-up menu, select one of the following options:
●

To delete automation spikes for all tracks in the active project, select Delete
Automation Spikes.

●

To delete automation spikes for selected tracks only, select Delete Automation
Spikes of Selected Tracks.

RELATED LINKS
Spike Detection Range on page 721

Functions
At the top right of the Automation Panel, you will find the Functions pop-up menu, which
contains a number of global automation commands.
Delete All Automation in Project
Removes all automation data from your project.
Delete Automation of Selected Tracks
Removes all automation data for the selected tracks.
Delete Automation in Range
Deletes all automation data between the left and right locators on all tracks.
Fill Gaps on Selected Tracks
This option is used with virgin territories. Select this to fill any gaps in the automation
curves of the selected tracks with a continuous value. The value of the last event (the
end point) of a section is used to fill the gap. This value is written across the gap up
to one millisecond before the first event of the next automated section. A new event
is inserted here; the value will be ramped to the next automated section.
Fill Gaps with Current Value (Selected Tracks)
This option is used with virgin territories. Select this option to fill any gaps in the
automation curves of the selected tracks. The gaps are filled with the current value of
the corresponding control.
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Create Initial Parameter Events
This function creates and stores the initial automation values for each automatable
parameter in the MixConsole. For parameters that have not been automated yet,
automation events are created at the current parameter position, for example, at
value 0. As initial parameter events are created on all channels, all channels will have
automation data, even if you did not add automation to them. If this is not what you
want, use the Global Snapshot function instead.
Freeze All Trim Automation in Project
Freezes all trim automation for all tracks in the project.
Freeze Trim Automation of Selected Tracks
Freezes all trim automation for the selected tracks.
Global Snapshot: Store
Use this function to save a backup copy of all automatable MixConsole parameters
as a snapshot so that you can reapply them later. The snapshot is saved with the
project. You can only save one snapshot at a time. By storing a snapshot, a
previously stored snapshot may be overwritten.
Global Snapshot: Apply
Applies the stored snapshot.
Global Snapshot: Remove
Removes the stored snapshot.
Reduce Automation Events
Allows you to delete redundant automation points and smoothen the automation
curve for all tracks in the active project.
Reduce Automation Events of Selected Tracks
Allows you to delete redundant automation points and smoothen the automation
curve for the selected tracks.
Delete Automation Spikes
Allows you to delete automation spikes in the automation curve for all tracks in the
active project.
Delete Automation Spikes of Selected Tracks
Allows you to delete automation spikes in the automation curve for the selected
tracks.

Automation Passes
An automation pass begins with the first parameter that is written after activating Write
automation and starting playback. It ends when playback stops, either when you click Stop or
when the position cursor jumps to another position. This occurs when cycle or arranger mode is
activated. You can undo automation passes in the automation pass history.

Activating Automation Passes
PROCEDURE
1.

At the top right of the Automation Panel, click Activate Automation Passes.

2.

Click Passes to open the automation pass history.

3.

Activate Write automation and perform some actions.
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NOTE
Automation passes are only created when you write automation automatically. If you want
to undo manually written automation events use the Edit History instead.

RESULT
The Activate Automation Passes button indicates that an automation pass is running and the
pass is written to the history.

Undoing Automation Passes
PROCEDURE
1.

In the automation pass history, drag the horizontal line upwards.
The corresponding automation events on the automation track are removed and the
entries in the automation pass history are grayed out. The State column displays Undone.
NOTE
All automation that you performed manually as well as other edits and processes
performed during or after the automation passes are also undone.

2.

If you want to redo automation passes again, drag the horizontal line downwards.
The corresponding automation events on the automation track are inserted and the State
column shows Executed again.

Undoing Branches
A branch is a sequence of automation passes.
In a branch, each automation pass is represented by a rectangle with the number of the
automation pass. Automation that you perform manually, as well as other edits and processes in
between automation passes, are represented by smaller rectangles. These rectangles only serve
as indicators, they cannot be used to undo the edits.

When you undo an automation pass and subsequently write new automation, a new branch is
created and all following automation passes are gathered in the new branch.
If you have 2 or more branches, you can choose to undo the automation passes of the separate
branches in the automation pass history by activating and deactivating specific branches.
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Deactivating Undo Branches
PROCEDURE
1.

At the top right of the Automation Panel, click Activate Automation Passes.

2.

Click Passes to open the automation pass history.

3.

In the right section of the Edit History dialog, click a branch to select it.
The actions of the selected branch are displayed in the left section of the dialog.

4.

Click Activate Selected to deactivate all subsequent branches.
All automation passes from the subsequent branches are undone. The automation passes
of the activated branch are redone until the branch ends. For example, the first edits of a
following branch are merged back into it.

5.

To undo and delete a branch, click Remove Inactive.
All branches are removed. The actions of the inactive branch disappear completely
whereas the actions of the active branches are merged.

6.

When you are done, click Activate Automation Passes to return to the regular
Automation Panel.
NOTE
The automation pass history is not saved with the project. If you close your project, the
history is deleted.

Join Options
The Join options help you to resume write automation. This is useful if several editors work on
the same project simultaneously, and running automation passes are interrupted.
NOTE
The Join options are not available in Touch mode.

Activating Join Now
Join Now allows you to resume automation manually.
PROCEDURE
1.

Start playback and watch the automation curve.

2.

When the cursor reaches the desired position, click Join Now.
All parameters from the last pass are punched in and the last value is written for the whole
section. All previous automation events are overwritten.
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Activating Auto Join
Auto Join allows you to resume automation automatically.
PROCEDURE
1.

On the Automation Panel, activate Auto Join.

2.

Start playback and watch the automation curve.
All parameters from the last pass are punched in automatically at the position where you
hit stop. The position is indicated by the join indicator.
NOTE
The join indicator shows the timecode position where the last automation pass was
stopped, for example, the point where the Auto Join will automatically occur. When
automation is resumed, this indicator is updated.

Fill Options
The Fill options define what happens in a specific section of your project when you punch out of
a running automation pass.
The Fill options write one particular value across a defined section of your automation track. Any
previously created data within this section is overwritten.
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You can also combine the various Fill options.

Activating To Punch
PROCEDURE
1.

On the Automation Panel, activate Touch, and activate To Punch as Fill option.

2.

Start playback.

3.

Move the fader until you have found the volume setting that you need and release the
fader to punch out.
The volume curve is set from the point of punch out back to where you punched in. The
values written while moving the fader to find the right value are deleted, and the volume
jumps at exactly the right moment from the value set in the first scene to the value found
for the second scene.

Activating To Start
PROCEDURE
1.

On the Automation Panel, activate Touch, and activate To Start as Fill option.

2.

Start playback.

3.

Move the fader until you have found the volume setting that you need and release the
fader to punch out.
The automation track is filled from where you punched out to the start of the project.

Activating To End
PROCEDURE
1.

On the Automation Panel, activate Touch, and activate To End as Fill option.

2.

Start playback and touch the parameter control to punch in the automation pass.

3.

Move the fader until you have found the setting that you want and release it.
This will punch out the writing of automation data. As you let go of the fader, the
automation curve takes the found value setting, from where you punched out to the end
of the project.

Activating Loop
PREREQUISITE
You have set up a loop range with the left and right locators.
PROCEDURE
1.

On the Automation Panel, activate Touch, and activate Loop to activate it as Fill option.

2.

Start playback.

3.

Move the fader until you have found the volume setting that you need and release the
fader to punch out.
The found value is set within the range that is defined by the left and right locators.
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Activating Gaps
PREREQUISITE
You have set up virgin territories.
NOTE
When Trim is active, Gap has no effect. This is because Trim only modifies already existing data.

PROCEDURE
1.

On the Automation Panel, activate Touch, and activate Gaps to activate it as Fill option.

2.

Start playback.

3.

Move the fader until you have found the volume setting that you need and release the
fader to punch out.
Any gaps between previously written automation events is filled with the last value that
was found during the last automation pass.

RELATED LINKS
Virgin Territory vs. Initial Value on page 704

One Shot vs Continuous Fill
You can use the Fill options in different ways:
●

One shot
When you click one of the Fill buttons, it is highlighted, and will be enabled during the next
automation pass. Afterwards, the option is disabled again.

●

Continuous fill
If you click a Fill button a second time, a lock symbol is displayed on the highlighted
button, indicating that you are in continuous fill mode and that the operation can be
repeated as many times as you want. Click the button a third time to disable the
corresponding Fill option.

Drawing Fill Manually
You can use the Fill options on the Automation Panel in combination with the Draw tool. This
provides you with a powerful method for writing automation data manually.
PROCEDURE
1.

Open an automation track and select the Draw tool.

2.

On the Automation Panel, select To End as a Fill option.

3.

Click and draw to create an automation curve.

4.

Release the mouse button.
At the moment of release, a final automation event is created. The automation curve is
written from this last event through to the end of the project.
NOTE
This procedure can be used with all the Fill options.

716

Automation
Automation Panel

Preview Options
The Preview options allow you to find new settings without recording the steps needed to locate
them.
This is useful if you want to audition changes on automation values without deleting any of the
original automation data. When you have found the settings, you can punch the previewed value.
When changing a preset of a VST plug-in while in Preview mode, the change in the parameter
settings caused by the preset change is recorded automatically as automation. Note that the
plug-in must have 32 or fewer parameters for this to work.

Activating Preview
PROCEDURE
1.

On the Automation Panel, in the Preview section, activate Preview.
NOTE
To set the Preview mode permanently, click Preview 2 times. A lock symbol is displayed
on the highlighted button. You can disable this by clicking the button a third time.

2.

Touch a parameter control.
The Suspend, Punch, and Punch on Play options are displayed. You now have full manual
control of the touch-collected parameter and can suspend any previously recorded
automation data.

3.

Optional: Touch-collect another parameter if you want to write data for several parameters
during the same automation pass.

4.

Play back the scene to find the parameter settings that you want.

5.

Touch the required parameter, start playback, find the value, and activate Punch to start
the new automation pass.

6.

Optional: If you want to compare the value that was found during preview with previously
automated values, activate the Suspend option.
This plays back your audio material using the parameter values set before activating
Preview. You can use the delta indicator in the automation track as an additional visual aid
for comparing the values.

7.

When you are happy with the values found, click Punch to start the new automation pass.
The new value setting is recorded from the point where you punched in to your punch out
position as defined by the automation mode setting.

Punch vs. Punch on Play
When using the Punch option, starting playback and punching in are separate actions. If you
want to punch in when starting playback, activate Punch on Play.
●

Use Punch on Play when you cannot punch in on the fly, for example in situations where
you need to find the punch in position in stop mode. Once you have found the exact
position, enable Punch on Play and start playback from there.

●

Punch is the option to use if you need to listen to the section before your punch in point
and if this section already contains automation data that you do not want to overwrite. Roll
through this section and then punch in the automation pass.

●

You can also use Punch in stop mode. To create automation data in this way, Punch must
be combined with one of the Fill modes.
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Auto Punch
Auto Punch allows you to begin and end the automation pass at defined positions.
●

Activate Preview mode and set the left and right locators at the positions where you want
to automatically punch in and out.

Auto Punch allows you to set up a safe zone for previously written automation data.
●

Place the right locator at the beginning of an area that you want to protect and enable
cycle mode.
This ensures that a running automation pass always punches out before reaching this
section of your project.

Touch Assist
When you use Preview mode, you may get into a situation where you change some parameters,
but not others, although they belong to the same group of parameters (for example EQ settings).
Touch Assist allows you to avoid forgetting some parameters while touch-collecting parameters
for Preview.
When Touch Assist is enabled, the parameters of the following features are treated as groups:
●

Channel EQ module (21 parameters)

●

Aux send on/off and send level

●

Stereo panner

●

Surround panner (Left-Right, Front-Rear, LFE)

●

Insert plug-ins (only available for plug-ins with 32 or fewer parameters)

Touch Assist ensures that touching one parameter in a group will touch all other parameters in
that group as well.
However, if you want to automate only one particular parameter, disable Touch Assist to avoid
inadvertently overwriting any previously created automation data.
NOTE
Enabling Touch Assist may lead to the creation of a large amount of automation data, causing a
higher CPU load. Only use Touch Assist if the performance is still acceptable.

Punch Log
The Punch Log section displays a list of the recent punch in operations that you performed in
Preview mode. You can load one of these log entries for the current track to recall the
corresponding touch-collected parameters and their values at the moment of punch in.
●

To load an entry in the punch log, select it in the list and click Load.
The Preview button on the Automation Panel and on the corresponding automation
track lights up.
NOTE
When loading a log entry, you add the corresponding parameters to any other parameters
that you have touch-collected during the current preview session. However, if you
manually touch-collect the volume parameter, for example, and then add volume again by
loading a punch log entry, the settings for volume from the punch log are used, replacing
any values set manually.

●

To rename any log, double-click it and enter a new name.

●

To delete an entry, select it and click Delete.
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●

To specify how many log entries are displayed, use the Max Punch Logs setting in the
Automation Settings section.
If this value is set to 10 entries, the eleventh punch event overwrites the entry created for
the first event, the twelfth replaces the second entry, etc. The maximum possible number
of punch log entries is 100.

●

To prevent a particular entry from being overwritten, click in the right section for this
entry, so that a checkmark is displayed.

Punch log entries are saved with the current project.
Punch log data is always project-specific. You cannot export log entries to another project.

Suspend Options
This section on the Automation Panel allows you to exclude specific parameters from the
reading or writing of automation data. This way, you have full manual control of these
parameters.

Suspend Read
Suspending the reading for a specific parameter during automation gives you full manual control
of it.
●

To suspend the reading of automation data for a specific parameter, click the
corresponding parameter.

●

To suspend the reading of automation data for all parameters/parameter groups, click All.
NOTE
When any of the options in the Suspend Read category are enabled, clicking All will
disable these buttons.

EXAMPLE
Imagine that you have already automated several tracks. While working on the current track, you
want one of the other tracks to be louder, to better identify a particular position in your audio
material.
By suspending Read for the volume parameter, you regain full manual control and can set the
volume to the required level.

Suspend Write
Suspending the writing for a specific parameter during automation punches this parameter out
of the automation pass.
●

To suspend the writing of automation data for a specific parameter, click the
corresponding parameter.

●

To suspend the writing of automation data for all parameters/parameter groups, click All.
NOTE
When any of the options in the Suspend Write category are enabled, clicking All will
disable these buttons.

EXAMPLE
Imagine the following situation: To help you concentrate while working on a particular track, you
mute several other tracks. However, because write automations are active on these tracks, this
mute state is also automated during the next automation pass – a classic situation in mixing.
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To avoid inadvertently excluding whole tracks from your mix in this way, you can exclude Mute
from all automation writing. Simply click Mute in the Suspend Write category on the
Automation Panel.

Show Options
The Show options allow you to open all automation tracks for a specific parameter. This gives
you an overview of the automated parameter.
●

To open the volume, pan, EQ, sends, or inserts automation tracks for all tracks, click the
corresponding parameter.
The automation tracks are opened even if no automation data was recorded on these
tracks.

●

To step through the individual parameter sets of parameter groups, for example Pan, EQ,
Sends, and Inserts, click the respective button repeatedly.

●

To show only the automation tracks for which automation data has already been written,
activate Used Only and click one of the options.

●

To show all automation tracks that contain automation data, activate Show Used.

●

To hide all open automation tracks, activate Hide All.

NOTE
The Show options on the Automation Panel affect all tracks.

Automation Settings
To set up specific automation settings, click the button in the bottom left of the automation
panel.
Use Undo Branches
Activate this to gather automation passes in branches.
Show Data on Tracks
Activate this to show audio waveforms or MIDI events on automation tracks.
The events are displayed only if Show Waveforms is enabled in the Preferences
dialog (Event Display—Audio page), and if Part Data Mode is set to an option other
than No Data(Event Display—MIDI page).
Use Virgin Territory
Activate this if you want to use virgin territories.
Continue Writing
If you activate this option, the recording of automation will not be blocked when
locating to a new position. This can be used to perform multiple automation passes
in cycle mode or if you are using the arranger functions.
If this option is deactivated and you write automation data and locate to another
position in the project, the writing will be stopped until the mouse button is released
or until a stop command is received.
Reveal Parameter on Write
If you activate this option, the corresponding automation track is revealed on writing
automation parameters. This is useful if you want to have a visual control of all
parameters changed on writing.
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Return Time
This determines how fast the automated parameter returns to any previously
automated value when you release the mouse button. Set this to a value higher than
0 to prevent sudden jumps in your parameter settings which may lead to crackles.
Reduction Level
Punching out or using the Reduce Automation Events function removes all
superfluous automation events. This results in an automation curve that contains
only the events necessary to reproduce your actions. A reduction level value of 0 %
removes repeated automation points only. A reduction level value between 1 to 100
% smoothens the automation curve. The default value of 50 % should reduce the
automation data amount significantly without touching the sound result of the
existing automation.
Spike Detection Range
Defines a period of time in which sudden changes in the automated parameter are
considered to be unwanted spikes. The spikes can be removed using the Delete
Automation Spikes function. You can set values from 0 to 200 ms.
Max Punch Logs
This specifies how many log entries are displayed. You can set values from 5 to 100.
Freeze Trim
In this pop-up menu, you can specify how to freeze your trim curve.
●

To freeze your trim curve manually, select Manually.

●

To perform a freeze whenever a write operation is finished, select On Pass
End.

●

If you want the trim data to freeze automatically when the trim mode is
switched off (globally or individually for a track), select On Leaving Trim
Mode.

RELATED LINKS
Automation Passes on page 711
Virgin Territory vs. Initial Value on page 704
Punch Log on page 718

MIDI Controller Automation
When working with Nuendo, it is possible to record automation data for MIDI controllers as MIDI
part data and as data on an automation track.
If you have such conflicting automation data, you can specify separately for every parameter how
these will be combined during playback. This is done by selecting an automation Merge Mode in
the track list for the automation track.

Automation Merge Modes
This pop-up menu is only available for controllers that can be recorded both for a part and a
track. The settings that you make for a controller are applied to all MIDI tracks that use this
controller.
Use Global Settings
When this is selected, the automation track uses the global automation Merge Mode
that is specified in the MIDI Controller Automation Setup dialog.
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Replace 1 - Part Range
When this option is selected, the part data has playback priority over the automation
track data. At the left and right part borders, for example, the automation mode
switches abruptly from part to track automation, and vice versa.
Replace 2 - Last Value Continues
Similar to the above, but part automation only begins when the first controller event
within the part is reached. At the end of the part, the last controller value is kept until
an automation event is reached on the automation track.
Average
When this option is selected, the average values between part and track automation
is used.
Modulation
In this mode, the automation track curve modulates the existing part automation,
with higher curve points emphasizing the automation values and lower curve points
reducing the automation values even further.

MIDI Controller Automation Setup
In the MIDI Controller Automation Setup dialog, you can specify how existing MIDI automation
is handled on playback and new automation data is recorded in a MIDI part or as track
automation. All settings that you make in this dialog are saved with the project.
●

To open the MIDI Controller Automation Setup select MIDI > CC Automation Setup.

Record Destination on Conflict (global)
Allows you to determine which destination is used if MIDI controller data is received
by Nuendo and both the Record and the Write Automation buttons are enabled.
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Select MIDI Part to record MIDI part automation. Select Automation Track to
record the controller data on an automation track in the Project window.
Automation Merge Mode (global)
Allows you to specify the global merge mode for automation.
Controller list
Lists all MIDI controllers for which you can specify the record destination and the
merge mode for automation separately. This gives you full control over the MIDI
automation (destination as well as merge mode) in your project.
Record Destination
Click in the Record Destination column for a MIDI controller to open the pop-up
menu where you can choose where you want recorded data of this particular MIDI
controller to be saved.
Automation Merge Mode
Click in the Automation Merge Mode column for a MIDI controller to specify what
happens with data for this specific controller on playback.
Save As Default
Allows you to save the current settings as default settings. When you create a new
project, the default settings are used.
Load Default
Allows you to load the default settings.
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VST instruments are software synthesizers or other sound sources that are contained within
Nuendo. They are played internally via MIDI. You can add effects or EQ to VST instruments.
Nuendo allows you to make use of VST instruments in the following ways:
●

By adding a VST Instrument and assigning one or several MIDI tracks to it.

●

By creating an instrument track.
This is a combination of a VST instrument, an instrument channel, and a MIDI track. You
play and record MIDI note data directly for this track.

NOTE
Some VST instruments are included with Nuendo. These are described in the separate document
Plug-in Reference.

RELATED LINKS
Instrument Tracks on page 108

Adding VST Instruments
PROCEDURE
1.

On the Studio menu, select VST Instruments.

2.

Right-click on an empty area of the VST Instruments window.

3.

From the context menu, select one of the following:

4.

●

Add Track Instrument

●

Add Rack Instrument

From the instrument selector, select an instrument.
●

Click Add Track if you chose to add a track instrument.

●

Click Create if you chose to add a rack instrument.

RESULT
If you chose Add Track Instrument, the instrument control panel opens, and an instrument
track with the name of the instrument is added to your project.
If you chose Add Rack Instrument, the instrument control panel opens, and the following tracks
are added to the track list:
●

A MIDI track with the name of the instrument. The output of the MIDI track is routed to
the instrument.
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NOTE
In the Preferences dialog (VST—Plug-ins page), you can specify what happens when you
load a VST instrument.
●

A folder with the name of the instrument that is added within a VST Instruments folder.
The instrument folder contains two automation tracks: one for the plug-in parameters and
one for the synth channel in the MixConsole.

Creating Instrument Tracks
You can create instrument tracks that hold dedicated VST instruments.
PROCEDURE
1.

Select Project > Add Track > Instrument.

2.

Open the Instrument pop-up menu and select a VST instrument for the instrument track.

3.

Click Add Track.

RESULT
The selected VST instrument is loaded for the instrument track. In the MixConsole an instrument
channel is added.

VST Instruments in the Right Zone
The VST Instruments in the right zone of the Project window allow you to add VST instruments
for MIDI and instrument tracks.
All instruments that are used in your project are shown. You can access up to 8 quick controls for
each added instrument.
To open the VST Instruments in the right zone, click Show/Hide Right Zone on the Project
window toolbar, and at the top of the right zone, click the VST Instruments tab.

NOTE
The VST Instruments in the right zone are just another representation of the VST Instruments
window. All features are the same.

725

VST Instruments
VST Instruments Window
RELATED LINKS
Showing/Hiding Zones on page 40

VST Instruments Window
The VST Instruments window allows you to add VST instruments for MIDI and instrument
tracks.
All instruments that are used in your project are shown. You can access up to 8 quick controls for
each added instrument.
To open the VST Instruments window, select Studio > VST Instruments.

RELATED LINKS
Instrument Tracks on page 108

VST Instruments Toolbar
The VST instruments toolbar contains controls that allow you to add and set up VST instruments
and VST quick controls.
The following controls are available:

1

Add Track Instrument
Opens the Add Instrument Track dialog that allows you to select an instrument and add
an instrument track that is associated to this instrument.

2

Find Instruments
Opens a selector that allows you to find a loaded instrument.

3

Set Remote-Control Focus for VST Quick Controls to Previous/Next Instrument
Allows you to set the remote-control focus to the next/previous instrument.

4

Show/Hide all VST Quick Controls
Shows/Hides the default quick controls for all loaded instruments.

5

Settings
Opens the Settings menu where you can activate/deactivate the following modes:
●

Show VST Quick Controls for One Slot Only shows the VST Quick Controls
exclusively for the selected instrument.

●

MIDI Channel follows track selection ensures that the Channel selector follows
the MIDI track selection in the Project window. Use this mode if you work with
multitimbral instruments.

●

Remote-Control Focus for VST Quick Controls follows track selection ensures
that the VST Quick Control remote-control focus follows the track selection.
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VST Instrument Controls
The VST instrument controls allow you to make settings for a loaded VST instrument.
The following controls are available on each instrument:

1

Activate Instrument
Activates/Deactivates the instrument.

2

Edit Instrument
Opens the instrument panel.

3

Freeze Instrument
Freezes the instrument. This allows you to save CPU power.

4

Instrument Selector
Allows you to select another instrument. Double-click to rename the instrument. The name
is shown in the VST Instruments window in the Output Routing pop-up menu for MIDI
tracks. This is useful when you work with several instances of the same instrument.

5

Preset Browser
Allows you to load or save an instrument preset.

6

Input Options
This lights up when MIDI data is received by the instrument. Click this button to open a
pop-up menu that allows you to select, mute/unmute, and solo/unsolo for tracks that send
MIDI to the instrument (inputs).
NOTE
If you resize the VST Instruments window, you can access this option by using an Input/
Output Options pop-up menu.

7

Activate Outputs
This control is only available if the instrument provides more than one output. It allows
you to activate one or more outputs for the instrument.
NOTE
If you resize the VST Instruments window, you can access this option by using an Input/
Output Options pop-up menu.

8

Read/Write Automation
Allows you to read/write automation for the instrument parameter settings.

9

Select Quick Control Layer
Allows you to select a program.

NOTE
The Activate Side-Chain option allows you to activate/deactivates side-chain input for VST 3
instruments that support side-chaining.

RELATED LINKS
Freezing Instruments on page 730
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VST Instrument Context Menu
The following functions are available in the instruments context menu:
Copy/Paste Instrument Setting
Allows you to copy the instrument settings and paste them to another instrument.
Load/Save Preset
Allows you to load/save an instrument preset.
Default Preset
Allows you to define and save a default preset.
Switch to A/B Setting
Activates the setting A or B.
Copy A to B
Copies the effect parameters of effect setting A to effect setting B.
Activate Outputs
Allows you to activate one or more outputs for the instrument.
Activate Side-Chain
Activates/Deactivates side-chain input for the instrument.
NOTE
This option is only available for VST 3 instruments that support side-chaining.
Remote Control Editor
Opens the Remote Control Editor.
RELATED LINKS
Side-Chain Input for VST Instruments on page 735

Presets for Instruments
You can load and save presets for instruments. These contain all the settings that are required
for the sound that you want.
The following presets for instruments are available:
●

VST presets include the parameter settings of a VST instrument.
These are available from the VST instruments window, from the instrument control
panels, and from the Programs field in the Inspector.

●

Track presets include the instrument track settings and the settings for the corresponding
VST instrument.
These are available from the Inspector or the track list context menu.
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Loading VST Presets
You can load VST Presets from the VST Instruments window, from the instrument panel or from
the Inspector.
PROCEDURE
1.

2.

Do one of the following:
●

Select the track that contains the VST instrument and in the Inspector, click the
Programs field.

●

In the VST Instruments window, click Preset Browser for the instrument, and
select Load Preset.

●

In the control panel for the VST instrument, click Preset Browser, and select Load
Preset.

In the preset browser, select a preset from the list and double-click it to load it.

RESULT
The preset is applied. To return to the previously loaded preset, open the preset browser again
and click Revert to Last Setting.

Saving VST Presets
You can save your settings on VST instruments as VST presets for further use.
PROCEDURE
1.

Do one of the following:
●

In the VST Instruments window, click Preset Browser for the instrument, and
select Save Preset.

●

In the control panel for the VST instrument, click Preset Browser, and select Save
Preset.

2.

In the Save <VST instrument name> Preset dialog, enter a name for the preset.

3.

Optional: Click Show Attribute Inspector and define attributes for the preset.

4.

Click OK to save the preset and close the dialog.

Loading Track Presets
You can load track presets for instrument tracks from the Inspector.
PROCEDURE
1.

2.

Do one of the following:
●

Select the instrument track and in the Inspector, click the Load Track Preset field.

●

Right-click the instrument track and from the context menu, select Load Track
Preset.

In the preset browser, select a preset from the list and double-click it to load it.

RESULT
The track preset is applied. To return to the previously loaded preset, open the preset browser
again and click Revert to Last Setting.
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Saving Track Presets
You can save your settings on instrument tracks as track presets for further use.
PROCEDURE
1.

Do one of the following:
●

Select the instrument track and in the Inspector, click Save Track Preset.

●

Right-click the instrument track and from the context menu, select Save Track
Preset.

2.

In the Save Track Preset dialog, enter a name for the preset.

3.

Optional: Click Show Attribute Inspector and define attributes for the preset.

4.

Click OK to save the preset and close the dialog.

Playing Back VST Instruments
After you have added a VST instrument and selected a sound, you can play back the VST
instrument using the instrument or MIDI track in your project.
PROCEDURE
1.
2.

In the track list, activate Monitor for the track that has the VST instrument loaded.
Press one or more keys on your MIDI keyboard or use the On-Screen Keyboard.
The corresponding sounds are triggered on your VST instrument.

3.

Select Studio > MixConsole to open the MixConsole and adjust the sound, add EQ or
effects, assign another output routing, etc.

VST Instruments and Processor Load
VST instruments can consume a lot of CPU power. The more instruments you add, the more likely
you will run out of processor power during playback.
If the CPU overload indicator in the Audio Performance window lights up or you get crackling
sounds, you have the following options:
●

Activate Freeze for instruments.
This renders the instrument into an audio file and unloads it.

●

Activate Suspend VST 3 plug-in processing when no audio signals are received for VST
3 instruments.
This ensures that your instruments do not consume CPU power on silent passages.

RELATED LINKS
Freezing Instruments on page 730
Suspend VST 3 plug-in processing when no audio signals are received on page 1210

Freezing Instruments
If you are using a moderately powerful computer or a large number of VST instruments, your
computer may not be able to play back all instruments in realtime. At this point, you can freeze
instruments.
PROCEDURE
1.

Do one of the following:
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●

Select Studio > VST Instruments.

●

Select the instrument track and open the top Inspector section.

2.

Click Freeze.

3.

In the Freeze Instrument Options dialog, make your settings.

4.

Click OK.

RESULT
●

The instrument is rendered to an audio file and on playback you hear the same sound as
before freezing.

●

Less CPU load is used.

●

The Freeze button lights up.

●

The MIDI/instrument track controls are grayed out.

●

The MIDI parts are locked.

NOTE
To edit the tracks, parameters, or synth channels again, and to delete the rendered file, unfreeze
the instrument by clicking Freeze again.

Freeze Instrument Options
The Freeze Instrument Options dialog opens when you click Freeze. It allows you to specify
exactly what should happen if you freeze an instrument.
The following controls can be found in the Freeze Instrument Options dialog:
Freeze Instrument Only
Activate this option if you still want to be able to edit insert effects on the synth
channel after freezing the instrument.
Freeze Instrument and Channels
Activate this option if you do not need to edit the insert effects on your synth
channels.
NOTE
You can still adjust level, pan, sends, and EQ.
Tail Size
Allows you to set a Tail Size time to let sounds complete their normal release cycle.
Unload Instrument when Frozen
Activate to unload the instrument after freezing. This makes the RAM available again.

Latency
The term latency stands for the time it takes for the instrument to produce a sound when you
press a key on your MIDI controller. It can be an issue when using VST instruments in realtime.
Latency depends on your audio hardware and its ASIO driver.
In the Studio Setup dialog (VST Audio System page), the input and output latency values should
ideally be a few milliseconds.
If the latency is too high to allow comfortable realtime VST instrument playback from a keyboard,
you can use another MIDI sound source for live playback and recording, and switch to the VST
instrument for playback.
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RELATED LINKS
Selecting an Audio Driver on page 13

Delay Compensation
During playback Nuendo automatically compensates any delay inherent in the VST plug-ins you
use.
You can specify a Delay Compensation Threshold in the Preferences dialog (VST page) so that
only plug-ins with a delay higher than this threshold setting are affected.

Constrain Delay Compensation
To avoid Nuendo to add latency when you play a VST instrument in realtime or record live audio,
you can activate Constrain Delay Compensation. This minimizes the latency effects of the delay
compensation, while maintaining the sound of the mix as far as possible.
Constrain Delay Compensation is available on the Project window toolbar and in the
Transport zone. You can also find it as a menu item in the MixConsole on the Functions menu.
Activating Constrain Delay Compensation turns off VST plug-ins which are activated for VST
instrument channels, audio track channels that are record-enabled, group channels, and output
channels. VST plug-ins which are activated for FX channels are disregarded. After recording or
using a VST instrument Constrain Delay Compensation should be deactivated again in order to
restore full delay compensation.

Import and Export Options
Importing MIDI Loops
You can import MIDI loops (file extension .midiloop) in Nuendo. These files contain MIDI part
information (MIDI notes, controllers, etc.) and all the settings that are saved in instrument track
presets. This way, you can reuse instrument patterns in other projects or applications, for
example.
PROCEDURE
1.

Select Media > MediaBay.

2.

Optional: In the Results section, open the Select Media Types menu, and activate MIDI
Loops and Plug-in Presets.

3.

In the results list, select a MIDI loop and drag it to an empty section in the Project window.
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RESULT
An instrument track is created and the instrument part is inserted at the position where you
dragged the file. The Inspector reflects all settings that are saved in the MIDI loop, for example,
the VST instrument that was used, applied insert effects, track parameters, etc.
NOTE
You can also drag MIDI loops onto existing instrument or MIDI tracks. However, this only imports
the part information. This means this part only contains the MIDI data (notes, controllers) that is
saved in the MIDI loop, but no inspector settings or instrument parameters.

RELATED LINKS
Presets for Instruments on page 728
Filtering According to Media Type on page 619

Exporting MIDI Loops
You can export MIDI loops to save a MIDI part together with its instrument and effect settings.
This allows you to reproduce patterns that you created without having to search for the correct
sound, style, or effect. MIDI loops have the file extension .midiloop.
PROCEDURE
1.

Select an instrument part.

2.

Select File > Export > MIDI Loop.

3.

In the New MIDI Loop section, enter a name for the MIDI loop.

4.

Optional: To save attributes for the MIDI loop, click the button below the New MIDI Loop
section at the bottom left.
The Attribute Inspector section opens, allowing you to define attributes for your MIDI
loop.

5.

Click OK.

RESULT
MIDI Loop files are saved in the following folder:
Windows: \Users\<user name>\AppData\Roaming\Steinberg\MIDI Loops
macOS: /Users/<user name>/Library/Application Support/Steinberg/MIDI Loops/
The default folder cannot be changed. However, you can create subfolders within this folder to
organize your MIDI loops. To create a subfolder, click New Folder in the Save MIDI Loop dialog.

Exporting Instrument Tracks as MIDI File
You can export instrument tracks as standard MIDI files.
NOTE
●

As there is no MIDI patch information in an instrument track, this information is missing in
the resulting MIDI file.

●

If you activate Export Inspector Volume/Pan, volume and pan information of the VST
instrument are converted and written into the MIDI file as controller data.

RELATED LINKS
Exporting MIDI Tracks as Standard MIDI File on page 164
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VST Quick Controls
VST Quick Controls allow you to remote-control a VST instrument from within the VST
Instruments window.
To show the VST Quick Controls on the VST Instruments window, activate Show/Hide all VST
Quick Controls.
The following controls are available on each rack:

1

Show/Hide VST Quick Controls
Allows you to show/hide the VST Quick Controls for the instrument.

2

VST Quick Controls
Allow you to remote-control the parameters of the instrument.
NOTE
The number of VST Quick Controls that are shown depends on the size of the VST
Instruments window.

3

Set Remote-Control Focus for VST Quick Controls
Allows you to activate the VST Quick Controls to remote-control the instrument.

RELATED LINKS
Remote Controlling Nuendo on page 748
Connecting VST Quick Controls with Remote Controllers on page 734
Activating Pick-up Mode for Hardware Controls on page 747

Connecting VST Quick Controls with Remote Controllers
VST Quick Controls become powerful, if you use them together with a remote controller.
PREREQUISITE
The MIDI output on your remote unit is connected to a MIDI input on your MIDI interface.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select VST Quick Controls.

3.

Open the MIDI Input pop-up menu, and select a MIDI input.

4.

Optional: Open the MIDI Output pop-up menu, and select a MIDI output.

5.

Click Apply.

6.

Activate Learn.

7.

In the Control Name column, select QuickControl 1.

8.

On your MIDI device, move the control that you want to connect with the first quick
control.

9.

Select the next slot in the Control Name column and repeat the previous steps.
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10.

Click OK.

RESULT
The VST Quick Controls are now connected with control elements on your MIDI device. If you
move a control element, the value of the parameter that is assigned to the corresponding VST
Quick Controls changes accordingly.
NOTE
The remote controller setup for VST Quick Controls is saved globally, that is, it is independent of
any projects.

RELATED LINKS
Generic Remote on page 752

Side-Chain Input for VST Instruments
You can send audio into VST 3 instruments that feature a side-chain input. Side-chaining allows
you to use the output of one track to control the action of an instrument on another track.
Depending on the instrument, activating its side-chain input allows you to:
●

Use the instrument as an effect plug-in on audio events.

●

Use the side-chain signal as a modulation source.

●

Apply ducking to the instrument, that is, reduce the volume of the instrument track when a
signal is present on the audio track.

You can route the audio signal to the side-chain input of an instrument in different ways:
●

To process the audio signal completely through the instrument, route the output of the
audio track to the side-chain input of an instrument.

●

To use both the clean audio signal and the signal processed by the instrument, route a
send to the instrument side-chain.

NOTE
To hear the audio played through the instrument, you must trigger a note, either by playing MIDI
events or by playing notes on your external MIDI keyboard.

RELATED LINKS
Using Instruments as Effects on Audio Tracks on page 735

Using Instruments as Effects on Audio Tracks
You can use instruments that support side-chaining to modify the audio on audio tracks. The
following example shows you how to apply the parameters in Retrologue to a drum loop.
PREREQUISITE
You have a drum loop on an audio track. You have created an instrument track with Retrologue
loaded.
PROCEDURE
1.

In the header of the Retrologue panel, click Activate Side-Chain.

2.

Open the Output Routing pop-up menu in the Inspector for the audio track and select
the side-chain input of Retrologue.
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3.

On the Retrologue panel in the Oscillator Mix section, adjust the Input Level control.
This adjusts the input level of the incoming audio.

4.

Optional: Deactivate oscillators OSC 1, OSC 2, and OSC 3.

5.

Do one of the following:
●

On the instrument track, create a MIDI event, set up a cycle with the left and right
locators, and activate cycle mode.

●

Play notes on your MIDI keyboard.
NOTE
For this to work, your MIDI keyboard must be installed and set up.

RESULT
When a note is played, the drum loop is played back through Retrologue.
AFTER COMPLETING THIS TASK
Use Retrologue to modify the sound of your drum loop. For example, you can do the following:
●

Use the filter and distortion settings on the Synth page.

●

Modulate the input signal. To do this, select Modulation Matrix > Destination >
Oscillator > Audio Input.

●

Set up a rhythmical modulation on the Arp page.

●

Use the effects on the FX page, for example the Resonator.

NOTE
For detailed information about Retrologue and its parameters, see the separate document
Retrologue.

External Instruments
An external instrument bus is an input (return) to your audio hardware, along with a MIDI
connection via Nuendo and few additional settings.
External instrument busses are created in the Audio Connections window. All external
instrument busses that you have created will appear on the VST Instrument pop-up menus and
can be selected in the same way as any VST instrument plug-in.
If you select an external instrument, you play it via MIDI as usual (you have to create a MIDI
device to play it) and the sound (synth audio output) will come in to the VST environment where
you can apply processing, etc.
RELATED LINKS
Setting Up External Instruments on page 34
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Installing VST Plug-Ins
Nuendo supports the VST 2 and VST 3 plug-in standards. You can install effects and instruments
that comply with these formats.
A plug-in is a piece of software that adds a specific functionality to Nuendo. The audio effects and
instruments that are used in Nuendo are VST plug-ins.
Effect or instrument plug-ins normally have their own installation application. Read the
documentation or readme files before installing new plug-ins.
When you scan for newly installed plug-ins or relaunch Nuendo, the new effects appear on the
effect selectors.
Nuendo comes with a number of effect plug-ins included. These effects and their parameters are
described in the separate document Plug-in Reference.

VST Plug-In Manager
The VST Plug-in Manager provides lists of the effects and VST instruments that are installed on
your computer. These lists are used in the selectors for VST instruments and effects.
The VST Plug-in Manager allows you to do the following:
●

You can view lists of all effects and VST instruments that are loaded by Nuendo when you
launch the program.
The lists of all effects or VST instruments are created automatically every time you start
Nuendo. You can also initiate a rescan at any time. This ensures that these lists are always
up-to-date.

●

You can create your own lists of effects or instruments for use in the selectors for effects
or instruments. User-defined lists are called collections.
Collections allow you to create sub-sets of the available effects or instruments, for
example, to give you a better overview of the effects used in a project.
NOTE
If an installed effect or instrument cannot be loaded by Nuendo, it does not appear in the
list of all effects or instruments. Also, the effect or instrument is grayed out in any
collections in which it is included. For example, this can happen if a copy-protection dongle
required to run the effect or instrument is missing, or after uninstalling a plug-in.

VST Plug-In Manager Window
You can manage your effects and VST instruments in the VST Plug-in Manager window.
●

To open the VST Plug-in Manager window, select Studio > Plug-in Manager.
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The VST Plug-in Manager window shows the following:
VST Effects
This tab lists all VST effects that are loaded in Nuendo. You can sort the list by name,
vendor, category, etc. by clicking the corresponding column heading.
VST Instruments
This tab lists all VST instruments that are loaded in Nuendo. You can sort the list by
name, vendor, category, etc. by clicking the corresponding column heading.
Blacklist
This tab lists all VST effects and VST instruments that are installed on your system but
not loaded in Nuendo. These plug-ins might lead to stability problems or even cause
the program to crash. As Nuendo does not support 32-bit, all 32-bit plug-ins are
shown in this list.
NOTE
You can reactivate a blacklisted 64-bit plug-in by selecting it and clicking Reactivate.
This causes Nuendo to rescan the plug-in and remove it from the blacklist. To move
the plug-in back to the blacklist, you must rescan all plug-ins and restart Nuendo.
Collection list
By default, the window section to the right shows the Default collection, which
contains all effects or VST instruments loaded by the program. The Default collection
cannot be changed.
You can compile your own collections of effects or VST instruments by clicking New
Collection and dragging and dropping items from the list of all effects or VST
instruments to the collection list.
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Collections are shown in the selectors for effects/VST instruments, and all changes
made to collections in the VST Plug-in Manager are immediately reflected in the
selectors.
Search Field
Enter the name of a plug-in in the search field. The list of all effects or VST
instruments is filtered to show only those plug-ins whose names contain the text that
you entered.
Display Options
Allows you to choose which plug-ins are shown:
●

To show all loaded plug-ins, select Show All Plug-ins.

●

To hide all plug-ins that are part of the active collection, select Hide Plug-ins
That Are in Active Collection.

●

To show all VST 3 plug-ins that support 64-bit processing, select Show Plug-ins
That Support 64-Bit Float Processing.
NOTE
This might take a while since all your plug-ins must be scanned.

New Folder
Allows you to create a new folder in the current collection.
Delete
Allows you to delete the selected item in the current collection.
New Collection
Allows you to create a new collection.
To create a new, empty list, select Empty. To create a new collection based on the list
of all effects, select Add All Plug-ins. To create a new collection based on the current
collection, select Add Current Collection.
User Collections
Allows you to select a different collection, and to rename or delete the current
collection.
To remove unavailable plug-ins from all collections, select Remove Unavailable
Plug-ins from All Collections.
Show VST Plug-in Information
Opens a section at the bottom of the window in which more information about the
selected item is shown. If you select several plug-ins, the information for the plug-in
that you have selected first is shown. In this section, you can also deactivate selected
plug-ins. Deactivated plug-ins are no longer available in collections. This is useful if
you have plug-ins installed that you do not want to use in Nuendo.
VST Plug-in Manager Settings
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Opens a section at the bottom of the window in which all current paths to VST 2 plugins are listed. You can add or remove folder locations by using the corresponding
buttons. Click Rescan All to rescan your computer for plug-ins.
RELATED LINKS
VST Plug-In Manager on page 737
VST Audio System on page 14

Compiling a New Effects Collection
You can create a new collection of effects or VST instruments for use in the plug-in selectors.
PREREQUISITE
A number of effect plug-ins is correctly installed on your computer, and these plug-ins are listed
on the VST Effects tab of the VST Plug-in Manager window.
PROCEDURE
1.

In the VST Plug-in Manager window, click New Collection and do one of the following:
●

To create a new collection based on the list of all effects, select Add All Plug-ins.

●

To create a new collection based on the current collection, select Copy Current
Collection.

2.

Enter a name for the new collection and click OK.

3.

Drag items from the list of all effects and drop them to the new collection. A line indicates
the drop position.
●

Click New Folder to create folders and place items directly in them.

●

You can drag items to new positions within the collection.

●

Drag items from the collection list to the list of all plug-ins to delete them, or select
items and click Delete.

RESULT
The new collection is saved automatically and made available in the plug-in selectors.
The procedure is the same for compiling collections of VST instruments.
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Nuendo allows you to set up 8 different track parameters or settings as Track Quick Controls for
quick access.
Track Quick Controls are available for the following track types:
●

Audio

●

MIDI

●

Instrument

●

Sampler

●

FX Channel

●

Group Channel

●

VCA Fader

For instrument tracks and for MIDI tracks for which you assigned a VST instrument on creation,
that is, that you created by loading a rack instrument, Track Quick Controls are automatically
assigned to the Quick Controls of the VST instrument.
For sampler tracks, Track Quick Controls are automatically assigned to the sound parameters of
Sampler Control.
NOTE
You can change the default assignment by assigning different track parameters or by loading a
preset.
Assigning parameters to Quick Controls is done in the Inspector or the MixConsole.

Quick Controls section in the Inspector
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Track Quick Controls rack in the MixConsole

Quick Controls assignments are saved with the project.
You can assign Track Quick Controls to an external remote control device. For this to work, you
must connect Track Quick Controls with your remote controller.
You can automate parameter settings in the Quick Controls section using the Read/Write
buttons (R and W).
RELATED LINKS
Track Presets on page 188
Automation on page 695
Channel Racks on page 378

Parameter Assignment
You can assign track, effect, and instrument parameters to Quick Controls.
For the parameter assignment, you can use the Inspector or the MixConsole. You can assign
parameters manually, use the QC Learn Mode, or load an assignment preset.
RELATED LINKS
Assigning Track Parameters to Quick Controls on page 742
Assigning Effect Parameters to Quick Controls on page 743
Using QC Learn Mode on page 743
Assigning MixConsole Parameters to Quick Controls on page 744
Setting Instrument Parameter Assignments to Default on page 744
Removing Parameter Assignments on page 744
Loading Track Quick Control Assignments as Presets on page 745

Assigning Track Parameters to Quick Controls
You can assign track parameters manually.
NOTE
For instrument tracks and MIDI tracks for which you assigned a VST instrument on creation, the
main parameters of the instrument are automatically assigned to the slots in the Quick Controls
section in the Inspector.

PROCEDURE
1.

In the Inspector for your track, open the Quick Controls section.

2.

In the Quick Controls section, click the first slot to open a selector that lists all parameters
for the track.

3.

Select the parameter that you want to assign to the first Quick Control.
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The parameter name and its value are displayed in the slot. You can change the value by
dragging the slider.

4.

Repeat these steps for all slots for which you want to assign track parameters.

RESULT
You can now control the track parameters via the Quick Controls section in the Inspector or via
the Track Quick Controls rack in the MixConsole.
AFTER COMPLETING THIS TASK
You can rename a Quick Control by double-clicking on the name and entering a new one. This is
useful if a parameter name is very long, for example.

Assigning Effect Parameters to Quick Controls
You can assign effect parameters to Quick Control slots directly from within plug-in panels.
NOTE
This is only available for VST 3 plug-ins that support this function.

PROCEDURE
●

In the effect plug-in panel, right-click the parameter.
●

Select Add “x” to Quick Controls (where x is the name of the parameter) to assign
the parameter to the next empty slot.

●

Select Add “x” to Quick Controls Slot (where x is the name of the parameter), and
select the slot from the submenu to assign the parameter to a specific slot.

RESULT
You can now control the effect parameters via the Quick Controls section in the Inspector or via
the Track Quick Controls rack in the MixConsole.

Using QC Learn Mode
The QC Learn Mode allows you to assign a parameter by moving controls. This applies to all
automatable controls.
PROCEDURE
1.

In the Inspector for your track, open the Quick Controls section.

2.

Activate QC Learn Mode.

3.

Select the slot to which you want to assign a parameter.

4.

Move the control.

RESULT
The track parameter is assigned to the corresponding control.
RELATED LINKS
Quick Controls and Automatable Parameters on page 745
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Assigning MixConsole Parameters to Quick Controls
You can assign MixConsole parameters to Quick Controls.
PROCEDURE
●

In the MixConsole, right-click the parameter that you want to assign to a Quick Control.
●

Select Add “x” to Quick Controls (where x is the name of the parameter) to assign
the parameter to the next empty slot.

●

Select Add “x” to Quick Controls Slot (where x is the name of the parameter), and
select the slot from the submenu to assign the parameter to a specific slot.

RESULT
You can now control the MixConsole parameters via the Quick Controls section in the
Inspector or via the Track Quick Controls rack in the MixConsole.
RELATED LINKS
Track Quick Controls on page 741
Adding Track Quick Controls in the MixConsole on page 412

Setting Instrument Parameter Assignments to Default
If you have changed the parameter assignment or if you manually routed a MIDI track to a VST
instrument, you can retrieve the default assignments.
PROCEDURE
1.

In the Inspector for the instrument or MIDI track, open the Quick Controls section.

2.

Click Get Default QCs from Plug-in.

RESULT
The instrument parameter assignments are set to default.

Removing Parameter Assignments
You can remove parameter assignments for individual Quick Controls or for all Quick Controls
at once.
PROCEDURE
●

Do one of the following:
●

To remove a parameter from a slot, click in the corresponding slot and select No
parameter from the pop-up menu.
NOTE
You can also double-click the parameter name, press Delete or Backspace, and
confirm with Return.

●

To remove the Quick Control assignments for all slots, click Remove All QC
Assignments.
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Saving Track Quick Control Assignments as Presets
You can save Quick Control assignments as track presets.
PREREQUISITE
You have assigned track parameters to Quick Controls.
PROCEDURE
1.

In the Inspector for your track, open the Quick Controls section.

2.

In the Quick Controls section, click Preset Management .

3.

Click Save Preset.

4.

Enter a name in the Type In Preset Name dialog.

5.

Click OK.

RESULT
The Quick Control assignment is saved as a preset.
RELATED LINKS
Assigning Track Parameters to Quick Controls on page 742

Loading Track Quick Control Assignments as Presets
You can load presets for Quick Control assignments.
PROCEDURE
1.

In the Inspector for your track, open the Quick Controls section.

2.

In the Quick Controls section, click Preset Management .

3.

Select one of the presets in the upper list of the menu.

RESULT
The preset is loaded and allows you to access the channel parameters.

Quick Controls and Automatable Parameters
You can use Quick Controls to control all automatable parameters. This allows you to control
parameters on other tracks using Quick Controls.
IMPORTANT
Use this function with caution, as you might accidentally modify parameters on other tracks.

PROCEDURE
1.

Create a new, empty audio track and open the Quick Controls section.
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2.

Hold down the Ctrl/Cmd key and click the first Quick Control slot.
The selector lists all automatable parameters.

3.

Open the VST Mixer folder.
The selector lists all channels that are available in the MixConsole of your project.

4.

Assign a parameter of one particular channel to Quick Control 1, and another parameter
of another channel to Quick Control 2.

RESULT
The Quick Controls section now allows you to control automatable parameters on different
tracks.
IMPORTANT
You cannot save Quick Control assignments for automatable parameters on different tracks as
track presets.

Showing Automated Quick Control Assignments
You can show all Quick Control assignments that have been automated for one track.
PROCEDURE
1.

Click the track for which you want to show automated Quick Control assignments.

2.

In the Inspector for your track, open the Quick Controls section.

3.

In the Quick Controls section, click Preset Management .

4.

Select Show Automated QC Assignments.

RESULT
The automation tracks of the automated Quick Control parameters open for the selected track.
NOTE
●

If Volume is assigned as a Quick Control parameter, it is always shown as automated,
independent of whether it is automated or not.

●

You can also show automated Quick Control assignments via the Track Quick Controls
rack in the MixConsole.
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Connecting Track Quick Controls with Remote Controllers
Track Quick Controls become powerful if you use them together with a remote controller.
PREREQUISITE
The MIDI output on your remote unit is connected to a MIDI input on your MIDI interface.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select Track Quick Controls.

3.

Open the MIDI Input pop-up menu, and select a MIDI input.

4.

Optional: Open the MIDI Output pop-up menu, and select a MIDI output.

5.

Click Apply.

6.

Activate Learn.

7.

In the Control Name column, select QuickControl 1.

8.

On your MIDI device, move the control that you want to connect with the first quick
control.

9.

Select the next slot in the Control Name column and repeat the previous steps.

10.

Click OK.

RESULT
The Track Quick Controls are now connected with control elements on your MIDI device. If you
move a control element, the value of the parameter that is assigned to the corresponding Track
Quick Controls changes accordingly.
NOTE
The remote controller setup for Track Quick Controls is saved globally, that is, it is independent
of any projects.

RELATED LINKS
Generic Remote on page 752

Activating Pick-up Mode for Hardware Controls
Pick-up Mode allows you to change configured Quick Control parameters without accidentally
modifying the previous values. This is useful if you want the control to pick up the parameter at
the value to which it was last set. If you move a hardware control, the parameter only changes
once the control reaches the previous value.
NOTE
This only applies to hardware controllers whose controls use specific ranges.

PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select Track Quick Controls or VST Quick Controls.

3.

Activate Pick-up Mode.

4.

Click OK.
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You can control Nuendo via MIDI with a connected MIDI device.
The supported devices are described in the separate document Remote Control Devices. You
can also use a generic MIDI controller to remote control Nuendo.
NOTE
Most remote control devices are able to control both MIDI and audio channels in Nuendo, but
the parameter setup may be different. Audio-specific controls such as EQ are disregarded when
controlling MIDI channels.

RELATED LINKS
Generic Remote on page 752

Connecting Remote Devices
You can connect your remote device via USB or via MIDI.
PROCEDURE
●

Do one of the following:
●

If your remote device provides a USB MIDI port, use a USB cable to connect it to the
USB port of your computer.

●

If your remote device provides a MIDI output, use a MIDI cable to connect it to a
MIDI input on your MIDI interface.
NOTE
If the remote unit features feedback devices such as indicators, motorized faders,
etc., connect a MIDI Out on the interface to a MIDI In on the remote unit.

RELATED LINKS
MIDI Connections on page 19

Removing the Remote Input from All MIDI Inputs
To avoid that you accidentally record data from the remote unit when you record MIDI, you must
remove the remote input from ‘All MIDI Inputs’.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select MIDI Port Setup.
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3.

In the table on the right, deactivate In ‘All MIDI Inputs’ for the MIDI input to which you
have connected the MIDI remote unit.
The State column reads Inactive.

4.

Click OK.

RESULT
The remote unit input is removed from the All MIDI Inputs group.
RELATED LINKS
MIDI Port Setup on page 20

Setting Up Remote Devices
PROCEDURE
1.

Select Studio > Studio Setup.

2.

Click + in the top left corner and select a remote device from the pop-up menu to add it to
the Devices list.
NOTE
If your device is not available in the pop-up menu, select Generic Remote.

3.

In the Devices list, select the device.
Depending on the selected device, either a list of programmable function commands or a
blank panel is shown in the right half of the dialog window.

4.

Open the MIDI Input pop-up menu, and select a MIDI input.

5.

Optional: Open the MIDI Output pop-up menu, and select a MIDI output.

6.

Click OK.

RESULT
You can now use the MIDI device to control Nuendo functions.
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A bright stripe in the Project window and in the MixConsole indicates which channels are linked
to the remote control device.

You can open a panel for the added device by selecting Studio > More Options.
AFTER COMPLETING THIS TASK
Depending on your external MIDI control device, you might need to configure the parameters.

Resetting Remote Devices
Sometimes you must reset remote devices, because the communication between Nuendo and a
remote device was interrupted or the handshaking protocol fails to create a connection.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select the remote device.

3.

Click Reset in the lower part of the Studio Setup dialog to reset the selected remote
device.
NOTE
To reset all devices in the Devices list, click Send Reset Message to all Devices in the top
left of the dialog.

Global Options for Remote Controllers
On the page for your remote device, global functions may be available.

MIDI Input
Allows you to select a MIDI Input.
MIDI Output
Allows you to select a MIDI Output.
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User Commands
Lists the controls or buttons of your remote device.
Smart Switch Delay
Allows you to specify a delay for the smart switch function. Functions that support
the smart switch behavior are activated for as long as the button is pressed.
Enable Auto Select
On touch-sensitive remote control devices this automatically selects a channel when
you touch a fader. On devices without touch-sensitive faders, the channel gets
selected as soon as you move the fader.

Remote Devices and Automation
You can write automation using remote devices.
If your remote device does not have touch-sensitive controls and you want to replace existing
automation data in Write mode, consider the following:
●

Make sure that you move only the controller that you want to replace.

●

Stop playback to deactivate Write mode.

This way, all data for the corresponding parameter is replaced from the position where you
moved the control, up to the position where you stop playback.

Assigning Commands to Remote Devices
You can assign any Nuendo command to which a key command can be assigned to remote
devices.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select your remote device.
In the User Commands section, the controls or buttons of your remote device are listed in
the Button column.

3.

Click in the Category column for the control to which you want to assign a Nuendo
command, and select the category from the pop-up menu.
The categories correspond to the categories in the Key Commands dialog.
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4.

Click in the Command column, and select the Nuendo command from the pop-up menu.
The available items on the pop-up menu depend on the selected category.

5.

Click Apply.

RESULT
The selected function is assigned to the button or control on the remote device.
RELATED LINKS
Key Commands on page 1137

Generic Remote
You can use a generic MIDI controller to remote control almost any function in Nuendo. After
setting up the Generic Remote device, you can control the specified parameters from the MIDI
remote device.
●

To open the Generic Remote settings, select Studio > Studio Setup, and from the Devices
list, select Generic Remote.

The following options are available:
MIDI Input
Allows you to select the MIDI input port to which your remote device is connected.
MIDI Output
Allows you to select the MIDI output port to which your remote device is connected.
MIDI Remote Control Configuration
The upper table shows the MIDI remote control configuration of your remote device.
Nuendo Control Assignment
The lower table allows you to assign Nuendo controls to your remote device.
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RELATED LINKS
MIDI Remote Control Configuration on page 753
Nuendo Control Assignment on page 754

MIDI Remote Control Configuration
The MIDI remote control configuration is shown in the upper table of the Generic Remote setup
page.
●

To open the Generic Remote settings, select Studio > Studio Setup, and from the Devices
list, select Generic Remote.

The following options are available in the upper table:
Control Name
Double-click this field to change the name for the control, and enter the one written
on the console, for example. This name is automatically reflected in the lower table.
MIDI Status
Allows you to specify the type of MIDI message sent by the control.
MIDI Channel
Allows you to select the MIDI channel on which the controller is transmitted.
Address
Allows you to specify the continuous controller number, the pitch of a note, or the
address of an NRPN/RPN continuous controller.
Max. Value
Allows you to specify the maximum value that the control transmits. This value is
used by the program to scale the value range of the MIDI controller to the value
range of the program parameter.
Flags
Allows you to select one of the following flags:
●

Receive
Activate this if the MIDI message should be processed on reception.

●

Transmit
Activate this if a MIDI message should be transmitted when the corresponding
value in the program changes.

●

Relative
Activate this if the control is an endless rotary encoder, which reports the
number of turns instead of an absolute value.

●

Pick-up
Activate this if you want the control to pick up the parameter at the value to
which it was last set.
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The buttons and options to the right of the table have the following function:
Import
Allows you to import saved remote setup files.
Export
Allows you to export the current setup with the file extension .xml.
Add
Adds controls to the bottom of the table.
Delete
Deletes the selected control from the table.
Learn
Allows you to assign MIDI messages by learning.

Nuendo Control Assignment
You can specify the Nuendo control assignment in the lower table of the Generic Remote setup
page. Each row in the table is assigned to the controller in the corresponding row in the MIDI
remote control configuration table.
●

To open the Generic Remote settings, select Studio > Studio Setup, and from the Devices
list, select Generic Remote.

The following options are available:
Control Name
Reflects the control name selected in the upper table.
Device
Allows you to select the Nuendo device that you want to control.
Channel/Category
Allows you to select the channel or the command category that you want to control.
Value/Action
Allows you to select the parameter of the channel that you want to control. If the
Command device is selected, this is where you specify the Action of the category.
Flags
Allows you to select one of the following flags:
●

Push Button
Activate this if the parameter should only be changed if the received MIDI
message shows a value unequal to 0.

●

Toggle
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Activate this if the parameter value should be switched between minimum and
maximum value each time a MIDI message is received.
You can combine Push Button and Toggle for remote controls which do not
latch the state of a button. This is useful if you want to control the mute status
with a device on which pressing the mute button turns it on, and releasing the
mute button turns it off.
●

Not Automated
Activate this if the parameter value should not be automated.

The buttons to the right of the table have the following functions:
Bank pop-up menu
Allows you to switch banks. This is necessary if your MIDI control device has 16
volume faders, and you are using 32 MixConsole channels in Nuendo, for example.
Rename
Allows you to rename the selected bank.
Add
Adds banks to the pop-up menu.
Delete
Deletes the selected bank from the pop-up menu.
RELATED LINKS
Assignable Devices and Functions on page 755

Assignable Devices and Functions
The Device column in the Nuendo control assignment lists the Nuendo devices that you can
control.
Command
Allows you to assign the Nuendo commands to which a key command can be
assigned. If you select Add Track in the Channel/Category column, and Audio in
the Value/Action column, you can add audio tracks using your MIDI device, for
example.
VST Quick Controls Manager
Allows you to assign VST Quick Controls. If you select Device in the Channel/
Category column, and one of the Quick Control options in the Value/Action
column, you can control that VST quick control using your MIDI device.
Midi Mixer
Allows you to control the functions of the Midi Mixer panel. If you select Device in
the Channel/Category column, and one of the options in the Value/Action column,
you can control that function using your MIDI device.
MMC Master
Allows you to control the functions of the MMC Master panel. If you select Device in
the Channel/Category column, and one of the options in the Value/Action column,
you can control that function using your MIDI device.
Mixer
Allows you to control MixConsole functions. If you select one of the available
channels or Selected in the Channel/Category column, and one of the options in
the Value/Action column, you can control that function of that specific channel or of
the selected channel using your MIDI device.
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Transport
Allows you to control the transport functions. If you select Device in the Channel/
Category column, and one of the options in the Value/Action column, you can
control that function using your MIDI device.
Metronome
Allows you to control metronome functions. If you select Device in the Channel/
Category column, and one of the options in the Value/Action column, you can
control that function using your MIDI device.
VST Mixer
Allows you to control MixConsole functions. If you select one of the available
channels or Selected in the Channel/Category column, and one of the options in
the Value/Action column, you can control that function of that specific channel or of
the selected channel using your MIDI device.
VST Control Room
Allows you to control the functions of the Control Room. If you select Device in the
Channel/Category column, and one of the options in the Value/Action column, you
can control that function using your MIDI device.
NOTE
You can also control all VST Instruments that you added in the Project window, and that are
listed in the Device column.

Assigning MIDI Messages in Learn Mode
You can assign MIDI messages in Learn mode.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select Generic Remote.

3.

Activate Learn.

4.

Select the control in the upper table, and move the corresponding control on your MIDI
device.

RESULT
The values for MIDI Status, MIDI Channel, and Address are automatically set to those of the
moved control.
NOTE
If you use the Learn function for a control that sends a program change value, Prog. Change
Trigger is automatically selected in the MIDI Status pop-up menu. This allows you to use the
different values of a program change parameter to control different parameters in Nuendo.
If this does not give you the result you want, try using the Prog. Change value instead.
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The Remote Control Editor
The Remote Control Editor allows you to define your own mapping of VST plug-in parameters to
the controls of the supported hardware controllers. This is useful if you think that the automatic
mapping of plug-in parameters to remote control devices is not too intuitive.
●

To open the Remote Control Editor, right-click the plug-in panel of the plug-in that you
want to remote-control, and select Remote Control Editor.

1

Inspector
Contains the settings and the parameter assignment for the selected cell. The upper
section contains settings for the text label. The lower section contains settings for the knob
and the switches.

2

Layout Selection
Shows the name of the layout. Click to select a different layout.

3

Set up Cell Layout
Opens the Cell Layout Configuration, where you can specify the number of cells per
page, and select the switch layout that you want to use for the pages. To specify the
number of switches for a cell, activate/deactivate them.

4

Add New Hardware Layout
Adds a new layout for a particular hardware type. To remove a hardware layout, click its
Close button.

5

Layout Section
Shows layouts that represent the hardware devices that are used to remote-control the
plug-in parameters. Here you can change the parameter assignments, the name in the
text label, the cell setup, and the order of cells and pages.

6

Toolbar
Shows tools for setting up the layout.

7

Status Bar
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Shows information on an element when you position the mouse pointer over it in the
editor window.
RELATED LINKS
Toolbar on page 758

Toolbar
Shows tools for setting up the layout.

1

Remove All Assignments
Removes all parameter assignments.

2

Get Default Factory Layout/Copy Layout from Other Tab
Reverts to the default settings for the current layout or copies the settings of one layout
page to another.

3

Activate/Deactivate Learn Mode
Activates/Deactivates the Learn mode for the Remote Control Editor.

4

Activate/Deactivate Assignment Inspection View
Shows the current assignment of all cells in a layout.

5

Apply Current Layout
Saves the settings. If the hardware supports this function, the changes are immediately
reflected on the hardware controllers.

Control Settings
You can define the control style for switches or knobs to which you have assigned a function. This
includes changing the LED ring or changing its behavior, from continuous value representation
to on/off, for example.
To open the Control Settings panel, right-click the control.
NOTE
Not all hardware devices support all control type settings.

Control Type Settings for Knobs

The following control types are available for knobs:
Standard
A standard knob with undefined LED style.
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Toggle Switch
A knob with 2 states.
LED Ring
An LED ring around the knob. The setting increases clockwise.
LED Ring (counter-clockwise)
An LED ring around the knob. The setting increases counter-clockwise.
Center Width
An LED ring that starts at the top center position, and when the settings increase, an
LED is shown growing in both directions.
Center Neutral
A dial that starts at the top center position and can be moved left or right, like a pan
control, for example.
Single Dot
An LED ring around the knob. The setting increases clockwise with a dot indicating
the current value.

Control Type Settings for Switches

The following options are available for switches:
Momentary
Activates the assigned function as long as you hold the switch.
Increasing Stepwise
Steps through the available settings until the maximum is reached.
Decreasing Stepwise
Steps through the available settings in reverse order until the minimum is reached.
Increasing Stepwise (cycle)
Steps through the available settings, starting over with the minimum value when the
maximum is reached.
Decreasing Stepwise (cycle)
Steps through the available settings in reverse order, starting over with the
maximum value when the minimum is reached.
Smart Switch
Switches between 2 states every time you press the switch. Enters Momentary mode
if you hold the switch.

Invert Control Value
Inverts the control state/value.
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Hide Control When Inactive
Hides plug-in parameters when they are inactive or disabled.

Assigning Parameters to Controls
PROCEDURE
1.

In the Remote Control Editor, click
editor.

2.

Select the control that you want to assign to a plug-in parameter.

3.

Do one of the following:

4.

on the toolbar to activate Learn mode for the

●

Click a parameter on the plug-in panel.

●

Double-click on a control in the Remote Control Editor, and select a parameter
from the list of available plug-in parameters.

Press Esc to end Learn mode.

RESULT
The parameter is assigned to the control.
NOTE
To remove the parameter assignment for a cell, activate Learn mode, select the cell, and press
Delete or Backspace.

Editing the Layout
In the layout section, you can perform a number of editing operations and arrange the pages to
your liking.
●

To navigate from cell to cell, use the cursor keys.

●

To step through the controls within the cells in Learn mode, press Shift and use the cursor
keys.

●

To step through the different layouts, use Tab and Shift-Tab.

●

To copy the settings of one cell to another, select a cell, press Alt and drag it to another
cell.

●

To move a cell, drag it to an empty cell.

●

To swap the contents of 2 cells, press Ctrl/Cmd and drag one cell to the other.

NOTE
Drag and drop also works between different pages.
●

To add a page to a layout, click Add New Page.

●

To remove a page, click Remove Current Page.

●

To specify the label for a cell, use the top 3 text fields in the Inspector.
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The first text field shows the long name, as it is shown in the cell. In the second field, you
can enter a name that can contain up to 8 characters, and up to 4 characters in the third.
NOTE
This is useful if your hardware devices have value fields that only display a limited number
of characters, for example.

Joysticks
You can use a joystick to remote-control panning operations in Nuendo. This can be useful, for
example, for creating smooth automation curves.
●

To use a joystick for remote-controlling, connect it to your computer and restart Nuendo.
After restarting the application, the joystick is automatically activated.

RELATED LINKS
Panning with a Joystick on page 671
Deactivating Joysticks on page 761

Deactivating Joysticks
If you have a joystick connected to your system, but do not want to use it with Nuendo, you can
deactivate it.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select the joystick device.
The available device settings are shown to the right.

3.

Deactivate the respective option.

Apple Remote (macOS only)
Many Apple computers come with an Apple Remote, a small hand-held device that allows you to
remotely control specific features in Nuendo.
●

To open the Apple Remote Control settings, select Studio > Studio Setup, and from the
Devices list, select Apple Remote Control.

761

Remote Controlling Nuendo
Track Quick Controls

Control list
Lists the Apple Remote controls. Open the pop-up menu to select the Nuendo
parameter that you want to assign to that control.
Disable when application is not in front
Activate this if you do not want the Apple Remote to control Nuendo when it does
not have the focus.
By default, the Apple Remote always controls the application that has the focus on
your Macintosh computer, provided that this application supports the Apple Remote.

Track Quick Controls
If you have an external remote control device, you can set it up to control up to 8 parameters of
each audio track, MIDI track or instrument track, using the Track Quick Controls feature in
Nuendo.
RELATED LINKS
Connecting Track Quick Controls with Remote Controllers on page 747
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VST Quick Controls
If you have an external remote control device, you can control 8 parameters of a VST instrument,
using the VST Quick Controls feature in Nuendo.
RELATED LINKS
Connecting Track Quick Controls with Remote Controllers on page 747
VST Quick Controls on page 734
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MIDI realtime means that you can change or transform MIDI events on MIDI or instrument
tracks before they are sent to the MIDI outputs. This allows you to change the way MIDI data is
played back.
The actual MIDI events on the track are not affected. Therefore, MIDI real time changes are not
reflected in any MIDI editor.
The following functions allow you to change MIDI events in realtime:
●

MIDI track parameters

●

MIDI modifiers

●

MIDI effects

●

Transpose and Velocity on the info line

NOTE
If you want to convert the track settings to real MIDI events, select MIDI > Freeze MIDI
Modifiers or MIDI > Merge MIDI in Loop.

RELATED LINKS
Merging MIDI Events into a New Part on page 786

MIDI Track Parameters
The MIDI track parameters are located in the topmost Inspector section for MIDI and instrument
tracks.
These settings either affect the basic functionality for the track (mute, solo, enable record, etc.) or
send out additional MIDI data to the connected devices (program change, volume, etc.).
The following track parameters allow you to change MIDI events in real time:
●

MIDI Volume

●

MIDI Pan

●

Track Delay

●

Input Transformer

RELATED LINKS
MIDI Track Inspector on page 116
Input Transformer on page 764

Input Transformer
The Input Transformer allows you to filter out and change MIDI data coming to a MIDI track
before it is recorded.
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Use the Input Transformer for the following purposes:
●

Set up split keyboard combinations for recording left and right hands separately.

●

Convert a controller such as a foot pedal into MIDI notes (for playing bass drum the right
way).

●

Filter out a specific type of MIDI data on one MIDI channel only.

●

Turn aftertouch into any controller and vice versa.

●

Invert velocity or pitch.

Input Transformer Window
To open the Input Transformer window, perform one of the following actions:
●

Select a MIDI or instrument track, click Input Transformer

, and select Global.

This allows you to make settings that affect all MIDI inputs and all MIDI tracks.
●

Select a MIDI or instrument track, click Input Transformer, and select Local.
This allows you to make settings for the selected track only.

The Input Transformer window contains the following parameters:
1

Select Preset
Allows you to select a preset for the Input Transformer.

2

Module selector
Allows you to view and edit a module.

3

Filter conditions list
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Allows you to set up the filter conditions, determining which elements to find. The list can
contain one or several conditions, each on a separate line.
4

Action list
Allows you to specify any changes that are made to the found events.

5

Function pop-up menu
Allows you to select between Filter and Transform as a basic type of editing to be
performed.

Specifying Filter Conditions
PROCEDURE
1.

Select a MIDI or instrument track.

2.

Perform one of the following actions:

3.

●

To make settings that affect all MIDI tracks, open the Inspector, click Input
Transformer, and select Global from the pop-up menu.

●

To make settings that affect the selected MIDI track, open the Inspector, click Input
Transformer, and select Local from the pop-up menu.

Open the Function pop-up menu, and perform one of the following actions:
●

Select Filter if you want to filter the found events.

●

Select Transform if you want to transform the found events.

4.

Click + to add a line to the filter conditions list.

5.

In the filter conditions list, specify the conditions to match by clicking the Filter Target,
Condition, and Parameter columns and selecting options from the pop-up menu.

6.

In the action list, specify how the found events are transformed or filtered by clicking the
Action Target, Operation, and Parameter columns, and selecting options from the popup menu.
NOTE
You can also select a preset from the Select Preset pop-up menu to specify conditions and
actions.

RESULT
The settings affect all MIDI events that you record on the track.
AFTER COMPLETING THIS TASK
In the Inspector, click Input Transformer, and select Off. Otherwise the Input Transformer is
still active.

MIDI Modifiers
MIDI modifiers allow you to modify MIDI events during playback.
You can use them for the following purposes:
●

To modify already existing MIDI events on MIDI or instrument tracks.

●

To modify MIDI events that you play live.
NOTE
For live playing, select and record-enable the track, and activate MIDI Thru Active in the
Preferences dialog (MIDI page).
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MIDI Modifiers Section

NOTE
If you want to compare the result of your modifier settings with the unprocessed MIDI, you can
use the bypass button in the MIDI modifiers section. If this button is activated, the MIDI
modifiers settings are temporarily disabled.

Transpose
Allows you to transpose all notes on the track in semitones. Extreme transpositions
can give rather strange and unwanted results.
Velocity Shift
Allows you to add a velocity value to all notes on the track. Positive values increase
the velocity while negative values lower the velocity.
Velocity Compression
Allows you to add a multiplier to the velocity of all notes on the track. The value is set
with a numerator and a denominator. This parameter also affects the velocity
differences between the notes, thus compressing or expanding the velocity scale.
Values smaller than 1/1 compress the velocity range. Values greater than 1/1
together with negative Velocity Shift values expand the velocity range.
IMPORTANT
Remember that the maximum velocity is always 127, no matter how much you try to
expand.
NOTE
Combine this setting with the Velocity Shift parameter.
Length Compression
Allows you to add a multiplier to the length of all notes on the track. The value is set
with a numerator and a denominator.
Random
Allows you to introduce random variations to various properties of MIDI notes.
Range
Allows you to specify a pitch or velocity range and either force all notes to fit within
this range, or exclude all notes outside this range from playback.
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HMT: Follow
Activate this button to apply Hermode tuning to the notes played on this track.
HMT: Use for Analysis
Activate this option to use the notes you played on this track to calculate retuning.

Setting up Random Variations
You can set up random variations for position, pitch, velocity, and length of MIDI events using
one or two random generators.
PROCEDURE
1.

Select a MIDI or instrument track.

2.

In the Inspector, open the MIDI Modifiers section.

3.

Open the Random pop-up menu and select the note property you want to randomize.

4.

Specify the limits of the randomization in the two number fields.
The values will vary between the left value and the right value. You cannot set the left
value higher than the right value.

5.

Play back the track to hear the randomized events.

RESULT
The corresponding properties are randomized.
NOTE
Depending on the track content, certain changes might not be immediately noticeable or might
have no effect at all.
AFTER COMPLETING THIS TASK
Deactivate the random function by opening the Random pop-up menu and selecting OFF.

Setting up Ranges
You can filter out pitches or velocities that do not match a specified range, or force them to fit a
specified range.
PROCEDURE
1.

Select a MIDI or instrument track.

2.

In the Inspector, open the MIDI Modifiers section.

3.

Open the Range pop-up menu and select a mode.

4.

Set the minimum and maximum values with the two fields to the right.
NOTE
You can make independent settings for the two Range functions.

AFTER COMPLETING THIS TASK
To deactivate the function, open the Range pop-up menu and select OFF.
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Range Modes
On the Range pop-up menu, you can select different range modes. Values are shown as
numbers, from 0 to 127, for the velocity modes and as note numbers, from C-2 to G8, for the
pitch modes.
Vel. Limit
Allows you to force all velocity values to fit within the range that you specify with the
min and max values. Values below the lower limit are set to the min value, velocity
values above the higher setting are set to the max value.
Vel. Filter
Allows you to filter out notes with velocity values below the min value or above the
max value.
Note Limit
Allows you to transpose all notes below the min value upwards and all notes above
the max value downwards in octave steps.
Note Filter
Allows you to filter out notes that are lower than the min value or higher than the
max value.

Applying Hermode Tuning
Hermode Tuning changes the tuning of notes that you play. It creates clear frequencies for every
fifth and third interval, for example. Retuning only affects individual notes and maintains the
pitch relationship between keys and notes. The retuning is a continuous process and takes the
musical context into account.
PROCEDURE
1.

Select a MIDI or instrument track.

2.

In the Inspector, open the MIDI Modifiers section.

3.

Activate HMT: Follow.

4.

Activate HMT: Use for Analysis to use the notes you play to calculate retuning.
NOTE
If you use tracks with acoustic piano, activate HMT: Use for Analysis and deactivate HMT:
Follow. This excludes the piano from being tuned which would sound unnatural.

5.

Select Project > Project Setup to open the Project Setup dialog.

6.

Open the HMT Type pop-up menu and select one of the options.

7.

Play some notes.
It may take a moment until all notes are recalculated and you hear the results of the
retuning.
NOTE
Notes that are produced by MIDI plug-ins are not taken into account.

RESULT
If you use a VST 3 instrument that supports Micro Tuning and Note Expression, notes are retuned
dynamically while you play them. For VST instruments that support Note Expression, this also
works in MIDI Thru mode.
If you use a track that has a VST 2 instrument loaded, the notes you play are retuned on every
keystroke.
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Hermode Tuning on page 770

Hermode Tuning
You can select different Hermode tuning types.
●

To select a Hermode Tuning type, select Project > Project Setup and select an option from
the HMT Type pop-up menu.

The following options are available:
None
No tuning is applied.
Reference (pure 3/5)
Tunes pure thirds and fifths.
Classic (pure 3/5 equalized)
Tunes pure thirds and fifths. In conflict situations, a slight equalization is applied.
This tuning type is suitable for all kinds of music.
Pop Jazz (3/5/7)
Tunes pure thirds and fifths, and natural sevenths. This tuning type should not be
applied to polyphonic music. Try this with pop or jazz.
Baroque (3/5 adaptive)
Tunes pure thirds and fifths. The degree of purity changes according to the sequence
of harmonies. This tuning type is suitable for church organ and polyphonic music.

Freezing MIDI Modifiers
You can apply all filter settings permanently to the selected track. The settings are applied to the
events on the track, and all modifiers are set to zero.
PROCEDURE
1.

Select the MIDI track.

2.

Select MIDI > Freeze MIDI Modifiers.

RESULT
The following settings are frozen:
●

Several settings in the top section of the Inspector, such as Delay, Program Selector, and
Bank Selector.

●

The settings in the MIDI Modifiers section, such as Transpose, Vel. Shift, Vel. Comp., and
Len. Comp..

●

The settings in the MIDI Inserts section, such as arpeggiators.

●

The info line settings Transpose and Velocity.
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RELATED LINKS
MIDI Track Inspector on page 116

MIDI Effects
MIDI effects allow you to transform the MIDI data played back from the track in real time.
You can add new events by using MIDI effects, or change MIDI event properties like pitches, for
example.
NOTE
The included MIDI effect plug-ins are described in the separate document Plug-in Reference.

MIDI Inserts
MIDI insert effects are inserted in the signal chain of MIDI channels. If you add an insert effect to
a MIDI track, the MIDI events on the track are sent to the effect and processed by it. The whole
signal passes through the effect.
●

To add a MIDI insert effect, open the MIDI Inserts section of the MIDI track Inspector.

You can add up to four MIDI insert effects. The following parameters are available:
Bypass
Allows you to bypass all insert effects for the track.
Activate Insert
Allows you to activate/deactivate the selected effect.
Open/Close Insert Effect Editor
Allows you to open/close the control panel for the selected effect. Depending on the
effect, this may appear in a separate window or below the insert slot in the
Inspector.
Select Effect Type
Allows you to select and activate an effect and open its control panel. To remove an
effect, select No Effect.
Record Output to Track
Allows you to record the output of the MIDI insert effect on a MIDI or instrument
track.
NOTE
To open a separate control panel for effects that display their controls in the Inspector, press Alt
and click Open/Close Insert Effect Editor.
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Applying a MIDI Insert Effect
You can apply MIDI insert effects to a MIDI track.
PROCEDURE
1.

Select the MIDI track.

2.

In the Inspector, open the MIDI Inserts section.

3.

Click Select Effect Type to open the MIDI effect pop-up menu.

4.

Select a MIDI effect from the pop-up menu.

RESULT
The effect is automatically activated and its control panel is opened, allowing you to make
settings for the effect. All MIDI from the track is routed through the effect.
NOTE
The included MIDI effects are described in the separate document Plug-in Reference.

Recording a MIDI Insert Effect
You can record the output of a MIDI insert effect, that is, the events are created directly on a
MIDI or instrument track.
PROCEDURE
1.

Select Project > Add Track > Instrument.

2.

In the Add Instrument Track dialog, select a VST instrument.

3.

On the Instrument track, activate Record Enable.

4.

In the Inspector, open the MIDI Inserts section.

5.

Click the first insert effect slot and select a MIDI insert effect.

6.

Activate Record Output to Track.

7.

On the Transport panel, activate Record and use your MIDI keyboard or the On-Screen
Keyboard to play some notes.

RESULT
The notes that you play are modified by the MIDI insert effect and recorded directly on the track.
AFTER COMPLETING THIS TASK
You can edit the recorded MIDI events in the Key Editor, for example.

MIDI Sends
If you use a send effect, the MIDI events are sent both to the output of the MIDI track and to the
send effect. This way, you get both the unprocessed MIDI events and the output of the MIDI
effect. Note that the effect can send its processed MIDI data to any MIDI output, not necessarily
to the one used by the track.
●

To add a MIDI send effect, open the MIDI Sends section of the MIDI track Inspector.
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You can add up to four MIDI send effects.
Bypass
Allows you to bypass all send effects for the track.
Activate Send
Allows you to activate/deactivate the selected effect.
Pre/Post
Activate this to send the MIDI signals to the send effects before the MIDI modifiers
and insert effects.
Open/Close Send Effect Editor
Allows you to open/close the control panel for the selected effect. Depending on the
effect, this may appear in a separate window or below the sends slot in the
Inspector.
Select Effect Type
Allows you to select and activate an effect and open its control panel. To remove an
effect, select No Effect.
MIDI Send Destination
Allows you to determine to which MIDI output the processed MIDI events are sent.
MIDI Send Channel
Allows you to determine on which MIDI channel the processed MIDI events are sent.
NOTE
To open a separate control panel for effects that display their controls in the Inspector, press Alt
and click Open/Close Send Effect Editor.
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Presets
Some of the MIDI effects come with a number of presets for instant use.

1

MIDI In/MIDI Out Activity
Indicates if the plug-in receives or transmits MIDI data.

2

Save Preset/Remove Preset
Allows you to save your settings as a preset or to remove saved presets. Saved presets are
available in the Select Preset pop-up menu for all instances of that MIDI plug-in, and in all
projects.

Transpose and Velocity on the Info Line
You can edit the transposition and the velocity for selected MIDI parts on the info line. This only
affects the notes on playback.
●

Use the Transpose field to transpose the selected parts in semitone steps.
The value is added to the transposition set for the whole track.

●

Use the Velocity Offset field to offset the velocity for the selected parts.
The value is added to the velocities of the notes in the parts.

RELATED LINKS
Transpose Functions on page 326
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The MIDI Device Manager allows you to specify and set up your MIDI devices, making global
control and patch selection easy.
But the MIDI Device Manager also features powerful editing functions that can be used to create
MIDI device panels. MIDI device panels are internal representations of external MIDI hardware,
complete with graphics. The MIDI device panel editor provides all the tools you need to create
device maps where every parameter of an external device (and even an internal device like a VST
instrument) can be controlled and automated from inside Nuendo.
For additional information on how to create panels for VST instruments, see the separate
document MIDI Devices.
RELATED LINKS
About Device panels on page 782

MIDI devices – general settings and patch handling
On the following pages, we will describe how to install and set up preset MIDI devices, and how
to select patches by name from within Nuendo. For a description on how to create a MIDI device
from scratch, please see the separate PDF document MIDI Devices.

About Program Change and Bank Select
To instruct a MIDI instrument to select a certain patch (sound), you send a MIDI Program Change
message to the instrument. Program Change messages can be recorded or entered in a MIDI
part like other events, but you can also enter a value in the Program Selector field in the
Inspector for a MIDI track. This way, you can quickly set each MIDI track to play a different
sound.
With Program Change messages, you are able to select between 128 different patches in your
MIDI device. However, many MIDI instruments contain a larger number of patch locations. To
make these available from within Nuendo, you need to use Bank Select messages, a system in
which the programs in a MIDI instrument are divided into banks, each bank containing 128
programs. If your instruments support MIDI Bank Select, you can use the Bank Selector field in
the Inspector to select a bank, and then the Program Selector field to select a program in this
bank.

Unfortunately, different instrument manufacturers use different schemes for how Bank Select
messages are constructed, which can lead to some confusion and make it hard to select the
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correct sound. Also, selecting patches by numbers this way seems unnecessarily cumbersome,
when most instruments use names for their patches nowadays.
To help with this, you can use the MIDI Device Manager to specify which MIDI instruments you
have connected by selecting from a vast list of existing devices or by specifying the details
yourself. Once you have specified which MIDI devices you are using, you can select to which
particular device each MIDI track is routed. It is then possible to select patches by name in the
track list or Inspector.

Opening the MIDI Device Manager
Select MIDI Device Manager from the More Options submenu of the Studio menu to bring up the
following window:

Installed Devices
List of connected MIDI devices. The first time you open the MIDI Device Manager,
this list will be empty.
Install Device/Remove Device
Use these buttons to install/remove devices.
Export Setup/Import Setup
Use these buttons to import/export XML Device setups.
Open Device
This button opens the selected device.
Output
Here you specify to which MIDI output the selected device is connected.
When you open the MIDI Device Manager for the first time, it will be empty (because you have
not installed any devices yet). On the following pages we describe how to add a pre-configured
MIDI device to the list, how to edit the settings and how to define a device from scratch.
Note that there is an important difference between installing a preset MIDI device (“Install
Device”) and importing a MIDI device setup (“Import Setup”):
●

The presets do not include any device mapping of parameters and controls and no graphic
panels.
They are simply patch name scripts. When you install a preset MIDI device, it is added to
the Installed Devices list. For more information about patch name scripts, see the separate
document MIDI Devices.

●

A device setup can include device mapping, panels and/or patch information.
Device setups are also added to the list of installed devices when imported.

RELATED LINKS
About Device panels on page 782
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Defining a new MIDI device
If your MIDI device is not included in the list of pre-configured devices (and is not a “plain” GM or
XG device), you need to define it manually to make it possible to select patches by name.
PROCEDURE
1.

In the MIDI Device Manager, click the Install Device button.
The Add MIDI Device dialog opens.

2.

Select “Define New…” and click OK.
The “Create New MIDI Device” dialog opens. For a description of the options in this dialog,
see the separate document MIDI Devices.

3.

In the Identical Channels list, activate the MIDI channels you would like the device to use.
This means that the device will receive Program Change over any MIDI channel. For a
description of Identical and Individual Channels, see the separate document MIDI
Devices.

4.

Enter a name for the device at the top of the dialog, and click OK.
The device appears in the Installed Devices list, and the device node structure for the
device is automatically shown in a new window.

5.

Select Patch Banks from the pop-up menu at the top of the window.
As you can see, the list is empty.

6.

Make sure that the Enable Edit checkbox is activated.
Now you can use the functions on the Commands pop-up menu on the left to organize the
patch structure of the new device.

Installing a preset MIDI device
PROCEDURE
1.

Click the Install Device button.
A dialog opens listing all pre-configured MIDI devices. For now we assume that your MIDI
device is included in this list.

2.

Locate and select the device in the list and click OK.
If your MIDI device is not included in the list but is compatible with the GM (General MIDI)
or XG standards, you can select the generic GM or XG Device options at the top of the list.
When you select one of these options, a name dialog will appear. Enter a name for the
instrument and click OK.
The device now appears in the Installed Devices list to the left.

3.

Make sure that the new device is selected in the list and open the Output pop-up menu.

4.

Select the MIDI output that the device is connected to.

5.

Click the Open Device button.
A separate window opens for the selected device, showing a node structure in the left half
of the window. At the top of this structure is the device itself, and below it the MIDI
channels used by the device. For more information about the Device window, see the
separate document MIDI Devices.

6.

Select Patch Banks from the pop-up menu at the top of the window.
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RESULT
The Patch Banks list in the left half of the window shows the patch structure of the device. This
could simply be a list of patches, but it is usually one or several layers of banks or groups
containing the patches (much like a folder structure on a hard disk for example).

●

You can rename a device in the Installed Devices list by double-clicking and typing – this is
useful if you have several devices of the same model, and want to separate them by name
instead of by number.

●

To remove a device from the Installed Devices list, select it and click Remove Device.

NOTE
Note that if there already exists a panel for the device, opening the device might open this panel
first. In this case, click on the Edit button to open the Device window.

About Patch Banks
Depending on the selected device, you may find that the Patch Banks list is divided in two or
more main banks. Typically, these are called Patches, Performances, Drums, etc. The reason for
having several patch banks is that different “types” of patches are handled differently in the
instruments. For example, while “patches” typically are “regular” programs that you play one at
the time, “performances” may be combinations of programs, which could be split across the
keyboard, layered, or used for multi-timbral playback, and so on.
For devices with several banks, you will find an additional item labeled “Bank Assignment” in the
pop-up menu at the top of the window. Selecting this opens a window in which you can specify
for each MIDI channel which bank it should use.

The selection here will affect which bank is displayed when you select programs by name for the
device in the track list or Inspector. For example, many instruments use MIDI channel 10 as an
exclusive drum channel, in which case you would want to select the “Drums” (or “Rhythm Set”,
“Percussion”, etc.) bank for channel 10 in this list. This would then let you choose between
different drum kits in the track list or Inspector.

Limitations
There is no easy way to import a patch name script into an existing MIDI device. For a complex
workaround based on XML editing, see the separate document MIDI Devices.
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Selecting a patch for an installed device
If you return to the Project window at this point, you will find that the installed device has been
added to the MIDI Output menus (in the track list and the Inspector). Now you can select patches
by name, in the following way:
PROCEDURE
1.

Open the Output menu (in the track list or Inspector) for the track you want to associate
the installed device with, and select the device.
This directs the track to the MIDI output specified for the device in the MIDI Device
Manager. The Bank and Program Selector fields in the track list and Inspector are replaced
by a single Program Selector field that reads “Off”.

2.

Click the Program Selector field to display a pop-up menu, hierarchically listing all the
patches in the device.
The list is similar to the one displayed in the MIDI Device Manager. You can scroll the list
up and down (if required), click the plus/minus signs to show or hide subgroups, etc.

You can also use a filter function here. For this, enter a search term such as drum in the
Filter field, and press Return to display all sounds with drum in the name.
3.

Click a patch in the list to select it.
This sends the appropriate MIDI message to the device. You can also scroll the program
selection up or down, as with any value.

Renaming patches in a device
The pre-configured devices list is based on the factory-preset patches, that is, the patches
included in the device when you first bought it. If you have replaced some of the factory presets
with your own patches, you need to modify the device so that the patch name list matches the
actual device:
PROCEDURE
1.

In the MIDI Device Manager, select the device in the Installed Devices list.

2.

Click Open Device.
Make sure that Patch Banks is selected on the pop-up menu at the top of the window.

3.

Activate the Enable Edit checkbox.
When this is turned off (default), you cannot edit the pre-configured devices.

4.

In the Patch Banks list, locate and select the patch you want to rename.
In many instruments, the user-editable patches are located in a separate group or bank.

5.

Click on the selected patch in the Patch Banks list to edit its name.

6.

Type in the new name and press Return.

7.

Rename the desired patches in this way, and finish by deactivating Enable Edit again (to
avoid modifying the device by accident).
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NOTE
You can also make more radical changes to the patch structure in a device (adding or
deleting patches, groups or banks). For example, this is useful if you expand your MIDI
device by adding extra storage media such as RAM cards.

Patch Structure
Patches are structured as follows:
●

Banks are the main categories of sounds – typically patches, performances and drums.

●

Each bank can contain any number of groups, represented by folders in the list.

●

The individual patches, performances or drum kits are represented by presets in the list.

The Commands pop-up menu contains the following items:
Create Bank
Creates a new bank at the highest hierarchical level of the Patch Banks list. You can
rename this by clicking on it and typing a new name.
New Folder
Creates a new subfolder in the selected bank or folder. This could correspond to a
group of patches in the MIDI device, or just be a way for you to categorize sounds,
etc. When you select this item, a name dialog opens, allowing you to name the
folder. You can also rename the folder afterwards by clicking it and typing in the list.
New Preset
This adds a new preset in the selected bank or folder.
When the preset is selected, the corresponding MIDI events (Program Change, Bank
Select, etc.) are shown in the event display to the right. The default setting for a new
preset is Program Change 0 – to change this, proceed as follows:
IMPORTANT
For details on which MIDI events are used for selecting patches in the MIDI device,
consult its documentation.
●

To change which Program Change value is sent out to select the patch, adjust
the number in the Value column for the Program Change event.

●

To add another MIDI event such as Bank Select click directly below the last
event in the list and select a new event from the pop-up menu.
After adding a new event, you need to set its value in the Value column, as
with Program Change.

●

To replace an event, click on it and select another event from the pop-up
menu.
For example, a MIDI device may require that a Bank Select message is sent
first, followed by a Program Change message, in which case you would need
to replace the default Program Change message with a Bank Select message
and add a new Program Change after that.

●

To remove an event, select it and press Delete or Backspace.

IMPORTANT
Different devices use different schemes for Bank Select. When you insert a Bank
Select event, you should check the device’s documentation to find out whether to
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choose “CC: BankSelect MSB”, “Bank Select 14 Bit”, “Bank Select 14 Bit MSB-LSB
Swapped” or some other option.
Add Multiple Presets
This opens a dialog, allowing you to set up a range of presets to be added to the
selected bank or folder.

Adding Multiple Presets
PROCEDURE
1.

Add the event types required for selecting a patch in the MIDI device.
This is done just as when editing the settings for a single event: clicking in the event
display brings up a pop-up menu from which you can select an event type.

2.

Use the Range column to set up either a fixed value or a range of values for each event
type in the list.
This requires some explanation:
If you specify a single value such as 3, 15 or 127 in the Range column, all added presets will
have an event of this type set to the same value.
If you instead specify a value range (a start value and an end value, separated by a dash
such as 0–63), the first added preset will have an event set to the start value, the next value
will be incrementally raised by one and so on, up to and including the end value.

NOTE
The number of added presets depends on the Range setting.
3.

Specify a Default Name below the event display.
The added events will get this name, followed by a number. You can rename presets
manually in the Patch Banks list later.

4.

Click OK.
A number of new presets have now been added to the selected bank or folder, according
to your settings.

Other editing functions
●

You can move presets between banks and folders by dragging them to the Patch Banks
list.

●

You can remove a bank, folder or preset by selecting it in the Patch Banks list and pressing
Backspace.

●

If you specify more than one bank, a Bank Assignment item is added to the pop-up menu
at the top of the window. Use this to assign banks to the different MIDI channels.

RELATED LINKS
About Patch Banks on page 778
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About Device panels
On the following pages we will describe how to use MIDI Device panels and the powerful MIDI
device panel editing features of the MIDI Device Manager.
NOTE
We recommend that you first configure the patch banks, then export the device setup before
editing the panels. This way, most of your settings will be saved in case of panel configuration
problems.
The panels are saved in XML format. For more information, see the separate document MIDI
Devices.

Basic concept
The panel editing features in the MIDI Device Manager can be seen as a separate application or
entity within Nuendo. It allows you to build device maps complete with control panels, including
all parameters controllable from within Nuendo.
Building more complex device maps requires that you are familiar with SysEx programming (see
the separate document MIDI Devices). But you can also create simpler panels by assigning MIDI
Control Change messages to control objects, which does not require any programming skills.
Although these powerful editing features are there if you need them, you do not have to use
them to use MIDI devices.

Device panels in the program
In this section we will take a look at a pre-configured MIDI device panel to illustrate how it can be
used in Nuendo.

Opening a device setup
PROCEDURE
1.

Select Studio > More Options > MIDI Device Manager.

2.

Click the “Import Setup” button.
A file dialog opens.

3.

Select a setup file.
The setup files are saved in XML format, for more information see the separate document
MIDI Devices.

4.

Click Open. The Import MIDI Devices dialog opens where you can select one or several
devices for import.
A setup file can contain one or several MIDI devices.

5.

Select a device and click OK.
The device is added to the list of installed devices in the MIDI Device Manager.

6.

Select the correct MIDI output from the Output pop-up menu, select the device in the list
and click the Open Device button.
The device panel opens in a separate window. The Edit button at the top opens the Edit
Panel window, see the separate document MIDI Devices.

7.

Close the Device panel and return to the Project window.

8.

Select the device from the “Output Routing” pop-up menu for a MIDI track.
Note that for some devices, you may have to set the MIDI channel to “Any”.
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RESULT
Now the Device panel can be opened by clicking the Open Device Panels button in the Inspector
or in the channel for the corresponding track in the MixConsole.

NOTE
Note that Ctrl/Cmd-clicking the Open Device Panels button allows you to open a subpanel via
the panel browser pop-up menu.

Showing panels in the Inspector
PROCEDURE
1.

In the Inspector, open the Device Panel section and click on the arrow on the right.
A “Panels” folder is shown with the selected device in a node structure below it. If you open
all the folders, you can select any individual panel from the device that “fits” into the Device
Panel space.

2.

Select a panel from the list.
The panel opens in the Inspector.

NOTE
If you cannot see any panels in the “Panels” folder, although you have successfully set up a
MIDI device with several panels, make sure that you selected the correct channel from the
Channel pop-up menu, preferably “Any” to see all device panels. Also make sure that the
panels fit into the space, otherwise they will not be available in the “Panels” folder.

Showing panels in the MixConsole
PROCEDURE
1.

Open the MixConsole and click Racks to open the rack selector and activate the Device
Panels rack.

2.

Click the Panel header to expand the Device Panels rack.

3.

Click the button at the right of the header.
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The Panels folder is displayed like in the Inspector, but with different available panels. Just
like in the Inspector, the panel has to “fit” into the available space to be selectable.
4.

Select a panel.
The panel is shown in the Channel Racks section of the MixConsole.

Automating device parameters
Automation works just like for normal audio and MIDI tracks:
PROCEDURE
1.

Open the device panel by clicking the Open Device Panels button in the Inspector.

2.

Activate Write automation on the device panel.
You can automate the device by either moving knobs and sliders on the device panel or by
drawing curves on the automation track for a selected parameter.

3.

If you now go back to the Project window, there will be a MIDI Device Automation track in
the track list.
If the track is hidden, select “Show All Used Automation” on the Track Folding submenu of
the Project menu.
If you click in the name field, all parameters in the device are shown and can be selected
for automation.

●

To open another automation track for the next parameter on the pop-up menu, click
the + button (“Append automation track”) at the bottom left of the automation track.

NOTE
If you wrote automation but your MIDI device is not yet connected, the panel will not
display any parameter changes when playing back the track with the Read button
activated.
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MIDI functions allow you to permanently edit MIDI events or MIDI parts in the Project window or
from within a MIDI editor.
Which events are affected when you use a MIDI function depends on the function, the active
window and the current selection:
●

In the Project window, the MIDI functions apply to all selected parts, affecting all events of
the relevant types in them.

●

In the MIDI editors, MIDI functions apply to all selected events. If no events are selected,
all events in the edited parts are affected.

NOTE
Some MIDI functions only apply to MIDI events of a certain type. For example, Delete
Controllers only applies to MIDI controller events.

RELATED LINKS
MIDI Realtime Parameters and MIDI Effects on page 764

Transpose Setup
The Transpose Setup dialog contains settings for transposing the selected events.
●

Select the MIDI notes that you want to transpose and select MIDI > Transpose Setup to
open the Transpose Setup dialog.

The following settings are available:
Semitones
Sets the amount of transposition.
Scale Correction
Transposes the selected notes to the closest note of a specific scale type. This allows
you to change the key and the tonality.
●

Select a root note and a scale type for the current scale in the Current Scale
pop-up menus.
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●

Select a root note and a scale type for the new scale in the New Scale pop-up
menus.
NOTE
If the new root note differs from the current root note, this leads to an entirely
different key.

Use Range
Limits the transposition of notes to the note values that you specify with the Low and
High settings.
NOTE
Notes that would end up outside the range after transposition, are shifted to another
octave, keeping the correct transposed pitch if possible. If the range between the
upper and lower limit is very narrow, the note is transposed as far as possible, that is,
to notes specified with the Low and High values. If you set Low and High to the
same value, all notes will be transposed to this pitch.
NOTE
You can also use the transpose track for transposing.

RELATED LINKS
Transpose Functions on page 326

Merging MIDI Events into a New Part
You can merge all MIDI events, apply MIDI modifiers and effects and generate a new part.
PROCEDURE
1.

2.

Do one of the following:
●

Mute the tracks or parts that you do not want to include in the merge.

●

Solo the track that contains the events that you want to include in the merge.

Set up the left and right locators to encompass the area that you want to merge.
NOTE
Only events starting within this area will be included.

3.

Optional: Select a track for the new part.
If you do not select a track, a new MIDI track is created. If several MIDI tracks are selected,
the new part is inserted on the first selected track.

4.

Select MIDI > Merge MIDI in Loop....

5.

In the MIDI Merge Options dialog, activate the desired options.

6.

Click OK.

RESULT
A new part is created between the locators on the destination track, containing the processed
MIDI events.
RELATED LINKS
MIDI Merge Options Dialog on page 787
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Freezing MIDI Modifiers on page 770

MIDI Merge Options Dialog
The following options are available:
Include Inserts
Applies MIDI insert effects and MIDI modifiers.
Include Sends
Applies MIDI send effects.
Erase Destination
Deletes MIDI data between the left and right locators on the destination track.
Include Chase
Includes events placed outside the selected part but relating to it in the processing,
for example, a program change right before the left locator.
Convert VST 3
Converts all VST 3 data within the selected area to MIDI data.
RELATED LINKS
Chase on page 256

Applying Effects to a Single Part
You can apply MIDI modifiers and effects to a single part.
PROCEDURE
1.

Set up your MIDI modifiers and MIDI effects the way you want them for the part.

2.

Set the locators to encompass the part.

3.

In the track list, select the track with the part.

4.

Select MIDI > Merge MIDI in Loop....

5.

In the MIDI Merge Options dialog, activate Erase Destination.

6.

Click OK.

RESULT
A new part is created on the same track, containing the processed events. The original part is
deleted.
AFTER COMPLETING THIS TASK
Turn off or reset all MIDI modifiers and effects, so that the track plays back as before.

Dissolve Part
You can separate MIDI events in a part according to channels or pitches and dissolve the part to
different tracks or lanes.
●

Select the MIDI part you want to dissolve and select MIDI > Dissolve Part to open the
Dissolve Part dialog.

The following settings are available:
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Separate Channels
Separates MIDI events according to their channel. This is useful for MIDI parts on
MIDI channel Any that contain events on different MIDI channels.
Separate Pitches
Separates MIDI events according to their pitch. This is useful for drum and
percussion tracks, where different pitches usually correspond to separate drum
sounds.
Optimized Display
Automatically removes silent areas of the resulting parts.
NOTE
This option is not available when Dissolve to Lanes is activated.
Dissolve to Lanes
Dissolves the part to lanes.

Dissolving Parts into Separate Channels
You can dissolve MIDI parts that contain events on different MIDI channels and distribute the
events into new parts on new tracks, one for each MIDI channel found.
PROCEDURE
1.

Select the parts that contain MIDI events on different channels.

2.

Select MIDI > Dissolve Part.

3.

Activate Separate Channels.

4.

Click OK.

RESULT
For each MIDI channel used in the selected parts, a new MIDI track is created and set to the
corresponding MIDI channel. Each event is copied into the part on the track with the
corresponding MIDI channel, and the original parts are muted.

MIDI Channel Setting
Setting a track to MIDI channel Any causes each MIDI event to play back on its original MIDI
channel, rather than a channel set for the whole track.
There are two main situations when Any channel tracks are useful:
●

When you record several MIDI channels at the same time.
You may for example have a MIDI keyboard with several keyboard zones, where each zone
sends MIDI on a separate channel. Setting the channel to Any allows you to play back the
recording with different sounds for each zone (since the different MIDI notes play back on
separate MIDI channels).

●

When you have imported a MIDI file of Type 0.
MIDI files of Type 0 contain only one track, with notes on up to 16 different MIDI channels.
If you were to set this track to a specific MIDI channel, all notes in the MIDI file would be
played back with the same sound; setting the track to Any will cause the imported file to
play back as intended.
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Dissolving Parts into Separate Pitches
You can dissolve MIDI parts that contain events of different pitches and distribute the events into
new parts on new tracks, one for each MIDI pitch found. This is useful when the different pitches
are used for separating different sounds such as MIDI drum tracks or sampler sound FX tracks.
By dissolving such parts, you can work with each sound individually, on a separate track.
PROCEDURE
1.

Select the parts that contain MIDI events of different pitches.

2.

Select MIDI > Dissolve Part.

3.

Activate Separate Pitches.

4.

Click OK.

RESULT
For each MIDI pitch used in the selected parts, a new MIDI track is created. Each event is copied
into the part on the track for the corresponding pitch, and the original parts are muted.

Dissolve to Lanes
You can dissolve MIDI parts that contain events on different MIDI channels or pitches and
distribute the events into new parts on new lanes of the original track.
Dissolving to lanes has the following advantages:
●

You get a better overview of what MIDI material belongs together.

●

It allows you to split up a part into different drum sounds and edit these independently.

●

It allows you to split up instrument parts and still route them to the same VST instrument
instance.

NOTE
To reassemble all events into one part, use Bounce MIDI.

RELATED LINKS
Bouncing MIDI Parts on page 789

Bouncing MIDI Parts
You can combine MIDI parts on different lanes to one MIDI part. This is useful, if you want to
reassemble a drum part that you dissolved to lanes.
PROCEDURE
1.

Select the MIDI parts on the different lanes that you want to combine.

2.

Select MIDI > Bounce MIDI.

RESULT
The selected MIDI parts are combined to one part. Any muted parts are removed. Transpose and
velocity values that are set for the parts are taken into account.
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Repeating MIDI Events of Independent Track Loops
You can repeat the MIDI events inside an independent track loop to fill up a MIDI part. This is
useful, if you want to convert the events of an independent track loop to actual MIDI events.
PREREQUISITE
You have set up an independent track loop and the Key Editor is open. The part ends after the
end of the independent track loop.
PROCEDURE
●

Select MIDI > Repeat Loop.

RESULT
The events of the independent track loop are repeated to the end of the part. Events that are
located to the right of the independent track loop in the part are replaced.
RELATED LINKS
Setting Up the Independent Track Loop on page 570

Extending MIDI Notes
You can extend MIDI notes so that they reach the next notes.
PREREQUISITE
A MIDI part with some note events is open in the Key Editor.
PROCEDURE
1.

Select the note events that you want to extend to the next notes.

2.

Select MIDI > Functions > Legato.

RESULT
The selected note events are extended to the start of the next notes.

NOTE
To specify a gap or overlap for this, adjust the Legato Overlap setting in the Preferences dialog
(Editing—MIDI page).

RELATED LINKS
Key Editor Inspector on page 812
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Fixing MIDI Note Lengths
You can set the length of selected MIDI notes to the Length Quantize value.
PREREQUISITE
A MIDI part with some note events is open in the Key Editor.
PROCEDURE
1.

In the Key Editor toolbar, open the Length Quantize pop-up menu and select the desired
note length.

2.

Select the note events that you want to fix.

3.

Select MIDI > Functions > Fixed Lengths.

RESULT
The selected note events are set to the specified Length Quantize value.

Fixing MIDI Note Velocities
You can set the velocity of selected MIDI notes to the Insert Velocity value.
PREREQUISITE
A MIDI part with some note events is open in the Key Editor.
PROCEDURE
1.

In the Key Editor toolbar, open the Insert Velocity pop-up menu and select the desired
velocity value.

2.

Select the note events that you want to fix.

3.

Select MIDI > Functions > Fixed Velocity.

RESULT
The selected note events are set to the specified Insert Velocity value.

Rendering Sustain Pedal Data to Note Lengths
You can render sustain pedal data to into note lengths. This is useful, if you recorded MIDI data
with a MIDI keyboard and a sustain pedal, and you want to extend the actual MIDI notes for as
long as you held the pedal, in order to edit the notes later.
PREREQUISITE
You recorded MIDI using a MIDI keyboard and a sustain pedal. The MIDI part is open in the Key
Editor.
PROCEDURE
1.

Select the note events.

791

MIDI Functions
Deleting Overlaps
2.

Select MIDI > Functions > Pedals to Note Length.

RESULT
The selected notes are lengthened to match the sustain pedal off position, and the sustain
controller on/off events are removed.

Deleting Overlaps
You can delete overlaps of notes that have the same or different pitches. This is useful, if your
MIDI instruments cannot handle overlapping events.
PROCEDURE
1.

Select the note events.

2.

Do one of the following:
●

Select MIDI > Functions > Delete Overlaps (mono).

●

Select MIDI > Functions > Delete Overlaps (poly).

RESULT
The overlapping MIDI notes are shortened, so that no note begins before another ends.

Editing Velocity
You can manipulate the velocity of notes.
PROCEDURE
1.

Select the note events.

2.

Select MIDI > Functions > Velocity.

3.

Open the Type pop-up menu and activate the desired option.

4.

Optional: Enter a Ratio.

5.

Click OK.

RESULT
The note velocities are changed according to your settings.
RELATED LINKS
Velocity on page 792

Velocity

Add/Subtract
Adds the Amount value to the velocity value. You can enter positive or negative
values.
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Compress/Expand
Uses the Ratio setting (0 to 300 %) to compress or expand the dynamic range of
MIDI notes. A factor higher than 1 (over 100 %) expands the differences between
velocity values, while using a factor lower than 1 (under 100 %) compresses them.
●

To compress the dynamic range, use ratio values below 100 %.
After compression, you can add a velocity amount to maintain the average
velocity level.

●

To expand the dynamic range, use ratio values above 100 %.
Before expansion, you may can adjust the velocity to a middle of the range.

Limit
Limits the velocity values so that they stay between the Lower and the Upper values.

Deleting Double Notes
You can delete double notes of the same pitch on the exact same position from selected MIDI
parts. Double notes can occur when recording in cycle mode, after quantizing, for example.
PROCEDURE
1.

Select the MIDI part that contains the double notes.

2.

Select MIDI > Functions > Delete Doubles.

RESULT
The double notes are automatically deleted.

Deleting Controller Data
You can delete controller data from selected MIDI parts.
PROCEDURE
1.

Select the MIDI parts that contain the controller data.

2.

Select MIDI > Functions > Delete Controllers.

RESULT
The controller data is automatically deleted.

Deleting Continuous Controller Data
You can delete continuous controller data from selected MIDI parts.
PROCEDURE
1.

Select the MIDI parts that contain the controller data.

2.

Select MIDI > Functions > Delete Continuous Controllers.

RESULT
The continuous controller data is automatically deleted. However, On/Off events such as sustain
pedal events are kept.
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Restricting Polyphonic Voices
You can restrict polyphonic voices in selected MIDI notes or parts. This is useful when you have
an instrument with limited polyphony and want to make sure all notes are played.
PROCEDURE
1.

Select the MIDI notes or parts that contain the voices.

2.

Select MIDI > Functions > Restrict Polyphony.

3.

Specify how many voices you want to use.

4.

Click OK.

RESULT
The notes are shortened as required, so that they end before the next note starts.

Thinning Out Controller Data
You can thin out controller data in selected MIDI parts. Use this to ease the load on your external
MIDI devices if you have recorded very dense controller curves, etc.
PROCEDURE
1.

Select the MIDI parts that contain the controllers that you want to thin out.

2.

Select MIDI > Functions > Thin Out Data.

RESULT
The controller data is thinned out.
NOTE
This also thins out MIDI controller and VST 3 events that form part of Note Expression data.

Extracting MIDI Automation
You can convert continuous controllers of your recorded MIDI parts into MIDI track automation
data, so that you can edit them in the Project window.
PROCEDURE
1.

Select the MIDI part that contains the continuous controller data.

2.

Select MIDI > Functions > Extract MIDI Automation.

RESULT
In the Project window, for each of the continuous controllers in the MIDI part an automation
track is created.
In the MIDI editors, the controller data is removed from the controller lane.
NOTE
This only works for continuous controllers. Data such as Aftertouch, Pitchbend, or SysEx cannot
be converted to MIDI track automation data.
MIDI controller automation is also affected by the Automation Merge Mode.
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RELATED LINKS
MIDI Controller Automation on page 721
Creating a Tempo Track from Tapping on page 795

Reversing the Playback Order of MIDI Events
You can invert the order of the selected events or of all events in a selected parts rhythmically.
This causes the MIDI to play backwards. However, this is different from reversing an audio
recording. The individual MIDI notes still play as usual, but the playback order changes.
PROCEDURE
1.

Select the MIDI events or the MIDI part.

2.

Select MIDI > Functions > Reverse.

RESULT
The playback order of the events is reversed while the individual notes still play as usual in the
MIDI instrument. Technically, this function reverses the Note On message of a note within a part
or selection.

Inverting the Order of Selected MIDI Events
This function inverts the order of the selected events (or of all events in the selected parts)
graphically. Technically, this function turns a Note On message into a Note Off message and vice
versa which can lead to rhythmic inaccurancies if the Note Off position of a note has not been
quantized.
PROCEDURE
1.

Select the MIDI events or the MIDI part.

2.

Select MIDI > Functions > Mirror.

RESULT
The order of the events is inverted while the individual notes still play as usual in the MIDI
instrument. Technically, this function turns a Note On message into a Note Off message and vice
versa which can lead to rhythmic inaccuracies if the Note Off position of a note has not been
quantized.

Creating a Tempo Track from Tapping
You can create a complete tempo track based on your tapping.
PREREQUISITE
You recorded some MIDI notes by tapping the tempo on your MIDI keyboard.
PROCEDURE
1.

Select the recorded MIDI events or the whole part.

2.

Select MIDI > Functions > Merge Tempo from Tapping.

RESULT
The tempo that you tapped is calculated, and a tempo curve is created in the Tempo Track
Editor.
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RELATED LINKS
Tempo Track Editor on page 976
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There are several ways to edit MIDI in Nuendo. You can use the tools and functions in the Project
window for large-scale editing or the functions on the MIDI menu to process MIDI parts in
various ways. To manually edit your MIDI data on a graphical interface, you can use the MIDI
editors.
●

The Key Editor presents notes graphically in a piano roll-style grid. The Key Editor also
allows for detailed editing of non-note events such as MIDI controllers.

●

The Score Editor shows MIDI notes as a musical score and provides advanced tools and
functions for notation, layout, and printing.

●

The Drum Editor is similar to the Key Editor, but each key corresponds to a separate
drum sound.
You can use the Drum Editor to edit drum or percussion parts.

●

The List Editor shows all events in the selected MIDI parts as a list and allows you to view
and edit their properties numerically. It also allows you to edit SysEx messages.

●

The In-Place Editor allows you to edit MIDI parts directly in the Project window so that
you can edit MIDI in context with other track types.
You can also edit MIDI in the Project Browser.

RELATED LINKS
Key Editor on page 804
Drum Editor on page 833
List Editor on page 854
Project Browser on page 994
In-Place Editor on page 868

Common MIDI Editor Functions
You can use the tools and functions within the MIDI editors to process MIDI parts in various
ways.

Changing the Display Format for the Ruler
By default, the ruler shows the timeline in the display format that is selected on the transport
panel.
You can change the display format for the ruler. Click the arrow button to the right of the ruler
and select an option from the pop-up menu.
RELATED LINKS
Ruler Display Formats on page 48
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Zooming in MIDI Editors
The MIDI editors provide several zooming options:
●

The zoom sliders.

●

The Zoom tool.

●

The Zoom submenu in the Edit menu.

When you use the Zoom tool for zooming, you can determine if you want to zoom horizontal
only or horizontal and vertical at a time.
●

To activate/deactivate the corresponding option, activate/deactivate Zoom Tool Standard
Mode: Horizontal Zooming Only in the Preferences dialog (Editing—Tools page).

Using Cut and Paste
You can use the Cut, Copy, and Paste options from the Edit menu to move or copy material
within a part or between different parts.
●

To insert note events at the project cursor position without affecting existing notes, select
Edit > Paste.

●

To insert note events at the project cursor position, move, and if necessary split the
existing note events to make room for the pasted notes, select Edit > Range > Paste Time.

1

Data on clipboard

2

Cursor position

3

Pasted data at cursor position

Handling Note Events
Coloring Notes and Events
You can select different color schemes for the note events in the MIDI editor.
The following options are available on the Event Colors pop-up menu on the toolbar:
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Velocity
The note events get different colors depending on their velocity values.
Pitch
The note events get different colors depending on their pitch.
Channel
The note events get different colors depending on their MIDI channel value.
Part
The note events get the same color as their corresponding part in the Project
window. Use this option if you are working with 2 or more tracks in an editor, to see
which note events belong to which track.
Grid Match
The note events get different colors depending on their time position. For example,
this mode enables you to see if the notes of a chord start at the exact same beat.
Sound Slot
The note events get different colors depending on the articulation that has been
assigned to the note in the Expression Map Setup dialog.
Voice
The note events get different colors depending on their voice (soprano, alto, tenor,
etc.).
Chord Track
The note events get different colors depending on whether they match the current
chord, scale, or both.
For all of the options except Part, the pop-up menu also contains a Setup option. This option
opens a dialog in which you can specify the colors that are associated with velocities, pitches, or
channels.
RELATED LINKS
Expression Maps on page 871

Selecting Note Events
The selected MIDI editor determines which of the following methods apply.
Do one of the following:
●

Use the Object Selection tool to drag a selection rectangle around the note events that
you want to select. You can also click individual events.

●

Select Edit > Select and select one of the options.

●

To select the previous or next note event, use the Left Arrow/Right Arrow key.

●

To select several notes, press Shift and use the Left Arrow/Right Arrow key.

●

To select all notes of a certain pitch, press Ctrl/Cmd and click on a key in the keyboard
display to the left.

●

To select all the following note events of the same pitch/staff, press Shift and double-click
a note event.

RELATED LINKS
Selecting Note Events Using the Select Submenu on page 800
Editing on page 1182
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Selecting Note Events Using the Select Submenu
The Select submenu offers you several options to select note events.
To open the Select submenu, select Edit > Select.
All
Selects all note events in the edited part.
None
Deselects all note events.
Invert
Inverts the selection. All selected note events are deselected and all notes that were
not selected are selected instead.
In Loop
Selects all note events that are partially or completely inside the boundaries of the
left and right locators (only visible if locators are set).
From Start to Cursor
Selects all note events that begin to the left of the project cursor.
From Cursor to End
Selects all note events that end to the right of the project cursor.
Equal Pitch - all Octaves
Selects all note events of the highlighted part that have the same pitch (in any
octave) as the selected note event.
NOTE
This function requires that a single note event is selected.
Equal Pitch - same Octave
Selects all note events of the highlighted part that have the same pitch (same octave)
as the selected note event.
NOTE
This function requires that a single note event is selected.
Select Controllers in Note Range
Selects the MIDI controller data within the range of the selected note events.
RELATED LINKS
Deleting Note Events on page 801

Muting Note Events
You can mute individual note events in a MIDI editor. Muting individual notes allows you to
exclude note events from playback.
Do one of the following:
●

Click on a note event with the Mute tool.

●

Drag a rectangle with the Mute tool, enclosing all note events that you want to mute.

●

Select the note events and select Edit > Mute.
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●

To unmute a note event, click it or enclose it with the Mute tool. You can also select a note
event and select Edit > Unmute.

Muted notes are dimmed in the note display.

Toggle Selections
●

To toggle selected elements within a selection rectangle, press Ctrl/Cmd and enclose the
same elements within a new selection rectangle.

Once you release the mouse button, the previous selection is deselected and vice versa.

Deleting Note Events
●

To delete note events, click on them with the Erase tool or select them and press
Backspace.

Cutting Note Events
The Trim tool allows you to cut off the end or the beginning of note events.
PROCEDURE
1.

Select the Trim tool on the toolbar.

2.

Do one of the following:
●

To trim the end of a single note event, click on the note event.

●

To trim the beginning of a single note event, press Alt and click the note event.

●

To trim several note events, click and drag across the note events.

●

To set the same start and end time for all edited note events, press Ctrl/Cmd and
vertically drag along the note events.

Editing Note Events on the Info Line
You can move, resize, or change the velocity of note events on the info line using regular value
editing.
●

To apply a value change to all selected note events, press Ctrl/Cmd and change a value on
the info line.

●

To adjust the pitch or velocity of note events via your MIDI keyboard, click in the Pitch or
Velocity fields on the info line, and play a note on your MIDI keyboard.
If you have several note events selected and change a value, all selected events are
changed by the set amount.

Duplicating and Repeating Note Events
You can duplicate and repeat note events in the same way as events in the Project window.
●

To duplicate the selected note events, hold down Alt and drag the note events to a new
position.
If Snap is activated, it determines to which positions you can copy notes.

●

To copy the selected note events and place them directly behind the original, select Edit >
Functions > Duplicate.
If several note events are selected, all of them are copied as one unit, maintaining the
relative distance between the note events.

●

To create a number of copies of the selected note events, select Edit > Functions >
Repeat, specify the number, and click OK.

801

MIDI Editors
Common MIDI Editor Functions
You can also press Alt and drag the right edge of the note events to the right to create
copies of the note events.

Finding Exact Positions with Snap
The Snap function restricts horizontal movement and positioning to certain positions. This helps
you find exact positions in the note display when editing note events in a MIDI editor. Affected
operations include moving, duplicating, drawing, sizing, etc.
●

To activate/deactivate snap, click Snap

.

If you select the Bars+Beats display format, the snap grid is set by the quantize value on
the toolbar. This makes it possible to snap to straight note values and to swing grids that
have been set up in the Quantize Panel.
●

If you select any of the other display formats, positioning is restricted to the displayed
grid.

Setting Velocity Values
When you draw note events in the MIDI editor, the note events get the velocity value that is set in
the Insert Velocity field on the toolbar. There are different methods to set the velocity.
●

Use the Edit Velocity tool modifier. The cursor changes into a speaker, and next to the
note, a field with the Note Velocity slider shows the value. Move the mouse pointer up or
down to change the value.

Value changes are applied to all selected notes.
For this, a tool modifier must be assigned for the Edit Velocity action. You can edit the tool
modifier in the Preferences dialog (Tool Modifiers page).
●

Open the Insert Velocity pop-up menu and select a velocity value.
On this menu, you can also select Setup and specify custom velocity values for the pop-up
menu.

●

Double-click the Insert Velocity field on the toolbar and enter a velocity value.

●

Assign key commands to Insert Velocity 1-5 and use them.
This allows you to quickly switch between different velocity values when you enter note
events.

Handling Several MIDI Parts
●

To activate a part for editing, open the Currently Edited Part menu and select a part.
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When you select a part from the list, it is automatically active and centered in the note
display.
●

To zoom in on an active part, select Edit > Zoom > Zoom to Event.

●

To display defined borders for the active part, activate Show Part Borders.

If this option is activated, all parts, except the active part, are grayed out.
●

To restrict editing operations to the active part, activate Edit Active Part Only.

●

To change the size of the part, drag the part borders.
The part borders display the name of the active part.

NOTE
If the part that you open for editing is a shared copy, any editing that you perform affects all
shared copies of this part. In the Project window, shared copies are indicated by an equal sign in
the top right corner of the part.

Looping MIDI Parts
The Independent Track Loop function allows you to loop a MIDI part independent of the project
playback.
When you activate the loop, the MIDI events within the loop are repeated continuously while
other events on other tracks are played back as usual. Every time the cycle restarts, the
independent track loop also restarts.
PROCEDURE
1.

Activate Independent Track Loop

on the toolbar.

NOTE
If you activate Independent Track Loop, the Link Project and Lower Zone Editor
Cursors function is automatically deactivated in the lower zone editor.
If the button is not visible, right-click the toolbar and select Independent Track Loop from
the menu.
If you have set up a loop range in the Project window, it is hidden from the ruler in the
MIDI editor.
2.

Ctrl/Cmd-click in the ruler to specify the start of the independent track loop.

3.

Alt-click in the ruler to specify the end of the independent track loop.

RESULT
The independent loop range is indicated in a different color.
The start and end of the loop range are displayed on the status line.
AFTER COMPLETING THIS TASK
To repeat the events of the loop range and fill up the active MIDI part, select MIDI > Repeat
Loop.
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Key Editor
The Key Editor is the default MIDI editor. It displays notes graphically in a piano roll-style grid.
The Key Editor allows for detailed editing of notes and non-note events, such as MIDI
controllers.
You can open the Key Editor in a separate window or in the lower zone of the Project window.
Opening the Key Editor in the lower zone of the Project window is useful if you want to access
the Key Editor functions from within a fixed zone of the Project window.
To open a MIDI part in the Key Editor, do one of the following:
●

Double-click a MIDI part in the Project window.

●

Select a MIDI part in the Project window and press Return or Ctrl/Cmd-E.

●

Select a MIDI part in the Project window and select MIDI > Open Key Editor.

●

In the Key Commands dialog in the Editors category, assign a key command for Open
Key Editor. Select a MIDI part in the Project window and use the key command.

NOTE
If you select MIDI > Set up Editor Preferences, the Preferences dialog opens on the Editors
page. Make your settings to specify if you want the editors to open in a separate window or in
the lower zone of the Project window.
The Key Editor window:

The Key Editor in the lower zone of the Project window:
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The Key Editor is divided into several sections:
1

Toolbar
Contains tools and settings.

2

Status line
Informs about the mouse time position, the mouse note position, and the current chord.

3

Info line
Displays note event information about a selected MIDI note.

4

Ruler
Displays the timeline.

5

Inspector
Contains tools and functions for working with MIDI data.

6

Note display
Contains a grid in which MIDI notes are displayed as boxes.

7

Controller display
The area below the note display consists of one or multiple controller lanes.

NOTE
You can activate/deactivate the status line, the info line, and the controller lanes by clicking Set
up Window Layout on the toolbar and activating/deactivating the corresponding options.
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Toolbar
The toolbar contains tools and settings for the Key Editor.
●

To show or hide the toolbar elements, right-click the toolbar and activate or deactivate the
elements.

Static Buttons
Solo Editor
Solos the editor during playback if the editor has the focus.
Record in Editor
Enables the recording of MIDI data in the editor if the editor has the focus.
NOTE
This only works if MIDI Record Mode is set to Merge or Replace.

Left Divider
Left Divider

Allows you to use the left divider. Tools that are placed to the left of the divider are
always shown.

Auto-Scroll
Link Project and Lower Zone Editor Cursors
Links timelines, cursors, and zoom factors of the lower zone editor and the Project
window.
NOTE
You cannot activate Link Project and Lower Zone Editor Cursors if Independent
Track Loop is active.
Auto-Scroll
Keeps the project cursor visible during playback. The Switch Auto-Scroll Settings
pop-up menu allows you to activate Page Scroll or Stationary Cursor and to activate
Suspend Auto-Scroll when Editing.
Switch Auto-Scroll Settings
Allows you to specify the auto-scroll settings.

Tool Buttons
Object Selection
Allows you to select events.

806

MIDI Editors
Key Editor
Draw
Allows you to draw events.
Erase
Allows you to delete events.
Trim
Allows you to trim events.
Split
Allows you to split events.
Mute
Allows you to mute events.
Glue
Allows you to glue together events of the same pitch.
Zoom
Allows you to zoom in/out. Hold Alt and click to zoom out.
Line
Allows you to create a series of contiguous events.
Time Warp
Allows you to drag a musical position to a certain position in time.

Acoustic Feedback
Acoustic Feedback
Automatically plays back events when you move or transpose them, or when you
create them by drawing.

Auto Select Controllers
Auto Select Controllers
Automatically selects controller data of the selected MIDI notes.

Independent Track Loop
Independent Track Loop
Activates/Deactivates the independent track loop.
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NOTE
If you activate Independent Track Loop, the Link Project and Lower Zone Editor Cursors
function is automatically deactivated in the lower zone editor.

Show Note Expression Data
Show Note Expression Data
Shows note expression data.

Multiple Part Controllers
Show Part Borders
Shows/Hides part borders for the active MIDI part within the left and right locators.
Edit Active Part Only
Restricts editing operations to the active part.
Currently Edited Part
Lists all parts that were selected when you opened the editor, and allows you to
activate a part.

Indicate Transpositions
Indicate Transpositions
Allows you to display the transposed pitches of MIDI notes.

Insert Velocity
Insert Velocity
Allows you to specify a velocity value for new notes.

Nudge Palette
Trim Start Left
Increases the length of the selected event by moving its start to the left.
Trim Start Right
Decreases the length of the selected event by moving its start to the right.
Move Left
Moves the selected event to the left.
Move Right
Moves the selected event to the right.
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Trim End Left
Decreases the length of the selected event by moving its end to the left.
Trim End Right
Increases the length of the selected event by moving its end to the right.

Transpose Palette
Move Up
Transposes the selected event up by a half note.
Move Down
Transposes the selected event down by a half note.
Move Up More
Transposes the selected event up by an octave.
Move Down More
Transposes the selected event down by an octave.

Snap
Snap On/Off
Activates/Deactivates the snap function.
Snap Type
Allows you to select one of the following snap types:
●

Grid snaps events to the grid that is selected in the Quantize Presets popup menu.

●

Grid Relative

●

Events

●

Shuffle changes the order of events if you drag one event to the left or right
of other events.

●

Magnetic Cursor

●

Grid + Cursor
snaps events to the quantize grid that is selected in the
Quantize Presets pop-up menu or to the cursor position.

●

Events + Cursor
cursor position.

●

Grid + Events + Cursor
snaps events to the quantize grid that is
selected in the Quantize Presets pop-up menu, to the start or end of other
events or to the cursor position.

keeps the relative positions when snapping events to the grid.

snaps events to the start or end of other events.

snaps events to the cursor position.

snaps events to the start or end of other events or to the

Grid Type
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Allows you to select one of the following grid types:
●

Use Quantize activates a grid where events snap to the value that is selected
in the Quantize Preset pop-up menu.

●

Adapt to Zoom activates a grid where events snap to the zoom level.

Quantize
Iterative Quantize On/Off
Activates/Deactivates iterative quantize.
Quantize Presets
Allows you to select a quantize or a groove preset.
Apply Quantize
Applies the quantize settings.
Open Quantize Panel
Opens the Quantize Panel.

Length Quantize
Length Quantize
Allows you to set a value for quantizing event lengths.

Step/MIDI Input
Step Input
Activates/Deactivates MIDI step input.
MIDI Input/Note Expression MIDI Input
Activates/Deactivates MIDI input and note expression MIDI input.
Move Insert Mode
Moves all note events to the right of the step input position to the right to make
room for the inserted event when you insert notes.
NOTE
This only works if Step Input is activated.
Record Pitch
Includes the pitch when you insert notes.
Record NoteOn Velocity
Includes the NoteOn velocity when you insert notes.
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Record NoteOff Velocity
Includes the NoteOff velocity when you insert notes.

Event Colors
Event Colors
Allows you to select event colors.

Edit VST Instrument
Edit VST Instrument
Opens the VST Instrument that the track is routed to.

Right Divider
Right Divider

Allows you to use the right divider. Tools that are placed to the right of the divider
are always shown.

Window Zone Controls
Open in Separate Window
This button is available in the lower zone editor. It opens the editor in a separate
window.
Open in Lower Zone
This button is available in the editor window. It opens the editor in the lower zone of
the Project window.
Set up Window Layout
Allows you to set up the window layout.
Set up Toolbar
Opens a pop-up menu where you can set up which toolbar elements are visible.
RELATED LINKS
Zooming in MIDI Editors on page 798

Status Line
The status line shows information about the mouse time position, the mouse note position, and
the current chord.
To show or hide the status line, click Set up Window Layout on the toolbar, and activate or
deactivate Status Line.
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The on/off status of the status line in the Key Editor window and in the lower zone editor are
independent of each other.
Mouse Time Position
Displays the exact time position of the mouse pointer, depending on the selected
ruler display format. This lets you edit or insert notes at exact positions.
Mouse Note Position
Displays the exact pitch of the mouse pointer position. This facilitates finding the
right pitch when entering or transposing notes.
Current Chord Display
When the project cursor is positioned over notes that form a chord, the chord is
displayed here.
RELATED LINKS
Looping MIDI Parts on page 803

Info Line
The info line shows values and properties of the selected events. If several notes are selected, the
values for the first note are displayed in color.
To show or hide the info line, click Set up Window Layout on the toolbar, and activate or
deactivate Info Line.

Length and position values are displayed in the selected ruler display format.
The on/off status of the info line in the Key Editor window and in the lower zone editor are
independent of each other.
RELATED LINKS
Editing Note Events on the Info Line on page 801
Changing the Display Format for the Ruler on page 797

Key Editor Inspector
In a MIDI editor, the inspector is located left of the note display. The inspector contains tools and
functions for working with MIDI data.

Expression Map
Allows you to load an expression map. Expression maps are useful for working with
articulations.
Note Expression
Contains functions and settings related to Note Expression.
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Chord Editing
Allows you to enter chords instead of single notes.
Quantize
Allows you to access the main quantize parameters. These are identical with the
functions on the Quantize panel.
Transpose
Allows you to access the main parameters for transposing MIDI events.
Length
Contains length-related options, similar to the Functions submenu of the MIDI
menu.
●

To change the length of the selected MIDI events or all events of the active
part if no events are selected, use the Scale Length/Scale Legato slider.
At the maximum value, the notes reach the beginning of the next note.

●

To make the new length settings permanent, click Freeze MIDI Lengths to the
right of the Scale Length/Scale Legato slider.

●

To fine-tune the distance between consecutive notes, use the Overlap slider.
At 0 Ticks, the Scale Length/Scale Legato slider extends each note so that it
reaches the next note exactly. Positive values cause the notes to overlap and
negative values allow you to define a small gap between the notes.

●

To use the Legato function or slider to extend a note until the next selected
note, activate Between Selected.
This is identical with activating the Legato Mode: Between Selected Notes
Only option in the Preferences dialog.

Setup
Allows you to open a dialog to edit the Inspector settings for the editor. Click Setup
Inspector , and from the pop-up menu, select Setup.
NOTE
These sections are also featured by the Inspector for the editor in the lower zone.

RELATED LINKS
Expression Maps on page 871
Note Expression Inspector Section on page 884
Quantize Panel on page 291
Transpose Functions on page 326
Opening the Editor Inspector on page 55
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Note Display
The note display is the main area in the Key Editor. It contains a grid in which note events are
shown as boxes.

The width of a box corresponds to the note length. The vertical position of a box corresponds to
the note number (pitch), with higher note events higher up in the grid. The piano keyboard helps
you to find the right note number.

Controller Display
The area at the bottom of the Key Editor window is the controller display. It contains the
controller events.
To show or hide the controller display, click Set up Window Layout on the toolbar, and activate
or deactivate Controller Lanes.
The on/off status of the controller lanes in the Key Editor window and in the lower zone editor
are independent of each other.
The controller display consists of one or several controller lanes that show one of the following
properties or event types:
●

Velocity values of the notes

●

Pitchbend events

●

Aftertouch events

●

Poly Pressure events

●

Program Change events

●

System Exclusive events

●

Articulations and Dynamics

●

Any type of continuous controller event

Velocity values are shown as vertical bars in the controller display. Each velocity bar corresponds
to a note event in the note display. Higher bars correspond to higher velocity values.

814

MIDI Editors
Key Editor Operations

Events other than velocity values are shown as blocks. The block corresponds to the event values.
The beginning of an event is marked by a curve point.
NOTE
Unlike note events, controller events have no length. The value of a controller event in the
display is valid until the beginning of the next controller event.

Key Editor Operations
This section describes the principal editing operations within the Key Editor.

Inserting Note Events with the Object Selection Tool
You can insert note events with the Object Selection tool.
PREREQUISITE
You have set up the length for the note events quantize value in the Length Quantize pop-up
menu of the toolbar.
PROCEDURE
●

In the note display, double-click with the Object Selection tool at the position where you
want to insert a note.

RESULT
A note is inserted at the position where you double-clicked with the length that you have set up
in the Length Quantize pop-up menu.

Drawing Note Events with the Draw Tool
The Draw tool allows you to insert single note events in the note display.
When you move the cursor inside the note display, its position is indicated on the status line. Its
pitch is indicated both on the status line and on the piano keyboard to the left.

815

MIDI Editors
Key Editor Operations

●

To draw a note, click in the note display.
The note event has the length that is set on the Length Quantize pop-up menu.

●

To draw longer note events, click and drag in the note display.
The length of the note event is a multiple of the Length Quantize value. If Length
Quantize is set to Quantize Link, the note value is determined by the quantize grid. The
Snap function is taken into account.

NOTE
To temporarily switch from the Object Selection tool to the Draw tool, hold down Alt.

Modifying Note Values while Inserting Notes
When inserting note events, you can modify specific note values on the fly.
●

To edit the note velocity, drag upwards or downwards.

●

To edit the note pitch, hold down Alt and drag upwards or downwards.

●

To edit the note length, drag to the left or to the right.

●

To edit the time position, hold down Shift and drag to the left or to the right.

NOTE
You can activate/deactivate Snap temporarily by holding down Ctrl/Cmd.

Drawing Note Events with the Line Tool
In the note display, the Line tool allows you to draw a series of contiguous note events along
different line shapes.
●

To create contiguous note events, click and drag in the note display.

●

To restrict movement to horizontal, press Ctrl/Cmd and drag.
The notes have the same pitch.

If Snap is activated, the note events and controller events are positioned and sized according to
the Quantize and Length Quantize values.
RELATED LINKS
The Line Tool Modes on page 817
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The Line Tool Modes
The Line tool allows you to create a series of contiguous note events along different line shapes.
You can also edit multiple controller events simultaneously.
To select a different line mode, click Line and select a mode from the menu.

The following line modes are available:
Line
If this option is activated, you can click and drag to insert note events in the note
display along a straight line in any angle. Use this option to edit controller data along
a straight line in the controller display.
Parabola, Sine, Triangle, Square
These modes insert note events along different curve shapes.
Paint
This mode allows you to insert note events by painting in the note display.

Moving and Transposing Note Events
There are several options to move and transpose note events.
●

To move note events in the editor, select the Object Selection tool and drag them to a
new position.
All selected note events are moved, maintaining their relative positions. Snap is taken into
account.

●

To allow only horizontal or only vertical movement, hold down Ctrl/Cmd while dragging.

●

To move note events via the Nudge Palette buttons on the toolbar, select the note events
and click a Nudge Palette button.
This moves the selected note events by the Snap value in the drum sound list.

●

To move note events to the project cursor position, select the note events and select Edit >
Move to > Cursor.

●

To move a note event via the info line, select a note event and edit the Position or Pitch on
the info line.

●

To transpose note events, select the note events and use the Transpose Palette buttons
on the toolbar or the Up Arrow/Down Arrow keys.
Transpose is also affected by the global transpose setting.

●

To transpose note events via the Transpose Setup dialog, select the note events and
select MIDI > Transpose Setup.

●

To transpose note events in steps of one octave, press Shift and use the Up Arrow/Down
Arrow keys.

NOTE
●

When you move selected note events to a different position, any selected controllers for
these note events move accordingly.

●

You can also adjust the position of note events by quantizing.
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RELATED LINKS
Transpose Setup on page 785

Resizing Note Events
Do one of the following:
●

To resize the note event, position the Object Selection tool at the start or the end of a
note event and drag the mouse cursor to the left or right.

●

To apply time-stretching and Note Expression data to a controller that is associated with
the note event that you resize, activate Sizing Applies Time Stretch for the Object
Selection tool before you resize the note.

●

To move the start or end positions of the selected notes in steps according to the Length
Quantize value on the toolbar, use the Trim Start/End buttons on the Nudge palette.

●

Select the note and adjust its length on the info line.

●

Select Draw

and drag left or right within the note display to draw a note.

The resulting note event length is a multiple of the Length Quantize value on the toolbar.
●

Select Trim

and cut off the end or the beginning of note events.

RELATED LINKS
Using the Setup Options on page 1161
Editing on the Info Line on page 50
Using the Trim Tool on page 818
Resizing Events with the Object Selection Tool - Sizing Applies Time Stretch on page 210

Using the Trim Tool
The Trim tool allows you to change the length of note events by cutting off the end or the
beginning of notes. Using the Trim tool means moving the note-on or the note-off event for one
or several notes to a position defined with the mouse.
PROCEDURE
1.

Select Trim

on the toolbar.

The mouse pointer changes to a knife symbol.
2.

To edit a single note, click on it with Trim

.

The range between the mouse pointer and the end of the note will be removed. Use the
mouse note info on the status line to find the exact position for the trim operation.
3.

To edit several notes, click and drag with the mouse across the notes.

By default, the Trim tool cuts off the end of notes. To trim the beginning of notes, press Alt
while dragging. When dragged across several notes, a line is displayed. The notes will be
trimmed along this line. If you press Ctrl/Cmd while dragging, you will get a vertical trim
line, allowing you to set the same start or end time for all edited notes. You can change the
Trim tool key commands in the Preferences dialog (Editing—Tool Modifiers page).
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Splitting Note Events
●

To split the note at the position that you point, click on a note with Split

.

If several notes are selected, they are all split at the same position. The snap setting is
taken into account.
●

To split all notes that are intersected by the project cursor position, select Edit >
Functions > Split at Cursor.

●

To split all notes that are intersected by the left or right locator at the locator positions,
select Edit > Functions > Split Loop.

Gluing Note Events
You can glue together note events of the same pitch.
●

To glue note events, select Glue

and click on a note event.

The note event is glued together with the next note event of the same pitch. The result is a
long note event that spans from the start of the first note to the end of the second note.
The properties (velocity, pitch, etc.) of the first note event apply.

Changing the Pitch of Chords
You can use the chord type buttons to change the pitch of chords.
PROCEDURE
1.

In the Inspector, open the Chord Editing section.

2.

In the note display, select the notes that you want to edit.
If the chord is recognized, the root note, chord type, and tensions are indicated in the
Chord Type field. This also works with arpeggiated notes.

3.

In the Chord Editing section, activate one of the Triads buttons or 4-Note Chords
buttons.
The selected notes are transposed so that they fit the selected chord type.

4.

Use the Up Arrow/Down Arrow keys to change the pitch of the chord.

Changing the Voicing of Chords
PROCEDURE
1.

In the Inspector, open the Chord Editing section.

2.

In the note display, select the notes that you want to edit.

3.

In the Chord Editing section, use the Inversions buttons and the Drop Notes buttons to
change the voicing.

RESULT
The selected notes are transposed so that they fit the selected chord type.
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Chord Editing Section
The Chord Editing section in the Inspector allows you to insert and edit chords, and change
voicings.

Chord Type
Shows the chord type of the selected chords.
Add to Chord Track
Adds the chord indicated in the Chord Type field to the chord track. The chord event
is inserted at the position on the chord track that corresponds to the position of the
MIDI notes. Any existing chord events at this position are overwritten.
Match with Chord Track
Applies the chord events from the chord track to the selected notes in the MIDI
editor. The chord event that is effective at the position of the first selected note is
applied to the selected notes, which are then transposed. Only the basic chord type
is applied. Tensions are not taken into account.
Only the first effective chord event is applied.
Triads
Allows you to insert triads to the note display. You can also click one of the Triads
buttons to transpose the selected notes so that they fit to the selected chord type.
4-Note Chords
Allows you to insert 4-note chords to the note display. You can also click one of the 4Note Chords buttons to transpose the selected notes so that they fit to the selected
chord type.
Inversions - Move highest note to bottom
Inverts the highest note of a chord. The corresponding notes are transposed by as
many octaves as needed.
Inversions - Move lowest note to top
Inverts the lowest note of a chord. The corresponding notes are transposed by as
many octaves as needed.
Drop Notes - Move the second highest note an octave lower
Moves the second highest note of a chord down by one octave.
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Drop Notes - Move the third highest note an octave lower
Moves the third highest note of a chord down by one octave.
Drop Notes - Move the second and fourth highest notes an octave lower
Moves the second and fourth highest notes of a chord down by one octave.
Create Chord Symbols
Performs a chord analysis of the selected notes. If nothing is selected, the whole
MIDI part is analyzed.

Inserting Chords
You can use the tools in the Chord Editing section of the Inspector to insert and edit chords.
PROCEDURE
1.

In the Inspector, open the Chord Editing section.

2.

Select the Insert tool

3.

Click in the note display and drag to the left or right to determine the length of the chord.
Drag up or down to determine its pitch.

to the right of the chord type that you want to insert.

To change the chord type while you insert chords, hold Alt and drag up or down.
If Acoustic Feedback is activated, you hear the chord while dragging. A tooltip indicates
the root note and chord type of the inserted chord. Snap and Length Quantize are taken
into account.

Applying Chord Events to Note Events
You can apply chord events from the chord track to notes in the MIDI editor.
PREREQUISITE
Create a chord track and add chord events.
PROCEDURE
1.

Open the MIDI editor.

2.

In the Inspector, open the Chord Editing section.

3.

Select Match with Chord Track.

RESULT
The first chord event of the chord track is applied to the selected notes. Only the basic chord type
is applied. Tensions are not taken into account.

Drum Map Handling
When a drum map is assigned to a MIDI or instrument track, the Key Editor displays the drum
sound names as defined by the drum map. This allows you to use the Key Editor for drum
editing, for example, when editing drum note lengths or when editing several parts to identify
drum events.
The name of the drum sound is displayed in the following locations:
●

On the info line in the Pitch field.

●

On the status line in the Mouse Note Position field.
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●

In the note event if the zoom factor is high enough.

●

When dragging a note event.

Expression Map Handling
When an expression map is assigned to a MIDI track, the musical articulations that are defined
for that map are displayed in the following locations of the Key Editor:
●

On the info line in the Articulations field.

●

On the controller lane.

●

In the note event if the vertical zoom factor is high enough.

Note Expression Data
The Key Editor is the main editor for working with Note Expression.
RELATED LINKS
Expression Maps on page 871

Editing Note Events via MIDI Input
You can directly hear your editing results. Editing the properties of note events via MIDI can be a
quick way to, for example, set the velocity value of a note event.
PROCEDURE
1.

In the Key Editor, select the note event that you want to edit.

2.

Click MIDI Input

on the toolbar.

Editing via MIDI is enabled.
3.

Use the note buttons on the toolbar to decide which properties are changed by the MIDI
input.
You can enable editing of pitch, note-on and/or note-off velocity. For example, with the
following setting, the edited notes get the pitch and velocity values of the notes input via
MIDI, but the note-off velocities remain as they are.

4.

Play a note on your MIDI instrument.

RESULT
The selected note gets the pitch, note-on velocity and/or note-off velocity of the played note. The
next note in the edited part is automatically selected to allow quick editing of a series of notes.
AFTER COMPLETING THIS TASK
To try another setting, select the note again and play a note on your MIDI instrument.

Step Input
Step input, or step recording, allows you to enter note events or chords one at a time without
worrying about the exact timing. This is useful, for example, when you know the part that you
want to record but are not able to play it exactly as you want it.
PROCEDURE
1.

On the toolbar, activate Step Input .

2.

Use the note buttons to the right to determine which properties are included when you
insert the note events.
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For example, you can include the note-on velocity and/or note-off velocity of the played
notes. You can also deactivate the pitch property, in which case all notes get a pitch C3, no
matter what you play.
3.

Click anywhere in the note display to set the start position of the first note event or chord.
The step input position is shown as a vertical line in the note display.

4.

Specify the note event spacing and length with the Quantize and Length Quantize popup menus.
The note events that you insert are positioned according to the Quantize value and have
the length of the Length Quantize value.
NOTE
If Length Quantize is set to Quantize Link, the note length is also determined by the
Quantize value.

5.

Play the first note event or chord on your MIDI instrument.
The note event or chord appears in the editor and the step input position advances by one
quantize value step.
NOTE
If Move Insert Mode is activated, all note events to the right of the step input position are
moved to make room for the inserted note event or chord.

6.

Continue in the same way with the rest of the note events or chords.
You can adjust the Quantize or Length Quantize values to change the timing or note
event lengths. You can also move the step input position manually by clicking anywhere in
the note display.
To insert a rest, press the Right Arrow key. This advances the step input position by one
step.

7.

When you are done, click Step Input again to deactivate step input.

Using the Controller Display
The Controller Display displays the controller events. By default, the controller display has a
single lane that shows one event type at a time. However, you can add as many lanes as you
need. The use of several controller lanes allows you to view and edit different controllers at the
same time.
Each MIDI track has its own controller lane setup (number of lanes and selected event types).
When you create new tracks, they get the last used controller lane setup.
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The controller display with lanes.

●

To add a controller lane, click Create Controller Lane
or open the Controller Selection
and Functions menu and select Create Controller Lane.

●

To remove a controller lane, open the Controller Selection and Functions pop-up menu
and select Remove this Lane.
This hides the lane from view. It does not affect the events in any way.
If you remove all lanes, the controller display is hidden. To bring it back, click Create
Controller Lane.

●

To show/hide multiple lanes, open the Controller Lane Setup pop-up menu, and select
Show/Hide Controller Lanes.

●

To reset the controller display to show only the velocity lane, open the Controller Lane
Setup pop-up menu, and select Velocity Only.

●

To automatically show all controller lanes with controller data, open the Controller Lane
Setup pop-up menu, and select Show Used Controllers.

Selecting the Controller Event Type
Each controller lane shows one event type at a time. You can select which event type to display
on a controller lane.
●

To select which type is displayed, open the Controller Selection and Functions pop-up
menu and select an event type.
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Setting up Available Continuous Controllers
In the MIDI Controller Setup dialog, you can specify which continuous controllers are available
for selection.
NOTE
The MIDI Controller Setup dialog can be opened from different areas in the program. The
settings are global, that is, the setup you choose here affects all areas of the program where
MIDI controllers can be selected.

PROCEDURE
1.

Select Controller Selection and Functions > Setup.

2.

In the MIDI Controller Setup dialog, move all the controllers that you need to the list on
the left and move the controllers that you do not need to the list on the right.

3.

Click OK.

Handling Controller Lane Presets
Once you have made up your controller lane setup, you can save it as a controller lane preset.
For example, you can have a preset with one velocity lane and another preset with a combination
of several controller lanes, such as velocity, pitchbend, or modulation.

Saving a Controller Lane Setup as Preset
You can save a controller lane setup via the Controller Lane Setup pop-up menu.
PROCEDURE
1.

Click Controller Lane Setup

.

2.

Select Add Preset.

3.

In the Type In Preset Name dialog, enter a name for the preset.

4.

Click OK.

RESULT
Your controller lane setup is now available as a controller lane preset.
NOTE
To apply a saved preset, open the Controller Lane Setup pop-up menu and select the preset.
NOTE
To remove or rename a preset, open the Controller Lane Setup pop-up menu and select
Organize Presets. A dialog opens, where you can remove and rename presets.

Adding Events in the Controller Display
●

To create a new event in the velocity controller display, click with the Draw tool or the Line
tool in the event display.

●

To create a new event for any other event type, click with the Draw tool or the Line tool in
the controller display.
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NOTE
In the Key Editor, you can also add modulation controller events (CC1) by copying note events
from the event display and pasting them on the controller lane.

Editing Events in the Controller Display
All controller values can be edited with the Draw tool or the Line tool. If you have selected more
than one controller event on a controller lane, the controller lane editor is displayed.
●

To edit events in the velocity controller display, use the Draw tool or the Line tool and drag
the event.

The Object Selection tool automatically switches to the Draw tool when you move the
pointer into the controller display.
When you move the pointer in the controller lane, the corresponding event type value is
displayed below the event type name.
In velocity mode, no new controller events are added this way.
●

To edit the values of any other event type in the controller display, press Alt and drag, or
use the Draw tool or the Line tool and drag.

When you move the pointer inside a controller lane, the event type value changes
corresponding to the pointer movement. The event type value is displayed below the event
type name, left of the controller display.
●

If there is more than one note at the same position, their velocity bars overlap on the
controller lane. If none of the notes are selected, all notes at the same position are set to
the same velocity value when you draw.
To edit the velocity of only one of the notes at the same position, first select the note in the
note display.

●

To select all events on a controller lane, open the Controller Lane Setup pop-up menu
and select the Select all Controller Events option.

●

To use the Object Selection tool to select events in the velocity controller display, press
Alt.

●

To cut, copy, and paste events in the controller display select the event and select Edit >
Cut/Copy/Paste.
When pasting events, the events on the clipboard are added, starting at the project cursor
position and maintaining their relative distances. If a pasted event ends up at the same
position as an existing event of the same type, the old event is replaced.

NOTE
If the speaker icon (Acoustic Feedback) is activated on the toolbar, the notes are played back
when you adjust the velocity. This allows you to audition your changes.

RELATED LINKS
Controller Event Editor on page 831
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Editing Events in the Controller Display Using the Line Tool
You can draw and edit events in the controller display with the Line tool.

Line Mode
In Line mode, you can draw events in a straight line.
●

To draw a straight line in the controller display, click where you want the ramp to start and
drag the cursor to where you want the ramp to end.

NOTE
If Snap is activated, the Length Quantize value determines the density of created controller
curves. For very smooth curves, use a small Length Quantize value or deactivate Snap. To avoid
over-dense controller curves, which can cause MIDI playback to stutter, use a medium-low
density.

Parabola Mode
In Parabola mode, you can draw events on a parabola curve. This gives more natural curves and
fades. The result depends on the direction from which you draw the parabola.

You can use modifier keys to determine the shape of the parabola curve.
●

To reverse the parabola curve, press Ctrl/Cmd.

●

To change the position of the whole curve, press Alt.

●

To increase or decrease the exponent, press Shift.

NOTE
If Snap is activated, the Length Quantize value determines the density of created controller
curves. For very smooth curves, use a small Length Quantize value or deactivate Snap. To avoid
over-dense controller curves, which can cause MIDI playback to stutter, use a medium-low
density.

Sine, Triangle, and Square Mode
The Sine, Triangle, and Square modes create events with values that are aligned with
continuous curves.

In these modes, the quantize value determines the period of the curve that is the length of one
curve cycle and the Length Quantize value determines the density of the events. The lower the
Length Quantize note value becomes, the smoother the curve gets.
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NOTE
If Length Quantize is set to Quantize Link and you enter data in Sine, Triangle or Square
mode, the density of the events depends on the zoom factor.
You can use modifier keys to determine the shape of the curve.
●

To change the phase of the beginning of the curve, press Ctrl/Cmd.

●

To change the position of the whole curve, press Alt-Ctrl/Cmd.

●

To change the maximum position of the triangle curve or the pulse of the square curve in
Triangle and Square mode, press Shift-Ctrl/Cmd. This creates sawtooth curves.

●

You can also set the curve period freely by holding down Shift when you insert events in
Sine, Triangle, or Square mode. Activate Snap, Shift-click and drag to set the length of
one period. The period length will be a multiple of the quantize value.

Paint Mode
In Paint mode, you can draw in multiple notes.
The quantize value determines the density of created controller curves. For very smooth curves,
use a small quantize value or deactivate Snap. However, this creates a large number of MIDI
events, which can cause MIDI playback to stutter in some situations. A medium-low density is
often sufficient.

Editing Events using the Draw Tool
You can draw and edit events in the controller display with the Draw tool. The Draw tool has the
same functionality as the Line tool in Paint mode.
●

To change the velocity of a single note, click on its velocity bar and drag the bar up or
down.
NOTE
When you move the pointer inside a controller lane, the event type value changes
corresponding to the pointer movement. The event type value is displayed below the event
type name, left of the controller display.

Editing Articulations
You can add and edit musical expressions or articulations in the controller lane.
RELATED LINKS
Expression Maps on page 871

Editing Dynamics
Provided that the dynamics mapping is set up and activated for the track, you can insert 12
dynamics symbols in the lower part of the Articulations/Dynamics lane.
●

To insert a dynamics symbol, click in the controller lane with the Draw tool.
A mezzo forte symbol is inserted.

●

To select another dynamics symbol for an event, click on the triangle in the upper left
corner of the event and select a symbol from the pop-up menu.
If several events are selected, the same symbol is applied to all events.
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●

To step through the available dynamics symbols, use the mouse wheel or the One down
and One up key commands.
If several events are selected, they all change in increments, that is, relative to the original
values.

●

To modify the settings for the dynamics symbols, open the Controller Selection and
Functions pop-up menu and select Dynamics Mapping Setup.

Moving and copying dynamics events is identical to working with other events on the controller
lane.
RELATED LINKS
Moving Events in the Controller Display on page 832

Using Continuous Controllers
When a continuous controller is selected for a controller lane, additional data is displayed on the
controller lane. This is due to the fact that MIDI controller data can be recorded or entered either
for an automation track or for a MIDI part.
If automation data already exists for a controller, this is indicated by an asterisk that is displayed
next to the controller name on the Controller Selection and Functions pop-up menu.

If the automation data is controller data that you have entered in a MIDI editor, the data is
displayed on the controller lane. If the controller data was recorded on an automation track in
the Project window, no events are displayed on the controller lane.
If conflicting controller data exists in different places, you can specify what happens on playback
by making settings for the automation merge mode. The resulting curve is displayed in addition
to the curve that you entered on the controller lane.
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1

The controller curve before the part starts. This curve depends on the existing controller
data and on the selected merge mode.

2

Controller curve entered on the controller lane.

3

Resulting controller curve if controller automation was also recorded on a track. These
values depend on the selected automation merge mode.

On the controller lane, you can also see the controller curve that is applied before the part starts.
This tells you which controller value is being used at the starting point of the part so that you can
choose the start value accordingly.
The start value also depends on the automation merge mode.
RELATED LINKS
MIDI Controller Automation on page 721
Automation Merge Modes on page 721

Poly Pressure Events
Poly Pressure events are events that belong to a specific note number (key). That is, each Poly
Pressure event has the following editable values: the note number and the amount of pressure.
When Poly Pressure is selected on the Controller Selection and Functions pop-up menu, value
fields for the note number and for the amount are shown to the left of the controller display.

Adding Poly Pressure Events
PROCEDURE
1.

Open the Controller Selection and Functions pop-up menu and select Poly Pressure.

2.

Click on the keyboard display to set the note number.
The selected note number is displayed in the upper value field to the left of the controller
display.
NOTE
This only works for the topmost lane. If you have selected Poly Pressure for several
controller lanes, you have to type in the note number directly in the lower value field to the
left of each lane.

3.

Use the Draw tool to add a new event.

Editing Poly Pressure Events
PROCEDURE
1.

Open the Controller Selection and Functions pop-up menu and select Poly Pressure.

2.

Click the arrow button next to the note number to the left of the controller lane.
A pop-up menu appears and lists all note numbers for which there already are Poly
Pressure events.

3.

Select a note number from the pop-up menu.
The Poly Pressure events for the selected note number are shown in the controller lane.

4.

Use the Draw tool to edit the events.
To edit events without adding new events, press Ctrl/Cmd+Alt while drawing.
Poly Pressure events can also be added and edited in the List Editor.
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Controller Event Editor
The controller event editor allows you to perform additional scaling operations for selection
ranges on existing controller curves.
●

To open the controller event editor, activate the Object Selection tool and drag a selection
rectangle on the controller lane.

The controller event editor features the following smart controls for specific editing modes:

1

Tilt Left
If you click in the upper left corner of the editor, you can tilt the left part of the curve. This
allows you to tilt the event values at the start of the curve upwards or downwards.

2

Compress Left
If you Alt-click in the upper left corner of the editor, you can compress or expand the left
part of the curve. This allows you to compress or expand the event values at the start of
the curve.

3

Scale Vertically
If you click in the middle of the upper border of the editor, you can scale the curve
vertically. This allows you to raise or lower the event values of the curve in percent.

4

Move Vertically
If you click on the upper border of the editor, you can move the entire curve vertically. This
allows you to raise or lower the values of the event values of the curve.

5

Compress Right
If you Alt-click in the upper right corner of the editor, you can compress or expand the
right part of the curve. This allows you to compress or expand the event values at the end
of the curve.

6

Tilt Right
If you click in the upper right corner of the editor, you can tilt the right part of the curve.
This allows you to tilt the event values at the end of the curve upwards or downwards.

7

Scale Around Relative Center
If you Alt-click in the middle right border of the editor, you can scale the curve relative to
its center. This allows you to raise or lower the event values horizontally around the center
of the editor.

8

Scale Around Absolute Center
If you click in the middle right corner of the editor, you can scale the curve absolute to its
center. This allows you to raise or lower the event values horizontally around the center of
the editor.

9

Stretch
If you click on the lower border of the editor, you can stretch the curve horizontally. This
allows you to move the event values of the curve to the left or to the right.
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Editing Selection Ranges
The controller lane editor allows you to perform additional scaling operations for selection
ranges on existing controller curves.
●

To open the controller lane editor, use the Object Selection tool to create a selection
rectangle on the controller lane, encompassing the controller events that you want to edit.
For velocity lanes, press Alt to get the Object Selection tool.
NOTE
●

The controller lane editor is not available for Articulation or Dynamics lanes.

●

For velocity lanes, the editor also opens if you select multiple MIDI notes in the note
display.

●

To switch the controller lane editor to vertical scaling mode, press Shift and click on any of
the smart controls.

●

To move the whole selection up/down or left/right, click on a controller event inside the
editor and drag the curve.

●

To restrict the direction to horizontal or vertical movement, depending on the direction in
which you start dragging, press Ctrl/Cmd when dragging.
NOTE
Snap is taken into account when moving controller curves horizontally.

Moving Events in the Controller Display
You can move events in a controller lane.
PROCEDURE
1.

Select the events that you want to move with the Object Selection tool.
You can also click and drag to create a selection rectangle that encompasses the events
that you want to move.

2.

Click on a curve point inside the selection and drag the events.

RESULT
The events inside the selection are moved to the new position. Snap is taken into account.
NOTE
If Auto Select Controllers is activated on the Key Editor toolbar, selecting notes also selects the
corresponding controller events. Moving events in the note display also moves the
corresponding controller events.

RELATED LINKS
Selecting Controllers within the Note Range on page 833

Deleting Events in the Controller Display
IMPORTANT
If there is more than one note at the same position, there is only one visible velocity bar. Make
sure that you delete only the notes that you want to delete.
●

To delete events, click on them with the Erase tool or select them and press Backspace.
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You can also delete notes by deleting their velocity bars in the controller display.
If there is more than one note at the same position, there may still only be one velocity bar
visible. Make sure that you delete only the desired notes!

Selecting Controllers within the Note Range
A note range lasts until the start of the next note or the end of the part. Selected controllers for
notes are moved when the corresponding notes are moved.
You can select the controllers within the range of the selected notes.
●

To always select the corresponding controllers when you select a note event, activate Auto
Select Controllers .

●

To select the controllers within the note range, select Edit > Select > Select Controllers in
Note Range.
For this to work, only 2 notes have to be selected.

Drum Editor
The Drum Editor is the editor to use when you are editing drum or percussion parts.
You can open the Drum Editor in a separate window or in the lower zone of the Project window.
Opening the Drum Editor in the lower zone of the Project window is useful if you want to access
the Drum Editor functions from within a fixed zone of the Project window.
To open a MIDI part in the Drum Editor, do one of the following:
●

Select a MIDI part in the Project window and select MIDI > Open Drum Editor.

If the MIDI track has a drum map assigned and Editor Content Follows Event Selection and
Use Drum Editor when Drum Map is assigned are activated in the Preferences dialog (Editors
page), you can do the following to open a MIDI part in the Drum Editor:
●

Double-click a MIDI part in the Project window.

●

Select a MIDI part in the Project window and press Return or Ctrl/Cmd-E.

●

Select a MIDI part in the Project window and select MIDI > Open Drum Editor.

●

In the Key Commands dialog in the Editors category, assign a key command for Open
Drum Editor. Select a MIDI part in the Project window and use the key command.

NOTE
If you select MIDI > Set up Editor Preferences, the Preferences dialog opens on the Editors
page. Make your settings to specify if you want the Drum Editor to open in a separate window or
in the lower zone of the Project window.
The Drum Editor window:
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The Drum Editor in the lower zone of the Project window:
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The Drum Editor is divided into several sections:
1

Toolbar
Contains tools and settings.

2

Status line
Informs about the mouse time position and the mouse note position.

3

Info line
Displays information about the selected event.

4

Inspector
Contains tools and functions for working with MIDI data.

5

Drum sound list
Lists all drum sounds.

6

Drum map
Lets you select the drum map for the edited track or a list of drum sound names.

7

Ruler
Displays the time line.

8

Note display
Contains a grid in which notes are displayed.

9

Controller display
The area below the note display consists of one or multiple controller lanes.
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NOTE
You can activate/deactivate the status line, the info line, and the controller lanes by clicking Set
up Window Layout on the toolbar and activating/deactivating the corresponding options.

Toolbar
The toolbar contains tools and various settings for the Drum Editor.
●

To show or hide the toolbar elements, right-click the toolbar and activate or deactivate the
elements.

Static Buttons
Solo Instrument (Requires Drum Map)
Solos the instrument during playback.
NOTE
This only works if there is a drum map assigned.
Solo Editor
Solos the editor during playback if the editor has the focus.
Record in Editor
Enables the recording of MIDI data in the editor if the editor has the focus.
NOTE
This only works if MIDI Record Mode is set to Merge or Replace.

Left Divider
Left Divider

Allows you to use the left divider. Tools that are placed to the left of the divider are
always shown.

Drum Sound Visibility
Drum Visibility Agents
Allows you to determine which drum sounds are displayed in the drum sound list.

Auto-Scroll
Link Project and Lower Zone Editor Cursors
Links timelines, cursors, and zoom factors of the lower zone editor and the Project
window.
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NOTE
You cannot activate Link Project and Lower Zone Editor Cursors if Independent
Track Loop is active.
Auto-Scroll
Keeps the project cursor visible during playback. The Switch Auto-Scroll Settings
pop-up menu allows you to activate Page Scroll or Stationary Cursor and to activate
Suspend Auto-Scroll when Editing.
Switch Auto-Scroll Settings
Allows you to specify the auto-scroll settings.

Tool Buttons
Object Selection
Allows you to select events.
Drumstick
Allows you to draw events.
Erase
Allows you to delete events.
Zoom
Allows you to zoom in/out. Hold Alt and click to zoom out.
Mute
Allows you to mute events.
Line
Allows you to create a series of contiguous events.
Time Warp
Allows you to drag a musical position to a certain position in time.

Acoustic Feedback
Acoustic Feedback
Automatically plays back events when you move or transpose them, or when you
create them by drawing.
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Auto Select Controllers
Auto Select Controllers
Automatically selects controller data of the selected MIDI notes.

Independent Track Loop
Independent Track Loop
Activates/Deactivates the independent track loop.
NOTE
If you activate Independent Track Loop, the Link Project and Lower Zone Editor Cursors
function is automatically deactivated in the lower zone editor.

Multiple Part Controls
Show Part Borders
Shows/Hides part borders for the active MIDI part within the left and right locators.
Edit Active Part Only
Restricts editing operations to the active part.
Currently Edited Part
Lists all parts that were selected when you opened the editor, and allows you to
activate a part.

Insert Velocity
Insert Velocity
Allows you to specify a velocity value for new notes.

Notes Length
Insert Length
Allows you to determine a length for newly created notes.
Show Note Length On/Off
Shows drum notes as boxes that display the note length.

Nudge Palette
Trim Start Left
Increases the length of the selected event by moving its start to the left.
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Trim Start Right
Decreases the length of the selected event by moving its start to the right.
Move Left
Moves the selected event to the left.
Move Right
Moves the selected event to the right.
Trim End Left
Decreases the length of the selected event by moving its end to the left.
Trim End Right
Increases the length of the selected event by moving its end to the right.

Transpose Palette
Move Up
Transposes the selected event up by a half note.
Move Down
Transposes the selected event down by a half note.
Move Up More
Transposes the selected event up by an octave.
Move Down More
Transposes the selected event down by an octave.

Snap
Snap On/Off
Activates/Deactivates the snap function.
Snap Type
Allows you to select one of the following snap types:
●

Grid snaps events to the grid that is selected in the Quantize Presets popup menu.

●

Grid Relative

●

Events

●

Shuffle changes the order of events if you drag one event to the left or right
of other events.

keeps the relative positions when snapping events to the grid.

snaps events to the start or end of other events.
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●

Magnetic Cursor

●

Grid + Cursor
snaps events to the quantize grid that is selected in the
Quantize Presets pop-up menu or to the cursor position.

snaps events to the cursor position.

●

Events + Cursor
cursor position.

●

Grid + Events + Cursor
snaps events to the quantize grid that is
selected in the Quantize Presets pop-up menu, to the start or end of other
events or to the cursor position.

snaps events to the start or end of other events or to the

Grid Type
Allows you to select one of the following grid types:
●

Use Quantize activates a grid where events snap to the value that is selected
in the Quantize Preset pop-up menu.

●

Adapt to Zoom activates a grid where events snap to the zoom level.

●

Use Snap from Drum Map activates a grid where events snap to the Snap
value that is selected in the drum map.

Quantize
Iterative Quantize On/Off
Activates/Deactivates iterative quantize.
Quantize Presets
Allows you to select a quantize or a groove preset.
Apply Quantize
Applies the quantize settings.
Open Quantize Panel
Opens the Quantize Panel.

Step/MIDI Input
Step Input
Activates/Deactivates MIDI step input.
MIDI Input/Note Expression MIDI Input
Activates/Deactivates MIDI input and note expression MIDI input.
Move Insert Mode
Moves all note events to the right of the step input position to the right to make
room for the inserted event when you insert notes.
NOTE
This only works if Step Input is activated.
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Record Pitch
Includes the pitch when you insert notes.
Record NoteOn Velocity
Includes the NoteOn velocity when you insert notes.
Record NoteOff Velocity
Includes the NoteOff velocity when you insert notes.

Event Colors
Event Colors
Allows you to select event colors.

Edit VST Instrument
Edit VST Instrument
Opens the VST Instrument that the track is routed to.

Right Divider
Right Divider

Allows you to use the right divider. Tools that are placed to the right of the divider
are always shown.

Window Zone Controls
Open in Separate Window
This button is available in the lower zone editor. It opens the editor in a separate
window.
Open in Lower Zone
This button is available in the editor window. It opens the editor in the lower zone of
the Project window.
Set up Window Layout
Allows you to set up the window layout.
Set up Toolbar
Opens a pop-up menu where you can set up which toolbar elements are visible.
RELATED LINKS
Zooming in MIDI Editors on page 798
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Status Line
The status line is displayed below the toolbar. It displays important mouse information.
To show or hide the status line, click Set up Window Layout on the toolbar, and activate or
deactivate Status Line.

The on/off status of the status line in the Drum Editor window and in the lower zone editor are
independent of each other.
Mouse Time Position
Displays the exact time position of the mouse pointer, depending on the selected
ruler display format. This lets you edit or insert notes at exact positions.
Mouse Note Position
Displays the exact pitch of the mouse pointer position. This facilitates finding the
right pitch when entering or transposing notes.
Track Loop Start/Track Loop End
If Independent Track Loop is activated on the toolbar and you set up a loop, the
start/end position is displayed.
RELATED LINKS
Toolbar on page 836

Info Line
The info line shows values and properties of the selected events. If several notes are selected, the
values for the first note are displayed in color.
To show or hide the info line, click Set up Window Layout on the toolbar, and activate or
deactivate Info Line.

Length and position values are displayed in the selected ruler display format.
The on/off status of the info line in the Drum Editor window and in the lower zone editor are
independent of each other.
RELATED LINKS
Editing Note Events on the Info Line on page 801

Drum Editor Inspector
The Inspector is located to the left of the note display. The inspector contains tools and functions
for working with MIDI data.
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Expression Map
Allows you to load an expression map. Expression maps are useful for working with
articulations.
Quantize
Allows you to access the main quantize parameters. These are identical with the
functions on the Quantize Panel.
Length
Contains length-related options, similar to the Functions submenu of the MIDI
menu.
●

To change the length of the selected MIDI events or all events of the active
part if no events are selected, use the Scale Length/Scale Legato slider.
At the maximum value the notes reach the beginning of the next note.

●

To make the new length settings permanent, click Freeze MIDI Lengths to the
right of the Scale Length/Scale Legato slider.

●

To fine-tune the distance between consecutive notes, use the Overlap slider.
At 0 Ticks, the Scale Length/Scale Legato slider extends each note so that it
reaches the next note exactly. Positive values cause the notes to overlap and
negative values allow you to define a small gap between the notes.

●

To use the Legato function or slider to extend a note until the next selected
note, activate Between Selected.
This is identical with activating the Legato Mode: Between Selected Notes
Only option in the Preferences dialog.

Setup
Allows you to open a dialog to edit the Inspector settings for the editor. Click Setup
Inspector , and from the pop-up menu, select Setup.
NOTE
These sections are also featured by the editor Inspector for the editor in the lower zone.

RELATED LINKS
Expression Maps on page 871
Note Expression Inspector Section on page 884
Quantize Panel on page 291
Transpose Functions on page 326
Opening the Editor Inspector on page 55

Note Display
The note display of the Drum Editor contains a grid in which note events are shown.

The notes are displayed as diamond symbols. If you activate Show Note Length On/Off on the
toolbar, notes are displayed as boxes and show the note length.
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The vertical position of the notes corresponds to the drum sound list to the left, while the
horizontal position corresponds to the note’s position in time.
RELATED LINKS
Toolbar on page 836

Controller Display
The area at the bottom of the Drum Editor window is the controller display.
It consists of one or several controller lanes that show one of the following properties or event
types:
●

Velocity values of the notes

●

Pitchbend events

●

Aftertouch events

●

Poly Pressure events

●

Program Change events

●

System Exclusive events

●

Articulations and Dynamics

●

Any type of continuous controller event

Velocity values are shown as vertical bars in the controller display. Each velocity bar corresponds
to a note in the note display. Higher bars correspond to higher velocity values.
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Events other than velocity values are shown as blocks. The block corresponds to the event values.
The beginning of an event is marked by a curve point.
When you select a line in the drum sound list, only the velocity controller events that belong to
the note events on this line are displayed in the controller display.
If you select more than one line in the drum sound list, the controller lane shows all velocity
controller events for all notes on the selected lines. This is useful when you have to adjust the
controller values between different drum sounds.
NOTE
Unlike note events, controller events have no length. The value of a controller event in the
display is valid until the beginning of the next controller event.

Drum Sound List
The drum sound list lists all drum sounds by name and allows you to adjust and manipulate the
drum sound setup in various ways.

NOTE
The number of columns in the list depends on whether a drum map is selected for the track or
not.
Pitch
Note number of the drum sound.
Instrument
Name of the drum sound.
Snap
This is used when entering and editing notes.
Mute
Allows you to mute drum sounds.
I-Note
Input note for the drum sound. When you play this note, it is mapped to the
corresponding drum sound and automatically transposed according to the Pitch
setting for the sound.
O-Note
The MIDI output note that is sent out every time the drum sound is played back.
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Chan
The MIDI channel, on which the drum sound is played back.
Output
MIDI output on which the drum sound is played back.
RELATED LINKS
Muting Notes and Drum Sounds on page 850
Drum Maps on page 850

Drum Sound Visibility
The Drum Visibility Agents on the drum editor toolbar allow you to determine which drum
sounds are shown in the drum sound list.

●

To open the visibility agents, click Drum Visibility Agents on the toolbar.

Show All Drum Sounds
Shows all drum sounds as defined in the selected drum map.
NOTE
In this mode, you can edit the order of the drum sound list manually.
Show Drum Sounds with Events
Shows only the drum sounds for which events are available in the selected MIDI part.
Show Drum Sounds in use by Instrument
Shows all drum sounds for which a pad etc. is in use for the instrument. This option
is only available if the instrument can provide this information.
Reverse Drum Sound List
Reverses the order of the sounds displayed in the drum sound list.

Drum Map and Names Menus
Below the drum sound list are pop-up menus that are used for selecting a drum map for the
edited track or, if no drum map is selected, a list of drum sound names.

RELATED LINKS
Drum Maps on page 850
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Drum Editor Operations
This section describes the general editing operations within the Drum Editor.

Inserting Note Events
You can insert note events with the Object Selection tool or the Drumstick tool.
PREREQUISITE
You have set up the Insert Length on the toolbar to determine the length of the inserted note. If
Insert Length is set to Drum-Map Link, the note gets the length of the Snap value set for the
sound in the drum sound list. You have activated Snap.
NOTE
If you want to snap positions according to the Quantize Presets setting on the toolbar, activate
Use Quantize.

PROCEDURE
●

Perform one of the following actions:
●

Select the Object Selection tool and double-click in the event display.

●

Select the Drumstick tool and click in the event display.

NOTE
To temporarily switch from the Object Selection tool to the Drumstick tool, hold down
Alt.

RESULT
A note event is inserted.

Inserting Multiple Note Events
You can insert multiple note events of the same pitch with the Object Selection tool or the
Drumstick tool.
PREREQUISITE
You have set up the Insert Length on the toolbar to determine the length of the inserted note. If
Insert Length is set to Drum-Map Link, the note gets the length of the Snap value set for the
sound in the drum sound list. You have activated Snap.
NOTE
If you want to snap positions according to the Quantize Presets setting on the toolbar, activate
Use Quantize.

PROCEDURE
●

Perform one of the following actions:
●

On the toolbar, select the Object Selection tool, double-click in the event display
and drag to the right.

●

On the toolbar, select the Drumstick tool, click in the event display and drag to the
right.

847

MIDI Editors
Drum Editor Operations
RESULT
The note events are inserted.
RELATED LINKS
Toolbar on page 836

Modifying Note Values While Inserting Notes
When inserting note events, you can modify specific note values on the fly.
●

To edit the note velocity, drag upwards or downwards.

●

To edit the note pitch, hold down Alt and drag upwards or downwards.

●

To edit the note length, drag to the left or to the right.
NOTE
If you want to edit the note length in the Drum Editor, you must deactivate Snap and
activate Show Note Length On/Off. Otherwise, the note is repeated.

●

To edit the time position, hold down Shift and drag to the left or to the right.

NOTE
You can activate/deactivate Snap temporarily by holding down Ctrl/Cmd.

Changing the Note Length
You can change the note length in the drum editor with the Object Selection tool or with the
Drumstick tool.
PREREQUISITE
You have activated Show Note Length On/Off on the drum editor toolbar.
PROCEDURE
1.

Move the mouse pointer to the beginning or the end of the note that you want to edit.
The mouse pointer turns into a double arrow.

2.

Drag to the left or to the right to adjust the length.
An info box with the current length value is displayed.

3.

Release the mouse button.

RESULT
The note length is changed. Snap is taken into account.

Deleting Note Events
PROCEDURE
●

Perform one of the following actions:
●

Select the Erase tool and click the event.

●

Select the Object Selection tool and double-click the event.

●

Select the Drumstick tool and click the event.
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RESULT
The note event is deleted.

Deleting Multiple Note Events
You can delete multiple note events of the same pitch with the Object Selection tool or the
Drumstick tool.
PREREQUISITE
To delete multiple note events with the Object Selection tool, Snap must be activated.
PROCEDURE
●

Do one of the following:
●

On the toolbar, select the Object Selection tool, double-click the first event you
want to delete, and drag to the right.

●

On the toolbar, select the Drumstick tool, click the first event you want to delete,
and drag to the right.

RESULT
The note events are deleted.

Moving and Transposing Note Events
There are several options to move and transpose note events.
●

To move note events in the editor, select the Object Selection tool and drag them to a
new position.
All selected note events are moved, maintaining their relative positions. Snap is taken into
account.

●

To allow only horizontal or only vertical movement, hold down Ctrl/Cmd while dragging.

●

To move note events via the Nudge Palette buttons on the toolbar, select the note events
and click a Nudge Palette button.
This moves the selected note events by the Snap value in the drum sound list.

●

To move note events to the project cursor position, select the note events and select Edit >
Move to > Cursor.

●

To move a note event via the info line, select a note event and edit the Position or Pitch on
the info line.

●

To transpose note events, select the note events and use the Transpose Palette buttons
on the toolbar or the Up Arrow/Down Arrow keys.
Transpose is also affected by the global transpose setting.

●

To transpose note events via the Transpose Setup dialog, select the note events and
select MIDI > Transpose Setup.

●

To transpose note events in steps of one octave, press Shift and use the Up Arrow/Down
Arrow keys.

NOTE
●

When you move selected note events to a different position, any selected controllers for
these note events move accordingly.

●

You can also adjust the position of note events by quantizing.
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RELATED LINKS
Transpose Setup on page 785

Muting Notes and Drum Sounds
IMPORTANT
The mute state for drum sounds is part of the drum map. All other tracks using this map are
affected.
●

To mute individual notes, click or enclose them with the Mute tool, or select Edit > Mute.

●

To mute a drum sound in a drum map, click in the Mute column for the drum sound.

●

To mute all other drum sounds, click Solo Instrument (Requires Drum Map) on the
toolbar.

RELATED LINKS
Selecting a Drum Map for a Track on page 853

Drum Maps
A drum kit in a MIDI instrument is most often a set of different drum sounds with each sound
placed on a separate key. For example, the different sounds are assigned to different MIDI note
numbers. One key plays a bass drum sound, another a snare, and so on.
Different MIDI instruments often use different key assignments. This can be troublesome if you
have made a drum pattern using one MIDI device and then want to try it on another. When you
switch devices, it is very likely that your snare drum becomes a ride cymbal or your hi-hat
becomes a tom, etc., because the drum sounds are distributed differently in the instruments.
To solve this problem and to simplify several aspects of MIDI drum kits, such as using drum
sounds from different instruments in the same drum kit, Nuendo features drum maps. A drum
map is a list of drum sounds with a number of settings for each sound. When you play back a
MIDI track for which you have selected a drum map, the MIDI notes are filtered through the
drum map before they are sent to the MIDI instrument. The map determines which MIDI note
number is sent out for each drum sound and which sound is played on the receiving MIDI device.
When you want to try your drum pattern on another instrument, you simply switch to the
corresponding drum map, and your snare drum sound remains a snare drum sound.
If you want to have the same drum maps included in your projects, you can load these into the
template.
NOTE
Drum maps are saved with the project files. If you have created or modified a drum map, use the
Save function to save it as a separate XML file to make it available for loading into other projects.

RELATED LINKS
Saving a Project Template File on page 88
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Drum Map Setup Dialog
This dialog allows you to load, create, modify, and save drum maps.
To open the Drum Map Setup dialog, select Drum Map Setup from the Map pop-up menu or
the MIDI menu.

The list on the left shows the loaded drum maps. The sounds and settings of the selected drum
map are displayed on the right.
NOTE
The settings for the drum sounds are the same as in the Drum Editor.
Use Head Pairs
If this option is activated, 2 head symbols for each drum sound are displayed in the
drum sound list.
Edit in Scores
If this option is activated, you can change the settings for the score drum map
directly in the score.
Output
Allows you to select the output for the drum map sounds.
Drum Sound List
Lists all drum sounds and their settings. To audition a drum sound, click the leftmost
column.
NOTE
If you audition a sound in the Drum Map Setup dialog and the sound is set to MIDI
output Default, the output that is selected on the Output pop-up menu in the lower
left corner is used. When auditioning a default output sound in the Drum Editor, the
MIDI output selected for the track is used.
The Functions pop-up menu contains the following options:
New Map
Adds a new drum map to the project. The drum sounds are named “Sound 1, Sound
2, etc.” and have all parameters set to default values. The map is named “Empty
Map”.
To rename the drum map, click the name in the list and type in a new name.
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New Copy
Adds a copy of the selected drum map to create a new drum map. You can then
change the drum sound settings of the copy and rename the drum map in the list.
Remove
Removes the selected drum map from the project.
Load
Allows you to load drum maps into your project.
Save
Allows you to save the drum map that is selected in the list on disk. Drum map files
have the extension .drm.
Edit head pairs
Allows you to customize the note pairs.
RELATED LINKS
Drum Map Settings on page 852
Channel and Output Settings on page 853

Drum Map Settings
A drum map consists of settings for 128 drum sounds, one for each MIDI note number.
●

To get an overview of the drum map settings, open the Drum Editor and use the Map
pop-up menu below the drum sound list to select the GM Map drum map.

The GM map is set up according to the General MIDI standard.
You can change all drum map settings except the pitch directly in the drum sound list or in the
Drum Map Setup dialog. These changes affect all tracks that use the drum map.
RELATED LINKS
Drum Sound List on page 845
Drum Map Setup Dialog on page 851

Importing Drum Maps from Virtual Instruments
You can import your drum map settings to an instrument track that is routed to Groove Agent SE.
PREREQUISITE
To import your drum map settings to an instrument track, the track has to be routed to Groove
Agent SE or another drum instrument that supports drum maps.
PROCEDURE
1.

Load a drum kit in Groove Agent SE.

2.

In the Inspector for the track, open the Drum Maps pop-up menu and select Create Drum
Map from Instrument.
The drum map is created for the kit that is assigned to the MIDI port and channel selected
in the Inspector.

3.

Open the Drum Maps pop-up menu again and select Drum Map Setup.
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4.

In the list on the left, select the kit that you have loaded in the instrument.

RESULT
The sounds and settings of the instrument are displayed in the Drum Map Setup.
NOTE
Instrument and pattern pads are both exported to the drum map. If they share keys, the pattern
pads get priority, that is, their settings are included in the drum map.

Channel and Output Settings
You can set separate MIDI channels and/or MIDI outputs for each sound in a drum map. When a
drum map is selected for a track, the MIDI channel settings in the drum map override the MIDI
channel setting for the track.
You can select different channels and/or outputs for different sounds. This allows you to
construct drum kits with sounds from several different MIDI devices, etc.
●

To make a drum sound use the channel of the track, set the channel in the drum map to
Any.

●

To make the sound use the MIDI output that is selected for the track, set the MIDI output
for a sound in a drum map to Default.

●

To send the sound to a specific MIDI output, select any other option.

●

To select the same MIDI channel or MIDI device for all sounds in a drum map, click in the
Channel column, press Ctrl/Cmd, and select a channel or output.

●

If you make specific MIDI channel and output settings for all sounds in a drum map, you
can switch between drum maps to send your drum tracks to another MIDI instrument.

Selecting a Drum Map for a Track
●

To select a drum map for a MIDI track, open the Map pop-up menu in the Inspector or in
the Drum Editor and select a drum map.

●

To deactivate the drum map functionality in the Drum Editor, open the Map pop-up menu
in the Inspector or in the Drum Editor and select No Drum Map.
Even if you do not use a drum map, you can still separate sounds by name using a name
list.

NOTE
Initially, the Map pop-up menu only contains GM Map.

I-Notes, O-Notes and Pitches
Going through the following theory helps you make the most out of the drum map concept –
especially if you want to create your own drum maps.
A drum map is a kind of filter that transforms notes according to the settings in the map. It does
this transformation twice; once when it receives an incoming note, that is when you play a note
on your MIDI controller, and once when a note is sent from the program to the MIDI sound
device.
The following example shows a modified drum map with a bass drum sound that has different
pitch, I-note, and O-note values.
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I-Notes (Input Notes)
When you play a note on your MIDI instrument, the program looks for this note number among
the I-notes in the drum map. If you play the note A1, the program finds that this is the I-note of
the bass drum sound.
This is where the first transformation happens: the note gets a new note number according to
the pitch setting for the drum sound. In our case, the note is transformed to a C1 note, because
that is the pitch of the bass drum sound. If you record the note, it is recorded as a C1 note.
For example, you can place drum sounds near each other on the keyboard so that they can be
easily played together, move sounds so that the most important sounds can be played from a
short keyboard, play a sound from a black key instead of a white. If you never play your drum
parts from a MIDI controller but draw them in the editor you do not need the I-note setting.

O-Notes (Output Notes)
The next step is the output. This is what happens when you play back the recorded note, or when
the note you play is sent back out to a MIDI instrument in real time (MIDI Thru):
The program checks the drum map and finds the drum sound with the pitch of the note. In our
case, this is a C1 note and the drum sound is the bass drum. Before the note is sent to the MIDI
output, the second transformation takes place: the note number is changed to that of the O-note
for the sound. In our example, the note sent to the MIDI instrument is a B0 note.
The O-note settings let you set things up so that the bass drum sound really plays a bass drum. If
you are using a MIDI instrument in which the bass drum sound is on the C2 key, you set the Onote for the bass drum sound to C2. When you switch to another instrument (in which the bass
drum is on C1) you want the bass drum O-note set to C1. Once you have set up drum maps for all
your MIDI instruments, you can select another drum map when you want to use another MIDI
instrument for drum sounds.

Setting Pitches of Notes According to their O-Note Settings
You can set the pitch of notes according to their O-note settings. This is useful if you want to
convert a track to a regular MIDI track with no drum map and still have the notes play back the
correct drum sound.
It is a typical use case to export your MIDI recording as a standard MIDI file. If you first perform
an O-note conversion, you make sure that your drum tracks play back as intended when they are
exported.
●

To perform an O-note conversion, select MIDI > O-Note Conversion.

RELATED LINKS
Exporting MIDI Tracks as Standard MIDI File on page 164

List Editor
The List Editor shows all events in the selected MIDI parts as a list, allowing you to view and edit
their properties numerically. It also allows you to edit SysEx messages.
●

To open a MIDI part in the List Editor, select a MIDI part in the Project window and select
MIDI > Open List Editor.
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The List Editor is divided into several sections:
1

Toolbar

2

Status line

3

Event list

4

Filters bar

5

Ruler

6

Event display

7

Value display

NOTE
The filters, the status line, and the value display can be activated/deactivated by clicking Set up
Window Layout on the toolbar and activating/deactivating the corresponding options.

Toolbar
The toolbar contains tools and various settings for the List Editor.
●

To show or hide the toolbar elements, right-click the toolbar and activate or deactivate the
elements.

Static Buttons
Solo Editor
Solos the editor during playback if the editor has the focus.
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Record in Editor
Enables the recording of MIDI data in the editor if the editor has the focus.
NOTE
This only works if MIDI Record Mode is set to Merge or Replace.

Auto-Scroll
Auto-Scroll
Keeps the project cursor visible during playback.
Switch Auto-Scroll Settings
Allows you to specify the auto-scroll settings.

Tool Buttons
Object Selection
Allows you to select events.
Draw
Allows you to draw events.
Erase
Allows you to delete events.
Zoom
Allows you to zoom in/out. Hold Alt and click to zoom out.
Mute
Allows you to mute events.
Trim
Allows you to trim events.

Acoustic Feedback
Acoustic Feedback
Automatically plays back events when you move or transpose them, or when you
create them by drawing.

Independent Track Loop
Independent Track Loop
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Activates/Deactivates the independent track loop.

Multiple Part Controls
Show Part Borders
Shows/Hides part borders for the active MIDI part within the left and right locators.
Edit Active Part Only
Restricts editing operations to the active part.
Currently Edited Part
Lists all parts that were selected when you opened the editor, and allows you to
activate a part.

Insert Type
Insert Event Type
Allows you to determine an event type for newly created events.

Insert Velocity
Insert Velocity
Allows you to specify a velocity value for new notes.

Nudge Palette
Trim Start Left
Increases the length of the selected event by moving its start to the left.
Trim Start Right
Decreases the length of the selected event by moving its start to the right.
Move Left
Moves the selected event to the left.
Move Right
Moves the selected event to the right.
Trim End Left
Decreases the length of the selected event by moving its end to the left.
Trim End Right
Increases the length of the selected event by moving its end to the right.
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Snap
Snap On/Off
Activates/Deactivates the snap function.
Snap Type
Allows you to select one of the following snap types:
●

Grid snaps events to the grid that is selected in the Quantize Presets popup menu.

●

Grid Relative

●

Events

●

Shuffle changes the order of events if you drag one event to the left or right
of other events.

●

Magnetic Cursor

●

Grid + Cursor
snaps events to the quantize grid that is selected in the
Quantize Presets pop-up menu or to the cursor position.

●

Events + Cursor
cursor position.

●

Grid + Events + Cursor
snaps events to the quantize grid that is
selected in the Quantize Presets pop-up menu, to the start or end of other
events or to the cursor position.

keeps the relative positions when snapping events to the grid.

snaps events to the start or end of other events.

snaps events to the cursor position.

snaps events to the start or end of other events or to the

Quantize
Iterative Quantize On/Off
Activates/Deactivates iterative quantize.
Quantize Presets
Allows you to select a quantize or a groove preset.
Apply Quantize
Applies the quantize settings.
Open Quantize Panel
Opens the Quantize Panel.

Length Quantize
Length Quantize
Allows you to set a value for quantizing event lengths.

Step/MIDI Input
Step Input
Activates/Deactivates MIDI step input.
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MIDI Input/Note Expression MIDI Input
Activates/Deactivates MIDI input and note expression MIDI input.
Move Insert Mode
Moves all note events to the right of the step input position to the right to make
room for the inserted event when you insert notes.
NOTE
This only works if Step Input is activated.
Record Pitch
Includes the pitch when you insert notes.
Record NoteOn Velocity
Includes the NoteOn velocity when you insert notes.
Record NoteOff Velocity
Includes the NoteOff velocity when you insert notes.

Event Colors
Event Colors
Allows you to select event colors.

Right Divider
Right Divider

Allows you to use the right divider. Tools that are placed to the right of the divider
are always shown.

Edit VST Instrument
Edit VST Instrument
Opens the VST Instrument that the track is routed to.

Window Zone Controls
Show/Hide Right Zone
Allows you to show/hide the right zone.
Set up Window Layout
Allows you to set up the window layout.
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Set up Toolbar
Opens a pop-up menu where you can set up which toolbar elements are visible.
RELATED LINKS
Using the Setup Options on page 1161

Status Line
The status line is displayed below the toolbar. It displays important information about the mouse
position.
To show or hide the info line, click Set up Window Layout on the toolbar, and activate or
deactivate Status Line.

The on/off status of the status line in the List Editor window and in the lower zone editor are
independent of each other.
Mouse Time Position
Displays the exact time position of the mouse pointer, depending on the selected
ruler display format. This allows you to edit or insert notes at exact positions.
Current Chord Display
When the project cursor is positioned over notes that form a chord, this chord is
displayed here.
Track Loop Start/End
If Independent Track Loop is activated on the toolbar, its start/end position are
displayed.
RELATED LINKS
Toolbar on page 836

Filters Bar
The filters bar allows you to hide events from view, based on their type and other properties.
To show or hide the status line, click Set up Window Layout on the toolbar, and activate or
deactivate Filters.

Show Section
The Show section allows you to set up filters.
No Focus
No filter is applied.
Event Types
Only events of the same event type as the selected type will be shown. This is the
same as activating event types in the Hide section.
Event Types and Data 1
Only events of the same event type as the selected type and with the same Data 1
value are shown. For example, if a note event is selected, only notes with the same
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pitch are shown. If a controller event is selected, only controllers of the same type
are shown.
Event Channels
Only events with the same MIDI channel value as the selected event are shown.
Presets
Allows you to use a preset.
Setup
Opens the Logical Editor. Here you can create complex filter settings.
When you apply any of the Logical Editor presets or use the Logical Editor to create
filter settings yourself, only the events that meet the specified criteria are visible.

Hide Section
The Hide section allows you to hide specific event types from view.
RELATED LINKS
Filtering the Event List on page 864
Logical Editor on page 943

Event List
The Event List lists all events in the selected MIDI parts, in the order in which they are played
back from top to bottom. The list allows you to perform detailed numerical editing of the event
properties.
The following options are available:
>
An arrow in this column indicates the event that starts closest before the project
cursor position. You can use this column for auditioning when you are editing in the
list.
●

To move the cursor to the start of the event, click in the auditioning column of
an event.

●

To move the cursor position and start/stop playback, double-click in the
column for an event.

Type
Event type. Cannot be changed.
Start
Starting position of the event, displayed in the format selected for the ruler.
Changing it has the same effect as moving the event.
NOTE
If you move the event past any other event in the list, the list is resorted. The list
always shows the events in the order in which they are played back.
End
Allows you to view and edit the end position of a note event. Editing resizes the note
event.
Length
Displays the length of the note event. Changing this resizes the note event and
automatically changes the End value.
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Data 1
Data 1 or Value 1 property of the event. Its content depends on the event type. For
notes, this is the pitch, for example. Where applicable, the values are displayed in the
most relevant form. For example, the Data 1 value for notes is displayed as a note
number in the format that was selected in the Preferences dialog.
Data 2
Data 2 or Value 2 property of the event. The content of this depends on the event
type. For notes, this is the note-on velocity value, for example.
Data 3
The Data 3 or Value 3 property of the event. This value is only used for note events,
where it corresponds with the note-off velocity.
Channel
MIDI channel of the event. This setting is normally overridden by the channel setting
for the track. To make a MIDI event play back on its own channel, set its track to the
Any channel in the Project window.
Comment
Allows you to add comments to some event types.

Event Display
The Event Display displays events graphically. The vertical position of an event in the display
corresponds to its entry in the list, that is, to the playback order. The horizontal position
corresponds to the actual event position in the project. In the event display, you can add new
parts or events, and drag events to another position.

Value Display
The value display to the right of the event display is a tool for quick viewing and editing of
multiple values, for example, velocities or controller amounts. The values are shown as horizontal
bars, with the bar length corresponding to the value.
To show or hide the value display, click Set up Window Layout on the toolbar, and activate or
deactivate Value Display.

The value that is displayed for an event depends on the event type. The following table shows
what is displayed and edited in the Data columns and the value display:
Event type

Data 1

Data 2

Value display

Note

Pitch (note number)

Note-on velocity

Velocity

Controller

Controller type

Controller amount

Controller amount

Program change

Program number

Not used

Program number
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Event type

Data 1

Data 2

Value display

Aftertouch

Aftertouch amount

Not used

Aftertouch amount

Pitchbend

Bend amount

Not used

Bend amount

SysEx

Not used

Not used

Not used

NOTE
For note events, there is also a value in the Data 3 column, which is used for note-off velocity.
NOTE
For SMF and text events, no values are displayed.

List Editor Operations
This section describes the principal editing operations within the List Editor.

Drawing Events
The Draw tool allows you to insert single events in the event display.
When you move the cursor inside the event display, its position is indicated on the status line.
The snap function is taken into account.

●

To change the event type that you want to draw, select it from the Insert Event Type popup menu.

●

To draw an event, click in the event display.
The note event gets the length that is set on the Length Quantize pop-up menu. Notes
get the insert velocity value set in the Insert Velocity field on the toolbar.

●

To draw longer note events, click and drag in the event display.
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The length of the event is a multiple of the Length Quantize value. If Length Quantize is
set to Quantize Link, the event value is determined by the quantize grid.

Filtering the Event List
You can filter the event list with the Filters bar that is displayed below the toolbar in the List
Editor.
●

To filter the event list based on complex criteria, open the Show pop-up menu and select a
filter.

●

To hide an event type, activate the corresponding checkbox on the Filters bar.

●

To hide all event types except one, press Ctrl/Cmd and click the checkbox of the event type
that you want to view.
If you Ctrl/Cmd-click again, all checkboxes are cleared.

Editing in the Event List
●

To edit the values of several events, select the events and edit the value for one event.
The values of the other selected events are also changed. Any initial value differences
between the events are maintained.

●

To set the values of all selected events to the same value, press Ctrl/Cmd and edit the
value for one event.

●

For SysEx events, you can only edit the Start position in the list. However, when you click
the Comment column, the MIDI SysEx Editor opens, in which you can perform detailed
editing of system exclusive events.

NOTE
When you trim the beginning of a note in the List Editor, the note may move to a different
position in the list, since other events may begin earlier than the edited event.

RELATED LINKS
SysEx Messages on page 865

Editing in the Event Display
The event display allows you to edit the events graphically using the tools on the toolbar. You can
edit single events as well as several selected events simultaneously.
●

To move an event, drag it to a new position.
Moving the event past any other event in the display resorts the list. The list always shows
the events in the order in which they are played back. As a result, the vertical position of
the event in the display also changes.

●

To make a copy of an event, press Alt and drag it to a new position.

●

To resize a note, select it and drag its end point with the Object Selection tool.

●

To mute or unmute an event, click on it with the Mute tool.
You can mute or unmute several events simultaneously by enclosing them in a selection
rectangle with the Mute tool.

●

You can select a color scheme for the events with the Event Colors pop-up menu on the
toolbar.

●

To delete an event, select it and press Backspace or Delete, or click on it with the Erase
tool.
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RELATED LINKS
Coloring Notes and Events on page 798

Editing in the Value Display
●

To edit values in the value display, click and drag.
The mouse pointer automatically takes on the shape of the Draw tool when you move it
over the value display.

SysEx Messages
SysEx (System Exclusive) messages are model-specific messages for setting various parameters
of a MIDI device. This makes it possible to address device parameters that would not be available
via normal MIDI syntax.
Every major MIDI manufacturer has its own SysEx identity code. SysEx messages are typically
used for transmitting patch data, for example, the numbers that make up the settings of one or
more sounds in a MIDI instrument.
Nuendo allows you to record and manipulate SysEx data in various ways.
RELATED LINKS
Using MIDI devices on page 775

Bulk Dumps
In any programmable device, the settings are saved as numbers in computer memory. If you
change these numbers, you will change the settings. Normally, MIDI devices allow you to dump
(transmit) all or some settings in the device’s memory in the form of MIDI SysEx messages.
A dump is therefore, among other things, a way of making backup copies of the settings of your
instrument: sending such a dump back to the MIDI device restores the settings.
If your instrument allows the dumping of a few or all of its settings via MIDI by activating some
function on the front panel, this dump will probably be recordable in Nuendo.

Recording a Bulk Dump
IMPORTANT
If your MIDI instrument does not offer a way to initiate a dump, you have to send a Dump
Request message from Nuendo to start the dump. In that case, use the MIDI SysEx Editor to
insert the specific Dump Request message (refer to the instrument’s documentation) at the
beginning of a MIDI track. When you activate recording, the Dump Request message is played
back (sent to the instrument), the dump starts and is recorded.

PROCEDURE
1.

In the Preferences dialog, select MIDI > MIDI Filter.

2.

In the Record section, deactivate the SysEx checkbox to make sure that the recording of
SysEx data is not filtered.
This way, SysEx messages are recorded but not echoed back to the instrument. This can
lead to unpredictable results.

3.

Activate recording on a MIDI track and initiate the dump from the front panel of the
instrument.

4.

When you have finished recording, select the new part and select MIDI > List Editor.
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This allows you to check that the SysEx dump was recorded. There should be one or
several SysEx events in the part/event list.

Transmitting a Bulk Dump Back to a Device
PREREQUISITE
Route the MIDI track with the System Exclusive data to the device. Check your device’s
documentation to find details about which MIDI channel should be used, etc.
PROCEDURE
1.

Solo the track.

2.

Make sure that the device is set up to receive SysEx messages.

3.

If necessary, put the device in Standby to Receive System Exclusive mode.

4.

Play back the data.

Recording and Transmitting Bulk Dumps
●

Do not transmit more data than you need. If all you want is a single program, do not send
all. Otherwise, it could get too difficult to find the recognized program. Usually, you can
specify exactly which data you want to send.

●

If you want the sequencer to dump the pertinent sounds to your instrument whenever you
load a project, put the SysEx data in a silent count-in before the project itself starts.

●

If the dump is very short, for example, a single sound, you can put the dump in the middle
of the project to quickly re-program a device. However, you can achieve the same effect by
using Program Change. This is preferable, since less MIDI data is sent and recorded. Some
devices may be set up to dump the settings for a sound as soon as you select it on the
front panel.

●

If you create parts with useful SysEx dumps, you can put these on a special muted track. To
make use of these parts, drag them to an empty unmuted track and play them back.

●

Do not transmit several SysEx dumps to several instruments at the same time.

●

Make a note of the current device ID setting of the instrument. If you change this, the
instrument may later refuse to load the dump.

Recording SysEx Parameter Changes
Often, you can use SysEx to remotely change individual settings in a device, for example, opening
a filter, selecting a waveform, changing the decay of the reverb, etc. Many devices are also
capable of transmitting changes that are made on the front panel as SysEx messages. These can
be recorded in Nuendo, and thus incorporated into a regular MIDI recording.
For example: you open up a filter while playing some notes. In that case, you record both the
notes and the SysEx messages that are generated when you open the filter. When you play back
the recording, the sound changes exactly as it did when you recorded it.
PROCEDURE
1.

In the Preferences dialog, select MIDI > MIDI Filter and make sure that SysEx is
deactivated in the Record section.

2.

Make sure that the instrument is set to transmit changes of front panel controls as SysEx
messages.

3.

Record.
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AFTER COMPLETING THIS TASK
In the List Editor, check if the events were recorded properly.

MIDI SysEx Editor
While SysEx events are displayed in the List Editor/Project Browser, it is not their entire content
that is displayed. Only the beginning of the message is displayed in the Comment column for the
event. The event is not editable. You can only move the event, the same way you would move it in
the List Editor.
●

To open the MIDI SysEx Editor for a SysEx event, click in the Comments column for the
event in the List Editor/Project Browser.

The display shows the entire message on one or several lines. SysEx messages always begin with
F0 and end with F7 and a number of arbitrary bytes in between. If the message contains more
bytes, so that they do not entirely fit on one line, it continues on the next line. The Address
indication to the left helps you find out on which position in the message a certain value is
located.
You can edit all values except for the first (F0) and the last ones (F7).
In the MIDI SysEx Editor, the bytes are displayed as follows:
●

In the main display, values are shown in hexadecimal format.

●

To the right of the main display, values are shown in ASCII format.

●

At the bottom of the dialog, the selected value is shown in ASCII, binary, and decimal
formats.

Adding and Deleting Bytes
●

To add a byte, open the MIDI SysEx Editor and click Insert. The byte is added before the
selected byte.

●

To delete a byte, open the MIDI SysEx Editor, select a byte, and click Delete.

●

To delete the complete SysEx message, select it in the List Editor and press Delete or
Backspace.

Editing Byte Values
You can edit the selected byte value in the main display of the MIDI SysEx Editor, or in the ASCII,
decimal, and binary displays.
●

To edit the selected value, open the MIDI SysEx Editor, click on a byte, and type in the
value.
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Importing and Exporting SysEx Data
You can import SysEx data from disk and export the edited data to a file.
The file has to be in MIDI SysEx (.syx) binary format. Only the first dump in a SYX file will be
loaded.
●

To import SysEx data, open the MIDI SysEx Editor and click Import.

●

To export SysEx data, open the MIDI SysEx Editor and click Export.

NOTE
Do not confuse this format with MIDI files, which have the extension .mid.

In-Place Editor
The In-Place Editor allows you to edit MIDI notes and controllers directly in the Project window,
for quick and efficient editing in context with other tracks.

The In-Place Editor expands the MIDI track to show a miniature Key Editor. When you select a
MIDI note, the Project window info line shows the same information about the note as the info
line in the Key Editor. You can perform the same editing here as in the Key Editor.
RELATED LINKS
Editing Note Events on the Info Line on page 801

Opening the In-Place Editor
●

To open the In-Place Editor for the selected tracks, select MIDI > Open In-Place Editor.

●

To open the In-Place Editor for a single MIDI track, click Edit In-Place in the track list.

Toolbar
The toolbar contains tools and settings for the In-Place Editor.
To open the toolbar, click on the triangle in the upper right corner of the track list for the edited
track.
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Acoustic Feedback
Acoustic Feedback
Automatically plays back events when you move or transpose them, or when you
create them by drawing.

Multiple Part Controls
Edit Active Part Only
Restricts editing operations to the active part.
List of Parts in Editor
Lists all parts that were selected when you opened the editor, and allows you to
activate a part.

Indicate Transpositions
Indicate Transpositions
Allows you to display the transposed pitches of MIDI notes.

Auto Select Controllers
Auto Select Controllers
Automatically selects controller data of the selected MIDI notes.

Insert Velocity
Insert Velocity
Allows you to specify a velocity value for new notes.

Length Quantize
Length Quantize
Allows you to set a value for quantizing event lengths.

Event Colors
Event Colors
Allows you to select event colors.

Transpose Palette
Move Up
Transposes the selected event up by a half note.
Move Down
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Transposes the selected event down by a half note.
Move Up More
Transposes the selected event up by an octave.
Move Down More
Transposes the selected event down by an octave.

Working with the In-Place Editor
●

To zoom or scroll the In-Place Editor, point at the left part of the piano keyboard display
so that the pointer changes to a hand. Then drag to the right or left to zoom in or out
vertically, and drag up or down to scroll the editor.

●

To add or remove controller lanes, right-click below the controller name field and select an
option from the context menu.

●

To close the In-Place Editor for one track, click Edit In-Place in the track list or doubleclick below the controller display in the In-Place Editor.

●

To open/close the In-Place Editor for one or several selected tracks, use the Edit In-Place
key command.

●

You can drag notes from one In-Place Editor to another.

NOTE
The Snap button and Snap Type pop-up menu on the Project window toolbar control snapping
in the In-Place Editor, but the snap grid is set using the Quantize pop-up menu.
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Expression maps allow you to set up a map for all your articulations. This allows you to audition a
project including articulations.
You can select expression maps in the Inspector for MIDI or instrument tracks, and specify the
sound mapping and characteristics for all your articulations.
If you select an expression map for a MIDI or instrument track, the articulations defined in the
map are automatically applied during playback. Nuendo recognizes the expressions scored for
the MIDI part and searches the sound slots in the expression map for a sound that matches the
defined criteria.
When a matching sound slot is found, the current note is either modified, or the MIDI channel,
program change or key switch information is sent to the instrument selected on the Output
Routing pop-up menu for the track, so that a different sound is played. When no sound slot is
found that matches the articulations used in the part, the closest match is used.
When you enter articulations in a MIDI part, you must set up an expression map in a way that the
right sounds in the connected VST or MIDI instrument are triggered.
Expression maps also allow you to link your articulations with remote keys on a MIDI input device
and map these to sounds that can be played by a MIDI device or VST instrument. This way, you
can enter notes and articulations using a remote MIDI device and have these automatically
recorded and played back correctly by Nuendo.
Expression maps are useful in the following situations:
●

When you want to enter musical articulations directly in the Key Editor, Drum Editor, Score
Editor, or In-Place Editor, without having to record MIDI data first.

●

When you want to play/record music in realtime and control articulation changes while
playing.

●

When you open and edit projects from other users. By using expression maps, you can
map the articulation information to a different instrument set or content library quickly
and easily.

Expression maps are available for MIDI and instrument tracks. You can create your own
expression maps or download expression maps for orchestra libraries and virtual instruments
from the Steinberg web site.
NOTE
You can also use the Note Expression functions to add musical articulations directly on your MIDI
notes in the Key Editor.

RELATED LINKS
Articulations on page 872
Creating and Editing Expression Maps on page 873
Groups on page 875
Note Expression on page 883
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Articulations
Musical articulations define how specific notes are sung or performed on a given instrument.
They can also define the relative volume of notes or the changes in pitch.
The following articulation types are available:
●

Directions
Directions, such as pizzicato, are valid for all notes from their insert position, to the insert
position of the next direction. They are applied to a continuous range of notes, or even an
entire piece of music.

●

Attributes
Attributes, such as accents, or staccato, are valid for single notes.

Expression Map Setup
The Expression Map Setup window allows you to load, create, and set up expression maps.
Do one of the following to open the Expression Map Setup window:
●

Select MIDI > Expression Map Setup.

●

In the Inspector for a MIDI or instrument track, open the Expression Map section, click
Select Expression Map for the track and select Expression Map Setup from the pop-up
menu.
NOTE
You can also open the Expression Map section in the Inspector of the Key Editor, Drum
Editor or Score Editor.

The following sections are available:
1

Expression Maps
Allows you to load, save, add, and remove expression maps. Loaded or added expression
maps are shown in the Maps list.

2

Sound Slots
Shows the sound slots that correspond to the expression map that is selected in the
Expression Maps section.
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3

Output Mapping
Shows the output mapping that corresponds to the sound slot that is selected in the
Sound Slots section.

4

Articulations
Allows you to organize articulations in groups.

5

Remote Settings
Allows you to set up remote keys for triggering articulations via a MIDI input device. Here,
you can also specify if you want to use key switches or program change messages to play a
certain sound slot.

RELATED LINKS
Expression Maps on page 871
Adding Sound Slots on page 874
Output Mapping on page 876
Articulations on page 872
Remote Settings on page 877

Expression Maps in the Project Window
Expression maps are available in the Project window, from within the Inspector for MIDI and
instrument tracks.
●

In the Inspector for a MIDI or instrument track, open the Expression Map section, click
Select Expression Map for the track and from the pop-up menu select Expression Map
Setup.

1

Indicates that an expression map is used for the track.

2

Shows which remote key is being pressed.

3

Marks the slot that is played back. This allows you to see whether the correct sound slot is
used when you record articulations with an external device, such as a MIDI keyboard.

Creating and Editing Expression Maps
Creating Expression Maps
You can create expression maps from scratch.
PROCEDURE
1.

In the Inspector for a MIDI or instrument track, open the Expression Map section.

2.

Click Select Expression Map for the track.

3.

From the pop-up menu, select Expression Map Setup.

The Expression Map Setup opens.
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4.

In the Expression Maps section, click + to create a new map.

5.

Enter a name for the expression map.

Adding Sound Slots
You must create sound slots for each articulation that you want to add.
PREREQUISITE
The Expression Map Setup window is open and an expression map is selected in the Expression
Maps section.
PROCEDURE
1.

2.

Do one of the following:
●

In the Sound Slots section, use the first default sound slot that is added
automatically when a new map is created.

●

Click Add Sound Slot to add a new sound slot.

Click the articulation column Art. 1 for the sound slot, and select an articulation from the
menu.
NOTE
If a specific articulation is not available on the pop-up menu, select Add Custom
Articulation to define your own articulations. This adds a default articulation that you can
define in the Articulations section.

3.

Optional: Click the Name column and enter a name for the sound slot.
The names of the sound slots are displayed in the Inspector for the track.

4.

Optional: Click the articulation columns Art. 2, Art. 3, Art. 4 for the sound slot, and select
an articulation from the menu.
This allows you to create a complex articulation, made of several different single
articulations for the sound slot. For each new articulation, an additional entry is added in
the Articulations section.

5.

Click the Remote column for the sound slot and specify the key on your external device
that triggers this sound slot.

6.

Optional: Click the Col column to assign a color to the sound slot.
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When working in the MIDI editors, you can color your events according to the color of the
sound slots.
RESULT
The sound slots are added and the articulations are available. You can create as many sound
slots as you need.
If Nuendo finds the sound slot, the current note is either modified, for example reduced in length
or played louder, or the MIDI channel, program change or key switch information is sent to the
connected instrument (the instrument selected on the Output Routing pop-up menu for the
track), so that a different sound is played.
If no sound slot is found that matches the articulations used in the part, the closest match is
used.
RELATED LINKS
Expression Maps in the Project Window on page 873
Remote Settings on page 877

Articulations
You can edit the articulations that you added for the sound slots in the Articulations section of
the Expression Map Setup window.
The following settings are available:
Art.
Click this column to choose whether you want to insert the articulation as a symbol
or a text string. If you select Symbol, a dialog with the available symbols opens. If
you select Text, you can directly enter the desired text.
Type
Click this column to specify whether you want to add an attribute or a direction. If
you select Attribute, only single notes are influenced by the articulation symbol. If
you select Direction, the articulation symbol is valid from its insertion position until
the next articulation start.
Description
Click this column to enter a text such as the name of the symbol or the long name of
a direction.
Group
Click this column to sort articulations in groups and prioritize them.
RELATED LINKS
Groups on page 875

Groups
Groups allow you to sort the articulations in order to prioritize and combine them.
The groups themselves are exclusive. Articulations that are in the same group cannot be used
together. You can place articulations that cannot be combined, such as arco (bowed) and
pizzicato (plucked) for violin in the same group.
Groups represent the musical importance, with group 1 having the highest priority. This is useful
if an expression map does not find an exact match for your data and tries to identify the sound
which matches most criteria. If two sounds are found which have the same articulation in group
1, the sound that also matches group 2 is preferred and so on.
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Output Mapping
The Output Mapping section allows you to map sound slots to specific sound characters of an
instrument. The available sounds depend on the instrument that is selected for the MIDI or
instrument track.
NOTE
Some virtual instruments require multiple key switches or combinations of key switches and
controllers to select a particular articulation. In this case, click + to add multiple output events to
a single sound slot.

You can make the following settings for the slots:
Status
Allows you to specify a note-on, program change, or controller message for the
selected sound slot.
Data 1/Data 2
Allows you to specify key switches for the selected sound slot. This allows you to
switch between a bowed and a pizzicato violin, or to switch to another program
containing a different articulation.
You can also create expressions by editing the incoming MIDI data:
Channel
Allows you to specify the MIDI channel for the selected sound slot. This allows you to
switch to a different program.
Length
Allows you to specify the note length for the selected sound slot. This way, you can
create staccato or tenuto sounds.
Transpose
Allows you to specify a transpose value for the selected sound slot. This way, you can
select different articulations in some sample libraries, in which different articulations
are located on different octaves.
Velocity
Allows you to specify the velocity for the selected sound slot. This way, you can create
accents.
Min. Pitch/Max. Pitch
Allows you to specify a minimum and a maximum pitch for the selected sound slot.
Min. Velocity/Max. Velocity
Allows you to specify a minimum and a maximum velocity for the selected sound
slot, to make sure that the sample mapped to a particular range is used. This way,
you can use instruments that have different velocity ranges on the same key.
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Remote Settings
The remote settings allow you to specify key switches or program change messages to trigger
specific sound slots.
NOTE
If you do not plan to record or trigger articulations via a MIDI input device, you do not need to
specify remote keys.
Active remote keys are indicated in the Inspector for the track.

Key Switches/Program Change Messages pop-up menu
Allows you to select if you want to use Key Switches or Progam Change Messages
to switch sound slots.
NOTE
If you use key switches, these keys are used to insert articulations instead of notes.
Latch Mode
If this is activated, the key you press on your MIDI input device is valid until you press
the next key. If this is deactivated, the key is valid for as long as you hold it. When
you release it, the first sound slot is played.
IMPORTANT
Latch Mode can only be activated/deactivated globally, not for single expression
maps.
Root Note
Allows you to specify the first key on your external device that you want to use as a
remote key. This allows you to automatically adjust existing remote key assignments
to suit your needs, for example when you use a MIDI keyboard with a very wide or
very narrow key range.
Set Remote Keys
Allows you to automatically assign a range of keys on your external device to the
sound slots in the expression map.
RELATED LINKS
Expression Maps in the Project Window on page 873
Set Remote Keys on page 878
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Set Remote Keys
The Set Remote Keys dialog allows you to assign a range of keys on your external device to the
sound slots in the expression map.

Start Key
Allows you to specify the first key on the MIDI input device that you want to trigger a
sound slot.
Key Mapping
Allows you to specify with which keys on your device you want to trigger the sound
slots.

Extracting Expression Maps from VST Instruments
You can extract mapping information from VST 3 instruments and convert it into a new
expression map. This way, you can set up expression maps for the instruments you often work
with.
PROCEDURE
1.

Load the VST instrument that you want to use and assign it to a MIDI or instrument track.

2.

Load an instrument preset that contains key switches.
Included with Nuendo are several track presets that are pre-configured for use with
expression maps. They contain sounds that make use of key switches and have different
articulations. These presets have the suffix VX.

3.

In the Inspector for the MIDI or instrument track, open the Expression Map section.

4.

Click Select Expression Map for the track.

5.

From the pop-up menu select Import Key Switches.
The Expression Map Setup opens.
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6.

Make the desired settings, enter a name for the map, and click Save.

RESULT
The expression map is saved and you can load it from the Select Expression Map for the track
pop-up menu on the Expression Map section of the Inspector.
RELATED LINKS
Creating Expression Maps on page 873
Track Presets on page 188

Saving Expression Maps
If you have created and set up your expression map, you must save it.
PROCEDURE
1.

In the Expression Maps Setup window, select the expression map in the Expression Maps
section.

2.

Click Save.

3.

In the file dialog, specify a file name and a location for the expression map, and click Save.

RESULT
The expression map is saved.

Loading Expression Maps
PROCEDURE
1.

In the Inspector for a MIDI or instrument track, open the Expression Map section.

2.

Click Select Expression Map for the track and from the pop-up menu, select Expression
Map Setup.
The Expression Map Setup opens.

3.

In the Expression Maps section on the left, click Load.

4.

In the file dialog, locate and select the expression map that you want to load, and click
Open.
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The expression map is now available in the Expression Maps section.
5.

Repeat the steps for all the maps that you want to make available, and close the dialog.

RESULT
All loaded maps are available on the Expression Map pop-up menu in the Inspector.
RELATED LINKS
Creating and Editing Expression Maps on page 873

Inserting Articulations
Inserting Articulations on Controller Lanes
You can insert articulation symbols on the controller lane of the Key Editor, Drum Editor, and
In-Place Editor.
PROCEDURE
1.

Select the MIDI part.

2.

Open the Key Editor, Drum Editor, or In-Place Editor.

3.

In the controller display, open the Controller Selection and Functions menu and select
Articulations/Dynamics.
All articulations that are specified for the selected expression map are shown on different
rows on the controller lane. The different groups are separated by lines, and articulations
that belong to the same group are shown in the same color.

4.

Select the Draw tool, and in the controller display, click at the exact position of the first
note to which you want to apply this articulation.
The note beginnings are displayed as vertical lines on the controller display.

RESULT
The attribute in the controller lane is now automatically connected to the corresponding note.
NOTE
If you delete an attribute by selecting it and pressing Delete or Backspace, the note is deleted as
well. If this is not what you want, deselect the articulation in the Articulations field in the info
line instead.
IMPORTANT
When you insert articulation symbols, make sure that they do not conflict with other
articulations.

RELATED LINKS
Inserting Articulations via the Info Line on page 881

Inserting Articulations in the Score Editor
You can insert articulation symbols in the Score Editor.
PROCEDURE
1.

Select the MIDI part.
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2.

Select Scores > Open Score Editor.

3.

In the Symbols Inspector, open the Expression Map section.

4.

Activate the articulation symbol, and click at the desired position in the note display.
IMPORTANT
When you insert articulation symbols, make sure that they do not conflict with other
articulations.

RESULT
The articulation symbols inserted in the note display are shown in a different color so that you
can distinguish them from other score symbols.

NOTE
You can view and change the colors in the Preferences dialog (Score–Colors for Additional
Meanings page).
To delete an articulation symbol, select it and press Delete or Backspace.

Inserting Articulations via the Info Line
You can insert articulation symbols via the info line of the Key Editor, Drum Editor, and Score
Editor.
PROCEDURE
1.

Select a MIDI note in the event display of the Key Editor, Drum Editor, or Score Editor.

2.

On the info line, click Articulations to open a pop-up menu with all note attributes that
are available in the expression map, and select the desired attribute.

RESULT
The name of the active attribute is now shown in the Articulations field.
NOTE
If you want to delete the attribute, deselect the articulation in the Articulations field in the info
line.
IMPORTANT
When you insert articulation symbols, make sure that they do not conflict with other
articulations.

RELATED LINKS
Groups on page 875
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Inserting Articulations in the List Editor
You can insert articulation symbols via the comment column of the List Editor. This only works if
your MIDI part already contains some articulation symbols.
PROCEDURE
1.

Select a MIDI note in the event display of the List Editor.

2.

Click the Comment column to open a pop-up menu with all note attributes that are
available in the expression map, and select the desired attribute.

RESULT
The name of the active attribute is now shown in the Comment column.
NOTE
If you want to delete the attribute, deselect the articulation in the Comment column.
IMPORTANT
When you insert articulation symbols, make sure that they do not conflict with other
articulations.
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Note expression allows you to show and edit controller events on MIDI note events in the event
display.
Note expression associates controller events with MIDI notes, so that they are treated as a unit.
When you quantize, move, copy, duplicate, or delete MIDI notes, all their associated controller
information follows. This allows for a very intuitive and accurate editing of note-related data.
Controller event curves are shown as an overlay of the corresponding MIDI notes in the event
display. All note expression data for a MIDI note is shown simultaneously.

To be able to record controller events in Nuendo, you must assign MIDI control change
messages to VST 3 controller parameters and MIDI controller parameters.
RELATED LINKS
VST 3 Controller Parameters on page 883
MIDI Controller Parameters on page 884

VST 3 Controller Parameters
VST 3 controller parameters are note-specific. They are suitable for polyphonic contexts, as they
allow you to edit the articulation of each individual note in a chord.
VST 3 controller parameters are provided by VST instruments. To be able to work with VST 3
controller parameters, you need a VST instrument that supports them, such as HALion Sonic SE.
Which VST 3 controller parameters are available depends on the instrument.
VST 3 controller parameters allow for a value range that exceeds the MIDI range of 0 to 127.
RELATED LINKS
HALion Sonic SE on page 884
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HALion Sonic SE
HALion Sonic SE is a VST 3-compatible VST instrument that can be used with note expression.
HALion Sonic SE offers the VST 3 parameters Tuning, Volume, and Pan, and it comes with
several presets.
For detailed information about HALion Sonic SE and its parameters, see the separate document
HALion Sonic SE.

MIDI Controller Parameters
MIDI controller parameters are channel-specific, with the exception of poly pressure messages.
They affect the entire voice, regardless of whether they are inserted for a part or a note.
The fact that MIDI controller parameters are channel-specific limits the potential of note
expression to monophonic (solo) performances. If you edit articulation data on one note, this
affects all other notes of the same voice, that is, any other note playing on the same channel at
the same time.
NOTE
If you want to use MIDI controller parameters in polyphonic performances, use controller lanes
instead, for example in the Key Editor.

RELATED LINKS
Using the Controller Display on page 823
Recording MIDI Control Change Messages as Note Expression Data on page 899
Converting MIDI Control Change Messages into Note Expression data on page 900

Note Expression Inspector Section
The Note Expression Inspector section features most of the functions that you need to work
with note expression.
The Note Expression section is divided as follows:

1

Section header/Bypass button
Shows the section name. The bypass button allows you to bypass all note expression data
for the track.
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2

Controller parameter list
Lists the available VST 3 and MIDI controller parameters.

3

Controller parameter settings
Allows you to make settings for the parameter that is selected in the controller parameter
list.

4

Global settings
Allows you to make global settings for all parameters.

RELATED LINKS
Controller Parameter List on page 885
Controller Parameter Settings on page 886
Global Settings on page 887

Controller Parameter List
The controller parameter list shows VST 3 and MIDI controller parameters. Which VST 3 controller
parameters are available depends on the instrument that is used. Which MIDI controller
parameters are available depends on the settings in the MIDI Controller Setup dialog.
The following sections and functions are shown in the controller parameter list:

1

Visibility
Shows/Hides the parameter in the note expression event editor and in the event display.

2

Parameter filter
Allows you to filter the list of controller parameters.

3

MIDI CC
For VST 3 controllers, this shows the number of the MIDI control change message that is
mapped to the parameter for recording.

4

VST 3 controllers
Lists the available VST 3 controller parameters.

5

MIDI controllers
Lists the available MIDI controller parameters.

Parameter Filter
You can filter the list of the available controller parameters. This allows for a better overview of
the parameters in the list.
●

To open the parameter filter, click the column header.
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The following options are available:
Show only used Parameters
Shows only the parameters in the list for which data exists. These are marked with an
asterisk (*) in front of the parameter name.
Make all Parameters visible
Shows all available parameters in the event display.
Make only edited Parameter visible
Shows only the selected parameter in the event display.
Load MIDI Input Assignment
Allows you to load mapping presets.
Save MIDI Input Assignment
Allows you to save mapping presets for a connected MIDI device.
MIDI Controller Setup
Opens a dialog that allows you to add MIDI controller parameters to the list.
RELATED LINKS
Controller Parameter List on page 885
Controller Parameter Mapping on page 888

Controller Parameter Settings
In this section, you can make settings for the controller parameter that is selected in the
controller parameter list, for example, set up the MIDI assignment.

1

Color selector
Allows you to specify a color for the selected parameter.

2

MIDI assignment
Allows you to specify the MIDI controller assignment for the selected parameter.

3

MIDI Learn
Click this button and move the fader or knob on your external MIDI controller to assign the
selected parameter to it.

4

Parameter range
Allows you to specify a value range that is used for the selected controller parameter.
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Global Settings
The global settings apply to all parameters in the controller parameter list.

MIDI as Note Expression
Activate this to record MIDI controller events as note expression data.
Channel Rotation
Activate this to assign individual MIDI channels to incoming MIDI notes and their
controller messages.
IMPORTANT
In order to use the Channel Rotation mode, the input controller must support
channel rotation.
Overdub
Activate this to overdub existing note expression data.
Latch Buffer
Allows you to activate/deactivate the latch buffer that is used for overdub recording.
RELATED LINKS
Channel Rotation on page 890

Note Expression Tools
The note expression tools are available on the Key Editor toolbar.
Show Note Expression Data
Gives you a visual feedback of your actions. Use the slider to the right to adjust the
display size of the note expression data in the event display.
Note Expression MIDI Input

Allows you to record note expression data via MIDI input.
Acoustic Feedback
Gives you an acoustic feedback of the controller events that are present at the
mouse position while you enter or change note expression data.
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Controller Parameter Mapping
Before you can record VST 3 events with external keyboards, you must map or assign specific
MIDI controller messages, or pitchbend and aftertouch to the note expression parameters that
you want to use.
NOTE
You can use the same MIDI controller message for several note expression parameters, but only
one can be active at a time.
You can map the parameters via the Inspector, via MIDI Learn or by using a mapping preset.
RELATED LINKS
Mapping Controller Parameters via the Inspector on page 888
Mapping Controller Parameters via MIDI Learn on page 889
Using Mapping Presets on page 889

Mapping Controller Parameters via the Inspector
You can assign the knobs and faders of your MIDI instrument to note expression parameters via
the Inspector.
PROCEDURE
1.

In the controller parameter list, select the parameter to which you want to assign a MIDI
controller.

2.

In the Global Settings section, open the MIDI assignment pop-up menu and select the
MIDI controller parameter that you want to map to the selected note expression
parameter.

3.

Optional: If the MIDI controller parameter you are looking for is not on the list, select MIDI
Controller Setup, and activate the parameter in the dialog.

RESULT
You can now record note expression data using the controller messages that you just assigned.
In the CC column in the Inspector, the number of the assigned MIDI controller message, or PB
for pitchbend, or AT for aftertouch is shown if the mapping is active. MIDI controller messages
that are assigned but inactive, are shown with a dot.
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NOTE
The VST 3 parameter Tuning is automatically assigned to the pitchbend wheel of your MIDI
controller. All other parameters are assigned by default to the first MIDI controller message, CC1:
Modulation.

RELATED LINKS
Global Settings on page 887

Mapping Controller Parameters via MIDI Learn
The MIDI Learn function allows you to assign the knobs and faders of your MIDI device to note
expression parameters.
PROCEDURE
1.

In the controller parameter list, select the parameter to which you want to assign a MIDI
controller.

2.

In the Controller Settings section, click MIDI Learn.

3.

On your MIDI device, use the knob or fader that you want to assign to the selected note
expression parameter.

4.

Repeat this for all the parameters that you want to control with your MIDI device.

RESULT
You can now record note expression data using the controls on your MIDI device that you just
assigned.

Using Mapping Presets
You can save your controller parameter mapping as a preset and load them later for use with the
same MIDI device.
PROCEDURE
1.

In the controller parameter list, click the Parameter column to open a pop-up menu.

2.

Select Save MIDI Input Assignment.

3.

In the file dialog that appears, specify a name and a location for the file.

RESULT
A file with the extension *.neinput is created.
You can load the mapping presets you created by selecting Load MIDI Input Assignment from
the same the pop-up menu.

Recording
You can record note expression data together with MIDI notes or you can record note expression
data for existing notes.
RELATED LINKS
Recording Notes and Note Expression Data on page 890
Recording Note Expression Data by Overdubbing on page 891
Recording Note Expression Data via MIDI Input on page 892
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Recording and the Sustain Pedal
If you hold the sustain pedal (MIDI CC 64) of the connected MIDI device during recording, the
following applies for VST 3 parameters:
●

When a note-off event is received (when the key on the connected keyboard is released),
this message is not sent to the VST 3 instrument but is instead created by the program
when the sustain pedal is released.
This makes it possible for the VST 3 instrument to play back control change messages that
are sent after a key was released.

●

The release phase of the recorded notes ends when the sustain pedal is released.

NOTE
This does not apply for continuous controller messages.

Recording Notes and Note Expression Data
You can use an external MIDI device to record MIDI notes together with note expression data.
PROCEDURE
1.

Select Project > Add Track > Instrument.

2.

Open the Instrument pop-up menu and select HALion Sonic SE, for example.

3.

Click Add Track.

4.

In the Inspector, open the Note Expression section.

5.

In the controller parameter list, select a parameter.

6.

In HALion Sonic SE, select a preset.
NOTE
In the Presets browser, enter noteexp in the search field of the Results section to show
the presets that were created especially for use with note expression.

7.

Map the controller parameters for recording.

8.

Use the mapped controls on your MIDI device to record MIDI notes together with note
expression data.

RESULT
The notes are recorded together with the note expression data. If you activate Show Note
Expression Data on the Key Editor toolbar, the note expression data is shown on the notes for
which they were recorded.
RELATED LINKS
Controller Parameter Mapping on page 888
Channel Rotation on page 890

Channel Rotation
Some input controllers support channel rotation, that is, they can assign individual MIDI
channels to incoming MIDI notes and their controller parameters.
Each new MIDI note event is assigned its own internal MIDI channel and all controller
parameters that belong to this note event are created with the same MIDI channel. This allows a
16 voice polyphony, which is sufficient for most performances.
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Channel rotation ensures a correct mapping of this data as note expression data per note event,
and reduces the amount of data in comparison to the MIDI to note expression conversion
method.
RELATED LINKS
Global Settings on page 887

Recording Note Expression Data by Overdubbing
You can record or replace note expression data for existing notes by overdubbing.
PREREQUISITE
Deselect all notes in the event display before you start overdubbing. This ensures that you record
control change messages for all notes touched by the position cursor.
PROCEDURE
1.

In the Inspector, open the Note Expression section, and activate Overdub.

2.

Use the mapped controls on your MIDI device to record note expression data for the note
that is playing.

RESULT
Only note expression data is recorded.
AFTER COMPLETING THIS TASK
Deactivate Overdub when you are done.
RELATED LINKS
Global Settings on page 887

Starting Overdub Recording at Specific Controller Values
When you record note expression data by overdubbing, you can activate a Latch Buffer. This is
useful if you want to start recording at predefined initial knob or fader settings.
When Nuendo receives controller data from an external MIDI device, the setting of the faders
and knobs on the device is automatically written to the Latch Buffer. This data is then added to
the notes during playback.
PROCEDURE
1.

Map each control to one of the available VST 3 parameters.

2.

Activate Latch Buffer and set the knobs and faders on the MIDI controller to the
corresponding values.

3.

Activate Overdub.

4.

Use the mapped controls on your MIDI device to record note expression data for the note
that is playing.

RESULT
The values for all controls are attached to the notes that are passed during overdub recording,
and replace any existing controller data of the same type.
AFTER COMPLETING THIS TASK
Remove all values from the Latch Buffer by clicking Reset Latch Buffer.
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NOTE
When you record in a cycle, the Latch Buffer is automatically reset at the end of the cycle.

Recording Note Expression Data via MIDI Input
You can record note expression data for existing notes using the Note Expression MIDI Input.
PROCEDURE
1.

On the Key Editor toolbar, activate MIDI Input and Note Expression MIDI Input.

2.

Select a note and move the active control on your MIDI device to replace the controller
events for that note.

RESULT
The note is played in real time and incoming control change messages are recorded for it.
Recording stops when the end of the note or the end of the release phase is reached, or when
you deselect the note.
RELATED LINKS
Adding Release Phases to Notes on page 897

Note Expression Event Editor
The note expression event editor offers various modes for editing and adding note expression
events.
●

To open the note expression event editor, double-click a note in the event display.
NOTE
If you select several notes in the Key Editor, and you double-click any of them, the note
expression event editor opens for all these notes. In this case, any editing affects all the
notes that are present at the time position where you perform the editing.

●

To close the editor, click in the event display.

The note expression event editor features the following controls:
●

Note Expression Controls
These controls allow you to select parameters and add note expression events.

●

Smart Controls
These allow you to edit the note expression events.

Note Expression Controls
The note expression event editor features the following specific note expression controls:
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1

One-Shot Mode
If this is active and you click with the Draw tool anywhere in the editor, a fixed value is set.
NOTE
This mode is automatically activated for VST 3 parameters that are one-shot only.

2

Vertical Snap
Allows you to enter the pitch in semitone steps instead of as a continuous curve. This way,
it is much easier to create fast pitch modulations. This is especially useful for the Tuning
parameter.
NOTE
To temporarily switch to vertical snapping while editing, hold down Shift.

3

Horizontal Snap
This corresponds to the Snap button in the Project window.

4

Change Release Length
Allows you to add a release length to your note.

5

Parameter Range
Shows the current value at the cursor position. The value range differs depending on the
parameter type.

6

Change Editor Size
Click this and drag up or down to change the size of the editor. This allows you to switch
between 3 different window sizes.

7

Parameter Selection
Shows the selected parameter. Click this to open a pop-up menu with all the parameters
that are used for the note. To make more parameters available, select them in the
Inspector.

Smart Controls
The note expression event editor features the following smart controls for specific editing
modes:

1

Tilt Left
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If you click in the upper left corner of the editor, you can tilt the left part of the curve. This
allows you to tilt the event values at the start of the curve upwards or downwards.
2

Compress Left
If you Alt-click in the upper left corner of the editor, you can compress or expand the left
part of the curve. This allows you to compress or expand the event values at the start of
the curve.

3

Scale Vertically
If you click in the middle of the upper border of the editor, you can scale the curve
vertically. This allows you to raise or lower the event values of the curve in percent.

4

Move Vertically
If you click on the upper border of the editor, you can move the entire curve vertically. This
allows you to raise or lower the values of the event values of the curve.

5

Compress Right
If you Alt-click in the upper right corner of the editor, you can compress or expand the
right part of the curve. This allows you to compress or expand the event values at the end
of the curve.

6

Tilt Right
If you click in the upper right corner of the editor, you can tilt the right part of the curve.
This allows you to tilt the event values at the end of the curve upwards or downwards.

7

Scale Around Relative Center
If you Alt-click in the middle right border of the editor, you can scale the curve relative to
its center. This allows you to raise or lower the event values horizontally around the center
of the editor.

8

Scale Around Absolute Center
If you click in the middle right corner of the editor, you can scale the curve absolute to its
center. This allows you to raise or lower the event values horizontally around the center of
the editor.

9

Stretch
If you click on the lower border of the editor, you can stretch the curve horizontally. This
allows you to move the event values of the curve to the left or to the right.

Navigation with the Note Expression Event Editor
You can navigate to the next/previous note while the note expression event editor is open.
●

To navigate to the next/previous note, use the Left Arrow/Right Arrow keys.

●

To step through the notes, press Tab and Shift-Tab.

Adding Note Expression Events
PROCEDURE
1.

Double-click a note in the event display to open the note expression event editor.

2.

Do one of the following to select the parameter that you want to make settings for:

3.

●

To create events for a parameter that has not been used yet, select the parameter in
the Inspector to make it available in the editor.

●

To edit existing events, specify which parameter you want to edit by clicking on the
curve, by selecting the corresponding parameter on the Parameter Selection popup menu, or by selecting the parameter in the Inspector in the Note Expression
section.

Select the Draw or the Line tool, and add note expression events for the selected note.
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RELATED LINKS
Adding Events in the Controller Display on page 825
Editing Events in the Controller Display on page 826

Deleting Note Expression Events
PROCEDURE
1.

Double-click the note that contains the note expression events you want to delete.
The note expression editor opens.

2.

Optional: Open the Parameter pop-up menu, and select the corresponding note
expression parameter in the list.

3.

Drag a selection rectangle to select the range of note expression values that you want to
delete.

4.

Select Edit > Delete.

RESULT
The selected note expression events are deleted from the note.
RELATED LINKS
Adding Events in the Controller Display on page 825
Editing Events in the Controller Display on page 826

Pasting Note Expression Events to Different Notes
You can copy all note expression events from one or more notes and paste them to one or more
other notes.
PREREQUISITE
You have set up a key command for Paste Note Expression in the Key Commands dialog (Note
Expression category).
PROCEDURE
1.

Double-click the note that contains the note expression events.
The note expression editor opens.

2.

Select the note expression events that you want to copy.

3.

Select Edit > Copy.

4.

Select the note to which you want to paste the note expression events.

5.

Press the key command that you assigned to the Paste Note Expression command.

RESULT
All copied note expression events are pasted to the selected note.
If you copied note expression events from several source notes and pasted them to a number of
destination notes, the following applies:
●

If the number of the source and destination notes matches, the events of the first source
note are pasted into the first destination note, the events of the second source note into
the second destination note, etc.

●

If the number of source notes is smaller than the number of destination notes, the source
note events are pasted repeatedly into the destination notes in the order in which they
appear.
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When you copy the events from 2 source notes into 4 destination notes, for example, the
first destination note gets the note expression events from the first source note, the
second destination note the events of the second source note, the third destination note,
the events of the first source note and the 4th destination note the events of the second
source note.
RELATED LINKS
Key Commands on page 1137

Pasting Note Expression Events to Different Parameters
You can copy note expression events from one parameter and paste them to a different
parameter.
PROCEDURE
1.

Double-click the note that contains the note expression events to open the note
expression event editor.

2.

Select the note expression events of the parameter that you want to copy.

3.

Select Edit > Copy.

4.

Select the parameter to which you want to paste the note expression events.

5.

Select Edit > Paste.

RESULT
All copied note expression events are pasted to the selected parameter.

Repeating Note Expression Events
PROCEDURE
1.

Double-click the note that contains the note expression events to open the note
expression event editor.

2.

Open the Parameter pop-up menu, and select the corresponding note expression
parameter from the list.

3.

Drag a selection rectangle to select the events that you want to repeat.

4.

Click the selection, and with the mouse button pressed press Alt and drag.

RESULT
The selected events are copied.

Moving Note Expression Events
PROCEDURE
1.

Double-click the note that contains the note expression events to open the note
expression event editor.

2.

Open the Parameter pop-up menu, and select the corresponding note expression
parameter from the list.

3.

Do one of the following:
●

Click the note expression event curve and drag to move all events.

●

Drag a selection rectangle to select events and drag to move the selected events.

896

Note Expression
Trimming Note Expression Data
NOTE
To restrict the direction to vertical or horizontal, you can press Ctrl/Cmd while dragging.

Adding Release Phases to Notes
You can add a release phase to a note. This allows you to work on the tail of a note which is still
sounding after the note-off message was sent, for example.
PROCEDURE
1.

Double-click a note in the event display to open the note expression event editor.

2.

Click and drag the Change Release Length control in the lower right corner of the editor
to add a release phase.

RESULT
The release phase is added to the note.

NOTE
You can change the release phase for several notes by opening the editor for these notes, and
holding down Alt while setting the release length.
AFTER COMPLETING THIS TASK
Add controller events in the release phase by overdubbing or by manually entering note
expression events in the editor. When you overdub note expression events, the length of the
existing release phase is used to associate newly recorded events to the notes.
NOTE
If you hold the sustain pedal of your external device during recording, the notes automatically
get a corresponding release phase.

Trimming Note Expression Data
You can trim note expression data to automatically match the note length.
PROCEDURE
1.

Select the notes that contain note expression data.

2.

Select MIDI > Note Expression > Trim Note Expression to Note Length.

RESULT
The note expression data is trimmed to the note length, and any data present after the end of
the release phase is deleted.
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Removing All Note Expression Data
You can delete all note expression data from the selected MIDI note or part.
PROCEDURE
1.

Select the MIDI note or the MIDI part that contains the note expression data that you want
to delete.

2.

Select MIDI > Note Expression > Remove Note Expression.

RESULT
The note expression data is removed.

Note Expression MIDI Setup Dialog
The Note Expression MIDI Setup dialog allows you to specify exactly which MIDI messages are
used every time you record MIDI control change messages as note expression data or you
convert them.

●

To open the Note Expression MIDI Setup dialog, select MIDI > Note Expression > Note
Expression MIDI Setup.

The following options are available:
Controller
Activates MIDI control change messages. Specify the MIDI control change messages
that you want to use in the list below.
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NOTE
MIDI controller data for deactivated MIDI control change messages will end up on
the controller lane.
Pitchbend
Activates pitchbend data.
Aftertouch
Activates aftertouch data.
Poly Pressure
Activates poly pressure data.
Controller Catch Range
Allows you to enter a controller catch range in ticks. This is useful to associate control
change messages with a note, although they were sent slightly before the note-on
message.
Load Default
Allows you to load the default settings.
Save as Default
Allows you to save the current settings as default settings.

Recording MIDI Control Change Messages as Note Expression Data
You can record MIDI control change messages as note expression data.
PROCEDURE
1.

In the Inspector, open the Note Expression section and activate MIDI as Note
Expression.

2.

Optional: Set the MIDI track to Any channel.
MIDI control change messages, with the exception of poly pressure, are channel-specific.
By splitting polyphony to separate channels, you can avoid conflicting controller
messages.

3.

Enter the notes and control change messages on your MIDI device.

RESULT
The controller data is now associated with the notes. If you copy, paste and move the notes, the
associated controller data will follow.
NOTE
If you want to edit the MIDI notes after recording, you might need to consolidate the controller
data.

RELATED LINKS
Consolidating Note Expression Overlaps on page 900
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Converting MIDI Control Change Messages into Note Expression
data
You can convert the MIDI control change messages on controller lanes into note expression data.
PREREQUISITE
The MIDI control change messages that you want to record are activated in the Note Expression
MIDI Setup dialog. You have a MIDI part with controller data written on controller lanes.
PROCEDURE
1.

Open the Key Editor for the MIDI part.

2.

Select MIDI > Note Expression > Convert to Note Expression.

RESULT
The MIDI control messages contained in the controller lanes are converted to note expression
data, and the data on the controller lanes is deleted.
Nuendo searches for notes that sound at the same time as the control change messages. If
several notes play at the same time, the same note expression parameters are attributed to
them, with the same values. Release phases are automatically created where necessary, so that
no controller data is lost during this process.
IMPORTANT
If you want to edit the MIDI notes after the conversion, you might need to consolidate the
controller data.

RELATED LINKS
Note Expression MIDI Setup Dialog on page 898
Adding Release Phases to Notes on page 897

Consolidating Note Expression Overlaps
If you move or quantize notes so that they overlap, and if these overlapping notes contain data
for the same control change message, you might need to consolidate the note expression
overlaps.
PROCEDURE
●

Select MIDI > Note Expression > Consolidate Note Expression Overlaps.

RESULT
If the overlapping notes contain data for the same control change message, the controller values
of the second note are used from the beginning of the overlap.
If a note is positioned entirely within a longer note and if these notes contain controller data for
the same control change message, the controller values of the longer note are used until the
encompassed note starts.

Distributing Notes to Different Channels
You can distribute notes to different channels. This allows you to use the note expression
functions, even if you do not have a VST 3 instrument.
PREREQUISITE
You have added a multi-timbral instrument, and assigned the same sound to different channels.
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PROCEDURE
1.

In the Inspector for the corresponding MIDI track, open the Channel pop-up menu, and
select Any.

2.

In the Inspector, open the Note Expression section.

3.

Enable MIDI as Note Expression.

4.

Record or enter MIDI notes with expression as needed.

5.

Select MIDI > Note Expression > Distribute Notes to MIDI Channels.

RESULT
The MIDI notes are distributed to different channels, starting at channel 1. You can now edit note
expression for each note independently without conflicts.

Converting Note Expression Data to MIDI Controller Data
You can convert note expression data of MIDI controller parameters to MIDI controller data on
controller lanes. Note expression data of VST 3 parameters cannot be converted.
PROCEDURE
●

Select MIDI > Note Expression > Dissolve Note Expression.

RESULT
The note expression data is converted. If you open the controller display and show the controller
lanes for the corresponding event type, the data is displayed.
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The chord functions provide you with many possibilities for working with chords.
The chord functions allow you to:
●

Build chord progressions by adding chord events to the chord track.

●

Convert chord events to MIDI.

●

Use the chord track to control audio playback or MIDI playback.

●

Use the chord track voicing to change the pitches of your MIDI.

●

Extract chord events from MIDI data to get an overview of the harmonic structure of a
MIDI file.

●

Record chord events with a MIDI keyboard.

RELATED LINKS
Chord Editing Section on page 820

Chord Track
The chord track allows you to add chord events and scale events.
RELATED LINKS
Scale Events on page 910
Chord Events on page 903

Adding the Chord Track
PROCEDURE
●

Select Project > Add Track > Chord.

RESULT
The chord track is added to your project.
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Chord Events
Chord events are representations of chords that control or transpose playback on MIDI,
instrument, and audio tracks.
Chord events alter the pitches of MIDI notes and VariAudio segments if their tracks are set up to
follow the chord track.
Chord events have a specific start position. Their end, however, is determined by the start of the
next chord event. They can have a root note, a type, a tension, and a bass note:

1

Root note

2

Type

3

Tension

4

Bass note

RELATED LINKS
Controlling MIDI or Audio Playback Using the Chord Track on page 914

Chord Editor
The Chord Editor allows you to define or change chord events, and to add new chord events.
●

To open the Chord Editor, double-click a chord event.

1

Go to Previous Chord/Go to Next Chord
Allow you to select the previous/next chord on the chord track for editing.

2

Add Chord
Adds a new undefined chord event on the chord track.
NOTE
This works only if the last chord event on the chord track is selected.

903

Chord Functions
Chord Events
3

Chord definition buttons
Activate these buttons to define a root note, a chord type, a tension, and a bass note for
your chord event.
NOTE
If you do not select a separate bass note, the setting is linked to the root note, so that no
extra bass note is heard.

4

Keyboard display
Shows the notes of the chord event, considering the current voicing settings.

5

Define Chord by Text Input
Allows you to define a chord using the computer keyboard.

6

Activate MIDI Input
Allows you to define a chord by playing a chord on your MIDI keyboard. If the chord is
recognized, it is reflected by the chord buttons and the keyboard display.

Adding Chord Events
PREREQUISITE
Add the chord track.
PROCEDURE
1.

Select the Draw tool and click in the chord track.
An undefined chord event named X is added.

2.

Select the Object Selection tool and double-click the chord event.

3.

In the Editor, select a root note.

4.

Optional: Select a chord type, tension, and bass note.

5.

Do one of the following:
●

To close the Editor, click anywhere outside the Editor.

●

To add a new undefined chord event, click Add Chord.

RELATED LINKS
Adding the Chord Track on page 902

Defining Chords By Text Input
In the chord Editor, you can use the text input field to define a chord with the computer
keyboard.
PROCEDURE
1.

Double-click a chord event to open the chord Editor.

2.

Click in the text input field at the bottom of the Editor.

3.

Enter a chord by performing the following actions:
●

Define a root note, for example, C, D, E.

●

Define accidentals, for example, # or b.

●

Define the chord type, for example maj, min, dim, sus, or aug.

●

Define a chord extension, for example 7, 9, or 13.
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NOTE
If you have activated Solfège in the Note Name pop-up menu in the Preferences dialog
(Event Display—Chords page), you can also enter chords in this format. You must
capitalize the first letter and write “Re” instead of “re”, for example. Otherwise, the chord is
not recognized.
4.

Press Tab to add a new chord and define it.

Chord Assistant
The Chord Assistant allows you to use a chord as a starting point to get suggestions for the next
chord.
●

To open the Chord Assistant, in the Chord Editor, click Chord Assistant.

The Chord Assistant has the following modes:
●

List

●

Proximity

●

Circle of Fifths

Chord Assistant – List
The List mode of the Chord Assistant allows you to create harmonic chord progressions based
on harmonic rules that can be more or less complex.
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1

Go to Previous Chord/Go to Next Chord
Allow you to select the previous/next chord on the chord track for editing.

2

Add Chord
Adds a new undefined chord event on the chord track.
NOTE
This works only if the last chord event on the chord track is selected.

3

Suggestions
Shows suggestions for the next chord. Click a chord suggestion to select it.

4

Complexity Filter
Allows you to increase the complexity and thus the number of suggestions. The higher the
complexity, the more suggestions you get.

5

Gap Mode
Activate this button to get suggestions for the chords in between 2 defined chords based
on the previous and the next chord.
Deactivate this button to get suggestions for the next chord based on the previous chord.
NOTE
For this to work you must select all undefined chords in between 2 defined chords.

6

Algorithm Mode
Select Cadence to build up a chord progression based on cadences. Select Common
Notes to build up a progression by specifying how many common notes the chords should
share.

7

Cadence Type
NOTE
This option is only available if you selected Cadence as Algorithm Mode.
Allows you to select a cadence type for the suggestions. This way, only the chords with
specific harmonic functions are suggested.
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8

Chord Assistant tabs
Click the tabs to open one of the chord assistant modes.

Chord Assistant – Proximity
The Proximity mode of the Chord Assistant takes a set of harmonic rules into account to offer
suggestions that match the origin chord.
If you open the Chord Assistant for a chord event, the previous event is set as origin chord. This
is shown in the bottom center of the Chord Assistant. The further away a suggestion is situated
from the origin chord in the graphic, the more complex the suggestion. The suggested chords
are triads or 4-note chords.

●

To assign a chord to the selected chord event and play it, click it.
The last 3 suggested chords that you clicked are shown with a highlighted border.

NOTE
●

If you move the mouse pointer over one of the suggestions in the Chord Assistant, a
tooltip with suggestions for progressions is shown.

●

The Proximity mode underlies the same rules as the List mode.

Adding Chord Events Based on Suggestions
If you do not know what your chord progression should look like, you can use the Chord
Assistant to get suggestions for the following chords.
PREREQUISITE
Add a chord event on the chord track.
PROCEDURE
1.

Double-click the chord event.

2.

Click Chord Assistant.

3.

Click Add Chord.

4.

Do one of the following:
●

To display the suggestions in a list, click the List tab.
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●

5.

To display the suggestions in a graphic, click the Proximity tab.

Click a suggestion to select it.

RESULT
The suggested chord is added as a chord event to the chord track. Repeat the steps above to
create as many chord events as required by your harmonic structure.

Chord Assistant – Circle of Fifths
The Circle of Fifths mode of the Chord Assistant shows the chords in an interactive visualization
of the circle of fifths.
The origin chord that defines the current key is shown in the center of the Chord Assistant and
is marked as tonic (I).
The outer circle shows the twelve major chords ordered in intervals of fifths.
The inner circle displays the corresponding parallel minor chords.
The roman numerals mark the chords of the current key with their scale degree. You can use
these chords to create typical chord progressions or you can use the other chords for more
creative results.
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●

To play a chord and assign it to the selected chord event, click it.
The last 3 chords that you clicked are shown with a highlighted border.

●

To define a new key, right-click the chord in the Chord Assistant and select Use as Origin,
or use the Rotate Left/Rotate Right controls.

●

To select the parallel minor chord and define it as key, click Major/Minor.

Auditioning Chord Events
To hear the chord events on the chord track, you must connect the chord track to the output of
an instrument or a MIDI track.
PREREQUISITE
Add the chord track and some chord events.
PROCEDURE
1.

Do one of the following:
●

To add an instrument track, select Project > Add Track > Instrument.

●

To add a MIDI track, select Project > Add Track > MIDI.

2.

Assign a VST instrument to your instrument or MIDI track and select a sound.

3.

In the chord track Inspector, activate Acoustic Feedback.

4.

From the Select Track for Auditioning pop-up menu, select the track that you want to use
for auditioning.

RESULT
The chord events on the chord track now trigger the sound of the assigned instrument on the
MIDI or instrument track.
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Changing How Chord Events Are Displayed
You can change how chord events are displayed. This is useful if chord events overlap each other
at low zoom levels or if you do not like the font type.
PROCEDURE
1.

On the chord track, activate Resolve Display Conflicts.

2.

In the Preferences dialog, select Event Display > Chords, and set up the chord font.
Here you can also determine the note name and naming format.

Scale Events
Scale events inform you which chord events fit in a specific sequence of notes that belong to a
specific root note.
Nuendo automatically creates scale events for your chord events.
●

To show the scale events, activate Show Scales on the chord track.

●

To audition the notes that belong to a scale event, click it.

However, you can also add and edit scale events manually.
Scale events have a specific start position. Their end is determined by the start of the next scale
event.

Editing Scale Events
PREREQUISITE
Add the chord track and chord events. Deactivate Automatic Scales in the chord track
Inspector.
PROCEDURE
1.

On the chord track, activate Show Scales.
The scale lane is displayed.

2.

Select the chord event.
A scale event is shown on the scale lane.

3.

Do one of the following:
●

Click the first scale event on the chord track, and on the info line, select a Root Key
and Type.

●

Double-click the scale event, and in the keyboard that appears, select a Root Key
and Type of the scale.
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The keys that correspond to the scale are highlighted.

Voicings
Voicings determine how chord events are set up. They define the vertical spacing and order of
the pitches in a chord, but also the instrumentation and genre of a musical piece.
For example, a C chord can be spread over a wide range of pitches, and a pianist will choose
different notes than a guitarist. The pianist may also play completely different pitches for
different musical genres.
●

You can set up voicing for the entire chord track in the chord track Inspector.

●

You can set up voicings for individual chord events on the Voicing pop-up menu on the
info line.
NOTE
If Adaptive Voicings is activated in the chord track Inspector, you can only change the
voicings for the first chord event on the info line.

Setting up Voicings
To set up voicings for the entire chord track, you can use the chord track Inspector.

1

Voicing library
Allows you to select Guitar, Piano, or Basic as a voicing library.

2

Voicing library subset
NOTE
This is only available if Guitar or Piano is set as voicing library.
Allows you to select a preset voicing library subset.

3

Configure voicing parameters
Allows you to configure your own voicing parameters for a specific voicing scheme.

4

Adaptive Voicings
Activate this to let Nuendo set the voicings automatically. This prevents the individual
voices from jumping too much.
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5

Automatic Scales
Activate this to let Nuendo set the scales automatically.

6

Mapping Offset
If you enter a negative number of ticks, the chord events will affect the MIDI notes that
have been triggered too early.

Configure Voicing Parameters
If you click Configure voicing parameters in the Voicings section of the Inspector, you can
configure your own voicing parameters for a specific voicing scheme.
NOTE
The Start Voicing section for piano, guitar, and basic voicings allows you to select a start voicing.
This is only available for MIDI, instrument, and audio tracks, but not for the chord track, and only
if you select Voicings in the Follow Chord Track pop-up menu.
In the Style section for Piano voicings, you can set up the following parameters:
Triads
Sets a triad. Chords with more than 3 notes are not changed.
Triads with maj9
Sets a triad with a major ninth, but without root note. Chords with more than 3 notes
are not changed.
Triads with maj9 and min9
Sets a triad with a major and a minor ninth, but without root note. Chords with more
than 3 notes are not changed.
4-note chords
Sets a 4-note chord without root note. Chords with less than 3 notes are not
changed.
4-note chords (Open Jazz)
Sets a 4-note chord without root note and without fifth. Chords with less than 3
notes are not changed.
5-note chords
Sets a 5-note chord with a ninth. Chords with less than 4 notes are not changed.
In the Options section for Piano voicings, you can set up the following parameters:
Add Root Note
Adds a root note.
Duplicate Root
Duplicates the root note.
Fatten up
Duplicates the tenor.
In the Voicing Range section for Piano voicings, you can set up the following parameters:
Lowest Root Note
Sets the limit for the lowest root note.
Lowest Note
Sets the limit for the lowest note, except the root note.
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Highest Note
Sets the limit for the highest note, except the root note.
In the Style section for Guitar voicings, you can set up the following parameters:
Triads
Sets a triad with 4, 5 or 6 voices.
4-note chords
Sets a 4-note chord with 4, 5 or 6 voices without tensions.
3-string triads
Sets a 3-string triad.
Modern Jazz
Sets 4-note, 5-note, and 6-note chords, partly without root note, but with tensions.
For Basic voicings only Octave Offset from C3 is available. This allows you to determine an
offset value for the octave range.

Converting Chord Events to MIDI
You can convert chord events to MIDI for further editing or for printing a lead sheet in the Score
Editor.
PROCEDURE
1.

2.

Add an instrument track or a MIDI track.
●

To add an instrument track, select Project > Add Track > Instrument.

●

To add a MIDI track, select Project > Add Track > MIDI.

Do one of the following:
●

To convert all chord events to MIDI, select Project > Chord Track > Chords to MIDI.

●

To convert only selected chords to MIDI, select the chord events and drag them to
the MIDI or instrument track.

RESULT
A new MIDI part is created, containing the chords as MIDI events.

Assigning Chord Events to MIDI Effects or VST Instruments
PREREQUISITE
Create a chord progression on the chord track and add a MIDI or instrument track to your
project.
PROCEDURE
1.

In the Inspector for the MIDI or instrument track, open the MIDI Inserts section.

2.

Click an insert slot and select Chorder from the Effect Type pop-up menu.
The Chorder effect is activated, and its control panel opens.

3.

On the chord track, select the chord events and drag them to the Chorder control panel.
The drop position determines the velocity area and the position of the first chord event. All
subsequent chord events are mapped chromatically. Chord events with more than one
occurrence are only assigned once.
To remap the chords, hold down Alt and drag again.
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4.

On your MIDI keyboard, hit the corresponding keys to play back the chords.

Assigning Chord Events to HALion Sonic SE Pads
PREREQUISITE
Create a chord progression on the chord track and add an instrument track with HALion Sonic SE
as VST instrument to your project.
PROCEDURE
1.

On the chord track, select the chord events and drag them to the HALion Sonic SE pads.
The first chord event is mapped to the pad where you dropped it and all subsequent chord
events are mapped to the following pads.

2.

Click the corresponding pads on the HALion Sonic SE keyboard to trigger the chords.

Controlling MIDI or Audio Playback Using the Chord Track
You can use the chord track to control audio playback or MIDI playback.

Using Live Transform
Live Transform allows you to transpose the MIDI input live to a chord progression on the chord
track. This way, you do not have to worry about what key you hit on your MIDI keyboard as the
MIDI input is transposed to match chords or scales on your chord track in real time.
PROCEDURE
1.

Create a MIDI or an instrument track and activate Record Enable.

2.

In the Inspector, open the Chords section.

3.

Open the Live Transform pop-up menu and do one of the following:

4.

●

To map the MIDI input to chord events, select Chords.

●

To map the MIDI input to scale events, select Scales.

Hit some keys on your MIDI keyboard or on the On-Screen Keyboard.

RESULT
Any key that you hit is mapped in real time to the chord or scale events on the chord track.

Using Follow Chord Track
This allows you to match an existing recording to a chord progression on the chord track.
PROCEDURE
1.

Select the track that you want to match to the chord track.

2.

In the Inspector, click Chords.

3.

Open the Follow Chord Track pop-up menu and select a mode.
NOTE
If this is the first time that you open this pop-up menu for the track, the Follow Chord
Track dialog opens.

4.

In the Follow Chord Track dialog, make your settings.
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5.

Click OK.

RESULT
The events on your track now match the chord progression on the chord track.
NOTE
If you matched your MIDI track to the chord track, some of the original MIDI notes may be
muted. To hide these notes in the editors, activate Hide Muted Notes in Editors in the
Preferences dialog (Editing—Chords page).

RELATED LINKS
Follow Chord Track Dialog on page 916
Follow Chord Track Modes on page 915

Follow Chord Track Modes
This section of the Inspector allows you to determine how your track follows the chord track.

The following options are available on the Follow Chord Track pop-up menu:
Off
Follow Chord Track is deactivated.
Chords & Scales
This maintains the intervals of the original chord or scale as far as possible.
Chords
This transposes MIDI notes to match the key note and maps them to the current
chord.
Scales
This transposes MIDI notes to match the current scale. This allows a bigger variety of
notes and a more natural performance.
Root Notes
This transposes MIDI notes to match the root note of the chord event. The effect
corresponds to using the transpose track. This option is suitable for bass tracks.
Voicings
This transposes MIDI notes to match the voices of the selected voicing library.
Single Voice
Maps MIDI notes and VariAudio segments to the notes of a single voice (soprano,
tenor, bass, etc.) of the voicing. Use the pop-up menu below to select the desired
voice.
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NOTE
If you apply this mode to a selection of tracks that contain separate voices, you can
set up one track as master and the others as voicing slaves. This way, you can
change the voicing of the master and the slaves will follow automatically.

RELATED LINKS
Assigning Voices to Notes on page 917

Follow Chord Track Dialog
This dialog opens the first time that you select an option from the Follow Chord Track pop-up
menu on the Chords section of the Inspector.

Follow Directly
Activate this if your VariAudio segments or MIDI notes are already in accordance with
the chord track. This is the case if you extracted your chords from the MIDI events on
the track by selecting Project > Chord Track > Create Chord Symbols, for example.
Synchronize Track Data with Chord Track First
Activate Analyze Chords if the track data has nothing in common with the chord
events. This analyzes the MIDI events and matches the found chords to the chord
track. This is only available for MIDI.
Activate Apply a Known Chord if the track data has nothing in common with the
chord events and if there are no chord changes. Specify Root Note and Chord Type
of your events.

Using Map to Chord Track
This allows you to match individual parts or events to a chord progression on the chord track.
PROCEDURE
1.

In the Project window, select the events or parts that you want to map to the chord track.

2.

Select Project > Chord Track > Map to Chord Track.

3.

From the Mapping Mode pop-up menu, select a mapping mode.
NOTE
If you select Voicings and no voices are found, Auto mode is used instead.

4.

Click OK.

RESULT
The chords and scales of each event or part are analyzed and used for mapping. If no chords are
found, Nuendo assumes that the performance is in “C”. The available mapping modes and
voicings correspond to the Follow Chord Track parameters in the Chords section of the
Inspector.
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RELATED LINKS
Follow Chord Track Modes on page 915

Assigning Voices to Notes
You can transpose MIDI notes to match the voices of a selected voicing library.
PROCEDURE
●

Select Project > Chord Track > Assign Voices to Notes.

RESULT
The note pitches now match the voicing of the chord track and you can still edit the MIDI notes. If
you now select a note in the Key Editor, you see that Voice on the info line is assigned.

Extracting Chord Events from MIDI
You can extract chords from MIDI notes, parts, or tracks. This is useful if you have a MIDI file and
want to show its harmonic structure, and use this file as starting point for further experimenting.
PREREQUISITE
Add the chord track and create MIDI notes that can be interpreted as chords. Drums,
monophonic bass, or lead tracks are not suitable.
PROCEDURE
1.

In the Project window, select a part or one or several MIDI tracks.
You can also select the MIDI tracks, parts, or notes that you want to extract in the Key
Editor, Score Editor, or In-Place Editor.

2.

Select Project > Chord Track > Create Chord Symbols.

3.

Make your settings and click OK.

RESULT
The chord events are added on the chord track.
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NOTE
You can now open the Chord Assistant to create variations.

RELATED LINKS
Create Chord Symbols Dialog on page 918

Create Chord Symbols Dialog
This dialog allows you to determine, which MIDI data should be taken into account when
extracting chord events from MIDI.

Include Bass Notes
Activate this if you want your chord events to contain a bass note.
Include Tensions
Activate this if you want your chord events to contain tensions.
Detect Arpeggios
Activate this if you want your chord events to contain arpeggiated chords, that is,
chords whose notes are played one after another instead of all at once.
Interpret Sustain Pedal
Activate this if you want your chord events to contain sustain pedal chords, that is,
notes that are played while the sustain pedal is held.
Ignore Notes Shorter Than
Allows you to determine the minimum length of the MIDI events that are taken into
account.

Recording Chord Events with a MIDI Keyboard
You can use a MIDI keyboard to record chord events on the chord track.
PREREQUISITE
Your project contains an instrument track with Record Enable or Monitor activated.
PROCEDURE
1.

On the chord track, activate Record Enable.

2.

On the Transport Panel, activate Record.

3.

Play some chords on your MIDI keyboard.

RESULT
All recognized chords are recorded as chord events on the chord track.
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NOTE
The chord track uses its own voicing settings. The recorded chord events may therefore sound
different.

RELATED LINKS
Creating Events from Chord Pads on page 941
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Chord pads allow you to play with chords, and to change their voicings and tensions. In terms of
harmonies and rhythms, they allow for a more playful and spontaneous approach to
composition than the chord track functions.
You can:
●

Perform with chords in real time via a MIDI keyboard.

●

Record your performance as MIDI events on a MIDI or instrument track or even on the
chord track.

NOTE
We assume that you have a MIDI keyboard connected and set up.

RELATED LINKS
Voicings on page 911

Chord Pads
The chord pads in the lower zone of the Project window hold all functions that you need to work
with chord pads.
To open the chord pads, select Project > Chord Pads.
NOTE
You can also select a MIDI or instrument track, and in the Inspector, open the Chords section
and activate Show/Hide Chord Pads Zone.
The chord pads hold the following controls:
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1

Current Player
Shows the current player and opens a menu where you can select another player.

2

Current Mode
Shows the current player mode and opens a menu where you can select another player
mode.

3

Chord Pad
Each chord pad can contain a chord symbol. To change it, click the Open Editor control on
the left edge of the chord pad.

4

Keyboard
Shows which keys are played when you trigger a chord pad. To zoom the keyboard, click a
key and drag up or down. To scroll the keyboard, click and drag to the left or to the right.

5

Pads Remote Range
The keys highlighted in blue on the keyboard correspond to the keys on your MIDI
keyboard that trigger the chord pads. You can define the remote range on the Remote
Control page of the chord pad Settings.

6

Remote Range for Voicings/Tensions/Transpose
The keys highlighted in green on the keyboard display correspond to the keys on your
MIDI keyboard that change the voicings, tensions, and transpose settings of the pads. You
can activate and define these remote keys on the Remote Control page of the chord pad
Settings.

7

Section Remote Range
The keys highlighted in brown on the keyboard correspond to the keys on your MIDI
keyboard that trigger the sections.

8

Activate/Deactivate Remote Control for Chord Pads
Allows you to activate/deactivate the chord pads. If you deactivate remote control for
chord pads, your MIDI keyboard no longer triggers the pads.

9

Functions Menu
Opens a menu with specific functions and settings for the chord pads.

10

Chord Pads Presets
Allows you to save and load presets for chord pads and players.

11

Show/Hide Chord Assistant
Shows/Hides the Chord Assistant window that shows suggestions of chords that match
the chord that you specified as the origin chord.

12

Show/Hide Settings
Shows/Hides the chord settings, where you can configure different players, the pad layout,
and the remote assignment.

RELATED LINKS
Chord Pad Settings – Remote Control on page 931
Players and Voicings on page 938
Opening Chord Pads on page 63

Chord Pad Controls
The chord pad controls allow you to edit the chord pads.
●

To show the chord pad controls, move the mouse over a chord pad.
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1

Open Editor
Opens the chord editor that allows you to select a chord for the chord pad.

2

Voicing Indicators
Shows the voicing used for the chord. Voicing indicators can only be displayed if the
horizontal zoom level for the chord pads is high enough.

3

Adaptive Voicing Reference/Use X as Origin for Chord Assistant
When the active chord pad is set as adaptive voicing reference, its borders are shown in
yellow. All other chord pads will follow its voicing and are set in a way that they do not get
too far away from the reference.
If the chord pad is set as origin for the Chord Assistant window, its borders are shown in
blue. This chord pad is used as a basis for the suggestions in the Chord Assistant window.

4

Assigned Chord
Shows the chord symbol that is assigned to the chord pad. Each chord pad can contain one
chord symbol. If the name of the assigned chord is too long to display it on the chord pad,
it is underlined, and the full chord name is shown in a tooltip.

5

AV (Adaptive Voicing)/L (Lock)
All chord pads follow the adaptive voicing. This is indicated by an AV symbol. If you change
the voicing for a pad manually, however, adaptive voicing is deactivated.
An L symbol indicates that the chord pad is locked for editing.

6

Voicing
Allows you to set another voicing for the chord pad.

7

Tensions
Allows you to add/remove tensions for the chord.

Chord Pad Context Menu
●

Use X as Origin for Chord Assistant
Sets the chord of the current pad as an origin chord for the chord assistant.

●

Assign Pad from MIDI Input
Allows you to assign a chord by pressing keys on your MIDI keyboard.

●

Lock
Allows you to lock a chord pad for editing.

●

Adaptive Voicing
All chord pads follow the adaptive voicing. This is indicated by a check mark. If you change
the voicing for a pad manually, adaptive voicing is deactivated.

●

Adaptive Voicings Reference
Sets the current pad as adaptive voicing reference. If set, the automatic voicings for the
following pads will be set in a way that they do not get too far away from the reference
voicing. Only one pad can be set as adaptive voicing reference.

●

Unassign Pad
Removes the chord assignment from the current pad.
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Functions Menu

●

Show Voicing Indicators
Allows you to activate/deactivate the voicing indicators that can be displayed at the bottom
of each chord pad.

●

Assign Pads from Chord Track
Assigns the chord events from the chord track to the chord pads in the same order as they
appear on the chord track. Chord events that have more than one occurrence are only
assigned once.

●

Snap Playback to Musical Grid
Allows you to delay the playback of a triggered chord pad to the next defined musical
position. This is useful if you work with an arpeggiator or with the Pattern Player.

●

Transpose All Pads
Transposes all chord pads by a defined transpose value.

●

Lock All Pads
Locks all chord pads for editing.

●

Unlock All Pads
Unlocks all chord pads.

●

Unassign All Pads
Removes the chord assignment from all pads.

Preparations
Before you can start working with the chord pads, you must add a MIDI or an instrument track
with an instrument loaded, and open the chord pads.
PREREQUISITE
You have installed and set up a MIDI keyboard.
PROCEDURE
1.

Select Project > Add Track > Instrument.

2.

In the Add Instrument Track dialog, select an instrument, and click Add Track.

3.

On the instrument track, click Record Enable.

4.

Select Project > Chord Pads to open the Chord Pads.

RESULT
You can now click the chord pads or press some of the assigned keys on your MIDI keyboard to
trigger the preassigned chords.
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Chord Assistant
The Chord Assistant allows you to use a chord as a starting point for suggestions for the next
chord. It assists you in finding the right chords for creating a chord progression for your song.
●

Click Show/Hide Chord Assistant on the left side of the chord pads area to open the
Chord Assistant.

The Chord Assistant window has 2 modes:
●

Chord Assistant – Proximity

●

Chord Assistant – Circle of Fifths

You must define an origin chord as follows:
●

Right-click the chord pad with the chord you want to use as origin and select Use X as
Origin for Chord Assistant.

The Chord Assistant window shows suggestions for follow-on chords that you can assign to the
chord pads.

Chord Assistant – Proximity Mode
The proximity mode of the Chord Assistant window uses a set of harmonic rules to offer
suggestions that match the origin chord.
The origin chord in the bottom center of the Chord Assistant window marks the tonal center.
The farther away a chord suggestion is situated from this chord, the more complex the
suggestion. The suggested chords are triads or 4-note chords.
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●

To play a suggested chord, click it.
The last 3 suggested chords that you clicked are shown with a highlighted border.

●

To assign a suggestion to the next unassigned chord pad, right-click the suggested chord
and select Assign to Pad.
You can also drag the suggested chord and drop it on a chord pad.

●

To assign a suggestion to the next unassigned chord pad and use this chord as origin for
further suggestions, right-click the suggested chord and select Assign to Pad and Use as
Origin.

NOTE
The Proximity mode is a different representation of the list in the Chord Assistant window for
the chord track.

RELATED LINKS
Chord Assistant – List on page 905

Chord Assistant – Circle of Fifths Mode
The Circle of Fifths mode of the Chord Assistant window shows the chords in an interactive
visualization of the circle of fifths.
The origin chord that defines the current key is shown in the center of the Chord Assistant
window. The tonic (I) of that key is displayed above the center. The outer circle shows the twelve
major chords ordered in intervals of fifths.
The inner circle displays the corresponding parallel minor chords.
The roman numerals mark the chords of the current key with their scale degree. You can use
these chords to create typical chord progressions. However, you can also use the other chords
for more creative results.
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●

To play a chord, click it.
The last 3 chords that you clicked are shown with a highlighted border.

●

To assign a chord to the next unassigned chord pad, right-click the suggested chord and
select Assign to Pad.
You can also drag the suggested chord and drop it on a chord pad.

●

To assign a suggestion to the next unassigned chord pad and use this chord as origin,
right-click the chord and select Assign to Pad and Use as Origin.

NOTE
The Circle of Fifths is also available in the Chord Assistant window for the chord track.

RELATED LINKS
Chord Assistant – List on page 905

Assigning Chords to Chord Pads
Some chords are preassigned to the chord pads. But you can also assign your own chords.
To assign chords to chord pads, you can use:
●

The chord Editor window

●

The Chord Assistant – Proximity window

●

The Chord Assistant – Circle of Fifths window

●

Your MIDI keyboard

●

The chord events from the chord track

Unassigning Chord Pads
You can clear all chord pads to start from scratch.
PROCEDURE
●

To the left of the chord pads, open the Functions Menu and select Unassign All Pads.
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Assigning Chords with the Chord Editor
If you know exactly which chord you want to assign to a specific chord pad, you can use the
chord editor.
PROCEDURE
1.

Move the mouse pointer to the left edge of the chord pad, and click Open Editor.

2.

In the chord Editor window, use the chord definition buttons to define a root note, a chord
type, a tension, and a bass note.
The new chord is triggered automatically to give an acoustic feedback.

Assigning Chords with the Chord Assistant – Proximity Mode
If you have a chord that you want to use as a starting point to find follow-on chords, you can use
the Chord Assistant – Proximity window.
PROCEDURE
1.

Right-click the chord pad that you want to use as a starting point and activate Use X as
Origin for Chord Assistant.

The Chord Assistant window opens, and the borders of the chord pad change their color
to indicate that the assigned chord is now used as origin.
2.

In the Chord Assistant window, click the chord symbols to trigger corresponding chords.
The farther away the chord is from the origin chord that is regarded as the tonal center,
the more complex the suggestion becomes.

3.

To assign a chord, drag it from the Chord Assistant window and drop it on a chord pad.
NOTE
If one of the next chord pads is free, you can also right-click the chord in the Chord
Assistant window and select Assign to Pad. This assigns the chord to the next free pad.

RELATED LINKS
Chord Assistant – List on page 905
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Assigning Chords with the Chord Assistant – Circle of Fifths Mode
If you have a chord that you want to use as a starting point for a chord progression, but you do
not know how to create such a progression, you can use the Chord Assistant – Circle of Fifths
window.
PROCEDURE
1.

Right-click the chord pad that you want to use as a starting point and activate Use X as
Origin for Chord Assistant.

The Chord Assistant window opens, and the borders of the chord pad change their color
to indicate that the assigned chord is now used as origin.
2.

Click 5th to switch to the circle of fifths mode.
The origin chord is displayed in the center, and the chords that belong to the scale are
shown above it. The numerals indicate the scale degree of the chords. These help you to
create chord progressions.

3.

In the Chord Assistant window, click the chord symbols to trigger the corresponding
chords.

4.

To assign a chord, drag it from the Chord Assistant window and drop it on the chord pad.
NOTE
If one of the next chord pads is free, you can also right-click the chord in the Chord
Assistant window and select Assign to Pad. This assigns the chord to the next free pad.

Assigning Chords with the MIDI Keyboard
If you know which chord you want to assign to a specific chord pad, you can use a MIDI
keyboard.
PREREQUISITE
You have selected a MIDI track or an instrument track.
PROCEDURE
1.

Right-click the chord pad that you want to use for the new chord, and select Assign Pad
from MIDI Input.
The borders of the chord pad change their color to indicate that it is now ready for
recording.

2.

On your MIDI keyboard, press the keys for the chord that you want to assign.
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The chord and its voicing is assigned to the chord pad, and you hear an acoustic feedback
of the chord.
NOTE
The assigned voicing can be changed by the Adaptive Voicing setting. Therefore, if you
want to keep the voicing for that specific pad, right-click the chord pad and select Lock
from the context menu.

RELATED LINKS
Adaptive Voicing on page 938

Assigning Chords from the Chord Track
You can assign the chord events from the chord track to the chord pads.
PROCEDURE
●

To the left of the chord pads, click the Functions Menu button, and select Assign Pads
from Chord Track.
If chords are already assigned to the chord pads, a warning message informs you that all
previous assignments will be overwritten.

RESULT
The chord events are assigned to the chord pads in the same order as they appear on the chord
track.
NOTE
Chord events that have more than one occurrence on the chord track are only assigned once.

Moving and Copying Chord Pads
You can swap the chord assignments between 2 pads or copy a specific chord and its settings
from one pad to another.
●

To swap the chord pad assignment between 2 pads, click a chord pad and drag it to
another chord pad.
While you drag, the border of the destination chord pad changes its color. When you drop
the pad on another, the chord assignments are swapped.

●

To copy the chord assignment of one chord pad to another pad, Alt-click a chord pad and
drag it to another chord pad.
While you drag, the border of the destination chord pad changes its color. When you drop
the pad on another, the first pad’s assignment is copied to the destination chord pad.

NOTE
When you move or copy chord pads, the chord is moved or copied together with its settings,
except for the Adaptive Voicings Reference.
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Playing Back and Recording Chords
Playing Back Chord Pads with your MIDI Keyboard
PREREQUISITE
You have connected and set up a MIDI keyboard.
PROCEDURE
1.

Select Project > Add Track > Instrument.

2.

In the Add Instrument Track dialog, select a VST instrument.

3.

Click Add Track.
An instrument track with the selected VST instrument is added to your project.

4.

On the instrument track, click Record Enable.

5.

Select Project > Chord Pads to open the Chord Pads at the bottom of the Project window.

6.

Press some keys on your MIDI keyboard to trigger the chords that are preassigned to the
chord pads.

RELATED LINKS
Chord Pad Settings – Remote Control on page 931
Changing the Pads Remote Range on page 935

Recording Chords on MIDI or Instrument Tracks
You can record the chords that are triggered through the chord pads on MIDI or instrument
tracks. This way, you can play back and edit your performance at any time.
PREREQUISITE
You have connected and set up a MIDI keyboard, you have opened and set up the chord pads,
and you have added an instrument or a MIDI track for which a VST instrument is loaded to your
project.
PROCEDURE
1.

On the instrument track, click Record Enable.

2.

On the Transport panel, activate Record.

3.

On your MIDI keyboard, press the keys that trigger the chord pads.
NOTE
Use the keys that are not assigned to play and record other chords.

RESULT
The triggered chords are recorded on the track. The note events are automatically assigned to
different MIDI channels according to their pitches. Note events that correspond to the soprano
voice are assigned to MIDI channel 1, alto is assigned to MIDI channel 2, and so on.
AFTER COMPLETING THIS TASK
You can now open the Key Editor and fine-tune your recorded MIDI parts using the chord
editing functions, for example. You can also use MIDI > Dissolve Part to dissolve the recorded
chords by pitches/channels.
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Recording Chords on the Chord Track
You can record the triggered chords on the chord track. This way, you can easily create chord
events for a lead sheet, for example.
PREREQUISITE
You have connected and set up a MIDI keyboard, you have opened and set up the chord pads,
and you have added an instrument or a MIDI track for which a VST instrument is loaded.
PROCEDURE
1.

On the instrument track, enable Monitor.

2.

Select Project > Add Track > Chord to add the chord track.

3.

In the Inspector for the chord track, click Record Enable.

4.

On the Transport panel, activate Record.

5.

On your MIDI keyboard, press the keys that trigger the chord pads.
NOTE
Use the keys that are not assigned to play and record other chords.

RESULT
The chord events are recorded on the chord track.
NOTE
The recorded chord events may sound different from the chord pad playback. This is because the
voicing settings for the chord track differ from the chord pad voicings.

RELATED LINKS
Chord Functions on page 902
Voicings on page 911

Chord Pad Settings – Remote Control
On the Remote Control tab in the chord pad Settings, you can change the remote key
assignments.
●

To the left of the chord pads, click Show/Hide Settings and activate the Remote Control
tab.

1

Show/Hide Settings
Opens the settings for the chord pads.

2

Pad Control
Allows you to set up remote keys for the chord pads and for voicings, tensions, and
transpose control. On the keyboard, these are highlighted in blue and in green.

3

Player Control
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Allows you to set up remote keys for the section player. On the keyboard, these are
highlighted in brown.
4

Pads Remote Range
The keys that are assigned as remote keys for the chord pads are highlighted in blue.

5

Voicings/Tensions/Transpose
The keys that are assigned as remote keys for voicings, tensions, and transpose control are
highlighted in green.

6

Section Remote Range
The keys that are assigned as remote keys for the sections are highlighted in brown.

7

Subsection Remote Range
The keys that are assigned as remote keys for the subsections are highlighted in light
green.

RELATED LINKS
Pads Remote Range on page 932
Section Remote Range on page 933
Section Player on page 936
Using Different Players on Multiple Tracks on page 940

Pads Remote Range
The pads remote range is the range of remote keys that trigger the chords that are assigned to
the chord pads.
●

Select Remote Control > Pad Control to open the settings for the pads remote range.

●

Select Remote Control to open the settings for the pads remote range.

1

Pads Remote Range
Allows you to set the start and end note for the remote range.
By default, Range Start is set to C1 and Range End to B1. This is indicated by the
corresponding keys on the keyboard in the chord pads being highlighted in blue. You can
trigger the chords that are assigned to the chord pads by hitting the keys that correspond
to this note range on your MIDI keyboard.

2

Voicings/Tension/Transpose
Allows you to assign remote keys for changing the voicings, tension, and transposition
settings of the last played chord pad. You can also assign continuous controllers to change
all chord pads simultaneously.
The remote keys for voicings, tensions, and transpose are highlighted in green.

3

MIDI Learn
Activates/Deactivates the MIDI learn function to assign MIDI input to the pads remote
range, and to the parameters for changing voicings, tensions, and transpose.

4

Activate
Activates/Deactivates the remote key assignment for the parameters voicings, tensions,
and transpose. If this option is deactivated, only the remote key assignment for the pads
remote range is active.
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5

Latch Chords
Activate this if you want the chord pad to play back until it is triggered again.

NOTE
●

If you use MIDI controllers that are already assigned to other remote control features, for
example, the Track Quick Controls or the VST Quick Controls, all previous assignments are
lost.

●

If you use MIDI controllers that are already assigned to other remote control features, for
example, the VST Quick Controls, all previous assignments are lost.

Section Remote Range
The section remote range is the range of remote keys that trigger the chord notes that
correspond to the sections.
●

Select Remote Control > Player Control to open the settings for the section remote
range.

1

Sections
Allows you to assign remote keys for up to 5 sections. You can use the section remote keys
together with a pad remote key to trigger the chord notes that correspond to the sections.
By default, Section 1 is set to G2, Section 2 is set to A2, Section 3 is set to B2, and Section
4 is set to C3. This is indicated by the corresponding keys on the keyboard in the chord
pads being highlighted in brown.

2

Subsections
Allows you to assign remote keys for up to 5 subsections. You can use the subsection
remote keys together with a pad remote key to trigger the chord notes that correspond to
the section transposed by the offset that is specified by its subsection.
There are no default remote keys for subsections. If you set remote keys for subsections,
the corresponding keys on the keyboard in the chord pads are highlighted in light green.

3

Select/Mute Player
Allows you to assign remote keys for player navigation and muting if you use different
players on multiple tracks.

4

MIDI Learn
Activates/Deactivates the MIDI learn function to assign MIDI input to sections,
subsections, and to the parameters for selecting and muting players.

RELATED LINKS
Section Player on page 936

Default Remote Assignment
Default Remote Assignment for Pad Control
By default, the MIDI events C1 to B1 trigger the chords that are assigned to the chord pads. All
keys that are not assigned for remote control can be used for regular playback.
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You can change the voicing, tension, or transposition of the triggered chord by enabling Activate
in the lower part of the Remote Control tab and using the following default remote notes:
Action

Description

Remote Note

Voicings: Previous

Plays back the previous
voicing of the last played
chord.

C2

Voicings: Next

Plays back the next voicing of
the last played chord.

C#2

Voicings for all chord pads

The wheel position
determines the voicings for
the next played chords of all
chord pads.

CC 1 Modulation wheel

Tensions: Less

Plays back the last played
chord with fewer tensions.

D2

Tensions: More

Plays back the last played
chord with more tensions.

D#2

Tensions for all chord pads

Allows you to determine the
CC 16
tension level for the next
played chord of all chord pads.

Transpose: Down

Plays back the last played
chord and transposes it
downwards.

E2

Transpose: Up

Plays back the last played
chord and transposes it
upwards.

F2

Transpose all chord pads

The wheel position
determines the transposition
value for the next played
chords of all chord pads.
Moving the wheel all the way
up or all the way down
corresponds to +/-5
semitones.

Pitchbend wheel

Remote assignments are saved globally.
NOTE
If you use the remote keys for voicings, tensions, or transposition after releasing the remote key
for the chord pad, the next played chord is affected.

Default Remote Assignment for Player Control
By default, the MIDI events G2 to B2 trigger the chord notes corresponding to the sections.
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The remote keys for Subsections, and also for selecting or muting players in a multitrack project,
are not assigned by default.
Remote assignments are saved globally.

Changing the Pads Remote Range
You can widen the pads remote range to access more chord pads. If you want to use a wider key
range on your MIDI keyboard for regular playing, you can narrow the pads remote range.
PROCEDURE
1.

Select Show/Hide Settings > Remote Control to open the remote control assignments.

2.

Do one of the following:
●

Click MIDI Learn so that the button lights up, and on your MIDI keyboard, press the
2 keys that you want to assign as range start and range end.

●

Enter a new value in the Range Start and Range End fields.

RESULT
On the keyboard, the indication for pads remote range is changed.

Chord Pad Settings – Players
On the Players tab in the chord pad Settings, you can change the voicing that is used for the
chord pads. You can select different players with specific voicing settings that are typical for that
kind of player. By default, the Piano Player option is active. By selecting Plain Chords, Pattern,
or Sections, you can determine how the notes of a chord are played.
●

To the left of the chord pads, click Show/Hide Settings and activate the Players tab.

1

Show/Hide Settings
Opens the settings for the chord pads.

2

Player Selection
Selects the player, and uses its voicing for the chord pads.

3

4

Plain Chords/Pattern/Sections
●

Select Plain Chords to trigger all notes of a chord simultaneously.

●

Select Pattern to break up the chords into their individual notes.

●

Select Sections to control the playback of single notes or groups of notes of a chord.

Manage Players
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Opens a menu where you can select the player that you want to add. From here, you can
also rename or remove the current player.
5

Overlaps
When you play a chord without releasing the previous chord, this option allows you to
select what happens with the notes of the first chord.

6

●

Select Hold First to hold the notes of the first chord. No note-off message is sent. If
the chords have common notes, these are not triggered again.

●

Select Legato to release the notes of the first chord, except for the common notes.
These are held and not triggered again.

●

Select Stop First to release the notes of the first chord including the common notes.

Filter Notes
Allows you to select which keys are filtered.
●

Select Off to filter nothing.

●

Select From MIDI Thru to filter unassigned keys, and keys that are assigned as
remote keys for voicings, tensions, and transpose.

●

Select From Chord Pads to filter keys that are assigned as remote keys for chord
pads, voicings, tensions, and transpose.

●

Select All to filter everything.

RELATED LINKS
Players and Voicings on page 938
Voicings on page 911
Chord Pad Settings – Players on page 935

Section Player
The section player allows you to control the playback of single notes or groups of notes, so called
sections, of a chord that is assigned to a chord pad.
Sections hold the chord notes, starting from bottom to top: the first section represents the
lowest note or voicing of a chord, usually the bass. The second section represents the tenor, and
so on.
You can play the sections and their corresponding chord notes by using the remote keys that are
assigned to them together with the remote keys that are assigned to a chord pad. To view and
edit the assignment, you can open the Remote Control tab.
The Pad Control tab shows the remote key assignment for the chord pads. The Player Control
tab shows the remote key assignment for the sections.
RELATED LINKS
Chord Pad Settings – Remote Control on page 931
Custom Settings for Section Player on page 936

Custom Settings for Section Player
The custom settings for the section player allow you to determine how the sections are
triggered, how they are distributed, or if they are played at all. Only sections with remote keys
assigned are available.
●

On the Players tab, activate the Sections tab and click Custom.
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The following settings are available:

Play Modes
●

Sections
On your MIDI keyboard, first press a key that is assigned to a chord pad, then
press the remote key for a specific section to hear the chord notes that
correspond to the section.

●

Chord Pads
On your MIDI keyboard, first press the remote key for a specific section, then
press a key that is assigned to a chord pad to hear the chord notes that
correspond to the section.

●

Combination
Combines sections and chord pads so that it does not matter whether you first
press the remote key for the chord pad or for the section.

For sections and combination modes you can activate Latch Chord Pads. This way, if
you release the remote key for the chord pad, you will still hear the sections if you
keep the section remote keys pressed.
Chord Note Distribution
Here, you can determine how chord notes are distributed among the sections if the
chord that is assigned to the chord pad has more notes than sections.
Mute Sections
Activate this option to exclude a section from being played. This is useful if you want
to exclude specific voicings from playback.
Subsection Assignments
These are available if you have set up remote keys for subsections on the Remote
Control tab in the Player Control settings.
●

Open the assigned to pop-up menu to assign a subsection to a section.

●

Use the Offset controls to specify an offset from the section. This way, when
you press the remote key for the subsection, you will hear the chord notes that
correspond to the section, transposed by the specified offset.
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NOTE
To set Play Modes, Chord Note Distribution, and Mute Sections to their default settings, close
the Custom Settings for Section Player pane and click Default.

Playing Back Chord Sections
You can play back single chord notes or chord sections of a chord pad.
PREREQUISITE
You have added an instrument track with an instrument assigned to your project. You have
record-enabled the instrument track. You have a MIDI keyboard connected and set up.
PROCEDURE
1.

In the chord pads, activate Show/Hide Settings.

2.

Open the Players tab, and activate Sections.
On the keyboard, the remote range for the sections is highlighted in orange.

3.

On your MIDI keyboard, press any key that corresponds to the pads remote range.
This normally triggers the chord pad, however, in sections mode, you do not hear anything
until you press a section remote key.

4.

On your MIDI keyboard, press any key that corresponds to the section remote range.

RESULT
The chord section of the chord whose chord pad you triggered is played back. You can press any
other key in the section remote range to play different sections of the same chord, or press them
all at once. You can use the remote keys for voicing, tension, and transpose to add variety.

Players and Voicings
Different types of instruments and styles have different voicing libraries. These determine how
the chords are played back, and which pitches are played. These voicings are referred to as
players.
RELATED LINKS
Voicings on page 911

Adaptive Voicing
In Nuendo, the adaptive voicing setting ensures that pitches in chord progressions do not
change abruptly.
Adaptive voicing is activated and the voicings of the chord pads are determined automatically
according to specific voice leading rules.
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If you want to set the voicing of a specific chord pad manually, and do not want it changed
automatically, you can use the voicing control to the right of a chord pad. When you assign your
own voicing, adaptive voicing is deactivated for that chord pad, so that the pad does no longer
follow the voice leading rules of the voicing reference. To activate adaptive voicing again, rightclick the chord pad and activate Adaptive Voicing.
To lock the voicing for a chord pad, you can right-click the pad and activate Lock. This locks this
pad for editing and remote control changes, and deactivates Adaptive Voicing. To unlock the
chord pad again, right-click the pad and deactivate Lock.

Pattern Player
The pattern player allows you to break up the triggered chord to individual notes that are played
back one after another (arpeggio).

Using the Pattern Player
The pattern player plays the notes that make up the chord one after another (arpeggio).
PROCEDURE
1.

Select Show/Hide Settings > Players > Pattern.

2.

Perform one of the following actions:
●

Click Import MIDI Loop to select a MIDI loop that you want to use as a pattern.

●

Drag a MIDI part from the event display to the Drop MIDI Part field.

NOTE
The loop or part must have between 3 and 5 voices. In the MediaBay, the number of
voices is indicated in the Voices column of the result list.
The loop or part is taken as a reference and defines how the chord is played. The Drop
MIDI Part field displays the name of the selected loop or part.
3.

In the Velocity from: field, select a velocity source for the notes.
●

Activate MIDI Keyboard to determine the velocity values by pressing the keys on
your MIDI keyboard harder or softer.

●

Activate Pattern to use the velocity values from the MIDI loop or the MIDI part that
is selected as a pattern.

AFTER COMPLETING THIS TASK
If you have a pattern that you want to use in other projects, you can save it using the presets
section in the pattern player.
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RELATED LINKS
Assigning Voices to Notes on page 917
Setting Up the Results List Columns on page 618

Using Different Players on Multiple Tracks
You can set up different players with different sounds on different tracks. If you record-enable
these tracks and play the chord pads, each track uses a dedicated player.
PROCEDURE
1.

Select Project > Add Track > Instrument.

2.

In the Add Instrument Track dialog, enter the number of tracks in the Count field, and
select a VST instrument.

3.

Click Add Track.
The instrument tracks are added to your project.

4.

Select Project > Chord Pads to open the chord pads.

5.

To the left of the chord pads, activate Show/Hide Settings and click Players.

6.

Select the first instrument track, select a sound on the VST instrument, and in the chord
pads, select a player.
For example, select a piano sound and assign a Piano Player.
NOTE
When setting up the player for a track, make sure that Record Enable or Monitor is only
active for this particular track.

7.

Select the second instrument track, select a sound on the VST instrument, and set up
another player.
For example, select a guitar sound and assign a Guitar Player.

8.

Select the next instrument track, and proceed as for the other 2 tracks.
For example, select a string sound and assign a Basic Player.

9.

Select all instrument tracks, and click Record Enable.

RESULT
You can now play the chord pads and use the remote control parameters for tensions and
transpose to change all chord symbols for each player simultaneously. However, if you change
the Voicing, only the selected player is affected.

Chord Pad Settings – Pad Layout
The Pad Layout tab in the chord pad Settings allows you to change the layout that is used for
the chord pads. By default, the keyboard layout is active, but you can change to a grid layout if
you prefer that. After changing the pad layout you may need to adjust the remote setup.
●

To the left of the chord pads, click Show/Hide Settings and activate the Pad Layout tab.

1

Show/Hide Settings
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Opens the settings for the chord pads.
2

Keyboard
Activate this to show the chord pads in a keyboard layout. You can display 1 or 2 octaves,
and you can select if the first chord pad starts with C, A or E.

3

Grid
Activate this to show the chord pads in a grid layout. You can display up to 4 rows and 16
columns.

4

Layout display
Shows how the active chord pad layout is displayed.

Chord Pads Presets
Chord pads presets are templates that can be applied to newly created or to existing chord pads.
Chord pads presets contain the chords that are assigned to the chord pads, as well as the player
configurations including any pattern data that you have imported via the MediaBay or by using
drag & drop. The chord pads presets allow you to quickly load chords, or reuse player settings.
The chord pads presets menu is located to the left of the chord pads. Chord pads presets are
organized in the MediaBay, and you can categorize them with attributes.
●

To save/load a chord pads preset, select Chord Pads Presets > Save/Load Chord Pads
Preset.

You can also load only the assigned chords from a chord pads preset, without loading the player
configurations. This is useful if you want to use specific chords that you have saved as a preset,
but do not want to alter your current player setting.
●

To load only the chords of a chord pads preset, select Chord Pads Presets > Load Chords
from Preset.

In the same way, you can also load only the player configurations of a chord pads preset. This is
useful if you have saved very complex player settings and want to reuse them on other chord
pads without changing the assigned chords.
●

To load only the player settings of a chord pads preset, select Chord Pads Presets > Load
Players from Preset.

Saving Chord Pads Presets
If you have set up the chord pads, you can save them as chord pads presets.
PROCEDURE
1.

To the left of the chord pads, select Chord Pads Preset > Save Chord Pads Preset.

2.

In the New Preset section, enter a name for the new preset.
NOTE
You can also define attributes for the preset.

3.

Click OK to save the preset and exit the dialog.

Creating Events from Chord Pads
You can use the chords assigned to the chord pads to create chord events or MIDI parts in the
Project window.
●

To create a chord event, drag a chord pad and drop it on the chord track.
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●

To create a MIDI part with the length of one bar, drag a chord pad and drop it on a MIDI or
instrument track.

RELATED LINKS
Recording Chord Events with a MIDI Keyboard on page 918
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The Logical Editor is a powerful tool for search and replace functions on MIDI data.
The principle of the Logical Editor is this:
●

You set up filter conditions to find certain elements.
This can be elements of a certain type, with certain attributes or values or on certain
positions, in any combination. You can combine any number of filter conditions and make
composite conditions using And/Or operators.

●

You select the basic function to be performed.
The options include Transform, for changing properties of the found elements, Delete,
for removing the elements, Insert, for adding new elements based on the found positions
of other elements, and more.

●

You set up a list of actions, which specify exactly what is done.
This is not necessary for all functions.

By combining filter conditions, functions and the specific actions, you can perform very powerful
processing.
To master the Logical Editor, you need some knowledge about how MIDI messages are
structured. However, the Logical Editor also comes with a rich selection of presets, allowing you
to access its processing powers without delving into its more complicated aspects.
IMPORTANT
Studying the included presets or using them as starting points to set up your own actions is an
excellent way to learn the workings of the Logical Editor.

RELATED LINKS
Presets on page 957

Window overview
The Logical Editor window allows you to combine filter conditions, functions, and actions to
perform very powerful MIDI processing.
●

To open the Logical Editor, select MIDI > Logical Editor.
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1

Filter Conditions
Allows you to specify the conditions such as type, attribute, value, position, that a specific
element must meet to be found. You can combine any number of filter conditions using
AND/OR operators.

2

Action List
Allows you to set up a list of actions that specifies exactly what is done. This is not
necessary for all functions.

3

Function pop-up menu
Allows you to select a function.

4

Apply
Applies your settings.
NOTE
This button is not available in the Transformer.

Filter Conditions
The upper list is where you set up the filter conditions, determining which elements to find. The
list can contain one or several conditions, each on a separate line.
To set up a filter condition, make the following settings:
Filter Target
Sets the property of the element. This setting affects the available options in the
other columns.
Condition
Determines how the Logical Editor compares the property in the Filter Target
column to the values in the Parameter columns. The available options depend on
the Filter Target setting.
Parameter 1
Sets which value the element properties are compared to. This depends on the Filter
Target.
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Parameter 2
Only available if one of the Range options is set in the Condition column. Allows you
to find all elements with values inside or outside the range between Parameter 1
and Parameter 2.
Bar Range/Time Base
Only available if the Filter Target is set to Position. If one of the Bar Range options
is selected in the Condition column, you use the Bar Range/Time Base column to
specify zones within each bar. This allows you to find all elements on or around the
first beat of every bar, for example. If any of the other Condition options is selected,
you can use the Bar Range/Time Base column to specify a time base such as PPQ,
seconds, etc.
NOTE
This is only available in the Logical Editor.
Left bracket
Together with the right bracket, this allows you to combine multiple filter conditions,
that is multiple lines with the boolean operators And/Or.
Right bracket
Together with the left bracket, this allows you to combine several filter conditions.
bool
Allows you to insert the boolean operators And/Or, when creating conditions with
multiple lines.
NOTE
If you make a mistake when combining multiple conditions with brackets, you are
informed in the status line.
NOTE
If you have already defined filter conditions and/or applied a preset, but want to start again from
scratch, you can initialize the settings by selecting the Init option from the Presets pop-up
menu.
NOTE
You can also set up filter conditions by dragging MIDI events directly into the upper list.
If the list contains no entries, a MIDI event dragged into this section will form conditions
including the state and type of the event. If it contains entries, the dragged event will initialize
the matching parameters. For example, if a length condition is used, the length will be set
according to the length of the event.
Depending on the Filter Target setting, the following options can be selected in the Condition
column:
Equal
Has the exact same value as set up in the Parameter 1 column.
Unequal
Has any value other than the one set up in the Parameter 1 column.
Bigger
Has a value higher than the one set up in the Parameter 1 column.
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Bigger or Equal
Has a value that is the same as or higher than the one set up in the Parameter 1
column.
Less
Has a value lower than the one set up in the Parameter 1 column.
Less or Equal
Has a value that is the same as or lower than the one set up in the Parameter 1
column.
Inside Range
Has a value that is between the values set up in the Parameter 1 and Parameter 2
columns. Note that Parameter 1 should be the lower value and Parameter 2 the
higher.
Outside Range
Has a value that is not between the values set up in the Parameter 1 and Parameter
2 columns.
Inside Bar Range (Logical Editor only)
Is within the zone set up in the Bar Range/Time Base column, in each bar within the
current selection. This is only used if the Filter Target is set to Position.
Outside Bar Range (Logical Editor only)
Is outside the zone set up in the Bar Range/Time Base column, in each bar within
the current selection. This is only used if the Filter Target is set to Position.
Before Cursor (Logical Editor only)
Is before the song cursor position. This is only used if the Filter Target is set to
Position.
Beyond Cursor (Logical Editor only)
Is after the song cursor position Position only.
Inside Track Loop (Logical Editor only)
Is inside the set track loop. This is only used if the Filter Target is set to Position.
Inside Cycle (Logical Editor only)
Is inside the set cycle. This is only used if the Filter Target is set to Position.
Exactly Matching Cycle (Logical Editor only)
Exactly matches the set cycle. This is only used if the Filter Target is set to Position.
Note is equal to
Is the note specified in the Parameter 1 column, regardless of octave only. For
example, lets you find all C notes, in all octaves. This is only used if the Filter Target
is set to Pitch.
NOTE
The conditions for the Property filter target are different.

RELATED LINKS
Combining Multiple Condition Lines on page 968
Searching for Properties on page 950
Searching for Elements at Specific Positions (Logical Editor only) on page 947
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Searching for Elements at Specific Positions (Logical Editor only)
You can search for elements starting at specific positions, either relative to the start of the
project or within each bar.
PROCEDURE
1.

Open the Filter Target pop-up menu and select Position.
This allows you to find elements starting at specific positions, either relative to the start of
the project or within each bar.

2.

Open the Condition pop-up menu and select one of the following options:
●

To find all elements at a specific position, select a position in the Parameter 1
column.
You can set a time base such as PPQ, seconds, samples, or frames in the Bar Range/
Time Base column.

●

To find all elements inside or outside a range, select Inside Bar Range or Outside
Bar Range.
You can set the bar range in the Bar Range/Time Base column by clicking and
dragging in the bar display or by adjusting the start position of the range in the
Parameter 1 column and the end position in the Parameter 2 column. You can
change the time base use the Bar Range/Time Base column. The position for Bar
Range is measured in ticks related to the start of the bar.

EXAMPLE
You can set up the Logical Editor to find all elements at 1.1.1.0 in the project.

You can set up the Logical Editor to find elements starting around the second beat in each bar.

Searching for Notes of Specific Lengths (Logical Editor only)
You can search for notes of specific lengths.
PROCEDURE
1.

Open the Filter Target pop-up menu and select Length.
This allows you to find notes of a specific length only.
NOTE
The Length parameter is interpreted via the time base setting in the Bar Range/Time
Base column, that is, in PPQ, seconds, samples, or frames.

2.

Open the Parameter 1 pop-up menu and set the length that you want to search for.

3.

Open the Condition pop-up menu and select an option.
If you select Inside Range or Outside Range, use Parameter 1 and Parameter 2 to set
the start and the end of the range.

4.

Click

below the list to add another condition line.

Parameter 1 is automatically set to Note as the Length Filter Target is only valid for
notes.
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RELATED LINKS
Combining Multiple Condition Lines on page 968

Value 1 and Value 2
MIDI events can be composed of value 1 and value 2.
Value 1 and value 2 have different meanings for different event types:
Event type

Value 1

Value 2

Notes

The Note Number/Pitch.

The velocity of the note.

Poly Pressure

The key that was pressed.

The amount of pressure for
the key.

Controller

The type of Controller,
displayed as a number.

The amount of Control
Change.

Program Change

The Program Change number. Not used.

Aftertouch

The amount of pressure.

Not used.

Pitchbend

The “fine-tune” of the bend.
Not always used.

The coarse amount of bend.

VST 3 Event

Not used.

The value of the VST 3 Event
parameter. The value range of
the VST 3 event (0.0 to 1.0) is
transformed into the MIDI
value range (0-127), that is,
the VST 3 event value 0.5
corresponds to 64. For some
operations that require a
higher resolution, you can
make use of the “VST 3 Value
Operation” parameter.

NOTE
System Exclusive events do not use value 1 and 2.

RELATED LINKS
Action Target on page 970

Searching for Note Pitches or Velocities
PROCEDURE
1.

Open the Filter Target pop-up menu and select Value 1 for pitches, or Value 2 for
velocities.

2.

Optional for pitches: In the Parameter 1 column, enter a pitch either as note name such
as C3, D#4, etc. or as a MIDI note number from 0 to 127.
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NOTE
To find all notes of a certain key, in all octaves, open the Condition pop-up menu and
select Note is equal to.
3.

Click

below the list to add another condition line.

Parameter 1 is automatically set to Note. Also, Value 1 and Value 2 will be displayed as
Pitch and Velocity respectively.

RELATED LINKS
Combining Multiple Condition Lines on page 968

Searching for Controllers
PROCEDURE
1.

Open the Filter Target pop-up menu and select Value 1.

2.

Click

3.

below the list to add another condition line.

Open the Parameter 1 pop-up menu and select Controller.
Value 1 is automatically set to MIDI Controller No. and the Parameter 1 column will
show the names of the MIDI controllers.

RELATED LINKS
Combining Multiple Condition Lines on page 968

Searching for MIDI Channels
Searching for MIDI channels is useful if you have recorded MIDI from an instrument sending on
several different channels. Or if you have imported a MIDI file of type 0 with a single track,
containing MIDI events with different channel settings.
PROCEDURE
1.

Open the Filter Target pop-up menu and select Channel.

2.

In the Parameter 1 field, enter a MIDI channel from 1 to 16.

3.

Open the Condition pop-up menu and select an option.

Searching for Element Types
PROCEDURE
1.

Open the Filter Target pop-up menu and select Type.

2.

Open the Parameter 1 pop-up menu and select a type such as note, poly pressure,
controller, etc.

3.

Open the Condition pop-up menu and select an option.
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Searching for Properties
You can search for properties that are not part of the MIDI standard but rather Nuendo-specific
settings.
PROCEDURE
1.

Open the Filter Target pop-up menu and select Property.

2.

Open the Parameter 1 pop-up menu and select the property that you want to search for.

3.

Open the Condition pop-up menu and select one of the following options:
●

Select Property is set if you want to search for events that have the specified
property.

●

Select Property is not set if you want to search for events that do not have the
specified property.

EXAMPLE
You can set up the Logical Editor to find all muted events.

You can set up the Logical Editor to find events that are selected and muted.

You can set up the Logical Editor to find all Note Expression data.

You can set up the Logical Editor to find all MIDI controller events that form part of note
expression data.

You can set up the Logical Editor to find all VST 3 events that cannot be played back, because
there is no Note Expression compatible VST instrument on the related track.

Searching for Event Contexts
You can perform context-dependent searches. This is especially useful in the Input Transformer.
The Filter Target Last Event indicates the state of an event which has already passed the Input
Transformer or the Logical Editor. The condition must be combined with Parameter 1 and
Parameter 2.
EXAMPLE
You can set up the Logical Editor to perform actions only when the sustain pedal is down.

You can set up the Input Transformer or the Transformer to perform actions only when the
note C1 is pressed.
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In this example, the action is performed after playing the C1.

Searching for Chords (Logical Editor only)
You can search for chords in a MIDI part or on the chord track.
PREREQUISITE
NOTE
A note belongs to a chord if at least 2 other notes play at the same time.

PROCEDURE
1.

Open the Filter Target pop-up menu and select Context Variable.

2.

Open the Parameter 1 pop-up menu and select the property that you want to search for.

3.

Open the Condition pop-up menu and select an option.

Chords Filter
If the Filter Target is set to Context Variable, you can search for the following parameters:
Highest/Lowest/Average Pitch
Finds notes with the highest, lowest or average pitch in the selected MIDI part.
Highest/Lowest/Average Velocity
Finds notes with the highest, lowest or average velocity in the selected MIDI part.
Highest/Lowest/Average CC Value
Controllers with the highest, lowest or average value in the selected MIDI part.
The following settings for Parameter 1 require a Parameter 2:
Number of Notes in Chord (Part)
If you set Parameter 2 to the number of notes in the chord, this finds chords with
the specified number of notes in the selected MIDI part.
Number of Voices (Part)
If you set Parameter 2 to the number of voices of the chord, this finds chords with
the specified number of voices in the selected MIDI part.
Position in Chord (Part)
If you set Parameter 2 to the position in the chord, this finds chords with the
specified chord interval in the selected MIDI part.
Note Number in Chord (lowest = 0)
If you set Parameter 2 to the voicing number of chord, this finds chords with the
specified voicing number in the selected MIDI part.
Position in Chord (Chord track)
If you set Parameter 2 to the position in the chord, this finds the specified chord
interval in the selected MIDI part. The Chord track is taken as reference.
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Voice
If you set Parameter 2 to the voice in the chord, this finds the specified voice in the
selected MIDI part.
NOTE
The Musical Context presets give you an idea of the possibilities of this filter target.

Combining multiple condition lines
You can add condition lines and combine them by using boolean And and Or operators and
brackets.
●

To add a new condition, click

below the list.

The new line is added at the bottom of the list.
●

To remove a condition, select it and click

below the list.

The Bool column
In the bool column to the right in the list, you can select a boolean operator: And or Or.
A boolean operator combines 2 condition lines and determines the result in the following way:
●

And determines that both conditions must be fulfilled for an element to be found.

●

Or determines that at least one of the conditions must be fulfilled for an element to be
found.

IMPORTANT
When you add a new condition line, the boolean setting defaults to And.
EXAMPLE
You can set up the Logical Editor to find elements that are notes and start at the beginning of
the third bar.

You can set up the Logical Editor to find all events that are notes (regardless of their position)
and all events starting at the beginning of the third bar (regardless of their type).

Using brackets
The bracket columns let you enclose 2 or more condition lines, dividing the conditional
expression into smaller units. This is only relevant when you have 3 or more condition lines and
want to use the boolean Or operator.
You add brackets by clicking in the bracket columns and selecting an option. Up to triple brackets
can be selected.
You can add brackets by clicking in the bracket columns and selecting an option. Up to triple
brackets can be selected.
If you add several layers of brackets, these are evaluated from the inside out, starting with the
innermost brackets.
Expressions within brackets are evaluated first.
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EXAMPLE
You can set up the Logical Editor to find all MIDI notes with the pitch C3, as well as all events
(regardless of their type) set to MIDI channel 1.

You can set up the Logical Editor to find all notes that either had the pitch C3 or the MIDI
channel 1 (but no non-note events).

Selecting a function
The pop-up menu at the bottom of the Logical Editor is where you select the function, that is,
the basic type of editing to be performed.

Below, the available options are listed.
NOTE
Some options are not available in the Transformer effect.
Delete
Deletes all elements found by the Logical Editor. In the case of the Transformer,
this function will remove or mute all found elements from the output stream. The
actual elements on the track are not affected.
Transform
Changes one or several aspects of the found elements. You set up exactly what is
changed in the action list.
Insert
Creates new elements and inserts these into the parts (Logical Editor) or the output
stream (Transformer). The new elements will be based on the elements found by the
filter conditions, but with any changes you have set up in the action list applied.
Another way of expressing this is that the Insert function copies the found elements,
transforms them according to the action list and inserts the transformed copies
among the existing elements.
Insert Exclusive
Transforms the found elements according to the action list. All elements that do not
meet the filter conditions are deleted (Logical Editor) or removed from the output
stream (Transformer).
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Copy (Logical Editor only)
Copies all found elements, transforms them according to the action list and pastes
them into a new part on a new MIDI track. The original events are not affected.
Extract (Logical Editor only)
Transforms all found events and moves them to a new part on a new MIDI track.
Select (Logical Editor only)
Selects all found events and highlights them for further work in the regular MIDI
editors.
RELATED LINKS
Specifying actions on page 954

Specifying actions
You can specify actions, that is, changes that are made to the found elements, in the lower list of
the Logical Editor. Actions are relevant for all function types except Delete and Select.

You can add action lines by clicking

, and remove them by selecting it and clicking

.

Action Target
The Action Target allows you to select the property that is changed in the events.
Position (Logical Editor only)
Moves the events.
Length (Logical Editor only)
Resizes note events.
Value 1
Adjusts value 1 in the events. What is displayed for value 1 depends on the event
type. For notes, value 1 is the pitch.
Value 2
Adjusts value 2 in the events. What is displayed for value 2 depends on the event
type. For notes, value 2 is the velocity value.
Channel
Allows you to change the MIDI channel setting.
Type
Allows you to change the event type, that is, transform aftertouch events to
modulation events, or pitchbend events to VST 3 Tuning events.
Value 3
Adjusts value 3 in the events, which is used for handling of Note-off velocity when
searching for properties.
NoteExp Operation (Logical Editor only)
Allows you to specify a Note Expression operation in the Operation column.
VST 3 Value Operation (Logical Editor only)
Allows you to perform common operations within the VST 3 value range (0.0 to 1.0)
instead of the standard MIDI value range (0-127), for finer adjustments.
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NOTE
The Position and Length parameters are interpreted via the time base setting in the Bar Range/
Time Base column, with the exception of the Random setting, which uses the time base of the
affected events.

RELATED LINKS
Searching for Properties on page 950
Value 1 and Value 2 on page 948

Operation
The Operation allows you to determine what to do with the Action Target.
The options on this pop-up menu are different depending on the selected Action Target.
Add
Adds the value specified in the Parameter 1 column to the Action Target.
Subtract
Subtracts the value specified in the Parameter 1 column from the Action Target.
Multiply by
Multiplies the Action Target with the value specified in the Parameter 1 column.
Divide by
Divides the Action Target by the value specified in the Parameter 1 column.
VST 3 Value Operation – Invert (Logical Editor only)
Inverts note expression data containing the specified VST 3 event parameter.
Round by
Rounds the Action Target value using the value specified in theParameter 1
column.
Set Random Values between
Sets the Action Target value to a random value within the range specified with
Parameter 1 and Parameter 2.
Set to fixed value
Sets the Action Target to the value specified in the Parameter 1 column.
Set Relative Random Values between
Adds a random value to the current Action Target value. The added random value
will be within the range specified with Parameter 1 and Parameter 2. Note that
these can be set to negative values.
Add Length (Logical Editor only)
This is only available if you set Action Target to Position. Furthermore, it is only
valid if the found events are notes. If you select Add Length, the length of each note
event is added to the Position value.
Transpose to Scale
This is only available if you set Action Target to Value 1, and if the filter conditions
are specifically set up to find notes (a Type = Note filter condition line has been
added). When Transpose to Scale is selected, you can specify a musical scale using
the Parameter 1 and Parameter 2 columns. Parameter 1 is the key (C, C#, D, etc.)
while Parameter 2 is the type of scale (major, melodic or harmonic minor, etc.).
Each note will be transposed to the closest note in the selected scale.
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Use Value 2
This is only available if you set Action Target to Value 1. If this option is selected, the
Value 2 setting in each event will be copied to the Value 1 setting.
Use Value 1
This is only available if you set Action Target to Value 2. If this option is selected, the
Value 1 setting in each event will be copied to the Value 2 setting.
Mirror
This is only available if you set Action Target to Value 1 or Value 2. When this option
is selected, the values are mirrored around the value set in the Parameter 1 column.
In the case of notes, this inverts the scale, with the key set in the Parameter 1
column as center point.
Linear Change in Loop Range (Logical Editor only)
This affects events between the left and right locators only. It creates a linear ramp
of values (replacing the original values) starting at the value in the Parameter 1
column and ending at the Parameter 2 value.
Relative Change in Loop Range (Logical Editor only)
This will create a ramp of values, affecting events in the loop range only, that is,
between the locators. However, here the changes are relative, meaning that values
will be added to the existing values.
In other words, you set up a value ramp starting at Parameter 1 and ending at
Parameter 2 (note that the values can be negative). The resulting value ramp is then
added to the existing values for the events within the loop range.
For example, if you apply this to note velocities with Parameter 1 set to 0 and
Parameter 2 set to -100, you create a velocity fade-out, keeping the original velocity
relations:

NoteExp Operation – Remove Note Expression (Logical Editor only)
This option is only available for notes. It allows you to remove all note expression
data from a note.
NoteExp Operation – Create One-Shot (Logical Editor only)
This option is only available for notes. It allows you to add note expression data for
notes in One Shot mode, meaning that you add a parameter as note expression
data. After having added the one-shot parameter, you have to set it to the desired
value in a second go.
NoteExp Operation – Reverse (Logical Editor only)
Reverses the note expression data.
RELATED LINKS
Value 1 and Value 2 on page 948
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Applying the Defined Actions
Once you have set up filter conditions, selected a function and set the required actions or loaded
a preset, you apply the actions defined with the Logical Editor by clicking the Apply button.
IMPORTANT
The MIDI insert effect Transformer does not feature an Apply button. Here, the current settings
are automatically applied in realtime during playback or live playing.
Logical Editor operations can be undone just like any other editing.

Presets
The section in the upper left section of the window allows you to load, save and manage Logical
Editor presets.
To load a preset, do one of the following:
●

Open the Select Preset pop-up menu, and select an option.

●

Select MIDI > Logical Presets, and select an option.

●

Open the List Editor and in the filters bar, select a preset from the Show section.

NOTE
If you set up a key command for a preset you can conveniently apply the same operation to
several selected events in one go.

RELATED LINKS
Key Commands on page 1137

Storing your own settings as a preset
You can save settings that you want to use again as presets.
PROCEDURE
1.

In the section in the upper left of the Logical Editor, click Store Preset.

2.

In the dialog that opens, specify a name for the preset and click OK.

RESULT
The preset is stored.
NOTE
To remove a preset, load it and click the Remove Preset button.

Organizing and sharing presets
The Logical Editor presets are stored within the application folder in the Presets\Logical Edit
Project subfolder.
Preset files cannot be edited manually, but you can reorganize them. This also makes it easy to
share presets with other Nuendo users, by transferring the individual preset files.
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NOTE
The list of presets is read each time the Logical Editor is opened.
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The Project Logical Editor is a powerful tool for search and replace functions in the Project
window.
The Project Logical Editor allows you to specify filter conditions and combine them with actions.
This way you can search for all open folder tracks in your project, for example, and close them.
The Project Logical Editor comes with a number of presets that show you the possibilities of this
feature, and that you can use as a starting point for your own settings.
RELATED LINKS
Presets on page 973
Window Overview on page 959

Window Overview
The Project Logical Editor window allows you to combine filter conditions, functions, actions,
and macros to perform very powerful processing.
●

To open the Project Logical Editor, select Edit > Project Logical Editor.

1

Filter Conditions
Allows you to specify the conditions such as type, attribute, value, position, that a specific
element must meet to be found. You can combine any number of filter conditions using
AND/OR operators.

2

Action List
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Allows you to set up a list of actions that specifies exactly what is done. This is not
necessary for all functions.
3

Function pop-up menu
Allows you to select if the found elements are transformed, deleted, or selected.

4

Macro pop-up menu
Allows you to select a macro.

5

Apply
Applies your settings.

IMPORTANT
Not every combination of settings always makes sense. Experiment a bit before applying your
edits to important projects.
NOTE
You can undo the operations by selecting Edit > Undo.

RELATED LINKS
Presets on page 973

Filter Conditions
By setting up filter conditions you can determine which filter target that is what elements you
want to find.

To set up a filter condition, make the following settings:
Filter Target
Sets the property of the element. This setting affects the available options in the
other columns.
Condition
Determines how the Project Logical Editor compares the property in the Filter
Target column to the values in the Parameter columns. The available options
depend on the Filter Target setting.
Parameter 1
Sets which value the element properties are compared to. This depends on the Filter
Target.
Parameter 2
Only available if one of the Range options is set in the Condition column. Allows you
to find all elements with values inside or outside the range between Parameter 1
and Parameter 2.
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Bar Range/Time Base
Only available if the Filter Target is set to Position. If one of the Bar Range options
is selected in the Condition column, you use the Bar Range/Time Base column to
specify zones within each bar. This allows you to find all elements on or around the
first beat of every bar, for example. If any of the other Condition options is selected,
you can use the Bar Range/Time Base column to specify a time base such as PPQ,
seconds, etc.
Left bracket
Together with the right bracket, this allows you to combine multiple filter conditions,
that is multiple lines with the boolean operators And/Or.
Right bracket
Together with the left bracket, this allows you to combine several filter conditions.
bool
Allows you to insert the boolean operators And/Or, when creating conditions with
multiple lines.
NOTE
If you make a mistake when combining multiple conditions with brackets, you are
informed in the status line.
NOTE
If you have already defined filter conditions and/or applied a preset, but want to start again from
scratch, you can initialize the settings by selecting the Init option from the Presets pop-up
menu.

RELATED LINKS
Searching for Elements at Specific Positions on page 964
Combining Multiple Condition Lines on page 968

Searching for Media Types
You can search for elements by their media type.
PROCEDURE
1.

Open the Filter Target pop-up menu and select Media Type.

2.

Open the Parameter 1 pop-up menu and select the media type that you want to search
for.

3.

Open the Condition pop-up menu and select one of the following options:
●

Select Equal if you want to search for the specified media type.

●

Select Unequal if you want to search for any other media type than the specified.

●

Select All Types if you want to search for all media types.

Media Type Filter
When the Filter Target is set to Media Type, the pop-up menu lists the available media types.
Audio
If no container type is specified, this finds audio events, audio parts and audio tracks.
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MIDI
If no container type is specified, this finds MIDI parts and MIDI tracks.
Automation
If no container type is specified, this finds automation events and automation tracks.
Marker
If no container type is specified, this finds marker events and marker tracks.
Transpose
If no container type is specified, this finds transpose events and transpose tracks.
Arranger
If no container type is specified, this finds arranger events and arranger tracks.
Tempo
If no container type is specified, this finds tempo events and tempo tracks.
Signature
If no container type is specified, this finds signature events and signature tracks.
Chord
If no container type is specified, this finds chord events and chord tracks.
Scale Event
If no container type is specified, this finds scale events.
Video
If no container type is specified, this finds video events.
Group
If no container type is specified, this finds group tracks.
Effect
If no container type is specified, this finds FX channel tracks.
Device
If no container type is specified, this finds device tracks.
VCA
If no container type is specified, this finds VCA fader tracks.
For media types, the following options are available:
Equal
This finds the media type set up in the Parameter 1 column.
All Types
This finds all media types.

Searching for Container Types
PROCEDURE
1.

Open the Filter Target pop-up menu and select Container Type.

2.

Open the Parameter 1 pop-up menu and select the container type that you want to search
for.

3.

Open the Condition pop-up menu and select one of the following options:
●

Select Equal if you want to search for the specified container type.
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●

Select Unequal if you want to search for any other container type than the specified.

●

Select All Types if you want to search for all container types.

EXAMPLE
You can set up the Project Logical Editor to find all folder tracks in the project.

Container Type Filter
When the Filter Target is set to Container Type, the pop-up menu lists the available container
types.
Folder Track
This finds all folder tracks, included FX channel and group channel folders.
Track
This finds all track types.
Part
This finds audio, MIDI, and instrument parts. Folder parts will not be found.
Event
This finds automation points, markers, as well as audio, arranger, transpose, tempo
and time signature events.
For container types, the following options are available:
Equal
This finds the container type set up in the Parameter 1 column.
All Types
This finds all container types.

Combining Media Type and Container Type
The combination of the filter targets Media Type and Container Type represents a versatile tool
for logical operations.
EXAMPLE
You can set up the Project Logical Editor to find all MIDI and instrument parts in the project.

You can set up the Project Logical Editor to find all automation tracks (not events) in the project
whose name contains vol.

You can set up the Project Logical Editor to find all MIDI and instrument parts (not tracks) in the
project that are muted.
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You can set up the Project Logical Editor to find all MIDI and instrument parts (not tracks) or all
audio events (not parts or tracks) in the project that are muted.

Searching for Names
PROCEDURE
1.

Open the Filter Target pop-up menu and select Name.

2.

Open the Parameter 1 pop-up menu and enter a name, or a part of a name that you want
to search for.

3.

Open the Condition pop-up menu and select one of the following options:
●

Select Equal if you want to search for the exact name.

●

Select Contains if you want to search for a name that contains the specified name.

●

Select Contains not if you want to search any other name than the specified.

EXAMPLE
You can set up the Project Logical Editor to find all tracks in the project whose name contains
voc.

Searching for Elements at Specific Positions
You can search for elements starting at specific positions, either relative to the start of the
project or within each bar.
PROCEDURE
1.

Open the Filter Target pop-up menu and select Position.
This allows you to find elements starting at specific positions, either relative to the start of
the project or within each bar.

2.

Open the Condition pop-up menu and select one of the following options:
●

To find all elements at a specific position, select a position in the Parameter 1
column.
You can set a time base such as PPQ, seconds, samples, or frames in the Bar Range/
Time Base column.

●

To find all elements inside or outside a range, select Inside Bar Range or Outside
Bar Range.
You can set the bar range in the Bar Range/Time Base column by clicking and
dragging in the bar display or by adjusting the start position of the range in the
Parameter 1 column and the end position in the Parameter 2 column. You can
change the time base use the Bar Range/Time Base column. The position for Bar
Range is measured in ticks related to the start of the bar.
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EXAMPLE
You can set up the Project Logical Editor to find all elements at the PPQ position 5.1.1. in the
project.

You can set up the Project Logical Editor to find elements starting around the second beat in
each bar.

Position Filter
For positions, the following options are available:
Equal
Has the exact same value as set up in the Parameter 1 column.
Unequal
Has any value other than the one set up in the Parameter 1 column.
Bigger
Has a value higher than the one set up in the Parameter 1 column.
Bigger or Equal
Has a value that is the same as or higher than the one set up in the Parameter 1
column.
Less
Has a value lower than the one set up in the Parameter 1 column.
Less or Equal
Has a value that is the same as or lower than the one set up in the Parameter 1
column.
Inside Range
Has a value that is between the values set up in the Parameter 1 and Parameter 2
columns. Note that Parameter 1 should be the lower value and Parameter 2 the
higher.
Outside Range
Has a value that is not between the values set up in the Parameter 1 and Parameter
2 columns.
Inside Bar Range
Is within the zone set up in the Bar Range/Time Base column, in each bar within the
current selection.
Outside Bar Range
Is outside the zone set up in the Bar Range/Time Base column, in each bar within
the current selection.
Before Cursor
Is before the cursor position.
Beyond Cursor
Is after the cursor position.
Inside Track Loop
Is inside the set track loop.

965

Project Logical Editor
Filter Conditions
Inside Cycle
Is inside the set cycle.
Exactly Matching Cycle
Exactly matches the set cycle.

Searching for Elements of Specific Lengths
PROCEDURE
1.

Open the Filter Target pop-up menu and select Length.
This allows you to find elements of a specific length only.
NOTE
The Length parameter is interpreted via the time base setting in the Bar Range/Time
Base column, that is, in PPQ, seconds, samples, or frames.

2.

Open the Parameter 1 pop-up menu and set the length that you want to search for.

3.

Open the Condition pop-up menu and select an option.
If you select Inside Range or Outside Range, use Parameter 1 and Parameter 2 to set
the start and the end of the range.

EXAMPLE
You can set up the Project Logical Editor to find all audio parts and events in the project with a
length value below 200 samples.

RELATED LINKS
Lengths Filter on page 966

Lengths Filter
For lengths, the following options are available:
Equal
Has the exact same value as set up in the Parameter 1 column.
Unequal
Has any value other than the one set up in the Parameter 1 column.
Bigger
Has a value higher than the one set up in the Parameter 1 column.
Bigger or Equal
Has a value that is the same as or higher than the one set up in the Parameter 1
column.
Less
Has a value lower than the one set up in the Parameter 1 column.
Less or Equal
Has a value that is the same as or lower than the one set up in the Parameter 1
column.
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Inside Range
Has a value that is between the values set up in the Parameter 1 and Parameter 2
columns. Note that Parameter 1 should be the lower value and Parameter 2 the
higher.
Outside Range
Has a value that is not between the values set up in the Parameter 1 and Parameter
2 columns.

Searching for Color Names
PROCEDURE
1.

Open the Filter Target pop-up menu and select Color Name.

2.

Open the Parameter 1 pop-up menu and enter the color name for which you want to
search.
You can also select the color from the pop-up menu.

3.

Open the Condition pop-up menu and select one of the following options:
●

Select Equal if you want to search for the exact color name.

●

Select Contains if you want to search for a color name that contains the specified
color name.

●

Select Contains not if you want to search any other color name than the specified
name.

Searching for Properties
PROCEDURE
1.

Open the Filter Target pop-up menu and select Property.

2.

Open the Parameter 1 pop-up menu and select the property that you want to search for.

3.

Open the Condition pop-up menu and select one of the following options:
●

Select Property is set if you want to search for events that have the specified
property.

●

Select Property is not set if you want to search for events that do not have the
specified property.

EXAMPLE
You can set up the Project Logical Editor to find all muted MIDI and instrument parts.

You can set up the Project Logical Editor to find all elements that are empty.

You can set up the Project Logical Editor to find all selected audio parts that are selected but
not muted.
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Properties Filter
For properties, the following options are available:
Property is set
This finds all events that have the property that is set in the Parameter 1 column.
Property is not set
This finds all events that do not have the property that is set in the Parameter 1
column.
When the Filter Target is set to Property, the pop-up menu lists the available properties.
Event is muted
This finds all muted events.
Event is selected
This finds all selected events.
Event is empty
This finds all empty events.
Event inside NoteExp
This finds all events that form part of Note Expression automation data. These can be
VST 3 or MIDI controller events.
Event is valid VST 3
This finds all VST3 events in a note that are valid. This means that the corresponding
track is routed to an instrument that supports them.
Is Hidden
This finds all hidden tracks.
Has TrackVersion
This finds all tracks that have TrackVersions.
Follows Chord Track
This finds all tracks that follow the chord track.
Is Disabled
This finds all disabled tracks.

Combining Multiple Condition Lines
You can add condition lines and combine them by using boolean And and Or operators and
brackets.
●

To add a new condition, click

below the list.

The new line is added at the bottom of the list.
●

To remove a condition, select it and click

below the list.

The Bool Column
In the bool column to the right in the list, you can select a boolean operator: And or Or.
A boolean operator combines 2 condition lines and determines the result in the following way:
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●

And determines that both conditions must be fulfilled for an element to be found.

●

Or determines that at least one of the conditions must be fulfilled for an element to be
found.

IMPORTANT
When you add a new condition line, the boolean setting defaults to And.
EXAMPLE
You can set up the Project Logical Editor to find MIDI tracks.

You can set up the Project Logical Editor to find all parts or events that match exactly the cycle.

Using Brackets
The bracket columns let you enclose 2 or more condition lines, dividing the conditional
expression into smaller units. This is only relevant when you have 3 or more condition lines and
want to use the boolean Or operator.
You can add brackets by clicking in the bracket columns and selecting an option. Up to triple
brackets can be selected.
If you add several layers of brackets, these are evaluated from the inside out, starting with the
innermost brackets.
Expressions within brackets are evaluated first.
EXAMPLE
You can set up the Project Logical Editor to find all audio parts and events whose name contains
perc as well as other MIDI parts and events whose name contains drums.

You can set up the Project Logical Editor to find all audio parts or events whose name contains
perc or drums.

Specifying Actions
You can specify actions, that is, changes that are made to the found elements, in the lower list of
the Project Logical Editor. Actions are only relevant for the function type Transform.

You can perform the following action types:
●

Track-based actions such as Track Operation, Name

●

Event-based actions such as Position, Length, Name.
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●

Actions that only take effect on automation data such as Trim.

You can add action lines by clicking

, and remove them by selecting it and clicking

.

Action Target
The Action Target allows you to select the property that is changed.

Position
Adjusting the Position value moves the elements.
This parameter is interpreted via the time base setting in the Bar Range/Time Base column, with
the exception of the Random setting, which uses the time base of the affected events:
Add
Adds the value specified in the Parameter 1 column to the Position.
Subtract
Subtracts the value specified in the Parameter 1 column from the Position.
Multiply by
Multiplies the Position value with the value specified in the Parameter 1 column.
Divide by
Divides the Position value by the value specified in the Parameter 1 column.
Round by
This rounds the Position value using the value specified in the Parameter 1 column.
In other words, the Position value is changed to the closest value that can be divided
by the Parameter 1 value.
Set relative Random Values between
This will add a random value to the current Position value. The added random value
will be within the range specified with Parameter 1 and Parameter 2. Note that
these can be set to negative values.
Set to fixed value
This sets the position to the value specified in the Parameter 1 column.

Length
Adjusting the Length value allows you to resize the elements.
This parameter is interpreted via the time base setting in the Bar Range/Time Base column, with
the exception of the Random setting, which uses the time base of the affected events:
Add
Adds the value specified in the Parameter 1 column to the Length.
Subtract
Subtracts the value specified in the Parameter 1 column from the Length.
Multiply by
Multiplies the Length value with the value specified in the Parameter 1 column.
Divide by
Divides the Length value by the value specified in the Parameter 1 column.
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Round by
This rounds the Length value using the value specified in the Parameter 1 column.
In other words, the Length value is changed to the closest value that can be divided
by the Parameter 1 value.
Set to fixed value
This sets the Length to the value specified in the Parameter 1 column.
Set Random Values between
This will add a random value to the current length. The added random value will be
within the range specified with Parameter 1 and Parameter 2.

Track Operation
Adjusting the Track Operation value allows you to change the track status.
NOTE
Track operations may also affect automation tracks. This may lead to unexpected results,
especially if you use the Toggle action.
Folder
Opens, closes, or toggles folders.
Record
Enables, disables, or toggles the record enable status.
Monitor
Enables, disables, or toggles the monitor status.
Solo
Enables, disables, or toggles the solo status.
Mute
Enables, disables, or toggles the mute status.
Read
Enables, disables, or toggles the read enable status.
Write
Enables, disables, or toggles the write enable status.
EQ Bypass
Enables, disables, or toggles the EQ bypass status.
Inserts Bypass
Enables, disables, or toggles the inserts bypass status.
Sends Bypass
Enables, disables, or toggles the sends bypass status.
Lanes Active
Enables, disables, or toggles the lanes active status.
Hide Track
Enables, disables, or toggles the track visibility status.
Time Domain
Sets the track time domain to Musical, Linear, or toggles the status.
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Name
Adjusting the Name value allows you to rename the found elements.
Replace
Replaces names with the text specified in the Parameter 1 column.
Append
Names will be appended with the string specified in the Parameter 1 column.
Prepend
The name will be prepended with the string specified in the Parameter 1 column.
Generate Name
The name will be replaced by the text specified in the Parameter 1 column, followed
by the number set with Parameter 2. The number will be increased by 1 for every
found element.
Replace Search String
You can specify a search string under Parameter 1 that is replaced by the text
specified in the Parameter 2 column.

Trim
Adjusting the Trim value allows you to trim the found elements. This is used for automation only.
Multiply by
Multiplies the Trim value with the value specified in the Parameter 1 column.
Divide by
Divides the Trim value by the value specified in the Parameter 1 column.

Set Color
Adjusting the Set Color value allows you to set the color for an element.
For this Action Target, you can select the operation Set to fixed value. To set a specific color,
click the Parameter 1 column and select the item in the pop-up menu.

Selecting a Function
The left pop-up menu at the bottom of the Project Logical Editor is where you select the
function – the basic type of editing to be performed.

The available options are:
Delete
Deletes all elements found by the Project Logical Editor.
NOTE
When you delete automation tracks and undo this operation by selecting Undo from
the Edit menu, the automation tracks will be restored, but the tracks will be closed.
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Transform
Changes one or several aspects of the found elements. You set up exactly what is
changed in the action list.
Select
This will simply select all found elements, highlighting them for further work in the
Project window.

Applying Macros
In the Macro pop-up menu you can select a macro that will be executed automatically after
completing the actions defined.
To use this, you set up the macro that you need in the Key Commands dialog and then select it
in the Project Logical Editor from the Macro pop-up menu.
EXAMPLE
Use the filter conditions to select all tracks that contain automation data for the volume
automation parameter. In the Function pop-up menu select Delete, and in the Macro pop-up
menu select Select all on Track. This removes the automation events from these tracks.
RELATED LINKS
Key Commands on page 1137

Applying the Defined Actions
Once you have set up filter conditions, selected a function and set the required actions or loaded
a preset, you apply the actions defined with the Project Logical Editor by clicking the Apply
button.
Project Logical Editor operations can be undone just like any other editing.

Presets
The section in the upper left section of the window allows you to load, save and manage Project
Logical Editor presets.
To load a preset, do one of the following:
●

Open the Select Preset pop-up menu, and select an option.

●

Select Edit > Process Project Logical Editor, and select an option.

NOTE
If you set up a key command for a preset you can conveniently apply the same operation to
several selected events in one go.

RELATED LINKS
Key Commands on page 1137
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Storing Your Own Settings as Presets
You can save settings that you want to use again as presets.
PROCEDURE
1.

In the section in the upper left of the Project Logical Editor, click Store Preset.

2.

In the dialog that opens, specify a name for the preset and click OK.

RESULT
The preset is stored.
NOTE
To remove a preset, load it and click the Remove Preset button.

Organizing and Sharing Presets
The Project Logical Editor presets are stored within the application folder in the Presets
\Logical Edit Project subfolder.
Preset files cannot be edited manually, but you can reorganize them. This also makes it easy to
share presets with other Nuendo users, by transferring the individual preset files.
NOTE
The list of presets is read each time the Project Logical Editor is opened.

Setting up Key Commands for Your Presets
If you have stored Project Logical Editor presets, you can set up key commands for them.
PROCEDURE
1.

Select File > Key Commands.

2.

In the Commands column navigate to the category Process Project Logical Editor and
click the plus sign to display the items in the folder.

3.

In the list, select the item to which you want to assign a key command, click in the Type in
Key field and enter a new key command.

4.

Click the Assign button above the field.
The new key command is shown in the Keys List.

5.

Click OK.

RELATED LINKS
Key Commands on page 1137
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Project Tempo Modes
For every project you can set a tempo mode, depending on whether your music has a fixed
tempo or if it changes throughout the project.
On the Transport panel, you can set the following tempo modes:
●

Fixed Tempo Mode
If you want to work with one fixed tempo that does not change throughout the project,
deactivate Activate Tempo Track on the Transport panel. You can change the tempo
value to set a fixed rehearsal tempo.

●

Tempo Track Mode
If the tempo of your music contains tempo changes, activate Activate Tempo Track on
the Transport panel. You can change the tempo value to change the tempo at the cursor.
If your project does not contain any tempo changes, the tempo is changed at the project
start.

RELATED LINKS
Setting up Projects for Tempo Changes on page 979

Track Time Base
The time base of a track determines if a track can follow the tempo changes of a project that is
set to tempo track mode.
In the Inspector for MIDI tracks, instrument tracks, and audio related tracks, you can activate/
deactivate Toggle Time Base to switch the track time base.
The following time base modes are available:
●

Musical
Use this mode for material with a musical, that is, tempo-related time base. All tracks that
are set to musical time base follow any tempo changes that you add on the tempo track.
NOTE
For audio events on audio tracks that are set to musical time base, the tempo changes on
the tempo track affect only the start position and not the actual audio.
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●

Linear
Use this mode for material with a linear, time-related time base.

RELATED LINKS
Instrument Track Inspector on page 109
MIDI Track Inspector on page 116
Audio Track Inspector on page 101

Tempo Track Editor
The Tempo Track Editor provides an overview of the project tempo settings. It allows you to add
and edit tempo events.
●

To open the Tempo Track Editor, select Project > Tempo Track, or press Ctrl/Cmd-T.

The Tempo Track Editor is divided into several sections:
1

Tempo scale
Shows the tempo scale in BPM.

2

Toolbar
Contains tools for selecting, adding, and changing tempo and time signature events.

3

Info line
Shows information about the selected tempo or time signature event.

4

Ruler
Shows the timeline and the display format of the project.

5

Time signature display
Shows the time signature events in the project.

6

Tempo curve display
If your project is set to a fixed tempo, only one tempo event and a fixed tempo is shown.
If your project is set to tempo track mode, the curve display shows the tempo curve with
the tempo events in the project.

Toolbar
The toolbar contains tools for selecting, adding, and changing tempo and time signature events.
The following tools are available:
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Activate Tempo Track
Switches the project tempo between fixed tempo mode and tempo track mode.
Show/Hide Info
Opens/Closes the info line.
Tools
Contains tools to select, erase, zoom, and draw.
Auto-Scroll
Allows the tempo event display to scroll during playback, keeping the project cursor
visible in the editor.
Snap
Allows you to restrict horizontal movement and positioning of tempo events to
certain positions. Time signature events always snap to the beginning of bars.
Type of New Tempo Points
Allows you to select the type of new tempo points. Select Ramp if you want new
tempo points to change gradually from the previous curve point to the new one.
Select Jump if you want new tempo points to change instantly. Select Automatic if
new tempo points should have the same type as the previous curve point.
Current Tempo
In fixed tempo mode, this allows you to change the current tempo.
Tempo Recording Slider
Allows you to record tempo changes.
Open Process Tempo Dialog
Opens the Process Tempo dialog.
Open Process Bars Dialog
Opens the Process Bars dialog.

Tempo Track
You can use the tempo track to create tempo changes within a project.
●

To add a tempo track to your project, select Project > Add Track > Tempo.

●

You can use the tools on the Project window toolbar to add and edit tempo events.

●

You can use the tempo event editor to edit selected tempo events.

●

To select a tempo event, click it with the Object Selection tool.

977

Editing Tempo and Time Signature
Tempo Track
●

To select multiple events, drag a selection rectangle with the Object Selection tool or
Shift-click the events.

●

To select all tempo events on the tempo track, right-click the tempo track and select Select
All Events from the context menu.

RELATED LINKS
Tempo Track Inspector on page 150
Tempo Track Controls on page 150

Tempo Event Editor
The tempo event editor allows you to edit selected events on the tempo track.
●

To open the tempo event editor, activate the Object Selection tool and drag a selection
rectangle on the tempo track.

The tempo event editor features the following smart controls for specific editing modes:

1

Tilt Left
If you click in the upper left corner of the editor, you can tilt the left part of the curve. This
allows you to tilt the event values at the start of the curve upwards or downwards.

2

Compress Left
If you Alt-click in the upper left corner of the editor, you can compress or expand the left
part of the curve. This allows you to compress or expand the event values at the start of
the curve.

3

Scale Vertically
If you click in the middle of the upper border of the editor, you can scale the curve
vertically. This allows you to raise or lower the event values of the curve in percent.

4

Move Vertically
If you click on the upper border of the editor, you can move the entire curve vertically. This
allows you to raise or lower the values of the event values of the curve.

5

Compress Right
If you Alt-click in the upper right corner of the editor, you can compress or expand the
right part of the curve. This allows you to compress or expand the event values at the end
of the curve.

6

Tilt Right
If you click in the upper right corner of the editor, you can tilt the right part of the curve.
This allows you to tilt the event values at the end of the curve upwards or downwards.

7

Scale Around Relative Center
If you Alt-click in the middle right border of the editor, you can scale the curve relative to
its center. This allows you to raise or lower the event values horizontally around the center
of the editor.

8

Scale Around Absolute Center
If you click in the middle right corner of the editor, you can scale the curve absolute to its
center. This allows you to raise or lower the event values horizontally around the center of
the editor.
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9

Stretch
If you click on the lower border of the editor, you can stretch the curve horizontally. This
allows you to move the event values of the curve to the left or to the right.

Setting up Tempo Changes for Projects
If the tempo track is activated, you can set up tempo changes for your project.
IMPORTANT
If your project is set to tempo track mode and you set up tempo changes, only tracks that are set
to musical time base follow the tempo changes.
NOTE
If you work in tempo track mode, make sure that the display format in the Project window ruler
is set to Bars+Beats. Otherwise, you may get confusing results.
If you activate Activate Tempo Track in the Transport panel, the tempo track curve is displayed
in the tempo curve display.
If you know the tempo of your music, you can adjust the tempo value as follows:
●

By adding tempo events in the Tempo Track Editor.

●

By recording tempo changes with the Tempo Recording slider on the toolbar of the
Tempo Track Editor.

●

By adding tempo events on the tempo track.

●

By importing tempo tracks.

If you do not know the tempo of your music, Nuendo offers tools to calculate and set it:
●

Tempo Detection Panel

●

Time Warp tool

●

Process Bars dialog

●

Process Tempo dialog

RELATED LINKS
Setting up Projects for Tempo Changes on page 979

Setting up Projects for Tempo Changes
When you create a new project, the project tempo is automatically set to fixed tempo mode. If
your music contains tempo changes, you must set your project to tempo track mode.
PROCEDURE
●

To set your project to tempo track mode, do one of the following:
●

On the Transport panel, activate Activate Tempo Track.

●

Select Project > Tempo Track and activate Activate Tempo Track.

●

Select Project > Add Track > Tempo and activate Activate Tempo Track.

RESULT
The project tempo is now set up to follow the tempo track.
All tracks that are set to musical (tempo-related) time base follow any tempo changes that you
add on the tempo track.
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RELATED LINKS
Track Time Base on page 975
Tempo Track Controls on page 150
Tempo Track Editor on page 976

Setting up a Tempo Track by Adding Tempo Changes
PROCEDURE
1.

Do one of the following:
●

Select Project > Tempo Track to open the Tempo Track Editor.

●

Select Project > Add Track > Tempo to add a tempo track to your project.

2.

Open the Type of New Tempo Points pop-up menu and select an option.

3.

Do one of the following:
●

On the toolbar, select the Object Selection tool and click the tempo curve.

●

On the toolbar, select the Draw tool, and click and drag in the tempo curve display.

NOTE
If Snap is activated, this determines at which time positions you can insert tempo curve
points.

RESULT
The tempo event is added to the tempo curve.

Setting up a Tempo Track by Recording Tempo Changes
You can set up a complete tempo track by recording tempo changes. This is useful if you want to
create natural sounding ritardandos, for example.
PROCEDURE
1.

Open the project for which you want to set up a tempo track and start playback.

2.

Select Project > Tempo Track.

3.

On the Tempo Track Editor toolbar, use the Tempo Recording Slider to add tempo
changes on the fly.
By moving the slider to the right, you can raise the project tempo, by moving it to the left,
you can lower it.

RESULT
The tempo changes are recorded and added to the tempo curve in the Tempo Track Editor.
RELATED LINKS
Toolbar on page 976

Setting up a Tempo Track from Tapping
You can create a complete tempo track based on tapping the tempo of freely recorded audio or
MIDI material.
PREREQUISITE
You have opened a project with a freely recorded audio or MIDI file. You have added an
instrument track and loaded an instrument. You have connected and set up a MIDI keyboard.
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PROCEDURE
1.

In the instrument track Inspector, deactivate Toggle Time Base to set the track time base
to linear.

2.

On the instrument track, activate Record Enable.

3.

On the Transport panel, activate Record.

4.

On the MIDI keyboard, tap the tempo by hitting a key to the beat of your music.

5.

Stop recording and play back the recorded MIDI notes together with the original recording
to check if the timing is correct.

6.

Do one of the following:
●

Select the MIDI part in the Project window.

●

Open the MIDI part in the Key Editor and select the notes that you want to use for
the calculation.

7.

Select MIDI > Functions > Merge Tempo From Tapping.

8.

Open the Tapping pop-up menu to specify what type of note you tapped during the
recording.

9.

Optional: To start the calculation of the tempo curve at the beginning of a bar, activate
Begin at Bar Start.

10.

Click OK.

RESULT
The project tempo is set to the tapped tempo.
AFTER COMPLETING THIS TASK
Open the Tempo Track Editor to see and edit the new tempo curve.
RELATED LINKS
Setting Up All MIDI Inputs on page 20

Setting up a Tempo Track from Tempo Detection
You can set up a complete tempo track using the result of a tempo detection for an audio event
or a MIDI part.
PROCEDURE
1.

In the Project window, select the audio event or the MIDI part that you want to analyze.

2.

Select Project > Tempo Detection.

3.

In the Tempo Detection Panel, click Analyze.

RESULT
●

A tempo track is added to the project. On the tempo track, tempo events are created
based on the analysis for the selected audio event or MIDI part.

●

A signature track is added to the project. On the signature track, a signature event with the
value 1/4 is added.

●

On the Project window toolbar, the Time Warp tool is selected.

AFTER COMPLETING THIS TASK
Depending on the rhythmic quality of the material, the analysis may instantly lead to a perfect
result. You can verify the quality of the analysis by activating the metronome click in the
Transport panel, and playing back the project. To correct the result manually, use the functions
in the Tempo Detection Panel.
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RELATED LINKS
Tempo Detection Panel on page 986
Correcting the Analysis Manually on page 982

Correcting the Analysis Manually
If your music contains sections that are played in a different tempo or with special rhythmic
characteristics, for example, you must adjust the tempo events manually.
PREREQUISITE
You have analyzed your material and the Tempo Detection Panel is still open. The metronome
click is activated.
PROCEDURE
1.

Play back the track with the analyzed material from the beginning and listen to the click.

2.

Optional: If you work with an audio event, zoom in on the waveform so that you can
compare the transients with the tempo events on the tempo track.

3.

Optional: If the first tempo event that is not placed correctly is located at the beginning of
the material, click the left arrow button in the Tempo Detection Panel to change the
direction of the reanalysis.

4.

Select the Time Warp tool and move the first tempo event that is not placed correctly to
the correct position.

RESULT
The material is reanalyzed and the tempo recalculated.
AFTER COMPLETING THIS TASK
Continue listening to the material and correcting tempo events until the end. Close the Tempo
Detection Panel.
NOTE
If your material includes multiple sections with different tempo, you can also cut the material at
each major tempo change and perform a tempo detection for every single resulting section.
Remember that each section must have a length of at least 7 seconds.

Editing Tempo Events
In the Tempo Track Editor, you can edit selected tempo events.
Use the following methods:
●

With the Object Selection tool, click and drag horizontally and/or vertically.

●

On the Info Line, adjust the tempo value in the Value field.

NOTE
When editing tempo events on tempo curves, make sure that the display format in the Project
window ruler is set to Bars+Beats. Otherwise, you may get confusing results.
Use the following methods to remove tempo events:
●

With the Erase tool, click the tempo event.

●

Select the tempo event and press Backspace.
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NOTE
You cannot remove the first tempo event.
Use the following method to change the tempo curve type:
●

On the Info Line, adjust the tempo curve type in the Type field.

Adjusting the Tempo of a Range
You can adjust the tempo of a range to match a specific length or end time.
PROCEDURE
1.

Set the left and right locator to specify the start and the end of the range you want to
adjust.

2.

Select Project > Tempo Track.

3.

Click Open Process Tempo Dialog.

4.

Open the Time Display Format pop-up menu and select a time display format for the new
range.

5.

In the New Range section, enter a new end time or a new length for the range.

6.

Click Process.

RESULT
The range is adjusted to match the new end time or the new length. The tempo track is adjusted
to show the new tempo of the range.

Setting up a Fixed Project Tempo
If your music does not contain tempo changes, and the tempo track is deactivated, you can set
up a fixed tempo for your project.
When the tempo track is deactivated, the tempo track curve is grayed out. The fixed tempo is
displayed as a horizontal line in the tempo curve display.
If you know the tempo of your music, you can adjust the tempo value in the following areas:
●

Tempo field on the Transport panel

●

Current Tempo field on the Tempo Track Editor toolbar

●

Current Tempo field on the tempo track

If you do not know the tempo of your music, use one of the following tools to calculate and set it:
●

Beat Calculator

●

Merge Tempo From Tapping

●

Set Project Tempo from Loop

RELATED LINKS
Setting the Project Tempo from a Recording on page 984
Setting the Project Tempo by Tapping on page 984
Setting the Project Tempo from an Audio Loop on page 985
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Setting the Project Tempo from a Recording
You can calculate the tempo of freely recorded audio or MIDI material with the Beat Calculator
and set it as the project tempo.
PREREQUISITE
The tempo mode is set to Fixed.
PROCEDURE
1.

On the Project window toolbar, select the Range Selection tool.

2.

In the event display, make a selection that covers an exact number of beats of the
recording.

3.

Select Project > Beat Calculator.

4.

In the Beats value field, enter the number of beats that the selection encompasses.
The calculated tempo is shown in the BPM field.

5.

In the Insert Tempo into Tempo Track section, click At Tempo Track Start.

RESULT
The project tempo is set to the tempo calculated from your recording.
RELATED LINKS
Beat Calculator on page 985

Setting the Project Tempo by Tapping
You can set the tempo of freely recorded audio or MIDI material by tapping.
PREREQUISITE
The tempo mode is set to Fixed.
PROCEDURE
1.

Activate playback.

2.

Select Project > Beat Calculator.

3.

Click Tap Tempo.
The Tap Tempo window opens.

4.

Use Space to tap the tempo of the recording that is played back.
In the BPM field, the calculated tempo is updated each time you tap.

5.

Click OK to close the window.
The tapped tempo is shown in the BPM field of the Beat Calculator.

6.

Click one of the buttons in the Insert Tempo into Tempo Track section to insert the
calculated tempo into the tempo track.

RESULT
The project tempo is set to the tapped tempo.
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RELATED LINKS
Setting up a Fixed Project Tempo on page 983

Setting the Project Tempo from an Audio Loop
You can set the project tempo from the tempo of an audio loop.
PREREQUISITE
Your project contains an audio loop that is not in Musical Mode.
PROCEDURE
1.
2.

In the Project window ruler, set the left locator to the beginning of the audio loop.
Set the right locator to the end of the last bar.
This does not need to match the end of the audio loop, but its number of bars.

3.

Select the audio loop.

4.

Select Audio > Advanced > Set Tempo from Event.
You are asked if you want to set the global project tempo.

5.

Perform one of the following actions:
●

Click Yes to adjust the project tempo globally.

●

Click No to adjust the project tempo only in the section of the audio event.

RESULT
The project tempo is set to the tempo calculated for the audio loop.

Beat Calculator
The Beat Calculator is a tool for calculating the tempo of freely recorded audio or MIDI material.
It also allows you to set the tempo by tapping.

●

To open the Beat Calculator for an audio or MIDI recording, select Project > Beat
Calculator.

1

Beats
Allows you to enter the number of beats for the selected section of your recording.

2

BPM
Shows the tempo calculated for the selection.

3

Tap Tempo
Opens a window where you can specify a tempo by tapping.

4

Insert Tempo into Tempo Track at Tempo Track Start
If your project is in tempo track mode, the calculated tempo is set as the first tempo curve
point. If your project is in fixed tempo mode, the calculated tempo is set for the entire
project.
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5

Insert Tempo into Tempo Track at Selection Start
If your project is in tempo track mode, the calculated tempo is set as a new tempo event at
the start of the selection.

6

Refresh
Allows you to recalculate the tempo. This is useful if you adjust the selection, for example.

Tempo Detection
You can detect the tempo of any rhythmic musical content, even if it has not been recorded to a
metronome click or if it contains tempo drift.
Detecting the tempo of musical material is useful for the following cases:
●

If you want your audio or MIDI tracks to follow the tempo of freely recorded material.

●

If you want to adjust freely recorded material to the project tempo.

To perform a tempo detection, the following requirements must be met:
●

The audio event or MIDI part must be at least 7 seconds long.

●

The material must have discernible beats or rhythms.

Tempo Detection Panel
The Tempo Detection Panel allows you to analyze the tempo of audio events or MIDI parts.
●

To open the Tempo Detection Panel for an audio event or a MIDI part, select the event or
the part and select Project > Tempo Detection.

1

Name
Shows the name of the selected event or part.

2

Analyze
Starts the tempo detection.

3

Multiply by 2
Allows you to double the detected tempo. This is useful if your material is twice as fast as
the detected tempo.

4

Divide by 2
Allows you to halve the detected tempo. This is useful if your material is half as fast as the
detected tempo.

5

Multiply by 4/3
Allows you to adjust the detected tempo with a factor of 4/3. This is useful if your material
contains dotted notes or triplets and the algorithm detects 3 beats where 4 are expected.

6

Multiply by 3/4
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Allows you to adjust the detected tempo with a factor of 3/4. Combined with Multiply by 2,
this is useful if the actual signature is 2/4 and the algorithm detects 6/8 beats or vice versa.
7

Offbeat Correction
Allows you to shift the detected tempo events by half a beat. This is useful for material
where the offbeat is so dominant that the algorithm mistakes it for an upbeat.

8

Smooth Tempo
Allows you to retrigger the tempo analysis and removes irregular spikes or tempo changes
for material that has a steady tempo. This is useful if irregular tempo changes were
detected, even though you know that the material has a more or less steady tempo.

9

Direction of reanalysis
When you correct the detected tempo curve by reanalyzing it manually, these buttons
allow you to change the direction in which the material is analyzed. To reanalyze the
beginning of the tempo curve, activate the left arrow button.

10

Reset
Resets the analysis data.

Exporting a Tempo Track
You can export a tempo track as an XML file to use it in other projects.
PROCEDURE
1.

Select File > Export > Tempo Track.

2.

In the file dialog that opens, specify a name and a location for the file.

3.

Click Save.

RESULT
The tempo track information is saved together with signature events with the file extension .smt.

Importing a Tempo Track
You can import a tempo track from another project.
PROCEDURE
1.

Select File > Import > Tempo Track.

2.

In the file dialog that opens, navigate to the file you want to import.

3.

Click Open.

RESULT
The tempo track is imported to your project together with signature events. All tempo track data
in the project is replaced.
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Process Tempo
The Process Tempo dialog allows you to set a range to a specific length or to adjust its end time
by automatic adjustment of the tempo track.

●

To open the Process Tempo dialog, activate Activate Tempo Track, select Project >
Tempo Track to open the Tempo Track Editor, and click Open Process Tempo Dialog.

The following options are available:
1

Range Start Time in PPQ
Shows the start time of the locator range in bars and beats.

2

Range End Time in PPQ
Shows the end time of the locator range in bars and beats.

3

Range Length in Selected Time Format
Shows the length of the locator range in bars and beats.

4

Range End Time in Selected Time Format
Shows the end time of the locator range in the selected time format.

5

Range Start Time in Selected Time Format
Shows the start time of the locator range in the selected time format.

6

Time Display Format
Allows you to select the time format that is displayed in the value fields of the new range.

7

New Range Start Time in Selected Time Format
Shows the start time of the new range in the selected time format.

8

New Range End Time in Selected Time Format
Shows the end time of the new range in the selected time format.

9

New Range Length in Selected Time Format
Shows the length of the new range in the selected time format.

10

Tempo Scaling
Shows the scaling value.
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Process Bars
The Process Bars dialog allows you to insert, delete, replace, or reinterpret the signature events
for a specified bar range by automatic adjustment of the signature and tempo events.

●

To open the Process Bars dialog, select Project > Tempo Track to open the Tempo Track
Editor, and click Open Process Bars Dialog.

The following options are available:
1

Bar Range
Shows the specified bar range.

2

Start
Allows you to set a start position for the bar range.

3

Length
Allows you to set a length for the bar range.

4

Action
Allows you to select one of the following actions:

5

●

Insert Bars inserts an empty Bar Range with the set time Signature at the Start
position.

●

Delete Bars deletes the set Bar Range at the Start position.

●

Reinterpret Bars reinterprets the set Bar Range with the set time Signature at the
Start position. However, the playback of the notes stays the same.

●

Replace Bars replaces the set Bar Range at the Start position.

Signature
Allows you to specify the time signature that is used for the Insert, Reinterpret, and
Replace actions.

6

Process
Applies the specified action.

Time Warp
The Time Warp tool allows you to adjust musical positions of events or parts to time positions.
●

You can adjust positions in musical time-based material to positions in time.

●

You can match material with a musical time base to material with a linear time base.

NOTE
The Time Warp tool can create tempo values up to 300 BPM.
If you activate Time Warp on the toolbar, the ruler shows tempo events as flags with tempo
values.
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If you click the Time Warp on the Project window toolbar and click again, a pop-up menu opens
where you can select one of the following modes:

●

Warp Grid
If you use the Time Warp tool in this mode, the absolute time positions for all tracks that
are set to musical time base are kept.

●

Warp Grid (musical events follow)
If you use the Time Warp tool in this mode, all tracks that are set to musical time base
follow the changes.

When you click with the Time Warp tool, it snaps to the tempo grid in the window. If you want
the Time Warp tool to snap to a marker or the start or end of an event instead, activate Snap
and set the Snap Type to Events.

Adjusting Musical Positions to Time Positions
You can adjust musical positions to positions in time with the Time Warp tool.
PREREQUISITE
Tempo track mode is activated. Snap is activated and you have selected an appropriate Snap
Type.
PROCEDURE
1.

On the Project window toolbar, click Time Warp.
The ruler is automatically set to Bars+Beats format.

2.

In the event display, locate the musical position that you want to adjust and drag the time
position to match it.

This can be the event start, a certain hit within the event, etc.
3.

Release the mouse button.

RESULT
The musical position is adjusted to the time position, and the tempo value of the last tempo
event before the click position is changed. If later tempo events exist, a new tempo event is
created at the click position.
RELATED LINKS
Project Tempo Modes on page 975
Time Warp on page 989
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Set Definition From Tempo
The Set Definition from Tempo dialog allows you to set up freely recorded audio material to
follow a specific tempo.

●

To open the Set Definition from Tempo dialog for an audio recording, select Audio >
Advanced > Set Definition from Tempo.

Save Definition in Project Only
Allows you to save the tempo information in the project file only.
Write Definition to Audio Files
Allows you to write the tempo information to the selected audio files. This is useful if
you want to use them in other projects together with the tempo information.
Set all Tracks to Musical Time Base
Allows you to set all tracks to musical time base. If this is deactivated, only the tracks
with the selected events are set to musical time base.

Adjusting the Audio Tempo to the Project Tempo
You can adjust the tempo of freely recorded audio material to the project tempo.
PROCEDURE
1.

Select the audio events that you want to adjust to the project tempo.

2.

Select Audio > Advanced > Set Definition from Tempo.

3.

Optional: Adjust the settings.

4.

Click OK.

RESULT
The tempo information is copied to the audio and the tracks are set to musical time base. This is
achieved by applying warping to the events. Musical Mode is activated for the audio events. The
audio tracks now follow any tempo changes in the project.

Time Signature Events
You can set up one or more time signatures for a project.
You can set up the first time signature event of your project on the Transport panel. You can add
further time signature events in the Tempo Track Editor.
Time signature events can have click patterns assigned. These allow you to create different
grooves and feels for the metronome click. You can create a triplet click pattern for a 4/4 time
signature, for example.
RELATED LINKS
Toolbar on page 41
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Transport on page 51
Signature Track on page 148
Adding Time Signature Events on the Signature Track on page 992
Setting Up a Click Pattern for a Time Signature Event on page 992

Adding Time Signature Events in the Tempo Track Editor
PROCEDURE
1.

Select Project > Tempo Track to open the Tempo Track Editor.

2.

Select Draw on the toolbar, and in the ruler, click at the time position where you want to
insert the time signature event.

3.

Edit the numerator and the denominator to change the value of the time signature event.
NOTE
You can also select the time signature event and edit the time signature value on the info
line.

RESULT
The time signature event is added at the specified time position. The timeline and the event
displays for the Project window and the editors reflect the changes.

Adding Time Signature Events on the Signature Track
You can add multiple time signature events for a project. This is useful if you want to change the
time signature at a specific bar, for example.
PROCEDURE
1.

Select Project > Add Track > Signature.

2.

Select Draw on the Project window toolbar and on the signature track, click at the time
position where you want to insert the time signature event.

3.

Edit the numerator and the denominator to change the value of the time signature event.

RESULT
The time signature event is added at the specified time position. The timeline and the event
displays for the Project window and the editors reflect the changes.
RELATED LINKS
Signature Track on page 148

Setting Up a Click Pattern for a Time Signature Event
For each signature event in your project, you can set up a metronome click pattern.
PROCEDURE
1.

Double-click the plus sign or the pattern to the right of the time signature value to open
the Click Pattern Editor.

2.

Do one of the following:
●

Open the Pattern pop-up menu and select one of the presets.

●

Use the Clicks setting to define the number of clicks that you want to hear, and click
in the event display to set up a new click pattern.
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3.

When you are done, click outside the Click Pattern Editor to close it.

4.

Repeat this for each signature event for which you want to set up a click pattern.

RESULT
If you play back the project and activate the metronome click, the different project parts use the
defined click patterns. The Click Pattern Editor in the Transport shows the pattern at the
project cursor position.
RELATED LINKS
Click Pattern Editor on page 247
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The Project Browser provides a list-based representation of the project. It allows you to view and
edit all events on all tracks.
●

To open the Project Browser, select Project > Browser.
NOTE
The Project Browser can be open while you are working in other windows. Any changes in
the Project window or an editor are immediately reflected in the Project Browser and vice
versa.

1

Project Structure
Allows you to select specific track types for viewing and editing in the event display.

2

Toolbar
Contains tools and settings for editing.

3

Info Line
Shows information about the selected item.

4

Event Display
Allows you to view and edit the selected item.

Toolbar
The toolbar contains tools and settings for editing in the Project Browser.
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1

Open/Close All
Opens/Closes all folders in the Project Structure list.

2

Time Format pop-up menu
Allows you to change the time display format in the Project Browser.

3

Track/Part/Event type pop-up menu
Shows what is added when you click Add.

4

Add button
Adds the track, part, or event type that is shown in the pop-up menu to the left.

5

Filter pop-up menu
Allows you to filter the event display by event type.

6

Sync Selection
Links the selection in the Project Browser to the selection in the Project window. This
allows you to locate events in the two windows.

Project Structure
The Project Structure allows you to select specific track types for viewing and editing in the
event display. Depending on what track type you select, different items can be available in the
Project Structure.

Track Data

If you select Track Data, the Project Structure shows audio events and/or audio parts, which in
turn can contain audio events, or MIDI parts, which in turn can contain MIDI events.
Track Data is available for audio and MIDI tracks.

Automation
Selecting Automation in the Project Structure shows the automation events of the track, if
available.
Each Automation item in the Project Structure has subentries for each automated parameter.

Event Display
The Project Browser event display allows you to view and edit the selected item.
NOTE
Not all columns are available for all events. You can rearrange the order of the columns by
clicking a header and dragging left or right.
Name
Double-click the name to change it. You cannot change the name for the left and
right locator.
Audio events: Double-click the waveform image to open the event in the Sample
Editor.
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Audio parts: Double-click the waveform image to open the event in the Audio Editor.
MIDI parts: Double-click the part image to open the event in the Key Editor.
File
Audio events: The name of the audio file referenced by the audio clip of the event.
Type
MIDI events: The type of the MIDI event.
Tempo track: The type of the tempo curve.
Start
The start position of the event.
End
The end position of the event.
Position
The position of an event.
Tempo
The tempo value of a tempo event.
Signature
The time signature value of a signature event.
Snap
Audio events: The position of the event snap point. Adjust this value to move the
audio event.
Length
The length of the event.
Offset
The event start position in the clip.
NOTE
If the event already plays the whole clip, this value cannot be adjusted.
Volume
The volume of the event.
Fade In/Fade Out
The length of the fade-in and fade-out areas respectively.
NOTE
If you add a fade, a linear fade is created. If you adjust the length of an existing fade,
the previous fade shape is maintained.
Mute
Mutes or unmutes the event.
Image
Audio events: Displays a waveform image of the event.

996

Project Browser
Event Display

Editing Note Expression Data
In the Project Browser, you can view and edit the MIDI controller events or VST 3 events of a
MIDI note with note expression data.
PROCEDURE
1.

In the Project Structure, select the Note Expression subitem of the MIDI note that you
want to view or edit.
In the event display, all MIDI controllers or VST 3 events within the note expression data
are listed.

2.

In the event display, edit the parameter values.

RESULT
The event changes accordingly.
EXAMPLE
If you entered a different Start value, the event is moved.
RELATED LINKS
Note Expression on page 883

Deleting events
PROCEDURE
1.

Select an event or a part in the event display.

2.

Do one of the following:
●

Select Edit > Delete.

●

Press Delete or Backspace.

RESULT
The selected event is deleted.
IMPORTANT
You cannot delete the first tempo event or the first time signature event of the project.
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The track sheet provides a text-form flow-chart representation of your project. It lists all audio
and video tracks and their contents, and you can easily print it out.
To open the Track Sheet window, select Project > Track Sheet.

The Track Sheet window contains the following items:
●

The leftmost time column contains a list of time positions in the display format selected in
the Project Setup dialog.
The time positions relate to start and end times of audio or video events or parts on the
tracks.

●

The following columns display the tracks in the order they appear in the track list.
Only audio and video tracks are shown.

●

The events are listed in their corresponding track columns in the order they appear
(starting at the top).

●

For each event, the start and end times are shown, with a vertical line binding the two
together.
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Viewing the Pages in the Track Sheet
If your project contains many tracks and events or if you are working with a large scale factor,
the track sheet may have more than one page.
The more tracks you have, the larger the number of pages next to each other. The more events
you have, the larger the number of pages below each other.
To select which page is visible, use the Y Page and X Page fields in the upper left part of the
Track Sheet window.

In this case, the page in row 2 and column 3 is shown:

●

To determine the size and proportions of the track sheet pages, select File > Page Setup.

RELATED LINKS
Printing the Track Sheet on page 1001

Adjusting the View
You can adjust the view of the contents in the Track Sheet window.
●

To adjust the size of the track sheet contents such as font sizes, and the number of tracks
and events shown on each page, use the slider in the lower left corner.

●

To zoom the display of the Track Sheet window, use the slider in the lower right corner.
The printout is not affected.

●

To also adjust the width of the columns, drag the edges of the Timecode and Tracks fields
at the top of the window. This resizes the corresponding columns in the track sheet.
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Additional Settings

Y Page
Determines which row is viewed. The number in parenthesis shows the total number
of rows.
X Page
Determines which column is viewed. The number in parenthesis shows the total
number columns.
Pen Width
Determines the thickness of the vertical lines that bind together the start and end
times for events and parts.
Timecode column on 1st page/Timecode column on all pages/No timecode column
Allows you to determine on which page the timecode column is displayed.
Less/More
Shows/Hides the track sheet settings.
Project
Shows the name of the current project by default. You can adjust this if you like. This
name is shown in the top left corner of each track sheet page.
Heading
Allows you to enter a heading that is shown centered at the top of each track sheet
page.
Editor
Allows you to enter an editor name that is shown below the project name in the track
sheet.
Do not show end times if length is under
Activate this to hide end times of events that are shorter than the time specified in
the field to the right. This is useful if you have many short events, like spot effects,
where only the start time is of any relevance.
No leading zeroes
Activate this, if you do not want to display leading zeros for timecode values.
Merge events if gap is less or equal
Allows you to specify a gap value that defines how large a gap between events must
be for them to be considered as separate events. If gaps between events are smaller
than or equal to this value, they are listed as a single event.
Name Filter
Allows you to filter out event names from the track sheet. You can enter several
names, separate each with a semi-colon.
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Printing the Track Sheet
Printing is done using the standard procedures:
PROCEDURE
1.

Select File > Page Setup.

2.

Make sure that the correct page size and page orientation are selected.
You may also want to make additional printer settings, following the standard Windows/
macOS procedures.

3.

Select File > Print.

4.

Make the desired printer settings, and click Print.

RESULT
The track sheet is printed.
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You can render existing material to new audio material.
You can render the following:
●

Audio tracks

●

Instrument tracks

●

Audio events or parts on audio tracks

●

MIDI parts on instrument tracks

●

Range selections on audio or instrument tracks

●

Range selections on multiple audio or instrument tracks

IMPORTANT
The rendering function does not support side-chain routing.

Render Tracks
The Render Tracks dialog allows you to customize the track render settings.
To open the Render Tracks dialog, select one or more audio tracks, instrument tracks, or MIDI
tracks, and select Edit > Render in Place > Render Settings.

The following settings are available:
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As Separate Events
One or more tracks are created. These contain separate events or parts that are
saved as separate audio files.
As Block Events
One or more tracks are created. These contain adjacent events/parts that are
combined to blocks. Every block is saved as a separate audio file.
As One Event
One or more tracks are created. These contain the events/parts that are combined to
one event/part. Every combination is saved as a separate audio file.
Dry
If this option is activated, all effects and panner settings are copied to new audio
tracks. The resulting audio tracks keep the formats of their source tracks. A mono
track results in a mono track, for example.
Channel Settings
If this option is activated, all effects are rendered into the resulting audio files. This
includes insert effects, channel strip settings, group channel settings, and FX send
channel settings. Panner settings are transferred to the new audio tracks. The
resulting audio tracks keep the formats of their source tracks. A mono track results in
a mono track, for example.
Complete Signal Path
If this option is activated, the complete signal path is rendered into the new audio
files, including all channel settings, group channel settings, FX send channel settings,
and panner settings. The new audio track is created without effects. Stereo balance
panner settings are activated. The resulting audio file format is determined by the
output channel of the source track. A mono track that is routed to a stereo bus
results in a stereo audio file.
Complete Signal Path + Master FX
If this option is activated, the complete signal path and the master bus settings are
rendered into the resulting audio files. This includes all channel settings, group
channel settings, FX send channel settings, and panner settings. The resulting audio
file format is determined by the output channel of the source track. A mono track
that is routed to a stereo bus results in a stereo audio file.
Mix Down to One Track
By default, rendering multiple tracks or selections from multiple tracks at once
results in multiple new audio tracks. To create one resulting audio track from all your
source material, activate Mix Down to One Track.
Mix Down to One Track is only available if several tracks are selected and Dry
(Transfer Channel Settings) is deactivated.
Tail Size
Allows you to set a tail size in seconds or bars and beats for the rendered files. This
adds time at the end of the rendered file to allow reverb and delay tails to fully fade
out.
Bit Depth
Allows you to set the bit depth for the resulting material to 16 bit, 24 bit, 32 bit,
32 bit float, or 64 bit float.
Name
Allows you to enter a custom name for the rendered files. To do this, unlock this
option by clicking the lock icon.
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Path
Allows you to select a custom folder to which the resulting .wav files are rendered.
Keep Source Tracks Unchanged
If this option is selected, the source tracks remain unchanged.
Mute Source Tracks
If this option is selected, the source tracks are automatically muted.
Disable Source Tracks
If this option is selected, the source tracks are disabled and are therefore no longer
processed. This option releases CPU and RAM resources and is therefore similar to
the Freeze function. To reenable the tracks, right-click the disabled track to open the
context menu and select Enable Track.
Remove Source Tracks
If this option is selected, the source tracks are removed from the track list.
Hide Source Tracks
If this option is activated, the source tracks are hidden after rendering. To show the
source tracks again, select the Visibility tab in the Project window and select the
track that you want to show.
RELATED LINKS
Setting Pan on page 386

Rendering Tracks
You can render selected tracks either via the Render Tracks dialog or by directly using the
Render (with Current Settings) command.
PROCEDURE
1.

Select one or more audio, MIDI, or instrument tracks.

2.

Select Edit > Render in Place > Render Settings.

3.

Specify the render options.

4.

Click Render.

RESULT
All selected source material is processed according to your render settings. Your render options
are saved and used for all further render operations.
NOTE
You can also start the rendering operation directly by selecting Edit > Render in Place > Render
(with Current Settings).

Render Selection
You can render selections of audio events and/or MIDI parts with default settings or with
customized settings. The Render Selection dialog allows you to customize the selection render
settings.
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The following settings are available:
As Separate Events
One or more tracks are created. These contain separate events or parts that are
saved as separate audio files.
As Block Events
One or more tracks are created. These contain adjacent events/parts that are
combined to blocks. Every block is saved as a separate audio file.
As One Event
One or more tracks are created. These contain the events/parts that are combined to
one event/part. Every combination is saved as a separate audio file.
Dry
If this option is activated, all effects and panner settings are copied to new audio
tracks. The resulting audio tracks keep the formats of their source tracks. A mono
track results in a mono track, for example.
Channel Settings
If this option is activated, all effects are rendered into the resulting audio files. This
includes insert effects, channel strip settings, group channel settings, and FX send
channel settings. Panner settings are transferred to the new audio tracks. The
resulting audio tracks keep the formats of their source tracks. A mono track results in
a mono track, for example.
Complete Signal Path
If this option is activated, the complete signal path is rendered into the new audio
files, including all channel settings, group channel settings, FX send channel settings,
and panner settings. The new audio track is created without effects. Stereo balance
panner settings are activated. The resulting audio file format is determined by the
output channel of the source track. A mono track that is routed to a stereo bus
results in a stereo audio file.
Complete Signal Path + Master FX
If this option is activated, the complete signal path and the master bus settings are
rendered into the resulting audio files. This includes all channel settings, group
channel settings, FX send channel settings, and panner settings. The resulting audio
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file format is determined by the output channel of the source track. A mono track
that is routed to a stereo bus results in a stereo audio file.
Mix Down to One Track
By default, rendering multiple tracks or selections from multiple tracks at once
results in multiple new audio tracks. To create one resulting audio track from all your
source material, activate Mix Down to One Track.
Mix Down to One Track is only available if several tracks are selected and Dry
(Transfer Channel Settings) is deactivated.
Tail Size
Allows you to set a tail size in seconds or bars and beats for the rendered files. This
adds time at the end of the rendered file to allow reverb and delay tails to fully fade
out.
Bit Depth
Allows you to set the bit depth for the resulting material to 16 bit, 24 bit, 32 bit,
32 bit float, or 64 bit float.
Name
Allows you to enter a custom name for the rendered files. To do this, unlock this
option by clicking the lock icon.
Path
Allows you to select a custom folder to which the resulting .wav files are rendered.
Keep Source Events Unchanged
If this option is selected, the source tracks remain unchanged.
Mute Source Events
If this option is selected, the source tracks are automatically muted.

Rendering Selections
You can render selections or range selections of audio events and/or MIDI parts via the Render
Selection dialog.
PROCEDURE
1.

Select one or more audio events and/or MIDI parts or make a range selection.

2.

Select Edit > Render in Place > Render Settings.

3.

In the Render Selection dialog, specify the render options.

4.

Click Render.

RESULT
All selected source material is processed according to your render settings. Your render options
are saved and used for all further render operations.
NOTE
You can also start the rendering operation directly by selecting Edit > Render in Place > Render
(with Current Settings).
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The Export Audio Mixdown function allows you to mix down and export all audio that is
contained between the left and right locators of a project or in ranges defined by cycle markers.
To open the Export Audio Mixdown dialog, select File > Export > Audio Mixdown.

The Export Audio Mixdown dialog is divided into several sections:
1

Channel Selection
Allows you to select the channels that are mixed down from a list of all output and audiorelated channels that are available in the project.

2

Cycle Marker Selection
Allows you to export sections of your project that are defined by cycle marker ranges of
the active marker track.
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3

File Location
Allows you to set up the naming scheme and to select a path for the exported file.

4

File Format
Allows you to select a file format and make additional settings for the file to be created.
This includes codec settings, metadata, sample rate, bit depth, etc. The available options
depend on the selected file format.

5

Audio Engine Output
Allows you to specify a sample rate, a bit depth, and the number of audio channels for the
audio output.

6

Import Into Project
Allows you to automatically import the resulting audio file back into your project.

7

Post Process
Allows you to specify what happens after the export process.

RELATED LINKS
Channel Selection on page 1009
Cycle Marker Selection on page 1010
File Location on page 1010
File Format on page 1013
Audio Engine Output on page 1020
Import Into Project on page 1021
Post Process on page 1022

Mixing Down to Audio Files
PROCEDURE
1.

Set up the left and right locators to encompass the section that you want to mix down.
You can also set up a cycle marker.

2.

Set up your tracks so that they play back the way you want.
This includes muting unwanted tracks or parts, making manual MixConsole settings,
and/or activating the R (Read) automation buttons for MixConsole channels.
IMPORTANT
The setting of the Output Routing in the corresponding track Inspector determines the
channel width of the Export Audio Mixdown export. This means, if no main output bus is
selected, the exported audio file only contains silence.

3.

Select File > Export > Audio Mixdown.

4.

In the Export Audio Mixdown dialog, make your settings.

5.

Click Export.

RESULT
The audio file is exported.
IMPORTANT
●

If you set the export range in such a way that the effects that are applied to a preceding
event, for example reverb, reach into the next, these will be heard in the mixdown even
though the event itself is not included. To avoid this, mute the first event.
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Available Channels for Export
The Channel Selection section of the Export Audio Mixdown dialog contains a list of channels
that you can export as an audio mixdown.
The channels are organized in a hierarchical structure. Channels of the same type are grouped.
This allows you to easily identify and select the channels for export.
NOTE
MIDI tracks are not available for export. To include MIDI in a mixdown, you must record MIDI to
audio tracks.
You can mix down the following channel types:
●

Output channels
All output channels that you configured in the Audio Connections dialog are listed in the
Channel Selection section. By activating an output channel in the list, you instruct Nuendo
to mix down all tracks that are routed to this output channel.

●

Audio channels
All audio channels that are available in your project are listed in the Channel Selection
section. By activating an audio channel in the list, you instruct Nuendo to mix it down to a
file, including insert effects, EQ, etc.

●

Any audio-related MixConsole channels
All VST instrument channels, instrument tracks, effect return channels (FX channel tracks),
group channels, and ReWire channels of your project are listed in the Channel Selection
section. By activating an audio-related channel in the list, you instruct Nuendo to mix it
down, including insert effects, EQ, etc.

RELATED LINKS
Audio Connections on page 22

Channel Selection
The Channel Selection section allows you to select the channels that are mixed down.

1

Channel Batch Export
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Activate this option if you want to mix down several channels simultaneously. An individual
file is created for each channel. If you activate a channel type in the list, all channels of this
type are selected.
2

Channels available for export
In the list, activate the channels that you want to include in the mixdown. Only the sound
of the activated channels is included in the mixdown. MixConsole settings, record enable,
and insert effects are taken into account.

3

Filter
Allows you to enter the channel name to filter the channels. This is useful if your project
contains a large number of channels.

Cycle Marker Selection
You can export different sections of a project at the same time.

To enable this, you must define several cycle marker ranges. In the Cycle Marker Selection
section of the Export Audio Mixdown dialog, you can activate the cycle markers to include their
ranges in the mixdown.
1

Export Cycle Marker(s)
Activate this option to select the available cycle markers in the list. This option is only
available if you set up at least 1 cycle marker.

2

Cycle markers available for export
Activate the cycle markers that define the ranges that you want to include in your
mixdown. On export, one audio file is created for each range.
NOTE
Only the cycle markers of the active marker track can be selected.

RELATED LINKS
Markers on page 334

File Location
The File Location section allows you to specify a name and path for the mixdown file.

1

Name
Specifies the name of the mixdown file.

2

Naming Options
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Opens a pop-up menu with naming options:

3

●

Set to Project Name inserts the project name into the Name field.

●

Auto Update Name adds a number to the file name and increments the number
every time you export a file.

Path
Opens a dialog that allows you to browse for a file location.

4

Path Options
Opens a pop-up menu with the following options:

5

●

Choose opens a dialog that allows you to browse for a file location.

●

Use Project Audio Folder sets the path to the Audio folder of your project.

●

Recent Paths allows you to select recently selected file locations.

●

Clear Recent Paths allows you to delete all recently selected file locations.

Naming Scheme
Opens a dialog where you can specify a naming scheme for the mixdown file name.

6

Resolve File Name Conflicts
Specifies how file name conflicts with existing files are resolved.

RELATED LINKS
Naming Scheme Dialog on page 1011
Resolve File Name Conflicts on page 1012

Naming Scheme Dialog
The Naming Scheme dialog allows you to define naming schemes for the audio material that
you want to export.
The naming attributes that are available in this dialog depend on the channel that you selected
for export.
●

To open the Naming Scheme dialog, click Naming Scheme in the Export Audio Mixdown
dialog.

1

Scheme
Allows you to select, create, save, and delete naming schemes.

2

Attributes
Shows the available naming scheme attributes.

1011

Export Audio Mixdown
File Location
3

Result
Allows you to drag and drop attributes to this field and rearrange them by dragging.

4

Settings
Allows you to make separator and counter settings.

5

Preview
Displays a preview of your current naming scheme.

RELATED LINKS
Channel Selection on page 1009

Defining Naming Schemes
You can define a naming scheme by combining attributes that determine the structure of the file
names for the exported audio files.
Depending on the settings in the Channel Selection section and the Cycle Marker Selection
section, different naming attributes are available.
PROCEDURE
1.

Drag and drop up to 5 attributes into the Result section.
You can also double-click an attribute to add it to the Result section.

2.

In the Settings section, double-click the Separator text field and type in a separator.
The Preview section displays the file name scheme according to your settings.

3.

Click the up or down arrows to set the Counter.
The counter will start counting from this value. You can also double-click the Counter text
field and enter a value.

4.

Click the Digits field and select the number of digits from the pop-up menu.
The Digits setting determines how many digits the counters will contain.

5.

Optional: Double-click the text field in the Scheme section and enter a preset name. Press
enter to save your settings as a preset.
NOTE
The preset is only available for the channels that are selected in the Channel Selection
section of the Export Audio Mixdown dialog.

Resolve File Name Conflicts
Exporting audio can cause name conflicts with existing files that have the same name. You can
define how file name conflicts are resolved.
In the Export Audio Mixdown dialog, select one of the following options from the Resolve File
Name Conflicts pop-up menu:
Always Ask
Always asks if an existing file should be overwritten or if a new unique file name
should be created by adding an incremental number.
Create Unique File Name
Creates a unique file name by adding an incremental number.
Always Overwrite
Always overwrites the existing file.
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File Format
The File Format section allows you to select a format and make additional settings for the
mixdown file.
The following file formats are available:
●

Wave File
This is the most common file format on the PC platform. Wave files have the
extension .wav.

●

AIFC File
This is an audio file format standard defined by Apple Inc. AIFC files are used on most
computer platforms. They support compression ratios as high as 6:1 and contain tags in
the header. AIFC files have the extension .aifc.

●

AIFF Files
This is an audio file format standard defined by Apple Inc. AIFF files are used on most
computer platforms. The files can contain embedded text strings. AIFF files have the
extension .aif.

●

MXF File
This is a container format for digital video and audio. MXF files are used on most computer
platforms. The files are often part of AAF projects and have the extension .mxf.

●

MPEG
This is a family of standards used for encoding audio-visual information such as movies,
video, and music in a digital compressed format. Nuendo can read MPEG Layer 2 and
MPEG Layer 3. MP3 files are highly compressed files that still provide good audio quality.
The files have the extension .mp3.

●

Windows Media Audio File (Windows only)
This is an audio file format defined by Microsoft Inc. WMA files can be decreased in size
with no loss of audio quality. WMA Pro features the possibility of mixing down to 5.1
surround sound. The files have the extension .wma.

●

FLAC File
This is an open source format that reduces the size of audio files by 50 to 60 % compared
to regular Wave files. The files have the extension .flac.

●

Ogg Vorbis File
This is an open source, patent-free audio encoding and streaming technology. The Ogg
Vorbis encoder uses variable bit rate encoding. It offers compressed audio files of small
size, but with comparatively high audio quality. The files have the extension .ogg.

●

Wave 64 File
This is a proprietary format developed by Sonic Foundry Inc. Wave 64 files offer the same
quality as Wave files, but they can be considerably larger than standard Wave files. They
are especially suited for long recordings with file sizes over 2 GB. The files have the
extension .w64.

Wave Files
Wave files have the extension .wav and are the most common file format on the PC platform.
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If you select the Wave File format for the exported file, you can make the following settings:
1

Insert Broadcast Wave Chunk
Activates the embedding of additional file information in Broadcast Wave format.
NOTE
By activating this option, you create a Broadcast Wave file. Some applications may not be
able to handle these files. If you get problems using the file in another application,
deactivate Insert Broadcast Wave Chunk and export the file again.
Broadcast Wave files also contain loudness metadata according to EBU R-128 that can be
shown in the Attribute Inspector of the MediaBay.

2

Edit
Opens the Broadcast Wave Chunk dialog where you can enter information.

3

Don’t Use Wave Extensible Format
Deactivates the Wave Extensible format that contains additional metadata, such as the
speaker configuration.

4

Don’t Use RF64-compliant File Format
Deactivates the RF64-compliant format that allows file sizes to exceed 4 GB.

5

Insert iXML Chunk
Includes additional project-related metadata, such as project name, author, and project
frame rate.

6

Insert Tempo Definition
This option is only available if Insert iXML Chunk is activated. It allows you to include
tempo information from the tempo track or from the Definition section of the Sample
Editor in the iXML chunk of the exported files.

7

Normalize to Integrated Loudness
Normalizes your audio to the integrated loudness value that is specified in the field to the
right.

RELATED LINKS
Attribute Inspector on page 632
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AIFC Files
AIFC files support compression ratios as high as 6:1 and contain tags in the header. AIFC files
have the extension .aifc and are used on most computer platforms.

1

Insert Broadcast Wave Chunk
Activates the embedding of additional file information in Broadcast Wave format.
NOTE
By activating this option, you create a Broadcast Wave file. Some applications may not be
able to handle these files. If you get problems using the file in another application,
deactivate Insert Broadcast Wave Chunk and export the file again.
Broadcast Wave files also contain loudness metadata according to EBU R-128 that can be
shown in the Attribute Inspector of the MediaBay.

2

Edit
Opens the Broadcast Wave Chunk dialog where you can enter embedded information.

3

Insert iXML Chunk
Includes additional project-related metadata, such as project name, author, and project
frame rate.

4

Insert Tempo Definition
This option is only available if Insert iXML Chunk is activated. It allows you to include
tempo information from the tempo track or from the Definition section of the Sample
Editor in the iXML chunk of the exported files.

5

Normalize to Integrated Loudness
Normalizes your audio to the integrated loudness value that is specified in the field to the
right.

AIFF Files
AIFF stands for Audio Interchange File Format, a standard defined by Apple Inc. AIFF files have
the extension .aif and are used on most computer platforms.

1

Insert Broadcast Wave Chunk
Activates the embedding of additional file information.
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NOTE
By activating this option, you create a Broadcast Wave file. Some applications may not be
able to handle these files. If you get problems using the file in another application,
deactivate Insert Broadcast Wave Chunk and export the file again.
Broadcast Wave files also contain loudness metadata according to EBU R-128 that can be
shown in the Attribute Inspector of the MediaBay.
2

Edit
Opens the Broadcast Wave Chunk dialog where you can enter embedded information.

3

Insert iXML Chunk
Includes additional project-related metadata, such as project name, author, and project
frame rate.

4

Insert Tempo Definition
This option is only available if Insert iXML Chunk is activated. It allows you to include
tempo information from the tempo track or from the Definition section of the Sample
Editor in the iXML chunk of the exported files.

5

Normalize to Integrated Loudness
Normalizes your audio to the integrated loudness value that is specified in the field to the
right.

MP3 (MPEG-1 Layer 3) files
MP3 files are highly compressed files that still provide good audio quality. They have the
extension .mp3.

1

Bit Rate
Sets the bit rate for the MP3 file. The higher the bit rate, the better the audio quality and
the larger the file. For stereo audio, 128 kBit/s is considered to be providing good audio
quality results.

2

Sample Rate
Sets the Sample Rate for the MP3 file.

3

High Quality Mode
Sets the encoder to a different resampling mode. This may give better results depending
on your settings. However, it does not allow you to select the Sample Rate.

4

Insert ID3 Tag
Includes ID3 Tag information in the exported file.

5

Edit ID3 Tag
Opens the ID3 Tag dialog that allows you to enter information about the file. This
information is embedded in the file and can be displayed by most MP3 playback
applications.
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Windows Media Audio Files (Windows only)
The Windows Media Audio format by Microsoft Inc. uses advanced audio codecs and lossless
compression. WMA files can be decreased in size with no loss of audio quality. Furthermore,
WMA features the possibility of mixing down to 5.1 surround sound. The files have the
extension .wma.

●

Codec Settings
Opens the Windows Media Audio File Settings dialog.

Windows Media Audio File Settings - General
The General tab in the Windows Media Audio File Settings dialog allows you to specify sample
rate, bit rate, and channels for the encoded file.

1

Sample Rate
Allows you to set the sample rate to 44.100, 48.000, or 96.000 kHz. Set this to match the
sample rate of the source material or use the closest available value that is higher than the
actual value.

2

Bit Depth
Allows you to set the bit depth to 16 bit or 24 bit. Set this parameter to match the bit depth
of the source material or use the closest available value that is higher than the actual
value.
NOTE
Always keep in mind the intended use of the file. For publication on the Internet, you
might not want too high bit rates, for example.

3

Channels
This setting depends on the chosen output. You cannot change it manually.

4

5

Mode
●

Select Constant Bit Rate if you want to limit the file size. To calculate the size of a
file that is encoded with a constant bit rate, multiply the bit rate by the duration of
the file.

●

Select Variable Bit Rate if you want the bit rate to fluctuate depending on the
character and intricacy of the material being encoded. The more complex passages
in the source material, the higher the bit rate – and the larger the final file.

●

Select Lossless to encode the file with lossless compression.

Bit Rate/Quality
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●

Allows you to set the bit rate settings depending on the selected mode and/or output
channels. The higher the bit rate or quality you select, the larger the final file.

Windows Media Audio File Settings - Advanced
The Advanced tab in the Windows Media Audio File Settings dialog allows you to specify the
dynamic range control, that is, the difference in dB between the average loudness and the peak
audio level (the loudest sounds) of the audio for the encoded file.

1

Dynamic Range Control
The dynamic range is automatically calculated during the encoding process. If you activate
this option, you can specify the dynamic range manually.
If Dynamic Range Control is activated and the Quiet Mode of the Windows Media Player
is set to Medium Difference, the peak level is limited to the peak value that you specified. If
Dynamic Range Control is deactivated, the peak level is limited to 12 dB above the
average level during playback.
If Dynamic Range Control is activated and the Quiet Mode of the Windows Media Player
is set to Little Difference, the peak level is limited to the average value between the peak
and average values that you specified. If Dynamic Range Control is deactivated, the peak
level is limited to 6 dB above the average level during playback.

2

Peak
Allows you to set a peak value between 0 and -90 dB.

3

Average
Allows you to set a peak value between 0 and -90 dB. However, this affects the overall
volume level and can have a negative effect on the audio quality.

Windows Media Audio File Settings - Media
The Media tab in the Windows Media Audio File Settings dialog allows you to enter information
about the file.

Use the Title, Author, Copyright, and Description fields to enter a file description of its content
that is embedded in the file header. This can be displayed by some Windows Media Audio
playback applications.
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FLAC Files
Free Lossless Audio Codec files are audio files that are typically 50 to 60 % smaller than regular
Wave files.

1

Compression Level
Sets the compression level for the FLAC file. Since FLAC is a lossless format, the level has
more influence on the encoding speed than on the file size.

Ogg Vorbis Files
Ogg Vorbis is an open source, patent-free audio encoding and streaming technology, offering
compressed audio files of small size, but with comparatively high audio quality. Ogg Vorbis files
have the extension .ogg.

1

Quality
Sets the quality for the variable bit rate encoding. This setting determines between which
limits the bit rate will vary. The higher the value, the higher the sound quality but also the
larger the files.

MXF files (OP-Atom)
MXF stands for Material Exchange Format. This is a container format for digital video and audio.
MXF files have the extension .mxf and are used on most computer platforms.
MXF audio files are often part of AAF projects.
RELATED LINKS
AAF Files on page 1124
MXF Files on page 1125

Wave 64 Files
Wave 64 is a proprietary format developed by Sonic Foundry Inc. Wave 64 files have the
extension .w64.

NOTE
In terms of audio quality, Wave 64 files are identical to standard Wave files, but in the file
headers, Wave 64 files use 64-bit values for addressing where Wave files use 32-bit values. The
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consequence of this is that Wave 64 files can be considerably larger than standard Wave files.
Wave 64 is therefore a good file format choice for long recordings, for example, if the file sizes
exceed 2 GB.
1

Insert Broadcast Wave Chunk
Embeds additional file information in Broadcast Wave Format.
NOTE
Activating this option creates a Broadcast Wave file. Some applications may not be able to
handle Broadcast Wave files. If you get problems using the file in another application,
deactivate Insert Broadcast Wave Chunk and export the file again.
Broadcast Wave files also contain loudness metadata according to EBU R-128 that can be
shown in the Attribute Inspector of the MediaBay.

2

Edit
Opens the Broadcast Wave Chunk dialog where you can enter embedded information.

3

Insert iXML Chunk
Includes additional project-related metadata, such as project name, author, and project
frame rate.

4

Insert Tempo Definition
This option is only available if Insert iXML Chunk is activated. It allows you to include
tempo information from the tempo track or from the Definition section of the Sample
Editor in the iXML chunk of the exported files.

5

Normalize to Integrated Loudness
Normalizes your audio to the integrated loudness values that are specified in the field to
the right.

Audio Engine Output
The Audio Engine Output section contains all the settings related to the output of the Nuendo
audio engine.

1

Sample Rate
NOTE
This parameter is only available for uncompressed audio file formats and FLAC files.
Allows you to select the frequency range of the exported audio. If you set the value lower
than the project sample rate, the audio quality degrades and the high-frequency content is
reduced. If you set the value higher than the project sample rate, the file size increases
without increasing the audio quality. For CD burning select 44.100 kHz, because this is the
sample rate used on audio CDs.

2

Bit Depth
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NOTE
This parameter is only available for uncompressed audio file formats and FLAC files.
Allows you to select 8 bit, 16 bit, 24 bit, 32 bit, 32 bit float, and 64 bit float. If you plan to reimport the mixdown file into Nuendo, select 32 bit float or 64 bit float, depending on the
Processing Precision setting in the Studio Setup dialog. 32-bit float files are twice the size
of 16-bit files. For CD burning, use the 16-bit option, as CD audio is always 16 bit. In this
case, we recommend dithering. Activating the UV22HR dithering plug-in reduces the
effects of quantization noise and artifacts when converting the audio to 16 bit. 8-bit format
results in limited audio quality and should only be used if required.
3

Real-Time Export
Allows you to export the mixdown file in real time. This takes at least the same time as
regular playback. Some VST plug-ins, external instruments, and effects require real-time
export in order to have enough time to update correctly during the mixdown. Consult the
plug-in manufacturers for further information.
During the real-time export of a single channel, the Audition Volume fader is displayed in
the progress dialog. It allows you to adjust the Control Room volume.
NOTE
If the CPU and disk speed of your computer do not allow to export all channels
simultaneously in real time, the program stops the process, reduces the number of
channels, and starts again. Afterwards, the next batch of files is exported. This is repeated
as often as needed to export all selected channels.

4

Mono Downmix
Allows you to downmix all the subchannels of a stereo or surround channel or bus to a
single mono file.
For stereo, the panning law as defined in the Project Setup dialog is applied to avoid
clipping. For surround, the channels are summed and divided through the number of
channels used (in case of a 5.1. channel = (L+R+C+LFE+Ls+Rs)/6).

5

Split Channels
Allows you to export the 2 channels of a stereo bus or all subchannels of a multi channel
bus as separate mono files.

6

L/R Channels
Allows you to export only the left and right subchannels of a multi channel bus into a
stereo file.

RELATED LINKS
VST Audio System on page 14
Dither Effects on page 457
Control Room on page 420

Import Into Project
This section offers several options for importing the resulting mixdown files back into the
existing or into a new project.
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NOTE
When you play back the reimported file in the same project, mute the original tracks so that you
only hear the mixdown.
1

Pool
Imports the resulting audio file automatically back into the Pool as a clip. Deactivating this
option also deactivates the Audio Track option.

2

Audio Track
Creates an audio event that plays the clip on a new audio track, starting at the left locator.
Activating this option also activates the Pool option.

3

Pool Folder
Allows you to specify a Pool folder for the clip.

4

Create New Project
NOTE
This option is only available for uncompressed file formats for which the Use Project
Audio Folder option in the File Location section is deactivated.
Activate this option to create a new project that contains an audio track for each of the
exported channels, as well as the signature and tempo track of the original project.
The tracks will have the corresponding mixdown file as audio event. The track names will
be identical with the export channel names. Note that the new project will be the active
project.
Activating this option disables the Pool and Audio Track options.

NOTE
If you activate any of the options in this section, the Import Options dialog opens for each
exported channel when the export is complete.

RELATED LINKS
Importing Media on page 599
File Location on page 1010

Post Process
In this section, you can select a process that you want to run after mixing down your audio file.

1

Deactivate External MIDI Inputs
Activate this option if MIDI inputs that are performed on external devices should be
ignored during the export process.

2

Close Window after Export
Closes the dialog automatically after export.

3

Update Display
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Export Audio Mixdown
Post Process
Activate this option if you want the meters to be updated during the export process. This
allows you to check for clipping, for example.
4

Post Process
If WaveLab 7.0.1 or higher is installed on your computer, you can select Open in WaveLab
to open your mixdown file in this application after export.
Select Upload to SoundCloud to launch SoundCloud, connect to your user account, and
upload your mixdown.
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Introduction
This chapter describes how you can use Nuendo’s networking technology to collaborate with
other users of Nuendo in a peer-to-peer network.
The “owner” of a project can share it with any number of users via LAN (Local Area Network)
connections and/or WAN (Wide Area Network) connections via standard network protocols.
This allows several separate users to work on a project simultaneously and coordinate their
efforts, as well as exchange ideas and suggestions.
Using Nuendo to collaborate in a network requires that:
●

All users have the same version of Nuendo.

●

All computers are either connected via LAN or via the internet through IP addresses.

What can I use the Networking functions for?
The networking technology in Nuendo allows collaboration with, and exchange of, MIDI, video,
and audio data. Marker tracks and instrument tracks are also included in a shared project. As of
this writing, it is not possible to exchange any MixConsole settings.
Even though the networking technology allows for collaboration via WAN connections over the
internet, it is primarily designed for use in a LAN workgroup. It can also be used for collaboration
over the internet.

Sound Designer II and Networking
IMPORTANT
Please note that using Sound Designer II (SD2) files in projects shared over a network may lead
to unpredictable results, and is not recommended.

Networking protocol and ports
In addition to TCP/IP, the Nuendo networking technology uses the standard network protocol
UDP (User Datagram Protocol - primarily used to broadcast messages over a network).
Since the technology uses the standard protocols and calls of the operating system, no special
hardware or drivers are required to use it, aside from a working NIC card.
Nuendo uses 3 ports in your system for establishing communication, broadcasting messages
and transferring data between users: UDP port 6990, TCP port 6991 and TCP port 6992. These
ports need to be open for network communication to be possible.
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Considerations for internet use
As previously mentioned, the Nuendo networking functions are designed mainly for use in local
area networks, but it is also possible to use them over the internet.
In this case, there are a few things to keep in mind and some system settings you may need to
make:
●

If a network is to be created with any users connected via the internet, all users need to
know the respective IP addresses of the other computers in the network, and use these to
establish the connection.

●

There may also be issues that need to be resolved regarding firewalls and/or computers
connected to the internet via private subnets.

RELATED LINKS
Setting up WAN connections on page 1028

If your computer is behind a firewall
In a LAN, Nuendo uses the UDP port 6990 to establish communication with the other computers.
Over the internet however, Nuendo does not use this port. Instead, connection and
communication is established and handled via TCP/IP messages sent to the TCP ports 6991 and
6992.
This means that the TCP ports 6991 and 6992 must be open on all computers. Firewalls may
block messages to these ports, thus making connection impossible. Consult the documentation
for your firewall (or operating system) for information about how to open ports – or contact your
network administrator.

If your computer is in a subnet that uses NAT
If your computer resides in a subnet that uses NAT (Network Address Translation), all computers
in the subnet share the same external IP address, while the individual computers in the subnet
have internal IP addresses.
In this case, you must set up a port mapping from the external ports 6991 and 6992 to your
internal ports 6991 and 6992, that is, the actual ports on your computer, as opposed to the ports
of the subnet.

If computers are in different NAT subnets
If you want to collaborate with users whose computers reside in different subnets that use NAT
(see above), it might be a good solution to set up a VPN (Virtual Private Network). A VPN allows
secure communication between networks, using the internet for transferring data.
It is beyond the scope of this document to go into any details on how to set up a VPN, but make
sure that your VPN will act as a single network and that the ports 6991, 6992, and, if possible,
6990 are open.
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The network dialogs
The following sections give you a short overview of the network dialogs and their use:

Project Sharing and Permissions
Open this dialog, if you want to specify the user permissions for the active project before sharing
it, either on a project basis, a track basis or both.

Shared Projects
Open this dialog, if you want a list of all identified users and shared projects in the network. This
allows you to share your own projects as well as join projects shared by other users.
Furthermore, the dialog offers the possibility of connecting to WAN (Wide Area Network) users.

User Manager
Open this dialog, if you want to set up lists of users, define their read and write permissions and
save the settings as a permission preset. The presets can then be loaded in the “Project Sharing
and Permissions” dialog, letting you share a project with the settings of the permission preset.

Selecting a user name
When your computer meets the criteria for communicating with other computers (see above),
this is how you quickly go about establishing network communication and share a project with
others:
PROCEDURE
1.
2.

Launch Nuendo.
Activate the network by opening the Network menu and activating the “Active” option.
This establishes network communication and introduces your computer to any computers
already present in the network. Your computer now needs to have a unique ID for
identification.

3.

A dialog opens where you can enter a unique user name to identify your computer in the
network.
This is the name that will be displayed in all the network dialogs to identify you to the
other users in a network.
IMPORTANT
Each user in a network must specify a user name, or network name, in order to be
identified in the network. You can also change the name later.

4.

Click Yes to enter your user name.
A dialog opens where you can enter your user name.
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If you do not enter a user name at this point, the network will not be activated.
5.

Click in the text field, type in a name of your choice and click OK.
If the network has already been created, the original creator – or administrator – may have
already decided on user names for all participants. If so, ask the administrator for yours
and enter it.
NOTE
If a name you enter is already in use on another computer in the network, you will be
prompted to select another name.
When you have entered a user name, you can load or create a project that you want to
share with the other users.

6.

Click the “Share Project” option on the toolbar, or open the “Project Sharing and
Permissions” dialog from the Network menu and activate the “Share Project” option.
The project is now shared and all other users have full access to it.

RELATED LINKS
Creating a permission preset on page 1031
Sharing projects on page 1030

Selecting a user name – alternative method
If you did not specify a user name or if you need to change it, proceed as follows:
PROCEDURE
1.

2.

Do one of the following:
●

Select Network > User Manager.

●

Select Network > Shared Projects.

Enter a name in the Network Name text field, and press Return.
This is the name that will be displayed in all the network dialogs to identify you to the
other users in a network.
IMPORTANT
The following user names “Guest”, “Administrator”, “Admin” and “Anonymous” are reserved
and cannot be used.
Once you have entered a user name and this has been established in the network, it
should not be changed unless absolutely necessary! To use an analogy, this is similar to
registering for an internet service or discussion forum – once you have registered under a
specific name, you cannot log in under another name, unless you create a new account.

Setting up a network
The following is a description of how to set up a network with both LAN and WAN connections.
Your network must meet the following criteria:
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●

For LAN connections, all computers must be part of the same network and communicate
properly.

●

For WAN connections, all computers must have a working internet connection and a public
IP address.

IMPORTANT
If your computer has multiple network interfaces, you must select the IP address of the interface
that is connected to the Nuendo workgroup in the Network Interface Setup dialog. Here, you
must also enter the Sub-Net Mask for your specific network adapter.
The Network Interface Setup dialog opens automatically when starting the application or when
you activate the Network function and multiple network interfaces are available on your
computer.

Setting up LAN connections
If you want to connect to other users via a LAN, you only have to make sure that all computers
actually use the same LAN, that they are communicating properly via the TCP/IP protocol, and
that you have activated the network by checking the “Active” item on the Network menu. If the
computers are unable to communicate, contact your network administrator, or consult the
network documentation for your operating system.

Setting up WAN connections
If you want to connect to other users over the internet, you have to open a WAN connection to
each. This requires that all users have a working internet connection and a public IP address.
WAN connections are set up in the Shared Projects dialog in the following way:
PROCEDURE
1.

Make sure the “Active” item on the Network menu is checked.
This initiates network communication with the other participants.

2.

Open the Shared Projects dialog from the Network menu.

3.

Click the “Add WAN Connection” button on the toolbar.
A dialog opens, requesting the Domain Name or the IP address of the computer you want
to connect to.

The “Add WAN Connection” button

4.

Type in the IP address/Domain Name of the computer you want to connect to and click OK.
An item called “Global IP Network” now appears in the dialog. This lists either the IP
address of the computer to which you have connected, or the domain name of its internet
service provider.

5.

Repeat this procedure for every user you want to connect to over the internet.
NOTE
If a computer is dynamically allocated an IP address by its internet service provider – as
opposed to having a permanent IP address – you will have to repeat the above procedure
each time the computer receives a new IP address!
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●

You can remove a WAN connection by selecting it and clicking the “Remove WAN
Connection” button.

The “Remove WAN Connection” button

●

You can remove the entire “Global IP Network” item by selecting it and pressing
Delete or Backspace.
This will also remove any existing WAN connections.

Should you be unable to establish a WAN connection, first verify that you entered the IP
address correctly. Connection problems may also occur for the following reasons:
●

Your computer and/or the computer you’re trying to connect to is protected by a
firewall.

●

Your computer and/or the computer you’re trying to connect to does not have the
necessary ports open.

RELATED LINKS
Considerations for internet use on page 1025

Updating the network information
If all users in a network are online and have entered user names, you can do the following to
update the network information in Nuendo:
●

Open the Shared Projects dialog and click the “Rescan Network” button to update the
network information.

At this point, the following will happen:
●

The item “Users in Local Network” is updated to display a list of all the online users
connected via LAN, along with their user names.

●

The item “Global IP Network” is updated to display a list of all the online users connected
via WAN, along with their user names.

If the user list is not updated as it should, this is probably because the computers in the network
are not communicating properly.
NOTE
Information about users that are offline will not be updated.

RELATED LINKS
Selecting a user name on page 1026

Verify Communication
Whenever project information needs to be updated over the network, Nuendo will first check if
the connection with all project participants is still working. This check is performed in the
background with a preset timeout period.
When participants do not respond within this timeout period, a “Commit Failed” message is
displayed. At this stage, no further action is performed, as the problem might be temporary due
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to an unplugged laptop, for example. If the problem persists, however, you can call the “Verify
Communication” function via the Network menu.

When this function is called, a dialog shows the progress of the checking process.
●

When all project participants are found, a dialog lists all project participants and their
response times, that is, the time it took for their computers to respond to the check. If the
response times were longer than the standard timeout, or if a participant was not found
who you know is in fact online and waiting for network information, you may want to click
on “Adjust timer”. This will change the timeout threshold in Nuendo to a longer setting,
allowing for participants with slower response times to be found.

●

If project participants are not found because they are offline, a dialog will be shown
allowing you to remove these users from the workgroup.

Transfer Status
Transfer of network data always is performed in the background. If you want to check on the
progress of your transfer processes, you can open the Transfer Status window by pulling down
the Network menu and selecting “Transfer Status…”.

As you upload or download project data, the Transfer Status window displays progress bars for
every track in the project. The Transfer Status window features Cancel buttons for each of the
transfer operations. Use these to stop any transfer operation.

Sharing projects
When you want to share a project with others, you first decide which users you want to have
access to the project, and then specify their read and write permissions.
To set up a list of users and their read and write permissions choose one of the following
methods:
●

Create a permission preset containing all the settings.
Storing permission presets is practical since they let you apply the same list of users and
their permissions to future projects.

●

Set up users and their permissions manually for each project.
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This method also allows you to specify permissions for separate tracks in a project, as
opposed to the entire project.
●

Load the default permissions to let all the participants in a network have access to a
project.

We will first describe all of these methods here, and then proceed to describe how you go about
sharing a project.
RELATED LINKS
About the Default Permissions preset and the Guest user on page 1032

Creating a permission preset
In the User Manager dialog, read and write permission settings for users can be stored in
permission presets. These can then be applied to other projects, that is, the users will
automatically get read and write permissions according to the settings stored in the permission
preset.
●

Read permission allows users to view and play back shared projects or tracks but not make
any changes to them.

●

Write permission allows users to make any changes to shared projects or tracks.
It is not possible to have write permission without also having read permission.

Proceed as follows to create a permission preset:
PROCEDURE
1.

From the Network menu open the User Manager dialog.

2.

Below the “Permission Presets” column click the plus sign.
A dialog for the naming of the new permission preset opens.

3.

Type in the desired name and click OK.
The permission preset is created and added to the list.

The “User Pool” column to the right lists all the users who have entered a user name, and
who have been online and established in the network at some point (note that users do
not have to be online to be listed here).
However, there may also be instances when you want to add a user who is offline and has
not been established in the network. If this is the case, the user is not available in the User
Pool list, but you can still add him to a permission preset in the following way:
4.

Below the “User Pool” column click the plus sign.
A user with a generic name – “User #” – is added to the list.

5.

Type in the desired name.
The user you’re adding may have decided on a user name and entered it, but has been
offline and therefore not yet established in the network. In this case, you can enter that
name if you know it. Otherwise, enter a name of your own choice and later let the user
know which name to use.

The next step is to add users to the permission preset.
6.

Make sure the preset is selected in the “Permission Presets” column.

7.

In the “User Pool” column, select the users you want to add to the permission preset.
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To select several users, hold down Shift or Ctrl/Cmd and click on the user names.
8.

When you have selected the users you want to add, click the Arrow symbol to the left of
the “User Pool” column.
The users you selected will now be added to the “User” column in the middle of the dialog.
The next thing to do is to define the read and write permissions for the added users. In the
Read and Write columns, the read and write permissions for each user can be specified. By
default each added user has both read and write permission.

9.

If you do not want a user to have read or write permission, click the corresponding column
to deactivate the permissions.
NOTE
Having write permission automatically means to also have read permission.

RESULT
When you have added the desired users and specified their read and write permissions, the
preset is complete. The permission preset will now be available for use.

Permission presets apply to entire projects. When a permission preset is loaded, the read and
write permission settings in it are valid for the entire project. However, you can also specify
separate permissions for each track.
NOTE
It is also possible to create a permission preset in the Project Sharing and Permissions dialog.

RELATED LINKS
User Manager on page 1026
Selecting a user name – alternative method on page 1027
Loading a permission preset on page 1035
Setting up permissions for separate tracks on page 1034
Saving the settings as a permission preset on page 1033

Removing permission presets and users
Below each column to the right is a Remove button (the trash icon). You can remove one or
several permission presets or users (including the “Guest” user) from the respective columns by
selecting them and clicking this icon.

About the Default Permissions preset and the Guest user
The “Default Permissions” preset cannot be removed. You can use it either as is, or you can
modify it by adding and removing users. By default, it contains one user – “Guest” – with both
read and write permission.
●

If “Guest” is added to a permission preset, anyone in the network can utilize the Guest
permissions.
Therefore, if you share a project that has Guest as a user, anyone in the network can join it
with the corresponding permissions.
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NOTE
If you want to share a project with everyone in a network and let everyone have both read and
write permission for the entire project, the easiest and quickest way to do this is to use the
Default Permissions preset as is.

Setting up users and permissions manually
Instead of creating a permission preset in the User Manager dialog, you can use the “Project
Sharing and Permissions” dialog to manually set up which users should be allowed to share a
project, and what read and write permissions they should have.
It is not possible to add users who have not yet been established in the network. If this is what
you want, use the “User Manager” dialog.
PROCEDURE
1.

Open the “Project Sharing and Permissions” dialog from the Network menu.

2.

In the “All Users” column to the right, select the users you want to share the project with.
All users in the network that have entered user names and are established in the network
are listed, along with the default “Guest” user. To select several users, hold down Shift or
Ctrl/Cmd and click on the user names.

3.

Click the Add User to Permission List button above the column (the left button).
The selected users are added to the “User Name” column above the “All Users” column.
To remove a user, select the user name in the “User Name” column and click the Delete
User button below the column (the right button).
The user is removed from the “User Name” column. You can remove several users at once.
You should remove the “Guest” user if you do not want everyone in the network to have
full access to the project.

4.

In the “Project & Tracks” column, make sure the top item (the project name) is selected.
This way, the settings you make affect the entire project, rather than separate tracks.

5.

Define the project read and write permissions for the added users, by checking and
unchecking the Read and Write permission columns (“r”, “w”) as desired.
Note that having write permission automatically means also having read permission.
These settings are valid for the entire project. If you want to specify read and write
permissions separately for each track.

RELATED LINKS
Creating a permission preset on page 1031
Setting up permissions for separate tracks on page 1034

Saving the settings as a permission preset
If you have manually added users and set up their read and write permissions for the project in
the “Project Sharing and Permissions” dialog, you can create a permission preset based on the
settings you have made:
PROCEDURE
1.

Click the plus sign to the left of the “Permission Presets” menu in the bottom right corner.
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A dialog opens, allowing you to enter a name for the permission preset.
2.

Type in the desired name and click OK.
The permission preset is saved and added to the menu.
You can now also access this preset in the “User Manager” dialog.

RELATED LINKS
Creating a permission preset on page 1031

Setting up permissions for separate tracks
The “Project Sharing and Permissions” dialog also offers the possibility of specifying read and
write permissions separately for each track in the project.
PROCEDURE
1.

In the “Project & Tracks” column, select the tracks for which you want to make separate
settings.
As you can see, the right part of the dialog now only contains a checkbox and the text
“Override Project Permissions”.

2.

Activate the “Override Project Permissions” option.

3.

Add users and specify their read and write permissions for the tracks.

4.

When you are done, select the top item (the project name) in the “Project & Tracks” column
again.
Permission settings for separate tracks are not saved in a permission preset, but you can
first load a preset with the project permissions and then make settings for separate tracks.
To make separate track permissions in the project Inspector, select a track in the track list,
open the Network section in the Inspector and click the “Override Project Permissions”
button (the key symbol).

This makes it possible to make read and write permission settings for the track directly in
the Inspector.

RELATED LINKS
Setting up users and permissions manually on page 1033
Loading a permission preset on page 1035
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Loading a permission preset
To load a permission preset for the active project, proceed as follows:
PROCEDURE
1.

Open the “Project Sharing and Permissions” dialog from the Network menu.

2.

In the bottom right corner of the dialog, click in the Permission Presets text box to open a
pop-up menu.
The menu lists all available permission presets.

3.

From the menu, select a permission preset.
The users defined in the permission preset are now listed in the User Name column, and
their read and write permissions are displayed.

RESULT
You can now either use the settings of the loaded permission preset as they are for the shared
project, or you can make manual adjustments on a project or track basis.
RELATED LINKS
Setting up users and permissions manually on page 1033

Sharing a project
Once you have set up all the users and their permissions by loading a permission preset and/or
manually adding users and specifying their permissions for this particular project – you can share
the project.

Using the “Project Sharing and Permissions” dialog
PROCEDURE
1.

If it is not already active, activate the network by checking the “Active” option on the
Network menu.

2.

Open the “Project Sharing and Permissions” dialog from the Network menu.

3.

Activate the “Share Project” option.
The project is now shared and available to the users you have specified.

To revoke sharing of the project, deactivate the “Share Project” option.
You can at any time make changes in this dialog, that is, add or remove users and change
permissions, and then update the shared project accordingly for all users by making the
desired changes and clicking the “Commit” button.

Quick Sharing
If you just want to share a project with full read and write access for every user in the network
without loading any permission preset or manually setting up users, the easiest way to do this is
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to click the “Share Project” button on the Project window toolbar (or activating “Share Project” in
the “Project Sharing and Permissions” dialog).
This is provided you have not made any changes to the “Default Permissions” preset. The reason
is that the default permissions (with only the user “Guest”) grant all users full access.
RELATED LINKS
About the Default Permissions preset and the Guest user on page 1032

In the “Shared Projects” dialog
PROCEDURE
1.

If it is not already active, activate the network by checking the option “Active” on the
Network menu.

2.

Open the “Shared Projects” dialog from the Network menu.

3.

Click the “Share Active Project” button.

The “Share Active Project” button

This will open the “Project Sharing and Permissions” dialog, to let you verify that all
permissions are OK before sharing. You can then share the project in the dialog. When the
active project is shared, it appears in the “My Shared Projects” folder.

The “Unshare Selected Project” button

To revoke sharing of a project, select it in the “My Shared Projects” folder and click the
“Unshare Selected Project” button.

Deactivating a shared project
If you are sharing a project and want to stop working on it, you do this by deactivating the
network. When you deactivate the network during work with a shared project, the other users
will be disconnected from it. However, sharing will not be revoked unless you specify it –
meaning that the next time you connect to the network, the project will still be shared, allowing
the other users to join it without you having to make permission settings and share it all over
again.
PROCEDURE
1.

To deactivate the network, pull down the Network menu and select “Active”, so that the
checkmark is removed.

2.

A dialog opens, asking you to confirm that you want to disconnect the network.
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All the users will be disconnected from the project. The project will still be shared when
you connect to the network again.
To reactivate the network, check the “Active” option on the Network menu again.
A dialog opens, asking you to confirm that you want to reconnect the network. All the
users with whom you previously shared the project will now be able to join it again.

About the project folder
When you’re sharing a project, you have to decide whether the project folder for it should be
located on your local hard disk, or – if you’re sharing the project over a LAN and have access to a
common file server – if it should be located on the server.
You should consider the following:
●

If the project folder is located on your hard disk, the files it contains will be copied to the
other users’ hard disks, and their project folders.
This way, work on the files will be done locally on the computer of each user, and the
updated files are then copied to the hard disks of the other users.

●

If you have access to a file server and place the project folder and its contents on it, the
other users can specify this folder as the project folder when they join the project.
In this case, the project files will not be copied to the other users’ hard disks, but are
instead accessed directly on the server. Working on the files directly on a server may be
slower compared to working on them locally. On the other hand, the files will not have to
be copied to each hard disk every time they are updated.

Where to put large media files
If you have a file server that is fast enough for connected workstations to call audio or video
playback of files stored on this server, you should place large media files on this server to avoid
excessive network traffic.
However, when you are using a Windows workstation, note that when you connect your file
server using a drive letter, such as V:\, Nuendo will treat this server as a local drive, which means
that any data from this server used in a shared project will always be copied over the Nuendo
network.
Therefore, try placing your large files on a file server and import them into Nuendo without using
the “Copy File to Working Directory” option. The server path should now be displayed in the Pool.

Joining projects
The “Shared Projects” dialog lets you join projects shared by other users in the network.
This dialog lists all the established users in the network, and any projects they are sharing. For
you to be able to join a project, the user sharing it must be online and have given you read
and/or write access.
To join a project, proceed as follows:
PROCEDURE
1.

Connect to the network by checking the “Active” option on the Network menu.

2.

Open the “Shared Projects” dialog from the Network menu.

3.

If necessary, click the “Rescan Network” button (the rightmost button on the toolbar).
Nuendo scans the network for any updated information about online users and/or shared
projects, and refreshes the Shared Projects dialog accordingly.
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●

The item “Users in Local Network” lists all the established users in a LAN.

●

The item “Global IP Network” lists all the users with whom you have established
WAN connections.

4.

If there are plus signs beside these items, this indicates that a list of users can be
displayed.

5.

If a user is sharing projects, this is indicated by a plus sign beside the user name. Click this
to display a list of the projects shared by this user.
If there are shared projects you can join, these are indicated by the text “You can join”.

6.

To join a project, select it and click the “Join Project” button (or double-click the project
name in the list).
A dialog opens, allowing you to specify the project folder.

7.

Select a project folder.
There may be 2 cases which require special approaches:

8.

●

If you are connected over a LAN, the owner of the project may have decided to keep
the project files in a special, common project folder on a server. If this is the case,
you will need to specify this folder as the Project folder.

●

If the owner of the project keeps the project files in a project folder on a local hard
disk, select a local folder on your hard disk. In this case, the project files will be
copied to the project folder on your hard disk.

When you have selected a project folder, the project and the files are copied to your hard
disk (unless you’re working on a server).
If you have access not to the entire project, but only separate tracks, only the tracks for
which you have read or write permission will be loaded.

RELATED LINKS
Setting up WAN connections on page 1028
About the project folder on page 1037

Downloading selected tracks
When you click the “Download Selected Tracks” button, you can select which tracks from which
shared projects you want to download to your computer.
You will be asked if you want to create a new project. When you select No, the downloaded tracks
will be added to your active project. Note that you cannot download tracks into a shared project.

Merging your project to the network project
When you click the “Merge Active Project to Selected Network Project” button, the active project
will be merged with the selected Network project.
You will be asked if you want to download the shared project before merging.
●

Clicking “No” allows you to simply commit your tracks without having to download all
shared tracks. (Please stay connected until all others have received your tracks.)

●

When you click “Yes”, you can join using your active project without having to create a new
project locally.
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The Project Sharing and Permissions dialog for your local project will be displayed. When you are
happy with all permission settings, click on “Start Merge”. This will join the Network project and
download all available tracks. When the download is complete, you can commit your tracks.

Disconnecting from projects
If you have joined a project and want to stop working on it, you do this by deactivating the
network. When you deactivate the network during work with a shared project, you will
disconnect from it. However, you will still have access to the project in the future as long as the
owner shares it with you. The next time you connect to the network, the project will still be
shared with you (unless the owner has changed the permissions) and you can join it again.
PROCEDURE
1.

Pull down the Network menu and select the Active item, so that it is not checked to
deactivate the network.
A dialog will appear, asking you to confirm that you want to disconnect from the network.

2.

Click “Yes”.
You will disconnect from the project.
To reactivate the network, select “Active” on the Network menu again.
A dialog opens, asking you to confirm that you want to reconnect to the network. If the
project is accessible on the network, you will rejoin it and all the project files will be loaded.

Working with shared projects
Any user who has write access to the project or separate tracks in it can make changes and
commit these to the other users. The communication and transfer of updated files is handled
mainly in the Network section for each track in the Inspector.
The permission status of a track is indicated in the Inspector as follows:
●

If the symbol on the right of the Network section in the Inspector is displayed in a lighter
color, you have both read and write access to the track and can make changes to it.

●

If the symbol on the right of the Network section in the Inspector is orange, you have only
read access to the track, and cannot make changes to it.

The Network section contains several controls for network-related track functions:

1

Load available update

2

Automatically apply updates

3

Get exclusive access (lock track)

4

Commit changes on this track

5

Override project permissions – only available for the owner of the project

In addition to the above, the Network section also displays the user name of the owner of a
project you join.

1039

Networking
Working with shared projects
NOTE
You can also customize Nuendo so that the 4 main network control buttons are available in the
track list. This is done in the Track Controls Settings dialog.

RELATED LINKS
Setting up permissions for separate tracks on page 1034
Track Control Settings on page 99

Committing changes
To a track
When you have made changes to a track, proceed as follows to commit them and make them
known to the users in the network:
PROCEDURE
1.

Open the Network section for the track in the Inspector.
If you have set things up so that the commit button is available in the track list, you do not
have to use the Inspector.

2.

Click the button “Commit changes on this track”.
The changes are committed to the network.
NOTE
If more than one track is selected, clicking this button for one selected track will commit
the changes on all selected tracks. For the owner of a project, this is also the way to update
permission settings made directly in the Inspector.

RELATED LINKS
Setting up permissions for separate tracks on page 1034

To a project
If you have made changes to several tracks, or made other project changes, you will probably
want to commit all changes at once:
●

Pull down the Network menu and select “Commit Changes” to commit the changes over
the network.
Alternatively, you can click the corresponding button on the Project window toolbar.

IMPORTANT
Each time you commit a change to a track or project, network activity is initiated, slowing the
network down. Depending on the speed of the network, it may take some time before the
changes are distributed to all users and work can continue, so commit changes sparingly and
only when necessary.

RELATED LINKS
Using the Setup Options on page 1161
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Loading changes
When other users have made changes to a track and committed them over the network, the
“Load available update” button in the network controls for the corresponding track lights up to
indicate that you can load the changes and update the project.
The “Load available update” button is located in the Network section of the Inspector. However,
when working with shared projects, you will probably want to customize Nuendo so that it is also
available in the track list (see above), since this makes it somewhat easier to get a visual overview
of when committed changes are available.
You can use 2 different methods to load available changes to tracks over the network:
●

Click the “Load available update” button in the Inspector or the track list.
This will load the available update for the track.

●

Click the “Automatically apply updates” button in the Inspector or the track list for one or
more tracks.
This way, all changes committed to the tracks by other users will be automatically loaded
without requiring your intervention.

There is also a special method for loading changes made to the tempo and signature tracks, as
well as loading new tracks:
●

Click the “Sync project to network state” button on the Project window toolbar.
This button lights up to indicate that there are changes available. Click it to have any new
tracks and any changes made to the tempo and signature tracks loaded.

NOTE
By default, the Network controls are not visible on the toolbar. If you want them to be visible, you
need to customize the toolbar.
NOTE
You can also undo an update! If you have loaded an available update, you can select “Undo Net
Update” from the Edit menu. Similarly, you can “undo the undo” by selecting “Redo Net Update”.

Locking tracks
If you have write permission for a track and want to prevent other users from making changes to
it, you can lock it for your own use only.
●

To lock a track for your exclusive use, click the “Get exclusive access” button for the track in
the Inspector or the track list.

●

To unlock a track, click the “Get exclusive access” button again so it is no longer lit.

The owner of a project can unlock a track, regardless of who locked it:
●

When you click the “Get exclusive access” button for a locked track that was not locked by
you, a warning message appears.

●

When you are the owner of the project or track, select “Release Lock” to unlock the track.
Other users can only click “Cancel” to leave the track locked.

About network communication problems
In any network, occasionally, connections may be lost.
When network communication with a participant fails, you can initiate a communication
verification process, and attempt to reestablish the lost connection.
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After the verification process, a dialog lists the results of the verification process. Nuendo may
either have been able to restore communication through the process, or still be unable to
communicate with some participants. The dialog lists each participant with whom
communication still failed.
At this point, you will have to decide whether to remove the participants from the network:
●

If you suspect the communication problems are temporary, select “No” and wait to see if
communications can be restored.
You can then later manually perform the verification process.

●

If you believe the communication problems are more severe, for instance if the
participants have experienced a system or network crash, select “Yes”.
The participants will then be removed from the network until able to rejoin again.

If the verification process does not solve the problem, the communication problems are probably
of a more serious nature and may require re-configuration of the network settings.
NOTE
You can also initiate the verification process manually by selecting “Verify Communication” from
the Network menu.

RELATED LINKS
Verify Communication on page 1029
Setting up a network on page 1027

Reconnecting participants to the Master Network project
When several users have joined a Network project and this is unexpectedly disconnected from
the network, these participants can be automatically reconnected.
PROCEDURE
1.

Open the Master project again.
The program automatically searches 10 seconds for the other users in the network. When
users are found, a dialog is displayed.

2.

Select “Reconnect” if you want the other users to be automatically reconnected.
When you click the “Unshare” button, the project is unshared.
NOTE
This only works if the Master project has been saved.
If you are unsure about the state of connection, it might be a good idea to unshare the
project and to submit it as a new network project, in order to avoid conflicts.

Further options
Chatting with other users on the network
When you are connected to the network, it is possible to chat with other users to discuss changes
you are making to shared projects. All network users can see the same chat window.
●

To chat with all other users on the network, select “Open Global Chat”, type in your
message in the window that opens and press Return.
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●

To chat only with the users working on the shared project, select “Open Project Chat”, type
in your message in the window that opens and press Return.

NOTE
Only messages entered after you joined the chat will be visible to you.

Opening projects with network settings
When you are loading a project containing network settings and the network is deactivated in
Nuendo, the following dialog opens:

●

Click “Activate” to activate the network in Nuendo and try to reconnect the project.

●

Click “Remove” to remove all network settings.
You can choose this when you do not want to work in the network any longer, or if you
have older projects with corrupt network settings, for example.

●

Click “Do Nothing” to open the project without changing any network settings.
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Background
What is synchronization?
Synchronization is the process of getting 2 or more devices to play back together at the same
speed and position. These devices can range from audio and video tape machines to digital
audio workstations, MIDI sequencers, synchronization controllers, and digital video devices.

Synchronization basics
There are 3 basic components of audio/visual synchronization: position, speed, and phase. If
these parameters are known for a particular device (the master), then a second device (the slave)
can have its speed and position “resolved” to the first in order to have the 2 devices play in
perfect sync with one another.
Position
The position of a device is represented by either samples (audio word clock), video
frames (timecode), or musical bars and beats (MIDI clock).
Speed
The speed of a device is measured either by the frame rate of the timecode, the
sample rate (audio word clock) or by the tempo of the MIDI clock (bars and beats).
Phase
Phase is the alignment of the position and speed components to each other. In other
words, each pulse of the speed component should be aligned with each
measurement of the position for the most accuracy. Each frame of timecode should
be perfectly lined up with the correct sample of audio. Put simply, phase is the very
precise position of a synchronized device relative to the master (sample accuracy).

Machine control
When 2 or more devices are synchronized, the question remains: how do we control the entire
system? We need to be able to locate to any position, play, record, and even jog and scrub the
entire system using one set of controls.
Machine control is an integral part of any synchronization setup. In many cases, the device
simply called “the master” will control the whole system. However, the term “master” can also
refer to the device that is generating the position and speed references. Care must be taken to
differentiate between the 2.

Master and slave
Calling one device the “master” and another the “slave” can lead to a great deal of confusion. The
timecode relationship and the machine control relationship must be differentiated in this regard.
In this document, the following terms are used:
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●

The “timecode master” is the device generating position information or timecode.

●

The “timecode slave” is any device receiving the timecode and synchronizing or “locking” to
it.

●

The “machine control master” is the device that issues transport commands to the system.

●

The “machine control slave” is the device receiving those commands and responding to
them.

For example, Nuendo could be the machine control master, sending transport commands to an
external device which in turn sends timecode and audio clock information back to Nuendo. In
that case, Nuendo would also be the timecode slave at the same time. So calling Nuendo simply
the master is misleading.
NOTE
In most scenarios, the machine control slave is also the timecode master. Once it receives a play
command, that device starts generating timecode for all the timecode slaves to synchronize to.

Timecode (positional references)
The position of any device is most often described using timecode. Timecode represents time
using hours, minutes, seconds, and frames to provide a location for each device. Each frame
represents a visual film or video frame.
Timecode can be communicated in several ways:
●

LTC (Longitudinal Timecode) is an analog signal that can be recorded on tape. It should be
used for positional information primarily. It can also be used for speed and phase
information as a last resort if no other clock source is available.

●

VITC (Vertical Interval Timecode) is contained within a composite video signal. It is
recorded onto video tape and is physically tied to each video frame.

●

MTC (MIDI Timecode) is identical to LTC except that it is a digital signal transmitted via
MIDI.

●

Sony P2 (9-Pin, RS-422) Machine Control also has a timecode protocol that is mainly used
for locating and is not nearly accurate enough for speed and phase. It can be used in
certain situations where there is no alternative.

NOTE
The Steinberg SyncStation is capable of using 9-Pin timecode in a very accurate manner.

Timecode standards
Timecode has several standards. The subject of the various timecode formats can be very
confusing due to the use and misuse of the shorthand names for specific timecode standards
and frame rates. The timecode format can be divided into 2 variables: frame count and frame
rate.

Frame count (frames per second)
The frame count of timecode defines the standard with which it is labeled. There are 4 timecode
standards:
24 fps Film (F)
This frame count is the traditional count for film. It is also used for HD video formats
and commonly referred to as 24 p. However, with HD video, the actual frame rate or
speed of the video sync reference is slower, 23.976 frames per second, so timecode
does not reflect the actual realtime on the clock for 24 p HD video.
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25 fps PAL (P)
This is the broadcast video standard frame count for European (and other PAL
countries) television broadcast.
30 fps non-drop SMPTE (N)
This is the frame count of NTSC broadcast video. However, the actual frame rate or
speed of the video format runs at 29.97 fps. This timecode clock does not run in
realtime. It is slightly slower by 0.1 %.
30 fps drop-frame SMPTE (D)
The 30 fps drop-frame count is an adaptation that allows a timecode display running
at 29.97 fps to actually show the clock-on-the-wall-time of the timeline by dropping or
skipping specific frame numbers in order to catch the clock up to realtime.
Confused? Just remember to keep the timecode standard (or frame count) and frame rate (or
speed) separate.

Frame rate (speed)
Regardless of the frame counting system, the actual speed at which frames of video go by in real
time is the true frame rate.
Nuendo supports the following frame rates:
23.98 fps
This frame rate is used for film that is being transferred to NTSC video and must be
slowed down for a 2-3 pull-down telecine transfer. It is also used for the type of HD
video referred to as 24 p.
24 fps
This is the true speed of standard film cameras.
24.98 fps
This frame rate is commonly used to facilitate transfers between PAL and NTSC video
and film sources. It is mostly used to compensate for some error.
25 fps
This is the frame rate of PAL video.
29.97 fps/29.97 dfps
This is the frame rate of NTSC video. The count can be either non-drop or dropframe.
30 fps/30 dfps
This frame rate is not a video standard anymore but has been commonly used in
music recording. Many years ago, it was the black and white NTSC broadcast
standard. It is equal to NTSC video being pulled up to film speed after a 2-3 telecine
transfer. The count can be either non-drop or drop-frame.
50 fps
This rate is also referred to as 50 p.
59.94 fps
This video frame rate is supported by high definition cameras and is compatible with
NTSC.
60 fps
This video frame rate is supported by many high definition cameras. However, the
NTSC compatible 59.94 fps frame rate is much more common.
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IMPORTANT
Video formats with a variable frame rate (VFR) are not supported.

Frame count vs. frame rate
Part of the confusion in timecode stems from the use of frames per second in both the timecode
standard and the actual frame rate. When used to describe a timecode standard, frames per
second defines how many frames of timecode are counted before one second on the counter
increments. When describing frame rates, frames per second define how many frames are
played back during the span of one second of realtime. In other words: Regardless of how many
frames of video there are per second of timecode (frame count), those frames can be moving at
different rates depending on the speed (frame rate) of the video format. For example, NTSC
timecode (SMPTE) has a frame count of 30 fps. However, NTSC video runs at a rate of 29.97 fps.
So the NTSC timecode standard known as SMPTE is a 30 fps standard that runs at 29.97 fps
realtime.
NOTE
When transferring material between various video formats and film, it becomes necessary to
change the speed (frame rate) of one timecode standard so that video or film frames can line up
in some mathematical relationship to the destination format. That is where all the various pullups and pull-downs come from. Certain frame rates were created as a result of applying a pulldown. For example, 23.976 fps is actually 24 fps pulled down by 0.1 %.

RELATED LINKS
Film Transfers on page 1094
Compensating for Speed Changes on page 1097

Clock sources (speed references)
Once the position is established, the next essential factor for synchronization is the playback
speed. Once 2 devices start playing from the same position, they must run at exactly the same
speed in order to remain in sync. Therefore, a single speed reference must be used and all
devices in the system must follow that reference. With digital audio, the speed is determined by
the audio clock rate. With video, the speed is determined by the video sync signal.

Audio clock
Audio clock signals run at the speed of the sample rate used by a digital audio device and are
transmitted in several ways:
Word clock
Word clock is a dedicated signal running at the current sample rate that is fed over
BNC coaxial cables between devices. It is the most reliable form of audio clock and is
relatively easy to connect and use.
AES/SPDIF Digital Audio
An audio clock source is embedded within AES and SPDIF digital audio signals. This
clock source can be used as a speed reference. Preferably, the signal itself does not
contain any actual audio (digital black), but any digital audio source can be used if
necessary.
ADAT Lightpipe
ADAT Lightpipe, the 8-channel digital audio protocol developed by Alesis, also
contains audio clock and can be used as a speed reference. It is transmitted via
optical cables between devices.
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NOTE
Do not confuse the audio clock embedded in the Lightpipe protocol with ADAT Sync, which has
timecode and machine control running over a proprietary DIN plug connection.

Video sync
Video sync signals are transmitted over BNC coaxial connections between devices and run at the
frame rate of the video device.
There are 2 types of video sync signals:
●

bi-level (also known as black burst)

●

tri-level (used for HD video)

Complications arise when a video device is used as a speed reference. The video sync signal must
be converted into an audio clock signal in order for audio devices to synchronize at the correct
speed. This can be accomplished as follows:
●

Using a dedicated synchronizer such as the Steinberg SyncStation.
A dedicated synchronizer can take a video sync signal (among others) and generate either
word clock or AES/SPDIF signals that may be used as an audio clock source.

●

Using a house sync generator.
A master sync generator such as the Rosendahl Nanosync HD can simultaneously
generate video sync and audio clock from the same source. This ensures that both video
and audio devices fed by the sync generator will run at the same speed.

NOTE
Some audio cards and interfaces can accept a video sync signal as an audio clock source,
performing a similar function to a dedicated synchronizer.
IMPORTANT
Care must be taken to ensure that the incoming video sync frame rate matches that of the
Nuendo project.

MIDI clock
MIDI clock is a signal that uses position and timing data based on musical bars and beats to
determine location and speed (tempo). It can perform the same function as a positional
reference and a speed reference for other MIDI devices. Nuendo supports sending MIDI clock to
external devices but cannot slave to incoming MIDI clock.
IMPORTANT
MIDI clock cannot be used to synchronize digital audio. It is only used for MIDI devices to play in
musical sync with one another. Nuendo does not support being a MIDI clock slave.

Frame edge alignment (phase)
There are 1600 samples of audio in one frame of video running at 48 kHz and 29.97 fps. Phase
alignment adjusts the playback of Nuendo so that the precise sample of audio is lined up with
the leading edge of the timecode frame.
While it is possible to have very good sync without proper phase alignment, it will not be sampleaccurate. With Nuendo there are 4 ways of achieving sample-accurate (phase aligned) sync:
●

Using Steinberg’s SyncStation synchronizer.
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The SyncStation can resolve video sync, word clock, and timecode all in one unit with
extensive machine control capabilities.
●

Using Steinberg’s Time Base synchronizer.
The Time Base has the ability to align the audio clock with the incoming timecode.

●

Using VST System Link.
VST System Link connects multiple workstations together using digital audio connections.
System Link uses the sample clock for position and speed references, ensuring sampleaccurate synchronization.

●

ASIO Positioning Protocol (APP)
Specific ASIO audio cards that have built in timecode readers support Steinberg’s APP. APP
is able to analyze the incoming timecode and compare that to the sample clock to provide
sample-accurate synchronization.

IMPORTANT
APP is only supported when Nuendo is a timecode slave.

The Project Synchronization Setup dialog
Nuendo’s Project Synchronization Setup dialog provides a central place to configure a complex
synchronized system. In addition to settings for timecode sources and machine control settings,
project setup parameters are available along with basic transport controls for testing the system.
●

To open the Project Synchronization Setup dialog, select Transport > Project
Synchronization Setup.

The dialog is organized into sections separating related groups of settings. The arrows shown
between the various sections of the dialog indicate how settings in one section influence settings
in another section. In the following, the available sections are described in detail.

The Nuendo Section
At the center of the Project Synchronization Setup dialog is the Nuendo section. It is provided to
help you visualize the role that Nuendo takes in your setup. It shows which external signals enter
or leave the application.
The only controls available in the Nuendo section are the transport controls and the Sync button
at the bottom. These controls are duplicates of the ones found on the Transport panel and are
made available in order to test various synchronization settings.

The two Project Setup sections
The Project Setup sections at the bottom left of the Project Synchronization Setup dialog are
related to the active project in Nuendo. Therefore they are only visible if you have opened a
project in Nuendo. Here you can change timecode parameters and project options that affect
synchronization.
Unlike the other settings in the Project Synchronization Setup dialog, which are applied globally,
the Project Setup options are saved with the active project.

Applying changes to the project setup
When you change any of the parameters in the Project Setup sections, the title bar of the top
section changes to “Apply”. Click anywhere on that title bar to apply your changes. If you close
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the Project Synchronization Setup dialog without applying your Project Setup changes, these will
be lost.
Changing the Project Setup settings in the Project Synchronization Setup dialog instead of the
Project Setup dialog allows you to test your changes without having to exit the dialog.

RELATED LINKS
Project Setup Dialog on page 89

Project Setup - Time
The “Project Setup - Time” section has 6 settings that relate to timecode and playback speed in
Nuendo.

Project Start Time
This setting determines the timecode value at the start of the project. For example,
many video timelines start at 01:00:00:00 to allow for pre-roll and test tones prior to
the one hour mark. In that case, a start time of 00:55:00:00 might be appropriate.
Project Length
This setting determines how much timeline Nuendo allocates to the project. Note
that the more time is allocated, the more resources are used. Therefore it is advised
to set the length to a reasonable amount for the current project.
Project Frame Rate
This setting determines both the timecode standard and frame rate for the project.
Make sure that this setting matches the frame rate of any incoming timecode.
Sample Rate
This setting determines the sample clock speed of Nuendo’s audio engine. Ensure
that this setting matches the sample rate of incoming word clock signals or other
audio clock sources.
Pull-Up/Pull-Down
This setting affects the speed of the audio transport in Nuendo. If Nuendo’s playback
is slowed down or sped up via an external sample clock source, you need to adjust
the time displays accordingly by selecting the correct pull factor.
Video Pull
This setting affects the video playback speed in Nuendo. The video playback rate may
also be pulled up or down, depending on the need.
RELATED LINKS
Adjusting Audio Playback Speed on page 1097
Video Pull-Up and Pull-Down on page 1100
Project Setup Dialog on page 89
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Project Setup - Display
Regardless of the technical needs of a project’s timeline, the user might want to see time
information displayed in a different format. The settings in the “Project Setup - Display” section
allow you to change how Nuendo’s timeline is displayed, but not the underlying timeline itself.

Display Format
This setting determines how Nuendo displays time in the Project window and the
primary display of the Transport panel.
Display Time Offset
The value set in this field will be added or subtracted from the current timeline
position. This setting is used for display only.
Bar Offset
This setting allows you to specify timeline display offsets in musical terms instead of
timecode. The Bar Offset value is independent of the “Display Time Offset” value.

Timecode Source
The Timecode Source setting determines whether Nuendo is acting as timecode master or slave.

When set to “Internal Timecode”, Nuendo is the timecode master, generating all position
references for any other device in the system. The other options are for external timecode
sources. Selecting any of these, makes Nuendo a timecode slave if “Use External Synchronization”
is activated on the Transport menu.
Internal Timecode
Nuendo generates timecode based on the project timeline and project setup
settings. The timecode will follow the format specified in the Project Setup section.
MIDI Timecode
Nuendo acts as a timecode slave to any incoming MIDI timecode (MTC) on the ports
selected in the MIDI Timecode Settings section, now visible to the left of the
Timecode Source section.

Selecting “All MIDI Inputs” allows Nuendo to sync to MTC from any MIDI connection.
You can also select a single MIDI port for receiving MTC.
9 Pin Sync 1 & 2
Timecode polling over Sony’s 9-Pin RS422 protocol can be used as a timecode source.
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IMPORTANT
Using 9-Pin timecode is not recommended without using Steinberg’s SyncStation
hardware. In other scenarios it should only be used if no other timecode source is
available.
When you select one of the 9-Pin options, further settings become available in the “9Pin Device Settings” section to the left of the Timecode Source section:
Option

Description

Serial Port

Use this pop-up menu to select the serial
port corresponding to the source of the
9-pin timecode.

Control Playback Speed

If this option is activated, Nuendo will
attempt to control the playback speed of
the 9-pin device.

Displays follow locating device

If this option is activated, the Project
cursor will follow the incoming
timecode’s position. This is very helpful
with tape-based devices as they locate
much slower than non-linear systems.
The cursor gives you a visual indication
of the position of the tape machine at all
times.

ASIO Audio Device
This option is only available with audio cards that support ASIO Positioning Protocol.
These audio cards have an integrated LTC reader or ADAT sync port and can perform
a phase alignment of timecode and audio clock.
VST System Link
VST System Link can provide all aspects of sample-accurate synchronization between
other System Link workstations.
Steinberg Time Base
The Time Base is a hardware synchronizer that can provide sample-accurate sync for
Nuendo. Please refer to the documentation that comes with the unit for setup
instructions.
Steinberg SyncStation
The SyncStation is a full-featured hardware synchronizer with extensive machine
control capabilities that provides sample-accurate sync with a variety of external
devices. Please refer to the documentation that comes with the unit for setup
instructions.
RELATED LINKS
Working with VST System Link on page 1065
Machine Control Output Settings - 9-Pin Control 1 and 2 on page 1055

Timecode Preferences
When MIDI Timecode, Steinberg Time Base, or Steinberg SyncStation is selected, the Timecode
Preferences section becomes available, providing several options for working with external
timecode.
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Lock Frames
This setting determines how many full frames of timecode it takes for Nuendo to try
and establish sync or “lock”. If you have an external tape transport with a very short
start-up time, try lowering this number to make lock-up even faster. This option can
only be set to multiples of 2.
Drop Out Frames
This setting determines the amount of missed timecode frames it takes for Nuendo
to stop. Using LTC recorded on an analog tape machine can result in some amount
of drop outs. Increasing this number allows Nuendo to “free-wheel” over missed
frames without stopping. Lowering this number causes Nuendo to stop sooner once
the tape machine has stopped.
Inhibit Restart ms
Some synchronizers still transmit MTC for a short period after an external tape
machine has been stopped. These extra frames of timecode sometimes cause
Nuendo to restart suddenly. The “Inhibit Restart ms” setting allows you to control the
amount of time in milliseconds that Nuendo will wait to restart (ignoring incoming
MTC) once it has stopped.
Jam-Sync
When the Jam-Sync option is activated, Nuendo will ignore any changes in timecode
once it has started playback. This can be useful in special situations, such as
synchronizing to broken timecode.
IMPORTANT
When Jam-Sync is enabled, the “Drop Out Frames” value is ignored so that Nuendo
does not stop if timecode is interrupted.
Auto-Detect Frame-Rate Changes
Nuendo can notify the user when the frame rate of timecode changes at any point.
This is helpful in diagnosing problems with timecode and external devices. This
notification will interrupt playback or recording. Deactivating this option will avoid
any interruption in playback or recording.
IMPORTANT
If there is a discrepancy between the project frame rate in Nuendo and incoming
timecode, Nuendo might still be able to lock to the incoming timecode. If the user is
unaware of these differences, problems can arise later in postproduction.

Machine Control Output Destination
If Use External Synchronization in the Transport menu is activated, all transport commands
(including movements of the cursor in the Project window) are translated into machine control
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commands and routed according to the settings that are made in the Machine Control Output
Destination section.

No Machine Control
If this option is selected, transport commands are not routed or sent to any device.
This does not affect the operation of the individual 9-Pin and MMC Device panels.
They can still function regardless of the machine control destination. The machine
control output destination only defines the routing of transport commands from
Nuendo while sync is enabled.
MIDI Machine Control
If this option is selected and sync is enabled, all transport commands from the
Nuendo transport are routed to MMC devices connected to the MIDI ports that you
defined in the “Machine Control Output Settings” section.
9-Pin Control 1 and 2
When one of the 9-Pin Control options is selected and sync is enabled, transport
commands from Nuendo are routed to the 9-Pin Device 1 or 2, as configured in the
“Machine Control Output Settings” section.
Steinberg ‘Time Base’ and Steinberg SyncStation
If this option is selected and sync is enabled, transport commands from Nuendo are
routed to a connected Time Base or Steinberg SyncStation unit (respectively). Please
refer to the documentation that comes with your unit for complete information on its
operation.
RELATED LINKS
Machine Control Output Settings on page 1054

Machine Control Output Settings
Each machine control destination has settings associated with it. These settings configure how
the remote device will respond to transport commands from Nuendo.

Machine Control Output Settings - MIDI Machine Control
There are 4 settings associated with MIDI Machine Control Operation:

MMC Input and Output
The MMC Input and MMC Output settings determine which MIDI port in your system
will send and receive MMC commands. Set both the input and output to MIDI ports
that are connected to the desired MIDI device.

1054

Synchronization
The Project Synchronization Setup dialog
MMC Device ID
The MMC device ID should be set to the same number as the receiving device. You
can also set the device ID to “All” if more than one machine is receiving MMC
commands or if the device ID is not known.
NOTE
Some devices can only listen to their specific IDs. Therefore, using the All option will
not work with such devices.
Number of Audio Tracks
The number of audio tracks should be set to match the amount of available audio
tracks in the destination device. This setting determines how many record-enable
buttons are shown in the MMC Master panel.
MMC Master panel

The MMC Master panel can be opened from the Studio menu. In order to use the
MMC Master panel, proceed as follows:
●

In the Preferences dialog, select MIDI > MIDI Filter, and make sure SysEx is
activated in the Thru section.
This is necessary since MMC uses 2-way communication (the tape recorder
“replies” to the MMC messages it receives from Nuendo). By filtering out SysEx
Thru, you ensure that these MMC System Exclusive replies are not echoed
back to the tape recorder.

●

On the MMC Master panel, activate the Online button to use the transport
buttons on the panel to control the transport of the device.
It is not necessary to have this activated in order to synchronize with the MMC
device. It only affects operation of the MMC Master panel.

●

You can use the buttons to the left on the MMC Master panel to arm tape
tracks for recording.

●

The “A1, A2, TC, VD” items refer to additional tracks usually found on video
tape recorders.
Refer to the manual of your VTR device to see if these tracks are supported.

Machine Control Output Settings - 9-Pin Control 1 and 2

Serial Port
The 2 9-Pin devices connect to your computer from available serial ports. Use the
Serial Port pop-up menu to select the appropriate serial port.
IMPORTANT
PCs and Apple computers use different types of serial ports. PCs typically provide a
RS232 interface on a 9-Pin Dsub connection that must be converted to RS422 in

1055

Synchronization
The Project Synchronization Setup dialog
order to interface with Sony 9-Pin devices. Apple computers require a USB to RS422
serial converter such as the Keyspan USA-19W.
Audio Track Count
Use this option to specify how many audio tracks are available. The 9-Pin Device
panel will then contain the same amount of record-enable buttons.
‘Try to Recognize Device’ vs. ‘Use Generic Device’
The RS422 9-Pin protocol can control a wide variety of devices. Each device may have
differing features. Nuendo has a library of device profiles that can be used with 9-Pin
devices.
You can choose whether Nuendo will try to recognize the device by polling it and
comparing that to its library, or you can use a generic device profile.
Auto Edit PRE/POST
Auto Edit is a feature of 9-Pin devices that allows for automatic punch in and out on
record-enabled tracks. The pre-roll and post-roll times determine where the 9-Pin
device will start and stop playback during an Auto Edit procedure.
RELATED LINKS
9-Pin Auto Edit on page 1059

Master Machine Control Preferences
There are 5 preference settings for Nuendo’s master machine control operation. They affect how
the machine reacts to various commands from Nuendo.

Machine follows mouse edits
If this option is activated, moving the project cursor with the mouse results in
transport commands so that the machine continuously locates to the new cursor
position.
If this causes a great deal of unnecessary tape winding, you can deactivate the
option. In that case transport commands are only sent to the machine when the
mouse button is released.
Machine follows jog
If this option is activated, turning the jog wheel on a remote controller results in
transport commands so that the machine continuously locates to the new project
cursor position.
Again, this might cause a great deal of unnecessary tape winding. If disabled,
transport commands are only sent to the machine when the user stops moving the
wheel.
Send ‘Shuttle’ instead of ‘FF/Rewind’
Many video decks respond differently to Shuttle commands or FF/Rewind
commands. FF/Rewind commands often result in the tape being released from the
heads and the motors entering a high-speed wind mode. This takes a great deal of
time, and the machine cannot read the timecode on the tape while winding.
Therefore position information is lost. Activate this option if shuttle commands are
preferred.
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Send ‘Still’ instead of ‘Stop’
Similar to FF/Rewind commands, Stop commands result in the tape being released
from the heads. Still commands on the other hand, also cause the transport to stop,
but without releasing the tape from the heads. Activate this option if you want the
picture from the video deck to be visible also in Stop mode or if you want the
machine to enter playback mode faster.
Allow machine controlled cycle
If this option is activated, Nuendo starts playback at the left locator minus the preroll time and stops playback at the right locator plus the post-roll time. When
repeating a section, Nuendo locates back to the pre-roll position and waits for the
machine to reach that position before issuing a start command.
If this option is deactivated, the machine will not follow when Nuendo cycles. Upon
reaching the right locator, Nuendo locates back to the left locator, but the machine
continues playback.

Machine Control Input Source
Nuendo can respond to machine control commands from external MIDI and 9-Pin devices.
Nuendo can follow incoming transport commands (locate, play, record) and respond to recordenabling commands for audio tracks. This allows Nuendo to easily integrate into larger studio
systems with centralized machine control and synchronization such as theatrical mixing stages.

MIDI Machine Control
When MIDI Machine Control is selected as the input source, several settings become
available in the Machine Control Input Settings section:
Option

Description

MMC Input

Set this to the MIDI input that is
connected to the master machine
control device.

MMC Output

Set this to the MIDI output that is
connected to the master machine
control device.

MMC Device ID

This determines the MIDI ID number
that is used to identify the machine in
Nuendo.

IMPORTANT
The MMC protocol involves polling devices (requesting information) for their status
which requires 2-way communication. While some functions may work with only one
way communication, it is best to connect both MIDI ports (input and output) of MMC
devices.
Steinberg ‘Time Base’
When the Time Base unit is connected to Nuendo, there are various settings for
machine control input. Please refer to the documentation that comes with the Time
Base for complete information on its use.
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Steinberg SyncStation
When the SyncStation is selected as the machine control input source, there are
several options for how these commands are routed within the SyncStation itself.
Please refer to the documentation that comes with the SyncStation for complete
information on its use.
RELATED LINKS
MMC Master panel on page 1055

MIDI Timecode Destinations
Nuendo can send MTC to any MIDI port. Use this section to specify the MIDI ports to which MTC
is routed. Devices that can lock to MTC will chase Nuendo’s timecode position.
NOTE
Some MIDI interfaces send MTC over all ports by default. If this is the case, only select one port
of the interface for MTC.

MIDI Timecode Follows Project Time
Activate this option to ensure that the MTC output follows Nuendo’s time position at
all times including looping, locating, or jumping while playing. If not, MTC will
continue on without changing locations at a loop or jump point until playback stops.
Timecode Offset
This option allows you to specify an offset to be applied to outgoing MTC. The
amount of offset will be added or subtracted from the project’s current position
before being transmitted.

MIDI Clock Destinations
Some MIDI devices like drum machines can match their tempo and location to incoming MIDI
clock. Select any MIDI ports that you want to output MIDI clock.

MIDI Clock Follows Project Position
Activate this option to ensure that the MIDI clock device follows Nuendo when
looping, locating, or jumping while playing.
NOTE
Some older MIDI devices might not respond well to these positioning messages and
could take some time synchronizing to the new location.
Always Send Start Message
MIDI clock transport commands include Start, Stop, and Continue. However, some
MIDI devices do not recognize the Continue command. By activating the “Always
Send Start Message” option, you can avoid this problem with specific MIDI devices.
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Send MIDI Clock in Stop Mode
Activate this option if you are working with a device that needs MIDI clock to run
continuously in order to operate arpeggiators and loop generators.

Synchronized operation
Once you have connected all the devices that will be synchronized, it is important to understand
how Nuendo operates in Sync mode.
●

To enable Sync mode, activate Use External Synchronization on the Transport menu.

Sync mode
If you activate “Use External Synchronization” on the Transport menu, the following happens:
●

Transport commands are routed to the machine control destination output as specified in
the Project Synchronization Setup dialog.
Locate, Play, Stop, and Record commands will now be sent to an external device.

●

Nuendo awaits incoming timecode from the chosen timecode source defined in the
Project Synchronization Setup dialog in order to play.
Nuendo will detect incoming timecode, locate to its current position, and start playback in
sync with the incoming timecode.

In a typical scenario, an external tape machine, such as a VTR, has its timecode output connected
to Nuendo. Nuendo is sending machine control commands to the deck. When Sync is activated
and you click Play on the Transport panel, a play command is sent to the VTR. The VTR in turn
starts playback, sending timecode back to Nuendo. Nuendo then synchronizes to that incoming
timecode.
If the “Machine follows mouse edits” option is activated and you change the project cursor
position with the mouse or key command, machine control commands are sent to the remote
deck so it will locate to the new position.
In this way, synchronized operation is somewhat invisible to the user. Just go about editing and
mixing while the synchronized devices chase all movements of the cursor automatically.
IMPORTANT
With tape-based devices, synchronized operation will be slower due to the winding time
necessary for the tape machine to locate to a new position.
Nuendo’s Edit Mode will take advantage of this feature by locating the VTR to the start of the first
selected event.
RELATED LINKS
Use Video Follows Edit Mode on page 1086

9-Pin Auto Edit
Most 9-Pin devices such as VTRs have the capability of performing very accurate punch-ins and
punch-outs on audio tracks. These punches are tied to video frames and are programmed using
timecode. This type of recording is called an “Auto Edit”.
Nuendo can use its auto-punch feature to program Auto Edit functions of a VTR via 9-Pin control.
The left and right locators in the Project window define the punch in and punch out of the Auto
Edit. Provided that Nuendo is in Sync mode, pressing the Auto Edit button on the 9-Pin Device
panel causes the punch-in to happen automatically.
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NOTE
Auto Edits can only happen on a timecode frame. Punching in or out in between video frames is
not possible.
IMPORTANT
In order to use the 9-Pin Device panel to control an external deck, the Online button must be
activated and tracks must be armed.

Auto Edit Pre-Roll and Post-Roll
Since VTRs require some amount of pre-roll time in order to get tape up to speed for proper
recording, each 9-Pin device has options for setting a pre-roll and post-roll amount in seconds.
The default values of 5 seconds pre-roll and 2 seconds post-roll should work in most cases. You
can change these values in the “Machine Control Output Settings” section.
RELATED LINKS
Machine Control Output Settings - 9-Pin Control 1 and 2 on page 1055

Example Scenarios
To better understand how synchronization options can be utilized, 3 example scenarios are
provided.

Personal music studio
In a personal music studio, the user might have the need of synchronizing with an external
recording device such as a portable hard disk recorder used for live remote recordings.
In this example, MIDI will be used for timecode and machine control while the audio clock will be
handled by Lightpipe digital audio connections.
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●

If “Use External Synchronization” is activated on the Transport menu, Nuendo sends MMC
commands to the hard disk recorder.
Nuendo can remotely start playback of the recorder.

●

The hard disk recorder is using audio clock from Nuendo’s audio interface as the speed
reference.
It is also possible for Nuendo to use the audio clock from the recorder. The audio clock is
carried over the Lightpipe digital audio connection that also carries audio signals.

●

The hard disk recorder sends back MTC to Nuendo.
When the recorder begins playing, MTC is sent back to Nuendo which will sync to that
timecode.

Sync settings for personal music studio
To synchronize the devices in this example scenario, proceed as follows:
PROCEDURE
1.

Make the connections as shown in the diagram above.
In this simple example, any device that uses MTC can be substituted.

2.

Open the Project Synchronization Setup dialog and select “MIDI Timecode” as the
timecode source.
When recording from the hard disk recorder into Nuendo, Nuendo will be the machine
control master and the timecode slave, locking to incoming MTC.

3.

In the “Machine Control Output Destination” section, select the “MIDI Machine Control”
option.
Nuendo will now send MMC commands to the hard disk recorder to locate and start
playback.

4.

In the “Machine Control Output Settings” section, assign the MIDI input and output ports
that are connected to the hard disk recorder.
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Since MMC uses 2-way communication, both MIDI ports should be connected. Be sure the
MIDI filter does not echo SysEx data.
5.

On the Transport menu, activate “Use External Synchronization”.
This routes transport commands to the hard disk recorder via MIDI and sets Nuendo as
the timecode slave.

6.

On the hard disk recorder, enable MMC and MTC.
Follow the instructions on how to set up the unit to receive MMC commands and transmit
MTC.

7.

In Nuendo, click the Play button.
The hard disk recorder should start playback and send MTC to Nuendo. Once Nuendo
syncs to MTC, the status on the Transport panel should read “Lock” and show the current
frame rate of incoming MTC.

Postproduction suite
In audio for video postproduction, synchronization needs are an everyday concern. Very often
users need to synchronize with a 9-Pin VTR in order to work with video material. At the same time
the audio clock has to be synchronized with the video clock source to ensure that both audio and
video run at the same speed.
Finished audio can then be recorded back onto the digital audio tracks of a VTR in perfect sync
with the video (known as a “layback”). In this example, 9-Pin machine control is used. The audio
clock is a word clock signal generated by the house sync generator that also generates the video
sync signal. Timecode is handled by a SMPTE to MTC reader, such as the audio interface.

●

The house sync generator creates both the video sync and audio word clock so that the
VTR and Nuendo play at the same speed.
When laying back digital audio to the VTR, the AES signal will already be in sync with the
VTR’s digital audio inputs.
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●

9-Pin machine control is used to manipulate the VTR’s transport.
The VTR can shuttle, locate, play, and record from commands issued by Nuendo. Also,
Nuendo can arm audio tracks on the VTR for layback.

●

When the VTR enters play, LTC is fed back to Nuendo which locks to that incoming
timecode.
If the LTC reader is part of an audio card that is APP compatible, sample-accurate
synchronization is possible in this scenario.

Sync settings for audio layback in a postproduction suite
These steps outline the process of “laying back” finished audio to the VTR. To configure Nuendo
for this example setup, proceed as follows:
PROCEDURE
1.

Make the connections as shown in the diagram above.
Ensure that video sync and word clock are tied to the same generating source!

2.

Open the Project Synchronization Setup dialog and select either “ASIO Audio Device” or
“MIDI Timecode” as the timecode source.
Depending on your system’s configuration, the sound card might have an LTC reader built
into it or you may have to use a LTC to MTC converter interface to get timecode into
Nuendo.

3.

In the “Machine Control Output Destination” section, select 9-Pin Control 1 or 2.
Nuendo’s transport buttons will send commands to the VTR over the 9-Pin RS422
connection.

4.

From the Studio menu, select the 9-Pin Device 1 or 2 option.
Using the Auto Edit feature, you will be able to perform laybacks to the VTR via digital
audio connections. VTRs with digital audio tracks use 48kHz as a standard sampling rate.
Some decks only have 20 bit depth capacity so make sure to dither properly for the
intended delivery format.

5.

Click the Online button.
Now you can use the device panel to control the VTR.

6.

Test the transport with the 9-Pin Device panel.
Ensure that all connections are working properly by testing the various transport buttons
on the 9-Pin Device panel.

7.

Record-enable the audio tracks that you want to record to.
Most professional VTRs have 4 audio tracks. Many high-definition VTRs have 8 for
recording 6-channel surround sound plus a stereo downmix all on the same tape.

8.

Play back the project and look at the meters on the VTR to ensure that proper recording
levels are set.
That way you can also make sure that the digital audio connections are working properly.

9.

Set the left and right locators to the punch in and punch out points.
Auto Edit uses the left and right locators to program the record in and out points of the
VTR.

10.

Ensure that the pre-roll and post-roll times are appropriate for the VTR.
In most cases, the default values will be sufficient for the VTR to get up to speed before
punching in.

11.

On Nuendo’s Transport panel, activate the Sync button.
This turns Nuendo into a timecode slave. Once the VTR starts to play, Nuendo will sync to
incoming timecode.

12.

On the 9-Pin Device panel, click the Auto Edit button.
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This starts the Auto Edit process. The tape transport locates to the set pre-roll position (by
default, 5 seconds before the left locator) and starts playback. When the left locator is
reached, the VTR enters record mode.
13.

The Auto Edit is complete when the right locator is reached and the VTR goes out of
record.
After reaching the right locator, the VTR continues playing for the set post-roll time (by
default 2 seconds) before it stops.

Theatrical mixing stage
A theatrical mixing stage (also known as a dub stage) is a large theater-sized room used to create
the final mixdown for feature films that will be presented in theaters with surround sound. These
types of studios are very complex, dealing with hundreds of audio tracks at once through large
mixing consoles along with high-quality video and film playback systems.
In this example, Nuendo is only one part of a very large system of devices that need to be
perfectly synchronized with one another. An external master 9-Pin controller will operate the
transport of the entire system remotely from the console and timecode will be handled via 9-Pin
interface through the SyncStation. The audio clock will be referenced to tri-level HD video sync
fed to the SyncStation which will output dedicated word clock to both Nuendo and the digital
console.

●

Audio clock is generated out of the video reference signal.
In this example, video sync is being fed to the SyncStation as both a speed reference and a
phase reference. Word clock goes from the SyncStation to Nuendo and the digital console.

●

The console is the machine control master, sending 9-Pin control commands and status
messages to the SyncStation.
The console controls the playback in Nuendo via the SyncStation. Nuendo is the timecode
slave. The SyncStation is acting as a machine control slave.
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●

Timecode is fed to the SyncStation via 9-Pin and then via a USB connection to Nuendo (as
MTC).
The SyncStation’s 9-Pin interface is capable of using 9-Pin timecode effectively for accurate
synchronization. Direct serial port 9-Pin connections should not be used this way.

Sync settings for a theatrical mixing stage
To configure Nuendo for this example setup, proceed as follows:
PROCEDURE
1.

Make the connections as shown in the diagram above.
In this example, the SyncStation handles many of the synchronization tasks. Please refer to
the documentation that comes with the SyncStation for complete information on its
operation.

2.

Open the Project Synchronization Setup dialog and select the SyncStation as the timecode
source.
The SyncStation sends MTC over the USB connection to Nuendo. The SyncStation will use
its “Virtual Master” mode to generate timecode.

3.

In the “Machine Control Input Source” section, select the SyncStation option.
Provided that the SyncStation is set to route record and track arming commands to
Nuendo, this will allow the digital console to record-enable audio tracks in Nuendo and
enter record mode via 9-Pin commands sent to the SyncStation.

4.

On the Transport panel, activate the Sync button.
Nuendo will await incoming timecode from the SyncStation.

5.

Test the record-enable buttons on the console.
If configured properly, the corresponding audio tracks in Nuendo become record-enabled.

6.

Press play on the console’s transport control.
This will send the play commands to the SyncStation over 9-Pin and the SyncStation will
start generating timecode to synchronize Nuendo.

Working with VST System Link
VST System Link is a network system for digital audio that allows you to have several computers
working together in one large system. Unlike conventional networks it does not require Ethernet
cards, hubs, or CAT-5 cables; instead it uses the kind of digital audio hardware and cables you
probably already possess in your studio.
VST System Link has been designed to be simple to set up and operate, yet give enormous
flexibility and performance gains in use. It is capable of linking computers in a “ring” network (the
System Link signal is passed from one machine to the next, and eventually returns to the first
machine). VST System Link can send its networking signal over any type of digital audio cable,
including S/PDIF, ADAT, TDIF, or AES, as long as each computer in the system is equipped with a
suitable ASIO compatible audio interface.
Linking up 2 or more computers gives you vast possibilities:
●

Dedicate one computer to running VST instruments while recording audio tracks on
another.

●

If you need lots of audio tracks, you may simply add tracks on another computer.

●

You could have one computer serve as a “virtual effect rack”, running CPU-intensive send
effect plug-ins only.
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●

Since you can use VST System Link to connect different VST System Link applications on
different platforms, you can take advantage of effect plug-ins and VST instruments that
are specific to certain programs or platforms.

Requirements
The following equipment is required for VST System Link operation:
●

2 or more computers.
These can be of the same type or use different operating systems – it does not matter. For
example, you can link an Intel-based PC to an Apple Macintosh without problems.

●

Each computer must have audio hardware with specific ASIO drivers.

●

The audio hardware must have digital inputs and outputs.
To be able to connect the computers, the digital connections must be compatible, that is,
the same digital formats and connection types must be available.

●

At least one digital audio cable must be available for each computer in the network.

●

A VST System Link host application must be installed on each computer.
Any VST System Link application can connect to another.

Additionally, use of a KVM switchbox is recommended.

Using a KVM switchbox
Whether you want to set up a multi-computer network or a small network in a limited space, it is
a good idea to invest in a KVM (Keyboard, Video, Mouse) switchbox. With one of these you can
use the same keyboard, monitor, and mouse to control each computer in the system, and you
can switch between computers very rapidly. If you decide not to go this route, the network will
function just the same, but you may end up doing a lot of jumping from one machine to the
other while setting up!

Making connections
Below, we assume that you are connecting 2 computers. Should you have more than 2
computers, it is still best to start with 2 and add the others one by one once the system is
working – this makes troubleshooting easier if you run into problems. For 2 computers, you will
need 2 digital audio cables, one in each direction:
PROCEDURE
1.

Use the first digital audio cable to connect the digital output of computer 1 to the digital
input of computer 2.

2.

Use the other cable to connect the digital output of computer 2 to the digital input of
computer 1.
If a card has more than one set of inputs and outputs, choose whichever one that suits you
– for simplicity usually the first set is best.
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Synchronization
Before you proceed, you need to make sure that the clock signals on your ASIO cards are
synchronized correctly. This is essential when cabling any kind of digital audio system, not just
VST System Link.
IMPORTANT
All digital audio cables by definition always carry a clock signal as well as audio signals, so you do
not have to use a special word clock input and output for this (although you may find that you
get a slightly more stable audio system if you do, especially when using multiple computers).
The clock mode or sync mode is set up in the ASIO control panel of the audio hardware.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select VST Audio System.

3.

In the ASIO Driver pop-up menu, select your audio hardware driver.

4.

In the Devices list, select the your audio interface.

5.

Click the Control Panel button.

6.

Open the ASIO control panel on the other computer as well.
If you are using another VST System Link host application on that computer, check its
documentation for details on how to open the ASIO control panel.

7.

Now you need to make sure that one audio card is set to be the clock master and all other
cards are set to be clock slaves, that is, they listen for the clock signal coming from the
clock master.
The naming and procedure for this differs depending on the audio hardware – consult its
documentation if required. If you are using Steinberg Nuendo ASIO hardware, all cards
default to the AutoSync setting. In this case you must set one of the cards (and only one)
to Master in the Clock Mode section of the control panel.

RESULT
Typically, the ASIO control panel for an audio card contains some indication of whether or not the
card receives a proper sync signal, including the sample rate of that signal.
This is a good indication that you have connected the cards and set up clock sync properly. Check
your audio hardware’s documentation for details.
IMPORTANT
It is very important that only one card is the clock master, otherwise the network cannot function
correctly. Once you have set this up, all the other cards in the network will take their clock signal
from this card automatically.
The only exception to this procedure is if you are using an external clock – from a digital mixing
desk or a special word clock synchronizer, for example. In that case you must leave all your ASIO
cards in clock slave or AutoSync mode and make sure that each of them is listening for the
signal coming from the synchronizer. This signal is usually passed through your ADAT cables or
word clock connectors in a daisy chain fashion.

VST System Link and latency
The general definition of latency is the amount of time it takes any system to respond to
whatever messages are sent to it. For example, if your system’s latency is high and you play VST
instruments in realtime, you will get a noticeable delay between when you press a key and when
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you hear the sound of the VST instrument. Nowadays, most ASIO-compatible audio cards are
capable of operating with very low latencies. Also, all VST applications are designed to
compensate for latency during playback, making the playback timing tight.
However, the latency time of a VST System Link network is the total latency of all the ASIO cards
in the system added together. Therefore it is extra important to minimize the latency times for
each computer in the network.
IMPORTANT
The latency does not affect the synchronization – it is always perfectly in time. But it can affect
the time it takes to send and receive MIDI and audio signals, or make the system seem sluggish.
To adjust the latency of a system, you adjust the size of the buffers in the ASIO control panel –
the lower the buffer size, the lower the latency. It is best to keep to fairly low latencies (buffer
sizes) if your system can handle it – about 12 ms or less is usually a good idea.

Setting up your software
Now it is time to set up your programs. The procedures below describe how to set things up in
Nuendo. If you are using another program on the other computer, please refer to its
documentation.

Setting the sample rate
The projects in both programs must be set to use the same sample rate. Select “Project Setup…”
from the Project menu and make sure that the sample rate is the same in both systems.

Streaming digital audio between applications
PROCEDURE
1.

Create input and output busses in both applications and route these to the digital inputs
and outputs.
The number and configuration of the busses depend on your audio hardware and on your
needs. If you have a system with 8 digital i/o channels (such as an ADAT connection), you
could create several stereo or mono busses, a surround bus together with a stereo bus, or
any combination you need. The important thing is that you should have the same
configuration in both applications – if you have 4 stereo output busses on computer 1, you
want 4 stereo input busses on computer 2, etc.

2.

Set things up so that computer 1 plays back some audio.
For example, you could import an audio file and play it back in Cycle mode.

3.

In the Inspector or MixConsole, make sure that the channel containing the audio material
is routed to one of the digital output busses.

4.

On computer 2, open the MixConsole and locate the corresponding digital input bus.
The audio being played back should now “appear” in the program running on computer 2.
You should see the input bus level meters moving.

5.

Reverse this procedure so that computer 2 plays back and computer 1 “listens”.

RESULT
Now you have verified that the digital connection works as it should.
NOTE
From this point on in this chapter, we refer to the busses connected to the digital inputs and
outputs as “VST System Link busses”.
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Settings for the audio hardware
When you exchange VST System Link data between computers, it is important that the digital
information is not changed in any way between the programs. Therefore, you should open the
control panel (or additional application) for your audio hardware and make sure that the
following conditions are met:
●

If there are additional “format settings” for the digital ports that you use for VST System
Link data, make sure that these are turned off.
For example, if you are using an S/PDIF connection for VST System Link, make sure that
“Professional format”, Emphasis, and Dithering are turned off.

●

If your audio hardware has a mixer application allowing you to adjust the levels of digital
inputs and outputs, make sure that this mixer is disabled or that the levels for the VST
System Link channels are set to ±0 dB.

●

Similarly, make sure no other forms of DSP (pan, effects, etc.) are applied to the VST
System Link signal.

Notes for Hammerfall DSP users
If you are using RME Audio Hammerfall DSP audio hardware, the Totalmix function allows for
extremely complex signal routing and mixing in the audio hardware. This can in some situations
lead to “signal loops” in which case the VST System Link will not work. If you want to make
absolutely sure this will not cause any problems, select the default or “plain” preset for the
Totalmix function.

Activating VST System Link
Before you proceed, you need to make sure that VST System Link is set as the timecode source
in the Project Synchronization Setup dialog and that the desired sync options are activated.
After setting up the inputs and outputs, you now need to define which input/output will carry the
actual VST System Link information.
The VST System Link networking signal is carried on only one bit of one channel. This means
that if you have an ADAT-based system which normally carries 8 channels of 24-bit audio, once
you activate VST System Link you will have 7 channels of 24-bit audio and one channel of 23-bit
audio (the least significant bit of this last channel will be used for networking). In practice this
makes no discernible difference to the audio quality, since you will still have around 138 dB
headroom on this channel.
To set things up, open the VST System Link panel:
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select VST System Link.
The VST System Link settings are shown to the right of the Devices list.
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3.

Use the ASIO Input and ASIO Output pop-up menus to define which channel is the
networking channel.

4.

Activate the Active checkbox at the top left of the panel.

5.

Repeat the steps above for every computer in the network.

RESULT
As the computers are made active, you should see the Sending and Receiving indicators flashing
on each active computer, and the name of each computer should appear in the list at the bottom
of the pane. Each computer is assigned a random number – do not worry about this, it is just so
the network knows internally which one is which.
●

You can double-click on the name in bold (which is the name of the computer you are
working on) and set it to whatever other name.
This name will appear in the VST System Link window of every computer on the network.

NOTE
If you do not see the name of each computer appearing once you have made it active, you need
to check your settings. Go through the procedure above again and make sure that all ASIO cards
are listening to the digital clock signals correctly, and that each computer has the correct inputs
and outputs assigned to the VST System Link network.

RELATED LINKS
Timecode Preferences on page 1052

Putting the network online
After each computer’s name you will see whether it is online or not. When a computer is online, it
will receive transport and timecode signals, and its sequencer application can be started and
stopped by remote control. If it is off-line, it can only be started from its own keyboard – it is
effectively an independent machine, although it is still on the network.
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NOTE
Note that any computer can control any and all of the others – VST System Link is a peer-to-peer
network and there is no absolute “master” computer.
To put all computers online, proceed as follows:
PROCEDURE
1.

For all computers, activate the Online checkbox on the VST System Link page.

2.

Start playback on one computer to check that the system is working – all computers
should start almost instantly and play perfectly in time, with sample-accurate precision.
●

The Offset Samples setting allows you to adjust whether one machine will play
slightly ahead or behind the rest.
This is normally not needed, but occasionally with some hardware you may find that
the lock is a few samples out. For now, leave it set to 0 – it will most likely be what
you want.

●

The Transfer Bits setting allows you to specify whether you want to transfer 24 or 16
bits. This allows you to use older audio cards which do not support transfer of 24
bits.

RESULT
VST System Link sends and understands all transport commands (such as play, stop, fast
forward, rewind, etc.). This allows you to control the entire network from one computer. If you
jump to a locator point on one machine, all other machines will also instantly jump to that locator
point.
IMPORTANT
Make sure that all computers have their tempos set to the same value, otherwise your
synchronization will be seriously skewed.

Scrubbing via VST System Link
You can scrub on one computer and have the video and audio on another computer scrub along.
However, the playback on the linked systems may not be perfectly in sync while scrubbing and
there are some further restrictions you should bear in mind when scrubbing via VST System Link:
●

Use a remote controller for scrubbing.

●

Always use the system where you started scrubbing to control the scrubbing.
Changing the scrub speed on a remote system will only change the speed on the local
system.

●

You can start playback on all systems.
This stops scrubbing and enters playback on all systems in sync.

Using MIDI
As well as supplying transport and sync control, VST System Link also supplies up to 16 MIDI
ports, with 16 channels each.
PROCEDURE
1.

Use the MIDI Inputs and MIDI Outputs value fields to specify the number of MIDI ports
you need.
The default value is 0 MIDI In and 0 MIDI Out ports.
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2.

In the Project window, create a MIDI track and open the Inspector (top section).

3.

If you now open the Input or Output Routing pop-up menu, you will find the specified
System Link ports added to the list of MIDI inputs or outputs.

This allows you to route MIDI tracks to VST instruments running on another computer.

RELATED LINKS
Application examples on page 1074

The “Use Selected ASIO Ports for Data only” setting
If you are sending huge amounts of MIDI data at once, there is a small possibility that you might
run out of bandwidth on your VST System Link network. This will manifest itself by notes
“choking” or timing becoming erratic.
If this happens, you can devote more bandwidth to MIDI by activating Use Selected ASIO Ports
for Data only on the VST System Link page of the Studio Setup dialog. When this is activated,
the VST System Link information will be sent on the entire channel instead of just one bit, more
than enough for all the MIDI you could ever hope to use. The downside is that you can no longer
use this ASIO channel for audio transfer (do not connect it to a speaker!), thus leaving you with
only 7 audio channels in our ADAT cable example. Depending on how you work, this might be a
reasonable compromise.

Hearing the network audio
If you are using an external mixing desk, hearing your audio really is not an issue – just plug the
outputs of each computer into the desired channels on the external mixing desk, start playback
on one of the computers, and you are good to go.
However, many people prefer to mix internally inside the computer and just use a desk for
monitoring (or maybe not use any external mixer at all). In this case you will need to select one
computer to be your “main mix computer” and send the audio from your other computers into
this.
In the following example, we assume you are using 2 computers, with computer 1 as your main
mix computer and computer 2 running 2 additional stereo audio tracks, an FX channel track with
a reverb plug-in and a VST instrument plug-in with stereo outputs.
PROCEDURE
1.

Set things up so that you can listen to the audio playback from computer 1.
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In other words, you need an unused set of outputs, such as an analog stereo output,
connected to your monitoring equipment.
2.

On computer 2, route each of the 2 audio tracks to a separate output bus.
These should be busses connected to the digital outputs – let’s call them Bus 1 and 2.

3.

Route the FX channel track to another VST System Link bus (Bus 3).

4.

Route the VST instrument channel to yet another bus (Bus 4).

5.

Go back to computer 1 and check the corresponding 4 VST System Link input busses.
If you start playback on computer 2, the audio should “appear” on the input busses on
computer 1. However, to mix these audio sources you need actual mixer channels.

6.

Add 4 new stereo audio tracks on computer 1 and route these to the output bus you use
for listening, such as the analog stereo outputs.

7.

For each of the audio tracks, select one of the 4 input busses.
Now, each computer 2 bus is routed to a separate audio channel on computer 1.

8.

Activate monitoring for the 4 tracks.

RESULT
If you now start playback, the audio from computer 2 will be sent “live” to the new tracks on
computer 1, allowing you to hear them together with any tracks you play back on computer 1.

Adding more tracks
What if you have more audio tracks than you have VST System Link busses (physical outputs)?
Then you just use the computer 2 mixer as a submixer: Route several audio channels to the same
output bus and adjust the output bus level if needed.
NOTE
If your audio cards have multiple sets of input and output connections, you can link up multiple
ADAT cables and send audio via any of the busses on any of the cables.

Internal mixing and latency
One problem with mixing inside the computer is the latency issue we mentioned earlier. The VST
engine always compensates for record latencies, but if you are monitoring through computer 1
you will hear a processing delay while you listen to signals coming from your other computers
(not on your recording!). If your audio card in computer 1 supports ASIO Direct Monitoring you
should definitely turn this on. You can find the setting on the VST Audio System device panel for
your hardware. Most modern ASIO cards support this function. If yours does not, you may want
to change the Offset Samples value on the VST System Link page to compensate for any latency
issues.
RELATED LINKS
ASIO Direct Monitoring on page 263

Setting up a larger network
Setting up a larger network is not much more difficult than a 2-computer network. The main
thing to remember is that VST System Link is a daisy chain system. In other words, the output of
computer 1 goes to the input of computer 2, the output of computer 2 goes to the input of
computer 3, and so on around the chain. The output of the last computer in the chain must
always go back into the input of computer 1, to complete the ring.
Once you have done this, the transmission of all the transport, sync, and MIDI information to the
whole network is handled pretty much automatically. However, where you may run into
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confusion in a large network is in the transmission of audio signals back to a central mix
computer.
If you have lots of hardware inputs and outputs on your ASIO cards, you do not have to send
audio via the chain at all, but can transmit it directly to the master mix computer via one or more
of its other hardware inputs. For example, if you have a Nuendo Digiset interface or 9652 card on
computer 1, you could use ADAT cable 1 for networking, ADAT cable 2 as a direct audio input
from computer 2, and ADAT cable 3 as a direct audio input from computer 3.
You can also transmit audio via the ring system if you do not have enough hardware I/Os for
direct audio transmission. For example, in a 4-computer scenario you could send audio from
computer 2 into a channel in the mixer in computer 3, from there to a channel in the mixer in
computer 4, and from there back to the master mixer in computer 1. This can certainly be tricky
to set up, so for complex networks it is generally recommended to use ASIO cards with at least 3
separate digital I/Os.

Application examples
Using one computer for VST instruments
In this example, one computer will be used as main record and playback machine, and another
computer as a virtual synth rack.
PROCEDURE
1.

Record a MIDI track into computer 1.

2.

Once you have finished recording, route the MIDI output of that track to VST System Link
MIDI port 1.

3.

On computer 2, open up the VST Instruments window and assign an instrument to the first
slot in the rack.

4.

Route the VST instrument channel to the desired output bus.
If you are using computer 1 as your main mixing computer, this would be one of the VST
System Link output busses, connected to computer 1.

5.

Create a new MIDI track in the Project window of computer 2 and assign the MIDI output
of the track to the VST instrument you created.

6.

Assign the MIDI input of the track to be VST System Link port 1.
Now, the MIDI track on computer 1 is routed to the MIDI track on computer 2, which in
turn is routed to the VST instrument.

7.

Now activate monitoring for the MIDI track on computer 2, so that it will listen and
respond to any MIDI commands coming in.
In Nuendo, click the Monitor button in the track list or Inspector.

8.

Start playback on computer 1.
It will now send the MIDI information on the track to the VST instrument loaded on
computer 2.

RESULT
Even with a slow computer you should be able to stack a whole bunch of extra VST instruments
this way, expanding your sound palette considerably. Do not forget that VST System Link MIDI is
also sample-accurate, and thus has much tighter timing than any hardware MIDI interface ever
invented!
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Creating a virtual effect rack
The effect sends for an audio channel in Nuendo can either be routed to an FX channel track or
to any activated group or output bus. This allows you to use a separate computer as a “virtual
effect rack”.
PROCEDURE
1.

On computer 2 (the machine you will use as effect rack), add a new stereo audio track.
You cannot use an FX channel track in this case, since the track must have an audio input.

2.

Add the desired effect as an insert effect for the track.
Let’s say you add a high-quality reverb plug-in.

3.

In the Inspector, select one of the VST System Link busses as input for the audio track.
You want to use a separate VST System Link bus, which will only be used for this purpose.

4.

Route the channel to the desired output bus.
If you are using computer 1 as your main mixing computer, this would be one of the VST
System Link output busses, connected to computer 1.

5.

Activate monitoring for the track.

6.

Go back to computer 1 and select a track to which you want to add some reverb.

7.

Bring up the effect sends for the track in the Inspector or the MixConsole.

8.

Open the Send Routing pop-up menu for one of the sends and select the VST System Link
bus assigned to the reverb in step 3.

9.

Use the Send slider to adjust the amount of effect as usual.

RESULT
The signal will be sent to the track on computer 2 and processed through its insert effect,
without using any processor power on computer 1.
You can repeat the steps above to add more effects to the “virtual effect rack”. The number of
effects available this way is only limited by the number of ports used in the VST System Link
connection (and of course by the performance of computer 2, but given that it will not have to
handle any recording or playback, you should be able to use quite a lot of effects).

Getting extra audio tracks
All computers on a VST System Link network are locked with sample-accuracy. Therefore, if you
find that the hard drive on one computer is not fast enough to run as many audio tracks as you
need, you can record new tracks on one of the other computers instead. This would create a
“virtual RAID system”, with several disks all operating together. All tracks will remain locked
together just as tightly as if they were all running on the same machine. This means that you
effectively have an unlimited track count! Need another 100 tracks? Just add another computer.

Dedicated Video Playback
Playback of high-resolution video can be taxing on a system’s CPU. By dedicating one computer
for video playback via System Link, you can free up resources on your main CPU for audio and
MIDI processing. Since all transport commands will respond on the VST System Link computers,
scrubbing video is possible even when it is coming from another computer. Spotting sound
effects to picture in Edit Mode will work the same way as it does on one computer. This is a viable
and economic alternative to dedicated hard disk video systems like the Doremi V1.
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Nuendo is a full-featured postproduction media tool that allows you to work with video content.
You can import video files, play back video, and apply speed changes to compensate for film
transfers.
Nuendo allows you to create complete soundtracks for your video and export them as audio files.
RELATED LINKS
Audio Editing to Picture on page 1084

Video File Compatibility
When working on a project involving a video file, you must make sure that the video file type
works on your system.
NOTE
If you are not able to play back a specific video file, use an external application to convert the file
into a compatible format.
To find out what video files are supported, refer to the Help Center on the Steinberg web site.
RELATED LINKS
Codecs on page 1077

Video Container Formats
Video and other multimedia files come in a container format.
This container holds various streams of information including video and audio, but also
metadata such as synchronization information required to play back audio and video together.
Data regarding creation dates, authors, chapter markings, and more can also be held within the
container format.
The following container formats are supported by Nuendo:
MOV
This is a QuickTime movie.
MPEG-4
This format can contain various metadata for streaming, editing, local playback, and
interchange of content. Its file extension is .mp4.
AVI
This is a multimedia container format introduced by Microsoft.
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Codecs
Codecs are methods of data compression used to make video and audio files smaller and more
manageable for computers.
For further details, refer to the Help Center on the Steinberg web site.

Frame Rates
Nuendo supports different video and film frame rates.

Frame rate (speed)
Regardless of the frame counting system, the actual speed at which frames of video go by in real
time is the true frame rate.
Nuendo supports the following frame rates:
23.98 fps
This frame rate is used for film that is being transferred to NTSC video and must be
slowed down for a 2-3 pull-down telecine transfer. It is also used for the type of HD
video referred to as 24 p.
24 fps
This is the true speed of standard film cameras.
24.98 fps
This frame rate is commonly used to facilitate transfers between PAL and NTSC video
and film sources. It is mostly used to compensate for some error.
25 fps
This is the frame rate of PAL video.
29.97 fps/29.97 dfps
This is the frame rate of NTSC video. The count can be either non-drop or dropframe.
30 fps/30 dfps
This frame rate is not a video standard anymore but has been commonly used in
music recording. Many years ago, it was the black and white NTSC broadcast
standard. It is equal to NTSC video being pulled up to film speed after a 2-3 telecine
transfer. The count can be either non-drop or drop-frame.
50 fps
This rate is also referred to as 50 p.
59.94 fps
This video frame rate is supported by high definition cameras and is compatible with
NTSC.
60 fps
This video frame rate is supported by many high definition cameras. However, the
NTSC compatible 59.94 fps frame rate is much more common.
IMPORTANT
Video formats with a variable frame rate (VFR) are not supported.
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Video Output Devices
Nuendo supports several video output devices.
Viewing video files onscreen in the Video Player window may work just fine for many
applications, but often it is necessary to display video in a large format for viewing small details
and so others involved in the session can also see the video. Nuendo provides the ability to use
several types of video output devices to accomplish this.

Dedicated Video Cards
You can use a dedicated video card. Video is sent directly to the output of this video device.
The following video cards are supported:
●

Blackmagic Design video output devices

IMPORTANT
●

You must install the appropriate driver for the video device and set the video card output
to the video file resolution used in your project.

●

Video output via FireWire is not supported.

RELATED LINKS
Video Player Setup on page 1080

Preparations for Creating Video Projects
Before you can start working with video in Nuendo, some basic preparations must be made.
In Nuendo, you may work with multiple video files of different formats on the same video track.
There can be 2 video tracks per project.
NOTE
For proper synchronization of audio and video events, make sure that the project frame rate
matches the frame rate of the video file.

RELATED LINKS
Project Setup Dialog on page 89

Importing Video Files
If you have a compatible video file, you can import it into your project.
PROCEDURE
1.

Select File > Import > Video File.

2.

In the Import Video dialog, select the video file that you want to import.

3.

Optional: Activate Extract Audio from Video to import any embedded audio streams.

4.

Click Open.

RESULT
Nuendo creates a video track with a video event. If Extract Audio from Video was activated, an
audio track with an audio event is positioned below the video track. The corresponding audio clip
is saved in the Pool Record folder.
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NOTE
You can also import video files by dragging them from the MediaBay, the File Explorer/macOS
Finder and dropping them in your project. If you want Nuendo to automatically extract the audio,
activate Extract Audio on Import Video File in the Preferences dialog (Video page).

RELATED LINKS
Pool on page 586
Extract Audio from Video on page 1083

Adopting the Frame Rate
To ensure that the time display of Nuendo corresponds to the actual frames in the video, you
must set the project frame rate to the frame rate of the imported video file.
PREREQUISITE
The frame rate of the imported video file differs from the project frame rate.

PROCEDURE
1.

Select Project > Project Setup.

2.

In the Project Setup dialog, click Get from Video.

3.

Click OK.

RESULT
●

If Nuendo supports the frame rate of the video, the project frame rate is adopted to it. If
needed, the project start time is automatically adjusted to reflect the change in frame rate.
For example, if the project frame rate is switched from 30 fps to 29.97 fps, the project start
time is adopted so that all the events in the project remain at the same positions in
relation to real time.
NOTE
If you want the project start time to remain the same, you must manually change it back.
In this case, you must snap the video event to the timeline to ensure proper positioning
and synchronization within the project.

●

If your project contains several video files with different frame rates, the project frame rate
is adjusted to the frame rate of the first video event on the upper video track. For proper
editing of any other of the imported video files, you must set the project frame rate to the
frame rate of that video file.

Thumbnail Cache Files
For every imported video, file Nuendo automatically creates a thumbnail cache file.
RELATED LINKS
Manually Generating Thumbnail Cache Files on page 1080
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Manually Generating Thumbnail Cache Files
You can manually generate thumbnail cache files. This is necessary if a thumbnail cache file could
not be generated during import because the folder is write-protected, or because you have
edited the file with an external video editing application.
PROCEDURE
●

Do one of the following:
●

In the Pool, right-click the video file and select Generate Thumbnail Cache.

●

In the Project window, right-click the video event, and select Media > Generate
Thumbnail Cache.

NOTE
Refreshing an already existing thumbnail cache file can be done only from within the Pool.

RESULT
The thumbnail cache file is generated in the background so that you can continue working with
Nuendo.

Preparations for Video Playback
You can play back imported video files from within Nuendo by using the transport controls.
For this to work, you must activate and set up a video output device.
IMPORTANT
Your graphics card must support OpenGL 2.0 or higher.
If you work with 2 video tracks in your project, the file on the lower track is played back. To play
back a video file that is positioned on the upper video track, change the order of the tracks or
mute the lower video track.

Video Player Setup
The Video Player setup page in the Studio Setup dialog allows you to set up your video player,
and to check if your video equipment allows for video playback from within Nuendo.
●

To open the Video Player page, select Studio > Studio Setup and activate Video Player in
the Devices list.
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The following options are displayed:
1

Device
Lists the video output devices that are available on your system.

2

Format
Allows you to select an output format.
NOTE
The Onscreen Window device only supports a fixed format.

3

Offset
If the video image does not match the audio, you can enter an offset value in milliseconds
to specify how much earlier the video should be delivered. This compensates for the
display delay. The offset is only used during playback. It is saved globally for each output
device and is independent of the project.

4

Active
Allows you to activate the device that you want to use for playing back video.

5

Show Timecode
Allows you to show the timecode.

6

Position
Allows you to determine the position for the timecode display.

Activating a Video Output Device
PROCEDURE
1.
2.

Select Studio > Studio Setup.
In the Devices list, activate Video Player.
The available video output devices are listed in the Device column.

3.

In the Active column, activate the checkbox for the device that you want to use for playing
back video.
NOTE
If you have no external device connected, you can use the Onscreen Window device that
allows you to play back the video file on your computer monitor.

RELATED LINKS
Video Output Devices on page 1078

Video Player Window
The Video Player window provides different size options for video playback on your computer
screen. However, the larger the size of the window and the higher the resolution of your video,
the more processor load is needed.
●

To open the Video Player window, select Studio > Video Player.
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Fullscreen Mode
Sets the window to full screen mode. To exit full screen mode, open the context
menu and select Exit Fullscreen Mode or press Esc.
Quarter Size
Reduces the window to a quarter of the actual size.
Half Size
Reduces the window to half the actual size.
Actual Size
Sets the window to the size of the video.
Double Size
Enlarges the window to twice the actual size.
Aspect Ratio
You can also drag the borders of the Video Player window to resize it. However, this
might lead to a distorted image. To prevent this, you can set an option from the
Aspect Ratio pop-up menu.
●

If you select None, the aspect ratio of the video is not kept when you resize
the window. The image is enlarged/reduced to occupy the whole Video Player
window.

●

Internal allows you to resize the window freely while keeping the aspect ratio
of the video. Borders might be displayed around the video image to fill the
window.

●

External allows you to resize the window within some limits so that the video
image always fills the full window and its aspect ratio is kept.

●

NOTE
In full screen mode, the aspect ratio of the video is always kept.
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Scrubbing Video
You can scrub video events, that is, play them back forwards or backwards.
PROCEDURE
1.

Select Studio > Video Player.

2.

Do one of the following:
●

Click in the Video Player window and move the mouse to the left or to the right.

●

Use a jog wheel on a remote controller.

Editing Video
Video events are created automatically when you import a video file.
You can view and edit video events in the Project window. A video event triggers the playback of
the corresponding video clip.
You can copy and trim video events. You can also lock video events in the Project window.
You cannot draw, glue, and mute video events, or apply fades or crossfades.
RELATED LINKS
Pool on page 586
Use Video Follows Edit Mode on page 1086

Extract Audio from Video
You can extract the audio stream of a video file on import. Nuendo supports video files with
audio in mono or stereo, and multi-channel configurations with up to 48 channels.
To extract audio from a video file, do one of the following:
●

Select File > Import > Video File and activate Extract Audio from Video in the dialog.

●

Select Media > Extract Audio from Video File, and select the video file in the file dialog.

●

Select File > Import > Audio from Video File.
This creates an audio clip in the Pool, but does not add any events to the Project window.

A dialog is displayed allowing you to select different import options.
The extracted audio stream is added to the project on a new audio track and can be edited like all
other audio material.
RELATED LINKS
Import Options for Audio Files on page 277
Importing Video Files on page 1078
Audio Editing to Picture on page 1084
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Nuendo is a production tool that allows you to create music and sound design for film and video.
This includes the following tasks:
●

Preparing a video project

●

Placing audio to picture

●

Adjusting and editing audio

Video Timeline and the Grid
As opposed to music that uses bars and beats, video and film use frames as a basic measuring
block for editing.
In the time displays, video frames are displayed in SMPTE timecode where colons separate each
division of time: hours, minutes, seconds, frames, and subframes:

The amount of frames per second depends on the frame rate of the video.
Film frames can be displayed as SMPTE numbers or in feet and frames, a traditional method used
by film editors.
Nuendo also offers a user-definable frame rate for specialized frame rates.
Feet and frames are displayed in the Transport panel, in the Project window ruler, and in the
Time Display.
RELATED LINKS
Video on page 1076
Frame rate (speed) on page 1046
Adopting the Frame Rate on page 1079

SMPTE Subframes and Days
Nuendo can also display subframes and days.
Each frame is divided into 80 subframes. These appear separated from frames by a period.
●

To display subframes, activate Show Timecode Subframes in the Preferences dialog
(Transport page).

If a project crosses the 24-hour mark, days can be displayed. These appear as a day number to
the left of the SMPTE display separated by a space.
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EXAMPLE
For live events that take place in the evening, it can be useful to display days in timecode even
when the project is shorter than 24 hours. If the central timecode generator for the event is
running time-of-day SMPTE that correlates to the actual time on the clock, the time display may
cross the 24-hour mark at midnight. In that case, all timecode values after midnight will have a 1
in the days position to the left of the SMPTE value.

Drop-Frame SMPTE
Drop-frame timecode is used for the 29.97 fps frame rate used by the NTSC video standard and
the 30 fps frame rate.
Since this frame rate does not correlate exactly to the actual time passing on the clock, a system
has been devised that omits certain frame numbers in order to match the displayed time with
the time of day.
Nuendo distinguishes drop-frame timecode by separating the frame number with a semicolon
instead of a colon.

If the Project window ruler is set to timecode, the following options are available in the Grid
Type pop-up menu:
●

Subframe

●

1/4 frame

●

1/2 frame

●

1 frame

●

2 frames

●

1 second

These grid options allow you to edit, nudge, and move events, fades, and automation data in
increments that relate to the video frames you can see.

Conforming Production Audio
Nuendo allows you to conform production audio, that is, placing audio on a timeline to match
the picture.
You must import production audio that was originally recorded during the filming process, or
any other audio you want to use into the project.
In Nuendo, you can import:
●

Separate audio files

●

Audio that is embedded in a video file

●

Sounds and music from sound effect libraries
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NOTE
Use the MediaBay to organize all your sound files.

RELATED LINKS
Importing Video Files on page 1078
Importing Audio from Video Files on page 282
Importing Audio Files on page 277
MediaBay on page 607
Loading Loops and Samples on page 637

EDL Files
EDL files (Edit Decision Lists) are lists of edits created by a video editing suite. They are text files
that contain the timecode and source tape information that you need to place audio events to
picture.
Each step in the EDL describes a complete editing task including:
●

The type of edit (audio, video or both)

●

The source material (tape number, audio file name, or video file name)

●

The start and ending source timecode values

●

The start and ending destination timecode values

NOTE
The source material must have correct timestamps, otherwise the EDL timecode values are
invalid. You can create audio files with embedded timestamps with timecode DAT machines,
video tape machines, field recorders, digital film cameras, etc.
Working with EDL files allows for the most precise control over the source material and
synchronization.
RELATED LINKS
Importing an EDL on page 346

OMF Files
OMF files can contain multiple tracks of audio that are either embedded or refer to external
audio media. They store information about where to place each piece of audio in the timeline.
Since the OMF audio is created during the video edit, its timecode values should be correct and
you can safely adjust the position of the video and reference audio to match the OMF audio.
RELATED LINKS
Importing OMF Files on page 1120

Use Video Follows Edit Mode
The Use Video Follows Edit Mode allows you to edit audio while getting continuous visual
feedback on the video display.
If you activate Use Video Follows Edit Mode in the Transport menu, project cursor and video
automatically follow each edit you make. This allows you to instantly see where in the video your
edit is taking place. If the project is in stop mode, the project cursor is only displayed in the
timeline.
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The video display gives you visual feedback during the following actions:
●

Selecting ranges

●

Editing audio

●

Moving audio events

●

Nudging audio events or range selections

●

Resizing audio events or range selections

●

Using the Time Warp tool

●

Adjusting audio fade handles

NOTE
Use Video Follows Edit Mode uses the snap point of audio events. By adjusting the snap point,
you can align to an audio position that is situated in the middle of the event.
EXAMPLE
The sound of a car skidding to a stop can be easily timed to picture by lining up the end of the
skid sound with the stopping of the car in the video. However, if the car comes into the frame
after the skidding, it can be very difficult to align the sound. In this case, move the snap point to
the end of the skidding sound and activate Use Video Follows Edit Mode to match that point to
the stopped car on screen.
RELATED LINKS
Snap Point on page 521
Editing Tempo and Time Signature on page 975

Event-Based Fades and Volume Envelopes
When working with picture, consider using event-based fades and volume envelopes.
Event-based fades and volume envelopes are useful for the following reasons:
●

They are calculated in real time which gives you instant feedback of your edits while
playback continues.
As long as you release the event handle before the cursor reaches the event, you can hear
the result of your edit.

●

They are calculated before the audio signal is sent to the MixConsole.
If you insert a compressor plug-in on an audio track and you increase the volume of an
event on that track, this will increase the input signal that reaches the compressor plug-in,
and the plug-in changes the gain reduction accordingly.

●

They move together with the event.

RELATED LINKS
Event-Based Fades on page 301
Creating Event-Based Volume Changes on page 316
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Placing Audio to Picture
In Nuendo, you have several possibilities to insert the audio in your project and place it to the
picture.
NOTE
If you work with reference audio, consider panning it to one side and the new audio to the other.
This allows you to discern whether one source is ahead of the other. You will hear a comb
filtering effect when 2 identical sources become very close in sync with one another.

Snapping Audio Events to Video Events
You can place audio to picture by using the Snap function.
PREREQUISITE
A project with an audio and a video event is open.
PROCEDURE
1.

In the Project window toolbar activate Snap.

2.

Open the Snap Type pop-up menu and select Events.

3.

Drag the audio event to the start of the video event.

RESULT
The start of the audio event is aligned with the start of the video event.
AFTER COMPLETING THIS TASK
Verify if audio and video are synchronized throughout the length of the project, and fix any
issues before editing.
RELATED LINKS
MediaBay on page 607
Adjusting and Editing Audio on page 1090

Inserting Audio at Timecode Positions
You can insert audio files from the MediaBay or from the Pool at the timecode start position of
the video event.
PREREQUISITE
A project with a video event is open. You know the timecode start position of the video event.
PROCEDURE
1.

Do one of the following:
●

Select Media > MediaBay to open the MediaBay.

●

Select Media > Open Pool Window to open the Pool.

2.

Right-click the audio event that you want to use and from the context menu select Insert
into Project > At Timecode Position.

3.

In the Insert Media at Position dialog, enter the timecode start position of the video
event.

4.

Click OK.
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RESULT
The audio event is inserted on the topmost selected track in the Project window with the event
start aligned with the timecode start position of the video event.
AFTER COMPLETING THIS TASK
Verify if audio and video are synchronized throughout the length of the project, and fix any
issues before editing.
RELATED LINKS
MediaBay on page 607
Adjusting and Editing Audio on page 1090

Inserting Audio at the Cursor Position
You can insert audio files from the MediaBay or from the Pool at the cursor position.
PREREQUISITE
A project with a video event is open. You have viewed the video and found the position where
you want to insert the audio event.
PROCEDURE
1.

Set the cursor to the position where you want to insert the audio event.
NOTE
You can use the Markers window to add markers at positions where you want to insert the
audio. Locate to these markers to set the cursor to these positions.

2.

3.

Do one of the following:
●

Select Media > MediaBay to open the MediaBay.

●

Select Media > Open Pool Window to open the Pool.

Right-click the audio event that you want to use and from the context menu select Insert
into Project > At Cursor.

RESULT
The audio event is inserted on the topmost selected track in the Project window with the event
start aligned with the cursor position.
AFTER COMPLETING THIS TASK
Verify if audio and video are synchronized throughout the length of the project, and fix any
issues before editing.
RELATED LINKS
MediaBay on page 607
Locating to Markers on page 1089
Adjusting and Editing Audio on page 1090

Locating to Markers
You can use the Markers window to add markers at positions where you want to insert audio. By
locating to markers you can set the cursor to these positions.
PROCEDURE
1.

View the film or the video in Nuendo, keep the Markers window open, and add markers at
the positions where you want to place sound effects and other audio elements.
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The marker is shown in the list.
2.

In the Description column, enter a description for the marker.

3.

Add as many markers as you need.

4.

Select a marker in the Markers window to set the cursor to its position.

RESULT
You have added markers for specific positions where you want to insert audio. You can select a
marker to set the cursor to the marker position.
RELATED LINKS
Markers on page 334
Inserting Audio at the Cursor Position on page 1089
Inserting Clips into a Project on page 593

Adjusting and Editing Audio
In Nuendo, you have several possibilities to adjust and edit audio events in your project so that
they match the picture.

Nudging Audio Events
You can fine-tune the start or end position of audio events or their size with the nudge buttons.
PROCEDURE
1.

Right-click in the Project window toolbar, and on the context menu, activate Nudge
Palette.

2.

Select the audio event and do one of the following:
●

Click Move Left or Move Right to incrementally adjust the position of the entire
audio event.

●

Click Trim Start Left or Trim Start Right to incrementally size the start of the audio
event.
NOTE
If the Object Selection tool is set to Sizing Moves Contents, the event content is
moved.

●

Click Trim End Left or Trim End Right to incrementally size the end of the audio
event.
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NOTE
If the Object Selection tool is set to Sizing Moves Contents, the event content is
moved.

RESULT
The audio event is moved accordingly.
NOTE
The nudge increment is determined by the timeline and grid in the Project window.

4-Point Editing with the Range Selection Tool
You can use the Range Selection tool in Nuendo to select a range on the track where you want
to place the audio, and another range that spans the audio you want to use. This works just like
marking points in 4-point editing.
PREREQUISITE
The audio that you want to use as work file is imported into your project at a position behind the
end of the program material. This prevents your work files from being included in the final mix.
The corresponding tracks are moved to a folder track.
PROCEDURE
1.

Watch the video, and with the Range Selection tool, select the range on the destination
track where you want to insert your audio.
NOTE
You can also use the key commands for Left Selection Side to Cursor (E) and Right
Selection Side to Cursor (D) to define the range selection on the fly.

2.

Listen to the audio to identify the audio that you want to use with the picture.

3.

Open the Range Selection pop-up menu and select Selection B.

4.

Select the audio range and press Ctrl/Cmd-C to copy this selection to the clipboard.

5.

Open the Range Selection pop-up menu and select Selection A to switch to the selection
range you defined on the destination track.
NOTE
If you switch selections, also the viewing area is switched. This allows you to move quickly
between source and destination audio.

6.

Press Ctrl/Cmd-V to paste the audio from the clipboard onto the track.

RESULT
The range on the destination track is replaced with the audio from the clipboard.
RELATED LINKS
Adjusting Range Selections on the Info Line on page 1092
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Adjusting Range Selections on the Info Line
You can adjust selection ranges by modifying their values on the info line.
PROCEDURE
●

Do one of the following:
●

Modify the Range Start value to move the selection without changing its length.

●

Modify the Range End value to change the end time.

●

Modify the Range Length value to change the length of the selection.

●

Modify the Top Track value to change the number of the topmost track in the
selection.

●

Modify the Bottom Track value to change the number of the bottom track in the
selection.

NOTE
By assigning key commands, you can increase the speed and efficiency for creating range
selections.

RELATED LINKS
Range Editing on page 225
Editing Selection Ranges on page 227
4-Point Editing with the Range Selection Tool on page 1091

Cut Head/Cut Tail
You can crop range selections in the Project window.
●

To delete everything to the left of the selection range, select Edit > Cut Head.

●

To delete everything to the right of the selection range, select Edit > Cut Tail.

NOTE
This affects any type of event in the Project window including video, MIDI, markers, and
automation data.

RELATED LINKS
Range Editing on page 225
Using Cut Head and Cut Tail on page 212

Time-Stretching Audio to Picture
You can change the length of an audio event that does not quite fit with a video by using time
stretch.
PREREQUISITE
The start of the audio event is aligned with the position of the video.
PROCEDURE
1.

Open the Transport menu and activate Use Video Follows Edit Mode.

2.

Select the Range Selection tool and double-click the audio event to create a selection
range that spans the whole audio event.

3.

Click the right edge of the selection range and drag to adjust it to the desired length.
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4.

Select Transport > Locators > Set Locators to Selection Range.

5.

With the Object Selection tool, select the audio event.

6.

Select Audio > Process > Time Stretch.

7.

In the Time Stretch dialog, click Use Locators.
This sets the time stretch ratio so that the audio event fits the locator range.

8.

Click Process.

RESULT
The audio is stretched or compressed to fit the range.

Adjusting Audio Fades to Picture
You can fade in the audio so that it reaches its full volume at a certain position in the video, and
fade it out at another position.
PREREQUISITE
The audio event is positioned and sized correctly according to the video. Show Event Volume
Curves Always is activated in the Preferences dialog (Event Display—Audio page).
PROCEDURE
1.

Open the Transport menu and activate Use Video Follows Edit Mode.

2.

On the Project window toolbar, select Range Selection.

3.

Select a range that covers the section of the audio event that you want to be played at full
volume.

4.

Select Audio > Adjust Fades to Range.

RESULT
The fade-in and fade-out handles of the audio events are adjusted to the selected range.
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When working on film projects, video postproduction editors typically transfer the film footage to
video for use with computer video editing systems.
Once the film has been edited, it can be transferred back to film for presentation in theaters or
may remain in video format for television broadcast and release on videotape or DVD.

Pull-Down and Speed Changes
Pull-down is an algorithm for the frame rate conversion of film footage to the faster video frame
rate.
When film footage is transferred to video, the frame rate must be converted from 24 fps to either
25 fps (PAL/SECAM) or 29.97 fps (NTSC). This process introduces a slight speed change as a result
of the mathematical relationships between the different frame rates. The film to NTSC
conversion is done as a 2-3 pull-down and the film is running at 23.98 fps to maintain the exact
2:3 relationship. As a result the film is running ~0.1 % slower in NTSC TV.
These speed changes must also be applied to the audio recorded along with the film, in order for
the audio to remain in sync with the picture. Sometimes the speed change is applied at the same
time as the film transfer and is recorded directly on the videotape. This allows the video editor to
hear the audio along with the transferred video while editing.
However, speed changes also result in pitch changes. Furthermore, this may lead to artifacts in
the audio, due to the fact that a direct digital transfer from the field recorder to videotape is not
possible without performing either a sample rate conversion or an analog transfer.
Therefore, most audio engineers prefer to use the original source material when working with
film audio. Once the original audio has been digitally transferred into Nuendo, the speed change
must be compensated for in order to keep the audio in sync with the video. Nuendo has the
flexibility to apply these speed changes independently to either the audio or video.
RELATED LINKS
Compensating for Speed Changes on page 1097

Telecine Process
A telecine machine is the device used to transfer film to videotape. It transfers images from each
frame of film to frames of video in a very specific way.
Having a clear understanding of this process will help alleviate the confusion surrounding pull-up
and pull-down sample rates and keeping film audio in sync.
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Film Frames and Video Fields
When transferring film to videotape, part of the film image must be transferred to one field and
then the rest to another field of video. This is due to the way that video signals are formatted.
In video signals, each frame or single image is composed of 2 video fields, each containing half
of the image. The first field contains all the odd horizontal lines of resolution and the second field
contains the even horizontal lines of the image. This is called interlacing and is needed to
minimize the flicker effect that would result if the image was presented all at once.
A film frame, however, is a single, complete image (like a 35 mm photograph). That means that
there are no fields involved.

Film Transfers to PAL/SECAM Video
Film transfers to PAL/SECAM video are relatively straightforward. Film runs at 24 fps and PAL
video runs at 25 fps. If you speed up film by roughly 4 % (or 4.16 %, to be precise), it will be
running at 25 fps. That means that film transfers to PAL video result in a 4 % pull-up in speed.
When properly done, the first frame of film will be transferred to both fields of the first frame of
video and so on. All that is needed is the 4 % increase in speed for this to be a one-to-one
transfer.
To keep the audio in sync, it must also be pulled up by 4 %. This will result in a 4 % increase in the
pitch as well. If the final project is to remain in the video format, pitch-correcting might be
necessary. If the project is going to be returned to film for the final presentation, the audio can
be slowed back down to normal speed when transferring back to film in order to preserve the
fidelity and performance values of the original material.

Film Transfers to NTSC Video
Transferring film at 24 fps to NTSC video at 29.97 fps presents a few more difficulties than the
PAL transfer. Simply speeding up film to 29.97 fps would cause both the visual and audio
elements to become too fast and high-pitched to be usable. There is no neat mathematical
relationship between 24 fps and 29.97 fps.
To allow film transfers to NTSC video, another method called the 2-3 pull-down was devised.

Two-Three Pull-Down
The 2-3 pull-down allows for a smooth transfer to NTSC video without any unwanted or
noticeable pitch changes in the audio. It consists of a combination of speed change and frameto-field counting.
The following steps are involved during the process:
●

The film speed is slowed or pulled down to 23.976 fps (-0.1 %).

●

The first frame of film is transferred to the first 2 fields of video.

●

The second frame of film is transferred to 3 fields of video, the 2 fields of the second video
frame, and just the first field of the third video frame.
NOTE
This is where the 2-3 part of the name comes from. Each alternating frame of film is
transferred to 2 fields of video, then 3 fields of video, and so on.

●

The third film frame is transferred to the second field of video frame 3 and the first field of
video frame 4.

●

The remaining film frames are transferred in this manner, alternating between 2 and 3
fields of video, until the end of the transfer. After 4 frames of film have been transferred
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this way, an even 5 video frames will be created. Over the course of one second, 24 frames
of film and 30 frames of video will have gone by. Because they are running at -0.1 %, the
actual frame rate is 29.97 video frames per second, the NTSC standard.

In order to make accurate decisions regarding audio pull-down and video pull-up when working
with NTSC film transfers in Nuendo, it is important to have a clear understanding of 2-3 pulldown.
Even though 29.97 fps (video speed) is a faster frame rate than 24 fps (film speed), the video is
running -0.1 % slower than the original film due to the 2-3 transfer process. Therefore, you need
to slow the audio down a bit so that production audio, such as DAT tapes or files from a field
recorder from a film shoot are played back in sync with NTSC video.
IMPORTANT
Many video editors working with NTSC video refer to 30 fps as film speed as opposed to 24 fps.
The reason for this is, if you speed NTSC video (29.97 fps) up by 0.1 %, you are running at the
same speed as the original film at 24 fps. Conversations regarding this can often get very
confusing. Make sure that you have a clear understanding of the material you are working with
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when dealing with film transfers and frame rates. It will avoid many mistakes and save time in
the long run.

Compensating for Speed Changes
In Nuendo, there are 2 basic ways to compensate for speed changes due to film transfers.
The first is by adjusting the playback speed of the audio to match the speed of the video. The
second is to adjust the speed of the video file to match the original speed of the film and
production audio in Nuendo.

Adjusting Audio Playback Speed
When adjusting audio playback speed to match the video, the playback adjustment depends on
the video format that the film is transferred to.
For NTSC, the speed change is down -0.1 %. For PAL/SECAM, the change is up +4.1667 %.

Audio Pull-Down -0.1 % (NTSC)
When you work with film projects that have been transferred to NTSC, the audio must be slowed
down in order to remain in sync.
Audio suffers a generation loss and speed change during the film transfer. Therefore, most audio
engineers prefer to use the original tapes from the film shoot when working on a film project
that has been transferred to NTSC video.
To slow down audio playback in Nuendo, you might need an external sample clock source to pull
the clock speed down by 0.1 %.
For this to work, your audio card must be set to external sync and connected to the clock device
via word clock, VST System Link, or some other clocking method. Furthermore, you must tell
Nuendo that it is being synchronized with an external clock source. This is done in the Studio
Setup dialog.
Because video and audio playback speeds are independent in Nuendo, the video will remain at
the same speed while the audio is slowed down (pulled down). This ensures that the production
audio and film transfer remain in sync.
Either you receive an OMF, AES 31, or OpenTL file that contains audio from the original source
tapes conformed to the edited video or you have to record the source tapes into Nuendo
yourself. In both cases, you have audio in Nuendo that is edited to the picture but will not stay in
sync with the video unless you pull down the sample rate.
IMPORTANT
●

When Nuendo is running at a non-standard sample rate (47.952 kHz = 48 kHz pull-down),
digital transfers into Nuendo from external equipment must be made with the external
equipment locked to the same sample clock as your audio card. Most devices are capable
of a 0.1 % change in sample rate and will function normally.

●

Any audio mixdowns that are exported from Nuendo when the sample clock is pulled
down will play back in other applications and devices faster because that sample clock will
be running at the standard 48 kHz.

The idea is that when you have completed the audio mix for your film project, the video will be
sped back up to film speed for the final transfer back to film and your audio mix can then be
played at the standard 48 kHz sample rate (no pull-down) and will remain in sync with the picture.
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Using this method preserves the quality of the original audio recording made during filming and
allows for a digital mixdown transfer at film speed without any generation loss or sample rate
conversion.
RELATED LINKS
Selecting an Audio Driver on page 13

Audio Pull-Up +4.1667 % (PAL/SECAM)
Audio pull-up (+4.1667 %) is the same concept applied to PAL/SECAM video transfers.
Because the film is sped up by 4.1667 % during transfer, audio in Nuendo must be running at
+4.1667 % speed in order to remain in sync with the video during editing and mixing.
In this case, the external clock must be set to +4 % varispeed.
IMPORTANT
Steinberg’s SyncStation is capable of varispeed and has presets for the 4.1667 % necessary with
PAL film transfers and the -0.1 % for NTSC.
Once the project is complete, the Nuendo sample rate can be returned to normal (48 kHz) for the
final mixdown at film speed. Once again, this allows for a digital transfer of the final master at
the correct speed for theatrical presentation.

Non-Standard Audio Pulls
It is also possible to use pulled sample rates that do not fit one of the above scenarios. These
sample rates would only need to be used in exceptional circumstances when an error has
occurred elsewhere in the process of making a film.
The following settings can be used to correct sync errors made at another studio or problems
with video editing systems:
●

-4 % pull-down
If a film project was transferred to PAL/SECAM video and the audio editing and mixing was
performed at video speed (48 kHz) without using audio pull-up, the final mix would be
running at video speed, not film speed. In this case, a -4 % pull-down can be used to
correct this and get the audio running at film speed again. The downside to this is that the
final transfer to film would either have to be analog or through a sample rate converter in
order to be recorded with the film.

●

+0.1 % pull-up
This pull-up is not normally used except in situations similar to the one described above,
but for NTSC video. It can be used to correct the speed of a project finished at video speed
(without pull-down) prior to transferring it to film. Because film is moving 0.1 % faster than
NTSC video, the audio mix can be sped up to film speed using +0.1 % pull-up for the
transfer.

●

Other pull-up/pull-down options
There may be other scenarios where non-standard pull-ups and pull-downs can be used to
correct mistakes. Nuendo provides further pull-up/pull-down options for such situations in
the Project Setup dialog and the respective section in the Project Synchronization Setup
dialog.

IMPORTANT
All the examples used here are with 48 kHz as the standard sample rate for the film and video
industry. However, it is possible to accomplish the same tasks using 44.1 kHz, 88.2 kHz, 96 kHz

1098

Film Transfers
Compensating for Speed Changes
(this is double the standard sample rate and commonly used for higher fidelity), 176.4 kHz and
192 kHz, provided you have an external clock device capable of pulling these higher sample rates.

Adjustments When Applying Audio Speed Changes
When the audio clock of your audio card is being slowed down or sped up by an external clock
source, Nuendo cannot know that it is running slower or faster than normal. The time displays
(minutes:seconds, timecode) will become inaccurate because they are based on a sample count,
not the independent clock source.
Nuendo provides an adjustment of the timeline to compensate for these changes. This setting is
found in the Project Setup dialog as well as in the Project Synchronization Setup dialog in the
Project Setup - Time section.

NOTE
It makes no difference whether you make your audio pull-up/audio pull-down settings in the
Project Setup dialog or the Project Synchronization Setup dialog. If you use the Project
Synchronization Setup dialog, your adjustment is reflected in the Project Setup dialog, and vice
versa.
Whenever you apply an audio pull to Nuendo from an external clock, also set Audio Pull-up/Pulldown to the corresponding setting. This allows Nuendo to recalculate the sample count to reflect
the adjusted sample rate.
For example, if the setting is switched from no pull-down to -0.1 % pull-down, events on the
timeline will appear longer because the sample rate has been slowed down. The event display
will show the accurate length of events relative to timecode, minutes, and seconds.
NOTE
In the Project window, the status line below the toolbar also indicates whether audio pull-up or
audio pull-down is applied to this project.
When you change Audio Pull-up/Pull-down and there are audio events in the timeline already,
Nuendo prompts you to choose whether or not to keep the original sample start times.
●

Select No to let the events follow the timecode and minutes:seconds clock change, and
remain at their SMPTE start times.

●

Select Yes to force Nuendo to leave events at the same sample start time regardless of the
clock speed change.
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Video Pull-Up and Pull-Down
Nuendo also provides a method to adjust for film transfers by speeding up or slowing down
playback of the video files in your project.
Depending on the situation, it can be helpful to make the video file play back at film speed and
not adjust the audio playback at all.
Adjusting the video playback speed back to film reverses the process used when adjusting audio
playback speed. For NTSC video, the video playback speed must be adjusted up +0.1 % back to
film speed.
Altering the video playback speed is done in the Project Synchronization Setup dialog (Project
Setup - Time section). You have 2 options: 0.1 % pull-up and 0.1 % pull-down.

Video +0.1 % Pull-Up for NTSC
Because NTSC video is running -0.1 % slower than the original film, pulling the video speed back
up by +0.1 %, returns it to original film speed. With the video now running at the correct film
speed, audio originally recorded at 48 kHz on the film shoot will remain in sync with the video.
Additionally, the final mix can be digitally transferred back to film at 48 kHz without the need for
an analog copy or sample rate conversion.

Video -0.1 % Pull-Down (Non-Standard)
Pulling the video speed down for an NTSC video is a non-standard procedure and would not
happen under normal circumstances. It is possible to pull down a video file that is running at 24
fps -0.1 % so it matches with material running at NTSC video speed. The resulting frame rate is
23.976 fps.
NOTE
Speeding up or slowing down the video speed is only possible if the video is running through a
computer video card. If a professional genlocked video card is used, the video playback speed is
derived from the genlock input.

What is 23.976 fps Used for?
The world of digital video formats is ever changing and the results are new developments for
every media professional involved in movies, television, corporate video, and more. With the
advent of HD cameras that are capable of recording at several different frame rates internally,
the options available to cinematographers have become staggering.
Because the look of film running at 24 fps is unique, many HD productions are filmed at 24 fps to
mimic the look of film on video. Because the speed change from 24 fps to 29.97 fps NTSC is such
an odd one (requiring the 0.1 % pull-down), designers of these cameras have developed a
method of recording that allows the camera to record like film, but also output an NTSC video
signal at the same time without any speed change. They record at 23.976 fps which translates to
24 fps pulled down -0.1 %.
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Working with Video Tape Recorders
Whenever you are interfacing Nuendo with external hardware, some additional computer
hardware may be necessary.
In the case of using video tape recorders (VTRs) with Nuendo, a device capable of dealing with
SMPTE timecode, word clock, video reference clock, MIDI machine control, and Sony 9-Pin
machine control protocols will be needed.
The most important aspect of working with VTRs is the ability to maintain the best possible
synchronization between Nuendo and the tape machine. Using a device, such as Steinberg’s
SyncStation, will provide the best results.
Regardless of your hardware setup, Nuendo will have to be configured to synchronize with the
VTR.
RELATED LINKS
Synchronization on page 1044

Tips
There are so many variables within the boundaries of a multimedia project that only years of
experience can cope with all of them. However, here are a few tips and good ideas you can use to
help eliminate some common issues.

Preproduction Planning
The most important tip for making postproduction go smoothly for a TV commercial, feature film
or even Internet media creation is good use of preproduction planning. Try and meet with all the
people involved in a project prior to starting in order to decide how the work will flow once you
get into postproduction. Determining frame rates for film and video, film transfer issues, what
format the location audio will be recorded in, delivery formats and other details including a
working copy of the script will be invaluable to any postproduction audio professional.

TC Burn-In
The timecode burn-in window (BITC) is a section of the video image that contains timecode
numbers for each frame of video from the original video editor. Using this, it is possible to align a
video perfectly in Nuendo so that all the timecode numbers line up exactly.
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The ReConform function allows you to automatically adapt edited audio projects to new cut
versions of video material.
Post production often includes working on audio mixes with early cut versions of video material.
When you get changed versions of the video material, you must identify the changed parts and
adapt the audio mix accordingly.
The ReConform function helps you by re-adapting the audio mix to the changed video material.
Most of the process is done automatically, however, you can still make manual changes.

Prerequisites
The following prerequisites are required to work with the ReConform function.
●

A Nuendo project.

●

An Edit Decision List (EDL) for the current cut version of the video material.

●

An Edit Decision List for the target cut version of the video material.
NOTE
Instead of old and new EDLs you can also use a change EDL that contains the changes
from old to new EDL.

●

Optional: The corresponding video for video preview.

RELATED LINKS
EDL Files on page 1086

ReConform Workflow
The ReConform function automates most of the typical workflow that includes comparing old
and new EDLs as well as applying the EDL changes correctly to the Nuendo project.
The workflow includes the following steps:
●

You import and compare different versions of EDLs. This creates a new EDL that contains
the differences between your current project and how it is supposed to be to match the
new video. This EDL is called Change EDL.
NOTE
If available, you can directly import a Change EDL.

●

You manually check and validate the entries in the Change EDL and make corrections
where necessary.
You can use the preview functions to see the result of the ReConform process for single
entries in the ReConform dialog and in the Project window. The preview does not affect
the original audio or video material.
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●

When you have made all changes to the Change EDL, you start the ReConform process
which applies the changes to the project.

ReConform Dialog
The ReConform dialog contains the main user interface for the ReConform function.
●

Select Project > ReConform to open the ReConform dialog.

1

Old EDL
The current cut version of the video material.

2

New EDL
The updated version of the video material.

3

Change EDL
The changes between old and new EDLs.

4

Video preview

5

Timeline

Displays video frames of selected entries in the Change EDL.
The entries of the old and the new EDL.
6

Open ReConform Settings
Allows you to configure the ReConform function.

RELATED LINKS
ReConform Settings on page 1111
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EDLs
Edit Decision Lists (EDLs) form the basis of the ReConform function.
The main idea of the ReConform function is to adapt changes in EDLs to a current audio mix. As a
prerequisite, you must have at least an existing EDL and a new EDL. Alternatively, you can use an
EDL that already contains changes, the Change EDL.
The ReConform dialog allows you to import old and new EDLs that you can use to generate a
Change EDL. You can also import an existing Change EDL.
In the dialog, you can find these EDLs in the Old EDL, New EDL, and Change EDL lists. In these
lists, you have the following options:
Add EDL
Allows you to add an existing EDL into the ReConform dialog.
Save EDL (Change EDL only)
Saves a generated Change EDL.
Delete EDL
Deletes all entries in the corresponding list.
Each EDL consists of the following data:
State
State of the entry. Green indicates that the entry is valid. Red indicates that the entry
is invalid. If you move the mouse pointer over the symbol in the column, a tooltip
provides an error description.
ID
ID of the entry.
Roll
Roll name of the entry.
Clip Name
Clip name of the entry.
EDL File
The name of the EDL file from which this entry was read.
TR
Transition type of the entry.
●

C - Cut

●

D - Dissolve

●

W - Wipe

SRC IN
Start timecode of the entry in the original video file or clip.
SRC OUT
End timecode of the entry in the original video file or clip.
DST IN
Start timecode of the entry in the project.

1105

ReConform
EDLs
DST OUT
End timecode of the entry in the project.
In addition to the columns, all EDLs inform you about the number of entries and how many of
them are selected or invalid.
RELATED LINKS
Adding EDLs on page 1107

Change EDLs
The Change EDL displays the changes between old and new EDLs.
It can either be generated through comparison of old and new EDLs or imported directly into the
ReConform dialog.

Each entry in the Change EDL specifies which parts of the current project version, indicated by
the timecodes in the SRCIN and SRCOUT columns, are to be put at a different position in the new
project version, indicated by the timecodes in the DSTIN and DSTOUT columns.
If you select an entry in the Change EDL, the corresponding entries in the old and new EDLs are
displayed in a different color.

Timelines
Below the Change EDL, the entries of the old and new EDLs that were used for creating the
Change EDL are displayed on timelines. The Source timeline displays the old EDL, the
Destination timeline the new EDL.
Entries that are selected in the Change EDL are highlighted in the same color on the timelines.
VFX shots that were found while the Change EDL was being created have a specific color in the
list and on the timelines.

Preview
The Preview function of the Change EDL section allows you to check how one or several selected
entries will affect the result of the ReConform process. Any manual healing or extending of
entries as well as the editing of timecodes in the Change EDL can be previewed before the start
of the actual process. You can listen to the result and inspect the audio and video material of the
source version and the destination version in detail. You can also add notes to the destination
preview. It is not possible to make changes to the destination version.
In the Project window, locators mark the time range that is used during the ReConform process.
Technically, the preview result is added to the project with a one day time offset, which will be
deleted after the preview is deactivated. The resulting tracks are locked for as long as the
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preview is active. This prevents you from making changes to the resulting material, as the
changes will be lost as soon as the preview is deactivated.

Preview
If this button is activated, the preview shows the source or the destination version of
the selected entry in the Project window. The button blinks if the preview is active.
SRC
If this button is activated, the preview shows the source version of the selected
entries in the project.
DST
If this button is activated, the preview shows the destination version of the selected
entries in the project.

Adding Notes to the Preview
In the preview, you can create markers to add notes within the destination time range.
For example, if you discover problems within the generated data of the preview, you can add
notes to the Memos marker track that is automatically created when you activate the preview.
The notes are transferred to the corresponding entry in the source version.

PROCEDURE
1.

Activate DST to display the destination version of the selected entry.

2.

On the Memos marker track, add a marker and move it to the required position.

3.

Enter a description for the marker.

RELATED LINKS
Marker Track on page 341

Adding EDLs
You can add standard EDLs to the Old EDL and New EDL lists in the ReConform dialog. You can
import an existing Change EDL to the Change EDL section.
PREREQUISITE
You have received EDL files in one of the following formats:
●

CMX3600

●

FILE16

●

FILE32
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PROCEDURE
1.

In any of the lists, click Add EDL

.

The Add EDL to <name of list> List dialog opens.
2.

Click Browse EDL Files

.

3.

Select one or more EDL files and click Open.

4.

Optional: In the Add EDL to <name of list> List dialog, specify a timecode offset for the
destination times in the DST Offset field. In the Add EDL to Change EDL List dialog, you
can also specify a timecode offset for the source times in the SRC Offset field.

5.

Click OK.

RESULT
The EDL is displayed in the ReConform dialog. The timecode offsets are added.

Deleting EDLs
You can delete added EDLs from the ReConform dialog.
PROCEDURE
●

In the EDL, click Delete

.

RESULT
The EDL is deleted from the dialog.

Modifying Timecodes
You can modify the source and destination start and end times for a selected entry in an EDL.
PROCEDURE
1.

Select an entry in Old EDL, New EDL, or Change EDL.

2.

Right-click the entry.
The context menu opens.

3.

Select Edit.

4.

In the dialog, change the timecodes of the source and destination time ranges. You have
the following options:
●

Activate either SRC IN and SRC OUT or DST IN and DST OUT and change only one of
the timecodes. The other timecode is automatically adjusted. The range length
remains the same.
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●

Activate either SRC IN and DST IN or SRC OUT and DST OUT and change only one of
the timecodes. The other timecode is automatically adjusted. The range length in
the SRC and DST areas are equally modified.

●

If you want to change the beginning or end of the time range, you can change one
of the timecodes.

NOTE
The Motion Speed indicator that is available if you modify timecodes in the old and new
EDLs informs you about differing source and destination range lengths. If it displays
“2.00x”, the source range is twice the length of the destination range. This indicates that
the source material is referenced with double playback speed.

EXAMPLE
You have received an EDL, but the EDL does not match with the video. This can occur if a video
sequence is changed after the EDL was created.
If the video sequence was moved, you can, for example, activate the SRC IN and SRC OUT
timecodes and change these accordingly.

Deleting EDL Entries
You can delete EDL entries from the added or generated EDLs.
PROCEDURE
1.

Select one or multiple entries in the EDL.

2.

Right-click the entries.

3.

Select Delete.

RESULT
The entries are deleted from the EDL.

Generating Change EDLs
You can generate a Change EDL from an old and a new EDL.
PREREQUISITE
You have added an old and a new EDL file to the ReConform dialog.
PROCEDURE
●

Click Generate.

RESULT
The Change EDL is added to the ReConform dialog. It displays the changes between the old and
new EDL files.

Saving Change EDLs
You can save a Change EDL that you generated with the ReConform function.
PROCEDURE
1.

Click Save Change EDL

.
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2.

Enter the name of the file.

3.

Click Save.

Healing Entries in the Change EDL
Healing entries helps reducing the complexity of a Change EDL by combining two or more
consecutive entries to become one entry.
Healing is useful if the comparison of old and new EDL results in a Change EDL in which multiple
consecutive entries are unchanged and still in the same order.
PROCEDURE
1.

Select two or more consecutive entries in the Change EDL.

2.

Right-click within the selected entries.

3.

Select Healing and choose from the following options:
●

None
Entries are not combined.

●

Normal
Consecutive entries without gaps are combined to a single entry.

●

Gaps without Inserts
Consecutive entries with gaps are combined to a single entry if the gap length is
identical in source and destination file and there is no New EDL entry that inserts a
new video clip into this gap.

●

Gaps with Inserts
Even if a New EDL entry inserts a new video clip into a gap, consecutive entries with
gaps are combined to a single entry if the gap length is identical in source and
destination file.

NOTE
You can automate the healing process by selecting one of the Heal Processing options in
the options dialog. You can always return to uncombined entries by selecting None.

RESULT
The selected consecutive entries become one entry.
RELATED LINKS
ReConform Settings on page 1111

Extending Entries in the Change EDL
Extending entries helps closing gaps that are caused by new inserts.
Some inserts from new EDLs can replace existing events in the previous EDLs. This deletes
already existing audio for the previous events and creates gaps. You can extend events before or
after a gap to use their audio within the gap.
PROCEDURE
1.

Right-click an entry in the Change EDL.

2.

Select Extend Event and choose one of the following options:
●

Until Previous Event
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Extends the entry to the previous event.
●

Until Next Event
Extends the entry to the following event.

●

Until Previous and Next Event
Extends the entry to the previous and the following event.

RESULT
The source and destination ranges of the entry are extended.
EXAMPLE
If you have a series of film scenes and in one shot, the director chose to use the picture of
camera 2 instead of camera 1, this picture change is detected by the ReConform function. In the
Change EDL, the original audio for the new picture shot is discarded and replaced by an empty
area. If you want to keep the audio that was used right before the shot, you can extend the
length of an existing Change EDL entry to a neighboring gap.

ReConform Settings
ReConform provides settings that allow you to configure the ReConform function and to
automate several functions.
To open the ReConform Settings pane, at the bottom of the ReConform dialog, click Open
ReConform Settings .
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EDL Loading Options
B-Roll Renaming
If this option is activated, the roll names of all entries in a loaded EDL are searched
for a trailing “B”. If a trailing “B” is found in any of the entry names and if the EDL
contains an entry with the same name that has no trailing “B”, the B is deleted from
the roll name.

Change EDL Generating Options
Match Name
Allows you to decide if the roll name or the clip name of an event is used for creating
the Change EDL. Use the clip name if the roll name is not unique due to the data
format, for example.
Heal Processing
Allows you to combine specific entries in the Change EDL to reduce complexity.
●

None
Entries are not combined.

●

Normal
Consecutive entries without gaps are combined to a single entry.

●

Gaps without Inserts
Consecutive entries with gaps are combined to a single entry if the gap length
is identical in source and destination file and there is no New EDL entry that
inserts a new video clip into this gap.

●

Gaps with Inserts
Even if a New EDL entry inserts a new video clip into a gap, consecutive entries
with gaps are combined to a single entry if the gap length is identical in source
and destination file.

VFX Handling
Allows you to specify and activate up to 3 naming patterns for recognizing VFX (visual
effects) shots in the loaded EDL. VFX shots are film sequences with a multitude of
different versions that are denoted in the clip or roll name of a corresponding EDL
entry according to a custom naming scheme. As VFX shot changes usually have no
impact on the audio, naming patterns ensure that simple version changes are not
treated as inserts.
Each pattern definition must contain a version number that may be extended by a
prefix and a suffix, for example, “VFX_01_V03.mpg”, where “VFX_01_V” is the prefix,
“03” the version number, and “.mpg” the suffix.
If naming patterns are activated, Old EDL, New EDL, and Change EDL show the
recognized VFX shots in a different color.

Processing Options
You can use the following options to specify what the ReConform function must take into
account. For every marker setting, a marker track is created in the Project window.
Apply ReConform to
Allows you to process all tracks or selected tracks.
Create Virgin Territories
If this option is activated, the ReConform function automatically creates automation
gaps where required, for example, where new scenes have been inserted.
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Restrict ReConform Range
If this option is activated, the project data before and after the specified timecodes is
not changed during the ReConform process.
●

Preserve Material Before
Enter the timecode before which the project data may not be changed.

●

Preserve Material After
Enter the timecode after which the project data may not be changed.

Include Overhanging Audio Events
If this option is activated, overhanging sections of audio events are taken into
account when video clips are moved. You can specify the maximum frame length for
these overhangs.
Create Destination Markers
If this option is activated, cycle markers are created that display the position of each
Change EDL entry after the ReConform function is applied.
Create Dissolve/Wipe Markers
If this option is activated, dissolve or wipe markers are created at positions where
dissolve or wipe transitions in the source EDLs are converted into cuts in the Change
EDL file.
Create Insert Markers
If this option is activated, cycle markers are created at positions where the new EDL
inserts new video clips.
Create Automation Warning Markers
If this option is activated, markers are created at positions where automation is
affected, for example, when a jump occurs. The name of the marker contains the
name of the affected audio track.
Create Audio Snippet Markers
If this option is activated, audio snippet markers are created for small sections of
audio events that are cut off from the events. For the ReConform function to detect a
snippet, you can specify the maximum threshold in frames.
Create Overlap Markers
If this option is activated, overlap markers are created for audio events that overlap
each other after the ReConform process.
RELATED LINKS
Restricting the ReConform Range on page 1113
Including/Excluding Overhanging Audio Events on page 1114
Examples for Markers on page 1115
Markers on page 334
Virgin Territory vs. Initial Value on page 704

Restricting the ReConform Range
You can exempt project material from the ReConform process.
Usually, the ReConform function is applied to an entire Nuendo project. In this case, the used
EDLs lead to a restructuring of all material that is available. However, if the project contains more
than one episode, you may want the new EDL to restructure only the episode that contains
changes instead of the entire project. To avoid that the rest of the project data is changed or
overwritten, use the Restrict ReConform Range option in the ReConform Settings pane.
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PROCEDURE
1.

In the ReConform Settings pane, activate Restrict ReConform Range.

2.

Enter the range that you want to preserve.
●

In the Preserve Material Before field, enter the timecode before which the project
data may not be changed.

●

In the Preserve Material After field, enter the timecode after which the project
data may not be changed.

RELATED LINKS
ReConform Settings on page 1111

Including/Excluding Overhanging Audio Events
You can prevent overhanging audio events from being cut if a video clip does not have the same
length as the audio event.
If a video clip is shorter than the corresponding audio event, the ReConform process may cut off
the sections of the audio event that hang over. To avoid these cuts, you can activate the Include
Overhanging Audio Events option in the Processing Options. If you move video clips to
another position, the overhanging sections of the audio events are moved together with the
video clip.
You can specify the maximum number of overhanging frames.
EXAMPLE
In the illustration, video clip 1 is shorter than audio event 1. If you activate the Include
Overhanging Audio Events option and move the video clip to another position, the audio event
moves with the video clip. Its length remains unchanged. If the option is deactivated, the
overhanging sections in audio event 1 are cut off.

RELATED LINKS
ReConform Settings on page 1111
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Examples for Markers
The following examples provide an overview of the markers that can be created by the
ReConform process.

Dissolve/Wipe Markers

A dissolve or wipe marker is created if either the old or the new EDL contains a dissolve or wipe
transition between 2 video clips. In the illustration, such a transition is detected in video version 2
where a marker is added. In the Change EDL, this transition is converted into a cut. The
Dissolve/Wipe marker track displays the position of the cut.

Insert Markers

An insert marker is created if the new EDL inserts a new video clip. The ReConform process
inserts a cycle marker at the position of the new video clip. In the illustration, clip 3 is the new
video clip. The Insert marker track displays the position of the new video clip.
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Automation Warning Markers

Automation warning markers are created if changes in the video cut lead to strong differences in
automation curves, such as jumps. In the illustration, the automation curve in version 1 increases
gradually from clip 1 to clip 3. In version 2, clip 2 has been deleted, which breaks the automation
curve and lets it continue at a different level. The ReConform process detects this and creates an
automation warning marker at this position. The Automation Warning marker track displays the
position of the automation issue.

Audio Snippet Markers

Audio snippet markers are created if the ReConform process divides existing audio events due to
insertions in the recut video. If one of the cut pieces is a small snippet, it is marked with an audio
snippet marker. To define the length of the snippets, you can set the number of frames using the
Create Audio Snippet Markers option. In the illustration, clip 3 is inserted between clip 1 and 2
in video version 2. The audio event audio 2 is divided in 2 sections. One of these events remains
as an audio snippet connected to clip 1. An audio snippet marker is inserted at the position of the
audio snippet. The Audio Snippet marker track displays the position of the audio snippet.
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Video Preview
You can preview new and recut video material in the Video section of the ReConform dialog.
The video preview allows you to check if the ReConform process performs a correct recut of the
available video material. The video preview displays the video track in a recut version that can be
compared with the new video material. In general, these must match. If the new video material is
longer or if it contains previously unavailable material, the resulting recut video preview shows
no content. In other cases, where the previews differ, there may be an issue with the delivered
video material or with the edits in the Change EDL.
Correct video preview

Erroneous video preview

The video preview displays video frames as soon as you select an entry in the Change EDL. You
can switch to the last frame. The timecode shows the start or end times of the entry.
Technically, the new video material is copied onto a specific video track when the video preview is
activated.
If you get new video material, you can select it in the video preview settings.
RELATED LINKS
Change EDLs on page 1106
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Video Section
The Video section in the ReConform dialog displays video frames of the selected entry in the
Change EDL.

1

Open Video Preview Settings
Opens the video preview settings.

2

IN/OUT
Allows you to switch between first (IN) and last (OUT) video frame. A highlighted button
indicates which frame is active.

3

Result
Displays the first or last video frame of the recut video track including the corresponding
timecode.

4

New
Displays the first or last video frame of the delivered new video track.

Video Preview Settings
The video preview settings allow you to specify the video tracks that the ReConform function
uses for a recut.
To open the video preview settings, in the Video section, click Open Video Preview Settings
Video Track Assignment
Allows you to specify which video track contains the old and which the new video
material. If you are working on a project that contains a video track, this track is
automatically selected as the one containing the old material.
New Video Track Configuration
Allows you to select one or multiple video files from the Pool to be used as the recut
video material.
NOTE
●

If you see no files, you must add them to the Pool.

●

If you select several files, their timecodes may not overlap.

RELATED LINKS
Pool on page 586
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Selecting Material for New Video Tracks
You can select video material from the Pool to be used for the recut version.
PREREQUISITE
You have added the video files to the Pool.
PROCEDURE
1.

In the New Video Track Configuration section, activate one or multiple video files by
clicking in the Use as New Video column next to the video file names.

2.

Adjust the Start and End timecodes according to your needs.

Determining Old and New Video Tracks
You can determine which of the used video tracks contains the old and which the new material.
PROCEDURE
●

In the Video Track Assignment section, click in the Old Edit Version or New Edit Version
column next to the video track name.
The other video track is automatically selected as the other version.
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OMF Files
Open Media Framework Interchange (OMFI) is a platform-independent file format that allows
you to transfer digital media between different applications.
Nuendo can import and export OMF files.

Importing OMF Files
PROCEDURE
1.

Select File > Import > OMF.

2.

In the file dialog, select the OMF file and click Open.

3.

Optional: If a project is open, choose if you want to create a new project.
If you select No, the OMF file is imported into the current project.

4.

In the Import Options dialog, choose the tracks that you want to import and make your
settings.

5.

Click OK.

6.

Optional: If the OMF file contains video event information, choose whether you want to
create markers at the start position of the video events.
NOTE
You can use these markers as position references if you want to manually import the video
files.

RESULT
The audio events of the imported OMF file are added.
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OMF Import Options

Import
Allows you to select a track for import.
Type
Shows the media type of the track.
Track Name
Shows the track name.
Select All Tracks
Selects all tracks for import.
Import All Media Files
Imports media files that are not referenced by events.
Import Clip Gain as Automation
Imports volume automation and envelopes of the volume automation track of each
track.
Import at Timecode Position
Inserts the elements contained in the file at their original timecode positions.
This ensures that the elements are placed at their correct time positions even if
Nuendo uses a different frame rate than the file.
Import at Absolute Time
Inserts the elements contained in the file starting at the timecode position saved in
the file and keeping the relative distances between the elements.

Exporting OMF Files
PREREQUISITE
Consider setting up your project to use mono tracks and mono files. This allows compatibility
with audio applications that provide limited support for interleaved audio files.
PROCEDURE
1.

Select File > Export > OMF.
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2.

In the Export Options dialog, select the tracks that you want to include in the exported file
and make your settings.

3.

Click OK.

4.

In the file dialog, specify a name and location.

5.

Click Save.

RESULT
The OMF file is exported. It contains or references all audio files that are played in the project,
including fade and edit files.
Unused audio files that are referenced in the Pool, or any MIDI data are not contained in the file.
Video files are not included.
RELATED LINKS
Splitting Multi-Channel Audio Tracks on page 166

OMF Export Options

Export
Allows you to select a track for export.
Track Name
Shows the track name.
Select All
Selects all tracks in the project for export.
From Left to Right Locator
Allows you to export the range between the locators only.
Media Destination Path
Allows you to specify a location for the exported files. You can also click Browse.
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NOTE
You can create references to media destinations that do not exist on the system you
are working with. This allows you to prepare files for use in projects on another
system or in a network environment, for example.
Copy Media
Allows you to create copies of all the media files. By default, the copied audio files are
placed in a subdirectory in the export destination folder. To specify a different
location for the copied files, use the Media Destination Path field.
Consolidate Events
Allows you to copy only the portions of audio files that are used in the project.
The Handle Length value allows you to define a length in milliseconds to include
audio outside each event boundary for later fine-tuning. Handles allow you to adjust
fades or edit points when the project is imported in another application.
OMF 1.0 File
Allows you to select an OMF version. Select this depending on which version is
supported by the application in which you plan to import the file.
OMF 2.0 File
Allows you to select an OMF version. Select this depending on which version is
supported by the application in which you plan to import the file.
Export Media File References
Exports only media file references. This keeps the exported file small. However, the
referenced audio files must be available for the receiving application.
Export All to One File
Exports all data to one self-contained file. This could result in a large file size.
Export Clip-Based Volume (OMF 2.0 only)
Includes the volume settings that you set up with the volume handles for the events.
Use Fade Curves (OMF 2.0 only)
Includes the fades that you set up with the fade handles for the events.
Export Clip Names (OMF 2.0 only)
Includes the clip names for the events.
Export Sample Size
Allows you to set a sample size for the exported files.
Quantize Events to Frames
Moves the event positions in the exported file to exact frames. This is sometimes
necessary when exporting projects to video workstations that limit the accuracy of
edits to the frame.
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AAF Files
The Advanced Authoring Format (AAF) is a multimedia file format that allows you to exchange
digital media and metadata between different systems and applications across multiple
platforms. Metadata include fades, automation, and processing information.

Importing AAF Files
PROCEDURE
1.

Select File > Import > AAF.

2.

In the file dialog, choose the AAF file and click Open.

3.

Optional: If a project is open, select if you want to create a new project.
If you select No, the AAF file is imported into the current project.

4.

In the Import Options dialog, choose the tracks you want to import and make your
settings.

5.

Click OK.
NOTE
Depending on the size of the imported project and whether the files are embedded or
referenced, the import process may take a while.

RESULT
The audio tracks and events of the imported AAF file are added.
RELATED LINKS
AAF Import Options on page 1124

AAF Import Options

Import
Allows you to select a track for import.
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Type
Shows the media type of the track.
Track Name
Shows the track name.
Select All Tracks
Selects all tracks for import.
Import All Media Files
Imports media files that are not referenced by events.
AAF File Info
Shows information about the file.

MXF Files
Nuendo supports audio files in the MXF (Material Exchange Format) container format (OP1a for
import only, and OP-Atom).
Project data from non-linear video editing systems is often delivered as AAF files referencing MXF
audio.
On importing AAF files, MXF media from the AAF project is automatically added as audio events
to the project. However, you can also import individual MXF media (clips) independently from an
AAF file.

Importing MXF Files
PROCEDURE
1.

Select File > Import > MXF.

2.

In the file dialog, locate and select the MXF file and click Open.

3.

Optional: If a project is open, choose whether you want to create a new project.
If you select No, the MXF file is imported into the current project.

RESULT
For multichannel audio, a single multichannel track is created. Each audio track contained in the
MXF file is imported on a separate audio track. The video track from the MXF file is ignored.
AFTER COMPLETING THIS TASK
Nuendo projects reference media files inside an MXF file using relative paths. Changing the
relative location of the MXF file and the Nuendo project file (.npr) leads to lost references.
Therefore, you might want to convert the MXF files to WAV. To consolidate the media files in the
project folder, select Media > Convert Files.

Exporting AAF Files
PROCEDURE
1.

Select File > Export > AAF.

2.

In the Export Options dialog, select the tracks that you want to include in the exported file
and make your settings.

3.

Click OK.

4.

In the file dialog, specify a name and location.

5.

Click Save.
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RESULT
The AAF file is exported.
RELATED LINKS
AAF Export Options on page 1126

AAF Export Options

Export
Allows you to select a track for export.
Track Name
Shows the track name.
Select All
Selects all tracks in the project for export.
From Left to Right Locator
Allows you to export the range between the locators only.
Media Destination Path
Allows you to specify a location for the exported files. You can also click Browse.
NOTE
You can create references to media destinations that do not exist on the system you
are working with. This allows you to prepare files for use in projects on another
system or in a network environment, for example.
Copy Media
Allows you to create copies of all the media files. By default, the copied audio files are
placed in a subdirectory in the export destination folder. To specify a different
location for the copied files, use the Media Destination Path field.
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Export Muted Events with Volume -inf dB
Sets muted events to a volume -inf dB on export.
Consolidate Events
Allows you to copy only the portions of audio files that are used in the project.
The Handle Length value allows you to define a length in milliseconds to include
audio outside each event boundary for later fine-tuning. Handles allow you to adjust
fades or edit points when the project is imported in another application.
Export Media File References
Exports only media file references. This keeps the exported file small. However, the
referenced audio files must be available for the receiving application.
Export All to One File
Exports all data to one self-contained file. This could result in a large file size.
Export Sample Size
Allows you to set a sample size for the exported files.
Quantize Events to Frames
Moves the event positions in the exported file to exact frames. This is sometimes
necessary when exporting projects to video workstations that limit the accuracy of
edits to the frame.

AES31 Files
The AES31 standard is an open file interchange format, developed by the Audio Engineering
Society that allows you to transfer projects from one workstation to another, retaining time
positions of events, fades, etc.
AES31 uses the widely used Microsoft FAT32 file system with Broadcast Wave as the default audio
file format. You can transfer AES31 files to digital audio workstations that support AES31,
regardless of the type of hardware and software used.

Importing AES31 Files
PROCEDURE
1.

Select File > Import > AES31.

2.

In the file dialog, locate and select the AES31 file and click Open.

3.

Optional: If a project is open, choose if you want to create a new project.
If you select No, the AES31 file is imported into the current project.

4.

In the Import Options dialog, select the tracks that you want to import and make your
settings.

5.

Click OK.

RESULT
The audio tracks and events of the imported AES31 file are added.

Exporting AES31 Files
PROCEDURE
1.

Select File > Export > AES31.
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2.

In the Export Options dialog, select the tracks that you want to include in the exported file
and make your settings.

3.

Click OK.

4.

In the file dialog, specify a name and location.

5.

Click Save.

RESULT
All audio track data including audio file references are exported.
Real-time fades set up with the fade handles are automatically converted and saved in a fades
folder.
MixConsole settings, automation, and MIDI Tracks are not exported.
The file is saved as an XML file with the extension .adl (audio decision list). You can open it in
any text editor.

AES31 Export Options

Export
Allows you to select a track for export.
Track Name
Shows the track name.
Select All
Selects all tracks in the project for export.
From Left to Right Locator
Allows you to export the range between the locators only.
Media Destination Path
Allows you to specify a location for the exported files. You can also click Browse.
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NOTE
You can create references to media destinations that do not exist on the system you
are working with. This allows you to prepare files for use in projects on another
system or in a network environment, for example.
Copy Media
Allows you to create copies of all the media files. By default, the copied audio files are
placed in a subdirectory in the export destination folder. To specify a different
location for the copied files, use the Media Destination Path field.
Consolidate Events
Allows you to copy only the portions of audio files that are used in the project.
The Handle Length value allows you to define a length in milliseconds to include
audio outside each event boundary for later fine-tuning. Handles allow you to adjust
fades or edit points when the project is imported in another application.

OpenTL Files
OpenTL is a file exchange format originally developed for Tascam hard disk recording systems.
OpenTL facilities also exist in a variety of DAWs, making Nuendo project transfer reliable and
solid.
You can import/export an OpenTL file between Nuendo and Pro Tools, for example. The resulting
project contains all audio files, edits, and track names made in the Tascam device or DAW, with all
events positioned sample-accurately on the timeline.
The following is a basic OpenTL specification description:
●

Maximum number of mono tracks: 999

●

Supported sample rates (Hz): 44056, 44100, 44144, 47952, 48000, 48048, 42294, 42336,
45938, 45983, 46034, 46080, 50000, 50050, 88200, 96000

●

Bit depth: 16 bit, 24 bit

●

Audio file types: BWF (Broadcast Wave format), WAVE (Standard Wave), SDII (Sound
Designer II) (macOS only)

●

Volume formats: FAT32, NTFS, HFS+

●

Automation support: Clip-based volume, breakpoint volume and mute

●

Fade support: Fade-in, fade-out, and crossfade

●

Frame rates (fps): 24/24, 23.976/24, 24.975/25, 25/25, 29.97/DF, 29.97/NDF, 30/DF, 30/NDF

OpenTL Implementation in Tascam® MMR-8, MMP-16 and MX-2424
All 3 Tascam devices work with either 2 types of disk volume formats: FAT32 (Windows standard)
or HFS+ (macOS standard). For proper Nuendo compatibility it is necessary that all MMR-8/
MMP-16 run OS v5.03 and MX-2424 v3.12. Some crucial OpenTL updates only appear in these
machine operating systems, and only this setup can assure reliable Nuendo exchange.
Audio file formats are volume type dependent: for FAT32 this is BWF (*.wav) and for HFS+ this is
SDII. OpenTL files can only be transferred within file systems of the same format, which means
that it is not possible to import an OpenTL project exported from macOS (HFS+) into a Windows
system (FAT32) or vice versa, unless you use a conversion utility, such as MM-EDL.
Nuendo for Windows supports OpenTL FAT32/BWF. Nuendo for macOS supports OpenTL HFS+/
SDII as well as FAT32/BWF. MMR-8, MMP-16, and MX-2424 support OpenTL projects sourcing or
targeting Nuendo PC with up to 999 mono tracks.
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Importing OpenTL FIles
PROCEDURE
1.

Select File > Import > OpenTL.

2.

In the file dialog, select the OpenTL file and click Open.

3.

Optional: If a project is open, choose if you want to create a new project.
If you select No, the OpenTL file is imported into the current project.

RESULT
The audio files and their associated edits are imported.
AFTER COMPLETING THIS TASK
Save the file as a Nuendo project, and prepare an archive.
RELATED LINKS
Preparing Archives on page 96

Exporting OpenTL Files
PREREQUISITE
All audio files in the Pool and all tracks in the Project window are in mono and in 16 bit or 24 bit.
All referenced audio files are located on the drive to which you want to export the OpenTL file.
NOTE
When exporting OpenTL files on PC, do not change the DF or NDF frame notation after you have
set the project start time. All audio files in the Pool must have the same sample rate, bit depth,
and be set to Broadcast Wave file type.

PROCEDURE
1.

Select File > Export > OpenTL.

2.

In the Export Options dialog, select the tracks that you want to include in the exported file
and make your settings.

3.

Click OK.

4.

In the file dialog, specify a name and location.

5.

Click Save.

RESULT
The exported file contains all audio track data, including file references, clip-based volume
automation, fade-in, fade-out, and crossfades.
Any real-time mixing, EQ, effects settings, breakpoint automation tracks, or MIDI tracks made in
Nuendo are not included in the exported file.
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OpenTL Export Options

Export
Allows you to select a track for export.
Track Name
Shows the track name.
Select All
Selects all tracks in the project for export.
From Left to Right Locator
Allows you to export the range between the locators only.
Media Destination Path
Allows you to specify a location for the exported files. You can also click Browse.
NOTE
You can create references to media destinations that do not exist on the system you
are working with. This allows you to prepare files for use in projects on another
system or in a network environment, for example.
Copy Media
Allows you to create copies of all the media files. By default, the copied audio files are
placed in a subdirectory in the export destination folder. To specify a different
location for the copied files, use the Media Destination Path field.
Consolidate Events
Allows you to copy only the portions of audio files that are used in the project.
The Handle Length value allows you to define a length in milliseconds to include
audio outside each event boundary for later fine-tuning. Handles allow you to adjust
fades or edit points when the project is imported in another application.
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Introduction
ReWire is a special protocol for streaming audio between two computer applications.
Developed by Propellerhead Software and Steinberg, ReWire provides the following possibilities
and features:
●

Realtime streaming of up to 256 separate audio channels, at full bandwidth, from the
synthesizer application into the mixer application.
In this case, the mixer application is of course Nuendo. An example of a synthesizer
application is Propellerhead Software’s Reason.

●

Automatic, sample accurate synchronization between the audio in the two programs.

●

The possibility to have the two programs share one audio card and take advantage of
multiple outputs on that card.

●

Linked transport controls that allow you to play, rewind, etc., either from Nuendo or from
the synthesizer application (provided it has some kind of transport functionality).

●

Automatic audio mixing functions of separate channels as required.
In the case of Reason, for example, this allows you to have separate channels for the
different devices.

●

Additionally, ReWire offers the possibility to route MIDI tracks in Nuendo to the other
application, for full MIDI control.
For each ReWire compatible device, a number of extra MIDI outputs will be made available
in Nuendo. In the case of Reason, this allows you to route different MIDI tracks in Nuendo
to different devices in Reason, with Nuendo serving as the main MIDI sequencer.

●

The overall load on your system is much reduced, compared to when using the programs
together in the conventional way.

Enabling ReWire Applications
To use the available ReWire applications on your computer in your project, you must enable
them in the ReWire Setup dialog.
IMPORTANT
●

Enabling ReWire applications may have an impact on performance and stability of Nuendo,
even if the ReWire connection is not used. We therefore recommend to enable only ReWire
applications that you want to use in your project.

●

Disabling a ReWire application, removes the corresponding ReWire channels from your
project. All associated automation or parameter settings are lost.
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PROCEDURE
1.

Select Studio > ReWire > ReWire Setup.

2.

Activate the ReWire applications that you want to use.

3.

Click Apply.

RESULT
The enabled ReWire applications become available in the ReWire submenu.
AFTER COMPLETING THIS TASK
You can activate ReWire channels in the ReWire panel of the application.
RELATED LINKS
Activating ReWire channels on page 1134

Launching and quitting
When using ReWire, the order in which you launch and quit the two programs is very important.

Launching for normal use with ReWire
PROCEDURE
1.

First launch Nuendo.

2.

Enable one or several ReWire channels in the ReWire Device dialog for the other
application.

3.

Launch the other application.
It may take slightly longer for the application to start when you are using ReWire.

RELATED LINKS
Activating ReWire channels on page 1134

Quitting a ReWire session
When you are finished, you also need to quit the applications in a special order.
PROCEDURE
1.

First quit the synthesizer application.

2.

Then quit Nuendo.

Launching both programs without using ReWire
We cannot think of any scenario, in which you would need to run Nuendo and the synthesizer
application simultaneously on the same computer, without using ReWire, but you can.
PROCEDURE
1.

First launch the synthesizer application.

2.

Then launch Nuendo.
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NOTE
Please note that the two programs now compete for system resources such as audio
cards, just as when running with other, non-ReWire audio applications.

Activating ReWire channels
ReWire supports streaming of up to 256 separate audio channels. The exact number of available
ReWire channels depends on the synthesizer application. The ReWire device panels in Nuendo
allow you to activate the channels you that want to use.
PREREQUISITE
You have enabled the ReWire application that you want to use in the ReWire Setup dialog.
PROCEDURE
1.

Select Studio > ReWire, and select the ReWire application that you want to use.
The corresponding ReWire panel appears. This consists of a number of rows, one for each
available ReWire channel.

2.

Click the power buttons to the left to activate/deactivate channels.
The buttons light up to indicate activated channels.

3.

Optional: Double-click the labels in the right column, and type in another name.
These labels are used in your project to identify the ReWire channels.

RESULT
The activated ReWire channels are added to the project.
NOTE
●

The more ReWire channels you activate, the more processing power is required.

●

For information about exactly what signal is carried on each channel, refer to the
documentation of the synthesizer application.

IMPORTANT
Deactivating ReWire channels in the ReWire panel, removes the channels from your project. All
associated automation or parameter settings are lost.

RELATED LINKS
Enabling ReWire Applications on page 1132

Using the transport and tempo controls
IMPORTANT
This is only relevant if the synthesizer application has some sort of built-in sequencer or similar.
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Basic transport controls
When you run ReWire, the transports in the two programs are completely linked. It does not
matter in which program you play, stop, fast forward or rewind. However, recording (if
applicable) is still completely separate in the two applications.

Loop settings
If there is a loop or cycle facility in the synthesizer application, that loop will be completely linked
to the cycle in Nuendo. This means that you can move the start and end point for the loop or turn
the loop on or off in either program, and this will be reflected in the other.

Tempo settings
As far as tempo goes, Nuendo is always the master. This means that both programs will run in
the tempo set in Nuendo.
However, if you are not using the tempo track in Nuendo, you can adjust the tempo in either
program, and this will immediately be reflected in the other.
IMPORTANT
If you are using the tempo track in Nuendo and the Tempo button is activated on the Transport
panel, you should not adjust the tempo in the synthesizer application, since a tempo request
from ReWire will automatically deactivate the tempo track in Nuendo.

How the ReWire channels are handled
When you activate ReWire channels in the ReWire device panels, they will become available as
channels in the MixConsole.
The ReWire channels have the following properties:
●

ReWire channels may be any combination of mono and stereo, depending on the
synthesizer application.

●

ReWire channels have the same functionality as regular audio channels.
This means you can set volume and pan, add EQ, insert effects and sends, and route the
channel outputs to groups or busses. However, ReWire channels have no monitor buttons.

●

All channel settings can be automated using the Read/Write buttons.
When you write automation, channel automation tracks will automatically appear in the
Project window. This allows you to view and edit the automation graphically, just as with
VST instrument channels, etc.

●

You can mix down the audio from ReWire channels to a file on your hard disk with the
Export Audio Mixdown function.
You can export the output bus to which you have routed the ReWire channels. You can also
export individual ReWire channels directly – “rendering” each ReWire channel to a separate
audio file.

RELATED LINKS
Mixing Down to Audio Files on page 1008

Routing MIDI via ReWire
When using Nuendo with a ReWire-compatible application, additional MIDI outputs will
automatically appear on the MIDI Output pop-up menus for MIDI tracks. This allows you to play
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the synthesizer application via MIDI from Nuendo, using it as one or several separate MIDI
sound sources.

The MIDI outputs for a Reason song. Here, each output goes directly to a device in the Reason
rack.
●

The number and configuration of MIDI outputs depends on the synthesizer application.

Considerations and limitations
Sample rates
Synthesizer applications may be limited to audio playback in certain sample rates. If Nuendo is
set to a sample rate other than those, the synthesizer application will play back at the wrong
pitch. Consult the documentation of the synthesizer application for details.

ASIO drivers
ReWire works well with ASIO drivers. By using the Nuendo bus system you can route sounds
from the synthesizer application to various outputs on an ASIO compatible audio card.
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Key commands are assigned to most of main menus and functions in Nuendo. They are stored as
global Nuendo preferences that are used for all your projects.
You can view and add key commands in the Key Commands dialog. Key command assignments
are also shown in the tooltips.

Tooltips that show an exclamation mark at the end have no key command assigned yet.
In addition, you can save complete or partial key commands settings as a “key commands file”,
which is stored separately and can be imported into any project. This way you can quickly and
easily recall customized settings, when moving projects between different computers, for
example. The settings are saved in an XML file on the hard disk.
RELATED LINKS
Saving Complete Key Commands Settings as Presets on page 1139

Adding Key Commands
You can add key commands in the Key Commands dialog.
PROCEDURE
1.

Select File > Key Commands.

2.

Do one of the following:
●

In the Commands list, click the plus sign to open a category folder, and select the
function to which you want to assign a key command.

●

In the search field, enter the name of the function to which you want to assign a key
command.

Assigned key commands are shown in the Keys column as well as in the Keys section to
the right.

3.

Click the Type in Key field and press the keys you want to use as a key command.
You can press individual keys or a combination of one or several modifier keys (Alt, Ctrl/
Cmd, Shift) plus any key.

4.

Click Assign.
The key command is shown in the Keys section.

5.

Click OK.
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NOTE
You can set up several different key commands for the same function. Adding a key
command to a function that already has another key command will not replace the key
command previously defined for the function.

Searching for Key Commands
You can search for key commands. This is useful, if you want to know which key command is
assigned to a certain function in Nuendo.
PROCEDURE
1.

Select File > Key Commands.

2.

In the search field, enter the name of the function for which you want to know the key
command.

3.

Click Start/Continue Search.

RESULT
The first matching command is selected and displayed in the Commands list. The Keys column
and the Keys list show the assigned key commands, if any.

Removing Key Commands
PROCEDURE
1.

Select File > Key Commands.

2.

In the Commands list, click the plus sign to open a category folder, and select the function
for which you want to remove a key command.

3.

Select the key command in the Keys section and click the Delete.

4.

Click Remove to remove the selected key command.

5.

Click OK.

Setting Up Macros
You can set up a combination of several functions or commands to be performed in one go as a
macro.
PROCEDURE
1.

Select File > Key Commands.

2.

Click Show Macros.

3.

Click New Macro.

4.

Enter a name for the macro and press Return to confirm it.

5.

In the upper half of the dialog, select the first command you want to include in the macro.

6.

Click Add Command.

7.

Select the next command and click Add Command.
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NOTE
Commands are added after the selected command in the list. This allows you to specify the
order of commands of a macro.
8.

Click OK.

RESULT
All macros are available in the Macros submenu of the Edit menu.

To remove a command from the macro, select it in the Macros list and click Delete.
Similarly, to remove an entire macro, select it in the Macros list and click Delete.
AFTER COMPLETING THIS TASK
You can also assign key commands to a macro. Macros are shown in the Commands list in the
Macros category folder.

Saving Complete Key Commands Settings as Presets
You can save key command settings as presets.
PREREQUISITE
You have set up the key commands to your liking.
PROCEDURE
1.

In the Key Commands dialog, deactivate Store Selected Items Only.

2.

In the Presets section, click Save.

3.

Enter a name for the preset an click OK.

RESULT
Your key commands settings are now available as a preset on the Presets pop-up menu.

Saving Partial Key Commands Settings
You can save partial key command settings as presets.
PREREQUISITE
You have set up the key commands to your liking.
PROCEDURE
1.

In the Key Commands dialog, activate Store Selected Items Only.

2.

Click in the Store column for the individual key commands items or for category folders
you want to save.
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3.

In the Presets section, click Save.

4.

Enter a name for the preset an click OK.

RESULT
Your key commands settings are now available as a preset on the Presets pop-up menu.
NOTE
When you apply a saved partial preset you only change these specific settings. All other key
commands settings remain unchanged.

Loading Key Command Presets
You can load key commands presets.
PROCEDURE
●

In the Presets section, open the pop-up menu and select the preset.

RESULT
The key command preset replaces the current key command settings and macros.

Importing Key Command Settings
You can import key commands settings that you saved with an earlier program version.
PROCEDURE
1.

Select File > Key Commands.

2.

In the Presets section, click Import Key Command File.

3.

In the file dialog, select the file that you want to import.
You can import key commands files with the file extension .key or macro commands files
with the file extension .mac.

4.

Click Open.

RESULT
The file is imported.
AFTER COMPLETING THIS TASK
You can save the imported file as a preset.
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Resetting Key Commands
PROCEDURE
1.

Select File > Key Commands.

2.

Do one of the following:
●

In the Commands list, select the key command that you want to restore and click
Reset.

●

Click Reset All.

RESULT
The key commands are reset.
IMPORTANT
Any changes made to the default key commands are lost. If you want to be able to revert to these
settings again, make sure to save them first.

Key Sets
Nuendo comes with default key sets. Additionally, you can set up and save alternative key sets.
The following key sets are available by default:
●

Markers is the default set of key commands.

●

Shuttle contains key commands settings for all Shuttle controls of the Transport panel.

You can switch between the different key commands settings. You can edit and save them as
additional key sets for your specific needs.

Saving Alternative Key Sets
PROCEDURE
1.

Select File > Key Commands.

2.

Set up the key commands and macros the way you want them.

3.

Do one of the following:
●

Activate Store Selected Items Only to save selected settings only.

●

Deactivate Store Selected Items Only to save the complete settings.

4.

In the Alternative Key Sets section, click Store Alternative Set.

5.

Enter a name for the key set.

6.

Click OK.
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RESULT
The saved key set appears in the list of alternative key sets.

Editing Alternative Key Sets
PROCEDURE
1.

In the Alternative Key Sets section, select the key set that you want to edit.

2.

Click Load Alternative Set to load and activate the key set.

3.

Make the desired changes.

4.

Click Store Alternative Set.

RESULT
The key set is saved with the updated settings.

Removing Alternative Key Sets
PROCEDURE
1.

In the Alternative Key Sets section, select the key set that you want to remove.

2.

Click Delete Alternative Set.

3.

In the dialog that opens, click Remove.

RESULT
The key set is removed.

Switching Between Alternative Key Sets
You can switch between different key sets in the Project window.
PROCEDURE
●

In the Project window, press Ctrl/Cmd-F5.
This is the default key command for Toggle Alternate Key Commands that is located in
the File subfolder in the Key Commands dialog.

RESULT
The next available alternative key set is activated and its name is briefly shown on top of the
Project window.

RELATED LINKS
Adding Key Commands on page 1137

The Default Key Commands
The default key commands are arranged in categories.
NOTE
When the On-Screen Keyboard is displayed, the usual key commands are blocked because they
are reserved for the On-Screen Keyboard. The only exceptions are: Ctrl/Cmd-S (Save), Num *
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(Start/Stop Record), Space (Start/Stop Playback), Num 1(Jump to left locator), Delete or
Backspace (Delete), Num / (Cycle on/off), F2 (Show/Hide Transport panel), and Alt-K (Show/Hide
On-Screen Keyboard).
●

Note that it is possible to switch key commands for menu items and other functions on
and off.

RELATED LINKS
Disabling Key Commands on page 1155

Audio Category
Option

Key command

Adjust Fades to Range

A

Auto-Grid

Shift-Q

Crossfade

X

Automation Category
Option

Key command

Open Panel

F6

Redo Pass

Ctrl/Cmd-Alt-Shift-Z

Read Automation for All Tracks On/Off

Alt-R

Write Automation for All Tracks On/Off

Alt-W

Undo Pass

Ctrl/Cmd-Alt-Z

Chords Category
Option

Key command

Chord Pads

Ctrl/Cmd-Shift-C

Devices (Studio) Category
Option

Key command

Audio Connections

F4

Audio Performance

F12
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Option

Key command

MixConsole

F3

MixConsole in Project Window

Alt-F3

On-Screen Keyboard

Alt-K

Video Player

F8

VST Instruments

F11

Direct Offline Processing Category
Option

Key command

Direct Offline Processing

F7

Edit Category
Option

Key command

Activate/Deactivate Focused Object

Alt-A

Auto-Scroll On/Off

F

Copy

Ctrl/Cmd-C

Cut

Ctrl/Cmd-X

Cut Time

Ctrl/Cmd-Shift-X

Delete

Delete or Backspace

Delete Time

Shift-Backspace

Duplicate

Ctrl/Cmd-D

Expand/Reduce

Alt-E

Find Track/Channel

Ctrl/Cmd-F

Group

Ctrl/Cmd-G

Group Editing on Selected Tracks On/Off

K

Insert Silence

Ctrl/Cmd-Shift-E
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Option

Key command

Invert

Alt-F

Left Selection Side to Cursor

E

Lock

Ctrl/Cmd-Shift-L

Move to Cursor

Ctrl/Cmd-L

Move to Front (Uncover)

U

Mute

M

Mute Events

Shift-M

Mute/Unmute Objects

Alt-M

Open

Ctrl/Cmd-E

Paste

Ctrl/Cmd-V

Paste at Origin

Alt-V

Paste Relative to Cursor

Shift-V

Paste Time

Ctrl/Cmd-Shift-V

Primary Parameter: Decrease

Ctrl/Cmd-Shift-Down Arrow

Primary Parameter: Increase

Ctrl/Cmd-Shift-Up Arrow

Record Enable

R

Redo

Ctrl/Cmd-Shift-Z

Repeat

Ctrl/Cmd-K

Right Selection Side to Cursor

D

Secondary Parameter: Decrease

Ctrl/Cmd-Shift-Left Arrow

Secondary Parameter: Increase

Ctrl/Cmd-Shift-Right Arrow

Select All

Ctrl/Cmd-A

Select None

Ctrl/Cmd-Shift-A

Snap On/Off

J
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Option

Key command

Solo

S

Split At Cursor

Alt-X

Split Range

Shift-X

Stationary Cursor

Alt-C

Undo

Ctrl/Cmd-Z

Ungroup

Ctrl/Cmd-U

Unlock

Ctrl/Cmd-Shift-U

Unmute Events

Shift-U

Write

W

Editors Category
Option

Key command

Edit In-Place

Ctrl/Cmd-Shift-I

Open Score Editor

Ctrl/Cmd-R

Open/Close Editor

Return

File Category
Option

Key command

Close

Ctrl/Cmd-W

New

Ctrl/Cmd-N

Open

Ctrl/Cmd-O

Quit

Ctrl/Cmd-Q

Save

Ctrl/Cmd-S

Save As

Ctrl/Cmd-Shift-S

Save New Version

Ctrl/Cmd-Alt-S
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Option

Key command

Toggle Alternate Key Commands

# or Ctrl/Cmd-F5

Media Category
Option

Key command

Open MediaBay

F5

Open/Close Attribute Inspector

Ctrl-Alt-Num6

Open/Close Favorites

Ctrl-Alt-Num8

Open/Close File Browser

Ctrl-Alt-Num4

Open/Close Filters

Ctrl-Alt-Num5

Open/Close Previewer

Ctrl-Alt-Num2

Preview Cycle On/Off

Shift-Num /

Preview Start

Shift-Enter

Preview Stop

Shift-Num 0

Search MediaBay

Shift-F5

MIDI Category
Option

Key command

Show/Hide Controller Lanes

Alt-L

MixConsole History Category
Option

Key command

Undo MixConsole Step

Alt-Z

Redo MixConsole Step

Alt-Shift-Z
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Navigate Category
Option

Key command

Add Down:

Shift-Down Arrow

Expand/Undo selection in the Project window
to the bottom/ Move selected event in the Key
Editor down 1 octave
Add Left:

Shift-Left Arrow

Expand/Undo selection in the Project
window/Key Editor to the left
Add Right:

Shift-Right Arrow

Expand/Undo selection in the Project
window/Key Editor to the right
Shift-Up Arrow

Add Up:
Expand/Undo selection in the Project window
to the top/Move selected event in the Key
Editor up one octave
Bottom:

End

Select bottom track in the track list
Down Arrow

Down:
Select next in the Project window/Move
selected event in the Key Editor one semitone
down
Left:

Left Arrow

Select previous in the Project window/Key
Editor
Right:

Right Arrow

Select next in the Project window/Key Editor
Toggle Selection

Ctrl/Cmd-Space

Top:

Home

Select top track in the track list
Up Arrow

Up:
Select next in the Project window/ Move
selected event in the Key Editor one semitone
up
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Nudge Category
Option

Key command

End Left

Alt-Shift-Left Arrow

End Right

Alt-Shift-Right Arrow

Left

Ctrl/Cmd-Right Arrow

Right

Ctrl/Cmd-Right Arrow

Start Left

Alt-Left Arrow

Start Right

Alt-Right Arrow

Project Category
Option

Key command

Open Browser

Ctrl/Cmd-B

Open Markers

Ctrl/Cmd-M

Open Pool

Ctrl/Cmd-P

Open Tempo Track

Ctrl/Cmd-T

Remove Selected Tracks

Shift-Delete

Setup

Shift-S

Quantize Category
Option

Key command

Quantize

Q

Set Insert Length Category
Option

Key command

1/1

Alt-1

1/2

Alt-2

1/4

Alt-3
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Option

Key command

1/8

Alt-4

1/16

Alt-5

1/32

Alt-6

1/64

Alt-7

1/128

Alt-8

Toggle Dotted

Alt-.

Toggle Triplet

Alt-,

Tool Category
Option

Key command

Draw Tool

8

Drumstick Tool

0

Erase Tool

5

Glue Tool

4

Mute Tool

7

Next Tool

F10

Play Tool

9

Previous Tool

F9

Range Tool

2

Select Tool

1

Split Tool

3

Zoom Tool

6
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TrackVersions Category
Option

Key command

Duplicate Version

Ctrl/Cmd-Shift-D

New Version

Ctrl/Cmd-Shift-N

Next Version

Ctrl/Cmd-Shift-H

Previous Version

Ctrl/Cmd-Shift-G

Transport Category
Option

Key command

Activate Metronome

C

Activate Punch In

I

Activate Punch Out

O

Cycle

Num /

Enter Left Locator

Shift-L

Enter Project Cursor Position

Shift-P

Enter Punch In Position

Shift-I

Enter Punch Out Position

Shift-O

Enter Right Locator

Shift-R

Enter Tempo

Shift-T

Enter Time Signature

Shift-C

Exchange Time Formats

.

Fast Forward

Shift-Num +

Fast Rewind

Shift-Num -

Forward

Num +

Go to Left Locator

Num 1

Go to Project Start

Num . or Num , or Num ;
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Option

Key command

Go to Right Locator

Num 2

Insert Marker (Windows only)

Insert

Locate Next Event

N

Locate Next Hitpoint

Alt-N

Locate Next Marker

Shift-N

Locate Previous Event

B

Locate Previous Hitpoint

Alt-B

Locate Previous Marker

Shift-B

Locate Selection Start

L

Loop Selection

Alt-P

Nudge Cursor Left

Ctrl/Cmd-Num -

Nudge Cursor Right

Ctrl/Cmd-Num +

Panel (Transport panel)

F2

Play Selection Range

Alt-Space

Recall Cycle Marker 1 to 9

Shift-Num 1 to Num 9

Record

Num *

Retrospective MIDI Record

Shift-Num *

Rewind

Num -

Set Left Locator to Project Cursor Position

Ctrl/Cmd-Num 1

Set Locators to Selection Range

P

Set Marker 1

Ctrl/Cmd-1

Set Marker 2

Ctrl/Cmd-2

Set Marker 3 to 9

Ctrl/Cmd-Num 3 to 9 or Ctrl/Cmd- 3 to 9

Set Right Locator to Project Cursor Position

Ctrl/Cmd-Num 2
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Option

Key command

Start

Enter

Start/Stop

Space

Stop

Num 0

To Marker 1

Shift-1

To Marker 2

Shift-2

To Marker 3 to 9

Num 3 to 9 or Shift-3 to 9

Use External Synchronization

Alt-Shift-T

Use Tempo Track

T

Window Zones Category
Option

Key command

Show/Hide Left Zone

Ctrl/Cmd-Alt-L; Alt-I

Show/Hide Right Zone

Ctrl/Cmd-Alt-R

Show/Hide Upper Zone

Ctrl/Cmd-Alt-U

Show/Hide Lower Zone

Ctrl/Cmd-Alt-E; Ctrl/Cmd-Alt-B

Show/Hide Transport Zone

Ctrl/Cmd-Alt-T

Show Previous Tab

Ctrl/Cmd-Alt-Left Arrow

Show Next Tab

Ctrl/Cmd-Alt-Right Arrow

Show Previous Page

Ctrl/Cmd-Alt-Up Arrow; Page Up

Show Next Page

Ctrl/Cmd-Alt-Down Arrow; Page Down

Show/Hide Info Line

Ctrl/Cmd-I

Show/Hide Overview

Alt-O
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Windows Category
Option

Key command

Inline: Key Commands

Shift-F4

Inline: Settings

Shift-F3

Inline: View Layout

Shift-F2

Workspaces Category
Option

Key command

New

Ctrl/Cmd-Num 0

No Workspace

Alt-Num 0

Update Workspace

Alt-U

Workspace 1-9

Alt-Num 1-9

Workspace X

Ctrl/Cmd-Alt-Num 0

Zoom Category
Option

Key command

Zoom Full

Shift-F

Zoom In

H

Zoom In Tracks

Ctrl/Cmd-Down Arrow

Zoom In Vertically

Shift-H

Zoom Out

G

Zoom Out Tracks

Ctrl/Cmd-Up Arrow

Zoom Out Vertically

Shift-G

Zoom to Event

Shift-E

Zoom to Selection

Alt-S

Zoom Tracks Exclusive

Ctrl/Cmd-Alt-Down Arrow
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Setting Up Tool Modifier Keys
You can set up tool modifier keys that allow you to get an alternate function when using a tool.
PROCEDURE
1.

In the Preferences dialog, select Editing > Tool Modifiers.

2.

Select an option in the Categories list, and locate the action for which you want to edit the
modifier key.

3.

In the Action list, select the action.

4.

Hold down the desired modifier keys and click Assign.
NOTE
If the modifier keys you pressed are already assigned to another tool, you will be asked
whether you want to overwrite them. If you do, this will leave the other tool without any
modifier keys assigned.

5.

Click OK.

RESULT
The modifier keys for the action are replaced.

Disabling Key Commands
You can disable key commands.
PROCEDURE
1.

In the Preferences dialog, select the Configuration page.

2.

Navigate to the item for which you want to disable the assigned key command, and select
it.

3.

Click the Command column beside the item to set the status to Off.
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4.

Click OK.

RESULT
Any key command assigned to that menu item or function is now disabled.
NOTE
If you disable an entire subfolder, all the items or functions it contains are automatically
disabled. If this is not what you want, you can reset separate items in the subfolder.
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In Nuendo you can organize windows and dialogs in workspaces, set up the appearance of
specific elements, configure the main menu items, customize colors, and save program settings
as profiles.
RELATED LINKS
Workspaces on page 1157
Using the Setup Options on page 1161
Configuring the Main Menu Items on page 1162
Customizing the Meter Colors on page 1164
Customizing the User Interface Colors on page 1165
Coloring Tracks, Parts, or Events Manually on page 1166
Profiles on page 1170

Workspaces
Workspaces in Nuendo allow you to organize windows and specific dialogs for your common
work routines.
A workspace saves the size, position, and layout or setting of important windows and dialogs,
such as the Project window, MixConsole, or Transport panel. You can define several
workspaces. This allows you to quickly switch between different working modes, either through
the Workspaces menu or by using key commands.
You can define different workspace types that are either available for all projects on your
computer or specific for one project. However, when you open a project, its last saved view is
opened by default. A view is the window layout and setting that you defined for your project. The
last saved view can either be a workspace view or a view that you saved without having any
workspace selected. When you open an external project, the last used view on your computer is
used by default.
The Workspaces Organizer and the Workspaces menu allow you to create and modify
workspaces.
NOTE
●

You can also work without workspaces. In this case, the last used view of the former
project will be used when you create a new project.

●

In the Preferences dialog (General page), you can select which view is used when you
open a project.
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Workspace Types
You can create different workspace types.
Global workspace
Allows you to save a specific layout of dialogs and windows for all projects on your
computer. Global workspaces are indicated by the letter G on your Workspaces
menu.
Project workspace
Allows you to save a specific layout of dialogs and windows that is saved with your
current project. This allows you to open your project layout on other computers.
Project workspaces are indicated by the letter P on your Workspaces menu.

Workspace Templates
Nuendo provides sample templates that you can use as a starting point for your own
workspaces.
The templates are made for screens with a resolution of 1280x800 px (minimal) or for screens
with a resolution of 1920x1080 px (HD). You can change these templates according to your
needs.
IMPORTANT
●

Deleting and overwriting templates cannot be undone.

●

If you have already used global workspaces in earlier Nuendo versions, the sample
templates are not installed.

The following workspace templates are provided on the Workspaces menu:
Project (minimal)
Displays the Project window with minimal resolution.
Project + MixConsole (minimal)
Displays the Project window and MixConsole with minimal resolution.
Project (HD)
Displays the Project window with HD resolution.
Project + MixConsole + Channel Settings (HD)
Displays the Project window, MixConsole, and Channel Settings window with HD
resolution.
NOTE
To see the Channel Settings window, you must select an audio, MIDI, instrument, FX
channel, or group channel track before you select the template.
Project + MixConsole + Racks (HD)
Displays the Project window, MixConsole, and Racks with HD resolution.

Workspaces for External Projects
You can determine the view of external projects when you open them in Nuendo.
When you open external projects, which are projects that have been created on other computers,
the window and dialog settings that you last used on your computer are applied by default. This
can either be the last used view that was saved on your computer or one of your specified global
workspaces.
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If you want to open the original layout setting of a project, you have the following options:
●

Select the project’s original layout from the project workspaces on the Workspaces menu
or in the Workspace Organizer.

●

In the Preferences dialog (General page), select Never from the Open Projects in Last
Used View menu. This opens all external projects using their original layout. However, this
may lead to a modification of your custom layout.

To return to the view that you last saved without any workspace assigned, select No Workspace
on the Workspaces menu.
RELATED LINKS
Workspaces Organizer on page 1160
Open Projects in Last Used View on page 1194

Creating Workspaces
To save your current dialog and window setting for future use, you can create a new workspace.
PROCEDURE
1.

Select Workspaces > Add Workspace.

2.

In the Name field of the New Workspace dialog, enter a workspace name.

3.

Select the type of workspace that you want to create.

4.

●

Global Workspace

●

Project Workspace

Click OK.

RESULT
The workspace is saved and added to the Workspaces menu.

Editing Workspaces
You can modify your created workspaces.
NOTE
To change a global workspace to a project workspace and vice versa, you must save it as a
different workspace type.

PROCEDURE
1.

On the Workspaces menu, select the workspace that you want to modify.

2.

Make your changes as required.

3.

On the Workspaces menu, select one of the following:
●

To update your current workspace, click Update Workspace.

●

To save your workspace as a different workspace or workspace type, click Add
Workspace.

RELATED LINKS
Creating Workspaces on page 1159
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Workspaces Organizer
The Workspaces Organizer allows you to manage the existing workspaces.
To open the Workspaces Organizer, click Workspaces > Organize.

The Workspaces Organizer displays the global workspaces and the project workspaces in
separate lists. Every workspace has an assigned key command that lets you switch views quickly.
Moving or deleting workspaces within the lists changes the key command assignments. When
you change the position of a workspace, the key command assignments remain in their original
list position. You can click a key command of a selected workspace to open the respective key
command assignment in the Workspace category of the Key Commands dialog.
To organize your workspace, you have the following options:
Move Up
Moves up a workspace by one position.
Move Down
Moves down a workspace by one position.
Delete
Deletes a selected workspace.
Add
Allows you to create a new workspace using the New Workspace dialog.
NOTE
●

You can also click and drag a workspace to another position within a list.

●

You can move workspaces only within a list. For a global workspace to become a project
workspace and vice versa, you must save it as a different type of workspace.

●

To rename a workspace, you can double-click the workspace name.

RELATED LINKS
Workspaces Category on page 1154
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Using the Setup Options
You can customize the appearance of the following elements:
●

Transport panel

●

Status line

●

Info line

●

Toolbars

●

Inspector

Setup Context Menus
Setup context menus are available for the Transport panel, the toolbars, the info lines, or the
Inspector.
●

To open the setup context menus, right-click the corresponding element.

●

NOTE
You can also click the corresponding setup buttons

to open the context menu.

The following general options are available on the setup context menus:
●

Show All makes all items visible.

●

Reset All resets the interface to the default setting.

●

Setup opens the setup dialog.

If presets are available, they can be selected on the lower half of the menu.

The info line setup context menu
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Setup Dialogs
The setup dialogs allow you to specify which elements are visible/hidden and in what order they
are shown. You can save and recall setup presets.
●

To open a setup dialog, right-click the element that you want to set up, and select Setup.

The left section of the dialog shows the visible items, the right section shows the hidden items.
●

To change the current show/hide status of an item, select it in one section and use the
arrow buttons in the middle of the dialog to move it to the other section.

●

To reorder the items list, select an item in the list of Visible Items and click Move Up or
Move Down.

●

To name the current configuration and save it as a preset, click Store in the Presets
section.

●

To remove a preset, select it on the presets pop-up menu and click Delete in the Presets
section.

●

To revert to the standard layout, open the setup context menu and select Reset All.

Configuring the Main Menu Items
You can configure what items are shown on the main menus and submenus, and even hide
entire menus. By customizing the menus you can hide items relating to program functions you
never use, to customize the program according to your needs.
NOTE
Do not hide menus or menu items unless you are sure that you do not need them.

PROCEDURE
1.

In the Preferences dialog, select Configuration.

2.

Click the + sign for a folder item.

3.

Do one of the following:

4.

●

Activate/Deactivate a menu in the Menu column.

●

Activate/Deactivate a key command in the Command column.

Click Apply to apply the changes or OK to apply the changes and exit the dialog.

1162

Customizing
Configuring the Main Menu Items
RESULT
The corresponding menu items and key commands are deactivated.
RELATED LINKS
Configuration on page 1163
Disabling Key Commands on page 1155

Configuration
The Configuration page in the Preferences dialog allows you to customize the menus in
Nuendo.

●
1

In the Preferences dialog, select Configuration.
Main Menu
This folder contains folders for all main menus.

2

Command Categories
This folder contains folders for all command categories.

3

Menu
This column allows you to show/hide entire menus from view by setting them to On or Off.
NOTE
Specific menu items, such as Save, Open, Close, Undo on the File and Edit menus, cannot
be hidden.

4

Command
This column allows you to enable/disable the key command for a menu item by setting
them to On or Off.
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5

Defaults
Click this button to show all menu items and activate their key commands again.

6

Apply
Allows you to apply the changes without exiting the dialog.

7

OK
Allows you to apply the changes and exit the dialog.

NOTE
You can save menu configurations as preference presets, either separately or together with
other Preferences dialog settings.

Customizing the Meter Colors
You can customize the meter colors in Nuendo. This helps you to keep an overview of what levels
are being reached.
PROCEDURE
1.

In the Preferences dialog, select Metering > Appearance.

2.

Do one of the following:

3.

●

Click Channel Meter to make settings for the channel meter.

●

Click Master Meter to make settings for the master meter.

Do one of the following:
●

Double-click a level position to the right of the meter scale and enter the level (dB)
value to specify the level for a color change. To enter dB values less than zero, add a
minus sign before the entered number.

●

Click a level position and drag it to a specific level, and press Shift for more accurate
positioning.

●

Click a level position and nudge it up or down with the Up Arrow/Down Arrow keys,
and press Shift for faster positioning.
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NOTE
You can add level position handles by clicking the Add button. New handles are always
added at the top of the meter. You can remove a selected level position handle by clicking
the Remove button.
4.

Click the upper or lower part of a handle so that a frame is shown, and in the color
selector, select a color.

5.

Click OK.

RELATED LINKS
Color Selector Pane on page 1165

Customizing the User Interface Colors
You can change the color of the Nuendo desktop, the track types, the Project window, the editor
elements, and MixConsole elements.
PROCEDURE
1.

In the Preferences dialog, select User Interface > Color Schemes.

2.

Do one of the following:
●

Activate a default color scheme by clicking on it.

●

Click Choose Custom Color and the color selector pane to select a new color.

RESULT
The color scheme is instantly applied.
RELATED LINKS
Color Selector Pane on page 1165

Color Selector Pane
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Color Selectors
Allow you to select a color.
Context Menu
Allows you to copy, paste or reset colors.
Current Color/New Color
Shows the current color and the new color.
Hue/Saturation/Brightness
Allows you to edit the colors numerically.
OK
Confirms the color changes.
NOTE
You must restart the application for some changes to take effect.

Coloring Tracks, Parts, or Events Manually
You can apply colors to individual tracks and events/parts for an easier overview in the Project
window.
PROCEDURE
1.

2.

In the Project window, do one of the following:
●

To change the color of an event or part, select it.

●

To change the color of a track, select the track and deselect all its events or parts.

On the toolbar, select the Color tool, click again, and select a color from the pop-up menu.

RESULT
If you apply a color to a track, the corresponding events and parts are displayed in the same
color.
NOTE
If you assign a different color to individual parts or events, they no longer follow color changes of
the track.
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Resetting the Default Track Color
You can reset the color of a track, part, or event to the default color.
PROCEDURE
1.

In the Project window, select the track, event or part that you want to reset to the default
color.

2.

On the toolbar, select the Color tool, click again, and select Default Color from the pop-up
menu.

Auto Track Color Mode
The Auto Track Color Mode offers you several options for automatically assigning colors to
tracks that are added to the project.
●

To change the Auto Track Color Mode and in the Preferences dialog, select Event
Display > Tracks.

The following options are available:
Use Default Track Color
The default color (gray) is assigned.
Use Previous Track Color
Analyzes the color of the selected track and uses the same color for the new track.
Use Previous Track Color +1
Analyzes the color of the selected track and uses the color that comes next in the
color palette for the new track.
Use Last Applied Color
Uses the color that is selected in the Select Colors pop-up menu.
Use Random Track Color
Uses the color palette as a basis to assign track colors randomly.

Colorizing Track Controls
You can apply the track color to the track controls. By default, only the left part of the track in the
track list is colorized.
PROCEDURE
1.

In the Preferences dialog, select Event Display > Tracks.

2.

Drag the Colorize Track Controls slider to the right.
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3.

On the Project window toolbar, select the Color Tool and click again to select a color.

RESULT
The track controls are colorized.

Colorizing Folder Track Controls Only
You can restrict the effect of the Colorize Track Control function to folder tracks only. This is
useful in projects with a large number of tracks and folder tracks.
PROCEDURE
1.

In the Preferences dialog, select Event Display > Tracks.

2.

Drag the Colorize Track Controls slider to the right.

3.

Activate Colorize Only Folder Track Controls.

4.

Click OK.

5.

In the track list, select the folder track that you want to colorize.

6.

On the Project window toolbar, select the Color Tool and click again to select a color.

RESULT
Only the folder track controls are colorized.

Project Colors Dialog
The Project Colors dialog allows you to set up a different set of colors for the tracks, events or
parts.
●

To open the Project Colors dialog, select the Color tool on the Project window toolbar.
Click again to open a pop-up menu and select Project Colors.
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Color fields
Click a field to open a color selector pane that allows you to specify a new color.
The following options are available in the Options pop-up menu:
Append New Color
Adds a new color button at the bottom of the color list.
Insert New Color before Selection
Adds a new color button above the selected color button.
Remove Selected Color
Removes the selected color.
Reset Selected Color
Resets the selected color to the factory settings.
Increase/Reduce Intensity of all Colors
Increases or reduces the intensity of all colors.
Increase/Reduce Brightness of all Colors
Increases or reduces the brightness of all colors.
Save Current Set as Program Defaults
Saves the current set of colors as default.
Load Program Defaults to Current Set
Applies the default set of colors.
Reset Current Set to Factory Settings
Returns to the standard color palette.
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Adding and Editing Individual Colors
You can add new colors to the color palette in the Project Colors dialog.
PROCEDURE
1.

Select the Color tool on the Project window toolbar.

2.

Click again to open a pop-up menu and select Project Colors

3.

Click Options and select Insert New Color before Selection.

4.

Click the newly created color field to open the color selector pane.

5.

Select a color and click OK.

RESULT
The color is applied to the selected color field.
RELATED LINKS
Color Selector Pane on page 1165

Profiles
Profiles allow you to save customized program settings and preferences. You can switch between
profiles, and import and export your profiles for use on different computers.
Profiles are helpful if you work on different computers if you use different settings for different
kinds of projects, or in a studio environment where several users work on the same computer.
Profiles are saved as files with file name extension .srf.
Profiles include the following:
●

Preferences

●

Toolbar settings for all windows

●

Global workspaces

●

Track control settings

●

Track control presets

●

Presets for input and output busses

●

Plug-in collections

●

Quantize presets

●

Crossfade presets

●

Key commands

All changes done for these settings are saved in the active profile.
IMPORTANT
The following is not included in profiles: Settings in the Studio Setup dialog and in the Audio
Connections window, presets in the Control Room tab of the Audio Connections window, track
presets, plug-in presets, and project templates.

Profile Manager
The Profile Manager allows you to save customized program settings as profiles and to organize
profiles on your computer.
●

To open the Profile Manager, click File > Profile Manager.
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The dialog lists all available profiles. The active profile is indicated by a checkmark.
To organize your profiles, you have the following options:
New
Adds a new profile with factory settings.
Duplicate
Duplicates the selected profile.
Rename
Allows you to rename the selected profile.
Delete
Deletes the selected profile.
Import
Opens a dialog that allows you to import a profile from a file.
Export
Opens a dialog that allows you to export the selected profile to a file.
Activate Profile
Activates the selected profile. You must restart the program for the change to take
effect.
Close
Closes the dialog.

Creating Profiles
The Profile Manager allows you to create a new profile that is based on the factory default
settings.
PROCEDURE
1.

Select File > Profile Manager.

2.

In the Profile Manager, click New.

3.

In the Add New Profile dialog, enter a profile name and click OK.

RESULT
The new profile is added to the list.
AFTER COMPLETING THIS TASK
Activate the new profile to apply the settings.
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RELATED LINKS
Activating Profiles on page 1172

Duplicating Profiles
The Profile Manager allows you to create a duplicate of a profile and save it under a different
name.
PROCEDURE
1.

Select File > Profile Manager.

2.

In the Profile Manager, select the profile that you want to duplicate.

3.

Click Duplicate.

4.

In the Duplicate Profile dialog, enter a profile name and click OK.

RESULT
The new profile is added to the list.

Activating Profiles
The Profile Manager allows you to switch to another profile. A profile switch requires a restart of
Nuendo.
PREREQUISITE
You have saved at least two profiles.
PROCEDURE
1.

Select File > Profile Manager.

2.

In the Profile Manager, select the profile that you want to activate.

3.

Click Activate Profile.

4.

Click OK.

5.

Restart the application.

RESULT
The settings of the profile are now active.

Renaming Profiles
The Profile Manager allows you to rename profiles.
PROCEDURE
1.

Select File > Profile Manager.

2.

In the Profile Manager, select the profile that you want to rename.

3.

Click Rename.

4.

In the Rename Profile dialog, enter a profile name and click OK.

Deleting Profiles
The Profile Manager allows you to delete profiles.
PREREQUISITE
You have saved at least two profiles.
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NOTE
You cannot delete the active profile.

PROCEDURE
1.

Select File > Profile Manager.

2.

In the Profile Manager, select the profile that you want to delete.
Select multiple profiles to delete them at once.

3.

Click Delete.

4.

Click OK.

RELATED LINKS
Activating Profiles on page 1172

Exporting Profiles
The Profile Manager allows you to export profiles for use on another computer.
PROCEDURE
1.

Select File > Profile Manager.

2.

In the Profile Manager, select the profile that you want to export.

3.

Click Export.

4.

In the file dialog, specify the file name and the location.

5.

Click Save.

RESULT
The exported profile is saved as .srf file at the specified location.
AFTER COMPLETING THIS TASK
Import the profile on another computer.

Importing Profiles
The Profile Manager allows you to import profiles.
PROCEDURE
1.

Select File > Profile Manager.

2.

In the Profile Manager, click Import.

3.

In the file dialog, select the profile that you want to import.

4.

Click Open.

RESULT
The imported profile is added to the list of available profiles.
AFTER COMPLETING THIS TASK
Activate the new profile to apply the settings.
RELATED LINKS
Activating Profiles on page 1172
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Where are the Settings Stored?
There is a large number of ways in which you can customize Nuendo. While some of the settings
you make are stored with each project, others are stored in separate preference files.
If you need to transfer your projects to another computer in another studio, for example, you
can bring all your settings along by copying the desired preference files and installing them on
the other computer.
NOTE
It is a good idea to make a backup copy of your preference files once you have set things up the
way you want! This way, if another Nuendo user wants to use his or her personal settings when
working on your computer, you can restore your own preferences afterwards.
●

On Windows, preference files are stored in the following location: “\Users\<user name>
\AppData\Roaming\Steinberg\<program name>\”.
On macOS, preference files are stored in the following location: “/Library/Preferences/
<program name>/” under your home directory.
On the Start menu, you will find a shortcut to this folder for easy access.
The full path is: “/Users/<user name>/Library/Preferences/<program name>/”.

NOTE
The RAMpresets.xml file, which contains various presets settings, is saved when exiting the
program.
NOTE
Program functions, such as crossfade, or configurations, such as panels, not used in the project
will not be stored.

Updating from a Previous Version of Nuendo
When you are updating from Nuendo 5 or higher, most of the customized settings of your
previous installation are used for the new Nuendo version.
When your previous Nuendo version is older than Nuendo 5, its settings are discarded, and the
default settings of the new version of Nuendo are used.

Disabling the Preferences
Sometimes you might experience odd program behaviour that can be due to inconsistent
preferences settings. In such a case, you should save your project and relaunch Nuendo. You can
disable or delete the current preferences settings, and load the factory defaults instead.
PROCEDURE
1.

Quit Nuendo.

2.

Launch Nuendo, and when the splash screen appears, hold down Shift-Ctrl/Cmd-Alt.

3.

Select one of the following options in the dialog that appears:
●

Use current program preferences
Opens the program with the current preference settings.

●

Disable program preferences
Disables the current preferences, and opens the program with the factory default
settings instead.
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●

Delete program preferences
Deletes the preferences and opens the program with the factory default settings
instead. This process cannot be undone. Note that this affects all versions of
Nuendo installed on your computer.

RELATED LINKS
Preferences on page 1180
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Optimizing Audio Performance
This section gives you some hints and tips on how to get the most out of your Nuendo system,
performance-wise.
NOTE
For details and current information on system requirements and hardware properties refer to
the Steinberg web site.

Performance Aspects
Tracks and Effects
The faster your computer, the more tracks, effects, and EQ you are able to play. Exactly what
constitutes a fast computer is almost a science in itself, but some hints are given below.

Short Response Times (Latency)
Another aspect of performance is response time. The term “latency” refers to the buffering, that
is, the temporary storing of small chunks of audio data during various steps of the recording and
playback process on a computer. The more and larger those chunks, the higher the latency.
High latency is most irritating when playing VST instruments and when monitoring through the
computer, that is, when listening to a live audio source via the Nuendo MixConsole and effects.
However, very long latency times (several hundred milliseconds) can also affect other processes
like mixing, for example, when the effect of a fader movement is heard only after a noticeable
delay.
While Direct Monitoring and other techniques reduce the problems associated with very long
latency times, a system that responds fast will always be more convenient to work with.
●

Depending on your audio hardware, it may be possible to trim your latency times, usually
by lowering the size and the number of buffers.

●

For details, refer to the audio hardware documentation.

Audio Hardware and Driver
The hardware and its driver can have some effect on regular performance. A badly written driver
can reduce the performance of your computer. But where the hardware driver design makes the
most difference is with latency.
NOTE
We recommend that you use audio hardware for which there is a specific ASIO driver.
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This is especially true when using Nuendo for Windows:
●

Under Windows, ASIO drivers written specifically for the hardware are more efficient than
the Generic Low Latency ASIO Driver and produce shorter latency times.

●

Under macOS, audio hardware with properly written macOS (Core Audio) drivers can be
very efficient and produce very low latency times.

However, there are additional features only available with ASIO drivers, such as the ASIO
Positioning Protocol.

Settings That Affect Performance
Audio Buffer Settings
Audio buffers affect how audio is sent to and from the audio hardware. The size of the audio
buffers affects both the latency and the audio performance.
Generally, the smaller the buffer size, the lower the latency. On the other hand, working with
small buffers can be demanding for the computer. If the audio buffers are too small, you may
get clicks, pops or other audio playback problems.

Adjusting the Buffer Size
To lower the latency, you can reduce the buffer size.
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select your audio hardware driver.

3.

Click Control Panel.

4.

Do one of the following:
●

Windows: Adjust the buffer size in the driver dialog that opens.

●

macOS: Adjust the buffer size in the CoreAudio Device Settings dialog.

Multi Processing
Multi processing distributes the processing load evenly to all available CPUs, allowing Nuendo to
make full use of the combined power of the multiple processors.
Multi processing is activated by default. You can find the setting in the Studio Setup dialog (VST
Audio System page).

Audio Performance Window
This window shows the audio processing load and the hard disk transfer rate. This allows you to
verify that you do not run into performance problems when adding effects or plug-ins, for
example.
●

To open the Audio Performance window, select Studio > Audio Performance.

Average load
Shows how much of the available CPU power is used for audio processing.
Real-time peak
Shows the processing load in the realtime path of the audio engine. The higher this
value, the higher the risk that dropouts occur.
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Overload indicator
The overload indicator to the right of the real-time peak indicator and the average
load indicator displays overloads of the average or real-time indicator.
If it lights up, decrease the number of EQ modules, active effects, and audio channels
that play back simultaneously. You can also activate the ASIO-Guard.
Disk
Shows the hard disk transfer load.
Disk overload indicator
The overload indicator to the right of the disk indicator lights up if the hard disk does
not supply data fast enough.
If it lights up, use Disable Track to reduce the number of tracks playing back. If this
does not help, you need a faster hard disk.
NOTE
You can show a simple view of the performance meter on the Transport panel and on the
Project window toolbar. These meters only feature the average and the disk indicator.

ASIO-Guard
The ASIO-Guard allows you to shift as much processing as possible from the ASIO realtime path
to the ASIO-Guard processing path. This results in a more stable system.
The ASIO-Guard allows you to preprocess all channels as well as VST instruments that do not
need to be calculated in realtime. This leads to fewer dropouts, the ability to process more tracks
or plug-ins, and the ability to use smaller buffer sizes.

ASIO-Guard Latency
High ASIO-Guard levels lead to an increased ASIO-Guard latency. When you adjust a volume
fader, for example, you will hear the parameter changes with a slight delay. The ASIO-Guard
latency, in contrast to the latency of the audio hardware, is independant from live input.

Restrictions
The ASIO-Guard cannot be used for:
●

Realtime-dependent signals

●

External effects and instruments

NOTE
If you select Studio > VST Plug-in Manager and click Show VST Plug-in Information, you can
deactivate the ASIO-Guard option for selected plug-ins.
If you activate the monitoring for an input channel, a MIDI or a VST instrument channel, the
audio channel and all dependent channels are automatically switched from ASIO-Guard to
realtime processing and vice versa. This results in a gentle fade out and fade in of the audio
channel.

Activating the ASIO-Guard
PROCEDURE
1.

Select Studio > Studio Setup.

2.

In the Devices list, select VST Audio System.

3.

Activate the Activate ASIO-Guard option.
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NOTE
This option is only available if you activate Multi Processing.
4.

Select an ASIO-Guard Level.
The higher the level, the higher the processing stability and audio processing
performance. However, higher levels also lead to an increased ASIO-Guard latency and
memory usage.
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The Preferences dialog provides options and settings that control the global behavior of the
program.

Preferences Dialog
The Preferences dialog is divided into a navigation list and a settings page. Clicking one of the
entries in the navigation list opens a settings page.
●

To open the Preferences dialog, select File > Preferences.

In addition to the settings, the dialog provides the following options:
Preference Presets
Allows you to select a saved preference preset.
Store
Allows you to save the current preferences as a preset.
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Rename
Allows you to rename a preset.
Delete
Allows you to delete a preset.
Store marked preferences only
Allows you to select which pages are included in the preset.
Help
Opens the dialog help.
Defaults
Resets the options on the active page to their default settings.
Apply
Applies any changes that you have made without closing the dialog.
OK
Applies any changes that you have made and closes the dialog.
Cancel
Closes the dialog without saving any changes.

Saving a Preference Preset
You can save complete or partial preference settings as presets.
PROCEDURE
1.

In the Preferences dialog make your settings.

2.

Click Store in the lower left section of the dialog.

3.

Enter a preset name and click OK.

RESULT
Your settings are now available on the Preferences Presets pop-up menu.

Saving Partial Preferences Settings
You can save partial preferences settings. This is useful when you have made settings that only
relate to a certain project or situation, for example. When you apply a saved partial preference
preset you only change the saved settings. All other preferences will be left unchanged.
PROCEDURE
1.
2.

In the Preferences dialog make your settings.
Activate Store marked preferences only.
In the preferences list a Store column is shown.
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3.

Click in the Store column of the preference pages that you want to save.

4.

Click Store in the lower left section of the dialog.

5.

Enter a preset name and click OK.

RESULT
Your settings are now available from the Preferences Presets pop-up menu.

Configuration
This section allows you to configure what items are shown on the main menus and submenus.
You can also hide entire menus.
You can activate/deactivate key commands for menu items by changing the On/Off status in the
Command column. Even if a key command is assigned to an item, it will be disabled if you set the
key command status to Off.
●

The Configuration page contains 2 parent folders: Main Menu, which contains subfolders
with items found on all main menus, and Command Categories, which contains
subfolders with items corresponding to program functions that are not available on the
main menus.

●

To hide a menu item or a menu, click in the Menu column beside it to change it to Off.
Click again to change back to On.
All menu items or menus set to Off will be hidden in the program when you click Apply or
OK.
NOTE
Note that certain essential menu items cannot be hidden, such as Save, Open, Close,
Undo/Redo, etc. This has the consequence that if you set a main menu folder that
contains such items to Off, all hideable items on the menu will be set to Off, but the menu
will still be visible.

●

To disable the key commands for a menu item, menu or function, click in the Command
column beside it so that the column reads Off. Click again to change back to On.
For all items set to Off it will not be possible to use any assigned key commands when you
click Apply or OK.

●

By clicking Enable All, you can revert back to the default settings - all items set to On.
Meaning all menu items are visible and all key commands enabled.

RELATED LINKS
Configuring the Main Menu Items on page 1162

Editing
‘Edit Solo’/’Record in MIDI Editors’ follow focus
If this option is activated, and Record in Editor or Solo Editor is activated in a MIDI
editor, these options follow the focus. That is, if the Project window gets the focus,
Record in Editor and Solo Editor are suspended in the MIDI editor.
Default Track Time Type
This allows you to specify the default track time type for new tracks. When you
change this setting, all new tracks will use the selected time type.
●

Musical
All added tracks are set to musical time type. The respective button shows a
note symbol.
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●

Time Linear
All new audio tracks use linear time base. The respective button shows a clock
symbol.

●

Follow Transport Main Display
New tracks use the primary time format setting on the transport panel. When
this is set to Bars+Beats, tracks with musical time base will be added. When
this is set to any of the other options (Seconds, Timecode, Samples, etc.), all
new tracks will use linear time base.

Display Warning before Deleting Non-Empty Tracks
If this option is activated, a warning message is displayed if you delete tracks that are
not empty.
Select Track on Background Click
This allows you to select a track by clicking in the event display background.
Auto Select Events under Cursor
If this option is activated, all events in the Project window or in an editor that are
touched by the project cursor are automatically selected. This can be helpful when
you rearrange your project, because it allows you to select whole sections (on all
tracks) simply by moving the project cursor.
Cycle Follows Range Selection
If this option is activated, range selections that you make in the Sample Editor will
be mirrored in the Project window as well. This lets you audition a range in the
Sample Editor as a loop with the main transport controls, rather than with the
Audition and Audition Loop controls in the Sample Editor.
Delete Overlaps
If this option is activated and you move, size, or nudge an event so that it partly
overlaps another event, the other event is automatically resized so that the
overlapped (hidden) section is removed. Hold Shift while moving to override this
setting.
Parts Get Track Names
If this option is activated and you move an event from one track to another, the
moved event will automatically be named according to its new track. Otherwise, the
event will retain the name of the original track.
Lock Event Attributes
This setting determines which properties are affected when you lock an event (by
selecting Lock from the Edit menu). You can select any combination of the following
3 options:
●

Position
If this is locked, the event cannot be moved.

●

Size
If this is locked, the event cannot be resized.

●

Other
If this is locked, all other editing of the event is disabled. This includes
adjusting the fades and event volume, processing, etc.

Quick Zoom
If this option is activated, the contents of parts and events will not be continuously
redrawn when you zoom manually. Instead, the contents are redrawn once you have
stopped changing the zoom – activate this if screen redraws are slow on your
system.
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Use Up/Down Navigation Commands for Selecting Tracks only
●

If this option is deactivated and no event/part is selected in the Project
window, the Up Arrow/Down Arrow keys are used to step through the tracks
in the track list.

●

If this option is deactivated and an event/part is selected in the Project
window however, the Up Arrow/Down Arrow keys still step through the tracks
in the track list. Only on the selected track, the first event/part will also be
selected.

●

If this option is activated, the Up Arrow/Down Arrow keys are only used to
change the track selection – the current event/part selection in the Project
window will not be altered.

Track Selection follows Event Selection
If this option is activated and you select an event in the Project window, the
corresponding track is also automatically selected.
Automation Follows Events
If this option is activated, automation events will automatically follow when you
move an event or part on the track.
This facilitates setting up automation that is related to a specific event or part,
instead of a specific position in the project. For example, you can automate the
panning of a sound effect event (having the sound pan from left to right, etc.) – if you
need to move the event, the automation will automatically follow. The rules are:
●

All automation events for the track between the start and end of the event or
part will be moved. If there are automation events in the position to which you
move the part or event, these will be overwritten.

●

If you duplicate an event or part, the automation events will be duplicated as
well.

●

This function also affects copying and pasting.

Drag Delay
When you click and drag an event, this setting determines the delay before the event
is moved. This helps you avoid accidentally moving events when you click on them in
the Project window.

Editing - Audio
Treat Muted Audio Events like Deleted
If you have 2 overlapping audio events in your project and you mute the top one (the
event you hear during playback), playback of the other (obscured) event will still only
start at the end of the overlapping section.
If this is not what you want, Treat Muted Audio Events like Deleted allows you to
immediately play the obscured event when muting the top event.
Use Mouse Wheel for Event Volume and Fades
●

If this option is activated, you can use the mouse wheel to move the event
volume curve up or down.

●

When you hold down Shift while moving the mouse wheel, the fade curves will
be affected. To move the end point of the fade in, position the mouse in the
left half of the event. To move the start point of the fade out, position the
mouse in the right half of the event.

Simple Crossfade Editor
If this option is activated, a simplified Crossfade dialog opens when you double-click
a crossfade or select Open Fade Editor(s) from the Audio menu. The regular
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Crossfade dialog contains a host of additional, advanced functions for adjusting
crossfades.
On Import Audio Files
This setting determines what happens when importing an audio file into a project:
●

Open Options Dialog
An Import Options dialog opens when you import, allowing you to select
whether you want to copy the file to the audio folder and/or convert it to the
project settings.

●

Use Settings
Allows you to set standard actions for importing audio.

Enable Automatic Hitpoint Detection
If this option is activated, and you add an audio file to your project by recording or by
importing, Nuendo automatically detects its hitpoints. This allows you to navigate to
hitpoints of an audio file from within the Project window.
Remove Regions/Hitpoints on all Offline Processes
If this option is activated, and you perform offline processing on an audio range that
contains regions, these will be removed.
On Processing Shared Clips
This setting determines what happens when you apply processing to a shared clip,
that is, a clip that is used by more than one event in the project:
●

Open Options Dialog
An Options dialog appears, allowing you to select whether you want to create
a new version of the clip or apply the processing to the existing clip.

●

Create New Version
A new editing version of the clip is automatically created, and the processing is
applied to that version (leaving the original clip unaffected).

●

Process Existing Clip
The processing is applied to the existing clip (which means that all events
playing that clip will be affected).

Time Stretch Tool Algorithm
Use this option to select a default algorithm that is applied when using the Object
Selection tool in Sizing Applies Time Stretch mode. This mode allows you to resize
parts and events in the Project window and apply time stretch to their contents in
the process, so that the audio material is adjusted to fit the new length of the part or
event. The following settings are available:
●

MPEX – Preview Quality
Use this mode only for preview purposes.

●

MPEX – Mix Fast
This mode is a very fast mode for preview. This works best with composite
music signals (mono or stereo material).

●

MPEX – Solo Fast
Use this mode for single instruments (monophonic material) and voice.

●

MPEX – Solo Musical
Same as above but higher quality.

●

MPEX – Poly Fast
Use this for processing monophonic and polyphonic material. This is the
fastest setting that still provides very good results. You can use this for drum
loops, mixes, or chords.
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●

MPEX – Poly Musical
Use this for processing monophonic and polyphonic material. This is the
recommended MPEX default quality setting. You can use this for drum loops,
mixes, or chords.

●

MPEX – Poly Complex
This high quality setting produces high CPU load. Use this setting when
processing difficult material or for stretch factors above 1.3.

●

Realtime
This algorithm is much quicker and allows for better CPU performance than
MPEX, but produces a lower sound quality.

Default Warping Algorithm
Determines which warp algorithm is used for new audio clips in the project.

Editing - Chords
‘X’ Chords Mute Notes on Tracks That are in Follow Chord Track Mode
This determines what happens when you play back a track that follows the chord
track and the cursor reaches an undefined chord event (X chord). Activate this option
to mute playback. Deactivate this option to continue playback of the last defined
chord event.
Disable ‘Acoustic Feedback’ during Playback
If you activate this option, Acoustic Feedback is automatically disabled on playback.
This ensures that chord events are not triggered twice.
Hide muted Notes in Editors
If you set up a MIDI track to follow the chord track by activating one of the Follow
Chord Track options, some of the original MIDI notes may be muted. Activate this
option to hide these notes in the editors.

Editing - Controls
Many Nuendo parameters are shown as rotary encoders, sliders, and buttons that emulate
hardware interfaces. Others are edited numerically in value fields. This page allows you to select
the preferred ways of controlling encoders, sliders, and value fields.
Value Box/Time Control Mode
The menu contains the following options:
●

Text Input on Left-Click
In this mode, clicking a value box will open it for editing by typing.

●

Increment/Decrement on Left/Right-Click
In this mode, you can click with the left or right mouse button to decrease or
increase the value. To edit values by typing in this mode, please double-click.
Under macOS, right-clicking is the same as Ctrl/Cmd-clicking. We recommend
that you use a 2-button mouse and set up the right button to generate a Ctrl/
Cmd-click.

●

Increment/Decrement on Left-Click and Drag
In this mode, you can click and drag up or down to adjust the value (much like
dragging a vertical fader). Double-click to enter values manually.

Knob Mode
The menu contains the following options:
●

Circular
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To move an encoder, click on it and drag in a circular motion, such as turning a
real encoder. When you click anywhere along the encoder’s edge, the setting
is immediately changed.
●

Relative Circular
Works like the Circular option, but clicking does not automatically change the
setting. This means you can make adjustments to the current setting by
clicking anywhere on an encoder and dragging. There is no need to click on
the exact current position.

●

Linear
To move an encoder, click on it and drag up or down (or left or right) with the
mouse button pressed – as if the encoder was a vertical (or horizontal) slider.

Slider Mode
The menu contains the following options:
●

Jump
In this mode, clicking anywhere on a slider will make the slider handle
instantly move to that position.

●

Touch
In this mode, you have to click on the actual slider handle to adjust the
parameter. This reduces the risk of accidentally moving sliders.

●

Ramp
In this mode, clicking anywhere on a slider (but not on the actual handle) and
keeping the mouse button pressed causes the handle to move smoothly to the
new position.

●

Relative
In this mode, clicking on a slider will not immediately change the setting.
Instead you click and drag up or down – the setting will be changed according
to how far you drag, not according to where you click.

Editing - MIDI
Select Controllers in Note Range: Use Extended Note Context
If this option is activated and you move notes together with their controllers, for
example, in the Key Editor, the extended note context will be taken into account. This
means that controllers between the last selected note and the following note (or the
end of the part) will also be moved. If this option is deactivated, only the controllers
between the first and the last selected note will be moved.
Legato Overlap
Determines the result of the Legato function on the MIDI menu.
●

If Legato Overlap is set to 0 Ticks, the Legato function extends each selected
note so that it reaches the next note exactly.

●

Setting Legato Overlap to a positive value causes the notes to overlap by the
specified number of ticks.

●

Setting Legato Overlap to a negative value makes the Legato function leave a
slight gap between the notes.

Legato Mode: Between Selected Notes Only
If this option is activated, the length of selected notes will be adjusted so that they
reach the next selected note, allowing you to apply Legato only to your bass line, for
example.
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Split MIDI Events
If you split a MIDI part in the Project window (with the Cut tool or one of the split
functions) so that the split position intersects one or several MIDI notes, the result
depends on this setting.
●

If Split MIDI Events is activated, the intersected notes are split. This creates
new notes at the beginning of the second part.

●

If Split MIDI Events is deactivated, the notes will remain in the first part, but
stick out after the end of the part.

Split MIDI Controllers
If you split a MIDI part containing controllers, the result depends on this setting:
●

If Split MIDI Controllers is activated and the part contains a controller with a
value other than zero at the split position, a new controller event (of the same
type and value) will be inserted at the split position (at the start of the second
part).

●

If Split MIDI Controllers is deactivated, no new controller events will be
inserted.

NOTE
If you just split a part and play back the result, it will sound the same regardless of
this setting. However, if you split a part and delete the first half or move the second
half to a different position in the project, you may want to activate Split MIDI
Controllers to make sure all controllers have the correct value at the beginning of
the second part.

Editing - Project & MixConsole
Select Channel/Track on Solo
When you activate this option, a track in the track list or a channel in the MixConsole
automatically gets selected if Solo is activated. Deactivating this option always keeps
the current selection status, regardless of the solo setting for the tracks.
Select Channel/Track on Edit Settings
When you activate this option, a track in the track list or a channel in the MixConsole
automatically gets selected when you click Edit Channel Settings. Deactivating this
option always keeps the current track/channel selection.
Scroll to selected Track
If you activate this option, selecting a MixConsole channel automatically scrolls the
track list to display the respective track.
Sync Selection in Project Window and MixConsole
If this option is activated, and you select a track in the Project window, the
corresponding channel is automatically selected in the MixConsole and vice versa.
This can be a very handy feature when making detailed settings for audio and MIDI
channels: open the Channel Settings window for a track by clicking its edit button,
and position it so that it can remain open without obstructing the view. Then you can
simply select the track for which you want to make settings in the Project window.
The Channel Settings window will automatically change to show the settings for the
selected track.
Enable Record on Selected MIDI Track
If this option is activated, the selected MIDI tracks are automatically record-enabled.
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Enable Record on Selected Audio Track
If this option is activated, selected audio tracks are automatically record-enabled.
Enable Solo on Selected Track
If this option is activated, the selected tracks are automatically soloed.
Deep Track Folding
If this option is activated, any folding settings that you make on the Track Folding
submenu of the Project menu also affect the subelements of the tracks. For
example, if you fold in a folder track that contains 10 audio tracks, of which 5 have
several open automation tracks, all these audio tracks within the folder track will also
be folded in.
Enlarge Selected Track
Activate this option to enter a mode where the selected track in the Project window
will be enlarged. You can adjust the size directly in the track list if the default
enlargement factor does not suit you. When you select another track in the track list,
this track is automatically enlarged, and the previously selected track is displayed in
its previous size.

Editing - Tool Modifiers
On this page you can specify which modifier keys are used for additional functionality when
using tools.
PROCEDURE
1.

Select an option in the Categories list.

2.

Select the action for which you want to edit the modifier key in the Action list.

3.

On your computer keyboard, hold down the modifier keys and click Assign.

RESULT
The current modifier keys for the action is replaced. If this tool already has assigned modifier
keys, you will be asked whether you want to replace them.

Editing - Tools
Pop-up Toolbox on Right-Click
If this option is activated, the toolbox opens on right-click in the event display and
editors. You can change the number of rows in which the tools are arranged on the
toolbox. Keep the right mouse button pressed until the mouse pointer changes to a
double arrow and drag to the bottom or right.
●

To open the context menu instead of the toolbox, press any modifier key when
right-clicking.

Cross Hair Cursor
This allows you to set up a cross-hair cursor when working in the event display and
editors, facilitating navigation and editing, especially when arranging in large
projects. You can set up the colors for the line and the mask of the cross-hair cursor,
and define its width. The cross-hair cursor works as follows:
●

If the Selection tool (or one of its subtools) is selected, the cross-hair cursor
appears when you start moving or copying a part/event or when you use the
event trim handles.

●

If the Draw tool, the Cut tool, or any other tool that makes use of this function
is selected, the cross-hair cursor appears as soon as you move the mouse over
the event display.
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●

The cross-hair cursor is only available for tools where such a function is of any
use.

NOTE
If the Key Editor, Drum Editor or the Audio Part Editor is open in the lower zone of
the Project window and Link Project and Lower Zone Cursors is activated, the
cross-hair cursor is shown in the lower zone editor and in the Project window.
Warn before switching Display Domain (Timewarp Tool)
If this option is activated, a warning opens if you select the Timewarp tool and the
ruler is not set to Bars & Beats.
Zoom Tool Standard Mode: Horizontal Zooming Only
This affects the result when using the Zoom tool.
If this option is activated and you drag a selection rectangle with the Zoom tool, the
window is only zoomed horizontally and the track height does not change. If this
option is deactivated, the window is zoomed both horizontally and vertically.
Select Tool: Show Extra Info
Activate this to show a tooltip for the Object Selection tool in the Project window
event display. This tooltip indicates the current pointer position and the name of the
track and event at which you are pointing.

Editors
Use Drum Editor when Drum Map is assigned
If this option is activated, parts on MIDI tracks to which drum maps are assigned are
shown with drum note symbols. The parts will automatically open in the Drum
Editor on double-click. This overwrites the Default MIDI Editor setting.
Default MIDI Editor
Determines which editor is opened when you double-click a MIDI part or when you
select it and press Ctrl/Cmd-E. Note that this setting is overwritten for tracks with
drum maps if the Use Drum Editor when Drum Map is assigned option is activated.
Editor Content Follows Event Selection
If this option is activated, the parts or events shown in the open editor will follow the
selection that you make in the Project window.
Double-Click opens Editor in a Window/in Lower Zone
Determines where an editor is opened when you double-click an audio event or a
MIDI part or when you use the key command assigned to Open/Close Editor.
Open Editor Commands open Editors in a Window/in Lower Zone
Determines where an editor is opened when you use an open command from the
Audio or MIDI menu or the corresponding key commands.

Event Display
The Event Display section contains several settings for customizing the display in the Project
window.
Show Event Names
Determines whether the names of parts and events are shown.
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Show Event Data on Small Track Heights
If this option is activated, the contents of events and parts are shown, even if the
height of a track is very small.
Transparent Events
If this option is activated, events and parts are transparent, and shows only the
waveforms and MIDI events.
Outline Event Data
Allows you to select whether you want event data to be displayed as solid images or
with an outline.
Colorize Event Background
When you select a color for a track or for individual events or parts, this setting
determines how the color is applied:
●

If this option is deactivated, the contents of the events and parts are colorized.
In the case of audio events, the waveform images are colorized. For MIDI
parts, the MIDI events are colorized.

●

If this option is activated, the background of the events/parts are colorized.

Event Display - Audio
Addition to Event Name
Allows you to add meta-data to the event name.
Further Addition to Event Name
Allows you to add more meta-data to the event name.
Interpolate Audio Waveforms
If you have zoomed in to one sample per pixel or less, the appearance of the samples
depends on this setting. If this option is deactivated, single sample values are drawn
as steps. If this option is activated, the sample values are interpolated to form
curves.
Show Event Volume Curves Always
If this option is activated, event volume curves, as created by the fade and volume
handles, are shown for all events, regardless of whether they are selected or not. If
this option is deactivated, volume curves are only shown for selected events.
However, note that you can still adjust fades and volumes for events that are not
selected, by clicking and dragging the top left, middle, or right edge respectively.
Thick Fade Lines
If this option is activated, the fades and volume curve are displayed by thicker lines
for better visibility.
Show Waveforms
If this option is activated, audio waveforms are displayed for audio events.
Show Hitpoints on Selected Events
If this option is activated, hitpoints are displayed for audio events.
Background Color Modulation
If this option is activated, the backgrounds of audio waveforms reflect the waveform
dynamics. This is especially useful to get an overview when working with small track
heights.
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Event Display - Chords & Pitches
Pitch Notation
●

The Note Name pop-up menu lets you select between 3 ways of displaying
chords: English, German, and Solfège.

●

The Naming Format pop-up menu lets you determine how MIDI note names
(pitches) are displayed in editors, etc. The options are: MIDI, MIDI + MIDI
Note Number, and Classic (Helmholtz).

●

The options Display ‘Bb’ as ‘B’ and Display ‘B’ as ‘H’ allow you to change the
corresponding pitch names.

●

If you activate Enharmonics from Chord Track, and your project contains a
chord track with chord events, these chord events determine if the
enharmonically equivalent notes in the Key Editor and in the List Editor are
displayed as sharp or flat.

Chord Font
Allows you to specify a font for all chord symbols.
Chord Symbols
There are several ways of indicating chord types, for example, major and minor
chords. These options allow you to select your preferred display method for major
7th chords, minor chords, half-diminished chords, diminished chords, and
augmented chords.
Custom Chord Symbols
You can modify the default chord symbols that are used on the chord track, for the
chord pads, and in the Score Editor.

●

The New Custom Chord button allows you to add a new custom chord
symbol.

●

The options to the left allow you to specify the chord for which you want to
change the chord symbol.

●

Click the Type and Tension fields and enter your custom symbol.
NOTE
You must define custom symbols for each set of tensions.

●

The Result field shows how the chord will be displayed.

●

The Remove Custom Chord button allows you to remove the custom chord
symbol that is selected in the list.
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EXAMPLE
To change the appearance of all minor chords from Xmin to X-, click New Custom Chord,
activate 5 and min3/#9 to define the chord type and change the symbol in the Type column from
min to -.

Event Display - Folders
Show Event Details
If this option is activated, event details are displayed. If this option is deactivated,
data blocks are displayed.
This setting depends on the Show Data on Folder Tracks setting.
Show Data on Folder Tracks
Determines in which case data blocks or event details are displayed on folder tracks.
●

Always Show Data
If this option is activated, data blocks or event details are always displayed.

●

Never Show Data
If this option is activated, nothing is displayed.

●

Hide Data When Expanded
If this option is activated, the display of events is hidden when you open folder
tracks.

Event Display - MIDI
Part Data Mode
Determines if and how events in MIDI parts are shown: not shown, as lines, as score
notes, as drum notes, or as blocks. Note that this setting is overwritten for tracks
with drum maps if the Use Drum Editor when Drum Map is assigned option is
activated.
Show Controllers
Governs whether non-note events such as controllers, etc. are shown in MIDI parts.

Event Display - Tracks
Colorize Track Controls
This slider allows you to apply the track color to the track controls. Drag the slider to
the right to intensify the color.
Colorize Only Folder Track Controls
Activate this to restrict the effect of the Colorize Track Control function to folder
tracks only. This is useful in projects with a large number of tracks and folder tracks.
Default Track Name Width
Allows you to determine the default name width for all track types.
Auto Track Color Mode
This offers you several options for automatically assigning colors to tracks that are
added to the project:
●

Use Default Track Color
New tracks get the default event color.

●

Use Previous Track Color
New tracks get the same color as the track above them in the track list.

1193

Preferences
General
●

Use Previous Track Color + 1
This is similar to the Use Previous Track Color option, except that the new
tracks get the next color in the color palette.

●

Use Last Applied Color
New tracks get the color that you last applied to an event/part.

●

Use Random Track Color
Inserted tracks get random track colors.

General
The General page contains general settings that affect the program user interface. Set these
according to your preferred work methods.
Language
Allows you to select which language is used in the program. After switching the
language, you must restart the program for the change to take effect.
Auto Save
If this option is activated, Nuendo automatically saves backup copies of all open
projects with unsaved changes. These are named Name.bak, where name is the
name of the project, and are saved in the project folder. Backup copies of unsaved
projects are named #UntitledX.bak where X is an incremental number, to allow
multiple backup copies in the same project folder.
Auto Save Interval
Allows you to specify how often a backup copy is created.
Maximum Backup Files
Allows you to specify how many backup files will be created with the Auto Save
function. When the maximum number of backup files is reached, the existing files
will be overwritten (starting with the oldest file).
Show Tips
If this option is activated and you position the pointer over an icon or button in
Nuendo, an explanatory tooltip is displayed after a second.
Use Edge Hints
If this option is activated, you can position the mouse pointer at one of the Project
window edges to show a pane with options to open or close the sections.
Maximum Undo Steps
Allows you to specify the number of undo levels.
Use Undo Branches
If this option is activated, edit actions in the Edit History dialog and automation
actions on the automation panel are gathered in branches. A new branch is always
created when you undo an action.
Run Setup on Create New Project
If this option is activated, Nuendo automatically displays the Project Setup dialog
every time you create a new project. This allows you to specify the basic project
configuration.
Open Projects in Last Used View
Allows you to select whether projects are opened using their original window layout
and settings, or using the view that you last used on your computer. This can either
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be the last used view that was saved on your computer or one of your specified
global workspaces.
●

Never
Projects are always opened using their original window layout and settings.

●

Only External Projects
Projects that have been created on a different computer are opened using the
view that you last used on your computer. Projects that have been created on
this computer are opened using their original window layout and settings.

●

Always
Projects are always opened using the view that you last used on your
computer.

Open Last Project on Startup
If this option is activated, the last saved project is opened when you start Nuendo.
Use Hub
Activate this option to open the Hub when you start Nuendo or create a new project
using the File menu.

General - Personalization
Default Author Name
Allows you to specify an author name that is used by default for new projects. This
will be included as metadata when exporting audio files with an iXML chunk.
Default Company Name
Allows you to specify a company name that is used by default for new projects. This
will be included as metadata when exporting audio files with an iXML chunk.

MIDI
This page contains settings that affect MIDI recording and playback.
MIDI Thru Active
If this option is activated, all MIDI tracks that are record-enabled or have monitoring
activated will “echo” incoming MIDI data, sending it back out on their respective MIDI
outputs and channels. This allows you to hear the correct sound from your MIDI
instrument during recording.
NOTE
If you use MIDI Thru, select Local Off mode on your MIDI instrument to prevent
each note from sounding twice.
Reset on Stop
If this option is activated, Nuendo sends out MIDI Reset messages (including noteoff
and controller resets) on stop.
Never Reset Chased Controllers
If this option is activated, controllers are not reset to 0 when you stop playback or
move to a new position in the project.
Length Adjustment
This allows you to enter a length adjustment value in ticks by which the notes that
have the same pitch and MIDI channel are adjusted. This ensures that there is always
a short time between the end of one note and the start of another. By default, there
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are 120 ticks per 1/16 note, but you can adjust this with the MIDI Display Resolution
setting.
Chase Events
Event types for which an option is activated are chased when you locate to a new
position and start playback. This makes your MIDI instruments sound as they should
when you locate to a new position and start playback.
If Chase not limited to Part Boundaries is activated, MIDI controllers are also
chased outside the part boundaries, and the chase is performed on the part touched
by the cursor as well as on all the parts to the left of it. Deactivate this for very large
projects, as it slows down processes such as positioning and soloing.
MIDI Display Resolution
This allows you to set the display resolution for viewing and editing MIDI data. This
only affects how MIDI events are displayed and not how they are recorded.
Extend Playback Range of Notes that start before the Part
This allows you to extend the playback range of MIDI notes that start before the part
in ticks. This is useful if MIDI events start shortly before the start of the MIDI part. If
you do not extend the playback range, these events are not played. This setting is
also taken into account during cycle playback.
Insert Reset Events after Record
If this option is activated, a reset event is inserted at the end of each recorded part.
This resets controller data, such as Sustain, Aftertouch, Pitchbend, Modulation,
Breath Control. This is useful if you stop recording before the note off command is
sent, for example.
Audition through MIDI Inserts/Sends
If this option is activated, the layering of MIDI instruments (by MIDI sends) is also
active within the MIDI editors. This way, the acoustic feedback of the editors sends
the MIDI data not only to the output selected for the track, but additionally through
any MIDI inserts and MIDI sends assigned to it. However, this also means that MIDI
events will be sent through any MIDI plug-ins assigned to this track.
MIDI Latency Mode
Allows you to specify the latency of the MIDI playback engine.
Low lowers the latency and increases the responsiveness of the MIDI playback
engine. However, this setting might also decrease your computer performance if
your project contains lots of MIDI data.
Normal is the default mode and the recommended setting for most workflows.
High increases the latency and the playback buffer. Use this if you work with
complex VST Instrument libraries or with projects that have a very high performance
level.
MIDI Max. Feedback in ms
This allows you to set the maximum length of the notes when using Acoustic
Feedback in MIDI editors.
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MIDI - MIDI File
Export Options
These options allow you to specify what data is included in exported MIDI files.

Export Inspector Patch
If this option is activated, the MIDI patch settings in the Inspector - Bank Select and
Program Select (used for selecting sounds in the connected MIDI instrument) are
included as MIDI Bank Select and Program Change events in the MIDI file.
Export Inspector Volume/Pan
If this option is activated, Volume and Pan settings made in the Inspector are
included as MIDI Volume and Pan events in the MIDI file.
Export Automation
If this option is activated, the automation data (just as it is heard during playback) is
converted to MIDI controller events and included in the MIDI file. This also includes
automation recorded with the MIDI Control plug-in.
Note that if a continuous controller (CC7, for example) has been recorded but the
Read button is deactivated for the automation track (that is the automation is
effectively switched off for this parameter), only the part data for this controller will
be exported.
If this option is deactivated and the Read Automation button is activated, no
continuous controllers will be exported. If the Read button is deactivated, the
controller data of the MIDI part are exported (these will now be handled like
“regular” part data).
It is recommended to activate the “Export Automation” option.
Export Inserts
If this option is activated and you are using MIDI modifiers or any MIDI plug-ins as
insert effects, the modifications to the original MIDI notes that occur as a result of
the effects will be included in the MIDI file. A MIDI delay, for example, will produce a
number of repeats to a MIDI note by actually adding additional, “echoing” notes at
rhythmic intervals - these notes will be included in the MIDI file if the option is
activated.
Export Sends
If this option is activated and you are using any MIDI plug-ins as send effects, the
modifications to the original MIDI notes that occur as a result of the effects will be
included in the MIDI file.
Export Markers
If this option is activated, any markers you have added will be included in the MIDI
file as Standard MIDI File Marker events.
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Export as Type 0
If this option is activated, the MIDI file will be of Type 0 (all data on a single track, but
on different MIDI channels). If you do not check this option, the MIDI file will be of
Type 1 (data on separate tracks). Which type to choose depends on what you want to
do with the MIDI file (in which application or sequencer it is to be used).
Export Resolution
You can specify a MIDI resolution between 24 and 960 for the MIDI file. The
resolution is the number of pulses, or ticks, per quarter note (PPQ) and determines
the precision with which you will be able to view and edit the MIDI data. The higher
the resolution, the higher the precision. The resolution should be chosen depending
on the application or sequencer with which the MIDI file will be used though,
because certain applications and sequencers may not be able to handle certain
resolutions.
Export Locator Range
If this option is activated, only the range between the left and right locator will be
exported.
Export includes Delay
If this option is activated, any delay settings you have made in the Inspector will be
included in the MIDI file.

Import Options for MIDI Files
The Import Options for MIDI files allow you to specify what data is included in imported MIDI
files.

Extract First Patch
Converts the first Program Change and Bank Select events for each track to
Inspector settings for the track.
Extract First Volume/Pan
Converts the first MIDI Volume and Pan events for each track to Inspector settings
for the track.
Import Controller as Automation Tracks
Converts MIDI Controller events in the MIDI file to automation data for the MIDI
tracks. If this option is deactivated, controller data for the MIDI parts will be
imported.
Import to Left Locator
Aligns the imported MIDI file at the position of the left locator. If this option is
deactivated, MIDI files start at the project start position. If you choose to have a new
project created automatically, the MIDI file always starts at the project start position.
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Import Markers
Imports Standard MIDI File Markers in the file and converts them to Nuendo
markers.
Import Dropped File as Single Part
Places the file on one track if you drag and drop a MIDI file into the project.
Ignore Master Track Events on Merge
Ignores tempo track data if you import a MIDI file into the current project. The
imported MIDI file will play according to the current Tempo track in the project.
If this option is deactivated, the Tempo Track Editor will be adjusted according to
the tempo information in the MIDI file.
Auto Dissolve Format 0
Automatically dissolves imported MIDI files of type 0. Each embedded MIDI channel
in the file is placed on a separate track in the Project window.
If this option is deactivated, only one MIDI track is created. This track is set to MIDI
channel Any, allowing all MIDI events to play back on their original channels. You can
also use the Dissolve Part function on the MIDI menu to distribute the events onto
different tracks (or lanes) with different MIDI channels at a later stage.
Destination
Allows you to specify what happens when you drag a MIDI file into the project:
●

MIDI Tracks creates MIDI tracks for the imported file.

●

Instrument Tracks creates instrument tracks for each MIDI channel in the
MIDI file and lets the program automatically load appropriate presets.

●

HALion Sonic SE multi-timbral creates several MIDI tracks, each routed to a
separate instance of HALion Sonic SE in the VST Instruments window, and
loads the appropriate presets.

Import Karaoke Lyrics as Text
Converts karaoke lyrics in the MIDI file to text that can be displayed in the Score
Editor. If this option is deactivated, lyrics are only shown in the List Editor.

MIDI - MIDI Filter
This page allows you to prevent certain MIDI messages from being recorded and/or echoed by
the MIDI Thru function (thruput).
The page is divided into 4 sections:
Record
Activating any of these options prevents the corresponding type of MIDI message
from being recorded. It will, however, be thruput, and if already recorded, it will play
back normally.
Thru
Activate any of these options to prevent the corresponding type of MIDI message
from being thruput. It will, however, be recorded and played back normally.
Channels
If you activate a Channel button, no MIDI messages on that MIDI Channel will be
recorded or thruput. Already recorded messages will however be played back
normally.
Controller
Allows you to prevent certain MIDI controller types from being recorded or thruput.
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To filter out a controller type, select it from the list at the top of the section and click
Add. It will appear in the list below.
To remove a controller type from the list (allow it to be recorded and thruput), select
it in the lower list and click Remove.

MediaBay
Maximum Items in Results List
This allows you to specify the maximum number of files that are displayed in the
Results list. This helps you to avoid unmanageably long lists of files in the Results
list.
Allow Editing in Results List
Activate this to edit attributes also in the Results list. Otherwise, editing can only be
done in the Attribute Inspector.
Show File Extensions in Results List
Activate this to display file name extensions in the Results list.
Scan Folders only when MediaBay is open
Activate this to scan Nuendo for media files when the MediaBay window is open.
Otherwise, the folders are scanned in the background even when the MediaBay
window is closed.
NOTE
During playback or recording no folder scans are performed.
Scan unknown File Types
Activate this to open and scan any file in the search location and ignore files that
cannot be recognized.

Metering
Map Input Bus Metering to Audio Track (in Direct Monitoring)
This allows you to map the input bus metering to monitor-enabled audio tracks,
giving you the opportunity to watch the input levels of your audio tracks when
working in the Project window. For this to work, activate Direct Monitoring in the
Studio Setup dialog.
●

If this option is activated, audio tracks show the metering signal from the
input bus to which they are routed as soon as the track is monitor-enabled.
Note that the tracks are mirroring the input bus signal, that is, you will see the
same signal in both places. When using mapped metering, any functions, such
as trimming, that you apply to the audio track are not reflected in its meters.

●

If this option is not activated, metering works as usual.

Meters’ Peak Hold Time
This allows you to specify for how long the peak levels are held in the meters. For this
to work, deactivate Meters - Hold Forever in the MixConsole.
Meters’ Fallback
This allows you to specify how quickly the meters in the MixConsole return to lower
values after signal peaks.
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Metering - Appearance
On this page you can assign colors to level meter values to quickly identify what levels are
reached. You can adjust the colors for the channel meter or the master meter. For the master
meter you can only make changes for the Digital Scale scaling mode. Changes take effect when
you click Apply or OK.
To adjust the levels and colors, activate the channel meter or master meter option and proceed
as follows:
●

To specify the level for a color change, double-click a handle to the right of the meter scale
and enter the level (dB) value. Note that for dB values less than 0, you must add a minus
sign before the entered number. You can also click a handle and drag it to a specific level.
Press Shift for more accurate positioning. Alternatively, you can nudge with the Up Arrow/
Down Arrow keys. Press Shift for faster positioning.

●

To assign a color, click the upper or lower part of a handle, and use the color selector pane
to select a color. Selecting the same color for the upper and lower part of the handle
results in a meter that changes its colors gradually, while different colors indicate level
changes even more precisely.

●

To add more color handles, click Add, or Alt-click at a level position to the right of the
meter scale. Each new handle is automatically associated with a default color.

●

To remove a handle, select the handle and click Remove, or Ctrl/Cmd-click the handle.

Record
This page contains settings related to audio and MIDI recording. Select one of the available
entries.
Deactivate Punch In on Stop
If this option is activated, Punch In on the Transport panel is automatically
deactivated whenever you enter Stop mode.
Stop after Automatic Punch Out
If this option is activated, playback will automatically stop after automatic Punch Out
(when the Project Cursor reaches the Right Locator and Punch Out is activated on the
Transport panel). If the Post-roll value on the Transport panel is set to a value other
than zero, playback will continue for the set time before stopping.

Record - Audio
Audio Pre-Record Seconds
This allows you to specify for how many seconds any incoming audio you play is
captured in buffer memory during playback or in stop mode.
When Recording Wave Files larger than 4GB
This allows you to specify what happens if you record Wave files that are larger than
4 GB.
●

To split the Wave file, activate Split Files.
Use this if you work on a FAT32 file system that supports only file sizes up to 4
GB.

●

To save the Wave file as RF64 file, activate Use RF64 Format.
RF64 files use the .wav extension. However, they can only be opened with an
application that supports the RF64 standard.
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Create Audio Images during Record
If this option is activated, Nuendo calculates the waveform image and displays it
during the actual recording process.
NOTE
This realtime calculation uses some extra processing power.

Record - Audio - Broadcast Wave
This page allows you to specify the Description, Author, and Reference text strings that are
embedded in recorded Broadcast Wave files. The settings you make here also appear as default
strings in the Broadcast Wave Chunk dialog when you export files to certain formats (not only
Broadcast Wave files can contain embedded information, but also Wave, Wave 64, and AIFF files).

Record - MIDI
Record-Enable allows MIDI Thru
Activate this option if you do not want record-enabled MIDI or instrument tracks to
echo incoming MIDI data. This prevents hearing doubled notes on record-enabled
tracks to which a VST instrument is assigned.
Snap MIDI Parts to Bars
Activate this to lengthen recorded MIDI parts automatically to start and end at whole
bar positions. If you are working in a Bars+Beats-based context, this can make
editing (Moving, Duplicating, Repeating, etc.) easier.
MIDI Record Catch Range in ms
When you record starting at the left locator, this setting helps you make sure that the
very start of the recording is included. If you raise the Record Catch Range, Nuendo
will catch the events played just before the recording start point, eliminating this
problem.
Retrospective Record
If this option is activated, the program captures MIDI input in buffer memory, even
when not recording. The contents of the buffer memory can then be retrieved and
turned into a MIDI part on a record-enabled MIDI track. This therefore allows you to
capture any MIDI notes you play in stop mode or during playback and later turn
them into a recorded MIDI part.
Use the Retrospective Record Buffer Size setting to determine how much MIDI
data can be captured in the buffer.
ASIO Latency Compensation Active by Default
This determines the initial state of the ASIO Latency Compensation button in the
track list for MIDI or instrument tracks.
If you record live on a VST instrument, you usually compensate the latency of your
audio card by playing too early. In consequence, the timestamps are recorded too
early. By activating this option, all recorded events are moved by the current latency,
and playback sounds like during the recording situation.
Replace Recording in Editors
This affects the result of recording in a MIDI editor when Replace Mode is selected
(Linear Record Mode on the Transport panel):
●

None
Nothing is replaced, even though Replace Mode is selected.

●

Controller
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Only controller data is replaced, not notes.
●

All
Replace mode works as usual - notes and controllers are replaced when
recording.

Scores
This page allows you to make settings for the Score Editor. Please select one of the available
entries.

Scores - Colors for Additional Meanings
Here, you can specify different colors to identify non-standard elements in the score.
●

Click in the Active column to activate this function for the respective element.

●

Click in the color field to the right to specify the desired color.

Scores - Editing
Display Object Selection tool after Inserting Symbol
If this option is activated, as soon as you add a symbol, the program switches back to
the Object Selection tool. If this option is deactivated, the Draw tool remains active
after inserting a symbol.
Double-Click Symbol to get Draw tool
If this option is activated, you need to double-click with the Object Selection tool in a
Palette to activate the Draw tool. If this option is deactivated, a single click is enough
to bring out the Pencil.
Keep Crescendo Symbols “Horizontal”
If this option is activated, crescendo symbols are never “slanted”.
Keep moved Notes within Key
If this option is activated, and you move notes vertically (to transpose them), you will
be restricted to pitches within the current key.
Tied Notes selected as Single Units
If this option is activated, and you click on either note in a tied note pair, both notes
will be selected.
Global Staff Spacings with [Alt-Gr + Ctrl] (Win)/[Option]-[Command] (Mac)
If this option is activated, pressing AltGr + Ctrl on Windows or Alt-Cmd on macOS
and adjusting the spacing of staves applies the spacing to all staves on the current
page and on all the following pages. If this option is deactivated, the spacing is only
applied to the current page.
Auto Layout: Don’t hide first staff
This option affects the Auto Layout functions “Hide Empty Staves” and “Optimize All”.
When “Don’t hide first staff” is activated, staves in the very first grand staff will not be
hidden, even if they are empty.
Show Braces in Edit Mode
Normally, braces are only shown in Page Mode. With this option activated they will
also be visible in Edit Mode.

1203

Preferences
Scores
“Apply” closes Property Windows
Normally, when you open a Property window or any non-modal score dialog, such as
Set Note Info or Score Settings, you can adjust the settings and click Apply to apply
the changes without closing the window. If this option is activated, clicking Apply
closes the window.
Show Position Cursor
If this option is activated the Project cursor position is shown as a vertical line in the
score. You can click and drag the line to move the cursor or hold down Ctrl/Cmd and
click anywhere in the score to move the cursor directly there.
Show pitch when inserting notes
If this option is activated the pitch of inserted notes is indicated.
Show Note Info by the Mouse
If this option is activated and you insert or drag a note in the score, a tooltip will
appear below the pointer, showing the current pitch and position. If you feel screen
redraws are too slow, you may want to turn this feature off.
Snap Slurs when dragging
If this option is activated, the endpoints of slurs will snap to notes when you draw or
move them.
Unlock Layout when editing single parts
If there are more than one part on a track, and you open score edit for one of these
parts, the other parts are displayed as “empty space” to preserve the layout. If this
option is activated, this empty space is avoided, so you can print this single part
without endless rests.
NOTE
Note that this option will erase the layout for the whole track! The next time you
open the entire track, the previous layout will be overwritten with the layout settings
you made for the single edited part.
Double-click on staff flips between full score/part
If this option is activated, double-clicking on a staff will switch between display of
either the whole track or the current part.
NOTE
Note that in this case, the Score Settings dialog will only open if you select the
“Settings...” option on the Scores menu.
Layout Tool Compatibility Mode
The behavior of the Layout tool was different in older versions of Nuendo. Activate
this option if you have an old project in which the Layout tool was used to ensure
that the project is displayed as expected.
Hide Notes beyond limits
If this option is activated, any notes outside the Note Limits range set in the Score
Settings dialog (Staff page - Options tab) will be hidden.
Computer Keyboard Note Entry: Legato
If this option is activated, the length of the previous note is changed on inserting
notes.
Computer Keyboard Note Entry: Require ALT-Key
If this option is activated, you must hold down Alt to insert notes.
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Computer Keyboard Note Entry: Use On-Screen Keyboard Keys
If this option is activated, you can insert notes by pressing the keys that correspond
to the note on the On-Screen Keyboard (qwerty).
Default Number of Bars per Staff
This is used in 2 cases:
●

In Edit Mode to set how many bars are shown across the page.

●

In Page Mode to decide how many bars there are shown across the page in a
new layout.

NOTE
When using the Auto Layout function, you will be asked for the maximum number of
bars across the page, overriding this setting.

Scores - Note Layer
If you are moving and editing notes, you might accidentally move other objects nearby. To avoid
this, you can assign different types of objects to different Note Layers (up to 3) and instruct
Nuendo to lock one or 2 of these layers, making them unmovable.
This page is where you specify to which layer each object type belongs. The actual locking of
layers is done on the extended toolbar of the Score Editor.

Transport
This page contains options related to playback, recording and positioning.
Playback Toggle triggers Local Preview
If this option is activated, you can use the Space on your keyboard to start/stop
“local” playback of the selected file in the Sample Editor or the Pool.
When the Sample Editor is not open or when there is no audio file selected in the
Pool, the Space still toggles the “global” project playback.
If this option is deactivated, the Space is used to start/stop playback of the project.
Show Timecode Subframes
If this option is activated, all frame based display formats (“.fps” and “.dfps”) will also
show subframes. There are 80 subframes per frame.
Timecode Input Scheme
You can enter a timecode value on the Transport panel. If you press Shift-P, a
specific timecode position is focused. Select one of the following options:
●

Full Timecode
Allows you to enter the timecode as a sequence of numbers. For example,
entering 010203 results in 00:01:02:03.

●

Starting at Hour Position
Allows you to enter the timecode per entry field, starting with hours.

●

Starting at Minute Position
Allows you to enter the timecode per entry field, starting with minutes.

Feet’n’Frames Count from Project Start
If you use any of the “Feet+Frames” display formats, you can activate this.
If this option is activated, time displays and rulers in Feet+Frames format will always
start with 0’00 at the beginning of the project - regardless of any Start offset settings
in the Project Setup dialog.
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User-definable Frame Rate
This is where you set the frame rate (the number of frames per second) for the
Display format “User”. This frame rate will then be used in every ruler for which you
select the User display format.
Return to Start Position on Stop
If this option is activated and you stop playback, the project cursor automatically
returns to the position where recording or playback last started.
If this option is deactivated and you stop playback, the project cursor remains at the
position where you stop playback.
If you click Stop again, the project cursor returns to the position where recording or
playback last started.
Stop playback while winding
You can use the winding functions during playback. If this option is activated, audio
playback is stopped as soon as you click Rewind or Fast Forward on the Transport
panel.
If this option is deactivated, audio playback will continue until you release Rewind or
Fast Forward.
Wind Speed Options
These options affect the fast forward/rewind speed.
●

If Adjust to Zoom is activated, the wind speed will be adapted to the
horizontal zoom factor.
If you zoom in very close for detailed editing, you probably do not want to
have a high fast forward/rewind speed. Because of this, the Speed Factor
does not have any effect in this mode. The Fast Wind Factor still applies
though.

●

If Fixed is activated, the wind speed will always be the same regardless of the
horizontal zoom factor.

●

Use the Speed Factor option to set the wind speed. You can set a value
between 2 and 50. The higher the value, the faster the wind speed will be.
If Adjust to Zoom is activated, this has no effect.

●

Use the Fast Wind Factor to set the wind speed multiple for fast winding.
If you press Shift while fast forwarding or rewinding, the wind speed will
increase. The increase in speed is a multiple of the Speed Factor. Meaning
that if you set the Fast Wind Factor to 2, the wind speed will be twice as fast.
If you set it to 4, the wind speed will be 4 times as fast, etc. You can set a value
between 2 and 50.

Cursor Width
Adjusts the width of the Project Cursor line.
Zoom while Locating in Time Scale
If this option is activated, you can zoom in or out by clicking in the Ruler and
dragging down or up.
Locate When Clicked in Empty Space
If this option is activated, you can move the Project Cursor by clicking anywhere in an
“empty” area of the Project window.
RELATED LINKS
Setting the Project Cursor Position on page 242
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Transport - Scrub
Scrub Volume
This lets you set the playback volume for the Scrub function in the Project window
and audio editors.
Use High Quality Scrub Mode
When you activate this option, effects are enabled for scrubbing and the resampling
quality is higher. However, scrubbing will be more demanding on the processor.
Use Inserts While Scrubbing
When you activate this option, you can activate insert effects for scrubbing with the
shuttle speed control. By default, insert effects are bypassed.

User Interface
This page contains options that allow you to adjust the default user interface colors.
Color Schemes
Allows you to adjust the color scheme for the application and the desktop cover.
●

Click one of the colors in the Choose Color Scheme section to apply a predefined color.

●

Click the field in the Choose Custom Color section to open the color selector
pane and select a custom color.

Custom Colors
Allows you to adjust the colors for the Project window and the editors and their
specific elements.
Track Type Default Colors
Allows you to adjust the colors for the different track types.
MixConsole Fader Colors
Allows you to adjust the colors for the level faders of the channel types in the
MixConsole.
MixConsole Rack Colors
Allows you to adjust the colors for the racks in the MixConsole.
MixConsole Channel Strip Colors
Allows you to adjust the colors for the channel strips in the MixConsole.
RELATED LINKS
Color Selector Pane on page 1165

VST
This page contains settings for the VST audio engine.
Default Stereo Panner Mode
This allows you to specify the default pan mode for inserted audio tracks (Stereo
Balance Panner, Stereo Dual Panner or Stereo Combined Panner).
Connect Sends automatically for each newly created Channel
When this option is enabled, creating a new audio or group channel will
automatically connect the send routing for existing FX channels. Note that this
option is disabled by default to save memory resources.
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Instruments use Automation Read All and Write All
If you deactivate this option, the Read and Write automation status in VST
instrument panels are not affected by the “Activate/Deactivate Read for All Tracks”
and “Activate/Deactivate Write for All Tracks” automation switches.
Mute Pre-Send when Mute
If this option is activated, sends set to “Pre-fader” mode will be muted if you mute
their channels.
Default Send Level
This allows you to specify a default level for your send effects.
Group Channels: Mute Sources as well
By default, when you mute a group channel no audio will pass through the group.
However, other channels that are routed directly to that group channel will remain
unmuted. If any of those channels have cue sends routed to other group channels,
FX channels or output busses, those will still be heard.
If Group Channels: Mute Sources as well is activated, muting a group channel will
cause all other channels directly routed to it to be muted as well. Pressing mute
again will unmute the group channel and all other channels directly routed to it.
Channels that were muted prior to the group channel being muted will not
remember their mute status and will be unmuted when the group channel is
unmuted.
NOTE
Group Channels: Mute Sources as well does not affect how mute automation is
written. Writing mute automation on a group channel only affects the group channel
and not channels routed to it. When writing the automation you will see the other
channels being muted when this option is checked. However, upon playback, only
the group channel will respond to the automation.
Delay Compensation Threshold (for Recording)
Nuendo features full delay compensation - any delay inherent in the VST plug-ins you
use will automatically be compensated for during playback. However, when you play
a VST instrument in realtime or record live audio (with monitoring through Nuendo
activated), this delay compensation may result in added latency. To avoid this, you
can click the Constrain Delay Compensation button on the toolbar or the Transport
zone of the Project window. This function tries to minimize the latency effects of the
delay compensation, while maintaining the sound of the mix as far as possible.
The Delay Compensation Threshold setting is a kind of “tolerance” setting for the
Constrain Delay Compensation function - only plug-ins with a delay higher than this
threshold setting will be affected by the Constrain Delay Compensation function. By
default, this is set to 0.0 ms, which means that all plug-ins will be affected when you
activate Constrain Delay Compensation. If you feel that a little latency is acceptable,
you can raise this threshold value.
Do not Connect Input/Output Busses When Loading External Projects
Activate this option to load external projects without automatically connecting their
input and output busses to the ASIO ports of your system. If you often work with
projects created on computers that have ASIO configurations different from the
configurations of your own system, this option prevents unwanted audio
connections.
Activate ‘Link Panners’ for New Tracks
Activate this to activate Link Panners by default for new tracks so that the channel
sends section always mirrors the Pan settings made in the channel fader section.
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Auto Monitoring
Determines how Nuendo handles monitoring (listening to the input signal during
recording). The following options are available:
●

Manual
This option allows you to turn input monitoring on or off by clicking the
monitor button in the track list, Inspector, or MixConsole.

●

While Record Enabled
With this option you will hear the audio source connected to the channel input
whenever the track is record-enabled.

●

While Record Running
This option switches to input monitoring only during recording.

●

Tapemachine Style
This option emulates standard tapemachine behavior: input monitoring in
Stop mode and during recording, but not during playback.

NOTE
The automatic monitoring options apply when you are monitoring through Nuendo,
or when you are using ASIO Direct Monitoring. If you are monitoring externally
(listening to the input signal from an external mixer, for example), select the
“Manual” mode and keep all audio monitor buttons turned off in Nuendo.
Warn on Processing Overloads
When you activate this option, a warning message is displayed as soon as the CPU
overload indicator (on the Transport panel) lights up during recording.

VST - Plug-ins
Warn Before Removing Modified Effects
If this option is activated, a dialog will appear whenever you remove an effect plug-in
for which you have made parameter changes, asking for confirmation as to whether
you really want to remove the effect.
If you do not want this dialog to appear and modified effects to be removed without
confirmation, leave this option deactivated.
Open Effect Editor after Loading it
If this option is activated, loading an effect or VST instrument in one of the plug-in
slots of the Send or Insert sections, for example, will automatically open the control
panel for the plug-in.
Create MIDI track when loading VSTi
This pop-up menu allows you to what specify happens when you add a VSTi in the
VST Instruments window. The following options are available:
●

Always
When this is selected, a corresponding MIDI track will always be created when
you add a VST instrument.

●

Do not
When this is selected, no MIDI track will be created when you add a VSTi in the
VST Instruments window. This is the behavior from earlier versions of Nuendo.

●

Always ask to
When this is selected, you will be asked whether a corresponding MIDI track is
created when you add a VSTi in the VST Instruments window.
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Synchronize Plug-in Program Selection to Track Selection
If you route multiple MIDI tracks to multi-timbral instruments and activate this
option, track selection and plug-in program selection are synchronized.
Suspend VST 3 plug-in processing when no audio signals are received
If this option is activated, VST plug-ins will not consume any CPU power in passages
where no audio is passing through them. This can improve system performance
noticeably.
NOTE
Note however that this might lead to situations where you loaded more plug-ins in
Stop mode than the system will be able to play back simultaneously. As a safety
measure, try playing back the part of your project which contains the largest number
of audio events to make sure that your computer system can handle the current
number of VST plug-ins.
Plug-in Editors “Always on Top”
If this option is activated, the control panels for effect plug-ins and VST instruments
will always be shown on top of other windows.

VST - Control Room
This page contains settings for the Control Room.
Show Control Room Volume in Transport Panel
If this option is activated, the Transport panel will display the Control Room Volume if
the Control Room is enabled. If the Control Room is disabled, the volume of the Main
Mix bus will be shown on the Transport panel.
Auto Disable Talkback Mode
Allows you to specify if Talkback is disabled during recording, during playback and
recording, or not at all.
NOTE
Set the Talkback DIM level to 0 dB so as not to radically change the mix level when
punching in and out of record mode.
Use Phones Channel as Preview Channel
If this option is activated, the Phones channel will be used for monitoring. If this
option is deactivated, the Monitor channel in the Control Room will be used.
Dim Cue during Talkback
If this option is activated, the cue mix heard in a studio will be dimmed (by the
amount set in the Talkback Dim Level field in the Control Room) for as long as the
Talkback channel is used. If this option is deactivated, the cue mix level remains the
same during Talkback.
Exclusive Device Ports for Monitor Channels
If this option is activated, the port assignment for Monitor channels is exclusive. If
your scenario does not require you to assign ports to several Monitor channels, it is
recommended to activate this option. This way you can make sure that you do not
accidentally assign ports to inputs/outputs and Monitor channels at the same time.
NOTE
This setting is saved with the Control Room presets.
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Reference Level
The reference level is the level that is used in calibrated mixing environments, such
as film dubbing stages. Use this option to specify the reference level that can be
assigned to the Control Room level.
NOTE
You can also manually adjust the reference level in the Control Room settings.
Main Dim Volume
Use this to set the amount of gain reduction applied to the Control Room channel
when the DIM button is activated.

VariAudio
Inhibit warning when changing the Sample Data
When you are modifying audio material that is used in several places in the project in
the Sample Editor, a warning message is shown. This message can be deactivated: If
you activate the Please, don’t ask again checkbox, the message will not be
displayed in the future (when editing the pitch or time of audio material that is used
several times in one project).
To display this message again, and thus be informed whether the audio is used in
other places, deactivate this option.
Inhibit warning when applying Offline Processes
When you apply offline processes, such as Envelope or Normalize, to audio material
that is used in several places in the project, a warning message is shown. This
message can be deactivated: If you activate the Please, don’t ask again checkbox,
the message will not be displayed in the future.
To display this message again, and thus be informed whether the audio is used in
other places, deactivate this option.

Video
Extract Audio on Import Video File
If this option is activated and you import a video file, the audio data of the video is
automatically extracted and saved as a separate audio clip.
Thumbnail Memory Cache Size
The value entered here determines how much memory is available for displaying
thumbnails. The image of a video is buffered in the thumbnail memory cache.
Whenever you move to another image and there is no memory capacity left, the
“oldest” picture in the cache is replaced by the current one. If you have long video
clips and/or work with a large zoom factor, you may have to raise this value.
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A
AAF files 1124
ACID® loops 533
Action Target 970
Length 970
Name 972
Position 970
Set Color 972
Track Operation 971
Trim 972
Activate Project 93
Activate Read/Write for all tracks 705
Activate tempo track 976
Active (Activating network) 1026
Active TrackVersion 184
Adapt to Zoom 75
Grid type 81
ADAT Lightpipe 1047
Add Track 640
Add Track dialog 158
Add WAN Connection 1028
Adding chords 904, 907
ADR
About 354
Defining takes 361
Modes 354
Record 364
Record-enabling target tracks 363
Rehearse 363
Review 364
Routing 362
Setting up 360
Show Dialogue 363
Video overlays 362
ADR environment
Setting up 361
ADR panel 354, 356
ADR Setup 357
ADR Track Assignment 361
AES/SPDIF Digital Audio 1047
AES17
Meters 434
AES31 files 1127
AIFC files
Exporting 1015
AIFF files
Exporting 1015
Algorithms
Limitations 490
Time-stretching 488

Aligning
Tempo matching audio 539
Using modifier keys 203
Aligning audio
Tempo matching 539
To other audio events 205
To selection ranges 205
To the cursor 205
Aligning file and project attributes
Pool 606
Alignment level (Meters) 434
All MIDI Inputs 20
Allow Editing in Results List 1200
Alternative Key Sets 1141
Ambisonics
About 683
Binaural playback 686, 689
Bypassing head tracking 691
Editing 683
Exporting 693
Format conversion 686
Format converter 694
GoPro Player VR Remote 692
Head-Locked Signal 691
Mixing 683
Monitoring 686
Monitoring via headphones 689
Monitoring via speakers 690
Panner plug-ins 684
Playback 686
Routing 683, 684
Side-chain input 691
Third-party plug-ins 689
VST AmbiConverter 694
VST MultiPanner 685
Appearance
Colors 1207
Metering 1201
Apple Remote 761
Archive
Prepare 96
Arranger track
Flattening 320, 322
Inspector 129
Track controls 130
Articulations 872, 875
Adding sound slots 874
Editing on the info line 881
Groups 875
Inserting on the controller lane 880
Mapping sound slots 876
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Articulations (continued)
Remote settings 877
Set Remote Keys 878
ASIO Direct Monitoring 19, 263
ASIO Latency Compensation Active by Default 1202
ASIO ports
Using for data only 1072
ASIO-Guard 1178
Aspect ratio
Video Player window 1081
Attribute Filter
Applying in the MediaBay 631
Context menu search 631
MediaBay 630
Attribute Inspector
Color scheme 633
MediaBay 634
Attributes
About 632
Defining 637
Editing in the MediaBay 634
Managing lists 636
MediaBay 630
Attributes for elements
Pool 602
Audio
Exporting 1008
Handling 195
Mixing down 1008
Overlapping 175
Placing to picture 1088
Pull-down 1097
Pull-up 1097
Rendering 1002
Zooming 76
Audio Alignment 539
Audio Assets
Exporting 501
Exporting to a Game Audio Engine 501
Audio Click
Render 255
Audio clock
About 1047
Audio Connections 22
About 22
Editing 37
Exclusive port assignment 421
Presets 30
Audio editing to picture 1084
Audio effects
Surround 647
Using VST System Link 1074
Audio events
About 194
Aligning 205
Auditioning 200
Processing with ReConform 1114
Audio files
Previewing in MediaBay 623
Audio Functions 491
Detect Silence 491
Spectrum Analyzer 493
Statistics 496

Audio hardware
Connections 12
Externally clocked 17
Audio Part Editor
Lower zone 66
Audio parts
Aligning 205
Auditioning 200
Creating 198
Audio performance
Optimizing 1176
Audio Pre-Record Seconds 1201
Audio processing
Pool 603
Audio Processing
Direct Offline Processing 467
Audio Recording 266
Downmix 267
Pre-Record Time 268
Preparations 265
RAM Requirements 266
Record File Format 265
Record Folder 265
Record Modes 267
Recovering 269
Recovering recordings 268
Undo 268
With Effects 267
Audio regions
About 197
Audio snippet markers 1115
Audio tracks 101
Inspector 101
Track controls 107
Audition chords 909
Audition through MIDI Inserts/Sends 1195
Auditioning
Audio events 200
Audio parts 200
Using key commands 598
Auto Disable Talkback Mode 1210
Auto Edit (9-Pin) 1059
Auto fades
Global settings 315
Track settings 315
Auto join
Automation 714
Auto layout
Don’t hide first staff 1203
Auto Monitoring
Manual 1207
Tapemachine Style 1207
Auto Punch
Preview options 718
Auto Save 95, 1194
Auto Save Internal 1194
Auto Select Events under Cursor 1182
Auto Track Color Mode 1193
Auto-Scroll 243
Crossfades 307
Suspend 243
Automatable parameters
Controlling with Quick Controls 745
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Automatic Hitpoint Detection
Enabling 1184
Automatic scales 910
Automatic voicings 911
Automatically generating new audio clips
Pool 606
Automation
About 695
Activating Gaps 716
Activating Loop 715
Activating Preview 717
Activating To End 715
Activating To Punch 715
Activating To Start 715
Auto join 714
Bézier curves 699
Bottom-Top Panning 658
Continuous fill 716
Drawing Fill manually 716
Elevation patterns 668
Fill options 714
Freeze Trim 709
Functions pop-up menu 710
Initial value 704
Join now 713
Join options 713
Jump curves 695
Merge Modes 721
Object Mode 681
One Shot 716
Preview options 717
Punch Log 718
Quick scaling 701
Ramp curves 695
Read 695
Show options 720
Smooth transitions 699
Static value line 695
Suspend options 719
Suspend Read 719
Trim 708
Virgin territory 704
VST MultiPanner 662
Write 695
Automation data
Cleaning 709
Deleting Automation Spikes 710
Editing 698
Reducing Automation Events 709
Removing 702, 709
Selecting 699
Automation Event Editor
Compress Left 700
Compress Right 700
Move Vertically 700
Scale Around Absolute Center 700
Scale Around Relative Center 700
Scale Vertically 700
Stretch 700
Tilt Left 700
Tilt Right 700
Automation Follows Events 1182

Automation modes
About 705
Auto-Latch 707
Cross-over 707
Touch 706
Automation panel
About 705
Read buttons 705
Write buttons 705
Automation passes 711
Activating 711
Deactivating undo branches 713
Undoing 712
Undoing branches 712
Automation tracks
About 703
Assigning parameters 703
Hiding 703
Muting 704
Removing 703
Showing 703
Automation warning markers 1115

B
Back up Project 96
Background Color Modulation 1191
Bank assignments 778
Basic chord types
Applying to selected notes 821
Batches Processing
Direct Offline Processing 474
Beat Calculator 984, 985
Bézier curves
Automation 699
Bounce MIDI 789
Bounce Selection 195
Braces
Showing in Edit Mode 1203
Branches
Undo history 84
Broadcast Wave files
Exporting 1013
Broadcast Wave Files
Embedded information 1202
Buffer
Settings 1177
Bulk Dumps 865
Busses
Adding 29
Child busses 29
Bypass
VST MultiPanner 661

C
Cadence mode
Chord Assistant 905
Complexity filters 905
Change EDL 1106
Adding 1107
Deleting 1108
Extending entries 1110
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Change EDL (continued)
Generating 1109
Healing entries 1110
Saving 1109
Change Release Length
Note Expression Event Editor 892
Changing object names
Pool 591
Channel linking 382
Channel names
Searching 374
Channel overview
MixConsole 366
Channel racks 378, 392
EQ 398
Filters 395
Gain 396
Inserts 396
Phase 396
Pre 395
Routing 393
Sends 408
Strips 400
Channel rotation 890
Channel settings 387
Copying 392
Channel strip rack 400
Compressor 400
EQ position 400
Gate 400
Limiter 400
Presets 407
Saturation 400
Transformer 400
Channel types
MixConsole 375
Channels
Adding to link groups 382
Connecting with VCA faders 418
Controlling with VCA faders 414
Disconnecting from VCA faders 418
Linking 379
Removing from link groups 382
Chase Events 256, 1195
Chatting options 1042
Child busses 29
Surround configurations 651
Chord Assistant 905, 924
Assigning chords 927, 928
Cadence mode 905
Circle of Fifths 924, 925
Common notes mode 905
Complexity 905
Gap mode 905
Proximity 924
Chord Editor 903
Adding chords 907
Assigning chords 927
MIDI Input 905
Chord events 903
Adding 904
Adding chords 904
Assigning to MIDI effects or VSTis 913

Chord events (continued)
Auditioning 909
Chord type 903
Converting to MIDI 913
Editing 904
Extracting from MIDI 917
Getting suggestions 907
Mapping offset 911
Resolving Display Conflicts 910
Tension 903
Voicings 911
Chord Font 1192
Chord Pad Controls 921
Chord Pad Settings
Pad layout 940
Players 935
Remote Control 931
Chord Pads 920–924
Adaptive voicing 938
Assigning chords 927–929
Context menu 922
Controls 924
Creating events 941
Functions menu 923
Moving and Copying 929
Multiple tracks 940
Pads remote range 932, 935
Pattern player 939
Players 938
Playing back 930
Preparations 923
Presets 941
Recording chords 930, 931
Remote assignment 933
Saving presets 941
Setting up 924
Voicings 938
Zone 924
Chord symbols 1192
Chord track 130
About 902
Assign Pads 929
Controlling MIDI or audio playback 914
Inspector 131
Live transform 914
Track controls 132
Chord voicing
Changing 819
Chords
Changing pitch 819
Changing voicing 819
Editing 820
Inserting 821
Click Pattern 246
Setting up 248
Signature events 248
Click Pattern Editor 247
Click Sounds
Custom Sounds 253
Click Track
Render 255
Clip editing
Pool 599

1215

Index

Clip packages
About 196
Creating (Exporting) 223
Importing 283
Clips
Renaming 591
Clock sources 1047
Color Selector Pane 1165
Coloring
Note events 798
Tracks 169
Colorize Event Background 1190
Colorize Only Folder Track Controls 1193
Colorize Track Controls 1193
Colors
Events 1166
Parts 1166
Preferences 1207
Project 1168
Track Controls 1167
Tracks 1166, 1167
User Interface 1165
Colors for Additional Meanings
Scores 1203
Committing changes 1040
Common notes mode
Chord Assistant 905
Complexity filters 905
Complexity filters
Cadence mode 905
Common notes mode 905
Compress Left
Automation Event Editor 700
Controller Event Editor 831
Tempo Event Editor 978
Compress Right
Automation Event Editor 700
Controller Event Editor 831
Tempo Event Editor 978
Compressor
Strip module 400
Configuration
Preferences 1182
Conforming
Audio to picture 1085
EDL files 1086
Multi-channel media 1086
OMF 1086
Connect Sends automatically for each newly created
Channel 1207
Connecting
Audio 12
MIDI 19
Constrain Delay Compensation 732
Continuous controllers
Controller display 825
Controller lane 829
Continuous Fill
Fill options 716
Control link 379, 382
Control Room 420
Adding channels 420
Channels section 425

Control Room (continued)
Cue channels 425
Downmix Presets section 427
Exclusive port assignment 421
External section 424
Input gain 430
Input phase 430
Insert effects 430
Inserts 430
Main 423
Main mix output 421
Monitor Sources section 424
Monitors section 426
Opening 420
Outputs 421
Phones section 427
Right zone 73
Routing 421
Control Room channels 421, 425
Adding 420
Control Room 428
Cues 422
External inputs 422
Metering 423
Monitor sources 422
Monitors 421, 430
Phones 422
Talkback 423, 430
Control Room Volume
Showing in Transport Panel 1210
Controller curves
Smart controls for scaling 831
Controller Data
Thinning Out 794
Controller display 823
Adding events 825
Continuous controllers 825
Deleting events 832
Drum Editor 844
Editing events 826
Editing events with Draw tool 828
Editing events with Line tool 827
Key Editor 814
Moving events 832
Controller Event Editor
Compress Left 831
Compress Right 831
Move Vertically 831
Scale Around Absolute Center 831
Scale Around Relative Center 831
Scale Vertically 831
Stretch 831
Tilt Left 831
Tilt Right 831
Controller events 883
Controller lane
Continuous controllers 829
Editor 832
Inserting articulations 880
Presets 825
Selecting event types 824
Setting up as preset 825
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Controller settings
Global settings 887
Controllers
Selecting 833
Showing 1193
Convert to Real Copy 215
Converting chord events to MIDI 913
Counter shots
VST MultiPanner 666
Create Audio Images During Record 1201
Create Chord Symbols 917
Create MIDI track when loading VSTi 1209
Creating gaps
Automation 704
Cross-hair cursor 82, 1189
Crossfades
Auto Zoom 307
Auto-Scroll 307
Changing the length 312
Creating 306
Editing in dialog 307
Equal Gain 307
Equal Power 307
Move Audio 311
Move Fade 311
Nudging 311
Overlap 310
Presets 307
Resizing 311
Simple Crossfade Editor 307
Splice Point 310
Symmetric Fades 307
CSV files
About 347
Cue Mix
Setting up 432
Cue Sends 433
Adjusting the volume 433
Cue mix 432
Cursor
Setting 242
Cursor Width 1205
Custom Chord Symbols 1192
Customizing
Colors 1165
Info line 1161
Inspector 1161
Menu 1162
Meter Colors 1164
Toolbars 1161
Transport panel 1161
User Interface Colors 1165
Cut Head 212
Cut Tail 212
Cycle Follows Range Selection 1182
Cycle markers
About 334
Editing with tools 335
Using 334
Zooming 78, 335
Cycle recording 261

D
Data on Folder Tracks
Showing 1193
DC Offset
Removing 483
Deactivate Read/Write for all tracks 705
Deactivating undo branches
Automation 713
Deep Track Folding 1188
Default MIDI Editor 1190
Default permissions 1032
Delay compensation
Constraining 732
Threshold for Recording 1207
Delete Overlaps 1182
Deleting
Continuous Controllers 793
Controllers 793
Doubles 793
MIDI controllers 793
Deleting Overlaps
Poly (MIDI) 792
Poly (Mono) 792
Designating a new pool record folder
Pool 602
Detect Silence
Audio Functions 491
Device panels
About 782
Device ports
Selecting for busses 29
Dim Cue during Talkback 1210
Direct Offline Processing
About 467
Applying 471
Applying permanently 477
Applying to multiple events 472
Auto Apply 472
Batches 474
Bypassing 477
Copying 477
Deleting 476
Envelope 478
Extend Process Range 475
Fade In 479
Fade Out 479
Favorites 473
FX Chain presets 475
Gain 479
Key Commands 487
Modifying 476
Normalize 480
Phase Reverse 480
Pitch Shift 481
Pool 603
Remove DC Offset 483
Resample 484
Reverse 484
Silence 484
Stereo Flip 484
Tail 475
Time Stretch 485
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Direct Offline Processing (continued)
Toolbar 470
Track Presets 475
Using key commands 486
Window 469
Workflow 468
Direct Routing
About 409
Automatic downmixing 410
Setting up 409
Disable Acoustic Feedback during Playback 1186
Disable Track 174
Display format
Ruler 48
Display line
Fader section 381
Display Object Selection tool after Inserting Symbol
1203
Dissolve markers 1115
Dithering
Applying 457
Effects 457
Divider
Project window toolbar 44
Dolby Atmos
About 676
Bed mixing 677
Channel routing 676
Connecting a Dolby RMU 678
Connecting objects to output busses 679
Defining objects 678
Multi-object busses 680
Object Mapping 678
Object routing 681
Object-based mixes 677
Object-based mixing 681
Output busses 676
Preparations 678
RMU 677
VST MultiPanner 677
Double-Click on staff flips between full score/part 1203
Double-Click Symbol to get Draw tool 1203
Drag Delay 1182
Draw tool
Drawing note events 815
Drop-Frame
Video 1085
Drum Editor 833
Controller display 844
Info line 842
Lower zone 66
Note display 843
Status line 842
Toolbar 836
Drum maps 850, 853
Key Editor 821
Selecting 846
Setting up 851, 852
Drum sounds 845
Changing the Note Length 848
Setup 845
Visibility 846

Drum Sounds
Settings 852
Drum Visibility Agents 836, 846
Dump request messages
MIDI SysEx Editor 865
Duplicating
Events 214
Tracks 173
Dynamics
Editing 828

E
Edge Hints
Using 1194
Edit Decision Lists
About 345
Edit History dialog 83
Branches 84
Editing
Project window info line 50
Editing events
Group editing 216
Editor Content Follows Event Selection 1190
Editor Inspector
Opening 55
Score 56
Switch Score Editor Inspector Content 56
EDL
Adding for ReConform process 1107
Changing timecodes with ReConform 1108
Deleting for ReConform process 1108
ReConform 1105
EDL entries
Extending with ReConform 1110
EDL files
About 345
Effect parameters
Track Quick Controls 743
Effect Plug-in Presets
Loading in MediaBay 639
Effects
About 441
Channel configuration 448
Comparing settings 459
Control panel 458
Copying presets 462
Direct Offline Processing 467
Dithering 457
Exporting system component information files
465
External effects 458
Extracting insert effect settings from track presets
464
Insert effects 441, 443
Managing system components 465
Multi-channel configuration 448
Pasting presets 462
Plug-in delay compensation 443
Pre/Post fader sends 453
Presets 459
Presets browser 460
Routing 448, 452
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Effects (continued)
Saving insert presets 463
Saving presets 461
Selecting presets 460
Send effects 441, 451
Setting up the channel configuration 448
Side-chain inputs 455
System Component Information window 464
Tempo sync 443
VST 3 442
élastique algorithm
About 488
Enable Record on Selected Audio Track 1188
Enable Record on Selected MIDI Track 1188
Enable Solo on Selected Track 1188
Enable Track 174
Enlarge Selected Track 172, 1188
Envelope
Direct Offline Processing 478
Realtime processing 315
Envelope editor
Sampler Control 581
EQ
Channel racks 398
Presets 400
EQ position
Strip module 400
Equal Gain
Crossfades 307
Equal Power
Crossfades 307
Equalizer curve
MixConsole 366
Event Data on Small Track Heights
Showing 1190
Event Details
Showing 1193
Event display
About 46
Editing events 864
Folder tracks 176
Modifying on folder tracks 176
Project Browser 995
Event lengths
Changing with Trim tool 818
Event list
Editing events 864
Filtering events 864
Event name
Showing 1190
Event Volume Curves
Showing 1191
Events
About 194
Copying and Pasting 213
Creating new files from events 195
Displaying on folder tracks 176
Duplicating 214
Editing 199
Envelopes 315
Gluing 213
Group editing 216
Grouping 216

Events (continued)
Locking 217, 218
Move to 203
Moving 202
Moving via Info Line 203
Moving with Nudge 202
Moving with Object Selection 202
Muting 218
Normal resizing 210
Pasting 213
Removing 202
Renaming 206
Renaming from list 206
Repeating 214
Resizing 209
Resizing with Object Selection 210
Resizing with Scrub 211
Resizing with Trim 211
Sizing Applies Time Stretch 210
Sizing Moves Contents 210
Sliding the contents 215
Splitting 212
Splitting repeatedly 212
Exclusive Device Ports for Monitor Channels 1210
Export Audio Mixdown 1007
AIFC files 1015
AIFF files 1015
Audio Engine Output section 1020
Broadcast Wave files 1013
Channel Batch Export 1009
Channel selection 1009
Channel selection section 1009
Cycle Marker Selection 1010
Defining Naming Schemes 1012
Export Cycle Marker(s) 1010
File Format section 1013
File Location section 1010
File name conflicts 1012
Flac files 1019
Import Into Project section 1021
MP3 files 1016
MXF files 1019
Naming Scheme dialog 1011
Ogg Vorbis files 1019
Post Process section 1022
Real-Time Export 1020
Surround mixes 676
Wave 64 files 1019
Wave files 1013
Windows Media Audio files 1017
Exporting
AAF 1124
AES31 1127
MIDI files 164
OMF 1120
OpenTL file 1129
Profiles 1173
Selected tracks 163
Track archives 163
Expression Map Setup 872
Expression maps 871
Creating 873
Extracting from VST instruments 878
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Expression maps (continued)
Inspector 873
List Editor 882
Loading 879
Project window 873
Saving 879
Score Editor 880
Setup 872
External effects
About 31, 458
Favorites 36
Freezing 36
Missing plug-ins 36
Setting up 32
External instruments
About 31
Favorites 36
Freezing 36
Missing plug-ins 36
Setting up 34
External monitoring 263
Extract Audio on Import Video File 1211
Extracting
Audio from video 282, 1083
MIDI Automation 794
Extracting chord events from MIDI 917

F
Fade In
Direct Offline Processing 479
Fade Out
Direct Offline Processing 479
Fader section (MixConsole) 385
Fades
Apply defaults 303
Auto fades 313
Editing in dialog 304
Presets 304
With Range Selection tool 303
Favorites
Adding 613, 616
Direct Offline Processing 473
Media rack 612
Feet’n’Frames Count from Project Start 1205
File Browser
Media rack 612
File Extensions
Showing in results list 1200
Fill Loop 215
Film Transfers
About 1094
Filter Target
Color Name 967
Combining Condition Lines 968
Combining Filter Types 963
Container Type 962, 963
Length 966
Media Type 961
Name 964
Position 964, 965
Property 967, 968
Filter Track Types 47

Find Tracks 47
Firewall 1025
Fixed lengths 791
Fixed tempo
Mode 975
Fixed Tempo
Mode 983
Setting up 983
Fixed velocity 791
Flac files
Exporting 1019
FLAC files
Importing 279
Flattening
Arranger track 320, 322
Realtime Processing 541, 560
Folder parts 199
Folder tracks 139
Displaying events 176
Inspector 139
Modifying event display 176
Track controls 139
Follow Chord Track 915
Auto 915
Chords 915
Directly 916
Scale events 916
Single Voice 915
Synchronizing Track Data 916
Using 914
Frame count 1045
Frame rates
Drop-Frame 1085
Mismatch 1079
Synchronization 1045
Video 1079
Frames
Subframes 1084
Free Run mode
ADR 354
Freeze
VST instruments 730
Freeze MIDI Modifiers 770
Freeze Trim
Automation 709
FX chain presets 397
FX Chain presets
Direct Offline Processing 475
FX Chain Presets
Loading in MediaBay 639
FX channel tracks 133
Adding 451
Inspector 133
Setting up 30
Track controls 137
FX Plug-in Presets
Loading in MediaBay 639

G
Gain
Direct Offline Processing 479

1220

Index

Game Audio Connect 498
Exporting Audio Assets 501
Network Communication 500
Perforce 500
Renaming assets 501
Renaming events 206
Settings Dialog 499
Gap mode
Chord Assistant 905
Gaps
Fill options 716
Gate
Strip module 400
Generic Remote 752
Get exclusive access (lock track) 1041
Global IP Network 1028
Global track controls 46
Filter Track Types 47
Find Tracks 47
Global workspaces 1158
Gluing
Events 213
GoPro Player VR Remote 692
Grid type
Project window 81
Groove quantizing 293
Group channel tracks 140
Inspector 140
Track controls 144
Group channels
Adding insert effects 445
Routing 394
Setting up 30
Group Channels - Mute Sources as well 1207
Group editing 216
Grouping events 216
Guest user 1032
Guide track
ADR 360

H
Hardware controls
Activating pick-up mode 747
Hardware setup
Control panel 13
Healing
ReConform 1110
Hermode tuning 769
Hide muted Notes in Editors 1186
Hide Notes beyond limits 1203
High Quality Scrub Mode 1207
History
Edit History 83
MixConsole 371, 375
Project window 41
Hitpoints
About 523
Showing 1191
HMT Type
Hermode tuning 770
Horizontal Snap
Note Expression Event Editor 892

Hub 86
Deactivating 87
Using 1194

I
I-notes (Input notes) 853
Immersive video playback 691
Importing
AAF 1124
AES31 1127
Audio files 279
Audio from video files 282
Compressed audio files 279
FLAC files 279
MIDI files 164, 284
MP3 files 279
MPEG files 279
MXF 1125
Ogg Vorbis files 279
OMF files 1120
OpenTL file 1129
Profiles 1173
REX files 283
Track archives 163
Tracks from a project 160
Tracks from a track archive 161
Tracks from projects 161
Video files 1078
WMA files 279
In-Place Editor
Editing controllers 868
Editing MIDI notes 868
Toolbar 868
Independent track loop
Audio Part Editor 570
Independent Track Loop
MIDI 803
Indicate Transpositions
Key Editor 331
Info line
Editing articulations 881
Project window 50
Transpose 332
Inhibit warning when applying Offline Processes 1211
Inhibit warning when changing the Sample Data 1211
Initial value
Automation 704
Input busses
Adding 29
Renaming 27
Routing 394
Surround configurations 654
Input gain
MixConsole 396
Input levels 13
Input ports 18
Inputs
Meter position options 390
Insert effects 441
About 443
Adding to busses 444
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Insert effects (continued)
Adding to Group channels 445
Routing 444
Insert markers 1115
Insert Reset Events after Record 1195
Inserting and finding media
Pool 597
Inserts
FX chain presets 397
MIDI 771
MixConsole 396
Monitor channels 430
Talkback channel 430
Using while scrubbing 1207
Inspector
About 53
Editor Inspector 55
Expression maps 873
Settings Dialog 57
Surround Pan 659
Synchronizing track and channel visibility 61
Track Inspector 54
Track Visibility 59
Visibility 59
VST MultiPanner 659
Zones Visibility 61
Inspector network controls 1039
Inspector Sections
Showing/Hiding 57
Instrument Freeze 730
Instrument parameters
Track Quick Controls 744
Instrument Presets
Applying 641
Loading in MediaBay 638
Results 641
Instrument tracks 108
Inspector 109
Track controls 114
Instruments use Automation Read All and Write All
1207
Interpolate Audio Waveforms 1191

J
Join now
Automation 713
Join options
Automation 713
Join project 1037

K
Keep Crescendo Symbols Horizontal 1203
Keep moved Notes within Key 1203
Key commands
About 1137
Alternative Key Sets 1141
Default 1142
Importing 1140
Loading 1140
Modifying 1137
Removing 1138

Key commands (continued)
Resetting 1141
Saving 1139
Searching for 1138
Key Editor 804
Controller display 814
Info line 812
Inspector 812
Lower zone 66
Note display 814
Note expression data 822
Status line 811
Toolbar 806
Keyboard focus
Activating for a zone 75
Zones 74
Keyboard navigation
MixConsole 412
Knob Mode 1186

L
LAN 1024
Setting up 1028
Lanes 177
Assembling a perfect take 177
Assembling operations 178
Audio Part Editor 569
Language (Preferences) 1194
Latch Buffer
Note expression 891
Latency
Optimizing 1176
VST System Link 1067
Layout Tool Compatibility Mode 1203
Left Locator 241
Left zone 53
Inspector 53
Track Visibility 59
Visibility 59
Zones Visibility 61
Legato 790
Legato Mode - Between Selected Notes Only 1187
Legato Overlap 1187
Length
Crossfades 312
Length Adjustment 1195
Level meters (MixConsole) 390
Limiter
Strip module 400
Line tool 817
Drawing note events 816
Editing controller display events 827
Linear Time Base 975
Link groups 379
Adding channels 382
Changing settings 382
Creating 381
Q-Link 383
Removing channels 382
Settings 380
Unlink 382
Link Project and Lower Zone Cursors 67
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List Editor 854
Editing events 864
Editing operations 863
Event display 862
Event list 861
Filters bar 860
Inserting events 863
Showing/Hiding events 860
Status line 860
Toolbar 855
Value display 862
Listen
MixConsole 387
Live transform
Chord track 914
Loading changes 1041
Loading Multi-Track Presets 192
Locate When Clicked in Empty Space 1205
Locators 241
Setting 242
Setting ranges 241
Lock
Transpose track 330
Lock Event Attributes 218, 1182
Lock Punch Points to Locators 245
Lock Record 275
Logical Editor
About 943
Actions 954
Functions 953
Presets 957
Logical Filter
Advanced Text Search 630
Applying 629
MediaBay 628
Looping
Audio Part Editor 570
Fill options 715
Loops and Samples
Loading in MediaBay 637
Loudness
About 434, 435
LU 435
LUFS 435
Measuring short-term loudness during playback
439
Measuring short-term loudness offline 440
Meter 436
Normalizing on export 440
Settings 438
Statistics 496
Units 435
Loudness track 156, 439
Lower zone 62
Chord Pads 63
Editor 66
Link Project and Lower Zone Cursors 67
MixConsole 64
Sampler 65
Selecting a MIDI editor 67
Setting up 63

M
M&E track
ADR 360
Machine control
About 1044
Input source 1057
Output destinations 1053
Output settings 1054
Preferences 1056
macOS
Port activation 28
Port selection 28
Macros 1138
Main Dim Volume 1210
Main mix
Output 421
Setting up 29
Managing media files
Pool 586
Map Input Bus Metering to Audio Track 1200
Mapping offset 911
Marker track 341
Inspector 146
Track controls 146
Marker tracks 145
Marker window
About 335
Functions 336
Marker list 336
Markers
About 334
ADR 356
Attributes 337
CSV files 347
Cycle markers 334
Exporting 345
Exporting CSV files 350
Exporting markers as track archive 353
Exporting via MIDI 352
IDs 341
Importing 345
Importing an EDL 346
Importing markers as track archive 353
Importing via MIDI 352
Position markers 334
ReConform 1115
Settings 337
Working with EDLs 346
Material
Preserving with ReConform 1113
Max. Record Time Display 275
Maximum Backup Files 1194
Maximum Items in Results List 1200
Maximum Undo Steps 1194
Media rack
Adding Favorites 613
Favorites 609, 612
File Browser 612
Instruments tile 612
Results 609, 610
Right zone 71, 72
Right Zone 607, 609
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MediaBay
About 607
Adding Favorites 616
Allow Editing in Results list 635
Attribute Filter 630, 631
Attribute Inspector 632, 634
Attributes 630
Defining user attributes 637
Editing attributes 634
Editing attributes of multiple files 635
Favorites 617
File Browser 615
Filters 628, 630
Finding file locations 619
Hiding sections 615
Instrument Presets 641
Key commands 646
Logical Filter 628–630
Media Type Filter 619
Media Types 620
Navigation controls 615
Previewer 623
Rating filter 621
Refresh Views 617
Related windows 640
Reset Filter 632
Results 618, 619, 623
Scanning 616
Scanning operations 615
Select Media Type 619
Settings 645
Show in Explorer/Reveal in Finder 619
Showing sections 615
Shuffle Results 619
Tagging 634
Text search 621, 622
Track Presets 641
Using Media Files 637
Volume databases 643–645
Window 613
Write-protected files 635
MediaBay results
Managing media files 619
Resetting 623
Setting up 618
Shuffling 619
Merge MIDI in Loop 786, 787
Metadata
Author Name 1195
Company Name 1195
Meter
Right zone 73
Meter Colors 1164
Meter peak options 390
Hold forever 390
Hold peaks 390
Meter position options 390
Input 390
Post-Fader 390
Post-Panner 390
Meter section
MixConsole 434, 435
Project window 434

Metering
About 434
Meters
AES17 434
Alignment level 434
Peak meter display 434
RMS display 434
Scale standards 434
Settings 390
Meters’ Fallback 1200
Meters’ Peak Hold Time 1200
Metronome 246, 250, 251, 253
Click Pattern Editor 247, 248
Setup window 249
Metronome Click
Setting up 248
Metronome Setup 249
Click Pattern 246
Click Patterns 253
Click Sounds 251
General 250
Mic Signal Track
ADR 360
MIDI channels
Send effects 772
Separating for drum map sounds 853
MIDI Click
Render 255
MIDI clock
Destinations 1058
Synchronization 1047
MIDI Controller Automation 721
Setting up 722
MIDI controller parameters
Note Expression 884
MIDI devices
Defining new for patch selection 777
Device Manager 776
Editing patches 779
Installing 777
Selecting patches 779
MIDI Display Resolution 1195
MIDI editors
Cutting and pasting 798
MIDI effects
About 771
Inserts 771
Presets 774
Sends 772
MIDI events
About 197
MIDI Export Options 1197
MIDI files 164, 284
Previewing in MediaBay 624
MIDI Filter 1199
MIDI Import Options 1197, 1198
MIDI Input
Chord Editor 905
MIDI Inputs
Setting up 270
MIDI insert effects
Recording 772
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MIDI interface
Connecting 19
MIDI Latency Mode 1195
MIDI Loops
Previewing in MediaBay 625
MIDI Max. Feedback in ms 1195
MIDI Merge Options 787
MIDI modifiers 766
Hermode tuning 769, 770
Random variations 768
Range 768
MIDI note numbers 852
MIDI notes
Transpose (function) 785
MIDI outputs
Send effects 772
MIDI pan
MIDI track parameters 764
MIDI parts
Creating 199
Handling several 802
Independent Track Loop 803
Processing 797
MIDI Port Setup 269
MIDI ports
Setting up 19
MIDI Record Catch Range in ms 1202
MIDI Record Mode 273
MIDI Recording
Channel and Output 270
Continuous messages 272
Different types of messages 272
Instruments and channels 269
MIDI Input setting 270
Naming MIDI ports 269
Notes 272
Preparations 269
Program Change Messages 272
Record mode 273
Recovering recordings 275
Reset 273
Retrospective Record 275
Sound selection 270
System Exclusive Messages 273
MIDI recordings
Exporting to MIDI file 854
MIDI SysEx Editor
Dump request messages 865
MIDI Thru Active 1195
Monitoring 264
MIDI timecode
Destinations 1058
MIDI track delay
MIDI track parameters 764
MIDI track parameters 764
MIDI tracks 116
Expression Maps 822
Freezing MIDI Modifiers 770
Inspector 116
Routing to device 866
Track controls 121
MIDI Velocity
Editing 792

MIDI volume
MIDI track parameters 764
Mirror
MIDI 795
Missing ports
Re-routing 94
MixConsole 366
Channel linking 379
Channel overview 366
Channel racks 378
Channel selector 371
Channel types 375
Creating VCA faders 415
Direct Routing 409
Display line 381
EQ presets 400
Equalizer curve 366
Fader section 385
FX chain presets 397
History tab 371
Level meters 390
Listen 387
Lower zone 64
Meter section 434, 435
Mute 387
Notepad 412
Opening 366
Panning 386
Pre rack 395
Racks 392
Sections 366
Setting volume 390
Solo 387
Solo Defeat 387
Strip presets 407
Surround Pan 659
Undoing parameter changes 371, 375
Visibility agents 377
Visibility tab 371
VST MultiPanner 659
Zones tab 371
Zoom tools 372
MixConsole in Project Window 64
MixConsole parameters
Track Quick Controls 744
MixConvert V6
3D downmixing 675
Channel configurations 675
In surround setups 671
MMC Master panel 1054
Modifier keys 1155
Monitoring 262
About 19
ASIO Direct Monitoring 263
External 263
MIDI 264
Via Nuendo 263
Mouse Wheel for Event Volume and Fades 1184
Move Audio
Crossfades 311
Move Fade
Crossfades 311
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Move Vertically
Automation Event Editor 700
Controller Event Editor 831
Tempo Event Editor 978
Moving
Events 202
Moving tracks 169
MP3 files
Exporting 1016
Importing 279
MPEG files
Importing 279
MPEX algorithm
About 489
Pitch Shift 481
Multi processing 1177
Multi-channel tracks
Split 166
Musical Articulations
Editing 828
Musical Mode
About 533
Musical Time Base 975
Musical track time base 180
Mute
MixConsole 387
Surround channels 669
Transpose track 330
Mute Pre-Send when Mute 1207
Muting events 218
MXF files 1125
Exporting 1019
My Shared Projects 1036

N
NAT 1025
Navigating
MixConsole 412
Network
name 1026
Network Interface Setup 1027
Networking
Sound Designer II 1024
Never Reset Chased Controllers 1195
New Project Dialog 87
Normalize
Direct Offline Processing 480
Note display
Drum Editor 843
Key Editor 814
Note events
Adding in controller display 825
Coloring 798
Cutting 801
Deleting 801
Drawing with Draw tool 815
Drawing with Line tool 816
Duplicating 801
Editing 801
Editing via MIDI 822
Excluding from playback 800
Gluing 819

Note events (continued)
Moving 817, 849
Muting 800
Repeating 801
Resizing 818
Selecting 799
Setting velocity values 802
Setting with Snap 802
Splitting 819
Transposing 817, 849
Note Expression 883
Adding events 894
Adding relase phases 897
Channel rotation 890
Controller parameter filter 885
Controller parameter list 885
Controller parameter mapping 888
Controller settings 886
Converting events 900
Deleting events 895
Global settings 887
Inspector section 884
Key Editor 822
Latch Buffer 891
Mapping controller parameters 888, 889
Mapping presets 889
MIDI controller parameters 884
MIDI learn 889
Moving events 896
Overdubbing 891
Overlaps 900
Pasting events 895
Pasting events to different parameters 896
Recording 889, 890
Recording by overdubbing 891
Recording via MIDI Input 892
Removing events 898
Repeating events 896
Sustain pedal 890
Tools 887
Trimming events 899
Trimming to note length 897
VST 3 controllers 883, 884
Note Expression Event Editor
Change Editor Size 892
Change Release Length 892
Compress Left 892
Compress Right 892
Horizontal Snap 892
Move Vertically 892
One-Shot Mode 892
Parameter Range 892
Parameter Selection 892
Scale Around Absolute Center 892
Scale Around Relative Center 892
Scale Vertically 892
Stretch 892
Tilt Left 892
Tilt Right 892
Vertical Snap 892
Note Expression MIDI Input 887
Note Expression MIDI Setup 898
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Note Info
Showing 1203
Note Layer
Scores 1205
Notepad
MixConsole 412
Notes
Adding in ReConform preview 1107
Nudge buttons
Crossfades 311
Nudging audio events to picture 1090
Number of Bars per Staff 1203

O
O-notes (Output notes) 853
Object Mapping 678
Offline Processing
Applying permanently 477
Ogg Vorbis files
Exporting 1019
Importing 279
OMF files 1120
On Import Audio Files 1184
On Processing Shared Clips 1184
On-Screen Keyboard
About 257
Computer keyboard 258
Modulation 258
Note velocity level 258
Octave offset 258
Options 258
Piano keyboard 258
Pitchbend 258
Recording MIDI 257
One Shot
Fill options 716
One-Shot Mode
Note Expression Event Editor 892
Open Effect Editor after Loading it 1209
Open Last Project on Startup 1194
OpenTL files 1129
Organizing files in subfolders
Pool 603
Outline Event Data 1190
Output busses
Adding 29
Default 29
Renaming 27
Routing 394
Surround configurations 651
Output Mapping 876
Output ports 18
Overlap
Crossfades 310
Overlapping Audio 175
Override Project Permissions 1034
Overview line
Project window 50
Overview Mode
VST MultiPanner 665

P
Panning
Bypass 387
Constant power 654
MixConsole 386
MixConvert V6 671
Surround 654
Using a joystick 671, 761
VST MultiPanner 654
Parameter Range
Note Expression Event Editor 892
Parameter Selection
Note Expression Event Editor 892
Part Data Mode 1193
Parts
About 194, 198
Editing 199
Folder 199
Sliding the contents 215
Parts Get Track Names 1182
Paste at Origin 213
Paste Relative to Cursor 213
Patch Banks 778
Pattern
Chord Pads 935
Pattern Banks
Loading in MediaBay 640
Previewing in MediaBay 627
Peak meter display 434
Pedals
To note length 791
Performance
Aspects 1176
Audio performance 1177
Optimizing 1176
Permission preset
Creating in Project Sharing and Permissions dialog
1033
Creating in User Manager dialog 1031
Loading 1035
Removing in User Manager dialog 1032
Permissions
Default preset 1032
Presets 1031
Setting up for tracks 1034
Setting up manually 1033
Phase
MixConsole 396
Phase Reverse
Direct Offline Processing 480
Phones channel
Source buttons 427
Phones Channel
Using as Preview Channel 1210
Piano voicings 911
Pick-up Mode 747
Pitch
Changing for chords 819
Pitch Notation 1192
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Pitch Shift
Algorithm 488
Direct Offline Processing 481
Limitations 490
Placing audio events to picture
Four-point editing with the Range Selection tool
1091
Placing audio to picture
At cursor 1089
At timecode positions 1088
Snap 1088
Plain Chords
Chord Pads 935
Playback
Disable Acoustic Feedback 1186
Excluding note events 800
Playback Toggle triggers Local Preview 487, 1205
Plug-in delay compensation 443
Plug-in Editors Always on Top 1209
Plug-in processing
Suspending 442
Plug-ins
Installing 737
Managing 737
Surround 647
Poly Pressure events 830
Polyphony
Restricting 794
Pool
Aligning file and project attributes 606
Applying different processing methods 592
Attributes for elements 602
Audio processing 603
Automatically generating new audio clips 606
Changing object names 591
Clip editing 599
Designating a new pool record folder 602
Inserting and finding media 597
Key commands 598
Managing large sound databases 596
Managing media files 586
Organizing files in subfolders 603
Reducing the project size 604
Reference file 586
Renaming clips and regions 591
Resolve missing files dialog 597
Sampler track 586
Toolbar 589
Transferring media from a library to a project 605
Pop-up Toolbox on Right-Click 1189
Position Cursor
Showing 1203
Position markers
About 334
Post fader sends 453
Post-roll
Recording 261
Transport panel 244
Pre fader sends 453
Pre-Record time
Audio recording 268

Pre-roll
Recording 261
Transport panel 244
Preferences
Colors 1207
Configuration 1182
Dialog 1180
Disabling 1174
Saving presets 1181
Store marked preferences only 1181
Presets
Previewing in MediaBay 626, 627
Previewing using a MIDI file 626
Previewing using the Memo Recorder 626
Previewing via MIDI Input 626
Previewing via the Computer Keyboard 627
Presets browser
Effects 460
Preview options
Activating 717
Previewing
ReConform results 1106
Video with ReConform 1117
Primary Time Format
Selecting 243
Process Bars 989
Process Tempo 988
Profiles
About 1170
Activating 1172
Adding 1171
Creating 1171
Deleting 1172
Duplicating 1172
Exporting 1173
Importing 1173
Managing 1170
Renaming 1172
Switching 1172
Project Browser 994
Deleting events 997
Editing Note Expression data 997
Event display 994, 995
Info line 994
Project structure 994, 995
Toolbar 994
Project Colors Dialog 1168
Project cursor
Setting 242
Project folder 1037
Project Logical Editor
About 959
Actions 969–972
Applying Actions 973
Filter conditions 960–968
Functions 972
Macros 973
Overview 959
Presets 973
Setting up Key Commands 974
Storing Presets 974
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Project Root Key
About 326
Assigning to a Project 327
Assigning to Parts or Events 327
Changing 328, 329
Recording with 328
Project Setup
Synchronization settings 1049
Project Setup Dialog 89
Project structure
Automation 995
Track data 995
Project window
Creating VCA faders 415
Event display 46
Global track controls 46
History 41
Info line 50
Inspector 53
Keyboard focus 74
Left zone 53
Lower zone 62–66
Meter section 434
Overview 39
Overview line 50
Project zone 40
Right zone 68
Ruler 47
Showing/Hiding Zones 40
Snap 79
Snap to zero crossings 79
Status line 49
Toolbar 41
Toolbox 44
Track list 45
Track Visibility 59
Transport 51, 237
Transport pop-up window 239
Visibility 59
Zones Visibility 61
Zoom presets 77
Zoom submenu 76
Zooming 75
Project workspaces 1158
Project zone 40
Event display 46
Global track controls 46
Ruler 47
Toolbar 41
Track list 45
Projects
About project files 87
About template files 88
Activating 93
Back up 96
Creating new 85, 87
Hub 86
Location 95
Locations 93
Missing ports 94
Opening 92
Opening from locations 93
Opening recent 94

Projects (continued)
Prepare archive 96
Revert 95
Saving 94
Saving templates 88
Setting up 89
Pull-down
Audio 1097
Video 1100
Pull-up
Audio 1097
Video 1100
Punch
Preview options 717
Punch In 245, 261
On Stop 1201
Punch In/Out
Common Record Modes 262
Punch Log
Automation 718
Punch on Play
Preview options 717
Punch Out 245, 261
Stop after automatic 1201
Punch Points 245

Q
Q-Link 383
QC Learn Mode
Track Quick Controls 743
Quantize Panel
About 291
Quantizing to a grid 293
Quantizing to a groove 295
Quantizing
About 287
Catch Range 293
Crossfades section 299
MIDI event starts 442
Multiple audio tracks 290
Original position 295
Pre-Quantize 295
Swing 293
Tuplets 293
Using groove presets 293
Quick Zoom 1182

R
Rack settings 378
Copying 392
Racks
MixConsole 392
VCA 417
RAM
Recording 266
Range Editing 225
Range selection
Video 1092
Range Selection tool 225
Creating fades 303
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Re-Record
Activating 262
Common Record Modes 262
Read automation 695
Real-Time Export 1020
Recent projects 94
ReConform
Audio snippet markers 1115
Automation warning markers 1115
Change EDL 1106
Dissolve markers 1115
Healing entries 1110
Insert markers 1115
Prerequisites 1103
Previewing video 1117
Restricting the range 1113
User interface 1104
Wipe markers 1115
Record
ADR 354
Record File Format
Audio 265
Record Folder
Audio 265
Record-Enable allows MIDI Thru 1202
Recording
About 259
Activating 260
Common Record Modes 262
Cycle 261
Levels 13
Lock Record 275
Notes and Note Expression 890
Pre-roll and post-roll 261
Remaining Record Time 275
Stopping 260
With Effects 267
Recovering recordings
Audio 268
MIDI 275
ReCycle files 283
Redo Net Update 1041
Reducing the project size
Pool 604
Reference file
Pool 586
Reference Level 1210
Refresh Views
MediaBay 617
Regions
About 197
Creating with Detect Silence 493
Event or Range as Region 197
Events from Regions 197
Renaming 591
Rehearse
ADR 354
Remote control
About 748
Apple Remote 761
Assigning commands 751
Automation 751
Connections 748

Remote control (continued)
Control Assignment 754
Generic Remote 752
Global Options 750
Joysticks 761
MIDI Port Setup 748
MIDI remote control configuration 753
Remote Control Editor 757
Resetting 750
Setting up 749
Remote Control Editor 757
Control settings 758
Layout 760
Parameter assignment 760
Toolbar 758
Remote Controllers
Connecting Track Quick Controls 747
Connecting VST Quick Controls 734
Remove
WAN Connection 1028
Remove DC Offset
Direct Offline Processing 483
Remove Empty Tracks 169
Remove Regions/Hitpoints on all Offline Processes
1184
Remove Selected Tracks 169
Removing
Events 202
Silence 493
Renaming
Clips 591
Events 206
Regions 591
Tracks 169
Render Audio Click between Locators 255
Render MIDI Click between Locators 255
Rendering
Naming Scheme 221
Rendering Audio 1002
Rendering Selected Events 219
Rendering Selections 1004
Rendering Tracks 1002, 1004
Repeat Events 214
Repeat Loop 790
Replace Recording in Editors 1202
Resample
Direct Offline Processing 484
Rescan Network 1029
Reset on Stop 1195
Resize crossfades 311
Resizing events 209
Retrospective Record 1202
MIDI 275
Return to Start Position on Stop 1205
Reverse
Audio 484
Direct Offline Processing 484
MIDI 795
Reverse shots
VST MultiPanner 666
Review
ADR 354
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ReWire
About 1132
Activating channels 1134
Channels 1135
Enabling applications 1132
Routing MIDI 1135
Setup 1132
REX files 283
Right Locator 241
Right zone 68
Control Room 73
Media rack 71, 72, 607, 610
Meter 73, 434
VSTi rack 69, 70
RMS display
Meters 434
Root Key
Sampler Control 584
Routing
For surround setups 652
Group channels 394
Input busses 394
MixConsole 393
Output busses 394
Through insert effects 444
Routing Editor 448
Ruler
Display format 48
Project window 47
Timeline 797
Ruler track 147
Track controls 147
Run Setup on Create New Project 1194

S
Sample editing
Sampler Control 583
Sample Editor 513
About 503
Info Line 509
Inspector 510
Lower zone 66
Overview Line 509
Regions 519
Ruler 513
Showing multiple waveforms 513
Snap 521
Toolbar 505
Undo zoom operations 514
Sampler
Lower zone 65
Sampler Control 574
Amp section 580
AudioWarp section 578
Envelope editor 581
Filter section 580
Keyboard section 583
Pitch section 579
Playing back samples 584
Root Key 584
Sample editing 583
Sound parameter section 578

Sampler Control (continued)
Toolbar 575
Transferring samples to VST instruments 585
Waveform display 577
Sampler track
Inspector 123
Loading Audio Samples 573
Loading MIDI Parts 573
Sampler Control 573
Track controls 127
Transferring Samples to Instruments 585
Sampler tracks 123
Creating 574
Pool 586
Samplerate
Externally clocked 17
Saturation
Strip module 400
Save as Template 88
Save partial preferences settings 1181
Save Track Preset 190, 191
Scale Around Absolute Center
Automation Event Editor 700
Controller Event Editor 831
Tempo Event Editor 978
Scale Around Relative Center
Automation Event Editor 700
Controller Event Editor 831
Tempo Event Editor 978
Scale events
About 910
Adding 910
Auditioning 910
Automatic scales 910
Changing 910
Follow Chord Track 916
Showing 910
Scale standards
Meters 434
Scale Vertically
Automation Event Editor 700
Controller Event Editor 831
Tempo Event Editor 978
Scan Folders only when MediaBay is open 1200
Scan unknown File Types 1200
Scanning
MediaBay 616
Score Editor
Lower zone 66
Scroll to selected Track 1188
Scrub Tool 200
Scrub Volume 1207
Scrubbing
Scrub tool 200
Secondary Time Format
Selecting 244
Sections
Chord Pads 935
Select Channel/Track on Edit Settings 1188
Select Channel/Track on Solo 1188
Select Controllers in Note Range - Use Extended Note
Context 1187
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Select Media Type
MediaBay 619
Select Tool - Show Extra Info 1189
Select Track for Auditioning 909
Select Track on Background Click 1182
Selected Events
Rendering 219
Selecting
Tracks 173
Selection ranges
Aligning audio 205
Selection Ranges
Creating 225
Editing 227
Editing in controller lane editor 832
Selections
Rendering 1004
Send effects 441
About 451
Adding FX channel tracks 451
Setting level 455
Setting pan 454
Send Level 1207
Sends
MixConsole 408
Settings
Factory defaults 1171
Share project 1035
Shared Copies
Convert to Real Copy 215
Creating 215
Show Dialogue during ADR 363
Show Note Expression Data 887
Show Scales 910
Show Timecode Subframes 1084
Side-chain 455
Ducking delay 456
Effect inputs 443
Inserts rack 397
Trigger signals 457
Side-chain inputs 443
Signal Switchboard
ADR 357
Signature track 148
Inspector 148
Track controls 149
Silence
Detecting 491
Direct Offline Processing 484
Inserting 229
Removing 493
Simple Crossfade Editor 307, 1184
Single Voice
Follow Chord Track 915
Slices
About 523
Slider Mode 1186
SMPTE
Drop-Frame 1085
Time-of-day 1084
Timecode 1084

Snap
About 79
Sample Editor 521
Snap MIDI Parts to Bars 1202
Snap point
Setting 79
Snap Point To Cursor 79
Snap Slurs when dragging 1203
Snap to zero crossings
About 79
Snap type
Project window 80
Solo
MixConsole 387
Surround channels 669
Solo Defeat
MixConsole 387
Solo Record in MIDI Editors 1202
Spectrum Analyzer 495
Audio Functions 493
Splice Point 310
Offset 310
Split MIDI Controllers 1187
Split MIDI Events 1187
Splitting
By ranges 229
Events 212
Into equal events 212
Tracks 166
Standard algorithm
About 489
Start Recording at Cursor
Common Record Modes 262
Start Recording at Left Locator
Common Record Modes 262
Static value line
Automation 695
Stationary Cursors 1205
Statistics
Audio Functions 496
Status line
Project window 49
Step recording 822
Stereo Flip
Direct Offline Processing 484
Stereo Panner Mode 1207
Stop playback while winding 1205
Stretch
Automation Event Editor 700
Controller Event Editor 831
Tempo Event Editor 978
Strip presets 407
Strip Presets
Loading in MediaBay 639
Surround
3D downmixing 675
3D mixing for Ambisonics 683
3D mixing for Dolby Atmos 676
About 647
Ambisonics mixing 683
Applying plug-ins 647
Automatic downmixing 410
Automation 662, 668
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Surround (continued)
Constant power 654
Counter shots 666
Deliverables 648
Disable channels 669
Divergence 667
Dolby Atmos mixing 676
Elevation patterns 668
Exporting to file 676
Input bus configuration 654
Inspector 654
MixConsole 654
MixConvert V6 671
Mute channels 669
Orbit Center 666
Output bus configuration 651
Panning 665, 669
Positioning 662
Radius 666
Rotating signals 666
Routing 652
Signal distribution 667
Solo channels 669
Supported channel configurations 648
Tilting signals 666
VST MultiPanner 654
Suspend Auto-Scroll when Editing 243
Suspend Read
Suspend options 719
Suspend VST 3 plug-in processing when no audio
signals are received 1209
Suspend Write
Suspend options 719
Swing
Quantizing 293
Sync Selection in Project Window and MixConsole 1188
Synchronization
9-Pin devices 1051
About 1044
Audio to picture 1085
Nuendo SyncStation 1051
Operation (Sync mode) 1059
Phase 1048
Setting up 1049
Speed references 1047
Timecode 1045
Timecode preferences 1052
Timecode source 1051
Synchronize Plug-in Program Selection to Track
Selection 1209
Synchronizing Track Data
Follow Chord Track 916
SysEx
Changing settings 866
Editing values 867
Messages 865
System component information
Exporting 465
Managing system components 465
System Component Information 464

T
Tail

Direct Offline Processing 475
Tap Tempo 984
Tapemachine Style
Monitoring 1207
TCP/IP 1024
Telecine process
About 1094
Template projects 88
Templates
Renaming 89
Workspaces 1158
Tempo
Process Bars 989
Process Tempo 988
Set Definition from Tempo 991
Tempo Changes
Tempo Detection 981
Tempo Detection 981, 986
Corrections 982
Panel 986
Tempo Editor
Toolbar 976
Tempo Event Editor 978
Compress Left 978
Compress Right 978
Move Vertically 978
Scale Around Absolute Center 978
Scale Around Relative Center 978
Scale Vertically 978
Stretch 978
Tilt Left 978
Tilt Right 978
Tempo Events
Editing 982
Tempo matching
Audio Alignment 539
Tempo modes
Fixed Tempo 975
Tempo track 975
Tempo related tracks 975
Tempo track 150, 975
About 977
Activate 976
Editor 976
Exporting 987
Importing 987
Inspector 150
Mode 975
Tempo changes 979
Track controls 150
Terminator point
Automation 704
Thick Fade Lines 1191
Thumbnail Memory Cache Size 1211
Thumbnails
About 1079
Thumbnail cache files 1079
Tied Notes selected as Single Units 1203
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Tilt Left
Automation Event Editor 700
Controller Event Editor 831
Tempo Event Editor 978
Tilt Right
Automation Event Editor 700
Controller Event Editor 831
Tempo Event Editor 978
Time Base
Default track time base 181
Linear 975
Musical 975
Tracks 180
Time display 243
Time Display 1084
Time Display Window 240
Time Format 243
Time linear track time base 180
Time related tracks 975
Time Signature Events
Adding 992
Adding on the Signature Track 992
Setting up 991
Setting up Click Patterns 992
Time Stretch
Algorithms 488
Direct Offline Processing 485
Limitations 490
Time Stretch Tool Algorithm 1184
Time Warp 989
Time-of-day
SMPTE 1084
Timecode
SMPTE 1084
Standards 1045
Synchronization 1045
Timecode Subframes
Showing 1205
Timecodes
Modifying in EDLs 1108
Timeline
Ruler 797
Timelines
ReConform 1106
Tips
Showing 1194
To End
Fill options 715
To Punch
Fill options 715
To Start
Fill options 715
Toggle Time Base 975
Tool modifier keys 1155, 1189
Toolbar
Pool 589
Project Browser 994
Project window 41
Toolbar Divider
Project window 44
Toolbox
Project window 44

Touch Assist
Preview options 718
Track archives
Exporting 163
Importing 161
Track Area Width 1193
Track Color
Automatic 1167
Resetting 1167
Track Controls Settings 99
Track Folding 175
Track Height 172
Track Inspector
Opening 54
Track list
About 45
Dividing 45
Track list network controls 1039
Track Name Width 1193
Track parameters
Track Quick Controls 742
Track Pictures 170
Browser 171
Showing 170
Track presets
Quick Control assignment 745
Track Presets
About 188
Applying 191, 641
Audio 188
creating 191
Creating 190
Extracting Sounds 192
Instrument 188
Loading 191
Loading in MediaBay 638
Loading Inserts and EQ 192
MIDI 189
Multi-Track 189
Pattern Banks 190
Previewing in MediaBay 625
Saving Track Quick Control Assignment Presets
193
Track Quick Controls 193
VST Presets 190
Track Quick Controls 762, 763
About 741
Assigning effect parameters 743
Assigning instrument parameters 744
Assigning MixConsole parameters 744
Assigning parameters 742
Automatable Parameters 745
Connecting with Remote Controllers 747
Inspector 742
Loading presets 745
Parameter assignment 742
Presets 193
QC Learn Mode 743
Removing assignments 744
Saving assignments as presets 193, 745
Showing automated assignments 746
Track Selection follows Event Selection 1182
Track Sheet 998

1234

Index

Track Time Base 180, 975
Track Time Type 1182
Track Visibility
Inspector 59
Track Zoom 172
Tracks
About 98
Audio 101
Chord 130
Coloring 169
Customizing track controls 99
Disabling audio tracks 174
Duplicating 173
Folder 139
FX channel 133
Group Channel 140
Importing from a project 160
Importing from a track archive 161
Instrument 108
Loudness 156
Marker 145
MIDI 116
Moving 169
Removing 169
Renaming 169
Rendering 1002, 1004
Ruler 147
Sampler 123
Selecting 173
Signature 148
Tempo 150
Transpose 151
VCA fader 152
Video 154
Tracks Presets
Direct Offline Processing 475
TrackVersion IDs 183
TrackVersions
About 181
Activating 184
Copying and Pasting 185, 186
Creating 183
Creating from lanes 188
Creating lanes from TrackVersions 187
Deleting 185
Duplicating 185
Names 186
Renaming 186
Renaming on multiple tracks 187
Transfer Status 1030
Transformer
Strip module 400
Transparent Events 1190
Transpors track
Track controls 152
Transport 237
Overview 237
Project window 51
Sections 237
Transport menu
Functions 232

Transport panel 230
Display format 243
Overview 230
Post-roll 244
Pre-roll 244
Sections 230
Transport pop-up window 239
Transpose
Exclude Parts or Events 333
Global 333
Independent 333
Indicate Transpositions 331
Info line 332
Lock 330
MIDI function 785
Mute 330
Project Root Key 326
Transpose functions
About 326
Transpose track 151
About 329
Inspector 151
Lock 330
Mute 330
Recording 332
Transposing 330
Treat Muted Audio Events like Deleted 1184
Trim
Automation 708
Trim tool
Changing event lengths 818
Tuplets
Quantizing 293
Type of New Tempo Points 976

U
UDP 1024
Undoing
Edit History 83
Maximum undo steps 83
Maximum Undo Steps 1194
MixConsole parameter changes 371, 375
Net Update 1041
Offline processing 476, 603
Project window 41
Recording audio 268
Use Undo Branches 1194
Zoom operations 514
Unlock Layout when editing single parts 1203
Unshare Selected Project 1036
Use Drum Editor when Drum Map is assigned 1190
Use Undo Branches 1194
Use Up/Down Navigation Commands for Selecting
Tracks only 1182
Use Video Follows Edit Mode
Video 1086
User name 1026, 1027
User-definable Frame Rate 1205
Users in Local Network 1029
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V
Value Box/Time Control Mode 1186
Value display
Editing in List Editor 865
VariAudio
About 542
VCA connections
Deactivating 419
VCA fader track
Inspector 152
Track controls 154
VCA fader tracks 152
VCA faders 414
Automation 416
Connecting 418
Creating 415
Nesting 416
Settings 414
VCA rack 417
Velocity
Changing for note events 828
MIDI function 792
Verify Communication 1029, 1041
Vertical Snap
Note Expression Event Editor 892
Video
Adjusting and editing audio to picture 1090–1093
Adjusting audio fades to picture 1093
Audio editing to picture 1084
Audio pull-up/pull-down 1097
Bi-level signals 1047
Codecs 1077
Conforming production audio 1085
Cut head/Cut tail 1092
Editing 1083
EDL 1086
Event-based fades 1087
Event-based volume envelopes 1087
Extracting audio from 1083
Formats 1076
Four-point editing 1091
Importing 1078
Inserting audio events at cursor position 1089
Inserting audio events at timecode positions 1088
Locating to markers 1089
Nudging audio events to picture 1090
OMF 1086
Output devices 1078
Placing audio to picture 1088
Playback 1080
Previewing with ReConform 1117
Pull-down 1100
Pull-up 1100
Range selections 1091, 1092
Scrubbing 1083
Snapping audio events to video events 1088
Studio Setup 1080
Synchronization 1047
Thumbnails 1079
Time-stretching audio to picture 1092
Timeline 1084

Video (continued)
Tri-level signals 1047
Use Video Follows Edit Mode 1086
Video overlays
ADR 362
Video Player window 1081
Aspect ratio 1081
Setting window size 1081
Video track
Inspector 154
Track controls 155
Video tracks 154
Virgin territory
Automation 704
Creating gaps 704
Defining a terminator point 704
Virtual reality
Video playback 691
Visibility
Inspector 59, 60
MixConsole 371
Synchronizing track and channel visibility 61
Voicings 911
Automatic voicings 911
Configuring parameters 911
Library 911
Library subset 911
Octave offset 911
Piano 911
Range 911
Volume
MixConsole 390
Volume curve 315
Volume databases
Creating in the MediaBay 643
Mounting in the MediaBay 645
Removing from the MediaBay 644
Unmounting in the MediaBay 645
VPN 1025
VST
Input ports 18
Output ports 18
VST 2 442
VST 3 442
VST 3
Suspend plug-in processing 730
VST 3 controllers
HALion Sonic SE 884
Note Expression 883
VST AmbiConverter 694
VST AmbiDecoder 686
VST Audio System 13
VST instruments
Extracting expression maps 878
Freezing 730
Presets 728
Saving presets 729
Setting up 724
Using VST System Link 1074
VST MultiPanner
3D mixing 658
3D mixing elevation patterns 668
3D mixing panning laws 669
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VST MultiPanner (continued)
About 654
Ambisonics mode 685
Automation 662
Bed mixing 658
Constant power 654
Disable channels 669
Divergence 667
Movement restrictions 663
Mute channels 669
Object mode 682
Object-based mixing 681
Orbit Center 666
Overview Mode 665
Panning 665, 669
Panning restrictions 663
Pinning mode 660
Plug-in panel 655
Positioning 662
Radius 666
Remote controlling 670, 671
Rotating signals 666
Signal distribution 667
Solo channels 669
Tilting signals 666
VST Plug-in Manager 737
Collections 737
Window 737
VST plug-ins
Installing 737
VST Presets
Loading 191
Previewing in MediaBay 625
VST Quick Controls
Connecting with Remote Controllers 734
VST System Link
About 1065
Activating 1069
Connections 1066
Latency 1067
MIDI 1071
Putting computers online 1070
Requirements 1066
Setting up sync 1067
Settings 1068
VSTi rack
Right zone 69, 70

W
WAN 1024
Setting up 1028
Warn before removing modified effects 1209
Warn on Processing Overloads 1207
Warping Algorithm 1184
Wave 64 files
Exporting 1019
Wave files
Exporting 1013
Waveform display 513
Sample Editor 513
Waveforms
Showing 1191

When Recording Wave Files larger than 4 GB 1201
Wind Speed Options 1205
Windows Media Audio files
Exporting 1017
Importing 279
Wipe markers 1115
Word clock
About 1047
Working with MIDI data
Tools and functions for 842
Workspaces
Adding 1159
Creating 1159
Editing 1159
External projects 1158
Modifying 1159
Organizing 1160
Saving 1159
Templates 1158
Types 1158
Updating 1159
Workspaces Organizer 1160
Writing automation 695
Automatically 696
Manually 696, 697
Tools 697

Z
Zones
Keyboard focus 74
Left zone 53
Lower zone 62
MixConsole 371
Project zone 40
Right zone 68
Zones Visibility
Inspector 61
Zoom
Adapt Grid to Zoom 75
Audio Contents 76
Cycle Markers 78
Project window 75
Zoom history
Project window 79
Zoom presets
Project window 77
Zoom Tool Standard Mode - Horizontal Zooming Only
1189
Zoom while Locating in Time Scale 1205
Zooming
To cycle markers 335
Zooming tracks 172
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