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New Features in Version 3.1.0
Highlights
Condensing changes
●

You can now manually change condensing results from any rhythmic position. Condensing
changes allow you to split phrases, change notation options for condensing, and specify
exactly how you want individual players to be allocated to voices and staves. See Changing
condensing options from rhythmic positions.

Dynamics lane
●

Each instrument track in Play mode now also has a dynamics lane, which presents the
profiles of dynamics over time in a graphical way and allows you to view and edit them. See
Dynamics lanes.

Bracketed noteheads
●

You can now show brackets around any notehead, where before this was limited to
unpitched percussion instruments. Both round and square brackets are available. See
Bracketed noteheads.

Lines
●

Dorico Pro now supports vertical, horizontal, and angled lines between notes, with different
styles and appearances available. They offer many notational possibilities, as lines can
convey a variety of meanings, but do not affect playback. See Lines.

More New Features
Voice indication in the status bar
●

The voice of a single selected note is now displayed in the status bar, making it easier to
keep track of voices. See Status bar.

XML export
●

Dorico Pro‘s MusicXML export has been improved. Accidentals, articulations, chord
symbols, instrument transpositions, jazz articulations and rehearsal marks are all now
included when exporting projects to MusicXML. See Exporting MusicXML files.

Local chord symbols
●

You can now input chord symbols that only apply to a single instrument, allowing you to
show different chord symbols for different players at the same rhythmic positions. See
Inputting chord symbols.

Master page import/export
●

You can now import and export master page sets between projects, allowing you to reuse
master pages you created in other projects. See Importing master page sets.

●

You can also import individual master pages from other master page sets in the project,
meaning you can create a single custom title page master page and use it in full score
layouts and part layouts. See Importing master pages.
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Bracket grouping settings for different layouts
●

The existing ensemble types for bracket grouping have been moved from Engraving
Options to Layout Options, allowing you to change the bracket grouping approach in
each layout independently. See Changing bracket grouping according to ensemble type.

Tonality system import/export
●

You can now import and export tonality systems between projects, allowing you to share
tonality systems with other users. See Importing tonality systems.

Harmonics playback
●

Both natural and artificial harmonics now play back at the appropriate pitch. If your
playback device includes dedicated sounds for harmonics, these are now also used
automatically. See Harmonics.

Guitar bend runs
●

Sequences of consecutive guitar bends are now notated as bend runs on tablature. See
Guitar bends.

Timecode position options
●

You can now show the timecode at the start of each system without showing a separate
timecode staff. The timecode can appear above or below the staff. See Changing the
vertical position of timecodes.

Last but Not Least
Auto-save file names
●

Dorico Pro now automatically adds “[AutoSave]” to the end of auto-save project file names
so that you can identify them, for example, if you need to recover a project from the bin on
your computer. See Auto-save.

Avoid double/triple accidentals when transposing
●

You can now avoid double and triple accidentals when transposing selections in tonality
systems that are compatible with 12-EDO. See Transpose dialog.

Copying automation
●

You can now copy automation points, including copying them to other automation lanes.
See Copying and pasting automation points.

Instrument names in the Endpoint Setup dialog
●

The Assigned Instruments column in the Endpoint Setup dialog now displays the
instrument name set for each instrument in the Edit Instrument Names dialog. See
Endpoint Setup dialog.

Square brackets for accidentals
●

You can now show square brackets on individual accidentals, in addition to the existing
support for round parentheses. See Hiding/Showing or parenthesizing accidentals.

●

This is also available for harmonic accidentals. See Hiding/Showing or parenthesizing
harmonic accidentals.

Short (top) barline
●

Dorico Pro now includes a short (top) barline that is similar to the existing short barline but
spans the top two spaces in a five-line staff. See Barlines.

Brace design span thresholds
●

You can now set span thresholds for when you want Dorico Pro to use the different
available brace designs, including preventing Dorico Pro ever showing flat braces. See
Project-wide engraving options for brackets and braces.
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Duplicating tonality systems
●

Dorico Pro now allows you to create a new tonality system by duplicating an existing one.
See Creating custom tonality systems.

Duplicating accidentals
●

Dorico Pro now allows you to create a new accidental by duplicating an existing one. See
Creating/Editing custom accidentals.

New Features in Version 3.0.10
Tablature input
●

You can now use a numeric keypad to input the fret numbers of notes on tablature. See
Inputting notes on tablature.

Harp pedaling filter
●

There is now a filter that you can use to select or deselect harp pedal diagrams within a
larger selection. See Filters.

New Features in Version 3.0.0
Highlights
Inputting onto multiple staves
●

You can now extend the caret to multiple staves and input notes and notations onto all of
them at once, including dynamics and playing techniques. When using a MIDI keyboard,
this also allows you to explode chords across those staves as you input them. See Inputting
notes and notations onto multiple staves.

Comments
●

This version introduces the ability to add comments as annotations as a way of adding
notes or instructions without affecting the music. See Comments.

Condensing
●

In Dorico Pro, you can now automatically produce condensed scores that still allow for
separate parts for each player. This allows you to create conductor’s scores easily. You can
enable condensing and set up custom condensing groups for each layout independently.
See Condensing.

Playback templates
●

It is now possible to create custom playback templates and edit existing ones. You can
include factory default playback templates and endpoint configurations and list them in
your order of preference in a single custom playback template. See Edit Playback Template
dialog.

Chord diagrams
●

You can now show chord diagrams alongside chord symbols in Dorico Pro. You can show
the suitable chord diagrams for guitars with a variety of tunings and any other fretted
instrument in the library and create your own chord diagram shapes. See Chord diagrams.

Fingerings for guitars and fretted instruments
●

Dorico Pro now offers comprehensive support for the complex fingerings required for
music for guitars and fretted instruments, including automatically positioning right-hand
and left-hand fingerings correctly. See Fingerings for fretted instruments.
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String indicators
●

Dorico Pro now supports string indicators both inside and outside the staff. When inside
the staff, they automatically erase their backgrounds. They also automatically
accommodate left-hand fingerings for the same notes. See String indicators.

Harmonics
●

Dorico Pro now supports various conventions for the notation of harmonics on stringed
and fretted instruments, including both natural and artificial harmonics. Dorico Pro can
also calculate the correct pitch to be notated for the second through sixth partials. See
Harmonics.

Guitar bends
●

Dorico Pro now supports the notation of guitar bends, including guitar pre-bends, holds,
and releases. These techniques can be shown on both notation staves and tablature. See
Guitar bends.

Harp pedaling
●

Dorico Pro now offers features designed to help write idiomatically for the harp, including
harp pedal diagrams that you can show as a diagram or using note names, a tool to
calculate the pedal positions required to play a passage of music, and highlights for notes
that are unplayable with the current pedal positions. See Harp pedaling.

Playing technique continuation lines
●

You can now show continuation lines for playing techniques and differentiate between lines
that show simply their duration and lines that indicate a gradual transition between playing
techniques. See Playing technique continuation lines.

Tablature
●

Dorico Pro now provides tablature for guitar and other fretted instruments, including
supporting a number of specific idiomatic notations for guitar, custom string tunings,
different conventions for representing rhythms on tablature, and so on. Music can be
shown on a regular notation staff and on tablature at the same time or separately, and they
are linked, meaning edits to one staff automatically affect the other. See Tablature.

More New Features
Project Info dialog
●

This new version updates the Project Info dialog significantly. It can now stay open whilst
you work, has a list of flows so you can select and change information for multiple flows at
once, and also allows you to add and delete flows from within the dialog in addition to
using the Flows panel in Setup mode. It also has a new default key command for quicker
access. See Project Info dialog.

Custom endpoint configurations
●

Related to custom playback templates, you can now save any overrides you have made to
endpoint configurations, such as changing the expression maps or instruments assigned to
particular endpoints, as custom endpoint configurations. You can then reuse these in other
projects and include them in custom playback templates. See Custom endpoint
configurations.

Bar numbers at multiple positions
●

You can now show bar numbers at multiple vertical positions in the same system. This is
often used in large orchestral scores so that conductors never have to look too far to see
the bar number. See Showing bar numbers above specific staves.

Chord symbol regions
●

It is now possible to show chord symbols only alongside slash regions or in new chord
symbol regions. This makes it easier to specify specific sections where it is helpful or
necessary to show chord symbols for players who do not need them elsewhere. See Chord
symbol regions.
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Clefs according to layout transposition
●

You can now choose to show individual clefs only in either transposed or concert pitch
layouts. This is useful when, for example, some instruments require clef changes in the
score but not in their part. Clefs hidden in this way do not affect note spacing. See Hiding/
Showing clefs according to layout transpositions.

Lyric line vertical adjustments
●

It is now possible to make graphical adjustments to the vertical positions of lyric lines on
individual systems. See Moving lyric lines vertically.

Curved arpeggio signs
●

Dorico Pro now offers a curved arpeggio sign, which some composers use to indicate
gentle or partial arpeggiation. See Types of arpeggio signs.

Glissando playback
●

Glissando lines now affect playback. For harps, the pitches included in glissando lines
automatically change according to the current harp pedaling setting. See Glissando lines in
playback.

Last but Not Least
MIDI activity indicator
●

Dorico Pro now displays a green light briefly in the status bar when it is receiving MIDI
input from a connected device. See Status bar.

Missing Fonts dialog
●

This new dialog informs you if a project you are opening contains a font you do not have
installed on your computer and allows you to select replacement fonts. See Missing Fonts
dialog.

Frame fullness indicator
●

Similar to the system fullness indicator already available in Dorico Pro, there is now also a
frame fullness indicator to show whether frames are comfortably full or over-full vertically.
See Frame fullness indicator.

Swing playback for 16th notes
●

Dorico Pro now allows you to use 16th notes as the unit for swing playback. See Swing
playback.

Multi-bar rest count font
●

It is now possible to change the font used for counts on multi-bar rests to a plain font,
rather than the default bold, Arabic font. See Changing the font used for multi-bar rest bar
counts.

Continuous instrument numbering regardless of transposition
●

There is a new option that allows Dorico Pro to number instruments continuously even if
they have different transpositions, such as Horn in F and Horn in D. See Numbering
instruments with different transpositions separately/together.
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Introduction
Thank you very much for purchasing Dorico Pro.
We are delighted that you have chosen Steinberg's scoring application and hope that you will
enjoy using it for years to come.
Dorico is a next-generation application for producing beautiful sheet music, whether you are a
composer, arranger, music engraver, publisher, instrumentalist, teacher, or student. Whether
you want to print your music or share it in a digital format, Dorico is the most sophisticated
program available.
Like all of Steinberg's products, Dorico has been designed from the ground up by a team of
musicians who understand your needs and who are dedicated to producing a tool that is both
easy to learn and use, but also capable of results of the highest quality. Dorico also integrates
with your existing workflow and can import and export files in a variety of formats.
Dorico thinks about music the same way a human musician does and has a deeper
understanding of the elements of music and musical performance than other scoring
applications. Its unique design allows an unprecedented degree of flexibility, in music input and
editing, in score layout, in rhythmic freedom, and many other areas besides.
Most sincerely yours,
Your Steinberg Dorico Team

Platform-independent documentation
This documentation applies to the operating systems Windows and macOS.
Features and settings that are specific to one of these platforms are clearly indicated. In all other
cases, the descriptions and procedures in the documentation are valid for Windows and macOS.
Some points to consider:
●

The screenshots are taken from macOS and use the dark theme in Dorico Pro.

●

Some functions that are available on the File menu on Windows can be found in the
program name menu on macOS.

Usage of musical terms
This documentation uses American terminology for musical items.
The following table lists all the notes and notations that have different names in American and
British English:

American Name

British Name

Double whole note

Breve

Whole note

Semibreve

Half note

Minim
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American Name

British Name

Quarter note

Crotchet

Eighth note

Quaver

Sixteenth note

Semiquaver

Thirty-second note

Demisemiquaver

Sixty-fourth note

Hemidemisemiquaver

Hundred twenty-eighth note

Semihemidemisemiquaver

Two hundred fifty-sixth note

Demisemihemidemisemiquaver

Staff

Stave

Bar/Measure

Bar

NOTE
This documentation only uses “bar”.

Conventions
In our documentation, we use typographical and markup elements to structure information.

Typographical elements
The following typographical elements mark the following purposes.
Prerequisite
Requires you to complete an action or to fulfill a condition before starting a procedure.
Procedure
Lists the steps that you must take to achieve a specific result.
Important
Informs you about issues that might affect the system, the connected hardware, or
that might bring a risk of data loss.
Note
Informs you about issues that you should consider.
Tip
Adds further information or useful suggestions.
Example
Provides you with an example.
Result
Shows the result of the procedure.
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After Completing This Task
Informs you about actions or tasks that you can perform after completing the
procedure.
Related Links
Lists related topics that you can find in this documentation.

Markup
Elements of the user interface are highlighted throughout the documentation.
Names of menus, options, functions, dialogs, windows, and so on, are highlighted in bold.
EXAMPLE
To open the Project Info dialog, choose File > Project Info.
If bold text is separated by a greater-than symbol, this indicates a sequence of different menus
to open.
EXAMPLE
Choose Setup > Layout Options.
File names and folder paths are shown in a different font.
EXAMPLE
example_file.txt

Key commands
Key commands are sets of keys that perform defined tasks when pressed together. They are also
known as “keyboard shortcuts”. Many of the default key commands use modifier keys, some of
which are different depending on the operating system.
When key commands with modifier keys are described in this manual, they are indicated with the
Windows modifier key first, followed by the macOS modifier key and the key.
EXAMPLE
Ctrl/Cmd-Z means: press Ctrl on Windows or Cmd on macOS, then press Z .

Key commands in Dorico Pro
The default key commands in Dorico Pro depend on your keyboard layout.
If you move the mouse over a tool or a function, the information in brackets shows the key
command that is used to activate or deactivate a tool or a function.
You can also do one of the following:
●

Choose Help > Key Commands to open the Dorico Key Commands window, which provides
an overview of all available key commands.

●

Search for key commands of specific functions or menu items in the Preferences dialog. In
this dialog, you can also assign new key commands or change default key commands.

RELATED LINKS
Interactive Dorico Pro key commands map on page 65
Searching for the key commands of functions on page 66
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Preferences dialog on page 62
Key Commands page in the Preferences dialog on page 63
Assigning key commands on page 66

How you can reach us
On the Help menu you find items linking to additional information.
The menu contains links to various Steinberg web pages. Selecting one of these menu items
automatically launches your web browser and opens the page. On these pages, you can find
support and compatibility information, answers to frequently asked questions, information
about updates and other Steinberg products, and so on.
This requires that you have a web browser installed on your computer and a working Internet
connection.
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First steps
This chapter helps you to get started with Dorico Pro.
When you start Dorico Pro for the first time, we recommend that you open one of the templates
first to have a look at the user interface and the functions that Dorico Pro provides before you
start your own projects. You are welcome to skip this part and explore the program for yourself.
The following sections inform you about the following topics:
●

Overview of the most important workspaces

●

Setting up a new project

●

Writing your music and adding notation items to your score

●

Laying out and formatting pages

●

Playing back what you created

●

Printing and exporting

Getting around
The following sections give you an overview of the user interface and introduce you to how
Dorico Pro is structured.

Opening a template
Before you start your own project, we recommend that you familiarize yourself with the user
interface of Dorico Pro. To prepare for this, open one of the templates that are provided with the
program.
PREREQUISITE
You have started Dorico Pro. The Hub is open.
PROCEDURE
1.

In the Hub, select one of the listed template groups. For example, select the Choral and
Vocal templates.

2.

Select one of the listed templates.

3.

Click New from Template.
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RESULT
The template opens. The players in the template are added to the project and their staves appear
in the music area.
RELATED LINKS
Hub on page 69

Quick tour of the user interface
The user interface of Dorico Pro consists of different modes that represent different phases in
the workflow of preparing a score.
The user interface has a structure that is the same in each of the application’s modes. There is
always a large area for editing your music in the center of the project window. In every mode,
there are collapsible panels on the left, right, and bottom of the project window, depending on
which mode you are using. The contents of these panels change according to the selected mode.
When you open the template, the first view shows the project window in Write mode:

The project window when you open a template

The project window contains the following areas:

Toolbar
The toolbar is located at the top of the project window.

Toolbar

On the left side of the toolbar, the modes are displayed. By changing the mode, you change the
workspace and the available panels. The current mode is highlighted in a different color. In the
middle of the toolbar, layout options allow you to switch between the different layouts in your
project and to show/hide panels and tabs.
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On the right side of the toolbar, you can open a Mixer and use basic transport controls that,
among other functions, allow you to play back and record your music.

Show Mixer button

Music area
The music area is the main part of the project window in Setup, Write, and Engrave modes where
you set up, input, edit and format your music. In Play mode, this area is called event display, in
which every note is displayed as an event. In Print mode, this area is called print preview area,
which shows a preview of what is going to be printed or exported as a graphic.

The music area in Write mode after starting a new project from a choral template

The music area displays the scores or the instrumental parts that you create. Above the music
area you can activate several layouts in tabs and switch between them. Layouts in Dorico Pro
allow you to show different presentations of your music. If you have a full score with different
instrumental parts, such as a violin part and a bassoon part, you can switch between that full
score layout and the layouts of each part. To save space on the screen or to focus on a specific
layout, you can hide the tabs.

Toolboxes
Toolboxes are the columns on the left and right edges of the project window. They contain
different tools and options according to the current mode, but in general they allow you to input
and modify notes, notation items, and frames, and to determine which options are shown in
their corresponding panels.
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Notes toolbox in Write mode

Notations toolbox in Write mode

Panels
Dorico Pro provides panels with various functions in all modes. When you open the template,
there is a panel on the left of the music area. This is the Notes panel in Write mode. It contains all
the durations, accidentals, slurs, and articulations that are most commonly used when inputting
notes.
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Notes panel in Write mode

Status Bar
At the bottom of the project window, a status bar allows you to select different views and page
arrangements for the music area. It contains different options in different modes.
Status bar

RELATED LINKS
User interface on page 42
Mixer on page 554
Transport window on page 557

Functions of the modes
Each mode represents a different phase in the workflow of preparing scores and parts, so
contain different toolboxes, panels, and functionality from each other.

Setup mode
In Setup mode, you can set up the fundamental elements of the project: instruments and the
players that hold them, flows, layouts, and videos. You can also determine how they interact with
each other, for example, by changing the players assigned to layouts.
You can view music in the music area and switch between viewing other tabs and layouts, but
you cannot select or interact with anything in the music area in Setup mode.
You can switch to Setup mode in any of the following ways:
●

Press Ctrl/Cmd-1 .

●

Click Setup in the toolbar.

●

Choose Window > Setup.
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Write mode
In Write mode, you can input and edit your music, including changing the rhythmic positions of
items, changing the pitch of notes, and deleting notes and items. The available toolboxes and
panels allow you to input all the notes and notation items that are most commonly used.
By design, you cannot move notes and items graphically in Write mode. Graphical adjustments
are only possible in Engrave mode.
You can switch to Write mode in any of the following ways:
●

Press Ctrl/Cmd-2 .

●

Click Write in the toolbar.

●

Choose Window > Write.

Engrave mode
In Engrave mode, you can make fine adjustments to notes and items and determine how the
pages of your project are laid out. By design, you cannot delete any notes or items, change their
rhythmic positions, or change the pitch of notes in Engrave mode; this prevents mistakes when
engraving.
You can switch to Engrave mode in any of the following ways:
●

Press Ctrl/Cmd-3 .

●

Click Engrave in the toolbar.

●

Choose Window > Engrave.

Play mode
In Play mode, you can change how your music sounds in playback, including by changing the
playback template and assigning VST instruments, inputting automation, adjusting the mix, and
changing the sounding duration of notes in playback without affecting their notated duration.
You can switch to Play mode in any of the following ways:
●

Press Ctrl/Cmd-4 .

●

Click Play in the toolbar.

●

Choose Window > Play.

Print mode
In Print mode, you can print your layouts or export them as graphics files. When printing layouts,
you can specify the paper size and other options, such as duplex or booklet printing. When
exporting layouts, you can specify different graphics file types, such as PDF or PNG, and the
information you want to include in their exported file names.
You can switch to Print mode in any of the following ways:
●

Press Ctrl/Cmd-5 .

●

Click Print in the toolbar.

●

Choose Window > Print.

RELATED LINKS
Setup mode on page 94
Write mode on page 152
Engrave mode on page 350
Print mode on page 592
Play mode on page 495
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Hiding/Showing panels
You can hide/show individual or multiple panels. This is useful if you want to see more of the
music area, for example.
PROCEDURE
●

Hide individual panels or all panels in the following ways:
●

To hide/show the left panel:
Press Ctrl/Cmd-7 .
Click the disclosure arrow on the left edge of the main window.
Choose Window > Show Left Panel.

●

To hide/show the right panel:
Press Ctrl/Cmd-9 .
Click the disclosure arrow on the right edge of the main window.
Choose Window > Show Right Panel.

●

To hide/show the bottom panel:
Press Ctrl/Cmd-8 .
Click the disclosure arrow at the bottom of the main window.
Choose Window > Show Bottom Panel.

●

To hide/show all panels:
Press Ctrl/Cmd-0 .
Click Hide/Restore Panels.

Choose Window > Hide/Restore Panels.
RESULT
The corresponding panels are hidden/shown. Panels are hidden when no tick is shown beside
the corresponding panel in the menu, and shown when a tick is shown in the menu.
If you hide all active panels, the Hide/Restore Panels button in the toolbar changes its look and
indicates which panels were active but are now hidden.
EXAMPLE

Appearance when panels are shown

Appearance when all panels were previously shown
but are now all hidden

Working with tabs and windows
Dorico Pro enables you to set up your workspace according to your working style.
Dorico Pro allows you to open multiple tabs to display multiple layouts in the same project within
the same window. You can also open the same project in several windows.
RELATED LINKS
Workspace setup on page 55
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Opening a new tab
You can open a new tab to display a different view or layout within the same project window.
Each tab can contain a separate layout or a different view of a layout already open in another tab
or window. Whenever you open a new tab, you are prompted to select a layout that you want to
display in the tab.
You can find tabs in the tab bar, located at the top of the music area, below the toolbar. If you do
not see any tabs, click Show Tabs in the toolbar.

PROCEDURE
●

To open a new tab, do one of the following:
●

Press Ctrl/Cmd-T .

●

At the right end of the tab bar, click New Tab.

●

Choose Window > New Tab.

RESULT
A new tab opens that shows several icons at the top and a list of layouts at the bottom.

Options available in the music area when you open a new tab

AFTER COMPLETING THIS TASK
You can click one of the icons or select a layout from the list at the bottom. Alternatively, you can
select a layout from the layout selector in the toolbar. The layout that you choose opens in the
active tab.
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RELATED LINKS
Tab bar on page 46
Toolbar on page 43

Opening a new window
You can open another window for the same project, for example, if you want to work on multiple
layouts at the same time. You can also show a different mode of the same project in each
window, such as having one window show Write mode and another show Play mode.
PROCEDURE
●

Open a new project window in any of the following ways:
●

Press Ctrl/Cmd-Shift-T .

●

Choose Window > New Window.

RESULT
A duplicate of the window opens. It contains the same tabs and the same view options as the
original window.
RELATED LINKS
Opening multiple project windows on page 59

Starting a new project
After getting a first impression of the Dorico Pro user interface, you can get started with
inputting your own music. In this section, you learn how to set up a new project.
PREREQUISITE
NOTE
All inputs that are made and the images that are used to accompany the steps in this chapter are
intended merely to be helpful examples. Therefore, there is no need to make the same entries in
order to get the depicted results.
Close the template without saving to reopen the Hub.
PROCEDURE
●

Start a new project in any of the following ways:
●

Press Ctrl/Cmd-N .

●

Click New Empty Project.

RESULT
A new project window opens.
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By default, new projects start in Setup mode. This allows you to specify players and assign
instruments straight away. The area in the middle, known as the project start area, allows you to
start your project with different types of players. Once you have added at least one player, this
area becomes the music area.
On the right, the Layouts panel shows a Full score layout card. This layout is automatically
created in every new project.
At the bottom of the window is the Flows panel, where you can specify separate spans of music
for your project.
AFTER COMPLETING THIS TASK
Start your project by adding a player and assigning an instrument to them. You are free to assign
any kind of instrument. The following examples use a single piano player.
RELATED LINKS
Windows on page 42

Adding a solo player
In this section, you learn how to add a player and assign an instrument.
PREREQUISITE
You have started a new project. You are in Setup mode.
PROCEDURE
1.

Click Add Solo Player to open the instrument picker.

2.

Enter piano into the instrument picker search box.

3.

Click Add.
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RESULT
You have added your first player. In the music area, the required piano staves including their
respective clefs are displayed.
AFTER COMPLETING THIS TASK
Save your project. You can do this at any time.
Optionally, you can now edit the project title or add more players.
The following sections help you to create flows and layouts. If you want to start composing, you
can skip those sections.
RELATED LINKS
Writing music on page 29

Creating a flow
Flows are separate spans of music within your project, for example, movements or songs. In this
section, you learn how to create a flow.
PREREQUISITE
You have added at least one player. You are in Setup mode.
PROCEDURE
●

In Setup mode, click Add Flow in the Flows panel at the bottom of the window.

RESULT
A new flow is added to your project each time you click Add Flow. All existing players are
assigned to new flows, and new flows are automatically assigned to all existing full score and
part layouts.
AFTER COMPLETING THIS TASK
You can double-click the flow card to rename the flow.
You can also remove players from the flow by deactivating their checkboxes in the Players panel,
and remove the flow from layouts by deactivating their checkboxes in the Layouts panel.
RELATED LINKS
Flows on page 132
Renaming flows on page 145

Creating a layout
Layouts define how music for one or more players in one or more flows is presented, including
page size, margins, staff size, and so on. In this section, you learn how to create a new layout.
PREREQUISITE
You have added at least one player and one flow. You are in Setup mode.
Several layouts are often used in ensembles with multiple players, where each player may
require a layout of the individual instrumental part. Dorico Pro automatically creates a full score
layout that contains all players and all flows as well as individual part layouts that each contain
one player and all flows. If you require a different combination of players and flows, for example,
a part containing the music for two players, you can create your own layouts, as follows:
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PROCEDURE
●

In the Layouts panel, click Add Instrumental Part Layout.

RESULT
An empty part is created on the Layouts panel.
AFTER COMPLETING THIS TASK
You can double-click the empty part card to rename it.
You can also assign flows to the layout by activating their checkboxes in the Flows panel, and
assign players to the layout by activating their checkboxes in the Players panel.

Writing music
Once you have set up your project, you can start writing music.
In Write mode, you can input notes and insert other notations into your score.
TIP
Throughout Dorico Pro, most tasks can be accomplished using only your computer's keyboard.
You do not need to use the mouse or touchpad. Learning key commands allows you to use
Dorico Pro most efficiently. The fastest way to input music is using a MIDI keyboard. If you do not
have a MIDI keyboard, you can use your computer's keyboard. Of course, you can still use the
mouse or touchpad if you want.
In the following sections, you learn how to input notes and notation items.

Inputting your first notes
In this section, you learn how to input notes. You can start inputting notes without having to first
add a time signature or key signature.
PREREQUISITE
●

You have set up your MIDI keyboard.
NOTE
If you have not set up a MIDI keyboard yet, you can start inputting notes with the computer
keyboard.

●

You have added a piano player in Setup mode.

●

You are in Write mode.

PROCEDURE
1.

Select the rest that was automatically inserted next to the clef when you added a solo player.
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2.

Start note input in any of the following ways:
●

Press Shift-N or Return .

●

Double-click the rest.

The caret is activated and appears on the staff.

3.

In the Notes panel, click a duration.
NOTE
By default, Dorico Pro selects a quarter note (crotchet) for you.

4.

Start playing notes on the MIDI keyboard, or press A , B , C , D , E , F , G on the computer
keyboard to input the corresponding pitches.
If you want higher or lower pitch for the note that Dorico Pro inputs for you, you can force a
different register.
●

To input a note above the previously input note, press Shift-Alt/Opt as well as the letter
for the note, for example, Shift-Alt/Opt-A .

●

To input a note below the previously input note, press Ctrl-Alt (Windows) or
Ctrl (macOS) as well as the letter for the note, for example, Ctrl-Alt-A (Windows) or
Ctrl-A (macOS) .

NOTE
You must press Ctrl on Mac, not Cmd .

RESULT
The pitches you enter or play in are input as notes.
EXAMPLE

Input notes with the caret still active after the final note

RELATED LINKS
Write mode on page 152
Register selection during note input on page 174
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Adding a time signature
In this section, you learn how to add a time signature at the beginning of the staff. You can add a
time signature before or after inputting a melody.
PREREQUISITE
Press Esc to deactivate the caret.
PROCEDURE
1.

Select the first note on the staff.

2.

Press Shift-M .
The time signatures popover opens above the staff.

3.

Enter a typical time signature into the popover, such as 3/4.

4.

Press Return to close the popover.

RESULT

The time signature is automatically input to the left of the note, and the required bar lines are
automatically inserted at the correct positions. If you want to insert a key signature, proceed to
the next section.

Adding a key signature
In this section, you learn how to add a key signature. You can add a key signature at any
rhythmic position on the staff.
When you start a new project from scratch, by default, there is no key signature shown.
Depending on the kind of music you are writing, the key signature might be taken to mean C
major or an open key with no specific tonal center.
You can change the key anywhere on the staff. To add a different key signature at the beginning
of the staff, for example, D major, proceed as follows:
PROCEDURE
1.

Select the first note on the staff.

2.

Press Shift-K .
This opens the key signatures popover on top of the staff.

3.

Enter a key signature into the popover. If you want to enter D major, enter an uppercase D.
For D minor, enter a lowercase d.
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4.

Press Return .

RESULT

The key signature is inserted between the clef and the time signature. Dorico Pro automatically
adds accidentals where necessary.

Inputting your first chord
In this section, you learn how to input a chord with the computer keyboard, using chord mode. If
you want to use a MIDI keyboard instead, you can input the chord with your keyboard, and you
do not need to use chord mode. Dorico Pro automatically inputs the correct notes.
PREREQUISITE
Select the last note or rest on the staff, and press Return . This shows the caret.
PROCEDURE
1.

Start chord input in any of the following ways:
●

Press Q .

●

In the Notes toolbox, click Chords.

The caret shows a plus sign at the top.

2.

Optional: In the Notes panel, select a duration.

3.

Input the notes that you want in your chord by pressing keys from A to G , one after the
other. For example, for a C major chord, press C , E , and G .
By default, Dorico Pro adds each new note above the previous note. You can select the
register of notes manually.
The example shows a possible result.
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4.

Press Space to advance the caret to the next note position and continue with the next
chord.
Dorico Pro expects further chord input until you deactivate it.

5.

Optional: To stop chord input, press Q or click Chords again in the Notes toolbox.

RELATED LINKS
Register selection during note input on page 174
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Dorico is based on a number of key concepts that come from its design philosophy.
We recommend familiarizing yourself with these concepts, as this will greatly enhance your
ability to work efficiently with Dorico and to navigate more easily through this documentation.

Design philosophy and higher-level concepts
Deep design considerations are required to create a notation software like Dorico, which might
be of particular interest to users familiar with scoring applications. Dorico has a forward-thinking
design that is led by musical concepts rather than computational convenience, and this provides
many benefits.
In most other graphically-orientated scoring applications, the highest-level concept is the staff or
the instrument definition that creates a staff or staves. When setting up your full score in such
programs, you start by adding the correct number of staves, and you are immediately forced into
making decisions about the layout. This means that you must know in advance whether two
flutes share a staff or have their own individual staves, or whether there should be two trumpets
or three. Many of these decisions have significant effects throughout the process of inputting,
editing, and producing individual instrumental parts.
Typically, every system of a score must contain the same number of staves, even if some are
hidden on particular systems. This requires the user to manage common conventions for
themselves, such as multiple players of the same instrument sharing staves. This can be timeconsuming and is naturally error-prone.
By contrast, Dorico is designed to conform more closely to how music is performed in the real
world and to make the score a flexible expression of the practical choices that go into a musical
performance, rather than to make the musical performance subservient to the way the score was
initially prepared.
To that end, the highest-level concept of Dorico is the group of human musicians that performs a
score. A score can be written for one or more groups, for example, a double choir or an orchestra
plus off-stage chamber ensemble, and so on. Each group includes one or more players which
correspond to the humans who play one or more instruments. Players may either be individuals
who play more than one instrument, such as an oboist doubling cor anglais, or groups in which
everyone plays only one instrument, such as eight desks of violinists.
One crucial difference between Dorico and other scoring applications is that the musical content
exists independently of the score layout in which it is viewed.
The actual music played by the group in your score belongs to one or more flows. A flow is any
span of music that stands alone, for example, a whole song, a movement of a sonata or
symphony, a number in a musical show, or even a short scale or exercise. Players might or might
not have any music to play in a given flow. For example, all the brass players might be omitted
from the slow movement of a classical symphony, or certain players might have nothing to play
in some cues in a movie score. This is no problem as you can combine players in flows in any
combination.
Dorico‘s design philosophy provides several benefits. Chief among them is its ability to produce
different score layouts that share the same musical content. For example, in the same project
you can create a conductor's score with as many instruments as possible condensed onto a
smaller number of staves, a full score with each player's music on separate staves, a custom
score layout containing just the piano and vocal staves for choral rehearsals, and an instrumental
part for each player that only contains the music belonging to them.
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Projects in Dorico
A project is an individual file that you create within Dorico Pro. It can contain multiple separate
pieces of music of any duration, written for any combination of instruments, and use as many
layouts as required.
For example, you can create a single project that contains all the preludes and fugues in Bach’s
“The Well-Tempered Clavier” as separate flows. You could then have one layout that contains only
the flows for Book 1 and another layout that contains the flows for Book 2.
In addition to the notated music, projects save other relevant information, such as the playback
template applied, its master pages, and settings in options dialogs.
Dorico projects are saved as .dorico files.
RELATED LINKS
Flows in Dorico on page 36
Layouts in Dorico on page 39

Modes in Dorico
Modes in Dorico Pro represent a logical sequence of the workflow phases of preparing music,
but you can switch between them at any time as required for your own workflow.
Dorico Pro contains the following modes:
Setup
In Setup mode, you can set up the fundamental elements of the project: instruments
and the players that hold them, flows, layouts, and videos. You can also determine how
they interact with each other, for example, by changing the players assigned to
layouts.
You can view music in the music area and switch between viewing other tabs and
layouts, but you cannot select or interact with anything in the music area in Setup
mode.
Write
In Write mode, you can input and edit your music, including changing the rhythmic
positions of items, changing the pitch of notes, and deleting notes and items. The
available toolboxes and panels allow you to input all the notes and notation items that
are most commonly used.
By design, you cannot move notes and items graphically on the page in Write mode.
Graphical adjustments are only possible in Engrave mode.
Engrave
In Engrave mode, you can make fine adjustments to the position, size, and appearance
notes and items and determine how the pages of your project are laid out, including
editing and creating master pages.
By design, you cannot delete any notes or items, change their rhythmic positions, or
change the pitch of notes in Engrave mode; this prevents mistakes when engraving.
Play
In Play mode, you can change how your music sounds in playback. You can do this by
changing the playback template and assigning VST instruments, inputting automation,
adjusting the mix, and changing the sounding duration of notes in playback without
affecting their notated duration.
Print
In Print mode, you can print your layouts or export them as graphics files. When
printing layouts, you can specify the paper size and other options, such as duplex or
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booklet printing. When exporting layouts, you can specify different graphics file types,
such as PDF or PNG, and the information you want to include in their exported file
names.
RELATED LINKS
Functions of the modes on page 22

Flows in Dorico
Flows are separate spans of music that are completely independent in musical content, for
example, a single song in an album, a movement in a sonata or symphony, a number in a stage
musical, or a short scale or sight-reading exercise of only a few bars in length. A single project
can contain any number of flows.
Each flow can contain music for any combination of players, independently of other flows. For
example, brass players are often tacet in the second movements of Classical-period symphonies,
so you can remove brass players from the flow for the second movement but leave them in the
flows for other movements. In a set of cues for a movie, for example, specific players might not
be required in some cues, so the corresponding flows can contain only those players who have
anything to play.
The correct assignment of players to flows allows Dorico Pro, for example, to generate tacet
sheets automatically for individual instrumental parts.
RELATED LINKS
Flows on page 132
Tacets on page 467

Players in Dorico
In Dorico Pro, a player can represent an individual musician or multiple musicians in the same
section. Players hold instruments, so you must add at least one player to your project before you
can add instruments.
●

A solo player represents a single person who can play one or more instruments. For
example, a clarinettist who doubles on alto saxophone or a percussionist who plays bass
drum, clash cymbals, and triangle.

●

A section player represents multiple people who all play the same instrument. For example,
a violin section player might represent all eight desks of the Violin I section in an orchestra,
or a soprano section player might represent the whole soprano section in a mixed voice
choir.
NOTE
Section players cannot double instruments, but they can play divisi. This means that they can
be divided into smaller units, which is commonly required for strings.

By using the concept of players, Dorico Pro makes it much easier to handle, for example,
instrument changes, divisi, and condensing music for multiple players onto a smaller number of
staves.
You can also group players together, for example, to separate off-stage players from on-stage
players in a large-scale work. Grouping players together means they are positioned together in
the score, numbered independently of players outside the group, and are bracketed together
according to the ensemble type set for each layout.
RELATED LINKS
Players on page 108
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Player groups on page 129
Divisi on page 1176
Condensing on page 470
Brackets according to ensemble type on page 685

Instruments in Dorico
In Dorico Pro, an instrument is an individual musical instrument, such as a piano, a flute, or a
violin. Human voices, such as soprano or tenor, are also considered instruments.
In Dorico Pro, instruments are held by players, just as real instruments are held by human
players. Section players can only hold a single instrument but solo players can hold multiple
instruments. This allows you to handle instrument changes easily, such as when an oboist
doubling the cor anglais switches from one instrument to the other.
Each instrument automatically gets its own staff, but when instrument changes are allowed, the
music for multiple instruments held by the same solo player can appear on the same staff as
long as no notes overlap.
Dorico Pro has a database of information about the properties of each instrument. These include
the playable range, common and uncommon playing techniques, notational conventions,
transposition properties, tunings, clef, number of staves, type of staff, and so on. Having these
properties predetermined makes it easier and quicker to set up projects correctly. For example,
selecting the horn instrument with the appropriate transposition and clef setting for its part
layout means you do not have to input a layout-specific clef. Similarly, there is a timpani
instrument that automatically hides all key signatures.
RELATED LINKS
Instruments on page 112
Instrument changes on page 114
Transposing instruments on page 115

Popovers
Popovers allow you to input different notations and perform tasks, such as transposing a
selection of notes, using only your computer keyboard. They are temporary value fields that use
text entries for different items and tasks, and there are specific popovers for different purposes.

The dynamics popover with an example entry

One of the key benefits of popovers is that you can use them as you input notes: once you reach
the position where you want to input a new time signature, for example, you can open the time
signatures popover using its key command, input the time signature you want, and then
continue inputting notes.
Although specific entries are required for many notations, the correct entries for different
notations are consistently and logically structured. For example, tuplets are always expressed as
a ratio, such as 3:2 or 5:4. Key signatures are expressed using capital letters for major keys and
lowercase letters for minor keys. Time signatures are expressed as a pair of separated numbers;
common time signatures use a slash, such as 3/4 or 6/8.
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During note input, and depending on the notation you are inputting with the respective popover,
notations are input either on the currently selected note, which is usually the last note you input,
or at the current rhythmic position, indicated by the caret.
You can always identify popovers by looking at the icon on their left-hand side. These are the
same icons used in the Notations toolbox on the right of the window, which hide/show the
Notations panel (which is another way you can input notations if you prefer to use the mouse).
You can only use popovers in Write mode, as that is the only mode where you can input notes
and items together and change the pitch of notes.
RELATED LINKS
Caret on page 167
Note input on page 167
Notations input on page 210

Notes and rests in Dorico
In Dorico, the notation and division of notes and rests is determined semantically by rules based
on convention. This means that note and rest durations can change and appear differently later
than when you first input them.
Dorico is able to update how notes and rests are notated depending on their context because of
the following key concepts:
1

Notes are treated as a single unit, even if they appear as a tie chain that contains multiple
notes tied together.

2

Implicit rests automatically fill the gaps between the notes you input.

In combination with time signatures and Dorico‘s understanding of their corresponding meters,
this allows you to input only the notes you want with the duration required. It is not necessary to
input rests between notes or input ties for notes that cross the half-bar, for example. If you
subsequently change the time signature or move notes rhythmically to start earlier or later,
Dorico updates how notes and rests are notated, such as by notating a quarter note as two tied
eighth notes if it now straddles a barline or consolidating two eighth note rests into a single
quarter note rest if they are now in the same bar.
If you tie existing notes together, you might find that they turn into a single note, such as a half
note instead of two tied quarter notes, or into a tie chain containing more notes. This is because
tie chains are treated as single notes in Dorico, and Dorico automatically notates and beams
notes appropriately depending on their duration, the current time signature, and their position
in the bar. Similarly, notes can change after you input notes immediately following them as this
changes the context, such as a quarter note tied to an eighth note becoming a dotted quarter
note when it is followed by an eighth note rather than a rest.
TIP
In Write mode, selecting any part of a tie chain selects the whole tie chain because it is a single
note. However, you can still input notations, such as dynamics, in the middle of tie chains by
activating the caret and moving it to the required rhythmic position within the tie chain.
You can change default settings for note and rest grouping, and also beam grouping, on a perflow basis. You can force the duration of individual notes and rests, for example, if you want to
specify subdivisions within a tie chain that are different than the prevailing meter.
RELATED LINKS
Notes on page 886
Ties on page 1219
Implicit vs. explicit rests on page 1107
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Note and rest grouping on page 681
Beam grouping according to meters on page 665
Per-flow notation options for beam grouping on page 665
Caret on page 167
Inputting notes on page 172
Forcing the duration of notes/rests on page 177
Inputting ties on page 192

Rhythmic position
In Dorico, notes and items exist at rhythmic positions, which are calculated using their place in
musical time in the flow rather than their position in a specific bar that has a particular time
signature.
In Dorico, musical time is the number of beats starting from the beginning of each flow. For
example, instead of a note existing on beat 3 in bar 4 in a 4/4 time signature, Dorico considers
that note to exist at beat 15, regardless of the time signature and its position in a bar.
This approach allows for a lot of flexibility. For example, because notes and items exist
independently of bars and time signatures in Dorico, you can change the time signature without
changing when notes happen in relation to each other or adding rests at the end of each bar.
Instead, the barlines simply move to different positions and note grouping is updated as
required, such as notating a quarter note as two tied eighth notes if it now straddles a barline or
crosses the half-bar. You can even start writing notes without inputting a time signature at all.
Similarly, you can easily push notes to later rhythmic positions or pull them in to earlier ones
using Insert mode, without the risk of them being incorrectly notated. It also means you can
think of items existing in the music independently of notes, because items exist at a particular
rhythmic position, rather than being attached to notes.
In Dorico, the rhythmic position of notes and items is separate from their graphical position on
the page. The benefit of this is that you can input items at the position in the music where they
must apply and then move them graphically without causing them to apply to different notes or
inadvertently split multi-bar rests. For example, if you want strings to play pizzicato from the start
of a bar, but because of tight vertical spacing you want to move the pizz. indication slightly to the
side. Attachment lines link items to the rhythmic positions to which they apply, so it is always
clear where they belong.
RELATED LINKS
Note and rest grouping on page 681
Beam groups on page 664
Time signatures on page 1235
Inputting notes in Insert mode on page 183
Notes on page 886
Caret on page 167
Rhythmic grid on page 166

Layouts in Dorico
Layouts combine musical content, as represented by flows and players, with rules for page
formatting and music engraving, and allow you to produce paginated music notation that can be
printed or exported in various formats. For example, part layouts only include the music for that
player whereas full score layouts contain all staves in the project.
A typical project for an ensemble contains several layouts. For example, a work for string quartet
in three movements contains four solo players – two violins, one viola, and one cello – and three
flows, one for each movement. Such a project might require five layouts:
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●

Four layouts each containing the music from all three flows for one of the solo players, that
is, the individual instrumental parts

●

One layout containing the music from all three flows and all four players, that is, the full
score

Each layout provides independent control over practically every aspect of the visual appearance
of the music, including independent staff size, note spacing, and system formatting. Each layout
can also have independent page formatting settings, such as page size, margins, running
headers, and footers.
The default formatting of pages in layouts is determined by master pages.
RELATED LINKS
Layouts on page 134
Page formatting on page 435

Master pages in Dorico
Master pages function like templates in Dorico Pro, allowing the same page formatting to be
applied to multiple different pages in different layouts.
Master pages contain arrangements of frames. Frames are boxes in which you can display text,
music, and graphics. The default master pages contain text frames at the tops of pages, to
display the page number and running header information, and a large music frame that takes up
most of the page.
All pages in your score and parts inherit their layout formats from master pages. Whenever you
create or change anything on master pages, this is automatically reflected on the pages that use
these master pages. For example, if you insert a new frame on a master page, a corresponding
frame appears on all the pages that use that master page, so long as those pages do not have
master page overrides.
NOTE
Changing individual pages in layouts is considered a master page override in Dorico Pro, which is
a type of page format change. This includes, for example, editing the title or running header on
one page, rather than in the master page editor. Pages with master page overrides no longer get
updated if you change the master page and are not automatically deleted, even if they are now
empty because the layout became shorter.

RELATED LINKS
Master pages on page 361
Frames on page 386
Page format changes on page 372

Options dialogs in Dorico Pro
Options to control the default appearance of music and functionality of Dorico Pro are available
in different dialogs according to their type and purpose.
Dorico Pro contains the following dialogs for global settings:
Layout Options
Contains options that are likely to vary from layout to layout, such as page size, staff
size, and the appearance and position of bar numbers. Options in Layout Options
affect only the selected layouts but apply to all flows in those layouts.
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Notation Options
Contains options that are likely to vary from flow to flow, such as beam grouping and
accidental duration rules. Options in Notation Options affect only the selected flows
but apply to all layouts in which those flows appear.
Note Input Options
Contains options relating to how you want Dorico Pro to interpret what you input, such
as creating chord symbols from a MIDI keyboard. Options in Note Input Options
affect the whole project but do not affect any other projects unless you save your
settings as default.
Engraving Options
Contains options that control the appearance and position of notes and items to a high
level of precision. For example, you can set whether crescendos appear as hairpins or
text and set the slant of beams according to the interval distance within the beam.
Options in Engraving Options affect the whole project but do not affect any other
projects unless you save your settings as default.
Playback Options
Contains options that control what you hear in playback and how notation items affect
playback, including setting a dynamic curve for how much different dynamics affect the
volume, whether repeats are included in playback, and whether you want a gap
between flows. Options in Playback Options affect the whole project but do not affect
any other projects unless you save your settings as default.
RELATED LINKS
Layout Options dialog on page 104
Notation Options dialog on page 160
Note Input Options dialog on page 162
Engraving Options dialog on page 359
Playback Options dialog on page 502
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The user interface of Dorico Pro is designed to be as unobtrusive as possible while keeping all of
the important tools at your fingertips.
You can explore the interface without doing any damage to your project. You can always undo
any inadvertent edits or close your project without saving it.

Windows
Dorico Pro provides a project window and floating windows.

Project window
You can open multiple project windows for the same or for different projects. The project window
consists of several areas.

Project window

1

Toolbar
Allows you to access the modes, the workspace options, the Mixer, the Video window, and
the main transport options.

2

Tab bar
In Setup, Write, and Engrave modes, the tab bar shows the tabs that are currently open. If
you split the music area and open several tabs, tab groups are shown.

3

Project start area/Music area/Event display/Print preview area
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When you set up a new empty project, this area in Setup, Write, and Engrave modes shows
the project start area that allows you to add your first players. Once you have added a player
or an ensemble, this area becomes the music area that shows the score or parts of the score
that you set up, write, edit, and format. In Play mode, this area contains an event display that
shows the effects of manipulating the playback of your score. In Print mode, the print
preview area shows a preview of how your project is going to be printed onto paper or
exported into a graphics file format.
4

Panel
Provides notes and notations that you need to create and edit your music. Different panels
contain different items and functions according to the mode.

5

Toolbox
Provides access to items and tools that you can use to input and edit your music. Different
toolboxes contain different items and tools according to the mode.

6

Status bar
Allows you to choose a different view and page arrangement of the music area. It also
contains zoom options and a summary of your current selection in the music area.

Floating windows
Dorico Pro allows you to open floating windows, such as the Mixer and the Transport windows.
These can be hidden and shown independently of the mode that is selected in the main window.
The following options hide/show floating windows:
Show Mixer

Hides/Shows the Mixer window.
Show Transport Bar

Hides/Shows the Transport window.
Show Video

Hides/Shows the Video window.
RELATED LINKS
Opening multiple project windows on page 59

Toolbar
The toolbar allows you to access the modes and workspace options as well as the Mixer and
main transport options. It is available in all modes and regardless of the tool that you are using.
●

You can hide/show the toolbar by clicking the disclosure arrow above the toolbar or by
pressing Ctrl/Cmd-6 .

The toolbar contains the following items:
1

Modes
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Selectable workspaces in the project window that represent different phases in the workflow
of preparing a score. If the width of the main project window becomes sufficiently small, the
mode buttons become a menu.
2

Workspace options
Provide options that allow you to select different layouts to open in the music area and to
change the working environment.

3

Show Video
Hides/Shows the Video window.

4

Show Mixer
Hides/Shows the Mixer window.

5

Mini transport
Allow to you quick access to the main transport functions, including Play, Record, and Click.

6

Activate Project
Shows which project is activated for playback when you have multiple projects open.

Workspace options
The workspace options in the middle of the toolbar provide options that allow you to select
different layouts and to change the working environment.
Layout selector

Allows you to select other layouts to show in the current tab.
Show Tabs
Shows/Hides the tab bar above the music area.

Appearance when the tab bar is hidden

Appearance when the tab bar is shown

Hide/Restore Panels
Shows/Hides all open panels.

Appearance when panels are shown

Appearance when all panels were previously
shown but are now all hidden

Mini transport
The mini transport on the right of the toolbar provides quick access to the main transport
functions of Dorico Pro.
Show Transport Bar

Opens the Transport window.
Time display
Shows the position of the playhead in one of the following formats:
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●

Bars, beats, and ticks

●

Elapsed time in the following order of units: hours, minutes, seconds, milliseconds

●

Timecode in the following order of units: hours, minutes, seconds, frames

Time display showing bars
and beats

Time display showing
elapsed time

Time display showing the
timecode

You can change the content shown in the time display by clicking it.
Fixed Tempo Mode
Displays the tempo used for both playback and recording. The value changes
according to the current position of the playhead and its appearance changes
according to its current mode.
You can change the tempo mode by clicking the beat unit. You can change the
metronome mark value used in fixed tempo mode by clicking and dragging upwards/
downwards on the number.

How Fixed Tempo Mode appears when
fixed tempo mode is active

How Fixed Tempo Mode appears when
follow tempo is active

Rewind to Beginning of Flow

Moves the playhead back to the beginning of the flow.
Play
Starts/Stops playback from the previous playhead position.

Play when playback is stopped

Play during playback

Record

Starts/Stops MIDI recording.
Click

Plays/Mutes the metronome click during playback and recording.
Activate Project

Shows which project is activated for playback when you have multiple projects open.
TIP
The Transport window contains additional transport functions.
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RELATED LINKS
Transport window on page 557
Playing back music on page 542
Moving the playhead on page 540
Changing the tempo mode on page 546
Changing the content shown in the transport display on page 558

Tab bar
The tab bar in Dorico Pro allows you to display different layouts within the same project window.
It is located between the toolbar and the music area.
TIP
If you cannot see the tab bar, click Show Tabs in the toolbar. If Show Tabs is activated, the tab
bar is always displayed, even if only a single tab is open.

The tab bar contains the following:
1

Tabs
All tabs currently open are displayed, with their position from left to right reflecting the order
in which you opened them. Each tab is labeled with the name of the selected layout. The tab
currently in view in the music area is highlighted.
When you hover over an individual tab, an x appears that allows you to close the tab.

2

New Tab
Allows you to open a new tab. Tabs can contain a different layout, or an additional view of a
layout that is already open in another tab or window.
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Project start area
The project start area is displayed in the middle of the project window in Setup, Write, and
Engrave modes when you set up a new empty project. When you add at least one player, the
view changes into the music area.

Project start area

The project start area shows cards that allow you to add your first players. To add players, click
one of the cards:
Add Solo Player
Adds an individual player to whom you can assign one or more instruments.
Add Section Player
Adds a player that represents multiple players who all play the same instrument.
Add Ensemble
Adds multiple players who play different instruments. The ensembles that you can add
represent standard combinations of musicians.

Music area
In Setup, Write, and Engrave modes, the music area shows the editable score.
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Music area showing a sample of a score

The music area can be displayed in several views. The music area tab bar allows you to open
several layouts from your project and switch between them. The scroll bars to the right and to
the bottom of the music area allow you to scroll within the layout.
When panels are open on the right, left, and at the bottom of the window, the size of the music
area can be reduced. You can hide/show panels when necessary.
RELATED LINKS
Hiding/Showing panels on page 24
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Print preview area
The print preview area in Print mode shows a preview of what is going to be printed or exported
as a graphic.

Print preview area displaying a score set to print 2-up

In the print preview area, you can scroll through the pages that are shown, but you cannot edit
your layouts. If you want to make changes, you must switch to Setup, Write, or Engrave mode.
TIP
You can go directly to the first page in the layout by pressing Home , and to the last page by
pressing End . You can change these key commands on the Key Commands page in
Preferences.
If you select multiple layouts to be printed as part of the same print job, the print preview area
only displays the first layout. If you want to show the expected page arrangement for each layout
in the print preview, you must check each layout individually before you start printing.
RELATED LINKS
Project window in Print mode on page 592
Key Commands page in the Preferences dialog on page 63
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Panels
The panels in the project window provide the notes, notations, and functions that you need to set
up, write, edit, and format your music.

Panels in Write mode

1

Left panel. In Write mode, this is the Notes panel.

2

Right panel. In Write mode, this is the Notations panel.

3

Bottom panel. In Write mode and Engrave mode, this is the Properties panel.

The panels have different names and functions in each mode in Dorico Pro.
Modes and their panels
Mode

Left Panel

Right Panel

Bottom Panel

Setup

Players

Layouts

Flows

Write

Notes

Notations

Properties

Engrave

Formatting

Pages

Properties

Play

n/a

VST and MIDI
Instruments

n/a

Print

Layouts

Print Options

n/a

Some panels are displayed by default. You can hide/show each panel individually or all of them at
the same time.
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RELATED LINKS
Modes in Dorico on page 35
Hiding/Showing panels on page 24
Project window in Setup mode on page 94
Project window in Write mode on page 152
Project window in Engrave mode on page 350
Project window in Play mode on page 495
Project window in Print mode on page 592

Disclosure arrows
Disclosure arrows indicate that objects and menus can be expanded/contracted, either vertically
or horizontally.
In Dorico Pro, disclosure arrows are commonly used to hide/show panels, sections, and
advanced options, and to expand/contract cards, such as player cards in the Players panel in
Setup mode.

Disclosure arrow for the bottom
panel

Disclosure arrows for both the
player card and the instrument
within it

Disclosure arrows for sections in
the Tempo panel

RELATED LINKS
Hiding/Showing panels on page 24
Players panel on page 95
Instruments on page 112

Toolboxes
Toolboxes are available in Write, Engrave, and Play modes. They contain different tools and
options according to the current mode, but in general they allow you to input and modify notes,
notation items, and frames, and to determine which options are shown in their corresponding
panels.
The following toolboxes are available in the different modes:
Write mode
●

Notes toolbox on the left of the window

●

Notations toolbox on the right of the window

Engrave mode
●

Engrave toolbox on the left of the window

Play mode
●

Play toolbox on the left of the window

RELATED LINKS
Notes toolbox on page 153
Notations toolbox on page 158
Engrave toolbox on page 351
Play toolbox on page 496
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Status bar
The status bar at the bottom of the project window allows you to choose a different view and
page arrangement in the music area.
NOTE
Not all options in the status bar are available in all modes.

Status bar in Write mode

1

Rhythmic Grid selector
Allows you to change the rhythmic grid resolution, which affects certain aspects of inputting
and editing, such as the amount by which items move.

2

Status display
Displays information about the current layout and selection, divided in up to three sections,
which are, from left to right:

3

●

Transposition of the current layout

●

The bar/range of bars of the current selection

●

Summary of the selection, for example, the pitch and voice of a single selected note or
the implied chord of multiple selected notes

Disclosure arrow
Allows you to show/hide the bottom panel in Setup, Write, and Engrave modes.

4

Selection tools
Allow you to switch between using the Marquee Tool and the Hand Tool in Write mode and
Engrave mode.

5

View type selector
Allows you to select one of the provided view types for the music area in Setup and Write
mode.

6

Page arrangement options
Allow you to choose between different horizontal and vertical arrangements of either
individual pages or pairs of pages, which are called spreads.

7

Zoom options
Allow you to change the zoom factor of the music area and its musical contents. There are
preset zoom levels but you can also use a custom zoom level.

8

MIDI activity indicator/Audio engine connection warning
Indicates that there might be MIDI or audio problems that require your attention.
●

A brief green light indicates that Dorico Pro is receiving MIDI input from a connected
device. If the green light is persistent, a connected MIDI device is sending lots of data,
which can cause problems.

●

A warning icon indicates that Dorico Pro is unable to send MIDI events to the audio
engine, for example, if no device is chosen or the sample rate is wrong. You can click the
warning icon to open the Device Setup dialog, where you can fix the problem in most
cases.
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RELATED LINKS
Rhythmic grid on page 166
View types on page 53
Page arrangements for page view on page 54
Zoom options on page 55
MIDI recording on page 204
Playing back music on page 542

Selection tools
The status bar in Dorico Pro contains selection tools that you can use to select items and change
the music shown within the music area.
Marquee Tool
Allows you to drag a rectangle to select multiple notes and notations.

Hand Tool
Allows you to move the view within the music area.

TIP
●

To use the other tool briefly without selecting it, you can press Shift in addition to using the
mouse.

●

You can change the default selection tool for all future projects on the Note Input and
Editing page in Preferences.

RELATED LINKS
Selecting multiple items using marquee selections on page 321
Dragging pages in the music area on page 334
Preferences dialog on page 62

View types
In Dorico Pro there are different ways to view your layouts. Dorico Pro saves your chosen view
type for each layout, so you only need to set it once.
The following view types are available:
Galley View
Lays out all the staves in the current layout and flow on a single continuous system.
This view type is most useful during the process of inputting the music as it allows you
to focus on the musical content of your project. Because it shows all staves, galley view
is particularly useful when inputting notes for solo players holding multiple
instruments and in layouts with condensing enabled.
By default, bar numbers are shown every bar above every staff. Staff labels are also
shown above every staff, and follow the view as you scroll so they are always visible.
NOTE
Note spacing in galley view is unjustified, meaning it neither expands nor contracts to
fit the width of a page or a music frame. However, changes made to note spacing in
galley view also apply to page view.

53
Dorico Pro 3.1.10

User interface
Windows
Additionally, there is no automatic vertical collision avoidance in galley view, so notes
and items might overlap.
Page View
Displays your layout paginated exactly as it appears when you print or export it.
This view type is useful if you want to view spreads or single pages. Spreads allow you
to work out page turns, because the performer only needs to turn the page at the end
of the right-hand page of a pair. Viewing single pages can be helpful if you want to
print the layout as a series of single pages. This might be necessary if you are using, for
example, a fan-fold or concertina approach, in which case the distinction between leftand right-hand pages is insignificant.
TIP
You can change the default view type used for all future projects on the General page in
Preferences.

RELATED LINKS
Preferences dialog on page 62
Switching to galley/page view on page 60
Page formatting on page 435
Condensing on page 470
Players on page 108
Instruments on page 112

Page arrangements for page view
You can change the way pages are arranged for display in the music area.
Spreads Horizontally
Displays pages in pairs as two-page spreads, with each pair laid out from left to right in
a row.
Spreads Vertically
Displays pages in pairs as two-page spreads, with each pair laid out from top to bottom
in a column.
Single Pages Horizontally
Displays individual pages laid out from left to right.
Single Pages Vertically
Displays individual pages laid out from top to bottom.
RELATED LINKS
Switching to galley/page view on page 60
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Zoom options
Zoom options in the status bar allow you to change the displayed size of pages in the music area.
Custom Zoom
Opens a dialog that allows you to set a custom zoom percentage.
Set Zoom
Allows you to select one of the preset zoom scaling factors. You can set a permanent
zoom factor for all future projects on the General page in Preferences.
Zoom Out
Decreases the size of notes and notations in the music area.
Zoom In
Increases the size of notes and notations in the music area.
RELATED LINKS
Preferences dialog on page 62
Zooming in/out of the music area on page 334

Workspace setup
Dorico Pro enables you to set up your workspace according to your working style.
Dorico Pro allows you to open multiple tabs to display multiple layouts in the same project within
the same window. You can also open the same project in several windows.
RELATED LINKS
Hiding/Showing panels on page 24
Navigation on page 331

Switching between layouts
If you have created several layouts in your project, you can switch between which is displayed in
the music area in every mode. In Setup, Write, and Engrave modes, this changes the layout
displayed in the current tab only.
NOTE
You can only switch between layouts to which players are assigned.

PROCEDURE
●

Switch to another layout in any of the following ways:
●

Press Shift-Alt/Opt-] to switch to the next layout.

●

Press Shift-Alt/Opt-[ to switch to the previous layout.

●

Select an item on a staff or in the piano roll of the player whose layout you want to open
and press W .
NOTE
Implicit rests are not items.

●

Select a layout from the layout selector in the toolbar.

55
Dorico Pro 3.1.10

User interface
Workspace setup

RESULT
The selected layout is opened in the music area. It replaces the layout previously open in the tab.
RELATED LINKS
Layouts on page 134
Implicit vs. explicit rests on page 1107

Opening new tabs
You can open multiple tabs in the same project window, which you can use to display multiple
layouts or different views of the same layout. For example, you can show your full score layout in
page view in one tab and in galley view in another tab.
Each tab can contain a separate layout or a different view of a layout already open in another tab
or window. Whenever you open a new tab, you are prompted to select a layout that you want to
display in the tab.
You can find tabs in the tab bar, located at the top of the music area, below the toolbar. If you do
not see any tabs, click Show Tabs in the toolbar.

PROCEDURE
1.

Open a new tab in any of the following ways:
●

Press Ctrl/Cmd-T .

●

At the right end of the tab bar, click New Tab.

●

Choose Window > New Tab.

A new tab opens that shows recent layouts at the top and a list of other layouts in the project
at the bottom.
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2.

Select a layout to open in the new tab in any of the following ways:
●

Click one of the icons.

●

Select a layout from the list at the bottom.

●

Select a layout from the layout selector in the toolbar.

RESULT
The layout that you choose opens in the active tab.
TIP
You can also switch between different layouts within the same tab.

RELATED LINKS
Tab bar on page 46
Toolbar on page 43

Closing tabs
You can close individual tabs of layouts that you no longer need, and you can close multiple tabs
at the same time.
PROCEDURE
●

Close tabs in any of the following ways:
●

Select the tab you want to close and press Ctrl/Cmd-W .

●

Hover over the tab you want to close and click x.

●

Right-click the single tab you want to close and choose Close Tab from the context
menu.
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●

Right-click the tab you do not want to close and choose Close Other Tabs from the
context menu.

NOTE
You cannot close the last tab in a window. If only one tab is open and you no longer want to
see the tabs, deactivate Show Tabs in the main toolbar. The tab is no longer displayed, but
the corresponding layout is still shown.

RESULT
If you selected a single tab and closed it, the selected tab and its corresponding layout are
closed.
If you selected a single tab and closed other tabs, all open tabs except for the selected tab are
closed.

Switching between tabs
You can switch between different open tabs to show different layouts in the music area.
PROCEDURE
●

Switch tabs in any of the following ways:
●

Press Ctrl-Tab to cycle through all open tabs.

●

Press Ctrl/Cmd - Shift - Tab to cycle through all open tabs in reverse order.

●

Click the tab to which you want to switch.

Changing the order of tabs
You can move tabs to a different position on the tab bar.
PROCEDURE
●

Click and drag a tab to the new position.
The other tabs move to show where the dragged tab will be positioned.

Showing multiple tabs in the same project window
You can split your project window to display two tabs at the same time. The split can be either
vertical or horizontal, allowing you to display different layouts either side by side or above one
another.
Splitting your project window divides your currently open tabs into two groups. You can move
tabs between the groups at any time, for example, to compare different layouts or to compare
two views of the same layout.
PROCEDURE
1.

Select the tab of the layout that you want to move to a new tab group.

2.

Split the view in one of the following ways:
●

To show layouts side by side, choose Window > Vertical Split.

●

To show layouts above one another, choose Window > Horizontal Split.
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RESULT
The project window is split to show two tabs at the same time. The selected tab is moved to the
new tab group.

Moving tabs to another tab group
You can move tabs to other tab groups.
PREREQUISITE
You have opened at least two tabs and they are both shown in the same project window.
PROCEDURE
●

Click and drag the tab into the target tab group.

RELATED LINKS
Opening new tabs on page 56

Moving tabs to other windows
You can move tabs to another open window of the same project to show the corresponding
layouts in a new window.
NOTE
●

The layouts must belong to the same project. If you attempt to move a tab to a window of a
different project, a new window is created for the project to which the layout belongs.

●

You can only move tabs to other windows if you have opened at least two tabs.

PROCEDURE
●

Do one of the following:
●

To create a new window of the same project with the tab inserted, click and drag a tab
horizontally to the right/left, away from the tab bar and release it.

●

To insert the tab into the tab bar of another window of the same project, click and drag a
tab onto the tab bar.

●

Select a tab, right-click it, and choose Move Tab To New Window from the context
menu.

●

Select a tab and choose Window > Move Tab To New Window.

Opening multiple project windows
You can open multiple project windows for the same project, for example, if you want to work on
multiple layouts at the same time. You can also show a different mode of the same project in
each window, such as having one window show Write mode and another show Play mode.
During playback, all windows that belong to the same project show the playhead and move the
view to follow the music during playback.
PROCEDURE
●

Open a new project window in any of the following ways:
●

Press Ctrl/Cmd-Shift-T .
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●

Choose Window > New Window.

RESULT
A duplicate of the window opens. It contains the same tabs and the same view options as the
original window.
RELATED LINKS
Playhead on page 540

Changing to full screen mode
You can maximize the amount of screen space available for your music by making any project
window cover the whole screen.
You can also hide the desktop elements provided by your operating system, for example, the
task bar in Windows or the system menu bar and Dock in macOS.
Within Dorico Pro, you can also hide/show the panels on the right, left, and at the bottom of the
window.
PROCEDURE
●

Choose View > Full Screen.

AFTER COMPLETING THIS TASK
To return to the default view, choose View > Full Screen again.
RELATED LINKS
Hiding/Showing panels on page 24
Zooming in/out of the music area on page 334

Switching to galley/page view
You can switch between different view types in the music area, for example, if a flute player in
your project is doubling piccolo, you can switch to galley view to see the piccolo staff in addition
to the flute staff.
PROCEDURE
1.

2.

Switch to galley or page view in any of the following ways:
●

Press Ctrl/Cmd-Alt/Opt-2 to switch to galley view.

●

Press Ctrl/Cmd-Alt/Opt-1 to switch to page view.

●

In the status bar, select Galley View or Page View from the view selector.

Optional: If you selected Page View, choose one of the available page arrangements in the
status bar.
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Spreads Horizontally

Spreads Vertically

Single Pages
Horizontally

Single Pages Vertically

RESULT
The view type in the music area is changed. In page view, only staves containing notes or items
are shown by default. For players holding multiple empty instruments, only the top instrument is
shown in full scores.
In galley view, all staves in the project are shown. However, note spacing is unjustified and there
is no automatic vertical collision avoidance, so notes and items might overlap.
TIP
●

You can change the default gaps between staves in galley view on the Vertical Spacing page
in Setup > Layout Options.

●

You can change the default view type used for all projects in the View section of the General
page in Preferences.

RELATED LINKS
View types on page 53
Page arrangements for page view on page 54
Changing the staff spacing in galley view on page 458
Zooming in/out of the music area on page 334

Changing the window color theme
You can change the color theme used throughout Dorico Pro, for example, you might switch to
the light theme if you prefer to read dark text on a light background. By default, Dorico Pro uses
the dark theme, which shows light text on a dark background.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click General in the page list.

3.

In the Window section, select one of the following options from the Theme menu:

4.

●

Dark

●

Light

Click Apply, then Close.

RESULT
The color theme used in Dorico Pro is changed. This affects the current project immediately and
all future projects you open, until you next change your setting.
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EXAMPLE

Dark theme

Light theme

Changing your preferred unit of measurement
You can change your default preferred unit of measurement to be used throughout Dorico Pro
for options that use absolute measurements, such as the size of page margins in Layout
Options. It does not affect options that are relative to the size of staves, such as options in
Engraving Options or Notation Options.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click General in the page list.

3.

In the General section, select one of the following options from the Preferred unit of
measurement menu:

4.

●

Points (pt)

●

Millimeters (mm)

●

Inches (in)

●

Centimeters (cm)

Click Apply, then Close.

Preferences dialog
In the Preferences dialog, you can make permanent settings for your workspace and define key
commands.
You can open Preferences in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Dorico > Preferences (macOS).

●

Choose Edit > Preferences (Windows).
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Preferences

The Preferences dialog contains the following:
1

Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages. When you click a page in this list, any applicable section titles appear below the page
in the page list.

2

Section titles
Shows the titles of any sections on the selected page. You can click these section titles to
navigate directly to that section of the page.

3

Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible settings,
the current setting is highlighted.
NOTE
The arrangement of options on the Key Commands page is significantly different to other
pages in the Preferences dialog. This page is described separately in further detail.

RELATED LINKS
View types on page 53
Zoom options on page 55
Selection tools on page 53
Layout Options dialog on page 104

Key Commands page in the Preferences dialog
The Key Commands page in the Preferences dialog allows you to view all the items and
functions that can be assigned key commands, change existing key commands, and assign new
key commands to items and functions that have no key command assigned by default.
Most of the main menus in Dorico Pro have key commands for certain menu items. In addition,
there are other Dorico Pro functions that can be assigned key commands. This can be helpful for
items or actions that you find yourself performing regularly, such as changing the rhythmic grid
resolution or exporting all layouts to PDF.
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●

You can find the Key Commands page by opening the Preferences dialog and clicking Key
Commands in the page list.

Key Commands page in Preferences

The Key Commands page comprises the following:
1

Search field
Allows you to search for menu items and functions to view, change, or add key commands.
Because there are multiple levels of disclosure arrows before you reach many menu items
and functions, this is often the quickest way to find what you are looking for.

2

Menu items and functions
Displays the menu items and functions that can be assigned key commands. The list can be
filtered using the Search field. Disclosure arrows beside options indicate that further options
are available when the option is expanded.
Hovering over menu items and functions shows a tool tip, which is helpful for some
functions with particularly long names.

3

Key Commands section
Allows you to see any existing key commands set for the selected menu item or function in
the list of assigned key commands and to set new ones. If you enter a key command that has
already been assigned to another menu item or function, a warning tells you that you cannot
use that key command.
You can assign multiple key commands to the same menu item or function, and the
Keyboard language menu allows you to assign different key commands for each of the
available languages.

4

●

Add Key Command: Adds the key command you pressed to the selected menu item or
function.

●

Remove Key Command: Removes the currently selected key command from the
selected menu item or function.

●

Print Summary: Directs you to an offline page in a web browser that displays your key
commands on an interactive keyboard.

●

Reset Key Commands: Resets all of your key commands to their defaults.

MIDI Learn section
Allows you to assign MIDI controllers, notes, and combinations of notes to control menu
items and functions.
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●

MIDI Learn: Prepares Dorico Pro to receive the MIDI input data that you want to save as
a command.

●

Add MIDI Command: Adds the MIDI controllers or notes you changed or pressed to the
selected menu item or function.

●

Remove MIDI Command: Removes the MIDI command from the selected menu item or
function.

RELATED LINKS
Assigning key commands on page 66
Assigning MIDI commands on page 67

Interactive Dorico Pro key commands map
The interactive Dorico Key Commands map shows a virtual computer keyboard, with keys that
have been assigned key commands highlighted in different colors according to the modifier keys
they contain. All key commands for the selected keyboard language layout are listed below,
divided into global and mode-specific groups.
You can open the Dorico Key Commands map in any of the following ways:
●

Choose Help > Key Commands.

●

Choose Edit > Preferences, and click Print Summary in the Key Commands section of the
Preferences dialog.

The interactive key commands map as it appears when US English is selected

The Dorico Key Commands map opens in a web browser. It allows you to do any of the
following:
●

To see the available key commands, select a context. The context of a key command is the
mode in which it can be used. Key commands that have a global context work in all modes.

●

To highlight the keys that you can press in combination with the modifier key to form a key
command, press a modifier key on your computer keyboard, such as Shift , or click a
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modifier key on the virtual keyboard. You can also press more than one modifier key. The
virtual computer keyboard shows the highlighted keys and displays on each key to which
functions it is assigned.
●

To search for a specific key command, enter one or multiple words in the search field.

●

To get an overview of all available key commands, browse the key commands that are listed
below the virtual keyboard. The key commands are listed according to the context in which
they can be used.

RELATED LINKS
Changing the keyboard layout on page 67

Searching for the key commands of functions
You can search for key commands that are assigned to functions or menu items in Dorico Pro.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Key Commands in the page list.

3.

Enter the name of a function in the Search field.
The entries that are listed below are filtered according to the words that you enter.

4.

Expand an entry and select the function for which you want to see the key command.
For particularly long names, you can hover over them to see a tool tip.

RESULT
If the function has a key command, it is shown in the list of assigned key commands.
TIP
You can also search for functions in the interactive key commands map.

Assigning key commands
You can assign key commands to many menu items and functions, for example, if you use a
menu item frequently and want to be able to access it quickly but it does not have a key
command assigned by default. You can also change existing key commands.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Key Commands in the page list.

3.

Search for the name of a function and select it.
For particularly long names, you can hover over them to see a tool tip.

4.

Optional: Press Remove Key Command if the function already has an assigned key
command.
If you assign a new key command without removing an existing one, you can use either key
command.

5.

Click the Press shortcut input field.

6.

Press the key command that you want to assign on your computer keyboard.

7.

Click Add Key Command.
The key command is added to the list of assigned key commands.
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8.

Click Apply, then Close.

RESULT
The key command you pressed is assigned to the selected menu item or function. You can use it
immediately.
RELATED LINKS
Resetting key commands on page 68

Assigning MIDI commands
You can assign specific keys or buttons on your MIDI keyboard to perform functions and access
menu items. For example, if you want to navigate using MIDI keys during chord symbol input.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Key Commands in the page list.

3.

Select the menu item or function to which you want to assign MIDI commands.
For particularly long names, you can hover over them to see a tool tip.

4.

Click MIDI Learn.

5.

Press the key or button on your MIDI keyboard that you want to assign to the selected
parameter.

6.

Click Add MIDI Command.

7.

Click Apply, then Close.

Changing the keyboard layout
You can change the keyboard layout in Dorico Pro to that of another language. This allows you to
use the predefined key commands for the selected language.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Key Commands in the page list.

3.

Select a different keyboard layout from the Keyboard language menu.

4.

Click Apply, then Close.

RESULT
You can immediately use the available key commands for the selected language.

Removing key commands
You can remove individual key commands from a function.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Key Commands in the page list.

3.

Search for the name of a function and select it.
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4.

Click Remove Key Command.

5.

Click Apply, then Close.

RESULT
The key command is removed from the selected function.
RELATED LINKS
Searching for the key commands of functions on page 66

Resetting key commands
You can reset all the key commands in your project to their defaults.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Key Commands in the page list.

3.

Click Reset Key Commands.

4.

Click Apply, then Close.

RESULT
All custom key commands are deleted and the default key commands are reinstated.
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Project and file handling
In addition to opening and importing/exporting projects and other file formats, project and file
handling also includes auto-save and project backups.
RELATED LINKS
File import and export on page 75
Auto-save on page 91
Project backups on page 92

Hub
When you start Dorico Pro, the Hub opens. The Hub keeps you up-to-date with the latest Dorico
information and tutorials, and assists you with organizing your projects.

The Hub contains the following:
1

Recent Projects
Allows you quick access to the projects that you worked on last. Selecting Recent Projects
shows them in the list. You can scroll through the list using either a mouse/touchpad or the
Up Arrow / Down Arrow keys.

2

Project template categories
Allows you quick access to a suitable project template in the available categories. Selecting a
category shows the possible templates in that category in the list.

3

New Empty Project
Starts a new project with no players or flows.

4

List
Displays either recent projects or project templates, depending on your selection on the left
of the dialog.
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5

Open Other
Allows you to search for and open any other project file in the File Explorer/macOS Finder.

6

New from Template (project template selected)
Creates a new project using the selected project template. This option is only available if you
have selected a project template.
Open Selected Project (recent project selected)
Opens the recent project file that you selected in the list.

7

User Forum
Links you to the user forum on the Steinberg website.

8

Downloads
Links you to the downloads page on the Steinberg website, where you can find relevant
update installers and a link to the documentation.

9

News
Displays recent Dorico news from the Dorico blog. Double-clicking a news item, or selecting
it and clicking Read More, opens it in a web browser.

10 Video Tutorials
Displays recent Dorico video tutorials. Double-clicking a video tutorial, or selecting it and
clicking Watch Now, opens it in a web browser.
11 More Videos
Links you directly to the Dorico YouTube channel, where you can find tutorial videos and
information about new features.
RELATED LINKS
Project template categories on page 71

Starting new projects
Dorico Pro provides several ways to start new projects.
PROCEDURE
●

Start a new project in any of the following ways:
●

Press Ctrl/Cmd-N at any time.

●

Choose File > New at any time.

●

In the Hub, click New Empty Project.

RESULT
A new project window opens.

Starting new projects from project templates
Dorico Pro provides multiple project templates that you can use to start a new project, for
example, multiple types of orchestras and vocal ensembles.
PROCEDURE
1.

In the Hub, select one of the following project template categories:
●

Orchestral

●

Band

●

Jazz
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●

Chamber

●

Choral and Vocal

●

Solo

2.

Select a project template in the list.

3.

Click New from Template.

RESULT
The project template opens in a new project window.
TIP
You can also start a new project from a template at any time by choosing File > New From
Template > [Template category] > [Project template].
AFTER COMPLETING THIS TASK
You can add additional players/instruments and delete players/instruments that were included in
the template to customize your project.
RELATED LINKS
Brackets according to ensemble type on page 685
Adding solo/section players on page 109
Adding instruments to players on page 116
Deleting players on page 111
Deleting instruments on page 119

Project template categories
Dorico Pro provides a number of different project template categories. Projects started from
different project template categories have different default settings that follow conventions as
appropriate for the ensemble, such as for bracketing and bracing or staff labels.
Orchestral
Large ensembles containing most Western instruments, including strings, woodwinds,
brass, and percussion.
Band
Large ensembles containing primarily wind instruments, including woodwind and
brass instruments, and optionally percussion and other instruments, such as strings
and guitars.
Jazz
Popular ensembles commonly used to perform jazz, such as big band or jazz trio.
Chamber
Typically small ensembles containing only a few players, such as string quartet.
Choral and Vocal
Ensembles containing voices, including popular choir arrangements, such as SATB
unaccompanied.
Solo
Ensembles containing only a single player/instrument, such as a solo organ or guitar
with tablature.
RELATED LINKS
Brackets according to ensemble type on page 685
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System objects on page 1172

Opening projects/files
You can open Dorico Pro projects at any time, for example, if the project you want to open is not
listed as a recent project in the list in the Hub. You can also open MusicXML and MIDI files.
PROCEDURE
1.

Open the File Explorer/macOS Finder in any of the following ways:
●

In the Hub, click Open Other.

●

Choose File > Open.

●

Choose File > Open Recent > [Project file name].

2.

In the File Explorer/macOS Finder, locate and select the files you want to open.

3.

Click Open.

RESULT
The selected Dorico projects are opened.
If you opened MusicXML or MIDI files, Dorico Pro creates new project files from the MusicXML or
MIDI content, which you can save as default Dorico Pro projects.
If MusicXML files include page size, margin, and staff size settings, Dorico Pro imports those
values. If they are not included, Dorico Pro creates suitable settings according to the number of
instruments in the file.
TIP
You can also import MusicXML and MIDI files as new flows in existing projects rather than
opening them as separate projects.

RELATED LINKS
Hub on page 69
Importing MusicXML files on page 78
Importing MIDI on page 81

Opening recent projects from the Hub
You can open a project on which you have recently worked from the Steinberg Hub.
PROCEDURE
1.

In the Hub, click Recent Projects.

2.

In the list, select a recent project in any the following ways:
●

Press Up Arrow / Down Arrow to navigate to the project file name, then press Return
to open it.

●

Double-click a project file name.

●

Select a project file name and click Open Selected Project.

RESULT
The selected Dorico projects are opened.
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Projects from different versions of Dorico
You can open projects that were last saved in other versions of Dorico than the one you have. In
such cases, Dorico Pro shows a warning message to make you aware of any implications.
The contents of the warning message vary according to the version of Dorico in which the project
was last saved:
●

When opening a project last saved in an older version, it shows the version number the
project was last saved in and informs you that the project will be updated to your current
version.

●

When opening a project last saved in a newer version, it shows only that the project is from a
newer version. It also informs you that items and notations from that version might not
appear and will be deleted if you save the project in your current version.

In both cases, opening the project is non-destructive. This means that its contents and
formatting are unaffected if you do not save it.
You can prevent Dorico Pro from showing you warnings about projects from different versions in
the Files section of the General page in Preferences. In the same section, you can also tell
Dorico Pro to prompt you to choose a new location for projects from different versions when you
save them. This reduces the risk of you overwriting them by mistake.
RELATED LINKS
Preferences dialog on page 62

Missing Fonts dialog
The Missing Fonts dialog appears when you open a project that contains a font that you do not
have installed on your computer. It allows you to select replacement fonts that are installed on
your computer as substitutes.
The Missing Fonts dialog displays a table with multiple columns that identify the specific font
families and styles that are missing for font, character, and paragraph styles and text objects.
Every place in the project where a font is missing has its own row. For example, if the bold style
of a font family is used in three different paragraph styles, three rows are shown in the dialog,
one for each paragraph style.
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Missing Fonts dialog

The Missing Fonts dialog comprises the following:
1

Missing Family column
Contains a list of font families included in the project but missing on your computer.

2

Missing Style column
Contains a list of the specific styles within the corresponding font families that are included
in the project but missing on your computer.

3

Used By column
Contains a list of the places in the project where the corresponding font is used.

4

Replacement Family column
Allows you to select replacement font families. Once selected, their names are displayed in
the corresponding entry.

5

Replacement Style column
Allows you to select any of the available styles within the corresponding replacement font
families. Once selected, the styles are displayed in the corresponding entry.

6

Available font menu
Contains a list of all the available fonts installed on your computer. You can access the menu
in the Replacement Family and Replacement Style columns by double-clicking any entry.

TIP
You can choose whether or not the Missing Fonts dialog appears when you open a project
containing fonts not installed on your computer on the General page in Preferences.

RELATED LINKS
Preferences dialog on page 62
Edit Font Styles dialog on page 407
Character Styles dialog on page 413
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Paragraph Styles dialog on page 410
Text editor options in Write mode on page 313
Text editor options in Engrave mode on page 415

File import and export
External files are files in different formats than Dorico projects, such as MIDI, MusicXML, or
tempo tracks. It is possible in Dorico Pro both to import and export different types of files.
This can be useful if, for example, you want to share your project with others who use a different
notation software, or to convert the notes, audio, or time signatures and tempo information in
your project into other formats.

Importing flows
You can import individual flows into existing projects, for example, if you want to bring together
multiple existing pieces into one project for publishing, or if you have an empty project file with
your preferred settings saved and want to reuse those settings.
PROCEDURE
1.

Choose File > Import > Flows to open the File Explorer/macOS Finder.

2.

In the File Explorer/macOS Finder, locate and select the project files of the flows you want to
import.

3.

Click Open to open the Flow Import Options dialog for the first selected project.

4.

In the Flow Import Options dialog, choose one of the following options for Player
handling:
●

Create All New Players

●

Merge with Existing Players Where Possible

5.

In the Import flows list, activate the checkbox for each flow you want to import.

6.

Click OK to import the selected flows and close the dialog.

7.

Optional: If you selected multiple projects from which to import flows, repeat steps 4 to 6 for
each project. The Flow Import Options dialog reopens automatically for each project.

RESULT
The selected flows are imported into the project.
●

If you chose Create All New Players, new players are added as required for each flow.

●

If you chose Merge with Existing Players Where Possible, any players that the imported
flows and existing project have in common are merged, for example, if you imported a flow
containing a solo piano into a project containing a piano and viola, the imported flow is
added to the existing piano player.

NOTE
●

Players are not automatically added to flows that you imported into the project.

●

You can also open flows directly if you want them to be separate projects rather than new
flows in existing projects.

RELATED LINKS
Opening projects/files on page 72
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Flow Import Options dialog
The Flow Import Options dialog allows you to determine whether players in imported flows are
merged with existing players in the project and which flows from within other projects you want
to import.
●

You can open the Flow Import Options dialog by choosing File > Import > Flows and
opening a Dorico project from the File Explorer/macOS Finder.

Flow Import Options dialog

The Flow Import Options dialog comprises the following:
1

Player handling
Allows you to determine how imported flows are assigned to players.

2

●

Create All New Players adds separate players for each imported flow.

●

Merge with Existing Players Where Possible merges players from imported flows with
any existing compatible players in the project.

Import flows
Contains a list of all the flows in the selected project. Flows are included in the import when
their checkbox is activated.

Exporting flows
You can export individual flows from projects, for example, to save small excerpts of large
projects separately.
NOTE
These steps export flows as separate Dorico projects. If you want to export flows as other file
formats, such as MusicXML or MP3, there are different methods.

PROCEDURE
1.

Choose File > Export > Flows to open the Export Flows dialog.

2.

In the Export Flows dialog, activate/deactivate Export each selected flow as a separate
file.

3.

In the Select flows to export list, activate the checkbox for each flow you want to export.
You can also click Select All or Select None at the bottom of the list.

4.

Activate/Deactivate Export layouts as separate files.
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5.

Optional: If you activated Export layouts as separate files, activate the checkbox for each
layout you want to export in the Select layouts to export list. You can also click Select All or
Select None at the bottom of the list.

6.

Click Choose Folder beside the Export to field to open the File Explorer/macOS Finder.

7.

In the File Explorer/macOS Finder, locate and select the destination folder you want.

8.

Click Select Folder (Windows)/Open (macOS) to insert the new path in the Export to field.

9.

Activate/Deactivate Create folder for exported files.

10. Click OK to export the selected flows and layouts and close the dialog.

RELATED LINKS
Exporting MusicXML files on page 79
Exporting MIDI on page 84
Exporting tempo tracks on page 87
Exporting audio on page 88

Export Flows dialog
The Export Flows dialog allows you to save individual flows and layouts as separate Dorico files.
●

You can open the Export Flows dialog by choosing File > Export > Flows.

Export Flows dialog

The Export Flows dialog contains the following options and lists:
1

Export each selected flow as a separate file
Allows you to export each flow as a separate file instead of all the selected flows as a single
file.

2

Select flows to export
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Contains a list of all the flows in the project. Flows are included in the export when their
checkbox is activated.
3

Export layouts as separate files
Allows you to export each layout in the project as a separate file instead of as a single file.

4

Select layouts to export
Contains a list of all the layouts in the project. Layouts are included in the export when their
checkbox is activated. Only available if you have activated Export layouts as separate files.

5

Selection options
Allow you to select/deselect all the flows/layouts in the corresponding list. For example, you
can deselect all flows and then activate the checkbox of a single flow you want to export.

6

Create folder for exported files
Controls whether or not Dorico Pro generates a new folder for the selected flows within the
selected export path. The automatic folder name is “Flows from” followed by the project file
name, for example, “Flows from Smyth - String Quintet”.

7

Export to field
Displays the current export path where exported flows will be saved.

8

Choose Folder
Opens the File Explorer/macOS Finder and allows you to change the export path.

Importing MusicXML files
You can import MusicXML files into existing Dorico Pro projects as separate flows, for example, to
continue work on a piece started in a different notation software.
PROCEDURE
1.

Choose File > Import > MusicXML to open the File Explorer/macOS Finder.

2.

In the File Explorer/macOS Finder, locate and select the MusicXML files you want to import.

3.

Click Open to open the Flow Import Options dialog for the first selected MusicXML file.

4.

In the Flow Import Options dialog, choose one of the following options for Player
handling:
●

Create All New Players

●

Merge with Existing Players Where Possible

5.

Click OK to import the selected flows and close the dialog.

6.

Optional: If you selected multiple MusicXML files, repeat steps 4 and 5 for each file. The Flow
Import Options dialog reopens automatically for each file.

RESULT
The selected MusicXML files are imported into the project as new flows.
●

If MusicXML files include page size, margin, and staff size settings, Dorico Pro imports those
values. If they are not included, Dorico Pro creates suitable settings according to the number
of instruments in the file.

●

If you chose Create All New Players, new players are added as required for each MusicXML
file.

●

If you chose Merge with Existing Players Where Possible, any players that the imported
MusicXML files and existing project have in common are merged, for example, if you
imported a MusicXML file containing a solo piano into a project containing a piano and viola,
the imported MusicXML file is added to the existing piano player.
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TIP
●

You can also open MusicXML files directly if you want them to be separate projects rather
than new flows in existing projects.

●

You can change your default preferences for the handling of imported MusicXML files on the
MusicXML Import page in Preferences.

RELATED LINKS
Flow Import Options dialog on page 76
Opening projects/files on page 72

Exporting MusicXML files
You can export flows and layouts as separate MusicXML files, for example, if you want to export
just the soloist’s layout containing the first flow.
PROCEDURE
1.

Choose File > Export > MusicXML to open the Export MusicXML dialog.

2.

In the Export MusicXML dialog, choose one of the following file format options:
●

Export compressed XML (.mxl)

●

Export uncompressed XML (.xml)

3.

In the Select flows to export list, activate the checkbox for each flow you want to export.
You can also click Select All or Select None at the bottom of the list.

4.

Activate/Deactivate Export layouts as separate files.

5.

Optional: If you activated Export layouts as separate files, activate the checkbox for each
layout you want to export in the Select layouts to export list. You can also click Select All or
Select None at the bottom of the list.

6.

Click Choose Folder beside the Export to field to open the File Explorer/macOS Finder.

7.

In the File Explorer/macOS Finder, locate and select the destination folder you want.

8.

Click Select Folder (Windows)/Open (macOS) to insert the new path in the Export to field.

9.

Activate/Deactivate Create folder for exported files.

10. Click OK to export the selected flows/layouts as MusicXML files and close the dialog.

Export MusicXML dialog
The Export MusicXML dialog allows you to save individual flows and layouts as separate
MusicXML files.
●

You can open the Export MusicXML dialog by choosing File > Export > MusicXML.
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Export MusicXML dialog

The Export MusicXML dialog contains the following options and lists:
1

File format options
Allows you to choose the MusicXML file format you want to export. Compressed MusicXML
files contain the same information as uncompressed MusicXML files but have a smaller file
size.

2

Select flows to export
Contains a list of all the flows in the project. Flows are included in the export when their
checkbox is activated.

3

Export layouts as separate files

4

Select layouts to export

Allows you to export each layout in the project as a separate file instead of as a single file.
Contains a list of all the layouts in the project. Layouts are included in the export when their
checkbox is activated. Only available if you have activated Export layouts as separate files.
5

Selection options
Allow you to select/deselect all the flows/layouts in the corresponding list. For example, you
can deselect all flows and then activate the checkbox of a single flow you want to export.

6

Create folder for exported files
Controls whether or not Dorico Pro generates a new folder for the selected flows within the
selected export path. The automatic folder name is “Flows from” followed by the project file
name, for example, “Flows from Smyth - String Quintet”.

7

Export to field
Displays the current export path where exported files will be saved.

8

Choose Folder
Opens the File Explorer/macOS Finder and allows you to change the export path.
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Importing MIDI
You can import MIDI files into existing Dorico Pro projects as separate flows, for example, to
work on a different version of a section of a piece.
PROCEDURE
1.

Choose File > Import > MIDI to open the File Explorer/macOS Finder.

2.

In the File Explorer/macOS Finder, locate and select the MIDI files you want to import.

3.

Click Open to open the MIDI Import Options dialog for the first selected MIDI file.

4.

In the MIDI Import Options dialog, change the settings as required.

5.

Optional: If you want to customize the quantization settings, click Quantize Options and
change the settings in the MIDI Quantize Options dialog.

6.

Optional: Click OK to save your quantization settings and return to the MIDI Import Options
dialog.

7.

Click OK to close the MIDI Import Options dialog, which automatically opens the Flow
Import Options dialog for the first selected MIDI file.

8.

In the Flow Import Options dialog, choose one of the following options for Player
handling:

9.

●

Create All New Players

●

Merge with Existing Players Where Possible

Click OK to import the selected flows and close the dialog.

10. Optional: If you selected multiple MIDI files, repeat steps 4 to 9 for each file. The MIDI
Import Options and Flow Import Options dialogs reopen automatically for each file.
RESULT
The selected MIDI files are imported into the project as new flows. Dorico Pro uses an algorithm
on imported MIDI notes to produce the correct enharmonic spelling for the imported notes.
●

If the MIDI files contained markers, they are also imported, and if they have SMPTE offset
values defined, Dorico Pro uses them to set the timecode position for the start of the flow.

●

If you chose Create All New Players, new players are added as required for each MIDI file.

●

If you chose Merge with Existing Players Where Possible, any players that the imported
MIDI files and existing project have in common are merged, for example, if you imported a
MIDI file containing a solo piano into a project containing a piano and viola, the imported
MIDI file is added to the existing piano player.

TIP
You can also open MIDI files directly if you want them to be separate projects rather than new
flows in existing projects.

RELATED LINKS
Opening projects/files on page 72
Requantizing notes on page 206
Changing the sustain pedal controller settings for MIDI recording/import on page 209

MIDI Import Options dialog
The MIDI Import Options dialog allows you to customize the settings Dorico Pro uses to
translate MIDI data into a Dorico project when importing MIDI files.
●

You can open the MIDI Import Options dialog by choosing File > Import > MIDI and
opening a MIDI file from the File Explorer/macOS Finder.
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MIDI Import Options dialog

The MIDI Import Options dialog contains the following sections:
1

Instrument handling
The options in this section determine how Dorico Pro chooses and names instruments based
on the imported MIDI file.
The Quantize Options button opens the MIDI Quantize Options dialog, which allows you
to customize the quantization settings.

2

Keyboard handling
The options in this section determine how Dorico Pro interprets keyboard music based on
the imported MIDI file, including the MIDI note number at which notes are split between the
right and left hand staves and whether CC64 indicates pedal lines.

3

Performance preservation
The options in this section allow you to determine how much of the original performance in
the MIDI file you want to preserve for playback purposes. They do not affect how the
imported MIDI notes are notated, as this is controlled by the quantization options set.

4

Player handling
The options in this section allow you to determine the players and layouts to which
instruments in the MIDI file are assigned. For example, if you are importing a MIDI file into
an existing project in order to orchestrate, you might want to activate Create player group
for new players and deactivate Create part layouts for new players to add a single,
independent group of players without creating any extra part layouts for them.
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RELATED LINKS
Changing the sustain pedal controller settings for MIDI recording/import on page 209

MIDI Quantize Options dialog
The MIDI Quantize Options dialog allows you to customize the quantization settings you want
to apply to imported MIDI files and notes input by recording with a MIDI device.
You can open the MIDI Quantize Options dialog in any of the following ways:
●

Click Quantize Options in the MIDI Import Options dialog.

●

Click Quantization Options in the Recording subsection of the Play page in Preferences.

NOTE
Your settings are linked between both ways of accessing the dialog.

MIDI Quantize Options dialog

The MIDI Quantize Options dialog contains the following options:
Quantization unit
Allows you to set the smallest beat unit to which you want notes to be quantized. For
example, if the smallest intentional note duration in your imported file is an eighth
note, set Quantization unit to eighth notes.
Detect tuplets
Allows you to control whether off-beat notes can be considered tuplets. If you know
there are no intentional tuplets in your imported MIDI file, deactivating Detect tuplets
ensures no notes are imported as tuplets.
Quantization unit for tuplets
Allows you to set the smallest beat unit to which you want tuplet notes to be quantized.
For example, if the smallest intentional tuplet note duration in your imported file is a
quarter note, set Quantization unit for tuplets to quarter notes.
Fill gaps
Allows you to determine whether Dorico Pro fills in gaps between short notes. If you
are importing already precisely quantized music, we recommend that you deactivate
Fill gaps to ensure that note and rest durations are notated exactly as quantized.
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RELATED LINKS
MIDI recording on page 204

Exporting MIDI
You can export flows as separate MIDI files, for example, if you want to edit the audio in further
detail in a DAW. MIDI files exported from Dorico Pro contain any markers in the project by
default.
PREREQUISITE
You have positioned a layout containing the players whose MIDI you want to export at the top of
the Layouts panel in Setup mode.
PROCEDURE
1.

Choose File > Export > MIDI to open the Export MIDI dialog.

2.

In the Select flows to export list, activate the checkbox for each flow you want to export.
You can also click Select All or Select None at the bottom of the list.

3.

Click Choose Folder beside the Export to field to open the File Explorer/macOS Finder.

4.

In the File Explorer/macOS Finder, locate and select the destination folder you want.

5.

Click Select Folder (Windows)/Open (macOS) to insert the new path in the Export to field.

6.

Activate/Deactivate Create folder for exported files.

7.

Click OK to export the selected flows as MIDI files and close the dialog.

RESULT
The selected flows are exported as MIDI files. They contain the MIDI of all the players assigned to
the layout at the top of the Layouts list in Setup mode.
RELATED LINKS
Sorting layouts on page 138
Layouts panel (Setup mode) on page 98
Changing the players assigned to layouts on page 136

Export MIDI dialog
The Export MIDI dialog allows you to save individual flows as separate MIDI files.
●

You can open the Export MIDI dialog by choosing File > Export > MIDI.
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Export MIDI dialog

The Export MIDI dialog comprises the following:
1

Select flows to export
Contains a list of all the flows in the project. Flows are included in the export when their
checkbox is activated.

2

Selection options
Allow you to select/deselect all the flows in the project. For example, you can deselect all
flows and then activate the checkbox of a single flow you want to export.

3

Create folder for exported files
Controls whether or not Dorico Pro generates a new folder for the selected flows within the
selected export path. The automatic folder name is “Flows from” followed by the project file
name, for example, “Flows from Smyth - String Quintet”.

4

Export to field
Displays the current export path where exported files will be saved.

5

Choose Folder
Opens the File Explorer/macOS Finder and allows you to change the export path.

Importing tempo tracks
You can import tempo tracks into individual flows in existing projects, for example, if you are
writing music for a film and changes to the footage require tempo and time signature changes.
This does not overwrite the notes and notations in the flow.
PROCEDURE
1.

Choose File > Import > Tempo Track to open the File Explorer/macOS Finder.

2.

In the File Explorer/macOS Finder, locate and select the MIDI file whose tempo track you
want to import.

3.

Click Open to open the Import Tempo Track dialog.
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4.

In the Import into flow list, select the flow into which you want to import the tempo track.

5.

In the Import and replace section, activate the checkbox for each tempo track aspect you
want to include.

6.

Optional: If you activated the checkbox for Markers as, choose one of the following options:
●

Markers

●

System Text

7.

Optional: If you chose System Text for Markers as, activate/deactivate Show border
around system text markers.

8.

Click OK to import the tempo track and close the dialog.

RESULT
The tempo track is imported into the selected flow. All selected aspects are applied to the
existing music, and notes and tempo marks are adjusted as required.

Import Tempo Track dialog
The Import Tempo Track dialog allows you to import tempo tracks to individual flows within
projects and to control which aspects of the tempo track you want to apply to the flow.
●

You can open the Import Tempo Track dialog by choosing File > Import > Tempo Track
and opening a MIDI file from the File Explorer/macOS Finder.

Import Tempo Track dialog

The Import Tempo Track dialog comprises the following:
1

Import into flow
Contains a list of all the flows in the project. The currently selected flow is highlighted.
NOTE
You can only import tempo tracks into a single flow at a time.

2

Import and replace
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Allows you to control which tempo track aspects you want to include in your import and
apply to the selected flow.
●

Timecode display offset sets the initial timecode position at the start of the flow.

●

Tempo changes replaces all immediate and gradual tempo changes in the flow with the
tempo changes from the MIDI file.

●

Time signatures replaces all time signatures in the flow with time signatures from the
MIDI file.

●

Markers as adds any markers from the MIDI file to the flow as either Markers or
System Text.
Importing markers as Markers replaces any existing markers in the flow with markers
from the MIDI file, while importing markers as System Text does not replace any
existing markers or system text objects.

●

Show border around system text markers adds borders to markers imported as
system text objects when activated. Only available if you have chosen System Text for
Markers as.

Exporting tempo tracks
You can export flows as separate tempo tracks, for example, if you want to apply the tempo
marks and time signatures of one flow to a different flow, which can be in the same project.
PROCEDURE
1.

Choose File > Export > Tempo Track to open the Export Tempo Track dialog.

2.

In the Export Tempo Track dialog, activate the checkbox for each flow you want to export as
a tempo track. You can also click Select All or Select None at the bottom of the list.

3.

Click Choose Folder beside the Export to field to open the File Explorer/macOS Finder.

4.

In the File Explorer/macOS Finder, locate and select the destination folder you want.

5.

Click Select Folder (Windows)/Open (macOS) to insert the new path in the Export to field.

6.

Activate/Deactivate Create folder for exported files.

7.

Click OK to export the selected flows as tempo tracks and close the dialog.

Export Tempo Track dialog
The Export Tempo Track dialog allows you to save individual flows as separate tempo tracks in
the format of MIDI files.
●

You can open the Export Tempo Track dialog by choosing File > Export > Tempo Track.
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Export Tempo Track dialog

The Export Tempo Track dialog comprises the following:
1

Select flows to export
Contains a list of all the flows in the project. Flows are included in the export when their
checkbox is activated.

2

Selection options
Allow you to select/deselect all the flows in the project. For example, you can deselect all
flows and then activate the checkbox of a single flow you want to export.

3

Create folder for exported files
Controls whether or not Dorico Pro generates a new folder for the selected flows within the
selected export path. The automatic folder name is “Flows from” followed by the project file
name, for example, “Flows from Smyth - String Quintet”.

4

Export to field
Displays the current export path where exported files will be saved.

5

Choose Folder
Opens the File Explorer/macOS Finder and allows you to change the export path.

Exporting audio
You can export projects as audio files in either MP3 or WAV format, including exporting flows and
players as separate files, for example, if you want to share an audio mock-up of only the soloist’s
part in the second flow.
PREREQUISITE
You have positioned the full score layout from which you want to export audio at the top of the
Layouts panel in Setup mode.
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PROCEDURE
1.

Choose File > Export > Audio to open the Export Audio dialog.

2.

In the Export Audio dialog, choose one of the following file format options:
●

Export compressed mp3 (.mp3)

●

Export uncompressed WAV (.wav)

3.

Activate/Deactivate Export each selected flow as a separate file.

4.

In the Select flows to export list, activate the checkbox for each flow you want to export as
audio. You can also click Select All or Select None at the bottom of the list.

5.

Activate/Deactivate Export players as separate files.

6.

Optional: If you activated Export players as separate files, activate the checkbox for each
player you want to export in the Select players to export list. You can also click Select All or
Select None at the bottom of the list.

7.

Click Choose Folder beside the Export to field to open the File Explorer/macOS Finder.

8.

In the File Explorer/macOS Finder, locate and select the destination folder you want.

9.

Click Select Folder (Windows)/Open (macOS) to insert the new path in the Export to field.

10. Click OK to export the selected flows/players as the selected type of audio file and close the
dialog.

RELATED LINKS
Sorting layouts on page 138
Layouts panel (Setup mode) on page 98
Changing the players assigned to layouts on page 136

Export Audio dialog
The Export Audio dialog allows you to save individual flows and players as separate audio files,
either MP3 or WAV.
●

You can open the Export Audio dialog by choosing File > Export > Audio.
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Export Audio dialog

The Export Audio dialog contains the following options and lists:
1

File format options
Allows you to choose the audio file format you want to export. Compressed MP3 files are
smaller than WAV files but this corresponds to a reduced audio quality.

2

Export each selected flow as a separate file
Allows you to export each flow in the project as a separate audio file instead of as a single
audio file.

3

Select flows to export
Contains a list of all the flows in the project. Flows are included in the export when their
checkbox is activated.

4

Export players as separate files
Allows you to export each player in the project as a separate audio file instead of all players
in a single audio file.

5

Select players to export
Contains a list of all the players in the project. Players are included in the export when their
checkbox is activated. Only available if you have activated Export players as separate files.

6

Selection options
Allow you to select/deselect all the flows/players in the corresponding list. For example, you
can deselect all flows and then activate the checkbox of a single flow you want to export.

7

Export to field
Displays the current export path where exported audio files will be saved.

8

Choose Folder
Opens the File Explorer/macOS Finder and allows you to change the export path.
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Auto-save
The auto-save function stores a version of the currently active project at regular intervals,
including new projects you have not explicitly saved yet. This reduces the chances of losing
significant amounts of work if you accidentally close a project without saving or in the unlikely
event that Dorico Pro or your computer crashes.
Dorico Pro saves auto-save projects in an AutoSave folder inside the application data folder for
your user account. You cannot change this location.
NOTE
Dorico Pro might become less responsive briefly in order to perform auto-saves, particularly for
larger projects.

Auto-save with multiple projects open
Only the currently activated project is auto-saved at each auto-save interval if you have multiple
projects open. This is because only a single project at a time can be activated for playback. If you
are switching between multiple projects frequently, we recommend that you set a smaller autosave interval.

Removal of auto-save files
All files in the AutoSave folder are automatically deleted when you close their corresponding
projects and also when you quit Dorico Pro. You can find deleted auto-save projects in the bin on
your computer. Dorico Pro automatically adds “[AutoSave]” to the end of auto-save project file
names so you can identify them.
IMPORTANT
This includes any file in the AutoSave folder, not just auto-save projects. Therefore, it is
important that you do not manually save anything in the AutoSave folder.
TIP
If you want to access earlier versions of projects, you can use project backups.

RELATED LINKS
Toolbar on page 43
Project backups on page 92

Recovering auto-saved projects
If Dorico Pro crashes, you can recover the most recent auto-saved version of each project that
was open.
PROCEDURE
1.

Reopen Dorico Pro.

2.

In the Recover Auto-saved Projects dialog that opens after the Dorico Pro splash screen,
activate the checkbox for each auto-saved project you want to recover.
NOTE
Any auto-saved projects you do not recover are permanently deleted once you close the
dialog.
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3.

Click Recover Selected Projects to recover the selected auto-saved projects and close the
dialog.

RESULT
The selected auto-saved projects are recovered and opened in separate project windows.
AFTER COMPLETING THIS TASK
You can save auto-saved projects permanently in any folder location and with new file names if
required.

Changing the auto-save frequency
You can change how frequently Dorico Pro auto-saves projects. By default, the auto-save interval
is five minutes for the currently active project.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click General in the page list.

3.

In the Files section, change the value for Auto-save every [n] minutes.

4.

Click Apply, then Close.

Disabling auto-save
You can disable auto-save completely, for example, if it is significantly affecting the performance
of a large project.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click General in the page list.

3.

In the Files section, deactivate Auto-save every [n] minutes.

4.

Click Apply, then Close.

Project backups
Dorico Pro stores backup versions of your projects each time you save them explicitly. By default,
the previous five saves are stored as backups.
Their default location is in a folder named after the corresponding project file name in the
Backup Projects folder in the Dorico Projects folder, whose default location is in the
Documents folder for your user account.
You can find deleted project backups in the bin on your computer.

Changing the number of backups per project
You can change the number of backups that Dorico Pro stores for each project, for example, if
you want to store a greater range of changes.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click General in the page list.
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3.

In the Files section, change the value for Number of backups per project.

4.

Click Apply, then Close.

Changing the backup location
You can change the folder that Dorico Pro uses to store project backups. By default, Dorico Pro
uses the Backup Projects folder inside your Dorico Projects folder, whose default location is in
the Documents folder for your user account.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click General in the page list.

3.

In the Files section, click Choose beside the Project backup folder field to open the File
Explorer/macOS Finder.

4.

In the File Explorer/macOS Finder, locate and select the folder where you want to save
project backups.

5.

Click Select Folder (Windows)/Open (macOS) to insert the new path in the Project backup
folder field.

6.

Click Apply, then Close.

RESULT
The default folder for project backups is changed. If the folder specified does not exist, Dorico
Pro creates it.
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Setup mode allows you to set up the fundamental elements of the project: instruments and the
players that hold them, flows, layouts, and videos. You can also determine how they interact with
each other, for example, by changing the players assigned to layouts.
You can view music in the music area and switch between viewing other tabs and layouts, but
you cannot select or interact with anything in the music area in Setup mode.

Project window in Setup mode
The project window in Setup mode contains the default toolbar, the music area, and the status
bar. It provides panels with all the tools and functions that allow you to add players and
instruments as well as to create layouts and flows for your project.
You can switch to Setup mode in any of the following ways:
●

Press Ctrl/Cmd-1 .

●

Click Setup in the toolbar.

●

Choose Window > Setup.

Panels in Setup mode

The following panels are available in Setup mode:
1

Players
Lists the players, instruments, and groups in your project. By default, players are assigned to
all flows and to both the full score layout and their own part layout.
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2

Layouts
Lists the layouts in your project. A single full score layout and a part layout for each player
are created automatically, but you can create and delete layouts as required. By default,
layouts contain all flows and full score layouts contain all players.

3

Flows
Shows the flows in your project, ordered left to right. By default, flows contain all players and
are assigned to all layouts.

The three panels work together to allow you to control how and where the players, layouts, and
flows in your project are used. When you select an item in one of the panels, that panel and the
selected item are highlighted in a different color and checkboxes appear in cards in the other
panels. You can activate/deactivate these checkboxes independently to change how material is
distributed across players, layouts, and flows.

Players panel
The Players panel contains all the players and groups in the project, shown in a list. It is located
on the left of the window in Setup mode.
You can hide/show the Players panel in Setup mode in any of the following ways:
●

Press Ctrl/Cmd-7 .

●

Click the disclosure arrow on the left edge of the main window.

●

Choose Window > Show Left Panel.

Players panel in Setup mode

In the Players panel, each player is shown as a card that contains the instruments held by that
player. Each player card shows the following:
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1

Disclosure arrow
Expands/Collapses the player card.

2

Player type
Shows the type of player from the following options:

3

●

Solo player

●

Section player

Player name
Shows the name of the player. Dorico Pro automatically adds the names of the assigned
instruments to the player name. If required, you can rename the player.

4

Add instruments icon
Opens the instrument picker from which you can select an instrument for the player.

5

Instrument labels
Each instrument assigned to a player has its own instrument label. If you hover the mouse
pointer over an instrument label, an arrow appears that allows you to open a menu with
further options that allow you to, for example, change the instrument names or move the
instrument to another player.

The action bar at the bottom of the panel contains the following options:
Add Solo Player

Adds an individual player to your project. Dorico Pro also automatically adds a part
layout for the player to the Layouts panel.
Add Section Player

Adds a player to your project that represents multiple players who all play the same
instrument. Dorico Pro also automatically adds a part layout for the player to the
Layouts panel.
Add Ensemble

Adds multiple players to your project that represent standard combinations of musical
instruments. Dorico Pro also automatically adds part layouts for each player in the
ensemble to the Layouts panel.
Add Group

Adds a group to your project to which you can assign all types of players.
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Delete Player

Deletes selected players or groups from the project. When you delete a player, a
warning message appears that allows you to delete only the player but leave their part
layouts in the project, delete both the player and their part layouts, or cancel.
The order in which the players are listed in the panel is the default order in which they appear in
layouts. You can change the player order for each layout individually in the Players section of the
Players page in Setup > Layout Options.
RELATED LINKS
Players on page 108
Layouts panel (Setup mode) on page 98
Layout Options dialog on page 104

Instrument picker
The instrument picker allows you to find and add instruments and ensembles to your project. It
contains multiple versions of some instruments that have specific formatting and tuning
requirements, such as French Horn, which has a version whose part layouts are always in treble
clef.
You can open the instrument picker in Setup mode in any of the following ways:
●

Click the plus symbol in solo player cards in the Players panel.

●

Select a player in the Players panel and press Shift-I .

●

Right-click a player in the Players panel and choose Add Instrument to Player.

●

Add a new player or ensemble.

Instrument picker
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The instrument picker contains the following sections and options:
1

Search field
Allows you to enter the instrument you are searching for directly. You can enter only part of
the instrument name, such as cello for Violoncello.

2

Instrument family column
Contains instrument families to help you focus your instrument search.

3

Instrument column
Contains the instruments available in the selected instrument family.

4

Instrument type column
Contains options for multiple possible transpositions, tunings, key signature options, or
different behavior in part layouts for the selected instrument. This column is not populated
for instruments that do not have further options.

5

Create Empty Kit
Adds an empty percussion kit to the player.

6

Import Kit
Imports an existing percussion kit previously exported as a library file.

7

Add/Add Ensemble to Score
Adds the selected instrument/ensemble to the project. Adding an ensemble adds multiple
players at once.

In addition to entering the instrument or ensemble you want directly into the Search field, you
can click options in the instrument picker to select them, and you can also select other items in
the same column by pressing Up Arrow / Down Arrow .
You can cycle forwards through the instrument picker by pressing Tab , which navigates in the
following order: Search field, Instrument, Instrument type, Instrument family. You can also
cycle backwards by pressing Shift-Tab , which navigates in the opposite direction.
An enclosure line shows which instrument family or instrument is selected when using the
keyboard to navigate.
RELATED LINKS
Transposing instruments on page 115
Adding solo/section players on page 109
Adding ensembles on page 111
Adding empty percussion kits to players on page 117
Importing percussion kits on page 1277

Layouts panel (Setup mode)
The Layouts panel contains all the layouts in the project, shown in a list. In Setup mode, it is
located on the right of the window.
You can hide/show the Layouts panel in Setup mode in any of the following ways:
●

Press Ctrl/Cmd-9 .

●

Click the disclosure arrow on the right edge of the main window.

●

Choose Window > Show Right Panel.
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Layouts panel in Setup mode

In the Layouts panel, each layout is shown as a card. Each layout card shows the following:

1

Disclosure arrow
Expands/Collapses the layout card.

2

Layout type
Shows the type of layout from the following options:

3

●

Full score layout

●

Instrumental part layout

●

Custom score layout

Layout name
Shows the name of the layout. Dorico Pro automatically adds default names depending on
the name of the instrument that is assigned to a player and on the type of layout that is
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added. For example, if you assign a flute to a player, the instrumental part layout
automatically gets the same name. If you add an empty instrumental part layout, the layout
name shows Empty part and an incremental number if you add multiple empty part layouts.
4

Page size and orientation
Shows the size and orientation of the layout as set on the Page Setup page in Setup >
Layout Options.

5

Space size
Shows the space size between two staff lines in points, as set on the Page Setup page in
Layout Options. This indicates the size of staves in the layout.

6

Layout number
Allows you to set a unique number for the layout that can be used as part of its file name
when exported as a graphic. This can be useful to ensure exported part layout files are
organized in their orchestral order, as this is usually different to their alphabetical order.

The action bar at the bottom of the panel contains the following options:
Add Full Score Layout

Adds a full score layout to your project. By default, every player and flow is
automatically included in the layout.
Add Instrumental Part Layout

Adds an empty instrumental part layout to your project. You can then add one or
multiple players to the layout. By default, a part layout contains all flows that are
created in your project.
Add Custom Score Layout

Adds a custom score layout that initially without players or flows.
Sort Layouts

Sorts all layouts in the Layouts panel according to their type in the following order: full
score layouts, instrumental part layouts, custom score layouts. It does not sort part
layouts according to orchestral order.
Layout Options

Opens the Layout Options dialog for one or multiple selected layouts.
Delete Layout

Deletes selected layouts from the project.
RELATED LINKS
Layouts on page 134
Layout Options dialog on page 104

100
Dorico Pro 3.1.10

Setup mode
Project window in Setup mode

Flows panel
The Flows panel contains all the flows in the project, shown in horizontal list. It is located at the
bottom of the window in Setup mode.
You can hide/show the Flows panel in Setup mode in any of the following ways:
●

Press Ctrl/Cmd-8 .

●

Click the disclosure arrow at the bottom of the main window.

●

Choose Window > Show Bottom Panel.

Flows panel in Setup mode

In the Flows panel, each flow is shown as a card. Each flow card shows the following:

1

Flow name
Shows the name of the flow. If you create multiple flows without renaming them, each flow
name shows a number that increments with each new flow that you create. The number also
indicates the position of the flow in a layout.

2

Film reel icon
Indicates the flow has an attached video.

3

Flow timecode
Shows the start timecode for the flow.

4

Flow number
Shows the number of the flow. The number increments with each new flow that you create.
The number also indicates the position of the flow in a layout.

To the right of the Flows panel, the following options are available:
Add Flow
Adds a new flow to your project. By default, every new flow is automatically included in
all layouts, and every player is added to the new flow.
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Notation Options
Opens the Notation Options dialog that provides multiple options that allow you to
make changes that affect the way music is notated for each flow.

Delete Flow
Deletes the selected flows from the project.

RELATED LINKS
Flows on page 132
Notation Options dialog on page 160
Videos on page 146

Project Info dialog
The Project Info dialog allows you to specify information about the whole project and each flow
within it separately, such as the title, composer, and lyricist, as these might be different for
different flows. You can then refer to these entries using text tokens in text frames.
You can open the Project Info dialog in any mode in any of the following ways:
●

Press Ctrl/Cmd-I .

●

Choose File > Project Info.
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Project Info dialog

The Project Info dialog comprises the following:
1

Flows list
Contains all the flows in the project, with a separate entry for the project as a whole at the
top. You can select individual or multiple flows in the flows list.
NOTE
The flows list uses the names of flows as shown in the Flows panel in Setup mode, which can
be different to their entry in the Title field if you have changed their flow title.
The action bar at the bottom of the list contains the following options:
●

New Flow: Creates a new flow with no information. Its default name is New Flow.

●

Duplicate Flow: Creates a new flow with all the information of the selected flow. Its
default name is Copy of [selected flow].
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●

Rename Flow: Opens the Rename Flow dialog, which allows you to change the name of
the flow.

NOTE
If you have already manually changed the flow title, changing the name of the flow does
not automatically change the flow title.

2

●

Move Down: Moves the selected flows down the flows list, which changes their order in
the project.

●

Move Up: Moves the selected flows up the flows list, which changes their order in the
project.

●

Delete Flow: Deletes the selected flows.

Information fields
Allow you to enter information about the currently selected flows or the whole project in the
corresponding field, such as Composer and Lyricist. If you have selected multiple flows with
different entries in the same fields, such as flows with different composers, those fields
display Mixed.

3

Copy info from menu
Allows you to select another flow or the whole project whose information you want to copy,
for example, for a project containing multiple flows that all have the same composer and
lyricist.

4

Copy
Copies all the information from the specified flow/project to the selected flows/project.

TIP
●

You can use tokens in text frames to refer to information in the Project Info dialog.

●

You cannot specify line breaks in single-line fields. However, you can enter line breaks in
larger fields, namely Copyright and Other information, which you can then copy into
single-line fields.

RELATED LINKS
Text tokens on page 396
Flow names and flow titles on page 145

Layout Options dialog
The Layout Options dialog provides multiple options that allow you to make changes that affect
the way the notation is laid out on pages of each layout.
You can change the physical properties of the layout, such as page size, staff size, or margins,
and the notation, such as note spacing or staff labels.
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TIP
You can save all options that you set in Layout Options as the default for new projects by
selecting a layout type from the Layout type menu and clicking Save as Default.
You can open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options in the Layouts panel in Setup mode.

Layout Options

The Layout Options dialog contains the following:
1

Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages. When you click a page in this list, any applicable section titles appear below the page
in the page list.

2

Section titles
Shows the titles of any sections on the selected page. You can click these section titles to
navigate directly to that section of the page.

3

Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible settings,
the current setting is highlighted.

4

Layouts list
Contains all the layouts in your project. You can select one, multiple, or all layouts. You can
select multiple layouts in any of the following ways:
●

Click one of the selection options in the action bar.

●

Ctrl/Cmd -click to select multiple layouts.

●

Shift -click to select multiple adjacent layouts.
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5

Action bar
Contains selection options that allow you to select layouts in the Layouts list according to
their type.

6

●

Select All selects all layouts, regardless of their type.

●

Select All Full Score Layouts selects all full score layouts only.

●

Select All Part Layouts selects all part layouts only.

●

Select All Custom Score Layouts selects all custom score layouts only.

Layout type
Allows you to select the layout type for which you want to save your settings as the default.
For example, you can save new default settings for part layouts without affecting the default
settings for full score layouts.

7

Save as Default/Remove Saved Defaults
This button has different functions depending on whether you have existing saved defaults
for the selected layout type.

8

●

Save as Default saves all options currently set in the dialog as the default for the
selected layout type in new projects.

●

Remove Saved Defaults deletes your previous saved defaults without resetting the
options in the current project. After removing your saved defaults, all layouts of the
selected type in future projects start with the default factory settings. If you have
existing saved defaults, you can access Remove Saved Defaults by pressing
Ctrl (Windows) or Opt (macOS) .

Reset to Factory/Reset to Saved Defaults
This button has different functions depending on whether you have existing saved defaults
for the selected layout type.
●

If you have no saved defaults for the selected layout type, this button is Reset to
Factory, which resets all the options in the dialog back to the default factory settings for
the selected layout type.

●

If you have existing saved defaults for the selected layout type, this button is Reset to
Saved Defaults, which resets all the options in the dialog back to your saved defaults for
the selected layout type. You can access Reset to Factory instead by pressing
Ctrl (Windows) or Opt (macOS) . Resetting options back to the default factory settings
only affects the selected layout type in the current project and does not delete your
saved defaults, meaning future projects still start with your saved defaults.

RELATED LINKS
Options dialogs in Dorico Pro on page 40
Staves on page 1158

Making layout-specific changes in Layout Options
You can make project-wide changes for each layout independently in Layout Options.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options at the bottom of the Layouts panel in Setup mode.
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2.

In the Layouts list, select the layouts in which you want to change options in one of the
following ways:
●

Click Select All in the action bar.

●

Click Select All Full Score Layouts in the action bar.

●

Click Select All Part Layouts in the action bar.

●

Click Select All Custom Score Layouts in the action bar.

●

Shift -click adjacent layouts.

●

Ctrl/Cmd -click individual layouts.

By default, the layout currently open in the music area is selected when you open the dialog.
3.

Click a page in the page list.

4.

Look through the available options, and change the settings as required.

5.

Click Apply, then Close.
If you make changes and close the dialog without clicking Apply, you are prompted to save
or discard your changes.

RESULT
The changes are applied immediately to the selected layouts.

Players, layouts, and flows
In Dorico Pro, players, layouts, and flows are all connected to each other. Because they exist in
the project rather than in a single score, you can, for example, have players and flows saved in
the project without showing them in the full score.
●

Players can be assigned to any combination of layouts and flows. For example, you can
assign a single player to both the full score layout and their own part layout, and remove
them from flows in which they do not play. By default, players are assigned to all flows that
originated in the project, all full score layouts, and their own part layout.

●

Layouts can contain any combination of players and flows. For example, you can assign all
the singers to a single part layout, then remove the flows from the layout in which they do
not sing. By default, layouts contain all flows and full score layouts contain all players.

●

Flows can contain any combination of players and be assigned to/removed from layouts. By
default, flows contain all players and are assigned to all layouts.

NOTE
●

If you remove a player from a flow, any notes you have already input for that player in that
flow are deleted.

●

Removing a flow from a layout automatically removes that layout from the flow, and vice
versa. The same is true for players and layouts, and players and flows.

When you select a card in one of the panels in Setup mode, each card in the other panels shows
a checkbox. Connected cards appear highlighted and have activated checkboxes, while
unconnected cards are not highlighted and have deactivated checkboxes. For example, if you
select a single player card in the Players panel, all the flows to which the player is assigned are
highlighted and activated in the Flows panel and all layouts to which the player is assigned are
highlighted and activated in the Layouts panel.
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A piano player selected in the Players panel with connected flows and layouts highlighted in the Flows and
Layouts panels

RELATED LINKS
Project window in Setup mode on page 94
Flows on page 132
Layouts on page 134
Changing the flows assigned to layouts on page 136
Changing the players assigned to layouts on page 136
Changing the players assigned to flows on page 134

Players
In Dorico Pro, a player can represent an individual musician or multiple musicians in the same
section. Players hold instruments, so you must add at least one player to your project before you
can add instruments.
●

A solo player represents a single person who can play one or more instruments. For
example, a clarinettist who doubles on alto saxophone or a percussionist who plays bass
drum, clash cymbals, and triangle.

●

A section player represents multiple people who all play the same instrument. For example,
a violin section player might represent all eight desks of the Violin I section in an orchestra,
or a soprano section player might represent the whole soprano section in a mixed voice
choir.
NOTE
Section players cannot double instruments, but they can play divisi. This means that they can
be divided into smaller units, which is commonly required for strings.

When you add a player in Dorico Pro, the following happens automatically:
●

A part layout is created and the new player is assigned to it.

●

The player is added to any full score layouts that already exist. If no full score layouts exists,
a new full score layout is created.

●

The player is assigned to all existing flows that originated in the project. It is not added to
any flows that you imported into the project.
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RELATED LINKS
Players, layouts, and flows on page 107
Flows on page 132
Layouts on page 134
Changing the players assigned to layouts on page 136
Changing the players assigned to flows on page 134
Player, layout, and instrument names on page 139
Changing player names on page 143
Condensing on page 470
Brackets according to ensemble type on page 685
Instrument numbering on page 113

Adding solo/section players
You can add both solo and section players to your project. Solo players can hold multiple
instruments, whereas section players can divide.
PREREQUISITE
The Players panel is open.
PROCEDURE
1.

In the Players panel, add an empty-handed player in any of the following ways:
●

To add a solo player, press Shift-P .

●

To add a section player, press Shift-Alt/Opt-P .

●

If you have started a new project, click Add Solo Player in the project start area.

●

If you have started a new project, click Add Section Player in the project start area.

●

At the bottom of the Players panel, click Add Solo Player.

●

At the bottom of the Players panel, click Add Section Player.

The instrument picker opens.
TIP
You can also open the instrument picker at any time selecting a player in the Players panel
and pressing Shift-I .
2.

Select the instrument you want in the instrument picker.

3.

Press Return to add the selected instrument.

RESULT
The solo/section player is added to all flows in the project. It is automatically named after the
selected instrument.

109
Dorico Pro 3.1.10

Setup mode
Players
Dorico Pro automatically loads sounds for the instrument according to the current playback
template.
NOTE
●

Players are not automatically added to flows that you imported into the project.

●

If you want to add multiple instruments to your project at the same time, you can add
ensembles or use a project template.

AFTER COMPLETING THIS TASK
If you added a solo player and you want them to hold multiple instruments, add other
instruments to the solo player.
RELATED LINKS
Instrument picker on page 97
Changing player names on page 143
Project start area on page 47
Adding instruments to players on page 116
Adding ensembles on page 111
Starting new projects from project templates on page 70
Playback templates on page 558

Duplicating players
You can duplicate players. This adds another player of the same type holding the same
instruments as the original.
PROCEDURE
●

In the Players panel, right-click the player you want to duplicate and choose Duplicate
Player from the context menu.

RESULT
A new player is added, with the same instruments as the original player. The original and new
players are automatically numbered to ensure their names are unique. However, any existing
music belonging to the original player is not duplicated.
RELATED LINKS
Changing player names on page 143
Instrument numbering on page 113

Changing the orchestral order of players
You can change the order in which players appear in the score in the Players panel.
PROCEDURE
1.

In the Players panel, select the player card of the player whose position in the score you
want to change.

2.

Click and drag the player card upwards/downwards in the panel.
An insertion line indicates where the player will be positioned.
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Deleting players
You can delete players from your project, which also deletes all instruments held by those
players.
IMPORTANT
Deleting instruments permanently deletes any music that you have input on their staves.

PROCEDURE
1.

In the Players panel, select the players that you want to delete.

2.

Press Backspace or Delete .

3.

Choose one of the following options in the warning message that appears:
●

Delete Player Only: Deletes the player and the music that you created for the
instruments belonging to that player.

●

Delete Player and Part Layouts: Deletes the player, the music, and all part layouts to
which the player is assigned.
NOTE
The part layout cannot be deleted if it also contains other players.

RELATED LINKS
Deleting instruments on page 119

Ensembles
If you add an ensemble in Dorico Pro, multiple players are added to your project at the same
time.
Dorico Pro provides a set of predefined ensembles that you can use. Adding an ensemble is one
of the ways to achieve building up an instrumentation quickly. The predefined ensembles that
you can create with Dorico Pro follow standard patterns, such as double woodwind which refers
to two flutes, two oboes, two clarinets, and two bassoons.

Adding ensembles
You can add multiple players at once by adding ensembles, such as a complete string section or
four-part choir.
PREREQUISITE
The Players panel is open.
PROCEDURE
1.

Open the instrument picker for ensembles in any of the following ways:
●

If you have started a new project, click Add Ensemble in the project start area.

●

Click Add Ensemble at the bottom of the Players panel.
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2.

Select the ensemble you want in the instrument picker.

3.

Click Add Ensemble to Score.

RESULT
The ensemble players are added to the Players panel, either as solo or as section players.
TIP
You can also add multiple instruments to your project at the same time by using a project
template.

RELATED LINKS
Instrument picker on page 97
Changing player names on page 143
Project start area on page 47
Starting new projects from project templates on page 70

Instruments
In Dorico Pro, an instrument is an individual musical instrument, such as a piano, a flute, or a
violin. Human voices, such as soprano or tenor, are also considered instruments.
In Dorico Pro, instruments are held by players, just as real instruments are held by human
players. Section players can only hold a single instrument but solo players can hold multiple
instruments, which allows you to handle instrument changes easily, such as when an oboist
doubling the cor anglais switches from one instrument to the other.
This means that before you can add instruments to a project, you must first add players or
ensembles, which may in turn also be assigned to groups if needed. If you add ensembles, the
appropriate instruments for the ensemble are automatically added to the players.
Each instrument automatically gets its own staff, but when instrument changes are allowed, the
music for multiple instruments held by the same solo player can appear on the same staff as
long as no notes overlap. By default, Dorico Pro allows instrument changes in all layouts and
automatically shows instrument change labels. This means that only the top instrument held by
players is shown automatically in the music area. You can see staves for all instruments in galley
view, and you can allow/disallow instrument changes in each layout independently. You can also
hide/show empty staves in each layout independently.
Instruments in Dorico Pro do not have limited ranges; it is possible to notate any pitch in any
register on every instrument. However, in the piano roll editor in Play mode, only pitches that fall
in the MIDI note range 0-127 can be represented. Similarly, if you input a pitch beyond the range
of samples in the assigned VST instrument, the pitch does not sound in playback.
You can change instruments at any time, add/delete them from players, and move them
between players.
RELATED LINKS
Players on page 108
Piano roll editor on page 504
VST and MIDI Instruments panel on page 498
Inputting notes on page 172
Adding instruments to players on page 116
Player, layout, and instrument names on page 139
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Changing instrument names on page 144
Staff labels on page 1145
Brackets according to ensemble type on page 685
Changing instruments on page 118
Changing the open pitches of fretted instrument strings on page 128
Moving instruments on page 119
Deleting instruments on page 119
Switching to galley/page view on page 60
Allowing/Disallowing instrument changes on page 114
Hiding/Showing empty staves on page 441
Edit Percussion Kit dialog on page 120

Instrument numbering
It is customary to number instruments when there is more than one in a piece so that they can
be easily identified, such as Horn 1 and Horn 2. Dorico Pro automatically numbers instruments
where there are multiple instruments of the same type in the same project.
For example, if there is only one flute in a project, it is called Flute, but if there are three flutes,
they are automatically called Flute 1, Flute 2, and Flute 3.

One violin with no number

Adding a second violin automatically generates
numbers for both violins

Instrument numbering applies to individual instruments, rather than players. For example, if an
ensemble contains two flute players and a piccolo player, but the second flute is also holding a
piccolo, then the instruments are numbered in the following way:
●

Flute 1

●

Flute 2 & Piccolo 1

●

Piccolo 2

TIP
You can move individual instruments to different players if you want to change which numbered
instruments are held by each player. For example, if you want the second flute to double second
piccolo rather than first piccolo, you can swap the piccolo instruments between the players.
Dorico Pro automatically generates instrument numbers for players if the following criteria are
met:
●

There are multiple instruments of the same type in the project.

●

The instrument names are the same.

●

The instruments have the same transposition.

●

The players holding them are the same type, either solo or section.

●

The players are in the same group.
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For example, if you have two flutes in your project, but one flute is a section player and the other
flute is a solo player, they are not numbered automatically. Similarly, if the two flutes are in
different player groups, they are not numbered automatically.
TIP
You can change whether instruments of the same type but with different transpositions are
numbered together, for example, if you have two Horns in F and two Horns in D and want them
to be numbered 1-4. They are numbered separately by default.

RELATED LINKS
Player, layout, and instrument names on page 139
Changing instrument names on page 144
Player groups on page 129
Instrument transpositions in staff labels on page 1150
Moving instruments on page 119
Numbering instruments with different transpositions separately/together on page 1152
Instrument names in staff labels on page 1146
Transposing instruments on page 115

Instrument changes
Instruments changes are when a player holding multiple instruments switches from playing one
instrument to a different instrument. They are usually indicated in full scores and parts with text
indications both after the last note before the change and at the first note after the change.
Dorico Pro handles instrument changes automatically, including showing the appropriate
instrument change labels, when you have input notes onto multiple instrument staves held by
the same solo player, as long as the notes do not overlap.
You can see staves for all instruments in galley view, and you can allow/disallow instrument
changes in each layout independently.
RELATED LINKS
Adding instruments to players on page 116
Switching to galley/page view on page 60

Allowing/Disallowing instrument changes
You can allow/disallow instrument changes in each layout independently, for example, if you
want to show multiple percussion instruments on as few staves as possible in the score but on
separate staves for each percussion instrument in the percussion part.
Disallowing instrument changes shows all instrument staves in the selected layouts, including
multiple instruments held by a single solo player.
TIP
If you want to input notes for other instruments held by solo players but keep instrument
changes in the layout, you can switch to galley view to see all staves in the project.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to allow/disallow instrument
changes.
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By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.
3.

Click Players in the page list.

4.

In the Instrument Changes section, activate/deactivate Allow instrument changes.

5.

Click Apply, then Close.

RESULT
Instrument changes are allowed in the selected layouts Allow instrument changes is activated,
and disallowed when it is deactivated.
NOTE
Multiple instruments can only appear on the same staff with an instrument change if none of
their notes overlap. If any of their notes do overlap, multiple staves are shown.

RELATED LINKS
Instruments on page 112
Inputting notes on page 172
Hiding/Showing empty staves on page 441
Switching to galley/page view on page 60

Transposing instruments
While most instruments produce notes at concert pitch, transposing instruments produce a note
that is different to the one that is written. For example, two common orchestral transposing
instruments are clarinet in B♭ and horn in F.
When a clarinet in B♭ plays a C, the sound produced is a B♭, one tone below. When a horn in F
plays a C, the sound produced is an F, a fifth below. Other instruments that conventionally
produce a pitch different to the one notated include the piccolo (sounding an octave above
written), double bass (sounding an octave below written), and glockenspiel (sounding two
octaves above written).
Dorico Pro stores all note information in concert pitch and automatically transposes notes as
appropriate for the transposition of the instrument. This means notes, key signatures, and chord
symbols are automatically changed in transposing layouts compared to non-transposing layouts.
You can also change instruments at any time, and the music is adjusted automatically to ensure
the correct pitches are shown.
RELATED LINKS
Instrument picker on page 97
Instrument numbering on page 113
Concert vs. transposed pitch on page 138
Making layouts transposing/concert pitch on page 137
Setting different clefs for concert/transposed pitch on page 729
Changing instruments on page 118
Hiding/Showing clefs according to layout transpositions on page 730
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Fretted instrument tuning
Fretted instruments can have different numbers of strings and frets. In order to display tablature
for fretted instruments in Dorico Pro, you must specify information about the tuning of fretted
instruments.
Dorico Pro requires the following information to display tablature:
●

The number of strings the instrument has

●

The open pitch of each string

●

The number of frets

●

The fret number at which each string starts, such as for the fifth string on a banjo

●

The pitch intervals between frets

When you assign a fretted instrument to a player or change an existing instrument, any available
tunings for that instrument are shown in the instrument picker.
You can also customize all aspects of fretted instruments in the Edit Strings and Tuning dialog.
NOTE
Any fretted instruments in projects created in earlier versions of Dorico Pro are automatically
assigned the standard set of strings and tunings associated with that instrument when the
project is first opened in Dorico Pro 3. The quickest way to change their tuning is changing the
instrument type in the instrument picker.

RELATED LINKS
Instrument picker on page 97
Changing instruments on page 118
Edit Strings and Tuning dialog on page 127

Adding instruments to players
You can add instruments to both solo and section players. You can add multiple instruments to
solo players but only a single instrument to section players.
PREREQUISITE
You have added a solo or section player.
PROCEDURE
1.

In the Players panel, select the player to which you want to add instruments.
NOTE
You can only add instruments to a single player at a time.

2.

Press Shift-I to open the instrument picker.

3.

Select the instrument you want in the instrument picker.

4.

Press Return to add the selected instrument.

5.

Optional: Repeat steps 2 to 4 to add multiple instruments to a single solo player.
NOTE
●

You can only add a single instrument to each section player.
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●

If you want to add multiple instruments to your project at the same time, you can add
ensembles or use a project template.

RESULT
The selected instrument is added to the selected player.
Dorico Pro automatically loads sounds for the instrument according to the current playback
template.
NOTE
Before you have input any notes, only the first instrument held by solo players is shown in full
scores in page view. All instrument staves are shown in galley view, so we recommend switching
to galley view to input notes for any other instruments held by solo players.

RELATED LINKS
Instrument picker on page 97
Adding ensembles on page 111
Starting new projects from project templates on page 70
Switching to galley/page view on page 60
Playback templates on page 558

Adding empty percussion kits to players
You can add empty percussion kits to players, to which you can then add unpitched percussion
instruments.
PROCEDURE
1.

2.

In the Players panel, open the Edit Percussion Kit dialog in any of the following ways:
●

Select a solo or section player, press Shift-I , and click Create Empty Kit in the
instrument picker.

●

Click the plus symbol to the right of the added empty-handed player and click Create
Empty Kit in the instrument picker.

●

Right-click a player and choose Create Empty Kit from the context menu.

Add the percussion instruments you want to the kit in the Edit Percussion Kit dialog.

RELATED LINKS
Edit Percussion Kit dialog on page 120
Instrument picker on page 97

Combining individual percussion instruments into kits
If a player is holding one or more individual percussion instruments, you can combine them into
a percussion kit.
PROCEDURE
1.

Right-click the card of the player whose percussion instruments you want to combine into a
kit and choose Combine Instruments into Kit from the context menu.

2.

Edit the kit in the Edit Percussion Kit dialog that opens.
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For example, you can change the order in which the instruments appear in a grid or on a
five-line staff.
RESULT
A new kit is created containing all the instruments held by the player.
NOTE
If the player was already holding one or more kit instruments, all individual instruments and any
other kits are combined into the first kit.

Changing instruments
You can change the instruments held by players without affecting any music already entered
onto their staves, for example, if your Clarinet part is very low and you want to change it to a
Bass Clarinet or you want to change the tuning of a guitar.
NOTE
●

You cannot change percussion kits into other instruments, you can only change individual
unpitched percussion instruments.

●

You cannot change a pitched instrument into an unpitched instrument, and vice versa.

●

These steps describe changing the instrument type, not an instrument change partway
through a flow.

PROCEDURE
1.

In the Players panel, expand the card of the player whose instrument you want to change.
The card lists the instruments of the player.

2.

Hover over the label of the instrument you want to change, click the arrow that appears, and
choose Change Instrument to open the instrument picker.

3.

Select the instrument you want in the instrument picker.

4.

Press Return to change to the selected instrument.

RESULT
The selected instrument is changed, without affecting any music on its staff.
NOTE
Where appropriate, new clefs are input. This means that notes can appear differently so that they
are notated correctly according to the new clef.

RELATED LINKS
Instrument picker on page 97
Fretted instrument tuning on page 116
Transposing instruments on page 115
Edit Strings and Tuning dialog on page 127
Instrument changes on page 114
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Moving instruments
You can move individual instruments without affecting any music already input for those
instruments. You can move instruments between players or to a different position in the
instrument list for a solo player, for example, if you want to change the order of staves in the
score.
PROCEDURE
●

In the Players panel, move instruments in any of the following ways:
●

To change the order of instruments for a single player, click and drag a single
instrument and release it at the required position.

●

To move instruments to another player, click and drag a single instrument and release it
over the player card to which you want to move them.

●

To move instruments to another player, click the arrow that appears in the instrument
label when you hover over it and choose Move Instrument to Player > [Player].
NOTE
You can only move instruments to players already added to your project.

RELATED LINKS
Instrument changes on page 114
Adding solo/section players on page 109

Deleting instruments
You can delete individual instruments without deleting the player holding them or other
instruments held by the same player.
IMPORTANT
Deleting instruments permanently deletes any music that you have input on their staves.

PROCEDURE
1.

In the Players panel, expand the card of the player holding the instrument you want to
delete.

2.

Click the arrow that appears in the instrument label when you hover over it and choose
Delete Instrument.

3.

Click OK.

RESULT
The instrument is deleted from the player.
TIP
If you want to delete all instruments held by a single player, you can also delete the player.

RELATED LINKS
Deleting players on page 111

119
Dorico Pro 3.1.10

Setup mode
Instruments

Edit Percussion Kit dialog
The Edit Percussion Kit dialog allows you to make changes to percussion kits, including which
instruments are included in them and how instruments are arranged in the different available kit
presentations.
●

The dialog opens automatically when you create empty kits or combine existing instruments
into a kit.

●

You can also open the Edit Percussion Kit dialog manually for existing percussion kit
instruments by expanding the player card of the player holding the percussion kit in the
Players panel in Setup mode, then clicking the arrow in its label and choosing Edit
Percussion Kit.

NOTE
Percussion kit instrument labels are green in the Players panel in Setup mode.

Edit Percussion Kit dialog

1

Name
Allows you to enter or change the full name for the percussion kit. This is used in Full staff
labels for percussion kits that use the five-line staff presentation type.

2

Short name
Allows you to enter or change the abbreviated name for the percussion kit. This is used in
Abbreviated staff labels for percussion kits that use the five-line staff presentation type.

3

Drum set
Percussion kits are defined as drum sets when the checkbox is activated. Percussion kits that
are defined as drum sets follow your settings for drum sets on the Percussion page in
Notation Options, including for voicing and default stem directions.
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4

Presentation types
Allows you to select a percussion kit presentation type in order to edit how the selected
percussion kit appears in that presentation type.

5

●

5-line Staff: Kit instruments are shown on a five-line staff. You can determine which
instruments are shown on each line and in each space of the staff. A single staff label
containing the name of the kit is shown.

●

Grid: Kit instruments are shown on a grid, with each instrument on its own line. You can
customize how large the gaps between each line are. Staff labels are shown for each
instrument in a smaller font than normal staff labels.

●

Single-line Instruments: Kit instruments are shown as individual instruments with their
own lines. Normal-sized staff labels are shown for each instrument.

Editor
Displays the current arrangement of instruments in the selected percussion kit presentation
type. You can change the order of instruments and the layout of lines and spaces in the grid
presentation type by using the controls.

6

Controls
Allows you to change the order and stem direction of instruments in the selected percussion
kit presentation type. It also allows you to add slash voices to the kit.
You can access dialogs to change the noteheads used for each instrument in the kit by
clicking Edit Noteheads. You can also change how combinations of noteheads, articulations,
and tremolos affect playback by clicking Edit Percussion Playing Techniques.
You can also change the names of individual instruments within percussion kits. Click Edit
Names to open the Edit Instrument Names dialog.
NOTE
This changes the appearance of percussion instrument names in all presentations.
Depending on the percussion kit presentation type, staff labels might use different
information than these instrument names.

7

Action bar
Contains options that apply to all presentation types.
●

Add New Instrument: Opens the instrument picker, which allows you to choose a new
unpitched percussion instrument to be added to the kit.

●

Add Existing Instrument From Player: Shows a menu listing the other players in your
project that are holding individual percussion instruments not in kits. You can select a
percussion instrument from another player to move to this kit, bringing its music with it.

●

Remove Instrument From Kit: Removes the selected instrument from the kit, so it
appears as an individual instrument. You can move individual instruments to other
players or into other kit instruments.

●

Change Instrument: Opens the instrument picker, which allows you to choose a new
unpitched instrument to replace the selected instrument while retaining its music.

●

Delete Instrument: Deletes the instrument from the kit, including its music.
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8

Export Kit
Allows you to export the percussion kit as a library file so you can use it in other projects.

RELATED LINKS
Percussion kits and drum sets on page 1276
Staff labels for percussion kits on page 1154
Percussion kit presentation types on page 1281
Percussion Instrument Playing Techniques dialog on page 1283
Playing techniques for unpitched percussion instruments on page 1283

Adding instruments to percussion kits
You can add new instruments to percussion kits within the Edit Percussion Kit dialog.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit to which you want to add
instruments.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Click Add New Instrument to open the instrument picker.

4.

Select the percussion instrument you want in the instrument picker.

5.

Press Return to add the selected instrument.

6.

Click Close.

RESULT
The selected instrument is added to the percussion kit.

Changing instruments in percussion kits
You can change existing instruments in percussion kits while retaining any existing music for that
instrument.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit in which you want to
change instruments.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Click the instrument you want to change.

4.

Click Change Instrument in the action bar to open the instrument picker.

5.

Select the percussion instrument you want in the instrument picker.

6.

Press Return to change to the selected instrument.

7.

Click Close.

RESULT
The instrument is changed to the one selected in the instrument picker. Any music input for the
previous instrument is retained.
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NOTE
Playing techniques expressed using playing technique-specific noteheads are not retained.

Defining percussion kits as drum sets
You can define individual percussion kits as drum sets. Drum sets follow your per-flow notation
options for voicing in drum sets with five-line staff presentations.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit you want to define as a
drum set.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Activate Drum set in the top right of the dialog.

4.

Click Apply, then Close.

RESULT
The selected percussion kit is defined as a drum set. The arrangement of voices for instruments
in the kit when using the five-line staff presentation type follows your project-wide setting on the
Percussion page in Write > Notation Options.
NOTE
If you no longer want a percussion kit to be defined as a drum set, you can deactivate Drum set
in the Edit Percussion Kit dialog for that kit.

RELATED LINKS
Notation Options dialog on page 160
Percussion Instrument Playing Techniques dialog on page 1283

Creating groups of instruments within grid presentation percussion kits
You can create groups of instruments within percussion kits that use the grid presentation type
in order to have a better overview of the instruments in the kit.
In grid presentation percussion kits, the name of each individual instrument is shown in the staff
label. You can simplify the staff label of grid presentation percussion kits by creating groups, for
example, to show Wood Blocks instead of Wood Block (High), Wood Block (Medium), and Wood
Block (Low).
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit in which you want to
create groups in the grid presentation.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Click Grid at the top of the dialog.

4.

Click the first instrument you want to include in the group.

5.

Shift -click the last instrument you want to include in the group.
NOTE
You can only include adjacent instruments in groups.
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6.

Click Add.

RESULT
A group is created containing the selected instruments. The group is given a default name that
you can change.

Renaming groups in grid presentation percussion kits
Group names are shown as instrument labels. You can change the names of groups in
percussion kits using grid presentation.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit in which you want to
change the names of groups in the grid presentation.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Click Grid at the top of the dialog.

4.

Double-click the group you want to rename to open the Edit Percussion Grid Group Names
dialog.
Groups are shown as colored blocks in the column to the left of the list of percussion kit
instruments.

5.

6.

Enter the names you want to give the group in the corresponding fields in the Edit
Percussion Grid Group Names dialog:
●

Full Name

●

Short Name

Click OK to save your changes and close the dialog.

RESULT
The name of the group is changed. This also changes the staff label for the group.
NOTE
Staff labels for groups in grid presentation percussion kits use a different paragraph style to the
staff labels for non-grouped instruments in grid presentation percussion kits.
EXAMPLE

Ungrouped grid presentation percussion kit
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RELATED LINKS
Staff labels for percussion kits on page 1154

Deleting groups within grid presentation percussion kits
You can delete groups in percussion kits using grid presentation, without deleting the
instruments within the group.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit from whose grid
presentation you want to delete groups.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Click Grid at the top of the dialog.

4.

Click the group you want to delete.
Groups are shown as colored blocks in the column to the left of the list of percussion kit
instruments.

5.

Click Delete.

RESULT
The group is deleted. The individual staff labels for each instrument in the group are restored.

Changing the positions of instruments within percussion kits
You can change the positions of instruments within percussion kits of all presentation types to
change the order in which the instruments appear in the score and parts. In five-line staff
presentation types, you can also change the staff position of slash voices.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit in which you want to
change the positions of instruments.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Click the kit presentation type in which you want to change the order of instruments.
For example, click Grid to change the order of instruments when the kit uses the grid
presentation type.

4.

Click the percussion instruments and/or slash voices whose position you want to change.
NOTE
When using the mouse, you can only move one instrument or slash voice at a time.

5.

Change the position of the selected instruments/slash voices in any of the following ways:
●

Click Move up arrow to move them upwards.

●

Click Move down arrow to move them downwards.

●

Click and drag a single instrument upwards/downwards (five-line staff presentation
only).

6.

Optional: Repeat these steps for other instruments in the percussion kit, and for other kit
presentation types for the same percussion kit.

7.

Click Apply, then Close.
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RESULT
The positions of the selected instruments and/or slash voices within the kit is changed. Multiple
instruments can share the same staff position, but we recommend that they use different
noteheads so that the player can tell them apart.
RELATED LINKS
Moving notes to different instruments in percussion kits on page 1279

Changing the size of gaps between lines in percussion grids
You can change the size of gaps between lines in percussion kits using the grid presentation
type.
PROCEDURE
1.

In the Players panel, expand the card of the player in whose percussion kit you want to
change the size of gaps in the grid presentation.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Click Grid at the top of the dialog.

4.

Click the instruments below which you want to change the gap size.

5.

Change the value for Gap.

6.

Click Apply, then Close.

RESULT
The size of the gaps below the selected instruments is changed.

Removing individual instruments from percussion kits
You can remove individual instruments from percussion kits, for example, if you want to move an
instrument from one percussion kit to another player.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit from which you want to
remove instruments.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Click the instruments you want to remove from the kit.

4.

Click Remove Instrument From Kit in the action bar.

5.

Click Close.

RESULT
The selected instruments appears as individual instruments belonging to the same player but
separate from the percussion kit.
You can then move the instruments to other players if required.
RELATED LINKS
Moving instruments on page 119
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Edit Strings and Tuning dialog
The Edit Strings and Tuning dialog allows you to customize the tuning of individual fretted
instruments by changing the number of strings and frets they have, the pitches of their open
strings, and the spacing of their frets.
●

You can open the Edit Strings and Tuning dialog in Setup mode by expanding the player
card of the player holding the fretted instrument in the Players panel, then clicking the
arrow in its label and choosing Edit Strings and Tuning.

Edit Strings and Tuning dialog

The Edit Strings and Tuning dialog comprises the following:
1

Instrument
Displays the name of the selected fretted instrument.

2

String editor
Allows you to select and edit individual or all strings of the fretted instrument. The
arrangement of strings in the editor matches that of the real instrument. The pitch and total
number of frets of each string is shown to the left of the vertical line that represents the nut.

3

Controls
Allow you to edit individual or multiple strings. The following controls are available when at
least one string is selected in the string editor:

4

●

Open pitch: Allows you to set the open pitch of the string using the note name and
octave, such as C4 for middle C. If necessary, you can add # for sharp and b for flat.

●

No. of frets: Allows you to set the number of frets for the selected strings.

●

Starting fret: Allows you to set the number of the first fret on the selected strings. For
example, the fifth string on the banjo starts at fret 5.

●

Tune Up Half-Step: Allows you to raise the open pitch of the selected strings by a halfstep (semitone).

●

Tune Down Half-Step: Allows you to lower the open pitch of the selected strings by a
half-step (semitone).

●

Irregular fret spacing: Allows you to set non-chromatic fret arrangements for
instruments with fretboards that correspond to other scales, such as the dulcimer. Enter
1 for a half-step and 2 for a whole-step, with each step separated by a comma. For
example, enter 2,2,1,2,2,2,1 to set the pattern for a major scale.

Select all
Selects all strings at once.
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5

Action bar
Contains options that allow you to change the number and arrangement of strings.

6

●

Add String: Adds a new string below the lowest currently selected string. The new string
is a duplicate of the lowest currently selected string.

●

Add String at Top: Adds a new string at the top of the fretboard. The new string is a
duplicate of the previous top string.

●

Move string buttons: Allow you to move the currently selected strings up/down the
fretboard.

●

Reset to Default: Returns all strings and corresponding tunings to the factory default
settings for the fretted instrument.

●

Delete String: Deletes the selected strings.

Import Tuning
Opens the File Explorer/macOS Finder, where you can select the .doricotuning file that
you want to import and apply to the fretted instrument.

7

Export Tuning
Opens the File Explorer/macOS Finder, where you can select the location to which you want
to export the strings and tuning settings of the fretted instrument as a .doricotuning file.
You can then import the .doricotuning file into other instruments/projects and share it
with other users.

RELATED LINKS
Tablature on page 1188
Fretted instrument tuning on page 116

Changing the open pitches of fretted instrument strings
You can change the open pitch of each fretted instrument string independently, for example, if
your project requires an unconventional tuning that is not available as an instrument type in the
instrument picker.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the fretted instrument whose
open pitches you want to change.

2.

Click the arrow that appears in the instrument label when you hover over it and choose Edit
Strings and Tuning to open the Edit Strings and Tuning dialog.

3.

Select the string whose open pitch you want to change.

4.

Change the Open pitch value, for example, to G2.

5.

Optional: Repeat steps 3 and 4 to change the open pitch of other strings.

6.

Click OK to save your changes and close the dialog.

RESULT
The open pitches of the selected strings are changed. This affects the tuning of the instrument
and the pitch of all fret positions on those strings.
RELATED LINKS
Fretted instrument tuning on page 116
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Importing fretted instrument tunings
You can import custom fretted instrument tunings that you have already created and apply them
to instruments. This allows you to reuse tunings without having to create them from scratch.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the fretted instrument to which
you want to apply an imported tuning.

2.

Click the arrow that appears in the instrument label when you hover over it and choose Edit
Strings and Tuning to open the Edit Strings and Tuning dialog.

3.

Click Import Tuning at the bottom of the dialog to open the File Explorer/macOS Finder.

4.

Locate and select the .doricotuning library file you want to import.

5.

Click Open.

RESULT
The selected .doricotuning file is applied to the fretted instrument.

Exporting fretted instrument tunings
You can export fretted instrument tunings so you can reuse them for other instruments and in
other projects. Fretted instrument tunings are exported as .doricotuning library files.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the fretted instrument whose
tuning you want to export.

2.

Click the arrow that appears in the instrument label when you hover over it and choose Edit
Strings and Tuning to open the Edit Strings and Tuning dialog.

3.

Click Export Tuning at the bottom of the dialog to open the File Explorer/macOS Finder.

4.

In the File Explorer/macOS Finder, specify a name and location for the library file.

5.

Click Save.

RESULT
The tuning of the selected fretted instrument is exported and saved as a .doricotuning library
file.
AFTER COMPLETING THIS TASK
You can import the library file into other projects to reuse the fretted instrument tuning.

Player groups
A group represents a collection of musicians that are considered together, such as one choir in a
work for double choir or an off-stage ensemble. Player groups have their own brackets.
Grouping players together means they are positioned together in the score, numbered
independently of players outside the group, and are bracketed together according to the
ensemble type set for each layout.
For example, if your project is for double choir (SATB/SATB), all voices are joined by a single
bracket by default because they are in the same family. However, if you add each choir to its own
group, they are bracketed separately. This is useful in works containing multiple groups, such as
in Britten's “War Requiem”, which has three distinct groups, or in Walton's “Belshazzar's Feast”
which requires two separate off-stage brass groups.
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You can add as many player groups as required, for example, to allow easy separation of forces
or to prevent automatic instrument numbering for percussion instruments when multiple
percussion players hold the same instrument to accommodate instrument changes.
NOTE
If the instruments you group together were not already next to each other according to
orchestral order, this changes the order of players in the score project-wide.

RELATED LINKS
Instrument numbering on page 113
Brackets and braces on page 683
Brackets according to ensemble type on page 685

Adding player groups
You can organize players into groups, for example, if you want to bracket them together. Players
in different groups are also numbered separately.
PREREQUISITE
The Players panel is open.
PROCEDURE
1.

Optional: If you want to add a group that includes existing players, select those players in
the Players panel.

2.

At the bottom of the Players panel, click Add Group.

RESULT
A new player group is added to the Players panel. If you selected players, those players are
added to the group. If you did not select players, the new group is empty.
AFTER COMPLETING THIS TASK
You can add players to groups and move them between groups.
RELATED LINKS
Adding players to groups on page 131
Moving players between groups on page 131

Renaming player groups
You can change the name of player groups after you have added them.
PROCEDURE
1.

In the Players panel, double-click the name of the group.

2.

Enter a new name for the group or edit the existing name.

3.

Press Return .
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Deleting player groups
You can delete groups of players, for example, if you no longer need a group of players that you
created when importing a MIDI file. When deleting player groups, you can choose to keep the
players within the group or delete them as well.
PROCEDURE
1.

In the Players panel, select the group that you want to delete.

2.

Press Backspace or Delete .

3.

Choose one of the following options in the warning message that opens:
●

Keep Players: Deletes the group but keeps the players.

●

Delete Players: Deletes the group and the players it contains.

Adding players to groups
You can add existing or new players to player groups.
PREREQUISITE
You have added at least one player, one ensemble, or one group.
PROCEDURE
●

In the Players panel, do one of the following:
●

Select one or more players and click Add Group.

●

Select a group, and click Add Solo Player, Add Section Player, or Add Ensemble.

RESULT
If you clicked Add Group, a new group is added for the selected players.
If you clicked Add Solo Player, Add Section Player or Add Ensemble, a new player or ensemble
is added to the selected group.
RELATED LINKS
Adding solo/section players on page 109

Moving players between groups
You can move players from one group to another.
PROCEDURE
1.

In the Players panel, select the players that you want to move to another group.

2.

Click and drag the selected players to the position you want in the other group.
An insertion line indicates where the players will be positioned.

RESULT
The players are moved to the other group.
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Removing players from groups
You can remove players from groups.
PROCEDURE
●

In the Players panel, remove players from groups in any of the following ways:
●

Click and drag multiple selected players out of the group and release the mouse.

●

Right-click a single player and choose Remove Player from Group from the context
menu.
NOTE
You can only remove a single player from a group at a time when using the context
menu.

RESULT
The players are removed from their groups but remain in the project as individual players.

Flows
Flows are separate spans of music that are completely independent in musical content, meaning
they can contain completely different players from each other and have different time signatures
and key signatures. A single project can contain any number of flows.
Depending on the purpose of each project, a flow could be, for example, a single song in an
album, a movement in a sonata or symphony, a number in a stage musical, or a short scale or
sight-reading exercise of only a few bars in length.
Dorico Pro automatically adds a flow to projects once you have added at least one player. You
cannot add flows until you have added at least one player to the project.
When you add a flow in Dorico Pro, the following happens automatically:
●

The flow is assigned to all full score and part layouts in the project.

●

All players are assigned to the new flow.

By default, all layouts include all flows in the project. If necessary, you can change the layouts to
which flows are assigned and which players are assigned to flows.
IMPORTANT
If you exclude a player from a flow, any notes that you have already input for that player in that
flow are deleted.
You can change notation options, such as beam grouping and accidental duration rules, for each
flow independently in the Notation Options dialog.
RELATED LINKS
Flows panel on page 101
Notation Options dialog on page 160
Players on page 108
Layouts on page 134
Tacets on page 467
Changing the players assigned to flows on page 134
Changing the flows assigned to layouts on page 136
Importing flows on page 75
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Exporting flows on page 76

Adding flows
You can add any number of new flows to your project.
PREREQUISITE
You have added at least one player to the project.
PROCEDURE
1.

In the Flows panel, click Add Flow.

2.

Optional: Repeat for as many flows as you require.

RESULT
A new flow is added to your project each time you click Add Flow. All existing players are
assigned to new flows, and new flows are automatically assigned to all existing full score and
part layouts.
AFTER COMPLETING THIS TASK
You can double-click the flow card to rename the flow. You can also change the players assigned
to the flow and the layouts to which the flow is assigned.
RELATED LINKS
Importing flows on page 75
Changing the flows assigned to layouts on page 136

Duplicating flows
You can duplicate flows, for example, if you want to experiment with some ideas without
affecting the original flow or if you want to copy material with any barlines you have added.
PROCEDURE
●

In the Flows panel, right-click the flow you want to duplicate and choose Duplicate Flow
from the context menu.

RESULT
A new flow is added, containing all the music and players of the original flow. It is automatically
added to all full score and part layouts.
RELATED LINKS
Changing the flows assigned to layouts on page 136
Changing the players assigned to layouts on page 136
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Changing the players assigned to flows
By default, all players in your project are added to all flows that originated in the project. You can
assign players to and remove players from flows manually, for example, if the soloists in a choral
work do not sing for an entire flow.
NOTE
If you remove a player from a flow, any notes you have already input for that player in that flow
are deleted.

PROCEDURE
1.

In the Flows panel, select the flow whose assigned players you want to change.

2.

In the Players panel, activate the checkbox in the player card of each player you want to
assign to the flow.

TIP
You can Shift -click to activate/deactivate the checkboxes in multiple player cards at once.
3.

Optional: Repeat steps 1 and 2 for other flows whose assigned players you want to change.

RESULT
Players are assigned to the selected flow when the checkbox in their player card is activated, and
removed from the flow when the checkbox is deactivated.
RELATED LINKS
Players on page 108
Layouts on page 134
Tacets on page 467
Changing the flows assigned to layouts on page 136
Changing the players assigned to layouts on page 136

Deleting flows
You can delete flows that you no longer need. This deletes all music for all instruments belonging
to all players in the flows.
PROCEDURE
1.

In the Flows panel, select the flows you want to delete.

2.

Press Backspace or Delete .

Layouts
Layouts combine musical content, as represented by flows and players, with rules for page
formatting and music engraving, and allow you to produce paginated music notation that can be
printed or exported in various formats. For example, part layouts only include the music for that
player whereas full score layouts contain all staves in the project.
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Dorico Pro provides the following layout types:
Full score
A full score layout includes all players and all flows in your project by default. Full score
layouts are concert pitch by default.
Part
A part layout is automatically created when you add a player to your project. You can
also create empty part layouts and assign players to them manually.
By default, instrumental part layouts contain all flows. They are also transposed pitch
by default.
Custom score
A custom score layout initially does not contain any players or flows. This allows you to
create your score manually and, for example, to assign only one flow instead of all
flows or only vocal and piano players to create a vocal score. Custom score layouts are
concert pitch by default.
TIP
You can combine players, layouts, and flows together in any combination. For example, you
might add all percussion players to a single part layout so that the performers can manage
instrument changes themselves. In a large-scale work, you might also create a piano reduction
for choir rehearsals, but only assign that piano player to the vocal score, meaning it does not
appear in the orchestral full score at all.

RELATED LINKS
Page formatting on page 435
Flows on page 132
Players on page 108
Players, layouts, and flows on page 107
Changing the flows assigned to layouts on page 136
Changing the players assigned to layouts on page 136
Player, layout, and instrument names on page 139
Changing layout names on page 143
Brackets according to ensemble type on page 685

Creating layouts
You can create multiple layouts for full scores and instrumental parts. You can also create
multiple custom score layouts.
PROCEDURE
●

At the bottom of the Layouts panel, click one of the following layout types:
●

Add Full Score Layout

●

Add Instrumental Part Layout

●

Add Custom Score Layout
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RESULT
The layout is added to the list of layouts in the Layouts panel.
AFTER COMPLETING THIS TASK
●

You can assign players and flows to your layout.

●

If you want to change the position of the new layout in the layouts list, you can sort and
renumber layouts.

RELATED LINKS
Sorting layouts on page 138
Renumbering layouts on page 138
Switching between layouts on page 55
Opening new tabs on page 56

Changing the players assigned to layouts
By default, all players are included in full score layouts and each player is automatically assigned
its own part layout. You can assign players to and exclude players from layouts manually, for
example, if you want to remove unnecessary players from the full score, or you want to add the
soloists’ music to the part for the accompanist.
PROCEDURE
1.

In the Layouts panel, select the layout whose assigned players you want to change.

2.

In the Players panel, activate the checkbox in the player card of each player you want to
assign to the layout.

TIP
You can Shift -click to activate/deactivate the checkboxes in multiple player cards at once.
3.

Optional: Repeat steps 1 and 2 for any other layouts whose assigned players you want to
change.

RESULT
Players are assigned to the selected layout when the checkbox in their player card is activated,
and removed from the layout when the checkbox is deactivated. If you have not changed the
name of the layout, it is automatically updated to reflect the players included in the layout.
RELATED LINKS
Player, layout, and instrument names on page 139
Changing layout names on page 143
Changing the players assigned to flows on page 134

Changing the flows assigned to layouts
By default, all flows in your project are added to all layouts. You can exclude flows that you do not
want to show in a layout. You can assign flows to and remove flows from layouts manually, for
example, if a flow in your project contains specific performance instructions for strings that you
want to show in string part layouts but not in other part layouts.
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PROCEDURE
1.

In the Layouts panel, select the layout whose assigned flows you want to change.

2.

In the Flows panel, activate the checkbox in the flow card of each flow you want to assign to
the layout.

TIP
You can Shift -click to activate/deactivate the checkboxes in multiple flow cards at once.
3.

Optional: Repeat steps 1 and 2 for other layouts whose assigned flows you want to change.

RESULT
Flows are assigned to the selected layout when the checkbox in their flow card is activated, and
removed from the layout when the checkbox is deactivated.
RELATED LINKS
Changing the players assigned to flows on page 134

Making layouts transposing/concert pitch
You can change whether each layout in your project is transposing or concert pitch. In Dorico
Pro, full score layouts are concert pitch and part layouts are transposing by default.
For example, full scores are often concert pitch, to show notes at their sounding pitch, but part
layouts are transposing so the player can read the notes they must play in order to achieve the
desired sounding pitch.
PROCEDURE
1.
2.

Press Ctrl/Cmd-Shift-L to open Layout Options.
In the Layouts list, select the layouts you want to make transposing/non-transposing.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Players section, activate/deactivate Transposing layout.

5.

Click Apply, then Close.

RESULT
The selected layouts are transposed pitch when Transposing layout is activated, and concert
pitch when it is deactivated.
TIP
You can also make layouts transposing by choosing Edit > Transposed Pitch, and concert pitch
by choosing Edit > Concert Pitch. This automatically updates the layout option but only for the
layout currently open in the music area.
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RELATED LINKS
Transposing instruments on page 115
Transpose dialog on page 203
Transposing selections on page 202
Setting different clefs for concert/transposed pitch on page 729
Hiding/Showing clefs according to layout transpositions on page 730

Concert vs. transposed pitch
Layouts in Dorico Pro can use concert or transposed pitch. This affects the pitches and key
signatures on staves belonging to transposing instruments.
When music is in concert pitch, all notes are written as they sound. This means that players with
transposing instruments reading music in concert pitch must transpose the music themselves.
For example, if a clarinet in B♭ reads a C in concert pitch, they must play the note D on their
instrument to produce the sounding note C.
When music is in transposed pitch, the notes written are the ones each instrument must play in
order to produce the desired sounding pitch. For example, if a clarinet in B♭ reads a D in
transposed pitch, the pitch that sounds from the instrument is C.
Transposing scores and parts also transpose key signatures according to the transposition of the
instrument.
RELATED LINKS
Transposing key signatures alongside selections on page 846
Enharmonic equivalent key signatures on page 846

Sorting layouts
You can change the order in which layouts appear in the Layouts panel and the layout selector,
for example, if you added a custom score layout and want it to be positioned at the top next to
the full score layout.
PROCEDURE
1.

In the Layouts panel, click and drag a layout card to a different position.
An insertion line indicates where the players will be positioned.

2.

Release the mouse.

RESULT
The layout is inserted at the selected position.

Renumbering layouts
You can renumber all the layouts in their project according to their current position in the
Layouts panel in Setup mode, for example, after you have dragged layouts to different positions.
PROCEDURE
●

In the Layouts panel, right-click any layout card and choose Renumber Layouts from the
context menu.

RESULT
All layouts are renumbered according to their current position in the panel. Full score layouts,
custom score layouts, and part layouts are all numbered separately.
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RELATED LINKS
Layouts panel (Setup mode) on page 98

Deleting layouts
You can delete any layout from the project, for example, if you only want to use a combined
Violin I and II part, you can delete their separate parts.
PROCEDURE
1.

In the Layouts panel, select the layouts that you want to delete.

2.

Press Backspace or Delete .

Restoring default layouts
You can recreate all the part layouts that Dorico Pro provides by default, for example, if you
accidentally deleted some part layouts.
PROCEDURE
●

Choose Setup > Create Default Part Layouts.

RESULT
The default set of part layouts is restored, recreating a single part layout for each player that
contains all flows in the project. Any part layouts that were recreated are added at the bottom of
the Layouts list. Their order matches the order of the corresponding players in the Players
panel.

Player, layout, and instrument names
In Dorico Pro, you can use three different names to refer to the same player in different contexts.
This allows you to show relevant information in different places in the score.
The following names relate to players and instruments:
Player name
Given to players in the Players panel. It is not used in the score, instead you can use
the player name as part of your own workflow, independently of what instruments and
players are called in staff labels and layout names. You can refer to the player name in
text frames using the {@playernames@} token.
Player names are automatically generated when you add instruments.
Layout name
The name for each layout in the Layouts panel. They are used at the top of individual
part layouts. You can refer to the layout name in text frames using the
{@layoutname@} token.
Layout names are automatically generated when you add instruments, and are linked
to the player name until you change the layout name.
Instrument names
Used in staff labels. This means that the instrument label on each staff is relevant to
the instrument or percussion kit currently being played by that player, rather than
listing all instruments that player is playing in the flow. You can refer to instrument
names in text frames using the {@stafflabelsfull@} and {@stafflabelsshort@} tokens.
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For example, if a clarinettist is doubling bass clarinet, the staff label where the player
plays clarinet automatically shows Clarinet, and the staff label automatically shows
Bass Clarinet where the player plays bass clarinet.
All instruments in Dorico Pro come with a set of instrument names that you can change
for individual instruments, independently of other players in the project holding the
same instrument. You can also save changes to instrument names as default, which
are then used whenever you add that instrument again in the current project and all
future projects.
NOTE
Changing the default instrument names does not change the instrument names of
existing instruments of that type in your project.

RELATED LINKS
Instrument numbering on page 113
Text tokens on page 396
Staff labels on page 1145
Staff labels on condensed staves on page 1156
Divisi staff labels on page 1184
Staff labels for percussion kits on page 1154
Percussion legends on page 1287
Players on page 108
Layouts on page 134

Edit Instrument Names dialog
The Edit Instrument Names dialog allows you to change the content and formatting of each
instrument’s names, which are used in staff labels and instrument change labels shown above
the staff. You can edit both singular/plural full instrument names and singular/plural short
instrument names.
●

You can open the Edit Instrument Names dialog in Setup mode by clicking the arrow in an
instrument label in the Players panel and choosing Edit Names.
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Edit Instrument Names dialog

The Edit Instrument Names dialog contains the following options and sections:
1

Editing instrument
Displays the permanent underlying name of the instrument.

2

Editing
Allows you to switch between editing the Singular names and Plural names of the selected
instrument.
Singular names is used when staff labels are shown by default, Plural names is used when
the staff contains multiple players.

3

Full name section
Contains options that allow you to edit the appearance of the full instrument name.

4

Full name text editor options
Allows you to customize the font, size, and formatting of the long staff label of the selected
instrument.
NOTE
The horizontal alignment of staff labels always uses the alignment of the paragraph style,
not the alignment set in the Edit Instrument Names dialog.

5

Full name text editing area
Shows the current long name for the selected instrument, as it appears in Full staff labels.
You can select any part of the instrument name and edit it independently of other parts, for
example, if you want to add additional information on a new line and in italics. However,
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when used for instrument change labels above the staff, instrument names are always
shown on a single line.
Staff labels are right-aligned by default, so appear at the right edge of the text editing area.
NOTE
Staff labels always use the alignment set for the paragraph style, they do not use the
alignment set in the Edit Instrument Names dialog. This ensures consistent alignment
across the whole system.
6

Short name section
Contains options that allow you to edit the appearance of the short instrument name.

7

Short name text editor options
Allows you to customize the font, size, and formatting of the short staff label of the selected
instrument.
NOTE
The horizontal alignment of staff labels always uses the alignment of the paragraph style,
not the alignment set in the Edit Instrument Names dialog.

8

Short name text editing area
Shows the current short staff label for the selected instrument, as it appears in Abbreviated
staff labels. You can select any part of the instrument name and edit it independently of
other parts, for example, if you want to add additional information on a new line and in
italics. However, when used for instrument change labels above the staff, instrument names
are always shown on a single line.
Staff labels are right-aligned by default, so appear at the right edge of the text editing area.
NOTE
Staff labels always use the alignment set for the paragraph style, they do not use the
alignment set in the Edit Instrument Names dialog. This ensures consistent alignment
across the whole system.

9

Show transposition
Allows you to choose when the transposition is shown in the instrument name for the
selected instrument. It is common to see the transposition included in the name of
transposing instruments, such as Clarinet in B♭.
You can choose when the transposition is shown from the following options:
●

Always: Instrument transpositions are shown even if you have chosen to hide them on
the Staves and Systems page in Setup > Layout Options.

●

Follow Layout Options: Instrument transpositions can be hidden and shown,
depending on your per-layout settings in Layout Options.

●

Never: Instrument transpositions are never shown, even if you have chosen to show
them in Layout Options.

10 Save as default for instrument
Activating the checkbox saves your changes in the dialog as the default. This affects all new
instruments of that type that you add to the project and all future projects. It does not affect
any existing instruments of that type.
11 Reset to Default
Removes all your changes to staff labels for the selected instrument type and reverts them
to the default settings.
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RELATED LINKS
Paragraph Styles dialog on page 410
Staff labels on page 1145
Hiding/Showing staff labels on page 1148

Changing player names
You can change the player names of players, and reset renamed players to their default name.
NOTE
Player names are not used for staff labels in the score or for naming layouts, instead they are for
your own reference in Setup mode.
Staff labels use the name set for each instrument in the Edit Instrument Names dialog.

PROCEDURE
1.

In the Players panel, select the card of the player whose player name you want to change.

2.

Open the player name text field in any of the following ways:
●

Double-click anywhere in the player card.

●

Right-click in the player card and choose Rename from the context menu.

3.

Enter a new name, or click Reset to Default to revert the name to the default name.

4.

Press Return .

RESULT
The player name of the selected player is changed.
NOTE
This does not change the staff label that appears in the score. You can change the name used for
staff labels in the Edit Instrument Names dialog, and change the layout name for the names at
the top of parts.

Changing layout names
Layout names are used to identify individual layouts, for example, as the name at the top of
parts. You can change the layout names of players, and reset renamed players to their default
name.
NOTE
Layout names are not used for staff labels. Staff labels use the name set for each instrument in
the Edit Instrument Names dialog.

PROCEDURE
1.

In the Layouts panel, select the name of the player whose layout name you want to change.

2.

Open the layout name text field in any of the following ways:

3.

●

Double-click anywhere in the layout card.

●

Right-click in the layout card and choose Rename from the context menu.

Enter a new name, or click Reset to Default to revert the name to the player name.
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4.

Press Return .

RESULT
The layout name of the selected player is changed, or reverted to the default name.
NOTE
This does not change the staff label that appears in the score. You can change the name used for
staff labels in the Edit Instrument Names dialog, and change the layout name for the names at
the top of parts.

RELATED LINKS
Instrument numbering on page 113

Changing instrument names
Instrument names are used in staff labels and instrument change labels shown above the staff.
You can change the different instrument names used for each instrument.
NOTE
Changing instrument names does not change the name shown at the top of part layouts. If you
want to change the name used at the top of part layouts, change the layout name.

PROCEDURE
1.

In the Players panel, click the disclosure arrow in the player card containing the instrument
whose names you want to change.
This expands the card to show the instruments held by the player.

2.

Click the arrow that appears in the instrument label when you hover over it and choose Edit
Names to open the Edit Instrument Names dialog.

3.

Enter new names in any of the name fields.

4.

Optional: Activate Save as default for instrument.

5.

Click OK to save your changes and close the dialog.

RESULT
The instrument names for the selected instrument are changed.
●

If you did not save your changes as default, only the names of the selected instrument are
changed. Any instruments of the same type added later or in future projects use the original
default names.

●

If you saved your changes as default, any instruments of the same type added later or in
future projects use your new instrument names. This does not affect any existing
instruments of that type.

RELATED LINKS
Instruments on page 112
Edit Instrument Names dialog on page 140
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Flow names and flow titles
Whenever you add a flow to a project, the default name of a flow is Flow plus an incremental
number. You can rename flows in the Project Info dialog and in the Flows panel in Setup mode.
When you enter names for flows, those names are automatically added in the Title field for the
appropriate flow in the Project Info dialog. If you later change the names of flows, the
corresponding flow titles are updated.
Titles shown in scores and parts are linked to the Title field for each flow in the Project Info
dialog, using the {@projectTitle@} and {@flowTitle@} text tokens.
Changing the titles of flows in the Project Info dialog removes this link, meaning that changing
flow names no longer automatically updates the corresponding flow titles.
This allows you to organize flows with different names to their official title, for example, if you
want to differentiate a sketch version of a flow.
TIP
You can change flow names and flow titles in the Project Info dialog, and you can also change
flow names in the Flows panel in Setup mode.

RELATED LINKS
Text tokens on page 396
Project Info dialog on page 102
Flows panel on page 101

Renaming flows
You can change the names of flows in Setup mode. This automatically updates the title of the
corresponding flow until you change the title in the Project Info dialog.
PROCEDURE
1.

In the Flows panel in Setup mode, double-click the card of the flow you want to rename to
open the flow name text field.

2.

Enter a new name for the flow or edit the existing name.

3.

Press Return .

RESULT
The name of the flow is changed. If you have not entered a different title for the flow in the
Project Info dialog, the title shown in the music area is updated to match the new flow name.
TIP
You can also rename flows in the Project Info dialog.

Changing flow titles
You can change flow titles in the Project Info dialog. Once you have done so, flow titles are no
longer automatically changed if you change their flow name.
PROCEDURE
1.

Press Ctrl/Cmd-I to open the Project Info dialog.

2.

Select the flow whose title you want to change in the flows list.
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3.

Enter a new title in the Title field.

4.

Optional: Repeat steps 2 and 3 for other flows in your project.

5.

Click OK to save your changes and close the dialog.

RESULT
The titles of the selected flows are changed.
NOTE
This breaks the link between flow names and the title shown in the music area.

Videos
Dorico Pro supports the use of videos within the program as well as the associated notations,
such as markers and timecodes, and allows you to find appropriate tempos based on where
important markers occur.
Videos are a fast sequence of images that create the impression of a moving image. They can be
any length, from only a few seconds up to several hours for feature-length films.
Videos in Dorico Pro are shown in a separate Video window and play back in sync with the music.
Any existing audio in the video is also played back, and you can control the volume of this audio
independently of the volume of the music.
TIP
You can use these features, including setting a project frame rate, without having a video
attached.

RELATED LINKS
Adding videos on page 148
Frame rates on page 151
Changing the project frame rate on page 151
Timecodes on page 1066
Markers on page 1060
Changing the volume of video audio on page 150

Supported video formats
Dorico Pro uses the same video engine that was introduced in Cubase and Nuendo in 2017. It
supports the most commonly-used video formats.
The following video formats are supported:
●

MOV: Including H263, H264, Apple ProRes, DV/DVCPro and Avid DNxHR codecs

●

MP4: Including H263 and H264

●

AVI: Including DV/DVCPro and MJPEG/PhotoJPEG

All the common frame rates, such as 23.976, 24, 24.975, 25, 29.97, and 30 frames per second, are
fully supported in Dorico Pro.
NOTE
●

Videos with variable frame rates are not supported.

●

Support for more formats is planned for future versions.
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You can consult the Steinberg support site for more information about the supported formats as
well as how to identify and change video formats.
RELATED LINKS
Frame rates on page 151

Video Properties dialog
The Video Properties dialog allows you to change video-related settings, including their frame
rate and start position.
●

You can open the Video Properties dialog in Setup mode by right-clicking a flow in the
Flows panel and choosing Video > Properties from the context menu.

The dialog also opens automatically when you add a new video.

Video Properties dialog

The Video Properties dialog contains the following fields and options:
Video file
Shows the location of the video file on your computer. This field is read-only.
Video frame rate
Shows the frame rate of the video file. This field is read-only.
Project frame rate
Allows you to select a frame rate for your project from the menu. You can only have a
single frame rate across the project.
Use video frame rate
Sets the project frame rate to be the same as the video file.
Flow attachment position
Allows you to set the rhythmic position at which the video attaches. This is set using
the Beat count and Beat unit settings in combination, such as eight dotted quarter
notes.
Video start offset
Allows you to set a position within the video that syncs with the flow attachment
position, for example, you can set the fifth second of the video to attach to the start of
the third bar.
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Timecode start
Allows you to set the timecode at the start of the video. This also affects the timecode
of the flow, but the initial timecode of the flow adjusts to accommodate the video. For
example, if the initial timecode of the video is 02:00:00:00 but the video does not start
until the start of the third bar in 4/4, the initial timecode of the flow is eight beats of
time less than 02:00:00:00; if the tempo is 60 bpm, this makes the initial flow timecode
01:59:52:00.
NOTE
Flow timecodes are shown in their flow cards in the Flows panel.

RELATED LINKS
Timecodes on page 1066
Flows panel on page 101

Adding videos
You can add a video to each flow in your project. You can also follow these steps to reload videos
previously added to the project that Dorico Pro can no longer locate.
Flows with missing videos show a warning icon instead of the video icon in the flow card in the
Flows panel. This can happen if you send a project to someone else without the video file.
PREREQUISITE
You have added at least one player to the project.
PROCEDURE
1.

In the Flows panel, right-click the flow to which you want to add/reload a video.

2.

Choose Video > Attach from the context menu to open the File Explorer/macOS Finder.

3.

In the File Explorer/macOS Finder, locate and select the video file you want to add.

4.

Click Open to open the Video Properties dialog.

5.

In the Video Properties dialog, change the options as appropriate for your project.

6.

Click OK to save your changes and close the dialog.

RESULT
The selected video file is added to the flow and is shown in the Video window. A video reel icon
appears in the flow card in the Flows panel, beside a timecode indicating the combination of the
Video start offset and Timecode start.
If you reloaded a video, all your previous settings are retained.
RELATED LINKS
Timecodes on page 1066
Changing the initial timecode value on page 1067

Changing the start position of videos
You can change both the rhythmic position in the music at which videos start, and the position in
the video that coincides with that rhythmic position, for example, if you want the fifth second of a
video to sync with the start of the third bar of music.
PROCEDURE
1.

In Setup mode, open the Video Properties dialog in one of the following ways:
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●

Add a video to a flow.

●

In the Flows panel, right-click a flow and choose Video > Properties from the context
menu.

2.

In the Video Properties dialog, change the values for Flow attachment position and/or
Video start offset.

3.

Click OK to save your changes and close the dialog.

RESULT
Changing the value for Flow attachment position changes the rhythmic position in the music at
which the video starts.
Changing the value for Video start offset changes the position in the video that occurs at the
Flow attachment position.
For example, if you change the Video start offset to 00:00:05:00 and the Flow attachment
position to 8, then the fifth second in the video happens on the eighth beat in the music.
NOTE
●

The initial rhythmic position is 0. Therefore, if the Flow attachment position is set to 8 and
the time signature is 4/4, the flow attachment occurs on the first beat in the third bar.

●

Changing the Video start offset changes what part of the video coincides with the Flow
attachment position, but this does not cut the video before this point. Any preceding video
material is shown as long as it happens within the flow.

RELATED LINKS
Timecodes on page 1066
Changing the initial timecode value on page 1067

Hiding/Showing the Video window
You can hide and show the Video window at any time and in any mode, for example, if you do
not want it in view when working on the music in the music area.
PROCEDURE
●

Hide/Show the Video window in any of the following ways:
●

Press F4 .

●

In the toolbar, click Show Video.

●

Choose Window > Video.

RESULT
The Video window is hidden/shown. It is shown when a tick appears beside Video in the Window
menu, and hidden when no tick appears.
RELATED LINKS
Toolbar on page 43
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Changing the size of the Video window
You can change the size of the Video window at any time.
PREREQUISITE
The Video window is shown.
PROCEDURE
●

Change the size of the Video window in any of the following ways:
●

Click and drag the corners/edges in any direction.

●

Shift -click and drag a corner/edge to change the size without changing the shape.

RESULT
The size of the Video window is changed. Dorico Pro saves the new size and shape and uses this
for all projects until you change the size again.

Removing videos
You can remove videos from each flow independently.
PROCEDURE
●

In the Flows panel, right-click the flow from which you want to remove a video and choose
Video > Detach from the context menu.

RESULT
The video is removed from the selected flow.

Changing the volume of video audio
Any audio that is part of a video you have added is played back in sync with the music in the
project. You can change the video volume manually.
PREREQUISITE
The Mixer window is shown.
PROCEDURE
1.

Optional: If the Video channel is not shown in the Mixer window, click Video in the Mixer
toolbar.

2.

Change the Video channel volume in any of the following ways:
●

Click and drag the Video channel fader upwards/downwards.

●

Click Mute at the top of the Video channel.

RESULT
The volume of audio from videos in your project is changed. If you clicked Mute, no audio from
videos sounds in playback.
RELATED LINKS
Hiding/Showing the Mixer window on page 556
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Frame rates
The frame rate of a video is the number of still images that are used per unit of time in order to
create the impression of a moving image, commonly measured in frames per second, or “fps”.
The number of frames per second required to create the impression of a moving image is
determined by how fast the human eye processes movement, and so the most common frame
rate is around 24 fps. However, recent major films have been released at 48 fps, which results in
sharper images.
Dorico Pro supports frame rates from 23.976 fps to 60 fps, for example, the US and Canadian
broadcast standard NTSC, which is used in, uses 29.97 fps.
Frame rates are closely linked to timecodes, as timecodes include both the time and the current
frame position.
All the common frame rates, such as 23.976, 24, 24.975, 25, 29.97, and 30 frames per second, are
fully supported in Dorico Pro.
By default, Dorico Pro uses the same frame rate for the project as the video file, but you can
manually choose a different frame rate.
RELATED LINKS
Timecodes on page 1066

Changing the project frame rate
By default, Dorico Pro uses the video frame rate as the project frame rate. You can change the
project frame rate if you want it to be different, for example, if your project contains multiple
videos with different frame rates.
TIP
You can change the frame rate even if there are no videos in the project.

PROCEDURE
1.

In Setup mode, open the Video Properties dialog in one of the following ways:
●

Add a video to a flow.

●

In the Flows panel, right-click a flow and choose Video > Properties from the context
menu.

2.

In the Video Properties dialog, select the frame rate you want to use for the project from
the Project frame rate menu.

3.

Click OK to save your changes and close the dialog.

RESULT
The project frame rate is changed.
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Write mode allows you to input and edit your music, including changing the rhythmic positions
of items, changing the pitch of notes, and deleting notes and items. The available toolboxes and
panels allow you to input all the notes and notation items that are most commonly used.
By design, you cannot move notes and items graphically in Write mode. Graphical adjustments
are only possible in Engrave mode.

Project window in Write mode
The project window in Write mode contains the default toolbar, the music area, and the status
bar. It provides toolboxes and panels with the tools and functions required to write your music.
You can switch to Write mode in any of the following ways:
●

Press Ctrl/Cmd-2 .

●

Click Write in the toolbar.

●

Choose Window > Write.

Toolboxes and panels in Write mode

The following panels and toolboxes are available in Write mode:
1

Notes toolbox
Contains tools that affect note input.

2

Notes panel
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Contains the note durations, accidentals, and articulations that are most commonly used
during note input.
3

Notations panel
Contains notation items that you can add to your music, such as dynamics and playing
techniques, divided into separate categories. Your current selection in the Notations toolbox
determines which notation items are shown.

4

Notations toolbox
Allows you to determine which notation items are shown in the Notations panel, and to input
certain items directly, such as rehearsal marks, chord symbols, and fingerings.

5

Properties panel
Contains properties that allow you to make individual modifications to the currently selected
notes and notations, independently of your project-wide settings.
NOTE
Many properties are layout-specific, meaning changing the properties of an item in one
layout does not affect the same item in other layouts. However, you can copy property
changes to other layouts.

RELATED LINKS
Copying property settings to other layouts on page 493

Notes toolbox
The tools in the Notes toolbox allow you to modify notes and change the type of notes you input.
The Notes toolbox is located on the left of the window in Write mode.
Dotted Notes

During note input, this inputs dotted notes, rests, or chords based on the currently
selected duration. When editing existing notes, you can use this tool to add/remove
rhythm dots from existing notes, rests, and chords.
You can also activate/deactivate Dotted Notes by pressing . (period). You can increase
the number of dots on notes by pressing Alt/Opt-. (period).
Rests

When this option is activated, you input rests of the currently selected duration instead
of notes.
You can also start/stop rest input by pressing , (comma).
Chords

When this option is activated, you add multiple notes at the same rhythmic position in
order to build a chord. This function prevents the caret from advancing automatically
after inputting a note. It also allows you to copy notes and items without overwriting
any existing notes or items.
You can also start/stop chord input by pressing Q .
Tuplets
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Clicking this option inputs a triplet bracket and the respective number of rests at the
specified rhythmic position. If the notes are beamed, no brackets are used.
You can input other types of tuplet, such as quintuplets, by using the tuplets popover.
Grace Notes

When this option is activated, you input grace notes at the current rhythmic position
instead of normal notes.
You can also start/stop grace note input by pressing / .
Insert

When this option is activated, the notes you input are inserted before existing music
ahead of the caret instead of overwriting it. Similarly, reducing the duration of notes
with Insert mode activated pulls them closer together without leaving rests between
the notes. Insert mode also instructs Dorico Pro to add any extra beats required to fill
bars when inputting or changing time signatures.
You can also activate/deactivate Insert mode by pressing I .
Lock to Duration

When this option is activated, the durations of existing notes are used as you input
notes. This allows you to maintain the duration of notes while you change their pitches.
You can also activate/deactivate Lock to Duration by pressing L .
Force Duration

When this option is activated, Dorico Pro always inputs notes/rests with the explicit
duration you have selected. For example, you can activate Force Duration to force the
input of a dotted quarter note on the second quarter beat of 4/4, where Dorico Pro
splits the note with a tie by default.
IMPORTANT
You can get unexpected results if you force the duration of notes and later change the
time signature or move barlines, for example.
If you activated Force Duration during input, you can remove the restrictions on how
Dorico Pro notates the music by selecting the affected passage of music and selecting
Edit > Reset Appearance.
You can also activate/deactivate Force Duration by pressing O .
Tie

During note input, this ties the note to be input to the previous note of the same pitch.
When editing existing notes, you can use this tool to tie together notes of the same
pitch in different voices or to tie grace notes to rhythmic notes.
You can also activate Tie by pressing T .
NOTE
You cannot deactivate Tie. If you want to delete ties, you must use Scissors.
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Scissors

During note input, this splits notes, chords, and explicit rests in two at the caret
position. When editing existing notes, it deletes all ties in tie chains.
You can also activate Scissors by pressing U .
Select

Activates/Deactivates mouse input. When mouse input is deactivated, you cannot input
notes by clicking on the staff.
RELATED LINKS
Inputting notes with rhythm dots on page 178
Inputting chords on page 194
Inputting tuplets on page 195
Inputting grace notes on page 193
Activating/Deactivating mouse input on page 175
Input methods for time signatures on page 222

Notes panel
The Notes panel contains buttons that allow you to select note and rest durations, and to input
accidentals, slurs, and articulations. It is located on the left of the window in Write mode.
You can hide/show the Notes panel in any of the following ways:
●

Press Ctrl/Cmd-7 .

●

Click the disclosure arrow on the left edge of the main window.

●

Choose Window > Show Left Panel.
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The upper part of the Notes panel contains note durations that you can select for input or to
change the duration of existing notes. By default, only the most common note durations are
shown. You can see all note durations by clicking the Show/Hide All Notes disclosure arrows at
the top and bottom of the section.
In the middle part of the Notes panel, you can activate/deactivate accidentals and activate slurs.
However, you cannot deactivate slurs, you must delete them.
In the bottom part of the Notes panel, you can activate/deactivate articulations.
RELATED LINKS
Inputting notes on page 172
Inputting accidentals on page 188
Inputting articulations on page 210
Inputting slurs on page 212

Properties panel (Write mode)
The Properties panel in Write mode contains quick access properties that allow you to change
notes and notations, both during note input and by changing existing notes. It is located at the
bottom of the window in Write mode.
The Properties panel contains a group of properties for each notation item. When you select a
note or item in the music area, the Properties panel displays the groups and options that you
might require to edit the selected note or item.
NOTE
●

If you select multiple different types of notation items, only the groups that they have in
common are displayed. For example, if you select a slur, the Common and Slurs groups are
displayed in the Properties panel. However, if you select a slur and a note, only the Common
group is displayed.

●

Many properties are layout-specific, meaning changing the properties of an item in one
layout does not affect the same item in other layouts. However, you can copy property
changes to other layouts.

●

If you need to change individual parts of notations, for example, the curvature direction of a
single tie within a tie chain, switch to Engrave mode.

You can hide/show the Properties panel in Write mode and Engrave mode in any of the following
ways:
●

Press Ctrl/Cmd-8 .

●

Click the disclosure arrow at the bottom of the main window.

●

Choose Window > Show Bottom Panel.
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Notes and Rests group of the Properties panel in Write mode

Changing the properties of individual notes and items
You can change the properties of individual notes and notations independently of your projectwide settings, for example, if you want crescendos to appear as hairpins by default but require a
single crescendo to appear as text.
NOTE
In Write mode, you can only change the properties of complete notes and notations. For
example, if a pedal line extends across multiple systems, you cannot change its line style on one
system but keep the original line style on another system. In Engrave mode, you can change
individual parts of notes and notations separately.

PROCEDURE
1.

Select a note or notation item in the music area.

2.

Optional: If the Properties panel is hidden, show it in any of the following ways:

3.

●

Press Ctrl/Cmd-8 .

●

Click the disclosure arrow at the bottom of the window.

●

Choose Window > Show Bottom Panel.

In the Properties panel, change the properties you want.

RESULT
The complete note or notation item is changed. The changes are immediately displayed in the
music area.
NOTE
●

Many properties are layout-specific. For example, if you change the staff-relative placement
of an item in a full score layout, this does not affect the placement of the item in the
corresponding part layout. However, you can copy property settings to other layouts.

●

You can change the default settings for how notes are notated in each flow independently,
such as the default note and beam grouping in different meters, in Write > Notation
Options.

●

You can change the default appearance and position of all notes and notations project-wide
in Engrave > Engraving Options.

RELATED LINKS
Notation Options dialog on page 160
Engraving Options dialog on page 359
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Copying property settings to other layouts on page 493
Resetting the appearance of items on page 331
Resetting the position of items on page 331

Notations toolbox
The options in the Notations toolbox allow you to determine what notation items are available in
the Notations panel. The Notations toolbox is located on the right of the window in Write mode.
Clefs

Hides/Shows the Clefs panel, which contains sections for the different clefs and octave
lines that you can input.
Key Signatures, Tonality Systems, and Accidentals

Hides/Shows the Key Signatures, Tonality Systems, and Accidentals panel, which
contains sections for the different key signatures, tonality systems, and accidentals
that you can input. You can also create and edit custom tonality systems from this
panel.
Time Signatures (Meter)

Hides/Shows the Time Signatures (Meter) panel, which contains sections for the
different types of time signatures that you can input, including a section where you can
create custom time signatures, such as interchangeable time signatures and time
signatures with pick-up bars.
Tempo

Hides/Shows the Tempo panel, which contains sections for the different types of tempo
changes that you can input, including gradual tempo changes, metronome marks, and
tempo equations.
Dynamics

Hides/Shows the Dynamics panel, which contains sections for the different dynamics
that you can input, including immediate, gradual, and custom combined dynamics.
Ornaments

Hides/Shows the Ornaments panel, which contains sections for the different
ornaments and glissando lines that you can input.
Repeat Structures

Hides/Shows the Repeat Structures panel, which contains sections for the different
types of repeat structures, including repeat endings and segments, repeat markers,
single-note and multi-note tremolos, bar repeats, and slash regions.
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Bars and Barlines

Hides/Shows the Bars and Barlines panel, which allows you to insert bars and to input
the different types of barlines.
Holds and Pauses

Hides/Shows the Holds and Pauses panel, which contains sections for the different
types of fermatas, breath marks, and caesuras that you can input.
Playing Techniques

Hides/Shows the Playing Techniques panel, which contains sections for the various
instrument family groups. Each section contains playing techniques for the
corresponding instrument family.
Lines

Hides/Shows the Lines panel, which contains sections for the different types of lines
that you can input.
Cues

Hides/Shows the Cues panel, which allows you to find suitable places for cues and
input cues.
Video

Hides/Shows the Video panel, which allows you to open the Video Properties dialog
and to view and edit markers in the current flow.
Rehearsal Marks

Inserts a rehearsal mark at the selected rhythmic position.
Text

Opens the text editor, which allows you to insert text at the selected rhythmic position.
Lyrics

Opens the lyrics popover above the selected note on the staff, which allows you to
input lyrics.
Chord Symbols

Opens the chord symbols popover above the selected note on the staff, which allows
you to input chord symbols.
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Fingering

Opens the fingerings popover above the selected note on the staff, which allows you to
input fingerings.
RELATED LINKS
Notations input on page 210
Text editor options in Write mode on page 313
Video Properties dialog on page 147

Notations panel
The Notations panel contains different notation items for your music depending on your
selection in the Notations toolbox. The Notations panel is located on the right of the window in
Write mode.
You can hide/show the Notations panel at any time, for example, if you want to find a notation to
input but then want to increase the size of the music area after inputting it.
RELATED LINKS
Hiding/Showing panels on page 24

Notation Options dialog
The Notation Options dialog provides multiple options that allow you to make changes that
affect the way music is notated for each flow by default.
The changes that you can make affect the following:
●

Note and rest grouping, such as the handling of syncopated rhythms or of different rhythms
in different time signatures

●

Voices, such as the sharing of noteheads among voices or the order in which multiple voices
are tucked together

●

Accidentals, such as the handling of cautionary accidentals

●

Transposition, such as the handling of key signatures in transposing instruments

●

Percussion kits, such as the handling of multiple voices in a single percussion kit

TIP
If you want to make direct changes to notes and notations, you can use the different options in
the Properties panel.
You can open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode or Setup > Notation Options in Setup
mode.

●

Click Notation Options in the Flows panel in Setup mode.
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Notation Options

The Notation Options dialog contains the following:
1

Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages. When you click a page in this list, any applicable section titles appear below the page
in the page list.

2

Section titles
Shows the titles of any sections on the selected page. You can click these section titles to
navigate directly to that section of the page.

3

Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible settings,
the current setting is highlighted.

4

Flows list
Contains all the flows in your project. You can select one, multiple, or all flows. You can select
multiple flows in any of the following ways:

5

●

Click Select All in the action bar to select all flows in the project.

●

Ctrl/Cmd -click to select multiple flows.

●

Shift -click to select multiple adjacent flows.

Select All
Allows you to select all flows in the Flows list.

6

Save as Default/Remove Saved Defaults
This button has different functions depending on whether you have existing saved defaults.

7

●

Save as Default saves all options currently set in the dialog as the default for new
projects.

●

Remove Saved Defaults deletes your previous saved defaults without resetting the
options in the current project. After removing your saved defaults, all future projects
start with the default factory settings. If you have existing saved defaults, you can access
Remove Saved Defaults by pressing Ctrl (Windows) or Opt (macOS) .

Reset to Factory/Reset to Saved Defaults

161
Dorico Pro 3.1.10

Write mode
Note Input Options dialog
This button has different functions depending on whether you have existing saved defaults.
●

If you have no saved defaults, Reset to Factory resets all the options in the dialog back
to the default factory settings.

●

If you have existing saved defaults, Reset to Saved Defaults resets all the options in the
dialog back to your saved defaults. You can access Reset to Factory instead by pressing
Ctrl (Windows) or Opt (macOS) . Resetting options back to the default factory settings
only affects the current project and does not delete your saved defaults, meaning future
projects start with your saved defaults.

RELATED LINKS
Flows on page 132
Options dialogs in Dorico Pro on page 40

Making flow-specific changes in Notation Options
You can change options in the Notation Options dialog for each flow independently.
PROCEDURE
1.

2.

Open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Click Notation Options in the Flows panel in Setup mode.

In the Flows list, select the flows in which you want to make changes in one of the following
ways:
●

Ctrl/Cmd -click individual flows.

●

Shift -click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Click a page in the page list.

4.

Look through the available options, and change the settings as required.

5.

Click Apply, then Close.

Note Input Options dialog
The Note Input Options dialog provides multiple options that allow you to determine how
Dorico Pro interprets the data and MIDI you input by default.
For example, there are options relating to how accidentals and notes are spelled when inputting
notes using a MIDI keyboard, what you want to include in chord symbols based on what you
play, and how to consider multiple different aspects of chord diagrams, such as whether or not
to omit the ninth in 11 and 13 chords.
You can open Note Input Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-I in any mode.

●

Choose Write > Note Input Options in Write mode.
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Note Input Options

1

Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages.

2

Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible settings,
the current setting is highlighted.

3

Save as Default/Remove Saved Defaults
This button has different functions depending on whether you have existing saved defaults.

4

●

Save as Default saves all options currently set in the dialog as the default for new
projects.

●

Remove Saved Defaults deletes your previous saved defaults without resetting the
options in the current project. After removing your saved defaults, all future projects
start with the default factory settings. If you have existing saved defaults, you can access
Remove Saved Defaults by pressing Ctrl (Windows) or Opt (macOS) .

Reset to Factory/Reset to Saved Defaults
This button has different functions depending on whether you have existing saved defaults.
●

If you have no saved defaults, Reset to Factory resets all the options in the dialog back
to the default factory settings.

●

If you have existing saved defaults, Reset to Saved Defaults resets all the options in the
dialog back to your saved defaults. You can access Reset to Factory instead by pressing
Ctrl (Windows) or Opt (macOS) . Resetting options back to the default factory settings
only affects the current project and does not delete your saved defaults, meaning future
projects start with your saved defaults.

RELATED LINKS
Navigation during chord symbol input on page 250
Accidental selection during MIDI input on page 190
Options dialogs in Dorico Pro on page 40

163
Dorico Pro 3.1.10

Write mode
Inputting vs. editing

Inputting vs. editing
Dorico Pro distinguishes the processes for inputting and editing music.

Inputting
If you can see the caret, you are inputting new music. The caret must be activated in order to
input notes and notations. If the caret is activated, selecting tools or items in the Notes toolbox
and the Notes panel affects the note or chord that you are about to input, as you can specify the
duration, rhythm dot, accidentals, and articulations. Then you specify the pitch by clicking the
note into the score, by pressing the letter name of the note on your computer keyboard, or by
playing the note or chord on your MIDI keyboard.
When the caret is activated, notes and notations are input at the caret position.
If no notes or chords are selected in the music area and you select a duration, either by pressing
its key command or by clicking it in the Notes panel, mouse input is activated. If you move the
mouse pointer over the staff, a shadow note is displayed to indicate where the note will be input
if you click.
NOTE
Deactivating mouse input prevents Dorico Pro from starting mouse input in this circumstance.

Editing
If you cannot see the caret, you can edit existing music. Editing music includes deleting notes
and notations, which you can only do in Write mode, although you can also delete notes in Play
mode but not notations. You can switch back and forth between inputting and editing at any
time.
When the caret is not activated, new items are input at the position of the first selected item in
the music area. If there is no selection, the mouse pointer is loaded with the new item. The item
is then created at the location where you click.
To edit existing notes and notations, you must select them in the music area. This allows you to
update the selected notes or items when you select, for example, new note durations,
accidentals, or articulations in the Notes panel.
We recommend that you spend a moment to understand the difference between how Dorico Pro
behaves if the caret is shown and if it is not. In the latter case, all editing functions operate on the
items that you have selected in the music area.
RELATED LINKS
Editing and selecting on page 320
Caret on page 167
Note input on page 167
Notations input on page 210

Mouse input settings
There are a number of different settings that you can choose from to determine how mouse
input functions in Dorico Pro.
You can set your preferences for mouse input in the Editing section of the Note Input and
Editing page in Preferences.
You can choose between the following options for mouse input:
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●

Create item at selection: Items are input at the position of selected items or notes in the
music area.

●

Load pointer with item: Items are loaded onto the mouse pointer so you can click in the
music area where you want to input the item.

You can also activate/deactivate Allow multiple items to be created with the mouse. When
this option is activated, you can load an item onto your mouse pointer and input the same item
in the music area multiple times without having to reselect the item each time you input it. When
this option is deactivated, you can only input an item loaded onto your mouse pointer once. If
you want to input the item at multiple positions, you must reselect it each time.
NOTE
Changing your preferences permanently changes the functionality for the current project and all
new projects.

RELATED LINKS
Preferences dialog on page 62

Changing your mouse input settings
You can change your mouse input settings, for example, if you want to load a playing technique
on the pointer once and input it in multiple places without having to reselect the playing
technique each time.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Note Input and Editing in the page list.

3.

In the Editing section, choose one of the following options for Creating items with the
mouse:
●

Create item at selection

●

Load pointer with item

4.

Optional: If you chose Load pointer with item, activate/deactivate Allow multiple items to
be created with the mouse.

5.

Click Apply, then Close.

RESULT
Your mouse input settings are changed in the current project and for all future projects.
RELATED LINKS
Notations input on page 210
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Rhythmic grid
The rhythmic grid is a unit of rhythmic duration whose value affects certain aspects of inputting
and editing, such as the amount by which items move. However, it does not control the duration
of notes and items that you input.

Rhythmic grid set to eighth notes (quavers) shown above the staff

The current rhythmic grid resolution is shown by the note value in the status bar, and by ruler
markings above the staff on which the caret is active. Longer lines in the rhythmic grid indicate
beat divisions, while shorter lines indicate beat subdivisions. In Play mode, the rhythmic grid is
shown by the frequency of vertical lines in tracks and in the ruler at the top of the event display.
The rhythmic grid controls the following:
●

The possible input positions when using the caret or the mouse, and when copying and
pasting. For example, setting the rhythmic grid resolution to 32nd notes allows you to input
notes and items at a greater number of possible rhythmic positions than when the rhythmic
grid is set to quarter notes.

●

The amount by which the caret moves when using Right Arrow / Left Arrow

●

The amount by which notes and items are lengthened/shortened

●

The amount by which notes and items move

You can change the rhythmic grid resolution at any time.
RELATED LINKS
Rhythmic position on page 39
Caret on page 167
Moving the caret manually on page 171
Event display on page 503
Tracks on page 510
Inputting notes on page 172

Changing the rhythmic grid resolution
You can change the resolution of the rhythmic grid. The resolution is indicated by the note value
symbol in the status bar and by the beat divisions and subdivisions in the ruler markings above
the caret.
The rhythmic grid resolution is set to eighth notes (quavers) by default.
PROCEDURE
●

Change the resolution of the rhythmic grid in any of the following ways:
●

Press Alt/Opt-] to decrease the rhythmic grid resolution.

●

Press Alt/Opt-[ to increase the rhythmic grid resolution.

●

Choose Write > Rhythmic Grid > Decrease Grid Resolution.

●

Choose Write > Rhythmic Grid > Increase Grid Resolution.

●

Choose Write > Rhythmic Grid > [Beat division].

●

Select a value from the Rhythmic Grid selector in the status bar.
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RESULT
Decreasing the rhythmic grid resolution makes it finer by making the note value shorter.
Increasing the rhythmic grid resolution makes it coarser by making the note value longer.
TIP
You can assign your own key commands for increasing and decreasing the rhythmic grid
resolution.

RELATED LINKS
Status bar on page 52
Assigning key commands on page 66

Note input
In Dorico Pro, you can only input notes during note input, which is when the caret is activated.
This allows you to input notations at the caret position at the same time as inputting notes, and
also reduces the risk of you adding notes to staves accidentally.
You can input notes in different ways and using any of the following devices, including switching
between them at any time:
●

MIDI keyboard

●

Computer keyboard

●

Mouse or touchpad

TIP
A MIDI keyboard is the fastest way to input notes.

RELATED LINKS
Notes on page 886
Inputting notes on page 172

Caret
In Dorico Pro, the caret is a vertical line that extends above and below five-line staves but
appears shorter on percussion staves and tablature. It shows the rhythmic position at which
notes, chords, or notation items are input.
A caret is a mark that is commonly used when proofreading published text to denote the position
at which something should be inserted or added, for example, a missing letter or a word. In
software, the caret shows where something is inserted. The caret is also known as an “insertion
point” or “cursor”. In this documentation, we use “caret” to refer to the line that appears during
note input, and “cursor” to refer to the line that appears during text input.
If you are inputting notes, the caret advances to the next rhythmic position automatically. If you
are inputting chords or notes on tablature, the caret does not move automatically, and you must
move it to the next rhythmic position manually. The caret has a note symbol beside it, which
indicates the stem direction and type of the currently selected voice. It is accompanied by a +
symbol if the voice is new.
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The caret

The appearance of the caret changes depending on the input mode and the currently selected
voice number.
Multiple staves
The caret extends vertically across all the staves onto which notes and notations will be
input. This allows you to input, for example, the same dynamics or playing techniques
on multiple staves simultaneously or play in chords on a MIDI keyboard and distribute
the notes in those chords onto multiple staves. The note symbol and rhythmic grid also
appear for each included staff.

Caret when inputting notes onto multiple staves

Insert
The caret shows V and inverted V shapes at the top and bottom. In Insert mode,
inserted notes shift all music in the current voice after the caret along by the input
duration instead of replacing existing notes. Similarly, reducing the duration of notes
with Insert mode activated pulls them closer together without leaving rests between
the notes.

Caret in Insert mode

Chords
The caret shows a plus symbol at the top left. During chord input, you can input
multiple notes at the same rhythmic position.

Caret when inputting chords

168
Dorico Pro 3.1.10

Write mode
Note input
Lock to Duration
The caret is dashed. Lock to Duration allows you to repitch notes without changing
their duration or rhythm.

Caret when Lock to Duration is activated

Grace Notes
The caret is shorter than the default caret. It allows you to input grace notes at the
caret position.

Caret when inputting grace notes

Voices
If you input multiple voices, the caret shows the following:
●

A plus symbol at the bottom left

●

The voice number into which you are inputting notes

●

An up-stem note or a down-stem note symbol to indicate the stem direction of the
voice

Caret when inputting notes into a new
down-stem voice

Caret when inputting notes into a new,
second up-stem voice

Slash voices
The note beside the caret indicates a slash notehead.
If you input multiple slash voices, the caret shows the following:
●

A plus symbol on the left at the bottom

●

The number of the slash voice into which you are about to input notes

●

An up-stem slash note or a down-stem slash note symbol indicating the stem
direction of the voice, and whether it has stems or is stemless
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Caret when inputting notes
into an up-stem slash voice

Caret when inputting notes
into a new, second up-stem
slash voice

Caret when inputting notes
into a new, stemless slash
voice

Percussion kits
The caret appears significantly smaller than usual when inputting notes into
percussion kits. The name of the kit instrument into which you are currently inputting
notes is shown above the rhythmic grid.

Caret when inputting notes into percussion kits

Tablature
The caret appears significantly smaller than usual when inputting notes into tablature.
On tablature, the caret behaves as if chord input is always active, meaning you must
advance the caret and move it to other string lines manually.

Caret when inputting notes on tablature

RELATED LINKS
Inputting notes in Insert mode on page 183
Inputting chords on page 194
Repitching notes without changing their rhythm on page 202
Inputting grace notes on page 193
Inputting notes into multiple voices on page 179
Inputting notes in percussion kits on page 184
Inputting notes on tablature on page 187

Activating/Deactivating the caret
When the caret is activated, you can input notes and notations at the caret position, for example,
if you want to input a dynamic in the middle of a tie chain. When the caret is deactivated, you
cannot input notes, instead you can select and edit items in the music area.
PROCEDURE
1.

Activate the caret in any of the following ways:
●

Select an item and press Shift-N .

●

Double-click a rhythmic position on a staff.
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2.

Deactivate the caret in any of the following ways:
●

Press Shift-N , Return , or Esc .

●

If you have deactivated mouse input, click any selectable item in the music area.

●

Switch to another mode.

RELATED LINKS
Moving the caret manually on page 171
Functions of the modes on page 22
Activating/Deactivating mouse input on page 175
Inputting notes on page 172
Notations input on page 210

Extending the caret to multiple staves
You can extend the caret so it spans multiple staves. This allows you to input notes and notations
onto multiple staves simultaneously, including automatically exploding the notes in chords that
you play on a MIDI keyboard onto the appropriate staves.
PROCEDURE
1.

2.

3.

Activate the caret in any of the following ways:
●

Select an item and press Shift-N .

●

Double-click a rhythmic position on a staff.

Extend the caret to other staves in any of the following ways:
●

To extend to the staff above, press Shift-Up Arrow .

●

To extend to the staff below, press Shift-Down Arrow .

Optional: Repeat step 2 as many times as you require.

RELATED LINKS
Inputting notes and notations onto multiple staves on page 182

Moving the caret manually
The caret moves automatically as you input notes, but you can also move it manually. For
example, the caret does not move automatically when inputting chords.
PROCEDURE
●

Move the caret in any of the following ways:
●

To move the caret according to the current rhythmic grid resolution, press
Right Arrow / Left Arrow .

●

To advance the caret according to the note value currently selected, press Space .

●

To move the caret to the next/previous bar, press Ctrl/Cmd-Right Arrow / Ctrl/CmdLeft Arrow .

●

To move the caret to the staff above/below, press Up Arrow / Down Arrow .

●

To move the caret to the top/bottom staff in the system, press Ctrl/Cmd-Up Arrow /
Ctrl/Cmd-Down Arrow .

RELATED LINKS
Inputting chords on page 194
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Inputting notes
You can input notes into your project during note input, which is when the caret is activated. You
can input notes with a computer keyboard, with the mouse, or by playing notes with a MIDI
keyboard.
NOTE
●

During note input, you must select the duration, articulations, and any accidentals not in the
prevailing key signature for each note before inputting them. This applies to all input
methods.

●

You do not have to input rests between notes, as Dorico Pro automatically shows implicit
rests of the appropriate duration between the notes you input. Similarly, you do not have to
input ties, as Dorico Pro shows notes as tie chains if necessary.

●

You can also input notations alongside inputting notes without deactivating note input.

PREREQUISITE
●

You have chosen the appropriate input pitch setting.

●

If you want to input notes into multiple instruments held by a single player or instruments
not visible in the score in page view, you are in Galley View.

●

If your music requires a key signature, you have input that key signature.

●

If you want to input notes using a MIDI device, you have connected the MIDI device you
want to use.

PROCEDURE
1.

Start note input in any of the following ways:
●

Select a note or rest on the staff where you want to input notes and press Shift-N .
NOTE
If you select a notation, such as a dynamic, pressing Return opens the corresponding
popover instead of starting note input.

●

Double-click the staff where you want to input notes.

2.

Optional: If you want to input notes onto multiple staves at once, extend the caret to those
staves.

3.

Select a note duration in any of the following ways:
●

Press the number on your computer keyboard that corresponds to the duration you
want.
For example, press 6 for quarter notes (crotchets). Press smaller numbers for smaller
durations, such as 5 for eighth notes (quavers) and 4 for 16th notes (semiquavers).
Press larger numbers for larger durations, such as 7 for half notes (minims).

●

Click the duration you want in the Notes panel on the left of the window.

4.

Optional: If you want to input a pitch whose accidental is not in the prevailing key signature,
select the appropriate accidental.

5.

Optional: Select any required articulations.

6.

Input the pitches you want in any of the following ways:
●

Press the corresponding letters on your computer keyboard.
TIP
Dorico Pro automatically selects the note whose register is the smallest interval away
from the previously input note. However, you can force a different register.
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●

●

To input a note above the previously input note, press Shift-Alt/Opt as well as the
letter for the note, for example, Shift-Alt/Opt-A .

●

To input a note below the previously input note, press Ctrl-Alt (Windows) or
Ctrl (macOS) as well as the letter for the note, for example, Ctrl-Alt-A (Windows)
or Ctrl-A (macOS) .

Click the staff at the rhythmic position of each note you want to input.
A shadow notehead appears when inputting with the mouse to indicate where the note
will be input.

●
7.

Play the notes on a MIDI keyboard.

Optional: Press Space to advance the caret without inputting notes.
TIP
You can also move the caret in different ways and by different increments.

8.

Press Esc or Return to stop note input.

RESULT
Notes are input at the caret position or where you click with the selected duration and are played
back as you input them by default. Their pitch follows the prevailing key signature. For example,
if you press F in G major, an F♯ is input automatically.
If you selected rhythm dots or articulations, notes continue to be input with them until you
deactivate them. However, accidentals not in the prevailing key signature are only added to the
first note you input after selecting them.
Dorico Pro notates and beams notes appropriately according to their duration, the current time
signature, and their position in the bar. This includes showing notes as tie chains if required.
If you advance the caret without inputting notes, Dorico Pro fills the gaps between notes with
implicit rests of the appropriate duration.
If you input notes on notation staves belonging to fretted instruments, Dorico Pro automatically
allocates these notes to the strings on which they can be played closest to the nut. Because this
calculation is done for each note separately, multiple notes can be allocated to the same string.
In such cases, the notes are shown next to each other on tablature and are colored green. You
can then select them individually and make your own string allocation.
TIP
You can change the default beam, note, and rest grouping settings for each flow independently
in Write > Notation Options. You can also specify custom beat groupings within individual time
signatures.
AFTER COMPLETING THIS TASK
You can move notes to different rhythmic positions after they have been input, and move them
to other staves.
You can also show brackets on noteheads individually.
RELATED LINKS
Changing the input pitch setting on page 174
Caret on page 167
Rhythmic grid on page 166
Extending the caret to multiple staves on page 171
Moving the caret manually on page 171
Adding notes above/below existing notes on page 198
Moving notes rhythmically on page 901
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Creating cross-staff beams on page 672
Per-flow notation options for beam grouping on page 665
Beam grouping according to meters on page 665
Note and rest grouping on page 681
Creating custom beat groupings for meters on page 682
Implicit vs. explicit rests on page 1107
Ties on page 1219
Key signatures on page 839
View types on page 53
Arranging tools on page 336
Playing/Muting notes during note input/selection on page 328
Changing the allocated string for notes on tablature on page 1190
Inputting rests on page 190
Disabling MIDI input devices on page 210
Bracketed noteheads on page 906

Register selection during note input
Dorico Pro automatically selects the register of pitches during note input, but you can override
this and select the register manually.
During note input, Dorico Pro automatically selects the note whose register is the smallest
interval away from the previously input note. For example, if you input an F and then press A , an
A is input a third above the F, rather than a sixth below.
You can override this automatic register selection in the following ways:
●

To input a note above the previously input note, press Shift-Alt/Opt as well as the letter for
the note, for example, Shift-Alt/Opt-A .

●

To input a note below the previously input note, press Ctrl-Alt (Windows) or Ctrl (macOS)
as well as the letter for the note, for example, Ctrl-Alt-A (Windows) or Ctrl-A (macOS) .

Register selection when inputting chords
During chord input, Dorico Pro automatically inputs notes above the highest note at the caret
position. For example, if you press A then E then A , a chord of A-E-A is input at the caret
position.
You can input notes below the lowest note at the caret position instead by pressing CtrlAlt (Windows) or Ctrl (macOS) as well as the letter for the note name, for example, Ctrl-AltA (Windows) or Ctrl-A (macOS) .
RELATED LINKS
Inputting notes on page 172
Inputting chords on page 194
Changing the pitch of individual notes on page 200

Changing the input pitch setting
You can input and record notes at either sounding pitch or written pitch according to the current
layout, for example, if you want to record notes at their sounding pitch in transposing part
layouts.
In concert pitch layouts, written pitch and sounding pitch are the same.
PROCEDURE
●

Choose one of the following input pitch settings:
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●

To input/record notes at their written pitch, choose Write > Input Pitch > Written Pitch.

●

To input/record notes at their sounding pitch, choose Write > Input Pitch > Sounding
Pitch.

RESULT
The resulting pitch notated or recorded is changed. For example, if you input a C in a Horn in F
transposing part layout with the input pitch set to Sounding Pitch, the note is written as a G.
RELATED LINKS
Inputting notes on page 172
Inputting notes using MIDI recording on page 204
Making layouts transposing/concert pitch on page 137

Activating/Deactivating mouse input
You can activate/deactivate mouse input, for example, if you only want to input notes using your
computer keyboard or MIDI device. Deactivating mouse input also allows you to click other items
to stop note input.
PROCEDURE
●

In the Notes toolbox, activate/deactivate Select.

RESULT
Mouse input is activated in the current project when Select is deactivated. Mouse input is
deactivated in the current project when Select is activated.
TIP
You can change the default setting for whether mouse input is activated/deactivated by
activating/deactivating Enable note input using the mouse on the Note Input and Editing
page in Preferences.
EXAMPLE

Select when deactivated

Select when activated

RELATED LINKS
Preferences dialog on page 62

Selecting note/rest durations
You can select different durations for notes/rests either from the Notes panel or by using one of
the assigned key commands, both during note input and for existing notes/rests.
PROCEDURE
1.

Optional: If you want to select a note duration not shown in the Notes panel, click the Show/
Hide All Notes disclosure arrows at the top and bottom of the notes list to show more note
durations.

2.

Select a note/rest duration in any of the following ways:
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●

Press the number on your computer keyboard that corresponds to the duration you
want.
For example, press 6 for quarter notes (crotchets). Press smaller numbers for smaller
durations, such as 5 for eighth notes (quavers) or 4 for 16th notes (semiquavers). Press
larger numbers for larger durations, such as 7 for half notes (minims).

●

Click the duration you want in the Notes panel on the left of the window.

RELATED LINKS
Notes panel on page 155
Key commands in Dorico Pro on page 16
Inputting notes on page 172

Changing the duration of notes
You can lengthen/shorten the duration of notes after they have been input.
PROCEDURE
1.

Select the notes whose duration you want to change.
NOTE
If you want to extend a note to the end of the current selection, select both that note and an
item at the rhythmic position to which you want to extend the note.

2.

Change the duration in any of the following ways:
●

Press the key command of the duration you want. For example, press 4 for a 16th note
(semiquaver).

●

Click the duration you want in the Notes panel on the left of the window.

●

To lengthen notes by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten notes by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .

●

To double the length of notes, press Ctrl/Cmd-Shift-Alt/Opt-Right Arrow .

●

To halve the length of notes, press Ctrl/Cmd-Shift-Alt/Opt-Left Arrow .

●

To lengthen notes by the current rhythmic grid resolution, choose Write > Edit
Duration > Lengthen Duration by Grid Value.

●

To shorten notes by the current rhythmic grid resolution, choose Write > Edit
Duration > Shorten Duration by Grid Value.

●

To double the length of notes, choose Write > Edit Duration > Lengthen Duration.

●

To halve the length of notes, choose Write > Edit Duration > Shorten Duration.

●

To lengthen notes up to the next existing note in their voice, choose Write > Edit
Duration > Extend to Next Note.
NOTE
This does not apply to grace notes.

●

To lengthen a single note up to the rhythmic position of the end of the current selection,
choose Write > Edit Duration > Extend to End of Selection.

●

To shorten overlapping notes in the same voice so that they no longer overlap, choose
Write > Edit Duration > Shorten to Next Note.
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RESULT
The duration of the selected notes is changed. Dorico Pro automatically notates and beams the
notes appropriately according to their new duration, the current time signature, and their
position in the bar.
When extending notes, their duration fills in any intervening rests. Extending notes to the end of
the current selection does not delete any intervening notes, instead they combine with the
extended note to create chords where necessary.
TIP
You can assign your own key commands to lengthen/shorten notes by specific durations and to
extend them. You can find these by searching for Shorten duration by, Lengthen duration by,
and Extend to on the Key Commands page in Preferences.

Forcing the duration of notes/rests
Dorico Pro automatically notates and beams notes/rests appropriately according to the current
time signature and their position in the bar. You can force the duration of notes/rests to specify
their notation.
For example, if you input a half note at the start of a 6/8 bar, it is notated as a dotted quarter
note (crotchet) tied to an eighth note (quaver). This is because, according to convention, 6/8 bars
are subdivided into two groups of three eighth notes. To reflect this for a half note (four eighth
notes), Dorico Pro automatically divides the note to show the correct grouping but you can force
the note duration to show a half note instead.
TIP
If you want to force the duration of all notes on a staff to imply a different meter, for example, to
show three quarter note groups in 6/8 to indicate a hemiola, you can also input a time signature
only on those staves to group notes according to that meter. You can then hide the time
signatures if required.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Selecting existing notes whose duration you want to force.

2.

Optional: If you want input rests with forced durations, press , (comma) to start rest input.

3.

Press O to activate Force Duration.

4.

Select the duration you want.
TIP
When forcing the duration of existing notes notated as tie chains, you must reduce their
duration first, then increase it to the duration you want.

5.

Optional: During note or rest input, input the notes or rests you want.

RESULT
During note or rest input, any notes you input are notated with their whole rhythmic value,
whatever their position in the bar. If you move them later, they keep the same notation. Rests
are input as explicit rests. Notes that cross barlines are notated as tied notes.
Forcing the duration of existing notes or rests preserves their current duration or any duration to
which you subsequently change them.
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TIP
●

Force position and duration in the Notes and Rests group of the Properties panel is
activated automatically for rests input with forced durations. You can also use this property
to force the duration and position of rests.

●

You can change how notes are grouped in different contexts project-wide on the Note
Grouping page in Write > Notation Options.

EXAMPLE

Default notation of notes in 6/8

Notes in the down-stem voice input with forced
durations

RELATED LINKS
Implicit vs. explicit rests on page 1107
Inputting notes on page 172
Inputting rests on page 190
Selecting note/rest durations on page 175
Beam grouping according to meters on page 665
Creating custom beat groupings for meters on page 682
Turning explicit rests into implicit rests on page 1109

Inputting notes with rhythm dots
The Dotted Notes tool allows you to input notes with rhythm dots and add rhythm dots to
existing notes. You can input notes with up to four rhythm dots.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select existing notes to which you want to add rhythm dots.

2.

Optional: If you want to input notes with rhythm dots onto multiple staves at once, extend
the caret to those staves.

3.

Press the number on your computer keyboard that corresponds to the note value you want
to input.
For example, press 5 for eighth notes (quavers), 6 for quarter notes (crotchets), 7 for half
notes (minims), and so on.

4.
5.

Press . (period) to activate Dotted Notes.
Optional: Press Alt/Opt-. (period) to change the number of rhythm dots.
Dotted Notes in the Notes toolbox updates to indicate the current number of rhythm dots.
You can input notes with up to four rhythm dots.

6.

Optional: Press O to activate Force Duration.
If Force Duration is not activated, the notes you input might be shown as tied notes rather
than dotted notes, depending on their position in the bar and the prevailing meter.

7.

Input the dotted notes you want.
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Dotted Notes remains activated until you either select a different note duration or
deactivate it.
8.

Press . again to deactivate Dotted Notes.

9.

Press Esc or Return to stop note input.

RESULT
During note input, notes are input as dotted notes until you deactivate Dotted Notes or change
the note duration.
If you add rhythm dots to multiple existing notes that would then overlap, Dorico Pro adjusts the
duration of notes in the selection to avoid deleting notes at the end of the selection.
EXAMPLE

A phrase containing eighth notes

After adding rhythm dots to the whole selection

RELATED LINKS
Note and rest grouping on page 681
Activating/Deactivating the caret on page 170
Extending the caret to multiple staves on page 171
Inputting notes in Insert mode on page 183

Inputting notes into multiple voices
By default, notes are input into the first up-stem voice, as indicated by the symbol of an up-stem
quarter note beside the caret. You can input notes directly into other voices during note input,
and switch between voices as required.
You can also create new voices on staves with existing notes and input notes into those voices
anywhere else on those staves.
PROCEDURE
1.

In Write mode, select an item on the staff and at the rhythmic position where you want to
input multiple voices.

2.

Press Shift-N to start note input.

3.

Press Shift-V to create a new voice.
When a new voice is added, a + sign appears beside the symbol of a quarter note beside the
caret. The quarter note symbol indicates the stem direction, and the number beside the
quarter note indicates the voice number if applicable.

Caret when adding the first down-stem voice
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4.

Optional: Repeat step 3 as many times as you require.
For example, on a staff containing no notes, creating one new voice allows you to input
notes into the first down-stem voice, but you can also create another new voice immediately
if you want to input notes into the second up-stem voice on the staff.

5.

Input the notes you want.

6.

Optional: Press V to cycle between all the active voices on the staff.

7.

Press Esc or Return to stop note input.

RESULT
Notes are input into new voices, as indicated by the caret symbol. They are input at the caret
position or where you click. If you are inputting notes into a new voice on a staff that already
contains notes in another voice, the stem directions of existing notes at the same rhythmic
position change automatically as necessary.
The quarter note symbol beside the caret changes to indicate which voice is currently selected.
Any notes input are input into the voice indicated by this symbol.
You can switch between voices as often as you like.
NOTE
●

If you have three or more voices on a single staff, you can only cycle through all the voices in
a set order. For example, if you have two up-stem voices and two down-stem voices, the
order is: first up-stem voice, first down-stem voice, second down-stem voice, second up-stem
voice.

●

You can show voice colors to check which notes are in which voice. You can also identify
voices by selecting individual notes and looking at the display in the status bar.

EXAMPLE

Caret when inputting notes into
the first up-stem voice

Caret when inputting notes into
the first down-stem voice

RELATED LINKS
Caret on page 167
Rhythmic grid on page 166
Inputting notes on page 172
Adding notes above/below existing notes on page 198
Voices on page 1294
Divisi on page 1176
Condensing on page 470
Inputting bar rests into specific voices on page 191
Hiding/Showing bar rests in additional voices on page 1112
Status bar on page 52
Hiding/Showing voice colors on page 1295
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Inputting notes into slash voices
You can input notes into multiple slash voices, for example, if you want to indicate a precise
rhythm without specifying pitches. By default, the first slash voice is up-stem, but you can add
extra slash voices both with and without stems, and switch between them as often as you want.
You can also input notes into new slash voices on a staff with existing notes. Once you have
created a slash voice somewhere on a staff, you can input notes into that slash voice anywhere
else on the same staff.
PROCEDURE
1.

In Write mode, select an item on the staff and at the rhythmic position where you want to
input slash voices.

2.

Press Shift-N to start note input.

3.

Press Shift-Alt/Opt-V to create a new slash voice.
When a new slash voice is added, a + sign appears beside the symbol of a note beside the
caret, which now appears as a slash note. The slash note symbol indicates the stem
direction, and the number beside the slash note symbol indicates the voice number if
applicable.

Caret when adding the first
down-stem slash voice

4.

Caret when adding the first
stemless slash voice

Caret when adding the second
up-stem slash voice

Optional: Repeat step 3 as many times as you require.
For example, on a staff containing no notes in slash voices, creating one new slash voice
allows you to input notes into the first up-stem slash voice. You can also create a second new
slash voice immediately if you want to input notes into a down-stem slash voice, or a third
new slash voice if you want to input notes into a stemless slash voice.

5.

Input the notes you want.
Notes in slash voices appear at the same staff position, regardless of their pitch. By default,
this is the middle line of the staff, but this changes in multiple-slash-voice contexts.

6.

Optional: Press V to cycle between all the active voices on the staff.

7.

Press Esc or Return to stop note input.

RESULT
Notes are input into new slash voices, as indicated by the caret symbol. The slash note symbol
beside the caret changes to indicate which voice is currently selected and into which notes are
input.
You can switch between voices as often as you like.
NOTE
●

If you are inputting notes into a new slash voice on a staff that already contains notes in
other voices/slash voices, the stem directions of existing notes and the staff positions of
slash voices at the same rhythmic position change automatically as necessary.

●

If you have three or more voices of any type on a single staff, you must cycle through all the
voices in a set order. For example, if you have two up-stem voices, two down-stem voices,
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and a slash voice, the order is: first up-stem voice, first down-stem voice, second down-stem
voice, second up-stem voice, slash voice.
EXAMPLE

Caret when inputting notes into
the first up-stem slash voice

Caret when inputting notes into
the first down-stem slash voice

Caret when inputting notes into a
new, second up-stem slash voice

RELATED LINKS
Slash voices on page 1299
Rhythm slashes on page 1095
Inputting slash regions on page 311

Inputting notes and notations onto multiple staves
You can input notes and notations onto multiple staves simultaneously, including automatically
exploding the notes in chords that you play on a MIDI keyboard onto the appropriate staves. For
example, if you want to input notes onto both piano staves or input the same dynamics for
multiple instruments.
Inputting notes and notations onto multiple staves is most useful for multiple adjacent pitched
instruments whose music is only a single voice.
PREREQUISITE
If you want to explode individual notes in chords onto multiple staves during note input, you
have connected a MIDI keyboard. You can only input the different notes in chords onto separate
staves when using a MIDI keyboard.
PROCEDURE
1.

In Write mode, select an item at the rhythmic position where you want to input notes/
notations onto multiple staves.

2.

Press Shift-N to start note input.

3.

Extend the caret to another staff in any of the following ways:
●

To extend to the staff above, press Shift-Up Arrow .

●

To extend to the staff below, press Shift-Down Arrow .

4.

Optional: Repeat step 3 for as many staves as you require.

5.

Input the notes and notations you want.
NOTE
You must input notes using a computer keyboard or MIDI keyboard. If you use the mouse,
notes are only input on the staff you click. Similarly, you must use the corresponding
popover to input notations on multiple staves. When inputting notations using the
corresponding panel, they are only input on the top staff.
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6.

Press Esc or Return to stop note input.

RESULT
The notes and notations you input are input at the caret position on all staves across which the
caret extends. If the caret extends across both staves of a piano, notes are input on either the
top or bottom staff according to their pitch and your set split point on the Play page in
Preferences.
When inputting notes using a MIDI keyboard, the individual notes in any chords you input are
automatically exploded across the staves.
TIP
You can change whether notes in chords are exploded onto multiple staves or all notes are input
onto all staves on the MIDI Input page in Write > Note Input Options

RELATED LINKS
Caret on page 167
Inputting notes on page 172
Inputting chords on page 194
Notations input on page 210
Preferences dialog on page 62
Note Input Options dialog on page 162
Exploding music onto multiple staves on page 340

Inputting notes in Insert mode
In Insert mode, you can input notes before existing notes without overriding them. This allows
you to push existing notes ahead at the same time as inputting new notes at their previous
positions.
NOTE
You cannot input chords in Insert mode.

PROCEDURE
1.

In Write mode, start note input.

2.

Optional: If you want to input notes in Insert mode onto multiple staves at once, extend the
caret to those staves.

3.

Press the number on your computer keyboard that corresponds to the note value you want
to input.
For example, press 5 for eighth notes (quavers), 6 for quarter notes (crotchets), 7 for half
notes (minims), and so on.

4.

Press I to activate Insert mode.
In Insert mode, the caret shows V and inverted V shapes at the top and bottom.

5.

Input the pitches you want in any of the following ways:
●

Press the corresponding letters on your keyboard.
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●

Click the staff at the rhythmic positions where you want to input notes.
A shadow notehead appears when inputting with the mouse to indicate where the note
will be input.

●

Play the notes on a MIDI keyboard.

6.

Optional: Press I again to deactivate Insert mode and return to normal note input.

7.

Press Esc or Return to stop note input.

RESULT
Notes are inserted before existing notes at the caret position or where you click, without
overriding any existing notes at rhythmic positions after the caret. Any existing notes after the
caret are pushed ahead to subsequent rhythmic positions.
RELATED LINKS
Caret on page 167
Rhythmic grid on page 166
Inputting chords on page 194

Inputting notes in percussion kits
You can input notes on all percussion instruments in percussion kits using any presentation type.
When inputting notes in percussion kits, the caret is smaller than when inputting notes on
pitched instrument staves.
Instead of occupying the whole height of the staff, the caret in percussion kits is positioned at a
particular staff position.
The name of the percussion instrument or slash voice currently selected by the caret, and any
applicable playing technique, is shown directly above the rhythmic grid display.
NOTE
You can only input notes into slash voices in percussion kits when using the five-line staff
presentation.

Inputting notes on instruments with five-line staff kit presentation

PREREQUISITE
If you want to use additional playing techniques for instruments in the kit, you have defined
these in the Percussion Instrument Playing Techniques dialog.
PROCEDURE
1.

In Write mode, select an item in the percussion kit and at the rhythmic position where you
want to input notes.

2.

Press Shift-N to start note input.

3.

Move the caret up/down to input notes on different instruments in any of the following ways:
●

Press Up Arrow to move it up.

●

Press Down Arrow to move it down.
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4.

Select an appropriate playing technique for the instrument currently selected by the caret
before inputting notes.
●

Press Shift-Alt/Opt-Up Arrow to cycle upwards through playing techniques.

●

Press Shift-Alt/Opt-Down Arrow to cycle downwards through playing techniques.

●

Play the pitch for the playing technique you want on a MIDI keyboard.
NOTE
You can define MIDI pitches for playing techniques on the Note Input and Editing page
in Preferences.

5.

Input notes in one of the following ways:
●

Five-line staff presentation type: Press letters on a computer keyboard or play notes on a
MIDI keyboard, corresponding to staff positions for the clef set in Preferences. For
example, press B to input notes for the instrument assigned to the middle line of a fiveline staff when Treble G clef is set.

●

Grid and single-line instruments presentation types: Press the letter of any note name A
to G on a computer keyboard or play any note on a MIDI keyboard to input notes for
the instrument on whose line the caret is currently positioned.
NOTE
Notes played on MIDI keyboards are interpreted differently, depending on whether Use
percussion map or Use staff position is set for the different kit presentation types in
the Note Input section of the Note Input and Editing page in Preferences.

6.

●

Any kit presentation type: Press Y to input notes for the instrument and playing
technique shown above the rhythmic grid.

●

Any kit presentation type: Click on the staff where you want to input notes, and at the
rhythmic positions where you want them.

Press Esc or Return to stop note input.

RELATED LINKS
Caret on page 167
Percussion kits and drum sets on page 1276
Note input setup for percussion kits on page 185
Percussion Instrument Playing Techniques dialog on page 1283
Changing the playing techniques of notes on percussion kit staves on page 1278
Preferences dialog on page 62

Note input setup for percussion kits
Inputting music for unpitched percussion instruments works differently than for pitched
instruments. You can use any of the usual methods for unpitched percussion input, but using a
MIDI keyboard or a computer keyboard is most efficient.
●

You can find options relating to note input for percussion in the Note Input section of the
Note Input and Editing page in Preferences.

There is one set of options for input onto five-line staves, and another set of options for input
onto grids and individual instruments.
The main choice affects input via MIDI keyboards and computer keyboards.
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Use percussion map
A percussion map defines which MIDI notes produce which sound for a particular
patch in a sound library. For example, in General MIDI percussion, C2 (note 36)
produces bass drum, and D2 (note 38) produces snare drum, and so on.
If you know a particular mapping well, you may find it helpful to use the mapping
directly for input.
Use staff position
This option uses the staff position defined in the Edit Percussion Kit dialog. For
example, on a drum set, the bass drum is normally positioned in the bottom space of
the staff, while the snare drum is positioned in the third space from the bottom.
You can think of staff positions relative to what they would be when using a treble G
clef (F4 and C5 respectively) or using a bass F clef (A2 and E3 respectively).
You can choose which clef is used to interpret staff positions for five-line staves:
●

Treble G clef

●

Bass F clef

When you select Use staff position, you can designate one octave of your MIDI keyboard to
input playing techniques.
By default, the Input techniques from MIDI key option is set to MIDI note 48, which is C3, the C
one octave below middle C (C4 = MIDI note 60). You can click the MIDI learn button and then play
a note on your MIDI keyboard to change the starting pitch. Assuming a starting pitch of C3,
ascending notes operate as follows:
●

C3 (48): Previous playing technique

●

C♯3 (49): Next playing technique

●

D3 (50): First mapped playing technique

●

E♭3 (51): Second mapped playing technique

●

E3 (52): Third mapped playing technique

And so on, up to:
●

B3 (59): Tenth mapped playing technique

In general, we recommend that you set Use staff position for percussion input. Use percussion
map is normally only useful when you are inputting notes onto a drum set and you have already
memorized the General MIDI percussion map.
RELATED LINKS
Preferences dialog on page 62
Edit Percussion Kit dialog on page 120
Inputting notes in percussion kits on page 184
Changing the playing techniques of notes on percussion kit staves on page 1278

Default note selection during note input for percussion kits
During note input in percussion kits, you can press the letters on a computer keyboard that
correspond to staff positions for kits using the five-line staff presentation type. For example, you
can press F to input a note on the F space or line.
In Preferences, you can set options for inputting notes into percussion kits in the Note Input
section of the Note Input and Editing page. For example, if you want to use staff positions to
determine notes, choose Use staff position for Input onto kit or grid.
If you have the staff positions set relative to Treble G clef, then F could mean either the bottom
space on the staff or the top line on the staff. In a standard drum set, this means either the kick
drum in the bottom space, or the ride cymbal on the top line.

186
Dorico Pro 3.1.10

Write mode
Note input
When inputting notes in pitched instruments, Dorico Pro chooses the lower or upper possible
staff position based on which is closer to the current position of the caret.
However, when inputting notes in percussion kits, Dorico Pro chooses the staff position of the
note with the same stem direction as the last input note, rather than the staff position that is
closest to the current position of the caret. This makes it easier to input common note patterns
used in percussion kits.
For example, inputting kick drum and snare drum notes on a standard drum set is a common
pattern. The kick drum is in the bottom space, and the snare drum is two spaces above: five staff
positions away from the bottom space, and four staff positions away from the top line.
You can press F for the kick drum and C for the snare drum.
The default stem direction behavior for inputting notes in kits in Dorico Pro means that you can
alternate pressing F and C , and the notes are input at the positions of the kick drum and snare
drum, even though the top line is the closer position after inputting a snare drum note.
This is because the kick drum uses the same stem direction, and therefore voice, as the snare
drum.

NOTE
Dorico Pro automatically changes the directions of stems according to the positions of notes on
the staff when only one voice on the staff contains notes, regardless of their voice.

RELATED LINKS
Preferences dialog on page 62
Stem direction on page 1196

Inputting notes on tablature
You can input notes directly into tablature in the same ways as inputting normal notes. When
inputting notes on tablature, the caret is smaller than when inputting notes on standard five-line
staves and behaves as if chord input is always active, meaning you must advance the caret
manually to input notes at other rhythmic positions.
PROCEDURE
1.

In Write mode, select an item on the tablature and at the rhythmic position where you want
to input notes.
NOTE
If both notation staves and tablature are shown in the current layout, you must select an
item on the notation staff and then move the caret to the tablature after starting note input.

2.

Press Shift-N to start note input.

3.

Select a note value in any of the following ways:

4.

●

To select the next longer note value, press = .

●

To select the next shorter note value, press - .

●

Click the note value you want in the Notes panel on the left of the window.

Input the pitch you want for the current string in any of the following ways:
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●

Press the number on your computer keyboard or numeric keypad that corresponds to
the fret number you want. For example, press 6 for fret 6.
For fret numbers 10 and above, press the two digits quickly.

●

Press the corresponding letters on your computer keyboard.
NOTE
When using letters, Dorico Pro automatically chooses the octave closest to the nut on
the corresponding string.

●
5.

6.

Play the note on a MIDI keyboard.

Move the caret up/down to input notes on different strings at the same rhythmic position in
any of the following ways:
●

Press Up Arrow to move it up.

●

Press Down Arrow to move it down.

Move the caret to other rhythmic positions in any of the following ways:
●

To move the caret according to the current rhythmic grid resolution, press
Right Arrow / Left Arrow .

●

To advance the caret according to the note value currently selected, press Space .

●

To move the caret to the next/previous bar, press Ctrl/Cmd-Right Arrow / Ctrl/CmdLeft Arrow .

RESULT
Notes are input at the caret position with the selected duration on the string indicated by the
caret and are played back as you input them by default. Notes continue to be input at the caret
position until you move the caret manually and overwrite any previous note on the same string.
If you attempt to input a note that is impossible on the current string, it is input on the closest
available string in addition to any existing notes.
If you have input two or more notes on the same string at the same rhythmic position, they are
shown next to each other on tablature and are colored green. You can then select them
individually and change their string allocation.
RELATED LINKS
Caret on page 167
Moving the caret manually on page 171
Tablature on page 1188
Hiding/Showing notation staves and tablature on page 1189
Hiding/Showing enclosures around notes on tablature on page 1192
Changing the allocated string for notes on tablature on page 1190

Inputting accidentals
You can input accidentals during note input and by adding them to existing notes. You can also
change the accidentals of existing notes.
NOTE
Accidentals that are part of the prevailing key signature are input automatically. For example, if
you press F in G major, an F♯ is input automatically. You would only need to specify an accidental
if you want to input an F♮, for example.
This also applies if you are using a MIDI keyboard, though you can respell notes if the accidentals
chosen automatically are not the ones that you expected.
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PREREQUISITE
You have created any custom accidentals, in custom tonality systems if required, that you want to
input.
PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select the existing notes to which you want to add accidentals or whose accidentals you
want to change.

Select the accidental you want to input in one of the following ways:
●

Press - for flat.

●

Press = for sharp.

●

Press 0 for natural.

●

Click the accidental you want in the Notes panel.

TIP
You can find uncommon accidentals, such as double sharps and flats, or microtonal
accidentals, in the Accidentals section of the Key Signatures, Tonality Systems, and
Accidentals panel on the right of the window.
3.

Optional: During note input, enter the note you want with your selected accidental.

RESULT
The accidental is added to the selected existing notes. If you selected existing notes with
different accidentals, they are changed to have the accidental you selected.
During note input, the selected accidental is only input on the next note you input. You must
reselect the accidental for each subsequent note.
NOTE
●

Depending on the accidental duration system in place, subsequent accidentals for the same
note in the same register might not appear in the same bar.

●

If you input notes using a MIDI device, Dorico Pro automatically shows an accidental if
necessary. It selects a sharp, flat, or natural based on key signature and context. You can
later respell notes so they are shown as their enharmonic equivalents with different
accidentals.

RELATED LINKS
Accidentals on page 613
Inputting notes on page 172
Changing the pitch of individual notes on page 200
Custom tonality systems on page 851
Creating/Editing custom accidentals on page 853
Creating custom tonality systems on page 851
Respelling notes on page 200
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Accidental selection during MIDI input
Dorico Pro interprets MIDI data to create accidentals, and automatically determines the spelling
of notes according to preset rules.
Dorico Pro automatically displays an accidental if one is required. It selects a sharp or flat based
on key signature and context.
The algorithm for this takes into account the key signature and the intervals between successive
notes and chords. Therefore Dorico Pro prefers sharp accidentals in a key with sharps, and flats
in a key with flats. If you change the spelling of an accidental, Dorico Pro follows your spelling
preference whenever that note is used again in the score.
If you input notes with accidentals outside the key signature, Dorico Pro uses sharps if the figure
is rising, and flats if it is falling. The spelling is also calculated vertically, meaning a simpler
interval is produced where possible, such as a major third rather than a diminished fourth.
By default, Dorico Pro makes retrospective changes to how it has spelled accidentals, depending
on how your music develops. For example, in C major, if you input a sequence of pitches C-E-G♯,
but then input a G♭, the G♯ is respelled as an A♭.
You can disable this setting.
RELATED LINKS
Respelling notes on page 200

Disabling automatic accidental respelling
You can turn off the automatic respelling of accidentals to prevent Dorico Pro from making
retrospective changes to accidentals.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-I to open Note Input Options.

2.

Click MIDI Input in the page list.

3.

Deactivate Allow spelling of notes to be adjusted retrospectively.

4.

Click Apply, then Close.

Inputting rests
Dorico Pro automatically shows rests as appropriate in the gaps between the notes you input.
However, you can also input rests manually, for example, to show fermatas on specific beats for
players without notes in that bar.
PROCEDURE
1.

Select an item on the staff and at the rhythmic position where you want to input rests.

2.

Press Shift-N to start note input.

3.

Optional: If you want to input rests onto multiple staves at once, extend the caret to those
staves.

4.

Press , (comma) to start rest input.

5.

Select the duration you want.

6.

Press O to activate Force Duration.

7.

Input rests in any of the following ways:
●

Press Y or any of the letters from A to G .

●

Play notes on a MIDI keyboard.
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8.

Optional: Press , (comma) again to stop rest input.

9.

Press Esc or Return to stop note input.

RESULT
Rests of the selected duration are input. If Force Duration is not activated, Dorico Pro
automatically combines adjacent rests as appropriate for their position in relation to notes and
according to the current meter.
RELATED LINKS
Rests on page 1106
Implicit vs. explicit rests on page 1107
Extending the caret to multiple staves on page 171
Selecting note/rest durations on page 175
Forcing the duration of notes/rests on page 177
Inputting notes on page 172

Inputting bar rests into specific voices
When inputting music in multiple voices, rests are normally created automatically when there is a
gap in the secondary voice. However, if you want secondary voices to begin with explicit bar rests
in strict contrapuntal music, you can input a bar rest into those voices.
For music in a single voice, you do not have to input bar rests as they appear in each new bar
automatically when you advance the care. You can also hide/show bar rests in all empty bars in
each layout independently.
PROCEDURE
1.

In Write mode, start note input.

2.

Select the appropriate secondary voice by pressing V until the voice direction indicator
shows the correct voice.
Alternatively, if you want to input bar rests into a new voice, press Shift-V until the voice
direction indicator shows the correct voice.

3.

Press Shift-B to open the bars and barlines popover.

4.

Enter rest into the popover to add a bar rest.

5.

Press Return to close the popover.

6.

Press Ctrl/Cmd-Right Arrow to advance the caret to the start of the next bar after the bar
rest.

7.

Optional: If you want to show bar rests in multiple bars for the selected voice, repeat steps 3
to 6 as many times as required.
TIP
If your notation options are set to show bar rests in additional voices, bar rests appear in all
subsequent empty bars for the selected voice after you have input one bar rest.

RESULT
Bar rests are input into the selected voice at the caret position. If the caret position is within a bar
that contains notes for the selected voice, these notes are replaced by the bar rest.
NOTE
Alternatively, you can click Insert Bar Rest in the Insert Bar Rest section of the Bars and
Barlines panel to input bar rests during note input.
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RELATED LINKS
Bars on page 631
Rests on page 1106
Bars and barlines popover on page 235
Inputting notes into multiple voices on page 179
Caret on page 167
Hiding/Showing bar rests in empty bars on page 1111
Hiding/Showing bar rests in additional voices on page 1112

Inputting ties
Dorico Pro automatically creates ties as required for note durations in each meter. However, you
can input ties manually to join two notes of the same pitch, both during note input and by joining
two existing notes with a tie.
For example, if you want to input a tie between two quarter notes across a barline, you can input
a half note at the rhythmic position where you want to input the first quarter note. Dorico Pro
automatically splits the half note into two quarter notes, one on each side of the barline, and
joins them with a tie.
NOTE
These steps do not apply to inputting ties between non-adjacent notes or notes in different
voices, for example, between two notes of the same pitch on different staves, or between a grace
note and a normal note.
PREREQUISITE
If you want to preserve the durations of existing notes, you have forced their duration. For
example, if you want to specify subdivisions within a tie chain that are different than the
prevailing meter.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select the note from which you want the tie to start.

2.

Optional: During note input, input the note that you want at the start of the tie.

3.

Press T to input ties.

4.

Optional: During note input, input the note that you want at the end of the tie.
NOTE
The second note must be the same pitch as the first note.

RESULT
During note input, the two notes input are joined by a tie.
When inputting ties between existing notes, the selected note is joined by a tie to the next note
of the same pitch in the same voice and staff.
NOTE
●

During note input, Dorico Pro ties the first note you input after inputting the tie to the
previous note of the same pitch in the same voice and staff, even if there are other notes of
other pitches between them.
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●

Depending on the current time signature, the position of the start of the note in the bar, and
your settings on the Note Grouping page in Write > Notation Options, inputting a tie
between two notes can instead create a single note of a different duration, such as a half
note instead of two tied quarter notes. You can override your note grouping settings and fix
your notated rhythm by forcing their duration. Dorico Pro then notates your input notes with
the rhythmic durations specified, as long as they can fit inside the bar.

RELATED LINKS
Forcing the duration of notes/rests on page 177
Ties on page 1219
Note and rest grouping on page 681
Beam grouping according to meters on page 665
Ties vs. slurs on page 1222
Inputting ties between non-adjacent notes on page 1224

Inputting grace notes
You input grace notes in the same ways as normal notes, and they can have any rhythmic note
value, accidental, and articulation. You can only input grace notes during note input.
PROCEDURE
1.

Select an item on the staff and at the rhythmic position where you want to input grace notes.

2.

Press Shift-N to start note input.

3.

Optional: If you want to input grace notes onto multiple staves at once, extend the caret to
those staves.

4.

Press / to start grace note input.

5.

Press the number for the rhythmic duration you want. For example, press 5 for eighth grace
notes.

6.

Optional: Press Alt/Opt-/ to switch between inputting slashed/unslashed grace notes.

The Grace Notes toolbox button when inputting unslashed grace notes.

7.

Input the grace notes you want.

8.

Press / again to stop grace note input and return to normal note input.

RESULT
The pitches you enter are input as grace notes at the caret position.
If you are inputting grace notes after previously inputting normal notes, the rhythmic duration of
the grace notes is the same as the last input normal note. You can change the rhythmic duration
in the same way as for normal notes.
There is no limit to the number of grace notes that can exist at the same rhythmic position.
TIP
You can also change the type of grace notes after they have been input.

RELATED LINKS
Grace notes on page 825
Extending the caret to multiple staves on page 171
Inputting notes on page 172
Inputting accidentals on page 188
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Inputting articulations on page 210
Changing the type of grace notes on page 828

Inputting chords
You can input chords during note input when both note input and Chords are activated. You can
input notes with a computer keyboard, with the mouse, or by playing notes with a MIDI
keyboard.
NOTE
You cannot input chords in Insert mode.

PROCEDURE
1.

Select an item on the staff and at the rhythmic position where you want to input chords.

2.

Press Shift-N to start note input.

3.

Optional: If you want to input chords onto multiple staves at once, extend the caret to those
staves.

4.

Press the number on your computer keyboard that corresponds to the note value you want
to input.
For example, press 5 for eighth notes (quavers), 6 for quarter notes (crotchets), 7 for half
notes (minims), and so on.

5.

Press Q to start chord input.
In chord input, a + sign appears at the top of the caret. This allows you to input multiple
notes at the caret position.

6.

Input the pitches you want in any of the following ways:
●

Press the corresponding letters on your keyboard.
TIP
Dorico Pro automatically inputs notes above the highest note at the caret position when
Chords is activated.
You can input notes below the lowest note at the caret position instead by pressing CtrlAlt (Windows) or Ctrl (macOS) as well as the letter for the note name, for example,
Ctrl-Alt-A (Windows) or Ctrl-A (macOS) .

●

Click the staff at the rhythmic positions where you want to input notes.
A shadow notehead appears when inputting with the mouse to indicate where the note
will be input.

●
7.

Play the notes on a MIDI keyboard.

Optional: Advance the caret to input chords at other rhythmic positions.
During chord input, notes are input at the same rhythmic position and above the previous
note until you advance the caret manually.

8.

Press Q again to stop chord input.
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RESULT
Multiple notes are input at the caret position.
●

If entering pitches by clicking with the mouse, you can put the same pitch into the chord
twice by clicking again on the same line.

●

If entering pitches with the keyboard, repeated notes are automatically input an octave
above. You can change the register of notes by forcing the register selection during note
input, or by transposing them after they have been input.

NOTE
●

You can stop chord input and immediately continue inputting notes as before, with a single
note at each rhythmic position and the caret advancing automatically to the next rhythmic
position.

●

When chords contain two pitches in the same register but with different accidentals, that is
known as an altered unison. Altered unisons are shown with either single stems or with split
stems, depending on your settings on the Accidentals page in Write > Notation Options.

RELATED LINKS
Register selection during note input on page 174
Extending the caret to multiple staves on page 171
Moving the caret manually on page 171
Altered unisons on page 617

Inputting tuplets
You can input all types of tuplets using the tuplets popover. Tuplets are input like normal notes,
and so can only be input during note input.
You can also input triplets by clicking Tuplets in the Notes toolbox. However, you can only input
one triplet at a time this way.
PROCEDURE
1.

Select an item on the staff and at the rhythmic position where you want to input tuplets.

2.

Press Shift-N to start note input.

3.

Optional: If you want to input tuplets onto multiple staves at once, extend the caret to those
staves.

4.

Press the number on your computer keyboard that corresponds to the note value on which
you want to base your tuplet.
For example, press 5 for eighth notes (quavers), 6 for quarter notes (crotchets), 7 for half
notes (minims), and so on.

5.

Press ; to open the tuplets popover.

6.

Enter the tuplet you want into the popover as a ratio. For example, enter 3:2 to input triplets.

7.

Press Return to close the popover.
The tuplet is entered.

8.

Optional: Change the selected note duration.
For example, you can input a tuplet based on eighth notes but input a quarter note within
that tuplet.

9.

Enter or play in the pitches you want.

10. Optional: Press Space to advance the caret to continue inputting tuplets of the same ratio at
later rhythmic positions.
11. Stop tuplet input in any of the following ways:
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●

To return to inputting normal notes, press : or move the caret with the arrow keys.

●

To stop note input completely, press Esc .

RESULT
The pitches you enter or play in are input as tuplets, starting from the caret position.
If you want to input a different type of tuplet immediately after inputting tuplets, you must stop
the first type of tuplet before inputting the second type. If you do not stop the first type, the
second type is input as a nested tuplet.
RELATED LINKS
Tuplets on page 1261
Nested tuplets on page 1262
Inputting notes on page 172
Extending the caret to multiple staves on page 171

Tuplets popover
The table contains examples of what you can enter into the tuplets popover to input different
types of tuplets. The tuplets popover can only be opened during note input.
You can open the tuplets popover during note input in Write mode in any of the following ways:
●

Press ; .
As tuplets are often described in ratios, such as 3:2, the tuplets popover uses the semicolon
key to be memorable.

●

Choose Write > Create Tuplet.

The icon on the left-hand side of the popover matches the corresponding button in the Notes
toolbox on the right of the window.

Tuplets button in the Notes toolbox
Tuplets popover with an example entry

NOTE
Clicking Tuplets in the Notes toolbox only inputs a single triplet. It does not open the tuplets
popover.
When inputting tuplets with the keyboard, Dorico Pro continues inputting notes as the specified
tuplet until any of the following happens:
●

You press : to return to inputting normal notes.

●

You move the caret with the arrow keys.

●

You stop note input.

Type of tuplet

Popover entry

Triplet, three notes in the space of two.

3 or 3:2

Triplet, three notes in the space of four.

3:4
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Type of tuplet

Popover entry

Quintuplet, five notes in the space of four.

5:4

Quintuplet, five notes in the space of two.

5:2

Septuplet, seven notes in the space of four.

7:4

Septuplet, seven notes in the space of two.

7:2

Duplet, two notes in the space of three. Often
used in compound meters.

2:3

Quintuplet, five notes in the space of six. Often 5:6
used in compound meters.
64th note beat unit in tuplet

z or 2

32nd note beat unit in tuplet

y or 3

16th note beat unit in tuplet

x or 4

Eighth note beat unit in tuplet

e or 5

Quarter note beat unit in tuplet

q or 6

Half note beat unit in tuplet

h or 7

Whole note beat unit in tuplet

w or 8

Double whole note beat unit in tuplet

2w or 9

Dotted eighth note beat unit in tuplet

e. or 5.

Dotted quarter note beat unit in tuplet

q. or 6.

Quintuplet, five dotted quarter notes in the
space of four.

5:4q. or 5:4-6.

NOTE
You must separate the tuplet ratio from the
beat unit using a space or hyphen when using
a number to specify the beat unit.

NOTE
Unless you specify a beat unit in your entry, the total duration of the tuplet depends on the note
value selected when you open the popover. For example, if a quarter note is selected when you
input a triplet, the triplet input is three quarter notes in the space of two.
This list is not comprehensive. It is intended to illustrate how you can structure your entry to
input different tuplets.
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RELATED LINKS
Inputting tuplets on page 195
Tuplets on page 1261
Turning existing notes into tuplets on page 1263
Selecting note/rest durations on page 175

Adding notes above/below existing notes
You can add notes above/below existing notes. You can add multiple notes at the same time,
according to their intervals relative to the existing notes.
PROCEDURE
1.

Select the notes to which you want to add notes.

2.

Press Shift-I to open the add intervals popover.

3.

Enter the intervals of the notes you want, relative to your selected notes. For example, enter
-m3,4 to add notes a minor third below and a fourth above the selected notes.

4.

Press Return to close the popover.

RESULT
Notes are added to the selected notes according to the intervals you entered into the add
intervals popover.
RELATED LINKS
Changing the pitch of individual notes on page 200

Add intervals popover
The add intervals popover allows you to add notes above and below existing notes, and also
transpose existing notes. It makes much of the functionality provided by the Add Notes Above
or Below and Transpose dialogs accessible directly via the keyboard.
You can open the add intervals popover in Write mode in any of the following ways when notes
are selected, including during note input:
●

Press Shift-I .

●

Choose Write > Add Intervals Popover.

The table contains examples of what you can enter into the add intervals popover to transpose
notes or add notes to existing notes.

Example action

Popover entry

Transpose notes upwards by a third.

t3

Transpose notes downwards by a sixth.

t-6

Add notes a third above.

3 or 3rd

Add notes a fourth below.

-4 or -4th
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Example action

Popover entry

Add multiple notes

3,6 or -3,3,4

NOTE
Separate notes with commas, not with spaces.

Add notes above and/or below all notes in
selected chords.

3 all or -M2,m3 to all

NOTE
Separate notes with commas, not with spaces.

Add notes only to the top notes in chords.

-3 top or dim5 top

Add notes only to the bottom notes in chords.

aug4 bottom or -2 bottom

Specify perfect interval.

p, per, or perf

Specify major interval.

M, maj, or major

Specify minor interval.

m, min, or minor

Specify diminished interval.

d, dim, or diminished

Specify augmented interval.

a, aug, or augmented

Specify diatonic interval.

diat or diatonic

Transpose notes by microtonal intervals.

t 3 8 qt

NOTE
The first number is the interval degree.
The second number is the number of quarter
tones.

If you do not otherwise specify it, the interval is calculated by adding or transposing notes by the
number of staff positions specified. For example, in C major, if the selected note is a D♮ and you
specify 3 to add a third above, the added note is an F♮. You can specify the quality of the interval
by including it before the interval.
If the selected material already includes chords, notes are added above the top note in the chord,
and added below the bottom note in the chord. You can add notes to all notes in selected chords
by including all or to all at the end of your entry.
For microtonal transpositions, the first number is the interval degree, and the second number is
the number of quarter tones. For example, if you have a C natural and you enter T 3 8 qt, it
changes to an E natural.
RELATED LINKS
Transposing existing notes with the add intervals popover on page 201

199
Dorico Pro 3.1.10

Write mode
Note input

Changing the pitch of individual notes
You can change the pitch and register of individual notes, including grace notes, after they have
been input by octave divisions, by staff position, and by octaves.
PROCEDURE
1.

In Write mode, select the notes whose pitches you want to change.

2.

Raise/Lower the pitches of the selected notes in any of the following ways:
●

To move notes up one staff position, such as from C to D, press Alt/Opt-Up Arrow .

●

To move notes down one staff position, such as from D to C, press Alt/OptDown Arrow .

●

To transpose notes up a single octave division, such as a semitone in 12-EDO or a
quarter tone in 24-EDO, press Shift-Alt/Opt-Up Arrow .

●

To transpose notes down a single octave division, such as a semitone in 12-EDO or a
quarter tone in 24-EDO, press Shift-Alt/Opt-Down Arrow .

●

To transpose notes up an octave, press Ctrl/Cmd-Alt/Opt-Up Arrow .

●

To transpose notes down an octave, press Ctrl/Cmd-Alt/Opt-Down Arrow .

RESULT
The pitch or register of the selected notes is changed.
If the pitch is now impossible to play on a fretted instrument, such as if a note would have to be
played below the nut on the lowest string, it appears on tablature as a question mark.
NOTE
You can press Alt/Opt-Up Arrow and Alt/Opt-Down Arrow to change the staff positions of
notes in percussion kits using grid and five-line staff presentation types. However, this also
changes the instrument playing the note.

RELATED LINKS
Equal Division of the Octave (EDO) on page 848
Adding notes above/below existing notes on page 198
Add intervals popover on page 198
Inputting accidentals on page 188

Respelling notes
You can change the enharmonic spelling of notes so they are shown as their enharmonic
equivalents, for example, to show the stepwise movement in a phrase clearly, or to avoid altered
unisons in a chord. You can do this for all layouts or just for part layouts.
Dorico Pro uses an algorithm that automatically decides the spelling of pitches, based on key
signature and context.
There are always at least three options for every pitch, as Dorico Pro allows enharmonic spellings
to show up to two accidental glyphs. This means the same note can be spelled four ways if the
original pitch can be spelled with the note name either two notes below or two notes above,
using a maximum of two accidental glyphs. For example, B is a possible enharmonic spelling of
G♯ because a triple-flat uses a single accidental glyph, whereas an F♯ uses two accidental glyphs.
PROCEDURE
1.

In the music area, open the layout in which you want to respell accidentals.
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NOTE
If you respell accidentals in a full score layout, this also affects their spelling in part layouts.
However, if you respell accidentals in part layouts, this only affects their spelling in that part
layout.
2.

Select the notes you want to respell.
NOTE
If you want to respell individual noteheads in tie chains, you must be in Engrave mode.

3.

Respell the selected notes in any of the following ways:
●

Press Alt/Opt-= to respell upwards.

●

Press Alt/Opt-- to respell downwards.

RESULT
The enharmonic spelling of the selected notes is changed.
EXAMPLE

A G sharp

When respelled
downwards, the G sharp
becomes an F triplesharp

When respelled upwards, When respelled upwards
the G sharp becomes an again, the G sharp
A flat
becomes a B triple-flat

RELATED LINKS
Accidentals on page 613
Inputting accidentals on page 188

Transposing existing notes with the add intervals popover
You can change the pitch of notes after they have been input using the add intervals popover.
PROCEDURE
1.

Select the notes you want to transpose.

2.

Press Shift-I to open the add intervals popover.

3.

Enter the transposition interval you want into the popover.
For example, enter t3 to transpose the notes up a third, or t-min6 to transpose the notes
down a minor sixth.

4.

Press Return to close the popover.

RESULT
The selected notes are transposed by the degree specified.
RELATED LINKS
Add intervals popover on page 198
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Repitching notes without changing their rhythm
You can repitch notes after you have input them while keeping their durations the same, for
example, if you want to duplicate the rhythm but have different pitches.
PROCEDURE
1.

Select the first note you want to repitch.

2.

Press Shift-N to start note input.

3.

Optional: If you want to repitch notes on multiple staves at once, extend the caret to those
staves.

4.

Press L to activate Lock to Duration.

5.

Enter the pitches you want.

6.

Optional: Press L again to deactivate Lock to Duration.
NOTE
Lock to Duration automatically deactivates when you reach the last existing note on the
staff. By default, normal note input continues using the previous note value selected before
you activated Lock to Duration.

RESULT
Existing notes on the selected staff are repitched without their rhythms being changed. The caret
automatically advances from note to note, even if there are large rests between notes on the
staff.
RELATED LINKS
Caret on page 167
Extending the caret to multiple staves on page 171

Transposing selections
You can transpose whole selections together, including key signatures within selections, using
the Transpose dialog.
PROCEDURE
1.

In Write mode, make a selection in the music area.

2.

Choose Write > Transpose to open the Transpose dialog.

3.

Adjust the parameters required for your transposition, such as interval and quality.
TIP

4.

●

We recommend using the Calculate interval section to determine your required
settings, for example, if you want to transpose from G♭ major to G major.

●

Different intervals have different possible qualities. For example, you can specify a major
third but not a major octave. Therefore, if you want to set your transposition parameters
manually, we recommend selecting the interval before the quality.

Click OK to save your changes and close the dialog.

RESULT
All notes in your selection are transposed according to the interval or number of divisions of the
octave specified in the Transpose dialog. If your selection included key signatures and you
activated Transpose key signatures, all key signatures in the selection are also transposed.
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Transpose dialog
The Transpose dialog allows you to transpose selections of notes simultaneously, including key
signatures. You can transpose according to an interval and quality or by a set number of octave
divisions.
●

You can open the Transpose dialog in Write mode by making a selection in the music area
and choosing Write > Transpose.

Transpose dialog

The Transpose dialog contains the following sections:
1

Transposition options
Contains options that allow you to specify the transposition you want. For example, you can
choose to transpose by an interval quality, such as a major third, or by a set number of
divisions of the octave. You can choose the direction of the transposition, whether it includes
octaves, and the interval and quality or number of divisions by which you want to transpose
your selection.
According to convention, different intervals have different possible qualities. For example,
you can specify a major third but not a major octave. Therefore, we recommend selecting
the interval before the quality.
Additional options also allow you to transpose any key signatures included in your selection,
keep relative respelled notes and chord symbols where possible, and avoid double and triple
accidentals.
NOTE
You can only use Respell to avoid double and triple sharps and flats when transposing
music in tonality systems that are compatible with 12-EDO.

2

Calculate interval
Allows you to set transposition options according to a starting note and the resulting note
you want. For example, if you want to transpose a selection relative to a C natural becoming
a G♯ but you are not certain of the interval and quality required, you can enter those two
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notes in the Calculate interval section, click Apply, and Dorico Pro automatically sets the
required transposition options for you.
NOTE
The Transpose dialog does not allow transpositions that would result in impossible notations,
such as sharper than a triple sharp, or that require a microtonal accidental that does not exist in
the tonality system in place at the position of your selection.

RELATED LINKS
Add intervals popover on page 198
Equal Division of the Octave (EDO) on page 848
Tonality systems on page 848

MIDI recording
MIDI recording is a way of inputting notes into Dorico Pro by playing them in real time on a MIDI
device. This can be particularly useful if, for example, you prefer to improvise your music rather
than plan pitches and note durations in advance.
In Dorico Pro, you can record MIDI notes using any MIDI device. However, you must connect the
device to your computer before starting Dorico Pro.
Outside of note input, Dorico Pro uses the instrument sounds of your most recent selection for
the notes you play on your MIDI device. In Play mode, this is the most recent track header you
clicked, while in Write mode, this is the last instrument staff on which you selected an item,
started note input, or into which you recorded MIDI. During note input, Dorico Pro always uses
the instrument sounds of the instrument into which you are recording notes.
TIP
You can enable/disable MIDI thru on the Play page in Preferences, for example, if you do not
want to hear sounds in Dorico Pro when playing on your MIDI keyboard.
As you play notes on your MIDI device, Dorico Pro uses an algorithm to produce the correct
enharmonic spelling for those notes.
RELATED LINKS
Optimization for MIDI recording on page 208
Preferences dialog on page 62

Inputting notes using MIDI recording
You can input notes by recording what you play on a MIDI device in real time. You can record
notes in both concert and transposed pitch.
PREREQUISITE
●

You have connected the MIDI device you want to use.

●

You have set the quantization options in the MIDI Quantize Options dialog as appropriate
for the music you intend to record.

●

You have set the options in the Recording section of the Play page in Preferences as
appropriate for the music you intend to record.

●

You have input enough bars or empty rhythmic space for the amount of music you want to
record. Dorico Pro does not automatically add extra bars or rhythmic space.
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●

If you want to hear a click during your recording, you have input a time signature. There is
no click in open meter or when there is no time signature.

●

You have chosen the appropriate input pitch setting.

PROCEDURE
1.

Select a note or rest on the staff/instrument track into which you want to record notes, at the
position from which you want to record. You can do this in Write mode and Play mode.
NOTE
●

In Play mode you cannot select rests, meaning you can only record into instrument
tracks that already contain at least one note.

●

You can also record MIDI during note input, but this prevents Dorico Pro from using
both staves in grand staff instruments.

2.

Optional: If you want to record notes without overwriting any existing notes on the staff,
press Q to activate Chords.

3.

Optional: If you want to record into a specific voice on the staff, press Shift-N to start note
input and then do one of the following:

4.

●

If the voice you want already exists on the staff, press V until the note symbol beside
the caret indicates the correct voice.

●

If the voice you want does not exist on the staff yet, press Shift-V until the note symbol
beside the caret indicates the correct voice.

Press Ctrl/Cmd-R to start recording.
During recording, the playhead appears red and moves along in time. By default, there is
one bar of count-in before the playhead reaches the rhythmic position of either your original
selection or the caret.

5.

Play the notes you want on your MIDI device.
In Write mode, no music appears on the staff until you stop recording. In Play mode, notes
appear in the piano roll in real time.

6.

Press Space or Enter or Ctrl/Cmd-R to stop recording.

RESULT
The notes you played on the MIDI device are input onto the selected staff. If you did not specify
the voice, notes are recorded into the first available voice on the staff, which is usually the first
up-stem voice. If you activated Chords, the notes you played are merged into the first available
voice on the staff without overwriting any existing notes.
The notated duration of the notes follows your quantization settings, but their played durations
are retained for playback.
AFTER COMPLETING THIS TASK
If the notes you played in are not notated as you intended, you can requantize them.
RELATED LINKS
Disabling MIDI input devices on page 210
Changing the count-in duration on page 208
Changing the input pitch setting on page 174
Changing the sustain pedal controller settings for MIDI recording/import on page 209
Repeats in MIDI recording on page 206
Input methods for bars and barlines on page 234
Input methods for time signatures on page 222
Inputting notes into multiple voices on page 179
MIDI Quantize Options dialog on page 83
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Retrieving played notes that you did not record
During playback, you can play notes on your MIDI keyboard and hear them without recording
them into the score. You can use retrospective recording to retrieve these notes and input them
into the project without previously explicitly recording them.
PREREQUISITE
You have started playback, played notes on a MIDI device alongside playback, then stopped
playback.
PROCEDURE
1.

Select a note or rest on the staff where you want to input the retrieved notes.

2.

Optional: If you want to input retrieved notes without overwriting any existing notes on the
staff, press Q to activate Chords.

3.

Press Ctrl/Cmd-Alt/Opt-R .

RESULT
All the notes you played on your MIDI device during the previous playback are input on the
selected staff, starting from the selected rhythmic position. They are input into the first available
voice on the staff and overwrite any existing notes in that voice by default. If you activated
Chords, the retrieved notes are merged into the first available voice on the staff without
overwriting any existing notes.
NOTE
The retrospective recording buffer is cleared each time you start playback, meaning you cannot
retrieve music you played before the most recent playback.

RELATED LINKS
Playing back music on page 542

Repeats in MIDI recording
When recording MIDI into flows that contain repeat structures, such as repeat barlines, Dorico
Pro records the notes you play during each playthrough and merges them together into the
same voice.
Any differences in rhythms between the recordings are notated according to the current meter.

Requantizing notes
You can requantize notes using different quantization settings, for example, if you want to
change notated rhythms after importing MIDI or recording notes using a MIDI device. This does
not affect the played duration of notes in playback.
PROCEDURE
1.

Select all the notes you want to requantize. You can do this in Write mode and Play mode.

2.

Choose Edit > Requantize to open the MIDI Quantize Options dialog.

3.

Change the quantization settings as appropriate for your selection.

4.

Click OK to save your changes and close the dialog.
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RESULT
The notated durations of all selected notes are changed according to the quantization options
you set. This does not affect their played duration in playback.
RELATED LINKS
MIDI Quantize Options dialog on page 83

Changing the click settings
You can change the pitch, volume, and subdivision of the metronome click, which is always used
during MIDI recording. During playback, the click only sounds if the metronome is activated.
By default, Dorico Pro only subdivides the beat in the metronome click in compound time
signatures, and uses a beep for the metronome click sound. The beep is a higher pitched tone
for the first beat of the bar and a lower and quieter tone for subsequent beats of the bar. Further
beat subdivisions use even lower tones.
The click is produced by a tone generator called DoricoBeep. You can change the device used for
the click in the Time track header in Play mode.
NOTE
There is no click in open meter or when there is no time signature.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-P to open Playback Options.

2.

Click Click in the page list.

3.

In the Metronome Click section, activate/deactivate the following options for Beat
subdivisions:

4.

5.

6.

●

Subdivide beats in simple time signatures

●

Subdivide beats in compound time signatures

Choose one of the following options for Click sound:
●

Click (unpitched)

●

Beep (pitched)

For Pitch and velocity, change the MIDI pitch and/or Velocity values for any of the
following types of beat:
●

First beat

●

Subsequent beats

●

Beat subdivisions

Click Apply, then Close.

RESULT
The pitch, volume, and subdivision settings for the metronome click in the current project are
changed.
RELATED LINKS
Types of time signatures on page 1237
Input methods for time signatures on page 222
Playback templates on page 558
Playing back music on page 542
Time track on page 530
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Changing the count-in duration
For each project, you can change the default number of bars used in the count-in before you
start recording. By default, Dorico Pro provides a one bar count-in.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-P to open Playback Options.

2.

Click Click in the page list.

3.

In the Count-in section, change the value for Number of bars count-in.

4.

Click Apply, then Close.

RESULT
The default duration of the count-in is changed in the current project.

Optimization for MIDI recording
Depending on your operating system and the MIDI devices you use for recording, you might find
that the notes you record are not notated with the durations or at the rhythmic positions you
expected. Optimizing the settings related to MIDI recording can help you achieve better results.
Because there can be a time latency between you pressing keys on a MIDI device and the notes
being picked up by Dorico Pro, we recommend that you check the latency by inputting a simple
rhythm against the click, for example, recording quarter notes in a 4/4 time signature.
Depending on the results, there are different settings you can change:
●

If your notes are notated with incorrect durations, such as sixteenth notes notated as eighth
notes, we recommend that you change your quantization settings in the MIDI Quantize
Options dialog.

●

If your notes are notated ahead of the beat, we recommend that you increase the latency
compensation value.

●

If your notes are notated behind the beat, we recommend that you reduce the buffer size for
your audio device to the lowest possible value that still produces stable playback with no
drop-outs.
NOTE
The built-in audio device on Windows computers cannot always achieve a low enough
latency for reliable input in real time. In such cases, we recommend that you use an external
USB audio interface with ASIO support.

RELATED LINKS
MIDI Quantize Options dialog on page 83
Changing the sustain pedal controller settings for MIDI recording/import on page 209

Changing the MIDI latency compensation value
You can change the MIDI latency compensation value to correct any discrepancy between when
you press keys during MIDI recording and where the corresponding notes are notated relative to
the beat.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Play in the page list.
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3.

In the Recording subsection, change the value for MIDI input latency compensation.

4.

Click Apply, then Close.

RESULT
Increasing the latency compensation value increases the time between pressing the key and the
note being notated. This is useful if the notes you record were previously notated ahead of the
beat.
Decreasing the latency compensation value decreases the time between pressing the key and
the note being notated. This is useful if the notes you record were previously notated behind the
beat.

Changing the audio device buffer size
You can change the audio buffer size, for example, if the current buffer size is causing notes
input using MIDI recording appear significantly after the beat.
NOTE
●

If the notes you play when recording MIDI are notated behind the beat, we recommend that
you reduce the buffer size for your audio device to the lowest possible value that still
produces stable playback with no drop-outs.

●

The built-in audio device on Windows computers cannot always achieve a low enough
latency for reliable input in real time. In such cases, we recommend that you use an external
USB audio interface with ASIO support.

PROCEDURE
1.

Choose Edit > Device Setup to open the Device Setup dialog.

2.

In the Device Setup dialog, select the audio device whose buffer size you want to change
from the ASIO Driver menu.

3.

Click Device Control Panel to open the device settings dialog for the selected audio device.

4.

In the audio device settings dialog, change the buffer size in one of the following ways, as
appropriate for your operating system:
●

For Windows systems, in the Audio buffer size section, either drag the slider to a
different position or activate User definable and change the value in the Selected
buffer size field.

●

For macOS systems, select a sample rate from the Buffer Size menu.

5.

Click OK (Windows)/Close (macOS) to close the audio device settings dialog.

6.

Click Close to close the Device Setup dialog.

Changing the sustain pedal controller settings for MIDI recording/
import
You can change your default setting for whether Dorico Pro interprets sustain pedal controllers
as pedal lines when recording MIDI and importing MIDI files.
NOTE
These options are also available in the MIDI Import Options dialog, and your settings are linked
between this dialog and Preferences.
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PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Play in the page list.

3.

In the Recording subsection, activate/deactivate Import CC64 as pedal lines.

4.

Optional: If you activated Import CC64 as pedal lines, activate/deactivate Snap pedal lines
to previous beat.

5.

Click Apply, then Close.

RESULT
When Import CC64 as pedal lines is activated, the MIDI controller CC64 is interpreted as pedal
lines.
When Snap pedal lines to previous beat is activated, the start of pedal lines is automatically
moved back to the start of the beat.
RELATED LINKS
MIDI Import Options dialog on page 81

Disabling MIDI input devices
By default, Dorico Pro accepts MIDI input from all connected MIDI devices, including virtual MIDI
cables and inter-application buses. You can disable MIDI devices individually, for example, if you
are using devices that continuously output MIDI data or if you want particular devices to remain
routed exclusively to another application.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Play in the page list.

3.

In the Recording subsection, click MIDI Input Devices.

4.

In the MIDI Input Devices dialog, deactivate the checkbox for each MIDI input device you
want to disable.

5.

Click OK to save your changes and close the dialog.

6.

Click Apply, then Close.

Notations input
You can input many types of notations, both during note input and by adding them to existing
notes. In Dorico Pro, “notation” is a broad term that includes many different items, including
articulations, slurs, dynamics, and more.

Inputting articulations
You can input notes with articulations during note input, and you can add articulations to notes
after they have been input.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select the existing notes to which you want to add articulations.
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2.

Optional: If you want to input notes with articulations onto multiple staves at once, extend
the caret to those staves.

3.

Select the articulations you want to input in any of the following ways:

4.

●

Press the key commands for the articulations you want.

●

Click the articulations you want in the Notes panel.

Optional: Enter the notes or chords you want with your selected articulations.

RESULT
The selected articulations are added to the selected notes. They are positioned between
noteheads or stems and tuplet brackets, so they are closer to the notes than tuplet brackets or
tuplet numbers/ratios.
During note input, the selected articulations are added to all notes that are input until the
articulations are deactivated.
NOTE
Some combinations of articulations on the same notes are not possible. For example, you cannot
have both staccato and staccatissimo marks on the same notes, as both articulations indicate
that notes are played shorter.
AFTER COMPLETING THIS TASK
You can enable independent voice playback for individual instruments, for example, if you have
slurs in one voice and staccatos in another voice.
RELATED LINKS
Articulations on page 623
Note input on page 167
Extending the caret to multiple staves on page 171
Enabling independent voice playback on page 543

Key commands for articulations
In addition to clicking them in the Notes panel, you can input common articulations by pressing
key commands on your computer keyboard.
You can use the following key commands to input articulations with the keyboard:

Type of articulation

Key command

Accent: 

[

Marcato: 

'

Stressed: 

{

Unstressed: 

@ (Windows) or " (macOS)

Staccato: 

]

Tenuto: 

# (Windows) or \ (macOS)

Staccatissimo: , , or 

}
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Type of articulation

Key command

Combined tenuto and staccato: 

~ (Windows) or | (macOS)

RELATED LINKS
Articulations on page 623

Inputting slurs
You can input slurs, both during note input and by adding them to existing notes. You can also
add slurs to existing notes on multiple staves at the same time.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select the notes to which you want to add slurs.
TIP
●

You can select notes on multiple staves and input slurs on them at the same time.

●

If you only select a single note, the slur connects that note to the next note on the
staff.

2.

Optional: If you want to input slurs onto multiple staves at once, extend the caret to those
staves.

3.

Press S .
TIP
Alternatively, click Slur in the Notes panel, and then click and drag to input a slur and extend
it to your preferred length.

4.

Optional: During note input, input the notes you want.
The slur extends automatically, even if there are rests between the notes you input.

5.

Optional: During note input, press Shift-S to end the slur on the currently selected note.

RESULT
During note input, slurs begin from the currently selected note on all staves across which the
caret extends, not from the caret position. Slurs extend automatically as you input notes, and
end on the currently selected note.
When adding slurs to existing notes, the selected notes are connected by slurs. For example, if
you select two notes in one staff and two notes in another staff, two slurs are input. They connect
the notes on each selected staff.
AFTER COMPLETING THIS TASK
You can enable independent voice playback for individual instruments, for example, if you have
slurs in one voice and staccatos in another voice.
RELATED LINKS
Slurs on page 1118
Inputting notes on page 172
Extending the caret to multiple staves on page 171
Slurs in playback on page 1144
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Enabling independent voice playback on page 543

Inputting fingerings
You can input fingerings on existing notes using the fingerings popover, both during note input
and by adding them to existing notes.
NOTE
●

You can only add fingerings to notes at one rhythmic position at a time, and you can only
input as many fingerings as there are notes at each rhythmic position. For example, you can
input three fingerings at the rhythmic position of a chord containing three notes, but only
one fingering at the rhythmic position of a single note.

●

If you select notes in multiple voices, fingerings are only input into the top voice.

●

Although they contain two numbers, substitution fingerings are considered one fingering,
meaning you can add substitution fingerings to single notes.

PROCEDURE
1.

In Write mode, do one of the following:
●
●

Start note input.
Select the existing notes to which you want to add fingering.
If you want to add fingerings to all notes in a chord, select all the notes in the chord.

2.

Press Shift-F to open the fingerings popover.

3.

Optional: If you are inputting fingerings for fretted instruments, change the hand in one of
the following ways:
●

To switch to the right hand, press Down Arrow .

●

To switch to the left hand, press Up Arrow .

The popover icon updates to show the current hand.

Fingerings popover when inputting right-hand
fingerings

4.

Fingerings popover when inputting left-hand
fingerings

Enter the fingerings you want into the popover.
For example, enter:

5.

●

3-2 for a substitution fingering from the third finger to the second finger.

●

1,3,5 for a chord.

●

12 to show the first two valves should be depressed on a valved brass instrument.

●

p for a right-hand thumb fingering or t for a left-hand thumb fingering.

Optional: When adding fingerings to existing notes, move the popover in one of the
following ways:
●

To advance the popover to the next note/chord in the current voice, press Space .

●

To move the popover back to the previous note/chord in the current voice, press ShiftSpace .

●

To advance the popover to the first note/chord in the current voice in the next bar, press
Tab .
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6.

●

To move the popover back to the first note/chord in the current voice in the previous
bar, press Shift-Tab .

●

To move the cursor and popover to the right/left and to the next/previous note/fingering
in the current voice, press Right Arrow / Left Arrow .

Press Return to close the popover.

RESULT
The fingerings are input on the selected notes, including during note input. The popover
advances through notes in the voice as indicated by the caret or in the same voice as your initial
selection.
RELATED LINKS
Fingering on page 788
Changing the rhythmic position of substitution fingerings on page 790
Fingerings for valved brass instruments on page 809
Deleting fingerings on page 796

Fingerings popover
The following tables contain examples of what you can enter into the fingerings popover to input
the different types of fingerings available. The fingerings popover behaves differently for fretted
instruments compared to other instruments, so there is a separate table for fretted instrument
fingerings.
You can open the fingerings popover in Write mode in any of the following ways when either a
note is selected or the caret is active:
●

Press Shift-F .

●

Choose Write > Create Fingerings.

●

Click Fingerings in the Notations toolbox.

When inputting fingerings for non-fretted instruments, the icon on the left-hand side of the
popover matches the corresponding button in the Notations toolbox. When inputting fingerings
for fretted instruments, the icon on the left-hand side of the popover indicates whether you are
inputting left-hand or right-hand fingerings.

Fingerings popover with an
Fingerings popover with an
example entry for inputting a non- example entry for a left-hand
fretted instrument fingering
fretted instrument fingering

Fingerings popover with an
example entry for a right-hand
fretted instrument fingering
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Keyboard and string instruments
Type of fingering

Example popover entry

Single fingerings for individual notes, including 1, 2, 3, and so on
for brass valve numbers and trombone slide
positions
Valved brass instruments

12

Single fingerings for each note in chords

1,3,5

For keyboard instruments, Dorico Pro
automatically orders numbers appropriately
according to the hand playing the notes. The
default is:
●

Right hand for the upper staff

●

Left hand for the lower staff

Left-hand fingerings (non-fretted instruments)

L2, G2, S5, I2, or H2

Right-hand fingerings (non-fretted
instruments)

R5, D5, or M5

Thumb indicator (non-fretted instruments)

T

Multiple fingerings for individual notes, for
example, for ornaments such as mordents or
turns

2343

Single fingerings for multiple notes: enter the
same fingering number for two adjacent
notes.

1,1

For example, in keyboard music the thumb
may depress two keys simultaneously.
2(3)

Alternative fingerings
NOTE
You must use parentheses in the popover,
even if you choose to show alternative
fingerings in square brackets.

[4]

Editorial fingerings
NOTE
You must use square brackets in the popover,
even if you choose to show editorial fingerings
in parentheses.

Finger substitutions

1-3
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Fretted instruments
Type of fingering

Example popover entries

Left-hand fingerings

0, 1, 2, 3, 4, 5

Left-hand thumb

t

Right-hand fingerings

1, 2, 3, 4, 5
p, i, m, a, e

Right-hand thumb

p, t, or 1

Right-hand pinky finger

e, x, c, o, or 5

These lists are not comprehensive as there are many possible fingerings. It is intended to
illustrate how you can structure your entries to input different types of fingerings.
NOTE
Finger substitutions are shown as immediate by default, but you can change the rhythmic
position of the substitution by changing the deferral duration.
You can change the appearance and position of each type of fingering on the Fingering page in
Engrave > Engraving Options.
RELATED LINKS
Fingering on page 788
Project-wide engraving options for fingerings on page 789
Changing the rhythmic position of substitution fingerings on page 790
Fingerings for valved brass instruments on page 809

Input methods for key signatures
You can input key signatures with the keyboard by using the key signatures popover, and with
the mouse by using the Key Signatures, Tonality Systems, and Accidentals panel.
NOTE
You can only input custom key signatures using the panel, you cannot input them using the
popover.

RELATED LINKS
Key signatures on page 839

Key signatures popover
The table contains the entries for the key signatures popover that you can use to input the
different key signatures available.
You can open the key signatures popover in Write mode in any of the following ways when either
an item is selected or the caret is active:
●

Press Shift-K .

●

Select an existing key signature and press Return .
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●

Choose Write > Create Key Signature.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Key signatures popover with an example entry

Key Signatures, Tonality Systems, and Accidentals
button in the Notations toolbox

Type of key signature

Popover entry

Open or atonal key signature

open or atonal

Major keys (capital letters)

C, D or G#, Ab, and so on

Minor keys (lowercase letters)

g, d, f#, bb, and so on

Number of sharps

3s, 2#, and so on

NOTE
Assumes the major key for that many sharps.

4f, 5b, and so on

Number of flats
NOTE
Assumes the major key for that many flats.

This list is not comprehensive as you can input every possible key signature. It is intended to
illustrate how you can structure your entry to input different types of key signatures.
RELATED LINKS
Key signatures on page 839

Key Signatures, Tonality Systems, and Accidentals panel
The Key Signatures, Tonality Systems, and Accidentals panel allows you to create and input
common key signatures and your own custom key signatures.
●

You can hide/show the Key Signatures, Tonality Systems, and Accidentals panel by clicking
Key Signatures, Tonality Systems, and Accidentals in the Notations toolbox on the right of
the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The Key Signatures, Tonality Systems, and Accidentals panel contains the following sections:
Tonality System
Contains a menu that allows you to select tonality systems to use and provides options
that open the Edit Tonality System dialog.
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The Tonality System section of the Key Signatures, Tonality Systems, and Accidentals panel

The action bar at the bottom of the section contains the following options:
●

New Tonality System: Creates a new custom tonality system and opens the Edit
Tonality System dialog.

●

Duplicate Tonality System: Creates a copy of an existing tonality system that you
can edit separately from the original and opens the Edit Tonality System dialog.

●

Edit Tonality System: Opens the Edit Tonality System dialog and allows you to
edit the selected existing tonality system.

●

Import Tonality System: Opens the File Explorer/macOS Finder, where you can
select the tonality system .doricolib file that you want to import into the current
project.

●

Export Tonality System: Opens the File Explorer/macOS Finder, where you can
select the location to which you want to export the selected tonality system as
a .doricolib file. You can then import the .doricolib file into other projects
and share it with other users.

●

Delete Tonality System: Deletes the selected tonality system.

NOTE
You cannot delete predefined tonality systems or any tonality system that is
currently used in your project.
Used in This Flow
Contains all the key signatures currently used in the flow.
Key Signatures
Allows you to create key signatures.
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The Key Signatures section of the Key Signatures, Tonality Systems, and Accidentals panel.

The Key Signatures section contains the following parts:
1

Major/Minor
Allow you to choose whether your key signature is Major or Minor.

2

More Sharps/Fewer Flats
Each time you click, you add one sharp accidental to the key signature, or remove
one flat accidental from the key signature.

3

Fewer Sharps/More Flats
Each time you click, you remove one sharp accidental from the key signature, or
add one flat accidental to the key signature.

4

Input key signature
Shows how the key signature looks on a staff. Clicking this button inputs the
displayed key signature. If nothing in the project is selected, the key signature is
loaded onto the mouse pointer.

Custom Key Signatures
Contains any custom key signatures you have created for the currently selected
tonality system.
Accidentals
Contains all accidentals available in the currently selected tonality system.
RELATED LINKS
Key signatures on page 839
Custom tonality systems on page 851
Edit Tonality System dialog on page 854
Creating custom tonality systems on page 851

Inputting key signatures with the popover
You can input key signatures using the key signatures popover, both during note input and by
adding them to existing music. You can also input key signatures only on single staves.
NOTE
●

You cannot input custom key signatures using the popover, you can only input them using
the panel.

●

It is not necessary to input different key signatures for transposing instruments, as Dorico
Pro automatically shows the appropriate key signatures for transposing instruments in
transposing layouts.
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PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a key signature. If you
want to input a key signature on a single staff, select an item that belongs to that staff
only.

2.

Optional: If you want to input key signatures onto multiple specific staves at once, extend
the caret to those staves.

3.

Press Shift-K to open the key signatures popover.

4.

Enter the key signature you want into the popover.
For example, enter g for G minor or 3s for 3 sharps.
NOTE
Entering 3s creates a key signature of A major, rather than F♯ minor.

5.

Input the key signature and close the popover in one of the following ways:
●

To input a key signature on all staves, press Return .

●

To input a key signature only on the selected staff or staves across which the caret
extends, press Alt/Opt-Return .

RESULT
During note input, key signatures are input at the caret position, even if this is in the middle of a
bar. However, it is preferable to input key signature changes at barlines.
All subsequently input notes follow the input key signature, until the next existing key signature
or the end of the flow, whichever comes first. If playing in notes using a MIDI keyboard,
accidentals are spelled according to the key signature.
When adding key signatures to existing music, they are added at the rhythmic position of the
earliest selected item. They appear to the right of barlines and clefs, and to the left of other
items, even if this is in the middle of an existing bar. If you selected an existing key signature, the
new key signature directly replaces the existing one.
NOTE
An individual key signature on a single staff is not intended for transposing instruments.
Transpositions of notes and key signatures are done automatically for transposing instruments.

RELATED LINKS
Extending the caret to multiple staves on page 171
Key signatures popover on page 216
Accidental selection during MIDI input on page 190
Key signatures on page 839
Project-wide spacing gaps for key signatures on page 843
Moving key signatures rhythmically on page 844
Transposing instruments on page 115
Making layouts transposing/concert pitch on page 137
Changing the tonality system on page 849
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Inputting key signatures with the panel
You can input key signatures using the Key Signatures, Tonality Systems, and Accidentals panel,
both during note input and by adding them to existing music. You can also input key signatures
only on single staves.
NOTE
●

These steps describe inputting with the default mouse input preference Create item at
selection.

●

It is not necessary to input different key signatures for transposing instruments, as Dorico
Pro automatically shows the appropriate key signatures for transposing instruments in
transposing layouts.

PREREQUISITE
You have created any custom key signatures, in custom tonality systems if required, that you
want to input.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a key signature. If you
want to input a key signature on a single staff, select an item that belongs to that staff
only.

2.

In the Notations toolbox, click Key Signatures, Tonality Systems, and Accidentals to show
the Key Signatures, Tonality Systems, and Accidentals panel.

3.

Optional: If you have not already used the key signature you want in the current flow, create
the key signature you want using the Key Signatures editor in the Key Signatures, Tonality
Systems, and Accidentals panel.

4.

Input the key signature you want in one of the following ways:
●

To input a key signature on all staves, click it in the Key Signatures, Tonality Systems, and
Accidentals panel.

●

To input a key signature on the selected staff only, Alt/Opt -click it in the Key Signatures,
Tonality Systems, and Accidentals panel.

RESULT
During note input, key signatures are input at the caret position, even if this is in the middle of a
bar. However, it is preferable to input key signature changes at barlines.
All subsequently input notes follow the input key signature, until the next existing key signature
or the end of the flow, whichever comes first. If playing in notes using a MIDI keyboard,
accidentals are spelled according to the key signature.
When adding key signatures to existing music, they are added at the rhythmic position of the
earliest selected item. They appear to the right of barlines and clefs, and to the left of other
items, even if this is in the middle of an existing bar. If you selected an existing key signature, the
new key signature directly replaces the existing one.
NOTE
An individual key signature on a single staff is not intended for transposing instruments.
Transpositions of notes and key signatures are done automatically for transposing instruments.

221
Dorico Pro 3.1.10

Write mode
Notations input
RELATED LINKS
Key signatures on page 839
Key Signatures, Tonality Systems, and Accidentals panel on page 217
Project-wide spacing gaps for key signatures on page 843
Accidental selection during MIDI input on page 190
Moving key signatures rhythmically on page 844
Mouse input settings on page 164
Transposing instruments on page 115
Making layouts transposing/concert pitch on page 137
Custom tonality systems on page 851
Custom key signatures on page 860
Creating custom tonality systems on page 851
Creating/Editing custom key signatures on page 854
Changing the tonality system on page 849

Input methods for time signatures
You can input time signatures with the keyboard by using the time signatures popover, and with
the mouse by using the Time Signatures (Meter) panel.
NOTE
You can create most types of custom time signatures using the Create Time Signature section
of the Time Signatures (Meter) panel, but certain time signatures are only possible using the time
signatures popover. For example, you can only specify beat subdivisions with the time signatures
popover.

RELATED LINKS
Preferences dialog on page 62
Time signatures on page 1235
Types of time signatures on page 1237

Time signatures popover
The table contains the entries for the time signatures popover that you can use to input the
different types of time signatures available.
You can open the time signatures popover in Write mode in any of the following ways when
either an item is selected or the caret is active:
●

Press Shift-M .

●

Select an existing time signature and press Return .

●

Choose Write > Create Time Signature.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Time signatures popover with an example entry
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Type of time signature

Popover entry

Simple time signatures

2/4, 6/8, 3/4, 5/4, and so on

For example, 2/4, 6/8, 3/4, 5/4 and so on
4/4,1.5, 6/8,2, and so on

Time signatures with a pick-up
For example, a 4/4 bar with a dotted quarter
note pick-up, or a 6/8 bar with a pick-up of two
eighth notes (quavers).
Alternating time signatures, such as 6/8+3/4

6/8 + 3/4

NOTE
You must include spaces either side of the plus
sign.

Common time, the equivalent of 4/4

c

Cut common time, the equivalent of 2/2

cutc or ¢

Open meter indicated by X

X or x

Open meter with no indication

open

NOTE
A time signature signpost is shown at the
position of the open meter.

Additive time signature with explicit beat
grouping

3+2+2/8, 3+2/4, and so on

Beat grouping specified but not shown in the
time signature

[2+3+2]/8

For example, a time signature of 7/8 is shown
but beams are subdivided into 2+3+2 eighth
notes.
Aggregate time signature with dashed barlines 2/4|6/8
shown in each bar, indicating the divisions
between the different meters
Aggregate time signature without dashed
barlines shown in each bar
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Type of time signature

Popover entry

Interchangeable time signature with different
styles: parenthesized, slash, equals sign, and
dashed

2/4 (6/8), 2/4 / 6/8, 2/4 = 6/8, or 2/4 – 6/8

NOTE
You must include spaces either side of the
slashes, equals signs, or dashes, and before
opening parentheses.

This list is not comprehensive, as there are many possible time signatures. It is intended to
illustrate how you can structure your entry to input different time signatures.
RELATED LINKS
Time signatures on page 1235

Time Signatures (Meter) panel
The Time Signatures (Meter) panel allows you to input different time signatures. In the Create
Time Signature section of the panel, you can create uncommon time signatures.
●

You can hide/show the Time Signatures (Meter) panel by clicking Time Signatures (Meter) in
the Notations toolbox on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The Time Signatures (Meter) panel contains the following sections:
Used in This Flow
Contains any time signatures already used in the current flow.
Common
Contains common time signatures, such as 4/4, 3/4, 6/8, and 7/8.
Create Time Signature
Allows you to design your own time signatures, including alternating time signatures
and aggregate time signatures.
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The Create Time Signature section of the Time Signatures (Meter) panel

The Create Time Signature section contains the following parts:
1

Time signature type menu
Allows you to select one of the following types of time signatures:

2

●

Regular

●

Interchangeable

●

Aggregate

●

Alternating

Time signature spaces
Allows you to combine up to four time signatures. For example, you can specify
only one time signature for a regular time signature, but for an alternating time
signature, you might want to include three time signatures.

3

Pick-up bar of
Allows you to include a pick-up bar before the time signature. A pick-up bar is not a
complete bar, and so allows you to include only a few beats before the first
complete bar.
You can select one of the following options for the number of beats in a pick-up
bar:

4

●

1/2 beat

●

1 beat

●

2 beats

Input time signature button
Click the button that displays the time signature to input it. If nothing in the project
is selected, the time signature is loaded onto the mouse pointer.

RELATED LINKS
Time signatures on page 1235
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Inputting time signatures with the popover
You can input time signatures, including time signatures with pick-up bars, using the time
signatures popover, both during note input and by adding them to existing music. You can also
input time signatures only on single staves.
NOTE
●

In order to input an upbeat or pick-up bar, you must input a new time signature that
includes the upbeat you want. For example, entering 4/4,1 into the time signatures popover
creates a 4/4 time signature with one quarter note upbeat.
The number after the comma indicates multiples of the rhythmic unit specified by the
denominator of the time signature. For example, 4/4,0.75 creates a dotted eighth note
(dotted quaver) upbeat, whereas 6/8,2 creates an upbeat of two eighth notes.

●

Dorico Pro does not automatically add beats to fill bars according to the new time signature
unless Insert mode is activated.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a time signature. If you
want to input a time signature on a single staff, select an item that belongs to that staff
only.

2.

Optional: If you want to input time signatures onto multiple specific staves at once, extend
the caret to those staves.

3.

Optional: If you want Dorico Pro to add beats at the end of the region affected by the new
time signature if required, press I to activate Insert mode.

4.

Press Shift-M to open the time signatures popover.

5.

Enter the time signature you want into the popover.
For example, enter [2+2+3]/8 for a 7/8 time signature with a custom beat grouping, or 4/4,1
for a 4/4 time signature with one quarter note upbeat.

6.

Input the time signature and close the popover in one of the following ways:
●

To input a time signature on all staves, press Return .

●

To input a time signature only on the selected staff or staves across which the caret
extends, press Alt/Opt-Return .

RESULT
During note input, time signatures are added at the caret position, even if this is in the middle of
an existing bar.
When adding time signatures to existing music, they are added at the rhythmic position of the
earliest selected item. They appear to the right of barlines, key signatures, and clefs, and to the
left of other items, even if this is in the middle of an existing bar. If you selected an existing time
signature, the new time signature directly replaces the existing one.
All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first. Dorico Pro automatically inputs and moves barlines as
required so that subsequent music is barred correctly.
RELATED LINKS
Time signatures on page 1235
Time signatures popover on page 222
Extending the caret to multiple staves on page 171
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Inputting time signatures with the panel
You can input time signatures, including time signatures with pick-up bars, using the Time
Signatures (Meter) panel, both during note input and by adding them to existing music. You can
also input time signatures only on single staves.
NOTE
●

These steps describe inputting with the default mouse input preference Create item at
selection.

●

Dorico Pro does not automatically add beats to fill bars according to the new time signature
unless Insert mode is activated.

PREREQUISITE
If necessary, you have created the time signature you want in the Create Time Signature section
of the Time Signatures (Meter) panel.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a time signature. If you
want to input a time signature on a single staff, select an item that belongs to that staff
only.

2.

Optional: If you want Dorico Pro to add beats at the end of the region affected by the new
time signature if required, press I to activate Insert mode.

3.

In the Notations toolbox, click Time Signatures (Meter) to show the Time Signatures (Meter)
panel.

4.

Optional: For pick-up bars, activate Pick-up bar of in the Create Time Signature section of
the Time Signatures (Meter) panel and select one of the following options:
●

1/2 beat

●

1 beat

●

2 beats
NOTE
Not all pick-up bar lengths are possible using this method. For example, a single eighth
note upbeat in 6/8 cannot be produced by any of these three options. In such cases, you
must use the time signatures popover.

5.

Input the time signature you want in one of the following ways:
●

To input a time signature on all staves, click it in the Time Signatures (Meter) panel.

●

To input a time signature on the selected staff only, Alt/Opt -click it in the Time
Signatures (Meter) panel.

RESULT
During note input, time signatures are added at the caret position, even if this is in the middle of
an existing bar.
When adding time signatures to existing music, they are added at the rhythmic position of the
earliest selected item. They appear to the right of barlines, key signatures, and clefs, and to the
left of other items, even if this is in the middle of an existing bar. If you selected an existing time
signature, the new time signature directly replaces the existing one.
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All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first. Dorico Pro automatically inputs and moves barlines as
required so that subsequent music is barred correctly.
RELATED LINKS
Time signatures on page 1235
Inputting notes on page 172
Time Signatures (Meter) panel on page 224
Mouse input settings on page 164

Input methods for tempo marks
You can input tempo marks with the keyboard by using the tempo popover, with the mouse by
using the Tempo panel, and in the Time track in Play mode. You can input a tempo mark
containing just a text instruction, just a metronome mark, or a combination of the two.
RELATED LINKS
Tempo marks on page 1203
Time track on page 530
Inputting tempo changes in the Time track on page 532

Tempo popover
The following tables contain examples of what you can enter into the tempo popover to input
tempo marks, tempo equations, and rhythmic feels for swing playback.
When you start entering a tempo into the tempo popover, a menu appears with suggestions
containing the letters/words you enter. You can select one of these suggestions to input, or enter
your own tempo into the popover.
You can open the tempo popover in Write mode in any of the following ways when either an item
is selected or the caret is active:
●

Press Shift-T .

●

Select an existing tempo mark and press Return .

●

Choose Write > Create Tempo.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Tempo button in the Notations toolbox
Tempo popover with an example entry

Tempo marks
Example tempo mark

Popover entry

Adagio

Adagio

Presto  = 176

Presto q = 176 or Presto q=176
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Example tempo mark

Popover entry

Largo ( = 52)

Largo (q = 52) or Largo (q=52)

 = 96-112

q = 96-112, q=96-112, 6 = 96-112, or 6=96-112

  = 84

q. = 84, q.=84, 6. = 84, or 6.=84

 = 30

w = 30, w=30, 8 = 30, or 8=30

 = 60

h = 60, h=60, 7 = 60, or 7=60

 = 120

e = 120, e=120, 5 = 120, or 5=120

  = 90

e. = 90, e.=90, 5. = 90, or 5.=90

 = 240

x=240, x = 240, 4=240 or 4 = 240

rit.

rit. or rit

accel.

accel. or accel

più

più or piu

meno

meno

Faster, with energy

Faster, with energy

Tempo equations
Tempo equation

Popover entry

 = 

e = e., e=e., 5 = 5., or 5=5.

=

q = e, q=e, 6 = 5, or 6=5

This list is not comprehensive as you can enter tempos freely and there are many possible
metronome marks, tempo marks, and tempo equations. It is intended to illustrate how you can
structure your entry to input different types of tempo marks and metronome marks.
NOTE
The tempo popover is case-sensitive. If you want your tempo mark to start with a capital letter,
you must enter a capital letter into the popover.

Rhythmic feels for swing playback
Rhythmic feel

Popover entry

Light 16th note swing rhythmic feel

light swing 16ths
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Rhythmic feel

Popover entry

Light eighth note swing rhythmic feel

light swing 8ths

Medium 16th note swing rhythmic feel

medium swing 16ths

Medium eighth note swing rhythmic feel

medium swing 8ths

Heavy 16th note swing rhythmic feel

heavy swing 16ths

Heavy eighth note swing rhythmic feel

heavy swing 8ths

Straight rhythmic feel

straight (no swing)

Triplet 16th fixed rhythmic feel

2:1 swing 16ths (fixed)

Triplet 8th fixed rhythmic feel

2:1 swing 8ths (fixed)

Dotted 16th-32nd fixed rhythmic feel

3:1 swing 16ths (fixed)

Dotted 8th-16th fixed rhythmic feel

3:1 swing 8ths (fixed)

TIP
For rhythmic feels, the popover uses the name of the rhythmic feel as set in the Rhythmic Feel
dialog. If you have created custom rhythmic feels, you can enter the name of these into the
tempo popover.

RELATED LINKS
Tempo marks on page 1203
Types of tempo marks on page 1204
Swing playback on page 548
Enabling swing playback for specific sections/instruments on page 550
Rhythmic Feel dialog on page 552

Tempo panel
The Tempo panel contains the different types of tempo marks available in Dorico Pro, organized
into sections. It is located on the right of the window in Write mode.
●

You can hide/show the Tempo panel by clicking Tempo in the Notations toolbox on the right
of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
Used in This Flow
Contains any tempo marks already used in the flow, including custom tempo marks
added using the tempo popover.
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Tap Tempo
Allows you to create an absolute tempo change based on the speed with which you
click the Tap button. It appears as a metronome mark with no text by default. The
metronome mark value is always rounded to the nearest integer.
You can use the available options to set the beat unit on which you want to base the
tempo.

Absolute Tempo Change
Contains a range of tempos with both an Italian tempo indication and a metronome
mark. You can later choose to show or hide the metronome mark for individual tempo
marks.
You can change the range shown in the list by adjusting the slider at the top.

Gradual Tempo Change
Contains tempo marks that indicate a change in tempo over a defined period of time,
such as rallentando or accelerando.
You can add modifiers to gradual tempo changes. Available modifiers are shown at the
top of the section.
Relative Tempo Change
Contains tempo marks that indicate a change in tempo that is relative to the previous
tempo, such as mosso (movement, or with movement). They often include modifiers
that qualify the change, such as poco meno mosso (a little less movement), and are not
defined by a metronome mark.
You can add modifiers to relative tempo changes. Available modifiers are shown at the
top of the section.
You can later set a relative metronome mark change as a percentage of the previous
metronome mark for individual tempo marks.
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Reset Tempo
Contains tempo marks that indicate a return to the previous tempo, such as A tempo,
or a previously defined tempo, such as Tempo primo.
Tempo Equation
Allows you to input a tempo equation, using beat units from 16th notes to whole notes
and up to two rhythm dots.

RELATED LINKS
Tempo marks on page 1203
Types of tempo marks on page 1204
Changing the metronome mark value on page 1212
Hiding/Showing decimal places for metronome marks on page 1214

Inputting tempo marks with the popover
You can input tempo marks using the tempo popover, both during note input and by adding
them to existing music.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a tempo mark. If you
want to input a gradual tempo change across a duration, select items that span that
duration.

2.

Press Shift-T to open the tempo popover.

3.

Enter the tempo you want into the popover.
For example, enter q=72 or Allegretto.
When you start entering a tempo into the tempo popover, a menu appears that shows
suggested tempos containing the letters/words you enter. You can select one of these
suggestions or you can enter your own tempo into the popover.
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NOTE
If you want to show gradual tempo changes separated into syllables spread across their
duration, such as rit-e-nu-to, we recommend selecting a suggested entry from the menu.
Only gradual tempo changes with valid full text appear separated into syllables.
4.

Press Return to close the popover.

RESULT
During note input, tempo marks are input at the caret position. Gradual tempo changes, such as
rallentando, are also input at the caret position with a default duration of a quarter note. Gradual
tempo changes do not extend as you input notes.
When adding tempo marks to existing music, they are added at the rhythmic position of the
earliest selected item. Gradual tempo changes span the duration of the selected items.
NOTE
Metronome mark values appear as integers without decimal places by default, even if you input
decimal places. However, the exact metronome mark value you input is always reflected in
playback.
AFTER COMPLETING THIS TASK
You can lengthen/shorten gradual tempo changes.
RELATED LINKS
Tempo marks on page 1203
Time track on page 530
Tempo mark components on page 1210
Gradual tempo changes on page 1215
Metronome marks on page 1212
Lengthening/Shortening gradual tempo changes on page 1215
Hiding/Showing decimal places for metronome marks on page 1214
Changing the style of gradual tempo changes on page 1216

Inputting tempo marks with the panel
You can input tempo marks using the Tempo panel, both during note input and by adding them
to existing music.
NOTE
●

These steps describe inputting with the default mouse input preference Create item at
selection.

●

You cannot specify decimal places for metronome marks using the panel. You can specify
decimal places using the popover or by changing the metronome mark value of existing
tempo marks.

PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a tempo mark. If you
want to input a gradual tempo change across a duration, select items that span that
duration.

In the Notations toolbox, click Tempo to show the Tempo panel.
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3.

In the Tempo panel, click the tempo mark you want.
TIP
If you want Dorico Pro to calculate the metronome mark for you, you can click Tap in the Tap
Tempo section multiple times at the required speed.

4.

Optional: Select a modifier from the available options.
NOTE
You can only add modifiers to a Gradual Tempo Change or a Relative Tempo Change.

RESULT
During note input, tempo marks are input at the caret position. Gradual tempo changes, such as
rallentando, are also input at the caret position with a default duration of a quarter note. Gradual
tempo changes do not extend as you input notes.
When adding tempo marks to existing music, they are added at the rhythmic position of the
earliest selected item. Gradual tempo changes span the duration of the selected items.
AFTER COMPLETING THIS TASK
You can lengthen/shorten gradual tempo changes.
RELATED LINKS
Tempo marks on page 1203
Lengthening/Shortening gradual tempo changes on page 1215
Mouse input settings on page 164
Hiding/Showing decimal places for metronome marks on page 1214
Changing the metronome mark value on page 1212
Changing the style of gradual tempo changes on page 1216

Input methods for bars and barlines
You can input both bars and barlines with the keyboard by using the bars and barlines popover,
and also with the mouse by using the available options in the Bars and Barlines panel.
Additionally, you can input bars using the system track, which allows you to input other rhythmic
durations, that is, a specified beat region.
Normally you do not need to create bars in Dorico Pro, as they are created automatically as
needed when you input music. However, you can add bars in advance if, for example, you are
copying or arranging an existing piece of music.
RELATED LINKS
Bars on page 631
Barlines on page 636
System track on page 323
Inputting bar rests into specific voices on page 191
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Bars and barlines popover
The following tables contain examples of what you can enter into the bars and barlines popover
to add and delete bars and beats, and the entries you can use to input the different barlines
available.
You can open the bars and barlines popover in Write mode in any of the following ways when
either an item is selected or the caret is active:
●

Press Shift-B .

●

Choose Write > Create Bar or Barline.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Bars and barlines popover with an
example entry for inputting bars

Bars and barlines popover with an
example entry for a barline

Bars and Barlines button in the
Notations toolbox

Bars
Example action

Popover entry

Add two bars

2 or +2

Add fourteen bars

14 or +14

Delete one bar

–1

Delete six bars

–6

Add a bar rest

rest

Delete empty bars at the end of the flow

trim

You can specify a number of beats that you want to add/delete by entering the number of beats
you want followed by either the number that corresponds to the beat unit, such as 5 for eighth
notes, or the letter that corresponds to the beat unit, such as h for half notes. When using
numbers for both the number of beats and the beat unit, you must separate them with a space
or hyphen. You can also specify beats in the form of a time signature, such as 3/4 for three
quarter note beats.
Beats
Example action

Popover entry

Add two quarter note beats

2q, 2-6, 2 6, or 2/4

Add two half note beats

2h, 2-7, 2 7, 2/2, or 4/4

Add one whole note beat

1w, 1-8, 1 8, or 4/4
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Example action

Popover entry

Add four eighth note beats

4e, 4-5, 4 5, 4/8, or 2/4

Add two 16th note beats

2x, 2-4, 2 4, 2/16, or 1/8

Delete two quarter note beats

–2q, -2-6, -2 6, or -2/4

These lists are not comprehensive, as you can add and delete any number of bars and beats
using the popover, including specifying beat units using the numbers one to nine as you would
to specify durations when inputting notes. These tables are intended to illustrate how you can
structure your entry to input and delete bars and beats, and input bar rests.
Barlines
Type of barline

Popover entry

Normal (Single)

|, single, or normal

Double

|| or double

Final

|] or final

Dashed

:, dash, or dashed

Tick

‘ or tick

Short

, or short

Short (top)

shorttop

Thick

thick

Triple

triple

Start repeat

|: or start

End repeat

:| or end

End/Start repeat

:|:, :||:, end-start, or endstart

RELATED LINKS
Inputting bar rests into specific voices on page 191
Bars on page 631
Barlines on page 636
Deleting bars/beats on page 631
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Bars and Barlines panel
The Bars and Barlines panel allows you to input bars, bar rests, and different types of barlines. It
is located on the right of the window in Write mode.
●

You can hide/show the Bars and Barlines panel by clicking Bars and Barlines in the
Notations toolbox on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The panel contains the following sections:
Insert Bars
Allows you to determine how many bars you want to insert and where to insert them,
such as at the end of the flow.
Insert Bar Rest
Allows you to insert a bar rest.
Create Barline
Contains the different barlines you can input.
RELATED LINKS
Hiding/Showing panels on page 24

Inputting bars/beats with the popover
You can input bars/beats using the bars and barlines popover, both during note input and by
adding them to or inserting them into existing music.
PREREQUISITE
If you want to input bars, you have input a time signature.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing barline after which you want to add bars/beats.

●

Select an existing item before which you want to add bars/beats.

2.

Press Shift-B to open the bars and barlines popover.

3.

Enter the number of bars/beats you want to input.
For example, enter 2 to input two bars or 2q to input two quarter note beats.

4.

Press Return to close the popover.

RESULT
The number of bars or beats specified is input.
During note input, bars/beats are input from the caret position. If the caret is in the middle of the
bar when inputting bars, sufficient beats are added to ensure that the final bar created has the
correct number of beats. The caret position stays at its previous position so you can continue
inputting music from the same position.
When you add bars/beats to existing music, they are added after a selected barline and before a
selected item, including time signatures.
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TIP
Another way to add bars is by choosing a note value, such as a whole note when in a 4/4 time
signature, and pressing Space repeatedly during note input.

RELATED LINKS
Bars and barlines popover on page 235
Bars on page 631
Inputting time signatures with the popover on page 226

Inputting bars with the panel
You can input bars using the Bars and Barlines panel, both during note input and by adding
them to existing music.
PREREQUISITE
You have input a time signature.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing barline after which you want to input bars.

●

Select an existing item before which you want to input bars.

2.

In the Notations toolbox, click Bars and Barlines to show the Bars and Barlines panel.

3.

In the Insert Bars section of the Bars and Barlines panel, change the number of bars you
want to input by changing the value in the value field.

4.

Select one of the following options for where you want to input bars:
●

Start of Flow: Bars are input at the beginning of the flow.

●

Start of Selection: Bars are input from the selected note or rest.

●

End of Flow: Bars are input at the end of the flow.
NOTE
If you want to input bars from the caret position, make sure that you have selected Start
of Selection from the menu.

5.

Click Insert Bars.

RESULT
The number of bars specified is input.
During note input, bars are input from the caret position.
If you selected Start of Selection, bars are input directly after a selected barline, and directly
before a selected note, bar, or time signature.
TIP
Another way to add bars is by choosing a note value, such as a whole note when in a 4/4 time
signature, and pressing Space repeatedly during note input.
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RELATED LINKS
Bars on page 631
Inputting time signatures with the panel on page 227

Inputting bars/beats with the system track
You can add bars/beats within existing music, for example, if you decide you want to repeat
several bars before the next section. You can add whole bars and you can add just a few beats.
NOTE
You cannot use the system track during note input.
PREREQUISITE
The system track is shown.
PROCEDURE
1.

In the system track, select the region whose duration you want to insert.
For example, if you want to insert two bars, select two bars in the system track immediately
before where you want the two new bars to be input.

2.

Click Add above the system track.

Add button above the system track

The Add button is highlighted when you hover
over it

RESULT
The rhythmic duration selected in the system track is added immediately after the end of the
selection. Existing music after the selection is pushed back after the inserted bars/beats.
RELATED LINKS
System track on page 323

Inputting barlines with the popover
You can input barlines using the bars and barlines popover, both during note input and by
adding them to existing music. You can also change the type of existing barlines.
PREREQUISITE
If you want to input barlines onto single staves only, you have input an independent key
signature on those staves.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a barline. If you want to
input a barline on a single staff, select an item that belongs to that staff only.

2.

Optional: If you want to input barlines onto multiple specific staves at once, extend the caret
to those staves.

3.

Press Shift-B to open the bars and barlines popover.

4.

Enter the barline you want into the popover.
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For example, enter || for a double barline.
5.

Input the barline and close the popover in one of the following ways:
●

To input a barline on all staves, press Return .

●

To input a barline only on the selected staff or staves across which the caret extends,
press Alt/Opt-Return .
NOTE
You can only input barlines onto single staves that already have an independent time
signature.

6.

Press Return to close the popover.

RESULT
During note input, barlines are input at the caret position.
When you add barlines to existing music, they are added at the rhythmic position of the earliest
selected item. They appear to the right of clefs and to the left of other items. If you selected an
existing barline, the new barline directly replaces the existing one.
Surrounding music automatically adjusts to accommodate the barline. For example, note
grouping, rests, and tied notes all adjust if necessary.
NOTE
Normal barlines that you have input directly, such as to replace an existing double barline, are
still considered explicit barlines and break multi-bar rests. Deleting barlines resets them
completely.

RELATED LINKS
Bars and barlines popover on page 235
Barlines on page 636
Inputting notes on page 172
Inputting time signatures with the popover on page 226
Extending the caret to multiple staves on page 171
Deleting barlines on page 640

Inputting barlines with the panel
You can input barlines using the Bars and Barlines panel, both during note input and by adding
them to existing music. You can also change the type of existing barlines.
NOTE
These steps describe inputting with the default mouse input preference Create item at
selection.
PREREQUISITE
If you want to input barlines onto single staves only, you have input an independent key
signature on those staves.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a barline. If you want to
input a barline on a single staff, select an item that belongs to that staff only.
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2.

In the Notations toolbox, click Bars and Barlines to show the Bars and Barlines panel.

3.

Input the barline you want in one of the following ways:
●

To input a barline on all staves, click it in the Bars and Barlines panel.

●

To input a barline on the selected staff only, Alt/Opt -click it in the Bars and Barlines
panel.
NOTE
You can only input barlines onto single staves that already have an independent time
signature.

RESULT
During note input, barlines are input at the caret position.
When you add barlines to existing music, they are added at the rhythmic position of the earliest
selected item. They appear to the right of clefs and to the left of other items. If you selected an
existing barline, the new barline directly replaces the existing one.
Surrounding music automatically adjusts to accommodate the barline. For example, note
grouping, rests, and tied notes all adjust if necessary.
NOTE
Normal barlines that you have input directly, such as to replace an existing double barline, are
still considered explicit barlines and break multi-bar rests. Deleting barlines resets them
completely.

RELATED LINKS
Barlines on page 636
Bars and barlines popover on page 235
Inputting notes on page 172
Mouse input settings on page 164

Input methods for dynamics
You can input dynamics with the keyboard by using the dynamics popover, and with the mouse
by using the Dynamics panel.
RELATED LINKS
Dynamics on page 760
Inputting dynamics with the popover on page 244
Inputting dynamics with the panel on page 245
Niente hairpins on page 769
Adding modifiers to existing dynamics on page 771

Dynamics popover
The table contains examples of what you can enter into the dynamics popover to input the
different dynamics available.
You can open the dynamics popover in Write mode in any of the following ways when either an
item is selected or the caret is active:
●

Press Shift-D .
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●

Select an existing dynamic and press Return .

●

Choose Write > Create Dynamic.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Dynamics button in the Notations toolbox
Dynamics popover with an example entry

Dynamic or modifier

Popover entry

pianissimo: 

pp

piano: 

p

mezzo piano: 

mp

mezzo forte: 

mf

forte: 

f

fortissimo: 

ff

subito

subito, sub, or sub.

possibile

possibile, poss, or poss.

poco

poco

molto

molto

più

piu or più

meno

meno

mosso

mosso

crescendo: 

<

cresc. (text)

cresc

diminuendo: 

>

dim. (text)

dim

crescendo then diminuendo messa di voce:  <>
diminuendo then crescendo messa di voce: 
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Dynamic or modifier

Popover entry

niente hairpins that start/end with a small circle o< or >o
niente hairpins that start/end with the letter “n” n< or >n
sforzando: 

sfz

rinforzando: 

rfz

This list is not comprehensive as you can enter anything as a dynamic modifier. It is intended to
illustrate how you can structure your entry to input different types of dynamics.
TIP
You can input hairpins directly into the score without the popover by pressing < for a crescendo
hairpin and > for a diminuendo hairpin.
You can change the appearance of gradual dynamics project-wide on the Dynamics page in
Engraving Options, or individually by activating Gradual style in the Dynamics group of the
Properties panel, and selecting one of the available options.

Inputting modifiers into the dynamics popover
You can enter modifiers into the dynamics popover, such as poco, molto, subito, espressivo, or
dolce. It appears in the correct italic font beside the dynamic. However, you must also enter an
accompanying immediate dynamic, such as p or f, and separate the two with a space, for
example, f molto or p espressivo.
You can hide immediate dynamics if you only want to show the modifier.
RELATED LINKS
Dynamics on page 760
Dynamic modifiers on page 771
Niente hairpins on page 769
Hiding immediate dynamics on page 772

Dynamics panel
The Dynamics panel contains the different dynamics available in Dorico Pro, including gradual
dynamics and dynamic modifiers, such as poco and possibile.
●

You can hide/show the Dynamics panel by clicking Dynamics in the Notations toolbox on the
right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The Dynamics panel contains the following sections:
Immediate Dynamics
Contains dynamics such as  and , and modifiers, such as subito and possibile.
Available modifiers are shown at the top of the section in boxes.
You can only input modifiers alongside a dynamic.
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Gradual Dynamics
Contains dynamics such as  and , and modifiers, such as poco and niente. Available
modifiers are shown at the top of the section in boxes.
You can only input modifiers alongside a dynamic.
Force/Intensity of Attack
Contains dynamics such as  and .
Combined Dynamics
Allows you to create your own combinations of dynamics, such as . The controls
allow you to increase and decrease the dynamic on each side, and to swap their order.

Combined Dynamics section of the Dynamics panel

Inputting dynamics with the popover
You can input dynamics and modifiers using the dynamics popover, both during note input and
by adding them to existing notes. You can also input different dynamics into each voice
independently in multiple-voice contexts.
TIP
You can also change dynamics during note input by following these steps when the caret is at the
rhythmic position of the dynamic you want to change.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
NOTE
If you want to input voice-specific dynamics, the caret must be active.

●

Select an item at the rhythmic position where you want to input dynamics. If you want to
input dynamics across a duration, select items that span that duration.

2.

Optional: If you want to input dynamics onto multiple staves at once, extend the caret to
those staves.

3.

Press Shift-D to open the dynamics popover.

4.

Enter the dynamic you want into the popover.
For example, p, p<f>p, or f>.

5.

Input the dynamics and close the popover in one of the following ways:
●

To input the dynamics for all voices on the staff, press Return .

●

During note input, input the dynamics only into the voice indicated by the caret indicator
by pressing Alt/Opt-Return .

244
Dorico Pro 3.1.10

Write mode
Notations input
Open-ended dynamics, such as p<, automatically extend during note input as you continue
inputting notes, or if you advance the caret by pressing Space .
6.

Optional: During note input, stop open-ended dynamics by pressing ? or by opening the
dynamics popover again and inputting another immediate dynamic, such as f.

RESULT
The specified dynamics are input. They are positioned according to your settings on the
Dynamics page in Engrave > Engraving Options. Voice-specific dynamics are placed below the
staff by default, even if they are input into an up-stem voice.
Adjoining dynamics, or dynamics that were input together or in sequence, are automatically
grouped together, both during note input and when adding dynamics to existing notes.
During note input, dynamics are input at the caret position, and extend automatically if you
included an open-ended gradual dynamic. Voice-specific dynamics are input in the voice
indicated by the quarter note symbol beside the caret.
When you add dynamics to existing notes, immediate dynamics are added to the first note in the
selection while gradual dynamics are added across the selection.
NOTE
●

If you entered a dynamic phrase into the popover during note input, such as p<f>p, each
dynamic and hairpin lasts a quarter note (crotchet) by default. You can lengthen/shorten
gradual dynamics and groups of dynamics later.

●

Some modifiers, such as molto, appear before immediate dynamics rather than after them,
even if you do not enter them in that order. This follows the generally accepted practice for
the placement of that text.
You can add modifiers before and after existing dynamics. You can also hide immediate
dynamics later if you only want to show the modifier.

AFTER COMPLETING THIS TASK
You can move dynamics within dynamic phrases and change the placement of dynamics relative
to the staff.
RELATED LINKS
Extending the caret to multiple staves on page 171
Dynamics on page 760
Dynamics lanes on page 513
Groups of dynamics on page 782
Voice-specific dynamics on page 769
Dynamic modifiers on page 771
Moving dynamics rhythmically on page 763
Lengthening/Shortening gradual dynamics and groups of dynamics on page 773
Hiding immediate dynamics on page 772
Changing the staff-relative placement of items on page 330

Inputting dynamics with the panel
You can input dynamics and modifiers using the Dynamics panel, both during note input and by
adding them to existing notes. You can also input different dynamics into each voice
independently in multiple-voice contexts.
NOTE
●

You can also change dynamics during note input by following these steps when the caret is
at the rhythmic position of the dynamic you want to change.
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●

These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
NOTE
If you want to input voice-specific dynamics, the caret must be active.

●

Select an item at the rhythmic position where you want to input dynamics. If you want to
input dynamics across a duration, select items that span that duration.

2.

In the Notations toolbox, click Dynamics to show the Dynamics panel.

3.

Input the dynamics you want in one of the following ways:
●

To input dynamics for all voices on the staff, click them in the Dynamics panel.

●

During note input, input the dynamics only into the voice indicated by the caret indicator
by Alt -clicking them in the Dynamics panel.

NOTE

4.

●

If you want to add expressive or qualifying text to the dynamics, do not deselect them.

●

When inputting voice-specific dynamics, you can release Alt once you have input the
dynamic level, such as .

●

Gradual dynamics have a default duration of a quarter note. You can lengthen/shorten
gradual dynamics later.

Optional: In the Dynamics panel, click the expressive/qualifying texts you want in the
Immediate Dynamics and Gradual Dynamics sections.

RESULT
The specified dynamics are input. They are positioned according to your settings on the
Dynamics page in Engrave > Engraving Options. Voice-specific dynamics are placed below the
staff by default, even if they are input into an up-stem voice.
Adjoining dynamics, or dynamics that were input together or in sequence, are automatically
grouped together, both during note input and when adding dynamics to existing notes.
During note input, dynamics are input at the caret position. Voice-specific dynamics are input in
the voice indicated by the quarter note symbol beside the caret.
When you add dynamics to existing notes, immediate dynamics are added to the first note in the
selection while gradual dynamics are added across the selection.
NOTE
●

Some modifiers, such as molto, appear before immediate dynamics rather than after them,
even if you do not enter them in that order. This follows the generally accepted practice for
the placement of that text.
You can add modifiers before and after existing dynamics. You can also hide immediate
dynamics later if you only want to show the modifier.

●

You can also input gradual dynamics by clicking the gradual dynamic you want in the
Dynamics panel when nothing is selected in the music area. Then click and drag to input the
gradual dynamic and extend it to the length you want.
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AFTER COMPLETING THIS TASK
You can move dynamics within dynamic phrases and change the placement of dynamics relative
to the staff.
RELATED LINKS
Dynamics on page 760
Hiding immediate dynamics on page 772
Mouse input settings on page 164

Input methods for chord symbols
You can input chord symbols in Dorico Pro with the computer keyboard and any connected MIDI
keyboard.
RELATED LINKS
Chord symbols on page 695
Inputting chord symbols on page 251
Project-wide engraving options for chord symbols on page 696
Navigation during chord symbol input on page 250

Chord symbols popover
The following tables contain examples of what you can enter into the chord symbols popover to
input the different possible chord symbol components. You can enter them in any combination.
You can open the chord symbols popover in Write mode in any of the following ways when either
an item is selected or the caret is active:
●

Press Shift-Q .

●

Select an existing chord symbol and press Return .

●

Choose Write > Create Chord Symbol.

●

Click Chord Symbols in the Notations toolbox.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.
When inputting global chord symbols, the icon on the left-hand side of the popover matches the
corresponding button in the Notations toolbox. When inputting local chord symbols, the icon on
the left-hand side of the popover appears smaller and includes the icon for a solo player.

Chord symbols popover with an
example entry for a global chord
symbol

Chord symbols popover with an
example entry for a local chord
symbol

Chord Symbols button in the
Notations toolbox

NOTE
You can combine multiple types of entries to create more complex chord symbols if you enter
them one after another into the chord symbols popover without spaces between them. For
example, enter Eblocrian for the following chord symbol:
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Chord symbol roots
Type of chord symbol root

Popover entry

English note names

C, Db, F#, B, and so on

C, D♭, F♯, B, and so on
German note names

C, Des, Fis, H, and so on

C, D♭, F♯, H, and so on
Fixed-do solfège

do, reb, fa, fa#, ti, and so on

C, D♭, F, F♯, B, and so on
Nashville numbers representing scale degrees

1, 2b, 4#, 7, and so on

Assuming C major:
C, D♭, F♯, B, and so on

Chord symbol qualities
Chord symbol quality

Popover entry

Major

maj, M, ma, or nothing after entering the root.

Minor

m, min, or mi

Diminished

dim, di, or o

Augmented

aug, au, ag, or +

Half-diminished

half-dim, halfdim, or hd

6/9

6/9, 69, or %

Chord symbol intervals
Interval

Popover entry

Major 7th

^7 or ^

Major 9th

^9, maj9, or 9maj7

Chord symbol alterations
Type of chord symbol alteration

Popover entry

Alterations

b5, #9, and so on

Added notes

add#11, addF#, addBb, and so on
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Type of chord symbol alteration

Popover entry

Suspensions

sus4, sus9, and so on

Omissions

omit3, no7, and so on

Chord symbols with altered bass notes
Example altered bass note chord symbols

Popover entry

G7/D

G7,D or Gmaj7,D

C(♭5)/E♭

CMb5/Eb or Cmajb5/Eb

Fm/D♯

Fm/D# or Fmi/D#

Polychord chord symbols
Example polychord chord symbols

Popover entry

G/E

G;E or Gmaj;E

Cmaj7/D

CM7|D or Cmaj7|D

Fm/D♯

Fm|D# Fmi|D#

No chord symbols
No chord symbol

Popover entry

No chord

N.C., NC, no chord, or none

Modal chord symbols
Modal chord symbol

Popover entry

Ionian

ionian

Dorian

dorian

Phrygian

phrygian

Lydian

lydian

Mixolydian

mixolydian

Aeolian

aeolian

Locrian

locrian
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Modal chord symbol

Popover entry

Melodic minor

melodicminor

Harmonic minor

harmonicminor

Whole tone

wholetone

Octatonic or diminished half-whole

diminishedhalfwhole,
diminishedsemitonetone,
octatonichalfwhole, or
octatonicsemitonetone

Octatonic or diminished whole-half

diminishedwholehalf,
diminishedtonesemitone,
octatonicwholehalf, or
octatonictonesemitone

This list is not comprehensive, as there are many possible chord symbols. It is intended to
illustrate the different components you can use to input different chord symbols.
NOTE
The appearance of the resulting chord symbols depends on the options you have set on the
Chord Symbols page in Engrave > Engraving Options. The structure of your entry in the chord
symbols popover is not considered. For example, entering a C major chord as C, Cmaj, or CM
results in the same chord symbol.

RELATED LINKS
Chord symbols on page 695

Navigation during chord symbol input
You can input multiple chord symbols without re-opening the popover each time by manually
advancing it to other positions.

Navigating with a computer keyboard
You can move the chord symbols popover to input chord symbols on other notes without having
to close and reopen the popover on each note.

Popover navigation

Key command

Advance the popover to the next beat.

Space

Move the popover back to the previous beat.

Shift-Space

Advance the popover to the start of the next
bar.

Tab

Move the popover back to the start of the
previous bar.

Shift-Tab
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Popover navigation

Key command

Move the cursor and popover to one of the
following positions, whichever is closest:

Right Arrow / Left Arrow

●

Next/Previous note

●

Next/Previous rest

●

Next/Previous rhythmic grid position

Move the popover to the next/previous chord
symbol.

Ctrl/Cmd-Right Arrow / Ctrl/Cmd-Left Arrow

Navigating with a MIDI keyboard
When inputting chord symbols using a MIDI keyboard, by default the popover advances
automatically to the next beat after you play a chord. You can change this behavior using the
Advance during chord symbol input via MIDI keyboard options on the MIDI Input page in
Write > Note Input Options.
You can define specific keys or buttons on your MIDI keyboard to trigger different navigation
behaviors. Use the MIDI Learn button on the Key Commands page in Preferences to assign
specific keys to the Note Input > Advance Chord Symbol Input commands.
RELATED LINKS
Key Commands page in the Preferences dialog on page 63
Assigning MIDI commands on page 67
Assigning key commands on page 66

Chord symbol input options for MIDI keyboards
There are different possible settings for how Dorico Pro interprets the notes you press on your
MIDI keyboard when inputting chord symbols.
You can find these options on the Chord Symbols page in Write > Note Input Options. The
available options include:
●

Whether you want Dorico Pro to consider the inversion in which you play a given chord, or
write the chord symbol as if it had been played in root position

●

Whether you want Dorico Pro to notate omissions. For example, if you play C and E, it could
be notated as “C” or “C(omit5)”

●

How you want Dorico Pro to notate added notes and suspensions

●

How you want Dorico Pro to handle complex enharmonic relationships between roots and
altered bass notes

RELATED LINKS
Note Input Options dialog on page 162

Inputting chord symbols
You can input chord symbols using the chord symbols popover, both for all instruments or only
for individual instruments. You can also open the chord symbols popover during note input;
however, inputting a chord symbol stops note input.
PREREQUISITE
If you want to input chord symbols using a MIDI device, you have connected the MIDI device you
want to use.
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PROCEDURE
1.

In Write mode, select an item at the rhythmic position where you want to input a chord
symbol.

2.

Press Shift-Q to open the chord symbols popover.
NOTE
If you selected an item on a staff that has local chord symbols at earlier rhythmic positions,
the chord symbols popover is automatically set to input local chord symbols when it opens.

3.

Optional: Change the type of chord symbol you want to enter in one of the following ways:
●

To input local chord symbols, press Alt/Opt-L .

●

To input global chord symbols, press Alt/Opt - G .

The popover icon updates to show the current type.

Chord symbols popover when inputting a global
chord symbol

4.

5.

Chord symbols popover when inputting a local
chord symbol

Enter the chord symbol you want into the chord symbols popover in any of the following
ways:
●

Enter the appropriate letters and numbers using the computer keyboard.

●

Play the chord using a MIDI keyboard.

Optional: Press Space to advance the popover to the next beat according to the current
time signature.
You can also navigate the popover forwards and backwards by different amounts.

6.

Press Return to close the popover.

RESULT
The chord symbol specified is input. If you selected an item on a staff that was not already set to
show chord symbols, it is automatically updated to show them.
Global chord symbols apply to all instruments in the project and appear on all staves set to show
chord symbols. Local chord symbols only apply to the selected staff. Local chord symbols always
appear, even if global chord symbols exist at the same rhythmic positions.
NOTE
The chord symbol may look different to what you entered into the popover. For example,
entering D|C7 may result in two chords placed directly above each other, or two chords placed
beside each other, depending on your settings on the Chord Symbols page in Engrave >
Engraving Options.
AFTER COMPLETING THIS TASK
You can hide/show chord symbols above specific staves and hide/show chord diagrams
alongside them.
RELATED LINKS
Chord symbols on page 695
Enabling chord symbol playback on page 536
Hiding/Showing chord symbols on page 706
Hiding/Showing chord diagrams on page 716
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Disabling MIDI input devices on page 210

Inputting polychord chord symbols
Polychord chord symbols indicate that multiple different chords, commonly two, are played
simultaneously. You can input polychords when inputting chord symbols with a MIDI keyboard.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Play the first chord of the polychord with one hand.
Keep the keys of the first chord depressed.

3.

Play the second chord with the other hand.

RESULT
The two chords you played are input as a polychord chord symbol.
TIP
You can also input polychords by entering the two chords separated by a semicolon or pipe
character into the chord symbols popover.

RELATED LINKS
Chord symbols popover on page 247
Chord symbol input options for MIDI keyboards on page 251

Indicating root notes in chord symbols
You can indicate the root note of chord symbols when inputting chord symbols with a MIDI
keyboard.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Indicate the root note of a chord symbol in any of the following ways when using a MIDI
keyboard:
●

First play the root with one finger, and then play the remaining notes of the chord while
still holding down the root.

●

Play all the notes of the chord together, then release them all, then replay the root note.
TIP
To input a chord symbol that consists only of the root note, just play a single note.

RELATED LINKS
Chord symbols popover on page 247
Chord symbol input options for MIDI keyboards on page 251
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Indicating altered bass notes in chord symbols
You can indicate that chords have altered bass notes when inputting chord symbols with a MIDI
keyboard.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Indicate which note is the altered bass note of a chord in any of the following ways on your
MIDI keyboard:
●

Play all notes of the chord together with the altered bass note at the bottom.

●

Play the chord and its altered bass note separately: Hold down the keys for the chord,
then play the altered bass note while keeping the rest of the keys of the chord
depressed.

RELATED LINKS
Chord symbols popover on page 247
Chord symbol input options for MIDI keyboards on page 251

Inputting chord symbol regions
You can input specific regions in which you want to show chord symbols, for example, if an
instrument that does not need chord symbols for most of the project has an improvisation
section that requires chord symbols to be shown.
PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select the region in which you want to show chord symbols.

Choose Write > Create Chord Symbol Region.

RESULT
During note input, chord symbol regions are input spanning the duration of the selected note or
item, which is usually the last input note. When adding chord symbol regions to existing music,
they span the selected duration.
The player holding the corresponding instrument is automatically set to show chord symbols in
chord symbol regions and slash regions, even if it was set to hide all chord symbols before.
RELATED LINKS
Chord symbol regions on page 707
Hiding/Showing chord symbols on page 706

Input methods for clefs and octave lines
You can input clefs and octave lines with the keyboard by using the clefs and octave lines
popover, and also with the mouse by using the Clefs panel.
Clefs and octave lines share the same popover and panel as both affect the pitch and register of
notes.
RELATED LINKS
Clefs on page 725
Octave lines on page 732
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Clefs and octave lines popover
The following tables contain the entries for the clefs and octave lines popover that you can use to
input the different clefs and octave lines available.
You can open the clefs and octave lines popover in Write mode in any of the following ways when
either an item is selected or the caret is active:
●

Press Shift-C .

●

Select an existing clef or octave line and press Return .

●

Choose Write > Create Clef.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Clefs and octave lines popover
with an example entry for a clef

Clefs and octave lines popover
with an example entry for an
octave line

Clefs button in the Notations
toolbox

Clefs
Type of clef

Popover entry

Treble G clef

g, G, sol, or treble

Bass F clef

f, F, fa, or bass

Tenor C clef

ct, CT, ut4, or tenor

Alto C clef

ca, CA, ut3, or alto

Treble G clef, octave below

g8ba, G8ba, g8d, G8d, treble8ba, or treble8d

Treble G clef, two octaves below

g15ba, G15ba, g15d, G15d, treble15ba, or
treble15d

Treble G clef, octave above

g8va, G8va, g8u, G8u, treble8va, or treble8u

Treble G clef, two octaves above

g15ma, G15ma, g15u, G15u, treble15ma, or
treble15u

Alto C clef, octave below

ca8ba, CA8ba, ca8d, CA8d, alto8ba, or alto8d

Tenor C clef, octave below

ct8ba, CT8ba, ct8d, CT8d, tenor8ba, or
tenor8d

Bass F clef, octave below

f8ba, F8ba, f8d, F8d, bass8ba, or bass8d

Bass F clef, two octaves below

f15ba, F15ba, f15d, F15d, bass15ba, or
bass15d
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Type of clef

Popover entry

Bass F clef, octave above

f8va, F8va, f8u, F8u, bass8va, or bass8u

Bass F clef, two octaves above

f15ma, F15ma, f15u, F15u, bass15ma, or
bass15u

Unpitched percussion

perc

4-string tablature

tab4

6-string tablature

tab6

Baritone bass clef

baritonebass

Baritone clef

baritone or ut5

Mezzo-soprano clef

mezzo or ut2

Soprano C clef

soprano or ut1

Sub-bass clef

subbass

Invisible clef

invisible

NOTE
More clefs are available in the Clefs panel, including the Indian drum clef and rectangular
percussion clef.

Octave lines
Function of octave line

Popover entry

Shifts notes up by 1 octave.

8va, 8, 8u, or 1u

Shifts notes up by 2 octaves.

15ma, 15, 15u, or 2u

Shifts notes up by 3 octaves.

22ma, 22, 22u, or 3u

Shifts notes down by 1 octave.

8ba, 8vb, 8d, or 1d

Shifts notes down by 2 octaves.

15ba, 15vb, 15d, or 2d

Shifts notes down by 3 octaves.

22ba, 22vb, 22d, or 3d

Loco indication

loco

End of octave line

| or stop

For example, enter stop to specify where an
octave line ends during note input.
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RELATED LINKS
Clefs on page 725
Octave lines on page 732

Clefs panel
The Clefs panel contains the different types of clefs and octave lines available in Dorico Pro,
including uncommon and archaic clefs.
●

You can hide/show the Clefs panel by clicking Clefs in the Notations toolbox on the right of
the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The Clefs panel contains the following sections:
Common Clefs
Contains the clefs you are most likely to need, including treble clef and bass clef.
Uncommon Clefs
Contains less frequently used clefs, such as an invisible clef and French violin clef.
Archaic Clefs
Contains clefs that are rarely used any more, such as the mezzo-soprano clef and subbass clef.
Octave Lines
Contains octave lines, indicating up to three octaves above and below, and a loco line.

Inputting clefs with the popover
You can input clefs using the clefs and octave lines popover, both during note input and by
adding them to existing music. You can also use the popover to change the type of existing clefs.
NOTE
●

In Dorico Pro, you cannot hide clefs. Therefore, if you do not want to show any clef, you must
input an invisible clef.

●

Many instruments in Dorico Pro have different types that show alternative clefs by default.
You can select the appropriate instrument type from the instrument picker when adding or
changing instruments.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a clef.

2.

Optional: If you want to input clefs onto multiple staves at once, extend the caret to those
staves.

3.

Press Shift-C to open the clefs and octave lines popover.

4.

Enter the appropriate entry for the clef you want into the popover.
For example, enter bass or G8ba.

5.

Press Return to close the popover.
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RESULT
During note input, clefs are input at the caret position. Note input continues after inputting the
clef, so you can continue inputting notes and clefs as required.
When you add clefs to existing music, clefs are added directly before a selected notehead, and
apply to all notes on that staff until the next clef, or the end of the flow.
Clefs apply to all notes on the staff until the next clef or the end of the flow, whichever comes
first.
RELATED LINKS
Clefs on page 725
Extending the caret to multiple staves on page 171
Setting different clefs for concert/transposed pitch on page 729
Hiding/Showing clefs according to layout transpositions on page 730
Changing instruments on page 118
Adding instruments to players on page 116

Inputting clefs with the panel
You can input clefs using the Clefs panel, both during note input and by adding them to existing
music.
NOTE
●

In Dorico Pro, you cannot hide clefs. Therefore, if you do not want to show any clef, you must
input an invisible clef.

●

These steps describe inputting with the default mouse input preference Create item at
selection.

●

Many instruments in Dorico Pro have different types that show alternative clefs by default.
You can select the appropriate instrument type from the instrument picker when adding or
changing instruments.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a clef.

2.

In the Notations toolbox, click Clefs to show the Clefs panel.

3.

In the Clefs panel, click the clef you want.

RESULT
During note input, clefs are input at the caret position. Note input continues after inputting the
clef, so you can continue inputting notes and clefs as required.
When you add clefs to existing music, clefs are added directly before a selected notehead, and
apply to all notes on that staff until the next clef, or the end of the flow.
Clefs apply to all notes on the staff until the next clef or the end of the flow, whichever comes
first.
RELATED LINKS
Clefs on page 725
Mouse input settings on page 164
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Inputting octave lines with the popover
You can input octave lines using the clefs and octave lines popover, both during note input and
by adding them to existing music. You can also input octave lines only into specific voices in
multiple-voice contexts.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select the notes to which you want to add an octave line. If you want to add an octave
line for a single voice, only select notes in that voice.

2.

Optional: If you want to input octave lines onto multiple staves at once, extend the caret to
those staves.

3.

Press Shift-C to open the clefs and octave lines popover.

4.

Enter the appropriate entry for the octave line you want into the popover.
For example, enter 8va for an octave line that shifts notes up one octave.

5.

6.

Input the octave line and close the popover in one of the following ways:
●

To input an octave line for all voices on the staff, press Return .

●

To input an octave line only for the currently selected voice, press Alt/Opt-Return .

Optional: During note input, press Space to advance the caret and extend the octave line.
The octave line also extends automatically as you continue inputting notes.

7.

Optional: During note input, stop any octave line by opening the clefs and octave lines
popover again and entering | or stop.

RESULT
During note input, octave lines are input from the caret position. When you stop octave lines,
they end at the caret position.
When you add octave lines to existing notes, they are added either above or below your
selection, depending on whether the octave line indicates that notes are played higher or lower
than notated.
TIP
You can also lengthen/shorten octave lines after they have been input.

RELATED LINKS
Clefs and octave lines popover on page 255
Octave lines on page 732
Lengthening/Shortening octave lines on page 733
Extending the caret to multiple staves on page 171

Inputting octave lines with the panel
You can input octave lines using the Clefs panel, both during note input and by adding them to
existing music. You can also input octave lines only into specific voices in multiple-voice contexts.
NOTE
These steps describe inputting with the default mouse input preference Create item at
selection.
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PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select the notes to which you want to add an octave line. If you want to add an octave
line for a single voice, only select notes in that voice.

2.

In the Notations toolbox, click Clefs to show the Clefs panel.

3.

Input the octave line you want in one of the following ways:
●

To input an octave line for all voices on the staff, click it in the Clefs panel.

●

To input an octave line only for the currently selected voice, Alt -click it in the Clefs
panel.

Alternatively, when adding octave lines to existing notes, you can click the octave line you
want in the Clefs panel first, and then click and drag it to the length you want.
RESULT
During note input, octave lines are input at the caret position. However, if you input notes using
the mouse, octave lines do not automatically extend as you continue inputting notes.
When you add octave lines to existing notes, they are added either above or below your
selection, depending on whether the octave line indicates that notes are played higher or lower
than notated.
TIP
You can also lengthen/shorten octave lines after they have been input.

RELATED LINKS
Octave lines on page 732
Lengthening/Shortening octave lines on page 733
Mouse input settings on page 164

Input methods for holds and pauses
You can input holds and pauses with the keyboard by using the holds and pauses popover in
Write mode, and with the mouse by using the Holds and Pauses panel.
RELATED LINKS
Holds and pauses on page 832
Correct positioning for caesura input on page 264

Holds and pauses popover
The table contains the entries for the holds and pauses popover that you can use to input the
different holds and pauses available.
You can open the holds and pauses popover in Write mode in any of the following ways when
either an item is selected or the caret is active:
●

Press Shift-H .

●

Select an existing hold or pause and press Return .

●

Choose Write > Create Hold or Pause.
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The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Holds and Pauses button in the Notations toolbox
Holds and pauses popover with an example entry

Type of hold or pause

Popover entry

Fermata

fer or fermata

Very long fermata

fermataverylong

Long fermata

fermatalong

Short fermata

fermatashort

Very short fermata

fermataveryshort

Short fermata (Henze)

fermatashorthenze

Long fermata (Henze)

fermatalonghenze

Curlew (Britten)

curlew

Caesura

caesura or //

Thick caesura

caesurathick
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Type of hold or pause

Popover entry

Curved caesura

caesuracurved

Short caesura

caesurashort

Breath mark (Comma-like)

breathmarkcomma, comma, or , (comma)

Breath mark (Tick-like)

breathmarktick

Breath mark (Upbow-like)

breathmarkupbow

Breath mark (Salzedo)

breathmarksalzedo

NOTE
The Curlew mark was originally devised by Benjamin Britten for “Curlew River”, a parable for
church performance inspired by Japanese Noh theater. It indicates that a player should hold a
note or a rest until a synchronization point in asynchronous music.

RELATED LINKS
Holds and pauses on page 832
Types of fermatas on page 832
Types of caesuras on page 834
Types of breath marks on page 834

Holds and Pauses panel
The Holds and Pauses panel allows you to input all the different types of holds and pauses
available in Dorico Pro, including alternative versions of fermatas.
●

You can hide/show the Holds and Pauses panel by clicking Holds and Pauses in the
Notations toolbox on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The Holds and Pauses panel contains the following sections:
●

Fermatas

●

Breath Marks
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●

Caesuras

NOTE
Holds and pauses do not currently have an effect in playback, but this is planned for future
versions.

Inputting holds and pauses with the popover
You can input holds and pauses using the holds and pauses popover, both during note input and
by adding them to existing music.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a hold or pause.
NOTE
You can only input one hold or pause at a time.

2.

Optional: If you want to input breath marks onto multiple staves at once, extend the caret to
those staves.

3.

Press Shift-H to open the holds and pauses popover.

4.

Enter the hold or pause you want into the popover.
For example, enter fermata for a pause or caesura for a caesura.

5.

Press Return to close the popover.

RESULT
During note input, the specified hold or pause is input at the caret position. When adding holds
or pauses to existing music, they are input at the rhythmic position of the earliest selected item.
●

Fermatas appear on all staves at the rhythmic position of the note, chord, or rest that
corresponds with the end of the fermata.

●

Breath marks appear to the right of the caret or selected note.

●

Caesuras appear on all staves to the left of the caret or selected note.

RELATED LINKS
Extending the caret to multiple staves on page 171
Holds and pauses on page 832

Inputting holds and pauses with the panel
You can input holds and pauses using the Holds and Pauses panel, both during note input and
by adding them to existing music.
NOTE
These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
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●

Select an item at the rhythmic position where you want to input a hold or pause.
NOTE
You can only input one hold or pause at a time.

2.

In the Notations toolbox, click Holds and Pauses to show the Holds and Pauses panel.

3.

In the Holds and Pauses panel, click the hold or pause you want.

RESULT
During note input, the specified hold or pause is input at the caret position. When adding holds
or pauses to existing music, they are input at the rhythmic position of the earliest selected item.
●

Fermatas appear on all staves at the rhythmic position of the note, chord, or rest that
corresponds with the end of the fermata.

●

Breath marks appear to the right of the caret or selected note.

●

Caesuras appear on all staves to the left of the caret or selected note.

RELATED LINKS
Holds and pauses on page 832
Mouse input settings on page 164

Correct positioning for caesura input
Caesuras are commonly placed at the end of a bar, before a barline. In Dorico Pro, caesuras must
be attached to the note immediately after the position where you want it to appear, as then
Dorico Pro can automatically position them correctly.
If you input caesuras with your mouse input preference set to Load pointer with item, you must
click the first note in the next bar for a caesura to appear to the left of the barline. You can also
click directly on the barline.

A correctly input caesura. The dotted attachment
lines are attached to the notehead after the barline,
meaning the caesura is correctly positioned before
the barline.

An incorrectly input caesura. By clicking to the left of
the barline, the caesura is attached to the last eighth
note in the bar.

When input correctly, the dotted attachment lines link the caesura to the notehead immediately
after the barline.
If your dotted attachment lines do not link the caesura to the notehead immediately after the
barline, delete the caesura and re-input it. Caesuras can cause spacing issues when input
incorrectly.
RELATED LINKS
Holds and pauses on page 832
Types of caesuras on page 834
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Input methods for ornaments, arpeggio signs, glissando lines, guitar
bends, and jazz articulations
You can input ornaments, including arpeggio signs, glissando lines, guitar bends, and jazz
articulations, with the keyboard by using the ornaments popover, and with the mouse by using
the Ornaments panel.
You can input ornaments and arpeggio signs during note input and by adding them to existing
notes, but you cannot input glissando lines or guitar bends during note input. You can only input
glissando lines and guitar bends by adding them to existing notes.
You can specify the type/length of jazz articulations when using the Ornaments panel but not
when using the ornaments popover.
RELATED LINKS
Ornaments on page 924
Arpeggio signs on page 941
Glissando lines on page 950
Guitar bends on page 957
Jazz articulations on page 966
Jazz ornaments on page 967
Lines on page 1033
Input methods for lines on page 290

Ornaments popover
The following tables contain the entries for the ornaments popover that you can use to input the
different ornaments, arpeggio signs, glissando lines, and jazz articulations available.
You can open the ornaments popover in Write mode in any of the following ways when either an
item is selected or the caret is active:
●

Press Shift-O .

●

Select an existing ornament and press Return .

●

Choose Write > Create Ornament.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Ornaments button in the Notations toolbox
Ornaments popover with an example entry

Ornaments
Type of ornament

Popover entry

Trill: 

tr or trill

Short trill: 

shorttr

Mordent: 

mor or mordent
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Type of ornament

Popover entry

Turn: 

turn

Inverted turn: 

invturn or invertedturn

Trill intervals
Trill interval

Popover entry

Major second

tr 2 or tr M2

Minor third

tr m3

Perfect fifth

tr p5

Augmented fourth

tr aug4

Diminished fifth

tr dim5

This list is not comprehensive, as there are many possible trill intervals. It is intended to illustrate
how you can structure your entry to input different trill intervals.
Jazz ornaments
Type of jazz ornament

Popover entry

Flip

flip

Smear

smear

Jazz turn

jazz or shake

Bend

brassbend

Arpeggio signs
Type of arpeggio sign

Popover entry

Up arpeggio sign

arp, arpup, or arpeggioup

Down arpeggio sign

arpdown or arpeggiodown

Non arpeggio sign

nonarp or nonarpeggio
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Type of arpeggio sign

Popover entry

Curved arpeggio sign

slurarp

Glissando lines
Type of glissando line/guitar bend

Popover entry

Straight glissando line

gliss

Wavy glissando line

glisswavy

Guitar bend

bend

Jazz articulations
Type of jazz articulation

Popover entry

Plop (bend)

plop

Plop (smooth)

plopsmooth

Scoop

scoop

Doit (bend)

doit

Doit (smooth)

doitsmooth

Fall (bend)

fall

Fall (smooth)

fallsmooth

TIP
Other ornaments are available in the Ornaments panel on the right of the window in Write mode.
You can specify the type/length of jazz articulations when using the Ornaments panel but not
when using the ornaments popover.

RELATED LINKS
Inputting arpeggio signs with the popover on page 270
Inputting glissando lines with the popover on page 271
Inputting jazz articulations with the popover on page 273
Inputting guitar bends with the popover on page 275
Ornaments on page 924
Trill intervals on page 932
Arpeggio signs on page 941
Glissando lines on page 950
Guitar bends on page 957
Jazz articulations on page 966
Jazz ornaments on page 967
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Ornaments panel
The Ornaments panel allows you to input all the different types of ornaments, including jazz
articulations, as well as arpeggio signs, guitar bends, and glissando lines.
●

You can hide/show the Ornaments panel by clicking Ornaments in the Notations toolbox on
the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The Ornaments panel contains the following sections:
Jazz
Contains ornaments and pitch alterations commonly used in jazz music, such as bends,
scoops, and falls.
Baroque and Classical
Contains ornaments commonly used in Baroque and Classical music, such as
mordents, turns, and trills.
Arpeggiation
Contains the different types of arpeggio signs.
NOTE
You cannot input arpeggio signs with the mouse during note input.
Glissandi
Contains the different types of glissando lines.
Guitar
Contains techniques and pitch alterations commonly associated with guitars, such as
guitar bends and the vibrato bar.

Inputting ornaments with the popover
You can input ornaments and jazz ornaments using the ornaments popover, both during note
input and by adding them to existing notes.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select a single existing note to which you want to add an ornament.

●

Select existing notes across which you want to add a trill.
NOTE
You can only add one ornament to one note at a time.

2.

Optional: If you want to input ornaments onto multiple staves at once, extend the caret to
those staves.

3.

Press Shift-O to open the ornaments popover.

4.

Enter the appropriate entry for the ornament you want into the popover.
For example, enter tr m3 for a trill with a minor third interval or mor for a mordent.
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5.

Press Return to close the popover.

RESULT
During note input, ornaments are input at the caret position. Trills last the duration of the
rhythmic value of the note input at the caret position and have a default interval of a second,
either major or minor depending on the context. If you specified an interval for your trill, the
interval applies only to the first note in the selection, but you can also change the interval
partway through trills.
When adding ornaments to existing notes, they are input above the selected note. Trills are input
above the first selected note, with an extender line across any subsequent selected notes.
RELATED LINKS
Ornaments on page 924
Trills on page 929
Trill interval appearance on page 935
Jazz ornaments on page 967
Inputting notes on page 172
Changing intervals partway through trills on page 934
Extending the caret to multiple staves on page 171

Inputting ornaments with the panel
You can input ornaments and jazz ornaments using the Ornaments panel, both during note
input and by adding them to existing notes.
NOTE
These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select a single existing note to which you want to add an ornament.

●

Select existing notes across which you want to add a trill.
NOTE
You can only add one ornament to one note at a time.

2.

In the Notations toolbox, click Ornaments to show the Ornaments panel.

3.

In the Ornaments panel, click the ornament you want.

RESULT
During note input, ornaments are input at the caret position. Trills are input with a default
duration of a quarter note.
When adding ornaments to existing notes, they are input above the selected note. Trills are input
above the first selected note, with an extender line across any subsequent selected notes.
RELATED LINKS
Mouse input settings on page 164
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Inputting arpeggio signs with the popover
You can input arpeggio signs using the ornaments popover, both during note input and by
adding them to existing notes. You can also input arpeggio signs across notes in multiple voices
and on different staves that belong to the same instrument, such as piano or harp.
NOTE
You can only input one arpeggio sign at a time.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select at least one note in each voice to which you want to add an arpeggio sign.
NOTE

2.

●

For instruments with multiple staves, such as piano and harp, you can select existing
notes on multiple staves to create cross-staff arpeggio signs. However, you cannot
create cross-staff arpeggio signs between different instruments.

●

Arpeggio signs are added to all notes in the selected voices at the selected rhythmic
position.

If you started note input, press Q to start chord input.
NOTE
You can only input arpeggio signs during chord input.

3.

Press Shift-O to open the ornaments popover.

4.

Enter the appropriate entry for the arpeggio sign you want into the popover.
For example, enter arpup for an up arpeggio sign or enter arpdown for a down arpeggio
sign.

5.

Press Return to close the popover.

6.

Optional: During chord input, input the notes you want.

RESULT
During chord input, arpeggio signs are input at the caret position.
When adding arpeggio signs to existing notes, they are input to the left of the selected notes.
Arpeggio signs automatically span the pitch range of all notes at that rhythmic position in the
current voice during chord input, and all notes in the selected voices/staves when adding
arpeggio signs to existing notes.
RELATED LINKS
Ornaments popover on page 265
Arpeggio signs on page 941
Inputting notes on page 172
Inputting chords on page 194
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Inputting arpeggio signs with the panel
You can input arpeggio signs on existing notes using the Ornaments panel. You can also input
arpeggio signs across notes in multiple voices and on different staves that belong to the same
instrument, such as piano or harp.
NOTE
●

You can only input one arpeggio sign at a time, and you cannot input arpeggio signs with
the mouse during note input.

●

These steps describe inputting with the default mouse input preference Create item at
selection.
You cannot create cross-staff and cross-voice arpeggio signs if your preference is set to Load
pointer with item.

PROCEDURE
1.

In Write mode, select at least one note in each voice to which you want to add an arpeggio
sign.
NOTE
●

For instruments with multiple staves, such as piano and harp, you can select existing
notes on multiple staves to create cross-staff arpeggio signs. However, you cannot
create cross-staff arpeggio signs between different instruments.

●

Arpeggio signs are added to all notes in the selected voices at the selected rhythmic
position.

2.

In the Notations toolbox, click Ornaments to show the Ornaments panel.

3.

In the Ornaments panel, click the arpeggio sign you want in the Arpeggiation section.

RESULT
The arpeggio sign specified is input to the left of the selected note or chord. Arpeggio signs
automatically span the pitch range of all notes in the selected voices/staves at that rhythmic
position.
RELATED LINKS
Arpeggio signs on page 941
Mouse input settings on page 164

Inputting glissando lines with the popover
You can input glissando lines between existing notes using the ornaments popover. You can
input glissando lines between both adjacent and non-adjacent notes.
NOTE
You cannot input glissando lines during note input.

PROCEDURE
1.

In Write mode, select one of the following:
●

The note from which you want a glissando line to start.

●

Any two notes that you want to join with a glissando line.

271
Dorico Pro 3.1.10

Write mode
Notations input
TIP
The two notes can be in different voices.
2.

Press Shift-O to open the ornaments popover.

3.

Enter the appropriate entry for the glissando line you want into the popover.

4.

●

Enter gliss for a straight glissando line.

●

Enter glisswavy for a wavy glissando line.

Press Return to close the popover.

RESULT
If you selected two notes, the glissando line specified is input between the selected notes.
If you selected a single note, the glissando line specified starts from the selected note and ends
at the next note in the same voice on the staff, even if this crosses rests.
NOTE
●

You cannot input a glissando line on the last note on a staff.

●

Glissando lines do not automatically adjust around any notes or rests between the selected
notes. If glissando text is shown, the text can collide with notes or rests, in which case we
recommend that you make further adjustments, such as not showing glissando text for that
glissando line.

RELATED LINKS
Ornaments popover on page 265
Glissando lines on page 950
Changing glissando line text on page 952
Changing when glissando line text is shown on page 953

Inputting glissando lines with the panel
You can input glissando lines between existing notes using the Ornaments panel. You can input
glissando lines between both adjacent and non-adjacent notes.
NOTE
●

These steps describe inputting with the default mouse input preference Create item at
selection.
If your preference is set to Load pointer with item, you can only input glissando lines
between the note you click on and the note immediately following it.

●

You cannot input glissando lines during note input.

PROCEDURE
1.

In Write mode, select one of the following:
●

The note from which you want a glissando line to start.

●

Any two notes that you want to join with a glissando line.
TIP
The two notes can be in different voices.

2.

In the Notations toolbox, click Ornaments to show the Ornaments panel.
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3.

In the Ornaments panel, click the style of glissando line you want.
●

Glissando (Straight)

●

Glissando (Wavy)

RESULT
If you selected two notes, the glissando line specified is input between the selected notes.
If you selected a single note, the glissando line specified starts from the selected note and ends
at the next note in the same voice on the staff, even if this crosses rests.
NOTE
●

You cannot input a glissando line on the last note on a staff.

●

Glissando lines do not automatically adjust around any notes or rests between the selected
notes. If glissando text is shown, the text can collide with notes or rests, in which case we
recommend that you make further adjustments, such as not showing glissando text for that
glissando line.

RELATED LINKS
Glissando lines on page 950
Mouse input settings on page 164

Inputting jazz articulations with the popover
You can input jazz articulations using the ornaments popover, both during note input and by
adding them to existing notes.
NOTE
You can input jazz ornaments, such as flips or jazz turns, in the same ways as inputting
ornaments.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select the notes to which you want to add jazz articulations.

2.

Optional: During note input, input at least one note.

3.

Optional: If you want to input jazz articulations onto multiple staves at once, extend the caret
to those staves.

4.

Press Shift-O to open the ornaments popover.

5.

Enter the appropriate entry for the jazz articulation you want into the popover.
For example, enter scoop for a scoop or fall for a fall.

6.

Press Return to close the popover.
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RESULT
The jazz articulation you specify is input on all selected notes. During note input, this is usually
the previous note you input.
NOTE
When using the popover, all jazz articulations follow your project-wide settings for their line style.
You can change their type/length after they have been input.
When using the panel, you can specify the line style of jazz articulations when you input them.

RELATED LINKS
Ornaments popover on page 265
Inputting ornaments with the popover on page 268
Jazz articulations on page 966
Changing the type/length of existing jazz articulations on page 970
Changing the line style of smooth jazz articulations on page 970
Extending the caret to multiple staves on page 171

Inputting jazz articulations with the panel
You can input jazz articulations using the Ornaments panel, both during note input and by
adding them to existing notes.
NOTE
●

You can input jazz ornaments, such as flips or jazz turns, in the same ways as inputting
ornaments.

●

These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select the notes to which you want to add jazz articulations.

2.

In the Notations toolbox, click Ornaments to show the Ornaments panel.

3.

In the Ornaments panel, click the jazz articulation you want in the Jazz section.

RESULT
The jazz articulation you specify is input on all selected notes. During note input, this is usually
the previous note you input.
RELATED LINKS
Inputting ornaments with the panel on page 269
Mouse input settings on page 164
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Inputting guitar bends with the popover
You can input guitar bends between existing notes using the ornaments popover. You can input
guitar bends between both adjacent and non-adjacent notes.
NOTE
You cannot input guitar bends during note input.

PROCEDURE
1.

In Write mode, select one of the following:
●

The note from which you want a guitar bend to start.
NOTE
You cannot input a guitar bend on the last note on a staff.

●

Any two notes that you want to join with a guitar bend.
TIP
The two notes can be in different voices.

2.

Press Shift-O to open the ornaments popover.

3.

Enter bend into the popover.

4.

Press Return to close the popover.

RESULT
If you selected two notes, the guitar bend is input between the selected notes.
If you selected a single note, the guitar bend starts from the selected note and ends at the next
note in the same voice on the staff, even if this crosses rests.
TIP
You can assign a key command for inputting guitar bends. The command is called Create Guitar
Bend and is in the Note Input category on the Key Commands page in Preferences.

RELATED LINKS
Guitar bends on page 957
Ornaments popover on page 265
Key Commands page in the Preferences dialog on page 63

Inputting guitar bends with the panel
You can input guitar bends between existing notes using the Ornaments panel. You can input
guitar bends between both adjacent and non-adjacent notes.
NOTE
●

These steps describe inputting with the default mouse input preference Create item at
selection.
If your preference is set to Load pointer with item, you can only input guitar bends
between the note you click on and the note immediately following it.

●

You cannot input guitar bends during note input.
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PROCEDURE
1.

In Write mode, select one of the following:
●

The note from which you want a guitar bend to start.
NOTE
You cannot input a guitar bend on the last note on a staff.

●

Any two notes that you want to join with a guitar bend.
TIP
The two notes can be in different voices.

2.

In the Notations toolbox, click Ornaments to show the Ornaments panel.

3.

In the Ornaments panel, click Guitar Bend in the Guitar section.

RESULT
If you selected two notes, the guitar bend is input between the selected notes.
If you selected a single note, the guitar bend starts from the selected note and ends at the next
note in the same voice on the staff, even if this crosses rests.
TIP
You can assign a key command for inputting guitar bends. The command is called Create Guitar
Bend and is in the Note Input category on the Key Commands page in Preferences.

RELATED LINKS
Guitar bends on page 957
Ornaments panel on page 268

Inputting guitar pre-bends
You can input guitar pre-bends on any existing notes belonging to fretted instruments.
PROCEDURE
1.

Select the notes before which you want to input guitar pre-bends. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Pre-bend interval in the Guitar Techniques group.

3.

Change the interval as required.

RESULT
Guitar pre-bends of the specified interval are input before the selected notes.
RELATED LINKS
Guitar bends on page 957
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Input methods for playing techniques, pedal lines, string indicators,
and harp pedal diagrams
You can input playing techniques with the keyboard by using the playing techniques popover,
and with the mouse by using the Playing Techniques panel. Pedal lines are considered playing
techniques in Dorico Pro because both affect the sound that the instrument produces.
You can input string indicators outside the staff in the same ways, using either the playing
techniques popover or Playing Techniques panel. However, you can only input harp pedal
diagrams using the playing techniques popover.
You can input string indicators inside the staff using a property in the String Indicators group of
the Properties panel.
RELATED LINKS
Playing techniques on page 1007
Pedal lines on page 986
Harp pedaling on page 977
String indicators on page 813
Inputting playing techniques with the popover on page 281
Inputting playing techniques with the panel on page 283
Inputting pedal lines, retakes, and pedal level changes with the popover on page 284
Inputting pedal lines, retakes, and pedal level changes with the panel on page 285
Inputting harp pedal diagrams on page 286
Inputting string indicators outside the staff with the popover on page 287
Inputting string indicators outside the staff with the panel on page 288
Inputting string indicators inside the staff on page 289

Playing techniques popover
The following tables contain the entries for the playing techniques popover that you can use to
input playing techniques, pedal lines, retakes, and pedal level changes.
When you start entering a playing technique into the playing techniques popover, a menu
appears that shows valid playing techniques containing the letters/words you enter. You can
then select one of these playing techniques to input.
You can open the playing techniques popover in Write mode in any of the following ways when
either an item is selected or the caret is active:
●

Press Shift-P .

●

Select an existing playing technique and press Return .

●

Choose Write > Create Playing Technique.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Playing techniques popover with
an example entry for inputting a
playing technique

Playing techniques popover with
an example entry for inputting a
pedal line
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Playing techniques
Playing technique

Popover entry

Vibrato

vibrato

Senza vibrato

senza vibrato

Naturale (nat.)

nat

Con sord.

con sord

Strong air pressure

strong air pressure

Double-tongue

double-tongue

Down bow

downbow

Up bow

upbow

Sul ponticello

sul pont

Sul tasto

sul tasto

Poco sul tasto

pst

Pizzicato

pizz

Spiccato

spicc

Arco

arco

Tongue click (Stockhausen)

tongue click

Finger click (Stockhausen)

finger click

Vibraphone motor on

motor on

Vibraphone motor off

motor off

Open

open

Damp

damp

Damp (large)

damp large

Full barré

full barre

Half barré

half barre

Strum up

strum up

Strum down

strum down
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Playing technique

Popover entry

Left hand

lh

Right hand

rh

This list is not comprehensive as there are many valid playing techniques. It is intended to
illustrate how you can structure your entry to input different types of common playing
techniques.
If you do not know the correct entry for a playing technique, start entering part of the playing
technique and see if it becomes available in the popover menu.
NOTE
●

To give playing techniques duration, add -> at the end of your entry, such as vibrato->.
During note input, the duration of the playing technique extends as you continue inputting
notes or advance the caret. When adding playing techniques to existing notes, they are
added as a group.

●

As playing techniques correspond to specific samples, they must be input as described or
selected from the popover menu.

Pedal lines
Type of pedal line, retake, or pedal level
change

Popover entry

Sustain pedal line

ped

Set sustain pedal level to 1/4

1/4

Set sustain pedal level to 1/2

r

Set sustain pedal level to 3/4

3/4

Fully depress sustain pedal

1

Retake in sustain pedal line

^, notch, or retake

Remove retake in sustain pedal line

nonotch

Stop sustain pedal line

*

Sostenuto pedal line

sost

Stop sostenuto pedal line

s*

Una corda pedal line

unacorda

Stop una corda pedal line

u*
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Harp pedaling
Example harp pedaling

Popover entry

D, C, Bb, Eb, F, G, A

DCBbEbFGA, BbEb, or --^|^---

D, C♯, B, E, F♯, G♯, A

DC#BEF#G#A, C#F#G#, or -v-|-vv-

TIP
The pipe character is optional.

String indicators outside the staff
Example string indicator

Popover entry

1

string1

3

string3

RELATED LINKS
Playing techniques on page 1007
Groups of playing techniques on page 1020
Pedal lines on page 986
Sustain pedal retakes and pedal level changes on page 987
Harp pedaling on page 977
Adding retakes and pedal level changes to existing pedal lines with the popover on page 284
Inputting harp pedal diagrams on page 286
Inputting string indicators outside the staff with the popover on page 287

Playing Techniques panel
The Playing Techniques panel contains the different playing techniques available in Dorico Pro,
divided into instrument families. Pedal lines are included in the Keyboard section.
●

You can hide/show the Playing Techniques panel by clicking Playing Techniques in the
Notations toolbox on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The Playing Techniques panel contains the following sections:
Common
Contains commonly used playing techniques that also apply to multiple different
instrument families, such as “mute” and “legato”.
Wind
Contains playing techniques typically only used for wind instruments, such as “key
clicks” and “whistle tones”.
Brass
Contains playing techniques typically only used for brass instruments, such as “cup
mute” and “stopped”.
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Unpitched Percussion
Contains playing techniques typically only used for unpitched percussion instruments,
such as “rim” and “scrape”.
Pitched Percussion
Contains playing techniques typically only used for pitched percussion instruments,
such as “motor on” and “½ Ped.” for vibraphones.
Keyboard
Contains playing techniques typically only used for keyboard instruments, such as
“Ped.” and different pedal depression levels.
Choral
Contains playing techniques typically only used for the voice, such as “mouth open”
and “tongue click”.
Strings
Contains playing techniques typically only used for string instruments, such as “col
legno battuto” and “down bow”.
Guitar
Contains playing techniques typically only used for guitars and fretted instruments,
such as string indicators, “half barré”, and “strum up”.
TIP
●

You can hover your mouse pointer over the options in each section to show the name of
each playing technique.

●

You can use the action bars at the bottom of each section to access the Edit Playing
Techniques dialog.

RELATED LINKS
Edit Playing Techniques dialog on page 1022
Inputting string indicators outside the staff with the panel on page 288

Inputting playing techniques with the popover
You can input playing techniques using the playing techniques popover, both during note input
and by adding them to existing notes.
NOTE
You can only enter one playing technique into the popover during note input. You can enter two
playing techniques when adding playing techniques to a selection if they are separated by ->.
PREREQUISITE
You have created any custom playing techniques you want to input.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a playing technique. If
you want to input playing techniques with duration, select items that span that duration.

2.

Optional: If you want to input playing techniques onto multiple staves at once, extend the
caret to those staves.

3.

Press Shift-P to open the playing techniques popover.

281
Dorico Pro 3.1.10

Write mode
Notations input
4.

Enter the appropriate entry for the playing technique you want into the popover.
For example, enter pizz or non vibrato->.
When you start entering a playing technique into the playing techniques popover, a menu
appears that shows valid playing techniques containing the letters/words you enter, which
you can select. If you want the playing technique to have duration, you can add -> at the end.

5.

Press Return to close the popover.
Open-ended playing techniques, such as non vibrato->, automatically extend during note
input as you continue inputting notes, or if you advance the caret by pressing Space .

6.

Optional: During note input, stop open-ended playing techniques by opening the playing
techniques popover again and entering one of the following entries:
●

To end the current playing technique with another playing technique, enter that playing
technique. For example, enter vibrato. This joins the current playing technique to the
following one with a continuation line.

●

To end the current playing technique with another open-ended playing technique, enter
that playing technique followed by ->. For example, enter vibrato->. This joins the
current playing technique to the following one with a continuation line.

●

To end the current playing technique without inputting another playing technique,
enter ? into the popover. This leaves the current playing technique with a duration line
rather than a continuation line.

RESULT
The specified playing techniques are input. They are considered voice-specific by default,
meaning they only apply to the voice indicated by the caret indicator during step input or the
selected voice when adding playing techniques to existing notes. They are automatically placed
above the staff for up-stem voices and below the staff for down-stem voices.
Adjoining playing techniques, or playing techniques that were input together or in sequence, are
automatically grouped together, both during note input and when adding playing techniques to
existing notes.
During note input, playing techniques are input at the caret position and extend automatically if
you included an open-ended playing technique with duration.
When adding playing techniques to a single existing note, they are added to the selected note
only and have no duration. When adding playing techniques to a range of notes, they are added
to the first note in the selection and have duration, which applies until the end of the selection.
For playing techniques whose continuation type is set to show lines, the appropriate
continuation line is shown.
AFTER COMPLETING THIS TASK
●

You can move playing techniques within playing technique groups, lengthen/shorten playing
techniques, and hide/show playing technique continuation lines.

●

You can enable independent voice playback for individual instruments to hear different
playing techniques in different voices simultaneously.

RELATED LINKS
Moving playing techniques rhythmically on page 1008
Groups of playing techniques on page 1020
Playing technique continuation lines on page 1015
Hiding/Showing playing technique duration lines on page 1018
Extending the caret to multiple staves on page 171
Enabling independent voice playback on page 543
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Creating custom playing techniques on page 1029

Inputting playing techniques with the panel
You can input playing techniques using the Playing Techniques panel, both during note input and
by adding them to existing notes.
NOTE
●

You cannot input playing techniques with duration in sequence, which automatically groups
them, when using the panel. If you want to input playing techniques with duration in
sequence, you can use the popover.

●

These steps describe inputting with the default mouse input preference Create item at
selection.
If you want to input the same playing technique in multiple places, change your mouse input
preference to Load pointer with item so that you do not have to reselect the playing
technique for each note.

PREREQUISITE
You have created any custom playing techniques you want to input.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a playing technique. If
you want to input playing techniques with duration, select items that span that duration.

2.

In the Notations toolbox, click Playing Techniques to show the Playing Techniques panel.

3.

In the Playing Techniques panel, click the playing technique you want.

RESULT
The specified playing technique is input. It is considered voice-specific by default, meaning it only
applies to the voice indicated by the caret indicator during step input or the selected voice when
adding playing techniques to existing notes. It is automatically placed above the staff for up-stem
voices and below the staff for down-stem voices.
During note input, playing techniques are input at the caret position, even if your preference is
set to Load pointer with item.
When adding playing techniques to a single existing note, they are added to the selected note
only and have no duration. When adding playing techniques to a range of notes, they are added
to the first note in the selection and have duration, which applies until the end of the selection.
For playing techniques whose continuation type is set to show lines, the appropriate
continuation line is shown.
AFTER COMPLETING THIS TASK
●

If you want to show transition lines between playing techniques, you can group them
together.

●

You can enable independent voice playback for individual instruments to hear different
playing techniques in different voices simultaneously.

RELATED LINKS
Changing your mouse input settings on page 165
Grouping playing techniques together on page 1021
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Enabling independent voice playback on page 543
Creating custom playing techniques on page 1029

Inputting pedal lines, retakes, and pedal level changes with the popover
You can input pedal lines using the playing techniques popover, both during note input and by
adding them to existing music. Because the pedal line extends automatically as you input notes
during note input, you can input retakes and pedal level changes when you reach the
appropriate rhythmic position.
PROCEDURE
1.

2.
3.

In Write mode, do one of the following:
●

Start note input.

●

Select items that span the required duration of the pedal line.

Press Shift-P to open the playing techniques popover.
Enter the appropriate entry for the pedal line you want into the popover.
For example, enter ped for a sustain pedal line.

4.

Press Return to close the popover.
The pedal line is input.

5.

Optional: During note input, extend the pedal line by pressing Space to advance the caret.
The pedal line also extends automatically as you continue inputting notes.

6.

Optional: During note input, input retakes or pedal level changes by opening the playing
techniques popover again at the appropriate rhythmic position and enter the entry for the
retake or pedal level change you want into the popover.
For example, enter ^ or retake for a retake.

7.

Optional: During note input, stop the pedal line by opening the playing techniques popover
again and enter the appropriate entry into the popover.
For example, enter * to stop a sustain pedal line.

8.

Press Return to close the popover.

RESULT
During note input, pedal lines start at the caret position, and end at the caret position.
When you add pedal lines to existing notes, pedal lines are added across the selected items.
RELATED LINKS
Sustain pedal retakes and pedal level changes on page 987
Inputting notes on page 172
Adding retakes and pedal level changes to existing pedal lines with the popover on page 284
Positions of pedal lines on page 992

Adding retakes and pedal level changes to existing pedal lines with the popover
You can add retakes and pedal level changes to existing sustain pedal lines using the playing
techniques popover.
NOTE
You cannot add retakes and pedal level changes to sostenuto or una corda pedal lines.
PREREQUISITE
You have input a sustain pedal line.
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PROCEDURE
1.

In Write mode, select an item at the rhythmic position where you want the retake or pedal
level change to apply.

2.

Press Shift-P to open the playing techniques popover.

3.

Enter the appropriate entry for the retake or pedal level change you want into the popover.
For example, enter ^ or retake for a retake.

4.

Press Return to close the popover.

RESULT
The retake or pedal level change is input at the selected rhythmic position.
RELATED LINKS
Sustain pedal retakes and pedal level changes on page 987
Playing techniques popover on page 277

Inputting pedal lines, retakes, and pedal level changes with the panel
You can input pedal lines, retakes, and pedal level changes using the Playing Techniques panel.
NOTE
●

When using the panel, you cannot input pedal lines, retakes, or pedal level changes during
note input.

●

These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE
1.

In Write mode, select the notes to which you want the pedal line to apply.

2.

In the Notations toolbox, click Playing Techniques to show the Playing Techniques panel.

3.

In the Playing Techniques panel, expand the Keyboard section.

4.

Click the pedal line you want.
Alternatively, with nothing selected, click the pedal line you want in the Keyboard section of
the Playing Techniques panel, then click and drag in the score to create a pedal line and
extend it to the duration you want.

5.

Optional: Select an item at the rhythmic position where you want to input a retake or pedal
level change.

6.

Optional: In the Playing Techniques panel, click the retake or pedal level change you want in
the Keyboard section.

RESULT
The pedal line is input across the selected range.
RELATED LINKS
Sustain pedal retakes and pedal level changes on page 987
Adding retakes and pedal level changes to existing pedal lines with the panel on page 286
Mouse input settings on page 164
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Adding retakes and pedal level changes to existing pedal lines with the panel
You can add retakes and pedal level changes to existing sustain pedal lines using the Playing
Techniques panel.
NOTE
You cannot add retakes and pedal level changes to sostenuto or una corda pedal lines.
PREREQUISITE
You have input a sustain pedal line.
PROCEDURE
1.

In Write mode, select an item at the rhythmic position where you want the retake or pedal
level change to apply.

2.

Input the retake or pedal level change you want in one of the following ways:
●

Click the retake or pedal level change you want in the Keyboard section of the Playing
Techniques panel.

●

Choose Edit > Pedal Lines > [Retake or pedal level change]. You can also choose this
option from the context menu.

RESULT
The retake or pedal level change is input at the selected rhythmic position.
TIP
Alternatively, if nothing is selected in the score, you can click a retake or pedal level change in the
Keyboard section of the Playing Techniques panel, and then click at the rhythmic position where
you want to input the retake or pedal level change.

RELATED LINKS
Sustain pedal retakes and pedal level changes on page 987
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277

Inputting harp pedal diagrams
You can input harp pedal diagrams using the playing techniques popover, both during note input
and by adding them to existing music.
If you do not input any harp pedaling, Dorico Pro assumes all harp pedals are in their natural
setting, as they would be for C major. Any pitches that do not fit with the current harp pedaling
appear red when colors for notes out of range are shown.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input on a harp staff.

●

Select an item on a harp staff at the rhythmic position where you want to input a harp
pedal diagram.

2.

Press Shift-P to open the playing techniques popover.

3.

Enter the appropriate entry for the harp pedals you want.
For example, enter C#F#G# for C♯, F♯, and G♯ pedals, such as in A major.
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4.

Press Return to close the popover.

RESULT
The corresponding harp pedal diagram is input at the selected rhythmic position. Depending on
your per-layout settings, it is either displayed as a diagram, using note names, or not shown and
instead indicated by a signpost.
During note input, harp pedal diagrams are input at the caret position.
RELATED LINKS
Harp pedaling on page 977
Hiding/Showing harp pedaling in layouts on page 979
Changing the appearance of harp pedal diagrams on page 978
Hiding/Showing colors for notes out range on page 905

Calculating harp pedal diagrams based on existing music
You can automatically calculate suitable harp pedal diagrams based on the notes you have
already input, either from a single point onwards or within a selected region.
If you do not input any harp pedaling, Dorico Pro assumes all harp pedals are in their natural
setting, as they would be for C major. Any pitches that do not fit with the current harp pedaling
appear red by default.
PROCEDURE
1.

2.

In Write mode, select the region you want to use to calculate harp pedaling in one of the
following ways:
●

Select an existing single note from which you want to calculate harp pedaling.

●

Select a range of notes for which you want to calculate harp pedaling.

Choose Write > Calculate Harp Pedals.

RESULT
A harp pedal diagram is input at the start of your selection. Depending on your per-layout
settings, it is either displayed as a diagram, using note names, or not shown and instead
indicated by a signpost.

Inputting string indicators outside the staff with the popover
You can input string indicators outside the staff using the playing techniques popover, both
during note input and by adding them to existing notes.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a string indicator above
the staff. If you want to input a string indicator with a duration line, select items that
span that duration.

2.

Optional: If you want to input string indicators onto multiple staves at once, extend the caret
to those staves.

3.

Press Shift-P to open the playing techniques popover.

4.

Enter the appropriate entry for the string indicator you want into the popover.
For example, enter string1 for just a string 1 indicator or string3-> for a string 3 indicator
with duration.
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5.

Press Return to close the popover.
Open-ended string indicators, such as string3->, automatically extend during note input as
you continue inputting notes, or if you advance the caret by pressing Space .

6.

Optional: During note input, stop open-ended string indicators by opening the playing
techniques popover again and entering ? into the popover.
This leaves the current string indicator with a duration line. You can also enter another string
indicator into the popover, but this joins the current string indicator to the following one
with a continuation line rather than a duration line, which is a less common notation.

RESULT
The specified string indicators are input. They are considered voice-specific by default, meaning
they only apply to the voice indicated by the caret indicator during step input or the selected
voice when adding string indicators to existing notes. They are automatically placed above the
staff for up-stem voices and below the staff for down-stem voices.
During note input, string indicators are input at the caret position, and extend automatically if
you included an open-ended string indicator with duration.
When adding string indicators to a single existing note, they are added to the selected note only
and have no duration. When adding string indicators to a range of notes, they are added to the
first note in the selection and have duration, which applies until the end of the selection.
By default, string indicators have dashed duration lines with a hook cap at the end.
AFTER COMPLETING THIS TASK
●

If you input string indicators without duration but want to show dashed duration lines, you
can add them.

●

You can change the staff-relative placement of string indicators.

RELATED LINKS
Playing techniques popover on page 277
String indicators on page 813
Lengthening/Shortening string indicators on page 815
Extending the caret to multiple staves on page 171
Changing the staff-relative placement of items on page 330

Inputting string indicators outside the staff with the panel
You can input string indicators outside the staff using the Playing Techniques panel, both during
note input and by adding them to existing notes.
NOTE
●

You cannot input string indicators with duration during note input when using the panel.
You can only do so when using the popover.

●

These steps describe inputting with the default mouse input preference Create item at
selection.
If you want to input the same string indicator in multiple places, change your mouse input
preference to Load pointer with item so that you do not have to reselect the string
indicator for each note.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

288
Dorico Pro 3.1.10

Write mode
Notations input
●

Select an item at the rhythmic position where you want to input a string indicator above
the staff. If you want to input a string indicator with a duration line, select items that
span that duration.

2.

In the Notations toolbox, click Playing Techniques to show the Playing Techniques panel.

3.

In the Playing Techniques panel, expand the Guitar section.

4.

Click the string indicator you want.

RESULT
The specified string indicator is input. It is considered voice-specific by default, meaning it only
applies to the voice indicated by the caret indicator during step input or the selected voice when
adding string indicators to existing notes. It is automatically placed above the staff for up-stem
voices and below the staff for down-stem voices.
During note input, string indicators are input at the caret position, even if your preference is set
to Load pointer with item.
When adding string indicators to a single existing note, they are added to the selected note only
and have no duration. When adding string indicators to a range of notes, they are added to the
first note in the selection and have duration, which applies until the end of the selection.
By default, string indicators have dashed duration lines with a hook cap at the end.
AFTER COMPLETING THIS TASK
●

If you input string indicators without duration but want to show dashed duration lines, you
can add them.

●

You can change the staff-relative placement of string indicators.

RELATED LINKS
Playing Techniques panel on page 280

Inputting string indicators inside the staff
You can show a string indicator inside the staff for each fretted instrument note. Dorico Pro
automatically detects a string that each pitch could be played on, but you can also specify the
string manually.
NOTE
●

These steps only apply to notes belonging to fretted instruments.

●

This only shows string indicators inside the staff in the current layout, but you can copy
property settings to other layouts.

PROCEDURE
1.

Select the notes belonging to fretted instruments beside which you want to show string
indicators. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Show in the String Indicators group.

RESULT
String indicators are shown in the staff beside each selected note. Unless you have specified a
string for each note, the string number shown in the string indicators is calculated automatically.
String indicators inside the staff for open strings appear as a bold number zero without a circle
enclosure.
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By default, string indicators appear on the left of noteheads without left-hand fingerings and on
the right of noteheads with left-hand fingerings.
AFTER COMPLETING THIS TASK
●

You can specify the string on which notes are played, which affects the number shown in
their corresponding string indicators.

●

You can change the notehead-relative position of string indicators.

●

You can change the default appearance of open string indicators.

●

You can copy property settings for the selected notes to show string indicators in all
applicable layouts.

RELATED LINKS
String indicators on page 813
Fingerings for fretted instruments on page 800
Fretted instrument tuning on page 116
Specifying the string for individual notes on page 904
Changing the notehead-relative position of string indicators on page 819
Changing the appearance of open string indicators on page 814
Copying property settings to other layouts on page 493

Input methods for lines
You can input both horizontal and vertical lines by using the Lines panel. There is no popover for
lines.
TIP
If you want lines to represent specific notations that affect playback if applicable, you can instead
input these notations directly. For example, dynamics, arpeggios, glissandi, and trills all have
dedicated features in Dorico Pro.

RELATED LINKS
Lines on page 1033
Input methods for dynamics on page 241
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277
Input methods for clefs and octave lines on page 254
Input methods for tempo marks on page 228
Input methods for repeats and tremolos on page 300

Lines panel
The Lines panel contains the different types of lines available in Dorico Pro. It is located on the
right of the window in Write mode.
●

You can hide/show the Lines panel by clicking Lines in the Notations toolbox on the right of
the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The Lines panel contains the following sections:
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Horizontal
Contains the different horizontal lines available. The options at the top of the section
allow you to determine the attachment type for the start and end of horizontal lines
you subsequently input. Horizontal lines can be attached to noteheads, barlines, or
rhythmic positions, and the start and end can have different attachment types.

Vertical
Contains the different vertical lines available.
RELATED LINKS
Lines on page 1033
Line components on page 1035

Inputting horizontal lines
You can input horizontal lines between existing notes or spanning a specified duration using the
Lines panel. Horizontal lines can be attached to noteheads, barlines, or rhythmic positions, and
can have different attachment types at their start and end.
You can also input barline-/rhythmic position-attached lines that apply to all staves.
NOTE
●

You cannot change the attachment type of horizontal lines after they have been input.

●

If you want to input notehead-attached horizontal lines to represent glissandi, you can
instead input glissando lines directly.

●

These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE
1.

In Write mode, select one of the following:
●

If you want to input notehead-attached lines, select the notes you want to join with a
line.
TIP
The notes can be in different voices, on different staves, and belong to any instruments
held by the same player.

●

If you want to input barline-/rhythmic position-attached lines, select items that span the
required duration of the line.

●

If you want to input horizontal lines that are attached to noteheads at one end but are
attached to barlines/rhythmic positions at the other end, select the required note and
any item at the required rhythmic position of the other end.

2.

In the Notations toolbox, click Lines to show the Lines panel.

3.

In the Horizontal section, choose one of the following options for both Start and End:
●

Attach to notehead
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4.

●

Attach to barline (where available)

●

Attach to rhythmic position

Input a line with the specified attachments in one of the following ways:
●

To input a notehead-attached line or barline-/rhythmic position-attached line on the
selected staff only, click it in the Horizontal section.

●

To input a barline-/rhythmic position-attached line that applies to all staves, Alt -click it
in the Horizontal section.

RESULT
A horizontal line with the specified attachments is input. They are positioned according to their
attachment types and their rhythmic positions.
Horizontal lines that apply to all staves are categorized as system objects. Therefore, they follow
your per-layout settings for the visibility and positioning of system objects.
AFTER COMPLETING THIS TASK
●

You can change the placement and staff position of barline-/rhythmic position-attached
lines.

●

You can add text to lines.

RELATED LINKS
Lines on page 1033
Positions of lines on page 1036
Length of lines on page 1042
System objects on page 1172
Changing the positions of system objects on page 1173
Adding text to lines on page 1046
Changing the placement of horizontal lines on page 1038
Mouse input settings on page 164
Inputting glissando lines with the popover on page 271

Inputting vertical lines
You can input vertical lines on existing notes using the Lines panel, including across notes in
multiple voices and on different staves that belong to the same instrument, such as piano or
harp.
NOTE
●

If you want to input vertical lines to represent arpeggios, you can instead input arpeggio
signs directly.

●

You can only input one vertical line at a time.

●

These steps describe inputting with the default mouse input preference Create item at
selection.
You cannot create cross-staff and cross-voice vertical lines if your preference is set to Load
pointer with item.

PROCEDURE
1.

In Write mode, select at least one note at the same rhythmic position in each voice to which
you want to add a vertical line.
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NOTE
●

For instruments with multiple staves, such as piano and harp, you can select existing
notes on multiple staves to create cross-staff vertical lines. However, you cannot create
cross-staff vertical lines between different instruments, even if they are held by the same
player.

●

Vertical lines are added to all notes in the selected voices at the selected rhythmic
position.

2.

In the Notations toolbox, click Lines to show the Lines panel.

3.

Click the line you want in the Vertical section.

RESULT
The vertical line specified is input to the left of the selected notes. Its length is adjusted
automatically so that it spans the range of all notes in the selected voices/staves at that rhythmic
position.
AFTER COMPLETING THIS TASK
●

You can change the order of lines when multiple exist at the same rhythmic position and
show vertical lines on the right of notes.

●

You can add text to lines.

RELATED LINKS
Lines on page 1033
Length of lines on page 1042
Adding text to lines on page 1046
Showing vertical lines on the right/left of notes on page 1037
Changing the horizontal order of vertical lines on page 1037
Inputting arpeggio signs with the popover on page 270

Inputting lyrics
You can input lyrics by entering text into the lyrics popover, and you can advance the lyrics
popover to the next note on the staff without closing and reopening it for every note.
PROCEDURE
1.
2.

In Write mode, select the first note to which you want to input lyrics.
Press Shift-L to open the lyrics popover.
By default, the lyrics popover opens with lyric line input selected.

3.

4.

5.

Optional: Change the type of lyric in one of the following ways:
●

To change the lyric line number, press Down Arrow .

●

To input lyrics above the staff, press Shift - Up Arrow .

●

To input chorus lines, press Up Arrow .

●

To input lyric line translations, press Alt/Opt - Down Arrow .

Enter the word or syllable you want to add to the selected note into the popover.
●

To enter multiple words on a single note, press Shift-Alt/Opt-Space .

●

To include a hyphen within a single word or syllable, press Alt/Opt-- (hyphen).

●

To include an elision in a lyric, press _ (underscore).

Advance the popover to the next note in one of the following ways:
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●

If you entered a complete word, or the final syllable in a multi-syllabic word, press
Space .

●

If you entered one syllable of a multi-syllabic word that is not the final syllable, press (hyphen).

●

If you do not want the syllable to be followed by an extension line or hyphen, press
Right Arrow .

6.

Continue entering words and syllables into the popover for the rest of the notes to which
you want to add lyrics.

7.

Press Return or Esc to close the popover.
The popover closes automatically when you reach the last note on the staff.

RESULT
The text you entered into the popover is input as lyrics of the type indicated by the icon on the
left-hand side of the popover.
If you advanced the popover to the next note by pressing - , a hyphen appears after the last
entered lyric. This is used for multi-syllabic words across multiple notes.
If you advance the popover by pressing Space , a gap appears after the last entered lyric. This is
used for single-syllable words or for the final syllable in multi-syllabic words.
NOTE
You can later change whether a gap or a hyphen appears between lyrics by changing their
syllable type.

RELATED LINKS
Lyrics on page 863
Navigation during lyric input on page 295
Types of lyrics on page 865
Types of syllables in lyrics on page 867
Lyric line numbers on page 879
Lyric hyphens and lyric extender lines on page 877

Lyrics popover
You can input lyrics, including chorus lines and lyric line translations, using the lyrics popover.
You can use key commands to change the type of lyric being input at any time.
You can open the lyrics popover in Write mode in any of the following ways when either an item
is selected or the caret is active:
●

Press Shift-L .

●

Select an existing lyric and press Return .

●

Choose Write > Create Lyrics.

●

Click Lyrics in the Notations toolbox.

Lyric lines
The popover automatically opens ready to input lyrics into Line 1, except if you are
changing an existing lyric.
The number shown on the left-hand side of the lyrics popover indicates the lyric line
into which the lyric is input.
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The lyrics popover with an example entry for Line 1

You can change the lyric line number by pressing Down Arrow when the lyrics
popover is open.

The lyrics popover with an example entry for Line 2

Lyric lines above the staff
You can input lyrics into lines above the staff by pressing Shift - Up Arrow when the
lyrics popover is open.
You can then press Up Arrow and Down Arrow to change the lyric line number
above the staff.
Chorus lines
You can input chorus lines by pressing Up Arrow when the lyrics popover is open. You
can do this when inputting lyrics below the staff and above the staff.
A c, for “chorus lines”, is shown on the left-hand side of the popover.

The lyrics popover with an example entry for a chorus line

Lyric line translations
You can input lyric line translations by pressing Alt/Opt - Down Arrow when the lyrics
popover is open.
An asterisk (*) is shown beside the lyric line number to which you want to add a lyric
line translation on the left-hand side of the popover.

The lyrics popover with an example entry for a lyric line translation

RELATED LINKS
Inputting lyrics on page 293
Lyrics on page 863
Types of lyrics on page 865

Navigation during lyric input
You can move the lyrics popover to input new lyrics and edit existing lyrics without having to
close and reopen the lyrics popover.

Popover navigation

Key command

Finish the current word and advance the
popover to the next note or chord.

Space

Finish the current syllable and advance the
popover to the next note or chord.

- (hyphen)
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Popover navigation

Key command

Advance the popover to the next note without
showing an extension line or hyphen.

Right Arrow

Move the cursor to the next/previous letter. If
the next/previous letter is in another lyric, the
popover advances to that lyric.

Right Arrow / Left Arrow

Move the popover forwards/backwards from
syllable to syllable within lines of lyrics.

Alt/Opt-Right Arrow / Alt/Opt-Left Arrow

Add spaces within a word or syllable without
advancing the popover.

Shift-Alt/Opt-Space

Add a hyphen within a single word or syllable
without advancing the popover.

Alt/Opt-- (hyphen)

Add an elision slur within a word or syllable.

_ (underscore)

RELATED LINKS
Lyrics on page 863
Inputting lyrics on page 293

Inputting rehearsal marks
You can input rehearsal marks with the mouse and the keyboard. You can input rehearsal marks
during note input and later by adding them to existing music.
NOTE
These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a rehearsal mark. For
example, a barline or a note.
NOTE
You can only input one rehearsal mark at a time, even if multiple items are selected.

2.

Press Shift-A .
Alternatively, you can click Rehearsal Marks in the Notations toolbox.

RESULT
A rehearsal mark is input at the selected barline, or at the rhythmic position of the start of a note,
a rest, or an object.
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The order of rehearsal marks is updated automatically, meaning you can input them in any
order, including before and between existing rehearsal marks.
RELATED LINKS
Rehearsal marks on page 1051
Mouse input settings on page 164

Inputting markers/timecodes
You can input markers at specific positions in time. Depending on your project-wide settings,
timecodes can also be shown alongside markers.
PROCEDURE
1.

In Write mode, move the playhead to the time position where you want to input a marker.

2.

Press Shift-Alt/Opt-M .

RESULT
A marker is input at the position of the playhead. It shows the default text “Marker” and includes
a timecode reflecting that position if you have chosen to show timecodes in markers.
TIP
You can also input markers by clicking Add Marker in the Markers section of the Video panel.
This method allows you to enter a timecode directly into the Add Marker dialog, rather than
input a marker at the playhead position, so it can be useful if, for example, you already know the
timecodes for each marker.
Additionally, you can input markers in the Markers track in Play mode.
AFTER COMPLETING THIS TASK
You can edit the text shown in the marker.
RELATED LINKS
Markers on page 1060
Timecodes on page 1066
Moving the playhead on page 540
Hiding/Showing timecodes in markers on page 1068
Editing marker text on page 1062
Markers track on page 537
Inputting markers in the Markers track on page 537

Markers section of the Video panel
In the Markers section of the Video panel in Write mode, you can input and edit markers and
timecodes, and also define markers as important.
●

You can hide/show the Video panel by clicking Video in the Notations toolbox.

The Markers section of the Video panel contains a table of markers, divided into the following
columns:
Timecode
Shows the timecode of the marker. You can edit the timecode by double-clicking in the
field.
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Text
Shows the text of the marker. You can edit the text by double-clicking in the field.
Imp.
Stands for “important”, allows you to define markers as important by activating their
checkbox in this column.
When markers are defined as important, their entry uses a bold font in the table and
they are considered when finding a suitable tempo in the Find Tempo dialog.
RELATED LINKS
Markers on page 1060
Timecodes on page 1066

Add Marker dialog
The Add Marker dialog allows you to input markers with custom text at specific timecodes.
●

You can open the Add Marker dialog in Write mode by clicking Add Marker in the Markers
section of the Video panel.

Add Marker dialog

The Add Marker dialog contains the following options:
Text
Allows you to enter custom text that is shown in the marker.
Timecode
Allows you to specify the timecode at which you want to input the marker.
Valid range
Displays the timecode range of the flow.
RELATED LINKS
Markers on page 1060
Timecodes on page 1066
Inputting markers/timecodes on page 297
Markers section of the Video panel on page 297
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Find Tempo dialog
The Find Tempo dialog allows you to calculate tempos that best accommodate your important
markers, for example, by identifying which tempos cause markers to coincide as closely as
possible with strong beats.
●

You can open the Find Tempo dialog in Write mode by clicking Find Tempo in the Markers
section of the Video panel.

NOTE
●

The Find Tempo dialog only considers markers in a single flow. You can change which flow
by selecting an item in the flow whose tempo you want to determine and then opening the
dialog.

●

The Find Tempo dialog is only available if you have input at least one marker in the flow
whose tempo you want to determine and defined at least one marker as important.

Find Tempo dialog

The Find Tempo dialog contains the following options and sections:
Flow
Shows the name of the flow whose tempo you are determining. This field is read-only.
Beat unit
Allows you to change the beat unit considered for the tempo. For example, if the time
signature for the flow is 6/8, you might want to change the beat unit to a dotted
quarter note.
Tempo range
Allows you to set the minimum/maximum tempos you want to consider.
Tempo increments
Allows you to filter the suggested tempos according to their precision.
●

Integral only: Only whole number tempos, that is, tempos without decimal places,
are suggested.

●

Allow increment by 0.25: Allows tempos with decimal places of .25, .5, and .75 to
be suggested.
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Tempos found
Contains a list of possible tempos that you can select to see how they affect the
position of your markers relative to beats. The list is updated automatically when you
change options such as Tempo range and Beat unit.
The list contains columns for the following information:
●

BPM: Stands for “beats per minute”. Lists different possible tempos according to
their metronome mark value.

●

IFO: Stands for “important frames off”. Indicates the average number of frames by
which important markers miss significant beats, either before or after.

●

NFO: Stands for “non-important frames off”. Indicates the average number of
frames by which non-important markers miss significant beats, either before or
after.

●

AFO: Stands for “all frames off”. Indicates the average number of frames by which
all markers in the flow miss significant beats, either before or after.

Found tempos are listed in descending order of average frames off for important
markers.
Markers
Shows the impact that the tempo currently selected in the Tempos found list would
have on each marker in the flow in more detail.
●

Timecode: Shows the exact timecode of each marker.

●

Text: Shows the marker text of each marker to help you identify them.

●

Imp.: Indicates whether a marker has been defined as important.

●

Fr. Off: Stands for “frames off”. Shows the average number of frames by which
each marker misses being aligned to beats.

●

Time Diff.: Stands for “time difference”. Shows the time difference between the
position of the marker and the position of the nearest beat, expressed in fractions
of a second.

●

Not. Diff.: Stands for “notated difference”. Shows the notated difference between
the position of the marker and the position of the nearest beat, expressed in
fractions of a whole note.

Selected tempo
Displays the currently selected tempo for the flow.
Apply
Applies the selected tempo to the flow by inputting it as a tempo mark at the
beginning of the flow. Any other tempo marks in the flow are automatically deleted.
RELATED LINKS
Defining markers as important on page 1064
Metronome marks on page 1212

Input methods for repeats and tremolos
You can input repeats and tremolos, including repeat endings, repeat markers, and rhythm
slashes, with the keyboard by using the repeats popover, and with the mouse by using the
Repeat Structures panel.
Tremolos are included in the Repeat Structures panel because they indicate that notes are
repeated, either individually as single-note tremolos or in sequences as multi-note tremolos.
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Repeats popover
The following tables contain the entries for the repeats popover that you can use to input the
different tremolos, bar repeats, rhythm slash regions, repeat markers, and repeat endings
available.
You can open the repeats popover in Write mode in any of the following ways when either an
item is selected or the caret is active:
●

Press Shift-R .

●

Select an existing repeat marker, slash region, or bar repeat and press Return .

●

Choose Write > Create Repeat.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Repeat Structures button in the Notations toolbox
Repeats popover with an example entry

Repeat endings
Part of repeat ending

Popover entry

Whole repeat ending

end or ending

Additional repeat ending segment

add

Repeat markers
Type of repeat marker

Popover entry

D.C.

dc, D.C., da capo, and so on

D.C. al Fine

dcalf, DC al Fine, D.C. al Fine, and so on

D.C. al Coda

dcalc, DC al Coda, D.C. al Coda, and so on

D.S.

ds, D.S., dal segno, and so on

D.S. al Fine

dsalf, DS al Fine, D.S. al Fine, and so on

D.S. al Coda

dsalc, DS al Coda, D.S. al Coda, and so on

to Coda

toc, tc, to coda, To Coda, and so on

Segno

s, seg, segno, and so on

Fine

f, fin, fine, and so on

Coda

c, co, coda, and so on
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The list of entries for repeat markers is not comprehensive, as the flexibility of the popover
means you can enter any reasonable version or abbreviation of the type of repeat marker you
want and the popover recognizes it in most cases.
Single-note tremolos
Type of tremolo

Popover entry

One stroke

/, \, or 1

Two strokes

//, \\, or 2

Three strokes

///, \\\, or 3

Four strokes

////, \\\\, or 4

Z on stem (buzz roll)

z or zonstem

Remove all tremolos

0 or clear

Multi-note tremolos
Type of tremolo

Popover entry

One stroke

/2, \2, or 12

Two strokes

//2, \\2, or 22

Three strokes

///2, \\\2, or 32

Four strokes

////2, \\\\2, or 42

Z on stem (buzz roll)

z or zonstem

Remove all tremolos

0 or clear

Slash regions
Slash region

Popover entry

New slash region

slash

Bar repeats
Type of bar repeat

Popover entry

Repeat last bar

% or %1

Repeat last 2 bars

%2

Repeat last 4 bars

%4
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Type of bar repeat

Popover entry

Repeat last bar, group in 2

%1,2

Repeat last bar, group in 4

%1,4

Repeat last 2 bars, group in 2

%2,2

Repeat last 4 bars, group in 4

%4,4

RELATED LINKS
Inputting repeat markers with the popover on page 307
Inputting tremolos with the popover on page 308
Inputting slash regions on page 311
Inputting bar repeats on page 312
Repeat endings on page 1070
Tremolos on page 1253
Rhythm slashes on page 1095
Bar repeats on page 1086

Repeat Structures panel
The Repeat Structures panel contains the different types of repeat notations, including repeat
endings, repeat markers, tremolos, rhythm slashes, and bar repeats.
Tremolos are included in the Repeat Structures panel because they indicate that notes are
repeated, either individually as single-note tremolos or in sequences as multi-note tremolos.
●

You can hide/show the Repeat Structures panel by clicking Repeat Structures in the
Notations toolbox on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The Repeat Structures panel contains the following sections:
Repeat Endings
Contains options that allow you to input new repeat endings and add additional
endings to existing repeat endings.
Repeat Jumps
Contains different types of repeat markers that instruct players to jump to a specific
point in the piece, such as “D.S. al Coda”.
Repeat Sections
Contains different sections used in conjunction with repeat jumps, such as “Coda”.
Tremolos
Contains different types of single-note and multi-note tremolos.
Rhythm Slashes
Allows you to input a region that displays rhythm slashes that are automatically
formatted to be compatible with the prevailing time signature.
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Bar Repeats
Allows you to input a region that indicates a set number of bars is repeated without renotating those bars.

Inputting repeat endings with the popover
You can input repeat endings using the repeats popover, both during note input and by adding
them to existing music.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
TIP
During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow / Shift-Left Arrow .

●

Select at least one item in each bar that you want to include in the first ending.

2.

Press Shift-R to open the repeats popover.

3.

Enter end or ending into the popover.

4.

Press Return to close the popover.

RESULT
The repeat ending is input, with the first ending segment covering the bars in which you selected
items, and a second ending segment created automatically in the following bar.
An end repeat barline is created at the end of the first ending if none exists already.
RELATED LINKS
Repeats popover on page 301
Repeat endings on page 1070

Adding additional repeat endings with the popover
You can have more than two possible endings in each repeat ending structure by adding
additional segments using the repeats popover. You can add repeat ending segments both
during note input and by adding them to existing music.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
TIP
During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow / Shift-Left Arrow .

●

Select the bars that you want to include in the additional ending.
NOTE
Your selection must start from the first bar following the previous repeat ending
segment.

2.

Press Shift-R to open the repeats popover.

304
Dorico Pro 3.1.10

Write mode
Notations input
3.

Enter add into the popover.

4.

Press Return to close the popover.

5.

Optional: Repeat these steps as many times as required for the number of additional
endings you want.

RESULT
A new repeat ending segment is added. The existing previous repeat ending segment now ends
with a closed line, with an end repeat barline created if necessary.
TIP
You can also add additional repeat ending segments by selecting the repeat ending and
changing the value for No. endings in the Repeat Endings group of the Properties panel.
However, No. endings only adds additional repeat ending segments that contain one bar, and
does not automatically input or reposition repeat barlines. You must input repeat barlines as
appropriate manually.
EXAMPLE

Default repeat ending structure with two
endings

Repeat ending structure with additional third ending

RELATED LINKS
Repeat endings on page 1070
Repeats popover on page 301

Inputting repeat endings with the panel
You can input repeat endings using the Repeat Structures panel, both during note input and by
adding them to existing music.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
TIP
During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow / Shift-Left Arrow .

●

Select at least one item in each bar that you want to include in the first ending.

2.

In the Notations toolbox, click Repeat Structures to show the Repeat Structures panel.

3.

In the Repeat Structures panel, click Create Repeat Ending in the Repeat Endings section.
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RESULT
The repeat ending is input, with the first ending segment covering the bars in which you selected
items, and a second ending segment created automatically in the following bar.
An end repeat barline is created at the end of the first ending if none exists already.
RELATED LINKS
Repeat endings on page 1070

Adding additional repeat endings with the panel
You can have more than two possible endings in each repeat ending structure by adding
additional segments using the Repeat Structures panel. You can add repeat ending segments
both during note input and by adding them to existing music.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
TIP
During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow / Shift-Left Arrow .

●

Select the bars that you want to include in the additional ending.
NOTE
Your selection must start from the first bar following the previous repeat ending
segment.

2.

In the Notations toolbox, click Repeat Structures to show the Repeat Structures panel.

3.

In the Repeat Structures panel, click Add Section To Repeat Ending in the Repeat Endings
section.

NOTE
If increasing the number of endings makes the repeat ending collide with any part of
another repeat ending, the other repeat ending is deleted. However, its repeat barlines are
not deleted.
4.

Optional: Repeat these steps as many times as required for the number of additional
endings you want.

RESULT
A new repeat ending segment is added. The existing previous repeat ending segment now ends
with a closed line, with an end repeat barline created if necessary.
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TIP
You can also add additional repeat ending segments by selecting the repeat ending and
changing the value for No. endings in the Repeat Endings group of the Properties panel.
However, No. endings only adds additional repeat ending segments that contain one bar, and
does not automatically input or reposition repeat barlines. You must input repeat barlines as
appropriate manually.
EXAMPLE

Default repeat ending structure with two
endings

Repeat ending structure with additional third ending

RELATED LINKS
Repeat endings on page 1070

Inputting repeat markers with the popover
You can input repeat markers, including repeat jumps and repeat sections, using the repeats
popover, both during note input and by adding them to existing music.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
TIP
During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow / Shift-Left Arrow .

●

Select an item at the rhythmic position where you want to input a repeat marker.
For repeat jumps, we recommend that you select the barline with which you want the
end of the jump instruction to align. For repeat sections, we recommend that you select
the barline with which you want the start of the section marker to align.

2.

Press Shift-R to open the repeats popover.

3.

Enter the appropriate entry for the type of repeat marker you want into the popover.
For example, enter coda to input a coda section or enter $ to input a segno.

4.

Press Return to close the popover.

RESULT
During note input, repeat markers are input at the caret position. Coda sections are
automatically formatted so that there is a gap between the coda and the preceding material.
When adding repeat markers to existing music, repeat markers are input at the rhythmic
position of the earliest selected item.
Repeat markers that indicate the end of a section, such as Fine and D.C. al Coda, are right-aligned
with the selected rhythmic position.
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RELATED LINKS
Repeats popover on page 301
Repeat markers on page 1077

Inputting repeat markers with the panel
You can input repeat markers using the Repeat Structures panel, both during note input and by
adding them to existing music.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
TIP
During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow / Shift-Left Arrow .

●

Select an item at the rhythmic position where you want to input a repeat marker.
For repeat jumps, we recommend that you select the barline with which you want the
end of the jump instruction to align. For repeat sections, we recommend that you select
the barline with which you want the start of the section marker to align.

2.

In the Notations toolbox, click Repeat Structures to show the Repeat Structures panel.

3.

In the Repeat Structures panel, click the repeat marker you want to input in any of the
following sections:
●

Repeat Jumps

●

Repeat Sections

RESULT
During note input, repeat markers are input at the caret position. Coda sections are
automatically formatted so that there is a gap between the coda and the preceding material.
When adding repeat markers to existing music, repeat markers are input at the rhythmic
position of the earliest selected item.
Repeat markers that indicate the end of a section, such as Fine and D.C. al Coda, are right-aligned
with the selected rhythmic position.
RELATED LINKS
Repeat markers on page 1077

Inputting tremolos with the popover
You can input both single-note and multi-note tremolos using the repeats popover, both during
note input and by adding them to existing notes.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
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TIP
During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow / Shift-Left Arrow .
●

Select the notes to which you want to add tremolos.
NOTE
If you want to input multi-note tremolos, you must select at least two notes, which can
also be tuplets.

2.

Press Shift-R to open the repeats popover.

3.

Enter the appropriate entry for the type of tremolo you want into the popover.
For example, to input a three-stroke multi-note tremolo, enter ///2.

4.

Press Return to close the popover.

5.

Optional: Repeat steps 2 to 3 to input other tremolos on the selected notes.
For example, if you want notes to have both single-stem and multi-stem tremolos.

RESULT
Single-note tremolos are input on the selected notes with the number of tremolo strokes
specified.
Multi-note tremolos with the number of tremolo strokes specified are input between selected
individual notes and the notes immediately after them, or between selected pairs of notes.
When tuplets are selected, multi-note tremolos are input across the selected tuplets, with the
tremolo strokes positioned in the center of all notes in the tuplet. The tuplet bracket is hidden,
and a signpost is shown at the start of each tuplet indicating its ratio.
NOTE
The appearance of stems in multi-note half note tremolos depends on your setting on the
Tremolos page in Engrave > Engraving Options.
EXAMPLE

Multi-note tremolos with three tremolo strokes across tuplets

AFTER COMPLETING THIS TASK
You can enable independent voice playback for individual instruments, for example, if you have
tremolos in one voice and slurs in another voice.
RELATED LINKS
Repeats popover on page 301
Tremolos on page 1253
Tremolos in playback on page 1259
Enabling independent voice playback on page 543
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Inputting tremolos with the panel
You can input both single-note and multi-note tremolos using the Repeat Structures panel, both
during note input and by adding them to existing notes.
Tremolos are included in the Repeat Structures panel because they indicate that notes are
repeated, either individually as single-note tremolos or in sequences as multi-note tremolos.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
TIP
During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow / Shift-Left Arrow .

●

Select the notes to which you want to add tremolos.
NOTE
If you want to input multi-note tremolos, you must select at least two notes, which can
also be tuplets.

2.

In the Notations toolbox, click Repeat Structures to show the Repeat Structures panel.

3.

In the Repeat Structures panel, click the button with the number of single-note or multi-note
tremolo strokes you want in the Tremolos section.
For example, click Two Strokes Single-note Tremolo to input single-note tremolos with two
strokes or click Three Strokes Multi-note Tremolo to input multi-note tremolos with three
strokes.

Two Strokes Single-note Tremolo button

Three Strokes Multi-note Tremolo button

RESULT
Single-note tremolos are input on the selected notes with the number of tremolo strokes
specified.
Multi-note tremolos with the number of tremolo strokes specified are input between selected
individual notes and the notes immediately after them, or between selected pairs of notes.
When tuplets are selected, multi-note tremolos are input across the selected tuplets, with the
tremolo strokes positioned in the center of all notes in the tuplet. The tuplet bracket is hidden,
and a signpost is shown at the start of each tuplet indicating its ratio.
NOTE
The appearance of stems in multi-note half note tremolos depends on your setting on the
Tremolos page in Engrave > Engraving Options.

310
Dorico Pro 3.1.10

Write mode
Notations input

EXAMPLE

Multi-note tremolos with three tremolo strokes across tuplets

AFTER COMPLETING THIS TASK
You can enable independent voice playback for individual instruments, for example, if you have
tremolos in one voice and slurs in another voice.
RELATED LINKS
Tremolos on page 1253
Deleting tremolos on page 1256
Changing the appearance of multi-note half note tremolos project-wide on page 1259
Tremolos in playback on page 1259
Enabling independent voice playback on page 543

Inputting slash regions
You can input slash regions using the repeats popover.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select items that span the duration in which you want to show rhythm slashes.

2.

Press Shift-R to open the repeats popover.

3.

Enter slash into the popover.

4.

Press Return to close the popover.

RESULT
During note input, slash regions are input spanning the duration of the selected note or item,
which is usually the last input note. When adding slash regions to existing music, they span the
selected duration.
Slash regions are automatically formatted as appropriate for the meter. If you later change the
time signature, slash regions retain their duration but the appearance of slashes within them
automatically updates.
TIP
You can also input slash regions by clicking Create Slash Region in the Rhythm Slashes group
of the Repeat Structures panel.

RELATED LINKS
Repeats popover on page 301
Rhythm slashes on page 1095
Slash regions on page 1095
Slash voices on page 1299
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Inputting bar repeats
You can input bar repeat regions when at least one bar before the region contains notes.
PROCEDURE
1.

In Write mode, select the bars you want to show as a bar repeat.
NOTE
●

You cannot input bar repeat regions in the first bar of a flow.

●

You can only input bar repeat regions on one staff at a time.

2.

Press Shift-R to open the repeats popover.

3.

Enter the appropriate entry for the type of bar repeat region you want into the popover.
For example, enter %2,2 to repeat the previous two bars, grouped in two.

4.

Press Return to close the popover.

RESULT
A region of the selected duration is input, in which the specified type of bar repeat symbol is
shown in the staff at the intervals specified.
NOTE
●

You can also input bar repeat regions during note input; however, this inputs bar repeat
regions from the bar containing the currently selected note. As bar repeats are mostly
shown in empty bars, this is likely to produce unintended results.

●

You can also input bar repeat regions by clicking Create Bar Repeat Region in the Bar
Repeats group of the Repeat Structures panel. However, this only inputs a bar repeat region
containing single-bar repeats.

AFTER COMPLETING THIS TASK
You can change how bar repeats are grouped.
RELATED LINKS
Repeats popover on page 301
Bar repeats on page 1086
Bar repeat grouping on page 1093
Changing bar repeat grouping on page 1094

Inputting text
You can input text at specific rhythmic positions in the score. You can input text for single staves
or input system text that applies to all staves.
NOTE
If you want to insert text that is independent of rhythmic positions and attached to a particular
page, you can use text frames.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input text.
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2.

Open the text editor in any of the following ways:
●

To input staff text, press Shift-X or click Text in the Notations toolbox.

●

To input staff text with a specific paragraph style, choose Write > Create Text >
[Paragraph style].

●

To input system text, press Shift-Alt/Opt-X .

●

To input system text with a specific paragraph style, choose Write > Create System
Text > [Paragraph style].

3.

Enter the text you want.

4.

Optional: Press Return to insert a line break.

5.

Optional: Use the text editor options to format the text.

6.

Press Esc or Ctrl/Cmd - Return to close the text editor.

RESULT
During note input, the text you entered into the text editor is input at the caret position. It is
automatically placed above the staves to which it applies, using the default paragraph style, and
follows your project-wide settings for the vertical position of text.
When adding text to existing music, it is input at the position of the earliest selected item.
NOTE
●

In Dorico Pro, system text is categorized as a system object. Therefore, system text follows
your per-layout settings for the visibility and positioning of system objects.

●

You can change the default position of all text items outside of the staff and other items, and
whether text items avoid collisions by default, on the Text page in Engrave > Engraving
Options.

●

You can assign key commands for inputting text with specific paragraph styles, for both
Create Text and Create System Text, on the Key Commands page in Preferences.

RELATED LINKS
Text frames on page 395
Changing the staff-relative placement of items on page 330
System objects on page 1172
Changing the positions of system objects on page 1173

Text editor options in Write mode
The text editor allows you to add and format text. In Write mode, it opens when you add or
change staff text or system text.

Text editor in Write mode

The text editor provides the following options:
1

Character Style
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Allows you to change the appearance of selected text within paragraphs. This overrides the
paragraph style applied to the corresponding paragraph.
2

Paragraph Style
Allows you to change the paragraph style applied to the whole paragraph, which can change
the appearance, formatting, and alignment of the text.
Staff text and system text are always treated as single paragraphs.

3

Font
Allows you to change the font family of selected text.

4

Font Style
Allows you to change the font style of selected text.
NOTE

5

●

Depending on the font selected, some font styles might not be available.

●

You can also change the font style using the following standard key commands:
●

Ctrl/Cmd-B for bold

●

Ctrl/Cmd-I for italic

Font Size
Allows you to change the size of selected text.
TIP
You can also change the font size using the following key commands:

6

●

Ctrl/Cmd-Shift-. to increase the font size

●

Ctrl/Cmd-Shift-, to decrease the font size

Font Stretch
Allows you to make selected text wider or narrower.

7

Baseline Shift
Allows you to shift the baseline of selected text gradually up or down.

8

Letter Spacing
Allows you to increase/decrease the space between the characters of selected text.

9

Word Spacing
Allows you to increase/decrease the space between the words of selected text.

10 Alignment
Allows you to choose the alignment of selected text relative to the rhythmic position of the
text in the score. For text in a text frame, the text is aligned along the left margin of a text
frame.
You can choose from the following alignments:
●

Align Left

●

Align Center

●

Align Right

11 Line Types
Allows you to show any of the following types of lines, in any combination, on selected text:
●

Underline
TIP
You can also make selected text underlined by pressing Ctrl/Cmd-U .

314
Dorico Pro 3.1.10

Write mode
Notations input
●

Overline

●

Strikethrough

12 Script Types
Allows you to position selected text in one of the following positions relative to the text on
the baseline:
●

Superscript

●

Subscript

13 Foreground Color
Allows you to change the color of selected text.
14 Background Color
Allows you to change the background color of selected text.
RELATED LINKS
Entering text in text frames on page 402
Paragraph Styles dialog on page 410
Character Styles dialog on page 413
Missing Fonts dialog on page 73

Editing text
You can edit text objects added to staves or text displayed in text frames at any time, including
changing the text and changing its formatting.
PROCEDURE
1.

Double-click the text you want to edit to open the text editor.
TIP
You can also select text/system text objects and press Return .

2.

Optional: Change the text in the text frame/object.

3.

Optional: Use the text editor options to format the text.

4.

Press Esc or Ctrl/Cmd - Return to close the text editor.

RELATED LINKS
Text objects vs. text in text frames on page 415

Inputting cues
You can input cues by using the cues popover.
PROCEDURE
1.

On the staff where you want to input a cue, select items that span the duration in which you
want to show a cue.

2.

Press Shift-U to open the cues popover.

3.

Start entering the name of the instrument whose music you want to show in the cue.
The candidate instrument menu appears below the popover and shows possible source
instruments.

4.

Select the instrument whose music you want to show in the cue from the candidate
instrument menu.
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NOTE
●

If you do not enter the name of an instrument that exists in your project, no cue is
created.

●

If you enter the full name of an instrument into the popover yourself, you must press
Return twice to input a cue using that instrument.

●

If multiple instruments of the same type exist in your project, music from the first player
is input as the cue if you do not specify the number you want. For example, if you have
Violin I and Violin II in your project and enter violin into the cues popover, music from
the Violin I staff is shown in the cue.

RESULT
A cue is input on the selected staff, showing the music of the instrument selected in the cues
popover.
If you are inputting cues in a full score layout in page view, the cue appears as a signpost by
default, showing the name of the source instrument. This is because cues are hidden in full score
layouts and shown in part layouts by default, but you can choose to hide/show cues in any
layout.
RELATED LINKS
Cues on page 742
Hiding/Showing cues in layouts on page 746
Lengthening/Shortening cues on page 748
Moving cues on page 748
Switching between layouts on page 55

Cues popover
The cues popover allows you to input cues that refer to other instruments in the project, using
the names of instruments as they are set in your project and language.
When you start entering the name of an instrument that exists in your project into the cues
popover, a candidate menu appears that shows source instruments that you can select to show
in the cue, excluding the destination instrument.

The cues popover with an example entry showing the menu of candidate instruments.

Each staff of grand staff and multi-staff instruments is listed separately, for example, Piano (a)
and Piano (b).
Each unpitched percussion instrument is listed separately. If you have a drum set in your project,
each individual instrument in the drum set appears as a candidate for cueing. For example, you
can show just the kick drum in a cue.
NOTE
●

You cannot use entire percussion kits in cues, you must select an individual instrument from
the kit.

●

If you directly input a cue at the same position as an existing cue, the new cue overrides the
existing cue, which is deleted. However, you can have multiple cues at the same rhythmic
position if you create them in separate bars and move them or lengthen/shorten them later.
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Cues panel
The Cues panel allows you to input cues and find suitable places to input cues.
●

You can hide/show the Cues panel by clicking Cues in the Notations toolbox on the right of
the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
The Cues panel contains the following sections:
Create Cue
Contains the Create Cue button which you can click to open the cues popover with the
mouse.
Suggest Cues
Allows you to generate suggested locations for cues based on how long players have
been resting.
RELATED LINKS
Cues on page 742

Cue suggestions
Cue suggestions are places in the current flow that Dorico Pro has identified as useful locations
to input cues, based on a set span of time during which players have not played.
The Suggest Cues section of the Cues panel is divided into the following sections that help you
find useful places to input cues:
Resting for
Allows you to specify the resting period for players after which you want to input cues.
The resting period is specified in absolute time rather than in bars or beats. This is
because meters and tempos can change many times throughout a flow, and music can
be partially or completely meterless, whereas one second always has the same
duration. Dorico Pro calculates time using metronome marks in the project.
Specifying an absolute time ensures consistency in the approach to finding places
where cues might be appropriate.
Rehearsal marks
Allows you to consider/ignore rehearsal marks when determining the resting period.
Rehearsal marks often coincide with new sections or other landmarks in the music,
which can be obvious to players without needing extra cues. By default, rehearsal
marks are ignored as they do not always act as signposts for the musical structure.
Cues
Allows you to consider/ignore cues that already exist between notes played by the
destination player when determining the resting period.
A cue that occurs immediately before an entry in the destination instrument is always
ignored and is never included as a suggested location, even if you choose to consider
cues.
However, orientation cues which serve to help the player keep their place during
extended rests, but do not immediately precede an entry, reset the timer if you choose
to consider cues.
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Update
Allows you to recalculate cue suggestions based on your Resting for duration and
inclusion choices for rehearsal marks and cues after you have changed values.
The names of the flow and layout that were active when you last updated the list of cue
suggestions are shown below the Update button. This allows you to see at a glance to
which flow and layout the suggestions shown in the table apply.
Cue suggestions table
Suggested cues are presented in a table, which contains the following columns:
●

Instr.: The destination instrument that has been resting for more than your
minimum specified duration. Click to show instruments with suggested cues in the
order in which they appear in the score.

●

Bar: The bar containing the first entry of the destination instrument after its rest
period. Click to show entries in ascending order, earlier bars down to later bars.

●

Sec.: The length of time in seconds the destination instrument has been resting
before the entry shown in the Bar column. Click to show the length of resting
period in descending order, longest period down to shortest period.

Click rows in the cue suggestions table to navigate directly to that location. By default,
an area with an equivalent rhythmic duration of 5 to 10 seconds prior to the entry in
the destination instrument is highlighted. The highlighted area is not a specific
recommendation for cue length, but it can be a good indication depending on the
musical context.
If you create a cue at a location suggested in the cue suggestions table, that
suggestion is automatically removed from the list.
You can click Ignore in the action bar at the bottom of the table to hide suggestions
where you do not think a cue is appropriate.
NOTE
If you later click Update and regenerate the list, hidden suggestions can reappear.
Highlight suggestions
Highlighted areas before entries in source instruments are shown when Highlight
suggestions is activated, and are hidden when it is deactivated.
Playing instruments list
Contains the instruments that are playing in the 5 to 10 seconds prior to the entry in
the destination instrument currently selected in the cue suggestions table, to help you
determine which instrument to use as the source instrument of cues.
RELATED LINKS
Cues on page 742

Inputting cues using cue suggestions
You can use the Suggest Cues section of the Cues panel in Write mode to find suitable places to
input cues. You can then input cues using the cues popover.
PROCEDURE
1.

In Write mode, open the layout in the music area in which you want to find suitable locations
for cues.
For example, suitable locations for cues are suggested for all instruments when the full score
layout is open in the music area, but only suitable locations for individual instruments are
suggested when a single part layout is open.

2.

In the Notations toolbox, click Cues to show the Cues panel.
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3.

In the Suggest Cues section of the Cues panel, specify the resting period after which you
want to input cues by changing the value for Resting for.

4.

Choose one of the following options for Rehearsal marks:

5.

●

Consider

●

Ignore

Choose one of the following options for Cues:
●

Consider

●

Ignore

6.

Click Update.

7.

Optional: To check the context of the cue suggestion, click a row in the cue suggestions table
to navigate directly to that position in the layout.
Cue suggestions are highlighted for the equivalent rhythmic duration of 5-10 seconds. You
can choose not to see highlighted areas by deactivating Highlight suggestions.

8.

On the staff where you want to input a cue, select items that span the duration in which you
want to show a cue.

9.

Press Shift-U to open the cues popover.

10. In the popover, start entering the name of the instrument whose music you want to show in
the cue.
The candidate instrument menu appears below the popover. You can use the Playing
instruments list in the Cues panel to help select an appropriate source instrument for your
cue.
11. Select the instrument whose music you want to show in the cue from the candidate
instrument menu.
NOTE
●

If you do not enter the name of an instrument that exists in your project, no cue is
created.

●

If you enter the full name of an instrument into the popover yourself, you must press
Return twice to input a cue using that instrument.

●

If multiple instruments of the same type exist in your project, music from the first player
is input as the cue if you do not specify the number you want. For example, if you have
Violin I and Violin II in your project and enter violin into the cues popover, music from
the Violin I staff is shown in the cue.

RESULT
A cue is input in the selected staff, showing the music of the instrument selected in the cues
popover.
If you are inputting cues in a full score layout in page view, the cue appears as a signpost by
default, showing the name of the source instrument. This is because cues are hidden in full score
layouts and shown in part layouts by default, but you can choose to hide/show cues in any
layout.
RELATED LINKS
Cues on page 742
Switching between layouts on page 55
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Editing and selecting
In Dorico Pro, there are multiple different ways you can select and edit the items in your project,
from selecting items individually to making large selections covering multiple staves.
RELATED LINKS
Filters on page 326
Selection tools on page 53

Selecting/Deselecting notes and items individually
You can select/deselect existing notes and other notation items individually in the music area, for
example, if you want to add articulations to a selection of notes or delete a short passage of
music.
TIP
If you want to select a large number of notes/items, we recommend that you use one of the
larger selection methods.

PROCEDURE
1.

Select individual notes/items in the music area in any of the following ways:
●

Ctrl/Cmd -click individual notes/items.

●

Shift -click adjacent notes/items.

●

Click a single note/item.
TIP
If the item you want to select is behind another item, Shift - Alt/Opt -click it.

●
2.

Make a marquee selection around multiple notes/items.

Deselect all currently selected items in any of the following ways:
●

Press Ctrl/Cmd-D .

●

Click outside of the staves within the music area.

RELATED LINKS
Selecting multiple items using marquee selections on page 321
Playing/Muting notes during note input/selection on page 328
Filters on page 326

Selecting more items of the same type
You can incrementally extend your current selection to more items of the same type and notes in
the same voices, which is particularly helpful if you want to select multiple different items at
once, such as dynamics and lyrics.
PROCEDURE
1.

Select the notes and items you want to select more of. You can do this in Write mode and
Engrave mode.
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TIP
You can select notes and items on multiple staves and in specific voices, for example, if you
only want to select notes in up-stem voices on four staves.
2.

Press Ctrl/Cmd-Shift-A to expand your selection.

3.

Optional: Continue pressing Ctrl/Cmd-Shift-A to extend your selection further.

RESULT
More of the same types of items and notes in the same voices as your original selection are
selected, with the range of selected items expanding each time you press the key command:
firstly to the boundaries of the bar, secondly to the boundaries of the system, and finally to the
rest of the flow. If there are no other items available in the bar, Dorico Pro automatically
advances to the second expansion. In galley view, the second expansion is to the entire flow
directly as there is only a single system in galley view.
For items that span multiple bars and systems, they are selected in the earliest bar/system in
which they exist.
NOTE
Dorico Pro selects the following items differently if you select only a single one of them:
●

Lyrics: The selection expands only to other lyrics with the same line number, placement, and
line type as the originally selected lyric.

●

Dynamics: The first expansion is to all other dynamics in the same group and on the same
staves as the original selection, with further expansions selecting other dynamics in other
groups.

●

Playing techniques: The selection expands only to playing techniques of the same category,
such as Strings or Choral. Additionally, if you select either an up bow or down bow playing
technique, the selection expands only to other up bow and down bow playing techniques. It
does not select any other playing techniques.

Selecting multiple items using marquee selections
You can use a marquee selection to select multiple notes and notations at the same time within a
specific area in Write, Engrave, and Play modes.
PROCEDURE
1.

In the status bar, click Marquee Tool.

2.

In the music area, click and drag across the area where you want to select everything.
A gray rectangle is shown to indicate which notes and notations will be selected. We
recommend that you click in one corner of the area you want to select and drag diagonally
across to the other corner.

RESULT
All notes and notations in the area within the gray rectangle are selected.
NOTE
Only items completely within the area are selected. However, if any part of a note/tie chain is
within the area, the whole note/tie chain is selected.
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RELATED LINKS
Status bar on page 52
Selection tools on page 53

Large selections
You can make large selections, including selecting the contents of whole staves or the whole
flow.
Select everything in a specific area
You can use the Marquee Tool to specify an area in which you want to select
everything.
Select everything in the whole flow
●

Press Ctrl/Cmd-A .

●

Choose Edit > Select All.

Select everything on a single staff
●

Select the first note on the staff, hold down Shift , and select the last note on the
staff.

●

Select the first note on the staff and choose Edit > Select To End Of System or
Edit > Select To End Of Flow.

●

Make a marquee selection that includes the staff you want to select.

Select everything on multiple adjacent staves
●

Select one whole staff at the top/bottom of the range of staves you want to select
and press Shift-Up Arrow or Shift-Down Arrow until all the staves you want are
selected.

●

Select one whole staff at the top/bottom of the range of staves you want to select
and Shift -click the staff at the other end of the range of staves you want to select.

●

Make a marquee selection that includes the staves you want to select.

Select more of the currently selected types of items
You can use Edit > Select More ( Ctrl/Cmd-Shift-A ) to expand your current selection
horizontally and incrementally to other items of the same types and in the selected
voices and staves in both Write mode and Engrave mode. For items that span multiple
bars and systems, they are selected in the earliest bar/system in which they exist.
1

The first expansion is to the boundaries of the current bar, both to the left and
right. If there is nothing to select within the bar, such as if you selected a whole
note in a 4/4 bar, Dorico Pro automatically advances to the second expansion.

2

The second expansion in page view is to the boundaries of the current system,
both to the left and right. In galley view, the second expansion is to the rest of the
flow, as there is only a single system in galley view.

3

In page view, the third expansion is to the entire flow.

Select everything in the system within a range of beats/bars
You can use the system track to select a region of beats/bars and then select
everything on all staves in the system within that region.
TIP
If you want to select only a certain type of item, such as lyrics or dynamics, you can then use the
corresponding filters.
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RELATED LINKS
Filters on page 326
Selecting/Deselecting notes and items individually on page 320
Selecting more items of the same type on page 320

System track
The system track is a translucent line above the top of each system in Write mode. It allows you
to add and delete bars and beats, and to select everything on all staves in the system.

The system track above a staff, showing bars

The system track above a staff, showing beat units
reflecting the current rhythmic grid resolution

The color of the system track changes depending on how you are interacting with it.
●

When you hover the mouse over it, it becomes opaque.

●

When you select a region in the system track, it appears highlighted.

The system track when the mouse pointer hovers
over it

The system track with a region selected

When you have selected a region in the system track, the following options are available:

1

Delete
Allows you to delete the selected region.
NOTE
When you hover over Delete, the highlight color of the selected region changes.

2

System Track Select
Allows you to select all items on all staves in the system across the selected region.

3

Add
Allows you to add bars or beats of the same duration as the selection in the system track.
The extra time is inserted immediately after the end of the selection.
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NOTE
Selections on the system track are cleared whenever you make any other kind of selection, or
when you switch layouts. However, selections on the system track are retained when switching
between page and galley view.

RELATED LINKS
Inputting bars/beats with the system track on page 239
Deleting bars/beats with the system track on page 631

Hiding/Showing the system track
The system track is shown by default in new projects, but you can hide/show it at any time.
PROCEDURE
●

Hide/Show the system track in any of the following ways:
●

Press Alt/Opt-T .

●

Choose View > System Track.

RESULT
The system track is shown when a tick appears beside System Track in the View menu, and
hidden when no tick appears.
TIP
If you do not want the system track to be shown in all future projects by default, deactivate Show
system track in new projects in the View section of the General page in Preferences.

RELATED LINKS
Preferences dialog on page 62

Selecting bars with the system track
The system track allows you to select all staves in the system across the selected bars.
PREREQUISITE
The system track is shown.
PROCEDURE
1.

Click a bar in the system track.

2.

Optional: Select multiple bars to the right/left of the first selected bar in any of the following
ways:

3.

●

Shift -click bars to the right/left along the system track.

●

Click and drag to the right/left along the system track.

Click System Track Select in the system track. It can also appear above the system track if
your selection is narrow.
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System Track Select button in the system track

The System Track Select button appears filled in
when you hover over it

RESULT
Everything on all staves in the selected bars is selected and highlighted, including notations and
signposts.
NOTE
If you then delete your selection, any signposts included are also deleted. This can affect the
page layout, for example, by removing ossia staves whose signposts were included in the
selection.

RELATED LINKS
Hiding/Showing the system track on page 324
Deleting the contents of bars on page 632
Deleting bars/beats with the system track on page 631

Selecting beats with the system track
The system track allows you to select all staves in the system across the selected beats.
PREREQUISITE
The system track is shown.
PROCEDURE
1.

Press and hold Alt/Opt .
Grid lines that match the current rhythmic grid resolution appear in the system track.

2.

Without releasing Alt/Opt , click and drag to the right/left along the system track.
NOTE
You cannot Shift -click when selecting beats.

3.

Click System Track Select in the system track. It can also appear above the system track if
your selection is narrow.

System Track Select button in the system track

The System Track Select button appears filled in
when you hover over it

RESULT
Everything on all staves in the selected beats is selected and highlighted, including notations and
signposts.
NOTE
If you then delete your selection, any signposts included are also deleted. This can affect the
page layout, for example, by removing ossia staves whose signposts were included in the
selection.
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RELATED LINKS
Hiding/Showing the system track on page 324
Deleting the contents of bars on page 632
Deleting bars/beats with the system track on page 631

Filters
Filters in Dorico Pro allow you to select only a specific type of item from a larger selection. Dorico
Pro includes a filter for every notation item.
●

You can find the available filters by choosing Edit > Filter > [Item] > [Item type].
You can also choose filters from the context menu.

All significant notation items have their own filter, for example, arpeggio signs, chord symbols,
key signatures, and playing techniques. You can also filter for note spacing changes.
The following items have multiple filters because they have multiple types:
Notes
Allows you to filter notes, grace notes, and chords. You can also filter notes according
to their accidental, pitch, and position in chords.
Voices
Allows you to filter voices according to their stem-direction. You can also filter slash
voices.
Dynamics
Allows you to filter all dynamics, or just gradual or immediate dynamics.
Tempos
Allows you to filter all tempo marks, or just absolute, relative, or gradual tempo
changes.
Lyrics
Allows you to filter all lyrics, or just lyrics with a specific line number, type, or staffrelative placement.
NOTE
There is no filter for barlines. You also cannot filter fingerings, beams, articulations, or tremolos,
as they are considered part of the notes to which they apply.

RELATED LINKS
Filters for lyrics on page 864
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Filter Notes by Pitch dialog
The Filter Notes by Pitch dialog allows you to specify notes that you want to filter from a larger
selection by their pitch. You can specify pitches in only a single octave or in all octaves.

Filter Notes by Pitch dialog

The Filter Notes by Pitch dialog comprises the following:
Written/Sounding pitches to filter
Allows you to choose whether to filter the notes according to their Written pitch or
their Sounding pitch.
Pitch filters list
Contains the different pitch filters that will be applied to the selection.
Remove Selected
Deletes only the selected pitch filters.
Clear
Deletes all pitch filters in the list.
Note name menu
Allows you to select the note name you want to filter, such as E or G.
Accidental menu
Allows you to select an accidental to specify the pitch, such as E♭ or G♯.
in octave
Allows you to choose the octaves in which you want to filter the pitch.
●

When in octave is activated, the filter applies only to a single octave. You can use
the value field to specify the octave.

●

When in octave is deactivated, the filter applies to all octaves.

Add
Adds the currently set parameters as a filter.
RELATED LINKS
Large selections on page 322
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Changing filters to select/deselect
You can change whether the available filter options select or deselect the specified items. By
default, filters select items, meaning that the resulting selection only includes the item being
filtered.
When filters are set to deselect, the resulting selection includes everything except the item being
filtered.
PROCEDURE
●

Change the filter behavior in one of the following ways:
●

To change filters to select, choose Edit > Filter > Select Only.

●

To change filters to deselect, choose Edit > Filter > Deselect Only.

TIP
You can also choose these options from the context menu.

RELATED LINKS
Filters for lyrics on page 864

Playing/Muting notes during note input/selection
You can change your default setting for whether notes are played back as you input them or not.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Note Input and Editing in the page list.

3.

In the Note Input section, activate/deactivate Play notes during note input and selection
in the Auditioning subsection.

4.

Click Apply, then Close.

RESULT
When the option is activated, notes play back as you input them during note input and when you
select them. When it is deactivated, notes do not play back.
RELATED LINKS
Inputting notes on page 172
Selecting/Deselecting notes and items individually on page 320

Playing all/individual notes in chords during note input/selection
You can change your default setting for whether all notes in chords are played when you select
any note in the chord or whether only the selected notes are played.
PREREQUISITE
Notes are played during note input/selection.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Note Input and Editing in the page list.
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3.

In the Note Input section, activate/deactivate Play all notes in chord when any is selected
in the Auditioning subsection.

4.

Click Apply, then Close.

RESULT
When the option is activated, all notes in chords are played when any note in the chord is
selected. When it is deactivated, only the selected notes are played.

Disabling automatic linking of dynamics and slurs when pasting
By default, dynamics and slurs are automatically linked when you copy them to other staves at
the same rhythmic position. You can disable this behavior so dynamics and slurs are not linked
by default.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Note Input and Editing in the page list.

3.

In the Editing section, deactivate Link dynamics and slurs to existing items when
pasting.

4.

Click Apply, then Close.

RELATED LINKS
Linked dynamics on page 783
Linked slurs on page 1126

Changing existing items
You can change all items that have an associated popover, rather than deleting them and
inputting new ones. For example, if you want to change an 8va octave line into a 15va octave line
or change a short fermata into a long fermata.
PROCEDURE
1.

Select the item or the signpost of the item you want to change.

2.

Press Return to open the popover for that item.

3.

Change the existing entry in the popover.
For chord symbols, you can also play the new chord on your MIDI keyboard.

4.

Press Return to close the popover.

RESULT
The selected item is changed according to the new entry in the popover. This changes different
parameters for different items, such as the duration of a hold or pause or the volume of a
dynamic.
NOTE
●

If you change a fermata to a breath mark, only the fermata on the top staff is changed to a
breath mark. If you change a caesura to a breath mark, a breath mark is input on the top
staff at the end of the bar to which the caesura is attached. However, the existing caesura
also remains on all staves.

●

If you open the playing techniques popover in this way, Dorico Pro inputs your new entry as
a separate playing technique and does not delete the previous one.
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●

If you change an immediate dynamic to a combined dynamic, such as  to , or vice versa,
Dorico Pro inputs your new entry as a separate dynamic and does not delete the previous
one.

●

You can assign key commands to commands that increase/decrease the intensity of
immediate dynamics without reopening the dynamics popover, such as increasing  to .

RELATED LINKS
Editing existing lyrics on page 870
Assigning key commands on page 66

Changing the staff-relative placement of items
You can flip any item that can be placed both above/below the staff to change their staff-relative
placement, for example, if you want to change the stem direction of notes quickly.
NOTE
These steps do not apply to text in text frames or pedal lines.

PROCEDURE
1.

Select the items you want to flip. You can do this in Write mode and Engrave mode.
NOTE

2.

●

You cannot flip items during note input. You cannot flip text items when the text editor is
open.

●

If you want to select parts of items, such as articulations, a single notehead within a tie
chain, or a single fermata, you must be in Engrave mode.

Press F .

RESULT
The staff-relative placement of the selected items is changed by setting Placement, Position, or
Direction properties appropriately in the corresponding groups of the Properties panel.
Deactivating these properties resets items to their default placement.
NOTE
●

If you flipped multiple multi-segment slurs or tuplet brackets with different hook directions
at the same time, all selected items are set to either above or below the staff, unless they all
originally had compatible directions set.

●

You can change the default staff-relative placement of many items on the corresponding
pages in Engrave > Engraving Options.

AFTER COMPLETING THIS TASK
If you need to move items to different graphical positions, you can move them graphically in
Engrave mode.
RELATED LINKS
Changing the staff-relative placement of beams on page 668
Changing the staff-relative placement of fingerings on page 792
Changing the staff-relative placement of tuplet brackets on page 1270
Changing the vertical alignment of text in text frames on page 403
Positions of lyrics on page 872
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Resetting the appearance of items
You can reset all changes you have made to the appearance of individual items, which returns
them to the default settings. Properties relating to the appearance of items include those that
change their style, type, and some additions, such as poco a poco text for dynamics.
PROCEDURE
1.

Select the items whose appearance you want to reset. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Reset Appearance.

RESULT
All properties that affect the appearance of the selected items are reset to their default settings.
For properties that are layout-specific and frame chain-specific, this only resets the appearance
of the selected items in the current layout and frame chain.
RELATED LINKS
Engraving Options dialog on page 359
Notation Options dialog on page 160
Copying property settings to other layouts on page 493

Resetting the position of items
You can reset the position of individual items you have moved graphically, which returns them to
their default position. Properties relating to the position of items include horizontal and vertical
offsets, beat-relative position, and staff-relative placement.
PROCEDURE
1.

Select the items whose position you want to reset. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Reset Position.

RESULT
All properties that affect the position of the selected items are reset to their default settings. For
properties that are layout-specific and frame chain-specific, this only resets the position of the
selected items in the current layout and frame chain.

Navigation
There are different ways you can navigate around the layout currently open in the music area,
such as moving the selection to different items or bringing specific bar numbers or pages into
view. Many navigation methods function in multiple modes.
If you have an item selected, you can navigate to other notes/items, which moves the selection to
those notes/items.
RELATED LINKS
Workspace setup on page 55
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Navigating to other items in the music area
You can navigate to other notes and items in the music area after you have selected a note/item,
for example, if you want to move the selection to other notes along the staff without using the
mouse.
NOTE
In Engrave mode, navigating to other items always moves the selection to the closest item
graphically, rather than the next/previous item of the same type.

PROCEDURE
1.

Select an item in the music area.
●

If you want to navigate through notes, select a note.

●

If you want to navigate through a particular type of item, such as rehearsal marks, select
an item of that type.
NOTE
You can only navigate forwards/backwards through items on the same staff. You cannot
navigate to other items of the same type on other staves.

2.

Navigate to other notes or items in any of the following ways:
●

To navigate to the next item or note in the same voice, press Right Arrow .

●

To navigate to the previous item or note in the same voice, press Left Arrow .

●

To navigate to the closest note above the current selection, press Up Arrow .
This navigates to any existing notes on the same staff first, then to the lowest note/rest
on the staff above.

●

To navigate to the closest note below the current selection, press Down Arrow .
This navigates to any existing notes on the same staff first, then to the highest note/rest
on the staff below.

3.

●

To navigate forwards to the note/rest at the start of the next bar, press Ctrl/CmdRight Arrow .

●

To navigate backwards to the note/rest at the start of the previous bar, press Ctrl/CmdLeft Arrow .

●

To navigate to the top staff in the system, press Ctrl/Cmd-Up Arrow .

●

To navigate to the bottom staff in the system, press Ctrl/Cmd-Down Arrow .

Optional: Switch the selection to another type of item at the same rhythmic position in one
of the following ways:
●

Press Tab to cycle forwards through items.

●

Press Shift-Tab to cycle backwards through items.

NOTE
You cannot switch the selection to system objects, such as system text or rehearsal marks.
However, you can select system objects directly and navigate through them.
4.

Optional: After switching the selection to another type of item, navigate to other items of
that type.

RELATED LINKS
System objects on page 1172
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Going to flows
You can go to the next/previous flow in the current layout, which automatically brings the start of
that flow into view in the music area. This is particularly useful when navigating around layouts
that contain many flows.
These steps function in Setup, Write, and Engrave modes.
PROCEDURE
●

Go to a different flow in one of the following ways:
●

To go to the previous flow in the layout, choose Edit > Go To > Go To Previous Flow.

●

To go to the next flow in the layout, choose Edit > Go To > Go To Next Flow.

RESULT
The music area updates to show the start of the corresponding flow. Dorico Pro automatically
positions the top staff towards the top left of the music area.
TIP
You can assign key commands to both Go To Previous Flow and Go To Next Flow on the Key
Commands page in Preferences.

RELATED LINKS
Key Commands page in the Preferences dialog on page 63

Going to pages
You can go to any specified page in the current layout using its page number, for example, to
jump quickly to the exact page that requires changes when editing music.
These steps function in Setup, Write, and Engrave modes.
PROCEDURE
1.

Choose Edit > Go To > Go To Page to open the Go To Page dialog.

2.

Enter the page number to which you want to go into the Page field.

3.

Click OK.

RESULT
The music area updates to show the start of the corresponding page. Dorico Pro automatically
centers the top of the page in the music area.
TIP
You can assign a key command for Go To Page on the Key Commands page in Preferences.

Going to bars
You can go to any specific bar in any flow in the current layout, for example, to jump quickly to
the exact bar that requires changes when editing music.
These steps function in Setup, Write, Engrave, and Play modes.
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PROCEDURE
1.

Press Ctrl/Cmd-G to open the Go To Bar dialog.

2.

Select the flow containing the bar to which you want to go from the Flow menu.

3.

Enter the bar number to which you want to go into the Bar field.

4.

Click OK.

RESULT
The music area updates to show the corresponding bar. Dorico Pro automatically positions the
top staff towards the top left of the music area.
In Play mode, the playhead moves to the start of the corresponding bar. Dorico Pro automatically
positions the playhead at the start of the ruler.

Dragging pages in the music area
You can drag pages in the music area in Write mode and Engrave mode to bring other parts of
your music into view, including in galley view.
PROCEDURE
1.

In the status bar, click Hand Tool.

2.

Click and drag in any empty space within the page boundaries in the music area.
The mouse pointer changes into a hand symbol during the move.

RELATED LINKS
Status bar on page 52
Selection tools on page 53

Zooming in/out of the music area
You can change the zoom level in the music area, for example, if you want a larger overview
when inputting notes but to see notes and notations more closely when making detailed
graphical amendments.
PREREQUISITE
If you want to keep a specific item in the center of the music area when you zoom in/out, you
have selected that item.
PROCEDURE
1.

2.

Zoom in in any of the following ways:
●

Press Ctrl/Cmd-= or Z .

●

Spread two fingers outwards on a touchpad.

●

Scroll upwards on a mouse wheel.

●

Use the zoom options in the status bar.

Zoom out in any of the following ways:
●

Press Ctrl/Cmd-- or X .

●

Pinch two fingers together on a touchpad.

●

Scroll downwards on a mouse wheel.
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●

Use the zoom options in the status bar.

RESULT
The zoom level in the music area is changed. If you had anything selected, Dorico Pro uses your
selection as the focal point of the zoom. If you had nothing selected, Dorico Pro focuses on the
area previously in the center of the view.
RELATED LINKS
Zoom options on page 55
Zooming in/out of tracks in the event display on page 510
Workspace setup on page 55

Signposts
In Dorico Pro, signposts indicate the positions of important items or changes that cannot be seen
in the score, such as key signatures with no accidentals, hidden items, and note spacing changes.
Signposts have different colors depending on the item they mark because many items can show
signposts, such as hidden bar numbers and time signatures. They are selectable, meaning you
can use signposts to change properties of hidden/invisible items, for example, by selecting
system break signposts in order to change the staff size from that position.
Signposts include a text summary of the hidden/invisible item to help you identify it. For
example, time signature signposts include the time signature, expressed as a fraction, and its
beat subdivision.

The signpost of a hidden time signature

You can hide/show signposts for the following items:
●

Accidentals

●

Chord symbols

●

Bracket and barline changes

●

Clefs

●

Cues

●

Dynamics

●

Frame breaks

●

Key signatures

●

Note spacing changes input using the Note Spacing Change dialog

●

Pedal lines

●

System breaks

●

Tempo marks

●

Text, both system and staff

●

Percussion legends

●

Time signatures

●

Tuplets
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When multiple signposts can exist at a single rhythmic position, they stack vertically so that they
do not overlap and remain legible.

Multiple signposts for different items at the same rhythmic position

NOTE
By default, signposts are not printed or included when you export graphics files.

RELATED LINKS
Annotations on page 610

Hiding/Showing signposts
You can hide/show all signposts or only hide/show signposts for specific items at any time in
Setup, Write, and Engrave modes.
PROCEDURE
●

Hide/Show signposts in any of the following ways:
●

To hide/show all signposts, choose View > Signposts > Hide Signposts.

●

To hide/show signposts for specific items, choose View > Signposts > [Type of item].

RESULT
Signposts for individual items are shown when a tick appears beside the corresponding item in
the menu, and hidden when no tick appears.
All signposts are shown when no tick appears beside Hide Signposts in the menu, and hidden
when a tick appears.

Arranging tools
Arranging tools in Dorico Pro allow you to allocate notes to different staves and voices quickly
and efficiently.
These tools include copying notes and items to multiple staves at the same time, and multiple
times within a selected range, moving notes between staves, and changing the voices of notes.
You can also explode notes onto more staves and reduce notes onto fewer staves.
RELATED LINKS
Filters on page 326
Condensing on page 470
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Deleting notes and items
You can delete any notes/items you have input into your project independently of each other,
such as deleting repeat endings without deleting the notes in them. However, you must be in
Write mode. You cannot delete notes and items in Setup, Engrave, or Print modes.
You can also delete notes in Play mode, but not other notation items.
PROCEDURE
1.

In Write mode, select the notes/items you want to delete.

2.

Press Backspace or Delete .

RESULT
All selected notes/items are deleted from your project. Deleted notes are replaced by implicit
rests as appropriate. Dorico Pro moves your selection to the most logical and nearby item to the
deleted items. For example, if you deleted a note, Dorico Pro‘s first choice is the nearest note in
the same voice.
If a slur began or ended on a deleted note, the slur is automatically repositioned to the next/
previous notehead. If only one note is left under a slur, the slur is automatically deleted.
Holds and pauses are not automatically deleted if they are not selected when you delete notes.
They are positioned above the note/rest closest to their rhythmic position, or over whole bar
rests if you delete all notes in a bar.
Any repeat barlines input as part of repeat endings are not deleted automatically when you
delete repeat endings.
TIP
You can also delete markers by selecting them in the Markers section of the Video panel and
clicking Delete in the action bar.

RELATED LINKS
Deleting barlines on page 640

Copying and pasting items
You can copy and paste items, including notes and notations, to other rhythmic positions and
staves in different ways.
PROCEDURE
1.

In Write mode, select the items you want to copy.

2.

Copy the selected items to other rhythmic positions in any of the following ways:
●

Alt/Opt -click each position to which you want to paste them.

●

Press R to repeat the material directly after itself.

●

Press Ctrl/Cmd-C , select the position to which you want to paste them, and press Ctrl/
Cmd-V .

●

To copy items to the staff above, select them and choose Edit > Paste Special >
Duplicate to Staff Above.

●

To copy items to the staff below, select them and choose Edit > Paste Special >
Duplicate to Staff Below.

RESULT
The selected items are copied without deleting them from their original positions.

337
Dorico Pro 3.1.10

Write mode
Arranging tools
RELATED LINKS
Copying and pasting automation points on page 527
Large selections on page 322
Selecting/Deselecting notes and items individually on page 320
Moving notes to other staves on page 339
Disabling automatic linking of dynamics and slurs when pasting on page 329
Repitching notes without changing their rhythm on page 202

Copying and pasting notes into different voices
You can copy and paste notes into voices that are different to their original voices, including into
slash voices. For example, you can copy notes from an up-stem voice on one staff into a downstem voice on another staff.
PROCEDURE
1.

In Write mode, select the notes you want to copy.

2.

Press Ctrl/Cmd-C to copy the selected notes.

3.

Select the staff to which you want to paste the notes, at the position where you want the
selection to start.

4.

Choose Edit > Paste Special > Paste Into Voice > [Existing or new voice]. You can also
choose this option from the context menu.

RESULT
The selected notes are copied to the selected staff and into the selected voice.

Copying and pasting items to multiple staves
You can copy and paste notes and other items to multiple staves at once, for example, to copy a
single phrase to all the woodwind staves when they are playing in unison.
PROCEDURE
1.

In Write mode, select the items you want to copy to multiple staves.

2.

Press Ctrl/Cmd-C to copy the selected items.

3.

Select an item on each staff to which you want to paste the selected items.

4.

Press Ctrl/Cmd-V to paste the selected items.

RESULT
The selected items are copied to all of the selected staves.
TIP
If you selected a range of items on each staff, the selected items are also pasted multiple times
to fill the selected range.

RELATED LINKS
Large selections on page 322
Disabling automatic linking of dynamics and slurs when pasting on page 329

338
Dorico Pro 3.1.10

Write mode
Arranging tools

Copying and pasting items to fill a selected range
You can copy and paste items, including notes and notations, multiple times within a selected
range at once, for example, if you want to fill multiple bars with the same phrase.
NOTE
You can only copy and paste items that have a duration to fill a selection. For example, you can
copy and paste gradual dynamics to fill a selection but not immediate dynamics.

PROCEDURE
1.

In Write mode, select the items you want to copy throughout a range.

2.

Press Ctrl/Cmd-C to copy the selected items.

3.

Select the range throughout which you want to paste the selected items.

4.

Press Ctrl/Cmd-V to paste the selected items.

RESULT
The selected items are copied as many times as will fit within the selected range without
extending beyond it.
TIP
If you selected a range on multiple staves, the selected items are also pasted to multiple staves.

RELATED LINKS
Large selections on page 322

Moving notes to other staves
You can move notes to other staves of any type, for example, if you want to move individual
notes from one keyboard staff to another after importing a keyboard part from a MIDI file.
PROCEDURE
1.

In Write mode, select the notes you want to move to another staff.

2.

Move the notes to another staff in one of the following ways:
●

To move notes to the staff above, press Alt/Opt-N .

●

To move notes to the staff below, press Alt/Opt-M .

RESULT
The selected notes are moved to another staff by cutting them from their original staff and
pasting them to the new staff. By default, they are pasted into the first voice active on that staff.
NOTE
When moving notes within tuplets to other staves, those notes do not remain tuplets unless you
have also selected the tuplet bracket, tuplet number/ratio, or tuplet signpost.

RELATED LINKS
Creating cross-staff beams on page 672
Copying and pasting items to multiple staves on page 338
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Swapping the contents of staves
You can swap the contents of two staves for a selected range, for example, if you want to change
quickly the default voicing in two particular bars that was achieved by exploding a chord or if you
change your mind about which players have each line in an arrangement.
PROCEDURE
1.

In Write mode, select the range of music on two staves that you want to swap.

2.

Choose Edit > Paste Special > Swap. You can also choose this option from the context
menu.

RESULT
The contents of the selected staves for the selected duration are swapped.
RELATED LINKS
Swapping the contents of voices on page 342

Reducing music onto fewer staves
You can reduce music onto fewer staves than it was originally notated across, for example, to
create a piano reduction of a choral piece.
PROCEDURE
1.

In Write mode, select the music you want to reduce.

2.

Press Ctrl/Cmd-C to copy the music.

3.

Select the staves onto which you want to reduce the selected music.

4.

Choose Edit > Paste Special > Reduce. You can also choose this option from the context
menu.

RESULT
The selected music is reduced onto the selected staves.
If the rhythms match, Dorico Pro merges the music into a single voice. Unison notes are removed
so that only a single note of the same pitch is pasted at a single rhythmic position, and clef
changes, octave lines, and cues are also deleted.
Each destination staff receives the music of at least one instrument, and the division of the music
to be reduced is calculated from the top selected staff downwards. For example, if you copy
material from five instruments and reduce it to three, the top selected staff is assigned the music
from the first and second instruments, the second selected staff is assigned music from the third
and fourth instruments, and the third selected staff is assigned music from the fifth instrument.
RELATED LINKS
Moving notes to other staves on page 339
Condensing on page 470

Exploding music onto multiple staves
You can explode music onto more staves than it was originally notated for, for example, to get
notes in dense piano chords onto all the woodwind staves quickly.
PROCEDURE
1.

In Write mode, select the music you want to explode.

2.

Press Ctrl/Cmd-C to copy the music.
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3.

Select the staves onto which you want to explode the selected music.

4.

Choose Edit > Paste Special > Explode. You can also choose this option from the context
menu.

RESULT
The selected music is exploded onto the selected staves. Each destination staff receives at least
one of the notes in the source chords, allocated from the top selected instrument staff
downwards.
●

If the number of notes in the chord matches the number of destination staves, each
instrument receives one note.

●

If the number of notes in the chord is less than the number of destination staves, then the
same note is allocated to multiple staves. Notations, such as slurs and dynamics, are
duplicated to each destination staff.

●

If the number of notes in the chord is more than the number of destination staves, then the
notes are spread as equally as possible across the destination staves. If the chord contained
an odd number of notes, Dorico Pro prefers to allocate extra notes to the upper staves.

Changing the voice of existing notes
You can change the voice of notes after they have been input, including notes in slash voices. For
example, you can change notes in an up-stem voice to a down-stem voice.
PROCEDURE
1.

In Write mode, select the notes whose voice you want to change.
TIP
You can use large selections and filters to select many notes in the same voice quickly.

2.

Change the voice in any of the following ways:
●

Choose Edit > Voices > Change Voice > [Voice].

●

Choose Edit > Voices > Change Voice > [Slash Voice].

TIP
●

You can also choose these options from the context menu.

●

If there is only one voice on the staff, you can create a new voice for your selected notes.

RESULT
The voice of the selected notes is changed, which might cause Dorico Pro to change the stem
directions of the selected notes and other notes on the staff, and add implicit rests to ensure
correct notation based on convention.
AFTER COMPLETING THIS TASK
You can later delete or hide rests and change the stem direction of notes manually.
You can also change whole voices into slash voices.
RELATED LINKS
Hiding/Showing voice colors on page 1295
Large selections on page 322
Filters on page 326
Implicit rests in multiple-voice contexts on page 1108
Deleting rests on page 1110
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Changing the stem direction of notes on page 1199
Changing the slash voice type on page 1299

Swapping the contents of voices
You can swap the contents of two voices that contain musical material.
PROCEDURE
1.

In Write mode, select the notes in two voices that you want to swap.

2.

Choose Edit > Voices > Swap Voice Contents. You can also choose this option from the
context menu.

RESULT
The contents of the voices are swapped. For example, the notes previously in an up-stem voice
are now in a down-stem voice, and the notes previously in a down-stem voice are now in an upstem voice.
NOTE
Depending on the pitches involved in the swap and their stem directions, the notes might
overlap. Dorico Pro automatically positions notes with the noteheads partially overlapping, in
order to minimize the horizontal space they occupy and maintain the clarity of the rhythm.
However, if you want to change this arrangement, you can change the order of voices or change
the voice column index.
EXAMPLE

An E is in the up-stem voice, an F in the down-stem
voice.

After swapping their voice contents, the E is in the
down-stem voice, and the F is in the up-stem voice.

RELATED LINKS
Swapping the order of voices on page 1297
Voice column index on page 1297

Splitting flows
You can split flows at specific rhythmic positions. Flows in Dorico Pro are independent of each
other, meaning they can contain different players, have different time signatures and key
signatures, and have different options for notations, including note grouping and accidental
duration rules.
PREREQUISITE
The layout currently open in the music area contains all players with music in the flow, such as a
full score layout.
IMPORTANT
We strongly recommend only splitting flows in layouts that contain all players.
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PROCEDURE
1.

In Write mode, select a note or item at the position where you want to split the flow.

2.

Choose Write > Split Flow.

RESULT
The flow is split into two flows: the existing flow and a new flow that begins from the position of
the item you selected. By default, new flows in full score layouts start on a new page in page view
and are shown on a separate background in galley view.
AFTER COMPLETING THIS TASK
You can set options for each flow independently in the Notation Options dialog.
RELATED LINKS
Flows on page 132
Adding flows on page 133
Deleting flows on page 134
Notation Options dialog on page 160
Deleting empty bars at the end of flows on page 632
Allowing/Disallowing multiple flows on the same page on page 443
Switching to galley/page view on page 60

Comments
Comments allow you to add notes or instructions at precise positions in your project without
affecting the music. They are considered annotations in Dorico Pro, meaning they are not printed
by default.
Comments exist outside of the music, so they do not affect note spacing, vertical spacing, or
casting off. However, you can attach them to specific items and staves in order to show the
precise subject of each comment.

A passage with comments and replies

By default, comments are shown in the music area. They appear as speech bubble symbols as
close as possible to their attached position. Comments that are replies are stacked vertically
below the original comment.
All comments in the current flow are listed in the Comments panel in Write mode. Clicking a
comment, either in the Comments panel or in the music area, automatically moves the view to
bring that rhythmic position into focus.
In addition to its content, each comment identifies the following:
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●

Author of the comment, using either the current user account name or a custom name
On macOS, the user account name uses the long account name; on Windows, it uses the full
name associated with the account. If Dorico Pro cannot determine your account name, a
dialog appears into which you can add the name and initials you want to use for comments.
You can also change these in Preferences.

●

Date the comment was added

●

Instrument to which the comment applies

●

Bars to which the comment applies

NOTE
In the music area, only the initials of the author are shown. In the Comments panel, all
information is shown.
You can hide/show comments at any time, and you can choose to include them, alongside other
view options, when printing/exporting layouts.
RELATED LINKS
Deleting notes and items on page 337
Comments panel on page 345
Changing the author name used for comments on page 348
Annotations on page 610

Adding comments
You can add comments at any rhythmic position in your project, including adding different
comments to multiple staves at the same rhythmic position.
PROCEDURE
1.

In Write mode, select an item on the staff and at the rhythmic position where you want to
add a comment. If you want your comment to apply to a range, select multiple items.

2.

Press Alt/Opt-C to open the Comment dialog.

3.

Enter your comment into the dialog.

4.

Click OK to close the dialog and add the comment.

RESULT
The text you entered into the dialog is saved as a comment. In the music area, it is indicated by a
speech bubble symbol that contains your initials. In the Comments panel, the text you entered is
shown alongside your full username, the date, and the instrument and bar number to which you
added the comment.
TIP
You can also add comments by clicking Create Comment in the action bar in the Comments
panel, or by choosing Write > Create Comment.
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EXAMPLE

A comment in the music area

Comment dialog
The Comment dialog allows you to enter and edit text as comments.
●

You can open the Comment dialog by adding a comment, replying to a comment, or doubleclicking an existing comment, either in the music area or in the Comments panel.

Comment dialog

Comments panel
The Comments panel shows all the comments in the current flow as a list. Replies to comments
are indented to indicate their relationship to the original comment. The Comments panel is
located on the right of the window in Write mode.
●

You can hide/show the Comments panel by clicking Comments in the Notations toolbox on
the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.
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Comments panel

Each comment in the panel shows the following:

1

Author name
This uses either the current user account or a custom name, depending on the preference
that was set when the comment was added.

2

Comment content

3

Date the comment was added to the project

4

Instrument to which the comment applies

5

Bars to which the comment applies

The action bar at the bottom of the panel contains the following options:
Create Comment
Adds a comment to the selected rhythmic position and staff.
Edit Comment
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Opens the selected comment in the Comment dialog and allows you to change its
content.
Reply to Comment
Adds a comment that is a reply to the selected comment. Replies are shown indented
in the Comments panel and stacked in the music area.
Export Comments
Exports all the comments in the project as an HTML file, which opens automatically in
your default web browser. The HTML file is automatically saved in the same location as
the project.
Delete Comment
Deletes the selected comments.
RELATED LINKS
Changing the author name used for comments on page 348
Exporting comments on page 349

Replying to comments
You can add replies to existing comments, which is useful when co-ordinating with others as this
organizes the list of comments in the Comments panel into clear sections.
PROCEDURE
1.

In Write mode, select the comment to which you want to reply. You can do this in the music
area and in the Comments panel.

2.

Press Alt/Opt-R to open the Comment dialog.

3.

Enter your reply into the dialog.

4.

Click OK to close the dialog and add the reply.

RESULT
The text you entered into the dialog is saved as a reply to the selected comment. In the music
area, it is indicated by a speech bubble symbol that contains your initials and is positioned
immediately below the selected comment.
In the Comments panel, the reply is indented below the selected comment.
TIP
You can also reply to comments by clicking Reply to Comment in the action bar in the
Comments panel, or by choosing Write > Reply to Comment.
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EXAMPLE

A reply stacked below the selected comment

Editing existing comments
You can change the contents of existing comments after you have added them, for example, to
correct misspellings or add further information.
PROCEDURE
1.

Double-click the comment you want to edit to open the Comment dialog. You can do this in
the music area and in the Comments panel.

2.

Change the text in the dialog.

3.

Click OK to save your changes and close the dialog.

Changing the author name used for comments
You can change the author name used for comments to either your user account name or a
custom name. This affects subsequent comments you add to the project without changing the
author name used for existing comments.
For the custom name, you can specify both the full name that is shown in the Comments panel
and the initials shown in the music area.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click General in the page list.

3.

In the Comments subsection, choose one of the following options for Author name for
comments:
●

User Name

●

Custom Name

4.

Optional: If you chose Custom Name, enter the full name you want to use into the Full
name field.

5.

Optional: If you chose Custom Name, enter the initials you want to use into the Initials
field.

6.

Click Apply, then Close.
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Exporting comments
You can export all comments in all flows in your project to an HTML file, for example, to view
them all in a single place.
PROCEDURE
1.

In Write mode, click Comments in the Notations toolbox to show the Comments panel.

2.

In the Comments section action bar, click Export Comments.

RESULT
All comments in the project are saved as an HTML file, which opens automatically in your default
web browser. The comments are displayed in a table. The HTML file is automatically saved in the
same location as the project.

Hiding/Showing comments
You can hide/show comments at their positions in the music, for example, if you want to hide
them when inputting music but show them when engraving.
PROCEDURE
●

Choose View > Comments.

RESULT
Comments are shown in the music as speech bubbles when a tick appears beside Comments in
the menu, and hidden when no tick appears.
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Engrave mode allows you to manipulate and modify every item in your project, but without
deleting them, moving them rhythmically, or changing the pitch of notes. You can also determine
how the pages in each layout of your project are formatted for printing or exporting.

Project window in Engrave mode
The project window in Engrave mode contains the default toolbar, the music area, and the status
bar. It provides panels with all the tools and functions that allow you to format the pages,
systems, and properties of individual notations in your score.
You can switch to Engrave mode in any of the following ways:
●

Press Ctrl/Cmd-3 .

●

Click Engrave in the toolbar.

●

Choose Window > Engrave.

Toolbox and panels in Engrave mode

The project window in Engrave mode contains the following:
1

Engrave toolbox
Contains options that allow you to determine which formatting options are shown in the
Formatting panel, and to activate Note Spacing and Staff Spacing.

2

Formatting panel
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Contains formatting options that allow you to control how music is arranged into systems
and frames, to insert frames, and edit frame constraints. Your current selection in the
Engrave toolbox determines which formatting options are shown, and the panel is hidden
automatically when either Note Spacing or Staff Spacing are activated.
3

Pages panel
Allows you to specify how the notation is formatted on pages. The way this is done is based
on the typical techniques used in desktop publishing programs.

4

Properties panel
Contains quick access properties that allow you to make specific modifications to individual
parts of notes and notations.

RELATED LINKS
Windows on page 42

Engrave toolbox
The Engrave toolbox allows you to change the options available in the Formatting panel and to
activate note and staff spacing. The Engrave toolbox is located on the left of the window in
Engrave mode.
Graphic Editing

Allows you to select and edit items in the music area or master page editor, and opens
sections in the Formatting panel that allow you to edit the formatting of systems,
frames, brackets, braces, and barline joins.
Frames

Allows you to select and edit frames in the music area or master page editor, and
opens sections in the Formatting panel that allow you to insert frames and edit their
constraints.
Staff Spacing

Allows you to move individual staves and systems vertically.
Note Spacing

Allows you to edit the graphical horizontal positions of individual notes and other
items, such as clefs and key signatures.
RELATED LINKS
Frames on page 386
Frame constraints on page 406
Staff spacing on page 455
Note spacing on page 425
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Formatting panel
The Formatting panel in Engrave mode allows you to insert different kinds of frames into pages
and to specify how these are aligned on a page. It also allows you to make changes to how
systems and frames are formatted on pages, including manually adding brackets and braces.
The Formatting panel is located on the left of the window in Engrave mode. You can hide/show
the Formatting panel in any of the following ways:
●

Press Ctrl/Cmd-7 .

●

Click the disclosure arrow on the left edge of the main window.

●

Choose Window > Show Left Panel.

Depending on your selection in the Engrave toolbox, different formatting options are available in
the Formatting panel.
The following sections are available when Graphic Editing is selected in the Engrave toolbox:

Format Music Frames
The Format Music Frames section allows you to change how the music in the layout currently
open in the music area is arranged into frames.
Insert Frame Break

Forces music from the selected item onwards onto the next frame, which is often on
the next page. This allows you to control what music appears on each page.
Lock Frame

Fixes the formatting of the selected frames, even if you change the formatting of
surrounding frames.
Make into Frame

Forces all music between the selected items into the same frame. You can use this
option to force music onto a single page.

Format Systems
The Format Systems section allows you to change how the music in the layout currently open in
the music area is arranged into systems.
Insert System Break

Forces music from the selected item onwards onto the next system. Depending on
your staff size and other settings, this may mean the music is forced onto the next
page.
Lock System
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Fixes the formatting of the selected systems, even if you change the formatting of
surrounding musical material and other systems.
Make into System

Forces all music between the selected items into the same system.

Bracketing
The Bracketing section allows you to change how the staves in the layout currently open in the
music area are bracketed and braced together, and change which staves are joined by barlines,
in each system individually.
Insert bracket

Joins the staves on which you have selected items with a bracket. By default, this also
causes barlines to be drawn across the bracketed group.
Insert sub-bracket

Joins the staves on which you have selected items with a sub-bracket.
NOTE
The selected staves must be within a bracket.
Insert sub-sub-bracket

Joins the staves on which you have selected items with a sub-sub-bracket.
NOTE
The selected staves must be within a bracket and sub-bracket.
Insert brace

Joins the staves on which you have selected items with a brace.
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NOTE
Staves cannot be joined by both a brace and a sub-bracket or sub-sub-bracket
simultaneously.
Change barline joins

Joins the barlines across the staves on which you have selected items.
The following sections are available when Frames is selected in the Engrave toolbox:

Insert Frames
The Insert Frames section allows you to create new frames on pages in layouts as well as on
master pages.
Insert Music Frame

Allows you to insert a music frame. On pages in layouts, this inserts a music frame that
belongs to a layout frame chain. On master pages in the master page editor, this
inserts a frame that belongs to a master page frame chain.
Insert Text Frame

Allows you to insert a frame into which you can enter text and text tokens.
Insert Graphics Frame

Allows you to insert a frame that can contain an image or an illustration.
Constraints
Allows you to specify which sides of the frame you want to lock to the page margin.
RELATED LINKS
Frames on page 386
Music frames on page 389
Text frames on page 395
Graphics frames on page 405
Master pages on page 361
Music frame chains on page 390
Brackets and braces on page 683
Frame constraints on page 406
Frame breaks on page 463
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Pages panel
The Pages panel in Engrave mode provides several sections that allow you to specify how the
pages of your notation are formatted. The way this is done is based on the typical techniques as
they are used in desktop publishing programs.
The Pages panel is located on the right of the window in Engrave mode. You can hide/show the
Pages panel in any of the following ways:
●

Press Ctrl/Cmd-9 .

●

Click the disclosure arrow on the right edge of the main window.

●

Choose Window > Show Right Panel.

Pages panel in Engrave mode

The Pages panel is divided into the following sections:
Pages
Shows the pages in your layout with their page number in the middle. A highlighted
page frame indicates the currently selected page. Markings in the top left and the
bottom right corner of the pages indicate that a page has overrides. Additional frames
at the top or left frames of the page indicate that master page changes have been
applied.
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The action bar at the bottom of the section contains the following options:
●

Insert Pages: Allows you to insert pages into your layout before or after existing
pages, based on a selected master page.

●

Insert Page Number Change: Allows you to change the page numbers for pages
in your layout.

●

Insert Master Page Change: Allows you to assign a different master page to the
selected page or from the selected page onwards.

●

Insert Flow Heading Change: Allows you to assign a different flow heading to the
selected page or from the selected page onwards.

●

Swap with Previous Page: Swaps the arrangement of the selected page with the
previous page.

●

Swap with Next Page: Swaps the arrangement of the selected page with the next
page.

●

Remove Overrides: Removes master page overrides from the selected pages.

Master Pages
Shows the master page pairs that are used in your layout. A highlighted frame
indicates the currently selected master page. If you select a page in the Pages display,
the master pages display highlights the master page pair that is used for this page.
The Current set menu allows you to view and change the master page set used in the
layout currently open in the music area.
The action bar at the bottom of the section contains the following options:
●

New Master Page: Allows you to add a new master page to a master page set.

●

Edit Master Page: Opens the master page editor in which you can change the
formatting of the master page. You can also open the master page editor by
double-clicking a master page in the Flow Headings section.

●

Rename Master Page: Allows you to rename the selected master page.

●

Import Master Page: Allows you to import individual master pages from any of
the other master page sets in the project.

●

Delete Master Page: Deletes the selected master page.
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Flow Headings
Shows the flow headings available in the currently selected master page set. A
highlighted frame indicates the currently selected flow heading.
The action bar at the bottom of the section contains the following options:
●

New Flow Heading: Allows you to add a new flow heading to a master page set.

●

Edit Flow Heading: Opens the flow heading editor in which you can change the
formatting of the flow heading. You can also open the flow heading editor by
double-clicking a flow heading in the Flow Headings section.

●

Rename Flow Heading: Allows you to rename the selected flow heading.

●

Delete Flow Heading: Deletes the selected flow heading.

Master Page Sets
Contains a list of available master page sets in the project.
The action bar at the bottom of the section contains the following options:
●

New Master Page Set: Creates a new master page set based on the master page
set that is selected in the list. The new master page set is automatically added to
the Current set menu in the Master Pages section.

●

Rename Master Page Set: Allows you to rename the selected master page set.

●

Import Master Page Set: Opens the File Explorer/macOS Finder, where you can
select the master page set .doricolib file that you want to import into the
current project.

●

Export Master Page Set: Opens the File Explorer/macOS Finder, where you can
select the location to which you want to export the selected master page set as
a .doricolib file. You can then import the .doricolib file into other projects
and share it with other users.

●

Delete Master Page Set: Deletes the selected master page set from the project.

RELATED LINKS
Master pages on page 361
Master page sets on page 362
Master page editor on page 370
Flow headings on page 381
Flow heading editor on page 382

Properties panel (Engrave mode)
The Properties panel in Engrave mode provides options that allow you to edit individual notes
and notations. All the properties that are available in the Properties panel in Write mode are also
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available in Engrave mode, but additional properties in Engrave mode allow you to edit items in
more detail.
You can hide/show the Properties panel in Write mode and Engrave mode in any of the following
ways:
●

Press Ctrl/Cmd-8 .

●

Click the disclosure arrow at the bottom of the main window.

●

Choose Window > Show Bottom Panel.

The Properties panel contains a group of properties for each notation item. When you select a
note or item in the music area, the Properties panel displays the groups and options that you
might require to edit the selected note or item.

Notes and Rests group of the Properties panel in Engrave mode

NOTE
●

If you select multiple different types of notation items, only the groups that they have in
common are displayed. For example, if you select a slur, the Common and Slurs groups are
displayed in the Properties panel. However, if you select a slur and a note, only the Common
group is displayed.

●

Many properties are layout-specific, meaning changing the properties of an item in one
layout does not affect the same item in other layouts. However, you can copy property
changes to other layouts.

RELATED LINKS
Changing the properties of individual notes and items on page 157
Copying property settings to other layouts on page 493
Resetting the appearance of items on page 331
Resetting the position of items on page 331

Selecting handles on items
In Engrave mode, you can select individual handles on items, for example, if you want to move
the graphical end of a gradual dynamic without moving its start.
NOTE
These steps do not apply to frame, note spacing, or staff spacing handles.

PROCEDURE
1.

Select a handle in any of the following ways:
●

Select the whole item and press Tab until the handle you want is selected.

●

Click the handle you want.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
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2.

Optional: Select handles on other items as well by Ctrl/Cmd -clicking them.
NOTE
You cannot select subsequent handles on other items by selecting the items and pressing
Tab .

Engraving Options dialog
The Engraving Options dialog provides multiple options that allow you to make project-wide
changes to your project by changing the graphical appearance and position of items.
You can make changes to, for example, the line thickness of notation items, their continuation
style, their default staff-relative placement, and their minimum distance from the staff and other
items.
TIP
●

You can save all options that you set in Engraving Options as the default for new projects by
clicking Save as Default.

●

If you want to make changes to individual notes and notations, you can use properties in the
Properties panel.

You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Engraving Options

The Engraving Options dialog contains the following:
1

Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages. When you click a page in this list, any applicable section titles appear below the page
in the page list.
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2

Section titles
Shows the titles of any sections on the selected page. You can click these section titles to
navigate directly to that section of the page.

3

Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible settings,
the current setting is highlighted.

4

Save as Default/Remove Saved Defaults
This button has different functions depending on whether you have existing saved defaults.

5

●

Save as Default saves all options currently set in the dialog as the default for new
projects.

●

Remove Saved Defaults deletes your previous saved defaults without resetting the
options in the current project. After removing your saved defaults, all future projects
start with the default factory settings. If you have existing saved defaults, you can access
Remove Saved Defaults by pressing Ctrl (Windows) or Opt (macOS) .

Reset to Factory/Reset to Saved Defaults
This button has different functions depending on whether you have existing saved defaults.
●

If you have no saved defaults, Reset to Factory resets all the options in the dialog back
to the default factory settings.

●

If you have existing saved defaults, Reset to Saved Defaults resets all the options in the
dialog back to your saved defaults. You can access Reset to Factory instead by pressing
Ctrl (Windows) or Opt (macOS) . Resetting options back to the default factory settings
only affects the current project and does not delete your saved defaults, meaning future
projects start with your saved defaults.

RELATED LINKS
Options dialogs in Dorico Pro on page 40
Resetting the appearance of items on page 331
Resetting the position of items on page 331

Making project-wide changes in Engraving Options
You can make project-wide changes to the appearance, placement, and default position of notes
and notations in Engraving Options.
PROCEDURE
1.

Open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

2.

Click a page in the page list.

3.

Look through the available options, and change the settings as required.

4.

Click Apply, then Close.
NOTE
If you make changes and close the dialog without clicking Apply, you are prompted to save
or discard your changes.

RESULT
The changes are applied to all music in your project, including in all layouts and flows.
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Master pages
Master pages function like templates in Dorico Pro, allowing the same page formatting to be
applied to multiple different pages in different layouts.
NOTE
Page size and margins, page orientation, and staff size for all layouts are specified in Setup >
Layout Options.
All pages in your score and parts inherit their layout formats from master pages. Whenever you
create or change anything on master pages, this is automatically reflected on the pages that use
these master pages. For example, if you insert a new frame on a master page, a corresponding
frame appears on all the pages that use that master frame, so long as those pages do not have
master page overrides.
In Dorico Pro, master pages consist of page pairs. Every page pair has a left and a right master
page, so that if a page in your project falls on a left page, the formatting of the left page of the
master page pair is used, and if a page falls on a right page, the formatting of the right page of
the master page pair is used. In both the Master Pages section of the Pages panel and the
master page editor, page pairs appear side-by-side.
Dorico Pro provides default master pages for first (First) and subsequent (Default) pages. This
enables you to format first pages differently compared to subsequent pages. Master pages are
contained in master page sets for full score and part layouts. Master page sets are automatically
applied to every layout that you create.

The Master Pages section of the Pages panel in Engrave mode, showing the two default master pages in the
Default Full Score master page set.

If you want to change the master page sets or to change the format of the master pages, you
can do so in any of the following ways:
●

Create new master pages and master page sets.

●

Edit the default master pages in the master page sets using the master page editor.

NOTE
Changing individual pages in layouts is considered a master page override in Dorico Pro, which is
a type of page format change. This includes, for example, editing the title or running header on
one page, rather than in the master page editor. Pages with master page overrides no longer get
updated if you change the master page and are not automatically deleted, even if they are empty
because the layout became shorter.

361
Dorico Pro 3.1.10

Engrave mode
Master pages
RELATED LINKS
Pages panel on page 355
Master page editor on page 370
Page format changes on page 372
Layout Options dialog on page 104

Master page sets
In Dorico Pro, master pages are provided as parts of master page sets. Master page sets group
master page formats together, so there is a master page for all possible situations in your
project.
The default master page sets contain predefined master pages for first page pairs (First) and
subsequent page pairs (Default). This ensures there is a master page format for the first page in
each flow, whether that is on a right page or a left page, and a master page format for
subsequent pages in each flow on both right and left pages.
New projects contain the following master page sets by default:
●

Default Full Score: Used for full score layouts by default.

●

Default Part: Used for part layouts by default.

Master page sets also contain flow headings that allow you to format how the titles of flows
appear when they start on the same page as a previous flow. The default master page sets each
contain a single flow heading.
You do not need to create or customize master page sets initially, as the default sets are applied
automatically when you create your project. If you find that you want or need to change the sets,
you can do so in any of the following ways:
●

Create new custom master page sets based on the default sets.

●

Change the default sets according to your requirements for the current project.

TIP
You can share master pages between master page sets by importing master pages. For example,
if you created a new title page master page in the Default Full Score master page set, you can
then import it into in the Default Part master page set to use it in part layouts as well.
You can also share master page sets between different projects by exporting and importing
them.

RELATED LINKS
Master page types on page 365
Flow headings on page 381
Importing master page sets on page 363
Exporting master page sets on page 363
Importing master pages on page 367

Creating master page sets
You can create new master page sets. They can be based on the sets provided by Dorico Pro and
on existing custom master page sets you have created.
PROCEDURE
1.

In the Master Page Sets section of the Pages panel, click the master page set on which you
want to base a new master page set.

2.

In the action bar, click New Master Page Set.
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RESULT
A new master page set is created based on the selected default master page set. It appears
immediately in the list of master page sets.
AFTER COMPLETING THIS TASK
You can rename your new master page set and add new master pages to it.
RELATED LINKS
Adding master pages on page 365

Importing master page sets
You can import master page sets into projects, for example, if you want to use a master page set
you created on a different computer or that contains a specific master page you want to use.
Master page sets are saved as .doricolib files.
PROCEDURE
1.

In the Pages panel, click Import Master Page Set in the Master Page Sets action bar to
open the File Explorer/macOS Finder.

2.

Locate and select the master page set file you want to import.

3.

Click Open.

RESULT
The selected master page is imported. It becomes available in the current project only.
AFTER COMPLETING THIS TASK
You can import individual master pages from the master page set into other master page sets in
your project.
RELATED LINKS
Importing master pages on page 367
Pages panel on page 355

Exporting master page sets
You can export master page sets so you can send them to other users or use them in other
projects. By default, any master page sets you create or edit are available in the current project
only.
PROCEDURE
1.

In the Master Page Sets section of the Pages panel, select the master page set you want to
export.

2.

Click Export Master Page Set to open the File Explorer/macOS Finder.

3.

Specify a name and location for the master page set file.

4.

Click Save.
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RESULT
The selected master page set is exported and saved in the selected location as a .doricolib
file.

Renaming master page sets
You can edit the names of master page sets that you have created. You cannot rename the
default master page sets.
PROCEDURE
1.

In the Master Page Sets section of the Pages panel, double-click the master page set that
you want to rename.
Alternatively, you can select the master page set and click Rename Master Page Set in the
action bar.

2.

Enter the new name you want.

3.

Press Return .

Deleting master page sets
You can delete master page sets that you no longer need, including the default master page sets.
PROCEDURE
1.

In the Master Page Sets section of the Pages panel, click the master page set that you want
to delete.

2.

In the action bar, click Delete Master Page Set.

Applying master page sets to layouts
You can apply a different master page set to each layout in your project.
PROCEDURE
1.

In the music area, open the layout to which you want to apply a master page set.

2.

In the Master Pages section of the Pages panel, select a master page set from the Current
set menu.

RESULT
The selected master page set is applied to the layout.
AFTER COMPLETING THIS TASK
You can make further changes to the layout, such as assigning different master pages in the
master page set to individual pages. You can also make individual master page overrides that
only apply to pages in the current layout, for example, if you need the frame padding on the first
page to be different to the master page setting.
RELATED LINKS
Assigning master pages to pages on page 377
Page format changes on page 372
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Master page types
If you add a new master page to a master page set, you must specify the type of master page
that you want to add.
You can add the following types of master pages:
First
A page pair that is usually used for the first page of music in a layout. By default, First
master pages contain tokens to display the project title, composer, and lyricist in
addition to the music.
Every master page set can only contain a single First master page.
NOTE
If you create no First page pair, the first page in your layout uses the Default page
pair.
Default
A page pair that is usually used for pages after the first page in a layout. By default,
Default master pages contain tokens to display the flow title and page number in
addition to the music.
Every master page set must contain a Default master page, but can only contain a
single Default master page.
Custom
A page pair that can have any layout. Custom master pages allow you to create layouts
that you want to apply to multiple pages but not all pages, for example, if you want to
show an image at the same position on only the final pages in each part layout.
NOTE
If you insert a page to a layout using a custom master page, you create an override.
This means that if you insert a page in the middle or at the end of the layout using a
custom master page and then remove the override, that page is automatically
assigned the Default master page.

RELATED LINKS
Master page sets on page 362
Page format changes on page 372
Changing when the First master page is used on page 444

Adding master pages
You can add new master pages to master page sets. Each master page set can have multiple
custom master pages, but only a single first master page and single default master page.
TIP
You can share master pages between master page sets by importing master pages. For example,
if you created a new title page master page in the Default Full Score master page set, you can
then import it into in the Default Part master page set to use it in part layouts as well.

PROCEDURE
1.

In the music area, open a layout that uses the master page set to which you want to add
master pages.
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NOTE
You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.
2.

In the Pages panel, click New Master Page in the Master Pages action bar to open the New
Master Page dialog.

3.

Enter a name for the new master page into the Name field.

4.

Select the existing master page on which you want to base the new master page from the
Based on menu.
NOTE

5.

●

Master pages based on existing master pages are linked to the Based on master page.
Any changes you make to frames shared between the master pages affect both master
pages, for example, changing the text in an existing text frame. Deleting frames and
inputting new ones breaks this link.

●

Selecting (None) always creates a master page without any formatting.

Choose one of the following master page types for your new master page:
●

First

●

Default

●

Custom

NOTE
If you select First or Default, the new master page replaces that existing master page, as
each master page set can only have a single first and default master page.
If you want to create a new master page without replacing any existing master pages,
choose Custom.
6.

Click OK to save your changes and close the dialog.

RESULT
A new master page of the selected type is added to the selected master page set.
AFTER COMPLETING THIS TASK
●

You can apply master pages to individual pages in layouts that use the master page set to
which they belong.

●

You can customize your new master page.

●

You can import your new master page into other master page sets in the current project.

RELATED LINKS
Master page sets on page 362
Customizing master pages on page 371
Applying master page sets to layouts on page 364
Assigning master pages to pages on page 377
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New Master Page dialog
The New Master Page dialog allows you to add new master pages to the current master page
set, define the type of the new master page, and base new master pages on existing ones.
●

You can open the New Master Page dialog in Engrave mode by clicking New Master Page
in the Master Pages section of the Pages panel.

New Master Page dialog

The New Master Page dialog contains the following options:
Name
Allows you to enter a name for the new master page, for example, Title page.
Based on
Allows you to select an existing master page on which you want to base the new
master page. This creates a new master page with the same frames and formatting as
the Based on master page.
NOTE
Master pages based on existing master pages are linked to the Based on master page.
Any changes you make to frames shared between the master pages affect both master
pages, for example, changing the text in an existing text frame. Deleting frames and
inputting new ones breaks this link.
Type
Allows you to choose the type of the new master page.
NOTE
If you select First or Default, the new master page replaces that existing master page,
as each master page set can only have a single first and default master page.

RELATED LINKS
Master page types on page 365
Pages panel on page 355

Importing master pages
You can import individual master pages into the current master page set from other master page
sets in the project, for example, if you created a custom title page master page for your full score
and also want to use it in the part layouts.
PREREQUISITE
If you want to import a master page from a master page set not currently in the project, you
have imported that master page set.
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PROCEDURE
1.

In the music area, open a layout that uses the master page set into which you want to import
master pages.
NOTE
You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2.

In the Pages panel, click Import Master Page in the Master Pages action bar to open the
Import Master Page dialog.

3.

Select the master page set that contains the master page you want to import from the
Master page set menu.

4.

Select the master page you want to import in the Master page to import list.
NOTE
You can only select and import a single master page at a time.

5.

Click OK to import the selected master page and close the dialog.

RESULT
The selected master page is imported into the master page set used in the layout currently open
in the music area. It becomes available in all layouts using that master page set.
If you import a First or Default master page, the imported master page replaces that existing
master page, as each master page set can only have a single first and default master page.
Music frames are automatically assigned to their own frame chain, regardless of the frame chain
to which they were originally assigned in their source master page set.
NOTE
Any subsequent changes you make to the master page are not automatically reflected in other
master page sets into which you imported it. You can reimport master pages if you made
changes in one master page set that you want to appear in all master page sets that include the
master page.
AFTER COMPLETING THIS TASK
You can change the frame chains to which music frames are assigned on imported master pages.
RELATED LINKS
Importing master page sets on page 363
Assigning music frames to frame chains on page 392
Customizing master pages on page 371
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Import Master Page dialog
The Import Master Page dialog allows you to import individual master pages into the current
master page set from other master page sets in the project.

Import Master Page dialog

The Import Master Page dialog comprises the following:
Master page set menu
Allows you to select the master page set from which you want to import a master page.
You can only select master page sets already in the current project.
Master page to import
Contains the master pages in the selected master page set, displayed in a list. You can
only select and import a single master page at a time.
RELATED LINKS
Master pages on page 361
Master page sets on page 362
Importing master page sets on page 363

Renaming master pages
You can change the names of master pages, including the default master pages and your own
custom master pages.
PROCEDURE
1.

In the music area, open a layout that uses the master page set containing the master page
you want to rename.
NOTE
You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2.

In the Master Pages section of the Pages panel, click the master page pair that you want to
rename.

3.

In the action bar, click Rename Master Page to open the Rename Master Page dialog.

4.

Enter the name you want in the Name field.

5.

Click OK to save your changes and close the dialog.
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Deleting master pages
You can delete master pages from master page sets.
NOTE
You cannot delete Default master pages. Every master page set must contain at least a Default
master page. You can replace Default master pages by adding a master page and setting its type
to Default.

PROCEDURE
1.

In the music area, open a layout that uses the master page set containing the master page
you want to delete.
NOTE
You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2.

In the Master Pages section of the Pages panel, click the master page pair that you want to
delete.

3.

In the action bar, click Delete Master Page.

RESULT
The selected master page pair is deleted. You can undo this action if you deleted a master page
in error.

Master page editor
The master page editor allows you to view and change the format of the master pages.
You can open the master page editor in any of the following ways:
●

Double-click a page pair in the Master Pages section of the Pages panel.

●

Select a page pair in the Master Pages section of the Pages panel and click Edit Master
Page.

You can customize master pages in the master page editor to suit your requirements, including
inserting extra frames and editing/moving existing frames. You can also change the frame chains
to which music frames are assigned, and change which flows and players are assigned to frames.
NOTE
Tokens in text frames and music in music frames are automatically updated as appropriate for
each layout. However, graphics frames can only show a single image in all layouts. If you change
the image in a graphics frame in one layout, this updates the master page and affects all layouts.

370
Dorico Pro 3.1.10

Engrave mode
Master pages

A master page pair open in the master page editor

RELATED LINKS
Pages panel on page 355

Customizing master pages
You can customize master pages according to your needs in the master page editor. Changing a
master page affects the appearance of all layouts that use that master page.
NOTE
●

You must specify the page size, margins, page orientation, and staff size of layouts on the
Page Setup page in Setup > Layout Options.

●

Master pages based on existing master pages are linked to their Based on master page. Any
changes you make to frames shared between the master pages affect both master pages,
for example, changing the text in an existing text frame. Deleting frames and inputting new
ones breaks this link.

PREREQUISITE
If you want to customize a new master page, rather than the default master pages, you have
added a new master page to the appropriate master page set.
PROCEDURE
1.

In the Pages panel, double-click a master page pair in the Master Pages section to open the
master page editor.

2.

Change the layout of one of the pages of the selected master page pair. For example, you
can change the size and shape of frames.

3.

Optional: If you want both the left and right pages to be the same, click one of the following
Copy Page Layout buttons at the top of the music area, depending on which page you
changed:
●

Left to Right
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●

Right to Left

NOTE

4.

●

This copies the master page layout exactly from one page to the other, not as a
mirror. For example, text frames for page numbers are not kept on the outside edge
automatically.

●

Frames copied between right/left pages are linked, including the contents of text
frames. Deleting frames and inputting new ones breaks this link.

Click Apply, then Close.

RESULT
The selected master page pair is changed.
RELATED LINKS
Inputting frames on page 386
Entering text in text frames on page 402
Moving frames on page 387
Changing the size/shape of frames on page 387
Adding master pages on page 365
Master page editor on page 370

Page format changes
Page format changes are changes to the format or design of specific pages in individual layouts,
as determined by the master page set, that do not affect the underlying master pages. For
example, making a frame smaller on a single page in a part layout, or changing the page
numbers from a selected page onwards.
You can identify the type of page format changes by the markings shown on individual pages in
the Pages section of the Pages panel in Engrave mode.
Master page overrides
A change to the format of individual pages made directly in the music area, rather than
in the master page editor. For example, changing the size of a music frame, adding a
text frame for footnotes, or inserting empty pages all result in master page overrides.
Pages with master page overrides no longer automatically inherit changes that are
made to the master page. To return overridden pages to following their master page
format, you must remove master page overrides.
Pages with master page overrides are shown with a marking in their top left corner.

Master page override
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Page number changes
A change to the default page number sequence, such as numbering prefatory pages
with Roman numerals.
Pages with page number changes inherit any subsequent changes you make to the
master page. They are shown with a marking in their bottom right corner.

Page number change

Master page changes
A change to the master page assigned to individual pages or all pages from a specific
point. For example, you might have a master page for title pages that you assign to the
first page in every part layout.
Pages with master page changes inherit any subsequent changes you make to the
corresponding master page. They are shown with markings in the following places:
●

Master page changes on the current page only: along top edge.

●

Master page changes from the page onwards: along left and top edges.

Master page change to single page only

Master page change from selected page
onwards

Flow heading changes
A change to the flow heading assigned to individual pages or all pages from a specific
point. For example, if you want the margins above and below flow headings to be
smaller on pages with more staves.
Pages with flow heading changes inherit any subsequent changes you make to the
master page. They are shown with markings in the following places:
●

Flow heading changes on the current page only: along bottom edge.

●

Flow heading changes from the page onwards: along left and bottom edges.

Flow heading change to single page only

Flow heading change from selected page
onwards
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NOTE
●

If you inserted a page in the middle or at the end of your layout using a custom master page
and remove the override, that page is automatically assigned the Default master page of
the master page set.

●

You cannot save overrides you have made to individual pages as a master page. If you know
you want to use the same formatting on multiple pages, we recommend creating a new
master page.

RELATED LINKS
Inserting pages on page 441
Page numbers on page 972
Master pages on page 361
Master page editor on page 370
Adding master pages on page 365
Customizing master pages on page 371
Flow headings on page 381

Removing master page overrides
You can remove overrides that you have made to individual pages and return them to the master
page format.
Any pages in your layout that contain overrides are shown with a colored triangle in their top left
corner in the Pages section of the Pages panel. Master page overrides include changing the size/
shape of frames inherited from the master page or flow heading format, inputting extra frames
on the page, and inputting a new empty page.
Removing overrides from empty pages deletes them from the layout.
PROCEDURE
1.

In the music area, open the layout whose master page overrides you want to remove.

2.

Optional: If you want to remove overrides from individual pages, select those pages in the
Pages section of the Pages panel.
You can Shift -click adjacent pages and Ctrl/Cmd -click individual pages.

3.

Remove master page overrides in one of the following ways:
●

To remove overrides from selected pages only, click Remove Overrides in the Pages
section action bar.

●

To remove overrides from all pages, right-click in the Pages section of the Pages panel
and choose Remove All Page Overrides from the context menu.

RESULT
Any overrides you made to the master page format are removed from either the selected pages
only or from all pages in the layout currently open in the music area. Empty pages that are
considered overrides are deleted.
If you removed overrides from selected pages only, any other pages with overrides in the layout
are unaffected.
RELATED LINKS
Frames on page 386
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Inserting page number changes
You can change the page numbers of pages in each layout in your project. Inserting page
number changes allows you to change the page number shown, the page number style, and also
affects whether the first page in layouts is a left or right page.
For example, you can use Roman numerals such as ii and iv for front matter pages, and numbers
such as 1 and 3 for music pages.
NOTE
●

If you change the first page in the layout to an even number, it automatically becomes a lefthand page. This is because convention dictates that even numbered pages are always on the
left-hand page, and odd numbered pages are always on the right-hand page. Similarly, if the
first page in the layout is on the left-hand page, it cannot show as page 1, it can only show as
page 2.

●

If you want to start a layout on the left-hand page, we do not recommend that you insert a
page number change, as there is a dedicated option in Setup > Layout Options for this.

PROCEDURE
1.

In the music area, open the layout whose page numbers you want to change.

2.

In the Pages section of the Pages panel, select the page from which you want to change the
page numbers.

3.

In the action bar, click Insert Page Number Change to open the Page Number Change
dialog.

4.

In the Page Number Change dialog, enter the number of the page from which you want the
page number change to start in the From page field.
For example, if you want to change the page number of your current page 3, enter 3.

5.

Enter the new page number that you want the selected page to have in the First page
number field. For example, if you want to change your current page 3 to page 5, enter 5.

6.

Select one of the following numeral styles for Sequence type:

7.

●

Number

●

Roman numeral

Click OK to save your changes and close the dialog.

RESULT
The page number of the selected page is changed. All subsequent pages are changed
correspondingly until the next page number change or the end of the project, whichever comes
first.
TIP
You can also change other aspects of the appearance of page numbers in the Page Number
Change dialog. For example, you can show subordinate numbers as uppercase letters or
lowercase letters.

RELATED LINKS
Starting layouts on left-hand pages on page 443
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Page Number Change dialog
The Page Number Change dialog allows you to change the page numbers shown on existing
pages in each layout. You can choose to show pages without page numbers or with different
numbering.
For example, you can change the number type to one of the available types:
●

Roman numeral, such as iii and iv

●

Number, such as 5 and 19

You can also change the visibility of page numbers. For example, you can hide page numbers on
introductory pages by setting their visibility to Not on first page.
You can open the Page Number Change dialog when a page is selected in the Pages section of
the Pages panel in any of the following ways:
●

Right-click in the Pages section and choose Insert Page Number Change from the context
menu.

●

Click Insert Page Number Change.

The Page Number Change dialog contains the following options:
From page
Allows you to select the page from which you want to change page numbers. The
number indicates its position within the layout.
The Displayed option shows you the number that the selected page currently has, and
how that number appears.
First page number
Allows you to specify the new page number you want for the selected page.
Subsequent pages follow the new sequence until the next page number change or end
of the project.
Sequence type
Allows you to select the type of number that the selected page and subsequent pages
have.
Visibility
Allows you to specify if a page number is hidden or shown. You can additionally specify
that the page number is also hidden on the page where the page number change
occurs.
Subordinate number type
Allows you to add a subordinate number to the page number and to specify a type.
Subordinate number
Allows you to specify the number from which you want the subordinate numbers to
start.
When you insert page number changes, a marking is shown in the bottom right corner of the
page in the Pages section of the Pages panel. The new page number is also shown in each page
in the Pages section of the Pages panel, in the appropriate numeral style.
RELATED LINKS
Page numbers on page 972
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Removing page number changes
You can remove page number changes you have made to individual pages, which reverts pages
to their default page numbers.
Any pages whose page number has been changed are shown with a colored triangle in their
bottom right corner in the Pages section of the Pages panel.
PROCEDURE
1.

In the music area, open the layout whose page number changes you want to remove.

2.

Optional: If you want to remove page number changes from individual pages, select those
pages in the Pages section of the Pages panel.
You can Shift -click adjacent pages and Ctrl/Cmd -click individual pages.

3.

Remove page number changes in one of the following ways:
●

To remove page number changes from selected pages only, right-click a page and
choose Remove Page Number Change(s) from the context menu.

●

To remove page number changes from all pages, right-click in the Pages section of the
Pages panel and choose Remove All Page Number Changes from the context menu.

RESULT
Page number changes are removed from either the selected pages only or from all pages in the
layout currently open in the music area.
If you removed page number changes from all pages, all pages are restored to the default page
number sequence.
If you removed page number changes from selected pages only, the default page number is
restored from the selected pages until the next page number change or the end of the project,
whichever comes first. Any other pages with page number changes in the layout are unaffected.
RELATED LINKS
Page Number Change dialog on page 376
Inserting page number changes on page 375

Assigning master pages to pages
You can assign different master pages in the master page set to each page in each layout in your
project. You can assign them to individual pages and to every page after a selected page.
PROCEDURE
1.

In the music area, open the layout in which you want to change the master pages assigned
to pages.

2.

In the Pages section of the Pages panel, click the page whose master page assignment you
want to change.

3.

In the action bar, click Insert Master Page Change to open the Insert Master Page Change
dialog.

4.

Optional: Change the start page for the master page change using the From page option.

5.

Select the master page that you want to assign from the Use master page menu.

6.

Choose one of the following options for Range:
●

Current Page Only
Only the selected page is assigned a different master page.

●

From This Page Onwards
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The selected page and all subsequent pages are assigned a different master page.
7.

Click OK to save your changes and close the dialog.

RESULT
If you selected Current Page Only, the selected master page is assigned to the selected page
only.
If you selected From This Page Onwards, the selected master page is assigned to the selected
page and all subsequent pages in the layout or until the next existing master page change.

Removing master page changes
You can remove master page changes you have assigned to individual pages, which reverts them
to the overall master page format applied to the layout.
Any pages whose master page has been changed are shown with a marking along their top
edge, or along their top and left edges, in the Pages section of the Pages panel.
PROCEDURE
1.

In the music area, open the layout whose master page changes you want to remove.

2.

Optional: If you want to remove master page changes from individual pages, select those
pages in the Pages section of the Pages panel.
You can Shift -click adjacent pages and Ctrl/Cmd -click individual pages.

3.

Remove master page changes in one of the following ways:
●

To remove master page changes from selected pages only, right-click a page and choose
Remove Master Page Change(s) from the context menu.

●

To remove master page changes from all pages, right-click in the Pages section of the
Pages panel and choose Remove All Master Page Changes from the context menu.

RESULT
All master page changes are removed from either the selected pages only or from all pages in
the layout currently open in the music area. Pages return to the overall master page format
applied to the layout.
If you removed master page changes from selected pages only, any other pages with master
page changes in the layout are unaffected.
RELATED LINKS
Page format changes on page 372

Inserting flow heading changes
Inserting flow heading changes allows you to change the margins above/below flow headings in
addition to changing the flow heading format used. You can insert flow heading changes on each
page in each layout independently.
PROCEDURE
1.

In the music area, open the layout whose flow headings you want to change.

2.

In the Pages section of the Pages panel, click the page on/from which you want to insert a
flow heading change.

3.

In the action bar, click Insert Flow Heading Change to open the Insert Flow Heading
Change dialog.
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4.

Optional: Change the start page for the flow heading change using the From page option.

5.

Select the flow heading that you want to insert from the Use flow heading menu.

6.

Choose one of the following options for Range:
●

Current Page Only

●

From This Page Onwards

7.

Optional: Activate Heading Top Margin and/or Heading Bottom Margin and change their
values to change the margins above/below flow headings on the selected pages.

8.

Click OK to save your changes and close the dialog.

RESULT
If you selected Current Page Only, the selected flow heading is applied to all flow headings on
the selected page only.
If you selected From This Page Onwards, the selected flow heading is applied to all flow
headings on the selected page and all subsequent pages in the layout or until the next existing
flow heading change.
RELATED LINKS
Flow headings on page 381
Allowing/Disallowing multiple flows on the same page on page 443

Insert Flow Heading Change dialog
The Insert Flow Heading Change dialog allows you to change the formats used for all flow
headings on specified pages in each layout. You can apply flow heading changes only to
individual pages or to all subsequent pages.
You can open the Insert Flow Heading Change dialog when a page is selected in the Pages
section of the Pages panel in any of the following ways:
●

Right-click in the Pages section and choose Insert Flow Heading Change from the context
menu.

●

Click Insert Flow Heading Change.

The Insert Flow Heading Change dialog contains the following options:
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From page
Allows you to select the page from which you want to change the flow heading format.
The number indicates its position within the layout.
The Displayed preview shows the current page number of the selected page, and how
that number appears. If you have inserted page number changes in the layout, this
might be different to From page.
Use flow heading
Allows you to specify the flow heading design you want to apply. The menu contains all
available flow headings in the current master page set.
Range
Allows you to specify the range to which you want to apply the flow heading change.
●

Current Page Only applies the flow heading change only to the selected page.

●

From This Page Onwards applies the flow heading change to the selected page
and all subsequent pages in the layout or until the next existing flow heading
change.

Heading Top Margin
Allows you to set the gap between the top of affected flow headings and the end of the
preceding flow, independently of the default setting for the layout.
Heading Bottom Margin
Allows you to set the gap between the bottom of affected flow headings and the start
of the next flow, independently of the default setting for the layout.
When you insert flow heading changes, a marking is shown on the bottom or bottom and left
edges of the page in the Pages section of the Pages panel.
RELATED LINKS
Changing the margins above/below flow headings on page 446

Removing flow heading changes
You can remove flow heading changes you have assigned to individual pages to revert to the
Default flow heading.
Any pages whose flow heading has been changed are shown with a marking along their bottom
edge, or along their bottom and left edges, in the Pages section of the Pages panel.
PROCEDURE
1.

In the music area, open the layout whose flow heading changes you want to remove.

2.

Optional: If you want to remove flow heading changes from individual pages, select those
pages in the Pages section of the Pages panel.
You can Shift -click adjacent pages and Ctrl/Cmd -click individual pages.

3.

Remove flow heading changes in one of the following ways:
●

To remove flow heading changes from selected pages only, right-click a page and
choose Remove Flow Heading Change(s) from the context menu.

●

To remove flow heading changes from all pages, right-click in the Pages section of the
Pages panel and choose Remove All Flow Heading Changes from the context menu.

RESULT
All flow heading changes are removed from either the selected pages or from all pages in the
layout currently open in the music area. Pages return to using the Default flow heading in the
master page set applied to the layout.
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If you removed flow heading changes from selected pages only, any other pages with flow
heading changes in the layout are unaffected.
RELATED LINKS
Flow headings on page 381

Swapping pages
You can swap pages that have overrides with adjacent pages.
PROCEDURE
1.

In the music area, open the layout in which you want to swap pages.

2.

In the Pages section of the Pages panel, select the overridden page whose overrides you
want to swap with another page.
Pages with overrides have markings in their top left corners.

3.

Swap the selected page with another page in any of the following ways:
●

In the action bar, click Swap with Previous Page.

●

In the action bar, click Swap with Next Page.

RESULT
The selected page exchanges the position with the previous or next page within the sequence of
pages in the layout.

Flow headings
Flow headings allow you to show the titles of flows immediately above their first system
automatically. They function like templates, in much the same way as master pages.
Flow headings exist as part of master page sets. By default, Dorico Pro provides one flow
heading in each master page set, which contains tokens to display the flow number and flow
title; in a new project, this appears as “1. Flow 1”. This is used automatically for all flow headings,
but you can insert flow heading changes to individual pages and ranges of pages.
Flow headings are automatically inserted above the first system of the flow to which they apply,
meaning they do not have a fixed vertical position on the page like other frames and follow the
music if it moves. They also occupy vertical space within music frames. You can change the
margins for the space above and below flow headings on a per-layout and on a per-page basis by
inserting flow heading changes.
When Frames is selected in the Engrave toolbox, frames in flow headings appear with dashed
lines instead of solid lines to help you identify them. You can move flow heading frames in the
same ways as moving any other frames, but this creates a master page override, which is a type
of page format change.
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Dashed lines showing the edges of a flow heading text frame

RELATED LINKS
Tacets on page 467
Hiding/Showing flow headings on page 445
Changing the margins above/below flow headings on page 446
Master page sets on page 362
Page format changes on page 372
Text tokens on page 396
Inserting flow heading changes on page 378

Flow heading editor
The flow heading editor allows you to view and change the format of flow headings.
It functions similarly to the master page editor; however, the background of the flow heading
editor is a different color to help you identify what you are editing.
You can open the flow heading editor in the following ways:
●

Double-click a flow heading in the Flow Headings section of the Pages panel.

●

Select a flow heading in the Flow Headings section of the Pages panel and click Edit Flow
Heading.

You can customize flow headings in the flow heading editor, including inputting extra frames,
changing the contents of text frames, and editing/moving existing text and graphics frames. You
can also change the vertical alignment of text in text frames and use text editor options to
format the appearance and horizontal alignment of text in text frames.
NOTE
●

You cannot input music frames in flow headings.

●

Frames in flow headings can only have right and left edge constraints, they cannot have top
or bottom constraints. This is because flow headings have no fixed vertical position.

You can position frames anywhere in the flow heading editor, as Dorico Pro always uses the top
of the highest frame and bottom of the lowest frame on the page in the editor to determine the
dimensions of the flow heading. However, we recommend that you keep the overall height of
flow headings as small as possible to reduce the amount of music they consequently displace in
music frames.
Unlike master pages, flow headings appear the same whether they are on left-hand or righthand pages, so only a single page is shown in the flow heading editor.
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A flow heading in the flow heading editor

RELATED LINKS
Pages panel on page 355
Text editor options in Engrave mode on page 415
Changing the horizontal alignment of text in text frames on page 404

Customizing flow headings
You can customize flow headings according to your needs in the flow heading editor, such as by
inputting a graphics frame or changing the tokens in an existing text frame. Changing a flow
heading affects the appearance of flow headings in all layouts that use that flow heading.
PROCEDURE
1.

In the Pages panel, double-click a flow heading in the Flow Headings section.
The flow heading editor opens in the music area.

2.

In the flow heading editor, change the layout of the flow heading. For example, you can
input a graphics frame or change the vertical alignment of text in the text frame.

3.

Click Apply, then Close.

RELATED LINKS
Inputting frames on page 386
Entering text in text frames on page 402
Moving frames on page 387
Changing the size/shape of frames on page 387
Changing the vertical alignment of text in text frames on page 403
Paragraph Styles dialog on page 410

Adding flow headings
You can add new flow headings to master page sets. Each master page set can have multiple
custom flow headings, but only a single default flow heading.
PROCEDURE
1.

In the music area, open a layout that uses the master page set to which you want to add flow
headings.
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NOTE
You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.
2.

In the Pages panel, click New Flow Heading in the Flow Headings action bar to open the
New Flow Heading dialog.

3.

In the New Flow Heading dialog, enter a name for the new flow heading into the Name
field.

4.

Select the existing flow heading on which you want to base the new flow heading from the
Based on menu.
NOTE

5.

●

Flow headings based on existing flow headings retain a link to the Based on flow
heading. This means some changes you make to the Based on flow heading, such as
changing the font size of text in text frames, also affect the new flow heading and vice
versa.

●

Selecting (None) always creates a flow heading without any formatting but the page
margins.

Choose one of the following flow heading types for your new flow heading:
●

Default

●

Custom

NOTE
If you select Default, the new flow heading replaces that existing default flow heading, as
each master page set can only have a single default flow heading.
If you want to create a new flow heading without replacing any existing flow headings,
choose Custom.
6.

Click OK to save your changes and close the dialog.

RESULT
A new flow heading of the selected type is added to the selected master page set.
AFTER COMPLETING THIS TASK
You can customize your new flow heading. You can apply flow headings to individual pages in
layouts that use the master page set to which they belong.
RELATED LINKS
Master page sets on page 362
Inserting flow heading changes on page 378
Hiding/Showing flow headings on page 445
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Renaming flow headings
You can change the names of flow headings, including default flow headings and your own
custom flow headings.
PROCEDURE
1.

In the music area, open a layout that uses the master page set containing the flow heading
you want to rename.
NOTE
You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2.

In the Flow Headings section of the Pages panel, click the flow heading pair that you want to
rename.

3.

In the action bar, click Rename Flow Heading to open the Rename Flow Heading dialog.

4.

Enter the name you want in the Name field.

5.

Click OK to save your changes and close the dialog.

Deleting flow headings
You can delete flow headings from master page sets.
NOTE
You cannot delete Default flow headings. Every master page set must contain at least a Default
flow heading. You can replace Default flow headings by adding a new flow heading and setting
its type to Default.

PROCEDURE
1.

In the music area, open a layout that uses the master page set containing the flow heading
you want to delete.
NOTE
You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2.

In the Flow Headings section of the Pages panel, click the flow heading that you want to
delete.

3.

In the action bar, click Delete Flow Heading.

RESULT
The selected flow heading is deleted. You can undo this action if you deleted a flow heading in
error.
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Frames
Frames are boxes that allow you to position your music, additional text, and graphics anywhere
inside the margins of a page.
Frames can be positioned inside the page margins that have been defined for a layout. In
Engrave mode, you can see and adjust frames according to your needs. In Dorico Pro, there are
the following types of frames:
●

Music frames that show the music of selected players and flows

●

Text frames that allow you to enter text and text tokens

●

Graphics frames that allow you to load images or illustrations in a variety of formats

For every frame, you can specify constraints that define the relationship between the sides of the
frame and the corresponding page margins.
RELATED LINKS
Flows in Dorico on page 36
Layouts in Dorico on page 39
Frame constraints on page 406
Music frames on page 389
Text frames on page 395
Graphics frames on page 405
Frame breaks on page 463
Text tokens on page 396

Inputting frames
You can input frames on pages manually, including on both individual pages and on master
pages in the master page editor. You can input music frames, text frames, and graphics frames.
PREREQUISITE
If you want to input frames on a master page, you have opened the master page in the master
page editor.
PROCEDURE
1.

In the Engrave toolbox, click Frames to show the Formatting panel.

2.

In the Insert Frames section, choose one of the following types of frames:

3.

●

Insert Music Frame

●

Insert Text Frame

●

Insert Graphics Frame

Click and drag in the music area to input the selected frame type.
You can draw a frame of any size and shape, as long as it fits within the page margins.

RESULT
When you release the mouse, the type of frame you chose is input on the page.
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AFTER COMPLETING THIS TASK
You can change the size of the frame or define its constraints.
If you inserted a music frame, you can determine which parts of your score you want to display in
the frame. If you inserted a text frame, you can enter text. If you inserted a graphics frame, you
can load a graphics file.
RELATED LINKS
Frame constraints on page 406
Music frames on page 389
Text frames on page 395
Entering text in text frames on page 402
Graphics frames on page 405
Music frame selectors on page 391
Master page editor on page 370

Moving frames
You can move individual frames around pages, including master pages, after they have been
inserted. However, you cannot move frames beyond page margins.
PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to move frames on a master page, you have opened the master page in the
master page editor.

PROCEDURE
1.

Select the frames you want to move.

2.

Move the frames in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

Changing the size/shape of frames
You can change the size and shape of individual frames on pages, including on master pages,
after they have been inserted.
PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to change the size/shape of frames on a master page, you have opened the
master page in the master page editor.

PROCEDURE
1.

Select the middle handle on an edge of the frame whose size or shape you want to change.
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NOTE
You can only select a single handle on a single frame at a time.
2.

Move the handle in any of the following ways:
●

Press Alt/Opt-Right Arrow to move it to the right.

●

Press Alt/Opt-Left Arrow to move it to the left.

●

Press Alt/Opt-Up Arrow to move it upwards.

●

Press Alt/Opt-Down Arrow to move it downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag the handle to the right/left or upwards/downwards.

NOTE
You can only move handles on the right/left edges of frames to the right/left. You can only
move handles on the top/bottom edges of frames upwards/downwards. For example, if you
want to make a frame wider, you can select the middle handle on the right edge of the frame
and move it to the right.
3.

Optional: Repeat steps 1 and 2 for any other edge of the frame you want to move to achieve
the size and shape you want.

RELATED LINKS
Master page editor on page 370

Selecting frame handles
You can select an individual handle on a frame, and you can switch between having a handle
selected and having the whole frame selected.
PREREQUISITE
Frames is selected in the Engrave toolbox.
PROCEDURE
1.

Select a frame handle in any of the following ways:
●

Select any handle on the frame and press Right Arrow / Left Arrow / Up Arrow /
Down Arrow to select other handles around the edge of the frame.

●

Select the frame, press Tab to switch to having the handle in the top left corner
selected, then press Right Arrow / Left Arrow / Up Arrow / Down Arrow to select other
handles around the edge of the frame.

●

Click a handle on the frame.

NOTE
You can only select a single handle on a single frame at a time.
2.

Optional: Switch back to having the whole frame selected at any time by pressing Tab .
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Copying frames
You can copy individual frames from one page to other pages in layouts, for example, if you want
the same frame to appear on multiple pages at exactly the same position. You can also copy
frames to the same page, for example, if you want to duplicate a frame on a page.
NOTE
These steps do not apply to frames on master pages. You can copy frames on master pages
when customizing the master page.
PREREQUISITE
Frames is selected in the Engrave toolbox.
PROCEDURE
1.

In the music area, open the layout in which you want to copy frames to other pages.

2.

Select the frames you want to copy, which can be on multiple pages.

3.

In the Pages section of the Pages panel, Ctrl/Cmd -click the pages to which you want to copy
the selected frames.

4.

Right-click in the Pages section and choose Copy Selected Frames to Selected Pages from
the context menu.

RESULT
All selected frames are copied to the selected pages at the same positions on the page. If you
copied frames to their original page, they overlay their original exactly.

Music frames
Music frames display the music in your project in a specified order. You can control which parts
of the project are displayed using master page music frames and layout music frames.
Both types of music frames display the music and notations you have input into the project
according to their music frame selectors, such as filtering only selected players or flows.

A master page music frame

Master page music frames
Master page music frames exist only on master pages, meaning you can only input and edit
master page music frames in the master page editor. They can only be assigned to master page
frame chains. Therefore, the flow and player selectors of master page music frames appear
grayed out on individual pages in layouts.
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Flow and player selectors grayed out on a master page music frame

By default, the master pages in the master page sets provided by Dorico Pro include master page
music frames assigned to a single master page frame chain. This frame chain is set to display all
players in all flows in each layout. These master pages are set to apply to all pages in all layouts
in your project by default according to the layout type.
You can input multiple master page music frames on a single master page, and change their size
and shape to whatever you want. If you want to connect separate master page music frames on
the same page, you can assign them to the same frame chain.

Layout music frames
Layout music frames exist only on individual pages in layouts, meaning you can only input and
edit layout music frames in individual layouts in the music area. Layout music frames can be
assigned to both master page and layout frame chains. However, assigning a layout frame to a
master page frame chain does not affect the master page.
You can input multiple layout music frames on a single page, and change their size and shape to
whatever you want. For example, layout music frames allow you to insert small musical excerpts
from a different flow within footnotes or in an index.
If you want to connect separate layout music frames on the same page, you can assign them to
the same frame chain.
IMPORTANT
Layout music frames are considered overrides to master pages. If you remove all overrides on
layout pages, all your layout music frames are also removed.

RELATED LINKS
Music frame selectors on page 391
Master pages on page 361
Page format changes on page 372
Master page editor on page 370
Changing the size/shape of frames on page 387

Music frame chains
A music frame chain is a collection of music frames that show the same selection of music in a
set order, often in sequence. Music frame chains are automatically created when you create a
music frame on a page, and can include any number of frames, including only a single music
frame.
You can control the music shown in each music frame chain by player and by flow using music
frame selectors.
In Dorico Pro, there are different types of frame chains.

Master page frame chains
Master page frame chains can be created and fully edited only on master pages in the master
page editor; you cannot change the flow and player filters for master page frame chains in
individual layouts. Whenever you create a music frame on a master page, you automatically start
a frame chain.
Frame chains that start with an “M”, such as “MA”, are master page frame chains. You can have
multiple master page frame chains on each page, such as “MA” and “MH”.
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The default master pages contain a single frame chain that is set to display all flows and all
players in the layout. Therefore, Dorico Pro automatically creates enough pages and frames to
display all flows in all the layouts that use those master pages.
NOTE
●

To ensure that a score continues automatically on subsequent pages, the music frame must
be created at least on the First and Default master pages.

●

All frames in the same music frame chain must display the same flows and players. For
example, you cannot have the first frame in a frame chain show just the violin but have the
second frame show all players.

●

Dorico Pro shows flows in layouts as many times as you want, not only once. Therefore, if
you want to change the formatting of some flows in a particular layout, such as showing
them in layout frame chains instead of the master page frame chain, but do not want those
flows to appear more than once, you must remove those flows from the Filter by Flows list
on the master page frame chain. As this affects which flows are automatically displayed in all
layouts that use the same master page, we recommend that in such cases you create a
separate master page for the layout in which you want to change the formatting.

Layout frame chains
Layout frame chains can only be created and edited on pages in individual layouts. If you create a
music frame and assign it to a layout frame chain in a layout, it is only displayed on that page in
that layout and starts its own frame chain. If you want the music frame to be continued on
subsequent pages, you must create music frames on all the pages in the layout on which you
want the chain to appear and assign all of these frames to the same layout frame chain.
Frame chains that start with an “L”, such as “LA”, are layout frame chains. You can have multiple
layout frame chains on each page, such as “LA” and “LB”.
NOTE
●

All frames in the same music frame chain must display the same flows and players. For
example, you cannot have the first frame in a frame chain show just the violin but have the
second frame show all players.

●

Assigning flows to layout frame chains does not stop those flows also appearing in the
master page frame chain, if the frame chain in the master page applied to the layout is set to
include those flows. By default, master page frame chains are set to display all flows in the
project.

RELATED LINKS
Master pages on page 361
Master page editor on page 370
Layouts in Dorico on page 39

Music frame selectors
When Frames is selected in the Engrave toolbox, music frames show selectors that allow you to
change what music is displayed, for example, by changing which flows and players are assigned
to each frame chain.
Selectors on music frames allow you to control which flows and players are displayed in frame
chains, and the order in which the selected music is shown in frames on the page. Frame chains
can include any number of frames, including only a single music frame.
Every music frame shows the following selectors:
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1

Frame Chain
Shows the current frame chain of the frame and allows you to change the frame chain to
which the frame is assigned. Frame chains that start with an “M” are master page frame
chains, while frame chains that start with an “L” are layout frame chains.
The second letter allows you to identify different frame chains of the same type. It is
automatically generated and reflects the order in which you created the frame chains, for
example, “LA” is the first layout frame chain you create in the layout and “LB” is the second.

2

Frame Order
If you have two or more music frames that belong to the same frame chain on the same
page, you can use this option to specify the order in which music flows through the frames.
For example, when the Frame Order is 1, that frame is the first frame in the frame chain.

3

Filter by Flow
If you have multiple flows in your project, you can specify which flows you want to display in
this frame chain. For example, you can show only a single flow, a selection of flows, or all
flows.

4

Filter by Player
If you have multiple players in your project, you can specify which players you want to
display in this frame chain. For example, you can show only a single player, multiple players,
or all players.

NOTE
You can only edit the Filter by Flow and Filter by Player selectors of master page music frames
on master pages in the master page editor.

RELATED LINKS
Frame constraints on page 406
Changing the size/shape of frames on page 387

Assigning music frames to frame chains
You can change the frame chains to which music frames belong, for example, to control what
music appears in specific music frames. This applies to both master page and layout music
frames.
NOTE
New music frames on a page always start a new frame chain, regardless of their type.
PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to assign music frames to frame chains on a master page, you have opened the
master page in the master page editor.
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PROCEDURE
1.

In the music frame whose frame chain you want to change, click Frame Chain.

2.

Select the frame chain to which you want to assign the music frame.
NOTE

3.

●

You cannot select layout frame chains for frames in the master page editor.

●

If you do not want to use any of the available frame chains, click Unlink.

Click outside of the selector to close it.

RESULT
The music frame is assigned to the selected frame chain. All settings from the frame chain are
applied to the frame, such as the players and flows displayed.
RELATED LINKS
Master page editor on page 370
Assigning flows to frame chains on page 394
Assigning players to frame chains on page 395

Unlinking music frames from frame chains
You can unlink music frames from music frame chains, for example, if you want to assign a music
frame to a new frame chain without deleting it.
PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to unlink frames from music frame chains on a master page, you have opened
the master page in the master page editor.

PROCEDURE
1.

In the music frame you want to unlink, click Frame Chain.

2.

Click Unlink.

RESULT
The music frame is unlinked from its previous frame chain. A new frame chain is automatically
created for the unlinked frame.
●

Unlinking a layout music frame from a layout frame chain changes it to a new layout frame
chain.

●

Unlinking a layout music frame from a master page frame chain changes it to a new layout
frame.

●

Unlinking a master page music frame from a master page frame chain changes it to a new
master page frame chain.
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Changing the order of music frames
If you have at least two music frames of the same type in the same frame chain on a page, you
can change the order in which music is displayed across the frames.
PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to change the order of music frames on a master page, you have opened the
master page in the master page editor.

PROCEDURE
1.

In one of the music frames whose order you want to change, click Frame Order.

2.

Select the ordinal number for this frame from the Frame Order menu.

3.

Click outside of the selector to close it.

RESULT
The position of the selected frame in the frame chain order is changed by exchanging its order
number with the frame previously assigned that number. For example, changing the number of
the second frame in a frame chain to 1 causes the frame originally number 1 to become number
2 in the frame chain order.

Assigning flows to frame chains
You can change which flows are included in each frame chain, for example, if you want to exclude
some flows from the master page frame chain because you want those flows to appear in layout
frame chains instead.
NOTE
●

You can assign flows to both master page frame chains and layout frame chains. However,
you can only change the flows assigned to layout frame chains in individual layouts, and you
can only change the flows assigned to master page frame chains in the master page editor.

●

Changing the assigned flows affects all frames in the frame chain.

PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to change the flows assigned to music frame chains on a master page, you have
opened the master page in the master page editor.

PROCEDURE
1.

In a music frame belonging to the frame chain whose assigned flows you want to change,
click Flows.

2.

Select the flows you want to display in the frame chain from the Filter by Flow menu.

3.

Click outside of the selector to close it.

RESULT
All frames in the frame chain are updated to display the selected flows. If you changed the flows
assigned to a master page music frame, the number of pages in the layouts to which the master
page is applied automatically updates. For example, if you assigned an extra flow to the master
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page frame chain, enough extra pages and frames to display that flow are added to the
corresponding layouts.

Assigning players to frame chains
You can change which players are included in each frame chain, for example, if you are writing a
piano duet and only want to show one piano on left pages and the other piano on right pages.
NOTE
●

You can assign players to both master page frame chains and layout frame chains. However,
you can only change the players assigned to layout frame chains in individual layouts, and
you can only change the players assigned to master page frame chains in the master page
editor.

●

Changing the assigned players affects all frames in the frame chain.

PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to change the players assigned to music frame chains on a master page, you
have opened the master page in the master page editor.

PROCEDURE
1.

In a music frame belonging to the frame chain whose assigned players you want to change,
click Players.

2.

Select the players you want to display in the music frame from the Filter by Player menu.

3.

Click outside of the selector to close it.

RESULT
All frames in the frame chain are updated to display the selected players.
NOTE
The staff size is not changed automatically, meaning staves can overlap in small frames in the
frame chain.

RELATED LINKS
Staff size on page 452

Text frames
Text frames allow you to add text, including tokens, to your project, independently of rhythmic
positions in the score. Adding text frames to pages individually, and not on a master page, is
considered a master page override.
You can open the text editor for individual frames in any of the following ways:
●

Activate Frames in the Formatting panel, select the text frame, and press Return .
TIP
You can switch between selecting a frame handle and the whole frame by pressing Tab .

●

Double-click within the text frame.
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Text frame

RELATED LINKS
Inputting frames on page 386
Entering text in text frames on page 402
Text formatting on page 407
Changing the default horizontal alignment of text styles on page 412
Changing the horizontal alignment of text in text frames on page 404
Page format changes on page 372
Changing the size/shape of frames on page 387

Text tokens
Text tokens are codes that you can use as substitutes for information stored in your project, such
as titles, composers, and the time and date. This can reduce the risk of mistakes or outdated
information appearing in your project. Text tokens are also known as “wildcards” or “text codes”.
For example, if you use a token for the title of your project, you can change the project title in the
Project Info dialog as often as you want, and the project title in every layout in your project is
updated automatically.
Tokens can refer to information in the Project Info dialog, including for the whole project or
each flow individually. Tokens can also refer to the current time and date or the time and date
the project was last saved.
NOTE
●

You can only use text tokens in text frames. You cannot use tokens in text/system text
objects.

●

Flow tokens refer to the nearest flow below the top edge of their text frame. When the top
edge of a text frame containing a flow token is in line with or above the top staff line of the
first staff in a system, it then refers to that flow.
You can specify the flow number to which you want flow tokens to refer, such as
{@flow2title@}. This always shows the specified flow, regardless of the token’s position.
If you want to use tokens that refer to flow information on pages that contain no music, such
as title pages, you must specify the flow number in the token. For example, if you use
{@flowtitle@} on a title page containing no music frames, the token does not display any
information, but {@flow1title@} displays the title of the first flow in your project.
You can see the flow number of each flow in the Flows panel in Setup mode.

The following tokens are available in Dorico Pro.
TIP
You can access all the available tokens from the context menu when the cursor is inside a text
frame. In the context menu, tokens are organized into submenus.
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General tokens
Description

Token

Page number

{@page@}

Player list

{@playerlist@}

Player names

{@playernames@}

Layout name

{@layoutname@}

Layout number, as set in the Layouts panel in
Setup mode

{@layoutnumber@}

Staff label tokens
Music symbol

Token

Full staff labels of the players in the current
layout

{@staffLabelsFull@}

Abbreviated staff labels of the players in the
current layout

{@staffLabelsShort@}

You can use staff label tokens, for example, as an alternative way to name part layouts, instead
of using the default {@layoutName@} token shown at the top left of the first page in part
layouts.
NOTE
Staff label tokens might not exactly match the appearance of staff labels shown before initial
barlines; however, staff label tokens respect your per-layout options for how transpositions
appear in staff labels.

Music symbol tokens
Music symbol

Token

Flat accidental: ♭

{@flat@}

Sharp accidental: ♯

{@sharp@}

Natural accidental: ♮

{@natural@}

Treble clef

{@U+E050@}

Fermata above

{@U+E4C0@}

TIP
●

This list is not comprehensive, as you can enter the code point for any SMuFL symbol within
a token. You can find the necessary code points in the SMuFL specification online.
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●

Music symbol tokens in text frames automatically use the Music text character style, which
is set to Bravura Text by default.

●

You can include music symbol tokens in fields in the Project Info dialog. For example, if you
enter Symphony in B{@flat@} major into the Title field, the title displayed in text frames
using the corresponding title token is Symphony in B♭ major.

Project/Flow-specific information tokens
Field in the Project Info
dialog

Token for Project page

Token for Flow pages

Title

{@projecttitle@}

{@flowtitle@}

Subtitle

{@projectsubtitle@}

{@flowsubtitle@}

Dedication

{@projectdedication@}

{@flowdedication@}

Composer

{@projectcomposer@}

{@flowcomposer@}

Arranger

{@projectarranger@}

{@flowarranger@}

Lyricist

{@projectlyricist@}

{@flowlyricist@}

Artist

{@projectartist@}

{@flowartist@}

Copyist

{@projectcopyist@}

{@flowcopyist@}

Publisher

{@projectpublisher@}

{@flowpublisher@}

Editor

{@projecteditor@}

{@floweditor@}

Copyright

{@projectcopyright@}

{@flowcopyright@}

Work number

{@projectworknumber@}

{@flowworknumber@}

Composer dates

{@projectcomposerdates@}

{@flowcomposerdates@}

Composition year

{@projectcompositionyear@} {@flowcompositionyear@}

Other information

{@projectotherinfo@}

{@flowotherinfo@}

Per-flow tokens
Per-flow token function

Token

Flow number of the current flow, according to
its position in the Flows panel in Setup mode

{@flownumber@}

Flow number of the current flow, according to
its position in the current layout.

{@flowInLayoutNumber@}
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Per-flow token function

Token

Flow number of the current flow shown in
lower case Roman numerals, such as iii or xvi

{@flowNumberRomanLower@}

Flow number of the current flow shown in
upper case Roman numerals, such as III or XVI

{@flowNumberRomanUpper@}

Number of this page within the current flow,
counting from 1

{@flowPage@}

Total number of pages in the current flow

{@flowPageCount@}

The displayed page number on which the
specified flow “n” begins, such as
{@flow3PageCount@}

{@flownPageCount@}

Duration of the current flow in minutes and
seconds

{@flowDuration@}

Duration of the specified flow “n” in minutes
and seconds, such as {@flow3Duration@}

{@flownDuration@}

Page number tokens
Page number token function

Token

Total number of pages in the layout

{@pageCount@}

Number of this page within the current flow,
counting from 1 for the first page of the flow
and including pages with no displayed page
number

{@flowPage@}

Total number of pages in the current flow

{@flowPageCount@}

Displayed page number of the page on which
the specified flow “n” begins, according to its
position in the Flows panel in Setup mode, for
example, {@flow5FirstPage@}

{@flownFirstPage@}

NOTE
{@flowPage@} and {@flowPageCount@} tokens only consider the flow that is active at the
beginning of the first system of the music frame closest to the top left corner of the page on
which the tokens are used.
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Time/Date tokens to show when the project was last saved
Time/Date description

Time/Date example

Token

Standard date and time string
(locale dependent)

Sun Dec 31 11:10:12 2017

{@projectdate@}

Four-digit year

2017

{@projectdateyear@}

Two-digit year

17

{@projectdateyearshort@}

Full month name (locale
dependent)

October

{@projectdatemonth@}

Short month name (locale
dependent)

Oct

{@projectdatemonthshort@}

Month as a decimal number,
range 1-12

10

{@projectdatemonthnum@}

Full weekday name (locale
dependent)

Friday

{@projectdateday@}

Abbreviated weekday name
(locale dependent)

Fri

{@projectdatedayshort@}

Day of month as decimal
number, range 1-31

24

{@projectdatedaynum@}

ISO 8601 date

2017-12-31

{@projectdateymd@}

Month day, year

December 31, 2017

{@projectdatemdy@}

Day month year

31 December 2017

{@projectdatedmy@}

Time representation (locale
dependent)

11:10:12

{@projectdatetime@}

Hours:minutes, hour in 24hour clock range

23:10

{@projectdatetimeHHMM@}

Hours:minutes:seconds, hour
in 24-hour clock range

13:02:24

{@projectdatetimeHHMMSS
@}

Hour in 24-hour clock range

23

{@projectdatetimehour24@}

Hour in 12-hour clock range

11

{@projectdatetimehour12@}

Minute as decimal number,
range 00-59

10

{@projectdatetimeminute@}

Second as decimal number,
range 00-59

44

{@projectdatetimesecond@}
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Time/Date tokens to show the current time and date
Time/Date description

Time/Date example

Token

Standard date and time string
(locale dependent)

Sun Dec 31 11:10:12 2017

{@date@}

Four-digit year

2017

{@dateyear@}

Two-digit year

17

{@dateyearshort@}

Full month name (locale
dependent)

October

{@datemonth@}

Short month name (locale
dependent)

Oct

{@datemonthshort@}

Month as a decimal number,
range 1-12

10

{@datemonthnum@}

Full weekday name (locale
dependent)

Friday

{@dateday@}

Abbreviated weekday name
(locale dependent)

Fri

{@datedayshort@}

Day of month as decimal
number, range 1-31

24

{@datedaynum@}

ISO 8601 date

2017-12-31

{@dateymd@}

Month day, year

December 31, 2017

{@datemdy@}

Day month year

31 December 2017

{@datedmy@}

Time representation (locale
dependent)

11:10:12

{@datetime@}

Hours:minutes, hour in 24hour clock range

23:10

{@datetimeHHMM@}

Hours:minutes:seconds, hour
in 24-hour clock range

13:02:24

{@datetimeHHMMSS@}

Hour in 24-hour clock range

23

{@datetimehour24@}

Hour in 12-hour clock range

11

{@datetimehour12@}

Minute as decimal number,
range 00-59

10

{@datetimeminute@}

Second as decimal number,
range 00-59

44

{@datetimesecond@}
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RELATED LINKS
Project Info dialog on page 102
Player, layout, and instrument names on page 139
Flow names and flow titles on page 145
Renumbering layouts on page 138
Instrument transpositions in staff labels on page 1150

Entering text in text frames
You can enter text in text frames, format the text, and insert separate paragraphs and line
breaks. You can also edit text in text frames at any time, for example, if you later want text to be
italic instead of bold.
PREREQUISITE
If you want to enter text in a text frame on a master page, you have opened the master page in
the master page editor.
PROCEDURE
1.

Double-click the text frame into which you want to enter text to open the text editor.

2.

Enter the text you want.

3.

Optional: To insert a token, right-click in the text frame and choose the required token from
the context menu.

4.

Optional: To insert a new paragraph, press Return .

5.

Optional: To insert a line break, press Shift - Return .

6.

Optional: Format the text using the text editor options.

7.

Press Esc or Ctrl/Cmd - Return to close the text editor.

RESULT
Text is entered into the text frame. Tokens are inserted at the cursor position.
If you insert a new paragraph or line, the cursor jumps to the beginning of the new paragraph or
line.
RELATED LINKS
Text editor options in Engrave mode on page 415

Adding borders to text frames
You can add borders to individual text frames, for example, if you want to make its boundaries
clear.
PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to add borders to text frames on a master page, you have opened the master
page in the master page editor.

PROCEDURE
1.

Select the text frames to which you want to add borders.

2.

In the Properties panel, activate Show border in the Text group.

RESULT
Borders are added to the selected text frames.
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AFTER COMPLETING THIS TASK
You can change the thickness of text frame borders and you can change the padding between
the borders and contents of text frames.

Changing the thickness of text frame borders
You can change the thickness of text frame borders individually. There is no default setting for
the thickness of text frame borders.
PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to change the thickness of text frame borders on a master page, you have
opened the master page in the master page editor.

PROCEDURE
1.

Select the text frames whose border thickness you want to change.

2.

In the Properties panel, change the value for Border thickness in the Text group.

RELATED LINKS
Changing the thickness of text object borders on page 420

Changing the padding in text frames
You can change the padding of individual text frames, which affects the distance between the
edges of frames and the text within them.
PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to change the padding of text frames on a master page, you have opened the
master page in the master page editor.

PROCEDURE
1.

Select the text frames whose padding you want to change.

2.

In the Properties panel, activate Padding in the Text group.

3.

Change the value in the value field.

RESULT
The padding between all edges of the selected text frames and the text within them is changed.

Changing the vertical alignment of text in text frames
You can change the vertical alignment of text in text frames. You can do this on master pages,
which changes the alignment of the selected text on all pages that use the master page format,
and on individual pages, which only changes the alignment of the selected text on that page.
PREREQUISITE
●

Frames is selected in the Engrave toolbox.

●

If you want to change the vertical alignment of text on a master page, you have opened the
master page in the master page editor.

PROCEDURE
1.

Select the frames whose text vertical alignment you want to change.
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2.

In the Properties panel, select one of the following options from the Vertical alignment
menu in the Text group:
●

Top

●

Center

●

Bottom

RESULT
The vertical alignment of text in the selected text frames is changed.
NOTE
Changing the vertical alignment of text does not override its paragraph style. Any changes you
make later to the paragraph styles of text whose vertical alignment has been changed are
applied to the text.

RELATED LINKS
Master page editor on page 370
Paragraph Styles dialog on page 410

Changing the horizontal alignment of text in text frames
You can change the horizontal alignment of any text style in text frames, independently of the
paragraph style for that text.
If you change the alignment of text in text frames on master pages, the horizontal alignment of
text is changed on all pages that use those master page formats.
If you change the alignment of text in text frames on individual pages, this change is
independent of the paragraph style for that text and also independent of the master page
format. You can later remove any overrides made on individual pages and revert them to the
master page format.
NOTE
●

Changes to text in text frames on master pages cannot be reset.

●

Removing overrides removes all changes made to individual pages, not just changes to the
alignment of text in text frames.

PREREQUISITE
If you want to change the horizontal alignment of text on a master page, you have opened the
master page in the master page editor.
PROCEDURE
1.

Double-click a text frame to open the text editor for that frame.

2.

Select the text in the text frame whose horizontal alignment you want to change.
TIP
You can apply different paragraph styles to separate paragraphs in the same text frame.

3.

Choose the horizontal alignment you want in the text editor.

4.

Press Esc or Ctrl/Cmd - Return to close the text editor.

RESULT
The horizontal alignment of the selected text is changed.
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TIP
You can change the horizontal alignment of text styles project-wide in the Paragraph Styles
dialog.

RELATED LINKS
Paragraph Styles dialog on page 410
Paragraph style overrides on page 417

Graphics frames
Graphics frames allow you to load images or illustrations into your score in a variety of formats.
You can load graphics files in the following formats:
●

.jpg or .jpeg

●

.png

●

.svg

Graphics frame

NOTE
Graphics frames on master pages can only show a single image in all layouts. If you change the
image in a graphics frame in one layout, this updates the master page and affects all layouts.

RELATED LINKS
Changing the size/shape of frames on page 387

Loading images into graphics frames
You can load images from your computer or server into your score.
PREREQUISITE
You have added a graphics frame, either to a master page or an individual layout.
PROCEDURE
1.

Double-click in the graphics frame to open the File Explorer/macOS Finder.

2.

In the File Explorer/macOS Finder, locate and select the file you want to load into the
graphics frame.

3.

Click Open.

RESULT
The selected image is loaded into the frame.

405
Dorico Pro 3.1.10

Engrave mode
Frames
NOTE
Graphics frames on master pages can only show a single image in all layouts. If you change the
image in a graphics frame in one layout, this updates the master page and affects all layouts.

Frame constraints
In Dorico Pro, constraints define the relationship between each of the four sides of a frame and
the corresponding page margins.
Frame constraints lock each side of frames to the corresponding page margin, meaning you can
change the page size, or the area that is defined by the page margin, while keeping the frame in
proportion. For example, a music frame that fills the entire height and width of a page has
constraints on all four sides. All sides have an inset of zero, which means that the edges of the
frames are in line with the page margins. If you change the size of the page, the frame size
changes accordingly so that it always fills the page, whatever the current page size.
NOTE
Page size and margins are set for each layout in Setup > Layout Options.
If you remove a constraint from one side of a frame, that unlocks that side of the frame from the
page margin, meaning you can determine a fixed width/height that prevents that side of the
frame from adjusting, even if the page size changes.
EXAMPLE
If you have set a frame for a header, you might want the left and right sides to be locked to the
left and right margins of the page. For the top side of the frame, you might want to lock it to the
top margin, but want to keep the height of the header fixed. In this case, you can remove the
lock to the bottom margin and specify a fixed height by moving the side of the frame, or by
entering a value in one of the value fields in the Properties panel.
In the Frames section of the Formatting panel, you can define the constraints for all types of
frames that are available in Dorico Pro. All new frames have active constraints on all sides by
default. You can unlock two sides of a frame to specify a fixed width or height. For example, if
you remove the lock to the top margin, you can also remove the lock to the right/left margin.
RELATED LINKS
Layout Options dialog on page 104

Defining frame constraints
You can determine on which sides of frames you want to apply constraints.
PREREQUISITE
If you want to define the constraints of frames on a master page, you have opened the master
page in the master page editor.
PROCEDURE
1.

In the Engrave toolbox, click Frames to show the Formatting panel.

2.

In the music area, select the frame whose constraints you want to define.

3.

In the Constraints section of the Formatting panel, click the constraint that corresponds to
the side of the frame that you want to change.
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Locked constraint

4.

Unlocked constraint

Move the unlocked side of the frame to the position you want.
TIP
You can also enter fixed values for Height or Width in the Frames group of the Properties
panel.

RELATED LINKS
Formatting panel on page 352
Master page editor on page 370
Customizing master pages on page 371

Text formatting
Dorico Pro combines different settings for the appearance of text, meaning that you can format
fonts and texts in different places depending on their function.
For example, you can change the font family used for all text in your project in the Edit Font
Styles dialog, and then make specific changes for when that font is used for titles in the
Paragraph Styles dialog.
Paragraph styles apply to whole text frames or all text within a single text object. Character styles
apply to individual selections, meaning you can apply different character styles to each word
within the same text frame.
Font styles apply to items that use text but are not text frames or text objects, such as tempo
marks and dynamics.
If you open a project that contains fonts not installed on your computer, the Missing Fonts
dialog opens and allows you to select replacement fonts as substitutes.
RELATED LINKS
Paragraph Styles dialog on page 410
Character Styles dialog on page 413
Text editor options in Engrave mode on page 415
Missing Fonts dialog on page 73
Text frames on page 395
Entering text in text frames on page 402
Changing the vertical alignment of text in text frames on page 403

Edit Font Styles dialog
The Edit Font Styles dialog allows you to edit the formatting of fonts used for items that you
cannot edit using the text editor, such as changing the font size of rehearsal marks, dynamics, or
tempo marks.
●

You can open the Edit Font Styles dialog in Engrave mode by choosing Engrave > Font
Styles.

The Edit Font Styles dialog contains fonts that are used in Dorico Pro that you cannot edit
directly in the music area, unlike text objects and text in text frames, which you can edit using the
text editor.
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Edit Font Styles dialog

Font style
Allows you to select different font styles in order to change aspects of the font. If you
have previously opened the Edit Font Styles dialog in the same session, your
previously selected font style is remembered.
Font family
Sets the overall font style.
Size
Sets the size of the font.
Staff-relative/Absolute
Allows you to choose whether the size of the font changes according to the staff size of
the layout or whether it is always the set size.
Style
Sets the appearance of the font from the following options:
●

Regular

●

Italic

●

Bold

●

Bold Italic

Underlined
Fonts appear underlined when Underlined and the corresponding checkbox are both
activated.
NOTE
●

You must activate options before you can change them.

●

Changes made to font styles apply project-wide, including in part layouts.

●

If you cannot find a particular font style, it might instead be a paragraph style.

RELATED LINKS
Paragraph Styles dialog on page 410
Missing Fonts dialog on page 73
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Music Fonts dialog
The Music Fonts dialog allows you to change the font used for notations and glyphs projectwide. Any font you use for notations and glyphs must be SMuFL-compliant.
●

You can open the Music Fonts dialog in Engrave mode by choosing Engrave > Music Fonts.

Music Fonts dialog

The dialog contains all available SMuFL fonts you have installed on your computer that have the
appropriate metadata for Dorico Pro to recognize them. By default, Dorico Pro comes with the
following SMuFL-compliant fonts:
●

Bravura: The default music font, inspired by traditional classical music engraving.

●

Petaluma: Handwritten music font style, similar to the traditional style used for jazz music.

Changing the music font used in the Music Fonts dialog changes the fonts used for notations,
glyphs, and other items that are not text, such as clefs, dynamics, and bold tuplet numbers/
ratios.
TIP
You can change the fonts used for these items individually by changing the Default Text Font
style in the Edit Font Styles dialog, and the Default Text paragraph style in the Paragraph
Styles dialog.
The Music Fonts dialog also contains the following options:
Update text fonts when changing music fonts
Allows you to include/exclude text fonts when changing the music font. For example,
deactivating this option allows you to change the appearance of notes and notations
without affecting the appearance of flow titles and staff labels.
●

For the Bravura music font, the equivalent text font is Academico.

●

For the Petaluma music font, the equivalent text font is Petaluma Script.

Use font’s recommended engraving options
Allows you to import the default settings that come with the font.
NOTE
Certain items that are marked as optional in SMuFL fonts, such as clef changes and non-bold
tuplet numbers/ratios, are not affected when you change the music font.
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Paragraph Styles dialog
The Paragraph Styles dialog allows you to change paragraph styles for text and create new
styles. You can later use different paragraph styles in different places in your project by choosing
them in the text editor.
For example, you can customize the paragraph style for layout names and then apply your layout
name paragraph style to every text frame in which you show layout names. This allows you to
keep the presentation of different types consistent across your project.
●

You can open the Paragraph Styles dialog in Engrave mode by choosing Engrave >
Paragraph Styles.

Paragraph Styles dialog

The Paragraph Styles dialog contains the following sections and options:
1

Paragraph styles list
Contains all the paragraph styles in the project. If you had text items selected when you
opened the dialog, the corresponding paragraph style of the first selected item is selected in
the paragraph styles list by default.
The action bar at the bottom of the list contains the following options:
●

New: Creates a new paragraph style with default values.

●

New from Selection: Creates a copy of an existing paragraph style that you can edit
separately from the original.

●

Save as Default: Copies the selected style to your library so that it is available in other
projects.

●

Revert to Factory: Removes all your changes to the selected predefined paragraph
styles, reverting them to the default factory settings.
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●

Delete: Deletes the selected style.

NOTE
You cannot delete predefined paragraph styles or any paragraph style that is currently
used in your project.
2

Name
Allows you to enter a name for new paragraph styles or edit the name of existing paragraph
styles.

3

Parent
Allows you to choose a parent paragraph style from which the selected paragraph style
inherits settings.

4

Font appearance options
Allow you to change parameters of the appearance of the paragraph style font, such as
changing the font, making the font bold, changing the size of the font, and changing the
letter or word spacing. You can also make the font in paragraph styles appear underlined or
overlined.

5

Paragraph layout options
Allow you to change the layout of the paragraph style, such as indenting the first line in each
paragraph and changing the alignment of text.

6

Color options
Allow you to change the foreground and background colors of the paragraph style.

RELATED LINKS
Missing Fonts dialog on page 73

Creating paragraph styles
You can create new paragraph styles from scratch and you can duplicate existing paragraph
styles and edit the settings, for example, to format text consistently in multiple text frames.
PROCEDURE
1.

In Engrave mode, choose Engrave > Paragraph Styles to open the Paragraph Styles dialog.

2.

Create a new paragraph style in one of the following ways:
●

To create an entirely new paragraph style, click New in the action bar.

●

To create a copy of an existing paragraph style, select it in the paragraph styles list and
click New From Selection in the action bar.

3.

Enter a name for the style in the Name field.

4.

Optional: Select one of the available styles from the Parent menu.
NOTE
If you select a parent style, your paragraph style inherits its settings automatically for all
options with deactivated sliders. If your paragraph style has activated sliders, which override
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its parent style settings, you can deactivate them to reset those options to follow the parent
style.
5.

Activate and change the options as required.

6.

Click OK to save your changes and close the dialog.

Changing the default horizontal alignment of text styles
You can change the default horizontal alignment of the paragraph styles used for different types
of text. This changes the horizontal alignment of the corresponding text style project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Paragraph Styles to open the Paragraph Styles dialog.

2.

In the paragraph style list, select the text style whose default alignment you want to change.

3.

Choose the Alignment option you want.

4.

Optional: Repeat steps 2 and 3 for other paragraph styles whose horizontal alignment you
want to change.

5.

Click OK to save your changes and close the dialog.

RESULT
The default alignment of the selected text style is changed.
TIP
You can also override the horizontal alignment of text in individual text frames.

RELATED LINKS
Changing the horizontal alignment of text in text frames on page 404

Deleting paragraph styles
You can delete paragraph styles you have created. However, you cannot delete any of the default
paragraph styles.
PROCEDURE
1.

In Engrave mode, choose Engrave > Paragraph Styles to open the Paragraph Styles dialog.

2.

In the paragraph style list, select the style that you want to delete.
NOTE
You cannot delete any of the default paragraph styles.

3.

Click Delete.

4.

Click OK to save your changes and close the dialog.
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Character Styles dialog
The Character Styles dialog allows you to change character styles and create new styles. You can
later apply character styles to individual letters or words in different places in your project by
choosing them in the text editor.
For example, you can create a custom character style with wide letter spacing for specific words
and then apply that character style to selected words. Unlike paragraph styles, character styles
do not have to apply to whole text frames or text objects.
●

You can open the Character Styles dialog in Engrave mode by choosing Engrave >
Character Styles.

Character Styles dialog

The Character Styles dialog contains the following sections and options:
1

Character styles list
Contains all the character styles in the project.
The action bar at the bottom of the list contains the following options:
●

New: Creates a new character style with default values.

●

New from Selection: Creates a copy of an existing character style that you can edit
separately from the original.

●

Save as Default: Copies the selected style to your library so that it is available in other
projects.

●

Revert to Factory: Removes all your changes to the selected predefined character
styles, reverting them to the default factory settings.

●

Delete: Deletes the selected style.
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NOTE
You cannot delete predefined character styles or any character style that is currently
used in your project.
2

Name
Allows you to enter a name for new character styles or edit the name of existing paragraph
styles.

3

Character style options
Allow you to change parameters of the character style, such as changing the font, making
the font bold, changing the size of the font, and changing the letter or word spacing. You can
also make the font in paragraph styles appear underlined or overlined, and change the
vertical alignment of characters.

4

Color options
Allow you to change the foreground and background colors of the character style.

RELATED LINKS
Missing Fonts dialog on page 73

Creating character styles
You can create new character styles from scratch and you can duplicate existing character styles
and edit the settings.
PROCEDURE
1.

In Engrave mode, choose Engrave > Character Styles to open the Character Styles dialog.

2.

Create a new character style in one of the following ways:
●

To create an entirely new character style, click New in the action bar.

●

To create a copy of an existing character style, select it in the character styles list and
click New From Selection in the action bar.

3.

Enter a name for the style in the Name field.

4.

Activate and change the options as required.
IMPORTANT
Only activated options have an effect on the text. If you deactivate options, their settings are
reset.

5.

Click OK to save your changes and close the dialog.

Deleting character styles
You can delete character styles.
PROCEDURE
1.

In Engrave mode, choose Engrave > Character Styles to open the Character Styles dialog.

2.

Select the style that you want to delete in the styles list.

3.

Click Delete.
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4.

Click OK to save your changes and close the dialog.

Text objects vs. text in text frames
Text in Dorico Pro can exist as a text object, added to individual staves or as system text, and in
text frames, which are fixed to the page rather than the music.
You can tell the difference between text objects and text in text frames by clicking them once: if
the text appears highlighted with an attachment line to a staff, it is a text/system text object. If
the text does not appear highlighted or has no attachment line, it is in a text frame.
You can edit both types of text in the same ways, but you can only use text tokens in text frames.
You cannot use tokens in text added to staves/systems.
RELATED LINKS
Text tokens on page 396
Text editor options in Engrave mode on page 415
Entering text in text frames on page 402

Text editor options in Engrave mode
The text editor allows you to add and format text. In Engrave mode, it opens when you enter or
edit text in a text frame.

Text editor in Engrave mode

The text editor provides the following options:
1

Character Style
Allows you to change the appearance of selected text within paragraphs. This overrides the
paragraph style applied to the corresponding paragraph.

2

Paragraph Style
Allows you to change the paragraph style applied to the whole paragraph, which can change
the appearance, formatting, and alignment of the text.
Staff text and system text are always treated as single paragraphs.

3

Font
Allows you to change the font family of selected text.

4

Font Style
Allows you to change the font style of selected text.
NOTE

5

●

Depending on the font selected, some font styles might not be available.

●

You can also change the font style using the following standard key commands:
●

Ctrl/Cmd-B for bold

●

Ctrl/Cmd-I for italic

Font Size
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Allows you to change the size of selected text.
TIP
You can also change the font size using the following key commands:

6

●

Ctrl/Cmd-Shift-. to increase the font size

●

Ctrl/Cmd-Shift-, to decrease the font size

Font Stretch
Allows you to make selected text wider or narrower.

7

Baseline Shift
Allows you to shift the baseline of selected text gradually up or down.

8

Letter Spacing
Allows you to increase/decrease the space between the characters of selected text.

9

Word Spacing
Allows you to increase/decrease the space between the words of selected text.

10 Alignment
Allows you to choose the alignment of selected text relative to the rhythmic position of the
text in the score. For text in a text frame, the text is aligned along the left margin of a text
frame.
You can choose from the following alignments:
●

Align Left

●

Align Center

●

Align Right

●

Justify

11 Line Types
Allows you to show any of the following types of lines, in any combination, on selected text:
●

Underline
TIP
You can also make selected text underlined by pressing Ctrl/Cmd-U .

●

Overline

●

Strikethrough

12 Script Types
Allows you to position selected text in one of the following positions relative to the text on
the baseline:
●

Superscript

●

Subscript

13 Foreground Color
Allows you to change the color of selected text.
14 Background Color
Allows you to change the background color of selected text.
RELATED LINKS
Inputting text on page 312
Entering text in text frames on page 402
Paragraph Styles dialog on page 410
Character Styles dialog on page 413
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Missing Fonts dialog on page 73

Changing the paragraph style of text
You can change the paragraph style that is applied to text added to staves and within individual
text frames, including on master pages. For example, if you want to use one paragraph style for
page numbers in full score layouts and another for page numbers in part layouts.
PREREQUISITE
●

If you want to use a different paragraph style to the ones provided by default, you have
created a new paragraph style.

●

If you want to change the paragraph style of text on a master page, you have opened the
master page in the master page editor.

PROCEDURE
1.

Double-click the text object or text frame whose paragraph style you want to change to open
the text editor.
NOTE
To open the text editor for text objects, you must be in Write mode. For text frames, you can
be in Write mode or Engrave mode.

2.

Select the text whose paragraph style you want to change.
TIP
You can apply different paragraph styles to separate paragraphs in the same text frame.

3.

Select a paragraph style from the paragraph style menu in the text editor.

4.

Press Esc or Ctrl/Cmd - Return to close the text editor.

RESULT
The paragraph style of the selected paragraphs is changed. For example, if you select a single
word, the whole paragraph containing that word is changed.
RELATED LINKS
Paragraph Styles dialog on page 410
Creating paragraph styles on page 411
Master page editor on page 370

Paragraph style overrides
If you override the paragraph style of text within text frames on individual pages, such as
changing the size of text in a text frame but not changing the size of its paragraph style, any
changes you later make to the paragraph style are not applied to the overridden text.
You can reset the changes you made to revert individual pages back to the master page format.
However, this removes all changes made to those pages.
NOTE
You cannot reset changes made to text in text frames on master pages.

RELATED LINKS
Removing master page overrides on page 374
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Moving text objects graphically
In Engrave mode, you can move text objects that you input in Write mode without changing the
rhythmic positions to which they are attached. You can move both staff text and system text,
including moving individual instances of system text independently of other instances shown at
different staff positions.
NOTE
These steps do not apply to text in text frames.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

Select the text objects that you want to move.

2.

Move the text objects in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected text objects are moved to new positions.
TIP
Offset in the Common group of the Properties panel is activated automatically when you move
text objects.
●

Offset X moves text objects horizontally.

●

Offset Y moves text objects vertically.

You can also use this property to move text objects by changing the values in the value fields.
Deactivating the property resets the selected items to their default position.

RELATED LINKS
Text editor options in Engrave mode on page 415
Moving frames on page 387
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Enabling/Disabling text collision avoidance
You can change whether individual text objects automatically move to avoid collisions,
independently of your project-wide setting. Text objects with collision avoidance disabled do not
contribute to automatic staff spacing calculations.
NOTE
These steps do not apply to text in text frames.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select the text objects whose collision avoidance you want to enable/
disable.

2.

In the Properties panel, activate Avoid collisions in the Text group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
The selected text objects avoid collisions when the checkbox is activated, and do not avoid
collisions when the checkbox is deactivated.
When the property is deactivated, text objects follow your project-wide setting for text collision
avoidance.
TIP
You can enable/disable text collision avoidance for all text objects project-wide on the Text page
in Engrave > Engraving Options.

Adding borders to text objects
You can add borders to text and system text objects individually, for example, if you want to
make the boundaries of text objects clear.
PROCEDURE
1.

Select the text objects to which you want to add borders. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Border in the Text group.

RESULT
Borders are added to the selected text objects.
TIP
●

You can show borders on text objects in addition to erasing their background.

●

Deactivating Border removes borders from the selected text objects.
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EXAMPLE

Text with no border

Text with border shown

AFTER COMPLETING THIS TASK
You can change the padding between text objects and each edge of their borders.

Changing the thickness of text object borders
You can change the thickness of borders around individual text objects, independently of your
project-wide setting.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select the text objects whose border thickness you want to change.

2.

In the Properties panel, activate Border thickness in the Text group.

3.

Change the value in the value field.

RESULT
The thickness of borders around the selected text objects is changed.
TIP
You can change the default thickness of all text object borders project-wide on the Text page in
Engrave > Engraving Options.

RELATED LINKS
Changing the thickness of text frame borders on page 403

Changing the padding around text objects
You can change the padding around text objects individually, and for each edge independently.
This affects the distance between text and erased backgrounds and borders.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select the text objects whose padding you want to change.

2.

In the Properties panel, activate the Erasure padding properties, individually or together, in
the Text group.
●

L changes the padding between text objects and their left edge.

●

R changes the padding between text objects and their right edge.

●

T changes the padding between text objects and their top edge.

●

B changes the padding between text objects and their bottom edge.

420
Dorico Pro 3.1.10

Engrave mode
Text formatting
3.

Change the values in the value fields for the edges whose padding you want to change.

RESULT
The padding around the selected text objects is changed. Increasing the values increases the
padding, decreasing the values decreases the padding.
TIP
You can change the default padding of all text objects project-wide on the Text page in
Engrave > Engraving Options. However, this does not allow you to change the padding of each
edge independently.

Erasing the background of text objects
You can erase the background of individual text and system text objects, for example, to ensure
the text remains legible when crossing barlines.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select the text objects whose backgrounds you want to erase.

2.

In the Properties panel, activate Erase background in the Text group.

RESULT
The backgrounds of the selected text objects are erased.
TIP
●

You can show borders on text objects in addition to erasing their background.

●

Deactivating Erase background returns the selected text objects to the default non-erased
background.

EXAMPLE

Text with non-erased background

Text with erased background

AFTER COMPLETING THIS TASK
You can change the padding between text objects and each edge of their erased areas.

421
Dorico Pro 3.1.10

Engrave mode
Music symbols

Music symbols
Music symbols in Dorico Pro is a broad term that covers all the different elements used in
musical notation, including stem flags, clefs, articulations, and the bold numbers used in multibar rests and time signatures.
In Dorico Pro, some music symbols have specific editor dialogs in which you can edit and create
custom versions of those symbols. For all other music symbols, you can edit their project-wide
appearance in the Edit Music Symbol dialog.
RELATED LINKS
Edit Accidental dialog on page 857
Edit Chord Symbol Component dialog on page 701
Edit Notehead dialog on page 895
Edit Playing Technique dialog on page 1025

Edit Music Symbol dialog
The Edit Music Symbol dialog allows you to edit the appearance of all the different music
symbols used in Dorico Pro that do not have a dedicated editor, such as chord symbols,
accidentals, noteheads, and playing techniques.
●

You can open the Edit Music Symbol dialog in Engrave mode by choosing Engrave > Music
Symbols.

NOTE
You cannot create new music symbols in the Edit Music Symbol dialog, you can only edit existing
music symbols.

Edit Music Symbol dialog

The Edit Music Symbol dialog contains the following sections and options:
1

Category menu
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Allows you to filter the list of music symbols by selecting a category from the menu.
2

Music symbol list
Contains all the music symbols in the project within the currently selected category.
The action bar at the bottom of the list contains the following options:

3

●

Save as Default: Saves the currently selected music symbol in its current state as the
default for all future projects.

●

Revert to Factory: Removes all edits you have made to the selected music symbol,
returning it to its original settings and appearance.

Name
Displays the default name for the selected music symbol.

4

Component selector
Allows you to choose components to add to the music symbol. You can add different types of
components by clicking the respective tab titles.
●

Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting different
fonts and different ranges from the menus. Click Add Glyph to add the selected glyph to
the music symbol.
NOTE
A full list of the different ranges of glyphs is available on the SMuFL website.

5

●

Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected text, or
input text, to the music symbol.

●

Graphic: Allows you to load a new graphics file, or select an existing graphic from the
Select existing list, in SVG, PNG, or JPG format. You can see a preview of the graphic in
the Preview box. Click Add Graphic to add the selected graphic to the music symbol.

Editor
Allows you to arrange and edit the components that make up the music symbol. You can
arrange and edit components by clicking and dragging them in the editor and by using the
controls at the bottom of the dialog. You can also use the handles on each component to
change their size.

6

Editor action bar
Contains selection and view options for the editor.

7

●

Zoom: Allows you to change the zoom level in the editor.

●

Select: Allows you to select the next/previous component.

●

Show Attachments: Shows all the attachments on all components in the editor.

●

Delete: Deletes the selected component.

Controls
Contains controls that allow you to edit individual components. Controls are divided into tabs
according to the aspect of the selected component they affect. For music symbols, only the
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Component and Attachments tabs are available as the other tabs do not apply to the
symbols in the dialog.
The Component tab contains the following options:
●

Offset: Controls the position of the selected component. X moves it horizontally, Y
moves it vertically.

●

Scale: Controls the size of the selected component. For graphics, X controls its width, Y
controls its height.
NOTE
Although some components scale their height and width independently, others retain
their aspect ratio, meaning only one value affects their overall size.

●

Z order: Allows you to Bring Forward or Send Backward the selected component in
relation to other components when they overlap.

The Attachments tab is only available if the music symbol comprises at least two separate
components. It contains the following options:
●

Attachment from: Sets the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend that
you select a right edge attachment point for Attachment from.

●

Attachment to: Sets the attachment point on the selected component which attaches to
the component to its left. We recommend that you select a left edge attachment point
for Attachment to.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.

The attachment points have the following names in the Edit Music Symbol dialog:
1

Top Left

2

Top Center

3

Top Right

4

Middle Left

5

Middle Right

6

Baseline Left (text only)

7

Baseline Center (text only)

8

Baseline Right (text only)

9

Bottom Left

10 Bottom Center
11 Bottom Right
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Note spacing
The positions of notes and rests relative to each other, and the automatic gaps between them,
are known as note spacing.
You can change note spacing in your project at different levels:
●

Change the default note spacing in each layout in Layout Options.

●

Change the note spacing from a specified point in individual frame chains in individual
layouts.

●

Change the note spacing at individual rhythmic positions and for individual notes.

TIP
●

We recommend adjusting the default note spacing values, changing the note spacing for
specific sections, or changing the staff size before moving individual notes, as in most cases
Dorico Pro produces suitable results without the need to move individual notes.

●

You can find other options that control the gaps between notes and other items, such as
barlines and time signatures, on the Spacing Gaps page in Engrave > Engraving Options.

RELATED LINKS
Changing note spacing from rhythmic positions on page 427
Adjusting note spacing at individual rhythmic positions on page 429
Changing the start/end position of systems on page 433
Layout Options dialog on page 104
Staff spacing on page 455
Changing the default staff size on page 438

Changing the default note spacing
You can change the default note spacing in each layout independently. For example, you can
have tighter note spacing in full score layouts compared to part layouts. The options available
include changing the default space for quarter notes and the scale space for grace notes and
cues.
PROCEDURE
1.
2.

Press Ctrl/Cmd-Shift-L to open Layout Options.
In the Layouts list, select the layouts in which you want to change note spacing.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Note Spacing in the page list.

4.

Change the values of the options you want to change.

5.

Click Apply, then Close.

RESULT
The default note spacing is changed in the selected layouts.
RELATED LINKS
Changing the horizontal justification of final systems on page 449
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Note Spacing page in Layout Options
The Note Spacing page in Layout Options allows you to change the default values for note
spacing in each layout independently. You can also change how full the final system in flows
must be before it is automatically justified.
●

You can access the Note Spacing page by choosing Setup > Layout Options and clicking
Note Spacing in the page list.

The Note Spacing page in Layout Options contains the following options:
Default space for crotchet/quarter note
Sets the default note spacing for quarter notes (crotchets). The spacing of other
durations is scaled proportionally. Increasing the value increases note spacing,
decreasing the value decreases note spacing. This is reflected in the preview as you
change the value.
Minimum space for short notes
Sets the minimum note spacing for notes with short durations. This can be
independent of the default note spacing value.
Custom spacing ratio
Sets the spacing of notes in relation to other notes according to their rhythmic values.
For example, setting Custom spacing ratio to 2 means half notes (minims) take up
twice as much space as quarter notes, and eighth notes (quavers) take up half as much
space as quarter notes.
Scale space for grace notes by
Sets the note spacing for grace notes as a percentage of the note spacing normally
used for notes of their duration. The value cannot be greater than 100%. Increasing the
value increases the note spacing for grace notes, decreasing the value decreases the
note spacing for grace notes.
Scale space for cue notes by
Sets the note spacing for cues as a percentage of the note spacing normally used for
notes of their duration. The value cannot be greater than 100%. Increasing the value
increases the note spacing for cues, decreasing the value decreases the note spacing
for cues.
Make space for lyrics
Controls whether or not lyrics are included in note spacing calculations. When
deactivated, lyrics are excluded from note spacing calculations, producing a result
where notes are spaced as if lyrics were not there.
We recommend using this option with caution and only if you intend to space lyrics
manually, such as in tightly-spaced hymnals.
Only justify final system in flow when more than [n]% full
Allows you to change how full the final system in each flow must be before it is justified
to the full width of the frame. By default, final systems that are 50% full or less are not
justified.
Use optical spacing for beams between staves
When activated, stems in cross-staff beams are evenly spaced, which can mean the
noteheads are unevenly spaced. When deactivated, noteheads in cross-staff beams are
evenly spaced, which can mean stems appear unevenly spaced.
RELATED LINKS
Optical spacing for cross-staff beams on page 673
Creating cross-staff beams on page 672
Adjusting note spacing at individual rhythmic positions on page 429
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Changing note spacing from rhythmic positions
You can change note spacing values from selected rhythmic positions onwards in individual
layouts, including changing the scale factor for grace notes and cues.
PROCEDURE
1.

In the music area, open the layout in which you want to change note spacing.

2.

Select an item at the rhythmic position from which you want to change note spacing, and in
the frame chain to which you want the changes to apply.

3.

Choose Engrave > Note Spacing Change to open the Note Spacing Change dialog.

4.

Activate the note spacing options you want to change.

5.

Choose Change for each activated option.

6.

Change the value of each note spacing option you want to change.

7.

Click OK to save your changes and close the dialog.

RESULT
Note spacing is changed from the selected rhythmic position onwards. This applies to the frame
chain containing the selected item and the layout currently open in the music area.
A signpost is shown at the position of the note spacing change.

Note Spacing Change dialog
The Note Spacing Change dialog allows you to change or reset values affecting the spacing and
scaling of notes from selected rhythmic positions in layouts, including the scale factor for grace
notes and cues.
●

You can open the Note Spacing Change dialog in Engrave mode by choosing Engrave >
Note Spacing Change when Graphic Editing is selected in the Engrave toolbox and an item
is selected in the music area.

Note Spacing Change dialog

The Note Spacing Change dialog contains the following options:
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Default space for crotchet/quarter note
Sets the default note spacing for quarter notes (crotchets). The spacing of other
durations is scaled proportionally. Increasing the value increases note spacing,
decreasing the value decreases note spacing. This is reflected in the preview as you
change the value.
Minimum space for short notes
Sets the minimum note spacing for notes with short durations. This can be
independent of the default note spacing value.
Custom spacing ratio
Sets the spacing of notes in relation to other notes according to their rhythmic values.
For example, setting Custom spacing ratio to 2 means half notes (minims) take up
twice as much space as quarter notes, and eighth notes (quavers) take up half as much
space as quarter notes.
Scale space for grace notes by
Sets the note spacing for grace notes as a percentage of the note spacing normally
used for notes of their duration. The value cannot be greater than 100%. Increasing the
value increases the note spacing for grace notes, decreasing the value decreases the
note spacing for grace notes.
Scale space for cue notes by
Sets the note spacing for cues as a percentage of the note spacing normally used for
notes of their duration. The value cannot be greater than 100%. Increasing the value
increases the note spacing for cues, decreasing the value decreases the note spacing
for cues.
Make space for lyrics
Controls whether or not lyrics are included in note spacing calculations. When
deactivated, lyrics are excluded from note spacing calculations, producing a result
where notes are spaced as if lyrics were not there.
We recommend using this option with caution and only if you intend to space lyrics
manually, such as in tightly-spaced hymnals.
Each option has an activation switch, meaning you can only change values for options that you
have chosen to change. You can then choose one of the following options for the note spacing
change:
Reset
Resets note spacing to the default setting in the layout, as set on the Note Spacing
page in Layout Options.
Change
Changes note spacing in the layout to the values set.
RELATED LINKS
Note Spacing page in Layout Options on page 426

Resetting note spacing from rhythmic positions
You can reset changes you have made to note spacing values using the Note Spacing Change
dialog. This applies from a selected rhythmic position onwards in the layout currently open in the
music area.
PROCEDURE
1.

In the music area, open the layout in which you want to reset note spacing from a specific
point.
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2.

Select an item at the rhythmic position from which you want to reset note spacing, and in the
frame chain to which you want the changes to apply.

3.

Choose Engrave > Note Spacing Change to open the Note Spacing Change dialog.

4.

Activate the note spacing options you want to reset.

5.

Choose Reset for each activated option.

6.

Click OK to save your changes and close the dialog.

RESULT
Note spacing is reset to the default settings in the layout for the activated options from the
selected rhythmic position onwards until the end of the flow. This applies to the frame chain
containing the selected item and the layout currently open in the music area.
A signpost is shown at the position of the note spacing change.

Deleting note spacing changes
You can delete note spacing changes you have made using the Note Spacing Change dialog,
which returns note spacing to either the previous existing note spacing change in the flow or the
default settings in the layout.
PROCEDURE
1.

Select the signposts of the note spacing changes you want to delete.

2.

Press Backspace or Delete .

RESULT
The selected note spacing changes are deleted. Note spacing returns to either the previous
existing note spacing change in the flow, if one exists, or the default settings in the layout if there
is no previous existing note spacing change. This applies until the next existing note spacing
change or until the end of the flow, whichever comes first.

Adjusting note spacing at individual rhythmic positions
You can make adjustments to the note spacing at individual rhythmic positions independently of
your project-wide settings.
When Note Spacing in the Engrave toolbox is activated, the following are shown:
●

Dashed lines that represent spacing columns.

●

Note spacing handles: square handles on every staff for each spacing-significant item, such
as notes, grace notes, rests, clefs, key signatures, and time signatures.

●

System handles: larger square handles at the start/end of each system, which control the
start/end horizontal position of individual systems. System handles are positioned on the top
left and bottom right corners of each system.

Handles and dashed lines are shown when Note Spacing is activated.
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PROCEDURE
1.

In the Engrave toolbox, activate Note Spacing.

2.

Select a square handle on the dashed line at each rhythmic position whose spacing you want
to adjust.

3.

Move the handles in any of the following ways:
●

To increase the space to the left of selected handles, press Alt/Opt-Right Arrow .

●

To decrease the space to the left selected handles, press Alt/Opt-Left Arrow .
NOTE
●

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

You cannot move note spacing handles with the mouse, you can only move them
using the keyboard.

RESULT
The selected note spacing handles are moved, which increases/decreases the spacing to the left
of their original rhythmic position. This also affects the spacing of each selected rhythmic
position on all staves in the system. The color of the handles changes to indicate that you have
moved them.
System breaks are automatically inserted at the start/end of each system in which you adjusted
note spacing.
NOTE
●

Moving notes too far away from their intended rhythmic positions can be misleading for
players reading the music.

●

You can also adjust the spacing of individual notes/items independently of their rhythmic
positions.

●

When Note Spacing is activated, you cannot select or edit anything other than note spacing
handles. To resume normal selection and editing, click Graphic Editing in the Engrave
toolbox or return to Write mode.
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EXAMPLE

Moving note spacing handles to the left reduces
spacing to the left of the rhythmic position
Moving note spacing handles to the right increases
spacing to the left of the rhythmic position

RELATED LINKS
Engrave toolbox on page 351
Changing the default note spacing on page 425
Changing note spacing from rhythmic positions on page 427
Changing the start/end position of systems on page 433
Adjusting the spacing of individual notes/items independently of their rhythmic positions on
page 432
Removing individual changes to note spacing on page 434
System breaks on page 465
Signposts on page 335

System fullness indicator
The system fullness indicator is a highlighted region in the right page margin that is shown when
Note Spacing is activated. The system fullness indicator uses colors and percentages to indicate
the fullness of the system.
The following colors are used in the system fullness indicator:
●

Green: the system is comfortably full. Notes have enough horizontal space to be legible but
are not too far apart. Systems that are 60-100% full are considered comfortably full.

●

Purple: the system is under-full, meaning notes might appear overly stretched. Systems that
are less than 60% full are considered under-full.

●

Red: the system is over-full, meaning notes might appear squashed with not enough
horizontal space between them. Systems that are more than 100% full are considered overfull.

The fullness of systems is also expressed using a percentage. The percentage indicated is
calculated by dividing the number of spaces occupied in the system by the total number of
available spaces in the system, which is measured from the start of the rhythmic space to the
right of the initial clef/time signature/key signature up to the final barline in the system.
Both the color of the system fullness indicator and the fullness percentage are updated in real
time as you adjust note spacing in the system.
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System comfortably full

System under-full

System over-full

RELATED LINKS
Engrave toolbox on page 351
Changing the default note spacing on page 425
Frame fullness indicator on page 460

Adjusting the spacing of individual notes/items independently of their rhythmic
positions
You can change the graphical position of notes according to their voice and some other items,
such as key signatures, time signatures, and clefs, independently of their rhythmic positions.
PROCEDURE
1.

In the Engrave toolbox, activate Note Spacing.

2.

Select the square handle at the rhythmic position of the note/item you want to move
graphically.

A circular handle appears beside each voice/item.
3.

Press Tab to select the circular handle.

4.

Move the handle in any of the following ways:
●

Press Alt/Opt-Right Arrow to move it to the right.

●

Press Alt/Opt-Left Arrow to move it to the left.
NOTE
●

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

You cannot move note spacing handles with the mouse, you can only move them
using the keyboard.

RESULT
The graphical position of the selected note/item is changed without changing the note spacing of
its rhythmic position. If other notes exist in the same voice at the same rhythmic position, they
are also moved.
System breaks are automatically inserted at the start/end of each system in which you adjusted
the position of individual notes/items.
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EXAMPLE

Changing the start/end position of systems
You can change the start/end horizontal position of each system individually, for example, if you
want to indent a single system or increase the gap before an individual coda section.
NOTE
●

If you want to increase the space before staff labels, you can change the minimum indent for
systems with staff labels in each layout independently on the Staves and Systems page in
Setup > Layout Options.

●

If you want to change the end position of systems because they do not fill the entire width of
the page, you can change the minimum fullness for justification on the Note Spacing page
in Layout Options.

●

If you want to change the width of all systems on a page by the same amount, you can
change the width of the music frame.

PROCEDURE
1.

In the Engrave toolbox, activate Note Spacing.

2.

Select the system handle at the start/end of each system whose start/end position you want
to change.

System handle at the start of a system

3.

System handle at the end of a system

Move the handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.
NOTE
●

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

You cannot move note spacing handles with the mouse, you can only move them
using the keyboard.

433
Dorico Pro 3.1.10

Engrave mode
Note spacing
RESULT
The start/end position of the selected systems is changed. Notes on the selected systems appear
more/less tightly spaced, depending on whether moving the system handles made their system
narrower or wider.
RELATED LINKS
System indents on page 1174
Changing the horizontal justification of final systems on page 449
Changing the first system indent on page 1175
Changing the minimum indent for systems with staff labels on page 1149
Positions of repeat markers on page 1082
Music frames on page 389

Removing individual changes to note spacing
You can remove changes you have made to the note spacing at individual rhythmic positions and
reset note spacing handles to their original default positions.
PROCEDURE
1.

In the Engrave toolbox, activate Note Spacing.

2.

Select the note spacing handles you want to restore to their original positions.

3.

Press Backspace or Delete .

RESULT
The selected rhythmic positions are reset to their default positions.
TIP
You can also reset all note spacing changes within selected systems, frames, or all note spacing
changes in the layout by choosing one of the options in the Engrave > Note Spacing menu.
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The formatting of pages in Dorico Pro is determined by a number of factors, including the
layout’s staff size, page margins, the master page applied to them, any casting off values applied
to them, system and frame breaks, and frame padding.
The most important factors that determine how pages are formatted in Dorico Pro are:
Staff size
Staff size refers to the distance between the top and bottom lines of staves. The most
appropriate staff size depends on the intended purpose and contents of the layout. In
many cases, changing the staff size is the quickest way to produce legible layouts.
Staff spacing
Staff spacing mostly involves the height of staves and the necessary gaps between
staves and systems.
Casting off
Casting off, that is, the process of determining a set number of bars per system and
systems per page, allows you to fix a regular appearance across entire layouts.
System and frame breaks
System and frame breaks allow you to adjust layouts on a local level, by determining
which bars are shown on each system and where music is pushed into the next frame.
Page margins
Page margins determine the dimensions of pages in layouts. Frames cannot exceed
the boundaries set by the margins of the layout, which you can change on the Page
Setup page in Setup > Layout Options. You can change the size of margins on each
edge of each page.
Master pages
All pages in your layouts inherit their layout formats from master pages. Whenever you
create or change anything on master pages, this is automatically reflected on the
pages that use these master pages. If you want to show information on pages in your
project, such as the composer’s name on the first page or the flow title in the running
header at the top of all subsequent pages, in most cases it is simplest to do this by
editing the relevant master page.
TIP
For displaying information such as the composer, librettist, or flow or project titles, we
recommend using tokens to refer to fields in the Project Info dialog.
Flow headings
Flow headings show the number and title of each flow immediately above their first
system automatically. They have no fixed vertical position and follow the music if it
moves. The default flow heading contains tokens to display the flow number and flow
title; in a new project, this appears as “1. Flow 1”.
You can hide/show flow headings on a per-layout basis. You can customize flow
headings in the flow heading editor, including inputting extra frames, changing the
contents of text frames, and editing/moving existing text and graphics frames.
Deleting or editing individual flow headings is considered a master page override,
which is a type of page format change.
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Music frame margins
Music frames have margins at the top and bottom. Music frame margins provide
padding to ensure that musical material displayed within the frame remains on the
page. For example, if music frames have no padding, the top line on the top staff in the
frame is positioned at the top of the frame. Any notes that require ledger lines above
the staff might then be positioned off the top of the page. You can change the default
music frame margins for each layout and change the padding of individual music
frames in Engrave mode using properties in the Properties panel.
Frame constraints
Frame constraints lock the edges of frames to edges of pages. This allows a single
master page to be applied to layouts with different paper sizes and remain consistently
proportioned.
We recommend familiarizing yourself with these concepts, and how to use them together and in
different contexts, in order to produce well-formatted layouts.
RELATED LINKS
Staff size on page 452
Staff spacing on page 455
Casting off on page 451
System breaks on page 465
Frame breaks on page 463
Frame constraints on page 406
Master pages on page 361
Master page editor on page 370
Flow headings on page 381
Hiding/Showing flow headings on page 445
Flow heading editor on page 382
Page format changes on page 372
Tacets on page 467
Layouts on page 134
Flows on page 132
Players on page 108
Project Info dialog on page 102
Text tokens on page 396

Changing the page size and orientation
You can change the page size and orientation of each layout independently. For example, you
can use a large, landscape page in full score layouts and a small, portrait page for part layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the page size and/or
orientation.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Page Size section, select a page size from the Size menu.
For example, you can select fixed page sizes, such as A3 or Letter, or select Custom to
define your own page size.
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5.

Optional: If you selected Custom, change the Width and Height of the page by changing
the values in the value fields.

6.

Choose one of the following options for Orientation:
●

Portrait

●

Landscape

7.

Optional: Repeat steps 2 to 6 for other layouts whose page size/orientation you want to
change.

8.

Click Apply, then Close.

RESULT
The page size is changed for all the selected layouts.
NOTE
Changing the page size of layouts might not change the paper size automatically selected for
those layouts in the Print Options panel in Print mode. For example, if your default printer
cannot print the page size selected for layouts, the largest paper size the printer can handle is
selected. Similarly, if you had already set options for printing layouts before changing the page
size in Layout Options, Dorico Pro attempts to preserve your original print options.
Similarly, the page orientation is independent of the paper orientation. We recommend that you
check that layouts have the correct paper orientation set for their page orientation in the Print
Options panel in Print mode before printing/exporting, as it is possible to print landscape layouts
on portrait paper and vice versa.

RELATED LINKS
Page sizes and paper sizes on page 607
Paper orientation on page 608
Paper size and orientation setup on page 608
Changing the default staff/system spacing on page 439

Changing page margins
You can change the page margins of each layout independently, for example, if you want wider
margins for layouts in your project that will be spiral bound.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the page margins.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Page Margins section, choose one of the following options for Page margins:

5.

●

Same: All pages in the selected layouts have the same margins.

●

Different: Left and right pages in the selected layouts can have completely different
margins.

●

Mirrored: Left and right pages in the selected layouts use the same margin values but
they correspond to the inside/outside edges of pages.

Optional: Change the margins by changing the values in the value fields.
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6.

Click Apply, then Close.

RESULT
The page margins in the selected layouts are changed. Any frames in the selected layouts with
fixed constraints are automatically moved or resized as required.
RELATED LINKS
Frame constraints on page 406

Changing the default staff size
You can change the default size of staves in each layout independently. For example, you can
have a small staff size in full score layouts but a larger staff size in part layouts.
NOTE
If the size of system object font styles is set to Staff-relative, the staff size of the top staff in each
instrument family group affects the size of system objects if they are shown above that bracketed
group. Font styles that are set to Absolute are unaffected by staff size.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts whose staff size you want to change.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Space Size section, select the staff size you want from the Rastral size menu.
NOTE
If you select Custom, you can set a custom value in the Space size field, expressed in your
preferred unit of measurement.
You can also set a Custom value by changing the value when any Rastral size is selected.

5.

Optional: Repeat steps 2 to 4 for other layouts.

6.

Click Apply, then Close.

RESULT
The staff size is changed throughout the selected layouts.
TIP
You can also change the staff size from selected rhythmic positions onwards in layouts, and
change the size of individual staves.

RELATED LINKS
Staff size on page 452
Edit Font Styles dialog on page 407
Brackets and braces on page 683
System objects on page 1172
Changing the size of individual staves on page 453
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Changing the staff size from system/frame breaks on page 452

Changing the default staff/system spacing
You can change the default gaps between staves and systems in each layout independently. For
example, you can have smaller gaps between staves in full score layouts to accommodate more
staves, and larger gaps between systems in part layouts to give players space to add pencil
markings.
TIP
●

If the staves in a layout are very close together, just decreasing the staff size might be
sufficient to produce good results.

●

We recommend that you set the ideal gaps to the minimum value acceptable to you, as
Dorico Pro automatically allocates additional space for other items, such as system objects
and dynamics, and avoids collisions between notes and staves above/below.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the default staff/system
spacing.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Vertical Spacing in the page list.

4.

In the Ideal Gaps section, change the values for the different contexts as required.

5.

Click Apply, then Close.

RESULT
The minimum gaps between staves and systems in the corresponding contexts are changed. This
affects how much space Dorico Pro allows for staves/systems in its casting off estimations and
whether frames are considered full enough to justify vertically automatically.
RELATED LINKS
Per-layout vertical spacing options on page 456
Note spacing on page 425
Changing the default note spacing on page 425

Changing the vertical justification of staves/systems
You can change the minimum fullness threshold above which Dorico Pro automatically vertically
justifies staves and systems, which means they are evenly distributed to fill the height of frames.
You can also control whether staves and systems are both vertically justified or only systems are
vertically justified.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the automatic vertical
justification of staves/systems.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.
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3.

Click Vertical Spacing in the page list.

4.

In the Ideal Gaps section, choose one of the following options for Gap to use for divisi
staves:

5.

●

Staff to staff

●

Braced staff to braced staff

In the Vertical Justification section, change the values for the following options, individually
or together:
●

Justify distance between staves and systems when frame is at least [n]% full

●

Justify distance only between systems when frame is at least [n]% full

6.

Activate/Deactivate Justify staves when frame with single system is above this threshold.

7.

Click Apply, then Close.

RESULT
The automatic vertical justification of staves and systems in the selected layouts is changed.
Braced staves are never vertically justified.
EXAMPLE

A page with staves and systems both justified

The same page with only systems justified

RELATED LINKS
Per-layout vertical spacing options on page 456
Changing the default staff/system spacing on page 439
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Hiding/Showing empty staves
You can hide/show empty staves differently in each layout in your project. For example, you can
show all staves, including empty staves, in a full score layout for the conductor but hide empty
staves in a full score layout intended for reference only.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show empty staves.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Vertical Spacing in the page list.

4.

In the Hide Empty Staves section, choose one of the following options for Hide empty
staves:
●

After first system

●

All systems

●

Never

5.

Activate/Deactivate Allow individual staves of multi-staff instruments to be hidden.

6.

Optional: For Players excluded from Hide Empty Staves, activate the checkbox for each
instrument you want to be shown regardless of your choice for Hide empty staves.

7.

Click Apply, then Close.

RESULT
Empty staves in the selected layouts are hidden/shown according to your choice. If you activated
Allow individual staves of multi-staff instruments to be hidden, any single empty staves in
multi-staff instruments, such as piano or harp, can be hidden in the selected layouts.
NOTE
●

Instruments that have extra staves added to them are not affected by Allow individual
staves of multi-staff instruments to be hidden, even if some of their staves are empty.

●

Systems containing divisi changes are always shown, even if their staves are empty.

●

You cannot hide one staff of multi-staff instruments if you have chosen to show chord
symbols between the staves, which you can do in the Position section of the Chord Symbols
page in Engrave > Engraving Options.

RELATED LINKS
Extra staves on page 1160
Changing the default staff/system spacing on page 439
Per-layout vertical spacing options on page 456

Inserting pages
You can insert empty pages or pages that use a different master page into each layout in your
project, for example, if you want to add a title page.
PROCEDURE
1.

In the Pages panel, click Insert Pages in the Pages section action bar to open the Insert
Pages dialog.
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2.

Enter the number of pages you want to insert into the Number of pages to insert field.

3.

Select where you want to insert pages. For example, to insert pages after page 8, select
After page and enter 8.

4.

Optional: Select the master page that you want to assign to the inserted pages from the Use
master page menu.

5.

Click OK to save your changes and close the dialog.

RESULT
The number of pages specified are added at the selected position. They are shown in the Pages
panel with a colored triangle in their top left corner. If you did not assign a master page to them,
they are empty.
Any existing page format changes on subsequent pages in the layout move accordingly. For
example, if you had a flow heading change on page 2 and inserted a single page at the start of
the layout, the flow heading change is now on page 3.
AFTER COMPLETING THIS TASK
If you want to add information to empty pages, you can edit them or assign a master page to
them, for example, if you have created a title page master page that you want to use in all the
parts in your project.
RELATED LINKS
Page format changes on page 372
Assigning master pages to pages on page 377
Frames on page 386

Deleting pages
You can delete empty pages and any extra pages you have added to layouts.
Dorico Pro automatically changes the number of pages in each layout to accommodate the flows
assigned to the layout. If you want to delete pages because you do not want to show certain
flows, you can instead remove the flows from the layout.
You only need to delete pages manually if you inserted them as a blank page or made an
override to a page in a layout that is no longer required and now appears blank. For example, an
override on the final page in a layout prevents that page and all previous pages being
automatically deleted if the layout becomes shorter.
PROCEDURE
1.

In the music area, open the layout from which you want to delete pages.

2.

In the Pages section of the Pages panel, Ctrl/Cmd -click the pages you want to delete.
NOTE
You can only delete pages that are considered master page overrides.

3.

Delete the selected pages by removing all their master page overrides.
●

If any pages in your selection have colored triangles in their top left corner, click
Remove Overrides in the Pages section action bar.

●

If any pages in your selection have colored triangles in their bottom right corner, rightclick a page and choose Remove Page Number Change(s) from the context menu.
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●

If any pages in your selection have colored markings on their top/top and left edges,
right-click a page and choose Remove Master Page Change(s) from the context menu.

●

If any pages in your selection have colored markings on their bottom/bottom and right
edges, right-click a page and choose Remove Flow Heading Change(s) from the
context menu.

RESULT
Once you have removed all overrides from all the pages you want to delete, they are deleted if
they are empty. If they are not empty, removing all their overrides reverts them back to following
their default master page.
RELATED LINKS
Page format changes on page 372
Master pages on page 361
Changing the flows assigned to layouts on page 136

Starting layouts on left-hand pages
By default, all layouts start on a right-hand page, as convention dictates that odd numbered
pages are always on the right-hand page. However, you can set individual layouts to start on a
left-hand page, for example, to facilitate page turns better in that layout.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts you want to start on a left-hand page.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Page Numbers section, change the value for Initial page number to an even
number.

5.

Click Apply, then Close.

RESULT
The first page in the selected layouts is shown on a left-hand page when the initial page number
is even.

Allowing/Disallowing multiple flows on the same page
You can allow/disallow new flows to be shown on the same page as previous flows if there is
space, for example, to reduce the number of pages required for parts in works with multiple
movements. By default, new flows are allowed on the same page in part layouts and are not
allowed in full score layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to allow multiple flows to be shown
on each page.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.
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3.

Click Page Setup in the page list.

4.

In the Flows section, choose one of the following options for New flows:

5.

●

Always start new page

●

Allow on existing page

Click Apply, then Close.

RESULT
Always start new page ensures flows in the selected layouts always begin at the start of the
next page after the end of the previous flow.
Allow on existing page allows flows in the selected layouts to continue immediately after each
other, including within the same music frame if there is sufficient space. Flow headings are
automatically shown above the start of flows if you have chosen to show flow headings in the
selected layouts.
NOTE
Flows are not automatically split into separate music frames. You must insert frame breaks
manually to divide flows into separate music frames if required.

RELATED LINKS
Text tokens on page 396
Inputting frames on page 386
Casting off on page 451
Changing the flows assigned to layouts on page 136
Changing the players assigned to flows on page 134
Hiding/Showing information in running headers above flow headings on page 447

Changing when the First master page is used
You can change the circumstances when the First master page is used in each layout
independently, for example, if you want to use it for the start of every flow in the full score but
only want to use it for the first flow in part layouts, even when subsequent flows start at the top
of the page.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change when the First master
page is used.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Flows section, choose one of the following options for Use ‘First’ master page:

5.

●

Never

●

First flow only

●

Any flow starting at top of page

Click Apply, then Close.
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RESULT
●

Choosing Never means the First master page is not used for any page in the selected
layouts.

●

Choosing First flow only means the First master page is used for the first page in the layout
but no other pages, even if some subsequent flows start at the top of a page.

●

Choosing Any flow starting at top of page means the First master page is used for all
pages in the layout that begin with the start of a flow.

RELATED LINKS
Layout Options dialog on page 104

Hiding/Showing flow headings
You can hide/show flow headings in each layout independently, for example, if your project only
contains a single flow and you only want to show the project title. You can also hide the heading
for the first flow but show flow headings for subsequent flows.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show flow headings.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Flows section, choose one of the following options for Show flow headings:

5.

●

Never

●

Not for first flow

●

For all flows

Click Apply, then Close.

RESULT
Flow headings are shown above the first system in each flow in the selected layouts when you
choose For all flows, hidden when you choose Never, and hidden above the first system in the
first flow but shown above all other flows when you choose Not for first flow.
They are automatically positioned above each flow and below the preceding flow according to
the margins set for each layout.
RELATED LINKS
Flow headings on page 381
Customizing flow headings on page 383
Allowing/Disallowing multiple flows on the same page on page 443
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Changing the margins above/below flow headings
You can change the margins both above and below flow headings, which control the gap
between the preceding flow and the flow heading, and the gap between the flow heading and
the start of the next flow.
PREREQUISITE
Flow headings are shown in the layouts in which you want to change the margins above/below
flow headings.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the margins above/below
flow headings.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Flows section, change the values for Flow heading top margin and/or Flow heading
bottom margin.

5.

Click Apply, then Close.

RESULT
Changing the value for Flow heading top margin increases/decreases the gap between the top
of flow headings and the end of the preceding flow.
Changing the value for Flow heading bottom margin increases/decreases the gap between the
bottom of flow headings and the start of the next flow. For example, when the bottom margin is
set to 0, the bottom of the lowest frame in the flow heading aligns with the top staff line of the
first system in the flow below the flow heading.
NOTE
●

If you want to change the margins above/below an individual flow heading, you can do this
by inserting a flow heading change and changing the margins at the change.

●

If you want to move individual flow headings upwards/downwards, you can do this by
moving the system handle of the first system of the flow to which the flow headings apply.
You can also move the frames in flow headings individually, but this creates a master page
override, preventing Dorico Pro from updating the page if, for example, you later change the
master page format.

EXAMPLE

Flow heading with default margins above/below
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RELATED LINKS
Flow headings on page 381
Customizing flow headings on page 383
Inserting flow heading changes on page 378
Moving individual staves/systems vertically on page 458
Page format changes on page 372

Hiding/Showing information in running headers above flow
headings
You can hide/show flow titles, page numbers, and flow page numbers separately when they
appear above flow headings at the top of a new page in each layout independently. Hiding such
information in running headers is a custom in publishing.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show information in running
headers above flow headings.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Flows section, choose one of the following options for Flow title in header:

5.

6.

7.

●

Show above flow heading

●

Hide above flow heading

Choose one of the following options for Page number in header:
●

Show above flow heading

●

Hide above flow heading

Choose one of the following options for Flow page number in header:
●

Show above flow heading

●

Hide above flow heading

Click Apply, then Close.

RESULT
The corresponding information is hidden/shown when they appear above flow headings at the
top of the page.
NOTE
In order to hide running header information, the top of the music frame containing the flow
heading frame must be lower than the top of text frames containing the corresponding
information. If the top of the music frame is the same height as a running header text frame, any
corresponding information in the text frame is shown, regardless of your setting.

RELATED LINKS
Frames on page 386
Master pages on page 361
Editing running headers in master pages on page 823
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Changing the default music frame margins
You can change the default margins in all music frames in each layout independently. For
example, you might want more padding at the top of music frames in part layouts containing lots
of notes above the staff.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts whose music frame margins you want to change.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Music Frame Margins section, change the values for Top and/or Bottom.

5.

Click Apply, then Close.

RESULT
The margins within all music frames in the selected layouts are changed.
RELATED LINKS
Changing the default staff/system spacing on page 439

Changing the padding in music frames individually
You can change the padding at the top/bottom of individual music frames, independently of your
setting for music frame margins for the layout.
PREREQUISITE
Frames is selected in the Engrave toolbox.
PROCEDURE
1.

Select the music frames whose padding you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Music group:

3.

●

Top padding

●

Bottom padding

Change the padding by changing the values in the value fields.
For example, entering 0 for Top padding aligns the top staff line of the top staff in the frame
with the top of the music frame.

RESULT
The padding at the top/bottom of the selected music frames is changed. This only applies to the
layout currently open in the music area.
Deactivating the properties returns the selected music frames to your settings for music frame
margins for the layout.
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Changing the horizontal justification of final systems
You can change whether the final systems of flows always fill the width of frames or only do so
above a certain fullness threshold in each layout independently. By default in Dorico Pro, the final
systems of flows only justify to the full width of the frame when they are more than half full.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the justification of the
final systems in flows.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Note Spacing in the page list.

4.

Change the justification of final systems in flows in one of the following ways:

5.

●

If you always want the final systems in flows to justify fully, deactivate Only justify final
system in flow when more than [n]% full.

●

If you want to change the minimum fullness of final systems before they justify, change
the value for Only justify final system in flow when more than [n]% full.

Click Apply, then Close.

RESULT
The automatic justification of the final systems in flows in the selected layouts is changed.
TIP
You can also change the width of individual systems independently of your default settings by
changing their start/end positions.

RELATED LINKS
Changing the start/end position of systems on page 433
Changing the first system indent on page 1175
Fixing the number of bars per system on page 451

Enabling/Disabling condensing
You can enable/disable condensing in each layout independently. For example, in a large-scale
work with orchestra and chorus, you might want to condense vocal staves in the full score but
show uncondensed vocal staves in a custom vocal score.
IMPORTANT
Enabling condensing in any layout in a project can cause Dorico Pro to operate more slowly, due
to the large number of calculations involved. Therefore, we recommend only enabling
condensing after you have finished the majority of the required work, such as inputting notes
and notations or adding flows.
PREREQUISITE
You have input the notes and notations you want for each instrument onto their separate staves.
If you have input the music for multiple parts onto the same staff, you can explode it.

449
Dorico Pro 3.1.10

Page formatting
Enabling/Disabling condensing

PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to enable/disable condensing.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Condensing section, activate/deactivate Enable condensing.

5.

Click Apply, then Close.

RESULT
Condensing is enabled in the selected layouts when the checkbox is activated, and disabled when
the checkbox is deactivated.
NOTE
●

In Write mode, you cannot select anything on condensed staves. In Engrave mode, you can
select notes and items on condensed staves but you can only edit them graphically.

●

Condensed music often requires different rhythmic spacing than uncondensed music, for
example, to accommodate the width of notes that are a small interval apart. Therefore,
enabling condensing can cause the casting off in the layout to change.

●

Condensing is never enabled in galley view. If you want to see all staves separately without
disabling condensing in the current layout, you can switch to galley view.

●

You can also enable/disable condensing in the current layout by choosing Edit >
Condensing. You can also assign a key command to this on the Key Commands page in
Preferences.

AFTER COMPLETING THIS TASK
●

You can create custom condensing groups for each layout to control which staves condense
together. You can also include/exclude individual condensing groups.

●

If you want more control over the condensing result, you can change condensing from
selected rhythmic positions manually.

RELATED LINKS
Condensing on page 470
Creating custom condensing groups on page 479
Including/Excluding condensing groups on page 479
Changing condensing options from rhythmic positions on page 480
Key Commands page in the Preferences dialog on page 63
Switching to galley/page view on page 60
Note input on page 167
Notations input on page 210
Exploding music onto multiple staves on page 340
Inputting notes and notations onto multiple staves on page 182
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Casting off
“Casting off” is the term used to encompass fixing the layout of pages of music, such as setting
the number of systems per page. In Dorico Pro, you can fix both the number of bars per system
and the number of systems per music frame in each layout independently.
RELATED LINKS
Per-layout vertical spacing options on page 456
Splitting multi-bar rests on page 1116

Fixing the number of bars per system
You can define a fixed number of bars you want included in each system in each layout in your
project.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to fix the number of bars per
system.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Casting Off section, activate Fixed number of bars per system.

5.

Change the number of bars you want in each system by changing the value in the value field.

6.

Click Apply, then Close.

RESULT
The number of bars automatically contained in each system in the selected layouts is changed. If
any of the layouts contain two-bar or four-bar repeat regions, Dorico Pro automatically adjusts
casting off to ensure phrases are not split across systems.
RELATED LINKS
Bar repeats on page 1086
Inserting system breaks on page 466
Inserting frame breaks on page 463
Changing the horizontal justification of final systems on page 449

Fixing the number of systems per frame
You can define a fixed number of systems you want included in each music frame in each layout
in your project. Because the default master pages have a single music frame per page, fixing the
number of systems per frame usually fixes the number of systems per page.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to fix the number of systems per
frame.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.
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4.

In the Casting Off section, activate Fixed number of systems per frame.

5.

Change the number of systems you want in each frame by changing the value in the value
field.

6.

Activate/Deactivate Scale number of systems by frame height.

7.

Click Apply, then Close.

RESULT
The number of systems automatically contained in each music frame in the selected layouts is
changed.
If you activated Scale number of systems by frame height, the number of systems contained in
each frame is adjusted according to the size of the music frame.

Staff size
Staff size refers to the distance between the top and bottom lines of staves, and can be
expressed as a point size or in another supported unit of measurement, such as millimeters. For
individual staves, you can use a scale size of the default staff size in the layout. The most
appropriate staff size depends on the intended purpose of the layout.
For example, full orchestral scores that are quite dense need a much smaller staff size than
individual parts, which require large enough notes so that performers can read them easily.
Staves can overlap and the music can become illegible if the staff size is too large in dense
scores.
In Dorico Pro, you can set the staff size using the rastral size and the space size, depending on
which measurement is more appropriate for the selected layouts.
●

Rastral size is the size of the full staff, measured from the bottom line to the top line.

●

Space size is the distance between two staff lines.

When changing the staff size of each layout in Layout Options, we recommend that you use one
of the preset rastral sizes, as these are based on traditional and generally accepted staff sizes
that are all widely used in music engraving.
NOTE
The size of staves can affect the size of system objects.

RELATED LINKS
System objects on page 1172
Changing your preferred unit of measurement on page 62
Changing the default staff size on page 438

Changing the staff size from system/frame breaks
You can change the staff size of all staves from the rhythmic position of system/frame breaks
onwards in layouts. For example, you can have smaller staves only on pages with more staves,
and larger staves on other pages with fewer staves.
NOTE
If the size of system object font styles is set to Staff-relative, the staff size of the top staff in each
instrument family group affects the size of system objects if they are shown above that bracketed
group. Font styles that are set to Absolute are unaffected by staff size.
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PREREQUISITE
●

You have inserted system/frame breaks at the positions from which you want to change the
staff size.

●

Signposts are shown for system/frame breaks.

PROCEDURE
1.

In Engrave mode, select the system/frame break signposts from which you want to change
the staff size.

2.

In the Properties panel, activate Space size in the Format group.

3.

Change the value in the value field.

RESULT
The staff size of all staves in the layout is changed until the next change in staff size or the end of
the flow, whichever comes first. Increasing Space size increases the staff size. Decreasing the
value decreases the staff size.
By default, the next flow in your project uses your project-wide staff size for the current layout.
RELATED LINKS
Changing the default staff size on page 438
Inserting system breaks on page 466
Inserting frame breaks on page 463
Hiding/Showing system break signposts on page 467
Hiding/Showing frame break signposts on page 465
Edit Font Styles dialog on page 407
Brackets and braces on page 683
System objects on page 1172

Changing the size of individual staves
You can change the size of individual staves in each flow independently of other staves and your
layout settings. For example, piano accompaniment parts often include the solo line of the
instrument the piano is accompanying on a smaller staff.

A piano part with smaller viola staff above

You can change the size of individual staves to a set scale size, expressed as a percentage of the
normal staff size in the layout, or set a custom scale.

453
Dorico Pro 3.1.10

Page formatting
Staff size
TIP
If you want to change the staff size to represent an alternative version of a passage, you can
instead add an ossia staff, which you can show for specific regions.

PROCEDURE
1.

Select an item on the staff whose size you want to change. You can do this in Write mode
and Engrave mode.
NOTE
You can only change the size of a single staff at a time.

2.

Choose Edit > Staff Size > [Staff size]. You can also choose this option from the context
menu.

3.

Optional: If you choose Custom Staff Size, you must set the staff size using the Custom
Staff Size dialog that opens.

RESULT
The size of the selected staff is changed in the current flow. This also works in combination with
the other ways of changing the staff size, such as changing the size of all staves in the layout or
changing the size of staves from a specific point.
NOTE
●

Changing the staff size of individual staves affects the staff size of all instruments held by
that player.

●

Changing the staff size of individual staves affects its size for the whole flow.

●

If the size of system object font styles is set to Staff-relative, the staff size of the top staff in
each instrument family group affects the size of system objects if they are shown above that
bracketed group. Font styles that are set to Absolute are unaffected by staff size.

RELATED LINKS
Changing the staff size from system/frame breaks on page 452
Edit Font Styles dialog on page 407
Brackets and braces on page 683
System objects on page 1172
Adding ossia staves on page 1165

Custom Staff Size dialog
The Custom Staff Size dialog allows you to change the size of individual staves by a custom scale
factor.
●

You can open the Custom Staff Size dialog by selecting an item in the music area and
choosing Edit > Staff Size > Custom Staff Size.
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Custom Staff Size dialog

The Custom Staff Size dialog contains the following options:
Default staff size
Displays the default size of staves in the current layout. This size is set on the Page
Setup page in Setup > Layout Options.
The default staff size is expressed as both a point size and in your preferred unit of
measurement.
Rastral size
Allows you to select the rastral size on which you want to base your custom staff size.
Scale factor
Sets the custom staff size, expressed as a percentage of the selected rastral size.
New staff size
Displays the new custom staff size for the selected staff as a result of the changes you
have made in the dialog.
The new staff size is expressed as both a point size and in your preferred unit of
measurement.
RELATED LINKS
Changing your preferred unit of measurement on page 62

Staff spacing
The vertical positioning of staves and systems within frames is known as staff spacing. Staff
spacing calculations consider the height of staves and the necessary gaps between staves and
systems.
You can change staff spacing in your project at different levels:
●

Change the default staff spacing in each layout in Layout Options.

●

Change the staff spacing between individual staves.

TIP
We recommend adjusting the default staff spacing values and/or changing the staff size in
layouts before moving individual staves, as in most cases Dorico Pro produces suitable results
without the need to move individual staves.

RELATED LINKS
Staff size on page 452
Staves on page 1158
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Engrave toolbox on page 351
Changing the default staff/system spacing on page 439
Changing the staff spacing in galley view on page 458
Changing the default staff size on page 438
Note spacing on page 425

Per-layout vertical spacing options
Dorico Pro provides multiple options that you can use to control the default vertical spacing and
justification of staves and systems in each layout.
●

You can access per-layout vertical spacing options by choosing Setup > Layout Options and
clicking Vertical Spacing in the page list.

The Vertical Spacing page contains the following sections and options:
Ideal Gaps
Contains multiple scenarios that allow you to set the gap you want Dorico Pro to allow
between staves and systems in the corresponding context, including the default
scaling of these gaps in galley view, as Dorico Pro does not automatically avoid
collisions between staves and items in galley view. The options are accompanied by
diagrams to help you visualize the contexts to which each option applies.
We recommend setting the ideal gaps to the minimum value acceptable to you
because Dorico Pro never reduces the gap between staves to less than your set values.
Setting smaller values gives Dorico Pro greater flexibility when determining staff
spacing, particularly in very full frames, such as reducing the space between staves
with no dynamics to allow more space between staves with dynamics. Similarly, we
recommend setting vertical spacing options after you have finished inputting notes
and items, as this allows you to consider the entire project when setting these options.
Depending on the context, the options are affected by automatic vertical justification in
different ways:
●

Staff to staff, Staff group to staff, Staff to staff group, Staff group to staff
group, Inter-system gap, and Timecode staff to staff
These gaps do not apply in frames that are automatically justified.

●

Braced staff to braced staff and Ossia staff to staff
These gaps always apply, including in frames that are automatically justified,
because braced and ossia staves are never justified. This includes extra staves.

NOTE
●

Divisi staves are vertically justified when they use the Staff to staff gap. When they
use the Braced staff to braced staff gap, the staves in each divisi section use only
the gap set for braced staves and are not vertically justified.

●

If the staves in a layout are very close together, just decreasing the staff size might
be sufficient to produce good results.

●

When calculating the number of systems that can fit in each frame in a layout,
Dorico Pro considers the height of staves, the minimum gaps between staves, the
maximum distances between very high/low notes and staves, and other items that
require vertical space, such as pedal lines and tempo marks. However, this
calculation happens before horizontal spacing is finalized, which can result in
either more or fewer systems being allocated to frames than ideally fit. In such
circumstances, you can use fixed casting off settings and system/frame breaks to
change which systems appear in frames.
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Minimum Gaps
Contains options for the minimum gaps you want Dorico Pro to allow for items in
addition to the staff spacing gaps.
●

Automatically resolve collisions between adjacent staves and systems: When
activated, Dorico Pro automatically allows extra space between staves and systems
to avoid collisions. When deactivated, Dorico Pro only uses your set gaps for
vertical spacing, which produces evenly-spaced staves and systems but with the
possibility of collisions between items.

●

Minimum inter-staff gap with content: Allows you to set the extra space you
want to allow between staves when items are present.

●

Minimum inter-system gap with content: Allows you to set the extra space you
want to allow between systems when items are present.

Vertical Justification
Contains options that allow you to control the frame fullness thresholds above which
you want staves and/or systems to justify vertically automatically.
●

Justify distance between staves and systems when frame is at least [n]% full:
When frames are filled above this threshold, the staves and systems they contain
are all automatically vertically justified, meaning they are evenly distributed to fill
the height of the frame. Frames filled below this threshold are not automatically
justified, instead staves follow your ideal gap settings. This can leave gaps between
the bottom staff/system and the bottom of the frame.

●

Justify distance only between systems when frame is at least [n]% full: When
frames are filled above this threshold, only the distance between systems in the
frame is justified. Staves follow your per-layout ideal gap settings. This helps keep
a clear distance between systems on very full pages.

●

Justify staves when frame with single system is above this threshold: When
activated, all the staves in a single system taller than the set threshold are
vertically justified, which distributes them evenly to fill the height of the frame.

Hide Empty Staves
Contains options allowing you to control when and which empty staves are hidden in
the layout.
●

Hide empty staves: Allows you to control when empty staves are hidden. For
example, it is a common practice to show all staves in the first system even if some
are empty, but this is not always required.

●

Allow individual staves of multi-staff instruments to be hidden: Allows you to
control whether individual empty staves belonging to multi-staff instruments can
be hidden independently or all multi-staff instrument staves must always be
shown.

●

Players excluded from Hide Empty Staves: Allows you to identify specific players
whose staves you always want to show, even if their staff is empty on systems
where you have hidden empty staves.

RELATED LINKS
Page formatting on page 435
Casting off on page 451
Staff size on page 452
Brackets and braces on page 683
Staves on page 1158
Ossia staves on page 1164
Tablature on page 1188
Changing the vertical justification of staves/systems on page 439
Changing the vertical position of markers on page 1061
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Changing the vertical position of timecodes on page 1067

Changing the staff spacing in galley view
You can change the vertical space between staves in galley view in each layout independently,
expressed as a percentage of the set ideal gaps. Increasing the gaps between staves in layouts
with very high/low notes can be useful because Dorico Pro does not perform automatic collision
avoidance in galley view.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the staff spacing in galley
view.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Vertical Spacing in the page list.

4.

In the Ideal Gaps section, change the value for In galley view, expand ideal staff gaps to.

5.

Click Apply, then Close.

Moving individual staves/systems vertically
You can change the spacing of individual staves, including ossia staves, by changing the vertical
position of individual staves and systems independently of your project-wide settings.
When Staff Spacing is activated in the Engrave toolbox, the following are shown:
●

System spacing handles: Large square handles on the top left corner of the top staff in each
system. System spacing handles control the vertical position of whole systems.

●

Staff spacing handles: Small square staff handles on the bottom left corner of each staff.
Staff spacing handles control the vertical position of individual staves.

●

Gap measurements: Lines and highlighted numbers indicating the distances between staves
and systems, shown using your preferred unit of measurement.

System spacing handle, staff spacing handle, and gap measurement in Engrave mode when Staff Spacing is
activated

IMPORTANT
We recommend that you add extra pages and finish laying out your pages before moving
individual staves, as individual staff spacing changes are automatically deleted if the frame in
which they occur changes. For example, if you move staves individually and then add a blank
page at the start of the layout, all individual staff spacing changes in the layout are deleted.

PROCEDURE
1.

In the Engrave toolbox, activate Staff Spacing.
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2.

Select one of the following on each staff/system you want to move vertically:
●

Staff spacing handle

●

System spacing handle

NOTE

3.

●

You can switch between having a staff or system spacing handle selected by pressing
Tab .

●

When using the mouse, you can only move one staff/system at a time.

Move the selected staves/systems in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag a single staff/system spacing handle upwards/downwards.

RESULT
The vertical position of the selected staves/systems is changed. The color of the handles changes
to indicate that you have moved them. When you move system handles, both the square handle
and the highlighted strip at the top of the system change color.
NOTE
●

When Staff Spacing is activated, you cannot select or edit anything other than staff/system
spacing handles. To resume normal selection and editing, click Graphic Editing in the
Engrave toolbox or return to Write mode.

●

You can also click the gap measurement numbers and change the value using any of the
supported units of measurement, which are points, millimeters, centimeters, and inches.
You can change your preferred unit of measurement to be used throughout Dorico Pro on
the General page in Preferences.
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EXAMPLE

Staff spacing handles at their default positions

The second staff has been moved upwards

AFTER COMPLETING THIS TASK
You can copy manual changes you have made to the staff spacing on individual pages to other
pages in the layout.
RELATED LINKS
Moving multiple systems simultaneously on page 461
Copying staff spacing changes to other pages on page 462
Changing your preferred unit of measurement on page 62

Frame fullness indicator
The frame fullness indicator is a highlighted region on the bottom right of frames that is shown
when Staff Spacing is activated. The frame fullness indicator uses colors and percentages to
indicate the fullness of the frame, which in most cases represents a full page.
The following colors are used in the frame fullness indicator:
●

Green: the frame is comfortably full. Staves and systems have enough vertical space to be
legible but are not too far apart. Frames that are 60-100% full are considered comfortably
full.

●

Red: the frame is over-full, meaning staves and systems might appear squashed with not
enough vertical space between them. Frames that are more than 100% full are considered
over-full.

The fullness of frames is also expressed using a percentage. The percentage indicated is
calculated by dividing the number of spaces occupied in the frame by the total number of
available spaces in the frame, which is measured using the vertical distance between the top and
bottom music frame padding margins.
Frame comfortably full

Frame over-full

RELATED LINKS
Engrave toolbox on page 351
Per-layout vertical spacing options on page 456
Changing the default staff/system spacing on page 439
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System fullness indicator on page 431
Changing the default music frame margins on page 448

Removing individual changes to staff spacing
You can remove changes you have made to the staff/system spacing and reset staff/system
spacing handles to their original default positions.
PROCEDURE
1.

In the Engrave toolbox, activate Staff Spacing.

2.

Select the staff/system handles you want to reset to their original positions.

3.

Press Backspace or Delete .

RESULT
The selected staff/system handles are reset to their original positions.
TIP
You can also reset all staff spacing changes within selected systems, frames, or all staff spacing
changes in the layout by choosing one of the options in the Engrave > Staff Spacing menu.

Moving multiple systems simultaneously
You can move multiple systems at the same time so that the gaps between each system remain
equal. This is also known as “concertina dragging”.
IMPORTANT
We recommend that you add extra pages and finish laying out your pages before moving
individual staves. Individual staff spacing changes are automatically deleted if the frame in which
they occur changes.
NOTE
●

You can only move multiple systems closer together, you cannot use this method to move
them further apart.

●

You cannot follow these steps for staff spacing handles on tacets.

PROCEDURE
1.

In the Engrave toolbox, activate Staff Spacing.

2.

Select the system handle on the highest system you want to move.

3.

Alt/Opt -click and drag the system handle downwards.
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RESULT
All systems below the selected system, until the bottom of the music frame, are moved closer
together. The gaps between each system remain equal.
RELATED LINKS
Staff spacing on page 455
Tacets on page 467

Copying staff spacing changes to other pages
You can copy manual staff spacing changes you have made on individual pages to other pages in
the layout.
NOTE
In order to copy staff spacing changes, destination pages must have the same number of staves
per system and the same number of systems per frame as the source page.

PROCEDURE
1.

In the music area, open the layout in which you want to copy staff spacing from one page to
other pages.

2.

Choose Engrave > Staff Spacing > Copy Staff Spacing to open the Copy Staff Spacing
dialog.

3.

Change the page whose staff spacing you want to copy by changing the value for From
page.

4.

Change the first page to which you want to copy staff spacing by changing the value for To
page start.

5.

Change the last page in the range to which you want to copy staff spacing by changing the
value for To page end.

6.

Click OK to save your changes and close the dialog.

RELATED LINKS
Moving individual staves/systems vertically on page 458

Copy Staff Spacing dialog
In the Copy Staff Spacing dialog, you can choose pages whose individual staff spacing changes
you want to copy. You can specify the pages in the layout to which you want to copy the staff
spacing changes.
●

You can open the Copy Staff Spacing dialog in Engrave mode by choosing Engrave > Staff
Spacing > Copy Staff Spacing.
TIP
You can assign a key command for opening the Copy Staff Spacing dialog on the Key
Commands page in Preferences.

The Copy Staff Spacing dialog contains the following options:
From page
Allows you to change the page whose staff spacing you want to copy by specifying the
page number.
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To page start
Allows you to set the first page in the layout to which staff spacing changes are copied.
To page end
Allows you to set the last page in the layout to which staff spacing changes are copied.
For example, if you wanted to copy staff spacing changes you made on the first page to the next
three pages, meaning pages two, three, and four, but not to page five and onwards, you would
set From page to 1, To page start to 2, and To page end to 4.
Previews show the displayed page number beside each value field, so that if you have changed
the displayed page number of pages within the layout you can still identify the page to which you
are copying staff spacing changes.
RELATED LINKS
Key Commands page in the Preferences dialog on page 63

Frame breaks
In Dorico Pro, you can use frame breaks to push musical material into the next frame, which is
usually on the next page, meaning you can use frame breaks to create page breaks. For example,
you can use frame breaks to insert page turns at specific positions in part layouts.
Frame breaks are indicated by signposts, which you can hide/show at any time. They are also
layout-specific, meaning each layout can have frame breaks at different rhythmic positions.
NOTE
●

Frame breaks at the start of frames that were created using Make into Frame have Wait for
next frame break activated in the Format group of the Properties panel by default. When
this property is activated, Dorico Pro creates a frame containing all material between that
frame break and the next frame break. If you later delete subsequent frame breaks, this
creates very full frames with tightly spaced, or overlapping, systems. For example, if you
delete all subsequent frame breaks, all music until the end of the flow is forced into a single
frame.

●

You can also control the content of music frames by fixing the number of systems per music
frame in each layout.

RELATED LINKS
Per-layout vertical spacing options on page 456

Inserting frame breaks
You can insert frame breaks at any rhythmic position, for example, to create page turns at
appropriate places in the current layout.
PROCEDURE
1.

Select a note or item at the rhythmic position where you want to insert a frame break.
For example, if you select a clef, the clef is placed at the end of the frame and all following
notes are moved to the start of the next music frame.

2.

Press Shift-F .

RESULT
A frame break is inserted immediately before the rhythmic position of the earliest selected item.
All notations after the frame break are moved to the next music frame.
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NOTE
If you insert a frame break in the middle of a phrase in a two-bar or four-bar repeat region,
Dorico Pro does not automatically move the frame break to before/after the phrase, causing it to
be split across the frame break.

RELATED LINKS
Engrave toolbox on page 351

Making selections into frames
You can make frames that contain all musical material between two selected rhythmic positions.
PROCEDURE
1.

Select an item at the rhythmic position that you want to be the start of the frame.
NOTE
We recommend that you select noteheads or barlines. Selecting other items, such as slurs,
can cause frame breaks to be inserted earlier/later than you might have intended.

2.

Ctrl/Cmd -click one of the following:
●

A notehead that you want to be at the end of the frame

●

An item that you want to be at the start of the next frame

3.

In the Engrave toolbox, click Graphic Editing to show the Formatting panel.

4.

In the Format Music Frames section, click Make into Frame.

RESULT
A fixed frame is created by inserting frame breaks at the start/end of your selection. The frame
contains all musical material between the two selected items.
●

If you selected items, such as barlines or slurs, the beginning your first selected item is
positioned at the start of the frame and the end of your last selected item is positioned at the
start of the next frame.

●

If you selected noteheads, the last selected notehead is also included in the frame, rather
than being positioned at the start of the next frame.

●

If you selected ties, all musical material between the first and last notes tie chains is included
in the frame, regardless of where in the tie chains you made selections.

NOTE
The frame break inserted at the start of the selection has Wait for next frame break activated in
the Format group of the Properties panel by default. Because this property tells Dorico Pro to
include all music in the frame until the next frame break, if you later delete subsequent frame
breaks, this can create very full frames with tightly spaced, or overlapping, systems.
Deactivating Wait for next frame break allows Dorico Pro to cast off subsequent music as
normal.

RELATED LINKS
Engrave toolbox on page 351
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Hiding/Showing frame break signposts
You can hide/show frame break signposts at any time.
PROCEDURE
●

Choose View > Signposts > Frame Breaks.

RESULT
Frame break signposts are shown when a tick appears beside Frame Breaks in the menu, and
hidden when no tick appears.

Deleting frame breaks
You can delete frame breaks after you have inserted them.
PREREQUISITE
Frame break signposts are shown.
PROCEDURE
1.

Select the frame break signposts of the frame breaks you want to delete.

2.

Press Backspace or Delete .

System breaks
System breaks are where musical material reaches the right page margin and must continue on
a new system, usually below the previous system on the same page or on a new page. Dorico Pro
automatically arranges music across systems so that notes are correctly spaced and legible, but
you can also control system breaks manually.
System breaks are indicated by signposts, which you can hide/show at any time. They are also
layout-specific, meaning each layout can have system breaks at different rhythmic positions.
NOTE
●

System breaks at the start of systems that were created using Make into System have Wait
for next system break activated in the Format group of the Properties panel by default.
When this property is activated, Dorico Pro creates a system containing all material between
that system break and the next system break or the end of the flow, whichever comes first. If
you later delete subsequent system breaks, this creates very full, tightly spaced systems. For
example, if you delete all subsequent system breaks, all music until the end of the flow is
forced into a single system.

●

You can also control the content of systems by fixing the number of bars per system in each
layout.

RELATED LINKS
Fixing the number of bars per system on page 451
Per-layout vertical spacing options on page 456
Splitting multi-bar rests on page 1116
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Inserting system breaks
You can insert system breaks at any rhythmic position.
PREREQUISITE
If you want to insert system breaks in the middle of multi-bar rests, you have either hidden multibar rests in the layout or split multi-bar rests at the required positions.
PROCEDURE
1.

Select a note or item at the rhythmic position where you want to insert a system break.
For example, if you select a clef, the clef is placed at the end of the system, and the notes are
moved to the start of the next system.

2.

Press Shift-S .

RESULT
A system break is inserted immediately before the rhythmic position of the earliest selected item.
All notations after the system break are moved to the next system.
NOTE
If you insert a system break in the middle of a phrase in a two-bar or four-bar repeat region,
Dorico Pro does not automatically move the system break to before/after the phrase, causing it
to be split across the system break.

RELATED LINKS
Engrave toolbox on page 351
Hiding/Showing multi-bar rests on page 1113
Splitting multi-bar rests on page 1116

Making selections into systems
You can make systems that contain all musical material between two selected rhythmic positions.
PROCEDURE
1.

Select an item at the rhythmic position that you want to be the start of the system.
NOTE
We recommend that you select noteheads or barlines. Selecting other items, such as slurs,
can cause system breaks to be inserted earlier/later than you might have intended.

2.

Ctrl/Cmd -click one of the following:
●

A notehead that you want to be at the end of the system

●

An item that you want to be at the start of the next system

3.

In the Engrave toolbox, click Graphic Editing to show the Formatting panel.

4.

In the Format Systems section, click Make into System.

RESULT
A fixed system is created by inserting system breaks at the start/end of your selection. The
system contains all musical material between the two selected items.
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●

If you selected items, such as barlines or slurs, the start of your first selected item is
positioned at the start of the system and the end of your last selected item is positioned at
the start of the next system.

●

If you selected noteheads, the last selected notehead is also included in the system, rather
than being positioned at the start of the next system.

●

If you selected ties, all musical material between the first and last notes tie chains is included
in the system, regardless of where in the tie chains you made selections.

NOTE
The system break inserted at the start of the selection has Wait for next system break activated
in the Format group of the Properties panel by default. Because this property tells Dorico Pro to
include all music in the system until the next system break or the end of the flow, if you later
delete subsequent system breaks, this can create very full, tightly spaced systems.
Deactivating Wait for next system break allows Dorico Pro to cast off subsequent music as
normal.

RELATED LINKS
Engrave toolbox on page 351

Hiding/Showing system break signposts
You can hide/show system break signposts at any time.
PROCEDURE
●

Choose View > Signposts > System Breaks.

RESULT
System break signposts are shown when a tick appears beside System Breaks in the menu, and
hidden when no tick appears.

Deleting system breaks
You can delete system breaks after you have inserted them.
PREREQUISITE
System break signposts are shown.
PROCEDURE
1.

Select the system break signposts of the system breaks you want to delete.

2.

Press Backspace or Delete .

Tacets
Tacet is the indication used to show that a player does not play anything in an entire flow, which
might be a movement in a symphony or cue in a film score. In Dorico Pro, you can generate
tacets automatically.
Dorico Pro shows tacets for flows in part layouts when the following conditions are met:
●

You have removed the player from the flows in which they do not play.

●

The flows are assigned to the part layout.
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●

The flows are assigned to the master page frame chain in the part layout.

●

You have chosen to show tacets in the part layout.

An extract of a part layout where the player is tacet in the second flow

In Engrave mode, tacets behave like systems, meaning they have their own staff spacing handle
when Staff Spacing is activated. This allows you to move individual tacets and their flow
headings upwards/downwards. You can also insert system and frame breaks at the start of
tacets.
NOTE
We do not recommend that you use Copy Staff Spacing and Lock Frame on pages where tacets
are the first or last system in frames. Because tacets do not contain any bars, Dorico Pro cannot
insert system or frame breaks at the ends of tacets in order to lock the frame contents.
You can change the text shown in tacets and the margin above/below them in each layout
independently.
You can further customize the project-wide appearance and design of tacets on the Tacets page
in Engrave > Engraving Options, and by formatting the Tacet paragraph style in Engrave >
Paragraph Styles.
RELATED LINKS
Changing the players assigned to flows on page 134
Assigning flows to frame chains on page 394
Allowing/Disallowing multiple flows on the same page on page 443
Staff spacing on page 455
Inserting system breaks on page 466
Inserting frame breaks on page 463
Paragraph Styles dialog on page 410
Engraving Options dialog on page 359
Flow headings on page 381
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Hiding/Showing tacets
You can hide/show tacets in each layout independently, for example, if you want to show empty
bars or multi-bar rests in some layouts to allow those players to add in notes on those staves
later.
PREREQUISITE
●

You have removed the player from the flows in which they do not play.

●

The flows are assigned to the part layout.

●

The flows are assigned to the master page frame chain in the part layout.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show tacets.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Tacets section, activate/deactivate Show tacet for flows where no players are
assigned.

5.

Click Apply, then Close.

RESULT
Tacets are shown in the selected layouts when Show tacet for flows where no players are
assigned is activated and the prerequisite criteria are also met.
When it is deactivated, any flows to which the player is not assigned do not appear in the layout.
When the player is assigned to those flows, all bars in the flow are shown in the part, split into
empty bars and multi-bar rests as appropriate for the flow.
TIP
If your project contains many short flows, which appear in part layouts as a single multi-bar rest
labeled “Tacet”, showing all the bars separately can help make the length of flows clearer. You
can do this by increasing the value for Minimum number of bars in flow to show ‘Tacet’ on the
Rests page in Engrave > Engraving Options.

RELATED LINKS
Tacets on page 467
Multi-bar rests on page 1112
Changing the players assigned to flows on page 134
Hiding/Showing multi-bar rests on page 1113

Editing tacet text
You can change the text shown in tacets in each layout independently.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts whose tacet text you want to edit.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.
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3.

Click Players in the page list.

4.

In the Tacets section, enter the text you want in the Tacet text field.

5.

Click Apply, then Close.

RESULT
The text shown in all tacets in the selected layouts is changed.
TIP
You can change the default padding to the right/left of tacets, show them with/without a border,
and change their border thickness project-wide on the Tacets page in Engrave > Engraving
Options.

Changing the margins above/below tacets
You can change the margins both above/below tacets in each layout independently, for example,
if you want smaller gaps between flow headings and tacets in some layouts to facilitate page
turns better.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the margins above/below
tacets.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Tacets section, change the values for Margin above tacet and/or Margin below
tacet.

5.

Click Apply, then Close.

RESULT
Changing the value for Margin above tacet increases/decreases the minimum gap between
tacets and whatever precedes them.
Changing the value for Margin below tacet increases/decreases the minimum gap between
tacets and whatever follows them.
TIP
You can change the default padding to the right/left of tacets, show them with/without a border,
and change their border thickness project-wide on the Tacets page in Engrave > Engraving
Options.

RELATED LINKS
Flow headings on page 381

Condensing
Condensing is the process of showing the music for multiple players on fewer staves than
normal, usually by allowing multiple instruments of the same type to share a staff, such as Flutes
1-2 or Horns 1-4. In Dorico Pro, this is an automatic process that allows you to show condensed
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staves in some layouts, such as full score layouts, and uncondensed staves in others, such as the
part layouts.
Condensing is most commonly used in large orchestral scores because the staff size can be
larger when there are fewer staves on a page, and larger staff sizes are easier for conductors to
read. In order to fit all the staves normally required for an orchestra on the paper used for
conductor scores, the staff size might be as small as 3.5 mm. For reference, the staff size in
instrumental parts is usually at least 7 mm in order to be legible.
Fitting the music for multiple players onto the same staff and maintaining clarity over which
notes are played by each player can be difficult. For example, if only a single, unlabeled note
appears on a condensed staff, it is unclear whether it must be played by one player or all players.
It is also important that staff labels accurately reflect the players on each condensed staff.

The woodwind section of an orchestral score, including some condensed and some uncondensed staves

The large number of complex calculations and considerations that are required to produce
condensed music has made this a traditionally difficult and time-consuming task, particularly as,
in other notation software applications, this has also required the manual duplication of music
and staves in order to produce separate instrumental parts from a condensed full score.
Because of how Dorico Pro handles players and layouts, you can have separate instrumental
parts and condensed full scores in the same project without any manual duplication required.
Staff labels on condensed staves automatically refer to all players on the staff, and player labels
indicate which notes belong to each player.
In order to ensure unambiguous results when condensing is enabled, in Dorico Pro you must
input the music for each player separately. Unlike inputting music onto condensed staves and
then exploding them as separate instrumental parts, this method ensures that Dorico Pro always
understands exactly how you want the music to be divided and therefore allows Dorico Pro to
condense even complicated music.
We recommend familiarizing yourself with the calculations and considerations that Dorico Pro
makes for condensing and the options available to you to customize your condensing results.
NOTE
●

In Write mode, you cannot select anything on condensed staves. In Engrave mode, you can
select notes and items on condensed staves but you can only edit them graphically.
Most graphical edits to condensed staves do not affect the source music, but some
properties do, such as slur and tie style properties.
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●

Condensing is never enabled in galley view, so you can switch to galley view to see all staves
separately. This does not disable condensing in the current layout.

IMPORTANT
Having condensing enabled in any layout in a project can cause Dorico Pro to operate more
slowly, due to the large number of calculations involved. Therefore, we recommend only
enabling condensing after you have finished the majority of the required work, such as inputting
notes and notations or adding flows.

RELATED LINKS
Enabling/Disabling condensing on page 449
Changing condensing options from rhythmic positions on page 480
Player labels on page 486
Staff labels on condensed staves on page 1156
Hiding/Showing condensed music colors on page 490
Switching to galley/page view on page 60
Divisi on page 1176

Per-flow notation options for condensing
You can find options to control condensing in each flow independently on the Condensing page
in Write > Notation Options.
The Condensing page provides the following options:
Whole-phrase unison approach
Allows you to choose how to present phrases that are completely in unison on
condensed staves.
●

Allow single-stem unison: Unison phrases appear as single noteheads with single
stems, and can represent any number of players.

●

Prevent single-stem unison: Unison phrases appear with separate noteheads and
stems for each player.

Mid-phrase unison approach
Allows you to choose how to present individual unison notes within phrases that are
not completely in unison.
●

Allow mid-phrase unisons: Mid-phrase unison notes appear with single stems.

●

Prevent mid-phrase unisons: Mid-phrase unison notes appear with separate
stems.

Pitch crossing approach
Pitch crossing happens when the pitch of notes in the up-stem voice is lower than in
the down-stem voice. This option allows you to choose whether players can still share a
staff if some of their pitches cross, or if you never want players to condense if their
phrases contain any crossed pitches.
●

Allow unlimited pitch crossing: Condensing is always allowed, regardless of pitch
crossing.

●

Limit pitch crossing: Condensing is only allowed in regions that contain the set
number of crossed pitches or fewer.

Maximum number of pitch crosses in region
Allows you to set the maximum number of pitches that can cross in each region and
still be condensed. This is set to 1 by default.

472
Dorico Pro 3.1.10

Page formatting
Condensing
Amalgamation approach for notes and chords
Allows you to choose whether or not you want to amalgamate notes and chords on
condensed staves into a single up-stem voice when players are sometimes in rhythmic
unison but have different rhythms at other times.
●

Allow amalgamation: Notes and chords are amalgamated into a single up-stem
voice when players are in rhythmic unison.

●

Prevent amalgamation: Notes and chords are never amalgamated and remain in
two voices, even when players are in rhythmic unison.

Amalgamation approach for slurs
Allows you to choose whether or not you want to amalgamate slurs when slurs of the
same durations exist in both voices at the same rhythmic position.
●

Allow amalgamation of slurs: Compatible slurs are amalgamated and appear as
a single slur for both voices.

●

Prevent amalgamation for slurs in down-stem voice: Slurs are shown for each
voice separately.

●

Prevent amalgamation for all slurs: Slurs are shown for each voice separately.
Any notes that were partly amalgamated into the up-stem voice are forced to
appear in the down-stem voice.

Amalgamation approach for playing techniques
Allows you to choose whether or not you want to amalgamate playing techniques
when the same technique exists in both voices at the same rhythmic position.
●

Allow amalgamation: A single playing technique is shown for both voices. It
appears either above or below the staff depending on the default placement for
the playing technique.

●

Prevent amalgamation: Playing techniques are shown both above and below the
staff.

Condensing for players inactive for some of the system
Allows you to choose how to condense and represent inactive players when they are
both active and inactive in the same system and other players in their condensing
group have notes.
●

Hide rests and label active player: Only the music for active players appears on
condensed staves with player labels for active players shown where rests are
hidden for inactive players.

●

Show rests and omit labels: Shows rests for inactive players on condensed staves
without additional player labels.

When hiding rests for inactive players
Allows you to choose specific circumstances in which to hide rests for inactive players.
Only applies when you have chosen Hide rests and label active player for
Condensing for players inactive for some of the system.
●

Hide rests only at the start or end of bars: Only rests whose ranges start or end
at barlines are hidden. This is a convention for some publishers and results in
more rests but fewer player labels.

●

Hide rests at any position: All rests are hidden. This results in fewer rests but
more player labels.

Minimum length of range of rests to allow hiding
Allows you to set the duration threshold of inactivity above which you want to hide
rests. It is a convention for some publishers to show rests that span short durations,
such as two beats between notes, but hide rests that span longer durations.
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Condensing for players inactive for the whole system
Allows you to choose how to condense and represent inactive players when they are
inactive throughout entire systems and other players in their condensing group have
notes.
●

Pair with active player: Shows inactive players on a condensed staff, alongside at
least one active player but in a different voice with rests shown as appropriate.

●

Include in staff label: Includes the player numbers of inactive players in staff
labels on condensed staves, but does not show rests for them. Only the music for
active players appears on condensed staves.

●

Do not condense: Inactive players are excluded from condensing in systems in
which they are inactive and instead appear on their own uncondensed staves.
These staves are considered empty and are included in your per-layout settings for
hiding empty staves.

NOTE
These options apply throughout each selected flow. However, you can override them from
selected rhythmic positions and for only selected condensing groups using condensing changes.

RELATED LINKS
Notation Options dialog on page 160
Hiding/Showing empty staves on page 441
Changing condensing options from rhythmic positions on page 480
Condensing Change dialog on page 481
Rests on page 1106

Condensing calculations and considerations
In order to produce clear and legible results, Dorico Pro considers a number of factors in its
condensing calculations, including the type of instruments and the rhythms and pitches of notes.
IMPORTANT
Having condensing enabled in any layout in a project can cause Dorico Pro to operate more
slowly, due to the large number of calculations involved. Therefore, we recommend only
enabling condensing after you have finished the majority of the required work, such as inputting
notes and notations or adding flows.
Condensing calculations include the following considerations and processes:
Instruments and players
Solo players in your project are considered for condensing. Adjacent players holding
similar instruments are automatically assigned to condensing groups.
NOTE
●

Section players cannot be condensed, except for vocal players, such as in an SATB
choir.

●

If a solo player holds multiple instruments, only their first instrument is considered
for condensing. Other instruments always appear on a separate staff.

●

Only instruments that normally have a single staff and whose music is in a single
voice can be condensed, as music already in multiple voices produces ambiguous
condensing results. Grand staff instruments cannot be condensed.

●

Unpitched percussion instruments cannot be condensed. You can change how
unpitched percussion appears in full scores using the available percussion kit
presentations.
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●

Divisi staves cannot currently be condensed. This is planned for future versions.

Condensing groups
Players within a condensing group can be condensed together, and can all share a
single staff, depending on their music and your set notation options.
By default, Dorico Pro assigns adjacent similar instruments to the same condensing
group, for example, Flutes 1 and 2. You can create your own custom condensing
groups to specify which players you want to condense together.
Phrases
Dorico Pro divides each flow into phrases because the required condensing result
varies depending on the texture and density of the music, which changes over the
course of a single piece. Each phrase is considered separately when calculating the
best condensing result.
Dorico Pro considers a sequence of notes between rests as a single phrase. However,
rests that are spanned by slurs, gradual dynamics, playing techniques with duration,
and similar items do not break phrases. Condensing can only change within phrases
where they span system/frame breaks.

Two phrases separated by a rest. They have different condensing results due to the parts in the
first phrase having different rhythms.

The phrases belonging to all the players on each condensed staff are considered
together in order to calculate the best condensing result, for example, whether or not
phrases can share a single stem or require separate voices.
Rhythms and pitches
Within each phrase, the rhythms and pitches of notes are considered. Where they are
both the same, the condensing result can be unison. Where they are both different, the
condensing result can be different voices on the same staff.
Notations
All other notations are considered in addition to notes, including articulations,
dynamics, slurs, grace notes, playing techniques, lyrics, ornaments, and so on. For
example, if two parts have the same rhythms and pitches but their slurs apply to
different notes, they are condensed into a shared staff with separate voices to ensure
the different slurs are clearly notated. Parts are also condensed into separate voices if
their articulations are different.
NOTE
Clefs and octave lines do not affect the condensing result. Players whose instruments
have different clefs and octave lines can be condensed together. The resulting
condensed staff uses the clefs and octave lines belonging to the first player on the staff
only.
Properties
The properties of notes and items are considered, such as if notes have forced stem
directions or slurs have been flipped. When properties are different, parts cannot be
condensed into the same voice.
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Time signatures and key signatures
Players with different time signatures or key signatures cannot be condensed together.
Casting off
Music is condensed each system at a time, from left to right. Condensing is calculated
for each system in its entirety, meaning that, for example, players cannot appear on
their own staff at the start of a system and then on a condensed staff later in the same
system.
Each system can have different condensing to neighboring systems, even if a single
phrase spans multiple systems. In such circumstances, the separate parts of the phrase
are considered separately.
Therefore, your casting off settings and system/frame breaks influence which phrases
are considered together and therefore the condensing result.
NOTE
Condensed music often requires different rhythmic spacing than uncondensed music,
for example, to accommodate the width of notes that are a small interval apart.
Therefore, enabling condensing can cause the casting off in the layout to change.
TIP
If the automatic condensing produced by Dorico Pro does not suit your requirements, you can
change the condensing manually from selected rhythmic positions onwards and for selected
condensing groups using condensing changes. You might find that using condensing changes
simply to start new phrases is sufficient to achieve the desired condensing result.

RELATED LINKS
Condensing groups on page 478
Creating custom condensing groups on page 479
Including/Excluding condensing groups on page 479
Changing condensing options from rhythmic positions on page 480
Adding solo/section players on page 109
Changing the voice of existing notes on page 341
Moving instruments on page 119
Resetting the appearance of items on page 331
Resetting the position of items on page 331

Condensing results
Depending on the pitches and rhythms of notes in the different parts on condensed staves,
condensing can result in parts sharing stems, having separate voices, or not condensing and
remaining on separate staves.
Dorico Pro calculates and considers the condensing of parts for each phrase separately in order
to produce the best result. Dorico Pro also automatically shows player labels so it is always clear
which notes belong to each part on condensed staves.
There are the following possible condensing results:
Unison
In phrases where the rhythms and pitches for all players are the same, all parts on the
condensed staff share the same noteheads on a single stem.
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NOTE
Phrases must start at the same rhythmic position to produce a unison condensing
result.
Shared stem
In phrases where the rhythms are the same, the pitches are different, and the pitches
do not cross, each part on the condensed staff has a separate notehead but the
noteheads share a single stem.

NOTE
Phrases must start at the same rhythmic position to produce a shared stem
condensing result.
Shared staff
In phrases where neither the rhythms nor the pitches for all players are the same, and
pitch crossing does not exceed your set value, parts on the condensed staff are split
into up-stem and down-stem voices.
If phrases start at the same rhythmic position, individual notes and entire beams/
tuplets in those phrases that have the same duration can be amalgamated into a single
voice, depending on any other notations in those phrases and your set notation
options.

Not condensed
In phrases where neither the rhythms nor the pitches for all players are the same, and
pitch crossing exceeds your set value, no condensing occurs and parts remain on
separate staves.
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NOTE
●

In addition to rhythms and pitches, Dorico Pro also considers all other notations, such as
slurs and dynamics, in order to calculate the best condensing result. For example, if two
parts have the same rhythms and pitches but their slurs apply to different notes, they are
condensed into a shared staff with separate voices to ensure the different slurs are clearly
notated. However, clefs and octave lines are not considered and do not affect the
condensing result.

●

Condensed staves always use a maximum of two voices, one up-stem and one down-stem.
Each voice can include the parts of multiple players.

●

If you want to change the automatic condensing results, you can do so from selected
rhythmic positions onwards using condensing changes. You might find that using
condensing changes simply to start new phrases is sufficient to achieve the desired
condensing result.

RELATED LINKS
Changing condensing options from rhythmic positions on page 480
Condensing Change dialog on page 481

Condensing groups
Condensing groups contain solo players whose music can be condensed onto the same staff or
fewer staves and who are usually adjacent in the score. Condensing groups can contain up to 16
players.
Typically, players in condensing groups hold the same type of instrument. However, there are
some common exceptions to this, for example, the trombone and tuba, which are different
instruments but often share a staff in orchestral scores. Another example is horns, which are
sometimes paired up in an interlocking fashion, that is, Horns 1 and 3 share a staff and Horns 2
and 4 share another.
Dorico Pro automatically creates condensing groups for adjacent solo players holding
instruments of the same type with the same transposition. You can see these groups in the
Condensing section of the Players page in Setup > Layout Options.
You can create custom condensing groups, for example, if you want to condense trumpets with
different transpositions together. You can also specify groups that you do not want to condense,
that is, groups whose players’ staves must always appear separately.
The condensing groups set up in each layout are then available in the Condensing Change
dialog, allowing you to change options for those condensing groups from selected rhythmic
positions onwards.
RELATED LINKS
Changing condensing options from rhythmic positions on page 480
Condensing Change dialog on page 481
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Creating custom condensing groups
You can create custom condensing groups in each layout independently, for example, if you want
Horns 1 and 3 and Horns 2 and 4 to condense together, rather than Horns 1-2 and 3-4.
Condensing groups can contain up to 16 players.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to create custom condensing
groups.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Condensing section, click New Group to open the Edit Custom Condensing Group
dialog.

5.

Select the players you want to include in the custom condensing group.
You can Shift -click adjacent players and Ctrl/Cmd -click individual players.

6.

Click OK to save your changes and close the dialog.

7.

Optional: Repeat steps 4 to 6 to create other custom condensing groups.

8.

Click Apply, then Close.

RESULT
The condensing groups are added to the selected layouts. This affects which players can be
condensed together in those layouts.
Any players now in custom condensing groups that were previously in default condensing
groups are removed from the default condensing groups.
NOTE
Other condensing calculations and considerations and your notation options still affect whether
or not players condense at specific points.
AFTER COMPLETING THIS TASK
If necessary, you can change options for those condensing groups from selected rhythmic
positions onwards to change the condensing result.
RELATED LINKS
Condensing calculations and considerations on page 474
Per-flow notation options for condensing on page 472
Enabling/Disabling condensing on page 449
Changing condensing options from rhythmic positions on page 480

Including/Excluding condensing groups
You can specify individual condensing groups that you want to include in or exclude from
condensing calculations, for example, if Dorico Pro automatically puts two horns in a condensing
group but you always want to show them on separate staves.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.
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2.

In the Layouts list, select the layouts in which you want to include condensing groups in, or
exclude them from, condensing calculations.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Condensing section, activate the checkbox for each condensing group you want to
exclude from condensing in the Groups to exclude from condensing list.

5.

Click Apply, then Close.

RESULT
Condensing groups are excluded from condensing when their checkbox is activated, meaning
players in those condensing groups are always shown on their own staves. Condensing groups
are included in condensing when their checkbox is deactivated.
RELATED LINKS
Divisi on page 1176

Changing condensing options from rhythmic positions
You can change the settings of notation options for condensing for individual condensing groups
from selected rhythmic positions onwards in individual layouts.
TIP
We recommend only changing the minimum condensing options required, and only if changing
the per-flow default condensing options, creating custom condensing groups, and starting new
phrases from selected rhythmic positions has not produced the required condensing result.
PREREQUISITE
You have enabled condensing in the current layout.
PROCEDURE
1.

In the music area, open the layout in which you want to change condensing.

2.

In Engrave mode, select an item at the rhythmic position where you want to change the
condensing result.
TIP
The item does not have to be on a condensed staff. Only one condensing change can exist at
a rhythmic position but it can change and reset different options for multiple condensing
groups.

3.

Choose Engrave > Condensing Change to open the Condensing Change dialog.

4.

In the condensing groups list, activate the checkbox for each condensing group you want to
include in the condensing change.
Including condensing groups starts new phrases from the selected rhythmic position.

5.

Select a condensing group whose condensing options you want to change.
NOTE
You can only change or reset options for a single selected condensing group at a time.

6.

In the Notation Options section, activate each option you want to change.
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7.

Choose Change for each activated option.

8.

Change the settings for the activated options as required.
NOTE
The prevailing settings for condensing options come from either previous condensing
changes, if they exist, or the default settings for the flow in Notation Options.

9.

Optional: Repeat steps 5 to 8 for each condensing group whose condensing options you
want to change from the selected rhythmic position.

10. Click OK to save your changes and close the dialog.
RESULT
The condensing result is changed in the current layout from the selected rhythmic position
onwards. Dorico Pro recalculates the condensing result both before and after the condensing
change for each condensing group whose checkbox you activated, as this treats the rhythmic
position of the condensing change as the start of a new phrase.
The notation options you changed apply to the corresponding condensing groups until the next
condensing change that changes or resets those options, if one exists, or the end of the flow,
whichever comes first.
A signpost is shown at the position of the condensing change.
RELATED LINKS
Per-flow notation options for condensing on page 472
Condensing results on page 476
Condensing groups on page 478
Creating custom condensing groups on page 479

Condensing Change dialog
The Condensing Change dialog allows you to change and reset notation options for condensing
from selected rhythmic positions onwards in layouts. It also allows you to assign players in
condensing groups to specific voices and staves manually.
●

You can open the Condensing Change dialog in Engrave mode by choosing Engrave >
Condensing Change when Graphic Editing is selected in the Engrave toolbox and an item is
selected in the music area.
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Condensing Change dialog

The Condensing Change dialog contains the following sections and options:
1

Condensing groups list
Contains all the condensing groups in the current layout.
Activating condensing groups includes them in the condensing change, which starts new
phrases from the rhythmic position of the condensing change. This allows Dorico Pro to
recalculate the condensing result before and after the condensing change separately, even if
there are no rests at that position.
Condensing groups show a warning icon if you have activated manual condensing for them
but not yet assigned all their players to voices/staves.

Warning icon

2

Notation Options section
Contains all the condensing options from the Notation Options dialog and allows you to
change or reset them for the selected condensing group from the position of the
condensing change.
The prevailing settings for condensing options come from either previous condensing
changes, if they exist, or the default settings for the flow in Notation Options.
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NOTE

3

●

Because you do not have to change all options in each condensing change, the
prevailing settings can cumulatively come from multiple preceding condensing changes.

●

In order to be more concise, the exact wording of some notation options is different in
the Condensing Change dialog than in Notation Options.

Manual Condensing section
Allows you to assign players in the selected condensing group to specific voices and staves.
Activating manual condensing for a condensing group shows the players in that group in the
players list on the left of the Manual Condensing section. You can then allocate the players
to voices/staves in the list on the right, which removes them from the players list.
The action bar at the bottom of the list on the right contains the following options:
●

Add Staff: Adds a staff. Dorico Pro automatically assigns the top player in the players list
to the up-stem voice on the new staff.

●

Remove Staff: Removes the selected staff. Any players assigned to the staff are
returned to the players list.

●

Remove Player: Removes the selected player and returns it to the players list.

●

Clear: Removes all your changes to manual condensing and returns all players to the
players list.

IMPORTANT
We recommend being careful and deliberate about your manual condensing choices. Dorico
Pro follows your manual condensing settings exactly, even if they produce ambiguous
results.
NOTE

4

●

You must always have at least one player assigned to the up-stem voice on a staff, you
cannot only have players in the down-stem voice.

●

You cannot have more staves than there are players in the condensing group.

●

You can only assign players within a single condensing group, you cannot share players
between different condensing groups.

●

Condensing changes that occur partway through systems and change the number of
staves required for condensing groups, or include players switching to other staves, do
not take effect until the next system.

OK button
Allows you to confirm your changes and close the dialog. You can only confirm the dialog
when you have assigned all players in all condensing groups with manual condensing
activated to voices/staves.

RELATED LINKS
Per-flow notation options for condensing on page 472
Condensing results on page 476
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Condensing groups on page 478

Manually condensing players
You can manually change the allocation of players to voices and staves in each condensing group
from selected rhythmic positions onwards in individual layouts.
IMPORTANT
We recommend only condensing players manually if changing the per-flow default condensing
options, creating custom condensing groups, starting new phrases from selected rhythmic
positions, and overriding selected condensing options has not produced the required
condensing result.
In such cases, we recommend being careful and deliberate about your manual condensing
choices. Dorico Pro follows your manual condensing settings exactly, even if they produce
ambiguous results. For example, if you assign two players with very different rhythms to the
same voice on the same staff, the resulting notation requires many tied notes and is harder to
read than if they were in separate voices.

PROCEDURE
1.

In the music area, open the layout in which you want to condense players manually.

2.

In Engrave mode, select an item at the rhythmic position from which you want to change
condensing manually.
TIP
The item does not have to be on a condensed staff. Only a single condensing change can
exist at a rhythmic position but you can change or reset options for multiple staves.

3.

Choose Engrave > Condensing Change to open the Condensing Change dialog.

4.

In the condensing groups list, activate the checkbox for each condensing group you want to
include in the condensing change.
Including condensing groups starts new phrases from the selected rhythmic position.

5.

Select a condensing group whose condensing you want to change manually.
NOTE
You can only change or reset options for a single selected condensing group at a time.

6.

In the Manual Condensing section, activate Condensing Approach.

7.

Choose Manual Condensing.

8.

Select a player in the players list.

9.

Assign the player to a voice and staff in any of the following ways:
●

Click and drag it across to the list on the right.

●

Click Add to Voice.

By default, the first player is assigned to the up-stem voice on the first staff.
10. Optional: If you want to assign the next player to a different staff, click Add Staff in the
action bar at the bottom of the list on the right.
By default, the top player in the players list is automatically assigned to the up-stem voice on
the new staff.
11. Optional: Continue assigning players to voices/staves in any of the following ways:
●

Click and drag them across to the required voice and staff in the list on the right.
An insertion line indicates where the player will be assigned.
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●

Select the player in the players list, select the destination voice and staff in the list on the
right, and click Add to Voice.

NOTE
●

You must assign all players in the condensing group to voices/staves before Dorico Pro
allows you to confirm and close the dialog. Until all players are assigned, a warning icon
appears beside the condensing group in the condensing group list.

●

You must always have at least one player assigned to the up-stem voice on a staff, you
cannot only have players in the down-stem voice.

12. Optional: Repeat steps 5 to 11 for each condensing group you want to condense manually
from the selected rhythmic position.
13. Click OK to save your changes and close the dialog.
RESULT
The condensing result is changed in the current layout from the selected rhythmic position
onwards. Dorico Pro recalculates the condensing result both before and after the condensing
change for each condensing group whose checkbox you activated, as this treats the rhythmic
position of the condensing change as the start of a new phrase.
The condensing groups whose manual condensing you changed follow your assignments until
the next condensing change that changes or resets those assignments, if one exists, or the end
of the flow, whichever comes first.
A signpost is shown at the position of the condensing change.
RELATED LINKS
Per-flow notation options for condensing on page 472
Condensing results on page 476
Condensing groups on page 478
Creating custom condensing groups on page 479
Changing condensing options from rhythmic positions on page 480

Resetting condensing changes from rhythmic positions
You can reset changes you have made to condensing to your per-flow defaults, including
resetting only selected notation options, from selected rhythmic positions onwards in individual
layouts.
PROCEDURE
1.

In the music area, open the layout in which you want to reset condensing changes.

2.

In Engrave mode, select an item at the rhythmic position where you want to reset
condensing.
TIP
The item does not have to be on a condensed staff. Only a single condensing change can
exist at a rhythmic position but you can change or reset options for multiple staves.

3.

Choose Engrave > Condensing Change to open the Condensing Change dialog.

4.

In the condensing groups list, activate the checkbox for each condensing group you want to
include in the condensing change.
Including condensing groups starts new phrases from the selected rhythmic position.

5.

Select a condensing group whose condensing you want to reset.
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NOTE
You can only change or reset options for a single selected condensing group at a time.
6.

Reset condensing in one of the following ways:
●

To reset a previous change to condensing options: In the Notation Options section,
activate each option you want to reset and choose Reset.

●

To reset a previous manual condensing change: In the Manual Condensing section,
activate Condensing Approach and choose Reset.

7.

Optional: Repeat steps 5-6 for each condensing group whose condensing you want to reset.

8.

Click OK to save your changes and close the dialog.

RESULT
The condensing result is reset to follow your per-flow notation options for the activated options,
or entirely for manual condensing changes. This applies from the selected rhythmic position
onwards until the next existing condensing change or the end of the flow, whichever comes first.
A signpost is shown at the position of the condensing change.

Deleting condensing changes
You can delete manual condensing changes, which returns condensing to the previous existing
condensing change in the flow, if one exists, or the default condensing settings in the layout.
PROCEDURE
1.

Select the signposts of the condensing changes you want to delete.

2.

Press Backspace or Delete .

RESULT
The selected condensing changes are deleted. The condensing result returns to either the
previous existing condensing change in the flow, if one exists, or the default settings in the
layout. This applies until the next existing condensing change or until the end of the flow,
whichever comes first.

Player labels
Player labels identify the players to which notes on condensed staves belong. They are usually
used to indicate a change in how music is condensed, such as going from having different parts
to playing in unison or from all players having separate stems to some players sharing a stem.
Player labels show the numbers of the players whose music is included in the corresponding
voice. Player labels are placed above the staff for up-stem voices and below the staff for downstem voices. They have a small horizontal offset to the left of their rhythmic position by default,
which reduces pressure on vertical spacing.
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Player labels (circled) indicating which music belongs to the first (1) and second (2) players on each staff

In Dorico Pro, player labels are automatically shown at the start of phrases whose condensing is
different to the previous phrase and at the start of new systems. By default, they also use the
standard indication a, meaning “to”, when multiple players play the same notes.
●

For notes that only belong to a single player, the player label shows the number of that
player or the abbreviated instrument name for unnumbered players condensed with
different instruments.

●

For notes that belong to all players on the staff, the player label shows the “to” indication
followed by the number of players on the staff, for example, a 3.

●

For notes that belong to multiple players, but not all players on the staff, the player label
shows the numbers of those players followed by the “to” indication, for example, 1.2 a 2.
Player labels for unnumbered players condensed with different instruments show their
abbreviated instrument names followed by the “to” indication, for example, Fl. Ob. a2.

TIP
●

You can change the appearance and position of player labels, including their offset and “to”
indication, on the Condensing page in Engrave > Engraving Options.

●

Player labels use the Player Labels paragraph style, which you can edit in the Paragraph
Styles dialog.

RELATED LINKS
Paragraph Styles dialog on page 410
Staff labels on condensed staves on page 1156
Changing number stacking in condensed staff labels on page 1157

Project-wide engraving options for player labels
You can find options for the project-wide appearance and position of player labels on the
Condensing page in Engrave > Engraving Options.
The options on the Condensing page allow you to set precise distances between player labels
and the staff and other items, choose whether they erase their backgrounds, change whether
player numbers are separated and appended with periods, and change the text shown for the
“to” indication.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
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RELATED LINKS
Engraving Options dialog on page 359

Hiding/Showing player labels
You can hide/show player labels individually, for example, if you want to hide the player labels
automatically shown at the start of systems when multiple systems fit on the same page.
PROCEDURE
1.

In Engrave mode, select the player labels you want to hide/show.

2.

In the Properties panel, activate/deactivate Hide in the Player Labels group.

RESULT
The selected player labels are hidden when Hide is activated, and shown when it is deactivated.
Signposts are shown at the position of each hidden player label. However, signposts are not
printed by default.
NOTE
●

This only affects player labels in the current layout, but you can copy property settings to
other layouts.

●

If you do not want to show player label signposts, choose View > Signposts > Player Labels.
Player label signposts are shown when a tick appears beside Player Labels in the menu, and
hidden when no tick appears.

RELATED LINKS
Copying property settings to other layouts on page 493
Hiding/Showing signposts on page 336
Annotations on page 610

Editing player label text
You can override the text shown in player labels individually, for example, if you want to describe
condensing on a staff in a different format than is shown by default.
PROCEDURE
1.

In Engrave mode, select the player labels whose text you want to edit.

2.

In the Properties panel, activate Custom text in the Player Labels group.

3.

Enter the text you want to be shown in the corresponding player labels into the value field.

4.

Press Return .

RESULT
The selected player labels are changed to show the text you entered.
Deactivating Custom text returns the corresponding player labels to their default text.
NOTE
Deactivating properties permanently deletes any custom text entered.
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Showing player labels on one/two lines
By default, player labels appear on a single line. You can insert line breaks in individual player
labels to show instrument numbers and the a2 indication spread across two lines. This can
reduce the horizontal space required for player labels containing many instrument numbers.
PROCEDURE
1.

In Engrave mode, select the player labels into which you want to insert a line break.

2.

In the Properties panel, activate/deactivate Line break in the Player Labels group.

RESULT
The selected player labels are shown on two lines in the current layout when Line break is
activated, and on one line when it is deactivated.
NOTE
This only affects player labels in the current layout, but you can copy property settings to other
layouts.
EXAMPLE

Player label on one line

Player label on two lines

Moving player labels graphically
You can move individual player labels graphically, for example, to move them closer to the staff
when other items cause them to appear further away.
PROCEDURE
1.

In Engrave mode, select the player labels you want to move.

2.

Move the player labels in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.
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RESULT
The selected player labels are moved to new graphical positions. By default, player labels erase
their backgrounds if positioned in the staff so they do not collide with staff lines.
TIP
Offset in the Common group of the Properties panel is activated automatically when you move
player labels.
●

Offset X moves player labels horizontally.

●

Offset Y moves player labels vertically.

You can also use this property to move player labels by changing the values in the value fields.
Deactivating the property resets the selected player labels to their default positions.

Erasing the background of player labels
By default in Dorico Pro, player labels have erased backgrounds so they do not collide with staff
lines if they must be positioned within the staff in dense scores. You can change this default
setting for all player labels, including changing their erasure padding.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Condensing in the page list.

3.

In the Player Labels subsection, activate/deactivate Erase background with padding.

4.

Optional: If you activated Erase background with padding, change the value in the value
field to change the erasure padding around player labels.

5.

Click Apply, then Close.

RESULT
All player labels project-wide have erased backgrounds when Erase background with padding
is activated, and do not have erased backgrounds when it is deactivated. When they have erased
backgrounds, the erasure padding is determined by the set value.

Hiding/Showing condensed music colors
You can show notes and rests on condensed staves in gray to help you identify condensed music.
Condensed music cannot be selected or edited directly.
Condensed music colors are considered annotations and are not printed by default.
NOTE
Condensed music colors only appear in layouts where condensing is enabled.

PROCEDURE
●

Choose View > Note And Rest Colors > Condensed Music.

RESULT
Notes and rests on condensed staves appear gray when a tick appears beside Condensed Music
in the menu, and black when no tick appears.
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EXAMPLE

Condensing colors shown, causing notes and rests to appear black on the uncondensed piccolo staff and
gray on the condensed Flutes 1-2 staff.

RELATED LINKS
Enabling/Disabling condensing on page 449
Annotations on page 610

Part formatting propagation
The propagation of part formatting involves copying the layout options and system formatting
that determine the layouts of pages in specific part layouts and applying them to other part
layouts. This can save time when formatting similar parts.
System formatting includes the positions of system and frame breaks, but also note spacing
changes that affect the horizontal space that notes require.
In Dorico Pro, you can copy layout options and system formatting both together and
independently of each other from a selected source layout to other destination layouts. For
example, for source layouts whose formatting relies primarily on their Casting Off settings in
Setup > Layout Options, it is likely that copying only their layout options is sufficient to produce
the required formatting in the destination layouts without adding system/frame breaks on every
system.
You can also copy the layout-specific property settings from the layout currently open in the
music area to all other layouts in which those items appear.
NOTE
●

Part formatting propagation is only available for part layouts. You cannot propagate part
formatting from/to full score or custom score layouts.

●

We do not recommend using layouts with multiple music frame chains as either source or
destination layouts as you can get unexpected results.

●

Propagating part formatting does not include overrides to individual pages made in Engrave
mode.

Propagate Part Formatting dialog
The Propagate Part Formatting dialog allows you to copy the page formatting and layout
options from a source layout to destination layouts.
You can open the Propagate Part Formatting dialog in Setup mode in any of the following
ways:
●

Right-click a part layout in the Layouts panel and choose Propagate Part Formatting from
the context menu. This automatically selects that layout as the source layout in the Copy
formatting from list.
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●

Choose Setup > Propagate Part Formatting.

Propagate Part Formatting dialog

The Propagate Part Formatting dialog contains the following sections and options:
1

Copy formatting from list
Contains a list of all the part layouts in the project. You can only select a single part layout as
the source layout.

2

Propagate formatting to list
Contains a list of all the part layouts in the project. You can select multiple part layouts as
destination layouts.

3

Selection options
Allow you to select/deselect all the part layouts in the Propagate formatting to list.

4

Include layout options
Allows you to copy layout options relating to part formatting from the source layout to the
destination layouts. These options include page size, page margins, the default master page
set, space size, vertical spacing, note spacing, casting off, multi-bar rest settings, and staff
labels.

5

Include system formatting
Allows you to copy the distribution of bars in systems, systems on pages, and note spacing
changes from the source layout to the destination layouts. Dorico Pro achieves this by
copying system breaks, frame breaks, and note spacing changes, inputting additional system
and frame breaks as required, and deleting any existing system breaks, frame breaks, and
note spacing changes in the destination layouts.
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Copying part formatting to other layouts
You can copy all the formatting from one part layout to other part layouts, for example, to save
time if multiple part layouts in your project require similar formatting. You can include layout
options, such as page size and margins, and other page formatting, such as system and frame
breaks.
NOTE
●

Part formatting propagation is only available for part layouts. You cannot propagate part
formatting from/to full score or custom score layouts.

●

We do not recommend using layouts with multiple music frame chains as either source or
destination layouts as you can get unexpected results.

PROCEDURE
1.

In the Layouts panel in Setup mode, right-click the card of the part layout whose part
formatting you want to copy and choose Propagate Part Formatting from the context
menu.

2.

In the Copy formatting from list, select the part layout whose part formatting you want to
copy.
By default, the layout whose card you used to open the dialog is selected.

3.

In the Propagate formatting to list, select the part layouts to which you want to copy part
formatting.
You can use the selection options in the action bar, Shift -click adjacent layouts, and Ctrl/
Cmd -click individual layouts.

4.

Activate/Deactivate Include layout options.

5.

Activate/Deactivate Include system formatting.

6.

Click OK to copy part formatting to the selected layouts and close the dialog.

RESULT
Part formatting from the selected source layout is copied to the selected destination layouts.
However, overrides to individual pages made in Engrave mode are not propagated.
●

If you activated Include layout options, layout options are copied from the source layout to
the destination layouts.

●

If you activated Include system formatting, Dorico Pro copies the distribution of bars in
systems, systems on pages, and note spacing changes from the source layout to the
destination layouts.

TIP
If the formatting of the source layout relies primarily on its Casting Off settings in Setup >
Layout Options, it is likely that only activating Include layout options is sufficient to produce
very similar formatting in the destination layouts without adding system/frame breaks on every
system.

Copying property settings to other layouts
Many properties are layout-specific, meaning they only affect the layout currently open in the
music area. You can copy the properties set on notes and items to all other layouts in which they

493
Dorico Pro 3.1.10

Page formatting
Part formatting propagation
appear, for example, to show gradual dynamics with the same style in part layouts after
changing their style in the full score layout.
PROCEDURE
1.

Select the notes or items whose properties you want to copy to other layouts. You can do
this in Write mode and Engrave mode.
NOTE
The mode you are in determines which properties are copied. For example, if you are in
Write mode, only properties available in Write mode are copied.

2.

Choose Edit > Propagate Properties.

RESULT
All properties set on the selected notes/items that are available in the current mode are copied to
all layouts in which those notes/items appear. For example, if you selected slurs in Write mode,
their staff-relative placement and design settings are copied. If you selected them in Engrave
mode, their slur end and control point positions are also copied.
RELATED LINKS
Large selections on page 322
Resetting the appearance of items on page 331
Resetting the position of items on page 331
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Play mode allows you to change how your music sounds in playback, including by changing the
playback template and assigning VST instruments, inputting automation, adjusting the mix, and
changing the sounding duration of notes in playback without affecting their notated duration.

Project window in Play mode
The project window in Play mode contains the default toolbar and the event display, and also a
toolbox and panels that contain all the tools and functions that allow you to set up your project
for playback.
You can switch to Play mode in any of the following ways:
●

Press Ctrl/Cmd-4 .

●

Click Play in the toolbar.

●

Choose Window > Play.

Project window in Play mode

NOTE
There is no Properties panel in Play mode.
The project window in Play mode comprises the following:
1

Play toolbox
Contains tools that allow you to select and edit note events in the event display.
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2

Event display
Allows you to view, input, and edit the playback of each flow in your project, including
changing the played duration of notes and the tempo at any rhythmic position.

3

VST and MIDI Instruments panel
Allows you to load new VST and MIDI instruments. You can also select existing VST and MIDI
instruments and edit their settings.

Play toolbox
The Play toolbox contains tools that allow you to select and edit the note events in the event
display in Play mode. It is located on the left of the window in Play mode.
Played Durations

Allows you to change when notes start/end in playback without affecting their notated
durations. When Played Durations is selected, the played durations of notes are
shown as a lighter event, above a thinner line that shows the notated duration of
notes.
Notated Durations

Allows you to change the rhythmic duration of notes, which affects the position and
notation of those notes. When Notated Durations is selected, the full, notated
durations of notes are shown as single events in the piano roll editor.
Object Selection

Allows you to select events, such as notes in the piano roll editor/drum editor and
points in automation lanes and dynamics lanes.
You can also select Object Selection by pressing S .
Draw

Allows you to input and edit notes in the piano roll editor and drum editor. You can
click and drag in the piano roll editor to input notes with the durations you want. The
ends of the notes you draw snap to rhythmic positions according to the current
rhythmic grid resolution.
It also allows you to add points in the Time track and automation and velocity lanes.
Using the Draw tool rather than the Line tool adds a point at regular intervals
according to the current rhythmic grid resolution.
You can also select Draw by pressing D .
Line

Allows you to draw straight lines between two points in the Time track and automation
and velocity lanes, without adding extra values between those points.
Draw Percussion

Allows you to add notes to percussion staves in the drum editor with one click. You do
not have to click and drag to a duration when using Draw Percussion.
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Erase

Allows you to delete notes. You can make marquee selections to delete multiple notes
when Erase is selected.
You can also select Erase by pressing E .
TIP
To deselect Erase, select Object Selection.

RELATED LINKS
Inputting notes in the event display on page 505
Deleting notes in the event display on page 509
Time track on page 530
Automation lanes on page 523
Velocity lanes on page 521
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VST and MIDI Instruments panel
The VST and MIDI instruments panel contains the VST and MIDI instruments available and used
in your project, and allows you to edit their settings. It is located on the right of the window in
Play mode.

VST and MIDI Instruments panel

The VST and MIDI Instruments panel contains the following sections:
1

VST Instruments

2

MIDI Instruments

VST Instruments
The VST Instruments section of the panel contains plug-in instances that each contain a VST
instrument plug-in. Dorico Pro automatically loads plug-ins and enough plug-in instances for the
instruments you add to your project according to the current playback template, but you can also
load VST instruments manually.
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Plug-in instances are automatically numbered to help you differentiate between instances when
you have multiple instances of the same plug-in.
NOTE
Dorico Pro only shows VST 3 instruments in the VST Instruments section by default. If you also
want VST 2 instruments to be available, you must whitelist them. Only Kontakt is available by
default.

Each plug-in instance contains the following:
1

Activate Instrument
Activates/Deactivates the plug-in instance.

2

Edit Instrument
Opens/Closes the VST instrument window.

3

Endpoint Setup
Opens the Endpoint Setup dialog for the corresponding plug-in instance.

4

VST Instruments menu
Displays the VST instrument currently loaded in the plug-in instance and allows you to select
another available VST instrument from the menu.

The action bar at the bottom of the section contains the following options:
●

Add: Adds a new empty plug-in instance.

●

Duplicate: Creates a copy of the selected plug-in instance that you can edit separately from
the original.

●

Save Endpoint Configuration: Saves the current state of all plug-in instances in the section
as a custom endpoint configuration.

●

Delete: Deletes the selected plug-in instance.

MIDI Instruments
The MIDI Instruments section of the panel contains plug-in instances that each contain a MIDI
device to use for output during playback. Which MIDI devices are available depends on your
operating system.
●

On Windows, you can select any MIDI device that is plugged into your computer.

●

On macOS, you can select any MIDI device that is plugged into your computer, and any other
device set up in the Audio MIDI Setup application. For example, this allows you to use MIDI
from one application in another application.
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TIP
We recommend plugging MIDI devices into your computer before starting Dorico Pro. Similarly,
if your device is not recognized, we recommend restarting Dorico Pro.
Plug-in instances are automatically numbered to help you differentiate between instances when
you have multiple instances of the same plug-in.

Each MIDI instance contains the following:
1

Activate Instrument
Activates/Deactivates the plug-in instance.

2

Endpoint Setup
Opens the Endpoint Setup dialog for the corresponding plug-in instance.

3

MIDI Instruments menu
Displays the MIDI device currently loaded in the plug-in instance and allows you to select
another available MIDI device from the menu.

The action bar at the bottom of the section contains the following options:
●

Add: Adds a new empty plug-in instance.

●

Duplicate: Creates a copy of the selected plug-in instance that you can edit separately from
the original.

●

Save Endpoint Configuration: Saves the current state of all plug-in instances in the section
as a custom endpoint configuration.

●

Delete: Deletes the selected plug-in instance.

RELATED LINKS
Playback templates on page 558
Endpoints on page 566
Endpoint Setup dialog on page 567

Loading VST/MIDI instruments manually
Dorico Pro automatically loads the plug-in instances required for your project, according to the
current playback template. However, you can also load VST/MIDI instruments manually, either
into new plug-in instances or into existing ones to replace existing VST/MIDI instruments.
PREREQUISITE
●

Any VST instruments you want to use are saved on your computer.

●

You have connected any MIDI devices you want to use.
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TIP
We recommend plugging MIDI devices into your computer before starting Dorico Pro.
Similarly, if your device is not recognized, we recommend restarting Dorico Pro.

PROCEDURE
1.

Optional: If you want to load a VST/MIDI instrument into a new plug-in instance, click Add in
the corresponding section of the VST and MIDI Instruments panel.

2.

In the plug-in instance into which you want to load a new VST/MIDI instrument, select the
one you want to load from the menu.

RELATED LINKS
Playback templates on page 558

Whitelisting VST instruments
You must whitelist any VST 2 instruments you want to use in Dorico Pro. After you have
whitelisted plug-ins once, they are available in any project.
A default vst2whitelist.txt file is included with your Dorico Pro installation, which lists
VST 2.x plug-ins that Steinberg has qualified for use with Dorico Pro.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Play in the page list.

3.

In the VST Plug-ins subsection, click Edit VST2 Whitelist to open the vst2whitelist.txt
file in a text editor.

4.

Enter the names of the VST plug-ins you want to whitelist.
NOTE
●

Each plug-in must have its own line in the text file.

●

Do not include the plug-in file extension (.dll on Windows and .vst on macOS).

5.

Save and close the text file.

6.

Click Close to close the Preferences dialog.

7.

Quit Dorico Pro.

RESULT
When Dorico Pro next opens, your whitelisted VST plug-in entries are available for use in the
program.
RELATED LINKS
Preferences dialog on page 62
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Playback Options dialog
The Playback Options dialog provides options that allow you to make project-wide changes to
how the music you have written sounds when played back. These options affect playback,
regardless of expression maps and patches.
In the Playback Options dialog, you can change how dynamics, pedal lines, and different
notations are interpreted during playback.
For example, you can change how much louder notes on the first beat in each bar are compared
to other notes in the bar, change how long each pedal retake lasts, and how much different
articulations, such as staccatissimo and tenuto, affect the duration of notes.
You can open Playback Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-P in any mode.

●

Choose Play > Playback Options in Play mode.

Playback Options

The Playback Options dialog contains the following:
1

Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages. When you click a page in this list, any applicable section titles appear below the page
in the page list.

2

Section titles
Shows the titles of any sections on the selected page. You can click these section titles to
navigate directly to that section of the page.

3

Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible settings,
the current setting is highlighted.

4

Save as Default/Remove Saved Defaults
This button has different functions depending on whether you have existing saved defaults.
●

Save as Default saves all options currently set in the dialog as the default for new
projects.
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●

5

Remove Saved Defaults deletes your previous saved defaults without resetting the
options in the current project. After removing your saved defaults, all future projects
start with the default factory settings. If you have existing saved defaults, you can access
Remove Saved Defaults by pressing Ctrl (Windows) or Opt (macOS) .

Reset to Factory/Reset to Saved Defaults
This button has different functions depending on whether you have existing saved defaults.
●

If you have no saved defaults, Reset to Factory resets all the options in the dialog back
to the default factory settings.

●

If you have existing saved defaults, Reset to Saved Defaults resets all the options in the
dialog back to your saved defaults. You can access Reset to Factory instead by pressing
Ctrl (Windows) or Opt (macOS) . Resetting options back to the default factory settings
only affects the current project and does not delete your saved defaults, meaning future
projects start with your saved defaults.

RELATED LINKS
Expression maps on page 573
Options dialogs in Dorico Pro on page 40

Event display
The event display in Play mode is the equivalent of the music area in Write mode. It allows you to
view and edit your music, but focuses more on how it sounds in playback rather than its notation.
The event display presents your project in a similar way to that used in a digital audio
workstation, or “DAW”, such as Cubase.

Event display in Play mode

The event display comprises the following:
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1

Flow menu
Allows you to select the flow you want to be shown in the event display. Only a single flow is
shown at a time.

2

Track headers
Display the name of each track and contain appropriate options for the track type. You can
expand the track headers of some track types, which reveals further options.

3

Ruler
Displays bar numbers and shows beat divisions that match the current rhythmic grid
resolution.

4

Playhead
Shows the current rhythmic position in playback.

5

Tracks
Horizontal rows that contain musical elements represented in time from left to right.

6

Drum editor
Displays notes for unpitched percussion instruments.

7

Piano roll editor
Displays notes for pitched instruments.

Tools and options in the Play toolbox allow you to input, edit, and delete notes and other events,
such as tempo changes, in the event display.
RELATED LINKS
Playhead on page 540
Tracks on page 510
Play toolbox on page 496

Piano roll editor
The piano roll editor displays MIDI notes for pitched instruments in a continuous sequence, with
the vertical position of note events indicating their pitch.
In Dorico Pro, pitched instruments are displayed in an individual piano roll editor for their
instrument track. Their notes are positioned vertically according to their pitch, which is
demonstrated by a piano keyboard on the left edge of the piano roll editor. Notes are positioned
horizontally according to their rhythm and duration.

Piano roll editor

Each instrument is automatically assigned a color when you add them in Setup mode, so that you
can tell them apart more easily in Play mode. This color is used for notes in the piano roll on that
instrument track, as well as shown as a strip on the instrument track header.
You can edit notes in the piano roll editor, including moving and transposing them.
NOTE
●

When instrument tracks have independent voice playback enabled, you can show notes in all
voices or only in a single voice in the piano roll editor. By default, the piano roll editor shows
all notes belonging to all voices for the corresponding instrument.
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●

Editing the played duration of notes causes them to appear in a darker color in the piano roll
editor to notes whose played duration you have not changed.

RELATED LINKS
Instrument tracks on page 511
Played vs. notated note durations on page 590
Enabling independent voice playback on page 543

Drum editor
The drum editor displays MIDI notes for unpitched percussion instruments in a continuous
sequence. The drum editor appears different to the piano roll editor and has different
functionality.
Instead of showing the piano roll view as used in the piano roll editor, in the drum editor the
onset of each note on each percussion instrument is shown. Each note is shown as an event of
the same size, unlike note events in the piano roll, whose width reflects the duration of the notes.

Drum editor

Each unpitched percussion instrument has its own instrument track, including when they are in a
percussion kit. You can expand unpitched percussion instrument tracks like other instrument
tracks if you want to make changes, such as assigning the instrument to another playback
endpoint.
NOTE
If you change the endpoint for an unpitched percussion instrument, that endpoint must have an
appropriate percussion map chosen, otherwise Dorico Pro does not know how to play the music
for that instrument.
You can move notes in the drum editor to new rhythmic positions. Unpitched percussion
instruments only have one vertical position for their notes, so you cannot transpose notes in the
drum editor.
RELATED LINKS
Instrument tracks on page 511
Expanding/Collapsing tracks on page 539

Inputting notes in the event display
You can input notes into the instruments in your project using the event display in Play mode.
You can follow these steps for both pitched and unpitched instruments.
PREREQUISITE
If you want to input notes into a specific voice for an instrument, you have:
●

Created that voice in Write mode and input at least one note into it.
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●

Enabled independent voice playback for that instrument.

PROCEDURE
1.

Optional: If you want to input notes for pitched instruments, expand those instrument
tracks.

2.

Optional: If you want to input notes into a specific voice, select that voice from the Voice
menu.

3.

Select one of the following tools, depending on the instrument type:

4.

●

To input notes in pitched instrument tracks, select Draw by pressing D or clicking Draw
in the Play toolbox.

●

To input notes in unpitched percussion instrument tracks, select Draw Percussion by
clicking Draw Percussion in the Play toolbox.

Input notes in one of the following ways, depending on the instrument type:
●

For pitched instruments, click and drag horizontally in the piano roll for the required
duration at the pitch position you want.

●

For unpitched percussion instruments, click in the drum editor at the positions where
you want to input notes.

RESULT
In the piano roll editor, notes are input at the pitches indicated by the piano keyboard on the left
of the piano roll. If you selected a voice from the Voice menu, they are input into that voice,
otherwise notes are input into the first available voice for that instrument.
In the drum editor, a note is input in the corresponding instrument each time you click. The
current rhythmic grid resolution determines the duration of the notes. The duration of notes is
indicated by a highlighted area in the track. The shape of the note event in the drum editor is the
same for all durations.
AFTER COMPLETING THIS TASK
You can change both the notated and played durations of notes. You can also change the
duration of notes in the score in Write mode.
RELATED LINKS
Instrument tracks on page 511
Expanding/Collapsing tracks on page 539
Changing the played duration of notes on page 590
Changing the duration of notes on page 176
Inputting notes into multiple voices on page 179
Changing the voice of existing notes on page 341
Enabling independent voice playback on page 543

Moving notes in the event display
You can move notes rhythmically within the event display. This also affects how the selected
notes are notated in any relevant score and part layouts.
PREREQUISITE
●

Notated Durations is selected in the Play toolbox.

●

Object Selection is selected in the Play toolbox.
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PROCEDURE
1.

Optional: If you want to move notes belonging to pitched instruments, expand those
instrument tracks.
You can move notes belonging to unpitched percussion instruments without expanding their
instrument tracks.

2.

In the piano roll/drum editor, select the notes you want to move rhythmically.
NOTE
When instrument tracks have independent voice playback enabled, only notes in the
currently selected voice appear in the piano roll editor. Selecting All voices from the Voices
menu in the track header shows all notes belonging to the corresponding instrument.

3.

Move the selected notes according to the current rhythmic grid resolution in any of the
following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag them to the right/left.

RESULT
The selected notes are moved to new rhythmic positions. If you selected multiple notes, they are
moved together as a block.
NOTE
When using the keyboard, you can both transpose and move notes in the piano roll editor in the
same action. When using the mouse, you must release the mouse between transposing and
moving.

RELATED LINKS
Expanding/Collapsing tracks on page 539
Play toolbox on page 496
Enabling independent voice playback on page 543

Lengthening/Shortening notes in the piano roll editor
You can change the duration of notes belonging to pitched instruments from within the piano
roll editor in Play mode. This automatically changes the notated duration of notes in any relevant
score and part layouts.
PREREQUISITE
●

Notated Durations is selected in the Play toolbox.

●

Object Selection is selected in the Play toolbox.

PROCEDURE
1.

Expand the instrument tracks whose notes you want to lengthen/shorten.

2.

In the piano roll editor, select the notes you want to lengthen/shorten.
NOTE
When instrument tracks have independent voice playback enabled, only notes in the
currently selected voice appear in the piano roll editor. Selecting All voices from the Voices
menu in the track header shows all notes belonging to the corresponding instrument.
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3.

Lengthen/Shorten the notes in any of the following ways:
●

To lengthen notes by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten notes by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .

●

To double the length of notes, press Ctrl/Cmd-Shift-Alt/Opt-Right Arrow .

●

To halve the length of notes, press Ctrl/Cmd-Shift-Alt/Opt-Left Arrow .

●

Click and drag the right end of one of the selected notes to the length you want.

RESULT
The selected notes are lengthened/shortened.
NOTE
If you select multiple notes that end at different rhythmic positions and drag them with the
mouse pointer, changing their duration forces all the notes to end at the same rhythmic position.

RELATED LINKS
Expanding/Collapsing tracks on page 539
Played vs. notated note durations on page 590
Changing the played duration of notes on page 590
Changing the duration of notes on page 176
Play toolbox on page 496
Enabling independent voice playback on page 543

Transposing notes in the piano roll editor
You can transpose notes in the piano roll editor by moving them vertically to other pitch
positions. You cannot transpose notes in the drum editor, or move them to other unpitched
percussion instruments.
PREREQUISITE
Object Selection is selected in the Play toolbox.
PROCEDURE
1.

Expand the instrument tracks whose notes you want to transpose.

2.

In the piano roll editor, select the notes you want to transpose.
NOTE
When instrument tracks have independent voice playback enabled, only notes in the
currently selected voice appear in the piano roll editor. Selecting All voices from the Voices
menu in the track header shows all notes belonging to the corresponding instrument.

3.

Transpose the notes in any of the following ways:
●

To move notes up one staff position, such as from C to D, press Alt/Opt-Up Arrow .

●

To move notes down one staff position, such as from D to C, press Alt/OptDown Arrow .

●

To transpose notes up a single octave division, such as a semitone in 12-EDO or a
quarter tone in 24-EDO, press Shift-Alt/Opt-Up Arrow .

●

To transpose notes down a single octave division, such as a semitone in 12-EDO or a
quarter tone in 24-EDO, press Shift-Alt/Opt-Down Arrow .
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●

To transpose notes up an octave, press Ctrl/Cmd-Alt/Opt-Up Arrow .

●

To transpose notes down an octave, press Ctrl/Cmd-Alt/Opt-Down Arrow .

●

Click and drag them upwards/downwards.

RESULT
The selected notes are transposed according to their new pitch positions in the piano roll editor.
NOTE
●

This also affects how the selected notes are notated in any relevant score and part layouts.

●

When using the keyboard, you can both transpose and move notes in the piano roll editor in
the same action. When using the mouse, you must release the mouse between transposing
and moving.

RELATED LINKS
Moving notes in the event display on page 506
Equal Division of the Octave (EDO) on page 848
Play toolbox on page 496
Enabling independent voice playback on page 543

Deleting notes in the event display
You can delete notes in the event display in Play mode. This also removes notes from any
relevant score and part layouts.
NOTE
When instrument tracks have independent voice playback enabled, only notes in the currently
selected voice appear in the piano roll editor. Selecting All voices from the Voices menu in the
track header shows all notes belonging to the corresponding instrument.

PROCEDURE
1.

Optional: If you want to delete notes from pitched instruments, expand those instrument
tracks.

2.

Optional: For instrument tracks with independent voice playback enabled, select one of the
following from the Voices menu in the track header:
●

If you want to delete notes from one voice only, select that voice.

●

If you want to delete notes from multiple voices, select All voices.

3.

Press E to select Erase.

4.

Delete notes in any of the following ways:
●

Click individual notes.

●

Make a marquee selection to delete multiple notes at once.
NOTE
You can only make marquee selections on a single instrument, including percussion
instruments in percussion kits.

RESULT
The notes you click or include in a marquee selection are deleted.
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TIP
You can also delete notes by selecting Object Selection in the Play toolbox, then selecting the
notes you want to delete and pressing Backspace or Delete .

RELATED LINKS
Selecting multiple items using marquee selections on page 321
Enabling independent voice playback on page 543

Zooming in/out of tracks in the event display
You can change the zoom level in the tracks in the event display to make notes appear larger/
smaller. This does not affect the height of tracks.
PROCEDURE
●

Change the zoom in any of the following ways:
●

To make notes appear wider, press Ctrl/Cmd-= or Z .

●

To make notes appear narrower, press Ctrl/Cmd-- or X .

●

To make notes appear taller, Shift -click and drag upwards on the piano keyboard on the
left.

●

To make notes appear shorter, Shift -click and drag downwards on the piano keyboard
on the left.

●

To make notes appear wider and taller, spread two fingers outwards on a touchpad.

●

To make notes appear narrower and shorter, pinch two fingers together on a touchpad.

●

To make notes appear wider, click and drag downwards in the ruler.

●

To make notes appear narrower, click and drag upwards in the ruler.

RELATED LINKS
Changing the height of tracks on page 539

Tracks
Tracks are rows in the event display that represent time horizontally from left to right. They allow
you to control multiple musical elements in a project simultaneously but independently of each
other.
The term was established when audio mixing was done on tapes, and multitracking allowed
separate elements of the music to be recorded and edited independently of each other before
being combined into the final piece of music.
In modern programs, such as Cubase, tracks can contain many types of sounds, including audio
recordings and software instruments. Tracks containing audio recordings often display the
waveform of the audio, while tracks containing software instruments often display the pitches as
rectangular note events positioned horizontally in time and vertically in pitch on a piano roll.
Dorico Pro provides the following types of tracks in the event display in Play mode:
Instrument tracks
Display the notes belonging to the instrument in a piano roll editor or drum editor,
depending on the type of instrument. Each instrument in the project has its own
instrument track, including when a single player holds multiple instruments.
Each instrument track also has its own dynamics lane, velocity lane, automation lane,
and playing techniques lane.
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Time track
Displays tempo changes in the flow, including tempo marks input in Write mode as
well as tempo changes input in the Time track.
Chords track
Displays any chord symbols in the flow.
Markers track
Displays any markers in the flow, including their text.
Video track
Shows any video regions in the flow, including their file names.
RELATED LINKS
Event display on page 503
Time track on page 530
Chords track on page 535
Markers track on page 537
Video track on page 538
Expanding/Collapsing tracks on page 539

Instrument tracks
Instrument tracks allow you to view, input, and edit notes belonging to the corresponding
instrument. Notes are displayed on a piano roll editor or drum editor, depending on the type of
instrument.
Each instrument in the project has its own instrument track in the event display in Play mode,
including when a single player holds multiple instruments. Instrument tracks are labeled using
the full instrument name set for each instrument.
Instruments are automatically assigned a track color when you add them in Setup mode, so that
you can tell them apart more easily in Play mode. This color appears around track disclosure
arrows, as a strip on expanded instrument tracks, and is used for notes in the event display and
events in lanes.

Each instrument track comprises the following:
1

Track height adjuster
Allows you to change the height of the track by clicking and dragging its bottom corner.

2

Track disclosure arrow/Color strip
The track disclosure arrow allows you to expand/collapse the track. The color strip displays
the color assigned to the track. This color is also used for notes in the piano roll editor/drum
editor, colored regions on collapsed instrument tracks, and events in the track’s lanes.
●

Collapsed instrument tracks show colored regions in the event display where the
instrument has notes. You cannot select or move colored regions.
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●
3

Expanded instrument tracks show notes in either a piano roll editor or drum editor,
depending on the instrument type.

Track name
Shows the name of the track. Instrument tracks use the full instrument name set in the Edit
Instrument Names dialog for the instrument.

4

Track header
Contains appropriate options for instrument tracks, such as VST or MIDI port/channel
menus.

5

Piano roll editor/Drum editor
Displays notes belonging to the instrument in either a piano roll editor or drum editor,
depending on the instrument type.

Instrument track headers

Each instrument track header contains the following:
1

Enable independent playback of voices
Allows you to enable/disable independent voice playback for the instrument track. When
enabled, Dorico Pro automatically loads enough additional endpoints, and additional plug-in
instances if necessary, to accommodate all voices belonging to the instrument.

2

Voices menu
Allows you to select individual voices or all voices belonging to the instrument. Only available
when independent voice playback is enabled. Selecting different voices affects which notes
appear in the piano roll editor or drum editor.

3

Set for This Flow/Set for All Flows
Allows you to determine whether changing the endpoint of the selected voice affects only its
endpoint in the current flow or in all flows in the project. This selection only applies once to
the changes you make immediately after choosing either Set for This Flow or Set for All
Flows.

4

Plug-in instance menu
Allows you to select a VST or MIDI instrument plug-in instance to use for the instrument
track or selected voice. Not available when independent voice playback is enabled and All
voices is selected.

5

Edit Instrument
Opens the corresponding VST or MIDI instrument, which allows you to edit its settings.

6

Port menu

512
Dorico Pro 3.1.10

Play mode
Tracks
Allows you to change the endpoint to which the instrument or voice is assigned by selecting
the port you want to use when using a plug-in that has multiple ports of 16 channels. Not
available when independent voice playback is enabled and All voices is selected.
7

Channel menu
Allows you to change the endpoint to which the instrument or voice is assigned by selecting
the channel in the selected VST or MIDI instrument that you want to use for the instrument
track. Not available when independent voice playback is enabled and All voices is selected.

8

Show the dynamics lane
Hides/Shows the dynamics lane below the instrument track. Not available when independent
voice playback is enabled and All voices is selected.

9

Show the MIDI note velocity editor
Hides/Shows the velocity lane below the instrument track.

10 Show the automation lane
Hides/Shows the automation lane below the instrument track. Not available when
independent voice playback is enabled and All voices is selected.
11 Show the playing techniques lane
Hides/Shows the playing techniques lane below the instrument track. Not available when
independent voice playback is enabled and All voices is selected.
RELATED LINKS
Expanding/Collapsing tracks on page 539
Event display on page 503
Piano roll editor on page 504
Drum editor on page 505
Playing techniques lanes on page 529
Automation lanes on page 523
Player, layout, and instrument names on page 139
Changing instrument names on page 144
Endpoint Setup dialog on page 567
Enabling independent voice playback on page 543
Assigning instruments/voices to endpoints on page 571

Dynamics lanes
Dynamics lanes allow you to view, input, and edit the dynamics that apply to the corresponding
instrument/voice. Each instrument track has its own dynamics lane that you can show in the
event display.
●

You can hide/show the dynamics lane for an instrument track/voice by clicking Show the
dynamics lane in the instrument track header.

NOTE
For instrument tracks with independent voice playback enabled, you can only show the
dynamics lane when a single voice is selected. You cannot show the dynamics lane for All
voices.
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Dynamics lane below an instrument track

Dynamics lanes comprise the following:
1

Lane height adjuster
Allows you to change the height of the lane by clicking and dragging its bottom corner.

2

Show the dynamics lane
Hides/Shows the dynamics lane. This button is located in the track header for the
corresponding instrument track.

3

Lane header
Shows the name of the lane.

4

Reference lines
Indicate the vertical positions of the most common dynamic levels. The maximum range of
dynamic levels is from 8 to -8, loudest to quietest.

5

●

Top line: Dynamic level 3, equivalent to the dynamic 

●

Middle line: Dynamic level 0, equivalent to the dynamic 

●

Bottom line: Dynamic level -3, equivalent to the dynamic 

Dynamic event
An immediate change in dynamic, input either in Write mode or using the Draw tool in the
dynamics lane. Immediate dynamic events comprise a single point that is constant by
default.

6

Dynamic text
Shows the text of the corresponding dynamic, if applicable, to help you identify different
dynamics and orientate yourself within the flow. This is also useful when identifying whether
points represent dynamics input in Write mode or were input directly in the dynamics lane,
as the points of dynamics input in Write mode function differently, for example, when
moving or deleting dynamic points.

7

Selected dynamic point
The currently selected dynamic point appears larger and highlighted.
TIP
Clicking and dragging dynamic points in the dynamics lane causes a read-out to appear
temporarily, showing their dynamic level.

8

Dynamic event region
A highlighted region that contains multiple dynamic points, input by clicking and dragging in
a single motion with the Draw or Line tools in the dynamics lane. When you use the Draw
tool, points within a dynamic event region are constant by default. When you use the Line
tool, dynamic event regions have a linear point at the start and a constant point at the end.
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NOTE
Dynamic event regions that you input in the dynamics lane override default playback
adjustments for dynamics, such as humanization and increased dynamics for notes with
accents. However, the dynamic curve setting still applies to dynamic event regions.
9

Gradual dynamic
A smooth change in dynamic between two dynamic points, representing gradual dynamics
input in Write mode. Gradual dynamics have a linear point at the start, a constant point at
the end, and a highlighted region. Messa di voce gradual dynamic events have an additional
linear point in the middle.
NOTE
Default playback adjustments for dynamics, such as humanization and increased dynamics
for notes with accents, still apply to notes within gradual dynamics that you input in Write
mode.

10 Combined/Force dynamic
A highlighted region that contains multiple dynamic points, representing combined or force
dynamics input in Write mode, such as  and . Combined/Force dynamics have multiple
points to control their envelopes. Combined dynamics have three points, while force
dynamics have four points.
NOTE
Because the points of combined/force dynamics correspond to parameters of their
envelopes, they function differently than other dynamic points. For example, if you change
the value of the second point of a force dynamic, the third point also moves because it
controls the duration of the second point.

RELATED LINKS
Making dynamic points constant/linear on page 517
Dynamics on page 760
Types of dynamics on page 760
Gradual dynamics on page 772
Input methods for dynamics on page 241
Play toolbox on page 496
Rhythmic grid on page 166
Enabling independent voice playback on page 543

Showing dynamics lanes
You can show the dynamics lane for each instrument track independently.
PROCEDURE
1.

Expand the instrument tracks whose dynamics lanes you want to show.

2.

Optional: For instrument tracks with independent voice playback enabled, select a voice from
the Voice menu.

3.

In each instrument track header, click Show the dynamics lane.

515
Dorico Pro 3.1.10

Play mode
Tracks
RESULT
The dynamics lane for each instrument track is shown when the button is highlighted. For
instrument tracks with independent voice playback enabled, the dynamics lane shows dynamics
for the currently selected voice only.
TIP
You can hide dynamics lanes by clicking Show the dynamics lane again so the button is not
highlighted.

Inputting dynamic points
You can input dynamic points, including gradual dynamic events, in the dynamics lane for each
instrument track. Dynamic points input in dynamics lanes do not appear in layouts.
PREREQUISITE
The dynamics lane is shown for each instrument to which you want to add dynamic points.
PROCEDURE
1.

2.

Select one of the following tools, depending on the type of dynamic points you want to input:
●

To input single dynamic points, or dynamic event regions containing multiple dynamic
points at regular intervals, select Draw by pressing D or clicking Draw in the Play
toolbox.

●

To input gradual dynamic events, select Line by clicking Line in the Play toolbox.

Input dynamic points in one of the following ways:
●

To input single dynamic points, click in the dynamics lane at each position where you
want a dynamic point.

●

To input a dynamic event region containing multiple dynamic points at regular intervals,
click and drag in a single motion in the dynamics lane.

●

To input gradual dynamic events, click and drag in the dynamics lane from where you
want the gradual dynamics event to start to where you want it to end.

RESULT
Dynamic points are input. If you used the Draw tool, separate dynamic points are input at each
position you clicked. If you clicked and dragged in a single motion using the Draw tool, dynamic
points are input at sixteenth note intervals, or at smaller intervals if the rhythmic grid resolution
is finer than sixteenth notes. If you used the Line tool, two dynamic points are input, one at each
end of the range.
By default, dynamic points input using the Draw tool are constant while gradual dynamic events
have a linear point at the start and a constant point at the end.
Gradual dynamic events and dynamic event regions appear with highlighted regions in the
dynamics lane.
Dynamic points input in dynamics lanes affect playback but are not shown in layouts.
NOTE
Inputting dynamic points/events at the positions of dynamics input in Write mode overrides
default playback adjustments for those dynamics. Single dynamic points only override the
dynamic level. Dynamic event regions also override, for example, humanization and increased
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dynamics for notes with accents. However, the dynamic curve setting still applies to dynamic
event regions.

RELATED LINKS
Play toolbox on page 496
Moving dynamic points on page 519
Input methods for dynamics on page 241

Making dynamic points constant/linear
You can make individual dynamic points constant or linear after they have been input, for
example, if you want to make constant points that you input by clicking and dragging using the
Draw tool linear so they have smooth transitions between them.
By default, dynamic points you input in the dynamics lane are constant when you use the Draw
tool and linear at the start when you use the Line tool.
NOTE
These steps do not apply to the points of dynamics input in Write mode.
PREREQUISITE
The dynamics lane is shown for each instrument whose dynamic points you want to make
constant/linear.
PROCEDURE
1.

Press S to select Object Selection.

2.

Select the dynamic points you want to make constant/linear in one of the following ways:
●

Click a single dynamic point.

●

Make a marquee selection around multiple dynamic points.

NOTE
You can only make dynamic points constant/linear in a single dynamics lane at a time.
3.

Right-click in the dynamics lane and choose one of the following options from the context
menu:
●

To make the selected points constant, choose Make Points Constant.

●

To make the selected points linear, choose Make Points Linear.

RESULT
The selected dynamic points become constant or linear. Constant points appear as squares with
short horizontal lines extending to their right, indicating that their value continues. Linear points
appear as circles.
The value line always appears horizontal after constant points. The value line appears angled
after linear points if the next point has a different value, indicating a smooth transition between
the points.
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EXAMPLE

Constant points in a dynamics lane

Linear points in a dynamics lane

Copying and pasting dynamic points
You can copy and paste dynamic points, including to other dynamics lanes and repeating them
directly after themselves in the same dynamics lane.
PREREQUISITE
The dynamics lane is shown for each instrument whose dynamic points you want to copy/paste.
PROCEDURE
1.

Press S to select Object Selection.

2.

Select the dynamic points you want to copy in one of the following ways:
●

Click a single dynamic point.

●

Make a marquee selection around multiple dynamic points.

NOTE
You can only copy and paste dynamic points in a single dynamics lane at a time.
3.

Copy the selected dynamic points in any of the following ways:
●

Press Ctrl/Cmd-C .

●

Choose Edit > Copy. You can also choose this option from the context menu.

4.

Move the playhead to the position to which you want to paste the selected dynamic points.

5.

Paste the selected dynamic points in any of the following ways:
●

Select the header of the dynamics lane into which you want to paste them and press
Ctrl/Cmd-V .

●

Right-click in the dynamics lane into which you want to paste them and choose Paste
from the context menu.

RESULT
The selected dynamic points are copied to the selected positions and dynamics lanes without
deleting them from their original positions.
NOTE
●

All the points of dynamics input in Write mode are copied, even if you only selected a single
point.

●

You can also repeat selections of two or more dynamic points immediately after themselves
by pressing R . Each repetition starts at the same position as the last point in the previous
repetition. However, you cannot repeat single dynamic points or the points of immediate,
combined, or force dynamics input in Write mode.
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RELATED LINKS
Moving the playhead on page 540
Copying dynamics on page 768

Moving dynamic points
You can move individual dynamic points, including moving them upwards and downwards to
change their values and therefore their dynamic level. For example, if you want to adjust the
volume of specific existing dynamics.
PREREQUISITE
The dynamics lane is shown for each instrument whose dynamic points you want to move.
PROCEDURE
1.

Press S to select Object Selection.

2.

Select the dynamic points you want to move in one of the following ways:
●

Click a single dynamic point.

●

Make a marquee selection around multiple dynamic points.

NOTE

3.

●

To move dynamics input in Write mode rhythmically, select only their start point,
including for gradual dynamics and combined/force dynamics that have multiple points.
We recommend only moving one dynamic rhythmically at a time.

●

We recommend that you select either only points of dynamics input in Write mode or
only points input in the dynamics lane.

●

You can only move dynamic points in a single dynamics lane at a time.

Move the selected dynamic points in any of the following ways:
●

To move points input in the dynamics lane to the right/left only, Ctrl/Cmd -click and
drag them to the right/left.

●

To move points input in the dynamics lane upwards/downwards only, Ctrl/Cmd -click
and drag them upwards/downwards.
NOTE
●

If you want to move dynamic points upwards/downwards by smaller increments,
you can press Alt when dragging.

●

You cannot move dynamic points beyond other existing dynamic points during the
same action when using the mouse. You must release the mouse before reselecting
the dynamic point and move it further.

●

To move a single dynamic input in Write mode to the next notehead on the staff, press
Alt/Opt-Right Arrow .

●

To move a single dynamic input in Write mode to the previous notehead on the staff,
press Alt/Opt-Left Arrow .

●

To move points of dynamics input in Write mode to the right according to the current
rhythmic grid resolution, press Ctrl/Cmd-Alt/Opt-Right Arrow .

●

To move points of dynamics input in Write mode to the left according to the current
rhythmic grid resolution, press Ctrl/Cmd-Alt/Opt-Left Arrow .
NOTE
You can only move dynamics according to the current rhythmic grid resolution when
multiple dynamics are selected.
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RESULT
The selected dynamic points are moved to new positions. Moving them to the right/left affects
their rhythmic positions. Moving them upwards/downwards affects their dynamic level.
Moving the end points of gradual dynamics to the right/left lengthens/shortens the
corresponding gradual dynamics rhythmically. Their notated length is automatically updated in
all applicable layouts.
NOTE
●

Moving dynamic points for linked dynamics affects all linked dynamics.

●

If a single dynamic input in Write mode passes over another dynamic input in Write mode as
part of its move, the existing one is unaffected as multiple dynamics can exist at the same
rhythmic position. However, if you move multiple dynamics input in Write mode together,
any existing dynamics input in Write mode they pass over are deleted.
You can undo this action, but any dynamics deleted in the process are only restored if you
moved dynamics using the keyboard.

RELATED LINKS
Gradual dynamics on page 772
Lengthening/Shortening gradual dynamics and groups of dynamics on page 773
Moving dynamics rhythmically on page 763
Linked dynamics on page 783

Deleting dynamic points
You can delete individual or multiple dynamic points.
PREREQUISITE
The dynamics lane is shown for each instrument whose dynamic points you want to delete.
PROCEDURE
1.

Press E to select Erase.

2.

Delete dynamic points in any of the following ways:
●

Click each dynamic point you want to delete.

●

Make a marquee selection around the dynamic points you want to delete.

RESULT
The dynamic points you click or include in a marquee selection are deleted. Deleting points that
overrode dynamics that you input in Write mode reverts those dynamics to their default points.
Deleting the points of dynamics input in Write mode also deletes the corresponding dynamics.
TIP
You can also delete dynamic points that you input in the dynamics lane by selecting Object
Selection in the Play toolbox, then selecting the dynamic points you want to delete and pressing
Backspace or Delete .

RELATED LINKS
Showing dynamics lanes on page 515
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Velocity lanes
Velocity lanes allow you to view and edit the velocity of each note in the corresponding
instrument. Each instrument track has its own velocity lane that you can show in the event
display.
●

You can hide/show the velocity lane for an instrument track by clicking Show the MIDI note
velocity editor in the instrument track header.

Velocity is often used to control the dynamics of non-sustaining instruments.
Velocities appear as vertical bars in the velocity lane. Each note belonging to each instrument has
its own velocity. When multiple notes exist at the same rhythmic position, such as in chords, the
velocities for all notes appear stacked on top of each other. You can select an individual velocity
by selecting its corresponding note in the instrument track.

Velocity lane below an instrument track

Velocity lanes comprise the following:
1

Lane height adjuster
Allows you to change the height of the lane by clicking and dragging its bottom corner.

2

Show the MIDI note velocity editor
Hides/Shows the velocity lane. This button is located in the track header for the
corresponding instrument track.

3

Lane header
Contains the velocity value field.

4

Velocity value field
Displays the velocity value of the currently selected note. You can change this value by
changing the value in the value field.

5

Velocities whose value has been changed
When you have edited the velocity of notes, their velocities appear darker in the velocity
lane.

6

Selected note and velocity
The currently selected notes and their velocities all appear highlighted.

7

Velocities with default values
All notes have a default velocity value of 100.

RELATED LINKS
Play toolbox on page 496
Instrument tracks on page 511
Inputting notes on page 172
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Inputting notes in the event display on page 505

Showing velocity lanes
You can show the velocity lane for each instrument track independently.
PROCEDURE
1.

Expand the instrument tracks whose velocity lanes you want to show.

2.

In each instrument track header, click Show the MIDI note velocity editor.

RESULT
The velocity lane for each instrument track is shown when the button is highlighted.
TIP
You can hide velocity lanes by clicking Show the MIDI note velocity editor again so the button
is not highlighted.

Changing the velocity of notes
You can change the velocity for each note, including for a single note in a chord or create a
consistent increase/decrease in velocity across a range of notes.
PREREQUISITE
The velocity lane is shown for each instrument whose note velocity you want to change.
PROCEDURE
1.

Select one of the following tools, depending on how you want to change velocities:
●

To change the velocity of one note at a time, select Object Selection by pressing S or
clicking Object Selection in the Play toolbox.

●

To change the velocity using free shapes, select Draw by pressing D or clicking Draw in
the Play toolbox.

●

To change the velocity using consistent slopes, select Line by clicking Line in the Play
toolbox.

2.

Optional: If you want to drag the velocity of a single note in a chord, select that note in the
piano roll editor. This also selects its velocity bar.

3.

Change the velocity in one of the following ways:
●

If you have Object Selection selected, click and drag the top of each velocity bar
upwards/downwards.

●

If you have Draw selected, click and draw any shape across the required range in the
velocity lane.

●

If you have Line selected, click and drag a line across the required range in the velocity
lane.
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RESULT
The velocity of the affected notes is changed. When using the Draw or Line tools, the velocities
of all notes within the range are updated when you release the mouse.

Removing changes to note velocity
You can remove changes you have made to the velocity of individual notes and reset them to
their default velocity.
PROCEDURE
1.

In the piano roll/drum editor, select the notes whose note velocity you want to reset.

2.

Choose Play > Reset Playback Overrides.

RESULT
Any changes you have made to the velocity of the selected notes are reset.
NOTE
This also resets any other playback overrides for the selected notes.

Automation lanes
Automation lanes allow you to view, input, and edit MIDI controller data that applies to the
corresponding instrument/voice. Each instrument track has its own automation lane that you can
show in the event display.
●

You can hide/show the automation lane for an instrument track/voice by clicking Show the
automation lane in the instrument track header.

NOTE
For instrument tracks with independent voice playback enabled, you can only show the
automation lane when a single voice is selected. You cannot show the automation lane for
All voices.
●

You can change the MIDI controller whose data is displayed in the automation lane by
selecting the controller from the menu in the automation lane track header.

Automation lane below an instrument track
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Automation lanes comprise the following:
1

Lane height adjuster
Allows you to change the height of the lane by clicking and dragging its bottom corner.

2

Lane header

3

Show the automation lane

Contains the MIDI controller menu and MIDI value field.
Hides/Shows the automation lane. This button is located in the track header for the
corresponding instrument track.
4

MIDI Controller menu
Allows you to select the MIDI controller whose automation data you want to view and edit in
the automation lane. Controllers that already contain automation data are shown with an
asterisk beside their name in the menu.

5

Automation value field
Displays the value of the currently selected automation point. You can change this value by
changing the value in the value field. The available range depends on the type of controller.
For example, MIDI CCs have values between 0 and 127.

6

Automation event region
A highlighted region that contains multiple automation points with smooth transitions
between each event, input by clicking and dragging in a single motion with the Draw tool in
the automation lane. By default, automation points within a region are linear and the last
point is constant.

7

Gradual automation event
A smooth change in value between two automation points, input using the Line tool.
Gradual automation events have a linear point at the start, a constant point at the end, and a
highlighted region.

8

Automation point
A single change to the automation value, input using the Draw tool. Automation points are
constant by default.

9

Selected automation point
The currently selected automation point appears larger and highlighted.
TIP
Clicking and dragging automation points in the automation lane causes a read-out to appear
temporarily, showing their value.

Although only a single automation lane can be displayed, it is possible to create data for multiple
MIDI controllers in the same lane.
Automation data is included when exporting MIDI files.
RELATED LINKS
Play toolbox on page 496
Instrument tracks on page 511
Making automation points constant/linear on page 526
Exporting MIDI on page 84

Showing automation lanes
You can show the automation lane for each instrument track independently.
PROCEDURE
1.

Expand the instrument tracks whose automation lanes you want to show.
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2.

Optional: For instrument tracks with independent voice playback enabled, select a voice from
the Voice menu.

3.

In each instrument track header, click Show the automation lane.

RESULT
The automation lane for each instrument track is shown when the button is highlighted. For
instrument tracks with independent voice playback enabled, the automation lane shows
automation for the currently selected voice only.
TIP
You can hide automation lanes by clicking Show the automation lane again so the button is not
highlighted.

Inputting automation data
You can input automation data for multiple MIDI controllers, including pitch bend, in the
automation lane for each instrument track.
PREREQUISITE
The automation lane is shown for each instrument to which you want to add automation.
PROCEDURE
1.

In each automation lane header, select the MIDI controller into which you want to input
automation from the MIDI Controller menu.

2.

Select one of the following tools, depending on the type of automation you want to input:

3.

●

To input single automation points, or automation event regions containing multiple
automation points at regular intervals, select Draw by pressing D or clicking Draw in
the Play toolbox.

●

To input gradual automation events, select Line by clicking Line in the Play toolbox.

Input automation in one of the following ways:
●

To input single automation points, click in the automation lane at each position where
you want an automation point.

●

To input an automation event region containing multiple automation points at regular
intervals, click and drag in a single motion in the automation lane.

●

To input gradual automation events, click and drag in the automation lane from where
you want the gradual automation event to start to where you want it to end.

NOTE
When you first start inputting pitch bend data, the horizontal line in the middle of the
automation lane represents the unmodified pitch.

RESULT
Automation is input for the selected MIDI controller. If you used the Draw tool, separate
automation points are input at each position you clicked. If you clicked and dragged in a single
motion using the Draw tool, automation points are input at sixteenth note intervals, or at
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smaller intervals if the rhythmic grid resolution is finer than sixteenth notes. If you used the Line
tool, two automation points are input, one at each end of the range.
By default, single automation points are constant, automation points in regions are linear, the
last automation point in regions is constant, and gradual automation events have a linear point
at the start and a constant point at the end.
Gradual automation events and automation event regions appear with highlighted regions in the
automation lane.
RELATED LINKS
Moving automation points on page 528

Making automation points constant/linear
You can make individual automation points constant or linear after they have been input, for
example, if you want to make constant points linear so they have smooth transitions between
them.
By default, automation points are constant when you input them separately and linear when you
click and drag them in a single motion. The last automation point in a clicked and dragged region
is constant.
PREREQUISITE
The automation lane is shown for each instrument whose automation points you want to make
constant/linear.
PROCEDURE
1.

In the automation lane header, select the MIDI controller whose automation points you want
to make constant/linear from the MIDI Controller menu.

2.

Press S to select Object Selection.

3.

Select the automation points you want to make constant/linear in one of the following ways:
●

Click a single automation point.

●

Make a marquee selection around multiple automation points.

NOTE
You can only make automation points constant/linear in a single automation lane at a time.
4.

Right-click in the automation lane and choose one of the following options from the context
menu:
●

To make the selected points constant, choose Make Points Constant.

●

To make the selected points linear, choose Make Points Linear.

RESULT
The selected automation points become constant or linear. Constant points appear as squares
with short horizontal lines extending to their right, indicating that their value continues. Linear
points appear as circles.
The value line always appears horizontal after constant points. The value line appears angled
after linear points if the next event has a different value, indicating a smooth transition between
the points.
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EXAMPLE

Constant points in an automation lane

Linear points in an automation lane

Copying and pasting automation points
You can copy and paste automation points, including to other automation lanes and repeating
them directly after themselves in the same automation lane.
PREREQUISITE
The automation lane is shown for each instrument whose automation points you want to copy/
paste.
PROCEDURE
1.

In the automation lane header, select the MIDI controller whose automation points you want
to copy from the MIDI Controller menu.

2.

Press S to select Object Selection.

3.

Select the automation points you want to copy in one of the following ways:
●

Click a single automation point.

●

Make a marquee selection around multiple automation points.

NOTE
You can only copy and paste automation points in a single automation lane at a time.
4.

Copy the selected automation points in any of the following ways:
●

Press Ctrl/Cmd-C .

●

Choose Edit > Copy. You can also choose this option from the context menu.

5.

Move the playhead to the position to which you want to paste the selected automation
points.

6.

Paste the selected automation points in any of the following ways:
●

Select the header of the automation lane into which you want to paste them and press
Ctrl/Cmd-V .

●

Right-click in the automation lane into which you want to paste them and choose Paste
from the context menu.

RESULT
The selected automation points are copied to the selected positions and automation lanes
without deleting them from their original positions.
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NOTE
You can also repeat automation points immediately after themselves by selecting them and
pressing R . In each repetition, the first point in the selection replaces the last point in the
automation lane.

RELATED LINKS
Showing automation lanes on page 524
Moving the playhead on page 540
Copying and pasting items on page 337

Moving automation points
You can move individual automation points, including moving them upwards and downwards to
change their values.
PREREQUISITE
The automation lane is shown for each instrument whose automation points you want to move.
PROCEDURE
1.

In the automation lane header, select the MIDI controller whose automation points you want
to move from the MIDI Controller menu.

2.

Press S to select Object Selection.

3.

Select the automation points you want to move in one of the following ways:
●

Click a single automation point.

●

Make a marquee selection around multiple automation points.

NOTE
You can only move automation points in a single automation lane at a time.
4.

Move the selected automation points in any of the following ways:
●

To move them to the right/left only, Ctrl/Cmd -click and drag them to the right/left.

●

To move them upwards/downwards only, Ctrl/Cmd -click and drag them upwards/
downwards.
TIP
●

If you want to move automation points upwards/downwards by smaller increments,
you can press Alt when dragging.

●

You cannot move automation points beyond other existing automation points
during the same action when using the mouse. You must release the mouse before
reselecting the automation point and move it further.

Deleting automation points
You can delete individual or multiple automation points.
PREREQUISITE
The automation lane is shown for each instrument whose automation points you want to delete.
PROCEDURE
1.

In the automation lane header, select the MIDI controller whose automation points you want
to delete from the MIDI Controller menu.
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2.

Press E to select Erase.

3.

Delete automation points in any of the following ways:
●

Click each automation point you want to delete.

●

Make a marquee selection around the automation points you want to delete.

RESULT
The automation points you clicked or included in a marquee selection are deleted.
TIP
You can also delete automation points by selecting Object Selection in the Play toolbox, then
selecting the automation points you want to delete and pressing Backspace or Delete .

Playing techniques lanes
Playing techniques lanes display where you have input playing techniques for the corresponding
instrument. Each instrument track has its own playing techniques lane that you can show in the
event display.
●

You can hide/show the playing techniques lane for an instrument track/voice by clicking
Show the playing techniques lane in the instrument track header.

NOTE
For instrument tracks with independent voice playback enabled, you can only show the
playing techniques lane when a single voice is selected. You cannot show the playing
techniques lane for All voices.

Playing techniques lane below an instrument track

Playing techniques lanes comprise the following:
1

Lane height adjuster
Allows you to change the height of the lane by clicking and dragging its bottom corner.

2

Lane header
Shows the name of the lane.

3

Show the playing techniques lane
Hides/Shows the playing techniques lane. This button is located in the track header for the
corresponding instrument track.

4

Playing technique regions
Display the playing technique that applies to notes in the region. You can hover your mouse
pointer over playing technique regions on the lane to see the following related information:
●

Playing technique/Playing technique combination used in the expression map

529
Dorico Pro 3.1.10

Play mode
Tracks
●

VST or MIDI instrument used for the region

●

Channel in the VST instrument used for the region

●

Expression map used for the region

NOTE
You cannot change playing techniques using this lane. You can only change them in Write mode.

RELATED LINKS
Instrument tracks on page 511
Event display on page 503
Expression maps on page 573
Enabling independent voice playback on page 543

Showing playing techniques lanes
You can show the playing techniques lane for each instrument track independently.
PROCEDURE
1.

Expand the instrument tracks whose playing techniques lanes you want to show.

2.

Optional: For instrument tracks with independent voice playback enabled, select a voice from
the Voice menu.

3.

In each instrument track header, click Show the playing techniques lane.

RESULT
The playing techniques lane for each instrument track is shown when the button is highlighted.
For instrument tracks with independent voice playback enabled, the playing techniques lane
shows playing techniques for the currently selected voice only.
TIP
You can hide playing techniques lanes by clicking Show the playing techniques lane again so
the button is not highlighted.

Time track
The Time track allows you to view and edit the tempo of your project, including inputting new
tempo changes. It appears above the top instrument track in the event display in Play mode, and
is one of the tracks you can hide/show.

The Time track comprises the following:
1

Track height adjuster
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Allows you to change the height of the track by clicking and dragging its bottom corner.
2

Track disclosure arrow
Allows you to expand/collapse the track.

3

Track name
Shows the name of the track.

4

Track header
Contains appropriate options for the track, such as the menu for the sound source for the
click.

5

Fixed tempo read-out
Displays the tempo that corresponds to the current mouse pointer position in the Time
track.

6

Absolute tempo change
An immediate change in tempo, input either in Write mode or using the Draw tool in the
Time track. Absolute tempo changes comprise a single constant point.

7

Tempo mark text
Shows the text of the corresponding tempo change, if applicable, to help you identify
different tempo marks and orientate yourself within the flow.

8

Gradual tempo change
A smooth change in tempo over time, either input in Write mode or using the Line tool in
the Time track. Gradual tempo changes have a linear point at the start, a constant point at
the end, and a highlighted region.

9

Selected tempo change
The currently selected tempo change appears larger and highlighted.
TIP
Clicking and dragging tempo changes in the Time track causes a read-out to appear
temporarily, showing their precise tempo.

Time track header

The Time track header contains the following:
1

Plug-in instance menu
Allows you to select a VST or MIDI instrument plug-in instance to use for the click.

2

Edit Instrument
Opens the corresponding VST or MIDI instrument, which allows you to edit its settings.

3

Port menu
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Allows you to change the endpoint to which the Time track is assigned by selecting the port
you want to use when using a plug-in that has multiple ports of 16 channels.
4

Channel menu
Allows you to change the endpoint to which the Time track is assigned by selecting the
channel in the selected VST or MIDI instrument that you want to use for the click.

5

Tempo
Displays the metronome mark value of the currently selected tempo change without decimal
places. You can change this value by changing the value in the value field.

Tempo changes input in the Time track in Play mode appear as signposts in Write mode by
default to avoid changing the appearance of the printed score. Signposts are not printed by
default, so if you want such tempo changes to be printed in the score as tempo marks, we
recommend that you show them.
All tempo changes input in the Time track are included when exporting MIDI files.
RELATED LINKS
Play toolbox on page 496
Rhythmic grid on page 166
Tempo marks on page 1203
Input methods for tempo marks on page 228
Changing the type and appearance of absolute tempo changes on page 1211
Signposts on page 335
Changing the click settings on page 207
Hiding/Showing tempo marks on page 1209
Hiding/Showing decimal places for metronome marks on page 1214
Exporting MIDI on page 84

Inputting tempo changes in the Time track
You can input tempo changes, including gradual tempo changes, in the Time track in Play mode.
Tempo changes input in the Time track do not appear in layouts, but instead are shown as
signposts.
PREREQUISITE
The Time track is shown and expanded.
PROCEDURE
1.

2.

Select one of the following tools, depending on the type of tempo change you want to input:
●

To input single absolute tempo changes, or multiple absolute tempo changes at regular
intervals, select Draw by pressing D or clicking Draw in the Play toolbox.

●

To input gradual tempo changes, select Line by clicking Line in the Play toolbox.

Input tempo changes in one of the following ways:
●

To input single absolute tempo changes, click in the Time track at each position where
you want a tempo change.

●

To input multiple absolute tempo changes at regular intervals, click and drag in the
Time track.

●

To input gradual tempo changes, click and drag in the Time track from where you want
the gradual tempo change to start to where you want it to end.
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TIP
The metronome value corresponding to the current vertical position of the mouse pointer is
displayed in the Time track header.

RESULT
Tempo changes are input. If you used the Draw tool, separate tempo changes are input at each
position you clicked. If you clicked and dragged in a single motion using the Draw tool, tempo
changes are input at eighth note intervals, or at smaller intervals if the rhythmic grid resolution is
finer than eighth notes. If you used the Line tool, two tempo changes are input, one at each end
of the range. The range appears with a highlighted region in the Time track.
This affects the speed of playback, but the tempo changes are not shown in layouts. Instead,
they appear as signposts.
Tempo changes are included when exporting MIDI files.
RELATED LINKS
Hiding/Showing tracks on page 539
Hiding/Showing tempo marks on page 1209
Signposts on page 335
Changing the rhythmic grid resolution on page 166

Moving tempo changes in the Time track
You can move tempo changes to new rhythmic positions in the Time track. This affects their
rhythmic position in all applicable layouts.
PREREQUISITE
The Time track is shown and expanded.
PROCEDURE
1.

Press S to select Object Selection.

2.

In the Time track, select the tempo changes you want to move in one of the following ways:
●

Click a single tempo change.

●

Make a marquee selection around multiple absolute tempo changes.

NOTE
For gradual tempo changes, you can only move a single point at a time.
3.

To move the selected tempo changes without changing their tempo, Ctrl/Cmd -click and
drag the selected tempo change, or one of the selected tempo changes, to the right/left.
NOTE
You cannot move tempo changes beyond other existing tempo changes during the same
move. Releasing the mouse causes the moved tempo change to replace the existing one.
You can then reselect it and move it further.

RESULT
The rhythmic positions of the selected tempo changes are changed. When you move multiple
selected absolute tempo changes, they maintain their positions relative to each other. This also
affects their rhythmic positions in any layouts in which they appear.
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AFTER COMPLETING THIS TASK
You can also move tempo changes vertically, which changes their tempo.
RELATED LINKS
Time track on page 530
Hiding/Showing tracks on page 539
Hiding/Showing tempo marks on page 1209
Selecting multiple items using marquee selections on page 321

Changing the tempo in the Time track
You can change the tempo of individual tempo changes in the Time track, expressed in beats per
minute.
PREREQUISITE
The Time track is shown and expanded.
PROCEDURE
1.

Press S to select Object Selection.

2.

In the Time track, select the tempo changes whose tempo you want to change in one of the
following ways:
●

Click a single tempo change.

●

Make a marquee selection around multiple absolute tempo changes.

NOTE
For gradual tempo changes, you can only change the tempo of a single point at a time.
3.

To change the tempo of the selected tempo changes without moving them rhythmically,
Ctrl/Cmd -click and drag the selected tempo change, or one of the selected tempo changes,
upwards/downwards.
A tempo read-out appears beside the mouse pointer, providing visual feedback of the
tempo.
TIP
If you want to change the tempo by smaller increments, you can press Alt when dragging.

RESULT
The tempo of the selected tempo changes is changed. This affects the speed of playback and the
displayed metronome mark of any tempo changes also shown in layouts.
TIP
You can also change the tempo of tempo changes by selecting them and changing the Tempo
value in the Time track header.

RELATED LINKS
Hiding/Showing tracks on page 539
Hiding/Showing decimal places for metronome marks on page 1214

534
Dorico Pro 3.1.10

Play mode
Tracks

Deleting tempo changes in the Time track
You can delete tempo changes in the Time track.
PREREQUISITE
The Time track is shown and expanded.
PROCEDURE
1.

Press E to select Erase.

2.

Delete tempo changes in any of the following ways:
●

Click each tempo change you want to delete.

●

Make a marquee selection around the tempo changes you want to delete.

RESULT
The tempo changes you click or include in a marquee selection are deleted. This also deletes
their corresponding tempo marks or tempo mark signposts from layouts.
TIP
You can also delete tempo changes by selecting Object Selection in the Play toolbox, then
selecting the tempo changes you want to delete and pressing Backspace or Delete .

RELATED LINKS
Selecting multiple items using marquee selections on page 321

Chords track
A Chords track is included in every project. You can assign the Chords track to its own endpoint
to hear any chords that you input into the score as chord symbols in playback.
The Chords track appears above the top instrument track in the event display, and is one of the
tracks you can hide/show.

The Chords track comprises the following:
1

Track height adjuster
Allows you to change the height of the track by clicking and dragging its bottom corner.

2

Track disclosure arrow
Allows you to expand/collapse the track.

3

Track name
Shows the name of the track.

4

Track header
Contains appropriate options for the track, such as the button that enables/disables chords
playback.

5

Chords
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Indicates where chord symbols exist in the flow and shows the chord symbol name.

Chords track header

The Chords track header contains the following:
1

Plug-in instance menu
Allows you to select a VST or MIDI instrument plug-in instance to use for chords playback.

2

Edit Instrument
Opens the corresponding VST or MIDI instrument, which allows you to edit its settings.

3

Enable Chords Playback
Allows you to include chords in, or exclude chords from, playback.

4

Port menu
Allows you to change the endpoint to which the Chords track is assigned by selecting the
port you want to use when using a plug-in that has multiple ports of 16 channels.

5

Channel menu
Allows you to change the endpoint to which the Chords track is assigned by selecting the
channel in the selected VST or MIDI instrument that you want to use for chords playback.
You can use an existing channel containing a sound already loaded in the project, or you can
use a new channel with a new sound loaded just for chords.
NOTE
●

You must assign a VST or MIDI instrument and a channel for the Chords track in order to
hear chords in playback.

●

If you manually load sounds into the channel you selected for your Chords track and
later add more instruments to your project, the sounds for the new instruments
overwrite the sounds you manually loaded in that channel.

RELATED LINKS
Chord symbols on page 695
Loading VST/MIDI instruments manually on page 500
Hiding/Showing tracks on page 539

Enabling chord symbol playback
You can include chord symbols in playback. They are played as sustained chords, with their
duration taken from the gap between one chord symbol and the next. Chord symbols input using
a MIDI keyboard use the same voicing as you used to input them, whereas chord symbols input
using a computer keyboard use a default voicing.
PREREQUISITE
The Chords track is shown.
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PROCEDURE
1.

In the Chords track header, click Enable Chords Playback.

2.

Optional: If you want to specify the sound used for chords playback, expand the Chords
track.

3.

In the Chords track header, select the endpoint you want using the Port and Channel
menus.

RELATED LINKS
Hiding/Showing tracks on page 539
Endpoints on page 566
Endpoint Setup dialog on page 567

Markers track
The Markers track allows you to view the markers in your project and input new ones. It appears
above the top instrument track in the event display in Play mode, and is one of the tracks you can
hide/show.

The Markers track comprises the following:
1

Track height adjuster
Allows you to change the height of the track by clicking and dragging its bottom corner.

2

Track header
Shows the name of the track and contains appropriate options.

3

Add Marker
Allows you to add a new marker at the current position of the playhead.

4

Markers
Show the position of each marker in the flow, including their text.

RELATED LINKS
Markers on page 1060
Videos on page 146
Hiding/Showing tracks on page 539
Editing marker text on page 1062

Inputting markers in the Markers track
You can input markers directly into the Markers track in Play mode.
PREREQUISITE
The Markers track is shown.
PROCEDURE
1.

Move the playhead to the time position where you want to input a marker.
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NOTE
You cannot input markers in negative time, such as when a video starts three bars into the
flow, causing the initial timecode of the flow to be in negative time.
2.

In the Markers track header, click Add Marker.

RESULT
A marker is input at the position of the playhead. It shows the default text “Marker”.
EXAMPLE

Marker in the Markers track

AFTER COMPLETING THIS TASK
You can change the text shown in the marker.
RELATED LINKS
Changing the start position of videos on page 148
Editing marker text on page 1062
Moving the playhead on page 540

Video track
The Video track shows where videos exist in the flow relative to the music. It appears above the
top instrument track in the event display in Play mode, and is one of the tracks you can hide/
show.

The Video track comprises the following:
1

Track height adjuster
Allows you to change the height of the track by clicking and dragging its bottom corner.

2

Track header
Shows the name of the track and contains appropriate options.

3

Show Video
Allows you to hide/show the Video window. This performs the same function as Show Video
in the toolbar.

4

Video file name
Shows the video file name and file extension.

5

Video region
Shows the position of the video file relative to the music and its length.

RELATED LINKS
Videos on page 146
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Adding videos on page 148
Hiding/Showing the Video window on page 149
Changing the start position of videos on page 148
Toolbar on page 43

Expanding/Collapsing tracks
You can expand/collapse tracks in Play mode individually, and you can expand/collapse all
instrument tracks in the current flow at the same time. Expanding tracks allows you to access
controls in track headers and to input and edit track contents, such as notes in the piano roll
editor and tempo changes in the Time track.
PROCEDURE
●

Expand/Collapse tracks in any of the following ways:
●

To expand/collapse an individual track, click its disclosure arrow.

●

To expand/collapse all instrument tracks, Ctrl/Cmd -click any instrument track
disclosure arrow.

Changing the height of tracks
You can change the height of all types of tracks at any time, for example, if you want a single
track to occupy more space in the event display temporarily so you can work on it in more detail.
PROCEDURE
●

Change the height of tracks in any of the following ways:
●

To make tracks taller, select them and press Shift-H .

●

To make tracks shorter, select them and press Shift-G .

●

Click and drag the bottom left corner of a single track upwards/downwards.
TIP
When the mouse pointer is in the correct position, it appears as a split arrow.

RELATED LINKS
Zooming in/out of tracks in the event display on page 510

Hiding/Showing tracks
You can hide/show the tracks that appear above the top instrument track in the event display in
Play mode.
By default, only the Time and Chords tracks are shown. If you have added at least one video to
one flow in the project, the Markers and Video tracks are also shown by default.
NOTE
You cannot hide/show player and instrument tracks.

PROCEDURE
●

Choose Play > Tracks > [track type].
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For example, choose Play > Tracks > Time Track to hide/show the Time track.
RESULT
The selected track type is shown when a tick appears beside its entry in the submenu, and
hidden when no tick appears.
RELATED LINKS
Tracks on page 510

Playhead
The playhead is a vertical line that moves during playback, showing the current rhythmic
position. It is also known as a “playback line”.
The playhead appears at all times in Play mode and during playback in other modes, and its
current is shown in both the Transport window and the mini transport in the toolbar. You can
also choose to show the playhead when playback is stopped in other modes.

The playhead in Play mode

Dorico Pro automatically keeps the playhead in view during playback by moving it along with the
music, but you can also move the playhead manually. Dorico Pro tries to keep systems in the
same place on the screen when it scrolls along with the playhead for consistency as you follow
your music.
NOTE
The playhead never appears in Print mode.

RELATED LINKS
Transport window on page 557
Mini transport on page 44

Moving the playhead
The playhead automatically moves along with the music during playback, but you can also move
the playhead manually in any mode.
You can move the playhead both when it is stopped and during playback, but not all methods of
moving the playhead work during playback.
By default, the playhead is only shown during playback but you can choose to show the playhead
at all times.
PROCEDURE
●

Move the playhead in any of the following ways:
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●

To move the playhead forwards, press Num + (plus on a numeric keypad).

●

To move the playhead backwards, press Num - (minus on a numeric keypad).

●

To move the playhead back to the start of the flow, press Num . (period on a numeric
keypad).

●

To move the playhead to the start of the earliest selected item, press Alt/Opt-P .

●

To move the playhead forwards by frames, press Ctrl/Cmd-Num + or Ctrl/Cmd-F9 .

●

To move the playhead backwards by frames, press Ctrl/Cmd-Num - or Ctrl/Cmd-F7 .

●

Click Fast Forward in the Transport window to navigate forwards.

●

Click Rewind in the Transport window to navigate backwards.

●

Click Rewind to Beginning of Flow in the Transport window to go back to the start of
the flow.

●

In Play mode, click the ruler at any position.
NOTE
You cannot click the ruler to move the playhead during playback.

RELATED LINKS
Transport window on page 557
Preferences dialog on page 62
Frame rates on page 151

Hiding/Showing the playhead
You can hide/show the playhead when playback is stopped, for example, to help line up your
music when working with timecodes and video. By default, the playhead is hidden when playback
is stopped, except in Play mode where it always appears.
PROCEDURE
1.

Press Ctrl/Cmd-, (comma) to open Preferences.

2.

Click Play in the page list.

3.

In the Playhead subsection, activate/deactivate Show playhead when stopped.

4.

Click Apply, then Close.

RESULT
The playhead is shown outside of playback when Show playhead when stopped is activated,
and hidden when it is deactivated.
NOTE
This does not apply to Play mode or Print mode. The playhead always appears in Play mode and
never appears in Print mode.
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Playing back music
You can listen to the music you have written from the beginning of your project or from a specific
point. You can also use the playback key commands in any mode.
PREREQUISITE
●

You have applied a playback template to the project that includes sounds for the instruments
in your project.

●

If you want to use different sounds for different voices, you have enabled independent voice
playback for those instruments.

PROCEDURE
1.

Start playback in one of the following ways:
●

To play back all instruments from the selection, select a single note and press P .

●

To play back all instruments from the selection, select a single note and choose Play >
Play From Selection.

●

To play back only a single staff, select multiple items on the staff and press P .
NOTE
This does not affect which channels are soloed or muted in Play mode.

●

To play back multiple staves, select items on multiple staves and press P .
NOTE
This does not affect which channels are soloed or muted in Play mode.

●

To continue playback from the playhead position, press Space or Enter .

●

To play back from the last playback start position, press Shift-Space . This works even if
you have since deselected the item at that position.

●

To play back from the start of the flow, press Shift-Alt/Opt-Space .

●

Click Play From Playhead Position in the Transport window.

●

Click Play From Selection in the Transport window.

●

Choose Play > Play From Playhead Position.

●

Choose Play > Play From Last Start Position.

●

Choose Play > Play From Start of Flow.

●

Choose Play > Play From Start of Project.

2.

Optional: Move the playhead during playback to later/earlier positions.

3.

Optional: To enable/disable the metronome click, click Click in the mini transport.

TIP
You can also sign a key command for enabling/disabling the metronome click during
playback on the Key Commands page in Preferences.
4.

Stop playback in any of the following ways:
●

Press Space or Enter or P .

●

Press Num 0 (0 on a numeric keypad).

●

Click Stop in the Transport window.
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TIP
If you notice a change in sound when stopping playback, you can deactivate Reset
controllers and send ‘all notes off’ when stopping playback on the Play page in
Preferences.

RELATED LINKS
Playback templates on page 558
Applying/Resetting playback templates on page 564
Enabling independent voice playback on page 543
Muting/Soloing tracks on page 544
Endpoint Setup dialog on page 567
Mini transport on page 44
Key Commands page in the Preferences dialog on page 63
Status bar on page 52
Preferences dialog on page 62

Enabling independent voice playback
By default, all voices belonging to a single instrument, including divisi staves, use the same
endpoint for playback. You can enable independent voice playback, for example, to hear the
different playing techniques in playback for a string divisi where some parts are pizzicato and
some parts are arco.
NOTE
You cannot enable independent voice playback for unpitched percussion kits.

PROCEDURE
1.

Expand the instrument tracks for which you want to enable independent voice playback.

2.

In each instrument track header, activate Enable independent playback of voices.

RESULT
Independent voice playback is enabled for each instrument. Dorico Pro automatically loads
enough additional channels, and additional plug-in instances if necessary, to accommodate all
voices belonging to the corresponding instrument project-wide.
Voices are automatically assigned to endpoints according to their order in the Voices menu.
Selecting an individual voice from the Voices menu shows only the corresponding notes in the
piano roll editor.
NOTE
For instrument tracks with independent voice playback enabled, you can only show dynamics,
automation, and playing techniques lanes when a single voice is selected.
AFTER COMPLETING THIS TASK
You can change the endpoints of each voice in each flow independently, for example, if some
voices in some flows require a solo sound instead of an ensemble one.
RELATED LINKS
Playback templates on page 558
Endpoints on page 566
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Instrument tracks on page 511
Dynamics lanes on page 513
Automation lanes on page 523
Playing techniques lanes on page 529
Piano roll editor on page 504
Assigning instruments/voices to endpoints on page 571

Muting/Soloing tracks
You can mute/solo individual tracks. This allows you to set fixed groups to sound in playback, for
example, if you only want to listen to certain groups of players at a time.
PROCEDURE
1.

In the toolbar, click Show Mixer to show the Mixer.

2.

In the Mixer, click the appropriate button at the top of each channel you want to mute/solo.
●

Mute

●

Solo

RESULT
Each track is muted/soloed and the corresponding buttons are enabled.
This affects which tracks play back until you change which tracks are muted/soloed, meaning you
do not have to reselect the tracks you want to hear each time. For example, if you have eight
tracks and solo four, only those four are played back. If you mute two tracks, those tracks are not
played back but the other six are played back.
NOTE
●

Soloing tracks automatically mutes all other tracks. If you solo a track that was muted, it is
automatically unmuted.

●

You can also play back only certain tracks/staves by selecting notes/items on each track/staff
you want to hear.

EXAMPLE

Mute when enabled

Solo when enabled

RELATED LINKS
Expanding/Collapsing tracks on page 539
Muting notes/items individually on page 546
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Muting/Soloing instruments
You can solo the currently selected instruments, which automatically mutes all other
instruments. This can be useful if you want to ensure only certain instruments are played back
while you are working on a specific section of a project.
PROCEDURE
1.

Select at least one note belonging to each instrument you want to solo. You can do this in
Write, Engrave, and Play modes.

2.

Press Alt/Opt-S .

RESULT
The selected instruments are soloed and all other instruments are muted by changing their
mute/solo states in the Mixer. This affects which instruments are muted/soloed until you
deactivate their mute/solo states.
TIP
You can also determine which staves are included in playback for each separate playback without
changing their states in the Mixer.

RELATED LINKS
Mixer on page 554

Deactivating mute/solo instrument states
You can deactivate the mute and solo states of all instruments in your project, for example, if you
want to hear all instruments in playback after soloing a small selection. You can do this in any
mode.
PROCEDURE
●

Deactivate mute/solo instrument states in the following ways:
●

To deactivate all mute instrument states, press Alt/Opt-U .

●

To deactivate all solo instrument states, press Shift-Alt/Opt-S .

●

In the Mixer, click Deactivate All Mute States.

●

In the Mixer, click Deactivate All Solo States.

RESULT
All instruments in the project have the corresponding state removed. For example, removing
both mute and solo instrument states reverts all instruments to their default state, causing all
instruments to be included in playback.
RELATED LINKS
Mixer on page 554
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Muting notes/items individually
You can mute individual notes and items to exclude them from playback without deleting them,
for example, to hear chords without their arpeggios, a passage with multiple dynamics at a
single volume level, or without tempo changes from tempo marks.
PROCEDURE
1.

In Write mode, select the notes/items you want to mute/suppress in playback.

2.

In the Properties panel, activate Suppress playback in the Common group.

Resetting changes to volume faders
You can reset changes you have made to volume faders in the Mixer back to their default level.
PREREQUISITE
The Mixer window is shown.
PROCEDURE
●

In the Mixer, Ctrl/Cmd -click each volume fader that you want to reset.

RELATED LINKS
Hiding/Showing the Mixer window on page 556
Mixer on page 554

Changing the tempo mode
You can switch the tempo mode at any time between using a single fixed tempo and following
tempo changes, for example, if you have a project with multiple tempo changes but want to use
a single fixed tempo when recording MIDI.
PROCEDURE
1.

2.

Change the tempo mode in any of the following ways:
●

In any mode, click Fixed Tempo Mode in the toolbar.

●

In Play mode, choose Play > Fixed Tempo Mode.

Optional: When Fixed Tempo Mode is active, change the metronome mark value by clicking
and dragging upwards/downwards on the Fixed Tempo Mode number in the toolbar.
TIP
If you want to change the metronome mark value by smaller increments, you can hold Shift
when clicking and dragging.

RESULT
In follow tempo mode, the tempo for playback and recording is set by tempo marks in the
project. Follow tempo mode is active when Fixed Tempo Mode in the toolbar appears
highlighted, and when no tick appears beside Fixed Tempo Mode in the Play menu.
In fixed tempo mode, the tempo for playback and recording is a single tempo, as determined by
the Fixed Tempo Mode metronome mark value. Fixed tempo mode is active when Fixed Tempo
Mode in the toolbar is not highlighted, and when a tick appears beside Fixed Tempo Mode in
the Play menu.
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EXAMPLE

Fixed Tempo Mode when fixed tempo mode is
active

Fixed Tempo Mode when follow tempo mode is
active

RELATED LINKS
Tempo marks on page 1203
Time track on page 530
MIDI recording on page 204
Playing back music on page 542

Changing the pre-roll duration
In Dorico Pro, pre-roll is the time added to playback before the first beat of the first bar in each
flow. You can change the pre-roll duration, for example, if some flows in your project start with
grace notes.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-P to open Playback Options.

2.

Click Timing in the page list.

3.

In the Flows section, change the value for Pre-roll before flow.
For example, for flows starting with a single grace note, 0.25 seconds is usually sufficient.

4.

Click Apply, then Close.

RESULT
The duration of the pre-roll before each flow in playback, measured in seconds, is changed.

Changing the playback tuning
You can change the tuning used for playback, based on the pitch of the A above middle C, for
example, if you want to hear your music played at the Baroque pitch of A=415 Hz.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-P to open Playback Options.

2.

Click Tuning in the page list.

3.

Change the value for Pitch of A4.

4.

Click Apply, then Close.

RESULT
The tuning of all notes in the project is changed, which affects their sounding pitch in playback.
TIP
The sample rate of the current playback device also affects the playback tuning.
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Repeats in playback
Dorico Pro supports the playback of repeat structures, including repeat endings, repeat barlines,
and repeat markers, provided all the correct jumps and sections are in place.
There is no limit to the number of repeat structures you can have in a single flow and still obtain
correct playback.
By default, Dorico Pro includes repeats in playback, except after repeat jumps, such as D.S. al
Coda. You can change both of these options on the Repeats page in Play > Playback Options.
During playback, the bars/beats and time displays in the mini transport and Transport window
reflect the current position of the playhead in repeat structures.
Dynamics and tempo marks are reflected in repeats. Repeats are also included in both audio and
MIDI exports.
RELATED LINKS
Transport window on page 557
Mini transport on page 44

Swing playback
Swing is a style of performance where equally-notated notes are played in a regular pattern of
alternating longer and shorter notes, which commonly entails eighth notes being played as a
quarter note triplet followed by an eighth note triplet.

A swing phrase with simplified straight notation

How the same phrase sounds with a 2:1 swing ratio

Swing playback allows you to hear the uneven rhythms you want whilst retaining their simplified
notation, including if the second eighth note beat is divided into two 16th notes. In Dorico Pro,
you can enable swing playback for your whole project, only for certain sections, and only for
individual instruments. You can also edit the default swing patterns to customize the rhythmic
feel you want in the Rhythmic Feel dialog. You can swing either eighth notes or 16th notes.
Based on academic research into the rendering of swing by musicians, swing patterns in Dorico
Pro are tempo-dependent by default. This means that the swing feels more pronounced at lower
tempos, and straighter at higher tempos. Rhythmic feels that produce the same swing ratio at all
tempos are also available in the Rhythmic Feel dialog.
RELATED LINKS
Enabling swing playback for specific sections/instruments on page 550
Rhythmic Feel dialog on page 552
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Swing ratios and rhythmic feels
Swing ratios express the strength of the swing using beat units. For example, a swing ratio of 2:1
means the first note in each pair is twice as long as the second, creating a triplet swing.
A swing ratio of 1:1 means the music is played straight, while a swing ratio of 5:1 means each
pair of notes is played as if they were sextuplets, with the first note in the pair lasting five
divisions and the second note lasting one.

Swing ratio 1:1

Swing ratio 5:1

The following rhythmic feels and swing ratios are provided by default in Dorico Pro:
2:1 swing 16ths (fixed)
Extends the first note in a pair of 16th notes to be twice as long as the second, creating
a strict triplet 2:1 ratio. This is also known as a “triplet swing”. This ratio is maintained
regardless of the tempo by default.
2:1 swing 8ths (fixed)
Extends the first note in a pair of eighth notes to be twice as long as the second,
creating a strict triplet 2:1 ratio. This is also known as a “triplet swing”. This ratio is
maintained regardless of the tempo by default.
3:1 swing 16ths (fixed)
Extends the first note in a pair of 16th notes to be three times as long as the second,
creating a dotted 16th-32nd ratio (dotted semiquaver-demisemiquaver). This ratio is
maintained regardless of the tempo by default.
3:1 swing 8ths (fixed)
Extends the first note in a pair of eighth notes to be three times as long as the second,
creating a dotted eighth-16th ratio (dotted quaver-semiquaver). This ratio is
maintained regardless of the tempo by default.
Heavy swing 16ths
Produces a tempo-dependent 16th note swing ratio of between 3:1 at low tempos and
1.5:1 at high tempos.
Heavy swing 8ths
Produces a tempo-dependent eighth note swing ratio of between 3:1 at low tempos
and 1.5:1 at high tempos.
Light swing 16ths
Produces a tempo-dependent 16th note swing ratio of between 1.5:1 at low tempos
and 1:1 at high tempos.
Light swing 8ths
Produces a tempo-dependent eighth note swing ratio of between 1.5:1 at low tempos
and 1:1 at high tempos.
Medium swing 16ths
Produces a tempo-dependent 16th note swing ratio of between 2:1 at low tempos and
1.5:1 at high tempos.
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Medium swing 8ths
Produces a tempo-dependent eighth note swing ratio of between 2:1 at low tempos
and 1.5:1 at high tempos.
Straight (no swing)
Produces no swing, that is, even eighth notes in the ratio 1:1 at all tempos.
You can change the swing ratio used project-wide, and you can also change the swing ratio used
for specific sections and for individual players. You can edit these settings and create your own
swing ratios in the Rhythmic Feel dialog.
RELATED LINKS
Rhythmic Feel dialog on page 552

Enabling swing playback project-wide
You can enable swing playback project-wide using any of the default swing ratios or custom
swing ratios you have created in the project.
PREREQUISITE
If you want to use a custom rhythmic feel for swing playback, you have created that custom
rhythmic feel.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-P to open Playback Options.

2.

Click Timing in the page list.

3.

In the Rhythmic Feel section, select the rhythmic feel you want from the Default rhythmic
feel menu.

4.

Click Apply, then Close.

RESULT
All pairs of either eighth notes or 16th notes in your project are played back with the selected
swing ratio, depending on the swing unit for the selected ratio. This includes if the second beat is
divided into two, such as two 16th notes in an eighth note swing.
RELATED LINKS
Playback Options dialog on page 502
Creating custom rhythmic feels for swing playback on page 552
Rhythmic Feel dialog on page 552

Enabling swing playback for specific sections/instruments
You can enable swing playback for specific sections in your project and for individual instruments
independently, for example, if you want only the soloist to swing for a twelve-bar section.
PROCEDURE
1.

In Write mode, select one of the following:
●

If you want to enable swing playback from a specific point onwards, select a single item
at the start of the bar where you want swing playback/a different rhythmic feel.

●

If you want to enable swing playback within a section then return to straight playback,
select multiple items that span the duration where you want swing playback/a different
rhythmic feel.
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NOTE
●

If you want to enable swing playback for a single instrument, select an item or items that
belong to that instrument only.

●

If you select an item in the middle of a bar, the rhythmic feel change only takes effect
from the start of the next bar.

2.

Press Shift-T to open the tempo popover.

3.

Enter the appropriate entry for rhythmic feel you want into the popover.
When you start entering a rhythmic feel into the tempo popover, a menu appears that shows
valid rhythmic feels containing the letters/words you enter, which you can select.

NOTE
If you do not enter the name of a rhythmic feel that exists in your project, the text you
entered into the popover is input as a tempo mark and does not enable swing playback.
4.

Input the rhythmic feel change and close the popover in one of the following ways:
●

To input a rhythmic feel change for all staves, press Return .

●

To input a rhythmic feel change only for the selected instrument, press Alt/Opt-Return .

RESULT
The rhythmic feel used for swing playback is changed from the start of the bar containing the
earliest selected item, or the start of the next bar if you selected an item in the middle of a bar. If
you selected multiple items, the rhythmic feel is automatically reset at the position of the last
selected item. If you pressed Alt/Opt-Return , the rhythmic feel change only applies to the
instrument on whose staff you selected an item. Rhythmic feels added to single instruments
apply to all staves belonging to those instruments.
A signpost appears showing the name of the rhythmic feel you input. It is shown above the top
staff in the system for rhythmic feel changes that apply to all staves, and directly above the top
staff for rhythmic feel changes that apply only to single instruments.
RELATED LINKS
Tempo popover on page 228

Deleting rhythmic feel changes
You can delete rhythmic feel changes you have enabled for specific sections or for individual
players only.
PREREQUISITE
Rhythmic change signposts are shown.
PROCEDURE
1.

In Write mode, select the signposts of the rhythmic changes you want to delete.

2.

Press Backspace or Delete .
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RESULT
The rhythmic changes are deleted. The playback of the affected staves returns to your projectwide settings until the next existing rhythmic change signpost, if applicable.
RELATED LINKS
Hiding/Showing signposts on page 336

Creating custom rhythmic feels for swing playback
You can create custom rhythmic feels that you can use for swing playback, for example, if you
want a swing ratio that is not included in the default rhythmic feels. You can create entirely new
rhythmic feels or rhythmic feels based on existing ones.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-P to open Playback Options.

2.

Click Timing in the page list.

3.

In the Rhythmic Feel section, click Edit to open the Rhythmic Feel dialog.

4.

Create a new rhythmic feel in one of the following ways:
●

To create an entirely new rhythmic feel, click New.

●

To create a new rhythmic feel based on an existing one, select the existing rhythmic feel
in the rhythmic feels list and click New from Selection.

5.

Enter a name for the rhythmic feel in the Name field.

6.

Move the Low tempo slider to the swing ratio you want.

7.

Optional: If you want the swing ratio of your custom rhythmic feel to vary according to the
tempo, activate Depends on tempo.

8.

Optional: If you activated Depends on tempo, change the bpm values for Low tempo
and/or High tempo.

9.

Optional: If you activated Depends on tempo, move the High tempo slider to the swing
ratio you want.

10. Choose one of the following for Swing unit:
●

8th (Quaver)

●

16th (Semiquaver)

11. Click OK to save your changes and close the dialog.
12. Click Apply, then Close.

Rhythmic Feel dialog
The Rhythmic Feel dialog allows you to edit the settings of the default rhythmic feels used for
swing playback and to create your own custom rhythmic feels.
●

You can open the Rhythmic Feel dialog by clicking Edit in the Rhythmic Feel section of the
Timing page in Play > Playback Options.
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Rhythmic Feel dialog

The Rhythmic Feel dialog contains the following options and sections:
1

Search field
Allows you to filter the rhythmic feels according to your entry.

2

Rhythmic feels list
Contains the rhythmic feels available for your project.
The action bar at the bottom of the list contains the following options:
●

New: Creates a new rhythmic feel with default values.

●

New from Selection: Creates a new rhythmic feel based on the selected one. Initially no
values are overridden but you can change the options for your new rhythmic feel.

●

Save as Default: Copies the selected rhythmic feel to your library so that it is available in
other projects.

●

Revert to Factory: Removes all your changes to the selected predefined rhythmic feels,
reverting them to the default factory settings.

●

Delete: Deletes the selected rhythmic feel.

NOTE
You cannot delete predefined rhythmic feels or any rhythmic feel that is currently used
in your project.
3

Name
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Allows you to enter a name for new rhythmic feels or edit the name of existing rhythmic
feels.
4

Depends on tempo
Controls whether the swing pattern uses the same ratio at all tempos or changes according
to the tempo.

5

●

When Depends on tempo is activated, the swing ratio varies according to the tempo. A
second slider appears for High tempo, allowing you to change the values for both Low
tempo and High tempo.

●

When Depends on tempo is deactivated, the swing ratio value of the single slider is
used at all tempos.

Low tempo
Sets the tempo at/below which the swing ratio changes, measured in quarter note beats per
minute. The swing ratio slider to the right controls the swing ratio used.

6

High tempo
Sets the tempo at/above which the swing ratio changes, measured in quarter note beats per
minute. When Depends on tempo is activated, the swing ratio slider to the right controls the
swing ratio used.

7

Swing ratio sliders
Allow you to set the swing ratio to be used below the set Low tempo and above the set High
tempo. Their possible ranges are from 1:1, which is straight, to 5:1, which is a sextuplet with
the second notated eighth note sounding on the final division.
The current swing ratio and swing percentage values of the sliders are shown to their right.

8

Swing unit
Allows you to choose the rhythmic duration you want to swing in the selected ratio. You can
swing either eighth notes or 16th notes.

RELATED LINKS
Playback Options dialog on page 502

Mixer
The Mixer allows you to control the sounds produced in playback, both for the master output and
on each individual channel.

The Mixer comprises the following:
1

Channel type buttons
Allow you to hide/show channels in the Mixer according to their type, and in any
combination.
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2

Channel controls
Allow you to hide/show the corresponding controls in the channel strip according to their
type, and in any combination.

3

Deactivate All Mute States/Deactivate All Solo States
Allows you to deactivate all mute/solo states by clicking the corresponding button.

4

Zoom
Allows you to make channels wider/narrower.

5

VST channels
There is a mixer channel for each stereo output from the VST instruments in your project,
and all instruments in your project are shown, even if they are spread across multiple VST
instrument instances. Channels are stereo by default.

6

Mute/Solo
Allows you to mute/solo individual tracks.

7

Balance panner
Allows you to position the sound of each individual track on the stereo spectrum for stereo
playback.

8

Fader
Allows you to control the volume level of each individual track.
MIDI channels have a MIDI fader.

9

Channel meter
Indicates the output volume of each individual channel in real time.

10 MIDI channels
Every VST instrument in your project has its own MIDI channel in addition to its VST channel.
These MIDI channels allow you to change the MIDI volume and MIDI pan of each
instrument.
11 MIDI pan
Allows you to position the MIDI output of the channel on the stereo spectrum for stereo
playback.
12 MIDI fader
Allows you to change the MIDI volume of the channel.
Some plug-ins require MIDI faders, and this is often useful if you are using a MIDI device for
playback.
13 Click channel
Allows you to control the volume of the metronome click.
14 Video channel
Allows you to control the volume of video audio.
15 FX Send channel
Allows you to control the volume of send effects, such as reverb. By default, this channel has
REVerence loaded automatically.
16 Output channel
Allows you to control the master output volume.
NOTE
In order to control the volume levels in your project, we recommend that you first input
dynamics and adjust the dynamic curve to suit your project before using the track faders.
Any changes you make in the Mixer are automatically saved and applied to the project.
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RELATED LINKS
Hiding/Showing the Mixer window on page 556
Muting/Soloing tracks on page 544
Resetting changes to volume faders on page 546

Mixer channel strips
Each channel in the Mixer has its own channel strip, which contains the channel controls. You can
hide/show each type of channel control by clicking the corresponding button at the top of the
mixer.
Each channel strip contains the following types of controls:
Inserts

Each channel has four slots into which you can load an insert. You can select an insert
from the available options in the menu.
EQ

Each channel has four bands of EQ.
In order to make changes to the EQ bands on a channel, you must first click Enable EQ.
You can use this to bypass the EQ on a channel without losing your settings.
Sends

Each channel has four slots for sends. By default, the first slot for each channel sends
to the FX channel, which has reverb loaded on it.

Hiding/Showing the Mixer window
You can open and close the Mixer window at any time, for example, if you do not want it in view
when working on the music in the music area.
PROCEDURE
●

Hide/Show the Mixer window in any of the following ways:
●

Press F3 .

●

Click Show Mixer in the toolbar.

●

Choose Window > Mixer.
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The Mixer window is shown when a tick appears beside Mixer in the menu, and hidden
when no tick appears.

Transport window
The Transport window contains all the transport functions in Dorico Pro. It contains more
precise versions of the transport functions available in the toolbar and additional transport
functions.
You can open/close the Transport window in any of the following ways:
●

Press F2 .

●

Click Show Transport Bar in the toolbar.

Transport window

The Transport window contains the following information and functions:
1

Bars/Beats display
Shows the position of the playhead relative to bars and beats in the current flow in the
following order of units: bars, beats, 16th notes, 120ths of a 16th note.

2

Time display
Shows the position of the playhead as elapsed time in the following order of units: hours,
minutes, seconds, milliseconds. Alternatively, it can show the timecode position of the
playhead in the current flow in the following order of units: hours, minutes, seconds, frames.
You can switch between having the time display show the time and timecode by clicking it.

3

Rewind to Beginning of Flow
Moves the playhead back to the beginning of the flow.

4

Rewind
Moves the playhead back by a half note each time you click.

5

Fast Forward
Moves the playhead forwards by a half note each time you click.

6

Stop
Stops playback.

7

Play From Playhead Position
Plays back from the position of the playhead.

8

Play From Selection
Plays back from the position of the first selected item in the music area.
If you select items on multiple staves, or multiple items on a single staff, only the selected
staves are played back.

9

Record
Starts/Stops MIDI recording.
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10 Retrospective Record
Retrieves any MIDI notes you played during the previous playback and allows you to input
them on any staff, even if you were not recording them explicitly.
11 Click
Plays/Mutes the metronome click during playback and recording.
12 Fixed Tempo Mode
Displays the tempo used for both playback and recording. The value changes according to
the current position of the playhead and its appearance changes according to its current
mode.
RELATED LINKS
Mini transport on page 44
Changing the tempo mode on page 546

Changing the content shown in the transport display
You can switch between showing the timecode, the total elapsed time, and the current rhythmic
position of the playhead expressed in bars, beats, and ticks in both the mini transport in the
toolbar and the Transport window.
PROCEDURE
●

In either the mini transport in the toolbar or the Transport window, click the transport
display until the content you want appears.
In the Transport window, this is the display on the right.

RESULT
Each time you click in the mini transport display, it cycles through showing the rhythmic position
of the playhead, elapsed time, and the timecode.
In the Transport window, it only switches between the timecode and elapsed time, as the
rhythmic position of the playhead is shown permanently on the left of the window.
TIP
You can change what is shown in the mini transport by default for all future projects on the Play
page in Preferences.

RELATED LINKS
Toolbar on page 43
Mini transport on page 44
Timecodes on page 1066
Preferences dialog on page 62

Playback templates
Dorico Pro uses playback templates to allocate sounds from VST instruments and MIDI devices to
the instruments in your project.
Playback templates combine the following information in order to obtain correct playback:
●

The instrument sounds, articulations, and playback playing techniques provided by plug-ins,
such as VST instruments

●

The expression/percussion maps required to obtain those sounds

●

The endpoint configurations required for the sounds for each instrument
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When you add instruments to players in a project, Dorico Pro automatically loads plug-ins for
them according to the current playback template and sets up expression maps and percussion
maps as required. Dorico Pro also automatically loads enough plug-in instances, as many plugins can only load a limited number of sounds in each instance.
You can override playback templates and make your own manual changes to the sounds used by
instruments in your project, such as by changing the expression maps assigned to endpoints.
You can then save such changes as custom endpoint configurations, which you can include in
your own custom playback templates.
You can also export custom playback templates, for example, to share them with other users.
Playback templates are saved as .dorico_pt files.
NOTE
●

Playback templates are available in all projects you open or create on your computer,
meaning any changes you make to playback templates affect all projects that use those
playback templates.

●

Dorico Pro automatically loads sounds for any new instruments you add to the project, using
the sounds included in the current playback template. Therefore, we recommend that you
always include a factory default playback template at the bottom of custom playback
templates as a fallback to ensure that all instruments are assigned sounds.

●

Any changes you make within plug-ins are saved when you save the project but are not
communicated to Dorico Pro, which can lead to unexpected low notes sounding in playback
because Dorico Pro is still using the expression and percussion maps for the original sounds.
If you make changes in plug-ins, you must manually assign the correct expression and
percussion maps to the appropriate endpoints.

RELATED LINKS
Edit Playback Template dialog on page 561
Applying/Resetting playback templates on page 564
Creating custom playback templates on page 564
Exporting playback templates on page 566
Endpoint Setup dialog on page 567
Assigning expression/percussion maps to endpoints on page 572
Endpoints on page 566
Custom endpoint configurations on page 569

Apply Playback Template dialog
The Apply Playback Template dialog allows you to change the playback template applied to the
current project and to import/export playback templates. It also allows you to access the Edit
Playback Template dialog.
●

You can open the Apply Playback Template dialog in Play mode by choosing Play >
Playback Template.

The Apply Playback Template dialog shows all the playback templates available on your
computer in a table. Dorico Pro provides the following factory default playback templates:
●

HSSE (Elements): Intended for use with HALion Sonic SE.

●

HSSE+HSO (Pro): Intended for use with both HALion Sonic SE and HALion Symphonic
Orchestra.

●

Silence: Prevents Dorico Pro from loading sounds.
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TIP
Choosing the Silence template makes Dorico Pro project files significantly smaller, for example, if
you want to send them electronically.

Apply Playback Template dialog

The Apply Playback Template dialog comprises the following:
1

Search field
Allows you to enter the name of the playback template you are searching for directly, which
filters the list.

2

Name column
Contains a list of the playback templates available on your computer. You can click the
column header to change the sorting order.

3

Factory column
Contains the factory symbol if the playback template in the corresponding row is a factory
default playback template. You can click the column header to change the sorting order.

4

Action bar
Contains the following options for playback templates:
●

Add Playback Template: Opens the Edit Playback Template dialog and allows you to
create a new playback template.

●

Duplicate Playback Template: Opens the Edit Playback Template dialog and allows
you to create a new playback template that starts as a duplicate of the selected one.

●

Edit Playback Template: Opens the Edit Playback Template dialog and allows you to
edit the existing selected playback template.
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NOTE
You cannot edit factory default playback templates.
●

Show Factory: Allows you to hide/show factory default playback templates in the table.

●

Export: Opens the File Explorer/macOS Finder, where you can select the location to
which you want to export the currently selected playback templates as .dorico_pt
files. You can then import the .dorico_pt files into Dorico Pro on other computers and
share them with other users.

●

Import: Opens the File Explorer/macOS Finder, where you can select the .dorico_pt
files that you want to import as playback templates.

●

Delete: Deletes the selected playback templates.

NOTE
You cannot delete factory default playback templates.
5

Apply and Close
Applies the selected playback template to the project and closes the dialog.

RELATED LINKS
Creating custom playback templates on page 564
Applying/Resetting playback templates on page 564
Importing playback templates on page 566
Exporting playback templates on page 566

Edit Playback Template dialog
The Edit Playback Template dialog allows you to create new custom playback templates and
edit existing ones. You can use any combination of custom endpoint configurations and existing
playback templates and specify the order in which they should be used.
Playback templates are available in all projects you open or create on your computer.
●

You can open the Edit Playback Template dialog in Play mode by clicking Add Playback
Template, Duplicate Playback Template, or Edit Playback Template in the Apply
Playback Template dialog.
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Edit Playback Template dialog

The Edit Playback Template dialog contains the following sections:
1

Playback template data
Allows you to specify the following identifying information for the selected custom playback
template:
●

Name: Allows you to set the name of the playback template that appears in the
program, for example, in the Apply Playback Template dialog.

●

ID: Allows you to set the unique ID of the playback template. Dorico Pro automatically
populates the ID field with the information you enter into the Name field.

●

Creator: Allows you to name the creator if you are sharing your playback template with
other users.

●

Version: Allows you to indicate the playback template version so you can identify the
most recent one, for example, you can increase the Version number each time you
make changes to the playback template.

●

Description: Allows you to add any other information about the playback template.
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NOTE
All fields in the playback template data section, except for Name, are locked by the Lock Info
button. You must click this button in order to change the information in the fields.
2

Entries
Contains a table of all the custom endpoint configurations and existing playback templates
used by the selected custom playback template. Entries are listed in order of priority,
meaning that Dorico Pro assigns sounds from the top entry first. We recommend that you
always include a factory default playback template at the bottom of the list as a fallback to
ensure that all instruments are assigned sounds.
In most cases, listing entries in your order of preference in the Entries section is sufficient to
achieve your desired playback. However, if multiple entries in your custom playback
template provide sounds for the same instrument, you must set family and/or instrument
overrides, for example, if you only want to use woodwind sounds from the first entry and use
all other sounds from the second entry.
The column on the right identifies the type of the entry in the corresponding row.
●

Manual: Entries that cannot load sounds automatically, including custom endpoint
configurations

●

Auto: Entries that can load sounds automatically, that is, factory default playback
templates

The action bar at the bottom of the section contains the following options:

3

●

Add Manual: Allows you to add a manual entry to the playback template.

●

Add Automatic: Allows you to add an automatic entry to the playback template.

●

Move up: Moves the selected entry up the list.

●

Move down: Moves the selected entry down the list.

●

Delete: Removes the selected entry from the playback template.

Family Overrides
Contains a list of family overrides applied to the selected entry and allows you to add/
remove overrides. Family overrides allow you to specify the instrument family sounds you
want to use, for example, if you only want to use the woodwind sounds from an entry that
also includes brass and string sounds.
The action bar at the bottom of the section contains the following options:

4

●

Add Instrument Family: Allows you to select an instrument family to apply as an
override to the selected entry.

●

Delete Instrument Family: Removes the selected family override from the selected
entry.

Instrument Overrides
Contains a list of instrument overrides applied to the selected entry and allows you to add/
remove overrides. Instrument overrides allow you to specify individual instrument sounds
you want to use, for example, if you only want to use a solo violin sound from an entry that
also includes ensemble string sounds.
The action bar at the bottom of the section contains the following options:
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●

Add Instrument: Allows you to select an instrument to apply as an override to the
selected entry.

●

Delete Instrument: Removes the selected instrument override from the selected entry.

RELATED LINKS
Apply Playback Template dialog on page 559
Endpoints on page 566
Custom endpoint configurations on page 569

Applying/Resetting playback templates
You can change the playback template applied to the current project, for example, if you do not
need to use playback and so want to prevent Dorico Pro from loading sounds. Re-selecting
playback templates resets them to their default settings.
PROCEDURE
1.

Choose Play > Playback Template to open the Apply Playback Template dialog.

2.

Select the playback template you want to use.

3.

Click Apply and Close.

RESULT
The playback template applied to the current project is changed. If you re-selected the playback
template already in use, the playback template is reset.
Sounds are loaded into plug-in instances in their score order.
TIP
●

You can change the default playback template used for all future projects on the Play page
in Preferences.

●

You can also load sounds just for instruments without assigned sounds by choosing Play >
Load Sounds for Unassigned Instruments.

RELATED LINKS
Playback templates on page 558
Preferences dialog on page 62

Creating custom playback templates
You can create custom playback templates that can include combinations of factory default
playback templates, custom endpoint configurations, and other non-factory default playback
templates that cannot load sounds automatically.
PROCEDURE
1.

In Play mode, choose Play > Playback Template to open the Apply Playback Template
dialog.

2.

Open the Edit Playback Template dialog to create a new playback template in one of the
following ways:
●

To create an empty playback template, click Add Playback Template in the action bar.
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●

3.

To create a copy of an existing playback template, select it and click Duplicate Playback
Template in the action bar.

In the Edit Playback Template dialog, click Lock Info to unlock the data fields.

Locked

Unlocked

4.

Enter information for your playback template in the relevant fields.

5.

In the Entries section, add the custom endpoint configurations and/or factory default
playback templates you want.
●

To add a custom endpoint configuration or non-factory default playback template, click
Add Manual and select the one you want from the menu.

●

To add a factory default playback template, click Add Automatic and select the one you
want from the menu.

TIP
We recommend that you always include a factory default playback template at the bottom of
the list as a fallback to ensure that all instruments are assigned sounds.
6.

Optional: To change the order of entries and their order of preference in the playback
template, select an entry and click one of the following options in the action bar:
●

To move the selected entry upwards, click Move up.

●

To move the selected entry downwards, click Move down.

7.

Optional: Repeat step 6 until all the entries are in the correct order of preference.

8.

Optional: Select an entry for which you want to specify instrument family overrides.

9.

In the Family Overrides section action bar, click Add Instrument Family and select the one
you want from the menu.
For example, if you only want to use the woodwind sounds from a sound library that also has
string sounds, select Woodwinds.

10. Optional: Select an entry for which you want to specify individual instrument overrides.
11. In the Instrument Overrides section action bar, click Add Instrument and select the one
you want in the instrument picker.
For example, if you only want to use the piano sound from a sound library that has other
keyboard instrument sounds, select Piano.
12. Optional: Repeat steps 8 to 11 for other entries for which you want to specify instrument
family and instrument overrides.
13. Click OK to save your changes and close the dialog.
RESULT
Your new custom playback template is created. It is available to use in the current project and all
projects you create/open on your computer.
RELATED LINKS
Apply Playback Template dialog on page 559
Edit Playback Template dialog on page 561
Endpoint Setup dialog on page 567
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Custom endpoint configurations on page 569
Saving custom endpoint configurations on page 570

Importing playback templates
You can import playback templates into projects, for example, if someone you are working with
exported their custom playback template for you to use. Playback templates are saved
as .dorico_pt files.
PROCEDURE
1.

Choose Play > Playback Template to open the Apply Playback Template dialog.

2.

Click Import to open the File Explorer/macOS Finder.

3.

In the File Explorer/macOS Finder, locate and select the playback template file you want to
import.

4.

Click Open.

RESULT
The selected playback template is imported. It becomes available in the current project and all
projects you create/open on your computer.
TIP
You can also import playback templates by dragging .dorico_pt files into a Dorico Pro project
window.

Exporting playback templates
You can export playback templates so you can send them to other users or use them on other
computers. By default, any playback templates you create are available in all projects on your
computer.
PROCEDURE
1.

Choose Play > Playback Template to open the Apply Playback Template dialog.

2.

Select the playback templates you want to export.

3.

Click Export to open the File Explorer/macOS Finder.

4.

Specify a name and location for the playback template files.

5.

Click Save.

RESULT
The selected playback templates are exported and saved in the selected location as
separate .dorico_pt files.

Endpoints
“Endpoint” is the term used for the unique combination of inputs and outputs that together allow
the correct sounds to be played for each instrument.
In Dorico Pro, each endpoint brings together the following:
●

A VST instrument or MIDI output device instance

●

A specific channel on that VST instrument or MIDI output device
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●

The patch or program assigned to that channel

●

The expression map and/or percussion map that describes the instrument or instruments
that can be played by that patch or program, and the playback playing techniques and
articulations provided

Each instrument in your project is connected to a specific endpoint. Assigning an expression/
percussion map to the same endpoint allows Dorico Pro to translate any playing technique
changes and articulations you input into the key switches and controller switches necessary to
produce the required sounds for the instrument in playback.
When you use a factory default playback template, Dorico Pro sets up endpoints and expression/
percussion maps automatically. If you want to load other plug-ins or change the patches within
HALion Sonic SE, you can do so in the Endpoint Setup dialog.
NOTE
Any changes you make within plug-ins are not communicated to Dorico Pro, for example,
changing a sound that the expression map expects to use a modulation wheel for dynamics to
one that uses note velocity instead. This can lead to unexpected low notes sounding in playback
because Dorico Pro is still using the expression and percussion maps for the original sounds. If
you make changes in plug-ins, you must manually assign the correct expression and percussion
maps to the appropriate endpoints.
You can then save your changes as a custom endpoint configuration if you want to reuse them in
other projects.

Endpoint Setup dialog
The Endpoint Setup dialog displays which expression and percussion maps are currently linked
to each endpoint in the corresponding plug-in instance, and allows you to change these settings.
It also allows you to save your current settings as custom endpoint configurations, which you can
then include in custom playback templates.
●

You can open the Endpoint Setup dialog by clicking Endpoint Setup in each plug-in instance
in the VST and MIDI Instruments panel.
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Endpoint Setup dialog

The Endpoint Setup dialog contains the following options and sections:
1

Name
Allows you to change the name of the selected plug-in instance. This affects the name shown
in the VST and MIDI Instruments panel and in the Mixer.

2

Number of MIDI ports
Displays the number of MIDI ports the corresponding plug-in instance currently uses.
You can change the number of MIDI ports, for example, if you are using a plug-in that uses
more than one port. Dorico Pro does not load multiple MIDI ports by default.

3

Number of MIDI channels
Displays the number of MIDI channels the corresponding plug-in instance currently uses.
You can change the number of channels, for example, if you have a monotimbral plug-in
such as a piano sampler which only has one MIDI channel, or a multitimbral plug-in with 16
MIDI channels and 16 audio outputs.

4

Set
Sets the plug-in instance to have the number of MIDI ports and channels specified in the
Number of MIDI ports and Number of MIDI channels value fields. This changes the
number of rows in the table.

5

Endpoint setup table
Contains the settings for the corresponding plug-in instance, arranged into the following
columns:
●

Port: Displays the port used by the instrument in the corresponding row of the table.
NOTE
You cannot change the port from within the Endpoint Setup dialog. You must change
the port in the instrument track headers.
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●

Channel: Displays the channel used by the instrument in the corresponding row of the
table.
NOTE
You cannot change the channel from within the Endpoint Setup dialog. You must
change the channel in the instrument track headers.

6

●

Assigned Instruments: Displays the full name of the instrument in the corresponding
row, as set for that instrument in the Edit Instrument Names dialog.

●

Expression map: Displays the expression map currently assigned to the instrument in
the corresponding row. You can change the expression map by double-clicking it and
selecting another expression map from the menu.

●

Percussion map: Displays the percussion map currently assigned to the instrument in
the corresponding row. You can change the percussion map by double-clicking it and
selecting another percussion map from the menu.

Number of audio outputs to show in Mixer
Allows you to change the number of audio outputs shown in the Mixer, for example, if you
want to hide unused outputs when using plug-ins that provide more audio outputs than
Dorico Pro uses.

7

Save Endpoint Configuration
Opens the Save Endpoint Configuration dialog, which allows you to enter a name for the
current endpoint configuration and save it as a custom endpoint configuration.

RELATED LINKS
Playback templates on page 558
Expression Maps dialog on page 574
Edit Instrument Names dialog on page 140

Custom endpoint configurations
Custom endpoint configurations save the current state and settings of plug-ins in your project,
such as the number and type of VST/MIDI instruments loaded and the instruments and
expression/percussion maps assigned to endpoints.
You can save custom endpoint configurations that include the settings for all plug-ins currently
loaded or only a single one.
Custom endpoint configurations are available in all projects you open or create on your
computer.
NOTE
You cannot delete custom endpoint configurations within Dorico Pro.
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RELATED LINKS
Playback templates on page 558
Edit Playback Template dialog on page 561
Creating custom playback templates on page 564

Save Endpoint Configuration dialog
The Save Endpoint Configuration dialog allows you to save the current state and settings of
plug-ins in your project. Saving custom endpoint configurations allows you to re-use them in
other projects and include them in custom playback templates.
You can open the Save Endpoint Configuration dialog in Play mode in any of the following
ways:
●

In the VST and MIDI Instruments panel, click Save Endpoint Configuration in the VST
Instruments or MIDI Instruments action bar. This saves the current state of all plug-ins in
the corresponding section of the panel.

●

In the Endpoint Setup dialog, click Save Endpoint Configuration. This saves the current
state of the selected plug-in only.

Save Endpoint Configuration dialog

The Save Endpoint Configuration dialog contains a Name field that allows you to enter a name
for the endpoint configuration you are saving. The arrow at the end of the field allows you to
select an existing custom endpoint configuration to use to populate the field.
If you enter a name that already exists, you can overwrite the existing custom endpoint
configuration. When you overwrite existing custom endpoint configurations, Dorico Pro moves
the previous version to your recycle bin.
RELATED LINKS
Playback templates on page 558

Saving custom endpoint configurations
You can save any overrides you have made to endpoint configurations, such as changing the
instruments and expression maps assigned to particular endpoints. This allows you to use these
overrides in custom playback templates and re-use the same endpoint configurations in other
projects.
PREREQUISITE
●

You have opened a project containing all instruments and plug-ins that are necessary for the
custom endpoint configuration.

●

You have created any necessary expression maps and playback playing technique
combinations.

●

You have created any necessary custom playing techniques.
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PROCEDURE
1.

Load the plug-ins you want.
You can do this by applying a playback template or by adding plug-in instances manually in
the VST Instruments section of the VST and MIDI Instruments panel.

2.

Change the settings for the endpoints as required.
For example, change the instruments or expression maps assigned to each endpoint.

3.

4.

Open the Save Endpoint Configuration dialog in one of the following ways:
●

To save a custom endpoint configuration for only a single plug-in instance, open the
Endpoint Setup dialog for that plug-in instance and click Save Endpoint Configuration.

●

To save a custom endpoint configuration that includes all plug-in instances, click Save
Endpoint Configuration in the VST Instruments section of the VST and MIDI
Instruments panel action bar.

Enter a name for your custom endpoint configuration in the Name field.
NOTE
If you enter a name that already exists, or select an existing custom endpoint configuration
from the menu, the existing custom endpoint configuration is overwritten.

5.

Click OK to save your changes and close the dialog.

RESULT
The current state of either the selected plug-in instance or all plug-in instances in the section is
saved as a custom endpoint configuration. This includes any custom playing techniques included
in any of the expression/percussion maps.
RELATED LINKS
Playback templates on page 558
Creating custom playback templates on page 564
Creating new expression maps on page 581
Creating playback playing technique combinations on page 582
Custom playing techniques on page 1022

Assigning instruments/voices to endpoints
You can assign instruments to any endpoint, for example, if you have loaded a plug-in with
multiple ports and want to change the endpoint of an existing instrument to an endpoint on one
of your new ports. For instruments with independent voice playback enabled, you can assign
each voice to a different endpoint.
PREREQUISITE
●

If you want to assign different voices belonging to the same instrument to different
endpoints, you have enabled independent voice playback.

●

If you want to assign instruments to endpoints in specific plug-in instances, you have loaded
those plug-in instances. You can do this by applying a suitable playback template or by
loading VST/MIDI instruments manually.

PROCEDURE
1.

Expand the instrument track whose assigned endpoint you want to change.

2.

Optional: For instruments with independent voice playback enabled, select the voice whose
assigned endpoint you want to change from the Voice menu.
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3.

Optional: Change the flows to which you want your changes to apply in one of the following
ways:
●

To change the assigned endpoint for the selected voice in the current flow only, click Set
for This Flow.

●

To change the assigned endpoint for the selected voice in all flows, click Set for All
Flows.
NOTE
This affects all voices in the same position in the Voices menu rather than by voice type.

4.

Optional: To assign the instrument/voice to an endpoint in a different plug-in instance, select
that plug-in instance from the menu in their track header.

5.

In the instrument track header, select a new option from one or both of the following
menus:
●

Port

●

Ch.

RESULT
The endpoint to which the instrument/voice is assigned is changed.
●

Changing just the Ch. value changes the channel in the plug-in instance that the
corresponding instrument uses.

●

Changing both the Port and Ch. values changes both the port in the plug-in instance, and
the channel in that port, that the corresponding instrument uses.

RELATED LINKS
Expression Maps dialog on page 574
Instrument tracks on page 511
Applying/Resetting playback templates on page 564
Loading VST/MIDI instruments manually on page 500
Enabling independent voice playback on page 543

Assigning expression/percussion maps to endpoints
You can assign expression/percussion maps to the endpoints in your project, for example, if you
have created a custom percussion map and must link it to the endpoint for the corresponding
VST patch.
PREREQUISITE
You have made or imported any expression/percussion maps that you require but do not exist
on your computer.
PROCEDURE
1.

In the VST and MIDI Instruments panel, click Endpoint Setup in the plug-in instance in which
you want to change the expression/percussion maps assigned to endpoints to open the
Endpoint Setup dialog.

2.

Double-click the expression/percussion map you want to change.

3.

Click the disclosure arrow to the right of the field.
A menu appears containing all maps of the same type currently loaded in your project.
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4.

Select the expression/percussion map you want from the menu.

5.

Press Return .

6.

Optional: Repeat steps 2 to 5 for any other endpoints whose assigned expression/percussion
maps you want to change.

7.

Click OK to save your changes and close the dialog.

RELATED LINKS
Percussion maps on page 583

Expression maps
Expression maps tell Dorico Pro how to use appropriately the patches and sounds in the VST
instruments that you have loaded into your project.
Expressing a range of dynamics on instruments means changing the volume and attack of notes.
Because the strength of attack changes the character of the start of sounds as well as their
volume, loud sounds often require stronger attacks and quiet sounds often require softer
attacks.
Different patches and instruments have different approaches to changing dynamics and volume
in playback. For example, some patches only change the velocity whereas others use a controller
in combination with changing the velocity.
Dorico Pro also uses expression maps to specify the playback playing techniques that are
supported by each patch in your project. For example, string instruments such as the violin have
different techniques, because they can play arco, pizzicato, and col legno, and their bow position
can be anywhere between sul ponticello and sul tasto.
Dorico Pro supports the following ways of sending information to VST instruments:
●

Key switches

●

Controllers

●

Program changes

●

Channel changes

In addition to the HALion Symphonic Orchestra expression maps, there are the following
expression maps in Dorico Pro:
●

CC11 Dynamics: Uses MIDI controller 11 to play dynamics.
NOTE
This only applies to instruments that can change their dynamic while notes are sounding,
such as violin or flute.
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●

Default: Uses note velocity to control dynamic volume.

●

Modulation Wheel Dynamics: Uses a modulation wheel to control the dynamic volume.

●

Transpose down 1 octave: Used by some instrument patches that sound an octave higher
than written so that they can be played without needing a full range keyboard.

●

Transpose up 1 octave: Allows the bottom octave of keyboards to be used for key switches
instead of notes, but is also used by some bass instrument patches that sound an octave
lower than written so that they can be played without needing a full range keyboard.

You can edit, create, and import/export expression maps in the Expression Maps dialog.
Expression maps are saved as .doricolib files.
RELATED LINKS
Percussion maps on page 583

Expression Maps dialog
The Expression Maps dialog allows you to create new expression maps, edit existing expression
maps, and import/export expression maps. You can also import expression maps made in
Cubase.
●

You can open the Expression Maps dialog in Play mode by choosing Play > Expression
Maps.

Although the format of expression maps in Dorico Pro is similar to Cubase, Dorico Pro does not
handle expression maps in exactly the same ways. For example, Dorico Pro allows you to use
more playback playing techniques, but Cubase can reproduce more combinations of multiple
playback playing techniques.
NOTE
During playback, Dorico Pro does not currently support all fields in the Expression Maps dialog,
including some settings imported from Cubase. This is planned for future versions.

574
Dorico Pro 3.1.10

Play mode
Expression maps

Expression Maps dialog

The Expression Maps dialog contains the following sections and options:
1

Expression maps list
Contains the expression maps currently available for your project.
The action bar at the bottom of the list contains the following options:
●

Add Expression Map: Adds a new expression map that contains no existing settings.

●

Duplicate: Creates a copy of an existing expression map that you can edit separately
from the original.

●

Delete Expression Map: Deletes the selected expression maps.

NOTE
You can only delete custom expression maps. You cannot delete any default expression
maps.
2

Search field
Allows you to search for expression maps by name.
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3

Show only expression maps used in this project
Allows you to filter the expression maps list so it only includes expression maps used in the
current project.

4

Expression Map Data section
Allows you to specify the following identifying information for the selected expression map:
●

Name: Allows you to set the name of the expression map that appears in the program,
for example, in the Endpoint Setup dialog.

●

ID: Allows you to set the unique ID of the expression map. You can enter any content in
the ID field.
It can be useful to include the instrument and sound library for which you created the
map, as well as your name, for example, xmap.user.paulsmith.hso.violinpizz.

●

Creator: Allows you to name the creator if you are sharing your expression map with
other users.

●

Version: Allows you to indicate the expression map version so you can identify the most
recent one.

●

Plug-ins: Allows you to list the names of plug-ins to which the expression map applies,
with each name separated by a comma. You can leave this field blank.

●

Description: Allows you to add any other information about the expression map.

NOTE
All fields in the Expression Map Data section are locked by the Lock Info button. You must
click this button in order to change the information in the fields.
You can hide/show the Expression Map Data section by clicking the section header.
5

Techniques and Actions section
Contains subsections that allow you to view, edit, and control the playback playing
techniques in the selected expression map.
You can hide/show the Techniques and Actions section by clicking the section header.

6

Techniques list
Contains a list of playback playing techniques for the expression map currently selected.
In simple cases, entries in the Techniques list are individual playback playing techniques,
such as Staccato or Accent. However, it is possible to combine multiple playback playing
techniques for plug-ins that have separate samples for different combinations of playback
playing techniques. For example, Staccato + Accent might require a separate set of key
switches to Staccato and Accent individually.
NOTE
Most instruments have a “natural” playback playing technique, which is the most common
way of playing the instrument. Dorico Pro requires every instrument to have a defined
natural playback playing technique.
Selecting a playback playing technique in the Techniques list allows you to edit its controls
and actions.
The action bar at the bottom of the list contains the following options:
●

Add Technique: Allows you to add a new playback playing technique or combination of
playback playing techniques to the expression map from the available playback playing
techniques in the Playing Technique Combinations dialog.
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●

Edit Technique: Opens the Playing Technique Combinations dialog, which allows you
to edit the combination of playback playing techniques used in the selected playback
playing technique.

You can also edit existing playback playing techniques by double-clicking them in the
Techniques list.
●

Duplicate: Creates a copy of an existing playback playing technique that you can edit
separately from the original.

●

Delete Technique: Deletes the selected playback playing technique.

NOTE
You can only select one playback playing technique at a time in the Techniques list.
7

Technique controls
Contains controls that affect the playback playing technique selected in the Techniques list,
such as Velocity. It also contains Volume dynamic, which allows you to choose whether the
volume dynamic for the selected playback playing technique is controlled by its Note
velocity or a Control change. For sound libraries that use both, you can use Use Secondary
dynamic to define an additional volume control.
NOTE
If you choose Control change for Volume dynamic, you must specify the controller by
number. You can consult the documentation for the VST instrument and/or MIDI controller
you are using to find the appropriate controller number.

8

Actions subsection
Allows you to determine how the switch required to execute each playback playing technique
is controlled. This subsection also contains the details of existing actions required to produce
the selected playback playing technique.
Actions can be any of the following types:
●

Control change

●

Program change

●

Key switch

NOTE
Depending on your plug-in, multiple types of actions can be required to change individual
playback playing techniques.
Actions are displayed in a table with three columns.

Actions table

The first column shows the type of action.
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The second column controls the first parameter of the MIDI event. For note events, this
indicates the pitch. For control changes, this indicates the control change number. For
program changes, this indicates the program number.
The third column controls the second parameter of the MIDI event. For note events, this
indicates the velocity. For control changes, this indicates the amount of control change
within the range 0 to 127. Program changes do not have a second parameter.
The action bar at the bottom of the subsection contains the following options:
●

Add Control Change Action: Adds a control change action with default settings.

●

Add Program Change Action: Adds a program change action with default settings.

●

Add Note Event Action: Adds a key switch action with default settings.

●

Add Absolute Channel Change Action: Adds an absolute channel change action with
default settings.

●

Add Relative Channel Change Action: Adds a relative channel change action with
default settings.

●

Duplicate Action: Creates a copy of an existing action that you can then edit separately
from the original.

●

Delete Action: Deletes the selected action.

NOTE
You can only select one action at a time in the Actions table.
The Actions subsection also allows you to specify which actions affect the start of notes and
which affect the end of notes. For example, you might want an event that resets the playback
playing technique back to normal to apply only to the end of notes.
●

On events affects the start of notes.

●

Off events affects the end of notes.

You can also use Middle C (note 60) to choose the pitch for middle C, as there are different
conventions for this. We recommend that you consult the documentation for your sound
libraries to check whether each one considers middle C to be C3, C4, or C5, and change this
setting accordingly.
9

Mutual Exclusion Groups section
Allows you to specify playback playing techniques that are mutually exclusive, that is, cannot
be in use concurrently. For example, players cannot play vibrato and non-vibrato at the same
time. Putting playback playing techniques into the same exclusion group means only one
can be used at a time.
Mutual exclusion groups apply only to the selected expression map. This allows you to set
different mutual exclusion groups in each expression map, for example, if one of your sound
libraries supports a particular playback playing technique combination for an instrument but
another sound library does not.
The Mutual Exclusion Groups column allows you to add and delete mutual exclusion
groups. The action bar at the bottom of the column contains the following options:
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●

Add: Opens a dialog that allows you to create a new mutual exclusion group and enter a
name for it.

●

Delete: Deletes the selected mutual exclusion group.

NOTE
You can only select one mutual exclusion group at a time.
The Has techniques column allows you to change the playback playing techniques included
in the selected mutual exclusion group. The action bar at the bottom of the column contains
the following options:
●

Add: Opens the Playing Technique Combinations dialog that allows you to select
playback playing techniques to add to the selected mutual exclusion group.

●

Delete: Deletes the selected playback playing technique from the mutual exclusion
group.

NOTE
You can only select one playback playing technique at a time.
You can hide/show the Mutual Exclusion Groups section by clicking the section header.
10 Reset to Library Defaults
Allows you to revert any changes you have made to the expression maps from the Default
Library.
11 Import Library
Opens the File Explorer/macOS Finder, where you can select the .doricolib files that you
want to import as expression maps.
12 Export Library
Opens the File Explorer/macOS Finder, where you can select the location to which you want
to export the currently selected expression maps as a .doricolib file. You can then import
the .doricolib file into other projects and share it with other users.
13 Import Cubase Expression Map
Opens the File Explorer/macOS Finder, where you can select the Cubase format expression
maps you want to import.
NOTE
It is not currently possible to import all combinations of playback playing techniques. Cubase
expression maps in Dorico Pro often require some editing to function correctly.
However, switch data is preserved.

RELATED LINKS
Endpoint Setup dialog on page 567
Edit Playback Playing Techniques dialog on page 1028
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Playing Technique Combinations dialog
The Playing Technique Combinations dialog allows you to create combinations of playback
playing techniques that you want to apply simultaneously. Playback playing techniques are used
by expression maps to assign the correct sounds to the required playing techniques in the music.
You can open the Playing Technique Combinations dialog in the following ways:
●

In the Expression Maps dialog, click Add Technique in the Techniques action bar.

●

In the Expression Maps dialog, select an existing playback playing technique in the
Techniques list and click Edit Technique in the Techniques action bar. You can also doubleclick the playback playing technique.

Playing Technique Combinations dialog

1

Techniques list
Allows you to select existing playback playing techniques to include in a new playback
playing technique or to edit an existing one.
You can select multiple playback playing techniques to combine by Ctrl/Cmd -clicking each
playback playing technique.

2

Name
Displays the name of the selected playback playing technique. If you select multiple playback
playing techniques, each name is automatically separated by a + symbol.
You cannot change the name of playback playing techniques.

RELATED LINKS
Creating playback playing technique combinations on page 582
Edit Playback Playing Techniques dialog on page 1028
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Creating new expression maps
You can create new expression maps from scratch and you can duplicate existing expression
maps and edit the settings, for example, when using third-party sound libraries or MIDI devices
that do not provide expression maps.
PROCEDURE
1.

Choose Play > Expression Maps to open the Expression Maps dialog.

2.

Create a new expression map in one of the following ways:

3.

●

To create an empty expression map, click Add Expression Map in the action bar.

●

To create a copy of an existing expression map, select it in the expression maps list and
click Duplicate Expression Map in the action bar.

In the Expression Map Data section, click Lock Info to unlock the fields.

Locked

Unlocked

4.

In the Expression Map Data section, enter information for your expression map in the
relevant fields.

5.

Optional: In the Techniques list in the Techniques and Actions section, add a new playback
playing technique in one of the following ways:
●

Click Add Technique.

●

Select an existing playback playing technique and click Duplicate Technique.

6.

Optional: If playback playing technique combinations you require do not exist in the
expression map, create them in the Playing Technique Combinations dialog.

7.

In the Techniques list, select a playback playing technique.

8.

In the Techniques and Actions section, change any of the options relevant to the selected
playback playing technique.
For example, choose whether the volume of the selected technique is controlled by its Note
velocity or a Control change.

9.

In the Actions subsection, add an action for the currently selected playback playing
technique in one of the following ways:
●

Click Add Note Event.

●

Click Add Control Change.

●

Click Add Program Change.

●

Select an existing action and click Duplicate.

10. Choose the type of event from one of the following options:
●

On events

●

Off events

11. Optional: Repeat steps 9 and 10 for each action you require for each technique.
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12. Optional: To change the values for actions, double-click them and change their values.
13. Optional: If you want to define mutual exclusion groups in your new expression map, add
the mutual exclusion groups you want in the Mutual Exclusion Groups section.
14. Optional: If you added mutual exclusion groups, add the necessary playback playing
techniques to each mutual exclusion group.
15. Click OK to save your changes and close the dialog.

RELATED LINKS
Expression Maps dialog on page 574
Endpoint Setup dialog on page 567
Playing Technique Combinations dialog on page 580

Creating playback playing technique combinations
You can create combinations of playback playing techniques for a single expression map, for
example, if the expression map requires a different set of key switches for Staccato + Accent
compared to Staccato and Accent individually.
PROCEDURE
1.

Choose Play > Expression Maps to open the Expression Maps dialog.

2.

In the expression maps list, select the expression map to which you want to add new
playback playing technique combinations.

3.

Open the Playing Technique Combinations dialog to change the combination for a
playback playing technique in one of the following ways:

4.

●

To create a new playback playing technique, click Add Techniques in the Techniques list
action bar.

●

To change the combination for an existing playback playing technique, select the
playback playing technique and click Edit Technique in the Techniques list action bar.

In the Playing Technique Combinations dialog, select the playback playing techniques you
want to combine.
You can Ctrl/Cmd -click multiple playback playing techniques, but you can also only select a
single playback playing technique.

5.

Click OK to save your changes and close the dialog.
The Playing Technique Combinations dialog closes.

RESULT
A new playback playing technique combination is created and becomes available in the
Techniques list for the selected expression map in the Expression Maps dialog.
RELATED LINKS
Playing Technique Combinations dialog on page 580
Expression Maps dialog on page 574
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Importing expression maps
You can import expression maps into projects. Expression maps are saved as .doricolib files.
PROCEDURE
1.

Choose Play > Expression Maps to open the Expression Maps dialog.

2.

Click Import Library to open the File Explorer/macOS Finder.

3.

In the File Explorer/macOS Finder, locate and select the expression map file you want to
import.

4.

Click Open.

RESULT
The selected expression map is imported into your project. It appears in the expression maps list.

Exporting expression maps
You can export expression maps so you can use them in other projects. Expression maps are
saved as .doricolib files.
PROCEDURE
1.

Choose Play > Expression Maps to open the Expression Maps dialog.

2.

In the expression maps list, select the expression maps you want to export.

3.

Click Export Library to open the File Explorer/macOS Finder.

4.

In the File Explorer/macOS Finder, specify a name and location for the library file.

5.

Click Save.

RESULT
The selected expression maps are exported as a library file and saved in the selected location.

Percussion maps
Unpitched percussion instruments are played back using patches that map unpitched sounds
onto different MIDI notes. The pitches required to produce different unpitched sounds vary by
device, sound library, manufacturer, and so on, and have no connection to the position of
percussion instruments on five-line staves.
The following list contains some examples of unpitched percussion instruments from the General
MIDI percussion map.
●

Bass drum: C2 (MIDI note 36, two octaves below middle C)

●

Kick drum: D2 (MIDI note 38)

●

Closed hi-hat: F♯2 (MIDI note 42)

●

Cowbell: G♯3 (MIDI note 56)

●

Open triangle: A5 (MIDI note 81)

Dorico Pro uses percussion maps to connect the written representation of notes and playing
techniques for percussion instruments to the samples required to play those sounds back.
NOTE
A percussion map describes which unpitched percussion instruments and their playback playing
techniques are present in a particular patch, and how to play them back. For example, it
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describes which MIDI note to play, and if another MIDI note is needed as a key switch to trigger
particular playing techniques.
A set of percussion maps for the unpitched percussion patches that are part of theHALion
Symphonic Orchestra and HALion Sonic SE factory libraries is provided with Dorico Pro. They are
automatically chosen when you add percussion instruments to your project.
You can define custom percussion maps for third-party sound libraries or MIDI devices in the
Percussion Maps dialog, in order to obtain correct playback.

Percussion Maps dialog
In the Percussion Maps dialog, you can define custom percussion maps for third-party sound
libraries or MIDI devices in order to obtain correct playback.
●

You can open the Percussion Maps dialog in Play mode by choosing Play > Percussion
Maps.

Percussion Maps dialog

The Percussion Maps dialog is divided into the following sections:
1

Percussion maps list
Contains the percussion maps currently available in your project.
You can add and delete percussion maps using the following buttons in the action bar at the
bottom of the percussion maps list:
●

Add Percussion Map: Adds a new percussion map that contains no existing settings.
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●

Duplicate: Creates a copy of an existing percussion map that you can edit separately
from the original.

●

Delete Percussion Map: Deletes the selected percussion maps.

NOTE
You can only delete custom percussion maps. You cannot delete any default percussion
maps.
2

Search field
Allows you to search for percussion maps by name.

3

Show only percussion maps used in this project
Allows you to filter the percussion maps list so it only includes percussion maps used in the
current project.

4

Percussion Map Data section
Allows you to specify the following identifying information for the selected percussion map:
●

Name: Allows you to specify the displayed name for the percussion map that appears in
the Endpoint Setup dialog.

●

ID: Allows you to set the unique ID of the percussion map. You can enter any content in
the ID field.
It can be useful to include the instrument and sound library for which you created the
map, as well as your name, for example, xmap.user.paulsmith.hso.cowbell.

●

Version: Allows you to indicate the percussion map version so you can identify the most
recent one.

NOTE
●

All fields in the Percussion Map Data section are locked by the Lock Info button. You
must click this button in order to change the information in the fields.

●

The Endpoint Setup dialog is where you set which percussion map Dorico Pro uses for
each channel on your VST instrument or MIDI output device.

You can choose one of the options for Map defines sounds for, as appropriate for the
current percussion map:
●

Multiple Instruments: Choose this if the patch for which you are creating a map
contains many different percussion instruments, such as the General MIDI drum map.

●

Single Instruments: Choose this if the patch for which you are creating a map contains
only a single percussion instrument, perhaps with multiple playback playing techniques
for that instrument. For example, a snare drumline patch in Virtual Drumline or another
specialist sound library.
This can also be useful when your VST instrument has several patches that have the
same playback playing technique mappings. For example, there are both large and small
cymbal patches in HALion Symphonic Orchestra which provide natural strike and roll
sounds. Creating a single individual instrument percussion map allows you to use the
same mapping for these sounds for multiple patches.

5

Drum Kit Note Map section
Contains subsections that allow you to view, edit, and control the drum kit notes in the
selected percussion map.
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6

Drum Kit Note Map table
By default, the table shows the drum kit notes in use by the selected percussion map in
numerical order. The table also contains the following columns, which display the
corresponding available data about the selected drum kit note:
●

MIDI Note

●

Name

●

Instrument

●

Key Switch

●

Playing Techniques

At the bottom of the table there are the following options:
●

Show all: Shows all MIDI notes from 0 to 127.

●

Show MIDI Notes in Use: Only shows the MIDI notes in use by the selected percussion
map.

●

Add Key Switch Alternative: Duplicates the selected drum kit note.

●

Clear: Deletes the selected drum kit note.

You can change the data for the currently selected drum kit note in the Edit Drum Kit Note
subsection.
7

Edit Drum Kit Note subsection
Allows you to specify data in the following fields for the drum kit note currently selected in
the Drum Kit Note Map table:
●

Name: The displayed name for the specific combination of instrument and playback
playing technique. You may choose to input the name used in the manufacturer’s
documentation for your VST instrument or MIDI output device.

●

Instrument: Allows you to select an instrument for the drum kit note selected in the
Drum Kit Note Map section from a list of all the unpitched percussion instruments you
can create in Dorico Pro.

●

Key switches: Allows you to specify the MIDI note number of the key you want to use as
a key switch if this sound requires another MIDI note to be played to trigger this specific
combination of instrument and playback playing techniques.
NOTE
Key switches are not compulsory.

●

8

Techniques: Allows you to select a playback playing technique to apply to the
instrument selected in the Instrument field from a list of the available playback playing
techniques.

Reset to Library Defaults
Allows you to revert any changes you have made to the percussion maps from the Default
Library.

9

Import Library
Opens the File Explorer/macOS Finder, where you can select the .doricolib files that you
want to import as percussion maps.

10 Export Library
Opens the File Explorer/macOS Finder, where you can select the location to which you want
to export the currently selected percussion maps as a .doricolib file. You can then import
the .doricolib file into other projects and share it with other users.
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Creating new percussion maps
You can create new percussion maps from scratch and you can duplicate existing percussion
maps and edit the settings, for example, to obtain correct playback when using third-party sound
libraries or MIDI devices.
PROCEDURE
1.

Choose Play > Percussion Maps to open the Percussion Maps dialog.

2.

Create a new percussion map in any of the following ways:

3.

●

To create an empty percussion map, click Add Percussion Map in the action bar.

●

To create a copy of an existing percussion map, select it in the percussion maps list and
click Duplicate Percussion Map in the action bar.

In the Percussion Map Data section, click Lock Info to unlock the fields.

Locked

4.

Unlocked

Enter the display name you want for the percussion map in the Name field.
This name appears in the Endpoint Setup dialog.

5.

Enter any unique identification name in the ID field.
It can be useful to include the instrument and sound library for which you created the map,
as well as your name, in the identification name for percussion maps, for example,
xmap.user.paulsmith.hso.cowbell.

6.

Choose one of the following options for Map defines sounds for, as appropriate for the
current percussion map:
●

Multiple Instruments

●

Single Instruments

7.

In the Drum Kit Note Map section, click Show all to show unmapped notes.

8.

Select the row corresponding to the MIDI note for which you want to create a new mapping.

9.

In the Edit Drum Kit Note subsection, click the following button beside the Instrument field
to open a dialog containing a list of percussion instruments.

10. Select the instrument that corresponds to the sound produced by the selected MIDI note.
11. Click OK.
12. In the Edit Drum Kit Note subsection, click the following button beside the Techniques field
to open the Playing Technique Combinations dialog.

13. Select the appropriate playback playing techniques for the sound produced by the selected
MIDI note.
For example, Ctrl/Cmd -click Buzz roll and Rim.
14. Click OK.
15. In the Edit Drum Kit Note subsection, enter the display name you want for this combination
of instrument and playing technique in the Name field.
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16. In the Key switches field, specify the MIDI note number of the key switch if this sound
requires one.
17. Click Apply.
18. Optional: Repeat these steps for each MIDI note until you have created all the required
mappings for your project.
19. Click OK to save your changes and close the dialog.
RESULT
Your new percussion map is created.
AFTER COMPLETING THIS TASK
You must assign percussion maps to the same endpoints as the VST instruments or MIDI devices
that provide the corresponding patches.
You can export the percussion map if you want to use it in other projects.
RELATED LINKS
Percussion maps on page 583
Assigning expression/percussion maps to endpoints on page 572
Endpoint Setup dialog on page 567

Importing percussion maps
You can import percussion maps into projects. Percussion maps are saved as .doricolib files.
PROCEDURE
1.

Choose Play > Percussion Maps to open the Percussion Maps dialog.

2.

Click Import Library to open the File Explorer/macOS Finder.

3.

In the File Explorer/macOS Finder, locate and select the percussion map file you want to
import.

4.

Click Open.

RESULT
The selected percussion map is imported into your project. It appears in the percussion maps list.

Exporting percussion maps
You can export percussion maps so you can use them in other projects. Percussion maps are
saved as .doricolib files.
PROCEDURE
1.

Choose Play > Percussion Maps to open the Percussion Maps dialog.

2.

In the percussion maps list, select the percussion maps you want to export.

3.

Click Export Library to open the File Explorer/macOS Finder.

4.

In the File Explorer/macOS Finder, specify a name and location for the library file.

5.

Click Save.

RESULT
The selected percussion maps are exported as a library file and saved in the selected location.
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Defining how combinations of articulations and single-note
tremolos sound in playback
You can define specific playback behaviors for particular combinations of articulations and
single-note tremolos in playing technique-specific noteheads for unpitched percussion
instruments.
PROCEDURE
1.

In Setup mode, open the Percussion Instrument Playing Techniques dialog in any of the
following ways:
●

For an individual percussion instrument: In the Players panel, expand the card of the
player holding the instrument, click the arrow in the instrument label, and choose Edit
Percussion Playing Techniques from the menu.

●

For percussion instruments that are part of percussion kits: In the Players panel, click
the arrow in the kit instrument label, and choose Edit Percussion Kit to open the Edit
Percussion Kit dialog, select the instrument whose playing techniques you want to edit
in the main editing area, and click Edit Percussion Playing Techniques.

2.

Select the playing technique-specific notehead whose playback behaviors you want to define
in the list at the top of the dialog.

3.

Click Add Technique in the action bar at the bottom left of the dialog.

4.

Click Choose Playing Techniques beside the Playback playing technique field.

5.

Select the playback playing technique you want from the list in the dialog that opens.
You can select multiple playback playing techniques by holding down Ctrl/Cmd and clicking
the playback playing techniques you want.

6.

Choose one of the following options:
●

Replace: Allows you to use this playing technique instead of the default playing
technique defined for this combination of notehead and staff position.

●

Add: Allows you to add this playing technique on top of the default playing technique
defined for this combination of notehead and staff position.

7.

Choose any articulations and the tremolo stroke that you want from the available options.

8.

Click OK to save your changes and close the dialog.

RESULT
The behavior of the selected playing technique in playback is changed.
RELATED LINKS
Percussion Instrument Playing Techniques dialog on page 1283
Creating new playing technique-specific noteheads for unpitched percussion instruments on
page 1286
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Played vs. notated note durations
You can show notes in the piano roll editor in Play mode with their played duration or notated
duration.

Played duration
When Played Durations in the Play toolbox is selected, note events in the piano roll editor are
each shown with two components:
●

A filled, light-colored rectangle showing the played duration of the note.

●

A thin, darker rod showing the notated duration of the note.

For example, notes with staccato articulations are played for less time than their notated
duration, whereas notes under slurs are played for longer than their notated duration.
By default in Dorico Pro, notes in the piano roll editor in Play mode are shown with their played
duration.
NOTE
Editing the played duration of notes causes them to appear in a darker color in the piano roll
editor to notes whose played duration you have not changed.

Notated duration
You can select Notated Durations in the Play toolbox to see note events as single rectangles,
which span the full width that corresponds to the notated duration of the note.
You can change the notated duration of notes in the piano roll editor when Notated Durations
is selected.
EXAMPLE
The following examples all contain the same musical phrase, shown in different ways.
Played duration

Notated duration

Score

RELATED LINKS
Slurs in playback on page 1144

Changing the played duration of notes
You can change the played duration of notes individually, both at the start and end of notes. For
example, you can make notes sound for longer or start sounding later.
PREREQUISITE
●

Played Durations is selected in the Play toolbox.

●

Object Selection is selected in the Play toolbox.
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PROCEDURE
1.

In the piano roll editor, select the notes whose played duration you want to change.

2.

Click and drag the end of one of the notes to the right/left.
Your mouse pointer becomes a two-way arrow when you are in the correct position.

3.

Optional: Repeat step 2 for the start of the notes.

RESULT
The played duration of the selected notes is changed.
RELATED LINKS
Play toolbox on page 496

Resetting playback overrides
You can remove all changes made to how individual notes play back, for example, if you
previously changed the played duration of notes and want to revert them to their default start
position, length, and velocity.
Removing playback overrides also removes any offsets to the start and end position of notes
imported from MIDI files with preserved note positions.
NOTE
Any note velocities that are set on notes are reflected in playback, for example, from imported
MIDI files or MIDI recording. If you want dynamics you input in Write mode to be reflected in
playback instead, you must remove playback overrides.

PROCEDURE
1.

In the piano roll editor or drum editor, select the notes whose playback overrides you want
to reset.

2.

Choose Play > Reset Playback Overrides.

RESULT
All playback overrides are removed from the selected notes.
NOTE
The played duration of the selected notes initially appears to revert to match their notated
duration. However, starting playback or switching modes refreshes their appearance to their
default played duration. For example, if the notes are staccato, their played duration is half their
notated duration by default.

RELATED LINKS
Velocity lanes on page 521
MIDI recording on page 204
Importing MIDI on page 81
MIDI Import Options dialog on page 81
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Print mode allows you to print your layouts or to export them as graphics files, such as PDF and
SVG.
●

When printing layouts, you can specify the paper size and other options, such as duplex or
booklet printing.

●

When exporting layouts, you can specify different graphics file types and the information
you want to include in their exported file names.

Project window in Print mode
The project window in Print mode contains the default toolbar and the print preview area as well
as panels and sections that provide all the tools and functions that allow you to prepare printing
or exporting your layouts.
You can switch to Print mode in any of the following ways:
●

Press Ctrl/Cmd-5 .

●

Click Print in the toolbar.

●

Choose Window > Print.

Panels and sections in Print mode

The following panels and sections are available in Print mode:
1

Layouts panel
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Shows a list of all layouts in your project and allows you to select what to print or export.
NOTE
The layout selector in the toolbar is disabled in Print mode. If you want to see a different
layout in the print preview area, select it in the Layouts panel.
2

Print Options panel
Contains options for printing or exporting your layouts.

3

System Dialogs (macOS only)
Contains macOS-specific printing options.

4

View options
Allows you to change the print preview area to show pages in one of the following views:
●

Page Width: The page fills the width of the print preview area, which might not show
the whole page depending on the orientation and format of the page.

●

Whole Page: Shows the whole page in the print preview area.

TIP
You can go directly to the first page in the layout by pressing Home , and to the last page by
pressing End . You can change these key commands on the Key Commands page in
Preferences.

RELATED LINKS
Toolbar on page 43
Print preview area on page 49
Key Commands page in the Preferences dialog on page 63

Layouts panel (Print mode)
In Print mode, the Layouts panel shows a list of all layouts in your project and allows you to
select layouts to print or export. It is located on the left of the window.
You can hide/show the Layouts panel in Print mode in any of the following ways:
●

Press Ctrl/Cmd-7 .

●

Click the disclosure arrow on the left edge of the main window.

●

Choose Window > Show Left Panel.

Layouts panel in Print mode

The Layouts panel contains all the layouts in your project, displayed as cards. Each layout card
shows the following:
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1

Disclosure arrow
Expands/Collapses the layout card.

2

Layout type
Shows the type of layout from the following options:

3

●

Full score layout

●

Instrumental part layout

●

Custom score layout

Layout name
Shows the name of the layout. Dorico Pro automatically adds default names depending on
the name of the instrument that is assigned to a player and on the type of layout that is
added. For example, if you assign a flute to a player, the instrumental part layout
automatically gets the same name. If you add an empty instrumental part layout, the layout
name shows Empty part and an incremental number if you add multiple empty part layouts.

4

Page size and orientation
Shows the size and orientation of the layout as set on the Page Setup page in Setup >
Layout Options.

5

Layout length
Shows the number of pages in the layout. You can use this in combination with its page size
and orientation to determine the best job type for printing/exporting.
TIP
A layout with two pages might best be printed as 2-up, while a layout with five pages might
best be printed as spreads with the final page printed on a different paper size. A layout with
12 pages might best be printed as a booklet.

The selected layouts are printed/exported when you click Print or Export. If you have selected
some layouts set to print and some set to export graphics, the button reads Print and Export.
RELATED LINKS
Page arrangements for printing/exporting on page 604
Booklet printing on page 605

Print Options panel
The Print Options panel contains options for printing or exporting your layouts. It is located on
the right of the window in Print mode.
You can hide/show the Print Options panel in any of the following ways:
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●

Press Ctrl/Cmd-9 .

●

Click the disclosure arrow on the right edge of the main window.

●

Choose Window > Show Right Panel.

All the options that you set in the Print Options panel are saved with your project. The options
are divided into the following sections:
Destination
Allows you to select a physical printer for printing or a file location for exporting a
graphics file. If you print your work, you can choose how many copies you want to
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print. If you choose to export a graphics file, you can specify the format, file name, and
directory of the saved file.
Depending on the destination type selected, the button at the bottom of the panel
reads either Print or Export. If you have selected some layouts set to print and some
set to export graphics, the button reads Print and Export.
Job Type
Allows you to choose the range of pages to be printed or exported and how they are
arranged.
Page Setup
Allows you to set the paper size and orientation. You can specify the scale factor of the
image to be printed or exported.
Duplex Printing
Allows you to specify whether to print on one or on both sides of each sheet of paper.
This option is only available if you select Printer in the Destination section.
Annotations
Allows you to activate options that are often required by publishing houses or printing
agencies, such as crop marks or a border around the printed image.
Print button
Allows you to print/export selected layouts according to the settings you have set in
the Print Options panel.
Depending on your selection, the print button can appear in one of the following ways:
●

Print

●

Export

●

Print and Export

For example, if you selected layouts that are all set to print, Print is shown. If you
selected some layouts set to export graphics and some layouts set to print, Print and
Export is shown.
RELATED LINKS
Duplex printing on page 606
Page arrangements for printing/exporting on page 604

Printing layouts
You can print layouts individually or multiple layouts together. You can specify print settings for
each layout independently, for example, you can select different printers for different layouts in
the same project.
Dorico Pro uses settings for layouts to create automatic print settings, so you might find that
many print options are already appropriate for the layouts you want to print. For example, if you
are connected to a printer that can print A3 paper and the page size of your full score layout is
set to A3 in Layout Options, Dorico Pro automatically selects A3 in the Page Setup section of the
Print Options panel.
PROCEDURE
1.

In the Layouts panel, select the layouts that you want to print.
NOTE
The layout selector in the toolbar is disabled in Print mode. If you want to see a different
layout in the print preview area, select it in the Layouts panel.
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2.

In the Print Options panel, enter the number of copies you want into the Copies field in the
Destination section.
NOTE
●

Changing the Copies value changes the number of copies for all currently selected
layouts. However, you can change the number of copies for layouts individually. For
example, you can select a full score layout and set it to print 3 copies and leave the part
layouts to print only 1 copy. You can then select all layouts to print them together and
the previously set values are followed.

●

The Copies field appears blank when you have selected layouts with different values.

3.

Activate/Deactivate Collate copies.

4.

In the Destination section, choose Printer and select a printer from the menu.

5.

In the Job Type section, select the page arrangement you want from the menu.

6.

Optional: If you only want to print a specified range of pages, choose Page Range in the Job
Type section.

7.

Optional: If you selected Page Range, enter the pages you want into the value field.
●

To specify a range, enter the first page and last page separated with a dash, such as 1-4.

●

To specify individual pages or separate ranges, enter each page/range separated with
commas, such as 1,3,5-8.

8.

In the Page Setup section, select a paper size from the menu.

9.

Choose the paper orientation you want.

10. Optional: If you selected Spreads or 2-up for the job type, activate/deactivate Print odd final
page on to specify the paper size on which you want to print final pages for layouts with odd
numbers of pages.
11. Select a paper size and paper orientation for the odd final page.
12. Choose one of the following size options:
●

Fit to Paper

●

Custom Scale

13. Optional: If you selected Custom Scale, enter the scale factor you want into the Scale factor
field.
14. In the Duplex Printing section, select one of the printing options from the Print on menu.
15. Optional: If you selected a duplex printing option, use the bottom two menus to select how
the printed image is flipped when printing on the reverse side of the paper.
16. In the Annotations section, activate each annotation you want to add to the selected
layouts.
17. Click Print.
RESULT
The selected layouts are printed according to the print settings you have applied.
If your selection included part layouts set to concert pitch, Dorico Pro shows a warning and offers
to switch them all to transposed pitch before printing/exporting. You can also select which
layouts you want to switch to transposed pitch or proceed anyway with no changes.
TIP
●

You can select individual layouts and set up their printing options without printing straight
away. Once you have set up the printing options you want for multiple layouts, you can then
select all the layouts you want to print and click Print. Your existing print settings are
applied, even if your selection contains layouts with different print settings.
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●

You can assign key commands to different printing and exporting commands on the Key
Commands page in Preferences.

RELATED LINKS
Key Commands page in the Preferences dialog on page 63
Printers on page 604
Paper size and orientation setup on page 608
Export File Names dialog on page 601
Page arrangements for printing/exporting on page 604
Print Options panel on page 594
Duplex printing on page 606
Annotations on page 610
Changing the page size and orientation on page 436

Printing/Exporting a page range
By default, Dorico Pro prints/exports all pages of the selected layouts. You can specify a specific
page range to print/export.
NOTE
You can only print booklets using the complete range of pages. You cannot define any page
ranges.

PROCEDURE
1.

In the Layouts panel, select the layouts from which you want to print/export a range of
pages.

2.

Optional: In the Destination section, check the layouts are set to print/export using the
printer/graphics file formats you want.

3.

In the Job Type section, choose Page Range.

4.

Enter the pages you want into the value field.
●

To specify a range, enter the first page and last page separated with a dash, such as 1-4.

●

To specify individual pages or separate ranges, enter each page/range separated with
commas, such as 1,3,5-8.
NOTE
Separate ranges are exported as separate files.

5.

Click Print/Export/Print and Export.

RESULT
The specified pages in the selected layouts are printed/exported. Exported files use the file name
recipe set for their graphics file format in the Export File Names dialog.
RELATED LINKS
Export File Names dialog on page 601
Page arrangements for printing/exporting on page 604
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Specifying printing options (macOS only)
Dorico Pro allows you to access the standard printing options of your operating system.
NOTE
If you use the standard printing options of your operating system, the settings in the Print
Options panel are ignored. macOS-specific print settings are not saved with your project. These
must be set each time you want to print, whereas the Dorico Pro print options are always saved
with your project.

PROCEDURE
1.

In the Layouts panel, click Page Setup in the OS X Dialogs section to open the macOS Page
Setup dialog.

2.

In the Page Setup dialog, set the paper size.

3.

Click OK.

4.

In the OS X Dialogs section, click Print to open the macOS Print.

5.

In the Print dialog, set up the printing options you want.

Exporting layouts as graphics files
You can export individual layouts as a variety of graphics files, such as PDF or PNG.
PROCEDURE
1.

In the Layouts panel, select the layouts you want to export.

2.

In the Print Options panel, choose Graphics in the Destination section.

3.

Choose a color mode.
●

Mono exports the graphic in black and white.

●

Color exports the graphic in full color.

NOTE
●

If you export a graphics file with a resolution of 72 dpi, we recommend that you select
Color. If you select Mono, staff lines can disappear.

●

If you want to export layouts with watermarks, you must choose Color.

4.

Select a graphics file format from the menu.

5.

Optional: If you selected PNG or TIFF, select a resolution from the Resolution menu.
TIP
The Resolution setting does not affect PDF and SVG files as they are vector formats.

6.

Optional: Specify an export path.

7.

Optional: If you want to change the file name recipe, click File Name Options to open the
Export File Names dialog.

8.

Optional: In the Export File Names dialog, change the file name recipe for your selected
graphics file formats.

9.

Optional: If you only want to export a specified range of pages, choose Page Range in the
Job Type section.

10. Optional: If you selected Page Range, enter the pages you want into the value field.
●

To specify a range, enter the first page and last page separated with a dash, such as 1-4.
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●

To specify individual pages or separate ranges, enter each page/range separated with
commas, such as 1,3,5-8.
NOTE
Separate ranges are exported as separate files.

11. In the Page Setup section, choose the page orientation you want.
12. In the Annotations section, activate each annotation you want to add to the selected
layouts.
NOTE
Watermarks are only included in layouts exported as Color graphics.
13. Click Export.
RESULT
The selected layouts are exported as the selected graphics format using the file name recipe set
for their graphics file format in the Export File Names dialog. They are saved in the folder set in
the Destination folder field, or in the same folder as the project file if the set export path is no
longer accessible.
If your selection included part layouts set to concert pitch, Dorico Pro shows a warning and offers
to switch them all to transposed pitch before printing/exporting. You can also select which
layouts you want to switch to transposed pitch or proceed anyway with no changes.
TIP
You can assign key commands to different printing and exporting commands on the Key
Commands page in Preferences.

RELATED LINKS
Printing/Exporting a page range on page 598
Export File Names dialog on page 601
Graphics file formats on page 609
Image resolution on page 609
Key Commands page in the Preferences dialog on page 63
Annotations on page 610

Specifying an export path for graphics files
You can specify a path to any folder to which you want to export graphics files. You can specify a
different export path for each layout and still export them all simultaneously.
By default, Dorico Pro exports graphics files into the same folder as your project file. If you have
not saved your project yet, graphics files are saved in the default user folder of your operating
system.
PROCEDURE
1.

In the Layouts list, select the layouts whose export path you want to change.

2.

In the Destination section of the Print Options panel, click Choose Folder beside the
Destination folder field to open the File Explorer/macOS Finder.

3.

In the File Explorer/macOS Finder, locate and select the destination folder you want.
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4.

Click Select Folder (Windows)/Open (macOS) to insert the new path in the Destination
folder field.

5.

Optional: Repeat steps 1 to 4 for other layouts whose export path you want to change.

6.

Optional: If you want to change the file name recipe, click File Name Options to open the
Export File Names dialog.

7.

Optional: In the Export File Names dialog, change the file name recipe for your selected
graphics file formats.

RESULT
The export path for the selected layouts is changed. When exported, the layouts use the file
name recipe set for their graphics file format in the Export File Names dialog.
NOTE
If the export path specified is no longer accessible, such as if you receive a project from someone
who uses a different operating system, Dorico Pro automatically updates the export path to the
same location as the project file.

Export File Names dialog
The Export File Names dialog allows you to determine the contents of file names for each
graphics file format independently. You can use universal ingredients that update to show the
correct information for each layout automatically, and you can enter text that is the same for all
layouts.
You can open the Export File Names dialog in any of the following ways:
●

Click File Name Options in the Destination section of the Print Options panel in Print mode
when the currently selected layout is set to Graphics.

●

Click Edit in the Exporting Files subsection of the General page in Preferences.

NOTE
Your settings are linked between both ways of accessing the dialog and are saved as the default
for all future projects.
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The Export File Names dialog contains the following options:
1

File names for
Allows you to select different graphics file formats. You can set different file name recipes for
each graphics file format.

2

Preview
Displays an example file name based on the current recipe. The layout used for the preview
is the one shown in the layout selector in the toolbar.
For example, the preview for a full score PDF file name using the default recipe might be
01 - Full score - Lieder.pdf

3

File name recipe
Displays the recipe for the selected graphics file format. You can enter text directly into this
field, and click ingredients to add them automatically.
For example, the default PDF file name recipe is $n - $l - $t.

4

Reset to Default
Resets the file name recipe to the default for the selected graphics file format.

5

Copy to All
Copies the file name recipe to all layouts in the project.

6

File name ingredients
Allow you to add ingredients to the file name recipe quickly that are automatically populated
as appropriate for each layout. For example, the ingredient $l becomes Piano when used to
export a piano part layout.
The buttons for each ingredient display both the information to which the ingredient refers
and the characters for it.
When you click file name ingredients, they are added to the end of the file name recipe. They
are automatically separated from the previous ingredient using the default separator.
NOTE
The page number ingredient is not available for the PDF file name recipe as it is a multi-page
format.
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7

Default separator
Allows you to set the characters used to separate ingredients in the file name recipe by
default.

RELATED LINKS
Exporting layouts as graphics files on page 599

Monochrome and color graphics processing
Dorico Pro applies different settings when you export monochrome and color graphics. The most
appropriate setting depends on your intended purpose for the graphics.
Most musical scores are monochrome, meaning they use only black ink and are normally printed
on white/near-white paper. Some educational books occasionally use colors to highlight
particular notations, for example, to identify clefs, or to color notes according to their pitch. If
you export graphics files and print them with your own printer, you can leave Color selected in
the Destination section.
However, if you export graphics files in PDF format for direct printing on a platesetter or for
further production work in a page layout program, select Mono, unless your layout actually
contains colored elements. If you select Mono, Dorico Pro uses a different color space for the
resulting PDF, ensuring that the printed image only uses black ink. If you choose Color, then the
black items in your layout are exported as rich black, that is, black produced by combining
multiple colored inks. This can cause problems in production when making color separations at
the pre-press stage.
Dorico Pro specifies colors using the RGB color model, rather than the CMYK color model that is
used by platesetters and other professional printing machines. If you have colored objects in
your layouts and your layouts are printed professionally, you must post-process the graphics files
that are exported from Dorico Pro in another graphics application to convert the colors from RGB
to CMYK.
RELATED LINKS
Exporting layouts as graphics files on page 599

Embedding of fonts in PDF and SVG files
How fonts are handled in PDF and SVG files mainly depends on the fonts that you use in the
project.
PDF Files
The music and text fonts, and their sub-sets, that are supplied with Dorico Pro are
embedded in PDF files during the export. If you open the PDF files on a different
computer, they look the same, even if that computer does not have the fonts installed
that are used in the document. If you use different fonts, make sure that these permit
embedding.
SVG Files
SVG (Scalable Vector Graphics) files do not embed fonts directly. Some font characters,
such as note heads, articulations, and accidentals, are converted into outlines, so that
they do not depend on the font from which they are taken. Other font characters, such
as time signature and tuplet digits, are only encoded using references to the font from
which they are taken. The latter also applies to regular text, such as staff labels, tempo
instructions, and dynamics. This means that the SVG file looks incorrect if rendered by
a web browser on a computer that does not have the fonts installed. The appearance
of SVG files depends on the browser or the rendering software, and on the fonts that
are installed on the computer.
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To ensure that the SVG file appears correctly if embedded in a web page, you can open
the SVG file in an illustration program and convert all font characters to outline paths,
then re-export the SVG file and embed that file. Alternatively, you can use web fonts to
ensure that the necessary fonts are available on the web server.
SVG graphics that are exported from Dorico Pro conform to the SVG Tiny 1.1
specification, which defines a subset of features in the full SVG specification.
For information about using web fonts with SVG, refer to the Help Center on the
Steinberg website.

Printers
You can print layouts from Dorico Pro projects to any printer to which your computer is
connected.
You can select different printers for each layout in your project. This allows you to send layouts to
the most appropriate printer for their requirements. You can select a printer when Printer is
chosen in the Destination section of the Print Options panel.
Dorico Pro uses the same printer as designated by the operating system by default, unless you
specify another printer. In this case, the settings in the following sections in the Print Options
panel can change:
●

In the Page Setup section, the list of available paper sizes lists only paper sizes that the
chosen printer provides.

●

In the Duplex Printing section, the option for automatic duplex printing is only available if
the chosen printer has this function.

NOTE
The printer menu in the Destination section only shows the name of a printer if all currently
selected layouts are set to print to the same printer. If you select a new printer from the menu,
all selected layouts are set to print to that printer.

RELATED LINKS
Print Options panel on page 594
Printing layouts on page 596

Page arrangements for printing/exporting
Dorico Pro provides several page arrangements that you can use for printing/exporting your
layouts.
In the Job Type section of the Print Options panel, you can specify how you want the layouts to
be printed/exported. You can select the following job types from the Job Type menu:
Normal
Prints one page on each sheet of paper. This produces single-sided pages, for example,
for instrumental parts that do not have regular page turns and must be bound in a
continuous line.
Spreads
Prints two pages on each sheet of paper, with odd-numbered pages on the right-hand
side and even-numbered pages on the left-hand side.
You can also specify a paper size on which to print odd final pages, for example, if you
are printing a layout containing five pages.
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2-up
Prints two pages on each sheet of paper. The first page in the range is printed on the
left-hand side of the first sheet of paper. This can be useful for printing instrument
parts as it reduces the number of edges that must be bound, because pages can also
be folded in half.
You can also specify a paper size on which to print odd final pages, for example, if you
are printing a layout containing five pages.
Booklet
Prints two pages on each sheet of paper according to imposition requirements. This
means that if the paper is folded, the pages are laid out like a book. This can be useful
for scores and choir parts in particular as they often contain more pages than
instrumental parts.
NOTE
You can only print booklets using the complete range of pages. You cannot define any
page ranges.
NOTE
●

Depending on the job type that you choose, Dorico Pro switches the page orientation
automatically. The changed orientation is immediately displayed in the music area. If this is
not what you want, you can override the orientation in the Page Setup section.

●

All of the job types allow printing either onto a single side of each sheet of paper or on both
sides of the paper.

●

It is usual to print booklets, spreads, and 2-up onto paper in landscape orientation. Printing
one page to each sheet typically uses portrait orientation, unless the layout itself uses
landscape orientation.

Also in the Job Type section, you can choose which pages you want to print/export.
All Pages
Allows you to print/export all pages of the selected layouts.
Page Range
Allows you to set a range of pages to be printed. Choosing Page Range makes the
value field available.
●

To specify a range, enter the first page and last page separated with a dash, such
as 1-4.

●

To specify individual pages or separate ranges, enter each page/range separated
with commas, such as 1,3,5-8.

RELATED LINKS
Paper size and orientation setup on page 608
Printing/Exporting a page range on page 598

Booklet printing
Booklets are documents printed on both sides of the paper and folded to resemble the pages in
a book. When printed as a booklet, pages are reordered so that you can fold the printed pages
and read the content in the same order as they were in the project.
Printing layouts as a booklet can be much quicker than printing pages single-sided or doublesided. For example, if your full score is twenty pages long and you print it on both sides
automatically, you must then bind one edge of the printed pages in order to keep them together.
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However, if you print the full score as a booklet, you can simply fold the printed pages in the
middle.
Booklet printing settings reorder pages so that they appear in the correct order on the printed
page. For example, a layout containing four pages printed as a booklet is laid out as follows:
●

First side: page four on the left, page one on the right

●

Reverse side: page two on the left, page three on the right

If the layout you are printing as a booklet contains an odd number of pages, Dorico Pro
automatically places any empty last pages at the end of the booklet. This follows the convention
of showing odd-numbered pages on the right. For example, if you print a layout containing six
pages as a booklet, a total of eight pages are printed with the last two pages in the booklet left
blank. If you want the empty pages to be positioned differently, you can add extra pages to the
layout, for example, a title page.
NOTE
●

You can only print booklets using the complete range of pages. You cannot define any page
ranges.

●

If the order of inward pages is incorrect when you are printing booklets using manual
duplexing, you can activate Reverse order of outward pages in the Duplex Printing section
of the Print Options panel, which instructs Dorico Pro to output the first set of pages in the
opposite order.

RELATED LINKS
Printing layouts on page 596
Duplex printing on page 606

Duplex printing
Dorico Pro allows duplex printing, which means that you can print on both sides of each sheet of
paper.
If your printer supports automatic duplex printing, you can use this function in Dorico Pro. If
your printer can only print on one side of each sheet of paper, there is a manual duplex printing
option.
The Print on menu in the Duplex Printing section of the Print Options panel contains the
following options:
One side only
Prints on one side of each sheet of paper.
Both sides manually
Prints on both sides of each sheet of paper. Use this option if you printer lacks an
automatic duplex printing function. After all outward pages have been sent to the
printer, a message box informs you to turn over the stack of printed pages and put
them back into the printer. Click OK to continue printing the inward pages.
Both sides automatically
Prints on both sides of each sheet of paper automatically. This option is only available if
your printer supports this type of printing.
The other menus in the Duplex Printing section allow you to set how the printed image is
flipped when printing on the reverse side of the paper.
Flip image (portrait)
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Determines how the image is flipped for reverse side printing in portrait orientation.
●

Flip automatically uses the printer’s default settings for printing on the reverse
side. If you find that the printer flips on a different edge than expected, use one of
the other options.

●

Flip long side sets the printer to flip the pages on the long edge.

●

Flip short side sets the printer to flip the pages on the short edge.

Flip image (landscape)
Determines how the image is flipped for reverse side printing in landscape orientation.
●

Flip automatically uses the printer’s default settings for printing on the reverse
side. If you find that the printer flips on a different edge than expected, use one of
the other options.

●

Flip long side sets the printer to flip the pages on the long edge.

●

Flip short side sets the printer to flip the pages on the short edge.

Reverse order of outward pages at the bottom of the section instructs Dorico Pro, when
activated, to output the first set of pages in the opposite order when printing booklets using
manual duplexing. This is necessary for some printers so that you do not have to reverse sort the
pages manually before returning them to the printer to print the other sides.
RELATED LINKS
Printing layouts on page 596

Page sizes and paper sizes
In Dorico Pro, page sizes and paper sizes use different settings. This means that you can print
layouts with any page size onto paper with a different paper size.
For each layout in your project, you can define a page size on the Page Setup page in Setup >
Layout Options. This means that you define the dimensions of the layout. For printing your
layout, you must usually choose a paper size that is provided by the printer that you are using.
Normally, the layout's page size and the printed paper size match. However, if you define a
layout with an unusual page size that is not supported by your printer, such as 10" x 13", one of
the standard page sizes for instrumental parts, you may have to print the layout onto a different
paper size. You can change the paper size in the Page Setup section of the Print Options panel
according to your needs. As long as your printer supports sufficiently large paper for your page
size settings, and they match a standard paper size, your dimensions are included in the menu.
Changing the paper size has no effect on your layout's page size, and does not, therefore, affect
the way the music is laid out.
If you do not select a specific paper size, Dorico Pro automatically chooses a paper size that is
based on your computer's locale settings. For example, if these are set to a European country, an
international ISO standard might be used, such as A4. If they are set to a North American
country, one of their typical standards might be used, such as US Letter.
If you have defined a page size for your layout that is larger than a typical standard, Dorico Pro
automatically chooses the next larger paper size, provided that your printer supports this. For
example, if the layout's page size is larger than A4/US Letter, A3/Tabloid is used.
If you print to a different paper size than the layout's page size, Dorico Pro automatically scales
the image to fit the paper. You can change this setting by specifying a custom scale factor in the
Page Setup section.
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Paper orientation
Paper orientation is the direction of rectangular paper for viewing and printing. Paper can have
either landscape or portrait orientation.
Instrumental parts are most often printed using portrait orientation, as this allows two or three
pages to be spread out at a time on most music stands.
Full scores for conductors are also commonly printed using portrait orientation, as this allows
more staves to fit on the page than with landscape orientation. However, full scores for small
ensembles might use landscape orientation as fewer staves have to fit on the page. Having more
horizontal room on the page allows more bars to fit on each page, reducing the number of page
turns required.
In Dorico Pro, you can set the orientation of pages independently of the paper orientation, for
example, you can print portrait pages on landscape paper. You can also separately set the paper
orientation of the odd final page in layouts using the Spreads and 2-up page arrangements.
RELATED LINKS
Changing the page size and orientation on page 436

Paper size and orientation setup
Layouts can have different paper sizes and orientation settings.
NOTE
If you have selected Graphics in the Destination section of the Print Options panel, you can only
change the paper orientation. No other options are available.
The Page Setup section of the Print Options panel contains the following options when you have
chosen Printer in the Destination section:
Paper size
Allows you to select one of the available paper sizes from the menu. The paper sizes
available depend on the capabilities of the selected printer.
Paper orientation
You can choose one of the following paper orientation options:
●

Portrait

●

Landscape

Print odd final page on
For Spreads and 2-up job types only: If this is activated, you can select a different
paper size or orientation for the odd final page.
This setting is useful when printing layouts with an odd number of pages on A3 paper
in landscape orientation. For example, if your layout contains five pages, the first four
pages fit onto two sheets of A3, while the fifth page would occupy only the left-hand
side of a third sheet of A3. This setting allows you to print the odd final page on A4
paper in portrait orientation instead.
Fit to Paper
The whole page is scaled to fit the paper size selected. For example, if you select a
layout with a page size of A4 and select a paper size of A3, pages in the layout are
enlarged to fit the larger paper size.
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Custom Scale
The page is scaled to the set percentage of its original size. For example, if you are
printing a layout with a page size of A3, select a paper size of A4, and set Custom Scale
to 100, the original page remains at its original size, exceeding the boundaries of the
A4 paper.
RELATED LINKS
Page arrangements for printing/exporting on page 604
Changing the page size and orientation on page 436

Graphics file formats
Dorico Pro supports multiple graphics file formats as which you can export your layouts.
PDF
Stands for Portable Document Format. Exporting layouts to PDF allows you to create a
platform-independent document that contains a fixed version of each layout, for
example, to send to someone who does not have access to Dorico Pro.
PNG
Stands for Portable Network Graphics. PNG files are losslessly compressed, meaning
they produce high-quality images.
SVG
Stands for Scalable Vector Graphics. Because SVG is an XML-based text format, it can
be scaled to any size without any loss of quality. Dorico Pro renders SVG graphics using
drawing instructions rather than rasterizing them, resulting in better resolutions and
smaller file sizes.
TIFF
Stands for Tagged Image File Format. TIFF files are not compressed, which means their
file sizes can be larger than other formats and the quality of the image is not reduced.
RELATED LINKS
Exporting layouts as graphics files on page 599

Image resolution
Image resolution refers to the number of pixels contained in an image. The larger the number of
pixels, the sharper and clearer the image appears.
In Dorico Pro, you can export PNG and TIFF files with different image resolutions. The image
resolution is measured in dots per inch, or “dpi”.
●

72

●

150

●

300

●

600

●

1200

NOTE
A resolution of 72 dpi is suitable for display on screen so that you can embed the graphic in an email or on a web page. If you choose 300, 600, or 1200 dpi, a high-resolution image is saved that
you can include as an illustration in a word processing or desktop publishing document.
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RELATED LINKS
Exporting layouts as graphics files on page 599

Annotations
Annotations provide additional information for printed or exported documents, such as the date
and time it was printed. Publishers and printing agencies can use these to identify and register
printed images correctly or to embed exported graphics files into a desktop publishing
application.
When printing/exporting your layouts for publication, you can include typical annotations. You
can also allow Dorico Pro to print or export any view options that you have activated in your
project.
NOTE
Crop marks and the border can only be printed if the page size is smaller than the paper size.
The Annotations section of the Print Options panel contains the following options:
Crop marks
Adds short vertical and horizontal lines at each of the four corners of the page.
Border
Adds an outline around the edge of the page dimensions.
Date and time
Adds the date and time of printing at the bottom of each page.
Watermark
Adds large translucent text across the middle of each page. This is useful for indicating
that this version is a draft, proof, or perusal score.
In the Watermark field at the bottom of the section, you can enter the text that you
want to show on each page.
TIP
●

Watermarks use the Print Watermark Font font style. You can edit the formatting
of this font in the Edit Font Styles dialog, for example, to change its font size.

●

Watermarks are only included in layouts exported as Color graphics.

View options
Adds all active view options, such as signposts, comments, and note and rest colors, to
the printout or exported graphic.
RELATED LINKS
Signposts on page 335
Comments on page 343
Edit Font Styles dialog on page 407
Printing layouts on page 596
Exporting layouts as graphics files on page 599
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Introduction
This notation reference contains information about the accepted conventions for presenting
different notations and how to change their appearance and placement in Dorico Pro, both for
individual items and by changing default settings.
It also contains instructions for inputting more complex notations, such as cross-staff glissando
lines, which are described in the corresponding chapter.
Tasks in the notation reference outline the default changes you can make to items, which can
apply per-flow, per-layout or project-wide; for example, changing spacing gaps or the projectwide appearance of pedal lines are both project-wide changes you can make in Engrave >
Engraving Options. Tasks also outline the individual changes you can make to items
independently of your default settings, which often involve using properties in the Properties
panel.
You can find basic input methods for notations in the Write mode chapter.
RELATED LINKS
Write mode on page 152
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Accidentals are shown beside notes to indicate their pitch, both when notated on a staff and
written out in text. In music based in Western tonality, they usually show that the pitch of a note
has been altered so that it does not conform to the current prevailing key signature.
In Dorico Pro, each note has its own fixed pitch that is independent of the prevailing key
signature, and accidentals are automatically hidden and shown as appropriate. For example, if
you input F♮s and then add a D major key signature before them, they do not turn into F♯s; they
remain F♮s and show natural accidentals. However, if you input the D major key signature first,
any Fs you then input without stating an accidental are input as F♯s.
There are different conventions for accidental duration rules, such as not repeating the same
accidental on subsequent notes of the same pitch in the same bar. In music that has no key
signatures, some or all notes might require accidentals, depending on the notation convention in
use.
You can use accidental duration rules to determine when accidentals are shown, and control how
accidentals are arranged in complex chords.
RELATED LINKS
Accidental duration rules on page 619
Inputting notes on page 172
Inputting accidentals on page 188

Deleting accidentals
You can delete accidentals according to their type and you can delete all accidentals from a
selection of notes with different accidentals at the same time. This changes the pitch of the
selected notes.
NOTE
These steps do not apply to cautionary accidentals, such as those shown on natural notes that
follow the same notes with an accidental but in a different octave. In Dorico Pro, you can hide,
show, or parenthesize cautionary accidentals in each flow and on individual notes.

PROCEDURE
1.

In Write mode, select the notes whose accidentals you want to delete.

2.

Delete accidentals in any of the following ways:
●

Press 0 to delete naturals.

●

Press - to delete flats.

●

Press = to delete sharps.

●

Click the button of the accidental in the Notes panel.

RESULT
The corresponding accidentals are deleted from the selected notes. This changes their pitch. For
example, deleting the sharp from a G♯ turns it into G♮.
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NOTE
●

Depending on the accidental duration rule applied to the flow, deleting accidentals might
cause accidentals to appear on subsequent notes of the same pitch in the same bar. You can
check the pitch of notes by selecting them and looking in the status bar.

●

To delete accidentals from a selection of notes with different accidentals, we recommend
that you revert them all to natural by pressing 0 or clicking Natural in the Notes panel. This
is because re-inputting an accidental over a selection of notes with different accidentals adds
that accidental to every note in the selection. For example, two G♯s followed by two G♭s
become four G♯s if you re-input a sharp. If you click Sharp or press = twice, all accidentals
are deleted.

RELATED LINKS
Inputting accidentals on page 188
Hiding/Showing cautionary accidentals on page 621
Changing the pitch of individual notes on page 200
Accidental duration rules on page 619
Status bar on page 52

Hiding/Showing or parenthesizing accidentals
You can show individual accidentals in round or square brackets and hide/show accidentals
individually, including cautionary accidentals shown by default. For example, you can show
cautionary accidentals on subsequent notes in tie chains that cross system/frame breaks by
showing accidentals in round brackets.
PROCEDURE
1.

Select the notes whose accidentals you want to hide/show or parenthesize. You can do this in
Write mode and Engrave mode.
NOTE
You can only select individual noteheads within tie chains in Engrave mode.

2.

In the Properties panel, activate Accidental in the Notes and Rests group.

3.

Select one of the following options from the menu:
●

Hide

●

Show

●

Round brackets

●

Square brackets

RESULT
Accidentals on the selected notes are shown, hidden, or shown in round or square brackets.
NOTE
●

Hiding accidentals does not affect the pitch of notes in playback.

●

If you are hiding/showing many accidentals, we recommend that you consider changing the
accidental duration rule.

●

You can assign key commands for different accidental hiding, showing, and parenthesizing
commands on the Key Commands page in Preferences.
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AFTER COMPLETING THIS TASK
You can also hide/show or parenthesize accidentals on artificial harmonics shown using diamond
noteheads, independently of the normal noteheads that indicate the stopped pitch.
RELATED LINKS
Accidental duration rules on page 619
Preferences dialog on page 62
Hiding/Showing or parenthesizing harmonic accidentals on page 919
Deleting accidentals on page 613

Project-wide engraving options for accidentals
You can find options for the project-wide appearance and position of accidentals on the
Accidentals page in Engrave > Engraving Options.
The options on the Accidentals page allow you to change the order of accidentals in chords and
the precise positioning of accidentals relative to noteheads, ledger lines, and parentheses.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Stacking of accidentals
If multiple accidentals are required for a chord in a single voice, or for notes in multiple voices at
the same rhythmic position, they are stacked to the left of the chord in columns.
For chords with multiple accidentals, accidentals are generally stacked as follows:
1.

The highest accidental is inserted in the first column immediately to the left of the notes.

2.

The lowest accidental is added to the same column, provided that it does not collide with the
first accidental.

3.

The remaining highest and lowest accidentals are alternated in successive columns located
further left from the chord.

In Dorico Pro, additional rules help to produce a stack of accidentals that uses as few columns as
possible. The following list contains some of the rules that are applied:
●

Columns closer to the notes contain more accidentals than columns further from the notes.

●

Accidentals on notes that are an octave apart are stacked in the same column. This also
applies to accidentals that are a sixth or more apart, depending on the combination of
accidentals.

●

Accidentals in the same column never collide. The minimum interval between accidentals
that is required to prevent collisions depends on the types of accidentals.

●

Accidentals that are a second apart are arranged in adjacent columns, with the higher
accidental in the right-hand column.

These rules minimize the amount of extra space that is required between successive notes or
chords and ensure that accidentals appear as close as possible to the noteheads to which they
apply. At the same time, they produce a contour that resembles a C-curve on the left-hand side of
the chord.
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TIP
You can customize the default settings for the stacking of accidentals project-wide in the
Stacking section of the Accidentals page in Engrave > Engraving Options. For example, you
can allow accidentals to be stacked without interspersion, so that accidentals appear in a
diagonal line sloping downwards to the left.

RELATED LINKS
Project-wide engraving options for accidentals on page 615

Accidental stacking rules for dense chords
Dorico Pro uses special stacking calculations in dense chords with multiple accidentals to ensure
legibility. Chords are considered dense when they have six or more accidentals within the span of
an octave.
For dense chords, accidentals are stacked as follows:
1.

The highest accidental is inserted in the first column to the left of the notes.

2.

The next accidental on a note that is located at least a seventh below the highest note is
stacked into the same column. This continues with the remaining notes until no more
accidentals fit into the first column.

3.

Steps 1 and 2 are repeated for the following columns until all accidentals are stacked.

4.

The columns are grouped, interspersed, and re-stacked. This results in a stack with
alternating accidentals, reminiscent of the way accidentals are arranged in a key signature.

NOTE
By default for dense chords, Dorico Pro uses a lattice arrangement of accidentals rather than the
usual zig-zag arrangement. In very dense chords, the lattice arrangement can be wider and
require more columns. You can change the default arrangement of all dense chords project-wide
in the Stacking section of the Accidentals page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for accidentals on page 615

Kerning of accidental columns
Dorico Pro applies kerning to accidental columns to ensure that the columns to the left of a
chord occupy as little horizontal space as possible.
In typography, kerning adjusts the space between individual characters to increase legibility. In
Dorico Pro, as well as in music engraving in general, kerning allows accidentals to interlock.
EXAMPLE
If a low note is followed by a high note with an accidental, the accidental can be tucked above the
low note to prevent the note spacing from being distorted.
Similarly, in the case of multiple columns of accidentals on a chord, the overall width of the stack
of accidentals is reduced if, for example, a flat in the second column is kerned underneath a
sharp in the first column belonging to a note a third higher. This also reduces the need to distort
note spacing to accommodate accidentals.
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Altered unisons
Altered unisons occur when two or more notes of the same name in the same octave have
different accidentals in the same chord, such as D♯ and D♭.
In Dorico Pro, this is notated with a split stem by default. Split stems show the main body of a
chord with a stem branch coming off the main stem that connects noteheads in altered unisons
to the chord. This allows all notes to appear with their corresponding accidental directly beside
them. A split stem is also known as a “cherry stalk” or a “tree”.
You can change individual altered unisons appear with a single stem, meaning noteheads appear
directly beside each other, and the two accidentals are shown beside each other to the left of the
chord.
You can also change the default appearance of all altered unisons in each flow independently on
the Accidentals page in Write > Notation Options.
NOTE
If a chord contains notes a second interval apart and one of those notes has an altered unison, it
is always shown with a split stem, regardless of your setting. This is to ensure clarity in clusters.
EXAMPLE

A single stem altered unison

A split stem altered unison

RELATED LINKS
Inputting chords on page 194

Changing how altered unisons appear
You can change how individual altered unisons appear, including within chords containing other
altered unisons, and independently of your per-flow settings.
PROCEDURE
1.

Select the altered unison notes whose appearance you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Split stem in the Notes and Rests group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
The selected altered unison notes are shown with split stems when the checkbox is activated,
and with single stems when the checkbox is deactivated.
TIP
●

Split stem applies to individual notes. You can have altered unisons appear differently within
the same chord by setting their properties independently.
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●

You can change the default appearance of all altered unisons in each flow independently in
the Altered unisons section of the Accidentals page in Write > Notation Options.

RELATED LINKS
Notation Options dialog on page 160

Microtonal accidentals
Microtonal accidentals indicate pitches beyond the standard accepted chromatic scale in Western
tonality, such as a quarter sharp or quarter flat.
You can use microtonal accidentals when you have selected a tonality system that includes
microtonal accidentals, such as Equal temperament (24-EDO).
The default tonality system is Equal temperament (12-EDO), which you can see in the Tonality
System section of the Key Signatures, Tonality Systems and Accidentals panel. When this option
is selected, the accidentals available in the Accidentals section of the panel are only half-step
(semitone) accidentals, such as sharp, flat, double flat, and so on. Equal temperament (12-EDO)
does not include microtonal accidentals.
You can change the tonality system for specific passages of music, which changes the microtonal
accidentals available. You can also define your own tonality systems with custom octave
divisions, key signatures, and accidentals.
NOTE
Even if you do not want to use a conventional key signature, you must input an open or atonal
key signature in order to change the tonality system and use microtonal accidentals.

RELATED LINKS
Tonality systems on page 848
Changing the tonality system on page 849
Custom tonality systems on page 851
Custom accidentals on page 857
Playback of custom tonality systems on page 862

Inputting microtonal accidentals
You can input microtonal accidentals, such as quarter tone flat or three quarter tones sharp, into
your project.
PREREQUISITE
You have input a key signature and selected a tonality system for that key signature that allows
microtonal accidentals, such as Equal temperament (24-EDO), for the section of your project
where you want to input microtonal accidentals.
PROCEDURE
1.

In Write mode, select the note or notes to which you want to apply a microtonal accidental.

2.

In the Key Signatures, Tonality Systems, and Accidentals panel, click the microtonal
accidental you want in the Accidentals section.

RESULT
The selected microtonal accidental appears beside the selected note or notes.
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NOTE
You can only input one type of accidental at a time.

RELATED LINKS
Tonality systems on page 848
Changing the tonality system on page 849
Input methods for key signatures on page 216

Accidental duration rules
Accidental duration rules determine how long accidentals apply, such as within a bar, at a
different octave, or just for a single note.
Dorico Pro allows you to use different accidental duration rules.
Common practice
In Dorico Pro, this is the default accidental duration rule. In common practice, an
accidental applies for the duration of a bar and only to the pitch at which it is written,
meaning each octave requires a separate accidental.
Second Viennese School
The Second Viennese School accidental duration rule requires writing every note with
an accidental, including naturals.
Modernist
The Modernist accidental duration rule states that only notes that have been altered
from the key signature show accidentals. Naturals are not shown.
RELATED LINKS
Common practice accidental duration rule on page 620
Second Viennese School accidental duration rule on page 621
Modernist accidental duration rule on page 622

Changing the accidental duration rule
You can change the accidental duration rule to the one most appropriate for each flow in your
project.
PROCEDURE
1.
2.

Press Ctrl/Cmd-Shift-N to open Notation Options.
In the Flows list, select the flows in which you want to change the accidental duration rule.
By default, only the current flow is selected when you open the dialog.

3.

Click Accidentals in the page list.

4.

In the Basic section, choose one of the following options for Accidental duration rule:

5.

●

Common Practice

●

Second Viennese School

●

Modernist

Optional: Customize the options for your chosen accidental duration rule.
TIP
Options in the Basic section can apply to all accidental duration rules.
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6.

Click Apply, then Close.

RELATED LINKS
Common practice accidental duration rule on page 620
Second Viennese School accidental duration rule on page 621
Modernist accidental duration rule on page 622

Double accidental cancellation
There are two generally accepted practices for the cancellation of double accidentals, which are
archaic and modern. You can use either practice in each flow independently in Dorico Pro.
By default, Dorico Pro uses modern cancellation. This means that if a double sharp is cancelled
by a single sharp, or a double flat is cancelled by a single flat, then no natural sign is shown in
front of the single sharp or single flat, as these accidentals are unambiguous.
You can change how double accidentals are cancelled in each flow independently in the Basic
section of the Accidentals page in Write > Notation Options. You can use this option with any
accidental duration rule.
●

If you choose Use archaic cancellation, natural signs are shown before new accidentals that
come after double accidentals.

●

If you choose Use modern cancellation, double accidentals are replaced immediately with a
new accidental without showing a natural sign first.

EXAMPLE

Archaic cancellation

Modern cancellation

RELATED LINKS
Notation Options dialog on page 160

Common practice accidental duration rule
In common practice, an accidental affects all notes of the same pitch in the same octave within
the same bar, unless it is cancelled by another accidental. If it is not cancelled, it is automatically
cancelled in the following bar.
NOTE
To ensure that the cancellation is unambiguous, it is customary to add a cautionary accidental to
the first note of the same pitch in the following bar.
In Dorico Pro, the common practice accidental duration rule is used by default. You can change
the accidental duration rule on the Accidentals page in Write > Notation Options.
In common practice, the accidental of a note in one bar is automatically cancelled in the
following bar. For example, in the key of G major, if an F♮ is in one bar, an F in the following bar
shows a sharp sign, even though the sharp is already implied by the key signature.
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When using the common practice accidental duration rule by default, Dorico Pro also displays
cautionary accidentals, which are restatements of an earlier accidental. They are considered
optional; that is, they are neither explicit confirmations nor cancellations, but help to eliminate
ambiguities. Cautionary accidentals are also known as “courtesy accidentals”.
Cautionary accidentals are shown in the following circumstances:
●

Subsequent notes within the same bar have the same note name in different octaves.

●

Subsequent notes in the following bar have the same note name in the same octave.

●

The first occurring note in the following bar has the same note name in any octave.

●

Augmented/Diminished or double-diminished/augmented intervals are identified within the
same bar.

For each of these situations, you can choose whether cautionary accidentals are shown in
parentheses, shown without parentheses, or not shown at all.
RELATED LINKS
Changing the accidental duration rule on page 619

Hiding/Showing cautionary accidentals
You can hide/show cautionary accidentals if you use the common practice accidental duration
rule.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-N to open Notation Options.

2.

In the Flows list, select the flows in which you want to hide/show cautionary accidentals.
By default, only the current flow is selected when you open the dialog.

3.

Click Accidentals in the page list.

4.

In the Basic section, choose Common practice for Accidental duration rule.

5.

In the Cautionary accidentals section, choose the options that you want to apply to the
selected flows.

6.

Click Apply, then Close.

RELATED LINKS
Common practice accidental duration rule on page 620

Second Viennese School accidental duration rule
The accidental duration rule of the Second Viennese School states that an accidental applies only
to the note on which it is written. All notes show an accidental regardless of key signature,
including unaltered notes which show naturals.
This accidental duration rule was used by Schoenberg and other composers of the Second
Viennese School.
You can customize the options within the Second Viennese School accidental duration rule when
changing the accidental duration rule, including choosing whether immediate repetitions of the
same note within the same bar require a restatement of the accidental.
RELATED LINKS
Changing the accidental duration rule on page 619
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Modernist accidental duration rule
The Modernist accidental duration rule states that only notes that have been altered from the
key signature show accidentals. Naturals are not shown. However, accidentals that are shown
only apply to the notes on which they are written, as with the Second Viennese School.
Charles Ives and Robert Crumb used this variation.
You can customize the options within the Modernist accidental duration rule when changing the
accidental duration rule, including choosing whether or not the same accidental on the same
pitch is restated later in the bar if the subsequent pitches occur immediately and if subsequent
pitches occur after other, different notes. Similarly, there are options for accidentals on notes in
different octaves in the same bar and following bar. There is also an option controlling the
restatement of accidentals within beam groups.
RELATED LINKS
Changing the accidental duration rule on page 619
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Articulations are markings that are drawn above or below notes and chords. Articulations tell a
performer how to attack a note or how long to play a note relative to its notated duration.
In Dorico Pro, articulations are defined as something that alters the way a note is played, in a
way that is consistent across all instruments.
As instructions like bowing directions, harmonics, or tonguing apply to different instrument
groups, in Dorico Pro such directions are defined as playing techniques, and can be found in the
Notations panel on the right of the window.
Articulations are categorized into the following types:
Articulations of force
Indicate a stronger attack at the start of notes, and include articulations such as accent
and marcato. Marcato is also sometimes known as a “strong accent”. Dorico Pro shows
these articulations at the start of a note or tie chain by default.
Articulations of duration
Indicate a shorter duration than notated, and include articulations such as
staccatissimo, staccato, tenuto, and staccato-tenuto. Staccato-tenuto is also sometimes
known as a “louré”. If a note includes ties, Dorico Pro shows articulations of duration
above the last note in the chain by default.
Articulations of stress
Indicate notes that should be emphasized or not emphasized where that contradicts
the prevailing meter, using stressed and unstressed marks. Dorico Pro shows these
articulations at the start of a note or tie chain by default.
You can find articulations at the bottom of the Notes panel in Write mode.

Dorico Pro positions articulations automatically on the notehead or stem side of notes and
chords, according to the musical context. A note or chord can display one of each of the three
types of articulations.
You can change the effect of articulations on playback, based both on the type of instrument and
the playback devices in use in the Note Dynamics section of the Dynamics page in Play >
Playback Options.
RELATED LINKS
Inputting articulations on page 210
Playback Options dialog on page 502
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Project-wide engraving options for articulations
You can find options for the appearance and placement of articulations project-wide on the
Articulations page in Engrave > Engraving Options.
The options on this page allow you to change the positions of articulations in detail, including
whether different articulations are shown above the staff or by the notehead, the positions of
articulations relative to ties and slurs, and the vertical gaps between articulations and notes/
other articulations.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Copying articulations
Articulations are automatically included if you copy notes, but they cannot be copied and pasted
independently of notes.
PROCEDURE
1.

In Write mode, select the notes with articulations you want to copy.

2.

Copy the notes in one of the following ways:
●

Press R to repeat the material directly after itself.

●

Press Ctrl/Cmd-C , select the position where you want to copy the selected notes, then
press Ctrl/Cmd-V .

●

Alt/Opt -click the position where you want to copy the selected notes with articulations.

AFTER COMPLETING THIS TASK
If you want the copied notes to have the same rhythm but different pitches, you can repitch the
notes.
RELATED LINKS
Repitching notes without changing their rhythm on page 202

Changing articulations
You can change the articulations on notes after they have been input.
PROCEDURE
1.

In Write mode, select the note whose articulation you want to change.

2.

Change the articulation in any of the following ways:
●

Press the key command of the articulation you want. For example, press ] for staccato.

●

Click the new articulation you want in the Notes panel.

RESULT
The new articulation is added. This replaces any existing articulation of the same type.
RELATED LINKS
Inputting articulations on page 210
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Key commands for articulations on page 211

Deleting articulations
Individual articulation markings cannot be selected and deleted separately from their notehead
in Write mode, so articulations must be deleted by selecting the note or notes to which they are
attached, and deselecting the articulation.
PROCEDURE
1.

In Write mode, select the notes whose articulations you want to delete.

2.

Deselect the articulations in any of the following ways:
●

Press the key commands of the articulations you want to delete.

●

Click the articulations you want to delete in the Notes panel.

Positions of articulations
There are established conventions for the position and placement of articulations relative to
notes, the staff, and staff lines, which ensure articulations are always clearly visible. For the
smallest articulations, such as staccato marks, correct placement relative to staff lines in
particular is vital.
Articulations are placed on the notehead side by default, with the following exceptions:
●

In single-voice contexts, marcato is always placed above the staff, regardless of the stem
direction of the note or chord on which it is used. In multiple-voice contexts, marcato can
also be placed below the staff.

●

If multiple voices are active, articulations are placed at the end of the stem side of a note or
chord. This clarifies which articulations belong to the up-stemmed notes and which to the
down-stemmed notes.

●

If a note is placed on the middle staff line or on the space immediately on either side,
articulations that are less than a space in height are centered in the next unoccupied space.
This normally only applies to staccato and tenuto. If a note in the middle of the staff has a
staccato-tenuto articulation, the component parts of the articulation are split up and placed
in separate spaces.

●

If an articulation cannot fit within a staff space, or if the note is placed high or low on the
staff, the articulation is placed outside the staff.

●

If a note or chord is tied and the tie is placed above or below the notehead, articulations that
are placed on the notehead side of a note or chord are offset by an additional 1/4 space in
order to avoid the end of the tie.

Articulations on the notehead side are always centered horizontally on the notehead. This also
applies to articulations on the stem side, except if the only articulation is a staccato or
staccatissimo. In this case, the articulation is centered on the stem.
RELATED LINKS
Project-wide engraving options for articulations on page 624
Changing the horizontal position of staccato marks on page 627
Moving individual articulations vertically on page 627
Changing the placement of articulations individually on page 628
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Order of articulations
If there are multiple articulations on the same notes, their vertical position and proximity to
noteheads/stems depends on their type.
Articulations are positioned in the following order:
1.

Articulations of duration are positioned closest to notehead/stems.

2.

Articulations of force are positioned outside articulations of duration.

3.

Articulations of stress are positioned furthest from noteheads/stems.

Order of articulations in relation to slurs
Articulations of duration are positioned as follows:
●

Inside slurs that start/end on a note or chord with an articulation.

●

Inside the curvature of a slur.

●

Inside tuplet brackets.

Articulations of force are positioned as follows:
●

Outside slurs that start/end on a note or chord with an articulation, except if they can be
positioned within the staff.

●

Inside the curvature of a slur if they fit between the slur and the note or stem, to which they
belong, without colliding.

●

Outside tuplet brackets.

Force and stress articulations outside the ends of the Duration articulations inside the ends of the slur
slur

Changing the positions of articulations on tie chains
You can change where in tie chains articulations appear individually, independently of your
project-wide settings. By default, articulations of force and stress are shown on the first note/
chord in tie chains, while articulations of duration are shown on the last note/chord.
PROCEDURE
1.

Select the tied notes/chords whose articulation position you want to change. You can do this
in Write mode and Engrave mode.

2.

In the Articulations group of the Properties panel, activate Pos. in tie chain under the
corresponding heading for the articulation whose position you want to change.
For example, activate Pos. in tie chain under the Articulations of force heading to change
the position of accents.

3.

Choose one of the following options:
●

First note

●

Last note
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RESULT
The position of articulations in the selected tie chains is changed.
TIP
You can change the default position of each type of articulation relative to all tie chains projectwide in the Ties section of the Articulations page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for articulations on page 624

Changing the horizontal position of staccato marks
You can change the default horizontal position of all staccato and staccatissimo articulations
when they are placed on the stem side of notes project-wide. By default, staccato and
staccatissimo articulations are centered on the stem when on the stem side.
The horizontal position of most articulations is centered on a stem or a notehead. However, if a
staccato or staccatissimo is the only articulation, its horizontal position can also be half-centered
when they are placed on the stem side.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Articulations in the page list.

3.

In the Horizontal Position section, choose one of the following options for Horizontal
position of staccato on stem side:

4.

●

Center on notehead

●

Center on stem

●

Half-center

Click Apply, then Close.

RESULT
Staccato marks are positioned project-wide according to the option selected.

Moving individual articulations vertically
You can move individual articulations graphically upwards/downwards so they are closer to/
further away from notes.
PROCEDURE
1.

In Engrave mode, select the articulations that you want to move.

2.

Move the articulations in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them upwards/downwards.
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RESULT
The selected articulations are moved vertically.
TIP
●

When you move articulations vertically, Offset Y in the Articulations group of the Properties
panel is activated for the corresponding type of articulation. For example, Offset Y under the
Articulations of force heading is activated when you move accents.
You can also use these properties to move articulations vertically by changing the value in
the value field.
Deactivating the properties resets the selected articulations to their default positions.

●

You can change the default gaps between all articulations and their noteheads and other
articulations on the Articulations page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for articulations on page 624

Changing the placement of articulations individually
You can change whether individual articulations are placed on the notehead side or stem side of
notes.
PROCEDURE
1.

Select the notes/chords whose articulation placement you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Articulations group of the Properties panel, activate Placement under the
corresponding heading for the articulations whose placement you want to change.
For example, activate Placement under the Articulations of force heading to change the
placement of accents.

3.

Select one of the following options from the menu:
●

Notehead side

●

Stem side

RESULT
The articulation is placed on the selected side of the notes or chords. If this creates a collision
with other markings, such as playing techniques, Dorico Pro automatically makes adjustments to
make sure all markings are clear and legible.
RELATED LINKS
Moving individual articulations vertically on page 627

Changing the default placement of articulations
You can change the default placement of all articulations according to their type, for example, if
you want articulations of stress always to be placed above the staff but articulations of duration
to be placed beside noteheads, both above and below the staff.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Articulations in the page list.

3.

In the Placement section, choose one of the following options for each articulation type:
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4.

●

Always above

●

Natural placement

Click Apply, then Close.

RESULT
The default placement of the corresponding types of articulations is changed project-wide.
Articulations with Natural placement are placed on the notehead side of notes.
TIP
You can also change the default gaps between noteheads/stems and articulations and between
stacked articulations in the Vertical Position section of the Articulations page.

Allowing/Disallowing articulations inside the staff
You can choose whether or not each type of articulation is allowed to appear inside the staff
project-wide, for example, if you want all staccato marks to appear outside the staff.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Articulations in the page list.

3.

In the Vertical Position section, click Advanced Options to show the available options.

4.

For Position of articulations relative to the staff, choose one of the following options for
each articulation type:

5.

●

Allow inside staff

●

Do not allow inside staff

Click Apply, then Close.

RESULT
The staff-relative placement of the corresponding articulation types is changed project-wide.

Articulations in playback
Adding articulations affects how notes sound in playback.
If you do not have a sound library, Dorico Pro still changes how a note sounds in playback if you
have put an articulation on it. For example, a staccato mark causes a note to sound shorter than
normal, and an accent causes a note to sound louder than normal.
If you do have a sound library, Dorico Pro loads the specific sample for an articulation if such a
sample is included in your sound library for that instrument.
As the articulation applies to the whole note, the sample is triggered at the start of a note. This
includes notes that are tie chains.
TIP
●

The Timing page in Play > Playback Options provides options for the default effect of
articulations of duration. The Dynamics page contains options for articulations of force.

●

You can enable independent voice playback for individual instruments, for example, if you
have slurs in one voice and staccatos in another voice.
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RELATED LINKS
Playback Options dialog on page 502
Enabling independent voice playback on page 543
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Bars indicate a usually regular segment of time according to the number of beats, which is
usually determined by the prevailing time signature. Bars are separated from other bars to the
left and the right by vertical barlines.
Bars are usually the same length and at the same position for all players, but in some music, bars
of different lengths may coincide, and there are situations where some players may have no bars
indicated at all.
Each bar has a number, allowing players to keep track of their place in the music and aiding
rehearsal. This is especially important in music for multiple players.
RELATED LINKS
Bar numbers on page 646
Input methods for bars and barlines on page 234

Deleting bars/beats
You can delete whole bars and specific beats from your project completely by using the bars and
barlines popover.
PROCEDURE
1.

In Write mode, select one of the following:
●

The first bar you want to delete, or the first note or rest in that bar.

●

An item at the rhythmic position from which you want to delete beats

2.

Press Shift-B to open the bars and barlines popover.

3.

Enter – (minus), followed by the number of bars or beats you want to delete into the
popover.
For example, enter –6 to delete six bars, meaning the bar you selected and the subsequent
five bars, or -2q to delete two quarter note beats, starting from the selected rhythmic
position.

4.

Press Return to close the popover.

RESULT
The number of bars or beats specified is deleted.
RELATED LINKS
Bars and barlines popover on page 235

Deleting bars/beats with the system track
You can delete whole bars and selected beats from your project completely using the system
track, for example, if you want to delete the last beat in the final bar for flows that begin with a
pick-up bar.
PREREQUISITE
The system track is shown.
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PROCEDURE
1.

In the system track in Write mode, select the region that you want to delete.

2.

Click Delete in the system track. It can also appear above the system track if your selection is
narrow.

Delete button in the system track

The system track changes color when you hover
over the Delete button.

RESULT
The selected region is deleted. Just as when Insert mode is active, music to the right of the
selection moves up to fill in the gap.
NOTE
Any signposts in the selection are also deleted. This can affect the page formatting, for example,
by removing ossia staves whose signposts were included in the selection.

RELATED LINKS
System track on page 323
Hiding/Showing the system track on page 324

Deleting empty bars at the end of flows
You can trim flows by deleting any empty bars left at the end.
PROCEDURE
1.

In Write mode, select an item in the flow you want to trim.

2.

Press Shift-B to open the bars and barlines popover.

3.

Enter trim into the popover.

4.

Press Return to close the popover.

RESULT
Empty bars at the end of the selected flow are deleted.
RELATED LINKS
Bars and barlines popover on page 235
Splitting flows on page 342

Deleting the contents of bars
You can delete just the contents of bars without deleting barlines or the bars themselves.
PROCEDURE
1.

In Write mode, select the bars whose contents you want to delete.
TIP
Notes, rests, and other objects are highlighted orange when selected.
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2.

Press Backspace or Delete .

RESULT
The contents of the selected bars are deleted.
RELATED LINKS
Large selections on page 322
Filters on page 326

Changes to the length of bars
You can change the length of a bar so that its duration is longer or shorter.
You can change the length of a bar by changing its time signature. You can later hide the time
signature, for example, if you are writing music with an irregular meter and you require barlines
only to group material together, but not to imply any sense of meter.
RELATED LINKS
Input methods for time signatures on page 222
Hiding/Showing time signatures on page 1250

Changing the width of empty bars
You can change the width of empty bars individually in Engrave mode.
PROCEDURE
1.

In the Engrave toolbox, activate Note Spacing.

2.

Select a square handle at the rhythmic position of a barline at the start/end of an empty bar
whose width you want to change.

3.

Adjust the spacing in any of the following ways:
●

Press Alt/Opt-Right Arrow to increase the space to the left of the selected handle.

●

Press Alt/Opt-Left Arrow to decrease the space to the left of the selected handle.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

RESULT
The width of the empty bar is changed.
For example, if you select the handle of the barline on the right of a bar and nudge the handle to
the left, the bar appears narrower. If you select the barline on the right of a bar and nudge the
handle to the right, the bar appears wider.
RELATED LINKS
Note spacing on page 425
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Hiding/Showing bar rests in empty bars on page 1111
Hiding/Showing multi-bar rests on page 1113

Splits in bars
You can split bars rhythmically by changing the number of beats in each bar. You can split bars
visually across systems or frame breaks, which might be required in music with an irregular
meter or in passages of polymeter.

Splitting bars by inputting new time signatures
You can split bars into two or more bars by changing the time signature. New time signatures
apply until the next existing time signature or the end of the flow, whichever comes first.
If the new time signature does not fit completely into the given space, for example, if you wanted
to replace two 4/4 bars (eight quarter notes) with either two 3/4 bars or three 3/4 bars (either six
or nine quarter notes), then Dorico Pro does not override your existing time signature. Instead,
the final bar is made shorter.
For example, replacing a 4/4 time signature with a 3/4 time signature two bars before an existing
time signature creates two 3/4 bars and the equivalent of a 2/4 bar, as shown in this example.

However, in Insert mode, Dorico Pro inserts time at the end of the final bar of the new time
signature to make sure the final bar is the correct length. For example, in the same scenario as
above but with Insert mode activated, two 4/4 bars become three 3/4 bars, with the extra beat
required to fill the third 3/4 bar added at the end of the phrase.

Splitting bars by inputting new barlines
You can also split bars by inputting new barlines that are not normal (single) barlines anywhere
within a bar without affecting the time signature.
However, inputting a normal (single) barline anywhere within an existing bar resets the pattern
of the time signature from that point onwards.
For example, selecting the third quarter note (crotchet) in a 4/4 bar and inserting a new barline
causes a new 4/4 bar to start from the added barline. This leaves the equivalent of a 2/4 bar
without a time signature to the left of the barline, but the bars to the right of the added barline
are in 4/4 and continue to be in 4/4 until the next time signature or the end of the flow,
whichever comes first.
After a normal (single) barline is added, a signpost appears to show how it affects the time
signature.
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Two 4/4 bars with quarter notes

Adding a normal barline halfway through the first
4/4 bar restarts the time signature from that point.

RELATED LINKS
Input methods for time signatures on page 222
Input methods for bars and barlines on page 234
Inserting system breaks on page 466
Inserting frame breaks on page 463
Inputting notes in Insert mode on page 183

Combining bars
You can combine two or more bars into one, longer bar by deleting the barline between them.
PROCEDURE
1.

In Write mode, select the barline you want to delete.

2.

Press Backspace or Delete .

RESULT
The bars on either side of the deleted barline combine into one bar. If required, the notes inside
are automatically re-beamed appropriately.
NOTE
Deleting a barline does not automatically change the time signature. To avoid confusion, we
recommend that you input a new time signature to reflect the new rhythmic duration of the bar.

RELATED LINKS
Deleting barlines on page 640
Input methods for time signatures on page 222
Hiding/Showing multi-bar rests on page 1113
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Barlines are vertical lines that cross staves in order to show how music is divided into bars,
according to the time signature.
There are a number of different types of barlines that are used in different contexts:
Normal (Single)
A standard single barline that spans the entire height of the staff. For single-line staves,
the barline extends one space above and below the staff line by default.

Double
A double barline consists of two lines, both the width of a single barline, positioned half
a space apart by default. It is often used to denote significant changes in the music, or
to mark the placement of rehearsal marks, key signature changes, and tempo changes.

Triple
A triple barline consists of three lines, all the width of a single barline, positioned half a
space apart by default. It is sometimes used in musicological analysis to demarcate
structural units larger than a single bar.

Final
A final barline consists of two lines: one of normal width, the other thick. It marks
where the music ends.

Dashed
A dashed barline has the same thickness as a normal barline, but has gaps within it to
give it a dashed appearance. It is used to subdivide bars to make complex time
signatures easier to read, and to differentiate editorial barlines from ones originally in
the manuscript.
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Tick
A tick barline is a short line that spans only the top line of the staff. It is useful when
notating plainsong, in which context it denotes a breath or short gap between phrases,
or other music with an unusual metrical structure.

Short
A short barline spans either the middle of the staff, which on a five-line staff is between
the second and fourth lines, or the top half of the staff, which on a five-line staff is
between the first and third lines. On staves with fewer than fives lines, the short barline
is scaled proportionally. It is useful when notating plainsong, in which context it
denotes a longer gap between phrases than a tick barline.

Short barline

Short (top) barline

Thick
A thick barline is half a space wide by default, so it is noticeably thicker than a normal
barline. This gives it a greater visual impact.

Start repeat
A start repeat line consists of a thick barline, followed by a normal barline, followed by
one of the following arrangements of dots:
●

Two dots, one each in the middle two spaces of a five-line staff

●

Four dots, one each in all four spaces of a five-line staff

It shows the start of a repeated section. It is used alongside end repeat lines, which
show the end of a repeated section.

End repeat
An end repeat line is the mirror of a start repeat line, so it consists of either two or four
dots, followed by a normal barline, followed by a thick barline. It shows the end of a
repeated section. It is used alongside start repeat lines, which show the start of a
repeated section.
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End/Start repeat
This line combines the start repeat and end repeat barlines, with either two single
barlines with a single shared thick barline in the middle, or two thick barlines and no
single barlines. On either side, there are either two or four repeat dots. It is used when
a repeated section is immediately followed by another, separate repeated section.

RELATED LINKS
Input methods for bars and barlines on page 234
Repeats in playback on page 548

Project-wide engraving options for barlines
You can find options for the project-wide appearance of barlines on the Barlines page in
Engrave > Engraving Options.
The options on the Barlines page allow you to change the appearance and thickness of barlines,
and which barlines are used in different contexts. For example, you can change the default
appearance of repeat barlines, changing the default barline shown before codas, and whether
barlines join vocal staves and ossia staves.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359
Barline spacing on page 640
Barlines on ossia staves on page 1169
Changing the barline shown before codas on page 1081

Per-flow notation options for barlines
You can find options for the per-flow the appearance of barlines on the Barlines page in Write >
Notation Options.
For example, you can change which barline is shown by default at the end of each flow, and
whether barlines join all staves at the end of each system and at the end of the final system in a
flow.
Musical examples demonstrate how each option affects the appearance of your music.
RELATED LINKS
Notation Options dialog on page 160

Changing the barline shown at key signature changes
You can change the default barline shown at all key signature changes that occur at barlines
project-wide. By default, Dorico Pro shows double barlines at key signature changes.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.
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2.

Click Barlines in the page list.

3.

In the Key Signatures section, choose one of the following options for Changes of key
signature at the start of the bar:

4.

●

Draw double barline

●

Draw single barline

Click Apply, then Close.

RESULT
The barline shown at all key signature changes that occur at the start of bars is changed projectwide.

Changing the default barline at the end of flows
You can choose which type of barline is placed automatically at the end of each flow.
PROCEDURE
1.
2.

Press Ctrl/Cmd-Shift-N to open Notation Options.
In the Flows list, select the flows whose default end barline you want to change.
By default, only the current flow is selected when you open the dialog.

3.

Click Barlines in the page list.

4.

Choose one of the following options for Automatic barline at end of flow:
●

Final barline

●

Double barline

●

Normal barline

●

Dashed barline

●

Thick barline

●

No barline

RESULT
The default final barline at the end of the selected flows is changed.
TIP
You can override individual final barlines by changing their type, but you cannot delete individual
final barlines.

RELATED LINKS
Input methods for bars and barlines on page 234

Hiding/Showing systemic barlines on single-staff systems
By default, systemic barlines are shown at the start of systems containing two or more staves
and hidden on single-staff systems. You can hide/show systemic barlines on single-staff systems
after the first system.
Showing systemic barlines on single-staff systems is a convention used in hand-copied lead
sheets, usually in combination with no clefs being shown.
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PROCEDURE
1.

Press Ctrl/Cmd-Shift-N to open Notation Options.

2.

In the Flows list, select the flows in which you want to hide/show systemic barlines after the
first system.
By default, only the current flow is selected when you open the dialog.

3.

Click Barlines in the page list.

4.

In the Systemic Barline subsection, choose one of the following options for Barline at start
of systems following first system:

5.

●

Show for one or more staves

●

Show for two or more staves

Click Apply, then Close.

Deleting barlines
You can delete barlines without affecting the rhythmic positions of notes. For example, you
might delete existing barlines and input new ones if you want to change where a barline occurs.
PROCEDURE
1.

In Write mode, select the barlines you want to delete.
NOTE
You must select barlines directly, not their signposts.

2.

Press Backspace or Delete .

RESULT
The barline is deleted. The two bars either side of the barline combine into one bar, containing
the same number of beats but without changing the time signature. This might cause note, rest,
and beam groupings to change.
AFTER COMPLETING THIS TASK
●

To avoid confusion, you can add a new time signature to reflect the new rhythmic duration of
the bar.

●

If you deleted barlines because you want to change where they occur, you can input new
barlines at the new positions.

RELATED LINKS
Input methods for time signatures on page 222
Input methods for bars and barlines on page 234

Barline spacing
You can find options for the default spacing of all barlines project-wide on the Spacing Gaps
page in Engrave > Engraving Options.
On the Spacing Gaps page in Engraving Options, you can change project-wide values for the
spaces before and after barlines, and between barlines and other staff objects, such as clefs,
time signatures, or key signatures.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
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RELATED LINKS
Engraving Options dialog on page 359
Project-wide engraving options for barlines on page 638

Moving barlines graphically
You can adjust the spacing between barlines and neighboring notes, time signatures, key
signatures, or rests.
PROCEDURE
1.

In the Engrave toolbox, activate Note Spacing.

2.

Select a note spacing handle at the rhythmic position of the barline.

3.

Move the handle in any of the following ways:
●

Press Alt/Opt-Right Arrow to move it to the right.

●

Press Alt/Opt-Left Arrow to move it to the left.
NOTE
●

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

You cannot move note spacing handles using the mouse. You can only move them
using the keyboard.

RESULT
The spacing to the right/left of the barline is increased/decreased.
EXAMPLE

The new position of the barline after decreasing the space to its left

Barlines across staff groups
In order to make it easier to find a particular instrument within a score, barlines can extend
across instrumental and staff groups.

Barlines across default staff groups
When a barline only appears on individual staves, it is much harder to locate individual lines at a
glance. However, when barlines continue across instrumental groups in the score, instrument
families are shown as blocks, which makes finding an instrument much easier.
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Barlines on individual staves

Barlines across instrumental groups

Barlines extend across staff groups automatically when they are joined by a bracket. Which
staves are included in a bracket depends on the instrumentation and context, but usually staves
for instruments from the same family, such as woodwind or strings, are bracketed together.
Dorico Pro automatically brackets staves according to the ensemble type set for each layout.

Barlines across grand staff instruments
Dorico Pro automatically joins barlines across grand staff instrument staves as they are braced.
Because staves cannot be bracketed and braced simultaneously, grand staff instruments are
excluded from brackets and therefore are not joined with barlines to any other staves.

Custom barline groups
You can create custom barline joins and bracket groups by manually arranging your players into
groups. If one or more players included in your group were previously in another group, any
remaining instruments in their previous group remain grouped.
You can put a single player in its own player group so they appear separately, for example, to
separate the soloist from the remainder of the ensemble in a concerto.
You can also input custom barline joins to determine the staves across which individual barlines
extend.
RELATED LINKS
Brackets according to ensemble type on page 685
Adding player groups on page 130
Adding players to groups on page 131
Deleting player groups on page 131
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Showing barlines across all staves at time signature changes
You can join all staves with a barline at time signature changes in individual layouts, regardless of
your bracketing style.
PROCEDURE
1.

Select the time signature changes where you want to join all staves with a barline. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Barline joins all staves in the Time Signatures group.

RESULT
All staves in the layout currently open in the music area are joined by a barline at the selected
time signature changes.

Inputting custom barline joins
You can input custom barline joins at any position that change which staves are joined with
barlines.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select an item on the top staff you want to join with a barline, at the start
of the system from which you want this change to apply.

2.

Ctrl/Cmd -click an item on the bottom staff you want to join with a barline.

3.

In the Formatting panel, click Change barline joins in the Bracketing group.

RESULT
All staves between and including the staves on which you selected items are joined by a barline
until the next existing bracket and barline change or the end of the flow, whichever comes first. A
signpost appears at the start of the system in which you selected items.
If necessary, any existing barline joins are adjusted to accommodate the new barline join.
NOTE
You cannot move bracket and barline change signposts, as they are intended to apply to system
start positions. However, they can appear partway through systems if, for example, you move
system breaks. When a bracket and barline change signpost is positioned partway through a
system, the corresponding change only takes effect from the start of the next system.
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EXAMPLE

Divisi cello staves with default staff grouping

Divisi cello staves with separate barline joins across
each instrument

RELATED LINKS
Signposts on page 335
Resetting bracket and barline changes on page 693
Deleting bracket and barline changes on page 693

Deleting barline joins individually
You can delete individual barline joins independently of other barline joins and bracket/brace
grouping changes at the same rhythmic position, which splits selected barline joins into showing
separate barlines on each staff.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select the barline joins you want to delete.

2.

Press Backspace or Delete .

Lengthening/Shortening custom barline joins
You can lengthen/shorten custom barline joins vertically to change the staves across which they
span, for example, if you added a new player below a barline join and want to extend the barline
join to that staff.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select a handle at either the top or bottom of each barline join you want to
lengthen/shorten.
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TIP
You only need to select a handle on one barline join for each bracket and barline change, as
they apply from their signpost until the next existing change or the end of the flow,
whichever comes first.
2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them to the staff above.

●

Press Alt/Opt-Down Arrow to move them to the staff below.

RESULT
The selected barline joins are lengthened/shortened to staves above/below. This affects the
staves included in the barline joins on all systems to which the corresponding bracket and barline
changes apply.
NOTE
Only one barline join can exist on each staff, they cannot overlap. If any part of a selected barline
join collides with another barline join when it is lengthened/shortened, the other barline join is
shortened to accommodate this.
You can undo this action, which restores the previous length of any shortened barline joins.
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Bar numbers provide a crucial reference point for music that has multiple players, and make the
chronological sequence of the music clear. They indicate where players are in the piece, which
allows them to co-ordinate themselves easily in rehearsals and concerts.
Bar numbers can also be useful when preparing parts and scores, as you can use bar numbers
and rehearsal marks to help you quickly compare a part to the score and check the music is
correct.
In Dorico Pro, bar numbers appear automatically, following the most common practice of
showing a bar number at the start of each system in all layouts by default. You can hide and
show bar numbers in each layout independently, including showing them at a specified regular
interval or in every bar, which is frequently used in film music scores.
TIP
The majority of options relating to bar numbers are on the Bar Numbers page in Setup >
Layout Options. This is because it is very common to display bar numbers differently in different
layouts, such as in every bar in full score layouts but only at the start of each system in part
layouts.

RELATED LINKS
Bar number paragraph styles on page 651
Positions of bar numbers on page 653
Layout Options dialog on page 104

Hiding/Showing bar numbers
You can hide/show bar numbers in each layout independently, including showing them at
different frequencies. For example, you can show bar numbers every bar in full score layouts but
only at the start of each system in part layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show bar numbers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

In the Frequency subsection, choose one of the following options for Show bar numbers:
●

Every system

●

Every n bars

●

Every bar

●

None

5.

Optional: If you chose Every n bars, set a custom frequency for bar numbers by changing
the value for Interval.

6.

Click Apply, then Close.
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RESULT
Bar numbers are hidden in the selected layouts when you choose None, and shown at the
corresponding frequency when you choose any other option.
Changing the Interval value changes how frequently bar numbers are shown. For example,
setting an interval value of 10 means that bar numbers are shown every tenth bar.
TIP
You can also hide individual bar numbers in layouts where bar numbers are shown by selecting
them and activating Hide bar number in the Time Signatures group of the Properties panel.

RELATED LINKS
Hiding/Showing bar number ranges on multi-bar rests on page 650
Showing bar numbers above specific staves on page 654
Hiding/Showing guide bar numbers on page 651
Bar number paragraph styles on page 651
Positions of bar numbers on page 653

Hiding/Showing bar number enclosures
You can optionally show bar numbers in either a rectangular or circular enclosure in each layout
independently, for example, if you want bar numbers to appear with rectangle enclosures in the
full score layout so the conductor can easily see them but with no enclosures in part layouts,
where pages tend to be less busy.
Bar numbers in enclosures automatically erase their backgrounds.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the bar number enclosure
type.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

In the Appearance subsection, choose one of the following options for Enclosure type:

5.

●

None

●

Rectangle

●

Circle

Click Apply, then Close.

RESULT
Bar numbers in the selected layouts are shown within your selected enclosure type. The size of
the enclosure is relative to the font size of the bar numbers, but the size and shape of the
enclosure are also determined by your padding values.
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EXAMPLE

Bar number with no enclosure

Bar number with a rectangle
enclosure

Bar number with a circle enclosure

RELATED LINKS
Layout Options dialog on page 104

Bar number enclosure size and padding values
In the Enclosure subsection of the Bar Numbers page in Engrave > Engraving Options, there
are a number of options to control the shape and size of bar number enclosures.

Rectangle bar number enclosure
The figure shows a rectangle bar number enclosure with default settings. The minimum height
and minimum width are both 2 spaces, horizontal padding is half a space, and minimum bottom
and minimum top padding are both 1/8 of a space.

Adjusting the minimum values can help make bar number enclosures more consistent projectwide, as the default values can allow their size to vary significantly, depending on the size and
shape of the bar number inside. This might make a narrow bar number less obvious to a
conductor. Increasing Minimum width to reduce the difference in size can create a more
consistent visual effect.

Bar numbers with rectangle enclosures, default
minimum width

Bar numbers with rectangle enclosures, minimum
width increased to 5

Minimum width
Sets a minimum value for the width of enclosures. In this example, the value was
increased from 2 spaces to 6 spaces.
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Minimum height
Sets a minimum value for the height of enclosures. In this example, the value was
increased from 2 spaces to 6 spaces.

Minimum horizontal padding
Sets a minimum value for the distance between the two sides of the enclosure and the
bar number within it. In this example, the value was increased from 1/2 a space to 4
spaces.

Minimum bottom padding
Sets a minimum value for the distance between the bottom line of the enclosure and
the bar number within it. In this example, the value was increased from 1/8 of a space
to 2 spaces.

Minimum top padding
Sets a minimum value for the distance between the top line of the enclosure and the
bar number within it. In this example, the value was increased from 1/8 of a space to 2
spaces.

Circle bar number enclosure
The figure shows a circle bar number enclosure with default settings. The minimum diameter is 2
spaces, and the minimum padding is 1/6 of a space.

Minimum diameter
Sets a minimum value for the diameter of the enclosure. In this example, the value was
increased from 2 spaces to 8 spaces.
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Minimum padding
Sets a minimum value for the distance between the enclosure line and the bar number
within it. In this example, the value was increased from 1/6 of a space to 1 space.

All enclosures
Enclosure line thickness
Sets the thickness of enclosure lines for both rectangle and circle enclosure types. The
default is 1/8 of a space. The examples have a thickness of 1/2 a space.

NOTE
Changing the Enclosure line thickness changes the thickness of bar number
enclosures in all layouts in the project. Changing any padding values for rectangle
enclosures affects all layouts with rectangle enclosures, and changing any padding
values for circle enclosures affects all layouts with circle enclosures.

Hiding/Showing bar number ranges on multi-bar rests
You can hide/show bar number ranges on multi-bar rests, for example, so it is clear in part
layouts which bars the player does not play. Multi-bar rests can include bar repeat regions, if you
have chosen to consolidate bar repeat regions as well as empty bars into multi-bar rests.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show bar number ranges on
multi-bar rests.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

In the Showing and Hiding subsection, activate/deactivate Show ranges of bar numbers
under multi-bar rests and consolidated bar repeats.

5.

Click Apply, then Close.

RESULT
Bar number ranges are shown beneath multi-bar rests and consolidated bar repeats in the
selected layouts when the option is activated, and hidden when it is deactivated.
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TIP
You can change the bar number range separator and the default distance between bar number
ranges and the staff in the Multi-bar Rests section of the Rests page in Engrave > Engraving
Options.

RELATED LINKS
Hiding/Showing bar numbers on page 646
Hiding/Showing multi-bar rests on page 1113

Hiding/Showing guide bar numbers
You can hide/show guide bar numbers on every bar and above every system in page view and
galley view independently, for example, to make it easier to check the bar number in scores with
many staves. Guide bar numbers are not printed.
PROCEDURE
●

Hide/Show guide bar numbers in any of the following ways:
●

To hide/show guide bar numbers in page view, choose View > Bar Numbers > Page
View.

●

To hide/show guide bar numbers in galley view, choose View > Bar Numbers > Galley
View.

RESULT
Guide bar numbers are shown for every bar and above every staff in the corresponding view type
when a tick appears beside the corresponding option in the menu, and hidden when no tick
appears.

Bar number paragraph styles
In Dorico Pro, bar numbers use paragraph styles so that you can use different paragraph styles
in different layouts. In particular, part layouts often require differently formatted bar numbers
compared to full score layouts.
By default, there are the following paragraph styles for bar numbers:
●

Bar numbers (parts): Used in part layouts

●

Bar numbers (score): Used in full score and custom score layouts

Initially, both paragraph styles have the same settings, but you can change the settings of each
paragraph style independently. For example, you might want to use a bold italic font for bar
numbers in part layouts but use a plain font with a much larger font size in full score layouts.
You can then change which paragraph style is used in each layout independently.
RELATED LINKS
Paragraph Styles dialog on page 410
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Editing the bar number paragraph styles
You can edit the formatting of the paragraph styles used for bar numbers, for example, if you
want to increase their font size. By default, there is a paragraph style for bar numbers in full
score layouts and another paragraph style for bar numbers in part layouts.
PREREQUISITE
If you want to use additional bar number paragraph styles to the ones provided by default, you
have created new paragraph styles.
PROCEDURE
1.

In Engrave mode, choose Engrave > Paragraph Styles to open the Paragraph Styles dialog.

2.

In the paragraph style list, select one of the following bar number paragraph styles:

3.

●

Bar numbers (parts)

●

Bar numbers (score)

Optional: Select one of the available styles from the Parent menu.
If you select a parent style, an activated switch is shown beside all the options that are
different in the selected paragraph style compared to its parent style.

4.

Activate and change the options you want for the selected paragraph style.

5.

Click OK to save your changes and close the dialog.

RESULT
The selected bar number paragraph style is changed. This affects the appearance of bar
numbers in all layouts that use the selected style.
TIP
You can also make additional bar number paragraph styles, as each layout can use a different
paragraph style for bar numbers.

RELATED LINKS
Creating paragraph styles on page 411

Changing the bar number paragraph style used in layouts
You can choose which paragraph style is used for bar numbers in each layout independently. By
default, full score layouts and part layouts use different paragraph styles for bar numbers.
PREREQUISITE
If you want to use a custom paragraph style for bar numbers in some layouts, you have created
it in the Paragraph Styles dialog.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the paragraph style used
for bar numbers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

In the Appearance subsection, select a paragraph style from the Paragraph style menu.
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5.

Click Apply, then Close.

RESULT
The selected paragraph style is used for all bar numbers in the selected layouts.

Positions of bar numbers
Bar numbers are typically shown at the start of each system, above the staff, and aligned with
the initial barline.
You can change the default positions and frequency of bar numbers in each layout
independently on the Bar Numbers page in Layout Options, and you can move individual bar
numbers in Engrave mode. For example, you might want to show bar numbers every bar in full
score layouts but only at the start of each system in part layouts.

Changing the horizontal position of bar numbers
You can change the horizontal position of bar numbers in each layout independently. For
example, you can have bar numbers centered in the middle of bars in full score layouts but
centered on barlines in part layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the horizontal position of
bar numbers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

In the Horizontal Position subsection, choose one of the following options for Horizontal
position:

5.

●

Centered on barline

●

Centered on bar

Click Apply, then Close.

RESULT
The horizontal position of bar numbers is changed in the selected layouts.
●

Centered on barline shows bar numbers above barlines, at the top left of the bar.

●

Centered on bar shows bar numbers above the staff, in the middle of the bar.

RELATED LINKS
Showing bar numbers above specific staves on page 654
Moving bar numbers graphically on page 655
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Showing bar numbers above specific staves
You can change the staves above which bar numbers appear, which allows you to show bar
numbers at multiple vertical positions in each system. For example, in large orchestral scores,
you might show bar numbers both at the top of the system and above the string section.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the vertical position of bar
numbers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

In the Placement subsection, activate the checkbox for each player in the Show above
specific players list above whose top staff you want to show bar numbers.

5.

Click Apply, then Close.

RESULT
The vertical positions of bar numbers are changed in the selected layouts. For players holding
multiple instruments, bar numbers appear above their top instrument staff.
NOTE
You can change the distances between bar numbers and the staff/other objects and your vertical
spacing settings for the gaps between staves in order to accommodate bar numbers shown
between staves.

RELATED LINKS
Changing the default staff/system spacing on page 439
Per-layout vertical spacing options on page 456
Moving instruments on page 119

Changing the distance between bar numbers and the staff/other
objects
You can change the minimum distance between bar numbers and the staff, and set a separate
value for the distance between bar numbers and other objects, in each layout independently. For
example, you can position bar numbers further from the staff/other objects in full score layouts
than in part layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the minimum distance of
bar numbers from the staff.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

Optional: In the Placement subsection, change the value for Minimum distance from staff.
The default value is 2 spaces.
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5.

Optional: In the Placement subsection, change the value for Minimum distance from
other objects.
The default value is 3/4 of a space.

6.

Click Apply, then Close.

RESULT
If you increase the values, bar numbers are positioned further away from the staff and/or other
objects, either above or below the staff depending on your setting for Placement relative to
staff. If you decrease the values, bar numbers are positioned closer to the staff and/or other
objects.
NOTE
These options affect the minimum distance between bar numbers and the staff and other
objects, so bar numbers might be positioned further away than this to avoid collisions.

Changing the system-relative placement of bar numbers
You can show bar numbers either above or below each system in each layout independently. For
example, bar numbers can appear below the system in full score layouts but above the system in
individual part layouts.
NOTE
This does not affect the placement of bar numbers shown above specific staves.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the bar number
placement.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

In the Placement subsection, choose one of the following options for Placement relative to
system:

5.

●

Show above top staff of system

●

Show below bottom staff of system

Click Apply, then Close.

RESULT
The placement of bar numbers relative to the system is changed in the selected layouts.

Moving bar numbers graphically
You can move individual bar numbers graphically without changing the rhythmic positions to
which they apply.
PROCEDURE
1.

In Engrave mode, select the bar numbers you want to move.

2.

Move the bar numbers in any of the following ways:
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●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

RESULT
The selected bar numbers are moved graphically.
TIP
The following properties in the Time Signatures group of the Properties panel are activated
automatically when you move bar numbers in the corresponding directions:
●

Bar number X moves bar numbers horizontally.

●

Bar number Y moves bar numbers vertically.

You can also use these properties to move bar numbers graphically by changing the values in the
value fields.
Deactivating the properties resets the selected bar numbers to their default positions.

RELATED LINKS
Adding bar number changes on page 658
Changing the horizontal position of bar numbers on page 653
Changing the distance between bar numbers and the staff/other objects on page 654

Hiding bar numbers at time signatures shown at system object
positions
You can choose to hide bar numbers at the same rhythmic position as time signatures shown at
system object positions, as the resulting collision can be difficult to resolve in a visually clear way
when bar numbers are centered on barlines.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide bar numbers at time
signatures shown at system object positions.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

In the Showing and Hiding subsection, activate/deactivate Show bar numbers at time
signatures at system object positions.

5.

Click Apply, then Close.
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RESULT
Bar numbers are shown at time signatures shown at system object positions when the option is
activated, and hidden when it is deactivated.
EXAMPLE

Bar numbers shown at time signatures at system
object positions

Bar numbers hidden at time signatures at system
object positions

RELATED LINKS
Time signatures on page 1235
Large time signatures on page 1240

Project-wide engraving options for bar numbers
You can find options for the project-wide appearance, enclosures, and contents of bar numbers
on the Bar Numbers page in Engrave > Engraving Options.
The options on the Bar Numbers page allow you to choose whether repeated sections are
included in bar numbers or not, change the case of letters in subordinate bar numbers, and
change the thickness and padding values for all bar number enclosures project-wide.
RELATED LINKS
Hiding/Showing bar number enclosures on page 647
Bar number enclosure size and padding values on page 648
Bar numbers and repeats on page 661

Bar number changes
Bar numbers follow a continuous sequence, with each bar having a unique bar number that
continues from the previous bar number. However, you can make manual changes to the bar
number sequence, including changing to a subordinate sequence.
In Dorico Pro, you can make the following types of changes to bar number sequences using the
Insert Bar Number Change dialog:
Primary
Adds a change to the main bar number sequence, which the bars in your project follow
in a continuous sequence in each flow separately by default.
Subordinate
Adds a secondary bar number sequence that uses letters rather than numbers to
indicate the sequence. This can be useful in situations where a new version of a piece
has been created with more bars inserted, but the original bar numbers are required.
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Don’t Include
Excludes the selected bar from the current bar number sequence. If bar numbers are
shown every bar, no bar number is shown in bars in which you have chosen Don’t
Include.
Continue Primary
Returns the bar number sequence to the Primary sequence without counting
intervening bars, for example, after a section of bars following the Subordinate bar
number sequence.
RELATED LINKS
Subordinate bar numbers on page 659

Adding bar number changes
You can manually add bar number changes to bar number sequences, for example, if you want
bar numbers in the second flow in your project to appear to continue the sequence from the first
flow, rather than start again from bar one.
PROCEDURE
1.

In Write mode or Engrave mode, select one of the following:
●

An item in the bar from the beginning of which you want to change the bar number
sequence.

●

An existing bar number or barline from which you want to change the bar number
sequence.

2.

Choose Edit > Bar Numbers > Add Bar Number Change to open the Insert Bar Number
Change dialog. You can also choose this option from the context menu.

3.

Choose one of the following options for Type:
●

Primary

●

Subordinate

●

Don’t Include

●

Continue Primary

4.

Optional: If you chose Primary or Subordinate, change the bar number where you want the
bar number sequence change to start by changing the value in the corresponding value
field.

5.

Click OK to save your changes and close the dialog.

RESULT
The bar number sequence changes, starting from the beginning of the bar in which you selected
an item, or from the position of a selected bar number or barline.
This affects the corresponding bar number sequence from the changed bar number until the
next bar number change, or until the end of the flow.

Deleting bar number changes
You can delete any bar number changes you have added.
PROCEDURE
1.

In Write mode, select the bar number changes you want to delete.

2.

Press Backspace or Delete .
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RESULT
The bar number changes are deleted. Subsequent bars follow the previous bar number
sequence until the next bar number change, or until the end of the flow.

Subordinate bar numbers
Subordinate bar numbers are useful for numbering repeat endings, and for situations when the
music is being altered, but the original bar numbers cannot be changed.
For example, you can use subordinate bar numbers to show where music has been added if a
previous, shorter version has already been rehearsed. In this situation, players have likely started
to associate certain parts of the piece with particular bar numbers, so if four bars need to be
added after bar 10, they would be numbered 10a to 10d. The bar number of the following bar
then continues from 11 exactly as it did before the new bars were added.
They might also be useful if you want different bar numbers for a repeat ending.
Subordinate bar numbers are shown with lowercase letters by default, but you can present them
as either uppercase or lowercase letters.

Lowercase subordinate bar number

Uppercase subordinate bar number

RELATED LINKS
Changing the appearance of subordinate bar numbers on page 660

Adding subordinate bar numbers
You can create a subordinate bar number sequence that is independent of your primary bar
number sequence. This can be useful if you want to insert new bars without changing the bar
numbers of existing subsequent bars.
PROCEDURE
1.

In Write mode or Engrave mode, select one of the following:
●

An item in the bar from the beginning of which you want subordinate bar numbers to
start.

●

An existing bar number or barline from which you want subordinate bar numbers to
start.

2.

Choose Edit > Bar Numbers > Add Bar Number Change to open the Insert Bar Number
Change dialog. You can also choose this option from the context menu.

3.

Choose Subordinate for Type to activate the Subordinate value field.

4.

Change the first letter in the subordinate bar number sequence by changing the value in the
Subordinate value field.
The corresponding alphabetical letter is shown to the right of the value field. For example,
entering 1 into the value field is shown as a, 2 appears as b, and so on.

5.

Click OK to save your changes and close the dialog.
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RESULT
The subordinate bar number sequence starts from the bar in which you selected an item, or from
the position of a selected bar number or barline. It has the same bar number as the bar
immediately before, but with subordinate alphabetical letters.
For example, if you start a subordinate bar number sequence from what was originally bar 5, the
sequence starts from 4a and continues until the next specified bar number change, or until the
end of the flow.

Returning to the primary bar number sequence
You can specify the point where you want to return to the primary bar number sequence after a
section of subordinate bar numbers.
PROCEDURE
1.

In Write mode or Engrave mode, select one of the following:
●

An item in the bar from the beginning of which you want to return to the primary bar
number sequence.

●

An existing bar number or barline from which you want to return to the primary bar
number sequence.

2.

Choose Edit > Bar Numbers > Add Bar Number Change to open the Insert Bar Number
Change dialog. You can also choose this option from the context menu.

3.

Choose Continue Primary for Type.
Text indicating the new bar number appears below the value fields for Primary and
Subordinate. For example, Primary sequence will continue from bar 5.

4.

Click OK to save your changes and close the dialog.

RESULT
The primary bar number sequence resumes from the bar in which you selected an item, or from
the position of a selected bar number or barline.
TIP
You do not have to add subordinate bar number changes in chronological order. You can enter a
return to the primary bar number sequence first, before adding the subordinate bar number
sequence.

Changing the appearance of subordinate bar numbers
You can show subordinate bar numbers as either lowercase or uppercase letters.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Bar Numbers in the page list.

3.

In the Sequence subsection, select how you want subordinate numbers to appear:
●

Lower case (default)

●

Upper case
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Bar numbers and repeats
By default in Dorico Pro, repeats are not included in the bar number count. For example, if the
first ending ends in bar 10, the second ending starts in bar 11, even though the first section is
repeated and therefore more than ten bars have been played.
Including repeats in the bar number count, so that bar numbers reflect the total number of bars
played rather than the number of bars written on the page, can make music with multiple
playthroughs clearer, as you can refer to a specific bar number for each playthrough instead of,
for example, “bar eight the third time round”.

Bar number for subsequent repeat shown in parentheses beside the initial bar number

In Dorico Pro, you can include repeats in the bar number count automatically; you do not have to
input bar number changes manually. This applies to any presentation of multiple playthroughs,
including repeat endings and repeat markers, such as D.C. al Coda.
Because it is important that all players refer to the same bar numbers, this affects all layouts
project-wide.
When you include repeats in the bar number count, multiple bar numbers apply to the same
notated bars. To reflect this, Dorico Pro shows the initial bar number as normal but adds bar
numbers for subsequent repeats to the right by default. You can change which playthroughs are
included in bar numbers, and the appearance of bar numbers for subsequent repeats, in each
layout independently. By default, they are shown in parentheses.
EXAMPLE

Bar numbers not counting repeats with only initial
bar numbers shown

Bar numbers counting repeats with bar numbers for
subsequent repeats shown alongside the initial bar
numbers

RELATED LINKS
Changing the appearance of bar numbers for subsequent repeats on page 663
Adding bar number changes on page 658

Including/Excluding repeats from the bar number count
You can choose to include/exclude repeats from the bar number count in all layouts project-wide.
By default, repeats are excluded from the bar number count.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Bar Numbers in the page list.

3.

In the Repeats subsection, choose one of the following options for Bar numbering for
repeated sections:
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4.

●

Count repeats

●

Do not count repeats

Click Apply, then Close.

RESULT
Repeats are included in the bar repeat count when you choose Count repeats, and excluded
from the bar repeat count when you choose Do not count repeats.

Changing which playthroughs are shown in bar numbers
In projects that contain repeats, you can change which playthroughs are shown in bar numbers
in each layout independently, for example, if some players want to see bar numbers for all
playthroughs in their parts but others only want to see the last repeat.
NOTE
This does not affect the overall bar number count, only which bar numbers are shown.
PREREQUISITE
Repeat sections are included in the bar number count.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change which playthroughs are
shown in bar numbers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

In the Repeats subsection, choose one of the following options for Count repeats:

5.

●

All repeats

●

First repeat only

●

Last repeat only

Click Apply, then Close.

RESULT
The playthroughs shown in bar numbers in the selected layouts are changed.
EXAMPLE

Bar numbers with all repeats
shown

Bar numbers with first repeat only
shown

662
Dorico Pro 3.1.10

Bar numbers with last repeat only
shown

Bar numbers
Bar numbers and repeats

Changing the appearance of bar numbers for subsequent repeats
When the bar number count includes repeats, bar numbers for subsequent repeats are shown
beside the initial bar numbers. They are parenthesized by default, but you can change the prefix
and suffix of bar numbers for subsequent repeats in each layout independently.
PREREQUISITE
Repeat sections are included in the bar number count.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the appearance of bar
numbers for subsequent repeats.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Bar Numbers in the page list.

4.

Optional: In the Repeats subsection, enter the prefix you want into the Prefix field.
This field starts with a space by default so there is a gap between the initial bar number and
the subsequent repeat bar number.

5.

Optional: Enter the suffix you want into the Suffix field.

6.

Click Apply, then Close.

RESULT
The appearance of bar numbers for subsequent repeats in the select layouts is changed. For
example, if you want multiple bar numbers for the same bar to be separated by pipes, enter |
into the Prefix field and nothing into the Suffix field.
EXAMPLE

Bar number for subsequent repeat with parentheses Bar number for subsequent repeat with pipe for
for suffix/prefix
prefix
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A beam is a line that connects notes with tails to show rhythmic grouping, which varies according
to the metrical structure of the current time signature.
This way of grouping notes helps performers calculate quickly exactly how to play their given
rhythm and helps them follow both their part and, if applicable, the conductor.
If appropriate for the current meter and position in the bar, beams are automatically formed in
Dorico Pro when you input two or more adjacent notes or chords that are an eighth note
(quaver) or shorter in duration.

Multiple beam groups in a 6/8 time signature

There are many different accepted standards for how to present beams, so Dorico Pro offers a
number of customizing options. You can find these options on the Beams page in Engrave >
Engraving Options.
You can find options that control how notes are grouped into beam groups by default in each
flow on the Beam Grouping page in Write > Notation Options.
RELATED LINKS
Inputting notes on page 172
Per-flow notation options for beam grouping on page 665
Engraving Options dialog on page 359
Notation Options dialog on page 160

Beam groups
Notes are commonly beamed as regular groups to help reflect the meter. You can control how
notes are beamed in multiple ways in Dorico Pro.
●

You can set beam grouping defaults in each flow in your project independently in Notation
Options.

●

You can set beam groups by controlling subdivisions of time signatures.

●

You can change beam groups individually using properties in the Properties panel, and by
choosing Edit > Beaming and selecting one of the available options.

RELATED LINKS
Beaming notes together manually on page 667
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Per-flow notation options for beam grouping
You can find options to control the default beam grouping rules in each flow independently on
the Beam Grouping page in Write > Notation Options.
Dorico Pro has sophisticated underlying rules for producing beam groupings that follow the
accepted conventions of music theory, including crossing the half-bar in time signatures like 4/4,
beaming all eighth notes together in 3/4, beam groups that include tuplets, and many other
situations.
There are alternative conventions for some of these rules, which you can change for each flow in
your project independently on the Beam Grouping page in Notation Options.
Musical examples demonstrate how each option affects the appearance of your music.
RELATED LINKS
Notation Options dialog on page 160

Beam grouping according to meters
According to accepted conventions, notes are beamed differently in different time signatures to
make the meter clear and easily readable. In Dorico Pro, default beam groupings are determined
by time signatures.
Dorico Pro has default beaming settings for common time signatures, based on general
conventions and your chosen settings. For example, although the time signatures of 3/4 and 6/8
contain the same number of beats, they imply different meters and so are beamed differently. In
3/4, phrases of eighth notes are beamed together within each bar and phrases of other
durations are beamed in quarter notes (crotchets) by default, but in 6/8, phrases are beamed in
dotted quarter notes.

Default eighth note beam grouping in 3/4

Default eighth note beam grouping in 6/8

Dorico Pro groups and beams notes in irregular time signatures, such as 5/8 or 7/8, according to
the most common practices for those time signatures.

Default beam grouping in 5/8

Default beam grouping in 7/8

For situations where you want to control the beat grouping in more detail, you can input a
custom time signature with an explicit rhythmic subdivision. Dorico Pro then automatically
beams phrases according to this subdivision. For example, entering [7]/8 into the time signatures
popover means all seven eighth notes (quavers) are beamed together, whereas entering
[2+2+3]/8 subdivides the seven eighth notes into two, then two, then three.
NOTE
The duration of beam groups in Dorico Pro depends on the beat grouping in the current time
signature and your per-flow beam grouping settings in Write > Notation Options.
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RELATED LINKS
Note and rest grouping on page 681
Creating custom beat groupings for meters on page 682

Splitting beam groups
You can split beams and secondary beams into two beam groups at specific rhythmic positions.
You can also split secondary beams within beamed groups.
PROCEDURE
1.

Select the noteheads to the right of where you want to split beams. You can do this in Write
mode and Engrave mode.

2.

Split the beam or secondary beam in one of the following ways:
●

Choose Edit > Beaming > Split Beam.

●

Choose Edit > Beaming > Split Secondary Beam.

TIP
You can also choose these options from the context menu.

RESULT
Beams/Secondary beams are split to the left of each selected note, but the notes either side of
the split remain grouped if there are at least two beamed notes on each side that can be in a
beam group.
NOTE
To unbeam the entire selection and give all notes in the group individual tails, you can make all
notes unbeamed.

RELATED LINKS
Unbeaming notes on page 667

Resetting beam grouping
You can remove all changes made to the beam grouping of notes and chords. This can also be
useful if, for example, MusicXML files you have imported have incorrect beaming.
PROCEDURE
1.

Select the notes/chords whose beaming you want to reset. You can do this in Write mode
and Engrave mode.

2.

Choose Edit > Beaming > Reset Beaming. You can also choose this option from the context
menu.

RESULT
Beam grouping is reset to your default settings in Notation Options for the current flow and
time signature.
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Beaming notes together manually
You can beam notes together manually, including notes across barlines as well as system/frame
breaks, for example, if you want to beam a phrase differently to how it is usually beamed in the
current time signature.
Beams by default stay within bars and systems, so to have beams cross barlines, system breaks,
and frame breaks, you must force the phrase to beam together.
PROCEDURE
1.

Select the notes you want to beam together. You can do this in Write mode and Engrave
mode.

2.

Choose Edit > Beaming > Beam Together. You can also choose this option from the context
menu.

RESULT
The selected notes are beamed together, even if they cross barlines or system/frame breaks.
If there are notes either side of the new beam group that were previously beamed to part or all
of your selection, they either beam together as separate beams, or appear unbeamed. This
depends on how many notes are left either side in the bar, and on the beam grouping settings
for the flow.
NOTE
Even if part of the beamed group previously had a centered beam, the new beam is not centered.

RELATED LINKS
Creating fanned beams on page 679
Allowing/Disallowing tuplets to span barlines on page 1264

Unbeaming notes
You can separate all notes in a beamed group so that each note shows its own tail, for example,
when fast rhythms have syllabic text settings.
PROCEDURE
1.

Select the notes you want to make unbeamed. You can do this in Write mode and Engrave
mode.

2.

Choose Edit > Beaming > Make Unbeamed. You can also choose this option from the
context menu.

Changing the direction of partial beams
Dorico Pro automatically inputs a partial beam if one is required. You can change on which side
of stems individual partial beams appear.
PROCEDURE
1.

Select the notes whose partial beam direction you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Partial beam direction in the Beaming group.

3.

Choose one of the following options:
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●

Left

●

Right

RESULT
The partial beam appears on the corresponding side of the stem.
EXAMPLE

Partial beam direction Left

Partial beam direction Right

Beam placement relative to the staff
The default staff-relative placement of beams is determined by the staff positions of the notes
within the beamed group and their resulting stem directions.
This means that the note furthest from the middle line of the staff determines the placement of
the beam, although there are exceptions to this rule and other considerations that can influence
the staff-relative placement of beams.
Changing the staff-relative placement of beams involves changing the direction of the stems in
the beam. Therefore, Dorico Pro categorizes changing the staff-relative placement of beams as a
stem change.

Changing the staff-relative placement of beams
You can change the side of the staff on which beams appear by forcing the stem direction to
change.
PROCEDURE
1.

Select at least one note in each of the beamed phrases whose staff-relative placement you
want to change. You can do this in Write mode and Engrave mode.

2.

Force the stem direction of notes in the selected beams in any of the following ways:
●

Choose Edit > Stem > Force Stem Up.

●

Choose Edit > Stem > Force Stem Down.

TIP
●

You can also choose these options from the context menu.

●

You can also change the staff-relative placement of selected beams by pressing F .

RESULT
The beam appears on the side of the staff that corresponds to its forced stem direction.
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Removing beam placement changes
You can undo changes to the staff-relative placement of beams in order to remove the stem
direction change. This reverts selected beams to their default placement.
PROCEDURE
1.

Select at least one note in each of the beamed phrases whose staff-relative placement
change you want to remove. You can do this in Write mode and Engrave mode.

2.

Choose Edit > Stem > Remove Forced Stem. You can also choose this option from the
context menu.

RESULT
The selected beams revert to their default staff-relative placement.

Beam slants
The slant of a beam controls how steeply the beam deviates from horizontal, according to the
pitches of the notes within the beamed group.
●

When the last note of the phrase is higher than the first, the beam slants upwards.

●

When the last note of the phrase is lower than the first, the beam slants downwards.

●

If the group makes a concave shape, where inner notes are closer to the beam than the
outer ones at either end of the beam, then the beaming is horizontal by default.
Beams are also horizontal if all the pitches are the same, or for certain patterns of repeated
pitches.

When a beam is drawn inside the staff, each end of the beam, meaning the end of the stem of
the note at either end of the beam, must be snapped to a staff line position. A beam line may sit
on a staff line, be centered on a staff line, or hang from a staff line. Ted Ross describes these
three positions as “sit”, “straddle”, and “hang” respectively in “Teach Yourself the Art and Practice
of Music Engraving”.

A phrase containing multiple different beam slants and directions

The amount by which a beam slants is typically determined by the interval between the first and
last note in the beamed group, provided the pattern of notes in the beam does not dictate a
horizontal beam instead. Smaller intervals require a shallower slant and larger intervals require a
steeper one.
However, the desired amount of slant is not the only factor that must be considered. The
innermost beam line should not come too close to the innermost notehead, and the beam itself,
if possible, should be positioned relative to the staff lines such that it does not form a wedge. A
wedge is a tiny triangle formed by the horizontal staff line, the vertical stem, and the angled line
of the slanted beam, which can be visually confusing.
Determination of the amount of slant for a beam is therefore a balancing act that must weigh up
several factors: the desired amount of slant, valid snapping positions for each end of the beam,
ensuring a minimum distance between the note closest to the beam and the innermost beam
line, and avoiding wedges where possible.
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You can change the default settings for how beams appear project-wide.
●

You can specify the minimum stem length for notes of different durations on the Notes page
in Engrave > Engraving Options.

●

You can set ideal beam slants on the Beams page in Engrave > Engraving Options.

You can also change the beam slants of individual beams.

Changing beam slants
You can change the slants, or angles, of individual beams.
PROCEDURE
1.

In Engrave mode, select the square handles on the beam corners of the beams whose slants
you want to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
You can also select the beams first, and then select the handles.

2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●
3.

Click and drag them upwards/downwards.

Optional: Repeat steps 1 and 2 to move the other end of the selected beams.

RESULT
The slants of the selected beams are changed
TIP
●

You can also use Beam direction in the Beaming group of the Properties panel to change
the slant of beams. The property is available when you select noteheads within the beam
group, and its options all ensure that beam ends are positioned correctly relative to staff
lines.

●

You can set ideal beam slants for all beams project-wide on the Beams page in Engrave >
Engraving Options.

Centered beams
Centered beams are positioned between high and low notes within the same beamed group,
typically drawn in the middle of the staff or between the staves of grand staff instruments.
Centered beams are also known as “kneed” or “elbowed” beams due to their often angular
shape.
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When a beamed phrase spans a large pitch range, normal beams are often positioned very close
to some notes in the phrase but very far from other notes in the phrase, making some stems
very long. Having a centered beam in a phrase that spans a large pitch range can reduce the
maximum distance between noteheads and the beam, but can also place the beam within the
staff, which can obscure staff lines.

A phrase with high and low notes with default
beaming

The same phrase with high and low notes, but with a
centered beam

RELATED LINKS
Changing the staff-relative placement of beams on page 668

Creating centered beams
You can make beams appear in the middle of staves, with high notes above the beam and lower
notes below the beam.
NOTE
As this action requires changing the direction of some stems in order to appear correctly, it is
located in the Stem submenu rather than Beaming in the Edit menu.

PROCEDURE
1.

Select at least one note in each of the beams you want to center. You can do this in Write
mode and Engrave mode.

2.

Choose Edit > Stem > Force Centered Beam. You can also choose this option from the
context menu.

RESULT
Beams are centered between the notes in the selected beam groups.
If you select notes in multiple beams, each beam is centered separately. If you want to create a
single centered beam, you can beam the notes in those beam groups together. You can do this
both before and after centering the beams.
NOTE
Dorico Pro automatically angles the beam based on the shape of the phrase, but you can change
the angles or slants of beams manually.
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RELATED LINKS
Beaming notes together manually on page 667
Changing beam slants on page 670

Removing centered beams
You can remove centered beams and revert beams to their default placements either above or
below the phrase.
PROCEDURE
1.

Select at least one note in each centered beam that you want to revert to the default
placement. You can do this in Write mode and Engrave mode.

2.

Choose Edit > Stem > Remove Centered Beam. You can also choose this option from the
context menu.

RESULT
The centered beams are removed.

Creating cross-staff beams
Cross-staff beams work in a similar way to normal beams, but allow a phrase that covers a wide
pitch range to be shown on two staves. You can create cross-staff beams by inputting all notes in
the phrase on one staff and crossing some notes to appear on another staff.
PREREQUISITE
You have input a phrase on one staff.
PROCEDURE
1.

Select the notes you want to cross to another staff. You can do this in Write mode and
Engrave mode.
NOTE
You can only cross notes to other staves in multi-staff instruments.

2.

Cross the notes to other staves in any of the following ways:
●

To cross notes to the staff above, press N .

●

To cross notes to the staff below, press M .

RESULT
The selected notes are shown on a different staff, with a cross-staff beam shown if the notes are
part of a beam group. This does not change the staff to which the notes belong.
NOTE
●

When crossing notes to a staff that already contains notes, the stem direction of the existing
notes on the staff can change. This is due to how multiple voices at the same rhythmic
position are handled. Therefore, you may have to change the stem direction of notes
manually.

●

You can reset notes to appear on their default staff by selecting them and choosing Edit >
Cross Staff > Reset to Original Staff.

●

If you want notes to belong to a different staff, you can move them to another staff.
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EXAMPLE

Notes shown on their original staves

Cross-staff beams created by crossing some notes to
the other staff

RELATED LINKS
Moving notes to other staves on page 339
Notes crossed to staves with existing notes in other voices on page 1298
Note positions in multiple-voice contexts on page 1294
Changing the stem direction of notes on page 1199

Optical spacing for cross-staff beams
Normally, the human eye perceives the evenness of rhythmic spacing according to the distance
between noteheads. However, for cross-staff beams we consider the distance between stems,
rather than the noteheads, to be even/uneven.

Default spacing: The distance between noteheads is
optimized.

Optical spacing for cross-staff beaming: the distance
between stems is optimized.

Changing to optical cross-staff beam spacing
You can make the stems in cross-staff beams, rather than the noteheads, evenly spaced in each
layout independently.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts that you want to change to optical cross-staff beam
spacing.
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By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.
3.

Click Note Spacing in the page list.

4.

Activate Use optical spacing for beams between staves.

5.

Click Apply, then Close.

Cross-staff beam placement in multiple staves
When instruments have three or more staves, cross-staff beams can be placed in multiple ways.
For example, the beam can be placed between the top and the middle staves, and also between
the middle and bottom staves.
If a beam only crosses two staves, the cross-staff beam goes between those two staves.

A cross-staff beam across the upper two staves on
an instrument with three staves

A cross-staff beam across the lower two staves on an
instrument with three staves

If a beam group contains notes on all three staves, the placement of the beam depends on the
stem directions of the notes in each staff.

1

If all notes in the beam group are stem-up, the beam is placed above the top staff.

2

If all notes in the beam group are stem-down, the beam is placed below the bottom staff.

3

If notes are stem-down on the top staff and stem-up on the bottom two staves, the beam is
placed between the top and middle staves.

4

If notes are stem-down on the top two staves and stem-up on the bottom staff, the beam is
placed between the bottom and middle staves.
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NOTE
If you have not specified stem directions, Dorico Pro might place the beam above/below the staff
into which the notes were originally input, even if the stem directions mean it should be placed
between other staves.
If you want the beam to be placed between specific staves, you can change the stem directions
of notes in the beam group.

RELATED LINKS
Changing the stem direction of notes on page 1199

Beam corners
Beam corners can occur when a change of stem direction within a beam is combined with a
break in the secondary beam group. This can be at the end of a subdivision or at a change in
rhythmic speed.
Beam corners do not follow accepted rules regarding the order and rhythmic meaning of
secondary beams, and can be confusing for the reader.

Dorico Pro avoids beam corners by analyzing the pitches and stems within a phrase, and
implementing stem directions that avoid a beam corner.

Secondary beams
Secondary beams are the lines that are added between the primary beam and the notehead as
the rhythmic division gets smaller.
The primary beam is the outermost beam line that joins all of the notes in the beamed group.
Depending on the durations of the notes in the beamed group, the primary beam may in fact be
two or more lines; that is, for notes of a 16th or shorter in duration.
Secondary beams are additional beam lines that join only some of the notes in the group,
creating subdivisions of the beam in order to make the metrical groupings of the beam clearer.

A phrase of 64th notes, with secondary beams subdivided to show 16th and eighth note groups

You can set per-flow options for how secondary beams appear on the Beam Grouping page in
Write > Notation Options.
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Changing the number of beam lines in secondary beams
You can change the number of beam lines shown in secondary beams individually,
independently of your default setting for the current flow.
PROCEDURE
1.

Select the notes to the right of where you want to change the number of secondary beaming
lines. You can do this in Write mode and Engrave mode.

2.

Optional: If any of the notes you selected do not immediately follow existing splits in the
secondary beam, split the secondary beams in any of the following ways:
●

In the Properties panel, activate Split secondary beam in the Beaming group.
NOTE
The Beaming group is only shown in the Properties panel if your selection only contains
notes.

●
3.

Choose Edit > Beaming > Split Secondary Beam. You can also choose this option from
the context menu.

In the Properties panel, select the note value that corresponds to the number of beam lines
you want shown from the Split secondary beam menu.

RESULT
The number of beam lines shown immediately to the left of each selected note is changed.
NOTE
●

The number of beam lines shown at a split in the secondary beam cannot be the same or
greater than the number of beam lines in the secondary beam. For example, if you split a
secondary beam containing 64th notes, the maximum number of beam lines shown at the
split in that beam is three, the equivalent of 32nd notes.

●

You can change the default number of secondary beam lines shown in each flow
independently on the Beam Grouping page in Write > Notation Options.

Resetting changes to the number of secondary beam lines
You can reset any changes you have made to the number of beam lines shown in secondary
beams and return them to their default appearance.
PROCEDURE
1.

Select the notes to the right of where you want to reset the number of secondary beam lines.
You can do this in Write mode and Engrave mode.

2.

Reset your changes to the number of secondary beam lines in any of the following ways:
●

In the Properties panel, deactivate Split secondary beam in the Beaming group.

●

Choose Edit > Beaming > Reset Beaming. You can also choose this option from the
context menu.

676
Dorico Pro 3.1.10

Beaming
Tuplets within beams

Tuplets within beams
Tuplets that contain notes that produce beams are also beamed together, but special beam
grouping rules apply to tuplets within beams that also contain non-tuplet notes.
The default setting for a tuplet in a beamed group with secondary beams is to split the secondary
beam and to show the tuplet with a bracket. The primary beam is not split.
You can alter the appearance of the bracket by selecting the bracket and changing relevant
properties in the Tuplets group of the Properties panel.

Tuplets in beam groups with secondary beams are beamed together with a split secondary beam by default.

The default setting for a tuplet in a beamed group with only a primary beam is to separate the
tuplet entirely. However, you can change this setting on the Beam Grouping page in Notation
Options.

Eighth note (quaver) tuplets are not beamed together with subsequent non-tuplet eighth notes by default.

RELATED LINKS
Tuplets on page 1261

Stemlets
Stemlets are short stems that extend from beams to rests within beam groups. They can help
make music easier to read, as they help to maintain a regular pattern of stems within beams.
In the examples, beaming all notes and rests together to show the boundaries of quarter note
(crotchet) beats makes the syncopation of the notes easier to read. The stemlets on the rests
help make clear where within the quarter note beats each note occurs.

A syncopated phrase without stemlets

The same phrase with stemlets

You can change the default appearance of stemlets in each flow, and you can show stemlets in
individual beams.

Showing stemlets in beam groups
You can show stemlets on rests in beam groups individually, independently of your default
setting for showing stemlets in the current flow.
PROCEDURE
1.

Select the notes you want to beam together with stemlets shown on rests.
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For example, to show a stemlet on a rest between two notes, select both notes. To show a
stemlet on a rest at the end of a beamed phrase, select all notes in the beam and the rest.
2.

Choose Edit > Beaming > Stemlets > Force Stemlet Beam. You can also choose this option
from the context menu.

RESULT
The selected notes are beamed together with stemlets shown on rests within the beam group.
NOTE
●

If you later reset the beaming of the selected group, stemlets revert to your default setting
for the flow.

●

You can choose to show stemlets on rests in all beamed groups in each flow on the Beam
Grouping page in Write > Notation Options.

EXAMPLE

Stemlet with only the rest selected Stemlet with notes either side
selected

Stemlets shown with all notes and
rests in beam group selected

Removing stemlets from beam groups
You can remove stemlets from rests in beam groups individually, independently of your default
setting for showing stemlets in the current flow.
PROCEDURE
1.

Select at least one note in each of the beam groups from which you want to remove stemlets
on rests.

2.

Choose Edit > Beaming > Stemlets > Suppress Stemlet Beam. You can also choose this
option from the context menu.

RESULT
Stemlets are removed from all rests in the selected beams.
NOTE
●

Removing stemlets from beams does not reset the selected beams to your default beam
grouping for the flow.

●

You can choose not to show stemlets on rests in all beam groups in each flow on the Beam
Grouping page in Write > Notation Options.
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EXAMPLE

Beam group showing stemlets

Beam group with suppressed stemlets

RELATED LINKS
Resetting beam grouping on page 666

Fanned beams
Fanned beams show either an accelerando or rallentando by having multiple beam lines either
converging on, or diverging from, a single beam line at the other end. Fanned beams are also
known as “feathered beams”.
A single fanned beam can have multiple changes of direction within it.
The grouping can use either two or three beams, with three beams indicating a greater change
of speed than two beams. The slowest part of the phrase is where the beams converge, and the
fastest is where the beams are the most spread out.
EXAMPLE
Fanned beam accelerando with three lines

Fanned beam accelerando with two lines

Fanned beam rallentando with three lines

Fanned beam rallentando with two lines

Creating fanned beams
You can create fanned beams across a group of any notes that can be beamed, such as eighth
notes (quavers), 16th notes (semiquavers), and 32nd notes.
PROCEDURE
1.

Select the notes you want to include in a fanned beam. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Beaming > Create Fanned Beam > [Direction and number of lines]. You can
also choose these options from the context menu.
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For example, choose Edit > Beaming > Create Fanned Beam > Accelerando (Three Lines)
for an accelerando fanned beam with three lines.
RESULT
The selected notes are joined with a fanned beam with a single slope, whatever their original
duration.

Changing the direction within fanned beams
You can change the direction of fanned beams within phrases to indicate tempo changes.
PROCEDURE
1.

In Engrave mode, select the notehead at each rhythmic position where you want to change
the direction of the fanned beam slope. You can select multiple positions within phrases.

2.

In the Properties panel, activate Change fanned beam direction in the Beaming group.

EXAMPLE

Fanned beam with multiple changes of direction
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There are generally accepted conventions for how notes and rests of different durations are
notated and grouped in different contexts and meters. In Dorico Pro, notes are automatically
notated to fit within bars and are grouped according to your per-flow settings.
Depending on the prevailing time signature, there can be many different ways to beam notes
together. For example, you might want to beam all notes in the bar together in time signatures
that cannot be divided in half and are often not divided at all, such as 3/4.

A passage containing different meters. Notes are grouped and beamed differently in the different meters,
and the durations of tied notes that cross the second barline are automatically correct.

Tied notes are affected by your note and rest grouping settings, as there are different
conventions for how notes within tie chains should be divided to indicate significant beat
boundaries within bars, and in which contexts they can cross beat boundaries.
Similar options apply to dotted notes, which are often notated as a single dotted note if they
start at the beginning of bars, but as a tie chain that shows significant beat boundaries in the bar
if they start part-way through bars.
TIP
You can change the default note grouping and beam grouping settings for your project on the
Note Grouping and Beam Grouping pages in Write > Notation Options.
Musical examples demonstrate how each option affects the appearance of your music.

RELATED LINKS
Beaming on page 664
Beam grouping according to meters on page 665
Notation Options dialog on page 160
Per-flow notation options for beam grouping on page 665
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Creating custom beat groupings for meters
If your music requires a different beat grouping for a particular meter than the default setting
for that time signature, you can specify your preferred beat grouping within the time signature.
You can choose whether or not the time signature shows this custom beat grouping.
NOTE
The duration of beam groups in Dorico Pro depends on the beat grouping in the current time
signature and your per-flow beam grouping settings in Write > Notation Options. For example,
entering [1+1+1+1]/4 into the time signatures popover inputs a time signature with four quarter
note (crotchet) groups. Because this creates a time signature with a half-bar, beam grouping
options for time signatures with a half-bar apply.

PROCEDURE
1.

In Write mode, select an item at the rhythmic position where you want to input a time
signature with a custom beam grouping.

2.

Press Shift-M to open the time signatures popover.

3.

Enter the division you want in square brackets into the popover.
For example, to divide a 7/8 time signature into 2+3+2, enter [2+3+2]/8 into the popover. To
divide a 5/4 time signature into 2+3 rather than 3+2, enter [2+3]/4 into the popover.

4.

Input the time signature and close the popover in one of the following ways:
●

To input a time signature on all staves, press Return .

●

To input a time signature on the selected staff only, press Alt/Opt-Return .

RESULT
The time signature specified is input and beam and beat grouping in subsequent bars follows
the division you specified. The time signature appears either as a single number, such as 7/8, or
showing the beat groups, such as 2+3+2/8, depending on your setting on the Time Signatures
page in Engrave > Engraving Options.
TIP
You can change the appearance of numerators in individual time signatures so that they show a
single number or beat groups, independently of your project-wide settings.

RELATED LINKS
Beam grouping according to meters on page 665
Per-flow notation options for beam grouping on page 665
Project-wide engraving options for time signatures on page 1237
Time signature styles on page 1243
Changing the numerator style of time signatures on page 1243
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Brackets and braces are thick straight and curved lines in the left-hand margin that show
instrument groupings.

Brackets
A bracket is a thick black line, the width of a beam, that groups staves together, most commonly
according to instrument family. It often has winged ends that point inwards towards the score.
It is always positioned directly to the left of a systemic barline. If secondary brackets are used in
addition to a bracket, they are positioned further away from the start of the system to allow
space for the bracket.

An example of a bracket, connecting instruments in the string family. A sub-bracket connects the two violin
lines.

In Dorico Pro, barlines join the same staves that are joined by brackets and braces, meaning that
bracketed groups of staves and braced pairs of staves appear with barlines extending across the
group.

Braces
A brace is a wavy or curly line that joins multiple staves belonging to the same instrument,
usually a grand staff instrument such as the piano or harp. If necessary, a brace can extend to
three or more staves, although two is most common.
The brace is also sometimes used instead of a sub-bracket to show groupings of identical
instruments within a family whose staves are joined by a bracket.
It is positioned outside the systemic barline, and if used in place of a sub-bracket, outside of the
bracket as well.
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A brace connecting two piano staves

NOTE
●

Staves cannot be bracketed and braced simultaneously. Therefore, braced staves are
excluded from bracketed groups. They also cannot show sub-brackets or sub-sub-brackets.

●

System objects are only shown above instrument families that are bracketed or braced
together.

RELATED LINKS
Barlines across staff groups on page 641
Player groups on page 129
Adding player groups on page 130
Brackets according to ensemble type on page 685
Changing bracket grouping according to ensemble type on page 684
Custom staff grouping on page 689
System objects on page 1172

Changing bracket grouping according to ensemble type
You can change which staves are included in brackets by changing the ensemble type for each
layout independently, for example, if a part layout containing all percussion players requires
different bracketing than used for percussion staves in the full score layout.
The default setting is Orchestral. We recommend that you change this setting for projects
containing small ensembles.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the ensemble type for
bracket grouping.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Brackets and Braces in the page list.

4.

Choose one of the following options for Ensemble type:

5.

●

No brackets

●

Orchestral

●

Small ensemble

●

Wind band

●

Big band

●

British brass band

Click Apply, then Close.
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RESULT
The default bracket grouping is changed in the selected layouts.
TIP
●

There are further options for bracketing on the Brackets and Braces page, such as hiding/
showing brackets when there is only a single instrument in the bracket group and hiding/
showing braces when only a single staff is shown.

●

You can also input custom bracket/brace grouping for specific staves, independently of the
bracket grouping setting in the layout.

Brackets according to ensemble type
In Dorico Pro, default staff grouping is determined by the ensemble type chosen for each layout.
This affects which staves are bracketed together and joined by barlines.
The following ensemble types are available on the Brackets and Braces page in Setup > Layout
Options:
No brackets
All staves appear separately, with no brackets. Grand staff instruments are still shown
with braces.
This is the default setting for full score layouts in projects started from Solo and small
Jazz project templates.
Orchestral
Staves are bracketed according to their instrument family. For example, adjacent string
instruments are bracketed together separately from adjacent woodwind instruments.
However, vocal staves are not joined by barlines.
This is the default setting for all layouts in new projects and projects started from
Orchestral, Choral and Vocal, and Concert band project templates, and for custom
score and part layouts in projects started from all other project templates.
Small ensemble
All staves in the project are bracketed together, regardless of their instrument family,
excluding braced staves.
This is the default setting for full score layouts in projects started from Chamber and
Pit band project templates.
Wind band
Staves are bracketed according to their instrument type. For example, Flute 1 and Flute
2 are bracketed together, but separately from the other woodwind instruments.
Big band
Staves are bracketed according to their instrument family, except for brass
instruments, which are all bracketed according to their instrument type.
Rhythm section instruments are bracketed together.
Percussion and timpani are bracketed together.
British brass band
Brass instruments are bracketed according to their instrument type, except for horns
and trumpets, which are bracketed together.
Any other instruments in the score are bracketed according to their instrument family.
Percussion and timpani are bracketed separately.
This is the default setting for full score layouts in projects started from the Big band
project template.
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NOTE
●

Staves cannot be bracketed and braced simultaneously. Therefore, braced staves, such as
the piano and other grand staff instruments, are excluded from brackets. They also split
brackets if they are placed within a bracketed group.

●

By default, there must be at least two adjacent instruments to show a bracket. You can
choose to show brackets on single instruments in each layout independently on the
Brackets and Braces page in Setup > Layout Options.

●

Vocal staves are never joined by barlines, even when bracketed together.

●

System objects are only shown above instrument families that are bracketed or braced
together.

RELATED LINKS
Project template categories on page 71
System objects on page 1172
Custom staff grouping on page 689

Secondary brackets
Secondary brackets are a second level of staff grouping. They are positioned to the left of
brackets and allow you to mark groups of staves within a bracketed group. In Dorico Pro,
secondary brackets can appear as a brace or as a sub-bracket.
By default, secondary brackets appear as sub-brackets: thin lines with square corners that extend
beyond the bracket. You can change the appearance of secondary brackets and hide/show them
for adjacent identical instruments in bracketed groups in each layout independently.

Secondary bracket as a sub-bracket

Secondary bracket as a brace

NOTE
You cannot show sub-sub-brackets in addition to braces, you can only show sub-sub-brackets in
addition to sub-brackets.
You can input and delete sub-brackets from selected rhythmic positions using custom bracket/
brace groups.
You can change various aspects of the appearance and position of secondary brackets, such as
whether sub-brackets reach to the systemic barline or just to the bracket, in the Sub-brackets
subsection of the Design section of the Brackets and Braces page in Engraving Options.
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RELATED LINKS
Custom staff grouping on page 689

Hiding/Showing secondary brackets
You can hide/show secondary brackets for adjacent identical instruments in bracketed groups in
each layout independently.
PROCEDURE
1.
2.

Press Ctrl/Cmd-Shift-L to open Layout Options.
In the Layouts list, select the layouts in which you want to hide/show secondary brackets.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Brackets and Braces in the page list.

4.

Choose one of the following options for Instruments of the same kind within a bracketed
group:

5.

●

Use secondary brackets

●

No secondary brackets

Click Apply, then Close.

RESULT
Secondary brackets are shown in the selected layouts when you choose Use secondary
brackets, and hidden when you choose No secondary brackets.
TIP
You can show sub-brackets from selected rhythmic positions onwards using custom bracket/
brace groups, including in layouts where they are hidden by default.

Showing secondary brackets as sub-brackets/braces
Secondary brackets extend beyond brackets, allowing you to mark groups of staves within a
bracketed group. You can show secondary brackets as either braces positioned outside the
bracket or as sub-brackets in each layout independently.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the appearance of
secondary brackets.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Brackets and Braces in the page list.

4.

Choose one of the following options for Secondary bracket appearance:

5.

●

Brace

●

Sub-bracket

Click Apply, then Close.
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RESULT
The appearance of all secondary brackets in the selected layouts is changed. This includes
secondary brackets in custom bracket/brace groups.
NOTE
Because you cannot show sub-sub-brackets in addition to braces, sub-sub-brackets are not
shown in layouts where sub-brackets appear as braces.

Sub-sub-brackets
Sub-sub-brackets are a tertiary level of staff grouping with the same design as sub-brackets. They
are positioned outside of both brackets and sub-brackets, allowing you to mark groups of staves
within bracketed and sub-bracketed groups. Sub-sub-brackets can only appear as brackets in
Dorico Pro.
Sub-sub-brackets cannot extend beyond their sub-bracket and cannot be shown on staves with a
brace as either the primary or secondary group.

You can input and delete sub-sub-brackets from selected rhythmic positions using custom
bracket/brace groups.
You can change how thick the lines of sub-sub-brackets are, their width, and their design in the
Sub-sub-brackets subsection of the Design section of the Brackets and Braces page in
Engrave > Engraving Options.

Project-wide engraving options for brackets and braces
You can find options for the project-wide appearance of brackets and braces on the Brackets
and Braces page in Engrave > Engraving Options.
The options on the Brackets and Braces page allow you to change the design of brackets, such
as by hiding or showing wings on bracket ends, and the gaps between brackets, braces, subbrackets, and sub-sub-brackets and other items, such as systemic barlines. You can also set span
thresholds for when you want Dorico Pro to use the different available brace designs, including
preventing Dorico Pro ever showing flat braces.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
RELATED LINKS
Engraving Options dialog on page 359
Changing bracket grouping according to ensemble type on page 684
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Changing the appearance of bracket ends
You can change the appearance of all bracket ends project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Brackets and Braces in the page list.

3.

In the Design section, choose one of the following options for Bracket end design:
●

Wings (default)

●

Horizontal line

●

None

Custom staff grouping
In Dorico Pro, custom staff grouping allows you to change which staves are joined with brackets,
braces, sub-brackets, sub-sub-brackets, and barlines if your project requires staff grouping not
included in the default bracketing settings.
Any changes to the default staff grouping are shown as bracket and barline change signposts,
which also show the rhythmic position from which the changes apply. They only affect the staff
grouping in the current layout.
If bracket and barline change signposts are positioned at the start of a system, the
corresponding staff grouping changes apply from that system onwards. If the signpost is
positioned partway through a system, the change takes effect from the following system.
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A bracket and barline change signpost indicating sub-sub-brackets have been added to separate the divisi
cello parts and barlines only join staves of the same instrument type rather than all strings.

NOTE
For best results, we recommend that you input any bracket/brace grouping or barline join
changes you want only after adding any extra staves, ossia staves, or additional instruments you
want and with all staves shown in the layout. You can hide empty staves again after inputting the
changes.
We also recommend that you input any bracket/brace grouping or barline join changes you want
at the beginning of the flow, and add any subsequent changes in chronological order. We do not
recommend starting at the end of the flow.

RELATED LINKS
Signposts on page 335
Inputting custom barline joins on page 643
Barlines across staff groups on page 641

Inputting custom bracket/brace groups
You can input custom bracket/brace grouping changes at any position that change which staves
are grouped with brackets, sub-brackets, sub-sub-brackets, and braces.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select an item on the top staff you want to group with a bracket/brace, at
the start of the system from which you want this change to apply.
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2.

Ctrl/Cmd -click an item on the bottom staff you want to group with a bracket/brace.

3.

In the Formatting panel, click one of the following in the Bracketing group:
●

Insert bracket

●

Insert sub-bracket

●

Insert sub-sub-bracket

●

Insert brace

RESULT
All staves in the current layout between and including the staves on which you selected items are
joined by the bracket or brace you chose until the next existing bracket and barline change or the
end of the flow, whichever comes first. A signpost appears at the start of the system in which you
selected items.
If necessary, any existing bracket or brace groupings are adjusted to accommodate the new
group as brackets/braces cannot overlap.
NOTE
●

You cannot move bracket and barline change signposts, as they are intended to apply to
system start positions. However, they can appear partway through systems if, for example,
you move system breaks. When a bracket and barline change signpost is positioned partway
through a system, the corresponding change only takes effect from the start of the next
system.

●

Sub-brackets can appear as braces, depending on your per-layout setting for the appearance
of secondary brackets. Because you cannot show sub-sub-brackets in addition to braces,
sub-sub-brackets are not shown in layouts where sub-brackets appear as braces.

●

Staves cannot be bracketed and braced simultaneously. Therefore, braced staves are
excluded from bracketed groups.
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EXAMPLE

Divisi cello staves with default staff grouping

Divisi staves with sub-sub-brackets added

RELATED LINKS
Showing secondary brackets as sub-brackets/braces on page 687

Lengthening/Shortening custom brackets/braces
You can lengthen/shorten custom brackets/braces vertically to change the staves across which
they span, for example, if you added a new player below a bracket group and want to extend the
bracket to that staff.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select a handle at either the top or bottom of each bracket/brace you want
to lengthen/shorten.
TIP
You only need to select a handle on one bracket/brace for each bracket and barline change,
as they apply from their signpost until the next existing change or the end of the flow,
whichever comes first.

2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them to the staff above.

●

Press Alt/Opt-Down Arrow to move them to the staff below.

●

Click and drag them upwards/downwards to staves above/below.

RESULT
The selected brackets/braces are lengthened/shortened to staves above/below. This affects the
staves included in the brackets/braces on all systems to which the corresponding bracket and
barline changes apply.

692
Dorico Pro 3.1.10

Brackets and braces
Custom staff grouping
NOTE
Only one bracket/brace can exist on each staff, they cannot overlap. If any part of a selected
bracket/brace collides with another bracket/brace when it is lengthened/shortened, the other
bracket/brace is shortened to accommodate this.
You can undo this action, but the previous length of any shortened brackets/braces is only
restored if you lengthened/shortened brackets/braces using the keyboard.

Resetting bracket and barline changes
You can reset custom changes to bracket/brace grouping and barline joins after a passage with
custom grouping/joins to revert subsequent systems to the project-wide staff grouping settings.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select an item at the rhythmic position where you want to reset staff
grouping.

2.

Choose Engrave > Reset Bracketing.

RESULT
Staff grouping, including both bracket/brace grouping and barline join changes, is reset to the
project-wide staff grouping sections from the selected rhythmic position until the next existing
bracket and barline change or the end of the flow, whichever comes first. A signpost appears at
the rhythmic position of the selected item.
If you selected an item partway through a system, staff grouping is not reset until the start of the
next system.
TIP
You can also reset changes to bracket/brace grouping and barline joins independently of each
other by using the Change bracketing and Change barlines properties in the Bracket and
Barline Changes group of the Properties panel. When they are set to Auto, the corresponding
part of the selected changes is reset.

Deleting bracket and barline changes
You can delete custom changes to bracket/brace grouping and barline joins, for example, if you
change your mind about where you want to reset the bracket/brace grouping.
PROCEDURE
1.

Select the bracket and barline change signposts that you want to delete. You can do this in
Write mode and Engrave mode.

2.

Press Backspace or Delete .

RESULT
The selected bracket and barline changes are deleted. Staff grouping on any corresponding
systems follows either the previous bracket and barline change or the project-wide staff
grouping settings if there is no previous bracket and barline change.
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TIP
●

In Engrave mode, you can also select the brackets/braces you want to delete.

●

You can also delete individual barline joins independently of other barline joins and bracket/
brace grouping changes at the same rhythmic position.

RELATED LINKS
Brackets according to ensemble type on page 685
Deleting barline joins individually on page 644
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Chord symbols describe the vertical harmony of the music at a specific moment. They are
frequently used in jazz and pop music, where players often improvise around chord
progressions.

Chord symbols shown above slashes on the Clarinet and Piano staves to help the players improvise around
the notated Cornet melody.

In Dorico Pro, chord symbols exist globally at their rhythmic position by default. This means that
you must only input chord symbols once, but they can appear above multiple or no staves as
required. However, in some circumstances it is necessary to show different chord symbols for
different players at the same rhythmic position. In such cases, you can input local chord symbols.
You can hide/show chord symbols project-wide above specific instrument staves, including if
multiple instruments belong to the same player, and in different layouts. You can also show
chord symbols only within chord symbol/slash regions and hide/show individual chord symbols.
If you have input chord symbols but no players in the current layout are set to show them, they
are indicated by signposts.
Depending on the style of music, there are different conventions regarding how to present chord
names.
Dorico Pro provides a comprehensive set of chord symbol appearance presets that you can
choose from, including customizing the appearance of each component independently. In
addition to these, you can edit the appearance of different chord symbols, such as Gmaj7, both
for all instances of that chord symbol project-wide and for a single chord symbol.
RELATED LINKS
Input methods for chord symbols on page 247
Chord symbol appearance presets on page 696
Hiding/Showing chord symbols on page 706
Hiding/Showing signposts on page 336
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Chord components
Chord symbols consist of a root and a quality, with intervals, alterations, and an altered bass note
included if required.
Root
The root note of the chord, expressed either as a note name or as a specific degree of a
scale.
Quality
Defines the type of chord, such as major, minor, diminished, augmented, halfdiminished, or with added note, such as six or nine.
Interval
Chord symbols can include one or more added intervals, such as a major seventh or
ninth. Intervals in chord symbols are also known as “extensions”.
Alterations
Define notes in chords that are different to what is normally expected of that chord.
For example, a sharpened fifth, flattened ninth, suspensions, or omissions.
Altered bass note
A chord symbol has an altered bass note if the lowest pitch of a chord is not its root
note, such as Cm7♭5/E♭.

Project-wide engraving options for chord symbols
You can find options for the project-wide appearance and position of chord symbols on the
Chord Symbols page in Engrave > Engraving Options.
The options on the Chord Symbols page allow you to change the appearance of different types
of chords, including the order and arrangement of accidentals and alterations, and their default
positions.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Chord symbol appearance presets
There are many conventions for the appearance of chord symbols, so Dorico Pro provides a
choice of preset conventions that you can use and edit.
For example, you can edit default preset chord symbols, you can edit individual chord symbols
without changing the default appearance for that chord symbol, and you can edit individual
components within chord symbols.
You can find chord symbol presets at the top of the Chord Symbols page in Engraving Options.

Chord symbol preset example

Chord symbol preset name
Default
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Chord symbol preset example

Chord symbol preset name
Boston

Brandt-Roemer

Indiana

New York

Nashville

Jazz Standards

Ross

Japanese

These presets use specific combinations of the options on the Chord Symbols page. You can also
adjust these options individually to suit your requirements.
Default uses a set of symbols intended to be as unambiguous as possible. For example, Default
avoids the use of symbols for major seventh, augmented, diminished, and half-diminished. This
is the default preset for new projects.
Custom is automatically selected when you change any of the preset options on the Chord
Symbols page.
RELATED LINKS
Edit Chord Symbol Appearance dialog on page 700
Edit Chord Symbol Component dialog on page 701
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Project Default Chord Symbol Appearances dialog
The Project Default Chord Symbol Appearances dialog allows you to edit the default
appearance of chord symbols. This changes the appearance of chord symbols project-wide.
●

You can open the Project Default Chord Symbol Appearances dialog by clicking Edit in the
Project Default Appearances section of the Chord Symbols page in Engrave > Engraving
Options.

Project Default Chord Symbol Appearances dialog

The Project Default Chord Symbol Appearances dialog contains the following sections:
1

Enter a chord symbol
Allows you to enter the chord symbol whose default project-wide appearance you want to
edit. Click Add Project Default or press Return to add the chord symbol to the Project
Default Appearances list, which allows you to edit the chord symbol in the editor.

2

Project Default Appearances list
Contains the chord symbols whose project default appearance you have edited in the
project.
You can delete changes to the project default appearance of chord symbols by clicking
Delete in the action bar.

3

Single Overrides list
Contains the chord symbols whose individual appearance you have overridden in the
project.
You can promote your edits to individual chord symbols to be the project default appearance
for that chord symbol by clicking Promote to Project Default in the action bar.
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You can reset single overrides to the project default appearance for that chord symbol by
clicking Remove Overrides in the action bar.

4

Editor
Allows you to arrange and edit the components that make up the chord symbol. You can use
the controls at the bottom of the dialog, and you can also move individual components in
any of the following ways after selecting them in the editor:
●

Press the standard key commands for moving items. For example, press Alt/OptRight Arrow to move components to the right, or press
Ctrl/Cmd-Alt/Opt-Right Arrow to move components to the right by larger increments.

●

Click and drag each component.

NOTE
You cannot move the first component in chord symbols.
In addition to using Scale, you can also change the size of components by clicking and
dragging the square handle in the top right corner after selecting a component in the editor.
5

6

Controls
●

X offset moves components horizontally. Increasing the value moves components to the
right, decreasing the value moves components to the left.

●

Y offset moves components vertically. Increasing the value moves components
upwards, decreasing the value moves components downwards.

●

Scale changes the size of components. Increasing the value increases the size of
components proportionally, decreasing the value decreases the size of components
proportionally.

●

Reset X offset resets the horizontal position of the selected component.

●

Reset Y offset resets the vertical position of the selected component.

●

Reset Scale resets the size of the selected component.

Alternative component presentations
Contains alternative ways of presenting the component selected in the editor.
Allows you to create new components and edit existing components by clicking the
respective button in the action bar.
●

Add Component

●

Edit Component

Clicking either button opens the Edit Chord Symbol Component dialog, in which you can
create new chord symbol components and edit existing chord symbol components.
RELATED LINKS
Chord symbol appearance presets on page 696
Edit Chord Symbol Component dialog on page 701

699
Dorico Pro 3.1.10

Chord symbols
Chord symbol appearance presets

Edit Chord Symbol Appearance dialog
The Edit Chord Symbol Appearance dialog allows you to edit the appearance and arrangement
of individual chord symbols, without changing the project default appearance of that chord
symbol.
●

You can open the Edit Chord Symbol Appearance dialog in Engrave mode by selecting a
chord symbol and pressing Return , or double-clicking a chord symbol.

Edit Chord Symbol Appearance dialog

The Edit Chord Symbol Appearance dialog contains the following sections:
1

Editor
Allows you to arrange and edit the components that make up the chord symbol.
As well as using the controls at the bottom of the dialog, you can move individual
components in any of the following ways after selecting them in the editor:
●

Press the standard key commands for moving items. For example, press Alt/OptRight Arrow to move components to the right, or press
Ctrl/Cmd-Alt/Opt-Right Arrow to move components to the right by larger increments.

●

Click and drag each component.

NOTE
You cannot move the first component in chord symbols.
In addition to using Scale, you can also change the size of components by clicking and
dragging the square handle in the top right corner after selecting a component in the editor.
2

Controls
Allow you to move individual components and change their size. You can also reset their
position and size.
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3

●

X offset moves components horizontally. Increasing the value moves components to the
right, decreasing the value moves components to the left.

●

Y offset moves components vertically. Increasing the value moves components
upwards, decreasing the value moves components downwards.

●

Scale changes the size of components. Increasing the value increases the size of
components proportionally, decreasing the value decreases the size of components
proportionally.

●

Reset X offset resets the horizontal position of the selected component.

●

Reset Y offset resets the vertical position of the selected component.

●

Reset Scale resets the size of the selected component.

Alternative component presentations
You can create new components and edit existing components by clicking the respective
button in the action bar.
●

Add Component

●

Edit Component

Clicking either button opens the Edit Chord Symbol Component dialog, in which you can
create new components and edit existing components.
RELATED LINKS
Chord symbol appearance presets on page 696

Edit Chord Symbol Component dialog
The Edit Chord Symbol Component dialog allows you to create custom components and edit
existing components for both individual chord symbols and for project default chord symbols.
You can open the Edit Chord Symbol Component dialog by clicking either Add Component or
Edit Component in the alternative component presentations action bar in the following dialogs:
●

Project Default Chord Symbol Appearances dialog

●

Edit Chord Symbol Appearance dialog
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Edit Chord Symbol Component dialog

The Edit Chord Symbol Component dialog contains the following sections:
1

Name
Contains an automatically generated name for the chord symbol component. You cannot
change this name.

2

Component selector
Allows you to choose components to add to your chord symbol component. You can add
different types of components by clicking the respective tab titles.
●

Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting different
fonts and different ranges from the menus. Click Add Glyph to add the selected glyph to
the chord symbol component.
NOTE
A full list of the different ranges of glyphs is available on the SMuFL website.

3

●

Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected text, or
input text, to the chord symbol component.

●

Graphic: Allows you to load a new graphics file, or select an existing graphic from the
Select existing list, in SVG, PNG, or JPG format. You can see a preview of the graphic in
the Preview box. Click Add Graphic to add the selected graphic to the chord symbol
component.

●

Composite: Allows you to select a composite from the list. Click Add Composite to add
the selected composite to the chord symbol component.

Editor
Allows you to arrange and edit the components that make up your chord symbol
component. You can arrange and edit components using the controls at the bottom of the
dialog.

4

Editor action bar
Contains selection and view options for the editor.
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5

●

Zoom: Allows you to change the zoom level in the editor.

●

Select: Allows you to select the next/previous component.

●

Delete: Deletes the selected component.

Controls
Contains controls that allow you to edit individual components. Controls are divided into tabs
according to the aspect of the selected component they affect. For chord symbols, only the
Component and Attachments tabs are available as the other tabs do not apply to chord
symbols.
The Component tab contains the following options:
●

Offset: Controls the position of the selected component. X moves it horizontally, Y
moves it vertically.

●

Scale: Controls the size of the selected component. For graphics, X controls its width, Y
controls its height.
NOTE
Although some components scale their height and width independently, others retain
their aspect ratio, meaning only one value affects their overall size.

●

Z order: Allows you to Bring Forward or Send Backward the selected component in
relation to other components when they overlap.

The Attachments tab is only available if the chord symbol component comprises at least
two separate components. It contains the following options:
●

Attachment from: Sets the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend that
you select a right edge attachment point for Attachment from.

●

Attachment to: Sets the attachment point on the selected component which attaches to
the component to its left. We recommend that you select a left edge attachment point
for Attachment to.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.

The attachment points have the following names in the Edit Chord Symbol Component dialog:
1

Top Left

2

Top Center

3

Top Right

4

Middle Left

5

Middle Right

6

Baseline Left (text only)

7

Baseline Center (text only)

8

Baseline Right (text only)
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9

Bottom Left

10 Bottom Center
11 Bottom Right
RELATED LINKS
Chord symbol appearance presets on page 696
Project Default Chord Symbol Appearances dialog on page 698
Edit Chord Symbol Appearance dialog on page 700

Setting single chord symbol overrides as the project default
You can set single overrides you have made to individual chord symbols as the project default
appearance for that chord symbol.
PROCEDURE
1.

Open the Project Default Chord Symbol Appearances dialog.

2.

Select the single override that you want to set as project default in the Single Overrides list.

3.

Click Promote to Project Default.

RESULT
The selected single chord symbol override becomes the default appearance for that chord
symbol.
NOTE
This cannot be undone. If you want to revert your changes, you must delete the chord symbol
from the Project Default Appearances list.

RELATED LINKS
Project Default Chord Symbol Appearances dialog on page 698

Resetting the appearance of chord symbols with single overrides
You can reset the appearance of chord symbols you have overridden individually to the project
default appearance for that chord symbol.
PROCEDURE
1.

Open the Project Default Chord Symbol Appearances dialog.

2.

Select the single override that you want to reset in the Single Overrides list.

3.

Click Remove Overrides.

RESULT
All individual changes to the chord symbol are removed. It now follows the project default
appearance for that chord symbol.
RELATED LINKS
Project Default Chord Symbol Appearances dialog on page 698
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Editing chord symbol fonts
You can edit the formatting of the text fonts used for chord symbols project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2.

Select one of the following fonts from the Font style menu:
●

Chord Symbols Altered Bass Separator Font

●

Chord Symbols Font

●

Chord Symbols Music Text Font
NOTE

3.

4.

●

We recommend that you do not edit Chord Symbols Music Text Font, which is set
to Bravura Text by default. This can only be set to a SMuFL-compliant font intended
for use in text-based applications.

●

When using the option to show the word “on” instead of a slash or line to separate a
chord from its altered bass note, you can edit the font used for that word by editing
Chord Symbols Altered Bass Separator Font.

Activate the following options, individually or together, to change the corresponding aspect
of the font:
●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

Transposing chord symbols
You can transpose chord symbols after you have input them, independently of any notes.
NOTE
Dorico Pro automatically shows the appropriate chord symbols for transposing instruments in
transposing layouts.

PROCEDURE
1.

In Write mode, select the chord symbols you want to transpose.

2.

Choose Write > Transpose to open the Transpose dialog.

3.

Adjust the parameters required for your transposition, such as interval and quality.
TIP

4.

●

We recommend using the Calculate interval section to determine your required
settings, for example, if you want to transpose from G♭ major to G major.

●

Different intervals have different possible qualities. For example, you can specify a major
third but not a major octave. Therefore, if you want to set your transposition parameters
manually, we recommend selecting the interval before the quality.

Click OK to save your changes and close the dialog.

705
Dorico Pro 3.1.10

Chord symbols
Hiding/Showing chord symbols
RESULT
The selected chord symbols are transposed.
RELATED LINKS
Transpose dialog on page 203
Concert vs. transposed pitch on page 138
Making layouts transposing/concert pitch on page 137
Respelling chord symbols on page 712

Hiding/Showing chord symbols
You can hide/show chord symbols above particular staves or only within chord symbol/slash
regions project-wide on a per-player basis. By default, chord symbols appear above rhythm
section instrument staves, such as keyboards, guitars, and bass guitars.
PROCEDURE
1.

In Setup mode, select a player in the Players panel for whom you want to hide/show chord
symbols.

2.

Right-click the player and choose one of the following options from the context menu:
●

To show chord symbols above all instrument staves held by the player, choose Chord
Symbols > Show For All Instruments.

●

To show chord symbols only above rhythm section instrument staves held by the player,
choose Chord Symbols > Show For Rhythm Section Instruments.

●

To show chord symbols only in chord symbol/slash regions on instrument staves held by
the player, choose Chord Symbols > Show in Chord Symbol and Slash Regions.

●

To hide chord symbols above all instrument staves held by the player, choose Chord
Symbols > Hide For All Instruments.

RESULT
Chord symbols are hidden/shown above the corresponding instrument staves held by the
selected player, depending on the layouts in which chord symbols are shown for that player in
your project.
TIP
●

You can choose to show chord symbols between the two staves of grand staff instruments,
such as piano, in the Position section of the Chord Symbols page in Engrave > Engraving
Options.

●

You can also hide/show individual chord symbols in layouts where chord symbols are shown
by selecting them and activating Hidden in the Chord Symbols group of the Properties
panel. Signposts are shown at the position of each hidden chord symbol. However, signposts
are not printed by default.
You can assign a key command for Hide/Show Item on the Key Commands page in
Preferences, which applies to chord symbols, playing techniques, and time signatures.

RELATED LINKS
Chord symbol regions on page 707
Inputting chord symbol regions on page 254
Signposts on page 335
Hiding/Showing chord diagrams on page 716
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Hiding/Showing chord symbols in layouts
You can hide/show chord symbols in different types of layouts. By default, chord symbols appear
in all applicable layouts for rhythm section instruments.
NOTE
If chord symbols are hidden for all instruments in the current layout, signposts are shown above
the top staff.

PROCEDURE
1.

In Setup mode, select a player in the Players panel.

2.

Right-click the player and choose one of the following options from the context menu:
●

To show chord symbols for the selected player in all layouts, choose Chord Symbols >
Show in Full Score and Parts.

●

To show chord symbols for the selected player only in full score/custom score layouts
and not in part layouts, choose Chord Symbols > Show in Full Score Only.

●

To show chord symbols for the selected player only in part layouts and not in full score/
custom score layouts, choose Chord Symbols > Show in Parts Only

Hiding/Showing the root and quality of chord symbols
You can hide the root and quality of chord symbols if they follow another chord symbol with the
same root and quality, but have a different altered bass note.
PROCEDURE
1.

Select the chord symbols whose root and quality you want to hide. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Hide root and quality in the Chord Symbols group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
The root and quality of the selected chord symbols are hidden when the checkbox is activated,
and shown when the checkbox is deactivated.
When the property is deactivated, chord symbols follow your project-wide setting.
TIP
You can choose to show the root and quality of chord symbols always, even if successive chord
symbols have the same root and quality, in the Altered Bass Notes section of the Chord
Symbols page in Engrave > Engraving Options.

Chord symbol regions
Chord symbol regions specify passages where you want to show chord symbols. They are
particularly useful for players and layouts that do not need chord symbols for most of the project
but have improvisation sections that require chord symbols to be shown.
Chord symbol regions allow you to show chord symbols only where players require them, instead
of showing chord symbols throughout the project and manually hiding the ones you do not want
to show.
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When you input chord symbol regions in Dorico Pro, the corresponding players are automatically
set to show chord symbols in chord symbol/slash regions. This is because it is common to use
both slashes and chord symbols to aid players in improvisation sections. Any chord symbols
outside chord symbol/slash regions are automatically hidden and are indicated by signposts.
By default, chord symbol regions are highlighted with a solid colored line above the top staff line
and a colored background. As you zoom out, the colored backgrounds become more opaque,
which is especially useful when viewing full score layouts in galley view. These highlights are
considered annotations, are not printed by default, and you can hide and show them.

Chord symbol region followed by chord symbol signposts after the end of the chord symbol region

In Write mode, each region has a handle at the start and end, which you can use to move and
lengthen/shorten regions.

Handles on a selected chord symbol region

RELATED LINKS
Inputting chord symbol regions on page 254
Hiding/Showing chord symbols on page 706
Slash regions on page 1095
Hiding/Showing signposts on page 336
Annotations on page 610

Moving chord symbol regions
You can move chord symbol regions to different rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the chord symbol regions you want to move.
NOTE
When using the mouse, you can only move one chord symbol region at a time.

2.

Move the chord symbol regions to the right/left in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the chord symbol region to the right/left.
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RESULT
The selected chord symbol regions are moved to new rhythmic positions according to the current
rhythmic grid resolution.
NOTE
Only one chord symbol region can exist at each rhythmic position. If any part of a selected chord
symbol region collides with any part of another chord symbol region as part of its move, the
other chord symbol region is shortened to accommodate the one you moved.
You can undo this action and restore the previous length of the other chord symbol region.
However, if you moved a chord symbol region using the mouse and it overwrote another chord
symbol region completely, the other chord symbol region is permanently deleted.

Lengthening/Shortening chord symbol regions
You can lengthen/shorten chord symbol regions after they have been input.
PROCEDURE
1.

In Write mode, select the chord symbol regions you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one chord symbol region at a time.

2.

Lengthen/Shorten the chord symbol regions in any of the following ways:
●

To lengthen them by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten them by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .
NOTE
Key commands lengthen/shorten items by moving their end only.

●

Click and drag the circular handle at the start/end to the right/left.

RESULT
The selected chord symbol regions are lengthened/shortened.
NOTE
Only one chord symbol region can exist at each rhythmic position. If any part of a selected chord
symbol region collides with any part of another chord symbol region when it is lengthened/
shortened, the other chord symbol region is shortened to accommodate this.
You can undo this action and restore the previous length of the other chord symbol region.
However, if you lengthened/shortened a chord symbol region using the mouse and it overwrote
another chord symbol region completely, the other chord symbol region is permanently deleted.
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Hiding/Showing chord symbol region highlights
You can hide/show colored highlights for chord symbol regions at any time, for example, if you
want to show the highlights when inputting music but hide them when engraving.
NOTE
This does not affect the solid line shown above the staff in chord symbol regions, which you
cannot hide.

PROCEDURE
●

Choose View > Highlight Chord Symbol Regions.

RESULT
Highlights in chord symbol regions are shown when a tick appears beside Highlight Chord
Symbol Regions in the menu, and hidden when no tick appears.

Positions of chord symbols
By default, chord symbols are centered horizontally on the middle of the front notehead in the
first voice column, at the rhythmic position to which they are attached.
NOTE
The front notehead is the notehead on the correct side of the stem at that rhythmic position.
Their vertical position in full scores is determined by the staves above which they are set to
appear and any chord symbol regions you have input. This also affects in which part layouts
chord symbols appear.

Alignment of chord symbols relative to notes and chords
You can change whether chord symbol text is left-aligned above the notehead, center-aligned
above the notehead, or right-aligned above the notehead, although right-aligned typically
produces unclear results.
You can change the horizontal alignment of chord symbols by choosing an option for Horizontal
alignment relative to note, chord or rest in the Position section of the Chord Symbols page in
Engraving Options.
You can also override this for an individually selected chord symbol by activating Alignment in
the Chord Symbols group of the Properties panel and selecting an option from the menu.

Alignment of chord symbols across the system
Chord symbols are aligned at the same vertical position across the width of the system by
default. You can deactivate Align chord symbols across width of system in the Position section
of the Chord Symbols page in Engraving Options if you want each chord symbol to be
positioned above the staff independently.
RELATED LINKS
Project-wide engraving options for chord symbols on page 696
Chord symbol regions on page 707
Hiding/Showing chord symbols on page 706
Hiding/Showing chord symbols in layouts on page 707
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Moving chord symbols rhythmically
You can move chord symbols to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the chord symbols you want to move.
NOTE
When using the mouse, you can only move one chord symbol rhythmically at a time.

2.

Move the chord symbols according to the current rhythmic grid resolution in any of the
following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the chord symbol to the right/left.

RESULT
The selected chord symbols are moved to new rhythmic positions.
NOTE
Only one chord symbol can exist at each rhythmic position. If a chord symbol passes over
another chord symbol as part of its move, the existing chord symbol is deleted.
You can undo this action, but any chord symbols deleted in the process are only restored if you
moved the chord symbol using the keyboard.

Moving chord symbols graphically
You can move chord symbols graphically without affecting the rhythmic positions to which they
apply.
PROCEDURE
1.

In Engrave mode, select the chord symbols you want to move.

2.

Move the chord symbols in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected chord symbols are moved graphically, without affecting the rhythmic positions to
which they are attached.
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TIP
Start offset in the Chord Symbols group of the Properties panel is activated automatically when
you move chord symbols.
●

Start offset X moves chord symbols horizontally.

●

Start offset Y moves chord symbols vertically.

You can also use this property to move chord symbols graphically by changing the values in the
value fields.
Deactivating the property resets the selected chord symbols to their default positions.

Respelling chord symbols
You can change the enharmonic spelling of chord symbols for transposing instruments, for
example, to choose a simpler enharmonic equivalent spelling. This changes the enharmonic
spelling of chord symbols in all transposing layouts and for all instruments with the same
transposition.
PROCEDURE
1.

In Write mode, open a layout with the transposition for which you want to respell chord
symbols.
For example, to respell a chord symbol for all instruments in B♭, open the part layout for an
instrument in B♭.

2.

Select the chord symbol you want to respell.

3.

Press Return to open the chord symbols popover for the selected chord symbol.
The existing entry for the chord symbol is shown inside the popover.

4.

Change the root name of the chord, but leave other details as they were, such as quality,
interval, or alterations.
For example, change just the root of D♭maj13 from Db to C#.

RESULT
The spelling of the chord symbol is changed in transposing layouts for all instruments with the
same transposition. For example, changing the spelling of a chord symbol for a Clarinet in B♭ also
changes the spelling of that chord symbol in the part layout for a Trumpet in B♭.
RELATED LINKS
Chord symbols popover on page 247
Transposing chord symbols on page 705
Concert vs. transposed pitch on page 138
Making layouts transposing/concert pitch on page 137

Showing chord symbols as modes
You can show individual chord symbols as their modal equivalent if one exists for that chord
symbol.
PROCEDURE
1.

Select the chord symbols you want to show as a mode. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Show as mode in the Chord Symbols group.
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3.

Select the mode you want from the menu.

RESULT
The selected chord symbols are respelled according to the selected mode. This does not affect
the notes included in the chord symbols.

Resetting the enharmonic spelling of chord symbols
You can remove enharmonic spelling overrides for chord symbols you have respelled and return
them to their default spelling. You can remove overrides for instruments with a single
transposition only, such as instruments in B♭, or for all instrument transpositions.
PROCEDURE
1.

2.

In Write mode, select the chord symbol whose spelling you want to reset.
●

If you want to reset the enharmonic spelling of the chord symbol for a single instrument
transposition only, select the chord symbol on a staff belonging to an instrument with
that transposition. For example, select it on the staff of any instrument in B♭ to reset the
chord symbol for all instruments in B♭.

●

If you want to reset the enharmonic spelling of the chord symbol for all instrument
transpositions, select the chord symbol on any staff that belongs to a transposing
instrument.

Press Return to open the chord symbols popover for the selected chord symbol.
The existing entry for the chord symbol is shown inside the popover.

3.

Reset the enharmonic spelling of the chord symbol in any of the following ways:
●

To reset the enharmonic spelling of the chord symbol for instruments only with the
selected transposition, enter Alt/Opt-S into the chord symbols popover.

●

To reset the enharmonic spelling of the chord symbol for all instrument transpositions,
enter Shift-Alt/Opt-S into the popover.

RESULT
The enharmonic spelling of the selected chord symbol in transposing layouts is reset, either just
for instruments with the specified transposition or for all transposing instruments.

Chord symbols imported from MusicXML
Chord symbols are imported from MusicXML files. However, chords that specify Neapolitan,
Italian, French, German, Pedal, Tristan, and Other values for the kind of element are ignored
during import, as there is no information to specify what notes these chord symbols are meant
to describe.
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Chord diagrams represent the pattern of strings and frets on fretted instruments and use dots to
indicate the stopped finger positions required to produce the corresponding chord. This
demonstrates the specific shape of chords in a compact way and is useful if a particular voicing is
required.
In Dorico Pro, chord diagrams are part of chord symbols, meaning you can show them below
chord symbols wherever they are shown. You can show chord diagram shapes for any fretted
instrument, including different tunings and string arrangements, such as guitar DADGAD tuning.
This can be different to the instrument above which they appear, for example, if you want to
show chord diagram shapes for standard guitar tuning above the bass staff.

A sequence of chord symbols with chord diagrams for banjo

The positions of stopped frets relative to each other are known as “shapes” in Dorico Pro. Any
playable shape can be re-used for other chords whose pitches match the shape, including any
new chord diagram shapes you have created. This includes shapes being available for other
instruments, other tunings, and other positions along the fretboard, so long as any open strings
included in the shape can be played with a barré at other fret positions.
A single chord can appear with different chord diagram shapes for different instruments and
tunings, as their open string pitches and the number of strings they have varies.
RELATED LINKS
Hiding/Showing chord diagrams on page 716

Chord diagram components
Chord diagrams use a combination of symbols, dots, and lines to convey the information about
strings, fret positions, and finger positions that performers require to play the corresponding
chord.
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1

Omitted string
Indicates a string that must not sound.

2

Open string
Indicates a string that must sound but must be left open, that is, not stopped.

3

Dots
Indicate the fret positions where strings should be stopped, usually with left-hand fingers.

4

Barré
Indicates that multiple strings must be stopped with the same finger, usually pressed flat
against the fretboard.

5

Starting fret number
Indicates the number of the highest fret in the chord diagram when this is not the first fret.

6

Nut
Represents the top of the fretboard, or “nut”, and appears in chord diagrams whose highest
fret is the first fret.

RELATED LINKS
Changing the chord diagram shape on page 717

Project-wide engraving options for chord diagrams
You can find options for the project-wide appearance and position of chord diagrams on the
Chord Diagrams page in Engrave > Engraving Options.
The options on the Chord Diagrams page in Engraving Options allow you to change the default
number of frets shown in chord diagrams, the scale factor of chord diagrams relative to chord
symbols, and the precise dimensions of each aspect within chord diagrams, including the
thickness of strings and lines and size of dots. You can also change the appearance and position
of fret numbers, such as showing them as Roman numerals.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
RELATED LINKS
Engraving Options dialog on page 359
Changing the horizontal position of starting fret numbers on page 724
Changing the orientation of chord diagrams on page 724

Project-wide note input options for chord diagrams
You can find options for the project-wide handling of chord diagrams and different components
within chord diagrams on the Chord Diagrams page in Write > Note Input Options.
The options on the Chord Diagrams page include whether or not to include the root note in
chord diagrams, as it can be useful to omit root notes in chord diagrams for the guitarist in
ensembles with a bass player, and whether or not to include particular scale degrees depending
on the chord symbol, such as omitting the fifth in dominant seventh chords.
RELATED LINKS
Note Input Options dialog on page 162
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Hiding/Showing chord diagrams
You can hide/show chord diagrams for any type of fretted instrument alongside chord symbols.
You can also change the fretted instrument or tuning for which chord diagrams are shown.
However, you cannot show chord diagrams when chord symbols are hidden.
PREREQUISITE
●

You have input the chord symbols for which you want to show chord diagrams.

●

Chord symbols are shown above the staves where you want to show chord diagrams.

PROCEDURE
1.

In Setup mode, select a player in the Players panel for whom you want to hide/show chord
diagrams.

2.

Right-click the player and choose one of the following options from the context menu:
●

To show chord diagrams, choose Chord Diagrams > [Fretted instrument and tuning].
For example, to show chord diagrams for a guitar in DADGAD tuning, choose Chord
Diagrams > DADGAD guitar tuning.

●

To hide chord diagrams, choose Chord Diagrams > No Chord Diagrams.

RESULT
Chord diagrams are shown alongside all chord symbols for the selected player, as appropriate
for the selected fretted instrument and tuning. Dorico Pro shows the simplest diagram available
for each chord, that is, shapes with the most open strings and finger positions closest to the nut.
If no chord diagram is available for a chord symbol, an empty chord diagram is shown.
TIP
You can edit empty chord diagrams to save a new chord diagram shape.
EXAMPLE

Chord symbols shown but chord diagrams hidden

RELATED LINKS
Inputting chord symbols on page 251
Hiding/Showing chord symbols on page 706
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Changing the chord diagram shape
You can change the chord diagram shape shown at individual rhythmic positions, for example, if
you require a shape with a different voicing. Many chords have multiple playable shapes.
You can also apply your changes to all other instances of the same chord for instruments with
compatible tunings.
PROCEDURE
1.

Select the chord diagram whose shape you want to change. You can do this in Write mode
and Engrave mode.
NOTE
You can only change the shape of a single chord diagram at a time.

2.

3.

Change the shape in any of the following ways:
●

To cycle through all the available shapes for the selected chord, press Alt/Opt-Q .

●

To open the Choose Chord Diagram dialog and see all the available shapes for the
selected chord at once, press Shift-Alt/Opt-Q .

Optional: In the Choose Chord Diagram dialog, select the shape you want to use.
TIP
If the shape you require is not available, you can click Edit, which allows you to create a new
shape.

4.

Click OK to save your changes and close the dialog.

5.

Optional: To apply the new shape to other instances of the same chord for instruments with
compatible tunings, choose Edit > Chord Diagrams > Copy Shape to Matching Chord
Symbols.

RESULT
The shape shown for the selected chord diagram is changed. This also updates all other chord
diagrams using the same fretted instrument tuning at the same rhythmic position.

Choose Chord Diagram dialog
The Choose Chord Diagram dialog allows you to view all available chord diagram shapes for the
selected chord and select the one you want to use.
●

You can open the Choose Chord Diagram dialog in Write mode by selecting a chord
diagram and pressing Shift-Alt/Opt-Q .
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Choose Chord Diagram dialog

The Choose Chord Diagram dialog comprises the following:
1

Available chord diagrams
Displays all the valid chord diagram shapes for the selected chord and allows you to select a
different shape to show at the selected rhythmic position. Shapes you have created yourself
appear in a different color.

2

Edit
Opens the Edit Chord Diagram dialog, which allows you to edit the shape of chord
diagrams, including changing the number of frets shown, stopped fret positions, and the
starting fret number.

Creating new chord diagram shapes
You can create new chord diagram shapes by editing an existing one, for example, if you want an
alternative voicing for a chord or to show a barré. Your changes to existing chord diagram
shapes are saved as a new shape, they do not overwrite the existing one.
TIP
If you want to define multiple new chord shapes at once or start a new shape from scratch, you
can do so in the Edit Chord Diagrams dialog.

PROCEDURE
1.

In Engrave mode, double-click the chord diagram whose shape you want to edit to open the
Edit Chord Diagram dialog.

2.

Edit the shape and settings of the chord diagram as required.
For example, you can change open strings to omitted strings or change the stopped fret
position on strings to change the corresponding string pitch.

3.

Optional: If you want the shape to be available for chords with different start fret positions,
activate Chord may be moved along the neck.

4.

Click Save, then Close.
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RESULT
The new shape is saved and is used for the selected chord diagram. The new shape also becomes
available for any other chord for which it is valid.

Edit Chord Diagram dialog
The Edit Chord Diagram dialog allows you to edit the shape of individual chord diagrams,
including changing the number of frets shown, stopped fret positions, and the starting fret
number.
You can open the Edit Chord Diagram dialog in any of the following ways:
●

In Write mode by opening the Choose Chord Diagram dialog, selecting the chord diagram
whose shape you want to edit, and clicking Edit.

●

In Engrave mode by double-clicking a chord diagram, or selecting it and pressing Return .

Edit Chord Diagram dialog

The Edit Chord Diagram dialog contains the following options and sections:
1

Name
Displays the name of the chord whose chord diagram you are editing in the dialog. You
cannot change this name.

2

Tuning
Displays the fretted instrument and tuning for the current chord diagram.

3

Chord may be moved along the neck
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Allows you to specify whether or not the shape of the chord diagram can be reused at other
fret positions, for example, by playing open strings with a barré at higher fret positions.
4

Notes not in chord diagram
Displays any pitches that are part of the chord but not currently included in the chord
diagram.

5

Open string pitch
Displays the open pitch of the corresponding string for reference.

6

Current string pitch
Displays the current pitch of the corresponding string if it is open or stopped. If the pitch of a
string is not part of the chord, the string pitch appears red.

7

String status
Displays the current usage status of the corresponding string and allows you to switch the
status of individual strings between open and omitted by clicking in this row.

8

●

O: Open string

●

X: Omitted string

●

No symbol: Stopped string

Chord diagram shape editor
Displays the current arrangement of stopped frets using dots, and allows you to change the
chord diagram shape and move the stopped fret positions by clicking at the required
positions. Each string can only have a single stopped fret position.
If two or more strings are stopped at the same fret, you can hide/show a barré by clicking
any of the dots at that fret position.

9

Action bar
Contains options that allow you to edit and change the number of frets.
●

Starting fret: Changes the fret number of the highest fret in the chord diagram.

●

Starting fret number offset: Changes the offset of the starting fret number, for
example, if you want the starting fret label to appear beside the second fret down the
chord diagram in order to include a barré.

●

Add fret: Adds a fret to the bottom of the chord diagram.

●

Remove fret: Removes a fret from the bottom of the chord diagram.

●

Reset Chord Diagram: Removes your changes to the chord diagram and resets it to its
default shape.

10 Save
Saves the chord diagram shape and updates the selected chord diagram in the music area.
The shape also becomes available as an alternative shape for other compatible chords.
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Edit Chord Diagrams dialog
The Edit Chord Diagrams dialog allows you to design your own chord diagram shapes, either by
creating a new blank one or by editing any of the available chord diagram shapes.
NOTE
When you edit an existing chord diagram, Dorico Pro saves a duplicate of it with your changes.
The original chord diagram is always retained.
●

You can open the Edit Chord Diagrams dialog in Engrave mode by choosing Engrave >
Chord Diagrams.

Edit Chord Diagrams dialog

The Edit Chord Diagrams dialog contains the following options and sections:
1

Category menu
Allows you to select which shapes are available in the chord diagram shapes list by selecting
the number of instrument strings required.

2

Search field
Allows you to filter the chord diagrams according to your entry.

3

Chord diagram shapes list
Contains all the available chord diagram shapes within the currently selected category and
your search filter, if applicable.
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NOTE
Shapes appear in the chord diagram shapes list with the name of their simplest usage or
their closest position to the nut. Movable chord diagram shapes that can produce many
different chords only appear once. For example, replacing the open strings in the E, open
position shape with a barré and moving the shape up the neck can produce multiple major
chords. Therefore, chords that use the same shape but at different fret positions, such as F,
open position, do not appear in the list.
The action bar at the bottom of the list contains the following options:
●

New: Adds a new blank chord diagram.

●

Save as Default: Saves the currently selected chord diagram shape as a default in your
user library, allowing you to use it in multiple projects. For chord diagram shapes saved
as default, the icon appears filled in. Clicking Save as Default again removes it from
your user library.

●

Delete: Deletes the selected chord diagram shape.

NOTE
You cannot delete predefined chord diagram shapes. You must click Delete twice to
delete your own chord diagram shapes that you have saved as default.
4

Name
Displays the name of the chord whose chord diagram you are editing in the dialog.
Optionally includes other relevant identifying information, such as “movable” or “open-g”.
You cannot change the name of predefined chord diagrams and chord diagrams that you
have saved as default.

5

Tuning
Displays the fretted instrument and tuning for the current chord diagram. You can select
other tunings to see what chords the current shape produces in different tunings and on
different instruments. The open and current string pitches update when you select other
tunings.

6

Chord may be moved along the neck
Allows you to specify whether or not the shape of the chord diagram can be reused at other
fret positions, for example, by playing open strings with a barré at higher fret positions.
Because it is not normally possible to reuse chord diagram shapes that have more than
three stopped strings at other fret positions, Dorico Pro shows a warning icon when this
option is activated for chord symbols with four or more stopped strings.

Warning icon

7

Open string pitch
Displays the open pitch of the corresponding string according to the currently selected
tuning for reference.

8

Current string pitch
Displays the current pitch of the corresponding string if it is open or stopped, according to
the currently selected tuning. If the pitch of a string is not part of the chord, the string pitch
appears red.
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9

String status
Displays the current usage status of the corresponding string and allows you to switch the
status of individual strings between open and omitted by clicking in this row.
●

O: Open string

●

X: Omitted string

●

No symbol: Stopped string

10 Chord diagram shape editor
Displays the current arrangement of stopped frets using dots, and allows you to change the
chord diagram shape and move the stopped fret positions by clicking at the required
positions. Each string can only have a single stopped fret position.
If two or more strings are stopped at the same fret, you can hide/show a barré by clicking
any of the dots at that fret position.
11 Action bar
Contains options that allow you to edit and change the number of frets.
●

Starting fret: Changes the fret number of the highest fret in the chord diagram.

●

Starting fret number offset: Changes the offset of the starting fret number, for
example, if you want the starting fret label to appear beside the second fret down the
chord diagram in order to include a barré.

●

Add fret: Adds a fret to the bottom of the chord diagram.

●

Remove fret: Removes a fret from the bottom of the chord diagram.

●

Reset Chord Diagram: Removes your changes to the chord diagram and resets it to its
default shape.

12 OK
When you click OK, all your changes in the dialog are saved.

Editing the chord diagram font style
You can edit the formatting of the text font used for fret numbers in chord diagrams projectwide. For example, if you want to make fret numbers in chord diagrams appear larger, you can
increase the font size.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2.

Select Chord Diagram Fret Number Font from the Font style menu.

3.

Activate the following options, individually or together, to change the corresponding aspect
of the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.
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RESULT
The formatting of the font used for all fret numbers in chord diagrams in your project is
changed.

Changing the horizontal position of starting fret numbers
You can choose whether all starting fret numbers in chord diagrams appear on the right or left of
the diagram. By default, starting fret numbers appear on the right.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Chord Diagrams in the page list.

3.

In the Fret Numbers section, choose one of the following options for Horizontal position:

4.

●

Left

●

Right

Click Apply, then Close.

RESULT
The position of starting fret numbers relative to chord diagrams is changed project-wide.
TIP
There are other options on the Chord Diagrams page to control the appearance and exact
position of fret numbers.

Changing the orientation of chord diagrams
You can change the default orientation of all chord diagrams project-wide, for example, if you
want them to appear horizontal for educational purposes. By default, chord diagrams appear
vertical.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Chord Diagrams in the page list.

3.

In the Design section, choose one of the following options for Orientation:

4.

●

Vertical

●

Horizontal

Click Apply, then Close.

RESULT
The orientation of all chord diagrams project-wide is changed.
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Clefs are the symbol at the start of every system that give the notes on the staff context; that is,
the clef tells you which note of the scale applies to each line or space of the staff.
For example, the treble clef is also known as a “G clef”, because the spiral shape in the middle
centers around G, normally the one above middle C.

The other common clefs are:
●

The bass clef, or F clef, in which two dots are shown either side of the line corresponding to
F, normally the F below middle C.
Middle C uses one ledger line below staves with treble clefs, and one ledger line above
staves with bass clefs.

●

The C clef, in which the center of the bracket to the right of the clef’s thick vertical line is
positioned on the line that corresponds to C, normally middle C.

The C clef today is commonly used at two positions on the staff:
●

On the middle line of the staff, commonly called the alto clef.

●

On the line above the middle line of the staff, commonly called the tenor clef.

To minimize the number of ledger lines required, these clefs are used to match the register of
the instrument for which they are used.

The E below middle C
shown in a treble clef

The E below middle C
shown in a bass clef

The E below middle C
shown in a C (alto) clef

The E below middle C
shown in a C (tenor) clef

In Dorico Pro, clefs and octave lines are both contained in the Clefs panel on the right of the
window. Three sections of the panel apply to clefs:
●

Common Clefs, including treble clef, bass clef, alto clef, tenor clef, tab, and percussion.

●

Uncommon Clefs, including Indian drum clef, French violin clef, treble clef octave above,
treble clef octave below, and so on.

●

Archaic Clefs, including baritone bass clef, mezzo-soprano clef, and soprano clef, which are
not commonly used any more.

RELATED LINKS
Input methods for clefs and octave lines on page 254
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General placement conventions for clefs
Clefs are placed at the start of every system, with a small gap between the start of the staff and
the left edge of the clef. Their vertical placement must be precise, as this signifies which pitches
are intended by the subsequent notes on the staff.
Clef changes that occur during a piece are usually smaller than the clefs shown at the start of
each system. If clef changes occur at the start of a new system or page, a cautionary clef is
shown at the end of the previous system to ensure the performer notices the change of clef.
Wherever possible, clef changes should not be positioned in the middle of tie chains. Changing
the clef changes the position of the tied note on the staff, which could easily cause a performer
to misread the tie as a slur and play two different notes. You can input clef changes in the middle
of tie chains in Dorico Pro, but we recommend that you position clef changes either before or
after tie chains.
RELATED LINKS
Ties on page 1219

Project-wide spacing gaps for clefs
You can change the minimum gaps between objects, including clefs, on the Spacing Gaps page
in Engrave > Engraving Options.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
The following minimum values directly relate to clefs:
●

Gap after barline before clef, key or time signature

●

Gap after initial clef

●

Gap to the left of clef, cancellation naturals or grace notes before note or barline

●

Gap after clef change

Other values may have an effect on the position of clefs, but they also affect other objects.
RELATED LINKS
Engraving Options dialog on page 359

Moving clefs rhythmically
You can move clefs to new rhythmic positions after they have been input.
TIP
You can change the default positions of clefs relative to notes or barlines by changing the
project-wide values for spacing gaps on the Spacing Gaps page in Engrave > Engraving
Options.

PROCEDURE
1.

In Write mode, select the clefs you want to move.
NOTE
●

You cannot select an initial clef at the start of the flow or clefs shown automatically at
the start of each system.
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●
2.

When using the mouse, you can only move one clef rhythmically at a time.

Move the clefs according to the current rhythmic grid resolution in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the clef to the right/left.

RESULT
The selected clefs are moved to new rhythmic positions. They take effect from their new
positions until the next clef, or the end of the flow, whichever comes first.
NOTE
●

You can only move clefs along staves. If you want to move a clef across staves, you must
delete the clef and input a new clef on the other staff.

●

Only one clef can exist at each rhythmic position, except for clefs that only apply to single
staves. If a clef passes over another clef as part of its move, the existing clef is deleted.
You can undo this action, but any clefs deleted in the process are only restored if you moved
the clef using the keyboard.

Moving clefs graphically
You can move individual clefs graphically without affecting the positions of any other items.
PROCEDURE
1.

In the Engrave toolbox, activate Note Spacing.

2.

Select the square handle above the clef you want to move.

A circular handle appears beside the clef.
3.

Press Tab to select the circular handle.

4.

Move the handle in any of the following ways:
●

Press Alt/Opt-Right Arrow to move it to the right.

●

Press Alt/Opt-Left Arrow to move it to the left.
NOTE
●

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

You cannot move note spacing handles with the mouse, you can only move them
using the keyboard.
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RESULT
The clef is moved graphically to the right/left, without affecting other items at the same rhythmic
position.
TIP
You can also change Spacing offset in the Clefs group of the Properties panel to move clefs
horizontally. However, this also affects global note spacing around the rhythmic position of the
clef.
The Spacing offset property in the Clefs group of the Properties panel is not available when
Note Spacing is activated.

RELATED LINKS
Note spacing on page 425

Deleting clefs
You can delete clefs without affecting the pitches of notes. Notes are automatically respelled
according to the previous clef on the staff.
NOTE
You cannot delete an initial clef at the start of the flow or clefs shown automatically at the start of
each system. If you do not want any clef to appear on a staff, you can input an invisible clef.

PROCEDURE
1.

In Write mode, select the clefs or signposts of clefs you want to delete.

2.

Press Backspace or Delete .

RESULT
The selected clefs are deleted. Any music on the staff is respelled according to the previous clef,
up until the next existing clef or the end of the flow.
RELATED LINKS
Input methods for clefs and octave lines on page 254

Default size of clef changes
You can change the default scale factor of all clef changes project-wide.
The default Clef change scale factor is 2/3. You can change the default clef change size on the
Clefs page in Engrave > Engraving Options.
Increasing the scale factor makes clef changes appear larger, decreasing the scale factor makes
clef changes appear smaller. This does not affect the size of clefs at the start of each system.
The smallest scale factor that you can input is 1/8. There is no maximum limit. However, for
example, a scale factor of more than 30 causes a single clef to take up most of an A4 page, which
is rarely beneficial.
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Showing clefs after grace notes
According to convention, clefs are positioned before grace notes so this is the default in Dorico
Pro. However, in some circumstances you might want to position clefs between grace notes and
normal notes.
PROCEDURE
1.

Select the clefs you want to show after grace notes. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Clef Position > After Grace Notes. You can also choose this option from the
context menu.

RESULT
The selected clefs are positioned between normal notes and grace notes.
NOTE
You can reset the position of clefs relative to grace notes by selecting the clefs whose position
you want to reset and choosing Edit > Clef Position > Reset Clef Position. You can also choose
this option from the context menu.
EXAMPLE

Treble clef before grace notes

Treble clef after grace notes to align with bass clef

RELATED LINKS
General placement conventions for clefs on page 726

Setting different clefs for concert/transposed pitch
You can set clef changes to show a different clef in concert pitch layouts compared to transposed
pitch layouts. For example, if you want a clef change on a Bass Clarinet staff to appear as a treble
clef in the part layout but as a bass clef in the full score layout.
NOTE
●

These steps only apply to clefs you have input, as you cannot select initial clefs or the clefs
shown automatically at the start of each system.

●

Many instruments in Dorico Pro show different clefs in full score/custom score and part
layouts by default. You can select the appropriate instrument type from the instrument
picker when adding or changing instruments.
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PROCEDURE
1.

Select the clefs whose concert/transposed pitch versions you want to change. You can do
this in Write mode and Engrave mode.

2.

Choose one of the following options:
●

To change the concert pitch version of the selected clefs, choose Edit > Clef > Concert
Pitch > [Clef].

●

To change the transposed pitch version of the selected clefs, choose Edit > Clef >
Transposed Pitch > [Clef].
TIP
You can also choose these options from the context menu.

RESULT
The clefs shown at the selected clef changes in layouts of the corresponding transposition are
changed up to the next existing clef change or the end of the flow, whichever comes first.
AFTER COMPLETING THIS TASK
If you want to show the clefs in some layouts but hide them in others, you can hide/show clefs in
layouts according to the layout transposition.
RELATED LINKS
Adding instruments to players on page 116
Changing instruments on page 118
Instrument picker on page 97

Hiding/Showing clefs according to layout transpositions
You can show individual clefs only in layouts that are either concert or transposed pitch. For
example, due to their transpositions, some instruments require clef changes in concert pitch
scores to avoid excess ledger lines, but do not require those clef changes in their transposed
pitch parts.
By default, all clefs appear in all layouts.
PROCEDURE
1.

Select the clefs or signposts of clefs you want to hide/show according to the layout
transposition. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Show for transposition in the Clefs group.

3.

Choose one of the following options:
●

Concert Pitch

●

Transposing Pitch

RESULT
The selected clefs only appear in layouts with the corresponding transposition. In layouts where
clefs are hidden, they are indicated by signposts.
Hidden clefs have no effect on note and staff spacing.
RELATED LINKS
Making layouts transposing/concert pitch on page 137
Signposts on page 335
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Transposing clefs
Transposing clefs indicate that notes are played in a different register to the one notated. A
number above the clef indicates that notes are played higher than notated, while a number
below the clef indicates that notes are played lower than notated.
Of these clefs, only the treble clef 8 below is still commonly used for tenor vocal parts.

RELATED LINKS
Transposing instruments on page 115
Concert vs. transposed pitch on page 138
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Octave lines indicate where notes are played higher/lower than they appear in the score or part.
Octave lines are dashed or dotted horizontal lines with an italic numeral at the start. The numeral
indicates the number of pitches by which the phrase is changed, such as 8 for one octave and 15
for two octaves.
Octave lines that indicate notes are played higher than notated are placed above the staff, while
octave lines that indicate notes are played lower than notated are placed below the staff.

A treble clef phrase notated at
pitch

The treble clef phrase with an
octave above line

A bass clef phrase notated at pitch The bass clef phrase with an
octave below line

The treble clef phrase with a two
octaves above line

The bass clef phrase with a two
octaves below line

In Dorico Pro, pitches are adjusted automatically when an octave line is present. You do not have
to change the register of the notes within the line.
You can use octave lines across a few notes, a single phrase, or multiple phrases, but they must
not confuse the contour of the music. If used excessively and for inappropriate sections, octave
lines can mask the shape of the original melody. However, careful usage of octave lines can make
music easier to read quickly as the performer has fewer ledger lines to count.

An angular phrase with no octave
lines

The same phrase with many
octave lines, which distort the
overall shape of the phrase.

The same phrase with just two
octave lines to reduce ledger lines.
They do not change the overall
shape of the phrase.

It is generally best to use a different clef for a whole phrase if appropriate for that instrument, or
to input an octave line for the whole phrase in order to ensure the shape and register are clear to
the performer.
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Octave lines should be horizontal, meaning they can take up significant vertical space, as octave
lines are usually placed outside all other notations. However, they can be placed within slurs and
tuplet brackets if the slur or tuplet bracket is longer than the octave line.
Octave lines can continue across system and page breaks. It is customary to show the numeral
again at the start of each system as a reminder. Cautionary octave line numerals are usually
parenthesized and the suffix is optional.
RELATED LINKS
Input methods for clefs and octave lines on page 254
Lines on page 1033

Project-wide engraving options for octave lines
You can find options for the project-wide appearance of octave lines on the Octave Lines page in
Engrave > Engraving Options.
The options on this page allow you to change the appearance of continuation lines, continuation
labels, the numeral at the start of octave lines, the position of octave lines relative to accidentals
and noteheads, and their staff-relative placement.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Lengthening/Shortening octave lines
You can lengthen/shorten octave lines after they have been input.
PROCEDURE
1.

In Write mode, select the octave lines you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one octave line at a time.

2.

Lengthen/Shorten the selected octave lines in any of the following ways:
●

To lengthen them by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten them by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .

●

To snap the end of a single octave line to the next notehead, press Ctrl/Cmd-Shift-Alt/
Opt-Right Arrow .

●

To snap the end of a single octave line to the previous notehead, press Ctrl/Cmd-ShiftAlt/Opt-Left Arrow .
NOTE
●

You can only lengthen/shorten octave lines by the current rhythmic grid resolution
when multiple octave lines are selected.

●

When using the keyboard, you can only move the end of octave lines. You can move
the start of octave lines by moving the whole line, or by clicking and dragging the
start handle.

733
Dorico Pro 3.1.10

Octave lines
Changing the angles of octave lines
●

Click and drag the circular handle at the start/end of a single octave line to noteheads to
the right/left.

RESULT
Single octave lines are lengthened/shortened according to the current rhythmic grid resolution
or to the next/previous notehead, whichever is closer.
Multiple octave lines are lengthened/shortened according to the current rhythmic grid
resolution.

Changing the angles of octave lines
You can change the angles of octave lines in multiple places, for example, if you want to add
corners to allow an octave line to follow the shape of an angular phrase more closely to save
vertical space.
PROCEDURE
1.

In Write mode or Engrave mode, select one of the following:
●

Individual notes/chords within octave lines where you want to add single corners.
NOTE
We do not recommend selecting adjacent notes, as this can distort the dashes in octave
lines.

●
2.

An even number of adjacent notes across which you want to angle the octave line.

Change the angles in one of the following ways:
●

To add a single corner at the position of each selected note, choose Edit > Octave Line >
Add Corner.

●

To angle the octave line across the range of selected notes, choose Edit > Octave Line >
Make Angled.

TIP
You can also choose these options from the context menu.

RESULT
If you added corners to individual notes, Dorico Pro compares the furthest note from the staff at
each selected rhythmic position to the height of the previous note/chord and adds a corner with
a suitable angle.
If you angled the octave line across a range of selected notes, Dorico Pro adjusts the angle of the
octave line in order to fit around changes in height in the selected range.
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EXAMPLE

An octave line with multiple corners, allowing it to fit better under the slur

Resetting the angles of octave lines
You can reset the angles and corners of octave lines to return them to a single horizontal line.
PROCEDURE
1.

Select the notes within the octave lines at the positions of the angles/corners you want to
reset. You can do this in Write mode and Engrave mode.

2.

Choose Edit > Octave Line > Remove Corner/Angle. You can also choose this option from
the context menu.

RESULT
The angles and corners of octave lines above/below the selected notes are reset. This does not
affect any other angles in the same octave lines above/below unselected notes.

Positions of octave lines
By default, octave lines that indicate notes are played higher than written are placed above the
staff, while octave lines that indicate notes are played lower than written are placed below the
staff.
You can move octave lines to new rhythmic positions in Write mode. They are positioned by
default according to your settings in Engraving Options.
You can move octave lines graphically in Engrave mode, but this does not change the rhythmic
positions to which they apply.
You can change the default positions of all octave lines project-wide on the Octave Lines page in
Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for octave lines on page 733
Tucking index properties on page 740

Moving octave lines rhythmically
You can move octave lines to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the octave lines you want to move.
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NOTE
When using the mouse, you can only move one octave line rhythmically at a time.
2.

Move the octave lines to the next or previous notehead on the staff, while maintaining their
total durations, in any of the following ways:
●

To move a single octave line to the next notehead on the staff, press Alt/OptRight Arrow .

●

To move a single octave line to the previous notehead on the staff, press Alt/OptLeft Arrow .

●

To move them to the right according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Right Arrow .

●

To move them to the left according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Left Arrow .
NOTE
You can only move octave lines according to the current rhythmic grid resolution when
multiple octave lines are selected.

●

Click and drag the octave line to the right/left.

RESULT
The octave lines are moved to new rhythmic positions. The octave lines now apply to the notes at
their new positions.
NOTE
●

If a single octave line passes over another octave line as part of its move, the existing line is
unaffected as multiple octave lines can exist at the same rhythmic position. However, if you
move multiple octave lines together, existing octave lines are shortened or deleted
according to where you move the selected ones.

●

If you move octave lines to a rhythmic position that does not have a notehead, they do not
appear in the music area. You must continue moving them to the right/left until you reach
the next notehead for them to appear.

●

Octave lines can only be moved along staves. If you want to move an octave line across
staves, you must delete the octave line and input a new octave line on the other staff.

RELATED LINKS
Input methods for clefs and octave lines on page 254

Moving octave lines graphically
You can move octave lines graphically without changing the rhythmic positions to which they
apply. You can move each end of octave lines independently, meaning you can also adjust the
graphical lengths of individual octave lines.
PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Whole octave lines

●

Individual start/end handles on octave lines
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TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the octave lines or handles in any of the following ways:
●

To move octave lines and handles to the right, press Alt/Opt-Right Arrow .

●

To move octave lines and handles to the left, press Alt/Opt-Left Arrow .

●

To move octave lines and start handles upwards, press Alt/Opt-Up Arrow .

●

To move octave lines and start handles downwards, press Alt/Opt-Down Arrow .
NOTE
●

You cannot move the end handles on octave lines upwards/downwards, you can
only move them to the right/left. You can move the start handles on octave lines
upwards/downwards but this also moves the whole octave line.

●

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag whole octave lines upwards/downwards.

●

Click and drag handles on octave lines to the right/left.

RESULT
The selected octave lines or handles are moved to new graphical positions.
TIP
The following properties in the Octave Lines group of the Properties panel are activated
automatically when you move octave lines in the corresponding directions:
●

Start X offset moves the start of octave lines horizontally.

●

End X offset moves the end hooks of octave lines horizontally.

●

Y offset moves whole octave lines vertically.

For example, if you move a whole octave line to right, both handles are moved, so Start X offset
and End X offset are both activated. You can also use all three properties to move and lengthen/
shorten octave lines graphically by changing the values in the value fields.
Deactivating the properties resets the selected octave lines to their default positions.

Changing the alignment of octave line numerals relative to notes
You can change whether the left edge, center, or right edge of individual octave line numerals is
aligned with the first note to which each octave line applies.
PROCEDURE
1.

Select the octave lines whose numeral alignment relative to notes you want to change. You
can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate L alignment in the Octave Lines group.

3.

Select one of the following options from the menu:
●

Left

●

Center

●

Right
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RESULT
The alignment of the numerals of the selected octave lines is changed. For example, if you select
Right, the right edge of the selected octave line numerals is aligned with the first noteheads to
which the octave lines apply.

Changing the position of octave line numerals relative to accidentals
You can change whether the numerals at the start of individual octave lines are positioned on
noteheads or accidentals, independently of your project-wide setting.
PROCEDURE
1.

Select the octave lines whose numeral alignment relative to accidentals you want to change.
You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate L position in the Octave Lines group.

3.

Choose one of the following options:
●

Notehead

●

Accidental

RESULT
The alignment of the numerals of the selected octave lines is changed. For example, if you
choose Accidental, the octave line numerals are aligned with the accidental on the first
noteheads to which the octave lines apply.
TIP
You can change the default alignment of all octave line numerals project-wide in the Horizontal
Position section of the Octave Lines page in Engrave > Engraving Options.

Deleting octave lines
You can delete octave lines without deleting notes and other items.
PROCEDURE
1.

In Write mode, select the octave lines you want to delete.

2.

Press Backspace or Delete .

RESULT
The selected octave lines are deleted. Any notes to which the deleted octave lines previously
applied are shown at either concert pitch or transposed pitch, depending on your current setting
for the layout.
RELATED LINKS
Input methods for clefs and octave lines on page 254
Making layouts transposing/concert pitch on page 137
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Octave lines in Engrave mode
In Engrave mode, each octave line has three square handles. You can use these handles to move
the start/end of octave lines graphically, and to lengthen/shorten octave line hooks.

An octave line in Engrave mode

●

The start handle moves the start of octave lines graphically. You can move this handle to the
right/left.
NOTE
When using the keyboard, you can also move this handle upwards/downwards. This moves
the whole octave line.

●

The top end handle moves the end of octave lines graphically. You can move this handle to
the right/left.

●

The bottom end handle changes the length of the hook. You can move this handle upwards/
downwards.

If octave lines cross system and frame breaks, you can move the line segments on each side of
the break independently.
RELATED LINKS
Moving octave lines graphically on page 736
Lengthening/Shortening octave lines on page 733
Project-wide engraving options for octave lines on page 733

Lengthening/Shortening octave line hooks
You can change the length of individual octave line hooks, independently of your project-wide
setting.
PROCEDURE
1.

In Engrave mode, select the hook handles on the octave lines whose hooks you want to
lengthen/shorten.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag them upwards/downwards.
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RESULT
The length of the selected octave line hooks is changed.
TIP
●

Hook length in the Octave Lines group of the Properties panel is activated automatically
when you move octave line hooks. You can also use this property to lengthen/shorten octave
line hooks by changing the value in the value field.
Deactivating the property resets the selected octave lines to their default hook length.

●

You can change the default hook length for all octave lines project-wide by changing the
value for Octave line hook length, which you can find by clicking Advanced Options in the
Appearance section of the Octave Lines page in Engrave > Engraving Options.

Tucking index properties
The tucking index of notations determines their position relative to other notations in the vertical
stacking order when multiple notations exist at the same rhythmic positions.
In most published music, the order in which items appear relative to each other is consistent.
Dorico Pro uses established conventions to determine the position and placement of notations
automatically. For example, where slurs and tuplet brackets exist at the same positions, Dorico
Pro calculates their placement based on their relative lengths. If the slur is longer than the tuplet
bracket, the slur is placed outside the tuplet bracket; if the tuplet bracket is longer than the slur,
the slur is placed inside the tuplet bracket.
However, rules for the order and placement of articulations, slurs, tuplets, and octave lines
frequently vary, based on their lengths and musical context. Therefore, you can override the
automatic order and manually change the order in which they appear in specific contexts.
To allow you this flexibility, slurs, octave lines, and tuplets all have Tucking index properties in
their respective Properties panel groups.
NOTE
Articulations are considered alongside these notations when calculating the stacking order, but
do not have a tucking index property.
A Tucking index value of 0 positions items closest to notes. The higher the number, the further
away the item is positioned from notes in the stacking order.

Changing the vertical stacking order of octave lines
You can change the placement of individual octave lines relative to other objects in the vertical
stack by changing their tucking index value.
According to general convention, octave lines are placed outside all other objects, but there are
some instances where they can go inside other objects, for example, inside a slur if that slur is
longer than the octave line.
PROCEDURE
1.

In Engrave mode, select the octave lines whose placement in the vertical stack you want to
change.

2.

In the Properties panel, activate Tucking index in the Octave Lines group.

3.

Change the value in the value field.
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0 positions items closest to notes. The higher the number, the further the item is positioned
from notes in the stacking order.
RESULT
The placement of the selected octave lines in the vertical stacking order is changed.
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Cues are passages of music shown in instrumental parts that are played by a different player,
usually to help orientate players before entries or solos following a significant passage of rests.
Cues can also be used to assist with co-ordination or tuning between players, or to indicate
material that the player might be asked to double.
In Dorico Pro, you can input correctly formatted cues quickly using the cues popover. Cues are
automatically input into a new voice, with bar rests shown alongside cues to make sure the
player reading the cue understands that they do not play the cued music. Clefs are automatically
input in cues as required, including restorative clefs.

A cue in a violin part showing music from a Bassoon 1 part

Dorico Pro features dynamic cues that are linked to the original source material, meaning cues
are updated in real time if the source material changes.
The instrument whose music is included in a cue is known as the source instrument. The
instrument whose part contains a cue from another instrument is known as the destination
instrument.
By default, cues are hidden in full score/custom score layouts and shown in part layouts. In
layouts where cues are hidden, they are indicated by signposts.
NOTE
In Write mode, you cannot select anything within cues. In Engrave mode, you can select notes
and items in cues but you can only edit them graphically.

RELATED LINKS
Inputting cues on page 315
Hiding/Showing cues in layouts on page 746
Cue contents on page 750
Note spacing on page 425
Changing note spacing from rhythmic positions on page 427
Viewing options for cues on page 758
Signposts on page 335

General placement and notation conventions for cues
Cues are usually notated using notes of a smaller size than normal notes, with the name of the
cued instrument indicated at the start of the passage.
It is generally accepted that full-sized rests are shown above/below cues to reinforce that the
player reading the cue does not play these notes.
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Cues might exclude some notations that are present in the source instrument. However, cues
normally include slurs, articulations, and dynamics, as these often help the player reading the
cue to identify passages.
Depending on the register of the cued instrument and the range of each cue passage, clef
changes might also be needed at the start of cues.
RELATED LINKS
Cue labels on page 750
Clef changes in cues on page 756
Notations in cues on page 753
Changing the notations included in cues on page 753

Project-wide engraving options for cues
You can find options for the project-wide appearance, content, and position of cues on the Cues
page in Engrave > Engraving Options.
The options on the Cues page allow you to change the size, appearance, placement, and precise
position of cues. You can also decide which notations are included in all cues, set the default
spacing of cues, and set the default staff position of rhythmic cues and cues from unpitched
percussion source instruments.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359
Note spacing on page 425
Changing existing cues to rhythmic cues on page 744

Rhythmic cues
Rhythmic cues only show the rhythm of the source instrument, whether it is pitched or
unpitched, and are positioned above the staff by default. By default, cues from unpitched
percussion source instruments are input as rhythmic cues.
Rhythmic cues do not show clef changes, accidentals, or ledger lines. They also do not show
octave transpositions in their cue labels, even when the destination instrument is octave
transposing. Their default position outside staff lines ensures they can never be misread as
containing pitched material.
You can change existing cues into rhythmic cues and vice versa. This causes cues that were
originally from pitched source instruments to show only the rhythm, which can be helpful when
multiple instruments play the same rhythm together but on different notes, such as in big band
music with large unison chords. In this context, showing the pitches of a single instrument in the
group could be misleading as the destination instrument might think this indicates a distinctive
melody. You can then change the cue label to include information about the instruments playing
the rhythm in the cue.
By default, cues from unpitched percussion source instruments are input as rhythmic cues. If you
want to save vertical space, you can change them to cues from unpitched percussion source
instruments. This positions them on the middle line of the staff by default.
You can change the default staff positions for rhythmic cues and cues from unpitched percussion
source instruments in the Rhythmic Cues and Unpitched Instruments sections of the Cues
page in Engrave > Engraving Options.
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You can also change the staff position of rhythmic cues and cues from unpitched percussion
source instruments individually.

A rhythmic cue

A cue from an unpitched percussion source

RELATED LINKS
Editing cue label text on page 751
Changing the staff position of cues from unpitched percussion source instruments on page 745

Changing existing cues to rhythmic cues
Cues normally show pitched material played by a specific instrument. However, you can change
existing cues showing pitched material into rhythmic cues that only show the rhythm of the cued
music. This can be helpful for passages where many instruments play the same distinctive
rhythm together.
PROCEDURE
1.

Select the labels of the cues you want to change into rhythmic cues. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Rhythmic cue in the Cues group.

RESULT
The selected cues are shown as rhythmic cues. They are automatically positioned above the staff
according to your setting for Distance from space above staff in the Rhythmic Cues section of
the Cues page in Engrave > Engraving Options.
NOTE
Deactivating Rhythmic cue returns the selected cues back to normal cues. This includes cues
from unpitched percussion instruments that are automatically input as rhythmic cues.
If you deactivate Rhythmic cue for cues from unpitched percussion instruments, the cues are
positioned on the middle line of the staff by default.

RELATED LINKS
Inputting cues on page 315

Changing the distance between rhythmic cues and the staff
You can change the distance between individual rhythmic cues and the staff, independently of
your project-wide setting.
PROCEDURE
1.

Select the labels of the rhythmic cues whose distance from the staff you want to change. You
can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Distance in the Cues group.
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3.

Change the value in the value field.

RESULT
The position of the selected cues is changed according to the new value. For example, entering 0
positions rhythmic cues in the space immediately above the top line on the staff. Higher values
increase the distance between rhythmic cues and the staff.
TIP
You can change the default distance between all rhythmic cues and the top line of the staff
project-wide on the Cues page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for cues on page 743

Changing the staff position of cues from unpitched percussion
source instruments
You can change the staff position of cues from unpitched percussion source instruments
individually, independently of your project-wide setting.
By default, cues from unpitched percussion source instruments that are not rhythmic cues are
positioned on the middle line of staves.
PROCEDURE
1.

Select the labels of the cues from unpitched percussion source instruments whose staff
position you want to change. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Unpitched notes pos. in the Cues group.

3.

Change the value in the value field.

RESULT
The staff position of the selected cues is changed according to the new value. For example, 0 is
the middle line of the staff, 4 is the top line of the staff, and -4 is the bottom line of the staff.
TIP
You can change the default staff position of all cues from unpitched percussion source
instruments project-wide on the Cues page in Engrave > Engraving Options.
EXAMPLE

Unpitched cue on the middle line of the staff
(default)
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Hiding/Showing cues in layouts
You can input cues in any layout, but by default cues do not appear in full score layouts, as cues
are normally only shown in instrumental parts. You can hide/show cues in each layout in your
project independently of other layouts.
Cue signposts are shown in full score layouts by default in page view. In galley view, the cued
music appears in addition to cue signposts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show cues.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Cues section, activate/deactivate Show cues.

5.

Click Apply, then Close.

RESULT
All cues in the selected layouts are shown when the checkbox is activated, and hidden when the
checkbox is deactivated.
In layouts where cues are hidden, they are indicated by signposts.
NOTE
●

You can hide individual cues in layouts where cues are shown, but you cannot show
individual cues in layouts where cues are hidden.

●

You can hide/show cue signposts by choosing View > Signposts > Cues. Cue signposts are
shown when a tick appears beside Cues in the menu, and hidden when no tick appears.

RELATED LINKS
Signposts on page 335

Hiding cues individually
You can hide individual cues in layouts in which cues are shown. However, you cannot show
individual cues in layouts where cues are hidden.
PROCEDURE
1.

In the music area, open the layout in which you want to hide individual cues.

2.

Select the labels of the cues you want to hide. You can do this in Write mode and Engrave
mode.

3.

In the Properties panel, activate Hide in the Cues group.

RESULT
The selected cues are hidden when Hide is activated. Signposts are shown at the position of each
hidden cue. However, signposts are not printed by default.
Deactivating Hide shows the selected cues again.
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Changing the octave of cues
You can change the octave in which cues are shown so the cue fits better on the staff of the
destination instrument. This can be useful if the source instrument plays in a significantly
different octave to the destination instrument.
PROCEDURE
1.

In the music area, open the layout in which you want to change the octave of cues.

2.

Select the labels of the cues whose octave you want to change. You can do this in Write
mode and Engrave mode.

3.

In the Properties panel, activate Octave shift in the Cues group.

4.

Change the value in the value field.

RESULT
The octave of the selected cues is changed. For example, 1 shifts the cue up one octave, and -1
shifts the cue down one octave.
If octave transpositions are shown in the cue labels, they are automatically updated.
EXAMPLE

Cue with no octave change

Cue with an octave above line

Hiding/Showing octave transpositions in cue labels
By default, octave transpositions are included in cue labels when you shift the octaves at which
cues are shown. You can hide/show octave transpositions in cue labels individually,
independently of your project-wide setting.
PROCEDURE
1.

Select the cue labels in which you want to hide/show octave transpositions. You can do this
in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Show octave transposition in the Cues group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Octave transpositions are shown in the selected cue labels when the checkbox is activated, and
hidden when the checkbox is deactivated.
Deactivating the property returns cue labels to your project-wide setting.
TIP
You can show/hide octave transpositions in all cue labels project-wide on the Cues page in
Engrave > Engraving Options.
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RELATED LINKS
Changing the information included in cue labels project-wide on page 751

Moving cues
You can move cues to new rhythmic positions after they have been input. This changes the
material shown in cues to reflect the material at the corresponding rhythmic positions in the
source instrument.
PROCEDURE
1.

In Write mode, select the labels of the cues you want to move.
NOTE
When using the mouse, you can only move one cue at a time.

2.

Move the cues in any of the following ways:
●

To move a single cue to the right according to the rhythm in the source instrument,
press Alt/Opt-Right Arrow .

●

To move a single cue to the left according to the rhythm in the source instrument, press
Alt/Opt-Left Arrow .

●

To move them to the right according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Right Arrow .

●

To move them to the left according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Left Arrow .
NOTE
You can only move cues according to the current rhythmic grid resolution when multiple
cues are selected.

●

Click and drag the cue to the right/left, according to the rhythm in the source
instrument.

RESULT
The selected cues are moved to new rhythmic positions. Their contents are updated to reflect the
music in the source instrument in their duration.
RELATED LINKS
Overlapping cues on page 754
Hiding/Showing cues in layouts on page 746

Lengthening/Shortening cues
You can change the length of cues after they have been input. This changes the material shown
in cues to reflect the material at the corresponding rhythmic positions in the source instrument.
PROCEDURE
1.

In Write mode, select the labels of the cues you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one cue at a time.

2.

Lengthen/Shorten the cues in any of the following ways:
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●

To lengthen them by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten them by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .

●

To lengthen a single cue to the next notehead of the source instrument, press Ctrl/
Cmd-Shift-Alt/Opt-Right Arrow .

●

To shorten a single cue to the previous notehead of the source instrument, press Ctrl/
Cmd-Shift-Alt/Opt-Left Arrow .
NOTE

●

●

When multiple cues are selected, you can only lengthen/shorten cues by the current
rhythmic grid resolution.

●

Key commands lengthen/shorten items by moving their end only.

Click and drag the circular handle at the start/end to the right/left.

RESULT
The selected cues are lengthened/shortened.
NOTE
You can lengthen cues so that they overlap with other existing cues, as multiple cues can exist at
the same rhythmic position. However, their stem directions are not automatically adjusted so you
might have to change them manually.

RELATED LINKS
Overlapping cues on page 754
Overriding default stem directions in single-voice cues on page 754
Moving cues on page 748

Deleting cues
You can delete individual cues without deleting the corresponding notes in the source
instrument or other instruments containing the same cue.
PROCEDURE
1.

In Write mode, select the labels/signposts of the cues you want to delete.

2.

Press Backspace or Delete .

RESULT
The selected cues are deleted from all the layouts containing the affected instruments. For
example, deleting a cue in a piano part also deletes the cue from the piano staff in
corresponding full score layouts.
RELATED LINKS
Hiding/Showing cues in layouts on page 746
Signposts on page 335
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Cue contents
The content of individual cues can appear differently in each layout, independently of other
layouts and without changing the source material, if you make changes in a layout that does not
contain the source instrument.
Music in cues is dynamically linked to the music in the source instrument. Any changes you make
to the source music are automatically shown in the cue, but you cannot change the pitch or
duration of notes within the cue. This ensures that cues are an accurate reflection of the notes
being played by the cued instrument.
You can make graphical changes to the music in cues without affecting the corresponding music
in the source instrument. For example, you can adjust the placement of slurs and the angles of
glissando lines, lengthen/shorten stems in cues, and respell accidentals. You can also change the
note spacing scale factor of cues for whole layouts and from selected rhythmic positions
onwards in individual layouts.
NOTE
Graphical changes to cues are layout-specific. For example, if you make changes to a cue within a
full score layout that also contains the source instrument, your changes to the cue affect the
corresponding material in the source instrument and other instruments with the same cue in the
layout. However, if you make changes to a cue in a part layout that only contains the destination
instrument, the corresponding material in the part layout of the source instrument is not
affected.
It is also possible to change the enharmonic spelling of notes in cues in Engrave mode in the
same way as changing the enharmonic spelling of normal notes. If you respell notes in cues in
the part layout of the destination instrument, the spelling of notes in the source instrument is
not affected. For example, you can change the enharmonic spelling of notes in cues in
transposing instrument layouts to avoid double accidentals.
IMPORTANT
If you respell notes in cues in a layout that also contains the source instrument, the enharmonic
spelling is also changed in the source instrument.

RELATED LINKS
Respelling notes on page 200
Slurs in Engrave mode on page 1129
Lengthening/Shortening stems on page 1201
Note spacing on page 425
Note Spacing Change dialog on page 427
Changing note spacing from rhythmic positions on page 427

Cue labels
Cue labels usually indicate the source instrument from which the music is taken, but can also
include other information, such as the transposition interval for transposing instruments. This
information can help players identify both where the sound is coming from in the ensemble and
the type of sound to listen for.
By default, cue labels in Dorico Pro use abbreviated instrument names, exclude instrument
transpositions, include octave transpositions, and do not show an additional label at the end of
cues to indicate where players enter after cues. Additional labels showing “Play” at the end of
cues are sometimes used in jazz scores, where it is customary not to show bar rests alongside
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cues. Showing additional labels at the ends of cues can also be useful in film music, where cues
are often included in parts as an option that the player might be asked to play.
You can change the information and text shown in cue labels both project-wide and on an
individual basis in Dorico Pro.
NOTE
If you want to hide/show cue labels at the start/end of cues individually, you can use the
following properties in the Cues group of the Properties panel:
●

Start text applies to labels at the start of cues.

●

End text applies to labels at the end of cues.

Changing the information included in cue labels project-wide
You can change the information included as text in cue labels project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Cues in the page list.

3.

In the Cue Labels section, change any of the following options:

4.

●

Instrument name in label

●

Instrument pitch or transposition

●

Octave transposition

●

Additional label at end of cue

Click Apply, then Close.

RESULT
The information included in cue labels is changed project-wide.
TIP
You can also edit cue labels individually. For example, if two instruments are playing in unison,
you can edit the cue label that shows the name of one of the instruments to include both
instrument names.

Editing cue label text
You can override the text shown in cue labels individually. For example, if two instruments are
playing in unison, you can change the cue label that shows the name of one of the instruments
to include both instrument names.
You can also show additional labels at the ends of individual cues, even if your project-wide
setting is to show no additional labels.
PROCEDURE
1.

Select the cue labels whose text you want to edit. You can do this in Write mode and Engrave
mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Cues group:
●

Start text
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●
3.

End text

Enter the text you want to be shown in the corresponding cue labels into each value field.
For example, to indicate that two violinists are playing the same material but an octave
apart, you might enter Vln.I & Vln.II coll’ottava in the value field for Start text.

4.

Press Return .

RESULT
The cue labels of the selected cues are changed to show the text you entered.
Deactivating the properties returns the corresponding cue labels of the selected cues to their
default text.
NOTE
Deactivating properties permanently deletes any custom text entered.

Moving cue labels graphically
You can move individual cue labels graphically without affecting the rhythmic positions of the
cue. You can move cue labels at the start and end of cues independently of each other.
PROCEDURE
1.

In Engrave mode, select the cue labels you want to move.

2.

Move the cue labels in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected cue labels are moved to new graphical positions.
TIP
Offset in the Cues group of the Properties panel is activated automatically when you move cue
labels.
●

Offset X moves cue labels horizontally.

●

Offset Y moves cue labels vertically.

You can also use this property to move cue labels by changing the values in the value fields. The
same property applies to cue labels both at the start and end of cues.
Deactivating the property resets the selected cue labels to their default positions.
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Notations in cues
It is beneficial to include musically significant notations from the source instrument in cues, as
they can help players identify the cued music more easily. However, only certain notations are
included in cues to avoid overloading players with too much information.
By default, Dorico Pro includes the following notations in cues:
●

Slurs

●

Articulations

●

Ornaments

●

Playing techniques

●

Lyrics (for vocal music)

You can also include dynamics and text in cues, but these are not included by default as this
information is not usually required to help identify the cued material.
NOTE
Playing techniques that only indicate important information for the source instrument, such as
bowing marks for string players, are not included in cues.
To be included in cues, playing techniques must exist within the range of the cued material. For
example, slurs must begin and end within the cued material to be included in cues.
Similarly, pizzicato markings are not shown in cues if they are input before the first cued note.
However, pizzicato strings sound significantly different to bowed strings, so omitting this
information could prevent the player reading the cue from identifying it.
NOTE
If important playing technique information does not exist within the range of cued material, we
recommend that you include this information in the corresponding cue labels.

Changing the notations included in cues
You can change the notations included in individual cues, such as slurs and playing techniques,
independently of your project-wide settings.
PROCEDURE
1.

Select the labels of the cues whose included notations you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Cues group of the Properties panel, activate the property for each notation that you
want to include in, or exclude from, the selected cues.

3.

Activate/Deactivate the corresponding checkboxes.

RESULT
The corresponding notations are included in cues when the checkboxes are activated, and
excluded from cues when the checkboxes are deactivated.
NOTE
●

Playing techniques that only indicate important information for the source instrument, such
as bowing marks for string players, are not included in cues.
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●

You can change which notations are included in all cues project-wide on the Cues page in
Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for cues on page 743
Editing cue label text on page 751

Stem direction in cues
Notes in cues normally have the same stem direction, as cues usually highlight lines containing
only one voice. Cues are shown by default with bar rests alongside them to indicate that the
player reading the cue does not play those notes.
If cues contain music in multiple voices, the original stem directions of the source music are
used. For single-voice cues, Dorico Pro determines the default stem direction depending on the
pitches in the cue. Stems point downwards when most notes in the cue are at positions below
the middle line of the staff, and upwards when most notes in the cue are at positions above the
middle line of the staff.
TIP
You can override the stem directions of notes in single-voice cues individually.

Overlapping cues
Sometimes it is helpful to give players multiple consecutive cues so they can follow passages of
music more easily. Dorico Pro allows cues to overlap in order to give you flexibility over how to
give useful information in cues to players.
However, the stem directions of cues are not automatically adjusted when they exist at the same
rhythmic position as other cues. For example, if you want to show a melody passing from Violin 1
to Violin 2 that requires the two cues to overlap, and both instruments are shown in up-stem
voices by default, then the two cues appear with up-stem notes.
You can override the default stem directions of cues individually to make overlapping cues easier
to read.

Default stem directions in two overlapping cues

Overridden stem directions in the cue containing
lower notes so that its notes are down-stem

Overriding default stem directions in single-voice cues
You can override the default stem directions of individual single-voice cues.
PROCEDURE
1.

In the music area, open the layout in which you want to override the default stem direction
of selected cues.
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2.

Select the labels of the cues whose stem direction you want to change. You can do this in
Write mode and Engrave mode.

3.

In the Properties panel, activate Voice direction in the Cues group.

4.

Choose one of the following options:
●

Force stems up

●

Force stems down

RESULT
The stem direction of all notes in the selected cues is changed.
Deactivating Voice direction returns the selected cues back to their default stem direction.

Ties in cues
If cues begin in the middle of sustained notes, ties are shown joining to the first note in cues.
Similarly, if cues end in the middle of sustained notes, ties are shown proceeding from the final
notes in cues.
For monophonic instruments, these ties are normally positioned correctly by default. However, in
complex cases, such as cues involving chords, the positions of these ties can require some
adjustment.
You can edit ties that start before/end after cues in the same way as normal ties in Engrave
mode.
RELATED LINKS
Changing the shape/angle of ties on page 1226

Rests in cues
If cues start/end partway through bars, they are padded with cue-sized rests up to bar
boundaries or up to the next played entry, whichever comes first. This ensures it is clear to the
player how the rhythm of the cue fits within the current time signature and how it relates to their
existing material.
By default, full-sized bar rests also appear throughout cued passages. This makes it clear that the
performer does not play the cued notes.
Full-sized bar rests are automatically positioned according to the stem direction of the notes in
the cue. If cues use up-stem notes, bar rests are positioned below cued notes. If cues use downstem notes, bar rests are positioned above the cued notes.
You can choose not to show bar rests alongside cues. For example, this can be appropriate in
some jazz scores, or in scores where the cues are provided as potential passages for doubling.
TIP
You can adjust the vertical position of full-sized bar rests individually using Rest pos. in the
Notes and Rests group of the Properties panel.

RELATED LINKS
Moving rests vertically on page 1116
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Hiding/Showing padding rests in cues
You can hide/show padding rests around individual cues. Padding rests fill up bars when cues
start/end partway through bars, so that the full duration of each bar is clear.
PROCEDURE
1.

Select the labels/signposts of the cues whose padding rests you want to hide/show. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Hide rests around cue in the Cues group.

RESULT
Padding rests around the selected cues are hidden when Hide rests around cue is activated, and
shown when it is deactivated.
RELATED LINKS
Implicit vs. explicit rests on page 1107

Hiding/Showing bar rests in cues
You can hide/show bar rests alongside all cues in each flow in your project.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-N to open Notation Options.

2.

In the Flows list, select the flows in which you want to hide/show bar rests.
By default, only the current flow is selected when you open the dialog.

3.

Click Rests in the page list.

4.

In the Rests in additional voices section, choose one of the following options for Bar rests
in cues:

5.

●

Show bar rests

●

Omit bar rests

Click Apply, then Close.

RESULT
Bar rests alongside cues are hidden/shown in all layouts in the selected flows in your project.

Clef changes in cues
If the music for the source instrument is in a different clef from the destination instrument,
Dorico Pro automatically inputs a clef change at the start of cues to match the clef used by the
source instrument, and a restorative clef change at the end of cues to match the original clef
used by the destination instrument.
Clef changes at the start of cues are positioned differently to normal clef changes.
Cues starting at the beginning of bars
Clef changes appear to the right of barlines.
Restorative clef changes at the ends of cues are positioned like normal clef changes.
Cues crossing system breaks
Original clefs of destination parts are shown in their usual positions at the start of new
systems.
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Clefs required for cues appear immediately before the first note of the new system, to
the right of key signatures and time signatures.
When there are multiple adjacent cues, clef changes are created as needed:
●

If two adjacent cues use the same clef that is different than the clef in the destination
instrument, a single clef change appears at the start of the first cue, with a restorative clef at
the end of the second cue.

●

If cues overlap, and the second cue requires a different clef than the first, Dorico Pro creates
a clef change at the start of the second cue.

●

If there are two adjacent cues, the first of which uses a different clef than the destination
instrument, and the clef property for the second cue is set to None, then the clef change
that restores the destination instrument’s original clef appears at the end of the first cue.

You can override this automatic behavior for individual clefs using either Concert clef or
Transposed clef in the Cues group of the Properties panel, depending on whether the layout
currently open in the music area uses concert or transposed pitch.
Dorico Pro can show the following clefs in cues:
●

None

●

Treble

●

Alto

●

Tenor

●

Bass

NOTE
●

If you select None, the clef of the destination instrument is used instead of the clef of the
source instrument.

●

Any clef changes that occur in the source instrument in the middle of cued passages are not
included in the cue in the destination instrument.

Changing the clef shown in cues
You can change the clef shown in individual cues, independently of your project-wide settings.
You can show different clefs for the same cue in each layout in which it appears. For example,
you can show a cue with a treble clef in a full score layout but with a bass F clef in the
corresponding part layout.
PROCEDURE
1.

In the music area, open the layout in which you want to change the clef shown in cues.

2.

Select the labels of the cues whose clef you want to change. You can do this in Write mode
and Engrave mode.

3.

In the Properties panel, activate one of the following properties in the Cues group:

4.

●

Concert clef: Shown if the layout uses concert pitch

●

Transposed clef: Shown if the layout uses transposed pitch

Select one of the following clefs from the menu:
●

None: Uses the clef of the destination instrument instead of the clef of the source
instrument.

●

Treble

●

Alto

●

Tenor
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●

Bass

The same clefs are available for each property.
RESULT
The clef shown in the selected cues is changed.
TIP
You can change whether the clef of the source instrument or destination instrument is used in all
cues project-wide on the Cues page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for cues on page 743

Viewing options for cues
You can highlight cues and/or show cued material in a different color to normal notes in your
project to help you identify cues more easily as you are working.
NOTE
In layouts where cues are hidden, they are indicated by signposts. You can hide/show cue
signposts by choosing View > Signposts > Cues. Cue signposts are shown when a tick appears
beside Cues in the menu, and hidden when no tick appears.

RELATED LINKS
Signposts on page 335
Hiding/Showing cue note colors on page 759

Hiding/Showing cue highlights
You can hide/show highlights on bars where cues exist, which can help you get an overview of
where you have already added cues and which instruments are used as the source of cues.
Bars containing cues on destination instrument staves are shown with a translucent yellow
highlight, and the corresponding bars on the source instrument staves are shown with a
translucent blue highlight.
As you zoom out, the highlights become more opaque. This is especially useful when viewing full
score layouts in galley view.
NOTE
Cue highlights only appear in layouts where cues are shown.

PROCEDURE
●

Choose View > Highlight Cues.

RESULT
Highlights on bars containing cues are shown when a tick appears beside Highlight Cues in the
menu, and hidden when no tick appears.
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EXAMPLE

Cue highlights shown on source staff and destination staff

Hiding/Showing cue note colors
You can show the material in cues, including notes and rests, in gray to help you identify cues.
Cued material cannot be edited directly.
Cue note colors are considered annotations and are not printed by default.
NOTE
Cue note colors only appear in layouts where cues are shown.

PROCEDURE
●

Choose View > Note And Rest Colors > Cues.

RESULT
Material in cues appears gray when a tick appears beside Cues in the menu, and black when no
tick appears.
EXAMPLE

Cue note colors shown
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Dynamics indicate the loudness of the music, and can be combined with other instructions to
give the performer a detailed understanding of how to perform the music, while also leaving
room for interpretation.
Dynamics can indicate an immediate change in volume or a gradual change over a specified
duration. By default, they are placed below the staff for instruments and above the staff for
voices.
You can add modifiers to dynamics that can give stylistic direction context alongside the volume
level, such as  espressivo, which indicates that a passage is played loudly but also with
expressive feeling.
While almost all expression text is written in italics, dynamics such as  and  use a bold italic
font.
RELATED LINKS
Input methods for dynamics on page 241
Positions of dynamics on page 761
Dynamics lanes on page 513

Types of dynamics
Dorico Pro categorizes dynamics into different groups according to their function.
Immediate dynamics
Immediate dynamics apply to the note to which they are attached until the next
dynamic marking, and indicate an immediate change from any previous dynamic.
Immediate dynamics include dynamic symbols, such as  or , and qualifying text,
such as subito or molto.
Gradual dynamics and hairpins
Gradual dynamics are often shown as hairpins but can also be shown using text. In
Dorico Pro, you can show gradual dynamic text in the following ways:
●

cresc. or dim.: abbreviated text with no continuation line

●

cresc... or dim...: abbreviated text with a dotted continuation line

●

cre-scen-do or di-mi-nuen-do: the full word spread out across the duration of the
gradual dynamic

Gradual dynamics can also have qualifying text, such as poco, molto, poco a poco, and
niente.
In Dorico Pro, a hairpin can be shown as messa di voce, which shows a pair of hairpins.
In some cases, this is easier than having separate lines for each half of the pair.
Force/Intensity of attack
These dynamics, such as  and , indicate that a note has a stronger attack than is
usually expected for the dynamic, similar to an accent articulation.
Combined dynamics
Combined dynamics, such as  or –, specify a sudden change of dynamic.
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You can create custom combined dynamics in Dorico Pro, and control the intensity of
each dynamic in the pair, in the Combined Dynamics section of the Dynamics panel.
For example, you can make dynamics such as , –, and .
RELATED LINKS
Gradual dynamics on page 772

Project-wide engraving options for dynamics
You can find options for the project-wide appearance and position of dynamics on the Dynamics
page in Engrave > Engraving Options.
The options on the Dynamics page allow you to change the appearance of dynamics and
gradual dynamics, and their default positions relative to noteheads, barlines, and the ends of
systems.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Positions of dynamics
Dynamics are placed below the staff for instruments, where they can be read alongside the
notes, and above the staff for voices. This way, they do not clash with lyrics placed below the
staff, and are still close enough to the notes to be read simultaneously.
Immediate dynamics, such as  or , are centered on the notehead to which they apply. The
beginnings of gradual dynamics are centered on the notehead from which they begin, or
immediately after an immediate dynamic at the same position. The ends of gradual dynamics are
centered on the notehead at which they end, or immediately before an immediate dynamic at
the same position.
The staff-relative placement of dynamics varies, depending on their function and the type of
player. For example, dynamics are placed below instrumental staves and above vocal staves by
default. This ensures dynamics are kept as close to the staff as possible for legibility but are not
placed between noteheads and lyrics on vocal staves. For grand staff instruments, such as piano
or harp, dynamics are usually placed between the two staves, but can be placed both above and
below when each staff requires separate dynamics.
In general, dynamics are not placed within the staff, as hairpins in particular become very hard to
read. They are also not usually placed within tuplet brackets. Dynamics are placed outside of
notations such as slurs, which must be kept close to noteheads, but inside pedal lines, which can
be placed further from noteheads and still be clearly understood.
You can move dynamics to different rhythmic positions in Write mode. They snap to noteheads
and are positioned by default according to your settings in Engraving Options.
You can move dynamics graphically in Engrave mode; however, this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all dynamics project-wide, and their positions relative to
beats, barlines, system ends, the staff, and other objects on the Dynamics page in Engrave >
Engraving Options.
RELATED LINKS
Changing the staff-relative placement of items on page 330
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Moving dynamics rhythmically on page 763
Moving dynamics graphically on page 764

Changing the horizontal beat-relative position of dynamics
You can position individual dynamics before or after the beat.
PROCEDURE
1.

Select the dynamics whose position relative to the beat you want to change. You can do this
in Write mode and Engrave mode.

2.

In the Properties panel, activate Beat-relative position in the Dynamics group.

3.

Choose one of the following options:
●

Before

●

After

EXAMPLE

A dynamic positioned before the beat

A dynamic positioned after the beat

Changing the alignment of immediate dynamics relative to
noteheads
Immediate dynamics, such as  and , are usually horizontally aligned with the optical center
of noteheads. However, you can change the horizontal alignment of immediate dynamics
individually, independently of your project-wide setting.
PROCEDURE
1.

Select the dynamics whose alignment relative to noteheads you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Text alignment in the Dynamics group.

3.

Choose one of the following options:
●

Align optical center with notehead

●

Left-align with notehead

●

Align optical center with left of notehead

RESULT
The alignment of the selected immediate dynamics is changed.
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TIP
You can change the default alignment of all immediate dynamics relative to noteheads projectwide in the Horizontal Position section of the Dynamics page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for dynamics on page 761

Moving dynamics rhythmically
You can move dynamics to new rhythmic positions after they have been input, including within
tie chains.
NOTE
If you want to move a single dynamic within a group, you must click and drag it with the mouse.
If you use the key commands, the whole group is moved.

PROCEDURE
1.

In Write mode, select the dynamics you want to move.
NOTE
When using the mouse, you can only move one dynamic rhythmically at a time.

2.

Move the dynamics in any of the following ways:
●

To move a single dynamic to the next notehead on the staff, press Alt/OptRight Arrow .

●

To move a single dynamic to the previous notehead on the staff, press Alt/OptLeft Arrow .

●

To move them to the right according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Right Arrow .

●

To move them to the left according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Left Arrow .
NOTE
You can only move dynamics according to the current rhythmic grid resolution when
multiple dynamics are selected.

●

Click and drag the dynamic to noteheads to the right/left.

RESULT
The selected dynamics are moved to new rhythmic positions.
NOTE
If a single dynamic passes over another dynamic as part of its move, the existing one is
unaffected as multiple dynamic can exist at the same rhythmic position. However, if you move
multiple dynamics together, any existing dynamics they pass over are deleted.
You can undo this action, but any dynamics deleted in the process are only restored if you moved
dynamics using the keyboard.
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RELATED LINKS
Moving dynamic points on page 519

Moving dynamics graphically
You can move dynamics graphically, without changing the rhythmic positions to which they
apply. When you select hairpins in Engrave mode, three adjustment handles appear at each end.
You can use these handles to lengthen/shorten gradual dynamics graphically.
PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Immediate dynamics or whole gradual dynamics

●

Individual handles on gradual dynamics

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the dynamics or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected dynamics or handles are moved graphically, without affecting the rhythmic
positions to which they are attached.
TIP
The following properties in the Dynamics group of the Properties panel are activated
automatically when you move dynamics in the corresponding directions:
●

Start offset moves immediate dynamics and the start of gradual dynamics. X moves them
horizontally, Y moves them vertically.

●

End offset moves the end of gradual dynamics. X moves them horizontally, Y moves them
vertically.

For example, if you move a whole gradual dynamic upwards, both handles are moved so both
properties are activated. You can also use these properties to move dynamics graphically by
changing the values in the value fields.
Deactivating the properties resets the selected dynamics to their default positions.

RELATED LINKS
Lengthening/Shortening gradual dynamics and groups of dynamics on page 773
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Aligning dynamics
You can graphically align individually selected dynamics in a row without grouping/ungrouping
them, for example, if system breaks in part layouts are different to the full score layout and so
require parts of different groups of dynamics to be aligned, but you do not want to change their
grouping.
PROCEDURE
1.

In Engrave mode, select the dynamics you want to align.

2.

Choose Edit > Dynamics > Align Dynamics. You can also choose this option from the
context menu.

RESULT
The selected dynamics are aligned in a row with the dynamic within the selection that was
furthest from the staff. This does not affect their grouping or their alignment in other layouts.

General placement conventions for hairpins relative to barlines
In Dorico Pro, the ends of hairpins align with the left edge of the note to their right. This can
include hairpins extending across barlines.
Hairpins that end on the first note of a bar extend across the preceding barline in the following
cases:
●

If there is no immediate dynamic on the first note in the next bar.

●

If there is a time signature or key signature change at the barline that increases the gap
between the end of the current bar and the first note in the new bar.

Dorico Pro avoids hairpins overlapping barlines by a small amount, as this is less visually clear.
However, this means that the same dynamic phrase on two different staves can appear
differently if one of the staves does not have a barline join extending below it.
You can allow/disallow hairpins across barlines if the hairpin ends on the first note in the next
bar. Disallowing hairpins across barlines ensures hairpins appear the same length on all staves.
You can also change the minimum distance before hairpins are allowed to extend beyond
barlines.

The ends of the two hairpins are not aligned despite their duration being identical, as the barline does not
extend to the bottom staff of the system.
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Allowing/Disallowing hairpins across barlines
You can allow/disallow hairpins across barlines when they end on the first note in the next bar,
for example, so all hairpins appear the same length across multiple staves that do not all have
barline joins.
PROCEDURE
1.

Select the hairpins you want to allow/disallow across barlines. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Barline interaction in the Dynamics group.

3.

Choose one of the following options:
●

Stop before

●

Continue

RESULT
The selected hairpins are allowed across barlines in the current layout when you choose
Continue, and disallowed in the current layout when you choose Stop before.
Deactivating the property returns the selected hairpins to your project-wide setting.
NOTE
●

Changing the appearance of individual gradual dynamics only affects their appearance in the
current layout, but you can copy property settings to other layouts.

●

You can find the project-wide option that allows/disallows all hairpins to cross barlines by
clicking Advanced Options in the Gradual Dynamics section of the Dynamics page in
Engrave > Engraving Options. You can also change the minimum distance before hairpins
are allowed to extend beyond barlines in the Horizontal Position section of the Dynamics
page.

RELATED LINKS
Copying property settings to other layouts on page 493

Showing dynamics in parentheses
You can show individual dynamics in parentheses, for example, to show editorial dynamics that
were not in the original manuscript.
PROCEDURE
1.

Select the dynamics you want to appear parenthesized. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Parenthesized in the Dynamics group.

RESULT
Each of the selected dynamics is shown in parentheses individually.
Deactivating Parenthesized removes parentheses from the selected dynamics.
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Erasing the background of dynamics
You can erase the background of individual dynamics, for example, to ensure the dynamic
remains legible when crossing barlines. You can erase the backgrounds of all types of dynamics.
PROCEDURE
1.

In Engrave mode, select the dynamics whose backgrounds you want to erase.

2.

In the Properties panel, activate Erase background in the Dynamics group.

RESULT
The backgrounds of the selected dynamics are erased.
Deactivating Erase background returns the selected dynamics to the default non-erased
background.
EXAMPLE

Dynamic with non-erased background

Dynamic with erased background

AFTER COMPLETING THIS TASK
You can change the padding between dynamics and each edge of their erased areas.

Changing the erasure padding of dynamics
You can change the erasure padding of individual dynamics, including changing the padding
between dynamics and each edge of their erased areas independently.
Erasure padding considers the prefix/suffix separately from immediate dynamics and also takes
into account ascenders/descenders in the text. This can cause the erasure padding to appear
larger below the dynamic than above, such as for “espressivo” due to the “p”. In such cases, you
can change the padding on the affected edge to make the padding appear symmetrical.
PROCEDURE
1.

In Engrave mode, select the dynamics whose erasure padding you want to change.

2.

In the Properties panel, activate the Erasure padding properties, individually or together, in
the Dynamics group.

3.

●

L changes the padding between dynamics and their left edge.

●

R changes the padding between dynamics and their right edge.

●

T changes the padding between dynamics and their top edge.

●

B changes the padding between dynamics and their bottom edge.

Change the values in the value fields.

RESULT
Increasing the values increases the padding, decreasing the values decreases the padding. This
also affects the area considered for collision avoidance.
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TIP
You can change the default erasure padding of all dynamics project-wide in the Appearance
section of the Dynamics page in Engrave > Engraving Options. However, this does not allow
you to change the padding of each edge independently.

Copying dynamics
You can copy dynamics to other rhythmic positions after they have been input. You can select
dynamics on a single staff to copy to another single staff, or you can select dynamics across
multiple staves to copy across the same number of staves.
PROCEDURE
1.

In Write mode, select the dynamics you want to copy.
TIP
If you want to copy many dynamics or, for example, just gradual dynamics, you can use a
filter.

2.

Press Ctrl/Cmd-C to copy the dynamics.

3.

Select the notehead at the rhythmic position to which you want to copy the dynamics.

4.

Press Ctrl/Cmd-V to paste the dynamics.

RESULT
The selected dynamics are pasted to new rhythmic positions. If you copied dynamics to other
staves at the same rhythmic position as the original dynamics, the dynamics on all staves are
automatically linked.
If you selected multiple dynamics at different rhythmic positions, their new positions reflect their
original rhythmic spacing.
TIP
●

You can also copy dynamics without adding them to your clipboard by selecting them and
Alt/Opt -clicking each notehead to which you want to copy the selected dynamics.

●

If you want to copy dynamic phrases immediately after where they were originally input, you
can select them and press R . If you select a single immediate dynamic, it is copied to the
same position.

RELATED LINKS
Linked dynamics on page 783
Filters on page 326

Deleting dynamics
You can delete dynamics from your project. If you delete some but not all dynamics from a group
that is linked to dynamics on other staves, all equivalent linked dynamics are also deleted.
PROCEDURE
1.

In Write mode, select the dynamics you want to delete.

2.

Press Backspace or Delete .
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RESULT
The selected dynamics are deleted. If you delete immediate dynamics immediately before/after
hairpins, the length of hairpins can adjust automatically, depending on the context.
NOTE
Deleting dynamics that are linked to other staves can cause the selected dynamics to be deleted
from all linked staves as well. If you do not select and delete all dynamics in the group, the
selected dynamics are also deleted from all linked staves. However, if you select and delete the
whole group of dynamics from a single staff, those dynamics are not deleted from other staves.

RELATED LINKS
Groups of dynamics on page 782
Linked dynamics on page 783

Voice-specific dynamics
Voice-specific dynamics only apply to a single voice on a staff, which allows you to specify
different dynamics for each voice in multiple-voice contexts.
Inputting voice-specific dynamics allows you to show different dynamics for multiple voices on a
staff, or to highlight an inner melody voice in a piano texture. They change the dynamics of each
voice in playback.
NOTE
●

You can only input voice-specific dynamics when the caret is active, such as during note
input. Voice-specific dynamics apply to the voice indicated by the quarter note symbol beside
the caret.

●

Voice-specific dynamics only affect playback automatically for sounds that use velocity to
control dynamics. When using playback devices that control dynamics in other ways, such as
with CC, you must enable independent voice playback to hear different dynamics in different
voices for the same instrument.

RELATED LINKS
Input methods for dynamics on page 241
Enabling independent voice playback on page 543
Dynamics lanes on page 513

Niente hairpins
Niente markings at the start/end of gradual dynamics indicate that the dynamic either increases
from, or decreases to, silence.
This effect works very well on strings and singers with vowels, but it cannot always be played
literally. For example, singers with words beginning with consonants cannot begin from silence,
nor can reed and brass instruments, as they have to achieve a certain air pressure before a note
sounds.
Niente markings can be shown in two ways: as a circle at the end of a hairpin, and as text directly
before or after a hairpin. You can input both types of niente markings in Dorico Pro using the
dynamics popover and by clicking niente in the Gradual Dynamics section of the Dynamics
panel.
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TIP
You can turn existing hairpins into niente hairpins by selecting them and clicking niente in the
Gradual Dynamics section of the Dynamics panel, or by activating Niente in the Dynamics
group of the Properties panel.
EXAMPLE

A niente shown as Circle on hairpin

A niente shown as Text

RELATED LINKS
Lengthening/Shortening gradual dynamics and groups of dynamics on page 773
Input methods for dynamics on page 241

Changing the appearance of individual niente hairpins
You can show niente hairpins in two ways in Dorico Pro, and you can change how they appear
individually, independently of your project-wide setting.
PROCEDURE
1.

Select the hairpins whose niente style you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Niente style in the Dynamics group.

3.

Choose one of the following options:
●

Circle on hairpin

●

Text

RESULT
The niente style of the selected hairpins is changed.
TIP
You can change how all niente hairpins appear project-wide in the Gradual Dynamics section of
the Dynamics page in Engrave > Engraving Options.
EXAMPLE

A niente shown as Circle on hairpin

A niente shown as Text
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RELATED LINKS
Project-wide engraving options for dynamics on page 761

Dynamic modifiers
Modifiers add further detail to dynamics than simply their volume level, and can help guide how
a player performs a note or phrase. Modifiers include poco a poco, molto and subito. They are also
known as “expressive text”.
In Dorico Pro, modifiers must accompany a dynamic level, such as  or .
NOTE
You cannot input dynamic modifiers on their own. However, you can hide the immediate
dynamic that follows or precedes them.
You can input dynamic modifiers by entering them into the dynamics popover alongside an
immediate dynamic or by clicking available options in the Immediate Dynamics section of the
Dynamics panel. You can also add them to existing dynamics by entering the text you want into
one of the following properties in the Dynamics group of the Properties panel:
●

Prefix: Adds modifiers before existing dynamics.

●

Suffix: Adds modifiers after existing dynamics.

RELATED LINKS
Hiding immediate dynamics on page 772

Adding modifiers to existing dynamics
You can add modifiers both before and after dynamics after they have been input, for example, if
you want to add “sim.” instead of repeating dynamics across multiple phrases.
PROCEDURE
1.

Select the dynamics to which you want to add modifiers. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Dynamics group:
●

Prefix

●

Suffix

3.

Enter the text you want to add into the corresponding value field.

4.

Press Return .

RESULT
The text you entered is added to the selected dynamics as a modifier. Text entered into the
Prefix field appears before dynamics, while text entered into the Suffix field appears after
dynamics. Modifiers appear below hairpins placed below the staff and above hairpins placed
above the staff, and are aligned with the start of the hairpin.
Deactivating the properties removes the corresponding modifiers from the selected dynamics.
NOTE
Deactivating properties permanently deletes any custom text entered.
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AFTER COMPLETING THIS TASK
If you added modifiers to hairpins, you can show them centered inside the hairpins.
RELATED LINKS
Niente hairpins on page 769
Input methods for dynamics on page 241
Adding poco a poco text to gradual dynamics on page 779
Showing modifiers centered inside hairpins on page 780

Hiding immediate dynamics
You can hide immediate dynamics such as  and , for example, if you only want to show the
dynamic modifier, such as “sim.”, without its accompanying immediate dynamic.
PROCEDURE
1.

Select the immediate dynamics you want to hide. You can do this in Write mode and Engrave
mode.

2.

In the Properties panel, activate Hide intensity marking in the Dynamics group.

RESULT
The selected immediate dynamics are hidden. If no other dynamic exists at their rhythmic
position, they are indicated by signposts. However, signposts are not printed by default.
Deactivating Hide intensity marking shows the selected immediate dynamics again.

Gradual dynamics
Gradual dynamics indicate a change in volume that happens incrementally over the specified
duration. They usually appear either as hairpins or as text instructions, such as cresc. or dim..
A pair of hairpins without an immediate dynamic in the middle is known as a messa di voce.
In Dorico Pro, gradual dynamics appear as hairpins by default. You can change the appearance
of individual gradual dynamics and their default appearance project-wide. For example, if you
want to show a particularly long crescendo using cresc. text rather than a hairpin.
You can also show two or more consecutive hairpins of the same direction that are separated by
immediate dynamics as a single, continuous hairpin.
NOTE
Changing the appearance of individual gradual dynamics only affects their appearance in the
current layout, but you can copy property settings to other layouts.
In Engrave mode, hairpins have three square handles at both the start and end:
●

The middle handles at the start/end change the offset position of the start/end of the
hairpin.

●

The pair of outer handles at the start/end adjusts the aperture of the corresponding end of
the hairpin.

A hairpin with the start middle handle selected in Engrave mode
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You can use these handles to change the angle of hairpins.
RELATED LINKS
Types of dynamics on page 760
Changing the angle of hairpins on page 776
Changing the aperture of hairpins on page 777

Lengthening/Shortening gradual dynamics and groups of dynamics
You can change the length of gradual dynamics and groups of dynamics after they have been
input.
NOTE
You can only lengthen/shorten one gradual dynamic or group of dynamics at a time.

PROCEDURE
1.

2.

In Write mode, select one of the following that you want to lengthen/shorten:
●

A single gradual dynamic

●

A single gradual dynamic in a group of dynamics

Lengthen/Shorten the gradual dynamic or groups of dynamics in any of the following ways:
●

To lengthen them by the current rhythmic grid resolution or to the next notehead,
whichever is closer, press Shift-Alt/Opt-Right Arrow .

●

To shorten them by the current rhythmic grid resolution or to the previous notehead,
whichever is closer, press Shift-Alt/Opt-Left Arrow .

●

To lengthen them to the next notehead, press Ctrl/Cmd-Shift-Alt/Opt-Right Arrow .

●

To shorten them to the previous notehead, press Ctrl/Cmd-Shift-Alt/Opt-Left Arrow .
NOTE
When using the keyboard, you can only move the end of dynamics. You can move the
start of dynamics by moving the whole dynamic, or by clicking and dragging the start
handle.

●

Click and drag the circular handle at the start/end to the right/left.

RESULT
Individual gradual dynamics are lengthened/shortened either according to the current rhythmic
grid resolution or to next/previous noteheads.
Dynamic groups are lengthened/shortened proportionally by lengthening/shortening the
gradual dynamics and moving any other type of dynamic in the group. This retains the relative
durations of the gradual dynamics in the group.
In the example, the  at the end moves two quarter notes to the right, but the  in the middle
only moves one quarter note to the right. This keeps the lengths of the gradual dynamics equal.
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EXAMPLE

Original dynamic phrase

Lengthened dynamic phrase

RELATED LINKS
Groups of dynamics on page 782
Positions of dynamics on page 761
Ungrouping dynamics and removing dynamics from groups on page 783

Changing the appearance of gradual dynamics
You can change the appearance of individual gradual dynamics, for example, to change a
crescendo hairpin to a messa di voce pair of hairpins with two directions or to show a particularly
long crescendo using “cresc.” text rather than a hairpin.
PROCEDURE
1.

Select the gradual dynamics whose appearance you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Gradual style in the Dynamics group.

3.

Select one of the following options from the menu:

4.

5.

●

Hairpin

●

cresc./dim.

●

cresc...

●

cre - scen - do

Optional: Customize the appearance of the selected gradual dynamics in one of the following
ways, depending on their Gradual style:
●

If you selected Hairpin, activate Hairpin line style and choose one of the available
options.

●

If you selected cresc./dim., cresc..., or cre - scen - do, activate Diminuendo style and
select one of the available options from the menu.

●

If you selected cresc..., activate Continuation line style and choose one of the available
options.

Optional: For hairpin gradual dynamics, choose one of the following options for Type
●

Cresc. or dim.

●

Messa di voce

RESULT
The appearance of the selected gradual dynamics is changed in the current layout.
NOTE
●

Changing the appearance of individual gradual dynamics only affects their appearance in the
current layout, but you can copy property settings to other layouts.

774
Dorico Pro 3.1.10

Dynamics
Gradual dynamics
●

You can change the default appearance of all gradual dynamics project-wide on the
Dynamics page in Engrave > Engraving Options.

EXAMPLE

Hairpin

cresc./dim.

cresc….

cre-scen-do

RELATED LINKS
Copying property settings to other layouts on page 493

Showing consecutive hairpins as continuous
You can show two or more consecutive hairpins of the same direction that are separated by
immediate dynamics as a single hairpin that continues through any immediate dynamics, for
example, to indicate that you want a single smooth change in dynamic rather than multiple
separate ones.
PREREQUISITE
The hairpins are grouped together.
PROCEDURE
1.

In Engrave mode, select at least one of the hairpins in each group that you want to show as
continuous.

2.

In the Properties panel, activate Hairpin shown as continuation in the Dynamics group.

3.

Activate the corresponding checkbox.

RESULT
Consecutive hairpins of the same direction in the selected groups appear as a single continuous
hairpin in the current layout.
NOTE
This only affects the appearance of hairpins in the current layout, but you can copy property
settings to other layouts.
EXAMPLE

Hairpin shown as continuation

Hairpin not shown as continuation

RELATED LINKS
Grouping dynamics together on page 782
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Changing the angle of hairpins
By default, hairpins are horizontal and are automatically adjusted to avoid collisions with other
objects, such as noteheads and slurs. You can change the angle of individual hairpins as required
for your music.
NOTE
Changing only the start offset position with the keyboard or activating Start offset only changes
the vertical position of the whole hairpin not its angle. You must change the end offset position
or activate End offset as well to change the angle of hairpins.
Dragging handles with the mouse always changes the angle.

PROCEDURE
1.

In Engrave mode, select the middle handles of the hairpins whose angle you want to change.
TIP

2.

●

The hairpins you select do not have to be the same direction, or on the same staff.

●

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

Move the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag them upwards/downwards.

RESULT
The angle of the selected hairpins is changed. Each end can be moved independently of the
other.
TIP
The following properties in the Dynamics group of the Properties panel are activated
automatically when you move the corresponding handles on hairpins vertically:
●

Start offset Y moves the start handles of hairpins vertically.

●

End offset Y moves the end handles of hairpins vertically.

For example, if you move a whole hairpin upwards, both handles are moved so both properties
are activated. You can also use these properties to change the angles of hairpins by changing the
values in the value fields.
Deactivating the properties resets the selected hairpins to their default positions.
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Changing the aperture of hairpins
The change in volume indicated by individual hairpins is shown in the distance between the two
lines that make up hairpins at their apertures. You can change the aperture of hairpins
individually.
Hairpins typically have a closed end and an open end. If the hairpin crosses a system or frame
break, the closed end can appear with a small gap so that the hairpin is not misread as two
separate hairpins.
In Dorico Pro, you can use the pair of outer handles at the start/end of hairpins in Engrave mode
to change the aperture. These handles are linked and mirror each other: moving one handle also
moves the other handle by the same amount, but in the opposite direction. This ensures that
hairpins remain symmetrical.

A hairpin with the outer handle selected in Engrave mode

PROCEDURE
1.

In Engrave mode, select one of the outer handles of the hairpins whose aperture you want
to change.
TIP

2.

●

The hairpins you select do not have to be the same direction, or on the same staff.

●

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

Change the distance between the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag them upwards/downwards.

RESULT
The apertures of the selected hairpins are changed.
TIP
●

You can also change the aperture of individual hairpins by activating Hairpin open aperture
and/or Hairpin closed aperture in the Dynamics group of the Properties panel.
Increasing the value makes the corresponding aperture wider. Decreasing the value makes
the corresponding aperture narrower.

●

You can find options to set minimum and maximum values for the width of hairpin apertures
project-wide, including for hairpins across system and page breaks, by clicking Advanced
Options in the Hairpins subsection of the Gradual Dynamics section of the Dynamics page
in Engrave > Engraving Options.
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EXAMPLE

A diminuendo that goes across a system break:
aperture at the start is open, aperture at the end is
closed. It appears slightly open to indicate the
diminuendo continues after the system break.

The diminuendo continues onto a new system:
aperture at the start is open, aperture at the end is
closed.

Hiding/Showing flared ends on hairpins
Flared ends are usually shown at the end of crescendo hairpins and indicate a sudden burst in
volume at the end of the crescendo. You can hide/show flared ends on any hairpin.
NOTE
You can only show flared ends on hairpins with solid lines.

PROCEDURE
1.

Select the hairpins on which you want to hide/show flared ends. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Flared end in the Dynamics group.

RESULT
A flared end is shown on the selected dynamics when Flared end is activated, and hidden when
it is deactivated.
EXAMPLE

Crescendo hairpin with flared end hidden

Crescendo hairpin with flared end shown

Changing the size of flared ends on hairpins
You can change the height and width of flared ends on individual hairpins.
PROCEDURE
1.

In Engrave mode, select the flared hairpins whose flare size you want to change.

2.

In the Properties panel, activate Flare size in the Dynamics group.

3.

Change the value for W to change the width of the flared ends.

4.

Change the value for H to change the height of the flared ends.

778
Dorico Pro 3.1.10

Dynamics
Gradual dynamics
RESULT
Increasing the W value makes the selected flared ends wider by starting their angle earlier in the
hairpin, decreasing the value makes the selected flared ends narrower.
Increasing the H value makes the selected flared ends taller, decreasing the value makes them
shorter.
Changing the values independently of each other changes the angle of the flared ends. For
example, increasing the W value without changing the H value makes the angle shallower.
TIP
You can change the default design and size of all flared hairpins project-wide in the Gradual
Dynamics section of the Dynamics page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for dynamics on page 761
Changing the aperture of hairpins on page 777

Adding poco a poco text to gradual dynamics
You can add poco a poco text to individual gradual dynamics after they have been input.
PROCEDURE
1.

Select the gradual dynamics to which you want to add poco a poco. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Poco a poco (little by little) in the Dynamics group.

RESULT
Poco a poco is shown immediately after gradual dynamic text, below hairpins placed below the
staff, and above hairpins placed above the staff.
Deactivating Poco a poco (little by little) removes poco a poco text from the selected gradual
dynamics.
EXAMPLE

Text gradual dynamic with poco a poco

Hairpin gradual dynamic with poco a poco

AFTER COMPLETING THIS TASK
You can show poco a poco text centered inside hairpins.
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Showing modifiers centered inside hairpins
You can show modifiers you have added to hairpins, such as poco a poco or molto, centered both
horizontally and vertically inside hairpins. By default, modifiers appear at the start of and either
above or below hairpins.
PROCEDURE
1.

Select the hairpins whose modifiers you want to show centered inside hairpins. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Modifier position in the Dynamics group.

3.

Choose one of the following options:
●

Above or Below

●

Inside

RESULT
Modifiers on the selected hairpins appear centered inside the hairpins. They automatically erase
their background so the text does not collide with the hairpin lines.
NOTE
●

This only affects the position of modifiers in the current layout, but you can copy property
settings to other layouts.

●

You can change the default position of all modifiers relative to hairpins in the Gradual
Dynamics section of the Dynamics page in Engrave > Engraving Options.

●

You can change the erasure padding of modifiers centered inside hairpins, both individually
and by changing your default settings.

EXAMPLE

Modifier (molto) below a hairpin

Modifier (molto) centered inside hairpin

RELATED LINKS
Adding modifiers to existing dynamics on page 771
Project-wide engraving options for dynamics on page 761
Changing the erasure padding of dynamics on page 767
Copying property settings to other layouts on page 493

Gradual dynamic spacing
Dorico Pro ensures that hairpins can always be clearly distinguished by giving hairpins a
minimum default length. However, this can affect note spacing.
The default minimum hairpin length is three spaces. When hairpins are shorter than this, they
can sometimes be confused with the accent articulation mark. Therefore, if you add a hairpin to a
note which would make the hairpin less than three spaces long, the spacing of the note is
changed to ensure the hairpin meets the minimum length.
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You can change the minimum length of hairpins by changing the value for Minimum length for
hairpins, which you can find by clicking Advanced Options in the Hairpins subsection of the
Gradual Dynamics section of the Dynamics page in Engrave > Engraving Options.

Gradual dynamics that start/end partway through notes
If the start/end of a gradual dynamic is not attached to a note, there are restrictions on how you
can move the start/end position.
For example, if you enter two hairpins separated by a space into the dynamics popover, pair of
hairpins that looks like a messa di voce is created but containing two separate hairpins, rather
than the combined option. Neither of the open ends of the hairpins is attached to a specific
notehead, and you cannot move the center of the pair of hairpins rhythmically. You can
lengthen/shorten the two hairpins as a group but you cannot lengthen/shorten each hairpin
individually.

However, if you enter two hairpins without a space between them into the dynamics popover,
you can move the center of the pair of hairpins and each hairpin rhythmically, but only to
noteheads. You can lengthen/shorten each hairpin separately according to the current rhythmic
grid resolution.
You can move individual hairpins in Engrave mode to any graphical position. If you input hairpins
separated by a space into the popover, you can move each hairpin independently, for example, if
you want to adjust the graphical peak of the pair of hairpins. You cannot move the graphical
peak of messa di voce hairpins, except by adjusting the note spacing. However, moving dynamics
graphically does not affect dynamics in playback.
RELATED LINKS
Lengthening/Shortening gradual dynamics and groups of dynamics on page 773
Moving dynamics graphically on page 764
Note spacing on page 425
Adjusting note spacing at individual rhythmic positions on page 429

Gradual dynamics truncated by immediate dynamics
A hairpin is automatically truncated if an immediate dynamic is positioned within its range, either
before or after the hairpin is input.
The hairpin remains tied to its originally designated rhythmic positions, even if graphically it
appears shorter. This means that if the immediate dynamic that truncated it is ever deleted, the
hairpin extends up to its end or the next immediate dynamic within its range.
The examples demonstrate a crescendo hairpin that is truncated by two dynamics, but the
hairpin extends to its total length as they are deleted. The dotted attachment line shows the link
between the hairpin and the rhythmic position to which its end is attached.

A long hairpin truncated by a p

After deleting the p, the hairpin is
now truncated by the f
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Groups of dynamics
Groups of dynamics are automatically aligned in a row and can be moved and edited as a group.
When you move immediate dynamics within a group, the length of the hairpins on either side
automatically adjust to compensate.

A group of dynamics

The same group of dynamics adjusts to compensate
when the middle dynamic moves rhythmically.

A single dynamic, either immediate or gradual, is considered a group on its own.
Two or more dynamics are automatically grouped together if they immediately follow each other
horizontally on the staff, were input together or in sequence, and have gradual dynamics
between the immediate dynamics.
All of the dynamics in a group are highlighted when any of the dynamics in the group are
selected.

NOTE
●

Groups of dynamics apply project-wide, meaning you cannot have dynamics grouped one
way in some layouts but differently in other layouts. However, you can graphically align
selected dynamics independently of their groups.

●

As well as horizontal groups of dynamics, you can also link groups of dynamics across staves
if you want the same dynamics to appear on multiple staves. This can be useful when
multiple instruments play the same dynamics simultaneously and you want to make the
same change in all staves, for example, moving the peak of a crescendo to a later beat, or
changing a  to a .

RELATED LINKS
Linked dynamics on page 783
Aligning dynamics on page 765

Grouping dynamics together
You can manually group dynamics together that were not automatically grouped when they were
input. Grouped dynamics are automatically aligned in a row and can be moved and edited as a
group.
PROCEDURE
1.

In Write mode, select the dynamics you want to group together.

2.

Choose Edit > Dynamics > Group Dynamics. You can also choose this option from the
context menu.

782
Dorico Pro 3.1.10

Dynamics
Linked dynamics
RESULT
The selected dynamics are grouped together. If the first dynamic in the group is linked to other
staves, all dynamics in the group are added to those staves. This applies to all layouts in which
the dynamics appear.
RELATED LINKS
Linked dynamics on page 783

Ungrouping dynamics and removing dynamics from groups
You can ungroup dynamics so that all dynamics in the group become ungrouped. You can also
remove only selected dynamics from groups while leaving other dynamics in the group.
This applies to all layouts in which the dynamics appear.
PROCEDURE
1.

In Write mode, select the dynamics you want to ungroup or remove from groups.

2.

Do one of the following:
●

To ungroup all dynamics in the selected groups, choose Edit > Dynamics > Ungroup
Dynamics.

●

To remove only the selected dynamics from their groups, choose Edit > Dynamics >
Remove from Group.

TIP
You can also choose these options from the context menu.

Linked dynamics
Identical dynamics at the same rhythmic position on multiple staves can be linked together. This
happens automatically when you copy and paste dynamics between staves.
If you select one dynamic in a linked group, all other dynamics in the linked group appear
highlighted. If one linked dynamic is moved to a new rhythmic position, all linked dynamics
move.

Two linked dynamics with only the top dynamic
selected

Moving just the top dynamic of the linked group
automatically moves the other to match its new
position.

Similarly, if you change one linked dynamic, for example, from  to , all dynamics linked to the
changed dynamic are also changed.
If you group other dynamics to one of the linked dynamics, such as a hairpin, the hairpin is
added at the same position in all linked staves.
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If one staff has another immediate dynamic before the end of a hairpin, the hairpin is truncated
automatically. If you delete such a dynamic, the hairpin extends automatically up to the next
immediate dynamic or to its full length, whichever comes first.

Two staves with linked dynamics, but the lower staff
has another immediate dynamic that truncates the
hairpin.

Deleting the mf at the end of the first bar in the
second staff causes the hairpin to extend to match
the range of the top staff.

NOTE
●

If you delete only some dynamics from a group that is linked to other staves, those dynamics
are also deleted from the linked staves. If you delete a whole dynamic group from one staff,
this does not affect linked dynamics on other staves.

●

As well as vertically linked dynamics, you can also group dynamics horizontally. This
automatically aligns the dynamics in a row and allows them to be moved and edited as a
group.

●

Linking or unlinking dynamics applies project-wide, meaning you cannot have dynamics
linked one way in some layouts but differently in other layouts.

RELATED LINKS
Groups of dynamics on page 782
Disabling automatic linking of dynamics and slurs when pasting on page 329

Linking dynamics together
When you copy and paste identical dynamics to the same rhythmic position on other staves,
those dynamics are linked together automatically. You can also manually link dynamics and
groups of dynamics together that are not automatically linked to allow simultaneous editing.
NOTE
Groups of dynamics must be the same in order to link them together. For example, you can link
two  dynamics together if neither is part of a group, but you cannot link them together if one is
grouped with a hairpin.

PROCEDURE
1.

In Write mode, select the dynamics you want to link together.

2.

Choose Edit > Dynamics > Link. You can also choose this option from the context menu.

RESULT
The selected dynamics are linked together. If you later change one of the linked dynamics, all
linked dynamics are changed to match. This applies to all layouts in which the dynamics appear.
RELATED LINKS
Copying dynamics on page 768

784
Dorico Pro 3.1.10

Dynamics
Dynamics font styles

Unlinking dynamics
You can unlink dynamics, including dynamics that were linked automatically.
PROCEDURE
1.

In Write mode, select a dynamic in each linked group that you want to unlink.

2.

Choose Edit > Dynamics > Unlink. You can also choose this option from the context menu.

RESULT
All dynamics in the linked groups are unlinked. This applies to all layouts in which the dynamics
appear.
RELATED LINKS
Disabling automatic linking of dynamics and slurs when pasting on page 329

Dynamics font styles
You can change different aspects of the fonts used for dynamics in the Edit Font Styles dialog.
There are different font styles for different types of dynamics.
The following fonts affect the appearance of dynamics:
●

Dynamic Music Text Font: Used for dynamic glyphs, such as  and .

●

Dynamic Text Font: Used for dynamic modifiers and gradual dynamics shown as text.

NOTE
Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Edit Font Styles dialog on page 407
Dynamic modifiers on page 771

Editing the dynamic modifier font style
You can edit the formatting of the font that affects the appearance of dynamic modifiers, such as
poco a poco and molto.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2.

Select Dynamic Text Font from the Font style menu.

3.

Activate the following options, individually or together, to change the corresponding aspect
of the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The formatting of the default font used for dynamic modifiers is changed.
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Editing the dynamic glyph font style
You can edit the formatting of the font used for dynamic glyphs, such as  or . However, you
must choose a SMuFL-compliant font.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2.

Select Dynamic Music Text Font from the Font style menu.

3.

Activate the following options, individually or together, to change the corresponding aspect
of the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The formatting of the font used for dynamic glyphs is changed project-wide.

Playback Options for dynamics
You can change settings for how dynamics are interpreted in playback by making adjustments to
the scale of the graphical curve on the Dynamics page in Play > Playback Options.

Dynamic Curve
The graph at the top of the Dynamics page in Playback Options maps a continuous curve. This
curve determines how the volume of dynamics increases across the range  to .
A dynamic curve power of 1 creates a straight line, producing a steady dynamic increase. The
difference between  and  is the same as between  and .
A dynamic curve power higher than 2 creates a curved line, producing a faster dynamic increase
in the middle of the range. The difference between  and  is much smaller than the
difference between  and .
The higher the dynamic curve power, the greater the contrast between dynamics in the middle of
the range, and the smaller the contrast between dynamics at the ends of the range.
If your project uses a wide range of dynamics, including dynamics such as  and , you
might want a lower curve power with larger differences between the extremes of the range.
If your project has a smaller range of dynamics, such as a minimum of  to a maximum of ,
you might prefer a higher curve power, so the differences between the dynamics in the middle of
the range are more discernible.
NOTE
Changing the dynamic curve affects the playback of all instruments in the project.

Note Dynamics
In the Note Dynamics section of the Dynamics page, you can set how much the volume of notes
in playback is affected by stresses and articulation marks.
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Humanize
Humanize allows dynamics to vary randomly by the degree you set to mimic the natural
fluctuations in a live performance.
RELATED LINKS
Playback Options dialog on page 502
Dynamics lanes on page 513

Sustaining and non-sustaining instruments
The volume settings for sustaining instruments and non-sustaining instruments vary in terms of
their control of gradual dynamics.
Sustaining instruments
Sustaining instruments include string, wind, and brass instruments, because they can
hold a note while being in control of its volume throughout.
Dorico Pro applies gradual dynamics to these instruments in playback. You can control
settings for each software instrument by choosing Play > Expression Maps and
selecting software instruments from the list on the left.
Non-sustaining instruments
Non-sustaining instruments, such as piano, harp, marimba, and most percussion
instruments, have no further control of the dynamic of notes after they have been
struck. For this reason, non-sustaining software instruments often use note velocity for
dynamics, because this is set at the start of the note.
TIP
You can control settings for each software instrument in the Expression Maps dialog.

RELATED LINKS
Expression Maps dialog on page 574

VST Expression Maps for volume types
If you are using a third-party sound library, you may need to change or edit the expression map
to make instruments respond to gradual dynamics. Otherwise, the sound library uses velocity by
default.
The setup of the expression map for dynamics depends on how the instrument is configured.
Consult the documentation for the sound library for further information.
Dorico Pro provides the following default expression maps:
●

CC11 Dynamics for dynamics produced by changing MIDI channel expression

●

Modulation Wheel Dynamics for dynamics produced by changing MIDI controller 1

TIP
You can edit expression maps in the Expression Maps dialog.
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Fingerings can be added to music to recommend which fingers players should use for notes. This
can be useful for music aimed at players learning the instrument and for difficult musical
passages where certain fingering patterns make the notes much easier to play.
Fingerings are often used in keyboard music, as players can use all ten fingers to play notes, and
in guitar music, where fingerings are often used alongside fret positions. However, fingerings
can also be useful for other instruments, for example, to indicate that string players should
change the finger used to stop the string while holding the note, or to instruct wind players to
use uncommon fingerings for particular notes in order to create a special sonic effect.

Piano music containing multiple fingerings, including a substitution fingering and alternative fingerings

Dorico Pro also provides fingerings for brass instruments. For example, you can specify which
valves players should depress for instruments such as trumpet and horn, and you can specify the
horn branch you want players to use for double horns.
Fingerings in Dorico Pro use a bold roman font by default, following accepted conventions for
the appearance of fingerings. You can change the font used for fingerings project-wide and edit
the formatting of fingering font styles.
RELATED LINKS
Inputting fingerings on page 213
Fingerings popover on page 214
Fingering font styles on page 796
Changing the font used for fingerings project-wide on page 797
Editing the fingering font styles on page 797
Hiding/Showing fingering on page 795
String indicators on page 813

General placement conventions for fingering
Fingerings are placed as close as possible to the notes to which they apply, so the performer can
read them easily and clearly.
In music for grand staff instruments, such as the piano and harp, it is accepted to place
fingerings for the right hand above the top staff, and fingerings for the left hand below the
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bottom staff. However, in dense contrapuntal music for these instruments, fingerings can be
placed between the staves to follow the direction of the voices to which they apply.
Different conventions apply to fingerings for fretted instruments, as they require fingerings for
both the right and left hands.

Right-hand fingering placement
By default, all right-hand fingerings are placed outside the staff and on the notehead side of
notes, which can be above or below the staff depending on the stem direction. When shown
beside notes inside the staff, Dorico Pro automatically joins adjacent notes with the same righthand fingering with a bracket.

Left-hand fingering placement
Left-hand fingerings are usually positioned inside the staff and to the left of the notes to which
they apply. However, they also must not collide with other items, such as accidentals and rhythm
dots. Dorico Pro automatically calculates the most appropriate positions for left-hand fingerings
and erases their backgrounds by default, which improves their readability when placed on staff
lines.
RELATED LINKS
Fingerings for fretted instruments on page 800
Changing the position of left-hand fingerings on page 802
Hiding/Showing brackets for right-hand fingerings on page 801

Project-wide engraving options for fingerings
You can find options for the project-wide appearance and position of fingerings on the Fingering
page in Engrave > Engraving Options.
The options on the Fingering page allow you to change the font, size, appearance, placement,
and precise position of fingerings on standard notes, cross-staff chords, and grace notes,
including fine adjustments for the different instrument groups, such as brass instruments and
fretted instruments, and the design of enclosures around fingerings and lines beneath
fingerings. There are separate options controlling the position of fingerings shown inside the
staff, and you can also change the position of fingerings relative to slurs, octave lines, and
tuplets.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Changing fingerings to substitution fingerings
Substitution fingerings indicate where players should change the finger used for the note. You
can change existing fingerings to substitution fingerings.
PROCEDURE
1.

Select the fingerings you want to change to substitution fingerings. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Substitution in the Fingering and Positions group.

3.

Enter the fingering you want for the substitution into the value field.
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4.

Press Return .

RESULT
The selected fingerings are now shown as substitution fingerings. The deferred position of the
substitution is the same as the original fingering by default, but you can change the rhythmic
position of substitution fingerings.

Changing the rhythmic position of substitution fingerings
Substitution fingerings are shown as immediate by default, meaning that the substitution takes
place on the same note, but you can change the rhythmic position at which individual
substitutions take place.
PROCEDURE
1.

Select the substitution fingering whose deferred rhythmic position you want to change. You
can do this in Write mode and Engrave mode.

2.

Change the rhythmic position of the substitution fingering in any of the following ways:
●

In Write mode, click and drag the circular handle to the right/left.

●

In Write mode and Engrave mode, activate Substitution offset in the Fingering and
Positions group of the Properties panel.
Change the rhythmic position of substitutions as fractions of a quarter note (crotchet) by
entering a value into the left value field, or by clicking the arrows beside the value field.
Increasing the value moves substitutions to later positions, decreasing the value moves
them to earlier positions.
NOTE
The right value field is for the grace note position at which substitutions occur, if
applicable.

RESULT
The rhythmic position of the substitution fingering is changed.
Dorico Pro automatically arranges deferred substitutions so they are ordered appropriately
alongside any fingerings that coincide with the substitution.
NOTE
You can only change the position of single substitution fingerings when dragging their handles
with the mouse. However, you can change the positions of multiple substitution fingerings with
Substitution offset in the Fingering and Positions group of the Properties panel.
Deferred substitutions are always shown with horizontal lines, even if you have chosen to show
immediate substitutions with slurs.

RELATED LINKS
Fingerings popover on page 214
Project-wide engraving options for fingerings on page 789
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Changing existing fingerings
You can change fingerings after you have input them, for example, if you decide a different
fingering would be better.
PROCEDURE
1.

Select the fingerings you want to change. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, enter the new fingering you want into the Finger or position value
field in the Fingering and Positions group.

3.

Press Return .

RESULT
The selected fingerings are changed.
TIP
You can also change existing fingerings in Write mode by opening the fingerings popover. Any
existing fingerings on the selected note are shown in the popover.

RELATED LINKS
Inputting fingerings on page 213
Fingerings popover on page 214

Moving fingerings graphically
You can move fingerings graphically, independently of the noteheads to which they apply.
NOTE
You cannot move fingerings to different rhythmic positions as they are intrinsic parts of notes. If
you want to move fingerings to other noteheads, you must delete the existing fingerings and reinput them on the noteheads to which you wanted to move them.

PROCEDURE
1.

In Engrave mode, select the fingerings you want to move graphically.

2.

Move the fingerings in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The fingerings are moved to new graphical positions.
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TIP
Offset in the Fingering and Positions group of the Properties panel is activated automatically
when you move fingerings.
●

Offset X moves fingerings horizontally.

●

Offset Y moves fingerings vertically.

You can also use this property to move fingerings by changing the values in the value fields.
Deactivating the property resets the selected fingerings to their default positions.

Resetting the positions of fingerings
You can reset the positions of individual fingerings whose graphical positions you have moved.
PROCEDURE
1.

In Engrave mode, select the fingerings whose positions you want to reset.

2.

Reset their positions in any of the following ways:
●

Choose Edit > Reset Position.

●

In the Properties panel, deactivate Offset in the Fingering and Positions group.

Changing the staff-relative placement of fingerings
Dorico Pro automatically follows conventions for fingering placement, but you can show
individual fingerings belonging to non-fretted instruments either above or below the staff,
independently of your project-wide setting.
According to convention, keyboard instrument fingering is positioned above the right-hand staff,
and below the left-hand staff. String and brass instrument fingering is always positioned above
the staff.
NOTE
These steps only apply to non-fretted instruments.

PROCEDURE
1.

Select the fingerings whose staff-relative placement you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Staff-relative position in the Fingering and Positions
group.

3.

Choose one of the following options:
●

Above

●

Below

RESULT
The selected fingerings appear above/below the staff.
TIP
●

You can also change the staff-relative placement of fingerings by selecting them in Engrave
mode and pressing F .
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●

You can change the staff-relative placement of all fingerings project-wide to follow voice
directions on the Fingering page in Engrave > Engraving Options.
This can be useful in complex contrapuntal music where fingering may not be clear if it is
only placed above the top staff and below the bottom staff.

RELATED LINKS
Fingerings for fretted instruments on page 800
Project-wide engraving options for fingerings on page 789

Showing fingerings inside the staff
You can show individual fingerings belonging to non-fretted instruments beside noteheads
inside the staff.
NOTE
●

These steps only apply to non-fretted instruments. Left-hand fingerings for fretted
instruments are shown inside the staff by default.

●

These steps do not apply to substitution fingerings.

PROCEDURE
1.

Select the notes whose fingerings you want to show inside the staff. You can do this in Write
mode and Engrave mode, but in Engrave mode you must select the fingerings.

2.

In the Properties panel, activate Inside staff in the Fingering and Positions group.

RESULT
Fingerings belonging to the selected notes are shown inside the staff, directly beside the
noteheads. By default, if they belong to a note on a staff line, they erase part of the staff line to
ensure legibility.
TIP
You can find project-wide options controlling the erasure padding and size of fingerings shown
inside the staff by clicking Advanced Options in the Design section of the Fingering page in
Engrave > Engraving Options. You can also change how fingerings shown to the left of notes
avoid collisions in the Position section.
EXAMPLE
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Changing the position of individual fingerings relative to slurs,
octave lines, and tuplet brackets
By default, fingerings are positioned inside the arcs of slurs, but outside the start/end of slurs.
You can change the position of fingerings relative to individual slurs, independently of your
project-wide settings.
PROCEDURE
1.

In Engrave mode, select the fingerings whose position relative to slurs you want to change.

2.

In the Properties panel, activate Slur-relative position in the Fingering and Positions
group.

3.

Choose one of the following options:
●

Inside

●

Outside

RESULT
The position of the selected fingerings relative to slurs, octave lines, and tuplet brackets is
changed.
NOTE
●

If fingerings also coincide with the first note or last note of slurs, fingerings are positioned
outside all of these notations.

●

You can change the position of all fingerings relative to slurs, octave lines, and tuplet
brackets project-wide on the Fingering page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for fingerings on page 789

Changing the size of fingerings
You can change the size of fingerings individually, without changing the size of the noteheads to
which they apply.
PROCEDURE
1.

In Engrave mode, select the fingerings whose size you want to change.

2.

In the Properties panel, activate Scale in the Fingering and Positions group.

3.

Change the value in the value field.

4.

Press Return .

RESULT
The scale size of the selected fingerings is changed. For example, changing the value to 50 scales
the selected fingerings to half their normal size.
TIP
You can change the default size of all fingerings project-wide by changing the size of the
Fingering Font in Engrave > Font Styles.

RELATED LINKS
Editing the fingering font styles on page 797

794
Dorico Pro 3.1.10

Fingering
Showing enclosures/underlines on fingerings

Showing enclosures/underlines on fingerings
You can show individual fingerings belonging to non-fretted instruments with either a circle
enclosure or an underline.
NOTE
These steps only apply to non-fretted instruments. For fretted instruments, you can instead show
string indicators inside the staff, which are shown in a circle enclosure.

PROCEDURE
1.

In Engrave mode, select the fingerings on which you want to show an enclosure/underline.

2.

In the Properties panel, activate Decoration in the Fingering and Positions group.

3.

Choose one of the following options:
●

Circle

●

Underline

RESULT
The selected fingerings are shown with the chosen decoration.
TIP
You can find options that determine the default design of all fingering decorations project-wide,
such as their line thickness, by clicking Advanced Options in the Design section of the Fingering
page in Engrave > Engraving Options.
EXAMPLE

Fingering with circle

Fingering with underline

RELATED LINKS
Project-wide engraving options for fingerings on page 789
String indicators on page 813

Hiding/Showing fingering
You can hide/show fingering in each layout in your project independently of other layouts. For
example, you can show fingering in part layouts but hide fingering in full score layouts as
conductors rarely require fingering information.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show fingering.

795
Dorico Pro 3.1.10

Fingering
Deleting fingerings
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.
3.

Click Players in the page list.

4.

In the Fingering section, activate/deactivate Show fingering.

5.

Click Apply, then Close.

RESULT
All fingerings in the selected layouts are shown when the checkbox is activated, and hidden when
the checkbox is deactivated.
RELATED LINKS
Changing the appearance of cautionary fingerings on page 799

Deleting fingerings
You can remove fingerings from notes after you have input them. However, because fingerings
are considered an intrinsic part of notes rather than a separate item, you cannot select and
delete them as you would for other items.
PROCEDURE
1.

Select the notes from which you want to remove fingerings. You can do this in Write mode
and Engrave mode.

2.

Choose Edit > Fingering > Reset Fingering.

RESULT
All fingerings are removed from the selected notes.
TIP
You can assign your own key command for this action.

RELATED LINKS
Large selections on page 322
Assigning key commands on page 66

Fingering font styles
Different types of fingerings use different fonts. You can change different aspects of the font
styles used for fingering in the Edit Font Styles dialog.

The following fonts are used for fingering:
1

Fingering Font: Used for bold fingerings, including bold italic fingerings. Must be SMuFLcompliant.
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2

Fingering Text Font: Used for plain fingerings.

3

Fingering Text Italic Font: Used for italic fingerings.

4

Fingering Horn Branch Text Font: Used for note names in horn branch indicators.

5

Fingering Horn Branch Accidental Font: Used for accidentals in horn branch indicators.
Must be SMuFL-compliant.

6

Fingering Horn Branch Alto Text Font: Used for the alto abbreviation in triple horn branch
indicators.

NOTE
Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Edit Font Styles dialog on page 407
Project-wide engraving options for fingerings on page 789
String indicators on page 813
Changing the appearance of open string indicators on page 814

Changing the font used for fingerings project-wide
By default, fingerings are drawn in a bold, Arabic font that is similar in appearance to the digits in
time signatures. You can change the font used for all fingerings project-wide, which affects the
appearance of fingering numbers, parentheses, brackets, and open string indicators that appear
as zero fingerings.
NOTE
The font used for thumb indicator, substitution lines and slurs, and brass valve separators is not
changed.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Fingering in the page list.

3.

In the Design section, choose one of the following options for Fingering appearance:

4.

●

Bold font

●

Plain font

Click Apply, then Close.

RESULT
The font style used for fingerings and open string indicators that appear as zero fingerings
project-wide is changed.
TIP
You can edit different aspects of the font styles used for fingerings in the Edit Font Styles dialog.
Bold fingerings use Fingering Font. Plain fingerings use Fingering Text Font.

Editing the fingering font styles
You can edit the formatting of the font styles used for all fingerings and open string indicators
that appear as zero fingerings project-wide, for example, if you want them to appear larger by
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default. However, you must choose a SMuFL-compliant font for the Fingering Font and
Fingering Horn Branch Accidental Font font styles.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2.

Select the fingering font style you want to edit from the Font style menu.

3.

Activate the following options, individually or together, to change the corresponding aspect
of the font:
●

Font family

●

Size

●

Style

●

Underlined

4.

Optional: Repeat steps 2 and 3 for any other font style you want to edit.

5.

Click OK to save your changes and close the dialog.

RESULT
The formatting of the selected fingering font styles is changed project-wide.
RELATED LINKS
Fingering font styles on page 796
Project-wide engraving options for fingerings on page 789
Changing the size of fingerings on page 794

Showing individual fingerings in italics
Fingerings are normally shown in a bold, non-italic font, but you can show individual fingerings in
italics.
PROCEDURE
1.

In Engrave mode, select the fingerings you want to show in italics.

2.

In the Properties panel, activate Italic in the Fingering and Positions group.

RESULT
The selected fingerings are shown in a bold italic font if your project-wide setting for fingerings is
a bold font, and in a plain italic font if your project-wide setting for fingerings is a plain font.
NOTE
Bold italic fingerings look very similar to tuplet numbers, which can be confusing.

Cautionary fingerings
Cautionary fingerings remind players that fingerings specified at previous rhythmic positions
continue to apply to notes that are still sounding. Dorico Pro automatically shows cautionary
fingerings when you add other fingerings at rhythmic positions where notes with existing
fingerings are still sounding.
By default, cautionary fingerings are shown enclosed in parentheses. You can choose to show
cautionary fingerings without parentheses or not to show cautionary fingerings at all projectwide, and you can change the appearance of cautionary fingerings individually, for example, if
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you want to show cautionary fingerings manually on tied notes that cross system or frame
breaks.

Cautionary fingering shown in parentheses (default)

Changing the appearance of cautionary fingerings
You can change the appearance of cautionary fingerings individually and independently of your
project-wide setting, for example, if you want particular fingerings to appear without
parentheses or to hide specific cautionary fingerings.
NOTE
These steps only apply to fingerings input as cautionary fingerings.

PROCEDURE
1.

In Engrave mode, select the noteheads whose cautionary fingering appearance you want to
change.
NOTE
You must select the specific noteheads to which the cautionary fingerings apply, not the
fingerings themselves.

2.

In the Properties panel, activate Cautionary in the Fingering and Positions group.

3.

Select one of the following options from the menu:
●

Default

●

With parentheses

●

Without parentheses

●

Suppress

RESULT
The appearance of cautionary fingerings on the selected notes is changed.
TIP
You can change the default appearance of all cautionary fingerings project-wide in the
Alternative, Editorial and Cautionary section of the Fingering page in Engrave > Engraving
Options.

RELATED LINKS
Cautionary fingerings on page 798
Project-wide engraving options for fingerings on page 789
Inputting fingerings on page 213
Fingerings popover on page 214
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Fingerings for fretted instruments
Fretted instruments, such as the classical guitar, require additional fingering instructions for
both hands and engraving options due to the complex nature of the music.
Fingerings for fretted instruments use the same fonts as normal fingerings.

A passage for guitar with right-hand and left-hand fingerings

Right-hand fingering
Right-hand fingerings tell the performer which finger to use to pluck the string, which
is usually the right hand. By default, all right-hand fingerings are placed outside the
staff, on the notehead side of notes, and follow the stem directions of voices in
multiple-voice contexts. When the same finger plays multiple notes in a chord, you can
show a single fingering with a bracket for the notes plucked by that finger.

By default, Dorico Pro shows “p” for right-hand thumb fingerings and “e” for right-hand
fingerings for the pinky finger, but there are different conventions for these letters.
You can change these default settings for all fingerings project-wide.
NOTE
In Dorico Pro, we use “pinky” to refer to the smallest finger, but it can also be called
“little” or “fifth digit”.
Left-hand fingering
Left-hand fingerings tell the performer which finger to use to stop the string, which is
usually the left hand. In Dorico Pro, left-hand fingerings are placed inside the staff and
to the left of the notes to which they apply.

When shown inside the staff next to notes, left-hand fingering appears smaller than
fingering shown outside the staff. The default scale factor for left-hand fingering inside
the staff is 95 %. You can find this option by clicking Advanced Options in the Design
section of the Fingering page in Engrave > Engraving Options.
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RELATED LINKS
Inputting fingerings on page 213
Fingerings popover on page 214
Fingering font styles on page 796
Changing the letters shown for fretted instrument fingerings on page 805
Adding fingerings to arpeggio signs on page 804
Fingering slides on page 806
String indicators on page 813

Hiding/Showing brackets for right-hand fingerings
When multiple notes in the same chord are plucked by the same right-hand finger, you can show
the same fingering multiple times, once for each note, or show a single fingering for all notes
with a bracket spanning the notes plucked by that finger. When showing a separate fingering for
each note, you can also choose to place each fingering either above or below the staff.
NOTE
These steps only apply to right-hand fingerings belonging to fretted instruments.
PREREQUISITE
You have input the fingerings for which you want to hide/show brackets or whose vertical
position you want to change.
PROCEDURE
1.

Select all the notes for which you want to hide/show brackets for right-hand fingerings. You
can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Vertical position in the Plucked Fingering group.

3.

Select one of the following options from the menu:
●

To hide brackets and show a separate fingering for each selected note, select Above
staff or Below staff.

●

To show brackets and a single fingering for all notes in each bracket, select Next to
note.

RESULT
Brackets on the selected right-hand fingerings are hidden/shown. If you selected Above staff or
Below staff, their staff-relative placement is changed accordingly.
TIP
You can change the default staff-relative placement of all right-hand fingerings in the Position
section of the Fingering page in Engrave > Engraving Options.
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EXAMPLE

Right-hand fingerings shown next
to notes with a bracket

Right-hand fingerings shown
above the staff

Right-hand fingerings shown
below the staff

RELATED LINKS
Inputting fingerings on page 213

Changing the position of left-hand fingerings
You can change the position of individual left-hand fingerings. By default, they are positioned
inside the staff and to the left of the notes to which they apply.
NOTE
These steps only apply to left-hand fingerings belonging to fretted instruments.
PREREQUISITE
You have input the fingerings whose position you want to change.
PROCEDURE
1.

Select the left-hand fingerings whose position you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Stopping finger position in the Fingering and Positions
group.

3.

Select one of the following options from the menu:
●

Outside staff

●

Left of note

●

Right of note

EXAMPLE
The position of the selected left-hand fingerings is changed. When shown outside the staff, they
are placed above the staff by default.
TIP
You can change how all fingerings shown to the left of notes project-wide avoid collisions in the
Position section of the Fingering page in Engrave > Engraving Options.
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Outside staff

Left of note

Right of note

RELATED LINKS
General placement conventions for fingering on page 788
Inputting fingerings on page 213

Erasing the background of left-hand fingerings inside the staff
By default in Dorico Pro, left-hand fingerings have erased backgrounds because they are often
placed in the staff on staff lines. You can change whether individual left-hand fingerings have
erased backgrounds or not.
NOTE
These steps only apply to left-hand fingerings belonging to fretted instruments.

PROCEDURE
1.

In Engrave mode, select the left-hand fingerings whose background erasure you want to
change.

2.

In the Properties panel, activate Erase background in the Fingering and Positions group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
The backgrounds of the selected left-hand fingerings are erased when the checkbox is activated,
and not erased when the checkbox is deactivated.
When the property is deactivated, left-hand fingerings follow your project-wide setting for erased
backgrounds.
TIP
You can find the default setting for erasing the backgrounds of all left-hand fingerings projectwide by clicking Advanced Options in the Design section of the Fingering page in Engrave >
Engraving Options.
EXAMPLE

Left-hand fingerings with erased backgrounds
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RELATED LINKS
Project-wide engraving options for fingerings on page 789

Adding fingerings to arpeggio signs
You can add fingerings to arpeggio signs to indicate which right-hand finger should be used to
strum a chord. By default, fingerings are placed at the bottom of arpeggio signs.
NOTE
These steps only apply to arpeggio signs belonging to fretted instruments.
PREREQUISITE
You have input the arpeggio signs to which you want to add fingerings.
PROCEDURE
1.

Select the arpeggio signs belonging to fretted instruments to which you to add fingerings.
You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Finger in the Plucked Fingering group.

3.

Enter the fingering you want into the value field.
For example, for the thumb, enter p.

RESULT
The specified fingering is added to the selected arpeggio signs. It is positioned at the bottom of
the arpeggio signs by default.
TIP
You can find options relating to arpeggio sign fingerings on the Fingering page in Engrave >
Engraving Options. For example, you can find the option for their default scale factor for them
relative to normal fingerings by clicking Advanced Options in the Design section.
EXAMPLE

Arpeggio signs played with the thumb

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
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Allowing/Disallowing arpeggio sign fingerings in the staff
By default, arpeggio sign fingerings are always shown outside the staff. You can choose to allow
them to be shown in the staff when their arpeggio signs end inside the staff.
NOTE
These steps only apply to arpeggio signs belonging to fretted instruments.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Fingering in the page list.

3.

In the Position section, choose one of the following options for Vertical position for
arpeggio sign fingering in the Vertical Position subsection:

4.

●

Force outside staff

●

Allow in staff

Click Apply, then Close.

Changing the letters shown for fretted instrument fingerings
You can change which letters are shown for fingerings indicating the thumb and pinky finger. By
default, Dorico Pro shows “p” for the thumb and “e” for the pinky finger.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Fingering in the page list.

3.

In the Design section, choose one of the following options for Thumb indicator in the
Right-hand Plucked Fingering subsection:

4.

5.

●

P (Pulgar)

●

T (Thumb)

Choose one of the following options for Pinky finger indicator:
●

E

●

Q

●

C

●

S

●

O

●

X

Click Apply, then Close.

RESULT
The letters used for thumb and pinky finger fingerings are changed project-wide.
RELATED LINKS
Fingerings popover on page 214
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Fingering slides
Fingering slides indicate that the performer should slide their finger up/down the neck of the
instrument. They are notated as an angled line between fingerings.
The note at the start of a fingering slide is known as a source note. The note at the end of a
fingering slide is known as the destination note.

A passage with fingering slides

When the source and destination notes are sufficiently close horizontally, fingering slides are
shown between the fingerings, joining them directly in their existing positions without moving
them. When the source and destination notes are far apart horizontally, fingering slides appear
with a fixed length to the left of the destination note. You can change the length of individual
fingering slides.
Fingering slides automatically avoid obstructions, such as noteheads, accidentals, and other
fingerings.
In Engrave mode, you can select fingering slides independently of their source/destination
fingerings and the corresponding notes. They have a handle at each end that you can use to
move the start/end and adjust the angle of each fingering slide independently. You can also
move whole fingering slides graphically.
NOTE
●

Dorico Pro automatically adjusts the length/angle of fingering slides when you move the
fingerings at the start/end.

●

In Dorico Pro, you can only show fingering slides on staves belonging to fretted instruments.
You can show string fingering shift indicators on staves belonging to other string
instruments.

RELATED LINKS
Hiding/Showing fingering slides on page 806
Changing the length of fingering slides on page 808
Hiding/Showing string fingering shift indicators on page 811

Hiding/Showing fingering slides
You can hide/show slides between notes played by the same left-hand finger on the same string
on fretted instruments.
NOTE
These steps only apply to fingerings belonging to fretted instruments.
PREREQUISITE
●

You have input the same left-hand fingering for the notes at the start and end of the slides.

●

You have specified the same string for the notes at the start and end of the slides.
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PROCEDURE
1.

Select the destination notes before which you want to hide/show fingering slides. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Slide in in the Fingering and Positions group.

RESULT
Fingering slides are shown before the selected notes when Slide in is activated, and hidden
when it is deactivated. If the gap between the source and destination notes is small enough,
fingering slides appear as an angled line joining the fingerings. If the gap is large, fingering
slides appear as a fixed length angled line to the left of the destination notes.
TIP
If you want to adjust the placement or angle of the slide, you can move either the fingerings or
the slide itself graphically in Engrave mode. Dorico Pro automatically adjusts the length/angle of
fingering slides when you move the fingerings at the start/end.

RELATED LINKS
Inputting fingerings on page 213
Changing existing fingerings on page 791
Specifying the string for individual notes on page 904
Moving fingerings graphically on page 791

Moving fingering slides graphically
You can move individual fingering slides graphically without changing the notes to which they
apply and independently of the fingerings at their start/end. You can move each end of fingering
slides that join notes independently, meaning you can also adjust their angles.

Handles on a slide joining two notes in Engrave mode

NOTE
●

If you want to move handles at the start/end of fingering slides because you want to change
their length, we recommend that you do so by changing their Slide type property or by
moving the fingerings. Dorico Pro automatically adjusts the length/angle of fingering slides
when you move the fingerings at the start/end.

●

You cannot move fingering slides rhythmically. If you want to change the notes to which
fingering slides apply, you must hide them between their original notes and show new
fingering slides between the new notes.

●

Fingering slides shown only before the destination note have a fixed length, and so do not
have handles at the start/end.

●

You cannot move whole fingering slides that join notes. You can only move their handles.

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Whole fingering slides shown before destination notes
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●

Individual handles on fingering slides that join notes

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the fingering slides or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected fingering slides or handles are moved graphically, without affecting the notes to
which they apply or the fingerings at their start/end.
TIP
The following properties in the Fingering and Positions group of the Properties panel are
activated automatically when you move the corresponding fingering slide handle:
●

Slide start moves the start handle of fingering slides. X moves them horizontally, Y moves
them vertically.

●

Slide end moves the end handle of fingering slides. X moves them horizontally, Y moves
them vertically.

For example, if you move a whole fingering slide, both handles are moved so both Slide start
and Slide end are activated. You can also use these properties to move fingering slides
graphically and change their angles by changing the values in the value fields.
Deactivating the properties resets the selected fingering slides to their default positions.

Changing the length of fingering slides
You can change the length of individual fingering slides and show them either joining the source
and destination fingerings or with a fixed length before the destination note, independently of
your project-wide maximum distance threshold.
NOTE
These steps only apply to fingerings belonging to fretted instruments.

PROCEDURE
1.

In Engrave mode, select the fingering slides whose length you want to change.

2.

In the Properties panel, activate Slide type in the Fingering and Positions group.

3.

Choose one of the following options:
●

Join
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●

Destination only

RESULT
Join shows a fingering slide between the fingerings at the start/end of the selected slides.
Destination only shows a fixed length fingering slide before the destination notes.
TIP
You can change the default threshold above which all fingering slides are only shown before the
destination note rather than joining the fingerings at their start/end in the Fingering Slides
section of the Fingering page in Engrave > Engraving Options.
EXAMPLE

Join

Destination only

Fingerings for valved brass instruments
For instruments like trumpet and horn, fingering is used to show which valves must be
depressed to produce a specific note.
You can enter fingerings for valved brass instruments into the fingerings popover as numbers
without any separation. For example, enter 12 for a C♯ on a trumpet to indicate that the first two
valves must be depressed.
By default, Dorico Pro automatically stacks fingerings added to notes on brass instrument staves
vertically. They are shown with no separator by default.
You can change the appearance of fingerings for valved brass instruments in the Brass section of
the Fingering page in Engrave > Engraving Options. For example, you can show fingerings for
valved brass instruments in a single row or stacked vertically. You can also change the
appearance of the separator or show no separator.
You can also edit the formatting of the fonts used for the different parts of fingerings for valved
brass instruments.
RELATED LINKS
Fingering font styles on page 796
Fingerings popover on page 214
Inputting fingerings on page 213
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Showing horn branch indicators
You can indicate the branch on which notes are played for double horns and triple horns by
adding branch indicators as prefixes to horn fingerings. Some publications simply indicate “T” for
thumb, while others more explicitly indicate which branch is to be used by specifying its pitch.
NOTE
You can only add branch indicators to notes belonging to horns in F.

PROCEDURE
1.

Select the horn fingerings to which you want to add branch indicators. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Horn branch in the Fingering and Positions group.

3.

Select one of the following horn branches from the menu:
●

F

●

B flat

●

F alto

●

E flat alto

●

Thumb trigger

RESULT
Branch indicators are added to the selected fingerings.
TIP
You can change the appearance of branch indicators in the Brass section of the Fingering page
in Engrave > Engraving Options.

RELATED LINKS
Inputting fingerings on page 213
Project-wide engraving options for fingerings on page 789

Changing the appearance of slide positions for brass instruments
You can use Arabic or Roman numerals to indicate slide positions for slide brass instruments,
such as trombones. By default, Dorico Pro uses Arabic numerals for slide positions.
NOTE
You must enter slide positions using Arabic numerals into the fingerings popover, even if you
have chosen to show slide positions with Roman numerals in your project.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Fingering in the page list.

3.

In the Brass section, choose one of the following options for Slide position appearance in
the Slide brass instruments subsection:
●

Arabic numerals

●

Roman numerals
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4.

Click Apply, then Close.

RESULT
The numeral style used for slide positions on slide brass instruments is changed project-wide.
RELATED LINKS
Inputting fingerings on page 213

Hiding/Showing string fingering shift indicators
An angled line can be used to indicate the direction of movement when string players must shift
their finger position on the fingerboard to play a higher/lower note with the same finger as the
previous note.
PROCEDURE
1.

Select the notes or fingerings on string instrument staves from which you want to indicate a
fingering shift. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Indicate shift to next note in the Fingering and
Positions group.

RESULT
Shift indicators are shown when the property is activated, even if neither of the notes at each end
have explicit fingerings, and hidden when the property is deactivated. They are positioned
between the selected notes and the notes that immediately follow them.
TIP
You can change the length, thickness, angle, and placement of shift indicators in the String
Fingering Shifts section of the Fingering page in Engrave > Engraving Options.
EXAMPLE

RELATED LINKS
Specifying the string for individual notes on page 904
String indicators on page 813

Changing the direction of string fingering shift indicators
You can change the direction of individual string fingering shift indicators if they do not point in
the direction required.
PROCEDURE
1.

Select the shift indicators whose direction you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Shift direction in the Fingering and Positions group.

3.

Choose one of the following options:
●

Up
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●

Down

RESULT
The selected shift indicators are angled up/down.
NOTE
You can also affect the direction of string shift indicators by specifying the strings on which notes
are played.

RELATED LINKS
Specifying the string for individual notes on page 904

Fingerings imported from MusicXML files
Dorico Pro imports fingerings that are specified using the fingering element in MusicXML files.
MusicXML files exported from Finale typically represent fingerings in the correct way. However,
because Sibelius does not use the fingering element, Dorico Pro cannot import fingerings from
MusicXML files exported by Sibelius.
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String indicators are commonly used in guitar music to tell performers the string on which they
should play a note, particularly for pitches that are possible on multiple strings.
String indicators show the string number inside a circle enclosure, optionally with a dashed line
to indicate they apply to a range of notes. Open pitches commonly appear as a zero without an
enclosure.
In Dorico Pro, string indicators for stopped pitches appear in a plain font while string indicators
for open strings use the fingering font when they appear as zero fingerings. If you want to edit
the appearance of string indicators, you can do so in the Edit Playing Techniques dialog.

A phrase with string indicators and left-hand fingerings

There are two types of string indicators in Dorico Pro, which you input in different ways.
String indicators outside the staff
String indicators outside the staff always appear inside circle enclosures. They
automatically show dashed duration lines when they have duration to indicate that
multiple notes are played on that string.
In Dorico Pro, string indicators outside the staff are considered playing techniques. You
can select and delete them independently of the notes to which they apply. You can
also change the duration line style of string indicators outside the staff in the same
ways as for playing technique continuation lines.

String indicator outside the staff with duration line

String indicators inside the staff
String indicators inside the staff appear inside circle enclosures, except when they
show open strings, which appear as a bold number zero without an enclosure. They
automatically erase their backgrounds so they do not collide with staff lines. They
appear to the left of noteheads by default but automatically appear to the right if lefthand fingerings are present.
The string number shown in string indicators inside the staff is calculated
automatically, but you can also specify the string manually.
String indicators inside the staff for stopped pitches are scaled-down versions of string
indicators outside the staff. Therefore, changing the appearance of string indicators in
the Edit Playing Techniques dialog also affects the appearance of string indicators
inside the staff for stopped pitches.
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In Dorico Pro, string indicators inside the staff are considered properties of the
corresponding notes. You can only select them independently of their corresponding
notes in Engrave mode.

String indicators inside the staff, with the last one for an open string

RELATED LINKS
Fingerings for fretted instruments on page 800
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277
Playing techniques on page 1007
Playing technique duration on page 1016
Edit Playing Techniques dialog on page 1022
Fingering font styles on page 796
Lengthening/Shortening string indicators on page 815
Specifying the string for individual notes on page 904
Changing the style of playing technique continuation lines on page 1019
Deleting string indicators on page 817

Project-wide engraving options for string indicators
You can find options for the project-wide appearance and position of string indicators on the
String Indicators page in Engrave > Engraving Options.
The options on the String Indicators page allow you to change the appearance of open string
indicators, the size of string indicators inside the staff, whether their notehead-relative position
should change if left-hand fingerings are present, and the exact positions of string indicators
relative to each other and other items.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
RELATED LINKS
Engraving Options dialog on page 359

Changing the appearance of open string indicators
You can change the appearance of all string indicators for open strings project-wide. By default,
string indicators inside the staff for open strings appear as a bold number zero without a circle
enclosure, similar to left-hand fingerings.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click String Indicators in the page list.

3.

In the Design section, choose one of the following options for Open string appearance:
●

Zero fingering

●

String number as indicator
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●
4.

Zero as indicator

Click Apply, then Close.

RESULT
The appearance of all open string indicators inside the staff is changed project-wide. When open
string indicators appear as Zero fingering, they use the fingering font style set for the project.
This does not affect the appearance of string indicators outside the staff.
TIP
If you want to edit the appearance of all string indicators, you can do so in the Edit Playing
Techniques dialog.

RELATED LINKS
Inputting string indicators inside the staff on page 289
Changing the font used for fingerings project-wide on page 797

Changing the size of string indicators
You can change the size of all string indicators inside the staff project-wide, for example, if you
want them to appear closer in size to string indicators outside the staff. You can also change
whether or not they appear smaller on grace notes.
By default, string indicators inside the staff are scaled down to reduce their impact on note
spacing and general readability, and are proportionally scaled down further on grace notes.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click String Indicators in the page list.

3.

In the Design section, change the value for Scale factor for string indicators inside the
staff.

4.

Activate/Deactivate Scale string indicators on grace notes.

5.

Click Apply, then Close.

RESULT
The size of string indicators inside the staff is changed project-wide. They appear smaller on
grace notes when Scale string indicators on grace notes is activated, and always the same size
when it is deactivated.

Lengthening/Shortening string indicators
You can lengthen/shorten the duration of string indicators outside the staff after they have been
input. Lengthening a string indicator outside the staff that was added to a single note gives it
duration and shows a duration line, which is dashed by default.
PROCEDURE
1.

In Write mode, select the string indicators outside the staff you want to lengthen/shorten.
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NOTE
When using the mouse, you can only lengthen/shorten one string indicator at a time. When
using the keyboard, you can lengthen/shorten multiple string indicators, but they must all
have duration already.
2.

Lengthen/Shorten the string indicators in any of the following ways:
●

To lengthen them by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten them by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .

●

To snap the end of a single string indicator to the next notehead, press Ctrl/Cmd-ShiftAlt/Opt-Right Arrow .

●

To snap the end of a single string indicator to the previous notehead, press Ctrl/CmdShift-Alt/Opt-Left Arrow .
NOTE

●

●

You can only lengthen/shorten string indicators according to the current rhythmic
grid resolution when multiple string indicators are selected.

●

When using the keyboard, you can only move the end of string indicators with
duration. You can move the start of string indicators with duration by moving them
rhythmically, or by clicking and dragging the start handle.

Click and drag the circular handle at the start/end to the right/left.

RESULT
Single string indicators are lengthened/shortened according to the current rhythmic grid
resolution or to the next/previous notehead, whichever is closer. If they previously had no
duration, they now have duration and show a duration line.
Multiple string indicators are lengthened/shortened according to the current rhythmic grid
resolution.
TIP
You can move string indicators graphically in Engrave mode, including changing their graphical
length.
EXAMPLE

String indicator (selected) with no duration

String indicator (selected) with duration and duration
line

RELATED LINKS
Moving string indicators graphically on page 818
Playing technique duration on page 1016
Playing technique continuation lines on page 1015
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Hiding/Showing playing technique duration lines on page 1018
Edit Playing Techniques dialog on page 1022
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277

Deleting string indicators
You can remove string indicators inside the staff from notes after you have input them. However,
because string indicators inside the staff are properties of notes rather than separate items, you
cannot select and delete them as you would for other items.
NOTE
These steps only apply to string indicators inside the staff. You can delete string indicators
outside the staff in the same ways as for other items.

PROCEDURE
1.

Select the notes from which you want to remove string indicators inside the staff. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, deactivate Show in the String Indicators group.

RESULT
String indicators inside the staff are removed from the selected notes.
RELATED LINKS
Large selections on page 322
Deleting notes and items on page 337
Inputting string indicators inside the staff on page 289

Positions of string indicators
String indicators outside the staff are placed above it by default. In multiple-voice contexts, string
indicators for the up-stem voices are placed above the staff and string indicators for the downstem voices are placed below the staff.
String indicators inside the staff automatically erase their backgrounds so they do not collide
with staff lines. They appear to the left of noteheads by default but automatically appear to the
right if left-hand fingerings are present. You can change the notehead-relative position of string
indicators individually.
You can move string indicators outside the staff to different rhythmic positions in Write mode.
They are positioned by default according to your settings in Engraving Options. You can also
change the staff-relative placement of string indicators outside the staff individually, in the same
ways as for playing techniques.
You can move string indicators graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all string indicators project-wide on the String
Indicators page in Engrave > Engraving Options.
RELATED LINKS
Changing the staff-relative placement of items on page 330
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Moving string indicators rhythmically
You can move string indicators outside the staff to new rhythmic positions after they have been
input.
PROCEDURE
1.

In Write mode, select the string indicators outside the staff you want to move.
NOTE
When using the mouse, you can only move one string indicator rhythmically at a time.

2.

Move the string indicators in any of the following ways:
●

To move a single string indicator to the next notehead on the staff, press Alt/OptRight Arrow .

●

To move a single string indicator to the previous notehead on the staff, press Alt/OptLeft Arrow .

●

To move them to the right according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Right Arrow .

●

To move them to the left according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Left Arrow .
NOTE
You can only move string indicators according to the current rhythmic grid resolution
when multiple string indicators are selected.

●

Click and drag the string indicator to the right/left to the notehead you want.

RESULT
The selected string indicators are moved to new rhythmic positions.
NOTE
If a single string indicator above the staff passes over another string indicator above the staff as
part of its move, the existing one is unaffected as multiple string indicators can exist at the same
rhythmic position. However, if you move multiple string indicators together, any existing string
indicators they pass over are shortened or deleted accordingly.
You can undo this action, but any string indicators shortened/deleted in the process are only
restored if you moved string indicators using the keyboard.

RELATED LINKS
Lengthening/Shortening string indicators on page 815

Moving string indicators graphically
You can move string indicators graphically without changing the rhythmic positions or notes to
which they apply. You can also move the start/end handles of string indicator duration lines
independently of each other, meaning you can lengthen/shorten string indicators graphically.
PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

String indicators

●

Individual handles on string indicator duration lines
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TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the string indicators or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected string indicators or handles are moved to new graphical positions. Moving string
indicators with duration lines moves them both together. Moving string indicator duration line
handles moves the duration lines independently of the string indicator.
TIP
Offset in the String Indicators group of the Properties panel is activated automatically when
you move string indicators inside the staff.
●

Offset X moves string indicators inside the staff horizontally.

●

Offset Y moves string indicators inside the staff vertically.

The following properties in the Playing Techniques group of the Properties panel are activated
automatically when you move the corresponding item:
●

Offset moves string indicators. X moves them horizontally, Y moves them vertically.

●

Start offset moves the start handle of string indicator duration lines. X moves them
horizontally, Y moves them vertically.

●

End offset moves the end handle of string indicator duration lines. X moves them
horizontally, Y moves them vertically.

You can also use these properties to move string indicators and duration lines by changing the
values in the value fields.
Deactivating the properties resets the selected string indicators to their default positions.

RELATED LINKS
Lengthening/Shortening string indicators on page 815

Changing the notehead-relative position of string indicators
By default, string indicators inside the staff appear to the left of noteheads when there are no
left-hand fingerings and to the right of noteheads when there are left-hand fingerings. You can
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change the position of string indicators inside the staff relative to noteheads, independently of
your project-wide settings.
PROCEDURE
1.

Select the string indicators inside the staff whose notehead-relative position you want to
change. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Notehead-relative pos. in the String Indicators group.

3.

Choose one of the following options:
●

Left

●

Right

RESULT
The notehead-relative position of the selected string indicators is changed.
TIP
You can change the default notehead-relative positions of all string indicators inside the staff
project-wide on the String Indicators page in Engrave > Engraving Options. The available
options include automatically changing the notehead-relative position if left-hand fingerings are
present.
EXAMPLE

String indicators to the left of noteheads

String indicators to the right of noteheads

RELATED LINKS
Project-wide engraving options for string indicators on page 814
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Front matter in Dorico Pro is a broad term that covers all information included before the first
bar of music in scores.
Front matter includes musical information often added on pages before the first pages of scores,
such as:
●

Performance instructions

●

Contents

●

Instrumentation list

Front matter also includes information above the music on the first page of scores and parts,
such as:
●

Dedications

●

Titles

●

Subtitles

●

Composers

All information in your project that is independent of the music must be added within frames,
which you can input and edit in Engrave mode. You can do this on individual pages in layouts or
on master pages, which allow you to apply the same formatting to multiple pages in all the
layouts that use the same master page set, for example, if you want the music frame for the last
page in all part layouts to be smaller because it only contains a few systems.
RELATED LINKS
Master pages on page 361
Master page sets on page 362
Master page types on page 365
Paragraph Styles dialog on page 410
Frames on page 386

Project information used in default master pages
An efficient way of ensuring all text information in the different layouts in your project is
consistent is to use tokens that link to information for the current project entered in the Project
Info dialog.
Tokens are codes that refer to text elsewhere, meaning they are updated automatically if the
source text is changed.
The default master pages in Dorico Pro include tokens, so that any information you add about
the project in the Project Info dialog is automatically shown. For example, the Default Full
Score master page set includes tokens for the following information:
●

Composer

●

Lyricist

●

Title
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NOTE
These tokens refer to the project by default. If you only enter information for flows in the Project
Info dialog, that information does not automatically appear. You can change the tokens in the
default master pages to refer to specific flows if required.

RELATED LINKS
Project Info dialog on page 102
Flow names and flow titles on page 145
Text tokens on page 396
Customizing master pages on page 371

Adding dedications in master pages
You can show dedications in multiple layouts by adding them to master pages. Dedications are
usually shown above titles in scores, use a smaller font size than titles, and are shown in italics.
PREREQUISITE
●

You have entered a dedication in one of the Dedication fields in the Project Info dialog. You
can enter different dedications for the whole project and individual flows.

●

If you want to use a new paragraph style for dedications, you have created a new paragraph
style.

PROCEDURE
1.

In Engrave mode, open a layout in the music area that uses the master page set containing
the master page to which you want to add a dedication.
NOTE
You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2.

In the Master Pages section of the Pages panel, double-click the master page pair to which
you want to add a dedication to open the master page editor.

3.

Double-click the title text frame to open the text editor.

4.

Position the cursor at the start of the title token.

5.

Press Return to input a new line above the title token.

6.

Enter one of the following tokens in the new line above the title token:
●

{@flowDedication@} shows the dedication for the flow.

●

{@projectDedication@} shows the dedication for the whole project.

7.

Optional: Change the appearance of the dedication text using the text editor options.

8.

Press Esc or Ctrl/Cmd - Return to close the text editor.

RESULT
A dedication is shown above the title of all pages that use the selected master page format if a
dedication is entered into the appropriate field in the Project Info dialog.
RELATED LINKS
Project Info dialog on page 102
Creating paragraph styles on page 411
Text editor options in Engrave mode on page 415
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Adding player lists
You can add the player list text token to any layout or master page. It automatically displays the
names of all players in the layout, and includes all instruments held by each player.
PREREQUISITE
●

If you want to add a player list to a master page, you have opened the master page in the
master page editor.

●

If you want to add a player list into a new text frame, you have input the text frame where
you want the player list to appear.

PROCEDURE
1.

Double-click the text frame to which you want to add a player list to open the text editor.

2.

Enter {@playerlist@}.

3.

Press Esc or Ctrl/Cmd - Return to close the text editor.

RESULT
The player list text token is added. It is populated with a list of all players in the layout. If you
added it to a master page, the text frame and text token are automatically added to all pages in
all layouts that use that master page.
NOTE
Pages with overrides are not updated when you change the master page.
EXAMPLE

Player list token in a text frame

Player list token populated with players in the layout

RELATED LINKS
Inputting frames on page 386
Page format changes on page 372
Master page editor on page 370

Editing running headers in master pages
The Default Part master page set shows the part name at the top left of the first pages in flows,
and shows the part name centered at the top of subsequent pages as a running header. You can
change the text shown in running headers, for example, if you want to include the flow title as
well.
PROCEDURE
1.

In Engrave mode, open a layout in the music area that uses the master page set containing
the master page whose running header you want to edit.
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NOTE
You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.
2.

In the Master Pages section of the Pages panel, double-click the master page master page
pair whose running header text you want to change to open the master page editor.

3.

Double-click the header text frame to open the text editor.

4.

Change or delete the header text.
For example, to show both the part name and the flow title in the header text separated by a
dash, enter - {@flowTitle@} after the part name token in the text frame.

5.

Press Esc or Ctrl/Cmd - Return to close the text editor.

RESULT
The running header text is changed for all layouts that use the selected master page format.
EXAMPLE

Token text added to a text frame

Token text in a part layout

RELATED LINKS
Master page editor on page 370
Changing the vertical alignment of text in text frames on page 403
Changing the horizontal alignment of text in text frames on page 404
Changing the paragraph style of text on page 417

824
Dorico Pro 3.1.10

Grace notes
Grace notes are notes without a fixed duration, which are intended to be played quickly. They are
scaled-down versions of normal notes, and are commonly shown with a slash through their
stem.
Grace notes with slashed stems are known as acciaccaturas and are often played very fast. Grace
notes without slashed stems are known as appoggiaturas and are often played slower than
acciaccaturas.
In Baroque music, appoggiaturas are often understood to last for a specific duration, based on
the prevailing meter and the rhythmic value of the notehead to which they are attached.
Grace notes do not take up space rhythmically, as they are intended to be fitted into the space
before the notehead to which they are attached, which is the notehead immediately to their
right.
There can be multiple grace notes before a notehead. If there are two or more grace notes
attached to the same notehead, and they have a rhythmic value that shows a flag on the stem,
such as eighth notes (quavers) and 16th notes (semiquavers), they are automatically beamed
together.

Multiple grace notes before notes

In Dorico Pro, grace notes are scaled to 3/5 the size of a normal notehead by default and are
affected by your note spacing settings. There is a separate option specifically for grace note
spacing.
You can add notations, such as slurs and articulations, to grace notes in the same ways as to
normal notes, and you can transpose grace notes after they have been input.
RELATED LINKS
Inputting grace notes on page 193
Grace note slashes on page 828
Slur placement relative to grace notes on page 1120
Note spacing on page 425
Changing the pitch of individual notes on page 200
Inputting articulations on page 210
Inputting slurs on page 212
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General placement conventions for grace notes
Grace notes function like normal notes in many ways, but there are some specific conventions
about their stem direction, position relative to noteheads, and the placement of stem slashes.
Grace notes appear stem up by default, except when there are multiple voices with grace notes
in a single staff, in which case grace notes in the lower voices appear stem down. This affects the
placement of slurs relative to grace notes.
Grace notes are always positioned before a notehead, even if they are intended to be played on
the beat rather than before the beat. They are normally placed after a barline, so they can be
positioned directly before the notehead to which they are attached. However, groups of three or
more grace notes can be placed before the barline so that the note of the first beat in the bar is
not pushed too far from the barline.
Grace note stem slashes appear at the beginning of a grace note beam if multiple grace notes
can be joined by a single beam at the same rhythmic position. If there is a single grace note, the
slash appears across the stem, and its flag if applicable, and extends either side of the stem.

Adding accidentals causes their spacing to readjust so that the accidentals are clearly legible,
similar to normal notes.
Articulations can be added to grace notes wherever they are most clearly legible, which is most
likely outside the staff. Dorico Pro automatically places articulations on the stem-side of grace
notes, and outside the staff if the stem or beam is within the staff.

Slurs relative to grace notes
By default, slurs starting on grace notes and ending on tie chains end on the first note of the tie
chain. You can change the position of individual slurs relative to tie chains, including those
starting from grace notes.
You can change the default position of all slurs relative to grace notes in the Grace Notes section
of the Slurs page in Engraving Options. Included in this section are options for the position of
slurs relative to grace notes in multiple voices.
In the Tied notes section of the page, you can change the default position of slurs relative to tie
chains when slurs start on grace notes.
RELATED LINKS
Changing the position of grace notes relative to barlines on page 827
Slur placement relative to grace notes on page 1120
Slur position relative to tie chains on page 1119
Changing the position of slurs relative to tie chains on page 1120
Note spacing on page 425

Grace note placement in multiple-voice contexts
According to accepted notation convention, grace notes appear stem up by default when there is
only one voice on a staff, even if the notehead to which they are attached is stem down.
However, when there are multiple voices on the staff, all notes in the upper voices appear stem
up and all notes in the lower voices appear stem down, including all grace notes. This adjustment
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happens automatically in Dorico Pro, but you can also override the stem direction of grace notes
in multiple voices and change their directions individually if necessary.

RELATED LINKS
Changing the stem direction of notes on page 1199
Slur placement relative to grace notes on page 1120

Changing the position of grace notes relative to barlines
By default, grace notes are positioned after barlines and directly before the notehead to which
they apply, including for the first note in a bar. You can position individual grace notes before
barlines, for example, so the first normal note in the bar is not pushed too far from the barline,
or to indicate that grace notes are played before the beat.
PROCEDURE
1.

Select the grace notes whose position relative to barlines you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Grace note before barline in the Grace Notes
group.

RESULT
The selected grace notes are positioned before barlines when the property is activated, and after
barlines when the property is deactivated.

Project-wide changes to the position of grace notes
The Grace Notes section of the Notes page in Engrave > Engraving Options allows you to
change the default distance between grace notes and the noteheads to which they apply.
Increasing the value for the minimum distance to the right of the rightmost grace note moves
grace notes further from the notehead to which they apply. Decreasing the value moves them
closer to the notehead to which they apply.

A grace note with the default minimum value of half
a space between it and the notehead to its right

A grace note with an increased value of 1.5 spaces
between it and the notehead to its right

You can also adjust the position of grace notes in each layout independently by changing the
note spacing scale factor for grace notes on the Note Spacing page in Setup > Layout Options.
Decreasing the note spacing scale value for grace notes decreases the gap between multiple
grace notes at the same rhythmic position.
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Three grace notes with long durations, with the
default note spacing scale of 70%

Three grace notes with long durations, with a
decreased note spacing scale of 20%

RELATED LINKS
Engraving Options dialog on page 359
Note spacing on page 425

Grace note size
Grace notes are smaller versions of normal notes, and are scaled down by a ratio that is set by
default to 3/5 of a normal note.
You can find the ratio that controls the default size of all grace notes project-wide in the Grace
Notes section of the Notes page in Engrave > Engraving Options.
You can also change the size of grace notes individually in the same way as for normal notes.
RELATED LINKS
Changing the size of notes on page 900

Grace note slashes
Slashes shown diagonally across grace note stems are often used to distinguish different types
of grace notes. Grace notes with slashed stems are known as acciaccaturas and are often played
very fast. Grace notes without slashed stems are known as appoggiaturas and are often played
slower than acciaccaturas.
In Dorico Pro, grace notes appear with slashed stems by default. You can change whether grace
notes are slashed or unslashed during note input as well as by changing the type of existing
grace notes.
You can set the precise measurements of each part of grace note stem slashes in the Grace
Notes section of the Notes page in Engrave > Engraving Options.
In this section, you can change the following:
●

Thickness of grace note stem slashes

●

Default length of grace note stem slashes

●

Position of grace note stem slashes relative to the end of the stem

Changing the type of grace notes
You can change the type of individual grace notes after they have been input. Grace notes have
slashed stems by default, but you can change them to have unslashed stems.
PROCEDURE
1.

Select the grace notes whose type you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, choose one of the following options for Grace note type in the
Grace Notes group:
●

Slashed stem
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●

Unslashed stem

RESULT
The selected grace notes are shown with slashed/unslashed stems.
TIP
You can also change the grace note type during note input.

RELATED LINKS
Inputting grace notes on page 193

Moving slashes on grace note stems
You can change the vertical position of individual grace note slashes, independently of your
project-wide settings.
PROCEDURE
1.

In Engrave mode, select the grace notes whose slash positions you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Grace Notes group:

3.

●

Slash inset from stem tip

●

Slash offset to right

Change the values in the value fields.

RESULT
Increasing Slash inset from stem tip moves grace note slashes further from the tips of stems
and closer to the noteheads. Decreasing the value moves them closer to the tips of stems and
further from the noteheads.
Increasing Slash offset to right moves grace note slashes to the right, decreasing the value
moves them to the left.
TIP
You can change the default position of all grace note slashes project-wide in the Grace Notes
section of the Notes page in Engrave > Engraving Options.

Changing the length of grace note slashes
You can change the length of slashes on grace note stems individually, independently of your
project-wide setting.
PROCEDURE
1.

In Engrave mode, select the grace notes whose slash length you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Grace Notes group:
●

Slash length
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●

Slash protrusion from beam (beamed grace notes only)

NOTE
Grace note slashes seem to disappear when you activate Slash length because activating
the property resets the value to 0.
3.

Change the length and/or protrusion of the selected slashes by changing the values in the
corresponding value fields.

RESULT
Increasing Slash length lengthens grace note slashes on both single grace notes and grace note
beams, decreasing the value shortens grace note slashes.
Increasing Slash protrusion from beam increases how far slashes extend beyond grace note
beams, decreasing the value decreases how far slashes extend beyond grace note beams.
TIP
You can change the default appearance of all grace note slashes project-wide in the Grace Notes
section of the Notes page in Engrave > Engraving Options.

Grace note stems
Grace notes are scaled-down notes, so the length of grace note stems is determined by your
project-wide settings for the stem length of all notes.
You can change the default lengths of all stems project-wide in the Stems section of the Notes
page in Engrave > Engraving Options.
Following accepted conventions, grace notes in Dorico Pro are stem up by default in any clef,
regardless of the stem direction of the note to which they apply. The stem directions of grace
notes are changed automatically when there are multiple voices on a staff, but you can change
the stem direction of individual grace notes manually. You can also lengthen/shorten grace note
stems in the same ways as for normal stems.
RELATED LINKS
Stems on page 1195
Grace note slashes on page 828
Changing the stem direction of notes on page 1199
Lengthening/Shortening stems on page 1201
Hiding stems on page 1201

Grace note beams
Dorico Pro automatically beams multiple adjacent grace notes together if they are an eighth note
(quaver) or shorter in duration.
Like all beams, grace note beams ideally follow the accepted standards for beam placement
relative to staff lines, in order to avoid wedges. However, because grace notes are smaller than
normal notes, this can lead to extreme slants in grace note beams.
You can adjust the slants of individual grace note beams in the same ways as for normal beams.
You can also change how all grace note beam slants are positioned project-wide in the Vertical
Position section of the Beams page in Engrave > Engraving Options.
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Beam slants in two-note groups of beamed grace notes
If two adjacent grace notes covering a wide pitch range are joined by a beam at the same
rhythmic position, the angle of the beam can appear very steep.
You can choose whether the beam slant in such cases is left unchanged, or whether shallower
slants are used, in the Grace Notes subsection of the Slants section of the Beams page in
Engraving Options.
RELATED LINKS
Engraving Options dialog on page 359
Beaming on page 664
Beam groups on page 664
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Different notations are used to show where the established rhythmic flow of the music is
interrupted, either with a moment of repose or a short silence, before continuing. The most
subtle effect is produced by a tenuto mark, with more significant effects denoted with holds and
pauses.
The duration of the break in the music intended by the hold or pause does not need to be
specified. This leaves significant room for interpretation, even though the different styles of
holds and pauses normally indicate larger or smaller breaks.
NOTE
Holds and pauses do not currently have an effect in playback, but this is planned for future
versions.

RELATED LINKS
Input methods for holds and pauses on page 260

Types of holds and pauses
There are three types of holds and pauses in Dorico Pro, and they can all be input, moved, and
deleted in the same ways.
Fermatas
Fermatas indicate that a note is held for longer than its notated length, which applies
to the whole ensemble.
They are also known as “pauses” and informally sometimes called “birds’ eyes”.
Breath marks
Breath marks show suitable places for players to breathe, or suggest how the music is
phrased to create a similar effect.
Caesuras
Caesuras indicate that a note is sustained for its full value and is followed by a break in
sound before continuing.

Types of fermatas
There are different types of fermatas available in Dorico Pro. Each fermata indicates a suggested
pause duration whilst leaving room for interpretation.
Fermata

Description

Very short fermata

Indicates that a note is held only a fraction
longer than the rhythm indicates.
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Fermata

Description

Short fermata

Indicates that a note is held a little bit longer
than the rhythm indicates.

Short fermata (Henze)

Indicates that a note is held a little bit longer
than the rhythm indicates, as used by Hans
Werner Henze.

Fermata

Indicates that a note is held for longer than the
rhythm indicates.

Long fermata

Indicates that a note is held quite a lot longer
than the rhythm indicates.

Long fermata (Henze)

Indicates that a note is held quite a lot longer
than the rhythm indicates, as used by Hans
Werner Henze.

Very long fermata

Indicates that a note is held for much longer
than the rhythm indicates.

Curlew (Britten)

Indicates that a note or rest is held until the
next synchronization point in asynchronous
music, as used by Benjamin Britten.

Fermatas can be divided into two styles. Because their meanings overlap, it can be confusing for
players if both styles are used in a single project.
Style

Very short
fermata

Short
fermata

Fermata

Long fermata Very long
fermata

Normal
Henze

N/A

N/A

RELATED LINKS
Holds and pauses popover on page 260
Changing existing items on page 329
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Types of breath marks
There are different types of breath marks available in Dorico Pro. Breath marks indicate a
suitable place for a player to take a breath, or create a musical effect like a breath.
Comma-like

Tick-like

Upbow-like

Salzedo

Types of caesuras
There are different types of caesuras available in Dorico Pro. All caesuras indicate a break in
sound, but different types are often needed for different styles of musical scores.
Caesura

Thick caesura

Short caesura

Curved caesura

Two diagonal slashes

Two thick diagonal
slashes

Two straight, vertical
slashes

Two curved diagonal
slashes

If you intend to communicate a specific length of hold or gap with each type of caesura, we
recommend that you consider adding a legend, as different players may interpret these symbols
differently.
RELATED LINKS
Changing existing items on page 329

Project-wide engraving options for holds and pauses
You can find options for the project-wide positions of holds and pauses on the Holds and Pauses
page in Engrave > Engraving Options.
The options on the Holds and Pauses page allow you to change the default positions and
placement of holds and pauses, including the placement of fermatas in multiple-voice contexts.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
RELATED LINKS
Engraving Options dialog on page 359
Positions of holds and pauses on page 834

Positions of holds and pauses
Holds and pauses are placed above the staff by default in single-voice contexts, and are shown
on all staves at the closest rhythmic position available, for example, if a single staff has a fermata
on the last beat in the bar, it is shown above the bar rests on the other empty staves. For staves
with multiple voices, fermatas are also shown inverted below the staff.
You can move holds and pauses to different rhythmic positions in Write mode. They are
positioned by default according to your settings in Engraving Options.
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You can move holds and pauses graphically in Engrave mode; however, this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all holds and pauses project-wide, and values for the
minimum gaps around holds and pauses, on the Holds and Pauses page in Engrave >
Engraving Options.

Fermatas
Fermatas are positioned horizontally so that they are centered on noteheads, regardless of the
stem direction of notes.

Fermatas affect the overall tempo of the piece, so all players must be able to see where they
occur. Therefore, fermatas are shown on all staves at the same rhythmic position, or the
rhythmic position of the note, chord, or rest that corresponds with the end of the fermata,
including over a bar rest if a staff has no notes in that bar.
You can change the minimum distance between fermatas and the staff on the Holds and Pauses
page in Engrave > Engraving Options.

Breath marks
Breath marks are placed above the top line of the staff, at the end of the note to which they
apply; that is, they appear just before the following note.
Breath marks apply only to the staff to which they were added, as they do not affect the overall
tempo, but instead only indicate to a single player or group of players a suitable place to break
their line in order to breathe.
You can change the minimum distance between breath marks and the staff, and between breath
marks and the next note or rest, on the Holds and Pauses page in Engraving Options.

Caesuras
Caesuras are positioned at the top of the staff, with the top staff line passing through the middle
of the caesura and the bottom of the caesura resting on the second staff line. They are
commonly placed at the end of a bar, before the barline.
Caesuras are automatically added to all staves at the same rhythmic position, immediately to the
left of the notehead or barline to which they were input. They are not linked to noteheads, and
adjust note spacing to create a clear gap.
You can change the size of the gap to the right of caesuras on the Holds and Pauses page in
Engraving Options.
RELATED LINKS
Project-wide engraving options for holds and pauses on page 834
Moving holds and pauses graphically on page 837
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Multiple holds and pauses at the same rhythmic position
Because fermatas apply to all staves, only one type of fermata can exist at the same rhythmic
position. For example, you cannot have a short fermata on one staff and a long fermata at the
same rhythmic position on another staff.
A Britten curlew can be used at the same rhythmic position as another kind of fermata, but it
cannot exist simultaneously with any breath mark. This is the only exception in Dorico Pro.
Caesuras can co-exist with any type of breath mark, but you cannot have a caesura and a fermata
at the same rhythmic position.

Changes to fermatas on single staves
Changing the type of fermata or caesura on one staff automatically changes the type on all
staves at that rhythmic position, as a pause at one particular rhythmic position can only be of
one duration.
However, if you override a particular fermata on one staff, for example, by changing it to a
Britten curlew or a breath mark, changing the existing fermata on another staff does not change
the marking on the overridden staff. Deleting the marking on the overridden staff reverts that
marking to match the fermata on the other staves.
For example, changing a fermata to a breath mark changes the marking for only that staff. That
note is not affected when the type of fermata on the other staves at that rhythmic position is
changed.

The bottom staff is overridden to
show a breath mark instead of a
fermata.

The fermata is changed to a very
short fermata, but the bottom
staff is exempt as it was
overridden to show a breath mark.

Deleting the breath mark from the
bottom staff returns it to showing
the fermata currently chosen for
that rhythmic position.

Moving holds and pauses rhythmically
You can move holds and pauses to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the holds and pauses you want to move.
NOTE
When using the mouse, you can only move one hold or pause rhythmically at a time.

2.

Move the holds and pauses according to the current rhythmic grid resolution in any of the
following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.
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●

Click and drag the hold or pause to the right/left.

RESULT
The selected holds and pauses are moved to new rhythmic positions on each staff where they
appear, even if their position does not appear to move. For example, if one staff has a bar rest,
the rhythmic position of the hold or pause moves, but the hold or pause still appears above the
rest.
NOTE
Only one type of hold or pause can exist at each rhythmic position. If a hold or pause passes over
another hold or pause as part of its move, the existing hold or pause is deleted.
You can undo this action, but any holds and pauses deleted in the process are only restored if
you moved the hold or pause using the keyboard.

Moving holds and pauses graphically
You can move holds and pauses graphically without changing the rhythmic positions to which
they are attached.
PROCEDURE
1.

In Engrave mode, select the holds and pauses you want to move.

2.

Move the holds and pauses in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The holds and pauses are moved to new graphical positions.
TIP
Start offset in the Holds and Pauses group of the Properties panel is activated automatically
when you move fermatas and breath marks. You can use this property to move fermatas and
breath marks by changing the values in the value fields. However, you cannot move caesuras
using this property.
●

Offset X moves fermatas and breath marks horizontally.

●

Offset Y moves fermatas and breath marks vertically.

Deactivating the property resets the selected fermatas and breath marks to their default
positions.
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Changing the number of fermatas per staff
You can change the maximum number of fermatas that appear in each staff at individual
positions when there are multiple voices on a staff.
PROCEDURE
1.

Select a fermata or multiple fermatas. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Max. fermatas per staff in the Holds and Pauses group.

3.

Select one of the following options from the menu:
●

One per voice

●

One per each side of staff

●

One per staff

RESULT
The number of fermatas shown at the selected positions is changed.
TIP
You can change the maximum number of fermatas that can appear on a single staff project-wide
on the Holds and Pauses page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for holds and pauses on page 834

Positioning fermatas on barlines
You can position individual fermatas over a barline instead of over a note to indicate a gap
before the start of the following bar.
NOTE
Fermatas cannot be positioned on barlines if Max. fermatas per staff is also activated.

PROCEDURE
1.

Select the fermatas you want to position over barlines. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Attach to barline in the Holds and Pauses group.

RESULT
The selected fermatas are positioned above the barline at the end of the bars they were in
originally, appearing only above staves that are not joined by the barline. Depending on the
instrumentation, this may mean they only appear at the top of the system.
Deactivating Attach to barline returns the selected fermatas to their default positions.
RELATED LINKS
Changing the number of fermatas per staff on page 838
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Key signatures are the markings that show the current key of music by indicating which notes in
the scale for that key are sharpened or flattened. They are shown at the start of each system on
every applicable staff.
Traditionally, accidentals are organized following the pattern of the circle of fifths, which is
different for sharp keys and flat keys.
Using key signatures saves space, as by indicating which notes are generally going to be sharp or
flat in the music in one group at the start of each system, these notes do not need an accidental
beside them every time they occur.
By default, key signatures apply to the whole score. However, there are certain situations where
some parts require their own key signature, independently of the rest of the ensemble. You can
input key signatures that apply to all staves or only apply to single staves in Dorico Pro. Once you
have input a key signature, all notes you subsequently input follow the key signature, for
example, if you input an F after inputting a G major key signature, an F♯ is input automatically.
In Dorico Pro, key signatures exist within the overarching tonality system for your project. The
two tonality systems that come as standard in Dorico Pro are 12-EDO and 24-EDO.
Once you have selected or created a tonality system for your project, you can create custom key
signatures and custom accidentals within that tonality system.
RELATED LINKS
Tonality systems on page 848
Input methods for key signatures on page 216
Note input on page 167

Key signature arrangements
Dorico Pro automatically follows conventions for the placement and appearance of key
signatures, such as showing accidentals in the accepted circle of fifths order and positioning key
signatures between clefs and time signatures.
The order in which accidentals are shown in key signatures is different for sharp keys and flat
keys.
●

For sharps: F♯, C♯, G♯, D♯, A♯, E♯, B♯

●

For flats: B♭, E♭, A♭, D♭, G♭, C♭, F♭

Accidentals are arranged automatically in these orders in Dorico Pro for all standard Western key
signatures. There is an accepted pattern for the placement of accidentals in a key signature, so
that they fit inside the staff according to the current clef. The pattern of accidentals is the same in
all clefs, apart from the tenor clef, which requires sharp key signatures to follow a different,
ascending pattern to ensure the accidentals fit on the staff.
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Clef

Arrangement of sharps

Arrangement of flats

Treble

Bass

Alto

Tenor

NOTE
For custom, non-standard key signatures, you can determine the order in which accidentals
appear in the Edit Custom Key Signature dialog.

RELATED LINKS
Custom key signatures on page 860
Changing the barline shown at key signature changes on page 638
Positions of key signatures on page 843

Types of key signatures
There are four types of key signatures in Dorico Pro, which can all be input, moved, and deleted
in the same ways.
The four types are:
●

Major

●

Minor

●

Open key, or atonal

●

No key signature (for specific instruments, such as horn or percussion)

Major/Minor key signatures
The key signature for a major key appears the same as the key signature for its relative minor,
and vice versa. For example, B♭ major has two flats in its key signature. This is the same number
of flats as for G minor, which is the relative minor key to B♭ major. The difference is that music in
G minor usually has sharpened Fs, as the seventh degree of the scale is raised in minor keys.
Therefore, if you input an F♯/G♭ after a G minor key signature, Dorico Pro prefers to spell it as F♯ in
most cases, in order to follow the convention of harmonic minor keys.
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A B flat major scale following a B flat major key
signature

A G minor scale following a G minor key signature

Open key signature
Although open, or atonal, key signatures appear the same as C major or A minor key signatures
because none shows any accidentals, open key signatures behave differently.
In an open key signature, the spelling of accidentals is based on the current direction of the
music. If the music is rising, sharps are preferred, whereas if the music is falling, flats are
preferred. There is no hierarchy of pitches in an open key signature, so the same pitch might be
spelled differently each time it appears depending on its context, even within a few bars.
In a C major or A minor key signature, accidentals are spelled based on the context of the major
or minor tonality implied. For example, in C major, sharps in general are preferred, whether the
music is going up or going down. Similarly, in A minor, G♯ in particular is preferred, whether the
music is going up or going down, as G♯ is the leading note in A minor.

No key signature
Some instruments are accustomed to seeing no key signatures in their parts, no matter the
overall key of the piece. These instruments include timpani, percussion, horn, trumpet, and
sometimes the harp. If you have added the No key sig version of these instruments, then no key
signature is shown in their parts, even if they are a transposing instrument, such as horn or
trumpet.
Any pitch can be input into these instruments, and they show accidentals if needed.
RELATED LINKS
Adding instruments to players on page 116

Project-wide engraving options for key signatures
You can find options for the project-wide appearance of key signatures on the Key Signatures
page in Engrave > Engraving Options.
The options on the Key Signatures page allow you to change the key signature cancellation style
and the spacing gaps between accidentals in key signatures.
TIP
If you want to change the barline shown at key signature changes, you can find this option on
the Barlines page in Engraving Options.

RELATED LINKS
Engraving Options dialog on page 359
Changing the barline shown at key signature changes on page 638
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Deleting key signatures
You can delete key signatures without affecting the pitches of notes. Where appropriate, pitches
are shown with accidentals after you have deleted a key signature.
NOTE
●

You cannot hide key signatures as they provide crucial information about the pitch of notes.
If you do not want to see a key signature, you can input an open key signature or delete all
key signatures from the flow or project.

●

Instruments that do not usually have key signatures, such as timpani or horn, have a No key
sig version in Dorico Pro which never show key signatures. You can select the appropriate
instrument type from the instrument picker when adding or changing instruments.

PROCEDURE
1.

In Write mode, select the key signatures or signposts of key signatures you want to delete.

2.

Press Backspace or Delete .

RESULT
The selected key signatures are deleted from the score. The pitches of notes in the bars following
the deleted key signatures are not changed, but the notes are shown with accidentals if the
deleted key signature indicated an accidental for them, up until the next existing key signature or
the end of the flow.
NOTE
If you delete the only key signature in the flow, your music appears without a key signature, with
accidentals shown as necessary. This is treated as if there were an open key signature rather
than a key signature of A minor or C major.

RELATED LINKS
Input methods for key signatures on page 216
Adding instruments to players on page 116
Changing instruments on page 118
Signposts on page 335

Multiple simultaneous key signatures
You can have multiple key signatures simultaneously by inputting each one onto a single staff.
NOTE
You do not have to input multiple simultaneous key signatures if you have transposing
instruments in your score. Dorico Pro handles instrument transpositions automatically.
You can check the transposition of transposing instruments by choosing Edit > Transposed
Pitch to see the music in your layout at written pitch rather than concert pitch.
Alternatively, you can open the individual part layout of a transposing instrument and compare it
to the full score.
RELATED LINKS
Input methods for key signatures on page 216
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Positions of key signatures
Key signatures are positioned between clefs and time signatures by default, and are shown on
every staff that requires a key signature. They are not shown on staves for unpitched
instruments.
Key signatures are shown at the start of a piece and at the start of subsequent movements, even
if the music carries straight on and in the same key. Unlike time signatures, key signatures
appear at the start of every system, even if the key signature has not changed. They apply until
the end of the flow or until the next key signature change, whichever comes first.

The correct position for key signatures is between clefs and time signatures.

If a key signature change occurs during a piece or movement, it should be placed immediately
after a barline. It is customary to have a double barline where a key signature change takes
place, which is the default setting in Dorico Pro. However, you can change the default barline
shown at key signature changes.

Examples of key signatures positioned after double barlines

You can move key signatures to new rhythmic positions in Write mode. They are positioned
according to your settings on the Key Signatures and Spacing Gaps pages in Engrave >
Engraving Options.
If you find you need to move individual key signatures graphically,you can do this in Engrave
mode, but this does not change their rhythmic positions.
If you want to adjust the default position of key signatures relative to notes or barlines, you must
change the project-wide values for spacing gaps on the Spacing Gaps page in Engraving
Options.
RELATED LINKS
Key signature arrangements on page 839
Moving key signatures rhythmically on page 844
Moving key signatures graphically on page 845
Changing the barline shown at key signature changes on page 638

Project-wide spacing gaps for key signatures
Options for spacing gaps allow you to change the minimum gaps between objects project-wide,
including key signatures.
Among the available values on the Spacing Gaps page in Engrave > Engraving Options, the
following minimum values directly relate to key signatures:
●

Gap after barline before clef, key or time signature

●

Gap after cancellation naturals

●

Gap after key signature

●

Gap after end repeat barline
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NOTE
Other values may have an effect on the position of key signatures, but they also affect other
objects.
On the Key Signatures page in Engraving Options, you can change the following gaps:
●

Gap between accidentals in key signatures

●

Gap between cancellation naturals

RELATED LINKS
Engraving Options dialog on page 359

Moving key signatures rhythmically
You can move key signatures to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the key signatures you want to move.
NOTE
When using the mouse, you can only move one key signature rhythmically at a time.

2.

Move the selected key signatures according to the current rhythmic grid resolution in any of
the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the key signature to the right/left.

RESULT
The key signatures are moved to new rhythmic positions. They take effect from their new
positions until the next key signature, or the end of the flow, whichever comes first.
NOTE
●

Key signatures can only be moved along the staff. If you want to move a key signature across
staves, you must delete the key signature and input a new key signature on the other staff.

●

Only one key signature can exist at each rhythmic position, except for key signatures that
only apply to single staves. If a key signature passes over another key signature as part of its
move, the existing key signature is deleted and replaced by the key signature being moved.
You can undo this action, but any key signatures deleted in the process are only restored if
you moved the key signature using the keyboard.

RELATED LINKS
Input methods for key signatures on page 216
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Moving key signatures graphically
You can make individual changes to the graphical position of key signatures without affecting the
positions of any other items.
PROCEDURE
1.

In the Engrave toolbox, activate Note Spacing.

2.

Select the square handle above the key signature you want to move.

A smaller circular handle appears beside the key signature.
3.

Press Tab to select the circular handle.

4.

Move the handle in any of the following ways:
●

Press Alt/Opt-Right Arrow to move it to the right.

●

Press Alt/Opt-Left Arrow to move it to the left.
NOTE
●

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

You cannot move note spacing handles with the mouse, you can only move them
using the keyboard.

RESULT
The key signature is moved graphically to the right/left.
TIP
When Graphic Editing is selected in the Engrave toolbox, you can also change Spacing offset in
the Key Signatures group of the Properties panel to move key signatures horizontally. However,
this also affects global note spacing at the rhythmic position of the key signature, including
moving cancellation naturals.
You can also move cancellation naturals graphically, independently of the subsequent key
signature and without affecting the spacing of any other item using the Cancellation naturals X
offset property.

RELATED LINKS
Note spacing on page 425
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Transposing key signatures alongside selections
You can transpose key signatures at the same time as transposing notes, which transposes both
key signatures and notes by the same degree.
NOTE
Dorico Pro automatically shows the appropriate key signatures for transposing instruments in
transposing layouts.

PROCEDURE
1.

In Write mode, make a selection that includes both a key signature change and notes.

2.

Choose Write > Transpose to open the Transpose dialog.

3.

Adjust the parameters required for your transposition, such as interval and quality.
TIP

4.

●

We recommend using the Calculate interval section to determine your required
settings, for example, if you want to transpose from G♭ major to G major.

●

Different intervals have different possible qualities. For example, you can specify a major
third but not a major octave. Therefore, if you want to set your transposition parameters
manually, we recommend selecting the interval before the quality.

Activate Transpose key signatures.
It is activated automatically if your selection includes a key signature.

5.

Click OK to save your changes and close the dialog.

RESULT
All notes and key signatures within the selection are transposed by the degree you set in the
dialog.
NOTE
If a key signature included in the transposed selection applies to all staves, then it is transposed
on all staves in the layout, even if your selection did not include all staves.
Individual key signatures, that is, key signatures added only to single staves using the Alt key,
are transposed if included in a selection, but this does not affect any other staff in the layout.

RELATED LINKS
Transpose dialog on page 203
Concert vs. transposed pitch on page 138
Making layouts transposing/concert pitch on page 137
Selecting/Deselecting notes and items individually on page 320
Large selections on page 322

Enharmonic equivalent key signatures
Enharmonic equivalent key signatures are keys with different names that include the same
pitches, such as C♯ major and D♭ major. Dorico Pro follows the convention for transposing to keys
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with the same type of accidental as the previous key, except where the enharmonic equivalent
key signature has fewer accidentals.
When transposing selections of notes, Dorico Pro prefers keys with the same type of accidental
as the previous key signature. When choosing key signatures for transposing instruments, Dorico
Pro prefers key signatures with the same type of accidental as the current concert pitch key.
However, there are some instances where you might prefer to transpose to a key with a different
type of accidental as it has fewer accidentals than the enharmonic equivalent key. For example,
C♯ major has seven sharps, whereas the enharmonic equivalent key of D♭ major only has five
flats. This means the player has to remember the accidentals for fewer notes.
Transposing to an enharmonic equivalent key with fewer accidentals can have the added benefit
of improving readability by avoiding double sharps or double flats. For example, transposing
music from F♯ to G♯ requires the leading note to be spelled as an F, but transposing to A♭ instead
means the leading note is G♮.

G♯ major requires a double sharp leading note

A♭ major, the enharmonic equivalent to G♯, does not
require a double sharp leading note

By default, Dorico Pro selects an enharmonic equivalent key signature if it has fewer accidentals.
However, you can change this setting by deactivating Prefer enharmonic equivalent key
signatures with fewer accidentals in the Transposition section of the Accidentals page in
Write > Notation Options.

How key signatures affect transposing instruments
If there is a key signature in the full score, it is transposed for a transposing instrument by the
same degree as the transposing interval for the instrument. For example, in a project in E major,
a B♭ clarinet part has a key of F♯ major, as a B♭ clarinet sounds a whole tone below its notated
pitch.

Instruments that do not show a key signature
Some instruments are accustomed to seeing no key signatures in their parts, no matter the
overall key of the piece. These instruments include timpani, percussion, horn, trumpet, and
sometimes the harp. If you have input the No key sig version of these instruments, then no key
signature is shown in their parts, even if they are a transposing instrument, such as horn or
trumpet.
You can still transpose music in the staves of these instruments, but they show accidentals as
necessary, instead of showing a key signature.
RELATED LINKS
Notation Options dialog on page 160
Transpose dialog on page 203
Transposing selections on page 202
Adding instruments to players on page 116
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Cautionary key signatures
When a key signature change occurs at a system break, either in the score or in a part, the new
key signature is shown at the end of the first system as well as at the start of the new system.
This is sometimes considered a “cautionary key signature”, as players become used to seeing the
key signature at the start of the system and therefore may miss a change of key signature if it is
not conspicuously shown at the end of systems.
In Dorico Pro, as key signature changes occur immediately after barlines, the key signature at the
end of a system is the key signature itself, rather than a cautionary key signature.
If the music is separate enough that you do not want to see a key signature at the end of a
system and you cannot change where the system break occurs, you can separate the music by
creating a new flow at the point of the system break.
RELATED LINKS
Flows on page 132
Splitting flows on page 342
Formatting panel on page 352
Inserting system breaks on page 466

Tonality systems
The term “tonality system” is used in Dorico Pro to encompass three crucial elements that
together make up the concept of tonality.
The three elements that make up tonality systems are:
●

A number of equal divisions of the octave, or EDO. For example, standard Western scales
with semitone steps have 12-EDO.

●

A set of accidentals. This allows you to notate how much a note is raised or lowered. This can
be a traditional or a custom set of accidentals, either selected from the wide variety available
or of your own design.

●

A key signature. This can be a traditional Western key signature, or a custom key signature of
your own design.

RELATED LINKS
Custom tonality systems on page 851
Changing the tonality system on page 849
Playback of custom tonality systems on page 862

Equal Division of the Octave (EDO)
EDO stands for Equal Division of the Octave: the number of equal pieces, or intervals, into which
an octave is divided. In Dorico Pro, you can create any number of divisions of an octave and
design custom key signatures and custom accidentals for each tonality system.
Traditional Western harmony is based on equal temperament, another method used to describe
tonality systems, or 12-EDO, as the traditional scale from C-C is made up of twelve steps spread
across the seven notes in the scale.
When you edit the 12-EDO tonality system in the Edit Tonality System dialog, you can see how
these steps are divided across each interval in the scale. For example, between the notes A and B
there are two steps, but between B and C there is one step. This is because in 12-EDO, each step
represents a semitone, and there are two semitones between A and B according to standard
equal temperament, but only one semitone between B and C.
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To have the smallest step in the tonality system be a quarter tone rather than a semitone, the
octave must be divided into twice as many equal divisions as 12-EDO. Therefore, to be able to use
quarter tone accidentals in a project, you must choose the Equal temperament (24-EDO)
tonality system for the project.
Although you can divide the octave into any number of divisions, to be able to show a standard
Western key signature, the number of equal divisions in the octave must be divisible by 12.
EDO also allows you to map non-conventional Western pitches on to the seven note names A-G,
and create a coherent notation to express that, because there is no limit to how you can divide
the octave. For example, Turkish music is traditionally divided in 53-EDO, the division of which is
usually spread across the notes A-A with the following number of divisions for each interval:
9-4-9-9-9-4-9.
RELATED LINKS
Custom tonality systems on page 851
Edit Tonality System dialog on page 854

Changing the tonality system
You can change the tonality system used in your project at key signature changes, including
changing to a custom tonality system you have created.
PREREQUISITE
If you want to use a tonality system other than Equal temperament (12-EDO) or Equal
temperament (24-EDO), you have created or imported a custom tonality system.
PROCEDURE
1.

In Write mode, click Key Signatures, Tonality Systems, and Accidentals in the Notations
toolbox to show the Key Signatures, Tonality Systems, and Accidentals panel.

2.

In the music area, select an item at the position from which you want to change the tonality
system.

3.

Without deselecting the item, select the tonality system you want from the menu in the
Tonality System section of the Key Signatures, Tonality Systems, and Accidentals panel.

4.

Input a new key signature.
NOTE
●

If you do not want to show a key signature, you can input an atonal key signature.

●

Key signatures in the Used in This Flow section of the Key Signatures, Tonality Systems,
and Accidentals panel retain their original tonality system. We recommend inputting a
new key signature from scratch when changing the tonality system, such as by using the
popover or the Key Signatures section of the Key Signatures, Tonality Systems, and
Accidentals panel.

RESULT
The tonality system is changed from the key signature you input until the next key signature with
a tonality system change or the end of the flow.
If you selected a tonality system that allows microtonal accidentals, such as Equal temperament
(24-EDO), microtonal accidentals become available in the Accidentals section of the Key
Signatures, Tonality Systems, and Accidentals panel.
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RELATED LINKS
Custom tonality systems on page 851
Creating custom tonality systems on page 851
Input methods for key signatures on page 216
Key Signatures, Tonality Systems, and Accidentals panel on page 217
Inputting microtonal accidentals on page 618

Importing tonality systems
You can import tonality systems into projects, for example, if you want to use a custom tonality
system you created on a different computer. Tonality systems are saved as .doricolib files.
PROCEDURE
1.

In Write mode, click Key Signatures, Tonality Systems, and Accidentals in the Notations
toolbox to show the Key Signatures, Tonality Systems, and Accidentals panel.

2.

In the Tonality System section, click Import Tonality System to open the File Explorer/
macOS Finder.

3.

Locate and select the tonality system file you want to import.

4.

Click Open.

RESULT
The selected tonality system is imported. It becomes available in the current project only.
TIP
If you want to make tonality systems available in all future projects you make on your computer,
you can save them as default in the Edit Tonality System dialog.

Exporting tonality systems
You can export tonality systems so you can send them to other users or use them in other
projects. By default, any tonality systems you create are available in the current project only.
PROCEDURE
1.

In Write mode, click Key Signatures, Tonality Systems, and Accidentals in the Notations
toolbox to show the Key Signatures, Tonality Systems, and Accidentals panel.

2.

In the Tonality System section, select the tonality system you want to export from the
menu.

3.

Click Export Tonality System to open the File Explorer/macOS Finder.

4.

Specify a name and location for the tonality system file.

5.

Click Save.

RESULT
The selected tonality system is exported and saved in the selected location as a .doricolib file.
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TIP
If you want to make tonality systems available in all future projects you make on your computer,
you can save them as default in the Edit Tonality System dialog.

Custom tonality systems
Custom tonality systems allow you to specify a unique number of divisions of the octave for your
project. This can be useful for music not based on traditional Western harmony. In Dorico Pro,
you can design your own custom accidentals and combine them into custom key signatures
within each custom tonality.
You can find existing tonality systems in your project in the Tonality System section of the Key
Signatures, Tonality Systems, and Accidentals panel.
Dorico Pro provides two tonality systems in each project by default: Equal temperament (12EDO) and Equal temperament (24-EDO).
You can create custom tonality systems and edit existing tonality systems in the Edit Tonality
System dialog. You can also export tonality systems, for example, to share them with other
users. Tonality systems are saved as .doricolib files.
RELATED LINKS
Custom divisions of the octave on page 856
Custom accidentals on page 857
Custom key signatures on page 860
Key Signatures, Tonality Systems, and Accidentals panel on page 217

Creating custom tonality systems
You can create your own custom tonality systems, which can have any number of octave
divisions and contain as many custom accidentals and custom key signatures as required. Each
project can contain multiple custom tonality systems.
PROCEDURE
1.

In Write mode, click Key Signatures, Tonality Systems, and Accidentals in the Notations
toolbox to show the Key Signatures, Tonality Systems, and Accidentals panel.

2.

In the Tonality System section, create a new tonality system and open the Edit Tonality
System dialog in one of the following ways:
●

To create an entirely new tonality system, click New Tonality System in the action bar.

●

To create a copy of an existing tonality system, select it from the menu and click
Duplicate Tonality System in the action bar.

3.

Enter a name for the new custom tonality system in the Name field.

4.

In the Divisions section, change the number of octave divisions assigned to each interval.
For example, you might give the intervals A-B, C-D, D-E, F-G and G-A a different number of
octave divisions than for B-C and E-F.

5.

In the Accidentals section, create a new custom accidental or edit an existing accidental.
●

To create a new custom accidental, click New Accidental in the action bar to open the
Edit Accidental dialog.
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6.

●

To create a copy of an existing accidental, select it and click Duplicate Accidental in the
action bar to open the Edit Accidental dialog.

●

To edit an existing accidental, select it and click Edit Accidental in the action bar to open
the Edit Accidental dialog.

Customize the appearance, name, and pitch delta of the accidental.
NOTE
●

We do not recommend setting pitch deltas that are more than half of the total number
of octave divisions.

●

You cannot change the pitch delta of the default Natural accidental.

7.

Click OK to save your changes and close the Edit Accidental dialog.

8.

Optional: Repeat steps 5 to 7 for each accidental you want in your custom tonality system.

9.

In the Custom Key Signatures section, add a new custom key signature or edit one of the
default custom key signatures.
●

To edit one of the default custom key signatures, select it and click Edit Key Signature in
the action bar to open the Edit Custom Key Signature dialog.

●

To create a new custom key signature, click New Key Signature in the action bar to
open the Edit Custom Key Signature dialog.

10. Customize the arrangement of the key signature.
11. Click OK to save your changes and close the Edit Custom Key Signature dialog.
12. Optional: Repeat steps 9 to 11 for each custom key signature you want in your custom
tonality system.
13. Optional: If you want your new custom tonality system to be available in all future projects
you make on your computer, click Save As Default.
14. Click OK to save your changes and close the Edit Tonality System dialog.
RESULT
The new custom tonality system is added to the project and becomes available in the menu in
the Tonality System section of the Key Signatures, Tonality Systems, and Accidentals panel. If
you clicked Save As Default, it is available in all future projects on your computer.
AFTER COMPLETING THIS TASK
●

You can change the tonality system, for example, so your new custom tonality system
applies to a specific section of music.

●

You can export custom tonality systems, for example, to share them with other users.

RELATED LINKS
Changing the tonality system on page 849
Exporting tonality systems on page 850
Edit Accidental dialog on page 857
Edit Custom Key Signature dialog on page 860
Key Signatures, Tonality Systems, and Accidentals panel on page 217
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Creating/Editing custom accidentals
You can create new and edit existing custom accidentals, for example, if your tonality system
does not have equal divisions of the octave and so requires specific accidental glyphs to indicate
the amount by which pitches are raised/lowered.
PREREQUISITE
If you want to create/edit accidentals for a custom tonality system, you have created that custom
tonality system.
PROCEDURE
1.

In Write mode, click Key Signatures, Tonality Systems, and Accidentals in the Notations
toolbox to show the Key Signatures, Tonality Systems, and Accidentals panel.

2.

In the Tonality System section, select the tonality system for which you want to create
custom accidentals from the menu.

3.

Click Edit Tonality System to open the Edit Tonality System dialog.

4.

In the Accidentals section, open the Edit Accidental dialog in one of the following ways:
●

To create a new custom accidental, click New Accidental in the action bar.

●

To create a copy of an existing accidental, select it and click Duplicate Accidental in the
action bar.

●

To edit an existing accidental, select it and click Edit Accidental in the action bar.

5.

Optional: Enter a name for the new custom accidental in the Name field. You can also edit
the name of existing accidentals.

6.

Optional: If you created a new custom accidental, change the value in the Pitch delta value
field to change the number of octave divisions by which it raises/lowers notes.
NOTE

7.

●

We do not recommend setting pitch deltas that are more than half of the total number
of octave divisions.

●

You cannot change the pitch delta of the default Natural accidental.

Customize the appearance of the accidental.
For example, you can add glyphs to your accidental using the options on the right, then
arrange and resize them in the editor.

8.

Click OK to save your changes and close the dialog.

9.

Optional: Repeat steps 4 to 8 for each custom accidental you want to create for the current
tonality system.

10. Click OK to save your changes and close the Edit Tonality System dialog.
AFTER COMPLETING THIS TASK
You can arrange your custom accidentals into a custom key signature.
RELATED LINKS
Edit Accidental dialog on page 857
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Creating/Editing custom key signatures
You can create new and edit existing custom key signatures in any tonality system, for example,
to show an arrangement of custom accidentals.
PREREQUISITE
If you want to create/edit key signatures for a custom tonality system, you have created that
custom tonality system.
PROCEDURE
1.

In Write mode, click Key Signatures, Tonality Systems, and Accidentals in the Notations
toolbox to show the Key Signatures, Tonality Systems, and Accidentals panel.

2.

In the Tonality System section, select the tonality system for which you want to create
custom key signatures from the menu.

3.

Click Edit Tonality System to open the Edit Tonality System dialog.

4.

In the Custom Key Signatures section, open the Edit Custom Key Signature dialog in one
of the following ways:
●

To edit an existing custom key signatures, select it and click Edit Key Signature in the
action bar.

●

To create a new custom key signature, click New Key Signature in the action bar.

5.

Optional: Enter a name for the new custom key signature in the Name field. You can also
edit the name of existing custom key signatures.

6.

Customize the arrangement of the key signature.
For example, you can add accidentals to the key signature and then change the pitch and
octave to which it applies. You can also select other clefs to see how they affect the
arrangement of the key signature.

7.

Click OK to save your changes and close the dialog.

8.

Optional: Repeat steps 4 to 7 for each custom key signature you want to create for the
current tonality system.

9.

Click OK to save your changes and close the Edit Tonality System dialog.

RELATED LINKS
Edit Custom Key Signature dialog on page 860
Custom key signatures on page 860

Edit Tonality System dialog
The Edit Tonality System dialog allows you to create custom tonality systems and edit existing
tonality systems.
You can open the Edit Tonality System dialog in the following ways:
●

To create a new tonality system, click New Tonality System in the Tonality System section
of the Key Signatures, Tonality Systems, and Accidentals panel.
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●

To create a copy of an existing tonality system, select it from the menu in the Tonality
System section of the Key Signatures, Tonality Systems, and Accidentals panel and click
Duplicate Tonality System.

●

To edit an existing tonality system, select it from the menu in the Tonality System section of
the Key Signatures, Tonality Systems, and Accidentals panel and click Edit Tonality System.

Edit Tonality System dialog

The Edit Tonality System dialog contains the following sections and options:
1

Name
Allows you to enter a name for a new tonality system, or edit the name of an existing custom
tonality system you created.

2

Divisions
Allows you to specify how many divisions of the octave you want assigned to each interval.

3

Accidentals
Displays the accidentals currently available in the selected tonality system in a list, from
lowest pitch delta at the top to highest pitch delta at the bottom.
The action bar at the bottom of the section contains the following options:
●

New Accidental: Opens the Edit Accidental dialog and allows you to create a new
accidental.

●

Duplicate Accidental: Opens the Edit Accidental dialog and allows you to create a new
accidental that is a copy of an existing accidental.
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●

Edit Accidental: Opens the Edit Accidental dialog and allows you to edit the existing
selected accidental.

●

Delete Accidental: Deletes the selected accidental.

NOTE
You cannot delete predefined accidentals in the default tonality systems.
4

Custom Key Signatures
Displays the custom key signatures currently available in the selected tonality system.
The action bar at the bottom of the section contains the following options:

5

●

New Key Signature: Opens the Edit Custom Key Signature dialog and allows you to
create a new custom key signature.

●

Edit Key Signature: Opens the Edit Custom Key Signature dialog and allows you to
edit the selected custom key signature.

●

Delete Key Signature: Deletes the selected custom key signature.

Save As Default
Saves the tonality system, either a new custom one or edits you have made to a default
tonality system, as a default in your user library, allowing you to use it in all future projects.

RELATED LINKS
Key Signatures, Tonality Systems, and Accidentals panel on page 217
Custom divisions of the octave on page 856
Edit Accidental dialog on page 857
Edit Custom Key Signature dialog on page 860

Custom divisions of the octave
You can change the number of divisions of the octave for an existing tonality system, or create a
new tonality system with as many divisions of the octave as you like.
In the Divisions section of the Edit Tonality System dialog, you can change the number of
divisions assigned to each interval. The total number of divisions of an octave, which is shown at
the top of the section, is updated automatically as you change the number of divisions.
In Equal temperament, or 12-EDO, the total number of divisions is 12. There are 2 divisions
between A and B, 1 division between B and C, and so on. This follows the standard Western
pattern which you can also see in the pattern of white and black keys on a keyboard.
Although you can divide the octave into any number of divisions, the number of equal divisions
in the octave must be divisible by 12 to be able to show a standard Western key signature in
Dorico Pro.
RELATED LINKS
Creating custom tonality systems on page 851
Custom key signatures on page 860
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Custom accidentals
Custom accidentals can contain traditional accidental glyphs but also other musical symbols,
text, and graphics. This allows you to design accidentals that express specific pitch deltas in your
custom tonality systems.
●

You can find all accidentals available in the current tonality system in the Accidentals section
of the Edit Tonality System dialog.

You can create new and edit existing custom accidentals in the Edit Accidental dialog. You can
edit accidentals included in the default tonality systems that come with Dorico Pro. New custom
tonality systems start with a natural accidental, which you can edit or delete.
RELATED LINKS
Creating custom tonality systems on page 851
Creating/Editing custom accidentals on page 853
Edit Tonality System dialog on page 854

Edit Accidental dialog
The Edit Accidental dialog allows you to create new and edit existing custom accidentals.
●

You can open the Edit Accidental dialog by clicking either New Accidental, Duplicate
Accidental, or Edit Accidental in the action bar at the bottom of the Accidentals section of
the Edit Tonality System dialog.

Edit Accidental dialog

The Edit Accidental dialog contains the following sections:
1

Name
Allows you to enter a name for your accidental.

2

Pitch delta
Allows you to set a value for how much the accidental raises/lowers the pitch of notes. For
example, in 12-EDO, a pitch delta of 2 raises notes by two equal divisions of the octave.
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NOTE
We do not recommend setting pitch deltas that are more than half of the total number of
octave divisions.
3

Accidental component selector
Allows you to choose components to add to your accidental. You can add different types of
components by clicking the respective tab titles.
●

Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting different
fonts and different ranges from the menus. Click Add Glyph to add the selected glyph to
the accidental.
NOTE
A full list of the different ranges of glyphs is available on the SMuFL website.

4

●

Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected text, or
input text, to the accidental.

●

Graphic: Allows you to load a new graphics file, or select an existing graphic from the
Select existing list, in SVG, PNG, or JPG format. You can see a preview of the graphic in
the Preview box. Click Add Graphic to add the selected graphic to the accidental.

Editor
Allows you to arrange and edit the components that make up your accidental. You can use
the controls at the bottom of the dialog to edit and arrange accidental components.

5

Editor action bar
Contains selection and view options for the editor.
●

6

Zoom: Allows you to change the zoom level in the editor.

●

Select: Allows you to select the next/previous component.

●

Delete: Deletes the selected component.

Controls
Contains controls that allow you to edit individual components. Controls are divided into tabs
according to the aspect of the selected component they affect. For accidentals, only the
Component, Attachments, and Cut-outs tabs are available as the Stem tab does not apply
to accidentals.
The Component tab contains the following options:
●

Offset: Controls the position of the selected component. X moves it horizontally, Y
moves it vertically.

●

Scale: Controls the size of the selected component. For graphics, X controls its width, Y
controls its height.
NOTE
Although some components scale their height and width independently, others retain
their aspect ratio, meaning only one value affects their overall size.

●

Z order: Allows you to Bring Forward or Send Backward the selected component in
relation to other components when they overlap.

The Attachments tab is only available if the accidental comprises at least two separate
components. It contains the following options:
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●

Attachment from: Sets the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend that
you select a right edge attachment point for Attachment from.

●

Attachment to: Sets the attachment point on the selected component which attaches to
the component to its left. We recommend that you select a left edge attachment point
for Attachment to.

The Cut-outs tab allows you to mark individual corners within an accidental component that
can overlap with other accidentals, for example, in order to position accidentals closer
together in dense chords. It contains the following options for each of the four corners,
which are labeled according to their compass direction:
●

Width: Sets the width of the cut-out area.

●

Height: Sets the height of the cut-out area.

●

Add: Adds a cut-out to the corresponding corner.

●

Delete: Removes the cut-out from the corresponding corner.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.

The attachment points have the following names in the Edit Accidental dialog:
1

Top Left

2

Top Center

3

Top Right

4

Middle Left

5

Middle Right

6

Baseline Left (text only)

7

Baseline Center (text only)

8

Baseline Right (text only)

9

Bottom Left

10 Bottom Center
11 Bottom Right
RELATED LINKS
Edit Tonality System dialog on page 854
Creating/Editing custom accidentals on page 853
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Custom key signatures
Custom key signatures can comprise traditional accidentals in a different order, or custom
accidentals you have designed in a specific order for your requirements.
●

You can find all key signatures available in the current tonality system in the Custom Key
Signatures section of the Edit Tonality System dialog.

NOTE
If you edit one of the default tonality systems that come with Dorico Pro, no key signatures are
available to edit in this section. However, you can create new key signatures within one of the
default tonality systems.
You can create new and edit existing custom key signatures for both new and existing tonality
systems in the Edit Custom Key Signature dialog. You can then input them from the Custom
Key Signatures section of the Key Signatures, Tonality Systems, and Accidentals panel.
RELATED LINKS
Creating custom tonality systems on page 851
Creating/Editing custom key signatures on page 854
Edit Tonality System dialog on page 854
Key Signatures, Tonality Systems, and Accidentals panel on page 217
Inputting key signatures with the panel on page 221

Edit Custom Key Signature dialog
The Edit Custom Key Signature dialog allows you to create new and edit existing custom key
signatures.
●

You can open the Edit Custom Key Signature dialog by clicking either New Key Signature
or Edit Key Signature in the action bar in the Custom Key Signatures section of the Edit
Tonality System dialog.
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Edit Custom Key Signature dialog

The Edit Custom Key Signature dialog contains the following sections:
1

Name
Allows you to enter a name for your key signature.

2

Clef
Shows how your key signature appears in treble clef, bass clef, alto clef, and tenor clef. You
can edit your key signature in any of these clefs.

3

Root
Allows you to select the base note of your key signature from the menu.

4

Accidentals
Allows you to add accidentals from your tonality system to the key signature, including
custom accidentals you have created in the Edit Accidental dialog. Click Add Accidental to
Key Signature to add the selected accidental to the key signature.

5

Editor
Allows you to arrange accidentals in your preferred order using the Order arrow buttons,
and change their position on the staff using the Note arrow buttons and Octave arrow
buttons.

RELATED LINKS
Key Signatures, Tonality Systems, and Accidentals panel on page 217
Edit Tonality System dialog on page 854
Edit Accidental dialog on page 857
Creating/Editing custom key signatures on page 854
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Playback of custom tonality systems
Dorico Pro can play back custom tonality systems with any number and distribution of octave
divisions.
Dorico Pro achieves full microtonal playback by calculating the appropriate pitch delta for every
note, whether or not it is written with an accidental. Depending on the virtual instruments used
for playback, Dorico Pro produces microtonal playback in different ways.
●

For HALion virtual instruments, Dorico Pro uses VST 3 Note Expression.

●

For all other instruments, including NotePerformer, Dorico Pro uses the VST 2 detune
parameter.

RELATED LINKS
Custom tonality systems on page 851
Changing the playback tuning on page 547
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In Dorico Pro, the term lyrics is used for all text that is sung by singers.
To differentiate sung text from any other forms of text that often appear in musical scores, other
forms of text are referred to as performance instructions, tempos, dynamics, and so on.

Lyrics for a soprano duet with basso continuo accompaniment

In Dorico Pro, lyrics were designed so that it is simple to make changes to existing lyrics without
having to re-input new lyrics each time. For example, you can change the syllable type of lyrics so
that they are either followed or not followed by a hyphen.
Lyrics are organized into lines to ensure consistent horizontal alignment and to make showing
verse numbers simple and accurate. There are different types of lyric lines for lyrics with different
purposes, and the appearance of lyrics changes depending on their line type. For example, lyrics
in a chorus line are shown in an italic font.
When inputting lyrics, you can use key commands to switch between lyric lines, to change on
which side of the staff lyrics are input, and to switch the lyric style between normal lyrics, chorus
lyrics, and translation lyrics. You can also change the type of lyrics after they have been input.
You can input multiple lines of lyrics, chorus lyrics, and translations, both above or below staves.
You can filter existing lyrics according to their type and lyric line.
RELATED LINKS
Types of lyrics on page 865
Lyric line numbers on page 879
Filters for lyrics on page 864
Inputting lyrics on page 293
Changing the syllable type of existing lyrics on page 867

General placement conventions for lyrics
Lyrics are generally placed below the staff to which they apply, and are positioned so that they
align horizontally with their corresponding notehead.
A plain font is generally used for normal lyrics, and an italic font is generally used for chorus
lyrics and translation lyrics in order to differentiate them.
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The horizontal spacing of lyrics must be wide enough so that words or syllables do not overlap
with the words or syllables on either side. For this reason, note spacing must sometimes be
adjusted to accommodate lyrics.
To reduce how severely the note spacing is changed to accommodate lyrics, which can distort the
appearance of rhythms, Dorico Pro allows the alignment of some lyrics to be adjusted relative to
their corresponding notes. For example, if a long, single-syllable word on a long note follows
another long, single-syllable word on a short note, the second word is moved a little to the right
to give both words enough space.

A short note followed by a long note, where the horizontal position of the lyrics is automatically adjusted for
legibility

RELATED LINKS
Positions of lyrics on page 872
Changing the font styles used for lyrics on page 884

Project-wide engraving options for lyrics
You can find options for the project-wide appearance and placement of lyrics on the Lyrics page
in Engrave > Engraving Options.
The options on the Lyrics page allow you to change the default appearance, spacing, and
position of lyrics, and the appearance and position of lyric hyphens and lyric extender lines.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Filters for lyrics
In Dorico Pro, lyrics filters allow you to select all lyrics of a specified type across your project or
across a specific selection.
The following filters are available in the menu when you choose Edit > Filter > Lyrics:
All Lyrics
Selects all types of lyrics in the current selection, with any lyric line number and
placement above/below the staff.
Line 1
Selects only Line 1 lyrics and translation lyrics for Line 1 in the current selection,
including Line 1 below the staff and Line 1 above the staff.
Line 2
Selects only Line 2 lyrics and translation lyrics for Line 2 in the current selection,
including Line 2 below the staff and Line 2 above the staff.
Line 3
Selects only Line 3 lyrics and translation lyrics for Line 3 in the current selection,
including Line 3 below the staff and Line 3 above the staff.
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Line 4
Selects only Line 4 lyrics and translation lyrics for Line 4 in the current selection,
including Line 4 below the staff and Line 4 above the staff.
Line 5
Selects only Line 5 lyrics and translation lyrics for Line 5 in the current selection,
including Line 5 below the staff and Line 5 above the staff.
Above Staff
Selects all lyrics above the staff in the current selection. You can use this filter in
addition to the other filters. For example, you can filter first by line number, and then
filter again by staff-relative placement.
Below Staff
Selects all lyrics below the staff in the current selection. You can use this filter in
addition to the other filters. For example, you can filter first by line number, and then
filter again by staff-relative placement.
Chorus
Selects all chorus lyrics in the current selection.
Translations
Selects all translation lyrics in the current selection.

Selecting lyrics using filters
You can use lyric filters to select all lyrics of a specified type across your project or across a
specific selection.
PREREQUISITE
You filter setting is set to Select Only. You can check this by choosing Edit > Filter > Select Only.
PROCEDURE
1.

In the music area, make a selection that includes all the lyrics you want to select.
For example, press Ctrl/Cmd-A to select the whole flow.

2.

Choose Edit > Filter > Lyrics > [Lyrics type].

RESULT
All lyrics of the selected type in your selection are selected. For example, if you choose Edit >
Filter > Lyrics > Chorus, all chorus lyrics in your selection are selected.
RELATED LINKS
Filters for lyrics on page 864
Large selections on page 322

Types of lyrics
Lyrics are divided into different lyric types in Dorico Pro.
Lyric lines
Lyric lines contain normal lyrics and can be shown with verse numbers. They can be
both below and above the staff.
Chorus lines
Chorus lines contain lyrics in an italic font and are placed between lyric lines. For
example, if there are two lyric lines, the chorus line appears between Line 1 and Line 2.
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Chorus lines do not have verse numbers.
Lyric line translations
Lyric line translations show the text in lyric lines or chorus lines in different languages.
They are placed directly below the lyric line or chorus line of which they are a
translation. They are shown in an italic font.
Each lyric line can have its own lyric line translation, including chorus lines.
Lyric line translations do not have verse numbers, as they are part of the line of which
they are a translation.
You can input all types of lyrics using the lyrics popover. The icon shown on the left-hand side of
the popover indicates the type of lyric currently being input.
RELATED LINKS
Lyric line numbers on page 879
Changing the line number and type of lyric lines on page 880
Lyrics popover on page 294

Changing the type of individual lyrics
You can change the type of individual lyrics after they have been input. For example, you can
change lyrics into chorus lyrics or translation lyrics.
PROCEDURE
1.

Select the individual lyrics whose type you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate/deactivate the following properties, individually or together,
in the Lyrics group:
●

Chorus

●

Is translation

RESULT
●

Activating Chorus changes the selected individual lyrics to chorus lyrics.

●

Activating Is translation changes the selected lyrics to translation lyrics of the same lyric line
number. For example, selecting lyrics in Line 2 and activating Is translation turns them into
translation lyrics for Line 2.

●

Activating both properties changes the selected lyrics to translation lyrics of the chorus.

●

Deactivating both properties changes the selected lyrics to normal lyrics. Their line number
is indicated by the number in Line number in the Lyrics group of the Properties panel.

NOTE
If other chorus lines exist at the same position on the side of the staff where you want to change
your current selection to chorus lines, the two lines collide. To avoid this, change the type of the
whole lyric line, which automatically avoids collisions.

RELATED LINKS
Showing lyrics in italics on page 884
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Types of syllables in lyrics
There are different types of syllables in lyrics, depending on their position in words. The key you
press to advance the popover indicates the syllable type for each lyric.
Dorico Pro defines lyrics as different syllables depending on how you advance the popover when
inputting lyrics.
Whole word
Lyrics are considered a whole word if the lyric comes after a gap and is followed by a
gap or a period.
No hyphens are shown either side of whole word lyrics. Extender lines can be shown
after lyrics.
Start
Lyrics are considered the start syllable in a multi-syllabic word if the lyric comes after a
gap, but is followed by a hyphen.
Hyphens are shown after start lyrics, which can be continuation hyphens depending on
the distance before the next lyric in the same lyric line.
Middle
Lyrics are considered the middle syllable in a multi-syllabic word if the lyric comes after
a hyphen, and is followed by a hyphen.
Hyphens are shown after middle lyrics, which can be continuation hyphens depending
on the distance before the next lyric in the same lyric line.
End
Lyrics are considered the end syllable in a multi-syllabic word if the lyric comes after a
hyphen but is followed by a gap or a period.
Extender lines can be shown after end lyrics.
RELATED LINKS
Inputting lyrics on page 293

Changing the syllable type of existing lyrics
You can change the syllable type of lyrics after they have been input.
For example, if you advanced the lyrics popover to the next note by pressing Space but you later
want it to be followed by a hyphen, you can change its syllable type.
NOTE
Changing the syllable type changes whether a hyphen is shown after the selected lyrics, not
before them. Therefore, if you want to show a hyphen before lyrics, you must change the syllable
type of the lyrics immediately preceding them.

PROCEDURE
1.

Select the lyrics whose syllable type you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, select one of the following options from the Syllable type menu in
the Lyrics group:
●

Whole word

●

Start

●

Middle
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●

End

RESULT
Lyrics with a syllable type of Whole word or End are followed by a space.
Lyrics with a syllable type of Start or Middle are followed by a hyphen.
RELATED LINKS
Inputting lyrics on page 293

Deleting lyric lines
You can delete whole lines of lyrics.
PROCEDURE
1.

In Write mode, select the staves from which you want to delete a whole lyric line.

2.

Select just the lyric line you want to delete by choosing Edit > Filter > Lyrics > [Lyrics type].

3.

Press Backspace or Delete .

RESULT
All lyrics in the selected lyric line are deleted.
RELATED LINKS
Filters for lyrics on page 864
Selecting lyrics using filters on page 865
Large selections on page 322

Deleting lyrics individually
You can delete individually selected lyrics without deleting other lyrics in the same lyric line.
PROCEDURE
1.

In Write mode, select the lyrics you want to delete.

2.

Press Backspace or Delete .

RESULT
The selected lyrics are deleted.

Copying/Pasting lyrics
You can copy and paste lyrics from both existing lyric lines in Dorico Pro and from external text
editors, for example, if you want to copy a lyric line to a player who has different rhythms to the
source but uses the same lyrics.
When copying text from outside Dorico Pro, you must format the text so it is suitably separated
into syllables, for example, by adding hyphens in multi-syllabic words. This ensures Dorico Pro
can correctly identify the characters required for each word/syllable and therefore format the
resulting lyrics appropriately. There are automatic hyphenation tools that you can use, but
results from these are not always reliable. Dorico Pro checks text you have copied to your
clipboard to make sure it contains only single spaces and single hyphens for correct syllable
input.
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NOTE
You cannot currently copy/paste lyrics containing Chinese, Japanese, or Korean characters. This is
planned for future versions.

PROCEDURE
1.

In Write mode, select the lyrics/text you want to copy.
TIP
If you want to select many lyrics, you can use filters for lyric lines or you can select a single
lyric and press Ctrl/Cmd-Shift-A multiple times to select the rest of the lyrics in the lyric line.

2.

Press Ctrl/Cmd-C to copy the selected lyrics/text.

3.

In Write mode, select the first note in the voice to which you want to copy lyrics.

4.

Press Shift-L to open the lyrics popover.
By default, the lyrics popover opens with lyric line input selected.

5.

6.

Optional: Change the lyric type into which you will paste lyrics in one of the following ways:
●

To change the lyric line number, press Down Arrow .

●

To change to a lyric line above the staff, press Shift - Up Arrow .

●

To change to a chorus line, press Up Arrow .

●

To change to a translation lyric line, press Alt/Opt - Down Arrow .

Press Ctrl/Cmd-V to paste the first word/syllable of the copied lyrics/text.
The lyrics popover automatically advances to the next note in the selected voice according to
the source text. For example, for syllables followed by hyphens in the source, the popover
advances as if you had pressed - (hyphen), which automatically shows hyphens after those
syllables.

7.

8.

Optional: For words/syllables that you want to apply to two or more notes, you must advance
the popover manually in one of the following ways:
●

After complete words or the final syllable in multi-syllabic words, press Space .

●

After syllables that are not the final syllable in multi-syllabic words, press - (hyphen).

●

After syllables that you do not want to be followed by an extension line or hyphen, press
Right Arrow .

Continue pressing Ctrl/Cmd-V for each word/syllable you want to paste.

RESULT
The selected lyrics/text is pasted into the selected lyric line belonging to the voice in which you
selected a note.
NOTE
Words/syllables are removed from your clipboard as you paste them. If you want to paste the
same lyrics/text again into another lyric line or staff, you must copy the source again.

RELATED LINKS
Edit Lyrics dialog on page 870
Large selections on page 322
Selecting lyrics using filters on page 865
Selecting more items of the same type on page 320
Lyrics popover on page 294
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Lyric text editing
Proofreading lyrics can be challenging, because lyrics are spaced more widely than regular text
and individual words are often split up over large horizontal distances. In Dorico Pro, you can
change the text of individual words/syllables within the lyrics popover and also by viewing entire
lyric lines in a single dialog.

Editing existing lyrics
You can change the text of lyrics after they have been input, for example, to correct misspellings.
NOTE
This resets any properties you had set on the affected lyrics.

PROCEDURE
1.

In Write mode, select the lyric you want to change.
NOTE
You can only change one lyric at a time.

2.

Press Return or Shift-L to open the lyrics popover.

3.

Change the existing text in the lyrics popover.

4.

Optional: If you want to change other existing lyrics, advance the popover in one of the
following ways:
●

To advance the popover to the next note if you entered a complete word, or the final
syllable in a multi-syllabic word, press Space .
Existing lyrics are automatically selected in the popover when you press Space .

●

To advance the popover to the next note if you entered one syllable of a multi-syllabic
word, press - .

●

To move the cursor one character to the right, press Right Arrow .

●

To move the cursor one character to the left, press Left Arrow .
The cursor automatically moves to the next/previous lyric/note if you keep pressing the
arrow keys.

5.

Press Return or Esc to close the popover when you have finished changing lyrics.
The popover closes automatically when you reach the last note on the staff.

RELATED LINKS
Lyric line numbers on page 879
Inputting lyrics on page 293

Edit Lyrics dialog
The Edit Lyrics dialog allows you to view and edit entire lyric lines in one place and with the text
displayed with consistent spacing. This is more convenient than changing each word/syllable
individually alongside the music, where lyrics can be split up over large horizontal distances.
●

You can open the Edit Lyrics dialog by making a selection that includes at least a single lyric
and choosing Edit > Lyrics > Edit Line of Lyrics.

The dialog shows all lyrics in the same lyric line as the selected lyric and allows you to edit the
lyrics, such as fixing misspellings, adding commas, or changing where in a word the hyphen is
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placed. If you selected multiple lyrics to open the dialog, Dorico Pro populates the dialog with the
lyric line of the earliest lyric on the highest staff you selected.

Edit Lyrics dialog

The Edit Lyrics dialog comprises the following:
1

Text editor
Allows you to edit all the lyrics in the selected lyric line in the current flow, with hyphens and
spaces as appropriate. For example, you can add a comma after the final syllable in a line for
a poem setting or replace a hyphen with a space.
NOTE
You cannot add, delete, or change the duration/rhythmic position of lyrics, such as the
number of notes to which each lyric applies.

2

Zoom controls
Allow you to increase/decrease the size of text in the dialog.

3

Current number of lyrics
Displays the number of lyrics currently shown in the text editor and the target number of
lyrics in the lyric line. The target number is the number of lyrics that already exists in the
selected lyric line in the flow.
The current number of lyrics updates automatically as you work in the dialog. Dorico Pro
requires the current number and target number of lyrics to match before you can confirm
the dialog.

4

OK button
Allows you to confirm your changes and close the dialog. You can only confirm the dialog
when the current number and target number of lyrics match.

NOTE
Any properties you had previously set on any lyrics in the line, such as making them italic, are
reset when you confirm the dialog.

RELATED LINKS
Showing lyrics in italics on page 884
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Positions of lyrics
Dorico Pro automatically positions lyrics and makes adjustments to accommodate variations in
the length of lyrics, including adjusting the horizontal alignment of lyrics in melismatic music.
However, you can also move lyrics manually and also change their default positions project-wide.
You can move lyrics to different rhythmic positions in Write mode. They are positioned by default
according to your chosen options on the Lyrics page in Engrave > Engraving Options.
You can move individual lyrics graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached.
NOTE
The horizontal position of lyrics is automatically adjusted in Dorico Pro to minimize changes to
the note spacing. Syllables are moved by small amounts either left or right to accommodate
longer syllables without distorting the appearance of note rhythms.
Moving lyrics graphically in Engrave mode overrides the automatic spacing for the selected lyrics.
If you move a lyric whose position was automatically readjusted, the note spacing at that
rhythmic position might change.
You can prevent Dorico Pro from considering lyrics in note spacing calculations using the Make
space for lyrics option on the Note Spacing page in Setup > Layout Options and in the Note
Spacing Change dialog; however, we recommend using this option with caution.
You can change the default positions of lyrics project-wide on the Lyrics page in Engraving
Options.
The default settings for lyrics on the Lyrics page in Engraving Options are optimized for scores
with comfortable spacing. If your project requires note spacing to be narrower, with less room
for each note, change these settings to achieve a clearly legible result without the need for lots of
editing in Engrave mode.
For scores that have less horizontal space, the following changes often improve the appearance
of lyrics and rhythmic space:
●

Make minimum gaps smaller, such as the minimum gap between lyrics and hyphens, in the
Hyphens section of the Lyrics page in Engraving Options.

●

Increase the amount that lyrics can be adjusted by in the Spacing section of the Lyrics page
in Engraving Options.

Positions of syllables
The number of notes sung on syllables or words determines how the lyrics are positioned:
●

Single syllables, which are whole words or parts of longer words that are sung on only one
note, are centered on their corresponding note.

●

Melismata, which are syllables or words that are sung on more than one note, are leftaligned with the left side of the first note to which they apply.

Placement of lyric lines
Lyrics are placed relative to other lyric lines according to their line number. For example, lyrics in
Line 1 are placed at the top, including when there are multiple lyric lines above the staff.
If a line of lyrics is missing across the width of a whole system, no additional gap is left between
the remaining lines of lyrics.
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You can also move individual lyric lines vertically. In Engrave mode, when you select any lyric in a
lyric line, a square handle appears on the bottom left of the first lyric in the line on that system.
This allows you to adjust the vertical position of lyric lines independently of other lyric lines.

Square handle selected at the start of a lyric line in Engrave mode

EXAMPLE
You have three lines of lyrics, but one system does not have a second line of lyrics. On this
system, the third line of lyrics is moved upwards, closer to the first line of lyrics.
If a subsequent system does not have a first line, but does have the second and third lines, then
the second and third lines of lyrics are moved upwards. The second line of lyrics takes the place
of the first line.
RELATED LINKS
Project-wide engraving options for lyrics on page 864
Moving lyrics graphically on page 874
Moving lyric lines vertically on page 874
Changing the staff-relative placement of lyric lines on page 881
Note Spacing page in Layout Options on page 426
Note Spacing Change dialog on page 427

Moving lyrics rhythmically
You can move lyrics to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the lyrics you want to move.

2.

Move the lyrics according to the current rhythmic grid resolution in any of the following
ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

NOTE
You cannot move lyrics rhythmically with the mouse, you can only move them using the
keyboard.

RESULT
The selected lyrics are moved to new rhythmic positions.
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Moving lyrics graphically
You can move individual lyrics graphically without changing the rhythmic positions to which they
apply.
NOTE
Moving lyrics graphically in Engrave mode overrides the automatic spacing of the selected lyrics.
If you move a lyric whose position was automatically readjusted, the spacing at that rhythmic
position might change.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select the lyrics you want to move.

2.

Move the selected lyrics in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them to the right/left.

RESULT
The selected lyrics are moved to the right/left.
NOTE
You cannot move individual lyrics upwards/downwards, but you can move lyric lines upwards/
downwards on a per-system basis. Their default vertical position is determined by their lyric line
number and your project-wide settings in Engrave > Engraving Options.

RELATED LINKS
Changing the line number and type of lyric lines on page 880
Changing the staff-relative placement of lyric lines on page 881

Moving lyric lines vertically
You can move lyric lines graphically upwards/downwards on a per-system basis, independently
of your project-wide settings. For example, if the shapes of phrases on certain systems make lyric
lines appear unevenly centered between staves.
NOTE
●

You cannot move individual lyrics upwards/downwards; instead, you can change their lyric
line number or staff-relative placement.

●

We recommend that you add extra pages and finish laying out your pages before moving
individual lyric lines vertically, as lyric line offsets are automatically deleted if the frame in
which they occur changes. For example, if you move lyric lines individually and then add a
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blank page at the start of the layout, all of the individual lyric line offsets in the layout are
deleted.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select any of the following in each system where you want to move lyric
lines vertically:
●

Any lyric in each lyric line you want to move vertically.

●

The handles on the bottom left of the first lyric on each lyric line you want to move
vertically.
NOTE
When using the mouse, you must only select handles at the start of each lyric line.

2.

Move the selected lyric lines upwards/downwards in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag the handles upwards/downwards.

RESULT
The selected lyric lines are moved upwards/downwards on the selected systems. This does not
affect the vertical offset of any other lyric lines on those systems.
TIP
You can change the default position of lyrics relative to the staff, other lyric lines, and to other
objects project-wide in the Vertical Position section of the Lyrics page in Engraving Options.
EXAMPLE
Because of the shape of the music in this example, the default vertical alignment of the chorus in
the middle of the three lyric lines for the verses causes the chorus to appear much closer to
notes on the top staff than the bottom staff. Moving the chorus line downwards makes it appear
more evenly distributed between the staves.
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Default chorus placement

Chorus line moved downwards

RELATED LINKS
Changing the line number of individual lyrics on page 881
Changing the type of individual lyrics on page 866
Project-wide engraving options for lyrics on page 864

Removing lyric line vertical offsets
You can remove changes you have made to the vertical offsets of individual lyric lines and reset
them to their default positions.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

2.

In Engrave mode, select one of the following:
●

To remove offsets from specific lyric lines in specific systems, select any lyric in each lyric
line and in each system.

●

To remove offsets from all lyric lines in specific frames, select any lyric in each frame.

●

To remove offsets from all lyric lines in the layout, select any lyric in any frame.

Remove lyric line offsets in one of the following ways:
●

To remove offsets from all lyric lines in the current layout, choose Engrave > Lyric
Offsets > Reset Layout.

●

To remove offsets from all lyric lines in the selected frames, choose Engrave > Lyric
Offsets > Reset Selected Frames.

●

To remove offsets from only the selected lyric lines in the selected systems, choose
Engrave > Lyric Offsets > Reset Selected Systems.

Changing the alignment of lyrics relative to notes
By default, the center of lyrics is aligned horizontally with noteheads, but you can change the
horizontal alignment of individual lyrics.
There is no default setting for the alignment of lyrics relative to notes, as Dorico Pro
automatically adjusts the horizontal position of lyrics to minimize note spacing changes.
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NOTE
Changing the alignment of lyrics manually overrides Dorico Pro‘s automatic spacing for the
selected lyrics, meaning that note spacing at the affected rhythmic positions might change.

PROCEDURE
1.

Select the lyrics whose alignment you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Lyric text alignment in the Lyrics group.

3.

Select one of the following alignment options from the menu:
●

Left

●

Center

●

Right

RESULT
The alignment of the selected lyrics is changed.

Lyric hyphens and lyric extender lines
Lyric hyphens indicate that individual lyrics are syllables within multi-syllabic words, for example,
“Hal-le-lu-jah”. Lyric extender lines indicate that individual lyrics, either whole words or the last
syllables in multi-syllabic words, extend across multiple notes.

A phrase containing hyphens and an extender line

Dorico Pro automatically inputs and positions lyric hyphens when you advance the lyrics popover
by pressing - between syllables, and lyric extender lines when you advance the lyrics popover by
pressing Space multiple times after an entry.
In Engrave mode, lyric hyphens and lyric extender lines have two square handles, one at the start
and one at the end. You can move whole lyric hyphens and lyric extenders lines, and you can also
move their handles independently of each other. This allows you to lengthen/shorten lyric
hyphens and extender lines, which for lyric hyphens means increasing/decreasing the length of
the space in which lyric hyphens are shown.

Lyric extender line with handles shown

Lyric hyphen with handles shown

NOTE
You can change the default lyric hyphen in the Hyphens section of the Lyrics page in Engrave >
Engraving Options.

RELATED LINKS
Lengthening/Shortening lyric extender lines and hyphens on page 878
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Moving lyric extender lines and hyphens
You can move lyric extender lines and hyphens horizontally.
NOTE
You cannot move lyric extender lines or hyphens upwards/downwards, as their vertical position
is determined by their lyric line number and your project-wide settings in Engrave > Engraving
Options.

PROCEDURE
1.

In Engrave mode, select the lyric extender lines or hyphens that you want to move.

2.

Move the lyric extender lines or hyphens in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them to the right/left.

RESULT
The selected lyric extender lines or hyphens are moved to the right/left.
NOTE
●

The start handles of lyric extender lines are attached to the lyrics from which they extend,
and the start handles and end handles of lyric hyphens are attached to the lyrics on each
side. If you move either of those lyrics, the corresponding lyric extender line or hyphen
handles also move.

●

You can change the position of lyric extender lines and hyphens relative to lyrics, to the ends
of systems, and to other extender lines and hyphens for all lyric extender lines and hyphens
project-wide in the Extender Lines and Hyphens sections of the Lyrics page in Engraving
Options.

Lengthening/Shortening lyric extender lines and hyphens
You can lengthen/shorten individual lyric extender lines and lyric hyphens. Lengthening/
Shortening lyric hyphens increases/decreases the space in which lyric hyphens are shown.
NOTE
The start handles of lyric extender lines and hyphens are attached to the lyrics from which they
extend. If you move those lyrics, the start handles also move.

PROCEDURE
1.

In Engrave mode, select the square handles at one of the following positions on the lyric
extender lines or hyphens you want to lengthen/shorten:
●

The start of lyric extender lines or hyphens

●

The end of lyric extender lines or hyphens
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TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●
3.

Click and drag them to the right/left.

Optional: Repeat steps 1 and 2 for the other handle of the lyric extender lines or hyphens.

RESULT
The length of the selected lyric extender lines is changed. For example, moving the start handle
of a lyric extender line to the right without moving the end handle makes the line shorter.
Lengthening/Shortening lyric hyphens does not change the size or shape of the hyphens
themselves. Instead, you increase/decrease the distance between the handles in which hyphens
can appear.
NOTE
●

Depending on your settings for the size of gaps relating to hyphens in the Hyphens section
of the Lyrics page in Engrave > Engraving Options, more/fewer hyphens can appear in the
space when you lengthen/shorten lyric hyphens.

●

The following properties in the Lyrics group of the Properties panel are activated if you
move the corresponding handle on lyric extender lines and hyphens:
●

Line start X moves the start handles of lyric extender lines and hyphens horizontally.

●

Line end X moves the end handles of lyric extender lines and hyphens horizontally.

For example, if you move a whole lyric extender line to the right, both handles are moved so
both properties are activated. You can also use these properties to move lyric extender lines
and hyphens graphically by changing the values in the value fields.
Deactivating the properties resets the selected lyric extender lines and hyphens to their
default positions.

Lyric line numbers
Lyric line numbers are used to organize lyrics when a single musical passage can have different
lyrics sung to it, such as music that contains multiple verses. In Dorico Pro, you can specify the
line number of lyrics as you input them and by changing the line number of existing lyrics.
For example, if you input lyrics in Line 3 but later want to change those lyrics to Line 4 because
you want to input different lyrics as Line 3, you can change your current Line 3 into Line 4, and
then input a new line of lyrics as Line 3. The spacing is automatically adjusted to show lyric lines
in the correct order.
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The start of a choral piece with three lyric lines for its three verses

In Dorico Pro, you can have multiple lines of lyrics both above and below the same staff. Turning
lyric lines into chorus lyric lines or lyric line translations changes both their placement and
appearance as chorus lyrics generally use an italic font.
RELATED LINKS
Verse numbers on page 882
Filters for lyrics on page 864
Showing lyrics in italics on page 884

Changing the line number and type of lyric lines
You can change the lyric line number of whole lyric lines after they have been input. You can also
change whole lyric lines to chorus lines and lyric line translations.
For example, you can change the existing Line 1 into a lyric translation of Line 4, or change Line 2
into a chorus line.
TIP
To identify which line you are working on, select a syllable in the line of lyrics and check the
number in the Line number value field in the Lyrics group of the Properties panel. Alternatively,
you can activate verse numbers on the Lyrics page in Engrave > Engraving Options.

PROCEDURE
1.

In Write mode, select a lyric in the line whose lyric line type you want to change. The lyric line
can be above or below the staff.
TIP
You can also make a selection and use the lyric filters to select different lyric lines according
to their line numbers.

2.

Change the line type of the selected lyric line in one of the following ways:
●

Choose Edit > Lyrics > Line > [Line number].

●

Choose Edit > Lyrics > Line > Chorus.

●

Choose Edit > Lyrics > Translations > [Line number Translation].

●

Choose Edit > Lyrics > Translations > Chorus Translation.
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TIP
You can also choose these options from the context menu.

RESULT
The line number or type of the whole lyric line of the selected lyric is changed.
NOTE
The position of the selected lyric line relative to other lyric lines at the same position might be
changed. For example, if there were two lyric lines and you changed Line 1 to Line 3, it now
appears below Line 2.
If a lyric line with the same number already exists at the same position on the same side of the
staff, the two lines switch. For example, if there is already a Line 1 at the rhythmic position where
you want to change Line 2 to Line 1, then the existing Line 1 becomes Line 2 to accommodate
your most recent preference. The same applies to chorus lines and lyric line translations.

RELATED LINKS
Lyric line numbers on page 879
Types of lyrics on page 865
Filters for lyrics on page 864

Changing the line number of individual lyrics
You can change the lyric line number of individually selected lyrics after they have been input.
PROCEDURE
1.

Select the individual lyrics whose line number you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, change the value for Lyric number in the Lyrics group.

RESULT
The line number of the selected lyrics is changed to match the value in the value field.
NOTE
The position of the selected lyrics relative to other lyric lines might be changed. For example, if
there were two lyric lines and you changed lyrics in Line 1 to Line 3, they now appear below Line
2.

Changing the staff-relative placement of lyric lines
You can change the staff-relative placement of whole lyric lines after they have been input.
PROCEDURE
1.

In Write mode, select a lyric in each line whose staff-relative placement you want to change.
TIP
You can also make a selection and use the lyric filters to select different lyric lines according
to their line numbers and staff-relative placement.

2.

Select the staff-relative placement you want in one of the following ways:
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●

Choose Edit > Lyrics > Placement > Above.

●

Choose Edit > Lyrics > Placement > Below.

TIP
You can also choose these options from the context menu.

RESULT
The staff-relative placement of the whole lyric lines in which you selected lyrics is changed.
NOTE
If other lyric lines with the same lyric line number exist at the same position on the side of the
staff to which you want to change your current selection, the two lines switch sides. For example,
if there is already a Line 2 above the staff at the position where you want to change the
placement of Line 2 below the staff, then the existing Line 2 above the staff is placed below the
staff to accommodate your most recent preference.

RELATED LINKS
Lyric line numbers on page 879
Filters for lyrics on page 864
Changing the line number and type of lyric lines on page 880

Changing the staff-relative placement of individual lyrics
You can change the staff-relative placement of individual lyrics within lyric lines.
PROCEDURE
1.

Select the lyrics whose staff-relative placement you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, choose one of the following options for Line placement in the
Lyrics group:
●

Above

●

Below

RESULT
The staff-relative placement of the selected individual lyrics is changed.
NOTE
If other lyric lines with the same lyric line number already exist at the same position on the same
side of the staff, the two lines collide. To avoid this, change the lyric line number of one of the
lyric lines, or change their staff-relative placement by choosing Edit > Lyrics > Placement and
selecting an option from the menu, which avoids collisions.

Verse numbers
Verse numbers indicate the order in which lyrics are sung when multiple lines of lyrics share the
same musical passage. They are commonly used in hymns and song sheets.
Depending on the type of music you are writing, verse numbers might not be appropriate.
Therefore, hiding/showing verse numbers in Dorico Pro is optional. By default, verse numbers
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are not shown. You can hide/show verse numbers on all lines of lyrics project-wide and on
individually selected lyrics.
When verse numbers are shown on all lyric lines project-wide, they only appear before the first
lyric in the line by default, they are not repeated on subsequent systems automatically.
Therefore, if you want to show verse numbers at the start of subsequent systems, you must
show verse numbers on those individual lyrics.
NOTE
Lyric line translations are part of the lyric line of which they are a translation so do not have their
own verse number.

Hiding/Showing verse numbers project-wide
You can hide/show verse numbers project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Lyrics in the page list.

3.

In the Verse Numbers section, choose one of the following options for Verse numbers for
each line of lyrics:

4.

●

Show verse numbers

●

Do not show verse numbers

Click Apply, then Close.

RESULT
Verse numbers are either shown or hidden project-wide.

Changing the punctuation of verse numbers
You can change how verse numbers are punctuated project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Lyrics in the page list.

3.

In the Verse Numbers section, choose one of the following options for Punctuation for
verse numbers:

4.

●

Append period (full stop)

●

Do not append period (full stop)

Click Apply, then Close.

RESULT
Verse numbers are shown with/without a period project-wide.

Hiding/Showing verse numbers on individual lyrics
You can hide/show verse numbers on individual lyrics, independently of your project-wide
setting, for example, if you want to show the verse number at the start of every system.
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PROCEDURE
1.

Select the lyrics before which you want to hide/show verse numbers. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Show verse number in the Lyrics group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Verse numbers are shown before the selected lyrics when the checkbox is activated, and hidden
when the checkbox is deactivated.
When the property is deactivated, lyrics follow your project-wide setting for hiding/showing verse
numbers.

Changing the font styles used for lyrics
You can change aspects of the fonts used for the available types of lyrics project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2.

Select the font you want to change from the Font style menu:

3.

●

Lyrics Font

●

Lyrics Translation Font

●

Lyrics Verse Numbers Font

●

Chorus lyrics Font

●

Chorus lyrics translation Font

Activate the following options, individually or together, to change the corresponding aspect
of the font:
●

Font family

●

Size

●

Style

●

Underlined

4.

Optional: Repeat steps 2 and 3 for each font whose style you want to change.

5.

Click OK to save your changes and close the dialog.

RESULT
The font style for the selected lyrics type is changed project-wide.
RELATED LINKS
Edit Font Styles dialog on page 407

Showing lyrics in italics
You can show individual lyrics in an italic font without changing their font style, lyric type, or
staff-relative placement.
PROCEDURE
1.

Select the lyrics you want to show in an italic font. You can do this in Write mode and
Engrave mode.
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2.

In the Properties panel, activate Italic in the Lyrics group.

RESULT
The selected lyrics are shown in an italic font.
TIP
If you want to show lyrics in an italic font because they are intended to be either chorus lyrics or
translation lyrics, you can change their lyric type instead.
If you want all normal lyric lines to appear in an italic font project-wide, you can change the font
style of the Lyrics Font.

RELATED LINKS
Changing the line number and type of lyric lines on page 880
Changing the type of individual lyrics on page 866

East Asian elision slurs
East Asian elision slurs are used to show that two or more characters in East Asian languages are
part of the same lyric.

A phrase containing an East Asian elision slur

You can hide/show East Asian elision slurs on all applicable lyrics project-wide and on individual
lyrics.

Hiding/Showing East Asian elision slurs
You can hide/show East Asian elision slurs for individual lyrics, independently of your projectwide setting.
PROCEDURE
1.

Select the lyrics on which you want to show East Asian elision slurs. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Show East Asian elision slur in the Lyrics group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
East Asian elision slurs are shown on the selected lyrics when the checkbox is activated, and
hidden when the checkbox is deactivated.
When the property is deactivated, lyrics follow your project-wide setting.
TIP
You can choose to hide/show East Asian elision slurs on all applicable lyrics project-wide on the
Lyrics page in Engrave > Engraving Options.
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Notes are shapes that are positioned on staves to indicate musical pitches. Notes are most
commonly shown with oval-shaped, round noteheads that are either filled or void depending on
their duration, but there are many different designs of noteheads that you can use.
Depending on their duration, notes can have stems that help indicate their duration.
In Dorico Pro, a sequence of adjacent notes joined with ties is considered a single note of the
total duration of the tie chain, rather than separate notes. Note grouping is automatically
adjusted according to the prevailing beat grouping, which is normally set by the time signature.
RELATED LINKS
Inputting notes on page 172
Note spacing on page 425
Stems on page 1195
Changing the notehead design of individual noteheads on page 898
Add intervals popover on page 198
Adding notes above/below existing notes on page 198
Bracketed noteheads on page 906
Ties on page 1219
Note and rest grouping on page 681
Beam grouping according to meters on page 665

Project-wide engraving options for notes
There are a number of options for the appearance of notes and noteheads project-wide that you
can choose from on the Notes page in Engrave > Engraving Options.
The options on this page allow you to change the design, appearance, and position of noteheads,
ledger lines, stem flags, and rhythm dots. You can also change the appearance of double whole
notes (breves) and the size of grace notes relative to normal notes.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Notehead sets
A notehead set is a collection of related noteheads that together allow you to represent all the
different noteheads required for the different durations used in music notation.
A typical notehead set contains at least four noteheads:
●

A black notehead for quarter notes (crotchets) and shorter

●

A white notehead for half notes (minims)

●

A wider white notehead for whole notes (semibreves)

●

A wider white notehead with one or two vertical strokes on either side, or a square white
notehead, for double whole notes (breves)
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Pitch-dependent notehead sets contain noteheads that vary according to the pitch of notes
rather than their duration.
●

In pitched notehead sets, there are different noteheads for different pitches.
For example, the Pitch Names notehead set shows the letter name and any applicable
accidental of each note within its notehead.

●

In scale degree notehead sets, there is a different notehead for each scale degree, relative to
the current key signature.
For example, the Aikin 7-shape notehead set uses a different notehead shape for each pitch.

NOTE
●

A single notehead can appear in multiple notehead sets. If you edit a notehead within one
notehead set, your changes affect the appearance of that notehead in all notehead sets that
contain it.

●

Notehead sets can only contain noteheads of the same type. For example, you cannot use a
normal notehead in a pitched notehead set.

●

You cannot change the type of an existing notehead set or an existing notehead.

RELATED LINKS
Pitch-dependent notehead set designs on page 890
Custom notehead sets on page 891

Notehead set designs
There are a number of different notehead set designs that you can use for individual noteheads
in Dorico Pro.
●

You can find the available notehead designs by choosing Edit > Notehead > [Notehead
type] > [Notehead design].

NOTE
Dorico Pro does not offer stemless noteheads. Instead, you can hide the stems of notes with any
notehead design.

Notehead set design

Notehead set name
Larger Noteheads

Default Noteheads

Large Circled Noteheads

Circled Noteheads
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Notehead set design

Notehead set name
Slashed Noteheads (Bottom Left to Top Right)

Slashed Noteheads (Top Left to Bottom Right)

Cross noteheads
Notehead set design

Notehead set name
Circle X Noteheads

Large X and Diamond Noteheads

Ornate X Noteheads

Plus Noteheads

With X Noteheads

X Noteheads

X and Circle X Noteheads

X and Diamond Noteheads

888
Dorico Pro 3.1.10

Notes
Notehead sets
Triangular noteheads
Notehead set design

Notehead set name
Large Arrow Down Noteheads

Large Arrow Up Noteheads

Triangle Down Noteheads

Triangle Left Noteheads

Triangle Right Noteheads

Triangle Up Noteheads

Diamond noteheads
Notehead set design

Notehead set name
Diamond Noteheads

Old-Style Diamond Noteheads

White Diamond Noteheads

Wide Diamond Noteheads
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Slash noteheads
Notehead set design

Notehead set name
Muted Slash Noteheads

Oversized Slash Noteheads

Slash Noteheads

Small Slash Noteheads

Round and square noteheads
Notehead set design

Notehead set name
Moon Noteheads

Rectangular Noteheads

Round White with Dot Noteheads

RELATED LINKS
Changing the notehead design of individual noteheads on page 898
Hiding stems on page 1201

Pitch-dependent notehead set designs
Pitch-dependent notehead sets use different notehead designs or different notehead colors
depending on the pitch of notes. There are a number of different pitch-dependent notehead sets
available in Dorico Pro.
●

You can find the available notehead designs by choosing Edit > Notehead > [Notehead
type] > [Notehead design].
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TIP
You can choose to use a pitch-dependent notehead design for all noteheads project-wide on the
Notes page in Engrave > Engraving Options.

Scale degree noteheads
Notehead set design

Notehead set name
Aikin 7-shape Noteheads

Funk 7-shape Noteheads

Walker 4-shape Noteheads

Walker 7-shape Noteheads

Pitched noteheads
Notehead set design

Notehead set name
Figurenotes© Noteheads

Pitch Name Noteheads

RELATED LINKS
Notehead sets on page 886
Changing the notehead design of individual noteheads on page 898
Showing differently shaped noteheads for each scale degree project-wide on page 899
Showing note names in noteheads project-wide on page 899

Custom notehead sets
You can create and edit custom noteheads and notehead sets, for example, to create noteheads
with specific shapes that represent extended techniques.
In Dorico Pro, noteheads are grouped into sets, which allow you to customize the noteheads
used for different durations. For example, the standard notehead set uses different noteheads
for quarter notes compared to half notes.
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You can create new custom notehead sets, and edit existing notehead sets, in the Edit Notehead
Sets dialog.
You can create new and edit individual noteheads within each notehead set in the Edit
Notehead dialog.
RELATED LINKS
Notehead sets on page 886
Edit Notehead dialog on page 895

Edit Notehead Sets dialog
The Edit Notehead Sets dialog allows you to add, edit, and delete custom notehead sets. It also
allows you to change various settings relating to the appearance and function of noteheads
within each notehead set.
●

You can open the Edit Notehead Sets dialog in Engrave mode by choosing Engrave >
Notehead Sets.

Edit Notehead Sets dialog

The Edit Notehead Sets dialog contains the following sections and options:
1

Category menu
Allows you to filter the list of notehead sets by selecting a category from the menu, such as
Crosses or Diamonds. This corresponds to where notehead sets are located in the menu, for
example, Edit > Notehead > Crosses > X Noteheads.

2

List of notehead sets
Contains all the notehead sets in the project within the currently selected category.
The action bar at the bottom of the list contains the following options:
●

New: Adds a new notehead set. By default, new notehead sets are Normal and in the
Common category.

●

New from Selection: Adds a new notehead set that is a duplicate of the notehead set
currently selected.
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NOTE
A single notehead can appear in multiple notehead sets. If you edit a notehead within
one notehead set, your changes affect the appearance of that notehead in all notehead
sets that contain it.
●

Save as Default: Saves the currently selected notehead set as a default in your user
library, allowing you to use it in multiple projects.

●

Revert to Factory: Removes all edits you have made to the selected predefined
notehead set, returning it to its original settings and appearance.

●

Delete: Deletes the selected notehead set.

NOTE
You cannot delete predefined notehead sets.
3

Notehead Set section
Displays the noteheads in the notehead set currently selected in the notehead set list, and
contains the following options that apply to the notehead set:
●

Name: Allows you to enter a new name or edit the existing name for the selected
notehead set.

●

Category: Allows you to select a category for the notehead set, such as Crosses. This
corresponds to where notehead sets are located in the menu, for example, Edit >
Notehead > Crosses > X Noteheads.

●

Type: Displays whether the notehead set is Normal, Pitched, or Scale Degree.
NOTE
You cannot change the Type of notehead sets. If you want a new notehead set of a
particular Type, you must select an existing notehead set of that type in the notehead
set list and click New from Selection.

●

4

Default notehead: Allows you to select which notehead within the set Dorico Pro uses if
there is no notehead in the set that exactly matches the requirements of a note, for
example, if you input a note longer than a whole note, but there is no notehead defined
for this duration in the set.

Notehead Set action bar
Contains the following options for changing which noteheads are included in the notehead
set:
●

Add Notehead to Set: Adds a new notehead to the notehead set. You can select any
notehead from the menu.
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NOTE
A single notehead can appear in multiple notehead sets. If you edit a notehead within
one notehead set, your changes affect the appearance of that notehead in all notehead
sets that contain it.
●

5

Remove Notehead from Set: Deletes the selected notehead from the notehead set.

Notehead section
Contains the following options that apply to the notehead currently selected in the
Notehead Set section:

6

●

Name: Allows you to enter a new name or edit the existing name for the selected
notehead. This is the identifying name used in the Add Notehead to Set menu.

●

Duration: Allows you to select the primary rhythmic duration for which the selected
notehead is intended. You can then specify whether the selected notehead can also be
used for shorter/longer notes.

●

Use for durations shorter than and equal: Allows you to specify that the selected
notehead can be used for notes of the selected Duration and shorter notes.

●

Use for durations longer than and equal: Allows you to specify that the selected
notehead can be used for notes of the selected Duration and longer notes.

●

Stem direction: Allows you to specify that the selected notehead should be used for upstem or down-stem notes only. This is particularly important for noteheads with shapes,
for example, the triangles in triangular noteheads point in different directions according
to their stem direction.

●

Double whole note: Allows you to specify whether the selected notehead is Round or
Square. This determines which notehead is used for double whole notes (breves)
according to your project-wide setting for Appearance of double whole note (breve)
notehead on the Notes page in Engrave > Engraving Options.

●

Pitch: Specifies the note name and accidental for which the selected notehead is used
(Pitched type noteheads only).

●

Degree: Specifies the scale degree for which the selected notehead is used, using
integer numbers from 1 to 7 (Scale Degree type noteheads only).

Notehead action bar
Contains the following options that allow you to edit new and existing noteheads:
●

New Notehead: Creates a new Normal notehead, based on the default black notehead.

●

New from Selection: Creates a new notehead that is a duplicate of the notehead
currently selected in the Notehead Set section.

●

Edit Notehead: Opens the Edit Notehead dialog, where you can change the
appearance of the notehead itself.

●

Save as Default: Saves the currently selected notehead as a default in your user library,
allowing you to use it in multiple projects.

●

Revert to Factory: Removes all edits you have made to the selected predefined
notehead, returning it to its original settings and appearance.
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●

Delete: Deletes the selected notehead.

NOTE
You cannot delete predefined noteheads or any notehead that is currently used in your
project.

RELATED LINKS
Notehead sets on page 886

Edit Notehead dialog
The Edit Notehead dialog allows you to design custom noteheads and edit the appearance and
arrangement of noteheads.
●

You can open the Edit Notehead dialog from within the Edit Notehead Sets dialog, by
selecting the notehead whose design you want to edit from the Notehead Set list and either
double-clicking it or clicking Edit Notehead in the action bar in the Notehead section.

Edit Notehead dialog

The Edit Notehead dialog contains the following sections and options:
1

Name
Contains the saved name for predefined noteheads, or an automatically generated name for
new noteheads. You cannot change this name.

2

Component selector
Allows you to choose components to add to the notehead. You can add different types of
components by clicking the respective tab titles.
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●

Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting different
fonts and different ranges from the menus. Click Add Glyph to add the selected glyph to
the notehead.
NOTE
A full list of the different ranges of glyphs is available on the SMuFL website.

3

●

Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected text, or
input text, to the notehead.

●

Graphic: Allows you to load a new graphics file, or select an existing graphic from the
Select existing list, in SVG, PNG, or JPG format. You can see a preview of the graphic in
the Preview box. Click Add Graphic to add the selected graphic to the notehead.

●

Composite: Allows you to select a composite from the list. Click Add Composite to add
the selected composite to the notehead.

Editor
Allows you to arrange and edit the components that make up the notehead. You can arrange
and edit components by clicking and dragging them in the editor and by using the controls
at the bottom of the dialog. You can also use the handles on each component to change
their size.
We recommend that you position the notehead in the center of the editor so that its left
edge is aligned with the thicker vertical grid line and its middle is aligned with the thicker
horizontal grid line.

4

Editor action bar
Contains selection and view options for the editor.

5

●

Zoom: Allows you to change the zoom level in the editor.

●

Select: Allows you to select the next/previous component.

●

Show Attachments: Shows all the attachments on all components in the editor.

●

Delete: Deletes the selected component.

Controls
Contains controls that allow you to edit individual components. Controls are divided into tabs
according to the aspect of the selected component they affect. For noteheads, the
Component, Stem, and Attachments tabs are available. The Cut-outs tab does not apply to
noteheads.
The Component tab contains the following options:
●

Offset: Controls the position of the selected component. X moves it horizontally, Y
moves it vertically.

●

Scale: Controls the size of the selected component. For graphics, X controls its width, Y
controls its height.
NOTE
Although some components scale their height and width independently, others retain
their aspect ratio, meaning only one value affects their overall size.

●

Z order: Allows you to Bring Forward or Send Backward the selected component in
relation to other components when they overlap.
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The Stem tab contains options controlling the position of where stems attach to the
notehead. Each notehead can have multiple stem attachment points, as stems often attach
to noteheads in different places when the note is stem up, stem down, and split for altered
unisons. Stem attachment points include an indication of the stem direction for which the
attachment is used and the part of the stem that attaches to this position, given as a
compass direction. For example, Stem up SE is where the bottom right corner of an up stem
attaches to the notehead.
Each stem attachment point in the Stem tab has the following options:
●

X: Moves the attachment point horizontally.

●

Y: Moves the attachment point vertically.

●

Add: Adds the attachment point to the notehead.

●

Delete: Removes the attachment point from the notehead.

The Attachments tab is only available if the notehead comprises at least two separate
components. It contains the following options:
●

Attachment from: Sets the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend that
you select a right edge attachment point for Attachment from.

●

Attachment to: Sets the attachment point on the selected component which attaches to
the component to its left. We recommend that you select a left edge attachment point
for Attachment to.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.

The attachment points have the following names in the Edit Notehead dialog:
1

Top Left

2

Top Center

3

Top Right

4

Middle Left

5

Middle Right

6

Baseline Left (text only)

7

Baseline Center (text only)

8

Baseline Right (text only)

9

Bottom Left

10 Bottom Center
11 Bottom Right
RELATED LINKS
Altered unisons on page 617
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Changing the notehead design of individual noteheads
You can change the notehead design of individual noteheads, including trill auxiliary notes. For
example, cross noteheads might be used to indicate where players should produce pitchless
sounds, such as air sounds on wind instruments.
NOTE
These steps do not apply to notes in slash voices.

PROCEDURE
1.

Select the noteheads whose design you want to change. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Notehead > [Notehead type] > [Notehead design]. You can also choose
these options from the context menu.
For example, to change the notehead design of the selected notes to X noteheads, choose
Edit > Notehead > Crosses > X Noteheads.

RESULT
The notehead design of the selected notes is changed.
TIP
You can also change the notehead design for all noteheads project-wide.

RELATED LINKS
Project-wide engraving options for rhythm slashes on page 1096
Rhythm slashes on page 1095
Slash voices on page 1299
Hiding stems on page 1201

Changing the notehead design project-wide
You can change the notehead design of all noteheads project-wide, for example, if you are
working on an educational project and want to show the note name in every notehead.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Notes in the page list.

3.

In the Noteheads section, choose one of the following options for Notehead design:

4.

●

Default size noteheads (smaller than Larger noteheads)

●

Larger noteheads (Default)

●

Note names

●

Figurenotes© colors

Click Apply, then Close.

RESULT
The notehead design of all notes is changed project-wide.
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NOTE
This does not change the notehead design of noteheads whose design you have changed
individually, for example, if you changed selected notes to have diamond noteheads.

Showing differently shaped noteheads for each scale degree project-wide
You can show each degree of the scale with a different notehead design project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Notes in the page list.

3.

In the Noteheads section, choose one of the following options for Shaped noteheads
based on scale degree:
●

Walker 4-shape

●

Walker 7-shape

●

Funk 7-shape

●

Aikin 7-shape

RESULT
The notehead design of all noteheads project-wide is changed to show a different notehead
design for each degree of the scale, depending on your selection.
NOTE
This does not override the notehead design of noteheads whose design you have changed
individually.

RELATED LINKS
Pitch-dependent notehead set designs on page 890
Changing the notehead design of individual noteheads on page 898

Showing note names in noteheads project-wide
You can show the note name as a letter in all noteheads project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Notes in the page list.

3.

In the Noteheads section, choose Note names for Notehead design.
NOTE
This does not change the notehead design of noteheads whose design you have changed
individually.

RESULT
The notehead design of all noteheads not overridden individually is changed to show the note
name inside noteheads.
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NOTE
To ensure legibility, you can increase the staff size of layouts in your project.

RELATED LINKS
Changing the notehead design of individual noteheads on page 898
Staff size on page 452
Changing the default staff size on page 438

Changing the size of notes
You can change the size of notes individually using the default scale sizes for notes in cues or
grace notes, or you can use a custom scale size.
TIP
●

You can change the size of all notes project-wide by changing the notehead design on the
Notes page in Engrave > Engraving Options. However, these options offer less flexibility
than changing the size of notes individually.

●

If you want to change the size of notes because you want them to be grace notes or cues,
you can input them as either grace notes or cues instead.

PROCEDURE
1.

Select the notes whose size you want to change. You can do this in Write mode and Engrave
mode.

2.

In the Properties panel, activate any of the following properties in the Common group:

3.

4.

●

If you want to use a default scale size, activate Scale.

●

If you want to use a custom scale size, activate Custom scale.

●

If you want to use a custom scale size based on a default scale size, activate both Scale
and Custom scale.

Optional: If you activated Scale, select one of the following options from the menu:
●

Normal

●

Grace

●

Cue

●

Cue grace

Optional: If you activated Custom scale, change the value in the value field.

RESULT
●

If you activated Scale, the selected notes are changed to the selected default scale size.

●

If you activated Custom Scale, the selected notes are changed to the custom percentage
scale size you set.

●

If you activated both Scale and Custom Scale, the selected notes are changed to the custom
percentage scale size of the selected default scale size. For example, if you selected Grace
for Scale then set Custom Scale to 50, the size of the selected notes is half the size of grace
notes.

RELATED LINKS
Inputting grace notes on page 193
Inputting cues on page 315
Notehead set designs on page 887
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Moving notes rhythmically
You can move notes, including grace notes, to different rhythmic positions along staves after
they have been input.
NOTE
Although these steps can apply to tuplet notes, their behaviour depends on whether or not you
have selected their tuplet brackets or tuplet numbers/ratios. We recommend following the
dedicated steps for moving tuplets.

PROCEDURE
1.

In Write mode, select the notes you want to move.

2.

Move the selected notes according to the current rhythmic grid resolution in any of the
following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

RESULT
The selected notes are moved to new rhythmic positions. If you selected multiple notes, they are
moved together as a block.
Notes are automatically positioned according to their rhythmic duration and position relative to
other notes.
NOTE
If Chords is not activated and any of your selected notes collide with other notes in the same
staff and at the same rhythmic position that are in the same voice as your selected notes, the
existing notes are deleted and replaced with your selected notes.
You can undo moving notes immediately, which restores any notes deleted in the process.

RELATED LINKS
Moving tuplets rhythmically on page 1265
Rhythmic grid on page 166
Inputting chords on page 194
Notes toolbox on page 153
Note spacing on page 425
Creating cross-staff beams on page 672
Moving notes to other staves on page 339

Changing the width of ledger lines
You can change the width of ledger lines on individual notes, for example, to allow notes with
short durations to be spaced more tightly and still be legible.
PROCEDURE
1.

In Engrave mode, select the noteheads whose ledger line width you want to change.

2.

In the Properties panel, activate Ledger line in the Notes and Rests group.

3.

Change the values for L and R.

901
Dorico Pro 3.1.10

Notes
Rhythm dot consolidation
RESULT
Increasing Ledger line L makes the left side of ledger lines longer, decreasing the value makes
the left side of ledger lines shorter.
Increasing Ledger line R makes the right side of ledger lines longer, decreasing the value makes
the right side of ledger lines shorter.
TIP
You can change the width of all ledger lines project-wide on the Notes page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide engraving options for notes on page 886

Hiding/Showing ledger lines
You can hide/show ledger lines on individual notes, for example, if you want to indicate
approximate pitches using the relative vertical positions of notes.
PROCEDURE
1.

In Engrave mode, select the noteheads whose ledger lines you want to hide/show.
NOTE
If you want to hide ledger lines, you must also select all other noteheads in the same voice
and voice column index.

2.

In the Properties panel, activate/deactivate Hide ledger lines in the Notes and Rests group
of the Properties panel.

RESULT
Ledger lines are hidden/shown for the selected notes.
If you deactivated Hide ledger lines for only some notes in a chord, ledger lines are also shown
on all notes between the selected notes and the staff in the same voice and voice column index.
RELATED LINKS
Voice column index on page 1297

Rhythm dot consolidation
Rhythm dot consolidation controls how many rhythm dots appear at the same rhythmic position
in multiple-voice contexts. Depending on the number of notes and voices present, and their
positions on the staff, different numbers of rhythm dots can be required to appear, and in
different positions.
In the Rhythm Dots section of the Notes page in Engrave > Engraving Options, you can choose
how rhythm dots in multiple voices are consolidated project-wide. There are separate options for
the consolidation of rhythm dots generally and on unison notes in particular.
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Rhythm dot consolidation

Notes of any duration have
rhythm dots consolidated

Only notes of the same duration
have rhythm dots consolidated

No rhythm dot consolidation

Rhythm dot consolidation on unison notes

One rhythm dot shown per
notehead in unisons

Rhythm dots shown for each
notehead for unisons on lines, but
only one shown per unison in
spaces

Only one rhythm dot shown per
unison

TIP
You can also change how rhythm dots in multiple voices are consolidated individually.

Changing the consolidation of rhythm dots
You can change how rhythm dots in multiple voices are consolidated at individual rhythmic
positions, independently of your project-wide setting. For example, if you want to show fewer
rhythm dots for a very dense chord.
PROCEDURE
1.

In Engrave mode, select the notes whose rhythm dot consolidation you want to change.

2.

In the Properties panel, activate Rhythm dot consolidation in the Notes and Rests group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Rhythm dots for notes of any duration are consolidated when the checkbox is activated, and no
rhythm dots are consolidated when the checkbox is deactivated.
When the property is deactivated, rhythm dots follow your project-wide setting for consolidation
according to note durations.
TIP
You can change how all rhythm dots in multiple voices are consolidated project-wide on the
Notes page in Engrave > Engraving Options.
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Moving rhythm dots
You can move rhythm dots horizontally. However, you cannot move an individual rhythm dot
independently of other rhythm dots at the same rhythmic position.
PROCEDURE
1.

In Engrave mode, select a notehead at each rhythmic position where you want to move
rhythm dots.

2.

In the Properties panel, activate Rhythm dot X in the Notes and Rests group.

3.

Change the value in the value field.

RESULT
Increasing the Rhythm dot X value moves all rhythm dots at the selected rhythmic positions to
the right, decreasing the value moves them to the left.

Specifying the string for individual notes
You can specify on which string individually selected notes are played for notes belonging to
string instruments, such as violin, cello, or guitar. Many notes can be played on multiple strings,
depending on where along its length the string is stopped.
Specifying the string can be useful for notes that also have glissando lines or fingering shifts, as
the string and finger position required to play the note affects the direction of these changes.
However, the string number is not shown in the music. You can instead input fingerings, which
can help string players understand the string on which they should play.
NOTE
You can only specify strings on notes belonging to string instruments.

PROCEDURE
1.

Select the notes whose assigned string you want to change. You can do this in Write mode
and Engrave mode.
NOTE
If selecting multiple notes at once, select notes only in staves of the same instrument type.
For example, select multiple Cs in Violin 1 and Violin 2 staves.

2.

In the Properties panel, activate String in the Notes and Rests group.

3.

Select your preferred string from the menu.
The string number for the instrument is shown, followed by the fundamental pitch and the
octave number of that string in parentheses. For example, the lowest cello string is
expressed as 4 (C2).
NOTE
The options available in the menu depend on the selected pitches and the instrument type.

RESULT
The string on which the selected notes are played is changed.
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NOTE
If you subsequently change the pitches of notes, String is automatically deactivated for all notes
that can no longer be played on their specified string.

RELATED LINKS
Glissando lines on page 950
Changing the direction of string fingering shift indicators on page 811
String indicators on page 813
Inputting string indicators inside the staff on page 289

Hiding/Showing colors for notes out range
You can show colors for notes that are considered out of range, such as notes too high/low for
the instrument to play or the voice type to sing, or pitches that do not fit with the current harp
pedal settings. When colors for notes out of range are hidden, all notes appear black by default.
Colors for notes out of range are considered annotations and are not printed by default.
PROCEDURE
●

Choose View > Note And Rest Colors > Notes Out Of Range.

RESULT
Notes out of range appear red when a tick appears beside Notes Out Of Range in the menu,
and black when no tick appears.
Notes that are considered challenging are shown in a darker red, while notes that are impossible
or virtually impossible are shown in a bright red.
NOTE
Notes out of the fret range of the corresponding string on tablature are always shown as
question marks, even if you do not show colors for notes out of range.
EXAMPLE

Colors for notes out of range shown. Three notes in the middle of the phrase are bright red, while the rest
are the darker red.

AFTER COMPLETING THIS TASK
If showing colors for notes out of range reveals some notes do not fit with the current harp pedal
settings, you can input a new pedal diagram for that passage or calculate a suitable harp pedal
diagram.
RELATED LINKS
Inputting harp pedal diagrams on page 286
Calculating harp pedal diagrams based on existing music on page 287
Annotations on page 610
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Bracketed noteheads
Bracketed noteheads are often used to indicate that notes are optional, editorial, not played in all
playthroughs in music with repeats, or pressed down but not fully struck on the piano. In Dorico
Pro, you can show brackets on any notehead.
Notehead brackets extend slightly above and below noteheads so it is clear which notes are
included in each bracket.

A phrase containing round and square notehead brackets

You can also show brackets on noteheads on notation staves and tablature independently of
each other.
The following types of notehead brackets are available in Dorico Pro:
Round notehead brackets
Round notehead brackets have a similar appearance to slurs, but vertical.
By default, round brackets on single noteheads use the font glyph on notation staves
and the drawn curve on tablature. In Engrave mode, round notehead brackets that use
the drawn curve have handles that allow you to change their shape. Round notehead
brackets that use the font glyph do not have handles in Engrave mode.
NOTE
On tablature, round brackets are automatically shown around the second note/chord
and all subsequent notes/chords in tie chains. If you show brackets around all
noteheads in tie chains on tablature, these automatic notehead brackets are included.

Round brackets on
single noteheads on
a notation staff

Round bracket on a
chord on a notation
staff

Round brackets on
single noteheads on
tablature

Round bracket on a
chord on tablature

Square notehead brackets
Square notehead brackets comprise a straight vertical line with horizontal hooks at the
top and bottom. Dorico Pro automatically adjusts the length of square brackets to
ensure they do not end on staff lines and their hooks remain visible.
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Square brackets on
single noteheads on
a notation staff

Square bracket on a
chord on a notation
staff

Square brackets on
single noteheads on
tablature

Square bracket on a
chord on tablature

RELATED LINKS
Showing brackets around one/all noteheads in tie chains on page 909
Notehead brackets in Engrave mode on page 911
Showing notes as dead notes on page 1192
Inputting notes on page 172
Ties on page 1219
Changing the appearance of round brackets on single noteheads on page 911

Project-wide engraving options for bracketed noteheads
You can find options for the project-wide appearance and position of notehead brackets on the
Bracketed Noteheads page in Engrave > Engraving Options.
The options on the Bracketed Noteheads page allow you to change the default gaps between
round and square notehead brackets and noteheads, the thickness and shape of notehead
brackets, and the appearance of round brackets on both notation staves and tablature.
NOTE
Round brackets on single noteheads that use the font glyph do not show handles in Engrave
mode, meaning you cannot lengthen/shorten them or change their shape/width.
You can also change the maximum interval within chords for which you want to allow Dorico Pro
to use a single bracket and whether adjacent strings in tablature show a single bracket or
separate brackets.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Showing brackets on noteheads
You can show round or square brackets on individual noteheads, on single notes within chords,
and on whole chords. For example, if you want to indicate that specific notes are optional or an
editorial change, or to show notes belonging to unpitched percussion instruments as ghost
notes.
NOTE
If you want to show brackets on noteheads to represent dead notes, you can instead show notes
as dead notes.
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PROCEDURE
1.

Select the noteheads on which you want to show brackets. You can do this in Write mode
and Engrave mode.
NOTE
●

If you want to show brackets on individual noteheads in tie chains that are not the first
notehead, you must select them in Engrave mode.

●

If you want to show brackets on whole chords, you must select all notes in those chords.

●

If you want to show brackets on both notation staves and tablature, you must select
notes on both.

2.

In the Properties panel, activate Bracket style in the Bracketed Noteheads group.

3.

Choose one of the following options:
●

Round

●

Square

RESULT
The corresponding type of notehead brackets is shown on the selected notes. If you only
selected notes on tablature, brackets are not shown on the corresponding notes on the notation
staff, and vice versa.
In Write mode, only the first noteheads in tie chains are bracketed. In Engrave mode, only the
selected noteheads are bracketed, including in tie chains.
If you selected all notes in chords, Dorico Pro shows a single bracket for each chord unless they
contain very large gaps, in which case Dorico Pro automatically splits brackets. If you selected
individual notes within chords, they are each shown with separate brackets.
TIP
●

Deactivating Bracket style hides brackets on the selected notes.

●

You can also hide/show brackets on noteheads by choosing Edit > Notehead > Toggle
Round Brackets or Edit > Notehead > Toggle Square Brackets. You can also choose these
options from the context menu.
You can assign key commands for these options on the Key Commands page in
Preferences.

EXAMPLE

Round brackets on single
noteheads on a notation staff

Round bracket on a chord on a
notation staff
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Round brackets on single
noteheads on tablature

Round bracket on a chord on
tablature

Split round bracket on a chord on
tablature

RELATED LINKS
Showing notes as dead notes on page 1192
Notehead brackets in Engrave mode on page 911
Inputting notes on page 172

Showing brackets around one/all noteheads in tie chains
You can change whether brackets appear only on the first notehead in tie chains or span the
entire duration of the tie chain, that is, with the left bracket on the first notehead and the right
bracket on the last notehead in the tie chain. By default, brackets appear only on the first
notehead in tie chains.
PREREQUISITE
You have shown brackets on the required notes.
PROCEDURE
1.

Select the notes whose notehead bracket positions relative to tie chains you want to change.
You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Bracket until end of tie chain in the Bracketed
Noteheads group.

RESULT
Brackets appear at the start and end of the selected tie chains when Bracket until end of tie
chain is activated, and only around the first note/chord when it is deactivated.
If you activated Bracket until end of tie chain for a single note in a bracketed chord, the bracket
on the first chord is not split but an additional bracket appears at the end of the tie chain for the
selected note only. If you deactivated Bracket until end of tie chain for a single note in a
bracketed chord whose other notes are bracketed to the end of the tie chain, the bracket at the
end of the tie chain is split.
If you selected notes on tablature, the automatic brackets shown around the second note/chord
and all subsequent notes/chords in tie chains are updated to follow your property setting.
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EXAMPLE

Brackets around only the first chords in tie chains on
a notation staff

Brackets at the start and end of whole tie chains on a
notation staff

Brackets around only the first chord in a tie chain,
with automatic brackets shown on the second chord
on tablature

Brackets around the start and end of the whole tie
chain on tablature

RELATED LINKS
Ties on page 1219

Splitting brackets on chords
You can split brackets on any notehead within a chord. By default, Dorico Pro automatically
shows a single bracket for all notes in a chord unless it contains very large gaps, in which case
Dorico Pro automatically splits brackets.
PROCEDURE
1.

Select the individual notes in chords immediately above where you want to split brackets.
You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Break bracket in the Bracketed Noteheads group.

RESULT
Brackets are split immediately below the selected notes.
TIP
You can change the default interval between notes above which Dorico Pro automatically splits
brackets on chords in the Vertical Extent section of the Bracketed Noteheads page in
Engrave > Engraving Options.
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EXAMPLE

Chord with single round bracket

Chord with split round bracket

RELATED LINKS
Inputting chords on page 194

Changing the appearance of round brackets on single noteheads
You can change whether round brackets on single noteheads are drawn using the font glyph or
drawn curve. Only round notehead brackets that use the drawn curve have handles in Engrave
mode that allow you to change their shape.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Bracketed Noteheads in the page list.

3.

In the Design section, choose one of the following options for Round bracket appearance
for single noteheads:

4.

●

Use font glyph

●

Use drawn curve

Click Apply, then Close.

RESULT
The appearance of round brackets on all single noteheads is changed project-wide.
AFTER COMPLETING THIS TASK
You can change the length and shape of individual round notehead brackets that use the drawn
curve.
RELATED LINKS
Lengthening/Shortening notehead brackets on page 913
Changing the shape of round notehead brackets on page 914

Notehead brackets in Engrave mode
In Engrave mode, each round notehead bracket has multiple handles that you can move
independently to adjust their graphical position, length, and shape.
Round notehead brackets that use the drawn curve have three square handles that you can
move independently. When you move either of the top/bottom handles, the middle handle also
moves to retain its position relative to the start/end handles.
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NOTE
Round brackets on single noteheads that use the font glyph do not show handles in Engrave
mode, meaning you cannot lengthen/shorten them or change their shape/width.
Square notehead brackets have two handles, one at the top and one at the bottom.

Round notehead bracket handles in Engrave mode

Square notehead bracket handles in Engrave mode

●

Top and bottom handles move the corresponding end of the notehead bracket, controlling
its graphical length.

●

Middle handles control the shape of round notehead brackets. Moving them vertically
adjusts their curve by changing the angle at which notehead bracket endpoints approach
noteheads, while moving them horizontally changes the width of round notehead brackets.

You can move these handles to change the graphical length of notehead brackets and the shape
of round notehead brackets.

Moving notehead brackets graphically
You can move individual notehead brackets graphically without changing the notes to which they
apply, including moving left and right notehead brackets independently of each other.
NOTE
You cannot move notehead brackets rhythmically. If you want to show notehead brackets on
different notes, you must hide them on their original notes and show them on the new notes.

PROCEDURE
1.

In Engrave mode, select the notehead brackets you want to move graphically.
NOTE
You must select whole notehead brackets, not any of their handles.

2.

Move the notehead brackets in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.
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RESULT
The selected notehead brackets are moved graphically, without changing the notes to which they
apply. If necessary, other items, such as ties and slurs, automatically move out of the way to
accommodate their new positions. This might affect note spacing and casting off.
TIP
●

The following properties in the Bracketed Noteheads group of the Properties panel are
activated automatically when you move the corresponding notehead bracket.
●

L bracket body moves left notehead brackets. X moves them horizontally, Y moves
them vertically.

●

R bracket body moves right notehead brackets. X moves them horizontally, Y moves
them vertically.

You can also use these properties to move notehead brackets graphically by changing the
values in the value fields.
Deactivating the properties resets the selected notehead brackets to their default positions.
●

You can change the default positions of all notehead brackets, including the gaps between
them and other items, on the Bracketed Noteheads page in Engrave > Engraving Options.

Lengthening/Shortening notehead brackets
You can lengthen/shorten individual notehead brackets graphically to change their height,
independently of your project-wide settings.
NOTE
You can only lengthen/shorten round notehead brackets on single noteheads if they use the
drawn curve, rather than the font glyph.

PROCEDURE
1.

In Engrave mode, select one of the outer handles of the notehead brackets you want to
lengthen/shorten.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag them upwards/downwards.

RESULT
The selected notehead brackets are lengthened/shortened graphically. This does not change the
notes to which they apply.
If necessary, other nearby items, such as ties and slurs, automatically move to avoid collisions.
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TIP
●

The following properties in the Bracketed Noteheads group of the Properties panel are
activated automatically when you lengthen/shorten the corresponding notehead bracket.
●

L bracket extents controls the height of left notehead brackets. T moves their top
handles, B moves their bottom handles.

●

R bracket extents controls the height of right notehead brackets. T moves their top
handles, B moves their bottom handles.

You can also use these properties to lengthen/shorten notehead brackets graphically by
changing the values in the value fields.
Deactivating the properties resets the selected notehead brackets to their default positions.
●

You can change how far all notehead brackets extend beyond notes project-wide on the
Bracketed Noteheads page in Engrave > Engraving Options.

RELATED LINKS
Changing the appearance of round brackets on single noteheads on page 911

Changing the shape of round notehead brackets
You can change the shape of individual round notehead brackets, for example, if you want some
notehead brackets to appear wider or to change their curvature, so that their endpoints
approach noteheads at a sharper angle.
NOTE
You can only change the shape of round notehead brackets on single noteheads if they use the
drawn curve, rather than the font glyph.

PROCEDURE
1.

In Engrave mode, select the middle handles of each round notehead bracket whose shape
you want to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Change the shape of the selected round notehead brackets in any of the following ways:
●

To widen right notehead brackets or narrow left notehead brackets, press Alt/OptRight Arrow .

●

To narrow right notehead brackets or widen left notehead brackets, press Alt/OptLeft Arrow .

●

To increase the angle of notehead bracket endpoints, press Alt/Opt-Up Arrow .

●

To decrease the angle of notehead bracket endpoints, press Alt/Opt-Down Arrow .
TIP
●

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

You can also click and drag middle handles in the corresponding directions.
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RESULT
The shape of the selected notehead brackets is changed. If necessary, other nearby items, such
as ties and slurs, automatically move to avoid collisions. This might affect note spacing and
casting off.
TIP
The following properties in the Bracketed Noteheads group of the Properties panel are
activated automatically when you move the middle handle of notehead brackets.
●

L round br. middle moves left notehead bracket middle handles. X moves them horizontally,
changing the width of notehead brackets, and Y moves them vertically, changing the
curvature of notehead brackets.

●

R round br. middle moves right notehead bracket middle handles. X moves them
horizontally, changing the width of notehead brackets, and Y moves them vertically,
changing the curvature of notehead brackets.

You can also use these properties to change the width and shape of round notehead brackets by
changing the values in the value fields.
Deactivating the properties resets the selected notehead brackets to their default shape.
EXAMPLE

Widened round notehead Narrowed round
bracket
notehead bracket

Endpoint angle increased Endpoint angle
decreased

RELATED LINKS
Slur shoulder offset on page 1136
Changing the appearance of round brackets on single noteheads on page 911
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Harmonics are pitches produced by touching resonating strings at specific positions along their
length, allowing the corresponding harmonic partial to sound. Harmonics often have a high pitch
with a glassy, purer sound than stopped pitches. There are two different types of harmonics:
natural and artificial.
Harmonic partials are numbered according to their order in the harmonic series, which also
correlates to the node on the string which produces them. For example, the second partial in the
harmonic series is produced by the node halfway along a string, that is, the node that divides the
string into two equal parts. The third partial is produced by the node that divides the string into
thirds, and so on.
Natural harmonics
Natural harmonics are produced by touching an open string at one of its nodes and
then bowing or plucking the string. The sounding pitch of the resulting harmonic
varies according to the node and its corresponding partial in the harmonic series. For
example, touching the node halfway along a string produces the second partial, which
sounds an octave above the open string pitch.
Artificial harmonics
Artificial harmonics are produced by stopping a string fully (as if playing a normal note)
and then touching the string at one of the nodes of its stopped length. The sounding
pitch of the resulting harmonic varies according to the node and its corresponding
partial in the harmonic series. For example, touching the node that is the equivalent of
a fourth higher than the stopped pitch produces the fourth partial, which sounds two
octaves above the stopped pitch.
To produce artificial harmonics, players must both fully stop the string and touch the
string at the correct node. This can be more difficult to produce than natural
harmonics.

A passage for violin alternating between artificial
and natural harmonics on the A string

The sounding pitches of the same passage

Dorico Pro supports multiple conventions for the notation of harmonics on stringed and fretted
instruments, including for both natural and artificial harmonics. For artificial harmonics shown
using two noteheads, one normal and one diamond, Dorico Pro automatically calculates the
correct pitch for the touched pitch diamond notehead for the second to sixth harmonic partials.
These pitches are reflected in playback, using dedicated sounds for harmonics if the
corresponding playback device includes them.
RELATED LINKS
Hiding/Showing or parenthesizing accidentals on page 614
Changing the harmonic partial on page 918
Appearances/Styles of harmonics on page 919
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Turning notes into harmonics
You can turn existing notes into artificial and natural harmonics. Harmonics can represent either
the sounding, touched, or stopped pitch.
PREREQUISITE
You have input the notes you want to turn into harmonics. However, the pitch you should input
depends on the style/appearance you want to use.
●

For natural harmonics, we recommend that you input the desired sounding pitch.

●

For artificial harmonics, we recommend that you input the stopped pitch.

PROCEDURE
1.

Select the notes you want to turn into harmonics. You can do this in Write mode and Engrave
mode.

2.

In the Properties panel, activate Type in the Harmonics group.

3.

Choose one of the following options:
●

Artificial

●

Natural

RESULT
The selected notes are turned into harmonics of the corresponding type. If the corresponding
playback device has dedicated sounds for harmonics, the selected notes automatically use those
sounds. The sounding pitch of artificial harmonics in playback is also changed accordingly.
●

Artificial harmonics represent the second partial by default. They are shown with a diamond
notehead indicating the touched pitch an octave above the selected notes. On tablature, the
stopped fret is shown on the left and the touched fret is shown on the right in parentheses.

●

Natural harmonics represent the sounding pitch by default. They are shown with a circle
symbol above the selected notes. On fretted instrument notation staves, natural harmonics
appear as black diamond noteheads. On tablature, the fret of the touched pitch is shown, if it
can be calculated; if it cannot be calculated, a pink question mark is shown above the
tablature.

EXAMPLE
The following examples show the default appearances of natural and artificial harmonics on
different staves.

Artificial
Artificial
harmonic on
harmonic on
notation staff
tablature
(any instrument)

Natural
harmonic on
non-fretted
instrument staff

Natural
harmonic on
fretted
instrument
notation staff

Natural
harmonic on
tablature

Natural
harmonic on
tablature that
cannot be
calculated

AFTER COMPLETING THIS TASK
You can change the partial for harmonics. You can also change the appearance of natural
harmonics and the type of artificial harmonics.
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If you want to turn harmonics back into normal notes, deactivate Type in the Harmonics group.
RELATED LINKS
Inputting notes on page 172
Changing the appearance of natural harmonics on page 922
Changing the style of artificial harmonics on page 922
Tablature on page 1188

Changing the harmonic partial
By default, harmonics indicate the second partial in the harmonic series, which is an octave
above the fundamental. You can change the partial for individual harmonics, for example, if you
want a higher partial instead.
NOTE
Dorico Pro can only correctly calculate artificial harmonic partials for nodes two to six.

PROCEDURE
1.

Select the harmonics whose partial you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Partial in the Harmonics group.

3.

Change the value in the value field to the node at which the string should be touched to
produce the partial you want.

RESULT
The partial of the selected harmonics is changed. For artificial harmonics using the Normal type,
the pitch of the white diamond notehead/parenthesized fret number is updated automatically.
The sounding pitch of artificial harmonics in playback is also changed accordingly.
EXAMPLE
Artificial harmonic with default partial
(notation and tablature)

Partial changed to the fifth (notation and
tablature)

RELATED LINKS
Tablature on page 1188
Changing the style of artificial harmonics on page 922
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Hiding/Showing or parenthesizing harmonic accidentals
You can show harmonic accidentals in round or square brackets and hide/show accidentals
individually, independently of hiding/showing or parenthesizing accidentals of stopped pitch
notes. For example, you can show cautionary accidentals on subsequent notes in tie chains that
cross system/frame breaks by showing accidentals in round brackets.
PROCEDURE
1.

Select the harmonics whose accidentals you want to hide/show or parenthesize. You can do
this in Write mode and Engrave mode.
NOTE
You can only select individual noteheads within tie chains in Engrave mode.

2.

In the Properties panel, activate Accidental in the Harmonics group.

3.

Select one of the following options from the menu:
●

Hide

●

Show

●

Round brackets

●

Square brackets

RESULT
Accidentals on the selected harmonics are shown, hidden, or shown in round or square brackets.
NOTE
●

Hiding accidentals does not affect the pitch of notes in playback.

●

If you are hiding/showing many accidentals, we recommend that you consider changing the
accidental duration rule.

●

You can assign key commands for different accidental hiding, showing, and parenthesizing
commands on the Key Commands page in Preferences.

AFTER COMPLETING THIS TASK
You can also hide/show or parenthesize accidentals on the normal noteheads that indicate the
stopped pitch for artificial harmonics shown using diamond noteheads.
RELATED LINKS
Hiding/Showing or parenthesizing accidentals on page 614

Appearances/Styles of harmonics
Both artificial and natural harmonics can be notated in different ways. In Dorico Pro, it is possible
to indicate the desired sounding pitch, either the stopped or touched pitch, or both stopped and
touched pitches for individual harmonics.
In this documentation we refer to “styles” of artificial harmonics, because one artificial harmonic
style indicates the use of a different performance technique, and “appearances” of natural
harmonics, as their different appearances do not indicate different performance techniques.
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Natural harmonics
Circle above
Shows a harmonic circle symbol on the notehead side of notes. Usually indicates the
desired sounding pitch of the harmonic. Used for natural harmonics on staves that do
not belong to fretted instruments by default, such as violin.

Diamond notehead
Changes the notehead of notes to a diamond notehead. The diamond notehead
appears black/filled when the note is a quarter note or shorter, and white/unfilled
when the note is a half note or longer. Usually indicates the touched pitch required.
Used for natural harmonics on fretted instrument notation staves by default.

White diamond notehead
Changes the notehead of notes to a diamond notehead that is always unfilled,
regardless of the duration of notes. Usually indicates the touched pitch required.

On tablature, the touched fret is always shown for natural harmonics, regardless of the selected
appearance. If the touched fret cannot be calculated, a pink question mark is shown.

Artificial harmonics
Normal
Shows two noteheads: one indicating the stopped pitch, the other the touched pitch.
The touched pitch is automatically calculated based on the partial; the default partial is
the second partial. On tablature, the stopped fret is shown on the left and the touched
fret is shown on the right in parentheses. This is the default appearance of artificial
harmonics on all staves.
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Normal artificial harmonic on notation staff Normal artificial harmonic on tablature

Pinch
Shows two noteheads: one indicating the stopped pitch, the other the sounding pitch.
The sounding pitch is automatically calculated based on the partial; the default partial
is the second partial. On tablature, only the stopped fret is shown.
NOTE
Intended for fretted instruments only. A pinch is produced by the performer catching a
resonating string at a node near the pick-ups, producing a high-pitched squeal. Also
known as a “false harmonic” or “squeal”.

Pinch harmonic on notation staff

Pinch harmonic on tablature

Single notehead (sounding)
Shows a single notehead indicating the sounding pitch. On tablature, the stopped fret
is shown on the left and the sounding pitch is shown on the right in parentheses.

Single notehead (sounding) artificial
harmonic on notation staff

Single notehead (sounding) artificial
harmonic on tablature

Single notehead (stopped)
Shows a single notehead indicating the stopped pitch. On tablature, the stopped fret is
shown on the left and the touched fret is shown on the right in parentheses.

Single notehead (stopped) artificial
harmonic on notation staff

Single notehead (stopped) artificial
harmonic on tablature
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RELATED LINKS
Tablature on page 1188

Changing the appearance of natural harmonics
By default, natural harmonics appear as normal noteheads with a circle shown above, which
indicates the desired sounding pitch. You can change the appearance of natural harmonics
individually, for example, to show them as a white diamond notehead to indicate the touched
pitch.
NOTE
These steps only apply to harmonics with the Natural type.

PROCEDURE
1.

Select the natural harmonics whose appearance you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Style in the Harmonics group.

3.

Select one of the following options from the menu:
●

Circle above

●

Diamond notehead

●

White diamond notehead

RESULT
The appearance of the selected natural harmonics is changed, including on fretted instrument
notation staves. The touched pitch shown on tablature is not changed automatically.
NOTE
●

Changing the appearance of natural harmonics does not automatically change their notated
pitch. For example, if you want to change a sounding pitch Circle above harmonic to a
touched pitch White diamond notehead harmonic, you must also change the pitch of the
note.

●

Dorico Pro automatically assigns natural harmonics with the White diamond notehead style
to the lowest possible string for that harmonic. You can specify different strings if necessary.

●

You can change the staff-relative placement of harmonic circle symbols by activating
Placement in the Harmonics group of the Properties panel and choosing the option you
want.

RELATED LINKS
Changing the pitch of individual notes on page 200
Specifying the string for individual notes on page 904

Changing the style of artificial harmonics
By default, artificial harmonics appear as two noteheads: one normal, which indicates the
stopped pitch, and one diamond, which indicates the touched pitch. You can change the style of
artificial harmonics individually, for example, to indicate pinch harmonics.
NOTE
These steps only apply to harmonics with the Artificial type.

922
Dorico Pro 3.1.10

Harmonics
Appearances/Styles of harmonics

PROCEDURE
1.

Select the artificial harmonics whose style you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Style in the Harmonics group.

3.

Select one of the following options from the menu:
●

Normal

●

Pinch

●

Single notehead (sounding)

●

Single notehead (stopped)

RESULT
The style of the selected artificial harmonics is changed.
NOTE
Pinch indicates the use of a different technique to produce the harmonic.

RELATED LINKS
Hiding/Showing or parenthesizing accidentals on page 614
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Ornaments are markings that indicate multiple notes are played in addition to the notated pitch.
They are used to decorate music, such as in Baroque music, which is highly decorated with trills
and other ornaments.
Over time, specific ways of notating how performers should play notes have developed and
different ornament symbols indicate different patterns of decorative notes. Nonetheless,
ornaments give some freedom to performers to embellish music in their own way.
Dorico Pro offers a range of ornament symbols to allow you to notate different styles of
ornaments.
The term “ornaments” covers a wide range of decorative notes, including:
●

Mordents

●

Trills

●

Turns

●

Grace notes

●

Acciaccaturas

●

Appoggiaturas

In Dorico Pro, the term “ornaments” refers to ornament symbols and trill marks that are input
above notes.

A phrase containing a turn, short trills, and a trill with extension line

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
Grace notes on page 825
Positions of ornaments on page 926

Project-wide engraving options for ornaments
You can find options for the project-wide appearance and position of ornaments and trills on the
Ornaments page in Engrave > Engraving Options.
The options on the Ornaments page allow you to change the position of trills relative to
accidentals, noteheads, trill extension lines. You can also change the default appearance of trill
marks on subsequent systems, the appearance and restatement of trill intervals, and set the
minimum distance between ornaments and the staff and noteheads.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
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RELATED LINKS
Engraving Options dialog on page 359

Changing ornament intervals
You can change the intervals of ornaments, both above and below the notated pitch, to indicate
which pitches are played in the ornament. The intervals of ornaments are indicated by
accidentals.
For some ornaments, you can only change the interval in one direction. For example, you can
only change the interval above short trills and below mordents.
NOTE
These steps do not apply to trills.

PROCEDURE
1.

Select the ornaments whose interval you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate the appropriate properties for the selected ornaments in the
Ornaments group:
●

Interval above

●

Interval below

For trills, activate Interval in the Trills group of the Properties panel.
3.

Change the value in the value field to the interval you want.
●

0 or 4 and above shows no accidental.

●

1 shows a flat.

●

2 shows a natural.

●

3 shows a sharp.

RESULT
The interval of the selected ornaments is changed.
NOTE
●

Some ornaments do not show accidentals either above or below, depending on their type.

●

You can change the position of ornament accidentals relative to all trills project-wide on the
Ornaments page in Engrave > Engraving Options.

EXAMPLE
No accidentals

Flats above and
below
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below

Sharps above and
below
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RELATED LINKS
Changing the intervals of existing trills on page 934
Project-wide engraving options for ornaments on page 924

Positions of ornaments
Ornaments, including trills, are placed above the notes to which they apply. They are only placed
below the staff for down-stem voices in multiple-voice contexts.
Ornaments and trills are positioned outside of slurs by default. Similarly, they are positioned
further from noteheads than articulations.
The center of ornaments aligns with the center of the notehead to which they apply. Trills are
aligned differently, as the left side of trill marks aligns with the left edge of the notehead to which
the trill applies.
Dorico Pro automatically positions ornaments correctly according to their type, and attaches
them to their notehead.
You can move ornaments to different rhythmic positions in Write mode. They are positioned by
default according to your settings in Engraving Options.
You can move ornaments graphically in Engrave mode, but this does not change the rhythmic
positions to which they are attached.
You can change the default positions of all ornaments and trills project-wide on the Ornaments
page in Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for ornaments on page 924
Moving ornaments graphically on page 927
Changing the position of ornaments relative to slurs on page 928

Moving ornaments rhythmically
You can move ornaments to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the ornaments you want to move.
NOTE
When using the mouse, you can only move one ornament at a time.

2.

Move the ornaments in any of the following ways:
●

To move a single ornament to the next notehead on the staff, press Alt/OptRight Arrow .

●

To move a single ornament to the previous notehead on the staff, press Alt/OptLeft Arrow .

●

To move them to the right according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Right Arrow .

●

To move them to the left according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Left Arrow .
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NOTE
You can only move ornaments according to the current rhythmic grid resolution when
multiple ornaments are selected.
●

Click and drag the ornament to the right/left to snap it to different rhythmic positions.

RESULT
The selected ornaments are moved to new rhythmic positions.
NOTE
Only one ornament can exist at each rhythmic position. If an ornament passes over another
ornament as part of its move, the existing ornament is deleted.
Trills can overlap with other trills and ornaments. However, if the start of a trill passes over the
start of another trill as part of its move, the existing trill is deleted.
You can undo these actions, but any ornaments/trills deleted in the process are only restored if
you moved items using the keyboard.

Moving ornaments graphically
You can move ornaments graphically without changing the rhythmic positions to which they
apply. You can also move the start/end handles of trills independently of each other, meaning
you can lengthen/shorten trills graphically.
PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Ornaments or trills

●

Individual handles on trills

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the ornaments or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected items are moved graphically, without affecting the rhythmic positions to which they
are attached.
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TIP
Offset in the Common group of the Properties panel is activated automatically when you move
ornaments.
●

Offset X moves ornaments horizontally.

●

Offset Y moves ornaments vertically.

The following properties in the Trills group of the Properties panel are activated automatically
when you move trills:
●

Start offset moves whole trills. X moves them horizontally, Y moves them vertically.

●

End offset X moves the end of trill extension lines horizontally.

For example, if you move a whole trill to the right, both handles are moved so both properties
are activated. You can also use these properties to move ornaments/trills and lengthen/shorten
trills graphically by changing the values in the value fields.
Deactivating the properties resets the selected ornaments and trills to their default positions.

Changing the position of ornaments relative to slurs
Ornaments are positioned outside of slurs by default. You can change the position of ornaments
relative to slurs individually.
PROCEDURE
1.

In Engrave mode, select the ornaments whose slur-relative position you want to change.

2.

In the Properties panel, activate Slur-relative position in the corresponding group for the
selected ornaments:

3.

●

Ornaments

●

Trills

Choose one of the following options:
●

Inside

●

Outside

RESULT
The selected ornaments are positioned either inside or outside of slurs.

Changing the start position of trills
You can change whether the start position of individual trills is aligned with the notehead or with
its accidental, independently of your project-wide setting.
PROCEDURE
1.

Select the trills whose start position you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Start position in the Trills group.

3.

Choose one of the following options:
●

Notehead

●

Accidental
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RESULT
The start position of the selected trills is changed.
TIP
You can change the start position of all trills project-wide on the Ornaments page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide engraving options for ornaments on page 924

Trills
Trills are fast alternations between two notes, similar to a tremolo, that were a common
decoration in Baroque, Classical, and Romantic music. Trill marks are usually added to a single
note, to indicate the performed notes are the notated pitch and the note either a half-step or
whole step above, and can have extension lines to show the duration of the trill.

A phrase containing multiple trills with extension lines

Because of their legacy as an ornament, many performers interpret trills differently to tremolos:
some players add more emphasis to the notated pitch in a trill and less on the trilled-to note but
play both notes equally in tremolos.
The most common trills are to notes a major or minor second above, but it is also possible to
specify other trill intervals.
In Dorico Pro, you can specify any trill interval, change their appearance on notation staves, and
hear them in playback.
On tablature, the trilled-to pitch always appears as a parenthesized fret number.

Trills on a notation staff and tablature

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
Trill intervals on page 932
Trill interval appearance on page 935
Trills in playback on page 937
Tablature on page 1188
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Hiding/Showing trill marks
You can hide/show trill marks at the start of individual trills. This also hides/shows trill marks on
all systems on which the trills extend.
PROCEDURE
1.

Select the trills whose trill marks you want to hide/show. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Show trill mark in the Trills group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Trill marks are shown when the checkbox is activated, and hidden when the checkbox is
deactivated.
When the property is deactivated, trill marks follow your project-wide setting.

Changing the speed of trills
You can indicate different speeds for trills, including indicating a change of speed within a single
trill, by changing the height and frequency of wiggles in their extension lines.
PROCEDURE
1.

Select the trills whose speed you want to change. You can do this in Write mode and Engrave
mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Trills group:

3.

●

Start speed

●

End speed

Select one of the following options from each property menu:
●

Slow

●

Normal

●

Fast

RESULT
The speed of the selected trills is changed. This affects both the frequency of wiggles in their
extension lines and their playback speed.
If only Start speed is activated, the speed of the whole trill extension line is changed. If only End
speed is activated, the speed of the end half of the trill extension line is changed.
EXAMPLE

A trill extension line starting slow and ending fast

AFTER COMPLETING THIS TASK
You can customize the playback speed of trills individually.
RELATED LINKS
Changing the playback speeds of trills on page 939
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Hiding/Showing speed changes in trill extension lines
You can hide/show speed changes in the extension lines for individual trills, for example, if you
want to hear different speeds in playback but show extension lines with consistent wiggles.
PROCEDURE
1.

Select the trills whose speed changes you want to hide/show. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate/deactivate Suppress drawing speed changes in the Trills
group.

RESULT
Speed changes are hidden when the property is activated, and shown when it is deactivated.
EXAMPLE

Trill speed changes hidden

Trill speed changes shown

Hiding/Showing trill extension lines
You can hide/show the extension lines of individual trills.
PROCEDURE
1.

Select the trills whose extension lines you want to hide/show. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate/deactivate Has trill line in the Trills group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Trill extension lines are shown when the checkbox is activated, and hidden when the checkbox is
deactivated.
When the property is deactivated, trills follow your project-wide setting.
TIP
You can hide/show trill extension lines on all trills project-wide on the Ornaments page in
Engrave > Engraving Options.

RELATED LINKS
Changing the speed of trills on page 930
Changing the playback speeds of trills on page 939
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Lengthening/Shortening trills rhythmically
You can lengthen/shorten trills after they have been input. Trills can overlap with other trills and
ornaments, so you can also lengthen/shorten trills to noteheads that already have ornaments.
PROCEDURE
1.

In Write mode, select the trills you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one trill at a time.

2.

Lengthen/Shorten the trills in any of the following ways:
●

To lengthen them by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten them by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .

●

To lengthen a single trill to the next notehead, press Ctrl/Cmd-Shift-Alt/OptRight Arrow .

●

To shorten a single trill to the previous notehead, press Ctrl/Cmd-Shift-Alt/OptLeft Arrow .
NOTE

●

●

You can only lengthen/shorten trills by the current rhythmic grid resolution when
multiple trills are selected.

●

Key commands lengthen/shorten items by moving their end only.

Click and drag the circular handle at the start/end of the trill to noteheads to the right/
left.

RESULT
Single trills are lengthened/shortened according to the current rhythmic grid resolution or to the
next/previous notehead, whichever is closer.
Multiple trills are lengthened/shortened according to the current rhythmic grid resolution.
RELATED LINKS
Positions of ornaments on page 926
Moving ornaments rhythmically on page 926
Moving ornaments graphically on page 927

Trill intervals
Trill intervals tell performers which notes to play and also affect the pitches used in playback in
Dorico Pro. For example, a trill with a sharp accidental on an E indicates that the performer trills
between E and F♯, rather than between E and F.

The different accidentals on these trills indicate changes in the trilled-to note.
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If you do not specify an interval when inputting a trill, Dorico Pro calculates an appropriate
interval based on the top note in the voice to which the trill belongs, the current key signature,
and any accidentals earlier in the bar. For example, inputting a trill on an E♮ in C major produces a
half-step/minor second trill interval to F♮. If there were a sharp accidental on the F earlier in the
bar, the trill interval produced is a whole step/major second between the E♮ and F♯.
In open/atonal key signatures, Dorico Pro produces whole step/major second trill intervals by
default.
You can specify trill intervals when inputting them with the popover, including at different
noteheads in the same trill, and you can change their intervals after they have been input.

Trills and accidentals
If required, Dorico Pro shows accidentals to clarify trill intervals. Dorico Pro also automatically
shows accidentals on other notes in the bar if they have different accidentals to any upper notes
of trills.
By default, trill marks themselves show intervals, unless the upper note is modified by an
accidental in the key signature. If the upper note has been modified by an accidental earlier in
the bar, trills always show the interval. If trills modify pitches modified by an accidental in the key
signature, any subsequent notes of that pitch show the appropriate accidental automatically. Any
cautionary accidentals required in the current and following bars are also shown automatically.

Microtonal trill intervals
When using other tonality systems than 12-EDO, you can specify trill intervals based on diatonic
steps and the total number of divisions from the written note. In 24-EDO, you can describe trill
intervals based on their quality, such as major or minor. In tonality systems with a greater
number of divisions or an unequal number of divisions between each diatonic step, you must
specify trill intervals based on their octave divisions, as specifying only the interval quality is
insufficient in such cases.
RELATED LINKS
Trill interval appearance on page 935

Hiding/Showing trill interval accidentals
You can hide/show trill interval accidentals for individual trills.
NOTE
These steps only hide the accidentals shown in trill intervals, they do not hide auxiliary notes or
Hollywood-style markings.

PROCEDURE
1.

Select the trills whose accidentals you want to hide/show. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Accidental in the Trills group.

3.

Choose one of the following options:
●

Hide

●

Show
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RESULT
Accidentals in the selected trill intervals are hidden when you choose Hide, and shown when you
choose Show.
NOTE
Trill accidentals are restated at each new pitch over which the trill extends. You can choose to
repeat or hide all Hollywood-style trill intervals on successive notes in the Trill Intervals section
of the Ornaments page in Engrave > Engraving Options.

RELATED LINKS
Changing the appearance of trill intervals on page 936

Changing the intervals of existing trills
The default trill interval is a second, either major or minor depending on the context. In addition
to specifying the interval when inputting trills with the ornaments popover, you can change the
intervals of trills individually after they have been input.
PROCEDURE
1.

In Write mode, select the trills whose interval you want to change.

2.

In the Properties panel, activate Interval in the Trills group.
The existing interval of the trill is shown as a number and quality.

3.

Change the interval by changing the value in the value field.

4.

Select one of the following interval qualities from the menu:
●

Diminished

●

Minor

●

Major

●

Augmented

RESULT
The interval of the selected trills is changed. By default, trill intervals appear as accidentals when
the interval is a second and as auxiliary notes for all other intervals.
RELATED LINKS
Ornaments popover on page 265

Changing intervals partway through trills
You can change the interval of trills multiple times within their duration, including before you
have input notes, for example, if you want a trill to change seamlessly from a minor second in
one bar to a major second in the next.
PROCEDURE
1.

In Write mode, select one of the following:
●

The note whose trill interval you want to change.

●

An item or rest on the staff where you want to input notes and specify trill intervals.

2.

Press Shift-N to start note input.

3.

Press Right Arrow / Left Arrow to move the caret according to the current rhythmic grid
resolution to the notehead where you want to change the trill interval.
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NOTE
You can only change trill intervals at noteheads.
4.

Press Shift-O to open the ornaments popover.

5.

Enter the trill interval you want into the popover. For example, enter m3 for a minor third.

6.

Press Return to close the popover.

7.

Optional: Repeat steps 3 to 6 to change the trill interval at other noteheads in the trill.

8.

Press Esc or Return to stop note input.

RESULT
The trill interval is changed at the corresponding noteheads. By default, all trill intervals in the
trill appear as accidentals when the intervals are all seconds and as auxiliary notes when the trill
contains at least one trill interval with a different interval.
EXAMPLE

Trill with interval changes shown as accidentals

Trill with interval changes shown as auxiliary notes

Trill interval appearance
There are different accepted ways to present trill intervals on notation staves, including
accidental symbols and the Hollywood convention of showing “H.T.” for a half-step (semitone)
and “W.T.” for a whole step (tone).
In Dorico Pro, trill intervals can appear in the following ways on notation staves:
Accidental
Indicates the trill interval using accidentals positioned above, below, or beside the tr
mark. This is the default trill interval appearance in Dorico Pro for major or minor
second trills.

Hollywood-style
Indicates the trill interval using text.
●

H.T. for half-step/minor second trills

●

W.T. for whole step/major second trills
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Auxiliary note
Indicates the trill interval using a small, parenthesized, stemless notehead shown in
the staff immediately to the right of the first note to which the trill applies, and at the
correct staff position for the trilled-to pitch. Auxiliary notes are used for all trill intervals
that are not a major or minor second, but are automatically hidden for unison trills if
the notehead design of the auxiliary note has not been overridden.

NOTE
●

On tablature, the trilled-to pitch always appears as a parenthesized fret number.

●

You can find options for the default appearance, position, and restatement of trill intervals
on the Ornaments page in Engrave > Engraving Options.

Changing the appearance of trill intervals
You can change the appearance of trills with a second interval on notation staves individually,
independently of your project-wide setting, for example, if you want to show auxiliary notes on
some trills to clarify a change in the trilled-to pitch.
NOTE
You can only change the trill interval appearance of trills with a major/minor second interval.

PROCEDURE
1.

Select the trills whose trill interval appearance you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Appearance in the Trills group.

3.

Select one of the following options from the menu:
●

Accidental

●

Hollywood style

●

Auxiliary note

RESULT
The appearance of the selected trill intervals on notation staves is changed. This does not affect
their appearance on tablature.
TIP
You can change the default appearance of all trills with a second interval project-wide in the Trill
Intervals section of the Ornaments page in Engrave > Engraving Options.
AFTER COMPLETING THIS TASK
You can change the notehead design of individual auxiliary notes, for example, to show that the
trilled-to note is a harmonic.
RELATED LINKS
Project-wide engraving options for ornaments on page 924
Changing the notehead design of individual noteheads on page 898
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Changing the position of trill interval indicators
You can change where trill interval indicators, such as an accidental or W.T. marking, are
positioned relative to individual trills, independently of your project-wide setting.
PROCEDURE
1.

Select the trills whose interval indicator position you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Interval position in the Trills group.

3.

Select one of the following options from the menu:
●

Above

●

Below

●

On the right

●

Superscript

RESULT
The position of interval indicators relative to the selected trills is changed.
TIP
You can change the default position of interval indicators relative to all trills project-wide in the
Trill Intervals section of the Ornaments page in Engrave > Engraving Options.

Trills in playback
Dorico Pro plays back trills by using a combination of sampled trills, when available, and
triggering multiple notes.
●

You can find options for trill playback on the Trills page in Play > Playback Options.

Dorico Pro can play back sampled half-step (semitone) and whole step (tone) trills automatically if
these playing techniques are defined in the VST expression map, which is the case for a number
of instruments in HALion Symphonic Orchestra. For sound libraries that do not provide sampled
trills, or for intervals beyond a whole step, Dorico Pro generates trills. If your project contains
some trill intervals that can only be generated, you can disable sampled trills and use generated
trills throughout to produce a more consistent result.
When playing generated trills, Dorico Pro incorporates grace notes immediately before and after
trills. A single unslashed grace note on the initial trill note produces an appoggiatura, while
multiple grace notes on the initial trill note are included in the trill pattern. Grace notes on the
note immediately following a trill are also included in the trill pattern.
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A trill with grace notes at both the start and end

Variable speeds within trills are included in playback. You can determine the default playback
speeds of slow, normal, and fast trills on the Trills page in Playback Options, and you can
change the playback speed of individual trills. Additionally, you can hide trill speed changes in
trill extension lines whilst retaining the speed changes in playback.
In contemporary performance practice, trills are usually performed starting on the written note,
while in the historical performance practice of the Baroque and Classical eras, trills are usually
performed starting on the upper (trilled-to) note. You can change the default starting pitch for
trills individually and by changing the default setting.
Another common performance practice, in particular for Romantic piano music, is to perform all
trills with an acceleration, starting slowly and getting faster during the trill. You can choose this
setting on the Trills page in Playback Options. It applies to all trills whose speed has not been
changed.
RELATED LINKS
Changing the speed of trills on page 930
Hiding/Showing speed changes in trill extension lines on page 931
Changing the starting pitch of trills on page 939

Sampled vs. generated trills
Sampled trills are recorded, looped samples, whereas generated trills are produced by manually
triggering separate notes.
Because they use fixed sounds, sampled trills typically offer no parameters that allow any kind of
variation in the trill interpretation, such as different trill speeds or incorporating grace notes and
termination notes into the pattern of trilled notes. By contrast, generated trills can provide
greater flexibility but produce a less natural and realistic sound.
If your project contains some trill intervals that can only be generated, you can disable sampled
trills and use generated trills throughout to produce a more consistent result.

Enabling/Disabling trill samples in playback
You can enable/disable the use of sampled trills in your project. This can be useful if your project
contains some trill intervals that can only be generated and you want to use only generated trills
throughout, or if you want to incorporate grace notes immediately before/after trills.
NOTE
If you are using NotePerformer for playback, we recommend that you disable sampled trills to
allow Dorico Pro to send the correct notes and controllers for NotePerformer to produce its most
realistic trill playback.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-P to open Playback Options.
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2.

Click Trills in the page list.

3.

Choose one of the following options for Playback approach for trills:

4.

●

Generated trills only

●

Use samples if possible

Click Apply, then Close.

RESULT
Sampled trills are enabled when you choose Use samples if possible, and disabled when you
choose Generated trills only.

Changing the playback speeds of trills
In addition to changing the speed of trills, which changes both the frequency of wiggles in their
extension lines and their playback speed, you can also change the playback speed of each speed
variant in individual trills, for example, if you want to make the fastest part of an individual trill
faster than your default setting.
PROCEDURE
1.

Select the trills whose playback speeds you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate any of the following properties, as appropriate for your
selected trills:

3.

●

Slow trill speed

●

Normal trill speed

●

Fast trill speed

Change the values in the value fields.

RESULT
The playback speed of the selected trills is changed. The values in the value fields correspond to
the number of notes sounding per second.
TIP
You can change the default speeds for each level on the Trills page in Play > Playback Options.

RELATED LINKS
Changing the speed of trills on page 930
Hiding/Showing speed changes in trill extension lines on page 931

Changing the starting pitch of trills
By default in Dorico Pro, trills start on the lower note, which is usually the written note. However,
the accepted practice in Baroque and Classical music is to start trills on the upper note. You can
change the starting pitch of trills individually.
PROCEDURE
1.

Select the trills whose starting note you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Start on upper note in the Trills group.

3.

Activate/Deactivate the corresponding checkbox.
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RESULT
The selected trills start on the upper note when the checkbox is activated, and on the lower note
when the checkbox is deactivated.
When the property is deactivated, trills follow your project-wide setting for the starting pitch of
trills.
TIP
You can change the default starting pitch of all trills project-wide on the Trills page in Play >
Playback Options.
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Arpeggio signs are vertical lines that indicate chords are to be played arpeggiated, or “spread”,
so that the notes in the chord are played very quickly one after another. Arpeggio signs are
normally shown as vertical wavy lines.

Arpeggiated chords can be played in two directions:
●

Upwards, starting from the bottom note in the chord.

●

Downwards, starting from the top note in the chord.

It is most common for up arpeggio signs to have nothing at the top end, because chords are
usually arpeggiated upwards, and for down arpeggio signs to have an arrow at the bottom, so
these are the defaults in Dorico Pro. However, it is also accepted practice to show up arpeggio
signs with an arrow at the top if down arpeggio signs are also used in the same piece of music.
Arpeggio signs in Dorico Pro automatically span the range of all notes in the voices/staves to
which they apply.
RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
Lines on page 1033

Types of arpeggio signs
There are different types of arpeggio signs to convey the different arpeggiation directions and
techniques.
Up arpeggio

A vertical wavy line that indicates chords are to be arpeggiated from the bottom note
upwards.
Down arpeggio
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A vertical wavy line that indicates chords are to be arpeggiated from the top note
downwards.
Non arpeggio

A bracket with straight lines that indicates all notes in the chord are to be played
together, not arpeggiated.
Curved arpeggio

A curved line, similar to a slur but vertical, that some composers use to indicate gentle
or partial arpeggiation.
You can show both up and down arpeggio signs with one of the following ends in Dorico Pro:
●

Nothing

●

Arrow

●

Swash

Up arpeggio sign with nothing at
the end

Up arpeggio sign with an arrow at
the end

Up arpeggio sign with a swash at
the end

Changing the type of arpeggio signs
You can change the type of arpeggio signs after they have been input.
PROCEDURE
1.

Select the arpeggio signs whose type you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, select one of the following options from the Arpeggio type menu in
the Arpeggios group:
●

Non arpeggio

●

Up arpeggio

●

Down arpeggio

●

Up arpeggio (curve)

RESULT
The type of the selected arpeggio signs is changed.
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TIP
You can also change the arpeggio type by opening the ornaments popover and changing the
entry.

RELATED LINKS
Ornaments popover on page 265
Changing existing items on page 329

Changing the end appearance of arpeggio signs
Down arpeggio signs have an arrowhead at the bottom of the line by default, but up arpeggio
signs have no arrowhead by default. You can change the appearance of the ends of arpeggio
signs individually, independently of your project-wide settings.
NOTE
These steps only apply to up and down arpeggio signs. They do not apply to curved or non
arpeggio signs.

PROCEDURE
1.

Select the arpeggio signs of any direction whose ends you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Sign end in the Arpeggios group.

3.

Select the end you want from the menu:
●

Nothing

●

Arrow

●

Swash

RESULT
The appearance of the ends of the selected arpeggio signs is changed.
TIP
You can change the default appearance of the ends of all arpeggio signs project-wide on the
Arpeggio Signs page in Engrave > Engraving Options.
EXAMPLE

Up arpeggio sign with nothing at
the end

Up arpeggio sign with an arrow at
the end
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Length of arpeggio signs
The length of arpeggio signs is determined by the pitch range of notes in the voices/staves to
which the arpeggio sign applies.
Dorico Pro automatically adjusts the length of arpeggio signs if the pitches of the notes in the
voices/staves to which the sign applies change, or you add notes to, or delete notes from, the
chords.
You can change how far arpeggio signs extend beyond the outer notes in all chords project-wide
on the Arpeggio Signs page in Engrave > Engraving Options. You can set different values for
when notes are on staff lines and in staff spaces.
You can also lengthen/shorten individual arpeggio signs.
RELATED LINKS
Project-wide engraving options for arpeggio signs on page 947

Lengthening/Shortening arpeggio signs
You can lengthen/shorten individual arpeggio signs graphically. For example, you might
lengthen an arpeggio sign on a chord with a small pitch range so the arpeggio sign is more
clearly visible.
PROCEDURE
1.

In Engrave mode, select the square handles at one end of the arpeggio signs you want to
lengthen/shorten.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag them upwards/downwards.

RESULT
The selected arpeggio signs are lengthened/shortened graphically. This does not change the
notes to which they apply.
TIP
●

The following properties in the Arpeggios group of the Properties panel are activated
automatically when you move the corresponding end of arpeggio signs:
●

Top Y offset moves the handles at the top of arpeggio signs.

●

Bottom Y offset moves the handles at the bottom of arpeggio signs.

For example, if you move a whole arpeggio sign, both handles are moved so both properties
are activated. You can also use these properties to lengthen/shorten arpeggio signs
graphically by changing the values in the value fields.

944
Dorico Pro 3.1.10

Arpeggio signs
General placement conventions for arpeggio signs
Deactivating the properties resets the selected arpeggio signs to their default positions.
●

You can change how far all arpeggio signs extend beyond the outer notes in chords projectwide on the Arpeggio Signs page in Engrave > Engraving Options.

RELATED LINKS
Moving arpeggio signs graphically on page 946
Project-wide engraving options for arpeggio signs on page 947

General placement conventions for arpeggio signs
Arpeggio signs are positioned to the left of the notes, including any applicable accidentals, to
which they apply, but are positioned between grace notes and normal notes. They should appear
within the same bar as the notes to which they apply, and not on the other side of the barline.
Dorico Pro makes automatic adjustments to note spacing and staff spacing to accommodate
arpeggio signs and ensure they are positioned correctly.
Arpeggio signs should cover the whole vertical range of all notes in the chord to which they
apply, and protrude slightly at each end. However, they do not need to cover the stems of notes.
Dorico Pro automatically creates the lengths of arpeggio signs to cover the notes in chords, and
adjusts their lengths if the notes in chords change or are deleted.
If an arpeggiated chord spans two staves, such as in a piano part, its arpeggio sign can extend
across both staves.
You can move arpeggio signs to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.
You can move arpeggio signs graphically in Engrave mode; however, this does not change the
rhythmic positions to which they are attached.
You can change the default position of all arpeggio signs project-wide on the Arpeggio Signs
page in Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for arpeggio signs on page 947
Length of arpeggio signs on page 944

Moving arpeggio signs rhythmically
You can move arpeggio signs to new rhythmic positions after they have been input.
NOTE
●

You cannot move arpeggio signs over rests, you can only move them to adjacent notes/
chords in the same voice. If you want to move arpeggio signs along a phrase containing
rests, we recommend deleting them and inputting new arpeggio signs at the new positions
instead.

●

You cannot move arpeggio signs rhythmically with the mouse.

PROCEDURE
1.

In Write mode, select the arpeggio signs you want to move.

2.

Move the arpeggio signs in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.
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RESULT
Arpeggio signs are moved to the right/left, according to the current rhythmic grid resolution.
If no notes exist at the next rhythmic position according to the rhythmic grid, the arpeggio sign is
not shown. If you continue moving it to the right/left, it is shown again beside the next note at a
rhythmic position that can be reached according to the current rhythmic grid resolution.
You can change the rhythmic grid resolution if you want to move arpeggio signs to notes at
other rhythmic positions.
NOTE
●

If you move arpeggio signs to the rhythmic position of a rest, they are deleted.

●

Only one arpeggio sign can exist at each rhythmic position. If an arpeggio sign in your
selection passes over another arpeggio sign as part of its move, the existing arpeggio sign is
deleted.

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265

Moving arpeggio signs graphically
You can move arpeggio signs graphically without changing the rhythmic positions to which they
apply.
PROCEDURE
1.

In Engrave mode, select the arpeggio signs you want to move.

2.

Move the arpeggio signs in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected arpeggio signs are moved graphically, without affecting the rhythmic positions to
which they apply.
TIP
The following properties in the Arpeggios group of the Properties panel are activated
automatically when you move the corresponding part of arpeggio signs:
●

Top Y offset moves the top of arpeggio signs vertically.

●

Bottom Y offset moves the bottom of arpeggio signs vertically.

●

X offset moves whole arpeggio signs horizontally.

For example, if you move a whole arpeggio sign upwards, both handles are moved, so Top Y
offset and Bottom Y offset are both activated. You can also use all three properties to move
arpeggio signs graphically by changing the values in the value fields.
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Deactivating the properties resets the selected arpeggio signs to their default position.

RELATED LINKS
Lengthening/Shortening arpeggio signs on page 944

Showing arpeggio signs before/after grace notes
You can show arpeggio signs before/after grace notes individually. By default, arpeggio signs are
positioned immediately to the left of the notes to which they apply, and so are positioned
between normal notes and grace notes.
PROCEDURE
1.

Select the arpeggio signs you want to show before grace notes. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Arpeggio before grace notes in the Arpeggios
group.

RESULT
The selected arpeggio signs are shown before grace notes when the property is activated, and
after grace notes when the property is deactivated.

Project-wide engraving options for arpeggio signs
You can find options for the project-wide appearance and position of arpeggio signs on the
Arpeggio Signs page in Engrave > Engraving Options.
The options on this page allow you to change the design, appearance, and precise position of
arpeggio signs, including whether they can be shown on notes in slash voices.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Arpeggios in playback
You can find options to control the playback of all arpeggios project-wide in the Arpeggio Signs
section of the Timing page in Play > Playback Options.
For example, you can control the speed of arpeggiation and whether arpeggiation starts on the
beat or ends on the beat.
You can set a default arpeggio length for wiggly arpeggio signs and curved arpeggio signs
separately, expressed as a fraction of a quarter note (crotchet) at 120 bpm. It can be helpful to
set arpeggio lengths using this measurement instead of defining arpeggios as a fraction of their
notated rhythm, as otherwise arpeggios in very slow music would play back much slower than
most people intend.
As well as setting a default length for arpeggios, you can also set minimum and maximum values
for the length of arpeggios, expressed as a fraction of the notated value of the arpeggio. This is
to ensure all notes with arpeggio signs can be heard within their notated duration.
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TIP
You can also use properties in the Arpeggios Playback group of the Properties panel to override
the default playback options for individual arpeggio signs.

Changing arpeggio playback relative to the beat
You can change whether individual arpeggios are played before their notated position or after
their notated position, independently of your project-wide settings.
PROCEDURE
1.

Select the arpeggio signs whose playback relative to the beat you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Playback position in the Arpeggios Playback group.

3.

Choose one of the following options:
●

Start on beat

●

End on beat

RESULT
The beat-relative position of the selected arpeggios in playback is changed.
TIP
You can change the playback of all arpeggios relative to the beat project-wide on the Timing
page in Play > Playback Options.
EXAMPLE

Arpeggio starting on the beat

Arpeggio ending on the beat

RELATED LINKS
Arpeggios in playback on page 947
Playback Options dialog on page 502

Changing the playback duration of arpeggios
You can change the duration of individual arpeggios in playback, independently of your projectwide settings.
The duration of arpeggios is expressed as a fraction of the notated rhythm of chords. For
example, an arpeggio on a quarter note (crotchet) chord with a note offset value of 1/2 lasts an
eighth note (quaver), whereas with a note offset value of 1/8 it lasts a 32nd note.
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PROCEDURE
1.

Select the arpeggio signs whose playback duration you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Note offset in the Arpeggios Playback group.

3.

Change the playback duration of the selected arpeggio signs by changing the value in the
value field.

4.

Press Return .

RESULT
The playback duration of the selected arpeggios is changed. This overrides your project-wide
settings for the duration of arpeggios for the selected arpeggios.
EXAMPLE

Arpeggiated chord with a note offset value of 1/8

RELATED LINKS
Arpeggios in playback on page 947
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Glissando lines
Glissando lines indicate a continuous transition between two notes, which can be smooth or in
chromatic steps. They can have straight lines or wiggly lines, and can be shown with a text
indication or as a line without text.
There are different conventions regarding the playing techniques for glissando and portamento.
Some people understand glissando lines to indicate a chromatic scale between the two notes,
either rising or falling in a series of semitones, and portamento lines to indicate a smooth,
continuous glide between the two notes. However, the terms glissando and portamento can be
used interchangeably in other cases.
You can input both glissando lines and portamento lines in Dorico Pro, and you can easily change
their style after they have been input.
Glissando lines in Dorico Pro automatically follow the notes at each end, meaning if you change
the pitch of either note, the glissando line end positions move accordingly.

An example glissando line with text shown and a
wiggly line

An example portamento line with text shown and a
straight line

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
Changing the style of glissando lines on page 952
Lines on page 1033
Playing technique continuation lines on page 1015
Changing the pitch of individual notes on page 200

General placement conventions for glissando lines
Glissando lines are positioned between noteheads and the steepness of their angle should
reflect the interval between the notes: the steeper the angle, the greater the interval. The
endpoints of glissando lines must be directly beside noteheads but not directly touching them.
Glissando lines must not collide with accidentals, and instead must stop short so the accidental
can be clearly read. Dorico Pro automatically positions glissando lines so they do not collide with
accidentals.
Usually, glissando lines join two adjacent noteheads because they indicate a gradual but
constant change in pitch between those two notes, but they can also cross multiple notes.
Glissando lines can cross system breaks and page breaks. If text is shown for glissando lines that
span system or page breaks, then that text is shown on every glissando line segment. By default,
the start and end positions of each segment matches the original start and end points of the
whole glissando line.
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In Dorico Pro, you can make detailed adjustments to the default positions of glissando lines on
the Glissando Lines page in Engrave > Engraving Options. You can also adjust the start/end
positions of individual glissando lines in Engrave mode.
RELATED LINKS
Project-wide engraving options for glissando lines on page 951
Changing the default angles of glissando lines project-wide on page 955
Changing the angles of glissando lines individually on page 955

Project-wide engraving options for glissando lines
You can find options for the project-wide appearance and position of glissando lines on the
Glissando Lines page in Engrave > Engraving Options.
The options on the Glissando Lines page allow you to change the style, appearance, and
thickness of glissando lines. You can also set precise positions for the endpoints of glissando
lines relative to noteheads.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Glissando lines across empty bars
In Dorico Pro, you can input glissando lines between any two notes, even if there are rests or
other notes between them, and including between notes in different voices and notes on
different staves.
For very long glissando lines that extend across multiple bars, you might not want to show
pitches at the start of each bar, for example, to indicate that performers do not emphasize
pitches during the course of the glissando, or that performers can play the glissando at their own
speed. By default, Dorico Pro shows notes or rests in every bar.
Once you have input a glissando line between the selected notes, you can delete any rests
between them.
EXAMPLE

A glissando line across multiple bars with no rests shown between the two notes

RELATED LINKS
Inputting glissando lines with the popover on page 271
Inputting glissando lines with the panel on page 272
Hiding/Showing bar rests in empty bars on page 1111
Deleting rests on page 1110
Turning explicit rests into implicit rests on page 1109
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Changing the style of glissando lines
Glissando lines can be shown as straight lines or wiggly lines. You can change the glissando line
style of glissando lines individually, independently of your project-wide setting.
PROCEDURE
1.

Select the glissando lines whose style you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Glissando style in the Glissando Lines group.

3.

Choose one of the following options:
●

Straight line

●

Wiggly line

RESULT
The glissando line style is changed for the selected glissando lines.
TIP
●

Deactivating Glissando style returns the selected glissando lines to the default style.

●

You can also change the glissando style by opening the ornaments popover and changing
the entry.

●

You can change the default style for all glissando lines project-wide on the Glissando Lines
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for glissando lines on page 951
Ornaments popover on page 265
Changing existing items on page 329

Changing glissando line text
Glissando lines can be shown with text or without text. You can change the text of glissando lines
individually, independently of your project-wide setting.
PROCEDURE
1.

Select the glissando lines whose text you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Glissando text in the Glissando Lines group.

3.

Select one of the following options from the menu:
●

Gliss.

●

Port.

●

No text
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RESULT
The text shown on the selected glissando lines is changed.
TIP
You can change the text shown on all glissando lines project-wide on the Glissando Lines page
in Engrave > Engraving Options.

Changing when glissando line text is shown
By default, glissando text is not shown when glissando lines are too short to accommodate the
text. You can choose to show text on individual glissando lines always, or only if there is sufficient
space.
PROCEDURE
1.

Select the glissando lines whose setting for when text is shown you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Glissando text shown in the Glissando Lines group.

3.

Choose one of the following options:
●

Show if sufficient space

●

Always show

RESULT
If Show if sufficient space is chosen, glissando line text is not shown if the glissando line is too
short.
If Always show is chosen, glissando line text is always shown, even if the glissando line is short.
However, this can cause the glissando line text to collide with other items, such as noteheads and
stems.
TIP
You can increase the default gaps between noteheads by changing the default note spacing, and
between individual noteheads by adjusting note spacing at individual rhythmic positions in
Engrave mode.

RELATED LINKS
Note spacing on page 425
Changing the default note spacing on page 425

Moving glissando lines graphically
You can move individual glissando lines graphically without changing the rhythmic positions to
which they are attached. You can move each end of glissando lines independently, meaning you
can also adjust the angle and graphical length of individual glissando lines.
In Engrave mode, each glissando line has two square handles, one at the start and one at the
end.
If glissando lines cross system and frame breaks, you can move the glissando line segments on
each side of the break independently.
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NOTE
You cannot move glissando lines rhythmically. If you want to change the rhythmic positions of
glissando lines, you must delete them from their original positions and input new glissando lines
at the new positions.

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Whole glissando lines or glissando line segments

●

Individual handles on glissando lines

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the glissando lines or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected glissando lines or handles are moved graphically, without affecting the rhythmic
positions to which they are attached.
TIP
The following properties in the Glissando Lines group of the Properties panel are activated
automatically when you move the corresponding glissando line handle:
●

Start offset moves start glissando line handles. X moves them horizontally, Y moves them
vertically.

●

End offset moves end glissando line handles. X moves them horizontally, Y moves them
vertically.

For example, if you move a whole glissando line, both handles are moved so both properties are
activated. You can also use these properties to move and lengthen/shorten glissando lines
graphically by changing the values in the value fields.
Deactivating the properties resets the selected glissando lines to their default positions.

RELATED LINKS
Changing the angles of glissando lines individually on page 955
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
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Changing the default angles of glissando lines project-wide
In Dorico Pro, the endpoints of glissando lines are automatically positioned beside noteheads.
When glissando lines cover a small pitch range, the angle of the line can be quite shallow. You
can change the values for the minimum spans of glissando lines covering a small pitch range in
different contexts project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Glissando Lines in the page list.

3.

In the Vertical Position section, change the values for the positions of glissando lines in the
contexts relevant to your project.
For example, you can increase the minimum span of glissando lines between notes in the
same staff space.

4.

Click Apply, then Close.

RESULT
The default positions and angles of glissando lines are changed.
TIP
You can make graphical adjustments to the positions of individual glissando lines in Engrave
mode.

RELATED LINKS
Moving glissando lines graphically on page 953

Changing the angles of glissando lines individually
You can adjust the angles of individual glissando lines in Engrave mode by moving the handles at
each end of glissando lines in any direction.
PROCEDURE
1.

In Engrave mode, select the square handles at the start/end of the glissando lines whose
angles you want to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag them in any direction.
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3.

Optional: Repeat steps 1 and 2 for the other glissando line handles.

RESULT
The angles of the selected glissando lines are changed.
NOTE
You can also use the Start offset and End offset properties in the Glissando Lines group of the
Properties panel in Engrave mode to adjust the angles and graphical lengths of glissando lines.
Deactivating the properties resets the selected glissando lines to their default positions.

Glissando lines in playback
Glissando lines are reflected in playback using a sequence of notes, all a small interval apart,
between the start and end notes for each glissando.
Glissandos belonging to harps consider the current harp pedaling when determining the pitches
to use in playback. Glissandos for all other instruments use the 12-EDO chromatic scale,
regardless of the current tonality system.
When glissando lines start or end on tie chains, their playback starts on the last note in tie chains
and ends on the first note in tie chains.
By default in playback, glissandos sound across their full duration, but you can delay the start of
glissandos in playback individually.
NOTE
Playing back glissando lines as a continuous, smooth slide is not yet supported. This is planned
for future versions.

RELATED LINKS
Harp pedaling on page 977

Delaying the start of glissandos in playback
You can delay the start of glissandos in playback so that they start partway through their
duration. By default, glissandos sound for their full duration in playback.
PROCEDURE
1.

Select the glissando lines whose playback start you want to delay. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Delayed start in the Glissando Lines group.

3.

Optional: If you want to specify exactly how far through the glissando lines playback starts,
activate Delay and change the value in the value field.
The value represents fractions of a quarter note. For example, 1/2 delays the start of
glissandos by an eighth note.

RESULT
If you activated Delayed start only, the playback of the selected glissando lines is starts halfway
through their duration.
If you also activated Delay, playback of the selected glissando lines follows your set value.
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The guitar bend is a technique commonly performed on electric guitars, where the performer
pushes a string out of its normal alignment. Bending the string tightens it, which produces the
characteristic pitch fluctuation.
In addition to guitar bends, where the player bends the string after playing a note, Dorico Pro
supports guitar pre-bends. Guitar pre-bends require the player to bend the string before playing
the note, so there is no change in pitch at the start of the note.
Performing a guitar bend often also involves sustaining the bent pitch before allowing the string
to return to its natural position and un-bent pitch. In Dorico Pro, these actions are called a “guitar
bend hold” and “release” respectively.

A phrase containing guitar bends, a guitar bend hold, guitar pre-bends, and releases, shown on both a
notation staff and tablature

Guitar bends
Guitar bends indicate that the performer should bend the string after playing a note,
so that the pitch increases while the note sounds. In Dorico Pro, guitar bends join two
notes: the start pitch and the pitch at the peak of the bend.
On notation staves, guitar bends are notated using an angled line between the
noteheads at the start and end. On tablature, guitar bends are notated using an
upwards-pointing curved line with an arrowhead at the top, with text or a number/
fraction above the arrowhead to indicate the bend interval. The fret number of the end
note is hidden automatically.

Guitar bend on notation staff

Guitar bend on tablature

Sequences of consecutive guitar bends are notated as bend runs on tablature.
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Guitar bend holds
Guitar bend holds indicate that the performer should maintain the pitch at the peak of
a guitar bend. This is usually shown on tied notes.
On tablature, guitar bend holds are notated using a horizontal line. They are not
notated on notation staves.

Guitar bend hold on tablature

Releases
Releases indicate that the performer should allow a bent string to return to its natural
position, which decreases the pitch. In Dorico Pro, releases join two notes: the pitch at
the peak of the bend and the end pitch.
On notation staves, releases are notated using an angled line between the noteheads
at the start and end. On tablature, releases are notated using a downwards-pointing
curved line with an arrowhead at the bottom, with a parenthesized fret number below
the arrowhead to indicate the end pitch. The fret number of the start note is hidden
automatically.

Release on notation staff

Release on tablature

NOTE
Because you input releases in the same way as you input guitar bends, in this
documentation, “guitar bends” refers to both guitar bend and release items in projects.
Guitar pre-bends
Guitar pre-bends indicate that the performer should bend the string before playing the
note, so that the start pitch is already increased, for example, to repeat a note that was
at the end of a previous guitar bend. In Dorico Pro, guitar pre-bends apply to a single
note.
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On notation staves, guitar pre-bends are notated using an angled line between the
noteheads at the start and end. However, unlike guitar bends, the parenthesized
auxiliary notehead at the start is shown automatically as part of the pre-bend. On
tablature, guitar pre-bends are notated using a vertical line with an arrowhead at the
top, with text or a number/fraction above the arrowhead to indicate the pre-bend
interval and a small fret number below the line to indicate the start pitch.

Guitar pre-bend on notation staff

Guitar pre-bend on tablature

Bend intervals
Bend intervals indicate the change in pitch, expressed in relation to whole steps. For
example, full indicates a whole step guitar bend/pre-bend, 1/2 a half-step, and 1 1/2 a
minor third.

A phrase showing two different pre-bend intervals, 1 1/2 and full

NOTE
●

Guitar bends, releases, and pre-bends are not currently reflected in playback. This is planned
for future versions.

●

By default, stems, stem flags, and beaming appear stem-up on tablature in single-voice
contexts, which means they can collide with guitar bends. Therefore, in projects where you
want to show both guitar bends and rhythms on tablature, we recommend that you change
the Default stem direction to Down on the Tablature page in Engrave > Engraving
Options.

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
Inputting guitar pre-bends on page 276
Tablature on page 1188
Hiding/Showing notation staves and tablature on page 1189
String indicators on page 813
Lines on page 1033
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Project-wide engraving options for guitar bends/pre-bends
You can find options for the project-wide appearance and position of guitar bends and pre-bends
on the Guitar Bends page in Engrave > Engraving Options.
The options on the Guitar Bends page allow you to change the height, minimum horizontal
spacing requirements, and thickness of guitar bends/pre-bends, both on notation staves and
tablature. For bends/pre-bends on tablature, there are multiple options for the appearance of
bend intervals, releases, and hold lines. You can also set precise positions for the endpoints of
guitar bends relative to noteheads, beams, and staff lines.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Hiding/Showing guitar bend hold lines
Guitar bend hold lines indicate that the bend should be held for the duration of the note, which is
usually a tied note. You can hide/show hold lines on guitar bends on tablature.
NOTE
These steps only apply to guitar bends. You cannot show hold lines on pre-bends or releases.

PROCEDURE
1.

Select the guitar bends on which you want to hide/show hold lines. You can do this on
notation staves and tablature in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Show hold in the Guitar Bends group.

RESULT
Hold lines are shown on the selected bends on tablature when Show hold is activated, and
hidden when it is deactivated.
TIP
Guitar bends can have solid or dashed hold lines. You can change the line type for all guitar bend
holds in the Design section of the Guitar Bends page in Engrave > Engraving Options.
EXAMPLE

Hold line hidden

Hold line shown
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Changing the direction of guitar pre-bends
You can change the direction of guitar pre-bends individually. By default, guitar pre-bends are
positioned on the notehead-side of notes in single-voice contexts. In multiple-voice contexts,
they are positioned on the stem-side of notes.
PROCEDURE
1.

Select the guitar pre-bends whose direction you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Pre-bend direction in the Guitar Techniques group.

3.

Choose one of the following options:
●

Up

●

Down

RESULT
The direction of the selected guitar pre-bends is changed.
TIP
You can change the direction of guitar bends by selecting them and pressing F . However, you
cannot use this key command for guitar pre-bends.

RELATED LINKS
Changing the staff-relative placement of items on page 330

Showing guitar bends as a dive and return
You can show existing guitar bends as a dive and return, which is a technique that uses the
vibrato bar on guitars. Dives and returns appear differently on tablature than guitar bends.
PREREQUISITE
You have input guitar bends between the notes of each dive and return.
PROCEDURE
1.

Select the guitar bends you want to show as a dive and return. You can do this in Write mode
and Engrave mode.
For example, to show the notes F-E-F as a dive and return, select both guitar bends between
F-E and E-F.

2.

In the Properties panel, activate Use vibrato bar in the Guitar Bends group.

RESULT
The selected guitar bends appear as V-shaped dives and returns on tablature. A number/fraction
appears outside the staff at the point of the V to indicate the interval.
If the middle pitch is lower than the outer pitches, the V points downwards. If the middle pitch is
higher than the outer pitches, the V points upwards.
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EXAMPLE

A pair of guitar bends as they appear by default

A pair of guitar bends shown as a dive and return

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
Tablature on page 1188

Hiding/Showing accidentals on guitar pre-bends
You can hide/show accidentals on guitar pre-bends individually, for example, to save horizontal
space in a layout that also shows the interval clearly on tablature.
PROCEDURE
1.

Select the guitar pre-bends whose accidentals you want to hide/show. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Pre-bend accidental in the Guitar Techniques group.

3.

Choose one of the following options:
●

Hide

●

Show

RESULT
Accidentals on the selected guitar pre-bends are hidden when you choose Hide, and shown
when you choose Show. This does not affect the interval shown for the selected guitar pre-bends
on tablature.

Moving guitar bends graphically
You can move individual guitar bends/pre-bends and holds graphically. You can move each
handle independently, meaning you can also adjust the shape and graphical length of individual
guitar bends/pre-bends and holds.
If guitar bends cross system and frame breaks, you can move the guitar bend segment on each
side of the break independently.
NOTE
You cannot move guitar bends rhythmically. If you want to change the rhythmic positions of
guitar bends, you must delete them from their original positions and input new guitar bends at
the new positions.
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PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Whole guitar bends/pre-bends, holds, or guitar bend segments

●

Individual handles on guitar bends/pre-bends or holds

TIP

2.

●

You cannot move whole guitar pre-bends on tablature, only on notation staves.

●

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

●

You can cycle through the handles on a selected guitar bend/pre-bend by pressing Tab .

Move the selected guitar bends/pre-bends, holds, or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected guitar bends/pre-bends, holds, or handles are moved graphically, without affecting
the rhythmic positions to which they are attached.
TIP
The following properties in either the Guitar Bends or Guitar Techniques group of the
Properties panel are activated automatically when you move the corresponding guitar bend/prebend or hold handle:
●

Start offset moves start guitar bend/pre-bend handles. X moves them horizontally, Y moves
them vertically.

●

Mid offset moves middle guitar bend/pre-bend handles. X moves them horizontally, Y
moves them vertically.

●

End offset moves end guitar bend/pre-bend handles. X moves them horizontally, Y moves
them vertically.

●

Interval offset moves guitar bend/pre-bend interval handles. X moves them horizontally, Y
moves them vertically.

●

Hold start offset moves start guitar bend hold handles. X moves them horizontally, Y moves
them vertically.

●

Hold end offset moves end guitar bend hold handles. X moves them horizontally, Y moves
them vertically.

For example, if you move a whole guitar bend on a notation staff, all three handles are moved so
Start offset, Mid offset, and End offset are all activated. You can also use these properties to
move and lengthen/shorten guitar bends/pre-bends and guitar bend holds graphically by
changing the values in the value fields.
Deactivating the properties resets the selected guitar bends to their default positions.
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Guitar bends in Engrave mode
In Engrave mode, each guitar bend, pre-bend, release, and hold has multiple handles that you
can move independently to adjust their graphical position and shape.
On notation staves, guitar bends, pre-bends, and releases all have three square handles that you
can move independently. When you move either of the start/end handles, the middle handle also
moves to retain its position relative to the start/end handles.

Guitar bend handles on notation staff in Engrave mode

On tablature, guitar bends and holds have the following handles:

1

Guitar bend start handle

2

Guitar bend middle handle

3

Guitar bend end handle

4

Guitar bend interval handle

5

Hold start handle

6

Hold end handle

On tablature, releases have the following handles:

1

Release start handle

2

Release middle handle

3

Release end handle

On tablature, guitar pre-bends have the following handles:
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1

Guitar pre-bend interval handle

2

Guitar pre-bend end handle

3

Guitar pre-bend start handle

You can move these handles to change the shape of guitar bends, pre-bends, and releases, and
to change the graphical length and angle of guitar bend holds.
If guitar bends cross system and frame breaks, you can move the guitar bend segment on each
side of the break independently.
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Jazz articulations in Dorico Pro cover a range of note ornamentations that are idiomatic to jazz
music, and brass instruments in particular.
Although they are often known as jazz “articulations”, these techniques function more like
ornaments than articulations because they change the pitch rather than the duration or attack of
notes. For this reason, they are considered ornaments in Dorico Pro. They are found in the
Ornaments panel, and you can also input them using the ornaments popover.
Jazz articulations can be shown as a curved line similar to a slur, which is called a “bend” in Dorico
Pro, and as a straight line, which can be solid, dashed, or wiggly, which is called “smooth” in
Dorico Pro.
Each note can have a single jazz articulation on each side of it, one before the note and one after.
Jazz articulations after notes can have different lengths.
The following jazz articulations can be shown before notes:
Plop
An approach into the note from above.

Plop (bend)

Plop (smooth)

Scoop/Lift
An approach into the note from below. A bend approach is a scoop, a smooth approach
is a lift.

Scoop

Lift (straight)

The following jazz articulations can be shown after notes:
Doit
A rise in pitch after the note.

Doit (bend)

Doit (smooth)

Fall
A lowering of pitch after the note.
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Fall (bend)

Fall (smooth)

Additionally, there are other jazz ornaments commonly used by brass instruments that you can
add to notes in the same ways as inputting jazz articulations.
NOTE
Jazz articulations are not currently reflected in playback.

RELATED LINKS
Ornaments popover on page 265
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265

Jazz ornaments
Jazz ornaments are notations that are commonly used in jazz music and by brass instruments,
such as flips and smears, that are positioned outside of the staff rather than beside noteheads
like jazz articulations.
Jazz ornaments behave more like other ornaments than jazz articulations, in that they are items
separate from notes, and so can be selected independently of notes in Write mode and added to
notes in addition to jazz articulations. Because they are so commonly used alongside jazz
articulations, in Dorico Pro they are also included in the Jazz section in the Ornaments panel.
You can input jazz ornaments in the same ways as inputting other ornaments rather than jazz
articulations.
The following ornaments are considered jazz ornaments in Dorico Pro:
●

Flip

●

Smear

●

Jazz turn/Shake

●

Bend

NOTE
Jazz articulations are not currently reflected in playback.

RELATED LINKS
Ornaments on page 924
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
Ornaments popover on page 265
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Project-wide engraving options for jazz articulations
You can find options for the project-wide appearance and position of ornaments on the Jazz
Articulations page in Engrave > Engraving Options.
The options on the Jazz Articulations page allow you to change the default length of bends and
the default line style, design, and angle of smooth jazz articulations. You can also change the
default positions of jazz articulations relative to noteheads, staff lines, rhythm dots, and jazz
articulations belonging to other notes at the same rhythmic position.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Moving jazz articulations graphically
You can move individual jazz articulations graphically without changing the notes to which they
apply. You can move each end of smooth jazz articulations independently, meaning you can also
adjust the angle and graphical length of individual smooth jazz articulations.

Handles on a smooth doit in Engrave mode

NOTE
You cannot move jazz articulations rhythmically. If you want to change the notes to which jazz
articulations apply, you must delete them from their original notes and input new jazz
articulations on the new notes.

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Whole jazz articulations

●

Individual handles on smooth jazz articulations

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the jazz articulations or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .
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●

Click and drag them in any direction.

RESULT
The selected jazz articulations or handles are moved graphically, without affecting the notes to
which they apply.
TIP
The following properties in the Jazz Articulations group of the Properties panel are activated
automatically when you move the corresponding smooth jazz articulation handle:
●

In far offset moves the start handle of jazz articulations shown before notes, that is, the
handle further from the note. X moves them horizontally, Y moves them vertically.

●

In offset moves the end handle of jazz articulations shown before notes, that is, the handle
closer to the note. X moves them horizontally, Y moves them vertically.

●

Out offset moves the start handle of jazz articulations shown after notes, that is, the handle
closer to the note. X moves them horizontally, Y moves them vertically.

●

Out far offset moves the end handle of jazz articulations shown after notes, that is, the
handle further from the note. X moves them horizontally, Y moves them vertically.

For example, if you move a whole smooth fall, both handles are moved so both Out offset and
Out far offset are activated. You can also use these properties to move and lengthen/shorten
smooth jazz articulations graphically by changing the values in the value fields.
Deactivating the properties resets the selected smooth jazz articulations to their default
positions.

RELATED LINKS
Jazz articulations on page 966
Deleting jazz articulations on page 971
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265

Positions of jazz articulations
In Dorico Pro, jazz articulations are automatically positioned relative to the noteheads to which
they apply, with any other notations on those notes, such as rhythm dots, accidentals, and back
notes, automatically considered.
When multiple notes in a chord have a jazz articulation, Dorico Pro considers the best way to
align them based on how close to the noteheads they can be positioned and how many jazz
articulations to show in total. Dorico Pro allows a maximum of one jazz articulation per space,
meaning fewer jazz articulations than noteheads are sometimes shown on cluster chords.
They are positioned by default according to your settings in Engraving Options.
You can change the default positions of all jazz articulations project-wide relative to other jazz
articulations and to noteheads on the Jazz Articulations page in Engrave > Engraving Options.
In Engrave mode, smooth jazz articulations have a handle at each end that you can use to move
the start and end of each smooth jazz articulation independently. You can also move whole
individual jazz articulations graphically.
RELATED LINKS
Project-wide engraving options for jazz articulations on page 968
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Changing the type/length of existing jazz articulations
You can change the type and length of jazz articulations after you have input them, for example,
if you want to change a smooth doit to a long bend doit. You can specify the type/length of jazz
articulations when using the Ornaments panel but not when using the ornaments popover.
PROCEDURE
1.

In Write mode, select the notes whose jazz articulation you want to change.

2.

In the Ornaments panel, click the jazz articulation you want in the Jazz section.

RESULT
The jazz articulation shown on the selected notes is changed.
TIP
You can also change the type/duration of jazz articulations using the In and Out properties in the
Jazz Articulations group of the Properties panel.
EXAMPLE

Short bend doit

Medium bend doit

Long bend doit

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265

Changing the line style of smooth jazz articulations
You can change the line style of smooth jazz articulations individually, independently of your
project-wide settings. For example, if you want selected smooth falls to have straight lines
instead of wavy lines.
PROCEDURE
1.

Select the notes with smooth jazz articulations whose line style you want to change. You can
do this in Write mode and Engrave mode.
NOTE
You must select notes with smooth jazz articulations on the same side, for example, only
select notes with smooth jazz articulations before them.

2.

In the Properties panel, select one of the following line styles from the In line style menu
and/or Out line style menu in the Jazz Articulations group:
●

Straight

●

Wavy

●

Dashed
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NOTE
In line style is available when you select notes with smooth jazz articulations before them,
and Out line style is available when you select notes with smooth jazz articulations after
them. Both are available when you select notes with smooth jazz articulations on both sides.

RESULT
The line style of the selected smooth jazz articulations is changed.
TIP
●

You can reset jazz articulations back to their default line style by selecting them and
choosing Edit > Reset Appearance.

●

You can change the default line style of each smooth jazz articulation independently on the
Jazz Articulations page in Engrave > Engraving Options.

EXAMPLE

Doit smooth with straight line

Doit smooth with wavy line

Doit smooth with dashed line

RELATED LINKS
Changing the type/length of existing jazz articulations on page 970
Project-wide engraving options for jazz articulations on page 968
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265

Deleting jazz articulations
You can remove jazz articulations from notes after you have input them. However, because jazz
articulations are considered an intrinsic part of notes rather than a separate item, you must
select and delete them differently from other items.
PROCEDURE
1.

In Write mode, select the notes from which you want to remove jazz articulations.

2.

In the Ornaments panel, click Remove in the Jazz section.

RESULT
All jazz articulations are removed from the selected notes.
RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, guitar bends, and jazz
articulations on page 265
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Page numbers are used to give each page a unique number, and indicate its position relative to
other pages. Just as in newspapers and books, musical scores and parts use page numbers to
make sure the music stays in the correct order.
Because you can have multiple flows in a single project in Dorico Pro, you do not need to change
page numbers manually in most cases. However, if you have separate files that together make
up a single piece, page number changes are necessary to make sure the page numbers continue
seamlessly from movement to movement.
In such cases, you can change the default page numbers. For example, if you want to have four
pages of front matter before the first page of music in the score, but you want the first page of
music in the score to be shown as page 1, you can insert a page number change on the first page
of music.
Page numbers are layout-specific in Dorico Pro, meaning you can change the page numbers in
each layout independently. For example, you can change the page numbers in the score but
show the default page numbers in the parts.
Page numbers in Dorico Pro use a text token to ensure the number is correct.
NOTE
You must have a text frame containing the page number token on every page on which you want
page numbers to be shown.
The default master pages contain text frames with page number tokens. You can change the
position of page number text frames in the master page editor, which changes the position of
page numbers on all pages that use that master page. You can also move page number text
frames on individual pages.
You can also change the type of number used to show page numbers in each layout. For
example, if you want the front matter to use Roman numerals but the music pages to use Arabic
numerals, you can change the type of number together with the page number.
RELATED LINKS
Page Number Change dialog on page 376
Inserting page number changes on page 375
Page format changes on page 372
Removing page number changes on page 377
Inputting frames on page 386
Text tokens on page 396

Moving page numbers in master pages
In order to change where page numbers are shown, you must move the text frames that contain
page numbers. The most efficient way to do this is to move the text frames containing page
numbers in master page formats.
PROCEDURE
1.

In Engrave mode, double-click a master page pair whose page number position you want to
change in the Master Pages section of the Pages panel.
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2.

In the master page editor, select the text frames that contain page numbers.

3.

Move the text frames in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●
4.

Click and drag them in any direction.

Click Apply, then Close.

RESULT
The selected text frames are moved.
TIP
When you move text frames, values for Left, Top, Right, and Bottom in the Frames group of the
Properties panel are changed to reflect the distance of the corresponding edge of the frame
from the page margin, but the values are only visible if the corresponding constraint is locked.
You can also use these properties to move text frames by changing the values in the value fields.
●

Right/Left move the right/left edges of frames horizontally.

●

Top/Bottom move the top/bottom edges of frames vertically.

You can lock/unlock constraints for each text frame in the Frames section of the Formatting
panel.

RELATED LINKS
Frame constraints on page 406
Master pages on page 361

Page number paragraph styles
The paragraph style for page numbers controls all aspects of their appearance, including their
font, size, and horizontal alignment. You can edit the existing page number paragraph style, and
create additional page number paragraph styles, in the Paragraph Styles dialog.
●

You can open the Paragraph Styles dialog in Engrave mode by choosing Engrave >
Paragraph Styles.

Dorico Pro offers a single paragraph style for page numbers by default, but you can create other
paragraph styles for page numbers. For example, if you want page numbers to appear bold and
centered at the tops of pages in full score layouts but appear italic and on the outer edges of
pages in part layouts, you can create a new paragraph style based on the existing Page Number
paragraph style, but rename it and change the settings.
RELATED LINKS
Paragraph Styles dialog on page 410
Text editor options in Engrave mode on page 415
Changing the paragraph style of text on page 417
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Changing the page number numeral style
Page numbers can appear as Arabic or Roman numerals. You can change the numeral style of
page numbers in each layout independently.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts whose page number numeral style you want to change.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Page Numbers section, select one of the following options from the Use menu:

5.

●

Number

●

Roman numeral

Click Apply, then Close.

RESULT
The page number numeral style is changed in the selected layouts.

Changing the page number numeral style for individual pages
Page numbers can appear as Arabic or Roman numerals. You can change the numeral style for
individual page numbers.
PROCEDURE
1.

In Engrave mode, in the music area, open the layout whose page number numeral style you
want to change.

2.

In the Pages section of the Pages panel, select a page.

3.

Open the Page Number Change dialog in any of the following ways:
●

Right-click in the Pages section and choose Insert Page Number Change from the
context menu.

●

Click Insert Page Number Change.

4.

In the Page Number Change dialog, enter the number of the page from which you want to
change the page number numeral style in the From page field.

5.

Select the numeral style you want from the following options for Sequence type:

6.

●

Number

●

Roman numeral

Click OK to save your changes and close the dialog.

RESULT
The page number numeral style is changed until the next page number change or the end of the
project, whichever comes first.
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RELATED LINKS
Inserting page number changes on page 375

Hiding/Showing page numbers
You can hide/show page numbers in each layout independently, including specifying whether to
hide/show a page number on the first page. For example, you can show page numbers on every
page in the score but hide page numbers on the first page in the parts.
NOTE
To show page numbers, there must be a text frame containing the page number token on the
page. The default master page formats for first pages do not contain text frames containing
page number tokens, so you must add these if you want to show page numbers on first pages in
your project that use the default master page formats.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show page numbers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Page Setup in the page list.

4.

In the Page Numbers section, select one of the following options from the Visibility menu:

5.

●

Always shown

●

Always hidden

●

Not on first page

Click Apply, then Close.

RESULT
●

If you select Always shown, page numbers are shown on all pages that have a text frame
containing the page number token in the selected layouts.

●

If you select Always hidden, page numbers are hidden on all pages in the selected layouts,
including on pages that have a text frame containing the page number token.

●

If you select Not on first page, page numbers are hidden on the first page in the selected
layouts, but shown on all other pages that have a text frame containing the page number
token.

NOTE
Your per-layout setting for whether page numbers are hidden/shown above flow headings
affects whether page numbers are shown on pages where they are higher on the page than flow
headings.

RELATED LINKS
Page Number Change dialog on page 376
Inserting page number changes on page 375
Inputting frames on page 386
Flow headings on page 381
Hiding/Showing information in running headers above flow headings on page 447

975
Dorico Pro 3.1.10

Page numbers
Hiding/Showing page numbers

Hiding/Showing page numbers on individual pages
You can change when page numbers are shown on individual pages, independently of your
settings for showing page numbers in each layout.
NOTE
To show page numbers, there must be a text frame containing the page number token on the
page. The default master page formats for first pages do not contain text frames containing
page number tokens, so you must add these if you want to show page numbers on first pages in
your project that use the default master page formats.

PROCEDURE
1.

In the music area, open the layout in which you want to hide/show page numbers.

2.

In the Pages section of the Pages panel, select a page.

3.

Open the Page Number Change dialog in any of the following ways:
●

Right-click in the Pages section and choose Insert Page Number Change from the
context menu.

●

Click Insert Page Number Change.

4.

In the From page field, enter the number of the page from which you want to hide/show
page numbers.

5.

Optional: Change the value for First page number.
First page number is 1 by default. If you do not want to change the page number together
with changing the visibility of page numbers, enter the existing page number in this field.

6.

7.

Select one of the following options from the Visibility menu:
●

Always shown

●

Always hidden

●

Not on first page

Click OK to save your changes and close the dialog.

RESULT
The visibility of page numbers is changed in the layout currently open in the music area, from the
page number specified until the next page number change with a different setting or the end of
the project, whichever comes first.
EXAMPLE
If you want to see page numbers up to page 3 but hide page numbers from page 4, enter 4 for
From page, enter 4 for First page number, and select Always hidden for Visibility.
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Harp pedaling is a broad term that covers the specific requirements for notating music for harps.
This primarily involves harp pedal diagrams, which are often necessary due to the way in which
modern concert harps change their tuning.

A passage with a full harp pedal diagram at the start and two subsequent partial pedal changes

Harps have seven strings in each octave, one for each diatonic pitch C-B, unlike pianos, which
have twelve keys in each octave, one for each semitone degree between C-B. Therefore, harps
have a mechanical action to change their tuning that includes seven pedals, with each pedal
controlling the pitch of the corresponding note in all octaves. These pedals are organized into
two groups, one for each foot: three pedals for the left foot and four pedals for the right foot.
Each harp pedal has three possible positions:
1

Flat or highest position: lowers the pitch of the corresponding note by a semitone

2

Natural or middle position

3

Sharp or lowest position: raises the pitch of the corresponding note by a semitone

There are different ways to notate the pedal settings required for a piece of music or a passage
within a piece. In Dorico Pro, you can show harp pedaling in the following ways:
Diagram

Indicates the physical positions of the seven pedals. The vertical line represents the
split between left-foot and right-foot pedals and the horizontal line represents the
natural position.
●

Pedals below the horizontal line indicate sharpened notes.

●

Pedals above the horizontal line indicate flattened notes.

Note Names

Indicates the required accidentals for the seven diatonic pitches, arranged in two lines.
Right-foot pedals are shown on top and left-foot pedals are shown below.
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Any pitches that you input that do not fit with the current harp pedal diagram are considered out
of range, and appear red when colors are shown for notes that are out of range. If you do not
input any harp pedaling, Dorico Pro assumes all harp pedals are in their natural setting, as they
would be for C major.
In Dorico Pro, you can input harp pedal diagrams using the playing techniques popover and you
can automatically generate accurate harp pedal diagrams based on an entire flow or a specific
passage of music. However, you can only input and show harp pedal diagrams on staves
belonging to harp instruments; if you copy material from harp staves to other instruments, harp
pedaling is automatically removed.
By default, harp pedaling is hidden in full score/custom score layouts and shown in part layouts.
In layouts where harp pedaling is hidden, harp pedal diagrams are indicated by signposts. You
can hide/show harp pedaling in each layout independently and hide individual harp pedal
diagrams in layouts where harp pedaling is shown. You can also determine when to show partial
harp pedaling, such as when only a single pedal must be changed at one time.
Harp pedal diagrams in Dorico Pro affect the pitches played back in glissando lines.
RELATED LINKS
Partial harp pedaling on page 984
Inputting harp pedal diagrams on page 286
Hiding/Showing harp pedaling in layouts on page 979
Hiding harp pedal diagrams individually on page 980
Calculating harp pedal diagrams based on existing music on page 287
Hiding/Showing colors for notes out range on page 905
Glissando lines in playback on page 956

Project-wide engraving options for harp pedaling
You can find options for the project-wide appearance and position of harp pedal diagrams on the
Harp Pedaling page in Engrave > Engraving Options.
The options on the Harp Pedaling page allow you to change the size of lines, pedal indicators,
and gaps in harp pedal diagrams, the order of left-side pedals when using note names, and the
maximum number of pedal changes below which partial pedal diagrams can be shown. You can
also change the default position of harp pedal diagrams, including setting precise values for the
gaps between harp pedal diagrams and the staff or other objects.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
RELATED LINKS
Engraving Options dialog on page 359

Changing the appearance of harp pedal diagrams
Harp pedaling can be shown as a diagram or using note names. You can change the appearance
of harp pedal diagrams individually, independently of your project-wide setting.
PREREQUISITE
Harp pedaling is shown in the current layout.
PROCEDURE
1.

Select the harp pedal diagrams whose appearance you want to change. You can do this in
Write mode and Engrave mode.

978
Dorico Pro 3.1.10

Harp pedaling
Hiding/Showing harp pedaling in layouts
2.

In the Properties panel, activate Appearance in the Harp Pedals group.

3.

Choose one of the following options:
●

Diagram

●

Note Names

RESULT
The appearance of the selected harp pedal diagrams is changed in the current layout.
TIP
You can change the default appearance of harp pedaling in each layout independently in the
Harp Pedaling section of the Players page in Setup > Layout Options.
EXAMPLE

Harp pedaling shown as a diagram
Harp pedaling shown using note names

RELATED LINKS
Partial harp pedaling on page 984
Inputting harp pedal diagrams on page 286
Calculating harp pedal diagrams based on existing music on page 287

Hiding/Showing harp pedaling in layouts
You can input and calculate harp pedaling in any layout, but by default harp pedaling is not
shown in full score layouts, as they are usually only useful for the performer. You can hide/show
harp pedaling in each layout in your project independently of other layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show harp pedaling.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Harp Pedaling section, activate/deactivate Show harp pedaling.

5.

Click Apply, then Close.

RESULT
Harp pedaling is shown in the selected layouts when the checkbox is activated, and hidden when
the checkbox is deactivated.
In layouts where harp pedaling is hidden, harp pedal diagrams are indicated by signposts.
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NOTE
●

You can hide individual harp pedal diagrams in layouts where harp pedaling is shown, but
you cannot show individual harp pedal diagrams in layouts where harp pedaling is hidden.

●

You can hide/show harp pedaling signposts by choosing View > Signposts > Harp Pedals.
Harp pedaling signposts are shown when a tick appears beside Harp Pedals in the menu,
and hidden when no tick appears.

Hiding harp pedal diagrams individually
You can hide individual harp pedal diagrams in layouts in which harp pedaling is shown.
PREREQUISITE
Harp pedaling is shown in the current layout.
PROCEDURE
1.

In the music area, open the layout in which you want to hide/show individual harp pedal
diagrams.

2.

Select the harp pedal diagrams you want to hide. You can do this in Write mode and Engrave
mode.

3.

In the Properties panel, activate Hide in the Harp Pedals group.

RESULT
The selected harp pedal diagrams are hidden when Hide is activated. Signposts are shown at the
position of each hidden harp pedal diagram. However, signposts are not printed by default.
Deactivating Hide shows the selected harp pedal diagrams again.

Hiding/Showing borders on harp pedal diagrams
You can hide/show borders on individual note name harp pedal diagrams, independently of your
project-wide setting. For example, on systems with very tight vertical spacing, hiding borders on
harp pedal diagrams can give you a little extra space.
NOTE
These steps only apply to harp pedal diagrams using note names.
PREREQUISITE
Harp pedaling is shown in the current layout.
PROCEDURE
1.

Select the note name harp pedal diagrams on which you want to hide/show borders. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Border in the Harp Pedals group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Borders are shown on the selected note name harp pedal diagrams when the checkbox is
activated, and hidden when the checkbox is deactivated.
When the property is deactivated, the selected harp pedal diagrams follow your project-wide
setting for hiding/showing borders.
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TIP
You can hide/show borders on all note name harp pedal diagrams project-wide in the Note
Names subsection of the Harp Pedaling page in Engrave > Engraving Options.
EXAMPLE

Note name harp pedal diagram with border hidden

Note name harp pedal diagram with border shown

Changing the thickness of harp pedal diagram borders
You can change the thickness of borders on individual note name harp pedal diagrams,
independently of your project-wide setting.
NOTE
These steps only apply to harp pedal diagrams using note names.
PREREQUISITE
●

Harp pedaling is shown in the current layout.

●

Graphic Editing is selected in the Engrave toolbox.

PROCEDURE
1.

In Engrave mode, select the note name harp pedal diagrams whose border thickness you
want to change.

2.

In the Properties panel, activate Border thickness in the Harp Pedals group.

3.

Change the value in the value field.

RESULT
The thickness of borders on the selected harp pedal diagrams is changed.
TIP
You can change the default border thickness for all harp pedal diagrams project-wide in the Note
Names subsection of the Harp Pedaling page in Engrave > Engraving Options.
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Changing the padding around harp pedal diagrams
You can change the padding around harp pedal diagrams individually, and for each edge
independently. This affects the distance between harp pedal diagrams and erased backgrounds
and borders.
PREREQUISITE
●

Harp pedaling is shown in the current layout.

●

Graphic Editing is selected in the Engrave toolbox.

PROCEDURE
1.

In Engrave mode, select the harp pedal diagrams whose padding you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Harp Pedals group:

3.

●

Left padding

●

Right padding

●

Top padding

●

Bottom padding

Change the values in the value fields.

RESULT
The padding around the selected harp pedal diagrams is changed. Increasing the values
increases the padding, decreasing the values decreases the padding.
TIP
You can change the default padding around all harp pedal diagrams project-wide in the Note
Names subsection of the Harp Pedaling page in Engrave > Engraving Options. However, this
does not allow you to change the padding of each edge independently.

Positions of harp pedal diagrams
By default, harp pedal diagrams are centered vertically between the two staves usually shown for
harps.
You can move harp pedal diagrams to different rhythmic positions in Write mode. They are
positioned by default according to your settings in Engraving Options.
You can move harp pedal diagrams graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all harp pedal diagrams project-wide on the Harp
Pedaling page in Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for harp pedaling on page 978
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Moving harp pedal diagrams rhythmically
You can move harp pedal diagrams to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the harp pedal diagrams or the signposts of harp pedal diagrams that
you want to move.
NOTE
When using the mouse, you can only move one harp pedal diagram rhythmically at a time.

2.

Move the harp pedal diagrams according to the current rhythmic grid resolution in any of
the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the harp pedal diagram to the right/left.

RESULT
The selected harp pedal diagrams are moved to new rhythmic positions.
NOTE
If moving harp pedal diagrams means some notes no longer fit with the current harp pedal
diagram and colors are shown for notes out of range, these notes appear red.

RELATED LINKS
Hiding/Showing colors for notes out range on page 905

Moving harp pedal diagrams graphically
You can move harp pedal diagrams graphically without changing the rhythmic positions to which
they apply.
PREREQUISITE
●

Harp pedaling is shown in the current layout.

●

Graphic Editing is selected in the Engrave toolbox.

PROCEDURE
1.

In Engrave mode, select the harp pedal diagrams you want to move.

2.

Move the harp pedal diagrams in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.
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RESULT
The selected harp pedal diagrams are moved to new graphical positions.
TIP
Offset in the Harp Pedals group of the Properties panel is activated automatically when you
move harp pedal diagrams.
●

Offset X moves harp pedal diagrams horizontally.

●

Offset Y moves harp pedal diagrams vertically.

You can also use this property to move harp pedal diagrams by changing the values in the value
fields.
Deactivating the property resets the selected harp pedal diagrams to their default positions.

Partial harp pedaling
Partial harp pedal diagrams only show the notes whose pedal setting must change at that
position, rather than showing the required settings for all pedals. This can make those changes
immediately clear to the performer, as they have fewer pedals to read.

Partial pedal diagrams for a sequence containing several quick pedal changes

You can allow partial harp pedaling for individual harp pedal diagrams and you can set a
maximum threshold of pedal changes at a single position, above which all harp pedal diagrams
must show all pedals. This is because performers are used to the pattern of note names in
complete harp pedal diagrams, and if there are many changes in a partial harp pedal diagram,
this can be harder to read than a complete one.
By default, Dorico Pro shows notes in partial harp pedal diagrams on two lines with right-foot
pedals on top and left-foot pedals below.
NOTE
Only harp pedal diagrams using note names can be shown as partial.

RELATED LINKS
Inputting harp pedal diagrams on page 286

Allowing/Disallowing partial harp pedaling
You can allow/disallow partial harp pedaling for individual note name harp pedal diagrams,
independently of your project-wide settings. For example, if your default setting is to allow
partial harp pedaling for up to two pedal changes, but you want to show one harp pedal diagram
with three pedal changes as partial.
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NOTE
●

These steps only apply to harp pedal diagrams using note names.

●

Harp pedal diagrams positioned at the very beginning of a flow can only appear as full harp
pedal diagrams.

PREREQUISITE
Harp pedaling is shown in the current layout.
PROCEDURE
1.

Select the note name harp pedal diagrams for which you want to allow/disallow partial harp
pedaling. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Partial pedaling in the Harp Pedals group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Partial harp pedaling is allowed for the selected note name harp pedal diagrams when the
checkbox is activated, and disallowed when the checkbox is deactivated.
When the property is deactivated, the selected harp pedal diagrams follow your project-wide
settings for partial harp pedaling.
TIP
You can allow/disallow partial pedal diagrams project-wide, and change the default pedal change
threshold below which partial harp pedal diagrams are allowed, in the Note Names subsection
of the Harp Pedaling page in Engrave > Engraving Options.
EXAMPLE

Harp pedal diagram showing all pedals

Partial harp pedal diagram

RELATED LINKS
Hiding/Showing harp pedaling in layouts on page 979

985
Dorico Pro 3.1.10

Pedal lines
Pedal lines indicate to performers which piano pedals to use, and can also give performance
instructions, such as how far down to depress the pedals and when to lift the pedal to clear the
resonance.
Most pianos have either two or three pedals. These pedals are:
Sustain pedal
The sustain pedal controls the dampers on the piano strings, which is why it is also
known as the “damper pedal”. It is also the most commonly used pedal. Depressing the
sustain pedal removes the dampers, allowing the strings to resonate longer. Sustain
pedals are usually on the right.

An example sustain pedal line

Sostenuto pedal
The sostenuto pedal only allows the strings of the notes currently depressed on the
keyboard to resonate. It is also known as the “middle pedal” as it is usually in the
middle of the other pedals.

An example sostenuto pedal line

Una corda pedal
The una corda pedal shifts the action inside the piano so that the hammers hit fewer
strings than normal. Historically, this caused hammers only to hit one string, not the
usual three, which is where the name comes from. Because this reduces the volume
and impact of the sound, it is also known as the “soft pedal”.

An example una corda pedal line

Dorico Pro offers comprehensive notational and playback support for piano pedal lines. You can
create pedaling for the sustain, sostenuto, and una corda pedals, with support for modern sustain
pedaling techniques, including changing the pedal level over the course of a single pedal
instruction.
In Dorico Pro, pedal lines are considered playing techniques because they alter the sound
produced by the instrument. Therefore, pedal lines are included in the Playing Techniques panel
in Write mode and you can input them using the playing techniques popover. However, pedal
lines have additional, unique requirements that do not apply to other playing techniques, such as
retakes, pedal level changes, start signs, end signs, and continuation lines.
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RELATED LINKS
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277
Pedal lines in playback on page 1005
Pedal line start signs, hooks, and continuation lines on page 998
Text pedal line signs on page 1003
Lines on page 1033
Playing technique continuation lines on page 1015

Sustain pedal retakes and pedal level changes
Pedal retakes indicate where a player should lift the sustain pedal, which dampens the piano’s
strings and clears the resonance, before depressing the pedal again. Pedal level changes indicate
a change to how far the pedal is depressed.
Dorico Pro provides clear representations of pedal retakes and level changes.
NOTE
You can only add pedal retakes and level changes to sustain pedal lines.
EXAMPLE

Example pedal line with retake and level changes

1

Ped. glyph

2

Retake

3

One quarter depressed

4

Half depressed

5

Three quarters depressed

6

Fully depressed

7

Line end hook

RELATED LINKS
Removing retakes and pedal level changes on page 992
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277

Sustain pedal lines in Engrave mode
When you select sustain pedal lines in Engrave mode, handles appear at the start/end of each
pedal line, and on any retakes or pedal level changes on the line. These handles allow you to
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move each part of the pedal line independently, and to change the pedal levels at the start, end,
and at each retake or pedal level change.

A sustain pedal with a retake in Engrave mode

There are two handles for the start of the pedal line, three for retakes and pedal level changes,
and three for the end of the pedal line.
NOTE
Sostenuto and una corda pedal lines only have a single handle at their start/end, which allows you
to move their start/end positions graphically, but only horizontally.
You can move each handle with the keyboard, with the mouse, and using the Properties panel.
Each handle corresponds to a property in either the Pedal Lines group or the Pedal Line
Retakes group of the Properties panel.
NOTE
Pedal levels cannot be lower than 0 or higher than 1.
●

1 is fully depressed.

●

0 is not depressed.

Start of sustain pedal lines
There are two handles at the start of pedal lines.

●

The left handle moves the start point of the pedal line. You can move this handle to the right/
left.

●

The right handle changes the start pedal level of the pedal line. You can move this handle
upwards/downwards. This changes the angle of the pedal continuation line in relation to the
next retake or pedal level change, or the end of the pedal line.

Pedal level changes and retakes

●

The left handle changes the pedal level before the retake. You can move this handle
upwards/downwards.

●

The right handle changes the pedal level after the retake. You can move this handle
upwards/downwards.

●

The bottom handle corresponds to the position of the pedal level change or retake. You can
move this handle to the right/left.
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End of sustain pedal lines

●

The top handle changes the hook length. You can move this handle upwards/downwards.

●

The right handle changes the pedal level at the end of the pedal line. You can move this
handle upwards/downwards.

●

The bottom handle moves the end point of the pedal line. You can move this handle to the
right/left.

RELATED LINKS
Moving pedal lines graphically on page 994

Changing the type of pedal line retakes
You can change existing retakes on sustain pedal lines to pedal level changes and vice versa.
For example, if you do not want the pedal to be released completely between the old and new
levels, change the type to Change Level instead of Retake.
PROCEDURE
1.

In Engrave mode, select the retake or pedal level change whose type you want to change.

2.

In the Properties panel, activate Retake type in the Pedal Line Retakes group.

3.

Choose the type you want from the following options:
●

Retake

●

Change Level

RESULT
The type of pedal line retake is changed.
NOTE
The appearance of the new type of pedal line retake depends on the pedal levels already set on
each side. For example, a retake notch is only shown on one side of the retake if the pedal level
on the other side is set to 0.

Changing the start level of pedal lines
You can change the start level of individual sustain pedal lines by moving start level handles
upwards/downwards.
PROCEDURE
1.

In Engrave mode, select the right handles on the start signs whose start pedal levels you
want to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the start level handles in any of the following ways:
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●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.

●

Press Ctrl/Cmd-Alt/Opt-Up Arrow to snap the level to 0 (not depressed).

●

Press Ctrl/Cmd-Alt/Opt-Down Arrow to snap the level to 1 (fully depressed).

●

Click and drag the handles upwards/downwards to the level you want.

RESULT
The start level of the selected pedal line is changed.
TIP
Start level in the Pedal Lines group of the Properties panel is activated when you change the
start level of pedal lines.
You can also use this property to change the start level of pedal lines by changing the value in
the value field. For example, 1 is fully depressed and 0 is not depressed.
Deactivating the property resets the selected pedal lines to their default start level.

RELATED LINKS
Sustain pedal lines in Engrave mode on page 987

Changing pedal levels at retakes and pedal level changes
You can change both the start level and end level of individual sustain pedal lines at retakes and
pedal level changes by moving the corresponding handles upwards/downwards.
The end level is the pedal level immediately before the retake or pedal level change occurs, and
the start level is the pedal level immediately after the retake or pedal level change occurs.
PROCEDURE
1.

In Engrave mode, select one of the handles on the retakes or pedal level changes whose
start/end pedal level you want to change.
●

Select the left handle to change the end pedal level.

●

Select the right handle to change the start pedal level.

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

3.

Move the start level handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.

●

Press Ctrl/Cmd-Alt/Opt-Up Arrow to snap the level to 0 (not depressed).

●

Press Ctrl/Cmd-Alt/Opt-Down Arrow to snap the level to 1 (fully depressed).

●

Click and drag the handles upwards/downwards to the level you want.

Optional: Repeat steps 1 and 2 for any other handles.

RESULT
The pedal levels of the selected retakes or pedal level changes are changed.
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TIP
The following properties in the Pedal Lines group of the Properties panel are activated when you
change the corresponding level at retakes and pedal level changes:
●

Start level at retake

●

End level at retake

You can also use these properties to change the corresponding level at retakes and pedal level
changes by changing the values in the value fields. For example, 1 is fully depressed and 0 is not
depressed.
Deactivating the properties resets the selected pedal lines to their default start/end levels.

RELATED LINKS
Sustain pedal lines in Engrave mode on page 987

Changing the end level of pedal lines
You can change the end level of individual sustain pedal lines by moving end level handles
upwards/downwards.
NOTE
You can only change the end level of pedal lines that have a hook as their end sign.

PROCEDURE
1.

In Engrave mode, select the right handles on the end hooks whose end pedal levels you
want to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the end level handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.

●

Press Ctrl/Cmd-Alt/Opt-Up Arrow to snap the level to 0 (not depressed).

●

Press Ctrl/Cmd-Alt/Opt-Down Arrow to snap the level to 1 (fully depressed).

●

Click and drag the handles upwards/downwards to the level you want.

RESULT
The end levels of the selected pedal lines are changed.
TIP
End level in the Pedal Lines group of the Properties panel is activated when you change the end
level of pedal lines.
You can also use this property to change the end level of pedal lines by changing the value in the
value field. For example, 1 is fully depressed and 0 is not depressed.
Deactivating the property resets the selected pedal lines to their default end level.
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RELATED LINKS
Sustain pedal lines in Engrave mode on page 987

Removing retakes and pedal level changes
You can remove pedal retakes and level changes without deleting the sustain pedal line or
changing its rhythmic position.
PROCEDURE
1.

In Write mode, select the note on the staff and at the rhythmic position of the retake or
pedal level change you want to remove.
NOTE
You can only remove one retake or pedal level change at a time.

2.

Remove the retake or pedal level change in any of the following ways:
●

Open the playing techniques popover, enter nonotch into the popover, then press
Return .
NOTE
nonotch must be spelled as one word, without a space.

●

Choose Edit > Pedal Lines > Remove Retake. You can also choose this option from the
context menu.

RESULT
The selected retake or pedal level change is removed, and the pedal line returns to its previous
level as set by either the start of the pedal line, or the retake or pedal level change immediately
preceding the one you removed.
RELATED LINKS
Playing techniques popover on page 277

Positions of pedal lines
The default placement of pedal lines is below the bottom staff, even if there are only notes in the
upper staff for the right hand. They are placed outside all other notations, including octave lines,
slurs, and articulations.
If one pedal is used, it is placed as close to the bottom of the staff as possible, while remaining
outside of all other notations.
If multiple pedals are used simultaneously, they are organized below the bottom of the staff as
follows:
1.

Sustain pedal: closest to the staff

2.

Sostenuto pedal: below the sustain pedal line

3.

Una corda pedal: furthest from the staff

The beginning of the glyph/text that indicates the start position of pedal lines aligns with the
note to which it applies. If you are using a line end hook to indicate the end of pedal lines, the
hook aligns with the note or rhythmic position to which it applies.
You can move pedal lines to different rhythmic positions in Write mode. They are positioned by
default according to your settings in Engraving Options.
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NOTE
You cannot move retakes or pedal level changes rhythmically. You must remove them and input
a new retake or pedal level change at the position you want.
You can move pedal lines graphically in Engrave mode. However, this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all pedal lines project-wide on the Pedal Lines page in
Engrave > Engraving Options. For example, you can change values for the minimum distances
between pedal lines and staves, pedal lines and other pedal lines, and the position of pedal lines
relative to noteheads and grace notes.
RELATED LINKS
Project-wide engraving options for pedal lines on page 998
Text pedal line signs on page 1003
Pedal line start signs, hooks, and continuation lines on page 998
Moving pedal lines graphically on page 994
Lengthening/Shortening pedal lines on page 996
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277

Moving pedal lines rhythmically
You can move pedal lines to new rhythmic positions after they have been input. Any retakes or
pedal level changes on the pedal lines are also moved.
NOTE
If you want to move retakes or pedal level changes independently of the pedal line, you must
first remove them from their original positions and input new retakes or pedal level changes at
the new positions.

PROCEDURE
1.

In Write mode, select the pedal lines you want to move.
NOTE
When using the mouse, you can only move one pedal line rhythmically at a time.

2.

Move the pedal lines in any of the following ways:
●

To move a single pedal line to the next notehead on the staff, press Alt/OptRight Arrow .

●

To move a single pedal line to the previous notehead on the staff, press Alt/OptLeft Arrow .

●

To move them to the right according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Right Arrow .

●

To move them to the left according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Left Arrow .
NOTE
You can only move pedal lines according to the current rhythmic grid resolution when
multiple pedal lines are selected.
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●

Click and drag the pedal line to the right/left.

RESULT
The selected pedal lines are moved to new rhythmic positions.
NOTE
Pedal lines can only be moved along staves. If you want to move a pedal line across staves, you
must delete the pedal line and input a new pedal line on the other staff.

RELATED LINKS
Lengthening/Shortening pedal lines on page 996
Sustain pedal lines in Engrave mode on page 987
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277

Moving pedal lines graphically
You can move pedal lines, retakes, and pedal level changes graphically without changing the
rhythmic positions to which they apply. You can also move the start/end of pedal lines
independently, meaning you can lengthen/shorten them graphically.
NOTE
You can only change the angle of pedal lines by changing the level.

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Whole pedal lines

●

Individual start/end handles on pedal lines

●

Individual bottom handles on retakes and pedal level changes

NOTE

2.

●

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

●

You can move multiple pedal lines together, but only upwards/downwards.

●

You can move handles on multiple pedal lines together, but only to the right/left.

Move the pedal lines or handles in any of the following ways:
●

To move pedal lines and handles to the right, press Alt/Opt-Right Arrow .

●

To move pedal lines and handles to the left, press Alt/Opt-Left Arrow .

●

To move whole pedal lines upwards, press Alt/Opt-Up Arrow .

●

To move whole pedal lines downwards, press Alt/Opt-Down Arrow .
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.
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RESULT
The selected pedal lines or handles are moved to new graphical positions.
TIP
The following properties in the Pedal Lines group of the Properties panel are activated
automatically when you move pedal lines in the corresponding directions:
●

Start X offset moves the start of pedal lines horizontally.

●

End X offset moves the end of pedal lines horizontally.

●

Y offset moves whole pedal lines vertically.

X offset in the Pedal Line Retakes group of the Properties panel is activated automatically when
you move pedal retakes or pedal level changes horizontally.
For example, if you move a whole pedal line to the right, both handles are moved, so Start X
offset and End X offset are both activated. You can also use all of these properties to move
pedal lines, retakes, and pedal level changes, and lengthen/shorten pedal lines graphically, by
changing the values in the value fields.
Deactivating the properties resets the selected pedal lines to their default positions.

RELATED LINKS
Lengthening/Shortening pedal lines on page 996
Sustain pedal lines in Engrave mode on page 987

Changing the position of pedal lines relative to grace notes
You can change the start/end positions of individual pedal lines relative to grace notes,
independently of your project-wide settings.
PROCEDURE
1.

Select the pedal lines whose position relative to grace notes you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate any of the following properties in the Pedal Lines group:

3.

●

Starts before grace notes

●

Ends before grace notes

Activate/Deactivate the corresponding checkboxes.

RESULT
When the checkboxes are activated, the corresponding parts of the selected pedal lines are
positioned before grace notes.
When the checkboxes are deactivated, the corresponding parts of the selected pedal lines are
positioned after grace notes.
TIP
●

You can adjust the precise position of pedal lines in further detail in Engrave mode.

●

You can change the position of all pedal lines relative to grace notes project-wide on the
Pedal Lines page in Engrave > Engraving Options.
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EXAMPLE

Pedal line starting/ending before grace notes

Pedal line starting/ending after grace notes

RELATED LINKS
Project-wide engraving options for pedal lines on page 998
Moving pedal lines graphically on page 994

Lengthening/Shortening pedal lines
You can lengthen/shorten pedal lines rhythmically after they have been input.
PROCEDURE
1.

In Write mode, select the pedal lines you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one pedal line at a time.

2.

Lengthen/Shorten the pedal lines in any of the following ways:
●

To snap the end of a single pedal line to the next notehead, press Ctrl/Cmd-Shift-Alt/
Opt-Right Arrow .

●

To snap the end of a single pedal line to the previous notehead, press Ctrl/Cmd-ShiftAlt/Opt-Left Arrow .

●

To lengthen them by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten them by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .
NOTE

●

●

You can only lengthen/shorten pedal lines according to the current rhythmic grid
resolution when multiple pedal lines are selected.

●

When using the keyboard, you can only move the end of pedal lines. You can move
the start of pedal lines by moving the whole line, or by clicking and dragging the
start handle.

Click and drag the circular handle at the start/end to the right/left.

RESULT
Single pedal lines are lengthened/shortened according to the current rhythmic grid resolution or
to the next/previous notehead, whichever is closer.
Multiple pedal lines are lengthened/shortened according to the current rhythmic grid resolution.
TIP
You can move pedal lines graphically in Engrave mode, including changing their graphical length.
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RELATED LINKS
Positions of pedal lines on page 992
Moving pedal lines rhythmically on page 993
Moving pedal lines graphically on page 994

Splitting pedal lines
You can split sustain pedal lines at any rhythmic position with an existing item along their length
into two separate pedal lines.
NOTE
These steps only apply to sustain pedal lines.

PROCEDURE
1.

Select an item on the staff and at the rhythmic position where you want to split the sustain
pedal line. You can do this in Write mode and Engrave mode.
NOTE
You can only split one pedal line at a time.

2.

Choose Edit > Pedal Lines > Split Pedal Line. You can also choose this option from the
context menu.

RESULT
The pedal line on the selected staff is split at the selected rhythmic position.
AFTER COMPLETING THIS TASK
You can move, lengthen/shorten, and edit both pedal lines independently.
RELATED LINKS
Moving pedal lines rhythmically on page 993
Pedal line start signs, hooks, and continuation lines on page 998
Text pedal line signs on page 1003

Merging pedal lines
You can merge existing sustain pedal lines together, for example, if you want to fill in a gap
between two sustain pedal lines.
NOTE
These steps only apply to sustain pedal lines.

PROCEDURE
1.

Select the sustain pedal lines on the same staff that you want to merge together. You can do
this in Write mode and Engrave mode.
NOTE
You can only merge pedal lines on one staff at a time.

2.

Choose Edit > Pedal Lines > Merge Pedal Lines. You can also choose this option from the
context menu.
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RESULT
The selected pedal lines are merged together into a single pedal line. If there were gaps between
them, a continuation line is automatically shown across them.
EXAMPLE

Two separate pedal lines

Two pedal lines merged into one

AFTER COMPLETING THIS TASK
You can input retakes and pedal level changes, for example, if you want to show a retake at the
position where previously one of the pedal lines started.
RELATED LINKS
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277

Project-wide engraving options for pedal lines
You can find options for the project-wide appearance and position of pedal lines on the Pedal
Lines page in Engrave > Engraving Options.
The options on the Pedal Lines page allow you to change the symbol shown at the start of each
type of pedal line, the appearance of pedal line symbols on subsequent systems, the appearance
of pedal continuation lines, and the width of retake notches. You can also set precise values for
the gaps between pedal lines and the staff or other objects and change the default position of
pedal lines, start signs, retakes, and pedal line ends.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Pedal line start signs, hooks, and continuation lines
Pedal lines normally comprise a start sign, a continuation line, and an end hook. This indicates
clearly to performers where to depress each type of pedal, how long to keep it depressed, and
where to lift it.
In Dorico Pro, you can change the appearance of each part of pedal lines both individually and
for all pedal lines project-wide. For example, you can show all pedal lines with a glyph as their
start sign, but change the start sign of an individual pedal line to show text instead.
You can select whole pedal lines in Write mode and change most aspects of their appearance
according to the type of pedal line, such as their continuation line or start sign.
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For sustain pedals only, you can select each segment of a sustain pedal independently in Engrave
mode, and set different properties for each segment. Sustain pedal lines have independent
segments on each separate system on which they appear.
TIP
If you are changing the appearance of many pedal lines, it might be easier to change the
corresponding project-wide settings on the Pedal Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for pedal lines on page 998
Sustain pedal lines in Engrave mode on page 987

Changing the start sign appearance of pedal lines
You can change the appearance of the start of pedal lines individually, independently of your
project-wide settings. Pedal line start signs can be shown as variations of the traditional pedal
line glyph, other symbols, or text.
PROCEDURE
1.

Select the pedal lines whose start sign appearance you want to change. You can do this in
Write mode and Engrave mode.
NOTE
The pedal lines you select must be the same type, for example, only sustain pedal lines.

2.

In the Properties panel, activate Sign appearance in the Pedal Lines group.

3.

Select one of the options from the menu.
The options are different according to the type of pedal line selected.

RESULT
The start sign appearance of the selected pedal lines is changed.
TIP
●

Deactivating Sign appearance returns the selected pedal lines to your default setting for
start sign appearance.

●

You can change the default start sign appearance of all pedal lines project-wide on the Pedal
Lines page in Engrave > Engraving Options.

AFTER COMPLETING THIS TASK
If you selected a text sign appearance, you can edit the text shown.
RELATED LINKS
Project-wide engraving options for pedal lines on page 998
Editing pedal line start text on page 1004
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Changing the type of hook at the start/end of pedal lines
You can change the type of hook shown at the start/end of pedal lines individually.
NOTE
You can only change the start hook type of pedal lines that have a hook as their start sign, and
you can only change the end hook type of pedal lines that have a continuation line.

PROCEDURE
1.

Select the pedal lines whose hook type you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Pedal Lines group:

3.

●

Line start hook

●

Line end hook

Select one of the following options from each menu:
●

No Hook

●

Vertical Hook

●

Slant Hook

●

Inverse Hook

RESULT
The hook type at the start/end of the selected pedal lines is changed.
TIP
You can change the default appearance of all pedal lines project-wide on the Pedal Lines page in
Engrave > Engraving Options.

Lengthening/Shortening pedal line hooks
You can change the length of hooks shown at the start/end of pedal lines individually,
independently of each other and independently of your project-wide settings.
For example, if you have a pedal line with a hook at the start/end, you can make the end hook
longer without changing the length of the start hook.
NOTE
These steps only apply to pedal lines that have a hook as their start sign and/or end sign.

PROCEDURE
1.

In Engrave mode, select the top handle at the start/end of the pedal lines whose hooks you
want to lengthen/shorten.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.
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●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag them upwards/downwards.

RESULT
The length of the selected pedal line hooks is changed.
TIP
●

The following properties in the Pedal Lines group of the Properties panel are activated
automatically when you move the corresponding pedal line hook:
●

Start hook length changes the length of hooks at the start of pedal lines.

●

End hook length changes the length of hooks at the end of pedal lines.

You can also use these properties to lengthen/shorten pedal line hooks by changing the
values in the value fields.
Deactivating the properties resets the selected pedal lines to their default hook length.
●

You can change the default hook length for all pedal lines project-wide by changing the value
for Hook length in the Design section of the Pedal Lines page in Engrave > Engraving
Options. This value applies to hooks at the start/end of pedal lines.

Changing the continuation line type of pedal lines
You can change the type of continuation line used for the different types of pedal lines
individually, independently of your project-wide settings.
PROCEDURE
1.

Select the pedal lines whose continuation line type you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Continuation type in the Pedal Lines group.

3.

Select one of the following continuation types from the menu:
●

Line

●

Sign at End

●

Sign at End and Dashed Line

●

None

RESULT
The continuation line type of the selected pedal lines is changed.
TIP
You can change the continuation type for all pedal lines project-wide on the Pedal Lines page in
Engrave > Engraving Options. You can choose different continuation types for each pedal type,
for example, you can have a line for sustain pedal lines and just a sign at the end for una corda
pedal lines.
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Lengthening/Shortening gaps and dashes in pedal continuation lines
You can change the length of dashes and the gaps between dashes in individual dashed pedal
continuation lines, independently of your project-wide settings.
NOTE
These steps only apply to pedal lines with dashed continuation lines.

PROCEDURE
1.

In Engrave mode, select the pedal lines whose dashes you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Pedal Lines group.

3.

●

Dash length

●

Dash gap length

Change the values in the value fields.

RESULT
Increasing Dash length makes dashes in pedal continuation lines longer, decreasing the value
makes dashes shorter.
Increasing Dash gap length makes gaps between dashes in pedal continuation lines longer,
decreasing the value makes gaps shorter.
TIP
You can find options that change the default dash length and default gap length for all dashed
pedal continuation lines project-wide by clicking Advanced Options in the Design section of the
Pedal Lines page in Engrave > Engraving Options.

Changing the line width of pedal lines
You can change the thickness of continuation lines individually, independently of your projectwide settings.
PROCEDURE
1.

In Engrave mode, select the pedal lines whose continuation line thickness you want to
change.

2.

In the Properties panel, activate Line width in the Pedal Lines group.
The value resets to 0 automatically when you first activate the property.

3.

Change the value in the value field.

RESULT
Increasing Line width makes pedal continuation lines thicker, decreasing the value makes pedal
continuation lines thinner.
TIP
You can change the default thickness for all pedal continuation lines project-wide in the Design
section of the Pedal Lines page in Engrave > Engraving Options.
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Parenthesizing pedal line continuation signs
You can show individual pedal line continuation signs with/without parentheses, independently
of your project-wide setting. Pedal line continuation signs are shown by default at the start of
new systems when pedal lines continue across system/frame breaks.
PROCEDURE
1.

Select the pedal lines whose continuation sign appearance you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Show continuation sign in parentheses in the Pedal Lines
group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Continuation signs are shown with parentheses when the checkbox is activated, and without
parentheses when the checkbox is deactivated.
When the property is deactivated, pedal lines follow your project-wide setting.
TIP
You can change the default appearance of all pedal line continuation signs project-wide in the
Design section of the Pedal Lines page in Engrave > Engraving Options.

Text pedal line signs
All types of pedal lines can have text as their start signs, instead of glyphs or hooks. You can
override the text shown at the start of pedal lines that have text start signs, you can change the
continuation text shown at the start of new systems, and you can override the restorative text
shown at the end of una corda pedal lines.
You can change the design of all pedal lines project-wide according to their type in the Design
section of the Pedal Lines page in Engraving Options, and you can change the appearance of
individual pedal lines, independently of your project-wide settings.

Pedal lines that use a text indication rather than a symbol
For pedal lines such as una corda or sustain that have text for their start sign, such as Ped. Text,
rather than the more ornate symbol, you can override the text shown at the start of the pedal
line and replace it with your preferred performance direction.

Continuation sign/text
When pedal lines continue onto subsequent systems, a continuation sign/text is shown in
parentheses by default. If the pedal line is using text for their start sign, such as Ped. Text, rather
than a symbol, you can change the text shown at the start of a new system and replace it with
your preferred performance direction.

Una corda pedal lines
The equivalent to the final pedal lift for the una corda pedal marking is the indication to return to
tre corde. You can override the tre corde text shown at the end of the pedal line and replace it with
your preferred performance direction.
RELATED LINKS
Changing the start sign appearance of pedal lines on page 999
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Editing pedal line start text
You can change the text shown at the start of individual pedal lines that use text as their start
sign.
PROCEDURE
1.

Select the pedal lines whose start text you want to edit. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Text in the Pedal Lines group.

3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The text shown at the start of the selected pedal lines is changed.
Deactivating Text restores the default start text for the selected pedal lines.
NOTE
Deactivating properties permanently deletes any custom text entered.

RELATED LINKS
Changing the start sign appearance of pedal lines on page 999

Editing pedal line continuation text
You can change the text shown at the start of subsequent systems when pedal lines continue
across system/frame breaks.
NOTE
These steps only apply to pedal lines that use text as their start sign.

PROCEDURE
1.

Select the pedal lines whose continuation text you want to edit. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Continuation text in the Pedal Lines group.

3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The continuation text shown at the start of subsequent systems for the selected pedal lines is
changed.
Deactivating Continuation text restores the default continuation text for the selected pedal
lines.
NOTE
Deactivating properties permanently deletes any custom text entered.
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Editing una corda pedal line restorative text
The equivalent to the final pedal lift for una corda pedal lines is the indication to return to tre
corde. You can change the tre corde text shown at the end of individual una corda pedal lines.
NOTE
These steps only apply to una corda pedal lines that use text as their start sign.

PROCEDURE
1.

Select the una corda pedal lines whose restorative text you want to edit. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Restorative text in the Pedal Lines group.

3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The restorative text shown at the ends of the selected una corda pedal lines is changed.
Deactivating Restorative text restores the default restorative text for the selected pedal lines.
NOTE
Deactivating properties permanently deletes any custom text entered.

Pedal lines in playback
Pedal lines are automatically played back in Dorico Pro.
The three piano pedals send MIDI controllers as follows:
●

Sustain pedal lines send MIDI controller 64 (Sustain).

●

Sostenuto pedal lines send MIDI controller 66 (Sostenuto).

●

Una corda pedal lines send MIDI controller 67 (Soft Pedal).

Some piano VST instruments, such as Pianoteq and Garritan CFX Concert Grand, support partial
depression of the sustain pedal. Consult the manufacturer’s documentation for more
information.

Playback Options
You can find options for how Dorico Pro plays back pedaling on the Pedal Lines page in Play >
Playback Options.
You can control the following parameters of pedal line playback:
●

The length of the initial pedal depression

●

The length of a retake in the middle of a pedal line

●

The length of the final pedal release

●

Whether initial depressions and retakes are played before or after the onset of the notes or
chords at their rhythmic positions

RELATED LINKS
Playback Options dialog on page 502
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Pedal lines imported from MusicXML files
Sustain pedal lines can be imported from MusicXML files. MusicXML can only describe the sustain
pedal, and it cannot describe changes in pedal depression level.
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The term “playing techniques” covers a wide range of instructions intended to tell performers to
modify the sound of the notes they are playing, for example, by changing their embouchure or
changing the position of their bow, or by modifying their instrument, such as adding a mute or
depressing a pedal.
In Dorico Pro, playing techniques can be expressed as symbols or as text. All available playing
techniques can be found in the Playing Techniques panel in Write mode, organized by
instrument family. For example, you can find pedal lines in the Keyboard section of the Playing
Techniques panel.
NOTE
Because pedal lines have additional, unique requirements that do not apply to other playing
techniques, such as retakes, start signs, and continuation lines, they are documented separately.
Pedal lines also have their own group of the Properties panel that is separate from the Playing
Techniques group.
Adding playing techniques can change how the instrument plays back. For example, adding
pizzicato to a violin staff activates a key switch that changes the sound produced by the VST
instrument.
Many playing techniques that only appear once in the music nonetheless imply that the playing
technique continues. For example, pizzicato usually appears once but applies until the next
playing technique, such as arco. In Dorico Pro, you can show continuation lines after and
between playing techniques to convey clearly to performers the notes to which you want them to
apply. You can also group multiple playing techniques together.
Playing technique texts use a plain font, neither bold nor italic, so they are not confused with
dynamics and expressive text.
NOTE
This does not apply to pedal lines, as they use a separate font style to other playing techniques.

Some of the playing techniques in Dorico Pro

RELATED LINKS
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277
Playback playing techniques on page 1031
Pedal lines on page 986
String indicators on page 813
Playing technique continuation lines on page 1015
Groups of playing techniques on page 1020
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Project-wide engraving options for playing techniques
You can find options for the project-wide appearance and position of playing techniques on the
Playing Techniques page in Engrave > Engraving Options.
The options on the Playing Techniques page allow you to change the distance between playing
techniques and the staff, the arrangement of multiple text playing techniques at the same
rhythmic position, the default horizontal offset of text playing techniques, and playing technique
continuation styles. You can also change whether playing techniques on grace notes appear
smaller.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Positions of playing techniques
Playing techniques, both as text and symbols, are placed above the staff by default. On vocal
staves, they are placed above the staff and below dynamics. In multiple-voice contexts, playing
techniques for the up-stem voices are placed above the staff and playing techniques for the
down-stem voices are automatically placed below the staff.

Placement of playing techniques with two voices on the same staff

You can move playing techniques to different rhythmic positions in Write mode. They are
positioned by default according to your settings in Engraving Options.
You can move playing techniques graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all playing techniques project-wide on the Playing
Techniques page in Engrave > Engraving Options.
RELATED LINKS
Text pedal line signs on page 1003
Project-wide engraving options for playing techniques on page 1008
Moving playing techniques graphically on page 1009
Changing the staff-relative placement of items on page 330

Moving playing techniques rhythmically
You can move playing techniques to new rhythmic positions after they have been input, including
individual playing techniques within a group.
PROCEDURE
1.

In Write mode, select the playing techniques you want to move.
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NOTE

2.

●

When using the mouse, you can only move one playing technique rhythmically at a time.

●

Moving multiple playing techniques in the same group at the same time ungroups them.

Move the playing techniques in any of the following ways:
●

To move a single playing technique to the next notehead on the staff, press Alt/OptRight Arrow .

●

To move a single playing technique to the previous notehead on the staff, press Alt/
Opt-Left Arrow .

●

To move them to the right according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Right Arrow .

●

To move them to the left according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Left Arrow .
NOTE
You can only move playing techniques according to the current rhythmic grid resolution
when multiple playing techniques are selected.

●

Click and drag the playing technique to the right/left to the notehead you want.

RESULT
The selected playing techniques are moved to new rhythmic positions.
NOTE
If a single playing technique passes over another playing technique as part of its move, the
existing one is unaffected as multiple playing techniques can exist at the same rhythmic position.
However, if you move multiple playing techniques together, any existing playing techniques they
pass over are shortened or deleted accordingly.
You can undo this action, but any playing techniques shortened/deleted in the process are only
restored if you moved playing techniques using the keyboard.

RELATED LINKS
Moving pedal lines rhythmically on page 993
Groups of playing techniques on page 1020

Moving playing techniques graphically
You can move playing techniques graphically without changing the rhythmic positions to which
they apply. You can also move the start/end of playing technique continuation lines
independently, meaning you can lengthen/shorten them graphically.
In Engrave mode, each playing technique continuation line has two square handles, one at the
start and one at the end.
If playing technique continuation lines cross system and frame breaks, you can move the line
segments on each side of the break independently.

Groups of playing techniques have an additional handle at the start of the group, which controls
the vertical position of the whole group.
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NOTE
These steps do not apply to pedal lines.

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Whole playing techniques

●

Playing technique group start handles
NOTE
You can only move playing technique group start handles upwards/downwards.

●
2.

Individual handles on playing technique continuation lines

Move the playing techniques or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected playing techniques or handles are moved to new graphical positions. Playing
techniques in groups are attached to continuation lines, meaning that if you move a playing
technique in a group, any adjacent continuation lines automatically move with it.
Moving the start handle for playing technique groups moves the whole group upwards/
downwards.
TIP
The following properties in the Playing Techniques group of the Properties panel are activated
automatically when you move the corresponding item:
●

Offset moves playing techniques. X moves them horizontally, Y moves them vertically.

●

Start offset moves the start handle of playing technique continuation lines. X moves them
horizontally, Y moves them vertically.

●

End offset moves the end handle of playing technique continuation lines. X moves them
horizontally, Y moves them vertically.

You can also use these properties to move playing techniques and continuation lines by
changing the values in the value fields.
Deactivating the properties resets the selected playing techniques and continuation lines to their
default positions.
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RELATED LINKS
Changing the staff-relative placement of items on page 330
Groups of playing techniques on page 1020
Moving pedal lines graphically on page 994
Playing technique continuation line components on page 1017

Changing the vertical order of playing techniques
You can change the vertical order of playing techniques when multiple playing techniques exist
at the same rhythmic position. By default, glyph playing techniques are placed closer to the staff
than text playing techniques, and playing techniques without lines are placed closer to the staff
than playing techniques with lines.
PROCEDURE
1.

In Engrave mode, select the playing techniques whose vertical order you want to change.

2.

In the Properties panel, activate Tucking index in the Playing Techniques group.

3.

Change the value in the value field.

RESULT
The order of the selected playing techniques relative to any other playing techniques at the same
rhythmic position, or along their duration, is changed. This also affects other playing techniques
in the same groups. Playing techniques with higher Tucking index values are placed further
from the staff, while playing techniques with lower values are placed closer.
RELATED LINKS
Tucking index properties on page 740

Adding text to playing techniques
You can add text above or alongside playing techniques after they have been input, for example,
to clarify the intention of the playing technique.
NOTE
These steps do not apply to pedal lines.

PROCEDURE
1.

Select the playing techniques to which you want to add text. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Alternative text in the Playing Techniques group.

3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The text you entered into the value field is shown directly after text playing techniques, and
directly above symbol playing techniques.
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EXAMPLE

Alternative text added to text playing technique

Alternative text added to symbol playing technique

RELATED LINKS
Text pedal line signs on page 1003

Erasing the background of text playing techniques
You can erase the background of individual text playing techniques, for example, to ensure they
remain legible when crossing barlines.
PROCEDURE
1.

In Engrave mode, select the playing techniques whose backgrounds you want to erase.

2.

In the Properties panel, activate Erase background in the Playing Techniques group.

RESULT
The backgrounds of the selected playing techniques are erased.
Deactivating Erase background returns the selected playing techniques to the default nonerased background.
EXAMPLE

Text playing technique with non-erased background

Text playing technique with erased background

AFTER COMPLETING THIS TASK
You can change the padding between playing techniques and each edge of their erased areas.

Changing the erasure padding of text playing techniques
You can change the erasure padding of individual playing techniques, including changing the
padding between playing techniques and each edge of their erased areas independently.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

1012
Dorico Pro 3.1.10

Playing techniques
Hiding/Showing playing techniques

PROCEDURE
1.

In Engrave mode, select the text playing techniques whose erasure padding you want to
change.

2.

In the Properties panel, activate the Erasure padding properties, individually or together, in
the Playing Techniques group.

3.

●

L changes the padding between playing techniques and their left edge.

●

R changes the padding between playing techniques and their right edge.

●

T changes the padding between playing techniques and their top edge.

●

B changes the padding between playing techniques and their bottom edge.

Change the values in the value fields.

RESULT
Increasing the values increases the padding, decreasing the values decreases the padding.
TIP
You can change the default erasure padding of all playing techniques project-wide in the Design
section of the Playing Techniques page in Engrave > Engraving Options. However, this does
not allow you to change the padding of each edge independently.

Hiding/Showing playing techniques
You can hide/show playing techniques individually, for example, if your expression map requires
you to input a playing technique to trigger the correct playback but you do not want that
technique to appear in the music.
PROCEDURE
1.

Select the playing techniques you want to hide, or the signposts of playing techniques you
want to show. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Hidden in the Playing Techniques group.

RESULT
The selected playing techniques are hidden when Hidden is activated, and shown when it is
deactivated.
Signposts are shown at the position of each hidden playing technique. However, signposts are
not printed by default.
TIP
●

If you do not want to show playing technique signposts, choose View > Signposts > Playing
Techniques. Playing technique signposts are shown when a tick appears beside Playing
Techniques in the menu, and hidden when no tick appears.

●

You can assign a key command for Hide/Show Item on the Key Commands page in
Preferences, which applies to chord symbols, playing techniques, and time signatures.

RELATED LINKS
Expression maps on page 573
Signposts on page 335
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Lengthening/Shortening playing techniques
You can lengthen/shorten the duration of playing techniques after they have been input,
including string indicators outside the staff. Lengthening a playing technique that was added to a
single note gives it duration.
NOTE
●

You can only lengthen/shorten non-grouped playing techniques or the last playing
technique in a group.

●

Lengthening/Shortening playing techniques does not affect playback. The sounds produced
in playback rely on the playback playing technique associated with the playing technique, the
expression map settings, and sound libraries loaded in the project.

PROCEDURE
1.

In Write mode, select the playing techniques you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one playing technique at a time.
When using the keyboard, you can lengthen/shorten multiple playing techniques, but they
must all have duration already.

2.

Lengthen/Shorten the playing techniques in any of the following ways:
●

To lengthen them by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten them by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .

●

To snap the end of a single playing technique to the next notehead, press Ctrl/CmdShift-Alt/Opt-Right Arrow .

●

To snap the end of a single playing technique to the previous notehead, press Ctrl/CmdShift-Alt/Opt-Left Arrow .
NOTE

●

●

You can only lengthen/shorten playing techniques according to the current rhythmic
grid resolution when multiple playing techniques are selected.

●

When using the keyboard, you can only move the end of playing techniques with
duration. You can move the start of playing techniques with duration by moving
them rhythmically, or by clicking and dragging the start handle.

Click and drag the circular handle at the start/end to the right/left.
NOTE
Playing technique groups only have a single handle at their start and end, not individual
handles for each playing technique within the group.

RESULT
Single playing techniques are lengthened/shortened according to the current rhythmic grid
resolution or to the next/previous notehead, whichever is closer.
Multiple playing techniques are lengthened/shortened according to the current rhythmic grid
resolution.
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TIP
You can move playing techniques graphically in Engrave mode, including changing their
graphical length.

RELATED LINKS
Playing technique duration on page 1016
Moving playing techniques graphically on page 1009

Playing technique continuation lines
Playing technique continuation lines convey exactly the notes to which playing techniques apply,
and can also indicate a gradual transition between playing techniques.

A phrase with multiple playing technique continuation lines

In Dorico Pro, there are the following types of playing technique continuation lines:
Duration line

Indicates a specific duration to which the playing technique applies. The duration line
for most playing techniques is a solid line with a hook cap at the end.
Playing techniques show duration lines when the following conditions are met:
●

The playing technique has duration.

●

The continuation type for the playing technique is set to show lines.

●

The playing technique is ungrouped or is the final playing technique in a group.

Transition line

Indicates that the playing technique at the start must gradually turn into the playing
technique at the end over the duration specified by the line. The transition line for
most playing techniques is a solid line with an arrow cap at the end.
Transition lines are automatically shown between playing techniques in groups.
You can change the continuation type and specify the default duration line and transition line
types for each playing technique in the Edit Playing Techniques dialog.
NOTE
Playing technique continuation lines do not affect playback. The sounds produced in playback
rely on the playback playing technique associated with the playing technique, the expression
map settings, and the sound libraries loaded in the project.

RELATED LINKS
Groups of playing techniques on page 1020
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Playing technique continuation line components on page 1017
Edit Playing Techniques dialog on page 1022
Creating custom playing techniques on page 1029
Lines on page 1033
Line components on page 1035

Playing technique duration
In Dorico Pro, playing techniques have an explicit duration when they apply to a specific range,
rather than from a single rhythmic position onwards. Playing techniques with duration can show
continuation lines.
You can give duration to any playing technique in any of the following ways:
●

Group playing techniques together

●

Input playing techniques with an open end during note input and extend them

●

Add playing techniques to a range of notes

●

Lengthen playing techniques

In Write mode, playing techniques with duration have start and end handles that show their
duration.

Start and end handles on a playing technique with duration

NOTE
Playing technique duration does not affect playback. The sounds produced in playback rely on
the playback playing technique associated with the playing technique, the expression map
settings, and the sound libraries loaded in the project.

RELATED LINKS
Grouping playing techniques together on page 1021
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277
Lengthening/Shortening string indicators on page 815
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Playing technique continuation line components
In Dorico Pro, playing technique continuation lines consist of multiple components that together
function as a single item. The duration line and transition line for the same playing technique can
have different default components.

1

Playing technique
Controls the default appearance of the following line.

2

Start cap
Symbol shown at the start of playing technique continuation lines.

3

Line body
Horizontal line, pattern, or wedge that makes up the main part of a playing technique
continuation line and extends across its entire length.

4

Continuation end cap
Symbol shown at the end of segments of playing technique continuation lines that continue
across multiple systems.

5

Playing technique continuation sign
Parenthesized reminder of the current playing technique shown at the start of subsequent
segments of playing technique continuation lines that continue across multiple systems. You
cannot hide playing technique continuation signs independently of the playing technique.

6

Continuation cap
Symbol shown at the start of subsequent segments of playing technique continuation lines
that continue across multiple systems.

7

End cap
Symbol shown at the end of playing technique continuation lines.

RELATED LINKS
Changing the style of playing technique continuation lines on page 1019
Changing the caps of playing technique continuation lines on page 1019
Lines on page 1033
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Hiding/Showing playing technique duration lines
You can hide/show duration lines for individual playing techniques. If you want to hide duration
lines, you can choose to show nothing or sim..
NOTE
These steps only apply to playing technique duration lines. They do not apply to playing
technique transition lines. Instead, you can change the style of transition lines.
PREREQUISITE
The playing techniques whose duration lines you want to hide/show have duration.
PROCEDURE
1.

In Write mode, select the playing techniques whose duration lines you want to hide/show.

2.

In the Properties panel, activate Continuation type in the Playing Techniques group.

3.

Select one of the following options from the menu:
●

None

●

sim.

●

Line

RESULT
Duration lines are hidden after the selected playing techniques when you select None. When you
select sim., duration lines are hidden and sim. is shown once after each selected playing
technique.
Duration lines are shown after the selected playing techniques when you select Line.
TIP
You can change the default continuation type for each playing technique in the Edit Playing
Techniques dialog.
EXAMPLE

Duration line shown

Duration line hidden

AFTER COMPLETING THIS TASK
You can change the style of the duration lines.
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Changing the style of playing technique continuation lines
You can change the style of individual playing technique duration lines and transition lines, for
example, if you want to show a single duration line as a wiggly line. You can change the whole
line style, including the caps, or only the body style, which does not affect the caps.
PROCEDURE
1.

In Engrave mode, select the playing technique continuation lines whose style you want to
change.

2.

In the Properties panel, activate one of the following properties in the Playing Techniques
group:

3.

●

To change the whole line style, including caps, activate Line style.

●

To change only the body style, excluding caps, activate Line body style.

Select the style you want from the menu.

RESULT
The corresponding style of the selected playing technique continuation lines is changed.
TIP
You can change the default duration line and transition line types for each playing technique in
the Edit Playing Techniques dialog. However, this only changes the whole line style.
AFTER COMPLETING THIS TASK
You can change the caps of individual playing technique continuation lines.
RELATED LINKS
Edit Playing Techniques dialog on page 1022
Playing technique continuation line components on page 1017
Changing the body style of lines on page 1045

Changing the caps of playing technique continuation lines
You can change the caps of individual playing technique continuation lines independently of their
line body styles. You can also change the caps of individual segments of playing technique
continuation lines that continue across multiple systems.
PROCEDURE
1.

In Engrave mode, select the playing technique continuation lines whose caps you want to
change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Playing Techniques group:

3.

●

To change the cap at the start of the selected lines, activate Start cap.

●

To change the cap at the end of the selected lines, activate End cap.

●

To change the cap at the start of segments of the selected lines on subsequent systems,
activate Continuation cap.

●

To change the cap at the end of segments of the selected lines on subsequent systems,
activate Continuation end cap.

Select the style you want from each menu.
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RESULT
The corresponding caps of the selected playing technique continuation lines are changed.
AFTER COMPLETING THIS TASK
You can change the style of individual playing technique continuation lines.
RELATED LINKS
Changing the caps of lines on page 1045

Groups of playing techniques
Groups of playing techniques are automatically aligned in a row and can be moved and edited as
a group. When you move individual playing techniques within a group, the lengths of any
continuation lines on either side automatically adjust to compensate.

A group of playing techniques

The same group of playing techniques with adjusted
transition lines after the middle playing technique
moved rhythmically

Two or more playing techniques are automatically grouped together if they are adjoining with
duration between them and were added to existing notes together or input in sequence during
note input.
Transition lines are automatically shown between playing techniques in groups. The final playing
technique in playing technique groups can show a duration line if it has duration.
All of the playing techniques in a group are highlighted when any of the playing techniques in
the group are selected.

In Engrave mode, you can move each playing technique and continuation line within a group
individually. Playing techniques in groups are attached to continuation lines, meaning that if you
move a playing technique, any adjacent continuation lines automatically move with it. Groups of
playing techniques have a handle at the start of the group, which controls the vertical position of
the whole group.

NOTE
●

You cannot group a playing technique group to another playing technique group, you can
only group single playing techniques together or single playing techniques to an existing
group.

●

Groups of playing techniques apply project-wide, meaning you cannot have playing
techniques grouped one way in some layouts but differently in other layouts. However, you
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can move playing techniques graphically in each layout independently and independently of
their groups.
RELATED LINKS
Playing technique continuation lines on page 1015
Moving playing techniques rhythmically on page 1008
Playing technique duration on page 1016

Grouping playing techniques together
You can manually group playing techniques together that were not automatically grouped when
they were input. Grouped playing techniques are automatically aligned in a row, show transition
lines between them, and can be moved and edited as a group.
NOTE
You cannot group a playing technique group to another playing technique group. You can only
group single playing techniques together or single playing techniques to an existing group.
If you want to group a playing technique group to another playing technique group, you must
first ungroup them.

PROCEDURE
1.

In Write mode, select the playing techniques you want to group together.

2.

Choose Edit > Playing Techniques > Group Playing Techniques. You can also choose this
option from the context menu.

RESULT
The selected playing techniques are grouped together. Their durations are extended to reach the
next playing technique in the group, and transition lines are shown between playing techniques
in the group. Each transition line in the group uses the appropriate line type defined for the
playing technique at the start of the line in the Edit Playing Techniques dialog.
RELATED LINKS
Edit Playing Techniques dialog on page 1022
Playing technique continuation lines on page 1015

Ungrouping playing techniques and removing playing techniques
from groups
You can ungroup playing techniques so that all playing techniques in the group become
ungrouped. You can also remove only selected playing techniques from groups while leaving
other playing techniques in the group.
This applies to all layouts in which the playing techniques appear.
PROCEDURE
1.

In Write mode, select the playing techniques you want to ungroup or remove from groups.

2.

Do one of the following:
●

To ungroup all playing techniques in the selected groups, choose Edit > Playing
Techniques > Ungroup Playing Techniques.
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●

To remove only the selected playing techniques from their groups, choose Edit >
Playing Techniques > Remove Playing Technique from Group.

TIP
You can also choose these options from the context menu.

RESULT
The selected playing techniques or all playing techniques are removed from the selected groups.
Playing techniques that previously had transition lines now appear with duration lines, as defined
for the playing technique in the Edit Playing Techniques dialog.

Custom playing techniques
Custom playing techniques allow you to represent any playing technique in any way you want,
for example, if the default glyph used for a particular playing technique is not the one to which
you or the players reading the music are accustomed.
As well as designing the appearance of custom playing techniques using existing glyphs, text,
and your own graphics, you can define how they should affect playback and whether or not they
show continuation lines.
You can create and edit custom playing techniques in the Edit Playing Techniques dialog and its
related dialogs. You can find your custom playing techniques in their assigned category in the
Playing Techniques panel in Write mode. You can also input them using the popover by entering
the popover text assigned to them.
RELATED LINKS
Creating custom playing techniques on page 1029
Playback playing techniques on page 1031
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277

Edit Playing Techniques dialog
The Edit Playing Techniques dialog allows you to add, edit, and delete custom playing
techniques. It also allows you to change various settings relating to the appearance and function
of all playing techniques in the project.
●

You can open the Edit Playing Techniques dialog in Engrave mode by choosing Engrave >
Playing Techniques, or by clicking Add Playing Technique in the action bar of any section
in the Playing Techniques panel in Write mode.
You can also open it for a specific playing technique by selecting that playing technique in
the Playing Techniques panel in Write mode and clicking Edit Playing Technique in the
action bar for that section, or double-clicking a playing technique in Engrave mode.
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Edit Playing Techniques dialog

The Edit Playing Techniques dialog contains the following sections and options:
1

Category menu
Allows you to filter the list of playing techniques by selecting an instrument or instrument
family category from the menu, such as String or Choral. This corresponds to the titles of
sections in the Playing Techniques panel.

2

Playing techniques list
Contains all the playing techniques in the project within the currently selected category.
The action bar at the bottom of the list contains the following options:
●

New: Adds a new blank playing technique.

●

New from Selection: Creates a copy of an existing playing technique that you can edit
separately from the original.

●

Save as Default: Saves the currently selected playing technique as a default in your user
library, allowing you to use it in multiple projects.

●

Revert to Factory: Removes all edits you have made to the selected predefined playing
technique, returning it to its original settings and appearance.
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●

Delete: Deletes the selected playing technique.

NOTE
You cannot delete predefined playing techniques or any playing technique that is
currently used in your project.
3

Name
Allows you to enter a new name or edit the existing name for the selected playing technique.

4

Preview
Displays the playing technique in its current form. If the playing technique is set to appear
the same both above and below the staff, a single preview area is shown. If the playing
technique is set to appear differently according to its staff-relative placement, the preview is
split to show both possible appearances.
Clicking Edit Composite in the action bar below the preview opens the Edit Playing
Technique dialog, where you can edit the appearance of the playing technique. This button
is only available for glyph playing techniques.

5

Playing technique options
Contains options relating to the appearance and function of the selected playing technique.
Options are divided into tabs according to the aspect of the selected playing technique they
affect.
The General tab contains the following options:
●

Category: Allows you to select an instrument family category for the selected playing
technique, for example, if you duplicated a String technique but want to save your new
playing technique in the Wind category.

●

Type: Allows you to choose whether the playing technique is a Glyph or Text. This
affects how the technique appears in the preview.
If you select Text, a Text field appears beside the Type menu. You can enter any text
into the field, and select any font style from the menu beside the field. The playing
technique appears on the left of the preview.
If you select Glyph, the playing technique appears in the middle of the preview.
Selecting Glyph also allows you to edit the playing technique in the Edit Playing
Technique dialog.

●

Default placement: Allows you to choose whether the playing technique is placed
Above or Below the staff by default.

●

Appearance: Allows you to choose whether the playing technique appears the same on
either side of the staff, or whether it has a different appearance on each side. If you
choose Different above and below, you can edit each appearance independently.

●

Popover text: Allows you to set the text you want to enter into the popover to input the
playing technique.

●

Playback playing technique: Allows you to choose the playback playing technique for
the playing technique, that is, the action/switch that changes the sample sound used.
Multiple playing techniques can use the same playback playing technique.
If you need a playback playing technique not in the list, click Edit to the Edit Playback
Playing Techniques dialog, where you can create your own playback playing
techniques.

●

Cues: Allows you to choose whether or not the playing technique appears in cues when
playing techniques are shown in cues.
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●

Tablature: Allows you to choose whether the playing technique always appears on
tablature or only appears in layouts with no notation staff shown.

The Continuation tab contains the following options:
●

Continuation type: Allows you to choose whether or not the playing technique shows
duration lines when it has duration, and if not, whether it shows nothing or sim.. If you
choose Line, you can change the duration line style.
NOTE
This only applies to ungrouped playing techniques and the final playing techniques in
groups.

●

Duration line: Allows you to choose the default duration line style for the playing
technique.
Alignment above/Below: Allow you to set the vertical position at which duration lines
attach to the playing technique above and below the staff independently.

●

Transition line: Allows you to choose the default transition line style for the playing
technique.
NOTE
Playing techniques within groups always show transition lines. Only the final playing
technique in groups can show a duration line.
Alignment above/Below: Allow you to set the vertical position at which transition lines
attach to the playing technique above and below the staff independently.

RELATED LINKS
Edit Playback Playing Techniques dialog on page 1028
Creating custom playing techniques on page 1029
Playing Techniques panel on page 280
Playing technique duration on page 1016
Playing technique continuation lines on page 1015
Changing the style of playing technique continuation lines on page 1019
Changing the caps of playing technique continuation lines on page 1019

Edit Playing Technique dialog
The Edit Playing Technique dialog allows you to design custom playing techniques and edit the
appearance and arrangement of playing techniques.
●

You can open the Edit Playing Technique dialog from within the Edit Playing Techniques
dialog by selecting the playing technique whose design you want to edit from the list and
clicking Edit Composite in the action bar below the preview. Its Type must be set to Glyph in
order for you to do this.
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Edit Playing Technique dialog

The Edit Playing Technique dialog contains the following sections and options:
1

Name
Contains the saved name for predefined playing techniques, or an automatically generated
name for new playing techniques. You cannot change this name.

2

Component selector
Allows you to choose components to add to the playing technique. You can add different
types of components by clicking the respective tab titles.
●

Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting different
fonts and different ranges from the menus. Click Add Glyph to add the selected glyph to
the playing technique.
NOTE
A full list of the different ranges of glyphs is available on the SMuFL website.

3

●

Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected text, or
input text, to the playing technique.

●

Graphic: Allows you to load a new graphics file, or select an existing graphic from the
Select existing list, in SVG, PNG, or JPG format. You can see a preview of the graphic in
the Preview box. Click Add Graphic to add the selected graphic to the playing
technique.

●

Composite: Allows you to select a composite from the list. Click Add Composite to add
the selected composite to the playing technique.

Editor
Allows you to arrange and edit the components that make up the playing technique. You can
arrange and edit components by clicking and dragging them in the editor and by using the
controls at the bottom of the dialog. You can also use the handles on each component to
change their size.

4

Editor action bar
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Contains selection and view options for the editor.

5

●

Zoom: Allows you to change the zoom level in the editor.

●

Select: Allows you to select the next/previous component.

●

Show Attachments: Shows all the attachments on all components in the editor.

●

Delete: Deletes the selected component.

Controls
Contains controls that allow you to edit individual components. Controls are divided into tabs
according to the aspect of the selected component they affect. For playing techniques, only
the Component and Attachments tabs are available as the other tabs do not apply to
playing techniques.
The Component tab contains the following options:
●

Offset: Controls the position of the selected component. X moves it horizontally, Y
moves it vertically.

●

Scale: Controls the size of the selected component. For graphics, X controls its width, Y
controls its height.
NOTE
Although some components scale their height and width independently, others retain
their aspect ratio, meaning only one value affects their overall size.

●

Z order: Allows you to Bring Forward or Send Backward the selected component in
relation to other components when they overlap.

The Attachments tab is only available if the playing technique comprises at least two
separate components. It contains the following options:
●

Attachment from: Sets the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend that
you select a right edge attachment point for Attachment from.

●

Attachment to: Sets the attachment point on the selected component which attaches to
the component to its left. We recommend that you select a left edge attachment point
for Attachment to.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.

The attachment points have the following names in the Edit Playing Technique dialog:
1

Top Left

2

Top Center

3

Top Right

4

Middle Left
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5

Middle Right

6

Baseline Left (text only)

7

Baseline Center (text only)

8

Baseline Right (text only)

9

Bottom Left

10 Bottom Center
11 Bottom Right
RELATED LINKS
Edit Playing Techniques dialog on page 1022

Edit Playback Playing Techniques dialog
The Edit Playback Playing Techniques dialog allows you to define new playback playing
techniques and edit existing ones. Playback playing techniques are used by expression maps to
assign the correct sounds to the required playing techniques in the music.
●

You can open the Edit Playback Playing Techniques dialog by clicking Edit beside Playback
playing technique in the Edit Playing Techniques dialog.

Edit Playback Playing Techniques dialog

The Edit Playback Playing Techniques dialog contains the following sections and options:
1

Category menu
Allows you to filter the list of playback playing techniques by selecting a category from the
menu, such as Techniques or Dynamics.

2

List of playback playing techniques
Contains all the playback playing techniques in the project within the currently selected
category.
The action bar at the bottom of the list contains the following options:
●

New: Adds a new blank playback playing technique.
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●

New from Selection: Creates a copy of an existing playback playing technique that you
can edit separately from the original.

●

Save as Default: Saves the currently selected playback playing technique as the default,
allowing you to use it in multiple projects.

●

Revert to Factory: Removes all edits you have made to the selected predefined
playback playing technique, returning it to its original settings.

●

Delete: Deletes the selected playback playing technique.

NOTE
You cannot delete predefined playing techniques or any playing technique that is
currently used in your project.
3

Name
Allows you to edit or enter the name of the playback playing technique. This is the name
shown in lists in the Edit Playing Techniques, Expression Maps, Playing Technique
Combinations, and Percussion Maps dialogs.

4

Playback options
●

Alias for: Allows you to select another playback playing technique whose sound
mapping you want to apply to the selected playback playing technique as well.

●

Group: Sets the group in which this playback playing technique appears.

●

Fallback: Allows you to specify another playback playing technique that can be used if
the present one is not available.

●

Articulation type: Sets the duration over which the playback playing technique takes
effect. Attribute applies only to the note at the rhythmic position where the playing
technique is found, such as a staccato articulation, while Direction applies to all
following notes until it is replaced by another playing technique, such as pizzicato.

RELATED LINKS
Edit Playing Techniques dialog on page 1022
Edit Playing Technique dialog on page 1025
Expression Maps dialog on page 574
Playing Technique Combinations dialog on page 580

Creating custom playing techniques
You can create your own custom playing techniques, including choosing their continuation line
styles and playback playing techniques, for example, if the default glyph used for a particular
playing technique is not the one to which you or the players reading the music are accustomed.
PROCEDURE
1.

In Engrave mode, choose Engrave > Playing Techniques to open the Edit Playing
Techniques dialog.

2.

Select the category in which you want to create the custom playing technique from the
Category menu.
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3.

Create a new playing technique in one of the following ways:
●

To create a blank playing technique, click New in the playing techniques list action bar.

●

To create a playing technique that is a copy of an existing one, select the existing playing
technique in the playing techniques list and click New from Selection in the playing
techniques list action bar.

4.

Enter the name you want for the new playing technique in the Name field.

5.

On the General tab, select one of the following options from the Type menu:

6.

7.

●

Glyph

●

Text

Customize the appearance of your playing technique in one of the following ways:
●

For text playing techniques, change the text in the Text field and/or change the font
style used.

●

For glyph playing techniques, click Edit Composite below the appearance you want to
customize to open the Edit Playing Technique dialog, in which you can customize its
appearance.

Optional: For glyph playing techniques, choose one of the following options for Appearance
on the General tab:
●

Same above and below

●

Different above and below

8.

Optional: If you chose Different above and below, customize the other appearance.

9.

Select the playback playing technique you want the playing technique to use in playback
from the Playback playing technique menu.

10. Optional: If you want to use a playback playing technique that is not available, click Edit to
open the Edit Playback Playing Techniques dialog, in which you can add and edit playback
playing techniques.
For example, some sound libraries require you to map specific actions/switches manually, so
you might create a new playback playing technique to which you can assign actions/switches
in the expression map for such a sound library.
11. Change any other options on the General tab as required.
12. Optional: If you want the playing technique to show continuation lines, select Line from the
Continuation type menu on the Continuation tab.
13. Optional: For playing techniques that show continuation lines, select the style you want to
use for duration lines and transition lines from the corresponding menus.
14. Optional: Change the alignment positions of duration and transition lines.
15. Click OK to save your changes and close the dialog.
RESULT
The custom playing technique is created. It is available in the current project only.
AFTER COMPLETING THIS TASK
●

If you created a new playback playing technique, add it to the expression maps for all the
instruments that use the custom playing technique and assign the appropriate action/switch
for the sound library.

●

You can save the custom playing technique as default to make it available in other projects.

●

You can input the playing technique so it appears in your music.
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RELATED LINKS
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277

Saving custom playing techniques as default
By default, custom playing techniques are only available in the project in which you created
them. You can save them as default to make them available to use in multiple projects.
PROCEDURE
1.

In Engrave mode, choose Engrave > Playing Techniques to open the Edit Playing
Techniques dialog.

2.

In the playing techniques list, select the playing techniques you want to use in multiple
projects.

3.

Click Save as Default in the action bar.

4.

Click OK to save your changes and close the dialog.

RESULT
The selected playing techniques are saved as a default in your user library, allowing them to be
used in multiple projects.
RELATED LINKS
Custom playing techniques on page 1022
Edit Playing Techniques dialog on page 1022

Playback playing techniques
Playback playing techniques link together the playing technique items that you input into your
music and techniques/articulations in sound libraries in order to produce the correct sounds in
playback. They are used by expression and percussion maps to trigger the appropriate
commands, such as key switches or control changes.
When you input a playing technique or articulation in Write mode, the corresponding expression
map looks for the appropriate playback playing technique. For example, inputting pizz. playing
techniques causes expression maps to use the Pizzicato playback playing technique to switch to
the pizzicato sound for playback. If the expression map cannot locate the sound, the playback
playing technique applied either remains the same as the previous playback playing technique or
reverts to the natural playback playing technique.
Custom playing techniques that use playback playing techniques which do not already exist in
expression maps do not play back automatically. In order for them to play back appropriately,
you must add them to the expression maps for each instrument for which you want to use them.
You must also assign an action for each custom playing technique that determines how the
switch required to execute the technique is controlled.
You can map playback playing techniques as required for different sound libraries in the
Expression Maps dialog, including creating new combinations of existing playback playing
techniques, such as Legato and Tremolo, which allows them to be used simultaneously.
You can see which playing techniques are in use at any particular rhythmic position in the
Playing Techniques lane, which you can show by expanding individual instruments in Play
mode.
TIP
●

If you have input a playing technique but cannot hear a change in the sound, you might be
using a combination of playing techniques that the expression map does not expect. For
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example, if you input a new playing technique without cancelling an existing playing
technique, the expression map cannot process the two playing techniques together if the
expression map does not have an entry for those two techniques combined.
To avoid playing technique clashes, input a “naturale”, or “nat.”, playing technique to return
the software instrument to its natural state. You can then input new playing techniques
without clashes. Alternatively, you can create a combination of those playing techniques in
order to use them simultaneously.
●

You can enable independent voice playback for individual instruments to hear different
playing techniques in different voices simultaneously.

RELATED LINKS
Expression maps on page 573
Expression Maps dialog on page 574
Playing Technique Combinations dialog on page 580
Enabling independent voice playback on page 543
Creating new expression maps on page 581
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Lines can convey a variety of meanings in music, such as indicating which hand to use in piano
music or a gradual change in bow pressure. In Dorico Pro, lines can be vertical, horizontal, or
angled between notes and have different styles and appearances.

A phrase containing horizontal and vertical lines that convey a range of meanings

NOTE
Due to their generic designs, such as a dashed line with arrow end cap, lines in Dorico Pro have
no definitive musical meaning and function primarily graphically, meaning they do not affect
playback. Dorico Pro includes dedicated features for specific notations that affect playback if
applicable, such as dynamics, arpeggios, glissandi, and trills.
The following types of lines are available in Dorico Pro:
Horizontal lines
Horizontal lines span a specified duration, that is, they start at one rhythmic position
and end at a later rhythmic position. They might indicate a change over time, such as a
wedge that represents bow pressure, or suggest a link between notes, such as a
bracket spanning the theme in a fugue or a straight line between notes showing where
a melody moves to a different staff.
Attachment types control the positions of horizontal lines and certain aspects of their
functionality. Horizontal lines can have different attachment types at their start and
end.
NOTE
You cannot change the attachment type of horizontal lines after they have been input.
In Dorico Pro, each end of horizontal lines can have the following attachment types:
●

Notehead-attached
Attached to an individual note independently of its rhythmic position, meaning
that the ends of notehead-attached lines move with notes if you change their pitch
or move them rhythmically. Notehead-attached lines can be both angled or
horizontal, as their end positions and resulting angles are determined by the
interval between the start and end notes.
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A phrase containing two notehead-attached lines, showing where the melody moves
between piano staves

●

Barline-attached
Attached to a rhythmic position and aligned with barlines, if their rhythmic
positions coincide with barline positions. Barline-attached lines are always
horizontal.

A barline-attached line spanning two full bars

●

Rhythmic position-attached
Attached to a rhythmic position and positioned relative to notes, chords, or rests at
those rhythmic positions.
Rhythmic position-attached lines are horizontal and placed above the staff by
default. Their endpoints start to the left and end to the right of notes, chords, or
rests at the corresponding rhythmic positions.

A rhythmic position-attached line spanning two full bars

Vertical lines
Vertical lines exist at a single rhythmic position and are positioned relative to notes,
chords or rests at that position. They might convey details about a specific moment,
such as indicating which hand to use for specific notes in piano music.

Vertical lines indicating which notes to play with the right hand

RELATED LINKS
Input methods for lines on page 290
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Line components
Lines panel on page 290
Adding text to lines on page 1046
Changing the placement of horizontal lines on page 1038
Arpeggio signs on page 941
Glissando lines on page 950
Octave lines on page 732
Trills on page 929
Playing technique continuation lines on page 1015
Pedal lines on page 986
Repeat endings on page 1070
Guitar bends on page 957
Tuplet brackets on page 1267

Line components
In Dorico Pro, lines consist of multiple components that together function as a single item.

1

Start cap
Symbol shown at the start of lines.

2

Line body
Horizontal or vertical line, pattern, or wedge that makes up the main part of a line and
extends across its entire length or height.

3

Text
Text shown in the middle of lines/line segments, centered by default. On vertical lines, text
reads upwards by default.

4

Continuation end cap
Symbol shown at the end of segments of lines that continue across multiple systems.

5

Continuation cap
Symbol shown at the start of subsequent segments of lines that continue across multiple
systems.

6

End cap
Symbol shown at the end of lines.

RELATED LINKS
Changing the body style of lines on page 1045
Changing the caps of lines on page 1045
Adding text to lines on page 1046
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Project-wide engraving options for lines
Changing the position of text relative to horizontal lines on page 1048
Changing the position of text relative to vertical lines on page 1048
Playing technique continuation lines on page 1015

Project-wide engraving options for lines
You can find options for the default gaps at the start and end of horizontal lines, and between
horizontal lines and other items, on the Lines page in Engrave > Engraving Options.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
RELATED LINKS
Engraving Options dialog on page 359
Length of lines on page 1042

Positions of lines
The position of lines relative to notes and staves depends on the line type and, for horizontal
lines, their attachment type.
Notehead-attached horizontal lines
Notehead-attached lines are positioned in relation to the corresponding noteheads,
that is, starting to the right of the start note and ending to the left of the end note.
They automatically follow the notes at each end, meaning if you change the pitch of
either note or move them rhythmically, the line end positions move accordingly.
Because their positions depend on the pitches of notes, they can appear both inside
and outside the staff. If they are only attached to noteheads at one end, they remain
horizontal but follow the staff position of the note to which they are attached.
Barline-attached horizontal lines
Barline-attached horizontal lines are placed above the staff by default. Their endpoints
align with barlines if their duration coincides with barline positions. If their endpoints
do not coincide with barlines, they are positioned like rhythmic position-attached lines.
Rhythmic position-attached horizontal lines
Rhythmic position-attached lines are placed above the staff by default. Their endpoints
start to the left and end to the right of notes, chords, or rests at the corresponding
rhythmic positions.
Vertical lines
Vertical lines are positioned to the left of the notes to which they apply, including any
applicable accidentals, but are positioned between grace notes and normal notes. If
multiple vertical lines exist at the same rhythmic position, the most recent line is
positioned furthest to the right, that is, directly to the left of notes, chords or rests.
You can change the position/placement of lines in a variety of ways, such as showing vertical
lines on the right of notes or changing the placement of horizontal lines to show them inside the
staff.
RELATED LINKS
Changing the horizontal order of vertical lines on page 1037
Showing vertical lines before grace notes on page 1038
Changing the placement of horizontal lines on page 1038
Moving lines graphically on page 1041
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Showing vertical lines on the right/left of notes
You can change the side of notes on which vertical lines appear, for example, to show selected
vertical lines on the right side of notes.
PROCEDURE
1.

Select the vertical lines whose horizontal position you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Side in the Vertical Lines group.

3.

Choose one of the following options:
●

Left

●

Right

RESULT
The selected lines appear on the corresponding side of notes.
EXAMPLE

Vertical line on the left of notes

Vertical line on the right of notes

AFTER COMPLETING THIS TASK
You can change the order of vertical lines when multiple vertical lines exist at the same rhythmic
position and on the same side of notes.

Changing the horizontal order of vertical lines
You can change the horizontal order of vertical lines when multiple vertical lines exist at the
same rhythmic position and on the same side of notes.
PROCEDURE
1.

Select the vertical lines whose order you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Column in the Vertical Lines group.

3.

Change the value in the value field.

RESULT
The order of the selected vertical lines relative to any other vertical lines at the same rhythmic
positions is changed. Lines with higher Column values are placed further to the left, while lines
with lower values are placed further to the right.
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Showing vertical lines before grace notes
You can position individual vertical lines so they appear to the left of grace notes. By default,
vertical lines are positioned after grace notes, that is, between grace notes and normal notes.
PROCEDURE
1.

Select the vertical lines you want to show before grace notes. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Line before grace notes in the Vertical Lines group.

RESULT
The selected vertical lines are positioned before grace notes.
Deactivating Line before grace notes shows the selected vertical lines after grace notes again.
EXAMPLE

Vertical line after grace notes

Vertical line before grace notes

Changing the placement of horizontal lines
You can show individual horizontal lines above, below, or inside the staff. By default, horizontal
lines are placed above the staff.
NOTE
These steps only apply to barline-/rhythmic position-attached horizontal lines.

PROCEDURE
1.

Select the horizontal lines whose placement you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Placement in the Horizontal Lines group.

3.

Select one of the following options from the menu:
●

Above

●

Below

●

Inside staff

RESULT
The placement of the selected horizontal lines is changed. Horizontal lines inside the staff are
centered on the middle staff line by default.
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TIP
You can also cycle through the different placement options for selected horizontal lines by
pressing F .
AFTER COMPLETING THIS TASK
●

You can change the staff position of lines shown inside the staff.

●

You can erase the background of text on lines shown inside the staff.

RELATED LINKS
Changing the staff-relative placement of items on page 330

Changing the staff position of horizontal lines inside the staff
You can change the staff position of horizontal lines shown inside the staff, including changing
the staff position of the start/end of lines independently of each other, for example, if you want
lines to appear angled.
PREREQUISITE
The horizontal lines whose staff position you want to change are placed inside the staff and have
at least one barline-/rhythmic position-attached end.
PROCEDURE
1.

Select the horizontal lines placed inside the staff whose staff position you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Horizontal Lines group:

3.

●

Start position

●

End position

Change the values in the value fields.

RESULT
The staff positions of the corresponding ends of the selected lines are changed according to the
new values. For example, 0 is the middle line of the staff, 4 is the top line of the staff, and -4 is the
bottom line of the staff.
EXAMPLE

Horizontal lines inside the staff with different staff positions at their start/end
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Moving horizontal lines rhythmically
You can move barline-/rhythmic position-attached horizontal lines to new rhythmic positions
after they have been input.
NOTE
●

You cannot move notehead-attached starts/ends of horizontal lines rhythmically, except by
moving the notes to which they are attached.

●

Although you can use these key commands for vertical lines, you cannot move vertical lines
over rests, you can only move them to adjacent notes/chords in the same voice. If you want
to move vertical lines along a phrase containing rests, we recommend deleting them and
inputting new vertical lines at the new positions instead.

PROCEDURE
1.

In Write mode, select the lines you want to move.
NOTE
When using the mouse, you can only move one horizontal line rhythmically at a time.

2.

Move the lines in any of the following ways:
●

To move a single horizontal line to the next notehead on the staff, press Alt/OptRight Arrow .

●

To move a single horizontal line to the previous notehead on the staff, press Alt/OptLeft Arrow .

●

To move them to the right according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Right Arrow .

●

To move them to the left according to the current rhythmic grid resolution, press Ctrl/
Cmd-Alt/Opt-Left Arrow .
NOTE
You can only move horizontal lines according to the current rhythmic grid resolution
when multiple lines are selected.

●

Click and drag the line to the right/left to the notehead you want.
NOTE
You cannot move vertical lines rhythmically with the mouse.

RESULT
The selected lines are moved to new rhythmic positions.
NOTE
If a single horizontal line passes over another line as part of its move, the existing one is
unaffected as multiple lines can exist at the same rhythmic position. However, if you move
multiple horizontal lines together or a single vertical line, any existing lines of the same type that
they pass over are shortened or deleted accordingly.
You can undo this action, but any lines shortened/deleted in the process are only restored if you
moved lines using the keyboard.
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Moving lines graphically
You can move individual horizontal and vertical lines graphically without changing the rhythmic
positions to which they are attached. You can move each end of lines independently, meaning
you can also adjust the angle and graphical length of individual lines.
In Engrave mode, each line has two square handles, one at the start and one at the end of
horizontal lines, and one at the top and one at the bottom of vertical lines.
If horizontal lines cross system and frame breaks, you can move the line segments on each side
of the break independently.

Handles on a vertical line and horizontal line in Engrave mode

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Whole lines or horizontal line segments

●

Individual handles on lines

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the lines or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected lines or handles are moved graphically, without affecting the rhythmic positions to
which they are attached.
TIP
The following properties in the Horizontal Lines group of the Properties panel are activated
automatically when you move the corresponding horizontal line handle:
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●

Start offset moves start horizontal line handles. X moves them horizontally, Y moves them
vertically.

●

End offset moves end horizontal line handles. X moves them horizontally, Y moves them
vertically.

The following properties in the Vertical Lines group of the Properties panel are activated
automatically when you move the corresponding vertical line handle:
●

Top offset moves top vertical line handles. X moves them horizontally, Y moves them
vertically.

●

Bottom offset moves bottom vertical line handles. X moves them horizontally, Y moves
them vertically.

For example, if you move a whole line, both handles are moved so both properties are activated.
You can also use these properties to move and lengthen/shorten lines graphically by changing
the values in the value fields.
Deactivating the properties resets the selected lines to their default positions.

RELATED LINKS
Line components on page 1035
Positions of lines on page 1036
Showing vertical lines on the right/left of notes on page 1037
Changing the horizontal order of vertical lines on page 1037
Changing the placement of horizontal lines on page 1038

Length of lines
Dorico Pro automatically calculates the appropriate length for both horizontal and vertical lines.
●

The length of horizontal lines is determined by the rhythmic duration of the line. Horizontal
lines with different attachment types are positioned differently, which can affect their
graphical length. For example, barline-attached lines can appear longer than rhythmic
position-attached lines with the same duration.

●

The length of vertical lines is determined by the pitch range of notes in the voices/staves to
which the line applies. Dorico Pro automatically adjusts the length of vertical lines if the
pitches of notes in the voices/staves to which the lines apply change, or you add notes to, or
delete notes from, chords.

You can lengthen/shorten both horizontal and vertical lines, for example, if you want an
individual vertical line to extend above the top note in a chord.
You can change the default gaps at the start and end of horizontal lines, and between horizontal
lines and other items, on the Lines page in Engrave > Engraving Options.

Lengthening/Shortening horizontal lines
You can lengthen/shorten horizontal lines rhythmically after they have been input.
NOTE
These steps only apply to barline-/rhythmic position-attached horizontal lines. You cannot
lengthen/shorten notehead-attached horizontal lines, except by lengthening/shortening the
notes to which they are attached.
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PROCEDURE
1.

In Write mode, select the horizontal lines you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one line at a time.

2.

Lengthen/Shorten the lines in any of the following ways:
●

To lengthen them by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten them by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .

●

To snap the end of a single line to the next notehead, press Ctrl/Cmd-Shift-Alt/OptRight Arrow .

●

To snap the end of a single line to the previous notehead, press Ctrl/Cmd-Shift-Alt/OptLeft Arrow .
NOTE

●

●

You can only lengthen/shorten lines according to the current rhythmic grid
resolution when multiple lines are selected.

●

When using the keyboard, you can only move the end of lines. You can move the
start of lines by moving lines rhythmically, or by clicking and dragging the start
handle of a single line.

Click and drag the circular handle at the start/end to the right/left.

RESULT
Single lines are lengthened/shortened according to the current rhythmic grid resolution or to the
next/previous notehead, whichever is closer.
Multiple lines are lengthened/shortened according to the current rhythmic grid resolution.
TIP
You can move lines graphically in Engrave mode, including changing their graphical length.

RELATED LINKS
Inputting horizontal lines on page 291
Moving horizontal lines rhythmically on page 1040
Moving lines graphically on page 1041

Lengthening/Shortening vertical lines
You can lengthen/shorten individual vertical lines to different staff positions. By default, vertical
lines span the range of all notes in the same voice at the same rhythmic position.
PROCEDURE
1.

Select the vertical lines you want to lengthen/shorten. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Vertical Lines group:
●

Top position

●

Bottom position
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3.

Change the values in the value fields.

RESULT
The vertical length of the selected lines is changed. Increasing the values moves the
corresponding end up by staff positions, decreasing the values moves the corresponding end
down by staff positions.
TIP
You can move lines graphically in Engrave mode, including changing their graphical length.

RELATED LINKS
Inputting vertical lines on page 292

Changing the end position of horizontal lines
By default, rhythmic position-attached horizontal lines end immediately after the last note,
chord, or rest at their end rhythmic position. You can change the end position of rhythmic
position-attached horizontal lines individually, for example, if you want them to end immediately
before the following note, chord, or rest.
NOTE
These steps only apply to rhythmic position-attached horizontal lines.

PROCEDURE
1.

Select the rhythmic position-attached horizontal lines whose end position you want to
change. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Horizontal end position in the Horizontal Lines group.

3.

Select one of the following options from the menu:
●

End at right-hand side of final note

●

End immediately before following note

RESULT
The end position of the selected rhythmic position-attached horizontal lines is changed.
EXAMPLE

Horizontal line ending after final note

Horizontal line ending before following note
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Changing the body style of lines
You can change the body style of individual lines without changing their caps.
PROCEDURE
1.

Select the lines whose body style you want to change. You can do this in Write mode and
Engrave mode.
NOTE
You must select either only horizontal lines or only vertical lines.

2.

In the Properties panel, activate Line body style in either the Horizontal Lines or Vertical
Lines group.

3.

Select the style you want from the menu.

RESULT
The body style of the selected lines is changed.
NOTE
This does not affect the caps of the selected lines.

RELATED LINKS
Line components on page 1035
Lines panel on page 290

Changing the caps of lines
You can change the caps of individual lines without changing their body style.
PROCEDURE
1.

Select the lines whose caps you want to change. You can do this in Write mode and Engrave
mode.
NOTE
You must select either only horizontal lines or only vertical lines.

2.

3.

In the Properties panel, activate the following properties, individually or together, in either
the Horizontal Lines or Vertical Lines group:
●

To change the cap at the start/bottom of the selected lines, activate Start cap.

●

To change the cap at the end/top of the selected lines, activate End cap.

●

To change the cap at the start of segments of the selected horizontal lines on
subsequent systems, activate Continuation cap.

●

To change the cap at the end of segments of the selected horizontal lines on subsequent
systems, activate Continuation end cap.

Select the style you want from each menu.

RESULT
The corresponding caps of the selected lines are changed.
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NOTE
This does not affect the body style of the selected lines.

Changing the direction of lines
You can change the direction of both horizontal and vertical lines, for example, to make a
horizontal line with an arrow end cap point to the left, or to make a vertical line with text appear
upside-down with its text reading downwards.
PROCEDURE
1.

Select the lines whose direction you want to change. You can do this in Write mode and
Engrave mode.
NOTE
You must select either only horizontal lines or only vertical lines.

2.

In the Properties panel, activate Reverse in either the Horizontal Lines or Vertical Lines
group.

RESULT
The direction of the selected lines is change. Text on vertical lines now reads downwards.
Deactivating Reverse returns the selected lines to their default direction.
EXAMPLE

Horizontal and vertical lines with default directions

Reversed horizontal and vertical lines

Adding text to lines
You can add text to both horizontal and vertical lines, for example, to clarify the intention of the
line.
PROCEDURE
1.

Select the lines to which you want to add text. You can do this in Write mode and Engrave
mode.
NOTE
You must select either only horizontal lines or only vertical lines.

2.

In the Properties panel, activate Text in either the Horizontal Lines or Vertical Lines group.
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3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The text you entered into the value field is shown centered in the middle of the selected lines. On
vertical lines, it reads upwards.
EXAMPLE

Text on a horizontal line

Text on a vertical line

AFTER COMPLETING THIS TASK
●

If you want text on vertical lines to read downwards, you can reverse the lines.

●

You can erase the backgrounds of text on lines.

RELATED LINKS
Line components on page 1035
Input methods for lines on page 290

Line text font styles
There are different font styles for line text according to the line type. You can change different
aspects of these fonts in the Edit Font Styles dialog, such as changing the font size to make line
text appear larger.
The following fonts are used for line text:
●

Horizontal Line Font: Used for text on horizontal lines.

●

Vertical Line Font: Used for text on vertical lines.

NOTE
Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Edit Font Styles dialog on page 407
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Changing the position of text relative to horizontal lines
You can change the position of text relative to horizontal lines, for example, to show text above
horizontal lines. By default, text is centered on horizontal lines.
NOTE
Text on lines always appears in the middle of the line. If you want to show text at the start or end
of lines, you can create a custom playing technique and set it to show continuation lines instead.

PROCEDURE
1.

Select the horizontal lines whose text position you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Text position in the Horizontal Lines group.

3.

Select one of the following options from the menu:
●

Above

●

Centered

●

Below

RESULT
The position of text relative to the selected horizontal lines is changed.
EXAMPLE

Text Above

Text Centered

Text Below

RELATED LINKS
Creating custom playing techniques on page 1029

Changing the position of text relative to vertical lines
You can change the position of text relative to vertical lines, for example, to show text on the left
of vertical lines. By default, text is centered on vertical lines.
NOTE
Text on lines always appears in the middle of the line. If you want to show text at the start or end
of lines, you can create a custom playing technique and set it to show continuation lines instead.

PROCEDURE
1.

Select the vertical lines whose text position you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Text position in the Vertical Lines group.

3.

Select one of the following options from the menu:
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●

Left

●

Centered

●

Right

RESULT
The position of text relative to the selected vertical lines is changed.
EXAMPLE

Text Left

Text Centered

Text Right

Erasing the background of line text
You can erase the background of text shown on individual lines, for example, to ensure they
remain legible if they appear inside the staff.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select the lines whose text backgrounds you want to erase.
NOTE
You must select either only horizontal lines or only vertical lines.

2.

In the Properties panel, activate Erase background in either the Horizontal Lines or
Vertical Lines group.

RESULT
The backgrounds of text on the selected lines are erased.
Deactivating Erase background returns text on the selected lines to the default non-erased
background.

1049
Dorico Pro 3.1.10

Lines
Adding text to lines

EXAMPLE

Line text with non-erased background

Line text with erased background

Changing the erasure padding of line text
You can change the erasure padding of text on individual lines, including changing the padding
between line text and each edge of their erased areas independently.
PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
PROCEDURE
1.

In Engrave mode, select the lines whose text erasure padding you want to change.
NOTE
You must select either only horizontal lines or only vertical lines.

2.

3.

In the Properties panel, activate the Erasure padding properties, individually or together, in
either the Horizontal Lines or Vertical Lines group.
●

L changes the padding between line text and their left edge.

●

R changes the padding between line text and their right edge.

●

T changes the padding between line text and their top edge.

●

B changes the padding between line text and their bottom edge.

Change the values in the value fields.

RESULT
Increasing the values increases the padding, decreasing the values decreases the padding.
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Rehearsal marks are an ordered sequence of letters or numbers, which along with bar numbers,
provide a reference point for music that has multiple players, and make the chronological
sequence of the music clear.
They tell performers where they are in the piece, and allow performers to orient and co-ordinate
themselves easily in rehearsals and concerts. Rehearsal marks can also be used to indicate
significant changes in the music, and you can freely decide their positions.
They can also be useful when preparing parts and scores, as you can use rehearsal marks and
bar numbers to compare quickly a part to the score and check it is correct. In Dorico Pro,
rehearsal marks follow an automatic sequence, ensuring there are never duplicate rehearsal
marks.
In Dorico Pro, rehearsal marks are categorized as system objects. Therefore, rehearsal marks
follow your per-layout settings for the visibility and positioning of system objects, which you can
change on the Staves and Systems page in Setup > Layout Options.
RELATED LINKS
Inputting rehearsal marks on page 296
System objects on page 1172
Changing the positions of system objects on page 1173

General placement conventions for rehearsal marks
Rehearsal marks should be at noticeable positions in the score so they can be seen easily. They
should use a large, non-italic bold font, and be positioned above the system and outside the
music.

Rehearsal marks should be positioned above barlines, and not below the system. Although you
can input rehearsal marks at rhythmic positions within a bar in Dorico Pro, this is not common
practice. Depending on the style of music and the context, it can be helpful to input a double
barline beneath each rehearsal mark.
In order to ensure they are easily noticeable, and cannot be confused with bar numbers if you
are using numbers for rehearsal marks, rehearsal marks should be shown in an enclosure. You
can change the shape and size of rehearsal mark enclosures in Dorico Pro.
The placement of rehearsal marks relative to the music is discretionary, but they are most helpful
to players when they coincide with a change in the music, such as a tempo change or a change in
texture. They are also helpful when placed at a point in the music where players are likely to start
from in order to rehearse a specific section, such as a significant solo entry or the start of a
difficult passage.
In general, it is good practice to place rehearsal marks at regular intervals as well as at significant
moments. It is often recommended to have rehearsal marks every 5-20 bars to reduce the
amount of bars players need to count before or after a rehearsal mark.
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If a rehearsal mark coincides with a tempo change, you should position the tempo text to the
right of the rehearsal mark. However, if space is tight, the text can be positioned above or below
the rehearsal mark. The position of the rehearsal mark should remain clear, so it should not be
moved away from the barline to which it applies, otherwise its position can be misunderstood.
Dorico Pro automatically adjusts staff spacing to ensure rehearsal marks are correctly positioned.

The vertical spacing between the top two staves is increased to allow room for the rehearsal mark and the
tempo marks.

RELATED LINKS
Inputting rehearsal marks on page 296
Input methods for bars and barlines on page 234
Changing the rehearsal mark enclosure type on page 1052

Project-wide engraving options for rehearsal marks
You can find options for the project-wide appearance and position of rehearsal marks on the
Rehearsal Marks page in Engrave > Engraving Options.
For example, you can change the sequence type of rehearsal marks, their default positions, and
whether they are shown in enclosures.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359
Rehearsal mark enclosure size and padding values on page 1053

Changing the rehearsal mark enclosure type
Rehearsal marks are usually shown in an enclosure, which can be a rectangle or a circle. You can
change the enclosure type of all rehearsal marks project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Rehearsal Marks in the page list.

3.

In the Enclosure section, choose one of the following options for Enclosure type:
●

Rectangle

●

Circle

●

No enclosure
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RESULT
The enclosure type of all rehearsal marks in your project is changed. The default size of the
enclosure is relative to the font size of the rehearsal marks, but your padding values also
determine the size and shape of the enclosure.
EXAMPLE

Rehearsal mark with a rectangle
enclosure

Rehearsal mark with a circle
enclosure

Rehearsal mark with no enclosure

Rehearsal mark enclosure size and padding values
You can change the default shape and size of rehearsal mark enclosures on the Rehearsal
Marks page in Engraving Options. You can change the minimum dimensions, line thickness,
and padding values of rehearsal mark enclosures.

All enclosures
Enclosure line thickness
Sets the thickness of enclosure lines for both rectangle and circle enclosures. The
default is 1/8 of a space. The examples have a thickness of 1/2 a space.

Rectangle rehearsal mark enclosure
The figure shows a rectangle rehearsal mark enclosure with default settings. The minimum
height and minimum width are both 4 spaces, horizontal padding is 3/4 of a space, and
minimum bottom and minimum top padding are both 1/8 of a space.

Minimum width
Sets a minimum value for the width of enclosures. In this example, the value was
increased from 4 spaces to 8 spaces.
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Minimum height
Sets a minimum value for the height of enclosures. In this example, the value was
increased from 4 spaces to 8 spaces.

Left and right padding between text and enclosure
Sets the value for the distance between the two sides of the enclosure and the
rehearsal mark within it. In this example, the value was increased from 3/4 of a space
to 3 spaces.

Top padding between text and enclosure
Sets the value for the distance between the top line of the enclosure and the rehearsal
mark within it. In this example, the value was increased from 1/2 a space to 2 spaces.

Bottom padding between text and enclosure
Sets the value for the distance between the bottom line of the enclosure and the
rehearsal mark within it. In this example, the value was increased from 1/8 of a space
to 2 spaces.

Circle rehearsal mark enclosure
The figure shows a circle rehearsal mark enclosure with default settings. The minimum diameter
is 4 spaces, and the minimum padding is 1/4 of a space.

Minimum diameter
Sets a minimum value for the diameter of the enclosure. In this example, the value was
increased from 4 spaces to 8 spaces.
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Minimum padding between text and enclosure
Sets the value for the distance between the enclosure line and the rehearsal mark
within it. In this example, the value was increased from 1/4 of a space to 2 spaces.

Positions of rehearsal marks
Rehearsal marks are placed above the staff and at the same positions as other system objects.
You can move rehearsal marks to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.
You can move rehearsal marks graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all rehearsal marks project-wide, and set values for the
minimum distances between rehearsal marks and staves, and rehearsal marks and other items,
on the Rehearsal Marks page in Engrave > Engraving Options.
Rehearsal marks are categorized as system objects in Dorico Pro, which you can show above the
first bracket of selected instrument families. You can change the instrument families above which
system objects appear in each layout independently, if you want rehearsal marks to appear at
multiple vertical positions in each system in the full score only.
RELATED LINKS
Project-wide engraving options for rehearsal marks on page 1052
Moving rehearsal marks graphically on page 1056
Changing the positions of system objects on page 1173

Moving rehearsal marks rhythmically
You can move rehearsal marks to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the rehearsal marks you want to move.
NOTE
When using the mouse, you can only move one rehearsal mark rhythmically at a time, and
you can only drag it to existing barlines.

2.

Move the rehearsal marks in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the rehearsal mark to barlines to the right/left.

RESULT
A single rehearsal mark is moved to existing barlines to the right/left.
Multiple rehearsal marks are moved according to the current rhythmic grid resolution.
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NOTE
Only one rehearsal mark can exist at each rhythmic position. If a rehearsal mark passes over
another rehearsal mark as part of its move, the existing rehearsal mark is deleted and replaced
by the rehearsal mark being moved.
You can undo this action, but any rehearsal marks deleted in the process are only restored if you
moved the rehearsal mark using the keyboard.

Moving rehearsal marks graphically
You can move rehearsal marks graphically, without changing the rhythmic positions to which
they are attached.
PROCEDURE
1.

In Engrave mode, select the rehearsal marks you want to move.

2.

Move the rehearsal marks in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The graphical positions of the selected rehearsal marks are changed.
TIP
Start offset in the Rehearsal Marks group of the Properties panel is activated automatically
when you move rehearsal marks.
●

Start offset X moves rehearsal marks horizontally.

●

Start offset Y moves rehearsal marks vertically.

You can also use this property to move rehearsal marks by changing the values in the value
fields.
Deactivating the property resets the selected rehearsal marks to their default positions.

Deleting rehearsal marks
You can delete rehearsal marks. Deleting a rehearsal mark in any layout deletes the rehearsal
mark from all layouts.
PROCEDURE
1.

In Write mode, select the rehearsal marks you want to delete.

2.

Press Backspace or Delete .
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RESULT
The selected rehearsal marks are deleted. Any subsequent rehearsal marks are adjusted until the
next change in the sequence or the end of the flow. For example, if you delete the first rehearsal
mark, the second rehearsal mark shows either the letter A, the number 1, or the bar number,
depending on your choice of sequence type.

Changing the order of rehearsal marks
By default, the rehearsal mark sequence resets at the start of each flow. If you want the
rehearsal mark sequence to continue across flows, for example, to avoid having multiple
rehearsal marks with the same letter in the same project, you can change the index position of a
rehearsal mark.
Changing the index position changes the shown number or letter. For example, index position 1
appears as rehearsal mark A or 1, position 2 appears as B or 2, and so on.
You can also change the index position of a rehearsal mark to avoid showing a letter that could
easily be confused with another letter or another number, such as I or O.
PROCEDURE
1.

Select the rehearsal mark whose index position you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Index in the Rehearsal Marks group.

3.

Change the value in the value field.

RESULT
The selected rehearsal mark changes according to the Index value and its sequence type.
Any subsequent rehearsal marks in the same sequence follow the new index automatically. For
example, if you changed a rehearsal mark from A to P, the next rehearsal mark changes from B
to Q.
NOTE
You can also change the sequence type of rehearsal marks, for example, if you want rehearsal
mark C to appear as rehearsal mark 3.

Changing the rehearsal mark sequence type
Rehearsal marks can be letters, numbers, or bar numbers. You can change the sequence type of
individual rehearsal marks, and create secondary rehearsal mark sequences.
In Dorico Pro, you can use all three available rehearsal mark sequences simultaneously. For
example, you can have the main sequence of rehearsal marks showing letters, but also have a
secondary sequence of numbers to mark different moments, perhaps entry points for a solo line,
and also highlight prominent bar numbers within those sections.
TIP
You can change the sequence type used for all rehearsal marks project-wide on the Rehearsal
Marks page in Engraving Options.

PROCEDURE
1.

Select the rehearsal mark whose sequence type you want to change. You can do this in Write
mode and Engrave mode.
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2.

In the Properties panel, activate Sequence type in the Rehearsal Marks group.

3.

Select one of the following options from the menu:
●

Letters

●

Numbers

●

Bar numbers

RESULT
The selected rehearsal mark now displays a letter, a number, or the current bar number.
If it is the first rehearsal mark in either the letters sequence or the numbers sequence in the flow,
it shows either A or 1. If there are already rehearsal marks in either the letters sequence or the
numbers sequence in the flow, it shows the next letter or number according to the index.
NOTE
You can change the index of a rehearsal mark sequence independently of other rehearsal mark
sequences. However, you cannot change the bar number sequence using this method.

RELATED LINKS
Project-wide engraving options for rehearsal marks on page 1052
Adding bar number changes on page 658

Adding prefixes/suffixes to rehearsal marks
You can add both prefixes and suffixes to individual rehearsal marks.
PROCEDURE
1.

Select the rehearsal marks to which you want to add a prefix or suffix. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate one of the following properties in the Rehearsal Marks
group:
●

Prefix

●

Suffix

3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The text you entered into the value field is added to the selected rehearsal marks as a prefix or a
suffix.
TIP
You can add a custom prefix/suffix to all rehearsal marks project-wide on the Rehearsal Marks
page in Engrave > Engraving Options.

Editing the rehearsal mark font style
You can edit the formatting of the font style used for all rehearsal marks project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.
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2.

Select Rehearsal Mark Font from the Font style menu.

3.

Activate the following options, individually or together, to change the corresponding aspect
of the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The formatting of the rehearsal mark font style is changed project-wide.
RELATED LINKS
Edit Font Styles dialog on page 407
Project-wide engraving options for rehearsal marks on page 1052
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Markers are labels locked to a particular position in time, most commonly in relation to a video.
They typically indicate an important moment that requires musical prominence, and composers
often use them to help shape the writing process.

Markers on a timecode staff showing custom text and timecodes

By default, markers in Dorico Pro show the default text “Marker” and also include the timecode of
their fixed position in time.
In Dorico Pro, you can use markers in any project. However, because they are most commonly
used in conjunction with video, markers are included in the Video panel in Write mode. There is
also a Markers track in Play mode that displays markers, and allows you to input new ones.
You can use markers to help find suitable tempos for your project, as Dorico Pro can calculate
possible tempos between important markers so that the markers occur on strong beats in the
time signature.
Any markers you input are automatically included when you export MIDI.
RELATED LINKS
Inputting markers/timecodes on page 297
Editing marker text on page 1062
Markers section of the Video panel on page 297
Markers track on page 537
Find Tempo dialog on page 299
Defining markers as important on page 1064

Project-wide engraving options for markers
You can find options controlling the project-wide design, position, and appearance of markers on
the Markers page in Engrave > Engraving Options.
For example, you can change whether markers include the timecode of their position, whether
markers are shown above or below timecodes, the thickness of the enclosure line, and the
default vertical position of markers.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
RELATED LINKS
Engraving Options dialog on page 359
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Hiding/Showing markers
By default, markers are shown in full score layouts and hidden in part layouts. You can hide and
show markers in each layout independently, for example, if markers are helpful for the
conductor to see but not for the players.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show markers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Markers and Timecode in the page list.

4.

Activate/Deactivate Show markers.

5.

Click Apply, then Close.

RESULT
Markers are hidden/shown in the selected layouts.

Changing the vertical position of markers
You can show markers above the system, below the system, or on a separate single-line staff
above a selected bracketed instrument family group, which can make them clearer in the score.
When markers are shown on a separate staff, timecodes are also automatically shown below the
separate staff.
NOTE
You cannot show multiple timecode staves in a system.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the vertical position of
markers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Markers and Timecode in the page list.

4.

In the Markers subsection, choose one of the following options for Vertical position:
●

Above system

●

Below system

●

Timecode staff

5.

Optional: If you chose Timecode staff, select the bracketed instrument family above which
you want to show the timecode staff from the Position timecode staff above bracket
menu.

6.

Click Apply, then Close.

RESULT
The vertical position of markers is changed in the selected layouts.
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NOTE
●

If you show markers on a timecode staff, timecodes are also shown on the staff by default. If
you only want to show markers on a separate staff and exclude timecodes, you must then
change Timecode frequency on timecode staff to Never.
You can also change the vertical position of timecodes so they appear above/below the start
of systems rather than on the timecode staff.

●

You can change the default distance between the timecode staff and other staves on the
Vertical Spacing page in Setup > Layout Options.

AFTER COMPLETING THIS TASK
●

You can edit the font used for markers and timecodes shown on a timecode staff.

●

You can change the frequency of timecodes on the timecode staff.

RELATED LINKS
Changing the timecode frequency on page 1069
Changing the vertical position of timecodes on page 1067
Hiding/Showing timecodes in markers on page 1068
Editing the marker/timecode font styles on page 1063

Editing marker text
The default text shown in new markers is “Marker”. You can change the text shown in each
marker individually.
PROCEDURE
1.

Select the markers whose text you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Marker text in the Markers group.

3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The text shown in the selected markers is changed. It uses the Marker Text Font font style.
TIP
You can also enter custom text for markers when inputting them using the Add Marker dialog,
and change marker text in the Markers section of the Video panel in Write mode.

RELATED LINKS
Add Marker dialog on page 298
Markers section of the Video panel on page 297
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Editing the marker/timecode font styles
You can edit the formatting of the font styles used for all markers and timecodes project-wide,
for example, if you want markers to appear bold and italic. Markers and timecodes use different
fonts, meaning you can change them independently of each other.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2.

Select one of the following font styles from the Font style menu:

3.

●

Marker Text Font: Used for markers

●

Marker Timecode Font: Used for timecodes shown in markers

●

Timecode Font: Used for timecodes shown on a timecode staff

Activate the following options, individually or together, to change the corresponding aspect
of the font:
●

Font family

●

Size

●

Style

●

Underlined

4.

Optional: If required, repeat steps 2 and 3 to change the other font.

5.

Click OK to save your changes and close the dialog.

RESULT
The formatting of the selected font styles is changed project-wide.
RELATED LINKS
Edit Font Styles dialog on page 407

Changing the timecodes of markers
You can change the timecode of markers, for example, if the video is edited and the marker now
occurs ten seconds later.
NOTE
Because this changes where markers occur in the project, this also moves markers relative to the
notated music.

PROCEDURE
1.

In Write mode, click Video in the Notations toolbox to show the Video panel.

2.

In the Markers section, double-click the timecode you want to change.

3.

Enter the new timecode you want into the value field.

4.

Press Return .

RESULT
The timecode of the marker is changed. The marker automatically moves relative to the music to
reflect its new time position.
RELATED LINKS
Markers section of the Video panel on page 297
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Moving markers rhythmically
You can move markers to new rhythmic positions. However, as markers have a fixed position in
time, moving markers relative to the notated music automatically changes the tempo on either
side of the marker.
TIP
If you want to move a marker to a new time position, for example, if you want to move it from 25
seconds to 28 seconds, you must change the timecode of the marker.

PROCEDURE
1.

In Write mode, select the marker you want to move.
NOTE
You can only move one marker at a time.

2.

Move the marker according to the current rhythmic grid resolution in any of the following
ways:
●

Press Alt/Opt-Right Arrow to move it to the right.

●

Press Alt/Opt-Left Arrow to move it to the left.

●

Click and drag it to the right/left.

RESULT
The selected marker is moved to a new rhythmic position. However, its fixed position in time is
not changed. Therefore, the tempo immediately preceding the marker automatically updates so
that the marker occurs at the correct time. For example, moving a marker to the right increases
the preceding tempo.
Any gradual tempo changes between the preceding tempo change or the start of the flow and
the marker are removed.
NOTE
The tempo change affects the positions of all other markers in the flow relative to the notated
music.

RELATED LINKS
Inputting markers/timecodes on page 297

Defining markers as important
You can define individual markers as important, which allows them to be considered when
finding suitable tempos in the Find Tempo dialog.
PROCEDURE
1.

In Write mode, click Video in the Notations toolbox to show the Video panel.

2.

In the Markers section, activate the checkbox in the Imp. column for each marker you want
to define as important.

RESULT
Markers with activated checkboxes are defined as important. The Find Tempo button at the
bottom of the Markers section becomes available.
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RELATED LINKS
Find Tempo dialog on page 299
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Timecodes indicate an exact position in time, usually in the context of a video. They allow precise
synchronization between multiple elements, such as music and moving images, and can be used
as a reference tool.
Timecodes are displayed in the format hh:mm:ss:ff, which is two-digit hours, minutes, seconds,
and frames.

A timecode on a timecode staff

In Dorico Pro, you can specify the type of timecode from the following types:
Non-drop frame timecodes
Each frame is numbered sequentially from the preceding one without skipping any
frame numbers.
Non-drop frame timecodes are shown with the suffix fps and use a colon separator
between seconds and frames, for example, 00:00:01:05.
Drop frame timecodes
Some frame numbers are skipped in order to accommodate the difference in frame
rate between 29.97 fps and 30 fps. In every minute except every tenth minute, two
timecode numbers are dropped from the frame count.
Drop frame timecodes are shown with the suffix dfps and use a semicolon separator
between the seconds and frames, for example, 00:00:01;05.
Timecodes in Dorico Pro are flow-specific, meaning you can set timecodes for each flow that are
completely independent of the timecodes for other flows. You can set timecodes in the Video
Properties dialog, including for flows without a video.
NOTE
The timecodes shown in flow cards in the Flows panel in Setup mode reflect the timecode at the
start of the flow, which can be different to the timecode you set in the Video Properties dialog.
For example, if you set the Timecode start to 02:00:00:00 but also set the Flow attachment
position to 8 quarter note beats, and the tempo is 60 bpm, the timecode shown in the flow card
is 01:59:52:00.

By default, timecodes appear in markers. You can show additional markers above/below the start
of each system or below the timecode staff, if there is one, in each layout independently. You can
also hide/show timecodes in markers.
Additionally, you can change the time displayed in the Transport window to be the timecode
rather than elapsed time, which is shown by default.
RELATED LINKS
Frame rates on page 151
Video Properties dialog on page 147
Editing the marker/timecode font styles on page 1063
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Changing the initial timecode value
Changing the timecode frequency on page 1069
Changing the content shown in the transport display on page 558
Markers on page 1060
Changing the vertical position of markers on page 1061
Changing the vertical position of timecodes on page 1067
Hiding/Showing timecodes in markers on page 1068

Changing the initial timecode value
You can change the timecode at which each flow in your project starts, for example, if you are
using a separate project for the second reel of a film. You can also change the initial timecode in
projects without videos.
PROCEDURE
1.

In Write mode, select an item in the flow whose initial timecode value you want to change.

2.

In the Notations toolbox, click Video to show the Video panel.

3.

In the Video panel, click Properties to open the Video Properties dialog.

4.

In the Video Properties dialog, change the value for Timecode start.

5.

Click OK to save your changes and close the dialog.

RESULT
The initial timecode for the flow in which you selected an item is changed.
RELATED LINKS
Timecodes on page 1066
Changing the start position of videos on page 148

Changing the vertical position of timecodes
You can show timecodes either above/below the start of systems or on a separate single-line
staff, for example, if you might want to show timecodes above the start of systems in part
layouts without showing markers or a separate timecode staff.
NOTE
You cannot show timecodes on multiple staves in a system.
PREREQUISITE
If you want to show timecodes on a separate staff, you have changed the vertical position of
markers so they appear on a separate staff.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the vertical position of
timecodes.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Markers and Timecode in the page list.
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4.

5.

In the Timecode subsection, choose one of the following options for Show timecode:
●

Above or below start of system

●

Below timecode staff

If you chose Above or below start of system, choose one of the following options for
Timecode position relative to system:
●

Above system

●

Below system

6.

Optional: If you chose Above or below start of system, change the gap between timecodes
and the staff by changing the values in the Offset at start of system value fields.

7.

Click Apply, then Close.

RESULT
The vertical position of timecodes is changed in the selected layouts.
NOTE
Your setting for Timecode frequency on timecode staff also applies when timecodes are shown
above/below the start of systems.

RELATED LINKS
Changing the vertical position of markers on page 1061

Hiding/Showing timecodes in markers
You can hide/show timecodes within all markers project-wide and show them above/below the
marker text, for example, to ensure the precise positions of key moments are clearly labeled. This
is in addition to your per-layout settings for showing timecodes on a separate staff.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Markers in the page list.

3.

Choose one of the following options for Timecode in markers:

4.

5.

●

Show timecode

●

Do not show timecode

Optional: Choose one of the following options for Order of information, if timecode
shown:
●

Text above timecode

●

Timecode above text

Click Apply, then Close.

RELATED LINKS
Markers on page 1060
Changing the vertical position of timecodes on page 1067
Changing the vertical position of markers on page 1061
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Changing the timecode frequency
You can show timecodes at different intervals in layouts in which timecodes are shown on a
separate staff. For example, you can show timecodes every bar in full score layouts but only at
the start of each system in part layouts.
NOTE
We do not recommend that you show timecodes every bar in layouts with multi-bar rests, as the
result is illegible overlapping timecodes. If you want to show timecodes in part layouts with
multi-bar rests, we recommend either showing timecodes only at the start of each system or not
showing multi-bar rests in the layout.
PREREQUISITE
Markers are shown in the selected layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the timecode frequency.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Markers and Timecode in the page list.

4.

Optional: If the selected layouts do not show timecodes on a separate staff, choose
Timecode staff for Vertical position.

5.

Choose one of the following options for Timecode frequency on timecode staff:

6.

●

Start of system

●

Every bar

●

Never

Click Apply, then Close.

RELATED LINKS
Hiding/Showing markers on page 1061
Hiding/Showing multi-bar rests on page 1113
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For music with repeated passages, repeat endings show which bars are played at the end of each
repetition, with different endings each time if required. They are also known as “volta lines”, or as
“first and second endings”, but in this documentation, we refer to them as “repeat endings”.
Repeat endings comprise two or more segments, where each segment contains a different
possible ending. When you input repeat endings, Dorico Pro automatically inputs an end repeat
barline at the end of the first segment. Segments in repeat endings are clearly marked with solid
lines above and number that indicate the playthroughs in which the segment is used.

A repeat ending with three possible endings

Dorico Pro allows you to create repeat endings containing any number of segments, and allows
you to control which segments are used for each playthrough. For example, you might want a
repeat ending with two segments but four total playthroughs, where the first two playthroughs
use the first repeat ending segment and the final two playthroughs use the second repeat
ending segment.
In Dorico Pro, repeat endings are categorized as system objects. Therefore, repeat endings
follow your per-layout settings for the visibility and positioning of system objects, which you can
change on the Staves and Systems page in Setup > Layout Options.
RELATED LINKS
Input methods for repeats and tremolos on page 300
Dividing playthroughs across repeat ending segments on page 1071
System objects on page 1172
Changing the positions of system objects on page 1173
Lines on page 1033

Changing the total number of playthroughs in repeat
endings
By default, each segment in repeat endings is played once, so each segment shows a single digit
that indicates the playthrough for which it is used. You can increase the total number of
playthroughs for repeat endings individually so that segments are played more than once.
PROCEDURE
1.

Select the repeat endings whose total number of playthroughs you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate No. times played in the Repeat Endings group.

3.

Change the value in the value field.
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NOTE
You cannot have fewer playthroughs than the number of segments.

RESULT
The total number of playthroughs in the selected repeat endings is changed. By default, Dorico
Pro adds any playthroughs not already assigned to specific segments to the last closed segment
in the repeat ending.
AFTER COMPLETING THIS TASK
Once you have set the total number of playthroughs, you can then change which segment is
used for each playthrough.
RELATED LINKS
Repeats in playback on page 548

Dividing playthroughs across repeat ending segments
You can control how the total number of playthroughs is divided across the different segments in
individual repeat endings.
PROCEDURE
1.

In Engrave mode, select an individual segment in the repeat ending structure whose
included playthroughs you want to change.

2.

In the Properties panel, activate Times played for segment in the Repeat Endings group.

3.

Enter the number of each playthrough that you want to include in the selected segment.
For example, for a repeat ending with six playthroughs, enter 4,5,6 to include the 4th, 5th,
and 6th playthroughs in the second segment.

RESULT
The playthroughs included in the selected segment are changed.
EXAMPLE

Default distribution of playthroughs

Customized distribution of playthroughs

Project-wide engraving options for repeat endings
You can find options controlling the project-wide design, position, and appearance of repeat
ending segments on the Repeat Endings page in Engrave > Engraving Options.
The options on the Repeat Endings page allow you to change the ends of repeat ending lines,
the appearance of numbers and hooks, and the default position of repeat endings.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
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RELATED LINKS
Engraving Options dialog on page 359

Lengthening/Shortening segments in repeat endings
You can increase/decrease the number of bars included in each segment of repeat endings by
lengthening/shortening each segment independently.
PROCEDURE
1.

In Write mode, select the repeat ending you want to lengthen/shorten.
NOTE
You can only lengthen/shorten one repeat ending segment at a time.

2.

Select the circular handle at the end of the segment you want to lengthen/shorten.

The selected handle in the middle has a thicker line.

3.

Click and drag the handle to the right/left to snap it to the next/previous barline.
NOTE
Segments must contain at least one bar.

4.

Optional: Repeat steps 1 to 3 for each segment in the repeat ending.

RESULT
The selected segment is lengthened/shortened.
NOTE
●

This does not automatically input or reposition repeat barlines. You must input repeat
barlines as appropriate manually.

●

You can also lengthen/shorten the final segment in a single repeat ending by selecting the
repeat ending and using the following key commands:
●

Press Shift-Alt/Opt-Right Arrow to lengthen the final segment.

●

Press Shift-Alt/Opt-Left Arrow to shorten the final segment.

RELATED LINKS
Moving repeat endings graphically on page 1074

Positions of repeat endings
Repeat endings are placed above the staff at the same positions as other system objects, and
their hooks align with barlines. They are commonly positioned outside of other notations, but
some long items, such as gradual tempo changes, can be placed above repeat endings.
You can change the positions of repeat endings individually and by changing their default
positions project-wide. For example, you can override the default position for individual repeat
endings if the musical material at those positions requires more vertical space.
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You can move repeat endings to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.
You can move each repeat ending segment graphically in Engrave mode and independently of
other segments in the repeat ending; however, this does not change the rhythmic positions to
which they are attached.
You can change the default appearance and position of all repeat endings project-wide on the
Repeat Endings page in Engrave > Engraving Options.
Repeat endings are categorized as system objects in Dorico Pro, which you can show above the
first bracket of selected instrument families. You can change the instrument families above which
system objects appear in each layout independently, for example, if you want repeat endings to
appear at multiple vertical positions in each system in the full score only.
RELATED LINKS
Project-wide engraving options for repeat endings on page 1071
Moving repeat endings graphically on page 1074
System objects on page 1172
Changing the positions of system objects on page 1173

Moving repeat endings rhythmically
You can move repeat endings to different rhythmic positions after they have been input so they
apply to different bars.
PROCEDURE
1.

In Write mode, select the repeat ending you want to move.
NOTE
You can only move one repeat ending rhythmically at a time.

2.

Move the repeat ending to the next/previous bar in any of the following ways:
●

Press Alt/Opt-Right Arrow to move it to the right.

●

Press Alt/Opt-Left Arrow to move it to the left.

●

Click and drag it to the right/left.

RESULT
The selected repeat ending is moved to the next/previous bar.
NOTE
●

This does not automatically input or reposition repeat barlines. You must input repeat
barlines manually as appropriate.

●

Only one repeat ending can exist at each rhythmic position. If any part of a selected repeat
ending collides with any part of another repeat ending as part of its move, the other repeat
ending is deleted. However, its repeat barlines are not deleted.
You can undo this action, but any repeat endings deleted in the process are only restored if
you moved the repeat ending using the keyboard.
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Moving repeat endings graphically
You can move repeat endings graphically without changing their rhythmic positions. You can also
move the start/end of repeat ending segments independently, meaning you can lengthen/
shorten them graphically.
In Engrave mode, each repeat ending segment has two square handles, one at the start and one
at the end.
If repeat ending segments cross system and frame breaks, you can move the segments on each
side of the break independently.

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Repeat ending segments

●

Individual handles on repeat ending segments

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the repeat ending segments or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected repeat ending segments or handles are moved graphically.
TIP
The following properties in the Repeat Endings group of the Properties panel are activated
automatically when you move repeat ending segments in the corresponding directions:
●

Start X offset moves start repeat ending segment handles horizontally.

●

End X offset moves end repeat ending segment handles horizontally.

●

Y offset moves whole repeat ending segments vertically.

For example, if you move a whole repeat ending segment to the right, both handles are moved,
so Start X offset and End X offset are both activated. You can also use all three properties to
move and lengthen/shorten repeat endings graphically by changing the values in the value
fields.
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Deactivating the properties resets the selected repeat ending segments to their default
positions.

RELATED LINKS
Moving repeat endings rhythmically on page 1073
Lengthening/Shortening segments in repeat endings on page 1072

Editing repeat ending text
You can replace the text shown in individual segments in repeat endings with custom text. By
default, it shows the playthrough numbers for the segment.
PROCEDURE
1.

In Engrave mode, select the repeat ending segments whose text you want to change.

2.

In the Properties panel, activate Custom text in the Repeat Endings group.

3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The text shown in the selected segments is changed.
Deactivating Custom text restores the default text for the selected repeat ending segments.
NOTE
Deactivating properties permanently deletes any custom text entered.

Changing the appearance of individual final repeat ending
segments
You can change the appearance of the line ends in the final segments of individual repeat
endings, independently of your project-wide settings.
PROCEDURE
1.

Select the repeat endings whose final segment appearance you want to change. You can do
this in Write mode and Engrave mode.
NOTE
In Engrave mode, you can select any segment in the repeat ending.

2.

In the Properties panel, activate End of line in the Repeat Endings group.

3.

Select one of the following options from the menu:
●

Open, short

●

Open, full length

●

Closed

RESULT
The end of the line of the final segment in the selected repeat endings is changed.
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TIP
You can change the appearance of final segments in all repeat endings project-wide in the
Segments section of the Repeat Endings page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for repeat endings on page 1071

Lengthening/Shortening repeat ending hooks
You can lengthen/shorten the hooks in repeat endings individually, independently of your
project-wide settings.
NOTE
You cannot change the hook length of an individual segment in a repeat ending. Changing the
hook length affects the whole repeat ending.

PROCEDURE
1.

In Engrave mode, select the repeat endings whose hooks you want to lengthen/shorten.

2.

In the Properties panel, activate Hook length in the Repeat Endings group.

3.

Change the value in the value field.

RESULT
Increasing the value makes repeat ending hooks longer. Decreasing the value makes repeat
ending hooks shorter.
TIP
You can change the default length of all repeat ending hooks project-wide on the Repeat
Endings page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for repeat endings on page 1071

Repeat endings in MusicXML files
All aspects of repeat endings can be imported from and exported in MusicXML files.
However, while MusicXML can represent this, segments in the middle of sets of endings cannot
have an open right-hand end in Dorico Pro.
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Repeat markers show that musical material is to be repeated, but unlike repeat endings, repeat
markers often involve jumping to different positions and sections in the music instead of moving
through the music consecutively.

In Dorico Pro, repeat markers are divided into the following types:
Repeat jumps
Specify the position from which players or playback must jump, such as D.C. al Coda.
You can qualify the conditions under which repeat jumps are used, such as “second
time only”.
Repeat jumps are right-aligned with their rhythmic position, meaning their text or
symbol ends at that rhythmic position and extends to the left.

Repeat sections
Specify the destinations for jumps, such as segno or coda, or where the music should
end, such as Fine. In Dorico Pro, coda sections that start mid-system are automatically
separated from the preceding music with a gap.
Repeat markers are left-aligned with their rhythmic position, meaning their text or
symbol starts at that rhythmic position and extends to the right.

By default, repeat markers are shown on a single line, but you can show them on two lines
individually to reduce their horizontal length if necessary. You can also customize their
paragraph styles, including changing their font size, in the Paragraph Styles dialog and use the
options on the Repeat Markers page in Engrave > Engraving Options to customize their
appearance.
RELATED LINKS
Input methods for repeats and tremolos on page 300
Showing repeat markers on one/two lines on page 1080
Paragraph Styles dialog on page 410
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Project-wide engraving options for repeat markers
Repeats in playback on page 548

Project-wide engraving options for repeat markers
You can find options controlling the project-wide design, position, and appearance of repeat
markers on the Repeat Markers page in Engrave > Engraving Options.
The options on the Repeat Markers page allow you to change the appearance, design, and
length of repeat markers, the default gap before coda sections that start mid-system, and their
default position. You can also change the order of symbols and text in repeat markers, the scale
size of symbols compared to text, and the letter case for repeat marker text.
The following appearance presets are provided in the Repeat Markers Preset section:
●

Standard: Based on the most commonly-used conventions in current rock/pop sheet music
publishing, which produce shorter, more abbreviated instructions.

●

Gould: Based on the recommendations made in Elaine Gould’s book “Behind Bars”, which is
better suited for classical and concert music as it produces longer, more explicit instructions.
NOTE
Gould also recommends placing repeat markers below the staff instead of above it.

●

Custom: A mixture of settings according to your preference. This preset is automatically
selected when you override an appearance preset by changing individual options.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359
Changing the staff-relative placement of repeat markers on page 1083

Repeat marker paragraph styles
Repeat markers use paragraph styles to format their fonts, including their size, spacing,
alignment, and other formatting options. Because the different types of repeat markers require
different formatting, they each have a separate paragraph style by default.
Dorico Pro provides the following default paragraph styles for repeat markers:
●

Repeat Marker Jumps: The default paragraph style used for repeat jumps, such as D.C. al
Coda.

●

Repeat Marker Sections: The default paragraph style used for repeat sections, such as a
coda.

By default, the formatting of these paragraph styles is the same but you can edit paragraph
styles independently of each other in the Paragraph Styles dialog, for example, if you want to
decrease the size of repeat jumps but leave repeat sections with their default size.
NOTE
The Repeat Marker Jumps paragraph style inherits settings from the Repeat Marker Sections
style. If you change the Repeat Marker Sections paragraph style, this also affects any
corresponding options for the Repeat Marker Jumps paragraph style that have not been
overridden.
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RELATED LINKS
Paragraph Styles dialog on page 410
Editing repeat marker text on page 1080
Showing repeat markers on one/two lines on page 1080

Changing the size of coda/segno symbols
You can change the default size of all coda and segno symbols project-wide and independently of
each other. This does not affect the size of text in repeat markers.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Repeat Markers in the page list.

3.

In the Design section, change the value for Scale factor for coda symbols.

4.

Change the value for Scale factor for segno symbols.

5.

Click Apply, then Close.

RESULT
The size of coda and segno symbols relative to repeat marker text is changed project-wide.

Changing the index for repeat markers
You can change the index of individual repeat markers, for example, if a flow requires two
different codas with different symbols so players can tell them apart.
By default, all repeat markers of the same type have the same appearance, even when there are
multiple repeat markers in the flow.
NOTE
You cannot change the index of Fine or D.C. repeat markers.

PROCEDURE
1.

Select the repeat marker whose index you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together as
appropriate for your selection, in the Repeat Markers section:

3.

●

Marker index

●

‘Jump to’ index

Change the values in the value fields.
NOTE
You can only enter values between 1 and 3.

RESULT
Marker index changes the order of the selected repeat marker relative to other repeat markers
of the same type.
‘Jump to’ index changes the destination of the selected repeat marker.
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TIP
You can change the default appearance of all multiple repeat markers project-wide in the Repeat
Sections section of the Repeat Markers page in Engrave > Engraving Options.
EXAMPLE
If you have two codas in a flow with two different D.S. al Coda markers, you might set Marker
index to 1 for the first coda and 2 for the second, then set ‘Jump to’ index to 1 for the first D.S. al
Coda marker and 2 for the second.

D.S. al Coda marker with default indexes

D.S. al Coda marker with both indexes set to 2

RELATED LINKS
Project-wide engraving options for repeat markers on page 1078

Editing repeat marker text
You can change the text shown in individual repeat markers, for example, if you are typesetting a
score with an unusual repeat marker instruction.
PROCEDURE
1.

Select the repeat markers whose text you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Custom text in the Repeat Markers group.

3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The text shown in the selected repeat markers is changed. This replaces the text in the selected
repeat markers without removing any symbols.
RELATED LINKS
Project-wide engraving options for repeat markers on page 1078

Showing repeat markers on one/two lines
You can show individual repeat markers either on a single line or spread across two lines
independently of your per-layout settings, for example, if a single long repeat marker extends
beyond the page margins in one part layout.
NOTE
You can only change the word wrapping of repeat jumps, such as D.C. al Fine and D.S. al Coda,
that do not have custom text.

PROCEDURE
1.

In Engrave mode, select the repeat markers whose word wrapping you want to change.
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2.

In the Properties panel, activate Word wrap in the Repeat Markers group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
The selected repeat markers are shown on two lines when the checkbox is activated, and on one
line when the checkbox is deactivated.
When the property is deactivated, repeat markers follow your per-layout setting for word
wrapping.
TIP
You can show all repeat markers on two lines in each layout independently in the Repeat
Markers section of the Staves and Systems page in Setup > Layout Options. For example, you
can show them on one line in the full score but on two lines in part layouts.
EXAMPLE

Repeat marker with word wrapping

Repeat marker without word wrapping

RELATED LINKS
Layout Options dialog on page 104

Changing the barline shown before codas
You can change the default barline shown before all codas project-wide that are preceded by a
repeat jump, for example, if you want to show double barlines in such cases instead of normal
barlines.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Barlines in the page list.

3.

In the Repeats section, choose one of the following options for Barline coinciding with
repeat jump before Coda:

4.

●

Double barline

●

Single barline

Click Apply, then Close.

RESULT
The barline shown automatically before codas immediately preceded by a repeat jump is
changed project-wide.
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Positions of repeat markers
Repeat markers are placed above the staff by default, and at the same positions as other system
objects. Coda sections are separated from the preceding music by a gap in the system.
You can move repeat markers to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.
You can move repeat markers graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached. You can adjust the size of individual mid-system
gaps before codas by adjusting the note spacing at their rhythmic positions in Engrave mode.
You can change the default positions of all repeat markers project-wide, set values for the
minimum distances between repeat markers and staves and other items, and set the default gap
preceding coda sections on the Repeat Markers page in Engrave > Engraving Options. Dorico
Pro uses the same gap size before the start of codas whether they occur partway through
systems or at the start of a new system.
You can change the default staff-relative placement of repeat markers in each layout
independently in the Repeat Markers section of the Staves and Systems page in Setup >
Layout Options.
Repeat markers are categorized as system objects in Dorico Pro, which you can show above the
first bracket of selected instrument families. You can change the instrument families above which
system objects appear in each layout independently, for example, if you want repeat markers to
appear at multiple vertical positions in each system in the full score only.
RELATED LINKS
Project-wide engraving options for repeat endings on page 1071
Adjusting note spacing at individual rhythmic positions on page 429
Changing the staff-relative placement of repeat markers on page 1083
Changing the positions of system objects on page 1173

Moving repeat markers rhythmically
You can move repeat markers to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the repeat markers you want to move.
NOTE
When using the mouse, you can only move one repeat marker rhythmically at a time.

2.

Move the selected repeat markers according to the current rhythmic grid resolution in any of
the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the repeat marker to the right/left.

RESULT
The selected repeat markers are moved to new rhythmic positions.
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Moving repeat markers graphically
You can move repeat markers graphically, without changing the rhythmic positions to which they
are attached.
PROCEDURE
1.

In Engrave mode, select the repeat markers you want to move.

2.

Move the repeat markers in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The graphical positions of the selected repeat markers are changed.
TIP
Start offset in the Repeat Markers group of the Properties panel is activated automatically
when you move repeat markers.
●

Start offset X moves repeat markers horizontally.

●

Start offset Y moves repeat markers vertically.

You can also use this property to move repeat markers by changing the values in the value fields.
Deactivating the property resets the selected repeat markers to their default positions.

RELATED LINKS
Positions of repeat markers on page 1082

Changing the staff-relative placement of repeat markers
You can show repeat markers either above, below, or both above and below the staff in each
layout independently.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the staff-placement of
repeat markers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Repeat Markers section, choose one of the following options for Default placement
for repeat jumps and ‘Fine’:
●

Above staff

1083
Dorico Pro 3.1.10

Repeat markers
Including/Excluding repeats in playback after repeat jumps

5.

●

Below staff

●

Above and below bottom staff

Click Apply, then Close.

RESULT
The staff-relative placement of all repeat markers is changed in the selected layouts.

Including/Excluding repeats in playback after repeat jumps
By default, Dorico Pro plays back all playthroughs in all types of repeat structures. You can
manually include/exclude repeats indicated by repeat markers, repeat endings, and repeat
barlines in playback after individual repeat jumps, independently of your project-wide setting.
NOTE
You can only include/exclude repeats after repeat jumps, such as D.C. al Fine and D.S. al Coda.

PROCEDURE
1.

Select the repeat jumps after which you want to include/exclude repeats in playback. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Replay repeats in the Repeat Markers group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Repeats are included in playback after the selected repeat jumps when the checkbox is activated,
and excluded from playback when the checkbox is deactivated.
When the property is deactivated, repeat markers follow your project-wide setting for including
repeats in playback after repeat jumps.
TIP
You can include/exclude all repeats after all repeat jumps project-wide on the Repeats page in
Play > Playback Options.

RELATED LINKS
Playback Options dialog on page 502

Changing the number of playthroughs at repeat barlines
End repeat barlines typically indicate that the preceding music is played through twice. You can
change the number of playthroughs for each end repeat barline individually.
PROCEDURE
1.

Select the end repeat barlines whose number of playthroughs you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Play n times in the Time Signatures group.

3.

Change the value in the value field.
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NOTE
The minimum value is 2.

RESULT
The number of times the music preceding the selected end repeat barlines is played through is
changed. A marker is shown at system object positions that indicates the number of
playthroughs set when this is 3 or more.
EXAMPLE

Final repeat barline with the default 2 playthroughs
set

Final repeat barline with 4 playthroughs set and
marker shown

RELATED LINKS
Including/Excluding repeats in playback after repeat jumps on page 1084
Changing the total number of playthroughs in repeat endings on page 1070
Repeats in playback on page 548
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Bar repeats indicate that the musical material in preceding bars must be repeated exactly, but
without notating that material again. Bar repeats can comprise groups of one, two, or four bars.
For example, a one-bar repeat indicates that the material in one bar is repeated, meaning every
bar in the region repeats the same material. A four-bar repeat indicates that the material in the
previous four bars is repeated.

One-bar repeat region

Two-bar repeat region

Four-bar repeat region

This notational short-hand can make repetitive music easier to read, as performers must only
read the repeated phrase once and then simply count how many times they repeat it. Bar
repeats can also save horizontal space, as bar repeat symbols are usually narrower than the
equivalent fully written-out bars.
In Dorico Pro, bar repeat regions are used to display bar repeats, meaning as many bar repeat
symbols as necessary to fill the region are shown automatically.
In Write mode, each region has a handle at the start and end, which you can use to move and
lengthen/shorten regions.
By default, bar repeat regions are highlighted with a colored background. As you zoom out, the
highlights become more opaque, which is especially useful when viewing full score layouts in
galley view. These highlights are considered annotations, are not printed by default, and you can
hide and show them.
You can also show adjacent bar repeat regions, for example, if you want to use a two-bar repeat
in the first iteration of a phrase, and then a four-bar repeat to indicate the whole phrase is
repeated. When two different bar repeat regions are adjacent, they alternate highlight colors to
ensure the separate regions are always identifiable.

Phrase containing two adjacent bar repeat regions

RELATED LINKS
Inputting bar repeats on page 312
Repeats popover on page 301
Bar repeat counts on page 1089
Bar repeat grouping on page 1093
Hiding/Showing bar repeat region highlights on page 1089
Moving bar repeat regions on page 1088
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Lengthening/Shortening bar repeat regions on page 1088
Hiding/Showing multi-bar rests on page 1113
Annotations on page 610

Project-wide engraving options for bar repeats
You can find options controlling the project-wide design and appearance of bar repeats on the
Bar Repeats page in Engrave > Engraving Options.
The options on the Bar Repeats page allow you to change the frequency of bar repeat counts,
the appearance of bar repeat counts, and how bar repeats are grouped when a four-bar phrase
contains a single bar followed by a three-bar repeat.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
RELATED LINKS
Engraving Options dialog on page 359

Changing the length of the repeated phrase in bar repeat
regions
You can change the number of bars that make up the repeated phrase in individual bar repeats
after you have input them, for example, if you want the region to repeat the previous two bars
rather than the previous four bars.
NOTE
You cannot repeat more bars than exist before the bar repeat region. For example, if a bar
repeat region follows the first notated bar in a flow, you cannot increase the number of bars in
the repeated phrase.

PROCEDURE
1.

Select the bar repeat regions whose phrase length you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, select one of the following options from the No. bars menu in the
Bar Repeat Regions group:
●

One bar

●

Two bars

●

Four bars

RESULT
The number of bars that make up the repeated phrase in the selected bar repeat regions is
changed. This is also reflected in playback.
TIP
●

Any dynamics you add within bar repeat regions affect the playback of the repeated music.

●

You can also change the length of the repeated phrase by opening the repeats popover and
changing the entry.

1087
Dorico Pro 3.1.10

Bar repeats
Moving bar repeat regions
RELATED LINKS
Bar repeat grouping on page 1093
Inputting bar repeats on page 312
Repeats popover on page 301
Changing existing items on page 329

Moving bar repeat regions
You can move bar repeat regions to different rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the bar repeat region you want to move.
NOTE
You can only move one bar repeat region at a time.

2.

Move the bar repeat region to other bars in any of the following ways:
●

Press Alt/Opt-Right Arrow to move it to the right.

●

Press Alt/Opt-Left Arrow to move it to the left.

●

Click and drag it to the right/left.

RESULT
The selected bar repeat region is moved to bars to the right/left.
When you move bar repeat regions using the keyboard, they are moved to the right by the
duration of their grouping, for example, two-bar repeats are moved two bars to the right.
However, when you move them to the left, they are always moved to the next bar, regardless of
their grouping.
When you move bar repeat regions using the mouse, they are always moved to the next/
previous bar.
NOTE
Only one bar repeat region can exist at each rhythmic position. If any part of a selected bar
repeat region collides with any part of another bar repeat region as part of its move, the other
bar repeat region is shortened to accommodate the one you moved. In some cases, this means
the grouping of the other bar repeat region is changed or it is deleted entirely.
You can undo this action and restore the previous length of the other bar repeat region.

Lengthening/Shortening bar repeat regions
You can lengthen/shorten bar repeat regions after they have been input.
PROCEDURE
1.

In Write mode, select the bar repeat region you want to lengthen/shorten.
NOTE
You can only lengthen/shorten one bar repeat region at a time.

2.

Lengthen/Shorten the bar repeat region in any of the following ways:
●

To lengthen it by the duration of its grouping, press Shift-Alt/Opt-Right Arrow .
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●

To shorten it by the duration of its grouping, press Shift-Alt/Opt-Left Arrow .
NOTE
Key commands lengthen/shorten items by moving their end only.

●

Click and drag the start/end handle to the next/previous bar.

RESULT
The selected bar repeat region is lengthened/shortened.
NOTE
●

The minimum length of a bar repeat region is one bar. If you shorten regions with longer
groupings, such as every four bars, the length of the region is halved until a one-bar repeat
region remains.

●

Only one bar repeat region can exist at each rhythmic position. If any part of a selected bar
repeat region collides with any part of another bar repeat region when it is lengthened/
shortened, the other bar repeat region is shortened to accommodate this. In some cases,
this means the grouping of the other bar repeat region is changed or it is deleted entirely.
You can undo this action and restore the previous lengths of all bar repeat regions involved.

RELATED LINKS
Bar repeats on page 1086
Bar repeat grouping on page 1093
Hiding/Showing multi-bar rests on page 1113

Hiding/Showing bar repeat region highlights
You can hide/show colored highlights for bar repeat regions at any time, for example, if you want
to show the highlights when inputting music but hide them when engraving.
PROCEDURE
●

Choose View > Highlight Bar Repeat Regions.

RESULT
Highlights on bar repeat regions are shown when a tick appears beside Highlight Bar Repeat
Regions in the menu, and hidden when no tick appears.

Bar repeat counts
Bar repeat counts are numbers shown at regular intervals either above or below bar repeats, to
help players keep track of how many bars have passed. The intervals are usually based on typical
musical phrases, such as every four or eight bars.
NOTE
Bar repeat counts are only shown on one-bar repeat regions.
Because bar repeats must start with a fully notated phrase of at least one bar, the bar repeat
count starts from the notated bar rather than the first bar in the bar repeat region. For example,
the third bar in a bar repeat region shows the count number 4, as that bar is the fourth time the
original notated bar is played. Each bar repeat region has its own separate count.
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Bar repeat region with counts shown every four bars

In Dorico Pro, you can change the start count of each bar repeat region, how frequently bar
repeat counts are shown, whether they are parenthesized, and customize the font style used for
bar repeat counts.
NOTE
The Bar Repeat Count font style also affects the appearance of counts on slash regions.

RELATED LINKS
Changing the bar repeat count appearance on page 1091
Changing the bar repeat count frequency on page 1091
Editing the bar repeat count font style on page 1092
Repeats popover on page 301
Inputting bar repeats on page 312
Hiding/Showing bar number ranges on multi-bar rests on page 650

Changing the start count of bar repeats
You can change the number from which individual bar repeats start, for example, if you want to
notate the first bar in a repeated phrase at the start of each system but show a continuous count
across multiple bar repeats.
NOTE
●

The start count applies to the first bar in the bar repeat, which is the notated bar. For
example, changing the start count of a one-bar repeat region lasting three bars to 5, with
bar repeat counts shown every four bars, causes the count at the end of the bar repeat
region to show the number 8.

●

Bar repeat counts are only shown on one-bar repeat regions.

PROCEDURE
1.

Select the one-bar repeat regions whose start count you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Count from in the Bar Repeat Regions group.

3.

Change the value in the value field.

RESULT
The number and position of bar repeat counts on the selected bar repeats is changed. For
example, changing the start count from 1 to 2, with counts shown every four bars, causes the
count to appear on the second bar in the bar repeat region instead of the third.

1090
Dorico Pro 3.1.10

Bar repeats
Bar repeat counts

EXAMPLE

Separate bar repeats on multiple systems in the
same part layout with the default count

Separate bar repeats on multiple systems in the
same part layout with their counts changed to imply
a continuous region

RELATED LINKS
Bar repeat counts on page 1089

Changing the bar repeat count frequency
You can change how often counts are shown on individual one-bar repeat regions independently
of your project-wide setting, for example, if you want to show the count after eight bars on a
single bar repeat region.
NOTE
Bar repeat counts are only shown on one-bar repeat regions.

PROCEDURE
1.

Select the one-bar repeats whose count frequency you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Count frequency in the Bar Repeat Regions group.

3.

Change the value in the value field.

RESULT
The count frequency is changed for the selected bar repeat regions.
TIP
You can also change the default count frequency for all bar repeat regions project-wide on the
Bar Repeats page in Engrave > Engraving Options.

RELATED LINKS
Bar repeat counts on page 1089
Project-wide engraving options for bar repeats on page 1087
Hiding/Showing bar number ranges on multi-bar rests on page 650

Changing the bar repeat count appearance
You can show individual bar repeat counts with or without parentheses, or not show any repeat
count at all, independently of your project-wide setting.
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NOTE
Bar repeat counts are only shown on one-bar repeat regions.

PROCEDURE
1.

Select the one-bar repeats whose count appearance you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Count appearance in the Bar Repeat Regions group.

3.

Select one of the following options from the menu:
●

Parenthesized

●

No parentheses

●

Don’t show

RESULT
The appearance of counts on the selected bar repeat regions is changed.
TIP
You can also change the default appearance of all bar repeat counts project-wide on the Bar
Repeats page in Engrave > Engraving Options.

RELATED LINKS
Changing the bar repeat count frequency on page 1091

Editing the bar repeat count font style
You can edit the formatting of the font style used for all bar repeat and slash region counts
project-wide, for example, if you want counts to appear bold and italic.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2.

Select Bar Repeat Count from the Font style menu:

3.

Activate the following options, individually or together, to change the corresponding aspect
of the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The formatting of the font style used for counts on bar repeats and slash regions is changed
project-wide.
RELATED LINKS
Edit Font Styles dialog on page 407
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Moving bar repeat counts
You can move individual bar repeat counts graphically without changing the rhythmic positions
to which they apply, for example, to accommodate other items at the same position better.
NOTE
If you want to move bar repeat counts because you want to change the bar to which the number
applies, you can change the start count instead.

PROCEDURE
1.

In Engrave mode, select the bar repeat counts you want to move.

2.

Move the selected bar repeat counts in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected bar repeat counts are moved to new graphical positions.
TIP
Number offset in the Bar Repeat Regions group of the Properties panel is activated
automatically when you move bar repeat counts in the corresponding directions:
●

Number offset X moves bar repeat counts horizontally.

●

Number offset Y moves bar repeat counts vertically.

You can also use this property to move bar repeat counts graphically by changing the values in
the value fields.
Deactivating the property resets the selected bar repeat counts to their default positions.

RELATED LINKS
Changing the start count of bar repeats on page 1090

Bar repeat grouping
Bar repeat grouping allows you to condense longer bar repeat regions, which can be helpful in
very regular music as it can simplify the overall phrasing.
The symbols shown on the staff are different for the different groupings, and two-bar and fourbar repeats also show a number to indicate how many bars are included in the group.
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One-bar repeat symbol

Two-bar repeat symbol

Three-bar repeat symbol

Four-bar repeat symbol

You can specify the grouping when inputting bar repeats, and you can change the grouping of
bar repeats after they have been input. Depending on where the bar repeat region starts and
ends relative to the written material, Dorico Pro automatically adjusts the displayed symbols to
achieve an accurate result. For example, an eight-bar phrase containing a single notated bar
followed by seven one-bar repeats grouped every four bars is automatically shown with a onebar repeat, two-bar repeat, then four-bar repeat to fill the seven bars.

Eight-bar phrase with seven one-bar repeats grouped every four bars

TIP
You can also choose to show a three-bar repeat to complete a four-bar phrase on the Bar
Repeats page in Engrave > Engraving Options; however, this is less commonly used than a
combination of one-bar and two-bar repeats.

RELATED LINKS
Repeats popover on page 301
Inputting bar repeats on page 312

Changing bar repeat grouping
You can change how bar repeats are grouped after they have been input, for example, if you
want to group a region of one-bar repeats every two bars.
PROCEDURE
1.

Select the bar repeat regions whose grouping you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, select one of the following options from the Group every menu in
the Bar Repeat Regions group:
●

One bar

●

Two bars

●

Four bars

NOTE
The options available depend on the minimum length of the selected bar repeat regions. For
example, if you select bar repeat regions that last three bars, only One bar and Two bars are
available in the menu.

RESULT
The grouping in the selected bar repeat regions is changed. Dorico Pro automatically calculates
the clearest way to group the region. For example, an eight-bar phrase containing a single
notated bar followed by seven one-bar repeats grouped every four bars is automatically shown
with a one-bar repeat, two-bar repeat, then four-bar repeat to fill the seven bars.
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Rhythm slashes are diagonal lines positioned on staves that are used to indicate that performers
should play something, but without specifying the exact rhythms and pitches. They are often
accompanied by chord symbols to indicate the set of notes the performer should use.
There are two different types of rhythm slashes:
●

Slashes with stems, which usually indicate the rhythm to be played, but not the pitches.

●

Slashes without stems, which do not usually indicate either rhythms or pitches.

Slashes with stems are also known as “rhythmic notation”, and slashes without stems are also
known as “slash notation”.
In Dorico Pro, you can present both types of rhythm slashes simultaneously by using a
combination of slash regions and slash voices.
RELATED LINKS
Slash voices on page 1299
Inputting slash regions on page 311
Inputting notes into slash voices on page 181
Chord symbols on page 695
Hiding/Showing chord symbols on page 706

Slash regions
Slash regions automatically display rhythm slashes as appropriate for the meter throughout their
duration, for example, they show four slashes per bar in 4/4 and two slashes per bar in 6/8. A
single slash region can extend across multiple different meters.

A single slash region covering multiple different meters

Multiple slash regions can exist at the same rhythmic position. When slash regions overlap,
Dorico Pro treats this as a multiple-voice context and changes the staff position of slashes
automatically.
By default, slash regions are highlighted with a colored background. As you zoom out, the
highlights become more opaque, which is especially useful when viewing full score layouts in
galley view. These highlights are considered annotations, are not printed by default, and you can
hide and show them.
In Write mode, each region has a handle at the start and end, which you can use to move and
lengthen/shorten regions.
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When two different slash regions are adjacent, they alternate highlight colors to ensure the
separate regions are always identifiable.

Two adjacent slash regions with different highlight colors

You can use slash regions and slash voices in the same project and at the same rhythmic
positions, for example, you can input a slash region where you do not want to be specific about
the rhythm, then input notes in a slash voice for a single bar where you want to specify an exact
rhythm.
TIP
Because rhythm slashes are often accompanied by chord symbols to indicate the set of notes the
performer should use, you can hide/show chord symbols in slash/chord symbol regions on
instrument staves where chord symbols are hidden.

RELATED LINKS
Slash voices on page 1299
Project-wide engraving options for rhythm slashes on page 1096
Slash region counts on page 1102
Slashes in multiple-voice contexts on page 1097
Moving slash regions on page 1100
Lengthening/Shortening slash regions on page 1101
Hiding/Showing chord symbols on page 706
Chord symbol regions on page 707
Annotations on page 610

Hiding/Showing slash region highlights
You can hide/show the colored highlights for slash regions at any time, for example, if you want
to show the highlights when inputting music but hide them when engraving.
PROCEDURE
●

Choose View > Highlight Slash Regions.

RESULT
Highlights on slash regions are shown when a tick appears beside Highlight Slash Regions in
the menu, and hidden when no tick appears.
RELATED LINKS
Slash voices on page 1299

Project-wide engraving options for rhythm slashes
You can find options controlling the project-wide design and appearance of rhythm slashes in the
Rhythmic slashes section of the Notes page in Engrave > Engraving Options. These options
affect both slash voices and slash regions.
The options in the Rhythmic slashes section of the Notes page allow you to change the design
of slashes, both with and without stems, whether slashes are shown with rhythm dots in
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compound time signatures, and the frequency, appearance, and position of slash region counts.
For example, you can choose to show slash region bar counts on every bar.
Musical examples demonstrate how each option affects the appearance of your music.
RELATED LINKS
Engraving Options dialog on page 359

Slashes in multiple-voice contexts
Multiple slash regions and slash voices can exist at the same rhythmic positions. In multiple-voice
contexts for slash voices and when slash regions overlap, Dorico Pro automatically changes their
staff position and offset to accommodate all slashes as legibly as possible.

Single slash region

Two slash regions, one up-stem and one down-stem

You can set default per-flow settings for the position and offset of slashes relative to other
slashes at the same rhythmic positions on the Voices page in Write > Notation Options.
NOTE
These options affect all rhythm slashes, including notes in slash voices as well as slash regions.
You can also control the positions of rhythm slashes relative to each other manually by changing
their stem/voice direction and by changing their staff position.
RELATED LINKS
Note positions in multiple-voice contexts on page 1294
Changing the voice of existing notes on page 341
Changing the staff position of rhythm slashes on page 1098

Changing the voice direction of slash regions
You can change the voice direction of slash regions individually. When multiple slash regions
overlap, this affects their stem directions.
PROCEDURE
1.

Select any part of each slash region whose voice direction you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Voice direction in the Slash Regions group.

3.

Choose one of the following options:
●

Up

●

Down

RESULT
The voice direction, and therefore stem direction, of the selected slash regions is changed.
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NOTE
This only affects the direction of stems in slash regions on the middle line of the staff and when
multiple slash regions exist at the same rhythmic position. For example, if you change the voice
direction of a slash region on the bottom line of the staff to Down, its stem direction does not
change if it does not overlap with another slash region.

RELATED LINKS
Stem direction on page 1196

Changing the staff position of rhythm slashes
You can change the staff position of rhythm slashes in both slash voices and slash regions, for
example, to accommodate other notes at the same rhythmic positions better. By default, rhythm
slashes are positioned on the middle line of the staff.
PROCEDURE
1.

2.

3.

Select the rhythm slashes whose staff position you want to change. You can do this in Write
mode and Engrave mode.
●

For notes in slash voices, you must select every note whose staff position you want to
change.

●

For slash regions, you can select any part of each region whose staff position you want
to change.

In the Properties panel, activate Slash pos. in the corresponding group for the type of
rhythm slash whose staff position you want to change:
●

Notes and Rests for notes in slash voices

●

Slash Regions for slash regions

Change the value in the value field.

RESULT
The staff position of the selected rhythm slashes is changed. For example, changing the Slash
pos. value to 4 positions rhythm slashes on the top line of a five-line staff, while -4 positions them
on the bottom line.
If any of the rhythm slashes have stems, their stem direction is adjusted automatically.
RELATED LINKS
Stem direction on page 1196

Hiding/Showing notes alongside slash regions
You can hide/show notes at the same rhythmic positions as slash regions, for example, if you
want to input notes to hear in playback but only want to show the slash region, or if you want to
notate suggested notes in addition to the slash region.
PROCEDURE
1.

Select any part of each slash region alongside which you want to hide/show other notes. You
can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Show other voices in the Slash Regions group.
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RESULT
All notes in other voices present alongside the selected slash regions are shown when Show
other voices is activated, and hidden when it is deactivated.
EXAMPLE

Notes hidden alongside a slash region

Notes shown alongside a slash region

RELATED LINKS
Slash regions on page 1095
Slash voices on page 1299
Hiding/Showing slash region highlights on page 1096

Hiding/Showing padding rests before/after slash regions
You can hide/show padding rests before/after slash regions that start partway through bars
individually, for example, if you have other notes at those positions and the rests would be
misleading.
By default, Dorico Pro automatically shows implicit padding rests around slash regions that
start/end partway through bars, so that the full duration of each bar is clear.
PROCEDURE
1.

Select any part of each slash region whose padding rests you want to hide/show. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Slash Regions group:
●

Hide rests before start

●

Hide rests after end

RESULT
Padding rests are hidden on the corresponding side of the selected slash regions. For example,
activating both properties hides padding rests both before and after the selected slash regions.
RELATED LINKS
Implicit vs. explicit rests on page 1107

Splitting slash regions
You can split slash regions after they have been input, for example, if you later want to input
more precise notation in the middle of an existing slash region.
PROCEDURE
1.

In Write mode, select a slash in each slash region you want to split, immediately to the right
of where you want to split them.
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2.

Press U .

RESULT
The slash regions are split immediately to the left of the selected slashes. Each part now has its
own start/end handles, which you can use to lengthen/shorten each part independently.
RELATED LINKS
Changing the slash region count frequency on page 1103
Lengthening/Shortening slash regions on page 1101

Moving slash regions
You can move slash regions to different rhythmic positions after they have been input. Because
multiple slash regions can exist at the same rhythmic position, you can also move slash regions
so they overlap with other slash regions.
PROCEDURE
1.

In Write mode, select any part of each slash region you want to move.

2.

Move the selected slash regions according to the current rhythmic grid resolution in any of
the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

NOTE
You cannot move slash regions rhythmically with the mouse.

RESULT
The selected slash regions are moved to new rhythmic positions.
NOTE
If a single slash region passes over another slash region as part of its move, the existing one is
unaffected as multiple slash regions can exist at the same rhythmic position. Where slash
regions overlap, the staff positions of slashes are automatically adjusted.
However, when you move multiple slash regions together, any existing slash regions they pass
over are shortened or deleted accordingly.
You can undo this action, but any slash regions shortened/deleted in the process are only
restored if you moved slash regions using the keyboard.

RELATED LINKS
Slashes in multiple-voice contexts on page 1097
Changing the voice direction of slash regions on page 1097
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Lengthening/Shortening slash regions
You can lengthen/shorten slash regions after they have been input. Because multiple slash
regions can exist at the same rhythmic position, you can also lengthen/shorten slash regions so
they overlap with other slash regions.
PROCEDURE
1.

In Write mode, select any part of each slash region you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one slash region at a time.

2.

Lengthen/Shorten the selected slash regions in any of the following ways:
●

To lengthen them by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten them by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .

●

Click and drag the circular handle at the start/end to the right/left.

RESULT
The selected slash regions are lengthened/shortened according to the current rhythmic grid
resolution. If any part of them overlap rhythmic positions with other slash regions, the staff
positions of slashes are automatically adjusted to accommodate multiple slash regions at the
same positions.
RELATED LINKS
Slashes in multiple-voice contexts on page 1097
Changing the voice direction of slash regions on page 1097

Hiding/Showing stems in slash regions
You can hide/show stems on slashes in individual slash regions. By default, slashes in slash
regions are shown without stems.
PROCEDURE
1.

Select any part of each slash region in which you want to hide/show stems. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Slash type in the Slash Regions group.

3.

Choose one of the following options:
●

With stems

●

Without stems

RESULT
Stems are hidden in the selected slash regions when you choose Without stems, and shown
when you choose With stems.
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Slash region counts
Slash region counts are numbers shown at regular intervals, either above or below slash regions,
to help players keep track of how many bars have passed. The intervals are usually based on
typical musical phrases, such as every four or eight bars.
By default, slash region counts are shown every four bars and are placed below the staff. Each
slash region has its own separate count.

Slash region with counts shown every two bars

In Dorico Pro, you can change the start count of each slash region, how frequently slash region
counts are shown, their staff-relative placement, whether they are parenthesized, and customize
the font style used for slash region counts.
NOTE
Slash region counts use the same font style as bar repeat counts.

RELATED LINKS
Slash regions on page 1095
Project-wide engraving options for rhythm slashes on page 1096
Editing the bar repeat count font style on page 1092

Changing the start count of slash regions
You can change the number from which individual slash region counts start, for example, if you
want to input more precise notation between two slash regions but want the count to appear to
continue across the regions.
PROCEDURE
1.

Select any part of each slash region whose start count you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Count from in the Slash Regions group.

3.

Change the value in the value field.

RESULT
The number and position of counts on the selected slash regions is changed. For example,
changing the start count from 1 to 2, with counts shown every four bars, causes the count to
appear on the third bar in the slash region instead of the fourth.
EXAMPLE

Two separate slash regions, where the start count on the second region has been changed so it appears to
continue on from the first region.
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Changing the slash region count frequency
You can change how frequently counts are shown on slash regions independently of your
project-wide setting, for example, if you want to show the count after eight bars on a single slash
region. By default, slash region counts are shown every four bars.
PROCEDURE
1.

Select any part of each slash region whose count frequency you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Count frequency in the Slash Regions group.

3.

Change the value in the value field.

RESULT
The count frequency is changed for the selected slash regions.
TIP
You can also change the default count frequency for all slash regions project-wide in the
Rhythmic slashes section of the Notes page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for rhythm slashes on page 1096
Splitting slash regions on page 1099

Changing the slash region count appearance
You can show individual slash region counts with or without parentheses, or not show any count
at all, independently of your project-wide setting.
PROCEDURE
1.

Select any part of each slash region whose count appearance you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Count appearance in the Slash Regions group.

3.

Select one of the following options from the menu:
●

Parenthesized

●

No parentheses

●

Don’t show

RESULT
The appearance of counts on the selected slash regions is changed.
TIP
You can also change the default appearance of all slash region counts project-wide in the
Rhythmic slashes section of the Notes page in Engrave > Engraving Options.
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Moving slash region counts
You can move individual slash region counts graphically without changing the rhythmic positions
to which they apply, for example, to accommodate other items at the same position better.
NOTE
If you want to move slash region counts because you want to change the bar to which the
number applies, you can change the start count instead.

PROCEDURE
1.

In Engrave mode, select the slash region counts you want to move.

2.

Move the selected slash region counts in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected slash region counts are moved to new graphical positions.
TIP
Count offset in the Slash Regions group of the Properties panel is activated automatically when
you move slash region counts in the corresponding directions:
●

Count offset X moves slash region counts horizontally.

●

Count offset Y moves slash region counts vertically.

You can also use this property to move slash region counts graphically by changing the values in
the value fields.
Deactivating the property resets the selected slash region counts to their default positions.

RELATED LINKS
Changing the start count of slash regions on page 1102

Changing the staff-relative placement of slash region counts
You can show the counts on individual slash regions either above or below the staff,
independently of your project-wide setting.
NOTE
Changing the staff-relative placement of slash region counts affects all counts on the region. You
cannot change the placement of a single count independently of other counts on the same slash
region.
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PROCEDURE
1.

Select any part of each slash region whose count staff-relative placement you want to
change.

2.

In the Properties panel, activate Count position in the Slash Regions group.

3.

Choose one of the following options:
●

Above

●

Below

RESULT
The staff-relative placement of all counts on the selected slash regions is changed.
TIP
You can change the default placement of all slash region counts project-wide in the Rhythmic
slashes section of the Notes page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for rhythm slashes on page 1096
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Rests are markings with a rhythmic value that indicate no note is played for that duration. Each
note duration has an equivalent rest, for example, a quarter note rest is different to a sixteenth
note rest.
All notes and rests within a bar must add up to the duration of the bar, according to the
prevailing time signature.
The table shows some examples of notes and the rests with the equivalent rhythmic value.

Duration

Note

Rest

Half

Quarter

Eighth

Sixteenth

During note input, Dorico Pro automatically fills the gaps between notes with implicit rests of the
appropriate duration. Therefore, it is usually not necessary to input rests in Dorico Pro.
RELATED LINKS
Implicit vs. explicit rests on page 1107
Inputting rests on page 190
Deleting rests on page 1110
Inputting notes on page 172

General placement conventions for rests
Rests are positioned at the rhythmic position at the start of their duration, and not in the middle
of beats as this can cause confusion over when the rest begins and ends. Rests are aligned with
other items at the same rhythmic position.
The only exception is whole bar rests, which are positioned at the visual center of bars. This way,
they are clearly distinguishable from half note and whole note rests that are followed by notes in
the same bar.
Rests stay within the staff wherever possible. They do not move above or below the staff when
the notes around them are very high or very low.
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However, on staves with multiple voices, rests are placed higher on the staff, or above the staff,
for up-stem voices and lower on the staff, or below the staff, for down-stem voices.

Example rest positions in a multiple-voice context

Rests in multiple voices must not overlap. You can consolidate rests so that only one is shown
when multiple voices have a rest of the same duration at the same rhythmic position.
The precise vertical positioning of rests is limited, as their detailed shapes require specific
positions relative to staff lines and staff spaces.
RELATED LINKS
Deleting rests on page 1110
Turning explicit rests into implicit rests on page 1109

Implicit vs. explicit rests
Implicit rests are automatically shown between the notes you input, and their duration
automatically follows the time signature and their position in the bar. Explicit rests are rests that
are explicitly entered during note input by forcing their duration, or rests that were imported
from a MusicXML file.
Dorico Pro notates implicit rests according to the current time signature, for example, different
implicit rests are shown in 6/8 compared to 4/4. This also applies if you later change the time
signature for existing notes and rests.
Therefore, it is not necessary to input rests in Dorico Pro, as implicit rests are automatically
shown around the notes that you input. You can turn implicit rests into explicit rests by forcing
their duration to be fixed.

A quarter note input at the fourth eighth note of the
bar in a 6/8 time signature has a dotted quarter
implicit rest at the start of the bar.

A quarter note input at the fourth eighth note of the
bar in a 4/4 time signature has two implicit rests, a
quarter and an eighth, at the start of the bar.

Explicit rests cannot be suppressed when using the Starts voice and Ends voice properties to
hide rests before the first note in voices and after the last note in voices.
You can show rest colors to see which rests are implicit and which are explicit in your project.
RELATED LINKS
Inputting rests on page 190
Inputting notes on page 172
Forcing the duration of notes/rests on page 177
Turning explicit rests into implicit rests on page 1109
Deleting rests on page 1110
Hiding/Showing rest colors on page 1110
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Implicit rests in multiple-voice contexts
In Dorico Pro, implicit rests are shown automatically to fill in rhythmic positions around notes,
including when there are multiple voices on the staff. However, in these contexts you might want
more control over when and where rests are shown.
Usually, rests or notes are shown for whole bars when voices contain at least one note in the bar.
This helps make the rhythmic position of every note in all voices in the bar immediately clear.
When there are multiple voices on a staff, implicit rests are shown in every bar in which there are
notes of any duration in more than one voice. However, there might be circumstances in which
you do not want to show rests either before the first note in a voice or after the last note in a
voice when there are multiple voices on the staff. For example, it can be useful to hide rests when
a voice is being used to show passing notes within a bar that otherwise contains a single melodic
line.

A second voice used to notate passing notes

TIP
By default, Dorico Pro consolidates rests when multiple voices have rests of the same duration at
the same rhythmic position.
You can show multiple rests at individual rhythmic positions by changing the vertical position of
rests.
You can also change your project-wide settings for the consolidation of rests in multiple-voice
contexts on the Rests page in Notation Options.
You can hide rests before the first note in voices and after the last note in voices individually by
activating properties in the Properties panel. You can show rests that you have hidden by
deactivating the corresponding property.

A phrase with multiple voices showing implicit rests.

The same phrase without implicit rests.

You can choose when rests are shown in a number of different multiple-voice contexts projectwide on the Rests page in Write > Notation Options.
You can also delete rests from selected passages.
RELATED LINKS
Per-flow notation options for rests on page 1109
Moving rests vertically on page 1116
Deleting rests on page 1110
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Turning explicit rests into implicit rests
Implicit rests and explicit rests behave differently. For example, you can hide implicit rests using
the Properties panel, but you cannot hide explicit rests or rests with forced durations.
NOTE
You can only hide implicit rests using Starts voice and Ends voice in the Notes and Rests group
of the Properties panel.

PROCEDURE
1.

In Write mode, select the explicit rests you want to turn into implicit rests.

2.

Press Backspace or Delete .

RESULT
The selected explicit rests are now implicit rests. You can check this by showing rest colors.
RELATED LINKS
Hiding/Showing rest colors on page 1110
Deleting rests on page 1110

Per-flow notation options for rests
You can find per-flow options controlling how rests are positioned and notated, and when rests
are shown, on the Rests page in Write > Notation Options.
For example, you can change whether bar rests are shown in additional voices, when dotted
rests are permitted, and the default positions of rests in different contexts.
Musical examples demonstrate how each option affects the appearance of your music.
RELATED LINKS
Notation Options dialog on page 160
Voices on page 1294
Per-flow notation options for voices on page 1295
Stem direction on page 1196

Project-wide engraving options for rests
You can find options for the project-wide appearance of rests on the Rests page in Engrave >
Engraving Options.
The options on the Rests page allow you to change the style, appearance, width, and precise
position of rests. You can also change the appearance and design of multi-bar rests, such as
choosing to hide or show H-bars and bar counts on single bar rests and how to display multi-bar
rests at the end of flows. For example, the default appearance of multi-bar rests at the end of
flows is to show “tacet al fine”, but you can show the total bar count instead.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359
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Hiding/Showing rest colors
You can hide/show rest colors, which causes implicit rests and explicit rests to appear with
different colors.
When rest colors are shown, rests in your project appear gray if they are implicit, and black if
they are explicit. For example, this can be useful to help diagnose why rests do not disappear
when you activate Starts voice and Ends voice, as these properties only hide implicit rests.
PROCEDURE
●

Choose View > Note And Rest Colors > Implicit Rests.

RESULT
Rest colors are shown when a tick appears beside Implicit Rests in the menu, and hidden when
no tick appears.
EXAMPLE

Rests colored black, as they appear without implicit
rests shown

Rests colored gray to indicate implicit rests

AFTER COMPLETING THIS TASK
You can delete rests that you have identified as explicit rests. The implicit rests that replace them
now respect the Starts voice and Ends voice properties.

Deleting rests
You can delete both implicit rests and explicit rests, for example, if you want to hide rests before/
after notes in another voice used to show passing notes.
NOTE
●

If you want to delete rests because multiple rests of the same duration appear at the same
position in multiple-voice contexts, you can choose to consolidate these rests in the Rest
positioning section of the Rests page in Notation Options.

●

You cannot delete rests from unpitched percussion instruments.

PROCEDURE
1.

In Write mode, select the rests you want to delete.
TIP
You can select rests individually, or make a larger selection that contains the rests you want
to delete.

2.

Choose Edit > Remove Rests.
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RESULT
All rests in the selection are deleted. This is done by automatically activating Starts voice and
Ends voice in the Notes and Rests group of the Properties panel so that no rests are shown in
the selected regions.
TIP
You can undo deleting rests immediately.
You can also show rests again later by selecting the notes or rests immediately to the right/left of
deleted rests and deactivating the corresponding Starts voice or Ends voice properties in the
Notes and Rests group of the Properties panel.

RELATED LINKS
Rests on page 1106
Per-flow notation options for rests on page 1109
Implicit vs. explicit rests on page 1107
Large selections on page 322
Implicit rests in multiple-voice contexts on page 1108

Hiding/Showing bar rests in empty bars
You can hide/show bar rests in empty bars in each layout in your project independently of other
layouts. For example, you can hide bar rests in full score layouts but show bar rests in part
layouts.
Bar rests are usually shown in empty bars in music to indicate to performers that they have
nothing to play. However, there are contexts in which it is preferable to hide bar rests in empty
bars, and instead leave the bar completely empty.
For example, hiding bar rests in empty bars is sometimes the preferred visual aesthetic in large
scores, so that it is quicker to identify bars containing music. You can also hide bar rests in
layouts where you want to include other instructions, such as verbal indications for performers
to do something other than play notated pitches.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show bar rests in empty
bars.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Bar Rests and Multi-bar Rests section, activate/deactivate Show bar rests in empty
bars.

5.

Click Apply, then Close.

RESULT
All bar rests in empty bars in the selected layouts are shown when the checkbox is activated, and
hidden when the checkbox is deactivated.
RELATED LINKS
Hiding/Showing multi-bar rests on page 1113
Hiding/Showing bar rests in additional voices on page 1112
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Hiding/Showing bar rests in additional voices
You can hide/show bar rests between notes or explicit rests in additional voices on a per-flow
basis, for example, you might show bar rests in contrapuntal music to ensure each voice can be
easily followed.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-N to open Notation Options.

2.

In the Flows list, select the flows in which you want to hide/show bar rests in additional
voices.
By default, only the current flow is selected when you open the dialog.

3.

Click Rests in the page list.

4.

In the Rests in Additional Voices section, choose one of the following options for Bar rests
in additional voices:

5.

●

Show bar rests

●

Omit bar rests

Click Apply, then Close.

RESULT
Bar rests are shown between notes or explicit rests in all voices in the selected flows when you
choose Show bar rests, and hidden when you choose Omit bar rests.
NOTE
Show bar rests does not automatically show bar rests in empty bars before the first note or
explicit rest in additional voices. For additional voices that do not start in the first bar, you must
input a bar rest in the first bar manually.

RELATED LINKS
Implicit vs. explicit rests on page 1107
Inputting notes into multiple voices on page 179
Inputting bar rests into specific voices on page 191

Multi-bar rests
Multi-bar rests group two or more consecutive empty bars together into a single unit, commonly
shown with a thick horizontal line positioned on the middle staff line, known as an “H-bar”. They
can reduce the horizontal space required by multiple empty bars and make it easier for players
to find their place in the music.

A multi-bar rest representing four empty bars

NOTE
Multi-bar rests are automatically split by items positioned within their range, such as system text,
rehearsal marks, and holds and pauses. This includes when the items are invisible, except for
hidden tempo marks, such as those input in the Time track in Play mode. However, if items are
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positioned at the start of the first bar in a multi-bar rest, that bar remains part of the subsequent
multi-bar rest.
You can hide/show multi-bar rests in each layout independently in Dorico Pro, and you can hide/
show bar number ranges below them.
By default, the multi-bar rest bar counts only appear once between the staves of grand staff
instruments.
You can find options controlling the project-wide appearance, design, width, and content of
multi-bar rests on the Rests page in Engrave > Engraving Options.
RELATED LINKS
Hiding/Showing bar number ranges on multi-bar rests on page 650
Time track on page 530
Changing the width of multi-bar rest H-bars on page 1114
Changing the placement of multi-bar rest bar counts on page 1115
Splitting multi-bar rests on page 1116

Hiding/Showing multi-bar rests
You can hide/show multi-bar rests in each layout in your project independently of other layouts,
and choose whether bar repeats are consolidated into multi-bar rests. For example, you can hide
multi-bar rests in full score layouts but show multi-bar rests in part layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show multi-bar rests.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Bar Rests and Multi-bar rests section, choose one of the following options for
Consolidate:

5.

●

None

●

Multi-bar Rests

●

Multi-bar Rests and Bar Repeats

Click Apply, then Close.

RESULT
●

When you choose None, no multi-bar rests are shown in the selected layouts. Each empty
bar is shown separately.

●

When you choose Multi-bar Rests, any adjacent empty bars are consolidated into multi-bar
rests in the selected layouts. However, bar repeats prevent the consolidation of multi-bar
rests, even if there are no other notes in those bars.

●

When you choose Multi-bar Rests and Bar Repeats, any adjacent empty bars or bars that
only contain bar repeats are consolidated into multi-bar rests in the selected layouts. Multibar rest counts are also shown above consolidated bar repeats.
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TIP
You can also hide/show H-bars and bar counts on all single bar rests project-wide in the Multibar Rests section of the Rests page in Engrave > Engraving Options.

RELATED LINKS
Bar repeats on page 1086
Multi-bar rests on page 1112
Hiding/Showing bar number ranges on multi-bar rests on page 650

Hiding/Showing tacet al fine on multi-bar rests at the end of flows
You can change the appearance of multi-bar rests that extend to the end of flows in all layouts
project-wide. By default, multi-bar rests that extend to the end of flows show “tacet al fine” above
the staff instead of the total bar count.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Rests in the page list.

3.

In the Multi-bar Rests section, choose one of the following options for Multi-bar rests that
extend to the end of the flow in the Appearance subsection:
●

Show tacet al fine

●

Show bar count

4.

Optional: Change the value for Minimum number of bars’ rest at the end of flow to show
‘tacet al fine’.

5.

Click Apply, then Close.

RESULT
The appearance of all multi-bar rests at the end of flows is changed project-wide. Changing the
value for Minimum number of bars’ rest at the end of flow to show ‘tacet al fine’ changes
when “tacet al fine” is shown to only multi-bar rests containing the set number of bars or more.

Changing the width of multi-bar rest H-bars
You can choose whether Dorico Pro calculates the width H-bars in multi-bar rests using either an
inset from barlines, meaning their width varies depending on the width of bars, or a fixed width
regardless of the width of bars.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Rests in the page list.

3.

In the Multi-bar Rests section, choose one of the following options for H-bar width in the
Design subsection:
●

Inset from barlines

●

Fixed width

4.

Optional: If you chose Inset from barlines, change the value for Gap between end of H-bar
and barline.

5.

Optional: If you chose Fixed width, change the value for Fixed H-bar width.

6.

Click Apply, then Close.
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RESULT
The width of all H-bars is changed project-wide.

Changing the placement of multi-bar rest bar counts
You change the placement of bar counts on multi-bar rests to be either above or below the staff.
For grand staff instruments, you can also choose to show bar counts only once between the
staves or above/below each staff.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Rests in the page list.

3.

In the Multi-bar Rests section, choose one of the following options for Placement for bar
count on single staff instruments in the Appearance subsection:

4.

5.

●

Above

●

Below

Choose one of the following options for Bar count on grand staff instruments:
●

Show between staves

●

Show above or below each staff

Click Apply, then Close.

Changing the font used for multi-bar rest bar counts
By default, bar counts on multi-bar rests use a bold, Arabic font that is similar in appearance to
the digits in time signatures. You can change the font used for bar counts on multi-bar rests
project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Rests in the page list.

3.

In the Multi-bar Rests section, choose one of the following options for Bar count
appearance in the Design subsection:

4.

●

Music font

●

Plain font

Click Apply, then Close.

RESULT
The font style used for bar counts on multi-bar rests is changed project-wide.
TIP
You can edit different aspects of the font styles used for multi-bar rest bar counts in the Edit
Font Styles dialog, for example, if you want to make the font italic or change the font size.
●

Music font bar counts use Multi-bar Rest Bar Count Font, which must be SMuFL-compliant.

●

Plain font bar counts use Multi-bar Rest Bar Count Plain Font.

RELATED LINKS
Edit Font Styles dialog on page 407
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Splitting multi-bar rests
You can manually split multi-bar rests without showing any extra notation in the music. Splitting
multi-bar rests affects all layouts in the project, including full scores and parts.
NOTE
Multi-bar rests are automatically split by items positioned within their range, such as system text,
rehearsal marks, and holds and pauses.
PREREQUISITE
You have opened a layout in the music area that either has items in the bars where you want to
split multi-bar rests or in which multi-bar rests are hidden. You cannot select rhythmic positions
within multi-bar rests.
PROCEDURE
1.

In Engrave mode, select an item at the rhythmic position where you want to split multi-bar
rests.

2.

Choose Engrave > Split Multi-bar Rest.

RESULT
All multi-bar rests in all layouts are split at the selected position. A signpost is shown at the
position of the multi-bar rest split.
RELATED LINKS
Multi-bar rests on page 1112
Hiding/Showing signposts on page 336
Hiding/Showing multi-bar rests on page 1113
Switching between layouts on page 55

Moving rests vertically
You can change the vertical position of rests individually, for example, if you want to change the
staff line from which a whole bar rest hangs, or you want to show rests for all voices at a
particular rhythmic position.
Moving rests vertically shows multiple rests at that rhythmic position if more than one voice on
the staff has a rest of the same duration. By default, Dorico Pro consolidates rests in multiplevoice contexts and automatically positions rests in multiple-voice contexts to avoid collisions.
NOTE
You cannot change the vertical position of rests when using the mouse.

PROCEDURE
1.

Select the rests whose vertical positions you want to change, or rests at the rhythmic
positions where you want to see rests for every voice. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Rest pos. in the Notes and Rests group.

3.

Change the value in the value field.
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RESULT
Increasing the value moves rests upwards, decreasing the value moves rests downwards.
Position 0 is the middle line of the staff.
If there are multiple voices on the staff with rests of the same duration, multiple rests are now
shown.
TIP
●

Deactivating Rest pos. returns the selected rests to their default positions.

●

You can choose to show all rests in every voice or only show one rest for all voices in the Rest
positioning section of the Rests page in Notation Options.

●

You can change the horizontal position of rests, and the spacing around them, in Engrave
mode when Note Spacing is activated, in the same ways as changing the position of notes.

RELATED LINKS
Notation Options dialog on page 160
Note spacing on page 425
Adjusting note spacing at individual rhythmic positions on page 429
Adjusting the spacing of individual notes/items independently of their rhythmic positions on
page 432
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Slurs are tapered, curved lines that join notes to indicate legato articulation and phrasing.
Depending on the context and the instrument to which they apply, slurs can have additional
meanings to simply marking phrases. For example, for wind players, a slur indicates that all the
notes in the phrase are played in the same breath and without re-tonguing or re-articulating any
notes. For string players, a slur indicates that all the notes in the phrase are played legato and
under one bow. For singers, slurs indicate that more than one note is sung to the same syllable.
Slurs can be placed both above and below the staff, depending on the stem directions of the
notes to which they apply. In order to keep slur endpoints close to notes, slurs are placed outside
articulations on notes in the middle of slurs, but between notes and larger articulations on the
first/last notes of slurs. For example, accents and stress marks are placed outside the ends of
slurs but staccato and tenuto marks are placed inside the ends of slurs by default.

Slurs both above and below the staff, including a cross-staff slur

You can change the placement of accent, marcato, stress, and unstress articulations relative to
slurs in the Slurs section of the Articulations page in Engrave > Engraving Options.
NOTE
Slurs must not be confused with ties, which look superficially similar, but instead join notes of the
same pitch to indicate that they are played as a single note. In that sense, ties are part of
rhythmic notation, while slurs are considered articulation.

RELATED LINKS
Inputting slurs on page 212
Ties on page 1219
Project-wide engraving options for articulations on page 624

General placement conventions for slurs
The staff-relative placement of slurs, and therefore their curvature direction, depends on the
stem direction of the notes within the slur. Depending on whether slurs are placed on the
notehead or stem side of notes, their endpoint positions are different.

Slur direction
A slur on a single staff always curves upwards and is placed above the notes, unless all of the
notes under the slur are up-stem, in which case it curves downwards and is placed below the
notes. If a slur applies to a mixture of up-stem and down-stem notes, it is placed above the staff
and curves upwards.
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Examples of the slur direction changing according to the stem direction

You can set your preference for whether slurs follow the stem direction, or always appear above
notes, on the Slurs page in Engrave > Engraving Options.
NOTE
In jazz scores, slurs are sometimes treated as an articulation and so positioning all slurs above
the staff is preferred.

Stem-side slurs between unbeamed notes
In Dorico Pro, slurs appear between the stems of unbeamed notes when placed on their stem
side, and the default setting is for them to attach a short distance from the end of the stem.

You can change where slurs attach to stems by adjusting Vertical offset from end of stem in
the Endpoint Positioning section of the Slurs page in Engrave > Engraving Options.
RELATED LINKS
Slur endpoint position relative to other items on page 1121

Slur position relative to tie chains
There are different conventions for the position of slurs relative to tie chains in music for modern
use and historical editions.
Modern practice is for slurs to start on the first note in tie chains, and end on the last note in tie
chains. This makes the full length of the phrase visually clear to the performer, which helps their
performance, and is the default in Dorico Pro.

Slur ending on the last note in a tie chain

Slur starting from the first note in a tie chain

However, in historical editions, slurs might end on the first note in a tie chain, and start on the
last note in a tie chain. Both of these changes save vertical space, as shorter slurs do not extend
as far above or below a staff.

Slur ending on the first note in a tie chain

Slur starting on the last note in a tie chain
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You can choose whether all slurs start on the first/last note in tie chains, and end on the first/last
note in tie chains, on the Slurs page in Engrave > Engraving Options. There are different
options for slurs between normal notes and slurs starting on grace notes.

Changing the position of slurs relative to tie chains
You can change the position of individual slurs relative to tie chains, including slurs starting on
grace notes, for example, to save vertical space.
PROCEDURE
1.

Select the slurs whose position relative to tie chains you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Slurs group:

3.

●

Start pos. in tie chain

●

End pos. in tie chain

Choose one of the following options for each property:
●

First note

●

Last note

RESULT
The position of the selected slurs relative to tie chains is changed.
TIP
You can change the default position of all slurs relative to tie chains project-wide on the Slurs
page in Engrave > Engraving Options. There are different options for slurs between normal
notes and slurs starting on grace notes.

RELATED LINKS
Project-wide engraving options for slurs on page 1122

Slur placement relative to grace notes
There are specific placement rules that affect slurs when they start from a grace note and end on
a normal note immediately following the grace note.
These rules are:
●

Slurs connect noteheads rather than stems.

●

Slurs are scaled to match the proportions of grace notes.

●

Slurs must not obscure ledger lines.

●

Slurs are placed above notes if they would collide with the accidental of a standard note
when placed below the notes.

You can adjust the values for the different parameters of the special placement rules. For
example, you can change the vertical and horizontal offsets for the right-hand end of a grace
note slur relative to the standard, full-sized notehead to which it is attached in the Grace Notes
section of the Slurs page in Engrave > Engraving Options.
NOTE
These rules do not apply when slurs attach to a standard note at any rhythmic position beyond
the note immediately following the grace note.
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Due to the general placement conventions of grace notes, slurs in Dorico Pro appear below grace
notes and curve downwards by default. Slurs starting from grace notes only appear above notes
and curve upwards in up-stem voices in multiple-voice contexts.

Automatic changes to the curvature direction of slurs on grace notes in multiple-voice contexts

You can change the automatic placement of grace note slurs by changing the stem direction of a
grace note, changing the direction of a slur, and using the slur handles in Engrave mode to
adjust the position of a slur in finer detail.
RELATED LINKS
Changing the curvature direction of slurs on page 1138
Changing the stem direction of notes on page 1199
General placement conventions for grace notes on page 826
Slurs in Engrave mode on page 1129
Changing the shape of slurs on page 1131

Slur position relative to staff lines
Slur endpoints must not touch staff lines, and the high point of the arcs of slurs should not stop
on staff lines.
This is the convention because a slur whose arc peaks on a staff line can create the appearance
of a triangular wedge between the staff line and the curve of the slur. If a slur peaks on a staff
line, you can adjust its height so that it peaks either above/below the staff.
NOTE
Although Dorico Pro automatically ensures slur endpoints do not touch staff lines, manual
adjustments might be necessary to position the arcs of slurs correctly.
You can set a value for the minimum distance between slur endpoints and staff lines in the
Avoiding Collisions section of the Slurs page in Engrave > Engraving Options. The default
position of slur endpoints relative to staff lines is 1/4 space above/below, to ensure the start/end
points do not touch the staff line.
RELATED LINKS
Project-wide engraving options for slurs on page 1122
Changing the height of slurs on page 1135

Slur endpoint position relative to other items
In order to avoid collisions, the default positions of slur endpoints vary depending on whether
slurs are placed on the notehead side or stem side of notes, their position relative to staff lines,
and whether articulations, ties, and other slurs exist at the same rhythmic position.

Slur endpoints relative to noteheads and stems
The default position of slur endpoints relative to noteheads is 1/2 space above a notehead in a
space on the staff, and 1/4 space above a notehead on a line on the staff.
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You can change the vertical and horizontal offsets for the endpoints of slurs in the Endpoint
Positioning section of the Slurs page in Engraving Options. However, you might also need to
reduce the value for Minimum gap inside slur curvature to avoid collisions in the Avoiding
Collisions section, as endpoints cannot be closer to noteheads than this value.
NOTE
This value affects all slur collisions in your project.

Slur endpoints relative to articulations
By default, articulations of force and stress are placed outside slur endpoints, and articulations of
duration are placed inside slur endpoints, which automatically raises the endpoints.
You can position slur endpoints closer to articulations by reducing the value for Minimum gap
inside slur curvature to avoid collisions in the Avoiding Collisions section of the Slurs page in
Engraving Options.
NOTE
Changing this value affects the position of slur endpoints project-wide. You may find it more
appropriate to move slur endpoints relative to articulations individually in Engrave mode.

Slur endpoints relative to ties and other slurs
The default position of slur endpoints is 1/4 space above an existing slur that starts/ends on the
same note.
You can change this by increasing/decreasing the value for Minimum vertical gap between two
slurs starting or ending on the same note in the Avoiding Collisions section of the Slurs page
in Engraving Options.
To make slurs appear closer to tied notes, you can adjust the values for slur endpoint position
relative to noteheads.
RELATED LINKS
Slurs in Engrave mode on page 1129
Changing the shape of slurs on page 1131
Articulations on page 623

Project-wide engraving options for slurs
You can find options for the project-wide appearance, position, and placement of slurs on the
Slurs page in Engrave > Engraving Options.
The options on the Slurs page allow you to change the direction, style, height, and thickness of
slurs. You can also set precise values for the positions of slurs relative to noteheads, stems, grace
notes, and ties, and change the collision avoidance behavior of cross-staff slurs.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359
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Cross-staff and cross-voice slurs
Cross-staff slurs start on one staff and end on another staff, and cross-voice slurs start in one
voice and end in another voice.
Dorico Pro positions cross-staff and cross-voice slurs in the same way as it positions standard
slurs, so their appearance might be the same as standard slurs. You can move and lengthen/
shorten cross-staff and cross-voice slurs in the same ways as standard slurs; however, they do
not behave in the same way.
For example, you cannot move cross-voice slurs to notes on the same staff in other voices, and
you cannot lengthen cross-voice slurs to notes on the same staff in other voices. You also cannot
shorten cross-voice slurs if noteheads under the slur are not in one of the voices in which the slur
started/ended.
You can only move and lengthen/shorten cross-staff slurs to notes on the same staff as the
corresponding endpoint. For example, if a cross-staff slur covers a phrase that starts on the
bottom staff and ends on the upper staff, you can only shorten the cross-staff slur to the first
note on the upper staff, you cannot shorten it to any notes on the bottom staff.
The different voices can be on the same staff, or on different staves.
RELATED LINKS
Lengthening/Shortening slurs on page 1126
Moving slurs rhythmically on page 1125

Inputting cross-staff and cross-voice slurs
You can input cross-staff and cross-voice slurs. For example, musical phrases in grand staff
instruments, such as piano and harp, can span both staves and may need slurs to join them.
PROCEDURE
1.

In Write mode, select the note from which you want the slur to start, in any voice or staff.

2.

Ctrl/Cmd -click the note where you want the slur to end, in any voice and on any staff
belonging to the same instrument as the note in step 1.
NOTE
Only select those two notes.

3.

Press S .

RESULT
A cross-voice or cross-staff slur is input spanning the select notes. It is placed either above or
below the notes, depending on the stem direction of the notes within the selection.
AFTER COMPLETING THIS TASK
You can change the curvature direction of individual slurs.
RELATED LINKS
Changing the curvature direction of slurs on page 1138
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Nested slurs
Nested slurs are two or more slurs used simultaneously, where the overarching slur shows the
structure of the phrase and the inner slurs show the articulation within the phrase. They are also
known as “slurs within slurs”.
Depending on the stem directions within the overarching outer slur and your settings on the
Slurs page in Engrave > Engraving Options, inner slurs may appear on the opposite side of the
staff to the outer slur.

A phrase with nested slurs

If you want to change the default distance between the endpoints of nested slurs, you can
increase/decrease the project-wide value for Minimum vertical gap between two slurs
starting or ending on the same note in the Avoiding Collisions section of the Slurs page in
Engraving Options.
You can input nested slurs in the same ways as inputting standard slurs. By default, Dorico Pro
makes automatic adjustments to their positioning to avoid collisions if you have not activated
Disable auto curve adjustment in the Slurs group of the Properties panel in Engrave mode.
RELATED LINKS
Enabling/Disabling slur collision avoidance on page 1143

Inputting nested slurs during note input
You can input nested slurs directly during note input, for example, if you already know how you
want to phrase the notes you are currently inputting.
PROCEDURE
1.

In Write mode, start note input.

2.

Press S twice to start two slurs from the currently selected note.
One slur is the inner slur, the other slur is the outer slur.

3.

Input your notes.
The slurs extend automatically as you continue inputting notes, even if there are rests
between the notes you input.

4.

Press Shift-S once to end the inner slur on the currently selected note.

5.

Continue inputting notes.

6.

Optional: Start/End other inner slurs.

7.

Press Shift-S again to end the outer slur on the currently selected note.

RELATED LINKS
Nested slurs on page 1124
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Adding nested slurs to existing notes
You can add multiple slurs to existing notes so that they appear as nested slurs.
PROCEDURE
1.

In Write mode, select the notes you want to include in the outer slur.

2.

Press S to input the outer slur.

3.

Select the notes within the outer slur that you want to place under an inner slur.

4.

Press S to input the inner slur.

5.

Optional: Repeat steps 3 and 4 for any other inner slurs you want.
NOTE
●

You can input the outer slur and inner slurs in any order as Dorico Pro automatically
adjusts slurs so that shorter slurs are positioned within longer slurs, and makes sure
they do not collide.

●

Slur collisions are not automatically avoided if you activate Disable auto curve
adjustment in the Slurs group of the Properties panel for individual notes.

RELATED LINKS
Slur collision avoidance on page 1142

Moving slurs rhythmically
You can move slurs to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the slur you want to move.
NOTE
You can only move one slur rhythmically at a time.

2.

Move the slur to other noteheads on the staff in any of the following ways:
●

Press Alt/Opt-Right Arrow to move it to the next notehead on the staff.

●

Press Alt/Opt-Left Arrow to move it to the previous notehead on the staff.

●

Click and drag it to the right/left.

RESULT
The slur is moved to other noteheads on the staff.
NOTE
The rhythmic duration of the slur is usually maintained. However, depending on the rhythms it
crosses as it moves, the slur may cover longer/shorter durations than before it was moved.
AFTER COMPLETING THIS TASK
You can adjust the shape and graphical positions of slurs, both individually and by changing the
default settings for all slurs.
RELATED LINKS
Slurs in Engrave mode on page 1129
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Lengthening/Shortening slurs
Changing the shape of slurs on page 1131
Project-wide engraving options for slurs on page 1122

Lengthening/Shortening slurs
You can change the length of slurs rhythmically after they have been input.
NOTE
You can only lengthen/shorten cross-staff slurs to notes on the same staff as the corresponding
endpoint, and you can only lengthen/shorten cross-voice slurs to notes in the same voice as the
corresponding endpoint.

PROCEDURE
1.

In Write mode, select the slurs you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one slur at a time.

2.

Lengthen/Shorten the slurs in any of the following ways:
●

Press Shift-Alt/Opt-Right Arrow to lengthen the slur to the next notehead.

●

Press Shift-Alt/Opt-Left Arrow to shorten the slur to the previous notehead.
NOTE
Key commands lengthen/shorten items by moving their end only. You can move the
start of slurs by moving the whole slur, or by clicking and dragging the start handle.

●

Click and drag the start/end of the slur to the next/previous notehead.

RESULT
The selected slurs are lengthened/shortened.
RELATED LINKS
Moving slurs rhythmically on page 1125
Slurs in Engrave mode on page 1129
Cross-staff and cross-voice slurs on page 1123

Linked slurs
Slurs of the same duration at the same rhythmic position on multiple staves can be linked
together. This happens automatically when you copy and paste slurs or material including slurs
between staves, or enter them simultaneously.
If slurs are linked, moving one slur in the linked group moves any slurs linked to it in the same
way. Similarly, lengthening or shortening a slur in a linked group lengthens or shortens any slurs
linked to it in the same way.
However, deleting one slur in a linked group only deletes the slur selected, not the whole group.
Linked slurs appear highlighted when any slur in the linked group is selected.
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Three linked slurs with the top slur selected

You can also manually link and unlink slurs.
RELATED LINKS
Inputting slurs on page 212
Unlinking slurs on page 1127
Disabling automatic linking of dynamics and slurs when pasting on page 329

Linking slurs together
Dorico Pro automatically links slurs of the same duration at the same rhythmic positions
together when you copy and paste slurs or material including slurs between staves, or enter
them simultaneously. However, you can also link slurs together manually.
PROCEDURE
1.

In Write mode, select the slurs you want to link together.
NOTE
Only slurs that have the same duration and start at the same position can be linked together.

2.

Choose Edit > Slurs > Link. You can also choose this option from the context menu.

RESULT
The selected slurs are linked together.

Unlinking slurs
You can unlink slurs manually that were automatically linked together, for example, if you want
to lengthen/shorten them independently of each other.
PROCEDURE
1.

In Write mode, select a slur from each linked group you no longer want to be linked.

2.

Choose Edit > Slurs > Unlink. You can also choose this option from the context menu.

RESULT
All slurs linked to the selected slurs are unlinked.
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NOTE
You cannot only unlink a single slur from the group.

RELATED LINKS
Disabling automatic linking of dynamics and slurs when pasting on page 329

Slur segments
A standard slur consists of one segment. You can make more elaborate shapes with slurs with
multiple segments, for example, to allow you to create more complex slur shapes than are
possible with a single curved segment.
Adding more segments to a slur by default creates evenly spaced waves within its length.
Therefore, having more segments makes each wave shorter.

Slur with eight segments

In Engrave mode, you can move each segment graphically, independently of the other segments
in the slur, as each segment has its own set of five square handles. These allow you to form slurs
into unusual and complicated shapes.
NOTE
You may find that you need more segments than there are curves in your planned shape, as in
many cases you need a segment for each significant change of angle. In Dorico Pro, you can
increase/decrease the number of segments in a slur at any time.

An unusual slur shape created using five segments.

The same slur, showing the positions of the handles
of all five segments.

RELATED LINKS
Changing the shape of slurs on page 1131
Multi-segment slurs in Engrave mode on page 1130

Changing the number of segments in individual slurs
You can change the number of segments in individual slurs, for example, to allow you to create
slurs with unusual shapes.
PROCEDURE
1.

In Engrave mode, select the slurs whose number of segments you want to change.
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2.

In the Properties panel, activate Number of segments in the Slurs group.

3.

Change the value in the value field.

RESULT
Increasing the value increases the number of slur segments. Decreasing the value decreases the
number of slur segments.
AFTER COMPLETING THIS TASK
You can adjust the shape of slur segments in more detail using their handles.
NOTE
Handles on multi-segment slurs are connected to the corresponding type of handle on adjacent
segments. Moving handles causes any connected handles to move the same amount in the
opposite direction.

RELATED LINKS
Changing the shape of slurs on page 1131

Slurs in Engrave mode
In Engrave mode, each slur has five square handles that you can move independently. When
using slur handles to edit slurs in Engrave mode, each handle adjusts the corresponding part of
the slur but can also affect the positions of other handles on the slur.

Slurs have the following handles in Engrave mode:
1

Left endpoint

2

Left control point

3

Slur height

4

Right control point

5

Right endpoint

For example, moving the left endpoint moves the start of a slur, but the rest of the handles stay
in their existing positions. However, moving the right control point also causes the slur height
handle to move. This gives you fine control over the shape of slurs, while ensuring the end result
remains curved and smooth.
NOTE
Multi-segment slurs have additional links between control point handles that affect how they
move in relation to other handles moving.
You can move these handles to change the shape of slurs with the keyboard, with the mouse,
and by using properties in the Slurs group of the Properties panel. You can also change the
angle of slurs without changing their overall shape.
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RELATED LINKS
Slur shoulder offset on page 1136
Slur height on page 1134
Changing the shape of slurs on page 1131
Changing the angle of slurs on page 1132

Multi-segment slurs in Engrave mode
In Engrave mode, each segment in multi-segment slurs, such as S-shaped slurs, has handles just
like standard slurs. This allows you to edit each segment of multi-segment slurs independently as
if they were separate slurs, but in order to maintain a consistent shape, moving certain handles
causes other handles to move simultaneously.
Multi-segment slurs have the following handles in Engrave mode:

1

Left endpoint

2

Left control point

3

Slur height

4

Right control point

5

Center control point

6

Left control point

7

Slur height

8

Right control point

9

Right endpoint

You can select and move each handle in the same ways as for standard slurs; however, handles
on multi-segment slurs are connected between adjacent segments. Moving a connected control
point causes the control point at the start/end of the next/previous segment to move the same
amount in the opposite direction. This avoids tight corners, ensuring that multi-segment slurs
are always as smoothly and symmetrically curved as possible.
In multi-segment slurs, right control points are connected to the left control point in the adjacent
segment. If there is no adjacent segment, the right/left control points next to the right/left
endpoints can be moved independently. For example, in the labeled diagram, the control point 4
is connected to control point 6, but control points 2 and 8 are not connected to another control
point.
Similarly, moving the slur height handle causes the slur height handle on any adjacent segments
to move the same amount in the opposite direction. For example, if you move the slur height
handle on the middle segment of a slur with three segments, all three slur height handles are
moved.
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EXAMPLE

The left control point is selected.

Moving the selected left control point upwards and
to the left causes the right control point on the
adjacent segment to move downwards and to the
right.

Changing the shape of slurs
You can change the shape of individual slurs and move slurs/slur handles graphically, for
example, if you want to adjust an endpoint relative to an individual notehead. This only changes
the appearance of slurs, and does not change the rhythmic positions to which they are attached.
PROCEDURE
1.

In Engrave mode, select the whole slurs or individual slur handles you want to move in any
of the following ways:
●

Ctrl/Cmd -click multiple slurs.

●

Select a whole slur and press Tab to cycle through the handles until the one you want to
move is selected.

●

Click the handle you want to move.

●

Ctrl/Cmd -click individual handles on multiple slurs.

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the slurs or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move handles to the right.

●

Press Alt/Opt-Left Arrow to move handles to the left.

●

Press Alt/Opt-Up Arrow to move slurs or handles upwards.

●

Press Alt/Opt-Down Arrow to move slurs or handles downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag the slurs upwards/downwards.

●

Click and drag the handles in any direction.

NOTE
You cannot move whole slurs to the right/left, you can only move them upwards/downwards.
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3.

Optional: Repeat steps 1 and 2 for any other slurs or slur handles you want to move.

RESULT
The selected slurs or slur handles are moved. Depending on the handles you selected, this can
change the shape of the corresponding slurs.
TIP
The following properties in the Slurs group of the Properties panel are activated automatically
when you move the corresponding slur handles:
●

Start offset moves the left endpoints of slurs. X moves them horizontally, Y moves them
vertically.

●

End offset moves the right endpoints of slurs. X moves them horizontally, Y moves them
vertically.

●

Start handle offset moves the left control points of slurs. X moves them horizontally, Y
moves them vertically.

●

End handle offset moves the right control points of slurs. X moves them horizontally, Y
moves them vertically.

For example, if you move a whole slur upwards and to the right, all of its handles are moved so
all properties are activated. You can also use these properties to change the shape of individual
slurs by changing the values in the value fields.
Deactivating the properties resets the corresponding handles on the selected slurs to their
default positions.
AFTER COMPLETING THIS TASK
You can also change the angle of slurs without affecting their overall shape.
RELATED LINKS
Slur height on page 1134
Slur shoulder offset on page 1136

Changing the angle of slurs
You can change the angle or rotation of individual slurs without affecting their overall shape.
This is useful, for example, if you want one end of a slur to start higher after a system break than
its default position, as you can change the rotation of the slur while keeping all slur handles on
the slur in the same positions relative to each other.
PROCEDURE
1.

In Engrave mode, select an endpoint on the slurs whose angle you want to change.
TIP

2.

●

You can select individual handles on multiple slurs by holding down Ctrl/Cmd and
clicking.

●

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

Alt/Opt -click and drag the endpoints in any direction.
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NOTE
You cannot use the keyboard to change the angles of individual slurs.

RESULT
The angle or rotation of the selected slurs is changed without affecting their shape.
EXAMPLE

Endpoint moved without holding Alt/Opt

Endpoint moved while holding Alt/Opt

Changing the thickness of slurs
You can change the thickness of individual slurs, including changing the thickness of the middle
of slurs independently of the ends of slurs, independently of your project-wide settings.
PROCEDURE
1.

In Engrave mode, select the slurs whose thickness you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Slurs group:

3.

●

End thickness

●

Middle thickness

Change the values in the value fields.

RESULT
Increasing the values makes the corresponding part of the selected slurs thicker, decreasing the
values makes the corresponding part of the selected slurs thinner.
TIP
●

Deactivating the properties returns the corresponding part of the selected slurs to their
default thickness.

●

You can change the default thickness of all slurs project-wide on the Slurs page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide engraving options for slurs on page 1122

Short slurs that cover large pitch ranges
When short slurs span large pitch ranges, they are significantly rotated to compensate. This can
make the ends of short slurs appear too angular.
You can move the control point handles of slurs to improve their curves.
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Of the three examples, the middle slur has the smoothest curve. The handles on the slur on the
right have been moved poorly, making the curve far too angular.
In the bottom row, the positions of the handles are shown to indicate how each curve above was
created.

Short slur spanning a large pitch
range, without adjustment

The same slur with some shape
adjustment, making the curve
smoother

The same slur again with poor
adjustment, making the curve too
angular

Default slur handle placement

Slur handle placement to create
the corresponding slur

Slur handle placement to create
the corresponding slur

TIP
When adjusting slur ends, you can achieve the best results using the following guidelines:
●

The control point at the lower end of the slur does not extend outside the width of the slur,
as marked by its neighboring endpoint.

●

The control point at the higher end of the slur does not form an angle greater than 90
degrees relative to the endpoints. You can use the dashed lines to help you judge this.

You can adjust the shape of short slur ends in different ways:
●

Project-wide, by increasing the value for Offset shoulders by fraction of half length of
short slur, which you can find by clicking Advanced Options in the Design section of the
Slurs page in Engrave > Engraving Options.

●

Individually, by activating Start handle offset and End handle offset in the Properties panel
in Engrave mode, and changing their X values.

●

Individually, by moving the handles of slurs in Engrave mode.

RELATED LINKS
Slurs in Engrave mode on page 1129
Project-wide engraving options for slurs on page 1122
Changing the shape of slurs on page 1131

Slur height
The height of slurs determines how far above/below notes slurs extend vertically.
You can change values for the heights of all slurs project-wide on the Slurs page in Engraving
Options. You can also change the height of individual slurs in Engrave mode.
Increasing the height of slurs makes them extend further from the staff. This gives them a
rounder shape, which takes up more vertical space. Where vertical space is limited, there should
be a balance between how curved slurs are, which can help readability for players, and ensuring
staves do not overlap.
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A long slur with default height

A long slur with increased height

A long flat slur with default height

A long flat slur with increased height

TIP
You can find options that change project-wide values for the height of short slurs, short flat slurs,
long slurs, and long flat slurs by clicking Advanced Options in the Design section of the Slurs
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for slurs on page 1122

Changing the height of slurs
You can change the height of individual slurs independently of your project-wide settings, for
example, to reduce the height of a particularly long slur.
PROCEDURE
1.

In Engrave mode, select the slur height (middle) handle of the slurs whose height you want
to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag them upwards/downwards.

RESULT
The height of the selected slurs is changed.
NOTE
●

To maintain a visually pleasing and symmetrical curve when changing the height of slurs
manually, you may need to move slur height handles to the right/left by a small amount, as
well as upwards/downwards.

●

Moving slur height handles to the right/left affects the shape of the whole slur.
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●

You can find options controlling the default height of all slurs project-wide by clicking
Advanced Options in the Design section of the Slurs page in Engrave > Engraving
Options. There are separate settings for short slurs and long slurs.

RELATED LINKS
Changing the shape of slurs on page 1131

Slur shoulder offset
Slur shoulders affect the angles of the curves of slurs as they taper towards an endpoint, because
the tapered ends often approach noteheads at a steeper angle than that of a slur’s arch.
Increasing the shoulder offset makes the onset of the curve shallower, whereas decreasing the
shoulder offset makes the onset steeper. The shoulder offset must therefore be balanced with
the height of the slur in order to achieve the ideal curved shape.

A long slur with default shoulder
offset of 1/5

A long slur with increased
shoulder offset of 1.5

A long slur with decreased
shoulder offset of 1/2

You can change the project-wide settings for the shoulder offset of slurs and the shoulder offset
of flat slurs by changing the values of the following options, which you can find by clicking
Advanced Options in the Design section of the Slurs page in Engraving Options.
●

Offset shoulders by fraction of half length of short slur

●

Offset shoulders by fraction of half length of long slur

●

Offset shoulders by fraction of half length of flat slur

You can adjust the shoulders of individual slurs in Engrave mode.
RELATED LINKS
Slur height on page 1134

Changing the shoulder offset of slurs
You can adjust the shoulders of individual slurs, independently of your project-wide settings, by
moving their control point handles. You can move each control point independently.
PROCEDURE
1.

In Engrave mode, select one of the control point handles on each of the slurs whose
shoulders you want to adjust in any of the following ways:
●

Select a whole slur and press Tab to cycle through the handles until the one you want to
move is selected.

●

Click the handle you want to move.

●

Ctrl/Cmd -click individual handles on multiple slurs.

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
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2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●
3.

Click and drag them in any direction.

Optional: Repeat steps 1 and 2 for the other control point handle on the slurs whose
shoulders you want to adjust.

RESULT
The shoulder offset of the selected slurs is changed.
TIP
●

The following properties in the Slurs group of the Properties panel are activated
automatically when you move the corresponding slur handles:
●

Start handle offset moves the left control points of slurs. X moves them horizontally, Y
moves them vertically.

●

End handle offset moves the right control points of slurs. X moves them horizontally, Y
moves them vertically.

You can also use these properties to change the shoulder offset of individual slurs by
changing the values in the value fields.
Deactivating the properties resets the corresponding handles on the selected slurs to their
default positions.
●

You can find options controlling the default shoulder offset of all slurs project-wide by
clicking Advanced Options in the Design section of the Slurs page in Engrave > Engraving
Options. There are separate settings for short slurs and long slurs.

RELATED LINKS
Project-wide engraving options for slurs on page 1122

Slur curvature direction
Slurs can curve upwards, downwards, or have a multi-segment S-shape.
The following options for slur curvature direction are available when you activate Direction in
the Slurs group of the Properties panel:
Up
Forces slurs to curve upwards, and appear above notes.

Down
Forces slurs to curve downwards, and appear below notes.
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Up/Down
Forces slurs to comprise two segments: the first curves upwards, the second curves
downwards to create a mirrored S-shape. It is typically used when phrases start in the
lower staff and end in the upper staff, for example, in piano parts.

Down/Up
Forces slurs to comprise two segments: the first curves downwards, the second curves
upwards to create an S-shape. It is typically used when phrases start in the upper staff
and end in the lower staff, for example, in piano parts.

TIP
You can adjust the precise shapes of individual slurs, and each slur segment, in Engrave mode
using the square handles on each slur.

RELATED LINKS
Slurs in Engrave mode on page 1129
Changing the shape of slurs on page 1131

Changing the curvature direction of slurs
You can change the curvature direction of individual slurs so that they curve upwards,
downwards, or have a multi-segment S-shape, independently of your project-wide settings.
PROCEDURE
1.

Select the slurs whose curvature direction you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Direction in the Slurs group.

3.

Choose one of the following options:
●

Up

●

Down

●

Up/Down (mirrored S-shape)

●

Down/Up (S-shape)

RESULT
The curvature direction of the selected slurs is changed.
TIP
●

You can adjust the precise shapes of slurs, and each slur segment, in Engrave mode using
the handles on each slur.

●

You can change the default curvature direction behavior of all slurs project-wide on the Slurs
page in Engrave > Engraving Options.

RELATED LINKS
Slurs in Engrave mode on page 1129
Changing the shape of slurs on page 1131
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Slur styles
There are different styles of slurs available in Dorico Pro, which indicate different meanings and
have different use cases.
The following options for slur style are available when you activate Style in the Slurs group of the
Properties panel:
Solid
This is the default style for slurs. Slurs appear as tapered solid lines: thinner at the ends
and thicker in the middle.

Dashed
Slurs appear as tapered dashed lines. Can be used to indicate an optional slur, for
example, to recommend breathing/bowing patterns.

Dotted
Slurs appear as dotted lines. The dots are the same size and the same distance apart
over the whole length of the slur.

Half-dashed start
The first halves of slurs appear as dashed lines, the second halves as solid lines. Used
to denote that a slur was written incompletely in the source in critical editions.

Half-dashed end
The first halves of slurs appear as solid lines, the second halves as dashed lines. Used
to denote that a slur was written incompletely in the source in critical editions.

Editorial
Slurs appear as solid black lines, but with a smaller vertical line intersecting them
exactly halfway along their length, perpendicular to the curve of the slur. Used to show
that a slur was added by the editor and was not present in the original source.

TIP
You can set the precise parameters of each of these options project-wide on the Slurs page in
Engrave > Engraving Options. For example, you can change the length and width of the stroke
in Editorial slurs, the diameter of dots and length of dashes, and the sizes of the gaps between
dots and dashes.
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Changing the style of slurs
You can change the style of individual slurs after they have been input.
PROCEDURE
1.

Select the slurs whose style you want to change. You can do this in Write mode and Engrave
mode.

2.

In the Properties panel, activate Style in the Slurs group.

3.

Select one of the following options from the menu:
●

Solid

●

Dashed

●

Dotted

●

Half-dashed start

●

Half-dashed end

●

Editorial

Changing the size of dashes/dots in slurs
You can change the length of dashes and the size of dots in dashed/dotted slurs individually,
independently of your project-wide settings.
NOTE
These steps only apply to dashed/dotted slurs.

PROCEDURE
1.

In Engrave mode, select the dashed/dotted slurs whose dash length/dot size you want to
change.

2.

In the Properties panel, activate one of the following properties in the Slurs group:

3.

●

For dashed slurs, activate Dash length.

●

For dotted slurs, activate Dot size.

Change the value in the value field.

RESULT
Increasing the value makes dashes longer and dots bigger, decreasing the value makes dashes
shorter and dots smaller.
TIP
You can find options to set the default size of dashes/dots in all dashed/dotted slurs project-wide
by clicking Advanced Options in the Design section of the Slurs page in Engrave > Engraving
Options.

RELATED LINKS
Project-wide engraving options for slurs on page 1122
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Changing the size of gaps in dashed/dotted slurs
You can change the length of gaps in dashed/dotted slurs individually, independently of your
project-wide settings.
PROCEDURE
1.

In Engrave mode, select the dashed/dotted slurs whose gap length you want to change.

2.

In the Properties panel, activate one of the following properties in the Slurs group:

3.

●

For dashed slurs, activate Dash gap length.

●

For dotted slurs, activate Dot gap length.

Change the values in the value fields.

RESULT
Increasing the values makes the gaps between dashes/dots larger. Decreasing the values makes
the gaps between dashes/dots smaller.
TIP
You can find options to set the default length of the gaps between dashes/dots in all dashed/
dotted slurs project-wide by clicking Advanced Options in the Design section of the Slurs page
in Engrave > Engraving Options.

Changing individual slurs to flat slurs
Although they are not often used as standard, some publishers use flat slurs in order to reduce
the vertical space occupied by slurs. You can change individual slurs to flat slurs, independently
of your project-wide setting.
NOTE
Short slurs, that is, slurs between only a few notes, can look odd as flat slurs, so it may not be
appropriate to select the flat curvature style project-wide. However, it would also be unusual only
to use flat slurs once or twice in a project. Therefore, we recommend that you avoid changing the
curvature style for only one or two slurs in a project.
It can be more effective to modify them rather than changing their curvature style, for example,
by making an individual slur thicker/thinner, adjusting the shoulder offset of slurs, or adjusting
their height using their slur height handles in Engrave mode.

PROCEDURE
1.

Select the slurs whose curvature style you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Curvature style in the Slurs group.

3.

Choose one of the following options:
●

Normal (curved)

●

Flat

RESULT
The curvature style of the selected slurs is changed.
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TIP
You can change the curvature style of all slurs project-wide in the Design section of the Slurs
page in Engrave > Engraving Options.

RELATED LINKS
Changing the thickness of slurs on page 1133
Changing the height of slurs on page 1135
Changing the shoulder offset of slurs on page 1136
Project-wide engraving options for slurs on page 1122

Slur collision avoidance
By default, Dorico Pro automatically adjusts the shape and position of slurs to avoid collisions
with items under their arc.
This means that if a notehead under a slur is either higher than the others under a slur curving
upwards, or lower than the others under a slur curving downwards, the curvature of the slur is
adjusted to avoid the collision and keep the notehead under the slur. You can manually disable
collision avoidance for individual slurs.
In the Avoiding Collisions section of the Slurs page in Engrave > Engraving Options, you can
choose options for how slurs are adjusted to avoid collisions, such as choosing a balance
between changing the shape of slurs to compensate or moving the endpoints of a slur, and how
asymmetrical slurs are allowed to be.

Slur with collision avoidance activated (default)

Slur with collision avoidance deactivated

Collision avoidance for cross-staff slurs
In the Avoiding Collisions section of the Slurs page in Engrave > Engraving Options, you can
activate/deactivate collision avoidance for cross-staff slurs.
This avoids collisions, but due to the increased complexity in positioning slurs across staves,
further manual adjustment in Engrave mode might be required.
NOTE
This setting does not apply to S-shaped slurs between staves, which do not have any collision
avoidance.

Slurs bisecting flat accidentals
According to conventions in published music, slurs can bisect the stems of flat accidentals, but
not sharps or naturals, to save vertical space.
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You can choose not to allow slurs to bisect flat signs, or alter the maximum amount of the stems
of flat signs that can protrude above slurs, on the Slurs page in Engraving Options.
RELATED LINKS
Project-wide engraving options for slurs on page 1122

Enabling/Disabling slur collision avoidance
You can allow or prevent individual slurs from automatically adjusting to avoid collisions,
independently of your project-wide settings.
PROCEDURE
1.

In Engrave mode, select the slurs whose collision avoidance you want to enable/disable.

2.

In the Properties panel, activate/deactivate Disable auto curve adjustment in the Slurs
group.

RESULT
The selected slurs do not avoid collisions when the property is activated, and avoid collisions
when the property is deactivated.
TIP
You can enable/disable slur collision avoidance for all cross-staff slurs project-wide in the
Avoiding Collisions section of the Slurs page in Engrave > Engraving Options.
You can also customize the default settings for the shape and endpoint positions of slurs that are
avoiding collisions in this section.

Slurs over system and frame breaks
Slurs automatically cross system breaks and frame breaks.
A system or frame break divides slurs into two parts. The end of the first part of the slur, and the
start of the second part of the slur, are both positioned 1 space vertically outside the staff by
default.
In Engrave mode, you can move and edit each slur part separately. This allows you to adjust the
start/end height of each slur part independently on each system.
If multiple slurs cross the same system break or frame break, such as if a phrase split by a break
contains nested slurs, the ends of the slurs are stacked automatically and spaced a minimum of
1/2 space apart vertically.

The end of a system showing the first slur part; the
end on the right indicates a continuation to the next
system.

RELATED LINKS
Slurs in Engrave mode on page 1129
Changing the shape of slurs on page 1131
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Slurs in playback
Slurs trigger the legato playing technique in playback. By default, this increases the length of the
MIDI notes without affecting the notation of the music.
Slurred notes sound for 105% of the length indicated by their notated rhythm, as opposed to
non-slurred notes which sound for 85% of their notated rhythm.
The final note of a slur sounds for 85% of its notated rhythm, as there is no slur after it and the
legato technique is no longer required.
TIP
●

You can change the default values for the sounding duration of slurred notes on the Timing
page in Play > Playback Options.

●

You can enable independent voice playback for individual instruments, for example, if you
have slurs in one voice and staccatos in another voice.

The example shows how MIDI note length, indicated by the filled, light-colored rectangles, is
increased when slurs are used. The thin, darker rod shows the notated duration of each note.
The first three notes are non-slurred, so the MIDI length rectangle is shorter than the line of the
notated rhythm. The last four notes are slurred together, so the MIDI length is longer than the
notated length in order to create the legato, slurred sound. However, the last note of the slurred
group is not longer, as the last note of a slurred phrase is treated like a normal, non-slurred note.

A phrase in an instrument staff

The same phrase in the piano roll in Play mode

RELATED LINKS
Playback Options dialog on page 502
Played vs. notated note durations on page 590
Enabling independent voice playback on page 543
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Staff labels are used to identify staves in music containing multiple players, and are positioned to
the left of systems, before the initial barline of each system. Staff labels indicate the instrument
or instruments currently playing the music on the staff or staves to which they apply.
It is usual to show instrument names in full in the staff labels for the first systems in each flow,
and abbreviated instrument names in the staff labels of subsequent systems. Using abbreviated
instrument names saves horizontal space, allowing you to include more music in each system.

Examples of staff labels on the first system in a flow

In Dorico Pro, staff labels use the instrument names set for each instrument in the Edit
Instrument Names dialog. In the dialog, you can specify singular and plural names for each
instrument, and singular and plural abbreviations for each instrument.
TIP
You do not need to number instruments in staff labels manually, as Dorico Pro automatically
numbers instruments when there are multiple players of the same type playing instruments of
the same type.
Part layouts by default do not show staff labels, as most parts only contain a single staff whose
identity is clear from the context and the layout name. The layout name is shown at the top left
of the first page in part layouts by default.
NOTE
Layout names are different to the instrument names used for staff labels.
For players holding multiple instruments, the staff label shows the instrument they are currently
playing. If the player changes instrument partway through a system, the name of the new
instrument is shown above the staff at its first note and the staff label is updated at the start of
the next system.
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NOTE
Staff labels do not show all instruments held by players, for example, in the staff label for the first
system. You should include a comprehensive instrumentation list that shows any doubling at the
front of your score.
Dorico Pro includes the instrument transposition, or instrument pitch, in staff labels for
transposing instruments by default. Transposing instruments are instruments whose sounding
pitch is different to the notated pitch.
You can change when instrument transpositions, or instrument pitches, are shown in staff labels.
You can also change whether the instrument transposition is shown before or after the
instrument name in staff labels.

Staff labels imported from MusicXML files
When exporting MusicXML files from Cubase and importing them into Dorico Pro, you can
improve the accuracy of the automatic instrument selection by changing the instrument names
in the Cubase Score Editor to the same English instrument names that Dorico Pro uses before
exporting the file.
RELATED LINKS
Player, layout, and instrument names on page 139
Instrument numbering on page 113
Edit Instrument Names dialog on page 140
Changing instrument names on page 144
Divisi staff labels on page 1184
Staff labels on condensed staves on page 1156

Instrument names in staff labels
Staff labels use the instrument names set for each instrument. Staff labels can show full or short
instrument names.
On the Staves and Systems page in Setup > Layout Options, you can choose whether you want
to show full, short, or no instrument names in staff labels in each layout independently.
●

Full staff labels use full instrument names.

●

Abbreviated staff labels use short instrument names.

●

None shows no staff labels.

Instrument numbers are automatically shown in both full and abbreviated staff labels.
NOTE
●

You can change the full and short instrument names for each instrument in the Edit
Instrument Names dialog in Setup mode.

●

Changing instrument names does not change the name shown at the top of each part
layout, as that uses the layout name. You can change the layout name in Setup mode.

RELATED LINKS
Player, layout, and instrument names on page 139
Instrument numbering on page 113
Hiding/Showing staff labels on page 1148
Edit Instrument Names dialog on page 140
Changing instrument names on page 144
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Staff label paragraph styles
Staff labels use paragraph styles to format their fonts, including their size, spacing, alignment,
and other formatting options. When staff labels contain multiple separate parts, such as when
the instrument name and instrument number have different vertical positions, you can format
each part separately.
Dorico Pro provides the following default paragraph styles for staff labels:
●

Staff Labels: The default style used for staff labels that have the instrument name and
number aligned and next to each other. It is also used for the group labels on divisi staves
and for instrument names aligned between multiple identical instruments or between player
numbers in staff labels on condensed staves.

●

Staff Labels (Inner): Used for individual staves within divisi groups, instrument numbers
when instrument names are aligned between multiple identical instruments, and player
numbers in staff labels on condensed staves.

●

Staff Labels (Percussion Grid): Used for percussion kits in layouts using the grid
presentation.

You can edit each paragraph style independently of each other in the Paragraph Styles dialog,
for example, if you want outer staff labels to be left-aligned but inner staff labels to be rightaligned.
TIP
You can make further changes to the appearance and alignment of staff labels on divisi staves at
each individual divisi change.

RELATED LINKS
Paragraph Styles dialog on page 410
Editing divisi staff labels on page 1184
Staff labels on condensed staves on page 1156

Project-wide engraving options for staff labels
You can find options for the project-wide appearance and position of staff labels on the Staff
Labels page in Engrave > Engraving Options.
For example, you can change the distance between staff labels and the systemic barline and
whether instruments are numbered using Arabic or Roman numerals. You can also determine
whether a single instrument name for adjacent identical solo instruments is grouped and shown
justified between their staves or shown on each staff, and whether vocal staff labels are
uppercase or title case. There are also options specifically for ossia staff labels and staff labels on
condensed staves.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
TIP
You can change the length of staff labels shown on systems for each layout independently on the
Staves and Systems page in Setup > Layout Options.

RELATED LINKS
Engraving Options dialog on page 359
Changing the staff label numbering style on page 1153
Showing vocal staff labels in uppercase/title case on page 1154
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Hiding/Showing staff labels
You can show full or abbreviated instrument names in staff labels, or hide all staff labels entirely,
in each layout independently. The first system in each flow and all subsequent systems can have
different staff label lengths.
By default, full staff labels are shown on the first system of each flow and abbreviated staff labels
are shown on subsequent systems in full score layouts. In part layouts, staff labels are not shown
on any systems.
PROCEDURE
1.
2.

Press Ctrl/Cmd-Shift-L to open Layout Options.
In the Layouts list, select the layouts in which you want to hide/show staff labels.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Staff Labels section, select one of the following options from the Staff labels on first
system menu:

5.

6.

●

Full

●

Abbreviated

●

None

Select one of the following options from the Staff labels on subsequent systems menu:
●

Full

●

Abbreviated

●

None

Click Apply, then Close.

RESULT
Staff labels are hidden/shown on the corresponding staves in the selected layouts.
●

None hides staff labels.

●

Full and Abbreviated show staff labels using the corresponding instrument name length.

TIP
●

These settings apply to each flow in the layout, not the project as a whole. If, for example,
you want to show full staff labels on the first system in the first flow in your project, but want
to show abbreviated staff labels on the first systems of all subsequent flows, we recommend
choosing the setting appropriate for the most flows in the layout, then changing the length
of staff labels at other positions as required.

●

You can change both full and short instrument names in the Edit Instrument Names dialog.

RELATED LINKS
Instrument names in staff labels on page 1146
Changing instrument names on page 144
Edit Instrument Names dialog on page 140
Hiding/Showing staff labels at specific positions on page 1149
Hiding/Showing divisi section numbers in staff labels on page 1185
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Changing the minimum indent for systems with staff labels
You can change the minimum indent for all systems that show staff labels to optimize horizontal
space in each layout independently.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts whose minimum indent for systems with staff labels
you want to change.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Staff Labels section, change the value for Minimum indent for systems with staff
labels.

5.

Click Apply, then Close.

RESULT
The minimum indent on all systems that show staff labels is changed in the selected layouts.
RELATED LINKS
System indents on page 1174
Changing the first system indent on page 1175
Changing the start/end position of systems on page 433

Hiding/Showing staff labels at specific positions
You can change whether staff labels at specific positions show full, abbreviated, or no instrument
names, independently of your per-layout settings. For example, if you want full staff labels at the
start of the first flow but abbreviated staff labels at the start of subsequent flows, or if you want
to show staff labels in choral music only on systems that contain more complicated parts, solo
lines, or divisi lines.
PREREQUISITE
●

You have inserted a system or frame break at the position from which you want to change
the length of instrument names in staff labels.

●

Signposts are shown for system/frame breaks.

PROCEDURE
1.

In Engrave mode, select the system/frame break signposts at the positions where you want
to hide/show staff labels.

2.

In the Properties panel, activate Staff labels in the Format group.

3.

Select one of the following options from the menu:
●

Full

●

Abbreviated

●

None
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RESULT
Staff labels are hidden/shown on the corresponding systems to the selected system/frame
breaks. Horizontal spacing is automatically adjusted so the system fills the width of the music
frame.
●

None hides staff labels.

●

Full and Abbreviated show staff labels using the corresponding instrument name length.

Deactivating the property returns any selected system break signposts to your per-layout
settings.
EXAMPLE

Full staff labels shown

No staff labels shown

RELATED LINKS
Staff labels on page 1145
Instrument names in staff labels on page 1146
Hiding/Showing staff labels on page 1148
Inserting system breaks on page 466
Inserting frame breaks on page 463
Hiding/Showing system break signposts on page 467
Hiding/Showing frame break signposts on page 465

Instrument transpositions in staff labels
Instrument transpositions indicate the interval between the note an instrument plays and the
sounding note produced. Transposing instruments, such as Horn in F and Clarinet in B♭, are
commonly shown with their transposition, also known as their “instrument pitch”, as part of their
instrument name or layout name.
Depending on the options set for Show transposition in the Edit Instrument Names dialog for
each transposing instrument, they might show transpositions in staff labels even if you have
hidden transpositions in staff labels in their layout.
Dorico Pro sets common transposing instruments, such as Clarinet in B♭ and Trumpet in B♭, to
follow your per-layout settings for hiding/showing instrument transpositions in staff labels.
To reduce the risk of confusion, uncommon transposing instruments, such as Clarinet in A or
Trumpet in E, are set to show their transposition in staff labels always, even if you have hidden
instrument transpositions in the layout.
RELATED LINKS
Edit Instrument Names dialog on page 140
Transposing instruments on page 115
Changing instrument names on page 144
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Hiding/Showing instrument transpositions in staff labels
You can hide/show instrument transpositions in staff labels in each layout independently. For
example, you can hide instrument transpositions in staff labels in full score layouts but show
them in part layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show instrument
transpositions in staff labels.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Staff Labels section, activate/deactivate the following options for Instrument pitch
or transposition:
●

Show in full staff labels

●

Show in abbreviated staff labels

5.

Optional: Repeat steps 2 to 4 for other layouts.

6.

Click Apply, then Close.

RESULT
Instrument transpositions are shown in staff labels of the corresponding length in the selected
layouts when the corresponding checkbox is activated, and hidden when the corresponding
checkbox is deactivated.
NOTE
Depending on the options set for Show transposition in the Edit Instrument Names dialog for
each transposing instrument, they might show transpositions in staff labels even if you have
hidden transpositions in staff labels in their layout.

RELATED LINKS
Changing instrument names on page 144

Changing the position of instrument transpositions in full staff
labels
You can show instrument transpositions before/after instrument names in staff labels in each
layout independently.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts whose instrument transposition position you want to
change.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Staff Labels section, choose one of the following options for Position of instrument
pitch in full staff labels:
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5.

●

Start

●

End

Click Apply, then Close.

RESULT
The position of instrument transpositions relative to instrument names in staff labels is changed
in the selected layouts.

Numbering instruments with different transpositions separately/
together
You can change whether instruments are numbered separately or together in all staff labels
project-wide when you have multiple instruments of the same type but with different
transpositions, such as two Horns in F and two Horns in D. By default, Dorico Pro numbers
instruments with different transpositions separately.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Staff Labels in the page list.

3.

In the Numbering subsection, choose one of the following options for Numbering for
similar instruments with different transpositions:

4.

●

Number separately

●

Number together

Click Apply, then Close.

Hiding/Showing instrument change labels at the start of
flows
You can hide/show instrument change labels at the start of each flow in each layout
independently. These labels can be useful for players holding multiple instruments as a way of
clarifying the instrument required in their part layouts, which do not normally show staff labels.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show instrument change
labels at the start of flows.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Instrument Changes section, activate/deactivate Show instrument change label at
start of flow.

5.

Click Apply, then Close.

RESULT
Instrument change labels are shown in the first bar of each flow in the selected layouts when
Show instrument change label at start of flow is activated, and hidden when it is deactivated.
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Grouping the staff labels of adjacent identical instruments
When multiple adjacent solo players hold the same instrument, you can group them so that
there is only a single instrument name for all staves with the instrument number shown beside
each individual staff.
By default, every staff is shown with its own staff label, including the appropriate instrument
name.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Staff Labels in the page list.

3.

In the Numbering subsection, choose Group between staves for Staff labels for identical
adjacent solo instruments.

4.

Click Apply, then Close.

RESULT
A single instrument name is shown justified between all adjacent identical solo instruments in all
layouts project-wide.
EXAMPLE

Each staff shown with a separate staff label

Staff labels grouped between adjacent identical solo
instruments

RELATED LINKS
Staff labels on condensed staves on page 1156

Changing the staff label numbering style
You can change the staff label numbering style of solo and section players independently, for
example, if you want solo players to use Arabic numerals, such as “2”, and section players to use
Roman numerals, such as “II”.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Staff Labels in the page list.

3.

In the Numbering subsection, choose one of the following options for Numbering style for
solo players:
●

Arabic numerals

●

Roman numerals

1153
Dorico Pro 3.1.10

Staff labels
Showing vocal staff labels in uppercase/title case
4.

5.

Choose one of the following options for Numbering style for section players:
●

Arabic numerals

●

Roman numerals

Click Apply, then Close.

RESULT
Instruments held by solo and section players use the selected numbering style in all layouts
project-wide.
RELATED LINKS
Staff labels on condensed staves on page 1156
Condensing on page 470

Showing vocal staff labels in uppercase/title case
You can show the staff labels on vocal staves in uppercase letters or in title case. Many European
publishers prefer vocal staves to have staff labels with capital letters, but this is not true of all
publishers.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Staff Labels in the page list.

3.

In the Case subsection, choose one of the following options for Labels for vocal staves:

4.

●

Shown in uppercase

●

Shown in title case

Click Apply, then Close.

RESULT
Staff labels on all vocal staves project-wide use either uppercase letters or title case.

Staff labels for percussion kits
The staff labels shown for percussion kit staves depend on how kits are presented in your
project. Kits can be presented as five-line staves, grids, and as single-line instruments.

Percussion kit presentation
type

Staff label

5-line staff

Single instrument name using
the instrument name of the
percussion kit.
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Percussion kit presentation
type

Staff label

Grid

Multiple instrument names:
one for each kit instrument,
positioned at the staff position
of the corresponding
instrument.

Example

Staff labels for grids use a
smaller font and a different
paragraph style than used for
standard instrument staff
labels.
Single-line instruments

Multiple instrument names:
one for each kit instrument,
positioned beside the
corresponding single-line
staff.
Staff labels for single-line
instruments use the same font
and paragraph style as used
for standard instrument staff
labels.

You can change the player names, layout names, and instrument names of percussion kits in the
same ways as for other players and instruments. However, to change the staff labels for
percussion kits, you must change kit instrument names in different ways for percussion kits,
depending on your percussion kit presentation type:
●

5-line staff: Open the Edit Instrument Names dialog from the Players panel in Setup mode,
or use the Name field in the Edit Percussion Kit dialog, to change the name of the kit.

●

Grid/Single-line instruments: Open the Edit Instrument Names dialog from inside the Edit
Percussion Kit dialog in Setup mode to change the names of individual instruments.

The same instrument name fields and options are available for kit instruments as for standard
pitched instruments.
NOTE
Smaller staff labels for each line in grid presentations use the Staff Labels (Percussion Grid)
paragraph style. You can edit this paragraph style in the Paragraph Styles dialog.

RELATED LINKS
Edit Instrument Names dialog on page 140
Player, layout, and instrument names on page 139
Edit Percussion Kit dialog on page 120
Unpitched percussion on page 1275
Changing the presentation type of percussion kits on page 1282
Paragraph Styles dialog on page 410
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Staff labels on condensed staves
Staff labels on condensed staves must reflect all the players included on the staff. Dorico Pro
automatically consolidates similar instrument names in staff labels on condensed staves but
always shows all the required player numbers.
On condensed staves containing different types of instruments, all required instrument names
are shown.

Staff labels on condensed brass staves

Because condensing can change frequently, staff labels on condensed staves can vary from one
system to another. You can change how player numbers are stacked in staff labels on condensed
staves.
Dorico Pro also shows player labels above/below condensed staves to identify the players to
which notes on condensed staves belong, as condensing can change within a single system.
NOTE
Your setting for the grouping of staff labels of adjacent identical instruments applies to adjacent
condensed staves with the same instruments, such as if you have a condensed staff for Flutes 1-2
and a separate staff for Flute 3.
Your settings for staff label numbering styles also apply to condensed staves.

RELATED LINKS
Staff label paragraph styles on page 1147
Player labels on page 486
Condensing on page 470
Condensing calculations and considerations on page 474
Condensing results on page 476
Enabling/Disabling condensing on page 449
Grouping the staff labels of adjacent identical instruments on page 1153
Changing the staff label numbering style on page 1153
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Changing number stacking in condensed staff labels
You can change how player numbers on condensed staves are stacked, for example, if you
always want them stacked vertically, including on systems where players are condensed into a
single voice.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Staff Labels in the page list.

3.

In the Numbering subsection, choose one of the following options for Player numbers for
condensed players:

4.

5.

●

Stack vertically

●

Stack horizontally

Optional: If you chose Stack vertically, choose one of the following options for When
stacking player numbers for condensed players vertically:
●

Consider stem allocation

●

Ignore stem allocation

Click Apply, then Close.

RESULT
The stacking of player numbers in all staff labels on condensed staves is changed project-wide.
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A staff is a line or group of lines on which musical notes are notated to indicate the pitch and
rhythm of music. Pitched instruments use the traditional five-line staff and unpitched
instruments often use a single-line staff.
Notes are positioned on the lines and in the spaces on five-line staves, and can also use ledger
lines above/below the staff to represent pitches that cannot fit on the staff.

A phrase on a five-line staff

The same phrase on a single-line staff

The pitch and register of notes on five-line staves are determined by clefs, which can also be
combined with octave lines to indicate what pitches performers play.
On five-line staves for unpitched percussion instruments, the different staff positions correspond
to different percussion instruments.

Because it is often necessary to have different staff sizes in different layouts depending on their
type, such as having smaller staves in full score layouts than in part layouts, in Dorico Pro you
can change various aspects of staves in Setup > Layout Options.
RELATED LINKS
Clefs on page 725
Octave lines on page 732
Percussion kit presentation types on page 1281
Hiding/Showing empty staves on page 441

Per-layout options for staves
You can change settings that affect the staves in each layout independently.
You can change the size of staves in each layout in the Space Size section of the Page Setup
page in Setup > Layout Options.
You can change other aspects of staves on the Staves and Systems page in Layout Options. For
example, you can change which staff labels are shown on systems, indent the first system of
each flow, and fix the number of bars included in each system. You can also select above which
staves system objects appear, according to their instrument families.
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NOTE
●

If the size of system object font styles is set to Staff-relative, the staff size of the top staff in
each instrument family group affects the size of system objects if they are shown above that
bracketed group. Font styles that are set to Absolute are unaffected by staff size.

●

System objects are only shown above bracketed groups in your project. If you have no
brackets, system objects only appear at the top of systems.

You can show system dividers between systems when systems contain a minimum number of
players. You can also change the appearance of system dividers.
RELATED LINKS
Page formatting on page 435
Staff size on page 452
Changing the default staff size on page 438
System objects on page 1172
Changing the positions of system objects on page 1173
Hiding/Showing empty staves on page 441
Edit Font Styles dialog on page 407
Brackets and braces on page 683

Changing the thickness of staff lines
You can change the thickness of staff lines project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Staves in the page list.

3.

In the Staff Lines section, change the value for Staff line thickness.

4.

Click Apply, then Close.

RESULT
The thickness of staff lines project-wide is changed. Increasing the value for Staff line thickness
makes staff lines thicker, decreasing the value makes staff lines thinner.

Deleting staves
You can delete staves, including extra staves and ossia staves, so they no longer appear in any
layout in which the instrument appears. However, this does not automatically delete any
remaining notes on those staves, which will still play back even if the staff does not appear.
PROCEDURE
1.

In Write mode, select any of the following:
●

An item on the staff you want to delete, at the rhythmic position from which you want to
delete it

●

The signpost of the extra staff you want to delete

NOTE
You can only delete one staff at a time.
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2.

Choose Edit > Staff > Remove Staff. You can also choose this option from the context menu.

RESULT
The selected staff is deleted from the selected rhythmic position and a signpost appears
indicating the staff change. The staff is deleted until the next staff change signpost that applies
to that staff or the end of the flow, whichever comes first.
NOTE
●

If you delete an extra staff without deleting the music on it, that music still exists but is not
shown, meaning it is included in playback. If you later recreate an extra staff at the same
position, the music reappears.

●

You cannot delete all staves of an instrument as at least one must always appear. If you do
not want to see any staves for a particular instrument in a layout, you can instead hide
empty staves in that layout.

EXAMPLE

A three-staff piano with the bottom staff deleted in the second bar

RELATED LINKS
Hiding/Showing empty staves on page 441

Extra staves
In Dorico Pro, you can add extra staves to any instrument, for example, to make complex
contrapuntal music easier to read because it is spread out across more staves than usual for that
instrument.

An extract of Debussy's piano prelude "Feuilles mortes" with three staves

1160
Dorico Pro 3.1.10

Staves
Extra staves
When you add extra staves, they exist for the whole flow. However, you can control exactly where
they appear, as often extra staves are only needed for short sections. Extra staves can end
immediately, and so are followed by white space until the end of the system, or can fill the width
of the system, even if they do not contain music for part of the system.
Signposts are automatically added when you add or remove extra staves, indicating the number
of staves added or removed at that position. If multiple staff changes happen at the same
rhythmic position, they are all shown in the same signpost.

An extract of Debussy's piano prelude "Feuilles mortes" with three staff change signposts

You can use these signposts to change the start/end positions of extra staves, for example, if you
want to lengthen or shorten the region where an extra staff is shown. You can also use these
signposts to delete extra staves.
Dorico Pro also allows you to change the number of staves in different ways according to the
intended purpose of the staves, with dedicated features for each type.
●

Extra staves are full-sized staves belonging to a solo player.

●

Ossia staves are small staves belonging to any type of player.

●

Divisi staves are full-sized staves belonging to a section player.

RELATED LINKS
Showing extra staves across whole systems on page 1163
Ossia staves on page 1164

Adding extra staves
You can add extra staves both above and below instruments that belong to solo players, and
show them for both limited sections or for the entire flow. For example, some complex piano
music requires three staves rather than two to display the music clearly.
NOTE
●

If you want to add extra staves to notate a divisi passage or to show an alternative
interpretation, you can use the dedicated divisi and ossia staff features instead.

●

You can add as many staves above/below instruments as you like, but only one at a time. You
must also select an item on one of the original staves of the instrument to add additional
staves, not on any existing extra staves you have added.

●

You can only add extra staves to instruments held by solo players. You cannot add extra
staves to instruments that belong to section players or percussion kits.
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PROCEDURE
1.

In Write mode, select an item on the one of the instrument’s original staves and at the
rhythmic position where you want to add an extra staff.

2.

Add an extra staff in one of the following ways:
●

Choose Edit > Staff > Add Staff Above.

●

Choose Edit > Staff > Add Staff Below.

TIP
You can also choose these options from the context menu.
3.

Optional: Repeat steps 1 and 2 as many times as you like.

RESULT
An extra full-sized staff is added either above or below the selected staff, starting at the earliest
rhythmic position you selected and lasting until the end of the flow. A signpost appears at its
start position, indicating the number of staves that have been added.
TIP
By default, extra staves do not extend to the start/end of systems, meaning they start/stop in the
middle of systems.
If you want extra staves to extend to the start/end of systems automatically regardless of their
rhythmic start/end positions, you can show extra staves across whole systems in each layout
independently.
EXAMPLE

Piano with an extra staff added above the top staff in the second bar

RELATED LINKS
Ossia staves on page 1164
Adding ossia staves on page 1165
Showing extra staves across whole systems on page 1163

Moving the start/end positions of extra staves
You can move the rhythmic start and end positions of extra staves after you have added them.
Because you can move the start/end of extra staves independently, you can also lengthen/
shorten extra staves.
PROCEDURE
1.

In Write mode, select the staff change signposts at the start/end of the extra staves whose
start/end position you want to change.
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NOTE
When using the mouse, you can only move one staff change signpost rhythmically at a time.
2.

3.

Move the selected staff change signposts according to the current rhythmic grid resolution
in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the staff change signpost to the right/left.

Optional: Repeat steps 1 and 2 for the signposts at the other end of the extra staves.

RESULT
The rhythmic start/end positions of the selected extra staves are changed.
NOTE
Only one staff change signpost can exist at each rhythmic position. If a staff change signpost
passes over another staff change signpost as part of its move, the existing staff change signpost
is deleted and replaced by the one being moved. For example, if you move the start signpost of
an extra staff over its end signpost, the extra staff now continues up to the next staff change on
that staff or the end of the flow, whichever comes first.
You can undo this action, but any staff change signposts deleted in the process are only restored
if you moved the staff change signpost using the keyboard.

Showing extra staves across whole systems
By default, extra staves are only shown from where they begin and until where they end. You can
change this setting to that extra staves fill the full width of any system on which they appear
instead, in each layout independently.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to show extra staves across the full
width of systems.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Ossias and Extra Staves section, activate Show extra staves across full system
when starting or stopping.

5.

Click Apply, then Close.

RESULT
Extra staves in the selected layouts always fill the full width of any system on which they appear.
Deactivating the property returns layouts to showing extra staves only for the duration specified
by their signposts.
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EXAMPLE

Extra staff not shown across the full width of the
system

Extra staff shown across the full width of the system

RELATED LINKS
Extra staves on page 1160

Ossia staves
Ossia staves are smaller staves shown above/below the main staff of an instrument. They are
used to show alternative phrases that can be played instead of the original phrase, such as
suggestions for ornaments, alternative notations from other sources, or an easier version.

An ossia staff below the left-hand piano staff shows an easier alternative

In Dorico Pro, you can add ossia staves both above and below instrumental staves for specific
durations only, and their formatting is handled automatically. Vertical spacing is adjusted around
ossia staves automatically.
Signposts are automatically added when you add or remove ossia staves, indicating the number
of staves added or removed at that position. If multiple staff changes happen at the same
rhythmic position, they are all shown in the same signpost.
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An ossia staff with signposts shown

By default, ossia staves are scaled to two thirds the size of a regular staff. Because this is a scale
factor rather than a fixed staff size, ossia staves automatically adjust according to the staff size,
which you can set per layout, per section, and per player.
NOTE
Music on ossia staves is not played back.

RELATED LINKS
Extra staves on page 1160
Changing the size of ossia staves on page 1167
Ossia staff labels on page 1170
Hiding/Showing ossia staves in the preamble on page 1168
Hiding/Showing ossia staves on page 1168
Changing the placement of system objects relative to ossia staves on page 1174

Adding ossia staves
You can add ossia staves for solo and section players, both above and below existing staves. For
grand staff instruments, you can add two-staff ossias.
NOTE
●

You cannot add ossia staves to percussion kit instruments.

●

Although instruments can show ossias both above and below staves, only one ossia can exist
on each side of the staff at a time.

PROCEDURE
1.

In Write mode, select the range above/below which you want to add an ossia staff.
NOTE
If you want to add a two-staff ossia, you must select both instrumental staves.

2.

Add an ossia staff in any of the following ways:
●

Choose Edit > Staff > Create Ossia Above.

●

Choose Edit > Staff > Create Ossia Below.

TIP
You can also choose these options from the context menu.

RESULT
An ossia is added above/below the selected staff that lasts for the selected range. One signpost
appears at the start of the ossia passage, and another appears where the ossia staff ends.
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TIP
You can select these signposts and move them to change the start/end positions of ossia staves.

Moving the start/end positions of ossia staves
You can move the rhythmic start and end positions of ossia staves after you have added them.
Because you can move the start/end of ossia staves independently, you can also lengthen/
shorten ossia staves.
PROCEDURE
1.

In Write mode, select the staff change signposts at the start/end of the ossias whose
start/end position or length you want to change.
NOTE
When using the mouse, you can only move one staff change signpost rhythmically at a time.

2.

3.

Move the selected staff change signposts according to the current rhythmic grid resolution
in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the ossia signpost to the right/left.

Optional: Repeat steps 1 and 2 for the signposts at the other end of the ossia staves.

RESULT
The rhythmic start/end positions of the selected ossia staves are changed.
NOTE
Only one ossia signpost can exist at each rhythmic position. If an ossia signpost passes over
another ossia signpost as part of its move, the existing ossia signpost is deleted and replaced by
the one being moved. For example, if you move the start signpost of an ossia over its end
signpost, the ossia now continues up to the next ossia on the staff or the end of the flow,
whichever comes first.
You can undo this action, but any ossia signposts deleted in the process are only restored if you
moved the ossia signpost using the keyboard.
EXAMPLE

The same ossia staff after moving the start signpost
to the right and end signpost to the left

An ossia staff with signposts shown
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Changing the size of ossia staves
By default, ossia staves are scaled to two thirds the size of a regular staff. You can change the
scale factor of all ossia staves project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Staves in the page list.

3.

In the Ossias section, change the value for Ossia scale factor.

4.

Click Apply, then Close.

RESULT
The scale factor of ossia staves relative to the prevailing staff size is changed in all layouts
project-wide.
RELATED LINKS
Staff size on page 452

Changing the padding on ossias that start/end mid-bar
You can change how far staff lines extend beyond the left/right of ossia staves that begin/end in
the middle of bars. Padding such ossia staves ensures that notes, accidentals, rhythm dots, and
other items are always shown on staff lines.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Staves in the page list.

3.

In the Ossias section, change the values for Extend staff lines at start of ossia and/or
Extend staff lines at end of ossia.

4.

Click Apply, then Close.

RESULT
The padding before and/or after ossia staves that start/end mid-bar is changed project-wide.
EXAMPLE

Ossia staff with padding set to 3 both at the start
and end

Ossia staff with no padding
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Hiding/Showing ossia staves in the preamble
You can include ossia staves in or exclude them from the preamble when they cross system/
frame breaks in each layout independently.
Showing ossia staves in the fixed preamble means their clefs and time signatures appear
alongside all the regular staves at the start of each system. As this can suggest the ossia staff is
an additional instrument, it is common to exclude ossia staves from the fixed preamble.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show ossia staves in the
preamble.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Ossias and Extra Staves section, choose one of the following options for Ossias
crossing a system break:

5.

●

Include in preamble

●

Exclude from preamble

Click Apply, then Close.

RESULT
Preamble notations for ossia staves are hidden in the main preamble in the selected layouts
when you choose Exclude from preamble, and shown when you choose Include in preamble.
EXAMPLE

Ossia included in the preamble

Ossia excluded from the preamble

Hiding/Showing ossia staves
By default, ossia staves appear in all layouts. You can change the layouts in which ossia staves
are shown, for example, if you want ossia staves to appear in the part layout but not in the full
score.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show ossia staves.

1168
Dorico Pro 3.1.10

Staves
Ossia staves
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.
3.

Click Staves and Systems in the page list.

4.

In the Ossias and Extra Staves section, activate/deactivate Show ossias.

5.

Click Apply, then Close.

RESULT
Ossias are shown in the selected layouts when Show ossias is activated, and hidden when it is
deactivated.

Deleting ossia staves
You can remove ossia staves so they are no longer shown in any layout, but without
automatically deleting the music on them.
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The signposts at the start/end of the ossia staves you want to delete

●

An item on each ossia stave you want to delete

Remove the selected ossia staves in one of the following ways:
●

If you selected ossia signposts, press Backspace or Delete , or choose Edit > Delete.

●

If you selected items on ossia staves, choose Edit > Staff > Remove Staff. You can also
choose this option from the context menu.

RESULT
The selected ossia staves are removed and no longer appear in any layouts in which that player
appears.
NOTE
If you delete an ossia staff without deleting the music on it, that music still exists but is not
shown. If you later recreate an ossia at the same position, the music reappears.

RELATED LINKS
Hiding/Showing ossia staves on page 1168

Barlines on ossia staves
There are different conventions for whether ossias are connected to their corresponding staves
with barlines, and if so, which type of barline should be used.
If an ossia both starts and ends at barlines, the following accepted conventions exist amongst
different publishers:
●

Barlines join the ossia to the main staff at both its start and end

●

A barline joins the ossia to the main staff only at its end

●

The ossia does not join to the main staff at all

When an ossia is joined to the main staff, some publishers use the same kind of barline as used
for the other staves, which is typically a single barline, whereas other publishers use a dashed
barline.
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Dorico Pro provides options to accommodate all of these conventions in the Ossias section of the
Barlines page in Engrave > Engraving Options.
NOTE
When an ossia appears between the main staves of an instrument, for example, below the righthand staff of a piano, then the ossia is joined with the same barline as the main staves,
regardless of your chosen settings on the Barlines page in Engraving Options.

RELATED LINKS
Barlines on page 636
Project-wide engraving options for barlines on page 638

Ossia staff labels
Ossias can show staff labels like normal staves, the only difference being that staff labels on ossia
staves are typically drawn within the system to the left of where the ossia starts, even if this is in
the middle of a system, rather than behind the initial barline.
Ossia staff labels use the Ossia Staff Label font style, which you can edit in the Edit Font Styles
dialog.

An ossia staff with the default staff label

Ossia staff labels are positioned according to the distances set in the Ossias section of the
Staves page in Engrave > Engraving Options. There are separate options for labels before
single ossias and braced two-staff ossias.
RELATED LINKS
Edit Font Styles dialog on page 407

Hiding/Showing staff labels on ossia staves
You can hide/show staff labels on ossia staves in each layout independently, and you can show
the default staff label or enter a custom ossia label.
The default staff label on ossia staves is “ossia”.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show staff labels on ossia
staves.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.
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3.

Click Staves and Systems in the page list.

4.

In the Ossias and Extra Staves section, activate/deactivate Show label before ossia.

5.

Optional: If you activated Show label before ossia, choose one of the following staff label
options:
●

Default

●

Custom

6.

Optional: If you chose Custom, enter the staff label you want into the Custom ossia label
field.

7.

Click Apply, then Close.

RESULT
Staff labels are hidden/shown in the selected layouts.
RELATED LINKS
Ossia staff labels on page 1170

System dividers
System dividers are used to clarify the separation of different systems when they appear on the
same page. They are usually shown as two thick, parallel angled lines positioned to the left of
initial barlines.
In Dorico Pro, the outer edges of system dividers are aligned with the corresponding edges of
music frames.

A system divider between two systems in a string quartet score

You can show system dividers in different circumstances and change their appearance in each
layout independently. You can also change their default insets in all layouts project-wide on the
System Dividers page in Engrave > Engraving Options.

Showing system dividers
You can change the circumstances in which system dividers are shown, including specifying the
minimum number of players required to show them, in each layout independently. For example,
if you only want to show system dividers between systems that contain different numbers of
staves.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to show system dividers.
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By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.
3.

Click Staves and Systems in the page list.

4.

In the System Dividers section, choose one of the following options for Show system
dividers:
●

When number of staves differs

●

When minimum number of players present

5.

Optional: If you selected When minimum number of players present, change the value for
Minimum number of players.

6.

Click Apply, then Close.

RESULT
System dividers are shown between systems in all flows in the selected layouts that either
contain the minimum number of players you set or contain different numbers of staves.
RELATED LINKS
Hiding/Showing empty staves on page 441

Changing the length of system dividers
You can change the length of system dividers in each layout independently, for example, if you
want to show longer system dividers in layouts that show full staff labels.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to show system dividers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the System Dividers section, choose one of the following options for Appearance:

5.

●

Default

●

Long

●

Extra long

Click Apply, then Close.

System objects
System objects are items that apply to all staves in the system and appear in all layouts, but are
not necessary to show on every staff in full score layouts. For example, tempo marks and
rehearsal marks are important for all players to see in their parts, but would cause an orchestral
full score to appear very cluttered if they were shown on every staff.
In Dorico Pro, the following items are considered system objects:
●

Rehearsal marks

●

Repeat endings

●

Repeat markers
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●

System text

●

Tempo marks

●

Time signatures shown above the staff

●

Horizontal lines that apply to all staves

System objects automatically appear at least once in all layouts. You can show system objects at
multiple positions in each system by showing them above multiple instrument families. For
example, you might show them above the woodwind, brass, percussion, and string families. In
an orchestral full score, this would ensure system objects are spread out evenly across the page,
meaning no staff is very far from these important markings.
NOTE
●

System objects are only shown above instrument families that are bracketed or braced
together. You can change bracket grouping in each layout independently. You can also
bracket or brace specific staves together using custom bracket/brace grouping.

●

If the size of system object font styles is set to Staff-relative, the staff size of the top staff in
each instrument family group affects the size of system objects if they are shown above that
bracketed group. Font styles that are set to Absolute are unaffected by staff size.

RELATED LINKS
Changing bracket grouping according to ensemble type on page 684
Custom staff grouping on page 689
Edit Font Styles dialog on page 407
Brackets and braces on page 683
Rehearsal marks on page 1051
Tempo marks on page 1203
Repeat endings on page 1070
Large time signatures on page 1240
Inputting text on page 312

Changing the positions of system objects
You can show system objects above different instrument families in each layout independently.
Multiple items are categorized as system objects, including system text, rehearsal marks, tempo
marks, repeat markers, and repeat endings.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the instrument families
above which system objects appear.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the System Objects section, activate the checkboxes for the instrument families above
which you want system objects to appear.

5.

Optional: Activate Additionally show repeat endings below bottom staff.

6.

Click Apply, then Close.

RESULT
System objects appear above the top staff in each bracketed group you select if a bracketed
group for that instrument family is included in the selected layouts. If you activate Additionally
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show repeat endings below bottom staff, repeat endings additionally appear below the
bottom staff.
NOTE
System objects are only shown above instrument families that are bracketed or braced together.
You can change bracket grouping in each layout independently. You can also bracket or brace
specific staves together using custom bracket/brace grouping.

RELATED LINKS
System objects on page 1172

Changing the placement of system objects relative to ossia staves
You can change whether system objects are placed between main staves and their ossia staves
or above ossia staves in each layout independently.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the placement of system
objects relative to ossia staves.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Ossias and Extra Staves section, choose one of the following options for Position of
system objects relative to ossia above staff:

5.

●

Inside ossia

●

Outside ossia

Click Apply, then Close.

System indents
System indents control the distance between the left page margin and the start of systems of
music. According to tradition, the first system in part layouts is indented, but in modern use this
is not always necessary.
According to convention, coda sections at the start of new systems are also indented. Dorico Pro
uses the same gap size before the start of codas whether they occur partway through systems or
at the start of a new system.

A violin part with the first system indented
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In Dorico Pro, system indents automatically adjust to accommodate staff labels. For example, if a
system contains a staff label that is significantly longer than the minimum system indent, Dorico
Pro increases the indent on that system to ensure the staff label remains legible and is not cut off
on the left edge or collides with the music.
You can change both the minimum indent on systems with staff labels and the first system
indent in each layout independently. You can also adjust the system indent at both the start and
end of individual systems, independently of your per-layout settings.
RELATED LINKS
Changing the minimum indent for systems with staff labels on page 1149
Changing the start/end position of systems on page 433
Changing the horizontal justification of final systems on page 449

Changing the first system indent
By default in Dorico Pro, the first system of each flow is indented in part layouts. You can change
the indent for the first system of each in each layout independently.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts whose first system indent you want to change.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Staff Labels section, change the value for Indent first system of flow by.

5.

Click Apply, then Close.

RESULT
The indent of the first system of all flows is changed in the selected layouts.
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Divisi is when players split, or “divide”, in order to play multiple lines of music, commonly for a
limited passage, before returning to play together, or “tutti”. Divisi passages can be notated with
all lines on a single staff or across multiple staves.
Divisi is a technique most commonly used in orchestral string writing, as the string section
typically contains a large number of players compared to the number of staves. For example,
large orchestras commonly have twelve first violins all playing the same part most of the time.
Dividing those players into multiple parts allows composers to write more complex contrapuntal
music.

An example divisi change in a Violin I part, splitting it into two sections and a solo line

If the division is relatively simple, it is possible to write all parts on the same staff and label the
section, with an indication of how many players are required for each line if necessary. If the
parts have different rhythms at times, you can input them into separate voices on the same staff.
However, when a section is divided into multiple parts that are too different to be clearly written
on a single staff, it is necessary to divide them onto multiple staves. In Dorico Pro, you can create
divisi changes for specific regions. This allows you not only to divide sections into any number of
parts with any number of staves, but also to include solo lines and group staves as required. You
can input divisi changes on any staff belonging to a section player.
NOTE
●

You cannot input divisi changes on staves belonging to solo players. If you want to notate
music for a solo player across multiple staves, you can add extra staves instead.

●

The number of staves in a system is defined by the first divisi change in the system. If you
input a divisi change on a system with an existing divisi change, the number of staves is not
changed to reflect the new divisi change until the next system.

If divisi changes occur partway through a system, Dorico Pro automatically extends the extra
staves to the start or end of the system, and duplicates the regions where the section is tutti
automatically using unison ranges.
Divisi changes apply to all layouts.
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TIP
If you want to show the parts for multiple solo players on the same staff, you can use
condensing.

RELATED LINKS
Unison ranges on page 1181
Extra staves on page 1160
Inputting notes into multiple voices on page 179
Condensing on page 470

Change Divisi dialog
The Change Divisi dialog allows you to change how section players are divided and change the
appearance and grouping of staff labels.
●

You can open the Change Divisi dialog by selecting an item on a section player’s staff and
choosing Edit > Staff > Change Divisi.

The Change Divisi dialog contains the following sections and options:

1

Divisions section
Shows the current divisions and groups for the selected section player at the selected
rhythmic position.

2

Groups
Shows any groups of divisions you have created. Grouping sections together gives you more
flexibility in how the staves are labelled.
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3

Divisions
Shows each current individual division. Each division corresponds to a separate staff.

4

Action bar
Contains options that allow you to change the number and arrangement of divisions.
●

Add Solo Division: Adds a solo staff to the section. Dorico Pro automatically adds solo
staves above section staves.

●

Add Section Division: Adds a section division to the section. Dorico Pro automatically
adds new section divisions below existing sections.

●

Add Group: Groups the selected solo or section divisions together.

●

Delete Division or Group: Deletes the selected section divisions or groups.

NOTE
If you delete a divisi without deleting any music on it, that music is no longer shown but
still exists. If you later recreate a division of the same type at the same position, the
music reappears.
5

Staff labels section
Displays the current staff label for the selected division or group and allows you to edit it,
independently of your default staff label paragraph style settings.

6

Editing
For groups only, this option allows you to switch between editing the Full Name and Short
Name of the selected group.
Full Name is used for Full staff labels, Short Name is used for Abbreviated staff labels.

7

Text editor options
Allows you to customize the font, size, and formatting of the staff label of the selected
division or group, independently of the formatting of the corresponding paragraph style.

8

Text editing area
Shows the current staff label for the selected division or group. You can select any part of the
staff label and edit it independently of other parts, for example, if you want the numbers to
use a different font to the instrument name.
Divisi staff labels are right-aligned by default, so appear at the right edge of the text editing
area.

9

Staff label visibility options
Allow you to customize when the different parts of divisi staff labels are shown,
independently of your per-layout settings for hiding/showing staff labels and divisi section
numbers in staff labels.
●

Follow Options: The corresponding part of divisi staff labels follows your per-layout
settings for staff labels.

●

Show: The corresponding part of divisi staff labels is always shown, regardless of your
per-layout settings.

●

Hide: The corresponding part of divisi staff labels is always hidden, regardless of your
per-layout settings.
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RELATED LINKS
Staff label paragraph styles on page 1147
Divisi staff labels on page 1184
Hiding/Showing staff labels on page 1148
Hiding/Showing divisi section numbers in staff labels on page 1185

Inputting divisi changes
You can input divisi changes on any section player staff. Divisi changes can last for any duration
and include any number of staves.
NOTE
●

You cannot input divisi changes on staves belonging to solo players. If you want to notate
music for a solo player across multiple staves, you can add extra staves instead.

●

Divisi changes appear in all applicable layouts automatically.

PROCEDURE
1.

2.
3.

In Write mode, do one of the following:
●

Start note input.

●

Select an item on the staff you want to divide, at the rhythmic position from which you
want the divisi to apply.

Choose Edit > Staff > Change Divisi to open the Change Divisi dialog. You can also choose
this option from the context menu.
In the Change Divisi dialog, create the divisi you want.
For example, if you want to divide the player into two sections, click Add Section Division.

4.

Optional: Edit the staff labels.

5.

Click OK.

RESULT
The selected staff is divided into the number and types of staves specified in the Change Divisi
dialog, either from the caret position during note input or from the selected item outside of note
input. A signpost is shown at the position of the divisi change.
The divisi change applies from the selected item until the next existing divisi change or the end
of the flow, whichever comes first. It appears in all applicable layouts.
If the divisi change occurs partway through a system, any extra staves are automatically shown
across the whole system. A unison range is created automatically to replicate any tutti material
onto all staves added by the divisi change.
NOTE
The number of staves in a system is defined by the first divisi change in the system. If you input a
divisi change on a system with an existing divisi change, the number of staves is not changed to
reflect the new divisi change until the next system.
AFTER COMPLETING THIS TASK
You can input further divisi changes at any position or end the divisi passage.
RELATED LINKS
Change Divisi dialog on page 1177
Divisi staff labels on page 1184
Ending divisi passages on page 1181
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Editing existing divisi changes
You can edit divisi changes after you have input them, for example, if you want to add a solo line
in addition to an existing section division.
PROCEDURE
1.

Double-click the signpost of the existing divisi change you want to edit to open the Change
Divisi dialog. You can do this in Setup, Write, and Engrave modes.

2.

In the Change Divisi dialog, edit the divisi change.

3.

Optional: Edit the staff labels.

4.

Click OK.

RESULT
The selected divisi change is updated.
If you added extra divisions to the divisi change, those staves are added to the region to which
the divisi change applies.
If you removed divisions from the divisi change, those staves are removed from the region to
which the divisi change applies.
NOTE
Removing divisi sections does not automatically delete music previously on the staff. Even
though removed staves no longer appear, any notes left on them still play back. If you later
restore the staff, the notes are also restored.
If you do not want to hear notes on divisi staves you have removed, we recommend deleting all
music from the staves first.

RELATED LINKS
Change Divisi dialog on page 1177
Divisi staff labels on page 1184
Large selections on page 322

Moving divisi changes
You can move divisi changes to new rhythmic positions after you have input them. Because the
start and end of divisi passages have separate signposts that you can move independently, you
can also lengthen/shorten divisi passages.
PROCEDURE
1.

In Write mode, select the divisi change signposts you want to move.
NOTE
When using the mouse, you can only move one divisi change signpost at a time.

2.

3.

Move the divisi changes according to the current rhythmic grid resolution in any of the
following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the divisi change signpost to the right/left.

Optional: Repeat steps 1 and 2 for the signposts at the other end of the divisi passages.
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RESULT
The selected divisi change signposts are moved to new rhythmic positions. Any music on divisi
staves now outside divisi passages is automatically hidden, and any unison ranges before/after
divisi passages are automatically updated according to the new start/end positions of the divisi
passages.
NOTE
Only one divisi change signpost can exist at each rhythmic position. If a divisi change signpost
passes over another divisi change signpost as part of its move, the existing divisi change
signpost is deleted and replaced by the divisi change signpost being moved. For example, if you
move the start signpost of a divisi change over its tutti restoration, the divisi passage now
continues up to the next divisi change on the staff or the end of the flow, whichever comes first.
You can undo this action, but any divisi change signposts deleted in the process are only restored
if you moved the divisi change signpost using the keyboard.

Ending divisi passages
You can end divisi passages and return to a unison section on a single staff at any position,
including partway through systems.
PROCEDURE
1.

In Write mode, select an item on a divisi staff at the rhythmic position where you want the
divisi passage to end.

2.

Choose Edit > Staff > Restore Unison. You can also choose this option from the context
menu.

RESULT
A default divisi change with a single unison section is input at the selected position, which ends
the previous divisi passage. A signpost is shown at the position of the unison restoration.
The unison restoration applies from the selected item until the next existing divisi change or the
end of the flow, whichever comes first. It appears in all applicable layouts.
If the unison restoration occurs partway through a system, all staves from the previous divisi
change automatically continue until the end of the system. A unison range is created
automatically to replicate any unison material onto all staves from the divisi change.
NOTE
The number of staves in a system is defined by the first divisi change in the system. If you input a
divisi change on a system with an existing divisi change, the number of staves is not changed to
reflect the new divisi change until the next system.

Unison ranges
Unison ranges are passages of tutti music that are replicated automatically onto all staves when
divisi passages start/end partway through systems. This ensures there is no ambiguity about
what players are expected to play at any point.
To replicate music, Dorico Pro uses the top staff in the section as a source staff, and replicates all
notes and notations on that staff onto all staves in the section.
You cannot edit notes in unison ranges independently on each staff. When you select a note or
item on a unison range staff, that note or item is selected on all staves in the section. Therefore,
editing notes or items in unison ranges simultaneously edits those notes or items on all staves in
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the section. Similarly, when you input notes onto a staff in a unison range, Dorico Pro also inputs
them on all staves in the section.

A note and slur selected simultaneously on all staves in the unison range, with unison range colors shown

NOTE
Replicating music from the source staff to other staves in the section is complex, and there are
limitations to what Dorico Pro can calculate, particularly notations that start before divisi changes
or end after divisi changes. For example, slurs that start before a divisi change and continue into
the divisi change are not replicated in unison ranges. In such cases, we recommend that you
move the divisi change to before/after the slur and manually copy unison material if required.
If staves in divisions use different clefs to the main staff at the position of the tutti restoration,
Dorico Pro automatically inputs the appropriate clefs.
NOTE
The default spacing of clef changes at the end of divisions can be small, positioning the clef
tightly beside the previous notes. In such cases, we recommend that you adjust note spacing at
that position.

RELATED LINKS
Adjusting note spacing at individual rhythmic positions on page 429

Hiding/Showing unison range colors
You can show unison ranges in a different color so you can identify those passages more easily.
When unison range colors are shown, notes in unison ranges appear gray. Notes on the top staff
remain black, as Dorico Pro notates real notes in tutti sections on the top staff in the section by
default.
PROCEDURE
●

Choose View > Note And Rest Colors > Divisi Unison Ranges.

RESULT
Unison range colors are shown when a tick appears beside Divisi Unison Ranges in the menu,
and hidden when no tick appears.
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EXAMPLE

A tutti passage with unison range colors not shown

The same tutti passage with unison range colors
shown

RELATED LINKS
Unison ranges on page 1181

Divisi on vocal staves
When vocal staves divide to show different lines on separate staves, it is common to show arrows
at the end of the system to emphasize the change, and again at the end of the division to show
the staves are rejoining.

Divide arrows indicating the staff splits into two on
the next system

Divide arrows indicating two staves rejoin into one
on the next system

Arrows at the start and end of divisi passages on vocal staves are known in Dorico Pro as divide
arrows. Dorico Pro shows these arrows on vocal staves by default, but you can also hide them on
all staves project-wide.

Hiding/Showing divide arrows on vocal staves
You can hide/show divide arrows on all vocal staves project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Divisi in the page list.

3.

Choose one of the following options for Indicate divisi at end of system on vocal staves:
●

Show divide arrows

●

Do not show divide arrows
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4.

Click Apply, then Close.

Divisi staff labels
Staff labels on divisi staves often require further detail than normal staff labels. Therefore, Dorico
Pro allows you extra control over the appearance and formatting of staff labels on divisi staves.
By default, staff labels on divisi staves use the same paragraph styles for the formatting of their
text as normal staves, and options for staff labels also apply to divisi staves. However, you can
also edit each individual staff label in divisi changes independently of these settings in the
Change Divisi dialog, including changing the font, style, and alignment. You can also hide and
show player/group names and section numbers on the staves belonging to that specific divisi
change independently of your per-layout settings for hiding/showing staff labels.
Creating custom groups of staves in divisi changes allows you to edit the group staff label
independently of each staff label. You can edit both the full and abbreviated group staff labels.
NOTE
Editing individual divisi staff labels overrides your paragraph style settings. If you later change
the staff label paragraph styles, the edited divisi staff label is not updated.
You can show additional divisi change labels above divisi staves in each layout independently. By
default, divisi change labels display the same information as divisi staff labels, are positioned
above each staff, and are aligned with the position of the divisi change. Such labels can be
particularly useful when divisi changes occur partway through systems and the precise division
of the section would otherwise be ambiguous.
RELATED LINKS
Change Divisi dialog on page 1177
Staff labels on page 1145
Staff label paragraph styles on page 1147
Editing divisi change labels on page 1185

Editing divisi staff labels
You can change the text shown in the staff labels shown at each divisi change individually, for
example, if a single division in your project is significantly different to others and needs further
clarification. When editing divisi staff labels individually, you can also customize the font of each
label in the divisi change.
NOTE
Changes made to staff labels in the Change Divisi dialog apply to all layouts. They also affect the
text shown in any corresponding divisi change labels above staves, even if you had already
changed the text shown in those labels.

PROCEDURE
1.

Open the Change Divisi dialog in any of the following ways:
●

Double-click the signpost of an existing divisi change whose staff labels you want to
change.

●

Input a new divisi change.

2.

In the Divisions section, select the group or section whose staff label you want to edit.

3.

Optional: If you selected a group, choose one of the following staff labels to edit:
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●

Full Name

●

Short Name

4.

In the Staff labels section, edit the selected staff label.

5.

Choose one of the following options for Show player or group name and Show section
numbers:
●

Follow Options

●

Show

●

Hide

NOTE
Show and Hide both override your per-layout settings for staff labels in all layouts.
6.

Optional: Repeat steps 2 to 5 for other sections or groups in the divisi change.

7.

Click OK.

RESULT
The appearance, length, and behavior of the staff labels in the divisi change are changed in all
applicable layouts.
RELATED LINKS
Change Divisi dialog on page 1177
Editing existing divisi changes on page 1180
Hiding/Showing staff labels on page 1148

Editing divisi change labels
You can show custom text in individual divisi change labels shown above staves. This does not
affect the content of staff labels on divisi staves.
PROCEDURE
1.

In Engrave mode, select the divisi change labels you want to edit.

2.

In the Properties panel, activate Custom text in the Divisi group.

3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The text shown in the selected divisi change labels is changed.

Hiding/Showing divisi section numbers in staff labels
You can hide/show divisi section numbers in staff labels before initial barlines in each layout
independently. For example, you can show divisi section numbers in staff labels in part layouts
but hide them in full score layouts.
NOTE
●

These steps only apply to divisi changes whose section numbers are set to Follow Options in
the Change Divisi dialog.

●

These steps do not apply to divisi group or instrument names, which follow either your perlayout settings for showing staff labels or your setting in the Change Divisi dialog.

1185
Dorico Pro 3.1.10

Divisi
Divisi staff labels

PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show divisi section numbers.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Staff Labels section, activate/deactivate the following options:

5.

●

Show section names on first system

●

Show section names on subsequent systems

Click Apply, then Close.

RESULT
Divisi section numbers are shown before the initial barline in the first system of each divisi
passage when Show section names on first system is activated, and hidden when it is
deactivated.
Divisi section numbers are shown before the initial barlines on all subsequent systems in divisi
passages when Show section names on subsequent systems is activated, and hidden when it
is deactivated.
EXAMPLE

Divisi section numbers and staff labels both shown

RELATED LINKS
Divisi staff labels on page 1184
Change Divisi dialog on page 1177
Hiding/Showing staff labels on page 1148
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Divisi
Divisi in playback

Hiding/Showing divisi change labels above staves
You can hide/show section numbers above staves in divisi sections in each layout independently,
for example, to clarify which staves correspond to sections in the divisi when divisi changes occur
partway through systems, or to show a change in weighting between staves.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show divisi change labels
above staves.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Staves and Systems in the page list.

4.

In the Staff Labels section, activate/deactivate Show divisi change labels above staves.

5.

Click Apply, then Close.

RESULT
Section numbers are shown above staves in the division when Show divisi change labels above
staves is activated, and hidden when it is deactivated.
NOTE
This does not affect whether divisi section numbers are shown in staff labels before the initial
barline on each system.
EXAMPLE

Divisi section names shown above each staff

Divisi section names hidden above each staff

RELATED LINKS
Divisi staff labels on page 1184

Divisi in playback
All notes on divisi staves play back, regardless of the number of staves. By default, because divisi
staves belong to a single section player, all staves are played back through the same channel.
If you want to hear different sounds for different divisi staves in playback, for example, if one
staff is pizzicato and another is arco, you can enable independent voice playback.
RELATED LINKS
Enabling independent voice playback on page 543
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Tablature is an alternative notation to the five-line staff, and is used for fretted instruments. On
tablature, pitches are indicated by fret numbers positioned on lines, each of which represents a
string on the instrument. As tablature is commonly used for guitars, it usually shows six lines.

An extract of guitar music shown on both a notation staff and tablature

In Dorico Pro, you can show music for fretted instruments, such as the guitar or bass, on a
regular notation staff and tablature together or only show one or the other. Notes and notations
are linked between both presentations, meaning any changes you make to one, including
inputting notes, automatically updates the other.
On tablature, ties are automatically notated as round brackets around the second note/chord
and all subsequent notes/chords in tie chains.
Any notes beyond the range of the instrument or impossible to calculate, such as below the nut
on the lowest string or a natural harmonic without a suitable node, are shown on tablature as
pink question marks. If two notes are allocated to the same string at the same rhythmic position,
both notes appear beside each other and are colored green.

Note on tablature that cannot be calculated

The appropriate tablature is automatically shown for instruments according to their strings and
tuning settings. There are default tunings stored for each instrument type in Dorico Pro, which
you can customize in the Edit Strings and Tuning dialog.
RELATED LINKS
Fretted instrument tuning on page 116
Edit Strings and Tuning dialog on page 127
Inputting notes on tablature on page 187
Harmonics on page 916
Guitar bends on page 957
Ties on page 1219
Trills on page 929
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Project-wide engraving options for tablature
You can find options for the project-wide design of tablature notation on the Tablature and
Staves pages in Engrave > Engraving Options.
The options on the Tablature page allow you to change the default direction, position, and
alignment of stems, the position of rhythm dots, and the enclosures for chords on tablature.
Many options are informed by the conventions established by different publishers.
On the Staves page, you can change the scale factor that controls the distance between
tablature string lines.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.

Rhythms on tablature
When notation staves and tablature are both shown, it is customary only to notate rhythms on
the notation staff. However, when only tablature is shown, it is necessary to show rhythms on
tablature.
The following items are shown to indicate rhythms when tablature is shown without notation
staves:
●

Time signatures

●

Stems, stem flags, and beaming

●

Rhythm dots

You can change how these items appear on tablature on the Tablature page in Engrave >
Engraving Options.

Rhythms shown on tablature

NOTE
By default, stems, stem flags, and beaming appear stem-up on tablature in single-voice contexts,
which means they can collide with guitar bends. Therefore, in projects where you want to show
both guitar bends and rhythms on tablature, we recommend that you change the Default stem
direction to Down on the Tablature page in Engrave > Engraving Options.

RELATED LINKS
Inputting notes on tablature on page 187
Changing the placement of rhythm dots on tablature on page 1194

Hiding/Showing notation staves and tablature
You can hide/show notation staves and tablature in different combinations in each layout
independently and for each fretted instrument independently of each other. For example, you
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Tablature
Changing the allocated string for notes on tablature
can show only notation staves in the full score layout but the notation staff and tablature in a
guitar part layout.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to hide/show tablature.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Fretted Instruments section, choose one of the following options for each fretted
instrument in your project:

5.

●

Notation

●

Tab

●

Notation and Tab

●

Tab (no rhythms)

Click Apply, then Close.

RESULT
●

Notation shows only notation staves and hides tablature.

●

Tab shows only tablature with rhythms and hides notation staves.

●

Notation and Tab shows notation staves and tablature with rhythms.

●

Tab (no rhythms) shows only tablature with no rhythms.

EXAMPLE

Notation

Tab

Notation and Tab

Tab (no rhythms)

Changing the allocated string for notes on tablature
You can change the string to which individual notes are allocated on tablature manually, for
example, if you input the notes on the notation staff and want to change their default string
allocation.
NOTE
You cannot allocate notes to a string on which they are impossible, such as if the note is lower
than the open pitch of the string.
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PROCEDURE
1.

On tablature, select the fret numbers of notes whose allocated string you want to change.
You can do this in Write mode and Engrave mode.
NOTE
You must select fret numbers on tablature, you cannot select the notes on notation staves.

2.

Change their allocated string in any of the following ways:
●

To move them up a string, press N .

●

To move them down a string, press M .

●

In the Properties panel, select a string from the String menu in the Notes and Rests
group.

RESULT
The string to which the selected notes are allocated is changed. Using the key commands
changes the string of the selected notes proportionally, whereas selecting a string from the
String menu allocates all selected notes to the selected string.
NOTE
●

If they are now allocated to the same string as another note at that rhythmic position, both
notes appear beside each other and are colored green.

●

Deactivating the property resets the selected notes to their default string.

EXAMPLE

Default string allocation

After changing the strings for some notes to reduce
the distance between frets

RELATED LINKS
Inputting notes on tablature on page 187
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Showing notes as dead notes
You can show individual notes belonging to fretted instruments as dead notes. Dead notes are
notated with cross noteheads on notation staves and with an X on tablature.
PROCEDURE
1.

Select the notes belonging to fretted instruments that you want to show as dead notes. You
can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Dead note in the Notes and Rests group.

RESULT
The selected notes are shown as dead notes.
NOTE
This does not currently affect their sound in playback; this is planned for future versions.
EXAMPLE

Normal notes

Dead notes

RELATED LINKS
Inputting notes on tablature on page 187
Bracketed noteheads on page 906

Hiding/Showing enclosures around notes on tablature
You can hide/show enclosures around all chords on tablature that are a half note or longer, that
is, durations shown with hollow noteheads on notation staves.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Tablature in the page list.

3.

In the Enclosures section, choose one of the following options for Enclosures for notes and
chords longer than a quarter note (crotchet):

4.

●

None

●

Ellipse

●

Rounded rectangle

Click Apply, then Close.
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RESULT
Enclosures are hidden around notes a half note or longer when you choose None, and shown
using the corresponding shape when you choose Ellipse or Rounded rectangle.
EXAMPLE

None

Ellipse

Rounded rectangle

Changing the shape of enclosures on single notes on tablature
Single notes on tablature require different enclosure shapes to chords as their overall
dimensions can be very different, such as double-digit fret numbers often being wider than their
height. You can show either all single notes in circle enclosures or show single-digit fret numbers
in ellipse enclosures.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Tablature in the page list.

3.

In the Enclosures section, choose one of the following options for Enclosure shape for
single notes:

4.

●

Prefer circle

●

Allow ellipse

Click Apply, then Close.

RESULT
Prefer circle shows all single notes, with both single-digit and double-digit fret numbers, in circle
enclosures.
Allow ellipse shows single-digit fret numbers in ellipse enclosures but double-digit fret numbers
in circle enclosures.
EXAMPLE

Allow ellipse

Prefer circle
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Changing the placement of rhythm dots on tablature
By default, rhythm dots shown on tablature appear once per chord and are placed above the top
string line. You can change their placement and show multiple rhythm dots next to notes.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Tablature in the page list.

3.

In the Rhythm Dots section, choose one of the following options for Position of rhythm
dots:

4.

●

Next to notes

●

Outside staff

Click Apply, then Close.

RELATED LINKS
Rhythms on tablature on page 1189

Editing the tablature numbers font style
You can edit the formatting of the font used for numbers on tablature.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2.

Select Tablature Numbers Font from the Font style menu.

3.

Activate the following options, individually or together, to change the corresponding aspect
of the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The formatting of the font used for numbers on tablature is changed project-wide.
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Stems
Stems are vertical lines that extend from noteheads that are a half note or shorter in duration. In
combination with notehead design, they allow the duration of each note to be clearly identified.
For example, quarter notes (crotchets) and eighth notes (quavers) both have solid black
noteheads and stems, but eighth notes also have flags on their stems. 16th notes have two flags,
32nd notes have three flags, and so on. The length of stems is determined by default in Dorico
Pro, so stems automatically adjust their length to accommodate more/fewer flags.

Notes with stems, ranging from a half note (minim) on the left to a 128th note on the right

The stems of notes and chords can point upwards/downwards, depending on the conventions of
music engraving and the context of the music. For example, in choral music on two staves, stems
in the soprano and tenor lines point up, and stems in the alto and bass lines point down.
RELATED LINKS
Stem length on page 1200
Changing the default stem direction of notes on the middle staff line on page 1198
Altered unisons on page 617

Project-wide engraving options for stems
You can find options for the project-wide appearance of stems on the Notes page in Engrave >
Engraving Options.
The options on the Notes page allow you to change the design, collision avoidance, length, and
thickness of stems. You can also set when stems are stem up or stem down, when stems are
shortened in various contexts, and change their default stem direction when on the middle line
of the staff.

Default flag design

Straight flag design

There are musical examples for many options to demonstrate how they affect the appearance of
your music.
NOTE
Stems with tremolo strokes have specific options, which you can find on the Tremolos page in
Engraving Options. For example, you can change the default distance between tremolo strokes
and the tips of stems/different stem flags.

RELATED LINKS
Engraving Options dialog on page 359
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Stem direction
Project-wide engraving options for tremolos on page 1258

Stem direction
In Dorico Pro, the stem direction of notes and chords follows rules that are based on the
conventions of music engraving.
Stem direction is determined automatically, but you can manually change the stem direction of
individual notes, chords, or of an entire voice. The rules that are applied depend on the following:
●

How many voices are active on the staff.

●

Whether notes, chords, or beamed groups of notes are affected.

●

Whether notes in the same chord or notes in the same beamed group are split between
staves.

Single notes in single voices
On a five-line staff with only a single voice active, the default stem direction of a single note is
determined by its staff position.
●

If the note is above the middle line, its stem points downwards.

●

If the note is below the middle line, its stem points upwards.

●

If the note is on the middle line of the staff, its stem direction is determined by the stem
directions of any adjacent notes, beam groups, or chords. If they both have the same stem
direction, the note matches them. If the adjacent notes, beam groups, or chords have
different stem directions, or if there are no adjacent notes, beam groups, or chords, the note
follows the default stem direction.
The default stem direction depends on the instrument type. By default, the stems of notes
on the middle lines of staves point downwards on instrumental staves and upwards on vocal
staves, to avoid lyrics.
TIP
You can change the default stem direction for notes and beam groups on the middle lines of
staves, and equally balanced chords, in the Stems section of the Notes page in Engraving
Options. You can also choose whether they follow your default stem direction or change
according to the musical context.

Notes on the middle line are stem up because the
fourth note is stem up

Notes on the middle line are stem down because the
fourth note is stem down

By default, notes are first input into an up-stem voice, and Dorico Pro treats notes as the only
voice on the staff until you input more voices.

Single notes in multiple voices
When there are multiple voices on a staff and all voices contain notes, the stem direction of notes
is determined by the stem direction of their voice. Notes in up-stem voices have up stems, and
notes in down-stem voices have down stems. This applies even when the stems of notes would
normally point in the other direction, based on their position on the staff.
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NOTE
The order in which notes appear between different up-stem voices and different down-stem
voices depends on their pitch and your settings on the Voices page in Write > Notation
Options. You can also change the voice column index of notes individually.
When there are only notes in one voice for at least a whole bar, Dorico Pro automatically changes
the directions of stems so they point in the default direction for their pitch. For example, if a staff
contains a single up-stem voice and a single down-stem voice but only the down-stem voice
contains notes or rests, then the stems of notes in the down-stem voice may point upwards,
depending on the position of the notes on the staff. However, showing rests or implicit rests in
empty voices forces the stem direction of notes to follow the stem direction of their voice.

Notes in an up-stem voice shown
in blue.

Notes in a down-stem voice shown
in purple. The stems point
upwards despite being in a downstem voice because there are no
other voices.

When notes in up-stem and downstem voices are in the same bar,
the stem direction is automatically
changed.

Chords in single voices
The stem direction for a chord in a single voice is determined by the balance of notes above/
below the middle line of the staff.
●

If the note furthest from the middle line is above the middle line, the stem of the chord
points downwards.

●

If the note furthest from the middle line is below the middle line, the stem of the chord
points upwards.

●

If the chord is equally balanced on either side of the middle line of the staff, the stem
direction is determined by the stem directions of any adjacent notes, beam groups, or
chords. If they both have the same stem direction, the chord matches them. If the adjacent
notes, beam groups, or chords have different stem directions, equally balanced chords
follow the default stem direction.
The default stem direction depends on the instrument type. By default, the stems of notes
on the middle lines of staves point downwards on instrumental staves and upwards on vocal
staves, to avoid lyrics.
TIP
You can change the default stem direction for notes and beam groups on the middle lines of
staves, and equally balanced chords, in the Stems section of the Notes page in Engraving
Options. You can also choose whether they follow your default stem direction or change
according to the musical context.

Beam groups in single voices
The stem direction within beam groups is determined by the balance of notes within the beam
group that are above/below the middle line of the staff.
●

If the majority of notes in the beam group are above the middle line, stems in the beam
group point downwards.
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●

If the majority of notes in the beam group are below the middle line, stems in the beam
group point upwards.

●

If the beam group contains an equal number of notes either side of the middle line of the
staff, the stem direction is determined by the stem directions of any adjacent notes, beam
groups, or chords. If they both have the same stem direction, the beam group matches
them. If the adjacent notes, beam groups, or chords have different stem directions, equally
balanced beam groups follow the default stem direction.
The default stem direction depends on the instrument type. By default, the stems of notes
on the middle lines of staves point downwards on instrumental staves and upwards on vocal
staves, to avoid lyrics.
TIP
You can change the default stem direction for notes and beam groups on the middle lines of
staves, and equally balanced chords, in the Stems section of the Notes page in Engraving
Options. You can also choose whether they follow your default stem direction or change
according to the musical context.

RELATED LINKS
Project-wide engraving options for stems on page 1195
Per-flow notation options for voices on page 1295
Voice column index on page 1297
Implicit rests in multiple-voice contexts on page 1108
Note positions in multiple-voice contexts on page 1294
Changing the default stem direction of voices on page 1199
Removing stem direction changes on page 1200
Notation Options dialog on page 160
Altered unisons on page 617

Changing the default stem direction of notes on the middle staff line
The stems of notes on the middle lines of staves can point upwards/downwards. You can change
their default direction, and choose whether the stem direction is determined by the stem
directions of any adjacent notes, beam groups, or chords, or always uses the default direction.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Notes in the page list.

3.

In the Stems section, choose one of the following options for Stem direction for notes on
the middle line of the staff in the Stem Directions subsection:

4.

5.

●

Determine by context

●

Use default direction

Optional: Choose one of the following options for Default stem direction for notes on the
middle line of the staff:
●

Up

●

Down

Click Apply, then Close.
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Changing the stem direction of notes
You can manually change the stem direction of any note.
PROCEDURE
1.

Select the notes whose stem direction you want to change. You can do this in Write mode
and Engrave mode.

2.

Change the stem direction in one of the following ways:
●

Choose Edit > Stem > Force Stem Up.

●

Choose Edit > Stem > Force Stem Down.

TIP
You can also choose these options from the context menu.

RESULT
The stem direction of the selected notes is changed. The selected notes follow this stem
direction, even if you later change their pitch to one that usually requires a different stem
direction.
NOTE
This does not change the voice to which notes belong.
EXAMPLE

Stems pointing in the same direction but in different
voices

Stems in the same direction and in the same voice

RELATED LINKS
Changing the voice of existing notes on page 341

Changing the default stem direction of voices
You can change the default stem direction of voices after they have been input, including slash
voices.
NOTE
This changes the implicit stem direction of the voice, but may not change the stem direction of all
notes in single-voice contexts. Stem directions are automatically changed in Dorico Pro when
only one voice contains notes.
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PROCEDURE
1.

Select a note or chord in the voice whose stem direction you want to change. You can do this
in Write mode and Engrave mode.

2.

Change the default stem direction of the selected voice in one of the following ways:
●

Choose Edit > Voices > Default Stems Down.

●

Choose Edit > Voices > Default Stems Up.

TIP
You can also choose these options from the context menu.

RELATED LINKS
Stem direction on page 1196

Removing stem direction changes
You can remove changes to the directions of stems and revert stems to their default directions.
PROCEDURE
1.

Select the notes whose stem direction changes you want to remove. You can do this in Write
mode and Engrave mode.

2.

Choose Edit > Stem > Remove Forced Stem. You can also choose this option from the
context menu.

RESULT
All stem direction changes are removed from the selected notes. The stems of the selected notes
revert to their default directions.
NOTE
Alternatively, you can change the stem direction to the opposite direction. However, notes with
forced stems do not change automatically if, for example, you later change their pitch.

RELATED LINKS
Changing the stem direction of notes on page 1199

Stem length
The length of stems is determined by default in Dorico Pro, according to accepted standards for
the appearance of stems of notes at different positions on staves.
You can change the default settings for the length of all stems project-wide and you can
lengthen/shorten individual stems in Engrave mode.
RELATED LINKS
Project-wide engraving options for stems on page 1195
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Lengthening/Shortening stems
You can lengthen/shorten the stems of individual notes, independently of your project-wide
settings.
PROCEDURE
1.

In Engrave mode, select the stems you want to lengthen/shorten.

2.

Lengthen/Shorten the stems in any of the following ways:
●

Press Alt/Opt-Up Arrow to make stems longer.

●

Press Alt/Opt-Down Arrow to make stems shorter.
NOTE
If you want to lengthen/shorten stems by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag the square handles at the end of the stems upwards/downwards.

RESULT
The selected stems are lengthened/shortened, regardless of their stem direction. For example,
selecting a down-stem note and pressing Alt/Opt-Up Arrow lengthens it by moving the end of
the stem downwards, away from the notehead.
TIP
●

Stem adj. in the Notes and Rests group of the Properties panel is activated when you
lengthen/shorten stems.
You can also use this property to lengthen/shorten stems by changing the value in the value
field. However, the Notes and Rests group is only available when the notehead is selected
rather than the stem.
Deactivating the property resets the selected stems to their default length.

●

You can change the default length of all stems project-wide in the Stems section of the
Notes page in Engrave > Engraving Options. There are different options for stems in
different contexts.

Hiding stems
You can hide the stems on notes with any notehead design.
Dorico Pro allows you to hide stems rather than using a stemless notehead design as this allows
you to hide the stem of any notehead design.
PROCEDURE
1.

In Engrave mode, select the notes whose stems you want to hide.

2.

In the Properties panel, activate Hide stem in the Notes and Rests group.

RESULT
The stems and any applicable flags of the selected notes are hidden. The stems remain
completely hidden even if you later change the pitch of the notes.
If the selected notes are part of beamed groups, the beams continue to be shown as normal,
unless you have hidden the stems of all notes in the beamed group, which also hides the beam.
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RELATED LINKS
Lengthening/Shortening stems on page 1201
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Tempo marks indicate how fast music is played, often with a combination of text instructions and
metronome marks. They are also known as “tempo changes”, “tempo indications”, and “tempo
markings”.
A tempo mark can show text instructions, a metronome mark, or a combination of the two.

Tempo mark containing text instruction in French and metronome mark

Text instructions are traditionally expressed in Italian, such as largo or allegretto, but other
languages, such as English, French, and German, have become widely accepted. The text
instruction can express simply how fast the music is played, but can also suggest its character.
For example, grave means slow but also solemn and sad, and vivo means fast but also lively and
sprightly.
Metronome marks show the speed of the music, indicated in beats per minute, or “bpm”.
Metronome marks can show a fixed bpm or indicate a range of possible or acceptable values.
Gradual tempo changes indicate a change in tempo over a defined period of time. They can
appear differently, for example, with/without a continuation line or with the text split into
syllables and spread across their duration.
Tempo marks use a bold font with a large point size, so they are clearly noticeable on the page.
They do not usually use an italic font. You can edit the formatting of the fonts used for tempo
marks, such as by changing their font size to make tempo marks appear larger.
In Dorico Pro, tempo marks are categorized as system objects. Therefore, tempo marks follow
your per-layout settings for the visibility and positioning of system objects, which you can change
on the Staves and Systems page in Setup > Layout Options.
By default, the tempo marks you input set the tempo for playback and MIDI recording, but you
can change the tempo mode if, for example, you want to use a single fixed tempo when
recording MIDI. Gradual tempo changes also affect the playback tempo, and you can change the
final tempo at the end of gradual tempo changes, for example, if you want to reach a specific
bpm at the end. If you do not input any tempo marks into your project, the default playback
tempo is 120 bpm.
RELATED LINKS
Metronome marks on page 1212
Gradual tempo changes on page 1215
Tempo mark components on page 1210
Tempo mark font styles on page 1209
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Time track on page 530
Input methods for tempo marks on page 228
Positions of tempo marks on page 1205
System objects on page 1172
Changing the positions of system objects on page 1173
Changing the tempo mode on page 546

Types of tempo marks
Dorico Pro groups tempo marks into different types according to their function and effect on the
music.
The following tempo changes are available in the Tempo panel in Write mode, but you can also
input all types of tempo changes using the tempo popover.
Absolute Tempo Change
Indicates a defined change in tempo, and is often shown with a metronome mark.
Gradual Tempo Change
Indicates a change in tempo over a defined period of time, such as rallentando (slowing
down) or accelerando (speeding up).
Relative Tempo Change
Indicates a change in tempo that is relative to the previous tempo, such as mosso
(movement).
Relative tempo changes often include modifiers that qualify the change, such as poco
meno mosso (a little less movement), and are not defined by a metronome mark. You
can, however, set a relative metronome mark change as a percentage of the previous
metronome mark.
Reset Tempo
Returns the tempo to the previous tempo, such as A tempo, or a previously defined
tempo, such as Tempo primo (return to the first tempo of the piece).
Tempo Equation
Indicates a change in the beat unit on which metronome marks are based. For
example, if the time signature changes from 3/4 to 6/8, a tempo equation of =
indicates the same metronome mark value that applied to the quarter note beat unit in
3/4 now applies to the dotted quarter note beat unit in 6/8.
RELATED LINKS
Metronome marks on page 1212
Gradual tempo changes on page 1215
Input methods for tempo marks on page 228
Tempo panel on page 230
Tempo popover on page 228
Tempo mark font styles on page 1209

Project-wide engraving options for tempo marks
You can find options for the project-wide appearance of tempo marks on the Tempo page in
Engrave > Engraving Options.
The options on the Tempo page allow you to change the appearance of tempo marks, including
how many decimal places to show for metronome marks, and their position relative to the staff,
time signature changes, and other items. You can also change the appearance, thickness, and
position of continuation lines relative to barlines for gradual tempo changes.
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There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359
Hiding/Showing decimal places for metronome marks on page 1214

Positions of tempo marks
Tempo marks are placed above the staff and at the same positions as other system objects,
because they usually apply to all staves. They are placed above notations such as slurs, ties, and
octave lines, and are often aligned with rehearsal marks to ensure clear readability.
Tempo marks should be aligned with either a time signature or the notehead/rest at the
rhythmic position to which they apply. For example, if there is a notehead with an accidental at
the rhythmic position of a tempo mark, it is convention to align the tempo mark with the
accidental.
If a repeat mark occurs mid-system and is not treated as a barline, tempo marks are aligned with
the repeat mark.
When a tempo mark includes both text and a metronome mark, the text appears first, followed
by the metronome mark. When horizontal space is tight, the metronome mark can be positioned
below the tempo mark text.
You can move tempo marks to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.
You can move tempo marks graphically in Engrave mode, but this does not change the rhythmic
positions to which they are attached.
You can change the default positions and appearance of tempo marks project-wide on the
Tempo page in Engrave > Engraving Options.
Tempo marks are categorized as system objects in Dorico Pro, which you can show above the
first bracket of selected instrument families. You can change the instrument families above which
system objects appear in each layout independently, for example, if you want tempo marks to
appear at multiple vertical positions in each system in the full score only.
RELATED LINKS
Project-wide engraving options for tempo marks on page 1204
System objects on page 1172
Changing the positions of system objects on page 1173

Moving tempo marks rhythmically
You can move tempo marks to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the tempo marks you want to move.
NOTE
When using the mouse, you can only move one tempo mark at a time.

2.

Move the tempo marks according to the current rhythmic grid resolution in any of the
following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.
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●

Press Alt/Opt-Left Arrow to move them to the left.

●

Click and drag the tempo mark to the right/left.

RESULT
The selected tempo marks are moved to new rhythmic positions.
NOTE
Only one tempo mark can exist at each rhythmic position. If a tempo mark in your selection
passes over another tempo mark as part of its move, the existing tempo mark is deleted.
You can undo this action, but any tempo marks deleted in the process are only restored if you
moved the tempo mark using the keyboard.

RELATED LINKS
Lengthening/Shortening gradual tempo changes on page 1215

Moving tempo marks graphically
You can move tempo marks graphically without changing the rhythmic positions to which they
apply. You can move the start/end of gradual tempo changes independently, meaning you can
also lengthen/shorten individual gradual tempo changes graphically.
NOTE
You cannot change the angle of gradual tempo changes.

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Tempo marks

●

Individual start/end handles of gradual tempo changes

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the tempo marks or handles in any of the following ways:
●

To move tempo marks or handles to the right, press Alt/Opt-Right Arrow .

●

To move tempo marks or handles to the left, press Alt/Opt-Left Arrow .

●

To move tempo marks or whole gradual tempo changes upwards, press Alt/OptUp Arrow .

●

To move tempo marks or whole gradual tempo changes downwards, press Alt/OptDown Arrow .
NOTE
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.
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RESULT
The selected tempo marks, gradual tempo changes, or handles are moved to new graphical
positions.
TIP
The following properties in the Tempo group of the Properties panel are activated automatically
when you move tempo marks in the corresponding directions:
●

Start offset moves tempo marks and the start of gradual tempo changes. X moves them
horizontally, Y moves them vertically.

●

End X moves the end of gradual tempo changes horizontally.

For example, if you move a whole gradual tempo change, both handles are moved so both
properties are activated. You can also use these properties to move tempo marks and lengthen/
shorten gradual tempo changes graphically by changing the values in the value fields. However,
you cannot move absolute tempo marks and gradual tempo changes graphically at the same
time when using these properties.
Deactivating the properties resets the selected tempo marks and gradual tempo changes to their
default positions.

Changing the end position of gradual tempo changes relative to
barlines
You can change how the ends of individual gradual tempo change continuations are positioned
relative to barlines, independently of your project-wide setting.
NOTE
This does not affect the appearance of gradual tempo changes with the text-only style.

PROCEDURE
1.

In Engrave mode, select the gradual tempo changes whose end position relative to barlines
you want to change.

2.

In the Properties panel, activate Barline interaction in the Tempo group.

3.

Choose one of the following options:
●

Stop before

●

Continue

RESULT
The end position of the selected gradual tempo changes is changed.
NOTE
You can change the default position of all gradual tempo change ends project-wide in the
Horizontal Position section of the Tempo page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for tempo marks on page 1204
Changing the style of gradual tempo changes on page 1216
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Changing tempo text
You can change the text of existing tempo marks individually.
PROCEDURE
1.

Select the tempo marks whose tempo text you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, enter the tempo text you want into the Text field in the Tempo
group.

3.

Press Return .

RESULT
The tempo text for the selected tempo marks is changed.
TIP
You can also change the tempo text by opening the tempo popover and changing the entry.

RELATED LINKS
Tempo popover on page 228
Changing existing items on page 329
Tempo mark components on page 1210

Showing abbreviated tempo text
You can show individual tempo marks with custom abbreviated text in some layouts, for
example, if a long tempo mark extends beyond the page boundary in some part layouts but the
abbreviated version fits within the boundary.
PROCEDURE
1.

In the music area, open the layout in which you want to show abbreviated tempo text. You
can do this in Write mode and Engrave mode.

2.

Select the tempo marks you want to show with abbreviated text.

3.

In the Properties panel, activate Abbreviation in the Tempo group.

4.

Enter the text you want into the value field.

5.

Activate Abbreviate in the Tempo group.

6.

Activate the corresponding checkbox.

RESULT
The selected tempo marks appear with abbreviated text. This does not affect the appearance of
the same tempo mark in layouts that show full tempo text as properties in Dorico Pro are layoutspecific.
Abbreviated tempo text is shown when Abbreviation is activated and Abbreviate is deactivated,
or when Abbreviation and both Abbreviate and its corresponding checkbox are all activated.
This allows you to switch between showing abbreviated/full text in different layouts without
deleting your abbreviated text from the Abbreviation value field.
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Tempo mark font styles
There are different font styles for different types of tempo marks and tempo mark components.
You can change different aspects of these fonts in the Edit Font Styles dialog, such as changing
their font size to make tempo marks appear larger.
The following fonts are used for tempo marks:
●

Gradual Tempo Text Font: Used for gradual tempo changes, such as rallentando.

●

Immediate Tempo Text Font: Used for absolute tempo changes, such as “Adagio”.

●

Metronome Music Text Font: Used for the note value glyphs in metronome marks, such as
.

●

Metronome Text Font: Used for the equation and numbers in metronome marks, such as
“=76”.

NOTE
Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Edit Font Styles dialog on page 407

Hiding/Showing tempo marks
You can hide/show the different components in individual tempo marks without changing the
speed of playback. This affects their appearance in all layouts.
PROCEDURE
1.

Select the tempo marks you want to hide, or the signposts of tempo marks you want to
show. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate the following properties in the Tempo group:
●

Text shown

●

Metronome mark shown

RESULT
When at least one of the properties is activated, the selected tempo marks are shown. They
display components according to the properties that are activated.
When neither property is activated, the selected tempo marks are hidden. Signposts are shown
at the position of each hidden tempo mark as they still affect the speed of playback.
RELATED LINKS
Changing the type and appearance of absolute tempo changes on page 1211
Signposts on page 335

Deleting tempo marks
You can delete tempo marks, which resets the tempo for playback to the previous tempo mark or
the default tempo if there is no previous tempo mark.
PROCEDURE
1.

In Write mode, select the tempo marks or the signposts of tempo marks you want to delete.
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2.

Press Backspace or Delete .

RESULT
The selected tempo marks are deleted and no longer appear in the music area or in the Time
track in Play mode. The tempo in playback follows the previous tempo mark, or the default
tempo of 120 bpm if there is no previous tempo mark.
If you delete a tempo mark that truncated the line of a gradual tempo change, the line of the
gradual tempo change automatically extends to its full length or until the next existing tempo
mark.

Tempo mark components
Tempo mark components include text, metronome marks, parentheses, and approximate
indications. Tempo marks can include different components in different combinations,
depending on your preference or the requirements for different projects.
You can change which components are shown in different types of tempo marks project-wide,
and you can change which components are shown in individual tempo marks.
You can activate properties that correspond to the different components in the Tempo group of
the Properties panel. You can activate one or more of the following tempo mark properties in any
combination for individual absolute tempo changes:
Text shown
Shows text when activated, and no text when deactivated.
Metronome mark shown
Shows metronome marks when activated, and no metronome marks when
deactivated.
Parenthesized
Shows metronome marks in parentheses when activated, and without parentheses
when deactivated. This also applies to approximate metronome marks.
Is approximate
Shows metronome marks as approximate when activated, and absolute when
deactivated.
Approximate appearance
Allows you to choose how approximate metronome marks appear, for example, c. or
circa.
NOTE
This property applies specifically to approximate tempo marks, and is only available
when Is approximate is activated.
Show equals sign
An equals sign is shown when the property and its corresponding checkbox are both
activated. No equals sign is shown when the checkbox is deactivated.
NOTE
This property applies specifically to approximate tempo marks, and is only available
when Is approximate is activated.
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Components for gradual tempo changes
The following components only apply to gradual tempo changes, such as rallentando:
Poco a poco
Poco a poco text is shown immediately after gradual tempo change text when the
checkbox beside the property is activated.
RELATED LINKS
Project-wide engraving options for tempo marks on page 1204

Changing the type and appearance of absolute tempo changes
You can change which components are included in individual absolute tempo changes, and how
they appear.
PROCEDURE
1.

Select the absolute tempo marks whose components you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate any of the following properties in the Tempo group:
●

Text shown

●

Metronome mark shown

●

Parenthesized

●

Is approximate

●

Approximate appearance (only available if Is approximate is activated)

●

Show equals sign (only available if Is approximate is activated)

RESULT
The selected tempo marks are changed to include the corresponding components.
NOTE
If you have activated none of these properties, no tempo mark is shown in the music. Instead, a
signpost indicates the position of the tempo mark.

Adding poco a poco text to gradual tempo changes
You can add poco a poco text immediately after individual gradual tempo changes.
NOTE
You can also enter poco a poco directly into the tempo popover. However, this means the entry
is treated as a tempo mark rather than a gradual tempo change, which changes the properties
you can use on it.

PROCEDURE
1.

Select the gradual tempo changes to which you want to add poco a poco text. You can do this
in Write mode and Engrave mode.

2.

In the Properties panel, activate Poco a poco in the Tempo group.

RESULT
Poco a poco text is shown immediately after the text in the selected gradual tempo changes.
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Deactivating Poco a poco (little by little) removes poco a poco text from the selected gradual
tempo changes.
EXAMPLE

Rallentando with poco a poco text

Metronome marks
Tempo marks often include a metronome mark value. Metronome marks show the speed of the
music, indicated in beats per minute, or “bpm”. For example, a bpm of 60 means one beat per
second. The more beats per minute, the faster the music.

A metronome mark shown as a range

Metronome marks can be precise, such as  = 176, or can indicate an acceptable range, such as 
= 152-176. They can also be shown in parentheses, which is useful if the metronome mark is
intended as a guide rather than a fixed value.
By default, metronome marks appear as integers and do not show decimal places. If you input a
metronome mark with a decimal place, it is rounded to the nearest integer. Metronome marks
that you input in the Time track in Play mode appear as signposts by default.
The beat unit used in metronome marks commonly relates to the meter, for example, the
metronome mark beat unit is often a quarter note in 4/4 but a dotted quarter note in 6/8.
In Dorico Pro, metronome marks can appear as an individual value or as a range. Depending on
the type and appearance of metronome marks, the bpm value can indicate a fixed tempo or an
approximate tempo.
RELATED LINKS
Input methods for tempo marks on page 228
Time track on page 530
Hiding/Showing decimal places for metronome marks on page 1214
Changing the type and appearance of absolute tempo changes on page 1211

Changing the metronome mark value
You can change the metronome mark value of individual absolute tempo marks after they have
been input, including changing the beat unit.
NOTE
These steps do not apply to gradual tempo changes or reset/relative tempo marks.

PROCEDURE
1.

Select the absolute tempo marks whose metronome mark values you want to change. You
can do this in Write mode and Engrave mode.
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2.

In the Properties panel, change the value for Tempo (bpm) in the Tempo group.

3.

Press Return .

4.

Choose the appropriate note duration and rhythm dot, if applicable, for Beat unit.

RESULT
The metronome mark value and beat unit is changed for the selected absolute tempo marks.
This affects the tempo of playback, even if no metronome mark component is shown for those
tempo marks.
NOTE
●

By default, any decimals you enter are hidden and the displayed metronome mark value
appears as the nearest integer. However, metronome marks always reflect their exact values
in playback.

●

You can also change the metronome mark value by opening the tempo popover and
changing the entry.

RELATED LINKS
Tempo popover on page 228
Changing existing items on page 329

Showing the metronome mark value as a range
You can show the metronome mark value of individual absolute tempo marks as a range. For
example, you can use this to indicate that any speed within the given range is musically
appropriate for the piece.
NOTE
These steps do not apply to gradual tempo changes or reset/relative tempo marks.

PROCEDURE
1.

Select the absolute tempo marks whose metronome mark values you want to show as a
range. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Tempo range (bpm) in the Tempo group.

3.

Change the value in the value field.

RESULT
The tempo range, expressed as beats per minute, is changed for the selected tempo marks. By
default, metronome mark ranges use a dash separator.
NOTE
●

Depending on the values set for each property, both Tempo (bpm) and Tempo range (bpm)
can be the minimum/maximum tempo in the range, as Dorico Pro automatically arranges
metronome mark ranges with the lower value first. However, the metronome mark used for
playback is always Tempo (bpm), regardless of whether that is the higher/lower value in the
range.

●

You can change the default separator used for metronome mark ranges in the Absolute
Changes section of the Tempo page in Engrave > Engraving Options.
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Changing the relative tempo mark value
You can change the tempo of individual relative tempo marks, expressed as a percentage of the
previous tempo mark.
PROCEDURE
1.

Select the relative tempo marks whose value you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, change the value for Relative % in the Tempo group.

3.

Press Return .

RESULT
The tempo at the relative tempo mark is changed. For example, if the previous tempo was
100 bpm, and you change a relative tempo mark to 90, the new tempo is 90% of 100 bpm, which
is 90 bpm.

Changing the final tempo at the end of gradual tempo changes
You can change how significantly gradual tempo changes affect the tempo in playback,
expressed as a percentage of the tempo at the start of the gradual tempo change.
PROCEDURE
1.

Select the gradual tempo changes whose final tempo you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, change the value for Final tempo % in the Tempo group.

3.

Press Return .

RESULT
The final tempo at the end of the selected gradual tempo changes is changed.
For example, if you change the value to 20 on a gradual tempo change that started at 100 bpm,
the final tempo is 20% of 100 bpm, which is 20 bpm. If you change the value to 120 on a gradual
tempo change that started at 100 bpm, the final tempo is 120% of 100 bpm, which is 120 bpm.

Hiding/Showing decimal places for metronome marks
You can change the maximum number of decimal places you want to show for all metronome
marks project-wide, for example, if you require very precise metronome mark values when
writing music to film but only want to show one decimal place for metronome marks in the
music.
By default, decimal places are hidden for metronome marks and are rounded to the nearest
integer. However, metronome marks always reflect their exact values in playback.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Tempo in the page list.

3.

In the Absolute Changes section, change the value for Number of decimal places to show
tempo.

4.

Click Apply, then Close.
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Gradual tempo changes
Gradual tempo changes indicate a change in tempo over a defined period of time, such as
rallentando, which indicates slowing down, and accelerando, which indicates speeding up.

Rallentando with dashed line

Gradual tempo changes are considered a type of tempo mark in Dorico Pro, meaning you can
input them in the same ways as for tempo marks.
Because gradual tempo changes have a different metronome mark value at the start/end, you
can change the final tempo at the end of individual gradual tempo changes.
In Dorico Pro, you can show gradual tempo changes with different styles, such as with a
continuation line or with syllables spread across their duration. You can also show gradual tempo
changes with different line styles, such as dotted or dashed.
RELATED LINKS
Input methods for tempo marks on page 228
Changing the line style of gradual tempo changes on page 1216
Project-wide engraving options for tempo marks on page 1204
Changing the final tempo at the end of gradual tempo changes on page 1214

Lengthening/Shortening gradual tempo changes
You can lengthen/shorten gradual tempo changes rhythmically after they have been input.
PROCEDURE
1.

In Write mode, select the gradual tempo changes you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one gradual tempo change at a time.

2.

Lengthen/Shorten the gradual tempo changes in any of the following ways:
●

To lengthen them by the current rhythmic grid resolution, press Shift-Alt/OptRight Arrow .

●

To shorten them by the current rhythmic grid resolution, press Shift-Alt/OptLeft Arrow .
NOTE
Key commands lengthen/shorten items by moving their end only.

●

Click and drag the circular handle at the start/end to the right/left.

RESULT
The selected gradual tempo changes are lengthened/shortened according to the current
rhythmic grid resolution.
TIP
You can adjust the graphical positions of gradual tempo changes in Engrave mode.
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RELATED LINKS
Moving tempo marks graphically on page 1206

Changing the style of gradual tempo changes
You can change the style of individual gradual tempo changes, independently of your projectwide setting. Gradual tempo changes can appear as text only with no continuation line, text with
a continuation line, or with the word spread across their duration.
PROCEDURE
1.

Select the gradual tempo changes whose style you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Gradual style in the Tempo group.

3.

Select one of the following options from the menu:
●

rit.

●

rit...

●

rit-e-nu-to

RESULT
The style of the selected gradual tempo changes is changed.
NOTE
●

Only gradual tempo changes with valid full text appear separated into syllables, for example,
ritenuto or accelerando. Gradual tempo changes automatically have valid full text when you
input them using the panel or select a suggested entry from the menu when using the
popover. You can also change the text of existing gradual tempo changes.

●

You can change the style of all gradual tempo changes project-wide on the Tempo page in
Engrave > Engraving Options.

EXAMPLE

rit.: Text only

rit...: Text with a continuation line

rit-e-nu-to: Syllables in the text
spread across the duration of the
gradual tempo change

RELATED LINKS
Project-wide engraving options for tempo marks on page 1204
Input methods for tempo marks on page 228
Changing tempo text on page 1208

Changing the line style of gradual tempo changes
You can change the line style of individual gradual tempo changes whose style includes a
continuation line, independently of your project-wide settings.
NOTE
This does not affect the appearance of gradual tempo changes with the text-only style.
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PROCEDURE
1.

Select the gradual tempo changes whose line style you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Line style in the Tempo group.

3.

Select one of the following options from the menu:
●

Solid

●

Dotted

●

Dashed

RESULT
The line style of the selected gradual tempo changes is changed.
TIP
You can change the default line style of all gradual tempo changes project-wide on the Tempo
page in Engrave > Engraving Options.

Lengthening/Shortening gaps and dashes in gradual tempo changes
You can change the length of dashes and the gaps between dashes in individual gradual tempo
changes, independently of your project-wide settings.
NOTE
These steps only apply to gradual tempo changes with dashed lines.

PROCEDURE
1.

In Engrave mode, select the gradual tempo changes with dashed lines whose dash length
you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Tempo group:

3.

●

Line dash length

●

Line dash gap

Change the values in the value fields.

RESULT
Increasing Line dash length makes dashes in gradual tempo changes longer, decreasing the
value makes dashes shorter.
Increasing Line dash gap makes gaps between dashes in gradual tempo change lines longer,
decreasing the value makes gaps shorter.
TIP
You can find options that change the default dash length for all dashed gradual tempo changes
project-wide by clicking Advanced Options in the Gradual Changes section of the Tempo page
in Engrave > Engraving Options.
For example, you can change the default dash length for dashed lines following text and dashed
lines between hyphenated text separately.
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Changing the line thickness of gradual tempo changes
You can change the thickness of dashed and solid lines in gradual tempo changes individually,
independently of your project-wide settings.
PROCEDURE
1.

In Engrave mode, select the gradual tempo changes whose thickness you want to change.

2.

In the Properties panel, activate Line thickness in the Tempo group.

3.

Change the value in the value field.

RESULT
Increasing the value makes dashed and solid lines thicker, decreasing the value makes dashed
and solid lines thinner.
TIP
You can change the thickness of all dashed and solid gradual tempo change lines project-wide on
the Tempo page in Engrave > Engraving Options.

Tempo equations
Tempo equations indicate a change in the beat unit on which metronome marks are based. They
are often used to maintain a consistent pulse across multiple different meters.
For example, if the time signature changes from 6/8 to 3/4, a tempo equation of  = indicates the
same metronome mark value that applied to the dotted quarter note beat unit in 6/8 now applies
to the quarter note beat unit in 3/4.

RELATED LINKS
Input methods for tempo marks on page 228
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A tie is a curved line that joins two notes of the same pitch. When notes are longer than the
maximum duration of a bar in the prevailing time signature, they automatically appear in Dorico
Pro as tie chains, that is, a sequence of adjacent notes joined with ties.
Each sequence of ties, whether they join two notes or ten notes together, represents a single
note with the duration of all the tied notes combined. A performer plays the notes as one note,
without re-striking, re-blowing, or re-bowing the note at any point within the rhythmic duration
of the tie chain.

A tie chain across several bars on the bottom piano staff

On tablature, ties are automatically notated as round brackets around notes/chords in
subsequent bars. When tablature is shown with rhythms, ties within the same bar are indicated
with stems rather than bracketed noteheads.

A phrase on tablature with some ties within bars and The same phrase on a notation staff
a chord tied across two bars

In Dorico Pro, most ties are created automatically. Rhythms are notated according to the
prevailing beat grouping, which is normally set by the time signature. Therefore, notes that
cannot be notated using a single duration are automatically drawn as tie chains. For example, if
you input a dotted whole note at the start of a bar in a 4/4 time signature, it is automatically
notated as a whole note tied to a half note in the next bar. If the time signature changes, tie
chains are automatically adjusted to remain correct in the new meter.
NOTE
●

In Write mode, you can only select whole tie chains because Dorico Pro considers each tie
chain to be a single note. Any edits you make to tie chains in Write mode affect all notes in
them, such as changing the pitch, but only affect the first tie in the chain, such as changing
the tie style to dashed. However, you can still input notations, such as dynamics, in the
middle of tie chains by activating the caret and moving it to the required rhythmic position
within the tie chain.
In Engrave mode, you can select individual notes and ties within tie chains and edit them
independently.
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●

When you tie existing notes together, they might be consolidated into fewer or more notes
within a tie chain, depending on the musical context, the time signature, and the position of
the start of the note in the bar.

●

Articulations can only appear once on each tie chain, either at the start or the end,
depending on the type of articulation. For example, staccato marks appear at the end
whereas accents appear at the start. You can change the positions of articulations relative to
tie chains project-wide and for individual tie chains.

RELATED LINKS
Note and rest grouping on page 681
Beam grouping according to meters on page 665
Inputting notes on page 172
Forcing the duration of notes/rests on page 177
Inputting ties on page 192
Splitting tie chains on page 1226
Time signatures on page 1235
Input methods for time signatures on page 222
Notes on page 886
Positions of articulations on page 625
Changing the positions of articulations on tie chains on page 626
Bracketed noteheads on page 906
Tablature on page 1188
Caret on page 167
Moving the caret manually on page 171

General placement conventions for ties
Ties join two noteheads together, meaning the ends of ties are positioned close to the noteheads
to which they are attached.
Ties are curved lines, and the direction of the curve usually follows the stem direction of the
notes. If notes are stem-up, ties curve downwards, and if notes are stem-down, ties curve
upwards.
NOTE
If there are multiple voices on the staff, all ties in up-stem voices curve upwards and all ties in
down-stem voices curve downwards.
There are two main conventions for the placement of the ends of ties relative to noteheads. One
convention is to place the ends of ties outside noteheads, meaning above or below them, ideally
positioned at the horizontal center of noteheads. The other convention is to place the ends of
ties between noteheads, ideally positioned at the vertical center of noteheads.

A tie outside noteheads

A tie between noteheads

For both conventions, Dorico Pro automatically positions the ends of ties as close as possible to
the notes that they join while avoiding collisions with other notations.
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The vertical placement of ties is also automatically adjusted in Dorico Pro so that neither of the
end points of ties, nor the apex of tie curves, starts or ends on a staff line. If this happens, it can
cause the shape of ties to appear distorted, which makes the music harder to read.
To avoid this, Dorico Pro changes the vertical position of ties slightly, and makes small changes to
the curvature of ties. These changes are small, but the placement of ties is subtly different
depending on the position of notes relative to staff lines.

A tie outside noteheads

When transposed one note down, the tie appears
with a steeper curve to avoid reaching its apex on
the staff line.

A tie between noteheads, with the ends slightly
above the vertical center of the noteheads to avoid
the tie appearing too close to the staff line at its
ends or apex.

When transposed up, the ends of the tie are now
positioned at the vertical center of the notehead, as
there is no staff line with which it could collide.

Wherever possible, clef changes should not be positioned in the middle of tie chains. Changing
the clef changes the position of the tied note on the staff, which could easily cause a performer
to misread the tie as a slur and play two different notes.
Ties can look distorted when they are very short, and can be overlooked. You can change the
minimum length of ties when they are within a single system on the Ties page in Engrave >
Engraving Options.
NOTE
Slurs must not be confused with ties, which look superficially similar, but instead join notes of the
same pitch to indicate that they are played as a single note. In that sense, ties are part of
rhythmic notation, while slurs are considered articulation.

RELATED LINKS
Ties vs. slurs on page 1222
Inputting ties on page 192
Project-wide engraving options for ties on page 1221
General placement conventions for clefs on page 726

Project-wide engraving options for ties
You can find options for the project-wide appearance, position, and placement of ties on the Ties
page in Engrave > Engraving Options.
The options on the Ties page allow you to change the default curvature direction, shape, and
appearance of ties, and the position of ties relative to noteheads and other ties in tie chains.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
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RELATED LINKS
Engraving Options dialog on page 359

Ties vs. slurs
Ties and slurs look superficially similar but differ in meaning.
Ties indicate that a note should not be re-struck. They are used to join notes of the same pitch
together. For example, ties can be used to extend notes across multiple bars. Although multiple
notes can be included in a single tie chain, each tie in the chain only joins one notehead to the
next notehead on the staff.
Ties can be used in conjunction with articulation, but articulation on tied notes only affects the
attack at the start of the tie chain and the release at the end of the tie chain.

Two long notes tied together

Slurs indicate articulation, such as bowing or breathing, and normally group notes of different
pitches together. Slurs can join two noteheads together with any number of pitches in between.
They often indicate the shaping of phrases.
Slurs can also be used in conjunction with articulation. Unlike ties, articulation within slurs can
affect the sound throughout the phrase. For example, staccato articulations on repeated notes of
the same pitch within a slur indicate that notes should be played on a stringed instrument using
the same bow direction, but stopping the bow between each note.

A phrase with notes grouped together by slurs

Non-standard ties
Usually, ties join two notes of the same pitch in the same staff. However, ties can also cross
system breaks and frame breaks, clef changes, or time signature changes. These types of ties are
all positioned automatically in Dorico Pro.
Ties can also join non-adjacent notes, notes in different voices, or notes in different staves
together. In Dorico Pro, you must input these types of ties manually.

Ties across system breaks and page breaks
The ends of ties that cross system breaks are automatically positioned in Dorico Pro.
Their vertical position remains the same, as both ends are centered on the noteheads to which
they are attached. Their behavior also remains the same, as selecting one note in a tie chain that
crosses a system or frame break in Write mode selects all notes in the tie chain.
The horizontal space for the parts of ties shown to the left of notes at the start of new systems/
frames may not be sufficient to show an ideal tie curve. In such cases, you can use Note Spacing
in Engrave mode to adjust the spacing of individual notes at the start of systems/frames to give
ties more space.
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The start of a tie chain before a system break

The end of the same tie chain after a system break

Tied notes with accidentals across system breaks and page breaks
The ends of ties for tied notes with accidentals across system breaks and page breaks are also
automatically positioned.
As tied notes in Dorico Pro are treated as one note notated to fit in time signatures, cautionary
accidentals at the start of new systems/frames are not shown by default. If you choose to show
accidentals beside notes in tie chains at the start of new systems/frames, the position of the
notes is changed to accommodate accidentals. However, this automatic position might not leave
sufficient room for the part of the tie to the left of the notes to be shown with an ideal curve.

The start of a tie chain before a
system break

The end of the same tie chain,
with a cautionary accidental in
parentheses

The end of the same tie chain after
adjusting note spacing to give the
tie beside the accidental more
space

Ties across time signature changes
Ties are automatically positioned between notes that span a time signature change. If ties
crossing a time signature change are joining notes in the middle of a staff, the top or bottom of
time signature changes are partially obscured by the ties. However, as ties are curved, the time
signature is unlikely to be completely obscured.

Ties across clef changes
Ties are automatically positioned between notes that span a change of clef. Ties across clef
changes are not horizontal, as the same pitch is positioned differently in each clef.
The result of cross-clef ties is likely to be visually and musically confusing, as they can be misread
as slurs. In this case, consider moving the change of clef to before/after the tied note.

Ties between non-adjacent notes
You can input ties between notes of the same pitch that are not directly beside each other. This
can be useful when inputting ties between multiple notes before a chord, for example.

Notes leading into a chord notated Notes leading into a chord notated Multiple grace notes before a
as a series of tied chords
as tied non-adjacent notes
chord with ties between nonadjacent notes
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Ties between different voices
You can input ties between notes of the same pitch in different voices.

Ties between notes on different staves
You can input ties between notes of the same pitch in different staves.

Laissez vibrer ties
Laissez vibrer ties are short ties that indicate a note should be left to ring, and should not be
stopped. They extend a small amount to the right of the note to which they apply, but do not
connect to another note.
You can add laissez vibrer ties to any note. You can edit laissez vibrer ties in Engrave mode like any
other tie.
RELATED LINKS
Hiding/Showing laissez vibrer ties on page 1225
Hiding/Showing or parenthesizing accidentals on page 614
Note spacing on page 425
Adjusting note spacing at individual rhythmic positions on page 429

Inputting ties between non-adjacent notes
You can manually input ties between notes of the same pitch that are not rhythmically adjacent.
You can also input ties between notes of the same pitch in different voices and different staves.
For example, you might have input a melody across multiple voices in order to accommodate
passing notes, but want to tie two notes together even though they are in different voices.
Similarly, you might have written multiple notes before a chord that are all held down and want
to reduce the number of tied notes.
PROCEDURE
1.

In Write mode, select the two notes that you want to tie together.
NOTE
The second note must be the same pitch as the first note. If the second note is a different
pitch to the first note, no tie is input.

2.

Press T .

RESULT
A tie is input between the two selected notes.
EXAMPLE

Spread chord with ties between all adjacent notes
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Ties
Deleting ties
RELATED LINKS
Inputting ties on page 192

Hiding/Showing laissez vibrer ties
You can add laissez vibrer ties to any note.
PROCEDURE
1.

Select the notes on which you want to add a laissez vibrer tie. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate/deactivate Laissez vibrer tie in the Notes and Rests group.

RESULT
Laissez vibrer ties are added to the selected notes when the property is activated, and are
removed when the property is deactivated. Laissez vibrer ties are positioned automatically.
TIP
●

You can edit the length and shape of laissez vibrer ties individually like any other tie in
Engrave mode.

●

You can assign a key command for Toggle Laissez Vibrer Tie on the Key Commands page
in Preferences.

RELATED LINKS
Changing the shape/angle of ties on page 1226

Deleting ties
You can delete ties without deleting the notes to which they are attached.
NOTE
Deleting ties from tie chains removes all ties in the tie chain. If you want to remove single ties
from longer tie chains, you can split the tie chain.

PROCEDURE
1.

In Write mode, select the tie chains from which you want to delete all ties.

2.

Press U .

RESULT
All ties in the selected tie chains are deleted. Notes previously in the tie chain remain at their
rhythmic positions.
RELATED LINKS
Changing the duration of notes on page 176
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Splitting tie chains
You can split tie chains at specified positions, for example, if you want to change the pitch
halfway through a tie chain or delete individual ties within tie chains. This does not remove any
other ties in the tie chain.
PROCEDURE
1.

In Write mode, select the tie chain you want to split.

2.

Press Shift-N to start note input.

3.

Move the caret to where you want to split the tie chain.
●

Press Right Arrow / Left Arrow to move the caret to the right/left, according to the
current rhythmic grid resolution.

●

Press Space to advance the caret to the next rhythmic position, according to the note
value currently selected.

4.

Press U to split the tie chain.

5.

Optional: If you want to split the same tie chain in multiple places, move the caret to the next
rhythmic position where you want to split the tie chain.

6.

Press Esc or Return to stop note input.

RESULT
The tie chain is split at the caret position.
RELATED LINKS
Moving the caret manually on page 171

Changing the shape/angle of ties
In Engrave mode, each tie has five square handles that you can move separately to change the
shape and angle of individual ties. Some handles are connected to others, meaning moving one
can affect the position of neighboring handles.

A tie in Engrave mode

Handles on ties behave differently to slurs. For example, moving the left endpoint moves both
the start of a tie and the other handles apart from the right endpoint. This allows you to change
the angle and/or width of the tie without changing its overall shape. Moving the left control point
causes the tie height handle to move but does not affect the position of the left and right
endpoints or right control point. This gives you fine control over the shape of ties while ensuring
that the end result remains curved and smooth.
PROCEDURE
1.

In Engrave mode, select the tie handles you want to move in any of the following ways:
●

Select a whole tie and press Tab to cycle through its handles until the one you want to
move is selected.

●

Click the handle you want to move.

●

Ctrl/Cmd -click individual handles on multiple ties.
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TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The positions of the selected tie handles are changed, which can change the shape, width, and/or
angle of the corresponding ties, depending on the handles you moved.
TIP
The following properties in the Ties group of the Properties panel are activated automatically
when you move the corresponding tie handles:
●

Start offset moves the left endpoints of ties. X moves them horizontally, Y moves them
vertically.

●

End offset moves the right endpoints of ties. X moves them horizontally, Y moves them
vertically.

●

Start handle offset moves the left control points of ties. X moves them horizontally, Y
moves them vertically.

●

End handle offset moves the right control points of ties. X moves them horizontally, Y
moves them vertically.

You can also use these properties to change the shape of individual ties by changing the values
in the value fields.
Deactivating the properties resets the corresponding handles on the selected ties to their default
positions.

Tie shoulder offset
Tie shoulders affect the angles of the curves of ties as they taper towards an endpoint, as the
tapered ends often approach noteheads at a steeper angle than that of a tie’s arch.
Increasing the shoulder offset makes the onset of the curve shallower, whereas decreasing the
shoulder offset makes the onset steeper.
You can change the project-wide settings for the offset of tie shoulders by changing the values
for the following options, which you can find by clicking Advanced Options in the Design section
of the Ties page in Engrave > Engraving Options:
●

Offset shoulders by fraction of half length of short tie

●

Offset shoulders by fraction of half length of long tie
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A long tie with default shoulder offset (1/10)

A long tie with increased shoulder offset (7/8)

You can also change the shoulder offset of ties individually by moving their control point handles
in Engrave mode.
RELATED LINKS
Project-wide engraving options for ties on page 1221

Changing the shoulder offset of ties
You can change the shoulder offset of individual ties, independently of your project-wide
settings. For example, you might want to change the shoulder offset of a few very short or very
long ties in your project to improve their shape.
PROCEDURE
1.

In Engrave mode, select one of the control point handles on each of the ties whose
shoulders you want to adjust in any of the following ways:
●

Select a whole tie and press Tab to cycle through the handles until the one you want to
move is selected.

●

Click the handle you want to move.

●

Ctrl/Cmd -click individual handles on multiple ties.

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●
3.

Click and drag them in any direction.

Optional: Repeat steps 1 and 2 for the other control point handle on the ties whose
shoulders you want to adjust.

RESULT
Moving tie offset handles further apart reduces the shoulder offset, while moving them closer
together increases the shoulder offset.
TIP
The following properties in the Ties group of the Properties panel are activated automatically
when you move the corresponding tie handles:
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●

Start handle offset moves the left control points of ties. X moves them horizontally, Y
moves them vertically.

●

End handle offset moves the right control points of ties. X moves them horizontally, Y
moves them vertically.

You can also use these properties to change the shoulder offset of individual ties by changing the
values in the value fields.
Deactivating the properties resets the corresponding handles on the selected ties to their default
positions.
TIP
You can find options controlling the default shoulder offset of all ties project-wide by clicking
Advanced Options in the Design section of the Ties page in Engrave > Engraving Options.
There are separate settings for short ties and long ties.

RELATED LINKS
Project-wide engraving options for ties on page 1221

Tie height
You can change values for the heights of all short ties and long ties project-wide. You can also
change the height of individual ties in Engrave mode.
You can find options that change the project-wide heights of ties by clicking Advanced Options
in the Design section of the Ties page in Engrave > Engraving Options. There are separate
settings for short ties and long ties.
Increasing the height of ties makes them extend further from the staff, which gives them a
rounder shape and means they take up more vertical space. Ties generally do not need to be as
curved as slurs, as they join notes of the same pitch instead of arching over or above a range of
pitches.
Where vertical space is tight, a balance must be found between how curved ties are and ensuring
staves do not overlap.

A long tie with default height

A long tie with increased height

Changing the height of ties
You can change the height of individual ties, independently of your project-wide settings, for
example, to save vertical space.
PROCEDURE
1.

In Engrave mode, select the tie height (middle) handle of the ties whose height you want to
change.
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TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the handles in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag them upwards/downwards.

RESULT
The height of the selected ties is changed.
NOTE
●

To maintain a visually pleasing and symmetrical curve when changing the height of ties
manually, you may need to move tie height handles to the right/left by a small amount, as
well as upwards/downwards.

●

Moving tie height handles to the right/left affects the shape of the whole tie.

●

You can find options controlling the default height of all ties project-wide by clicking
Advanced Options in the Design section of the Ties page in Engrave > Engraving Options.
There are separate settings for short ties and long ties.

RELATED LINKS
Project-wide engraving options for ties on page 1221

Tie styles
There are different styles of ties available in Dorico Pro, which you can use to indicate different
meanings.
Solid
This is the default style for ties. Ties appear as tapered solid lines: thinner at the ends
and thicker in the middle.

Dashed
Ties appear as tapered dashed lines. Can be used to denote optional or suggested ties,
for example, in vocal music where some verses have more syllables than others and
therefore require more notes.

Dotted
Ties appear as dotted lines. The dots are the same size and the same distance apart
over the whole length of the tie. Can also be used to denote optional or suggested ties.

1230
Dorico Pro 3.1.10

Ties
Tie styles
Half-dashed start
The first halves of ties appear as dashed lines, the second halves as solid lines. Used to
denote that a tie was written incompletely in the source in critical editions.

Half-dashed end
The first halves of ties appear as solid lines, the second halves as dashed lines. Used to
denote that a tie was written incompletely in the source in critical editions.

Editorial
Ties appear as solid black lines, but with a smaller vertical line intersecting them
exactly halfway along their length. Used to show that ties were added by the editor and
were not present in the source.

Changing the style of ties
You can change the style of individual ties. By default, all ties are solid.
NOTE
You can only select whole tie chains in Write mode. Any changes to tie chains in Write mode only
affect the first tie in the tie chain.

PROCEDURE
1.

Select the ties whose style you want to change. You can do this in Write mode and Engrave
mode.
NOTE
●

In Write mode, you can only select whole tie chains. In Engrave mode, you can select
individual ties within tie chains.

●

Any changes to tie chains in Write mode only affect the first tie in the chain.

2.

In the Properties panel, activate Style in the Ties group.

3.

Select one of the following options from the menu:
●

Solid

●

Dashed

●

Dotted

●

Half-dashed start

●

Half-dashed end

●

Editorial

RESULT
The style of the selected ties is changed.
TIP
You can set the precise parameters of each of these options project-wide on the Ties page in
Engrave > Engraving Options. For example, you can change the length and width of the stroke

1231
Dorico Pro 3.1.10

Ties
Tie styles
in Editorial ties, the diameter of dots and length of dashes, and the sizes of the gaps between
dots and dashes.

Changing the size of dashes/dots in ties
You can change the size of the dashes/dots in dashed/dotted ties individually, independently of
your project-wide settings.
NOTE
These steps only apply to dashed/dotted ties.

PROCEDURE
1.

Select the dashed/dotted ties whose dash/dot size you want to change. You can do this in
Write mode and Engrave mode.
NOTE
●

In Write mode, you can only select whole tie chains. In Engrave mode, you can select
individual ties within tie chains.

●

Any changes to tie chains in Write mode only affect the first tie in the chain.

2.

In the Properties panel, activate Dash/dot in the Ties group.

3.

Change the value in the value field.

RESULT
Increasing the value makes dashes/dots bigger, decreasing the value makes dashes/dots
smaller.
TIP
You can find options to set the default size of dashes/dots in all dashed/dotted ties project-wide
by clicking Advanced Options in the Design section of the Ties page in Engrave > Engraving
Options.
You can also change the thickness of all tie styles on this page. However, you cannot change the
thickness of ties individually.

RELATED LINKS
Project-wide engraving options for ties on page 1221

Changing the size of gaps in dashed/dotted ties
You can change the size of the gaps in dashed/dotted ties individually, independently of your
project-wide settings.
PROCEDURE
1.

In Engrave mode, select the individual dashed/dotted ties whose gap size you want to
change.

2.

In the Properties panel, activate Gap in the Ties group.

3.

Change the value in the value field.
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RESULT
Increasing the value makes the gaps between dashes/dots larger. Decreasing the value makes
the gaps between dashes/dots smaller.
TIP
You can find options to set the default size of the gaps between dashes/dots in all dashed/dotted
ties project-wide by clicking Advanced Options in the Design section of the Ties page in
Engrave > Engraving Options.

Tie curvature direction
The direction of tie curvatures is determined by the stem direction of the notes/chords at each
end of the tie, the number of notes in chords at each end, and the number of voices on the staff.

Tied single notes in single-voice contexts
If a single voice is active and a tie joins two single notes, tie curvature direction is determined by
the stem directions of the notes at either end of the tie.
●

If the stem directions match, the tie curves away from the notes and is positioned on the
notehead side.

●

If the stem directions differ, the tie curves upwards by default.

Tied chords in single-voice contexts
If a tie joins two chords, the direction of the ties is determined by the number of tied notes in the
chords.
●

For an even number, the ties are equally split between curving towards the notehead end
and curving towards the stem end.

●

For an uneven number, the majority of ties curve towards the notehead end.

Tied notes in multiple-voice contexts
Ties are positioned on the stem side and are curved as follows:
●

For up-stem voices, ties curve upwards.

●

For down-stem voices, ties curve downwards.

●

For overlapping/interlocking pitches in multiple voices, the rules for tied chords in singlevoice contexts apply. All notes in all voices are treated as if they belong to a single voice.

TIP
You can change the default tie curvature direction of ties between notes with different stem
directions on the Ties page in Engrave > Engraving Options.
You can also change the curvature direction of ties individually.

1233
Dorico Pro 3.1.10

Ties
Tie curvature direction

Changing the curvature direction of ties
You can change the curvature direction of ties individually, including individual ties within tie
chains.
PROCEDURE
1.

Select the ties whose curvature direction you want to change. You can do this in Write mode
and Engrave mode.
NOTE
●

In Write mode, you can only select whole tie chains. In Engrave mode, you can select
individual ties within tie chains.

●

Any changes to tie chains in Write mode only affect the first tie in the chain.

2.

In the Properties panel, activate Direction in the Ties group.

3.

Choose one of the following options:
●

Up

●

Down

RESULT
The curvature direction of the selected ties is changed.
TIP
You can adjust the precise shapes of tie chains, and of each tie within tie chains, in Engrave mode
using the square handles on each tie.

RELATED LINKS
Changing the shape/angle of ties on page 1226
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Time signatures indicate the meter of music, and apply to all bars from where they first appear
until a subsequent change of time signature. Meter describes the rhythmic pulse of music, and
its division into beats and bars.
A time signature is made up of two parts: numerator on top, and denominator underneath.
These are the same mathematical terms as are used for fractions due to their similar
arrangement. Depending on your project-wide settings for time signature style, numerators and
denominators can have different appearances.

1

Numerator
Specifies the number of beats in each bar for the time signature. The duration of beats is
specified by the denominator.

2

Denominator
Specifies the beat duration for the time signature. The denominator doubles for every
halving of the beat duration: 1 is a whole note (breve), 2 is a half note (minim), 4 is a quarter
note (crotchet) and so on.

For example, a 4/4 time signature tells you the bar is made up of four beats, and each of those
beats is a quarter note in length. A time signature of 4/2 contains four half notes in each bar, and
4/8 contains four eighth notes (quavers) in each bar. Both 3/4 and 6/8 contain six eighth notes,
but it is understood that a 3/4 bar contains three quarter note beats, whereas a 6/8 bar contains
two dotted quarter note beats.
Bars are rhythmic groups, divided according to the time signature, and they make following the
music much more practical and easier to read. Notes are beamed differently in different time
signatures for the same reasons.
By default, time signatures apply to all staves. However, there are some situations, such as in
polymetric music, that require some parts to have their own time signature, independently of the
rest of the ensemble. You can input time signatures that apply to all staves or only apply to single
staves in Dorico Pro.
Time signatures apply until the next time signature change or the end of the flow, whichever
comes first.
NOTE
●

Beat lengths are fixed across all staves in your project, regardless of the time signature. For
example, if you have a 2/4 time signature on one staff and a 6/8 time signature on another
staff, then one quarter note in the 2/4 time signature equals one quarter note in the 6/8 time
signature, meaning their barlines do not match.

●

Dorico Pro does not automatically add beats to fill bars when you input time signatures
unless Insert mode is activated.
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A 5/8 time signature input before an existing 4/4 time signature without Insert mode activated, leaving
only three eighth note beats in the second 5/8 bar.

RELATED LINKS
Time signature styles on page 1243
Input methods for time signatures on page 222
Beam grouping according to meters on page 665
Time Signatures (Meter) panel on page 224
Creating custom beat groupings for meters on page 682
Bars on page 631

General conventions for time signatures
Over time, the placement and appearance of time signatures has developed conventions to
ensure that their notation is always understood. Dorico Pro follows these conventions
automatically.

Appearance conventions
Time signatures should fill the height of the staff. There is a risk they may not be noticed if they
are smaller. The size of time signatures on staves with fewer than five lines should be the same
as that of a time signature on an equivalent five-line staff.

Time signature on a five-line staff

Time signature on a single-line staff

Time signatures use a unique, heavy font that ensures they stand out against staff lines, and are
instantly recognizable.
For some types of music, particularly film music, it is typical to use large time signatures that
span several staves.

Placement conventions
Time signatures should be shown at the start of a piece and at the start of subsequent
movements, if applicable, even if the music carries straight on. They should be placed after clefs
and key signatures.
If time signature changes occur during a piece or movement, it should be placed immediately
after a barline to avoid causing the duration of the previous bar to be different than the previous
time signature implies.
RELATED LINKS
Input methods for time signatures on page 222
Inputting notes in Insert mode on page 183
Large time signatures on page 1240
Changing the size and position of time signatures on page 1242
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Time signature font styles on page 1251

Project-wide engraving options for time signatures
You can find options for the project-wide appearance of time signatures, including large time
signatures, on the Time Signatures page in Engrave > Engraving Options.
The options on this page allow you to change the appearance of all numerators and
denominators project-wide, the appearance of meterless time signatures, and how
interchangeable time signatures are separated. You can also change the default gaps in time
signatures, for example, the gap between interchangeable time signatures and their separator.
Separate sections control the appearance and position of large time signatures when shown
once per bracketed group and when shown at system object positions, including how collisions
with other items at the same position as time signatures shown at system object positions are
avoided.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359
Time signatures on page 1235
Large time signatures on page 1240

Project-wide spacing gaps for time signatures
You can change the minimum gaps between objects, including time signatures, on the Spacing
Gaps page in Engrave > Engraving Options.
The following minimum values relate to time signatures:
●

Gap after barline before clef, key or time signature

●

Gap after key signature

●

Gap after mid-system time signature

Other values may have an effect on the position of time signatures; however, they also affect
other objects.

Types of time signatures
There are different types of time signatures, which can indicate various and complex meters.
NOTE
Dorico Pro uses the definitions for meters commonly used in American English. These
definitions, such as which meters are considered simple and compound, might be different in
other languages.
Simple
In simple time signatures, each beat is divided by two into equal groups of notes.
Simple time signatures can be simple duple, such as 2/4, simple triple, such as 3/4, or
simple quadruple, such as 4/4.
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Compound
In compound time signatures, each beat is divided by three into equal groups of
dotted notes, such as 6/8, which contains two dotted quarter note beats, or 9/4, which
contains three dotted half note beats.

Irregular
Irregular time signatures, such as 5/4 or 7/8, cannot be subdivided into equal beat
groups. Because the numerator is odd, these time signatures must be divided into
unequal beat groups. For example, 5/4 usually contains a half note beat and a dotted
half note beat.

Additive
Additive time signatures show how bars are subdivided into beat groups. You can show
beat group numerators for any type of time signature. For example, instead of 7/8, you
could show an additive time signature of 2+3+2/8.

Alternating
An alternating time signature indicates a regular pattern that switches every bar
between two or more time signatures, in the indicated order. For example, for a phrase
with twelve eighth notes that needs to be emphasized 3+3+2+2+2, an alternating time
signature of 6/8+3/4 might allow the two meters to be read more clearly.

Interchangeable
An interchangeable time signature indicates a set of time signatures at the start of the
piece that can be used during the piece, such as 3/4–2/4. Unlike alternating time
signatures, interchangeable time signatures do not require a fixed pattern; any bar in
the piece can follow any of the time signatures in the set without having to restate the
time signature.
NOTE
You must manually input the appropriate time signatures where you want them, as
unlike alternating time signatures, there is no fixed pattern for them. Any time
signatures you input that are specified in the interchangeable time signature are
hidden automatically.
They can have different separator styles in Dorico Pro, which you can set project-wide
and also change individually.

Aggregate
An aggregate time signature shows two or more meters within the same bar, such as
2/4+3/8+5/4. Dorico Pro automatically shows dashed barlines to indicate the divisions
between the different meters, but you can also specify that you do not want to show
dashed barlines when you input aggregate time signatures with the popover.
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Open
An open time signature has no restrictions on meter, beaming, or beats. Any number
of notes can be added, with any beaming. In Dorico Pro, an open time signature can be
shown with an X or N, or without any signature.

Non-power of two
A non-power of two time signature is one such as 5/6, which indicates five sextuplet
notes lasting for a whole note (semibreve). Examples of time signatures like this can be
found in the music of Adès.

Some composers, such as Boulez, have written fractional time signatures. Dorico Pro does not
currently support these.
RELATED LINKS
Time signature styles on page 1243
Large time signatures on page 1240
Input methods for time signatures on page 222
Time signatures popover on page 222

Pick-up bars
Pick-up bars allow you to include music before the first full bar. They are also known as “upbeats”
or an “anacrusis”. Often, pick-up bars only comprise a few beats whose main purpose is to lead in
to the start of the piece.

Pick-up bar of a single quarter note beat at the start of Chopin's Mazurka Op. 30 No. 2

Pieces that start with a pick-up bar have time signatures that are positioned at the start of the
system as normal. However, the first full bar of the time signature occurs after the first barline
and not before. Therefore, pick-up bars do not contribute to the bar number count. Bar numbers
are counted from the first full bar in the flow.
Because pick-up bars are linked to the number of notes/rests in the music, in Dorico Pro they are
linked to time signatures and so you must input pick-up bars alongside a time signature.
However, you can hide time signatures you do not want to show in the music.
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RELATED LINKS
Input methods for time signatures on page 222
Hiding/Showing time signatures on page 1250

Defining partial bars as pick-up bars or irregular bars
You can change whether explicit irregular bars at the start of time signatures are defined as pickup bars. This affects how notes in the bars are beamed and grouped.
Notes in irregular bars defined as pick-up bars are beamed/grouped backwards from the end of
the bar, while notes in irregular bars not defined as pick-up bars are beamed/grouped forwards
from the start of the bar.
NOTE
You must input explicit irregular bars and pick-up bars as part of a time signature, such as by
entering 4/4,1.5 into the time signatures popover to input a 4/4 time signature with a pick-up bar
containing 1.5 quarter note beats, or three eighth notes.

PROCEDURE
1.

Select the time signatures or the signposts of time signatures starting with an explicit
irregular bar whose pick-up definition you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Group first bar as pick-up in the Time Signatures group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Irregular bars at the start of the selected time signatures are defined as pick-up bars when
Group first bar as pick-up and its corresponding checkbox are both activated, and defined as
normal irregular bars when the corresponding checkbox is deactivated.
When the property is deactivated, Dorico Pro uses internal heuristics to define them as either
pick-up bars or normal irregular bars automatically.
EXAMPLE

Irregular bar defined as pick-up into common time

Irregular bar defined as normal irregular bar, not a
pick-up

Large time signatures
Large time signatures are scaled-up time signatures that appear much larger than normal
relative to the staff size. They can be helpful in orchestral scores, as the smaller staff size in such
scores means standard time signatures are small and harder for conductors to read.
Large time signatures are also very commonly used in film scores, as conductors rarely have
much time to prepare the scores before recording sessions. Having large time signatures makes
changes in meter more visually clear on the page, especially when music contains multiple
changes in meter.
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In Dorico Pro, you can show large time signatures at the following positions:
●

Once per bracketed group

●

Above the staff and at system object positions

Time signatures shown once per bracketed group
Instead of showing a time signature on every staff that is the same height as the staff, you can
instead show a single large time signature on each bracketed group of staves. When shown once
per bracketed group, time signatures are scaled up in size according to the number of staves in
the bracketed group. The largest time signatures are shown on bracketed groups containing four
or more staves. When shown on single staves, they extend a small amount above and below the
staff, which is commonly used for parts for film music recording sessions.

Narrow, serif time signatures shown once per bracketed group

You can change the size of time signatures on different sizes of bracketed groups on the Time
Signatures page in Engrave > Engraving Options. You can also change whether all the staves
between the brass and string brackets, which often include percussion, harp, and piano, are
treated as a single bracket or separately for the purposes of showing large time signatures.
Large time signatures shown on bracketed groups occupy horizontal space, which can be a
significant amount when they are especially large and use the standard time signature design.
Therefore, we recommend that you use one of the narrow designs in layouts that show large
time signatures on bracketed groups.

Time signatures shown at system object positions
Similar to showing large time signatures once per bracketed group, you can also show time
signatures only at system object positions and above the staff. Therefore, its positions in each
system are controlled by the same options that control the positions of other system objects,
such as rehearsal marks and tempo marks.

Normal time signatures shown at system object positions

Time signatures shown at system object positions do not occupy horizontal space, meaning it is
less important to use a narrow font style. This also reduces the horizontal distance between
notes either side of time signatures. Because of this reduced disruption to note spacing, this
placement of time signatures has become popular in contemporary art music since the 20th
Century.
When using the note denominator style for time signatures shown at system object positions,
the note is shown to the right of the numerator rather than below.
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By default, time signatures at system object positions are twice the size of normal time
signatures and force other items at the same position to appear to the right. You can change
their scale factor and the default position of other items at the same position on the Time
Signatures page in Engraving Options. You can also change their alignment relative to barlines.
RELATED LINKS
Time signature font styles on page 1251
Changing the design of time signatures on page 1251
Changing the position of time signatures on bracketed groups on page 1249
System objects on page 1172
Changing the positions of system objects on page 1173
Hiding bar numbers at time signatures shown at system object positions on page 656

Changing the size and position of time signatures
You can change the size of time signatures in each layout independently, including changing
their vertical position. For example, you can show large time signatures centered on each bracket
in full score layouts but standard-sized time signatures on each staff in part layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the size of time
signatures.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Time Signatures in the page list.

4.

Choose one of the following options for Time signature position and size:

5.

●

Show on every staff

●

Show once per bracket

●

Show at system object positions

Click Apply, then Close.

RESULT
The size and position of time signatures in the selected layouts is changed.
Showing large time signatures above the staff at system object positions means they do not
occupy any rhythmic or horizontal space, whereas the other options do cause time signatures to
occupy horizontal space.
AFTER COMPLETING THIS TASK
You can change whether large time signatures are placed vertically in the middle or on the top of
bracketed groups on the Time Signatures page in Engrave > Engraving Options.
RELATED LINKS
Large time signatures on page 1240
Positions of time signatures on page 1246
Hiding bar numbers at time signatures shown at system object positions on page 656
Project-wide engraving options for time signatures on page 1237
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Time signature styles
Dorico Pro allows you to show time signatures in a variety of styles. For example, you can show
denominators as a number or as a note value.
You can change the style of all time signatures project-wide according to their type on the Time
Signatures page in Engrave > Engraving Options, and you can change the style of individual
time signatures independently of your project-wide settings.
The numerator is always one or more numbers, and can either show the total number of beats in
the bar, or show how the total duration of the bar is subdivided.

Numerator in a 7/8 time signature shown as a single
number

Numerator in a 7/8 time signature showing
subdivisions

The denominator can appear as a number, as a note indicating the equivalent duration, or not
appear at all.

Denominator shown as number

Denominator shown as notehead
(beat length)

No denominator shown

If shown as a notehead, the denominator can either show the length of each beat in the bar, or
the note duration for the bar. When showing the beat length, the numerator can also be
changed. In the example, the numerator 6 in the 6/8 time signature becomes a 2 to reflect the
two dotted quarter note beats that make up a 6/8 bar.

Denominator notehead showing the beat length of a Denominator showing the note duration of a 6/8
6/8 time signature
time signature

RELATED LINKS
Project-wide engraving options for time signatures on page 1237
Changing the design of time signatures on page 1251
Changing the separator style of interchangeable time signatures on page 1245
Changing the open meter style of time signatures on page 1244

Changing the numerator style of time signatures
You can choose whether the numerators of individual time signatures show the total number of
beats in each bar, or the subdivision of beats in each bar, independently of your project-wide
setting.
PROCEDURE
1.

Select the time signatures whose numerator style you want to change. You can do this in
Write mode and Engrave mode.
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2.

In the Properties panel, activate Numerator style in the Time Signatures group.

3.

Choose one of the following options:
●

Number

●

Beat group

RESULT
The numerator style of the selected time signatures is changed.
TIP
You can change the numerator style of all time signatures project-wide on the Time Signatures
page in Engrave > Engraving Options.

RELATED LINKS
Time signature styles on page 1243
Project-wide engraving options for time signatures on page 1237

Changing the denominator style of time signatures
You can change the denominator style of individual time signatures independently of your
project-wide settings, for example, if you want to show the denominator as a note instead of a
number.
PROCEDURE
1.

Select the time signatures whose denominator style you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Denominator style in the Time Signatures group.

3.

Choose one of the following options:
●

Number

●

Note

●

None

RESULT
The denominator style of the selected time signatures is changed.
TIP
You can change the denominator style of all time signatures project-wide on the Time
Signatures page in Engrave > Engraving Options.

Changing the open meter style of time signatures
You can change the open meter style of individual time signatures, independently of your
project-wide setting.
PROCEDURE
1.

Select the open meter time signatures whose style you want to change. You can do this in
Write mode and Engrave mode.
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NOTE
In the Properties panel, Open style in the Time Signatures group is automatically activated
for open meter time signatures.
2.

In the Properties panel, choose one of the following options for Open style in the Time
Signatures group:
●

No symbol

●

X

●

Penderecki’s symbol

RESULT
The open meter style of the selected time signatures is changed.
TIP
You can change the style of all open meter time signatures project-wide on the Time Signatures
page in Engrave > Engraving Options.

Changing the separator style of interchangeable time signatures
You can change the separator shown in interchangeable time signatures individually,
independently of your project-wide setting.
PROCEDURE
1.

Select the interchangeable time signatures whose separator you want to change. You can do
this in Write mode and Engrave mode.
NOTE
In the Properties panel, Separator in the Time Signatures group is automatically activated
for interchangeable time signatures.

2.

Select one of the following options from the Separator menu:
●

Parentheses

●

Brackets

●

Equals sign

●

Slash

●

Space

●

Hyphen
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RESULT
The separator style of the selected interchangeable time signatures is changed.
NOTE
●

You can change the default separator of all interchangeable time signatures project-wide on
the Time Signatures page in Engrave > Engraving Options.

●

Although they might look similar to interchangeable time signatures, aggregate time
signatures behave differently. Aggregate time signatures are separated by a + sign, whereas
interchangeable time signatures can be shown with six different separators but not a + sign.
Therefore, although you can activate Separator and choose from the available options for
aggregate time signatures, the property only affects the appearance of interchangeable time
signature separators.

RELATED LINKS
Time signature styles on page 1243
Project-wide engraving options for time signatures on page 1237

Positions of time signatures
Standard time signatures are positioned on staves with the middle staff line, or only staff line for
single-line staves, passing through their center. Large time signatures can be positioned in the
middle or at the top of bracket groups, or above staves at system object positions.
You can move time signatures to different rhythmic positions in Write mode. They move
according to the current rhythmic grid resolution and are positioned by default according to your
settings in Engraving Options.
You can move individual time signatures graphically in Engrave mode; however, this does not
change the rhythmic positions to which they are attached.
You can change the default positions of all time signatures project-wide, including both their
horizontal and vertical positions, on the Spacing Gaps and Time Signatures pages in Engrave >
Engraving Options.
You can also change the position of time signatures in each layout independently, for example, if
you want to show time signatures above the staff and at system object positions in some layouts
but only once per bracket in other layouts.
RELATED LINKS
System objects on page 1172
Changing the positions of system objects on page 1173
Changing the size and position of time signatures on page 1242
Moving tempo marks graphically on page 1206
Changing the position of time signatures on bracketed groups on page 1249
Project-wide engraving options for time signatures on page 1237
Project-wide spacing gaps for time signatures on page 1237
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Moving time signatures rhythmically
You can move time signatures to new rhythmic positions after they have been input.
NOTE
●

You can only move time signatures rhythmically using the keyboard.

●

Time signatures can only be moved along staves. If you want to move a time signature
across staves, you must delete the time signature and input a new time signature on the
other staff.

●

If you want to adjust the default position of time signatures relative to notes or barlines, you
must change the project-wide values for spacing gaps on the Spacing Gaps page in
Engrave > Engraving Options.

PROCEDURE
1.

In Write mode, select the time signatures you want to move.

2.

Move the time signatures according to the current rhythmic grid resolution in any of the
following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

RESULT
The time signature takes effect from its new rhythmic position until the next existing time
signature, or the end of the flow. Barlines are automatically updated either side of the time
signature up to the previous/next existing time signature, or the start/end of the flow.
NOTE
Only one time signature can exist at each rhythmic position, except for time signatures that only
apply to single staves. If a time signature moves to the exact rhythmic position of another time
signature as part of its move, the existing time signature is deleted.
You can undo this action which restores any time signatures deleted in the process.

Moving time signatures graphically
You can move individual time signatures to new graphical positions without affecting the
positions of any other items.
NOTE
●

These steps do not apply to time signatures shown at system object positions.

●

You cannot move time signatures shown at the start of systems. You can only move time
signature changes that occur partway through systems or at the end of systems.

PROCEDURE
1.

In the Engrave toolbox, activate Note Spacing.

2.

Select a square note spacing handle at the rhythmic position of the time signature you want
to move.
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A circular handle appears beside the time signature.
3.

Press Tab to select the circular handle.

4.

Move the handle in any of the following ways:
●

Press Alt/Opt-Right Arrow to move it to the right.

●

Press Alt/Opt-Left Arrow to move it to the left.
NOTE
●

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

You cannot move note spacing handles with the mouse, you can only move them
using the keyboard.

RESULT
The time signature is moved graphically to the right/left.
TIP
You can also change the value for Spacing offset in the Time Signatures group of the Properties
panel to move time signatures horizontally. However, this also affects global note spacing
around the rhythmic position of the time signature.
The Spacing offset value is independent of note spacing changes.

RELATED LINKS
Note spacing on page 425

Moving time signatures shown at system object positions
graphically
You can move time signatures shown at system object positions graphically, in different ways to
moving other time signatures graphically.
NOTE
●

These steps do not apply to time signatures shown on staves.

●

If you want to move time signatures because you want to change their alignment with
barlines, you can change the default alignment of all time signatures shown at system object
positions in the Time Signatures at System Object Positions section of the Time
Signatures page in Engrave > Engraving Options.

PROCEDURE
1.

In Engrave mode, select the time signatures at system object positions that you want to
move graphically.

2.

Move the time signatures in any of the following ways:

1248
Dorico Pro 3.1.10

Time signatures
Positions of time signatures
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as the
standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag them in any direction.

RESULT
The selected time signatures shown at system object positions are moved to new graphical
positions.
TIP
Offset in the Time Signatures group of the Properties panel is activated automatically when you
move time signatures shown at system object positions graphically.
●

Offset X moves time signatures horizontally.

●

Offset Y moves time signatures vertically.

You can also use this property to move time signatures shown at system object positions
graphically by changing the values in the value fields.
Deactivating the property resets the selected time signatures to their default positions.

RELATED LINKS
Changing the size and position of time signatures on page 1242
Hiding bar numbers at time signatures shown at system object positions on page 656
System objects on page 1172
Changing the positions of system objects on page 1173
Moving time signatures graphically on page 1247
Project-wide engraving options for time signatures on page 1237

Changing the position of time signatures on bracketed groups
By default, time signatures shown once per bracket are centered on each bracketed group. You
can change their vertical position on bracketed groups for all layouts project-wide, for example, it
is common in film scores to show the top of large time signatures aligned with the top of each
bracketed group.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Time Signatures in the page list.

3.

In the Time Signatures Centered on Brackets section, choose one of the following options
for Vertical alignment relative to bracket:

4.

●

Top

●

Middle

Click Apply, then Close.
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RESULT
The vertical alignment of large time signatures relative to bracketed groups is changed in all
layouts project-wide.
RELATED LINKS
Positions of time signatures on page 1246
Large time signatures on page 1240
Changing the size and position of time signatures on page 1242

Hiding/Showing time signatures
You can hide/show time signatures without deleting them from your project. This hides/shows
them in all layouts, not just the one currently open in the music area.
PROCEDURE
1.

Select the time signatures you want to hide, or the signposts of time signatures you want to
show. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Hide time signature in the Time Signatures
group.

RESULT
The selected time signatures are hidden in all layouts when Hide time signature is activated,
and shown when it is deactivated.
Signposts are shown at the position of each hidden time signature. However, signposts are not
printed by default.
NOTE
●

Hidden time signatures do not take up any horizontal space, so hiding/showing time
signatures affects note spacing.

●

You can hide/show time signature signposts by choosing View > Signposts > Time
Signatures. Time signature signposts are shown when a tick appears beside Time
Signatures in the menu, and hidden when no tick appears.
You can choose to print time signature signposts if you activate View options in the
Annotations section of the Print Options panel on the right of the window in Print mode.

●

You can assign a key command for Hide/Show Item on the Key Commands page in
Preferences, which applies to chord symbols, playing techniques, and time signatures.

RELATED LINKS
Note spacing on page 425
Signposts on page 335

Deleting time signatures
You can delete time signatures without affecting the relative rhythmic positions of notes.
PROCEDURE
1.

In Write mode, select one of the following:
●

The time signatures you want to delete.

●

The signposts of hidden time signatures you want to delete.
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2.

Press Backspace or Delete .

RESULT
The time signatures are deleted from the score. Bars after their previous positions are re-barred
according to the previous time signature in the score, up until the next time signature or the end
of the flow.
If you delete the only time signature in the flow, your music appears in an open meter, but with
all the same rhythmic values.
RELATED LINKS
Types of time signatures on page 1237

Time signature font styles
Different time signature designs use different font styles. You can edit the formatting of fonts
used for time signatures in the Edit Font Styles dialog.
The following fonts are used for time signatures:
●

Time Signature Font: Used for standard time signatures and large time signatures that use
the Normal, Narrow, serif, or Narrow, sans serif design types. Must use a SMuFLcompliant font family.

●

Time Signature Plain Font: Used for time signatures using the Plain font design type. Can
use any font family, but we recommend that you use narrow fonts for large time signatures.

NOTE
Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Edit Font Styles dialog on page 407
Large time signatures on page 1240

Changing the design of time signatures
You can change the design of time signatures in each layout independently, including changing
the font style used for them, for example, if you want to use a plain font for time signatures in
full score layouts but the standard time signature font in part layouts.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the design of time
signatures.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Time Signatures in the page list.

4.

Choose one of the following options for Time signature design:
●

Normal

●

Narrow, serif

●

Narrow, sans serif

●

Plain font
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5.

Click Apply, then Close.

RESULT
The design of time signatures in the selected layouts is changed. If you choose Plain font, time
signatures use a different font style than the one used for the other options.
RELATED LINKS
Time signature styles on page 1243
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Tremolos are thick, slanted lines that cross individual stems or are positioned between multiple
stems. They are used to indicate that notes are repeated, either individually or in sequences of
multiple notes.
Using tremolo strokes instead of notating each notehead can save horizontal space and make
fast passages easier to read.
The number of tremolo strokes indicates both how many times notes are repeated and how fast
they are. In measured tremolos, for example, one tremolo stroke on the stem of a quarter note
(crotchet) indicates two eighth notes (quavers) are played, whereas three tremolo strokes on the
stem of a quarter note indicates eight 32nd notes are played.

Quarter note with a one-stroke single-note tremolo
and its equivalent notation

Quarter note with a three-stroke single-note tremolo
and its equivalent notation

There are different types of tremolos:
Single-note tremolos
Individual notes are repeated.

Multi-note tremolos
Multiple notes, usually two, are played in sequence, similar to a trill. However, trills
usually indicate a fast alternation between two adjacent notes, such as G and A,
whereas multi-note tremolos can be between any notes, limited only by the capabilities
of the instrument.

Tuplet tremolos
Multiple notes in tuplets are repeat in the notated sequence.

Depending on the musical context, tremolos can be either measured or unmeasured. There is no
visual difference between measured/unmeasured tremolos, so composers/arrangers often
specify how they want tremolos to be played, such as an indication in the front matter of the
score or as a text instruction in the score.
Measured tremolos
The number of tremolo strokes corresponds to a precise rhythm in the prevailing
tempo and meter.
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Unmeasured tremolos
There is no link between the number of strokes and rhythm. Instead, unmeasured
tremolos are played as fast as possible, whatever the tempo.
Unmeasured tremolos often use three or more tremolo strokes, and can also be
accompanied by a “trem.” text indication.
RELATED LINKS
Input methods for repeats and tremolos on page 300

Tremolos in tie chains
By default, all notes in tie chains are shown with tremolo strokes when single-note tremolos are
added to tie chains. Deleting tremolo strokes from tied notes removes tremolo strokes from all
notes in tie chains.
In Dorico Pro, tremolos are considered measured by default, so the number of tremolo strokes
shown is automatically adjusted on subsequent notes in tie chains as required. For example, if an
eighth note with two tremolo strokes is tied to a quarter note, the quarter note has three
tremolo strokes. This is because tremolo strokes function like beams, so two tremolo strokes and
an eighth note stem flag is the equivalent of three tremolo strokes.
However, there might be circumstances in which you want all notes to have the same number of
tremolo strokes, whatever their duration. You can also start tremolos partway through tie chains,
or stop tremolos partway through tie chains.
You can change the number of tremolo strokes shown on individual notes independently in
Engrave mode.

Changing the number of tremolo strokes on individual notes in tie
chains
Dorico Pro automatically changes the number of tremolo strokes on subsequent notes in tie
chains according to their duration, but you can manually change the number of single-note
tremolo strokes shown on each note in tie chains individually to represent your intended rhythm.
PROCEDURE
1.

In Engrave mode, select the noteheads of the notes whose number of tremolo strokes you
want to change.

2.

In the Properties panel, activate Single stem tremolo in the Notes and Rests group.

3.

Select one of the following options from the menu:
●

None

●

One stroke

●

Two strokes

●

Three strokes

●

Four strokes

●

Buzz roll

RESULT
The number of tremolo strokes shown on the selected notes is changed.
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EXAMPLE

The default number of tremolo strokes in a tie chain
where the second note is longer than the first.

The number of tremolo strokes on the second note
has been changed to match the first.

RELATED LINKS
Changing the speed of tremolos on page 1255

General placement conventions for tremolos
Single-note tremolos are positioned on note stems, whereas multi-note tremolos are positioned
between the stems of two or more notes. When multi-note tremolos cross three or more notes,
the tremolo strokes are positioned between all the notes.
Tremolo strokes are slightly thinner than beams, so that the gaps between strokes are large
enough and the number of strokes can be instantly recognized.
Tremolo strokes should not collide with ledger lines or stem flags. Dorico Pro automatically
positions tremolo strokes to ensure such collisions are avoided.
Tremolo strokes within the staff are positioned so that they are at least one staff space clear of
noteheads, and at valid positions relative to staff lines and staff spaces. This means that tremolo
strokes might not move every time you change the pitch of notes.

The positions of the tremolo strokes on the first two notes and the last two notes are the same, although the
pitches are all different.

In Dorico Pro, the angle of single-note tremolo strokes is always the same, no matter the
direction of the phrase. The angles of multi-note tremolo strokes are determined by the height of
the stems to which the multi-note tremolos apply. You can change the angles of multi-note
tremolo strokes individually by lengthening/shortening the stems at the start/end of the tremolo.
You can change the default positions of all tremolo strokes project-wide on the Tremolos page in
Engrave > Engraving Options.
RELATED LINKS
Moving tremolo strokes on page 1257
Project-wide engraving options for tremolos on page 1258

Changing the speed of tremolos
You can change the speed of tremolos after they have been input by changing the number of
strokes.
PROCEDURE
1.

In Write mode, select the notes with tremolos whose speed you want to change.
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The buttons with the number of tremolo strokes corresponding to your selection are
highlighted in the Tremolos section of the Repeat Structures panel.
NOTE
Select single-note tremolos and multi-note tremolos separately.
2.

Click the button with the number of tremolo strokes you want in the Tremolos section of the
Repeat Structures panel.
For example, click Two Strokes Single-note Tremolo to input single-note tremolos with two
strokes, or click Three Strokes Multi-note Tremolo to input multi-note tremolos with three
strokes.

Two Strokes Single-note Tremolo

Three Strokes Multi-note Tremolo

RESULT
The number of tremolo strokes on the selected notes is changed, which changes the speed of
the tremolos.
RELATED LINKS
Tremolos in playback on page 1259
Changing the number of tremolo strokes on individual notes in tie chains on page 1254

Deleting tremolos
You can remove single-note tremolos and multi-note tremolos from notes separately without
affecting the notes to which they applied.
PROCEDURE
1.

In Write mode, select the notes whose tremolo strokes you want to delete.

2.

Click the appropriate buttons in the Tremolos section of the Repeat Structures panel for the
types of tremolos selected:
●

Remove Single-note tremolo

●

Remove Multi-note tremolo

RESULT
The corresponding types of tremolo strokes are deleted.
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EXAMPLE

Notes with single-note tremolos
and multi-note tremolo

Notes with multi-note tremolo
deleted but single-note tremolos
remain

Notes with both multi-note
tremolo and single-note tremolos
deleted

Rhythmic positions of notes with tremolos
You can move notes with single-note tremolos and multi-note tremolos to new rhythmic
positions in the same ways as normal notes. However, if you move multi-note tremolos across
barlines, the tremolo strokes are deleted automatically.
NOTE
You can undo moving tremolos immediately, which restores any multi-note tremolo strokes
deleted in the process.
You can move single-note tremolos to new rhythmic positions and across barlines without
affecting their tremolo strokes. The notes are automatically respelled as tie chains if required by
their new rhythmic positions and time signature, in the same ways as normal notes.
NOTE
If tie chains with single-note tremolos contain notes of different durations, the number of
tremolo strokes on each note in the tie chain is different. You can change the number of tremolo
strokes shown on each note in tie chains individually.

RELATED LINKS
Moving notes rhythmically on page 901
Changing the number of tremolo strokes on individual notes in tie chains on page 1254

Moving tremolo strokes
You can move tremolo strokes upwards/downwards graphically.
NOTE
●

You cannot move tremolo strokes to the right/left.

●

You cannot move tremolo strokes rhythmically, as they apply to specific notes, but you can
move notes with tremolos to different rhythmic positions. Notes with single-note tremolos
can cross barlines; however, multi-note tremolo strokes are deleted automatically when their
notes cross barlines.

PROCEDURE
1.

In Engrave mode, select the tremolo strokes you want to move.

2.

Move the tremolo strokes in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them upwards.
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●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Up Arrow .

●

Click and drag them upwards/downwards.

RESULT
The selected tremolo strokes are moved upwards/downwards.
NOTE
●

Moving multi-note tremolo strokes also changes the length of the stems to which they are
attached.

●

When you first move tremolo strokes graphically, they may appear to move in the wrong
direction or by a larger increment than you expected. This is because their positions are
reset when you override those positions by moving them.

●

The following properties in the Beaming group of the Properties panel are activated
automatically when you move the start/end of multi-note tremolo strokes:
●

Start Y offset moves the start of multi-note tremolo strokes vertically by moving the end
of the corresponding stem.

●

End Y offset moves the end of multi-note tremolo strokes vertically by moving the end
of the corresponding stem.

Tremolo Y in the Notes and Rests group of the Properties panel is activated automatically
when you move single-note tremolo strokes. It moves single-note tremolo strokes vertically.
For example, if you move a whole multi-note tremolo stroke upwards, both stem handles are
moved so both properties are activated. You can also use these properties to move tremolo
strokes by changing the values in the value fields. However, you must select the noteheads
rather than the tremolo strokes in order to see the relevant groups in the Properties panel.
Deactivating the properties resets the selected stem handles, and therefore tremolo strokes,
to their default positions.

Project-wide engraving options for tremolos
You can find options for the project-wide appearance and position of tremolos on the Tremolos
page in Engrave > Engraving Options.
The options on the Tremolos page allow you to change the appearance of tremolo strokes, and
their positions relative to the ends of stems, stem flags, noteheads, and beams.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359
Project-wide engraving options for stems on page 1195
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Changing the appearance of multi-note half note tremolos projectwide
There are multiple accepted ways of notating multi-note half note tremolos. You can change how
multi-note half note tremolos are notated project-wide.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Tremolos in the page list.

3.

In the Multi-note Tremolos section, choose one of the following options for Appearance of
half note (minim) tremolos:

4.

●

All lines join stems

●

Outermost line joins stems

●

No lines join stems (default)

Click Apply, then Close.

RESULT
The appearance of all multi-note half note tremolos project-wide is changed, according to your
preference.

Tremolos in playback
You can control the playback of unmeasured tremolos by specifying the minimum number of
tremolo strokes that are interpreted as unmeasured tremolos. This considers both the number of
tremolo strokes and the number of beam lines that would be used for the note.
●

You can do this on the Timing page in Play > Playback Options.

For example, if the option is set to require three tremolo strokes, an eighth note with two
tremolo strokes is played as unmeasured, because the single beam of the eighth note is included
in the calculation.
You can also specify the default length of notes in unmeasured tremolos. You express the
duration of notes as a fraction of the length of a quarter note played at 120 quarters per minute
in the Tremolos section.
The number of tremolo strokes determines the note value of the repeated notes. For example,
one stroke indicates an eighth note, two strokes indicate a 16th note, and so on.
TIP
You can enable independent voice playback for individual instruments, for example, if you have
tremolos in one voice and slurs in another voice.

RELATED LINKS
Playback Options dialog on page 502
Enabling independent voice playback on page 543

1259
Dorico Pro 3.1.10

Tremolos
Tremolos in playback

Changing the duration of tremolos in playback
You can change both the default length of each note in unmeasured tremolos in playback, and
the minimum number of tremolo strokes required to indicate tremolos should be unmeasured in
playback.
For example, to change the value in the value field to set the default length to 0.5 seconds, enter
1 into the value field for Default unmeasured tremolo length in the Tremolos section on the
Timing page in Play > Playback Options.
TIP
If you hover over either of the arrows beside the Default unmeasured tremolo length value
field, a small box appears that displays the current fraction as a decimal.

PROCEDURE
1.

Press Ctrl/Cmd-Shift-P to open Playback Options.

2.

Click Timing in the page list.

3.

Optional: In the Tremolos section, change the value for Minimum number of strokes for
playback of unmeasured tremolos.

4.

Change the value for Default unmeasured tremolo length.
For example, to set the default length of unmeasured tremolo notes to 0.5 seconds, change
the value to 1.
TIP
If you hover over either of the arrows beside the value field, a small box appears that
displays the current fraction as a decimal.

5.

Click Apply, then Close.

RESULT
The sounding duration of each note in unmeasured tremolos in playback is changed projectwide.
Changing the value for Minimum number of strokes for playback of unmeasured tremolos
changes the minimum number of tremolo strokes required for tremolos to be unmeasured in
playback.
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Tuplets indicate where a beat is divided into a different number of subdivisions than is usually
expected according to the current meter. They can be used to fit more notes or fewer notes in a
beat than usually exist in a beat, according to the usual pattern of subdivision.

A 4/4 bar with the standard subdivision of four
quarter notes

A 4/4 bar with a subdivision of six triplet quarter
notes in the space of four regular quarter notes

A 6/8 bar with the standard subdivision of six eighth
notes

A 6/8 bar with a subdivision of four duplet eighth
notes in the space of six regular eighth notes

Because these subdivisions are not standard but tuplet notes use the same rhythmic notation as
normal notes, tuplets must be clearly marked to show that their rhythmic duration is different.
In the examples, the triplet quarter notes are shown under a bracket with the number 3. The
duplet eighth notes do not need a bracket as they are joined by a beam, which has a number 2
above it.
Tuplets in Dorico Pro can be shown with just a tuplet bracket, with a tuplet bracket and a tuplet
number/ratio, or with a tuplet bracket, a tuplet number/ratio, and a note indicating the note
value of the tuplet.
RELATED LINKS
Inputting tuplets on page 195
Tuplet brackets on page 1267
Tuplet numbers/ratios on page 1271

General placement conventions for tuplets
Tuplet brackets and tuplet numbers/ratios are generally placed on the stem side of notes. When
tuplets are shown with a tuplet beam, a tuplet bracket is not always necessary but can be shown
in addition to a tuplet number/ratio.
According to convention, tuplet brackets and tuplet numbers/ratios are always placed above the
staff for vocal staves, so they do not come between notes and lyrics.
Tuplet brackets should be placed as close to notes as possible without colliding with other
notation, such as slurs or articulation. Slurs are usually placed inside tuplet brackets if the slur is
shorter than the tuplet bracket. If a slur is longer than a tuplet bracket, the slur can be placed
outside the tuplet bracket.
The horizontal position of tuplet brackets should allow it to be immediately obvious which notes
are included in the bracket. They should not extend so far that notes following the tuplet appear
to be included.

1261
Dorico Pro 3.1.10

Tuplets
Project-wide engraving options for tuplets

A tuplet clearly showing the three quarter notes
included in the triplet.

With an extended tuplet bracket, the duration of the
triplet is now unclear.

Project-wide engraving options for tuplets
You can find options for the project-wide appearance of tuplets, tuplet brackets, and tuplet
numbers/ratios on the Tuplets page in Engrave > Engraving Options.
The options on the Tuplets page allow you to change the appearance and angles of tuplet
brackets, and the position of tuplet brackets, tuplet numbers/ratios relative to the staff and
noteheads.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
RELATED LINKS
Engraving Options dialog on page 359

Nested tuplets
Nested tuplets are tuplets within larger tuplets that are often used to create complex rhythms. In
Dorico Pro, there is no limit to the number of levels you can have in nested tuplets.
EXAMPLE

Nested tuplets

Inputting nested tuplets
You can input nested tuplets in new, empty staves and you can select existing tuplets and input
nested tuplets within them.
PROCEDURE
1.

In Write mode, start note input.

2.

Press ; to open the tuplets popover.

3.

Optional: If inputting nested tuplets in an empty staff, enter the ratio for the outer tuplet
into the popover. For example, enter 3:2.

4.

Optional: Press Return to close the popover and enter the outer tuplet.
NOTE
You can skip steps 3 and 4 if you are inputting nested tuplets into existing tuplets.

5.

Press ; to open the tuplets popover again.

6.

Enter the ratio for the inner tuplet into the popover. For example, enter 5:4.
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7.

Press Return to close the popover and enter the inner tuplet.

8.

Enter or play in the pitches you want.

9.

Stop inputting nested tuplets in one of the following ways:
●

Press : once to stop the inner tuplet and continue inputting the outer tuplet.

●

Press : twice to stop both tuplets and return to inputting normal notes.

●

Press Esc to stop note input completely.

●

Move the caret with the arrow keys to return to inputting normal notes.

RESULT
The pitches you enter or play in are input as nested tuplets, starting from the caret position.
If multiples of the inner tuplet fit exactly inside the outer tuplet, you can continue inputting notes
as the specified nested tuplet until you stop the tuplets manually.
If multiples of the inner tuplet do not fit exactly inside the outer tuplet, the inner tuplet stops
automatically at the end of the last tuplet that fits in the outer tuplet. After that, the outer tuplet
continues until you stop it manually.
NOTE
You can also input nested triplets by clicking Tuplets in the Notes toolbox when the caret is
within an existing tuplet. However, you can only input one nested triplet at a time this way.

Turning existing notes into tuplets
You can turn any existing notes into tuplets, for example, if you need to fit extra notes into an
existing duration.
PROCEDURE
1.

In Write mode, select the notes you want to turn into tuplets.

2.

Press ; to open the tuplets popover.
The popover is automatically populated with a suggested ratio based on your selection.

3.

Optional: Change the ratio in the popover. For example, enter 3:2 to input triplets.

4.

Press Return to close the popover.

RESULT
The selected notes are turned into tuplets according to the ratio in the popover. For example, if
you select five eighth notes and enter 5:4 into the popover, the selected notes become
quintuplet eighth notes.
If the selected notes fit into a single tuplet of the specified ratio, only a single tuplet is created. If
the selected notes do not fit into a single tuplet, as many tuplets as required are created
automatically.
RELATED LINKS
Tuplets popover on page 196
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Turning tuplets into normal notes
You can turn any existing tuplets notes into normal notes, for example, if you want to turn tuplet
eighth notes into standard eighth notes.
PROCEDURE
1.

In Write mode, select just the brackets, numbers/ratios, or signposts of the tuplets you want
to turn into normal notes.
NOTE
You must not select any of the noteheads in the tuplets.

2.

Optional: If you want to retain all notes in the selected tuplets, press I to activate Insert
mode.

3.

Press Backspace or Delete .

RESULT
All notes in the selected tuplets are unscaled and appear as normal notes with the same notated
duration, for example, a tuplet quarter note becomes a standard quarter note.
When Insert mode is activated, all notes in the tuplets are retained and any subsequent existing
notes are pushed to later rhythmic positions to accommodate the extra rhythmic durations
required. When Insert mode is deactivated, the earliest selected tuplets expand and overwrite
subsequent notes and tuplets.
RELATED LINKS
Hiding/Showing signposts on page 336
Tuplet numbers/ratios on page 1271
Tuplet brackets on page 1267

Allowing/Disallowing tuplets to span barlines
You can allow tuplets to span barlines, for example, in Renaissance music, you might want
tuplets to span tick barlines without affecting their notation. By default, Dorico Pro automatically
splits tuplets over barlines so that both the durations of bars and the divisions in tuplets are
clear.
PROCEDURE
1.

Select the tuplet brackets or tuplet numbers/ratios of the tuplets you want to allow/disallow
to span barlines. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Spans barline in the Tuplets group.

RESULT
The selected tuplets span barlines when Spans barline is activated, and are automatically split at
barlines when it is deactivated.
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EXAMPLE

A 16th note sextuplet across a barline, notated as
two triplets

The same sextuplet allowed to span the barline and
beamed together

AFTER COMPLETING THIS TASK
You can beam notes in the selected tuplets together.
RELATED LINKS
Barlines on page 636
Beaming notes together manually on page 667
Tuplet brackets on page 1267
Tuplet numbers/ratios on page 1271

Moving tuplets rhythmically
You can move tuplets to different rhythmic positions after they have been input, including
independently of tuplet brackets and tuplet numbers/ratios. Moving notes beyond the
boundaries of a tuplet turns them back into normal notes.
PROCEDURE
1.

In Write mode, select the tuplets you want to move.
NOTE
You must also select their tuplet numbers/ratios, brackets, or tuplet signposts in the
selection if you want the notes to remain tuplets. If a tuplet number/ratio or tuplet bracket is
not selected, the notes become normal notes of their rhythmic value when you move them
beyond the boundaries of tuplets.

2.

Move the selected tuplets according to the current rhythmic grid resolution in any of the
following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

NOTE
You cannot move tuplets rhythmically using the mouse.

RESULT
The selected tuplets are moved to new rhythmic positions.
If a tuplet number/ratio or tuplet bracket is included in the selection, the whole tuplet is moved
along the staff. If it crosses a barline, the tuplet is automatically adjusted to compensate.
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NOTE
●

If Chords is not activated and any of your selected notes collide with other notes in the same
staff and at the same rhythmic position that are in the same voice as your selected notes, the
existing notes are deleted and replaced with your selected notes.
You can undo moving notes immediately, which restores any notes deleted in the process.

●

Tuplets are not automatically adjusted at the mid-point of bars, where it is convention to split
tuplets to show the beat division. You must enter two tuplets manually to show the beat
division at the mid-point of bars.

EXAMPLE

Deleting tuplets
You can delete tuplets, including all the tuplet notes, but you can also delete tuplet brackets and
numbers/ratios without deleting the corresponding notes.
PROCEDURE
1.

In Write mode, select the tuplets you want to delete.
TIP
To delete an entire tuplet and all the notes within it, select all the noteheads and the
corresponding tuplet bracket or tuplet number/ratio.

2.

Press Backspace or Delete .

RESULT
The selected tuplets are deleted.
●

Selecting just the notes deletes the notes, but does not delete the tuplet.

●

Selecting just the tuplet bracket or tuplet number/ratio deletes the tuplet, and the notes that
were previously within the tuplet are retained with the same notated duration. For example,
deleting the bracket from triplet quarter notes leaves the notes previously in the triplet as
three quarter notes.

NOTE
This overrides existing notes immediately after the tuplet. However, if Insert mode is activated,
any subsequent existing notes are pushed to later rhythmic positions to accommodate the extra
rhythmic durations required.

RELATED LINKS
Turning tuplets into normal notes on page 1264
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Tuplet beams
Tuplet beams join notes in tuplets that can be joined with beams just like non-tuplet beams. You
can make the same changes to tuplet beams that you can make to any other beam.
RELATED LINKS
Beaming on page 664
Tuplets within beams on page 677
Beaming notes together manually on page 667
Unbeaming notes on page 667
Splitting beam groups on page 666
Changing the direction of partial beams on page 667
Changing beam slants on page 670

Tuplet brackets
Tuplet brackets show the duration of tuplets that are not joined by beams, such as triplet quarter
notes, by showing the notes within the tuplet under a bracket.
You can change the precise positions and shapes of tuplet brackets individually in Engrave mode.
Each tuplet bracket has four handles that can be moved graphically.

The two upper handles set the position of the start/end of the tuplet bracket. These handles can
be moved independently of each other to create angled tuplet brackets, even if you have set
tuplet brackets to be Always horizontal on the Tuplets page in Engrave > Engraving Options.
The two lower handles set the length of the tuplet bracket hooks. Moving either of these handles
changes the length of both hooks.
NOTE
You can use properties in the Tuplets group of the Properties panel to edit individual tuplet
brackets; however, the Tuplets group is only shown if you select tuplet numbers/ratios or
brackets. It is not shown if you select notes within the tuplet, or notes within the tuplet and the
tuplet number/ratio or bracket.

RELATED LINKS
Changing the angles of tuplet brackets on page 1269
Lines on page 1033

Moving tuplet numbers/ratios and brackets graphically
You can move tuplet numbers/ratios and tuplet brackets graphically without changing the
rhythmic positions to which they apply. You can also move the start/end handles of tuplet
brackets independently of each other, meaning you can lengthen/shorten tuplet brackets
graphically.
PROCEDURE
1.

In Engrave mode, select any of the following that you want to move:
●

Tuplet numbers/ratios

●

Whole tuplet brackets
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●
2.

Individual handles on tuplet brackets

Move the tuplet brackets, tuplet numbers/ratios, or handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move handles to the right.

●

Press Alt/Opt-Left Arrow to move handles to the left.

●

Press Alt/Opt-Up Arrow to move handles, whole brackets, and tuplet numbers/ratios
upwards.

●

Press Alt/Opt-Down Arrow to move handles, whole brackets, and tuplet numbers/
ratios downwards.
TIP
If you want to move tuplet brackets, tuplet numbers/ratios, or handles by larger
increments, you can press Ctrl/Cmd as well as the standard key command, for example,
Ctrl/Cmd-Alt/Opt-Left Arrow .

●

Click and drag whole tuplet brackets or tuplet numbers/ratios upwards/downwards.

●

Click and drag handles on tuplet brackets in any direction.

RESULT
The selected tuplet brackets or tuplet numbers/ratios are moved to new graphical positions,
without changing the rhythmic positions to which they apply.
TIP
●

The following properties in the Tuplets group of the Properties panel are activated
automatically when you move the corresponding part of tuplet brackets:
●

Start offset moves the start of tuplet brackets. X moves them horizontally, Y moves
them vertically.

●

End offset moves the end of tuplet brackets. X moves them horizontally, Y moves them
vertically.

●

Hook length changes the length of tuplet bracket hooks.

For example, if you move a whole tuplet bracket, both handles are moved, so Start offset
and End offset are both activated. You can also use these properties to move tuplet brackets
and tuplet numbers/ratios graphically by changing the values in the value fields.
As you can change values for the properties for the start/end of tuplet brackets
independently, you can also use the properties to change the angles of tuplet brackets.
Deactivating the properties resets tuplet brackets to their default positions.
●

You can change the default position of all tuplet brackets project-wide in the Horizontal
Position section of the Tuplets page in Engrave > Engraving Options.

Hiding/Showing tuplet brackets
You can hide/show tuplet brackets independently of tuplet numbers/ratios.
PROCEDURE
1.

Select the tuplet brackets you want to hide, or the signposts of tuplets whose brackets you
want to show. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Bracket in the Tuplets group.

3.

Choose one of the following options:
●

Hidden
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●

Shown

RESULT
Brackets on the selected tuplets are hidden/shown. Signposts are shown at the position of each
hidden tuplet, that is, tuplets with no numbers/ratios or brackets shown.
AFTER COMPLETING THIS TASK
If you want to hide indications of tuplets entirely, you might also need to hide the tuplet
numbers/ratios.
RELATED LINKS
Signposts on page 335
Hiding/Showing tuplet numbers/ratios on page 1272

Changing the angles of tuplet brackets
You can change the angles of individual tuplet brackets by moving the square handles on each
corner of tuplet brackets to new graphical positions independently.
PROCEDURE
1.

2.

In Engrave mode, select one of the following handles on the tuplet brackets whose angle you
want to change:
●

The start corner handle

●

The end corner handle

Move the handles in any of the following ways:
●

Press Alt/Opt-Right Arrow to move them to the right.

●

Press Alt/Opt-Left Arrow to move them to the left.

●

Press Alt/Opt-Up Arrow to move them upwards.

●

Press Alt/Opt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt/Opt-Left Arrow .

●
3.

Click and drag them in any direction.

Optional: Repeat steps 1 and 2 for the other corner handle on the tuplet brackets whose
angle you want to change.

RELATED LINKS
Moving tuplet numbers/ratios and brackets graphically on page 1267
Forcing tuplet brackets to be horizontal on page 1271
Tuplet brackets on page 1267
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Changing the staff-relative placement of tuplet brackets
You can show individual tuplet brackets and tuplet numbers/ratios above or below the staff or
between staves.
PROCEDURE
1.

Select the tuplet brackets and tuplet numbers/ratios whose staff-relative placement you
want to change. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Placement in the Tuplets group.

3.

Choose one of the following options:
●

Above

●

Below

●

Cross-staff above

●

Cross-staff below

RESULT
The placement of the selected tuplet brackets is changed.
TIP
●

Deactivating Placement returns the selected tuplets to their default placement.

●

You can also switch selected tuplets between being above/below the staff or cross-staff
above/cross-staff below by pressing F .

●

You can change the placement of all tuplet brackets relative to vocal staves project-wide in
the Placement section of the Tuplets page in Engrave > Engraving Options.

Changing the rhythmic end position of tuplet brackets
You can change the rhythmic end position of tuplet brackets relative to individual notes
individually.
PROCEDURE
1.

Select the tuplet brackets whose end position you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate End position in the Tuplets group.

3.

Choose one of the following options:
●

End at right-hand side of final note

●

End immediately before following note

●

End at position of final tuplet division
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RESULT
The end position for the selected tuplet brackets is changed.
TIP
●

Deactivating the property returns the selected tuplets to your default settings.

●

You can change the horizontal position of tuplet numbers/ratios on all tuplets project-wide in
the Horizontal Position section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Changing the angles of tuplet brackets on page 1269
Project-wide engraving options for tuplets on page 1262

Forcing tuplet brackets to be horizontal
You can change the angle of individual tuplet brackets so that they appear horizontal,
independently of your project-wide setting.
PROCEDURE
1.

Select the tuplet brackets whose angle you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Force horizontal in the Tuplets group.

RESULT
The selected tuplet brackets appear horizontal when the property is activated. When the
property is deactivated, the selected tuplet brackets follow your project-wide setting for angled
tuplet brackets.
TIP
You can change whether all tuplet brackets can appear angled or always appear horizontal
project-wide in the Brackets section of the Tuplets page in Engrave > Engraving Options.

Tuplet numbers/ratios
Tuplet numbers and ratios are very similar: both indicate the number of equal notes included in
the tuplet, such as 3 for triplets, but tuplet ratios also include the number of normal notes into
whose duration the tuplet fits, such as 3:2 for triplets.
Additionally, tuplet ratios can include a note that indicates the duration of notes in the tuplet.

A triplet with a ratio and note value indication

Tuplet numbers/ratios help performers quickly identify the type of tuplet and how they must fit
the number of notes indicated into the prevailing tempo and meter.
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In Dorico Pro, you can change the appearance of all tuplet numbers/ratios project-wide on the
Tuplets page in Engrave > Engraving Options, such as changing the font used for them, and for
individual tuplets independently of this setting.
NOTE
You can use properties in the Tuplets group of the Properties panel to edit individual tuplet
numbers/ratios; however, the Tuplets group is only shown if you select tuplet numbers/ratios or
brackets. It is not shown if you select notes within the tuplet, or notes within the tuplet and the
tuplet number/ratio or bracket.

RELATED LINKS
Changing the font used for tuplet numbers/ratios on page 1273

Hiding/Showing tuplet numbers/ratios
You can hide/show tuplet numbers/ratios individually. When showing tuplet numbers/ratios, you
can choose a different type for each tuplet individually, independently of your project-wide
setting.
PROCEDURE
1.

Select the tuplet brackets whose numbers/ratios you want to hide/change, or the signposts
of tuplets whose numbers/ratios you want to show. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Number in the Tuplets group.

3.

Choose one of the following options:
●

None

●

Number

●

Ratio

●

Ratio+note

RESULT
The tuplet number/ratio shown for the selected tuplets is changed. If you selected None, the
tuplet numbers/ratios for the selected tuplets are hidden. Signposts are shown at the position of
each hidden tuplet, that is, tuplets with no numbers/ratios or brackets shown.
TIP
●

Deactivating Number returns the selected tuplets to the default setting.

●

You can change which tuplet number/ratio appears on all tuplets project-wide in the
Number and Ratio section of the Tuplets page in Engrave > Engraving Options.

AFTER COMPLETING THIS TASK
If you want to hide indications of tuplets entirely, you might also need to hide the tuplet brackets.
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RELATED LINKS
Hiding/Showing tuplet brackets on page 1268
Project-wide engraving options for tuplets on page 1262

Changing the position of tuplet numbers/ratios
You can change the horizontal positions of tuplet numbers and ratios in individual tuplet
brackets, independently of your project-wide setting.
PROCEDURE
1.

Select the tuplet brackets whose tuplet number/ratio positions you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Center in the Tuplets group.

3.

Choose one of the following options:
●

Visual

●

Rhythmic

RESULT
●

Visual positions tuplet numbers/ratios at the visual center of the tuplet beam or tuplet
bracket.

●

Rhythmic positions tuplet numbers/ratios at the rhythmic center of the tuplet beam or
tuplet bracket, which might be visually off-center.

TIP
●

Deactivating the property returns tuplets to your project-wide setting.

●

You can change the horizontal position of tuplet numbers/ratios on all tuplets project-wide in
the Number and Ratio section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Tuplet brackets on page 1267
Changing the angles of tuplet brackets on page 1269

Changing the font used for tuplet numbers/ratios
By default, tuplet numbers/ratios are drawn in a bold, italic, Arabic font that is similar in
appearance to fingerings. You can change the font used for all tuplet numbers/ratios projectwide. This also affects the appearance of note value indications.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-E to open Engraving Options.

2.

Click Tuplets in the page list.

3.

In the Number and Ratio section, choose one of the following options for Tuplet digit
style:

4.

●

Bold weight

●

Regular weight

●

Plain font

Click Apply, then Close.
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RESULT
The font used for tuplet numbers/ratios project-wide is changed.
●

Bold weight and Regular weight are both based on the Tuplet Font style, which must be
SMuFL-compliant.

●

Plain font uses the Tuplet Plain Font style, which can be any text font.

TIP
You can edit different aspects of the Tuplet Plain Font style, such as its font size, in the Edit Font
Styles dialog.

RELATED LINKS
Edit Font Styles dialog on page 407
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The term “unpitched percussion” covers all percussion instruments that are not tuned to specific
pitches. This includes instruments such as bass drum, guiro, maracas, cymbals, and shakers.
Dorico Pro provides comprehensive support for unpitched percussion notation, with flexible
options for combining music for multiple instruments into percussion kits that can then be
displayed differently in different layouts. You can also define percussion kits as drum sets, which
changes the default stem directions of notes.
The different percussion kit presentation types in Dorico Pro are layout-specific, meaning you can
present percussion kits in different ways in different layouts. For example, you could present a
percussion kit as a five-line staff in the full score layout but with single-line instruments in the
percussion part layout.
You can also customize and create new playing technique-specific noteheads for unpitched
percussion. This allows you to indicate how notes are played by using different noteheads for
different playing techniques on each instrument in percussion kits.
RELATED LINKS
Percussion kits and drum sets on page 1276
Percussion kit presentation types on page 1281
Staff labels for percussion kits on page 1154
Defining percussion kits as drum sets on page 123
Inputting notes in percussion kits on page 184
Playing techniques for unpitched percussion instruments on page 1283
Showing brackets on noteheads on page 907

Percussion kits vs. individual percussion instruments
Percussion kits allow you to show multiple unpitched percussion instruments held by a single
player at the same time in different ways. Multiple percussion instruments not combined into kits
are shown on a single line that only shows the instrument currently being played by default.
One common type of percussion kit is a drum set. A drum set consists of a number of separate
instruments mounted together on a frame, and is typically written on a regular five-line staff.
Each instrument has its own position on the staff, and sometimes its own notehead type.
Similarly, a pair of bongos is a percussion kit by default in Dorico Pro, consisting of the two
bongo drums, typically written on a grid with two lines: the smaller drum shown on the top line,
and the larger drum shown on the bottom line.
Showing individual percussion instruments separately can be appropriate if a player only has one
or two percussion instruments. However, combining percussion instruments into a kit gives you
more flexibility over the presentation of music, which you can vary in each layout independently.
Kits also give you greater control over the labeling of instruments.
If instrument changes are enabled on the Players page in Setup > Layout Options, Dorico Pro
changes from one instrument to the next, just as it does for pitched instruments.
NOTE
Kit instruments in player cards in the Players panel in Setup mode are colored green, whereas
individual percussion instruments not part of percussion kits are colored the same light blue as
all other instruments.
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Percussion kits and drum sets
A percussion kit is a collection of unpitched percussion instruments that are played by a single
player. Drum sets are a particular type of percussion kit that are often used in pop and rock
music.
NOTE
In this documentation, we use “percussion kit” to refer to both percussion kits and drum sets.
In Dorico Pro, you can present percussion kits in different ways, including as a five-line staff and
as a grid. If you want percussion kits to behave as drum sets, you can define them as drum sets.
There are notation options for voices that only apply to drum sets.
You can create percussion kits in Setup mode. You can combine existing unpitched percussion
instruments into kits and add empty kits to players, to which you can then add unpitched
percussion instruments. You can also import existing kits you have previously exported and
saved.
You can move percussion instruments between players, without affecting any music already
added to that instrument.
NOTE
If the instrument you want to move is combined into a percussion kit, you must first remove the
instrument from the kit before you can move it to another player.
You can change individual percussion instruments like any other instrument. However, you can
only change unpitched percussion instruments to other unpitched percussion instruments, and
you can only change the percussion instruments in kits within the Edit Percussion Kit dialog.
RELATED LINKS
Note input setup for percussion kits on page 185
Percussion kit presentation types on page 1281
Staff labels for percussion kits on page 1154
Edit Percussion Kit dialog on page 120
Combining individual percussion instruments into kits on page 117
Defining percussion kits as drum sets on page 123
Adding instruments to percussion kits on page 122
Removing individual instruments from percussion kits on page 126
Moving instruments on page 119
Inputting notes in percussion kits on page 184

Exporting percussion kits
You can export percussion kits as library files. This allows you to use kits again without having to
create them from scratch.
PROCEDURE
1.

In the Players panel in Setup mode, expand the card of the player whose percussion kit you
want to export.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Click Export Kit at the bottom of the dialog to open the File Explorer/macOS Finder.

4.

In the File Explorer/macOS Finder, specify a name and location for the library file.
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5.

Click Save.

RESULT
The kit is exported and saved as a library file.
TIP
You can later import the library file into other projects to reuse the percussion kit.

Importing percussion kits
You can import library files containing percussion kits, which allows you to use kits again without
having to create them from scratch.
PREREQUISITE
You have added a new solo player in the Players panel in Setup mode.
PROCEDURE
1.

In Setup mode, open the instrument picker for your empty solo player in any of the following
ways:
●

Select the empty player and press Shift-I .

●

Click the plus symbol in the empty player card.

●

Right-click the empty player and choose Add Instrument to Player from the context
menu.

2.

Click Import Kit in the instrument picker to open the File Explorer/macOS Finder.

3.

In the File Explorer/macOS Finder, locate and select the percussion kit library file you want to
import.

4.

Click Open.

RESULT
The selected library file is imported as a percussion kit. It is assigned to the player from whose
card you opened the instrument picker.

Project-wide engraving options for unpitched percussion
You can find options for the project-wide appearance and position of percussion legends and
ghost notes on the Percussion page in Engrave > Engraving Options.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
RELATED LINKS
Engraving Options dialog on page 359
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Per-flow notation options for unpitched percussion
You can find options for how notes in percussion kits are notated in each flow independently on
the Percussion page in Notation Options.
For example, you can choose to notate all notes in a percussion kit in a single voice rather than in
multiple voices.
RELATED LINKS
Notation Options dialog on page 160

Changing the playing techniques of notes on percussion kit
staves
For notes on percussion kit staves that use playing technique-specific noteheads to indicate
different playing techniques, you can change their playing techniques after they have been input
by cycling through the available playing technique-specific noteheads.
NOTE
These steps only apply to changing playing technique-specific noteheads.
PREREQUISITE
The percussion kit instruments whose playing techniques you want to change have at least two
playing technique-specific noteheads defined in the Percussion Instrument Playing
Techniques dialog.
PROCEDURE
1.

In Write mode, select the notes whose playing technique-specific notehead you want to
change.
NOTE
The current playing technique is shown above the rhythmic grid if you select a single note. It
is not shown if you select multiple notes.

2.

Cycle through the available playing techniques for the selected instruments in any of the
following ways:
●

Press Shift-Alt/Opt-Up Arrow to cycle upwards.

●

Press Shift-Alt/Opt-Down Arrow to cycle downwards.

RESULT
The playing techniques of the selected notes are changed. Their notehead design and/or position
might be changed.
RELATED LINKS
Percussion Instrument Playing Techniques dialog on page 1283
Inputting notes in percussion kits on page 184
Defining how combinations of articulations and single-note tremolos sound in playback on page
589
Playing techniques on page 1007
Showing brackets on noteheads on page 907
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Moving notes to different instruments in percussion kits
You can move notes to different instruments in the same percussion kit after they have been
input, except in layouts using the single-line instruments kit presentation type.
In layouts using the single-line instruments kit presentation type, you can instead cross notes to
other staves to create cross-staff beams.
PROCEDURE
1.

In Write mode, select the notes you want to move to a different instrument in the percussion
kit.

2.

Move the notes to another instrument in any of the following ways:
●

Press Alt/Opt-Up Arrow to move them to the instrument above.

●

Press Alt/Opt-Down Arrow to move them to the instrument below.

RESULT
The notes are moved to another instrument in the kit.
AFTER COMPLETING THIS TASK
You can change the position of each instrument in the kit.
RELATED LINKS
Edit Percussion Kit dialog on page 120
Changing the positions of instruments within percussion kits on page 125
Percussion kit presentation types on page 1281
Changing the presentation type of percussion kits on page 1282
Creating cross-staff beams on page 672

Notations on notes in percussion kits
You can add notations to notes and use different rhythms in percussion kits in the same ways as
for normal notes; however, they can behave differently.

Articulations
You can add articulations to percussion instruments in all kit presentation types in the same ways
as for other instruments.
However, in grid and five-line staff presentations, any articulations you add apply to all
instruments in the same voice that have notes at that rhythmic position. For example, if both a
snare drum and tom-tom note are at the same rhythmic position, and you add an accent, the
accent is added to both instruments because they are both shown in the same down-stem voice
by default.
You can see the accent applied to each note if you switch to the single-line instruments
presentation type.

Tuplets
When working in the grid and five-line staff kit presentation types, tuplets are added to all
instruments in the same voice.
You can switch to the single-line instruments presentation type to input cross-rhythms on each
instrument separately. When you switch back to the grid or five-line staff kit presentation types,
Dorico Pro attempts to resolve the rhythmic conflicts.
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●

Conflicting tuplets: One tuplet is moved into an extra voice for the duration of the conflict.

●

Tuplet notes in one instrument and non-tuplet notes in another instrument starting at the
same rhythmic position: The non-tuplet note is displayed as if it were part of the tuplet. This
is because the note onset is at the same position as the start of the tuplet, so it sounds the
same as the original notation.

●

Tuplet notes in one instrument and non-tuplet notes in another instrument that do not start
at the same rhythmic position, or other non-tuplet notes that start part-way through the
tuplet: Non-tuplet notes are moved into an extra voice for the duration of the conflict.
NOTE
Deleting a tuplet from grid and five-line staff kit presentation types deletes the tuplet from
all instruments whose notes contribute to the same shared voice.

Playing techniques
You can input playing techniques, such as + for closed and o for open hi-hat, during note input
and add them later to existing notes in the same ways as for other instruments. You can use the
playing techniques popover or click any of the playing techniques in the Playing Techniques
panel in Write mode.
Playing techniques are only added to the instrument to which the note you select belongs, even
if there are other instruments in the same voice.

Percussion stickings
Dorico Pro does not yet have a dedicated feature for percussion stickings. However, you can use
lyrics to represent percussion stickings in all kit presentation types:
●

Grid/Five-line staff presentation types: Select a note in the instrument in which you want to
show stickings.

●

Single-line instruments presentation type: Input lyrics directly into instruments in which you
want to show stickings.

RELATED LINKS
Inputting articulations on page 210
Inputting tuplets on page 195
Changing the pitch of individual notes on page 200
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277
Inputting lyrics on page 293

Dynamics in percussion kits
Unlike other items, dynamics are not shared between the grid/five-line staff presentation types
and the single-line instruments presentation type. Any dynamics added to instruments in the
single-line instruments presentation type do not appear when you switch to grid/five-line
presentations.
This is due to the complexity of combining a large number of different dynamics at the same
rhythmic position, as allowed in the single-line instruments presentation, into the single position
required for both the grid and five-line staff presentations. Therefore, you can add dynamics in
the grid and five-line staff presentation types independently of the single-line instruments
presentation type.
RELATED LINKS
Input methods for dynamics on page 241
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Percussion kit presentation types
You can show percussion kits in three different presentation types, which can be different in each
layout in your project.
NOTE
Dynamics are not shared between the grid/five-line staff presentation types and the single-line
instruments presentation type. Any dynamics added to instruments in the single-line
instruments presentation type do not appear when you switch to grid/five-line presentations.
You can edit the appearance/structure of each presentation type independently in the Edit
Percussion Kit dialog. For example, changing the order of instruments in the five-line staff
presentation does not affect the order of instruments in the grid presentation of the same
percussion kit.
5-line staff
Kit instruments are shown on a five-line staff. You can determine which instruments
are shown on each line and in each space of the staff. A single staff label containing the
name of the kit is shown.
The numbers down the left-hand side of the editing area in the Edit Percussion Kit
dialog correspond to staff positions. For example, position 0 is the middle line of the
five-line staff, position 1 is the space immediately above the middle staff line, position
-2 is the line below the middle staff line, and so on.
Bold black lines show the five staff lines, while gray lines above and below the staff
show nominal staff line positions. Each instrument is shown on its staff position.

5-line staff presentation

Grid
Kit instruments are shown on a grid, with each instrument on its own line. You can
customize the size of the gaps between each line. Staff labels are shown for each
instrument in a smaller font than normal staff labels.
The numbers down the right-hand side of the editing area in the Edit Percussion Kit
dialog correspond to the number of staff spaces between each instrument line. By
default, all instruments in a grid are two spaces apart.
The order in which the instruments are listed matches the order in which they appear
in the score.
Each instrument in a grid shows its own staff label by default, aligned vertically with its
own line, but you can group adjacent instruments together and show a single label for
each group.

Grid presentation

Single-line instruments
Kit instruments are shown as individual instruments with their own lines. Normal-sized
staff labels are shown for each instrument.
The editing area in the Edit Percussion Kit dialog lists all of the instruments in the
order in which they appear in the score.
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Single-line instruments presentation

Multiple instruments held by the same player are vertically spaced according to the ideal gaps
defined on the Vertical Spacing page in Setup > Layout Options.
RELATED LINKS
Percussion kits and drum sets on page 1276
Edit Percussion Kit dialog on page 120
Staff labels for percussion kits on page 1154
Overriding the appearance of playing technique-specific noteheads on page 1287
Override Percussion Noteheads dialog on page 1285

Changing the presentation type of percussion kits
You can change the presentation type of percussion kits in each layout independently and
independently of each other. For example, you can use a five-line staff in the full score layout but
a grid in the percussion part layout, and have two percussion kits with different presentation
types in the same full score layout.
PROCEDURE
1.

Press Ctrl/Cmd-Shift-L to open Layout Options.

2.

In the Layouts list, select the layouts in which you want to change the percussion kit
presentation type.
By default, the layout currently open in the music area is selected when you open the dialog.
You can select other layouts by using the selection options in the action bar, Shift -clicking
adjacent layouts, and Ctrl/Cmd -clicking individual layouts.

3.

Click Players in the page list.

4.

In the Percussion section, choose one of the following options for each percussion kit in
your project:

5.

●

5-line Staff

●

Grid

●

Single-line Instruments

Click Apply, then Close.

RESULT
The presentation type is changed for the selected percussion kits in the selected layouts.
RELATED LINKS
Percussion kit presentation types on page 1281
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Playing techniques for unpitched percussion instruments
As well as using normal playing techniques on notes in percussion kits, you can use the design
and position of noteheads to indicate different playing techniques for unpitched percussion
instruments and percussion kits.
You can indicate playing techniques for unpitched percussion instruments in any of the following
ways:
●

Use playing technique-specific noteheads

●

Position notes in spaces directly above/below the line on which notes are normally written

●

Add articulations or single-note tremolos

●

Add playing techniques in the same ways as for pitched instruments

For example, you can add open and closed techniques for hi-hats using the playing techniques
popover, or by clicking the playing techniques you want in the Playing Techniques panel.
You can edit the set of playing technique-specific noteheads defined for each percussion
instrument in the Percussion Instrument Playing Techniques dialog.
RELATED LINKS
Edit Percussion Kit dialog on page 120
Defining how combinations of articulations and single-note tremolos sound in playback on page
589
Exporting percussion kits on page 1276
Importing percussion kits on page 1277
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277

Percussion Instrument Playing Techniques dialog
The Percussion Instrument Playing Techniques dialog allows you to edit the set of playing
technique-specific noteheads defined for each percussion instrument.
You can open the Percussion Instrument Playing Techniques dialog in Setup mode in the
following ways:
●

For an individual percussion instrument: In the Players panel, expand the card of the player
holding the instrument, click the arrow in the instrument label, and choose Edit Percussion
Playing Techniques from the menu.

●

For percussion instruments that are part of percussion kits: In the Players panel, click the
arrow in the kit instrument label, and choose Edit Percussion Kit to open the Edit
Percussion Kit dialog, select the instrument whose playing techniques you want to edit in
the main editing area, and click Edit Percussion Playing Techniques.
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Percussion Instrument Playing Techniques dialog

1

List of playing technique-specific noteheads
Contains the main playing technique-specific noteheads currently defined for the selected
percussion instrument, showing the notehead set and the staff position corresponding to
the playing technique as applicable.
You can add new playing technique-specific noteheads for unpitched percussion
instruments. Normally, percussion instruments define at least the Natural playing
technique, which is usually shown using the default notehead set.

2

Playback of Articulations and Tremolos
Allows you to define how combinations of articulations and tremolo strokes affect or
override the playback of playing techniques.
For example, you can define an entirely different playing technique for a playing techniquespecific notehead for when an accent is added to it.

3

Overrides of articulations and tremolos list
Displays any overrides of articulations and tremolos you define.

EXAMPLE

Three different snare drum playing technique-specific noteheads followed by two clash cymbal playing
technique-specific noteheads

All of these settings are saved in the percussion instrument within your project, and you can
export them from one project and import them into others.
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NOTE
Overrides for articulations and tremolos are not currently reflected in playback, but this is
planned for future versions.

RELATED LINKS
Defining how combinations of articulations and single-note tremolos sound in playback on page
589
Exporting percussion kits on page 1276
Importing percussion kits on page 1277

Override Percussion Noteheads dialog
The Override Percussion Noteheads dialog lists the playing technique-specific noteheads
defined for the selected instrument in the Percussion Instrument Playing Techniques dialog,
shows the notehead type mapped for each technique, and allows you to override those
noteheads for five-line staff kit presentations only.
For example, the same notehead can indicate different playing techniques for different
instruments. When those instruments are presented on the same five-line staff, this can cause
confusion, so you can use the Override Percussion Noteheads dialog to disambiguate the
notes for one instrument from another in five-line staff kit presentations only.
●

You can open the Override Percussion Noteheads dialog by selecting an instrument in the
Edit Percussion Kit dialog and clicking Edit Noteheads.

Override Percussion Noteheads dialog for a snare drum

The Override Percussion Noteheads dialog comprises the following:
1

Instrument name
Displays the name of the percussion instrument whose noteheads are listed in the dialog.

2

Playing techniques table
Contains the noteheads for the selected percussion instrument, arranged into the following
columns:
●

Playing Technique: Displays the playing technique associated with the notehead in the
corresponding row of the table.

●

Default Notehead: Displays the notehead used by default for the playing technique in
the corresponding row of the table.
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●

Notehead Override: Displays the notehead override used in five-line staff presentations
for the playing technique in the corresponding row of the table. You can change the
notehead override by clicking it and selecting another notehead from the menu.

RELATED LINKS
Percussion kit presentation types on page 1281

Creating new playing technique-specific noteheads for unpitched
percussion instruments
You can define new playing technique-specific noteheads for unpitched percussion instruments
individually, which are saved for that type of percussion instrument in your project. You can also
export playing technique-specific noteheads from your project and import them into other
projects.
PROCEDURE
1.

In Setup mode, open the Percussion Instrument Playing Techniques dialog in one of the
following ways:
●

For an individual percussion instrument: In the Players panel, expand the card of the
player holding the instrument, click the arrow in the instrument label, and choose Edit
Percussion Playing Techniques from the menu.

●

For percussion instruments that are part of percussion kits: In the Players panel, click
the arrow in the kit instrument label, and choose Edit Percussion Kit to open the Edit
Percussion Kit dialog, select the instrument whose playing techniques you want to edit
in the main editing area, and click Edit Percussion Playing Techniques.

2.

Click Add Playing Technique.

3.

Select the playing technique you want to create in the dialog that opens.

4.

Click OK to add the selected playing technique to the list of playing technique-specific
noteheads.

5.

Select the notehead you want for the playing technique from the Notehead set menu.
NOTE
Leave Notehead set as (Unset) to use the default notehead set as defined on the Notes
page in Engrave > Engraving Options.

6.

Choose one of the following options for Staff position:
●

Below

●

Line

●

Above

RESULT
A new playing technique-specific notehead is added to the selected unpitched percussion
instrument.
RELATED LINKS
Input methods for playing techniques, pedal lines, string indicators, and harp pedal diagrams on
page 277
Defining how combinations of articulations and single-note tremolos sound in playback on page
589
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Overriding the appearance of playing technique-specific noteheads
It might be necessary to override the appearance of playing technique-specific noteheads in
order to disambiguate the notes for one instrument from another if they share a staff position in
five-line staff kit presentations.
PROCEDURE
1.

In the Players panel in Setup mode, expand the card of the player holding the kit whose
playing technique-specific noteheads you want to override.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

Select the instrument whose noteheads you want to override in the main editing area of the
dialog.

4.

Click Edit Noteheads to open the Override Percussion Noteheads dialog.

5.

Click in the Notehead Override column for the appropriate playing technique and select a
new notehead type from the menu to override its notehead.

6.

Click OK to save your changes and close the dialog.

RESULT
The playing technique-specific notehead is overridden for the selected instrument in five-line
staff kit presentations.
NOTE
This does not affect the appearance of playing technique-specific noteheads in grid and singleline instrument kit presentation types.

RELATED LINKS
Override Percussion Noteheads dialog on page 1285

Percussion legends
Percussion legends list the percussion instruments in use when using the five-line presentation
type. Percussion legends can include all instruments that are represented on the staff, or only
show sounding instruments in a set range to remind players which instruments to play at certain
points.
You can change the default position of percussion legends in the Percussion Legends section of
the Percussion page in Engrave > Engraving Options.
By default, percussion legends appear above the staff. You can change the placement and
appearance of percussion legends individually using properties in the Percussion Legends
group of the Properties panel.
You can change various aspects of the paragraph style for percussion legends, such as the font
size and style, in the Paragraph Styles dialog.
Percussion legends appear as signposts if there are no instruments sounding at their position, or
in layouts using the grid presentation type. Percussion legends do not appear at all in layouts
using the single-line instrument presentation type.
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TIP
You can hide/show percussion legend signposts by choosing View > Signposts > Percussion
Legends. Percussion legend signposts are shown when a tick is shown beside Percussion
Legends in the menu, and hidden when no tick is shown.

RELATED LINKS
Paragraph Styles dialog on page 410
Project-wide engraving options for unpitched percussion on page 1277
Per-flow notation options for unpitched percussion on page 1278
Staff labels for percussion kits on page 1154

Adding percussion legends to five-line staff kit presentations
You can add percussion legends at specific rhythmic positions to indicate the instruments in the
kit. Percussion legends can show all instruments in the kit or only instruments sounding within
the specified range.
NOTE
Percussion legends only appear when kits use the five-line staff percussion kit presentation type.

PROCEDURE
1.

2.

In Write mode, select one of the following:
●

An item on the staff at the rhythmic position where you want to add a percussion legend
for all instruments.

●

The range of notes/items for which you want to show a percussion legend for sounding
instruments.

Add a percussion legend in one of the following ways:
●

Choose Edit > Percussion > Legend for All Instruments.

●

Choose Edit > Percussion > Legend for Sounding Instruments.

TIP
You can also choose these options from the context menu.

RESULT
A percussion legend is added to the kit. It appears above the staff in layouts where the kit uses
the five-line staff presentation. It lists instruments, either all instruments or just instruments with
notes within the selected range, in the order in which they appear in the five-line staff, from
highest down to lowest.

Changing the sounding instrument percussion legend range
You can change the rhythmic range of sounding instrument percussion legends to include more/
fewer instruments in the legend, as they only show the instruments playing at the rhythmic
positions included in the range.
PROCEDURE
1.

In Write mode, select the sounding instrument percussion legend whose range you want to
change.
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2.

Change the range in any of the following ways, according to the current rhythmic grid
resolution:
●

To move the whole range to the right, press Alt/Opt-Right Arrow .

●

To move the whole range to the left, press Alt/Opt-Left Arrow .

●

To lengthen the range, press Shift-Alt/Opt-Right Arrow .

●

To shorten the range, press Shift-Alt/Opt-Left Arrow .
NOTE
Key commands lengthen/shorten items by moving their end only.

●

Click and drag the circular handle at the start/end to the right/left.

RESULT
The rhythmic range covered by the selected sounding instrument percussion legend is changed
according to the current rhythmic grid resolution.
The instruments included in the percussion legend are automatically updated to reflect the
instruments playing within the range.

Changing the percussion legend type
You can change the type of percussion legends so they show all instruments or only sounding
instruments in five-line staff presentations.
PROCEDURE
1.

Select the percussion legends whose type you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Legend type in the Percussion Legends group.
NOTE
The property is already activated for sounding instrument percussion legends.

3.

Choose one of the following options:
●

Legend

●

Sounding instruments

RESULT
The legend type of the selected legends is changed.

Showing short instrument names in percussion legends
Percussion legends use full instrument names by default, but you can choose to use short names
to save space.
PROCEDURE
1.

Select the percussion legends whose instrument name lengths you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Use short names in the Percussion Legends group.

RESULT
Short instrument names are shown in the selected percussion legends.
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Deactivating Use short names returns the selected percussion legends to showing full
instrument names.
RELATED LINKS
Staff labels for percussion kits on page 1154

Editing percussion legend text
By default, percussion legends show the instrument names of percussion instruments in five-line
staff presentations, stacked vertically. You can change the text shown in percussion legends to
show custom text.
PROCEDURE
1.

In Engrave mode, select the percussion legends you want to edit.

2.

In the Properties panel, activate Custom text in the Percussion Legends group.

3.

Enter the text you want into the value field.

4.

Press Return .

RESULT
The text shown in the selected percussion legends is changed.

Voices in percussion kits
Dorico Pro automatically combines music into a smaller number of voices when multiple
percussion instruments are presented in a five-line staff or as a grid, even if they contain
different rhythms. By default, music is combined into one up-stem voice and one down-stem
voice.
Alternatively, you can choose to notate all notes in a percussion kit in a single voice when the kit
is defined as a drum set on the Percussion page in Write > Notation Options. This convention is
used less frequently for orchestral percussion.
You can also override this option for individual percussion kits, and for individual notes in
percussion kits.
Notes in the same voice cannot be notated using different durations and are notated using ties
by default instead. You can eliminate the use of ties by choosing to truncate longer notes so that
only their onsets appear on the Percussion page in Notation Options.
If one of the instruments in a percussion kit has a tuplet rhythm, other instruments can share the
voice if their notation is compatible, such as if the tuplet structure is the same, or if they have a
single note that coincides with the start of the tuplet. In this case, the single non-tuplet note is
notated as the same duration of the first note of the tuplet.
If the music of the different instruments in the same voice is incompatible, Dorico Pro
dynamically creates another voice and notates the remaining music in that voice until the music
is compatible again.
RELATED LINKS
Notations on notes in percussion kits on page 1279
Defining percussion kits as drum sets on page 123
Adding slash voices to percussion kits on page 1300
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Changing the voice of individual notes in percussion kits
You can override the default voice for individual notes in percussion kits, including drum sets.
PROCEDURE
1.

Select the notes whose voice you want to override. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Percussion > Change Voice > [Voice].
For example, to change notes to the second down-stem voice, choose Edit > Percussion >
Change Voice > Down-stem Voice 2. You can also choose this option from the context
menu.

RESULT
The voice of the selected notes is changed, independently of the default voice for their
instrument and independently of your setting for voices in drum sets.
TIP
You can reset the voice of individual notes by selecting them and choosing Edit > Percussion >
Change Voice > Reset Note Destination Voice. You can also choose this option from the
context menu.

Specifying the stem direction/voice of instruments in percussion kits
You can specify the stem direction for each instrument in individual percussion kits. You can also
set which voice they are in, allowing you to control which instruments share voices in percussion
kits.
PROCEDURE
1.

In the Players panel in Setup mode, expand the card of the player holding the kit whose
instrument stem directions and voices you want to specify.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

In the dialog, select an instrument whose stem direction and voice you want to specify.

4.

Choose one of the following stem directions for Stem direction and voice:

5.

●

Up-stem

●

Down-stem

Specify a voice by changing the value for Stem direction and voice.
NOTE
You do not have to change the voice number if you are switching between up- and downstem voices as the number corresponds to the voice number for each stem direction.

6.

Click Apply, then Close.

RESULT
The default stem direction and voice of the selected instrument is changed.

1291
Dorico Pro 3.1.10

Unpitched percussion
Unpitched percussion in Play mode

Unpitched percussion in Play mode
Unpitched percussion instruments are handled differently in Play mode than pitched
instruments. Instead of showing the usual piano roll view, the onset of each note on each
percussion instrument is shown in the drum editor.
You can expand each instrument in a kit at the left end of the track header in order to assign that
particular instrument to another playback endpoint. For example, you can assign instruments to
another channel on the same VST instrument or MIDI output device, or to a different device.
NOTE
The endpoint must have an appropriate selected percussion map.
Notes can be moved in Play mode by dragging them to the rhythmic position you want. However,
like other instruments, you cannot move notes between percussion instruments, even if they are
in the same percussion kit.
NOTE
You cannot change the duration of unpitched percussion notes within Play mode. This is planned
for future versions.

RELATED LINKS
Percussion maps on page 583
Drum editor on page 505
Inputting notes in the event display on page 505
Moving notes in the event display on page 506

Unpitched percussion imported from MIDI files
When importing MIDI files, Dorico Pro optionally interprets music for tracks set to use channel 10
as drum sets if Interpret channel 10 as General MIDI percussion is activated in the MIDI
Import Options dialog.
NOTE
The MIDI Import Options dialog opens automatically when you open MIDI files in Dorico Pro.
This is the only condition under which Dorico Pro interprets any music in MIDI files as percussion.

Unpitched percussion imported from MusicXML files
Unpitched percussion music can be expressed in a number of ways in MusicXML. Scoring
applications take different approaches to what data is exported and how it is encoded. Therefore,
the results of importing MusicXML into Dorico Pro vary considerably.
Dorico Pro identifies each instrument in kits explicitly and then combines them dynamically onto
five-line staves. Other scoring applications and MusicXML have a different approach to how
unpitched percussion music is represented. For example, a drum set may be effectively notated
as pitched notes on a five-line staff and annotated with additional information to help identify
which instrument corresponds to each staff position.
Because of these different approaches, mapping information between the MusicXML
representation and the Dorico Pro representation can be challenging, so Dorico Pro employs
heuristics to improve the quality of results.
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Typically, drum set instruments in MusicXML files exported from both Sibelius and Finale are
imported quite cleanly into Dorico Pro.
Results are particularly good, and more likely to be imported correctly, if the voicing of the drum
set is consistent, such as consistently notating the snare drum in a down-stem voice. If the
voicing changes from bar to bar, it is possible that some notes are either identified correctly or
not imported at all.
Other kinds of percussion that are notated on five-line staves produce more variable results. In
most cases, Finale includes information about which percussion instrument maps onto each staff
position, but Sibelius does not. As a result, you might find that Dorico Pro chooses different
instruments than you expected, but you can change instruments using the Edit Percussion Kit
dialog.
RELATED LINKS
Edit Percussion Kit dialog on page 120
Changing instruments in percussion kits on page 122
Adding instruments to percussion kits on page 122

Universal Indian Drum Notation
Dorico Pro supports the Universal Indian Drum Notation system developed by Keda Music Ltd.
Universal Indian Drum Notation has been designed primarily for tabla, but can also be applied to
other Indian drums with two heads, such as nagara, dhol, dholak, mridangam, and pakhawaj.
An Indian drum clef is automatically added to the staff when you add tabla instruments to
players.

You can input Indian drum clefs by clicking Indian drum clef in the Uncommon Clefs section of
the Clefs panel.
RELATED LINKS
Adding instruments to players on page 116
Input methods for clefs and octave lines on page 254
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For many instruments, such as flute or trombone, each staff usually contains a single musical line
in a single voice that is read from left to right along the staff. When multiple, independent lines
must be shown in a single staff, each line can be a separate voice.
The most common use for showing multiple voices in a single staff is in vocal music, when the
soprano and alto lines share a single staff and the tenor and bass lines share another staff.
Showing each vocal line in its own voice helps to separate the lines, making the music easier to
read and making the shape of each melodic line clear.
In Dorico Pro, you can create as many voices as you like on each staff. Each voice has its own
color, which you can see if you show voice colors. This can help you to keep track of which notes
are in which voices if there are multiple overlapping musical lines in your project.
Voices in Dorico Pro are divided into up-stem voices and down-stem voices. Stems of notes in upstem voices point upwards, while stems of notes in down-stem voices point downwards.
However, in bars where only one voice contains notes, stem directions are automatically changed
to the directions they would have if there were only one voice on the staff. By default, the first
voice on the staff is up-stem.
Following most notation conventions, rests are shown in bars for all voices that have notes in the
bar. If two or more voices have a rest of the same rhythmic duration at the same rhythmic
position, that rest is consolidated: instead of showing two identical rests, only one is shown.
RELATED LINKS
Inputting notes into multiple voices on page 179
Hiding/Showing voice colors on page 1295
Per-flow notation options for voices on page 1295
Per-flow notation options for rests on page 1109
Adding notes above/below existing notes on page 198
Stem direction on page 1196
Implicit rests in multiple-voice contexts on page 1108
Moving rests vertically on page 1116

Note positions in multiple-voice contexts
Notes are usually placed directly above each other and at the same horizontal position, so that it
is immediately clear which notes are played together. However, the horizontal alignment of
notes can be different in multiple-voice contexts.
When there are three or more voices in a single staff, some notes must be positioned slightly to
one side in a different voice column to ensure the division of notes across the voices is clear.
Interlocking notes in different voices can be positioned in two ways:
1.

Notehead to notehead, which allows noteheads to overlap partially. This voice order often
takes up less horizontal space than positioning notes stem to stem, as notes can overlap.
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2.

Stem to stem, which does not allow noteheads to overlap. This voice order keeps notes in
different voices separate.

You can choose how interlocking notes in different voices are positioned project-wide on the
Voices page in Write > Notation Options.
Dorico Pro positions notes by default with the noteheads partially overlapping, in order to
minimize the horizontal space they occupy and to maintain the clarity of the rhythm.
The order and position of notes in different voices is also automatically adjusted so that each
rhythmic position uses as little horizontal space as possible, while remaining clear and legible.
The voice column for some voices automatically changes as more voices are added, as Dorico Pro
prefers showing voices with the widest pitch range between them on the left of the rhythmic
position and voices with narrower pitch ranges to the right, as this produces the most balanced
result, especially when there are multiple accidentals.

One voice

Two voices vertically Three voices all still
aligned
vertically aligned

Four voices with
two voice columns

Five voices with two
voice columns

RELATED LINKS
Slashes in multiple-voice contexts on page 1097
Stem direction on page 1196
Implicit rests in multiple-voice contexts on page 1108

Per-flow notation options for voices
You can find options controlling how notes in multiple voices are positioned in each flow
independently on the Voices page in Write > Notation Options.
The options on this page allow you to change the position and order of notes in multiple-voice
contexts, and choose when noteheads in different voices can overlap.
Musical examples demonstrate how each option affects the appearance of your music.
RELATED LINKS
Notation Options dialog on page 160
Per-flow notation options for rests on page 1109

Hiding/Showing voice colors
You can show notes in different colors according to their voice, for example, to check which notes
are in which voice. When voice colors are hidden, all notes appear black by default.
Voice colors are randomly assigned, meaning colors do not refer to specific voices. Voice colors
are considered annotations and are not printed by default.
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PROCEDURE
●

Choose View > Note And Rest Colors > Voice Colors.

RESULT
Voice colors are shown when a tick appears beside Voice Colors in the menu, and hidden when
no tick appears.
TIP
You can also identify voices by selecting individual notes and looking at the display in the status
bar.
EXAMPLE

Voice colors shown

AFTER COMPLETING THIS TASK
If showing voice colors reveals some notes are not in the voice you want, you can change their
voice.
RELATED LINKS
Changing the voice of existing notes on page 341
Swapping the contents of voices on page 342
Stem direction on page 1196
Annotations on page 610
Status bar on page 52

Unused voices
An unused voice is one that contains no notes anywhere in the project. Any unused voices are
automatically deleted when you close a project, but you cannot manually delete voices once they
have been created. You can create as many voices as you want in each staff.
NOTE
Deleting all notes in a voice does not delete the voice immediately.
If you later want to input notes in a voice that was automatically deleted when you last closed the
project, you can create a new voice at any rhythmic position.
RELATED LINKS
Inputting notes into multiple voices on page 179
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Swapping the order of voices
Dorico Pro automatically positions notes with the noteheads partially overlapping, in order to
minimize the horizontal space they occupy and maintain the clarity of the rhythm. You can
manually swap the order in which opposing voices are positioned horizontally.
PROCEDURE
1.

Select the notes whose order you want to change. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Voices > Swap Voice Order. You can also choose this option from the context
menu.

RESULT
The voice order of the selected notes is changed.
NOTE
If you want to revert the selected notes to their default voice order for the current flow, we
recommend that you deactivate Voice column index in the Notes and Rests group of the
Properties panel, which is available in Engrave mode and is activated automatically when you
swap the order of voices. If you simply swap the contents of these notes again, their positions
might not appear as expected.
EXAMPLE

Interlocking notes in opposing voices positioned
notehead to notehead.

Interlocking notes in opposing voices positioned
stem to stem.

RELATED LINKS
Stem direction on page 1196
Implicit rests in multiple-voice contexts on page 1108

Voice column index
The voice column index is used to determine the positions of notes when multiple columns are
needed, for example, when notes are in multiple voices and cannot be placed directly above each
other vertically, and instead must partially overlap.
The Voice column index property in the Notes and Rests group of the Properties panel is
automatically activated when you swap the order of voices manually.
NOTE
This property is available in Engrave mode only.
You can activate this property to change the index number, and therefore the horizontal order,
of individually selected notes. Deactivating the property returns the selected notes to their
default position.
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TIP
●

You can change the order of notes in multiple voices project-wide on the Voices page in
Write > Notation Options.

●

You can also change the minimum gaps between notes in different voices in the Voices
section of the Notes page in Engrave > Engraving Options.

You can move notes graphically in Engrave mode. You can move notes individually and
independently of all other items at that rhythmic position, or move everything at the same
rhythmic position.
RELATED LINKS
Per-flow notation options for voices on page 1295
Engraving Options dialog on page 359

Notes crossed to staves with existing notes in other voices
When you create cross-staff beams by crossing notes to staves that already contain notes, the
stem direction of the existing notes may change. This is due to how multiple voices at the same
rhythmic position are handled in Dorico Pro.
For example, if a piano part contains notes in up-stem voices on both staves, the stem direction
of notes in both voices can change if notes from the upper staff are crossed to the lower staff. In
this situation, the notes from the two staves are not combined, but are instead treated as two upstem voices in a multiple-voice context.

Two piano staves, each with notes in a single upstem voice.

When the notes in the upper staff are crossed to the
lower staff, the stem direction of the notes already in
the lower staff changes so they point upwards.

You can change the stem direction of the notes originally in the lower staff in any of the following
ways:
●

Select the notes originally in the lower staff and change their voice to another voice, such as
a down-stem voice.

●

Select the notes originally in the lower staff and change their stem direction.

Alternatively, you can move the notes in the upper staff permanently to the lower staff.
RELATED LINKS
Moving notes to other staves on page 339
Changing the voice of existing notes on page 341
Creating cross-staff beams on page 672
Changing the stem direction of notes on page 1199
Stem direction on page 1196
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Slash voices
Slash voices allow you to notate specific rhythms for rhythm slashes. They behave similarly to
normal voices as you must input notes and rhythms manually, but all notes in slash voices are
positioned by default on the middle line of the staff, regardless of the pitches you input.
If you later change the time signature, such as from 3/4 to 6/8, Dorico Pro only changes the note
grouping to fit the meter just like for other notes; it does not change the presentation of rhythm
in slash voices like it does for slash regions.
NOTE
●

Because you can change notes in slash voices to normal voices and vice versa, the pitches
you input are retained.

●

Notes in slash voices are not played back.

You can have multiple slash voices active at the same time. To accommodate all slash voices in
multiple-voice contexts, Dorico Pro changes their staff position automatically. However, you can
also change the staff position of rhythm slashes manually.
You can use slash regions and slash voices in the same project and at the same rhythmic
positions, for example, you can input a slash region where you do not want to be specific about
the rhythm, then input notes in a slash voice for a single bar where you want to specify an exact
rhythm.
RELATED LINKS
Rhythm slashes on page 1095
Slash regions on page 1095
Slashes in multiple-voice contexts on page 1097
Changing the voice of existing notes on page 341
Changing the staff position of rhythm slashes on page 1098
Copying and pasting notes into different voices on page 338

Changing the slash voice type
You can change the voice type of slash voices, for example, if you want to change a slash voice
from having stems to being stemless. You can also change the type to normal notes, which
restores the original pitches you input, and change normal notes to rhythm slashes.
NOTE
This affects all notes in the same voice. If you only want to change the slash voice type of some
notes, you must change the voice of those notes instead.

PROCEDURE
1.

Select a note in the voice whose slash type you want to change. You can do this in Write
mode and Engrave mode.

2.

Choose Edit > Voices > Rhythmic Slashes > [Voice type].
For example, to change a whole normal voice to a stemless slash voice, choose Edit >
Voices > Rhythmic Slashes > Slashes without Stems.
TIP
You can also choose these options from the context menu.
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RESULT
The slash voice type of all notes in the same voice and flow as the selected note is changed.
If you change normal notes to a slash voice, they are all automatically positioned on a single staff
line. By default in single-voice contexts, this is the middle line of the staff.
If you change rhythm slashes to normal notes, their original pitches are restored, meaning their
staff positions reflect their pitches.
RELATED LINKS
Changing the voice of existing notes on page 341

Adding slash voices to percussion kits
You can add slash voices to percussion kits, for example, to show the desired rhythm for a
passage without specifying the instruments to be played. You can add multiple slash voices to
the same kit, including slash voices with and without stems.
NOTE
Rhythm slashes in percussion kits only appear when the five-line staff presentation is used. They
do not appear in grid or single-line instrument presentations.

PROCEDURE
1.

In the Players panel in Setup mode, expand the card of the player holding the percussion kit
to which you want to add slash voices.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3.

In the action bar below the five-line staff editor, click the button that corresponds to the type
of slash voice you want to add.

4.

●

Slashes with stems

●

Slashes without stems

Optional: Repeat step 3 as many times as required for the number of slash voices you want
to add.

RESULT
The slash voices are added to the kit. They are positioned on the middle line of the staff by
default.
In note input, you can move the caret to slash voices just like moving it to other instruments in
the kit, and input notes into slash voices just like inputting notes in percussion kit instruments.
AFTER COMPLETING THIS TASK
You can change the staff position of the slash voices you added to the kit.
RELATED LINKS
Percussion kit presentation types on page 1281
Voices in percussion kits on page 1290
Edit Percussion Kit dialog on page 120
Inputting notes in percussion kits on page 184
Changing the positions of instruments within percussion kits on page 125
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A
action
The mechanism inside pianos that allows the hammers to strike the strings with different forces,
depending on the strength with which the player depresses the corresponding key. It allows
pianos to use a greater dynamic range, hence their full name “pianoforte”.
anacrusis
See pick-up bar.
articulation
(1) In music notation, symbols that indicate how a note should be played, typically affecting their
onset (attack), release, or duration. (2) In sound libraries, a term that refers to playing techniques
generally.
attachment
The rhythmic position at which an item occurs, or to which an item applies, in the music. In
Engrave mode in Dorico Pro, an attachment line is shown between a selected item and its
rhythmic position.

B
bar
A span of music comprising a specific number of beats, as defined by the prevailing time
signature, whose boundaries are indicated by bar lines. Also known as a “measure”, but this
documentation uses “bar”.

C
cancellation natural
A natural accidental positioned on the staff immediately before a change in key signature or a
single note. It indicates that the previous accidental no longer applies and can be followed
immediately by a new accidental if applicable. Showing cancellation naturals before single
accidentals that follow double accidentals is also known as “archaic cancellation”. Cancellation
naturals before a change in key signature are known as “traditional” when positioned after the
barline and “Russian” when positioned before the barline.
caret
Shown during note input, the caret is the vertical line that extends above and below the staff and
indicates the rhythmic position at which items are input. Also known as an “insertion point”. In
Dorico Pro, the caret, cursor, and pointer are related but serve different purposes. See also
rhythmic grid, note input.
casting off
The act of fixing the layout of pages of music, such as defining a set number of systems per page
or the number of bars per system.
cautionary accidental
A restatement of an earlier accidental to eliminate ambiguities, such as when a tied note with an
accidental continues onto another page. Also known as “courtesy accidentals”.
channel
In MIDI, a channel determines which note, controller, or other data is played by which sound on
which device. In Dorico Pro, notes on a single staff may be played by different channels,
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depending on which playing techniques are provided by the patch assigned to each channel. See
also MIDI, patch.
chord
Two or more notes of the same duration that start at the same rhythmic position and share a
stem.
chord input
A variation of note input where notes are stacked on top of each other to create chords rather
than being input after the previous note in sequence. Notes are input at the caret position, which
does not advance automatically. See also caret, note input.
collision avoidance
Automatic adjustments made by Dorico Pro to ensure multiple items at the same position do not
overlap and that all remain clearly legible. Includes changing the shape of items, such as slurs,
and changing the vertical and/or horizontal position of items, such as accidentals in chords.
column
A vertical line representing the same horizontal position across all staves in the system. Used to
determine the position of notes and chords for the purposes of spacing music accurately.
Multiple columns can be used for the same rhythmic position to accommodate multiple voices,
with notes or chords in some voices being offset horizontally from notes or chords in other
voices.
concert pitch
All notes are written as they sound. Full scores are often notated in concert pitch, so that
harmonies and themes are easier to identify. Also known as “sounding pitch”. See also
transposed pitch, instrument transposition.
condensing
The process of showing the music for multiple players on fewer staves than is normal, usually by
allowing multiple instruments of the same type to share a staff, such as Flutes 1-2 or Horns 1-4.
Most commonly used for large orchestral scores, as when there are fewer staves on a page it is
possible to use a larger staff size, which is easier for conductors to read. See also divisi, pitch
crossing.
constant point
A change in value in a track or lane in Play mode that sets a fixed value until the next point in the
track or lane. See also linear point, value line.
context menu
A menu that you can access by right-clicking on a mouse or double-tapping on a touchpad. Its
options vary by the location of the mouse pointer when you access it, but it most commonly
contains options also found on the Edit menu.
cursor
The vertical blinking line that appears when entering or editing text. See also caret.

D
dead note
A note played on a fretted instrument whose sound is muted to produce a sound that is more
percussive than pitched. Usually produced by gently resting one hand on the string. Also known
as a “muted”, “muffled”, “ghost”, or “silenced” note. In Dorico Pro, only notes belonging to fretted
instruments, such as the guitar or banjo, can be dead notes.
disclosure arrow
A small arrow that is shown on all edges of the main window in Dorico Pro. It allows you to hide/
show the toolbar and panels individually.
divisi
Italian for “divide” or “divided”, divisi is when players split in order to play multiple lines of music.
This commonly involves a section, such as Violin I, dividing and using two staves rather than one
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for a limited passage. Divisi passages can be notated all on the same staff, using multiple voices
if required, or across multiple staves. See also tutti, condensing.
drum set
A particular type of percussion kit that is often used in pop and rock music. Drum sets often use a
different arrangement of voices than percussion kits. In this documentation, references to
“percussion kits” also apply to drum sets, as drum sets are a type of percussion kit.

E
EDO
An abbreviation for Equal Division of the Octave, it is a unit used to describe how an octave can
be divided into equal parts, often for the purpose of defining a microtonal scale or tonality
system. Traditional Western European music uses 12-EDO, that is, each octave is divided into 12
equal semitones or half-steps. Music that uses equal quarter tones uses 24-EDO.
endpoint
The unique combination of inputs and outputs that together allow the correct sounds to be
played for each instrument.
Engrave mode
A mode in Dorico Pro where you can manipulate and modify every item in your project, but
without deleting them, moving them rhythmically, or changing the pitch of notes. You can also
determine how the pages in each layout of your project are formatted for printing or exporting.
See also modes.
engraving options
Options that affect the graphical appearance of the notation, including choice of symbols, line
thicknesses, and distances. These options apply to the whole project, including all flows and
layouts, and can be set in the Engraving Options dialog.
enharmonic equivalent
An alternative spelling of a note that uses a different scale degree and accidental but produces
the same sounding pitch, such as G♯ and A♭.
ensemble
A predefined collection of players, each holding instruments that are often used together, such
as string quartet, wind quintet, brass quintet, string ensemble, and double woodwinds.
envelope
A change in sound over time that comprises multiple stages, such as attack, sustain, and decay.
In dynamics lanes in Play mode, envelopes are represented by multiple separate points, each
controlling a different parameter of the overall envelope. See also constant point, linear point,
value line.
explicit rest
A rest that was deliberately input during rest input or imported from a MusicXML file. Explicit
rests cannot be suppressed between notes in a particular voice. See also implicit rest.
exploding
The process of assigning music to more instruments than it was written for originally. Exploding
music is often a key step in arranging and orchestrating music, such as when a piano piece is
arranged for string quartet. See also reducing.

F
family
Instruments of a similar kind that are typically bracketed together in a score, such as woodwind,
brass, percussion, and strings.
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fermata
A notation that indicates all notes at that position are held for longer than their notated length. It
is most commonly shown as a curved line with a dot under the curve, but it can also be shown
with a pointed arch or square shape. Also known as a “pause” or a “birds’ eye”.
flow
A self-contained span of music of any scope, such as a movement in a symphony, a song in an
album, a number in a musical, or a short exercise in a music theory worksheet. A flow can
contain the same players as other flows in the project or separate players just for that flow. See
also player.
formatting
The act of determining the number of bars in a system, the number of systems on a page, and
the distances between staves and systems.
fps
A unit of measurement, short for “frames per second”, that refers to the number of video frames
occurring each second.
fragment
Part of a notation item. For example, fragments of a note include its notehead, rhythm dots,
accidentals, the tip of its stem, and beam. In Write mode, selecting any part of an item also
selects all of its fragments, so any changes you make affect the whole item. In Engrave mode,
you can select each fragment individually to tweak its position or appearance. See also item,
segment.
frame
A rectangular container for music, text, or graphics on a page.
fretted instrument
A type of instrument that in most cases has multiple strings, a neck with marked frets, and is
played by stopping the strings at fret positions on the neck with one hand, usually the left, and
plucking the corresponding strings with the other hand, usually the right. Common fretted
instruments include the guitar, ukulele, and banjo.
full score
A score comprising all of the music for all of the players and their instruments, typically laid out
in a specific order. The order used varies according to the ensemble for which the music is
written. In full scores for orchestra, the players are typically ordered from the highest wind
instrument at the top of the page, for example, piccolo, to the lowest string instrument at the
bottom of the page, for example, contrabass, with brass, keyboards, voices, and percussion in
between.

G
galley view
A viewing option that shows music laid out as a single, infinitely wide system.
grace note
A small note, often used to show an ornament or embellishment, that is not counted towards the
number of beats in the bar; instead, it steals from the duration of either the preceding or the
following rhythmic notes. Also known as an “arhythmic note”. In common practice, a grace note
with a slashed stem is an acciaccatura, which is to be played as quickly as possible, either
immediately before or at the rhythmic position of the note or chord that follows it. A grace note
with an unslashed stem is an appoggiatura, which is played as half of the written duration of the
note or chord that follows it.
group
A collection of players that comprises either a subset of the main ensemble, for example, a choir
within an orchestra, or a separate group, for example, an off-stage brass group or second
orchestra. Each group of players is labeled separately in the full score and is grouped and
numbered together in the instrument order. See also player.

1304
Dorico Pro 3.1.10

Glossary

H
hairpin
A notation for dynamics that uses a pair of angled lines, diverging from or converging on a single
point, to show a gradual increase or reduction in the dynamic level, that is, a crescendo or
diminuendo.
half-bar
The rhythmic position that divides bars into two equal sections when the prevailing time
signatures can be divided into four equal beats. In Dorico Pro, specific beam grouping and note
grouping settings apply to bars with a half-bar. Time signatures that have a half-bar include 4/4
and 12/8.
handle
A selectable item that marks the ends of lines, the corners of frames, and other moveable
positions, such as pedal line retakes and slur control points. In Write mode, handles are circular
and mark rhythmic positions. In Engrave mode, handles are square and mark graphical
positions.
harmonic series
A naturally-occurring set of frequencies that are all related to a single pitch, known as the
“fundamental”. When a fundamental pitch is played, the note produced contains many different
notes within the harmonic series. These additional notes are known as “partials” or “overtones”. It
is also possible to bring out the sound of individual partials by playing them as harmonics. There
is a consistent pattern of intervals between partials within the harmonic series, and these
intervals become increasingly smaller the further up the harmonic series they occur. For
example, the interval between the first and second partials is an octave whereas the interval
between the seventh and eighth partials is only approximately a major second. At the top end of
the harmonic series, most partials are microtones. See also partial.
hook
A short line that extends from other lines, most commonly at a right angle, that helps to clarify
the end position of lines. In Dorico Pro, hooks can be used at the end of pedal lines, octave lines,
repeat endings, and tuplet brackets.
horizontal justification
The alignment of musical content to the left and right edges of the frame. To ensure that all
staves in a system occupy the same width, any remaining space that is left over after the music is
spaced is distributed evenly between all of the columns in the system. Sometimes the final
system of a flow is not fully justified and is allowed to end partway across the width of the frame.
See also frame, justification.

I
implicit rest
A rest that is automatically shown around the notes you input. Its notated duration automatically
adjusts according to the time signature and its position in the bar. Implicit rests can be
suppressed between notes in a particular voice, which hides them. See also explicit rest.
Insert mode
A way of changing how notes are input. When Insert mode is activated, new notes push all the
music that follows after the caret along by the input duration instead of overwriting existing
notes. Similarly, reducing the duration of notes with Insert mode activated pulls them closer
together without leaving rests between the notes. This affects not just note input, but also when
you copy and paste notes and inputting time signatures.
instrument
Anything that requires at least one staff to represent the sounds or music it produces. Common
instruments include the violin, flute, tuba, and bass drum. However, human voices, computer
triggering samples, and tape recordings can also be instruments.
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instrument transposition
The interval difference between the pitch the instrument plays and the resulting sounding pitch,
often included as part of the instrument name. For example, when a Clarinet in B♭ plays a C, the
pitch produced is a concert B♭. Instrument transposition is also known as “instrument pitch”. See
also concert pitch, transposed pitch.
item
Generic term for any note, rest, chord, notation, or other selectable object that appears in the
score in Dorico Pro. See also fragment, segment.

J
justification
The alignment of musical content to the edges of the frame, both horizontally and vertically. See
also frame, horizontal justification, vertical justification.

K
key command
A set of keys that perform a defined task when pressed together. Also known as a “keyboard
shortcut”.

L
layout
A page-based presentation of the music for one or more players in one or more flows, for
example, a full score that contains all players or an instrumental part that contains only a single
player. See also flow, player.
layout options
Options that affect the setup of an individual layout, such as page and staff size. These options
can be set in each layout independently in the Layout Options dialog. See also layout.
linear point
A change in value in a track or lane in Play mode that acts as a point on a curve, setting a value
for its position only and allowing for a smooth change in value from that position until the next
point in the track or lane. See also constant point, value line.
lock duration
Functionality that allows you to change the pitches of existing music while retaining existing
rhythms.
lyric
Any text that is intended to be sung or spoken by an individual singer or group of singers. A lyric
can be a whole word or an individual syllable in a multi-syllabic word. Lyrics are shown at each
rhythmic position where a new word or syllable begins. Typically, lyrics are found below the staff,
but are sometimes placed above the staff, for example, in the case of a short score.

M
measure
See bar.
MIDI
An abbreviation for Musical Instrument Digital Interface, a standard for how electronic musical
instruments, computers, and virtual instruments can connect to and communicate with each
other. In Dorico Pro, MIDI data can be sent to one of 16 channels, which allow either a specific
instrument, or a specific patch on a specific instrument, to receive and respond to the data. See
also channel, patch.
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minor key
A key signatures based on a minor scale, which have a different pattern of intervals to major
scales. See also minor scale.
minor scale
A sequence of notes containing the pitches of a minor key. There are three types of minor scales:
natural, harmonic, and melodic. Natural minor scales follow the interval pattern of the Aeolian
mode, which on a keyboard is all the white notes from A-A. Harmonic minor scales also follow the
Aeolian mode interval pattern but the seventh degree of the scale is sharpened, for example, G♯
in A harmonic minor. Melodic minor scales follow different interval patterns when they are
rising/falling: when rising, melodic minor scales have sharpened sixth and seventh degrees, but
when falling, the sixth and seventh degrees are both natural. See also minor key.
modes
Selectable workspaces in the project window that represent different phases in the workflow of
preparing a score.
multi-bar rest
A consolidation of multiple adjacent empty bars into a smaller unit, typically shown as a single
bar with the total number of bars' rest written above the staff. A multi-bar rest normally shows
an H-bar symbol, which is a thick horizontal line with vertical lines at each end. In some older
published scores, a multi-bar rest of up to nine bars in length is shown using a combination of
double whole and whole rests. Also known as a “multirest”.
music area
The main part of the window in Setup, Write, and Engrave modes where you input and edit your
music.
MusicXML
A file format designed to allow the interchange and archiving of music notation data in an open
and non-proprietary way. It is useful for exchanging scores between different music applications.

N
node
A position along the length of a string that marks an equal division of the string, such as a
quarter of the way along a string. Touching, but not fully stopping, a string at a node produces a
harmonic partial. See also partial, harmonic series.
notation options
Options that affect the way the music is notated, particularly concerning how notes and rests are
grouped according to meter, rules for the extent of accidentals, and options for transposition.
These options can be set independently for each flow in the Notation Options dialog.
note input
The standard method of adding notes to staves in sequence that is possible when the caret is
active. The caret automatically advances to the next rhythmic position after each note is input.
During note input, it is also possible to input other items at the caret position. Also known as
“step input” because notes are input step-by-step. See also caret, chord input, Insert mode.

O
overtone
See partial. See also harmonic series, node.

P
padding
The minimum distance/gap between two items, such as text and its enclosure. Padding values
can be independent of other set values, such as minimum height or width.
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padding rest
A rest that fills the extra rhythmic space before or after cues that start or end partway through
bars. This shows clearly how the rhythm of the cue fits within the current time signature and how
it relates to the player’s existing material.
page break
The forced termination of a page of music at a particular rhythmic position, typically at a barline.
Often used to ensure a convenient page turn in a part. In Dorico Pro, page breaks can be
achieved using frame breaks, which are indicated using signposts.
page view
A viewing option that shows music laid out on a page with a fixed width and height, as it appears
when printed. See also galley view.
panel
Wide palettes of tools on the left, right, and bottom edges of the program window that are
available in all modes, but their content varies in each mode.
part
The music belonging to the instruments played by one or more players, shown on its own rather
than in a full score. Performers who do not need to see the music belonging to the whole
ensemble play from parts so they only have to read the music they play themselves. See also full
score.
partial
A single pitch or frequency in the harmonic series, which varies in pitch according to the pitch of
the fundamental but is always a consistent interval above the fundamental according to its
number in the harmonic series. For example, the second partial is an octave above the
fundamental, the third partial is an octave and a fifth above the fundamental, and the fourth
partial is two octaves above the fundamental. Also known as simply a “harmonic” or “overtone”,
although when described as an overtone it has a different number, as the first overtone is the
same as the second partial. See also harmonic series.
patch
An older term for a discrete sound on a MIDI device or virtual instrument. See also channel,
MIDI.
pedal level change
A change to how far a piano sustain pedal is depressed, between 1 (fully depressed) and 0 (not
depressed). It is notated as a change to the height of a pedal line. Also known as a “pedal lift”.
pick-up bar
A note or notes played before the first full bar of a piece. Also known as an “upbeat” or
“anacrusis”. Pick-up bars often only comprise one or two beats whose main purpose is to lead in
to the start of the piece.
pitch crossing
A possible situation on staves containing multiple voices or parts, such as condensed staves,
where notes in down-stem voices have higher pitches than notes in up-stem voices. See also
condensing.
player
A musician who plays one or more instruments. Players are defined as either solo players or
section players and are assigned to flows and layouts. See also solo player, section player, flow,
layout.
playhead
A vertical line that moves alongside music during playback and when recording, showing the
current rhythmic position. Also known as a “playback line”.
Play mode
A mode in Dorico Pro where you can change how your music sounds in playback, including by
changing the playback template and assigning VST instruments, inputting automation, adjusting
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the mix, and changing the sounding duration of notes in playback without affecting their notated
duration. See also modes.
playthrough
A single time playing from the beginning of the piece to the end. Music that contains multiple
possible endings, such as music with repeat endings or codas, requires multiple playthroughs.
plug-in
A software program that can operate within another software program. Dorico Pro supports VST
instruments and effects and script plug-ins written in Lua.
pointer
The symbol on the computer screen that follows movements made by the user with a mouse or
on a touchpad. It is most commonly an arrow pointing towards the top left corner of the screen.
polymeter
Music containing multiple simultaneous meters, for example, one instrument in the ensemble
plays in 6/8 and another plays in 7/4.
popover
A temporary value field that is evoked using a key command and allows you to input items using
text entries. You can open popovers in Write mode during note input or when items are selected
in the music area. There are dedicated popovers for different types of items.
preamble
The notations typically drawn before the first note or rest on each system of music. The preamble
usually includes clefs, key signatures, and time signatures. In Dorico Pro, the preamble is drawn
automatically and so you cannot select any items included in it.
Print mode
A mode in Dorico Pro that allows you to print and export the layouts in your project. See also
modes.
print preview area
The main part of the window in Print mode where you can see a preview of what is going to be
printed or exported as a graphic. See also Print mode.
project
A Dorico Pro file that can contain multiple flows and layouts. See also flow and layout.
properties
The characteristics of individual items and fragments of items in your project that can be edited
via the Properties panel. Many properties are layout-specific, meaning changing the properties of
an item in one layout does not affect the same item in other layouts.

Q
quantization
In music, the act of adjusting the positions and durations of notes so they align with the nearest
defined beat. This process eliminates small variations in rhythm and duration produced naturally
by live performers, and can be useful when importing/exporting MIDI data as quantized music
produces neater notation.

R
rastral size
The size of a full five-line staff, measured from the bottom line to the top line. The term comes
from the rastra engravers historically used to draw five-line staves on blank paper. Because the
rastrum is a fixed object, people became used to their set sizes and Dorico Pro continues this
tradition by offering users a selection of rastral staff sizes.
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reducing
The process of taking music for more than one instrument and assigning it to fewer instruments,
such as a keyboard reduction of a choral piece. A piece of music that has been reduced is known
as a “reduction”. See also exploding.
rhythmic grid
A unit of rhythmic duration whose value affects certain aspects of inputting and editing, such as
the amount by which items move. Its current value is shown by the note value in the status bar,
and by ruler markings indicating beat divisions and subdivisions above the staff on which the
caret is active. See also caret.

S
score
See full score, part, project.
section player
Multiple musicians who all play the same instrument and read from the same part layout, for
example, Violin I. Section players may not play multiple different instruments, but can divide. See
also player.
segment
Part of a notation item that functions autonomously in Engrave mode. Segments can exist
regardless of their position, such as individual ending brackets within a repeat ending, or only
when a single item is split across a system or frame break, such as glissando lines. See also item,
fragment.
Setup mode
A mode in Dorico Pro where you can set up the fundamental elements of the project:
instruments and the players that hold them, flows, layouts, and videos. You can also determine
how they interact with each other, for example, by changing the players assigned to layouts. See
also modes.
SMuFL
Short for “Standard Music Font Layout”, it is a font specification that maps all the different
symbols required for music notation onto a standard layout. Dorico Pro requires SMuFLcompliant fonts for certain areas of the program, such as clefs and dynamic glyphs, to ensure it
can locate the correct symbol. SMuFL-compliant fonts include Bravura, Petaluma, and November
2.0.
solo player
An individual musician who can play one or more instruments, for example, a flute doubling
piccolo. See also player.
space
A unit of measurement in music engraving based on the distance between the center of two
adjacent staff lines. Practically all notation items are scaled in proportion to the size of a space,
for example, a notehead is normally one space tall.
spacing
The act of determining the horizontal distance between successive columns in order to format
the music. Horizontal spacing in Dorico Pro considers the graphical shape and size of notes and
other items, such as rhythm dots and accidentals, and the note spacing values set. Full systems
are automatically horizontally justified.
spelling
The way in which a note of a given pitch is specified by a letter name plus an accidental. For
example, assuming the conventional 12-EDO pitch system, MIDI note 61 can be spelled as C♯, D♭,
and B. The same pitch is normally spelled a certain way in a given key, for example, MIDI note 61
is normally spelled as C♯ in D major, but is spelled as D♭ in A♭ major. See also EDO, MIDI.
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split stem
A way of presenting altered unisons that keeps each accidental directly beside the notehead to
which it applies. Also known as a “cherry stalk” or “tree”.
staff-relative placement
The vertical position of items relative to musical staves, that is, either above or below.
staff spacing handle
The square handle on the bottom left corner of each staff when Staff Spacing is activated in
Engrave mode. Staff spacing handles only change the vertical position of a single staff. See also
system spacing handle.
string shift indicator
An angled line that indicates the direction of movement when string players have to shift
position on the fingerboard to play a higher/lower note with the same finger as the previous
note.
stroke
The short line that bisects editorial slurs and ties. Also known as a “notch”.
SVG
SVG stands for Scalable Vector Graphics, which is an XML-based way of displaying and modifying
graphics. Due to the way it is coded, it allows you to modify graphics very flexibly compared to
other formats.
system break
The forced termination of a system of music at a particular rhythmic position, typically at a
barline. Indicated in Dorico Pro with signposts.
system formatting
The distribution of bars into systems and systems into frames. When copying part formatting
between layouts, Dorico Pro considers the positions of system breaks, frame breaks, and note
spacing changes to be aspects of system formatting.
system fullness indicator
The highlighted region in the right page margin that is shown when Note Spacing is activated. It
combines a color (green, purple, or red) and a percentage to indicate how full the system is.
system object
An item that applies to all staves in the system, but is not necessary to show on every staff, such
as tempo marks and rehearsal marks. In Dorico Pro, you can show system objects at multiple
positions in each system by showing them above multiple instrument families.
system spacing handle
The square handle on the top left corner of each system when Staff Spacing is activated in
Engrave mode. System spacing handles change the vertical position of the top staff in systems,
which also moves all staves in the system accordingly. See also staff spacing handle.

T
tempo track
The timing-related information included in MIDI data that affects tempo, SMPTE offsets, time
signatures, timecodes, and markers, which can be imported independently of the rest of the data
in MIDI files.
token
A code used in a text string that is automatically replaced by a piece of information from
elsewhere in the project, such as the title of the current flow, the name of the player, or the page
number. Also known as a “wildcard” or “text code”.
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touchpad
Any flat device with a tactile sensor that functions as an alternative to the traditional computer
mouse. Commonly built into laptop computers but can also be separate appliances connected
wirelessly or via a cable.
transport
Encompasses all options related to playback and recording.
transposed pitch
In transposed pitch, the pitches notated are the pitches that the instrument plays, rather than
the desired sounding pitch. Instrumental parts are always in transposed pitch so that players can
simply play the written notes, which is especially important for transposing instruments. See also
concert pitch, instrument transposition.
tuplet
A rhythm that is performed at a fraction of its normal written duration. For example, a triplet is
three notes of a given note value played in the time it would normally take to play two notes of
that note value. Also known as an “irrational rhythm” or a “countermetric rhythm”.
tutti
Italian for “everyone”, tutti indicates that a passage of music is to be played by all players reading
from that part or staff. It is most commonly used to indicate the end of a divisi passage, or for
clarification when a staff can indicate both solos and tutti passages at different times. See also
divisi.

U
upbeat
See pick-up bar.

V
value line
A visual representation of value over time in tracks or lanes in Play mode. Fully horizontal value
lines indicate a constant value, while angled value lines indicate a smooth change in value within
a given duration, usually between two points. See also constant point, linear point.
vertical justification
The spreading out of staves and systems across the full height of frames with as even a
distribution of space as possible. If the music in the frame requires less vertical space than is
available, the remaining space is distributed evenly between the systems, and between the
staves of the systems. See also frame, justification.
vibrato bar
A device on electric fretted instruments, typically guitars, that allows the performer to add
vibrato to notes and to adjust the pitch of notes, similar to a guitar bend. Also known as a
“whammy bar”, “tremolo bar”, or “vibrato arm”.
voice
In Dorico Pro, a series of notes, chords, rests, and other notations that make up a single musical
line and are normally played by the same instrument. Assigning notes and items to different
voices allows multiple lines of music to be presented on the same staff as clearly as possible,
such as in vocal music where the soprano line uses an up-stem voice and the alto line uses a
down-stem voice. Dorico Pro allows as many voices as are needed to be input onto a single staff,
and lays them out and spaces them automatically.
VST instrument
Short for “Virtual Studio Technology instrument”, it is a digital plug-in that converts MIDI data
into audio output. It can emulate an existing piece of studio hardware or can be an entirely new
creation.
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W
Write mode
A mode in Dorico Pro where you can input and edit your music, including changing the rhythmic
positions of items, changing the pitch of notes, and deleting notes and items. See also modes.
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abbreviated
staff labels 1146, 1148, 1149
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absolute tempo changes 1204
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Academico font 409
accelerando. See gradual tempo changes. See also trills
accents. See articulations
acciaccaturas. See grace notes
accidental components 857
attachment points 857
accidental duration rules 619
changing 619
common practice 620
Modernist 622
Second Viennese School 621
accidental spelling 190
changing 200
disabling respelling 162, 190
accidentals 613
altered unisons. See altered unisons
appearance 614
brackets 614, 919
cancellation 620
cautionary 620, 621
changing 188
chord symbols 696, 712, 713
chords 616
collision avoidance 615, 616
custom 851, 853, 857. See also custom tonality
systems
default settings 615
deleting 613
duration rules. See accidental duration rules
engraving options 615
enharmonic equivalents 200
filters 326, 327
guitar pre-bends 962
harmonics 919
harp pedaling. See harp pedaling
hiding 613, 614, 621, 919, 933
horn branch indicators 796
inputting 188, 618
kerning 616
key signatures 613, 839, 846
ledger lines 615
microtonal 618
MIDI input 190
octave divisions 848
order 615
ornaments 925, 937
panel 155, 221
parentheses 614, 620, 919

accidentals (continued)
position 615
quarter tones 618
respelling 190, 200
restating 621, 622
showing 613, 614, 621, 919, 933
signposts 335
slurs 1142
spacing 616
stacking order 615, 616
ties across breaks 614, 1223
titles 397
tokens 397
tonality systems 851
transposing 203
trills 932, 933, 935, 937
action
expression maps 574
activating 170
caret 170
chord input 153, 194
dotted notes 153
force duration 153
frames 351
grace note input 153
graphic editing 351
independent voice playback 543
Insert mode 153, 183
lock to duration 153
mouse input 153, 175
note input 170, 172
note spacing 351, 429
rest input 153
scissors 153
staff spacing 351, 458
tuplet input 153
adagio. See tempo marks
add intervals popover 198
adding notes 198
transposing notes 201
added notes
chord symbols 248
adding. See inputting
additional
endings 304, 306, 1070
voices 179, 1112, 1294
additive time signatures 1237
advanced options
hiding 51
showing 51
advancing
caret 171
chord symbols popover 250
lyrics popover 295
aeolian chord symbols 249, 712
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aggregate time signatures 222, 1237
dashed barlines 222, 1237
inputting 222
aikin noteheads 890
showing 898
alignment
arpeggio signs 945
chord symbols 710
dynamics 762, 765, 782, 783
gradual dynamics 765
instrument names 140
lines 1036
lyrics 863, 876
octave line numerals 737, 738
ornaments 926
page numbers 973
pedal lines 992, 998
playing techniques 1021
repeat endings 1072
repeat markers 1078
rests 1106
staff labels 140, 1147
staves 448
tempo marks 1205
text 313, 403, 404, 410, 412, 413, 415
time signatures 1248
trills 928
voices 1294, 1297
allegretto. See tempo marks
allowing. See activating. See also enabling
alterations
chord diagrams 715
chord symbols 248, 696
jazz ornaments 268
altered bass notes 249, 254, 696
inputting 249, 254
altered unisons 617
appearance 617
formatting 617
split stems 617
alternating time signatures 1237
alto abbreviation
horn fingerings 796
alto clef. See clefs
anacrusis. See pick-up bars
angles
beams 670, 679, 680
fanned beams 679, 680
fingering slides 806
glissando lines 950, 953, 955
hairpins 776
lines 290, 1033, 1039, 1041
octave lines 734, 735
slurs 1132
string shift indicators 811
ties 1226
tremolos 1255
tuplet brackets 1269
annotations 343, 610
comments 343
highlights 707, 710, 758, 1086, 1089, 1095, 1096
lines 1035
note/rest colors 490, 759, 905, 1110, 1295

annotations (continued)
signposts 335
voice colors 1295
aperture
hairpins 777
appearance
default settings 104, 160, 359
resetting 331
appending
player numbers 487
verse numbers 883
appoggiaturas. See grace notes
Arabic numerals
chord diagrams 715
fingerings 810
fret numbers 715
page numbers 376, 974
staff labels 1153
arco. See playing techniques
areas
editing 120, 1281
music 47
print preview 49
project start 47
arpeggio signs 941, 945, 1033
alignment 945
appearance 941–943, 947
beat-relative playback 948
brackets 941
changing 329
cross-staff 270, 271
curved 266
default settings 947
deleting 337
direction 941
duration 947, 948
ends 943
engraving options 947
filter 326
fingerings 789, 804, 805
formatting 422, 942, 943
grace notes 947
handles 944, 946
inputting 265, 266, 270, 271
length 270, 271, 944
moving 945, 946
muting in playback 546
panel 271
playback 947, 948
popover 266, 270
position 944, 945, 947
rhythm slashes 947
spacing 945
swash 941
symbols 422
types 266, 942
voices 270, 271
arrangements
accidentals in key signatures 839
flows 132
movements 132
arranger 102, 398
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arranging 336, 337
changing instruments 118
condensing. See condensing
copying 337–339
exploding 340
filters 326–328
pasting 339
reducing 340, 470
swapping staves 340
voices 338, 341, 342
arrows 1033
arpeggio signs 941
caps 1019, 1045
design 1019
disclosure 51
dividers 1183
noteheads 889
vocal staves 1183
articulations 623
changing 624
collision avoidance 628
copying 624
cues 753
default settings 624
deleting 625
duration 623, 629
engraving options 624
formatting 422
gaps 628
inputting 210, 211
inverting 628
jazz. See jazz articulations
key commands 211
kits 1279
moving 627
notes 626
order 626
outside the staff 629
overlapping 628
panel 155
percussion 589, 1279, 1283
placement 626, 628
playback 543, 589, 629, 1031
playing technique-specific noteheads 589
position 624–627
slur endpoints 1122
slurs 626
spacing 627
staves 629
stems 626
symbols 422
ties 626, 629, 1219
tremolos 589
tuplets 210
types 623
vertical position 628
artificial harmonics 916
accidentals 919
changing 922
hiding 917
partials 918
pitch 918
playback 916–918

artificial harmonics (continued)
showing 917
styles 919, 922
assigning
expression maps to endpoints 572
flows to frame chains 394
flows to layouts 107, 136
frames to frame chains 392
instruments to endpoints 571
key commands 66
MIDI commands 67
percussion maps to endpoints 572
players to flows 107, 134
players to frame chains 395
players to layouts 107, 136
voices to endpoints 571
atonal key signatures 841
attachment lines 39
caesuras 264
dynamics 781
playing techniques 1009, 1016
text 415
attachment points
accidental components 857
chord symbol components 701
lines 290–292, 1033, 1036
noteheads 892, 895
playing techniques 1025
stems 895
attack
articulations 623
dynamics 760
playback 573
audio
buffer size 208, 209
device setup 62
dialog 89
exporting 88, 89
mixer 554
outputs in mixer 567
repeats 548
videos 150
volume 150, 554
warning 52
auditioning
chords 328
MIDI devices 204
notes 204, 328
augmented 198
accidentals 620
chord symbols 248, 696
intervals 198, 266, 620, 934
trills 266, 934
author name 343
changing 348
auto-save 91
deleting projects 91
disabling 92
interval 92
automation lanes 523
constant points 526
copying points 527
deleting points 528
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automation lanes (continued)
dynamics. See dynamics lanes
editing 528
hiding 524
inputting data 525
linear points 526
moving points 528
showing 524
tempo 530, 532
velocity. See velocity lanes
auxiliary notes 935
notehead design 898
position 937
showing 936

B
backgrounds 61
dynamics 767
erasing 421, 490, 767, 803, 813, 1012, 1049
fingerings 803
lines 1049
player labels 490
playing techniques 1012
text 421, 1049
backups 92
auto-save. See auto-save
location 93
number 92
balalaika. See fretted instruments
bands
staff grouping 71, 685
templates 70, 71
banjo. See fretted instruments
bar counts
font style 1115
multi-bar rests 650, 1115
bar numbers 646
alternative 661
appearance 646, 651, 660, 662, 663
changing 658
comments 343–345
default settings 646, 657
deleting 658
enclosures 647, 648
engraving options 657
erased backgrounds 647
excluding repeats 661
font 651, 652, 660
frequency 646
galley view 53
guide 651
hiding 646, 651, 656
including repeats 661
layout options 646
moving 653–655
multi-bar rests 650, 1115
multiple positions 654
paragraph styles 652
part layouts 651
pick-up bars 1239
position 653, 654
prefixes 663

bar numbers (continued)
ranges 650
repeat sections 661, 662
returning to primary sequence 660
sequence changes 657
showing 646, 651
signposts 335
size 652
staff-relative placement 654
subordinate 659, 660
subsequent repeats 661–663
suffixes 663
system-relative placement 655
time signatures 656
bar repeats 1086
bar numbers 650
casting off 451
changing 329, 1087
changing number 1090
consolidating 1113
counts 1089, 1090
default settings 1087
deleting 337
dynamics 1087
engraving options 1087
filter 326
font style 1089, 1092
formatting 422
frame breaks 463
frequency 1091
grouping 1093, 1094
handles 1088
hiding counts 1091
highlights 1086, 1089
inputting 302, 303, 312
length 1088
moving 1088
moving counts 1093
multi-bar rests 1113
panel 303
parentheses 1091
phrase length 329, 1087
playback 329, 1087
popover 302
regions 1086
symbols 422, 1093
system breaks 466
types 302
viewing options 1089
bar rests 1111
counts 1113
cues 160, 755, 756
hiding 1111, 1112
inputting 191, 235
moving 1116
multi-bar rests 1113
showing 1111, 1112
voices 1112
barline joins 641–643, 685, 689
deleting 644
inputting 353, 643
length 644
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barline joins (continued)
resetting 693
splitting 644
barline-attached lines. See lines
barlines 636
across staves 353, 641, 643
appearance 638
caesuras 264
coda 638
connected. See barline joins
copying 133
custom joins 641, 643, 693
dashed 636
default settings 638
deleting 640
double 636, 1081
dynamics 765, 766
end barlines 639
engraving options 638
fermatas 838
final 636
formatting 353, 422
gaps 421, 767, 1012, 1049
grace notes 827
gradual tempo changes 1207
grand staff instruments 641
hiding 421, 767, 1012, 1049
hymnal-style 638
initial. See systemic barlines
inputting 234, 236, 237, 239, 240, 634
joins. See barline joins
key signature changes 638
key signatures 843
moving 640, 641
notation options 638
ossia staves 1169
panel 237, 240
popover 235, 236, 239
repeat 636, 638, 1084
resetting 693
scale size 636
short 636
signposts 335, 640
single 636
spacing 640
staff grouping 353, 642, 685, 689
staves 641, 643
symbols 422
systemic 639
thickness 636, 638
tick 636
time signatures 643, 1248
triple 236
tuplets 1264
types 236, 636
Baroque
appoggiaturas 825
ornaments 268, 924
trills 937, 939
tuning 547
barré 1007
adding 718
appearance 715

barré (continued)
chord diagrams 714, 719
hiding 1013
inputting 277, 281, 283
bars 14, 631
bar rests. See bar rests
beam grouping 39
chord symbols 707
combining 635
count-in 208
deleting 235, 631, 632
deleting contents 632
display 557, 558
divisions 634
duration 633
fixing number per system 451
glissando lines 951
going to 333
grouping 1093, 1094
inputting 234, 235, 237–239
moving 463, 466
multi-bar rests 1112, 1113
navigation 333
note grouping 39
numbers 646
panel 237, 238
pick-up bars 1239, 1240
popover 235, 237
repeat symbols 1086
rests. See bar rests
selecting 324
splitting 634
timecodes 1069
tuplets 1264
upbeats. See pick-up bars
width 633
Bars and Barlines panel 237, 238, 240
based on
master pages 365, 367, 371
baseline
attachment points 422, 701, 857, 895, 1025
lyrics 874, 876
text 313, 415
bass clef. See clefs
bass guitar. See fretted instruments
bass notes
altered 254
beam corners 675
beam groups 38, 664, 665, 681
creating 667
default settings 160, 665
defining 665, 682
half-bar 665
notation options 665
pick-up bars 1240
resetting 666
stem directions 1197
time signatures 665
beam lines
number 676
beam slants 669
changing 670
grace notes 830
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beaming 664, 667, 679
accidentals 622
centered beams 670, 671
corners 675
cross-staff 672, 674
default settings 665
direction 667, 670, 680
fanned 679, 680
grace notes 830
grouping 664, 667, 681. See also beat groups
half-bar 665, 682
handles 670
hiding 1201
inverting 668
large pitch ranges 830
meter 682
multiple staves 674
notation options 665
notes 667
optical cross-staff spacing 673
partial 667
primary beams 675
resetting 666, 669, 672
restating accidentals 622
secondary beams 675, 676
slants 669, 670, 830
spacing 673
splitting 160, 666
staff-relative placement 668
stem direction 668, 674
stemlets. See stemlets
tablature 1189
ties 192
time signatures 665, 682
tuplets 677
unbeaming 667
beat groups 38, 664, 681, 682
defining 682
numerators 1243
specifying 222
ties 1219
time signatures 1243
beat units 1212
metronome marks 329, 1212
setting 230
tuplets 196
beats
deleting 235, 631
display 557, 558
inputting 235, 237, 239
per minute 1212
popover 235
recording latency 208
relative position 331
selecting 325
beep. See click
bends
guitar. See guitar bends
jazz. See jazz articulations. See also jazz ornaments
birds eyes. See fermatas
black noteheads 886, 887
blank areas. See erased backgrounds

blank pages 372
deleting 374
inserting 441
staff spacing changes 458
blue selections 783, 1126
body
changing 1045
lines 1033, 1035, 1045
playing technique continuation lines 1017, 1019
bold text 313, 410, 413, 415
booklets 605
duplex printing 606
printing 604, 605
borders 419, 610
exporting 599
harp pedaling 980, 981
padding 420, 982
printing 596
text 402, 419
thickness 403, 420, 981
Boston chord symbols 696
bottom panel 50
bowing. See playing techniques
boxes. See borders. See also frames
bpm 1212
changing 534, 1212
swing playback 552
braces 683
appearance 688
custom grouping 689, 690
deleting 693
design 688
formatting 353, 422
grouping 689
hiding 687
inputting 690
length 692
resetting 693
secondary brackets 686, 687
showing 687
signposts 335, 690
splitting 690
staff spacing 439, 456
symbols 422
bracketed noteheads 906, 907, 1192
appearance 911
changing type 907
chords 906, 907, 910
curve 914
default settings 907
drawn curve 907, 911
engraving options 907
font glyph 907, 911
formatting 913, 914
gaps 907
ghost notes 907
handles 911, 913
hiding 907
inputting 907
length 911, 913
moving 912–914
percussion 907
shape 911, 914
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bracketed noteheads (continued)
showing 907
slurs 912
splitting 910
tablature 906, 907
tie chains 909
ties 912
ties on tablature 909, 1219
width 914
brackets 683
appearance 688, 689
arpeggio signs 941
barlines 641
custom grouping 689, 690
deleting 693
design 688
ends 689
ensemble types 71, 685
fingerings 801
formatting 353, 422
grouping 129, 353, 684, 689
hiding 687
inputting 690
layouts 684
length 692
noteheads. See bracketed noteheads
player groups 129, 642
project templates 71
resetting 693
secondary 686, 687
showing 687
signposts 335, 690
splitting 690
staff spacing 439, 456
sub-brackets 353, 686, 687
sub-sub-brackets 688
symbols 422
templates 71
time signatures 1241, 1242, 1249
tuplets 1268
wings 689
Brandt-Roemer chord symbols 696
brass instruments
fingerings 788, 796, 809
horn branch indicators 796, 810
playing techniques 280
slide positions 810
Bravura music font 409
breaking
multi-bar rests 1112, 1116
tie chains 1226
breaks
frame 463
page 463
system 465
breath marks 832, 834
appearance 329
deleting 337
inputting 260, 262, 263
moving 836, 837
multiple at same position 836
placement 835

breath marks (continued)
position 835
types 329, 834
breves. See double whole notes
Britten fermata 832
buffer
audio 208, 209

C
C clef. See clefs
caesuras 832, 834
appearance 329
deleting 337
inputting 260, 262–264
moving 836, 837
multiple at same position 836
placement 835
position 264, 835
types 329, 834
cancellation
accidentals 620
double accidentals 620
key signatures 841, 845
naturals 845
candidate menus
cues popover 316
playing techniques popover 277
tempo popover 228
capitals
staff labels 1154
caps 1015, 1033
arrows 1019, 1045
changing 1019, 1045
lines 1033, 1035
playing technique continuation lines 1017, 1019
cards
disclosure arrows 51
flows 101
layouts 98
players 95
timecodes 101
caret 167
activating 170
advancing 171
chords 32, 167, 194
deactivating 170
extending 171, 182
grace notes 167, 193
inputting vs. editing 164
Insert mode 167, 183
lock to duration 167
moving 166, 171, 1262
multiple staves 171, 182
percussion kits 184
rhythmic grid 166
slash voices 167
slashes 181
tablature 167
types 167
voice indicator 167, 179, 769
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casting off 451
bars per system 451
condensing 474
copying to other layouts 491, 493
systems per frame 451
categories
templates 70, 71, 685
cautionary accidentals 620
hiding 614, 621, 919
parentheses 620
showing 614, 621, 919
tie chains 614, 919
cautionary fingering 798
hiding 799
parentheses 799
showing 799
CC64
pedal lines 81, 209
centered beams 670
creating 671
removing 672
centered text
hairpins 780
centimeters
staff spacing 458
unit of measurement 62
chains
frames 390
ties 1219
Change Divisi dialog 1177
change labels
condensing. See player labels
divisi 1184
instruments 114
channels 554
changing 571
controls 554, 556
endpoints 566
expression maps 567, 572
instruments 571
meter 554
MIDI 554
mixer 554, 556
percussion maps 567, 572
playback 566
plug-ins 567
setup 567
strips 556
character styles 407, 413
creating 414
deleting 414
dialog 413
missing fonts 73
saving as default 413
Character Styles dialog 413
cherry stalks 617
choir templates 70
staff grouping 71, 685
Choose Chord Diagram dialog 717
choral
divider arrows 1183
lyrics 863

choral (continued)
playing techniques 280
verse numbers 882
chord brackets. See bracketed noteheads
chord diagrams 714
barré 714, 719
changing 717
colors 717, 719
components 714
copying shapes 717
custom 718
default settings 715
dots 715, 718, 719
editing 718
engraving options 715
font styles 723
formatting 718, 719, 721
fret numbers 718, 719, 723, 724
hiding 716
lines 715
note input options 715
nut 714
omitted notes 162
omitted strings 714, 719
open strings 714, 719
orientation 724
resetting 719
shape 719, 721
shapes 717, 718
showing 716
size 715
symbols. See chord symbols
chord input
activating 153, 194
arpeggio signs 270
caret 167
exploding 182
multiple staves 182
register selection 174
tablature 187
chord symbol components 696
attachment points 701
handles 698, 700, 701
inputting 247
popover 247
types 696
chord symbol regions 707
handles 709
hiding 706
highlights 710
inputting 254
length 709
moving 708
showing 706
chord symbols 695
accidentals 696
added notes 248
alignment 710
alterations 696
altered bass notes 254
appearance 696, 698, 700, 701
changing 329
components. See chord symbol components
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chord symbols (continued)
default settings 162, 696
deleting 337
diagrams. See chord diagrams
dialog 698, 700, 701
engraving options 696
enharmonic spelling 162, 696, 712, 713
filter 326
fonts 705
global. See global chord symbols
hiding 706, 707
highlights 710
input settings 162
inputting 247, 250, 251, 253, 254
instruments 251, 706
intervals 248
layouts 707
local. See local chord symbols
MIDI input 247, 251
MIDI navigation 67, 162
modal 249, 712
moving 711
MusicXML import 713
navigation during input 250
no chord 249
omissions 248
pitch 137
playback 535, 536
players 251, 706
polychords 249, 253
popover 162, 247
position 710
quality 253, 707
regions. See chord symbol regions
resetting appearance 704
root 253, 707
roots 248
saving as default 704
separators 705
showing 251, 254, 706, 707
signposts 335, 695, 707
slash regions 706, 707, 1095
staves 251, 706
suspensions 248
track. See chords track
transposing 137, 202, 203, 705
transposing instruments 137, 712, 713
types 247, 696
viewing options 710
chords
accidentals 615, 616
arpeggio signs 945
auditioning 328
bracketed noteheads 906, 907, 910
caret 32, 167, 171, 194
collision avoidance 615
dense 616
enclosures 1192
fingerings 804
inputting 32, 153, 182, 194
register selection 174
rolled. See arpeggio signs
stacking accidentals 616

chords (continued)
stem directions 1197
tablature 1189
ties 1233
track. See chords track
chords track 535
chorus lyrics 865
changing lines to 880
changing lyrics to 866
popover 294
chromatic glissando 950
playback 956
circle
bar number enclosures 647, 648
harmonics 919, 922
note enclosures 1193
noteheads 887
rehearsal mark enclosures 1052, 1053
string indicator enclosures 814
string indicators 813
Classical
ornaments 268
trills 937, 939
classical guitar. See fretted instruments
clefs 725
cues 742, 756, 757
deleting 728
filter 326
formatting 422
grace notes 729
hiding 257, 258, 730
inputting 254, 255, 257, 258
key signatures 843
moving 726, 727, 729
panel 258
placement 726
popover 255, 257
position 726, 729
showing 730
signposts 335, 730
size at clef changes 728
spacing gaps 726
symbols 422
tie chains 726
ties 1223
transposing instruments 97, 729–731
types 255
Clefs panel 257, 258
click 207, 557
count-in 208
disabling 542
enabling 542
MIDI recording 204
mixer 554
playback 207, 530, 542
settings 207
sound 530
closing tabs 57
coda 1077
appearance 1078
barlines 638, 1081
font 1078
gap 433, 1082, 1174
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coda (continued)
indent 433, 1082, 1174
inputting 307, 308
mid-system gap 1077, 1082
multiple 1078, 1079
sections 1077
size 1078, 1079
codec 146
codes 396
time 1066
col legno. See playing techniques
collapsing. See expanding
collision avoidance
articulations 628
bracketed noteheads 907
fingerings 789
galley view 458
slurs 1124, 1142, 1143
text 419
ties 1220
colored regions 511, 710, 758, 1089, 1096
dynamics lane 513
exporting 610
printing 610
time track 530, 532
colors
bar repeats 1089
chord diagrams 717, 719
chord symbol regions 710
condensed music 490
cues 758, 759
dark theme 61
graphics 603
light theme 61
monochrome 603
note ranges 905
rests 1110
slash regions 1096
tablature 905, 1188, 1190
text 313, 410, 413, 415
unison ranges 1182
voices 1294, 1295
windows 61
columns
accidentals 615, 616
lines 1037
voices 1294, 1297
combinations
playback playing techniques 580, 582, 589
tremolos 589
combined dynamics. See dynamics
combining. See consolidation
comma breath marks 834
commands
key commands 63, 66
MIDI 63, 67
Comment dialog 345
comments 343
adding 344, 347
authors 343, 348
bar numbers 344, 345
changing 348
deleting 337, 345

comments (continued)
dialog 345
exporting 345, 349, 599, 610
hiding 349
initials 343, 348
instruments 345
list 345
panel 345
printing 596, 610
replying 347
showing 349
common practice accidental duration rule 620
common time 839, 1237
components
accidentals 857
articulations 625
chord diagrams 714
chord symbols 247, 696, 701
lines 1035
noteheads 892, 895
playing technique continuation lines 1017
playing techniques 1025
tempo marks 1210
composer 102
default master pages 821
text tokens 396
compound time signatures 1237
inputting 222
rhythm slashes 1096
compressed MusicXML 79
con sordino. See playing techniques
concert pitch 138
clefs 729–731, 756
cues 756
filters 327
input pitch 174
instrument transpositions 1150
layouts 134, 137
staff labels 1145, 1150
status display 52
viewing 137
concertina dragging 461
condensing 470, 472, 480, 1176
calculations 474, 476
changing 472, 479–481, 484, 485
colors 490
default settings 472, 476, 486
deleting changes 486
dialog 481
disabling 449
enabling 449
erased backgrounds 490
excluding groups 479
groups. See condensing groups
hiding player labels 488
including groups 479
labels. See player labels
manual 484
paragraph styles 486, 1147, 1156
periods 487
phrases 474, 476, 480, 481
resetting 485
rests 472, 474, 481
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condensing (continued)
results 476, 480
staff labels 472, 481, 1147, 1153, 1156, 1157
voices 474, 476
Condensing Change dialog 481
condensing groups 478
calculations 474
changing settings 480, 481, 484
creating 479
default settings 472
excluding 479
including 479
manual condensing 484
conductor score. See condensing. See also layouts
configurations
endpoints 567, 569, 570
consolidation 635
bar repeats 1113
bars 635
players 130
rests 160, 1108, 1112, 1113
rhythm dots 902, 903
staff labels 1147, 1152, 1153, 1156
staves. See condensing
constant points 517, 526
inputting 516, 525
constraints
defining 406
flow headings 382
frames 406
contents
bars 632
cue labels 750, 751
cues 750
front matter 821
table 821
continuation lines 1015, 1033
angles 987
appearance 1022
caps 1019
custom playing techniques 1029
default settings 1022
duration 1016
dynamics 760, 772
gradual dynamics 774
hairpins 766, 774, 775
inputting 277, 281, 283
octave lines 733
pedal lines 986, 987, 998, 1001, 1002
playing techniques 1015, 1018–1021
slurs across breaks 1143
tempo marks 1207, 1215, 1216
thickness 1002, 1218
continuation signs 1003
lines 1035
parentheses 1003
playing technique continuation lines 1017
text 1004
continuous hairpins 775
contrapuntal. See counterpoint
control changes
expression maps 574

control points
handles 1133, 1136, 1228
slurs 1129, 1130
ties 1226, 1227
controllers
automation 523
expression maps 573
MIDI. See MIDI controllers
conventions
arpeggio signs 945
breath marks 835
caesuras 835
cues 742
dynamics 761
fermatas 835
fingerings 788
glissando lines 950
grace notes 826
harp pedaling 982
key signatures 839, 843
lyrics 863
ornaments 926
pauses 834
pedal lines 992
playing techniques 1008
rehearsal marks 1051
rests 1106
tempo marks 1205
ties 1220
time signatures 1236
tremolos 1255
trills 926
tuplets 1261
voices 1294
converting
layouts to graphics files 599
notes into tuplets 1263
PDF 599
tuplets into normal notes 1264
copies
printing multiple 596
Copy Staff Spacing dialog 462
copying 336–339
articulations 624
automation 527
barlines 133
chord diagram shapes 717
divisi 1181
dynamics 329, 518, 768
exploding 340
flows 133
frames 371, 389
lyrics 868
master pages 371
notes 624
notes into voices 338
page formatting 371, 491
part formatting 493
players 110
properties 493
reducing 340
slurs 329
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copying (continued)
staff spacing 462
staves 1181
copyright 102, 398
corners
accidental cut-outs 857
beaming 675
crop marks 610
octave lines 734, 735
count-in
duration 208
metronome click 208
counterpoint 191
bar rests 191, 1112
voices 179, 1294
counts
bar numbers 661, 662, 1239
bar repeats 1089–1091
bars 1114
frames 1066
lyrics 870
moving 1093, 1104
multi-bar rests 1113–1115
page numbers 399
pick-up bars 1239
placement 1104
repeat endings 1070
repeat sections 661
rests 1114
rhythm slashes 1102, 1103
staff-relative placement 1104
tacet al fine 1114
timecodes 1066
courtesy accidentals
hiding 621
showing 621
creating. See inputting
crescendo. See gradual dynamics
crop marks 610
exporting 599
printing 596
cross noteheads 888
dead notes 1192
cross-staff beams 672
placement 674
spacing 673
cross-staff chords
fingerings 789
cross-staff slurs 1123
collision avoidance 1142
inputting 1123
length 1123, 1126
moving 1123, 1125
cross-staff ties 1224
cross-voice slurs 1123
inputting 1123
length 1123, 1126
moving 1123, 1125
cross-voice ties 1224
crossing pitches 472. See also condensing
crotchets. See quarter notes

Cubase
expression map data 574
instrument names 1146
staff labels 1146
cue labels 750
changing 751
contents 751
moving 752
octave transpositions 743, 747
staff-relative placement 330
text 751
cues 742
appearance 750
articulations 753
bar rests 160, 756
changing to rhythmic cues 744
clefs 742, 756, 757
contents 750
default settings 743
deleting 749
dynamics 753
engraving options 743
filter 326
hiding 746
highlights 758, 759
inputting 315, 317, 318
instrument names 750
instrument transpositions 750
instruments 316
labels. See cue labels
length 748
lyrics 753
moving 744, 745, 748, 752
multiple 754
notations included 742, 753
ornaments 753
overlapping 754
panel 317, 318
placement 742, 750
playing techniques 753
popover 315, 316
position 742, 744, 745
register 747
respelling notes 750
rests 160, 742, 755, 756
rhythmic. See rhythmic cues
showing 746
signposts 335, 742, 746, 758, 759
size 742
spacing 425, 427
staff position 745
staves 453
stem direction 754
suggestions 317
text 753
ties 755
transposing 750
unpitched instruments 743
vertical position 743, 744
viewing options 758, 759
voices 754
Cues panel 317
curlew fermata 832
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cursor
caret 167
chord symbols 250
fingerings 213
lyrics 295, 870
text 396, 402
curvature direction
grace notes 1120
guitar bends 330
guitar pre-bends 961
notehead brackets 911, 914
slurs 1118, 1120, 1122, 1137, 1138
ties 1220, 1221, 1233, 1234
curved arpeggio signs 941
duration 947, 948
inputting 266
playback 947, 948
popover 266
custom
accidentals 851, 853, 857
barline joins 642–644
brace grouping 689
bracket grouping 689
chord diagrams 718
condensing 484
condensing groups 478, 479
condensing results 481
endpoint configurations 569, 570
flow headings 383
key signatures 851, 854, 860
layouts 107
markers 1062
master pages 365, 367
note sizes 900
noteheads. See custom notehead sets
octave divisions 856
page size 607
paper size 607
playback templates 558, 561, 564
playing techniques. See custom playing techniques
repeat endings 1075
repeat markers 1080
rhythmic feels 552
score layouts. See layouts
staff grouping 689
staff size 454
symbols 422
tonality systems. See custom tonality systems
trill speeds 939
custom notehead sets 891
appearance 895
design 892, 895
editing 892, 895
custom playing techniques 1022
creating 1029
design 1025
editing 1025
exporting 1031
inputting 281, 283
playback 1031
saving as default 1031
custom score layouts. See layouts
Custom Staff Size dialog 454

custom tonality systems 851, 853, 857
accidentals 853, 857
creating 851
editing 851, 854
exporting 850
importing 850
key signatures 854, 860
octave divisions 856
panel 217
playback 862
cut common time 839, 1237
cutting
slash regions 1099
tie chains 1226

D
da capo
al coda 1077
al fine 1077
al segno 1077
font 1078
inputting 307, 308
size 1078
word wrapping 1080
dal segno 1077
damping. See playing techniques
dark theme 61
dashed
barlines 222, 236, 239, 636, 1169, 1237. See also
aggregate time signatures
guitar bend hold lines 960
jazz articulations 970
lines 290, 1033
octave lines 732
pedal continuation lines 1002
slurs 1139–1141
string indicator lines 813, 815
tempo marks 1216, 1217
ties 1230, 1232
data
expression maps 574
date and time
annotations 610
comments 343
exporting 599
printing 596
tokens 400
deactivating
caret 170
chord input 194
Insert mode 183
mouse input 175
mute states 545
muted tracks 554
note input 172
note respelling 190
solo states 545
soloed tracks 554
dead notes 1192
hiding 1192
playback 1192
showing 1192
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decimal places
metronome marks 232, 233, 1212, 1214
decorations. See ornaments
decrescendo. See gradual dynamics
dedications 102, 821, 822
text tokens 396
default flow headings 362, 381
replacing 383
default master pages 362, 365
composer 821
customizing 367, 371
lyricist 821
replacing 365
title 821
tokens 821
default playback templates 559
default settings 360
accidentals 615
barlines 639
beam grouping 160, 666
changing 360
chord diagrams 715
condensing 472, 481
dialogs 40
dynamics 329
flow headings 381
hand tool 53
jazz articulations 968
key commands 16, 63, 66
layouts 139
marquee tool 53
mouse input 164, 165
note grouping 160
note input options 162
note spacing 425, 426
overlapping notes 160
playback 502
playback template 564
player labels 487
playing techniques 1015
selection tools 53
slurs 329
staff grouping 685
staff spacing 439, 456
swing playback 552
tablature strings 172
text 412
text collision avoidance 419
voice order 160
delay
glissando line playback 956
deleting 337, 350
accidentals 613
arpeggio signs 337
articulations 625
auto-save projects 91
automation 528
bar number changes 658
bar repeats 337
barline joins 644
barlines 640
bars 235, 631, 632
beams 667

deleting (continued)
beats 235, 631
braces 693
brackets 693
breath marks 337
caesuras 337
centered beams 672
clefs 728
comments 337, 345
condensing changes 486
cues 749
duplicate notes 340
dynamics 520, 768
empty pages 40
endpoints 569
fermatas 337
fingerings 796
flow heading changes 380
flow headings 385, 445
flow numbers 382, 383
flows 134, 136
frame breaks 465
frames 445
glissando lines 337
grace notes 337
groups from percussion kits 125
instruments 111, 119, 126
jazz articulations 971
key commands 67, 68
key signatures 842
layouts 139
lyrics 868
markers 337
master page changes 378
master page overrides 374
master page sets 364
master pages 370
note spacing changes 429, 434
notes 337, 509
octave lines 738
ornaments 337
ossia staves 1169
overlapping notes 176
page number changes 377
pages 374, 442
paragraph styles 412
pauses 337
pedal lines 337
playback overrides 591
players 111, 131, 132, 134, 136
playing techniques 337
reducing 340
rehearsal marks 1056
repeat endings 337
repeat markers 337
rests 1110
rhythm slashes 337
rhythmic feel change 551
slurs 337
staff spacing changes 461
staves 1159
stem direction changes 1200
stemlets 678
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deleting (continued)
string indicators 817
strings 127
system breaks 467
tempo marks 535, 1209
ties 1225, 1226
time signatures 1250
tremolos 1256
trills 337
tuplets 1264, 1266
unison notes 340
velocity changes 523
videos 150
voices 1296
denominators
styles 1243, 1244
time signatures 1235, 1237
dense chords 616
accidental stacking 616
depth
nested tuplets 1262
deselecting. See selecting
design
arrows 1019, 1033, 1045
fingerings 422, 795
grace note slashes 828
guitar bends 960
lines 1019, 1022, 1033, 1045
music symbols 422
noteheads 887, 890–892, 895, 898
playing techniques 1022, 1025
rhythm slashes 1096
slurs 1139, 1141
stem flags 422, 1195
time signatures 1251
designation
strings. See string indicators
destination
exporting files 600
instruments 742
notes 806
devices
audio 62
diagonal
accidental stacking 615
diagrams
chords. See chord diagrams
harp pedaling 977, 978
dialogs 40
diamond noteheads 888, 889
accidentals 919
harmonics 919, 922
showing 898
dimensions
page size 607
paper size 607
diminished. See augmented
diminuendo. See gradual dynamics
direction
arpeggio signs 941, 942
fanned beams 679, 680
glissando lines 904
gradual dynamics 772

direction (continued)
guitar bends 330
guitar pre-bends 961
hairpins 772
lines 1046
notes on middle line 1198
paper orientation 608
partial beams 667
rhythm slashes 1097
slur curvature 1118, 1137, 1138
stems 1196, 1199, 1200
string shift indicators 811, 904
tie curvature 1220, 1233, 1234
transposing 202, 203
disabling. See enabling
disclosure arrows 51
expression maps dialog 574
Properties panel 52
tracks 511
display options 42, 53
drum editor 505
frames 370, 382, 390, 435
image resolution 609
layouts 46
music area 47, 54
pages 435
panels 24, 50
piano roll editor 504
playback 558
print preview 49
project window 46
tabs 56
time 44, 558
transport 44
distance
bar numbers 654
braces 686
brackets 686, 688
cues 744
noteheads 673
rehearsal mark enclosures 1053
staff labels 1147
stems 673
system indents 1175
text borders 403, 420
distribution
bars per system 451
divisions per octave 856
staves per frame 439
systems per frame 451
dives 961
divide arrows 1183
dividers. See system dividers
divisi 470, 1176
arrows 1183
change labels 1184, 1185, 1187
changing 1177
colors 1182
condensing. See condensing
dialog 1177
editing 1180
ending 1181
fonts 1184
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divisi (continued)
hiding empty staves 441
hiding labels 1185, 1187
hiding staff labels 1148
inputting 1177, 1179
inputting notes 1181
lengthening 1180
moving 1180
playback 543, 571, 1187
shortening 1180
staff labels 1148, 1177, 1184, 1185, 1187
staff spacing 439
staves 441, 1179, 1181
text 1185
tutti 1181
unison ranges 1181, 1182
vocal staves 1183
divisions of the octave. See octave divisions. See also
EDO
doits. See jazz articulations
dorian chord symbols 249, 712
dots
chord diagrams 714, 715, 718, 719
rhythm. See rhythm dots. See also dotted notes
dotted
beat units 230
dynamics 760
noteheads 890
notes. See dotted notes
octave lines 732
rests 153, 160
slurs 1139–1141
tempo marks 1216
ties 1230, 1232
dotted notes 178, 681
consolidation 902, 903
double 178
forcing 177
inputting 153, 178
moving dots 904
note grouping 681
swing playback 548, 549
tempo equations 1218
triple 178
double
accidentals 200, 203, 620
barlines 236, 239, 636, 638, 1081
dotted notes 178
whole notes 14, 155
double whole notes 14
doubling instruments 108
adding 116
inputting notes 172
instrument changes 114
labels 1152
showing staves 60
down arpeggio signs. See arpeggio signs
down-stem voices. See voices
downloads
accessing 69
dpi 609
dragging 53, 334. See also drawing

drawing 53, 334, 496
automation 525
dynamics 516
notes 505
tempo 530
velocity 522
drop frame timecodes 1066
drops. See jazz articulations
drum editor 505, 1292
deleting notes 509
event display. See event display
inputting notes 505
moving notes 506
selecting notes 496
tracks 510
zoom 510
drum kits. See percussion kits
drum rolls. See tremolos
drum sets 120, 1275, 1276
caret 184
defining kits as 123
exporting 1276
filtering instruments 120
importing 1277
inputting notes 184
naming 120
note input 185
setting up 120, 185
stem direction 123
voices 123, 1290
duplets. See tuplets
duplex printing 596, 606
booklets 605
duplicating
character styles 414
exploding 340
expression maps 581
flows 133
items 337–339
master pages 363, 365, 367
notes 338, 339
paragraph styles 411
percussion maps 587
playback templates 564
players 110
duration 1016
accidentals 619
arpeggio signs 947, 948
articulations 623, 629
bars 39, 633
count-in for MIDI recording 208
fermatas 329
flows 398
forcing 177
horizontal lines 1042
jazz articulations 970
lines. See duration lines
locking 202
notated 590
notes 39, 155, 175, 176, 507, 590
pedal lines 1005
played 590
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duration (continued)
playing techniques 277, 281, 283, 1014, 1016,
1021
pre-roll 547
rests 175
slurs 1144
string indicators 1014
terminology 14
tremolos 1259, 1260
duration lines 1015, 1033
appearance 1019, 1022
default settings 1022
handles 818, 1016
hiding 815, 1018, 1019
inputting 277, 281, 283
playing techniques 1016, 1020, 1029
showing 815, 1018, 1019
string indicators 287, 288, 813, 815, 818
dynamic curve 786
dynamic glyphs 760
font styles 786
dynamic modifiers 760, 771
centered 780
font styles 785
hairpins 780
inputting 241, 243–245, 771
poco a poco 779
showing 772
dynamics 760
aligning 765
alignment 762, 765, 782, 783
appearance 761
backgrounds 767
bar repeats 1087
barlines 765, 766
changing 329
combined 760
continuation lines 760, 772
continuous hairpins 775
conventions 761
copying 768
crescendo. See gradual dynamics
cues 753
default settings 761
deleting 768
diminuendo. See gradual dynamics
dynamic curve 786
editing 519
endpoint positions 765
engraving options 761
erased backgrounds 767
expressive text. See dynamic modifiers
filters 326, 768
flared hairpins 778
font styles 785, 786
force 760
formatting 422
gradual. See gradual dynamics
grouping 782, 783
hairpins. See hairpins
handles 764, 772, 773, 776, 777
hiding 772
humanize 513, 787

dynamics (continued)
immediate 760
inputting 241, 243–245
intensity 329
lanes. See dynamics lanes. See also velocity lanes
length 519, 764, 773
linking 329, 783–785
modifiers. See dynamic modifiers
moving 519, 763, 764
muting in playback 546
niente hairpins. See niente hairpins
non-sustaining instruments 787
padding 767
panel 245
parentheses 766
percussion kits 1280
placement 761
playback 543, 548, 769, 786
poco a poco 779, 780
popover 241, 244
position 761, 762
repeats 548
selecting 320
signposts 335, 772
spacing 780
staff-relative placement 330
sustaining instruments 787
symbols 422
text 774, 785
types 241, 760
ungrouping 783
unlinking 329, 785
velocity 521, 522. See also velocity lanes
voice-specific 244, 245, 513, 516, 769
dynamics lanes 241, 513, 760
constant points 517
copying points 518
deleting points 520
editing 519
hiding 515
inputting points 516
linear points 517
moving points 519
showing 515
Dynamics panel 243, 245

E
East Asian elision slurs 885
hiding 885
showing 885
Edit Accidental dialog 857
Edit Chord Diagram dialog 719
Edit Chord Diagrams dialog 721
Edit Chord Symbol Appearance dialog 700
Edit Chord Symbol Component dialog 701
Edit Custom Condensing Group dialog 479
Edit Custom Key Signature dialog 860
Edit Font Styles dialog 407
Edit Instrument Names dialog 140
Edit Notehead dialog 895
Edit Notehead Sets dialog 892
Edit Percussion Kit dialog 120
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Edit Playback Playing Techniques dialog 1028
Edit Playing Technique dialog 1025
Edit Playing Techniques dialog 1022
Edit Tonality System dialog 854
editing 164, 329
area 120, 1281
flow headings 383
handles 358
inputting vs. editing 164
items 157, 329, 358
lyric text 870
master pages 371
methods 320
mouse input 164, 165
notes 153
tools 320
editorial
notes 906, 907
slurs 1139
ties 1230
editors
drum 505
flow headings 382
master pages 370
piano roll 504
text 313, 415
EDO 848, 856
effects channels 556
mixer 554
eighth notes 14, 155
beaming 665
swing playback 229, 548, 549, 552
tempo equations 1218
elbowed beams. See centered beams
ellipse
chord enclosures 1192
note enclosures 1192, 1193
empty bars
cues 755
deleting 632
inputting 237, 238
multi-bar rests 1112
rests. See bar rests
width 633
empty pages 442
deleting 40, 374, 415, 442
inserting 441
staff spacing changes 458
empty staves
hiding 441, 456
showing 441, 456
tacets 467
empty voices 1296
enabling 170
auto-save 92
chord symbol playback 535, 536
click during playback 542
condensing 449, 479
dynamics linking 329
independent voice playback 543
instrument changes 114
MIDI devices 210
partial harp pedaling 984

enabling (continued)
sampled trills in playback 938
slur collision avoidance 1143
slurs linking 329
swing playback 229, 550, 551
text collision avoidance 419
enclosures
bar numbers 647, 648
fingerings 795
line thickness 648, 1053
padding values 648, 1053
rehearsal marks 1051–1053
string indicators 814
tablature 1189, 1192, 1193
text 419, 420
end barlines 639
end repeat barlines 236, 636
inputting 239
playthroughs 1084
endings
additional 304, 306
playthroughs 1070
repeat 304, 305
endpoint positions
arpeggio signs 944
dynamics 765
lines 1036, 1042, 1044
octave lines 737, 738
pedal lines 995
repeat endings 1075
slurs 1119, 1121, 1129–1131
staff lines 1121
ties 1220
trills 928
tuplet brackets 1270
Endpoint Setup dialog 567
endpoints 566
changing 571, 572
configurations 569, 570
custom 570
expression maps 567, 572
instruments 571
notehead brackets 914
percussion maps 567, 572
plug-ins 558
saving 570
setup 567
voices 571
Engrave mode 22, 350
casting off 451
Engraving Options dialog 359
frame breaks 463
frame chains 390
frames 386
graphics frames 405
make into frame 464
make into system 466
moving text 418
music frames 389
note spacing 425
page breaks. See frame breaks
page formatting 435
panels 50, 350, 352, 355, 357
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Engrave mode (continued)
selecting items 351
signposts 335
staff spacing 455
switching 350
system breaks 465
text editor 415
text frames 395
toolbox 351
engraving options 40, 359, 360
accidentals 615
advanced options 51
arpeggio signs 947
articulations 624
bar numbers 657
bar repeats 1087
barlines 638, 1169
bracketed noteheads 907
breath marks 834
caesuras 834
changing 360
chord symbols 696
cues 743
dialog 359
dynamics 761
fermatas 834
fingerings 789
glissando lines 951
guitar bends 960
holds 834
jazz articulations 968
key signatures 841
ledger lines 886
lines 1036
lyrics 864
markers 1060, 1068
music fonts 409
notes 886, 1195
octave lines 733
ornaments 924
ossia staves 1169, 1170
pauses 834
pedal lines 998
percussion 1277
playing techniques 1008
rehearsal marks 1052
repeat endings 1071
repeat markers 1078
rests 1109
rhythm slashes 1096
saving as default 359
slurs 1122
staff labels 1147
stems 886, 1189, 1195
tablature 1189
tempo marks 1204
text 312
ties 1221
time signatures 1237
timecodes 1068
tremolos 1258
trills 924
tuplets 1262

Engraving Options dialog 359
enharmonic spelling
accidentals 190, 200
chord symbols 696, 712, 713
key signatures 846
MIDI 81, 204
modes 712
notes 190, 200
respelling 200
ensembles 95, 111
adding 97, 111, 131
brackets 71, 684, 685
divisi 1176, 1177
groups 129, 131
staff grouping 71, 685
templates 70
envelopes
dynamics 513, 519
equal division of the octave 848
equalization 556
equations
tempo marks 230, 1218
erased backgrounds 421
bar numbers 647
dynamics 767
fingerings 803
lines 1049
padding 420, 767, 982, 1012, 1050
player labels 490
playing techniques 1012
staff lines 793
string indicators 813
text 421, 1050
espressivo. See dynamics
event display 503
automation lanes. See automation lanes
chords track 535
dynamics lanes. See dynamics lanes
inputting notes 505
instrument tracks 511
markers track 537
playing techniques lanes 529
time track 530
velocity lanes. See velocity lanes
video track 538
zoom 510
events
automation 523, 525
dynamics 513, 516, 518
markers 537
notes 505
tempo changes 530, 532
velocity 522
excluding 107
condensing groups 479
flows from layouts 107, 136
playback 546
players 134
players from flows 107
players from layouts 107, 136
playthroughs from bar numbers 661
exclusion groups
expression maps 574
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expanding 320, 539
caret 171, 182
menus 51
notes 176
options 51
selections 320, 322
tracks 539
explicit rests 1106, 1107
colors 1110
deleting 1110
hiding 1110
implicit rests 1109
showing 1110
exploding 171, 182, 340
note input 171, 182
exponential hairpins. See flared hairpins
Export Audio dialog 89
Export File Names dialog 601
Export Flows dialog 77
Export MIDI dialog 84
Export MusicXML dialog 79
Export Tempo Track dialog 87
exporting
annotations 610
arrangements 604
audio 88, 89
borders 610
color graphics 603
comments 345, 349, 610
crop marks 610
custom playing techniques 1031
date 610
expression maps 583
file names 601
flows 76, 77
fretted instrument tunings 129
key commands 63
layouts 599
master page sets 363
MIDI 84
monochrome graphics 603
MP3 files 88, 89
MusicXML files 79, 1076
note colors 610
output format 599
page ranges 598, 604
path 600
PDF 599
percussion kits 1276
percussion maps 588
playback templates 566
PNG 599
repeats 548
signposts 610
stems 88, 89
SVG 599
tempo tracks 87
TIFF 599
time 610
tonality systems 850
voice colors 610
watermarks 610
WAV files 88, 89

expression maps 573
creating 581
dialog 574, 580
endpoints 566, 569, 570, 572
exporting 583
file format 573, 583
filters 574
hiding playing techniques 1013
importing 583
MIDI 787
playback playing techniques 574, 580, 582
playing techniques 1013, 1031
trills 937
volume 787
Expression Maps dialog 574
expressive text. See dynamic modifiers
extending. See expanding
extension lines
lyrics 295, 867, 877
trills 929–931
extra staves 1160
adding 1161
deleting 1159
divisi. See divisi
hiding 441
moving 1162
ossia staves. See ossia staves
showing 441
signposts 1160
width 1163

F
F clef. See clefs
factory default playback templates 559
fader 554
fallback
playback templates 561
falls. See jazz articulations
families
fonts 73
instruments 97, 561, 1007, 1022
fanned beams 679
angles 680
creating 679
direction 679, 680
fast-forwarding 540
feathered beams. See fanned beams
feedback
comments. See comments
fermatas 832
appearance 329
barlines 838
changing 836
deleting 337
duration 329
inputting 260, 262, 263
moving 836, 837
multiple at same position 836
number per staff 838
placement 835
position 835
single staves 836
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fermatas (continued)
staff-relative placement 330
types 329, 832, 836
voices 838
fifth chord diagrams 162
file formats 609
audio 88
backups 92
expression maps 573, 583
frames 405
graphics files 609
MIDI 81
MusicXML 78
percussion maps 588
playback templates 558
tonality systems 851
videos 146
file names 601
ingredients 601
recipes 601
setting 601
files 75
different Dorico versions 73
exporting 75, 599, 600
importing 75
loading into frames 405
missing fonts 73
opening 72
videos 148
filled noteheads 887
films. See videos
filters 326
accidentals 326
deselect 328
drums 120
dynamics 326, 768
ensembles 97
expression maps 574
flows 394
frame chains 394, 395
harp pedaling 326
instruments 97
lyrics 326, 864, 865
notes 326, 327
percussion 120
percussion maps 584
pitch 326, 327
players 395
select 328
stem direction 326
tempo marks 326
voices 326
final barlines 236, 636, 639
inputting 239
number of times played 1084
final tempo 1214
gradual tempo changes 1214
Find Tempo dialog 299
important markers 1064
fine
d.c. al 1077
font 1078
inputting 307, 308

fine (continued)
sections 1077
size 1078
tacet al 1114
fingering 788
appearance 789, 795–798
arpeggio signs 804, 805
backgrounds 803
brackets 801
cautionary 798
changing 791
chord diagrams 714
collision avoidance 789
cross-staff chords 789
default settings 789
deleting 796
design 795
enclosures 795
engraving options 789
erased backgrounds 803
font 797
font styles 796, 798
formatting 422
fretted instruments 800
handles 790
hiding 795, 799
horn branch indicators 810
inputting 213, 214
inside the staff 793
inverting 792
italics 798
letters 805
moving 791
MusicXML import 812
numeral style 810
parentheses 213, 214, 798, 799
pinky letter 805
placement 788, 793, 801, 802
popover 213, 214
position 788, 789
resetting 792
separators 809
showing 795, 799
size 794, 797
slide positions 810
slides. See fingering slides
slurs 794
staff-relative placement 792
string indicators 814, 819
string shift indicators 811
strings 904
substitution 789, 790
symbols 422
thumb letter 805
types 214, 809
underlines 795
valved brass instruments 809
fingering slides 806
handles 806, 807
hiding 806
length 808
moving 807
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fingering slides (continued)
resetting 807
showing 806
first and second endings. See repeat endings
first master pages
customizing 371
replacing 365, 367
first pages
formatting 444
master pages 365, 444
page numbers 975
first steps
starting new projects 70
first systems
indents 1175
fit to paper 608
five-line staff 1158
noteheads 1285, 1287
percussion kits 1281, 1282
percussion legends 1288
fixed tempo mode 546
fixing
bars per system 451
frames 464
note durations 177, 192
systems 466
systems per page 451
flags 335
design 1195
formatting 422
hiding 1201
notes 1195
stems 1195
symbols 422
flared hairpins 778
size 778
flat braces 688
flat slurs 1141
flats
filters 326
flipping 330, 1138
flips. See jazz ornaments
floating windows 43
flow heading editor 382
opening 383
flow headings 102, 362, 381
adding new 383
arrangements 383
changing 378, 379, 383
constraints 382
default 381, 383
deleting 385
editing 382, 383
flow titles 447
frames 381
hiding 445
inserting 379
margins 446
master pages 444
moving 441, 446, 458
naming 385
page numbers 447, 975
panel 355

flow headings (continued)
removing changes 380
removing overrides 374
showing 445
text alignment 403, 404
titles 447
Flow Import Options dialog 76
flows 36, 107, 132
accidental duration rules 619
adding 28, 133
adding players 134
adding to layouts 136
audio 88
cards 101
condensing options 472, 481
copying 133
default settings 160
deleting 134
deleting empty bars 632
duplicating 133
duration 398
end barlines 639
exporting 76, 77
frame chains 391, 394
going to 333
headings. See flow headings
hiding 136
importing 75, 76, 78, 81
instrument change labels 1152
justification 449
layouts 107
master pages 444
multiple on pages 443
MusicXML files 79
names 145
navigation 333
notation options 162
numbers 382, 383, 398
page numbers 398, 399, 447
panel 101
playback 547, 571
players 107, 134
pre-roll 547
removing from layouts 136
removing players 134
selecting 322
showing 136
splitting 342
staff labels 1148
staff size 453
systems 449
tacets 467, 469
timecodes 101
titles 145, 447
tokens 398
trimming 235, 632
videos 101, 146, 148
voices 571
Flows panel 94, 101
hiding 101
showing 101
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folders
backups 92, 93
export path 600
follow tempo mode 546
font styles 407
bar numbers. See paragraph styles
bar repeats 1089, 1091, 1092
changing 407
character styles 413
chord diagrams 723
chord symbols 705
dedications 822
dialog 407
divisi staff labels 1184
dynamics 785, 786
fingerings 796–798
glyphs 409, 786
line text 1047
lyrics 865, 884
markers 1063
missing fonts 73
multi-bar rests 1115
music 409
notations 409
notes 409
ossia staff labels 1170
page numbers 973
paragraph styles 410
PDF files 603
playing techniques 1008
rehearsal marks 1058
repeat markers 1078
rhythm slashes 1092, 1102, 1103
staff labels 1147
string indicators 797, 813, 1022
SVG files 603
tablature 1194
tempo marks 1209
time signatures 1236, 1251
timecodes 1063
tuplets 1273
force
articulations 623
dynamics 760
force duration 153, 177
activating 153
inputting notes with 177
inputting rests with 177
formats. See file formats
formatting
altered unisons 617
arpeggio signs 942, 943
bar numbers 646, 651–653
bar repeats 1092
barlines 353, 638
braces 353
brackets 353, 689
caps 1019, 1045
chord diagram fonts 723
chord diagram shapes 721
chord diagrams 718
chord symbols 698, 700, 701
cue labels 751

formatting (continued)
divisi changes 1180
divisi staff labels 1184, 1185, 1187
dynamics 774
dynamics fonts 785, 786
file names 601
flow headings 382
fonts 407
frame constraints 406
frames 352, 354, 491
front matter 821
glissando lines 952
gradual dynamics 774
hairpins 774
handles 358
layouts 364, 491, 493
lines 1019, 1045
markers 1062, 1063
master pages 361, 370, 371, 383
music symbols 422
niente hairpins 770
notehead brackets 911, 913, 914
noteheads 891, 892, 895, 898
page formatting 362, 372, 451
pages 435, 491, 493, 821
pedal lines 999–1002
player labels 488
playing techniques 1022, 1025
repeat markers 1078
rhythm slashes 1096
slurs 1131, 1133, 1140, 1141
staff labels 1147
symbols 422
systems 352, 491
tablature font 1194
tacets 467, 469
tempo marks 1216–1218
text 313, 315, 407, 410–415
ties 1226, 1231, 1232
time signatures 1251
timecodes 1063
tremolos 1259
tuplets 1264, 1272
Formatting panel 350, 352
forte. See dynamics
forum
accessing 69
fps 151
frame breaks 352, 435, 463
bar repeats 463
condensing 474
copying to other layouts 491, 493
deleting 465
divisi 1176
filter 326
glissando lines 953
inserting 463
lines 1041
octave lines 739
playing techniques 1009
repeat endings 1074
signposts 335, 465
slurs 1143
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frame breaks (continued)
staff labels 1149
staff size 452
staff spacing 439
ties 1222
frame chains
flows 394
frames 392
layouts 391
linking 392
master pages 390
music. See music frame chains
note spacing 427, 428
order 394
players 395
resetting note spacing 428
unlinking 393
frame fullness indicator 460
frame rates 151
changing 147, 151
dialog 147
drop frame timecodes 1066
non-drop frame timecodes 1066
transport window 557, 558
frames 386, 419
borders 402
breaks 435, 463
constraints 406
copying 371, 383, 389
dashed 381
editing 351, 372
flow heading editor 382
flow headings 381, 446, 447
formatting 354
fullness 460
graphics 405
handles 388, 395
inputting 386
making from selection 464
master page editor 370
moving 387
music 389, 448
order 394
padding 403, 435, 448
resetting 374
running headers 447
selecting 351
shape 387
size 387
staves 439, 449
systems 439, 449, 451
text 395, 396, 415
text alignment 404
tokens 396
frequency
auto-save 92
bar numbers 646
bar repeat counts 1091
harmonics 916
pitches in playback 547
slash region counts 1103
timecodes 1069
trills 930

frets 116
adding 127, 719
changing 1190
chord diagrams. See chord diagrams
deleting 127, 719
font style 1194
intervals 127
notes out of range 1190
numbers 724
position 127, 724
size 723
spacing 127
starting number 714, 718, 719, 721, 723
fretted instruments 116
adding 97, 116
arpeggio fingering 804, 805
chord diagrams 714, 716, 721
exporting tunings 129
fingerings 213, 789, 800
frets 127
harmonics 916–919
importing tunings 129
open pitches 128
pinch harmonics 922
popover 216
slides 806
string indicators. See string indicators
strings 128, 904
tablature. See tablature
tuning 116, 127
front matter 821
dedications 822
player list 396
project information 821
running headers 823
full score layouts. See layouts
full screen mode 60
full stop. See period
fullness
frames 460
systems 431
fullness threshold
horizontal justification 449
vertical justification 439, 456
functions
key commands 66
removing key commands 67
fundamental
harmonics 916
string pitches 127
funk noteheads 890
showing 898
FX channels 556

G
G clef. See clefs
galley view 53, 60
bar numbers 53
changing to 60
dragging pages 334
flows 342
instrument changes 114
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galley view (continued)
staff labels 53
staff spacing 456, 458
gaps
around items. See erased backgrounds
articulations 628
barlines 421, 767, 1012, 1049
braces 688
bracketed noteheads 907
brackets 688
codas 433, 1082, 1174
erased backgrounds. See erased backgrounds
fingering slides 806
flow headings 379, 446
galley view 458
H-bars 1114
hairpins 777
harp pedaling 978
key signatures 843
lines 1036
multi-bar rests 1114
notes. See note spacing
ossia staves 439, 456
paragraphs 410, 411
pedal lines 997
quantization 83
slurs 1141
staves 439, 455, 456, 1077
string indicators 814
system indents 1174
systems 1077
tablature 1189
tacets 470
tempo marks 1217
text 410, 411, 413
text collision avoidance 419
ties 1232
time signatures 1237
General MIDI 81
generated trills 937, 938
playback 938
ghost notes 906, 907
engraving options 1277
guitar. See dead notes. See also bracketed
noteheads
gli altri. See divisi
glissando lines 950, 1033
angles 955
appearance 951
changing 329
default settings 951
deleting 337
direction 904
engraving options 951
filter 326
formatting 952
frame breaks 953
guitar bends. See guitar bends
handles 953, 955
harp pedaling 956, 977
hiding 953
inputting 265, 267, 271, 272, 951
length 953

glissando lines (continued)
line styles 952
moving 953
panel 272
placement 950
playback 956, 977
popover 267, 271
position 950
segments 953
showing 953
styles 952
system breaks 953
text 952, 953
thickness 951
tie chains 956
types 267
global chord symbols 695
inputting 251
glyphs
accidentals 200, 857
bracketed noteheads 907, 911
chord symbols 701
dynamics 786
fonts 409, 786
formatting 422
music symbols 422
noteheads 892, 895
pedal lines 998
playing techniques 1025
trills 924, 926
go to. See navigation
Go To Bar dialog 333
Go To Page dialog 333
Gould
repeat markers 1078
grace notes 825
appearance 830
arpeggio signs 947
barlines 827
beams 830
caret 167, 193
clefs 729
default settings 826, 827
deleting 337
inputting 153, 193
inverting 826
lines 1038
moving 901
pedal lines 995, 998
pitch 200
placement 826
playback 547
playing techniques 1008
position 826, 827
register 200
size 828, 900
slashes 826, 828, 829
slurs 826, 1119, 1120
spacing 425, 427, 827
stems 826, 828, 830
string indicators 815
transposing 202
trills 937
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grace notes (continued)
types 828
voices 826
gradual dynamics 760, 772
alignment 765
angles 776
aperture 777
appearance 774
barlines 765, 766
centered text 780
continuation lines 774
continuous hairpins 775
end position 765, 781
flared hairpins 778
font styles 785
handles 764, 773, 777
inputting 241, 243–245
length 773
messa di voce 774
moving 781
niente. See niente hairpins
poco a poco 779, 780
position 781
rotating 776
spacing 780
start position 781
system breaks 777
truncated 781
width 777
gradual tempo changes 937, 1204, 1215
barlines 1207
components 1211
continuation lines 1215, 1216
dashes 1217
drawing 530
editing 530
final tempo 1214
formatting 1216–1218
gaps 1217
inputting 228, 230, 232, 233, 532
length 1206, 1215
Play mode 530
popover 228
position 1207
style 1216, 1218
thickness 1218
time track 530
grand staff instruments
barlines 641
braces 683
brackets 71, 685
centered beams 670
chord symbols 706
cross-staff beams 672
cross-staff slurs 1123
cues popover 316
dynamics 761
hiding staves 441, 456
MIDI recording 204
multi-bar rests 1112, 1115
staff grouping 71, 685
staves 641

grand staff instruments (continued)
swing playback 550
vertical justification 456
graphics
accidentals 857
chord symbols 701
files. See graphics files
noteheads 892, 895
playing techniques 1025
graphics files 599, 609
colors 603
exporting 599, 600
file names 601
fonts 603
formats 405, 609
image resolution 609
monochrome 603
graphics frames 405
file formats 405
inputting 386
loading images 405
master pages 370, 405
selecting 388
green notes
tablature 1190
grids
gaps 126
instrument groups 123
naming groups 124
percussion kits 1281, 1282
rhythmic 166
staves 1154, 1281
groups
bar repeats 1093, 1094
beams. See beam groups
braces 683, 689
brackets 683, 689
condensing 474, 478
dynamics 782, 783
instruments. See instrument groups
notes. See note grouping
players. See player groups
playing techniques 1015, 1016, 1020, 1021
rests. See note grouping
staff labels 1147, 1153, 1156
staff spacing 439, 456
staves 641, 643, 644, 689, 690, 692, 693
tabs 58, 59
guide bar numbers 651
guitar
bends. See guitar bends
changing string for notes 1190
chord diagrams. See chord diagrams
chord symbols. See chord symbols
dead notes 1192
fingerings 800
harmonics 916, 918, 919
note input 187
notes out of range 905
open pitches 128
slides 806
string indicators. See string indicators
strings 128
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guitar (continued)
strumming 804
tablature. See tablature
tuning 97, 116, 127, 128
guitar bends 832, 957, 960
accidentals 962
appearance 960
default settings 960
direction 330, 961
dives 961
engraving options 960
handles 964
height 960
hold lines 960
holds 957, 960, 964
inputting 265, 267, 275, 276
intervals 957, 960
length 962
moving 962
popover 267, 275
position 960
pre-bends 957
releases 957, 960
runs 957
segments 964
shape 962
spacing 960
tablature 1189
thickness 960
guitar pre-bends. See guitar bends

H
H-bars 1112
bar count font 1115
hiding 1113
showing 1113
width 1112, 1114
hairpins. See gradual dynamics
half notes 14, 155
tempo equations 1218
half-bar
beam grouping 665, 682
half-step trills 932, 937
appearance 935
hiding 930, 933
position 937
showing 930, 933
HALion Sonic SE
endpoints 571
independent voice playback 543
playback template 558, 559
HALion Symphonic Orchestra
endpoints 571
independent voice playback 543
playback template 558, 559
hand tool 53
dragging pages 334
handles 969
arpeggio signs 944, 946
bar repeats 1088
beams 670
brackets 911, 913

handles (continued)
chord symbol components 698, 700, 701
chord symbol regions 709
dynamics 764, 772, 773, 776, 777
fingering slides 807
fingerings 790
frames 387, 388, 391, 395, 406
glissando lines 953, 955
guitar bends 962, 964
hairpins 764, 777
jazz articulations 968
lines 1041
lyrics 872, 874, 877, 878
note spacing 429, 432
notehead brackets 911, 913
octave lines 733, 736, 739
pedal lines 987, 994, 1000
percussion legends 1288
playing techniques 1009, 1016
releases 964
repeat endings 1072, 1074
selecting 358, 432
slash regions 1101
slurs 1128–1130, 1133
staff spacing 458
stems 1201, 1257
string indicators 818
system spacing 458
tempo marks 1206, 1215
ties 1226, 1227, 1229
trills 927, 932
tuplet brackets 1267, 1269
harmonics 916
accidentals 919
appearance 919, 922
artificial 916
hiding 917
inputting 917
natural 916
noteheads 898
partials 918
pitch 918
playback 916–918
question marks 917
showing 917
styles 919, 922
tablature 917, 919
harp pedal diagrams 977, 978
placement 982
position 982
showing 978
harp pedaling 977
appearance 977, 978
borders 980, 981
calculating 287
default settings 978
diagrams. See harp pedal diagrams
engraving options 978
erased backgrounds 982
filter 326
glissando lines 956, 977
hiding 979, 980
inputting 280, 286, 287
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harp pedaling (continued)
moving 983
note names 978
notes out of range 905
padding 982
partial. See partial harp pedaling
playback 977
popover 280
showing 979
signposts 977, 979, 980
headers
chords track 535
flows 381
instrument tracks 511
running headers 823
heavy swing 549, 552
height
braces 688
enclosures 648, 1053
flared hairpins 778
frames 387
guitar bends 960
handles 1129, 1130, 1135
lines 1043
notehead brackets 913
slurs 1134, 1135
staves 439, 456
systems 439, 456
ties 1227, 1229
time signatures 1236
tracks 539
hemiola
forcing note durations 177
Henze fermatas 832
inputting 260, 262, 263
hiding 44
accidentals 613, 614, 621, 919, 933, 962
audio outputs in mixer 567
automation lanes 524
backgrounds 421, 767, 1012, 1049
bar numbers 646, 650, 651, 656
bar repeat counts 1091
bar rests 756, 1111, 1112
barlines 421, 638, 639, 767, 1012, 1049
borders 419, 980
braces 687
brackets 687
brackets on noteheads 907
caps 1019
caret 170
cautionary accidentals 614, 919
chord diagrams 716
chord symbols 706, 707
clefs 257, 258, 730
colors 490, 758, 759, 905, 1089, 1096, 1110, 1182,
1295
comments 349
condensing colors 490
continuation lines 1018, 1019
cue colors 759
cues 746
dead notes 1192
decimal places 1214

hiding (continued)
divider arrows 1183
divisi change labels 1177
divisi colors 1182
divisi staff labels 1148, 1185, 1187
divisi staves 441
dynamics 772
dynamics lanes 515
East Asian elision slurs 885
empty staves 441
fingering slides 806
fingerings 795, 799
flared hairpins 778
flow headings 445
flow page numbers 447
flow titles 447
flows 136, 467
Flows panel 101
glissando line text 953
guitar bend hold lines 960
guitar pre-bend accidentals 962
harmonics 917
harp pedaling 979, 980, 984
initial page numbers 975
instrument change labels 1152
instrument changes 114
instrument transpositions 1151
interchangeable time signatures 1237
key signatures 97, 842
laissez vibrer ties 1225
ledger lines 902
lines 1018, 1019
markers 1061
metronome marks 1214
mixer 556
multi-bar rests 1113
note colors 610, 905
notes 1098
octave transpositions in cue labels 747
ossia staves 1168
ossia staves in preamble 1168
padding rests 756, 1099
page numbers 447, 975, 976
panels 24, 44, 51, 52, 95, 98
partial harp pedaling 984
percussion legend signposts 1287
player labels 488
players 134, 136
playhead 541
playing techniques 1013, 1018
playing techniques lanes 530
quality in chord symbols 707
rest colors 1110
rests 1110–1113
root in chord symbols 707
running headers 447
signposts 336, 465, 467
slash region counts 1103
staff labels 1148, 1149, 1177, 1184, 1185, 1187
staff lines 490, 803
staves 107, 134, 136, 441, 1159, 1189
stems 1101, 1201
string indicator lines 815
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hiding (continued)
string indicators 289
system dividers 1171
system track 324
systemic barlines 639
tablature 1189
tabs 44
tacets 469
tempo marks 1209
text borders 419
text on lines 1046
time signatures 1250
timecodes 1068, 1069
toolbar 43
tracks 539
transport window 557
trill extension lines 931
trill intervals 933
trill marks 924, 930
tuplets 1268, 1272
velocity lanes 522
verse numbers 883
video window 149
voice colors 610, 1295
VST instruments 498
highlights
automation 523
bar repeats 1086, 1089
chord symbol regions 707, 710
comments 349
cues 758, 759
dynamics 513
exporting 610
printing 610
slash regions 1095, 1096
tempo changes 530, 532
tracks 503, 513, 523, 530
hold lines 957, 960
guitar bends 960, 962
moving 962
holds. See pauses. See also guitar bends
Holds and Pauses panel 263
Hollywood-style trills 935
intervals 937
position 937
showing 936
hooks
length 1076, 1267
octave lines 739
pedal lines 987, 991, 998, 1000
playing techniques 1015, 1018
repeat endings 1076
tuplets 1267
horizontal alignment
dynamics 765
ornaments 926
staves 449
systems 449
text 404, 412
horizontal lines. See lines. See also glissando lines
horizontal position
arpeggio signs 945
articulations 627

horizontal position (continued)
bar numbers 653
chord diagrams 724
chord symbols 710
clefs 729
dynamics 761, 762, 780
fret numbers 724
lines 1037, 1038, 1040, 1041, 1044
lyrics 863
modifiers 780
notes 425, 431, 1294, 1297
ornaments 926
playing techniques 1008
poco a poco 780
rehearsal marks 1051
rests 1106
rhythm dots 904
staccato 627
staves 449, 1163
string indicators 819
systems 433, 449
tempo marks 1205
ties 1220
time signatures 1236
trills 926
tuplet brackets 1270
tuplets 1261, 1273
horns
branch indicators 796, 810
clefs 97
fingerings 796, 809
key signatures 97
hotkeys. See key commands
HTML files
comments 349
Hub 69
opening projects 72
humanize
dynamics 513, 787
hymnal-style repeat barlines 638
hyphens
lyrics 295, 867, 877, 878
time signatures 1245
Hz
playback tuning 547

I
illustrations
exporting 599
frames 405
image resolution 609
images
exporting 599
frames 405
inputting 405
videos 146
immediate dynamics. See dynamics
implicit rests 38, 1106, 1107
colors 1110
deleting 1110
explicit rests 1109
hiding 1108, 1110
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implicit rests (continued)
showing 1110
voices 1108
Import Master Page dialog 369
Import Tempo Track dialog 86
important markers 299, 1064
importing
Cubase data 574
expression maps 574, 583
flows 75, 76
fretted instrument tunings 129
master pages 363, 367, 369
MIDI files 81, 1292
MusicXML files 78, 1076, 1292
percussion kits 1277
percussion maps 588
playback templates 566
tempo tracks 85, 86
tonality systems 850
unpitched percussion 1292
inches
staff spacing 458
unit of measurement 62
including. See excluding
indents 1174
changing 1175
codas 433, 1082, 1174
first systems 1175
staff labels 1149
systems 433
independent voice playback 543
changing endpoints 571
inputting notes 505
piano roll editor 504
playing techniques 281, 283
Indian drum notation 725, 1293
Indiana chord symbols 696
indicators
audio engine 52
caret 769
fingerings 214, 810
frame fullness 460
horn branches 810
MIDI input 52
string fingerings 811, 904
system fullness 431
tempo. See tempo marks
thumbs 214
trill intervals 932, 937
voices 769
information. See project information
ingredients 601
initial pages
left-hand page 443
page numbers 443, 975
initial trill notes 937
initials
comments 343, 348
input pitch
changing 174
inputting 164
accidentals 188, 613
additional repeat endings 304, 306

inputting (continued)
altered bass note chord symbols 254
arpeggio signs 265, 266, 270
articulations 210, 211
automation 525
bar number changes 658
bar repeats 302, 303, 312
bar rests 191, 235
barline joins 643
barlines 234, 236, 237, 239, 240, 643
bars 234, 235, 237–239
beats 235, 237, 239
braces 690
bracketed noteheads 907
brackets 690
breath marks 260, 262, 263
caesuras 260, 262, 263
caret 167, 170
centered beams 671
chord diagram shapes 718
chord symbols 162, 247, 250, 251, 254
chords 153, 194
clefs 254, 255, 257, 258
comments 344, 345, 347
condensing groups 479
cues 315–318
custom accidentals 188, 851, 853
custom key signatures 221, 851, 854
custom playing techniques 281, 283, 1029
custom tonality systems 851
divisi 1179, 1181
dynamic modifiers 241, 243–245, 771
dynamics 241, 243–245, 516, 771
empty pages 441
ensembles 97, 111
expression maps 581
fanned beams 679
fermatas 260, 262, 263
fingerings 213
flow heading changes 378, 379
flow headings 383
flows 133
frame breaks 463
frames 386
glissando lines 265, 267, 271, 272, 951
grace notes 193
gradual tempo changes 228, 230, 232, 233
guitar bend hold lines 960
guitar bends 265, 267, 275
guitar pre-bends 276
harmonics 917
harp pedaling 280, 286, 287
inputting vs. editing 164
Insert mode 183
instrument changes 172
instruments 97, 109, 116
instruments in percussion kits 122
jazz articulations 265, 267, 273, 274
jazz ornaments 266, 268, 269
key signatures 216, 217, 219, 221, 613
layouts 135
left-hand fingerings 216
line text 1046
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inputting (continued)
lines 277, 281, 283, 290–292
lyrics 293, 295
markers 297, 298, 537
master page changes 377
master page sets 362
master pages 365, 367
metronome marks 228, 232, 233
microtonal accidentals 618
MIDI 204, 210, 525
mouse input 164, 165, 175
nested slurs 1124, 1125
nested tuplets 1262
notehead brackets 907
notes 167, 172, 177, 183, 204, 505
notes in multiple voices 179
notes in percussion kits 184, 185
notes on divisi staves 1181
octave lines 254, 256, 257, 259
ornaments 265, 268, 269
ossia staves 1165
page number changes 375
pages 441
paragraph styles 411
pauses 260, 262, 263
pedal lines 277, 279, 284, 285
percussion kits 117
pick-up bars 222, 226, 227
playback templates 564, 566
player groups 130
player lists 823
players 109
playing techniques 277, 281, 283
popovers 37
position 164
register selection 174
rehearsal marks 296
repeat endings 301, 303–306
repeat markers 301, 303, 307, 308
rests 153, 177, 190
rhythm dots 172, 178
rhythm slashes 302, 303, 311
rhythmic feel changes 228, 550
rhythmic feels 552
rhythmic grid 166
right-hand fingerings 216
settings 165
slash regions 302, 311
slash voices 181, 1300
slurs 212, 1123–1125
staves 1161
stem direction 186
string indicator lines 815
string indicators 280, 287–289
strings 127
sub-brackets 690
sub-sub-brackets 690
swing playback 229
system breaks 466
tablature 187, 1189
tempo equations 228
tempo marks 228, 230, 232, 233, 532
text 312, 402, 1046

inputting (continued)
ties 153, 192, 1224
time signatures 222, 226, 227
timecodes 297
tokens 396, 402
tonality systems 849, 851
tremolos 302, 303, 308, 310
trills 266, 268
tuplets 195, 1262, 1263
unpitched percussion 505
upbeats. See pick-up bars
velocity 522
videos 148
voices 179, 181
Insert Flow Heading Change dialog 379
Insert mode 153, 183
activating 153
caret 167, 183
inputting notes 183
time signatures 226, 227, 634, 1235
tuplets 1266
Insert Pages dialog 441
insertion point 167
inserts 556
instances
adding 500
plug-ins 498
instrument change labels 112, 1152
hiding 1152
showing 1152
instrument changes 114
allowing 114
disallowing 114
inputting 116, 172
labels. See instrument change labels
instrument groups 123, 129
deleting 125
naming 124
percussion kits 123
instrument labels
percussion kits 124
instrument names 139, 1145
alignment 140
changing 144
cues. See cue labels
length 140, 1148
numbering 113, 1146, 1152
Play mode 511
saving as default 140
staff labels 140, 397, 1146, 1148
tokens 397
tracks 511. See also instrument tracks
instrument picker 97
instrument pitches. See instrument transpositions
instrument tracks 510, 511
automation. See automation lanes
collapsing 539
colored regions 511
controls 511
dynamics. See dynamics lanes
expanding 539
headers 511
piano roll editor 504
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instrument tracks (continued)
playing techniques. See playing techniques lanes
velocity. See velocity lanes
instrument transpositions 115, 1150
clefs 730
cue labels. See cue labels
hiding 1151
numbering 1152
showing 1151
staff labels 140, 1151
instrumental parts. See layouts
instrumentation lists 396, 821
adding 823
instruments 37, 112
adding 97, 111, 116
adding staves 1161
adding to flows 134
adding to parts 136
adding to percussion kits 122
arranging tools 336
assigning to endpoints 571
automatic numbering 113
brackets 71, 684, 685
changes. See instrument changes
changing existing 118, 122
chord symbols 251, 706
clefs 729
combining into kits 117
comments 343, 345
cues popover 316
deleting 111, 119
deleting staves 1159
divisi 1176, 1177, 1179
doubling 60, 116
dynamics 513, 787. See also dynamics lanes
empty staves 441
endpoints 566, 567, 571
ensembles 111
expression maps 567
fretted 116
fretted fingerings 800
groups. See instrument groups
hiding 134, 136
inputting notes 172
key signatures 840, 841, 846, 847
loading 500
MIDI 499, 500
MIDI recording 204
moving 119
moving between players 119
muting 545
names. See instrument names
non-sustaining 787
numbering 113, 1152
order 110, 119, 129
order in percussion kits 125
part layouts. See layouts
percussion 583, 1281
percussion legends 1287, 1288
percussion maps 567
Play mode 511
playback 543, 558, 559, 561, 564, 566, 571, 573,
583

instruments (continued)
players 108
Players panel 95
plucked fingerings 800
ranges 905
removing from kits 126
removing from parts 134, 136
searching 97
showing 134, 136
showing staves 60
soloing 545
staff grouping 71, 685
staff labels 140, 1146, 1147, 1151, 1153
staff size 453
staves 60, 1159, 1161, 1163, 1281
strings 116
sustaining 787
swing playback 550
templates 70
tracks. See instrument tracks
transposing 115, 137. See also instrument
transpositions
tuning 97, 116
velocity 521. See also velocity lanes
VST 498, 500
integers
metronome marks 1214
intensity
dynamics 329
interactive key commands map 65
interchangeable time signatures 1237
inputting 222
specifying for individual bars 1237
interface 42
interspersion
accidentals 615
intervals
add intervals popover 198
auto-save 92
chord symbols 248, 696
fretted instruments 127
guitar bends 957, 960
guitar pre-bends 957
harmonics 916–919, 922
octave divisions 848
ornaments 925
transposing 198, 202, 203
trills 266, 932–934, 937
inverting 1138
articulations 628
beaming 668
fingerings 792
grace note stems 826
slurs 1118, 1120, 1138
ties 1234
tuplets 1270
ionian chord symbols 249, 712
irregular
bars as pick-up bars 1240
time signatures 1237
italics
dynamics 760
fingerings 796, 798
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italics (continued)
lyrics 884
text 313, 410, 413, 415
items 164, 320
behind other items 320
changing 329
copying 337
deselecting 328
editing 156
resetting 331
selecting 164, 320–322, 328, 332

J
Japanese
chord symbols 696
coda 1078
segno 1078
jazz
articulations. See jazz articulations
band templates 70, 71
chord symbols 696
glyphs 409
music font 409
staff grouping 71, 685
jazz articulations 966, 967
appearance 968, 970
bend 966
changing 970
default settings 968
deleting 971
duration 970
engraving options 968
handles 968
inputting 265, 267, 273, 274
length 968, 970
line styles 970
moving 968, 969
ornaments. See jazz ornaments
panel 274
playback 966
popover 267, 273
position 968, 969
smooth 966
types 267, 966, 970
jazz ornaments 966, 967
inputting 266, 268, 269
popover 266
types 266
Jazz Standards chord symbols 696
job types 594, 604
page ranges 598
printing 604
selecting 604
joins
barlines 638, 641, 643, 644, 685, 693, 1169
beams 672
ossia staves 1169
pedal lines 997
staves with barlines 643
stems 672
JPEG files
graphics frames 405

jumps
inputting 307, 308
playback 1084
repeat 1077
justification
staves 439, 449, 456, 1163
systems 433, 439, 449, 456
vertical 439, 456

K
kerning 616
key clicks. See playing techniques
key commands 16, 63
articulations 211
assigning 66
defining 62
finding 66
galley view 60
keyboard layouts 67
languages 67
maps 65
MIDI 67
muting 545
navigation 49, 333
page view 60
playback 542
removing 67
resetting 68
searching 65, 66
soloing 545
text formatting 313, 415
key signatures 839
accidentals 613, 839, 857
appearance 841
atonal 841
barlines 638, 843
cancellation style 841
cautionary 848
changes 638, 839, 843
changing 329
clefs 843
custom 851, 854, 856, 857, 860
default settings 841
deleting 842
dialog 854, 857, 860
engraving options 841
enharmonic equivalent 846
filter 326
gaps 843
hiding 97, 842
inputting 31, 216, 217, 219, 221
instruments without 842, 847
major 840
minor 840
moving 844, 845
multiple 842
none 841
octave divisions 848, 856
open 841
panel 217, 221
placement 843
playback 862
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key signatures (continued)
polytonality 219, 221
popover 216, 219
position 219, 843
scales 840
signposts 335, 842
spacing 843
tonality systems 848, 849, 851, 854
transposing 202, 203, 846
transposing instruments 138, 160, 847
types 216, 840
Key Signatures, Tonality Systems, and Accidentals
panel 217, 221
key switches
expression maps 573, 574
percussion maps 584
keyboard shortcuts. See key commands
keyboards
inputting chord symbols 162
inputting notes 167
key command maps 65
layouts 67
MIDI 162
keys
major 840
minor 840
signatures. See key signatures
transposing 202, 203
kits. See percussion kits
kneed beams. See centered beams

L
l.v. ties. See laissez vibrer ties
labels
condensing. See player labels
cues. See cue labels
divisi 1184, 1185, 1187
instrument changes 114
instruments 140, 1145
markers 1060
ossia staves 1170
percussion kits 1154, 1281
staves. See staff labels
laissez vibrer ties 1224, 1225
angle 1226
shape 1226
width 1226
landscape orientation 608
lanes
automation. See automation lanes
dynamics. See velocity lanes
playing techniques. See playing techniques lanes
velocity. See velocity lanes
languages
key commands 65, 67
large
noteheads 890
selections 322
time signatures. See large time signatures
large time signatures 1240, 1242
bar numbers 656
vertical position 1249

largo. See tempo marks
latency
changing value 208
MIDI recording 204, 208
lattice arrangement
accidentals 615, 616
layout cards 98
disclosure arrows 51
numbers 98. See also layout numbers
opening 98
layout frame chains 391
layout names 139, 143
changing 143
text tokens 396
layout numbers 98
order 138
renumbering 138
layout options 40, 104
bar numbers 646, 647, 650, 653
changing 106
copying to other layouts 491, 493
dialog 104
saving as default 104
Layout Options dialog 104
layout selector 44
order of layouts 138
switching layouts 55
layouts 39, 98, 107, 134, 470
accidentals 200
adding flows 136
adding pages 441
adding players 136
bar numbers 646, 650–652, 662
braces 71, 684, 685, 687, 689. See also staff
grouping
brackets 71, 684, 685, 687, 689. See also staff
grouping
cards. See layout cards
casting off 451
chord symbols 707
clefs 729, 730
comparing 58
concert pitch 138
condensing 449, 470
condensing labels. See player labels
copies 596
copying formatting 491, 493
copying frames 389
copying properties 493
creating 28, 135
cues. See cues
custom scores 134
deleting 139
deleting pages 442
divisi 1176, 1177
divisi staff labels 1185, 1187
dynamics 765
editing 372
empty pages 441
empty staves 441
enharmonic spelling 200
exporting 599, 604
exporting audio 88
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layouts (continued)
exporting MIDI 84
file names 601
fit to paper 608
flow headings 381, 382, 445, 447
flows 107, 136, 394, 443, 444
formatting 491, 493
frame breaks 463
frame chains. See music frame chains
frame order 394
frames 389
front matter 821
full scores 134
graphics files 599, 609
harp pedaling 979
headers 823
hiding ossia staves 1168
hiding staves 441
indents 1174, 1175
instrument change labels 1152
instrumental order 129
justification 439, 449, 456
keyboard 65, 67
large time signatures 1240, 1242
Layouts panel 98
left pages 443
margins 437, 448
markers 1061
master page sets 362, 364
master pages 361, 370, 377
multi-bar rests 650, 1113, 1114, 1116
multiple windows 26, 59
music frames 390
MusicXML files 79
naming 143. See also layout names
note spacing 425
numbers. See layout numbers
opening 25, 46, 55
opening multiple 56, 58
orchestral order 110
order 138
orientation 436, 608
ossia staves 1168, 1170
page numbers 972
page ranges 596, 604
page size 607
page turns 463
panel in Print mode 593
panel in Setup mode 98, 134
paper sizes 607
parts 134, 491
percussion kit presentation 1282
player labels 486
player lists 823
players 107, 136, 395
playthroughs 662
printing 596, 604, 608
propagating layouts 493
propagating parts 491
removing flows 136
removing page overrides 374
removing players 136
renumbering 138

layouts (continued)
repeat marker text 1080
restoring 139
running headers 447, 823
scale size 608
selecting 44
settings 104
sorting 138
staff grouping 689
staff labels 397, 1148, 1185, 1187
staff size 438
staff spacing 419, 439, 456
switching 55
system breaks 465
system dividers 1171
system formatting 491
system justification 449
system objects 1172–1174
system spacing 439, 456
tabs 46, 56
tacet al fine 1114
tacets 467, 469, 470
text collision avoidance 419
time signatures 1240, 1242, 1251
timecodes 1061, 1067, 1069
tokens 397
transposing 115, 134, 137, 138
vertical justification 439
view types 53
Layouts panel 50
hiding 98
Print mode 592, 593
Setup mode 94, 98
showing 98
lead sheets
systemic barlines 639
leading 410, 411, 417
ledger lines 886, 901
accidentals 615
hiding 902
width 901
left pages
starting from 443
left panel 50
left-foot pedals. See harp pedaling
left-hand fingering 800
default settings 789
engraving options 789
erased backgrounds 803
inputting 213, 216
letters 805
placement 789
popover 216
position 802
size 800
slides 806
string indicators 814
legends
percussion. See percussion legends
length
arpeggio signs 270, 271, 944
bar repeat phrases 329, 1087
bar repeats 1088
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length (continued)
barlines 644
braces 692
brackets 692, 911, 913
chord symbol regions 709
continuation lines 1009
cues 748
divisi passages 1180
dynamics 519, 764, 773
fingering slides 808
glissando lines 953
grace note slashes 829
guitar bends 962
H-bars 1114
hairpins 766
hooks 1000, 1076
jazz articulations 968, 970
lines 1041–1044
lyric extender lines 878
lyric hyphens 878
multi-bar rests 1114
notated duration of notes 590
notehead brackets 911, 913
notes 176, 507, 590
octave lines 733, 736, 739
pedal lines 994, 996, 997, 1000, 1002
percussion legend names 1289
percussion legend ranges 1288
played duration of notes 590
playing techniques 1009, 1014
repeat endings 1072, 1074, 1076
slash regions 1101
slurs 1123, 1126
staff labels 1148, 1184, 1185
stems 1195, 1200, 1201
string indicators 818
system dividers 1172
tempo marks 1206, 1215, 1217
trills 927, 932
tuplet brackets 1267
lento. See tempo marks
letter paper sizes 607
letters
right-hand fingering 805
level changes for pedal lines 987, 989–991
handles 987
levels
channels 554
dynamics 513, 786
nested tuplets 1262
libraries
chord diagrams 721
fretted instrument tunings 129
percussion 583
sound 498, 501, 558, 574, 583
lifts
jazz articulations. See jazz articulations
pedal lines. See pedal retakes
light swing 549, 552
light theme 61
line breaks
player labels 489
repeat markers 1080

line spacing 410, 411, 417
linear points 517, 526
inputting 516, 525
lines 950, 1015, 1033, 1035
angled 290, 1033, 1039
annotations 1035
appearance 1019, 1022, 1033, 1045
arpeggio signs. See arpeggio signs
attachment types 1036
attachments 290, 291, 1033
automation 523, 525
backgrounds 1049
barlines 636
beams. See beaming
caps 1019, 1033, 1045
changing 1019, 1045
chord diagrams 715
columns 1037
components 1035
cross-staff 292
default settings 1036
divider arrows 1183
drawing 532
duration 1042, 1043
dynamics 513, 516
enclosures 648, 1053
end position 1044
engraving options 1036
erased backgrounds 1049, 1050
fingerings 811
fonts 1047
frame breaks 1041
gaps 1036
glissando. See glissando lines
grace note slashes 828
grace notes 1038
gradual tempo changes 1218
guitar bends 957, 960
handles 1041
harp pedaling 977, 984
hiding 1018
holds. See hold lines. See also guitar bends
horizontal 1033, 1036
horizontal position 1037
inputting 290–292
jazz articulations 966, 970
joining notes. See beams
ledger 901
length 1041–1044
lyric extender 877, 878
lyrics 863, 879
moving 1037, 1038, 1040, 1041
notes. See stems. See also beaming
octave lines. See octave lines
order 1011, 1037
padding 1050
pedal. See pedal lines
placement 1037–1039
playback. See playhead
player labels 489
playing techniques. See playing technique lines
position 1036
repeat endings. See repeat endings
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lines (continued)
repeat marker text 1080
reversing 1046
secondary beams 676
segments 1041
size 1042, 1047
slurs 1140
staff-relative placement 1038, 1039
staves 1158, 1159
string indicators 287, 288, 815
string shift indicators 811
system breaks 1035, 1041
system dividers. See system dividers
tablature 1188, 1189
tempo marks 530, 1216
text 419, 1035, 1046–1048
thickness 359
ties 1230, 1232
trills 930, 931
tuplet brackets. See tuplet brackets
types 1019, 1033, 1036
velocity 522
vertical 1033, 1036
vertical position 1011, 1036, 1038
wiggly 930, 941
linking
dynamics 329, 783–785
flow names 145
flow titles 145
groups of dynamics 782
master pages 365, 367, 371
music to frames 392, 393
percussion maps to VST/MIDI 572
slurs 329, 1126, 1127
lists
comments 345
players 396, 823
little finger. See pinky finger
loading
MIDI instruments 500
playback templates 564
sounds 500, 564
video files 148
VST instruments 500
local chord symbols 695
inputting 251
locations
backups folder 93
lock
duration. See lock to duration
frame 352
system 352
lock to duration 153, 202
activating 153
loco. See octave lines
locrian chord symbols 249, 712
lower case
flow titles 398
repeat marker text 1078
Roman numerals 398
lower notes
trills 939
lute. See fretted instruments

lv ties. See laissez vibrer ties
lydian chord symbols 249, 712
lyric extender lines 867, 877
handles 877, 878
inputting 293, 295
moving 878
lyric hyphens 867, 877
handles 877, 878
inputting 293
moving 878
lyric lines 294, 863, 865
changing 866, 880, 881
copying 868
deleting 868
moving 874
numbers 879, 880
offsets 874, 876
placement 872
position 872, 874
resetting 876
lyricist 102, 398
default master pages 821
text tokens 396
lyrics 863
alignment 863, 876
appearance 864
changing 866, 870, 880
chorus 294, 865, 866, 880
copying 868
counts 870
cues 753
default settings 864
deleting 868
East Asian elision slurs 885
editing 870
engraving options 864
extender lines. See lyric extender lines
filters 326, 864, 865
font styles 884
handles 872, 874, 877, 878
hyphens. See lyric hyphens
inputting 293, 295
italics 884
line numbers 879–881
lines. See lyric lines
melismatic 293, 295, 872, 877
moving 873, 874
note spacing 426, 427, 863
offsets 874, 876
placement 863, 872
popover 293–295
position 863, 864, 872
resetting 876
selecting 320, 865
size 884
spacing 426, 427, 872, 874, 876
staff-relative placement 881, 882
syllable types 295, 867
text 870
translations 294, 865, 866, 880
types 294, 865, 867
verse numbers 882, 883
zoom 870
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M
macOS
printing 599
major
chord symbols 248
keys 840
scales 840
make into
frame 352, 464
system 352, 466
mandolin. See fretted instruments
maps
expression 573
key commands 65
percussion 583
marcato. See articulations
margins
changing 437
flow headings 378, 379, 446
music frames 448
MusicXML files 78
pages 435, 437
tacets 470
mark-up. See comments. See also annotations
markers 1060
appearance 1060
comments. See comments
default settings 1060
deleting 337
dialog 298
engraving options 1060
filter 326
font style 1063
hiding 1061
important 299, 1064
inputting 297, 298, 537
moving 1063, 1064
panel 297
position 1060
repeats 301, 1077
showing 1061
staff 1061
staff spacing 439, 456
text 297, 1062
timecodes 298, 1063, 1068
track 537
vertical position 439, 456, 1060, 1061
marks
rehearsal. See rehearsal marks
tempo. See tempo marks
trills 924, 926, 929, 930
marquee tool 53
using 321
master output volume 554
master page editor 370
opening 371
master page overrides 372, 415
deleting pages 442
moving 441
removing 374
text 395

master page sets 362
applying 364
creating 362
deleting 364
exporting 363
flow headings 362, 381, 383
importing 363
naming 364
master pages 40, 361, 365
adding 367
adding new 365
assigning to pages 377, 444
based on 365, 367, 371
copying layouts 371
custom 365, 367
dedications 822
default 365
deleting 370
editing 370, 371
first 365
flow headings 382
frame chains 390, 392, 393
frame constraints 406
frames 386, 387
graphics frames 370, 405
importing 367, 369
links 365, 367, 371
moving 441
music frames 389
naming 369
overriding. See master page overrides
page numbers 972
panel 355
removing changes 378
removing flow heading changes 380
running headers 823
sets. See master page sets
text alignment 403, 404
types 365
measured tremolos. See tremolos
measurement
units 62
measures. See bars
medium swing 549, 552
melismatic lyrics 295, 872, 877
merging
pedal lines 997
players 75, 76, 78, 81
voices 340
messa di voce 772
moving 781
showing 774
meter 1235
beam grouping 665, 682
changing 329
channel levels 554
irregular 633, 634
meterless time signatures 1237
note grouping 665, 681
open 1237, 1244
rest grouping 665, 681
time signatures 1237
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meter (continued)
tremolos 1253
tuplets 1261
metric modulation
tuplets 1264
metronome click. See click
metronome marks 1203, 1212
appearance 1210, 1211
beat units 329, 1212
changing 329, 534, 1212
click 207
components 1210, 1211
decimal places 232, 233, 1212, 1214
equations 230, 1218
fonts 1209
hiding 1209
inputting 228, 232, 233
multiple positions 1172
parentheses 1210
playback 207, 557, 1213, 1214
popover 228
range 1213
selecting 320
showing 1209
size 1209
values 329, 534, 1212
vertical positions 1172
microtones 618, 851
accidentals 857
custom tonality systems 851
EDO 848
inputting 618
key signatures 860
octave divisions 856
playback 862
transposing 198
trills 933
mid-system gaps
codas 1077, 1082
middle line
stem direction 1196, 1198
MIDI
accidental spelling 190
automation 523, 525, 528
channels 554, 567
commands 63, 67
controllers. See MIDI controllers
deleting 528
devices. See MIDI devices
dialog 81, 83, 84
editing 528
endpoints 566, 571
exporting 87
expression maps 573, 574, 581
fader 554
files. See MIDI files
inputting 525
instruments 499, 511. See also MIDI instruments
lanes 523
loading instruments 500
markers 537
navigation 67
note input 167, 182, 190

MIDI (continued)
note range 112
overlapping notes 176
pan 554
percussion maps 572, 583, 584, 587
piano roll editor 504
playback 511, 566, 583
ports 567
quantization 83
range 112
recording. See MIDI recording
respelling 190
slurs 1144
tempo 530, 546
tempo tracks 85–87
thru 204
time track 530
volume 787
MIDI controllers 523, 787
automation 523, 525
dynamics 787
pedal lines 1005
MIDI devices 210
activity 52
chord symbols 162, 247, 251, 253, 254, 535, 536
disabling 210
enabling 210
expression maps 573, 581
navigation 162
note input setup 185
note spelling 162
percussion kits 185
percussion maps 583, 587
playback templates 558, 559
polychords 253
settings 162
warning 52
MIDI files 81
dialog 81, 84
exporting 84
importing 81, 1292
opening 72
pedal lines 209
playback overrides 591
quantization 81, 83
repeats 548
requantizing 206
sustain pedal controllers 209
unpitched percussion 1292
MIDI Import Options dialog 81
MIDI Input Devices dialog 210
MIDI instruments 499
instances 499
loading 500
numbering 499
MIDI Quantize Options dialog 83
MIDI recording 204
audio buffer size 208, 209
click settings 207
count-in 208
devices 210. See also MIDI devices
dialog 83
input pitch 174
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MIDI recording (continued)
latency 208
optimization 208
pedal lines 209
pitch 174
quantization 83, 204
repeats 206
requantizing 206
retrospective recording 206
setup 208
starting 204
stopping 204
sustain pedal controllers 209
tempo mode 546
time signatures 204
transport window 557
MIDI thru 204
millimeters
staff spacing 458
unit of measurement 62
mini transport 43, 44
minims. See half notes
minor
chord symbols 248
keys 840
scales 840
Missing Fonts dialog 73
missing sounds
loading 564
mixer 554
channel strips 556
hiding 556
hiding audio outputs 567
mute states 545, 554
muting tracks 544
ports 554
resetting 546
showing 556
solo states 545, 554
soloing tracks 544
soundtracks 150
videos 150
volume 546
window 42
mixolydian chord symbols 249, 712
mock-ups
exporting 88
modal chord symbols 249, 712
moderato. See tempo marks
Modernist accidental duration rule 622
modes 22, 35
chords 167, 712
Engrave 350
full screen 60
functions 22
Insert 167, 183
Play 495
Print 592
Setup 94
switching 22
tempo 546
toolbar 19
Write 152

modifier keys
key commands 65
searching 65
modifiers. See dynamic modifiers
modulation wheel dynamics 787
molto
centered 780
dynamics 241, 243, 780
font style 785
tempo marks 228, 230
monochrome graphics 603
moon noteheads 890
showing 898
mordents 924
intervals 925
motors. See playing techniques
mouse input 164
activating 153, 175
deactivating 153, 175
settings 164, 165
movements 36, 132
adding 28, 133
exporting 76, 77
flow headings 381
importing 75, 76
multiple on pages 443
splitting 342
tacets 467
movies. See videos
moving
arpeggio signs 945, 946
articulations 627
automation points 528
bar numbers 653–655
bar repeats 1088, 1093
bar rests 1116
barlines 640, 641
bars 463, 466
cancellation naturals 845
caret 171, 195
chord diagrams 724
chord symbols 708, 711
clefs 726, 727, 729
cues 744, 748, 752
cursor 213, 250, 295
divisi 1180
dynamics 519, 763–765, 781
extra staves 1162
fingerings 791, 807
flow headings 446, 458
frames 387
fret numbers 724
glissando lines 953
grace notes 829, 901
guitar bends 962
harp pedal diagrams 983
hold lines 962
instruments 119, 131
jazz articulations 968, 969
key signatures 844, 845
lines 1037, 1038, 1040, 1041
lyric extender lines 878
lyric hyphens 878
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moving (continued)
lyrics 873, 874
markers 1063, 1064
MIDI data 528
navigating. See navigation
notehead brackets 912–914
notes 200, 425, 506, 901. See also note spacing
notes to other instruments 1279
notes to other staves 339, 672
octave lines 735, 736, 739
ornaments 926, 927
ossia staves 1166
page numbers 972
pages 334, 441
pauses 836, 837
pedal lines 993, 994
player labels 489
players 131
playhead 333, 540
playing techniques 1008, 1009, 1011
rehearsal marks 1055, 1056
repeat endings 1073, 1074
repeat markers 1082, 1083
rests 425, 1116
rhythm dots 904
rhythm slashes 1098
selection. See navigation
slash regions 1100, 1104
slashes 829
slurs 1123, 1125, 1131, 1132
staves 458
string indicators 818, 819
systems 458, 461
tabs 59
tempo marks 533, 1205, 1206
text 418
text on lines 1048
time signatures 1247, 1248
tremolos 1257
trills 927
tuplets 1265, 1273
view 333, 334
MP3 files
exporting 88, 89
muffed notes. See dead notes
multi-bar rests 1112, 1113
appearance 1109, 1114
bar count font 1115
bar numbers 650
end of flows 1114
formatting 422
hiding 1113
numbers 422
placement 1115
showing 1113
signposts 1116
single bars 1109, 1113
splitting 1116
staves 1115
symbols 422
tacet al fine 1114
tacets 467, 469
width 1114

multi-note tremolos. See tremolos
multi-pasting 338, 339
multi-rests. See multi-bar rests
multi-segment slurs 1128, 1130
multi-staff instruments 1160
adding staves 1161
cross-staff beams 672
cross-staff slurs 1123
cues popover 316
deleting staves 1159
hiding staves 441, 456
width 1163
multiple
bar numbers per system 654
codas 1078, 1079
cues 754
flows on pages 443
movements 132
segnos 1078, 1079
staff input 171, 182
multiple-voice contexts 1294
articulations 625
cues 754
dynamics 330, 769
fermatas 834, 838
grace notes 826, 1120
guitar pre-bends 961
inputting notes 179
note alignment 1294
notes 1298
ornaments 330, 926
rests 1106, 1108
rhythm dot consolidation 902, 903
slashes 1097, 1098
slurs 1120
stem direction 826, 1196, 1298
ties 1233
voice column index 1297
music
arranging. See arranging
assigning to frames 392
condensing. See condensing
editing 164
fixing into frames 464
fixing into systems 466
symbols. See music symbols
music area 20, 47
event display. See event display
flow heading editor 382
making selections 322
master page editor 370
moving music 333, 334
multiple windows 59
opening layouts 46, 55
page arrangements 54
panels 24
selecting views 60
zoom options 55, 334
Music Fonts dialog 409
music frame chains 390
assigning to frames 392
flows 394
layout 390, 391

1354
Dorico Pro 3.1.10

Index

music frame chains (continued)
master page 389, 390
players 395
propagating part formatting 491, 493
selectors 391
unlinking frames 393
music frames 389
flows 394
frame chains 390, 392, 393
fullness 460
inputting 386
layouts 390
margins 448
master pages 389
order 394
overrides 389
padding 448, 460
players 395
selecting 388
selectors 391
vertical justification 456
music symbols 422
dialog 422
editing 422
tokens 397
MusicXML
chord symbols 713
dialog 79
exporting 79
importing 78
opening 72
pedal lines 1006
percussion 1292
repeat endings 1076
resetting beaming 666
staff labels 1146
muted
notes. See dead notes
muted noteheads 890
mutes. See playing techniques
muting
deactivating 545, 554
instruments 545
items 546
notes 328, 546
tracks 544, 554
mutual exclusion groups
expression maps 574

N
names
drum sets 120
flow headings 385
flows 145
instruments 139, 140, 144
layouts 139, 143
master page sets 364
master pages 367, 369
noteheads 899
percussion kits 120
player groups 129, 130

names (continued)
players 139, 143
staff labels 139, 144
naming schemes
file names 601
Nashville
chord symbols 248, 696
numbers 247
natural harmonics 916
appearance 919, 922
hiding 917
showing 917
naturale. See playing techniques
naturals
hiding 614, 919
inputting 188
parentheses 614, 919
showing 614, 919
navigation 331, 332
bars 333
caret 171
chord symbols popover 250
fingerings popover 213
flows 333
frames 388
handles 358, 388, 432, 458
items 332
lyrics popover 295
music area 332
note input 172, 174, 187
notes 332
pages 333
print preview area 49, 592
rhythmic grid 166
Write mode 332
nested
slurs 1124, 1125
tuplets 1262
nested slurs
endpoints 1122
New Master Page dialog 367
new projects
starting 70
templates 69, 70
New York chord symbols 696
niente hairpins 769
changing 770
circle 769
inputting 241, 244, 245
styles 770
text 769
ninth chord diagrams 162
no chord symbols 249
nodes 916
changing 918
non-arpeggio signs. See arpeggio signs
non-drop frame timecodes 1066
non-power of two time signatures 1237
non-sustaining instruments 787
velocity 521. See also velocity lanes
non-transposing layouts 137
nontuplets. See tuplets
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notated duration 590
played duration 590
requantizing 206
tool 496
notation options 40, 160
barlines 638, 639
beaming 665
changing 162
condensing 472, 481
dialog 160
percussion kits 1278
rests 1109
saving as default 160
voices 1295
Notation Options dialog 160
notation reference 612
notation staves 1188
hiding 1189
showing 1189
notations
appearance 156, 357, 359
changing 329
copying 337–339
cues 742, 743, 753
editing 357
inputting 37, 210
percussion kits 1279
popovers 37
position 357, 359
properties 156, 157
selecting 320, 321
settings 104, 106, 160, 359
stacking order 740
tucking index 740
zoom options 55, 334
Notations panel 152, 160
Notations toolbox 158
notches
octave lines 734
note and rest colors 905, 1110
condensed music 490
cues 759
exporting 599, 610
notes out of range 905, 1188
printing 596, 610
rests 1110
tablature 1188
unison ranges 1182
voices 1295
note brackets. See bracketed noteheads
note durations 155, 590
changing 176
forcing 177
hiding 155
quantization 83
rhythm dot consolidation 903
selecting 175
showing 155
tempo equations 229
note grouping 38, 681
changing 177
hemiola 177
meter 665, 682

note grouping (continued)
note input 38, 39
pick-up bars 1240
rests 38
ties 192
time signatures 39
note input 167, 172, 505
adding notes 198
caret 167, 171
chord input 167
chords 194
grace notes 193
input pitch 174
inputting vs. editing 164
Insert mode 167
lock to duration 202
MIDI 204, 206, 208
mouse input 175
multiple staves 171, 182
muting notes 328
options 40
percussion kits 184–186
pitch 174
playing notes back 328
register selection 174
repitching notes 202
rests 1107
retrospective recording 206
rhythmic grid 166
starting 170
stem direction 186
tablature 187
ties 192
tuplets 195
voices 179
Note Input Options dialog 162
chord diagrams 715
note spacing 200, 351, 425–427, 506, 590, 901
activating 351
barlines 641
changing 425, 427, 429
copying to other layouts 493
default 425
deleting changes 429
dialog 427
filter 326
fullness 431
galley view 53
grace notes 826, 827
guitar bends 960
handles 429, 432
individual notes 429, 432
justification 431
layout options 104, 426
lyrics 426, 427, 863
resetting 428, 429
reverting 434
signposts 335, 427
systems 431
Note Spacing Change dialog 427
note spelling 200
disabling respelling 162
note values. See note durations
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note velocities
MIDI import 81
notehead sets 886, 887, 890
custom 892
designs 887, 890
dialog 892
ledger lines 902
pitch-dependent 890
scale degree 890
types 886
notehead-attached lines. See lines
noteheads 887
aikin 890
arrows 889
articulations 628
attachment points 892, 895
brackets. See bracketed noteheads
changing 898, 899
circular 887
crosses 888
custom 891, 895
default design 898
designs 887, 890–892, 895, 898. See also notehead
sets
dialog 892, 895
diamond 888, 889
dotted 890
editing 895
five-line staff 1285
funk 890
large 890
ledger lines 902
moon 890
muted 890
note names 899
parentheses. See bracketed noteheads
percussion 1283, 1285, 1287
pitch-dependent 890
playing technique-specific 1283, 1286
playing techniques 1283, 1285
rectangular 890
sets. See notehead sets
shapes 887, 890, 891, 895, 899. See also notehead
sets
slashes 1095, 1299
square 890
staccato position 627
stemless 1201
time signatures 1244
triangular 889
types 887
unpitched percussion 1283, 1285
walker 890
wedges 889
NotePerformer
microtonal playback 862
trills 938
notes 38, 886
accidentals 155, 188
add intervals popover 198
adding to existing notes 198
alignment 762
appearance 156, 886, 1189

notes (continued)
arpeggio signs. See arpeggio signs
articulations 155, 624, 626
auditioning 328
auxiliary 935
beaming 664, 667
brackets. See bracketed noteheads
brass fingerings 809
changing pitch 200, 202
chord diagrams 715
chords 194
colors 490, 905, 1295
condensing. See condensing
copying 337–339, 624
crossing to other staves 339, 672
cues 742, 754
custom scale size 900
dead notes 1192
default settings 886, 1189
deleting 337, 509, 1256
deselecting 328
dotted 178, 665, 681
drum editor 506
durations 155, 175, 176, 507, 590
dynamics 241, 513, 760. See also dynamics lanes
dynamics alignment 762
editing 153, 156, 357
editorial 906, 907
enclosures 1192, 1193
engraving options 886, 1189
enharmonic spelling 200
filters 326, 327
fixing duration 177
flags 422
fonts 409
formatting 422
ghost notes 907
glissando lines. See glissando lines
grace notes 193, 825
grouping 665, 681
guitar bends 275, 957
guitar pre-bends 276, 957
harmonics. See harmonics
harp pedaling 977, 978
hiding 1098
hiding ledger lines 902
hiding stems 1201
horizontal spacing. See note spacing
horn branch indicators 810
inputting 29, 167, 172, 177, 178, 183, 184, 194, 505
Insert mode 183
jazz articulations. See jazz articulations
ledger lines 901, 902
length 176, 507
lines. See lines. See also glissando lines
lock to duration 202
lyric alignment 876
middle line 1198
moving graphically. See note spacing
moving rhythmically 506, 901, 1265
moving to other instruments 1279
moving to other staves 339, 340, 672
multiple-voice contexts 1298
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notes (continued)
muting 546
navigation 332
notated duration 39, 590
note spacing 425, 427
notehead designs 887, 891, 892, 895
notehead sets 886
order 1297
out of range 905, 1190
overlapping 176
overrides 590, 591
parentheses 906, 907
partials 916
pasting into voices 338
percussion kits 184, 1291
piano roll editor 504–508
pitch 200, 202
pitch-dependent noteheads 890
Play mode 505
playback 573
played duration 590, 591
properties 157
ranges 905
register 174, 200, 202
removing stem direction changes 1200
repitching 202
requantizing 206
resetting 591
rests 1107
rhythm dots 178, 902–904
rhythm slashes 1299
rhythmic grid 166
rolls. See tremolos
scale size 900
secondary beams 675
selecting 320, 321, 328, 332
showing 1098
size 900
slash regions 1098
slashes 1095, 1299
slurs 155, 1121
spacing. See note spacing
spelling 190, 200
staff spacing 439
stem direction 341, 1196, 1199, 1291
stem length 1200
stemlets 677
stems 1201
string fingerings 811, 904
string indicators. See string indicators
swapping 340
symbols 422
tablature 1189, 1190
terminology 14
ties 39, 192, 626, 1223, 1224
time signatures 1244
transposing 198, 200–203, 508, 846
tremolos. See tremolos
trill intervals 934
trills 929
tuplets 1261, 1263
types 155
unbeaming 667

notes (continued)
unscaling 1264
velocity 521. See also velocity lanes
voices 179, 341, 342
Notes panel 152, 155
showing more note durations 155
Notes toolbox 153
scissors 1226
November music font 409
numbers
backups 92
bar repeats 1089, 1090
bars 646, 657
beam lines 676
fingerings 810
instruments 113, 1152
layouts 138
lyric lines 879–881
pages 376, 972, 974
plug-in instances 498, 499
rhythm slashes 1102
slash region counts 1102
slur segments 1128
staff labels 1153
strings. See string indicators
time signatures 1243
tuplets 1271
verses 882, 883
numerators
styles 1243
time signatures 1235, 1237
nut
chord diagrams 714
fretted instruments 127

O
octatonic chord symbols 249
octave divisions 848, 856
changing 851, 856
custom 856
EDO 848
playback 862
tonality systems 851, 856
transposing 202, 203
octave lines 732
alignment 737, 738
angles 734, 735
appearance 733
default settings 733
deleting 738
Engrave mode 739
engraving options 733
filter 326
formatting 422
frame breaks 739
handles 733, 736, 739
hooks 739
inputting 254, 256, 257, 259
length 733, 736
moving 735, 736
panel 259
placement 740
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octave lines (continued)
popover 255, 256, 259
position 733, 735, 737, 738, 740
selecting 320
stacking order 740
staff-relative placement 330
symbols 422
system breaks 739
tucking index 740
types 256, 732
octave transpositions 200, 202, 203
clefs 255, 725
cues 743, 747
octave lines 256, 732
octuplets. See tuplets
odd-numbered layouts
booklets 605
printing 596, 605
offsets
fret numbers 718, 719, 721
lyric lines 874, 876
player labels 486
playing techniques 1008
resetting 331
timecodes 147, 1067
videos 147
voice columns 1297
omissions
chord diagrams 162, 714, 715, 719
chord symbols 248
open
key signatures 841
meter 1244
strings. See open strings
style 1244
time signatures 222, 1237
open strings 916
appearance 814
chord diagrams 714, 719
harmonics 916
pitches 127, 128
string indicators 814
opening
auto-saved files 91
files 72, 91
flow heading editor 383
layouts 25, 55
master page editor 371
MIDI files 72
mixer 556
MusicXML files 72
projects 70, 72, 91
tabs 25, 56
templates 18, 70
tracks 539
video tutorials 69
video window 149
windows 26, 59
optical spacing
cross-staff beams 673
optional notes. See bracketed noteheads

options
dialogs 40
engraving 359
layout 104
notation 160
note input 162
page sizes 608
playback 502
preferences 62
text formatting 313, 415
toolbar 43
transport 43, 44
workspaces 43, 44
zoom 52, 55, 334
orchestral
cues. See cues
order 110, 119, 129, 138
staff grouping 71, 685
templates 70, 71
orchestrating. See arranging
order
accidentals 615, 616, 839
articulations 626
frame chains 390, 392, 394
instrument numbering 113
instruments 119
instruments in percussion kits 125
key signatures 839
layouts 138
lines 1037
notes 1297
orchestral 119, 129
players 110
playing techniques 1011
rehearsal marks 1057
repeat markers 1079
score 110
tabs 58
voices 160, 1297
orientation
changing 436
chord diagrams 724
exporting 608
landscape 608
portrait 608
printing 596, 608
ornaments 924
acciaccaturas. See grace notes
accidentals 925, 937
alignment 926
appoggiaturas. See grace notes
changing 329
cues 753
default settings 924
deleting 337
engraving options 924
filter 326
formatting 422
handles 927
inputting 265, 268, 269
interval 925
jazz 967. See also jazz articulations
length 927, 932
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ornaments (continued)
moving 926, 927
panel 268, 269
placement 926
popover 265, 268
position 924, 926
selecting 320
slurs 928
staff-relative placement 330
symbols 422
trills. See trills
types 265
Ornaments panel 269, 271, 272
ossia staves 1164
adding 1165
barlines 1169
deleting 1169
hiding 1168
moving 1166
padding 1167
playback 1164
preamble 1168
showing 1168
signposts 1164
size 1167
staff labels 1170
staff spacing 439, 456
system objects 1174
vertical spacing 439, 455, 456
outcomes. See results
outputs
audio export 62
channel in the mixer 554
mixer 567
plug-ins 567
overdubbing
MIDI recording 206
overlapping
accidentals 615, 616
articulations 628
barlines 644
braces 690, 692
brackets 690, 692
cues 754
notes 176
slash regions 1097
slurs 1142
text 419
ties 1220
overline text 313, 410, 413, 415
Override Percussion Noteheads dialog 1285
overrides
chord symbols 698, 704
condensing 480
endpoints 569
flow headings 374, 381
master pages. See master page overrides
music frames 389
note duration 590, 591
paragraph styles 417
playback templates 558, 559, 561, 564, 569, 570
removing 404, 591

overrides (continued)
swapping 381
text 395, 417
overtones. See partials

P
padding
bar numbers 648
dynamics 767
enclosures 648, 1053
frames 403, 435
harp pedaling 982
lines 1050
music frames 448, 460
ossia staves 1167
player labels 490
playing techniques 1012
rehearsal marks 1053
rests. See padding rests
text 403, 420, 1050
padding rests 755, 1106
cues 756
hiding 756, 1099
slash regions 1099
page arrangements 53, 54
page breaks. See frame breaks
page formatting 435
bars per system 451
casting off 451
copying 462
dedications 822
divisi 1176, 1177
empty staves 441
fixing 451, 464
flow headings 378, 380, 381, 435
formatting 362, 372
frame constraints 406
left pages 443
make into frame 464
make into system 466
master pages 361, 362, 364, 365, 370, 371, 378
moving systems 461
multi-bar rests 1116
multiple flows 443
page size 436
staff size 452
staff spacing 419, 439, 455, 462
system spacing 439
systems 433, 451
tacets 469
text collision avoidance 419
titles 361, 381
page margins 435
changing 437, 448
Page Number Change dialog 376
page numbers 376, 972
appearance 973
changing 375, 376
count 399
flow headings 447, 975
flows 398
font styles 973
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page numbers (continued)
hiding 447, 975, 976
horizontal alignment 973
initial 443, 975
moving 441, 972
numeral style 376, 974
paragraph styles 973
position on page 972
removing changes 377
sequence changes 375, 376
showing 447, 976
size 973
tokens 398, 399
total 399
page ranges
exporting 598
printing 598
selecting 604
page size 607, 608
changing 436
layout options 104
MusicXML files 78
page turns
first page on the left 443
page view 53
arrangements 54
changing to 60
flows 342
pages
adding 441
arrangements 54
assigning flow headings 378
assigning master pages 377
breaks. See frame breaks
changing view 60
deleting 374, 442
dragging 334
editing 372, 374
exporting 604
flow headings 382
formatting 372, 821
frames 386, 387, 394, 406
fullness 460
going to 333
layouts 361, 370, 435, 451
making from selection 464
margins 435, 437, 448
master pages 361, 370, 377, 435
moving 441
multiple flows 443
navigation 333
numbers. See page numbers
order 394
orientation 436
panel 355
printing 604, 608
ranges 604
setup 608
size. See page size
staff spacing 462
swapping 381
templates 361, 370, 382
text tokens 396

pages (continued)
total number 399
turns. See frame breaks
view options 52
Pages panel 350, 355
pan 554
panels 21, 50
accidentals 221
arpeggio signs 271
bar repeats 303
barlines 237, 240
bars 237, 238
clefs 257–259
cues 317, 318
dynamics 243, 245
Engrave mode 350
flows 94, 101
formatting 352
glissando lines 272
hiding 24, 44, 51
holds 263
jazz articulations 274
key signatures 217, 221
layouts 94, 98, 593
MIDI instruments 499
notations 160
notes 155
octave lines 259
ornaments 268, 269, 271, 272, 274
pages 355
pauses 263
pedal lines 280, 285
Play mode 495
players 94, 95
playing techniques 280, 283, 285
Print mode 592
print options 594
properties 156, 357
repeat endings 303
repeat markers 303
rhythm slashes 303
Setup mode 94
showing 24, 44, 51
tempo 230, 233
time signatures 224, 227
tonality systems 221
tremolos 303, 310
VST and MIDI Instruments 498
VST instruments 498
Write mode 152, 155, 156, 160
paper
duplex printing 606
orientation 608
size 436, 607, 608
paragraph styles 407, 410, 651
bar numbers 651, 652, 660
condensing 486, 1147
creating 411
deleting 412
dialog 410
divisi staff labels 1184
inputting text 312
missing fonts 73
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paragraph styles (continued)
overrides 417
page numbers 973
player labels 486
repeat markers 1078
resetting 417
saving as default 410
staff labels 1147
tacets 467
text frames 417
Paragraph Styles dialog 410
parent styles
paragraph styles 410, 411
parentheses
accidentals 614, 620, 919
bar repeat counts 1091
dynamics 766
fingerings 213, 214, 798, 799
ghost notes. See bracketed noteheads
guitar bend releases 960
harmonics 919
metronome marks 1210, 1211
noteheads. See bracketed noteheads
octave line numerals 732
pedal continuation signs 1003
percussion notes. See bracketed noteheads
slash region counts 1103
string shift indicators 904
tempo marks 1210, 1211
time signatures 222, 226, 1245
trills 924
part formatting 491, 493
system formatting 491
part layouts. See layouts
part names 139
changing 143
partial beams 667
partial harp pedaling 984
hiding 984
showing 984
partial hiding
barlines 421, 767, 1012
erased backgrounds 421, 767, 1012
partials 916
changing 918
parts. See layouts
pasting. See copying
patches
endpoints 566
playback 566, 573, 583
patterns
chord diagrams 714, 717–719, 721
pauses 832
appearance 329
barlines 838
breath marks. See breath marks
caesuras. See caesuras
changing 836
default settings 834
deleting 337
duration 329
engraving options 834
fermatas 832, 838

pauses (continued)
filter 326
formatting 422
inputting 260, 262, 263
linked 836
moving 836, 837
multiple at same position 836
panel 263
playback 832
popover 260, 263
position 834
selecting 320
single staves 836
staff-relative placement 330, 834
symbols 422
types 260, 832
PDF files 609
color 603
exporting 599
fonts 603
key commands 63
layout numbers 138
pedal level changes 987
adding 279, 284–286
changing 989–991
end level 991
removing 992
start level 989
pedal lines 986
alignment 992, 998
appearance 998, 999, 1001, 1004, 1005
changing 329
continuation lines 986, 998, 1001, 1002
dashes 1002
default settings 998
deleting 337
duration 1005
Engrave mode 987
engraving options 998
filter 326
formatting 422, 999–1002
gaps 1002
grace notes 995, 998
handles 987, 994, 1000
harp pedaling. See harp pedaling
hooks 998, 1000
inputting 277, 279, 284, 285
length 994, 996, 997
levels. See pedal level changes
lifts 987
merging 997
MIDI import 81, 209
MIDI recording 209
moving 993, 994
MusicXML import 1006
muting in playback 546
order 992
panel 280, 285
parentheses 1003
percussion 1007
playback 1005
popover 279, 284
position 992, 995, 998
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pedal lines (continued)
releases 998
removing retakes 992
retakes. See pedal retakes
signposts 335
splitting 997
staff-relative placement 992
start signs 998, 999, 1003
symbols 422
text 1003–1005
thickness 1002
types 279, 986
pedal retakes 987
adding 279, 284–286
alignment 998
handles 987
pedal level 990
position 998
removing 992
types 989
pedals
harp pedaling. See harp pedaling
percussion 1275
default settings 1277
drum sets. See drum sets
engraving options 1277
kits. See percussion kits
legends 1287, 1288
note input 505
noteheads 1283
playing techniques 589
tremolos 589
Percussion Instrument Playing Techniques dialog 1283
percussion kits 1275, 1276
adding instruments 122
caret 184
changing instruments 122
creating 117, 122
drum sets. See drum sets
dynamics 1280
editing area 120, 1281
exporting 1276
filtering instruments 120
five-line staff 1158, 1281
gap sizes 126
grids 123–126, 1281
groups 123–125
importing 1277
individual instruments vs. kits 1275
inputting notes 184
instrument order 125
legends 1287
moving notes 1279
naming 120, 124
notation options 1278
notations 1279
note input 185, 186, 505
playing techniques 1278
presentation types 120, 1275, 1281, 1282
removing instruments 126
rests 160
rhythm slashes 1300
setting up 120, 185

percussion kits (continued)
single-line instruments 1281
spacing 126
staff labels 120, 1154, 1281
staff-relative legend placement 330
staves 120, 1275, 1281, 1282
stem direction 120, 160, 186, 1290, 1291
stickings 1280
voices 160, 1290, 1291
percussion legends 1287
adding 1288
changing 1289
handles 1288
instrument names 1289
length 1288, 1289
position 1277
ranges 1287, 1288
signposts 335, 1287
sounding instruments 1288
staff-relative placement 330
text 1290
types 1287, 1289
percussion maps 583
creating 587
custom 587
dialog 584
endpoints 566, 572
exporting 588
file format 588
filters 584
importing 588
linking 572
note input 185
playback playing techniques 584
Percussion Maps dialog 584
percussion stickings 1280
performance instructions 821
period 14
lyrics 867, 883
player labels 487
resting 317
rhythm dots 153, 178
verse numbers 883
Petaluma music font 409
phrases 474, 476
bar repeats 329, 1087
chord symbol regions 707
condensing 474, 476, 481
splitting 480, 481
phrygian chord symbols 249, 712
piano
depressed notes. See bracketed noteheads
dynamics. See dynamics
level changes 987, 992
pedal lines. See pedal lines
playback 1005
retakes 987, 992
substitution fingering 789
piano roll editor 504
changing note durations 590
deleting notes 509
event display. See event display
independent voice playback 504
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piano roll editor (continued)
inputting notes 505
instrument tracks 511
moving notes 506
note length 507
played vs. notated durations 590
selecting notes 496
slurred notes 1144
tracks 510
transposing notes 508
zoom 510
pick-up bars 222, 1237, 1239
deleting beats 235, 631
inputting 222, 226, 227
turning bars into 1240
pictures
frames 405
inputting 405
videos 146
pinch harmonics 919
showing 922
pinky finger 800
inputting 216
letter 805
popover 216
pitch
accidentals 188, 613
add intervals popover 198
bends. See pitch bends
changing 128, 200–203
changing string 1190
chord diagrams 718, 719
clefs 257, 258, 725
concert 138
crossing 472, 481
cues 750
filters 326, 327
fretted instrument strings 128
guitar strings 128
harmonics 916–918
input 174
jazz articulations 966
key signatures 839
microtonal 618, 848
note input 174, 188
noteheads 886, 890, 899
notes 201
octave lines 259, 732
open strings 127, 128
partials 916, 918
playback 547
ranges 905
strings 127, 128, 718, 719
transposed 138
trills 934, 936, 937, 939
pitch bends 525, 950, 957
guitar. See guitar bends
MIDI controllers 523, 525
pitch delta 857
accidentals 853
changing 853
microtonal playback 862
tonality systems 854

pizzicato. See playing techniques
placement
articulations 628
breath marks 835
caesuras 835
changing 330
clefs 726
cues 742
dynamics 761
fermatas 835
fingerings 788, 789, 793
glissando lines 950
grace notes 826
harp pedal diagrams 982
lines 1037–1039
lyrics 863, 872
octave lines 740
order 740
ornaments 926
pauses 834
pedal lines 992
playing techniques 330, 1008
rehearsal marks 1051
rests 1106
rhythm dots 1194
slurs 1118, 1121
tempo marks 1205
ties 1220
time signatures 1236
tremolos 1255
tucking index 740
tuplets 1261
voices 1294
plain font
fingerings 797
multi-bar rests 1115
Play mode 22, 495
channel strips 556
deleting notes 509
drum editor 505
Endpoint Setup dialog 567
event display 503
exporting expression maps 583
expression maps 573, 580
inputting notes 505
loading sounds 500
mixer 554, 556
moving notes 506
note durations 507, 590
overrides 591
panels 50, 495, 498
percussion maps 583
piano roll editor 504
playback 502, 542
playhead. See playhead
switching 495
toolboxes 495, 496
tracks 510, 539
transport 44, 557
unpitched percussion 1292
whitelisting VST 2 plug-ins 501
window elements 495
zooming 510
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Play toolbox 496
playback 542, 1031
accidentals 862
arpeggio signs 947, 948
articulations 543, 629
audio buffer size 208, 209
automation 523
bar repeats 1087
changing sound libraries 564
channel strips 556
chord symbols 535, 536
chords 328
click 207, 530, 542, 557
custom tonality systems 862
dead notes 1192
default settings 564
default tempo 1203, 1209
divisi 1187
dynamic curve 786
dynamics 513, 543, 769, 786
elapsed time 557, 558
endpoints 566, 567, 569–572
excluding items 546
exporting audio 88, 89
expression maps 573, 574
fader 554
fast-forwarding 540
fixed tempo 546
flows 571
follow tempo 546
glissando lines 956, 977
harmonics 916–918
hidden staves 1159
hiding notes 1098
instruments 543, 573, 583
jazz articulations 966
line 540
metronome 557, 1214
microtones 862
mixer 554, 556
multiple windows 59
muting 544–546
note durations 590
note velocity 521
notes 328, 543
number of times played 1084
options. See playback options
ossia staves 1164
overrides 591
patches 566
pauses 832
pedal lines 1005
percussion 572, 583, 584, 1283, 1285
playhead. See playhead
playing techniques 543, 582, 1028, 1031
playthroughs 1084
plug-ins 554
pre-roll 547
preferences 62
recording notes 206
repeats 548, 1084
resetting volume 546
rewinding 540

playback (continued)
rhythmic feel 552
selections 542
silence playback template 558, 559
slash regions 1098
slurs 212, 543, 1144
soloing 544, 545
starting 542
swing 548, 550–552
templates. See playback templates
tempo 530, 557, 1212–1214
tempo equations 1218
timecode 557, 558
transport 557, 558
tremolos 543, 589, 1259, 1260
trills 937–939
tuning 547
velocity 521
voices 543, 571
volume 546, 554
playback options 40, 502
dialog 502
dynamics 786
pedal lines 1005
repeats 548
saving as default 502
slurs 1144
swing playback 550
timing 629, 947
tremolos 1259
trills 937
Playback Options dialog 502
playback playing techniques 566, 582, 1028, 1031
combinations 580, 582
endpoints 566
expression maps 573, 574
percussion 589
percussion maps 584
playback templates 558
playback templates 558, 559
changing 564
creating 564
custom 558, 561, 564
dialog 559, 561
endpoint configurations 498, 567, 569, 570
exporting 566
factory default 559
fallback 561
file format 558
importing 566
metronome click 207
overriding 558
resetting 564
played duration 590
changing 590, 591
notated duration 590
overrides 590, 591
tool 496
player cards 95
disclosure arrows 51
player groups 95, 129
adding players 131
bracket grouping 642
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player groups (continued)
creating 130
deleting 131
moving players 131
naming 130
removing players 132
player labels 486, 487
backgrounds 490
changing 487, 488
default settings 487
engraving options 487
erased backgrounds 490
hiding 488
lines 489
moving 489
periods 487
position 486
showing 488
signposts 488
staff labels 1156, 1157
word wrapping 489
player names 139
changing 143
instrument tracks 511
text tokens 396
player numbers. See player labels
players 36, 107, 108
adding 27, 111, 116, 131
adding ossia staves 1165
adding staves 1161
adding to flows 134
cards 95
chord symbols 251, 706
clefs 729, 730
condensing 449, 470, 478, 479
copying 110
deleting 111, 119, 131
deleting staves 1159
divisi 1176, 1177, 1179
duplicating 110
editing divisi changes 1180
empty staves 441
ensembles 95, 111
exporting audio 88
exporting MIDI 84
extra staves 1160
filters 395
flows 107, 134
frame chains 391, 395
groups. See player groups
hiding 134, 136
importing 75, 76
instrument change labels 1152
instrument order 119
instruments 37, 60, 112, 116, 118
layouts 107, 136, 143
lists 396, 823
merging 75, 76, 78, 81
moving between groups 131
moving instruments between 119
multiple instruments 60, 116
muting 545
naming 139, 143, 144

players (continued)
numbering instruments 113
ossia staves 1164
panel 94, 95
part layouts. See layouts
percussion kits 117
player names 143
position in score 110
removing from flows 134
removing from groups 132
section players 95, 108, 109
showing 134, 136
solo players 95, 108, 109
soloing 545
staff labels 1146
staff size 453
staves 1159, 1161
swing playback 550, 551
text tokens 396
unison ranges 1181, 1182
Players panel 94, 95
hiding 95
showing 95
playhead 540
fast-forwarding 540
hiding 541
moving 333, 540
playback 542
position 542
repeats 548
rewinding 540
showing 541
transport 557, 558
zooming 510
playing technique lines 1015, 1020
appearance 1018, 1019
caps 1019
changing 1019, 1021
components 1017
default settings 1015
duration 1014, 1016, 1018
hiding 1018, 1019
showing 1018, 1019, 1021
system breaks 1017
playing technique-specific noteheads 1283, 1285
appearance 1287
articulations 589
creating 1286
playback 589
playing techniques 1007
adding text 1011
attachment points 1025
backgrounds 1012
changing 329, 1278
combinations 580, 582, 589
continuation lines 1008, 1015, 1019–1021
creating 1029, 1286
cues 753
custom 1022, 1029, 1031
default settings 1008
deleting 337
design 1022, 1025
dialog 1025, 1028
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playing techniques (continued)
divisi 1176
duration 1014, 1016, 1018, 1021
editing 1025
endpoint configurations 570
engraving options 1008
erased backgrounds 1012
expression maps 573, 1031
filter 326
frame breaks 1009
grace notes 1008
grouping 1015, 1020, 1021
handles 1009, 1016
harmonics. See harmonics
hiding 1013
horizontal offset 1008
inputting 277, 281, 283
lanes. See playing techniques lanes
length 1009, 1014
lines. See playing technique lines
moving 1008, 1009, 1011
muting 546
noteheads 589, 1283, 1285–1287
order 1011
padding 1012
panel 280, 283
percussion 589, 1280, 1283, 1285
placement 1008
playback 543, 573, 1028, 1031
popover 277, 281
position 1008
selecting 320
showing 1013
signposts 1013
size 1008
staff-relative placement 330
system breaks 1009
tracks. See playing techniques lanes
types 277, 1007
ungrouping 1021
vertical position 1011
voices 281, 283, 543
playing techniques lanes 529
hiding 530
showing 530
Playing Techniques panel 283, 285
playthroughs 1070
bar numbers 661–663
changing 1084
dividing 1071
MIDI recording 206
optional notes. See bracketed noteheads
repeats 1071, 1084
total number 1070
plops. See jazz articulations
plucked instruments
arpeggio fingering 804, 805
fingerings 213, 789, 800
popover 216
slides 806
string indicators. See string indicators
strings 904

plucked instruments (continued)
tablature. See tablature
tuning 116
plug-ins 558
changing 558
configurations 567, 569–571
endpoints 558, 571, 572
expression maps 572, 574
instances 498
loading 500
mixer 567
percussion maps 572
playback 554
saving 570
whitelisting 501
PNG files 609
color 603
exporting 599
graphics frames 405
layout numbers 138
resolution 609
poco a poco
centered 780
dynamics 241, 243, 779, 780
font style 785
tempo marks 1211
points
automation 523, 525–528
constant 517, 526
dynamics 513, 516, 517, 519, 520
linear 517, 526
staff spacing 458
tempo changes 530
unit of measurement 62
polychord chord symbols 249
inputting 253
polymeter
time signatures 226, 227
polytonality
key signatures 219, 221
popovers 37
add intervals 198, 201
arpeggio signs 266, 270
bar repeats 302, 312
barlines 235–237, 239
bars 235, 237
beats 235
changing items 329
chord symbols 162, 247, 250
clefs 255, 257
cues 315, 316
dynamics 241, 244
fingerings 213, 214
glissando lines 267, 271
guitar bends 267, 275
harp pedaling 280
holds 260, 263
instruments. See instrument picker
jazz articulations 267, 273
key signatures 216, 219
lyrics 293–295
metronome marks 228
octave lines 255, 256, 259
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popovers (continued)
ornaments 265, 268, 270, 271, 273, 275
pauses 260, 263
pedal lines 279, 284
playing techniques 277, 281, 284
repeat endings 301
repeat markers 301
repeats 301, 308, 312
rhythm slashes 302
string indicators 280
tempo 228, 232
time signatures 222, 226
tremolos 302, 308
trills 266, 934
tuplets 195, 196
portamento. See glissando lines
portrait orientation 608
ports 511, 530, 535, 567
changing 571
chords track 535
expression maps 567, 572
instrument tracks 511
instruments 571
mixer 554
percussion maps 567, 572
setup 567
time track 530
position
arpeggio signs 945, 947
articulations 626, 627
cues 742, 744, 745
dynamics 761
fingerings 788
fret numbers 724
glissando lines 950
grace notes 826
gradual dynamics 781
hairpins 781
inputting 164
instruments in percussion kits 125
items 331
jazz articulations 969
key signatures 843
lines 1036
new items 164
notes in multiple-voice contexts 1294
octave lines 737, 738
order 740
pauses 834
pedal lines 995
resetting 331
rhythm dots 1194
slurs 1118, 1121
staccato 627
string indicators 817
time signatures 1236
trill intervals 937
tucking index 740
vertical order 740
videos 148
possibile
dynamics 243
pre-bends. See guitar bends

pre-roll 547
duration 547
preamble 821
barlines 639
ossia staves 1168
preferences
key commands 63, 66
MIDI 209
missing fonts 73
mouse input 164, 165
pedal lines 209
selection tools 53
sustain pedal controllers 209
theme 61
Preferences dialog 62
prefixes
bar numbers 663
dynamics 771
fingerings 810
rehearsal marks 1058
presentation types 120
changing 1282
dynamics 1280
editing area 120, 1281
percussion kits 1275, 1281
presto. See tempo marks
previous versions 73
primary bar number sequence
changing 658
returning to 660
primary beams 675
Print mode 22, 592
landscape orientation 604
page setup 608
panels 50, 592–594
portrait orientation 604
printers 604
switching 592
toolboxes 592
Print Options panel 592, 594
print preview area 49
navigation 49, 592
printers 604
selecting 596
printing 592, 596
annotations 610
arrangements 604
booklets 605
borders 610
comments 610
copies 596
crop marks 610
date 610
duplex 596, 606
job types 604
key commands 63
landscape 604, 608
layouts 596
macOS options 599
note colors 610
options 594
orientation 608
page sizes 607, 608
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printing (continued)
paper sizes 607
portrait 604, 608
preview 49
ranges 596, 598
scale size 596
signposts 610
spreads 604
time 610
voice colors 610
watermarks 610
program changes
expression maps 573, 574
Project Default Chord Symbol Appearances dialog 698
Project Info dialog 102
flow titles 145
project information 102
master pages 821
text tokens 102
tokens 145, 398
project window 42
dark 61
Engrave mode 350
light 61
opening multiple 59
Play mode 495
Print mode 592
Setup mode 94
splitting 58
theme 61
Write mode 152
projects 35, 75
adding images 405
auto-save 91
backup location 93
backups 92
different Dorico versions 73
exporting 79, 84, 87
exporting flows 76, 77
flows 75–77, 132, 133, 145, 342
frame rates 151
full screen mode 60
importing flows 75, 76, 78
layouts. See layouts
MIDI files 84
missing fonts 73
movements 132
multiple windows 26, 59
MusicXML files 79
opening 59, 72, 91
recent 72
recovering 91
settings 359, 360
splitting flows 342
start area 47
starting 26, 70
Steinberg Hub 69
tabs 58
templates 69–71
titles 145
tokens 398
videos 146, 148

projects (continued)
window 42
workspaces 55
Propagate Part Formatting dialog 491
propagating
part formatting 491, 493
properties 493
properties 156, 357
copying to other layouts 493
notations 157, 357
notes 157, 357
selected items 156
videos 147
Properties panel 50, 156
disclosure arrow 52
Engrave mode 350, 357
hiding 52
showing 52
Write mode 152
pulgar. See thumbs
punctuation
timecodes 1066
verse numbers 883

Q
qualifiers 241, 243
quality
chord symbols 248, 253, 696, 707
transposing 202, 203
quantization
changing 206
dialog 83
importing MIDI 81
MIDI recording 204
requantizing 206
tuplets 83
quarter notes 14, 155
swing playback 548, 549
tempo equations 1218
quarter tones 618, 851
accidentals 618, 857
key signatures 860
octave divisions 856
transposing 198
quartet templates 70
staff grouping 71, 685
quavers. See eighth notes
question marks
harmonics 917
tablature 200, 1188
quintet templates 70
staff grouping 71, 685
quintuplets. See tuplets

R
rallentando. See gradual tempo changes. See also
tempo marks
ranges
arpeggio signs 270, 271, 945
bar numbers 650
colors 905
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ranges (continued)
copying notes 339
cues 742
dynamics in playback 786
flow heading changes 379
glissando lines 955
instruments 112
lines 292, 944, 1042
master page changes 377
metronome marks 1212, 1213
notes 905
page number changes 376
pages 596, 598
percussion legends 1288
selecting 322
slurs 1133
swapping 340
unison 1181, 1182
rasterizing. See staff size
rastral size 452
rates
frames 151
ratios
grace notes 828
note spacing 426, 427
swing playback 549
tuplets 1271–1273
recent projects 72
recipes 601
recording
click settings 207
count-in 208
input pitch 174
MIDI 204, 208, 546, 557
retrospective recording 206, 557
tempo 546
Recover Auto-saved Projects dialog 91
recovering 206
backups 92
files 91, 92
notes 206
rectangle
bar number enclosures 647, 648
chord enclosures 1192
note enclosures 1192
noteheads 890
rehearsal mark enclosures 1052, 1053
text enclosures 419
reducing 340, 470. See also condensing
reduction 134
regions
bar repeats 1086
chord symbols 707
counts 1102
dynamics 513
engraving options 1087
Play mode. See colored regions
slashes 1095, 1099
register
changing 200, 201, 203
clefs 257, 258, 725, 731
cues 747, 750
note input 174

register (continued)
octave lines 259, 732
plug-ins 501
transposing 201, 731
rehearsal marks 1051
cues 317
default settings 1052
deleting 1056
enclosures 1052, 1053
engraving options 1052
filter 326
font styles 1058
inputting 296
moving 1055, 1056
multiple positions 1055, 1172, 1173
order 1057
padding values 1053
placement 1051
position 1051, 1055
prefixes 1058
sequences 1057
size 1058
staff-relative placement 1051
suffixes 1058
types 1057
vertical positions 1172
relative tempo changes 1204
values 1214
releases
guitar bends 957, 960
handles 964
reloading
video files 148
removing. See deleting
renaming
drum sets 120
flow headings 385
flows 145
instruments 144
layouts 143
master page sets 364
master pages 369
percussion kits 120
player groups 130
players 143
renumbering
layouts 138
repeat barlines 636
appearance 638
exporting 548
inputting 236, 239
MIDI recording 206
number of times played 1084
playback 548
playthroughs 1084
popover 236, 239
start of systems 638
repeat endings 1070
additional endings 304, 306
alignment 1072
appearance 1071, 1075
bar numbers 661–663
default settings 1071
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repeat endings (continued)
deleting 337
engraving options 1071
exporting 548
final segments 1075
frame breaks 1074
handles 1072, 1074
hooks 1076
inputting 301, 303–306
length 1072, 1074
MIDI recording 206
moving 1073, 1074
multiple positions 1072, 1172, 1173
MusicXML files 1076
number of playthroughs 1070
optional notes. See bracketed noteheads
panel 303, 305, 306
playback 548
playthroughs 1070, 1071
popover 301, 304
position 1071, 1072
segments 1070, 1072
system breaks 1074
text 1075
types 301
vertical positions 1172
repeat jumps. See repeat markers
repeat markers 1077
appearance 1078
bar numbers 661–663
barlines 638, 1081
changing 329
default settings 1078
deleting 337
engraving options 1078
exporting 548
fonts 1078
index 1079
inputting 301, 303, 307, 308
lines 1080
lower case 1078
MIDI recording 206
moving 1082, 1083
multiple 1079
multiple positions 1082, 1172, 1173
number of times played 1084
optional notes. See bracketed noteheads
order 1079
panel 303, 308
paragraph styles 1078
playback 548, 1084
popover 301, 307
position 1078, 1082
size 1078, 1079
staff-relative placement 1083
text 1080
types 301
upper case 1078
vertical positions 1172
word wrapping 1080
repeat sections. See repeat markers
Repeat Structures panel 303
repeating. See copying. See also repeats

repeats
barlines. See repeat barlines
bars 1086
counts 1089
endings. See repeat endings
engraving options 1087
font style 1092
frequency 1091
grouping 1093, 1094
length 329, 1087
markers. See repeat markers
moving counts 1093
optional notes. See bracketed noteheads
playback 1084
repeats popover 301
repitching notes 202
replacing
flow headings 383
fonts 73
master pages 365, 367
replying
comments 343, 345, 347
requantizing notes 206
resetting
appearance 331
bar numbers 658
barlines 693
beaming 666, 669, 672
beams 676
braces 693
brackets 693
chord diagrams 719
chord symbols 704, 713
condensing 485, 486
expression maps 574
fingering slides 807
fingerings 792, 802
items 331
key commands 68
layouts 139
lyric lines 876
note spacing 428, 429, 434
note velocity 523
octave line angles 735
page numbers 377
part layouts 139
percussion maps 584
playback overrides 591
playback templates 564
position 331
secondary beams 676
staff grouping 693
staff spacing 461
tempo 1204
text 417
velocity 523
volume 546
resolution
images 609
rhythmic grid 52, 166
respelling
accidentals 200
chord symbols 712, 713

1371
Dorico Pro 3.1.10

Index

respelling (continued)
notes 190, 200
notes in cues 750
rest grouping. See note grouping
restating
accidentals 621, 622
trill intervals 924
restorative text 1005
rests 38, 1106
alignment 1106
bar count font 1115
bar rests. See bar rests
changing type 1109
colors 1110. See also note and rest colors
condensing 472, 474, 481
consolidation 160, 1108, 1112, 1113
cues 742, 755, 756
default settings 1109
deleting 176, 1110
dotted 160
durations 175
empty bars 1111
engraving options 1109
explicit 1106, 1107, 1109
filling in 176
forcing duration 177
formatting 422
grouping. See note grouping
hiding 1099, 1110, 1111, 1113
implicit 1106, 1107, 1109
inputting 153, 177, 190, 191
moving 425, 1116
multi-bar rests 1109, 1112–1114
notation options 1109
padding 755, 756, 1099
percussion kits 160
placement 1106
position 1106
restoring 1110
showing 1110, 1111, 1113
stemlets. See stemlets
symbols 422
tacet al fine 1114
voices 1106, 1108, 1112, 1116
results 476
condensing 476, 481
retakes. See pedal retakes
retrieving. See recovering. See also retrospective
recording
retrospective recording 206, 557
reverb channels 556
mixer 554
reversing
lines 1046
reviewing
comments 343
rewinding 540
rhythm
locking 202
requantizing 206
slashes. See rhythm slashes
tablature 1189

rhythm dots 178
compound time signatures 1096
consolidation 902, 903
inputting 172, 178
moving 904
number 178
placement 1194
rhythm slashes 1096
tablature 1189, 1194
voices 902, 903
rhythm section
brackets 685
chord symbols 706, 707
staff grouping 685
rhythm slashes 825, 1095, 1299
appearance 1096, 1097
arpeggio signs 947
caret 167, 181
changing number 1102
counts 1102, 1103
default settings 1096
deleting 337
designs 1096
engraving options 1096
filter 326
font style 1089, 1092, 1102
frequency 1103
hiding counts 1103
hiding rests 1099
highlights 1096
inputting 181, 303, 311
moving 1098, 1100
moving counts 1104
panel 303
parentheses 1103
pasting notes into 338
percussion kits 120, 125, 184, 1300
placement 1104
popover 302, 311
regions 1095, 1102
rests 1099
rhythm dots 1096
splitting 1099
staff position 125, 1098
staff-relative placement 1104
stem direction 1097, 1199
stemless 167, 181
stems 1101
type 1299
vertical position 1098
viewing options 1096
voices 181, 341, 1097, 1299
rhythmic cues 743
changing cues into 744
moving 744
position 743, 744
staff position 745
rhythmic feel
changing 550
default settings 549
deleting changes 551
popover 229
signposts 335, 550, 551
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Rhythmic Feel dialog 552
rhythmic grid 52, 166
changing 166
key commands 63, 66
resolution 52, 166
selecting music 325
rhythmic notation 39, 1095
rhythmic position 39
playback 540
rhythmic position-attached lines. See lines
right panel 50
right-foot pedals. See harp pedaling
right-hand fingering 800
arpeggio signs 804, 805
brackets 801
default settings 789
engraving options 789
inputting 213
letters 805
placement 789
popover 216
rim shots. See playing techniques
rips. See jazz articulations
ritardando. See gradual tempo changes. See also
tempo marks
ritenuto. See gradual tempo changes. See also tempo
marks
rolled chords. See arpeggio signs
rolls. See tremolos
Roman numerals
fingerings 810
flow numbers 398
page numbers 376, 974
staff labels 1153
tokens 398
Romantic
trills 937
roots
chord diagrams 715
chord symbols 248, 253, 696, 707
Ross chord symbols 696
rotating
hairpins 776
slurs 1132
round notehead brackets 906
gaps 907
hiding 907
showing 907
rows
dynamics 765
rulers
Play mode 503
rhythmic grid 166
running headers 823
flow headings 447
hiding 447
runs
guitar bends 957

S
salzedo breath marks 834
sample libraries. See sound libraries

sampled trills 937, 938
disabling 938
enabling 938
Save Endpoint Configuration dialog 570
saving 69, 91
audio 84, 88
auto-save. See auto-save
backups 92
character styles as default 413
chord diagram shapes 718
chord symbols as default 704
comments 349
custom playing techniques 1029
endpoint configurations 569, 570
endpoints 570
engraving options as default 359
expression maps 583
folder location 93
graphics files 599, 600
instrument names as default 140
layout options as default 104
master page sets 363
MIDI files 84
MusicXML files 79
notation options as default 160
note input options as default 162
paragraph styles as default 410
percussion kits 1276
percussion maps 588
playback options as default 502
playback templates 566
played notes 206
playing techniques 1031
tonality systems 850
tonality systems as default 851, 854
scale degrees
chord diagrams 715
chord symbols 247
Nashville numbers 248
noteheads 890, 899
scale size
barlines 636
chord diagrams 715
chord symbol components 698, 700, 701
clef changes 728
cues 425–427
fingerings 794, 800
grace notes 425–427, 825, 828
note spacing 425–427
notes 900
ossia staves 1167
printing 596, 607, 608
staves 452–454
string indicators 815
tablature 1189
scales 848
degrees 696, 890, 899
EDO 848
key signatures 839, 840
major 840
minor 840
octave divisions 848
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scissors 153
activating 153
slashes 1099
ties 1226
scoops. See jazz articulations
scores. See layouts
scrapes. See playing techniques
scroll view. See galley view
searching
ensembles 97
instruments 97
key commands 65, 66
Second Viennese School accidental duration rule 621
second voices
adding 179
bar rests 191, 1112
secondary beams 675
changing 676
lines 676
resetting 676
secondary brackets 686
braces 687
hiding 687
showing 687
sub-brackets 687. See also sub-brackets
sub-sub-brackets 688
section players 108
adding 109
divisi 1176, 1177, 1179
editing divisi changes 1180
empty staves 441
ossia staves 1164, 1165
staff labels 1145
unison ranges 1181, 1182
sections
coda 1077
fine 1077
hiding 51
repeat 1077
showing 51
segments
caps 1045
final 1075
glissando lines 953
guitar bends 962, 964
lines 1041
playing technique continuation lines 1019
playthroughs 1071
repeat endings 304, 306, 1071, 1072, 1074
slurs 1128
segno 1077
font 1078
inputting 307, 308
multiple 1078, 1079
sections 1077
size 1078
selecting 53, 320, 322, 328, 331
bars 324
beats 325
blue 783, 1126
changing the selection. See navigation
chords 328
everything 321, 322, 324, 325

selecting (continued)
extending selection 320, 322
filters 326, 328
flows 322
frame handles 388
handles 358
items 164, 320, 322, 332, 351
items behind other items 320
lyrics 865
marquee 53, 321
more 320, 322
notations 53, 321
note spacing handles 432
notes 53, 320, 321, 328, 332
Play mode 496
staff spacing handles 458
status display 52
staves 322
system spacing handles 458
system track 323
tools 52, 53, 153, 496
transposing selections 202, 846
Write mode 153
selectors
music frames 391
semibreves. See whole notes
semiquavers. See sixteenth notes
sends 556
mixer 554
sentence case
repeat marker text 1078
separators
chord symbols 705
fingerings 809
player numbers 487
systems. See system dividers
time signatures 1237, 1245
timecodes 1066
septuplets. See tuplets
sequences
bar numbers 657–659
page numbers 375, 376, 443
rehearsal marks 1057
subordinate 659
types 1057
sets
drum sets. See drum sets
master pages. See master page sets
setting up
audio devices 62, 208, 209
drum sets 120
duplex printing 596
key commands 66
MIDI recording 208
percussion kit note input 185
percussion kits 120
windows 55
workspaces 55
settings 40
audio 62
copying properties 493
default 359, 360
flow-specific 160
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settings (continued)
harp pedals 977
layout-specific 104, 106
MIDI import 81
mouse input 164, 165
note input 162
preferences 62
project-wide 359, 360
videos 147
Setup mode 22, 94
adding players 111
ensembles 111
flows. See flows
instruments. See instruments
layouts. See layouts
panels 50, 94, 95, 98, 101
percussion 120
player groups 129
players. See players
signposts 335
switching 94
sextuplets. See tuplets
shakes. See jazz ornaments
shape
bar number enclosures 647, 648
beaming 670, 675, 679
chord diagrams 714, 717–719, 721
frames 387
guitar bends 962, 964
multi-segment slurs 1130
notehead brackets 911, 914
noteheads 887, 890, 891
rehearsal mark enclosures 1052, 1053
slurs 1128–1133, 1136
ties 1226
tuplet brackets 1267, 1269–1271
sharing staves. See condensing. See also divisi
sharps
filters 326
short
barlines 236, 239, 636
stemlets 677
shortcuts. See key commands
shoulder offset
notehead brackets 914
slurs 1136
ties 1227, 1228
showing. See hiding
signatures
annotations 610
key signatures. See key signatures
printing 610
time signatures. See time signatures
signposts 335
barlines 634, 640, 689
bars 634
bracket and barline changes 689, 690
chord symbols 695, 706, 707
clefs 730
condensing changes 480
cues 742, 746, 758, 759
dynamics 772
exporting 599, 610

signposts (continued)
extra staves 1160
frame breaks 465
harp pedaling 977, 979, 980
hiding 336
key signatures 842
multi-bar rests 1116
note spacing changes 427
ossia staves 1164, 1166
percussion legends 1287
player labels 488
playing techniques 1013
printing 596, 610
showing 336
staff changes 1160
staves 1162
sub-brackets 690
system breaks 465, 467
tempo marks 1209, 1211, 1212
time signatures 1250
tuplets 1268, 1272
silence
hairpins. See niente hairpins
missing sounds 564
muting items 546
notes 1192
playback template 558, 559, 564
simile
dynamics 241, 243, 771
hiding 1018
playing techniques 1018
showing 1018
simple time signatures 1237
single bar rests
bar counts 1113
H-bars 1113
hiding 1111
showing 1111
single barlines 636
single-digit numbers
tablature 1193
single-line
percussion kits 1281, 1282
staves 1158
single-note tremolos. See tremolos
single-voice contexts 1294
articulations 625
grace notes 826
guitar pre-bends 961
stem direction 826, 1196
tie curvature direction 1233
six-line staff
tablature. See tablature
sixteenth notes 14, 155
swing playback 229, 548, 549, 552
size
arpeggio sign fingerings 804
audio buffer 208, 209
bar numbers 651, 652
chord diagrams 715, 723
clef changes 728
coda symbols 1079
cues 742, 743
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size (continued)
fingerings 794, 797, 804
flared hairpins 778
frames 387
fret numbers 723
gaps 126, 1141, 1232
grace notes 825, 828, 900
H-bars 1114
left-hand fingering 800
line text 1047
lyrics 870, 884
metronome marks 1209
multi-bar rests 1114
noteheads 887
notes 742, 900
ossia staves 1167
pages 104, 436, 607
paper 607, 608
playing techniques 1008
rastral 452
rehearsal marks 1058
repeat markers 1078
segno symbols 1079
space 452
staff labels 1147
staves 104, 438, 452, 453
string indicators 814, 815
system objects 438, 452, 453
tempo marks 1209
time signatures 1240, 1242
tracks 510, 539
unit of measurement 62
video window 150
slants
beams 669, 830
octave lines 734, 735
pedal line hooks 1000
slash notation 1095
slash regions 1095
chord symbols 706, 707, 1095
counts 1102, 1103
default settings 1096
deleting 337
engraving options 1096
filter 326
font style 1089, 1092
handles 1101
hiding other notes 1098
hiding rests 1099
highlights 1095, 1096
inputting 311
length 1101
moving 1098, 1100
moving counts 1104
multiple 1097
overlapping 1097
parentheses 1103
placement 1104
popover 302
rests 1099
showing other notes 1098
staff position 1098
staff-relative placement 1104

slash regions (continued)
stem direction 1097
stems 1101
vertical position 1098
viewing options 1096
voices 1097, 1299
slash voices 1299
caret 167, 181
default settings 1096
engraving options 1096
hiding stems 1201
inputting 181
moving 1098
multiple-voice contexts 1097
percussion kits 120, 184, 1300
popover 302
regions 302, 1095
staff position 1098
stem direction 1199
stemless 167, 181
vertical position 1098
slashes 825, 1095
grace notes 825, 826, 828, 829
length 829
noteheads 887
notes. See tremolo strokes
regions. See slash regions
stemless 1299
stems. See tremolo strokes
time signatures 1245
tremolos. See tremolo strokes
voices. See slash voices
slides
fingerings. See fingering slides
pitch. See glissando lines. See also pitch bends
slur segments 1128, 1130
number 1128
slurs 1118, 1222
accidentals 1142
angles 1132
arpeggio signs. See curved arpeggio signs
articulations 626, 1122
collision avoidance 1124, 1142, 1143
control points 1129
cross-staff 1123, 1142
cross-voice 1123
cues 753
curvature 1118, 1120, 1122, 1137, 1138, 1141
dashed 1139–1141
default settings 1122
deleting 337
dotted 1139–1141
duration 1144
East Asian elision 885
editorial 1139
endpoints 1121, 1129, 1131
Engrave mode 1129
engraving options 1122
filter 326
fingerings 794
flat slurs 1141
formatting 1131, 1133, 1140, 1141
frame breaks 1143
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slurs (continued)
gap size 1141
grace notes 826, 1119, 1120
handles 1128–1130, 1133
height 1134, 1135
inputting 212, 1123–1125
inverting 1118, 1120, 1138
large pitch ranges 1133
length 1126
linking 329, 1126, 1127
moving 1125, 1131, 1132
multi-segment 1130
muting 546
nested 1122
nested slurs 1124, 1125
notehead brackets 912
ornaments 928
overlapping 1142, 1143
panel 155
placement 740, 1118, 1120, 1138
playback 212, 543, 1144
position 740, 1118, 1121, 1122
ranges 1133
rotating 1132
segments. See slur segments
selecting 320
shape 1128, 1130–1133, 1136
short 1133
shoulder offset 1136
staff lines 1121
styles 1139, 1140
system breaks 1143
thickness 1122, 1133
ties 1119, 1120, 1122
ties vs. slurs 1222
tucking index 740
unlinking 329, 1127
within slurs 1124, 1125
small notes 900
cues. See cues
staves. See staff size
smears. See jazz ornaments
smooth
automation 526
dynamics 517
glissando lines 950
jazz articulations 966
slur shapes 1129, 1130
tie shapes 1226
SMuFL 409
dynamic glyphs 786
fingerings 796, 797
multi-bar rests 1115
tokens 397
snare drums
rolls. See tremolos
solfège chord symbols 248
solid
slurs 1139
tempo marks 1216
ties 1230
solo. See divisi. See also text objects

solo players 108
adding 27, 109
adding staves 1161
empty staves 441
extra staves 1160, 1161
ossia staves 1164, 1165
staff labels 1145, 1147
staff size 453
soloing 554
deactivating 545, 554
instruments 545
playback 543
tracks 544
soprano clef. See clefs
sordino. See playing techniques
sorting
layouts 138
sostenuto pedal 986
MIDI controller 1005
sound libraries 558, 583
changing 564
loading sounds 500, 558, 564
missing sounds 564
percussion maps 587
playback 573, 583
trills 937
sounding
duration 1260
percussion legend ranges 1287, 1288
pitch. See sounding pitch. See also concert pitch
sounding pitch 138, 916
harmonics 919
input pitch 174
layouts 137
playback 547
sounds. See playback
soundtracks
audio 150
volume 150
source instruments 742
cue labels 750
source notes 806
space size 452
spacing
accidentals 616
arpeggio signs 945
articulations 627
barlines 640
bracketed noteheads 907
caesuras 264
chord diagrams 715
clefs 726
condensing 449, 470
cross-staff beams 673
cues 425, 743
frame fullness 460
frets 127
galley view 53
grace notes 425
gradual dynamics 780
guitar bends 960
key signatures 843
layout options 104
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spacing (continued)
lyrics 426, 427, 872, 874, 876
notes 425–427, 429
percussion kits 126
rehearsal marks 1051
staves 439, 449, 455
system fullness 431
systems 449
tablature 1189
tacets 470
text 410, 413, 417
time signatures 1237
voice columns 1297
speech bubbles
comments. See comments
speed
arpeggio signs 947, 948
bpm 1212
changing 232, 233, 532, 534, 546, 1212, 1214
frame rates 151
playback 546, 1203
tempo marks 1203, 1212, 1214, 1215
tremolos 1255
trills 930, 937, 939
videos 151
spelling
accidentals 190, 200
notes 190, 200
split point
MIDI import 81
split stems 617
appearance 617
splitting
barline joins 644
bars 634
beams 160, 666
braces 690
brackets 690, 910
flows 342
multi-bar rests 1112, 1116
notehead brackets 910
pedal lines 997
phrases 480, 481
player labels 489
project window 58
repeat marker text 1080
slash regions 1099
staves 307, 308, 1077
ties 1226
tuplets 1264
spreads page arrangement 54, 604
square
accidental brackets 614, 919
bracketed noteheads 906, 907, 911
noteheads 890
squeezes. See jazz ornaments
staccato. See articulations
stacking order 740
accidentals 615, 616
changing 740
lines 1037
numbers in staff labels 1157
octave lines 740

stacking order (continued)
playing techniques 1011
slurs 740
string indicators 814
tuplets 740
staff grouping 71, 684, 685, 689
barline joins 641, 643, 644, 689
braces 689, 690, 692
brackets 689, 690, 692
changing 684
custom 689
default settings 71, 684, 685
ensemble types 684, 685
resetting 693
staff labels 1145
alignment 140
changing first system indent 1175
condensed staves 472, 481, 486, 1153, 1156, 1157
condensing 1147
Cubase 1146
default settings 71, 1147
divisi 1177, 1184, 1185, 1187
engraving options 1147
fonts 1147
formatting 1147
galley view 53
grouping 1153, 1156
hiding 1148, 1149
indents 1149, 1174
instrument change labels 1152
instrument names 139, 140, 144, 397, 1146
length 1148, 1149
MusicXML import 1146
numbering 113, 1146, 1152, 1153, 1157
ossia staves 1170
paragraph styles 410, 1147
percussion 120, 1154, 1281, 1289
project templates 71
showing 1148, 1149
size 1147
systems 1149
tokens 397
transposing instruments 1145, 1150–1152
uppercase 1154
staff lines
erasing 490, 793, 803, 813, 1049
ossia staves 1167
slurs 1121
stem direction 1198
string indicators 813
tablature 127, 1188
thickness 1159
ties 1220
staff position
cues 743, 745
lines 944, 1039, 1042, 1043
note input 185
percussion kits 125, 185
staff size 452
changing 438, 452–454
custom 454
dialog 454
individual staves 453
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staff size (continued)
layouts 1158
MusicXML files 78
ossia staves 1167
rastral size 452
space size 452
staff spacing 351, 455
activating 351
changing 439, 455, 458
condensing 449, 470
copying 462
default settings 439, 456
divisi 439
fullness 460
galley view 456, 458
handles 458
justification 439, 456, 460
layout options 104
moving systems 461
rehearsal marks 1051
reverting 461
text collision avoidance 419
staff-relative placement
articulations 628, 629
bar numbers 655
beaming 668
changing 330
cue labels 330
dynamics 330, 761
fermatas 330
fingering 801
fingerings 792, 793, 805
guitar bends 330
guitar pre-bends 961
harmonics 922
left-hand fingerings 802
lines 1038, 1039
lyrics 881, 882
multi-bar rests 1115
octave lines 330
ornaments 330
pedal lines 992
percussion legends 330
player labels 486
playing techniques 330
rehearsal marks 1051
repeat markers 1083
resetting 331
slash region counts 1104
slurs 1138
string indicators 287–289, 813, 817
text 330
trills 330
tuplet brackets 1270
start area 47
start position
videos 148
start repeat barlines 236, 636
inputting 239
start signs
appearance 999
pedal lines 998, 1003, 1004
text 1004

starting 170
area 47
Hub 69
MIDI recording 204
note input 170, 172
playback 542
players 47
projects 26, 47, 70
timecode values 1067
workspaces 55
status bar 22, 52
selection tools 53
view types 53
status display 52
staves 14, 1158
adding 1160, 1161
adding ossias 1165
arranging tools 336
articulations 629
bar numbers 651, 653, 654
bar rests. See bar rests
barlines 353, 641, 643, 1169
beaming 672–674
braces 690, 692
brackets 71, 684, 685, 690, 692
chord symbols 137, 251, 706, 707, 710
clef for transposing instruments 731
comments 343, 345
condensing. See condensing
copying 1181
copying items 337, 338
crossing notes 672
cues 743, 745
deleting 1159
dialog 454
divider arrows 1183
dividers. See system dividers
divisi 1176, 1177, 1179, 1181, 1184, 1187
divisi labels 1187
dynamics 330
dynamics linking 329, 783
editing divisi changes 1180
ending divisi 1181
exploding 340
extra 1160
fermatas 838
fingerings 793, 803, 805
five-line 1154, 1158, 1281
galley view 60
gaps 1077
grids 1154, 1281
groups 642, 685
hiding 107, 134, 136, 441, 1159, 1189
indents 1149, 1158, 1174, 1175
inputting on multiple 171, 182
instrument change labels 1152
instrument changes 114
labels. See staff labels
large time signatures 1242
layout options 1158
line thickness 1159. See also staff lines
markers 1061
moving 458
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staves (continued)
multi-bar rests 1115
multiple voices 179, 470
notation 1188, 1189
note input 171, 182
notes 339
ossia staves 1164, 1169
page view 60
pauses 834
percussion 1281, 1282
playback 542
player labels. See player labels
preamble 1168
rasterizing. See staff size
reducing 340, 470
rehearsal marks 1172
repeat endings 1172
repeat markers 1083
resetting barline joins 693
resetting bracket/brace grouping 693
selecting 322
showing 60, 134, 136, 441
single-line 1061, 1067, 1069, 1154, 1158, 1281
size. See staff size
slurs 1123, 1126
slurs linking 329
spacing. See staff spacing
splitting 307, 308, 1077
staff labels. See staff labels
stem direction 1198
stem length 1200
string indicators. See string indicators
swapping contents 340
swing playback 550
system breaks 465
system dividers 1171
system objects 1172–1174
tablature 1188, 1189
tacets 467
tempo marks 1172
text 312, 1172
ties 1220, 1224
time signatures 1172, 1241, 1242, 1248, 1249
timecodes 1061, 1067, 1069
unison ranges 1181, 1182
uppercase staff labels 1154
vertical spacing. See staff spacing
vocal 1183
voices 179
width 449, 1163
Steinberg Hub 69
opening projects 72
starting projects 70
video tutorials 69
stem direction 1196
beam groups 1197
beam placement 668, 674
centered beams 671
changing 341, 754, 1097, 1199
chords 1197
condensing 472, 481, 484
cues 754
default settings 1198

stem direction (continued)
drum sets 123
filters 326
grace notes 826, 830
guitar pre-bends 961
middle line 1196, 1198
multiple-voice contexts 1196
notes crossed to other staves 672, 1298
notes on middle line of staff 1196, 1198
percussion kits 120, 123, 160, 186, 1290, 1291
pitch crossing 472, 481
resetting 669, 1200
rhythm slashes 1097, 1199
single-voice contexts 1196, 1199
slur curvature 1118
staff-relative placement 668
tablature 1189
tie curvature 1220
voices 341, 1196, 1199, 1294
stemless
noteheads 1201
rhythm slashes 167, 181, 1299
stemlets 677
removing 678
showing 677
stems 664, 1195
altered unisons 617
articulations 628
attachment points 895
audio 88, 89
beam placement 674
beaming 667
cues 754
custom noteheads 895
default settings 1195
deleting tremolos 1256
direction. See stem direction
engraving options 1195
flag design 1195
flags 422, 1195
formatting 422
grace notes 828, 830
handles 1201, 1257
hiding 1201
length 830, 1195, 1200, 1201
middle line direction 1198
multi-note tremolos 1259
noteheads 895
removing direction changes 1200
rhythm slashes 1097, 1101, 1299
slur endpoints 1121
split stems 617
staccato position 627
stemlets. See stemlets
symbols 422
tablature 1189
thickness 1195
tremolos 1253, 1254, 1257
tuplet placement 1261
voices 1196, 1199
step input. See note input
stickings 1280

1380
Dorico Pro 3.1.10

Index

stopped pitch 916
harmonics 919
stopping. See starting
stopping finger. See left-hand fingering
straight lines
glissando lines 950
guitar bends 957
jazz articulations 970
straight playback. See swing playback
stress marks. See articulations
strikethrough text 313, 410, 413, 415
string designation. See string indicators
string indicators 813
appearance 797, 1022
default settings 814
deleting 817
duration 1014, 1015
engraving options 814
fingering 814, 819
font 797, 813, 1022
grace notes 815
handles 818
horizontal position 819
inputting 277, 280, 287–289
inside staff 289, 813, 817
length 818
lines 287, 288, 815, 1015
moving 818, 819
open 814
outside staff 287, 288, 813
panel 280, 288
placement 817
popover 277, 280, 287
position 817
size 814, 815
string instruments 112, 116
fingering shifts 811
playing techniques. See playing techniques
specifying string 904
substitution fingering 789
string pitches
changing 128
fretted instruments 128
string shift indicators 811
angles 811
direction 811, 904
thickness 811
strings
adding 127
bends. See guitar bends
changing 904, 1190
changing pitch 127
chord diagrams 714, 719, 721
deleting 127
fingering 904
fretted instruments 97, 116, 127
harmonics 916
indicators. See string indicators
notes out of range 905, 1190
numbers. See string indicators
resetting 1190
tuning 97, 116

strokes
slurs 1139
ties 1230
tremolos 1253–1255, 1257
strumming
fingering 804
styles
appearance 331
breath marks 834
caesuras 834
fermatas 832
fonts 407
glissando lines 950, 952
jazz articulations 970
margins 435
niente hairpins 770
numbering 1153
page numbers 973
resetting 331
slurs 1139, 1140
tempo marks 1204, 1215
text 410, 413
ties 1230, 1231
time signatures 1243, 1244
sub-brackets 686–688
appearance 688
custom grouping 689, 690
default settings 688
deleting 693
design 688
formatting 353
hiding 687
inputting 690
length 692
resetting 693
showing 687
signposts 690
sub-sub-brackets. See sub-brackets
subito 241, 243
subordinate bar numbers 659
adding 659
appearance 660
subordinate page numbers 376
numeral style 375, 376
subsequent repeats
bar numbers 661, 663
substitution fingering 789
handles 790
position 790
subtitles 102, 381. See also flow headings
suffixes
bar numbers 663
dynamics 771
rehearsal marks 1058
timecodes 1066
suggestions
cues 317
sul ponticello. See playing techniques
sul tasto. See playing techniques
suppressing playback 546
suspensions
chord symbols 248
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sustain pedal 986
continuation lines 1001
Engrave mode 987
handles 987
inputting 279, 284, 285
level changes 284, 286, 987
merging 997
MIDI controller 209, 1005
MusicXML import 1006
popover 279, 284
removing retakes/level changes 992
retakes 284, 286, 987, 989
splitting 997
sustaining instruments 787
SVG files 609
color 603
exporting 599
fonts 603
graphics frames 405
layout numbers 138
swapping
note order 1297
notes 340
pages 381
staves 340
voices 342
swash
arpeggio signs 941
swing playback 548, 549
custom rhythmic feel 552
disabling 551
editing 552
enabling 229, 550
popover 229
ratios 549
rhythmic feel 552
tempo 552
triplets 549
units 552
switching
frame handles 388
handles 358
layouts 19, 43, 55
modes 22
note spacing handles 432
notes to percussion instruments 1279
staff spacing handles 458
tabs 58
syllables
position 872
types 867
symbols
bar repeats 1086, 1093, 1094
bar rests 1116
caret 167
chords 695, 714
coda 1079
dialog 422
editing 422
music 422
ornaments 924
pedal lines 998
playing techniques 1007

symbols (continued)
segno 1079
speech bubbles. See comments
syncing
videos to music 148
syncopation
stemlets 677
system breaks 352, 435, 465
automatic 451
bar repeats 451, 466
condensing 474
copying to other layouts 491, 493
deleting 467
divisi 1176
dynamics 777
filter 326
glissando lines 953
hairpins 777
inserting 466
lines 1035, 1041
make into system 466
octave lines 739
playing technique lines 1017
playing techniques 1009
repeat endings 1074
signposts 335, 465, 467
slurs 1143
staff labels 1149
staff size 452
staff spacing 439
ties 1222
system dividers 1171
formatting 422
hiding 1171
showing 1171
symbols 422
width 1172
system formatting 491
copying to other layouts 493
system fullness indicator 431
system objects 1172
layouts 1172
lines 291
positions 1173, 1174
rehearsal marks 1051, 1055
repeat endings 1070, 1072
repeat markers 1082
size 438, 452, 453, 1158
tempo marks 1203, 1205
text 312
time signatures 1241, 1248
system spacing 351, 439, 455
changing 439, 458
default settings 439, 456
handles 432, 458
justification 439, 456
system text 1172
backgrounds 421
borders 419
erased backgrounds 421
inputting 312
moving 418
multiple positions 1173
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system text (continued)
padding 420
staff-relative placement 330
stave positions 1172
system track 323
deleting music 631
hiding 324
inputting bars 239
inputting beats 239
selecting music 324, 325
systemic barlines 639
braces 683, 688
brackets 683, 688
hiding 639
secondary brackets 686, 687
showing 639
sub-brackets 686, 687
sub-sub-brackets 688
systems
bar numbers 646, 654, 655
barlines 639
breaks. See system breaks
casting off 451
changing indents 1175
coda gap 1082
condensed staves. See condensing
dividers. See system dividers
divisi 1176, 1179
end position 433
fixing bars 451
fixing per page 451
formatting 352
fullness. See system fullness indicator
gaps 1077
indents 433, 1149, 1158, 1174, 1175
make into system 466
moving 458, 461
player labels. See player labels
preamble 1168
repeat barlines 638
sections 1077
selecting 320, 322
spacing. See system spacing
splitting 1077
staff labels 1148, 1149, 1175
staff size 452
start position 433
text. See system text
timecodes 1067, 1069
tonality 848
track. See system track
trill marks 930
vertical position. See system spacing
width 433, 449

T
tabla notation 1293
tablature 1188
appearance 1194
beaming 1189
bends. See guitar bends
bracketed noteheads 906, 907

tablature (continued)
caret 167
changing string for notes 1190
chords 1189
clefs 725
dead notes 1192
default notation 172
dives 961
enclosures 1189, 1192, 1193
font style 1194
frets 127
gaps 1189
green notes 1188, 1190
guitar bends 957, 1189
harmonics 917, 919
hiding 1189
lines 1189
note input 187
notes out of range 200, 905, 1188, 1190
open pitches 128
question marks 200, 1188
resetting strings 1190
rhythm dots 1189, 1194
rhythms 1189
showing 1189
spacing 1189
stems 1189
strings 127, 128, 172
ties 1219
trills 929
tuning 116, 127, 129
tables
comments 349
tabs
bar 46
closing 57
groups 58, 59
hiding 44
layouts 55, 56
moving 59
opening 25, 56
order 58
showing 44
showing multiple 58
switching 58
view options 56
tacet al fine 1109, 1114
tacets 36, 467
formatting 467
hiding 469
margins 470
paragraph style 467
removing players from flows 134
showing 469
text 469
tap tempo 230
technique combinations
creating 582
Technique Combinations dialog 580
techniques 1007
endpoint configurations 570
exclusion groups 574
expression maps 574

1383
Dorico Pro 3.1.10

Index

techniques (continued)
percussion 584, 589, 1283, 1285
playback 1028, 1031
templates 70, 71
brackets 71
categories 70, 71
ensembles 97, 111
flow headings 381, 382
master pages 361, 370
new projects 69
opening 18
pages 40, 361, 370
playback 498, 558, 559, 564, 567
players 97, 111
staff grouping 71, 685
staves 71, 685
titles 381
tempo 1203
bpm 1212
changing 534
click settings 207
default 1203, 1209
deleting changes 535
drawing 530
editing 530
equations. See tempo equations
finding 299, 1064
fixed tempo 546, 557
follow tempo 546, 557
inputting 532
marks. See tempo marks
metronome marks 1212
MIDI recording 546
muting in playback 546
Play mode 530
range 1213
recording 546
swing playback 552
tracks. See tempo tracks
tempo changes. See tempo marks
tempo equations 1218
inputting 229, 230
panel 230
popover 229
tempo marks 530, 1203, 1215
abbreviated 1208
absolute tempo changes 230, 1204
alignment 1205
appearance 1204, 1211
barlines 1207
beat units 329, 1212
changing 329, 1208, 1211, 1212
components 1210, 1211
continuation lines 1203, 1215, 1216
dashes 1217
decimal places 232, 233, 1212, 1214
default settings 1204
deleting 1209
engraving options 1204
equations. See tempo equations
filters 326
finding 299, 1064
fonts 1209

tempo marks (continued)
formatting 422, 1216–1218
gaps 1217
gradual tempo changes 230, 1204, 1214, 1215
handles 1206, 1215
hiding 1209
inputting 228, 230, 232, 233
integers 232, 233, 1214
length 1206, 1215
metronome marks. See metronome marks
moving 533, 1205, 1206
multiple positions 1172, 1173, 1205
muting in playback 546
panel 230
parentheses 1210, 1211
placement 1205
playback 548, 1203, 1209, 1213, 1214
poco a poco 1211
popover 228
position 1204, 1205
relative tempo changes 230, 1204, 1214
repeats 548
reset tempo 230, 1204
selecting 320
showing 1209
signposts 335, 1209, 1211, 1212
size 1209
style 1216, 1218
symbols 422
text 329, 1208, 1209
types 228, 230, 1204
vertical positions 1172
Tempo panel 230
tempo tracks 85, 530
dialog 86, 87
exporting 87
importing 85, 86
Play mode 530. See also time track
tenor clef. See clefs
tenuto. See articulations
terminology
British vs. American English 14
note durations 14
text
abbreviated tempo text 1208
alignment 313, 404, 412, 415
backgrounds 421
borders 402, 403, 419, 420
character styles 413, 414
collision avoidance 419
comments 343, 348
cue labels 751
cues 753
dedications 822
default position 419
default settings 312
divisi change labels 1184, 1185
divisi staff labels 1184
dynamics 771, 774
Edit Font Styles dialog 407
editing 315, 402, 415
editor. See text editor
engraving options 312
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text (continued)
erased backgrounds 421, 1050
expressive 760, 771
filter 326
fingerings 798
flow titles 145
formatting 313, 407, 415
frames. See text frames
glissando lines 952, 953
horizontal alignment 404
inputting 312, 386, 402, 1046
leading 410, 411, 417
lines 1035, 1046, 1048
lyrics 867, 870
markers 297, 1060, 1062
missing fonts 73
moving 418
multiple positions 1172, 1173
music fonts 409
overlapping 419
padding 403, 420, 1050
paragraph styles 410, 411, 417
pedal lines 1003–1005
percussion legends 1290
player labels 486, 488, 489
playing techniques 1007, 1011
rehearsal marks 1051
repeat endings 1075
repeat markers 1078, 1080
resetting 417
spacing 410, 413, 417
staff labels 1147
staff-relative placement 330
system text 312, 1172
tacets 469
tempo marks 329, 1208
tokens. See tokens
types 415
uppercase staff labels 1154
vertical alignment 403
word wrapping 489, 1080
text editor 313, 315
comments 345
Engrave mode 415
lyrics 870
opening 402
text frames 402
Write mode 313
text frames 395
borders 402
changing text 402
entering text 402
flow headings 447
horizontal alignment 404
identifying 415
inputting 386
overrides 395
padding 403
paragraph styles 417
running headers 447
selecting 388
vertical alignment 403

text objects 415, 1176
editing 315
identifying 415
theme
changing 61
theorbo. See fretted instruments
thick barlines 236, 636
inputting 239
thickness
bar number enclosure lines 648
barlines 638
borders 403, 420, 981
brackets 686, 688
chord diagrams 715
glissando lines 951
grace note slashes 828
gradual tempo changes 1218
guitar bends 960
lines 359
notehead brackets 907
pedal lines 1002
rehearsal mark enclosure lines 1053
slurs 1122, 1133, 1140
staff lines 1159
stems 1195
string shift indicators 811
text borders 403, 420
ties 1221, 1232
thru
MIDI 204
thumbs 800
fingerings 800, 805
inputting 216
popover 214, 216
tick
barlines 236, 239, 636
breath marks 834
tie chains 1219
articulations 626, 1219
bracketed noteheads 909
clefs 726
deleting 1225
glissando lines 956
selecting 1219
slurs 1119, 1120, 1122
splitting 1226
tablature 1219
tremolos 1254
ties 38, 1219, 1222
accidentals 1223
appearance 1230
articulations 626, 629, 1219
bracketed noteheads 909
breaking 1226
cautionary accidentals 614, 919
chains. See tie chains
chords 1233
clef changes 1223
clefs 726
collision avoidance 1220
cross-staff 1224
cross-voice 1224
cues 755
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ties (continued)
curvature direction 1221, 1233, 1234
dashed 1230, 1232
default settings 1221
deleting 1225, 1226
dotted 1230, 1232
editorial 1230
engraving options 1221
forcing 177
formatting 1226, 1231, 1232
frame breaks 1222
gap size 1232
guitar bends 960
half-dashed 1230
handles 1226, 1227, 1229
height 1229
inputting 153, 192, 1224
inverting 1234
laissez vibrer 1224, 1225
non-adjacent notes 1223, 1224
non-standard types 1222
note grouping 177
notehead brackets 912
parentheses 909
placement 1220
position 1120, 1220, 1221, 1226
shape 1226
shoulder offset 1227, 1228
slurs 1119, 1120, 1122
slurs vs. ties 1222
solid 1230
splitting 177, 1226
staff lines 1220
style 1230, 1231
system breaks 1222
tablature 1219
tie chains. See tie chains
time signature changes 1223
time signatures 1219
tremolos 1254
voices 1220, 1233
width 1226
TIFF files 609
color 603
exporting 599
layout numbers 138
resolution 609
time
display 557, 558
latency 204, 208
markers 1060
rhythmic position 39
signatures. See time signatures
track. See time track
transport window 557, 558
videos 148
time and date
annotations 610
exporting 599
printing 596
tokens 400
time bars. See repeat endings

time signatures 1235
above staff 1241
additive 1237
aggregate 1237
alignment 1248
alternating 1237
appearance 1236, 1237, 1251
bar numbers 656
barlines 643, 1248
beam grouping 39, 160, 665, 682
beat groups 39, 160, 1243
bracketed groups 1241
changing 329, 634
click 204
compound 1237
custom 1237
default settings 1237
deleting 1250
denominators 1237, 1244
design 1251
engraving options 1237
filter 326
font 1236
font styles 1251
formatting 422
height 1236
hiding 1250
inputting 31, 222, 226, 227, 634
Insert mode 634
interchangeable 1237
irregular 1237
large 1240
MIDI recording 204
moving 1247–1249
multiple positions 1172, 1173
non-power of two 1237
note grouping 39, 665, 681
noteheads 1244
numerators 1237, 1243
open 1237, 1244
panel 224
parentheses 222, 226, 1245
pick-up bars 222, 226, 227, 1237, 1239, 1240
placement 1236
polymeter 226, 227
popover 222
position 226, 227, 1242, 1246, 1249
rest grouping 665, 681
rhythm slashes 1096
separators 1237, 1245
showing 1250
signposts 335, 1250
simple 1237
size 1242
spacing gaps 1237
styles 1243, 1245
symbols 422
system objects 1241
ties 1219, 1223
types 222, 1237
upbeats. See pick-up bars
vertical position 1240, 1242, 1249
vertical positions 1172, 1173
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Time Signatures (Meter) panel 224
time track 85, 530
changing tempo 534
collapsing 539
deleting tempo changes 535
expanding 539
inputting tempo changes 532
moving tempo changes 533
timecodes 1066
changing 147, 1063, 1067
dialog 147
drop frame 1066
flows 101
font style 1063
frequency 1069
hiding 1068
inputting 297
markers 297–299, 1068
non-drop frame 1066
offset 1067
panel 297
showing 1068
staff 1061, 1067
staff spacing 439, 456
start values 1067
tempo 299
transport window 557, 558
vertical position 1067
times played
changing 1084
timpani
key signatures 97
title case
repeat marker text 1078
staff labels 1154
title pages
adding 365, 377, 441
editing 371
exporting 363
importing 363, 367
text tokens 396
titles
accidentals 397
adding 102
changing 102, 145
default master pages 821
flow headings 447
flows 145, 381
hiding 445, 447
movements 381
projects 145
running headers 447
showing 445, 447
templates 381
text tokens 396
tokens 396, 415
accidentals 397
date 400
file names. See ingredients
flow headings 381–383
flow numbers 381–383
flows 145, 398
inputting 396, 402

tokens (continued)
master pages 365, 821
music symbols 397
page numbers 399
project information 102, 145, 398
Roman numerals 398
SMuFL 397
staff labels 397
time 400
titles 145
tonality systems 848
accidentals 853, 857
changing 849
creating 851
custom. See custom tonality systems
exporting 850
importing 850
key signatures 854, 860
octave divisions 848, 856
panel 217, 221
playback 862
tongue clicks. See playing techniques
toolbar 19, 43
hiding 43
transport options 43, 44
workspace options 43, 44
toolboxes 20, 51
Engrave 351
Notations 152, 158
Notes 152, 153
Play 495, 496
tools
arranging. See arranging
selecting 52, 53
timecodes 1066
touched pitch 916
harmonics 919
track names
MIDI import 81
tracks 510
automation. See automation lanes
chords. See chords track
collapsing 539
dynamics. See dynamics lanes
expanding 539
height 539
hiding 539
independent voice playback 543, 571
instruments. See instrument tracks
markers 537
muting 544
piano roll editor 504
playing techniques. See playing techniques lanes
showing 539
soloing 544
system 323
tempo. See tempo tracks. See also time track
time. See time track. See also tempo tracks
types 510
velocity. See velocity lanes
video 538
voices 543
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transition lines 1015, 1033
appearance 1019, 1022
automation 526
default settings 1022
duration 1016
dynamics 517
hiding 1019
inputting 277, 281, 283
playing techniques 1020, 1029
showing 1019, 1021
translation lyrics 865
changing lines to 880
changing lyrics to 866
popover 294
transport 557
basic options 43, 44
playhead 540
playhead position 557, 558
repeats 548
window 42, 557
Transpose dialog 202, 203
transposed pitch 138
chord symbols 137, 712, 713
clefs 729–731
filters 327
input pitch 174
instrument numbering 1152
instrument transpositions 1150
layouts 137
note input 174
part layouts 134, 137
showing 137
staff labels 1145, 1150
status display 52
viewing 137
transposing 203
accidentals 203
chord symbols 137, 202, 203, 705
clefs 731, 756
cues 750, 756
dialog 203
expression maps 573
instruments. See transposing instruments
key signatures 202, 203, 842, 846
layouts 134, 138
notes 198, 200–203, 508
octaves 200
pitch. See transposed pitch
popover 198
selections 202
staff labels 1151
transposing instruments 115, 137, 731, 1145
chord symbols 712, 713
clefs 97, 729–731
concert pitch 137, 138
cues 747
instrument numbering 1152
instrument transpositions 1150, 1151
key signatures 138, 160, 840, 842, 847
layouts 137, 138
register in cues 747
staff labels 1145, 1150, 1151
transposed pitch 137, 138

tre corde 986
treble clef. See clefs
trees
stems 617
tremblements 924
tremolo strokes 1253, 1255
changing number 1254, 1255
formatting 422
moving 1257
symbols 422
tremolos 1253
angles 1255
appearance 1258, 1259
articulations 589
default settings 1258
deleting 1256
duration 1259
engraving options 1258
formatting 422, 1259
inputting 302, 303, 308, 310
measured 1253
moving strokes 1257
multi-note 302, 1253, 1259
number of strokes 1254
panel 303, 310
placement 1255
playback 543, 589, 1259, 1260
popover 302, 308
position 1255, 1257, 1258
single-note 302, 1253
speed 1255
strokes. See tremolo strokes
symbols 422
tie chains 1254
tuplets 1253
types 302, 1253
unmeasured 1253
voices 1259
triangle noteheads 889
showing 898
trill intervals 932, 933, 937
accidentals 935
appearance 924, 935, 936
auxiliary notes 935
changing 934
hiding 933
Hollywood-style 935
indicators 932
microtonal 933
position 937
restatement 924
showing 933
trill lines 930, 931
hiding 931
length 932
showing 931
speed 930, 931
trills 924, 929, 937
accidentals 935, 937
alignment 928
appearance 935, 936
auxiliary notes 935
deleting 337
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trills (continued)
extension lines. See trill lines
filter 326
generated 938
grace notes 937
handles 927, 932
hiding marks 930
Hollywood-style 935
inputting 266, 268
intervals 266, 932, 933, 935, 937
length 927, 932
lines. See trill lines
moving 926
NotePerformer 938
parentheses 924
pitch 939
placement 926
playback 937–939
popover 266
position 926, 928
sampled 938
speed 930, 937, 939
staff-relative placement 330
start position 928
starting pitch 939
tablature 929
trimming flows 235, 632
triple accidentals
respelling 200
transposing 203
triple barlines 236, 636
inputting 239
triple-dotted notes 178
triplets 1261
inputting 153, 195, 196
swing playback 548, 549
tucking index 740
changing 740, 1011, 1037
lines 1037
playing techniques 1011
tuning
chord diagrams 717, 718
dialog 127
exporting 129
fretted instruments 97, 116, 127
guitar 97, 116, 127
importing 129
open pitches 128
playback 547
strings 128
systems. See tonality systems
tuplet brackets 1267
angle 1269
end position 1270
handles 1267, 1269
hiding 1268
hooks 1267
horizontal 1271
length 1267
moving 1267
position 1261
showing 1268

tuplet numbers 1271, 1272
appearance 1272, 1273
font 1273
hiding 1272
horizontal position 1273
tuplet ratios. See tuplet numbers
tuplets 1261
accidentals 188
appearance 1262, 1268, 1271, 1272
articulations 210, 626
barlines 1264
beams 677, 1267
beat units 196
brackets. See tuplet brackets
default settings 1262
deleting 1264, 1266
end position 1270
engraving options 1262
filter 326
formatting 422, 1272
handles 1267, 1269
hiding 1272
hooks 1267
horizontal brackets 1271
inputting 195, 1262, 1263
inverting 1270
moving 1265, 1267, 1273
nested tuplets 1262
notes 1263
numbers. See tuplet numbers
percussion kits 1279
placement 740, 1261
popover 195, 196
position 740, 1261, 1262
quantization 83
ratios. See tuplet numbers
showing 1272
signposts 335, 1268, 1272
slurs 212
staff-relative placement 1270
swing playback 548, 549
symbols 422
tremolos 1253
tucking index 740
turning into normal notes 1264
turning notes into 1263
types 196, 1261
unscaling 1264
Turkish music
octave divisions 848
turns 924
intervals 925
jazz. See jazz ornaments
pages. See frame breaks
tutorials 69
tutti 1176, 1181
restoring 1181
two-up page arrangement 604
types
appearance 331
arpeggio signs 266
articulations 967
bar repeats 302
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types (continued)
barlines 636
breath marks 260, 834
caesuras 260, 834
caret 167
chord symbols 247, 696
clefs 255
dynamics 241, 760
enclosures 647, 648, 1052, 1053
fermatas 260, 832
fingerings 214, 809
glissando lines 267
grace notes 828
holds 260, 832
jazz articulations 266, 267, 966, 967, 970
key signatures 216
lines 1033, 1035
lyrics 294, 865, 866
master pages 365
notehead sets 886
noteheads 887, 890, 891
notes 155
octave lines 256, 732
ornaments 265, 967
pauses 260, 832
pedal lines 279, 986
percussion legends 1289
playing technique lines 1017, 1019
playing techniques 277, 1007
rehearsal marks 1057
repeat endings 301
repeat markers 301
resetting 331
rhythm slashes 1299
syllables 867
templates 71
tempo marks 228, 230, 1204
text 415
ties 1230
time signatures 222, 1237, 1245
tracks 510
tremolos 302, 1253
tuplets 196, 1261

U
ukulele. See fretted instruments
una corda pedal 986
appearance 1005
MIDI controller 1005
text 1005
unassigned instruments
loading sounds 564
uncompressed MusicXML 79
underlines
fingerings 795
text 313, 410, 413, 415
ungrouping
dynamics 783
playing techniques 1021
unison ranges 1181
colors 1182

unisons 1176
altered. See altered unisons
arranging 340
deleting 340
divisi 1181
restoring 1181
units
beats 147, 230, 299, 329, 1212
measurement 62
metronome marks 329, 1212
quantization 83
rhythmic grid 166
swing 552
swing playback 549
system track 323
tempo 230, 299
time 147, 557
tuplets 196
video 147
Universal Indian Drum Notation 1293
unlinking
dynamics 785
music frames 393
slurs 1127
unmeasured tremolos. See tremolos
unpitched percussion 1275
articulations 589, 1279
cues 743, 744
default settings 1277
drum sets. See drum sets
dynamics in kits 1280
engraving options 1277
exporting kits 1276
ghost notes. See bracketed noteheads
grid kit presentation 123–126
groups 123
importing kits 1277
Indian drum notation 1293
individual instruments 1275
instrument order 125
kits. See percussion kits
legends 1287, 1288, 1290
MIDI files 1292
moving notes 1279
MusicXML files 1292
naming groups 124
notation options 1278
notations 1279
note input 184–186, 505
noteheads 1283, 1286
parentheses. See bracketed noteheads
percussion maps 572, 583, 584
Play mode 505, 1292
playback 572, 583, 584, 589, 1283
playing techniques 589, 1278, 1280, 1283, 1285
presentation types 120, 1275, 1281, 1282
rhythm slashes 120, 1300
scrapes. See playing techniques
staff labels 1154
staves 120, 1281, 1282
stem direction 120, 186, 1290, 1291
stickings 1280
techniques. See playing techniques
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unpitched percussion (continued)
tremolos 589
tuplets 1279
voices in kits 1290, 1291
unscaling tuplets 1264
up arpeggio signs. See arpeggio signs
up-bow breath marks 834
up-stem voices. See voices
upbeats. See pick-up bars
upper case
flow numbers 398
repeat marker text 1078
Roman numerals 398
staff labels 1154
upper notes
trills 939
user account
comments 348
user interface 19, 42
music area 20
panels 21
status bar 22
toolbar 19
toolboxes 20
transport options 44
windows 42
user name
comments 343

V
value line
automation 523, 526
dynamics 513, 517
tempo 530
values
frame rates 147
latency compensation 208
metronome marks 329, 1212
notes. See note durations
rhythmic grid 52, 166
timecodes 147, 1067
valves
fingerings 809
velocity
changing 522
expression maps 574
lanes. See velocity lanes
MIDI import 81
velocity lanes 513, 521, 522
changing velocity 522
hiding 522
resetting velocity 523
showing 522
verse numbers 882
hiding 883
lyric line numbers 879
punctuation 883
showing 883
versions
files 73
vertical alignment
text 403

vertical justification
staves 439, 456
systems 439, 456
vertical lines. See lines. See also arpeggio signs
vertical position
articulations 624, 626–628
bar numbers 654, 655
breath marks 835
caesuras 835
changing 330
chord symbols 710
cues 743–745
dynamics 761, 780
fermatas 835
fingerings 788, 801, 802, 804, 805
flipping items 330
flow headings 381, 446, 447
harp pedal diagrams 982
instruments 110
layouts 138
lines 1011, 1036, 1038, 1039, 1041, 1043
lyrics 863, 865, 872, 874, 876
markers 1060, 1061
modifiers 780
numbers in staff labels 1157
ornaments 926
pauses 834
pedal lines 992
players 110
playing techniques 330, 1008, 1011
poco a poco 780
rehearsal marks 1051, 1055, 1172–1174
repeat endings 1072, 1172–1174
repeat markers 1082, 1083, 1173, 1174
rests 1106
rhythm slashes 1098
slurs 1118
stacking order. See stacking order
staves 439, 456, 458
string indicators 814
system objects 1173, 1174
system text 1173, 1174
systems 439, 456
tacets 470
tempo marks 1172–1174, 1205
text 330, 403, 419, 1172
ties 1220
time signatures 1172, 1240, 1242, 1246, 1249
timecodes 1060, 1061, 1067
tremolos 1255
trills 926
tuplets 1261
vertical spacing
articulations 624, 627
bracketed noteheads 907, 910
frame fullness indicator 460
lyrics 874, 876
ossia staves 1164
percussion kits 126
staves. See staff spacing
systems. See system spacing
tacets 470
text 410, 411
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vertical stacking order. See stacking order
vibrato. See playing techniques
Video Properties dialog 147
videos 69, 146
adding 148
audio 150, 554
dialog 147
flows 101
formats 146
frame rates 151
hiding 149
locating 148
markers 537, 1060
mixer 554
panel 297
reloading 148
removing 150
size 150
start position 148
syncing 148
timecodes 1066, 1067
track 538
tutorials 69
volume 150
window 149, 150
Viennese accidental duration rule 621
view options 53, 610
bar numbers 651
bar repeats 1089
changing 52
chord symbols 706, 710
comments 343, 349
condensing 490
cues 758, 759
divisi 1182
exporting 610
frame break signposts 465
full screen mode 60
galley view 53, 60
harp pedaling 905
layouts 46, 55
mixer 556
moving music 333, 334
music area 47, 54, 60
notes 490, 1295
notes out of range 905
page arrangements 52, 54, 60
page view 53, 60
panels 24, 50
percussion legends 1287
playhead 541, 558
printing 610
rests 1110
signposts 336
slash regions 1096
system break signposts 467
system track 324
tabs 46, 55, 56
time signature signposts 1250
timecode 558
tracks 510, 539
transport 558
types 53

view options (continued)
unison ranges 1182
video window 149
voices 1294, 1295
windows 59
zoom 55, 334, 510
vivace. See tempo marks
vocal staves
barlines 71
brackets 71
divider arrows 1183
staff grouping 71, 685
staff labels 1147, 1154
title case 1154
uppercase 1154
voice colors
exporting 610
printing 610
voice column index 1294, 1297
default settings 160
ledger lines 902
note spacing 432
swapping order 1297
voices 1294
accidental stacking order 615
adding 179
alignment 1294
articulations 625
automation 523
bar rests 191, 1112
beaming 1197
caret 167, 179
changing 338, 341, 342, 1299
chord symbol playback 536
colors 1294, 1295
column index 1297
condensed staves 472, 474, 476, 481, 484, 1157
copying 338
creating new 179
cues 754
deleting 1296
direction 1097
divider arrows 1183
drum sets 123
dynamics 244, 245, 513, 769
endpoints 571
fermatas 834, 838
filters 326
flows 571
grace notes 826
hiding 1098
identifying 52, 1295
inputting 179, 505
ledger lines 902
merging 340
MIDI recording 206
moving notes 339
notation options 1295
note spacing 432
octave lines 259
order 160, 1297
parts. See layouts
pasting notes into 338
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voices (continued)
percussion kits 1290, 1291
piano roll editor 504
pitch crossing 472, 481
placement 1294
playback 543, 571
playing techniques 281, 283
position 1294
rests 1106, 1108, 1116
rhythm dots 902, 903
rhythm slashes 181, 1097
selecting 320
showing 1098
slash regions 1098
slashes 181, 341, 1097, 1299
slurs 1118, 1123
status bar 52
stem direction 1196, 1199, 1290, 1291, 1294, 1298
swapping contents 342
swapping order 1297
switching between 179
ties 1224, 1233
tremolos 1259
volta lines. See repeat endings
volume
channel meters 554
dynamics 760, 786
metronome click 207
MIDI 787
mixer 554
playback 574, 786
resetting 546
silence playback template 558, 559
velocity 574
video audio 150
VST and MIDI Instruments panel 495, 498
VST instruments 498
editing 498
endpoints 566
instances 498
loading 500
microtonal playback 862
names 567
numbering 498
percussion maps 572
playback 566, 573, 583
playback templates 558, 559
ports 567
whitelisting VST 2 plug-ins 501

W
walker noteheads 890
showing 898
warnings
audio engine 52
deleting players 95, 111
different Dorico versions 73
MIDI input 52
missing fonts 73

watermarks 610
exporting 599
font style 407
printing 596
WAV files
exporting 88, 89
wavy lines. See wiggly lines. See also lines
wedge lines 290, 1033
hiding 1018
inputting 291
showing 1016, 1018, 1019, 1045
wedge noteheads 889
showing 898
weight
tuplet numbers/ratios 1273
Western tonality
key signatures 839
octave divisions 848
white noteheads 886, 887
whitelisting plug-ins 501
whole notes 14, 155
whole step trills 932, 937
appearance 935
hiding 930, 933
position 937
showing 930, 933
whole tone chord symbols 249
width
accidentals 616
barlines 636
braces 686, 688
brackets 686, 688
empty bars 633
enclosures 648, 1053
extra staves 1163
flared hairpins 778
frames 387, 406
graphics 701, 857
guitar bends 960
H-bars 1112, 1114
hairpin aperture 777
hairpins 766
ledger lines 615, 901
multi-bar rests 1114
note durations 425, 590. See also note spacing
notehead brackets 907, 914
noteheads 889
ossia staves 1167
system dividers 1172
systems 433, 449
text borders 403, 420
ties 1226
wiggly lines 950, 1033
glissando lines 950, 952
hiding 1018
inputting 270–274, 291
jazz articulations 970
playing techniques 1019
showing 1016, 1018, 1045
trills 930, 931
wildcards 396
wind instruments
playing techniques 280
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windows
floating 43
mixer 554, 556
moving tabs 59
multiple 56, 58, 59
opening 26, 59
playback 59
project 42
splitting 58
tabs 58
transport 557
video 149, 150
VST instruments 498
workspaces 55
winged brackets 689
workflow
comments 343
workspaces 35
key commands 16, 66
options 43, 44
preferences 62
setting up 55
wrapping text
player labels 489
repeat markers 1080
Write mode 22, 152
caret 170
inputting notations 210
inputting notes 167
inputting vs. editing 164
navigation. See navigation
notation options 160
note input options 162
panels 50, 152, 155, 156, 160
popovers 37
selecting 320, 322, 324, 325
selecting notes 332
signposts 335
switching 152
system track 323
text editor 313
toolboxes 51, 152, 153, 158
Transpose dialog 203

zoom (continued)
lyrics 870
options 52, 55, 334
piano roll editor 510
slash regions 1096

X
X-noteheads 888
dead notes 1192
showing 898

Z
zero
string indicators 813, 814
zig-zag arrangement
accidentals 616
zoom 52
bar repeats 1089
changing 334
chord symbols 710
cues 758, 759
drum editor 510
event display 510
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