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Thank you very much for purchasing Dorico Pro.

We are delighted that you have chosen Steinberg's scoring application and hope that you will
enjoy using it for years to come.

Dorico is a next-generation application for producing beautiful sheet music, whether you are a
composer, arranger, music engraver, publisher, instrumentalist, teacher, or student. Whether
you want to print your music or share it in a digital format, Dorico is the most sophisticated
program available.

Like all of Steinberg's products, Dorico has been designed from the ground up by a team of
musicians who understand your needs and who are dedicated to producing a tool that is both
easy to learn and use, but also capable of results of the highest quality. Dorico also integrates
with your existing workflow and can import and export files in a variety of formats.

Dorico thinks about music the same way a human musician does and has a deeper
understanding of the elements of music and musical performance than other scoring
applications. Its unique design allows an unprecedented degree of flexibility, in music input and
editing, in score layout, in rhythmic freedom, and many other areas besides.

Most sincerely yours,

Your Steinberg Dorico Team

Platform-independent documentation
This documentation applies to the operating systems Windows and macOS.

Features and settings that are specific to one of these platforms are clearly indicated. In all other
cases, the descriptions and procedures in the documentation are valid for Windows and macOS.

Some points to consider:

● The screenshots are taken from macOS.

● Some functions that are available on the File menu on Windows can be found in the
program name menu on macOS.

Usage of musical terms
This documentation uses American terminology for musical items.

The following table lists all the notes and notations that have different names in American and
British English:

American Name British Name

Double whole note Breve

Introduction
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American Name British Name

Whole note Semibreve

Half note Minim

Quarter note Crotchet

Eighth note Quaver

Sixteenth note Semiquaver

Thirty-second note Demisemiquaver

Sixty-fourth note Hemidemisemiquaver

Hundred twenty-eighth note Semihemidemisemiquaver

Two hundred fifty-sixth note Demisemihemidemisemiquaver

Staff Stave

Bar/Measure

NOTE

This documentation only uses “bar”.

Bar

Conventions
In our documentation, we use typographical and markup elements to structure information.

Typographical elements
The following typographical elements mark the following purposes.

Prerequisite
Requires you to complete an action or to fulfill a condition before starting a
procedure.

Procedure
Lists the steps that you must take to achieve a specific result.

Important
Informs you about issues that might affect the system, the connected hardware, or
that might bring a risk of data loss.

Note
Informs you about issues that you should consider.

Tip
Adds further information or useful suggestions.

Example
Provides you with an example.

Introduction
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Result
Shows the result of the procedure.

After Completing This Task
Informs you about actions or tasks that you can perform after completing the
procedure.

Related Links
Lists related topics that you can find in this documentation.

Markup
Elements of the user interface are highlighted throughout the documentation.

Names of menus, options, functions, dialogs, windows, and so on, are highlighted in bold.

EXAMPLE
To open the Project Info dialog, choose File > Project Info.

If bold text is separated by a greater-than symbol, this indicates a sequence of different menus
to open.

EXAMPLE
Choose Setup > Layout Options.

File names and folder paths are shown in a different font.

EXAMPLE
example_file.txt

Key commands
Key commands are sets of keys that perform defined tasks when pressed together. They are also
known as “keyboard shortcuts”. Many of the default key commands use modifier keys, some of
which are different depending on the operating system.

When key commands with modifier keys are described in this manual, they are indicated with the
Windows modifier key first, followed by the macOS modifier key and the key.

EXAMPLE
Ctrl/Cmd-Z means: press Ctrl on Windows or Cmd on macOS, then press Z.

Key commands in Dorico Pro
The default key commands in Dorico Pro depend on your keyboard layout.

If you move the mouse over a tool or a function, the information in brackets shows the key
command that is used to activate or deactivate a tool or a function.

You can also do one of the following:

● Choose Help > Key Commands to open the Dorico Key Commands window, which
provides an overview of all available key commands.

● Search for key commands of specific functions or menu items in the Preferences dialog. In
this dialog, you can also assign new key commands or change default key commands.

Introduction
Conventions 
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RELATED LINKS
Interactive Dorico Pro key commands map on page 54
Searching for the key commands of functions on page 55
Preferences dialog on page 51
Key Commands page in the Preferences dialog on page 52
Assigning key commands on page 55

How you can reach us
On the Help menu you find items linking to additional information.

The menu contains links to various Steinberg web pages. Selecting one of these menu items
automatically launches your web browser and opens the page. On these pages, you can find
support and compatibility information, answers to frequently asked questions, information
about updates and other Steinberg products, and so on.

This requires that you have a web browser installed on your computer and a working Internet
connection.

Introduction
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This chapter helps you to get started with Dorico Pro.

When you start Dorico Pro for the first time, we recommend that you open one of the templates
first to have a look at the user interface and the functions that Dorico Pro provides before you
start your own projects. You are welcome to skip this part and explore the program for yourself.

The following sections inform you about the following topics:

● Overview of the most important workspaces

● Setting up a new project

● Writing your music and adding notation items to your score

● Laying out and formatting pages

● Playing back what you created

● Printing and exporting

Getting around
The following sections give you an overview of the user interface and introduce you to how
Dorico Pro is structured.

Opening a template
Before you start your own project, we recommend that you familiarize yourself with the user
interface of Dorico Pro. To prepare for this, open one of the templates that are provided with the
program.

PREREQUISITE
You have started Dorico Pro. The Hub is open.

PROCEDURE

1. In the Hub, select one of the listed template groups. For example, select the Choral and
Vocal templates.

2. Select one of the listed templates.

First steps
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3. Click New from Template.

RESULT
The template opens. The players in the template are added to the project and their staves appear
in the music area.

RELATED LINKS
Hub on page 58

Quick tour of the user interface
The user interface of Dorico Pro consists of different modes that represent different phases in
the workflow of preparing a score.

The user interface has a structure that is the same in each of the application’s modes. There is
always a large area for editing your music in the center of the project window. In every mode,
there are collapsible panels on the left, right, and bottom of the project window, depending on
which mode you are using. The contents of these panels change according to the selected mode.

When you open the template, the first view shows the project window in Write mode:

The project window when you open a template

The project window contains the following areas:

Toolbar

The toolbar is located at the top of the project window.

Toolbar

First steps
Getting around 

14
Dorico 2.2.20



On the left side of the toolbar, the modes are displayed. By changing the mode, you change the
workspace and the available panels. The current mode is highlighted in a different color. In the
middle of the toolbar, layout options allow you to switch between the different layouts in your
project and to show/hide panels and tabs.

On the right side of the toolbar, you can open a Mixer and use basic transport controls that,
among other functions, allow you to play back and record your music.

Show Mixer button

Music area

The music area is the main part of the project window in Setup, Write, and Engrave modes where
you set up, input, edit and format your music. In Play mode, this area is called event display, in
which every note is displayed as an event. In Print mode, this area is called print preview area,
which shows a preview of what is going to be printed or exported as a graphic.

The music area in Write mode after starting a new project from a choral template

The music area displays the scores or the instrumental parts that you create. Above the music
area you can activate several layouts in tabs and switch between them. Layouts in Dorico Pro
allow you to show different presentations of your music. If you have a full score with different
instrumental parts, such as a violin part and a bassoon part, you can switch between that full
score layout and the layouts of each part. To save space on the screen or to focus on a specific
layout, you can hide the tabs.

Toolboxes

Toolboxes are the columns on the left and right edges of the project window. They contain
different tools and options according to the current mode, but in general they allow you to input
and modify notes, notation items, and frames, and to determine which options are shown in
their corresponding panels.

First steps
Getting around 
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Notes toolbox in Write mode

Notations toolbox in Write mode

Panels

Dorico Pro provides panels with various functions in all modes. When you open the template,
there is a panel on the left of the music area. This is the Notes panel in Write mode. It contains all
the durations, accidentals, slurs, and articulations that are most commonly used when inputting
notes.

Notes panel in Write mode

First steps
Getting around 
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Status Bar

At the bottom of the project window, a status bar allows you to select different views and page
arrangements for the music area. It contains different options in different modes.

Status bar

RELATED LINKS
User interface on page 33
Mixer on page 443
Transport window on page 446

Functions of the modes
Each mode represents a different phase in the workflow of preparing scores and parts, so
contain different toolboxes, panels, and functionality from each other.

Setup mode

In Setup mode, you can create players and groups of players, and assign instruments to them.
You can define different layouts for your project that you can print or export independently. For
example, you can print or export a layout for the full score and separate layouts for each
instrumental part.

You can view music in the music area and switch between viewing other tabs and layouts, but
you cannot select or interact with anything in the music area.

You can switch to Setup mode in any of the following ways:

● Press Ctrl/Cmd-1.

● Click Setup in the toolbar.

● Choose Window > Setup.

Write mode

In Write mode, you can input and edit your music, including changing the rhythmic positions of
items, changing the pitch of notes, and deleting notes and items. The available toolboxes and
panels allow you to input all the notes and notation items that are most commonly used.

You can switch to Write mode in any of the following ways:

● Press Ctrl/Cmd-2.

● Click Write in the toolbar.

● Choose Window > Write.

Engrave mode

In Engrave mode, you can make fine adjustments to the music that you input in Write mode and
determine how the pages of your project are laid out.

Because Engrave mode is focused on the formatting and appearance of layouts, you cannot
delete any notes or items, change their rhythmic positions, or change the pitch of notes in
Engrave mode.

You can switch to Engrave mode in any of the following ways:

● Press Ctrl/Cmd-3.

● Click Engrave in the toolbar.

● Choose Window > Engrave.

First steps
Getting around 
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Play mode

In Play mode, you can assign virtual instruments and effects for playback to instruments and
playing techniques. You can make adjustments to how individual notes are played back in order
to produce a more realistic performance.

You can switch to Play mode in any of the following ways:

● Press Ctrl/Cmd-4.

● Click Play in the toolbar.

● Choose Window > Play.

Print mode

In Print mode, you can print your layouts or export them as graphics files. You can also set the
information you want to include in their exported file names.

You can switch to Print mode in any of the following ways:

● Press Ctrl/Cmd-5.

● Click Print in the toolbar.

● Choose Window > Print.

RELATED LINKS
Setup mode on page 82
Write mode on page 131
Engrave mode on page 290
Print mode on page 468
Play mode on page 400

Hiding/Showing panels
You can hide/show individual or multiple panels. This is useful if you want to see more of the
music area, for example.

PROCEDURE

● Hide individual panels or all panels in the following ways:

● To hide/show the left panel:
Press Ctrl/Cmd-7.
Click the disclosure arrow on the left edge of the main window.
Choose Window > Show Left Panel.

● To hide/show the right panel:
Press Ctrl/Cmd-9.
Click the disclosure arrow on the right edge of the main window.
Choose Window > Show Right Panel.

● To hide/show the bottom panel:
Press Ctrl/Cmd-8.
Click the disclosure arrow at the bottom of the main window.
Choose Window > Show Bottom Panel.

● To hide/show all panels:
Press Ctrl/Cmd-0.
Click Hide/Restore Panels.

First steps
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Choose Window > Hide/Restore Panels.

RESULT
The corresponding panels are hidden/shown. Panels are hidden when no tick is shown beside
the corresponding panel in the menu, and shown when a tick is shown in the menu.
If you hide all active panels, the Hide/Restore Panels button in the toolbar changes its look and
indicates which panels were active but are now hidden.

EXAMPLE

Appearance when panels are shown Appearance when all panels were previously shown
but are now all hidden

Working with tabs and windows
Dorico Pro enables you to set up your workspace according to your working style.

Dorico Pro allows you to open multiple tabs to display multiple layouts in the same project within
the same window. You can also open the same project in several windows.

RELATED LINKS
Workspace setup on page 45

Opening a new tab
You can open a new tab to display a different view or layout within the same project window.

Each tab can contain a separate layout or a different view of a layout already open in another tab
or window. Whenever you open a new tab, you are prompted to select a layout that you want to
display in the tab.

You can find tabs in the tab bar, located at the top of the music area, below the toolbar. If you do
not see any tabs, click Show Tabs in the toolbar.

PROCEDURE

● To open a new tab, do one of the following:

● Press Ctrl/Cmd-T.

● At the right end of the tab bar, click New Tab.

● Choose Window > New Tab.

RESULT
A new tab opens that shows several icons at the top and a list of layouts at the bottom.
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Options available in the music area when you open a new tab

AFTER COMPLETING THIS TASK
You can click one of the icons or select a layout from the list at the bottom. Alternatively, you can
select a layout from the layout selector in the toolbar. The layout that you choose opens in the
active tab.

RELATED LINKS
Tab bar on page 37
Toolbar on page 34

Opening a new window
You can open another window for the same project, for example, if you want to work on multiple
layouts at the same time. You can also show a different mode of the same project in each
window, such as having one window show Write mode and another show Play mode.

PROCEDURE

● Open a new project window in any of the following ways:

● Press Ctrl/Cmd-Shift-T.

● Choose Window > New Window.

RESULT
A duplicate of the window opens. It contains the same tabs and the same view options as the
original window.

RELATED LINKS
Opening multiple project windows on page 49
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Starting a new project
After getting a first impression of the Dorico Pro user interface, you can get started with
inputting your own music. In this section, you learn how to set up a new project.

PREREQUISITE

NOTE

All inputs that are made and the images that are used to accompany the steps in this chapter are
intended merely to be helpful examples. Therefore, there is no need to make the same entries in
order to get the depicted results.

Close the template without saving to reopen the Hub.

PROCEDURE

● Start a new project in any of the following ways:

● Press Ctrl/Cmd-N.

● Click New Empty Project.

RESULT
A new project window opens.

By default, new projects start in Setup mode. This allows you to specify players and assign
instruments straight away. The area in the middle, known as the project start area, allows you to
start your project with different types of players. Once you have added at least one player, this
area becomes the music area.
On the right, the Layouts panel shows a Full score layout card. This layout is automatically
created in every new project.
At the bottom of the window is the Flows panel, where you can specify separate spans of music
for your project.

AFTER COMPLETING THIS TASK
Start your project by adding a player and assigning an instrument to them. You are free to assign
any kind of instrument. The following examples use a single piano player.

First steps
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RELATED LINKS
Windows on page 33

Adding a solo player
In this section, you learn how to add a player and assign an instrument.

PREREQUISITE
You have started a new project. You are in Setup mode.

PROCEDURE

1. Click Add Solo Player to open the instrument picker.

2. Enter piano into the instrument picker search box.

3. Click Add.

RESULT
You have added your first player. In the music area, the required piano staves including their
respective clefs are displayed.

AFTER COMPLETING THIS TASK
Save your project. You can do this at any time.
Optionally, you can now edit the project title or add more players.
The following sections help you to create flows and layouts. If you want to start composing, you
can skip those sections.

RELATED LINKS
Writing music on page 23

Creating a flow
Flows are separate spans of music within your project, for example, movements or songs. In this
section, you learn how to create a flow.

PREREQUISITE
You have added at least one player. You are in Setup mode.

PROCEDURE

● In Setup mode, click Add Flow in the Flows panel at the bottom of the window.

RESULT
A new flow is added to your project each time you click Add Flow. All existing players are
assigned to new flows, and new flows are automatically added to all existing full score and part
layouts.

AFTER COMPLETING THIS TASK
You can double-click the flow card to rename the flow.
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You can also remove players from the flow by deactivating their checkboxes in the Players panel,
and remove the flow from layouts by deactivating their checkboxes in the Layouts panel.

RELATED LINKS
Flows on page 117
Renaming flows in Setup mode on page 119

Creating a layout
Layouts define how music for one or more players in one or more flows is presented, including
page size, margins, staff size, and so on. In this section, you learn how to create a new layout.

PREREQUISITE
You have added at least one player and one flow. You are in Setup mode.

Several layouts are often used in ensembles with multiple players, where each player may
require a layout of the individual instrumental part. Dorico Pro automatically creates a full score
layout that contains all players and all flows as well as individual part layouts that each contain
one player and all flows. If you require a different combination of players and flows, for example,
a part containing the music for two players, you can create your own layouts, as follows:

PROCEDURE

● In the Layouts panel, click Add Instrumental Part Layout.

RESULT
An empty part is created on the Layouts panel.

AFTER COMPLETING THIS TASK
You can double-click the empty part card to rename it.
You can also assign flows to the layout by activating their checkboxes in the Flows panel, and
assign players to the layout by activating their checkboxes in the Players panel.

Writing music
Once you have set up your project, you can start writing music.

In Write mode, you can input notes and insert other notations into your score.

TIP

Throughout Dorico Pro, most tasks can be accomplished using only your computer's keyboard.
You do not need to use the mouse or touchpad. Learning key commands allows you to use
Dorico Pro most efficiently. The fastest way to input music is using a MIDI keyboard. If you do not
have a MIDI keyboard, you can use your computer's keyboard. Of course, you can still use the
mouse or touchpad if you want.

In the following sections, you learn how to input notes and notation items.

First steps
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Inputting your first notes
In this section, you learn how to input notes. You can start inputting notes without having to first
add a time signature or key signature.

PREREQUISITE

● You have set up your MIDI keyboard.

NOTE

If you have not set up a MIDI keyboard yet, you can start inputting notes with the
computer keyboard.

● You have added a piano player in Setup mode.

● You are in Write mode.

PROCEDURE

1. Select the rest that was automatically inserted next to the clef when you added a solo
player.

2. Start note input in any of the following ways:

● Press Shift-N or Return.

● Double-click the rest.

The caret is activated and appears on the staff.

3. In the Notes panel, click a duration.

NOTE

By default, Dorico Pro selects a quarter note (crotchet) for you.

4. Start playing notes on the MIDI keyboard, or press A, B, C, D, E, F, G on the computer
keyboard to input the corresponding pitches.
If you want higher or lower pitch for the note that Dorico Pro inputs for you, you can force
a different register.

● To input a note above the previously input note, press Shift-Alt as well as the letter
for the note.

First steps
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● To input a note below the previously input note, press Ctrl (macOS) or Ctrl-Alt
(Windows) as well as the letter for the note.

NOTE

You must press Ctrl on Mac, not Cmd.

RESULT
The pitches you enter or play in are input as notes.

EXAMPLE

Input notes with the caret still active after the final note

RELATED LINKS
Write mode on page 131
Register selection during step input on page 151

Adding a time signature
In this section, you learn how to add a time signature at the beginning of the staff. You can add a
time signature before or after inputting a melody.

PREREQUISITE
Press Esc to deactivate the caret.

PROCEDURE

1. Select the first note on the staff.

2. Press Shift-M.
The time signatures popover opens above the staff.

3. Enter a typical time signature into the popover, such as 3/4.

4. Press Return to close the popover.
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RESULT

The time signature is automatically input to the left of the note, and the required bar lines are
automatically inserted at the correct positions. If you want to insert a key signature, proceed to
the next section.

Adding a key signature
In this section, you learn how to add a key signature. You can add a key signature at any
rhythmic position on the staff.

When you start a new project from scratch, by default, there is no key signature shown.
Depending on the kind of music you are writing, the key signature might be taken to mean C
major or an open key with no specific tonal center.

You can change the key anywhere on the staff. To add a different key signature at the beginning
of the staff, for example, D major, proceed as follows:

PROCEDURE

1. Select the first note on the staff.

2. Press Shift-K.
This opens the key signatures popover on top of the staff.

3. Enter a key signature into the popover. If you want to enter D major, enter an uppercase
D.
For D minor, enter a lowercase d.

4. Press Return.

RESULT

The key signature is inserted between the clef and the time signature. Dorico Pro automatically
adds accidentals where necessary.

First steps
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Inputting your first chord
In this section, you learn how to input a chord with the computer keyboard, using chord mode. If
you want to use a MIDI keyboard instead, you can input the chord with your keyboard, and you
do not need to use chord mode. Dorico Pro automatically inputs the correct notes.

PREREQUISITE
Select the last note or rest on the staff, and press Return. This shows the caret.

PROCEDURE

1. Start chord input in any of the following ways:

● Press Q.

● In the Notes toolbox, click Chords.

The caret shows a plus sign at the top.

2. Optional: In the Notes panel, select a duration.

3. Input the notes that you want in your chord by pressing keys from A to G, one after the
other. For example, for a C major chord, press C, E, and G.
By default, Dorico Pro adds each new note above the previous note. You can select the
register of notes manually.
The example shows a possible result.

4. Press Space to advance the caret to the next note position and continue with the next
chord.
Dorico Pro expects further chord input until you deactivate it.

5. Optional: To stop chord input, press Q or click Chords again in the Notes toolbox.

RELATED LINKS
Register selection during step input on page 151
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The following sections give you an overview of the design philosophy as well as the concepts on
which Dorico Pro is based.

We recommend that you familiarize yourself with these concepts as these are often returned to
throughout the documentation.

Design philosophy and higher-level concepts
Deep design considerations are required to create a notation software like Dorico Pro, which
might be of particular interest to users familiar with scoring applications. Dorico Pro has a
forward-thinking design that is led by musical concepts rather than computational convenience,
and this provides many benefits.

In most other graphically-orientated scoring applications, the highest-level concept is the staff or
the instrument definition that creates a staff or staves. When setting up your full score in such
programs, you start by adding the correct number of staves, and you are immediately forced into
making decisions about the layout. This means that you must know in advance whether two
flutes share a staff or have their own individual staves, or whether there should be two trumpets
or three. Many of these decisions have significant effects throughout the process of inputting,
editing, and producing individual instrumental parts.

Typically, every system of a score must contain the same number of staves, even if some are
hidden on particular systems. This requires the user to manage common conventions for
themselves, such as multiple players of the same instrument sharing staves. This can be time-
consuming and is naturally error-prone.

By contrast, Dorico Pro is designed to conform more closely to how music is performed in the
real world and to make the score a flexible expression of the practical choices that go into a
musical performance, rather than to make the musical performance subservient to the way the
score was initially prepared.

To that end, the highest-level concept of Dorico Pro is the group of human musicians that
performs a score. A score can be written for one or more groups, for example, a double choir or
an orchestra plus off-stage chamber ensemble, and so on. Each group includes one or more
players which correspond to the humans who play one or more instruments. Players may either
be individuals who play more than one instrument, such as an oboist doubling cor anglais, or
groups in which everyone plays only one instrument, such as eight desks of violinists.

One crucial difference between Dorico Pro and other scoring applications is that the musical
content exists independently of the score layout in which it is viewed.

The actual music played by the group in your score belongs to one or more flows. A flow is any
span of music that stands alone, for example, a whole song, a movement of a sonata or
symphony, a number in a musical show, or even a short scale or exercise. Players might or might
not have any music to play in a given flow. For example, all the brass players might be omitted
from the slow movement of a classical symphony, or certain players might have nothing to play
in some cues in a movie score. This is no problem as you can combine players in flows in any
combination.

Dorico Pro concepts
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Dorico Pro‘s design philosophy provides several benefits. Chief among them is its ability to
produce different score layouts that share the same musical content. For example, in the same
project you can create a full score with each player's music on separate staves, a custom score
layout containing just the piano and vocal staves, and an instrumental part for each player that
only contains the music belonging to them.

Key musical concepts
In order to work efficiently with Dorico Pro, it is important to understand the conceptual model
of the program.

The model is closely based on the practical considerations of how music is written and performed
by real humans.

Projects in Dorico Pro
A project is an individual file that you create within Dorico Pro. It can contain multiple pieces of
music of any duration, written for any combination of instruments, and using different layouts.

For example, you can create a single project that contains all the preludes and fugues in Bach’s
“The Well-Tempered Clavier” as separate flows.

Modes in Dorico Pro
Modes in Dorico Pro represent a logical sequence of the workflow phases of preparing music,
but you can switch between them at any time as required for your own workflow.

Dorico Pro contains the following modes:

Setup
In this mode, you can set up the players and instruments for the project. You can
create and manage flows and set up layouts.

Write
In this mode, you can write your music. You can insert notes and rests, key
signatures, time signatures, and idiomatic notations.

Engrave
In this mode, you have access to fine-grain controls that allow you to manipulate and
modify every item in the project. You can also manage pages, master pages, layouts,
and formats.

Play
In this mode, you can set up your project for playback. You can assign VST
instruments, adjust the mix, and change the sounding duration of notes in playback
without affecting their notated duration.

Print
In this mode, you can define different print jobs, such as printing full scores, study
scores, individual parts, and so on. For every print job, you can specify options for
page size and duplex printing. You can also manage other output, such as exports to
various file types, such as PNG.

RELATED LINKS
Functions of the modes on page 17
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Options dialogs in Dorico Pro
Options to control the default appearance of music and functionality of Dorico Pro are divided
into different dialogs according to their type and purpose.

Dorico Pro contains the following dialogs for global settings:

Layout Options
Contains options that are likely to vary from layout to layout, such as page size, staff
size, and the appearance and position of bar numbers. Options in Layout Options
affect only the selected layouts but apply to all flows in those layouts.

Notation Options
Contains options that are likely to vary from flow to flow, such as beam grouping and
accidental duration rules. Options in Notation Options affect only the selected flows
but apply to all layouts in which those flows appear.

Note Input Options
Contains options relating to how you want Dorico Pro to interpret what you input,
such as creating chord symbols from a MIDI keyboard. Options in Note Input
Options affect the whole project but do not affect any other projects unless you save
your settings as default.

Engraving Options
Contains options that control the appearance and position of notes and items to a
high level of precision. For example, you can set whether crescendos appear as
hairpins or text and set the slant of beams according to the interval distance within
the beam. Engraving Options contains the largest number of options, which affect
the whole project. However, this does not affect any other projects unless you save
your settings as default.

Playback Options
Contains options that control what you hear in playback and how notation items
affect playback, including setting a dynamic curve for how much different dynamics
affect the volume, whether repeats are included in playback, and whether you want a
gap between flows. Options in Playback Options affect the whole project but do not
affect any other projects unless you save your settings as default.

RELATED LINKS
Layout Options dialog on page 90
Notation Options dialog on page 139
Note Input Options dialog on page 141
Engraving Options dialog on page 299
Playback Options dialog on page 405

Instruments in Dorico Pro
In Dorico Pro, an instrument is an individual musical instrument, such as a piano, a flute, or a
violin. Human voices, such as soprano or tenor, are also considered instruments.

Dorico Pro has a database of information about properties of each instrument. These include the
playable range, common and uncommon playing techniques, notational conventions,
transposition properties, tunings, clef, number of staves, type of staff, and so on.

RELATED LINKS
Instruments on page 103
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Players in Dorico Pro
In Dorico Pro, a player can represent an individual musician or several musicians.

● Solo players are individual musicians who can play one or more instruments, for example,
a clarinettist who doubles on alto saxophone or a percussionist who plays bass drum,
clash cymbals, and triangle.

● Section players represent multiple musicians who all play the same instrument, for
example, a violin section player can represent eight desks of musicians, or a soprano
section player can represent the whole soprano section in a mixed voice choir.

NOTE

Section players cannot double instruments, but they can play divisi. This means that they can be
divided into smaller units, which is commonly required for strings.

RELATED LINKS
Players on page 94
Divisi on page 929

Groups in Dorico Pro
A group represents a collection of musicians that are considered together, such as a choir,
orchestra, or chamber ensemble.

In a typical project, there might be only one group that contains all of the defined players, but
you can define as many groups as required to allow easy separation of forces in larger-scale
works. It might also be necessary to assign players to these groups for the purposes of, among
other things, properly bracketing and labelling their staves in the conductor's score.

EXAMPLE
A work for double choir and organ can define the two choirs as separate groups. This allows each
choir to have its own label in addition to the labels for each sectional player (soprano, alto, tenor,
bass) within the choir.
In a complex work, such as Elliott Carter's “A Symphony of Three Orchestras”, each of the
orchestras can be defined as a separate group.

RELATED LINKS
Player groups on page 115

Flows in Dorico Pro
Flows are separate spans of music that are completely independent in musical content, for
example, a single song in an album, a movement in a sonata or symphony, a number in a stage
musical, or a short scale or sight-reading exercise of only a few bars in length. A single project
can contain one or more flows.

Each flow can contain music for any combination of players. For example, brass players are often
tacet in the second movements of Classical-period symphonies, so you can simply remove brass
players from the flow for the second movement. In a set of cues for a movie, for example,
specific players might not be required in some cues, so the corresponding flows can contain only
those players who have anything to play.

The correct assignment of players to flows allows Dorico Pro, for example, to generate tacet
sheets automatically for individual instrumental parts.

Dorico Pro concepts
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RELATED LINKS
Flows on page 117

Layouts in Dorico Pro
Layouts combine musical content, as represented by flows, with rules for page layout and music
engraving. As well as part layouts for individual players, you can have layouts for multiple players
drawn from multiple different flows. You can use layouts to produce paginated music notation
that can be printed or exported in various formats.

A typical project for an ensemble of multiple players contains several layouts. For example, a
work for string quartet in three movements contains four solo players – two violins, one viola,
and one cello – and three flows, one for each movement. Such a project might require five
layouts:

● Four layouts each containing the music from all three flows for one of the solo players,
that is, the individual instrumental parts

● One layout containing the music from all three flows and all four players, that is, the full
score

Each layout provides independent control over practically every aspect of the visual appearance
of the music, including independent staff size, note spacing, and system formatting. Each layout
can also have independent page layout settings, such as page size, margins, running headers,
and footers.

The default formatting of pages in layouts is determined by master frames.

RELATED LINKS
Layouts on page 120
Page layouts on page 342
Master pages on page 301
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The user interface of Dorico Pro is designed to be as unobtrusive as possible while keeping all of
the important tools at your fingertips.

You can explore the interface without doing any damage to your project. You can always undo
any inadvertent edits or close your project without saving it.

Windows
Dorico Pro provides a project window and floating windows.

Project window

You can open multiple project windows for the same or for different projects. The project window
consists of several areas.

Project window

1 Toolbar
Allows you to access the modes, the workspace options, the Mixer, the Video window, and
the main transport options.

2 Tab bar

User interface

33
Dorico 2.2.20



In Setup, Write, and Engrave modes, the tab bar shows the tabs that are currently open. If
you split the music area and open several tabs, tab groups are shown.

3 Project start area/Music area/Event display/Print preview area
When you set up a new empty project, this area in Setup, Write, and Engrave modes shows
the project start area that allows you to add your first players. Once you have added a
player or an ensemble, this area becomes the music area that shows the score or parts of
the score that you set up, write, edit, and format. In Play mode, this area contains an event
display that shows the effects of manipulating the playback of your score. In Print mode,
the print preview area shows a preview of how your project is going to be printed onto
paper or exported into a graphics file format.

4 Panel
Provides notes and notations that you need to create and edit your music. Different panels
contain different items and functions according to the mode.

5 Toolbox
Provides access to items and tools that you can use to input and edit your music. Different
toolboxes contain different items and tools according to the mode.

6 Status bar
Allows you to choose a different view and page arrangement of the music area. It also
contains zoom options and a summary of your current selection in the music area.

Floating windows

Dorico Pro allows you to open floating windows, such as the Mixer and the Transport windows.
These can be hidden and shown independently of the mode that is selected in the main window.
The following options hide/show floating windows:

Show Mixer

Hides/Shows the Mixer window.

Show Transport Bar

Hides/Shows the Transport window.

Show Video

Hides/Shows the Video window.

RELATED LINKS
Opening multiple project windows on page 49

Toolbar
The toolbar allows you to access the modes and workspace options as well as the Mixer and
main transport options.

The toolbar is available in all modes and regardless of the tool that you are using. If you must
hide the toolbar for a specific reason, click the disclosure arrow above the toolbar.

The toolbar contains the following items:

User interface
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1 Modes
Selectable workspaces in the project window that represent different phases in the
workflow of preparing a score. If the width of the main project window becomes
sufficiently small, the mode buttons become a menu.

2 Workspace options
Provide options that allow you to select different layouts to open in the music area and to
change the working environment.

3 Show Video
Hides/Shows the Video window.

4 Show Mixer
Hides/Shows the Mixer window.

5 Mini transport
Allow to you quick access to the main transport functions, including Play, Record, and
Click.

6 Activate Project
Shows which project is activated for playback when you have multiple projects open.

Workspace options
The workspace options in the middle of the toolbar provide options that allow you to select
different layouts and to change the working environment.

Layout selector

Allows you to select other layouts to show in the current tab.

Show Tabs
Shows/Hides the tab bar above the music area.

Appearance when the tab bar is hidden Appearance when the tab bar is shown

Hide/Restore Panels
Shows/Hides all open panels.

Appearance when panels are shown Appearance when all panels were previously
shown but are now all hidden

Mini transport
The mini transport on the right of the toolbar provides quick access to the main transport
functions of Dorico Pro.

Show Transport Bar

Opens the Transport window.

Time display
Shows the position of the playhead in one of the following formats:

User interface
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● Bars, beats, and ticks

● Elapsed time in the following order of units: hours, minutes, seconds,
milliseconds

● Timecode in the following order of units: hours, minutes, seconds, frames

Time display showing bars
and beats

Time display showing elapsed
time

Time display showing the
timecode

You can change the content shown in the time display by clicking it.

Tempo
Displays the tempo used for both playback and recording. The value changes
according to the current position of the playhead and its appearance changes
according to its current mode.
You can change the tempo mode by clicking the Tempo beat unit.

How Tempo appears when fixed tempo mode
is active

How Tempo appears when follow tempo is
active

Rewind to Beginning of Flow

Moves the playhead back to the beginning of the flow.

Play
Starts/Stops playback from the previous playhead position.

Play when playback is stopped Play during playback

Record

Starts/Stops MIDI recording.

Click

Plays/Mutes the metronome click during playback and recording.

Activate Project

Shows which project is activated for playback when you have multiple projects open.

TIP

The Transport window contains additional transport functions.

RELATED LINKS
Transport window on page 446
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Playing back music on page 431
Moving the playhead on page 431
Changing the tempo mode on page 435

Tab bar
The tab bar in Dorico Pro allows you to display different layouts within the same project window.
It is located between the toolbar and the music area.

TIP

If you cannot see the tab bar, click Show Tabs in the toolbar. If Show Tabs is activated, the tab
bar is always displayed, even if only a single tab is open.

The tab bar contains the following:

1 Tabs
All tabs currently open are displayed, with their position from left to right reflecting the
order in which you opened them. Each tab is labeled with the name of the selected layout.
The tab currently in view in the music area is highlighted.
When you hover over an individual tab, an x appears that allows you to close the tab.

2 New Tab
Allows you to open a new tab. Tabs can contain a different layout, or an additional view of
a layout that is already open in another tab or window.

Project start area
The project start area is displayed in the middle of the project window in Setup, Write, and
Engrave modes when you set up a new empty project. When you add at least one player, the
view changes into the music area.

Project start area
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The project start area shows cards that allow you to add your first players. To add players, click
one of the cards:

Add Solo Player
Adds an individual player to whom you can assign one or more instruments.

Add Section Player
Adds a player that represents multiple players who all play the same instrument.

Add Ensemble
Adds multiple players who play different instruments. The ensembles that you can
add represent standard combinations of musicians.

Music area
In Setup, Write, and Engrave modes, the music area shows the editable score.

Music area showing a sample of a score

The music area can be displayed in several views. The music area tab bar allows you to open
several layouts from your project and switch between them. The scroll bars to the right and to
the bottom of the music area allow you to scroll within the layout.

When panels are open on the right, left, and at the bottom of the window, the size of the music
area can be reduced. You can hide/show panels when necessary.

RELATED LINKS
Hiding/Showing panels on page 18
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Print preview area
The print preview area in Print mode shows a preview of what is going to be printed or exported
as a graphic.

Print preview area displaying a score set to print 2-up

In the print preview area, you can scroll through the pages that are shown, but you cannot edit
your layouts. If you want to make changes, you must switch to Setup, Write, or Engrave mode.

NOTE

You can jump to the first page in the layout by pressing Home, and to the last page by pressing
End.

If you select multiple layouts to be printed as part of the same print job, the print preview area
only displays the first layout. If you want to show the expected page arrangement for each layout
in the print preview, you must check each layout individually before you start printing.

RELATED LINKS
Project window in Print mode on page 468
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Panels
The panels in the project window provide the notes, notations, and functions that you need to set
up, write, edit, and format your music.

Panels in Write mode

1 Left panel. In Write mode, this is the Notes panel.

2 Right panel. In Write mode, this is the Notations panel.

3 Bottom panel. In Write mode and Engrave mode, this is the Properties panel.

The panels have different names and functions in each mode in Dorico Pro.

Modes and their panels

Mode Left Panel Right Panel Bottom Panel

Setup Players Layouts Flows

Write Notes Notations Properties

Engrave Formatting Pages Properties

Play n/a VST and MIDI
Instruments

n/a

Print Layouts Print Options n/a

Some panels are displayed by default. You can hide/show each panel individually or all of them at
the same time.
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RELATED LINKS
Modes in Dorico Pro on page 29
Hiding/Showing panels on page 18
Project window in Setup mode on page 82
Project window in Write mode on page 131
Project window in Engrave mode on page 290
Project window in Play mode on page 400
Project window in Print mode on page 468

Disclosure arrows
Disclosure arrows indicate that objects and menus can be expanded/contracted, either vertically
or horizontally.

In Dorico Pro, disclosure arrows are commonly used to hide/show panels, sections, and
advanced options, and to expand/contract cards, such as player cards in the Players panel in
Setup mode.

Disclosure arrow for the bottom
panel

Disclosure arrows for both the
player card and the instrument
within it

Disclosure arrows for sections in
the Tempo panel

RELATED LINKS
Hiding/Showing panels on page 18
Players panel on page 83
Instruments on page 103

Toolboxes
Toolboxes are available in Write, Engrave, and Play modes. They contain different tools and
options according to the current mode, but in general they allow you to input and modify notes,
notation items, and frames, and to determine which options are shown in their corresponding
panels.

The following toolboxes are available in the different modes:

Write mode

● Notes toolbox on the left of the window

● Notations toolbox on the right of the window

Engrave mode

● Engrave toolbox on the left of the window

Play mode

● Play toolbox on the left of the window

RELATED LINKS
Notes toolbox on page 132
Notations toolbox on page 137
Engrave toolbox on page 291
Play toolbox on page 401
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Status bar
The status bar at the bottom of the project window allows you to choose a different view and
page arrangement in the music area.

NOTE

Not all options in the status bar are available in all modes.

Status bar in Write mode

1 Rhythmic Grid selector
Allows you to change the rhythmic grid value, which affects certain aspects of inputting
and editing, such as the amount by which items move.

2 Status display
Displays information about the current layout and selection, divided in up to three
sections, which are, from left to right:

● Transposition of the current layout

● The bar/range of bars of the current selection.

● Summary of the selection, for example, the pitch of a single selected note or the
implied chord of multiple selected notes.

3 Disclosure arrow
Allows you to show/hide the bottom panel in Setup, Write, and Engrave modes.

4 Selection tools
Allow you to switch between using the Marquee Tool and the Hand Tool in Write mode
and Engrave mode.

5 View type selector
Allows you to select one of the provided view types for the music area in Setup and Write
mode.

6 Page arrangement options
Allow you to choose between different horizontal and vertical arrangements of either
individual pages or pairs of pages, which are called spreads.

7 Zoom options
Allow you to change the zoom factor of the music area and its musical contents. There are
preset zoom levels but you can also use a custom zoom level.

RELATED LINKS
Rhythmic grid on page 144
View types on page 43
Page arrangements for page view on page 44
Zoom options on page 45

Selection tools
Dorico Pro allows you to choose selection tools from the status bar that you can use to select or
move items within the music area.

You can use the following tools:

Marquee Tool
Allows you to drag a rectangle to select multiple notes and notations.
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Hand Tool
Allows you to move the view within the music area.

TIP

To use the other tool briefly without selecting it, you can press Shift in addition to using the
mouse.

Selecting multiple items using marquee selections

You can use a marquee selection to select multiple notes and notations at the same time within a
specific area in Write, Engrave, and Play modes.

PROCEDURE

1. In the status bar, click Marquee Tool.

2. In the music area, click and drag across the area where you want to select everything,
A gray rectangle is shown to indicate which notes and notations will be selected. We
recommend that you click in one corner of the area you want to select and drag diagonally
across to the other corner.

RESULT
All notes and notations in the area within the gray rectangle are selected.

NOTE

Only items completely within the area are selected. However, if any part of a note/tie chain is
within the area, the whole note/tie chain is selected.

Moving the view

You can move the view within the music area in Write mode and Engrave mode, for example, to
bring other parts of pages into view when zoomed in.

PROCEDURE

1. In the status bar, click Hand Tool.

2. Click and drag in any empty space in the music area.
The mouse pointer changes into a hand symbol during the move.

View types
In Dorico Pro there are different ways to view your layouts. Dorico Pro saves your chosen view
type for each layout, so you only need to set it once.

The following view types are available:

Galley View
Lays out your music on a single continuous system. It also shows all the instrument
staves in the current layout and flow.
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This view type is most useful during the process of inputting the music as it allows
you to focus on the musical content of your project.
By default, bar numbers are shown every bar above every staff. Staff labels are also
shown above every staff, and follow the view as you scroll so they are always visible.

NOTE

Note spacing in galley view is unjustified, meaning it neither expands nor contracts
to fit the width of a page or a music frame. However, changes made to note spacing
in galley view also apply to page view.

Additionally, there is no automatic vertical collision avoidance in galley view, so notes
and items might overlap.

Page View
Displays your layout paginated exactly as it appears when you print or export it.
This view type is useful if you want to view spreads or single pages. Spreads allow
you to work out page turns, because the performer only needs to turn the page at
the end of the right-hand page of a pair. Viewing single pages can be helpful if you
want to print the layout as a series of single pages. This might be necessary if you
are using, for example, a fan-fold or concertina approach, in which case the
distinction between left- and right-hand pages is insignificant.

TIP

You can change the default view type used for all future projects on the General page in
Preferences.

RELATED LINKS
Preferences dialog on page 51
Switching to galley/page view on page 50

Page arrangements for page view
You can change the way pages are arranged for display in the music area.

Spreads Horizontally

Displays pages in pairs as two-page spreads, with each pair laid out from left to right
in a row.

Spreads Vertically

Displays pages in pairs as two-page spreads, with each pair laid out from top to
bottom in a column.

Single Pages Horizontally

Displays individual pages laid out from left to right.

Single Pages Vertically

Displays individual pages laid out from top to bottom.
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RELATED LINKS
Switching to galley/page view on page 50

Zoom options
Zoom options in the status bar allow you to change the displayed size of pages in the music area.

Custom Zoom
Opens a dialog that allows you to set a custom zoom percentage.

Set Zoom
Allows you to select one of the preset zoom scaling factors. You can set a permanent
zoom factor for all future projects on the General page in Preferences.

Zoom Out
Decreases the size of notes and notations in the music area.

Zoom In
Increases the size of notes and notations in the music area.

RELATED LINKS
Preferences dialog on page 51

Zooming in/out of the music area

You can change the zoom level in the music area, for example, if you want a larger overview
when inputting notes but to see notes and notations more closely when making detailed
graphical amendments.

PROCEDURE

1. Zoom in in any of the following ways:

● Press Ctrl/Cmd-+.

● Spread two fingers outwards on a touchpad.

● Scroll upwards on a mouse wheel.

● Use the zoom options in the status bar.

2. Zoom out in any of the following ways:

● Press Ctrl/Cmd--.

● Pinch two fingers together on a touchpad.

● Scroll downwards on a mouse wheel.

● Use the zoom options in the status bar.

RESULT
The zoom level in the music area is changed. If you had anything selected, Dorico Pro uses your
selection as the focal point of the zoom. If you had nothing selected, Dorico Pro focuses on the
area previously in the center of the view.

RELATED LINKS
Zooming in/out of tracks in the event display on page 413

Workspace setup
Dorico Pro enables you to set up your workspace according to your working style.
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Dorico Pro allows you to open multiple tabs to display multiple layouts in the same project within
the same window. You can also open the same project in several windows.

RELATED LINKS
Hiding/Showing panels on page 18

Switching between layouts
If you have created several layouts in your project, you can switch between which is displayed in
the music area in every mode. In Setup, Write, and Engrave modes, this changes the layout
displayed in the current tab only.

NOTE

You can only switch between layouts to which players are assigned.

PROCEDURE

● Switch to another layout in any of the following ways:

● Press Shift-Alt-] to switch to the next layout.

● Press Shift-Alt-[ to switch to the previous layout.

● Select an item on a staff or in the piano roll of the player whose layout you want to
open and press W.

NOTE

Implicit rests are not items.

● Select a layout from the layout selector in the toolbar.

RESULT
The selected layout is opened in the music area. It replaces the layout previously open in the tab.

Opening new tabs
You can open multiple tabs in the same project window, which you can use to display multiple
layouts or different views of the same layout. For example, you can show your full score layout in
page view in one tab and in galley view in another tab.

Each tab can contain a separate layout or a different view of a layout already open in another tab
or window. Whenever you open a new tab, you are prompted to select a layout that you want to
display in the tab.

You can find tabs in the tab bar, located at the top of the music area, below the toolbar. If you do
not see any tabs, click Show Tabs in the toolbar.

PROCEDURE

1. Open a new tab in any of the following ways:
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● Press Ctrl/Cmd-T.

● At the right end of the tab bar, click New Tab.

● Choose Window > New Tab.

A new tab opens that shows recent layouts at the top and a list of other layouts in the
project at the bottom.

2. Select a layout to open in the new tab in any of the following ways:

● Click one of the icons.

● Select a layout from the list at the bottom.

● Select a layout from the layout selector in the toolbar.

RESULT
The layout that you choose opens in the active tab.

TIP

You can also switch between different layouts within the same tab.

RELATED LINKS
Tab bar on page 37
Toolbar on page 34

Closing tabs
You can close individual tabs of layouts that you no longer need, and you can close multiple tabs
at the same time.

PROCEDURE

● Close tabs in any of the following ways:

● Select the tab you want to close and press Ctrl/Cmd-W.

● Hover over the tab you want to close and click x.
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● Right-click the single tab you want to close and choose Close Tab from the context
menu.

● Right-click the tab you do not want to close and choose Close Other Tabs from the
context menu.

NOTE

You cannot close the last tab in a window. If only one tab is open and you no longer want
to see the tabs, deactivate Show Tabs in the main toolbar. The tab is no longer displayed,
but the corresponding layout is still shown.

RESULT
If you selected a single tab and closed it, the selected tab and its corresponding layout are
closed.
If you selected a single tab and closed other tabs, all open tabs except for the selected tab are
closed.

Switching between tabs
You can switch between different open tabs to show different layouts in the music area.

PROCEDURE

● Switch tabs in any of the following ways:

● Press Ctrl/Cmd-Tab to cycle through all open tabs.

● Press Ctrl/Cmd-Shift-Tab to cycle through all open tabs in reverse order.

● Click the tab to which you want to switch.

Changing the order of tabs
You can move tabs to a different position on the tab bar.

PROCEDURE

● Click and drag a tab to the new position.
The other tabs move to show where the dragged tab will be positioned.

Showing multiple tabs in the same project window
You can split your project window to display two tabs at the same time. The split can be either
vertical or horizontal, allowing you to display different layouts either side by side or above one
another.

Splitting your project window divides your currently open tabs into two groups. You can move
tabs between the groups at any time, for example, to compare different layouts or to compare
two views of the same layout.

PROCEDURE

1. Select the tab of the layout that you want to move to a new tab group.

2. Split the view in one of the following ways:

● To show layouts side by side, choose Window > Vertical Split.

● To show layouts above one another, choose Window > Horizontal Split.
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RESULT
The project window is split to show two tabs at the same time. The selected tab is moved to the
new tab group.

Moving tabs to another tab group
You can move tabs to other tab groups.

PREREQUISITE
You have opened at least two tabs and they are both shown in the same project window.

PROCEDURE

● Click and drag the tab into the target tab group.

RELATED LINKS
Opening new tabs on page 46

Moving tabs to other windows
You can move tabs to another open window of the same project to show the corresponding
layouts in a new window.

NOTE

● The layouts must belong to the same project. If you attempt to move a tab to a window of
a different project, a new window is created for the project to which the layout belongs.

● You can only move tabs to other windows if you have opened at least two tabs.

PROCEDURE

● Do one of the following:

● To create a new window of the same project with the tab inserted, click and drag a
tab horizontally to the right/left, away from the tab bar and release it.

● To insert the tab into the tab bar of another window of the same project, click and
drag a tab onto the tab bar.

● Select a tab, right-click it, and choose Move Tab To New Window from the context
menu.

● Select a tab and choose Window > Move Tab To New Window.

Opening multiple project windows
You can open multiple project windows for the same project, for example, if you want to work on
multiple layouts at the same time. You can also show a different mode of the same project in
each window, such as having one window show Write mode and another show Play mode.

During playback, all windows that belong to the same project show the playhead and move the
view to follow the music during playback.

PROCEDURE

● Open a new project window in any of the following ways:

● Press Ctrl/Cmd-Shift-T.
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● Choose Window > New Window.

RESULT
A duplicate of the window opens. It contains the same tabs and the same view options as the
original window.

RELATED LINKS
Playhead on page 430

Changing to full screen mode
You can maximize the amount of screen space available for your music by making any project
window cover the whole screen.

You can also hide the desktop elements provided by your operating system, for example, the
task bar in Windows or the system menu bar and Dock in macOS.

Within Dorico Pro, you can also hide/show the panels on the right, left, and at the bottom of the
window.

PROCEDURE

● Choose View > Full Screen.

AFTER COMPLETING THIS TASK
To return to the default view, choose View > Full Screen again.

RELATED LINKS
Hiding/Showing panels on page 18

Switching to galley/page view
You can switch between different view types in the music area, for example, if a flute player in
your project is doubling piccolo, you can switch to galley view to see the piccolo staff in addition
to the flute staff.

PROCEDURE

1. Switch to galley or page view in any of the following ways:

● Press Ctrl/Cmd-Alt-2 to switch to galley view.

● Press Ctrl/Cmd-Alt-1 to switch to page view.

● In the status bar, select Galley View or Page View from the view selector.

2. Optional: If you selected Page View, choose one of the available page arrangements in the
status bar.

Spreads
Horizontally

Spreads Vertically Single Pages
Horizontally

Single Pages
Vertically
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RESULT
The view type in the music area is changed. In page view, only staves containing notes or items
are shown by default. For players holding multiple empty instruments, only the top instrument is
shown in full scores.
In galley view, all staves in the project are shown. However, note spacing is unjustified and there
is no automatic vertical collision avoidance, so notes and items might overlap.

TIP

● You can change the default gaps between staves in galley view on the Vertical Spacing
page in Setup > Layout Options.

● You can change the default view type used for all projects in the View section of the
General page in Preferences.

RELATED LINKS
View types on page 43
Page arrangements for page view on page 44
Changing the staff spacing in galley view on page 395

Preferences dialog
In the Preferences dialog, you can make permanent settings for your workspace and define key
commands.

You can open Preferences in any of the following ways:

● Press Ctrl/Cmd-, (comma).

● Choose Dorico > Preferences (macOS).

● Choose Edit > Preferences (Windows).

Preferences

The Preferences dialog contains the following:

1 Page list
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Contains the categories of options that you can view and change in the dialog, divided into
pages. When you click a page in this list, any applicable section titles appear below the
page in the page list.

2 Section titles
Shows the titles of any sections on the selected page. You can click these section titles to
navigate directly to that section of the page.

3 Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible
settings, the current setting is highlighted.

NOTE

The arrangement of options on the Key Commands page is significantly different to other
pages in the Preferences dialog. This page is described separately in further detail.

RELATED LINKS
View types on page 43
Zoom options on page 45
Selection tools on page 42
Layout Options dialog on page 90

Key Commands page in the Preferences dialog
The Key Commands page in the Preferences dialog allows you to view all the items and
functions that can be assigned key commands, change existing key commands, and assign new
key commands to items and functions that have no key command assigned by default.

Most of the main menus in Dorico Pro have key commands for certain menu items. In addition,
there are other Dorico Pro functions that can be assigned key commands. This can be helpful for
items or actions that you find yourself performing regularly, such as changing the rhythmic grid
value.

● You can find the Key Commands page by opening the Preferences dialog and clicking
Key Commands in the page list.

Key Commands page in Preferences
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The Key Commands page comprises the following:

1 Search field
Allows you to search for menu items and functions to view, change, or add key commands.
Because there are multiple levels of disclosure arrows before you reach many menu items
and functions, this is often the quickest way to find what you are looking for.

2 Menu items and functions
Displays the menu items and functions that can be assigned key commands. The list can
be filtered using the Search field. Disclosure arrows beside options indicate that further
options are available when the option is expanded.
Hovering over menu items and functions shows a tool tip, which is helpful for some
functions with particularly long names.

3 Key Commands section
Allows you to see any existing key commands set for the selected menu item or function in
the list of assigned key commands and to set new ones. If you enter a key command that
has already been assigned to another menu item or function, a warning tells you that you
cannot use that key command.
You can assign multiple key commands to the same menu item or function, and the
Keyboard language menu allows you to assign different key commands for each of the
available languages.

● Add Key Command
Adds the key command you pressed to the selected menu item or function.

● Remove Key Command
Removes the currently selected key command from the selected menu item or
function.

● Print Summary
Directs you to an offline page in a web browser that displays your key commands on
an interactive keyboard.

● Reset Key Commands
Resets all of your key commands to their defaults.

4 MIDI Learn section
Allows you to assign MIDI controllers, notes, and combinations of notes to control menu
items and functions.

● MIDI Learn

Prepares Dorico Pro to receive the MIDI input data that you want to save as a
command.

● Add MIDI Command
Adds the MIDI controllers or notes you changed or pressed to the selected menu
item or function.

● Remove MIDI Command
Removes the MIDI command from the selected menu item or function.

RELATED LINKS
Assigning key commands on page 55
Assigning MIDI commands on page 56
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Interactive Dorico Pro key commands map
The interactive Dorico Key Commands map shows a virtual computer keyboard, with keys that
have been assigned key commands highlighted in different colors according to the modifier keys
they contain. All key commands for the selected keyboard language layout are listed below,
divided into global and mode-specific groups.

You can open the Dorico Key Commands map in any of the following ways:

● Choose Help > Key Commands.

● Choose Edit > Preferences, and click Print Summary in the Key Commands section of the
Preferences dialog.

The interactive key commands map as it appears when US English is selected

The Dorico Key Commands map opens in a web browser. It allows you to do any of the
following:

● To see the available key commands, select a context. The context of a key command is the
mode in which it can be used. Key commands that have a global context work in all modes.

● To highlight the keys that you can press in combination with the modifier key to form a key
command, press a modifier key on your computer keyboard, such as Shift, or click a
modifier key on the virtual keyboard. You can also press more than one modifier key. The
virtual computer keyboard shows the highlighted keys and displays on each key to which
functions it is assigned.

● To search for a specific key command, enter one or multiple words in the search field.

● To get an overview of all available key commands, browse the key commands that are
listed below the virtual keyboard. The key commands are listed according to the context in
which they can be used.

RELATED LINKS
Changing the keyboard layout on page 56
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Searching for the key commands of functions
You can search for key commands that are assigned to functions or menu items in Dorico Pro.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click Key Commands in the page list.

3. Enter the name of a function in the Search field.
The entries that are listed below are filtered according to the words that you enter.

4. Expand an entry and select the function for which you want to see the key command.
For particularly long names, you can hover over them to see a tool tip.

RESULT
If the function has a key command, it is shown in the list of assigned key commands.

TIP

You can also search for functions in the interactive key commands map.

Assigning key commands
You can assign key commands to many menu items and functions, for example, if you use a
menu item frequently and want to be able to access it quickly but it does not have a key
command assigned by default. You can also change existing key commands.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click Key Commands in the page list.

3. Search for the name of a function and select it.
For particularly long names, you can hover over them to see a tool tip.

4. Optional: Press Remove Key Command if the function already has an assigned key
command.
If you assign a new key command without removing an existing one, you can use either
key command.

5. Click the Press shortcut input field.

6. Press the key command that you want to assign on your computer keyboard.

7. Click Add Key Command.
The key command is added to the list of assigned key commands.

8. Click Apply, then Close.

RESULT
The key command you pressed is assigned to the selected menu item or function. You can use it
immediately.

RELATED LINKS
Resetting key commands on page 57
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Assigning MIDI commands
You can assign specific keys or buttons on your MIDI keyboard to perform functions and access
menu items. For example, if you want to navigate using MIDI keys during chord symbol input.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click Key Commands in the page list.

3. Select the menu item or function to which you want to assign MIDI commands.
For particularly long names, you can hover over them to see a tool tip.

4. Click MIDI Learn.

5. Press the key or button on your MIDI keyboard that you want to assign to the selected
parameter.

6. Click Add MIDI Command.

7. Click Apply, then Close.

Changing the keyboard layout
You can change the keyboard layout in Dorico Pro to that of another language. This allows you to
use the predefined key commands for the selected language.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click Key Commands in the page list.

3. Select a different keyboard layout from the Keyboard language menu.

4. Click Apply, then Close.

RESULT
You can immediately use the available key commands for the selected language.

Removing key commands
You can remove individual key commands from a function.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click Key Commands in the page list.

3. Search for the name of a function and select it.

4. Click Remove Key Command.

5. Click Apply, then Close.

RESULT
The key command is removed from the selected function.

RELATED LINKS
Searching for the key commands of functions on page 55
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Resetting key commands
You can reset all the key commands in your project to their defaults.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click Key Commands in the page list.

3. Click Reset Key Commands.

4. Click Apply, then Close.

RESULT
All custom key commands are deleted and the default key commands are reinstated.

Changing your preferred unit of measurement
You can change your default preferred unit of measurement to be used throughout Dorico Pro
for options that use absolute measurements, such as the size of page margins in Layout
Options. It does not affect options that are relative to the size of staves, such as options in
Engraving Options or Notation Options.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click General in the page list.

3. In the General section, select one of the following options from the Preferred unit of
measurement menu:

● Points (pt)

● Millimeters (mm)

● Inches (in)

● Centimeters (cm)

4. Click Apply, then Close.
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In addition to opening and importing/exporting projects and other file formats, project and file
handling also includes auto-save and project backups.

RELATED LINKS
File import and export on page 63
Auto-save on page 78
Project backups on page 80

Hub
When you start Dorico Pro, the Hub opens. The Hub keeps you up-to-date with the latest Dorico
information and tutorials, and assists you with organizing your projects.

The Hub contains the following:

1 Recent Projects
Allows you quick access to the projects that you worked on last. Selecting Recent Projects
shows them in the list. You can scroll through the list using either a mouse/touchpad or
the Up Arrow/Down Arrow keys.

2 Project template categories
Allows you quick access to a suitable project template in the available categories. Selecting
a category shows the possible templates in that category in the list.

3 New Empty Project
Starts a new project with no players or flows.

Project and file handling
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4 List
Displays either recent projects or project templates, depending on your selection on the
left of the dialog.

5 Open Other
Allows you to search for and open any other project file in the File Explorer/macOS Finder.

6 New from Template (project template selected)
Creates a new project using the selected project template. This option is only available if
you have selected a project template.
Open Selected Project (recent project selected)
Opens the recent project file that you selected in the list.

7 User Forum
Links you to the user forum on the Steinberg website.

8 Downloads
Links you to the downloads page on the Steinberg website, where you can find relevant
update installers and a link to the documentation.

9 News
Displays recent Dorico news from the Dorico blog. Double-clicking a news item, or
selecting it and clicking Read More, opens it in a web browser.

10 Video Tutorials
Displays recent Dorico tutorials. Double-clicking a video tutorial, or selecting it and clicking
Read More, opens it in a web browser.

11 More
Links you directly to the Dorico YouTube channel.

RELATED LINKS
Brackets according to project template categories on page 60

Starting new projects
Dorico Pro provides several ways to start new projects.

PROCEDURE

● Start a new project in any of the following ways:

● Press Ctrl/Cmd-N at any time.

● Choose File > New at any time.

● In the Hub, click New Empty Project.

RESULT
A new project window opens.

Starting new projects from project templates
Dorico Pro provides multiple project templates that you can use to start a new project, for
example, multiple types of orchestras and vocal ensembles.

PROCEDURE

1. In the Hub, select one of the following project template categories:

● Orchestral

● Band
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● Jazz

● Chamber

● Choral and Vocal

● Solo

2. Select a project template in the list.

3. Click New from Template.

RESULT
The project template opens in a new project window.

TIP

You can also start a new project from a template at any time by choosing File > New From
Template > [Template category] > [Project template].

AFTER COMPLETING THIS TASK
You can add additional players/instruments and delete players/instruments that were included in
the template to customize your project.

RELATED LINKS
Adding solo/section players on page 95
Adding instruments to players on page 104
Deleting players on page 102
Deleting instruments on page 107

Brackets according to project template categories
Staves are bracketed differently depending on the category of project template you use to start a
new project, even if you later change the players in the project. For example, all staves are
bracketed together when you start a project using one of the chamber templates.

The following categories of templates are available in Dorico Pro, which bracket staves
automatically in different ways by automatically selecting the appropriate ensemble type for the
template on the Brackets and Braces page in Engrave > Engraving Options.

NOTE

● Grand staff instruments, such as piano, are always excluded from brackets. They also split
brackets if they are placed within a bracketed group.

● There must be at least two adjacent instruments for a bracket to be shown.

Orchestral
Large ensembles containing most Western instruments, including strings,
woodwinds, brass, and percussion.
In orchestral templates, staves are bracketed according to their instrument family.
For example, adjacent string instruments are bracketed together separately from
adjacent woodwind instruments.

Band
Large ensembles containing primarily wind instruments, including woodwind and
brass instruments, and optionally percussion and other instruments, such as strings
and guitars.
Different band templates bracket instruments differently, for example, the concert
band template brackets woodwind and brass instruments separately, whereas the
brass band template brackets brass instruments according to their instrument type,
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except for horns and trumpets, which are bracketed together. Any other instruments
in the score are bracketed according to their instrument family, and percussion and
timpani are bracketed separately.

Jazz
Popular ensembles commonly used to perform jazz.
In small jazz templates, no staves are bracketed together. Grand staff instruments
are still shown with braces. The big band template uses the Big band ensemble type
for brackets.

Chamber
Typically small ensembles containing only a few players.
In chamber templates, all staves in the project are bracketed together with a single
bracket, regardless of their instrument family.

Choral and Vocal
Ensembles containing voices, including popular choir arrangements.
In choral and vocal templates, staves are bracketed according to their instrument
family. For example, adjacent vocal staves are bracketed together separately from
accompanying instruments. However, vocal staves are not joined by barlines.

Solo
Ensembles containing only a single player/instrument.
In solo templates, no staves are bracketed together. Grand staff instruments are still
shown with braces.

RELATED LINKS
Brackets according to ensemble type on page 558

Opening projects/files
You can open Dorico Pro projects at any time, for example, if the project you want to open is not
listed as a recent project in the list in the Hub. You can also open MusicXML and MIDI files.

PROCEDURE

1. Open the File Explorer/macOS Finder in any of the following ways:

● In the Hub, click Open Other.

● Choose File > Open.

● Choose File > Open Recent > [Project file name].

2. In the File Explorer/macOS Finder, locate and select the files you want to open.

3. Click Open.

RESULT
The selected Dorico projects are opened.
If you opened MusicXML or MIDI files, Dorico Pro creates new project files from the MusicXML or
MIDI content, which you can save as default Dorico Pro projects.
If MusicXML files include page size, margin, and staff size settings, Dorico Pro imports those
values. If they are not included, Dorico Pro creates suitable settings according to the number of
instruments in the file.

TIP

You can also import MusicXML and MIDI files as new flows in existing projects rather than
opening them as separate projects.
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RELATED LINKS
Hub on page 58
Importing MusicXML files on page 66
Importing MIDI on page 69

Opening recent projects from the Hub
You can open a project on which you have recently worked from the Steinberg Hub.

PROCEDURE

1. In the Hub, click Recent Projects.

2. In the list, select a recent project in any the following ways:

● Press Up Arrow/Down Arrow to navigate to the project file name, then press
Return to open it.

● Double-click a project file name.

● Select a project file name and click Open Selected Project.

RESULT
The selected Dorico projects are opened.

RELATED LINKS
Hub on page 58

Projects from different versions of Dorico
You can open projects that were last saved in other versions of Dorico than the one you have. In
such cases, Dorico Pro shows a warning message to make you aware of any implications.

The contents of the warning message vary according to the version of Dorico in which the project
was last saved:

● When opening a project last saved in an older version, it shows the version number the
project was last saved in and informs you that the project will be updated to your current
version.

● When opening a project last saved in a newer version, it shows only that the project is
from a newer version. It also informs you that items and notations from that version might
not appear and will be deleted if you save the project in your current version.

In both cases, opening the project is non-destructive. This means that its contents and
formatting are unaffected if you do not save it.

You can prevent Dorico Pro from showing you warnings about projects from different versions in
the Files section of the General page in Preferences. In the same section, you can also tell
Dorico Pro to prompt you to choose a new location for projects from different versions when you
save them. This reduces the risk of you overwriting them by mistake.

RELATED LINKS
Preferences dialog on page 51
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File import and export
External files are files in different formats than Dorico projects, such as MIDI, MusicXML, or
tempo tracks. It is possible in Dorico Pro both to import and export different types of files.

This can be useful if, for example, you want to share your project with others who use a different
notation software, or to convert the notes, audio, or time signatures and tempo information in
your project into other formats.

Importing flows
You can import individual flows into existing projects, for example, if you want to bring together
multiple existing pieces into one project for publishing, or if you have an empty project file with
your preferred settings saved and want to reuse those settings.

PROCEDURE

1. Choose File > Import > Flows to open the File Explorer/macOS Finder.

2. In the File Explorer/macOS Finder, locate and select the project files of the flows you want
to import.

3. Click Open to open the Flow Import Options dialog for the first selected project.

4. In the Flow Import Options dialog, choose one of the following options for Player
handling:

● Create All New Players

● Merge with Existing Players Where Possible

5. In the Import flows list, activate the checkbox for each flow you want to import.

6. Click OK to import the selected flows and close the dialog.

7. Optional: If you selected multiple projects from which to import flows, repeat steps 4 to 6
for each project. The Flow Import Options dialog reopens automatically for each project.

RESULT
The selected flows are imported into the project.

● If you chose Create All New Players, new players are added as required for each flow.

● If you chose Merge with Existing Players Where Possible, any players that the imported
flows and existing project have in common are merged, for example, if you imported a
flow containing a solo piano into a project containing a piano and viola, the imported flow
is added to the existing piano player.

NOTE

● Players are not automatically added to flows that you imported into the project.

● You can also open flows directly if you want them to be separate projects rather than new
flows in existing projects.

RELATED LINKS
Opening projects/files on page 61

Flow Import Options dialog
The Flow Import Options dialog allows you to determine whether players in imported flows are
merged with existing players in the project and which flows from within other projects you want
to import.

● You can open the Flow Import Options dialog by choosing File > Import > Flows and
opening a Dorico project from the File Explorer/macOS Finder.
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Flow Import Options dialog

The Flow Import Options dialog comprises the following:

1 Player handling
Allows you to determine how imported flows are assigned to players.

● Create All New Players adds separate players for each imported flow.

● Merge with Existing Players Where Possible merges players from imported flows
with any existing compatible players in the project.

2 Import flows
Contains a list of all the flows in the selected project. Flows are included in the import
when their checkbox is activated.

Exporting flows
You can export individual flows from projects, for example, to save small excerpts of large
projects separately.

NOTE

These steps export flows as separate Dorico projects. If you want to export flows as other file
formats, such as MusicXML or MP3, there are different methods.

PROCEDURE

1. Choose File > Export > Flows to open the Export Flows dialog.

2. In the Export Flows dialog, activate/deactivate Export each selected flow as a separate
file.

3. In the Select flows to export list, activate the checkbox for each flow you want to export.
You can also click Select All or Select None at the bottom of the list.

4. Activate/Deactivate Export layouts as separate files.

5. Optional: If you activated Export layouts as separate files, activate the checkbox for each
layout you want to export in the Select layouts to export list. You can also click Select All
or Select None at the bottom of the list.

6. Click Choose Folder beside the Export to field to open the File Explorer/macOS Finder.
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7. In the File Explorer/macOS Finder, locate and select the destination folder you want.

8. Click Open (macOS)/Select Folder (Windows) to insert the new path in the Export to field.

9. Activate/Deactivate Create folder for exported files.

10. Click OK to export the selected flows and layouts and close the dialog.

RELATED LINKS
Exporting MusicXML files on page 67
Exporting MIDI on page 72
Exporting tempo tracks on page 75
Exporting audio on page 76

Export Flows dialog
The Export Flows dialog allows you to save individual flows and layouts as separate Dorico files.

● You can open the Export Flows dialog by choosing File > Export > Flows.

Export Flows dialog

The Export Flows dialog contains the following options and lists:

1 Export each selected flow as a separate file
Allows you to export each flow as a separate file instead of all the selected flows as a single
file.

2 Select flows to export
Contains a list of all the flows in the project. Flows are included in the export when their
checkbox is activated.

3 Export layouts as separate files
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Allows you to export each layout in the project as a separate file instead of as a single file.

4 Select layouts to export
Contains a list of all the layouts in the project. Layouts are included in the export when
their checkbox is activated. Only available if you have activated Export layouts as
separate files.

5 Selection options
Allow you to select/deselect all the flows/layouts in the corresponding list. For example,
you can deselect all flows and then activate the checkbox of a single flow you want to
export.

6 Create folder for exported files
Controls whether or not Dorico Pro generates a new folder for the selected flows within
the selected export path. The automatic folder name is “Flows from” followed by the
project file name, for example, “Flows from Smyth - String Quintet”.

7 Export to field
Displays the current export path where exported flows will be saved.

8 Choose Folder
Opens the File Explorer/macOS Finder and allows you to change the export path.

Importing MusicXML files
You can import MusicXML files into existing Dorico Pro projects as separate flows, for example, to
continue work on a piece started in a different notation software.

PROCEDURE

1. Choose File > Import > MusicXML to open the File Explorer/macOS Finder.

2. In the File Explorer/macOS Finder, locate and select the MusicXML files you want to import.

3. Click Open to open the Flow Import Options dialog for the first selected MusicXML file.

4. In the Flow Import Options dialog, choose one of the following options for Player
handling:

● Create All New Players

● Merge with Existing Players Where Possible

5. Click OK to import the selected flows and close the dialog.

6. Optional: If you selected multiple MusicXML files, repeat steps 4 and 5 for each file. The
Flow Import Options dialog reopens automatically for each file.

RESULT
The selected MusicXML files are imported into the project as new flows.

● If MusicXML files include page size, margin, and staff size settings, Dorico Pro imports
those values. If they are not included, Dorico Pro creates suitable settings according to the
number of instruments in the file.

● If you chose Create All New Players, new players are added as required for each
MusicXML file.

● If you chose Merge with Existing Players Where Possible, any players that the imported
MusicXML files and existing project have in common are merged, for example, if you
imported a MusicXML file containing a solo piano into a project containing a piano and
viola, the imported MusicXML file is added to the existing piano player.

TIP

● You can also open MusicXML files directly if you want them to be separate projects rather
than new flows in existing projects.
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● You can change your default preferences for the handling of imported MusicXML files on
the MusicXML Import page in Preferences.

RELATED LINKS
Flow Import Options dialog on page 63
Opening projects/files on page 61

Exporting MusicXML files
You can export flows and layouts as separate MusicXML files, for example, if you want to export
just the soloist’s layout containing the first flow.

PROCEDURE

1. Choose File > Export > MusicXML to open the Export MusicXML dialog.

2. In the Export MusicXML dialog, choose one of the following file format options:

● Export compressed XML (.mxl)

● Export uncompressed XML (.xml)

3. In the Select flows to export list, activate the checkbox for each flow you want to export.
You can also click Select All or Select None at the bottom of the list.

4. Activate/Deactivate Export layouts as separate files.

5. Optional: If you activated Export layouts as separate files, activate the checkbox for each
layout you want to export in the Select layouts to export list. You can also click Select All
or Select None at the bottom of the list.

6. Click Choose Folder beside the Export to field to open the File Explorer/macOS Finder.

7. In the File Explorer/macOS Finder, locate and select the destination folder you want.

8. Click Open (macOS)/Select Folder (Windows) to insert the new path in the Export to field.

9. Activate/Deactivate Create folder for exported files.

10. Click OK to export the selected flows/layouts as MusicXML files and close the dialog.

Export MusicXML dialog
The Export MusicXML dialog allows you to save individual flows and layouts as separate
MusicXML files.

● You can open the Export MusicXML dialog by choosing File > Export > MusicXML.
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Export MusicXML dialog

The Export MusicXML dialog contains the following options and lists:

1 File format options
Allows you to choose the MusicXML file format you want to export. Compressed MusicXML
files contain the same information as uncompressed MusicXML files but have a smaller file
size.

2 Select flows to export
Contains a list of all the flows in the project. Flows are included in the export when their
checkbox is activated.

3 Export layouts as separate files
Allows you to export each layout in the project as a separate file instead of as a single file.

4 Select layouts to export
Contains a list of all the layouts in the project. Layouts are included in the export when
their checkbox is activated. Only available if you have activated Export layouts as
separate files.

5 Selection options
Allow you to select/deselect all the flows/layouts in the corresponding list. For example,
you can deselect all flows and then activate the checkbox of a single flow you want to
export.

6 Create folder for exported files
Controls whether or not Dorico Pro generates a new folder for the selected flows within
the selected export path. The automatic folder name is “Flows from” followed by the
project file name, for example, “Flows from Smyth - String Quintet”.
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7 Export to field
Displays the current export path where exported files will be saved.

8 Choose Folder
Opens the File Explorer/macOS Finder and allows you to change the export path.

Importing MIDI
You can import MIDI files into existing Dorico Pro projects as separate flows, for example, to
work on a different version of a section of a piece.

PROCEDURE

1. Choose File > Import > MIDI to open the File Explorer/macOS Finder.

2. In the File Explorer/macOS Finder, locate and select the MIDI files you want to import.

3. Click Open to open the MIDI Import Options dialog for the first selected MIDI file.

4. In the MIDI Import Options dialog, change the settings as required.

5. Optional: If you want to customize the quantization settings, click Quantize Options and
change the settings in the MIDI Quantize Options dialog.

6. Optional: Click OK to save your quantization settings and return to the MIDI Import
Options dialog.

7. Click OK to close the MIDI Import Options dialog, which automatically opens the Flow
Import Options dialog for the first selected MIDI file.

8. In the Flow Import Options dialog, choose one of the following options for Player
handling:

● Create All New Players

● Merge with Existing Players Where Possible

9. Click OK to import the selected flows and close the dialog.

10. Optional: If you selected multiple MIDI files, repeat steps 4 to 9 for each file. The MIDI
Import Options and Flow Import Options dialogs reopen automatically for each file.

RESULT
The selected MIDI files are imported into the project as new flows. Dorico Pro uses an algorithm
on imported MIDI notes to produce the correct enharmonic spelling for the imported notes.

● If the MIDI files contained markers, they are also imported, and if they have SMPTE offset
values defined, Dorico Pro uses them to set the timecode position for the start of the flow.

● If you chose Create All New Players, new players are added as required for each MIDI file.

● If you chose Merge with Existing Players Where Possible, any players that the imported
MIDI files and existing project have in common are merged, for example, if you imported a
MIDI file containing a solo piano into a project containing a piano and viola, the imported
MIDI file is added to the existing piano player.

TIP

You can also open MIDI files directly if you want them to be separate projects rather than new
flows in existing projects.

RELATED LINKS
Opening projects/files on page 61
Requantizing notes on page 178
Changing the sustain pedal controller settings for MIDI recording/import on page 181
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MIDI Import Options dialog
The MIDI Import Options dialog allows you to customize the settings Dorico Pro uses to
translate MIDI data into a Dorico project when importing MIDI files.

● You can open the MIDI Import Options dialog by choosing File > Import > MIDI and
opening a MIDI file from the File Explorer/macOS Finder.

MIDI Import Options dialog

The MIDI Import Options dialog contains the following sections:

1 Instrument handling
The options in this section determine how Dorico Pro chooses and names instruments
based on the imported MIDI file.
The Quantize Options button opens the MIDI Quantize Options dialog, which allows you
to customize the quantization settings.

2 Keyboard handling
The options in this section determine how Dorico Pro interprets keyboard music based on
the imported MIDI file, including the MIDI note number at which notes are split between
the right and left hand staves and whether CC64 indicates pedal lines.

3 Performance preservation
The options in this section allow you to determine how much of the original performance
in the MIDI file you want to preserve for playback purposes. They do not affect how the
imported MIDI notes are notated, as this is controlled by the quantization options set.

4 Player handling
The options in this section allow you to determine the players and layouts to which
instruments in the MIDI file are assigned. For example, if you are importing a MIDI file into
an existing project in order to orchestrate, you might want to activate Create player
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group for new players and deactivate Create part layouts for new players to add a
single, independent group of players without creating any extra part layouts for them.

RELATED LINKS
Changing the sustain pedal controller settings for MIDI recording/import on page 181

MIDI Quantize Options dialog
The MIDI Quantize Options dialog allows you to customize the quantization settings you want
to apply to imported MIDI files and notes input by recording with a MIDI device.

You can open the MIDI Quantize Options dialog in any of the following ways:

● Click Quantize Options in the MIDI Import Options dialog.

● Click Quantization Options in the Recording subsection of the Play page in Preferences.

NOTE

Your settings are linked between both ways of accessing the dialog.

MIDI Quantize Options dialog

The MIDI Quantize Options dialog contains the following options:

Quantization unit
Allows you to set the smallest beat unit to which you want notes to be quantized. For
example, if the smallest intentional note duration in your imported file is an eighth
note, set Quantization unit to eighth notes.

Detect tuplets
Allows you to control whether off-beat notes can be considered tuplets. If you know
there are no intentional tuplets in your imported MIDI file, deactivating Detect
tuplets ensures no notes are imported as tuplets.

Quantization unit for tuplets
Allows you to set the smallest beat unit to which you want tuplet notes to be
quantized. For example, if the smallest intentional tuplet note duration in your
imported file is a quarter note, set Quantization unit for tuplets to quarter notes.

Fill gaps
Allows you to determine whether Dorico Pro fills in gaps between short notes. If you
are importing already precisely quantized music, we recommend that you deactivate
Fill gaps to ensure that note and rest durations are notated exactly as quantized.

RELATED LINKS
MIDI recording on page 176
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Exporting MIDI
You can export flows as separate MIDI files, for example, if you want to edit the audio in further
detail in a DAW. MIDI files exported from Dorico Pro contain any markers in the project by
default.

PROCEDURE

1. Choose File > Export > MIDI to open the Export MIDI dialog.

2. In the Select flows to export list, activate the checkbox for each flow you want to export.
You can also click Select All or Select None at the bottom of the list.

3. Click Choose Folder beside the Export to field to open the File Explorer/macOS Finder.

4. In the File Explorer/macOS Finder, locate and select the destination folder you want.

5. Click Open (macOS)/Select Folder (Windows) to insert the new path in the Export to field.

6. Activate/Deactivate Create folder for exported files.

7. Click OK to export the selected flows as MIDI files and close the dialog.

Export MIDI dialog
The Export MIDI dialog allows you to save individual flows as separate MIDI files.

● You can open the Export MIDI dialog by choosing File > Export > MIDI.

Export MIDI dialog

The Export MIDI dialog comprises the following:
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1 Select flows to export
Contains a list of all the flows in the project. Flows are included in the export when their
checkbox is activated.

2 Selection options
Allow you to select/deselect all the flows in the project. For example, you can deselect all
flows and then activate the checkbox of a single flow you want to export.

3 Create folder for exported files
Controls whether or not Dorico Pro generates a new folder for the selected flows within
the selected export path. The automatic folder name is “Flows from” followed by the
project file name, for example, “Flows from Smyth - String Quintet”.

4 Export to field
Displays the current export path where exported files will be saved.

5 Choose Folder
Opens the File Explorer/macOS Finder and allows you to change the export path.

Importing tempo tracks
You can import tempo tracks into individual flows in existing projects, for example, if you are
writing music for a film and changes to the footage require tempo and time signature changes.
This does not overwrite the notes and notations in the flow.

PROCEDURE

1. Choose File > Import > Tempo Track to open the File Explorer/macOS Finder.

2. In the File Explorer/macOS Finder, locate and select the MIDI file whose tempo track you
want to import.

3. Click Open to open the Import Tempo Track dialog.

4. In the Import into flow list, select the flow into which you want to import the tempo track.

5. In the Import and replace section, activate the checkbox for each tempo track aspect you
want to include.

6. Optional: If you activated the checkbox for Markers as, choose one of the following
options:

● Markers

● System Text

7. Optional: If you chose System Text for Markers as, activate/deactivate Show border
around system text markers.

8. Click OK to import the tempo track and close the dialog.

RESULT
The tempo track is imported into the selected flow. All selected aspects are applied to the
existing music, and notes and tempo marks are adjusted as required.

Import Tempo Track dialog
The Import Tempo Track dialog allows you to import tempo tracks to individual flows within
projects and to control which aspects of the tempo track you want to apply to the flow.

● You can open the Import Tempo Track dialog by choosing File > Import > Tempo Track
and opening a MIDI file from the File Explorer/macOS Finder.
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Import Tempo Track dialog

The Import Tempo Track dialog comprises the following:

1 Import into flow
Contains a list of all the flows in the project. The currently selected flow is highlighted.

NOTE

You can only import tempo tracks into a single flow at a time.

2 Import and replace
Allows you to control which tempo track aspects you want to include in your import and
apply to the selected flow.

● Timecode display offset sets the initial timecode position at the start of the flow.

● Tempo changes replaces all immediate and gradual tempo changes in the flow with
the tempo changes from the MIDI file.

● Time signatures replaces all time signatures in the flow with time signatures from
the MIDI file.

● Markers as adds any markers from the MIDI file to the flow as either Markers or
System Text.
Importing markers as Markers replaces any existing markers in the flow with
markers from the MIDI file, while importing markers as System Text does not
replace any existing markers or system text objects.

● Show border around system text markers adds borders to markers imported as
system text objects when activated. Only available if you have chosen System Text
for Markers as.
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Exporting tempo tracks
You can export flows as separate tempo tracks, for example, if you want to apply the tempo
marks and time signatures of one flow to a different flow, which can be in the same project.

PROCEDURE

1. Choose File > Export > Tempo Track to open the Export Tempo Track dialog.

2. In the Export Tempo Track dialog, activate the checkbox for each flow you want to export
as a tempo track. You can also click Select All or Select None at the bottom of the list.

3. Click Choose Folder beside the Export to field to open the File Explorer/macOS Finder.

4. In the File Explorer/macOS Finder, locate and select the destination folder you want.

5. Click Open (macOS)/Select Folder (Windows) to insert the new path in the Export to field.

6. Activate/Deactivate Create folder for exported files.

7. Click OK to export the selected flows as tempo tracks and close the dialog.

Export Tempo Track dialog
The Export Tempo Track dialog allows you to save individual flows as separate tempo tracks in
the format of MIDI files.

● You can open the Export Tempo Track dialog by choosing File > Export > Tempo Track.

Export Tempo Track dialog

The Export Tempo Track dialog comprises the following:

1 Select flows to export
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Contains a list of all the flows in the project. Flows are included in the export when their
checkbox is activated.

2 Selection options
Allow you to select/deselect all the flows in the project. For example, you can deselect all
flows and then activate the checkbox of a single flow you want to export.

3 Create folder for exported files
Controls whether or not Dorico Pro generates a new folder for the selected flows within
the selected export path. The automatic folder name is “Flows from” followed by the
project file name, for example, “Flows from Smyth - String Quintet”.

4 Export to field
Displays the current export path where exported files will be saved.

5 Choose Folder
Opens the File Explorer/macOS Finder and allows you to change the export path.

Exporting audio
You can export projects as audio files in either MP3 or WAV format, including exporting flows and
players as separate files, for example, if you want to share an audio mock-up of only the soloist’s
part in the second flow.

PROCEDURE

1. Choose File > Export > Audio to open the Export Audio dialog.

2. In the Export Audio dialog, choose one of the following file format options:

● Export compressed mp3 (.mp3)

● Export uncompressed WAV (.wav)

3. Activate/Deactivate Export each selected flow as a separate file.

4. In the Select flows to export list, activate the checkbox for each flow you want to export
as audio. You can also click Select All or Select None at the bottom of the list.

5. Activate/Deactivate Export players as separate files.

6. Optional: If you activated Export players as separate files, activate the checkbox for each
player you want to export in the Select players to export list. You can also click Select All
or Select None at the bottom of the list.

7. Click Choose Folder beside the Export to field to open the File Explorer/macOS Finder.

8. In the File Explorer/macOS Finder, locate and select the destination folder you want.

9. Click Open (macOS)/Select Folder (Windows) to insert the new path in the Export to field.

10. Click OK to export the selected flows/players as the selected type of audio file and close
the dialog.

Export Audio dialog
The Export Audio dialog allows you to save individual flows and players as separate audio files,
either MP3 or WAV.

● You can open the Export Audio dialog by choosing File > Export > Audio.
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Export Audio dialog

The Export Audio dialog contains the following options and lists:

1 File format options
Allows you to choose the audio file format you want to export. Compressed MP3 files are
smaller than WAV files but this corresponds to a reduced audio quality.

2 Export each selected flow as a separate file
Allows you to export each flow in the project as a separate audio file instead of as a single
audio file.

3 Select flows to export
Contains a list of all the flows in the project. Flows are included in the export when their
checkbox is activated.

4 Export players as separate files
Allows you to export each player in the project as a separate audio file instead of all
players in a single audio file.

5 Select players to export
Contains a list of all the players in the project. Players are included in the export when their
checkbox is activated. Only available if you have activated Export players as separate
files.

6 Selection options
Allow you to select/deselect all the flows/players in the corresponding list. For example,
you can deselect all flows and then activate the checkbox of a single flow you want to
export.

7 Export to field
Displays the current export path where exported audio files will be saved.

8 Choose Folder
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Opens the File Explorer/macOS Finder and allows you to change the export path.

Auto-save
The auto-save function stores a version of the currently active project at regular intervals. This
reduces the chances of losing significant amounts of work if you accidentally close a project
without saving or in the unlikely event that Dorico Pro or your computer crashes.

By default, Dorico Pro uses the AutoSave folder inside your Dorico Projects folder, whose
default location is in the Documents folder for your user account. Dorico Pro also auto-saves
new projects you have not explicitly saved yet.

NOTE

Dorico Pro might become less responsive briefly in order to perform auto-saves, particularly for
larger projects.

Auto-save with multiple projects open

Only the currently activated project is auto-saved at each auto-save interval if you have multiple
projects open. This is because only a single project at a time can be activated for playback. If you
are switching between multiple projects frequently, we recommend that you set a smaller auto-
save interval.

Removal of auto-save files

All files in the AutoSave folder are automatically deleted when you close their corresponding
projects and also when you quit Dorico Pro.

IMPORTANT

This includes any file in the AutoSave folder, not just auto-save projects. Therefore, it is
important that you do not choose your main projects folder as your AutoSave location or save
projects in the AutoSave folder.

TIP

If you want to access earlier versions of projects, you can use project backups.

RELATED LINKS
Toolbar on page 34
Project backups on page 80

Recovering auto-saved projects
If Dorico Pro crashes, you can recover the most recent auto-saved version of each project that
was open.

PROCEDURE

1. Reopen Dorico Pro.

2. In the Recover Auto-saved Projects dialog that opens after the Dorico Pro splash screen,
activate the checkbox for each auto-saved project you want to recover.

NOTE

Any auto-saved projects you do not recover are permanently deleted once you close the
dialog.
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3. Click Recover Selected Projects to recover the selected auto-saved projects and close the
dialog.

RESULT
The selected auto-saved projects are recovered and opened in separate project windows.

AFTER COMPLETING THIS TASK
You can save auto-saved projects permanently in any folder location and with new file names if
required.

Changing the auto-save frequency
You can change how frequently Dorico Pro auto-saves projects. By default, the auto-save interval
is five minutes for the currently active project.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click General in the page list.

3. In the Files section, change the value for Auto-save every [n] minutes.

4. Click Apply, then Close.

Changing the auto-save location
You can change the folder that Dorico Pro uses to store auto-save files. By default, Dorico Pro
uses the AutoSave folder inside your Dorico Projects folder, whose default location is in the
Documents folder for your user account.

IMPORTANT

● We strongly recommend not choosing your main Dorico Projects as the auto-save
location, as all files inside the AutoSave folder are deleted when you quit Dorico Pro.
Similarly, if you have saved projects in the AutoSave folder, those projects are deleted
when you quit Dorico Pro.

● If Dorico Pro is unable to write to the specified folder, it cannot auto-save projects. There is
no warning if this is the case, so we recommend that you only change the auto-save
location if you are certain your user account can successfully save files there.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click General in the page list.

3. In the Files section, click Choose beside the Auto-save folder field to open the File
Explorer/macOS Finder.

4. In the File Explorer/macOS Finder, locate and select the folder where you want to save
auto-save projects.

5. Click Open (macOS)/Select Folder (Windows) to insert the new path in the Auto-save
folder field.

6. Click Apply, then Close.

RESULT
The default auto-save folder is changed. If the folder specified does not exist, Dorico Pro creates
it.
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Disabling auto-save
You can disable auto-save completely, for example, if it is significantly affecting the performance
of a large project.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click General in the page list.

3. In the Files section, deactivate Auto-save every [n] minutes.

4. Click Apply, then Close.

Project backups
Dorico Pro stores backup versions of your projects each time you save them explicitly. By default,
the previous five saves are stored as backups.

Their default location is in a folder named after the corresponding project file name in the
Backup Projects folder in the Dorico Projects folder, whose default location is in the
Documents folder for your user account.

Changing the number of backups per project
You can change the number of backups that Dorico Pro stores for each project, for example, if
you want to store a greater range of changes.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click General in the page list.

3. In the Files section, change the value for Number of backups per project.

4. Click Apply, then Close.

Changing the backup location
You can change the folder that Dorico Pro uses to store project backups. By default, Dorico Pro
uses the Backup Projects folder inside your Dorico Projects folder, whose default location is in
the Documents folder for your user account.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click General in the page list.

3. In the Files section, click Choose beside the Project backup folder field to open the File
Explorer/macOS Finder.

4. In the File Explorer/macOS Finder, locate and select the folder where you want to save
project backups.

5. Click Open (macOS)/Select Folder (Windows) to insert the new path in the Project backup
folder field.

6. Click Apply, then Close.
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RESULT
The default folder for project backups is changed. If the folder specified does not exist, Dorico
Pro creates it.
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In Setup mode, you can determine the players and instruments for your project. You can also
create and manage flows, set up layouts, and add videos.

Project window in Setup mode
The project window in Setup mode contains the default toolbar, the music area, and the status
bar. It provides panels with all the tools and functions that allow you to add players and
instruments as well as to create layouts and flows for your project.

You can switch to Setup mode in any of the following ways:

● Press Ctrl/Cmd-1.

● Click Setup in the toolbar.

● Choose Window > Setup.

Panels in Setup mode

The following panels are available in Setup mode:

1 Players
Lists the players, instruments, and groups in your project. By default, players are assigned
to all flows and to both the full score layout and their own part layout.

Setup mode
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2 Layouts
Lists the layouts in your project. A single full score layout and a part layout for each player
are created automatically, but you can create and delete layouts as required. By default,
layouts contain all flows and full score layouts contain all players.

3 Flows
Shows the flows in your project, ordered left to right. By default, flows contain all players
and are assigned to all layouts.

The three panels work together to allow you to control how and where the players, layouts, and
flows in your project are used. When you select an item in one of the panels, that panel and the
selected item are highlighted in a different color and checkboxes appear in cards in the other
panels. You can activate/deactivate these checkboxes independently to change how material is
distributed across players, layouts, and flows.

Players panel
The Players panel lists the players, instruments, and groups in your project. It is located on the
left of the window in Setup mode.

You can hide/show the Players panel in Setup mode in any of the following ways:

● Press Ctrl/Cmd-7.

● Click the disclosure arrow on the left edge of the main window.

● Choose Window > Show Left Panel.

Players panel in Setup mode

The Players panel contains a list of all the groups, players, and ensembles in your project, with
each player shown as a card. Each player card shows the following:
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1 Disclosure arrow
Expands/Collapses the player card.

2 Player type
Shows the type of player from the following options:

● Solo player

● Section player

3 Player name
Shows the name of the player. Dorico Pro automatically adds the names of the assigned
instruments to the player name. If required, you can rename the player.

4 Add instruments icon
Opens the instrument picker from which you can select an instrument for the player.

5 Instrument labels
Each instrument assigned to a player has its own instrument label. If you hover the mouse
pointer over an instrument label, an arrow appears that allows you to open a menu with
further options that allow you to, for example, change the instrument names or move the
instrument to another player.

The action bar at the bottom of the panel contains the following options:

Add Solo Player

Adds an individual player to your project. Dorico Pro also automatically adds a part
layout for the player to the Layouts panel.

Add Section Player

Adds a player to your project that represents multiple players who all play the same
instrument. Dorico Pro also automatically adds a part layout for the player to the
Layouts panel.

Add Ensemble

Adds multiple players to your project that represent standard combinations of
musical instruments. Dorico Pro also automatically adds part layouts for each player
in the ensemble to the Layouts panel.

Add Group

Adds a group to your project to which you can assign all types of players.
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Delete Player

Deletes selected players or groups from the Players panel.

The order in which the players are listed in the panel is the default order in which they appear in
layouts. You can change the player order for each layout individually in the Players section of the
Players page in Setup > Layout Options.

RELATED LINKS
Players on page 94
Layouts panel (Setup mode) on page 86
Layout Options dialog on page 90

Instrument picker
The instrument picker allows you find and add instruments and ensembles to your project. It
contains multiple versions of some instruments that have specific formatting requirements, such
as French Horn, which has a version whose part layouts are always in treble clef.

You can open the instrument picker in Setup mode in any of the following ways:

● Click the plus symbol in solo player cards in the Players panel.

● Select a player in the Players panel and press Shift-I.

● Right-click a player in the Players panel and choose Add Instrument to Player.

● Add a new player or ensemble.

Instrument picker

The instrument picker contains the following sections and options:

1 Search field
Allows you to enter the instrument you are searching for directly. You can enter only part
of the instrument name, such as cello for Violoncello.

2 Instrument family column
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Contains instrument families to help you focus your instrument search.

3 Instrument column
Contains the instruments available in the selected instrument family.

4 Instrument type column
Contains options for multiple possible transpositions or different behavior in part layouts
for the selected instrument. This column is not populated for instruments that do not have
further options.

5 Create Empty Kit
Adds an empty percussion kit to the player.

6 Import Kit
Imports an existing percussion kit previously exported as a library file.

7 Add/Add Ensemble to Score
Adds the selected instrument/ensemble to the project. Adding an ensemble adds multiple
players at once.

In addition to entering the instrument or ensemble you want directly into the Search field, you
can click options in the instrument picker to select them, and you can also select other items in
the same column by pressing Up Arrow/Down Arrow.

You can cycle forwards through the instrument picker by pressing Tab, which navigates in the
following order: Search field, Instrument, Instrument type, Instrument family. You can also
cycle backwards by pressing Shift-Tab, which navigates in the opposite direction.

An enclosure line shows which instrument family or instrument is selected when using the
keyboard to navigate.

RELATED LINKS
Adding solo/section players on page 95
Adding ensembles on page 102
Adding empty percussion kits to players on page 105
Importing percussion kits on page 1021

Layouts panel (Setup mode)
In Setup mode, the Layouts panel contains a list of all the full score and instrumental part
layouts in the project. It is located on the right of the window.

You can hide/show the Layouts panel in Setup mode in any of the following ways:

● Press Ctrl/Cmd-9.

● Click the disclosure arrow on the right edge of the main window.

● Choose Window > Show Right Panel.
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Layouts panel in Setup mode

The Layouts panel lists the default full score layout and all the layouts that you have created for
your project, displayed as cards. Each layout card shows the following:

1 Disclosure arrow
Expands/Collapses the layout card.

2 Layout type
Shows the type of layout from the following options:

● Full score layout

● Instrumental part layout

● Custom score layout

3 Layout name
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Shows the name of the layout. Dorico Pro automatically adds default names depending on
the name of the instrument that is assigned to a player and on the type of layout that is
added. For example, if you assign a flute to a player, the instrumental part layout
automatically gets the same name. If you add an empty instrumental part layout, the
layout name shows Empty part and an incremental number if you add multiple empty
part layouts.

4 Page size and orientation
Shows the size and orientation of the layout as set on the Page Setup page in Setup >
Layout Options.

5 Space size
Shows the space size between two staff lines in points, as set on the Page Setup page in
Layout Options. This indicates the size of staves in the layout.

6 Layout number
Allows you to set a unique number for the layout that can be used as part of its file name
when exported as a graphic. This can be useful to ensure exported part layout files are
organized in their orchestral order, as this is usually different to their alphabetical order.

The action bar at the bottom of the panel contains the following options:

Add Full Score Layout

Adds a full score layout to your project. By default, every player and flow is
automatically included in the layout.

Add Instrumental Part Layout

Adds an empty instrumental part layout to your project. You can then add one or
multiple players to the layout. By default, a part layout contains all flows that are
created in your project.

Add Custom Score Layout

Adds a custom score layout that initially without players or flows.

Sort Layouts

Sorts all layouts in the Layouts panel according to their type in the following order:
full score layouts, instrumental part layouts, custom score layouts. It does not sort
part layouts according to orchestral order.

Layout Options

Opens the Layout Options dialog for one or multiple selected layouts.

Delete Layout

Deletes selected layouts from the Layouts panel.

RELATED LINKS
Layouts on page 120
Layout Options dialog on page 90
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Flows panel
The Flows panel shows all the flows that are created for your project. It is located at the bottom
of the window in Setup mode.

You can hide/show the Flows panel in Setup mode in any of the following ways:

● Press Ctrl/Cmd-8.

● Click the disclosure arrow at the bottom of the main window.

● Choose Window > Show Bottom Panel.

Flows panel in Setup mode

The Flows panel shows the default flow and all the flows that you created for your project as
cards. Each flow card shows the following:

1 Flow name
Shows the name of the flow. If you create multiple flows without renaming them, each
flow name shows a number that increments with each new flow that you create. The
number also indicates the position of the flow in a layout.

2 Film reel icon
Indicates the flow has an attached video.

3 Flow timecode
Shows the start timecode for the flow.

4 Flow number
Shows the number of the flow. The number increments with each new flow that you
create. The number also indicates the position of the flow in a layout.

To the right of the Flows panel, the following options are available:

Add Flow
Adds a new flow to your project. By default, every new flow is automatically included
in all layouts, and every player is added to the new flow.

Setup mode
Project window in Setup mode 

89
Dorico 2.2.20



Notation Options
Opens the Notation Options dialog that provides multiple options that allow you to
make changes that affect the way music is notated for each flow.

Delete Flow
Deletes one or multiple selected flows.

RELATED LINKS
Flows on page 117
Notation Options dialog on page 139
Videos on page 125

Project Info dialog
For every project and every flow that you create in Dorico Pro, you can specify project
information in the Project Info dialog.

● You can open the Project Info dialog by choosing File > Project Info.

In the Project Info dialog, you can enter information for the whole project and for each flow. For
example, each flow in your project might have a different composer and lyricist.

You can use tokens in text frames to refer to the information you enter into the different fields on
the different pages in the Project Info dialog.

RELATED LINKS
Text tokens on page 332

Layout Options dialog
The Layout Options dialog provides multiple options that allow you to make changes that affect
the way the notation is laid out on pages of each layout.

You can change the physical properties of the layout, such as page size, staff size, or margins,
and the notation, such as note spacing or staff labels.

TIP

You can save all options that you set in Layout Options as the default for new projects by
selecting a layout type from the Layout type menu and clicking Save as Default.

You can open Layout Options in any of the following ways:

● Press Ctrl/Cmd-Shift-L in any mode.

● Choose Setup > Layout Options in Setup mode.

● Click Layout Options in the Layouts panel in Setup mode.
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Layout Options

The Layout Options dialog contains the following:

1 Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages. When you click a page in this list, any applicable section titles appear below the
page in the page list.

2 Section titles
Shows the titles of any sections on the selected page. You can click these section titles to
navigate directly to that section of the page.

3 Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible
settings, the current setting is highlighted.

4 Layouts list
Contains all the layouts in your project. You can select one, multiple, or all layouts. You can
select multiple layouts in any of the following ways:

● Click one of the selection options in the action bar.

● Ctrl/Cmd-click to select multiple layouts.

● Shift-click to select multiple adjacent layouts.

5 Action bar
Contains selection options that allow you to select layouts in the Layouts list according to
their type.

● Select All selects all layouts, regardless of their type.

● Select All Full Score Layouts selects all full score layouts only.

● Select All Part Layouts selects all part layouts only.

● Select All Custom Score Layouts selects all custom score layouts only.

6 Layout type
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Allows you to select the layout type for which you want to save your settings as the default.
For example, you can save new default settings for part layouts without affecting the
default settings for full score layouts.

7 Save as Default/Remove Saved Defaults
This button has different functions depending on whether you have existing saved
defaults for the selected layout type.

● Save as Default saves all options currently set in the dialog as the default for the
selected layout type in new projects.

● Remove Saved Defaults deletes your previous saved defaults without resetting the
options in the current project. After removing your saved defaults, all layouts of the
selected type in future projects start with the default factory settings. If you have
existing saved defaults, you can access Remove Saved Defaults by pressing Alt
(macOS)/Ctrl (Windows).

8 Reset to Factory/Reset to Saved Defaults
This button has different functions depending on whether you have existing saved
defaults for the selected layout type.

● If you have no saved defaults for the selected layout type, this button is Reset to
Factory, which resets all the options in the dialog back to the default factory
settings for the selected layout type.

● If you have existing saved defaults for the selected layout type, this button is Reset
to Saved Defaults, which resets all the options in the dialog back to your saved
defaults for the selected layout type. You can access Reset to Factory instead by
pressing Alt (macOS)/Ctrl (Windows). Resetting options back to the default factory
settings only affects the selected layout type in the current project and does not
delete your saved defaults, meaning future projects still start with your saved
defaults.

RELATED LINKS
Options dialogs in Dorico Pro on page 30
Staves on page 906

Making layout-specific changes in Layout Options
You can make project-wide changes for each layout independently in Layout Options.

PROCEDURE

1. Open Layout Options in any of the following ways:

● Press Ctrl/Cmd-Shift-L in any mode.

● Choose Setup > Layout Options in Setup mode.

● Click Layout Options at the bottom of the Layouts panel in Setup mode.

2. In the Layouts list, select the layouts in which you want to change options in one of the
following ways:

● Click Select All in the action bar.

● Click Select All Full Score Layouts in the action bar.

● Click Select All Part Layouts in the action bar.

● Click Select All Custom Score Layouts in the action bar.

● Shift-click adjacent layouts.

● Ctrl/Cmd-click individual layouts
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By default, the layout currently open in the music area is selected when you open the
dialog.

3. Click a page in the page list.

4. Look through the available options, and change the settings as required.

5. Click Apply, then Close.
If you make changes and close the dialog without clicking Apply, you are prompted to
save or discard your changes.

RESULT
The changes are applied immediately to the selected layouts.

Players, layouts, and flows
In Dorico Pro, players, layouts, and flows are all connected to each other. Because they exist in
the project rather than in a single score, you can, for example, have players and flows saved in
the project without showing them in the full score.

● Players can be assigned to any combination of layouts and flows. For example, you can
assign a single player to both the full score layout and their own part layout, and remove
them from flows in which they do not play. By default, players are assigned to all flows that
originated in the project, all full score layouts, and their own part layout.

● Layouts can contain any combination of players and flows. For example, you can assign all
the singers to a single part layout, then remove the flows from the layout in which they do
not sing. By default, layouts contain all flows and full score layouts contain all players.

● Flows can contain any combination of players and be assigned to/removed from layouts.
By default, flows contain all players and are assigned to all layouts.

NOTE

● If you remove a player from a flow, any notes you have already input for that player in that
flow are deleted.

● Removing a flow from a layout automatically removes that layout from the flow, and vice
versa. The same is true for players and layouts, and players and flows.

When you select a card in one of the panels in Setup mode, each card in the other panels shows
a checkbox. Connected cards appear highlighted and have activated checkboxes, while
unconnected cards are not highlighted and have deactivated checkboxes. For example, if you
select a single player card in the Players panel, all the flows to which the player is assigned are
highlighted and activated in the Flows panel and all layouts to which the player is assigned are
highlighted and activated in the Layouts panel.
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A piano player selected in the Players panel with connected flows and layouts highlighted in the Flows and
Layouts panels

RELATED LINKS
Project window in Setup mode on page 82
Flows on page 117
Layouts on page 120
Changing the flows assigned to layouts on page 122
Changing the players assigned to layouts on page 121
Changing the players assigned to flows on page 118

Players
Before you start writing music, you must specify the players that are playing one or multiple
instruments.

A player can be a solo player, which represents a single person who can play one or more
instruments. For example, a clarinettist may double alto saxophone or bass clarinet.

A player can also be a sectional player, which represents multiple people, each of whom plays the
same instrument. For example, a violin section or the soprano section of a choir.

Dorico Pro uses this knowledge about players and their instruments to assist you in producing a
practical score efficiently, for example, by making it very easy to handle instrument doubling and
divisi.

When you add a player in Dorico Pro, the following happens automatically:

● An instrumental part layout is created.

● The player is added to any full score layouts that already exist. If no full score layouts
exists, a new full score layout is created.

● The player is assigned to all existing flows that originated in the project. It is not added to
any flows that you imported into the project.

RELATED LINKS
Players, layouts, and flows on page 93
Flows on page 117
Layouts on page 120
Changing the players assigned to layouts on page 121
Changing the players assigned to flows on page 118
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Adding solo/section players
You can add both solo and section players to your project. Solo players can hold multiple
instruments, whereas section players can divide.

PREREQUISITE
The Players panel is open.

PROCEDURE

1. In the Players panel, add an empty-handed player in any of the following ways:

● If you have started a new project, click Add Solo Player in the project start area.

● If you have started a new project, click Add Section Player in the project start area.

● At the bottom of the Players panel, click Add Solo Player.

● At the bottom of the Players panel, click Add Section Player.

The instrument picker opens.

TIP

You can also open the instrument picker at any time by clicking the plus symbol in solo
player cards, selecting a player in the Players panel and pressing Shift-I, or right-clicking a
player and choosing Add Instrument to Player.

2. Select the instrument you want in the instrument picker.

3. Press Return to add the selected instrument.

RESULT
The solo/section player is added to all flows in the project. It is automatically named after the
selected instrument.

NOTE

● Players are not automatically added to flows that you imported into the project.

● If you want to add multiple instruments to your project at the same time, you can add
ensembles or use a project template.

AFTER COMPLETING THIS TASK
If you added a solo player and you want them to hold multiple instruments, add other
instruments to the solo player.

RELATED LINKS
Instrument picker on page 85
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Changing player names on page 100
Project start area on page 37
Adding instruments to players on page 104
Adding ensembles on page 102
Starting new projects from project templates on page 59

Duplicating players
You can duplicate players. This adds another player of the same type.

PROCEDURE

● In the Players panel, right-click the player you want to duplicate and choose Duplicate
Player from the context menu.

RESULT
A new player is added, with the same instruments as the original player. The original and new
players are automatically numbered to ensure their names are unique.

RELATED LINKS
Changing player names on page 100
Instrument numbering on page 103

Player, layout, and instrument names
In Dorico Pro, you can use three different names to refer to the same player in different contexts.
This allows you to show relevant information in different places in the score.

The three different names that relate to players and instruments are:

● Player name

● Layout name

● Instrument name

You can change all of these names for individual players independently of other instruments of
the same type. Each name is used in different places. Player and layout names are shown using
text tokens.

Player name
Given to players in the Players panel. It is not used in the score, instead you can use
the player name as part of your own workflow, independently of what instruments
and players are called in staff labels and layout names.
Player names are automatically generated when you add instruments.

Layout name
The name for each layout in the Layouts panel. They are used at the top of individual
part layouts.
Layout names are automatically generated when you add instruments, and are
linked to the player name until you change the layout name.

Instrument names
Used in staff labels. This means that the instrument label on each staff is relevant to
the instrument currently being played by that player, rather than listing all
instruments that player is playing in the flow.
For example, if a clarinettist is doubling bass clarinet, the staff label where the player
plays clarinet automatically shows Clarinet, and the staff label automatically shows
Bass Clarinet where the player plays bass clarinet.
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All instruments in Dorico Pro come with a set of instrument names that you can
change.
You can change the instrument names for individual instruments independently,
even if other players in the project are playing the same instrument.
You can save your changes to instrument names as default, so your names are used
whenever you add that instrument again in the project.

NOTE

Changing the default instruments names does not change the instrument names of
existing instruments of that type in your project.

RELATED LINKS
Instrument numbering on page 103
Text tokens on page 332
Staff labels on page 895
Layouts on page 120

Edit Instrument Names dialog
The Edit Instrument Names dialog allows you to change the content and formatting of each
instrument’s names, which are used in staff labels and instrument change labels shown above
the staff. You can edit both singular/plural full instrument names and singular/plural short
instrument names.

● You can open the Edit Instrument Names dialog in Setup mode by clicking the arrow in
an instrument label in the Players panel and choosing Edit Names.
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Edit Instrument Names dialog

The Edit Instrument Names dialog contains the following options and sections:

1 Editing instrument
Displays the permanent underlying name of the instrument. You cannot change this
name.

2 Editing
Allows you to switch between editing the Singular names and Plural names of the
selected instrument.
Singular names is used when staff labels are shown by default, Plural names is used
when the staff contains multiple players.

3 Full name section
Contains options that allow you to edit the appearance of the full instrument name.

4 Full name text editor options
Allows you to customize the font, size, and formatting of the long staff label of the selected
instrument.

NOTE

The horizontal alignment of staff labels always uses the alignment of the paragraph style,
not the alignment set in the Edit Instrument Names dialog.

5 Full name text editing area
Shows the current long name for the selected instrument, as it appears in Full staff labels.
You can select any part of the instrument name and edit it independently of other parts,
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for example, if you want to add additional information on a new line and in italics.
However, when used for instrument change labels above the staff, instrument names are
always shown on a single line.
Staff labels are right-aligned by default, so appear at the right edge of the text editing
area.

NOTE

Staff labels always use the alignment set for the paragraph style, they do not use the
alignment set in the Edit Instrument Names dialog. This ensures consistent alignment
across the whole system.

6 Short name section
Contains options that allow you to edit the appearance of the short instrument name.

7 Short name text editor options
Allows you to customize the font, size, and formatting of the short staff label of the
selected instrument.

NOTE

The horizontal alignment of staff labels always uses the alignment of the paragraph style,
not the alignment set in the Edit Instrument Names dialog.

8 Short name text editing area
Shows the current short staff label for the selected instrument, as it appears in
Abbreviated staff labels. You can select any part of the instrument name and edit it
independently of other parts, for example, if you want to add additional information on a
new line and in italics. However, when used for instrument change labels above the staff,
instrument names are always shown on a single line.
Staff labels are right-aligned by default, so appear at the right edge of the text editing
area.

NOTE

Staff labels always use the alignment set for the paragraph style, they do not use the
alignment set in the Edit Instrument Names dialog. This ensures consistent alignment
across the whole system.

9 Show transposition
Allows you to choose when the transposition is shown in the instrument name for the
selected instrument. It is common to see the transposition included in the name of
transposing instruments, such as Clarinet in B♭.
You can choose when the transposition is shown from the following options:

● Always: instrument transpositions are shown even if you have chosen to hide them
on the Staves and Systems page in Setup > Layout Options.

● Follow Layout Options: instrument transpositions can be hidden and shown,
depending on your per-layout settings in Layout Options.

● Never: instrument transpositions are never shown, even if you have chosen to show
them in Layout Options.

10 Save as default for instrument
Activating the checkbox saves your changes in the dialog as the default for any new
instruments of that type that you add to the project.

11 Reset to Default
Removes all your changes to staff labels for the selected instrument type and reverts them
to the default settings.
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RELATED LINKS
Paragraph Styles dialog on page 366
Staff labels on page 895
Changing the length of staff labels project-wide on page 899

Changing player names
You can change the player names of players, and reset renamed players to their default name.

NOTE

Player names are not used for staff labels in the score or for naming layouts, instead they are for
your own reference in Setup mode.

Staff labels use the name set for each instrument in the Edit Instrument Names dialog.

PROCEDURE

1. In the Players panel, select the card of the player whose player name you want to change.

2. Open the player name text field in any of the following ways:

● Double-click anywhere in the player card.

● Right-click in the player card and choose Rename from the context menu.

3. Enter a new name, or click Reset to Default to revert the name to the default name.

4. Press Return.

RESULT
The player name of the selected player is changed.

NOTE

This does not change the staff label that appears in the score. You can change the name used for
staff labels in the Edit Instrument Names dialog, and change the layout name for the names at
the top of parts.

Changing layout names
Layout names are used to identify individual layouts, for example, as the name at the top of
parts. You can change the layout names of players, and reset renamed players to their default
name.

NOTE

Layout names are not used for staff labels. Staff labels use the name set for each instrument in
the Edit Instrument Names dialog.

PROCEDURE

1. In the Layouts panel, select the name of the player whose layout name you want to
change.

2. Open the layout name text field in any of the following ways:

● Double-click anywhere in the layout card.

● Right-click in the layout card and choose Rename from the context menu.

3. Enter a new name, or click Reset to Default to revert the name to the player name.
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4. Press Return.

RESULT
The layout name of the selected player is changed, or reverted to the default name.

NOTE

This does not change the staff label that appears in the score. You can change the name used for
staff labels in the Edit Instrument Names dialog, and change the layout name for the names at
the top of parts.

Changing instrument names
Instrument names are used in staff labels and instrument change labels shown above the staff.
You can change the different instrument names used for each instrument.

NOTE

Changing instrument names does not change the name shown at the top of part layouts. If you
want to change the name used at the top of part layouts, change the layout name.

PROCEDURE

1. In the Players panel, click the disclosure arrow in the player card containing the
instrument whose names you want to change.
This expands the card to show the instruments held by the player.

2. Click the arrow that appears in the instrument label when you hover over it and choose
Edit Names to open the Edit Instrument Names dialog.

3. Enter new names in any of the name fields.

4. Optional: Activate Save as default for instrument.

5. Click OK to save your changes and close the dialog.

RESULT
The instrument names for the selected instrument are changed.

● If you did not save your changes as default, only the names of the selected instrument are
changed. Any instruments of the same type added later use the original default names.

● If you saved your changes as default, any instruments of the same type added later use
your new instrument names. The instrument names of any other instruments of the same
type already in your project are not changed.

RELATED LINKS
Edit Instrument Names dialog on page 97

Changing the orchestral order of players
You can change the order in which players appear in the score in the Players panel.

PROCEDURE

1. In the Players panel, select the player card of the player whose position in the score you
want to change.

2. Click and drag the player card upwards/downwards in the panel.
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An insertion line indicates where the player will be positioned.

Deleting players
You can delete players from your project.

PROCEDURE

1. In the Players panel, select the players that you want to delete.

2. Press Backspace or Delete.

3. Choose one of the following options in the warning message that opens:

● Delete Player Only: Deletes the player and the music that you created for the
instruments belonging to that player.

● Delete Player and Part Layouts: Deletes the player, the music, and all part layouts
to which the player is assigned.

NOTE

The part layout cannot be deleted if it also contains other players.

Ensembles
If you add an ensemble in Dorico Pro, multiple players are added to your project at the same
time.

Dorico Pro provides a set of predefined ensembles that you can use. Adding an ensemble is one
of the ways to achieve building up an instrumentation quickly. The predefined ensembles that
you can create with Dorico Pro follow standard patterns, such as double woodwind which refers
to two flutes, two oboes, two clarinets, and two bassoons.

Adding ensembles
You can add multiple players at once by adding ensembles, such as a complete string section or
four-part choir.

PREREQUISITE
The Players panel is open.

PROCEDURE

1. Open the instrument picker for ensembles in any of the following ways:

● If you have started a new project, click Add Ensemble in the project start area.

● Click Add Ensemble at the bottom of the Players panel.

2. Select the ensemble you want in the instrument picker.

3. Click Add Ensemble to Score.
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RESULT
The ensemble players are added to the Players panel, either as solo or as section players.

TIP

You can also add multiple instruments to your project at the same time by using a project
template.

RELATED LINKS
Instrument picker on page 85
Changing player names on page 100
Project start area on page 37
Starting new projects from project templates on page 59

Instruments
You can assign instruments to solo and section players as well as to ensembles.

In Dorico Pro, you can assign multiple instruments to solo players, as solo players often play
multiple instruments, such as an oboist doubling the cor anglais.

Before you can assign instruments, you must add players or ensembles, which may in turn also
be assigned to groups if needed. If you add ensembles, it is by default not necessary to add any
instruments, since these are already included when you select the type of ensemble. However,
you can add further instruments to ensembles.

Instruments in Dorico Pro do not have limited ranges; it is possible to notate any pitch in any
register on every instrument. However, in the piano roll editor in Play mode, only pitches that fall
in the MIDI note range 0-127 can be represented. Similarly, if you input a pitch beyond the range
of samples in the assigned VST instrument, the pitch does not sound in playback.

You can always change the initial specification and add or delete instruments.

RELATED LINKS
Piano roll editor on page 408
VST and MIDI Instruments panel on page 402

Instrument numbering
When there are multiple instruments of the same type in the same score, they are each
automatically given a number for easy and clear identification.

For example, if there is only one flute in a score, it is called Flute, but if there are three flutes, they
are called Flute 1, Flute 2, and Flute 3.

Dorico Pro automatically numbers instruments when there are multiple instruments of the same
type in your project.

One violin with no number Adding a second violin automatically generates
numbers for both violins

Setup mode
Instruments 

103
Dorico 2.2.20



Instrument numbers are automatically generated for players if the following criteria are met:

● Players are the same type, either solo or section.

● Players have at least one instrument in common.

● Players are in the same group.

● Instrument names are the same.

For example, if you have two flutes in your project, but one flute is a section player and the other
flute is a solo player, they are not numbered automatically. Similarly, if the two flutes are in
different player groups, they are not numbered automatically.

RELATED LINKS
Player, layout, and instrument names on page 96
Changing instrument names on page 101
Player groups on page 115

Transposing instruments
While most instruments produce notes at concert pitch, transposing instruments produce a note
that is different to the one that is written. For example, two common orchestral transposing
instruments are clarinet in B♭ and horn in F.

When a clarinet in B♭ plays a C, the sound produced is a B♭, one tone below. When a horn in F
plays a C, the sound produced is an F, a fifth below. Other instruments that conventionally
produce a pitch different to the one notated include the piccolo (sounding an octave above
written), double bass (sounding an octave below written), and glockenspiel (sounding two
octaves above written).

Dorico Pro stores all note information in concert pitch and automatically transposes notes as
appropriate for the transposition of the instrument. This means notes are automatically changed
in transposing layouts compared to non-transposing layouts. You can also change instruments at
any time, and the music is adjusted automatically to ensure the correct pitches are shown.

RELATED LINKS
Concert vs. transposed pitch on page 123
Making layouts transposing/concert pitch on page 123
Setting different clefs for concert/transposed pitch on page 584

Adding instruments to players
You can add instruments to both solo and section players. You can add multiple instruments to
solo players, but only a single instrument to section players.

PREREQUISITE
You have added a solo or section player.

PROCEDURE

1. In the Players panel, select the player to which you want to add instruments.

2. Open the instrument picker in any of the following ways:

● Press Shift-I.

● Click the plus symbol to the right of the player card.

3. Select the instrument you want in the instrument picker.

4. Press Return to add the selected instrument.
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5. Optional: Repeat steps 1 to 3 to add multiple instruments to a single solo player.

NOTE

● You can only add a single instrument to each section player.

● If you want to add multiple instruments to your project at the same time, you can
add ensembles or use a project template.

RESULT
The selected instrument is added to the player. If you selected multiple players, the instrument is
only added to the first player in the Players panel.

NOTE

Before you have input any notes, only the first instrument held by solo players is shown in full
scores in page view. All instrument staves are shown in galley view, so we recommend switching
to galley view to input notes for any other instruments held by solo players.

RELATED LINKS
Instrument picker on page 85
Adding ensembles on page 102
Starting new projects from project templates on page 59
Switching to galley/page view on page 50

Adding empty percussion kits to players
You can add empty percussion kits to players, to which you can then add unpitched percussion
instruments.

PROCEDURE

1. In the Players panel, open the Edit Percussion Kit dialog in any of the following ways:

● Select a solo or section player, press Shift-I, and click Create Empty Kit in the
instrument picker.

● Click the plus symbol to the right of the added empty-handed player and click
Create Empty Kit in the instrument picker.

● Right-click a player and choose Create Empty Kit from the context menu.

2. Add the percussion instruments you want to the kit in the Edit Percussion Kit dialog.

RELATED LINKS
Edit Percussion Kit dialog on page 107
Instrument picker on page 85

Combining individual percussion instruments into kits
If a player is holding one or more individual percussion instruments, you can combine them into
a percussion kit.

PROCEDURE

1. Right-click the card of the player whose percussion instruments you want to combine into
a kit and choose Combine Instruments into Kit from the context menu.

2. Edit the kit in the Edit Percussion Kit dialog that opens.
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For example, you can change the order in which the instruments appear in a grid or on a
five-line staff.

RESULT
A new kit is created containing all the instruments held by the player.

NOTE

If the player was already holding one or more kit instruments, all individual instruments and any
other kits are combined into the first kit.

Changing instruments
You can change the instruments held by players without affecting any music already entered
onto their staves, for example, if your Clarinet part is very low and you want to change it to a
Bass Clarinet.

NOTE

● You cannot change percussion kits into other instruments, you can only change individual
unpitched percussion instruments.

● You cannot change a pitched instrument into an unpitched instrument, and vice versa.

PROCEDURE

1. In the Players panel, expand the card of the player whose instrument you want to change.
The card lists the instruments of the player.

2. Hover over the label of the instrument you want to change, click the arrow that appears,
and choose Change Instrument to open the instrument picker.

3. Select the instrument you want in the instrument picker.

4. Press Return to change to the selected instrument.

RESULT
The selected instrument is changed, without affecting any music on its staff.

NOTE

Where appropriate, new clefs are input. This means that notes can appear differently so that they
are notated correctly according to the new clef.

RELATED LINKS
Instrument picker on page 85
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Moving instruments between players
You can move individual instruments between players without affecting any music already input
for those instruments.

PROCEDURE

● In the Players panel, move instruments to other players in any of the following ways:

● Click and drag instruments individually and release them over the player card to
which you want to move them.

● Click the arrow that appears in the instrument label when you hover over it and
choose Move Instrument to Player > [Player].

NOTE

You can only move instruments to players already added to your project.

RELATED LINKS
Adding solo/section players on page 95

Deleting instruments
You can delete instruments from players.

IMPORTANT

If you delete an instrument from a player, any music that you have created for this instrument is
also deleted.

PROCEDURE

1. In the Players panel, expand the card of the player holding the instrument you want to
delete.

2. Click the arrow that appears in the instrument label when you hover over it and choose
Delete Instrument.

3. Click OK.

RESULT
The instrument is deleted from the player.

Edit Percussion Kit dialog
The Edit Percussion Kit dialog allows you to make changes to percussion kits, including which
instruments are included in them and how instruments are arranged in the different available kit
presentations.

● The dialog opens automatically when you create empty kits or combine existing
instruments into a kit.

● You can also open the Edit Percussion Kit dialog manually for existing percussion kit
instruments by expanding the player card of the player holding the percussion kit in the
Players panel in Setup mode, then clicking the arrow in its label and choosing Edit
Percussion Kit.
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NOTE

Percussion kit instrument labels are green in the Players panel in Setup mode.

Edit Percussion Kit dialog

1 Name
Allows you to enter or change the full name for the percussion kit. This is used in Full staff
labels for percussion kits that use the five-line staff presentation type.

2 Short name
Allows you to enter or change the abbreviated name for the percussion kit. This is used in
Abbreviated staff labels for percussion kits that use the five-line staff presentation type.

3 Drum set
Percussion kits are defined as drum sets when the checkbox is activated. Percussion kits
that are defined as drum sets follow your settings for drum sets on the Percussion page in
Notation Options, including for voicing and default stem directions.

4 Presentation types
Allows you to select a percussion kit presentation type in order to edit how the selected
percussion kit appears in that presentation type.

● 5-line Staff
Kit instruments are shown on a five-line staff. You can determine which instruments
are shown on each line and in each space of the staff. A single staff label containing
the name of the kit is shown.

● Grid
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Kit instruments are shown on a grid, with each instrument on its own line. You can
customize how large the gaps between each line are. Staff labels are shown for each
instrument in a smaller font than normal staff labels.

● Single-line Instruments
Kit instruments are shown as individual instruments with their own lines. Normal-
sized staff labels are shown for each instrument.

5 Editor
Displays the current arrangement of instruments in the selected percussion kit
presentation type. You can change the order of instruments and the layout of lines and
spaces in the grid presentation type by using the controls.

6 Controls
Allows you to change the order and stem direction of instruments in the selected
percussion kit presentation type. It also allows you to add slash voices to the kit.
You can access dialogs to change the noteheads used for each instrument in the kit by
clicking Edit Noteheads. You can also change how combinations of noteheads,
articulations, and tremolos affect playback by clicking Edit Percussion Playing
Techniques.
You can also change the names of individual instruments within percussion kits. Click Edit
Names to open the Edit Instrument Names dialog.

NOTE

This changes the appearance of percussion instrument names in all presentations.
Depending on the percussion kit presentation type, staff labels might use different
information than these instrument names.

7 Action bar
The action bar at the bottom of the dialog provides options that apply to all presentation
types.

● Add New Instrument

Opens the instrument picker, allowing you to choose a new unpitched percussion
instrument to be added to the kit.

● Add Existing Instrument From Player

Shows a menu listing the other players in your project that are holding individual
percussion instruments not in kits. You can select a percussion instrument from
another player to move to this kit, bringing its music with it.

● Remove Instrument From Kit

Removes the selected instrument from the kit, so it appears as an individual
instrument. You can move individual instruments to other players or into other kit
instruments.

● Change Instrument

Opens the instrument picker, which allows you to choose a new unpitched
instrument to replace the selected instrument while retaining its music.

● Delete Instrument
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Deletes the instrument from the kit, including its music.

8 Export Kit
Allows you to export the percussion kit as a library file so you can use it in other projects.

RELATED LINKS
Percussion kits on page 1020
Staff labels for percussion kits on page 904
Percussion kit presentation types on page 1025
Percussion Instrument Playing Techniques dialog on page 1027
Playing techniques for unpitched percussion instruments on page 1027

Adding instruments to percussion kits
You can add new instruments to percussion kits within the Edit Percussion Kit dialog.

PROCEDURE

1. In the Players panel, expand the card of the player holding the kit to which you want to
add instruments.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Click Add New Instrument to open the instrument picker.

4. Select the percussion instrument you want in the instrument picker.

5. Press Return to add the selected instrument.

6. Click Close.

RESULT
The selected instrument is added to the percussion kit.

Changing instruments in percussion kits
You can change existing instruments in percussion kits while retaining any existing music for that
instrument.

PROCEDURE

1. In the Players panel, expand the card of the player holding the kit in which you want to
change instruments.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Click the instrument you want to change.

4. Click Change Instrument in the action bar to open the instrument picker.

5. Select the percussion instrument you want in the instrument picker.

6. Press Return to change to the selected instrument.

7. Click Close.
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RESULT
The instrument is changed to the one selected in the instrument picker. Any music input for the
previous instrument is retained.

NOTE

Playing techniques expressed using playing technique-specific noteheads are not retained.

Defining percussion kits as drum sets
You can define individual percussion kits as drum sets. Drum sets follow your project-wide
setting for voicing in drum sets with five-line staff presentations.

PROCEDURE

1. In the Players panel, expand the card of the player holding the kit you want to define as a
drum set.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Activate Drum set in the top right of the dialog.

4. Click Apply, then Close.

RESULT
The selected percussion kit is defined as a drum set. The arrangement of voices for instruments
in the kit when using the five-line staff presentation type follows your project-wide setting on the
Percussion page in Write > Notation Options.

NOTE

If you no longer want a percussion kit to be defined as a drum set, you can deactivate Drum set
in the Edit Percussion Kit dialog for that kit.

RELATED LINKS
Notation Options dialog on page 139
Percussion Instrument Playing Techniques dialog on page 1027

Creating groups of instruments within grid presentation percussion kits
You can create groups of instruments within percussion kits that use the grid presentation type
in order to have a better overview of the instruments in the kit.

In grid presentation percussion kits, the name of each individual instrument is shown in the staff
label. You can simplify the staff label of grid presentation percussion kits by creating groups, for
example, to show Wood Blocks instead of Wood Block (High), Wood Block (Medium), and Wood
Block (Low).

PROCEDURE

1. In the Players panel, expand the card of the player holding the kit in which you want to
create groups in the grid presentation.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Click Grid at the top of the dialog.

4. Click the first instrument you want to include in the group.

5. Shift-click the last instrument you want to include in the group.
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NOTE

You can only include adjacent instruments in groups.

6. Click Add.

RESULT
A group is created containing the selected instruments. The group is given a default name that
you can change.

Renaming groups in grid presentation percussion kits
Group names are shown as instrument labels. You can change the names of groups in
percussion kits using grid presentation.

PROCEDURE

1. In the Players panel, expand the card of the player holding the kit in which you want to
change the names of groups in the grid presentation.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Click Grid at the top of the dialog.

4. Open the Edit Percussion Grid Group Names dialog in any of the following ways:

● Double-click the group.

● Click the group, then click Edit.

Groups are shown as colored blocks in the column to the left of the list of percussion kit
instruments.

5. Enter the names you want to give the group in the corresponding fields in the Edit
Percussion Grid Group Names dialog:

● Full Name

● Short Name

6. Click OK to save your changes and close the dialog.

RESULT
The name of the group is changed. This also changes the staff label for the group.

NOTE

Staff labels for groups in grid presentation percussion kits use a different paragraph style to the
staff labels for non-grouped instruments in grid presentation percussion kits.
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EXAMPLE

Ungrouped grid presentation percussion kit Grid presentation percussion kit with wood blocks
grouped

RELATED LINKS
Staff labels for percussion kits on page 904

Deleting groups within grid presentation percussion kits
You can delete groups in percussion kits using grid presentation, without deleting the
instruments within the group.

PROCEDURE

1. In the Players panel, expand the card of the player holding the kit from whose grid
presentation you want to delete groups.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Click Grid at the top of the dialog.

4. Click the group you want to delete.
Groups are shown as colored blocks in the column to the left of the list of percussion kit
instruments.

5. Click Delete.

RESULT
The group is deleted. The individual staff labels for each instrument in the group are restored.

Changing the positions of instruments within percussion kits
You can change the positions of instruments within percussion kits of all presentation types to
change the order in which the instruments appear in the score and parts. In five-line staff
presentation types, you can also change the staff position of slash voices.

PROCEDURE

1. In the Players panel, expand the card of the player holding the kit in which you want to
change the positions of instruments.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Click the kit presentation type in which you want to change the order of instruments.
For example, click Grid to change the order of instruments when the kit uses the grid
presentation type.

4. Click the percussion instruments and/or slash voices whose position you want to change.
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NOTE

When using the mouse, you can only move one instrument or slash voice at a time.

5. Change the position of the selected instruments/slash voices in any of the following ways:

● Click Move up arrow to move them upwards.

● Click Move down arrow to move them downwards.

● Click and drag a single instrument upwards/downwards (five-line staff presentation
only).

6. Optional: Repeat these steps for other instruments in the percussion kit, and for other kit
presentation types for the same percussion kit.

7. Click Apply, then Close.

RESULT
The positions of the selected instruments and/or slash voices within the kit is changed. Multiple
instruments can share the same staff position, but we recommend that they use different
noteheads so that the player can tell them apart.

RELATED LINKS
Moving notes to different instruments in percussion kits on page 1023

Changing the size of gaps between lines in percussion grids
You can change the size of gaps between lines in percussion kits using the grid presentation
type.

PROCEDURE

1. In the Players panel, expand the card of the player in whose percussion kit you want to
change the size of gaps in the grid presentation.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Click Grid at the top of the dialog.

4. Click the instruments below which you want to change the gap size.

5. Change the value for Gap.

6. Click Apply, then Close.

RESULT
The size of the gaps below the selected instruments is changed.

Removing individual instruments from percussion kits
You can remove individual instruments from percussion kits, for example, if you want to move an
instrument from one percussion kit to another player.

PROCEDURE

1. In the Players panel, expand the card of the player holding the kit from which you want to
remove instruments.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Click the instruments you want to remove from the kit.

4. Click Remove Instrument From Kit in the action bar.
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5. Click Close.

RESULT
The selected instruments appears as individual instruments belonging to the same player but
separate from the percussion kit.
You can then move the instruments to other players if required.

RELATED LINKS
Moving instruments between players on page 107

Player groups
A group represents a collection of musicians that are considered together, such as a choir,
orchestra, or chamber ensemble.

Grouping players together means they are positioned together in the score, numbered
independently, and are bracketed together according to the ensemble type chosen on the
Brackets and Braces page in Engrave > Engraving Options.

For example, if your project is for double choir (SATB/SATB), all voices are joined by a single
bracket by default because they are in the same family. However, if you add each choir to its own
group, they are bracketed separately. This is useful for to bracket players properly in works
containing multiple groups, such as in Britten's “War Requiem”, which has three distinct groups,
or in Walton's “Belshazzar's Feast” which requires two separate off-stage brass groups.

Similarly, you can create a group for an off-stage group of players in a large-scale work.

If the instruments were not already next to each other according to orchestral order, adding a
player group changes the order of players in the score project-wide.

RELATED LINKS
Brackets according to ensemble type on page 558
Brackets according to project template categories on page 60

Adding groups of players
You can organize players into groups, for example, if you want to bracket them together.

PREREQUISITE
The Players panel is open.

PROCEDURE

1. Optional: In the Players panel, select the players that you want to include in the group.

2. At the bottom of the Players panel, click Add Group.

RESULT
If you selected one or more players, they are added to the group. If no player was selected, an
empty group is added to the Players panel.

RELATED LINKS
Adding players to groups on page 116
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Brackets and braces on page 555

Renaming player groups
You can change the name of player groups after you have added them.

PROCEDURE

1. In the Players panel, double-click the name of the group.

2. Enter a new name for the group or edit the existing name.

3. Press Return.

Deleting player groups
You can delete groups of players, for example, if you no longer need a group of players that you
created when importing a MIDI file. When deleting player groups, you can choose to keep the
players within the group or delete them as well.

PROCEDURE

1. In the Players panel, select the group that you want to delete.

2. Press Backspace or Delete.

3. Choose one of the following options in the warning message that opens:

● Keep Players: Deletes the group but keeps the players.

● Delete Players: Deletes the group and the players it contains.

Adding players to groups
You can add existing or new players to player groups.

PREREQUISITE
You have added at least one player, one ensemble, or one group.

PROCEDURE

● In the Players panel, do one of the following:

● Select one or more players and click Add Group.

● Select a group, and click Add Solo Player, Add Section Player, or Add Ensemble.

RESULT
If you clicked Add Group, a new group is added for the selected players.
If you clicked Add Solo Player, Add Section Player or Add Ensemble, a new player or ensemble
is added to the selected group.

RELATED LINKS
Adding solo/section players on page 95
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Moving players between groups
You can move players from one group to another.

PROCEDURE

1. In the Players panel, select the players that you want to move to another group.

2. Click and drag the selected players to the position you want in the other group.
An insertion line indicates where the players will be positioned.

RESULT
The players are moved to the other group.

Removing players from groups
You can remove players from groups.

PROCEDURE

● In the Players panel, remove players from groups in any of the following ways:

● Click and drag multiple selected players out of the group and release the mouse
button.

● Right-click a single player and choose Remove Player from Group from the context
menu.

NOTE

You can only remove a single player from a group at a time when using the context
menu.

RESULT
The players are removed from their groups but remain in the project as individual players.

Flows
Flows are separate spans of music within your project, for example, movements or songs.

Every project contains at least one flow, and by default, every layout includes the music from
every flow in your project. If you create a new flow in Dorico Pro, the following happens:

● All music that you write for the new flow is automatically included in the existing full score
and instrumental part layouts. You can exclude any flow from any layout by deactivating
the respective flow card.

● All players are assigned to the new flow. You can exclude players from the flow by
deactivating the respective player card.

IMPORTANT

If you exclude a player from a flow, any notes that you have already input for that player in
that flow are deleted.

You can change certain options in each flow independently in the Notation Options dialog.

RELATED LINKS
Flows panel on page 89
Notation Options dialog on page 139
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Players on page 94
Layouts on page 120
Changing the players assigned to flows on page 118
Changing the flows assigned to layouts on page 122
Importing flows on page 63
Exporting flows on page 64

Adding flows
If you need more than one flow in your project, you can add new flows.

PROCEDURE

1. In the Flows panel, click Add Flow.

2. Optional: Repeat for as many flows as you require.

RESULT
A new flow is added to your project each time you click Add Flow. All existing players are
assigned to new flows, and new flows are automatically added to all existing full score and part
layouts.

RELATED LINKS
Importing flows on page 63

Changing the players assigned to flows
By default, all players in your project are added to all flows that originated in the project. You can
assign players to and remove players from flows manually, for example, if the soloists in a choral
work do not sing for an entire flow.

NOTE

If you remove a player from a flow, any notes you have already input for that player in that flow
are deleted.

PROCEDURE

1. In the Flows panel, select the flow whose assigned players you want to change.

2. In the Players panel, activate the checkbox in the player card of each player you want to
assign to the flow.

TIP

You can Shift-click to activate/deactivate the checkboxes in multiple player cards at once.

3. Optional: Repeat steps 1 and 2 for other flows whose assigned players you want to
change.
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RESULT
Players are assigned to the selected flow when the checkbox in their player card is activated, and
removed from the flow when the checkbox is deactivated.

RELATED LINKS
Players on page 94
Layouts on page 120
Tacets on page 352
Changing the flows assigned to layouts on page 122
Changing the players assigned to layouts on page 121

Flow names and flow titles
Whenever you add a flow to a project, the default name of a flow is Flow plus an incremental
number. You can rename flows in the Project Info dialog and in the Flows panel in Setup mode.

When you enter names for flows in the Flows panel in Setup mode, those names are
automatically added in the Title field for the appropriate flow in the Project Info dialog. If you
change the name in the Flows panel again later, the flow title is updated in the Project Info
dialog.

Titles shown in scores and parts in the music area are linked to the Title field for each flow in the
Project Info dialog.

This link is maintained until you change the names of flows in the Project Info dialog. Once you
change flow titles in the Project Info dialog, changing flow names in the Flows panel no longer
updates the Title field for that flow in the Project Info dialog.

This allows you to organize flows in Setup mode with different names to their official title.

RELATED LINKS
Project Info dialog on page 90
Text tokens on page 332

Renaming flows in Setup mode
You can change the names of flows in Setup mode. This automatically updates the title of the
corresponding flow until you change the title in the Project Info dialog.

PROCEDURE

1. In the Flows panel, double-click the card of the flow you want to rename to open the flow
name text field.

2. Enter a new name for the flow or edit the existing name.

3. Press Return.

RESULT
The name of the flow is changed. If you have not entered a different title for the flow in the
Project Info dialog, the title shown in the music area is updated to match the new flow name.

Changing flow titles in the Project Info dialog
You can change flow titles in the Project Info dialog. Once you have done so, flow titles are no
longer changed if you change their name in the Flows panel in Setup mode.

PROCEDURE

1. Choose File > Project Info to open the Project Info dialog.
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2. Select the flow whose title you want to change from the menu. Alternatively, use the arrow
buttons beside the menu to choose the flow.

3. Enter the new title you want in the Title field.

4. Optional: Repeat steps 2 and 3 for other flows in your project.

5. Click OK to save your changes and close the dialog.

RESULT
The titles of the selected flows are changed to what you entered.

NOTE

This breaks the link between flow names in the Flows panel in Setup mode and the title shown in
the music area.

Deleting flows
You can delete flows that you no longer need. This deletes all music for all instruments belonging
to all players in the flows.

PROCEDURE

1. In the Flows panel, select the flows you want to delete.

2. Press Backspace or Delete.

Layouts
Layouts allow you to present the music in your project differently for different purposes. For
example, part layouts only include the music that player needs to play whereas full score layouts
contain all staves in the project.

Dorico Pro provides the following layout types:

Full score
A full score layout includes by default all players and all flows in your project. You can
remove players and flows that you do not need. Full score layouts are concert pitch
by default.

Instrumental part
An instrumental part layout is automatically created when you add a player to your
project. You can add further players to the instrumental part layout. You can also
create empty instrumental part layouts and add players.
By default, instrumental part layouts contain all flows but you can exclude flows that
you do not need. They are also transposed pitch by default.

Custom score
A custom score layout initially does not contain any players or flows. This allows you
to create your score manually and to add, for example, only one flow instead of all
flows or only vocal and piano staves to create a condensed score for the chorus.
Custom score layouts are concert pitch by default.

RELATED LINKS
Page layouts on page 342
Flows on page 117
Players on page 94
Changing the flows assigned to layouts on page 122
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Changing the players assigned to layouts on page 121

Creating layouts
You can create multiple layouts for full scores and instrumental parts. You can also create
multiple custom score layouts.

PROCEDURE

● At the bottom of the Layouts panel, click one of the following layout types:

● Add Full Score Layout

● Add Instrumental Part Layout

● Add Custom Score Layout

RESULT
The layout is added to the list of layouts in the Layouts panel.

AFTER COMPLETING THIS TASK
You can assign players and flows to your layout.

Changing the players assigned to layouts
By default, all players are included in full score layouts and each player is automatically assigned
its own part layout. You can assign players to and exclude players from layouts manually, for
example, if you want to remove unnecessary players from the full score, or you want to add the
soloists’ music to the part for the accompanist.

PROCEDURE

1. In the Layouts panel, select the layout whose assigned players you want to change.

2. In the Players panel, activate the checkbox in the player card of each player you want to
assign to the layout.

TIP

You can Shift-click to activate/deactivate the checkboxes in multiple player cards at once.

3. Optional: Repeat steps 1 and 2 for any other layouts whose assigned players you want to
change.

RESULT
Players are assigned to the selected layout when the checkbox in their player card is activated,
and removed from the layout when the checkbox is deactivated. If you have not changed the
name of the layout, it is automatically updated to reflect the players included in the layout.
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RELATED LINKS
Player, layout, and instrument names on page 96
Changing layout names on page 100
Changing the players assigned to flows on page 118

Changing the flows assigned to layouts
By default, all flows in your project are added to all layouts. You can exclude flows that you do not
want to show in a layout. You can assign flows to and remove flows from layouts manually, for
example, if a flow in your project contains specific performance instructions for strings that you
want to show in string part layouts but not in other part layouts.

PROCEDURE

1. In the Layouts panel, select the layout whose assigned flows you want to change.

2. In the Flows panel, activate the checkbox in the flow card of each flow you want to assign
to the layout.

TIP

You can Shift-click to activate/deactivate the checkboxes in multiple flow cards at once.

3. Optional: Repeat steps 1 and 2 for other layouts whose assigned flows you want to
change.

RESULT
Flows are assigned to the selected layout when the checkbox in their flow card is activated, and
removed from the layout when the checkbox is deactivated.

RELATED LINKS
Changing the players assigned to flows on page 118

Renaming layouts
You can change the name of layouts.

If you add an instrumental part layout to project, its default name is Empty part. The default
names of full score and custom score layouts are Full score and Custom score. If you add
several layouts, an incremental number is added to the default names.

PROCEDURE

1. In the Layouts panel, open the layout name text field in any of the following ways:

● Double-click the name of the layout.

● Right-click the name of the layout and choose Rename from the context menu.

2. Enter the new name for the layout or edit the existing name.

3. Press Return.
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RELATED LINKS
Instrument numbering on page 103

Making layouts transposing/concert pitch
You can change whether each layout in your project is transposing or concert pitch. In Dorico
Pro, full score layouts are concert pitch and part layouts are transposing by default.

For example, full scores are often concert pitch, to show notes at their sounding pitch, but part
layouts are transposing so the player can read the notes they must play in order to achieve the
desired sounding pitch.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts you want to make transposing/non-transposing.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Players in the page list.

4. In the Players section, activate/deactivate Transposing layout.

5. Click Apply, then Close.

RESULT
The selected layouts are transposed pitch when Transposing layout is activated, and concert
pitch when it is deactivated.

TIP

You can also make layouts transposing by choosing Edit > Transposed Pitch, and concert pitch
by choosing Edit > Concert Pitch. This automatically updates the layout option but only for the
layout currently open in the music area.

RELATED LINKS
Transposing chord symbols on page 573
Setting different clefs for concert/transposed pitch on page 584

Concert vs. transposed pitch
Layouts in Dorico Pro can use concert or transposed pitch. This affects the pitches and key
signatures on staves belonging to transposing instruments.

When music is in concert pitch, all notes are written as they sound. This means that players with
transposing instruments reading music in concert pitch must transpose the music themselves.
For example, if a clarinet in B♭ reads a C in concert pitch, they must play the note D on their
instrument to produce the sounding note C.

When music is in transposed pitch, the notes written are the ones each instrument must play in
order to produce the desired sounding pitch. For example, if a clarinet in B♭ reads a D in
transposed pitch, the pitch that sounds from the instrument is C.

Transposing scores and parts also transpose key signatures according to the transposition of the
instrument.

RELATED LINKS
Transposing instruments on page 104
Transposing key signatures alongside selections on page 687
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Enharmonic equivalent key signatures on page 688
Setting different clefs for concert/transposed pitch on page 584

Sorting layouts
You can change the order in which layouts appear in the Layouts panel and the layout selector,
for example, if you added a custom score layout and want it to be positioned at the top next to
the full score layout.

PROCEDURE

1. In the Layouts panel, click and drag a layout card to a different position.
An insertion line indicates where the players will be positioned.

2. Release the mouse button.

RESULT
The layout is inserted at the selected position.

Renumbering layouts
You can renumber all the layouts in their project according to their current position in the
Layouts panel in Setup mode, for example, after you have dragged layouts to different positions.

PROCEDURE

● In the Layouts panel, right-click any layout card and choose Renumber Layouts from the
context menu.

RESULT
All layouts are renumbered according to their current position in the panel. Full score layouts,
custom score layouts, and part layouts are all numbered separately.

RELATED LINKS
Layouts panel (Setup mode) on page 86

Deleting layouts
You can delete any layout from the project, for example, if you only want to use a combined
Violin I and II part, you can delete their separate parts.

PROCEDURE

1. In the Layouts panel, select the layouts that you want to delete.

2. Press Backspace or Delete.

Restoring default layouts
You can recreate all the part layouts that Dorico Pro provides by default, for example, if you
accidentally deleted some part layouts.

PROCEDURE

● Choose Setup > Create Default Part Layouts.
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RESULT
The default set of part layouts is restored, recreating a single part layout for each player that
contains all flows in the project. Any part layouts that were recreated are added at the bottom of
the Layouts list.

Videos
Dorico Pro supports the use of videos within the program as well as the associated notations,
such as markers and timecodes, and allows you to find appropriate tempos based on where
important markers occur.

Videos are a fast sequence of images that create the impression of a moving image. They can be
any length, from only a few seconds up to several hours for feature-length films.

Videos in Dorico Pro are shown in a separate Video window and play back in sync with the music.
Any existing audio in the video is also played back, and you can control the volume of this audio
independently of the volume of the music.

TIP

You can use these features, including setting a project frame rate, without having a video
attached.

RELATED LINKS
Adding videos on page 127
Frame rates on page 129
Changing the project frame rate on page 130
Timecodes on page 819
Markers on page 814
Changing the volume of video audio on page 129

Supported video formats
Dorico Pro uses the same video engine that was introduced in Cubase and Nuendo in 2017. It
supports the most commonly-used video formats.

The following video formats are supported:

● MOV: Including H263, H264, Apple ProRes, DV/DVCPro and Avid DNxHR codecs

● MP4: Including H263 and H264

● AVI: Including DV/DVCPro and MJPEG/PhotoJPEG

All the common frame rates, such as 23.976, 24, 24.975, 25, 29.97, and 30 frames per second, are
fully supported in Dorico Pro.

NOTE

● Videos with variable frame rates are not supported.

● Support for more formats is planned for future versions.

You can consult the Steinberg support site for more information about the supported formats as
well as how to identify and change video formats.

RELATED LINKS
Frame rates on page 129
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Video Properties dialog
The Video Properties dialog allows you to change video-related settings, including their frame
rate and start position.

● You can open the Video Properties dialog in Setup mode by right-clicking a flow in the
Flows panel and choosing Video > Properties from the context menu.

The dialog also opens automatically when you add a new video.

Video Properties dialog

The Video Properties dialog contains the following fields and options:

Video file
Shows the location of the video file on your computer. This field is read-only.

Video frame rate
Shows the frame rate of the video file. This field is read-only.

Project frame rate
Allows you to select a frame rate for your project from the menu. You can only have a
single frame rate across the project.

Use video frame rate
Sets the project frame rate to be the same as the video file.

Flow attachment position
Allows you to set the rhythmic position at which the video attaches. This is set using
the Beat count and Beat unit settings in combination, such as eight dotted quarter
notes.

Video start offset
Allows you to set a position within the video that syncs with the flow attachment
position, for example, you can set the fifth second of the video to attach to the start
of the third bar.

Timecode start
Allows you to set the timecode at the start of the video. This also affects the
timecode of the flow, but the initial timecode of the flow adjusts to accommodate the
video. For example, if the initial timecode of the video is 02:00:00:00 but the video
does not start until the start of the third bar in 4/4, the initial timecode of the flow is
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eight beats of time less than 02:00:00:00; if the tempo is 60 bpm, this makes the
initial flow timecode 01:59:52:00.

NOTE

Flow timecodes are shown in their flow cards in the Flows panel.

RELATED LINKS
Timecodes on page 819
Flows panel on page 89

Adding videos
You can add a video to each flow in your project. You can also follow these steps to reload videos
previously added to the project that Dorico Pro can no longer locate.

Flows with missing videos show a triangle warning icon instead of the video icon in the flow card
in the Flows panel. This can happen if you send a project to someone else without the video file.

PREREQUISITE
You have added at least one player to the project.

PROCEDURE

1. In the Flows panel, right-click the flow to which you want to add/reload a video.

2. Choose Video > Attach from the context menu to open the File Explorer/macOS Finder.

3. In the File Explorer/macOS Finder, locate and select the video file you want to add.

4. Click Open to open the Video Properties dialog.

5. In the Video Properties dialog, change the options as appropriate for your project.

6. Click OK to save your changes and close the dialog.

RESULT
The selected video file is added to the flow and is shown in the Video window. A video reel icon
appears in the flow card in the Flows panel, beside a timecode indicating the combination of the
Video start offset and Timecode start.
If you reloaded a video, all your previous settings are retained.

RELATED LINKS
Timecodes on page 819
Changing the initial timecode value on page 820

Changing the start position of videos
You can change both the rhythmic position in the music at which videos start, and the position in
the video that coincides with that rhythmic position, for example, if you want the fifth second of a
video to sync with the start of the third bar of music.

PROCEDURE

1. In Setup mode, open the Video Properties dialog in one of the following ways:

● Add a video to a flow.

● In the Flows panel, right-click a flow and choose Video > Properties from the
context menu.
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2. In the Video Properties dialog, change the values for Flow attachment position and/or
Video start offset.

3. Click OK to save your changes and close the dialog.

RESULT
Changing the value for Flow attachment position changes the rhythmic position in the music at
which the video starts.
Changing the value for Video start offset changes the position in the video that occurs at the
Flow attachment position.
For example, if you change the Video start offset to 00:00:05:00 and the Flow attachment
position to 8, then the fifth second in the video happens on the eighth beat in the music.

NOTE

● The initial rhythmic position is 0. Therefore, if the Flow attachment position is set to 8
and the time signature is 4/4, the flow attachment occurs on the first beat in the third bar.

● Changing the Video start offset changes what part of the video coincides with the Flow
attachment position, but this does not cut the video before this point. Any preceding
video material is shown as long as it happens within the flow.

RELATED LINKS
Timecodes on page 819
Changing the initial timecode value on page 820

Hiding/Showing the Video window
You can hide and show the Video window at any time and in any mode, for example, if you do
not want it in view when working on the music in the music area.

PROCEDURE

● Hide/Show the Video window in any of the following ways:

● Press F4.

● In the toolbar, click Show Video.

● Choose Window > Video.

RESULT
The Video window is hidden/shown. It is shown when a tick appears beside Video in the Window
menu, and hidden when no tick appears.

RELATED LINKS
Toolbar on page 34

Changing the size of the Video window
You can change the size of the Video window at any time.

PREREQUISITE
The Video window is shown.
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PROCEDURE

● Change the size of the Video window in any of the following ways:

● Click and drag the corners/edges in any direction.

● Shift-click and drag a corner/edge to change the size without changing the shape.

RESULT
The size of the Video window is changed. Dorico Pro saves the new size and shape and uses this
for all projects until you change the size again.

Removing videos
You can remove videos from each flow independently.

PROCEDURE

● In the Flows panel, right-click the flow from which you want to remove a video and choose
Video > Detach from the context menu.

RESULT
The video is removed from the selected flow.

Changing the volume of video audio
Any audio that is part of a video you have added is played back in sync with the music in the
project. You can change the video volume manually.

PREREQUISITE
The Mixer window is shown.

PROCEDURE

1. Optional: If the Video channel is not shown in the Mixer window, click Video in the Mixer
toolbar.

2. Change the Video channel volume in any of the following ways:

● Click and drag the Video channel fader upwards/downwards.

● Click Mute at the top of the Video channel.

RESULT
The volume of audio from videos in your project is changed. If you clicked Mute, no audio from
videos sounds in playback.

RELATED LINKS
Hiding/Showing the Mixer window on page 445

Frame rates
The frame rate of a video is the number of still images that are used per unit of time in order to
create the impression of a moving image, commonly measured in frames per second, or “fps”.

The number of frames per second required to create the impression of a moving image is
determined by how fast the human eye processes movement, and so the most common frame
rate is around 24 fps. However, recent major films have been released at 48 fps, which results in
sharper images.
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Dorico Pro supports frame rates from 23.976 fps to 60 fps, for example, the US and Canadian
broadcast standard NTSC, which is used in, uses 29.97 fps.

Frame rates are closely linked to timecodes, as timecodes include both the time and the current
frame position.

All the common frame rates, such as 23.976, 24, 24.975, 25, 29.97, and 30 frames per second, are
fully supported in Dorico Pro.

By default, Dorico Pro uses the same frame rate for the project as the video file, but you can
manually choose a different frame rate.

RELATED LINKS
Timecodes on page 819

Changing the project frame rate
By default, Dorico Pro uses the video frame rate as the project frame rate. You can change the
project frame rate if you want it to be different, for example, if your project contains multiple
videos with different frame rates.

TIP

You can change the frame rate even if there are no videos in the project.

PROCEDURE

1. In Setup mode, open the Video Properties dialog in one of the following ways:

● Add a video to a flow.

● In the Flows panel, right-click a flow and choose Video > Properties from the
context menu.

2. In the Video Properties dialog, select the frame rate you want to use for the project from
the Project frame rate menu.

3. Click OK to save your changes and close the dialog.

RESULT
The project frame rate is changed.
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In Write mode, you can create your music. You can input notes and notations into your project,
make changes to existing music, and delete notes and notations.

Project window in Write mode
The project window in Write mode contains the default toolbar, the music area, and the status
bar. It provides toolboxes and panels with the tools and functions required to write your music.

You can switch to Write mode in any of the following ways:

● Press Ctrl/Cmd-2.

● Click Write in the toolbar.

● Choose Window > Write.

Toolboxes and panels in Write mode

The following panels and toolboxes are available in Write mode:

1 Notes toolbox
Contains tools that affect note input.

2 Notes panel
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Contains the note durations, accidentals, and articulations that are most commonly used
during note input.

3 Notations panel
Contains notation items that you can add to your music, such as dynamics and playing
techniques, divided into separate categories. Your current selection in the Notations
toolbox determines which notation items are shown.

4 Notations toolbox
Allows you to determine which notation items are shown in the Notations panel, and to
input certain items directly, such as rehearsal marks, chord symbols, and fingerings.

5 Properties panel
Contains properties that allow you to make individual modifications to the currently
selected notes and notations, independently of your project-wide settings.

NOTE

Many properties are layout-specific, meaning changing the properties of an item in one
layout does not affect the same item in other layouts. However, you can copy property
changes to other layouts.

RELATED LINKS
Copying property settings to other layouts on page 363

Notes toolbox
The tools in the Notes toolbox allow you to modify notes and change the type of notes you input.
The Notes toolbox is located on the left of the window in Write mode.

Dotted Notes

During step input, this inputs dotted notes, rests, or chords based on the currently
selected duration. When editing existing notes, you can use this tool to add/remove
rhythm dots from existing notes, rests, and chords.
You can also activate/deactivate Dotted Notes by pressing . (period). You can
increase the number of dots on notes by pressing Alt-. (period).

Rests

When this option is activated, you input rests of the currently selected duration
instead of notes.
You can also start/stop rest input by pressing , (comma).

Chords

When this option is activated, you add multiple notes at the same rhythmic position
in order to build a chord. This function prevents the caret from advancing
automatically after inputting a note.
You can also start/stop chord input by pressing Q.

Tuplets
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Clicking this option inputs a triplet bracket and the respective number of rests at the
specified rhythmic position. If the notes are beamed, no brackets are used.
You can input other types of tuplet, such as quintuplets, by using the tuplets
popover.

Grace Notes

When this option is activated, you input grace notes at the current rhythmic position
instead of normal notes.
You can also start/stop grace note input by pressing /.

Insert

When this option is activated, the notes you input are inserted before existing music
ahead of the caret instead of overwriting it. Similarly, reducing the duration of notes
with Insert mode activated pulls them closer together without leaving rests between
the notes.
You can also activate/deactivate Insert mode by pressing I.

Lock to Duration

When this option is activated, the durations of existing notes are used as you input
notes. This allows you to maintain the duration of notes while you change their
pitches.
You can also activate/deactivate Lock to Duration by pressing L.

Force Duration

When this option is activated, Dorico Pro always inputs notes/rests with the explicit
duration you have selected. For example, you can activate Force Duration to force
the input of a dotted quarter note on the second quarter beat of 4/4, where Dorico
Pro splits the note with a tie by default.

IMPORTANT

You can get unexpected results if you force the duration of notes and later change
the time signature or move barlines, for example.

If you activated Force Duration during input, you can remove the restrictions on
how Dorico Pro notates the music by selecting the affected passage of music and
selecting Edit > Reset Appearance.
You can also activate/deactivate Force Duration by pressing O.

Tie

During step input, this ties the note to be input to the previous note of the same
pitch. When editing existing notes, you can use this tool to tie together notes of the
same pitch in different voices or to tie grace notes to rhythmic notes.
You can also activate Tie by pressing T.
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NOTE

You cannot deactivate Tie. If you want to delete ties, you must use Scissors.

Scissors

During step input, this splits notes, chords, and explicit rests in two at the caret
position. When editing existing notes, it deletes all ties in tie chains.
You can also activate Scissors by pressing U.

Select

Activates/Deactivates mouse input. When mouse input is deactivated, you cannot
input notes by clicking on the staff.

RELATED LINKS
Inputting notes with rhythm dots on page 152
Inputting chords on page 167
Inputting tuplets on page 169
Inputting grace notes on page 167
Activating/Deactivating mouse input on page 151

Notes panel
The Notes panel contains buttons that allow you to select note and rest durations, and to input
accidentals, slurs, and articulations. It is located on the left of the window in Write mode.

You can hide/show the Notes panel in any of the following ways:

● Press Ctrl/Cmd-7.

● Click the disclosure arrow on the left edge of the main window.

● Choose Window > Show Left Panel.
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The upper part of the Notes panel contains note durations that you can select for input or to
change the duration of existing notes. By default, only the most common note durations are
shown. You can see all note durations by clicking the Show/Hide All Notes disclosure arrows at
the top and bottom of the section.

In the middle part of the Notes panel, you can activate/deactivate accidentals and activate slurs.
However, you cannot deactivate slurs, you must delete them.

In the bottom part of the Notes panel, you can activate/deactivate articulations.

RELATED LINKS
Inputting notes on page 149
Inputting accidentals on page 162
Inputting articulations on page 182
Inputting slurs on page 265

Properties panel (Write mode)
The Properties panel in Write mode contains quick access properties that allow you to change
notes and notations, both during note input and by changing existing notes. It is located at the
bottom of the window in Write mode.

The Properties panel contains a group of properties for each notation item. When you select a
note or item in the music area, the Properties panel displays the groups and options that you
might require to edit the selected note or item.

NOTE

● If you select multiple different types of notation items, only the groups that they have in
common are displayed. For example, if you select a slur, the Common and Slurs groups
are displayed in the Properties panel. However, if you select a slur and a note, only the
Common group is displayed.

● Many properties are layout-specific, meaning changing the properties of an item in one
layout does not affect the same item in other layouts. However, you can copy property
changes to other layouts.
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● If you need to change individual parts of notations, for example, the curvature direction of
a single tie within a tie chain, switch to Engrave mode.

You can hide/show the Properties panel in Write mode and Engrave mode in any of the following
ways:

● Press Ctrl/Cmd-8.

● Click the disclosure arrow at the bottom of the main window.

● Choose Window > Show Bottom Panel.

Notes and Rests group of the Properties panel in Write mode

Changing the properties of individual notes and items
You can change the properties of individual notes and notations independently of your project-
wide settings, for example, if you want crescendos to appear as hairpins by default but require a
single crescendo to appear as text.

NOTE

In Write mode, you can only change the properties of complete notes and notations. For
example, if a pedal line extends across multiple systems, you cannot change its line style on one
system but keep the original line style on another system. In Engrave mode, you can change
individual parts of notes and notations separately.

PROCEDURE

1. Select a note or notation item in the music area.

2. Optional: If the Properties panel is hidden, show it in any of the following ways:

● Press Ctrl/Cmd-8.

● Click the disclosure arrow at the bottom of the window.

● Choose Window > Show Bottom Panel.

3. In the Properties panel, change the properties you want.

RESULT
The complete note or notation item is changed. The changes are immediately displayed in the
music area.

NOTE

● Many properties are layout-specific. For example, if you change the placement of an item
relative to the staff in a full score layout, this does not affect the placement of the item in
the corresponding part layout. However, you can copy property settings to other layouts.
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● You can change the default settings for how notes are notated in each flow independently,
such as the default note and beam grouping in different meters, in Write > Notation
Options.

● You can change the default appearance and position of all notes and notations project-
wide in Engrave > Engraving Options.

RELATED LINKS
Notation Options dialog on page 139
Engraving Options dialog on page 299
Copying property settings to other layouts on page 363
Resetting the appearance of items on page 281
Resetting the position of items on page 281

Notations toolbox
The options in the Notations toolbox allow you to determine what notation items are available in
the Notations panel. The Notations toolbox is located on the right of the window in Write mode.

Clefs

Hides/Shows the Clefs panel, which contains sections for the different clefs and
octave lines that you can input.

Key Signatures, Tonality Systems, and Accidentals

Hides/Shows the Key Signatures, Tonality Systems, and Accidentals panel, which
contains sections for the different key signatures, tonality systems, and accidentals
that you can input. You can also create and edit custom tonality systems from this
panel.

Time Signatures (Meter)

Hides/Shows the Time Signatures (Meter) panel, which contains sections for the
different types of time signatures that you can input, including a section where you
can create custom time signatures, such as interchangeable time signatures and
time signatures with pick-up bars.

Tempo

Hides/Shows the Tempo panel, which contains sections for the different types of
tempo changes that you can input, including gradual tempo changes, metronome
marks, and tempo equations.

Dynamics

Hides/Shows the Dynamics panel, which contains sections for the different dynamics
that you can input, including immediate, gradual, and custom combined dynamics.

Ornaments

Write mode
Project window in Write mode 

137
Dorico 2.2.20



Hides/Shows the Ornaments panel, which contains sections for the different
ornaments and glissando lines that you can input.

Repeat Structures

Hides/Shows the Repeat Structures panel, which contains sections for the different
types of repeat structures, including repeat endings and segments, repeat markers,
single-note and multi-note tremolos, bar repeats, and slash regions.

Bars and Barlines

Hides/Shows the Bars and Barlines panel, which allows you to insert bars and to
input the different types of barlines.

Holds and Pauses

Hides/Shows the Holds and Pauses panel, which contains sections for the different
types of fermatas, breath marks, and caesuras that you can input.

Playing Techniques

Hides/Shows the Playing Techniques panel, which contains sections for the various
instrument family groups. Each section contains playing techniques for the
corresponding instrument family.

Cues

Hides/Shows the Cues panel, which allows you to find suitable places for cues and
input cues.

Video

Hides/Shows the Video panel, which allows you to open the Video Properties dialog
and to view and edit markers in the current flow.

Rehearsal Marks

Inserts a rehearsal mark at the selected rhythmic position.

Text

Opens the text editor which allows you to insert text at the selected rhythmic
position.

Lyrics

Opens the lyrics popover above the selected note on the staff, which allows you to
input lyrics.
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Chord Symbols

Opens the chord symbols popover above the selected note on the staff, which allows
you to input chord symbols.

Fingerings

Opens the fingerings popover above the selected note on the staff, which allows you
to input fingerings.

RELATED LINKS
Notations input on page 182
Text editor options in Write mode on page 266
Video Properties dialog on page 126

Notations panel
The Notations panel contains different notation items for your music depending on your
selection in the Notations toolbox. The Notations panel is located on the right of the window in
Write mode.

You can hide/show the Notations panel at any time, for example, if you want to find a notation to
input but then want to increase the size of the music area after inputting it.

RELATED LINKS
Hiding/Showing panels on page 18

Notation Options dialog
The Notation Options dialog provides multiple options that allow you to make changes that
affect the way music is notated for each flow by default.

The changes that you can make affect the following:

● Note and rest grouping, such as the handling of syncopated rhythms or of different
rhythms in different time signatures

● Voices, such as the sharing of noteheads among voices or the order in which multiple
voices are tucked together

● Accidentals, such as the handling of cautionary accidentals

● Transposition, such as the handling of key signatures in transposing instruments

● Percussion kits, such as the handling of multiple voices in a single percussion kit

TIP

If you want to make direct changes to notes and notations, you can use the different options in
the Properties panel.

You can open Notation Options in any of the following ways:

● Press Ctrl/Cmd-Shift-N in any mode.

● Choose Write > Notation Options in Write mode or Setup > Notation Options in Setup
mode.

● Click Notation Options in the Flows panel in Setup mode.
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Notation Options

The Notation Options dialog contains the following:

1 Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages. When you click a page in this list, any applicable section titles appear below the
page in the page list.

2 Section titles
Shows the titles of any sections on the selected page. You can click these section titles to
navigate directly to that section of the page.

3 Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible
settings, the current setting is highlighted.

4 Flows list
Contains all the flows in your project. You can select one, multiple, or all flows. You can
select multiple flows in any of the following ways:

● Click Select All in the action bar to select all flows in the project.

● Ctrl/Cmd-click to select multiple flows.

● Shift-click to select multiple adjacent flows.

5 Select All
Allows you to select all flows in the Flows list.

6 Save as Default/Remove Saved Defaults
This button has different functions depending on whether you have existing saved
defaults.

● Save as Default saves all options currently set in the dialog as the default for new
projects.

● Remove Saved Defaults deletes your previous saved defaults without resetting the
options in the current project. After removing your saved defaults, all future projects
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start with the default factory settings. If you have existing saved defaults, you can
access Remove Saved Defaults by pressing Alt (macOS)/Ctrl (Windows).

7 Reset to Factory/Reset to Saved Defaults
This button has different functions depending on whether you have existing saved
defaults.

● If you have no saved defaults, Reset to Factory resets all the options in the dialog
back to the default factory settings.

● If you have existing saved defaults, Reset to Saved Defaults resets all the options in
the dialog back to your saved defaults. You can access Reset to Factory instead by
pressing Alt (macOS)/Ctrl (Windows). Resetting options back to the default factory
settings only affects the current project and does not delete your saved defaults,
meaning future projects start with your saved defaults.

RELATED LINKS
Flows on page 117
Options dialogs in Dorico Pro on page 30

Making flow-specific changes in Notation Options
You can change options in the Notation Options dialog for each flow independently.

PROCEDURE

1. Open Notation Options in any of the following ways:

● Press Ctrl/Cmd-Shift-N in any mode.

● Choose Write > Notation Options in Write mode.

● Click Notation Options in the Flows panel in Setup mode.

2. In the Flows list, select the flows in which you want to make changes in one of the
following ways:

● Ctrl/Cmd-click individual flows.

● Shift-click adjacent flows.

● Click Select All.

By default, only the current flow is selected when you open the dialog.

3. Click a page in the page list.

4. Look through the available options, and change the settings as required.

5. Click Apply, then Close.

Note Input Options dialog
The Note Input Options dialog provides multiple options that allow you to determine how
Dorico Pro interprets the data and MIDI you input by default.

For example, there are options relating to how accidentals and notes are spelled when inputting
notes using a MIDI keyboard, and what you want to include in chord symbols based on what you
play.

You can open Note Input Options in any of the following ways:

● Press Ctrl/Cmd-Shift-I in any mode.

● Choose Write > Note Input Options in Write mode.
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Note Input Options

1 Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages.

2 Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible
settings, the current setting is highlighted.

3 Save as Default/Remove Saved Defaults
This button has different functions depending on whether you have existing saved
defaults.

● Save as Default saves all options currently set in the dialog as the default for new
projects.

● Remove Saved Defaults deletes your previous saved defaults without resetting the
options in the current project. After removing your saved defaults, all future projects
start with the default factory settings. If you have existing saved defaults, you can
access Remove Saved Defaults by pressing Alt (macOS)/Ctrl (Windows).

4 Reset to Factory/Reset to Saved Defaults
This button has different functions depending on whether you have existing saved
defaults.

● If you have no saved defaults, Reset to Factory resets all the options in the dialog
back to the default factory settings.

● If you have existing saved defaults, Reset to Saved Defaults resets all the options in
the dialog back to your saved defaults. You can access Reset to Factory instead by
pressing Alt (macOS)/Ctrl (Windows). Resetting options back to the default factory
settings only affects the current project and does not delete your saved defaults,
meaning future projects start with your saved defaults.

RELATED LINKS
Navigation during chord symbol input on page 216
Accidental selection during MIDI input on page 164
Options dialogs in Dorico Pro on page 30
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Inputting vs. editing
Dorico Pro distinguishes the processes for inputting and editing music.

Inputting

If you can see the caret, you are inputting new music. The caret must be activated in order to
input notes and notations. If the caret is activated, selecting tools or items in the Notes toolbox
and the Notes panel affects the note or chord that you are about to input, as you can specify the
duration, rhythm dot, accidentals, and articulations. Then you specify the pitch by clicking the
note into the score, by pressing the letter name of the note on your computer keyboard, or by
playing the note or chord on your MIDI keyboard.

When the caret is activated, notes and notations are input at the caret position.

If no notes or chords are selected in the music area and you select a duration, either by pressing
its key command or by clicking it in the Notes panel, mouse input is activated. If you move the
mouse pointer over the staff, a shadow note is displayed to indicate where the note will be input
if you click.

NOTE

Deactivating mouse input prevents Dorico Pro from starting mouse input in this circumstance.

Editing

If you cannot see the caret, you can edit existing music. Editing music includes deleting notes
and notations, which you can only do in Write mode, although you can also delete notes in Play
mode but not notations. You can switch back and forth between inputting and editing at any
time.

When the caret is not activated, new items are input at the position of the first selected item in
the music area. If there is no selection, the mouse pointer is loaded with the new item. The item
is then created at the location where you click.

To edit existing notes and notations, you must select them in the music area. This allows you to
update the selected notes or items when you select, for example, new note durations,
accidentals, or articulations in the Notes panel.

We recommend that you spend a moment to understand the difference between how Dorico Pro
behaves if the caret is shown and if it is not. In the latter case, all editing functions operate on the
items that you have selected in the music area.

RELATED LINKS
Editing and selecting on page 272
Caret on page 146
Note input on page 145
Notations input on page 182

Mouse input settings
There are a number of different settings that you can choose from to determine how mouse
input functions in Dorico Pro.

You can set your preferences for mouse input in the Editing section of the Note Input and
Editing page in Preferences.

You can choose between the following options for mouse input:

● Create item at selection
Items are input at the position of selected items or notes in the music area.
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● Load pointer with item
Items are loaded onto the mouse pointer so you can click in the music area where you
want to input the item.

You can also activate/deactivate Allow multiple items to be created with the mouse.

When Allow multiple items to be created with the mouse is activated, you can load an item
onto your mouse pointer and input the same item in the music area multiple times without
having to reselect the item each time you input it. When this option is deactivated, you can only
input an item loaded onto your mouse pointer once. If you want to input the item at multiple
positions, you must reselect it each time.

NOTE

Changing your preferences permanently changes the functionality for all new projects.

RELATED LINKS
Preferences dialog on page 51

Rhythmic grid
The rhythmic grid is a unit of rhythmic duration whose value affects certain aspects of inputting
and editing, such as the amount by which items move. However, it does not control the duration
of notes and items that you input.

Rhythmic grid set to eighth notes (quavers) shown above the staff

The current rhythmic grid value is shown by the note value in the status bar, and by ruler
markings above the staff on which the caret is active. Longer lines in the rhythmic grid indicate
beat divisions, while shorter lines indicate beat subdivisions. In Play mode, the rhythmic grid is
shown by the frequency of vertical lines in tracks and in the ruler at the top of the event display.

The rhythmic grid helps you to identify the following:

● The exact input position when using the caret or the mouse

● The amount by which the caret moves when using Right Arrow/Left Arrow

● The amount by which notes and items are lengthened/shortened

● The amount by which notes and items move

It also allows you to control how precisely notes and items are positioned when inputting them
with the mouse or when copying and pasting. For example, setting the rhythmic grid value to
32nd notes allows you to input notes and items at a greater number of possible rhythmic
positions than when the rhythmic grid is set to quarter notes.

You can change the rhythmic grid value at any time.

RELATED LINKS
Caret on page 146
Moving the caret manually on page 148
Event display on page 407
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Changing the rhythmic grid value
You can change the value of the rhythmic grid. The value is indicated by the note value symbol in
the status bar and by the beat divisions and subdivisions in the ruler markings above the caret.

The rhythmic grid value is set to eighth notes (quavers) by default.

PROCEDURE

● Change the value of the rhythmic grid in any of the following ways:

● Press Alt-] to decrease the rhythmic grid value.

● Press Alt-[ to increase the rhythmic grid value.

● Choose Write > Rhythmic Grid > Decrease Grid Resolution.

● Choose Write > Rhythmic Grid > Increase Grid Resolution.

● Choose Write > Rhythmic Grid > [Beat division].

● Select a value from the Rhythmic Grid selector in the status bar.

RESULT
Decreasing the rhythmic grid value makes it finer by making the note value shorter. Increasing
the rhythmic grid value makes it coarser by making the note value longer.

TIP

You can assign your own key commands for increasing and decreasing the rhythmic grid value.

RELATED LINKS
Status bar on page 42
Assigning key commands on page 55

Note input
In Dorico Pro, you can only input notes during note input, which is when the caret is activated.
This allows you to input notations at the caret position at the same time as inputting notes, and
also reduces the risk of you adding notes to staves accidentally.

You can input notes in different ways and using any of the following devices, including switching
between them at any time:

● MIDI keyboard

● Computer keyboard

● Mouse or touchpad

TIP

A MIDI keyboard is the fastest way to input notes.

RELATED LINKS
Notes on page 708
Inputting notes on page 149
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Caret
In Dorico Pro, the caret is a vertical line that extends above and below five-line staves but
appears shorter on percussion staves. It shows the rhythmic position at which notes, chords, or
notation items are input.

A caret is a mark that is commonly used when proofreading published text to denote the position
at which something should be inserted or added, for example, a missing letter or a word. In
software, the caret shows where something is inserted. The caret is also known as an “insertion
point” or “cursor”. In this documentation, we use “caret” to refer to the line that appears during
note input, and “cursor” to refer to the line that appears during text input.

If you are inputting notes, the caret advances to the next rhythmic position automatically. If you
are inputting chords, the caret does not move automatically, and you must move it to the next
rhythmic position manually. The caret has a note symbol beside it, which indicates the stem
direction and type of the currently selected voice. It is accompanied by a + symbol if the voice is
new.

The caret

The appearance of the caret changes depending on the input mode and the currently selected
voice number.

Insert
The caret shows V and inverted V shapes at the top and bottom. In Insert mode,
inserted notes shift all the music that follows the caret along by the input duration
instead of replacing existing notes. Similarly, reducing the duration of notes with
Insert mode activated pulls them closer together without leaving rests between the
notes.

Caret in Insert mode

Chords
The caret shows a plus symbol at the top left. During chord input, you can input
multiple notes at the same rhythmic position.

Caret when inputting chords

Lock to Duration
The caret is dashed. Lock to Duration allows you to repitch notes without changing
their duration or rhythm.
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Caret when Lock to Duration is activated

Grace Notes
The caret is shorter than the default caret. It allows you to input grace notes at the
caret position.

Caret when inputting grace notes

Voices
If you input multiple voices, the caret shows the following:

● A plus symbol at the bottom left

● The voice number into which you are inputting notes

● An up-stem note or a down-stem note symbol to indicate the stem direction of
the voice

Caret when inputting notes into a new down-
stem voice

Caret when inputting notes into a new,
second up-stem voice

Slash voices
The note beside the caret indicates a slash notehead.
If you input multiple slash voices, the caret shows the following:

● A plus symbol on the left at the bottom

● The number of the slash voice into which you are about to input notes

● An up-stem slash note or a down-stem slash note symbol indicating the stem
direction of the voice, and whether it has stems or is stemless

Caret when inputting notes
into an up-stem slash voice

Caret when inputting notes
into a new, second up-stem
slash voice

Caret when inputting notes
into a new, stemless slash
voice
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Percussion kits
The caret appears significantly smaller than usual when inputting notes into
percussion kits. The name of the kit instrument into which you are currently
inputting notes is shown above the rhythmic grid.

Caret when inputting notes into percussion kits

RELATED LINKS
Inputting notes in Insert mode on page 153
Inputting chords on page 167
Repitching notes without changing their rhythm on page 174
Inputting grace notes on page 167
Inputting notes into multiple voices on page 159
Inputting notes in percussion kits on page 154

Activating the caret
When the caret is activated, you can input notes and notations at the caret position, for example,
if you want to input a dynamic in the middle of a tie chain. When the caret is deactivated, you
cannot input notes, instead you can select and edit items in the music area.

PROCEDURE

● Activate the caret in any of the following ways:

● Select an item and press Shift-N or Return.

● Double-click the rhythmic position on the staff where you want to begin inputting
notes.

AFTER COMPLETING THIS TASK
You can deactivate the caret at any time by pressing Shift-N, Return, or Esc. If you have
deactivated mouse input, you can click another item in the music area to deactivate the caret.
Switching to another mode also deactivates the caret, as the caret can only be activated in Write
mode.

RELATED LINKS
Functions of the modes on page 17
Activating/Deactivating mouse input on page 151

Moving the caret manually
The caret moves automatically as you input notes, but you can also move it manually. For
example, the caret does not move automatically when inputting chords.

PROCEDURE

● Move the caret in any of the following ways:

● To move the caret according to the current rhythmic grid value, press Right Arrow/
Left Arrow.

● To advance the caret according to the note value currently selected, press Space.

Write mode
Note input 

148
Dorico 2.2.20



● To move the caret to the next/previous bar, press Ctrl/Cmd-Right Arrow/Ctrl/Cmd-
Left Arrow.

● To move the caret to the staff above/below, press Up Arrow/Down Arrow.

● To move the caret to the top/bottom staff in the system, press Ctrl/Cmd-Up Arrow/
Ctrl/Cmd-Down Arrow.

RELATED LINKS
Inputting chords on page 167

Changing the input pitch setting
You can input and record notes at either sounding pitch or written pitch according to the current
layout, for example, if you want to record notes at their sounding pitch in transposing part
layouts.

In concert pitch layouts, written pitch and sounding pitch are the same.

PROCEDURE

● Choose one of the following input pitch settings:

● To input/record notes at their written pitch, choose Write > Input Pitch > Written
Pitch.

● To input/record notes at their sounding pitch, choose Write > Input Pitch >
Sounding Pitch.

RESULT
The resulting pitch notated or recorded is changed. For example, if you input a C in a Horn in F
transposing part layout with the input pitch set to Sounding Pitch, the note is written as a G.

RELATED LINKS
Inputting notes on page 149
Inputting notes using MIDI recording on page 176
Making layouts transposing/concert pitch on page 123

Inputting notes
You can input notes into your project when note input is activated. You can input notes with a
computer keyboard, with the mouse, or by playing notes with a MIDI keyboard.

NOTE

During step input, you must specify the duration, accidentals, and articulations before specifying
the pitch. This applies to all input methods.

You can later add notations to notes after they have been input when note input is deactivated.

PREREQUISITE

● If you want to input notes into multiple instruments held by a single player or instruments
not visible in the score in page view, you are in Galley View.

● You have chosen the appropriate input pitch setting.

PROCEDURE

1. Start note input in any of the following ways:

Write mode
Note input 

149
Dorico 2.2.20



● Select a note or rest on the staff where you want to input notes and press Shift-N or
Return.

NOTE

If you select a notation, such as a dynamic, pressing Return opens the
corresponding popover instead of starting note input.

● Double-click the staff where you want to input notes.

2. Select a note value in any of the following ways:

● Press the number on your computer keyboard that corresponds to the rhythmic
value you want. For example, press 6 for quarter notes (crotchets), 5 for eighth
notes (quavers), 7 for half notes (minims), and so on.

● Click the rhythmic value you want in the Notes panel on the left of the window.

3. Optional: Add an accidental.

4. Optional: Add an articulation.

5. Input the pitches you want in any of the following ways:

● Press the corresponding letters on your keyboard.

TIP

Dorico Pro automatically selects the note whose register is the smallest interval
away from the previously input note. However, you can force a different register.

● To input a note above the previously input note, press Shift-Alt as well as the
letter for the note.

● To input a note below the previously input note, press Ctrl (macOS) or Ctrl-Alt
(Windows) as well as the letter for the note.

You must press Ctrl on Mac, not Cmd.

● Click the staff at the rhythmic position of each note you want to input.
A shadow notehead appears when inputting with the mouse to indicate where the
note will be input.

● Play the notes on a MIDI keyboard.

6. Press Esc or Return to stop note input.

RESULT
Notes are input with the selected duration and are played back as you input them by default.
Notes continue to be input with a rhythm dot and any articulations until you deactivate them.
However, accidentals are only added to the first note you input after selecting them.
Beams are automatically formed between adjacent notes that are an eighth note or shorter, as
appropriate for the time signature and their position in the bar.

TIP

● You can change the default beam grouping in your project on the Beam Grouping page in
Notation Options.

● You can also move the caret to other rhythmic positions without having to input notes.

AFTER COMPLETING THIS TASK
You can move notes to different rhythmic positions after they have been input, and move them
to other staves.
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RELATED LINKS
Changing the input pitch setting on page 149
Caret on page 146
Moving the caret manually on page 148
Adding notes above/below existing notes on page 171
Moving notes rhythmically on page 724
Per-flow changes to beam grouping defaults on page 539
View types on page 43
Arranging tools on page 283
Playing/Muting notes during note input/selection on page 278

Register selection during step input
Dorico Pro automatically selects the register of pitches during step input, but you can override
this and select the register manually.

During step input, Dorico Pro automatically selects the note whose register is the smallest
interval away from the previously input note. For example, if you input an F and then press A, an
A is input a third above the F, rather than a sixth below.

You can override this automatic register selection in the following ways:

● To input a note above the previously input note, press Shift-Alt as well as the letter for the
note.

● To input a note below the previously input note, press Ctrl (macOS) or Ctrl-Alt (Windows)
as well as the letter for the note.

NOTE

You must press Ctrl on macOS, not Cmd.

Register selection when inputting chords

During chord input, Dorico Pro automatically inputs notes above the highest note at the caret
position. For example, if you press A then E then A, a chord of A-E-A is input at the caret position.

You can input notes below the lowest note at the caret position instead by pressing Ctrl (macOS)
or Ctrl-Alt (Windows) as well as the letter for the note name.

For example, press Ctrl-F (macOS) or Ctrl-Alt-F (Windows) to input an F below the lowest note in
the chord at the caret position.

NOTE

You must press Ctrl on macOS, not Cmd.

RELATED LINKS
Inputting notes on page 149
Inputting chords on page 167
Changing the pitch of individual notes on page 173

Activating/Deactivating mouse input
You can activate/deactivate mouse input, for example, if you only want to input notes using your
computer keyboard or MIDI device. Deactivating mouse input also allows you to click other items
to stop note input.

PROCEDURE

● In the Notes toolbox, activate/deactivate Select.
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RESULT
Mouse input is activated in the current project when Select is deactivated. Mouse input is
deactivated in the current project when Select is activated.

TIP

You can change the default setting for whether mouse input is activated/deactivated by
activating/deactivating Enable note input using the mouse on the Note Input and Editing
page in Preferences.

EXAMPLE

Select when deactivated Select when activated

RELATED LINKS
Preferences dialog on page 51

Inputting notes with rhythm dots
The Dotted Notes tool allows you to input notes with rhythm dots and add rhythm dots to
existing notes. You can input notes with up to four rhythm dots.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select existing notes to which you want to add rhythm dots.

2. Press the number on your computer keyboard that corresponds to the note value you
want to input.
For example, press 5 for eighth notes (quavers), 6 for quarter notes (crotchets), 7 for half
notes (minims), and so on.

3. Press . (period) to activate Dotted Notes.

4. Optional: Press Alt-. (period) to change the number of rhythm dots.
Dotted Notes in the Notes toolbox updates to indicate the current number of rhythm
dots. You can input notes with up to four rhythm dots.

5. Optional: Press O to activate Force Duration.
If Force Duration is not activated, the notes you input might be shown as tied notes
rather than dotted notes, depending on their position in the bar and the prevailing meter.

6. Input the dotted notes you want.
Dotted Notes remains activated until you either select a different note duration or
deactivate it.

7. Press . again to deactivate Dotted Notes.

8. Press Esc or Return to stop note input.

RESULT
During step input, notes are input as dotted notes until you deactivate Dotted Notes or change
the note duration.
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If you add rhythm dots to multiple existing notes that would then overlap, Dorico Pro adjusts the
duration of notes in the selection to avoid deleting notes at the end of the selection.

EXAMPLE

A phrase containing eighth notes After adding rhythm dots to the whole selection

RELATED LINKS
Note and rest grouping on page 553

Inputting notes in Insert mode
In Insert mode, you can input notes before existing notes without overriding them. This allows
you to push existing notes ahead at the same time as inputting new notes at their previous
positions.

NOTE

You cannot input chords in Insert mode.

PROCEDURE

1. In Write mode, start note input.

2. Press the number on your computer keyboard that corresponds to the note value you
want to input.
For example, press 5 for eighth notes (quavers), 6 for quarter notes (crotchets), 7 for half
notes (minims), and so on.

3. Press I to activate Insert mode.
In Insert mode, the caret shows V and inverted V shapes at the top and bottom.

4. Input the pitches you want in any of the following ways:

● Press the corresponding letters on your keyboard.

● Click the staff at the rhythmic positions where you want to input notes.
A shadow notehead appears when inputting with the mouse to indicate where the
note will be input.

● Play the notes on a MIDI keyboard.

5. Optional: Press I again to deactivate Insert mode and return to normal note input.

6. Press Esc or Return to stop note input.

RESULT
Notes are inserted before existing notes, without overriding any existing notes at rhythmic
positions after the caret. Any existing notes after the caret are pushed ahead to subsequent
rhythmic positions.
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RELATED LINKS
Caret on page 146
Inputting chords on page 167

Inputting notes in percussion kits
You can input notes on all percussion instruments in percussion kits using any presentation type.
When inputting notes in percussion kits, the caret is smaller than when inputting notes on
pitched instrument staves.

Instead of occupying the whole height of the staff, the caret in percussion kits is positioned at a
particular staff position.

The name of the percussion instrument or slash voice currently selected by the caret, and any
applicable playing technique, is shown directly above the rhythmic grid display.

NOTE

You can only input notes into slash voices in percussion kits when using the five-line staff
presentation.

Inputting notes on instruments with five-line staff kit presentation

PROCEDURE

1. Optional: If you want to define additional playing techniques for instruments in the kit, do
so in the Percussion Instrument Playing Techniques dialog.

2. In Write mode, select an item in the percussion kit into which you want to input notes, at
the rhythmic position from which you want to input notes.

3. Press Shift-N or Return to start note input.

4. Move the caret up/down to input notes on different instruments in any of the following
ways:

● Press Up Arrow to move it up.

● Press Down Arrow to move it down.

5. Select an appropriate playing technique for the instrument currently selected by the caret
before inputting notes.

● Press Shift-Alt-Up Arrow to cycle upwards through playing techniques.

● Press Shift-Alt-Down Arrow to cycle downwards through playing techniques.

● Play the pitch for the playing technique you want on a MIDI keyboard.

NOTE

You can define MIDI pitches for playing techniques on the Note Input and Editing
page in Preferences.

6. Input notes in one of the following ways:

● Five-line staff presentation type: Press letters on a computer keyboard or play notes
on a MIDI keyboard, corresponding to staff positions for the clef set in Preferences.
For example, press B to input notes for the instrument assigned to the middle line
of a five-line staff when Treble G clef is set.
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● Grid and single-line instruments presentation types: Press the letter of any note
name A to G on a computer keyboard or play any note on a MIDI keyboard to input
notes for the instrument on whose line the caret is currently positioned.

NOTE

Notes played on MIDI keyboards are interpreted differently, depending on whether
Use percussion map or Use staff position is set for the different kit presentation
types in the Note Input section of the Note Input and Editing page in
Preferences.

● Any kit presentation type: Press Y to input notes for the instrument and playing
technique shown above the rhythmic grid.

● Any kit presentation type: Click on the staff where you want to input notes, and at
the rhythmic positions where you want them.

7. Press Esc or Return to stop note input.

RELATED LINKS
Caret on page 146
Percussion kits on page 1020
Note input setup for percussion kits on page 155
Percussion Instrument Playing Techniques dialog on page 1027
Changing the playing techniques of notes on percussion kit staves on page 1022
Preferences dialog on page 51

Note input setup for percussion kits

Inputting music for unpitched percussion instruments works differently than for pitched
instruments. You can use any of the usual methods for unpitched percussion input, but using a
MIDI keyboard or a computer keyboard is most efficient.

In the Note Input section of the Note Input and Editing page in Preferences you can find
options relating to note input for percussion.

There is one set of options for input onto five-line staves, and another set of options for input
onto grids and individual instruments.

The main choice affects input via MIDI keyboards and computer keyboards.

Use percussion map
A percussion map defines which MIDI notes produce which sound for a particular
patch in a sound library. For example, in General MIDI percussion, C2 (note 36)
produces bass drum, and D2 (note 38) produces snare drum, and so on.
If you know a particular mapping well, you may find it helpful to use the mapping
directly for input.

Use staff position
This option uses the staff position defined in the Edit Percussion Kit dialog. For
example, on a drum set, the bass drum is normally positioned in the bottom space of
the staff, while the snare drum is positioned in the third space from the bottom.
You can think of staff positions relative to what they would be when using a treble G
clef (F4 and C5 respectively) or using a bass F clef (A2 and E3 respectively).
You can choose which clef is used to interpret staff positions for five-line staves:

● Treble G clef

● Bass F clef
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When you select Use staff position, you can designate one octave of your MIDI keyboard to
input playing techniques.

By default, the Input techniques from MIDI key option is set to MIDI note 48, which is C3, the C
one octave below middle C (C4 = MIDI note 60). You can click the MIDI learn button and then play
a note on your MIDI keyboard to change the starting pitch. Assuming a starting pitch of C3,
ascending notes operate as follows:

● C3 (48): Previous playing technique

● C♯3 (49): Next playing technique

● D3 (50): First mapped playing technique

● E♭3 (51): Second mapped playing technique

● E3 (52): Third mapped playing technique

And so on, up to:

● B3 (59): Tenth mapped playing technique

In general, it is recommended that you set Use staff position for percussion input.

Use percussion map is normally only useful when you are inputting notes onto a drum set and
you have already memorized the General MIDI percussion map.

RELATED LINKS
Preferences dialog on page 51
Edit Percussion Kit dialog on page 107
Inputting notes in percussion kits on page 154
Changing the playing techniques of notes on percussion kit staves on page 1022

Default note selection during step input for percussion kits

During step input in percussion kits, you can press the letters on a computer keyboard that
correspond to staff positions for kits using the five-line staff presentation type. For example, you
can press F to input a note on the F space or line.

In Preferences, you can set options for inputting notes into percussion kits in the Note Input
section of the Note Input and Editing page. For example, if you want to use staff positions to
determine notes, choose Use staff position for Input onto kit or grid.

If you have the staff positions set relative to Treble G clef, then F could mean either the bottom
space on the staff or the top line on the staff. In a standard drum set, this means either the kick
drum in the bottom space, or the ride cymbal on the top line.

When inputting notes in pitched instruments, Dorico Pro chooses the lower or upper possible
staff position based on which is closer to the current position of the caret.

However, when inputting notes in percussion kits, Dorico Pro chooses the staff position of the
note with the same stem direction as the last input note, rather than the staff position that is
closest to the current position of the caret. This makes it easier to input common note patterns
used in percussion kits.

For example, inputting kick drum and snare drum notes on a standard drum set is a common
pattern. The kick drum is in the bottom space, and the snare drum is two spaces above: five staff
positions away from the bottom space, and four staff positions away from the top line.

You can press F for the kick drum and C for the snare drum.

The default stem direction behavior for inputting notes in kits in Dorico Pro means that you can
alternate pressing F and C, and the notes are input at the positions of the kick drum and snare
drum, even though the top line is the closer position after inputting a snare drum note.
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This is because the kick drum uses the same stem direction, and therefore voice, as the snare
drum.

NOTE

Dorico Pro automatically changes the directions of stems according to the positions of notes on
the staff when only one voice on the staff contains notes, regardless of their voice.

RELATED LINKS
Preferences dialog on page 51
Stem direction on page 943

Selecting note/rest durations
You can select different durations for notes/rests either from the Notes panel or by using one of
the assigned key commands, both during note input and for existing notes/rests.

PROCEDURE

1. Optional: If you want to select a note duration not shown in the Notes panel, click the
Show/Hide All Notes disclosure arrows at the top and bottom of the notes list to show
more note durations.

2. Select a note/rest duration in any of the following ways:

● Press the key command for the duration you want. For example, press 6 for quarter
notes (crotchets), 5 for eighth notes (quavers), 7 for half notes (minims), and so on.

● Click a duration in the Notes panel.

RELATED LINKS
Notes panel on page 134
Key commands in Dorico Pro on page 11
Inputting notes on page 149

Changing the duration of notes
You can lengthen/shorten the duration of notes after they have been input.

PROCEDURE

1. Select the notes whose duration you want to change.

2. Change the duration in any of the following ways:

● Press the key command of the duration you want. For example, press 4 for a 16th
note (semiquaver).

● Click the duration you want in the Notes panel.

● To lengthen notes by the current rhythmic grid value, press Shift-Alt-Right Arrow.

● To shorten notes by the current rhythmic grid value, press Shift-Alt-Left Arrow.

● To double the length of notes, press Ctrl/Cmd-Shift-Alt-Right Arrow.

● To halve the length of notes, press Ctrl/Cmd-Shift-Alt-Left Arrow.
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● To lengthen notes by the current rhythmic grid value, choose Write > Edit
Duration > Lengthen Duration by Grid Value.

● To shorten notes by the current rhythmic grid value, choose Write > Edit Duration >
Shorten Duration by Grid Value.

● To double the length of notes, choose Write > Edit Duration > Lengthen Duration.

● To halve the length of notes, choose Write > Edit Duration > Shorten Duration.

RESULT
The duration of the selected notes is changed. Dorico Pro automatically notates and beams the
notes appropriately according to their new duration, the current time signature, and their
position in the bar.

TIP

You can assign your own key commands to lengthen/shorten notes by specific durations. You
can find these by searching for Shorten duration by and Lengthen duration by on the Key
Commands page in Preferences.

Forcing the duration of notes/rests
Dorico Pro automatically notates and beams notes/rests appropriately according to the current
time signature and their position in the bar. You can force the duration of notes/rests to specify
their notation.

For example, if you input a half note at the start of a 6/8 bar, it is notated as a dotted quarter
note (crotchet) tied to an eighth note (quaver). This is because, according to convention, 6/8 bars
are subdivided into two groups of three eighth notes. To reflect this for a half note (four eighth
notes), Dorico Pro automatically divides the note to show the correct grouping but you can force
the note duration to show a half note instead.

TIP

If you want to force the duration of all notes on a staff to imply a different meter, for example, to
show three quarter note groups in 6/8 to indicate a hemiola, you can also input a time signature
only on those staves to group notes according to that meter. You can then hide the time
signatures if required.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Selecting existing notes whose duration you want to force.

2. Optional: If you want input rests with forced durations, press , (comma) to start rest input.

3. Press O to activate Force Duration.

4. Select the duration you want.

5. Optional: During note or rest input, input the notes or rests you want.

RESULT
During note or rest input, any notes you input are notated with their whole rhythmic value,
whatever their position in the bar. If you move them later, they keep the same notation. Rests
are input as explicit rests. Notes that cross barlines are notated as tied notes.
Forcing the duration of existing notes or rests preserves their current duration or any duration to
which you subsequently change them.
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TIP

● Force position and duration in the Notes and Rests group of the Properties panel is
activated automatically for rests input with forced durations. You can also use this
property to force the duration and position of rests.

● You can change how notes are grouped in different contexts project-wide on the Note
Grouping page in Write > Notation Options.

EXAMPLE

Default notation of notes in 6/8 Notes in the down-stem voice input with forced
durations

RELATED LINKS
Implicit vs. explicit rests on page 860
Inputting notes on page 149
Inputting rests on page 164
Selecting note/rest durations on page 157
Beams according to time signatures on page 539
Creating custom beat groupings for meters on page 554
Turning explicit rests into implicit rests on page 862

Inputting notes into multiple voices
By default, notes are input into the first up-stem voice, as indicated by the symbol of an up-stem
quarter note beside the caret. You can input notes directly into other voices during step input,
and switch between voices as often as you want.

You can also create new voices on staves with existing notes and input notes into those voices
anywhere else on those staves.

PROCEDURE

1. In Write mode, start note input on the staff on which you want to input multiple voices, at
the rhythmic position where you want the multiple voices to start.

2. Press Shift-V to create a new voice.
When a new voice is added, a + sign appears beside the symbol of a quarter note beside
the caret. The quarter note symbol indicates the stem direction, and the number beside
the quarter note indicates the voice number if applicable.

Caret when adding the first down-stem voice Caret when adding the second up-stem voice

3. Optional: Repeat step 2 as many times as you require.
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For example, on a staff containing no notes, creating one new voice allows you to input
notes into the first down-stem voice, but you can also create another new voice
immediately if you want to input notes into the second up-stem voice on the staff.

4. Input the notes you want.

5. Optional: Press V to cycle between all the active voices on the staff.

6. Press Esc or Return to stop note input.

RESULT
Notes are input into new voices, as indicated by the caret symbol. If you are inputting notes into
a new voice on a staff that already contains notes in another voice, the stem directions of existing
notes at the same rhythmic position change automatically as necessary.
The quarter note symbol beside the caret changes to indicate which voice is currently selected.
Any notes input are input into the voice indicated by this symbol.
You can switch between voices as often as you like.

NOTE

If you have three or more voices on a single staff, you can only cycle through all the voices in a
set order. For example, if you have two up-stem voices and two down-stem voices, the order is:
first up-stem voice, first down-stem voice, second down-stem voice, second up-stem voice.

EXAMPLE

Caret when inputting notes into
the first up-stem voice

Caret when inputting notes into
the first down-stem voice

Caret when inputting notes into a
new, second up-stem voice

RELATED LINKS
Caret on page 146
Inputting notes on page 149
Adding notes above/below existing notes on page 171
Voices on page 1039

Inputting notes into slash voices
You can input notes into multiple slash voices, for example, if you want to indicate a precise
rhythm without specifying pitches. By default, the first slash voice is up-stem, but you can add
extra slash voices both with and without stems, and switch between them as often as you want.

You can also input notes into new slash voices on a staff with existing notes. Once you have
created a slash voice somewhere on a staff, you can input notes into that slash voice anywhere
else on the same staff.

PROCEDURE

1. In Write mode, start note input.

2. Position the caret on the staff on which you want to input slash voices, at the rhythmic
position where you want the slash voices to start.

3. Press Shift-Alt-V to create a new slash voice.
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When a new slash voice is added, a + sign appears beside the symbol of a note beside the
caret, which now appears as a slash note. The slash note symbol indicates the stem
direction, and the number beside the slash note symbol indicates the voice number if
applicable.

Caret when adding the first down-stem slash
voice

Caret when adding the second up-stem slash
voice

4. Optional: Repeat step 3 as many times as you require.
For example, on a staff containing no notes in slash voices, creating one new slash voice
allows you to input notes into the first up-stem slash voice, but you can also create a
second new slash voice immediately if you want to input notes into a down-stem slash
voice.

5. Input the notes you want.
Notes in slash voices appear at the same staff position, regardless of their pitch. By
default, this is the middle line of the staff, but this changes in multiple-slash-voice
contexts.

6. Optional: Press V to cycle between all the active voices on the staff.

7. Press Esc or Return to stop note input.

RESULT
Notes are input into new slash voices, as indicated by the caret symbol. The slash note symbol
beside the caret changes to indicate which voice is currently selected and into which notes are
input.
You can switch between voices as often as you like.

NOTE

● If you are inputting notes into a new slash voice on a staff that already contains notes in
other voices/slash voices, the stem directions of existing notes and the staff positions of
slash voices at the same rhythmic position change automatically as necessary.

● If you have three or more voices of any type on a single staff, you must cycle through all
the voices in a set order. For example, if you have two up-stem voices, two down-stem
voices, and a slash voice, the order is: first up-stem voice, first down-stem voice, second
down-stem voice, second up-stem voice, slash voice.

EXAMPLE

Caret when inputting notes into
the first up-stem slash voice

Caret when inputting notes into
the first down-stem slash voice

Caret when inputting notes into a
new, second up-stem slash voice
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RELATED LINKS
Slash voices on page 1044
Rhythm slashes on page 849
Inputting slash regions on page 263

Inputting accidentals
You can input notes with accidentals, both during step input and by adding them to existing
notes.

NOTE

Accidentals that are part of the key signature are input automatically. For example, if you press F
in G major, an F♯ is input automatically. You would only need to specify an accidental if you want
to input an F♮, for example.

This also applies if you are using a MIDI keyboard, though you can respell notes if the accidentals
chosen automatically are not the ones that you expected.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the existing notes to which you want to add accidentals.

2. Select the accidental you want to input in one of the following ways:

● Press - for flat.

● Press = for sharp.

● Press 0 for natural.

● Click the accidental you want in the Notes panel.

TIP

You can find uncommon accidentals, such as double sharps and flats, or microtonal
accidentals, in the Accidentals section of the Key Signatures, Tonality Systems, and
Accidentals panel on the right of the window.

3. Optional: During step input, enter the note you want with your selected accidental.

NOTE

● Depending on the accidental duration system in place, subsequent accidentals for
the same note in the same register might not appear in the same bar.

● If you input notes using a MIDI device, Dorico Pro automatically shows an accidental
if necessary. It selects a sharp, flat, or natural based on key signature and context.
You can later respell accidentals.

RESULT
The accidental is added to the selected existing notes.
During step input, the selected accidental is only input on the next note you input. You must
reselect the accidental for each subsequent note.

RELATED LINKS
Accidentals on page 488
Inputting notes on page 149

Write mode
Note input 

162
Dorico 2.2.20



Respelling accidentals
You can change the enharmonic spelling of notes so they are shown as their enharmonic
equivalents, for example, to show the stepwise movement in a phrase clearly, or to avoid altered
unisons in a chord. You can do this for all layouts or just for part layouts.

Dorico Pro uses an algorithm that automatically decides the spelling of pitches, based on key
signature and context.

There are always at least three options for every pitch, as Dorico Pro allows enharmonic spellings
to show up to two accidental glyphs. This means the same note can be spelled four ways, if the
original pitch can be spelled with the note name either two notes below or two notes above,
using a maximum of two accidental glyphs. For example, B is a possible enharmonic spelling of
G♯ because a triple-flat uses a single accidental glyph, whereas an F♯ uses two accidental glyphs.

PROCEDURE

1. In Write mode, open the layout in which you want to respell accidentals.
If you respell accidentals in a full score layout, this also affects their spelling in part
layouts. If you respell accidentals in part layouts, this only affects their spelling in that part
layout.

2. Select the notes you want to respell.

3. Respell the selected notes upwards/downwards in any of the following ways:

● Press Alt-= to respell upwards.

● Press Alt-- to respell downwards.

RESULT
The enharmonic spelling of the selected notes is changed.

EXAMPLE

A G sharp When respelled
downwards, the G sharp
becomes an F triple-
sharp

When respelled upwards,
the G sharp becomes an
A flat

When respelled upwards
again, the G sharp
becomes a B triple-flat

RELATED LINKS
Accidentals on page 488

Changing accidentals
You can change the accidentals of notes after they have been input.

PROCEDURE

1. In Write mode, select the notes whose accidentals you want to change.

2. Change the accidentals in one of the following ways:

● Press 0 to change the accidentals to a natural.

● Press - to change the accidentals to a flat.

● Press = to change the accidentals to a sharp.
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● Click the type of accidental that you want in the Notes panel.

RESULT
All selected notes are changed to have the accidental you selected, even if notes in your selection
originally had different accidentals.

RELATED LINKS
Changing the pitch of individual notes on page 173

Accidental selection during MIDI input
Dorico Pro interprets MIDI data to create accidentals, and automatically determines the spelling
of notes according to preset rules.

Dorico Pro automatically displays an accidental if one is required. It selects a sharp or flat based
on key signature and context.

The algorithm for this takes into account the key signature and the intervals between successive
notes and chords. Therefore Dorico Pro prefers sharp accidentals in a key with sharps, and flats
in a key with flats. If you change the spelling of an accidental, Dorico Pro follows your spelling
preference whenever that note is used again in the score.

If you input notes with accidentals outside the key signature, Dorico Pro uses sharps if the figure
is rising, and flats if it is falling. The spelling is also calculated vertically, meaning a simpler
interval is produced where possible, such as a major third rather than a diminished fourth.

By default, Dorico Pro makes retrospective changes to how it has spelled accidentals, depending
on how your music develops. For example, in C major, if you input a sequence of pitches C-E-G♯,
but then input a G♭, the G♯ is respelled as an A♭.
You can disable this setting.

RELATED LINKS
Respelling accidentals on page 163

Disabling automatic accidental respelling

You can turn off the automatic respelling of accidentals to prevent Dorico Pro from making
retrospective changes to accidentals.

PROCEDURE

1. Press Ctrl/Cmd-Shift-I to open the Note Input Options dialog.

2. Click MIDI Input in the page list.

3. Deactivate Allow spelling of notes to be adjusted retrospectively.

4. Click Apply, then Close.

Inputting rests
Dorico Pro automatically shows rests as appropriate in the gaps between the notes you input.
However, you can also input rests manually.

PROCEDURE

1. Press , (comma) to start rest input.

2. Select the duration you want.

3. Optional: Press O to activate Force Duration.
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4. Input rests in any of the following ways:

● Press Y or any of the letters from A to G.

● Play notes on a MIDI keyboard.

5. Optional: Press , (comma) again to stop rest input.

RESULT
Rests of the selected duration are input. If Force Duration is not activated, Dorico Pro
automatically combines adjacent rests as appropriate for their position in relation to notes and
according to the current meter.

RELATED LINKS
Rests on page 859
Implicit vs. explicit rests on page 860
Selecting note/rest durations on page 157
Forcing the duration of notes/rests on page 158

Inputting bar rests during step input
When inputting music in multiple voices, rests are normally created automatically when there is a
gap in the secondary voice. However, if you want secondary voices to begin with explicit bar rests
in strict contrapuntal music, you can input a bar rest during step input.

For music in a single voice, you do not have to input bar rests. Bar rests appear in each new bar
automatically when you advance the caret, but you can also hide/show bar rests in all empty bars
in each layout independently.

PROCEDURE

1. In Write mode, start note input.

2. Select the appropriate secondary voice by pressing V until the voice direction indicator
shows the correct voice.
Alternatively, if you want to input bar rests into a new voice, press Shift-V until the voice
direction indicator shows the correct voice.

3. Press Shift-B to open the bars and barlines popover.

4. Enter rest into the popover to add a bar rest.

5. Press Return to close the popover.

6. Press Ctrl/Cmd-Right Arrow to advance the caret to the start of the next bar after the bar
rest.

RESULT
Bar rests are input at the caret position. If the caret position is within a bar that contains notes
for the selected voice, these notes are replaced by the bar rest.

NOTE

Alternatively, you can click Insert Bar Rest in the Insert Bar Rest section of the Bars and
Barlines panel to input bar rests during step input.

RELATED LINKS
Bars on page 504
Rests on page 859
Bars and barlines popover on page 201
Inputting notes into multiple voices on page 159
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Caret on page 146
Hiding/Showing bar rests in empty bars on page 864

Inputting ties
Dorico Pro automatically creates ties as required for note durations in each meter. However, you
can input ties manually to join two notes of the same pitch, both during step input and by joining
two existing notes with a tie.

For example, if you want to input a tie between two quarter notes across a barline, you can input
a half note at the rhythmic position where you want to input the first quarter note. Dorico Pro
automatically splits the half note into two quarter notes, one on each side of the barline, and
joins them with a tie.

NOTE

These steps do not apply to inputting ties between non-adjacent notes or notes in different
voices, for example, between two notes of the same pitch on different staves, or between a grace
note and a normal note.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the note from which you want the tie to start.

2. Press T to input ties.

3. Optional: During step input, input the note that you want at the end of the tie.

NOTE

The second note must be the same pitch as the first note. If the second note is a different
pitch to the first note, no tie is input.

RESULT
During step input, the two notes input are joined by a tie.
When inputting ties between existing notes, the selected note is joined by a tie to the next note
of the same pitch on the same staff.

NOTE

Depending on the current time signature and your settings on the Note Grouping page in
Write > Notation Options, inputting a tie between two notes can instead create a single note of
a different duration, such as a minim instead of two tied quarter notes. You can override your
note grouping settings and fix your notated rhythm by forcing their duration. Dorico Pro then
notates your input notes with the rhythmic durations specified, as long as they can fit inside the
bar.

RELATED LINKS
Ties on page 966
Ties vs. slurs on page 968
Inputting ties between non-adjacent notes on page 971
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Inputting grace notes
You input grace notes in the same ways as normal notes, and they can have any rhythmic note
value, accidental, and articulation. You can only input grace notes during note input.

PROCEDURE

1. In Write mode, start note input.

2. Position the caret at the rhythmic position where you want to input grace notes.

3. Press / to start grace note input.

4. Press the number for the rhythmic duration you want. For example, press 5 for eighth
grace notes.

5. Optional: Press Alt-/ to switch between inputting slashed/unslashed grace notes.

The Grace Notes toolbox button when inputting unslashed grace notes.

6. Input the grace notes you want.

7. Press / again to stop grace note input and return to normal note input.

RESULT
The pitches you enter are input as grace notes at the caret position.
If you are inputting grace notes after previously inputting normal notes, the rhythmic duration of
the grace notes is the same as the last input normal note. You can change the rhythmic duration
in the same way as for normal notes.
There is no limit to the number of grace notes that can exist at the same rhythmic position.

TIP

You can also change the type of grace notes after they have been input.

RELATED LINKS
Grace notes on page 657
Inputting notes on page 149
Inputting accidentals on page 162
Inputting articulations on page 182
Changing the type of grace notes on page 660

Inputting chords
You can input chords during step input when both note input and Chords are activated. You can
input notes with a computer keyboard, with the mouse, or by playing notes with a MIDI
keyboard.

NOTE

You cannot input chords in Insert mode.

PROCEDURE

1. Select the staff where you want to input chords and press Shift-N or Return to start note
input.

2. Press the number on your computer keyboard that corresponds to the note value you
want to input.
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For example, press 5 for eighth notes (quavers), 6 for quarter notes (crotchets), 7 for half
notes (minims), and so on.

3. Press Q to start chord input.
In chord input, a + sign appears at the top of the caret. This allows you to input multiple
notes at the caret position.

4. Input the pitches you want in any of the following ways:

● Press the corresponding letters on your keyboard.

TIP

Dorico Pro automatically inputs notes above the highest note at the caret position
when Chords is activated.

You can input notes below the lowest note at the caret position instead by pressing
Ctrl (macOS) or Ctrl-Alt (Windows) as well as the letter for the note name.

● Click the staff at the rhythmic positions where you want to input notes.
A shadow notehead appears when inputting with the mouse to indicate where the
note will be input.

● Play the notes on a MIDI keyboard.

5. Optional: Advance the caret to input chords at other rhythmic positions.
During chord input, notes are input at the same rhythmic position and above the previous
note until you advance the caret manually.

6. Press Q again to stop chord input.

RESULT
Multiple notes are input at the caret position.
If entering pitches by clicking with the mouse, you can put the same pitch into the chord twice by
clicking again on the same line.
If entering pitches with the keyboard, repeated notes are automatically input an octave above.
You can change the register of notes by forcing the register selection during note input, or by
transposing them after they have been input.

NOTE

● You can stop chord input and immediately continue inputting notes as before, with a
single note at each rhythmic position and the caret advancing automatically to the next
rhythmic position.

● When chords contain two pitches in the same register but with different accidentals, that is
known as an altered unison. Altered unisons are shown with either single stems or with
split stems, depending on your settings on the Accidentals page in Write > Notation
Options.

RELATED LINKS
Register selection during step input on page 151
Moving the caret manually on page 148
Altered unisons on page 491
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Inputting tuplets
You can input all types of tuplets using the tuplets popover. Tuplets are input like normal notes,
and so can only be input during note input.

You can also input triplets by clicking Tuplets in the Notes toolbox. However, you can only input
one triplet at a time this way.

PROCEDURE

1. In Write mode, start note input.

2. Press the number on your computer keyboard that corresponds to the note value on
which you want to base your tuplet.
For example, press 5 for eighth notes (quavers), 6 for quarter notes (crotchets), 7 for half
notes (minims), and so on.

3. Press ; to open the tuplets popover.

4. Enter the tuplet you want into the popover as a ratio. For example, enter 3:2 to input
triplets.

5. Press Return to close the popover.
The tuplet is entered.

6. Optional: Change the selected note duration.
For example, you can input a tuplet based on eighth notes but input a quarter note within
that tuplet.

7. Enter or play in the pitches you want.

8. Optional: press Space to advance the caret to continue inputting tuplets of the same ratio
at later rhythmic positions.

9. Stop tuplet input in any of the following ways:

● Press Shift-; or move the caret with the arrow keys to return to inputting normal
notes.

● Press Esc to stop note input completely.

RESULT
The pitches you enter or play in are input as tuplets, starting from the caret position.
If you want to input a different type of tuplet immediately after inputting tuplets, you must stop
the first type of tuplet before inputting the second type. If you do not stop the first type, the
second type is input as a nested tuplet.

RELATED LINKS
Tuplets on page 1007
Nested tuplets on page 1008
Inputting notes on page 149

Tuplets popover
The table contains examples of what you can enter into the tuplets popover to input different
types of tuplets. The tuplets popover can only be opened during step input.

You can open the tuplets popover during note input in Write mode in any of the following ways:

● Press ;.
As tuplets are often described in ratios, such as 3:2, the tuplets popover uses the
semicolon key to be memorable.

● Choose Write > Create Tuplet.

Write mode
Note input 

169
Dorico 2.2.20



The icon on the left-hand side of the popover matches the corresponding button in the Notes
toolbox on the right of the window.

Tuplets popover with an example entry Tuplets button in the Notes toolbox

NOTE

Clicking Tuplets in the Notes toolbox only inputs a single triplet. It does not open the tuplets
popover.

When inputting tuplets with the keyboard, Dorico Pro continues inputting notes as the specified
tuplet until any of the following happens:

● You press Shift-; to return to inputting normal notes.

● You move the caret with the arrow keys.

● You stop note input.

Type of tuplet Popover entry

Triplet, three notes in the space of two. 3 or 3:2

Triplet, three notes in the space of four. 3:4

Quintuplet, five notes in the space of four. 5:4

Quintuplet, five notes in the space of two. 5:2

Septuplet, seven notes in the space of four. 7:4

Septuplet, seven notes in the space of two. 7:2

Duplet, two notes in the space of three. Often
used in compound meters.

2:3

Quintuplet, five notes in the space of six. Often
used in compound meters.

5:6

64th note beat unit in tuplet z or 2

32nd note beat unit in tuplet y or 3

16th note beat unit in tuplet x or 4

Eighth note beat unit in tuplet e or 5

Quarter note beat unit in tuplet q or 6

Half note beat unit in tuplet h or 7

Whole note beat unit in tuplet w or 8
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Type of tuplet Popover entry

Double whole note beat unit in tuplet 2h or 9

Dotted eighth note beat unit in tuplet e. or 5.

Dotted quarter note beat unit in tuplet q. or 6.

Quintuplet, five dotted quarter notes in the
space of four.

NOTE

You must separate the tuplet ratio from the
beat unit using a space or hyphen when using
a number to specify the beat unit.

5:4q. or 5:4-6.

NOTE

The total duration of the tuplet depends on the note value selected when you open the popover.
For example, if a quarter note is selected when you input a triplet, the triplet input is three
quarter notes in the space of two.

This list is not comprehensive. It is intended to illustrate how you can structure your entry to
input different tuplets.

RELATED LINKS
Inputting tuplets on page 169
Tuplets on page 1007
Turning existing notes into tuplets on page 1009
Selecting note/rest durations on page 157

Adding notes above/below existing notes
You can add notes above/below existing notes. You can add multiple notes at the same time,
according to their intervals relative to the existing notes.

PROCEDURE

1. Select the notes to which you want to add notes.

2. Press Shift-I to open the add intervals popover.

3. Enter the intervals of the notes you want, relative to your selected notes. For example,
enter -m3,4 to add notes a minor third below and a fourth above the selected notes.

4. Press Return to close the popover.

RESULT
Notes are added to the selected notes according to the intervals you entered into the add
intervals popover.

RELATED LINKS
Changing the pitch of individual notes on page 173

Write mode
Note input 

171
Dorico 2.2.20



Add intervals popover
The add intervals popover allows you to add notes above and below existing notes, and also
transpose existing notes. It makes much of the functionality provided by the Add Notes Above
or Below and Transpose dialogs accessible directly via the keyboard.

You can open the add intervals popover in Write mode in any of the following ways when notes
are selected, including during note input:

● Press Shift-I.

● Choose Write > Add Intervals Popover.

The table contains examples of what you can enter into the add intervals popover to transpose
notes or add notes to existing notes.

Example action Popover entry

Transpose notes upwards by a third. t3

Transpose notes downwards by a sixth. t-6

Add notes a third above. 3 or 3rd

Add notes a fourth below. -4 or -4th

Add multiple notes

NOTE

Separate notes with commas, not with spaces.

3,6 or -3,3,4

Add notes above and/or below all notes in
selected chords.

NOTE

Separate notes with commas, not with spaces.

3 all or -M2,m3 to all

Add notes only to the top notes in chords. -3 top or dim5 top

Add notes only to the bottom notes in chords. aug4 bottom or -2 bottom

Specify perfect interval. p, per, or perf

Specify major interval. M, maj, or major

Specify minor interval. m, min, or minor

Specify diminished interval. d, dim, or diminished

Specify augmented interval. a, aug, or augmented

Specify diatonic interval. diat or diatonic
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Example action Popover entry

Transpose notes by microtonal intervals.

NOTE

The first number is the interval degree.

The second number is the number of quarter
tones.

t 3 8 qt

If you do not otherwise specify it, the interval is calculated by adding or transposing notes by the
number of staff positions specified. For example, in C major, if the selected note is a D♮ and you
specify 3 to add a third above, the added note is an F♮. You can specify the quality of the interval
by including it before the interval.

If the selected material already includes chords, notes are added above the top note in the chord,
and added below the bottom note in the chord. You can add notes to all notes in selected chords
by including all or to all at the end of your entry.

For microtonal transpositions, the first number is the interval degree, and the second number is
the number of quarter tones. For example, if you have a C natural and you enter T 3 8 qt, it
changes to an E natural.

RELATED LINKS
Transposing existing notes with the add intervals popover on page 174

Changing the pitch of individual notes
You can change the pitch and register of individual notes, including grace notes, after they have
been input by octave divisions, by staff position, and by octaves.

PROCEDURE

1. In Write mode, select the notes whose pitches you want to change.

2. Raise/Lower the pitches of the selected notes in any of the following ways:

● To move notes up one staff position, such as from C to D, press Alt-Up Arrow.

● To move notes down one staff position, such as from D to C, press Alt-Down Arrow.

● To transpose notes up a single octave division, such as a quarter tone in 24-EDO,
press Shift-Alt-Up Arrow.

● To transpose notes down a single octave division, such as a quarter tone in 24-EDO,
press Shift-Alt-Down Arrow.

● To transpose notes up an octave, press Ctrl/Cmd-Alt-Up Arrow.

● To transpose notes down an octave, press Ctrl/Cmd-Alt-Down Arrow.

RESULT
The pitch or register of the selected notes is changed.

NOTE

You can press Alt-Up Arrow and Alt-Down Arrow to change the staff positions of notes in
percussion kits using grid and five-line staff presentation types. However, this also changes the
instrument playing the note.
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RELATED LINKS
Equal Division of the Octave (EDO) on page 674
Adding notes above/below existing notes on page 171
Add intervals popover on page 172
Changing accidentals on page 163
Respelling accidentals on page 163

Transposing existing notes with the add intervals popover
You can change the pitch of notes after they have been input using the add intervals popover.

PROCEDURE

1. Select the notes you want to transpose.

2. Press Shift-I to open the add intervals popover.

3. Enter the transposition interval you want into the popover.
For example, enter t3 to transpose the notes up a third, or t-min6 to transpose the notes
down a minor sixth.

4. Press Return to close the popover.

RESULT
The selected notes are transposed by the degree specified.

RELATED LINKS
Add intervals popover on page 172

Repitching notes without changing their rhythm
You can repitch notes after you have input them while keeping their durations the same, for
example, if you want to duplicate the rhythm but have different pitches.

PROCEDURE

1. Select the first note you want to repitch.

2. Press Shift-N or Return to start note input.

3. Press L to activate Lock to Duration.

4. Enter the pitches you want.

5. Optional: Press L again to deactivate Lock to Duration.

NOTE

Lock to Duration automatically deactivates when you reach the last existing note on the
staff. By default, normal note input continues using the previous note value selected
before you activated Lock to Duration.

RESULT
Existing notes on the selected staff are repitched without their rhythms being changed. The caret
automatically advances from note to note, even if there are large rests between notes on the
staff.

RELATED LINKS
Caret on page 146
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Transpose dialog
The Transpose dialog allows you to transpose selections of notes simultaneously, including key
signatures. You can transpose according to an interval and quality or by a set number of octave
divisions.

● You can open the Transpose dialog in Write mode by making a selection in the music area
and choosing Write > Transpose.

Transpose dialog

The Transpose dialog contains the following sections:

1 Transposition options
Contains options that allow you to specify the transposition you want. For example, you
can choose to transpose by an interval quality, such as a major third, or by a set number of
divisions of the octave. You can choose the direction of the transposition, whether it
includes octaves, and the interval and quality or number of divisions by which you want to
transpose your selection.
According to convention, different intervals have different possible qualities. For example,
you can specify a major third but not a major octave.
Additional options also allow you to transpose any key signatures included in your
selection and keep relative respelled notes and chord symbols where possible.

2 Calculate interval
Allows you to set transposition options according to a starting note and the resulting note
you want. For example, if you want to transpose a selection relative to a C natural
becoming a G♯ but you are not certain of the interval and quality required, you can enter
those two notes in the Calculate interval section, click Apply, and Dorico Pro
automatically sets the required transposition options for you.

NOTE

The Transpose dialog does not allow transpositions that would result in impossible notations,
such as sharper than a triple sharp, or that require a microtonal accidental that does not exist in
the tonality system in place at the position of your selection.
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RELATED LINKS
Add intervals popover on page 172

Transposing selections
You can transpose whole selections together, including key signatures within selections, using
the Transpose dialog.

PROCEDURE

1. In Write mode, make a selection in the music area.

2. Choose Write > Transpose to open the Transpose dialog.

3. In the Transpose dialog, adjust the parameters required for your transposition, such as
interval and quality.

4. Click OK to save your changes and close the dialog.

RESULT
All notes in your selection are transposed according to the interval or number of divisions of the
octave specified in the Transpose dialog. If your selection included key signatures and you
activated Transpose key signatures, all key signatures in the selection are also transposed.

MIDI recording
MIDI recording is a way of inputting notes into Dorico Pro by playing them in real time on a MIDI
device. This can be particularly useful if, for example, you prefer to improvise your music rather
than plan pitches and note durations in advance.

In Dorico Pro, you can record MIDI notes using any MIDI device. However, you must connect the
device to your computer before starting Dorico Pro.

Outside of note input, Dorico Pro uses the instrument sounds of your most recent selection for
the notes you play on your MIDI device. In Play mode, this is the most recent track header you
clicked, while in Write mode, this is the last instrument staff on which you started note input or
into which you recorded MIDI. During note input, Dorico Pro always uses the instrument sounds
of the instrument into which you are recording notes.

As you play notes on your MIDI device, Dorico Pro uses an algorithm to produce the correct
enharmonic spelling for those notes.

RELATED LINKS
Optimization for MIDI recording on page 180

Inputting notes using MIDI recording
You can input notes by recording what you play on a MIDI device in real time. You can record
notes in both concert and transposed pitch.

PREREQUISITE

● You have connected and enabled the MIDI device you want to use.

NOTE

You must have connected the device to your computer before starting Dorico Pro. If not,
you must restart Dorico Pro.

● You have set the quantization options in the MIDI Quantize Options dialog as appropriate
for the music you intend to record.
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● You have set the options in the Recording section of the Play page in Preferences as
appropriate for the music you intend to record.

● You have input enough bars or empty rhythmic space for the amount of music you want to
record. Dorico Pro does not automatically add extra bars or rhythmic space.

● If you want to hear a click during your recording, you have input a time signature. There is
no click in open meter or when there is no time signature.

● You have chosen the appropriate input pitch setting.

PROCEDURE

1. Select a note or rest on the staff/instrument track into which you want to record notes, at
the position from which you want to record. You can do this in Write mode and Play mode.

NOTE

● In Play mode you cannot select rests, meaning you can only record into instrument
tracks that already contain at least one note.

● You can also record MIDI during note input, but this prevents Dorico Pro from using
both staves in grand staff instruments.

2. Optional: If you want to record notes without overwriting any existing notes on the staff,
press Q to activate Chords.

3. Optional: If you want to record into a specific voice on the staff, press Shift-N to start note
input and then do one of the following:

● If the voice you want already exists on the staff, press V until the note symbol beside
the caret indicates the correct voice.

● If the voice you want does not exist on the staff yet, press Shift-V until the note
symbol beside the caret indicates the correct voice.

4. Press Ctrl/Cmd-R to start recording.
During recording, the playhead appears red and moves along in time. By default, there is
one bar of count-in before the playhead reaches the rhythmic position of either your
original selection or the caret.

5. Play the notes you want on your MIDI device.
In Write mode, no music appears on the staff until you stop recording. In Play mode, notes
appear in the piano roll in real time.

6. Press Space or Ctrl/Cmd-R to stop recording.

RESULT
The notes you played on the MIDI device are input onto the selected staff. If you did not specify
the voice, notes are recorded into the first available voice on the staff, which is usually the first
up-stem voice. If you activated Chords, the notes you played are merged into the first available
voice on the staff without overwriting any existing notes.
The notated duration of the notes follows your quantization settings, but their played durations
are retained for playback.

AFTER COMPLETING THIS TASK
If the notes you played in are not notated as you intended, you can requantize them.

RELATED LINKS
Disabling MIDI input devices on page 182
Changing the count-in duration on page 180
Changing the input pitch setting on page 149
Changing the sustain pedal controller settings for MIDI recording/import on page 181
Repeats in MIDI recording on page 178
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Input methods for bars and barlines on page 201
Input methods for time signatures on page 190
Inputting notes into multiple voices on page 159
MIDI Quantize Options dialog on page 71

Retrieving played notes that you did not record
During playback, you can play notes on your MIDI keyboard and hear them without recording
them into the score. You can use retrospective recording to retrieve these notes and input them
into the project without previously explicitly recording them.

PREREQUISITE
You have started playback, played notes on a MIDI device alongside playback, then stopped
playback.

PROCEDURE

1. Select a note or rest on the staff where you want to input the retrieved notes.

2. Optional: If you want to input retrieved notes without overwriting any existing notes on
the staff, press Q to activate Chords.

3. Press Ctrl/Cmd-Alt-R.

RESULT
All the notes you played on your MIDI device during the previous playback are input on the
selected staff, starting from the selected rhythmic position. They are input into the first available
voice on the staff and overwrite any existing notes in that voice by default. If you activated
Chords, the retrieved notes are merged into the first available voice on the staff without
overwriting any existing notes.

NOTE

The retrospective recording buffer is cleared each time you start playback, meaning you cannot
retrieve music you played before the most recent playback.

RELATED LINKS
Playing back music on page 431

Repeats in MIDI recording
When recording MIDI into flows that contain repeat structures, such as repeat barlines, Dorico
Pro records the notes you play during each playthrough and merges them together into the
same voice.

Any differences in rhythms between the recordings are notated according to the current meter.

Requantizing notes
You can requantize notes using different quantization settings, for example, if you want to
change notated rhythms after importing MIDI or recording notes using a MIDI device. This does
not affect the played duration of notes in playback.

PROCEDURE

1. Select all the notes you want to requantize. You can do this in Write mode and Play mode.

2. Choose Edit > Requantize to open the MIDI Quantize Options dialog.

3. Change the quantization settings as appropriate for your selection.
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4. Click OK to save your changes and close the dialog.

RESULT
The notated durations of all selected notes are changed according to the quantization options
you set. This does not affect their played duration in playback.

RELATED LINKS
MIDI Quantize Options dialog on page 71

Changing the click settings
You can change the pitch, volume, and subdivision of the metronome click, which is always used
during MIDI recording. During playback, the click only sounds if the metronome is activated.

By default, Dorico Pro only subdivides the beat in the metronome click in compound time
signatures, and uses a beep for the metronome click sound. The beep is a higher pitched tone
for the first beat of the bar and a lower and quieter tone for subsequent beats of the bar. Further
beat subdivisions use even lower tones.

NOTE

● The click is produced by a tone generator called DoricoBeep. You can change the device
used for the click, but this overrides the playback template. This means you must
subsequently load sounds for any new instruments you add to your project manually, or
reset the playback template.

● There is no click in open meter or when there is no time signature.

PROCEDURE

1. Press Ctrl/Cmd-Shift-P to open Playback Options.

2. Click Click in the page list.

3. In the Metronome Click section, activate/deactivate the following options for Beat
subdivisions:

● Subdivide beats in simple time signatures

● Subdivide beats in compound time signatures

4. Choose one of the following options for Click sound:

● Click (unpitched)

● Beep (pitched)

5. For Pitch and velocity, change the MIDI pitch and/or Velocity values for any of the
following types of beat:

● First beat

● Subsequent beats

● Beat subdivisions

6. Click Apply, then Close.

RESULT
The pitch, volume, and subdivision settings for the metronome click in the current project are
changed.

RELATED LINKS
Types of time signatures on page 983
Input methods for time signatures on page 190
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Playback templates on page 436

Changing the count-in duration
For each project, you can change the default number of bars used in the count-in before you
start recording. By default, Dorico Pro provides a one bar count-in.

PROCEDURE

1. Press Ctrl/Cmd-Shift-P to open Playback Options.

2. Click Click in the page list.

3. In the Count-in section, change the value for Number of bars count-in.

4. Click Apply, then Close.

RESULT
The default duration of the count-in is changed in the current project.

Optimization for MIDI recording
Depending on your operating system and the MIDI devices you use for recording, you might find
that the notes you record are not notated with the durations or at the rhythmic positions you
expected. Optimizing the settings related to MIDI recording can help you achieve better results.

Because there can be a time latency between you pressing keys on a MIDI device and the notes
being picked up by Dorico Pro, we recommend that you check the latency by inputting a simple
rhythm against the click, for example, recording quarter notes in a 4/4 time signature.

Depending on the results, there are different settings you can change:

● If your notes are notated with incorrect durations, such as sixteenth notes notated as
eighth notes, we recommend that you change your quantization settings in the MIDI
Quantize Options dialog.

● If your notes are notated ahead of the beat, we recommend that you increase the latency
compensation value.

● If your notes are notated behind the beat, we recommend that you reduce the buffer size
for your audio device to the lowest possible value that still produces stable playback with
no drop-outs.

NOTE

The built-in audio device on Windows computers cannot always achieve a low enough
latency for reliable input in real time. In such cases, we recommend that you use an
external USB audio interface with ASIO support.

RELATED LINKS
MIDI Quantize Options dialog on page 71
Changing the sustain pedal controller settings for MIDI recording/import on page 181

Changing the MIDI latency compensation value
You can change the MIDI latency compensation value to correct any discrepancy between when
you press keys during MIDI recording and where the corresponding notes are notated relative to
the beat.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.
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2. Click Play in the page list.

3. In the Recording subsection, change the value for MIDI input latency compensation.

4. Click Apply, then Close.

RESULT
Increasing the latency compensation value increases the time between pressing the key and the
note being notated. This is useful if the notes you record were previously notated ahead of the
beat.
Decreasing the latency compensation value decreases the time between pressing the key and
the note being notated. This is useful if the notes you record were previously notated behind the
beat.

Changing the audio device buffer size
You can change the audio buffer size, for example, if the current buffer size is causing notes
input using MIDI recording appear significantly after the beat.

NOTE

● If the notes you play when recording MIDI are notated behind the beat, we recommend
that you reduce the buffer size for your audio device to the lowest possible value that still
produces stable playback with no drop-outs.

● The built-in audio device on Windows computers cannot always achieve a low enough
latency for reliable input in real time. In such cases, we recommend that you use an
external USB audio interface with ASIO support.

PROCEDURE

1. Choose Edit > Device Setup to open the Device Setup dialog.

2. In the Device Setup dialog, select the audio device whose buffer size you want to change
from the ASIO Driver menu.

3. Click Device Control Panel to open the device settings dialog for the selected audio
device.

4. In the audio device settings dialog, change the buffer size in one of the following ways, as
appropriate for your operating system:

● For macOS systems, select a sample rate from the Buffer Size menu.

● For Windows systems, in the Audio buffer size section, either drag the slider to a
different position or activate User definable and change the value in the Selected
buffer size field.

5. Click Close (macOS)/OK ((Windows only)) to close the audio device settings dialog.

6. Click Close to close the Device Setup dialog.

Changing the sustain pedal controller settings for MIDI recording/
import

You can change your default setting for whether Dorico Pro interprets sustain pedal controllers
as pedal lines when recording MIDI and importing MIDI files.

NOTE

These options are also available in the MIDI Import Options dialog, and your settings are linked
between this dialog and Preferences.
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PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click Play in the page list.

3. In the Recording subsection, activate/deactivate Import CC64 as pedal lines.

4. Optional: If you activated Import CC64 as pedal lines, activate/deactivate Snap pedal
lines to previous beat.

5. Click Apply, then Close.

RESULT
When Import CC64 as pedal lines is activated, the MIDI controller CC64 is interpreted as pedal
lines.
When Snap pedal lines to previous beat is activated, the start of pedal lines is automatically
moved back to the start of the beat.

RELATED LINKS
MIDI Import Options dialog on page 70

Disabling MIDI input devices
By default, Dorico Pro accepts MIDI input from all connected MIDI devices, including virtual MIDI
cables and inter-application buses. You can disable MIDI devices individually, for example, if you
are using devices that continuously output MIDI data or if you want particular devices to remain
routed exclusively to another application.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click Play in the page list.

3. In the Recording subsection, click MIDI Input Devices.

4. In the MIDI Input Devices dialog, deactivate the checkbox for each MIDI input device you
want to disable.

5. Click OK to save your changes and close the dialog.

6. Click Apply, then Close.

Notations input
You can input many types of notations, both during step input and by adding them to existing
notes. In Dorico Pro, “notation” is a broad term that includes many different items, including
articulations, slurs, dynamics, and more.

Inputting articulations
You can input notes with articulations during step input, and you can add articulations to notes
after they have been input.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the existing notes to which you want to add articulations.
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2. Select the articulations you want to input in any of the following ways:

● Press the key commands for the articulations you want.

● Click the articulations you want in the Notes panel.

3. Optional: Enter the notes or chords you want with your selected articulations.

RESULT
The selected articulations are added to the selected notes.
During step input, the selected articulations are added to all notes that are input until the
articulations are deactivated.

NOTE

Some combinations of articulations on the same notes are not possible. For example, you cannot
have both staccato and staccatissimo marks on the same notes, as both articulations indicate
that notes are played shorter.

RELATED LINKS
Articulations on page 497
Note input on page 145

Key commands for articulations
In addition to clicking them in the Notes panel, you can input common articulations by pressing
key commands on your computer keyboard.

You can use the following key commands to input articulations with the keyboard:

Type of articulation Key command

Accent:  [

Marcato:  '

Stressed:  {

Unstressed:  @ (Windows)

Shift-' (macOS)

Staccato:  ]

Tenuto:  # (Windows)

\ (macOS)

Staccatissimo: , , or  }

Combined tenuto and staccato:  ~ (Windows)

| (macOS)

RELATED LINKS
Articulations on page 497
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Inputting fingerings
You can input fingerings on existing notes using the fingerings popover, both during step input
and by adding them to existing notes.

NOTE

● You can only add fingerings to notes at one rhythmic position at a time, and you can only
input as many fingerings as there are notes at each rhythmic position. For example, you
can input three fingerings at the rhythmic position of a chord containing three notes, but
only one fingering at the rhythmic position of a single note.

● Although they contain two numbers, substitution fingerings are considered one fingering,
meaning you can add substitution fingerings to single notes.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the existing notes to which you want to add fingering.
If you want to add fingerings to all notes in a chord, select all the notes in the chord.

2. Press Shift-F to open the fingerings popover.

3. Enter the fingerings you want into the popover.
For example, enter:

● 3-2 for a substitution fingering from the third finger to the second finger.

● 1,3,5 for a chord.

● 12 to show the first two valves should be depressed on a valved brass instrument.

4. Optional: When adding fingerings to existing notes, advance the popover in one of the
following ways:

● To advance the popover to the next note/chord in the current voice, press Space.

● To advance the popover to the first note/chord in the current voice in the next bar,
press Tab.

● To navigate the popover back to the first note/chord in the current voice in the
previous bar, press Shift-Tab.

5. Press Return to close the popover.

RESULT
The fingerings are input on the selected notes, including during step input.

RELATED LINKS
Fingering on page 639
Changing the rhythmic position of substitution fingerings on page 640
Fingerings for valved brass instruments on page 649
Deleting fingerings on page 645

Fingerings popover
The table contains examples of what you can enter into the fingerings popover to input the
different types of fingerings available.

You can open the fingerings popover in Write mode in any of the following ways when either a
note is selected or the caret is active:

● Press Shift-F.
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● Choose Write > Create Fingerings.

● Click Fingerings in the Notations toolbox.

Type of fingering Example popover entry

Single fingerings for individual notes, including
for brass valve numbers and trombone slide
positions

1, 2, 3, and so on

Valved brass instruments 12

Single fingerings for each note in chords

For keyboard instruments, Dorico Pro
automatically orders numbers appropriately
according to the hand playing the notes. The
default is:

● Right hand for the upper staff

● Left hand for the lower staff

1,3,5

Left hand fingerings L2, G2, S5, I2, or H2

Right hand fingerings R5, D5, or M5

Multiple fingerings for individual notes, for
example, for ornaments such as mordents or
turns

2343

Single fingerings for multiple notes: enter the
same fingering number for two adjacent
notes.

For example, in keyboard music the thumb
may depress two keys simultaneously.

1,1

Alternative fingerings

NOTE

You must use parentheses in the popover,
even if you choose to show alternative
fingerings in square brackets.

2(3)

Editorial fingerings

NOTE

You must use square brackets in the popover,
even if you choose to show editorial fingerings
in parentheses.

[4]

Finger substitutions 1-3

Write mode
Notations input 

185
Dorico 2.2.20



Type of fingering Example popover entry

Thumb indicator for string instruments T

This list is not comprehensive as there are many possible fingerings. It is intended to illustrate
how you can structure your entries to input different types of fingerings.

NOTE

Finger substitutions are shown as immediate by default, but you can change the rhythmic
position of the substitution by changing the deferral duration.

You can change the appearance and position of each type of fingering on the Fingering page in
Engrave > Engraving Options.

RELATED LINKS
Fingering on page 639
Project-wide engraving options for fingerings on page 640
Changing the rhythmic position of substitution fingerings on page 640
Fingerings for valved brass instruments on page 649

Input methods for key signatures
You can input key signatures with the keyboard by using the key signatures popover, and with
the mouse by using the Key Signatures, Tonality Systems, and Accidentals panel.

RELATED LINKS
Key signatures on page 671

Key signatures popover
The table contains the entries for the key signatures popover that you can use to input the
different key signatures available.

You can open the key signatures popover in Write mode in any of the following ways when either
an item is selected or the caret is active:

● Press Shift-K.

● Select an existing key signature and press Return.

● Choose Write > Create Key Signature.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Key signatures popover with an example entry
Key Signatures, Tonality Systems, and Accidentals
button in the Notations toolbox

Type of key signature Popover entry

Open or atonal key signature open or atonal

Major keys (capital letters) C, D or G#, Ab, and so on
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Type of key signature Popover entry

Minor keys (lowercase letters) g, d, f#, bb, and so on

Number of sharps

NOTE

Assumes the major key for that many sharps.

3s, 2#, and so on

Number of flats

NOTE

Assumes the major key for that many flats.

4f, 5b, and so on

This list is not comprehensive as you can input every possible key signature. It is intended to
illustrate how you can structure your entry to input different types of key signatures.

RELATED LINKS
Key signatures on page 671

Key Signatures, Tonality Systems, and Accidentals panel
The Key Signatures, Tonality Systems, and Accidentals panel allows you to create and input
common key signatures and your own custom key signatures.

● You can hide/show the Key Signatures, Tonality Systems, and Accidentals panel by clicking
Key Signatures, Tonality Systems, and Accidentals in the Notations toolbox on the right
of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

The Key Signatures, Tonality Systems, and Accidentals panel contains the following sections:

Tonality System
Contains a menu that allows you to select tonality systems to use, and options for
editing and creating custom tonality systems.

The Tonality System section of the Key Signatures, Tonality Systems, and Accidentals panel

Used in This Flow
Contains all the key signatures currently used in the flow.

Key Signatures
Allows you to create key signatures.
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The Key Signatures section of the Key Signatures, Tonality Systems, and Accidentals panel.

The Key Signatures section contains the following parts:

1 Major/Minor
Allow you to choose whether your key signature is Major or Minor.

2 Up button: More Sharps/Fewer Flats
Each time you click, you add one sharp accidental to the key signature, or
remove one flat accidental from the key signature.

3 Down button: Fewer Sharps/More Flats
Each time you click, you remove one sharp accidental from the key signature,
or add one flat accidental to the key signature.

4 Input key signature
Shows how the key signature looks on a staff. Clicking this button inputs the
key signature it displays. If nothing in the project is selected, the key signature
is loaded onto the mouse pointer.

Custom Key Signatures
Contains any custom key signatures you have created for the currently selected
tonality system.

Accidentals
Contains all accidentals available in the currently selected tonality system.

RELATED LINKS
Key signatures on page 671
Custom tonality systems on page 675

Inputting key signatures with the popover
You can input key signatures using the key signatures popover, both during step input and by
adding them to existing music. You can also input key signatures only on single staves.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an existing barline immediately to the left of where you want to input a key
signature.

● Select an existing notehead or rest immediately to the right of where you want to
input a key signature.

2. Press Shift-K to open the key signatures popover.

3. Enter the key signature you want into the popover.

Write mode
Notations input 

188
Dorico 2.2.20



For example, enter g for G minor or 3s for 3 sharps.

NOTE

Entering 3s creates a key signature of A major, rather than F♯ minor.

4. Input the key signature and close the popover in one of the following ways:

● To input a key signature on all staves, press Return.

● To input a key signature on the selected staff only, press Alt-Return.

RESULT
During step input, key signatures are input at the caret position, even if this is in the middle of a
bar. However, it is preferable to input key signature changes at barlines.
All subsequently input notes follow the input key signature, until the next existing key signature
or the end of the flow, whichever comes first. If playing in notes using a MIDI keyboard,
accidentals are spelled according to the key signature.
When adding key signatures to existing music, they are added immediately to the right of a
barline, or immediately to the left of a selected note, even if this is in the middle of an existing
bar. If you selected an existing key signature, the new key signature directly replaces the existing
one.

NOTE

An individual key signature on a single staff is not intended for transposing instruments.
Transpositions of notes and key signatures are done automatically for transposing instruments.

RELATED LINKS
Key signatures popover on page 186
Accidental selection during MIDI input on page 164
Key signatures on page 671
Project-wide spacing gaps for key signatures on page 685
Moving key signatures rhythmically on page 686
Transposing instruments on page 104
Making layouts transposing/concert pitch on page 123

Inputting key signatures with the panel
You can input key signatures using the Key Signatures, Tonality Systems, and Accidentals panel,
both during step input and by adding them to existing music. You can also input key signatures
only on single staves.

NOTE

These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an existing barline immediately to the left of where you want to input a key
signature.

● Select an existing notehead or rest immediately to the right of where you want to
input a key signature.
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2. In the Notations toolbox, click Key Signatures, Tonality Systems, and Accidentals to
show the Key Signatures, Tonality Systems, and Accidentals panel.

3. Optional: If you have not already used the key signature you want in the current flow,
create the key signature you want using the Key Signatures editor in the Key Signatures,
Tonality Systems, and Accidentals panel.

4. Input the key signature you want in one of the following ways:

● To input a key signature on all staves, click it in the Key Signatures, Tonality Systems,
and Accidentals panel.

● To input a key signature on the selected staff only, Alt-click it in the Key Signatures,
Tonality Systems, and Accidentals panel.

RESULT
During step input, key signatures are input at the caret position, even if this is in the middle of a
bar. However, it is preferable to input key signature changes at barlines.
All subsequently input notes follow the input key signature, until the next existing key signature
or the end of the flow, whichever comes first. If playing in notes using a MIDI keyboard,
accidentals are spelled according to the key signature.
When adding key signatures to existing music, they are added immediately to the right of a
barline, or immediately to the left of a selected note, even if this is in the middle of an existing
bar. If you selected an existing key signature, the new key signature directly replaces the existing
one.

NOTE

An individual key signature on a single staff is not intended for transposing instruments.
Transpositions of notes and key signatures are done automatically for transposing instruments.

RELATED LINKS
Key signatures on page 671
Key Signatures, Tonality Systems, and Accidentals panel on page 187
Project-wide spacing gaps for key signatures on page 685
Accidental selection during MIDI input on page 164
Moving key signatures rhythmically on page 686
Mouse input settings on page 143
Transposing instruments on page 104
Making layouts transposing/concert pitch on page 123

Input methods for time signatures
You can input time signatures with the keyboard by using the time signatures popover, and with
the mouse by using the Time Signatures (Meter) panel.

NOTE

You can create most types of custom time signatures using the Create Time Signature section
of the Time Signatures (Meter) panel, but certain time signatures are only possible using the time
signatures popover. For example, you can only specify beat subdivisions with the time signatures
popover.

RELATED LINKS
Preferences dialog on page 51
Time signatures on page 981
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Types of time signatures on page 983

Time signatures popover
The table contains the entries for the time signatures popover that you can use to input the
different types of time signatures available.

You can open the time signatures popover in Write mode in any of the following ways when
either an item is selected or the caret is active:

● Press Shift-M.

● Select an existing time signature and press Return.

● Choose Write > Create Time Signature.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Time signatures popover with an example entry
Time Signatures (Meter) button in the Notations
toolbox

Type of time signature Popover entry

Simple time signatures

For example, 2/4, 6/8, 3/4, 5/4 and so on

2/4, 6/8, 3/4, 5/4, and so on

Time signatures with a pick-up

For example, a 4/4 bar with a dotted quarter
note pick-up, or a 6/8 bar with a pick-up of two
eighth notes (quavers).

4/4,1.5, 6/8,2, and so on

Alternating time signatures, such as 6/8+3/4

NOTE

You must include spaces either side of the plus
sign.

6/8 + 3/4

Common time, the equivalent of 4/4 c

Cut common time, the equivalent of 2/2 cutc or ¢

Open meter indicated by X X or x

Open meter with no indication

NOTE

A time signature signpost is shown at the
position of the open meter.

open

Additive time signature with explicit beat
grouping

3+2+2/8, 3+2/4, and so on
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Type of time signature Popover entry

Beat grouping specified but not shown in the
time signature

For example, a time signature of 7/8 is shown
but beams are subdivided into 2+3+2 eighth
notes.

[2+3+2]/8

Aggregate time signature: a dashed barline is
shown in the bar to show the division between
the different meters

2/4|6/8

Interchangeable time signature with different
styles: parenthesized, slash, equals sign, and
dashed

NOTE

You must include spaces either side of the
slashes, equals signs, or dashes, and before
opening parentheses.

2/4 (6/8), 2/4 / 6/8, 2/4 = 6/8, or 2/4 – 6/8

This list is not comprehensive, as there are many possible time signatures. It is intended to
illustrate how you can structure your entry to input different time signatures.

RELATED LINKS
Time signatures on page 981

Time Signatures (Meter) panel
The Time Signatures (Meter) panel allows you to input different time signatures. In the Create
Time Signature section of the panel, you can create uncommon time signatures.

● You can hide/show the Time Signatures (Meter) panel by clicking Time Signatures (Meter)
in the Notations toolbox on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

The Time Signatures (Meter) panel contains the following sections:

Used in This Flow
Contains any time signatures already used in the current flow.

Common
Contains common time signatures, such as 4/4, 3/4, 6/8, and 7/8.

Create Time Signature
Allows you to design your own time signatures, including alternating time signatures
and aggregate time signatures.
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The Create Time Signature section of the Time Signatures (Meter) panel

The Create Time Signature section contains the following parts:

1 Time signature type menu
Allows you to select one of the following types of time signatures:

● Regular

● Interchangeable

● Aggregate

● Alternating

2 Time signature spaces
Allows you to combine up to four time signatures. For example, you can
specify only one time signature for a Regular time signature, but for an
alternating time signature, you might want to include three time signatures.

3 Pick-up bar of
Allows you to include a pick-up bar before the time signature. A pick-up bar is
not a complete bar, and so allows you to include only a few beats before the
first complete bar.
You can select one of the following options for the number of beats in a pick-
up bar:

● 1/2 beat

● 1 beat

● 2 beats

4 Input time signature button
Click the button that displays the time signature to input it. If nothing in the
project is selected, the time signature is loaded onto the mouse pointer.

RELATED LINKS
Time signatures on page 981
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Inputting time signatures with the popover
You can input time signatures, including time signatures with pick-up bars, using the time
signatures popover, both during step input and by adding them to existing music. You can also
input time signatures only on single staves.

NOTE

In order to input an upbeat or pick-up bar, you must input a new time signature that includes the
upbeat you want. For example, entering 4/4,1 into the time signatures popover creates a 4/4
time signature with one quarter note upbeat.

The number after the comma indicates multiples of the rhythmic unit specified by the
denominator of the time signature. For example, 4/4,0.75 creates a dotted eighth note (dotted
quaver) upbeat, whereas 6/8,2 creates an upbeat of two eighth notes.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select a barline immediately to the left of where you want to input a new time
signature.

● Select a notehead or rest immediately to the right of where you want to input a new
time signature.

2. Press Shift-M to open the time signatures popover.

3. Enter the time signature you want into the popover.
For example, enter [2+2+3]/8 for a 7/8 time signature with a custom beat grouping, or
4/4,1 for a 4/4 time signature with one quarter note upbeat.

4. Input the time signature and close the popover in one of the following ways:

● To input a time signature on all staves, press Return.

● To input a time signature on the selected staff only, press Alt-Return.

RESULT
During step input, time signatures are added at the caret position, even if this is in the middle of
an existing bar.
When adding time signatures to existing music, they are added immediately to the right of a
selected barline, or immediately to the left of a selected note, even if this is in the middle of an
existing bar.
All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first. Dorico Pro automatically inputs and moves barlines as
required so that subsequent music is barred correctly.

RELATED LINKS
Time signatures popover on page 191
Time signatures on page 981
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Inputting time signatures with the panel
You can input time signatures, including time signatures with pick-up bars, using the Time
Signatures (Meter) panel, both during step input and by adding them to existing music. You can
also input time signatures only on single staves.

NOTE

These steps describe inputting with the default mouse input preference Create item at
selection.

PREREQUISITE
If necessary, you have created the time signature you want in the Create Time Signature section
of the Time Signatures (Meter) panel.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select a barline immediately to the left of where you want to input a new time
signature.

● Select a notehead or rest immediately to the right of where you want to input a new
time signature.

2. In the Notations toolbox, click Time Signatures (Meter) to show the Time Signatures
(Meter) panel.

3. Optional: For pick-up bars, activate Pick-up bar of in the Create Time Signature section
of the Time Signatures (Meter) panel and select one of the following options:

● 1/2 beat

● 1 beat

● 2 beats

NOTE

Not all pick-up bar lengths are possible using this method. For example, a single
eighth note upbeat in 6/8 cannot be produced by any of these three options. In such
cases, you must use the time signatures popover.

4. Input the time signature you want in one of the following ways:

● To input a time signature on all staves, click it in the Time Signatures (Meter) panel.

● To input a time signature on the selected staff only, Alt-click it in the Time
Signatures (Meter) panel.

RESULT
During step input, time signatures are added at the caret position, even if this is in the middle of
an existing bar.
When adding time signatures to existing music, they are added immediately to the right of a
selected barline, or immediately to the left of a selected note, even if this is in the middle of an
existing bar.
All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first. Dorico Pro automatically inputs and moves barlines as
required so that subsequent music is barred correctly.

Write mode
Notations input 

195
Dorico 2.2.20



RELATED LINKS
Time signatures on page 981
Inputting notes on page 149
Time Signatures (Meter) panel on page 192
Mouse input settings on page 143

Input methods for tempo marks
You can input tempo marks with the keyboard by using the tempo popover, with the mouse by
using the Tempo panel, and in the Time track in Play mode. You can input a tempo mark
containing just a text instruction, metronome mark, or a combination of the two.

Additionally, you can input tempo changes in the Time track in Play mode.

RELATED LINKS
Tempo marks on page 950
Time track on page 421
Inputting tempo changes in the Time track on page 423

Tempo popover
The following tables contain examples of what you can enter into the tempo popover to input
tempo marks, tempo equations, and rhythmic feels for swing playback.

When you start entering a tempo into the tempo popover, a menu appears with suggestions
containing the letters/words you enter. You can select one of these suggestions to input, or enter
your own tempo into the popover.

You can open the tempo popover in Write mode in any of the following ways when either an item
is selected or the caret is active:

● Press Shift-T.

● Select an existing tempo mark and press Return.

● Choose Write > Create Tempo.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Tempo popover with an example entry

Tempo button in the Notations toolbox

Tempo marks

Example tempo mark Popover entry

Adagio Adagio

Presto  = 176 Presto q = 176 or Presto q=176

Largo ( = 52) Largo (q = 52) or Largo (q=52)

 = 96-112 q = 96-112, q=96-112, 6 = 96-112, or 6=96-112
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Example tempo mark Popover entry

  = 84 q. = 84, q.=84, 6. = 84, or 6.=84

 = 30 w = 30, w=30, 8 = 30, or 8=30

 = 60 h = 60, h=60, 7 = 60, or 7=60

 = 120 e = 120, e=120, 5 = 120, or 5=120

  = 90 e. = 90, e.=90, 5. = 90, or 5.=90

 = 240 x=240, x = 240, 4=240 or 4 = 240

rit. rit. or rit

accel. accel. or accel

più più or piu

meno meno

Faster, with energy Faster, with energy

Tempo equations

Tempo equation Popover entry

 =   e = e., e=e., 5 = 5., or 5=5.

 =  q = e, q=e, 6 = 5, or 6=5

This list is not comprehensive as you can enter tempos freely and there are many possible
metronome marks, tempo marks, and tempo equations. It is intended to illustrate how you can
structure your entry to input different types of tempo marks and metronome marks.

NOTE

The tempo popover is case-sensitive. If you want your tempo mark to start with a capital letter,
you must enter a capital letter into the popover.

Rhythmic feels for swing playback

Rhythmic feel Popover entry

Light swing rhythmic feel light swing

Medium swing rhythmic feel medium swing

Heavy swing rhythmic feel heavy swing
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Rhythmic feel Popover entry

Straight rhythmic feel straight

Triplet 8th fixed rhythmic feel 2:1 swing (fixed)

Dotted 8th-16th fixed rhythmic feel 3:1 swing (fixed)

RELATED LINKS
Tempo marks on page 950
Types of tempo marks on page 951
Swing playback on page 438
Enabling swing playback for specific sections/players on page 440

Tempo panel
The Tempo panel contains all the different types of tempo marks available in Dorico Pro,
organized into sections. It is located on the right of the window in Write mode.

● You can hide/show the Tempo panel by clicking Tempo in the Notations toolbox on the
right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

Used in This Flow
Contains any tempo marks already used in the flow, including custom tempo marks
added using the tempo popover.

Tap Tempo
Allows you to create an absolute tempo change based on the speed with which you
click the Tap button. You can use the available options to set the beat unit on which
you want the tempo to be based.

Absolute Tempo Change
Contains a range of tempos with both an Italian tempo indication and a metronome
mark. You can later choose to show or hide the metronome mark for individual
tempo marks.
You can change the range shown in the list by adjusting the sliding bar at the top.
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Gradual Tempo Change
Contains tempo marks that indicate a change in tempo over a defined period of time,
such as rallentando or accelerando.
You can add modifiers to gradual tempo changes. Available modifiers are shown at
the top of the section.

Relative Tempo Change
Contains tempo marks that indicate a change in tempo that is relative to the
previous tempo, such as mosso (movement, or with movement). They often include
modifiers that qualify the change, such as poco meno mosso (a little less movement),
and are not defined by a metronome mark.
You can add modifiers to relative tempo changes. Available modifiers are shown at
the top of the section.
You can later set a relative metronome mark change as a percentage of the previous
metronome mark for individual tempo marks.

Reset Tempo
Contains tempo marks that indicate a return to the previous tempo, such as A tempo,
or a previously defined tempo, such as Tempo primo.

Tempo Equation
Allows you to input a tempo equation, using beat units from 16th notes to whole
notes and up to two rhythm dots.

RELATED LINKS
Tempo marks on page 950
Types of tempo marks on page 951
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Inputting tempo marks with the popover
You can input tempo marks using the tempo popover, both during step input and by adding
them to existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select a barline, notehead, or rest at the rhythmic position where you want to add a
tempo mark.

● Select multiple items that span the duration across which you want to add a gradual
tempo change.

2. Press Shift-T to open the tempo popover.

3. Enter the tempo you want into the popover.
For example, enter q=72 or Allegretto.
When you start entering a tempo into the tempo popover, a menu appears that shows
suggested tempos containing the letters/words you enter. You can select one of these
suggestions or you can enter your own tempo into the popover.

4. Press Return to close the popover.

RESULT
During step input, tempo marks are input at the caret position. Gradual tempo changes, such as
rallentando, are also input at the caret position with a default duration of a quarter note. Gradual
tempo changes do not extend as you input notes.
When adding tempo marks to existing music, they are added at the rhythmic position of the
selected barline, notehead, or rest. Gradual tempo changes span the duration of the selected
items.

AFTER COMPLETING THIS TASK
You can lengthen/shorten gradual tempo changes.

RELATED LINKS
Tempo marks on page 950
Lengthening/Shortening gradual tempo changes on page 956

Inputting tempo marks with the panel
You can input tempo marks using the Tempo panel, both during step input and by adding them
to existing music.

NOTE

These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

Write mode
Notations input 

200
Dorico 2.2.20



● Select a barline, notehead, or rest at the rhythmic position where you want to add a
tempo mark.

● Select multiple items that span the duration across which you want to add a gradual
tempo change.

2. In the Notations toolbox, click Tempo to show the Tempo panel.

3. In the Tempo panel, click the tempo mark you want.

4. Optional: Select a modifier from the available options.

NOTE

You can only add modifiers to a Gradual Tempo Change or a Relative Tempo Change.

RESULT
During step input, tempo marks are input at the caret position. Gradual tempo changes, such as
rallentando, are also input at the caret position but do not extend as you input notes, and are
input with a default duration of a quarter note.
When adding tempo marks to existing music, they are added at the rhythmic position of the
selected barline, notehead, or rest. Gradual tempo changes span the duration of the selected
items.

AFTER COMPLETING THIS TASK
You can lengthen/shorten gradual tempo changes.

RELATED LINKS
Tempo marks on page 950
Lengthening/Shortening gradual tempo changes on page 956
Mouse input settings on page 143

Input methods for bars and barlines
You can input both bars and barlines with the keyboard by using the bars and barlines popover,
and also with the mouse by using the available options in the Bars and Barlines panel.
Additionally, you can input bars using the system track, which allows you to input other rhythmic
durations, that is, a specified beat region.

Normally you do not need to create bars in Dorico Pro, as they are created automatically as
needed when you input music. However, you can add bars in advance if, for example, you are
copying or arranging an existing piece of music.

RELATED LINKS
Bars on page 504
Barlines on page 509
System track on page 275
Inputting bar rests during step input on page 165

Bars and barlines popover
The following tables contain examples of what you can enter into the bars and barlines popover
to add and delete bars and beats, and the entries you can use to input the different barlines
available.

You can open the bars and barlines popover in Write mode in any of the following ways when
either an item is selected or the caret is active:
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● Press Shift-B.

● Choose Write > Create Bar or Barline.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Bars and barlines popover with an
example entry for inputting bars

Bars and barlines popover with an
example entry for a barline

Bars and Barlines button in the
Notations toolbox

Bars

Example action Popover entry

Add two bars 2 or +2

Add fourteen bars 14 or +14

Delete one bar –1

Delete six bars –6

Add a bar rest rest

Deleting empty bars at the end of the flow trim

You can specify a number of beats that you want to add/delete by entering the number of beats
you want followed by either the number that corresponds to the beat unit, such as 5 for eighth
notes, or the letter that corresponds to the beat unit, such as h for half notes. When using
numbers for both the number of beats and the beat unit, you must separate them with a space
or hyphen. You can also specify beats in the form of a time signature, such as 3/4 for three
quarter note beats.

Beats

Example action Popover entry

Add two quarter note beats 2q, 2-6, 2 6, or 2/4

Add two half note beats 2h, 2-7, 2 7, 2/2, or 4/4

Add one whole note beat 1w, 1-8, 1 8, or 4/4

Add four eighth note beats 4e, 4-5, 4 5, 4/8, or 2/4

Add two 16th note beats 2x, 2-4, 2 4, 2/16, or 1/8

Delete two quarter note beats –2q, -2-6, -2 6, or -2/4

These lists are not comprehensive, as you can add and delete any number of bars and beats
using the popover, including specifying beat units using the numbers one to nine as you would
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to specify durations when inputting notes. These tables are intended to illustrate how you can
structure your entry to input and delete bars and beats, and input bar rests.

Barlines

Type of barline Popover entry

Normal (Single) |, single, or normal

Double || or double

Final |] or final

Dashed :, dash, or dashed

Tick ‘ or tick

Short , or short

Thick thick

Triple triple

Start repeat |: or start

End repeat :| or end

End/Start repeat :|:, :||:, end-start, or endstart

RELATED LINKS
Inputting bar rests during step input on page 165
Bars on page 504
Barlines on page 509
Deleting bars/beats on page 504

Bars and Barlines panel
The Bars and Barlines panel allows you to input bars, bar rests, and different types of barlines. It
is located on the right of the window in Write mode.

● You can hide/show the Bars and Barlines panel by clicking Bars and Barlines in the
Notations toolbox on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

The panel contains the following sections:

Insert Bars
Allows you to determine how many bars you want to insert and where to insert
them, such as at the end of the flow.

Insert Bar Rest
Allows you to insert a bar rest.
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Create Barline
Contains the different barlines you can input.

RELATED LINKS
Hiding/Showing panels on page 18

Inputting bars/beats with the popover
You can input bars/beats using the bars and barlines popover, both during step input and by
adding them to or inserting them into existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an existing barline after which you want to add bars/beats.

● Select an existing item before which you want to add bars/beats.

2. Press Shift-B to open the bars and barlines popover.

3. Enter the number of bars/beats you want to input.
For example, enter 2 to input two bars or 2q to input two quarter note beats.

4. Press Return to close the popover.

RESULT
The number of bars or beats specified is input.
During step input, bars/beats are input from the caret position. If the caret is in the middle of the
bar when inputting bars, sufficient beats are added to ensure that the final bar created has the
correct number of beats. The caret position stays at its previous position so you can continue
inputting music from the same position.
When you add bars/beats to existing music, they are added after a selected barline and before a
selected item, including time signatures.

TIP

Another way to add bars is by choosing a note value, such as a whole note when in a 4/4 time
signature, and pressing Space repeatedly during step input.

RELATED LINKS
Bars and barlines popover on page 201
Bars on page 504

Inputting bars with the panel
You can input bars using the Bars and Barlines panel, both during step input and by adding them
to existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an existing barline after which you want to input bars.

● Select an existing item before which you want to input bars.

2. In the Notations toolbox, click Bars and Barlines to show the Bars and Barlines panel.
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3. In the Insert Bars section of the Bars and Barlines panel, change the number of bars you
want to input by changing the value in the value field.

4. Select one of the following options for where you want to input bars:

● Start of Flow: Bars are input at the beginning of the flow.

● Start of Selection: Bars are input from the selected note or rest.

● End of Flow: Bars are input at the end of the flow.

NOTE

If you want to input bars from the caret position, make sure that you have selected
Start of Selection from the menu.

5. Click Insert Bars.

RESULT
The number of bars specified is input.
During step input, bars are input from the caret position.
If you selected Start of Selection, bars are input directly after a selected barline, and directly
before a selected note, bar, or time signature.

TIP

Another way to add bars is by choosing a note value, such as a whole note when in a 4/4 time
signature, and pressing Space repeatedly during step input.

RELATED LINKS
Bars on page 504

Inputting bars/beats with the system track
You can add bars/beats within existing music, for example, if you decide you want to repeat
several bars before the next section. You can add whole bars and you can add just a few beats.

NOTE

You cannot use the system track during note input.

PREREQUISITE
The system track is shown.

PROCEDURE

1. In the system track, select the region whose duration you want to insert.
For example, if you want to insert two bars, select two bars in the system track
immediately before where you want the two new bars to be input.

2. Click Add above the system track.

Add button above the system track The Add button is highlighted when you hover
over it
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RESULT
The rhythmic duration selected in the system track is added immediately after the end of the
selection. Existing music after the selection is pushed back after the inserted bars/beats.

RELATED LINKS
System track on page 275

Inputting barlines with the popover
You can input barlines using the bars and barlines popover, both during step input and by
adding them to existing music. You can also change the type of existing barlines.

PREREQUISITE
If you want to input barlines onto single staves only, you have input an independent key
signature on those staves.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an existing note or rest immediately to the right of where you want to input a
barline.

2. Press Shift-B to open the bars and barlines popover.

3. Enter the barline you want into the popover.
For example, enter || for a double barline.

4. Input the barline and close the popover in one of the following ways:

● To input a barline on all staves, press Return.

● To input a barline on the selected staff only, press Alt-Return.

NOTE

You can only input barlines onto single staves that already have an independent
time signature.

5. Press Return to close the popover.

RESULT
During step input, barlines are input at the caret position.
When you add barlines to existing music, they are added immediately to the left of a selected
note or rest.
When you change existing barlines, the new barline directly replaces the selected barline.
Surrounding music automatically adjusts to accommodate the barline. For example, note
grouping, rests, and tied notes all adjust if necessary.

RELATED LINKS
Bars and barlines popover on page 201
Barlines on page 509
Inputting notes on page 149
Inputting time signatures with the popover on page 194
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Inputting barlines with the panel
You can input barlines using the Bars and Barlines panel, both during step input and by adding
them to existing music. You can also change the type of existing barlines.

NOTE

These steps describe inputting with the default mouse input preference Create item at
selection.

PREREQUISITE
If you want to input barlines onto single staves only, you have input an independent key
signature on those staves.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an existing note or rest immediately to the right of where you want to input a
barline.

2. In the Notations toolbox, click Bars and Barlines to show the Bars and Barlines panel.

3. Input the barline you want in one of the following ways:

● To input a barline on all staves, click it in the Bars and Barlines panel.

● To input a barline on the selected staff only, Alt-click it in the Bars and Barlines
panel.

NOTE

You can only input barlines onto single staves that already have an independent
time signature.

RESULT
During step input, barlines are input at the caret position.
When you add barlines to existing music, they are added immediately to the left of a selected
note or rest.
When you change existing barlines, the new barline directly replaces the selected barline.
Surrounding music automatically adjusts to accommodate the barline. For example, note
grouping, rests, and tied notes all adjust if necessary.

RELATED LINKS
Barlines on page 509
Bars and barlines popover on page 201
Inputting notes on page 149
Mouse input settings on page 143
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Input methods for dynamics
You can input dynamics with the keyboard by using the dynamics popover, and with the mouse
by using the Dynamics panel.

RELATED LINKS
Dynamics on page 613
Inputting dynamics with the popover on page 210
Inputting dynamics with the panel on page 212
Niente hairpins on page 622
Adding expressive text to existing dynamics on page 624

Dynamics popover
The table contains examples of what you can enter into the dynamics popover to input the
different dynamics available.

You can open the dynamics popover in Write mode in any of the following ways when either an
item is selected or the caret is active:

● Press Shift-D.

● Select an existing dynamic and press Return.

● Choose Write > Create Dynamic.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Dynamics popover with an example entry
Dynamics button in the Notations toolbox

Dynamic or expression Popover entry

pianissimo:  pp

piano:  p

mezzo piano:  mp

mezzo forte:  mf

forte:  f

fortissimo:  ff

subito subito, sub, or sub.

possibile possibile, poss, or poss.

poco poco

molto molto
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Dynamic or expression Popover entry

più piu or più

meno meno

mosso mosso

crescendo:  <

cresc. (text) cresc

diminuendo:  >

dim. (text) dim

crescendo then diminuendo messa di voce:


<>

diminuendo then crescendo:  ><

niente hairpins that start/end with a small circle o< or >o

niente hairpins that start/end with the letter “n” n< or >n

sforzando:  sfz

rinforzando:  rfz

This list is not comprehensive as you can enter anything as expressive text. It is intended to
illustrate how you can structure your entry to input different types of dynamics.

TIP

You can input hairpins directly into the score without the popover by pressing Shift-, for a
crescendo hairpin and Shift-. for a diminuendo hairpin.

You can change the appearance of gradual dynamics project-wide on the Dynamics page in
Engraving Options, or individually by activating Gradual style in the Dynamics group of the
Properties panel, and selecting one of the available options.

Inputting expressive text into the dynamics popover

You can enter expressive text into the dynamics popover, such as poco, molto, subito, espressivo,
or dolce. It appears in the correct italic font beside the dynamic.

However, you must also enter an accompanying immediate dynamic, such as p or f, and separate
the two with a space, for example, f molto or p espressivo.

You can hide immediate dynamics if you only want to show the expressive text.

RELATED LINKS
Dynamics on page 613
Niente hairpins on page 622
Hiding immediate dynamics on page 624
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Dynamics panel
The Dynamics panel contains all the different dynamics available in Dorico Pro, including gradual
dynamics, dynamic modifiers, and expressive text, such as poco and possibile.

● You can hide/show the Dynamics panel by clicking Dynamics in the Notations toolbox on
the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

The Dynamics panel contains the following sections:

Immediate Dynamics
Contains dynamics such as  and , and modifiers, such as subito and possibile.
Available modifiers are shown at the top of the section in boxes.
You can only input modifiers alongside a dynamic.

Gradual Dynamics
Contains dynamics such as  and , and modifiers, such as poco and niente.
Available modifiers are shown at the top of the section in boxes.
You can only input modifiers alongside a dynamic.

Force/Intensity of Attack
Contains dynamics such as  and .

Combined Dynamics
Allows you to create your own combinations of dynamics, such as . The controls
allow you to increase and decrease the dynamic on each side, and to swap their
order.

Combined Dynamics section of the Dynamics panel

Inputting dynamics with the popover
You can input dynamics and expressive text using the dynamics popover, both during step input
and by adding them to existing notes. You can also input different dynamics into each voice
independently in multiple-voice contexts.

TIP

You can also change dynamics during step input by following these steps when the caret is at the
rhythmic position of the dynamic you want to change.

PROCEDURE

1. In Write mode, do one of the following:
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● Start note input.

● Select existing notes across which you want to add dynamics.

2. Press Shift-D to open the dynamics popover.

3. Enter the dynamic you want into the popover.
For example, p, p<f>p, or f>.

4. Input the dynamics and close the popover in one of the following ways:

● To input the dynamics for all voices on the staff, press Return.

● During note input, input the dynamics only into the voice indicated by the caret
indicator by pressing Alt-Return.

Open-ended dynamics, such as p<, automatically extend during step input as you continue
inputting notes, or if you advance the caret by pressing Space.

5. Optional: During step input, stop open-ended dynamics by pressing Shift-/ or by opening
the dynamics popover again and inputting another immediate dynamic, such as f.

RESULT
The selected dynamics are input. They are positioned according to your settings on the
Dynamics page in Engrave > Engraving Options. Voice-specific dynamics are placed below the
staff by default, even if they are input into an up-stem voice.
During step input, dynamics are input at the caret position, and extend automatically if you
included an open-ended gradual dynamic. Voice-specific dynamics are input in the voice
indicated by the quarter note symbol beside the caret.
When you add dynamics to existing notes, immediate dynamics are added to the first note in the
selection while gradual dynamics are added across the selection.

NOTE

● If you entered a dynamic phrase into the popover, such as p<f>p, each dynamic and
hairpin lasts a quarter note (crotchet) by default. You can lengthen/shorten gradual
dynamics and groups of dynamics later.

● Some expressive text, such as molto, appears before immediate dynamics rather than after
them, even if you do not enter them in that order. This follows the generally accepted
practice for expressive text placement.

You can hide immediate dynamics later if you only want to show expressive text.

AFTER COMPLETING THIS TASK
You can move dynamics within dynamic phrases and change the placement of dynamics relative
to the staff.

RELATED LINKS
Dynamics on page 613
Groups of dynamics on page 632
Voice-specific dynamics on page 622
Moving dynamics rhythmically on page 616
Lengthening/Shortening gradual dynamics and groups of dynamics on page 625
Hiding immediate dynamics on page 624
Changing the placement of dynamics relative to the staff on page 615
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Inputting dynamics with the panel
You can input dynamics and expressive text using the Dynamics panel, both during step input
and by adding them to existing notes. You can also input different dynamics into each voice
independently in multiple-voice contexts.

NOTE

● You can also change dynamics during step input by following these steps when the caret is
at the rhythmic position of the dynamic you want to change.

● These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select existing notes across which you want to add dynamics.

2. In the Notations toolbox, click Dynamics to show the Dynamics panel.

3. Input the dynamics you want in one of the following ways:

● To input dynamics for all voices on the staff, click them in the Dynamics panel.

● During note input, input the dynamics only into the voice indicated by the caret
indicator by Alt-clicking them in the Dynamics panel.

NOTE

● If you want to add expressive or qualifying text to the dynamics, do not deselect
them.

● When inputting voice-specific dynamics, you can release Alt once you have input the
dynamic level, such as .

● Gradual dynamics have a default duration of a quarter note. You can lengthen/
shorten gradual dynamics later.

4. Optional: In the Dynamics panel, click the expressive/qualifying texts you want in the
Immediate Dynamics and Gradual Dynamics sections.

RESULT
The selected dynamics are input. They are positioned according to your settings on the
Dynamics page in Engrave > Engraving Options. Voice-specific dynamics are placed below the
staff by default, even if they are input into an up-stem voice.
During step input, dynamics are input at the caret position. Voice-specific dynamics are input in
the voice indicated by the quarter note symbol beside the caret.
When you add dynamics to existing notes, immediate dynamics are added to the first note in the
selection while gradual dynamics are added across the selection.

NOTE

● Some expressive text, such as molto, appears before immediate dynamics rather than after
them, even if you do not enter them in that order. This follows the generally accepted
practice for expressive text placement.

● You can also input gradual dynamics by clicking the gradual dynamic you want in the
Dynamics panel when nothing is selected in the music area. Then click and drag to input
the gradual dynamic and extend it to the length you want.
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AFTER COMPLETING THIS TASK
You can move dynamics within dynamic phrases and change the placement of dynamics relative
to the staff.

RELATED LINKS
Dynamics on page 613
Hiding immediate dynamics on page 624
Mouse input settings on page 143

Input methods for chord symbols
You can input chord symbols in Dorico Pro with the computer keyboard and any connected MIDI
keyboard.

RELATED LINKS
Chord symbols on page 564
Inputting chord symbols on page 217
Project-wide engraving options for chord symbols on page 564
Navigation during chord symbol input on page 216

Chord symbols popover
The following tables contain examples of what you can enter into the chord symbols popover to
input the different possible chord symbol components. You can enter them in any combination.

You can open the chord symbols popover in Write mode in any of the following ways when either
an item is selected or the caret is active:

● Press Shift-Q.

● Select an existing chord symbol and press Return.

● Choose Write > Create Chord Symbol.

● Click Chord Symbols in the Notations toolbox.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Chord symbols popover with an example entry
Chord Symbols button in the Notations toolbox

NOTE

You can combine multiple types of entries to create more complex chord symbols if you enter
them one after another into the chord symbols popover without spaces between them. For
example, enter Eblocrian for the following chord symbol:
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Chord symbol roots

Type of chord symbol root Popover entry

English note names

C, D♭, F♯, B, and so on

C, Db, F#, B, and so on

German note names

C, D♭, F♯, H, and so on

C, Des, Fis, H, and so on

Fixed-do solfège

C, D♭, F, F♯, B, and so on

do, reb, so, so#, ti, and so on

Nashville numbers representing scale degrees

Assuming C major:

C, D♭, F♯, B, and so on

1, 2b, 4#, 7, and so on

Chord symbol qualities

Chord symbol quality Popover entry

Major maj, M, ma, or nothing after entering the root.

Minor m, min, or mi

Diminished dim, di, or o

Augmented aug, au, ag, or +

Half-diminished half-dim, halfdim, or hd

6/9 6/9, 69, or %

Chord symbol intervals

Interval Popover entry

Major 7th ^7 or ^

Major 9th ^9, maj9, or 9maj7

Chord symbol alterations

Type of chord symbol alteration Popover entry

Alterations b5, #9, and so on

Added notes add#11, addF#, addBb, and so on
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Type of chord symbol alteration Popover entry

Suspensions sus4, sus9, and so on

Omissions omit3, no7, and so on

Chord symbols with altered bass notes

Example altered bass note chord symbols Popover entry

G7/D G7,D or Gmaj7,D

C(♭5)/E♭ CMb5/Eb or Cmajb5/Eb

Fm/D♯ Fm/D# or Fmi/D#

Polychord chord symbols

Example polychord chord symbols Popover entry

G/E G;E or Gmaj;E

Cmaj7/D CM7|D or Cmaj7|D

Fm/D♯ Fm|D# Fmi|D#

No chord symbols

No chord symbol Popover entry

No chord N.C., NC, no chord, or none

Modal chord symbols

Modal chord symbol Popover entry

Ionian ionian

Dorian dorian

Phrygian phrygian

Lydian lydian

Mixolydian mixolydian

Aeolian aeolian

Locrian locrian
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Modal chord symbol Popover entry

Melodic minor melodicminor

Harmonic minor harmonicminor

Whole tone wholetone

Octatonic or diminished half-whole diminishedhalfwhole,
diminishedsemitonetone, octatonichalfwhole,
or octatonicsemitonetone

Octatonic or diminished whole-half diminishedwholehalf,
diminishedtonesemitone, octatonicwholehalf,
or octatonictonesemitone

This list is not comprehensive, as there are many possible chord symbols. It is intended to
illustrate the different components you can use to input different chord symbols.

NOTE

The appearance of the resulting chord symbols depends on the options you have set on the
Chord Symbols page in Engrave > Engraving Options. The structure of your entry in the chord
symbols popover is not considered. For example, entering a C major chord as C, Cmaj, or CM
results in the same chord symbol.

RELATED LINKS
Chord symbols on page 564

Navigation during chord symbol input

You can input multiple chord symbols without re-opening the popover each time by manually
advancing it to other positions.

Navigating with a computer keyboard

You can move the chord symbols popover to input chord symbols on other notes without having
to close and reopen the popover on each note.

Popover navigation Key command

Advance the popover to the next beat. Space

Move the popover back to the previous beat. Shift-Space

Advance the popover to the start of the next
bar.

Tab

Move the popover back to the start of the
previous bar.

Shift-Tab
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Popover navigation Key command

Move the popover to one of the following
positions, whichever is closest:

● Next/Previous note

● Next/Previous rest

● Next/Previous rhythmic grid position

Right Arrow/Left Arrow

Move the popover to the next/previous chord
symbol.

Ctrl/Cmd-Right Arrow/Ctrl/Cmd-Left Arrow

Navigating with a MIDI keyboard

When inputting chord symbols using a MIDI keyboard, by default the popover advances
automatically to the next beat after you play a chord. You can change this behavior using the
Advance during chord symbol input via MIDI keyboard options on the MIDI Input page in
Write > Note Input Options.

Furthermore, you can define specific keys or buttons on your MIDI keyboard to trigger different
navigation behaviors. Use the MIDI Learn button on the Key Commands page in Preferences to
assign specific keys to the NoteInput > Advance Chord Symbol Input commands.

RELATED LINKS
Key Commands page in the Preferences dialog on page 52
Assigning MIDI commands on page 56
Assigning key commands on page 55

Chord symbol input options for MIDI keyboards
There are different possible settings for how Dorico Pro interprets the notes you press on your
MIDI keyboard when inputting chord symbols.

You can find these options on the Chord Symbols page in Write > Note Input Options. The
available options include:

● Whether you want Dorico Pro to consider the inversion in which you play a given chord, or
write the chord symbol as if it had been played in root position

● Whether you want Dorico Pro to notate omissions. For example, if you play C and E, it
could be notated as “C” or “C(omit5)”

● How you want Dorico Pro to notate added notes and suspensions

● How you want Dorico Pro to handle complex enharmonic relationships between roots and
altered bass notes

RELATED LINKS
Note Input Options dialog on page 141

Inputting chord symbols
You can add chord symbols to existing music using the chord symbols popover. You can also
open the chord symbols popover during note input; however, inputting a chord symbol stops
note input.

PROCEDURE

1. In Write mode, select the note or rest where you want to input the first chord symbol.

2. Press Shift-Q to open the chord symbols popover.
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3. Enter the chord symbol you want into the chord symbols popover in any of the following
ways:

● Enter the appropriate letters and numbers using the computer keyboard.

● Play the chord using a MIDI keyboard.

4. Optional: Advance the popover to continue inputting chord symbols on following notes.

5. Press Return to close the popover.

RESULT
The chord symbol specified is input.

NOTE

The chord symbol may look different to what you entered into the popover. For example,
entering D|C7 may result in two chords placed directly above each other, or two chords placed
beside each other, depending on your settings on the Chord Symbols page in Engrave >
Engraving Options.

RELATED LINKS
Chord symbols on page 564

Inputting polychord chord symbols
Polychord chord symbols indicate that multiple different chords, commonly two, are played
simultaneously. You can input polychords when inputting chord symbols with a MIDI keyboard.

PROCEDURE

1. In Write mode, open the chord symbols popover.

2. Play the first chord of the polychord with one hand.
Keep the keys of the first chord depressed.

3. Play the second chord with the other hand.

RESULT
The two chords you played are input as a polychord chord symbol.

TIP

You can also input polychords by entering the two chords separated by a semicolon or pipe/
vertical line character into the chord symbols popover.

RELATED LINKS
Chord symbols popover on page 213
Chord symbol input options for MIDI keyboards on page 217

Indicating root notes in chord symbols
You can indicate the root note of chord symbols when inputting chord symbols with a MIDI
keyboard.

PROCEDURE

1. In Write mode, open the chord symbols popover.

2. Indicate the root note of a chord symbol in any of the following ways when using a MIDI
keyboard:
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● First play the root with one finger, and then play the remaining notes of the chord
while still holding down the root.

● Play all the notes of the chord together, then release them all, then replay the root
note.

TIP

To input a chord symbol that consists only of the root note, just play a single note.

RELATED LINKS
Chord symbols popover on page 213
Chord symbol input options for MIDI keyboards on page 217

Indicating altered bass notes in chord symbols
You can indicate that chords have altered bass notes when inputting chord symbols with a MIDI
keyboard.

PROCEDURE

1. In Write mode, open the chord symbols popover.

2. Indicate which note is the altered bass note of a chord in any of the following ways on your
MIDI keyboard:

● Play all notes of the chord together with the altered bass note at the bottom.

● Play the chord and its altered bass note separately: Hold down the keys for the
chord, then play the altered bass note while keeping the rest of the keys of the
chord depressed.

RELATED LINKS
Chord symbols popover on page 213
Chord symbol input options for MIDI keyboards on page 217

Input methods for clefs and octave lines
You can input clefs and octave lines with the keyboard by using the clefs and octave lines
popover, and also with the mouse by using the Clefs panel.

Clefs and octave lines share the same popover and panel as both affect the pitch and register of
notes.

RELATED LINKS
Clefs on page 580
Octave lines on page 586

Clefs and octave lines popover
The following tables contain the entries for the clefs and octave lines popover that you can use to
input the different clefs and octave lines available.

You can open the clefs and octave lines popover in Write mode in any of the following ways when
either an item is selected or the caret is active:

● Press Shift-C.

● Select an existing clef or octave line and press Return.

● Choose Write > Create Clef.
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The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Clefs and octave lines popover
with an example entry for a clef

Clefs and octave lines popover
with an example entry for an
octave line

Clefs button in the Notations
toolbox

Clefs

Type of clef Popover entry

Treble G clef g, G, sol, or treble

Bass F clef f, F, fa, or bass

Tenor C clef ct, CT, ut4, or tenor

Alto C clef ca, CA, ut3, or alto

Treble G clef, octave below g8ba, G8ba, g8d, G8d, treble8ba, or treble8d

Treble G clef, two octaves below g15ba, G15ba, g15d, G15d, treble15ba, or
treble15d

Treble G clef, octave above g8va, G8va, g8u, G8u, treble8va, or treble8u

Treble G clef, two octaves above g15ma, G15ma, g15u, G15u, treble15ma, or
treble15u

Alto C clef, octave below ca8ba, CA8ba, ca8d, CA8d, alto8ba, or alto8d

Tenor C clef, octave below ct8ba, CT8ba, ct8d, CT8d, tenor8ba, or tenor8d

Bass F clef, octave below f8ba, F8ba, f8d, F8d, bass8ba, or bass8d

Bass F clef, two octaves below f15ba, F15ba, f15d, F15d, bass15ba, or
bass15d

Bass F clef, octave above f8va, F8va, f8u, F8u, bass8va, or bass8u

Bass F clef, two octaves above f15ma, F15ma, f15u, F15u, bass15ma, or
bass15u

Unpitched percussion perc

4-string tablature tab4

6-string tablature tab6

Baritone bass clef baritonebass
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Type of clef Popover entry

Baritone clef baritone or ut5

Mezzo-soprano clef mezzo or ut2

Soprano C clef soprano or ut1

Sub-bass clef subbass

Invisible clef invisible

NOTE

More clefs are available in the Clefs panel, including Indian drum clef and Percussion clef
(rectangular).

Octave lines

Function of octave line Popover entry

Shifts notes up by 1 octave. 8va, 8, 8u, or 1u

Shifts notes up by 2 octaves. 15ma, 15, 15u, or 2u

Shifts notes up by 3 octaves. 22ma, 22, 22u, or 3u

Shifts notes down by 1 octave. 8ba, 8vb, 8d, or 1d

Shifts notes down by 2 octaves. 15ba, 15vb, 15d, or 2d

Shifts notes down by 3 octaves. 22ba, 22vb, 22d, or 3d

Loco indication loco

End of octave line

For example, enter stop to specify where an
octave line ends during step input.

| or stop

RELATED LINKS
Clefs on page 580
Octave lines on page 586

Clefs panel
The Clefs panel contains all the different types of clefs and octave lines available in Dorico Pro,
including uncommon and archaic clefs.

● You can hide/show the Clefs panel by clicking Clefs in the Notations toolbox on the right of
the window in Write mode.
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You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

The Clefs panel contains the following sections:

Common Clefs
Contains the clefs you are most likely to need, including treble clef and bass clef.

Uncommon Clefs
Contains less frequently used clefs, such as an invisible clef and French violin clef.

Archaic Clefs
Contains clefs that are rarely used any more, such as the mezzo-soprano clef and
sub-bass clef.

Octave Lines
Contains octave lines, indicating up to three octaves above and below, and a loco
line.

Inputting clefs with the popover
You can input clefs using the clefs and octave lines popover, both during step input and by
adding them to existing music. You can also use the popover to change the type of existing clefs.

In Dorico Pro, you cannot hide clefs. Therefore, if you do not want to show any clef, you must
input an invisible clef.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the note from which you want a new clef to start.

2. Press Shift-C to open the clefs and octave lines popover.

3. Enter the appropriate entry for the clef you want into the popover.
For example, enter bass or G8ba.

4. Press Return to close the popover.

RESULT
During step input, clefs are input at the caret position. Note input continues after inputting the
clef, so you can continue inputting notes and clefs as required.
When you add clefs to existing music, clefs are added directly before a selected notehead, and
apply to all notes on that staff until the next clef, or the end of the flow.
Clefs apply to all notes on the staff until the next clef or the end of the flow, whichever comes
first.

RELATED LINKS
Clefs on page 580

Inputting clefs with the panel
You can input clefs using the Clefs panel, both during step input and by adding them to existing
music.

NOTE

● In Dorico Pro, you cannot hide clefs. Therefore, if you do not want to show any clef, you
must input an invisible clef.
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● These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the note from which you want a new clef to start.

2. In the Notations toolbox, click Clefs to show the Clefs panel.

3. In the Clefs panel, click the clef you want.

RESULT
During step input, clefs are input at the caret position. Note input continues after inputting the
clef, so you can continue inputting notes and clefs as required.
When you add clefs to existing music, clefs are added directly before a selected notehead, and
apply to all notes on that staff until the next clef, or the end of the flow.
Clefs apply to all notes on the staff until the next clef or the end of the flow, whichever comes
first.

RELATED LINKS
Clefs on page 580
Mouse input settings on page 143

Inputting octave lines with the popover
You can input octave lines using the clefs and octave lines popover, both during step input and
by adding them to existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the notes to which you want to add an octave line.

2. Press Shift-C to open the clefs and octave lines popover.

3. Enter the appropriate entry for the octave line you want into the popover.
For example, enter 8va for an octave line that shifts notes up one octave.

4. Press Return to close the popover.

5. Optional: During step input, press Space to advance the caret and extend the octave line.
The octave line also extends automatically as you continue inputting notes.

6. Optional: During step input, stop any octave line by opening the clefs and octave lines
popover again and entering one of the following:

● |
● stop

RESULT
During step input, octave lines are input from the caret position. When you stop octave lines,
they end at the caret position.
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When you add octave lines to existing notes, they are added either above or below your
selection, depending on whether the octave line indicates that notes are played higher or lower
than notated.

TIP

You can also lengthen/shorten octave lines after they have been input.

RELATED LINKS
Clefs and octave lines popover on page 219
Octave lines on page 586
Lengthening/Shortening octave lines on page 587

Inputting octave lines with the panel
You can input octave lines using the Clefs panel, both during step input and by adding them to
existing music.

NOTE

These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the notes to which you want to add an octave line.

2. In the Notations toolbox, click Clefs to show the Clefs panel.

3. In the Clefs panel, click the octave line you want.
Alternatively, when adding octave lines to existing notes, you can click the octave lines you
want in the Clefs panel first, and then click and drag to the length you want.

RESULT
During step input, octave lines are input at the caret position. However, if input using the mouse,
octave lines do not automatically extend as you continue inputting notes.
When you add octave lines to existing notes, they are added either above or below your
selection, depending on whether the octave line indicates that notes are played higher or lower
than notated.

TIP

You can also lengthen/shorten octave lines after they have been input.

RELATED LINKS
Octave lines on page 586
Lengthening/Shortening octave lines on page 587
Mouse input settings on page 143
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Input methods for holds and pauses
You can input holds and pauses with the keyboard by using the holds and pauses popover in
Write mode, and with the mouse by using the Holds and Pauses panel.

RELATED LINKS
Holds and pauses on page 664
Correct positioning for caesura input on page 228

Holds and pauses popover
The table contains the entries for the holds and pauses popover that you can use to input the
different holds and pauses available.

You can open the holds and pauses popover in Write mode in any of the following ways when
either an item is selected or the caret is active:

● Press Shift-H.

● Select an existing hold or pause and press Return.

● Choose Write > Create Hold or Pause.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Holds and pauses popover with an example entry
Holds and Pauses button in the Notations toolbox

Type of hold or pause Popover entry

Fermata fer or fermata

Very long fermata fermataverylong

Long fermata fermatalong

Short fermata fermatashort

Very short fermata fermataveryshort

Short fermata (Henze) fermatashorthenze
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Type of hold or pause Popover entry

Long fermata (Henze) fermatalonghenze

Curlew (Britten) curlew

Caesura caesura or //

Thick caesura caesurathick

Curved caesura caesuracurved

Short caesura caesurashort

Breath mark (Comma-like) breathmarkcomma, comma, or , (comma)

Breath mark (Tick-like) breathmarktick

Breath mark (Upbow-like) breathmarkupbow

Breath mark (Salzedo) breathmarksalzedo

NOTE

The Curlew mark was originally devised by Benjamin Britten for “Curlew River”, a parable for
church performance inspired by Japanese Noh theater. It indicates that a player should hold a
note or a rest until a synchronization point in asynchronous music.

RELATED LINKS
Holds and pauses on page 664
Types of fermatas on page 664
Types of caesuras on page 666
Types of breath marks on page 666
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Holds and Pauses panel
The Holds and Pauses panel allows you to input all the different types of holds and pauses
available in Dorico Pro, including alternative versions of fermatas.

● You can hide/show the Holds and Pauses panel by clicking Holds and Pauses in the
Notations toolbox on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

The Holds and Pauses panel contains the following sections:

● Fermatas

● Breath Marks

● Caesuras

NOTE

Holds and pauses do not currently have an effect in playback, but this is planned for future
versions.

Inputting holds and pauses with the popover
You can input holds and pauses using the holds and pauses popover, both during step input and
by adding them to existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an existing note to which you want to add a hold or pause.

NOTE

You can only add one hold or pause to one note at a time.

2. Press Shift-H to open the holds and pauses popover.

3. Enter the hold or pause you want into the popover.
For example, enter fermata or caesura.

4. Press Return to close the popover.

RESULT
During step input, the specified hold or pause is input at the caret position.
Fermatas appear above the selected note, and above all notes or rests at that rhythmic position
on all staves, or the rhythmic position of the note, chord, or rest that corresponds with the end of
the fermata.
Breath marks appear to the right of the caret or selected note.
Caesuras appear to the left of the caret or selected note, and appear on all staves at that same
rhythmic position.

RELATED LINKS
Holds and pauses on page 664
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Inputting holds and pauses with the panel
You can input holds and pauses using the Holds and Pauses panel, both during step input and by
adding them to existing music.

NOTE

These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an existing note to which you want to add a hold or pause.

NOTE

You can only add one hold or pause to one note at a time.

2. In the Notations toolbox, click Holds and Pauses to show the Holds and Pauses panel.

3. In the Holds and Pauses panel, click the hold or pause you want.

RESULT
During step input, the specified hold or pause is input at the caret position.
Fermatas appear above the selected note, and above all notes or rests at that rhythmic position
on all staves, or the rhythmic position of the note, chord, or rest that corresponds with the end of
the fermata.
Breath marks appear to the right of the caret or selected note.
Caesuras appear to the left of the caret or selected note, and appear on all staves at that same
rhythmic position.

RELATED LINKS
Holds and pauses on page 664
Mouse input settings on page 143

Correct positioning for caesura input
Caesuras are commonly placed at the end of a bar, before a barline. In Dorico Pro, caesuras must
be attached to the note immediately after the position where you want it to appear, as then
Dorico Pro can automatically position them correctly.

If you input caesuras with your mouse input preference set to Load pointer with item, you must
click the first note in the next bar for a caesura to appear to the left of the barline. You can also
click directly on the barline.

A correctly input caesura. The dotted attachment
lines are attached to the notehead after the barline,
meaning the caesura is correctly positioned before
the barline.

An incorrectly input caesura. By clicking to the left of
the barline, the caesura is attached to the last eighth
note in the bar.
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When input correctly, the dotted attachment lines link the caesura to the notehead immediately
after the barline.

If your dotted attachment lines do not link the caesura to the notehead immediately after the
barline, delete the caesura and re-input it. Caesuras can cause spacing issues when input
incorrectly.

RELATED LINKS
Holds and pauses on page 664
Types of caesuras on page 666

Input methods for ornaments, arpeggio signs, glissando lines, and
jazz articulations

You can input ornaments, including arpeggio signs, glissando lines, and jazz articulations, with
the keyboard by using the ornaments popover, and with the mouse by using the Ornaments
panel.

You can input ornaments and arpeggio signs during step input and by adding them to existing
notes, but you cannot input glissando lines during step input. You can only input glissando lines
by adding them to existing notes.

You can specify the type/length of jazz articulations when using the Ornaments panel but not
when using the ornaments popover.

RELATED LINKS
Ornaments on page 729
Arpeggio signs on page 745
Glissando lines on page 753
Jazz articulations on page 759
Jazz ornaments on page 760
Inputting ornaments with the popover on page 232
Inputting ornaments with the panel on page 233

Ornaments popover
The following tables contain the entries for the ornaments popover that you can use to input the
different ornaments, arpeggio signs, glissando lines, and jazz articulations available.

You can open the ornaments popover in Write mode in any of the following ways when either an
item is selected or the caret is active:

● Press Shift-O.

● Select an existing ornament and press Return.

● Choose Write > Create Ornament.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Ornaments popover with an example entry
Ornaments button in the Notations toolbox
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Ornaments

Type of ornament Popover entry

Trill:  tr or trill

Short trill:  shorttr

Turn:  turn

Mordent:  mor or mordent

Trill intervals

Trill interval Popover entry

Major second tr 2 or tr M2

Minor third tr m3

Perfect fifth tr p5

Augmented fourth tr aug4

Diminished fifth tr dim5

This list is not comprehensive, as there are many possible trill intervals. It is intended to illustrate
how you can structure your entry to input different trill intervals.

Jazz ornaments

Type of jazz ornament Popover entry

Flip flip

Smear smear

Jazz turn jazz or shake

Bend bend
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Arpeggio signs

Type of arpeggio sign Popover entry

Up arpeggio sign arp, arpup, or arpeggioup

Down arpeggio sign arpdown or arpeggiodown

Non arpeggio sign nonarp or nonarpeggio

Glissando lines

Type of glissando line Popover entry

Straight glissando line gliss

Wavy glissando line glisswavy

Jazz articulations

Type of jazz articulation Popover entry

Plop (bend) plop

Plop (smooth) plopsmooth

Scoop scoop

Doit (bend) doit

Doit (smooth) doitsmooth

Fall (bend) fall

Fall (smooth) fallsmooth

TIP

Other ornaments are available in the Ornaments panel on the right of the window in Write mode.

You can specify the type/length of jazz articulations when using the Ornaments panel but not
when using the ornaments popover.

RELATED LINKS
Inputting arpeggio signs with the popover on page 234
Inputting glissando lines with the popover on page 235
Ornaments on page 729
Trill intervals on page 737
Arpeggio signs on page 745
Glissando lines on page 753
Jazz articulations on page 759
Jazz ornaments on page 760
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Ornaments panel
The Ornaments panel allows you to input all the different types of ornaments, incuding jazz
articulations, as well as arpeggio signs and glissando lines.

● You can hide/show the Ornaments panel by clicking Ornaments in the Notations toolbox
on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

The Ornaments panel contains the following sections:

Jazz
Contains ornaments and pitch alterations commonly used in jazz music, such as
bends, scoops, and falls.

Baroque and Classical
Contains ornaments commonly used in Baroque and Classical music, such as
mordents, turns, and trills.

Arpeggiation
Contains the different types of arpeggio signs.

NOTE

You cannot input arpeggio signs with the mouse during step input.

Glissandi
Contains the different types of glissando lines.

Inputting ornaments with the popover
You can input ornaments and jazz ornaments using the ornaments popover, both during step
input and by adding them to existing notes.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select a single existing note to which you want to add an ornament.

● Select existing notes across which you want to add a trill.

NOTE

You can only add one ornament to one note at a time.

2. Press Shift-O to open the ornaments popover.

3. Enter the appropriate entry for the ornament you want into the popover.
For example, enter trill for a trill or mor for a mordent.

4. Press Return to close the popover.

RESULT
During step input, ornaments are input at the caret position. Trills last the duration of the
rhythmic value of the note input at the caret position and have a default interval of a second,
either major or minor depending on the context. If you specified an interval for your trill, the
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interval applies only to the first note in the selection, but you can also change the interval
partway through trills.
When adding ornaments to existing notes, ornaments are input above the selected note. Trills
are input above the first selected note, with an extender line across any subsequent selected
notes.

RELATED LINKS
Ornaments on page 729
Jazz ornaments on page 760
Inputting notes on page 149
Changing intervals partway through trills on page 739

Inputting ornaments with the panel
You can input ornaments and jazz ornaments using the Ornaments panel, both during step input
and by adding them to existing notes.

NOTE

These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select a single existing note to which you want to add an ornament.

● Select existing notes across which you want to add a trill.

NOTE

You can only add one ornament to one note at a time.

2. In the Notations toolbox, click Ornaments to show the Ornaments panel.

3. In the Ornaments panel, click the ornament you want.

RESULT
During step input, ornaments are input at the caret position. Trills are input with a default
duration of a quarter note.
When adding ornaments to existing notes, ornaments are input above the selected note. Trills
are input above the first selected note, with an extender line across any subsequent selected
notes.

RELATED LINKS
Ornaments on page 729
Jazz ornaments on page 760
Inputting notes on page 149
Mouse input settings on page 143

Write mode
Notations input 

233
Dorico 2.2.20



Inputting arpeggio signs with the popover
You can input arpeggio signs using the ornaments popover, both during step input and by
adding them to existing notes. You can also input cross-staff arpeggio signs between notes in
different staves that belong to the same instrument, such as piano or harp.

NOTE

You can only add one arpeggio sign to one note or chord at a time.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the existing notes to which you want to add an arpeggio sign.

NOTE

● For instruments with multiple staves, such as piano and harp, you can select
existing notes in multiple staves to create cross-staff arpeggio signs.
However, you cannot create cross-staff arpeggio signs between different
instruments.

● Arpeggio signs are added to all notes in the same voice at the selected
rhythmic position.

2. Optional: During step input, press Q to start chord input.

3. Press Shift-O to open the ornaments popover.

4. Enter the appropriate entry for the arpeggio sign you want into the popover.
For example, enter arpup for an up arpeggio or enter arpdown for a down arpeggio.

5. Press Return to close the popover.

6. Optional: During step input, input the notes you want.

RESULT
During step input, arpeggio signs are input at the caret position.
When adding arpeggio signs to existing notes, they are input to the left of the selected note or
chord.
The length of arpeggio signs is adjusted automatically so that they span the range of all notes in
the selected voice at that rhythmic position.

RELATED LINKS
Ornaments popover on page 229
Arpeggio signs on page 745
Inputting notes on page 149
Inputting chords on page 167

Inputting arpeggio signs with the panel
You can input arpeggio signs on existing notes using the Ornaments panel. You can also input
cross-staff arpeggio signs between notes in different staves that belong to the same instrument,
such as piano or harp.

NOTE

● You can only add one arpeggio sign to one note or chord at a time, and you cannot input
arpeggio signs with the mouse during step input.
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● These steps describe inputting with the default mouse input preference Create item at
selection.

You cannot create cross-staff and cross-voice arpeggio signs if your preference is set to
Load pointer with item.

PROCEDURE

1. In Write mode, select the existing notes to which you want to add an arpeggio sign.

NOTE

● For instruments with multiple staves, such as piano and harp, you can select existing
notes in multiple staves to create cross-staff arpeggio signs. However, you cannot
create cross-staff arpeggio signs between different instruments.

● Arpeggio signs are added to all notes in the same voice at the selected rhythmic
position.

2. In the Notations toolbox, click Ornaments to show the Ornaments panel.

3. In the Ornaments panel, click the arpeggio sign you want in the Arpeggiation section.

RESULT
The arpeggio sign specified is input to the left of the selected note or chord. Its length is adjusted
automatically so that it spans the range of all notes in the selected voice at that rhythmic
position.

RELATED LINKS
Arpeggio signs on page 745
Mouse input settings on page 143

Inputting glissando lines with the popover
You can input glissando lines between existing notes using the ornaments popover. You can
input glissando lines between both adjacent/non-adjacent notes.

NOTE

You cannot input glissando lines during step input.

PROCEDURE

1. In Write mode, select one of the following:

● The note from which you want a glissando line to start.

● Any two notes that you want to join with a glissando line.

TIP

The two notes can be in different voices.

2. Press Shift-O to open the ornaments popover.

3. Enter the appropriate entry for the glissando line you want into the popover.

● Enter gliss for a straight glissando line.

● Enter glisswavy for a wavy glissando line.
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4. Press Return to close the popover.

RESULT
If you selected two notes, the glissando line specified is input between the selected notes.
If you selected a single note, the glissando line specified starts from the selected note and ends
at the next note on the staff, even if this crosses rests.

NOTE

● You cannot input a glissando line on the last note on a staff.

● Glissando lines do not automatically adjust around any notes or rests between the
selected notes. If glissando text is shown, the text can collide with notes or rests, in which
case we recommend that you make further adjustments, such as not showing glissando
text for that glissando line.

RELATED LINKS
Ornaments popover on page 229
Glissando lines on page 753
Changing glissando line text on page 755
Changing when glissando line text is shown on page 756

Inputting glissando lines with the panel
You can input glissando lines between existing notes using the Ornaments panel. You can input
glissando lines between both adjacent/non-adjacent notes.

NOTE

● These steps describe inputting with the default mouse input preference Create item at
selection.

If your preference is set to Load pointer with item, you can only input glissando lines
between the note you click on and the note immediately following it.

● You cannot input glissando lines during step input.

PROCEDURE

1. In Write mode, select one of the following:

● The note from which you want a glissando line to start.

● Any two notes that you want to join with a glissando line.

TIP

The two notes can be in different voices.

2. In the Notations toolbox, click Ornaments to show the Ornaments panel.

3. In the Ornaments panel, click the style of glissando line you want.

● Glissando (Straight)

● Glissando (Wavy)
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RESULT
If you selected two notes, the glissando line specified is input between the selected notes.
If you selected a single note, the glissando line specified starts from the selected note and ends
at the next note on the staff, even if this crosses rests.

NOTE

● You cannot input a glissando line on the last note on a staff.

● Glissando lines do not automatically adjust around any notes or rests between the
selected notes. If glissando text is shown, the text can collide with notes or rests, in which
case we recommend that you make further adjustments, such as not showing glissando
text for that glissando line.

RELATED LINKS
Glissando lines on page 753
Mouse input settings on page 143

Inputting jazz articulations with the popover
You can input jazz articulations using the ornaments popover, both during step input and by
adding them to existing notes.

NOTE

You can input jazz ornaments, such as flips or jazz turns, in the same ways as inputting
ornaments.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the existing notes to which you want to add jazz articulations.

2. Press Shift-O to open the ornaments popover.

3. Enter the appropriate entry for the jazz articulation you want into the popover.
For example, enter scoop for a scoop or fall for a fall.

4. Press Return to close the popover.

RESULT
The jazz articulation you specify is input on all selected notes. During note input, this is usually
the previous note you input.

NOTE

When using the popover, all jazz articulations follow your project-wide settings for their line style.
You can change their type/length after they have been input.

When using the panel, you can specify the line style of jazz articulations when you input them.

RELATED LINKS
Ornaments popover on page 229
Inputting ornaments with the popover on page 232
Jazz articulations on page 759
Changing the type/length of existing jazz articulations on page 763
Changing the line style of smooth jazz articulations on page 763
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Inputting jazz articulations with the panel
You can input jazz articulations using the Ornaments panel, both during step input and by
adding them to existing notes.

NOTE

● You can input jazz ornaments, such as flips or jazz turns, in the same ways as inputting
ornaments.

● These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the existing notes to which you want to add jazz articulations.

2. In the Notations toolbox, click Ornaments to show the Ornaments panel.

3. In the Ornaments panel, click the jazz articulation you want in the Jazz section.

RESULT
The jazz articulation you specify is input on all selected notes. During note input, this is usually
the previous note you input.

RELATED LINKS
Inputting ornaments with the panel on page 233
Mouse input settings on page 143

Input methods for playing techniques and pedal lines
You can input playing techniques with the keyboard by using the playing techniques popover,
and with the mouse by using the Playing Techniques panel. Pedal lines are considered playing
techniques in Dorico Pro because both affect the sound that the instrument produces.

RELATED LINKS
Playing techniques on page 790
Inputting playing techniques with the popover on page 242
Inputting playing techniques with the panel on page 243

Playing techniques popover
The following tables contain the entries for the playing techniques popover that you can use to
input playing techniques, pedal lines, retakes, and pedal level changes.

When you start entering a playing technique into the playing techniques popover, a menu
appears that shows valid playing techniques containing the letters/words you enter. You can
then select one of these playing techniques to input.

You can open the playing techniques popover in Write mode in any of the following ways when
either an item is selected or the caret is active:

● Press Shift-P.

● Select an existing playing technique and press Return.
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● Choose Write > Create Playing Technique.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Playing techniques popover with
an example entry for inputting a
playing technique

Playing techniques popover with
an example entry for inputting a
pedal line

Playing Techniques button in the
Notations toolbox

Playing techniques

Playing technique Popover entry

Vibrato vibrato

Senza vibrato senza vibrato

Naturale (nat.) nat

Con sord. con sord

Strong air pressure strong air pressure

Double-tongue double-tongue

Down bow downbow

Up bow upbow

Sul ponticello sul pont

Sul tasto sul tasto

Poco sul tasto pst

Pizzicato pizz

Spiccato spicc

Arco arco

Tongue click (Stockhausen) tongue click

Finger click (Stockhausen) finger click

Vibraphone motor on motor on

Vibraphone motor off motor off
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Playing technique Popover entry

Open open

Damp damp

Damp (large) damp large

Full barré full barre

Half barré half barre

Strum up strum up

Strum down strum down

Left hand lh

Right hand rh

This list is not comprehensive as there are many valid playing techniques. It is intended to
illustrate how you can structure your entry to input different types of common playing
techniques.

If you do not know the correct entry for a playing technique, start entering part of the playing
technique and see if it becomes available in the popover menu.

NOTE

As playing techniques correspond to specific samples, they must be input as described or
selected from the popover menu.

Pedal lines

Type of pedal line, retake, or pedal level
change

Popover entry

Sustain pedal line ped

Set sustain pedal level to 1/4 1/4

Set sustain pedal level to 1/2 r

Set sustain pedal level to 3/4 3/4

Fully depress sustain pedal 1

Retake in sustain pedal line ^, notch, or retake

Remove retake in sustain pedal line nonotch

Stop sustain pedal line *
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Type of pedal line, retake, or pedal level
change

Popover entry

Sostenuto pedal line sost

Stop sostenuto pedal line s*

Una corda pedal line unacorda

Stop una corda pedal line u*

RELATED LINKS
Playing techniques on page 790
Pedal lines on page 771
Sustain pedal retakes and pedal level changes on page 772
Adding retakes and pedal level changes to existing pedal lines with the popover on page 244

Playing Techniques panel
The Playing Techniques panel contains all the different playing techniques available in Dorico
Pro, divided into instrument families. Pedal lines are included in the Keyboard section.

● You can hide/show the Playing Techniques panel by clicking Playing Techniques in the
Notations toolbox on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

The Playing Techniques panel contains the following sections:

Common
Contains commonly used playing techniques that also apply to multiple different
instrument families, such as “mute” and “legato”.

Wind
Contains playing techniques typically only used for wind instruments, such as “key
clicks” and “whistle tones”.

Brass
Contains playing techniques typically only used for brass instruments, such as “cup
mute” and “stopped”.

Unpitched Percussion
Contains playing techniques typically only used for unpitched percussion
instruments, such as “rim” and “scrape”.

Pitched Percussion
Contains playing techniques typically only used for pitched percussion instruments,
such as “motor on” and “½ Ped.” for vibraphones.

Keyboard
Contains playing techniques typically only used for keyboard instruments, such as
“Ped.” and different pedal depression levels.
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Choral
Contains playing techniques typically only used for the voice, such as “mouth open”
and “tongue click”.

Strings
Contains playing techniques typically only used for string instruments, such as “col
legno battuto” and “down bow”.

Guitar
Contains playing techniques typically only used for guitars and fretted instruments,
such as “half barré” and “strum up”.

TIP

● You can hover your mouse pointer over the options in each section to show the name of
each playing technique.

● You can use the action bars at the bottom of each section to access the Edit Playing
Techniques dialog.

RELATED LINKS
Edit Playing Techniques dialog on page 796

Inputting playing techniques with the popover
You can input playing techniques using the playing techniques popover, both during step input
and by adding them to existing notes.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an existing note to which you want to add a playing technique.

NOTE

You can only add playing techniques to one note at a time.

2. Press Shift-P to open the playing techniques popover.

3. Enter the appropriate entry for the playing technique you want into the popover.
For example, enter non vibrato or tongue click.
When you start entering a playing technique into the playing techniques popover, a menu
appears that shows valid playing techniques containing the letters/words you enter, which
you can select.

4. Press Return to close the popover.

RESULT
The playing technique is added to the selected note.
During step input, playing techniques are input at the caret position.
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Inputting playing techniques with the panel
You can input playing techniques using the Playing Techniques panel, both during step input and
by adding them to existing notes.

NOTE

These steps describe inputting with the default mouse input preference Create item at
selection.

If you want to add the same playing technique to multiple notes, activate Allow multiple items
to be created with the mouse in the Editing section of the Note Input and Editing page in
Preferences, so that you do not have to reselect the playing technique for each note.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an existing note to which you want to add a playing technique.

NOTE

You can only add playing techniques to one note at a time.

2. In the Notations toolbox, click Playing Techniques to show the Playing Techniques panel.

3. In the Playing Techniques panel, click the playing technique you want.

RESULT
The playing technique is added to the selected note.
During step input, playing techniques are input at the caret position, even if your preference is
set to Load pointer with item.

RELATED LINKS
Mouse input settings on page 143

Inputting pedal lines, retakes, and pedal level changes with the popover
You can input pedal lines using the playing techniques popover, both during step input and by
adding them to existing music. Because the pedal line extends automatically as you input notes
during step input, you can input retakes and pedal level changes when you reach the appropriate
rhythmic position.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the notes to which you want the pedal line to apply.

2. Press Shift-P to open the playing techniques popover.

3. Enter the appropriate entry for the pedal line you want into the popover.
For example, enter ped for a sustain pedal line.

4. Press Return to close the popover.
The pedal line is input.
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5. Optional: During step input, extend the pedal line by pressing Space to advance the caret.
The pedal line also extends automatically as you continue inputting notes.

6. Optional: During step input, input retakes or pedal level changes by opening the playing
techniques popover again at the appropriate rhythmic position and enter the entry for the
retake or pedal level change you want into the popover.
For example, enter ^ or retake for a retake.

7. Optional: During step input, stop the pedal line by opening the playing techniques
popover again and enter the appropriate entry into the popover.
For example, enter * to stop a sustain pedal line.

8. Press Return to close the popover.

RESULT
During step input, pedal lines start at the caret position, and end at the caret position.
When you add pedal lines to existing notes, pedal lines are added across the selected notes.

RELATED LINKS
Sustain pedal retakes and pedal level changes on page 772
Inputting notes on page 149
Adding retakes and pedal level changes to existing pedal lines with the popover on page 244
Positions of pedal lines on page 777

Adding retakes and pedal level changes to existing pedal lines with the popover

You can add retakes and pedal level changes to existing sustain pedal lines using the playing
techniques popover.

NOTE

You cannot add retakes and pedal level changes to sostenuto or una corda pedal lines.

PREREQUISITE
You have input a sustain pedal line.

PROCEDURE

1. In Write mode, select an item at the rhythmic position where you want the retake or pedal
level change to apply.

2. Press Shift-P to open the playing techniques popover.

3. Enter the appropriate entry for the retake or pedal level change you want into the
popover. For example, enter ^ or retake for a retake.

4. Press Return to close the popover.

RESULT
The retake or pedal level change is input at the selected rhythmic position.

RELATED LINKS
Sustain pedal retakes and pedal level changes on page 772
Playing techniques popover on page 238
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Inputting pedal lines, retakes, and pedal level changes with the panel
You can input pedal lines, retakes, and pedal level changes using the Playing Techniques panel.

NOTE

● When using the panel, you cannot input pedal lines, retakes, or pedal level changes during
step input.

● These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE

1. In Write mode, select the notes to which you want the pedal line to apply.

2. In the Notations toolbox, click Playing Techniques to show the Playing Techniques panel.

3. In the Playing Techniques panel, click the pedal line you want in the Keyboard section.
Alternatively, with nothing selected, click the pedal line you want in the Keyboard section
of the Playing Techniques panel, then click and drag in the score to create a pedal line and
extend it to the duration you want.

4. Optional: Select an item at the rhythmic position where you want to input a retake or pedal
level change.

5. Optional: In the Playing Techniques panel, click the retake or pedal level change you want
in the Keyboard section.

RESULT
The pedal line is input across the selected range.

RELATED LINKS
Sustain pedal retakes and pedal level changes on page 772
Adding retakes and pedal level changes to existing pedal lines with the panel on page 245
Mouse input settings on page 143

Adding retakes and pedal level changes to existing pedal lines with the panel

You can add retakes and pedal level changes to existing sustain pedal lines using the Playing
Techniques panel.

NOTE

You cannot add retakes and pedal level changes to sostenuto or una corda pedal lines.

PREREQUISITE
You have input a sustain pedal line.

PROCEDURE

1. In Write mode, select an item at the rhythmic position where you want the retake or pedal
level change to apply.

2. Input the retake or pedal level change you want in one of the following ways:

● Click the retake or pedal level change you want in the Keyboard section of the
Playing Techniques panel.
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● Choose Edit > Pedal Lines > [Retake or pedal level change]. You can also choose
this option from the context menu.

RESULT
The retake or pedal level change is input at the selected rhythmic position.

TIP

Alternatively, if nothing is selected in the score, you can click a retake or pedal level change in the
Keyboard section of the Playing Techniques panel, and then click at the rhythmic position where
you want to input the retake or pedal level change.

RELATED LINKS
Sustain pedal retakes and pedal level changes on page 772
Input methods for playing techniques and pedal lines on page 238

Inputting lyrics
You can input lyrics by entering text into the lyrics popover, and you can advance the lyrics
popover to the next note on the staff without closing and reopening it for every note.

PROCEDURE

1. In Write mode, select the first note to which you want to input lyrics.

2. Press Shift-L to open the lyrics popover.
By default, the lyrics popover opens with lyric line input selected.

3. Optional: Change the type of lyric in one of the following ways:

● To change the lyric line number, press Down Arrow.

● To input lyrics above the staff, press Shift-Up Arrow.

● To input chorus lines, press Up Arrow.

● To input lyric line translations, press Alt-Down Arrow.

4. Enter the word or syllable you want to add to the selected note into the popover.

● To enter multiple words on a single note, press Shift-Alt-Space.

● To include a hyphen within a single word or syllable, press Alt-- (hyphen).

● To include an elision in a lyric, press _ (underscore).

5. Advance the popover to the next note in one of the following ways:

● If you entered a complete word, or the final syllable in a multi-syllabic word, press
Space.

● If you entered one syllable of a multi-syllabic word that is not the final syllable, press
- (hyphen).

● If you do not want the syllable to be followed by an extension line or hyphen, press
Right Arrow.

6. Continue entering words and syllables into the popover for the rest of the notes to which
you want to add lyrics.

7. Press Return or Esc to close the popover.
The popover closes automatically when you reach the last note on the staff.

RESULT
The text you entered into the popover is input as lyrics of the type indicated by the icon on the
left-hand side of the popover.
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If you advanced the popover to the next note by pressing -, a hyphen appears after the last
entered lyric. This is used for multi-syllabic words across multiple notes.
If you advance the popover by pressing Space, a gap appears after the last entered lyric. This is
used for single-syllable words or for the final syllable in multi-syllabic words.

NOTE

You can later change whether a gap or a hyphen appears between lyrics by changing their
syllable type.

RELATED LINKS
Lyrics on page 690
Navigation during lyric input on page 248
Types of lyrics on page 692
Types of syllables in lyrics on page 694
Lyric line numbers on page 701
Lyric hyphens and lyric extender lines on page 698

Lyrics popover
You can input lyrics, including chorus lines and lyric line translations, using the lyrics popover.
You can use key commands to change the type of lyric being input at any time.

You can open the lyrics popover in Write mode in any of the following ways when either an item
is selected or the caret is active:

● Press Shift-L.

● Select an existing lyric and press Return.

● Choose Write > Create Lyrics.

● Click Lyrics in the Notations toolbox.

Lyric lines
The popover automatically opens ready to input lyrics into Line 1, except if you are
changing an existing lyric.
The number shown on the left-hand side of the lyrics popover indicates the lyric line
into which the lyric is input.

The lyrics popover with an example entry for Line 1

You can change the lyric line number by pressing Down Arrow when the lyrics
popover is open.

The lyrics popover with an example entry for Line 2

Lyric lines above the staff
You can input lyrics into lines above the staff by pressing Shift-Up Arrow when the
lyrics popover is open.
You can then press Up Arrow and Down Arrow to change the lyric line number
above the staff.
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Chorus lines
You can input chorus lines by pressing Up Arrow when the lyrics popover is open.
You can do this when inputting lyrics below the staff and above the staff.
A c, for “chorus lines”, is shown on the left-hand side of the popover.

The lyrics popover with an example entry for a chorus line

Lyric line translations
You can input lyric line translations by pressing Alt-Down Arrow when the lyrics
popover is open.
An asterisk (*) is shown beside the lyric line number to which you want to add a lyric
line translation on the left-hand side of the popover.

The lyrics popover with an example entry for a lyric line translation

RELATED LINKS
Inputting lyrics on page 246
Lyrics on page 690
Types of lyrics on page 692

Navigation during lyric input
You can move the lyrics popover to input new lyrics and edit existing lyrics without having to
close and reopen the lyrics popover.

Popover navigation Key command

Finish the current word and advance the
popover to the next note or chord.

Space

Finish the current syllable and advance the
popover to the next note or chord.

- (hyphen)

Advance the popover to the next note without
showing an extension line or hyphen.

Right Arrow

Move the cursor to the next/previous letter. If
the next/previous letter is in another lyric, the
popover advances to that lyric.

Right Arrow/Left Arrow

Move the popover forwards/backwards from
syllable to syllable within lines of lyrics.

Alt-Right Arrow/Alt-Left Arrow

Add spaces within a word or syllable, without
advancing the popover.

Shift-Alt-Space

Add a hyphen within a single word or syllable
without advancing the popover.

Alt-- (hyphen)

Add an elision slur within a word or syllable. _ (underscore)
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RELATED LINKS
Lyrics on page 690
Inputting lyrics on page 246

Inputting rehearsal marks
You can input rehearsal marks with the mouse and the keyboard. You can input rehearsal marks
during step input and later by adding them to existing music.

NOTE

These steps describe inputting with the default mouse input preference Create item at
selection.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an item at the rhythmic position where you want to input a rehearsal mark.
For example, a barline or a note.

NOTE

You can only input one rehearsal mark at a time, even if multiple items are selected.

2. Press Shift-A.
Alternatively, you can click Rehearsal Marks in the Notations toolbox.

RESULT
A rehearsal mark is input at the selected barline, or at the rhythmic position of the start of a note,
a rest, or an object.
The order of rehearsal marks is updated automatically, meaning you can input them in any
order, including before and between existing rehearsal marks.

RELATED LINKS
Rehearsal marks on page 805
Mouse input settings on page 143

Inputting markers/timecodes
You can input markers at specific positions in time. Depending on your project-wide settings,
timecodes can also be shown alongside markers.

PROCEDURE

1. In Write mode, move the playhead to the time position where you want to input a marker.

2. Press Shift-Alt-M.

RESULT
A marker is input at the position of the playhead. It shows the default text “Marker” and includes
a timecode reflecting that position if you have chosen to show timecodes in markers.

Write mode
Notations input 

249
Dorico 2.2.20



TIP

You can also input markers by clicking Add Marker in the Markers section of the Video panel.
This method allows you to enter a timecode directly into the Add Marker dialog, rather than
input a marker at the playhead position, so it can be useful if, for example, you already know the
timecodes for each marker.

Additionally, you can input markers in the Markers track in Play mode.

AFTER COMPLETING THIS TASK
You can change the text shown in the marker.

RELATED LINKS
Markers on page 814
Timecodes on page 819
Moving the playhead on page 431
Hiding/Showing timecodes in markers on page 821
Changing the text shown in markers on page 815
Markers track on page 427
Inputting markers in the Markers track on page 428

Markers section of the Video panel
In the Markers section of the Video panel in Write mode, you can input and edit markers and
timecodes, and also define markers as important.

● You can hide/show the Video panel by clicking Video in the Notations toolbox.

The Markers section of the Video panel contains a table of markers, divided into the following
columns:

Timecode
Shows the timecode of the marker. You can edit the timecode by double-clicking in
the field.

Text
Shows the text of the marker. You can edit the text by double-clicking in the field.

Imp.
Stands for “important”, allows you to define markers as important by activating their
checkbox in this column.
When markers are defined as important, their entry uses a bold font in the table and
they are considered when finding a suitable tempo in the Find Tempo dialog.

RELATED LINKS
Markers on page 814
Timecodes on page 819

Add Marker dialog

The Add Marker dialog allows you to input markers with custom text at specific timecodes.

● You can open the Add Marker dialog in Write mode by clicking Add Marker in the
Markers section of the Video panel.
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Add Marker dialog

The Add Marker dialog contains the following options:

Text
Allows you to enter custom text that is shown in the marker.

Timecode
Allows you to specify the timecode at which you want to input the marker.

Valid range
Displays the timecode range of the flow.

RELATED LINKS
Markers on page 814
Timecodes on page 819
Inputting markers/timecodes on page 249
Markers section of the Video panel on page 250

Find Tempo dialog
The Find Tempo dialog allows you to calculate tempos that best accommodate your important
markers, for example, by identifying which tempos cause markers to coincide as closely as
possible with strong beats.

● You can open the Find Tempo dialog in Write mode by clicking Find Tempo in the
Markers section of the Video panel.

NOTE

● The Find Tempo dialog only considers markers in a single flow. You can change which flow
by selecting an item in the flow whose tempo you want to determine and then opening the
dialog.

● The Find Tempo dialog is only available if you have input at least one marker in the flow
whose tempo you want to determine and defined at least one marker as important.
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Find Tempo dialog

The Find Tempo dialog contains the following options and sections:

Flow
Shows the name of the flow whose tempo you are determining. This field is read-
only.

Beat unit
Allows you to change the beat unit considered for the tempo. For example, if the
time signature for the flow is 6/8, you might want to change the beat unit to a dotted
quarter note.

Tempo range
Allows you to set the minimum/maximum tempos you want to consider.

Tempo increments
Allows you to filter the suggested tempos according to their precision.

● Integral only
Only whole number tempos, that is, tempos without decimal places, are
suggested.

● Allow increment by 0.25
Allows tempos with decimal places of .25, .5, and .75 to be suggested.

Tempos found
Contains a list of possible tempos that you can select to see how they affect the
position of your markers relative to beats. The list is updated automatically when you
change options such as Tempo range and Beat unit.
The list contains columns for the following information:

● BPM
Stands for “beats per minute”. Lists different possible tempos according to
their metronome mark value.

● IFO
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Stands for “important frames off”. Indicates the average number of frames by
which important markers miss significant beats, either before or after.

● NFO
Stands for “non-important frames off”. Indicates the average number of
frames by which non-important markers miss significant beats, either before
or after.

● AFO
Stands for “all frames off”. Indicates the average number of frames by which
all markers in the flow miss significant beats, either before or after.

Found tempos are listed in descending order of average frames off for important
markers.

Markers
Shows the impact that the tempo currently selected in the Tempos found list would
have on each marker in the flow in more detail.

● Timecode
Shows the exact timecode of each marker.

● Text
Shows the marker text of each marker to help you identify them.

● Imp.
Indicates whether a marker has been defined as important.

● Fr. Off
Stands for “frames off”. Shows the average number of frames by which each
marker misses being aligned to beats.

● Time Diff.
Stands for “time difference”. Shows the time difference between the position
of the marker and the position of the nearest beat, expressed in fractions of a
second.

● Not. Diff.
Stands for “notated difference”. Shows the notated difference between the
position of the marker and the position of the nearest beat, expressed in
fractions of a whole note.

Selected tempo
Displays the currently selected tempo for the flow.

Apply
Applies the selected tempo to the flow by inputting it as a tempo mark at the
beginning of the flow. Any other tempo marks in the flow are automatically deleted.

RELATED LINKS
Defining markers as important on page 818
Metronome marks on page 960

Input methods for repeats and tremolos
You can input repeats and tremolos, including repeat endings, repeat markers, and rhythm
slashes, with the keyboard by using the repeats popover, and with the mouse by using the
Repeat Structures panel.

Tremolos are included in the Repeat Structures panel because they indicate that notes are
repeated, either individually as single-note tremolos or in sequences as multi-note tremolos.
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Repeats popover
The following tables contain the entries for the repeats popover that you can use to input the
different tremolos, bar repeats, rhythm slash regions, repeat markers, and repeat endings
available.

You can open the repeats popover in Write mode in any of the following ways when either an
item is selected or the caret is active:

● Press Shift-R.

● Select an existing repeat marker, slash region, or bar repeat and press Return.

● Choose Write > Create Repeat.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Repeats popover with an example entry
Repeat Structures button in the Notations toolbox

Repeat endings

Part of repeat ending Popover entry

Whole repeat ending end or ending

Additional repeat ending segment add

Repeat markers

Type of repeat marker Popover entry

D.C. dc, D.C., da capo, and so on

D.C. al Fine dcalf, DC al Fine, D.C. al Fine, and so on

D.C. al Coda dcalc, DC al Coda, D.C. al Coda, and so on

D.S. ds, D.S., dal segno, and so on

D.S. al Fine dsalf, DS al Fine, D.S. al Fine, and so on

D.S. al Coda dsalc, DS al Coda, D.S. al Coda, and so on

to Coda toc, tc, to coda, To Coda, and so on

Segno s, seg, segno, and so on

Fine f, fin, fine, and so on

Coda c, co, coda, and so on
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The list of entries for repeat markers is not comprehensive, as the flexibility of the popover
means you can enter any reasonable version or abbreviation of the type of repeat marker you
want and the popover recognizes it in most cases.

Single-note tremolos

Type of tremolo Popover entry

One stroke /, \, or 1

Two strokes //, \\, or 2

Three strokes ///, \\\, or 3

Four strokes ////, \\\\, or 4

Z on stem (buzz roll) z or zonstem

Remove all tremolos 0 or clear

Multi-note tremolos

Type of tremolo Popover entry

One stroke /2, \2, or 12

Two strokes //2, \\2, or 22

Three strokes ///2, \\\2, or 32

Four strokes ////2, \\\\2, or 42

Z on stem (buzz roll) z or zonstem

Remove all tremolos 0 or clear

Slash regions

Slash region Popover entry

New slash region slash

Bar repeats

Type of bar repeat Popover entry

Repeat last bar % or %1

Repeat last 2 bars %2

Repeat last 4 bars %4
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Type of bar repeat Popover entry

Repeat last bar, group in 2 %1,2

Repeat last bar, group in 4 %1,4

Repeat last 2 bars, group in 2 %2,2

Repeat last 4 bars, group in 4 %4,4

RELATED LINKS
Inputting repeat markers with the popover on page 260
Inputting tremolos with the popover on page 261
Inputting slash regions on page 263
Inputting bar repeats on page 264
Repeat endings on page 823
Tremolos on page 999
Rhythm slashes on page 849
Bar repeats on page 839

Repeat Structures panel
The Repeat Structures panel contains all the different types of repeat notations, including repeat
endings, repeat markers, tremolos, rhythm slashes, and bar repeats.

Tremolos are included in the Repeat Structures panel because they indicate that notes are
repeated, either individually as single-note tremolos or in sequences as multi-note tremolos.

● You can hide/show the Repeat Structures panel by clicking Repeat Structures in the
Notations toolbox on the right of the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

The Repeat Structures panel contains the following sections:

Repeat Endings
Contains options that allow you to input new repeat endings and add additional
endings to existing repeat endings.

Repeat Jumps
Contains different types of repeat markers that instruct players to jump to a specific
point in the piece, such as “D.S. al Coda”.

Repeat Sections
Contains different sections used in conjunction with repeat jumps, such as “Coda”.

Tremolos
Contains different types of single-note and multi-note tremolos.

Rhythm Slashes
Allows you to input a region that displays rhythm slashes that are automatically
formatted to be compatible with the prevailing time signature.
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Bar Repeats
Allows you to input a region that indicates a set number of bars is repeated without
re-notating those bars.

Inputting repeat endings with the popover
You can input repeat endings using the repeats popover, both during step input and by adding
them to existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

TIP

During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow/Left Arrow.

● Select at least one item in each bar that you want to include in the first ending.

2. Press Shift-R to open the repeats popover.

3. Enter end or ending into the popover.

4. Press Return to close the popover.

RESULT
The repeat ending is input, with the first ending segment covering the bars in which you selected
notes, and a second ending segment created automatically in the following bar.
An end repeat barline is created at the end of the first ending if none exists already.

RELATED LINKS
Repeats popover on page 254
Repeat endings on page 823

Adding additional repeat endings with the popover

You can have more than two possible endings in each repeat ending structure by adding repeats
using the repeats popover. You can add additional endings both during step input and by adding
them to existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

TIP

During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow/Left Arrow.

● Select the bars that you want to include in the additional ending.

NOTE

Your selection must start from the first bar following the previous repeat ending
segment.

2. Press Shift-R to open the repeats popover.

3. Enter add into the popover.
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4. Press Return to close the popover.

5. Optional: Repeat these steps as many times as required for the number of additional
endings you want.

RESULT
A new repeat ending segment is added. The existing previous repeat ending segment now ends
with a closed line, with an end repeat barline created if necessary.

TIP

You can also add additional repeat ending segments by selecting the repeat ending and
changing the value for No. endings in the Repeat Endings group of the Properties panel.

However, No. endings only adds additional repeat ending segments that contain one bar, and
does not automatically input or reposition repeat barlines. You must input repeat barlines as
appropriate manually.

EXAMPLE

Default repeat ending structure with two endings Repeat ending structure with additional third ending

RELATED LINKS
Repeat endings on page 823
Repeats popover on page 254

Inputting repeat endings with the panel
You can input repeat endings using the Repeat Structures panel, both during step input and by
adding them to existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

TIP

During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow/Left Arrow.

● Select at least one item in each bar that you want to include in the first ending.

2. In the Notations toolbox, click Repeat Structures to show the Repeat Structures panel.

3. In the Repeat Structures panel, click Create Repeat Ending in the Repeat Endings section.
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RESULT
The repeat ending is input, with the first ending segment covering the bars in which you selected
notes, and a second ending segment created automatically in the following bar.
An end repeat barline is created at the end of the first ending if none exists already.

RELATED LINKS
Repeat endings on page 823

Adding additional repeat endings with the panel

You can have more than two possible endings in each repeat ending structure by adding repeats
using the Repeat Structures panel. You can add additional endings both during step input and by
adding them to existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

TIP

During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow/Left Arrow.

● Select the bars that you want to include in the additional ending.

NOTE

Your selection must start from the first bar following the previous repeat ending
segment.

2. In the Notations toolbox, click Repeat Structures to show the Repeat Structures panel.

3. In the Repeat Structures panel, click Add Section To Repeat Ending in the Repeat
Endings section.

NOTE

If increasing the number of endings makes the repeat ending collide with any part of
another repeat ending, the other repeat ending is deleted. However, its repeat barlines are
not deleted.

4. Optional: Repeat these steps as many times as required for the number of additional
endings you want.

RESULT
A new repeat ending segment is added. The existing previous repeat ending segment now ends
with a closed line, with an end repeat barline created if necessary.

TIP

You can also add additional repeat ending segments by selecting the repeat ending and
changing the value for No. endings in the Repeat Endings group of the Properties panel.
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However, No. endings only adds additional repeat ending segments that contain one bar, and
does not automatically input or reposition repeat barlines. You must input repeat barlines as
appropriate manually.

EXAMPLE

Default repeat ending structure with two endings Repeat ending structure with additional third ending

RELATED LINKS
Repeat endings on page 823

Inputting repeat markers with the popover
You can input repeat markers, including repeat jumps and repeat sections, using the repeats
popover, both during step input and by adding them to existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

TIP

During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow/Left Arrow.

● Select an item at the rhythmic position where you want to input a repeat marker.
For repeat jumps, we recommend that you select the barline with which you want
the end of the jump instruction to align. For repeat sections, we recommend that
you select the barline with which you want the start of the section marker to align.

2. Press Shift-R to open the repeats popover.

3. Enter the appropriate entry for the type of repeat marker you want into the popover.
For example, enter coda to input a coda section or enter $ to input a segno.

4. Press Return to close the popover.

RESULT
During step input, repeat markers are input at the caret position. Coda sections are automatically
formatted so that there is a gap between the coda and the preceding material.
When adding repeat markers to existing music, repeat markers are input at the rhythmic
position of the selected note or item.
Repeat markers that indicate the end of a section, such as Fine and D.C. al Coda, are right-aligned
with the selected rhythmic position.

RELATED LINKS
Repeats popover on page 254
Repeat markers on page 830
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Inputting repeat markers with the panel
You can input repeat markers using the Repeat Structures panel, both during step input and by
adding them to existing music.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

TIP

During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow/Left Arrow.

● Select an item at the rhythmic position where you want to input a repeat marker.
For repeat jumps, we recommend that you select the barline with which you want
the end of the jump instruction to align. For repeat sections, we recommend that
you select the barline with which you want the start of the section marker to align.

2. In the Notations toolbox, click Repeat Structures to show the Repeat Structures panel.

3. In the Repeat Structures panel, click the repeat marker you want to input in any of the
following sections:

● Repeat Jumps

● Repeat Sections

RESULT
During step input, repeat markers are input at the caret position. Coda sections are automatically
formatted so that there is a gap between the coda and the preceding material.
When adding repeat markers to existing music, repeat markers are input at the rhythmic
position of the selected note or item.
Repeat markers that indicate the end of a section, such as Fine and D.C. al Coda, are right-aligned
with the selected rhythmic position.

RELATED LINKS
Repeat markers on page 830

Inputting tremolos with the popover
You can input both single-note and multi-note tremolos using the repeats popover, both during
step input and by adding them to existing notes.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

TIP

During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow/Left Arrow.

● Select the notes to which you want to add tremolos.
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NOTE

If you want to input multi-note tremolos, you must select at least two notes, which
can also be tuplets.

2. Press Shift-R to open the repeats popover.

3. Enter the appropriate entry for the type of tremolo you want into the popover.
For example, to input a three-stroke multi-note tremolo, enter ///2.

4. Press Return to close the popover.

5. Optional: Repeat steps 2 to 3 to input other tremolos on the selected notes.
For example, if you want notes to have both single-stem and multi-stem tremolos.

RESULT
Single-note tremolos are input on the selected notes with the number of tremolo strokes
specified.
Multi-note tremolos with the number of tremolo strokes specified are input between selected
individual notes and the notes immediately after them, or between selected pairs of notes.
When tuplets are selected, multi-note tremolos are input across the selected tuplets, with the
tremolo strokes positioned in the center of all notes in the tuplet. The tuplet bracket is hidden,
and a signpost is shown at the start of each tuplet indicating its ratio.

NOTE

The appearance of stems in multi-note half note tremolos depends on your setting on the
Tremolos page in Engrave > Engraving Options.

EXAMPLE

Multi-note tremolos with three tremolo strokes across tuplets

RELATED LINKS
Repeats popover on page 254
Tremolos on page 999

Inputting tremolos with the panel
You can input both single-note and multi-note tremolos using the Repeat Structures panel, both
during step input and by adding them to existing notes.

Tremolos are included in the Repeat Structures panel because they indicate that notes are
repeated, either individually as single-note tremolos or in sequences as multi-note tremolos.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

TIP

During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow/Left Arrow.
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● Select the notes to which you want to add tremolos.

NOTE

If you want to input multi-note tremolos, you must select at least two notes, which
can also be tuplets.

2. In the Notations toolbox, click Repeat Structures to show the Repeat Structures panel.

3. In the Repeat Structures panel, click the button with the number of single-note or multi-
note tremolo strokes you want in the Tremolos section.
For example, click Two Strokes Single-note Tremolo to input single-note tremolos with
two strokes or click Three Strokes Multi-note Tremolo to input multi-note tremolos with
three strokes.

Two Strokes Single-note Tremolo button Three Strokes Multi-note Tremolo button

RESULT
Single-note tremolos are input on the selected notes with the number of tremolo strokes
specified.
Multi-note tremolos with the number of tremolo strokes specified are input between selected
individual notes and the notes immediately after them, or between selected pairs of notes.
When tuplets are selected, multi-note tremolos are input across the selected tuplets, with the
tremolo strokes positioned in the center of all notes in the tuplet. The tuplet bracket is hidden,
and a signpost is shown at the start of each tuplet indicating its ratio.

NOTE

The appearance of stems in multi-note half note tremolos depends on your setting on the
Tremolos page in Engrave > Engraving Options.

EXAMPLE

Multi-note tremolos with three tremolo strokes across tuplets

RELATED LINKS
Tremolos on page 999
Deleting tremolos on page 1002
Changing the appearance of multi-note half note tremolos project-wide on page 1004

Inputting slash regions
You can input slash regions using the repeats popover.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.
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● Select the region in which you want to show rhythm slashes.

2. Press Shift-R to open the repeats popover.

3. Enter slash into the popover.

4. Press Return to close the popover.

RESULT
During step input, slash regions are input spanning the duration of the selected note or item,
which is usually the last input note. When adding slash regions to existing music, they span the
selected duration.
Slash regions are automatically formatted as appropriate for the meter. If you later change the
time signature, slash regions retain their duration but the appearance of slashes within them
automatically updates.

TIP

You can also input slash regions by clicking Create Slash Region in the Rhythm Slashes group
of the Repeat Structures panel.

RELATED LINKS
Repeats popover on page 254
Rhythm slashes on page 849
Slash regions on page 849
Slash voices on page 1044

Inputting bar repeats
You can input bar repeat regions when at least one bar before the region contains notes.

PROCEDURE

1. In Write mode, select the bars you want to show as a bar repeat.

NOTE

● You cannot input bar repeat regions in the first bar of a flow.

● You can only input bar repeat regions on one staff at a time.

2. Press Shift-R to open the repeats popover.

3. Enter the appropriate entry for the type of bar repeat region you want into the popover.
For example, enter %2,2 to repeat the previous two bars, grouped in two.

4. Press Return to close the popover.

RESULT
A region of the selected duration is input, in which the specified type of bar repeat symbol is
shown in the staff at the intervals specified.

NOTE

● You can also input bar repeat regions during step input; however, this inputs bar repeat
regions from the bar containing the currently selected note. As bar repeats are mostly
shown in empty bars, this is likely to produce unintended results.

● You can also input bar repeat regions by clicking Create Bar Repeat Region in the Bar
Repeats group of the Repeat Structures panel. However, this only inputs a bar repeat
region containing single-bar repeats.
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RELATED LINKS
Repeats popover on page 254
Bar repeats on page 839

Inputting slurs
You can input slurs, both during step input and by adding them to existing notes. You can also
add slurs to existing notes in multiple staves at the same time.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select the notes to which you want to add slurs.

TIP

● You can select notes in multiple staves and input slurs on them at the same
time.

● If you only select a single note, the slur connects that note to the next note on
the staff.

2. Press S.

TIP

Alternatively, click Slur in the Notes panel, and then click and drag to input a slur and
extend it to your preferred length.

3. Optional: During step input, input the notes you want.
The slur extends automatically, even if there are rests between the notes you input.

4. Optional: During step input, press Shift-S to end the slur on the currently selected note.

RESULT
During step input, a slur begins from the currently selected note, not from the caret position. The
slur extends automatically as you input notes, and ends on the currently selected note.
When adding slurs to existing notes, the selected notes are connected by slurs. For example, if
you select two notes in one staff and two notes in another staff, two slurs are input. They connect
the notes on each selected staff.

RELATED LINKS
Slurs on page 868
Inputting notes on page 149

Inputting text
You can input text at specific rhythmic positions in the score. You can input text for single staves
or input system text that applies to all staves.

NOTE

If you want to insert text that is independent of rhythmic positions and attached to a particular
page, you can use text frames.

PROCEDURE

1. In Write mode, do one of the following:
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● Start note input.

● Select a note or item at the position where you want to input text.

2. Open the text editor in any of the following ways:

● To input staff text, press Shift-X or click Text in the Notations toolbox.

● To input staff text with a specific paragraph style, choose Write > Create Text >
[Paragraph style].

● To input system text, press Shift-Alt-X.

● To input system text with a specific paragraph style, choose Write > Create System
Text > [Paragraph style].

3. Enter the text you want.

4. Optional: Press Return to insert a line break.

5. Optional: Format the text using the text editor options.

6. Press Esc or Ctrl/Cmd-Return to close the text editor.

RESULT
During step input, the text you entered into the text editor is input at the caret position. It is
automatically placed above the staves to which it applies, using the default paragraph style, and
follows your project-wide settings for the vertical position of text.
When adding text to existing music, it is input at the position of the earliest selected item.

NOTE

● In Dorico Pro, system text is categorized as a system object. Therefore, system text follows
your per-layout settings for the visibility and positioning of system objects.

● You can change the default position of all text items outside of the staff and other items,
and whether text items avoid collisions by default, on the Text page in Engrave >
Engraving Options.

● You can assign key commands for inputting text with specific paragraph styles, for both
Create Text and Create System Text, on the Key Commands page in Preferences.

RELATED LINKS
Text frames on page 331
Changing the placement of text objects relative to the staff on page 374
System objects on page 925
Changing the positions of system objects on page 926

Text editor options in Write mode
The text editor allows you to add and format text. In Write mode, it opens when you add or
change staff text or system text.

Text editor in Write mode

The text editor provides the following options:
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1 Paragraph Style
Allows you to change the paragraph style applied to the whole paragraph, which can
change the appearance, formatting, and alignment of the text.
Staff text and system text are always treated as single paragraphs.

2 Character Style
Allows you to change the appearance of selected text within paragraphs. This overrides
the paragraph style applied to the corresponding paragraph.

3 Font
Allows you to change the font family of selected text.

4 Font Style
Allows you to change the font style of selected text.

5 Font Size
Allows you to change the size of selected text.

6 Font Stretch
Allows you to make selected text wider or narrower.

7 Baseline Shift
Allows you to shift the baseline of selected text gradually up or down.

8 Letter Spacing
Allows you to increase/decrease the space between the characters of selected text.

9 Word Spacing
Allows you to increase/decrease the space between the words of selected text.

10 Alignment
Allows you to choose the alignment of selected text relative to the rhythmic position of the
text in the score. For text in a text frame, the text is aligned along the left margin of a text
frame.
You can choose from the following alignments:

● Align Left

● Align Center

● Align Right

11 Line Types
Allows you to show any of the following types of lines, in any combination, on selected
text:

● Underline

● Overline

● Strikethrough

12 Script Types
Allows you to position selected text in one of the following positions relative to the text on
the baseline:

● Superscript

● Subscript

13 Foreground Color
Allows you to change the color of selected text.

14 Background Color
Allows you to change the background color of selected text.
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RELATED LINKS
Entering text in text frames on page 337
Paragraph Styles dialog on page 366
Character Styles dialog on page 369

Editing text
You can edit text objects added to staves or text displayed in text frames at any time, including
changing the text and changing its formatting.

PROCEDURE

1. Double-click the text you want to edit to open the text editor.

TIP

You can also select text/system text objects and press Return.

2. Optional: Change the text in the text frame/object.

3. Optional: Use the text editor options to format the text.

4. Press Esc or Ctrl/Cmd-Return to close the text editor.

RELATED LINKS
Text objects vs. text in text frames on page 371

Inputting cues
You can input cues by using the cues popover.

PROCEDURE

1. On the staff where you want to input a cue, select multiple notes/rests spanning the
duration you want the cue to last.

2. Press Shift-U to open the cues popover.

3. Start entering the name of the instrument whose music you want to show in the cue.
The candidate instrument menu appears below the popover and shows possible source
instruments.

4. Select the instrument whose music you want to show in the cue from the candidate
instrument menu.

NOTE

● If you do not enter the name of an instrument that exists in your project, no cue is
created.

● If you enter the full name of an instrument into the popover yourself, you must
press Return twice to input a cue using that instrument.

● If multiple instruments of the same type exist in your project, music from the first
player is input as the cue if you do not specify the number you want. For example, if
you have Violin I and Violin II in your project and enter violin into the cues popover,
music from the Violin I staff is shown in the cue.

RESULT
A cue is input on the selected staff, showing the music of the instrument selected in the cues
popover.
If you are inputting cues in a full score layout in page view, the cue appears as a signpost by
default, showing the name of the source instrument. This is because cues are hidden in full score
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layouts and shown in part layouts by default, but you can choose to hide/show cues in any
layout.

RELATED LINKS
Cues on page 595
Hiding/Showing cues in layouts on page 606
Lengthening/Shortening cues on page 600
Moving cues on page 599
Switching between layouts on page 46

Cues popover
The cues popover allows you to input cues that refer to other instruments in the project, using
the names of instruments as they are set in your project and language.

When you start entering the name of an instrument that exists in your project into the cues
popover, a candidate menu appears that shows source instruments that you can select to show
in the cue, excluding the destination instrument.

The cues popover with an example entry showing the menu of candidate instruments.

Each staff of grand staff and multi-staff instruments is listed separately, for example, Piano (a)
and Piano (b).

Each unpitched percussion instrument is listed separately. If you have a drum set in your project,
each individual instrument in the drum set appears as a candidate for cueing. For example, you
can show just the kick drum in a cue.

NOTE

● You cannot use entire percussion kits in cues, you must select an individual instrument
from the kit.

● If you directly input a cue at the same position as an existing cue, the new cue overrides
the existing cue, which is deleted. However, you can have multiple cues at the same
rhythmic position if you create them in separate bars and move them or lengthen/shorten
them later.

Cues panel
The Cues panel allows you to input cues and find suitable places to input cues.

● You can hide/show the Cues panel by clicking Cues in the Notations toolbox on the right of
the window in Write mode.

You can also hide/show the panel whose icon is currently selected in the Notations toolbox
by pressing Ctrl/Cmd-9 or clicking the disclosure arrow on the right of the window.

The Cues panel contains the following sections:

Create Cue
Contains the Create Cue button which you can click to open the cues popover with
the mouse.
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Suggest Cues
Allows you to generate suggested locations for cues based on how long players have
been resting.

RELATED LINKS
Cues on page 595

Cue suggestions
Cue suggestions are places in the current flow that Dorico Pro has identified as useful locations
to input cues, based on a set span of time during which players have not played.

The Suggest Cues section of the Cues panel is divided into the following sections that help you
find useful places to input cues:

Resting for
Allows you to specify the resting period for players after which you want to input
cues.
The resting period is specified in absolute time rather than in bars or beats. This is
because meters and tempos can change many times throughout a flow, and music
can be partially or completely meterless, whereas one second always has the same
duration. Dorico Pro calculates time using metronome marks in the project.
Specifying an absolute time ensures consistency in the approach to finding places
where cues might be appropriate.

Rehearsal marks
Allows you to consider/ignore rehearsal marks when determining the resting period.
Rehearsal marks often coincide with new sections or other landmarks in the music,
which can be obvious to players without needing extra cues. By default, rehearsal
marks are ignored as they do not always act as signposts for the musical structure.

Cues
Allows you to consider/ignore cues that already exist between notes played by the
destination player when determining the resting period.
A cue that occurs immediately before an entry in the destination instrument is
always ignored and is never included as a suggested location, even if you choose to
consider cues.
However, orientation cues which serve to help the player keep their place during
extended rests, but do not immediately precede an entry, reset the timer if you
choose to consider cues.

Update
Allows you to recalculate cue suggestions based on your Resting for duration and
inclusion choices for rehearsal marks and cues after you have changed values.
The names of the flow and layout that were active when you last updated the list of
cue suggestions are shown below the Update button. This allows you to see at a
glance to which flow and layout the suggestions shown in the table apply.

Cue suggestions table
Suggested cues are presented in a table, which contains the following columns:

● Instr.: The destination instrument that has been resting for more than your
minimum specified duration. Click to show instruments with suggested cues in
the order in which they appear in the score.

● Bar: The bar containing the first entry of the destination instrument after its
rest period. Click to show entries in ascending order, earlier bars down to later
bars.
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● Sec.: The length of time in seconds the destination instrument has been
resting before the entry shown in the Bar column. Click to show the length of
resting period in descending order, longest period down to shortest period.

Click rows in the cue suggestions table to navigate directly to that location. By
default, an area with an equivalent rhythmic duration of 5 to 10 seconds prior to the
entry in the destination instrument is highlighted. The highlighted area is not a
specific recommendation for cue length, but it can be a good indication depending
on the musical context.
If you create a cue at a location suggested in the cue suggestions table, that
suggestion is automatically removed from the list.
You can click Ignore in the action bar at the bottom of the table to hide suggestions
where you do not think a cue is appropriate.

NOTE

If you later click Update and regenerate the list, hidden suggestions can reappear.

Highlight suggestions
Highlighted areas before entries in source instruments are shown when Highlight
suggestions is activated, and are hidden when it is deactivated.

Playing instruments list
Contains the instruments that are playing in the 5 to 10 seconds prior to the entry in
the destination instrument currently selected in the cue suggestions table, to help
you determine which instrument to use as the source instrument of cues.

RELATED LINKS
Cues on page 595

Inputting cues using cue suggestions
You can use the Suggest Cues section of the Cues panel in Write mode to find suitable places to
input cues. You can then input cues using the cues popover.

PROCEDURE

1. In Write mode, open the layout in the music area in which you want to find suitable
locations for cues.
For example, suitable locations for cues are suggested for all instruments when the full
score layout is open in the music area, but only suitable locations for individual
instruments are suggested when a single part layout is open.

2. In the Notations toolbox, click Cues to show the Cues panel.

3. In the Suggest Cues section of the Cues panel, specify the resting period after which you
want to input cues by changing the value for Resting for.

4. Choose one of the following options for Rehearsal marks:

● Consider

● Ignore

5. Choose one of the following options for Cues:

● Consider

● Ignore

6. Click Update.
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7. Optional: To check the context of the cue suggestion, click a row in the cue suggestions
table to navigate directly to that position in the layout.
Cue suggestions are highlighted for the equivalent rhythmic duration of 5-10 seconds. You
can choose not to see highlighted areas by deactivating Highlight suggestions.

8. On the staff where you want to input a cue, select multiple notes/rests spanning the
duration you want the cue to last.

9. Press Shift-U to open the cues popover.

10. In the popover, start entering the name of the instrument whose music you want to show
in the cue.
The candidate instrument menu appears below the popover. You can use the Playing
instruments list in the Cues panel to help select an appropriate source instrument for
your cue.

11. Select the instrument whose music you want to show in the cue from the candidate
instrument menu.

NOTE

● If you do not enter the name of an instrument that exists in your project, no cue is
created.

● If you enter the full name of an instrument into the popover yourself, you must
press Return twice to input a cue using that instrument.

● If multiple instruments of the same type exist in your project, music from the first
player is input as the cue if you do not specify the number you want. For example, if
you have Violin I and Violin II in your project and enter violin into the cues popover,
music from the Violin I staff is shown in the cue.

RESULT
A cue is input in the selected staff, showing the music of the instrument selected in the cues
popover.
If you are inputting cues in a full score layout in page view, the cue appears as a signpost by
default, showing the name of the source instrument. This is because cues are hidden in full score
layouts and shown in part layouts by default, but you can choose to hide/show cues in any
layout.

RELATED LINKS
Cues on page 595
Switching between layouts on page 46

Editing and selecting
In Dorico Pro, there are multiple different ways you can select and edit the items in your project,
from selecting items individually to making large selections covering multiple staves.

RELATED LINKS
Filters on page 278
Selection tools on page 42

Write mode
Editing and selecting 

272
Dorico 2.2.20



Selecting/Deselecting notes and items individually
You can select/deselect existing notes and other notation items individually in the music area, for
example, if you want to add articulations to a selection of notes or delete a short passage of
music.

NOTE

If you want to select a large number of notes/items, we recommend that you use one of the
larger selection methods.

PROCEDURE

1. Select individual notes/items in the music area in any of the following ways:

● Ctrl/Cmd-click individual notes/items.

● Shift-click adjacent notes/items.

● Click a single note/item.

● Make a marquee selection around multiple notes/items.

2. Deselect all currently selected items in any of the following ways:

● Press Ctrl/Cmd-D.

● Click outside of the staves within the music area.

RELATED LINKS
Selecting multiple items using marquee selections on page 43
Playing/Muting notes during note input/selection on page 278

Selecting more items of the same type
You can incrementally extend your current selection to more items of the same type and notes in
the same voices, which is particularly helpful if you want to select multiple different items at
once, such as dynamics and lyrics.

PROCEDURE

1. Select the notes and items you want to select more of. You can do this in Write mode and
Engrave mode.

TIP

You can select notes and items on multiple staves and in specific voices, for example, if you
only want to select notes in up-stem voices on four staves.

2. Press Ctrl/Cmd-Shift-A to expand your selection.

3. Optional: Continue pressing Ctrl/Cmd-Shift-A to extend your selection further.

RESULT
More of the same types of items and notes in the same voices as your original selection are
selected, with the range of selected items expanding each time you press the key command:
firstly to the boundaries of the bar, secondly to the boundaries of the system, and finally to the
rest of the flow. If there are no other items available in the bar, Dorico Pro automatically
advances to the second expansion. In galley view, the second expansion is to the entire flow
directly as there is only a single system in galley view.
For items that span multiple bars and systems, they are selected in the earliest bar/system in
which they exist.
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NOTE

Dorico Pro selects the following items differently if you select only a single one of them:

● Lyrics: The selection expands only to other lyrics with the same line number, placement,
and line type as the originally selected lyric.

● Dynamics: The first expansion is to all other dynamics in the same group and on the same
staves as the original selection, with further expansions selecting other dynamics in other
groups.

● Playing techniques: The selection expands only to playing techniques of the same
category, such as Strings or Choral. Additionally, if you select either an up bow or down
bow playing technique, the selection expands only to other up bow and down bow playing
techniques. It does not select any other playing techniques.

Large selections
You can make large selections, including selecting the contents of whole staves or the whole
flow.

Select everything in a specific area
You can use the Marquee Tool to specify an area in which you want to select
everything.

Select everything in the whole flow

● Press Ctrl/Cmd-A.

● Choose Edit > Select All.

Select everything on a single staff

● Select the first note on the staff, hold down Shift, and select the last note on
the staff.

● Select the first note on the staff and choose Edit > Select To End Of System or
Edit > Select To End Of Flow.

● Make a marquee selection that includes the staff you want to select.

Select everything on multiple adjacent staves

● Select one whole staff at the top/bottom of the range of staves you want to
select and press Shift-Up Arrow or Shift-Down Arrow until all the staves you
want are selected.

● Select one whole staff at the top/bottom of the range of staves you want to
select and Shift-click the staff at the other end of the range of staves you want
to select.

● Make a marquee selection that includes the staves you want to select.

Select more of the currently selected types of items
You can use Edit > Select More (Ctrl/Cmd-Shift-A) to expand your current selection
horizontally and incrementally to other items of the same types and in the selected
voices and staves in both Write mode and Engrave mode. For items that span
multiple bars and systems, they are selected in the earliest bar/system in which they
exist.

1 The first expansion is to the boundaries of the current bar, both to the left and
right. If there is nothing to select within the bar, such as if you selected a
whole note in a 4/4 bar, Dorico Pro automatically advances to the second
expansion.
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2 The second expansion in page view is to the boundaries of the current system,
both to the left and right. In galley view, the second expansion is to the rest of
the flow, as there is only a single system in galley view.

3 In page view, the third expansion is to the entire flow.

Select everything in the system within a range of beats/bars
You can use the system track to select a region of beats/bars and then select
everything on all staves in the system within that region.

TIP

If you want to select only a certain type of item, such as lyrics or dynamics, you can then use the
corresponding filters.

RELATED LINKS
Filters on page 278
Selecting/Deselecting notes and items individually on page 273
Selecting multiple items using marquee selections on page 43
Selecting more items of the same type on page 273

System track
The system track is a translucent line above the top of each system in Write mode. It allows you
to add and delete bars and beats, and to select everything on all staves in the system.

The system track above a staff, showing bars The system track above a staff, showing beat units
reflecting the current rhythmic grid resolution

The color of the system track changes depending on how you are interacting with it.

● When you hover the mouse over it, it becomes opaque.

● When you select a region in the system track, it appears highlighted.

The system track when the mouse pointer hovers
over it

The system track with a region selected

When you have selected a region in the system track, the following options are available:
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1 Delete
Allows you to delete the selected region.

NOTE

When you hover over Delete, the highlight color of the selected region changes.

2 System Track Select
Allows you to select all items on all staves in the system across the selected region.

3 Add
Allows you to add bars or beats of the same duration as the selection in the system track.
The extra time is inserted immediately after the end of the selection.

NOTE

Selections on the system track are cleared whenever you make any other kind of selection, or
when you switch layouts. However, selections on the system track are retained when switching
between page and galley view.

RELATED LINKS
Inputting bars/beats with the system track on page 205
Deleting bars/beats with the system track on page 505

Hiding/Showing the system track
The system track is shown by default in new projects, but you can hide/show it at any time.

PROCEDURE

● Hide/Show the system track in any of the following ways:

● Press Alt-T.

● Choose View > System Track.

RESULT
The system track is shown when a tick appears beside System Track in the View menu, and
hidden when no tick appears.

TIP

If you do not want the system track to be shown in all future projects by default, deactivate Show
system track in new projects in the View section of the General page in Preferences.

RELATED LINKS
Preferences dialog on page 51

Selecting bars with the system track
The system track allows you to select all staves in the system across the selected bars.

PREREQUISITE
The system track is shown.

PROCEDURE

1. Click a bar in the system track.

2. Optional: Select multiple bars to the right/left of the first selected bar in any of the
following ways:
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● Shift-click bars to the right/left along the system track.

● Click and drag to the right/left along the system track.

3. Click System Track Select in the system track. It can also appear above the system track if
your selection is narrow.

System Track Select button in the system track The System Track Select button appears filled in
when you hover over it

RESULT
Everything on all staves in the selected bars is selected and highlighted, including notations and
signposts.

NOTE

If you then delete your selection, any signposts included are also deleted. This can affect the
page layout, for example, by removing ossia staves whose signposts were included in the
selection.

RELATED LINKS
Hiding/Showing the system track on page 276
Deleting the contents of bars on page 506
Deleting bars/beats with the system track on page 505

Selecting beats with the system track
The system track allows you to select all staves in the system across the selected beats.

PREREQUISITE
The system track is shown.

PROCEDURE

1. Press and hold Alt.
Grid lines that match the current rhythmic grid resolution appear in the system track.

2. Without releasing Alt, click and drag to the right/left along the system track.

NOTE

You cannot Shift-click when selecting beats.

3. Click System Track Select in the system track. It can also appear above the system track if
your selection is narrow.

System Track Select button in the system track The System Track Select button appears filled in
when you hover over it

RESULT
Everything on all staves in the selected beats is selected and highlighted, including notations and
signposts.
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NOTE

If you then delete your selection, any signposts included are also deleted. This can affect the
page layout, for example, by removing ossia staves whose signposts were included in the
selection.

RELATED LINKS
Hiding/Showing the system track on page 276
Deleting the contents of bars on page 506
Deleting bars/beats with the system track on page 505

Filters
Filters in Dorico Pro allow you to select only a specific type of item from a larger selection. Dorico
Pro includes a filter for every notation item.

● You can find the available filters by choosing Edit > Filter > [Item] > [Item type].
You can also choose filters from the context menu.

All significant notation items have their own filter, for example, arpeggio signs, chord symbols,
key signatures, and playing techniques. You can also filter for note spacing changes.

The following items have multiple filters because they have multiple types:

Notes
Allows you to filter notes, grace notes, and chords. You can also filter notes
according to their accidental, pitch, and position in chords.

Voices
Allows you to filter voices according to their stem-direction. You can also filter slash
voices.

Dynamics
Allows you to filter all dynamics, or just gradual or immediate dynamics.

Tempos
Allows you to filter all tempo marks, or just absolute, relative, or gradual tempo
changes.

Lyrics
Allows you to filter all lyrics, or just lyrics with a specific line number, type, or staff-
relative placement.

NOTE

There is no filter for barlines. You also cannot filter fingerings, beams, articulations, or tremolos,
as they are considered part of the notes to which they apply.

RELATED LINKS
Filters for lyrics on page 691

Playing/Muting notes during note input/selection
You can change your default setting for whether notes are played back as you input them or not.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.
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2. Click Note Input and Editing in the page list.

3. In the Note Input section, activate/deactivate Play notes during note input and
selection in the Auditioning subsection.

4. Click Apply, then Close.

RESULT
When the option is activated, notes play back as you input them during note input and when you
select them. When it is deactivated, notes do not play back.

RELATED LINKS
Inputting notes on page 149
Selecting/Deselecting notes and items individually on page 273

Playing all/individual notes in chords during note input/selection
You can change your default setting for whether all notes in chords are played when you select
any note in the chord or whether only the selected notes are played.

PREREQUISITE
Notes are played during note input/selection.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click Note Input and Editing in the page list.

3. In the Note Input section, activate/deactivate Play all notes in chord when any is
selected in the Auditioning subsection.

4. Click Apply, then Close.

RESULT
When the option is activated, all notes in chords are played when any note in the chord is
selected. When it is deactivated, only the selected notes are played.

Disabling automatic linking of dynamics and slurs when pasting
By default, slurs and dynamics are automatically linked when you copy them to other staves at
the same rhythmic position. You can disable this behavior so slurs are not linked by default.

PROCEDURE

1. Press Ctrl/Cmd-, (comma) to open Preferences.

2. Click Note Input and Editing in the page list.

3. In the Editing section, deactivate Link dynamics and slurs to existing items when
pasting.

4. Click Apply, then Close.

RELATED LINKS
Dynamics linked across multiple staves on page 633
Slurs linked across multiple staves on page 876
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Changing existing items
You can change all items that have an associated popover, rather than deleting them and
inputting new ones. For example, if you want to change an 8va octave line into a 15va octave line
or change a short fermata into a long fermata.

PROCEDURE

1. Select the item or the signpost of the item you want to change.

2. Press Return to open the popover for that item.

3. Change the existing entry in the popover.
For chord symbols, you can also play the new chord on your MIDI keyboard.

4. Press Return to close the popover.

RESULT
The selected item is changed according to the new entry in the popover. This changes different
parameters for different items, such as the duration of a hold or pause or the volume of a
dynamic.

NOTE

● If you change a fermata to a breath mark, only the fermata on the top staff is changed to a
breath mark. If you change a caesura to a breath mark, a breath mark is input on the top
staff at the end of the bar to which the caesura is attached. However, the existing caesura
also remains on all staves.

● If you open the playing techniques popover in this way, Dorico Pro inputs your new entry
as a separate playing technique and does not delete the previous one.

● If you change an immediate dynamic to a combined dynamic, such as  to , or vice versa,
Dorico Pro inputs your new entry as a separate dynamic and does not delete the previous
one.

RELATED LINKS
Changing the text of existing lyrics on page 695

Changing the staff-relative placement of items
You can flip any item that can be placed both above/below the staff to change their staff-relative
placement, for example, if you want to change the stem direction of notes quickly.

PROCEDURE

1. Select the items you want to flip. You can do this in Write mode and Engrave mode.

NOTE

● You cannot flip items during note input.

● If you want to select parts of items, such as a single notehead within a tie chain or
articulations, you must be in Engrave mode.

2. Press F.

RESULT
The staff-relative placement of the selected items is changed by setting Placement or Direction
properties appropriately in the corresponding groups of the Properties panel.
Deactivating these properties resets items to their default placement.
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NOTE

If you flipped multiple multi-segment slurs or tuplet brackets with different hook directions at the
same time, all selected items are set to either above or below the staff, unless they all originally
had compatible directions set.

Resetting the appearance of items
You can reset all changes you have made to the appearance of individual items, which returns
them to the default settings. Properties relating to the appearance of items include those that
change their style, type, and some additions, such as poco a poco text for dynamics.

PROCEDURE

1. Select the items whose appearance you want to reset. You can do this in Write mode and
Engrave mode.

2. Choose Edit > Reset Appearance.

RESULT
All properties that affect the appearance of the selected items are reset to their default settings.
For properties that are layout-specific and frame chain-specific, this only resets the appearance
of the selected items in the current layout and frame chain.

RELATED LINKS
Engraving Options dialog on page 299
Notation Options dialog on page 139
Copying property settings to other layouts on page 363

Resetting the position of items
You can reset the position of individual items you have moved graphically, which returns them to
their default position. Properties relating to the position of items include horizontal and vertical
offsets, beat-relative position, and staff-relative placement.

PROCEDURE

1. Select the items whose position you want to reset. You can do this in Write mode and
Engrave mode.

2. Choose Edit > Reset Position.

RESULT
All properties that affect the position of the selected items are reset to their default settings. For
properties that are layout-specific and frame chain-specific, this only resets the position of the
selected items in the current layout and frame chain.

Signposts
In Dorico Pro, signposts indicate the positions of important items or changes that cannot be seen
in the score, such as key signatures with no accidentals, hidden items, and note spacing changes.

Signposts have different colors depending on the item they mark because many items can show
signposts, such as hidden bar numbers and time signatures. They are selectable, meaning you
can use signposts to change properties of hidden/invisible items, for example, by selecting
system break signposts in order to change the staff size from that position.
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Signposts include a text summary of the hidden/invisible item to help you identify it. For
example, time signature signposts include the time signature, expressed as a fraction, and its
beat subdivision.

The signpost of a hidden time signature

You can hide/show signposts for the following items:

● Accidentals

● Chord symbols

● Bracket and barline changes

● Clefs

● Cues

● Dynamics

● Frame breaks

● Key signatures

● Note spacing changes input using the Note Spacing Change dialog

● Pedal lines

● System breaks

● Tempo marks

● Text, both system and staff

● Percussion legends

● Time signatures

● Tuplets

When multiple signposts can exist at a single rhythmic position, they stack vertically so that they
do not overlap and remain legible.

Multiple signposts for different items at the same rhythmic position

NOTE

By default, signposts are not printed or included when you export graphics files.

RELATED LINKS
Annotations on page 485
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Hiding/Showing signposts
You can hide/show all signposts or only hide/show signposts for specific items at any time in
Setup, Write, and Engrave modes.

PROCEDURE

● Hide/Show signposts in any of the following ways:

● To hide/show all signposts, choose View > Signposts > Hide Signposts.

● To hide/show signposts for specific items, choose View > Signposts > [Type of
item].

RESULT
Signposts for individual items are shown when a tick appears beside the corresponding item in
the menu, and hidden when no tick appears.
All signposts are shown when no tick appears beside Hide Signposts in the menu, and hidden
when a tick appears.

Arranging tools
Arranging tools in Dorico Pro allow you to allocate notes to different staves and voices quickly
and efficiently.

These tools include copying notes and items to multiple staves at the same time, and multiple
times within a selected range, moving notes between staves, changing the voices of notes,
expanding notes onto more staves, and reducing notes onto fewer staves.

Deleting notes and items
You can delete any notes/items you have input into your project independently of each other,
such as deleting repeat endings without deleting the notes in them. However, you must be in
Write mode. You cannot delete notes and items in Setup, Engrave, or Print modes.

You can also delete notes in Play mode, but not other notation items.

PROCEDURE

1. In Write mode, select the notes/items you want to delete.

2. Press Backspace or Delete.

RESULT
All selected notes/items are deleted from your project. Deleted notes are replaced by implicit
rests as appropriate. Dorico Pro moves your selection to the most logical and nearby item to the
deleted items. For example, if you deleted a note, Dorico Pro‘s first choice is the nearest note in
the same voice.
If a slur began or ended on a deleted note, the slur is automatically repositioned to the next/
previous notehead. If only one note is left under a slur, the slur is automatically deleted.
Holds and pauses are not automatically deleted if they are not selected when you delete notes.
They are positioned above the note/rest closest to their rhythmic position, or over whole bar
rests if you delete all notes in a bar.
Any repeat barlines input as part of repeat endings are not deleted automatically when you
delete repeat endings.
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TIP

You can also delete markers by selecting them in the Markers section of the Video panel and
clicking Delete in the action bar.

RELATED LINKS
Deleting barlines on page 513

Copying and pasting items
You can copy and paste items, including notes and notations, to other rhythmic positions in
different ways.

PROCEDURE

1. In Write mode, select the items you want to copy.

2. Copy the selected items to other rhythmic positions in any of the following ways:

● Alt-click each position to which you want to paste them.

● Press Ctrl/Cmd-C, select the position to which you want to paste them, and press
Ctrl/Cmd-V.

● To copy items into a specific voice, including a slash voice, choose Edit > Copy, select
the position to which you want to paste them, and choose Edit > Paste Special >
Paste Into Voice > [Voice].

● To copy items to the staff above, select them and choose Edit > Paste Special >
Duplicate to Staff Above.

● To copy items to the staff below, select them and choose Edit > Paste Special >
Duplicate to Staff Below.

RESULT
The selected items are copied to other staves without deleting them from their original positions.

RELATED LINKS
Large selections on page 274
Selecting/Deselecting notes and items individually on page 273
Moving notes to other staves on page 286
Disabling automatic linking of dynamics and slurs when pasting on page 279

Copying and pasting notes into different voices
You can copy and paste notes into voices that are different to their original voices, including into
slash voices. For example, you can copy notes from an up-stem voice on one staff into a down-
stem voice on another staff.

PROCEDURE

1. In Write mode, select the notes you want to copy.

2. Press Ctrl/Cmd-C to copy the selected notes.

3. Select the staff to which you want to paste the notes, at the position where you want the
selection to start.

4. Choose Edit > Paste Special > Paste Into Voice > [Existing or new voice]. You can also
choose this option from the context menu.
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RESULT
The selected notes are copied to the selected staff and into the selected voice.

Copying and pasting items to multiple staves
You can copy and paste notes and other items to multiple staves at once, for example, to copy a
single phrase to all the woodwind staves when they are playing in unison.

PROCEDURE

1. In Write mode, select the items you want to copy to multiple staves.

2. Press Ctrl/Cmd-C to copy the selected items.

3. Select an item on each staff to which you want to paste the selected items.

4. Press Ctrl/Cmd-V to paste the selected items.

RESULT
The selected items are copied to all of the selected staves.

TIP

If you selected a range of items on each staff, the selected items are also pasted multiple times
to fill the selected range.

RELATED LINKS
Large selections on page 274
Disabling automatic linking of dynamics and slurs when pasting on page 279

Copying and pasting items to fill a selected range
You can copy and paste items, including notes and notations, multiple times within a selected
range at once, for example, if you want to fill multiple bars with the same phrase.

NOTE

You can only copy and paste items that have a duration to fill a selection. For example, you can
copy and paste gradual dynamics to fill a selection but not immediate dynamics.

PROCEDURE

1. In Write mode, select the items you want to copy throughout a range.

2. Press Ctrl/Cmd-C to copy the selected items.

3. Select the range throughout which you want to paste the selected items.

4. Press Ctrl/Cmd-V to paste the selected items.

RESULT
The selected items are copied as many times as will fit within the selected range without
extending beyond it.

TIP

If you selected a range on multiple staves, the selected items are also pasted to multiple staves.

RELATED LINKS
Large selections on page 274
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Moving notes to other staves
You can move notes to other staves of any type, for example, if you want to move individual
notes from one keyboard staff to another after importing a keyboard part from a MIDI file.

PROCEDURE

1. In Write mode, select the notes you want to move to another staff.

2. Move the notes to another staff in one of the following ways:

● To move notes to the staff above, press Alt-N.

● To move notes to the staff below, press Alt-M.

RESULT
The selected notes are moved to another staff by cutting them from their original staff and
pasting them to the new staff. By default, they are pasted into the first voice active on that staff.

NOTE

When moving notes within tuplets to other staves, those notes do not remain tuplets unless you
have also selected the tuplet bracket, tuplet number/ratio, or tuplet signpost.

RELATED LINKS
Creating cross-staff beams on page 544
Copying and pasting items to multiple staves on page 285

Swapping the contents of staves
You can swap the contents of two staves for a selected range, for example, if you want to change
quickly the default voicing in two particular bars that was achieved by exploding a chord.

PROCEDURE

1. In Write mode, select the range of music on two staves that you want to swap.

2. Choose Edit > Paste Special > Swap. You can also choose this option from the context
menu.

RESULT
The contents of the selected staves for the selected duration are swapped.

RELATED LINKS
Swapping the contents of voices on page 288

Reducing music onto fewer staves
You can reduce music onto fewer staves than it was originally notated across, for example, to
create a piano reduction of a choral piece.

PROCEDURE

1. In Write mode, select the music you want to reduce.

2. Press Ctrl/Cmd-C to copy the music.

3. Select the staves onto which you want to reduce the selected music.

4. Choose Edit > Paste Special > Reduce. You can also choose this option from the context
menu.
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RESULT
The selected music is reduced onto the selected staves.
If the rhythms match, Dorico Pro merges the music into a single voice. Unison notes are removed
so that only a single note of the same pitch is pasted at a single rhythmic position, and clef
changes, octave lines, and cues are also deleted.
Each destination staff receives the music of at least one instrument, and the division of the music
to be reduced is calculated from the top selected staff downwards. For example, if you copy
material from five instruments and reduce it to three, the top selected staff is assigned the music
from the first and second instruments, the second selected staff is assigned music from the third
and fourth instruments, and the third selected staff is assigned music from the fifth instrument.

RELATED LINKS
Moving notes to other staves on page 286

Exploding music onto multiple staves
You can explode music onto more staves than it was originally notated for, for example, to get
notes in dense piano chords onto all the woodwind staves quickly.

PROCEDURE

1. In Write mode, select the music you want to explode.

2. Press Ctrl/Cmd-C to copy the music.

3. Select the staves onto which you want to explode the selected music.

4. Choose Edit > Paste Special > Explode. You can also choose this option from the context
menu.

RESULT
The selected music is exploded onto the selected staves. Each destination staff receives at least
one of the notes in the source chords, allocated from the top selected instrument staff
downwards.

● If the number of notes in the chord matches the number of destination staves, each
instrument receives one note.

● If the number of notes in the chord is less than the number of destination staves, then the
same note is allocated to multiple staves. Notations, such as slurs and dynamics, are
duplicated to each destination staff.

● If the number of notes in the chord is more than the number of destination staves, then
the notes are spread as equally as possible across the destination staves. If the chord
contained an odd number of notes, Dorico Pro prefers to allocate extra notes to the upper
staves.

Changing the voice of existing notes
You can change the voice of notes after they have been input, including notes in slash voices. For
example, you can change notes in an up-stem voice to a down-stem voice.

PROCEDURE

1. In Write mode, select the notes whose voice you want to change.

TIP

You can use large selections and filters to select many notes in the same voice quickly.

2. Change the voice in any of the following ways:
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● Choose Edit > Voices > Change Voice > [Voice].

● Choose Edit > Voices > Change Voice > [Slash Voice].

TIP

● You can also choose these options from the context menu.

● If there is only one voice on the staff, you can create a new voice for your selected
notes.

RESULT
The voice of the selected notes is changed, which might cause Dorico Pro to change the stem
directions of the selected notes and other notes on the staff, and add implicit rests to ensure
correct notation based on convention.

AFTER COMPLETING THIS TASK
You can later delete or hide rests and change the stem direction of notes manually.
You can also change whole voices into slash voices.

RELATED LINKS
Showing voice colors on page 1041
Large selections on page 274
Filters on page 278
Implicit rests in multiple-voice contexts on page 861
Deleting rests on page 863
Changing the stem direction of notes on page 946
Changing the slash voice type on page 1044

Swapping the contents of voices
You can swap the contents of two voices that contain musical material.

PROCEDURE

1. In Write mode, select the notes in two voices that you want to swap.

2. Choose Edit > Voices > Swap Voice Contents. You can also choose this option from the
context menu.

RESULT
The contents of the voices are swapped. For example, the notes previously in an up-stem voice
are now in a down-stem voice, and the notes previously in a down-stem voice are now in an up-
stem voice.

NOTE

Depending on the pitches involved in the swap and their stem directions, the notes might
overlap. Dorico Pro automatically positions notes with the noteheads partially overlapping, in
order to minimize the horizontal space they occupy and maintain the clarity of the rhythm.
However, if you want to change this arrangement, you can change the order of voices or change
the voice column index.
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EXAMPLE

An E is in the up-stem voice, an F in the down-stem
voice.

After swapping their voice contents, the E is in the
down-stem voice, and the F is in the up-stem voice.

RELATED LINKS
Swapping the order of voices on page 1042
Voice column index on page 1042

Splitting flows
You can split flows at specific rhythmic positions. Flows in Dorico Pro are independent of each
other, meaning they can contain different players and have different options for notations,
including note grouping and accidental duration rules.

PROCEDURE

1. In Write mode, select a note or item at the position where you want to split the flow.

2. Choose Write > Split Flow.

RESULT
The flow is split into two flows: the existing flow and a new flow that begins from the position of
the item you selected. By default, new flows start on a new page in page view and are shown on
a separate background in galley view.

AFTER COMPLETING THIS TASK
You can choose different options for each flow in the Notation Options dialog.

RELATED LINKS
Flows on page 117
Adding flows on page 118
Deleting flows on page 120
Notation Options dialog on page 139
Deleting empty bars at the end of flows on page 505
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Engrave mode allows you to manipulate and modify every item in your project, but without
deleting them or changing the pitch of notes. You can also determine how the pages of your
project are formatted for printing or exporting.

Project window in Engrave mode
The project window in Engrave mode contains the default toolbar, the music area, and the status
bar. It provides panels with all the tools and functions that allow you to format the pages,
systems, and properties of individual notations in your score.

You can switch to Engrave mode in any of the following ways:

● Press Ctrl/Cmd-3.

● Click Engrave in the toolbar.

● Choose Window > Engrave.

Toolbox and panels in Engrave mode

The project window in Engrave mode contains the following:

1 Engrave toolbox

Engrave mode
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Contains options that allow you to determine which formatting options are shown in the
Formatting panel, and to activate Note Spacing and Staff Spacing.

2 Formatting panel
Contains formatting options that allow you to control how music is arranged into systems
and frames, to insert frames, and edit frame constraints. Your current selection in the
Engrave toolbox determines which formatting options are shown, and the panel is hidden
automatically when either Note Spacing or Staff Spacing are activated.

3 Pages panel
Allows you to specify how the notation is formatted on pages. The way this is done is
based on the typical techniques used in desktop publishing programs.

4 Properties panel
Contains quick access properties that allow you to make specific modifications to
individual parts of notes and notations.

RELATED LINKS
Windows on page 33

Engrave toolbox
The Engrave toolbox allows you to change the options available in the Formatting panel and to
activate note and staff spacing. The Engrave toolbox is located on the left of the window in
Engrave mode.

Graphic Editing

Allows you to select and edit items in the music area or master page editor, and
opens sections in the Formatting panel that allow you to edit the formatting of
systems, frames, brackets, braces, and barline joins.

Frames

Allows you to select and edit frames in the music area or master page editor, and
opens sections in the Formatting panel that allow you to insert frames and edit their
constraints.

Staff Spacing

Allows you to move individual staves and systems vertically.

Note Spacing

Allows you to edit the graphical horizontal positions of individual notes and other
items, such as clefs and key signatures.

RELATED LINKS
Frames on page 322
Frame constraints on page 340
Staff spacing on page 391
Note spacing on page 381
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Formatting panel
The Formatting panel in Engrave mode allows you to insert different kinds of frames into pages
and to specify how these are aligned on a page. It also allows you to make changes to how
systems and frames are formatted on pages, including manually adding brackets and braces.

The Formatting panel is located on the left of the window in Engrave mode. You can hide/show
the Formatting panel in any of the following ways:

● Press Ctrl/Cmd-7.

● Click the disclosure arrow on the left edge of the main window.

● Choose Window > Show Left Panel.

Depending on your selection in the Engrave toolbox, different formatting options are available in
the Formatting panel.

The following sections are available when Graphic Editing is selected in the Engrave toolbox:

Format Music Frames

The Format Music Frames section allows you to change how the music in the layout currently
open in the music area is arranged into frames.

Insert Frame Break

Forces music from the selected item onwards onto the next frame, which is often on
the next page. This allows you to control what music appears on each page.

Lock Frame

Fixes the formatting of the selected frames, even if you change the formatting of
surrounding frames.

Make into Frame

Forces all music between the selected items into the same frame. You can use this
option to force music onto a single page.

Format Systems

The Format Systems section allows you to change how the music in the layout currently open in
the music area is arranged into systems.

Insert System Break

Forces music from the selected item onwards onto the next system. Depending on
your staff size and other settings, this may mean the music is forced onto the next
page.

Lock System
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Fixes the formatting of the selected systems, even if you change the formatting of
surrounding musical material and other systems.

Make into System

Forces all music between the selected items into the same system.

Bracketing

The Bracketing section allows you to change how the staves in the layout currently open in the
music area are bracketed and braced together, and change which staves are joined by barlines,
in each system individually.

Insert bracket

Joins the staves on which you have selected items with a bracket. By default, this also
causes barlines to be drawn across the bracketed group.

Insert sub-bracket

Joins the staves on which you have selected items with a sub-bracket.

NOTE

The selected staves must be within a bracket.

Insert sub-sub-bracket

Joins the staves on which you have selected items with a sub-sub-bracket.

NOTE

The selected staves must be within a bracket and sub-bracket.

Insert brace

Joins the staves on which you have selected items with a brace.
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NOTE

Staves cannot be joined by both a brace and a sub-bracket or sub-sub-bracket
simultaneously.

Change barline joins

Joins the barlines across the staves on which you have selected items.

The following sections are available when Frames is selected in the Engrave toolbox:

Insert Frames

The Insert Frames section allows you to create new frames on pages in layouts as well as on
master pages.

Insert Music Frame

Allows you to insert a music frame. On pages in layouts, this inserts a music frame in
a layout frame chain. On master pages in the master page editor, this inserts a frame
in a master page frame chain.

Insert Text Frame

Allows you to insert a frame into which you can enter text and text tokens.

Insert Graphics Frame

Allows you to insert a frame that can contain an image or an illustration.

Constraints
Allows you to specify which sides of the frame you want to lock to the page margin.

RELATED LINKS
Frames on page 322
Music frames on page 325
Text frames on page 331
Graphics frames on page 340
Master pages on page 301
Music frame chains on page 326
Brackets and braces on page 555
Frame constraints on page 340
Frame breaks on page 356
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Pages panel
The Pages panel in Engrave mode provides several sections that allow you to specify how the
pages of your notation are formatted. The way this is done is based on the typical techniques as
they are used in desktop publishing programs.

The Pages panel is located on the right of the window in Engrave mode. You can hide/show the
Pages panel in any of the following ways:

● Press Ctrl/Cmd-9.

● Click the disclosure arrow on the right edge of the main window.

● Choose Window > Show Right Panel.

Pages panel in Engrave mode

The Pages panel is divided into the following sections:
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Pages
Shows the pages in your layout with their page number in the middle. A highlighted
page frame indicates the currently selected page. Markings in the top left and the
bottom right corner of the pages indicate that a page has overrides. Additional
frames at the top or left frames of the page indicate that master page changes have
been applied.
The action bar at the bottom of the section contains the following options:

● Insert Pages

Allows you to insert pages into your layout before or after existing pages,
based on a selected master page.

● Insert Page Number Change

Allows you to change the page numbers for pages in your layout.

● Insert Master Page Change

Allows you to assign a different master page to the selected page.

● Swap with Previous Page

Swaps the arrangement of the selected page with the previous page.

● Swap with Next Page

Swaps the arrangement of the selected page with the next page.

● Remove Overrides

Removes all overrides from the selected pages.

Master Pages
Shows the master page pairs that are used in your layout. A highlighted frame
indicates the currently selected master page. If you select a page in the Pages
display, the master pages display highlights the master page pair that is used for this
page.
The Current set menu allows you to view and change the master page set used in
the layout currently open in the music area.
The action bar at the bottom of the section contains the following options:

● New Master Page

Allows you to add a new master page to a master page set.

● Edit Master Page

Opens the master page editor in which you can change the formatting of the
master page. You can also open the master page editor by double-clicking a
master page in the Flow Headings section.

● Rename Master Page
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Allows you to rename the selected master page.

● Delete Master Page

Deletes the selected master page.

Flow Headings
Shows the flow headings available in the currently selected master page set. A
highlighted frame indicates the currently selected flow heading.
The action bar at the bottom of the section contains the following options:

● New Flow Heading

Allows you to add a new flow heading to a master page set.

● Edit Flow Heading

Opens the flow heading editor in which you can change the formatting of the
flow heading. You can also open the flow heading editor by double-clicking a
flow heading in the Flow Headings section.

● Rename Flow Heading

Allows you to rename the selected flow heading.

● Delete Flow Heading

Deletes the selected flow heading.

Master Page Sets
Contains a list of available master page sets in the project.
The action bar at the bottom of the section contains the following options:

● New Master Page Set

Creates a new master page set based on the master page set that is selected
in the list. The new master page set is automatically added to the Current set
menu in the Master Pages section.

● Rename Master Page Set

Allows you to rename the selected master page set.

● Delete Master Page Set

Deletes a selected master page set from the list.

RELATED LINKS
Master pages on page 301
Master page editor on page 306
Flow headings on page 318
Flow heading editor on page 318
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Properties panel (Engrave mode)
The Properties panel in Engrave mode provides options that allow you to edit individual notes
and notations. All the properties that are available in the Properties panel in Write mode are also
available in Engrave mode, but additional properties in Engrave mode allow you to edit items in
more detail.

You can hide/show the Properties panel in Write mode and Engrave mode in any of the following
ways:

● Press Ctrl/Cmd-8.

● Click the disclosure arrow at the bottom of the main window.

● Choose Window > Show Bottom Panel.

The Properties panel contains a group of properties for each notation item. When you select a
note or item in the music area, the Properties panel displays the groups and options that you
might require to edit the selected note or item.

Notes and Rests group of the Properties panel in Engrave mode

NOTE

● If you select multiple different types of notation items, only the groups that they have in
common are displayed. For example, if you select a slur, the Common and Slurs groups
are displayed in the Properties panel. However, if you select a slur and a note, only the
Common group is displayed.

● Many properties are layout-specific, meaning changing the properties of an item in one
layout does not affect the same item in other layouts. However, you can copy property
changes to other layouts.

RELATED LINKS
Changing the properties of individual notes and items on page 136
Copying property settings to other layouts on page 363
Resetting the appearance of items on page 281
Resetting the position of items on page 281

Selecting handles on items
In Engrave mode, you can select individual handles on items, for example, if you want to move
the graphical end of a gradual dynamic without moving its start.

NOTE

These steps do not apply to frame, note spacing, or staff spacing handles.

PROCEDURE

1. Select a handle in any of the following ways:

● Select the whole item and press Tab until the handle you want is selected.

● Click the handle you want.
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TIP

You can show handles on all items, not just selected items, by choosing Engrave >
Show Handles > Always. This can make it easier to select individual handles on
multiple items.

2. Optional: Select handles on other items as well by Ctrl/Cmd-clicking them.

NOTE

You cannot select subsequent handles on other items by selecting the items and pressing
Tab.

Engraving Options dialog
The Engraving Options dialog provides multiple options that allow you to make project-wide
changes to your project by changing the graphical appearance and position of items.

You can make changes to, for example, the line thickness of notation items, their continuation
style, their default staff-relative placement, and their minimum distance from the staff and other
items.

TIP

● You can save all options that you set in Engraving Options as the default for new projects
by clicking Save as Default.

● If you want to make changes to individual notes and notations, you can use properties in
the Properties panel.

You can open Engraving Options in any of the following ways:

● Press Ctrl/Cmd-Shift-E in any mode.

● Choose Engrave > Engraving Options in Engrave mode.

Engraving Options
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The Engraving Options dialog contains the following:

1 Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages. When you click a page in this list, any applicable section titles appear below the
page in the page list.

2 Section titles
Shows the titles of any sections on the selected page. You can click these section titles to
navigate directly to that section of the page.

3 Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible
settings, the current setting is highlighted.

4 Save as Default/Remove Saved Defaults
This button has different functions depending on whether you have existing saved
defaults.

● Save as Default saves all options currently set in the dialog as the default for new
projects.

● Remove Saved Defaults deletes your previous saved defaults without resetting the
options in the current project. After removing your saved defaults, all future projects
start with the default factory settings. If you have existing saved defaults, you can
access Remove Saved Defaults by pressing Alt (macOS)/Ctrl (Windows).

5 Reset to Factory/Reset to Saved Defaults
This button has different functions depending on whether you have existing saved
defaults.

● If you have no saved defaults, Reset to Factory resets all the options in the dialog
back to the default factory settings.

● If you have existing saved defaults, Reset to Saved Defaults resets all the options in
the dialog back to your saved defaults. You can access Reset to Factory instead by
pressing Alt (macOS)/Ctrl (Windows). Resetting options back to the default factory
settings only affects the current project and does not delete your saved defaults,
meaning future projects start with your saved defaults.

RELATED LINKS
Options dialogs in Dorico Pro on page 30
Resetting the appearance of items on page 281
Resetting the position of items on page 281

Making project-wide changes in Engraving Options
You can make project-wide changes to the appearance, placement, and default position of notes
and notations in Engraving Options.

PROCEDURE

1. Open Engraving Options in any of the following ways:

● Press Ctrl/Cmd-Shift-E in any mode.

● Choose Engrave > Engraving Options in Engrave mode.

2. Click a page in the page list.

3. Look through the available options, and change the settings as required.

4. Click Apply, then Close.
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NOTE

If you make changes and close the dialog without clicking Apply, you are prompted to
save or discard your changes.

RESULT
The changes are applied to all music in your project, including in all layouts and flows.

Master pages
Master pages function like templates in Dorico Pro, allowing the same page formatting to be
applied to multiple different pages in different layouts.

NOTE

Page size and margins, page orientation, and staff size for full score and part layouts are
specified in Setup > Layout Options.

All pages in your score and parts inherit their layout formats from master pages. Whenever you
create or change anything on master pages, this is automatically reflected on the pages that use
these master pages. For example, if you insert a new frame on a master page, a corresponding
frame appears on all the pages that use that master frame, so long as those pages do not have
master page overrides.

In Dorico Pro, master pages consist of page pairs. Every page pair has a left and a right master
page, so that if a page in your project falls on a left page, the formatting of the left page of the
master page pair is used, and if a page falls on a right page, the formatting of the right page of
the master page pair is used. In both the Master Pages section of the Pages panel and the
master page editor, page pairs appear side-by-side.

Dorico Pro provides default master pages for first (First) and subsequent (Default) pages. This
enables you to format first pages differently compared to subsequent pages. Master pages are
contained in master page sets for full score and part layouts. Master page sets are automatically
applied to every layout that you create.

The Master Pages section of the Pages panel in Engrave mode, showing the two default master pages in the
Default Full Score master page set.

If you want to change the master page sets or to change the format of the master pages, you
can do so in any of the following ways:

● Create new master pages and master page sets.

● Edit the default master pages in the master page sets using the master page editor.
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You can also make overrides to individual pages in layouts, but this does not affect the
formatting of master pages.

RELATED LINKS
Pages panel on page 295
Master page editor on page 306
Master page overrides on page 308
Layout Options dialog on page 90

Master page sets
In Dorico Pro, master pages are provided as parts of master page sets. Master page sets group
master page formats together, so there is a master page for all possible situations in your
project.

The default master page sets contain predefined master pages for first page pairs (First) and
subsequent page pairs (Default). This ensures there is a master page format for the first page in
each flow, whether that is on a right page or a left page, and a master page format for
subsequent pages in each flow on both right and left pages.

For every new project, the following default master page sets are available:

● Default Full Score is the default master page set used for full score layouts.

● Default Part is the default master page set used for part layouts.

Master page sets also contain flow headings that allow you to format how the titles of flows
appear when they start on the same page as a previous flow. The default master page sets
contain a single flow heading each.

You do not need to create or customize master page sets initially, as the default sets are applied
automatically when you create your project. If you find that you want or need to change the sets,
you can do so in any of the following ways:

● Create new custom master page sets based on the default sets.

● Change the default sets according to your requirements for the current project.

RELATED LINKS
Flow headings on page 318

Creating master page sets
You can create new master page sets. They can be based on the sets provided by Dorico Pro and
on existing custom master page sets you have created.

PROCEDURE

1. In the Master Page Sets section of the Pages panel, click the master page set on which
you want to base a new master page set.

2. In the action bar, click New Master Page Set.

RESULT
A new master page set is created based on the selected default master page set. It appears
immediately in the list of master page sets.

AFTER COMPLETING THIS TASK
You can rename your new master page set and add new master pages to it.
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RELATED LINKS
Adding master pages on page 304

Renaming master page sets
You can edit the names of master page sets that you have created. You cannot rename the
default master page sets.

PROCEDURE

1. In the Master Page Sets section of the Pages panel, double-click the master page set that
you want to rename.
Alternatively, you can select the master page set and click Rename Master Page Set in the
action bar.

2. Enter the new name you want.

3. Press Return.

Deleting master page sets
You can delete master page sets that you no longer need, including the default master page sets.

PROCEDURE

1. In the Master Page Sets section of the Pages panel, click the master page set that you
want to delete.

2. In the action bar, click Delete Master Page Set.

Applying master page sets to layouts
You can apply a different master page set to each layout in your project.

PROCEDURE

1. In the music area, open the layout to which you want to apply a master page set.

2. In the Master Pages section of the Pages panel, select a master page set from the
Current set menu.

RESULT
The selected master page set is applied to the layout.

AFTER COMPLETING THIS TASK
You can make further changes to the layout, such as assigning different master pages in the
master page set to individual pages. You can also make individual master page overrides that
only apply to pages in the current layout, for example, if you need the frame padding on the first
page to be different to the master page setting.

RELATED LINKS
Assigning master pages to pages on page 314
Master page overrides on page 308
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Master page types
If you add a new master page to a master page set, you must specify the type of master page
that you want to add.

You can add the following types of master pages:

First
A page pair that is usually used for the first page of music in a layout. By default,
First master pages contain tokens to display the project title, composer, and lyricist
in addition to the music.

NOTE

If you create no First page pair, the first page in your layout uses the Default page
pair.

Default
A page pair that is usually used for pages after the first page in a layout. By default,
Default master pages contain tokens to display the flow title and page number in
addition to the music.
Every master page set must contain a single Default master page.

Custom
A page pair that can have any layout. Custom master pages allow you to create
layouts that you want to apply to multiple pages but not all pages, for example, if
you want to show an image at the same position on only the final pages in each part
layout.

NOTE

If you insert a page to a layout using a custom master page, you create an override.
This means that if you insert a page in the middle or at the end of the layout using a
custom master page and then remove the override, that page is automatically
assigned the Default master page.

RELATED LINKS
Master page sets on page 302
Master page overrides on page 308
Changing when the First master page is used on page 345

Adding master pages
You can add new master pages to master page sets. Each master page set can have multiple
custom master pages, but only a single first master page and single default master page.

PROCEDURE

1. In the music area, open a layout that uses the master page set to which you want to add
master pages.

NOTE

You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2. In the Pages panel, click New Master Page in the Master Pages action bar to open the
New Master Page dialog.
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3. In the New Master Page dialog, enter a name for the new master page into the Name
field.

4. Select the existing master page on which you want to base the new master page from the
Based on menu.

NOTE

● Master pages based on existing master pages retain a link to the Based on master
page. This means some changes you make to the Based on master page, such as
changing the font size of text in text frames, also affect the new master page and
vice versa.

● Selecting (None) always creates a master page without any formatting but the page
margins.

5. Choose one of the following master page types for your new master page:

● First

● Default

● Custom

NOTE

If you select First or Default, the new master page replaces that existing master page, as
each master page set can only have a single first and default master page.

If you want to create a new master page without replacing any existing master pages,
choose Custom.

6. Click OK to save your changes and close the dialog.

RESULT
A new master page of the selected type is added to the selected master page set.

AFTER COMPLETING THIS TASK
You can apply master pages to individual pages in layouts that use the master page set to which
they belong.

RELATED LINKS
Master page sets on page 302
Applying master page sets to layouts on page 303
Assigning master pages to pages on page 314

Renaming master pages
You can change the names of master pages, including the default master pages and your own
custom master pages.

PROCEDURE

1. In the music area, open a layout that uses the master page set containing the master page
you want to rename.

NOTE

You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.
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2. In the Master Pages section of the Pages panel, click the master page pair that you want
to rename.

3. In the action bar, click Rename Master Page to open the Rename Master Page dialog.

4. Enter the name you want in the Name field.

5. Click OK to save your changes and close the dialog.

Deleting master pages
You can delete master pages from master page sets.

NOTE

You cannot delete Default master pages. Every master page set must contain at least a Default
master page. You can replace Default master pages by adding a master page and setting its type
to Default.

PROCEDURE

1. In the music area, open a layout that uses the master page set containing the master page
you want to delete.

NOTE

You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2. In the Master Pages section of the Pages panel, click the master page pair that you want
to delete.

3. In the action bar, click Delete Master Page.

RESULT
The selected master page pair is deleted. You can undo this action if you deleted a master page
in error.

Master page editor
The master page editor allows you to view and change the format of the master pages.

You can open the master page editor in any of the following ways:

● Double-click a page pair in the Master Pages section of the Pages panel.

● Select a page pair in the Master Pages section of the Pages panel and click Edit Master
Page.

You can customize master pages in the master page editor to suit your requirements, including
inserting extra frames and editing/moving existing frames. You can also change the frame chains
to which frames are assigned, and change which flows and players are assigned to frames.
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A master page pair open in the master page editor

RELATED LINKS
Pages panel on page 295

Customizing master pages
You can customize master pages according to your needs in the master page editor. Changing a
master page affects the appearance of all layouts that use that master page.

NOTE

You must specify the page size, margins, page orientation, and staff size of layouts on the Page
Setup page in Setup > Layout Options.

PROCEDURE

1. In the Pages panel, double-click a master page pair in the Master Pages section.
The master page editor opens in the music area.

2. In the master page editor, change the layout of one of the pages of the selected master
page pair. For example, you can change the size and shape of frames.

3. Optional: If you want both the left and right pages to be the same, click one of the
following Copy Page Layout buttons at the top of the music area, depending on which
page you changed:

● Left to Right

● Right to Left
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NOTE

This copies the master page layout exactly from one page to the other, not as a
mirror. For example, text frames for page numbers are not kept on the outside edge
automatically.

4. Click Apply, then Close.

RESULT
The selected master page pair is changed.

RELATED LINKS
Inputting frames on page 322
Moving frames on page 323
Changing the size/shape of frames on page 323
Master page editor on page 306

Master page overrides
All pages of a project inherit their format from the master pages that are specified in the
appropriate master page sets. In some cases, it is also possible to change the format of
individual pages without affecting the underlying master pages or master page sets.

In Dorico Pro, you can override the format of an individual page, for example, if you want to do
one of the following:

● Change the size of a music frame on an individual page.

● Insert an empty page.

● Change the page numbering.

● Add comments in the form of footnotes.

● Include small excerpts of music to show how a passage was reproduced in another source.

If you override the pages, they no longer automatically inherit changes that are made to the
master page. Pages that have been overridden are shown with a marking on them in the Pages
section of the Pages panel.

● Master page overrides: marking shown in top left corner.

● Page number changes: marking shown in bottom right corner.

To return overridden pages to following their master page format, you must remove the
overrides that you made.

NOTE

If you inserted a page in the middle or at the end of your layout using a custom master page and
remove the override, that page is automatically assigned the Default master page of the master
page set.

You can also change the master page used for individual pages. For example, you might want to
change the master page used for the last page in parts because it contains fewer staves and you
want the music frame to be shorter. Or you might want to change the master page used for a
score where the instrumentation is significantly different for one flow and you want the format of
those pages to be different.

Pages whose master page has been changed are shown with a marking on them in the Pages
section of the Pages panel.

● Master page changes on the current page only: marking shown along top edge.
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● Master page changes from the page onwards: marking shown along left and top edges.

Additionally, you can change the flow heading use for individual pages. For example, if you want
the margins above and below flow headings to be smaller on pages with more staves.

Pages whose flow heading has been changed are shown with a marking on them in the Pages
section of the Pages panel.

● Flow heading changes on the current page only: marking shown along bottom edge.

● Flow heading changes from the page onwards: marking shown along left and bottom
edges.

The table shows examples of how the different overrides you can make to individual pages in
layouts are shown in the Pages section of the Pages panel in Engrave mode.

Master page override Page number change Master page change to single
page only

Master page change from selected
page onwards

Flow heading change to single
page only

Flow heading change from
selected page onwards

Removing master page overrides
You can remove overrides that you have made to individual pages and return them to the master
page format.

Any pages in your layout that contain overrides are shown with a colored triangle in their top left
corner in the Pages section of the Pages panel. Master page overrides include changing the size/
shape of frames inherited from the master page or flow heading format, inputting extra frames
on the page, and inputting a new empty page.

Removing overrides from empty pages deletes them from the layout.

PROCEDURE

1. In the music area, open the layout whose master page overrides you want to remove.

2. Optional: If you want to remove overrides from individual pages, Ctrl/Cmd-click those
pages in the Pages section of the Pages panel.

3. Remove master page overrides in one of the following ways:

● To remove overrides from selected pages only, click Remove Overrides in the
Pages section action bar.

● To remove overrides from all pages, right-click in the Pages section of the Pages
panel and choose Remove All Page Overrides from the context menu.
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RESULT
Any overrides you made to the master page format are removed from either the selected pages
only or from all pages in the layout currently open in the music area. Empty pages that are
considered overrides are deleted.
If you removed overrides from selected pages only, any other pages with overrides in the layout
are unaffected.

RELATED LINKS
Frames on page 322

Inserting pages
You can insert empty pages or pages that use a different master page into each layout in your
project.

PROCEDURE

1. In the Pages panel, click Insert Pages in the Pages section action bar to open the Insert
Pages dialog.

2. Enter the number of pages you want to insert into the Number of pages to insert field.

3. Select where you want to insert pages. For example, select After page and enter 8 to
insert pages after page 8.

4. Optional: Select the master page that you want to assign to the inserted pages from the
Use master page menu.

5. Click OK to save your changes and close the dialog.

RESULT
The number of pages specified are added at the selected position. They are empty, have no
master page assigned by default, and are shown in the Pages panel with a colored triangle in
their top left corner.

Deleting pages
You can delete empty pages and any extra pages you have added to layouts.

Dorico Pro automatically changes the number of pages in each layout according to the length of
the flows they contain. If you want to delete pages because you do not want to show certain
flows, you can instead remove the flows from the layout.

You only need to delete pages manually if you inserted them as a blank page or made an
override to a page in a layout that is no longer required and now appears blank. For example, an
override on the final page in a layout prevents that page and all previous pages being
automatically deleted if the layout becomes shorter.

PROCEDURE

1. In the music area, open the layout from which you want to delete pages.

2. In the Pages section of the Pages panel, Ctrl/Cmd-click the pages you want to delete.

NOTE

You can only delete pages that are considered master page overrides.

3. Delete the selected pages by removing all their master page overrides.

● If any pages in your selection have colored triangles in their top left corner, click
Remove Overrides in the Pages section action bar.
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● If any pages in your selection have colored triangles in their bottom right corner,
right-click a page and choose Remove Page Number Change(s) from the context
menu.

● If any pages in your selection have colored markings on their top/top and left edges,
right-click a page and choose Remove Master Page Change(s) from the context
menu.

● If any pages in your selection have colored markings on their bottom/bottom and
right edges, right-click a page and choose Remove Flow Heading Change(s) from
the context menu.

RESULT
Once you have removed all overrides from all the pages you want to delete, they are deleted if
they are empty. If they are not empty, removing all their overrides reverts them back to following
their default master page.

RELATED LINKS
Master pages on page 301
Changing the flows assigned to layouts on page 122

Inserting page number changes
You can change the page numbers of pages in each layout in your project. Inserting page
number changes allows you to change the page number shown, the page number style, and also
affects whether the first page in layouts is a left or right page.

For example, you can use Roman numerals such as ii and iv for front matter pages, and numbers
such as 1 and 3 for music pages.

NOTE

● If you change the first page in the layout to an even number, it automatically becomes a
left-hand page. This is because convention dictates that even numbered pages are always
on the left-hand page, and odd numbered pages are always on the right-hand page.
Similarly, if the first page in the layout is on the left-hand page, it cannot show as page 1, it
can only show as page 2.

● If you want to start a layout on the left-hand page, we do not recommend that you insert a
page number change, as there is a dedicated option in Setup > Layout Options for this.

PROCEDURE

1. In the music area, open the layout whose page numbers you want to change.

2. In the Pages section of the Pages panel, select the page from which you want to change
the page numbers.

3. In the action bar, click Insert Page Number Change to open the Page Number Change
dialog.

4. In the Page Number Change dialog, enter the number of the page from which you want
the page number change to start in the From page field.
For example, if you want to change the page number of your current page 3, enter 3.

5. Enter the new page number that you want the selected page to have in the First page
number field. For example, if you want to change your current page 3 to page 5, enter 5.

6. Select one of the following numeral styles for Sequence type:
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● Number

● Roman numeral

7. Click OK to save your changes and close the dialog.

RESULT
The page number of the selected page is changed. All subsequent pages are changed
correspondingly until the next page number change or the end of the project, whichever comes
first.

TIP

You can also change other aspects of the appearance of page numbers in the Page Number
Change dialog. For example, you can show subordinate numbers as uppercase letters or
lowercase letters.

RELATED LINKS
Starting layouts on left-hand pages on page 344

Page Number Change dialog

The Page Number Change dialog allows you to change the page numbers shown on existing
pages in each layout. You can choose to show pages without page numbers or with different
numbering.

For example, you can change the number type to one of the available types:

● Roman numeral: such as iii and iv

● Number: such as 5 and 19

You can also change the visibility of page numbers. For example, you can hide page numbers on
introductory pages by setting their visibility to Not on first page.

You can open the Page Number Change dialog when a page is selected in the Pages section of
the Pages panel in any of the following ways:

● Right-click in the Pages section and choose Insert Page Number Change from the
context menu.

● Click Insert Page Number Change.

The Page Number Change dialog contains the following options:

From page
Allows you to select the page from which you want to change page numbers. The
number indicates its position within the layout.
The Displayed option shows you the number that the selected page currently has,
and how that number appears.

First page number
Allows you to specify the new page number you want for the selected page.
Subsequent pages follow the new sequence until the next page number change or
end of the project.

Sequence type
Allows you to select the type of number that the selected page and subsequent
pages have.
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Visibility
Allows you to specify if a page number is hidden or shown. You can additionally
specify that the page number is also hidden on the page where the page number
change occurs.

Subordinate number type
Allows you to add a subordinate number to the page number and to specify a type.

Subordinate number
Allows you to specify the number from which you want the subordinate numbers to
start.

When you insert page number changes, a marking is shown in the bottom right corner of the
page in the Pages section of the Pages panel. The new page number is also shown in each page
in the Pages section of the Pages panel, in the appropriate numeral style.

RELATED LINKS
Page numbers on page 765

Removing page number changes
You can remove page number changes you have made to individual pages, which reverts pages
to their default page numbers.

Any pages whose page number has been changed are shown with a colored triangle in their
bottom right corner in the Pages section of the Pages panel.

PROCEDURE

1. In the music area, open the layout whose page number changes you want to remove.

2. Optional: If you want to remove page number changes from individual pages, Ctrl/Cmd-
click those pages in the Pages section of the Pages panel.

3. Remove page number changes in one of the following ways:

● To remove page number changes from selected pages only, right-click a page and
choose Remove Page Number Change(s) from the context menu.

● To remove page number changes from all pages, right-click in the Pages section of
the Pages panel and choose Remove All Page Number Changes from the context
menu.

RESULT
Page number changes are removed from either the selected pages only or from all pages in the
layout currently open in the music area.
If you removed page number changes from all pages, all pages are restored to the default page
number sequence.
If you removed page number changes from selected pages only, the default page number is
restored from the selected pages until the next page number change or the end of the project,
whichever comes first. Any other pages with page number changes in the layout are unaffected.

RELATED LINKS
Page Number Change dialog on page 312
Inserting page number changes on page 311
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Assigning master pages to pages
You can assign different master pages in the master page set to each page in each layout in your
project. You can assign them to individual pages and to every page after a selected page.

PROCEDURE

1. In the music area, open the layout in which you want to change the master pages assigned
to pages.

2. In the Pages section of the Pages panel, click the page whose master page assignment
you want to change.

3. In the action bar, click Insert Master Page Change to open the Insert Master Page
Change dialog.

4. Optional: Change the start page for the master page change using the From page option.

5. Select the master page that you want to assign from the Use master page menu.

6. Choose one of the following options for Range:

● Current Page Only
Only the selected page is assigned a different master page.

● From This Page Onwards
The selected page and all subsequent pages are assigned a different master page.

7. Click OK to save your changes and close the dialog.

RESULT
If you selected Current Page Only, the selected master page is assigned to the selected page
only.
If you selected From This Page Onwards, the selected master page is assigned to the selected
page and all subsequent pages in the layout or until the next existing master page change.

Removing master page changes
You can remove master page changes you have assigned to individual pages, which reverts them
to the overall master page format applied to the layout.

Any pages whose master page has been changed are shown with a marking along their top
edge, or along their top and left edges, in the Pages section of the Pages panel.

PROCEDURE

1. In the music area, open the layout whose master page changes you want to remove.

2. Optional: If you want to remove master page changes from individual pages, Ctrl/Cmd-
click those pages in the Pages section of the Pages panel.

3. Remove master page changes in one of the following ways:

● To remove master page changes from selected pages only, right-click a page and
choose Remove Master Page Change(s) from the context menu.

● To remove master page changes from all pages, right-click in the Pages section of
the Pages panel and choose Remove All Master Page Changes from the context
menu.

RESULT
All master page changes are removed from either the selected pages only or from all pages in
the layout currently open in the music area. Pages return to the overall master page format
applied to the layout.
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If you removed master page changes from selected pages only, any other pages with master
page changes in the layout are unaffected.

RELATED LINKS
Master page overrides on page 308

Inserting flow heading changes
Inserting flow heading changes allows you to change the margins above/below flow headings in
addition to changing the flow heading format used. You can insert flow heading changes on each
page in each layout independently.

PROCEDURE

1. In the music area, open the layout whose flow headings you want to change.

2. In the Pages section of the Pages panel, click the page on/from which you want to insert a
flow heading change.

3. In the action bar, click Insert Flow Heading Change to open the Insert Flow Heading
Change dialog.

4. Optional: Change the start page for the flow heading change using the From page option.

5. Select the flow heading that you want to insert from the Use flow heading menu.

6. Choose one of the following options for Range:

● Current Page Only

● From This Page Onwards

7. Optional: Activate Heading Top Margin and/or Heading Bottom Margin and change
their values to change the margins above/below flow headings on the selected pages.

8. Click OK to save your changes and close the dialog.

RESULT
If you selected Current Page Only, the selected flow heading is applied to all flow headings on
the selected page only.
If you selected From This Page Onwards, the selected flow heading is applied to all flow
headings on the selected page and all subsequent pages in the layout or until the next existing
flow heading change.

RELATED LINKS
Flow headings on page 318
Allowing/Disallowing multiple flows on the same page on page 344

Insert Flow Heading Change dialog

The Insert Flow Heading Change dialog allows you to change the formats used for all flow
headings on specified pages in each layout. You can apply flow heading changes only to
individual pages or to all subsequent pages.

You can open the Insert Flow Heading Change dialog when a page is selected in the Pages
section of the Pages panel in any of the following ways:

● Right-click in the Pages section and choose Insert Flow Heading Change from the
context menu.

● Click Insert Flow Heading Change.
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The Insert Flow Heading Change dialog contains the following options:

From page
Allows you to select the page from which you want to change the flow heading
format. The number indicates its position within the layout.
The Displayed preview shows the current page number of the selected page, and
how that number appears. If you have inserted page number changes in the layout,
this might be different to From page.

Use flow heading
Allows you to specify the flow heading design you want to apply. The menu contains
all available flow headings in the current master page set.

Range
Allows you to specify the range to which you want to apply the flow heading change.

● Current Page Only applies the flow heading change only to the selected page.

● From This Page Onwards applies the flow heading change to the selected
page and all subsequent pages in the layout or until the next existing flow
heading change.

Heading Top Margin
Allows you to set the gap between the top of affected flow headings and the end of
the preceding flow, independently of the default setting for the layout.

Heading Bottom Margin
Allows you to set the gap between the bottom of affected flow headings and the
start of the next flow, independently of the default setting for the layout.

When you insert flow heading changes, a marking is shown on the bottom or bottom and left
edges of the page in the Pages section of the Pages panel.

RELATED LINKS
Changing the margins above/below flow headings on page 346
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Removing flow heading changes
You can remove flow heading changes you have assigned to individual pages to revert to the
Default flow heading.

Any pages whose flow heading has been changed are shown with a marking along their bottom
edge, or along their bottom and left edges, in the Pages section of the Pages panel.

PROCEDURE

1. In the music area, open the layout whose flow heading changes you want to remove.

2. Optional: If you want to remove flow heading changes from individual pages, Ctrl/Cmd-
click those pages in the Pages section of the Pages panel.

3. Remove flow heading changes in one of the following ways:

● To remove flow heading changes from selected pages only, right-click a page and
choose Remove Flow Heading Change(s) from the context menu.

● To remove flow heading changes from all pages, right-click in the Pages section of
the Pages panel and choose Remove All Flow Heading Changes from the context
menu.

RESULT
All flow heading changes are removed from either the selected pages or from all pages in the
layout currently open in the music area. Pages return to using the Default flow heading in the
master page set applied to the layout.
If you removed flow heading changes from selected pages only, any other pages with flow
heading changes in the layout are unaffected.

RELATED LINKS
Flow headings on page 318

Swapping pages
You can swap pages that have overrides with adjacent pages.

PROCEDURE

1. In the music area, open the layout in which you want to swap pages.

2. In the Pages section of the Pages panel, select the overridden page whose overrides you
want to swap with another page.
Pages with overrides have markings in their top left corners.

3. Swap the selected page with another page in any of the following ways:

● In the action bar, click Swap with Previous Page.

● In the action bar, click Swap with Next Page.

RESULT
The selected page exchanges the position with the previous or next page within the sequence of
pages in the layout.
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Flow headings
Flow headings allow you to show the titles of flows immediately above their first system
automatically. They function like templates, in much the same way as master pages.

Flow headings exist as part of master page sets. By default, Dorico Pro provides one flow
heading in each master page set, which contains tokens to display the flow number and flow
title. This is the default for all flow headings, but you can insert flow heading changes to
individual pages and ranges of pages.

Flow headings are automatically inserted above the first system of the flow to which they apply,
meaning they do not have a fixed vertical position on the page like other frames. They also
occupy vertical space within music frames. You can change the margins for the space above and
below flow headings on a per-layout and on a per-page basis by inserting flow heading changes.

Frames in flow headings appear with dashed lines instead of solid lines to help you identify them.
You can move flow heading frames in the same ways as moving any other frames, but this
creates a master page override.

Dashed lines showing the edges of a flow heading text frame

RELATED LINKS
Tacets on page 352
Hiding/Showing flow headings on page 346
Master page sets on page 302
Master page overrides on page 308
Text tokens on page 332
Inserting flow heading changes on page 315

Flow heading editor
The flow heading editor allows you to view and change the format of flow headings.

It functions similarly to the master page editor; however, the background of the flow heading
editor is a different color to help you identify what you are editing.

You can open the flow heading editor in the following ways:

● Double-click a flow heading in the Flow Headings section of the Pages panel.

● Select a flow heading in the Flow Headings section of the Pages panel and click Edit Flow
Heading.

You can customize flow headings in the master page editor, including inputting extra frames and
editing/moving existing text and graphics frames. You can also change the vertical alignment of
text in text frames and use text editor options to format the appearance and horizontal
alignment of text in text frames.

NOTE

● You cannot input music frames in flow headings.
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● Frames in flow headings can only have right and left edge constraints, they cannot have
top or bottom constraints. This is because flow headings have no fixed vertical position.

You can position frames anywhere in the flow heading editor, as Dorico Pro always uses the top
of the highest frame and bottom of the lowest frame on the page in the editor to determine the
dimensions of the flow heading. However, we recommend that you keep the overall height of
flow headings as small as possible to reduce the amount of music they consequently displace in
music frames.

Unlike master pages, flow headings appear the same whether they are on left-hand or right-
hand pages, so only a single page is shown in the flow heading editor.

A flow heading in the flow heading editor

RELATED LINKS
Pages panel on page 295
Text editor options in Engrave mode on page 371
Changing the horizontal alignment of text in text frames on page 339

Customizing flow headings
You can customize flow headings according to your needs in the flow heading editor. Changing a
flow heading affects the appearance of flow headings in all layouts that use that flow heading.

PROCEDURE

1. In the Pages panel, double-click a flow heading in the Flow Headings section.
The flow heading editor opens in the music area.

2. In the flow heading editor, change the layout of the flow heading. For example, you can
input a graphics frame or change the vertical alignment of text in the text frame.

3. Click Apply, then Close.

RELATED LINKS
Inputting frames on page 322
Moving frames on page 323
Changing the size/shape of frames on page 323
Paragraph Styles dialog on page 366
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Adding flow headings
You can add new flow headings to master page sets. Each master page set can have multiple
custom flow headings, but only a single default flow heading.

PROCEDURE

1. In the music area, open a layout that uses the master page set to which you want to add
flow headings.

NOTE

You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2. In the Pages panel, click New Flow Heading in the Flow Headings action bar to open the
New Flow Heading dialog.

3. In the New Flow Heading dialog, enter a name for the new flow heading into the Name
field.

4. Select the existing flow heading on which you want to base the new flow heading from the
Based on menu.

NOTE

● Flow headings based on existing flow headings retain a link to the Based on flow
heading. This means some changes you make to the Based on flow heading, such
as changing the font size of text in text frames, also affect the new flow heading and
vice versa.

● Selecting (None) always creates a flow heading without any formatting but the page
margins.

5. Choose one of the following flow heading types for your new flow heading:

● Default

● Custom

NOTE

If you select Default, the new flow heading replaces that existing default flow heading, as
each master page set can only have a single default flow heading.

If you want to create a new flow heading without replacing any existing flow headings,
choose Custom.

6. Click OK to save your changes and close the dialog.

RESULT
A new flow heading of the selected type is added to the selected master page set.

AFTER COMPLETING THIS TASK
You can apply flow headings to individual pages in layouts that use the master page set to which
they belong.

RELATED LINKS
Master page sets on page 302
Inserting flow heading changes on page 315
Hiding/Showing flow headings on page 346
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Renaming flow headings
You can change the names of flow headings, including default flow headings and your own
custom flow headings.

PROCEDURE

1. In the music area, open a layout that uses the master page set containing the flow
heading you want to rename.

NOTE

You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2. In the Flow Headings section of the Pages panel, click the flow heading pair that you want
to rename.

3. In the action bar, click Rename Flow Heading to open the Rename Flow Heading dialog.

4. Enter the name you want in the Name field.

5. Click OK to save your changes and close the dialog.

Deleting flow headings
You can delete flow headings from master page sets.

NOTE

You cannot delete Default flow headings. Every master page set must contain at least a Default
flow heading. You can replace Default flow headings by adding a new flow heading and setting
its type to Default.

PROCEDURE

1. In the music area, open a layout that uses the master page set containing the flow
heading you want to delete.

NOTE

You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2. In the Flow Headings section of the Pages panel, click the flow heading that you want to
delete.

3. In the action bar, click Delete Flow Heading.

RESULT
The selected flow heading is deleted. You can undo this action if you deleted a flow heading in
error.
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Frames
Frames allow you to position your music, additional text, and graphics anywhere inside the
margins of a page.

Frames are rectangular boxes that can be positioned inside the page margins that have been
defined for a layout. In Engrave mode, you can see and adjust frames according to your needs. In
Dorico Pro, there are the following types of frames:

● Music frames that show the music of selected players and flows

● Text frames that allow you to enter text and text tokens

● Graphics frames that allow you to load images or illustrations in a variety of formats

For every frame, you can specify constraints that define the relationship between the sides of the
frame and the corresponding page margins.

RELATED LINKS
Flows in Dorico Pro on page 31
Layouts in Dorico Pro on page 32
Frame constraints on page 340
Music frames on page 325
Text frames on page 331
Graphics frames on page 340
Frame breaks on page 356
Text tokens on page 332

Inputting frames
You can input frames on pages manually, including on both individual pages and on master
pages in the master page editor. You can input music frames, text frames, and graphics frames.

PREREQUISITE
If you want to input frames on a master page, you have opened the master page in the master
page editor.

PROCEDURE

1. In the Engrave toolbox, click Frames to show the Formatting panel.

2. In the Insert Frames section, choose one of the following types of frames:

● Insert Music Frame

● Insert Text Frame

● Insert Graphics Frame

3. Click and drag in the music area to input the selected frame type.
You can draw a frame of any size and shape, as long as it fits within the page margins.

RESULT
When you release the mouse, the type of frame you chose is input on the page.
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AFTER COMPLETING THIS TASK
You can change the size of the frame or define its constraints. If you inserted a music frame, you
can determine which parts of your score you want to display in the frame. If you inserted a text
frame, you can enter text. If you inserted a graphics frame, you can load a graphics file.

RELATED LINKS
Frame constraints on page 340
Music frames on page 325
Text frames on page 331
Graphics frames on page 340
Music frame selectors on page 328
Master page editor on page 306

Moving frames
You can move individual frames around pages, including master pages, after they have been
inserted. However, you cannot move frames beyond page margins.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to move frames on a master page, you have opened the master page in the
master page editor.

PROCEDURE

1. Select the frames you want to move.

2. Move the frames in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

Changing the size/shape of frames
You can change the size and shape of individual frames on pages, including on master pages,
after they have been inserted.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to change the size/shape of frames on a master page, you have opened the
master page in the master page editor.

PROCEDURE

1. Select the middle handle on an edge of the frame whose size or shape you want to
change.
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NOTE

You can only select a single handle on a single frame at a time.

2. Move the handle in any of the following ways:

● Press Alt-Right Arrow to move it to the right.

● Press Alt-Left Arrow to move it to the left.

● Press Alt-Up Arrow to move it upwards.

● Press Alt-Down Arrow to move it downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag the handle to the right/left or upwards/downwards.

NOTE

You can only move handles on the right/left edges of frames to the right/left. You can only
move handles on the top/bottom edges of frames upwards/downwards. For example, if
you want to make a frame wider, you can select the middle handle on the right edge of the
frame and move it to the right.

3. Optional: Repeat steps 1 and 2 for any other edge of the frame you want to move to
achieve the size and shape you want.

RELATED LINKS
Master page editor on page 306

Selecting frame handles
You can select an individual handle on a frame, and you can switch between having a handle
selected and having the whole frame selected.

PREREQUISITE
Frames is selected in the Engrave toolbox.

PROCEDURE

1. Select a frame handle in any of the following ways:

● Select any handle on the frame and press Right Arrow/Left Arrow/Up Arrow/
Down Arrow to select other handles around the edge of the frame.

● Select the frame, press Tab to switch to having the handle in the top left corner
selected, then press Right Arrow/Left Arrow/Up Arrow/Down Arrow to select
other handles around the edge of the frame.

● Click a handle on the frame.

NOTE

You can only select a single handle on a single frame at a time.

2. Optional: Switch back to having the whole frame selected at any time by pressing Tab.
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Copying frames
You can copy individual frames from one page to other pages in layouts, for example, if you want
the same frame to appear on multiple pages at exactly the same position. You can also copy
frames to the same page, for example, if you want to duplicate a frame on a page.

NOTE

This does not apply to frames on master pages. You can copy frames on master pages when
customizing the master page.

PREREQUISITE
Frames is selected in the Engrave toolbox.

PROCEDURE

1. In the music area, open the layout in which you want to copy frames to other pages.

2. Select the frames you want to copy, which can be on multiple pages.

3. In the Pages section of the Pages panel, Ctrl/Cmd-click the pages to which you want to
copy the selected frames.

4. Right-click in the Pages section and choose Copy Selected Frames to Selected Pages
from the context menu.

RESULT
All selected frames are copied to the selected pages at the same positions on the page. If you
copied frames to their original page, they overlay their original exactly.

Music frames
Music frames display the music in your project in a specified order. You can control which parts
of the project are displayed using master page music frames and layout music frames.

Both types of music frames display the music and notations you have input into the project
according to their music frame selectors, such as filtering only selected players or flows.

A master page music frame

Master page music frames

Master page music frames exist only on master pages, meaning you can only input and edit
master page music frames in the master page editor. They can only have master page frame
chains assigned to them.

By default, the master pages in the master page sets provided by Dorico Pro include master page
music frames with a single master page frame chain assigned to them. This frame chain is set to
display all players in all flows in each layout. These master pages are set to apply to all pages in
all layouts in your project by default according to the layout type.
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You can input multiple master page music frames on a single master page, and change their size
and shape to whatever you want. If you want to connect separate master page music frames on
the same page, you can assign the same frame chain to them.

Layout music frames

Layout music frames exist only on individual pages in layouts, meaning you can only input and
edit layout music frames in individual layouts in the music area. Layout music frames can have
both master page and layout frame chains assigned to them. However, assigning a master page
frame chain to a layout frame does not affect the master page.

You can input multiple layout music frames on a single page, and change their size and shape to
whatever you want. For example, layout music frames allow you to insert small musical excerpts
from a different flow within footnotes or in an index.

If you want to connect separate layout music frames on the same page, you can assign the same
frame chain to them.

IMPORTANT

Layout music frames are considered overrides to master pages. If you remove all overrides on
layout pages, all your layout music frames are also removed.

Identifying master page music frames and layout music frames

To differentiate between master page music frames and layout music frames, you can check the
following:

● Flow and player selectors: On individual pages in layouts, master page music frames never
allow you to change the selection of flows or players. Those selectors are grayed out
because they can only be edited on master pages in the master page editor.

Flow and player selectors grayed out on a master page music frame

● Frame chains: Frame chains assigned to layout music frames start with an “L” by default.
Frame chains assigned to master page music frames start with an “M” by default.

RELATED LINKS
Music frame selectors on page 328
Master pages on page 301
Master page overrides on page 308
Master page editor on page 306
Changing the size/shape of frames on page 323

Music frame chains
A music frame chain is a collection of music frames that show the same selection of music in a
set order, often in sequence. Music frame chains are automatically created when you create a
music frame on a page, and can include any number of frames, including only a single music
frame.

You can control the music shown in each music frame chain by player and by flow using music
frame selectors.

In Dorico Pro, there are different types of frame chains.

Master page frame chains

Master page frame chains can be created and fully edited only on master pages in the master
page editor; you cannot change the flow and player filters for master page frame chains in
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individual layouts. Whenever you create a music frame on a master page, you automatically start
a frame chain.

Frame chains that start with an “M”, such as “MA”, are master page frame chains. You can have
multiple master page frame chains on each page, such as “MA” and “MH”.

The default master pages contain a single frame chain that is set to display all flows and all
players in the layout. Therefore, Dorico Pro automatically creates enough pages and frames to
display all flows in all the layouts that use those master pages.

NOTE

● To ensure that a score continues automatically on subsequent pages, the music frame
must be created at least on the First and Default master pages.

● All frames in the same music frame chain must display the same flows and players. For
example, you cannot have the first frame in a frame chain show just the violin but have the
second frame show all players.

● Dorico Pro shows flows in layouts as many times as you want, not only once. Therefore, if
you want to change the formatting of some flows in a particular layout, such as showing
them in layout frame chains instead of the master page frame chain, but do not want
those flows to appear more than once, you must remove those flows from the Filter by
Flows list on the master page frame chain. As this affects which flows are automatically
displayed in all layouts that use the same master page, we recommend that in such cases
you create a separate master page for the layout in which you want to change the
formatting.

Layout frame chains

Layout frame chains can only be created and edited on pages in individual layouts. If you create a
music frame and assign it to a layout frame chain in a layout, it is only displayed on that page in
that layout and starts its own frame chain. If you want the music frame to be continued on
subsequent pages, you must create music frames on all the pages in the layout on which you
want the chain to appear and assign all of these frames to the same layout frame chain.

Frame chains that start with an “L”, such as “LA”, are layout frame chains. You can have multiple
layout frame chains on each page, such as “LA” and “LB”.

NOTE

● All frames in the same music frame chain must display the same flows and players. For
example, you cannot have the first frame in a frame chain show just the violin but have the
second frame show all players.

● Assigning flows to layout frame chains does not stop those flows also appearing in the
master page frame chain, if the frame chain in the master page applied to the layout is set
to include those flows; by default, master page frame chains are set to display all flows in
the project.

RELATED LINKS
Master pages on page 301
Master page editor on page 306
Layouts in Dorico Pro on page 32
Music frame selectors on page 328
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Music frame selectors
When Frames is selected in the Engrave toolbox, music frames show selectors that allow you to
change the music displayed, for example, changing which flows and players are displayed in
each frame chain.

Selectors on music frames allow you to control which flows and players are displayed in frame
chains, and the order in which the selected music is shown in frames on the page. Frame chains
can include any number of frames, including only a single music frame.

Every music frame shows the following selectors:

1 Frame Chain
Allows you to select which frame chain the music frame follows. Frames that start with an
“M” have master page frame chains assigned to them; frames that start with an “L” have
layout frame chains assigned to them.
The second letter allows you to identify different frame chains of the same type. It is
automatically generated and reflects the order in which you created the frame chains, for
example, “LA” is the first layout frame chain you create in the layout and “LB” is the second.

2 Frame Order
If you have two or more music frames in the same frame chain on the same page, you can
use this option to specify the order in which music flows through the frames. For example,
when the Frame Order is 1, that frame is the first frame in the frame chain.

3 Filter by Flow
If you have several flows in your project, you can specify which flows you want to display in
this frame chain. For example, you can show only a single flow, a selection of flows, or all
flows.

4 Filter by Player
If you have several players in your project, you can specify which players you want to
display in this frame chain. For example, you can show only a single player, multiple
players, or all players.

NOTE

You can only edit the Filter by Flow and Filter by Player selectors of master page music frames
on master pages in the master page editor.

RELATED LINKS
Frame constraints on page 340
Changing the size/shape of frames on page 323

Engrave mode
Frames 

328
Dorico 2.2.20



Assigning frame chains to music frames

You can assign existing music frame chains to new music frames and change the frame chain of
an existing music frame. This applies to both master page and layout music frames.

NOTE

New music frames on a page always start a new frame chain, regardless of their type.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to assign music frame chains to frames on a master page, you have opened
the master page in the master page editor.

PROCEDURE

1. In the music frame whose frame chain you want to change, click Frame Chain.

2. Select the frame chain that you want to assign to the music frame.

NOTE

● You cannot select layout frame chains for frames in the master page editor.

● If you do not want to use any of the available frame chains, click Unlink.

3. Click outside of the selector to close it.

RESULT
The selected frame chain is assigned to the music frame. All settings from the frame chain are
applied to the frame, such as the players and flows displayed.

RELATED LINKS
Master page editor on page 306

Unlinking music frames from frame chains

You can unlink music frames from music frame chains, for example, if you want to change the
music frame to a new frame chain without deleting it.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to unlink frames from music frame chains on a master page, you have opened
the master page in the master page editor.

PROCEDURE

1. In the music frame you want to unlink, click Frame Chain.

2. Click Unlink.

RESULT
The music frame is unlinked from its previous frame chain. A new frame chain is automatically
created for the unlinked frame.
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● Unlinking a layout music frame from a layout frame chain changes it to a new layout frame
chain.

● Unlinking a layout music frame from a master page frame chain changes it to a new layout
frame.

● Unlinking a master page music frame from a master page frame chain changes it to a new
master page frame chain.

Changing the order of music frames

If you have at least two music frames of the same type in the same frame chain on a page, you
can change the order in which music is displayed across the frames.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to change the order of music frames on a master page, you have opened the
master page in the master page editor.

PROCEDURE

1. In one of the music frames whose order you want to change, click Frame Order.

2. Select the ordinal number for this frame from the Frame Order menu.

3. Click outside of the selector to close it.

RESULT
The position of the selected frame in the frame chain order is changed by exchanging its order
number with the frame previously assigned that number. For example, changing the number of
the second frame in a frame chain to 1 causes the frame originally number 1 to become number
2 in the frame chain order.

Assigning flows to frame chains

You can change which flows are shown in each frame chain, for example, if you want to exclude
some flows from the master page frame chain because you want to display those flows in layout
frame chains instead.

NOTE

● You can assign flows to both master page frame chains and layout frame chains. However,
you can only change the flows assigned to layout frame chains in individual layouts, and
you can only change the flows assigned to master page frame chains in the master page
editor.

● Changing the assigned flows affects all frames in the frame chain.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to change the flows assigned to music frame chains on a master page, you
have opened the master page in the master page editor.

PROCEDURE

1. In the music frame whose assigned flows you want to change, click Flows.

2. Select the flows you want to be displayed in the frame chain from the Filter by Flow menu.
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3. Click outside of the selector to close it.

RESULT
The music frame shows the selected flows. If you changed the flows assigned to a master page
music frame, the number of pages in the layouts to which the master page is applied
automatically updates. For example, if you assigned an extra flow to the master page frame
chain, enough extra pages and frames to display that flow are added to the corresponding
layouts.

Assigning players to frame chains

You can change which players are included in different frame chains, for example, if you are
writing a piano duet and only want to show one piano on left pages and the other piano on right
pages.

NOTE

● You can assign players to both master page frame chains and layout frame chains.
However, you can only change the players assigned to layout frame chains in individual
layouts, and you can only change the players assigned to master page frame chains in the
master page editor.

● Changing the assigned players affects all frames in the frame chain.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to change the players assigned to music frame chains on a master page, you
have opened the master page in the master page editor.

PROCEDURE

1. In the music frame whose assigned players you want to change, click Players.

2. Select the players you want to be displayed in the music frame from the Filter by Player
menu.

3. Click outside of the selector to close it.

RESULT
Which players are displayed in the frame chain is changed.

NOTE

The staff size is not changed automatically, meaning staves can overlap in small frames in the
frame chain.

Text frames
Text frames allow you to add text, including tokens, to your project, independently of rhythmic
positions in the score. Adding text frames to pages individually, and not on a master page, is
considered a master page override.

You can open the text editor for individual frames in any of the following ways:

● Activate Frames in the Formatting panel, select the text frame, and press Return.
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TIP

You can switch between selecting a frame handle and the whole frame by pressing Tab.

● Double-click within the text frame.

Text frame

RELATED LINKS
Inputting frames on page 322
Entering text in text frames on page 337
Text formatting on page 363
Changing the default horizontal alignment of text styles on page 368
Changing the horizontal alignment of text in text frames on page 339
Master page overrides on page 308
Changing the size/shape of frames on page 323

Text tokens
Text tokens are codes that you can use as substitutes for information stored in your project, such
as titles, composers, and the time and date. This can reduce the risk of mistakes or outdated
information appearing in your project. Text tokens are also known as “wildcards” or “text codes”.

For example, if you use a token for the title of your project, you can change the project title in the
Project Info dialog as often as you want, and the project title in every layout in your project is
updated automatically.

Tokens can refer to the project-wide information on the Project page in the Project Info dialog,
or to individual Flow pages in the Project Info dialog. Tokens can also refer to the current time
and date or the time and date the project was last saved.

NOTE

● You can only use text tokens in text frames. You cannot use tokens in text/system text
objects.

● Flow tokens refer to the nearest flow below the top edge of their text frame. When the top
edge of a text frame containing a flow token is in line with or above the top staff line of the
first stave in a system, it then refers to that flow.

You can specify the flow number to which you want flow tokens to refer, such as
{@flow2title@}. This always shows the specified flow, regardless of the token’s position.

If you want to use tokens that refer to flow information on pages that contain no music,
such as title pages, you must specify the flow number in the token. For example, if you use
{@flowtitle@} on a title page containing no music frames, the token does not display any
information, but {@flow1title@} displays the title of the first flow in your project.

You can see the flow number of each flow in the Flows panel in Setup mode.

The following tokens are available in Dorico Pro:
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General tokens

Description Token

Page number {@page@}

Player list {@playerlist@}

Player names {@playernames@}

Layout name {@layoutname@}

Layout number, as set in the Layouts panel in
Setup mode

{@layoutnumber@}

Project/Flow-specific information tokens

Field in the Project Info
dialog

Token for Project page Token for Flow pages

Title {@projecttitle@} {@flowtitle@}

Subtitle {@projectsubtitle@} {@flowsubtitle@}

Dedication {@projectdedication@} {@flowdedication@}

Composer {@projectcomposer@} {@flowcomposer@}

Arranger {@projectarranger@} {@flowarranger@}

Lyricist {@projectlyricist@} {@flowlyricist@}

Artist {@projectartist@} {@flowartist@}

Copyist {@projectcopyist@} {@flowcopyist@}

Publisher {@projectpublisher@} {@flowpublisher@}

Editor {@projecteditor@} {@floweditor@}

Copyright {@projectcopyright@} {@flowcopyright@}

Work number {@projectworknumber@} {@flowworknumber@}

Composer dates {@projectcomposerdates@} {@flowcomposerdates@}

Composition year {@projectcompositionyear@} {@flowcompositionyear@}

Other information {@projectotherinfo@} {@flowotherinfo@}
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Per-flow tokens

Per-flow token function Token

Flow number of the current flow, according to
its position in the Flows panel in Setup mode

{@flownumber@}

Flow number of the current flow shown in
lower case Roman numerals, such as iii or xvi

{@flowNumberRomanLower@}

Flow number of the current flow shown in
upper case Roman numerals, such as III or XVI

{@flowNumberRomanUpper@}

Number of this page within the current flow,
counting from 1

{@flowPage@}

Total number of pages in the current flow {@flowPageCount@}

The displayed page number on which the
specified flow “n” begins, such as
{@flow3PageCount@}

{@flownPageCount@}

Duration of the current flow in minutes and
seconds

{@flowDuration@}

Duration of the specified flow “n” in minutes
and seconds, such as {@flow3Duration@}

{@flownDuration@}

Page number tokens

Page number token function Token

Total number of pages in the layout {@pageCount@}

Number of this page within the current flow,
counting from 1 for the first page of the flow
and including pages with no displayed page
number

{@flowPage@}

Total number of pages in the current flow {@flowPageCount@}

Displayed page number of the page on which
the specified flow “n” begins, according to its
position in the Flows panel in Setup mode

For example, {@flow5FirstPage@}

{@flownFirstPage@}

NOTE

{@flowPage@} and {@flowPageCount@} tokens only consider the flow that is active at the
beginning of the first system of the music frame closest to the top left corner of the page on
which the tokens are used.
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Time/Date tokens to show when the project was last saved

Time/Date description Time/Date example Token

Standard date and time string
(locale dependent)

Sun Dec 31 11:10:12 2017 {@projectdate@}

Four-digit year 2017 {@projectdateyear@}

Two-digit year 17 {@projectdateyearshort@}

Full month name (locale
dependent)

October {@projectdatemonth@}

Short month name (locale
dependent)

Oct {@projectdatemonthshort@}

Month as a decimal number,
range 1-12

10 {@projectdatemonthnum@}

Full weekday name (locale
dependent)

Friday {@projectdateday@}

Abbreviated weekday name
(locale dependent)

Fri {@projectdatedayshort@}

Day of month as decimal
number, range 1-31

24 {@projectdatedaynum@}

ISO 8601 date 2017-12-31 {@projectdateymd@}

Month day, year December 31, 2017 {@projectdatemdy@}

Day month year 31 December 2017 {@projectdatedmy@}

Time representation (locale
dependent)

11:10:12 {@projectdatetime@}

Hours:minutes, hour in 24-
hour clock range

23:10 {@projectdatetimeHHMM@}

Hours:minutes:seconds, hour
in 24-hour clock range

13:02:24 {@projectdatetimeHHMMSS@
}

Hour in 24-hour clock range 23 {@projectdatetimehour24@}

Hour in 12-hour clock range 11 {@projectdatetimehour12@}

Minute as decimal number,
range 00-59

10 {@projectdatetimeminute@}

Second as decimal number,
range 00-59

44 {@projectdatetimesecond@}
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Time/Date tokens to show the current time and date

Time/Date description Time/Date example Token

Standard date and time string
(locale dependent)

Sun Dec 31 11:10:12 2017 {@date@}

Four-digit year 2017 {@dateyear@}

Two-digit year 17 {@dateyearshort@}

Full month name (locale
dependent)

October {@datemonth@}

Short month name (locale
dependent)

Oct {@datemonthshort@}

Month as a decimal number,
range 1-12

10 {@datemonthnum@}

Full weekday name (locale
dependent)

Friday {@dateday@}

Abbreviated weekday name
(locale dependent)

Fri {@datedayshort@}

Day of month as decimal
number, range 1-31

24 {@datedaynum@}

ISO 8601 date 2017-12-31 {@dateymd@}

Month day, year December 31, 2017 {@datemdy@}

Day month year 31 December 2017 {@datedmy@}

Time representation (locale
dependent)

11:10:12 {@datetime@}

Hours:minutes, hour in 24-
hour clock range

23:10 {@datetimeHHMM@}

Hours:minutes:seconds, hour
in 24-hour clock range

13:02:24 {@datetimeHHMMSS@}

Hour in 24-hour clock range 23 {@datetimehour24@}

Hour in 12-hour clock range 11 {@datetimehour12@}

Minute as decimal number,
range 00-59

10 {@datetimeminute@}

Second as decimal number,
range 00-59

44 {@datetimesecond@}
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RELATED LINKS
Project Info dialog on page 90
Player, layout, and instrument names on page 96
Flow names and flow titles on page 119
Renumbering layouts on page 124

Entering text in text frames
You can enter text in text frames, format the text, and insert separate paragraphs and line
breaks. You can also edit text in text frames at any time, for example, if you later want text to be
italic instead of bold.

PREREQUISITE
If you want to enter text in a text frame on a master page, you have opened the master page in
the master page editor.

PROCEDURE

1. Double-click the text frame into which you want to enter text to open the text editor.

2. Enter the text you want.

3. Optional: Press Return to insert a new paragraph.

4. Optional: Press Shift-Return to insert a line break.

5. Optional: Format the text using the text editor options.

6. Press Esc or Ctrl/Cmd-Return to close the text editor.

RESULT
Text is entered into the text frame.
If you insert a new paragraph or line, the cursor jumps to the beginning of the new paragraph or
line.

RELATED LINKS
Text editor options in Engrave mode on page 371

Adding borders to text frames
You can add borders to individual text frames, for example, if you want to make its boundaries
clear.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to add borders to text frames on a master page, you have opened the master
page in the master page editor.

PROCEDURE

1. Select the text frames to which you want to add borders.

2. In the Properties panel, activate Show border in the Text group.

RESULT
Borders are added to the selected text frames.

AFTER COMPLETING THIS TASK
You can change the thickness of text frame borders and you can change the padding between
the borders and contents of text frames.
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Changing the thickness of text frame borders

You can change the thickness of text frame borders individually. There is no default setting for
the thickness of text frame borders.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to change the thickness of text frame borders on a master page, you have
opened the master page in the master page editor.

PROCEDURE

1. Select the text frames whose border thickness you want to change.

2. In the Properties panel, change the value for Border thickness in the Text group.

RELATED LINKS
Changing the thickness of text object borders on page 376

Changing the padding in text frames

You can change the padding of individual text frames, which affects the distance between the
edges of frames and the text within them.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to change the padding of text frames on a master page, you have opened the
master page in the master page editor.

PROCEDURE

1. Select the text frames whose padding you want to change.

2. In the Properties panel, activate Padding in the Text group.

3. Change the value in the value field.

RESULT
The padding between all edges of the selected text frames and the text within them is changed.

Changing the vertical alignment of text in text frames
You can change the vertical alignment of text in text frames. You can do this on master pages,
which changes the alignment of the selected text on all pages that use the master page format,
and on individual pages, which only changes the alignment of the selected text on that page.

PREREQUISITE

● Frames is selected in the Engrave toolbox.

● If you want to change the vertical alignment of text on a master page, you have opened
the master page in the master page editor.

PROCEDURE

1. Select the frames whose text vertical alignment you want to change.

2. In the Properties panel, select one of the following options from the Vertical alignment
menu in the Text group:

● Top
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● Center

● Bottom

RESULT
The vertical alignment of text in the selected text frames is changed.

NOTE

Changing the vertical alignment of text does not override its paragraph style. Any changes you
make later to the paragraph styles of text whose vertical alignment has been changed are
applied to the text.

RELATED LINKS
Master page editor on page 306
Paragraph Styles dialog on page 366

Changing the horizontal alignment of text in text frames
You can change the horizontal alignment of any text style in text frames, independently of the
paragraph style for that text.

If you change the alignment of text in text frames on master pages, the horizontal alignment of
text is changed on all pages that use those master page formats.

If you change the alignment of text in text frames on individual pages, this change is
independent of the paragraph style for that text and also independent of the master page
format. You can later remove any overrides made on individual pages and revert them to the
master page format.

NOTE

● Changes to text in text frames on master pages cannot be reset.

● Removing overrides removes all changes made to individual pages, not just changes to the
alignment of text in text frames.

PREREQUISITE
If you want to change the horizontal alignment of text on a master page, you have opened the
master page in the master page editor.

PROCEDURE

1. Double-click a text frame to open the text editor for that frame.

2. Select the text in the text frame whose horizontal alignment you want to change.

TIP

You can apply different paragraph styles to separate paragraphs in the same text frame.

3. Choose the horizontal alignment you want in the text editor.

4. Press Esc or Ctrl/Cmd-Return to close the text editor.

RESULT
The horizontal alignment of the selected text is changed.
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TIP

You can change the horizontal alignment of text styles project-wide in the Paragraph Styles
dialog.

RELATED LINKS
Paragraph Styles dialog on page 366
Paragraph style overrides on page 373

Graphics frames
Graphics frames allow you to load images or illustrations into your score in a variety of formats.

You can load graphics files in the following formats:

● .jpg or .jpeg

● .png

● .svg

Graphics frame

RELATED LINKS
Changing the size/shape of frames on page 323

Loading images into graphics frames
You can load images from your computer or server into your score.

PREREQUISITE
You have added a graphics frame, either to a master page or an individual layout.

PROCEDURE

1. Double-click in the graphics frame to open the File Explorer/macOS Finder.

2. In the File Explorer/macOS Finder, locate and select the file you want to load into the
graphics frame.

3. Click Open.

RESULT
The selected image is loaded into the frame.

Frame constraints
In Dorico Pro, constraints define the relationship between each of the four sides of a frame and
the corresponding page margins.

Frame constraints lock each side of frames to the corresponding page margin, meaning you can
change the page size, or the area that is defined by the page margin, while keeping the frame in

Engrave mode
Frames 

340
Dorico 2.2.20



proportion. For example, a music frame that fills the entire height and width of a page has
constraints on all four sides. All sides have an inset of zero, which means that the edges of the
frames are in line with the page margins. If you change the size of the page, the frame size
changes accordingly so that it always fills the page, whatever the current page size.

NOTE

Page size and margins are set for each layout in Setup > Layout Options.

If you remove a constraint from one side of a frame, that unlocks that side of the frame from the
page margin, meaning you can determine a fixed width/height that prevents that side of the
frame from adjusting, even if the page size changes.

EXAMPLE
If you have set a frame for a header, you might want the left and right sides to be locked to the
left and right margins of the page. For the top side of the frame, you might want to lock it to the
top margin, but want to keep the height of the header fixed. In this case, you can remove the
lock to the bottom margin and specify a fixed height by moving the side of the frame, or by
entering a value in one of the value fields in the Properties panel.

In the Frames section of the formatting panel, you can define the constraints for all types of
frames that are available in Dorico Pro. All new frames have active constraints on all sides by
default. You can unlock two sides of a frame to specify a fixed width or height. For example, if
you remove the lock to the top margin, you can also remove the lock to the right/left margin.

RELATED LINKS
Layout Options dialog on page 90

Defining frame constraints
You can determine on which sides of frames you want to apply constraints.

PREREQUISITE
If you want to define the constraints of frames on a master page, you have opened the master
page in the master page editor.

PROCEDURE

1. In the Engrave toolbox, click Frames to show the Formatting panel.

2. In the music area, select the frame whose constraints you want to define.

3. In the Constraints section of the Formatting panel, click the constraint that corresponds
to the side of the frame that you want to change.

Locked constraint Unlocked constraint

4. Move the unlocked side of the frame to the position you want.

TIP

You can also enter fixed values for Height or Width in the Frames group of the Properties
panel.

RELATED LINKS
Formatting panel on page 292
Master page editor on page 306
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Customizing master pages on page 307

Page layouts
In Dorico Pro, the layout of pages is determined by their margins, the master page applied to
them, any casting off values applied to them, system and frame breaks, and frame padding.

Casting off, meaning the process of determining a set number of bars per system and systems
per page, allows you to fix a regular appearance across entire layouts.

System and frame breaks allow you to adjust layouts on a local level, by determining which bars
are shown on each system and where music is pushed into the next frame.

Frames cannot exceed the boundaries set by the margins of the layout, which you can change on
the Page Setup page in Setup > Layout Options. You can change the size of margins in
millimeters on each edge of each page, and choose one of the following styles of margins:

● Same
All pages in the selected layouts have the same margins.

● Different
Left and right pages in the selected layouts can have completely different margins.

● Mirrored
Left and right pages in the selected layouts use the same margin values but they
correspond to inside/outside edges of pages.

Music frames in the default master pages have padding that ensures musical material displayed
within the frame remains on the page. For example, if music frames have no padding, the top
line on the top staff in the frame is positioned at the top of the frame. Any notes that require
ledger lines above the staff might then be positioned off the top of the page. You can change the
padding of all music frames in each layout in Layout Options, and change the padding of
individual music frames in Engrave mode using properties in the Properties panel.

Frame constraints are used to lock the edges of frames to edges of pages. This allows a single
master page to be applied to layouts with different paper sizes and remain consistently
proportioned.

RELATED LINKS
Frame constraints on page 340
Master pages on page 301
Master page editor on page 306
Casting off on page 355
Tacets on page 352
Layouts on page 120
Flows on page 117
Players on page 94

Changing page margins
You can change the page margins of each layout independently, for example, if you want wider
margins for layouts in your project that will be spiral bound.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the page margins.
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By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Page Margins section, choose one of the following options for Page margins:

● Same

● Different

● Mirrored

5. Optional: Change the margins by changing the values in the value fields.

6. Click Apply, then Close.

RESULT
The page margins in the selected layouts are changed. Any frames in the selected layouts with
fixed constraints are automatically moved or resized as required.

RELATED LINKS
Frame constraints on page 340

Changing the page size and orientation
You can change the page size and orientation of each layout independently. For example, you
can use a large, landscape page in full score layouts and a small, portrait page for part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the page size and/or
orientation.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Page Size section, select a page size from the Size menu.
For example, you can select fixed page sizes, such as A3 or Letter, or select Custom to
define your own page size.

5. Optional: If you selected Custom, change the Width and Height of the page by changing
the values in the value fields.

6. Choose one of the following options for Orientation:

● Portrait

● Landscape

7. Optional: Repeat steps 2 to 6 for other layouts whose page size/orientation you want to
change.

8. Click Apply, then Close.

RESULT
The page size is changed for all the selected layouts.

NOTE

Changing the page size of layouts might not change the paper size automatically selected for
those layouts in the Print Options panel in Print mode. For example, if your default printer
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cannot print the page size selected for layouts, the largest paper size the printer can handle is
selected. Similarly, if you had already set options for printing layouts before changing the page
size in Layout Options, Dorico Pro attempts to preserve your original print options.

Similarly, the page orientation is independent of the paper orientation. We recommend that you
check that layouts have the correct paper orientation set for their page orientation in the Print
Options panel in Print mode before printing/exporting, as it is possible to print landscape layouts
on portrait paper and vice versa.

RELATED LINKS
Page sizes and paper sizes on page 482
Paper orientation on page 483
Paper size and orientation setup on page 483
Changing the default staff/system spacing on page 393

Starting layouts on left-hand pages
By default, all layouts start on a right-hand page, as convention dictates that odd numbered
pages are always on the right-hand page. However, you can set individual layouts to start on a
left-hand page, for example, to facilitate page turns better in that layout.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts you want to start on a left-hand page.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Page Numbers section, change the value for Initial page number to an even
number.

5. Click Apply, then Close.

RESULT
The first page in the selected layouts is shown on a left-hand page when the initial page number
is even.

Allowing/Disallowing multiple flows on the same page
You can allow/disallow new flows to be shown on the same page as previous flows if there is
space, for example, to reduce the number of pages required for parts in works with multiple
movements. By default, new flows are allowed on the same page in part layouts and are not
allowed in full score layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to allow multiple flows to be
shown on each page.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Flows section, choose one of the following options for New flows:
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● Always start new page

● Allow on existing page

5. Click Apply, then Close.

RESULT

● When you choose Always start new page, flows in the selected layouts always begin at
the start of the next page after the end of the previous flow.

● When you choose Allow on existing page, flows in the selected layouts continue
immediately after each other, including within the same music frame if there is sufficient
space. Flow headings are automatically shown above the start of flows if you have chosen
to show flow headings in the selected layouts.

NOTE

Flows are not automatically split into separate music frames. You must insert frame breaks
manually to divide flows into separate music frames if required.

RELATED LINKS
Text tokens on page 332
Inputting frames on page 322
Casting off on page 355
Changing the flows assigned to layouts on page 122
Changing the players assigned to flows on page 118
Hiding/Showing information in running headers above flow headings on page 348

Changing when the First master page is used
You can change the circumstances when the First master page is used in each layout
independently, for example, if you want to use it for the start of every flow in the full score but
only want to use it for the first flow in part layouts, even when subsequent flows start at the top
of the page.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change when the First master
page is used.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Flows section, choose one of the following options for Use ‘First’ master page:

● Never

● First flow only

● Any flow starting at top of page

5. Click Apply, then Close.

RESULT

● Choosing Never means the First master page is not used for any page in the selected
layouts.

● Choosing First flow only means the First master page is used for the first page in the
layout but no other pages, even if some subsequent flows start at the top of a page.
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● Choosing Any flow starting at top of page means the First master page is used for all
pages in the layout that begin with the start of a flow.

RELATED LINKS
Layout Options dialog on page 90

Hiding/Showing flow headings
You can hide/show flow headings in each layout independently, for example, if your project only
contains a single flow and you only want to show the project title. You can also hide the heading
for the first flow but show flow headings for subsequent flows.

PREREQUISITE
You have allowed multiple flows on the same page in the layouts in which you want to show flow
headings.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show flow headings.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Flows section, choose one of the following options for Show flow headings:

● Never

● Not for first flow

● For all flows

5. Click Apply, then Close.

RESULT
Flow headings are shown above the first system in each flow in the selected layouts when you
choose For all flows, hidden when you choose Never, and hidden above the first system in the
first flow but shown above all other flows when you choose Not for first flow.
They are automatically positioned above each flow and below the preceding flow according to
the margins set for each layout.

RELATED LINKS
Allowing/Disallowing multiple flows on the same page on page 344

Changing the margins above/below flow headings
You can change the margins both above and below flow headings, which control the gap
between the preceding flow and the flow heading, and the gap between the flow heading and
the start of the next flow.

PREREQUISITE
Flow headings are shown in the layouts in which you want to change the margins above/below
flow headings.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.
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2. In the Layouts list, select the layouts in which you want to change the margins above/
below flow headings.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Flows section, change the values for Flow heading top margin and/or Flow
heading bottom margin.

5. Click Apply, then Close.

RESULT
Changing the value for Flow heading top margin increases/decreases the gap between the top
of flow headings and the end of the preceding flow.
Changing the value for Flow heading bottom margin increases/decreases the gap between the
bottom of flow headings and the start of the next flow. For example, when the bottom margin is
set to 0, the bottom of the lowest frame in the flow heading aligns with the top staff line of the
first system in the flow below the flow heading.

NOTE

● If you want to change the margins above/below an individual flow heading, you can do
this by inserting a flow heading change and changing the margins at the change.

● If you want to move individual flow headings upwards/downwards, you can do this by
moving the system handle of the first system of the flow to which the flow headings apply.
You can also move the frames in flow headings individually, but this creates a master page
override, preventing Dorico Pro from updating the page if, for example, you later change
the master page format.

EXAMPLE

Flow heading with default margins above/below Flow heading with decreased margins above/below

RELATED LINKS
Inserting flow heading changes on page 315
Moving individual staves/systems vertically on page 396
Master page overrides on page 308
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Hiding/Showing information in running headers above flow
headings

You can hide/show flow titles, page numbers, and flow page numbers separately when they
appear above flow headings at the top of a new page in each layout independently. Hiding such
information in running headers is a custom in publishing.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show information in
running headers above flow headings.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Flows section, choose one of the following options for Flow title in header:

● Show above flow heading

● Hide above flow heading

5. Choose one of the following options for Page number in header:

● Show above flow heading

● Hide above flow heading

6. Choose one of the following options for Flow page number in header:

● Show above flow heading

● Hide above flow heading

7. Click Apply, then Close.

RESULT
The corresponding information is hidden/shown when they appear above flow headings at the
top of the page.

NOTE

In order to hide running header information, the top of the music frame containing the flow
heading frame must be lower than the top of text frames containing the corresponding
information. If the top of the music frame is the same height as a running header text frame, any
corresponding information in the text frame is shown, regardless of your setting.

RELATED LINKS
Frames on page 322
Master pages on page 301

Changing the music frame margins in layouts
You can change the margins in all music frames in individual layouts, for example, if you want
more padding at the top of music frames in part layouts containing lots of notes above the staff.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the music frame
margins.
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By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Music Frame Margins section, change the values for Top and/or Bottom.

5. Click Apply, then Close.

RESULT
The margins within all music frames in the selected layouts is changed.

RELATED LINKS
Changing the default staff/system spacing on page 393

Changing the padding in music frames individually
You can change the padding at the top/bottom of individual music frames, independently of your
setting for music frame margins for the layout.

PREREQUISITE
Frames is selected in the Engrave toolbox.

PROCEDURE

1. Select the music frames whose padding you want to change.

2. In the Properties panel, activate the following properties, individually or together, in the
Music group:

● Top padding

● Bottom padding

3. Change the padding by changing the values in the value fields.
For example, entering 0 for Top padding aligns the top staff line of the top staff in the
frame with the top of the music frame.

RESULT
The padding at the top/bottom of the selected music frames is changed. This only applies to the
layout currently open in the music area.
Deactivating the properties returns the selected music frames to your settings for music frame
margins for the layout.

Changing the justification of final systems
By default in Dorico Pro, the final systems in flows only justify to the full width of the page when
they are more than half full. You can change this setting in each layout independently.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the justification of the
final systems in flows.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Note Spacing in the page list.
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4. Optional: If you want the final systems in flows to justify fully always, deactivate Only
justify final system in flow when more than [n]% full.

5. Optional: If you want to change the minimum fullness of final systems before they justify,
change the value for Only justify final system in flow when more than [n]% full.

6. Click Apply, then Close.

RESULT
The automatic justification of the final systems in flows in the selected layouts is changed.

TIP

You can also change the width of individual systems independently of your default settings by
changing their start/end positions independently.

RELATED LINKS
Changing the start/end position of systems on page 390

Changing the vertical justification of staves/systems
You can change the minimum fullness threshold above which Dorico Pro automatically vertically
justifies staves and systems, which means they are evenly distributed to fill the height of frames.
You can also control whether staves and systems are both justified or only systems are justified.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the automatic vertical
justification of staves/systems.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Vertical Spacing in the page list.

4. In the Ideal Gaps section, choose one of the following options for Gap to use for divisi
staves:

● Staff to staff

● Braced staff to braced staff

5. In the Vertical Justification section, change the values for the following options,
individually or together:

● Justify distance between staves and systems when frame is at least [n]% full

● Justify distance only between systems when frame is at least [n]% full

6. Activate/Deactivate Justify staves when frame with single system is above this
threshold.

7. Click Apply, then Close.

RESULT
The automatic vertical justification of staves and systems in the selected layouts is changed.
Braced staves are never vertically justified.
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EXAMPLE

A page with staves and systems both justified The same page with only systems justified

RELATED LINKS
Per-layout vertical spacing options on page 393
Changing the default staff/system spacing on page 393

Hiding/Showing empty staves
You can hide/show empty staves differently in each layout in your project. For example, you can
show all staves, including empty staves, in a full score layout for the conductor but hide empty
staves in a full score layout intended for reference only.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show empty staves.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Vertical Spacing in the page list.

4. In the Hide Empty Staves section, choose one of the following options for Hide empty
staves:

● After first system

● All systems

● Never

5. Activate/Deactivate Allow individual staves of multi-staff instruments to be hidden.

6. Optional: For Players excluded from Hide Empty Staves, activate the checkbox for each
instrument you want to be shown regardless of your choice for Hide empty staves.

7. Click Apply, then Close.
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RESULT
Empty staves in the selected layouts are hidden/shown according to your choice. If you activated
Allow individual staves of multi-staff instruments to be hidden, any single empty staves in
multi-staff instruments, such as piano or harp, can be hidden in the selected layouts.

NOTE

● Instruments that have extra staves added to them are not affected by Allow individual
staves of multi-staff instruments to be hidden, even if some of their staves are empty.

● You cannot hide one staff of multi-staff instruments if you have chosen to show chord
symbols between the staves, which you can do in the Position section of the Chord
Symbols page in Engrave > Engraving Options.

RELATED LINKS
Extra staves on page 913
Changing the default staff/system spacing on page 393
Per-layout vertical spacing options on page 393

Tacets
Tacet is the indication used to show that a player does not play anything in an entire flow, which
might be a movement in a symphony or cue in a film score. In Dorico Pro, you can generate
tacets automatically.

Dorico Pro shows tacets for flows in part layouts when the following conditions are met:

● You have removed the player from the flows in which they do not play.

● The flows are assigned to the master page frame chain in the part layout.

● Multiple flows are allowed on the same page in the part layout.

● You have chosen to show tacets in the part layout.

An extract of a part layout where the player is tacet in the second flow

In Engrave mode, tacets behave like systems, meaning they have their own staff spacing handle
when Staff Spacing is activated. This allows you to move individual tacets and their flow
headings upwards/downwards. You can also insert system and frame breaks at the start of
tacets.
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NOTE

We do not recommend that you use Copy Staff Spacing and Lock Frame on pages where tacets
are the first or last system in frames. Because tacets do not contain any bars, Dorico Pro cannot
insert system or frame breaks at the ends of tacets in order to lock the frame contents.

You can change the text shown in tacets and the margin above/below them in each layout
independently.

You can further customize the project-wide appearance and design of tacets on the Tacets page
in Engrave > Engraving Options, and by formatting the Tacet paragraph style in Engrave >
Paragraph Styles.

RELATED LINKS
Changing the players assigned to flows on page 118
Assigning flows to frame chains on page 330
Allowing/Disallowing multiple flows on the same page on page 344
Staff spacing on page 391
Inserting system breaks on page 359
Inserting frame breaks on page 357
Paragraph Styles dialog on page 366
Engraving Options dialog on page 299
Flow headings on page 318

Hiding/Showing tacets
You can hide/show tacets in each layout independently, for example, if you want to show empty
bars or multi-bar rests in some layouts to allow those players to add in notes on those staves
later.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show tacets.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Players in the page list.

4. In the Tacets section, activate/deactivate Show tacet for flows where no players are
assigned.

5. Click Apply, then Close.

RESULT
Tacets are shown in the selected layouts when Show tacet for flows where no players are
assigned is activated and the player is not assigned to the flows in which they do not play.
When it is deactivated, any flows to which the player is not assigned do not appear in the layout.
When the player is assigned to those flows, all bars in the flow are shown in the part, split into
empty bars and multi-bar rests as appropriate for the flow.

TIP

If your project contains many short flows, which appear in part layouts as a single multi-bar rest
labelled “Tacet”, showing all the bars separately can help make the length of flows clearer. You
can do this by increasing the value for Minimum number of bars in flow to show ‘Tacet’ on the
Rests page in Engrave > Engraving Options.
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RELATED LINKS
Tacets on page 352
Multi-bar rests on page 864
Changing the players assigned to flows on page 118
Hiding/Showing multi-bar rests on page 865

Changing the text shown in tacets
You can change the text shown in tacets in each layout independently.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the tacet text shown.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Players in the page list.

4. In the Tacets section, enter the text you want in the Tacet text field.

5. Click Apply, then Close.

RESULT
The text shown in all tacets in the selected layouts is changed.

TIP

You can change the default padding to the right/left of tacets, show them with/without a border,
and change their border thickness project-wide on the Tacets page in Engrave > Engraving
Options.

Changing the margins above/below tacets
You can change the margins both above/below tacets in each layout independently, for example,
if you want smaller gaps between flow headings and tacets in some layouts to facilitate page
turns better.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the margins above/
below tacets.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Players in the page list.

4. In the Tacets section, change the values for Margin above tacet and/or Margin below
tacet.

5. Click Apply, then Close.

RESULT
Changing the value for Margin above tacet increases/decreases the minimum gap between
tacets and whatever precedes them.
Changing the value for Margin below tacet increases/decreases the minimum gap between
tacets and whatever follows them.
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TIP

You can change the default padding to the right/left of tacets, show them with/without a border,
and change their border thickness project-wide on the Tacets page in Engrave > Engraving
Options.

RELATED LINKS
Flow headings on page 318

Casting off
“Casting off” is the term used to encompass fixing the layout of pages of music, such as setting
the number of systems per page. In Dorico Pro, you can fix both the number of bars per system
and the number of systems per music frame for each layout independently.

RELATED LINKS
Per-layout vertical spacing options on page 393

Fixing the number of bars per system
You can define a fixed number of bars you want included in each system in each layout in your
project.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to fix the number of bars per
system.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Casting Off section, activate Fixed number of bars per system.

5. Change the number of bars you want in each system by changing the value in the value
field.

6. Click Apply, then Close.

RESULT
The number of bars automatically contained in each system in the selected layouts is changed. If
any of the layouts contain two-bar or four-bar repeat regions, Dorico Pro automatically adjusts
casting off to ensure phrases are not split across systems.

RELATED LINKS
Bar repeats on page 839
Inserting system breaks on page 359
Inserting frame breaks on page 357
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Fixing the number of systems per frame
You can define a fixed number of systems you want included in each music frame in each layout
in your project. Because the default master pages have a single music frame per page, fixing the
number of systems per frame usually fixes the number of systems per page.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to fix the number of systems per
frame.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Casting Off section, activate Fixed number of systems per frame.

5. Change the number of systems you want in each frame by changing the value in the value
field.

6. Activate/Deactivate Scale number of systems by frame height.

7. Click Apply, then Close.

RESULT
The number of systems automatically contained in each music frame in the selected layouts is
changed.
If you activated Scale number of systems by frame height, the number of systems contained in
each frame is adjusted according to the size of the music frame.

Frame breaks
In Dorico Pro, you can use frame breaks to push musical material into the next frame, which is
usually on the next page, meaning you can use frame breaks to create page breaks. For example,
you can use frame breaks to insert page turns at specific positions in part layouts.

Frame breaks are indicated by signposts, which you can hide/show at any time.

NOTE

● Frame breaks at the start of frames that were created using Make into Frame have Wait
for next frame break activated in the Format group of the Properties panel by default.
When this property is activated, Dorico Pro creates a frame containing all material
between that frame break and the next frame break. If you later delete subsequent frame
breaks, this creates very full frames with tightly spaced, or overlapping, systems. For
example, if you delete all subsequent frame breaks, all music until the end of the flow is
forced into a single frame.

● You can also control the content of music frames by fixing the number of systems per
music frame in each layout.

RELATED LINKS
Per-layout vertical spacing options on page 393
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Inserting frame breaks
You can insert frame breaks that allow you to create page turns in particular places in your
music.

PROCEDURE

1. Select a note or item at the rhythmic position where you want to insert a frame break.
For example, if you select a clef, the clef is placed at the end of the frame, and the notes
are moved to the start of the next music frame.

2. Press Shift-F.

RESULT
A frame break is inserted immediately before the rhythmic position of the earliest selected item.
All notations after the frame break are moved to the next music frame.

NOTE

If you insert a frame break in the middle of a phrase in a two-bar or four-bar repeat region,
Dorico Pro does not automatically move the frame break to before/after the phrase, causing it to
be split across the frame break.

RELATED LINKS
Engrave toolbox on page 291

Making selections into frames
You can make frames that contain all musical material between two selected rhythmic positions.

PROCEDURE

1. Select an item at the rhythmic position that you want to be the start of the frame.

NOTE

We recommend that you select noteheads or barlines. Selecting other items, such as slurs,
can cause frame breaks to be inserted earlier/later than you might have intended.

2. Ctrl/Cmd-click one of the following:

● A notehead that you want to be at the end of the frame

● An item that you want to be at the start of the next frame

3. In the Engrave toolbox, click Graphic Editing to show the Formatting panel.

4. In the Format Music Frames section, click Make into Frame.

RESULT
A fixed frame is created by inserting frame breaks at the start/end of your selection. The frame
contains all musical material between the two selected items.

● If you selected items, such as barlines or slurs, the beginning your first selected item is
positioned at the start of the frame and the end of your last selected item is positioned at
the start of the next frame.

● If you selected noteheads, the last selected notehead is also included in the frame, rather
than being positioned at the start of the next frame.
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● If you selected ties, all musical material between the first and last notes tie chains is
included in the frame, regardless of where in the tie chains you made selections.

NOTE

The frame break inserted at the start of the selection has Wait for next frame break activated in
the Format group of the Properties panel by default. Because this property tells Dorico Pro to
include all music in the frame until the next frame break, if you later delete subsequent frame
breaks, this can create very full frames with tightly spaced, or overlapping, systems.

Deactivating Wait for next frame break allows Dorico Pro to cast off subsequent music as
normal.

RELATED LINKS
Engrave toolbox on page 291

Hiding/Showing frame break signposts
You can hide/show frame break signposts at any time.

PROCEDURE

● Choose View > Signposts > Frame Breaks.

RESULT
Frame break signposts are shown when a tick appears beside Frame Breaks in the menu, and
hidden when no tick appears.

Deleting frame breaks
You can delete frame breaks after you have inserted them.

PREREQUISITE
Frame break signposts are shown.

PROCEDURE

1. Select the frame break signposts of the frame breaks you want to delete.

2. Press Backspace or Delete.

System breaks
System breaks are where musical material must be split across multiple systems or pages in
order to fit on the required paper. Dorico Pro automatically arranges music across systems so
that notes are correctly spaced and legible, but you can also control system breaks manually.

System breaks are indicated by signposts, which you can hide/show at any time.

NOTE

● System breaks at the start of systems that were created using Make into System have
Wait for next system break activated in the Format group of the Properties panel by
default. When this property is activated, Dorico Pro creates a system containing all
material between that system break and the next system break or the end of the flow,
whichever comes first. If you later delete subsequent system breaks, this creates very full,
tightly spaced systems. For example, if you delete all subsequent system breaks, all music
until the end of the flow is forced into a single system.
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● You can also control the content of systems by fixing the number of bars per system in
each layout.

RELATED LINKS
Fixing the number of bars per system on page 355
Per-layout vertical spacing options on page 393

Inserting system breaks
You can insert system breaks at any rhythmic position.

PROCEDURE

1. Select a note or item at the rhythmic position where you want to insert a system break.
For example, if you select a clef, the clef is placed at the end of the system, and the notes
are moved to the start of the next system.

2. Press Shift-S.

RESULT
A system break is inserted immediately before the rhythmic position of the earliest selected item.
All notations after the system break are moved to the next system.

NOTE

If you insert a system break in the middle of a phrase in a two-bar or four-bar repeat region,
Dorico Pro does not automatically move the system break to before/after the phrase, causing it
to be split across the system break.

RELATED LINKS
Engrave toolbox on page 291

Making selections into systems
You can make systems that contain all musical material between two selected rhythmic positions.

PROCEDURE

1. Select an item at the rhythmic position that you want to be the start of the system.

NOTE

We recommend that you select noteheads or barlines. Selecting other items, such as slurs,
can cause system breaks to be inserted earlier/later than you might have intended.

2. Ctrl/Cmd-click one of the following:

● A notehead that you want to be at the end of the system

● An item that you want to be at the start of the next system

3. In the Engrave toolbox, click Graphic Editing to show the Formatting panel.

4. In the Format Systems section, click Make into System.

RESULT
A fixed system is created by inserting system breaks at the start/end of your selection. The
system contains all musical material between the two selected items.
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● If you selected items, such as barlines or slurs, the start of your first selected item is
positioned at the start of the system and the end of your last selected item is positioned at
the start of the next system.

● If you selected noteheads, the last selected notehead is also included in the system, rather
than being positioned at the start of the next system.

● If you selected ties, all musical material between the first and last notes tie chains is
included in the system, regardless of where in the tie chains you made selections.

NOTE

The system break inserted at the start of the selection has Wait for next system break activated
in the Format group of the Properties panel by default. Because this property tells Dorico Pro to
include all music in the system until the next system break or the end of the flow, if you later
delete subsequent system breaks, this can create very full, tightly spaced systems.

Deactivating Wait for next system break allows Dorico Pro to cast off subsequent music as
normal.

RELATED LINKS
Engrave toolbox on page 291

Hiding/Showing system break signposts
You can hide/show system break signposts at any time.

PROCEDURE

● Choose View > Signposts > System Breaks.

RESULT
System break signposts are shown when a tick appears beside System Breaks in the menu, and
hidden when no tick appears.

Deleting system breaks
You can delete system breaks after you have inserted them.

PREREQUISITE
System break signposts are shown.

PROCEDURE

1. Select the system break signposts of the system breaks you want to delete.

2. Press Backspace or Delete.

Part formatting propagation
The propagation of part formatting involves copying the layout options and system formatting
that determine the layouts of pages and applying them to other layouts. This can save time when
formatting similar parts.

System formatting includes the positions of system and frame breaks, but also note spacing
changes that affect the horizontal space that notes require.

In Dorico Pro, you can copy layout options and system formatting both together and
independently of each other from a selected source layout to other destination layouts. For
example, for source layouts whose formatting relies primarily on their Casting Off settings in
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Setup > Layout Options, it is likely that copying only their layout options is sufficient to produce
the required formatting in the destination layouts without adding system/frame breaks on every
system.

You can also copy the layout-specific property settings from the layout currently open in the
music area to all other layouts in which those items appear.

NOTE

● We do not recommend using layouts with multiple music frame chains as either source or
destination layouts as you can get unexpected results.

● Propagating part formatting does not include overrides to individual pages made in
Engrave mode.

Propagate Part Formatting dialog
The Propagate Part Formatting dialog allows you to copy the page formatting and layout
options from a source layout to destination layouts.

You can open the Propagate Part Formatting dialog in Setup mode in any of the following
ways:

● Right-click a layout in the Layouts panel and choose Propagate Part Formatting from the
context menu. This automatically selects that layout as the source layout in the Copy
formatting from list.

● Choose Setup > Propagate Part Formatting.

Propagate Part Formatting dialog

The Propagate Part Formatting dialog contains the following sections and options:

1 Copy formatting from list
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Contains a list of all the layouts in the project. You can only select a single layout as the
source layout.

2 Propagate formatting to list
Contains a list of all the layouts in the project. You can select multiple layouts as
destination layouts.

3 Selection options
Allow you to select/deselect all the layouts in the Propagate formatting to list.

4 Include layout options
Allows you to copy layout options relating to part formatting from the source layout to the
destination layouts. These options include page size, page margins, the default master
page set, space size, vertical spacing, note spacing, casting off, multi-bar rest settings, and
staff labels.

5 Include system formatting
Allows you to copy the distribution of bars in systems, systems on pages, and note spacing
changes from the source layout to the destination layouts. Dorico Pro achieves this by
copying system breaks, frame breaks, and note spacing changes, inputting additional
system and frame breaks as required, and deleting any existing system breaks, frame
breaks, and note spacing changes in the destination layouts.

Copying part formatting to other layouts
You can copy all the formatting from one layout to other layouts, for example, to save time if
multiple part layouts in your project require similar formatting. You can include layout options,
such as page size and margins, and other page formatting, such as system and frame breaks.

NOTE

We do not recommend using layouts with multiple music frame chains as either source or
destination layouts as you can get unexpected results.

PROCEDURE

1. In the Layouts panel in Setup mode, right-click the card of the layout whose part
formatting you want to copy and choose Propagate Part Formatting from the context
menu.

2. In the Propagate Part Formatting dialog, select the layout whose part formatting you
want to copy in the Copy formatting from list.
By default, the layout whose card you used to open the dialog is selected.

3. In the Propagate formatting to list, select the layouts to which you want to copy part
formatting.
You can use the selection options in the action bar, Shift-click adjacent layouts, and Ctrl/
Cmd-click individual layouts.

4. Activate/Deactivate Include layout options.

5. Activate/Deactivate Include system formatting.

6. Click OK to copy part formatting to the selected layouts and close the dialog.

RESULT
Part formatting from the selected source layout is copied to the selected destination layouts.
However, overrides to individual pages made in Engrave mode are not propagated.

● If you activated Include layout options, layout options are copied from the source layout
to the destination layouts.
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● If you activated Include system formatting, Dorico Pro copies the distribution of bars in
systems, systems on pages, and note spacing changes from the source layout to the
destination layouts.

TIP

If the formatting of the source layout relies primarily on its Casting Off settings in Setup >
Layout Options, it is likely that only activating Include layout options is sufficient to produce
very similar formatting in the destination layouts without adding system/frame breaks on every
system.

Copying property settings to other layouts
Many properties are layout-specific, meaning they only affect the layout currently open in the
music area by default. You can copy the properties set on notes and items to all other layouts in
which they appear, for example, to show gradual dynamics with the same style in part layouts
after changing their style in the full score layout.

PROCEDURE

1. Select the notes or items whose properties you want to copy to other layouts. You can do
this in Write mode and Engrave mode.

NOTE

The mode you are in determines which properties are copied. For example, if you are in
Write mode, only properties available in Write mode are copied.

2. Choose Edit > Propagate Properties.

RESULT
All properties set on the selected notes/items that are available in the current mode are copied to
all layouts in which those notes/items appear. For example, if you selected slurs in Write mode,
their staff-relative placement and design settings are copied. If you selected them in Engrave
mode, their slur end and control point positions are also copied.

RELATED LINKS
Large selections on page 274
Resetting the appearance of items on page 281
Resetting the position of items on page 281

Text formatting
Dorico Pro combines different settings for the appearance of text, meaning that you can format
fonts and texts in different places depending on their function.

For example, you can change the font family used for all text in your project in the Edit Font
Styles dialog, and then make specific changes for when that font is used for titles in the
Paragraph Styles dialog.

Paragraph styles apply to whole text frames or all text within a single text object. Character styles
apply to individual selections, meaning you can apply different character styles to each word
within the same text frame.

Font styles apply to items that use text but are not text frames or text objects, such as tempo
marks and dynamics.

RELATED LINKS
Paragraph Styles dialog on page 366
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Character Styles dialog on page 369
Text editor options in Engrave mode on page 371

Edit Font Styles dialog
The Edit Font Styles dialog allows you to change certain aspects of fonts used for items that you
cannot edit using the text editor, such as changing the font size of rehearsal marks.

● You can open the Edit Font Styles dialog in Engrave mode by choosing Engrave > Font
Styles.

The Edit Font Styles dialog contains fonts that are used in Dorico Pro that you cannot edit
directly in the music area, unlike text in text frames, which you can edit using the text editor.

Edit Font Styles dialog

Font style
Allows you to select different font styles in order to change aspects of the font. If you
have previously opened the Edit Font Styles dialog in the same session, your
previously selected font style is remembered.

Font family
Sets the overall font style.

Size
Sets the size of the font.

Staff-relative/Absolute
Allows you to choose whether the size of the font changes according to the staff size
of the layout or whether it is always the set size.

Style
Sets the appearance of the font from the following options:

● Regular

● Italic

● Bold

● Bold Italic
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Underlined
Fonts appear underlined when Underlined and the corresponding checkbox are
both activated.

NOTE

● These options must be activated before you can change them.

● Changes made to font styles apply project-wide, including in part layouts.

● If you cannot find a particular font style, it might instead be a paragraph style.

RELATED LINKS
Paragraph Styles dialog on page 366

Music Fonts dialog
The Music Fonts dialog allows you to change the font used for notations and glyphs project-
wide. Any font you use for notations and glyphs must be SMuFL-compliant.

● You can open the Music Fonts dialog in Engrave mode by choosing Engrave > Music
Fonts.

Music Fonts dialog

The dialog contains all available SMuFL fonts you have installed on your computer that have the
appropriate metadata for Dorico Pro to recognize them. By default, Dorico Pro comes with the
following SMuFL-compliant fonts:

● Bravura
The default music font, inspired by traditional classical music engraving.

● Petaluma
Handwritten music font style, similar to the traditional style used for jazz music.

Changing the music font used in the Music Fonts dialog changes the fonts used for notations,
glyphs, and other items that are not text, such as clefs, dynamics, and bold tuplet numbers/
ratios.

TIP

You can change the fonts used for these items individually by changing the Default Text Font
style in the Edit Font Styles dialog, and the Default Text paragraph style in the Paragraph
Styles dialog.
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The Music Fonts dialog also contains the following options:

Use font’s recommended engraving options
Allows you to import the default settings that come with the font.

Update text fonts when changing music fonts
Allows you to include/exclude text fonts when changing the music font. For example,
deactivating this option allows you to change the appearance of notes and notations
without affecting the appearance of flow titles and staff labels.

● For the Bravura music font, the equivalent text font is Academico.

● For the Petaluma music font, the equivalent text font is Petaluma Script.

NOTE

Certain items that are marked as optional in SMuFL fonts, such as clef changes and non-bold
tuplet numbers/ratios, are not affected when you change the music font.

Paragraph Styles dialog
The Paragraph Styles dialog allows you to change paragraph styles for text and create new
styles. You can later use different paragraph styles in different places in your project by choosing
them in the text editor.

For example, you can customize the paragraph style for layout names and then apply your layout
name paragraph style to every text frame in which you show layout names. This allows you to
keep the presentation of different types consistent across your project.

● You can open the Paragraph Styles dialog in Engrave mode by choosing Engrave >
Paragraph Styles.

Paragraph Styles dialog

The Paragraph Styles dialog contains the following sections and options:

1 Paragraph styles list
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Contains all the paragraph styles in the project. If you had text items selected when you
opened the dialog, the corresponding paragraph style of the first selected item is selected
in the paragraph styles list by default.
The action bar at the bottom of the list contains the following options:

● New

Allows you to create a new paragraph style with default values.

● New from Selection

Creates a new style based on the selected one. Initially no values are overridden but
you can change options for your new style.

● Save as Default

Copies the selected style to your library so that it is available in other projects.

● Revert to Factory

Removes all your changes to the selected predefined paragraph styles, reverting
them to the default factory settings.

● Delete

Deletes the selected style.

NOTE

You cannot delete predefined paragraph styles or any paragraph style that is
currently used in your project.

2 Name
Allows you to enter a name for new paragraph styles or edit the name of existing
paragraph styles.

3 Parent
Allows you to choose a parent paragraph style from which the selected paragraph style
inherits settings.

4 Font appearance options
Allow you to change parameters of the appearance of the paragraph style font, such as
changing the font, making the font bold, changing the size of the font, and changing the
letter or word spacing. You can also make the font in paragraph styles appear underlined
or overlined.

5 Paragraph layout options
Allow you to change the layout of the paragraph style, such as indenting the first line in
each paragraph and changing the alignment of text.

6 Color options
Allow you to change the foreground and background colors of the paragraph style.
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Creating paragraph styles
You can create new paragraph styles that you can use in your project, for example, to format text
consistently in multiple text frames. You can also create new paragraph styles based on existing
ones.

PROCEDURE

1. In Engrave mode, choose Engrave > Paragraph Styles to open the Paragraph Styles
dialog.

2. Create a new paragraph style in one of the following ways:

● To create an entirely new paragraph style, click New.

● To create a new paragraph style based on an existing one, select the existing
paragraph style in the styles list and click New From Selection.

3. Enter a name for the style in the Name field.

4. Optional: Select one of the available styles from the Parent menu.

NOTE

If you select a parent style, your paragraph style inherits its settings automatically for all
options with deactivated sliders. If your paragraph style has activated sliders, which
override its parent style settings, you can deactivate them to reset those options to follow
the parent style.

5. Activate and change the options as required.

6. Click OK to save your changes and close the dialog.

Changing the default horizontal alignment of text styles
You can change the default horizontal alignment of the paragraph styles used for different types
of text. This changes the horizontal alignment of the corresponding text style project-wide.

PROCEDURE

1. In Engrave mode, choose Engrave > Paragraph Styles to open the Paragraph Styles
dialog.

2. In the paragraph style list, select the text style whose default alignment you want to
change.

3. Choose the Alignment option you want.

4. Optional: Repeat steps 2 and 3 for other paragraph styles whose horizontal alignment you
want to change.

5. Click OK to save your changes and close the dialog.

RESULT
The default alignment of the selected text style is changed.

TIP

You can also override the horizontal alignment of text in individual text frames.

RELATED LINKS
Changing the horizontal alignment of text in text frames on page 339
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Deleting paragraph styles
You can delete paragraph styles you have created. However, you cannot delete any of the default
paragraph styles.

PROCEDURE

1. In Engrave mode, choose Engrave > Paragraph Styles to open the Paragraph Styles
dialog.

2. In the paragraph style list, select the style that you want to delete.

NOTE

You cannot delete any of the default paragraph styles.

3. Click Delete.

4. Click OK to save your changes and close the dialog.

Character Styles dialog
The Character Styles dialog allows you to change character styles and create new styles. You can
later apply character styles to individual letters or words in different places in your project by
choosing them in the text editor.

For example, you can create a custom character style with wide letter spacing for specific words
and then apply that character style to selected words. Unlike paragraph styles, character styles
do not have to apply to whole text frames or text objects.

● You can open the Character Styles dialog in Engrave mode by choosing Engrave >
Character Styles.

Character Styles dialog

The Character Styles dialog contains the following sections and options:

1 Character styles list
Contains all the character styles in the project.
The action bar at the bottom of the list contains the following options:

● New
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Allows you to create a new character style with default values.

● New from Selection

Creates a new style based on the selected one. Initially no values are overridden but
you can change options for your new style.

● Save as Default

Copies the selected style to your library so that it is available in other projects.

● Revert to Factory

Removes all your changes to the selected predefined character styles, reverting
them to the default factory settings.

● Delete

Deletes the selected style.

NOTE

You cannot delete predefined character styles or any character style that is currently
used in your project.

2 Name
Allows you to enter a name for new character styles or edit the name of existing paragraph
styles.

3 Character style options
Allow you to change parameters of the character style, such as changing the font, making
the font bold, changing the size of the font, and changing the letter or word spacing. You
can also make the font in paragraph styles appear underlined or overlined, and change
the vertical alignment of characters.

4 Color options
Allow you to change the foreground and background colors of the character style.

Creating character styles
You can create new character styles, both entirely new character styles and character styles
based on existed ones.

PROCEDURE

1. In Engrave mode, choose Engrave > Character Styles to open the Character Styles
dialog.

2. Create a new character style in one of the following ways:

● To create an entirely new character style, click New.

● To create a new character style based on an existing one, select the existing
character style in the styles list and click New From Selection.

3. Enter a name for the style in the Name field.

4. Activate and change the options as required.
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IMPORTANT

Only activated options have an effect on the text. If you deactivate options, their settings
are reset.

5. Click OK to save your changes and close the dialog.

Deleting character styles
You can delete character styles.

PROCEDURE

1. In Engrave mode, choose Engrave > Character Styles to open the Character Styles
dialog.

2. Select the style that you want to delete in the styles list.

3. Click Delete.

4. Click OK to save your changes and close the dialog.

Text objects vs. text in text frames
Text in Dorico Pro can exist as a text object, added to individual staves or as system text, and in
text frames, which are fixed to the page rather than the music.

You can edit both types of text in the same ways, but you can only use text tokens in text frames.
You cannot use tokens in text added to staves/systems.

RELATED LINKS
Text tokens on page 332
Text editor options in Engrave mode on page 371

Text editor options in Engrave mode
The text editor allows you to add and format text. In Engrave mode, it opens when you enter or
edit text in a text frame.

Text editor in Engrave mode

The text editor provides the following options:

1 Paragraph Style
Allows you to change the paragraph style applied to the whole paragraph, which can
change the appearance, formatting, and alignment of the text.
Staff text and system text are always treated as single paragraphs.

2 Character Style
Allows you to change the appearance of selected text within paragraphs. This overrides
the paragraph style applied to the corresponding paragraph.

3 Font
Allows you to change the font family of selected text.
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4 Font Style
Allows you to change the font style of selected text.

5 Font Size
Allows you to change the size of selected text.

6 Font Stretch
Allows you to make selected text wider or narrower.

7 Baseline Shift
Allows you to shift the baseline of selected text gradually up or down.

8 Letter Spacing
Allows you to increase/decrease the space between the characters of selected text.

9 Word Spacing
Allows you to increase/decrease the space between the words of selected text.

10 Alignment
Allows you to choose the alignment of selected text relative to the rhythmic position of the
text in the score. For text in a text frame, the text is aligned along the left margin of a text
frame.
You can choose from the following alignments:

● Align Left

● Align Center

● Align Right

● Justify

11 Line Types
Allows you to show any of the following types of lines, in any combination, on selected
text:

● Underline

● Overline

● Strikethrough

12 Script Types
Allows you to position selected text in one of the following positions relative to the text on
the baseline:

● Superscript

● Subscript

13 Foreground Color
Allows you to change the color of selected text.

14 Background Color
Allows you to change the background color of selected text.

RELATED LINKS
Inputting text on page 265
Entering text in text frames on page 337
Paragraph Styles dialog on page 366
Character Styles dialog on page 369
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Changing the paragraph style of text
You can change the paragraph style that is applied to text added to staves and within individual
text frames, including on master pages. For example, if you want to use one paragraph style for
page numbers in full score layouts and another for page numbers in part layouts.

PREREQUISITE
If you want to use a different paragraph style to the ones provided by default, you have created a
new paragraph style.

PROCEDURE

1. Optional: If you want to change the paragraph style of text on a master page, open the
master page editor.

2. Double-click the text frame whose paragraph style you want to change to open the text
editor.

3. Select the text whose paragraph style you want to change.

TIP

You can apply different paragraph styles to separate paragraphs in the same text frame.

4. Select a paragraph style from the paragraph style menu in the text editor.

5. Press Esc or Ctrl/Cmd-Return to close the text editor.

RESULT
The paragraph style of the selected paragraphs is changed. For example, if you select a single
word, the whole paragraph containing that word is changed.

RELATED LINKS
Paragraph Styles dialog on page 366
Creating paragraph styles on page 368

Paragraph style overrides
If you override the paragraph style of text within text frames on individual pages, such as
changing the size of text in a text frame but not changing the size of its paragraph style, any
changes you later make to the paragraph style are not applied to the overridden text.

You can reset the changes you made to revert individual pages back to the master page format.
However, this removes all changes made to those pages.

NOTE

You cannot reset changes made to text in text frames on master pages.

RELATED LINKS
Removing master page overrides on page 309

Moving text objects graphically
In Engrave mode, you can move text objects that you input in Write mode without changing the
rhythmic positions to which they are attached. You can move both staff text and system text,

Engrave mode
Text formatting 

373
Dorico 2.2.20



including moving individual instances of system text independently of other instances shown at
different staff positions.

NOTE

This does not apply to text in text frames.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

PROCEDURE

1. Select the text objects that you want to move.

2. Move the text objects in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected text objects are moved to new positions.

TIP

Offset in the Common group of the Properties panel is activated automatically when you move
text objects.

● Offset X moves text objects horizontally.

● Offset Y moves text objects vertically.

You can also use this property to move text objects by changing the values in the value fields.

Deactivating the property resets the selected items to their default position.

RELATED LINKS
Text editor options in Engrave mode on page 371
Moving frames on page 323

Changing the placement of text objects relative to the staff
You can show text objects either above or below the staff. Text is automatically positioned to
ensure that it does not collide with other objects.

NOTE

This does not apply to text in text frames.

PREREQUISITE
The text editor is closed.

Engrave mode
Text formatting 

374
Dorico 2.2.20



PROCEDURE

1. Select the text objects whose staff-relative placement you want to change. You can do this
in Write mode and Engrave mode.

2. In the Properties panel, choose one of the following options for Position in the Text
group:

● Above

● Below

RESULT
The selected text objects appear above/below the staff.

AFTER COMPLETING THIS TASK
If you need to move text objects to different graphical positions, you can drag them manually in
Engrave mode.

RELATED LINKS
Moving text objects graphically on page 373

Enabling/Disabling text collision avoidance
You can change whether individual text objects automatically move to avoid collisions,
independently of your project-wide setting. Text objects with collision avoidance disabled do not
contribute to automatic staff spacing calculations.

NOTE

This does not apply to text in text frames.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

PROCEDURE

1. In Engrave mode, select the text objects whose collision avoidance you want to enable/
disable.

2. In the Properties panel, activate Avoid collisions in the Text group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
The selected text objects avoid collisions when the checkbox is activated, and do not avoid
collisions when the checkbox is deactivated.
When the property is deactivated, text objects follow your project-wide setting for text collision
avoidance.

TIP

You can enable/disable text collision avoidance for all text objects project-wide on the Text page
in Engrave > Engraving Options.
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Adding borders to text objects
You can add borders to text and system text objects individually, for example, if you want to
make the boundaries of text objects clear.

PROCEDURE

1. Select the text objects to which you want to add borders. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Border in the Text group.

RESULT
Borders are added to the selected text objects.

TIP

● You can show borders on text objects in addition to erasing their background.

● Deactivating Border removes borders from the selected text objects.

EXAMPLE

Text with no border Text with border shown

AFTER COMPLETING THIS TASK
You can change the padding between text objects and each edge of their borders.

Changing the thickness of text object borders
You can change the thickness of borders around individual text objects, independently of your
project-wide setting.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

PROCEDURE

1. In Engrave mode, select the text objects whose border thickness you want to change.

2. In the Properties panel, activate Border thickness in the Text group.

3. Change the value in the value field.

RESULT
The thickness of borders around the selected text objects is changed.

TIP

You can change the default thickness of all text object borders project-wide on the Text page in
Engrave > Engraving Options.

RELATED LINKS
Changing the thickness of text frame borders on page 338
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Changing the padding around text objects
You can change the padding around text objects individually, including changing the padding
between text and each edge independently. This affects the distance between text and erased
backgrounds and borders.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

PROCEDURE

1. In Engrave mode, select the text objects whose padding you want to change.

2. In the Properties panel, activate the Erasure padding properties, individually or together,
in the Text group.

● L changes the padding between text objects and their left edge.

● R changes the padding between text objects and their right edge.

● T changes the padding between text objects and their top edge.

● B changes the padding between text objects and their bottom edge.

3. Change the values in the value fields for the edges whose padding you want to change.

RESULT
Increasing the values increases the padding, decreasing the values decreases the padding.

TIP

You can change the default padding of all text objects project-wide on the Text page in
Engrave > Engraving Options. However, this does not allow you to change the padding of each
edge independently.

Erasing the background of text objects
You can erase the background of individual text and system text objects, for example, to ensure
the text remains legible when crossing barlines.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

PROCEDURE

1. In Engrave mode, select the text objects whose backgrounds you want to erase.

2. In the Properties panel, activate Erase background in the Text group.

RESULT
The backgrounds of the selected text objects erase whatever is behind them.

TIP

● You can show borders on text objects in addition to erasing their background.

● Deactivating Erase background returns the selected text objects to the default non-
erased background.
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EXAMPLE

Text with non-erased background Text with erased background

AFTER COMPLETING THIS TASK
You can change the padding between text objects and each edge of their erased areas.

Music symbols
Music symbols in Dorico Pro is a broad term that covers all the different elements used in
musical notation, including stem flags, clefs, articulations, and the bold numbers used in multi-
bar rests and time signatures.

In Dorico Pro, some music symbols have specific editor dialogs in which you can edit and create
custom versions of those symbols. For all other music symbols, you can edit their project-wide
appearance in the Edit Music Symbol dialog.

RELATED LINKS
Edit Accidental dialog on page 678
Edit Chord Symbol Component dialog on page 569
Edit Notehead dialog on page 719
Edit Playing Technique dialog on page 798

Edit Music Symbol dialog
The Edit Music Symbol dialog allows you to edit the appearance of all the different music
symbols used in Dorico Pro that do not have a dedicated editor, such as chord symbols,
accidentals, noteheads, and playing techniques.

● You can open the Edit Music Symbol dialog in Engrave mode by choosing Engrave >
Music Symbols.

NOTE

You cannot create new music symbols in the Edit Music Symbol dialog, you can only edit existing
music symbols.
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Edit Music Symbol dialog

The Edit Music Symbol dialog contains the following sections and options:

1 Category menu
Allows you to filter the list of music symbols by selecting a category from the menu.

2 Music symbol list
Contains all the music symbols in the project within the currently selected category.
The action bar at the bottom of the list contains the following options:

● Save as Default

Saves the currently selected music symbol in its current state as the default for all
future projects.

● Revert to Factory

Removes all edits you have made to the selected music symbol, returning it to its
original settings and appearance.

3 Name
Displays the default name for the selected music symbol.

4 Component selector
Allows you to choose components to add to the music symbol. You can add different types
of components by clicking the respective tab titles.

● Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting
different fonts and different ranges from the menus. Click Add Glyph to add the
selected glyph to the music symbol.

NOTE

A full list of the different ranges of glyphs is available on the SMuFL website.
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● Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected
text, or input text, to the music symbol.

● Graphic: Allows you to load a new graphic file, or select an existing graphic from the
Select existing list, in SVG, PNG, or JPG format. You can see a preview of the graphic
in the Preview box. Click Add Graphic to add the selected graphic to the music
symbol.

5 Editor
Allows you to arrange and edit the components that make up the music symbol. You can
arrange and edit components by clicking and dragging them in the editor and by using the
controls at the bottom of the dialog. You can also use the handles on each component to
change their size.

6 Editor action bar
Contains selection and view options for the editor.

● Zoom
Allows you to change the zoom level in the editor.

● Select
Allows you to select the next/previous component.

● Show Attachments

Shows all the attachments on all components in the editor.

● Delete

Deletes the selected component.

7 Controls
Contains controls that allow you to edit individual components. Controls are divided into
tabs according to the aspect of the selected component they affect. For music symbols,
only the Component and Attachments tabs are available as the other tabs do not apply
to the symbols in the dialog.
The Component tab contains the following options:

● Offset: Controls the position of the selected component. X moves it horizontally, Y
moves it vertically.

● Scale: Controls the size of the selected component. For graphics, X controls its
width, Y controls its height.

NOTE

Although some components scale their height and width independently, others
retain their aspect ratio, meaning only one value affects their overall size.

● Z order: Allows you to Bring Forward or Send Backward the selected component in
relation to other components when they overlap.

The Attachments tab is only available if the music symbol comprises at least two separate
components. It contains the following options:

● Attachment from: Sets the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend
that you select a right edge attachment point for Attachment from.
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● Attachment to: Sets the attachment point on the selected component which
attaches to the component to its left. We recommend that you select a left edge
attachment point for Attachment to.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.

The attachment points have the following names in the Edit Music Symbol dialog:

1 Top Left

2 Top Center

3 Top Right

4 Middle Left

5 Middle Right

6 Baseline Left (text only)

7 Baseline Center (text only)

8 Baseline Right (text only)

9 Bottom Left

10 Bottom Center

11 Bottom Right

Note spacing
The positions of notes and rests relative to each other, and the automatic gaps between them,
are known as note spacing.

You can change note spacing in your project at different levels:

● Change the default note spacing project-wide in each layout in Layout Options.

● Change the note spacing from a specified point in individual frame chains in individual
layouts.

● Change the note spacing at individual rhythmic positions and for individual notes.

Note spacing changes project-wide

You can change the default note spacing values for each layout independently on the Note
Spacing page in Setup > Layout Options.

The options available include changing the default space for quarter notes (crotchets) and the
scale space for grace notes and cues. You can also change the minimum percentage value for
how full final systems must be before they are justified.

Note spacing changes from specific points in layouts

In Engrave mode, you can open the Note Spacing Change dialog and change or reset values
affecting the spacing and scaling of notes.

Engrave mode
Note spacing 

381
Dorico 2.2.20



Changes you make in the Note Spacing Change dialog only apply to the selected layout, and to
the frame chain containing the item selected when you made the note spacing change. The
preview in the dialog updates in real time as you change values.

Signposts are shown at rhythmic positions where you have made changes to note spacing using
the Note Spacing Change dialog.

Note spacing at individual rhythmic positions and of individual notes

You can make individual spacing adjustments and move individual notes graphically when Note
Spacing is activated in the Engrave toolbox. When Note Spacing is activated, dashed lines
representing spacing columns and handles for each spacing-significant item appear.

Handles and dashed lines are shown when Note Spacing is activated.

Each rhythmic position that contains a significant item, such as notes, grace notes, rests, clefs,
key signatures, and time signatures, can be adjusted using the square note spacing handles.
Note spacing handles allow you to adjust the spacing of the selected rhythmic position, which
changes the position of all items at that rhythmic position.

Selecting square note spacing handles above items, such as noteheads, causes a circular handle
to appear. Circular handles allow you to adjust the graphical position of that individual item,
independently of its rhythmic position.

Additionally, larger square system handles are shown at the start/end of each system when Note
Spacing is activated, allowing you to adjust the start/end horizontal position of individual
systems. System handles are positioned on the top left and bottom right corners of each system.

When note spacing handles have been moved, their color changes.

NOTE

When Note Spacing is activated, you cannot make any selections or make other types of edits to
items in the current layout. To resume normal selection and editing, click Graphic Editing in the
Engrave toolbox or return to Write mode.

RELATED LINKS
Changing the default note spacing on page 383
Engrave toolbox on page 291
Adjusting note spacing at individual rhythmic positions on page 388
Changing the start/end position of systems on page 390
Layout Options dialog on page 90
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Note Spacing Change dialog on page 386
Removing individual changes to note spacing on page 391

System fullness indicator
The system fullness indicator is a highlighted region in the right page margin that is shown when
Note Spacing is activated. The system fullness indicator uses colors and percentages to indicate
the fullness of the system.

The following colors are used in the system fullness indicator:

● Green: the system is comfortably full. Notes have enough horizontal space to be legible
but are not too far apart. Systems that are 60-100% full are considered comfortably full.

● Purple: the system is under-full, meaning notes might appear overly stretched. Systems
that are less than 60% full are considered under-full.

● Red: the system is over-full, meaning notes might appear squashed with not enough
horizontal space between them. Systems that are more than 100% full are considered
over-full.

The fullness of systems is also expressed using a percentage. The percentage indicated is
calculated by dividing the number of spaces occupied in the system by the total number of
available spaces in the system, which is measured from the start of the rhythmic space to the
right of the initial clef/time signature/key signature up to the final barline in the system.

Both the color of the system fullness indicator and the fullness percentage are updated in real
time as you adjust note spacing in the system.

System comfortably full System under-full System over-full

RELATED LINKS
Engrave toolbox on page 291
Adjusting note spacing at individual rhythmic positions on page 388

Changing the default note spacing
You can change the default note spacing in each layout independently. For example, you can
have tighter note spacing in full score layouts compared to part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change note spacing.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Note Spacing in the page list.

4. Change the values of the options you want to change.

5. Click Apply, then Close.
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RESULT
The default note spacing is changed project-wide in the selected layouts.

RELATED LINKS
Note Spacing page in Layout Options on page 384

Note Spacing page in Layout Options
The Note Spacing page in Layout Options allows you to change the default values for note
spacing project-wide in each layout independently. You can also change how full the final system
in flows must be before it is automatically justified.

● You can access the Note Spacing page by choosing Setup > Layout Options and clicking
Note Spacing in the page list.

Options on the Note Spacing page in Layout Options

The Note Spacing page in Layout Options contains the following options:

Default space for crotchet/quarter note
Sets the default note spacing for quarter notes (crotchets). The spacing of other
durations is scaled proportionally. Increasing the value increases note spacing,
decreasing the value decreases note spacing. This is reflected in the preview as you
change the value.

Minimum space for short notes
Sets the minimum note spacing for notes with short durations. This can be
independent of the default note spacing value.

Use custom spacing ratio
Sets the spacing of notes in relation to other notes according to their rhythmic
values. For example, setting Use custom spacing ratio to 2 means half notes
(minims) take up twice as much space as quarter notes, and eighth notes (quavers)
take up half as much space as quarter notes.
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Scale space for grace notes by
Sets the note spacing for grace notes as a percentage of the note spacing normally
used for notes of their duration. The value cannot be greater than 100%. Increasing
the value increases the note spacing for grace notes, decreasing the value decreases
the note spacing for grace notes.

Scale space for cue notes by
Sets the note spacing for cues as a percentage of the note spacing normally used for
notes of their duration. The value cannot be greater than 100%. Increasing the value
increases the note spacing for cues, decreasing the value decreases the note spacing
for cues.

Only justify final system in flow when more than [n]% full
Allows you to change how full the final system in each flow must be before it is
justified to the full width of the frame. By default, final systems that are 50% full or
less are not justified.

Use optical spacing for beams between staves
When activated, stems in cross-staff beams are evenly spaced, which can mean the
noteheads are unevenly spaced. When deactivated, noteheads in cross-staff beams
are evenly spaced, which can mean stems appear unevenly spaced.

RELATED LINKS
Changing the default note spacing on page 383
Optical spacing for cross-staff beams on page 546

Changing note spacing from specific points
You can change note spacing values from a specified point onwards in the layout currently open
in the music area, including changing the scale factor for grace notes and cues.

PROCEDURE

1. In the music area, open the layout in which you want to change note spacing.

2. Select an item at the rhythmic position from which you want to change note spacing, and
in the frame chain to which you want the changes to apply.

3. Choose Engrave > Note Spacing Change to open the Note Spacing Change dialog.

4. In the Note Spacing Change dialog, activate the note spacing options you want to
change.

5. Choose Change for each activated option.

6. Change the value of each note spacing option you want to change.

7. Click OK to save your changes and close the dialog.

RESULT
Note spacing is changed from the selected rhythmic position onwards. This applies to the frame
chain containing the selected item and the layout currently open in the music area.
A signpost is shown at the position of the note spacing change.

RELATED LINKS
Note Spacing Change dialog on page 386
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Note Spacing Change dialog
The Note Spacing Change dialog allows you to change or reset values affecting the spacing and
scaling of notes from specific points in layouts, including the scale factor for grace notes and
cues.

● You can open the Note Spacing Change dialog in Engrave mode by choosing Engrave >
Note Spacing Change when Graphic Editing is selected in the Engrave toolbox and an
item is selected in the music area.

Note Spacing Change dialog

The Note Spacing Change dialog contains the following options:

Default space for crotchet/quarter note
Sets the default note spacing for quarter notes (crotchets). The spacing of other
durations is scaled proportionally. Increasing the value increases note spacing,
decreasing the value decreases note spacing. This is reflected in the preview as you
change the value.

Minimum space for short notes
Sets the minimum note spacing for notes with short durations. This can be
independent of the default note spacing value.

Custom spacing ratio
Sets the spacing of notes in relation to other notes according to their rhythmic
values. For example, setting Custom spacing ratio to 2 means half notes (minims)
take up twice as much space as quarter notes, and eighth notes (quavers) take up
half as much space as quarter notes.

Use custom spacing ratio
Sets the spacing of notes in relation to other notes according to their rhythmic
values. For example, setting Use custom spacing ratio to 2 means half notes
(minims) take up twice as much space as quarter notes, and eighth notes (quavers)
take up half as much space as quarter notes.

Scale space for grace notes by
Sets the note spacing for grace notes as a percentage of the note spacing normally
used for notes of their duration. The value cannot be greater than 100%. Increasing
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the value increases the note spacing for grace notes, decreasing the value decreases
the note spacing for grace notes.

Scale space for cue notes by
Sets the note spacing for cues as a percentage of the note spacing normally used for
notes of their duration. The value cannot be greater than 100%. Increasing the value
increases the note spacing for cues, decreasing the value decreases the note spacing
for cues.

Each option has an activation switch, meaning you can only change values for options that you
have chosen to change.

You can then choose one of the following options for the note spacing change:

Reset
Resets note spacing to your project-wide setting for note spacing in the layout, as set
on the Note Spacing page in Layout Options.

Change
Changes note spacing in the layout to the values set.

RELATED LINKS
Note spacing on page 381

Resetting note spacing from specific points
You can reset changes you have made to note spacing values using the Note Spacing Change
dialog. This applies from a specified point onwards in the layout currently open in the music area.

PROCEDURE

1. In the music area, open the layout in which you want to reset note spacing from a specific
point.

2. Select an item at the rhythmic position from which you want to reset note spacing, and in
the frame chain to which you want the changes to apply.

3. Choose Engrave > Note Spacing Change to open the Note Spacing Change dialog.

4. Activate the note spacing options you want to reset.

5. Choose Reset for each activated option.

6. Click OK to save your changes and close the dialog.

RESULT
Note spacing is reset to your project-wide settings for the activated options from the selected
rhythmic position onwards. This applies to the frame chain containing the selected item and the
layout currently open in the music area.
A signpost is shown at the position of the note spacing change.

RELATED LINKS
Note Spacing Change dialog on page 386

Deleting note spacing changes at specific points
You can delete note spacing changes you have made using the Note Spacing Change dialog,
which returns note spacing to your project-wide settings.

PROCEDURE

1. Select the signposts of the note spacing changes you want to delete.
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2. Press Backspace or Delete.

RESULT
The selected note spacing changes are deleted. Note spacing returns to your project-wide
settings for the layout until the next existing note spacing change or until the end of the project,
whichever comes first.

Adjusting note spacing at individual rhythmic positions
You can make adjustments to the note spacing at individual rhythmic positions independently of
your project-wide settings.

NOTE

● Moving notes too far away from their intended rhythmic positions can be misleading for
players reading the music.

● When Note Spacing is activated, you cannot select or edit anything other than note
spacing handles. To resume normal selection and editing, click Graphic Editing in the
Engrave toolbox or return to Write mode.

PROCEDURE

1. In the Engrave toolbox, activate Note Spacing.

2. Select a square handle on the dashed line at each rhythmic position whose spacing you
want to adjust.

3. Move the handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.
This increases the space to the left of the rhythmic position of each selected handle.

● Press Alt-Left Arrow to move them to the left.
This decreases the space to the left of the rhythmic position of each selected handle.

NOTE

● If you want to move handles by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● You cannot move note spacing handles with the mouse, you can only move
them using the keyboard.

RESULT
The selected note spacing handles are moved, which increases/decreases the spacing to the left
of their original rhythmic position. This also affects the spacing of each selected rhythmic
position on all staves in the system.
System breaks are automatically inserted at the start/end of each system in which you adjusted
note spacing.

NOTE

You cannot select/delete system break signposts when Note Spacing is activated.
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EXAMPLE

Moving note spacing handles to the left reduces
spacing to the left of the rhythmic position

Moving note spacing handles to the right increases
spacing to the left of the rhythmic position

RELATED LINKS
Removing individual changes to note spacing on page 391
Signposts on page 281
Hiding/Showing system break signposts on page 360

Adjusting the spacing of individual notes/items independently of their rhythmic
positions

You can change the graphical position of individual notes and some other items, such as key
signatures, time signatures, and clefs, independently of their rhythmic positions.

PROCEDURE

1. In the Engrave toolbox, activate Note Spacing.

2. Select the square handle at the rhythmic position of the note/item you want to move
graphically.

A circular handle appears beside the note/item.

3. Press Tab to select the circular handle.

4. Move the handle in any of the following ways:

● Press Alt-Right Arrow to move it to the right.

● Press Alt-Left Arrow to move it to the left.

NOTE

● If you want to move handles by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● You cannot move note spacing handles with the mouse, you can only move
them using the keyboard.
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RESULT
The graphical position of the selected note/item is changed without changing the note spacing of
its rhythmic position.

EXAMPLE

Changing the start/end position of systems
You can change the start/end horizontal position of each system individually, for example, if you
want to indent a single system.

NOTE

● If you want to increase the space before staff labels, you can change the minimum indent
for systems with staff labels project-wide for each layout independently on the Staves and
Systems page in Setup > Layout Options.

● If you want to change the end position of systems because they do not fill the entire width
of the page, you can change the minimum fullness for justification on the Note Spacing
page in Layout Options.

● If you want to change the width of all systems on a page by the same amount, you can
change the width of the music frame.

PROCEDURE

1. In the Engrave toolbox, activate Note Spacing.

2. Select the system handle at the start/end of each system whose start/end position you
want to change.

3. Move the handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

NOTE

● If you want to move handles by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● You cannot move note spacing handles with the mouse, you can only move
them using the keyboard.
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RESULT
The start/end position of the selected systems is changed. Notes on the selected systems appear
more/less tightly spaced, depending on whether moving the system handles made their system
narrower or wider.

RELATED LINKS
System indents on page 927
Changing the justification of final systems on page 349
Changing the first system indent on page 927
Changing the minimum indent for systems with staff labels on page 900

Removing individual changes to note spacing
You can remove changes you have made to the note spacing at individual rhythmic positions and
reset note spacing handles to their original default positions.

PROCEDURE

1. In the Engrave toolbox, activate Note Spacing.

2. Select the note spacing handles you want to restore to their original positions.

3. Press Backspace or Delete.

RESULT
The selected rhythmic positions are reset to their default positions.

TIP

You can also reset all note spacing changes within selected systems, frames, or all note spacing
changes in the layout by choosing one of the options in the Engrave > Note Spacing menu.

RELATED LINKS
Note spacing on page 381

Staff spacing
The vertical positioning of staves and systems within frames is known as staff spacing. Staff
spacing calculations consider the height of staves and the necessary gaps between staves and
systems.

You can change staff spacing in your project at different levels:

● Change the default staff spacing project-wide in each layout in Layout Options.

● Change the staff spacing between individual staves.

Staff spacing changes project-wide

You can change the default vertical and staff spacing settings for each layout independently on
the Vertical Spacing page in Setup > Layout Options.

The options available allow you to set your ideal spacing, which Dorico Pro then produces as
closely as possible. For example, as part of the calculation to decide the number of systems that
can fit in each frame in a layout, Dorico Pro considers the height of staves, the minimum gaps
between staves, the maximum distances between very high/low notes and staves, and other
items that require vertical space, such as pedal lines and tempo marks. However, this calculation
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happens before horizontal spacing is finalized, which can result in either more or fewer systems
being allocated to frames than ideally fit.

We recommend familiarizing yourself with the available vertical spacing options.

Individual staff spacing changes

You can make adjustments to the vertical position of individual staves and systems when Staff
Spacing is activated in the Engrave toolbox. When Staff Spacing is activated, the following
handles are shown:

● A small square staff spacing handle on the bottom left corner of each staff.

● A large square system spacing handle on the top left corner of the top staff in each
system.

System spacing handle and staff spacing handle in Engrave mode when Staff Spacing is activated

Staff spacing handles allow you to adjust the vertical position of the selected staves. The gap
between staves is shown in millimeters by default, and you can click these numbers to change
the value using the supported units of measurement, which are points, millimeters, centimeters,
and inches. System handles allow you to adjust the vertical position of whole systems.

When staff spacing handles have been moved, their color changes. When you move system
handles, both the square handle and the highlighted strip at the top of the system change color.

You can copy manual changes you have made to the staff spacing on individual pages to other
pages in the layout.

IMPORTANT

We recommend that you add extra pages and finish laying out your pages before moving
individual staves, as individual staff spacing changes are automatically deleted if the page on
which they occur or the rhythmic position at the start of the system changes. For example, if you
move staves individually and then add a blank page at the start of the layout, all of the individual
staff spacing changes in the layout are deleted.

NOTE

● When Staff Spacing is activated, you cannot make any selections or make other types of
edits to items in the current layout. To resume normal selection and editing, click Graphic
Editing in the Engrave toolbox or return to Write mode.

● You can change your preferred unit of measurement to be used throughout Dorico Pro on
the General page in Preferences.

RELATED LINKS
Per-layout vertical spacing options on page 393
Staves on page 906
Brackets and braces on page 555
Engrave toolbox on page 291
Copying staff spacing changes to other pages on page 398
Hiding/Showing empty staves on page 351
Changing your preferred unit of measurement on page 57
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Changing the default staff/system spacing
You can change the default gaps between staves and systems in each layout independently. For
example, you can have smaller gaps between staves in full score layouts to accommodate more
staves, and larger gaps between systems in part layouts to give players space to add pencil
markings.

TIP

● If the staves in a layout are very close together, just decreasing the staff size might be
sufficient to produce good results.

● We recommend that you set the ideal gaps to the minimum value acceptable to you, as
Dorico Pro automatically allocates additional space for other items, such as system objects
and dynamics, and avoids collisions between notes and staves above/below.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the default staff/system
spacing.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Vertical Spacing in the page list.

4. In the Ideal Gaps section, change the values for the different contexts as required.

5. Click Apply, then Close.

RESULT
The minimum gaps between staves and systems in the corresponding contexts are changed. This
affects how much space Dorico Pro allows for staves/systems in its casting off estimations and
whether frames are considered full enough to justify vertically automatically.

RELATED LINKS
Changing the staff size in layouts on page 908
Changing the vertical justification of staves/systems on page 350

Per-layout vertical spacing options
Dorico Pro provides multiple options that you can use to control the default vertical spacing and
justification of staves and systems in each layout.

● You can access per-layout vertical spacing options by choosing Setup > Layout Options
and clicking Vertical Spacing in the page list.

The Vertical Spacing page contains the following sections and options:

Ideal Gaps
Contains multiple scenarios that allow you to set the gap you want Dorico Pro to
allow between staves and systems in the corresponding context, including the
default scaling of these gaps in galley view, as Dorico Pro does not automatically
avoid collisions between staves and items in galley view. The options are
accompanied by diagrams to help you visualize the contexts to which each option
applies.
We recommend setting the ideal gaps to the minimum value acceptable to you
because Dorico Pro never reduces the gap between staves to less than your set
values. Setting smaller values gives Dorico Pro greater flexibility when determining
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staff spacing, particularly in very full frames, such as reducing the space between
staves with no dynamics to allow more space between staves with dynamics.
Similarly, we recommend setting vertical spacing options after you have finished
inputting notes and items, as this allows you to consider the entire project when
setting these options.
Depending on the context, the options are affected by automatic vertical justification
in different ways:

● Staff to staff, Staff group to staff, Staff to staff group, Staff group to staff
group, Inter-system gap, and Timecode staff to staff
These gaps do not apply in frames that are automatically justified.

● Braced staff to braced staff and Ossia staff to staff
These gaps always apply, including in frames that are automatically justified,
because braced and ossia staves are never justified. This includes extra staves.

NOTE

● Divisi staves are vertically justified when they use the Staff to staff gap. When
they use the Braced staff to braced staff gap, the staves in each divisi section
use only the gap set for braced staves and are not vertically justified.

● If the staves in a layout are very close together, just decreasing the staff size
might be sufficient to produce good results.

Minimum Gaps
Contains options for the minimum gaps you want Dorico Pro to allow for items in
addition to the staff spacing gaps.

● Automatically resolve collisions between adjacent staves and systems:
When activated, Dorico Pro automatically allows extra space between staves
and systems to avoid collisions. When deactivated, Dorico Pro only uses your
set gaps for vertical spacing, which produces evenly-spaced staves and
systems but with the possibility of collisions between items.

● Minimum inter-staff gap with content: Allows you to set the extra space you
want to allow between staves when items are present.

● Minimum inter-system gap with content: Allows you to set the extra space
you want to allow between systems when items are present.

Vertical Justification
Contains options that allow you to control the frame fullness thresholds above which
you want staves and/or systems to justify vertically automatically.

● Justify distance between staves and systems when frame is at least [n]%
full: When frames are filled above this threshold, the staves and systems they
contain are all automatically vertically justified, meaning they are evenly
distributed to fill the height of the frame. Frames filled below this threshold
are not automatically justified, instead staves follow your ideal gap settings.
This can leave gaps between the bottom staff/system and the bottom of the
frame.

● Justify distance only between systems when frame is at least [n]% full:
When frames are filled above this threshold, only the distance between
systems in the frame is justified. Staves follow your per-layout ideal gap
settings. This helps keep a clear distance between systems on very full pages.

TIP

To achieve consistently spaced systems in part layouts where all the systems
contain only a single staff or a pair of braced staves, we recommend making
the Justify distance only between systems when frame is at least [n]% full
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value the same as or smaller than the Justify distance between staves and
systems when frame is at least [n]% full.

● Justify staves when frame with single system is above this threshold:
When activated, all the staves in a single system taller than the set threshold
are vertically justified, which distributes them evenly to fill the height of the
frame.

Hide Empty Staves
Contains options allowing you to control when and which empty staves are hidden in
the layout.

● Hide empty staves: Allows you to control when empty staves are hidden. For
example, it is a common practice to show all staves in the first system even if
some are empty, but this is not always required.

● Allow individual staves of multi-staff instruments to be hidden: Allows you
to control whether individual empty staves belonging to multi-staff
instruments can be hidden independently or all multi-staff instrument staves
must always be shown.

● Players excluded from Hide Empty Staves: Allows you to identify specific
players whose staves you always want to show, even if their staff is empty on
systems where you have hidden empty staves.

RELATED LINKS
Page layouts on page 342
Casting off on page 355
Changing the vertical justification of staves/systems on page 350

Changing the staff spacing in galley view
You can change the vertical space between staves in galley view in each layout independently,
expressed as a percentage of the set ideal gaps. Increasing the gaps between staves in layouts
with very high/low notes can be useful because Dorico Pro does not perform automatic collision
avoidance in galley view.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the staff spacing in
galley view.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Vertical Spacing in the page list.

4. In the Ideal Gaps section, change the value for In galley view, expand ideal staff gaps
to.

5. Click Apply, then Close.
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Moving individual staves/systems vertically
You can change the spacing of individual staves, including ossia staves, by changing the vertical
position of individual staves and systems independently of your project-wide settings.

IMPORTANT

We recommend that you add extra pages and finish laying out your pages before moving
individual staves. Individual staff spacing changes are automatically deleted if the page on which
they occur or the rhythmic position at the start of the system changes.

PROCEDURE

1. In the Engrave toolbox, activate Staff Spacing.

2. Select one of the following on each staff/system you want to move vertically:

● Staff spacing handle

● System spacing handle

NOTE

● You can switch between having a staff or system spacing handle selected by
pressing Tab.

● When using the mouse, you can only move one staff/system at a time.

3. Move the selected staves/systems in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

● Click and drag a single staff/system spacing handle upwards/downwards.

RESULT
The vertical position of the selected staves/systems is changed. The color of the handles changes
to indicate that you have moved them.
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EXAMPLE

Staff spacing handles at their default positions The second staff has been moved upwards

Removing individual changes to staff spacing
You can remove changes you have made to the staff/system spacing and reset staff/system
spacing handles to their original default positions.

PROCEDURE

1. In the Engrave toolbox, activate Staff Spacing.

2. Select the staff/system handles you want to reset to their original positions.

3. Press Backspace or Delete.

RESULT
The selected staff/system handles are reset to their original positions.

TIP

You can also reset all staff spacing changes within selected systems, frames, or all staff spacing
changes in the layout by choosing one of the options in the Engrave > Staff Spacing menu.

Moving multiple systems simultaneously
You can move multiple systems at the same time so that the gaps between each system remain
equal. This is also known as “concertina dragging”.

IMPORTANT

We recommend that you add extra pages and finish laying out your pages before moving
individual staves. Individual staff spacing changes are automatically deleted if the page on which
they occur or the rhythmic position at the start of the system changes.

NOTE

● You can only move multiple systems closer together, you cannot use this method to move
them further apart.

● You cannot follow these steps for staff spacing handles on tacets.

PROCEDURE

1. In the Engrave toolbox, activate Staff Spacing.

Engrave mode
Staff spacing 

397
Dorico 2.2.20



2. Select the system handle on the highest system you want to move.

3. Alt-click and drag the system handle downwards.

RESULT
All systems below the selected system, until the bottom of the music frame, are moved closer
together. The gaps between each system remain equal.

RELATED LINKS
Staff spacing on page 391
Tacets on page 352

Copying staff spacing changes to other pages
You can copy manual staff spacing changes you have made on individual pages to other pages in
the layout.

NOTE

In order to copy staff spacing changes, destination pages must have the same number of staves
per system and the same number of systems per frame as the source page.

PROCEDURE

1. In the music area, open the layout in which you want to copy staff spacing from one page
to other pages.

2. Choose Engrave > Staff Spacing > Copy Staff Spacing to open the Copy Staff Spacing
dialog.

3. In the Copy Staff Spacing dialog, change the page whose staff spacing you want to copy
by changing the value for From page.

4. Change the first page to which you want to copy staff spacing by changing the value for To
page start.

5. Change the last page in the range to which you want to copy staff spacing by changing the
value for To page end.

6. Click OK to save your changes and close the dialog.

RELATED LINKS
Moving individual staves/systems vertically on page 396

Copy Staff Spacing dialog
In the Copy Staff Spacing dialog, you can choose pages whose individual staff spacing changes
you want to copy. You can specify the pages in the layout to which you want to copy the staff
spacing changes.

● You can open the Copy Staff Spacing dialog in Engrave mode by choosing Engrave >
Staff Spacing > Copy Staff Spacing.

The Copy Staff Spacing dialog contains the following options:

From page
Allows you to change the page whose staff spacing you want to copy by specifying
the page number.
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To page start
Allows you to set the first page in the layout to which staff spacing changes are
copied.

To page end
Allows you to set the last page in the layout to which staff spacing changes are
copied.

For example, if you wanted to copy staff spacing changes you made on the first page to the next
three pages, meaning pages two, three, and four, but not to page five and onwards, you would
set From page to 1, To page start to 2, and To page end to 4.

Previews show the displayed page number beside each value field, so that if you have changed
the displayed page number of pages within the layout you can still identify the page to which you
are copying staff spacing changes.
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Play mode allows you to set up your project for playback. You can assign VST instruments, adjust
the mix, and change the sounding duration of notes in playback without affecting their notated
duration.

Project window in Play mode
The project window in Play mode contains the default toolbar and the event display, and also a
toolbox and panels that contain all the tools and functions that allow you to set up your project
for playback.

You can switch to Play mode in any of the following ways:

● Press Ctrl/Cmd-4.

● Click Play in the toolbar.

● Choose Window > Play.

Project window in Play mode

NOTE

There is no Properties panel in Play mode.

The project window in Play mode comprises the following:

Play mode
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1 Play toolbox
Contains tools that allow you to select and edit note events in the event display.

2 Event display
Allows you to view, input, and edit the playback of each flow in your project, including
changing the played duration of notes and the tempo at any rhythmic position.

3 VST and MIDI Instruments panel
Allows you to load new VST and MIDI instruments. You can also select existing VST and
MIDI instruments and edit their settings.

RELATED LINKS
Event display on page 407

Play toolbox
The Play toolbox contains tools that allow you to select and edit the note events in the event
display in Play mode. It is located on the left of the window in Play mode.

Played Durations

Allows you to change when notes start/end in playback without affecting their
notated durations. When Played Durations is selected, the played durations of notes
are shown as a lighter event, above a thinner line that shows the notated duration of
notes.

Notated Durations

Allows you to change the rhythmic duration of notes, which affects the position and
notation of those notes. When Notated Durations is selected, the full, notated
durations of notes are shown as single events in the piano roll editor.

Object Selection

Allows you to select notes in the piano roll editor. Select Object Selection to deselect
Erase.
You can also select Object Selection by pressing S.

Draw

Allows you to add and edit notes. You can click and drag in the piano roll editor to
input notes with the durations you want. The ends of the notes you draw snap to
rhythmic positions according to the current rhythmic grid value.
It also allows you to add points on time and automation tracks. Using the Draw tool
rather than the Line tool adds a point at regular intervals according to the current
rhythmic grid value.
You can also select Draw by pressing D.

Line

Allows you to draw straight lines between two points on time and automation tracks,
without adding extra values between those points.
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Draw Percussion

Allows you to add notes to percussion staves in the drum editor with one click. You
do not have to click and drag to a duration when using Draw Percussion.

Erase

Allows you to delete notes. You can make marquee selections to delete multiple
notes when Erase is selected.
You can also select Erase by pressing E.

VST and MIDI Instruments panel
The VST and MIDI instruments panel contains the VST and MIDI instruments available and used
in your project, and allows you to edit their settings. It is located on the right of the window in
Play mode.

VST and MIDI Instruments panel

The VST and MIDI Instruments panel contains the following sections:

1 VST Instruments

2 MIDI Instruments
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VST Instruments

The VST Instruments section of the panel contains rack slots in which you can select VST
instruments to use for playback.

NOTE

Dorico Pro only shows VST 3 instruments by default. If you want VST 2 instruments to be
available in the VST Instruments section of the VST and MIDI Instruments panel, you must
whitelist them. Only Kontakt is available by default.

When you add instruments in your project, Dorico Pro automatically creates a playback template
containing instances of HALion Sonic SE with sounds chosen from the HALion Sonic SE and
HALion Symphonic Orchestra libraries. Dorico Pro also sets up expression maps and percussion
maps as required.

If you change any of these default settings, Dorico Pro no longer makes automatic changes,
meaning you must then load sounds for new instruments manually. Additionally, the HALion
plug-in does not communicate changes in the plug-in to Dorico Pro, meaning Dorico Pro still tries
to play back the music in your project using the expression map for the original sounds.

You must change the expression map manually for each plug-in you change.

Therefore, we recommend that you do one of the following if you want to update the sounds
used for playback after making changes:

● Choose Play > Load Sounds for Unassigned Instruments to change the default settings
and then add new instruments to your project. This automatically loads sounds for
instruments in your project without assigned sounds.

● Choose Play > Playback Template to open the Playback Template dialog, where you can
reload a default playback template.

You can add new slots for VST instruments and delete VST instruments by clicking the respective
button in the action bar.

● Add

Adds a new slot for a VST instrument in the VST Instruments section of the VST and MIDI
Instruments panel.

● Delete

Deletes the selected VST instrument from the VST Instruments section of the VST and
MIDI Instruments panel.

MIDI Instruments

The MIDI Instruments section of the panel contains rack slots in which you can select MIDI
devices to use for output during playback.

NOTE

For your MIDI device to be available for selection, you must plug it into your computer before
starting Dorico Pro. If you plug it in after starting Dorico Pro, you must restart the program.

On Windows, you can select any MIDI device that is plugged into your computer.

On macOS, you can select any MIDI device that is plugged into your computer, and any other
device set up in Audio MIDI Setup. For example, this allows you to use MIDI from one application
in another application.
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You can add new slots for MIDI instruments and delete MIDI instruments by clicking the
respective button in the action bar.

● Add

Adds a new slot for a MIDI instrument in the MIDI Instruments section of the VST and
MIDI Instruments panel.

● Delete

Deletes the selected MIDI instrument from the MIDI Instruments section of the VST and
MIDI Instruments panel.

Loading VST and MIDI instruments manually
Dorico Pro automatically loads enough VST slots for all the samples required for your project.
However, you can also load VST and MIDI instruments manually, either into new slots or into
existing slots to replace existing VST and MIDI instruments.

PREREQUISITE

● You have any VST instruments you want to use saved on your computer.

● You have connected the MIDI device you want to use.

NOTE

You must have connected the device to your computer before starting Dorico Pro. If not,
you must restart Dorico Pro.

PROCEDURE

1. In either the VST Instruments or MIDI Instruments section of the VST and MIDI
Instruments panel, click Add.

2. In the slot in which you want to load a VST or MIDI instrument, select an instrument from
the menu.

Whitelisting VST instruments
You must whitelist any VST 2 instruments you want to use in Dorico Pro. Because whitelisting
works like a preference, you must only whitelist plug-ins once for them to be available in any
project.

A default vst2whitelist.txt file is included with your Dorico Pro installation, which lists
VST 2.x plug-ins that Steinberg has qualified for use with Dorico Pro.

You can create a second vst2whitelist.txt file in a user-specific location that is not
overwritten if you subsequently update or reinstall Dorico Pro.

When Dorico Pro starts up, it reads both the default whitelist file and your user-specific whitelist
file to build up the list of whitelisted plug-ins.

PREREQUISITE
You have quit Dorico Pro and all other programs.

PROCEDURE

1. Open a new text document in a plain text editor, such as Notepad.
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2. Enter the file names of the VST plug-ins you want to whitelist without their file extension
(.dll on Windows and .vst on macOS).
Each plug-in must have its own line in the text file.

3. Save your own vst2whitelist.txt file in one of the following places, depending on your
operating system:

● C:\Users\username\AppData\Roaming\Steinberg\VSTAudioEngine2_64
(Windows)

● /Users/username/Library/Preferences/VSTAudioEngine2 (macOS)

4. Delete the following files from the folder:

● Vst2xPlugin Blacklist VSTAudioEngine.xml

● Vst2xPlugin Infos VSTAudioEngine.xml

● Vst2xPlugin SearchPaths VSTAudioEngine.xml

RESULT
When you next start Dorico Pro, it considers your whitelisted VST plug-in entries, making them
available for use in the program.

Playback Options dialog
The Playback Options dialog provides options that allow you to make project-wide changes to
how the music you have written sounds when played back. These options affect playback,
regardless of expression maps and patches.

In the Playback Options dialog, you can change how dynamics, pedal lines, and different
notations are interpreted during playback.

For example, you can change how much louder notes on the first beat in each bar are compared
to other notes in the bar, change how long each pedal retake lasts, and how much different
articulations, such as staccatissimo and tenuto, affect the duration of notes.

You can open Playback Options in any of the following ways:

● Press Ctrl/Cmd-Shift-P in any mode.

● Choose Play > Playback Options in Play mode.
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Playback Options

The Playback Options dialog contains the following:

1 Page list
Contains the categories of options that you can view and change in the dialog, divided into
pages. When you click a page in this list, any applicable section titles appear below the
page in the page list.

2 Section titles
Shows the titles of any sections on the selected page. You can click these section titles to
navigate directly to that section of the page.

3 Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. For options that have multiple possible
settings, the current setting is highlighted.

4 Save as Default/Remove Saved Defaults
This button has different functions depending on whether you have existing saved
defaults.

● Save as Default saves all options currently set in the dialog as the default for new
projects.

● Remove Saved Defaults deletes your previous saved defaults without resetting the
options in the current project. After removing your saved defaults, all future projects
start with the default factory settings. If you have existing saved defaults, you can
access Remove Saved Defaults by pressing Alt (macOS)/Ctrl (Windows).

5 Reset to Factory/Reset to Saved Defaults
This button has different functions depending on whether you have existing saved
defaults.

● If you have no saved defaults, Reset to Factory resets all the options in the dialog
back to the default factory settings.

● If you have existing saved defaults, Reset to Saved Defaults resets all the options in
the dialog back to your saved defaults. You can access Reset to Factory instead by
pressing Alt (macOS)/Ctrl (Windows). Resetting options back to the default factory
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settings only affects the current project and does not delete your saved defaults,
meaning future projects start with your saved defaults.

RELATED LINKS
Expression maps on page 451
Options dialogs in Dorico Pro on page 30

Event display
The event display in Play mode is the equivalent of the music area in Write mode. It allows you to
view and edit your music, but focuses more on how it sounds in playback rather than its notation.
The event display presents your project in a similar way to that used in a digital audio
workstation, or “DAW”, such as Cubase.

Event display in Play mode

The event display comprises the following:

1 Flow menu
Allows you to select the flow you want to be shown in the event display. Only a single flow
is shown at a time.

2 Track headers
Display the name of each track and contain appropriate options for the track type. You can
expand the track headers of some track types, which reveals further options.

3 Ruler
Displays bar numbers and shows beat divisions that match the current rhythmic grid
value.

4 Playhead
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Shows the current rhythmic position in playback.

5 Tracks
Horizontal rows that contain musical elements represented in time from left to right.

6 Drum editor
Displays notes for unpitched percussion instruments.

7 Piano roll editor
Displays notes for pitched instruments.

Tools and options in the Play toolbox allow you to input, edit, and delete notes and other events,
such as tempo changes, in the event display.

RELATED LINKS
Playhead on page 430
Tracks on page 414
Play toolbox on page 401

Piano roll editor
The piano roll editor displays MIDI notes for pitched instruments in a continuous sequence, with
the vertical position of note events indicating their pitch.

In Dorico Pro, pitched instruments are displayed in an individual piano roll editor for their
instrument track.

Pitched instruments are positioned in the piano roll editor according to their pitch, which is
demonstrated by a piano keyboard on the left edge of the piano roll editor.

Piano roll editor

Each instrument is automatically assigned a color when you add them in Setup mode, so that you
can tell them apart more easily in Play mode. This color is used for notes in the piano roll on that
instrument track, as well as shown as a strip on the instrument track header.

You can edit notes in the piano roll editor, including moving and transposing them.

NOTE

Editing the played duration of notes causes them to appear in a darker color in the piano roll
editor to notes whose played duration you have not changed.

RELATED LINKS
Instrument tracks on page 416
Played vs. notated note durations on page 466
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Drum editor
The drum editor displays MIDI notes for unpitched percussion instruments in a continuous
sequence. The drum editor appears different to the piano roll editor and has different
functionality.

Instead of showing the piano roll view as used in the piano roll editor, in the drum editor the
onset of each note on each percussion instrument is shown. Each note is shown as an event of
the same size, unlike note events in the piano roll, whose width reflects the duration of the notes.

Drum editor

Each unpitched percussion instrument has its own instrument track, including when they are in a
percussion kit. You can expand unpitched percussion instrument tracks like other instrument
tracks if you want to make changes, such as assigning the instrument to another playback
endpoint.

NOTE

If you change the endpoint for an unpitched percussion instrument, that endpoint must have an
appropriate percussion map chosen, otherwise Dorico Pro does not know how to play the music
for that instrument.

You can move notes in the drum editor to new rhythmic positions. Unpitched percussion
instruments only have one vertical position for their notes, so you cannot transpose notes in the
drum editor.

RELATED LINKS
Instrument tracks on page 416
Expanding/Collapsing tracks on page 429

Inputting notes in the event display
You can input notes into the instruments in your project using the event display in Play mode.
You can follow these steps for both pitched and unpitched instruments.

PROCEDURE

1. Expand the instrument tracks into which you want to input notes.

TIP

When inputting notes in unpitched percussion instruments, expanding just the player
track is sufficient.

2. Select one of the following tools, depending on the instrument type:

● To input notes in pitched instrument tracks, select Draw by pressing D or clicking
Draw in the Play toolbox.
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● To input notes in unpitched percussion instrument tracks, select Draw Percussion
by clicking Draw Percussion in the Play toolbox.

3. Input notes in one of the following ways, depending on the instrument type:

● For pitched instruments, click and drag horizontally in the piano roll for the required
duration at the pitch position you want.

● For unpitched percussion instruments, click in the drum editor at the positions
where you want to input notes.

RESULT
In the piano roll editor, notes are input at the pitches indicated by the piano keyboard on the left
of the piano roll.
In the drum editor, a note is input in the corresponding instrument each time you click. The
current rhythmic grid value determines the duration of the notes. The duration of notes is
indicated by a highlighted area in the track. The shape of the note event in the drum editor is the
same for all durations.

AFTER COMPLETING THIS TASK
You can change both the notated and played durations of notes. You can also change the
duration of notes in the score in Write mode.

RELATED LINKS
Instrument tracks on page 416
Expanding/Collapsing tracks on page 429
Changing the played duration of notes on page 466
Changing the duration of notes on page 157

Moving notes in the event display
You can move notes rhythmically within the event display. This also affects how the selected
notes are notated in any relevant score and part layouts.

PREREQUISITE

● Object Selection is selected in the Play toolbox.

● Notated Durations is selected in the Play toolbox.

PROCEDURE

1. Expand the instrument tracks whose notes you want to move.

TIP

When moving notes belonging to unpitched percussion instruments, expanding just the
player track is sufficient.

2. Select the notes you want to move rhythmically.

3. Move the selected notes according to the current rhythmic grid value in any of the
following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.
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● Click and drag them to the right/left.

RESULT
The selected notes are moved to new rhythmic positions according to the current rhythmic grid
value. If you selected multiple notes, they are moved together as a block.

NOTE

When using the keyboard, you can both transpose and move notes in the piano roll editor in the
same action. When using the mouse, you must release the mouse between transposing and
moving.

RELATED LINKS
Play toolbox on page 401

Lengthening/Shortening notes in the piano roll editor
You can change the duration of notes belonging to pitched instruments from within the piano
roll editor in Play mode. This automatically changes the notated duration of notes in any relevant
score and part layouts.

PREREQUISITE

● Object Selection is selected in the Play toolbox.

● Notated Durations is selected in the Play toolbox.

PROCEDURE

1. Expand the instrument tracks whose notes you want to lengthen/shorten.

2. In the piano roll editor, select the notes you want to lengthen/shorten.

3. Lengthen/Shorten the notes in any of the following ways:

● To lengthen notes by the current rhythmic grid value, press Shift-Alt-Right Arrow.

● To shorten notes by the current rhythmic grid value, press Shift-Alt-Left Arrow.

● To double the length of notes, press Ctrl/Cmd-Shift-Alt-Right Arrow.

● To halve the length of notes, press Ctrl/Cmd-Shift-Alt-Left Arrow.

● Click and drag the right end of one of the selected notes to the length you want.

NOTE

You can only change the notated duration of notes with the mouse when Notated
Durations is selected in the Play toolbox. When Played Durations is selected, you
can click and drag notes to change their played duration.

RESULT
The notes are lengthened/shortened.

NOTE

If you select multiple notes that end at different rhythmic positions and drag them with the
mouse pointer, changing their duration forces all the notes to end at the same rhythmic position.

RELATED LINKS
Expanding/Collapsing tracks on page 429
Played vs. notated note durations on page 466
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Changing the duration of notes on page 157
Play toolbox on page 401

Transposing notes in the piano roll editor
You can transpose notes in the piano roll editor by moving them vertically to other pitch
positions. You cannot transpose notes in the drum editor, or move them to other unpitched
percussion instruments.

PREREQUISITE
Object Selection is selected in the Play toolbox.

PROCEDURE

1. Expand the instrument tracks whose notes you want to transpose.

2. In the piano roll editor, select the notes you want to transpose.

3. Transpose the notes in any of the following ways:

● To move notes up one staff position, such as from C to D, press Alt-Up Arrow.

● To move notes down one staff position, such as from D to C, press Alt-Down Arrow.

● To transpose notes up a single octave division, such as a quarter tone in 24-EDO,
press Shift-Alt-Up Arrow.

● To transpose notes down a single octave division, such as a quarter tone in 24-EDO,
press Shift-Alt-Down Arrow.

● To transpose notes up an octave, press Ctrl/Cmd-Alt-Up Arrow.

● To transpose notes down an octave, press Ctrl/Cmd-Alt-Down Arrow.

● Click and drag them upwards/downwards.

RESULT
The selected notes are transposed according to their new pitch positions in the piano roll editor.

NOTE

● This also affects how the selected notes are notated in any relevant score and part layouts.

● When using the keyboard, you can both transpose and move notes in the piano roll editor
in the same action. When using the mouse, you must release the mouse between
transposing and moving.

RELATED LINKS
Moving notes in the event display on page 410
Equal Division of the Octave (EDO) on page 674
Play toolbox on page 401

Deleting notes in the event display
You can delete notes in the event display in Play mode. This also removes notes from any
relevant score and part layouts.

PROCEDURE

1. Expand the instrument tracks whose notes you want to delete.
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TIP

When deleting notes from unpitched percussion instruments, expanding just the player
track is sufficient.

2. Press E to select Erase.

3. Delete notes in any of the following ways:

● Click individual notes.

● Make a marquee selection to delete multiple notes at once.

NOTE

You can only make marquee selections on a single instrument, including percussion
instruments in percussion kits.

RESULT
The notes you click or include in a marquee selection are deleted.

TIP

You can also delete notes by selecting Object Selection in the Play toolbox, then selecting the
notes you want to delete in the event display and pressing Backspace or Delete.

RELATED LINKS
Selecting multiple items using marquee selections on page 43

Zooming in/out of tracks in the event display
You can change the zoom level in the tracks in the event display to make notes appear larger/
smaller. This does not affect the height of tracks.

PROCEDURE

● Change the zoom in any of the following ways:

● To make notes appear wider, press Z.

● To make notes appear narrower, press X.

● To make notes appear taller, Shift-click and drag upwards on the piano keyboard on
the left.

● To make notes appear shorter, Shift-click and drag downwards on the piano
keyboard on the left.

● To make notes appear wider and taller, spread two fingers outwards on a touchpad.

● To make notes appear narrower and shorter, pinch two fingers together on a
touchpad.

● To make notes appear wider, click and drag downwards along the playhead in the
ruler.

● To make notes appear narrower, click and drag upwards along the playhead in the
ruler.

RELATED LINKS
Changing the height of tracks on page 429

Play mode
Event display 

413
Dorico 2.2.20



Tracks
Tracks are rows in the event display that represent time horizontally from left to right. They allow
you to control multiple musical elements in a project simultaneously but independently of each
other.

The term was established when audio mixing was done on tapes, and multitracking allowed
separate elements of the music to be recorded and edited independently of each other before
being combined into the final piece of music.

In modern programs, such as Cubase, tracks can contain many types of sounds, including audio
recordings and software instruments. Tracks containing audio recordings often display the
waveform of the audio, while tracks containing software instruments often display the pitches as
rectangular note events positioned horizontally in time and vertically in pitch on a piano roll.

Dorico Pro provides the following types of tracks in the event display in Play mode:

Player tracks
Contain all the instrument tracks belonging to that player. You can expand/collapse
player tracks to show the instrument tracks they contain.

Instrument tracks
Display the notes belonging to the instrument in a piano roll or drum editor,
depending on the type of instrument.
Each instrument track also has its own playing techniques lane and automation lane.

Time track
Displays tempo changes in the flow, including tempo marks input in Write mode as
well as tempo changes input in the Time track.

Chords track
Displays chord symbols in the flow.

Markers track
Displays markers in the flow, including their text.

Video track
Shows where there is video in the flow, if applicable, including its file name.

RELATED LINKS
Event display on page 407
Player tracks on page 415
Instrument tracks on page 416
Time track on page 421
Chords track on page 425
Markers track on page 427
Video track on page 429
Expanding/Collapsing tracks on page 429
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Player tracks
Player tracks represent each player in the flow currently shown in the event display and show
where notes exist for any of the instruments held by that player. Player tracks are labelled using
the player names given to players in Setup mode.

Example player track

Each player track comprises the following:

1 Track height adjuster
Allows you to change the height of the track by clicking and dragging its bottom corner.

2 Track disclosure arrow
Allows you to expand/collapse the track. Expanding player tracks reveals the instrument
tracks of all the instruments held by that player. You can then expand/collapse each
instrument track individually.

Expanded player track revealing two collapsed instrument tracks

3 Track name
Shows the name of the track. Player tracks use the player name given to the player in the
Players panel in Setup mode.

4 Track header
Shows the name of the track and contains the track disclosure arrow.

5 Colored regions
Show where notes exist for any of the instruments held by the player. On collapsed
instrument tracks, colored regions show where notes exist for that instrument.

● Colored regions on player tracks use the color assigned to the top instrument held
by the player.

● Colored regions on collapsed instrument tracks use the color assigned to that
instrument.

NOTE

To interact with the notes indicated by a colored region, you must expand the player track
and the corresponding instrument track.

RELATED LINKS
Event display on page 407
Piano roll editor on page 408
Drum editor on page 409
Expanding/Collapsing tracks on page 429
Player, layout, and instrument names on page 96
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Instrument tracks
Instrument tracks allow you to view, input, and edit notes belonging to the corresponding
instrument, displayed on a piano roll editor or drum editor, depending on the type of
instrument. They are labelled using the instrument name for each instrument.

Each instrument in your project has its own instrument track in the event display in Play mode,
including when a single player holds multiple instruments.

Instruments are automatically assigned a track color when you add them in Setup mode, so that
you can tell them apart more easily in Play mode. This color appears as a strip on the instrument
track and is used for notes in the event display.

Example instrument track

Each instrument track comprises the following:

1 Track height adjuster
Allows you to change the height of the track by clicking and dragging its bottom corner.

2 Color strip
Displays the color assigned to the track. This color is also used for notes in the piano roll
editor/drum editor and for colored regions on player tracks/collapsed instrument tracks.

3 Track header
Shows the name of the track and contains appropriate options for instrument tracks, such
as VST or MIDI slot menus.

4 Piano roll editor/Drum editor
Displays notes belonging to the instrument in either a piano roll editor or drum editor,
depending on the instrument type.

Example instrument track header
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Each instrument track header contains the following:

1 Track disclosure arrow
Allows you to expand/collapse the track.

● Collapsed player tracks show colored regions in the event display. You cannot select
or move colored regions.

● Expanded player tracks show notes in either a piano roll editor or drum editor,
depending on the instrument type.

2 Track name
Shows the name of the track. Instrument tracks use the instrument name set in the Edit
Instrument Names dialog for the instrument.

3 VST or MIDI Instrument menu
Allows you to select an instance of a VST or MIDI instrument to use for the instrument
track.

4 Edit Instrument
Opens the corresponding VST instrument, allowing you to edit settings for the slot or
channel.

5 Port menu
Allows you to change the endpoint to which the instrument is assigned by selecting the
port you want to use when using a plug-in that has multiple ports of 16 channels.

6 Slot menu
Allows you to change the endpoint to which the instrument is assigned by selecting the
slot in the selected VST instrument, or channel in the selected MIDI instrument, that you
want to use for the instrument track.

7 Show the automation lane
Hides/Shows the automation lane below the instrument track.

8 Show the playing techniques lane
Hides/Shows the playing techniques lane below the instrument track.

RELATED LINKS
Expanding/Collapsing tracks on page 429
Event display on page 407
Player tracks on page 415
Piano roll editor on page 408
Drum editor on page 409
Automation lanes on page 418
Player, layout, and instrument names on page 96
Endpoint Setup dialog on page 448
Assigning instruments to endpoints on page 450

Playing techniques lanes
Playing techniques lanes display where you have input playing techniques for the corresponding
instrument. Each instrument track has its own playing techniques lane that you can show in the
event display.

● You can hide/show the playing techniques lane for an instrument track by clicking Show
the playing techniques lane in the instrument track header.
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Playing techniques lane below an instrument track

Playing techniques lanes comprise the following:

1 Lane header
Shows the name of the lane.

2 Playing technique regions
Display the playing technique that applies to notes in the region. You can hover your
mouse pointer over playing technique regions on the lane to see the following related
information:

● Playing technique/Playing technique combination used in the expression map

● VST or MIDI instrument used for the region

● Channel in the VST instrument used for the region

● Expression map used for the region

NOTE

You cannot change playing techniques using this lane.

RELATED LINKS
Instrument tracks on page 416
Event display on page 407
Expression maps on page 451

Hiding/Showing playing techniques lanes

You can hide/show the playing techniques lane for each instrument track.

PROCEDURE

1. Expand the instrument tracks whose playing technique lanes you want to hide/show.

2. In each instrument track header, click Show the playing techniques lane.

RESULT
The playing techniques lane for each instrument track is shown when the button is highlighted,
and hidden when the button is not highlighted.

Automation lanes
Automation lanes allow you to view, input, and edit MIDI controller data that applies to the
corresponding instrument. Each instrument track has its own automation lane that you can show
in the event display.

● You can hide/show the automation lane for an instrument track by clicking Show the
automation lane in the instrument track header.

● You can change the MIDI controller whose data is displayed in the automation lane by
selecting the controller from the menu in the automation lane track header.
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Automation lane below an instrument track

Automation lanes comprise the following:

1 Lane header
Contains the MIDI controller menu.

2 MIDI Controller menu
Allows you to select the MIDI controller whose automation data you want to view and edit
in the automation lane. Controllers that already contain automation data are shown with
an asterisk beside their name in the menu.

3 Automation events input using the Draw tool
When you use the Draw tool to input automation, separate events are created where you
click. If you click and drag, separate events are created at regular intervals according to the
current rhythmic grid value.

4 Gradual automation events input using the Line tool
When you use the Line tool to input automation, a smooth line is created with a single
automation event at each end.

Although only a single automation lane can be displayed, it is possible to create data for multiple
MIDI controllers in the same lane.

All automation events drawn in automation lanes are included when exporting MIDI files.

RELATED LINKS
Instrument tracks on page 416

Hiding/Showing automation lanes

You can hide/show the automation lane for each instrument track.

PROCEDURE

1. Expand the instrument tracks whose automation lanes you want to hide/show.

2. In each instrument track header, click Show the automation lane.

RESULT
The automation lane for each instrument track is shown when the button is highlighted, and
hidden when the button is not highlighted.

Inputting automation in automation lanes

You can input automation data for multiple MIDI controllers in the automation lane for each
instrument track.

PREREQUISITE
The automation lane is shown for each instrument to which you want to add automation.
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PROCEDURE

1. In each automation lane header, select the MIDI controller into which you want to input
automation from the MIDI Controller menu.

2. Select one of the following tools, depending on the type of automation you want to input:

● To input single automation events, or multiple automation events at regular
intervals according to the current rhythmic grid value, select Draw by pressing D or
clicking Draw in the Play toolbox.

● To input gradual automation events, select Line by clicking Line in the Play toolbox.

3. Input automation in one of the following ways:

● To input single automation events, click in the automation lane at each position
where you want an automation event.

● To input multiple automation events at regular intervals, click and drag in the
automation lane.

● To input gradual automation events, click and drag in the automation lane from
where you want the gradual automation event to start to where you want it to end.

RESULT
Automation events are input.

Moving automation events

You can move individual automation events, including moving them upwards and downwards to
change their values.

PREREQUISITE
The automation lane is shown for each instrument whose automation events you want to move.

PROCEDURE

1. In the automation lane header, select the MIDI controller whose automation events you
want to move from the MIDI Controller menu.

2. Select the automation events you want to move in one of the following ways:

● Click a single automation event

● Make a marquee selection around multiple automation events

NOTE

You can only move automation events in a single automation lane at a time.

3. Move the selected automation events in any of the following ways:

● To move them to the right/left, Ctrl/Cmd-click and drag them to the right/left.

● To move them upwards/downwards, Ctrl/Cmd-click and drag them upwards/
downwards.

TIP

If you want to move automation events upwards/downwards by smaller increments,
you can press Alt when dragging.

● Click and drag them in any direction.
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NOTE

You cannot move automation events beyond other existing automation events during the
same action. Releasing the mouse causes the moved automation event to replace the
existing one. You can then reselect it and move it further.

RELATED LINKS
Hiding/Showing automation lanes on page 419

Deleting automation events

You can delete individual or multiple automation events.

PREREQUISITE
The automation lane is shown for each instrument whose automation events you want to delete.

PROCEDURE

1. Press E to select Erase.

2. Delete automation events in any of the following ways:

● Click each automation event you want to delete.

● Make a marquee selection around the automation events you want to delete.

RESULT
The automation events you click or include in a marquee selection are deleted.

RELATED LINKS
Hiding/Showing automation lanes on page 419

Time track
The Time track allows you to view and edit the tempo of your project, including inputting new
tempo changes. It appears above the top player track in the event display in Play mode, and is
one of the tracks you can hide/show.

Time track

The Time track comprises the following:

1 Track height adjuster
Allows you to change the height of the track by clicking and dragging its bottom corner.

2 Track header
Shows the name of the track and contains appropriate options, such as the menu for the
sound source for the metronome.
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3 Fixed tempo read-out
Displays the tempo that corresponds to the current mouse pointer position in the Time
track.

4 Absolute tempo change
Indicates an immediate change in tempo, shown as a step change.

5 Gradual tempo change
Indicates a steady change in tempo across the duration of the line between the tempo
changes at each end.

TIP

Clicking and dragging tempo changes in the Time track causes a tempo read-out to appear
temporarily, showing their precise tempo.

Time track header

The Time track header contains the following:

1 Track disclosure arrow
Allows you to expand/collapse the track.

2 Track name
Shows the name of the track.

3 VST or MIDI Instrument menu
Allows you to select an instance of a VST or MIDI instrument to use for the click.

4 Edit Instrument
Opens the corresponding VST instrument, allowing you to edit settings for the slot or
channel.

5 Port menu
Allows you to change the endpoint to which the Time track is assigned by selecting the
port you want to use when using a plug-in that has multiple ports of 16 channels.

6 Slot menu
Allows you to change the endpoint to which the Time track is assigned by selecting the
slot in the selected VST instrument, or channel in the selected MIDI instrument, that you
want to use for the click.

You can use the following tools to input tempo changes into the Time track in Play mode:

● Draw: Inputs a separate tempo change at regular intervals, as determined by the current
rhythmic grid value.

● Line: Inputs a tempo change only at the start and end of the drawn range.

Tempo changes input in the Time track in Play mode appear as signposts in Write mode by
default to avoid changing the appearance of the printed score. Signposts are not printed by
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default, so if you want such tempo changes to be printed in the score, we recommend that you
select them in Write mode and activate Metronome mark shown in the Tempo group of the
Properties panel. You can also change their appearance in other ways, for example, by adding
text.

All tempo changes input in the Time track are included when exporting MIDI files.

RELATED LINKS
Play toolbox on page 401
Rhythmic grid on page 144
Tempo marks on page 950
Changing the type and appearance of absolute tempo changes on page 959
Signposts on page 281

Inputting tempo changes in the Time track
You can input tempo changes, including gradual tempo changes, in the Time track in Play mode.
Tempo changes input in the Time track do not appear in layouts, but instead are shown as
signposts.

PREREQUISITE
The Time track is shown.

PROCEDURE

1. Expand the Time track.

2. Select one of the following tools, depending on the type of tempo change you want to
input:

● To input single absolute tempo changes, or multiple absolute tempo changes at
regular intervals according to the current rhythmic grid value, select Draw by
pressing D or clicking Draw in the Play toolbox.

● To input gradual tempo changes, select Line by clicking Line in the Play toolbox.

3. Input tempo changes in one of the following ways:

● To input single absolute tempo changes, click in the Time track at each position
where you want a tempo change.

● To input multiple absolute tempo changes at regular intervals, click and drag in the
Time track.

● To input gradual tempo changes, click and drag in the Time track from where you
want the gradual tempo change to start to where you want it to end.

TIP

The metronome value corresponding to the current vertical position of the mouse pointer
is displayed in the Time track header.

RESULT
Tempo changes are input. This affects the speed of playback, but the tempo changes are not
shown in layouts. Instead, they appear as signposts.
The tempo changes are included when exporting MIDI files.
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RELATED LINKS
Hiding/Showing tracks on page 430
Hiding/Showing tempo marks on page 957
Signposts on page 281
Changing the rhythmic grid value on page 145

Moving tempo changes in the Time track
You can move individual tempo changes to new rhythmic positions in the Time track. This affects
their rhythmic position everywhere in the project.

PREREQUISITE

● The Time track is shown.

● Object Selection is selected in the Play toolbox.

PROCEDURE

1. In the Time track, select the tempo changes you want to move in one of the following
ways:

● Click a single tempo change

● Make a marquee selection around multiple tempo changes

2. Ctrl/Cmd-click and drag the selected tempo change, or one of the selected tempo
changes, to the right/left.

NOTE

● You can also simply click and drag to the right/left but this does not prevent the
selected tempo changes from moving upwards/downwards, which affects their
tempo.

● You cannot move tempo changes beyond other existing tempo changes during the
same move. Releasing the mouse causes the moved tempo change to replace the
existing one. You can then reselect it and move it further.

RESULT
The rhythmic positions of the selected tempo changes are changed. This also affects their
rhythmic positions in any layouts in which they appear.

AFTER COMPLETING THIS TASK
You can also move tempo changes vertically, which changes their tempo.

RELATED LINKS
Time track on page 421
Hiding/Showing tracks on page 430
Hiding/Showing tempo marks on page 957
Selecting multiple items using marquee selections on page 43

Changing the tempo in the Time track
You can change the tempo of individual tempo changes in the Time track.

PREREQUISITE

● The Time track is shown.

● Object Selection is selected in the Play toolbox.
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PROCEDURE

1. In the Time track, select the tempo changes whose tempo you want to change in one of
the following ways:

● Click a single tempo change

● Make a marquee selection around multiple tempo changes

2. Ctrl/Cmd-click and drag the selected tempo change, or one of the selected tempo
changes, upwards/downwards.
A tempo read-out appears beside the mouse pointer, providing visual feedback of the
tempo.

TIP

● If you want to change the tempo by smaller increments, you can press Alt when
dragging.

● You can also simply click and drag them upwards/downwards but this does not
prevent the selected tempo changes from moving to the right/left, which affects
their rhythmic positions.

RESULT
The tempo of the selected tempo changes is changed. This affects the speed of playback and the
displayed metronome mark of any tempo changes also shown in layouts.

RELATED LINKS
Hiding/Showing tracks on page 430

Deleting tempo changes in the Time track
You can delete tempo changes in the Time track.

PREREQUISITE
The Time track is shown.

PROCEDURE

1. Press E to select Erase.

2. Delete tempo changes in any of the following ways:

● Click each tempo change you want to delete.

● Make a marquee selection around the tempo changes you want to delete.

RESULT
The tempo changes you click or include in a marquee selection are deleted. This also deletes
their corresponding tempo marks or tempo mark signposts from layouts.

RELATED LINKS
Selecting multiple items using marquee selections on page 43

Chords track
A Chords track is included in every project. You can assign a VST or MIDI instrument to this track
to hear any chords that you input into the score as chord symbols in playback.

The Chords track appears above the top player track in the event display, and is one of the tracks
you can hide/show.
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Chords track

The Chords track comprises the following:

1 Track height adjuster
Allows you to change the height of the track by clicking and dragging its bottom corner.

2 Track header
Shows the name of the track and contains appropriate options, such as the button that
enables/disables chords playback.

3 Chords
Indicates where chord symbols exist in the flow and shows the chord symbol name.

Chords track header

The Chords track header contains the following:

1 Track disclosure arrow
Allows you to expand/collapse the track.

2 Track name
Shows the name of the track.

3 VST or MIDI Instrument menu
Allows you to select an instance of a VST or MIDI instrument to use for chords playback.

4 Enable Chords Playback
Allows you to include chords in, or exclude chords from, playback.

5 Edit Instrument
Opens the corresponding VST instrument, allowing you to edit settings for the slot or
channel.

6 Port menu
Allows you to change the endpoint to which the Chords track is assigned by selecting the
port you want to use when using a plug-in that has multiple ports of 16 channels.

7 Slot menu
Allows you to change the endpoint to which the Chords track is assigned by selecting the
slot in the selected VST instrument, or channel in the selected MIDI instrument, that you
want to use for chords playback.
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You can use an existing slot containing a sound already loaded in the project, or you can
use a new slot with a new sound loaded just for chords.

NOTE

● You must assign a VST or MIDI instrument and a slot for the Chords track in order to
hear chords in playback.

● If you assign an empty slot to your Chords track and later add more instruments to
your project, the sounds for the new instruments overwrite the slot.

RELATED LINKS
Chord symbols on page 564
Loading VST and MIDI instruments manually on page 404
Hiding/Showing tracks on page 430

Enabling chord symbol playback
You can include chord symbols in playback. They are played as sustained chords, with their
duration taken from the gap between one chord symbol and the next. Chord symbols input using
a MIDI keyboard use the same voicing as you used to input them.

PREREQUISITE
The Chords track is shown.

PROCEDURE

1. In the Chords track header, click Enable chords playback.

2. Optional: If you want to specify the sound used for chords playback, expand the Chords
track.

3. In the Chords track header, select the endpoint you want using the Port and Slot menus.

RELATED LINKS
Hiding/Showing tracks on page 430
Endpoints on page 447
Endpoint Setup dialog on page 448

Markers track
The Markers track allows you to view the markers in your project and input new ones. It appears
above the top player track in the event display in Play mode, and is one of the tracks you can
hide/show.

Markers track

The Markers track comprises the following:

1 Track height adjuster
Allows you to change the height of the track by clicking and dragging its bottom corner.
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2 Track header
Shows the name of the track and contains any appropriate options for the track type.

3 Add Marker
Allows you to add a new marker at the current position of the playhead.

4 Markers
Shows the position of each marker in the flow, including their text.

RELATED LINKS
Markers on page 814
Videos on page 125
Hiding/Showing tracks on page 430
Changing the text shown in markers on page 815

Inputting markers in the Markers track
You can input markers directly into the Markers track in Play mode.

PREREQUISITE
The Markers track is shown.

PROCEDURE

1. Move the playhead to the time position where you want to input a marker.

NOTE

You cannot input markers in negative time, such as when a video starts three bars into the
flow, causing the initial timecode of the flow to be in negative time.

2. In the Markers track header, click Add Marker.

RESULT
A marker is input at the position of the playhead. It shows the default text “Marker”.

EXAMPLE

Marker in the Markers track

AFTER COMPLETING THIS TASK
You can change the text shown in the marker.

RELATED LINKS
Changing the start position of videos on page 127
Changing the text shown in markers on page 815
Moving the playhead on page 431
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Video track
The Video track shows where videos exist in the flow relative to the music. It appears above the
top player track in the event display in Play mode and is one of the tracks you can hide/show.

Video track

The Video track comprises the following:

1 Track height adjuster
Allows you to change the height of the track by clicking and dragging its bottom corner.

2 Track header
Shows the name of the track and contains any appropriate options for the track type.

3 e
Allows you to hide/show the Video window. This performs the same function as Show
Video in the toolbar.

4 Video file name

5 Video region
Shows the position of the video file relative to the music and its length.

RELATED LINKS
Videos on page 125
Adding videos on page 127
Hiding/Showing the Video window on page 128
Changing the start position of videos on page 127
Toolbar on page 34

Expanding/Collapsing tracks
You can expand/collapse tracks in Play mode individually, and you can expand/collapse all player
tracks in the current flow at the same time.

PROCEDURE

● Expand/Collapse tracks in any of the following ways:

● To expand/collapse an individual track, click its disclosure arrow.

● To expand/collapse all player tracks, Ctrl/Cmd-click any player track disclosure
arrow.

Changing the height of tracks
You can change the height of all types of tracks at any time, for example, if you want a single
track to occupy more space in the event display temporarily so you can work on it in more detail.

PROCEDURE

● Change the height of tracks in any of the following ways:

● To make tracks taller, select them and press Shift-H.
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● To make tracks shorter, select them and press Shift-G.

● Click and drag the bottom left corner of a single track upwards/downwards.

TIP

When the mouse pointer is in the correct position, it appears as a split arrow.

RELATED LINKS
Zooming in/out of tracks in the event display on page 413

Hiding/Showing tracks
You can hide/show the tracks that appear above the top player track in the event display in Play
mode.

By default, only the Time and Chords tracks are shown. If you have added at least one video to
one flow in the project, the Time, Chords, Markers, and Video tracks are all shown by default.

NOTE

You cannot hide/show player and instrument tracks.

PROCEDURE

● Choose Play > Tracks > [track type].
For example, choose Play > Tracks > Time Track to hide/show the Time track.

RESULT
The selected track type is shown when a tick appears beside their entry in the submenu, and
hidden when no tick appears.

RELATED LINKS
Tracks on page 414

Playhead
The playhead is a vertical line that moves during playback, showing the current rhythmic
position. It is also known as a “playback line”.

The playhead is shown at all times in Play mode, but you can also see it in other modes during
playback. You can also choose to show the playhead when playback is stopped in other modes
on the Play page in Preferences.

The playhead in Play mode
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Dorico Pro automatically keeps the playhead in view during playback by moving it along with the
music, but you can also move the playhead manually. Dorico Pro tries to keep systems in the
same place on the screen when it scrolls along with the playhead for consistency as you follow
your music.

RELATED LINKS
Preferences dialog on page 51

Moving the playhead
The playhead automatically moves along with the music during playback, but you can also move
the playhead manually in any mode.

You can move the playhead both when it is stopped and during playback, but not all methods of
moving the playhead work during playback.

By default, the playhead is only shown during playback. You can choose to show the playhead at
all times on the Play page in Preferences.

PROCEDURE

● Move the playhead in any of the following ways:

● To move the playhead forwards, press + (plus) on a numeric keypad.

● To move the playhead backwards, press Num - (minus on a numeric keypad).

● To move the playhead back to the start of the flow, press Num . (period on a
numeric keypad).

● To move the playhead to the start of the earliest selected item, press Alt-P.

● To move the playhead to the next frame, press Ctrl/Cmd-F9 or Ctrl/Cmd-Num +
(plus on a numeric keypad).

● To move the playhead back to the previous frame, press Ctrl/Cmd-F7 or Ctrl/Cmd-
Num - (minus on a numeric keypad).

● Click Fast Forward in the Transport window to navigate forwards.

● Click Rewind in the Transport window to navigate backwards.

● Click Rewind to Beginning of Flow in the Transport window to go back to the start
of the flow.

● In Play mode, click the ruler at any position.

NOTE

You cannot click the ruler to move the playhead during playback.

RELATED LINKS
Transport window on page 446
Preferences dialog on page 51

Playing back music
You can listen to the music you have written from the beginning of your project or from a specific
point. You can also use the playback key commands in any mode.

PROCEDURE

1. Start playback in one of the following ways:
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● Play back all instruments from the selection by selecting a single note and pressing
P.

● Play back all instruments from the selection by selecting a single note and choosing
Play > Play From Selection.

● Play back only a single staff by selecting multiple items on the staff and pressing P.

NOTE

This does not affect which channels are soloed or muted in Play mode.

● Play back multiple staves by selecting items on multiple staves and pressing P.

NOTE

This does not affect which channels are soloed or muted in Play mode.

● Continue playback from the playhead position by pressing Space.

● Play back from the last playback start position by pressing Shift-Space. This works
even if you have since deselected the item at that position.

● Play back from the start of the flow by pressing Shift-Alt-Space.

● Click Play From Playhead Position in the Transport window.

● Click Play From Selection in the Transport window.

● Choose Play > Play From Playhead Position.

● Choose Play > Play From Last Start Position.

● Choose Play > Play From Start of Flow.

● Choose Play > Play From Start of Project.

2. Optional: Move the playhead during playback to later/earlier positions.

3. Stop playback in any of the following ways:

● Press Space or P.

● Press 0 on a numeric keypad.

● Click Stop in the Transport window.

RELATED LINKS
Muting/Soloing tracks on page 432
Endpoint Setup dialog on page 448

Muting/Soloing tracks
You can mute/solo individual tracks. This allows you to set fixed groups to sound in playback, for
example, if you only want to listen to certain groups of players at a time.

PROCEDURE

1. In the toolbar, click Show Mixer to show the Mixer.

2. In the Mixer, click the appropriate button at the top of each channel you want to mute/
solo.

● Mute

● Solo
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RESULT
Each track is muted/soloed and the corresponding buttons are enabled.
This affects which tracks play back until you change which tracks are muted/soloed, meaning you
do not have to reselect the tracks you want to hear each time. For example, if you have eight
tracks and solo four, only those four are played back. If you mute two tracks, those tracks are not
played back but the other six are played back.

NOTE

● Soloing tracks automatically mutes all other tracks. If you solo a track that was muted, it is
automatically unmuted.

● You can also play back only certain tracks/staves by selecting notes/items on each track/
staff you want to hear.

EXAMPLE

Mute when enabled Solo when enabled

RELATED LINKS
Expanding/Collapsing tracks on page 429
Muting notes/items individually on page 434

Muting/Soloing instruments
You can solo the currently selected instruments, which automatically mutes all other
instruments. This can be useful if you want to ensure only certain instruments are played back
while you are working on a specific section of a project.

PROCEDURE

1. Select at least one note belonging to each instrument you want to solo. You can do this in
Write, Engrave, and Play modes.

2. Press Alt-S.

RESULT
The selected instruments are soloed and all other instruments are muted by changing their
mute/solo states in the Mixer. This affects which instruments are muted/soloed until you
deactivate their mute/solo states.

TIP

You can also determine which staves are included in playback for each separate playback without
changing their states in the Mixer.

RELATED LINKS
Mixer on page 443
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Deactivating mute/solo instrument states
You can deactivate the mute and solo states of all instruments in your project, for example, if you
want to hear all instruments in playback after soloing a small selection. You can do this in any
mode.

PROCEDURE

● Deactivate mute/solo instrument states in the following ways:

● To deactivate all mute instrument states, press Alt-U.

● To deactivate all solo instrument states, press Shift-Alt-S.

● In the Mixer, click Deactivate All Mute States.

● In the Mixer, click Deactivate All Solo States.

RESULT
All instruments in the project have the corresponding state removed. For example, removing
both mute and solo instrument states reverts all instruments to their default state, causing all
instruments to be included in playback.

RELATED LINKS
Mixer on page 443

Muting notes/items individually
You can mute individual notes and items to exclude them from playback without deleting them,
for example, to hear chords without their arpeggios or hear a passage with multiple dynamics at
a single volume level.

PROCEDURE

1. In Write mode, select the notes/items you want to mute in playback.

2. In the Properties panel, activate Muted in the Common group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
The selected notes/items are muted when the checkbox is activated, meaning they do not affect
playback,and are not muted when the checkbox is deactivated.

Resetting changes to volume faders
You can reset changes you have made to volume faders in the Mixer back to their default level.

PREREQUISITE
The Mixer window is shown.

PROCEDURE

● In the Mixer, Ctrl/Cmd-click each volume fader that you want to reset.

RELATED LINKS
Hiding/Showing the Mixer window on page 445
Mixer on page 443
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Changing the tempo mode
You can switch the tempo mode at any time between using a single fixed tempo and following
tempo changes, for example, if you have a project with multiple tempo changes but want to use
a single fixed tempo when recording MIDI.

PROCEDURE

● Change the tempo mode in any of the following ways:

● In any mode, click Fixed Tempo Mode in the toolbar.

● In Play mode, choose Play > Fixed Tempo Mode.

RESULT
Follow tempo mode is active when Fixed Tempo Mode in the toolbar appears highlighted, and
when no tick appears beside Fixed Tempo Mode in the Play menu.
Fixed tempo mode is active when Fixed Tempo Mode in the toolbar is not highlighted, and when
a tick appears beside Fixed Tempo Mode in the Play menu.

EXAMPLE

Tempo when fixed tempo mode is active Tempo when follow tempo mode is active

Changing the pre-roll duration
In Dorico Pro, pre-roll is the time added to playback before the first beat of the first bar in each
flow. You can change the pre-roll duration, for example, if some flows in your project start with
grace notes.

PROCEDURE

1. Press Ctrl/Cmd-Shift-P to open Playback Options.

2. Click Timing in the page list.

3. In the Flows section, change the value for Pre-roll before flow.
For example, for flows starting with a single grace note, 0.25 seconds is usually sufficient.

4. Click Apply, then Close.

RESULT
The duration of the pre-roll before each flow in playback, measured in seconds, is changed.

Changing the playback tuning
You can change the tuning used for playback, based on the pitch of the A above middle C, for
example, if you want to hear your music played at the Baroque pitch of A=415 Hz.

PROCEDURE

1. Press Ctrl/Cmd-Shift-P to open Playback Options.

2. Click Tuning in the page list.

3. Change the value for Pitch of A4.

4. Click Apply, then Close.
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RESULT
The tuning of all notes in the project is changed, which affects their sounding pitch in playback.

Repeats in playback
Dorico Pro supports the playback of repeat structures, including repeat endings, repeat barlines,
and repeat markers, provided all the correct jumps and sections are in place.

There is no limit to the number of repeat structures you can have in a single flow and still obtain
correct playback.

By default, Dorico Pro includes repeats in playback, except after repeat jumps, such as D.S. al
Coda. You can change both of these options on the Repeats page in Play > Playback Options.

During playback, the bars/beats and time displays in the mini transport and Transport window
reflect the current position of the playhead in repeat structures.

Dynamics and tempo marks are reflected in repeats. Repeats are also included in both audio and
MIDI exports.

RELATED LINKS
Transport window on page 446
Mini transport on page 35

Playback templates
Dorico Pro uses playback templates to allocate sounds from VST instruments and MIDI devices to
the instruments in your project.

● You can find the available playback templates by choosing Play > Playback Template,
which opens the Playback Template dialog.

Playback Template dialog

Dorico Pro offers the following playback templates:

● HSSE (Elements)
Intended for use with HALion Sonic SE.

● HSSE+HSO (Pro)
Intended for use with both HALion Sonic SE and HALion Symphonic Orchestra.

● Silence
Prevents Dorico Pro from loading sounds.
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TIP

Choosing the Silence template makes Dorico Pro project files significantly smaller, for
example, when sending them electronically.

When you use any of these playback templates, Dorico Pro automatically loads new sounds for
any new instruments you add to the project.

You can override the template and make your own manual changes to the sounds used by
instruments in your project, such as by changing the expression maps assigned to endpoints.
Overriding the playback template prevents Dorico Pro from making further changes to these
settings. This includes preventing Dorico Pro from automatically loading new sounds for new
instruments until you reapply one of the default playback templates.

RELATED LINKS
Endpoint Setup dialog on page 448
Assigning expression/percussion maps to endpoints on page 450

Changing/Resetting the playback template
You can change the playback template used for the project currently open, for example, if you do
not need to use playback and so want to prevent Dorico Pro from loading sounds. Re-selecting
playback templates resets them to their default settings.

PROCEDURE

1. Choose Play > Playback Template to open the Playback Template dialog.

2. Select the playback template you want to use.

3. Click OK to save your changes and close the dialog.

RESULT
The playback template used for the current project is changed. If you re-selected the playback
template already in use, the playback template is reset.

TIP

You can change the default playback template used for all future projects on the Play page in
Preferences.

RELATED LINKS
Playback templates on page 436
Preferences dialog on page 51
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Swing playback
Swing is a style of performance where equally-notated notes are played in a regular pattern of
alternating longer and shorter notes, which commonly entails eighth notes being played as a
quarter note triplet followed by an eighth note triplet.

A swing phrase with simplified straight notation How the same phrase sounds with a 2:1 swing ratio

Swing playback allows you to hear the uneven rhythms you want whilst retaining their simplified
notation, including if the second eighth note beat is divided into two 16th notes. In Dorico Pro,
you can enable swing playback for your whole project, only for certain sections, and only for
individual instruments. You can also edit the default swing patterns to customize the rhythmic
feel you want in the Rhythmic Feel dialog.

Based on academic research into the rendering of swing by musicians, swing patterns in Dorico
Pro are tempo-dependent by default. This means that the swing feels more pronounced at lower
tempos, and straighter at higher tempos. Rhythmic feels that produce the same swing ratio at all
tempos are also available in the Rhythmic Feel dialog.

NOTE

Dorico Pro currently only supports eighth note swing playback. 16th note swing playback is
planned for future versions.

RELATED LINKS
Rhythmic Feel dialog on page 441

Swing ratios and rhythmic feels
Swing ratios express the strength of the swing using beat units. For example, a swing ratio of 2:1
means the first note in each pair is twice as long as the second, creating a triplet swing.

A swing ratio of 1:1 means the music is played straight, while a swing ratio of 5:1 means each
pair of notes is played as if they were sextuplets, with the first note in the pair lasting five
divisions and the second note lasting one.

Swing ratio 1:1 Swing ratio 5:1

The following rhythmic feels and swing ratios are provided by default in Dorico Pro:

2:1 swing (fixed)
Extends the first note in a pair of eighth notes to be twice as long as the second,
creating a strict triplet 2:1 ratio. This is also known as a “triplet swing”. This ratio is
maintained regardless of the tempo by default.
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3:1 swing (fixed)
Extends the first note in a pair of eighth notes to be three times as long as the
second, creating a dotted eighth-16th ratio (dotted quaver-semiquaver). This ratio is
maintained regardless of the tempo by default.

Heavy swing
Produces a tempo-dependent swing ratio of between 3:1 at low tempos and 1.5:1 at
high tempos.

Light swing
Produces a tempo-dependent swing ratio of between 1.5:1 at low tempos and 1:1 at
high tempos.

Medium swing
Produces a tempo-dependent swing ratio of between 2:1 at low tempos and 1.5:1 at
high tempos.

Straight (no swing)
Produces no swing, that is, even eighth notes in the ratio 1:1 at all tempos.

You can change the swing ratio used project-wide, and you can also change the swing ratio used
for specific sections and for individual players. You can edit these settings and create your own
swing ratios in the Rhythmic Feel dialog.

RELATED LINKS
Rhythmic Feel dialog on page 441

Enabling swing playback project-wide
You can enable swing playback project-wide using any of the default swing ratios or custom
swing ratios you have created in the project.

PREREQUISITE
If you want to use a custom rhythmic feel for swing playback, you have created that custom
rhythmic feel.

PROCEDURE

1. Press Ctrl/Cmd-Shift-P to open Playback Options.

2. Click Timing in the page list.

3. In the Rhythmic Feel section, select the rhythmic feel you want from the Default
rhythmic feel menu.

4. Click Apply, then Close.

RESULT
All pairs of eighth notes in your project are played back with the selected swing ratio, including if
the second eighth note beat is divided into two 16th notes.

RELATED LINKS
Playback Options dialog on page 405
Creating custom rhythmic feels for swing playback on page 441
Rhythmic Feel dialog on page 441
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Enabling swing playback for specific sections/players
You can enable swing playback for specific sections in your project and for individual players
independently, for example, if you want only the soloist to swing for a twelve-bar section.

PROCEDURE

1. In Write mode, select an item at the start of the bar where you want to change the
rhythmic feel for swing playback.

NOTE

If you select an item in the middle of a bar, the rhythmic feel change only takes effect from
the start of the next bar.

2. Press Shift-T to open the tempo popover.

3. Enter the rhythmic feel you want into the popover. For example, enter med for Medium
swing.
When you start entering a rhythmic feel into the tempo popover, a menu appears that
shows suggested rhythmic feels containing the letters/words you enter, which you can
select.

4. Input the rhythmic feel change and close the popover in one of the following ways:

● To input a rhythmic feel change for all staves, press Return.

● To input a rhythmic feel change only for the selected staff, press Alt-Return.

RESULT
The rhythmic feel used for swing playback is changed from the start of the bar, or the start of the
next bar if you selected an item in the middle of a bar. If you pressed Alt-Return, the rhythmic
feel change only applies to the staff on which you selected an item.
A signpost appears showing the name of the rhythmic feel you input. It is shown above the top
staff in the system for rhythmic feel changes that apply to all staves, and directly above an
individual staff for rhythmic feel changes that apply only to that staff.

RELATED LINKS
Tempo popover on page 196

Deleting rhythmic feel changes
You can delete rhythmic feel changes you have enabled for specific changes or for individual
players only.

PREREQUISITE
Rhythmic change signposts are shown.

PROCEDURE

1. In Write mode, select the signposts of the rhythmic changes you want to delete.

2. Press Backspace or Delete.
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RESULT
The rhythmic changes are deleted. The playback of the affected staves returns to your project-
wide settings until the next existing rhythmic change signpost, if applicable.

RELATED LINKS
Hiding/Showing signposts on page 283

Creating custom rhythmic feels for swing playback
You can create custom rhythmic feels that you can use for swing playback, for example, if you
want a swing ratio that is not included in the default rhythmic feels. You can create entirely new
rhythmic feels or rhythmic feels based on existing ones.

PROCEDURE

1. Press Ctrl/Cmd-Shift-P to open Playback Options.

2. Click Timing in the page list.

3. In the Rhythmic Feel section, click Edit to open the Rhythmic Feel dialog.

4. Create a new rhythmic feel in one of the following ways:

● To create an entirely new rhythmic feel, click New.

● To create a new rhythmic feel based on an existing one, select the existing rhythmic
feel in the rhythmic feels list and click New from Selection.

5. Enter a name for the rhythmic feel in the Name field.

6. Move the Low tempo swing ratio slider to the swing ratio you want.

7. Optional: If you want the swing ratio of your custom rhythmic feel to vary according to the
tempo, activate Depends on tempo.

8. Optional: If you activated Depends on tempo, change the bpm values for Low tempo
and/or High tempo.

9. Optional: If you activated Depends on tempo, move the High tempo swing ratio slider to
the swing ratio you want.

10. Click OK to save your changes and close the dialog.

11. Click Apply, then Close.

Rhythmic Feel dialog
The Rhythmic Feel dialog allows you to edit the settings of the default rhythmic feels used for
swing playback and to create your own custom rhythmic feels.

● You can open the Rhythmic Feel dialog by clicking Edit in the Rhythmic Feel section of
the Timing page in Play > Playback Options.
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Rhythmic Feel dialog

The Rhythmic Feel dialog contains the following options and sections:

1 Search field
Allows you to filter the rhythmic feels according to your entry.

2 Rhythmic feels list
Contains the rhythmic feels available for your project.
The action bar at the bottom of the list contains the following options:

● New

Allows you to create a new rhythmic feel with default values.

● New from Selection

Creates a new rhythmic feel based on the selected one. Initially no values are
overridden but you can change the options for your new rhythmic feel.

● Save as Default

Copies the selected rhythmic feel to your library so that it is available in other
projects.

● Revert to Factory

Removes all your changes to the selected predefined rhythmic feels, reverting them
to the default factory settings.

● Delete

Deletes the selected rhythmic feel.
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NOTE

You cannot delete predefined rhythmic feels or any rhythmic feel that is currently
used in your project.

3 Name
Allows you to enter a name for new rhythmic feels or edit the name of existing rhythmic
feels.

4 Depends on tempo
Controls whether the swing pattern uses the same ratio at all tempos or changes
according to the tempo.

● When Depends on tempo is activated, the swing ratio varies according to the
tempo. A second slider appears for High tempo, allowing you to change the values
for both Low tempo and High tempo.

● When Depends on tempo is deactivated, the swing ratio value of the single slider is
used at all tempos.

5 Low tempo
Sets the tempo at/below which the swing ratio changes, measured in quarter note beats
per minute. The swing ratio slider to the right controls the swing ratio used.

6 High tempo
Sets the tempo at/above which the swing ratio changes, measured in quarter note beats
per minute. When Depends on tempo is activated, the swing ratio slider to the right
controls the swing ratio used.

7 Swing ratio sliders
Allow you to set the swing ratio to be used below the set Low tempo and above the set
High tempo. Their possible ranges are from 1:1, which is straight, to 5:1, which is a
sextuplet with the second notated eighth note sounding on the final division.
The current swing ratio and swing percentage values of the sliders are shown to their
right.

RELATED LINKS
Playback Options dialog on page 405

Mixer
The Mixer allows you to control the sounds produced in playback, both for the master output and
on each individual channel.

Mixer
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1 Channel type buttons
Allow you to hide/show channels in the Mixer according to their type, and in any
combination.

2 Channel controls
Allow you to hide/show the corresponding controls in the channel strip according to their
type, and in any combination.

3 Deactivate All Mute States/Deactivate All Solo States
Allows you to deactivate all mute/solo states by clicking the corresponding button.

4 Zoom
Allows you to make channels wider/narrower.

5 VST channels
There is a mixer channel for each stereo output from the VST instruments in your project,
and all instruments in your project are shown, even if they are spread across multiple VST
instrument instances. Channels are stereo by default.

6 Mute/Solo
Allows you to mute/solo individual tracks.

7 Balance panner
Allows you to position the sound of each individual track on the stereo spectrum for stereo
playback.

8 Fader
Allows you to control the volume level of each individual track.
MIDI channels have a MIDI fader.

9 Channel meter
Indicates the output volume of each individual channel in real time.

10 MIDI channels
Every VST instrument in your project has its own MIDI channel in addition to its VST
channel. These MIDI channels allow you to change the MIDI volume and MIDI pan of each
instrument.

11 MIDI pan
Allows you to position the MIDI output of the channel on the stereo spectrum for stereo
playback.

12 MIDI fader
Allows you to change the MIDI volume of the channel.
Some plug-ins require MIDI faders, and this is often useful if you are using a MIDI device
for playback.

13 Click channel
Allows you to control the volume of the metronome click.

14 Video channel
Allows you to control the volume of video audio.

15 FX Send channel
Allows you to control the volume of send effects, such as reverb. By default, this channel
has REVerence loaded automatically.

16 Output channel
Allows you to control the master output volume.

NOTE

In order to control the volume levels in your project, we recommend that you first input
dynamics and adjust the dynamic curve to suit your project before using the track faders.
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Any changes you make in the Mixer are automatically saved and applied to the project.

RELATED LINKS
Hiding/Showing the Mixer window on page 445
Muting/Soloing tracks on page 432
Resetting changes to volume faders on page 434

Mixer channel strips
Each channel in the Mixer has its own channel strip, which contains the channel controls. You can
hide/show each type of channel control by clicking the corresponding button at the top of the
mixer.

Each channel strip contains the following types of controls:

Inserts

Each channel has four slots into which you can load an insert. You can select an
insert from the available options in the menu.

EQ

Each channel has four bands of EQ.
In order to make changes to the EQ bands on a channel, you must first click Enable
EQ. You can use this to bypass the EQ on a channel without losing your settings.

Sends

Each channel has four slots for sends. By default, the first slot for each channel sends
to the FX channel, which has reverb loaded on it.

Hiding/Showing the Mixer window
You can open and close the Mixer window at any time, for example, if you do not want it in view
when working on the music in the music area.

PROCEDURE

● Hide/Show the Mixer window in any of the following ways:

● Press F3.

● Click Show Mixer in the toolbar.

● Choose Window > Mixer.
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The Mixer window is shown when a tick appears beside Mixer in the menu, and
hidden when no tick appears.

Transport window
The Transport window contains all the transport functions in Dorico Pro. It contains more
precise versions of the transport functions available in the toolbar and additional transport
functions.

You can open/close the Transport window in any of the following ways:

● Press F2.

● Click Show Transport Bar in the toolbar.

Transport window

The Transport window contains the following information and functions:

1 Bars/Beats display
Shows the position of the playhead relative to bars and beats in the current flow in the
following order of units: bars, beats, 16th notes, 120ths of a 16th note.

2 Time display
Shows the position of the playhead as elapsed time in the following order of units: hours,
minutes, seconds, milliseconds. Alternatively, it can show the timecode position of the
playhead in the current flow in the following order of units: hours, minutes, seconds,
frames.
You can switch between having the time display show the time and timecode by clicking it.

3 Rewind to Beginning of Flow
Moves the playhead back to the beginning of the flow.

4 Rewind
Moves the playhead back by a half note each time you click.

5 Fast Forward
Moves the playhead forwards by a half note each time you click.

6 Stop
Stops playback.

7 Play From Playhead Position
Plays back from the position of the playhead.

8 Play From Selection
Plays back from the position of the first selected item in the music area.
If you select items on multiple staves, or multiple items on a single staff, only the selected
staves are played back.

9 Record
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Starts/Stops MIDI recording.

10 Retrospective Record
Retrieves any MIDI notes you played during the previous playback and allows you to input
them on any staff, even if you were not recording them explicitly.

11 Click
Plays/Mutes the metronome click during playback and recording.

12 Tempo
Displays the tempo used for both playback and recording. The value changes according to
the current position of the playhead and its appearance changes according to its current
mode.

RELATED LINKS
Mini transport on page 35
Changing the tempo mode on page 435

Changing the content shown in the transport display
You can switch between showing the timecode, the total elapsed time, and the current rhythmic
position of the playhead expressed in bars, beats, and ticks in both the mini transport in the
toolbar and the Transport window.

PROCEDURE

● In either the mini transport in the toolbar or the Transport window, click the transport
display until the content you want appears.
In the Transport window, this is the display on the right.

RESULT
Each time you click in the mini transport display, it cycles through showing the rhythmic position
of the playhead, elapsed time, and the timecode.
In the Transport window, it only switches between the timecode and elapsed time, as the
rhythmic position of the playhead is shown permanently on the left of the window.

TIP

You can change what is shown in the mini transport by default for all future projects on the Play
page in Preferences.

RELATED LINKS
Toolbar on page 34
Mini transport on page 35
Transport window on page 446
Timecodes on page 819
Preferences dialog on page 51

Endpoints
“Endpoint” is the term used for the unique combination of inputs and outputs that together allow
the correct sounds to be played for each instrument.

In Dorico Pro, each endpoint brings together the following:

● A particular VST instrument or MIDI output device

● A specific channel on that VST instrument or MIDI output device
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● The patch or program assigned to that channel

● The expression map, and optionally percussion map as well, that describes the instrument
or instruments that can be played by that patch or program, and the playing techniques
and articulations provided

Each instrument in your project is connected to a specific endpoint, and assigning an expression
map to the same endpoint allows Dorico Pro to translate playing technique changes and note
articulations into the key switches and controller switches necessary to reflect the required
sounds for the instrument in playback.

If you are using the HSSE+HSO (Pro) playback template with HALion Sonic SE or HALion
Symphonic Orchestra, endpoints and expression maps are set up automatically. However, if you
want to load other plug-ins or change the patches within HALion Sonic SE, then you must use the
Endpoint Setup dialog.

For example, if you have a project that uses the HSSE+HSO (Pro) playback template and you
change one of the sounds in HALion Sonic SE, such as changing Clarinet Combi in HALion
Symphonic Orchestra to GM Clarinet, this plays back incorrectly because the HALion Symphonic
Orchestra patch uses a modulation wheel to control volume dynamics, but the GM patch uses
note velocity. In playback, notes consequently have no dynamics and too much vibrato. You can
correct this in the Endpoint Setup dialog by changing the expression map for that channel from
the HALion Symphonic Orchestra Clarinet to Default, which uses note velocity for dynamics
instead of a modulation wheel.

Endpoint Setup dialog
The Endpoint Setup dialog displays which expression and percussion maps are currently linked
to each endpoint, and allows you to change these settings.

● You can open the Endpoint Setup dialog by clicking the cog button beside each plug-in in
the VST and MIDI Instruments panel.

Endpoint Setup dialog

The Endpoint Setup dialog contains the following options and sections:
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1 Number of MIDI ports
Displays the number of MIDI ports currently used by the corresponding plug-in.
Allows you to change the number of MIDI ports, for example, if you are using a plug-in
that uses more than one port. Dorico Pro does not load multiple MIDI ports by default.

2 Number of MIDI channels
Displays the number of MIDI channels currently used by the corresponding plug-in.
Allows you to change the number of channels, for example, if you have a monotimbral
plug-in such as a piano sampler which only has one MIDI channel, or a multitimbral plug-
in with 16 MIDI channels and 16 audio outputs.

3 Set
Sets the plug-in to have the number of MIDI ports and channels specified in the Number
of MIDI ports and Number of MIDI channels fields.

4 Endpoint setup table
Contains the settings for the corresponding plug-in, arranged into the following columns:

● Port
Displays the port used by the instrument in the corresponding row of the table.

NOTE

You cannot change the port from within the Endpoint Setup dialog. You must
change the port in the instrument track headers.

● Channel
Displays the channel used by the instrument in the corresponding row of the table.

NOTE

You cannot change the channel from within the Endpoint Setup dialog. You must
change the channel in the instrument track headers.

● Assigned Instruments
Displays the name of the instrument in the corresponding row.

NOTE

This field uses the underlying instrument name, meaning that any changes you
have made to the instrument name in the Edit Instrument Names dialog are not
shown.

● Expression map
Displays the expression map currently assigned to the instrument in the
corresponding row. You can change the expression map by double-clicking it and
selecting another expression map from the menu.

● Percussion map

Play mode
Endpoints 

449
Dorico 2.2.20



Displays the percussion map currently assigned to the instrument in the
corresponding row. You can change the percussion map by double-clicking it and
selecting another percussion map from the menu.

5 Number of audio outputs to show in Mixer
Allows you to change the number of audio outputs shown in the Mixer, for example, if you
want to hide unused outputs when using plug-ins that provide more audio outputs than
are used by Dorico Pro.

RELATED LINKS
Expression Maps dialog on page 452
Edit Instrument Names dialog on page 97

Assigning instruments to endpoints
You can assign instruments to any endpoint, for example, if you have loaded a plug-in with
multiple ports and want to change the endpoint of an existing instrument to an endpoint on one
of your new ports.

PROCEDURE

1. Expand the instrument tracks whose assigned endpoints you want to change.

2. In each instrument track header, select a new option from one or both of the following
menus:

● Port

● Slot

RESULT
The endpoints to which the instruments are assigned are changed in one of the following ways:

● Changing just the Slot value changes the channel in the plug-in used by the corresponding
instrument.

● Changing both the Port and Slot values changes both the port in the plug-in, and the
channel in that port, used by the corresponding instrument.

RELATED LINKS
Expression Maps dialog on page 452
Instrument tracks on page 416

Assigning expression/percussion maps to endpoints
You can assign expression/percussion maps to the endpoints in your project, for example, if you
have created a custom percussion map and must link it to the endpoint for the corresponding
VST patch.

PROCEDURE

1. In the VST and MIDI Instruments panel, click the cog button beside the plug-in in which
you want to change the expression/percussion maps assigned to endpoints to open the
Endpoint Setup dialog.

2. Double-click the expression/percussion map you want to change.

3. Click the disclosure arrow on the right of the field.
A menu appears containing all maps of the same type currently loaded in your project.
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4. Select the expression/percussion map you want from the menu.

5. Press Return.

6. Optional: Repeat steps 2 to 5 for any other endpoints whose assigned expression/
percussion maps you want to change.

7. Click OK to save your changes and close the dialog.

RELATED LINKS
Percussion maps on page 460

Expression maps
Expression maps tell Dorico Pro how to use appropriately the patches and sounds in the VST
instruments that you have loaded into your project.

Expressing a range of dynamics on instruments means changing the volume and attack of notes.
Because the strength of attack changes the character of the start of sounds as well as their
volume, loud sounds often require stronger attacks and quiet sounds often require softer
attacks.

Different patches and instruments have different approaches to changing dynamics and volume
in playback. For example, some patches only change the velocity whereas others use a controller
in combination with changing the velocity.

Dorico Pro also uses expression maps to specify the playing techniques that are supported by
each patch in your project. For example, string instruments such as the violin have different
techniques, because they can play arco, pizzicato, and col legno, and their bow position can be
anywhere between sul ponticello and sul tasto.

Dorico Pro supports the following ways of sending information to VST instruments:

● Key switches

● Controllers

NOTE

Program changes are not currently supported.

In addition to the HALion Symphonic Orchestra expression maps, there are the following
expression maps in Dorico Pro:

● CC11 Dynamics
Uses MIDI controller 11 to play dynamics.

NOTE

This only applies to instruments that can change their dynamic while notes are sounding,
such as violin or flute.
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● Default
Uses note velocity to control dynamic volume.

● Modulation Wheel Dynamics
Uses a modulation wheel to control the dynamic volume.

● Transpose down 1 octave
Used by some instrument patches that sound an octave higher than written so that they
can be played without needing a full range keyboard.

● Transpose up 1 octave
Allows the bottom octave of keyboards to be used for key switches instead of notes, but is
also used by some bass instrument patches that sound an octave lower than written so
that they can be played without needing a full range keyboard.

You can edit, create, and import/export expression maps in the Expression Maps dialog.

RELATED LINKS
Percussion maps on page 460

Expression Maps dialog
The Expression Maps dialog allows you to create new expression maps, edit existing expression
maps, and import/export expression maps. You can also import expression maps made in
Cubase.

● You can open the Expression Maps dialog in Play mode by choosing Play > Expression
Maps.

Although the format of expression maps in Dorico Pro is similar to Cubase, Dorico Pro does not
handle expression maps in exactly the same ways. For example, Dorico Pro allows you to use
more playing techniques, but Cubase can reproduce more combinations of multiple playing
techniques.

NOTE

During playback, Dorico Pro does not currently support all fields in the Expression Maps dialog.
This is planned for future versions.
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Expression Maps dialog

The Expression Maps dialog contains the following sections and options:

1 Expression maps list
Contains the expression maps currently available for your project.
You can add and delete expression maps using the following buttons in the action bar at
the bottom of the expression maps list:

● Add Expression Map

Allows you to add a new expression map that contains no existing settings.

● Duplicate
Creates a copy of an existing expression map that you can edit separately from the
original.

● Delete Expression Map

Allows you to delete the selected expression maps.

NOTE

You can only delete custom expression maps. You cannot delete any default
expression maps.

2 Expression Map section
Allows you to specify the following identifying information for the selected expression
map:
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● Name
Allows you to set the name of the expression map that appears in the program, for
example, in the Endpoint Setup dialog.

● ID
Allows you to set the unique ID of the expression map. You can enter any content in
the ID field.
It can be useful to include the instrument and sound library for which you created
the map, as well as your name, for example, xmap.user.paulsmith.hso.violinpizz.

● Creator
Allows you to name the creator if you are sharing your expression map with other
users.

● Version
Allows you to indicate the expression map version so you can identify the most
recent one.

● Plug-ins
Allows you to list the names of plug-ins to which the expression map applies, with
each name separated by a comma. You can leave this field blank.

NOTE

All fields in the Expression Map section are locked by the Lock Info button at the top
right. You must click this button in order to change the information in the fields.

3 Techniques section
The Techniques section contains the following groups:

● Techniques list
Contains a list of techniques for the expression map currently selected.

NOTE

Most instruments have a “natural” technique, which is the most common way of
playing the instrument. Dorico Pro requires every instrument to have a defined
natural technique.

● Dynamics
Allows you to choose whether the volume dynamic for the selected technique is
controlled by its Note velocity or a Control change.

NOTE

Control change requires you to specify the controller by number. You can consult
the documentation for the VST instrument and/or MIDI controller you are using to
find the appropriate controller number.

● Technique controls
Contains controls that affect the technique selected in the Techniques list, such as
Velocity.

● Exclusion Groups
Allows you to specify techniques that are mutually exclusive. For example, players
cannot play vibrato and non-vibrato at the same time. Putting techniques into the
same exclusion group means only one can be used at a time.
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NOTE

Although settings are imported into the Technique controls and Exclusion Groups from
Cubase, Dorico Pro does not currently implement all the information. This is planned for
future versions.

In simple cases, techniques in the Techniques list are individual techniques, such as
Staccato or Accent. However, it is possible to combine multiple techniques for plug-ins
that have separate samples for different combinations of techniques. For example,
Staccato + Accent might require a separate set of key switches to Staccato and Accent
individually.
Selecting a technique in the Techniques list makes it available for editing in the Actions
section. All the controls in this panel apply to the current technique.
You can add new techniques, edit existing techniques, and delete techniques using the
following buttons in the Techniques list action bar:

● Add Technique

Allows you to add a new technique or combination of techniques to the expression
map from the available techniques in the Technique Combinations dialog.

● Edit Technique

Allows you to edit the combination of techniques used in the selected technique in
the Technique Combinations dialog.
You can also edit existing techniques by double-clicking them in the Techniques list.

● Duplicate
Creates a copy of an existing technique that you can then edit separately from the
original.

● Delete Technique

Allows you to delete the selected technique.

NOTE

You can only select one technique at a time in the Techniques list.

4 Actions section
Allows you to determine how the switch required to execute each technique is controlled.
This section also contains the details of existing actions required to produce the selected
playing technique.
Actions can be any of the following types:

● Key switch

● Control change

● Program change

NOTE

Depending on your plug-in, multiple types of actions can be required to change individual
techniques.

In the Actions section, actions are displayed in a table with three columns.
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Actions table

The first column shows the type of action.
The second column controls the first parameter of the MIDI event. For note events, this
indicates the pitch. For control changes, this indicates the control change number. For
program changes, this indicates the program number.
The third column controls the second parameter of the MIDI event. For note events, this
indicates the velocity. For control changes, this indicates the amount of control change
within the range 0 to 127. Program changes do not have a second parameter.
You can add new actions of each type and duplicate existing actions using the
corresponding button in the action bar.
You can delete actions by selecting them individually and clicking Delete Action in the
action bar.

The Actions section also allows you to specify which actions affect the start of notes and
which affect the end of notes. For example, you might want an event that resets the
technique back to normal to apply only to the end of notes.

● On events affects the start of notes.

● Off events affects the end of notes.

5 Reset to Library Defaults
Allows you to revert any changes you have made to the expression maps from the Default
Library.

6 Import Library
Allows you to import expression maps from .doricolib files.

7 Export Library
Allows you to select multiple expression maps and export them into a .doricolib file,
which you can import into other projects and share with other users.

8 Import Cubase Expression Map
Allows you to import an expression map in Cubase format.

NOTE

It is not currently possible to import all combinations of techniques. Cubase expression
maps in Dorico Pro often require some editing to function correctly.

However, switch data is preserved.

RELATED LINKS
Endpoint Setup dialog on page 448

Technique Combinations dialog
The Technique Combinations dialog allows you to create combinations of techniques. You can
later assign actions to these combinations to create specific sounds in playback.

You can open the Technique Combinations dialog in the following ways:

● In the Expression Maps dialog, click Add Technique in the Techniques action bar.
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● In the Expression Maps dialog, select an existing technique in the Techniques list and click
Edit Technique in the Techniques action bar.

● In the Expression Maps dialog, double-click an existing technique in the Techniques list.

Technique Combinations dialog

1 Techniques list
Allows you to select techniques to include in a new technique or to replace existing
techniques.
You can select multiple techniques to combine by Ctrl/Cmd-clicking each technique.

2 Name
Displays the name of the selected technique. If you select multiple techniques, each name
is automatically separated by a + symbol.
You cannot change the name of techniques.

RELATED LINKS
Expression Maps dialog on page 452
Creating playing technique combinations on page 458

Creating new expression maps
You can create new expression maps from scratch and you can duplicate existing expression
maps and edit the settings.

PROCEDURE

1. Choose Play > Expression Maps to open the Expression Maps dialog.

2. Create a new expression map in one of the following ways:
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● Click Add Expression Map to create an empty expression map.

● In the list on the left of the dialog, select an existing expression map on which you
want to base a new map and click Duplicate.

3. Click Lock Info to unlock the fields in the Expression Map section.

Locked Unlocked

4. In the Expression Map section, enter information for your expression map in the relevant
fields.

5. Optional: In the Techniques list, add a new technique in one of the following ways:

● Click Add Technique.

● Select an existing technique and click Duplicate.

6. Optional: If technique combinations you require do not exist in the expression map, create
them in the Technique Combinations dialog.

7. In the Techniques list, select a technique.

8. In the Techniques section, change any of the options relevant to the selected technique.
For example, choose whether the volume of the selected technique is controlled by its
Note velocity or a Control change.

9. In the Actions section, add an action for the currently selected technique in one of the
following ways:

● Click Add Note Event.

● Click Add Control Change.

● Click Add Program Change.

● Select an existing action and click Duplicate.

10. Choose the type of event from one of the following options:

● On events

● Off events

11. Optional: Repeat steps 9 and 10 for each action you require for each technique.

12. Optional: To change the values for actions, double-click them and change their values.

13. Click OK to save your changes and close the dialog.

RELATED LINKS
Expression Maps dialog on page 452
Endpoint Setup dialog on page 448
Technique Combinations dialog on page 456

Creating playing technique combinations

PROCEDURE

1. Choose Play > Expression Maps to open the Expression Maps dialog.

2. In the page list, select the expression map to which you want to add new technique
combinations.

Play mode
Expression maps 

458
Dorico 2.2.20



3. Open the Technique Combinations dialog to change the technique combination for a
technique in one of the following ways:

● To create a new playing technique, click Add Techniques in the Techniques list
action bar.

● To change the technique combination for an existing playing technique, select the
technique and click Edit Technique in the Techniques list action bar.

4. In the Technique Combinations dialog, select the techniques you want to combine.
You can select multiple techniques, but you can also only select a single technique.

5. Click OK to save your changes and close the dialog.
The Technique Combinations dialog closes.

RESULT
A new technique combination is created and becomes available in the Techniques list for the
selected expression map in the Expression Maps dialog.

RELATED LINKS
Technique Combinations dialog on page 456
Expression Maps dialog on page 452

Importing expression maps
You can import expression maps into projects.

PROCEDURE

1. Choose Play > Expression Maps to open the Expression Maps dialog.

2. Click Import Library to open the File Explorer/macOS Finder.

3. In the File Explorer/macOS Finder, locate and select the expression map file you want to
import.

4. Click Open.

RESULT
The selected expression map is imported into your project. It appears in the Expression Maps list.

Exporting expression maps
You can export expression maps so you can use them in other projects.

PROCEDURE

1. Choose Play > Expression Maps to open the Expression Maps dialog.

2. Click Export Library to open the File Explorer/macOS Finder.

3. In the File Explorer/macOS Finder, specify a name and location for the library file.

4. Click Save.

RESULT
The expression map is exported and saved in the selected location.
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Percussion maps
Unpitched percussion instruments are played back using patches that map unpitched sounds
onto different MIDI notes. The pitches required to produce different unpitched sounds vary by
device, sample library, manufacturer, and so on, and have no connection to the position of
percussion instruments on five-line staves.

The following list contains some examples of unpitched percussion instruments from the General
MIDI percussion map.

● Bass drum: C2 (MIDI note 36, two octaves below middle C)

● Kick drum: D2 (MIDI note 38)

● Closed hi-hat: F♯2 (MIDI note 42)

● Cowbell: G♯3 (MIDI note 56)

● Open triangle: A5 (MIDI note 81)

Dorico Pro uses percussion maps to connect the written representation of notes and playing
techniques for percussion instruments to the samples required to play those sounds back.

NOTE

A percussion map describes which unpitched percussion instruments and their playing
techniques are present in a particular patch, and how to play them back. For example, it
describes which MIDI note to play, and if another MIDI note is needed as a key switch to trigger
particular playing techniques.

A set of percussion maps for the unpitched percussion patches that are part of theHALion
Symphonic Orchestra and HALion Sonic SE factory libraries is provided with Dorico Pro. They are
automatically chosen when you add percussion instruments to your project.

You can define custom percussion maps for third-party sound libraries or MIDI devices in the
Percussion Maps dialog, in order to obtain correct playback.

Percussion Maps dialog
In the Percussion Maps dialog, you can define custom percussion maps for third-party sound
libraries or MIDI devices in order to obtain correct playback.

● You can open the Percussion Maps dialog in Play mode by choosing Play > Percussion
Maps.
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Percussion Maps dialog

The Percussion Maps dialog is divided into the following sections:

1 Percussion maps list
Contains the percussion maps currently available in your project.
You can add and delete percussion maps using the following buttons in the action bar at
the bottom of the Percussion Maps list:

● Add Percussion Map

Allows you to add a new percussion map that contains no existing settings.

● Duplicate
Creates a copy of an existing percussion map that you can edit separately from the
original.

● Delete Percussion Map

Allows you to delete the selected percussion maps.

NOTE

You can only delete custom percussion maps. You cannot delete any default
percussion maps.

2 Percussion Map section
Allows you to specify the following identifying information for the selected percussion
map:
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● Name
Allows you to specify the displayed name for the percussion map that appears in the
Endpoint Setup dialog.

● ID
Allows you to set the unique ID of the percussion map. You can enter any content in
the ID field.
It can be useful to include the instrument and sound library for which you created
the map, as well as your name, for example, xmap.user.paulsmith.hso.cowbell.

NOTE

The Endpoint Setup dialog is where you set which percussion map Dorico Pro uses for
each channel on your VST instrument or MIDI output device.

You can choose one of the options for Map defines sounds for, as appropriate for the
current percussion map:

● Multiple Instruments
Choose this if the patch for which you are creating a map contains many different
percussion instruments, such as the General MIDI drum map.

● Single Instruments
Choose this if the patch for which you are creating a map contains only a single
percussion instrument, perhaps with multiple playing techniques for that
instrument. For example, a snare drumline patch in Virtual Drumline or another
specialist sample library.
This can also be useful when your VST instrument has several patches that have the
same technique mappings. For example, there are both large and small cymbal
patches in HALion Symphonic Orchestra which provide natural strike and roll
sounds. Creating a single individual instrument percussion map allows you to use
the same mapping for these sounds for multiple patches.

3 Drum Kit Note Map section
Lists all MIDI notes from 0 to 127. You can specify which combination of unpitched
instrument and playing technique is produced by each note.

4 Edit Drum Kit Note section
Allows you to specify data in the following fields for the MIDI note selected in the Drum Kit
Note Map section:

● Name
The displayed name for the specific combination of instrument and technique. You
may choose to input the name used in the manufacturer’s documentation for your
VST instrument or MIDI output device.

● Instrument
Allows you to select an instrument for the MIDI note selected in the Drum Kit Note
Map section from a list of all the unpitched percussion instruments you can create
in Dorico Pro.

● Techniques
Allows you to select a playing technique to apply to the instrument selected in the
Instrument field from a list of all the playing techniques you can create in Dorico
Pro.

● Key switches
Allows you to specify the MIDI note number of the key you want to use as a key
switch if this sound requires another MIDI note to be played to trigger this specific
combination of instrument and playing techniques.
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NOTE

Key switches are not compulsory.

5 Reset to Library Defaults
Allows you to revert any changes you have made to the percussion maps from the Default
Library.

6 Import Library
Allows you to import percussion maps from .doricolib files.

7 Export Library
Allows you to select multiple percussion maps and export them into a .doricolib file,
which you can import into other projects and share with other users.

Creating custom percussion maps
You must define custom percussion maps in order to obtain correct playback when using third-
party sound libraries or MIDI devices. You can create new, empty percussion maps, or create
custom percussion maps based on existing maps that you have duplicated.

PROCEDURE

1. Choose Play > Percussion Maps to open the Percussion Maps dialog.

2. Create a new custom percussion map in any of the following ways:

● Click Add Percussion Map to create an empty map.

● In the list on the left of the dialog, select an existing percussion map on which you
want to base a new custom map and click Duplicate.

3. Click Lock Info to unlock fields in the Percussion Map section.

Locked Unlocked

4. In the Percussion Map section, enter the display name you want for the percussion map
in the Name field.
This name appears in the Endpoint Setup dialog.

5. In the Percussion Map section, enter any unique identification name in the ID field.
It can be useful to include the instrument and sound library for which you created the
map, as well as your name, in the identification name for percussion maps, for example,
xmap.user.paulsmith.hso.cowbell.

6. In the Percussion Map section, choose one of the following options for Map defines
sounds for, as appropriate for the current percussion map:

● Multiple Instruments

● Single Instruments

7. In the Drum Kit Note Map section, click Show all to show unmapped notes.

8. Select the row corresponding to the MIDI note for which you want to create a new
mapping.

9. In the Edit Drum Kit Note section, click the following button beside the Instrument field.

A dialog containing a list of instruments opens.

10. Select the instrument that corresponds to the sound produced by the selected MIDI note
from the list.
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11. Click OK.

12. In the Edit Drum Kit Note section, click the following button beside the Techniques field.

A dialog containing a list of playing techniques opens.

13. Select the appropriate playing techniques for the sound produced by the selected MIDI
note from the list.
For example, Ctrl/Cmd-click Buzz roll and Rim.

14. Click OK.

15. In the Edit Drum Kit Note section, enter the display name you want for this combination
of instrument and playing technique in the Name field.

16. In the Edit Drum Kit Note section, specify the MIDI note number of the key switch if this
sound requires one in the Key switches field.

17. Click Apply.

18. Optional: Repeat these steps for each MIDI note until you have created all the required
mappings for your project.

19. Click OK to save your changes and close the dialog.

RESULT
Your new percussion map is created.

AFTER COMPLETING THIS TASK
You must assign custom percussion maps to the same endpoints as the VST instruments or MIDI
devices that provide the corresponding patches.
You can export the percussion map if you want to use it in other projects.

RELATED LINKS
Percussion maps on page 460
Assigning expression/percussion maps to endpoints on page 450
Endpoint Setup dialog on page 448

Importing percussion maps
You can import percussion maps into projects.

PROCEDURE

1. Choose Play > Percussion Maps to open the Percussion Maps dialog.

2. Click Import Library to open the File Explorer/macOS Finder.

3. In the File Explorer/macOS Finder, locate and select the percussion map file you want to
import.

4. Click Open.

RESULT
The selected percussion map is imported into your project. It appears in the Percussion Maps list.

Exporting percussion maps
You can export percussion maps so you can use them in other projects.

PROCEDURE

1. Choose Play > Percussion Maps to open the Percussion Maps dialog.
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2. Click Export Library to open the File Explorer/macOS Finder.

3. In the File Explorer/macOS Finder, specify a name and location for the library file.

4. Click Save.

RESULT
The percussion map is exported and saved in the selected location.

Defining how combinations of articulations and single-note
tremolos sound in playback

You can define specific playback behaviors for particular combinations of articulations and
single-note tremolos in playing technique-specific noteheads for unpitched percussion
instruments.

PROCEDURE

1. In Setup mode, open the Percussion Instrument Playing Techniques dialog in any of the
following ways:

● For an individual percussion instrument: In the Players panel, expand the card of
the player holding the instrument, click the arrow in the instrument label, and
choose Edit Percussion Playing Techniques from the menu.

● For percussion instruments that are part of percussion kits: In the Players panel,
click the arrow in the kit instrument label, and choose Edit Percussion Kit to open
the Edit Percussion Kit dialog, select the instrument whose playing techniques you
want to edit in the main editing area, and click Edit Percussion Playing Techniques.

2. Select the playing technique-specific notehead whose playback behaviors you want to
define in the list at the top of the dialog.

3. Click Add Technique in the action bar at the bottom left of the dialog.

4. Click Choose Playing Techniques beside the Playback playing technique field.

5. Select the playing technique you want from the list in the dialog that opens.
You can select multiple playing techniques by holding down Ctrl/Cmd and clicking the
playing techniques you want.

6. Choose one of the following options:

● Replace
Allows you to use this playing technique instead of the default playing technique
defined for this combination of notehead and staff position.

● Add
Allows you to add this playing technique on top of the default playing technique
defined for this combination of notehead and staff position.

7. Choose any articulations and a tremolo stroke that you want from the available options.

8. Click OK to save your changes and close the dialog.

RESULT
The behavior of the selected playing technique in playback is changed.

RELATED LINKS
Percussion Instrument Playing Techniques dialog on page 1027
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Creating new playing technique-specific noteheads for unpitched percussion instruments on
page 1030

Played vs. notated note durations
You can show notes in the piano roll editor in Play mode with their played duration or notated
duration.

Played duration

When Played Durations in the Play toolbox is selected, note events in the piano roll editor are
each shown with two components:

● A filled, light-colored rectangle showing the played duration of the note.

● A thin, darker rod showing the notated duration of the note.

For example, notes with staccato articulations are played for less time than their notated
duration, whereas notes under slurs are played for longer than their notated duration.

By default in Dorico Pro, notes in the piano roll editor in Play mode are shown with their played
duration.

NOTE

Editing the played duration of notes causes them to appear in a darker color in the piano roll
editor to notes whose played duration you have not changed.

Notated duration

You can select Notated Durations in the Play toolbox to see note events as single rectangles,
which span the full width that corresponds to the notated duration of the note.

You can change the notated duration of notes in the piano roll editor when Notated Durations
is selected.

EXAMPLE
The following examples all contain the same musical phrase, shown in different ways.

Played duration Notated duration Score

RELATED LINKS
Slurs in playback on page 893

Changing the played duration of notes
You can change the played duration of notes individually, both at the start and end of notes. For
example, you can make notes sound for longer or start sounding later.

PREREQUISITE
Played Durations is selected in the Play toolbox.
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PROCEDURE

1. In the piano roll editor, select the notes whose played duration you want to change.

2. Click and drag the end of one of the notes to the right/left.
Your cursor becomes a two-way arrow when you are in the correct position.

3. Optional: Repeat step 2 for the start of the notes.

RESULT
The played duration of the selected notes is changed.

RELATED LINKS
Play toolbox on page 401

Removing changes to the played duration of notes
You can remove all changes made to the played duration of individual notes, for example, if you
change your mind about playback overrides you have made and want to revert those notes to
their default start position, length, and velocity.

Removing playback overrides also removes any offsets to the start and end position of notes
imported from MIDI files with preserved note positions.

NOTE

Note velocity is not currently displayed in Dorico Pro, but note velocities are imported from MIDI
files. If you want dynamics you input in Write mode to take effect in playback, you must remove
playback overrides.

PROCEDURE

1. In the piano roll editor or drum editor, select the notes whose played durations you want
to reset.

2. Choose Play > Reset Playback Overrides.

RESULT
All overrides to the default played duration of the selected notes are removed.

NOTE

The played duration of the selected notes appears to revert to match their notated duration.
However, starting playback or switching modes refreshes their appearance to their default
played duration. For example, if the notes are staccato, their played duration is half their notated
duration by default.

Play mode
Played vs. notated note durations 

467
Dorico 2.2.20



Print mode allows you to print your layouts or to export them as graphics files, such as PDF and
SVG.

Project window in Print mode
The project window in Print mode contains the default toolbar and the print preview area as well
as panels and sections that provide all the tools and functions that allow you to prepare printing
or exporting your layouts.

You can switch to Print mode in any of the following ways:

● Press Ctrl/Cmd-5.

● Click Print in the toolbar.

● Choose Window > Print.

Panels and sections in Print mode

The following panels and sections are available in Print mode:

1 Layouts panel
Shows a list of all layouts in your project and allows you to select what to print or export.

Print mode
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NOTE

The layout selector in the toolbar is disabled in Print mode. If you want to see a different
layout in the print preview area, select it in the Layouts panel.

2 Print Options panel
Contains options for printing or exporting your layouts.

3 macOS: System Dialogs
Contains macOS-specific printing options.

4 View options
Allows you to change the print preview area to show pages in one of the following views:

● Page Width
The page fills the width of the print preview area, which might not show the whole
page depending on the orientation and format of the page.

● Whole Page
Shows the whole page in the print preview area.

RELATED LINKS
Toolbar on page 34
Print preview area on page 39

Layouts panel (Print mode)
In Print mode, the Layouts panel shows a list of all layouts in your project and allows you to
select layouts to print or export. It is located on the left of the window.

You can hide/show the Layouts panel in Print mode in any of the following ways:

● Press Ctrl/Cmd-7.

● Click the disclosure arrow on the left edge of the main window.

● Choose Window > Show Left Panel.

Layouts panel in Print mode

The Layouts panel contains all the layouts in your project, displayed as cards. Each layout card
shows the following:
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1 Disclosure arrow
Expands/Collapses the layout card.

2 Layout type
Shows the type of layout from the following options:

● Full score layout

● Instrumental part layout

● Custom score layout

3 Layout name
Shows the name of the layout. Dorico Pro automatically adds default names depending on
the name of the instrument that is assigned to a player and on the type of layout that is
added. For example, if you assign a flute to a player, the instrumental part layout
automatically gets the same name. If you add an empty instrumental part layout, the
layout name shows Empty part and an incremental number if you add multiple empty
part layouts.

4 Page size and orientation
Shows the size and orientation of the layout as set on the Page Setup page in Setup >
Layout Options.

5 Layout length
Shows the number of pages in the layout. You can use this in combination with its page
size and orientation to determine the best job type for printing/exporting.

TIP

A layout with two pages might best be printed as 2-up, while a layout with five pages
might best be printed as spreads with the final page printed on a different paper size. A
layout with 12 pages might best be printed as a booklet.

The selected layouts are printed/exported when you click Print or Export. If you have selected
some layouts set to print and some set to export graphics, the button reads Print and Export.

RELATED LINKS
Page arrangements for printing/exporting on page 480
Booklet printing on page 481

Print Options panel
The Print Options panel contains options for printing or exporting your layouts. It is located on
the right of the window in Print mode.

You can hide/show the Print Options panel in any of the following ways:
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● Press Ctrl/Cmd-9.

● Click the disclosure arrow on the right edge of the main window.

● Choose Window > Show Right Panel.

All the options that you set in the Print Options panel are saved with your project. The options
are divided into the following sections:

Destination
Allows you to select a physical printer for printing or a file location for exporting a
graphics file. If you print your work, you can choose how many copies you want to
print. If you choose to export a graphics file, you can specify the format, file name,
and directory of the saved file.
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Depending on the destination type selected, the button at the bottom of the panel
reads either Print or Export. If you have selected some layouts set to print and some
set to export graphics, the button reads Print and Export.

Job Type
Allows you to choose the range of pages to be printed or exported and how they are
arranged.

Page Setup
Allows you to set the paper size and orientation. You can specify the scale factor of
the image to be printed or exported.

Duplex Printing
Allows you to specify whether to print on one or on both sides of each sheet of
paper. This option is only available if you select Printer in the Destination section.

Annotations
Allows you to activate options that are often required by publishing houses or
printing agencies, such as crop marks or a border around the printed image.

Print button
Allows you to print/export selected layouts according to the settings you have set in
the Print Options panel.
Depending on your selection, the print button can appear in one of the following
ways:

● Print

● Export

● Print and Export

For example, if you selected layouts that are all set to print, Print is shown. If you
selected some layouts set to export graphics and some layouts set to print, Print
and Export is shown.

RELATED LINKS
Duplex printing on page 481
Page arrangements for printing/exporting on page 480

Printing layouts
You can print layouts individually or multiple layouts together. You can specify print settings for
each layout independently, for example, you can select different printers for different layouts in
the same project.

Dorico Pro uses settings for layouts to create automatic print settings, so you might find that
many print options are already appropriate for the layouts you want to print. For example, if you
are connected to a printer that can print A3 paper and the page size of your full score layout is
set to A3 in Layout Options, Dorico Pro automatically selects A3 in the Page Setup section of the
Print Options panel.

PROCEDURE

1. In the Layouts panel, select the layouts that you want to print.

NOTE

The layout selector in the toolbar is disabled in Print mode. If you want to see a different
layout in the print preview area, select it in the Layouts panel.
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2. In the Print Options panel, enter the number of copies you want into the Copies field in
the Destination section.

NOTE

● Changing the Copies value changes the number of copies for all currently selected
layouts. However, you can change the number of copies for layouts individually. For
example, you can select a full score layout and set it to print 3 copies and leave the
part layouts to print only 1 copy. You can then select all layouts to print them
together and the previously set values are followed.

● The Copies field appears blank when you have selected layouts with different
values.

3. Activate/Deactivate Collate copies.

4. In the Destination section, choose Printer and select a printer from the menu.

5. In the Job Type section, select the page arrangement you want from the menu.

6. Optional: If you only want to print a specified range of pages, choose Page Range in the
Job Type section.

7. Optional: If you selected Page Range, enter the pages you want into the value field.

8. In the Page Setup section, select a paper size from the menu.

9. Choose the paper orientation you want.

10. Optional: If you selected Spreads or 2-up for the job type, activate/deactivate Print odd
final page on to specify the paper size on which you want to print final pages for layouts
with odd numbers of pages.

11. Select a paper size and paper orientation for the odd final page.

12. Choose one of the following size options:

● Fit to Paper

● Custom Scale

13. Optional: If you selected Custom Scale, enter the scale factor you want into the Scale
factor field.

14. In the Duplex Printing section, select one of the printing options from the Print on menu.

15. Optional: If you selected a duplex printing option, use the bottom two menus to select
how the printed image is flipped when printing on the reverse side of the paper.

16. In the Annotations section, activate each annotation you want to add to the selected
layouts.

17. Click Print.

RESULT
The selected layouts are printed according to the print settings you have applied.
If your selection included part layouts sets to concert pitch, Dorico Pro shows a warning and
offers to switch them all to transposed pitch before printing/exporting. You can also select which
layouts you want to switch to transposed pitch or proceed anyway with no changes.

TIP

● You can select individual layouts and set up their printing options without printing straight
away. Once you have set up the printing options you want for multiple layouts, you can
then select all the layouts you want to print and click Print. Your existing print settings are
applied, even if your selection contains layouts with different print settings.

● You can assign key commands to different printing and exporting commands on the Key
Commands page in Preferences, which you can use in any mode.
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RELATED LINKS
Printers on page 479
Paper size and orientation setup on page 483
Export File Names dialog on page 477
Page arrangements for printing/exporting on page 480
Print Options panel on page 470
Duplex printing on page 481
Annotations on page 485
Changing the page size and orientation on page 343

Printing/Exporting a page range
By default, Dorico Pro prints/exports all pages of the selected layouts. You can specify a specific
page range to print/export.

NOTE

You can only print booklets using the complete range of pages. You cannot define any page
ranges.

PROCEDURE

1. In the Layouts panel, select the layouts from which you want to print/export a range of
pages.

2. Optional: In the Destination section, check the layouts are set to print/export using the
printer/graphics file formats you want.

3. In the Job Type section, choose Page Range.

4. Enter the pages you want into the value field.

● To specify a range, enter the first page and last page separated with a dash, such as
1-4.

● To specify individual pages or separate ranges, enter each page/range separated
with commas, such as 1,3,5-8.

NOTE

Separate ranges are exported as separate files.

5. Click Print/Export/Print and Export.

RESULT
The specified pages in the selected layouts are printed/exported. Exported files use the file name
recipe set for their graphics file format in the Export File Names dialog.

RELATED LINKS
Export File Names dialog on page 477
Page arrangements for printing/exporting on page 480

Specifying printing options (macOS only)
Dorico Pro allows you to access the standard printing options of your operating system.

NOTE

If you use the standard printing options of your operating system, the settings in the Print
Options panel are ignored. macOS-specific print settings are not saved with your project. These
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must be set each time you want to print, whereas the Dorico Pro print options are always saved
with your project.

PROCEDURE

1. In the Layouts panel, click Page Setup in the OS X Dialogs section to open the macOS
Page Setup dialog.

2. In the Page Setup dialog, set the paper size.

3. Click OK.

4. In the OS X Dialogs section, click Print to open the macOS Print.

5. In the Print dialog, set up the printing options you want.

Exporting layouts as graphic files
You can export individual layouts as a variety of graphic files, such as PDF or PNG.

PROCEDURE

1. In the Layouts panel, select the layouts you want to export.

2. In the Print Options panel, choose Graphics in the Destination section.

3. Choose a color mode.

● Mono exports the graphic in black and white.

● Color exports the graphic in full color.

NOTE

If you export a graphic file with a resolution of 72 dpi, we recommend that you select
Color. If you select Mono, staff lines can disappear.

4. Select a graphics file format from the menu.

5. Optional: If you selected PNG or TIFF, select a resolution from the Resolution menu.

TIP

You cannot change the resolution if you select PDF or SVG. However, if you select PNG or
TIFF, change the resolution, and then select PDF or SVG, the resolution you selected still
applies.

6. Optional: Specify an export path.

7. Optional: If you want to change the file name recipe, click File Name Options to open the
Export File Names dialog.

8. Optional: In the Export File Names dialog, change the file name recipe for your selected
graphics file formats.

9. Optional: If you only want to export a specified range of pages, choose Page Range in the
Job Type section.

10. Optional: If you selected Page Range, enter the pages you want into the value field.

NOTE

Separate ranges are exported as separate files.

11. Click Export.
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RESULT
The selected layouts are exported as the selected graphics format using the file name recipe set
for their graphics file format in the Export File Names dialog. They are saved in the folder set in
the Destination folder field, or in the same folder as the project file if the set export path is no
longer accessible.
If your selection included part layouts sets to concert pitch, Dorico Pro shows a warning and
offers to switch them all to transposed pitch before printing/exporting. You can also select which
layouts you want to switch to transposed pitch or proceed anyway with no changes.

TIP

You can assign key commands to different printing and exporting commands on the Key
Commands page in Preferences, which you can use in any mode.

RELATED LINKS
Export File Names dialog on page 477
Graphics file formats on page 484
Image resolution on page 485

Specifying an export path for graphics files
You can specify a path to any folder to which you want to export graphics files. You can specify a
different export path for each layout and still export them all simultaneously.

By default, Dorico Pro exports graphics files into the same folder as your project file. If you have
not saved your project yet, graphics files are saved in the default user folder of your operating
system.

PROCEDURE

1. In the Layouts list, select the layouts whose export path you want to change.

2. In the Destination section of the Print Options panel, click Choose Folder beside the
Destination folder field to open the File Explorer/macOS Finder.

3. In the File Explorer/macOS Finder, locate and select the destination folder you want.

4. Click Open (macOS)/Select Folder (Windows) to insert the new path in the Destination
folder field.

5. Optional: Repeat steps 1 to 4 for other layouts whose export path you want to change.

6. Optional: If you want to change the file name recipe, click File Name Options to open the
Export File Names dialog.

7. Optional: In the Export File Names dialog, change the file name recipe for your selected
graphics file formats.

RESULT
The export path for the selected layouts is changed. When exported, the layouts use the file
name recipe set for their graphics file format in the Export File Names dialog.

NOTE

If the export path specified is no longer accessible, such as if you receive a project from someone
who uses a different operating system, Dorico Pro automatically updates the export path to the
same location as the project file.
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Export File Names dialog
The Export File Names dialog allows you to determine the contents of file names for each
graphics file format independently. You can use universal ingredients that update to show the
correct information for each layout automatically, and you can enter text that is the same for all
layouts.

You can open the Export File Names dialog in any of the following ways:

● Click File Name Options in the Destination section of the Print Options panel in Print
mode when the currently selected layout is set to Graphics.

● Click Edit in the Exporting Files subsection of the General page in Preferences.

NOTE

Your settings are linked between both ways of accessing the dialog and are saved as the default
for all future projects.

The Export File Names dialog contains the following options:

1 File names for
Allows you to select different graphics file formats. You can set different file name recipes
for each graphics file format.

2 File name recipe
Displays the recipe for the selected graphics file format. You can enter text directly into
this field, and click ingredients to add them automatically.
For example, the default PDF file name recipe is $n - $l - $t.

3 Reset to Default
Resets the file name recipe to the default for the selected graphics file format.

4 Copy to All
Copies the file name recipe to all layouts in the project.

5 Preview
Displays an example file name based on the current recipe. The layout used for the
preview is the one shown in the layout selector in the toolbar.

Print mode
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For example, the preview for a full score PDF file name using the default recipe might be
01 - Full score - Lieder.pdf

6 File name ingredients
Allow you to add ingredients to the file name recipe quickly that are automatically
populated as appropriate for each layout. For example, the ingredient $l becomes Piano
when used to export a piano part layout.
The buttons for each ingredient display both the information to which the ingredient
refers and the characters for it.
When you click file name ingredients, they are added to the end of the file name recipe.
They are automatically separated from the previous ingredient using the default
separator.

NOTE

The page number ingredient is not available for the PDF file name recipe as it is a multi-
page format.

7 Default separator
Allows you to set the characters used to separate ingredients in the file name recipe by
default.

RELATED LINKS
Exporting layouts as graphic files on page 475

Monochrome and color graphics processing
Dorico Pro applies different settings when you export monochrome and color graphics. The most
appropriate setting depends on your intended purpose for the graphics.

Most musical scores are monochrome, meaning they use only black ink and are normally printed
on white/near-white paper. Some educational books occasionally use colors to highlight
particular notations, for example, to identify clefs, or to color notes according to their pitch. If
you export graphics files and print them with your own printer, you can leave Color selected in
the Destination section.

However, if you export graphics files in PDF format for direct printing on a platesetter or for
further production work in a page layout program, select Mono, unless your layout actually
contains colored elements. If you select Mono, Dorico Pro uses a different color space for the
resulting PDF, ensuring that the printed image only uses black ink. If you choose Color, then the
black items in your layout are exported as rich black, that is, black produced by combining
multiple colored inks. This can cause problems in production when making color separations at
the pre-press stage.

Dorico Pro specifies colors using the RGB color model, rather than the CMYK color model that is
used by platesetters and other professional printing machines. If you have colored objects in
your layouts and your layouts are printed professionally, you must post-process the graphics files
that are exported from Dorico Pro in another graphics application to convert the colors from RGB
to CMYK.

RELATED LINKS
Exporting layouts as graphic files on page 475
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Embedding of fonts in PDF and SVG files
How fonts are handled in PDF and SVG files mainly depends on the fonts that you use in the
project.

PDF Files
The music and text fonts, and their sub-sets, that are supplied with Dorico Pro are
embedded in PDF files during the export. If you open the PDF files on a different
computer, they look the same, even if that computer does not have the fonts
installed that are used in the document. If you use different fonts, make sure that
these permit embedding.

SVG Files
SVG (Scalable Vector Graphics) files do not embed fonts directly. Some font
characters, such as note heads, articulations, and accidentals, are converted into
outlines, so that they do not depend on the font from which they are taken. Other
font characters, such as time signature and tuplet digits, are only encoded using
references to the font from which they are taken. The latter also applies to regular
text, such as staff labels, tempo instructions, and dynamics. This means that the SVG
file looks incorrect if rendered by a web browser on a computer that does not have
the fonts installed. The appearance of SVG files depends on the browser or the
rendering software, and on the fonts that are installed on the computer.
To ensure that the SVG file appears correctly if embedded in a web page, you can
open the SVG file in an illustration program and convert all font characters to outline
paths, then re-export the SVG file and embed that file. Alternatively, you can use web
fonts to ensure that the necessary fonts are available on the web server.
SVG graphics that are exported from Dorico Pro conform to the SVG Tiny 1.1
specification, which defines a subset of features in the full SVG specification.
For information about using web fonts with SVG, refer to the Help Center on the
Steinberg website.

Printers
You can print layouts from Dorico Pro projects to any printer to which your computer is
connected.

You can select different printers for each layout in your project. This allows you to send layouts to
the most appropriate printer for their requirements. You can select a printer when Printer is
chosen in the Destination section of the Print Options panel.

Dorico Pro uses the same printer as designated by the operating system by default, unless you
specify another printer. In this case, the settings in the following sections in the Print Options
panel can change:

● In the Page Setup section, the list of available paper sizes lists only paper sizes that the
chosen printer provides.

● In the Duplex Printing section, the option for automatic duplex printing is only available if
the chosen printer has this function.

NOTE

The printer menu in the Destination section only shows the name of a printer if all currently
selected layouts are set to print to the same printer. If you select a new printer from the menu,
all selected layouts are set to print to that printer.

RELATED LINKS
Print Options panel on page 470
Printing layouts on page 472
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Page arrangements for printing/exporting
Dorico Pro provides several page arrangements that you can use for printing/exporting your
layouts.

In the Job Type section of the Print Options panel, you can specify how you want the layouts to
be printed/exported. You can select the following job types from the Job Type menu:

Normal
Prints one page on each sheet of paper. This produces single-sided pages, for
example, for instrumental parts that do not have regular page turns and must be
bound in a continuous line.

Spreads
Prints two pages on each sheet of paper, with odd-numbered pages on the right-
hand side and even-numbered pages on the left-hand side.
You can also specify a paper size on which to print odd final pages, for example, if
you are printing a layout containing five pages.

2-up
Prints two pages on each sheet of paper. The first page in the range is printed on the
left-hand side of the first sheet of paper. This can be useful for printing instrument
parts as it reduces the number of edges that must be bound, because pages can also
be folded in half.
You can also specify a paper size on which to print odd final pages, for example, if
you are printing a layout containing five pages.

Booklet
Prints two pages on each sheet of paper according to imposition requirements. This
means that if the paper is folded, the pages are laid out like a book. This can be
useful for scores and choir parts in particular as they often contain more pages than
instrumental parts.

NOTE

You can only print booklets using the complete range of pages. You cannot define
any page ranges.

NOTE

● Depending on the job type that you choose, Dorico Pro switches the page orientation
automatically. The changed orientation is immediately displayed in the music area. If this
is not what you want, you can override the orientation in the Page Setup section.

● All of the job types allow printing either onto a single side of each sheet of paper or on
both sides of the paper.

● It is usual to print booklets, spreads, and 2-up onto paper in landscape orientation.
Printing one page to each sheet typically uses portrait orientation, unless the layout itself
uses landscape orientation.

Also in the Job Type section, you can choose which pages you want to print/export.

All Pages
Allows you to print/export all pages of the selected layouts.

Page Range
Allows you to set a range of pages to be printed. Choosing Page Range makes the
value field available.
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● To specify a range, enter the first page and last page separated with a dash,
such as 1-4.

● To specify individual pages or separate ranges, enter each page/range
separated with commas, such as 1,3,5-8.

RELATED LINKS
Paper size and orientation setup on page 483
Printing/Exporting a page range on page 474

Booklet printing
Booklets are documents printed on both sides of the paper and folded to resemble the pages in
a book. When printed as a booklet, pages are reordered so that you can fold the printed pages
and read the content in the same order as they were in the project.

Printing layouts as a booklet can be much quicker than printing pages single-sided or double-
sided. For example, if your full score is twenty pages long and you print it on both sides
automatically, you must then bind one edge of the printed pages in order to keep them together.
However, if you print the full score as a booklet, you can simply fold the printed pages in the
middle.

Booklet printing settings reorder pages so that they appear in the correct order on the printed
page. For example, a layout containing four pages printed as a booklet is laid out as follows:

● First side: page four on the left, page one on the right

● Reverse side: page two on the left, page three on the right

If the layout you are printing as a booklet contains an odd number of pages, Dorico Pro
automatically places any empty last pages at the end of the booklet. This follows the convention
of showing odd-numbered pages on the right. For example, if you print a layout containing six
pages as a booklet, a total of eight pages are printed with the last two pages in the booklet left
blank. If you want the empty pages to be positioned differently, you can add extra pages to the
layout, for example, a title page.

NOTE

● You can only print booklets using the complete range of pages. You cannot define any
page ranges.

● If the order of inward pages is incorrect when you are printing booklets using manual
duplexing, you can activate Reverse order of outward pages in the Duplex Printing
section of the Print Options panel, which instructs Dorico Pro to output the first set of
pages in the opposite order.

RELATED LINKS
Printing layouts on page 472
Duplex printing on page 481

Duplex printing
Dorico Pro allows duplex printing, which means that you can print on both sides of each sheet of
paper.

If your printer supports automatic duplex printing, you can use this function in Dorico Pro. If
your printer can only print on one side of each sheet of paper, there is a manual duplex printing
option.

The Print on menu in the Duplex Printing section of the Print Options panel contains the
following options:
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One side only
Prints on one side of each sheet of paper.

Both sides manually
Prints on both sides of each sheet of paper. Use this option if you printer lacks an
automatic duplex printing function. After all outward pages have been sent to the
printer, a message box informs you to turn over the stack of printed pages and put
them back into the printer. Click OK to continue printing the inward pages.

Both sides automatically
Prints on both sides of each sheet of paper automatically. This option is only
available if your printer supports this type of printing.

The other menus in the Duplex Printing section allow you to set how the printed image is
flipped when printing on the reverse side of the paper.

Flip image (portrait)

Determines how the image is flipped for reverse side printing in portrait orientation.

● Flip automatically uses the printer’s default settings for printing on the
reverse side. If you find that the printer flips on a different edge than
expected, use one of the other options.

● Flip long side sets the printer to flip the pages on the long edge.

● Flip short side sets the printer to flip the pages on the short edge.

Flip image (landscape)

Determines how the image is flipped for reverse side printing in landscape
orientation.

● Flip automatically uses the printer’s default settings for printing on the
reverse side. If you find that the printer flips on a different edge than
expected, use one of the other options.

● Flip long side sets the printer to flip the pages on the long edge.

● Flip short side sets the printer to flip the pages on the short edge.

Reverse order of outward pages at the bottom of the section instructs Dorico Pro, when
activated, to output the first set of pages in the opposite order when printing booklets using
manual duplexing. This is necessary for some printers so that you do not have to reverse sort the
pages manually before returning them to the printer to print the other sides.

RELATED LINKS
Printing layouts on page 472

Page sizes and paper sizes
In Dorico Pro, page sizes and paper sizes use different settings. This means that you can print
layouts with any page size onto paper with a different paper size.

For each layout in your project, you can define a page size on the Page Setup page in Setup >
Layout Options. This means that you define the dimensions of the layout. For printing your
layout, you must usually choose a paper size that is provided by the printer that you are using.

Normally, the layout's page size and the printed paper size match. However, if you define a
layout with an unusual page size that is not supported by your printer, such as 10" x 13", one of
the standard page sizes for instrumental parts, you may have to print the layout onto a different
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paper size. You can change the paper size in the Page Setup section of the Print Options panel
according to your needs. As long as your printer supports sufficiently large paper for your page
size settings, and they match a standard paper size, your dimensions are included in the menu.
Changing the paper size has no effect on your layout's page size, and does not, therefore, affect
the way the music is laid out.

If you do not select a specific paper size, Dorico Pro automatically chooses a paper size that is
based on your computer's locale settings. For example, if these are set to a European country, an
international ISO standard might be used, such as A4. If they are set to a North American
country, one of their typical standards might be used, such as US Letter.

If you have defined a page size for your layout that is larger than a typical standard, Dorico Pro
automatically chooses the next larger paper size, provided that your printer supports this. For
example, if the layout's page size is larger than A4/US Letter, A3/Tabloid is used.

If you print to a different paper size than the layout's page size, Dorico Pro automatically scales
the image to fit the paper. You can change this setting by specifying a custom scale factor in the
Page Setup section.

Paper orientation
Paper orientation is the direction of rectangular paper for viewing and printing. Paper can have
either landscape or portrait orientation.

Instrumental parts are most often printed using portrait orientation, as this allows two or three
pages to be spread out at a time on most music stands.

Full scores for conductors are also commonly printed using portrait orientation, as this allows
more staves to fit on the page than with landscape orientation. However, full scores for small
ensembles might use landscape orientation as fewer staves have to fit on the page. Having more
horizontal room on the page allows more bars to fit on each page, reducing the number of page
turns required.

In Dorico Pro, you can set the orientation of pages independently of the paper orientation, for
example, you can print portrait pages on landscape paper. You can also separately set the paper
orientation of the odd final page in layouts using the Spreads and 2-up page arrangements.

RELATED LINKS
Changing the page size and orientation on page 343

Paper size and orientation setup
Layouts can have different paper sizes and orientation settings.

NOTE

If you have selected Graphics in the Destination section of the Print Options panel, you can only
change the paper orientation. No other options are available.

The Page Setup section of the Print Options panel contains the following options when you have
chosen Printer in the Destination section:

Paper size
Allows you to select one of the available paper sizes from the menu. The paper sizes
available depend on the capabilities of the selected printer.

Paper orientation
You can choose one of the following paper orientation options:

● Portrait
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● Landscape

Print odd final page on
For Spreads and 2-up job types only: If this is activated, you can select a different
paper size or orientation for the odd final page.
This setting is useful when printing layouts with an odd number of pages on A3
paper in landscape orientation. For example, if your layout contains five pages, the
first four pages fit onto two sheets of A3, while the fifth page would occupy only the
left-hand side of a third sheet of A3. This setting allows you to print the odd final
page on A4 paper in portrait orientation instead.

Fit to Paper
The whole page is scaled to fit the paper size selected. For example, if you select a
layout with a page size of A4 and select a paper size of A3, pages in the layout are
enlarged to fit the larger paper size.

Custom Scale
The page is scaled to the set percentage of its original size. For example, if you are
printing a layout with a page size of A3, select a paper size of A4, and set Custom
Scale to 100, the original page remains at its original size, exceeding the boundaries
of the A4 paper.

RELATED LINKS
Page arrangements for printing/exporting on page 480
Changing the page size and orientation on page 343

Graphics file formats
Dorico Pro supports multiple graphics file formats as which you can export your layouts.

PDF
Stands for Portable Document Format. Exporting layouts to PDF allows you to create
a platform-independent document that contains a fixed version of each layout, for
example, to send to someone who does not have access to Dorico Pro.

PNG
Stands for Portable Network Graphics. PNG files are losslessly compressed, meaning
they produce high-quality images.

SVG
Stands for Scalable Vector Graphics. Because SVG is an XML-based text format, it can
be scaled to any size without any loss of quality. Dorico Pro renders SVG graphics
using drawing instructions rather than rasterizing them, resulting in better
resolutions and smaller file sizes.

TIFF
Stands for Tagged Image File Format. TIFF files are not compressed, which means
their file sizes can be larger than other formats and the quality of the image is not
reduced.

RELATED LINKS
Exporting layouts as graphic files on page 475
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Image resolution
Image resolution refers to the number of pixels contained in an image. The larger the number of
pixels, the sharper and clearer the image appears.

In Dorico Pro, you can export PNG and TIFF files with different image resolutions. The image
resolution is measured in dots per inch, or “dpi”.

● 72

● 150

● 300

● 600

● 1200

NOTE

A resolution of 72 dpi is suitable for display on screen so that you can embed the graphic in an e-
mail or on a web page. If you choose 300, 600, or 1200 dpi, a high-resolution image is saved that
you can include as an illustration in a word processing or desktop publishing document.

RELATED LINKS
Exporting layouts as graphic files on page 475

Annotations
Annotations provide additional information for printed or exported documents, such as the date
and time it was printed. Publishers and printing agencies can use these to identify and register
printed images correctly or to embed exported graphics files into a desktop publishing
application.

When printing/exporting your layouts for publication, you can include typical annotations. You
can also allow Dorico Pro to print or export any view options that you have activated in your
project.

NOTE

Crop marks and the border can only be printed if the page size is smaller than the paper size.

The Annotations section of the Print Options panel contains the following options:

Crop marks
Adds short vertical and horizontal lines at each of the four corners of the page.

Border
Adds an outline around the edge of the page dimensions.

Date and time
Adds the date and time of printing at the bottom of each page.

Watermark
Adds large translucent text across the middle of each page. This is useful for
indicating that this version is a draft, proof, or perusal score.
In the Watermark field at the bottom of the section, you can enter the text that you
want to show on each page.

View options
Adds all active view options, such as signposts and note colors, to the printout or
exported graphic.
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Notation reference



This notation reference contains information about the accepted conventions for presenting
different notations and how to change their appearance and placement in Dorico Pro, both for
individual items and by changing project-wide settings.

It also contains instructions for inputting more complex notations, such as cross-staff glissando
lines, which are described in the corresponding chapter.

Tasks in the notation reference outline the default changes you can make to items, which can
apply per-flow, per-layout or project-wide; for example, changing spacing gaps or the project-
wide appearance of pedal lines are both project-wide changes you can make in Engrave >
Engraving Options. Tasks also outline the individual changes you can make to items
independently of your default settings, which often involve using properties in the Properties
panel.

You can find basic input methods for notations in the Write mode chapter.

RELATED LINKS
Write mode on page 131

Introduction
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Accidentals show that the pitch of a note has been altered so that it does not conform to the
current prevailing key signature.

In music that has no key signatures, some or all notes might require accidentals, depending on
the notation convention in use.

Dorico Pro provides comprehensive duration rules that determine when accidentals are shown,
and also allows you to control how accidentals are arranged in complex chords.

RELATED LINKS
Inputting accidentals on page 162

Deleting accidentals
You can delete accidentals according to their type and you can delete all accidentals from a
selection of notes with different accidentals at the same time.

NOTE

These steps do not apply to cautionary accidentals, such as those shown on natural notes that
follow the same notes with an accidental but in a different octave. In Dorico Pro, you can hide,
show, or parenthesize cautionary accidentals in each flow and on individual notes.

PROCEDURE

1. In Write mode, select the notes whose accidentals you want to delete.

2. Delete accidentals in any of the following ways:

● Press 0 to delete naturals.

● Press - to delete flats.

● Press = to delete sharps.

● Click the button of the accidental in the Notes panel.

RESULT
The corresponding accidentals are deleted from the selected notes.

NOTE

● If a note of the same pitch appears with an accidental earlier in the bar, but that accidental
has not been deleted, any subsequent notes of the same pitch assume that accidental
even if it does not appear by every notehead.

● To delete accidentals from a selection of notes with different accidentals, we recommend
that you revert them all to natural by pressing 0 or clicking Natural in the Notes panel.
This is because re-inputting an accidental over a selection of notes with different
accidentals adds that accidental to every note in the selection. For example, two G♯s

Accidentals
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followed by two G♭s become four G♯s if you re-input a sharp. If you click Sharp or press =
twice, all accidentals are deleted.

RELATED LINKS
Inputting accidentals on page 162
Hiding/Showing cautionary accidentals on page 495
Hiding/Showing or parenthesizing accidentals on page 489

Hiding/Showing or parenthesizing accidentals
You can show individual accidentals in parentheses, and also hide/show accidentals individually,
including cautionary accidentals shown by default. For example, you can show an accidental in
parentheses on subsequent notes in tie chains that cross system/frame breaks.

PROCEDURE

1. Select the notes whose accidental appearance you want to change, or beside which you
want to show cautionary accidentals. You can do this in Write mode and Engrave mode.

NOTE

You can only select individual noteheads within tie chains in Engrave mode.

2. In the Properties panel, activate Accidental in the Notes and Rests group.

3. Select one of the following options from the menu:

● Show

● Hide

● Parenthesize

NOTE

Hiding accidentals does not affect the pitch of notes in playback.

RESULT
Accidentals on the selected notes are shown, hidden, or shown in parentheses.

TIP

● If you are hiding/showing many accidentals, it might be easier to change the accidental
duration rule.

● You can assign key commands for different accidental hiding, showing, and parenthesizing
commands on the Key Commands page in Preferences.

RELATED LINKS
Accidental duration rules on page 493
Preferences dialog on page 51

Project-wide engraving options for accidentals
You can find options for the project-wide appearance and position of accidentals on the
Accidentals page in Engrave > Engraving Options.

The options on the Accidentals page allow you to change the order of accidentals in chords and
the precise positioning of accidentals relative to noteheads, ledger lines, and parentheses.

Accidentals
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There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Stacking of accidentals
If multiple accidentals are required for a chord in a single voice, or for notes in multiple voices at
the same rhythmic position, they are stacked to the left of the chord in columns.

For chords with multiple accidentals, accidentals are generally stacked as follows:

1. The highest accidental is inserted in the first column immediately to the left of the notes.

2. The lowest accidental is added to the same column, provided that it does not collide with
the first accidental.

3. The remaining highest and lowest accidentals are alternated in successive columns located
further left from the chord.

In Dorico Pro, additional rules help to produce a stack of accidentals that uses as few columns as
possible. The following list contains some of the rules that are applied:

● Columns closer to the notes contain more accidentals than columns further from the
notes.

● Accidentals on notes that are an octave apart are stacked in the same column. This also
applies to accidentals that are a sixth or more apart, depending on the combination of
accidentals.

● Accidentals in the same column never collide. The minimum interval between accidentals
that is required to prevent collisions depends on the types of accidentals.

● Accidentals that are a second apart are arranged in adjacent columns, with the higher
accidental in the right-hand column.

These rules minimize the amount of extra space that is required between successive notes or
chords and ensure that accidentals appear as close as possible to the noteheads to which they
apply. At the same time, they produce a contour that resembles a C-curve on the left-hand side of
the chord.

TIP

You can customize the default settings for the stacking of accidentals project-wide in the
Stacking section of the Accidentals page in Engrave > Engraving Options. For example, you
can allow accidentals to be stacked without interspersion, so that accidentals appear in a
diagonal line sloping downwards to the left.

RELATED LINKS
Project-wide engraving options for accidentals on page 489

Accidental stacking rules for dense chords
Dorico Pro uses special stacking calculations in dense chords with multiple accidentals to ensure
legibility. Chords are considered dense when they have six or more accidentals within the span of
an octave.

For dense chords, accidentals are stacked as follows:

1. The highest accidental is inserted in the first column to the left of the notes.
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2. The next accidental on a note that is located at least a seventh below the highest note is
stacked into the same column. This continues with the remaining notes until no more
accidentals fit into the first column.

3. Steps 1 and 2 are repeated for the following columns until all accidentals are stacked.

4. The columns are grouped, interspersed, and re-stacked. This results in a stack with
alternating accidentals, reminiscent of the way accidentals are arranged in a key signature.

NOTE

By default for dense chords, Dorico Pro uses a lattice arrangement of accidentals rather than the
usual zig-zag arrangement. In very dense chords, the lattice arrangement can be wider and
require more columns. You can change the default arrangement of all dense chords project-wide
in the Stacking section of the Accidentals page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for accidentals on page 489

Kerning of accidental columns
Dorico Pro applies kerning to accidental columns to ensure that the columns to the left of a
chord occupy as little horizontal space as possible.

In typography, kerning adjusts the space between individual characters to increase legibility. In
Dorico Pro, as well as in music engraving in general, kerning allows accidentals to interlock.

EXAMPLE
If a low note is followed by a high note with an accidental, the accidental can be tucked above the
low note to prevent the note spacing from being distorted.
Similarly, in the case of multiple columns of accidentals on a chord, the overall width of the stack
of accidentals is reduced if, for example, a flat in the second column is kerned underneath a
sharp in the first column belonging to a note a third higher. This also reduces the need to distort
note spacing to accommodate accidentals.

Altered unisons
Altered unisons occur when two or more notes of the same name in the same octave have
different accidentals in the same chord, such as D♯ and D♭.
In Dorico Pro, this is notated with a split stem, which allows both notes to appear with their
corresponding accidental directly beside them. A split stem is sometimes known as a “cherry
stalk” or a “tree”.

You can also have altered unisons appear with a single stem, meaning noteheads appear directly
beside each other, and the two accidentals are shown beside each other to the left of the chord.

NOTE

If a chord contains notes a second interval apart and one of those notes has an altered unison, it
is always shown with a split stem, regardless of your setting. This is to ensure clarity in clusters.
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EXAMPLE

A single stem altered unison A split stem altered unison

RELATED LINKS
Inputting chords on page 167

Changing how altered unisons appear
You can change how individual altered unisons appear, including within chords containing other
altered unisons, and independently of your per-flow settings.

PROCEDURE

1. Select the altered unison notes whose appearance you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Split stem in the Notes and Rests group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
The selected altered unison notes are shown with split stems when the checkbox is activated,
and with single stems when the checkbox is deactivated.

TIP

● Split stem applies to individual notes. You can have altered unisons appear differently
within the same chord by setting their properties independently.

● You can change the default appearance of all altered unisons in each flow independently
in the Altered unisons section of the Accidentals page in Write > Notation Options.

RELATED LINKS
Notation Options dialog on page 139

Microtonal accidentals
Microtonal accidentals indicate pitches beyond the standard accepted chromatic scale in Western
tonality, such as a quarter sharp or quarter flat.

You can use microtonal accidentals when you have selected a tonality system that includes
microtonal accidentals, such as Equal temperament (24-EDO).

The default tonality system is Equal temperament (12-EDO), which you can see in the Tonality
System section of the Key Signatures, Tonality Systems and Accidentals panel. When this option
is selected, the accidentals available in the Accidentals section of the panel are only half-step
(semitone) accidentals, such as sharp, flat, double flat, and so on. Equal temperament (12-EDO)
does not include microtonal accidentals.

You can change the tonality system for specific passages of music, which changes the microtonal
accidentals available. You can also define your own tonality systems with custom octave
divisions, key signatures, and accidentals.
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NOTE

Even if you do not want to use a conventional key signature, you must input an open or atonal
key signature in order to change the tonality system and use microtonal accidentals.

RELATED LINKS
Tonality systems on page 673
Changing the tonality system on page 674
Custom tonality systems on page 675
Custom accidentals on page 677
Playback of custom tonality systems on page 683

Inputting microtonal accidentals
You can input microtonal accidentals, such as quarter tone flat or three quarter tones sharp, into
your project.

PREREQUISITE
You have input a key signature and selected a tonality system for that key signature that allows
microtonal accidentals, such as Equal temperament (24-EDO), for the section of your project
where you want to input microtonal accidentals.

PROCEDURE

1. In Write mode, select the note or notes to which you want to apply a microtonal accidental.

2. In the Key Signatures, Tonality Systems, and Accidentals panel, click the microtonal
accidental you want in the Accidentals section.

RESULT
The selected microtonal accidental appears beside the selected note or notes.

NOTE

You can only input one type of accidental at a time.

RELATED LINKS
Tonality systems on page 673
Changing the tonality system on page 674
Input methods for key signatures on page 186

Accidental duration rules
Accidental duration rules determine how long accidentals apply, such as within a bar, at a
different octave, or just for a single note.

Dorico Pro allows you to use different accidental duration rules.

Common practice
In Dorico Pro, this is the default accidental duration rule. In common practice, an
accidental applies for the duration of a bar and only to the pitch at which it is written,
meaning each octave requires a separate accidental.

Second Viennese School
The Second Viennese School accidental duration rule requires writing every note with
an accidental, including naturals.
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Modernist
The Modernist accidental duration rule states that only notes that have been altered
from the key signature show accidentals. Naturals are not shown.

RELATED LINKS
Common practice accidental duration rule on page 495
Second Viennese School accidental duration rule on page 496
Modernist accidental duration rule on page 496

Changing the accidental duration rule
You can change the accidental duration rule to the one most appropriate for each flow in your
project.

PROCEDURE

1. Press Ctrl/Cmd-Shift-N to open Notation Options.

2. In the Flows list, select the flows in which you want to change the accidental duration rule.
By default, only the current flow is selected when you open the dialog.

3. Click Accidentals in the page list.

4. In the Basic section, choose one of the following options for Accidental duration rule:

● Common Practice

● Second Viennese School

● Modernist

5. Optional: Customize the options for your chosen accidental duration rule.

TIP

Options in the Basic section can apply to all accidental duration rules.

6. Click Apply, then Close.

RELATED LINKS
Common practice accidental duration rule on page 495
Second Viennese School accidental duration rule on page 496
Modernist accidental duration rule on page 496

Double accidental cancellation
There are two generally accepted practices for the cancellation of double accidentals, which are
archaic and modern. You can use either practice in each flow independently in Dorico Pro.

By default, Dorico Pro uses modern cancellation. This means that if a double sharp is cancelled
by a single sharp, or a double flat is cancelled by a single flat, then no natural sign is shown in
front of the single sharp or single flat, as these accidentals are unambiguous.

You can change how double accidentals are cancelled in each flow independently in the Basic
section of the Accidentals page in Write > Notation Options. You can use this option with any
accidental duration rule.

● If you choose Use archaic cancellation, natural signs are shown before new accidentals
that come after double accidentals.

● If you choose Use modern cancellation, double accidentals are replaced immediately
with a new accidental without showing a natural sign first.
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EXAMPLE

Archaic cancellation Modern cancellation

RELATED LINKS
Notation Options dialog on page 139

Common practice accidental duration rule
In common practice, an accidental affects all notes of the same pitch in the same octave within
the same bar, unless it is cancelled by another accidental. If it is not cancelled, it is automatically
cancelled in the following bar.

NOTE

To ensure that the cancellation is unambiguous, it is customary to add a cautionary accidental to
the first note of the same pitch in the following bar.

In Dorico Pro, the common practice accidental duration rule is used by default. You can change
the accidental duration rule on the Accidentals page in Write > Notation Options.

In common practice, the accidental of a note in one bar is automatically cancelled in the
following bar. For example, in the key of G major, if an F♮ is in one bar, an F in the following bar
shows a sharp sign, even though the sharp is already implied by the key signature.

When using the common practice accidental duration rule by default, Dorico Pro also displays
cautionary accidentals, which are restatements of an earlier accidental. They are considered
optional; that is, they are neither explicit confirmations nor cancellations, but help to eliminate
ambiguities. Cautionary accidentals are also known as “courtesy accidentals”.

Cautionary accidentals are shown in the following circumstances:

● Subsequent notes within the same bar have the same note name in different octaves.

● Subsequent notes in the following bar have the same note name in the same octave.

● The first occurring note in the following bar has the same note name in any octave.

● Augmented/Diminished or double-diminished/augmented intervals are identified within
the same bar.

For each of these situations, you can choose whether cautionary accidentals are shown in
parentheses, shown without parentheses, or not shown at all.

RELATED LINKS
Changing the accidental duration rule on page 494

Hiding/Showing cautionary accidentals
You can hide/show cautionary accidentals if you use the common practice accidental duration
rule.

PROCEDURE

1. Press Ctrl/Cmd-Shift-N to open Notation Options.

2. In the Flows list, select the flows in which you want to hide/show cautionary accidentals.
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By default, only the current flow is selected when you open the dialog.

3. Click Accidentals in the page list.

4. In the Basic section, choose Common practice for Accidental duration rule.

5. In the Cautionary accidentals section, choose the options that you want to apply to the
selected flows.

6. Click Apply, then Close.

RELATED LINKS
Common practice accidental duration rule on page 495

Second Viennese School accidental duration rule
The accidental duration rule of the Second Viennese School states that an accidental applies only
to the note on which it is written. All notes show an accidental regardless of key signature,
including unaltered notes which show naturals.

This accidental duration rule was used by Schoenberg and other composers of the Second
Viennese School.

You can customize the options within the Second Viennese School accidental duration rule when
changing the accidental duration rule, including choosing whether immediate repetitions of the
same note within the same bar require a restatement of the accidental.

RELATED LINKS
Changing the accidental duration rule on page 494

Modernist accidental duration rule
The Modernist accidental duration rule states that only notes that have been altered from the
key signature show accidentals. Naturals are not shown. However, accidentals that are shown
only apply to the notes on which they are written, as with the Second Viennese School.

Charles Ives and Robert Crumb used this variation.

You can customize the options within the Modernist accidental duration rule when changing the
accidental duration rule, including choosing whether or not the same accidental on the same
pitch is restated later in the bar if the subsequent pitches occur immediately and if subsequent
pitches occur after other, different notes. There is also an option controlling the restatement of
accidentals within beam groups.

RELATED LINKS
Changing the accidental duration rule on page 494
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Articulations are markings that are drawn above or below notes and chords. Articulations tell a
performer how to attack a note or how long to play a note relative to its notated duration.

In Dorico Pro, articulations are defined as something that alters the way a note is played, in a
way that is consistent across all instruments.

As instructions like bowing directions, harmonics, or tonguing apply to different instrument
groups, in Dorico Pro such directions are defined as playing techniques, and can be found in the
Notations panel on the right of the window.

Articulations are categorized into the following types:

● Articulations of force
Indicate a stronger attack at the start of notes, and include articulations such as accent
and marcato. Marcato is also sometimes known as a “strong accent”. Dorico Pro shows
these articulations at the start of a note or tie chain by default.

● Articulations of duration
Indicate a shorter duration than notated, and include articulations such as staccatissimo,
staccato, tenuto, and staccato-tenuto. Staccato-tenuto is also sometimes known as a
“louré”. If a note includes ties, Dorico Pro shows articulations of duration above the last
note in the chain by default.

● Articulations of stress
Indicate notes that should be emphasized or not emphasized where that contradicts the
prevailing meter, using stressed and unstressed marks. Dorico Pro shows these
articulations at the start of a note or tie chain by default.

You can find articulations at the bottom of the Notes panel in Write mode.

Dorico Pro positions articulations automatically on the notehead or stem side of notes and
chords, according to the musical context. A note or chord can display one of each of the three
types of articulations.

You can change the effect of articulations on playback, based both on the type of instrument and
the playback devices in use in the Note Dynamics section of the Dynamics page in Play >
Playback Options.

RELATED LINKS
Inputting articulations on page 182
Playback Options dialog on page 405
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Copying articulations
Articulations are automatically included if you copy notes, but they cannot be copied and pasted
independently of notes.

PROCEDURE

1. In Write mode, select the notes with articulations you want to copy.

2. Copy the notes in one of the following ways:

● Press R to repeat the material directly after itself.

● Press Ctrl/Cmd-C, select the position where you want to copy the selected notes,
then press Ctrl/Cmd-V.

● Alt-click the position where you want to copy the selected notes with articulations.

Changing articulations
You can change the articulations on notes after they have been input.

PROCEDURE

1. In Write mode, select the note whose articulation you want to change.

2. Change the articulation in any of the following ways:

● Press the key command of the articulation you want. For example, press ] for
staccato.

● Click the new articulation you want in the Notes panel.

RESULT
The new articulation is added. This replaces any existing articulation of the same type.

RELATED LINKS
Inputting articulations on page 182
Key commands for articulations on page 183

Deleting articulations
Individual articulation markings cannot be selected and deleted separately from their notehead
in Write mode, so articulations must be deleted by selecting the note or notes to which they are
attached, and deselecting the articulation.

PROCEDURE

1. In Write mode, select the notes whose articulations you want to delete.

2. Deselect the articulations in any of the following ways:

● Press the key commands of the articulations you want to delete.

● Click the articulations you want to delete in the Notes panel.

RELATED LINKS
Key commands for articulations on page 183
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Project-wide engraving options for articulations
You can find options for the appearance and placement of articulations project-wide on the
Articulations page in Engrave > Engraving Options.

The options on this page allow you to change the positions of articulations in detail, including
whether different articulations are shown above the staff or by the notehead, the positions of
articulations relative to ties and slurs, and the vertical gaps between articulations and notes/
other articulations.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Positions of articulations
There are established conventions for the position and placement of articulations relative to
notes, the staff, and staff lines, which ensure articulations are always clearly visible. For the
smallest articulations, such as staccato marks, correct placement relative to staff lines in
particular is vital.

Articulations are placed on the notehead side by default, with the following exceptions:

● In single-voice contexts, marcato is always placed above the staff, regardless of the stem
direction of the note or chord on which it is used. In multiple-voice contexts, marcato can
also be placed below the staff.

● If multiple voices are active, articulations are placed at the end of the stem side of a note
or chord. This clarifies which articulations belong to the up-stemmed notes and which to
the down-stemmed notes.

● If a note is placed on the middle staff line or on the space immediately on either side,
articulations that are less than a space in height are centered in the next unoccupied
space. This normally only applies to staccato and tenuto. If a note in the middle of the staff
has a staccato-tenuto articulation, the component parts of the articulation are split up and
placed in separate spaces.

● If an articulation cannot fit within a staff space, or if the note is placed high or low on the
staff, the articulation is placed outside the staff.

● If a note or chord is tied and the tie is placed above or below the notehead, articulations
that are placed on the notehead side of a note or chord are offset by an additional 1/4
space in order to avoid the end of the tie.

Articulations on the notehead side are always centered horizontally on the notehead. This also
applies to articulations on the stem side, except if the only articulation is a staccato or
staccatissimo. In this case, the articulation is centered on the stem.

RELATED LINKS
Project-wide engraving options for articulations on page 499
Changing the horizontal position of staccato marks on page 501
Moving individual articulations vertically on page 501
Changing the placement of articulations individually on page 502
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Order of articulations
If there are multiple articulations on the same notes, their vertical position and proximity to
noteheads/stems depends on their type.

Articulations are positioned in the following order:

1. Articulations of duration are positioned closest to notehead/stems.

2. Articulations of force are positioned outside articulations of duration.

3. Articulations of stress are positioned furthest from noteheads/stems.

Order of articulations in relation to slurs

Articulations of duration are positioned as follows:

● Inside slurs that start/end on a note or chord with an articulation.

● Inside the curvature of a slur.

● Inside tuplet brackets.

Articulations of force are positioned as follows:

● Outside slurs that start/end on a note or chord with an articulation, except if they can be
positioned within the staff.

● Inside the curvature of a slur if they fit between the slur and the note or stem, to which
they belong, without colliding.

● Outside tuplet brackets.

Force and stress articulations outside the ends of the
slur

Duration articulations inside the ends of the slur

Changing the positions of articulations on tied notes
You can change where in tie chains articulations appear individually, independently of your
project-wide settings. By default, articulations of force and stress are shown on the first note/
chord in tie chains, while articulations of duration are shown on the last note/chord.

PROCEDURE

1. Select the tied notes/chords whose articulation position you want to change. You can do
this in Write mode and Engrave mode.

2. In the Articulations group of the Properties panel, activate Pos. in tie chain under the
corresponding heading for the articulation whose position you want to change.
For example, activate Pos. in tie chain under the Articulations of force heading to
change the position of accents.

3. Choose one of the following options:

● First note

● Last note

4. Optional: Repeat steps 2 and 3 to change the position of other types of articulations on the
selected tied notes/chords.
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RESULT
The position of articulations in the selected tie chains is changed.

TIP

You can change the default position of each type of articulation relative to all tie chains project-
wide in the Ties section of the Articulations page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for articulations on page 499

Changing the horizontal position of staccato marks
You can change the default horizontal position of all staccato and staccatissimo articulations
when they are placed on the stem side of notes project-wide. By default, staccato and
staccatissimo articulations are centered on the stem when on the stem side.

The horizontal position of most articulations is centered on a stem or a notehead. However, if a
staccato or staccatissimo is the only articulation, its horizontal position can also be half-centered
when they are placed on the stem side.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Articulations in the page list.

3. In the Horizontal Position section, choose one of the following options for Horizontal
position of staccato on stem side:

● Center on notehead

● Center on stem

● Half-center

4. Click Apply, then Close.

RESULT
Staccato marks are positioned project-wide according to the option selected.

RELATED LINKS
Project-wide engraving options for articulations on page 499

Moving individual articulations vertically
You can move individual articulations graphically upwards/downwards so they are closer to/
further away from notes.

PROCEDURE

1. In Engrave mode, select the articulations that you want to move.

2. Move the articulations in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.
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● Click and drag them upwards/downwards.

RESULT
The selected articulations are moved vertically.

TIP

● When you move articulations vertically, Offset Y in the Articulations group of the
Properties panel is activated for the corresponding type of articulation. For example,
Offset Y under the Articulations of force heading is activated when you move accents.

You can also use these properties to move articulations vertically by changing the value in
the value field.

Deactivating the properties resets the selected articulations to their default positions.

● You can change the default gaps between all articulations and their noteheads and other
articulations on the Articulations page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for articulations on page 499

Changing the placement of articulations individually
You can change whether individual articulations are placed on the notehead side or stem side of
notes.

PROCEDURE

1. Select the notes/chords whose articulation placement you want to change. You can do this
in Write mode and Engrave mode.

2. In the Articulations group of the Properties panel, activate Placement under the
corresponding heading for the articulations whose placement you want to change.
For example, activate Placement under the Articulations of force heading to change the
placement of accents.

3. Select one of the following options from the menu:

● Notehead side

● Stem side

4. Optional: Repeat steps 2 and 3 to change the placement of other types of articulations on
the selected notes/chords.

RESULT
The articulation is placed on the selected side of the notes or chords. If this creates a collision
with other markings, such as playing techniques, Dorico Pro automatically makes adjustments to
make sure all markings are clear and legible.

RELATED LINKS
Changing the default placement of articulations on page 503
Moving individual articulations vertically on page 501
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Changing the default placement of articulations
You can change the default placement of all articulations according to their type, for example, if
you want articulations of stress always to be placed above the staff but articulations of duration
to be placed beside noteheads, both above and below the staff.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Articulations in the page list.

3. In the Placement section, choose one of the following options for each articulation type:

● Always above

● Natural placement

4. Click Apply, then Close.

RESULT
The default placement of the corresponding types of articulations is changed project-wide.
Articulations with Natural placement are placed on the notehead side of notes.

TIP

You can also change the default gaps between noteheads/stems and articulations and between
stacked articulations in the Vertical Position section of the Articulations page.

Articulations in playback
Adding articulations to your score affects how notes sound in playback.

If you do not have a sample library, Dorico Pro still changes how a note sounds in playback if you
have put an articulation on it. For example, a staccato mark causes a note to sound shorter than
normal, and an accent causes a note to sound louder than normal.

The Timing page in Play > Playback Options provides options for the default effect of
articulations of duration. The Dynamics page contains options for articulations of force.

If you do have a sample library, Dorico Pro loads the specific sample for an articulation if such a
sample is included in your sample library for that instrument.

As the articulation applies to the whole note, the sample is triggered at the start of a note. This
includes notes that are tie chains.

RELATED LINKS
Playback Options dialog on page 405
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Bars indicate a usually regular segment of time according to the number of beats, which is
usually determined by the prevailing time signature. Bars are separated from other bars to the
left and the right by vertical barlines.

Bars are usually the same length and at the same position for all players, but in some music, bars
of different lengths may coincide, and there are situations where some players may have no bars
indicated at all.

Each bar has a number, allowing players to keep track of their place in the music and aiding
rehearsal. This is especially important in music for multiple players.

RELATED LINKS
Bar numbers on page 519
Input methods for bars and barlines on page 201

Deleting bars/beats
You can delete whole bars and specific beats from your project completely by using the bars and
barlines popover.

PROCEDURE

1. In Write mode, select one of the following:

● The first bar you want to delete, or the first note or rest in that bar.

● An item at the rhythmic position from which you want to delete beats

2. Press Shift-B to open the bars and barlines popover.

3. Enter – (minus), followed by the number of bars or beats you want to delete into the
popover.
For example, enter –6 to delete six bars, meaning the bar you selected and the subsequent
five bars, or -2q to delete two quarter note beats, starting from the selected rhythmic
position.

4. Press Return to close the popover.

RESULT
The number of bars or beats specified is deleted.

RELATED LINKS
Bars and barlines popover on page 201
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Deleting bars/beats with the system track
You can delete whole bars and selected beats from your project completely using the system
track, for example, if you want to delete the last beat in the final bar for flows that begin with a
pick-up bar.

PREREQUISITE
The system track is shown.

PROCEDURE

1. In the system track in Write mode, select the region that you want to delete.

2. Click Delete in the system track. It can also appear above the system track if your selection
is narrow.

Delete button in the system track The system track changes color when you hover
over the Delete button.

RESULT
The selected region is deleted. Just as when Insert mode is active, music to the right of the
selection moves up to fill in the gap.

NOTE

Any signposts in the selection are also deleted. This can affect the page layout, for example, by
removing ossia staves whose signposts were included in the selection.

RELATED LINKS
System track on page 275
Hiding/Showing the system track on page 276

Deleting empty bars at the end of flows
You can delete any empty bars left at the ends of flows.

PROCEDURE

1. In Write mode, select an item in the flow you want to trim.

2. Press Shift-B to open the bars and barlines popover.

3. Enter trim into the popover.

4. Press Return to close the popover.

RESULT
Empty bars at the end of the selected flow are deleted.

RELATED LINKS
Bars and barlines popover on page 201
Splitting flows on page 289
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Deleting the contents of bars
You can delete just the contents of bars without deleting barlines or the bars themselves.

PROCEDURE

1. In Write mode, select the bars whose contents you want to delete.

TIP

Notes, rests, and other objects are highlighted orange when selected.

2. Press Backspace or Delete.

RESULT
The contents of the selected bars are deleted.

RELATED LINKS
Large selections on page 274
Filters on page 278

Changes to the length of bars
You can change the length of a bar so that its duration is longer or shorter.

You can change the length of a bar by changing its time signature. You can later hide the time
signature, for example, if you are writing music with an irregular meter and you require barlines
only to group material together, but not to imply any sense of meter.

RELATED LINKS
Input methods for time signatures on page 190
Hiding/Showing time signatures on page 996

Changing the width of empty bars
You can change the width of empty bars individually in Engrave mode.

PROCEDURE

1. In the Engrave toolbox, activate Note Spacing.

2. Select a square handle at the rhythmic position of a barline at the start/end of an empty
bar whose width you want to change.

3. Adjust the spacing in any of the following ways:

● Press Alt-Right Arrow to increase the space to the left of the selected handle.

● Press Alt-Left Arrow to decrease the space to the left of the selected handle.
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TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

RESULT
The width of the empty bar is changed.
For example, if you select the handle of the barline on the right of a bar and nudge the handle to
the left, the bar appears narrower. If you select the barline on the right of a bar and nudge the
handle to the right, the bar appears wider.

RELATED LINKS
Note spacing on page 381
Hiding/Showing bar rests in empty bars on page 864
Hiding/Showing multi-bar rests on page 865

Splits in bars
You can split bars rhythmically by changing the number of beats in each bar. You can split bars
visually across systems or frame breaks, which might be required in music with an irregular
meter or in passages of polymeter.

Splitting bars by inputting new time signatures

You can split bars into two or more bars by changing the time signature. New time signatures
apply until the next existing time signature or the end of the flow, whichever comes first.

If the new time signature does not fit completely into the given space, for example, if you wanted
to replace two 4/4 bars (eight quarter notes) with either two 3/4 bars or three 3/4 bars (either six
or nine quarter notes), then Dorico Pro does not override your existing time signature. Instead,
the final bar is made shorter.

For example, replacing a 4/4 time signature with a 3/4 time signature two bars before an existing
time signature creates two 3/4 bars and the equivalent of a 2/4 bar, as shown in this example.

However, in Insert mode, Dorico Pro inserts time at the end of the final bar of the new time
signature to make sure the final bar is the correct length. For example, in the same scenario as
above but with Insert mode activated, two 4/4 bars become three 3/4 bars, with the extra beat
required to fill the third 3/4 bar added at the end of the phrase.

Splitting bars by inputting new barlines

You can also split bars by inputting new barlines that are not normal (single) barlines anywhere
within a bar without affecting the time signature.

However, inputting a normal (single) barline anywhere within an existing bar resets the pattern
of the time signature from that point onwards.

For example, selecting the third quarter note (crotchet) in a 4/4 bar and inserting a new barline
causes a new 4/4 bar to start from the added barline. This leaves the equivalent of a 2/4 bar
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without a time signature to the left of the barline, but the bars to the right of the added barline
are in 4/4 and continue to be in 4/4 until the next time signature or the end of the flow,
whichever comes first.

After a normal (single) barline is added, a signpost appears to show how it affects the time
signature.

Two 4/4 bars with quarter notes Adding a normal barline halfway through the first
4/4 bar restarts the time signature from that point.

RELATED LINKS
Input methods for time signatures on page 190
Input methods for bars and barlines on page 201
Inserting system breaks on page 359
Inserting frame breaks on page 357
Inputting notes in Insert mode on page 153

Combining bars
You can combine two or more bars into one, longer bar by deleting the barline between them.

PROCEDURE

1. In Write mode, select the barline you want to delete.

2. Press Backspace or Delete.

RESULT
The bars on either side of the deleted barline combine into one bar. If required, the notes inside
are automatically re-beamed appropriately.

NOTE

Deleting a barline does not automatically change the time signature. To avoid confusion, we
recommend that you input a new time signature to reflect the new rhythmic duration of the bar.

RELATED LINKS
Deleting barlines on page 513
Input methods for time signatures on page 190
Hiding/Showing multi-bar rests on page 865
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Barlines are vertical lines that cross staves in order to show how music is divided into bars,
according to the time signature.

There are a number of different types of barlines that are used in different contexts:

Normal (Single)
A standard single barline that spans the entire height of the staff. For single-line
staves, the barline extends one space above and below the staff line by default.

Double
A double barline consists of two lines, both the width of a single barline, positioned
half a space apart by default. It is often used to denote significant changes in the
music, or to mark the placement of rehearsal marks, key signature changes, and
tempo changes.

Triple
A triple barline consists of three lines, all the width of a single barline, positioned half
a space apart by default. It is sometimes used in musicological analysis to demarcate
structural units larger than a single bar.

Final
A final barline consists of two lines: one of normal width, the other thick. It marks
where the music ends.

Dashed
A dashed barline has the same thickness as a normal barline, but has gaps within it
to give it a dashed appearance. It is used to subdivide bars to make complex time
signatures easier to read, and to differentiate editorial barlines from ones originally
in the manuscript.

Barlines
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Tick
A tick barline is a short line that spans only the top line of the staff. It is useful when
notating plainsong, in which context it denotes a breath or short gap between
phrases, or other music with an unusual metrical structure.

Short
A short barline spans the middle of the staff, which on a five-line staff is between the
second and fourth lines. On staves with fewer than fives lines, the short barline is
scaled proportionally. It is useful when notating plainsong, in which context it
denotes a longer gap between phrases than a tick barline.

Thick
A thick barline is half a space wide by default, so it is noticeably thicker than a normal
barline. This gives it a greater visual impact.

Start repeat
A start repeat line consists of a thick barline, followed by a normal barline, followed
by one of the following arrangements of dots:

● Two dots, one each in the middle two spaces of a five-line staff

● Four dots, one each in all four spaces of a five-line staff

It shows the start of a repeated section. It is used alongside end repeat lines, which
show the end of a repeated section.

End repeat
An end repeat line is the mirror of a start repeat line, so it consists of either two or
four dots, followed by a normal barline, followed by a thick barline. It shows the end
of a repeated section. It is used alongside start repeat lines, which show the start of a
repeated section.

End/Start repeat
This line combines the start repeat and end repeat barlines, with either two single
barlines with a single shared thick barline in the middle, or two thick barlines and no
single barlines. On either side, there are either two or four repeat dots. It is used
when a repeated section is immediately followed by another, separate repeated
section.

Barlines
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RELATED LINKS
Input methods for bars and barlines on page 201
Repeats in playback on page 436

Project-wide engraving options for barlines
You can find options for the project-wide appearance of barlines on the Barlines page in
Engrave > Engraving Options.

The options on the Barlines page allow you to change the appearance and thickness of barlines,
and which barlines are used in different contexts. For example, you can change the default
appearance of repeat barlines, changing the default barline shown before codas, and whether
barlines join vocal staves and ossia staves.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299
Barline spacing on page 513
Barlines on ossia staves on page 922
Changing the barline shown before codas on page 834

Per-flow notation options for barlines
You can find options for the per-flow the appearance of barlines on the Barlines page in
Notation Options.

These options allow you to change which barline is shown by default at the end of each flow, and
whether barlines join all staves at the end of each system and at the end of the final system in a
flow.

You can open Notation Options in any of the following ways:

● Press Ctrl/Cmd-Shift-N in any mode.

● Choose Write > Notation Options in Write mode or Setup > Notation Options in Setup
mode.

● Click Notation Options in the Flows panel in Setup mode.

You can then click Barlines in the page list.

Changing the default barline at the end of flows
You can choose which type of barline is placed automatically at the end of each flow.

PROCEDURE

1. Press Ctrl/Cmd-Shift-N to open Notation Options.

2. In the Flows list, select the flows whose default end barline you want to change.
By default, only the current flow is selected when you open the dialog.

Barlines
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3. Click Barlines in the page list.

4. Choose one of the following options for Automatic barline at end of flow:

● Final barline

● Double barline

● Normal barline

● Dashed barline

● Thick barline

● No barline

RESULT
The default final barline at the end of the selected flows is changed.

TIP

You can override individual final barlines by changing their type, but you cannot delete individual
final barlines.

RELATED LINKS
Input methods for bars and barlines on page 201

Hiding/Showing systemic barlines on single-staff systems
By default, systemic barlines are shown at the start of systems containing two or more staves
and hidden on single-staff systems. You can hide/show systemic barlines on single-staff systems
after the first system.

Showing systemic barlines on single-staff systems is a convention used in hand-copied lead
sheets, usually in combination with no clefs being shown.

PROCEDURE

1. Press Ctrl/Cmd-Shift-N to open Notation Options.

2. In the Flows list, select the flows in which you want to hide/show systemic barlines after
the first system.
By default, only the current flow is selected when you open the dialog.

3. Click Barlines in the page list.

4. Choose one of the following options for Barline at start of systems following first
system:

● Show for one or more staves

● Show for two or more staves

5. Click Apply, then Close.

Changing the barline shown at key signature changes
You can change the default barline shown at all key signature changes that occur at barlines
project-wide. By default, Dorico Pro shows double barlines at key signature changes.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Barlines in the page list.

Barlines
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3. In the Key Signatures section, choose one of the following options for Changes of key
signature at the start of the bar:

● Draw double barline

● Draw single barline

4. Click Apply, then Close.

RESULT
The barline shown at all key signature changes that occur at the start of bars is changed project-
wide.

Deleting barlines
You can delete barlines without affecting the rhythmic positions of notes.

PROCEDURE

1. In Write mode, select the barlines you want to delete.

2. Press Backspace or Delete.

RESULT
The barline is deleted. The two bars either side of the barline combine into one bar, containing
the same number of beats but without changing the time signature.
To avoid confusion, you can add a new time signature to reflect the new rhythmic duration of the
bar.

RELATED LINKS
Input methods for time signatures on page 190

Barline spacing
You can find options for the default spacing of all barlines project-wide on the Spacing Gaps
page in Engrave > Engraving Options.

On the Spacing Gaps page in Engraving Options, you can change project-wide values for the
spaces before and after barlines, and between barlines and other staff objects, such as clefs,
time signatures, or key signatures.

The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.

RELATED LINKS
Engraving Options dialog on page 299
Project-wide engraving options for barlines on page 511

Moving barlines rhythmically
You can only move barlines to new rhythmic positions after they have been input by inputting
new barlines at the positions you want.

PROCEDURE

1. In Write mode, input a new barline of your preferred type at the position you want.

2. Delete the barline from the old position.
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NOTE

You can complete these steps in any order. However, deleting barlines can cause note and
beam groupings to change. If you are choosing a new barline position based on particular
phrases, this might make it harder to find the new position you want.

RELATED LINKS
Input methods for bars and barlines on page 201

Moving barlines graphically
You can adjust the spacing between barlines and neighboring notes, time signatures, key
signatures, or rests.

PROCEDURE

1. In the Engrave toolbox, activate Note Spacing.

2. Select a note spacing handle at the rhythmic position of the barline.

3. Move the handle in any of the following ways:

● Press Alt-Right Arrow to move it to the right.

● Press Alt-Left Arrow to move it to the left.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag it to the right/left.

NOTE

You cannot move note spacing handles using the mouse. You can only move them using
the keyboard.

RESULT
The spacing to the right/left of the barline is increased/decreased.

EXAMPLE

The new position of the barline after decreasing the space to its left

Barlines
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Barlines across staff groups
In order to make it easier to find a particular instrument within a score, barlines can extend
across instrumental and staff groups.

Barlines across default staff groups

When a barline only appears on individual staves, it is much harder to locate individual lines at a
glance. However, when barlines continue across instrumental groups in the score, instrument
families are shown as blocks, which makes finding an instrument much easier.

Barlines on individual staves Barlines across instrumental groups

Barlines extend across staff groups automatically when they are joined by a bracket. Which
staves are included in a bracket depends on the instrumentation and context, but usually staves
for instruments from the same family, such as woodwind or strings, are bracketed together.

By default, Dorico Pro brackets staves according to their instrument family. This means that in
projects with only a few instruments, barlines do not extend across the whole ensemble, because
all the instruments are from different families.

Custom barline groups

You can create custom barline joins and bracket groups by manually arranging your players into
groups. If one or more players included in your group were previously in another group, any
remaining instruments in their previous group remain grouped.

You can put a single player in its own player group so they appear separately, for example, to
separate the soloist from the remainder of the ensemble in a concerto.

You can also input custom barline joins to determine the staves across which individual barlines
extend.

RELATED LINKS
Changing bracket grouping according to ensemble type on page 559
Brackets according to project template categories on page 60
Adding groups of players on page 115
Adding players to groups on page 116
Deleting player groups on page 116

Barlines
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Showing barlines across all staves at time signature changes
You can join all staves with a barline at time signature changes in individual layouts, regardless of
your bracketing style.

PROCEDURE

1. Select the time signature changes where you want to join all staves with a barline. You can
do this in Write mode and Engrave mode.

2. In the Properties panel, activate Barline joins all staves in the Time Signatures group.

RESULT
All staves in the layout currently open in the music area are joined by a barline at the selected
time signature changes.

Inputting custom barline joins
You can input custom barline joins at any position that change which staves are joined with
barlines.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

PROCEDURE

1. In Engrave mode, select an item on the top staff you want to join with a barline, at the
start of the system from which you want this change to apply.

2. Ctrl/Cmd-click an item on the bottom staff you want to join with a barline.

3. In the Formatting panel, click Change barline joins in the Bracketing group.

RESULT
All staves between and including the staves on which you selected items are joined by a barline
until the next existing bracket and barline change or the end of the flow, whichever comes first. A
signpost appears at the start of the system in which you selected items.
If necessary, any existing barline joins are adjusted to accommodate the new barline join.

NOTE

You cannot move bracket and barline change signposts, as they are intended to apply to system
start positions. However, they can appear partway through systems if, for example, you move
system breaks. When a bracket and barline change signpost is positioned partway through a
system, the corresponding change only takes effect from the start of the next system.

Barlines
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EXAMPLE

Divisi cello staves with default staff grouping Divisi cello staves with separate barline joins across
each instrument

RELATED LINKS
Signposts on page 281
Resetting bracket and barline changes on page 562
Deleting bracket and barline changes on page 563

Deleting barline joins individually
You can delete individual barline joins independently of other barline joins and bracket/brace
grouping changes at the same rhythmic position, which splits selected barline joins into showing
separate barlines on each staff.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

PROCEDURE

1. In Engrave mode, select the barline joins you want to delete.

2. Press Backspace or Delete.

RELATED LINKS
Deleting bracket and barline changes on page 563
Resetting bracket and barline changes on page 562

Lengthening/Shortening custom barline joins
You can lengthen/shorten custom barline joins vertically to change the staves across which they
span, for example, if you added a new player below a barline join and want to extend the barline
join to that staff.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.
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PROCEDURE

1. In Engrave mode, select a handle at either the top or bottom of each barline join you want
to lengthen/shorten.

TIP

You only need to select a handle on one barline join for each bracket and barline change,
as they apply from their signpost until the next existing change or the end of the flow,
whichever comes first.

2. Move the handles in any of the following ways:

● Press Alt-Up Arrow to move them to the staff above.

● Press Alt-Down Arrow to move them to the staff below.

RESULT
The selected barline joins are lengthened/shortened to staves above/below. This affects the
staves included in the barline joins on all systems to which the corresponding bracket and barline
changes apply.

NOTE

Only one barline join can exist on each staff, they cannot overlap. If any part of a selected barline
join collides with another barline join when it is lengthened/shortened, the other barline join is
shortened to accommodate this.

You can undo this action, which restores the previous length of any shortened barline joins.

RELATED LINKS
Deleting bracket and barline changes on page 563
Resetting bracket and barline changes on page 562
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Bar numbers provide a crucial reference point for music that has multiple players, and make the
chronological sequence of the music clear. They indicate where players are in the piece, which
allows them to co-ordinate themselves easily in rehearsals and concerts.

Bar numbers can also be useful when preparing parts and scores, as you can use bar numbers
and rehearsal marks to help you quickly compare a part to the score and check it is correct.

In Dorico Pro, bar numbers appear automatically, following the most common practice of
showing a bar number at the start of each system in scores and parts by default.

However, sometimes it is useful to show a bar number for every bar, which is frequently done for
film music scores. You can also show bar numbers at a regular interval, such as every five bars,
but this can be misleading as it can give the impression that those bars are significant,
particularly if bar numbers are shown within an enclosure.

RELATED LINKS
Changing the bar number frequency on page 520
Changing the bar number enclosure type on page 522

Appearance of bar numbers
You can change different aspects of the appearance, frequency, and position of bar numbers in
three places in Dorico Pro and in each layout independently.

Different aspects of the appearance of bar numbers are controlled in different places, which are:

● The Bar Numbers page in Setup > Layout Options for aspects such as the bar number
frequency and enclosure type.

● The Bar Numbers page in Engrave > Engraving Options for aspects such as the
dimensions of enclosures.

● The Paragraph Styles dialog for the formatting of the fonts used for bar numbers.

Layout Options

On the Bar Numbers page in Setup > Layout Options, you can change the following aspects of
the appearance and position of bar numbers:

● Paragraph style used for bar numbers in the selected layouts

● Bar number frequency

● Placement above/below the staff

● Distance from the staff and from other objects

● Horizontal position

● Enclosure type

● Hiding/Showing bar numbers at rehearsal marks

● Hiding/Showing the first bar number when bar numbers are shown every bar

Bar numbers

519
Dorico 2.2.20



You can change options for bar numbers for each instrument layout and full score layouts
independently of each other within the dialog. For example, you can use different paragraph
styles for bar numbers in different layouts, and show bar numbers every bar in full score layouts
but only at the start of each system in part layouts.

Engraving Options

On the Bar Numbers page in Engrave > Engraving Options you can choose whether repeated
sections affect bar numbers or not, change the case of letters in subordinate bar numbers, and
change the thickness and padding values for bar number enclosures. This affects all layouts that
show bar numbers in enclosures.

Paragraph Styles dialog

Bar numbers use paragraph styles to control the appearance of their fonts and justification, so
that you can use different paragraph styles in full score layouts compared to part layouts. For
example, in large orchestral scores it is often necessary to make bar numbers much larger than
required in the part layouts, so that they are still legible even when the staff size is very small. It
is also common to use a bold plain font for bar numbers in the full score but italic bar numbers in
part layouts.

You can change different aspects of the default bar number paragraph styles, such as their font
size, in the Paragraph Styles dialog. These changes affect all layouts, but you can make as many
paragraph styles as you like, for example, if you want bar numbers in some part layouts to
appear bold but use italics in other part layouts.

● You can open the Paragraph Styles dialog in Engrave mode by choosing Engrave >
Paragraph Styles.

RELATED LINKS
Changing the bar number enclosure type on page 522
Layout Options dialog on page 90
Engraving Options dialog on page 299
Paragraph Styles dialog on page 366

Changing the bar number frequency
You can change how frequently bar numbers appear in each layout independently of other
layouts. For example, you can have bar numbers appear with different frequencies in full score
layouts compared to individual part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the bar number
frequency.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Bar Numbers in the page list.

4. In the Frequency subsection, choose one of the following options for Show bar numbers:

● Every system

● Every n bars

● Every bar

● None

5. Optional: If you chose Every n bars, set a custom frequency for bar numbers by changing
the value for Interval.

Bar numbers
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6. Click Apply, then Close.

RESULT
The frequency of bar numbers in the selected layouts is changed.
Changing the Interval value changes how frequently bar numbers are shown. For example,
setting an interval value of 10 means that bar numbers are shown every tenth bar.

RELATED LINKS
Appearance of bar numbers on page 519

Changing the bar number paragraph styles
You can change the formatting of the paragraph styles used for bar numbers. By default, there is
a paragraph style for bar numbers in full score layouts and another for bar numbers in part
layouts.

PROCEDURE

1. In Engrave mode, choose Engrave > Paragraph Styles to open the Paragraph Styles
dialog.

2. In the paragraph style list, select one of the following bar number paragraph styles:

● Bar numbers (parts)

● Bar numbers (score)

3. Optional: Select one of the available styles from the Parent menu.
If you select a parent style, an activated switch is shown beside all the options that are
different in the selected paragraph style compared to its parent style.

4. Activate and change the options you want for the selected paragraph style.

5. Click OK to save your changes and close the dialog.

RESULT
The selected bar number paragraph style is changed. This affects the appearance of bar
numbers in all layouts that use the selected style.

TIP

You can also make additional bar number paragraph styles, as each layout can use a different
paragraph style for bar numbers.

RELATED LINKS
Appearance of bar numbers on page 519
Paragraph Styles dialog on page 366

Changing the bar number paragraph style used in layouts
You can choose which paragraph style is used for bar numbers in each layout independently. By
default, bar numbers in full score layouts use one paragraph style and bar numbers in part
layouts use a different paragraph style.

PREREQUISITE
If you want to use a custom paragraph style for bar numbers in some layouts, you have already
created it in the Paragraph Styles dialog.

Bar numbers
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PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the paragraph style
used for bar numbers.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Bar Numbers in the page list.

4. In the Appearance subsection, select a paragraph style from the Paragraph style menu.

5. Click Apply, then Close.

RESULT
The selected paragraph style is used for all bar numbers in the selected layouts.

RELATED LINKS
Paragraph Styles dialog on page 366

Changing the bar number enclosure type
If you want bar numbers to stand out, you can enclose them in a rectangular or circular
enclosure. You can change the bar number enclosure type in each layout independently of other
layouts.

For example, you can have bar numbers appear with rectangle enclosures in full score layouts
but with no enclosures in part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the bar number
enclosure type.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Bar Numbers in the page list.

4. In the Appearance subsection, choose one of the following options for Enclosure type:

● None

● Rectangle

● Circle

5. Click Apply, then Close.

RESULT
Bar numbers in the selected layouts are shown within your selected enclosure type. The size of
the enclosure is relative to the font size of the bar numbers, but the size and shape of the
enclosure are also determined by your padding values.
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EXAMPLE

Bar number with no enclosure Bar number with a rectangle
enclosure

Bar number with a circle enclosure

RELATED LINKS
Layout Options dialog on page 90

Bar number enclosure size and padding values
In the Enclosure subsection of the Bar Numbers page in Engrave > Engraving Options, there
are a number of options to control the shape and size of bar number enclosures.

Rectangle bar number enclosure

The figure shows a rectangle bar number enclosure with default settings. The minimum height
and minimum width are both 2 spaces, horizontal padding is half a space, and minimum bottom
and minimum top padding are both 1/8 of a space.

Adjusting the minimum values can help make bar number enclosures more consistent project-
wide, as the default values can allow their size to vary significantly, depending on the size and
shape of the bar number inside. This might make a narrow bar number less obvious to a
conductor. Increasing Minimum width to reduce the difference in size can create a more
consistent visual effect.

Bar numbers with rectangle enclosures, default
minimum width

Bar numbers with rectangle enclosures, minimum
width increased to 5

Minimum width
Sets a minimum value for the width of enclosures. In this example, the value was
increased from 2 spaces to 6 spaces.
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Minimum height
Sets a minimum value for the height of enclosures. In this example, the value was
increased from 2 spaces to 6 spaces.

Minimum horizontal padding
Sets a minimum value for the distance between the two sides of the enclosure and
the bar number within it. In this example, the value was increased from 1/2 a space
to 4 spaces.

Minimum bottom padding
Sets a minimum value for the distance between the bottom line of the enclosure and
the bar number within it. In this example, the value was increased from 1/8 of a
space to 2 spaces.

Minimum top padding
Sets a minimum value for the distance between the top line of the enclosure and the
bar number within it. In this example, the value was increased from 1/8 of a space to
2 spaces.

Circle bar number enclosure

The figure shows a circle bar number enclosure with default settings. The minimum diameter is 2
spaces, and the minimum padding is 1/6 of a space.

Minimum diameter
Sets a minimum value for the diameter of the enclosure. In this example, the value
was increased from 2 spaces to 8 spaces.
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Minimum padding
Sets a minimum value for the distance between the enclosure line and the bar
number within it. In this example, the value was increased from 1/6 of a space to 1
space.

All enclosures

Enclosure line thickness
Sets the thickness of enclosure lines for both rectangle and circle enclosure types.
The default is 1/8 of a space. The examples have a thickness of 1/2 a space.

NOTE

Changing the Enclosure line thickness changes the thickness of bar number
enclosures in all layouts in the project. Changing any padding values for rectangle
enclosures affects all layouts with rectangle enclosures, and changing any padding
values for circle enclosures affects all layouts with circle enclosures.

Bar numbers in parts
You can show bar numbers differently in each layout, including using different font sizes, fonts,
frequency, and enclosure types. Parts often require differently formatted bar numbers compared
to full score layouts.

By default in Dorico Pro, there are two paragraph styles for bar numbers: one for full score
layouts and one for part layouts, but initially both paragraph styles have the same settings. You
can change the settings of these paragraph styles independently, for example, if you want to set
the paragraph style for bar numbers in part layouts to use a bold italic font but set the paragraph
style for bar numbers in full score layouts to use a plain font with a much larger font size.

In addition to changing the appearance of bar number fonts, you can change the following
aspects of the appearance and position of bar numbers independently in each layout:

● Bar number frequency

● Minimum distance from staff and other objects

● Horizontal position

● Enclosure type

For example, you can show bar numbers every bar in full score layouts but only at the start of
each system in part layouts.

NOTE

Changing values for enclosure sizes, padding values, and line thickness changes the
corresponding aspect of bar number enclosures in all layouts in the project.
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RELATED LINKS
Changing the bar number paragraph style used in layouts on page 521
Changing the bar number paragraph styles on page 521
Changing the bar number frequency on page 520
Changing the distance between bar numbers and the staff/other objects on page 527

Hiding/Showing bar number ranges on multi-bar rests
You can hide/show bar number ranges on multi-bar rests, for example, to make it clear in part
layouts the bars in which players do not play. Multi-bar rests can include bar repeat regions, if
you have chosen to consolidate bar repeat regions as well as empty bars into multi-bar rests.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show bar number ranges
on multi-bar rests.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Bar Numbers in the page list.

4. In the Showing and Hiding subsection, activate/deactivate Show ranges of bar numbers
under multi-bar rests and consolidated bar repeats.

5. Click Apply, then Close.

RESULT
Bar number ranges are shown beneath multi-bar rests and consolidated bar repeats in the
selected layouts when the option is activated, and hidden when it is deactivated.

TIP

You can change the bar number range separator and the default distance between bar numbers
ranges and the staff in the Multi-bar Rests section of the Rests page in Engrave > Engraving
Options.

RELATED LINKS
Hiding/Showing multi-bar rests on page 865

Hiding/Showing guide bar numbers
You can hide/show guide bar numbers on every bar and above every system in page view and
galley view independently, for example, to make it easier to check the bar number in scores with
many staves. Guide bar numbers are not printed.

PROCEDURE

● Hide/Show guide bar numbers in any of the following ways:

● To hide/show guide bar numbers in page view, choose View > Bar Numbers > Page
View.

● To hide/show guide bar numbers in galley view, choose View > Bar Numbers >
Galley View.
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RESULT
Guide bar numbers are shown for every bar and above every staff in the corresponding view type
when a tick appears beside the corresponding option in the menu, and hidden when no tick
appears.

Positions of bar numbers
Bar numbers are typically shown at the start of each system, above the staff, and aligned with
the initial barline. You can change the default positions and frequency of bar numbers in each
layout independently on the Bar Numbers page in Layout Options, and you can move
individual bar numbers in Engrave mode.

For example, you might want to show bar numbers every bar in full score layouts but only at the
start of each system in part layouts.

NOTE

Bar numbers can only be shown at one position per system. You cannot show bar numbers
above/below multiple staves in a single system.

RELATED LINKS
Changing the placement of bar numbers relative to the staff on page 528

Changing the horizontal position of bar numbers
You can change the horizontal position of bar numbers in each layout independently. For
example, you can have bar numbers centered in the middle of bars in full score layouts but
centered on barlines in part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the horizontal position
of bar numbers.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Bar Numbers in the page list.

4. In the Horizontal Position subsection, choose one of the following options for Horizontal
position:

● Centered on barline

● Centered on bar

5. Click Apply, then Close.

RESULT
Centered on barline shows bar numbers above barlines, at the top left of the bar.
Centered on bar shows bar numbers above the staff, in the middle of the bar.

Changing the distance between bar numbers and the staff/other
objects

You can change the minimum distance between bar numbers and the staff, and set a separate
value for the distance between bar numbers and other objects, in each layout independently. For

Bar numbers
Positions of bar numbers 

527
Dorico 2.2.20



example, you can position bar numbers further from the staff/other objects in full score layouts
than in part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the minimum distance
of bar numbers from the staff.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Bar Numbers in the page list.

4. Optional: In the Placement subsection, change the value for Minimum distance from
staff.
The default value is 2 spaces.

5. Optional: In the Placement subsection, change the value for Minimum distance from
other objects.
The default value is 3/4 of a space.

6. Click Apply, then Close.

RESULT
If you increase the values, bar numbers are positioned further away from the staff and/or other
objects, either above or below the staff depending on your setting for Placement relative to
staff. If you decrease the values, bar numbers are positioned closer to the staff and/or other
objects.

NOTE

These options affect the minimum distance between bar numbers and the staff and other
objects, so bar numbers might be positioned further away than this to avoid collisions.

Changing the placement of bar numbers relative to the staff
You can change the side of the staff on which bar numbers appear for each layout
independently. For example, bar numbers can appear below the staff in full score layouts but
above the staff in individual part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the bar number
placement.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Bar Numbers in the page list.

4. In the Placement subsection, choose one of the following options for Placement relative
to staff:

● Above

● Below

5. Click Apply, then Close.
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RESULT
The placement of bar numbers relative to the staff is changed in the selected layouts.

Moving bar numbers graphically
You can move individual bar numbers graphically without changing the rhythmic positions to
which they apply.

PROCEDURE

1. In Engrave mode, select the bar numbers you want to move.

2. Move the bar numbers in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

RESULT
The selected bar numbers are moved graphically.

TIP

The following properties in the Time Signatures group of the Properties panel are activated
automatically when you move bar numbers in the corresponding directions:

● Bar number X moves bar numbers horizontally.

● Bar number Y moves bar numbers vertically.

You can also use these properties to move bar numbers graphically by changing the values in the
value fields.

Deactivating the properties resets the selected bar numbers to their default positions.

RELATED LINKS
Adding bar number changes on page 531
Changing the horizontal position of bar numbers on page 527
Changing the distance between bar numbers and the staff/other objects on page 527

Hiding bar numbers at time signatures shown at system object
positions

You can choose to hide bar numbers at the same rhythmic position as time signatures shown at
system object positions, as the resulting collision can be difficult to resolve in a visually clear way
when bar numbers are centered on barlines.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide bar numbers at time
signatures shown at system object positions.
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By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Bar Numbers in the page list.

4. In the Showing and Hiding subsection, activate/deactivate Show bar numbers at time
signatures at system object positions.

5. Click Apply, then Close.

RESULT
Bar numbers are shown at time signatures shown at system object positions when the option is
activated, and hidden when it is deactivated.

EXAMPLE

Bar numbers shown at time signatures at system
object positions

Bar numbers hidden at time signatures at system
object positions

RELATED LINKS
Time signatures on page 981
Large time signatures on page 986

Bar number changes
Bar numbers follow a continuous sequence, with each bar having a unique bar number that
continues from the previous bar number. However, you can make manual changes to the bar
number sequence, including changing to a subordinate sequence.

In Dorico Pro, you can make the following types of changes to bar number sequences using the
Insert Bar Number Change dialog:

Primary
Adds a change to the main bar number sequence, which the bars in your project
follow in a continuous sequence in each flow separately by default.

Subordinate
Adds a secondary bar number sequence that uses letters rather than numbers to
indicate the sequence. This can be useful in situations where a new version of a piece
has been created with more bars inserted, but the original bar numbers are
required.

Don’t Include
Excludes the selected bar from the current bar number sequence. If bar numbers are
shown every bar, no bar number is shown in bars in which you have chosen Don’t
Include.

Continue Primary
Returns the bar number sequence to the Primary sequence without counting
intervening bars, for example, after a section of bars following the Subordinate bar
number sequence.
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RELATED LINKS
Subordinate bar numbers on page 532

Adding bar number changes
You can manually add bar number changes to bar number sequences, for example, if you want
bar numbers in the second flow in your project to appear to continue the sequence from the first
flow, rather than start again from bar one.

PROCEDURE

1. In Write mode or Engrave mode, select one of the following:

● An item in the bar from the beginning of which you want to change the bar number
sequence.

● An existing bar number or barline from which you want to change the bar number
sequence.

2. Choose Edit > Bar Numbers > Add Bar Number Change to open the Insert Bar Number
Change dialog. You can also choose this option from the context menu.

3. Choose one of the following options for Type:

● Primary

● Subordinate

● Don’t Include

● Continue Primary

4. Optional: If you chose Primary or Subordinate, change the bar number where you want
the bar number sequence change to start by changing the value in the corresponding
value field.

5. Click OK to save your changes and close the dialog.

RESULT
The bar number sequence changes, starting from the beginning of the bar in which you selected
an item, or from the position of a selected bar number or barline.
This affects the corresponding bar number sequence from the changed bar number until the
next bar number change, or until the end of the flow.

Deleting bar number changes
You can delete any bar number changes you have added.

PROCEDURE

1. In Write mode, select the bar number changes you want to delete.

2. Press Backspace or Delete.

RESULT
The bar number changes are deleted. Subsequent bars follow the previous bar number
sequence until the next bar number change, or until the end of the flow.
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Subordinate bar numbers
Subordinate bar numbers are useful for numbering repeat endings, and for situations when the
music is being altered, but the original bar numbers cannot be changed.

For example, you can use subordinate bar numbers to show where music has been added if a
previous, shorter version has already been rehearsed. In this situation, players have likely started
to associate certain parts of the piece with particular bar numbers, so if four bars need to be
added after bar 10, they would be numbered 10a to 10d, after which the bar number continues
from 11 exactly as it did before the new bars were added.

They might also be useful if you want different bar numbers for a repeat ending.

Subordinate bar numbers are shown with lower case letters by default, but you can present them
as either uppercase or lowercase letters.

Lowercase subordinate bar number Uppercase subordinate bar number

RELATED LINKS
Changing the appearance of subordinate bar numbers on page 533

Adding subordinate bar numbers
You can create a subordinate bar number sequence that is independent of your primary bar
number sequence. This can be useful if you want to insert new bars without changing the bar
numbers of existing subsequent bars.

PROCEDURE

1. In Write mode or Engrave mode, select one of the following:

● An item in the bar from the beginning of which you want subordinate bar numbers
to start.

● An existing bar number or barline from which you want subordinate bar numbers to
start.

2. Choose Edit > Bar Numbers > Add Bar Number Change to open the Insert Bar Number
Change dialog. You can also choose this option from the context menu.

3. Choose Subordinate for Type to activate the Subordinate value field.

4. Change the first letter in the subordinate bar number sequence by changing the value in
the Subordinate value field.
The corresponding alphabetical letter is shown to the right of the value field. For example,
entering 1 into the value field is shown as a, 2 appears as b, and so on.

5. Click OK to save your changes and close the dialog.

RESULT
The subordinate bar number sequence starts from the bar in which you selected an item, or from
the position of a selected bar number or barline. It has the same bar number as the bar
immediately before, but with subordinate alphabetical letters.
For example, if you start a subordinate bar number sequence from what was originally bar 5, the
sequence starts from 4a and continues until the next specified bar number change, or until the
end of the flow.
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Returning to the primary bar number sequence
You can specify the point where you want to return to the primary bar number sequence after a
section of subordinate bar numbers.

PROCEDURE

1. In Write mode or Engrave mode, select one of the following:

● An item in the bar from the beginning of which you want to return to the primary
bar number sequence.

● An existing bar number or barline from which you want to return to the primary bar
number sequence.

2. Choose Edit > Bar Numbers > Add Bar Number Change to open the Insert Bar Number
Change dialog. You can also choose this option from the context menu.

3. Choose Continue Primary for Type.
Text indicating the new bar number appears below the value fields for Primary and
Subordinate. For example, Primary sequence will continue from bar 5.

4. Click OK to save your changes and close the dialog.

RESULT
The primary bar number sequence resumes from the bar in which you selected an item, or from
the position of a selected bar number or barline.

TIP

You do not have to add subordinate bar number changes in chronological order. You can enter a
return to the primary bar number sequence first, before adding the subordinate bar number
sequence.

Changing the appearance of subordinate bar numbers
You can show subordinate bar numbers as either lowercase or uppercase letters.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Bar Numbers in the page list.

3. In the Sequence subsection, select how you want subordinate numbers to appear:

● Lower case (default)

● Upper case

Bar numbers and repeats
By default in Dorico Pro, repeats are not included in the bar number count. For example, if the
first ending ends in bar 10, the second ending starts in bar 11, even though the first section is
repeated and therefore more than ten bars have been played.

Including repeats in the bar number count, so that bar numbers reflect the total number of bars
played rather than the number of bars written on the page, can make music with multiple
playthroughs clearer, as you can refer to a specific bar number for each playthrough instead of,
for example, “bar eight the third time round”.
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Bar number for subsequent repeat shown in parentheses beside the initial bar number

In Dorico Pro, you can include repeats in the bar number count automatically; you do not have to
input bar number changes manually. This applies to any presentation of multiple playthroughs,
including repeat endings and repeat markers, such as D.C. al Coda.

Because it is important that all players refer to the same bar numbers, this affects all layouts
project-wide.

When you include repeats in the bar number count, multiple bar numbers apply to the same
notated bars. To reflect this, Dorico Pro shows the initial bar number as normal but adds bar
numbers for subsequent repeats to the right by default. You can change which playthroughs are
included in bar numbers, and the appearance of bar numbers for subsequent repeats, in each
layout independently. By default, they are shown in parentheses.

EXAMPLE

Bar numbers not counting repeats with only initial
bar numbers shown

Bar numbers counting repeats with bar numbers for
subsequent repeats shown alongside the initial bar
numbers

RELATED LINKS
Changing the appearance of bar numbers for subsequent repeats on page 535
Adding bar number changes on page 531

Including/Excluding repeats from the bar number count
You can choose to include/exclude repeats from the bar number count in all layouts project-wide.
By default, repeats are excluded from the bar number count.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Bar Numbers in the page list.

3. In the Repeats subsection, choose one of the following options for Bar numbering for
repeated sections:

● Count repeats

● Do not count repeats

4. Click Apply, then Close.

RESULT
Repeats are included in the bar repeat count when you choose Count repeats, and excluded
from the bar repeat count when you choose Do not count repeats.
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Changing which playthroughs are shown in bar numbers
In projects that contain repeats, you can change which playthroughs are shown in bar numbers
in each layout independently, for example, if some players want to see bar numbers for all
playthroughs in their parts but others only want to see the last repeat.

NOTE

This does not affect the overall bar number count, only which bar numbers are shown.

PREREQUISITE
Repeat sections are included in the bar number count.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change which playthroughs are
shown in bar numbers.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Bar Numbers in the page list.

4. In the Repeats subsection, choose one of the following options for Count repeats:

● All repeats

● First repeat only

● Last repeat only

5. Click Apply, then Close.

RESULT
The playthroughs shown in bar numbers in the selected layouts are changed.

EXAMPLE

Bar numbers with all repeats
shown

Bar numbers with first repeat only
shown

Bar numbers with last repeat only
shown

RELATED LINKS
Bar numbers and repeats on page 533

Changing the appearance of bar numbers for subsequent repeats
When the bar number count includes repeats, bar numbers for subsequent repeats are shown
beside the initial bar numbers. They are parenthesized by default, but you can change the prefix
and suffix of bar numbers for subsequent repeats in each layout independently.

PREREQUISITE
Repeat sections are included in the bar number count.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.
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2. In the Layouts list, select the layouts in which you want to change the appearance of bar
numbers for subsequent repeats.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Bar Numbers in the page list.

4. Optional: In the Repeats subsection, enter the prefix you want into the Prefix field.
This field starts with a space by default so there is a gap between the initial bar number
and the subsequent repeat bar number.

5. Optional: Enter the suffix you want into the Suffix field.

6. Click Apply, then Close.

RESULT
The appearance of bar numbers for subsequent repeats in the select layouts is changed. For
example, if you want multiple bar numbers for the same bar to be separated by pipes, enter |
into the Prefix field and nothing into the Suffix field.

EXAMPLE

Bar number for subsequent repeat with parentheses
for suffix/prefix

Bar number for subsequent repeat with pipe for
prefix
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A beam is a line that connects notes with tails to show rhythmic grouping, which varies according
to the metrical structure of the current time signature.

This way of grouping notes helps performers calculate quickly exactly how to play their given
rhythm and helps them follow both their part and, if applicable, the conductor.

If appropriate for the current meter and position in the bar, beams are automatically formed in
Dorico Pro when you input two or more adjacent notes or chords that are an eighth note
(quaver) or shorter in duration.

Multiple beam groups in a 6/8 time signature

There are many different accepted standards for how to present beams, so Dorico Pro offers a
number of customizing options. You can find these options on the Beams page in Engrave >
Engraving Options.

You can find options that control how notes are grouped into beam groups by default in each
flow on the Beam Grouping page in Write > Notation Options.

RELATED LINKS
Inputting notes on page 149
Per-flow changes to beam grouping defaults on page 539
Engraving Options dialog on page 299
Notation Options dialog on page 139

Beaming notes together manually
You can beam notes together manually, including notes across barlines as well as system/frame
breaks, for example, if you want to beam a phrase differently to how it is usually beamed in the
current time signature.

Beams by default stay within bars and systems, so to have beams cross barlines, system breaks,
and frame breaks, you must force the phrase to beam together.

PROCEDURE

1. Select the notes you want to beam together. You can do this in Write mode and Engrave
mode.

2. Choose Edit > Beaming > Beam Together. You can also choose this option from the
context menu.

Beaming
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RESULT
The selected notes are beamed together, even if they cross barlines or system/frame breaks.
If there are notes either side of the new beam group that were previously beamed to part or all
of your selection, they either beam together as separate beams, or appear unbeamed. This
depends on how many notes are left either side in the bar, and on the beam grouping settings
for the flow.

NOTE

Even if part of the beamed group previously had a centered beam, the new beam is not centered.

RELATED LINKS
Creating fanned beams on page 552

Unbeaming notes
You can separate all notes in a beamed group so that each note shows its own tail, for example,
when fast rhythms have syllabic text settings.

PROCEDURE

1. Select the notes you want to make unbeamed. You can do this in Write mode and Engrave
mode.

2. Choose Edit > Beaming > Make Unbeamed. You can also choose this option from the
context menu.

Changing the direction of partial beams
Dorico Pro automatically inputs a partial beam if one is required. You can change on which side
of stems individual partial beams appear.

PROCEDURE

1. Select the notes whose partial beam direction you want to change. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, activate Partial beam direction in the Beaming group.

3. Choose one of the following options:

● Left

● Right

RESULT
The partial beam appears on the corresponding side of the stem.

EXAMPLE

Partial beam direction Left Partial beam direction Right
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Beam groups
Notes are commonly beamed as regular groups to help reflect the meter. You can control how
notes are beamed in multiple ways in Dorico Pro.

● You can set beam grouping defaults in each flow in your project independently in
Notation Options.

● You can set beam groups by controlling subdivisions of time signatures.

● You can change beam groups individually using properties in the Properties panel, and by
choosing Edit > Beaming and selecting one of the available options.

RELATED LINKS
Beaming notes together manually on page 537

Per-flow changes to beam grouping defaults
You can find options to control the default beam grouping rules in each flow independently on
the Beam Grouping page in Notation Options.

Dorico Pro has sophisticated underlying rules for producing beam groupings that follow the
accepted conventions of music theory, including crossing the half-bar in time signatures like 4/4,
beaming all eighth notes together in 3/4, beam groups that include tuplets, and many other
situations.

There are alternative conventions for some of these rules, which you can change for each flow in
your project independently on the Beam Grouping page in Notation Options.

You can open Notation Options in any of the following ways:

● Press Ctrl/Cmd-Shift-N in any mode.

● Choose Write > Notation Options in Write mode or Setup > Notation Options in Setup
mode.

● Click Notation Options in the Flows panel in Setup mode.

Beams according to time signatures
Default beam groupings are determined by the time signature, which you can customize by
specifying the subdivision of beats within bars and by changing your per-flow beam grouping
settings in Notation Options.

Dorico Pro has default beaming settings for common time signatures, based on general
conventions and your chosen settings. For example, although the time signatures of 3/4 and 6/8
contain the same number of beats, they imply different meters and so are beamed differently. In
3/4, phrases of eighth notes are beamed together within each bar and phrases of other
durations are beamed in quarter notes (crotchets) by default, but in 6/8, phrases are beamed in
dotted quarter notes.

For situations where you want to control the beam grouping in more detail, you can input a
custom time signature with an explicit rhythmic subdivision. Dorico Pro then automatically
beams phrases according to this subdivision. For example, entering [7]/8 into the time signatures
popover means all seven eighth notes (quavers) are beamed together, whereas entering
[2+2+3]/8 subdivides the seven eighth notes into two, then two, then three.
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NOTE

The duration of beam groups in Dorico Pro depends on the beat grouping in the current time
signature and your per-flow beam grouping settings in Write > Notation Options.

RELATED LINKS
Note and rest grouping on page 553
Creating custom beat groupings for meters on page 554

Splitting beam groups
You can split beams and secondary beams into two beam groups at specific rhythmic positions.
You can also split secondary beams within beamed groups.

PROCEDURE

1. Select the noteheads to the right of where you want to split beams. You can do this in
Write mode and Engrave mode.

2. Split the beam or secondary beam in one of the following ways:

● Choose Edit > Beaming > Split Beam.

● Choose Edit > Beaming > Split Secondary Beam.

TIP

You can also choose these options from the context menu.

RESULT
Beams/Secondary beams are split to the left of each selected note, but the notes either side of
the split remain grouped if there are at least two beamed notes on each side that can be in a
beam group.

NOTE

To unbeam the entire selection and give all notes in the group individual tails, you can make all
notes unbeamed.

RELATED LINKS
Unbeaming notes on page 538

Resetting beam grouping
You can remove all changes made to the beam grouping of notes and chords. This can also be
useful if, for example, MusicXML files you have imported have incorrect beaming.

PROCEDURE

1. Select the notes/chords whose beaming you want to reset. You can do this in Write mode
and Engrave mode.

2. Choose Edit > Beaming > Reset Beaming. You can also choose this option from the
context menu.

RESULT
Beam grouping is reset to your default settings in Notation Options for the current flow and
time signature.
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Beam placement relative to the staff
You can change the staff-relative placement of the stems within beams, so that beams appear on
the other side of the staff to their default placement.

The default placement of beams relative to the staff is determined by the staff positions of the
notes within the beamed group.

This means that the note furthest from the middle line of the staff determines the placement of
the beam, although there are exceptions to this rule and other considerations that can influence
the placement of beams relative to the staff.

Changing the placement of beams relative to the staff involves changing the direction of the
stems in the beam. Therefore, Dorico Pro categorizes changing the placement of beams relative
to the staff as a stem change.

Changing the placement of beams relative to the staff
You can change on which side of the staff a beam appears by forcing the stem direction to
change.

PROCEDURE

1. Select at least one note in each of the beamed phrases whose staff-relative placement you
want to change. You can do this in Write mode and Engrave mode.

2. Force the stem direction of notes in the selected beams in any of the following ways:

● Choose Edit > Stem > Force Stem Up.

● Choose Edit > Stem > Force Stem Down.

TIP

You can also choose these options from the context menu.

RESULT
The beam appears on the side of the staff that corresponds to its forced stem direction.

Removing beam placement changes
You can undo changes to the placement of beams relative to the staff in order to remove the
stem direction change. This reverts selected beams to their default placement.

PROCEDURE

1. Select at least one note in each of the beamed phrases whose placement change relative
to the staff you want to remove. You can do this in Write mode and Engrave mode.

2. Choose Edit > Stem > Remove Forced Stem. You can also choose this option from the
context menu.

RESULT
The selected beams revert to their default staff-relative placement.

Beam slants
The slant of a beam controls how steeply the beam deviates from horizontal, according to the
pitches of the notes within the beamed group.

● When the last note of the phrase is higher than the first, the beam slants upwards.
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● When the last note of the phrase is lower than the first, the beam slants downwards.

● If the group makes a concave shape, where inner notes are closer to the beam than the
outer ones at either end of the beam, then the beaming is horizontal by default.
Beams are also horizontal if all the pitches are the same, or for certain patterns of
repeated pitches.

When a beam is drawn inside the staff, each end of the beam, meaning the end of the stem of
the note at either end of the beam, must be snapped to a staff line position. A beam line may sit
on a staff line, be centered on a staff line, or hang from a staff line. Ted Ross describes these
three positions as “sit”, “straddle”, and “hang” respectively in “Teach Yourself the Art and Practice
of Music Engraving”.

A phrase containing multiple different beam slants and directions

The amount by which a beam slants is typically determined by the interval between the first and
last note in the beamed group, provided the pattern of notes in the beam does not dictate a
horizontal beam instead. Smaller intervals require a shallower slant and larger intervals require a
steeper one.

However, the desired amount of slant is not the only factor that must be considered. The
innermost beam line should not come too close to the innermost notehead, and the beam itself,
if possible, should be positioned relative to the staff lines such that it does not form a wedge. A
wedge is a tiny triangle formed by the horizontal staff line, the vertical stem, and the angled line
of the slanted beam, which can be visually confusing.

Determination of the amount of slant for a beam is therefore a balancing act that must weigh up
several factors: the desired amount of slant, valid snapping positions for each end of the beam,
ensuring a minimum distance between the note closest to the beam and the innermost beam
line, and avoiding wedges where possible.

You can change the default settings for how beams appear project-wide.

● You can specify the minimum stem length for notes of different durations on the Notes
page in Engrave > Engraving Options.

● You can set ideal beam slants on the Beams page in Engrave > Engraving Options.

You can also change the beam slants of individual beams.

Changing beam slants
You can change the slants, or angles, of individual beams.

PROCEDURE

1. In Engrave mode, select the square handles on the beam corners of the beams whose
slants you want to change.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

You can also select the beams first, and then select the handles.

2. Move the handles in any of the following ways:
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● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

● Click and drag them upwards/downwards.

3. Optional: Repeat steps 1 and 2 to move the other end of the selected beams.

RESULT
The slants of the selected beams are changed

TIP

● You can also use Beam direction in the Beaming group of the Properties panel to change
the slant of beams. The property is available when you select noteheads within the beam
group, and its options all ensure that beam ends are positioned correctly relative to staff
lines.

● You can set ideal beam slants for all beams project-wide on the Beams page in Engrave >
Engraving Options.

Centered beams
Centered beams are positioned between high and low notes within the same beamed group,
typically drawn in the middle of the staff or between the staves of grand staff instruments.

Centered beams are also known as “kneed” or “elbowed” beams due to their often angular
shape.

When a beamed phrase spans a large pitch range, normal beams are often positioned very close
to some notes in the phrase but very far from other notes in the phrase, making some stems
very long. Having a centered beam in a phrase that spans a large pitch range can reduce the
maximum distance between noteheads and the beam, but can also place the beam within the
staff, which can obscure staff lines.

A phrase with high and low notes with default
beaming

The same phrase with high and low notes, but with a
centered beam

RELATED LINKS
Changing the placement of beams relative to the staff on page 541
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Creating centered beams
You can make beams appear in the middle of staves, with high notes above the beam and lower
notes below the beam.

NOTE

As this action requires changing the direction of some stems in order to appear correctly, it is
located in the Stem submenu rather than Beaming in the Edit menu.

PROCEDURE

1. Select at least one note in each of the beams you want to center. You can do this in Write
mode and Engrave mode.

2. Choose Edit > Stem > Force Centered Beam. You can also choose this option from the
context menu.

RESULT
Beams are centered between the notes in the selected beam groups.
If you select notes in multiple beams, each beam is centered separately. If you want to create a
single centered beam, you can beam the notes in those beam groups together. You can do this
both before and after centering the beams.

NOTE

Dorico Pro automatically angles the beam based on the shape of the phrase, but you can change
the angles or slants of beams manually.

RELATED LINKS
Beaming notes together manually on page 537
Changing beam slants on page 542

Removing centered beams
You can remove centered beams and revert beams to their default placements either above or
below the phrase.

PROCEDURE

1. Select at least one note in each centered beam that you want to revert to the default
placement. You can do this in Write mode and Engrave mode.

2. Choose Edit > Stem > Remove Centered Beam. You can also choose this option from the
context menu.

RESULT
The centered beams are removed.

Creating cross-staff beams
Cross-staff beams work in a similar way to normal beams, but allow a phrase that covers a wide
pitch range to be shown on two staves. You can create cross-staff beams by inputting all notes in
the phrase on one staff and crossing some notes to appear on another staff.

PREREQUISITE
You have input a phrase on one staff.

Beaming
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PROCEDURE

1. Select the notes you want to cross to another staff. You can do this in Write mode and
Engrave mode.

NOTE

You can only cross notes to other staves in multi-staff instruments.

2. Cross the notes to other staves in any of the following ways:

● To cross notes to the staff above, press N.

● To cross notes to the staff below, press M.

RESULT
The selected notes are shown on a different staff, with a cross-staff beam shown if the notes are
part of a beam group. This does not change the staff to which the notes belong.

NOTE

● When crossing notes to a staff that already contains notes, the stem direction of the
existing notes on the staff can change. This is due to how multiple voices at the same
rhythmic position are handled. Therefore, you may have to change the stem direction of
notes manually.

● You can reset notes to appear on their default staff by selecting them and choosing Edit >
Cross Staff > Reset to Original Staff.

● If you want notes to belong to a different staff, you can move them to another staff.

EXAMPLE

Notes shown on their original staves Cross-staff beams created by crossing some notes to
the other staff

RELATED LINKS
Moving notes to other staves on page 286
Notes crossed to staves with existing notes in other voices on page 1043
Note positions in multiple-voice contexts on page 1039
Changing the stem direction of notes on page 946
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Optical spacing for cross-staff beams
Normally, the human eye perceives the evenness of rhythmic spacing according to the distance
between noteheads. However, for cross-staff beams we consider the distance between stems,
rather than the noteheads, to be even/uneven.

Default spacing: The distance between noteheads is
optimized.

Optical spacing for cross-staff beaming: the distance
between stems is optimized.

Changing to optical cross-staff beam spacing
You can make the stems in cross-staff beams, rather than the noteheads, evenly spaced in each
layout independently.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts that you want to change to optical cross-staff beam
spacing.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Note Spacing in the page list.

4. Activate Use optical spacing for beams between staves.

5. Click Apply, then Close.

Cross-staff beam placement in multiple staves
When instruments have three or more staves, cross-staff beams can be placed in multiple ways.
For example, the beam can be placed between the top and the middle staves, and also between
the middle and bottom staves.

If a beam only crosses two staves, the cross-staff beam goes between those two staves.

Beaming
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A cross-staff beam across the upper two staves on
an instrument with three staves

A cross-staff beam across the lower two staves on an
instrument with three staves

If a beam group contains notes on all three staves, the placement of the beam depends on the
stem directions of the notes in each staff.

1 If all notes in the beam group are stem-up, the beam is placed above the top staff.

2 If all notes in the beam group are stem-down, the beam is placed below the bottom staff.

3 If notes are stem-down on the top staff and stem-up on the bottom two staves, the beam
is placed between the top and middle staves.

4 If notes are stem-down on the top two staves and stem-up on the bottom staff, the beam
is placed between the bottom and middle staves.

NOTE

If you have not specified stem directions, Dorico Pro might place the beam above/below the staff
into which the notes were originally input, even if the stem directions mean it should be placed
between other staves.

If you want the beam to be placed between specific staves, you can change the stem directions
of notes in the beam group.

RELATED LINKS
Changing the stem direction of notes on page 946
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Beam corners
Beam corners can occur when a change of stem direction within a beam is combined with a
break in the secondary beam group. This can be at the end of a subdivision or at a change in
rhythmic speed.

Beam corners do not follow accepted rules regarding the order and rhythmic meaning of
secondary beams, and can be confusing for the reader.

Dorico Pro avoids beam corners by analyzing the pitches and stems within a phrase, and
implementing stem directions that avoid a beam corner.

Secondary beams
Secondary beams are the lines that are added between the primary beam and the notehead as
the rhythmic division gets smaller.

The primary beam is the outermost beam line that joins all of the notes in the beamed group.
Depending on the durations of the notes in the beamed group, the primary beam may in fact be
two or more lines; that is, for notes of a 16th or shorter in duration.

Secondary beams are additional beam lines that join only some of the notes in the group,
creating subdivisions of the beam in order to make the metrical groupings of the beam clearer.

A phrase of 64th notes, with secondary beams subdivided to show 16th and eighth note groups

You can set per-flow options for how secondary beams appear on the Beam Grouping page in
Write > Notation Options.

Changing the number of beam lines in secondary beams
You can change the number of beam lines shown in secondary beams individually,
independently of your default setting for the current flow.

PROCEDURE

1. Select the notes to the right of where you want to change the number of secondary
beaming lines. You can do this in Write mode and Engrave mode.

2. Optional: If any of the notes you selected do not immediately follow existing splits in the
secondary beam, split the secondary beams in any of the following ways:

● In the Properties panel, activate Split secondary beam in the Beaming group.

NOTE

The Beaming group is only shown in the Properties panel if your selection only
contains notes.

Beaming
Beam corners 

548
Dorico 2.2.20



● Choose Edit > Beaming > Split Secondary Beam. You can also choose this option
from the context menu.

3. In the Properties panel, select the note value that corresponds to the number of beam
lines you want shown from the Split secondary beam menu.

RESULT
The number of beam lines shown immediately to the left of each selected note is changed.

NOTE

● The number of beam lines shown at a split in the secondary beam cannot be the same or
greater than the number of beam lines in the secondary beam. For example, if you split a
secondary beam containing 64th notes, the maximum number of beam lines shown at the
split in that beam is three, the equivalent of 32nd notes.

● You can change the default number of secondary beam lines shown in each flow
independently on the Beam Grouping page in Write > Notation Options.

Resetting changes to the number of secondary beam lines
You can reset any changes you have made to the number of beam lines shown in secondary
beams and return them to their default appearance.

PROCEDURE

1. Select the notes to the right of where you want to reset the number of secondary beam
lines. You can do this in Write mode and Engrave mode.

2. Reset your changes to the number of secondary beam lines in any of the following ways:

● In the Properties panel, deactivate Split secondary beam in the Beaming group.

● Choose Edit > Beaming > Reset Beaming. You can also choose this option from the
context menu.

Tuplets within beams
Tuplets that contain notes that produce beams are also beamed together, but special beam
grouping rules apply to tuplets within beams that also contain non-tuplet notes.

The default setting for a tuplet in a beamed group with secondary beams is to split the secondary
beam and to show the tuplet with a bracket. The primary beam is not split.

You can alter the appearance of the bracket by selecting the bracket and changing relevant
properties in the Tuplets group of the Properties panel.

Tuplets in beam groups with secondary beams are beamed together with a split secondary beam by default.

The default setting for a tuplet in a beamed group with only a primary beam is to separate the
tuplet entirely. However, you can change this setting on the Beam Grouping page in Notation
Options.

Eighth note (quaver) tuplets are not beamed together with subsequent non-tuplet eighth notes by default.

Beaming
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RELATED LINKS
Tuplets on page 1007

Stemlets
Stemlets are short stems that extend from beams to rests within beam groups. They can help
make music easier to read, as they help to maintain a regular pattern of stems within beams.

In the examples, beaming all notes and rests together to show the boundaries of quarter note
(crotchet) beats makes the syncopation of the notes easier to read. The stemlets on the rests
help make clear where within the quarter note beats each note occurs.

A syncopated phrase without stemlets The same phrase with stemlets

You can change the default appearance of stemlets in each flow, and you can show stemlets in
individual beams.

Showing stemlets in beam groups
You can show stemlets on rests in beam groups individually, independently of your default
setting for showing stemlets in the current flow.

PROCEDURE

1. Select the notes you want to beam together with stemlets shown on rests.
For example, to show a stemlet on a rest between two notes, select both notes. To show a
stemlet on a rest at the end of a beamed phrase, select all notes in the beam and the rest.

2. Choose Edit > Beaming > Stemlets > Force Stemlet Beam. You can also choose this
option from the context menu.

RESULT
The selected notes are beamed together with stemlets shown on rests within the beam group.

NOTE

● If you later reset the beaming of the selected group, stemlets revert to your default setting
for the flow.

● You can choose to show stemlets on rests in all beamed groups in each flow on the Beam
Grouping page in Write > Notation Options.

EXAMPLE

Stemlet with only the rest selected Stemlet with notes either side
selected

Stemlets shown with all notes and
rests in beam group selected
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Removing stemlets from beam groups
You can remove stemlets from rests in beam groups individually, independently of your default
setting for showing stemlets in the current flow.

PROCEDURE

1. Select at least one note in each of the beam groups from which you want to remove
stemlets on rests.

2. Choose Edit > Beaming > Stemlets > Suppress Stemlet Beam. You can also choose this
option from the context menu.

RESULT
Stemlets are removed from all rests in the selected beams.

NOTE

● Removing stemlets from beams does not reset the selected beams to your default beam
grouping for the flow.

● You can choose not to show stemlets on rests in all beam groups in each flow on the Beam
Grouping page in Write > Notation Options.

EXAMPLE

Beam group showing stemlets Beam group with suppressed stemlets

RELATED LINKS
Resetting beam grouping on page 540

Fanned beams
Fanned, or “feathered”, beams show either an accelerando or rallentando by having multiple
beam lines either converging on, or diverging from, a single beam line at the other end.

A single beam can have multiple changes of direction within it.

The grouping can use either two or three beams, with three beams indicating a greater change
of speed than two beams. The slowest part of the phrase is where the beams converge, and the
fastest is where the beams are the most spread out.

EXAMPLE

Fanned beam accelerando with three lines

Fanned beam accelerando with two lines

Fanned beam rallentando with three lines

Beaming
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Fanned beam rallentando with two lines

Creating fanned beams
You can create fanned beams across a group of any notes that can be beamed, such as eighth
notes (quavers), 16th notes (semiquavers), and 32nd notes.

PROCEDURE

1. Select the notes you want to include in a fanned beam. You can do this in Write mode and
Engrave mode.

2. Choose Edit > Beaming > Create Fanned Beam > [Direction and number of lines]. You
can also choose these options from the context menu.
For example, choose Edit > Beaming > Create Fanned Beam > Accelerando (Three
Lines) for an accelerando fanned beam with three lines.

RESULT
The selected notes are joined with a fanned beam with a single slope, whatever their original
duration.

Changing the direction within fanned beams
You can change the direction of fanned beams within phrases to indicate tempo changes.

PROCEDURE

1. In Engrave mode, select the notehead at each rhythmic position where you want to
change the direction of the fanned beam slope. You can select multiple positions within
phrases.

2. In the Properties panel, activate Change fanned beam direction in the Beaming group.

EXAMPLE

Fanned beam with multiple changes of direction
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There are generally accepted conventions for how notes and rests of different durations are
notated and grouped in different contexts.

In Dorico Pro, notes are automatically notated to fit within bars and are grouped according to
your per-flow settings.

Depending on the prevailing time signature, there can be many different ways to beam notes
together. For example, you might want to beam all notes in the bar together in time signatures
that cannot be divided in half and are often not divided at all, such as 3/4.

Tied notes are affected by your note and rest grouping settings, as there are different
conventions for how notes within tie chains should be divided to indicate significant beat
boundaries within bars, and in which contexts they can cross beat boundaries.

Similar options apply to dotted notes, which are often notated as a single dotted note if they
start at the beginning of bars, but as a tie chain that shows significant beat boundaries in the bar
if they start part-way through bars.

You can change the default note grouping and beam grouping settings for your project on the
Note Grouping and Beam Grouping pages in Write > Notation Options.

The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.

RELATED LINKS
Notation Options dialog on page 139
Per-flow changes to beam grouping defaults on page 539

Conventions for beam grouping according to meter
According to accepted conventions, notes are beamed differently in different time signatures to
make the meter clear and easily readable.

For example, music in 3/4 is beamed in one group of six eighth notes (quavers), whereas music in
6/8 is beamed in two groups, each the value of a dotted quarter note (crotchet). Although these
two time signatures describe the same rhythmic value, the implicit meter within them is
different, and so the beam grouping is different.

Default beam grouping in 3/4 Default beam grouping in 6/8

For irregular time signatures, such as 5/8 or 7/8, Dorico Pro beams notes by default according to
the most common practices for those time signatures.

Note and rest grouping
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Default beam grouping in 5/8 Default beam grouping in 7/8

RELATED LINKS
Per-flow changes to beam grouping defaults on page 539

Creating custom beat groupings for meters
If your music requires a different beat grouping for a particular meter than the default setting
for that time signature, you can specify your preferred beat grouping within the time signature.
You can choose whether or not the time signature shows this custom beat grouping.

NOTE

The duration of beam groups in Dorico Pro depends on the beat grouping in the current time
signature and your per-flow beam grouping settings in Write > Notation Options. For example,
entering [1+1+1+1]/4 into the time signatures popover inputs a time signature with four quarter
note (crotchet) groups. Because this creates a time signature with a half-bar, beam grouping
options for time signatures with a half-bar apply.

PROCEDURE

1. In Write mode, select an item at the rhythmic position where you want to input a time
signature with a custom beam grouping.

2. Press Shift-M to open the time signatures popover.

3. Enter the division you want in square brackets into the popover.
For example, to divide a 7/8 time signature into 2+3+2, enter [2+3+2]/8 into the popover.
To divide a 5/4 time signature into 2+3 rather than 3+2, enter [2+3]/4 into the popover.

4. Input the time signature and close the popover in one of the following ways:

● To input a time signature on all staves, press Return.

● To input a time signature on the selected staff only, press Alt-Return.

RESULT
The time signature specified is input and beam and beat grouping in subsequent bars follows
the division you specified. The time signature appears either as a single number, such as 7/8, or
showing the beat groups, such as 2+3+2/8, depending on your setting on the Time Signatures
page in Engrave > Engraving Options.

TIP

You can change the appearance of numerators in individual time signatures so that they show a
single number or beat groups independently of your project-wide settings.

RELATED LINKS
Per-flow changes to beam grouping defaults on page 539
Project-wide engraving options for time signatures on page 982
Time signature styles on page 988
Changing the numerator style of time signatures on page 989
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Brackets and braces are thick straight and curved lines in the left-hand margin that show
instrument groupings.

Brackets

A bracket is a thick black line, the width of a beam, that groups staves together, most commonly
according to instrument family. It often has winged ends that point inwards towards the score.

It is always positioned directly to the left of a systemic barline. If secondary brackets are used in
addition to a bracket, they are positioned further away from the start of the system to allow
space for the bracket.

An example of a bracket, connecting instruments in the string family. A sub-bracket connects the two violin
lines.

In Dorico Pro, barlines join the same staves that are joined by brackets and braces, meaning that
bracketed groups of staves and braced pairs of staves appear with barlines extending across the
group.

Braces

A brace is a wavy or curly line that joins multiple staves belonging to the same instrument, such
as the piano or harp. If necessary, a brace can extend to three or more staves, although two is
most common.

The brace is also sometimes used instead of a sub-bracket to show groupings of identical
instruments within a family whose staves are joined by a bracket.

Brackets and braces
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It is positioned outside the systemic barline, and if used in place of a sub-bracket, outside of the
bracket as well.

A brace connecting two piano staves

NOTE

Staves with braces cannot show sub-brackets or sub-sub-brackets.

RELATED LINKS
Barlines across staff groups on page 515
Player groups on page 115
Adding groups of players on page 115
Secondary brackets on page 556

Secondary brackets
Secondary brackets extend beyond brackets, allowing you to mark groups of staves within a
bracketed group. You can show secondary brackets as a brace positioned outside the bracket or
as a sub-bracket in Dorico Pro.

Secondary bracket as a sub-bracket

By default, secondary brackets appear as sub-brackets: thin lines with square corners that extend
beyond the bracket.

You can change how thick the lines of sub-brackets are, and the distance between sub-brackets
and the systemic barline, in the Sub-brackets subsection of the Design section of the Brackets
and Braces page in Engrave > Engraving Options.

Secondary bracket as a brace

Secondary brackets can also appear as a brace instead of a sub-bracket.

Brackets and braces
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You can change the distance between braces and brackets in the Sub-brackets subsection of the
Design section of the Brackets and Braces page in Engraving Options.

RELATED LINKS
Custom staff grouping on page 559
Inputting custom bracket/brace groups on page 560

Sub-sub-brackets
Sub-sub-brackets are a tertiary level of staff grouping with the same design as sub-brackets. They
are positioned outside of both brackets and sub-brackets, allowing you to mark groups of staves
within bracketed and sub-bracketed groups. Sub-sub-brackets can only appear as brackets in
Dorico Pro.

Sub-sub-brackets cannot extend beyond their sub-bracket and cannot be shown on staves with a
brace as either the primary or secondary group.

You can change how thick the lines of sub-sub-brackets are, their width, and their design in the
Sub-sub-brackets subsection of the Design section of the Brackets and Braces page in
Engrave > Engraving Options.

RELATED LINKS
Custom staff grouping on page 559
Inputting custom bracket/brace groups on page 560

Project-wide engraving options for brackets and braces
You can find options for the project-wide appearance of brackets and braces on the Brackets
and Braces page in Engrave > Engraving Options.

The options on the Brackets and Braces page allow you to change which instruments are
bracketed together, and change the design of brackets.

Brackets and braces
Sub-sub-brackets 
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The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.

RELATED LINKS
Engraving Options dialog on page 299

Changing the appearance of bracket ends
You can change the appearance of all bracket ends project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Brackets and Braces in the page list.

3. In the Design section, choose one of the following options for Bracket end design:

● Wings (default)

● Horizontal line

● None

Brackets according to ensemble type
In Dorico Pro, the default staff grouping settings for staves are determined by the ensemble type
chosen for the project. This affects which staves are bracketed together and joined by barlines.

The following ensemble types are available on the Brackets and Braces page in Engrave >
Engraving Options:

No brackets
All staves appear separately, with no brackets.

Orchestral
Staves are bracketed according to their instrument family. This is the default setting.

Small ensemble
All staves in the project are bracketed together.

Wind band
Staves are bracketed according to their instrument type. For example, Flute 1 and
Flute 2 are bracketed together, but separately from the other woodwind
instruments.

Big band
Staves are bracketed according to their instrument family, except for brass
instruments, which are all bracketed according to their instrument type.

Brackets and braces
Brackets according to ensemble type 
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Rhythm section instruments are bracketed together.
Percussion and timpani are bracketed together.

British brass band
Brass instruments are bracketed according to their instrument type, except for horns
and trumpets, which are bracketed together.
Any other instruments in the score are bracketed according to their instrument
family.
Percussion and timpani are bracketed separately.

NOTE

Vocal staves are never joined by barlines, even when the ensemble type in the project brackets
vocal staves together.

RELATED LINKS
Brackets according to project template categories on page 60

Changing bracket grouping according to ensemble type
You can change which staves are included in brackets by changing the project-wide setting for
ensemble type.

The default setting is Orchestral. We recommend that you change this setting for projects
containing small ensembles.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Brackets and Braces in the page list.

3. In the Approach section, choose one of the following options for Ensemble type:

● No brackets

● Orchestral

● Small ensemble

● Wind band

● Big band

● British brass band

RELATED LINKS
Barlines across staff groups on page 515

Custom staff grouping
In Dorico Pro, custom staff grouping allows you to change which staves are joined with brackets,
braces, sub-brackets, sub-sub-brackets, and barlines if your project requires staff grouping not
included in the default bracketing settings.

Any changes to the default staff grouping are shown as bracket and barline change signposts,
which also show the rhythmic position from which the changes apply. They only affect the staff
grouping in the current layout.

If bracket and barline change signposts are positioned at the start of a system, the
corresponding staff grouping changes apply from that system onwards. If the signpost is
positioned partway through a system, the change takes effect from the following system.

Brackets and braces
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A bracket and barline change signpost indicating sub-sub-brackets have been added to separate the divisi
cello parts and barlines only join staves of the same instrument type rather than all strings.

NOTE

For best results, we recommend that you input any bracket/brace grouping or barline join
changes you want only after adding any extra staves, ossia staves, or additional instruments you
want and with all staves shown in the layout. You can hide empty staves again after inputting the
changes.

We also recommend that you input any bracket/brace grouping or barline join changes you want
at the beginning of the flow, and add any subsequent changes in chronological order. We do not
recommend starting at the end of the flow.

RELATED LINKS
Signposts on page 281
Inputting custom barline joins on page 516
Barlines across staff groups on page 515

Inputting custom bracket/brace groups
You can input custom bracket/brace grouping changes at any position that change which staves
are grouped with brackets, sub-brackets, sub-sub-brackets, and braces.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

PROCEDURE

1. In Engrave mode, select an item on the top staff you want to group with a bracket/brace,
at the start of the system from which you want this change to apply.

2. Ctrl/Cmd-click an item on the bottom staff you want to group with a bracket/brace.
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3. In the Formatting panel, click one of the following in the Bracketing group:

● Insert bracket

● Insert sub-bracket

● Insert sub-sub-bracket

● Insert brace

RESULT
All staves in the current layout between and including the staves on which you selected items are
joined by the bracket or brace you chose until the next existing bracket and barline change or the
end of the flow, whichever comes first. A signpost appears at the start of the system in which you
selected items.
If necessary, any existing bracket or brace groupings are adjusted to accommodate the new
group as brackets/braces cannot overlap.

NOTE

You cannot move bracket and barline change signposts, as they are intended to apply to system
start positions. However, they can appear partway through systems if, for example, you move
system breaks. When a bracket and barline change signpost is positioned partway through a
system, the corresponding change only takes effect from the start of the next system.

EXAMPLE

Divisi cello staves with default staff grouping Divisi staves with sub-sub-brackets added

RELATED LINKS
Signposts on page 281

Lengthening/Shortening custom brackets/braces
You can lengthen/shorten custom brackets/braces vertically to change the staves across which
they span, for example, if you added a new player below a bracket group and want to extend the
bracket to that staff.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

Brackets and braces
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PROCEDURE

1. In Engrave mode, select a handle at either the top or bottom of each bracket/brace you
want to lengthen/shorten.

TIP

You only need to select a handle on one bracket/brace for each bracket and barline
change, as they apply from their signpost until the next existing change or the end of the
flow, whichever comes first.

2. Move the handles in any of the following ways:

● Press Alt-Up Arrow to move them to the staff above.

● Press Alt-Down Arrow to move them to the staff below.

● Click and drag them upwards/downwards to staves above/below.

RESULT
The selected brackets/braces are lengthened/shortened to staves above/below. This affects the
staves included in the brackets/braces on all systems to which the corresponding bracket and
barline changes apply.

NOTE

Only one bracket/brace can exist on each staff, they cannot overlap. If any part of a selected
bracket/brace collides with another bracket/brace when it is lengthened/shortened, the other
bracket/brace is shortened to accommodate this.

You can undo this action, but the previous length of any shortened brackets/braces is only
restored if you lengthened/shortened brackets/braces using the keyboard.

Resetting bracket and barline changes
You can reset custom changes to bracket/brace grouping and barline joins after a passage with
custom grouping/joins to revert subsequent systems to the project-wide staff grouping settings.

PREREQUISITE
Graphic Editing is selected in the Engrave toolbox.

PROCEDURE

1. In Engrave mode, select an item at the rhythmic position where you want to reset staff
grouping.

2. Choose Engrave > Reset Bracketing.

RESULT
Staff grouping, including both bracket/brace grouping and barline join changes, is reset to the
project-wide staff grouping sections from the selected rhythmic position until the next existing
bracket and barline change or the end of the flow, whichever comes first. A signpost appears at
the rhythmic position of the selected item.
If you selected an item partway through a system, staff grouping is not reset until the start of the
next system.

TIP

You can also reset changes to bracket/brace grouping and barline joins independently of each
other by using the Change bracketing and Change barlines properties in the Bracket and
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Barline Changes group of the Properties panel. When they are set to Auto, the corresponding
part of the selected changes is reset.

RELATED LINKS
Brackets according to ensemble type on page 558

Deleting bracket and barline changes
You can delete custom changes to bracket/brace grouping and barline joins, for example, if you
change your mind about where you want to reset the bracket/brace grouping.

PROCEDURE

1. Select the bracket and barline change signposts that you want to delete. You can do this in
Write mode and Engrave mode.

2. Press Backspace or Delete.

RESULT
The selected bracket and barline changes are deleted. Staff grouping on any corresponding
systems follows either the previous bracket and barline change or the project-wide staff
grouping settings if there is no previous bracket and barline change.

TIP

● In Engrave mode, you can also select the brackets/braces you want to delete.

● You can also delete individual barline joins independently of other barline joins and
bracket/brace grouping changes at the same rhythmic position.

RELATED LINKS
Brackets according to ensemble type on page 558
Deleting barline joins individually on page 517
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Chord symbols describe the vertical harmony of the music at a specific moment. They are
frequently used in jazz and pop music, where players often improvise around chord
progressions.

Depending on the style of music, there are different conventions regarding how to present chord
names.

RELATED LINKS
Input methods for chord symbols on page 213

Chord components
Chord symbols consist of a root and a quality, with intervals, alterations, and an altered bass note
included if required.

Root
The root note of the chord, expressed either as a note name or as a specific degree
of a scale.

Quality
Defines the type of chord, such as major, minor, diminished, augmented, half-
diminished, or with added note, such as six or nine.

Interval
Chord symbols can include one or more added intervals, such as a major seventh or
ninth. Intervals in chord symbols are also known as “extensions”.

Alterations
Define notes in chords that are different to what is normally expected of that chord.
For example, a sharpened fifth, flattened ninth, suspensions, or omissions.

Altered bass note
A chord symbol has an altered bass note if the lowest pitch of a chord is not its root
note, such as Cm7♭5/E♭.

Project-wide engraving options for chord symbols
You can find options for the project-wide appearance and position of chord symbols on the
Chord Symbols page in Engrave > Engraving Options.

The options on the Chord Symbols page in Engraving Options allow you to change the
appearance of different types of chords, including the order and arrangement of accidentals and
alterations, and their default positions.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.
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RELATED LINKS
Engraving Options dialog on page 299

Chord symbol appearance presets
There are many conventions for the appearance of chord symbols, so Dorico Pro provides a
choice of preset conventions that you can use and edit.

For example, you can edit default preset chord symbols, you can edit individual chord symbols
without changing the default appearance for that chord symbol, and you can edit individual
components within chord symbols.

You can find chord symbol presets at the top of the Chord Symbols page in Engraving Options.

Chord symbol preset example Chord symbol preset name

Default

Boston

Brandt-Roemer

Indiana

New York

Nashville

Jazz Standards

Ross

Japanese

These presets use specific combinations of the options on the Chord Symbols page. You can also
adjust these options individually to suit your requirements.
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Default uses a set of symbols intended to be as unambiguous as possible. For example, Default
avoids the use of symbols for major seventh, augmented, diminished, and half-diminished. This
is the default preset for new projects.

Custom is automatically selected when you change any of the preset options on the Chord
Symbols page.

RELATED LINKS
Edit Chord Symbol Appearance dialog on page 568
Edit Chord Symbol Component dialog on page 569

Project Default Chord Symbol Appearances dialog
The Project Default Chord Symbol Appearances dialog allows you to edit the default
appearance of chord symbols. This changes the appearance of chord symbols project-wide.

● You can open the Project Default Chord Symbol Appearances dialog by clicking Edit in
the Project Default Appearances section of the Chord Symbols page in Engrave >
Engraving Options.

Project Default Chord Symbol Appearances dialog

The Project Default Chord Symbol Appearances dialog contains the following sections:

1 Enter a chord symbol
Allows you to enter the chord symbol whose default project-wide appearance you want to
edit. Click Add Project Default or press Return to add the chord symbol to the Project
Default Appearances list, which allows you to edit the chord symbol in the editor.

2 Project Default Appearances list
Contains the chord symbols whose project default appearance you have edited in the
project.
You can delete changes to the project default appearance of chord symbols by clicking
Delete in the action bar.

3 Single Overrides list
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Contains the chord symbols whose individual appearance you have overridden in the
project.
You can promote your edits to individual chord symbols to be the project default
appearance for that chord symbol by clicking Promote to Project Default in the action
bar.

You can reset single overrides to the project default appearance for that chord symbol by
clicking Remove Overrides in the action bar.

4 Editor
Allows you to arrange and edit the components that make up the chord symbol. You can
use the controls at the bottom of the dialog, and you can also move individual components
in any of the following ways after selecting them in the editor:

● Press the standard key commands for moving items. For example, press Alt-
Right Arrow to move components to the right, or press Ctrl/Cmd-Alt-Right Arrow
to move components to the right by larger increments.

● Click and drag each component.

NOTE

You cannot move the first component in chord symbols.

In addition to using Scale, you can also change the size of components by clicking and
dragging the square handle in the top right corner after selecting a component in the
editor.

5 Controls

● X offset moves components horizontally. Increasing the value moves components
to the right, decreasing the value moves components to the left.

● Y offset moves components vertically. Increasing the value moves components
upwards, decreasing the value moves components downwards.

● Scale changes the size of components. Increasing the value increases the size of
components proportionally, decreasing the value decreases the size of components
proportionally.

● Reset X offset resets the horizontal position of the selected component.

● Reset Y offset resets the vertical position of the selected component.

● Reset Scale resets the size of the selected component.

6 Alternative component presentations
Contains alternative ways of presenting the component selected in the editor.
Allows you to create new components and edit existing components by clicking the
respective button in the action bar.

● Add Component

● Edit Component

Clicking either button opens the Edit Chord Symbol Component dialog, in which you can
create new chord symbol components and edit existing chord symbol components.
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RELATED LINKS
Chord symbol appearance presets on page 565
Edit Chord Symbol Component dialog on page 569

Edit Chord Symbol Appearance dialog
The Edit Chord Symbol Appearance dialog allows you to edit the appearance and arrangement
of individual chord symbols, without changing the project default appearance of that chord
symbol.

You can open the Edit Chord Symbol Appearance dialog in the following ways:

● In Engrave mode, select a chord symbol and press Return.

● In Engrave mode, double-click a chord symbol.

Edit Chord Symbol Appearance dialog

The Edit Chord Symbol Appearance dialog contains the following sections:

1 Editor
Allows you to arrange and edit the components that make up the chord symbol.
As well as using the controls at the bottom of the dialog, you can move individual
components in any of the following ways after selecting them in the editor:

● Press the standard key commands for moving items. For example, press Alt-
Right Arrow to move components to the right, or press Ctrl/Cmd-Alt-Right Arrow
to move components to the right by larger increments.

● Click and drag each component.
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NOTE

You cannot move the first component in chord symbols.

In addition to using Scale, you can also change the size of components by clicking and
dragging the square handle in the top right corner after selecting a component in the
editor.

2 Controls
Allow you to move individual components and change their size. You can also reset their
position and size.

● X offset moves components horizontally. Increasing the value moves components
to the right, decreasing the value moves components to the left.

● Y offset moves components vertically. Increasing the value moves components
upwards, decreasing the value moves components downwards.

● Scale changes the size of components. Increasing the value increases the size of
components proportionally, decreasing the value decreases the size of components
proportionally.

● Reset X offset resets the horizontal position of the selected component.

● Reset Y offset resets the vertical position of the selected component.

● Reset Scale resets the size of the selected component.

3 Alternative component presentations
You can create new components and edit existing components by clicking the respective
button in the action bar.

● Add Component

● Edit Component

Clicking either button opens the Edit Chord Symbol Component dialog, in which you can
create new components and edit existing components.

RELATED LINKS
Chord symbol appearance presets on page 565

Edit Chord Symbol Component dialog
The Edit Chord Symbol Component dialog allows you to create custom components and edit
existing components for both individual chord symbols and for project default chord symbols.

You can open the Edit Chord Symbol Component dialog by clicking either Add Component or
Edit Component in the alternative component presentations action bar in the following dialogs:

● Project Default Chord Symbol Appearances dialog

● Edit Chord Symbol Appearance dialog
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Edit Chord Symbol Component dialog

The Edit Chord Symbol Component dialog contains the following sections:

1 Name
Contains an automatically generated name for the chord symbol component. You cannot
change this name.

2 Component selector
Allows you to choose components to add to your chord symbol component. You can add
different types of components by clicking the respective tab titles.

● Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting
different fonts and different ranges from the menus. Click Add Glyph to add the
selected glyph to the chord symbol component.

NOTE

A full list of the different ranges of glyphs is available on the SMuFL website.

● Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected
text, or input text, to the chord symbol component.

● Graphic: Allows you to load a new graphics file, or select an existing graphic from
the Select existing list, in SVG, PNG, or JPG format. You can see a preview of the
graphic in the Preview box. Click Add Graphic to add the selected graphic to the
chord symbol component.

● Composite: Allows you to select a composite from the list. Click Add Composite to
add the selected composite to the chord symbol component.

3 Editor
Allows you to arrange and edit the components that make up your chord symbol
component. You can arrange and edit components using the controls at the bottom of the
dialog.

4 Editor action bar
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Contains selection and view options for the editor.

● Zoom
Allows you to change the zoom level in the editor.

● Select
Allows you to select the next/previous component.

● Delete

Deletes the selected component.

5 Controls
Contains controls that allow you to edit individual components. Controls are divided into
tabs according to the aspect of the selected component they affect. For chord symbols,
only the Component and Attachments tabs are available as the other tabs do not apply
to chord symbols.
The Component tab contains the following options:

● Offset: Controls the position of the selected component. X moves it horizontally, Y
moves it vertically.

● Scale: Controls the size of the selected component. For graphics, X controls its
width, Y controls its height.

NOTE

Although some components scale their height and width independently, others
retain their aspect ratio, meaning only one value affects their overall size.

● Z order: Allows you to Bring Forward or Send Backward the selected component in
relation to other components when they overlap.

The Attachments tab is only available if the chord symbol component comprises at least
two separate components. It contains the following options:

● Attachment from: Sets the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend
that you select a right edge attachment point for Attachment from.

● Attachment to: Sets the attachment point on the selected component which
attaches to the component to its left. We recommend that you select a left edge
attachment point for Attachment to.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.

The attachment points have the following names in the Edit Chord Symbol Component dialog:

1 Top Left

2 Top Center

3 Top Right

4 Middle Left
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5 Middle Right

6 Baseline Left (text only)

7 Baseline Center (text only)

8 Baseline Right (text only)

9 Bottom Left

10 Bottom Center

11 Bottom Right

RELATED LINKS
Chord symbol appearance presets on page 565
Project Default Chord Symbol Appearances dialog on page 566
Edit Chord Symbol Appearance dialog on page 568

Setting single chord symbol overrides as the project default
You can set single overrides you have made to individual chord symbols as the project default
appearance for that chord symbol.

PROCEDURE

1. Open the Project Default Chord Symbol Appearances dialog.

2. Select the single override that you want to set as project default in the Single Overrides
list.

3. Click Promote to Project Default.

RESULT
The selected single chord symbol override becomes the default appearance for that chord
symbol.

NOTE

This cannot be undone. If you want to revert your changes, you must delete the chord symbol
from the Project Default Appearances list.

RELATED LINKS
Project Default Chord Symbol Appearances dialog on page 566

Resetting the appearance of chord symbols with single overrides
You can reset the appearance of chord symbols you have overridden individually to the project
default appearance for that chord symbol.

PROCEDURE

1. Open the Project Default Chord Symbol Appearances dialog.

2. Select the single override that you want to reset in the Single Overrides list.

3. Click Remove Overrides.
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RESULT
All individual changes to the chord symbol are removed. It now follows the project default
appearance for that chord symbol.

RELATED LINKS
Project Default Chord Symbol Appearances dialog on page 566

Changing chord symbol fonts
You can change the formatting of the text fonts used for chord symbols project-wide.

PROCEDURE

1. In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2. Select one of the following fonts from the Font style menu:

● Chord Symbols Altered Bass Separator Font

● Chord Symbols Font

● Chord Symbols Music Text Font

TIP

When using the option to show the word “on” instead of a slash or line to separate a
chord from its altered bass note, you can edit the font used for that word by editing
Chord Symbols Altered Bass Separator Font.

NOTE

We recommend that you do not edit Chord Symbols Music Text Font, which is set
to Bravura Text by default. This can only be set to a SMuFL-compliant font intended
for use in text-based applications.

3. Activate the following options, individually or together, to change the corresponding
aspect of the font:

● Font family

● Size

● Style

● Underlined

4. Click OK to save your changes and close the dialog.

Transposing chord symbols
Chord symbols can be transposed, and appear at the appropriate transposed pitch when shown
on transposing instruments.

PROCEDURE

1. In Write mode, select the chord symbols you want to transpose.

2. Choose Write > Transpose to open the Transpose dialog.

3. Change the transposition using the options in the dialog.

4. Click OK to save your changes and close the dialog.

RESULT
The selected chord symbols are transposed.
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TIP

You can show chord symbols at the appropriate transposed pitch for transposing instruments in
the current layout, rather than at concert pitch, by choosing Edit > Transposed Pitch.

RELATED LINKS
Making layouts transposing/concert pitch on page 123

Hiding/Showing chord symbols
You can hide/show chord symbols in the current layout without deleting them.

PROCEDURE

1. Select the chord symbols or chord symbol signposts you want to hide/show. You can do
this in Write mode and Engrave mode.

2. In the Properties panel, activate/deactivate Hidden in the Chord Symbols group.

RESULT
Chord symbols are hidden when the property is activated, and shown when the property is
deactivated.
Signposts are shown at the positions of each chord symbol so you can always find them again.
However, signposts are not printed by default.

TIP

● If you do not want to show chord symbol signposts, choose View > Signposts > Chord
Symbols. Chord symbol signposts are shown when a tick appears beside Chord Symbols
in the menu, and hidden when no tick appears.

● You can assign a key command for Hide/Show Item on the Key Commands page in
Preferences, which applies to chord symbols, playing techniques, and time signatures.

RELATED LINKS
Signposts on page 281

Hiding/Showing the root and quality of chord symbols
You can hide the root and quality of chord symbols if they follow another chord symbol with the
same root and quality, but have a different altered bass note.

PROCEDURE

1. Select the chord symbols whose root and quality you want to hide. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, activate Hide root and quality in the Chord Symbols group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
The root and quality of the selected chord symbols are hidden when the checkbox is activated,
and shown when the checkbox is deactivated.
When the property is deactivated, chord symbols follow your project-wide setting.
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TIP

You can choose to show the root and quality of chord symbols always, even if successive chord
symbols have the same root and quality, in the Altered Bass Notes section of the Chord
Symbols page in Engrave > Engraving Options.

Positions of chord symbols
By default, chord symbols are centered horizontally on the middle of the front notehead in the
first voice column, at the rhythmic position to which they are attached.

NOTE

The front notehead is the notehead on the correct side of the stem at that rhythmic position.

Their vertical positions in full scores is determined by the staves above which they are set to
appear. This also affects in which part layouts chord symbols appear.

Alignment of chord symbols relative to notes and chords

You can change whether chord symbol text is left-aligned above the notehead, center-aligned
above the notehead, or right-aligned above the notehead, although right-aligned typically
produces unclear results.

You can change the horizontal alignment of chord symbols by choosing an option for Horizontal
alignment relative to note, chord or rest in the Position section of the Chord Symbols page in
Engraving Options.

You can also override this for an individually selected chord symbol by activating Alignment in
the Chord Symbols group of the Properties panel and selecting an option from the menu.

Alignment of chord symbols across the system

Chord symbols are aligned at the same vertical position across the width of the system by
default. You can deactivate Align chord symbols across width of system in the Position section
of the Chord Symbols page in Engraving Options if you want each chord symbol to be
positioned above the staff independently.

RELATED LINKS
Project-wide engraving options for chord symbols on page 564
Changing the staves above which chord symbols appear on page 577
Changing the layouts in which chord symbols appear on page 577

Moving chord symbols rhythmically
You can move chord symbols to new rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the chord symbols you want to move.

NOTE

When using the mouse, you can only move one chord symbol rhythmically at a time.

2. Move the chord symbols according to the current rhythmic grid value in any of the
following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.
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● Click and drag the chord symbol to the right/left.

RESULT
The selected chord symbols are moved to new rhythmic positions.

NOTE

Only one chord symbol can exist at each rhythmic position. If a chord symbol passes over
another chord symbol as part of its move, the existing chord symbol is deleted.

You can undo this action, but any chord symbols deleted in the process are only restored if you
moved the chord symbol using the keyboard.

Moving chord symbols graphically
You can move chord symbols graphically without affecting the rhythmic positions to which they
apply.

PROCEDURE

1. In Engrave mode, select the chord symbols you want to move.

2. Move the chord symbols in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected chord symbols are moved graphically, without affecting the rhythmic positions to
which they are attached.

TIP

Start offset in the Chord Symbols group of the Properties panel is activated automatically when
you move chord symbols.

● Start offset X moves chord symbols horizontally.

● Start offset Y moves chord symbols vertically.

You can also use this property to move chord symbols graphically by changing the values in the
value fields.

Deactivating the property resets the selected chord symbols to their default positions.
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Changing the staves above which chord symbols appear
You can change the players above whose staves chord symbols appear. By default, chord
symbols appear above the staves belonging to rhythm section instruments, such as keyboards,
guitars, and bass guitars.

PROCEDURE

1. In Setup mode, select a player in the Players panel above which you want to hide/show
chord symbols.

2. Right-click the player and choose one of the following options from the context menu:

● Chord Symbols > Show For All Instruments
Chord symbols are shown above the staff of the selected player.

● Chord Symbols > Show For Rhythm Section Instruments
Chord symbols are shown above the staff of the selected player if it is a rhythm
section instrument.

● Chord Symbols > Hide For All Instruments
Chord symbols are not shown above the staff of the selected player.

RESULT
Chord symbols are hidden/shown above the staff of the selected player. For example, if you
choose Show For All Instruments, chord symbols can now appear above the selected player in
the full score and any corresponding part layouts, depending on the layouts in which chord
symbols are shown in your project.

TIP

You can choose to show chord symbols between the two staves of grand staff instruments, such
as piano, in the Position section of the Chord Symbols page in Engrave > Engraving Options.

Changing the layouts in which chord symbols appear
You can change which layouts show chord symbols. By default, chord symbols appear both in full
score and part layouts for rhythm section instruments.

NOTE

If chord symbols are not set to appear for any instrument in the current layout, signposts are
shown above the top staff.

PROCEDURE

1. In Setup mode, select a player in the Players panel.

2. Right-click the player and choose one of the following options from the context menu:

● Chord Symbols > Show in Full Score and Parts
Chord symbols are shown above the staff of the selected player in all layouts that
include the player.

● Chord Symbols > Show in Full Score Only
Chord symbols are only shown above the staff of the selected player in full score
layouts and not in any part layouts.

● Chord Symbols > Show in Parts Only
Chord symbols are only shown above the staff of the selected player in part layouts
and not in full score layouts.

Chord symbols
Positions of chord symbols 

577
Dorico 2.2.20



Changing the enharmonic spelling of chord symbols
You can respell a chord symbol for transposing instruments, for example, to choose a simpler
enharmonic equivalent spelling. This changes the enharmonic spelling of chord symbols in all
layouts with the same transposition.

PROCEDURE

1. In Write mode, open a layout with the transposition for which you want to respell chord
symbols.

2. Select the chord symbol you want to respell.

3. Press Return to open the chord symbols popover for the selected chord symbol.
The existing entry for the chord symbol is shown inside the popover.

4. Change the root name of the chord, but leave other details as they were, such as quality,
interval, or alterations.
For example, change just the root of D♭maj13 from Db to C#.

RESULT
The spelling of the chord symbol is altered for all instruments with the same transposition. For
example, changing the spelling of a chord symbol for a Clarinet in B♭ also changes the spelling of
that chord symbol in a Trumpet in B♭ layout.

Showing chord symbols as modes
You can show individual chord symbols as their modal equivalent if one exists for that chord
symbol.

PROCEDURE

1. Select the chord symbols you want to show as a mode. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Show as mode in the Chord Symbols group.

3. Select the mode you want from the menu.

RESULT
The selected chord symbols are respelled according to the selected mode. This does not affect
the notes included in the chord symbols.

Resetting the enharmonic spelling of chord symbols
You can remove enharmonic spelling overrides for chord symbols. You can remove overrides for
the current instrument only, or for all instruments to which the chord symbol applies.

PROCEDURE

1. In Write mode, select the chord symbol you want to respell.

2. Press Return to open the chord symbols popover for the selected chord symbol.
The existing entry for the chord symbol is shown inside the popover.

3. Reset the enharmonic spelling of the chord symbol in any of the following ways:

● To remove the enharmonic spelling override for a chord symbol for the instrument
above which the popover appears, enter Alt-S into the chord symbols popover.

● To remove all enharmonic spelling overrides for a chord symbol for all instruments,
enter Shift-Alt-S into the popover.
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Chord symbols imported from MusicXML
Chord symbols are imported from MusicXML files. However, chords that specify Neapolitan,
Italian, French, German, Pedal, Tristan, and Other values for the kind of element are ignored
during import, as there is no information to specify what notes these chord symbols are meant
to describe.
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Clefs are the symbol at the start of every system that give the notes on the staff context; that is,
the clef tells you which note of the scale applies to each line or space of the staff.

For example, the treble clef is also known as a “G clef”, because the spiral shape in the middle
centers around G, normally the one above middle C.

The other common clefs are:

● The bass clef, or F clef, in which two dots are shown either side of the line corresponding
to F, normally the F below middle C.
Middle C uses one ledger line below staves with treble clefs, and one ledger line above
staves with bass clefs.

● The C clef, in which the center of the bracket to the right of the clef’s thick vertical line is
positioned on the line that corresponds to C, normally middle C.

The C clef today is commonly used at two positions on the staff:

● On the middle line of the staff, commonly called the alto clef.

● On the line above the middle line of the staff, commonly called the tenor clef.

To minimize the number of ledger lines required, these clefs are used to match the register of
the instrument for which they are used.

The E below middle C
shown in a treble clef

The E below middle C
shown in a bass clef

The E below middle C
shown in a C (alto) clef

The E below middle C
shown in a C (tenor) clef

In Dorico Pro, clefs and octave lines are both contained in the Clefs panel on the right of the
window. Three sections of the panel apply to clefs:

● Common Clefs, including treble clef, bass clef, alto clef, and tenor clef.

● Uncommon Clefs, including tab, French violin clef, treble clef octave above, treble clef
octave below, and so on.

● Archaic Clefs, including baritone bass clef, mezzo-soprano clef, and soprano clef, which
are not commonly used any more.

RELATED LINKS
Input methods for clefs and octave lines on page 219

Clefs

580
Dorico 2.2.20



General placement conventions for clefs
Clefs are placed at the start of every system, with a small gap between the start of the staff and
the left edge of the clef. Their vertical placement must be precise, as this signifies which pitches
are intended by the subsequent notes on the staff.

Clef changes that occur during a piece are usually smaller than the clefs shown at the start of
each system. If clef changes occur at the start of a new system or page, a cautionary clef is
shown at the end of the previous system to ensure the performer notices the change of clef.

Wherever possible, clef changes should not be positioned in the middle of tie chains. Changing
the clef changes the position of the tied note on the staff, which could easily cause a performer
to misread the tie as a slur and play two different notes. You can input clef changes in the middle
of tie chains in Dorico Pro, but we recommend that you position clef changes either before or
after tie chains.

RELATED LINKS
Tie chains on page 968
Input methods for clefs and octave lines on page 219

Project-wide spacing gaps for clefs
You can change the minimum gaps between objects, including clefs, on the Spacing Gaps page
in Engrave > Engraving Options.

The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.

The following minimum values directly relate to clefs:

● Gap after barline before clef, key or time signature

● Gap after initial clef

● Gap to the left of clef, cancellation naturals or grace notes before note or barline

● Gap after clef change

Other values may have an effect on the position of clefs, but they also affect other objects.

RELATED LINKS
Engraving Options dialog on page 299

Moving clefs rhythmically
You can move clefs to new rhythmic positions after they have been input.

TIP

You can change the default positions of clefs relative to notes or barlines by changing the
project-wide values for spacing gaps on the Spacing Gaps page in Engrave > Engraving
Options.

PROCEDURE

1. In Write mode, select the clefs you want to move.

NOTE

● You cannot select an initial clef at the start of the flow or clefs shown automatically
at the start of each system.

Clefs
General placement conventions for clefs 

581
Dorico 2.2.20



● When using the mouse, you can only move one clef rhythmically at a time.

2. Move the clefs according to the current rhythmic grid value in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the clef to the right/left.

RESULT
The selected clefs are moved to new rhythmic positions. They take effect from their new
positions until the next clef, or the end of the flow, whichever comes first.

NOTE

● You can only move clefs along staves. If you want to move a clef across staves, you must
delete the clef and input a new clef on the other staff.

● Only one clef can exist at each rhythmic position, except for clefs that only apply to single
staves. If a clef passes over another clef as part of its move, the existing clef is deleted.

You can undo this action, but any clefs deleted in the process are only restored if you
moved the clef using the keyboard.

RELATED LINKS
Input methods for clefs and octave lines on page 219

Moving clefs graphically
You can move individual clefs graphically without affecting the positions of any other items.

PROCEDURE

1. In the Engrave toolbox, activate Note Spacing.

2. Select the square handle above the clef you want to move.

A circular handle appears beside the clef.

3. Press Tab to select the circular handle.

4. Move the handle in any of the following ways:

● Press Alt-Right Arrow to move it to the right.

● Press Alt-Left Arrow to move it to the left.

NOTE

● If you want to move handles by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

Clefs
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● You cannot move note spacing handles with the mouse, you can only move
them using the keyboard.

RESULT
The clef is moved graphically to the right/left, without affecting other items at the same rhythmic
position.

TIP

You can also change Spacing offset in the Clefs group of the Properties panel to move clefs
horizontally. However, this also affects global note spacing around the rhythmic position of the
clef.

The Spacing offset property in the Clefs group of the Properties panel is not available when
Note Spacing is activated.

RELATED LINKS
Note spacing on page 381

Deleting clefs
You can delete clefs without affecting the pitches of notes. Notes are automatically respelled
according to the previous clef on the staff.

NOTE

You cannot delete an initial clef at the start of the flow or clefs shown automatically at the start of
each system. If you do not want any clef to appear on a staff, you can input an invisible clef.

PROCEDURE

1. In Write mode, select the clefs you want to delete.

2. Press Backspace or Delete.

RESULT
The selected clefs are deleted. Any music on the staff is respelled according to the previous clef,
up until the next existing clef or the end of the flow.

RELATED LINKS
Input methods for clefs and octave lines on page 219

Default size of clef changes
You can change the default scale factor of all clef changes project-wide.

The default Clef change scale factor is 2/3. You can change the default clef change size on the
Clefs page in Engrave > Engraving Options.

Increasing the scale factor makes clef changes appear larger, decreasing the scale factor makes
clef changes appear smaller. This does not affect the size of clefs at the start of each system.

The smallest scale factor that you can input is 1/8. There is no maximum limit. However, for
example, a scale factor of more than 30 causes a single clef to take up most of an A4 page, which
is rarely beneficial.
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Changing the position of clefs relative to grace notes
By default, clefs are not positioned between a note and its grace note. Dorico Pro automatically
positions clefs correctly and updates their position according to what you input. However, in
some circumstances you might want to position clefs between a note and its grace note.

PROCEDURE

1. Select the clef whose position you want to change. You can do this in Write mode and
Engrave mode.

2. Choose Edit > Clef Position > After Grace Notes. You can also choose this option from the
context menu.

RESULT
The clef is positioned between a note and its grace note.

NOTE

You can reset the position of clefs relative to grace notes by selecting the clefs whose position
you want to reset and choosing Edit > Clef Position > Reset Clef Position. You can also choose
this option from the context menu.

Setting different clefs for concert/transposed pitch
You can set clef changes to show a different clef in concert pitch layouts compared to transposed
pitch layouts. For example, if you want a clef change on a Bass Clarinet staff to appear as a treble
clef in the part layout but as a bass clef in the full score layout.

NOTE

● This only applies to clefs you have input, as you cannot select initial clefs or the clefs
shown automatically at the start of each system.

● Many instruments in Dorico Pro show different clefs in full score and part layouts by
default. You can select the appropriate instrument type from the instrument picker when
adding or changing instruments.

PROCEDURE

1. Select the clefs whose concert/transposed pitch versions you want to change. You can do
this in Write mode and Engrave mode.

2. Choose one of the following options:

● To change the concert pitch version of the selected clefs, choose Edit > Clef >
Concert Pitch > [Clef].

● To change the transposed pitch version of the selected clefs, choose Edit > Clef >
Transposed Pitch > [Clef].

TIP

You can also choose these options from the context menu.

RESULT
The clefs shown at the selected clef changes in layouts of the corresponding transposition are
changed up to the next existing clef change or the end of the flow, whichever comes first.

Clefs
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NOTE

Clef changes appear in all layouts. It is not possible to show clef changes only in one layout.

RELATED LINKS
Transposing instruments on page 104
Adding instruments to players on page 104
Changing instruments on page 106
Instrument picker on page 85

Transposing clefs
Transposing clefs indicate that notes are played in a different register to the one notated. A
number above the clef indicates that notes are played higher than notated, while a number
below the clef indicates that notes are played lower than notated.

Of these clefs, only the treble clef 8 below is still commonly used for tenor vocal parts.

RELATED LINKS
Transposing instruments on page 104
Making layouts transposing/concert pitch on page 123
Concert vs. transposed pitch on page 123
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Octave lines indicate where notes are played higher/lower than they appear in the score or part.

Octave lines are dashed or dotted horizontal lines with an italic numeral at the start. The numeral
indicates the number of pitches by which the phrase is changed, such as 8 for one octave and 15
for two octaves.

Octave lines that indicate notes are played higher than notated are placed above the staff, while
octave lines that indicate notes are played lower than notated are placed below the staff.

A treble clef phrase notated at
pitch

The treble clef phrase with an
octave above line

The treble clef phrase with a two
octaves above line

A bass clef phrase notated at pitch The bass clef phrase with an
octave below line

The bass clef phrase with a two
octaves below line

In Dorico Pro, pitches are adjusted automatically when an octave line is present. You do not have
to change the register of the notes within the line.

You can use octave lines across a few notes, a single phrase, or multiple phrases, but they must
not confuse the contour of the music. If used excessively and for inappropriate sections, octave
lines can mask the shape of the original melody. However, careful usage of octave lines can make
music easier to read quickly as the performer has fewer ledger lines to count.

An angular phrase with no octave
lines

The same phrase with many
octave lines, which distort the
overall shape of the phrase.

The same phrase with just two
octave lines to reduce ledger lines.
They do not change the overall
shape of the phrase.

Octave lines
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It is generally best to use a different clef for a whole phrase if appropriate for that instrument, or
to input an octave line for the whole phrase in order to ensure the shape and register are clear to
the performer.

Octave lines should be horizontal, meaning they can take up significant vertical space, as octave
lines are usually placed outside all other notations. However, they can be placed within slurs and
tuplet brackets if the slur or tuplet bracket is longer than the octave line.

Octave lines can continue across system and page breaks. It is customary to show the numeral
again at the start of each system as a reminder. Cautionary octave line numerals are usually
parenthesized and the suffix is optional.

RELATED LINKS
Input methods for clefs and octave lines on page 219

Project-wide engraving options for octave lines
You can find options for the project-wide appearance of octave lines on the Octave Lines page in
Engrave > Engraving Options.

The options on this page allow you to change the appearance of continuation lines, continuation
labels, the numeral at the start of octave lines, the position of octave lines relative to accidentals
and noteheads, and their staff-relative placement.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Lengthening/Shortening octave lines
You can lengthen/shorten octave lines after they have been input.

PROCEDURE

1. In Write mode, select the octave lines you want to lengthen/shorten.

NOTE

When using the mouse, you can only lengthen/shorten one octave line at a time.

2. Lengthen/Shorten the selected octave lines in any of the following ways:

● To lengthen them by the current rhythmic grid value, press Shift-Alt-Right Arrow.

● To shorten them by the current rhythmic grid value, press Shift-Alt-Left Arrow.

● To snap the end of a single octave line to the next notehead, press Ctrl/Cmd-Shift-
Alt-Right Arrow.

● To snap the end of a single octave line to the previous notehead, press Ctrl/Cmd-
Shift-Alt-Left Arrow.

NOTE

● You can only lengthen/shorten octave lines by the current rhythmic grid value
when multiple octave lines are selected.

● When using the keyboard, you can only move the end of octave lines. You can
move the start of octave lines by moving the whole line, or by clicking and
dragging the start handle.

Octave lines
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● Click and drag the circular handle at the start/end of a single octave line to
noteheads to the right/left.

RESULT
Single octave lines are lengthened/shortened according to the current rhythmic grid value or to
the next/previous notehead, whichever is closer.
Multiple octave lines are lengthened/shortened according to the current rhythmic grid value.

Changing the angles of octave lines
You can change the angles of octave lines in multiple places, for example, if you want to add
corners to allow an octave line to follow the shape of an angular phrase more closely to save
vertical space.

PROCEDURE

1. In Write mode or Engrave mode, select one of the following:

● Individual notes/chords within octave lines where you want to add single corners.

NOTE

We do not recommend selecting adjacent notes, as this can distort the dashes in
octave lines.

● An even number of adjacent notes across which you want to angle the octave line.

2. Change the angles in one of the following ways:

● To add a single corner at the position of each selected note, choose Edit > Octave
Line > Add Corner.

● To angle the octave line across the range of selected notes, choose Edit > Octave
Line > Make Angled.

TIP

You can also choose these options from the context menu.

RESULT
If you added corners to individual notes, Dorico Pro compares the furthest note from the staff at
each selected rhythmic position to the height of the previous note/chord and adds a corner with
a suitable angle.
If you angled the octave line across a range of selected notes, Dorico Pro adjusts the angle of the
octave line in order to fit around changes in height in the selected range.

Octave lines
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EXAMPLE

An octave line with multiple corners, allowing it to fit better under the slur

Resetting the angles of octave lines
You can reset the angles and corners of octave lines to return them to a single horizontal line.

PROCEDURE

1. Select the notes within the octave lines at the positions of the angles/corners you want to
reset. You can do this in Write mode and Engrave mode.

2. Choose Edit > Octave Line > Remove Corner/Angle. You can also choose this option from
the context menu.

RESULT
The angles and corners of octave lines above/below the selected notes are reset. This does not
affect any other angles in the same octave lines above/below unselected notes.

Positions of octave lines
By default, octave lines that indicate notes are played higher than written are placed above the
staff, while octave lines that indicate notes are played lower than written are placed below the
staff.

You can move octave lines to new rhythmic positions in Write mode. They are positioned by
default according to your settings in Engraving Options.

You can move octave lines graphically in Engrave mode, but this does not change the rhythmic
positions to which they apply.

You can change the default positions of all octave lines project-wide on the Octave Lines page in
Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for octave lines on page 587
Tucking index properties on page 594

Moving octave lines rhythmically
You can move octave lines to new rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the octave lines you want to move.

Octave lines
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NOTE

When using the mouse, you can only move one octave line rhythmically at a time.

2. Move the octave lines to the next or previous notehead on the staff, while maintaining
their total durations, in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the octave line to the right/left.

RESULT
The octave lines are moved to noteheads to the right/left along the staff. The octave lines now
apply to the notes at their new positions. If an octave line passes over another octave line as part
of its move, the existing line is unaffected as multiple octave lines can exist at the same rhythmic
position.

NOTE

Octave lines can only be moved along staves. If you want to move an octave line across staves,
you must delete the octave line and input a new octave line on the other staff.

RELATED LINKS
Input methods for clefs and octave lines on page 219

Moving octave lines graphically
You can move octave lines graphically without changing the rhythmic positions to which they
apply. You can move each end of octave lines independently, meaning you can also adjust the
graphical lengths of individual octave lines.

PROCEDURE

1. In Engrave mode, select one of the following that you want to move:

● Whole octave lines

● The start/end handles of octave lines

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the octave lines or handles in any of the following ways:

● Press Alt-Right Arrow to move octave lines and handles to the right.

● Press Alt-Left Arrow to move octave lines and handles to the left.

● Press Alt-Up Arrow to move octave lines and start handles upwards.

● Press Alt-Down Arrow to move octave lines and start handles downwards.

NOTE

You cannot move the end handles on octave lines upwards/downwards, you can
only move them to the right/left.

You can move the start handles on octave lines upwards/downwards but this also
moves the whole octave line.

Octave lines
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TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag whole octave lines upwards/downwards.

● Click and drag handles on octave lines to the right/left.

RESULT
The selected octave lines or handles are moved to new graphical positions.

TIP

The following properties in the Octave Lines group of the Properties panel are activated
automatically when you move octave lines in the corresponding directions:

● Start X offset moves the start of octave lines horizontally.

● End X offset moves the end hooks of octave lines horizontally.

● Y offset moves whole octave lines vertically.

For example, if you move a whole octave line to right, both handles are moved, so Start X offset
and End X offset are both activated. You can also use all three properties to move and lengthen/
shorten octave lines graphically by changing the values in the value fields.

Deactivating the properties resets the selected octave lines to their default positions.

Changing the alignment of octave line numerals relative to notes
You can change whether the left edge, center, or right edge of individual octave line numerals is
aligned with the first note to which each octave line applies.

PROCEDURE

1. Select the octave lines whose numeral alignment relative to notes you want to change. You
can do this in Write mode and Engrave mode.

2. In the Properties panel, activate L alignment in the Octave Lines group.

3. Select one of the following options from the menu:

● Left

● Center

● Right

RESULT
The alignment of the numerals of the selected octave lines is changed. For example, if you select
Right, the right edge of the selected octave line numerals is aligned with the first noteheads to
which the octave lines apply.

Changing the position of octave line numerals relative to accidentals
You can change whether the numerals at the start of individual octave lines are positioned on
noteheads or accidentals, independently of your project-wide setting.

PROCEDURE

1. Select the octave lines whose numeral alignment relative to accidentals you want to
change. You can do this in Write mode and Engrave mode.

2. In the Properties panel, activate L position in the Octave Lines group.

Octave lines
Positions of octave lines 

591
Dorico 2.2.20



3. Choose one of the following options:

● Notehead

● Accidental

RESULT
The alignment of the numerals of the selected octave lines is changed. For example, if you
choose Accidental, the octave line numerals are aligned with the accidental on the first
noteheads to which the octave lines apply.

TIP

You can change the default alignment of all octave line numerals project-wide in the Horizontal
Position section of the Octave Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for octave lines on page 587

Changing the placement of octave lines relative to the staff
You can change the side of the staff on which individual octave lines appear.

PROCEDURE

1. Select the octave lines whose staff-relative placement you want to change. You can do this
in Write mode and Engrave mode.

2. In the Properties panel, activate Placement in the Octave Lines group.

3. Choose one of the following options:

● Above

● Below

RESULT
The selected octave lines appear above/below the staff.

Deleting octave lines
You can delete octave lines without deleting notes and other items.

PROCEDURE

1. In Write mode, select the octave lines you want to delete.

2. Press Backspace or Delete.

RESULT
The selected octave lines are deleted. Any notes to which the deleted octave lines previously
applied are shown at either concert pitch or transposed pitch, depending on your current setting
for the layout.

RELATED LINKS
Input methods for clefs and octave lines on page 219
Making layouts transposing/concert pitch on page 123
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Octave lines in Engrave mode
In Engrave mode, each octave line has three square handles. You can use these handles to move
the start/end of octave lines graphically, and to lengthen/shorten octave line hooks.

An octave line in Engrave mode

● The start handle moves the start of octave lines graphically. You can move this handle to
the right/left.

NOTE

When using the keyboard, you can also move this handle upwards/downwards. This moves
the whole octave line.

● The top end handle moves the end of octave lines graphically. You can move this handle to
the right/left.

● The bottom end handle changes the length of the hook. You can move this handle
upwards/downwards.

Lengthening/Shortening octave line hooks
You can change the length of individual octave line hooks, independently of your project-wide
setting.

PROCEDURE

1. In Engrave mode, select the hook handles on the octave lines whose hooks you want to
lengthen/shorten.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the handles in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

● Click and drag them upwards/downwards.

RESULT
The length of the selected octave line hooks is changed.

TIP

● Hook length in the Octave Lines group of the Properties panel is activated automatically
when you move octave line hooks. You can also use this property to lengthen/shorten
octave line hooks by changing the value in the value field.

Deactivating the property resets the selected octave lines to their default hook length.

Octave lines
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● You can change the default hook length for all octave lines project-wide by changing the
value for Octave line hook length, which you can find by clicking Advanced Options in
the Appearance section of the Octave Lines page in Engrave > Engraving Options.

Tucking index properties
The tucking index of notations determines their position relative to other notations in the vertical
stacking order when multiple notations exist at the same rhythmic positions.

In most published music, the order in which items appear relative to each other is consistent.
Dorico Pro uses established conventions to determine the position and placement of notations
automatically. For example, where slurs and tuplet brackets exist at the same positions, Dorico
Pro calculates their placement based on their relative lengths. If the slur is longer than the tuplet
bracket, the slur is placed outside the tuplet bracket; if the tuplet bracket is longer than the slur,
the slur is placed inside the tuplet bracket.

However, rules for the order and placement of articulations, slurs, tuplets, and octave lines
frequently vary, based on their lengths and musical context. Therefore, you can override the
automatic order and manually change the order in which they appear in specific contexts.

To allow you this flexibility, slurs, octave lines, and tuplets all have Tucking index properties in
their respective Properties panel groups.

NOTE

Articulations are considered alongside these notations when calculating the stacking order, but
do not have a tucking index property.

A Tucking index value of 0 positions items closest to notes. The higher the number, the further
away the item is positioned from notes in the stacking order.

Changing the vertical stacking order of octave lines
You can change the placement of individual octave lines relative to other objects in the vertical
stack by changing their tucking index value.

According to general convention, octave lines are placed outside all other objects, but there are
some instances where they can go inside other objects, for example, inside a slur if that slur is
longer than the octave line.

PROCEDURE

1. In Engrave mode, select the octave lines whose placement in the vertical stack you want to
change.

2. In the Properties panel, activate Tucking index in the Octave Lines group.

3. Change the value in the value field.
0 positions items closest to notes. The higher the number, the further the item is
positioned from notes in the stacking order.

RESULT
The placement of the selected octave lines in the vertical stacking order is changed.
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Cues are passages of music shown in instrumental parts that are played by a different player,
usually to help orientate players before entries or solos following a significant passage of rests.

Cues can also be used to assist with co-ordination or tuning between players, or to indicate
material that the player might be asked to double.

In Dorico Pro, you can input correctly formatted cues quickly using the cues popover. Cues are
automatically input into a new voice, with bar rests shown alongside cues to make sure the
player reading the cue understands that they do not play the cued music. Clefs are automatically
input in cues as required, including restorative clefs.

A cue in a violin part showing music from a Bassoon 1 part

Dorico Pro features dynamic cues that are linked to the original source material, meaning cues
are updated in real time if the source material changes.

The instrument whose music is included in a cue is known as the source instrument. The
instrument whose part contains a cue from another instrument is known as the destination
instrument.

RELATED LINKS
Inputting cues on page 268
Cue contents on page 601
Note spacing on page 381
Changing note spacing from specific points on page 385
Viewing options for cues on page 611

General placement and notation conventions for cues
Cues are usually notated using notes of a smaller size than normal notes, with the name of the
cued instrument indicated at the start of the passage.

It is generally accepted that full-sized rests are shown above/below cues to reinforce that the
player reading the cue does not play these notes.

Cues might exclude some notations that are present in the source instrument. However, cues
normally include slurs, articulations, and dynamics, as these often help the player reading the
cue to identify passages.

Depending on the register of the cued instrument and the range of each cue passage, clef
changes might also be needed at the start of cues.

Cues
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RELATED LINKS
Cue labels on page 602
Clef changes in cues on page 609
Notations in cues on page 605
Changing the notations included in cues on page 605

Rhythmic cues
Rhythmic cues only show the rhythm of the source instrument, whether it is pitched or
unpitched, and are positioned above the staff by default. By default, cues from unpitched
percussion source instruments are input as rhythmic cues.

Rhythmic cues do not show clef changes, accidentals, or ledger lines. They also do not show
octave transpositions in their cue labels, even when the destination instrument is octave
transposing. Their default position outside staff lines ensures they can never be misread as
containing pitched material.

You can change existing cues into rhythmic cues and vice versa. This causes cues that were
originally from pitched source instruments to show only the rhythm, which can be helpful when
multiple instruments play the same rhythm together but on different notes, such as in big band
music with large unison chords. In this context, showing the pitches of a single instrument in the
group could be misleading as the destination instrument might think this indicates a distinctive
melody. You can then change the cue label to include information about the instruments playing
the rhythm in the cue.

By default, cues from unpitched percussion source instruments are input as rhythmic cues. If you
want to save vertical space, you can change them to cues from unpitched percussion source
instruments. This positions them on the middle line of the staff by default.

You can change the default staff positions for rhythmic cues and cues from unpitched percussion
source instruments in the Rhythmic Cues and Unpitched Instruments sections of the Cues
page in Engrave > Engraving Options.

You can also change the staff position of rhythmic cues and cues from unpitched percussion
source instruments individually.

A rhythmic cue A cue from an unpitched percussion source

RELATED LINKS
Changing the text shown in cue labels on page 603
Changing the staff position of cues from unpitched percussion source instruments on page 597

Changing existing cues to rhythmic cues
Cues normally show pitched material played by a specific instrument. However, you can change
existing cues showing pitched material into rhythmic cues that only show the rhythm of the cued
music. This can be helpful for passages where many instruments play the same distinctive
rhythm together.

PROCEDURE

1. Select the cues you want to change into rhythmic cues. You can do this in Write mode and
Engrave mode.
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2. In the Properties panel, activate Rhythmic cue in the Cues group.

RESULT
The selected cues are shown as rhythmic cues. They are automatically positioned above the staff
according to your setting for Distance from space above staff in the Rhythmic Cues section of
the Cues page in Engrave > Engraving Options.

NOTE

Deactivating Rhythmic cue returns the selected cues back to normal cues. This includes cues
from unpitched percussion instruments that are automatically input as rhythmic cues.

If you deactivate Rhythmic cue for cues from unpitched percussion instruments, the cues are
positioned on the middle line of the staff by default.

RELATED LINKS
Inputting cues on page 268
Changing the text shown in cue labels on page 603

Changing the distance between rhythmic cues and the staff
You can change the distance between individual rhythmic cues and the staff, independently of
your project-wide setting.

PROCEDURE

1. Select the cue label of the rhythmic cues whose distance from the staff you want to
change. You can do this in Write mode and Engrave mode.

2. In the Properties panel, activate Distance in the Cues group.

3. Change the value in the value field.

RESULT
The position of the selected cues is changed according to the new value. For example, entering 0
positions rhythmic cues in the space immediately above the top line on the staff. Higher values
increase the distance between rhythmic cues and the staff.

TIP

You can change the default distance between all rhythmic cues and the top line of the staff
project-wide on the Cues page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for cues on page 601

Changing the staff position of cues from unpitched percussion
source instruments

You can change the staff position of cues from unpitched percussion source instruments
individually, independently of your project-wide setting.

By default, cues from unpitched percussion source instruments that are not rhythmic cues are
positioned on the middle line of staves.
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PROCEDURE

1. Select the cue label of the cues from unpitched percussion source instruments whose staff
position you want to change. You can do this in Write mode and Engrave mode.

2. In the Properties panel, activate Unpitched notes pos. in the Cues group.

3. Change the value in the value field.

RESULT
The staff position of the selected cues is changed according to the new value. For example, 0 is
the middle line of the staff, 4 is the top line of the staff, and -4 is the bottom line of the staff.

TIP

You can change the default staff position of all cues from unpitched percussion source
instruments project-wide on the Cues page in Engrave > Engraving Options.

EXAMPLE

Unpitched cue on the middle line of the staff
(default)

Unpitched cue at a higher staff position

RELATED LINKS
Project-wide engraving options for cues on page 601

Changing the octave of cues
You can change the octave in which cues are shown so the cue fits better on the staff of the
destination instrument. This can be useful if the source instrument plays in a significantly
different octave to the destination instrument.

PROCEDURE

1. In the music area, open the layout in which you want to change the octave of cues.

2. Select the cues whose octave you want to change. You can do this in Write mode and
Engrave mode.

3. In the Properties panel, activate Octave shift in the Cues group.

4. Change the value in the value field.

RESULT
The octave of the selected cues is changed. For example, 1 shifts the cue up one octave, and -1
shifts the cue down one octave.
If octave transpositions are shown in the cue labels, they are automatically updated.
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EXAMPLE

Cue with no octave change Cue with an octave above line

Hiding/Showing octave transpositions in cue labels
By default, octave transpositions are included in cue labels when you shift the octaves at which
cues are shown. You can hide/show octave transpositions in cue labels individually,
independently of your project-wide setting.

PROCEDURE

1. Select the cue labels in which you want to hide/show octave transpositions. You can do this
in Write mode and Engrave mode.

2. In the Properties panel, activate/deactivate Show octave transposition in the Cues group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
Octave transpositions are shown in the selected cue labels when the checkbox is activated, and
hidden when the checkbox is deactivated.
Deactivating the property returns cue labels to your project-wide setting.

TIP

You can show/hide octave transpositions in all cue labels project-wide on the Cues page in
Engrave > Engraving Options.

RELATED LINKS
Changing the information included in cue labels project-wide on page 602

Moving cues
You can move cues to new rhythmic positions after they have been input. This changes the
material shown in cues to reflect the material at the corresponding rhythmic positions in the
source instrument.

PROCEDURE

1. In Write mode, select the cues you want to move.

NOTE

When using the mouse, you can only move one cue at a time.

2. Move the cues, while maintaining their total durations, in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.
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● Click and drag the cue to the right/left, according to the rhythm in the source
instrument.

RESULT
If a single cue is selected, it is moved to the right/left, depending on the rhythm in the source
instrument.
If multiple cues are selected, they are moved to the right/left, according to the current rhythmic
grid value.

RELATED LINKS
Overlapping cues on page 607
Hiding/Showing cues in layouts on page 606

Lengthening/Shortening cues
You can change the length of cues after they have been input. This changes the material shown
in cues to reflect the material at the corresponding rhythmic positions in the source instrument.

PROCEDURE

1. In Write mode, select the cues you want to lengthen/shorten.

NOTE

When using the mouse, you can only lengthen/shorten one cue at a time.

2. Lengthen/Shorten the cues in any of the following ways:

● To lengthen them by the current rhythmic grid value, press Shift-Alt-Right Arrow.

● To shorten them by the current rhythmic grid value, press Shift-Alt-Left Arrow.

● Press Ctrl/Cmd-Shift-Alt-Right Arrow to lengthen a single cue to the next notehead
of the source instrument.

● Press Ctrl/Cmd-Shift-Alt-Left Arrow to shorten a single cue to the previous
notehead of the source instrument.

NOTE

● When multiple cues are selected, you can only lengthen/shorten cues by the
current rhythmic grid value.

● Key commands lengthen/shorten items by moving their end only.

● Click and drag the circular handle at the start/end of a single cue to the right/left.

RESULT
The selected cues are lengthened/shortened.

NOTE

You can lengthen cues so that they overlap with other existing cues, as multiple cues can exist at
the same rhythmic position. However, their stem directions are not automatically adjusted so you
might have to change them manually.

RELATED LINKS
Overlapping cues on page 607
Overriding default stem directions in single-voice cues on page 607
Moving cues on page 599

Cues
Lengthening/Shortening cues 

600
Dorico 2.2.20



Deleting cues
You can delete individual cues without deleting the corresponding notes in the source
instrument or other instruments containing the same cue.

PROCEDURE

1. In Write mode, select one of the following:

● The cues you want to delete.

● The signposts of cues you want to delete that are not shown in the current layout.

2. Press Backspace or Delete.

RESULT
The selected cues are deleted from all the layouts containing the affected instruments. For
example, deleting a cue in a piano part also deletes the cue from the piano staff in
corresponding full score layouts.

Project-wide engraving options for cues
You can find options for the project-wide appearance, content, and position of cues on the Cues
page in Engrave > Engraving Options.

The options on the Cues page allow you to change the size, appearance, placement, and precise
position of cues. You can also decide which notations are included in all cues, set the default
spacing of cues, and set the default staff position of rhythmic cues and cues from unpitched
percussion source instruments.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299
Note spacing on page 381
Changing existing cues to rhythmic cues on page 596
Rhythmic cues on page 596

Cue contents
The content of individual cues can appear differently in each layout, independently of other
layouts and without changing the source material, if you make changes in a layout that does not
contain the source instrument.

Music in cues is dynamically linked to the music in the source instrument. Any changes you make
to the source music are automatically shown in the cue, but you cannot change the pitch or
duration of notes within the cue. This ensures that cues are an accurate reflection of the notes
being played by the cued instrument.

You can make graphical changes to the music in cues without affecting the corresponding music
in the source instrument. For example, you can adjust the placement of slurs and the angles of
glissando lines, lengthen/shorten stems in cues, and respell accidentals. You can also change the
note spacing scale factor of cues for whole layouts and from specific points in individual layouts.

NOTE

Graphical changes to cues are layout-specific. For example, if you make changes to a cue within a
full score layout that also contains the source instrument, your changes to the cue affect the
corresponding material in the source instrument and other instruments with the same cue in the
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layout. However, if you make changes to a cue in a part layout that only contains the destination
instrument, the corresponding material in the part layout of the source instrument is not
affected.

It is also possible to change the enharmonic spelling of notes in cues in Engrave mode in the
same way as changing the enharmonic spelling of normal notes. If you respell notes in cues in
the part layout of the destination instrument, the spelling of notes in the source instrument is
not affected. For example, you can change the enharmonic spelling of notes in cues in
transposing instrument layouts to avoid double accidentals.

IMPORTANT

If you respell notes in cues in a layout that also contains the source instrument, the enharmonic
spelling is also changed in the source instrument.

RELATED LINKS
Respelling accidentals on page 163
Slurs in Engrave mode on page 879
Lengthening/Shortening stems on page 947
Note spacing on page 381
Note Spacing Change dialog on page 386
Changing note spacing from specific points on page 385

Cue labels
Cue labels usually indicate the source instrument from which the music is taken, but can also
include other information, such as the transposition interval for transposing instruments. This
information can help players identify both where the sound is coming from in the ensemble and
the type of sound to listen for.

By default, cue labels in Dorico Pro use abbreviated instrument names, exclude instrument
transpositions, include octave transpositions, and do not show an additional label at the end of
cues to indicate where players enter after cues. Additional labels showing “Play” at the end of
cues are sometimes used in jazz scores, where it is customary not to show bar rests alongside
cues. Showing additional labels at the ends of cues can also be useful in film music, where cues
are often included in parts as an option that the player might be asked to play.

You can change the information and text shown in cue labels both project-wide and on an
individual basis in Dorico Pro.

NOTE

If you want to hide/show cue labels at the start/end of cues individually, you can use the
following properties in the Cues group of the Properties panel:

● Start text applies to labels at the start of cues.

● End text applies to labels at the end of cues.

Changing the information included in cue labels project-wide
You can change the information included as text in cue labels project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Cues in the page list.

3. In the Cue Labels section, change any of the following options:
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● Instrument name in label

● Instrument pitch or transposition

● Octave transposition

● Additional label at end of cue

4. Click Apply, then Close.

RESULT
The information included in cue labels is changed project-wide.

TIP

You can also change cue labels individually. For example, if two instruments are playing in
unison, you can change the cue label that shows the name of one of the instruments to include
both instrument names.

Changing the text shown in cue labels
You can override the text shown in cue labels individually. For example, if two instruments are
playing in unison, you can change the cue label that shows the name of one of the instruments
to include both instrument names.

You can also show additional labels at the ends of individual cues, even if your project-wide
setting is to show no additional labels.

PROCEDURE

1. Select the cue labels whose text you want to override. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate the following properties, individually or together, in the
Cues group:

● Start text

● End text

3. Enter the text you want to be shown in the corresponding cue labels into each value field.
For example, to indicate that two violinists are playing the same material but an octave
apart, you might enter Vln.I & Vln.II coll’ottava in the value field for Start text.

4. Press Return.

RESULT
The cue labels of the selected cues are changed to show the text you entered.
Deactivating the properties returns the corresponding cue labels of the selected cues to their
default text.

NOTE

Deactivating properties permanently deletes any custom text entered.

Changing the placement of cue labels relative to the staff
You can change the placement of individual cue labels relative to the staff, independently of your
project-wide setting.
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PROCEDURE

1. Select the cue labels whose staff-relative placement you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Placement in the Cues group.

3. Choose one of the following options:

● Above

● Below

RESULT
The selected cue labels appear above/below the staff.

TIP

● Deactivating Placement returns the selected cue labels to their default placement.

● You can change the default placement of all cue labels relative to the staff project-wide on
the Cues page in Engrave > Engraving Options.

Moving cue labels graphically
You can move individual cue labels graphically without affecting the rhythmic positions of the
cue. You can move cue labels at the start and end of cues independently of each other.

PROCEDURE

1. In Engrave mode, select the cue labels you want to move.

2. Move the cue labels in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected cue labels are moved to new graphical positions.

TIP

Offset in the Cues group of the Properties panel is activated automatically when you move cue
labels.

● Offset X moves cue labels horizontally.

● Offset Y moves cue labels vertically.

You can also use this property to move cue labels by changing the values in the value fields. The
same property applies to cue labels both at the start and end of cues.

Deactivating the property resets the selected cue labels to their default positions.
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Notations in cues
It is beneficial to include musically significant notations from the source instrument in cues, as
they can help players identify the cued music more easily. However, only certain notations are
included in cues to avoid overloading players with too much information.

By default, Dorico Pro includes the following notations in cues:

● Slurs

● Articulations

● Ornaments

● Playing techniques

● Lyrics (for vocal music)

You can also include dynamics and text in cues, but these are not included by default as this
information is not usually required to help identify the cued material.

NOTE

Playing techniques that only indicate important information for the source instrument, such as
bowing marks for string players, are not included in cues.

To be included in cues, playing techniques must exist within the range of the cued material. For
example, slurs must begin and end within the cued material to be included in cues.

Similarly, pizzicato markings are not shown in cues if they are input before the first cued note.
However, pizzicato strings sound significantly different to bowed strings, so omitting this
information could prevent the player reading the cue from identifying it.

NOTE

If important playing technique information does not exist within the range of cued material, we
recommend that you include this information in the corresponding cue labels.

RELATED LINKS
Changing the text shown in cue labels on page 603

Changing the notations included in cues
You can change the notations included in individual cues, such as slurs and playing techniques,
independently of your project-wide settings.

PROCEDURE

1. Select the cue labels of the cues whose included notations you want to change. You can do
this in Write mode and Engrave mode.

2. In the Cues group of the Properties panel, activate the property for each notation that you
want to include in, or exclude from, the selected cues.

3. Activate/Deactivate the corresponding checkboxes.

RESULT
The corresponding notations are included in cues when the checkboxes are activated, and
excluded from cues when the checkboxes are deactivated.

NOTE

● Playing techniques that only indicate important information for the source instrument,
such as bowing marks for string players, are not included in cues.
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● You can change which notations are included in all cues project-wide on the Cues page in
Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for cues on page 601
Changing the text shown in cue labels on page 603

Hiding/Showing cues in layouts
You can input cues in any layout, but by default cues do not appear in full score layouts, as cues
are normally only shown in instrumental parts. You can hide/show cues in each layout in your
project independently of other layouts.

Cue signposts are shown in full score layouts by default in page view. In galley view, the cued
music appears in addition to cue signposts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show cues.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Players in the page list.

4. In the Cues section, activate/deactivate Show cues.

5. Click Apply, then Close.

RESULT
All cues in the selected layouts are shown when the checkbox is activated, and hidden when the
checkbox is deactivated.
If cues are hidden, signposts show where they begin.

NOTE

● You can hide individual cues in layouts where cues are shown, but you cannot show
individual cues in layouts where cues are hidden.

● You can hide/show cue signposts by choosing View > Signposts > Cues. Cue signposts are
shown when a tick appears beside Cues in the menu, and hidden when no tick appears.

Hiding cues individually
You can hide individual cues in layouts in which cues are shown, but you cannot show individual
cues in layouts where cues are hidden.

PROCEDURE

1. In the music area, open the layout in which you want to hide individual cues.

2. Select the cues you want to hide. You can do this in Write mode and Engrave mode.

3. In the Properties panel, activate Hide in the Cues group.

RESULT
The selected cues are hidden when Hide is activated. Signposts are shown at the positions of
each cue so you can always find them again. However, signposts are not printed by default.
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Deactivating Hide shows the selected cues again.

Stem direction in cues
Notes in cues normally have the same stem direction, as cues usually highlight lines containing
only one voice. Cues are shown by default with bar rests alongside them to indicate that the
player reading the cue does not play those notes.

If cues contain music in multiple voices, the original stem directions of the source music are
used. For single-voice cues, Dorico Pro determines the default stem direction depending on the
pitches in the cue. Stems point downwards when most notes in the cue are at positions below
the middle line of the staff, and upwards when most notes in the cue are at positions above the
middle line of the staff.

TIP

You can override the stem directions of notes in single-voice cues individually.

Overlapping cues
Sometimes it is helpful to give players multiple consecutive cues so they can follow passages of
music more easily. Dorico Pro allows cues to overlap in order to give you flexibility over how to
give useful information in cues to players.

However, the stem directions of cues are not automatically adjusted when they exist at the same
rhythmic position as other cues. For example, if you want to show a melody passing from Violin 1
to Violin 2 that requires the two cues to overlap, and both instruments are shown in up-stem
voices by default, then the two cues appear with up-stem notes.

You can override the default stem directions of cues individually to make overlapping cues easier
to read.

Default stem directions in two overlapping cues Overridden stem directions in the cue containing
lower notes so that its notes are down-stem

Overriding default stem directions in single-voice cues
You can override the default stem directions of individual single-voice cues.

PROCEDURE

1. In the music area, open the layout in which you want to override the default stem direction
of selected cues.

2. Select the cue labels or cue signposts of the cues whose stem direction you want to
change. You can do this in Write mode and Engrave mode.

3. In the Properties panel, activate Voice direction in the Cues group.

4. Choose one of the following options:

● Force stems up

● Force stems down
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RESULT
The stem direction of all notes in the selected cues is changed.
Deactivating Voice direction returns the selected cues back to their default stem direction.

Ties in cues
If cues begin in the middle of sustained notes, ties are shown joining to the first note in cues.
Similarly, if cues end in the middle of sustained notes, ties are shown proceeding from the final
notes in cues.

For monophonic instruments, these ties are normally positioned correctly by default. However, in
complex cases, such as cues involving chords, the positions of these ties can require some
adjustment.

You can edit ties that start before/end after cues in the same way as normal ties in Engrave
mode.

RELATED LINKS
Changing the position/shape of ties on page 973

Rests in cues
If cues start/end partway through bars, they are padded with cue-sized rests up to bar
boundaries or up to the next played entry, whichever comes first. This ensures it is clear to the
player how the rhythm of the cue fits within the current time signature and how it relates to their
existing material.

By default, full-sized bar rests also appear throughout cued passages. This makes it clear that the
performer does not play the cued notes.

Full-sized bar rests are automatically positioned according to the stem direction of the notes in
the cue. If cues use up-stem notes, bar rests are positioned below cued notes. If cues use down-
stem notes, bar rests are positioned above the cued notes.

You can choose not to show bar rests alongside cues. For example, this can be appropriate in
some jazz scores, or in scores where the cues are provided as potential passages for doubling.

TIP

You can adjust the vertical position of full-sized bar rests individually using Rest pos. in the
Notes and Rests group of the Properties panel.

RELATED LINKS
Moving rests vertically on page 866

Hiding/Showing padding rests in cues
You can hide/show padding rests around individual cues. Padding rests fill up bars when cues
start/end partway through bars, so that the full duration of each bar is clear.

PROCEDURE

1. Select the cue labels or cue signposts of the cues whose padding rests you want to hide/
show. You can do this in Write mode and Engrave mode.

2. In the Properties panel, activate/deactivate Hide rests around cue in the Cues group.
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RESULT
Padding rests around the selected cues are hidden when Hide rests around cue is activated, and
shown when it is deactivated.

RELATED LINKS
Implicit vs. explicit rests on page 860

Hiding/Showing bar rests in cues
You can hide/show bar rests alongside all cues in each flow in your project.

PROCEDURE

1. Press Ctrl/Cmd-Shift-N to open Notation Options.

2. In the Flows list, select the flows in which you want to hide/show bar rests.
By default, only the current flow is selected when you open the dialog.

3. Click Rests in the page list.

4. In the Rests in additional voices section, choose one of the following options for Bar
rests in cues:

● Show bar rests

● Omit bar rests

5. Click Apply, then Close.

RESULT
Bar rests alongside cues are hidden/shown in all layouts in the selected flows in your project.

RELATED LINKS
Moving rests vertically on page 866

Clef changes in cues
If the music for the source instrument is in a different clef from the destination instrument,
Dorico Pro automatically inputs a clef change at the start of cues to match the clef used by the
source instrument, and a restorative clef change at the end of cues to match the original clef
used by the destination instrument.

Clef changes at the start of cues are positioned differently to normal clef changes.

Cues starting at the beginning of bars
Clef changes appear to the right of barlines.
Restorative clef changes at the ends of cues are positioned like normal clef changes.

Cues crossing system breaks
Original clefs of destination parts are shown in their usual positions at the start of
new systems.
Clefs required for cues appear immediately before the first note of the new system,
to the right of key signatures and time signatures.

When there are multiple adjacent cues, clef changes are created as needed:

● If two adjacent cues use the same clef that is different than the clef in the destination
instrument, a single clef change appears at the start of the first cue, with a restorative clef
at the end of the second cue.

● If cues overlap, and the second cue requires a different clef than the first, Dorico Pro
creates a clef change at the start of the second cue.
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● If there are two adjacent cues, the first of which uses a different clef than the destination
instrument, and the clef property for the second cue is set to None, then the clef change
that restores the destination instrument’s original clef appears at the end of the first cue.

You can override this automatic behavior for individual clefs using either Concert clef or
Transposed clef in the Cues group of the Properties panel, depending on whether the layout
currently open in the music area uses concert or transposed pitch.

Dorico Pro can show the following clefs in cues:

● None

● Treble

● Alto

● Tenor

● Bass

NOTE

● If you select None, the clef of the destination instrument is used instead of the clef of the
source instrument.

● Any clef changes that occur in the source instrument in the middle of cued passages are
not included in the cue in the destination instrument.

Changing the clef shown in cues
You can change the clef shown in individual cues, independently of your project-wide settings.

You can show different clefs for the same cue in each layout in which it appears. For example,
you can show a cue with a treble clef in a full score layout but with a bass F clef in the
corresponding part layout.

PROCEDURE

1. In the music area, open the layout in which you want to change the clef shown in cues.

2. Select the cues whose clef you want to change. You can do this in Write mode and Engrave
mode.

3. In the Properties panel, activate one of the following properties in the Cues group:

● Concert clef: shown if the layout uses concert pitch

● Transposed clef: shown if the layout uses transposed pitch

4. Select one of the following clefs from the menu:

● None: uses the clef of the destination instrument instead of the clef of the source
instrument.

● Treble

● Alto

● Tenor

● Bass

The same clefs are available for each property.

RESULT
The clef shown in the selected cues is changed.
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TIP

You can change whether the clef of the source instrument or destination instrument is used in all
cues project-wide on the Cues page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for cues on page 601

Viewing options for cues
You can highlight cues and/or show cued material in a different color to normal notes in your
project to help you identify cues more easily as you are working.

NOTE

In layouts where cues are not shown, cues are indicated by signposts. You can hide/show cue
signposts by choosing View > Signposts > Cues. Cue signposts are shown when a tick appears
beside Cues in the menu, and hidden when no tick appears.

RELATED LINKS
Signposts on page 281
Hiding/Showing cue note colors on page 612

Hiding/Showing cue highlights
You can hide/show highlights on bars where cues exist, which can help you get an overview of
where you have already added cues and which instruments are used as the source of cues.

Bars containing cues on destination instrument staves are shown with a translucent yellow
highlight, and the corresponding bars on the source instrument staves are shown with a
translucent blue highlight.

As you zoom out, the highlights become more opaque. This is especially useful when viewing full
score layouts in galley view.

PREREQUISITE
Cues are shown in the current layout. If cues are not shown, no highlights appear and cues are
only indicated by signposts.

PROCEDURE

● Choose View > Highlight Cues.

RESULT
Highlights on bars containing cues are shown when a tick appears beside Highlight Cues in the
menu, and hidden when no tick appears.

EXAMPLE
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Hiding/Showing cue note colors
You can show the material in cues, including notes and rests, in gray to help you identify cues.
Cued material cannot be edited directly.

PREREQUISITE
Cues are shown in the current layout. If cues are not shown, they are only indicated by signposts.

PROCEDURE

● Choose View > Note and Rest Colors > Cues.

RESULT
Material in cues appears gray when a tick appears beside Cues in the menu. When no tick
appears, they follow any other note and rest color settings you have selected.

EXAMPLE
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Dynamics indicate the loudness of the music, and can be combined with other instructions to
give the performer a detailed understanding of how to perform the music, while also leaving
room for interpretation.

Dynamics can indicate an immediate change in volume or a gradual change over a specified
duration. By default, they are placed below the staff for instruments and above the staff for
voices.

You can add qualifying and expressive text to dynamics that can give stylistic direction context
alongside the volume level, for example,  espressivo indicates that a passage is played loudly but
also with expressive feeling.

While almost all expression text is written in italics, dynamics such as  and  use a bold italic
font.

RELATED LINKS
Input methods for dynamics on page 208
Positions of dynamics on page 614

Types of dynamics
Dorico Pro categorizes dynamics into four groups.

Immediate dynamics

Immediate dynamics apply to the note to which they are attached until the next dynamic
marking, and indicate an immediate change from any previous dynamic. Immediate dynamics
include dynamic symbols, such as  or , and qualifying text, such as subito or molto.

Gradual dynamics and hairpins

Gradual dynamics are often shown as hairpins but can also be shown using text. In Dorico Pro,
you can show gradual dynamic text in the following ways:

● cresc. or dim.: abbreviated text with no continuation line

● cresc... or dim...: abbreviated text with a dotted continuation line

● cre-scen-do or di-mi-nuen-do: the full word spread out across the duration of the gradual
dynamic

Gradual dynamics can also have qualifying text, such as poco, molto, poco a poco, and niente.

In Dorico Pro, a hairpin can be shown as messa di voce, which shows a pair of hairpins. In some
cases, this is easier than having separate lines for each half of the pair.

Force/Intensity of attack

These dynamics, such as  and , indicate that a note has a stronger attack than is usually
expected for the dynamic, similar to an accent articulation.
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Combined dynamics

Combined dynamics, such as  or –, specify a sudden change of dynamic.

You can create custom combined dynamics in Dorico Pro, and control the intensity of each
dynamic in the pair, in the Combined Dynamics section of the Dynamics panel. For example, you
can make dynamics such as , –, and .

RELATED LINKS
Gradual dynamics on page 624

Project-wide engraving options for dynamics
You can find options for the project-wide appearance and position of dynamics on the Dynamics
page in Engrave > Engraving Options.

The options on the Dynamics page allow you to change the appearance of dynamics and
gradual dynamics, and their default positions relative to noteheads, barlines, and the ends of
systems.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Positions of dynamics
Dynamics are placed below the staff for instruments, where they can be read alongside the
notes, and above the staff for voices. This way, they do not clash with lyrics placed below the
staff, and are still close enough to the notes to be read simultaneously.

Immediate dynamics, such as  or , are centered on the notehead to which they apply. The
beginnings of gradual dynamics are centered on the notehead from which they begin, or
immediately after an immediate dynamic at the same position. The ends of gradual dynamics are
centered on the notehead at which they end, or immediately before an immediate dynamic at
the same position.

The placement of dynamics relative to the staff varies, depending on their function and the type
of player. For example, dynamics are placed below instrumental staves and above vocal staves by
default. This ensures dynamics are kept as close to the staff as possible for legibility but are not
placed between noteheads and lyrics on vocal staves. For grand staff instruments, such as piano
or harp, dynamics are usually placed between the two staves, but can be placed both above and
below when each staff requires separate dynamics.

In general, dynamics are not placed within the staff, as hairpins in particular become very hard to
read. They are also not usually placed within tuplet brackets. Dynamics are placed outside of
notations such as slurs, which must be kept close to noteheads, but inside pedal lines, which can
be placed further from noteheads and still be clearly understood.

You can move dynamics to different rhythmic positions in Write mode. They snap to noteheads
and are positioned by default according to your settings in Engraving Options.

You can move dynamics graphically in Engrave mode; however, this does not change the
rhythmic positions to which they are attached.

You can change the default positions of all dynamics project-wide, and their positions relative to
beats, barlines, system ends, the staff, and other objects on the Dynamics page in Engrave >
Engraving Options.
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RELATED LINKS
Project-wide engraving options for dynamics on page 614
Moving dynamics rhythmically on page 616
Moving dynamics graphically on page 617

Changing the placement of dynamics relative to the staff
By default, dynamics are placed below the staff for instruments and above the staff for voices.
You can change the placement of individual dynamics relative to the staff, for example, to have
different dynamics above and below the staff in multiple-voice contexts.

PROCEDURE

1. Select the dynamics whose staff-relative placement you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Placement in the Dynamics group.

3. Choose one of the following options:

● Above

● Below

RESULT
The placement of the selected dynamics is changed.

Changing the horizontal beat-relative position of dynamics
You can position individual dynamics before or after the beat.

PROCEDURE

1. Select the dynamics whose position relative to the beat you want to change. You can do
this in Write mode and Engrave mode.

2. In the Properties panel, activate Beat-relative position in the Dynamics group.

3. Choose one of the following options:

● Before

● After

EXAMPLE

A dynamic positioned before the beat A dynamic positioned after the beat
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Changing the alignment of immediate dynamics relative to
noteheads

Immediate dynamics, such as  and , are usually horizontally aligned with the optical center
of noteheads. However, you can change the horizontal alignment of immediate dynamics
individually, independently of your project-wide setting.

PROCEDURE

1. Select the dynamics whose alignment relative to noteheads you want to change. You can
do this in Write mode and Engrave mode.

2. In the Properties panel, activate Text alignment in the Dynamics group.

3. Choose one of the following options:

● Align optical center with notehead

● Left-align with notehead

● Align optical center with left of notehead

RESULT
The alignment of the selected immediate dynamics is changed.

TIP

You can change the default alignment of all immediate dynamics relative to noteheads project-
wide in the Horizontal Position section of the Dynamics page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for dynamics on page 614

Moving dynamics rhythmically
You can move dynamics to new rhythmic positions after they have been input.

NOTE

● You can only move dynamics to existing noteheads.

● If you want to move a single dynamic within a group, you must click and drag it with the
mouse. If you use the key commands, the whole group is moved.

PROCEDURE

1. In Write mode, select the dynamics you want to move.

NOTE

When using the mouse, you can only move one dynamic rhythmically at a time.

2. Move the dynamics to the next/previous notehead on the staff in any of the following
ways:

● Press Alt-Right Arrow to move them to the right.
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● Press Alt-Left Arrow to move them to the left.

● Click and drag the dynamic to the right/left.

RESULT
The selected dynamics are moved to noteheads to the right/left along the staff.

Moving dynamics graphically
You can move dynamics graphically, without changing the rhythmic positions to which they
apply. When you select hairpins in Engrave mode, three adjustment handles appear at each end.
You can use these handles to lengthen/shorten gradual dynamics graphically.

PROCEDURE

1. In Engrave mode, select one of the following that you want to move:

● Immediate dynamics or whole gradual dynamics

● Individual handles on gradual dynamics

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the dynamics or handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected dynamics or handles are moved graphically, without affecting the rhythmic
positions to which they are attached.

TIP

The following properties in the Dynamics group of the Properties panel are activated
automatically when you move dynamics in the corresponding directions:

● Start offset moves immediate dynamics and the start of gradual dynamics. X moves them
horizontally, Y moves them vertically.

● End offset moves the end of gradual dynamics. X moves them horizontally, Y moves them
vertically.

For example, if you move a whole gradual dynamic upwards, both handles are moved so both
properties are activated. You can also use these properties to move dynamics graphically by
changing the values in the value fields.

Deactivating the properties resets the selected dynamics to their default positions.
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RELATED LINKS
Lengthening/Shortening gradual dynamics and groups of dynamics on page 625

Aligning dynamics
You can graphically align individually selected dynamics in a row without grouping/ungrouping
them, for example, if system breaks in part layouts are different to the full score layout and so
require parts of different groups of dynamics to be aligned, but you do not want to change their
grouping.

PROCEDURE

1. In Engrave mode, select the dynamics you want to align.

2. Choose Edit > Dynamics > Align Dynamics. You can also choose this option from the
context menu.

RESULT
The selected dynamics are aligned in a row with the dynamic within the selection that was
furthest from the staff. This does not affect their grouping or their alignment in other layouts.

General placement conventions for hairpins relative to barlines
In Dorico Pro, the ends of hairpins align with the left edge of the note to their right.

Hairpins that end on the first note of a bar extend across the preceding barline in certain cases.

● If there is not an immediate dynamic on the first note in the next bar.

● If there is a time signature or key signature change at the barline which increases the gap
between the end of the current bar and the first note in the new bar.

Dorico Pro avoids hairpins overlapping barlines by a small amount, as this is less visually clear.
However, this means that the same dynamic phrase on two different staves can appear
differently if one of the staves does not have the barline extending below it.

You can change this default behavior and stop all hairpins project-wide from crossing barlines if
the hairpin ends on the first note in the next bar. This ensures all applicable hairpins appear the
same length. You can also change the minimum distance before hairpins are allowed to extend
beyond barlines.

The ends of the two hairpins are not aligned despite their duration being identical, as the barline does not
extend to the bottom staff of the system.
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Changing the project-wide position of hairpins relative to barlines
You can change whether all hairpins cross barlines when they end on the first note in the next
bar project-wide. You can also change the minimum distance before hairpins are allowed to
extend beyond barlines.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Dynamics in the page list.

3. In the Gradual Dynamics section, click Advanced Options.

4. Choose one of the following options for Hairpins ending at beginning of note at start of
bar:

● Do not cross barline

● Allow to cross barline

5. Optional: In the Horizontal Position section, change the value for Minimum distance to
right of barline to allow dynamic to cross barline.

6. Click Apply, then Close.

Showing dynamics in parentheses
You can show individual dynamics in parentheses, for example, to show editorial dynamics that
were not in the original manuscript.

PROCEDURE

1. Select the dynamics you want to appear parenthesized. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Parenthesized in the Dynamics group.

RESULT
Each of the selected dynamics is shown in parentheses individually.
Deactivating Parenthesized removes parentheses from the selected dynamics.

Erasing the background of dynamics
You can erase the background of individual dynamics, for example, to ensure the dynamic
remains legible when crossing barlines. You can erase the backgrounds of all types of dynamics.

PROCEDURE

1. In Engrave mode, select the dynamics whose backgrounds you want to erase.

2. In the Properties panel, activate Erase background in the Dynamics group.

RESULT
The backgrounds of the selected dynamics erase whatever is behind them.
Deactivating Erase background returns the selected dynamics to the default non-erased
background.
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EXAMPLE

Dynamic with non-erased background Dynamic with erased background

AFTER COMPLETING THIS TASK
You can change the padding between dynamics and each edge of their erased areas.

Changing the erasure padding of dynamics
You can change the erasure padding of individual dynamics, including changing the padding
between dynamics and each edge of their erased areas independently.

Erasure padding considers the prefix/suffix separately from immediate dynamics and also takes
into account ascenders/descenders in the text. This can cause the erasure padding to appear
larger below the dynamic than above, such as for “espressivo” due to the “p”. In such cases, you
can change the padding on the affected edge to make the padding appear symmetrical.

PROCEDURE

1. In Engrave mode, select the dynamics whose erasure padding you want to change.

2. In the Properties panel, activate the Erasure padding properties, individually or together,
in the Dynamics group.

● L changes the padding between dynamics and their left edge.

● R changes the padding between dynamics and their right edge.

● T changes the padding between dynamics and their top edge.

● B changes the padding between dynamics and their bottom edge.

3. Change the values in the value fields.

RESULT
Increasing the values increases the padding, decreasing the values decreases the padding. This
also affects the area considered for collision avoidance.

TIP

You can change the default erasure padding of all dynamics project-wide in the Appearance
section of the Dynamics page in Engrave > Engraving Options. However, this does not allow
you to change the padding of each edge independently.

Copying dynamics
You can copy dynamics to other rhythmic positions after they have been input. You can select
dynamics on a single staff to copy to another single staff, or you can select dynamics across
multiple staves to copy across the same number of staves.

PROCEDURE

1. In Write mode, select the dynamics you want to copy.

Dynamics
Copying dynamics 

620
Dorico 2.2.20



TIP

If you want to copy many dynamics or, for example, just gradual dynamics, you can use a
filter.

2. Press Ctrl/Cmd-C to copy the dynamics.

3. Select the notehead at the rhythmic position to which you want to copy the dynamics.

4. Press Ctrl/Cmd-V to paste the dynamics.

RESULT
The selected dynamics are pasted to new rhythmic positions. If you copied dynamics to other
staves at the same rhythmic position as the original dynamics, the dynamics on all staves are
automatically linked.
If you selected multiple dynamics at different rhythmic positions, their new positions reflect their
original rhythmic spacing.

TIP

● You can also copy dynamics without adding them to your clipboard by selecting them and
Alt-clicking each notehead to which you want to copy the selected dynamics.

● If you want to copy dynamic phrases immediately after where they were originally input,
you can select them and press R. If you select a single immediate dynamic, it is copied to
the same position.

RELATED LINKS
Dynamics linked across multiple staves on page 633
Filters on page 278

Deleting dynamics
You can delete dynamics from your project. If you delete some but not all dynamics from a group
that is linked to dynamics on other staves, all equivalent linked dynamics are also deleted.

PROCEDURE

1. In Write mode, select the dynamics you want to delete.

2. Press Backspace or Delete.

RESULT
The selected dynamics are deleted. If you delete immediate dynamics immediately before/after
hairpins, the length of hairpins can adjust automatically, depending on the context.

NOTE

Deleting dynamics that are linked to other staves can cause the selected dynamics to be deleted
from all linked staves as well. If you do not select and delete all dynamics in the group, the
selected dynamics are also deleted from all linked staves. However, if you select and delete the
whole group of dynamics from a single staff, those dynamics are not deleted from other staves.

RELATED LINKS
Groups of dynamics on page 632
Dynamics linked across multiple staves on page 633
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Voice-specific dynamics
You can input different dynamics into each voice independently in multiple-voice contexts.

Inputting voice-specific dynamics allows you to show different dynamics for multiple voices on a
staff, or to highlight an inner melody voice in a piano texture. They change the dynamics of each
voice in playback.

During step input, voice-specific dynamics are added to the voice indicated by the stem direction
of the quarter note symbol beside the caret.

By default, dynamics apply to all voices on a staff if input without pressing Alt. If you want each
voice to have their own dynamic in playback as well as in the score, press Alt when inputting
dynamics for every voice on a staff.

RELATED LINKS
Input methods for dynamics on page 208

Niente hairpins
Niente markings at the start/end of gradual dynamics indicate that the dynamic either increases
from, or decreases to, silence.

This effect works very well on strings and singers with vowels, but it cannot always be played
literally. For example, singers with words beginning with consonants cannot begin from silence,
nor can reed and brass instruments, as they have to achieve a certain air pressure before a note
sounds.

Niente markings can be shown in two ways: as a circle at the end of a hairpin, and as text directly
before or after a hairpin. You can input both types of niente markings in Dorico Pro using the
dynamics popover and by clicking niente in the Gradual Dynamics section of the Dynamics
panel.

TIP

You can turn existing hairpins into niente hairpins by selecting them and clicking niente in the
Gradual Dynamics section of the Dynamics panel, or by activating Niente in the Dynamics
group of the Properties panel.

EXAMPLE

A niente shown as Circle on hairpin A niente shown as Text

RELATED LINKS
Lengthening/Shortening gradual dynamics and groups of dynamics on page 625
Input methods for dynamics on page 208

Changing the appearance of individual niente hairpins
You can show niente hairpins in two ways in Dorico Pro, and you can change how they appear
individually, independently of your project-wide setting.
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PROCEDURE

1. Select the hairpins whose niente style you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Niente style in the Dynamics group.

3. Choose one of the following options:

● Circle on hairpin

● Text

RESULT
The niente style of the selected hairpins is changed.

TIP

You can change how all niente hairpins appear project-wide in the Gradual Dynamics section of
the Dynamics page in Engrave > Engraving Options.

EXAMPLE

A niente shown as Circle on hairpin A niente shown as Text

RELATED LINKS
Project-wide engraving options for dynamics on page 614

Expressive text
Expressive text adds further detail to a dynamic than simply its volume level, and can help guide
how a player performs a note or phrase.

In Dorico Pro, expressive text, such as “sim.”, poco, molto, or subito, must accompany a dynamic
level, such as  or .

NOTE

You cannot input expressive text on its own. However, you can hide the immediate dynamic that
follows/precedes it.

You can input expressive text by entering it into the dynamics popover alongside an immediate
dynamic or by clicking available options in the Immediate Dynamics section of the Dynamics
panel. You can also add it to existing dynamics by entering the expressive text you want into one
of the following properties in the Dynamics group of the Properties panel:

● Prefix adds expressive text before existing dynamics.

● Suffix adds expressive text after existing dynamics.

RELATED LINKS
Hiding immediate dynamics on page 624
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Adding expressive text to existing dynamics
You can add expressive text to dynamics after they have been input, for example, if you want to
add “sim.” instead of repeating dynamics across multiple phrases.

PROCEDURE

1. Select the dynamics to which you want to add expressive text. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, activate the following properties, individually or together, in the
Dynamics group:

● Prefix adds expressive text before the existing dynamic.

● Suffix adds expressive text after the existing dynamic.

3. Enter the expressive text you want to add into the corresponding value field.

4. Press Return.

RESULT
The text you entered is added to the selected dynamics as expressive text.
Deactivating the properties removes the corresponding expressive text from the selected
dynamics.

NOTE

Deactivating properties permanently deletes any custom text entered.

RELATED LINKS
Niente hairpins on page 622
Input methods for dynamics on page 208

Hiding immediate dynamics
You can hide immediate dynamics such as  and , for example, if you only want to show an
expressive text, such as “sim.”, without the immediate dynamic that accompanies it.

PROCEDURE

1. Select the immediate dynamics you want to hide. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Hide intensity marking in the Dynamics group.

RESULT
The selected immediate dynamics are hidden. If no other dynamic exists at their rhythmic
position, they are indicated by signposts so you can always find them again. However, signposts
are not printed by default.
Deactivating Hide intensity marking shows the selected immediate dynamics again.

Gradual dynamics
Gradual dynamics indicate a change in volume that happens incrementally over the specified
duration. By default, gradual dynamics appear either as hairpins or as text instructions, such as
cresc. or dim..

You can change the appearance and placement of gradual dynamics individually, independently
of your project-wide settings, using properties in the Dynamics group of the Properties panel.
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For example, you can change the type of gradual dynamics so that they are shown as a hairpin
with a single direction or as a messa di voce pair of hairpins with two directions.

You can change the style of gradual dynamics to show them in any of the following ways:

Hairpin cresc./dim. cresc…. cre-scen-do

TIP

You can also change the line style of hairpins using Hairpin line style in the Dynamics group of
the Properties panel.

If you enter two or more consecutive hairpins of the same direction separated by immediate
dynamics into the dynamics popover, you can show them as a single, continuous hairpin across
the immediate dynamics by activating Hairpin shown as continuation and the corresponding
checkbox in the Dynamics group of the Properties panel in Engrave mode.

Hairpin not shown as continuation Hairpin shown as continuation

You can also change the diminuendo style of gradual dynamics using the cresc./dim. style so
they show either “diminuendo” or “decrescendo”, and you can change the continuation line style
of gradual dynamics using the cresc…. style.

In Engrave mode, hairpins have three square handles at the start/end:

● The middle handles at the start/end change the offset position of the start/end of the
hairpin.

● The pair of outer handles at the start/end adjusts the aperture of the start/end of the
hairpin.

A hairpin with the start middle handle selected in Engrave mode

You can use these handles to change the angle of hairpins.

RELATED LINKS
Types of dynamics on page 613
Changing the angle of hairpins on page 627
Changing the aperture of hairpins on page 628

Lengthening/Shortening gradual dynamics and groups of dynamics
You can change the length of gradual dynamics and groups of dynamics after they have been
input.

NOTE

You can only lengthen/shorten one gradual dynamic or group of dynamics at a time.
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PROCEDURE

1. In Write mode, select one of the following that you want to lengthen/shorten:

● A single gradual dynamic

● A single gradual dynamic in a group of dynamics

2. Lengthen/Shorten the gradual dynamic or groups of dynamics in any of the following
ways:

● To lengthen them by the current rhythmic grid value or to the next notehead,
whichever is closer, press Shift-Alt-Right Arrow.

● To shorten them by the current rhythmic grid value or to the previous notehead,
whichever is closer, press Shift-Alt-Left Arrow.

● To lengthen them to the next notehead, press Ctrl/Cmd-Shift-Alt-Right Arrow.

● To shorten them to the previous notehead, press Ctrl/Cmd-Shift-Alt-Left Arrow.

NOTE

When using the keyboard, you can only move the end of dynamics. You can move
the start of dynamics by moving the whole dynamic, or by clicking and dragging the
start handle.

● Click and drag the circular handle at the start/end.

RESULT
Individual gradual dynamics are lengthened/shortened either according to the rhythmic grid or
to next/previous noteheads.
Dynamic groups are lengthened/shortened proportionally by lengthening/shortening the
gradual dynamics and moving any other type of dynamic in the group. This retains the relative
durations of the gradual dynamics in the group.
In the example, the  at the end moves two quarter notes to the right, but the  in the middle
only moves one quarter note to the right. This keeps the lengths of the gradual dynamics equal.

EXAMPLE

Original dynamic phrase Lengthened dynamic phrase

RELATED LINKS
Groups of dynamics on page 632
Positions of dynamics on page 614
Ungrouping dynamics and removing dynamics from groups on page 633
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Changing the angle of hairpins
By default, hairpins are horizontal and are automatically adjusted to avoid collisions with other
objects, such as noteheads and slurs. You can change the angle of individual hairpins as required
for your music.

NOTE

Changing only the start offset position with the keyboard or activating Start offset only changes
the position of the hairpin relative to the staff, not its angle. You must change the end offset
position or activate End offset as well to change the angle of hairpins.

Dragging handles with the mouse changes the angle straight away.

PROCEDURE

1. In Engrave mode, select the middle handles of the hairpins whose angle you want to
change.

TIP

● The hairpins you select do not have to be the same direction, or on the same staff.

● You can show handles on all items, not just selected items, by choosing Engrave >
Show Handles > Always. This can make it easier to select individual handles on
multiple items.

2. Move the handles in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

● Click and drag them upwards/downwards.

RESULT
The angle of the selected hairpins is changed. Each end can be moved independently of the
other.

TIP

The following properties in the Dynamics group of the Properties panel are activated
automatically when you move the corresponding handles on hairpins vertically:

● Start offset Y moves the start handles of hairpins vertically.

● End offset Y moves the end handles of hairpins vertically.

For example, if you move a whole hairpin upwards, both handles are moved so both properties
are activated. You can also use these properties to change the angles of hairpins by changing the
values in the value fields.

Deactivating the properties resets the selected hairpins to their default positions.
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Changing the aperture of hairpins
The change in volume indicated by individual hairpins is shown in the distance between the two
lines that make up hairpins at their apertures. You can change the aperture of hairpins
individually.

Hairpins typically have a closed end and an open end. If the hairpin crosses a system or frame
break, the closed end can appear with a small gap so that the hairpin is not misread as two
separate hairpins.

In Dorico Pro, you can use the pair of outer handles at the start/end of hairpins in Engrave mode
to change the aperture. These handles are linked and mirror each other: moving one handle also
moves the other handle by the same amount, but in the opposite direction. This ensures that
hairpins remain symmetrical.

A hairpin with the outer handle selected in Engrave mode

PROCEDURE

1. In Engrave mode, select one of the outer handles of the hairpins whose aperture you want
to change.

TIP

● The hairpins you select do not have to be the same direction, or on the same staff.

● You can show handles on all items, not just selected items, by choosing Engrave >
Show Handles > Always. This can make it easier to select individual handles on
multiple items.

2. Change the distance between the handles in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

● Click and drag them upwards/downwards.

RESULT
The apertures of the selected hairpins are changed.

TIP

● You can also change the aperture of individual hairpins by activating Hairpin open
aperture and/or Hairpin closed aperture in the Dynamics group of the Properties panel.

Increasing the value makes the corresponding aperture wider. Decreasing the value
makes the corresponding aperture narrower.

● You can find options to set minimum and maximum values for the width of hairpin
apertures project-wide, including for hairpins across system and page breaks, by clicking
Advanced Options in the Hairpins subsection of the Gradual Dynamics section of the
Dynamics page in Engrave > Engraving Options.
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EXAMPLE

A diminuendo that goes across a system break:
aperture at the start is open, aperture at the end is
closed. It appears slightly open to indicate the
diminuendo continues after the system break.

The diminuendo continues onto a new system:
aperture at the start is open, aperture at the end is
closed.

Hiding/Showing flared ends on hairpins
Flared ends are usually shown at the end of crescendo hairpins and indicate a sudden burst in
volume at the end of the crescendo. You can hide/show flared ends on any hairpin.

NOTE

You can only show flared ends on hairpins with solid lines.

PROCEDURE

1. Select the hairpins on which you want to hide/show flared ends. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, activate/deactivate Flared end in the Dynamics group.

RESULT
A flared end is shown on the selected dynamics when Flared end is activated, and hidden when
it is deactivated.

EXAMPLE

Crescendo hairpin with flared end hidden Crescendo hairpin with flared end shown

Changing the size of flared ends on hairpins
You can change the height and width of flared ends on individual hairpins.

PROCEDURE

1. In Engrave mode, select the flared hairpins whose flare size you want to change.

2. In the Properties panel, activate Flare size in the Dynamics group.

3. Change the value for W to change the width of the flared ends.

4. Change the value for H to change the height of the flared ends.

RESULT
Increasing the W value makes the selected flared ends wider by starting their angle earlier in the
hairpin, decreasing the value makes the selected flared ends narrower.
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Increasing the H value makes the selected flared ends taller, decreasing the value makes them
shorter.
Changing the values independently of each other changes the angle of the flared ends. For
example, increasing the W value without changing the H value makes the angle shallower.

TIP

You can change the default design and size of all flared hairpins project-wide in the Gradual
Dynamics section of the Dynamics page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for dynamics on page 614
Changing the aperture of hairpins on page 628

Adding poco a poco text to gradual dynamics
You can add poco a poco text to individual gradual dynamics after they have been input.

PROCEDURE

1. Select the gradual dynamics to which you want to add poco a poco. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, activate Poco a poco (little by little) in the Dynamics group.

RESULT
Poco a poco is shown immediately after gradual dynamic text, below hairpins placed below the
staff, and above hairpins placed above the staff.
Deactivating Poco a poco (little by little) removes poco a poco text from the selected gradual
dynamics.

EXAMPLE

Text gradual dynamic with poco a poco Hairpin gradual dynamic with poco a poco

Gradual dynamic spacing
Dorico Pro ensures that hairpins can always be clearly distinguished by giving hairpins a
minimum default length. However, this can affect note spacing.

The default minimum hairpin length is three spaces. When hairpins are shorter than this, they
can sometimes be confused with the accent articulation mark. Therefore, if you add a hairpin to a
note which would make the hairpin less than three spaces long, the spacing of the note is
changed to ensure the hairpin meets the minimum length.

You can change the minimum length of hairpins by changing the value for Minimum length for
hairpins, which you can find by clicking Advanced Options in the Hairpins subsection of the
Gradual Dynamics section of the Dynamics page in Engrave > Engraving Options.
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Gradual dynamics that start/end partway through notes
If the start/end of a gradual dynamic is not attached to a note, there are restrictions on how you
can move the start/end position.

For example, if you enter two hairpins separated by a space into the dynamics popover, pair of
hairpins that looks like a messa di voce is created but containing two separate hairpins, rather
than the combined option. Neither of the open ends of the hairpins is attached to a specific
notehead, and you cannot move the center of the pair of hairpins rhythmically. You can
lengthen/shorten the two hairpins as a group but you cannot lengthen/shorten each hairpin
individually.

However, if you enter two hairpins without a space between them into the dynamics popover,
you can move the center of the pair of hairpins and each hairpin rhythmically, but only to
noteheads. You can lengthen/shorten each hairpin separately according to the current rhythmic
grid value.

You can move individual hairpins in Engrave mode to any graphical position. If you input hairpins
separated by a space into the popover, you can move each hairpin independently, for example, if
you want to adjust the graphical peak of the pair of hairpins. You cannot move the graphical
peak of messa di voce hairpins, except by adjusting the note spacing. However, moving dynamics
graphically does not affect dynamics in playback.

RELATED LINKS
Lengthening/Shortening gradual dynamics and groups of dynamics on page 625
Moving dynamics graphically on page 617
Note spacing on page 381
Adjusting note spacing at individual rhythmic positions on page 388

Gradual dynamics truncated by immediate dynamics
A hairpin is automatically truncated if an immediate dynamic is positioned within its range, either
before or after the hairpin is input.

The hairpin remains tied to its originally designated rhythmic positions, even if graphically it
appears shorter. This means that if the immediate dynamic that truncated it is ever deleted, the
hairpin extends up to its end or the next immediate dynamic within its range.

The examples demonstrate a crescendo hairpin that is truncated by two dynamics, but the
hairpin extends to its total length as they are deleted. The dotted attachment line shows the link
between the hairpin and the rhythmic position to which its end is attached.

A long hairpin truncated by a p After deleting the p, the hairpin is
now truncated by the f

Deleting both immediate
dynamics allows the hairpin to
extend to its full length

RELATED LINKS
Lengthening/Shortening gradual dynamics and groups of dynamics on page 625
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Groups of dynamics
When dynamics are grouped together, they are automatically aligned in a row and can be moved
and edited as a group. For example, you can move the  in the middle of the example within the
group, and the hairpins either side automatically adjust to compensate.

A single dynamic, either immediate or gradual, is considered a group on its own.

Two or more dynamics are automatically grouped together if they immediately follow each other
horizontally on the staff, were input together or in sequence, and have gradual dynamics
between the immediate dynamics.

A group of dynamics The same group of dynamics adjusts to compensate
when the f moves position.

All of the dynamics in a group are highlighted when any of the dynamics in the group are
selected.

NOTE

● Groups of dynamics apply project-wide, meaning you cannot have dynamics grouped one
way in some layouts but differently in other layouts. However, you can graphically align
selected dynamics independently of their groups.

● As well as horizontal groups of dynamics, you can also link groups of dynamics across
staves if you want the same dynamics to appear on multiple staves. This can be useful
when multiple instruments play the same dynamics simultaneously and you want to make
the same change in all staves, for example, moving the peak of a crescendo to a later beat,
or changing a  to a .

RELATED LINKS
Dynamics linked across multiple staves on page 633
Aligning dynamics on page 618

Grouping dynamics together
You can manually group dynamics together that were not automatically grouped when they were
input. Grouped dynamics are automatically aligned in a row and can be moved and edited as a
group.

PROCEDURE

1. In Write mode, select the dynamics you want to group together.

2. Choose Edit > Dynamics > Group Dynamics. You can also choose this option from the
context menu.
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RESULT
The selected dynamics are grouped together. If the first dynamic in the group is linked to other
staves, all dynamics in the group are added to those staves. This applies to all layouts in which
the dynamics appear.

RELATED LINKS
Groups of dynamics on page 632
Dynamics linked across multiple staves on page 633

Ungrouping dynamics and removing dynamics from groups
You can ungroup dynamics so that all dynamics in the group become ungrouped, and you can
remove only selected dynamics from groups while leaving dynamics that were not selected in the
group.

PROCEDURE

1. In Write mode, select the dynamics you want to ungroup or remove from groups.

2. Do one of the following:

● Choose Edit > Dynamics > Ungroup Dynamics.

● Choose Edit > Dynamics > Remove from Group.

TIP

You can also choose these options from the context menu.

RESULT
If you ungroup dynamics, all dynamics in the group are ungrouped. This includes dynamics in
the group that were not included in your selection.
If you remove dynamics from groups, only the selected dynamics are removed from their groups.
Any unselected dynamics in the group remain grouped.
This applies to all layouts in which the dynamics appear.

Dynamics linked across multiple staves
Identical dynamics at the same rhythmic position on multiple staves can be linked together. This
happens automatically when you copy and paste dynamics between staves.

If you select one dynamic in a linked group, all other dynamics in the linked group appear
highlighted. If one linked dynamic is moved to a new rhythmic position, all linked dynamics
move.

Two linked dynamics with only the top dynamic
selected

Moving just the top dynamic of the linked group
automatically moves the other to match its new
position.
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Similarly, if you change one linked dynamic, for example, from  to , all dynamics linked to the
changed dynamic are also changed.

If you group other dynamics to one of the linked dynamics, such as a hairpin, the hairpin is
added at the same position in all linked staves.

If one staff has another immediate dynamic before the end of a hairpin, the hairpin is truncated
automatically. If you delete such a dynamic, the hairpin extends automatically up to the next
immediate dynamic or to its full length, whichever comes first.

Three linked dynamics, where a hairpin added to the
top staff and grouped with the dynamics on that
staff has been automatically added to the staves
below.

Deleting the f at the end of the first bar in the third
staff causes the hairpin to extend to match the range
of the top staff.

NOTE

● If you delete only some dynamics from a group that is linked to other staves, those
dynamics are also deleted from the linked staves. If you delete a whole dynamic group
from one staff, this does not affect linked dynamics on other staves.

● As well as vertically linked dynamics, you can also group dynamics horizontally. This
automatically aligns the dynamics in a row and allows them to be moved and edited as a
group.

● Linking or unlinking dynamics applies project-wide, meaning you cannot have dynamics
linked one way in some layouts but differently in other layouts.

RELATED LINKS
Groups of dynamics on page 632
Unlinking dynamics on page 635
Disabling automatic linking of dynamics and slurs when pasting on page 279

Linking dynamics together
When you copy and paste identical dynamics to the same rhythmic position on other staves,
those dynamics are linked together automatically. You can also manually link dynamics and
groups of dynamics together that are not automatically linked to allow simultaneous editing.

However, the groups of dynamics must be the same in order to link them together. For example,
you can link two  dynamics together if neither is part of a group, but you cannot link them
together if one is grouped with a hairpin.

PROCEDURE

1. In Write mode, select the dynamics you want to link together.
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2. Choose Edit > Dynamics > Link. You can also choose this option from the context menu.

RESULT
The selected dynamics are linked together. If you later change one of the linked dynamics, all
linked dynamics are changed to match. This applies to all layouts in which the dynamics appear.

RELATED LINKS
Dynamics linked across multiple staves on page 633
Copying dynamics on page 620

Unlinking dynamics
You can unlink dynamics, including dynamics that were linked automatically.

PROCEDURE

1. In Write mode, select a dynamic in each linked group that you want to unlink.

2. Choose Edit > Dynamics > Unlink. You can also choose this option from the context
menu.

RESULT
All dynamics in the linked groups are unlinked. This applies to all layouts in which the dynamics
appear.

RELATED LINKS
Dynamics linked across multiple staves on page 633

Dynamics font styles
You can change different aspects of the fonts used for dynamics in the Edit Font Styles dialog.

● You can open the Edit Font Styles dialog in Engrave mode by choosing Engrave > Font
Styles.

The following fonts affect the appearance of dynamics:

● Default Text Font: The parent font for all font styles in the project, including dynamic
modifiers.

● Dynamic Music Text Font: Used for dynamic glyphs, such as  and .

● Dynamic Text Font: Used for dynamic modifiers, including expressive text.

NOTE

Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Edit Font Styles dialog on page 364

Editing the dynamic modifier font styles
You can edit the formatting of the two fonts that affect the appearance of dynamic modifiers.
One font only affects dynamic modifiers and the other affects the entire project.

The Default Text Font is the parent font for the whole project, so any changes you make to this
font affect all fonts that are linked to the font. This includes dynamic modifiers, but also many
other fonts.
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The Dynamic Text Font is used for dynamic modifiers. Any changes you make to this font affect
all dynamic modifiers, including expressive text, but do not affect any other font style.

PROCEDURE

1. In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2. Select one of the following fonts from the Font style menu:

● Default Text Font

● Dynamic Text Font

3. Activate the following options, individually or together, to change the corresponding
aspect of the font:

● Font family

● Size

● Style

● Underlined

4. Optional: If required, repeat steps 2 and 3 to change the other font.

5. Click OK to save your changes and close the dialog.

RESULT
The formatting of the default font used for dynamic modifiers or all fonts in your project is
changed.

RELATED LINKS
Dynamics font styles on page 635

Editing the dynamic glyph font style
You can edit the formatting of the font used for dynamic glyphs, such as  or . However, you
must choose a SMuFL-compliant font.

PROCEDURE

1. In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2. Select Dynamic Music Text Font from the Font style menu.

3. Activate the following options, individually or together, to change the corresponding
aspect of the font:

● Font family

● Size

● Style

● Underlined

4. Click OK to save your changes and close the dialog.

RESULT
The formatting of the font used for dynamic glyphs is changed project-wide.

RELATED LINKS
Dynamics font styles on page 635
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Playback Options for dynamics
You can change settings for how dynamics are interpreted in playback by making adjustments to
the scale of the graphical curve on the Dynamics page in Playback Options.

You can open Playback Options in any of the following ways:

● Press Ctrl/Cmd-Shift-P in any mode.

● Choose Play > Playback Options in Play mode.

You can then click Dynamics in the page list on the left of the dialog.

Dynamic Curve

The graph at the top of the Dynamics page in Playback Options maps a continuous curve. This
curve determines how the volume of dynamics increases across the range  to .

A dynamic curve power of 1 creates a straight line, producing a steady dynamic increase. The
difference between  and  is the same as between  and .

A dynamic curve power higher than 2 creates a curved line, producing a faster dynamic increase
in the middle of the range. The difference between  and  is much smaller than the
difference between  and .

The higher the dynamic curve power, the greater the contrast between dynamics in the middle of
the range, and the smaller the contrast between dynamics at the ends of the range.

If your project uses a wide range of dynamics, including dynamics such as  and , you
might want a lower curve power with larger differences between the extremes of the range.

If your project has a smaller range of dynamics, such as a minimum of  to a maximum of ,
you might prefer a higher curve power, so the differences between the dynamics in the middle of
the range are more discernible.

NOTE

Changing the dynamic curve affects the playback of all instruments in the project.

Note Dynamics

In the Note Dynamics section of the Dynamics page, you can set how much the volume of notes
in playback is affected by stresses and articulation marks.

Humanize

Humanize allows dynamics to vary randomly by the degree you set to mimic the natural
fluctuations in a live performance.

Sustaining and non-sustaining instruments
The volume settings for sustaining instruments and non-sustaining instruments vary in terms of
their control of gradual dynamics.

You can control settings for each software instrument by choosing Play > Expression Maps and
selecting software instruments from the list on the left.

Sustaining instruments

Sustaining instruments include string, wind, and brass instruments, because they can hold a
note while being in control of its volume throughout.
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Dorico Pro applies gradual dynamics to these instruments in playback. You can control settings
for each software instrument by choosing Play > Expression Maps and selecting software
instruments from the list on the left.

Non-sustaining instruments

Non-sustaining instruments, such as piano, harp, marimba, and most percussion instruments,
have no further control of the dynamic of notes after they have been struck. For this reason, non-
sustaining software instruments often use note velocity for dynamics, because this is set at the
start of the note.

VST Expression Maps for volume types
If you are using a third-party sound library, you may need to change or edit the expression map
to make instruments respond to gradual dynamics. Otherwise, the sound library uses velocity by
default.

The setup of the expression map for dynamics depends on how the instrument is configured.
Consult the documentation for the sound library for further information.

Dorico Pro provides the following default expression maps:

● CC11 Dynamics for dynamics produced by changing MIDI channel expression

● Modulation Wheel Dynamics for dynamics produced by changing MIDI controller 1

You can edit expression maps in the Expression Maps dialog, which you can open by choosing
Play > Expression Maps.
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Fingerings can be added to music to recommend which fingers players should use for notes. This
can be useful for music aimed at players learning the instrument and for difficult musical
passages where certain fingering patterns make the notes much easier to play.

They are often used in keyboard music, as players can use all ten fingers to play notes, and in
guitar music, where fingerings are often used alongside fret positions. However, fingerings can
also be useful for other instruments, for example, to indicate that string players should change
the finger used to stop the string while holding the note, or to instruct wind players to use
uncommon fingerings for particular notes in order to create a special sonic effect.

Piano music containing multiple fingerings, including a substitution fingering and alternative fingerings

Dorico Pro also provides fingerings for brass instruments. For example, you can specify which
valves players should depress for instruments such as trumpet and horn, and you can specify the
horn branch you want players to use for double horns.

Fingerings in Dorico Pro use a bold roman font by default, following accepted conventions for
the appearance of fingerings. You can change the font used for fingerings project-wide on the
Fingering page in Engrave > Engraving Options.

RELATED LINKS
Inputting fingerings on page 184
Fingerings popover on page 184
Changing the font used for fingerings project-wide on page 646

General placement conventions for fingering
Fingerings are placed as close as possible to the notes to which they apply, so the performer can
read them easily and clearly.

In music for grand staff instruments, such as the piano and harp, it is accepted to place
fingerings for the right hand above the top staff, and fingerings for the left hand below the
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bottom staff. However, in dense contrapuntal music for these instruments, fingerings can be
placed between the staves to follow the direction of the voices to which they apply.

Project-wide engraving options for fingerings
You can find options for the project-wide appearance and position of fingerings on the Fingering
page in Engrave > Engraving Options.

The options on the Fingering page allow you to change the font, size, appearance, placement,
and precise position of fingerings on standard notes and grace notes, including fine adjustments
for the different instrument groups, such as brass instruments, and the design of enclosures
around fingerings and lines beneath fingerings. You can also change the position of fingerings
relative to slurs, octave lines, and tuplets.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Changing fingerings to substitution fingerings
Substitution fingerings indicate where players should change the finger used for the note. You
can change existing fingerings to substitution fingerings.

PROCEDURE

1. Select the fingerings you want to change to substitution fingerings. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Substitution in the Fingering and Positions group.

3. Enter the fingering you want for the substitution into the value field.

4. Press Return.

RESULT
The selected fingerings are now shown as substitution fingerings. The deferred position of the
substitution is the same as the original fingering by default, but you can change the rhythmic
position of substitution fingerings.

Changing the rhythmic position of substitution fingerings
Substitution fingerings are shown as immediate by default, meaning that the substitution takes
place on the same note, but you can change the rhythmic position at which individual
substitutions take place.

PROCEDURE

1. Select the substitution fingering whose deferred rhythmic position you want to change.
You can do this in Write mode and Engrave mode.

2. Change the rhythmic position of the substitution fingering in any of the following ways:

● In Write mode, click and drag the circular handle to the right/left.

● In Write mode and Engrave mode, activate Substitution offset in the Fingering
and Positions group of the Properties panel.
Change the rhythmic position of substitutions as fractions of a quarter note
(crotchet) by entering a value into the left value field, or by clicking the arrows
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beside the value field. Increasing the value moves substitutions to later positions,
decreasing the value moves them to earlier positions.

NOTE

The right value field is for the grace note position at which substitutions occur, if
applicable.

RESULT
The rhythmic position of the substitution fingering is changed.
Dorico Pro automatically arranges deferred substitutions so they are ordered appropriately
alongside any fingerings that coincide with the substitution.

NOTE

You can only change the position of single substitution fingerings when dragging their handles
with the mouse. However, you can change the positions of multiple substitution fingerings with
Substitution offset in the Fingering and Positions group of the Properties panel.

Deferred substitutions are always shown with horizontal lines, even if you have chosen to show
immediate substitutions with slurs.

RELATED LINKS
Fingerings popover on page 184
Project-wide engraving options for fingerings on page 640

Changing existing fingerings
You can change fingerings after you have input them, for example, if you decide a different
fingering would be better.

PROCEDURE

1. Select the fingerings you want to change. You can do this in Write mode and Engrave
mode.

2. In the Properties panel, enter the new fingering you want into the Finger or position
value field in the Fingering and Positions group.

3. Press Return.

RESULT
The selected fingerings are changed.

TIP

You can also change existing fingerings in Write mode by opening the fingerings popover. Any
existing fingerings on the selected note are shown in the popover.

RELATED LINKS
Inputting fingerings on page 184
Fingerings popover on page 184
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Moving fingerings graphically
You can move fingerings graphically, independently of the noteheads to which they apply.

NOTE

You cannot move fingerings to different rhythmic positions as they are intrinsic parts of notes. If
you want to move fingerings to other noteheads, you must delete the existing fingerings and re-
input them on the noteheads to which you wanted to move them.

PROCEDURE

1. In Engrave mode, select the fingerings you want to move graphically.

2. Move the fingerings in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The fingerings are moved to new graphical positions.

TIP

Offset in the Fingering and Positions group of the Properties panel is activated automatically
when you move fingerings.

● Offset X moves fingerings horizontally.

● Offset Y moves fingerings vertically.

You can also use this property to move fingerings by changing the values in the value fields.

Deactivating the property resets the selected fingerings to their default positions.

Resetting the positions of fingerings
You can reset the positions of individual fingerings whose graphical positions you have moved.

PROCEDURE

1. In Engrave mode, select the fingerings whose positions you want to reset.

2. Reset their positions in any of the following ways:

● Choose Edit > Reset Position.

● In the Properties panel, deactivate Offset in the Fingering and Positions group.
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Changing the placement of fingerings relative to the staff
Dorico Pro automatically follows conventions for fingering placement, but you can change the
placement of fingerings relative to the staff individually, independently of your project-wide
setting.

According to conventions, keyboard instrument fingering is positioned above the right-hand
staff, and below the left-hand staff. String and brass instrument fingering is always positioned
above the staff.

PROCEDURE

1. Select the fingerings whose position relative to the staff you want to change. You can do
this in Write mode and Engrave mode.

2. In the Properties panel, activate Staff-relative position in the Fingering and Positions
group.

3. Choose one of the following options:

● Above

● Below

RESULT
The selected fingerings appear above/below the staff.

TIP

You can change the placement of all fingerings relative to the staff project-wide to follow voice
directions on the Fingering page in Engrave > Engraving Options.

This can be useful in complex contrapuntal music where fingering may not be clear if it is only
placed above the top staff and below the bottom staff.

RELATED LINKS
Project-wide engraving options for fingerings on page 640

Changing the position of individual fingerings relative to slurs,
octave lines, and tuplet brackets

By default, fingerings are positioned inside the arcs of slurs, but outside the start/end of slurs.
You can change the position of fingerings relative to individual slurs, independently of your
project-wide settings.

PROCEDURE

1. In Engrave mode, select the fingerings whose position relative to slurs you want to
change.

2. In the Properties panel, activate Slur-relative position in the Fingering and Positions
group.

3. Choose one of the following options:

● Inside

● Outside

RESULT
The position of the selected fingerings relative to slurs, octave lines, and tuplet brackets is
changed.
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NOTE

● If fingerings also coincide with the first note or last note of slurs, fingerings are positioned
outside all of these notations.

● You can change the position of all fingerings relative to slurs, octave lines, and tuplet
brackets project-wide on the Fingering page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for fingerings on page 640

Changing the size of fingerings
You can change the size of fingerings individually, without changing the size of the noteheads to
which they apply.

PROCEDURE

1. In Engrave mode, select the fingerings whose size you want to change.

2. In the Properties panel, activate Scale in the Fingering and Positions group.

3. Change the value in the value field.

4. Press Return.

RESULT
The scale size of the selected fingerings is changed. For example, changing the value to 50 scales
the selected fingerings to half their normal size.

TIP

You can change the default size of all fingerings project-wide by changing the size of the
Fingering Font in Engrave > Font Styles.

RELATED LINKS
Editing the fingering font styles on page 647

Showing enclosures/underlines on fingerings
You can show individual fingerings with either a circle enclosure or an underline.

PROCEDURE

1. In Engrave mode, select the fingerings on which you want to show an enclosure/underline.

2. In the Properties panel, activate Decoration in the Fingering and Positions group.

3. Choose one of the following options:

● Circle

● Underline

RESULT
The selected fingerings are shown with the chosen decoration.
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TIP

You can find options that determine the default design of all fingering decorations project-wide,
such as their line thickness, by clicking Advanced Options in the Design section of the Fingering
page in Engrave > Engraving Options.

EXAMPLE

Fingering with circle Fingering with underline

RELATED LINKS
Project-wide engraving options for fingerings on page 640

Hiding/Showing fingering
You can hide/show fingering in each layout in your project independently of other layouts. For
example, you can show fingering in part layouts but hide fingering in full score layouts as
conductors rarely require fingering information.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show fingering.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Players in the page list.

4. In the Fingering section, activate/deactivate Show fingering.

5. Click Apply, then Close.

RESULT
All fingerings in the selected layouts are shown when the checkbox is activated, and hidden when
the checkbox is deactivated.

RELATED LINKS
Changing the appearance of cautionary fingerings on page 648

Deleting fingerings
You can remove fingerings from notes after you have input them. However, because fingerings
are considered an intrinsic part of notes rather than a separate item, you cannot select and
delete them as you would for other items.

PROCEDURE

1. Select the notes from which you want to remove fingerings. If you are in Engrave mode,
select the fingerings.
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2. In the Properties panel, deactivate Finger or position in the Fingering and Positions
group.

RESULT
All fingerings are removed from the selected notes.

RELATED LINKS
Large selections on page 274

Fingering font styles
Bold and plain fingerings use different fonts. You can change different aspects of the font styles
used for fingering in the Edit Font Styles dialog.

● You can open the Edit Font Styles dialog in Engrave mode by choosing Engrave > Font
Styles.

The following fonts are used for fingering:

1 Fingering Font: Used for bold fingerings.

2 Fingering Text Font: Used for plain fingerings.

3 Fingering Text Italic Font: Used for italic fingerings.

4 Fingering Horn Branch Text Font: Used for note names in horn branch indicators.

5 Fingering Horn Branch Accidental Font: Used for accidentals in horn branch indicators.

6 Fingering Horn Branch Alto Text Font: Used for the alto abbreviation in triple horn
branch indicators.

NOTE

Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Edit Font Styles dialog on page 364
Project-wide engraving options for fingerings on page 640

Changing the font used for fingerings project-wide
By default, fingerings are drawn in a bold, Arabic font that is similar in appearance to the digits in
time signatures. You can change the font used for all fingerings project-wide, which affects the
appearance of fingering numbers, parentheses, and brackets.

NOTE

The font used for thumb indicator, substitution lines and slurs, and brass valve separators is not
changed.
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PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Fingering in the page list.

3. In the Design section, choose one of the following options for Fingering appearance:

● Bold font

● Plain font

4. Click Apply, then Close.

RESULT
The font style used for fingerings project-wide is changed.

TIP

You can edit different aspects of the font style used in the Edit Font Styles dialog. Bold
fingerings use Fingering Font. Plain fingerings use Fingering Text Font.

RELATED LINKS
Editing the fingering font styles on page 647

Editing the fingering font styles
You can edit the formatting of the font styles used for all fingerings project-wide, for example, if
you want them to appear larger by default.

PROCEDURE

1. In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2. Select the fingering font style you want to edit from the Font style menu.

3. Activate the following options, individually or together, to change the corresponding
aspect of the font:

● Font family

● Size

● Style

● Underlined

4. Optional: Repeat steps 2 and 3 for any other font style you want to edit.

5. Click OK to save your changes and close the dialog.

RESULT
The formatting of the selected fingering font styles is changed project-wide.

RELATED LINKS
Fingering font styles on page 646
Project-wide engraving options for fingerings on page 640
Changing the size of fingerings on page 644
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Showing individual fingerings in italics
Fingerings are normally shown in a bold, non-italic font, but you can show individual fingerings in
italics.

PROCEDURE

1. In Engrave mode, select the fingerings you want to show in italics.

2. In the Properties panel, activate Italic in the Fingering and Positions group.

RESULT
The selected fingerings are shown in a bold italic font if your project-wide setting for fingerings is
a bold font, and in a plain italic font if your project-wide setting for fingerings is a plain font.

NOTE

Bold italic fingerings look very similar to tuplet numbers, which can be confusing.

Cautionary fingerings
Cautionary fingerings remind players that fingerings specified at previous rhythmic positions
continue to apply to notes that are still sounding. Dorico Pro automatically shows cautionary
fingerings when you add other fingerings at rhythmic positions where notes with existing
fingerings are still sounding.

By default, cautionary fingerings are shown enclosed in parentheses. You can choose to show
cautionary fingerings without parentheses or not to show cautionary fingerings at all project-
wide, and you can change the appearance of cautionary fingerings individually, for example, if
you want to show cautionary fingerings manually on tied notes that cross system or frame
breaks.

Cautionary fingering shown in parentheses (default)

Changing the appearance of cautionary fingerings
You can change the appearance of cautionary fingerings individually and independently of your
project-wide setting, for example, if you want particular fingerings to appear without
parentheses or to hide specific cautionary fingerings.

PROCEDURE

1. In Engrave mode, select the noteheads whose cautionary fingering appearance you want
to change.

NOTE

You must select the specific noteheads to which the cautionary fingerings apply, not the
fingerings themselves.

2. In the Properties panel, activate Cautionary in the Fingering and Positions group.

3. Select one of the following options from the menu:

● Default
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● With parentheses

● Without parentheses

● Suppress

RESULT
The appearance of cautionary fingerings on the selected notes is changed.

TIP

You can change the default appearance of all cautionary fingerings project-wide in the
Alternative, Editorial and Cautionary section of the Fingering page in Engrave > Engraving
Options.

RELATED LINKS
Cautionary fingerings on page 648
Project-wide engraving options for fingerings on page 640

Fingerings for valved brass instruments
For instruments like trumpet and horn, fingering is used to show which valves must be
depressed to produce a specific note.

You can enter fingerings for valved brass instruments into the fingerings popover as numbers
without any separation. For example, enter 12 for a C♯ on a trumpet to indicate that the first two
valves must be depressed.

By default, Dorico Pro automatically stacks fingerings added to notes on brass instrument staves
vertically. They are shown with no separator by default.

You can change the appearance of fingerings for valved brass instruments in the Brass section of
the Fingering page in Engrave > Engraving Options. For example, you can show fingerings for
valved brass instruments in a single row or stacked vertically. You can also change the
appearance of the separator or show no separator.

You can also edit the formatting of the fonts used for the different parts of fingerings for valved
brass instruments.

RELATED LINKS
Fingering font styles on page 646
Fingerings popover on page 184
Inputting fingerings on page 184

Showing horn branch indicators
You can indicate the branch on which notes are played for double horns and triple horns by
adding branch indicators as prefixes to horn fingerings. Some publications simply indicate “T” for
thumb, while others more explicitly indicate which branch is to be used by specifying its pitch.

NOTE

You can only add branch indicators to notes belonging to horns in F.

PROCEDURE

1. Select the horn fingerings to which you want to add branch indicators. You can do this in
Write mode and Engrave mode.
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2. In the Properties panel, activate Horn branch in the Fingering and Positions group.

3. Select one of the following horn branches from the menu:

● F

● B flat

● F alto

● E flat alto

● Thumb trigger

RESULT
Branch indicators are added to the selected fingerings.

TIP

You can change the appearance of branch indicators in the Brass section of the Fingering page
in Engrave > Engraving Options.

RELATED LINKS
Inputting fingerings on page 184
Project-wide engraving options for fingerings on page 640

Changing the appearance of slide positions for brass instruments
You can use Arabic or Roman numerals to indicate slide positions for slide brass instruments,
such as trombones. By default, Dorico Pro uses Arabic numerals for slide positions.

NOTE

You must enter slide positions using Arabic numerals into the fingerings popover, even if you
have chosen to show slide positions with Roman numerals in your project.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Fingering in the page list.

3. In the Brass section, choose one of the following options for Slide position appearance:

● Arabic numerals

● Roman numerals

4. Click Apply, then Close.

RESULT
The numeral style used for slide positions on slide brass instruments is changed project-wide.

RELATED LINKS
Inputting fingerings on page 184
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Hiding/Showing string fingering shift indicators
An angled line can be used to indicate the direction of movement when string players must shift
their finger position on the fingerboard to play a higher/lower note with the same finger as the
previous note.

PROCEDURE

1. Select the notes or fingerings on string instrument staves from which you want to indicate
a fingering shift. You can do this in Write mode and Engrave mode.

2. In the Properties panel, activate/deactivate Indicate shift to next note in the Fingering
and Positions group.

RESULT
Shift indicators are shown when the property is activated, even if neither of the notes at each end
have explicit fingerings, and hidden when the property is deactivated. They are positioned
between the selected notes and the notes that immediately follow them.

TIP

You can change the length, thickness, angle, and placement of shift indicators in the String
Fingering Shifts section of the Fingering page in Engrave > Engraving Options.

EXAMPLE

RELATED LINKS
Specifying on which string individual notes are played on page 727

Changing the direction of string fingering shift indicators
You can change the direction of individual string fingering shift indicators if they do not point in
the direction required.

PROCEDURE

1. Select the shift indicators whose direction you want to change. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, activate Shift direction in the Fingering and Positions group.

3. Choose one of the following options:

● Up

● Down

RESULT
The selected shift indicators are angled up/down.

NOTE

You can also affect the direction of string shift indicators by specifying the strings on which notes
are played.
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RELATED LINKS
Specifying on which string individual notes are played on page 727

Fingerings imported from MusicXML files
Dorico Pro imports fingerings that are specified using the fingering element in MusicXML files.

MusicXML files exported from Finale typically represent fingerings in the correct way. However,
because Sibelius does not use the fingering element, Dorico Pro cannot import fingerings from
MusicXML files exported by Sibelius.
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Front matter in Dorico Pro is a broad term that covers all information included before the first
bar of music in scores.

Front matter includes musical information often added on pages before the first pages of scores,
such as:

● Performance instructions

● Contents

● Instrumentation list

Front matter also includes information above the music on the first page of scores and parts,
such as:

● Dedications

● Titles

● Subtitles

● Composers

All information in your project that is independent of the music must be added within frames,
which you can input and edit in Engrave mode. You can do this on individual pages in layouts or
on master pages, which allow you to apply the same formatting to multiple pages in all the
layouts that use the same master page set, for example, if you want the music frame for the last
page in all part layouts to be smaller because it only contains a few systems.

RELATED LINKS
Master pages on page 301
Master page sets on page 302
Master page types on page 304
Paragraph Styles dialog on page 366
Frames on page 322

Project information used in default master pages
An efficient way of ensuring all text information in the different layouts in your project is
consistent is to use tokens that link to information for the current project entered in the Project
Info dialog.

Tokens are codes that refer to text elsewhere, meaning they are updated automatically if the
source text is changed.

The default master pages in Dorico Pro include tokens, so that any information you include for
each flow in the Project Info dialog is automatically shown. For example, the Default Full Score
master page set shows the following information for each flow:

● Composer

● Lyricist
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● Title

NOTE

These tokens are linked to the project information for each flow by default. If you only enter
information for Project in the Project Info dialog, no text is shown.

RELATED LINKS
Project Info dialog on page 90
Flow names and flow titles on page 119
Text tokens on page 332

Adding dedications in master pages
You can show dedications in multiple layouts by adding them to master pages. Dedications are
usually shown above titles in scores, use a smaller font size than titles, and are shown in italics.

PREREQUISITE

● You have entered a dedication in one of the Dedication fields in the Project Info dialog.
You can enter different dedications for the whole project and for each flow individually.

● If you want to use a new paragraph style for dedications, you have created a new
paragraph style.

PROCEDURE

1. In Engrave mode, open a layout in the music area that uses the master page set
containing the master page to which you want to add a dedication.

NOTE

You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2. In the Master Pages section of the Pages panel, double-click the master page master page
pair to which you want to add a dedication.
The master page editor opens in the music area.

3. Double-click the title text frame to open the text editor.

4. Position the cursor at the start of the title token.

5. Press Return to input a new line above the title token.

6. Enter one of the following tokens in the new line above the title token:

● {@flowDedication@} shows the dedication for the flow.

● {@projectDedication@} shows the dedication for the whole project.

7. Optional: Change the appearance of the dedication text using the text editor options.

8. Press Esc or Ctrl/Cmd-Return to close the text editor.

RESULT
A dedication is shown above the title of all pages that use the selected master page format if a
dedication is entered into the appropriate field in the Project Info dialog.

RELATED LINKS
Project Info dialog on page 90
Creating paragraph styles on page 368
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Text editor options in Engrave mode on page 371

Adding player lists
You can add the player list text token to any layout or master page. It automatically displays the
names of all players in the layout, and includes all instruments held by each player.

PREREQUISITE

● If you want to add a player list to a master page, you have opened the master page in the
master page editor.

● If you want to add a player list into a new text frame, you have input the text frame where
you want the player list to appear.

PROCEDURE

1. Double-click the text frame to whcih you want to add a player list to open the text editor.

2. Enter {@playerlist@}.
3. Press Esc or Ctrl/Cmd-Return to close the text editor.

RESULT
The player list text token is added. It is populated with a list of all players in the layout. If you
added it to a master page, the text frame and text token are automatically added to all pages in
all layouts that use that master page.

NOTE

Pages with overrides are not updated when you change the master page.

EXAMPLE

Player list token in a text frame Player list token populated with players in the layout

RELATED LINKS
Inputting frames on page 322
Master page overrides on page 308
Master page editor on page 306

Changing the text in running headers in master pages
The Default Part master page set shows the part name at the top left of the first pages in flows,
and also shows the part name centered at the top of subsequent pages as a running header.

You can change the text shown in running headers, for example, if you want to include the flow
title as well.

PROCEDURE

1. In Engrave mode, open a layout in the music area that uses the master page set
containing the master page whose running header text you want to change.
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NOTE

You can also select the master page set from the Current set menu in the Master Pages
section of the Pages panel when any layout is open in the music area, but this changes the
master page set applied to the layout.

2. In the Master Pages section of the Pages panel, double-click the master page master page
pair whose running header text you want to change.
The master page editor opens in the music area.

3. Double-click the header text frame to open the text editor.

4. Change or delete the header text.
For example, to show both the part name and the flow title in the header text separated by
a dash, enter - {@flowTitle@} after the part name token in the text frame.

5. Press Esc or Ctrl/Cmd-Return to close the text editor.

RESULT
The running header text is changed for all layouts that use the selected master page format.

EXAMPLE

Token text added to a text frame Token text in a part layout

RELATED LINKS
Master page editor on page 306
Changing the vertical alignment of text in text frames on page 338
Changing the horizontal alignment of text in text frames on page 339
Changing the paragraph style of text on page 373
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Grace notes are notes without a fixed duration, which are intended to be played quickly. They are
scaled-down versions of normal notes, and are commonly shown with a slash through their
stem.

Grace notes with slashed stems are known as acciaccaturas and are often played very fast. Grace
notes without slashed stems are known as appoggiaturas and are often played slower than
acciaccaturas.

In Baroque music, appoggiaturas are often understood to last for a specific duration, based on
the prevailing meter and the rhythmic value of the notehead to which they are attached.

Grace notes do not take up space rhythmically, as they are intended to be fitted into the space
before the notehead to which they are attached, which is the notehead immediately to their
right.

There can be multiple grace notes before a notehead. If there are two or more grace notes
attached to the same notehead, and they have a rhythmic value that shows a flag on the stem,
such as eighth notes (quavers) and 16th notes (semiquavers), they are automatically beamed
together.

Multiple grace notes before notes

In Dorico Pro, grace notes are scaled to 3/5 the size of a normal notehead by default and are
affected by your note spacing settings. There is a separate option specifically for grace note
spacing.

You can add notations, such as slurs and articulations, to grace notes in the same ways as to
normal notes, and you can transpose grace notes after they have been input.

RELATED LINKS
Inputting grace notes on page 167
Grace note slashes on page 660
Slur placement relative to grace notes on page 870
Note spacing on page 381
Changing the pitch of individual notes on page 173
Inputting articulations on page 182
Inputting slurs on page 265
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General placement conventions for grace notes
Grace notes function like normal notes in many ways, but there are some specific conventions
about their stem direction, position relative to noteheads, and the placement of stem slashes.

Grace notes appear stem up by default, except when there are multiple voices with grace notes
in a single staff, in which case grace notes in the lower voices appear stem down. This affects the
placement of slurs relative to grace notes.

Grace notes are always positioned before a notehead, even if they are intended to be played on
the beat rather than before the beat. They are normally placed after a barline, so they can be
positioned directly before the notehead to which they are attached. However, groups of three or
more grace notes can be placed before the barline so that the note of the first beat in the bar is
not pushed too far from the barline.

Grace note stem slashes appear at the beginning of a grace note beam if multiple grace notes
can be joined by a single beam at the same rhythmic position. If there is a single grace note, the
slash appears across the stem, and its flag if applicable, and extends either side of the stem.

Adding accidentals causes their spacing to readjust so that the accidentals are clearly legible,
similar to normal notes.

Articulations can be added to grace notes wherever they are most clearly legible, which is most
likely outside the staff. Dorico Pro automatically places articulations on the stem-side of grace
notes, and outside the staff if the stem or beam is within the staff.

Slurs relative to grace notes

By default, slurs starting on grace notes and ending on tie chains end on the first note of the tie
chain. You can change the position of individual slurs relative to tie chains, including those
starting from grace notes.

You can change the default position of all slurs relative to grace notes in the Grace Notes section
of the Slurs page in Engraving Options. Included in this section are options for the position of
slurs relative to grace notes in multiple voices.

In the Tied notes section of the page, you can change the default position of slurs relative to tie
chains when slurs start on grace notes.

RELATED LINKS
Changing the position of grace notes relative to barlines on page 659
Slur placement relative to grace notes on page 870
Slur position relative to tie chains on page 869
Changing the position of slurs relative to tie chains on page 870
Note spacing on page 381

Grace note placement in multiple-voice contexts
According to accepted notation convention, grace notes appear stem up by default when there is
only one voice on a staff, even if the notehead to which they are attached is stem down.

However, when there are multiple voices on the staff, all notes in the upper voices appear stem
up and all notes in the lower voices appear stem down, including all grace notes. This adjustment
happens automatically in Dorico Pro, but you can also override the stem direction of grace notes
in multiple voices and change their directions individually if necessary.

Grace notes
General placement conventions for grace notes 

658
Dorico 2.2.20



RELATED LINKS
Changing the stem direction of notes on page 946
Slur placement relative to grace notes on page 870

Changing the position of grace notes relative to barlines
By default, grace notes are positioned after barlines and directly before the notehead to which
they apply, including for the first note in a bar. You can position individual grace notes before
barlines, for example, so the first normal note in the bar is not pushed too far from the barline,
or to indicate that grace notes are played before the beat.

PROCEDURE

1. Select the grace notes whose position relative to barlines you want to change. You can do
this in Write mode and Engrave mode.

2. In the Properties panel, activate/deactivate Grace note before barline in the Grace Notes
group.

RESULT
The selected grace notes are positioned before barlines when the property is activated, and after
barlines when the property is deactivated.

Project-wide changes to the position of grace notes
The Grace Notes section of the Notes page in Engrave > Engraving Options allows you to
change the default distance between grace notes and the noteheads to which they apply.

Increasing the value for the minimum distance to the right of the rightmost grace note moves
grace notes further from the notehead to which they apply. Decreasing the value moves them
closer to the notehead to which they apply.

A grace note with the default minimum value of half
a space between it and the notehead to its right

A grace note with an increased value of 1.5 spaces
between it and the notehead to its right

You can also adjust the position of grace notes in each layout independently by changing the
note spacing scale factor for grace notes on the Note Spacing page in Setup > Layout Options.

Decreasing the note spacing scale value for grace notes decreases the gap between multiple
grace notes at the same rhythmic position.

Three grace notes with long durations, with the
default note spacing scale of 70%

Three grace notes with long durations, with a
decreased note spacing scale of 20%
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RELATED LINKS
Engraving Options dialog on page 299
Note spacing on page 381

Grace note size
Grace notes are smaller versions of normal notes, and are scaled down by a ratio that is set by
default to 3/5 of a normal note.

You can find the ratio that controls the default size of all grace notes project-wide in the Grace
Notes section of the Notes page in Engrave > Engraving Options.

You can also change the size of grace notes individually in the same way as for normal notes.

RELATED LINKS
Changing the size of notes on page 723

Grace note slashes
Slashes shown diagonally across grace note stems are often used to distinguish different types
of grace notes. Grace notes with slashed stems are known as acciaccaturas and are often played
very fast. Grace notes without slashed stems are known as appoggiaturas and are often played
slower than acciaccaturas.

In Dorico Pro, grace notes appear with slashed stems by default. You can change whether grace
notes are slashed or unslashed during note input as well as by changing the type of existing
grace notes.

You can set the precise measurements of each part of grace note stem slashes in the Grace
Notes section of the Notes page in Engrave > Engraving Options.

In this section, you can change the following:

● Thickness of grace note stem slashes

● Default length of grace note stem slashes

● Position of grace note stem slashes relative to the end of the stem

Changing the type of grace notes
You can change the type of individual grace notes after they have been input. Grace notes have
slashed stems by default, but you can change them to have unslashed stems.

PROCEDURE

1. Select the grace notes whose type you want to change. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, choose one of the following options for Grace note type in the
Grace Notes group:

● Slashed stem

● Unslashed stem

RESULT
The selected grace notes are shown with slashed/unslashed stems.
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TIP

You can also change the grace note type during step input.

RELATED LINKS
Grace note slashes on page 660
Inputting grace notes on page 167

Moving slashes on grace note stems
You can change the vertical position of individual grace note slashes, independently of your
project-wide settings.

PROCEDURE

1. In Engrave mode, select the grace notes whose slash positions you want to change.

2. In the Properties panel, activate the following properties, individually or together, in the
Grace Notes group:

● Slash inset from stem tip

● Slash offset to right

3. Move the selected grace note slashes by changing the values in the value fields.

RESULT
Increasing Slash inset from stem tip moves grace note slashes further from the tips of stems
and closer to the noteheads. Decreasing the value moves them closer to the tips of stems and
further from the noteheads.
Increasing Slash offset to right moves grace note slashes to the right, decreasing the value
moves them to the left.

TIP

You can change the default position of all grace note slashes project-wide in the Grace Notes
section of the Notes page in Engrave > Engraving Options.

Changing the length of grace note slashes
You can change the length of slashes on grace note stems individually, independently of your
project-wide setting.

PROCEDURE

1. In Engrave mode, select the grace notes whose slash length you want to change.

2. In the Properties panel, activate the following properties, individually or together, in the
Grace Notes group.

● Slash length

● Slash protrusion from beam (beamed grace notes only)

NOTE

Grace note slashes seem to disappear when you activate Slash length because activating
the property resets the value to 0.

3. Change the length and/or protrusion of the selected slashes by changing the values in the
corresponding value fields.
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RESULT
Increasing Slash length lengthens grace note slashes on both single grace notes and grace note
beams, decreasing the value shortens grace note slashes.
Increasing Slash protrusion from beam increases how far slashes extend beyond grace note
beams, decreasing the value decreases how far slashes extend beyond grace note beams.

TIP

You can change the default appearance of all grace note slashes project-wide in the Grace Notes
section of the Notes page in Engrave > Engraving Options.

RELATED LINKS
Moving slashes on grace note stems on page 661

Grace note stems
Grace notes are scaled-down notes, so the length of grace note stems is determined by your
project-wide settings for the stem length of all notes.

You can change the default lengths of all stems project-wide in the Stems section of the Notes
page in Engrave > Engraving Options.

Following accepted conventions, grace notes in Dorico Pro are stem up by default in any clef,
regardless of the stem direction of the note to which they apply. The stem directions of grace
notes are changed automatically when there are multiple voices on a staff, but you can change
the stem direction of individual grace notes manually. You can also lengthen/shorten grace note
stems in the same ways as for normal stems.

RELATED LINKS
Stems on page 942
Grace note slashes on page 660
Changing the stem direction of notes on page 946
Lengthening/Shortening stems on page 947
Hiding stems on page 948

Grace note beams
Dorico Pro automatically beams multiple adjacent grace notes together if they are an eighth note
(quaver) or shorter in duration.

Like all beams, grace note beams ideally follow the accepted standards for beam placement
relative to staff lines, in order to avoid wedges. However, because grace notes are smaller than
normal notes, this can lead to extreme slants in grace note beams.

You can adjust the slants of individual grace note beams in the same ways as for normal beams.
You can also change how all grace note beam slants are positioned project-wide in the Vertical
Position section of the Beams page in Engrave > Engraving Options.

Beam slants in two-note groups of beamed grace notes

If two adjacent grace notes covering a wide pitch range are joined by a beam at the same
rhythmic position, the angle of the beam can appear very steep.

You can choose whether the beam slant in such cases is left unchanged, or whether shallower
slants are used, in the Grace Notes subsection of the Slants section of the Beams page in
Engraving Options.
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RELATED LINKS
Engraving Options dialog on page 299
Beaming on page 537
Beam groups on page 539
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Different notations are used to show where the established rhythmic flow of the music is
interrupted, either with a moment of repose or a short silence, before continuing. The most
subtle effect is produced by a tenuto mark, with more significant effects denoted with holds and
pauses.

The duration of the break in the music intended by the hold or pause does not need to be
specified. This leaves significant room for interpretation, even though the different styles of
holds and pauses normally indicate larger or smaller breaks.

NOTE

Holds and pauses do not currently have an effect in playback, but this is planned for future
versions.

RELATED LINKS
Input methods for holds and pauses on page 225

Types of holds and pauses
There are three types of holds and pauses in Dorico Pro, and they can all be input, moved, and
deleted in the same ways.

Fermatas
Fermatas indicate that a note is held for longer than its notated length, which applies
to the whole ensemble.
They are also known as “pauses” and informally sometimes called “birds’ eyes”.

Breath marks
Breath marks show suitable places for players to breathe, or suggest how the music
is phrased to create a similar effect.

Caesuras
Caesuras indicate that a note is sustained for its full value and is followed by a break
in sound before continuing.

Types of fermatas
There are different types of fermatas available in Dorico Pro. Each fermata indicates a suggested
pause duration whilst leaving room for interpretation.

Fermata Description

Very short fermata Indicates that a note is held only a fraction
longer than the rhythm indicates.

Holds and pauses
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Fermata Description

Short fermata Indicates that a note is held a little bit longer
than the rhythm indicates.

Short fermata (Henze) Indicates that a note is held a little bit longer
than the rhythm indicates, as used by Hans
Werner Henze.

Fermata Indicates that a note is held for longer than the
rhythm indicates.

Long fermata Indicates that a note is held quite a lot longer
than the rhythm indicates.

Long fermata (Henze) Indicates that a note is held quite a lot longer
than the rhythm indicates, as used by Hans
Werner Henze.

Very long fermata Indicates that a note is held for much longer
than the rhythm indicates.

Curlew (Britten) Indicates that a note or rest is held until the
next synchronization point in asynchronous
music, as used by Benjamin Britten.

Fermatas can be divided into two styles. Because their meanings overlap, it can be confusing for
players if both styles are used in a single project.

Style Very short
fermata

Short
fermata

Fermata Long fermata Very long
fermata

Normal

Henze N/A N/A

RELATED LINKS
Holds and pauses popover on page 225
Changing existing items on page 280
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Types of breath marks
There are different types of breath marks available in Dorico Pro. Breath marks indicate a
suitable place for a player to take a breath, or create a musical effect like a breath.

Comma-like Tick-like Upbow-like Salzedo

Types of caesuras
There are different types of caesuras available in Dorico Pro. All caesuras indicate a break in
sound, but different types are often needed for different styles of musical scores.

Caesura Thick caesura Short caesura Curved caesura

Two diagonal slashes Two thick diagonal
slashes

Two straight, vertical
slashes

Two curved diagonal
slashes

If you intend to communicate a specific length of hold or gap with each type of caesura, we
recommend that you consider adding a legend, as different players may interpret these symbols
differently.

RELATED LINKS
Changing existing items on page 280

Project-wide engraving options for holds and pauses
You can find options for the project-wide positions of holds and pauses on the Holds and Pauses
page in Engrave > Engraving Options.

The options on the Holds and Pauses page allow you to change the default positions and
placement of holds and pauses, including the placement of fermatas in multiple-voice contexts.

The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.

RELATED LINKS
Engraving Options dialog on page 299
Positions of holds and pauses on page 666

Positions of holds and pauses
Holds and pauses are placed above the staff by default in single-voice contexts, and are shown
on all staves at the closest rhythmic position available, for example, if a single staff has a fermata
on the last beat in the bar, it is shown above the bar rests on the other empty staves. For staves
with multiple voices, fermatas are also shown inverted below the staff.

You can move holds and pauses to different rhythmic positions in Write mode. They are
positioned by default according to your settings in Engraving Options.

You can move holds and pauses graphically in Engrave mode; however, this does not change the
rhythmic positions to which they are attached.

Holds and pauses
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You can change the default positions of all holds and pauses project-wide, and values for the
minimum gaps around holds and pauses, on the Holds and Pauses page in Engrave >
Engraving Options.

Fermatas

Fermatas are positioned horizontally so that they are centered on noteheads, regardless of the
stem direction of notes.

Fermatas affect the overall tempo of the piece, so all players must be able to see where they
occur. Therefore, fermatas are shown on all staves at the same rhythmic position, or the
rhythmic position of the note, chord, or rest that corresponds with the end of the fermata,
including over a bar rest if a staff has no notes in that bar.

You can change the minimum distance between fermatas and the staff on the Holds and Pauses
page in Engrave > Engraving Options.

Breath marks

Breath marks are placed above the top line of the staff, at the end of the note to which they
apply; that is, they appear just before the following note.

Breath marks apply only to the staff to which they were added, as they do not affect the overall
tempo, but instead only indicate to a single player or group of players a suitable place to break
their line in order to breathe.

You can change the minimum distance between breath marks and the staff, and between breath
marks and the next note or rest, on the Holds and Pauses page in Engraving Options.

Caesuras

Caesuras are positioned at the top of the staff, with the top staff line passing through the middle
of the caesura and the bottom of the caesura resting on the second staff line. They are
commonly placed at the end of a bar, before the barline.

Caesuras are automatically added to all staves at the same rhythmic position, immediately to the
left of the notehead or barline to which they were input. They are not linked to noteheads, and
adjust note spacing to create a clear gap.

You can change the size of the gap to the right of caesuras on the Holds and Pauses page in
Engraving Options.

RELATED LINKS
Project-wide engraving options for holds and pauses on page 666
Moving holds and pauses graphically on page 669

Multiple holds and pauses at the same rhythmic position
Because fermatas apply to all staves, only one type of fermata can exist at the same rhythmic
position. For example, you cannot have a short fermata on one staff and a long fermata at the
same rhythmic position on another staff.

A Britten curlew can be used at the same rhythmic position as another kind of fermata, but it
cannot exist simultaneously with any breath mark. This is the only exception in Dorico Pro.

Caesuras can co-exist with any type of breath mark, but you cannot have a caesura and a fermata
at the same rhythmic position.

Holds and pauses
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Changes to fermatas on single staves
Changing the type of fermata or caesura on one staff automatically changes the type on all
staves at that rhythmic position, as a pause at one particular rhythmic position can only be of
one duration.

However, if you override a particular fermata on one staff, for example, by changing it to a
Britten curlew or a breath mark, changing the existing fermata on another staff does not change
the marking on the overridden staff. Deleting the marking on the overridden staff reverts that
marking to match the fermata on the other staves.

For example, changing a fermata to a breath mark changes the marking for only that staff. That
note is not affected when the type of fermata on the other staves at that rhythmic position is
changed.

The bottom staff is overridden to
show a breath mark instead of a
fermata.

The fermata is changed to a very
short fermata, but the bottom
staff is exempt as it was
overridden to show a breath mark.

Deleting the breath mark from the
bottom staff returns it to showing
the fermata currently chosen for
that rhythmic position.

Moving holds and pauses rhythmically
You can move holds and pauses to new rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the holds and pauses you want to move.

NOTE

When using the mouse, you can only move one hold or pause rhythmically at a time.

2. Move the holds and pauses according to the current rhythmic grid value in any of the
following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the hold or pause to the right/left.

RESULT
The selected holds and pauses are moved to new rhythmic positions on each staff where they
appear, even if their position does not appear to move. For example, if one staff has a bar rest,
the rhythmic position of the hold or pause moves, but the hold or pause still appears above the
rest.

NOTE

Only one type of hold or pause can exist at each rhythmic position. If a hold or pause passes over
another hold or pause as part of its move, the existing hold or pause is deleted.
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You can undo this action, but any holds and pauses deleted in the process are only restored if
you moved the hold or pause using the keyboard.

Moving holds and pauses graphically
You can move holds and pauses graphically without changing the rhythmic positions to which
they are attached.

PROCEDURE

1. In Engrave mode, select the holds and pauses you want to move.

2. Move the holds and pauses in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The holds and pauses are moved to new graphical positions.

TIP

Start offset in the Holds and Pauses group of the Properties panel is activated automatically
when you move fermatas and breath marks. You can use this property to move fermatas and
breath marks by changing the values in the value fields. However, you cannot move caesuras
using this property.

● Offset X moves fermatas and breath marks horizontally.

● Offset Y moves fermatas and breath marks vertically.

Deactivating the property resets the selected fermatas and breath marks to their default
positions.

Changing the placement of fermatas relative to the staff
Fermatas are normally placed above the staff, but you can change their staff-relative placement
individually.

PROCEDURE

1. In Engrave mode, select the fermatas whose staff-relative placement you want to change.

2. In the Properties panel, activate Placement in the Holds and Pauses group.

3. Choose one of the following options:

● Above

● Below

RESULT
The selected fermatas appear above/below the staff.
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Changing the number of fermatas per staff
You can change the maximum number of fermatas that appear in each staff at individual
positions when there are multiple voices on a staff.

PROCEDURE

1. Select a fermata or multiple fermatas. You can do this in Write mode and Engrave mode.

2. In the Properties panel, activate Max. fermatas per staff in the Holds and Pauses group.

3. Select one of the following options from the menu:

● One per voice

● One per each side of staff

● One per staff

RESULT
The number of fermatas shown at the selected positions is changed.

TIP

You can change the maximum number of fermatas that can appear on a single staff project-wide
on the Holds and Pauses page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for holds and pauses on page 666

Positioning fermatas on barlines
You can position individual fermatas over a barline instead of over a note to indicate a gap
before the start of the following bar.

NOTE

Fermatas cannot be positioned on barlines if Max. fermatas per staff is also activated.

PROCEDURE

1. Select the fermatas you want to position over barlines. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Attach to barline in the Holds and Pauses group.

RESULT
The selected fermatas are positioned above the barline at the end of the bars they were in
originally, appearing only above staves that are not joined by the barline. Depending on the
instrumentation, this may mean they only appear at the top of the system.
Deactivating Attach to barline returns the selected fermatas to their default positions.

RELATED LINKS
Changing the number of fermatas per staff on page 670
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Key signatures are the markings that show the current key of music by indicating which notes in
the scale for that key are sharpened or flattened. They are shown at the start of each system on
every applicable staff.

Using key signatures saves space, as by indicating which notes are generally going to be sharp or
flat in the music in one group at the start of each system, these notes do not need an accidental
beside them every time they occur.

By default, key signatures apply to the whole score. However, there are certain situations where
some parts require their own key signature, independently of the rest of the ensemble. You can
input key signatures that apply to all staves or only apply to single staves in Dorico Pro.

Traditionally, accidentals are organized following the pattern of the circle of fifths, which is
different for sharp keys and flat keys.

In Dorico Pro, key signatures exist within the overarching tonality system for your project. The
two tonality systems that come as standard in Dorico Pro are 12-EDO and 24-EDO.

Once you have selected or created a tonality system for your project, you can create custom key
signatures and custom accidentals within that tonality system.

RELATED LINKS
Tonality systems on page 673
Input methods for key signatures on page 186

Key signature arrangements
Dorico Pro automatically follows conventions for the placement and appearance of key
signatures, such as showing accidentals in the accepted circle of fifths order and positioning key
signatures between clefs and time signatures.

The order in which accidentals are shown in key signatures is different for sharp keys and flat
keys.

● For sharps: F♯, C♯, G♯, D♯, A♯, E♯, B♯
● For flats: B♭, E♭, A♭, D♭, G♭, C♭, F♭
Accidentals are arranged automatically in these orders in Dorico Pro for all standard Western key
signatures. There is an accepted pattern for the placement of accidentals in a key signature, so
that they fit inside the staff according to the current clef. The pattern of accidentals is the same in
all clefs, apart from the tenor clef, which requires sharp key signatures to follow a different,
ascending pattern to ensure the accidentals fit on the staff.

Key signatures
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Clef Arrangement of sharps Arrangement of flats

Treble

Bass

Alto

Tenor

NOTE

For custom, non-standard key signatures, you can determine the order in which accidentals
appear in the Edit Custom Key Signature dialog.

RELATED LINKS
Custom key signatures on page 681
Changing the barline shown at key signature changes on page 512
Positions of key signatures on page 684

Types of key signatures
There are four types of key signatures in Dorico Pro, which can all be input, moved, and deleted
in the same ways.

The four types are:

● Major

● Minor

● Open key, or atonal

● No key signature (for specific instruments, such as horn or percussion)

Major/Minor key signatures

The key signature for a major key appears the same as the key signature for its relative minor,
and vice versa. For example, B♭ major has two flats in its key signature. This is the same number
of flats as for G minor, which is the relative minor key to B♭ major. The difference is that music in
G minor usually has sharpened Fs, as the seventh degree of the scale is raised in minor keys.
Therefore, if you input an F♯/G♭ after a G minor key signature, Dorico Pro prefers to spell it as F♯ in
most cases, in order to follow the convention of harmonic minor keys.
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A B flat major scale following a B flat major key
signature

A G minor scale following a G minor key signature

Open key signature

Although open, or atonal, key signatures appear the same as C major or A minor key signatures
because none shows any accidentals, open key signatures behave differently.

In an open key signature, the spelling of accidentals is based on the current direction of the
music. If the music is rising, sharps are preferred, whereas if the music is falling, flats are
preferred. There is no hierarchy of pitches in an open key signature, so the same pitch might be
spelled differently each time it appears depending on its context, even within a few bars.

In a C major or A minor key signature, accidentals are spelled based on the context of the major
or minor tonality implied. For example, in C major, sharps in general are preferred, whether the
music is going up or going down. Similarly, in A minor, G♯ in particular is preferred, whether the
music is going up or going down, as G♯ is the leading note in A minor.

No key signature

Some instruments are accustomed to seeing no key signatures in their parts, no matter the
overall key of the piece. These instruments include timpani, percussion, horn, trumpet, and
sometimes the harp. If you have added the No key sig version of these instruments, then no key
signature is shown in their parts, even if they are a transposing instrument, such as horn or
trumpet.

Any pitch can be input into these instruments, and they show accidentals if needed.

RELATED LINKS
Adding instruments to players on page 104

Project-wide engraving options for key signatures
You can find options for the project-wide appearance of key signatures on the Key Signatures
page in Engrave > Engraving Options.

The options on the Key Signatures page allow you to change the key signature cancellation style
and the spacing gaps between accidentals in key signatures.

TIP

If you want to change the barline shown at key signature changes, you can find this option on
the Barlines page in Engraving Options.

RELATED LINKS
Engraving Options dialog on page 299
Changing the barline shown at key signature changes on page 512

Tonality systems
The term “tonality system” is used in Dorico Pro to encompass three crucial elements that
together make up the concept of tonality.

The three elements that make up tonality systems are:
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● A number of equal divisions of the octave, or EDO. For example, standard Western scales
with semitone steps have 12-EDO.

● A set of accidentals. This allows you to notate how much a note is raised or lowered. This
can be a traditional or a custom set of accidentals, either selected from the wide variety
available or of your own design.

● A key signature. This can be a traditional Western key signature, or a custom key signature
of your own design.

RELATED LINKS
Custom tonality systems on page 675
Changing the tonality system on page 674
Playback of custom tonality systems on page 683

Equal Division of the Octave (EDO)
EDO stands for Equal Division of the Octave: the number of equal pieces, or intervals, into which
an octave is divided. In Dorico Pro, you can create any number of divisions of an octave and
design custom key signatures and custom accidentals for each tonality system.

Traditional Western harmony is based on equal temperament, another method used to describe
tonality systems, or 12-EDO, as the traditional scale from C-C is made up of twelve steps spread
across the seven notes in the scale.

When you edit the 12-EDO tonality system in the Edit Tonality System dialog, you can see how
these steps are divided across each intervals in the scale. For example, between the notes A and
B there are two steps, but between B and C there is one step. This is because in 12-EDO, each
step represents a semitone, and there are two semitones between A and B according to standard
equal temperament, but only one semitone between B and C.

To have the smallest step in the tonality system be a quarter tone rather than a semitone, the
octave must be divided into twice as many equal divisions as 12-EDO. Therefore, to be able to use
quarter tone accidentals in a project, you must choose the Equal temperament (24-EDO)
tonality system for the project.

Although you can divide the octave into any number of divisions, to be able to show a standard
Western key signature, the number of equal divisions in the octave must be divisible by 12.

EDO also allows you to map non-conventional Western pitches on to the seven note names A-G,
and create a coherent notation to express that, because there is no limit to how you can divide
the octave. For example, Turkish music is traditionally divided in 53-EDO, the division of which is
usually spread across the notes A-A with the following number of divisions for each interval:
9-4-9-9-9-4-9.

RELATED LINKS
Custom tonality systems on page 675
Edit Tonality System dialog on page 675

Changing the tonality system
You can change the tonality system used in your project at key signature changes, including
changing to a custom tonality system you have created.

PREREQUISITE
If you want to use a tonality system other than Equal temperament (12-EDO) or Equal
temperament (24-EDO), you have created a custom tonality system.
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PROCEDURE

1. In Write mode, select an item at the position from which you want to change the tonality
system.

2. Without deselecting the item, select the tonality system you want from the menu in the
Tonality System section of the Key Signatures, Tonality Systems, and Accidentals panel.

3. Input a new key signature.

RESULT
The tonality system is changed from the key signature you input until the next key signature with
a tonality system change or the end of the flow.
If you selected a tonality system that allows microtonal accidentals, such as Equal temperament
(24-EDO), microtonal accidentals become available in the Accidentals section of the Key
Signatures, Tonality Systems, and Accidentals panel.

RELATED LINKS
Input methods for key signatures on page 186
Inputting microtonal accidentals on page 493

Custom tonality systems
Custom tonality systems allow you to specify a unique number of divisions of the octave for your
project. This can be useful for music not based on traditional Western harmony. In Dorico Pro,
you can design your own custom accidentals and combine them into custom key signatures
within each custom tonality.

You can find existing tonality systems in your project in the Tonality System section of the Key
Signatures, Tonality Systems, and Accidentals panel.

Dorico Pro provides two tonality systems in each project by default: Equal temperament (12-
EDO) and Equal temperament (24-EDO).

You can create custom tonality systems and edit existing tonality systems in the Edit Tonality
System dialog

RELATED LINKS
Custom divisions of the octave on page 677
Custom accidentals on page 677
Custom key signatures on page 681
Key Signatures, Tonality Systems, and Accidentals panel on page 187

Edit Tonality System dialog
The Edit Tonality System dialog allows you to create custom tonality systems and edit existing
tonality systems.

You can open the Edit Tonality System dialog in the following ways:

● To create a new tonality system, click New Tonality System in the Tonality System
section of the Key Signatures, Tonality Systems, and Accidentals panel.

● To edit an existing tonality system, click Edit Tonality System in the Tonality System
section of the Key Signatures, Tonality Systems, and Accidentals panel.
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Edit Tonality System dialog

The Edit Tonality System dialog contains the following sections:

1 Name
Allows you to enter a name for a new tonality system, or edit the name of an existing
custom tonality system you created.

2 Divisions
Allows you to specify how many divisions of the octave you want assigned to each interval.

3 Accidentals
Displays the accidentals currently available for the selected tonality system. The two
buttons at the bottom allow you to edit existing accidentals, and to create new accidentals.

4 Custom Key Signatures
Displays the key signatures currently available for the selected tonality system. The two
buttons at the bottom allow you to edit existing key signatures, and to create new key
signatures.

New Accidental/New Key Signature button Edit Accidental/Edit Key Signature button

Once you have decided on the number of divisions your octave has, and how many divisions are
assigned to each interval, in the Divisions section of the dialog, you can assign existing and
create custom accidentals for each raising/lowering pitch delta you want to notate in the Edit
Accidental dialog.

You can arrange these accidentals into a custom key signature in the Edit Custom Key
Signature dialog.

RELATED LINKS
Custom tonality systems on page 675
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Edit Accidental dialog on page 678
Edit Custom Key Signature dialog on page 682

Custom divisions of the octave
You can change the number of divisions of the octave for an existing tonality system, or create a
new tonality system with as many divisions of the octave as you like.

In the Divisions section of the Edit Tonality System dialog, you can change the number of
divisions assigned to each interval. The total number of divisions of an octave, which is shown at
the top of the section, is updated automatically as you change the number of divisions.

The Divisions section of the Edit Tonality System dialog, as it appears when editing the existing 12-EDO
tonality system.

In Equal temperament, or 12-EDO, the total number of divisions is 12. There are 2 divisions
between A and B, 1 division between B and C, and so on. This follows the standard Western
pattern which you can also see in the pattern of white and black keys on a keyboard.

Although you can divide the octave into any number of divisions, the number of equal divisions
in the octave must be divisible by 12 to be able to show a standard Western key signature in
Dorico Pro.

RELATED LINKS
Custom key signatures on page 681
Edit Tonality System dialog on page 675

Custom accidentals
Custom accidentals can contain traditional accidental glyphs but also other musical symbols,
text, and graphics. This allows you to design custom accidentals that express specific pitch deltas
in your custom tonality systems.

You can find all accidentals available in the current tonality system in the Accidentals section of
the Edit Tonality System dialog.
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The Accidentals section of the Edit Tonality System dialog, as it appears when editing the existing 12-EDO
tonality system.

You can create new and edit existing custom accidentals in the Edit Accidental dialog.

NOTE

You can edit any accidental that is included in either of the default tonality systems that come
with Dorico Pro. New tonality systems start with a natural accidental, which you can edit or
delete.

RELATED LINKS
Edit Tonality System dialog on page 675

Edit Accidental dialog

The Edit Accidental dialog allows you to create new and edit existing custom accidentals.

● You can open the Edit Accidental dialog by clicking either New Accidental or Edit
Accidental in the action bar at the bottom of the Accidentals section of the Edit Tonality
System dialog.
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Edit Accidental dialog

The Edit Accidental dialog contains the following sections:

1 Name
Allows you to enter a name for your accidental.

2 Pitch delta
Allows you to set a value for what effect this accidental has on notes to which it is added.
For example, a pitch delta of 2 raises notes by two equal divisions of the octave.

3 Accidental component selector
Allows you to choose components to add to your accidental. You can add different types of
components by clicking the respective tab titles.

● Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting
different fonts and different ranges from the menus. Click Add Glyph to add the
selected glyph to the accidental.

NOTE

A full list of the different ranges of glyphs is available on the SMuFL website.

● Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected
text, or input text, to the accidental.

● Graphic: Allows you to load a new graphics file, or select an existing graphic from
the Select existing list, in SVG, PNG, or JPG format. You can see a preview of the
graphic in the Preview box. Click Add Graphic to add the selected graphic to the
accidental.

4 Editor
Allows you to arrange and edit the components that make up your accidental. You can use
the controls at the bottom of the dialog to edit and arrange accidental components.

5 Editor action bar
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Contains selection and view options for the editor.

● Zoom
Allows you to change the zoom level in the editor.

● Select
Allows you to select the next/previous component.

● Delete

Deletes the selected component.

6 Controls
Contains controls that allow you to edit individual components. Controls are divided into
tabs according to the aspect of the selected component they affect. For accidentals, only
the Component, Attachments, and Cut-outs tabs are available as the Stem tab does not
apply to accidentals.
The Component tab contains the following options:

● Offset: Controls the position of the selected component. X moves it horizontally, Y
moves it vertically.

● Scale: Controls the size of the selected component. For graphics, X controls its
width, Y controls its height.

NOTE

Although some components scale their height and width independently, others
retain their aspect ratio, meaning only one value affects their overall size.

● Z order: Allows you to Bring Forward or Send Backward the selected component in
relation to other components when they overlap.

The Attachments tab is only available if the accidental comprises at least two separate
components. It contains the following options:

● Attachment from: Sets the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend
that you select a right edge attachment point for Attachment from.

● Attachment to: Sets the attachment point on the selected component which
attaches to the component to its left. We recommend that you select a left edge
attachment point for Attachment to.

The Cut-outs tab allows you to mark individual corners within an accidental component
that can overlap with other accidentals, for example, in order to position accidentals closer
together in dense chords. It contains the following options for each of the four corners,
which are labelled according to their compass direction:

● Width: Sets the width of the cut-out area.

● Height: Sets the height of the cut-out area.

● Add: Adds a cut-out to the corresponding corner.

● Delete: Removes the cut-out from the corresponding corner.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.
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The attachment points have the following names in the Edit Accidental dialog:

1 Top Left

2 Top Center

3 Top Right

4 Middle Left

5 Middle Right

6 Baseline Left (text only)

7 Baseline Center (text only)

8 Baseline Right (text only)

9 Bottom Left

10 Bottom Center

11 Bottom Right

RELATED LINKS
Edit Tonality System dialog on page 675

Custom key signatures
Custom key signatures can comprise traditional accidentals in a different order, or custom
accidentals you have designed in a specific order for your requirements.

You can find all key signatures available in the current tonality system in the Custom Key
Signatures section of the Edit Tonality System dialog.

The Custom Key Signatures section of the Edit Tonality System dialog, as it appears when creating or
editing custom tonality systems.
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NOTE

If you edit one of the default tonality systems that come with Dorico Pro, no key signatures are
available to edit in this section. However, you can create new key signatures within one of the
default tonality systems.

You can create new and edit existing custom key signatures for both new and existing tonality
systems in the Edit Custom Key Signature dialog.

RELATED LINKS
Edit Tonality System dialog on page 675

Edit Custom Key Signature dialog

The Edit Custom Key Signature dialog allows you to create new and edit existing custom key
signatures.

● You can open the Edit Custom Key Signature dialog by clicking either New Key
Signature or Edit Key Signature in the action bar in the Custom Key Signatures section
of the Edit Tonality System dialog.

Edit Custom Key Signature dialog

The Edit Custom Key Signature dialog contains the following sections:

1 Name
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Allows you to enter a name for your key signature.

2 Clef
Shows how your key signature appears in treble clef, bass clef, alto clef, and tenor clef. You
can edit your key signature in any of these clefs.

3 Root
Allows you to select the base note of your key signature from the menu.

4 Accidentals
Allows you to add accidentals from your tonality system to the key signature, including
custom accidentals you have created in the Edit Accidental dialog. Click Add Accidental
to Key Signature to add the selected accidental to the key signature.

5 Editor
Allows you to arrange accidentals in your preferred order using the Order arrow buttons,
and change their position on the staff using the Note arrow buttons and Octave arrow
buttons.

RELATED LINKS
Edit Tonality System dialog on page 675
Edit Accidental dialog on page 678

Playback of custom tonality systems
Dorico Pro can play back custom tonality systems with any number and distribution of octave
divisions.

Dorico Pro achieves full microtonal playback by calculating the appropriate pitch delta for every
note, whether or not it is written with an accidental. Depending on the virtual instruments used
for playback, Dorico Pro produces microtonal playback in different ways.

● For HALion virtual instruments, Dorico Pro uses VST 3 Note Expression.

● For all other instruments, including NotePerformer, Dorico Pro uses the VST 2 detune
parameter.

RELATED LINKS
Custom tonality systems on page 675
Changing the playback tuning on page 435

Deleting key signatures
You can delete key signatures without affecting the pitches of notes. Where appropriate, pitches
are shown with accidentals after you have deleted a key signature.

NOTE

● You cannot hide key signatures as they provide crucial information about the pitch of
notes. If you do not want to see a key signature, you can input an open key signature or
delete all key signatures from the flow or project.

● Instruments that do not usually have key signatures, such as timpani or horn, have a No
key sig version in Dorico Pro which ensures no key signature is shown for those
instruments. You can select No key sig versions of instruments when adding/changing
instruments in Setup mode.

PROCEDURE

1. In Write mode, select any of the following that you want to delete:

● Key signatures

Key signatures
Deleting key signatures 

683
Dorico 2.2.20



● Key signature signposts of key signatures with no accidentals in the current layout

2. Press Backspace or Delete.

RESULT
The selected key signatures are deleted from the score. The pitches of notes in the bars following
the deleted key signatures are not changed, but the notes are shown with accidentals if the
deleted key signature indicated an accidental for them, up until the next existing key signature or
the end of the flow.

NOTE

If you delete the only key signature in the flow, your music appears without a key signature, with
accidentals shown as necessary. This is treated as if there were an open key signature rather
than a key signature of A minor or C major.

RELATED LINKS
Input methods for key signatures on page 186
Adding instruments to players on page 104
Changing instruments on page 106

Multiple simultaneous key signatures
You can have multiple key signatures simultaneously by inputting each one onto a single staff.

NOTE

You do not have to input multiple simultaneous key signatures if you have transposing
instruments in your score. Dorico Pro handles instrument transpositions automatically.

You can check the transposition of transposing instruments by choosing Edit > Transposed
Pitch to see the music in your layout at written pitch rather than concert pitch.

Alternatively, you can open the individual part layout of a transposing instrument and compare it
to the full score.

RELATED LINKS
Input methods for key signatures on page 186

Positions of key signatures
Key signatures are positioned between clefs and time signatures by default, and are shown on
every staff that requires a key signature. They are not shown on staves for unpitched
instruments.

Key signatures are shown at the start of a piece and at the start of subsequent movements, even
if the music carries straight on and in the same key. Unlike time signatures, key signatures
appear at the start of every system in full score and part layouts, even if the key signature has
not changed. They apply until the end of the flow or until the next key signature change,
whichever comes first.

The correct position for key signatures is between clefs and time signatures.
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If a key signature change occurs during a piece or movement, it should be placed immediately
after a barline. It is customary to have a double barline where a key signature change takes
place, which is the default setting in Dorico Pro. However, you can change the default barline
shown at key signature changes.

Examples of key signatures positioned after double barlines

You can move key signatures to new rhythmic positions in Write mode. They are positioned
according to your settings on the Key Signatures and Spacing Gaps pages in Engrave >
Engraving Options.

If you find you need to move individual key signatures graphically,you can do this in Engrave
mode, but this does not change their rhythmic positions.

If you want to adjust the default position of key signatures relative to notes or barlines, you must
change the project-wide values for spacing gaps on the Spacing Gaps page in Engraving
Options.

RELATED LINKS
Key signature arrangements on page 671
Moving key signatures rhythmically on page 686
Moving key signatures graphically on page 686
Changing the barline shown at key signature changes on page 512

Project-wide spacing gaps for key signatures
Options for spacing gaps allow you to change the minimum gaps between objects project-wide,
including key signatures.

Among the available values on the Spacing Gaps page in Engrave > Engraving Options, the
following minimum values directly relate to key signatures:

● Gap after barline before clef, key or time signature

● Gap after cancellation naturals

● Gap after key signature

● Gap after end repeat barline

NOTE

Other values may have an effect on the position of key signatures, but they also affect other
objects.

On the Key Signatures page in Engraving Options, you can change the following gaps:

● Gap between accidentals in key signatures

● Gap between cancellation naturals

RELATED LINKS
Engraving Options dialog on page 299
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Moving key signatures rhythmically
You can move key signatures to new rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the key signatures you want to move.

NOTE

When using the mouse, you can only move one key signature rhythmically at a time.

2. Move the selected key signatures according to the current rhythmic grid value in any of
the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the key signature to the right/left.

RESULT
The key signatures are moved to new rhythmic positions. They take effect from their new
positions until the next key signature, or the end of the flow, whichever comes first.

NOTE

● Key signatures can only be moved along the staff. If you want to move a key signature
across staves, you must delete the key signature and input a new key signature on the
other staff.

● Only one key signature can exist at each rhythmic position, except for key signatures that
only apply to single staves. If a key signature passes over another key signature as part of
its move, the existing key signature is deleted and replaced by the key signature being
moved.

You can undo this action, but any key signatures deleted in the process are only restored if
you moved the key signature using the keyboard.

RELATED LINKS
Input methods for key signatures on page 186

Moving key signatures graphically
You can make individual changes to the graphical position of key signatures without affecting the
positions of any other items.

PROCEDURE

1. In the Engrave toolbox, activate Note Spacing.

2. Select the square handle above the key signature you want to move.

A smaller circular handle appears beside the key signature.

3. Press Tab to select the circular handle.
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4. Move the handle in any of the following ways:

● Press Alt-Right Arrow to move it to the right.

● Press Alt-Left Arrow to move it to the left.

NOTE

● If you want to move handles by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● You cannot move note spacing handles with the mouse, you can only move
them using the keyboard.

RESULT
The key signature is moved graphically to the right/left.

TIP

When Graphic Editing is selected in the Engrave toolbox, you can also change Spacing offset in
the Key Signatures group of the Properties panel to move key signatures horizontally. However,
this also affects global note spacing at the rhythmic position of the key signature, including
moving cancellation naturals.

You can also move cancellation naturals graphically, independently of the subsequent key
signature and without affecting the spacing of any other item using the Cancellation naturals X
offset property.

RELATED LINKS
Note spacing on page 381

Transposing key signatures alongside selections
You can transpose key signatures at the same time as transposing notes, which transposes both
key signatures and notes by the same degree.

PROCEDURE

1. In Write mode, make a selection that includes both a key signature change and notes.

2. Choose Write > Transpose to open the Transpose dialog.

3. In the Transpose dialog, adjust the parameters required for your transposition, such as
interval and quality.

4. Activate Transpose key signatures.
It is activated automatically if your selection includes a key signature.

5. Click OK to save your changes and close the dialog.

RESULT
All notes and key signatures within the selection are transposed by the degree you set in the
dialog.

NOTE

If a key signature included in the transposed selection applies to all staves, then it is transposed
on all staves in the layout, even if your selection did not include all staves.
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Individual key signatures, that is, key signatures added only to single staves using the Alt key, are
transposed if included in a selection, but this does not affect any other staff in the layout.

RELATED LINKS
Selecting/Deselecting notes and items individually on page 273
Large selections on page 274
Transpose dialog on page 175

Enharmonic equivalent key signatures
Enharmonic equivalent key signatures are keys with different names that include the same
pitches, such as C♯ major and D♭ major. Dorico Pro follows the convention for transposing to keys
with the same type of accidental as the previous key, except where the enharmonic equivalent
key signature has fewer accidentals.

When transposing selections of notes, Dorico Pro prefers keys with the same type of accidental
as the previous key signature. When choosing key signatures for transposing instruments, Dorico
Pro prefers key signatures with the same type of accidental as the current concert pitch key.

However, there are some instances where you might prefer to transpose to a key with a different
type of accidental as it has fewer accidentals than the enharmonic equivalent key. For example,
C♯ major has seven sharps, whereas the enharmonic equivalent key of D♭ major only has five
flats. This means the player has to remember the accidentals for fewer notes.

Transposing to an enharmonic equivalent key with fewer accidentals can have the added benefit
of improving readability by avoiding double sharps or double flats. For example, transposing
music from F♯ to G♯ requires the leading note to be spelled as an F, but transposing to A♭ instead
means the leading note is G♮.

G♯ major requires a double sharp leading note A♭ major, the enharmonic equivalent to G♯, does not
require a double sharp leading note

By default, Dorico Pro selects an enharmonic equivalent key signature if it has fewer accidentals.
However, you can change this setting by deactivating Prefer enharmonic equivalent key
signatures with fewer accidentals in the Transposition section of the Accidentals page in
Write > Notation Options.

How key signatures affect transposing instruments

If there is a key signature in the full score, it is transposed for a transposing instrument by the
same degree as the transposing interval for the instrument. For example, in a project in E major,
a B♭ clarinet part has a key of F♯ major, as a B♭ clarinet sounds a whole tone below its notated
pitch.

Instruments that do not show a key signature

Some instruments are accustomed to seeing no key signatures in their parts, no matter the
overall key of the piece. These instruments include timpani, percussion, horn, trumpet, and
sometimes the harp. If you have input the No key sig version of these instruments, then no key
signature is shown in their parts, even if they are a transposing instrument, such as horn or
trumpet.

You can still transpose music in the staves of these instruments, but they show accidentals as
necessary, instead of showing a key signature.
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RELATED LINKS
Notation Options dialog on page 139
Transpose dialog on page 175
Transposing selections on page 176
Adding instruments to players on page 104

Cautionary key signatures
When a key signature change occurs at a system break, either in the score or in a part, the new
key signature is shown at the end of the first system as well as at the start of the new system.

This is sometimes considered a “cautionary key signature”, as players become used to seeing the
key signature at the start of the system and therefore may miss a change of key signature if it is
not conspicuously shown at the end of systems.

In Dorico Pro, as key signature changes occur immediately after barlines, the key signature at the
end of a system is the key signature itself, rather than a cautionary key signature.

If the music is separate enough that you do not want to see a key signature at the end of a
system and you cannot change where the system break occurs, you can separate the music by
creating a new flow at the point of the system break.

RELATED LINKS
Flows on page 117
Splitting flows on page 289
Formatting panel on page 292
Inserting system breaks on page 359
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In Dorico Pro, the term lyrics is used for all text that is sung by singers.

To differentiate sung text from any other forms of text that often appear in musical scores, other
forms of text are referred to as performance instructions, tempos, dynamics, and so on.

In Dorico Pro, lyrics were designed so that it is simple to make changes to existing lyrics without
having to re-input new lyrics each time. For example, you can change the syllable type of lyrics so
that they are either followed or not followed by a hyphen.

Lyrics are organized into lines to ensure consistent horizontal alignment and to make showing
verse numbers simple and accurate. There are different types of lyric lines for lyrics with different
purposes, and the appearance of lyrics changes depending on their line type. For example, lyrics
in a chorus line are shown in an italic font.

When inputting lyrics, you can use key commands to switch between lyric lines, to change on
which side of the staff lyrics are input, and to switch the lyric style between normal lyrics, chorus
lyrics, and translation lyrics. You can also change the type of lyrics after they have been input.

You can input multiple lines of lyrics, chorus lyrics, and translations, both above or below staves.

You can filter lyrics according to their type and lyric line by choosing Edit > Filter > Lyrics and
choosing a lyric type or lyric line from the menu.

RELATED LINKS
Types of lyrics on page 692
Lyric line numbers on page 701
Filters for lyrics on page 691
Inputting lyrics on page 246
Changing the syllable type of existing lyrics on page 694

General placement conventions for lyrics
Lyrics are generally placed below the staff to which they apply, and are positioned so that they
align horizontally with their corresponding notehead.

A plain font is generally used for normal lyrics, and an italic font is generally used for chorus
lyrics and translation lyrics in order to differentiate them.

The horizontal spacing of lyrics must be wide enough so that words or syllables do not overlap
with the words or syllables on either side. For this reason, note spacing must sometimes be
adjusted to accommodate lyrics.

To reduce how severely the note spacing is changed to accommodate lyrics, which can distort the
appearance of rhythms, Dorico Pro allows the alignment of some lyrics to be adjusted relative to
their corresponding notes. For example, if a long, single-syllable word on a long note follows
another long, single-syllable word on a short note, the second word is moved a little to the right
to give both words enough space.

Lyrics
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A short note followed by a long note, where the horizontal position of the lyrics is automatically adjusted for
legibility

RELATED LINKS
Positions of lyrics on page 695
Changing the font styles used for lyrics on page 704

Project-wide engraving options for lyrics
You can find options for the project-wide appearance and placement of lyrics on the Lyrics page
in Engrave > Engraving Options.

The options on the Lyrics page allow you to change the default appearance, spacing, and
position of lyrics, and the appearance and position of lyric hyphens and lyric extender lines.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Filters for lyrics
In Dorico Pro, lyrics filters allow you to select all lyrics of a specified type across your project or
across a specific selection.

The following filters are available in the menu when you choose Edit > Filter > Lyrics:

All Lyrics
Selects all types of lyrics in the current selection, with any lyric line number and
placement above/below the staff.

Line 1
Selects only Line 1 lyrics and translation lyrics for Line 1 in the current selection,
including Line 1 below the staff and Line 1 above the staff.

Line 2
Selects only Line 2 lyrics and translation lyrics for Line 2 in the current selection,
including Line 2 below the staff and Line 2 above the staff.

Line 3
Selects only Line 3 lyrics and translation lyrics for Line 3 in the current selection,
including Line 3 below the staff and Line 3 above the staff.

Line 4
Selects only Line 4 lyrics and translation lyrics for Line 4 in the current selection,
including Line 4 below the staff and Line 4 above the staff.

Line 5
Selects only Line 5 lyrics and translation lyrics for Line 5 in the current selection,
including Line 5 below the staff and Line 5 above the staff.
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Above Staff
Selects all lyrics above the staff in the current selection. You can use this filter in
addition to the other filters. For example, you can filter first by line number, and then
filter again by staff-relative placement.

Below Staff
Selects all lyrics below the staff in the current selection. You can use this filter in
addition to the other filters. For example, you can filter first by line number, and then
filter again by staff-relative placement.

Chorus
Selects all chorus lyrics in the current selection.

Translations
Selects all translation lyrics in the current selection.

RELATED LINKS
Large selections on page 274

Selecting lyrics using filters
You can use lyric filters to select all lyrics of a specified type across your project or across a
specific selection.

PREREQUISITE
You filter setting is set to Select Only. You can check this by choosing Edit > Filter > Select Only.

PROCEDURE

1. In the music area, make a selection that includes all the lyrics you want to select.
For example, press Ctrl/Cmd-A to select the whole flow.

2. Choose Edit > Filter > Lyrics > [Lyrics type].

RESULT
All lyrics of the selected type in your selection are selected. For example, if you choose Edit >
Filter > Lyrics > Chorus, all chorus lyrics in your selection are selected.

RELATED LINKS
Filters for lyrics on page 691
Large selections on page 274

Types of lyrics
Lyrics are divided into different lyric types in Dorico Pro.

Lyric lines
Lyric lines contain normal lyrics and can be shown with verse numbers.

Chorus lines
Chorus lines contain lyrics in an italic font and are placed between lyric lines. For
example, if there are two lyric lines, the chorus line appears between Line 1 and Line
2.
Chorus lines do not have verse numbers.

Lyrics
Types of lyrics 

692
Dorico 2.2.20



Lyric line translations
Lyric line translations show the text in lyric lines or chorus lines in different
languages. They are placed directly below the lyric line or chorus line of which they
are a translation. They are shown in an italic font.
Each lyric line can have its own lyric line translation, including chorus lines.
Lyric line translations do not have verse numbers, as they are part of the line of
which they are a translation.

You can input all types of lyrics using the lyrics popover. The icon shown on the left-hand side of
the popover indicates the type of lyric currently being input.

RELATED LINKS
Lyric line numbers on page 701
Changing the line number and type of lyric lines on page 702
Lyrics popover on page 247

Changing the type of individual lyrics
You can change the type of individual lyrics after they have been input. For example, you can
change lyrics into chorus lyrics or translation lyrics.

PROCEDURE

1. Select the individual lyrics whose type you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate/deactivate the following properties, individually or
together, in the Lyrics group:

● Chorus

● Is translation

RESULT
If you activate Chorus, the selected individual lyrics are changed to chorus lyrics.
If you activate Is translation, the selected lyrics are changed to translation lyrics of the same
lyric line number. For example, selecting lyrics in Line 2 and activating Is translation turns them
into translation lyrics for Line 2.
If you activate both properties, the selected lyrics are changed to translation lyrics of the chorus.
If you deactivate both properties, the selected lyrics are changed to normal lyrics. Their line
number is indicated by the number in Line number in the Lyrics group of the Properties panel.

NOTE

If other chorus lines exist at the same position on the side of the staff where you want to change
your current selection to chorus lines, the two lines collide. To avoid this, change the type of the
whole lyric line, which automatically avoids collisions.

RELATED LINKS
Lyric line numbers on page 701
Showing lyrics in italics on page 705
Changing the line number and type of lyric lines on page 702
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Types of syllables in lyrics
There are different types of syllables in lyrics, depending on their position in words. The key you
press to advance the popover indicates the syllable type for each lyric.

Dorico Pro defines lyrics as different syllables depending on how you advance the popover when
inputting lyrics.

Whole word
Lyrics are considered a whole word if the lyric comes after a gap and is followed by a
gap or a period.
No hyphens are shown either side of whole word lyrics. Extender lines can be shown
after lyrics.

Start
Lyrics are considered the start syllable in a multi-syllabic word if the lyric comes after
a gap, but is followed by a hyphen.
Hyphens are shown after start lyrics, which can be continuation hyphens depending
on the distance before the next lyric in the same lyric line.

Middle
Lyrics are considered the middle syllable in a multi-syllabic word if the lyric comes
after a hyphen, and is followed by a hyphen.
Hyphens are shown after middle lyrics, which can be continuation hyphens
depending on the distance before the next lyric in the same lyric line.

End
Lyrics are considered the end syllable in a multi-syllabic word if the lyric comes after
a hyphen but is followed by a gap or a period.
Extender lines can be shown after end lyrics.

RELATED LINKS
Inputting lyrics on page 246

Changing the syllable type of existing lyrics
You can change the syllable type of lyrics after they have been input.

For example, if you advanced the lyrics popover to the next note by pressing Space but you later
want it to be followed by a hyphen, you can change its syllable type.

NOTE

Changing the syllable type changes whether a hyphen is shown after the selected lyrics, not
before them. Therefore, if you want to show a hyphen before lyrics, you must change the syllable
type of the lyrics immediately preceding them.

PROCEDURE

1. Select the lyrics whose syllable type you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, select one of the following options from the Syllable type menu in
the Lyrics group:

● Whole word

● Start

● Middle
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● End

RESULT
Lyrics with a syllable type of Whole word or End are followed by a space.
Lyrics with a syllable type of Start or Middle are followed by a hyphen.

RELATED LINKS
Inputting lyrics on page 246

Changing the text of existing lyrics
You can change the text of lyrics after they have been input.

PROCEDURE

1. In Write mode, select the lyric you want to change.

NOTE

You can only change one lyric at a time.

2. Press Return or Shift-L to open the lyrics popover.

3. Change the existing text in the lyrics popover.

4. Optional: If you want to change other existing lyrics as well, advance the popover in one of
the following ways:

● To advance the popover to the next note if you entered a complete word, or the final
syllable in a multi-syllabic word, press Space.
Existing lyrics are automatically selected in the popover when you press Space.

● To advance the popover to the next note if you entered one syllable of a multi-
syllabic word, press -.

● To move the cursor one character to the right, press Right Arrow.

● To move the cursor one character to the left, press Left Arrow.
The cursor automatically moves to the next/previous lyric/note if you keep pressing
the arrow keys.

5. Press Return or Esc to close the popover when you have finished changing lyrics.
The popover closes automatically when you reach the last note on the staff.

RELATED LINKS
Lyric line numbers on page 701
Inputting lyrics on page 246

Positions of lyrics
Dorico Pro automatically positions lyrics and makes adjustments to accommodate variations in
the length of lyrics, including adjusting the horizontal alignment of lyrics in melismatic music.
However, you can also move lyrics manually and also change their default positions project-wide.

You can move lyrics to different rhythmic positions in Write mode. They are positioned by default
according to your chosen options on the Lyrics page in Engrave > Engraving Options.

You can move individual lyrics graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached.
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NOTE

The horizontal position of lyrics is automatically adjusted in Dorico Pro to minimize changes to
the note spacing. Syllables are moved by small amounts either left or right to accommodate
longer syllables without distorting the appearance of note rhythms.

Moving lyrics graphically in Engrave mode overrides the automatic spacing for the selected lyrics.
If you move a lyric whose position was automatically readjusted, the note spacing at that
rhythmic position might change.

You can change the default positions of lyrics project-wide on the Lyrics page in Engraving
Options.

The default settings for lyrics on the Lyrics page in Engraving Options are optimized for scores
with comfortable spacing. If your project requires note spacing to be narrower, with less room
for each note, change these settings to achieve a clearly legible result without the need for lots of
editing in Engrave mode.

For scores that have less horizontal space, the following changes often improve the appearance
of lyrics and rhythmic space:

● Make minimum gaps smaller, such as the minimum gap between lyrics and hyphens, in
the Hyphens section of the Lyrics page in Engraving Options.

● Increase the amount that lyrics can be adjusted by in the Spacing section of the Lyrics
page in Engraving Options.

Positions of syllables

The number of notes sung on syllables or words determines how the lyrics are positioned:

● Single syllables, which are whole words or parts of longer words that are sung on only one
note, are centered on their corresponding note.

● Melismata, which are syllables or words that are sung on more than one note, are left-
aligned with the left side of the first note to which they apply.

Placement of lyric lines

Lyrics are placed relative to other lyric lines according to their line number. For example, lyrics in
Line 1 are placed at the top, including when there are multiple lyric lines above the staff.

If a line of lyrics is missing across the width of a whole system, no additional gap is left between
the remaining lines of lyrics.

EXAMPLE
You have three lines of lyrics, but one system does not have a second line of lyrics. On this
system, the third line of lyrics is moved upwards, closer to the first line of lyrics.
If a subsequent system does not have a first line, but does have the second and third lines, then
the second and third lines of lyrics are moved upwards. The second line of lyrics takes the place
of the first line.

RELATED LINKS
Project-wide engraving options for lyrics on page 691
Moving lyrics graphically on page 697
Changing the placement of lyric lines relative to the staff on page 703
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Moving lyrics rhythmically
You can move lyrics to new rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the lyrics you want to move.

2. Move the lyrics according to the current rhythmic grid value in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

NOTE

You cannot move lyrics rhythmically with the mouse, you can only move them using the
keyboard.

RESULT
The selected lyrics are moved to the right/left according to the current rhythmic grid value.

Moving lyrics graphically
You can move individual lyrics graphically without changing the rhythmic positions to which they
apply.

NOTE

Moving lyrics graphically in Engrave mode overrides the automatic spacing of the selected lyrics.
If you move a lyric whose position was automatically readjusted, the spacing at that rhythmic
position might change.

PROCEDURE

1. In Engrave mode, select the lyrics you want to move.

2. Move the selected lyrics in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them to the right/left.

RESULT
The selected lyrics are moved to the right/left.

NOTE

● You cannot move lyrics upwards/downwards, as their vertical position is determined by
their lyric line number and your project-wide settings in Engrave > Engraving Options.

● You can change the line number of whole lyric lines, and the placement of whole lyric lines
relative to the staff. You can also change the position of lyrics relative to the staff, other
lyric lines, and to other objects for all lyrics project-wide in the Vertical Position section of
the Lyrics page in Engraving Options.
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RELATED LINKS
Changing the line number and type of lyric lines on page 702
Changing the placement of lyric lines relative to the staff on page 703

Changing the alignment of lyrics relative to notes
By default, the center of lyrics is aligned horizontally with noteheads, but you can change the
horizontal alignment of individual lyrics.

You cannot change the alignment of lyrics relative to notes project-wide, as the horizontal
position of lyrics is automatically adjusted in Dorico Pro to minimize changes to the note spacing.

NOTE

Changing the alignment of lyrics manually overrides the automatic spacing for the selected
lyrics. If you change the alignment of a lyric whose position was automatically readjusted, the
note spacing at that rhythmic position might change.

PROCEDURE

1. Select the lyrics whose alignment you want to change. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Lyric text alignment in the Lyrics group.

3. Select one of the following alignment options from the menu:

● Left

● Center

● Right

RESULT
The alignment of the selected lyrics is changed.

Lyric hyphens and lyric extender lines
Lyric hyphens indicate that individual lyrics are syllables within multi-syllabic words, for example,
“Hal-le-lu-jah”. Lyric extender lines indicate that individual lyrics extend across multiple notes.

Dorico Pro automatically inputs and positions lyric hyphens when you advance the lyrics popover
by pressing - between syllables, and lyric extender lines when you advance the lyrics popover by
pressing Space multiple times after an entry.

In Engrave mode, lyric hyphens and lyric extender lines have two square handles, one at the start
and one at the end. You can move whole lyric hyphens and lyric extenders lines, and you can also
move their handles independently of each other. This allows you to lengthen/shorten lyric
hyphens and extender lines, which for lyric hyphens means increasing/decreasing the length of
the space in which lyric hyphens are shown.

Lyric extender line with handles shown

Lyric hyphen with handles shown
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NOTE

You can change the default lyric hyphen in the Hyphens section of the Lyrics page in Engrave >
Engraving Options.

RELATED LINKS
Lengthening/Shortening lyric extender lines and hyphens on page 700

Moving lyric extender lines and hyphens
You can move lyric extender lines and hyphens horizontally.

NOTE

You cannot move lyric extender lines or hyphens upwards/downwards, as their vertical position
is determined by their lyric line number and your project-wide settings in Engrave > Engraving
Options.

PROCEDURE

1. In Engrave mode, select the lyric extender lines or hyphens that you want to move.

2. Move the lyric extender lines or hyphens in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them to the right/left.

RESULT
The selected lyric extender lines or hyphens are moved to the right/left.

NOTE

● The start handles of lyric extender lines are attached to the lyrics from which they extend,
and the start handles and end handles of lyric hyphens are attached to the lyrics on each
side. If you move either of those lyrics, the corresponding lyric extender line or hyphen
handles also move.

● You can change the position of lyric extender lines and hyphens relative to lyrics, to the
ends of systems, and to other extender lines and hyphens for all lyric extender lines and
hyphens project-wide in the Extender Lines and Hyphens sections of the Lyrics page in
Engraving Options.

RELATED LINKS
Lyric hyphens and lyric extender lines on page 698
Lengthening/Shortening lyric extender lines and hyphens on page 700
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Lengthening/Shortening lyric extender lines and hyphens
You can lengthen/shorten individual lyric extender lines and lyric hyphens. Lengthening/
Shortening lyric hyphens increases/decreases the space in which lyric hyphens are shown.

NOTE

The start handles of lyric extender lines and hyphens are attached to the lyrics from which they
extend. If you move those lyrics, the start handles also move.

PROCEDURE

1. In Engrave mode, select the square handles at one of the following positions on the lyric
extender lines or hyphens you want to lengthen/shorten:

● The start of lyric extender lines or hyphens

● The end of lyric extender lines or hyphens

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them to the right/left.

3. Optional: Repeat steps 1 and 2 for the other handle of the lyric extender lines or hyphens.

RESULT
The length of the selected lyric extender lines is changed. For example, moving the start handle
of a lyric extender line to the right without moving the end handle makes the line shorter.
Lengthening/Shortening lyric hyphens does not change the size or shape of the hyphens
themselves. Instead, you increase/decrease the distance between the handles in which hyphens
can appear.

NOTE

● Depending on your settings for the size of gaps relating to hyphens in the Hyphens
section of the Lyrics page in Engrave > Engraving Options, more/fewer hyphens can
appear in the space when you lengthen/shorten lyric hyphens.

● The following properties in the Lyrics group of the Properties panel are activated if you
move the corresponding handle on lyric extender lines and hyphens:

● Line start X moves the start handles of lyric extender lines and hyphens
horizontally.

● Line end X moves the end handles of lyric extender lines and hyphens horizontally.

For example, if you move a whole lyric extender line to the right, both handles are moved
so both properties are activated. You can also use these properties to move lyric extender
lines and hyphens graphically by changing the values in the value fields.
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Deactivating the properties resets the selected lyric extender lines and hyphens to their
default positions.

RELATED LINKS
Lyric hyphens and lyric extender lines on page 698

Deleting lyric lines
You can delete whole lines of lyrics.

PROCEDURE

1. In Write mode, select the staves from which you want to delete a whole lyric line.

2. Select just the lyric line you want to delete by choosing Edit > Filter > Lyrics > [Lyrics
type].

3. Press Backspace or Delete.

RESULT
All lyrics in the selected lyric line are deleted.

RELATED LINKS
Filters for lyrics on page 691
Selecting lyrics using filters on page 692
Large selections on page 274

Deleting lyrics individually
You can delete individually selected lyrics without deleting other lyrics in the same lyric line.

PROCEDURE

1. In Write mode, select the lyrics you want to delete.

2. Press Backspace or Delete.

RESULT
The selected lyrics are deleted.

Lyric line numbers
Lyric line numbers are used to organize lyrics when a single musical passage can have different
lyrics sung to it, such as music that contains multiple verses. In Dorico Pro, you can specify the
line number of lyrics as you input them and by changing the line number of existing lyrics.

For example, if you input lyrics in Line 3 but later want to change those lyrics to Line 4 because
you want to input different lyrics as Line 3, you can change your current Line 3 into Line 4, and
then input a new line of lyrics as Line 3. The spacing is automatically adjusted to show lyric lines
in the correct order.

In Dorico Pro, you can have multiple lines of lyrics both above and below the same staff. Turning
lyric lines into chorus lyric lines or lyric line translations changes both their placement and
appearance as chorus lyrics generally use an italic font.

RELATED LINKS
Verse numbers on page 705
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Filters for lyrics on page 691
Showing lyrics in italics on page 705

Changing the line number and type of lyric lines
You can change the lyric line number of whole lyric lines after they have been input. You can also
change whole lyric lines to chorus lines and lyric line translations.

For example, you can change the existing Line 1 into a lyric translation of Line 4, or change Line 2
into a chorus line.

TIP

To identify which line you are working on, select a syllable in the line of lyrics and check the
number in the Line number value field in the Lyrics group of the Properties panel. Alternatively,
you can activate verse numbers on the Lyrics page in Engrave > Engraving Options.

PROCEDURE

1. In Write mode, select a lyric in the line whose lyric line type you want to change. The lyric
line can be above or below the staff.

TIP

You can also make a selection and use the lyric filters to select different lyric lines
according to their line numbers.

2. Change the line type of the selected lyric line in one of the following ways:

● Choose Edit > Lyrics > Line > [Line number].

● Choose Edit > Lyrics > Line > Chorus.

● Choose Edit > Lyrics > Translations > [Line number Translation].

● Choose Edit > Lyrics > Translations > Chorus Translation.

TIP

You can also choose these options from the context menu.

RESULT
The line number or type of the whole lyric line of the selected lyric is changed.

NOTE

The position of the selected lyric line relative to other lyric lines at the same position might be
changed. For example, if there were two lyric lines and you changed Line 1 to Line 3, it now
appears below Line 2.

If a lyric line with the same number already exists at the same position on the same side of the
staff, the two lines switch. For example, if there is already a Line 1 at the rhythmic position where
you want to change Line 2 to Line 1, then the existing Line 1 becomes Line 2 to accommodate
your most recent preference. The same applies to chorus lines and lyric line translations.

RELATED LINKS
Lyric line numbers on page 701
Types of lyrics on page 692
Filters for lyrics on page 691
Selecting lyrics using filters on page 692
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Changing the line number of individual lyrics
You can change the lyric line number of individually selected lyrics after they have been input.

PROCEDURE

1. Select the individual lyrics whose line number you want to change. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, change the value for Lyric number in the Lyrics group.

RESULT
The line number of the selected lyrics is changed to match the value in the value field.

NOTE

The position of the selected lyrics relative to other lyric lines might be changed. For example, if
there were two lyric lines and you changed lyrics in Line 1 to Line 3, they now appear below Line
2.

RELATED LINKS
Lyric line numbers on page 701

Changing the placement of lyric lines relative to the staff
You can change the staff-relative placement of whole lyric lines after they have been input.

PROCEDURE

1. In Write mode, select a lyric in each line whose staff-relative placement you want to
change.

NOTE

You can also make a selection and use the lyric filters to select different lyric lines
according to their line numbers, and to select lyric lines according to their position relative
to the staff.

2. Select the staff-relative placement you want in one of the following ways:

● Choose Edit > Lyrics > Placement > Above.

● Choose Edit > Lyrics > Placement > Below.

TIP

You can also choose these options from the context menu.

RESULT
The staff-relative placement of the whole lyric lines in which you selected lyrics is changed.

NOTE

If other lyric lines with the same lyric line number exist at the same position on the side of the
staff to which you want to change your current selection, the two lines switch sides. For example,
if there is already a Line 2 above the staff at the position where you want to change the
placement of Line 2 below the staff, then the existing Line 2 above the staff is placed below the
staff to accommodate your most recent preference.
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RELATED LINKS
Lyric line numbers on page 701
Filters for lyrics on page 691
Selecting lyrics using filters on page 692
Changing the line number and type of lyric lines on page 702

Changing the placement of individual lyrics relative to the staff
You can change the placement of individual lyrics relative to the staff after they have been input.

PROCEDURE

1. Select the lyrics whose staff-relative placement you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, choose one of the following options for Line placement in the
Lyrics group:

● Above

● Below

RESULT
The staff-relative placement of the selected individual lyrics is changed.

NOTE

If other lyric lines with the same lyric line number already exist at the same position on the same
side of the staff, the two lines collide. To avoid this, change the lyric line number of one of the
lyric lines, or change their staff-relative placement by choosing Edit > Lyrics > Placement and
selecting an option from the menu, which avoids collisions.

RELATED LINKS
Lyric line numbers on page 701
Changing the placement of lyric lines relative to the staff on page 703
Changing the line number and type of lyric lines on page 702

Changing the font styles used for lyrics
You can change aspects of the fonts used for the available types of lyrics project-wide.

PROCEDURE

1. In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2. Select the font you want to change from the Font style menu:

● Lyrics Font

● Lyrics Translation Font

● Lyrics Verse Numbers Font

● Chorus lyrics Font

● Chorus lyrics translation Font

3. Activate the following options, individually or together, to change the corresponding
aspect of the font:

● Font family

● Size

● Style
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● Underlined

4. Optional: Repeat steps 2 and 3 for each font whose style you want to change.

5. Click OK to save your changes and close the dialog.

RESULT
The font style for the selected lyrics type is changed project-wide.

RELATED LINKS
Edit Font Styles dialog on page 364

Showing lyrics in italics
You can show individual lyrics in an italic font without changing their font style, lyric type, or
staff-relative placement.

PROCEDURE

1. Select the lyrics you want to show in an italic font. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Italic in the Lyrics group.

RESULT
The selected lyrics are shown in an italic font.

TIP

If you want to show lyrics in an italic font because they are intended to be either chorus lyrics or
translation lyrics, you can change their lyric type instead.

If you want all normal lyric lines to appear in an italic font project-wide, you can change the font
style of the Lyrics Font.

RELATED LINKS
Changing the line number and type of lyric lines on page 702
Changing the type of individual lyrics on page 693
Changing the font styles used for lyrics on page 704

Verse numbers
Verse numbers indicate the order in which lyrics are sung when multiple lines of lyrics share the
same musical passage. They are commonly used in hymns and song sheets.

Depending on the type of music you are writing, verse numbers might not be appropriate.
Therefore, hiding/showing verse numbers in Dorico Pro is optional. By default, verse numbers
are not shown. You can hide/show verse numbers on all lines of lyrics project-wide and on
individually selected lyrics.

When verse numbers are shown on all lyric lines project-wide, they only appear before the first
lyric in the line by default, they are not repeated on subsequent systems automatically.
Therefore, if you want to show verse numbers at the start of subsequent systems, you must
show verse numbers on those individual lyrics.

NOTE

Lyric line translations are part of the lyric line of which they are a translation so do not have their
own verse number.
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Hiding/Showing verse numbers project-wide
You can hide/show verse numbers project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Lyrics in the page list.

3. In the Verse Numbers section, choose one of the following options for Verse numbers
for each line of lyrics:

● Show verse numbers

● Do not show verse numbers

4. Click Apply, then Close.

RESULT
Verse numbers are either shown or hidden project-wide.

Changing the punctuation of verse numbers
You can change how verse numbers are punctuated project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Lyrics in the page list.

3. In the Verse Numbers section, choose one of the following options for Punctuation for
verse numbers:

● Append period (full stop)

● Do not append period (full stop)

4. Click Apply, then Close.

RESULT
Verse numbers are shown with/without a period project-wide.

Hiding/Showing verse numbers on individual lyrics
You can hide/show verse numbers on individual lyrics, independently of your project-wide
setting, for example, if you want to show the verse number at the start of every system.

PROCEDURE

1. Select the lyrics before which you want to hide/show verse numbers. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate/deactivate Show verse number in the Lyrics group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
Verse numbers are shown before the selected lyrics when the property and the corresponding
checkbox are both activated. Verse numbers are not shown when the property is activated but
the checkbox is deactivated.
When the property is deactivated, lyrics follow your project-wide setting for hiding/showing verse
numbers.
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RELATED LINKS
Hiding/Showing verse numbers project-wide on page 706

East Asian elision slurs
East Asian elision slurs are used to show that two or more characters in East Asian languages are
part of the same lyric.

A phrase containing an East Asian elision slur

In Dorico Pro, you can hide/show East Asian elision slurs on all applicable lyrics project-wide and
on individually selected lyrics.

Hiding/Showing East Asian elision slurs
You can hide/show East Asian elision slurs for individual lyrics, independently of your project-
wide setting.

PROCEDURE

1. Select the lyrics on which you want to show East Asian elision slurs. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate/deactivate Show East Asian elision slur in the Lyrics
group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
East Asian elision slurs are shown on the selected lyrics when Show East Asian elision slur and
the corresponding checkbox are both activated, and hidden when the property is activated but
the checkbox is deactivated.
When the property is deactivated, lyrics follow your project-wide setting.

TIP

You can choose to hide/show East Asian elision slurs on all applicable lyrics project-wide on the
Lyrics page in Engrave > Engraving Options.
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Notes are shapes that are positioned on staves to indicate musical pitches. Notes are most
commonly shown with oval-shaped, round noteheads that are either filled or void depending on
their duration, but there are many different designs of noteheads that you can use.

Depending on their duration, notes can have stems that help indicate their duration.

RELATED LINKS
Inputting notes on page 149
Note spacing on page 381
Stems on page 942
Changing the notehead design of individual noteheads on page 722
Add intervals popover on page 172
Adding notes above/below existing notes on page 171

Project-wide engraving options for notes
There are a number of options for the appearance of notes and noteheads project-wide that you
can choose from on the Notes page in Engrave > Engraving Options.

The options on this page allow you to change the design, appearance, and position of noteheads,
ledger lines, stem flags, and rhythm dots. You can also change the appearance of double whole
notes (breves) and the size of grace notes relative to normal notes.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Changing the notehead design project-wide
You can change the notehead design of all noteheads project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Notes in the page list.

3. In the Noteheads section, select one of the following options for Notehead design:

● Default size noteheads (smaller than Larger noteheads)

● Larger noteheads (Default)

● Note names

● Figurenotes© colors
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RESULT
The notehead design of all notes project-wide is changed.

NOTE

This does not change the notehead design of noteheads whose design you have changed
individually, for example, if you changed selected notes to have diamond noteheads.

RELATED LINKS
Changing the notehead design of individual noteheads on page 722

Showing differently shaped noteheads for each scale degree project-
wide

You can show each degree of the scale with a different notehead design project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Notes in the page list.

3. In the Noteheads section, select one of the following options for Shaped noteheads
based on scale degree:

● Walker 4-shape

● Walker 7-shape

● Funk 7-shape

● Aikin 7-shape

RESULT
The notehead design of all noteheads project-wide is changed to show a different notehead
design for each degree of the scale, depending on your selection.

NOTE

This does not override the notehead design of noteheads whose design you have changed
individually.

RELATED LINKS
Pitch-dependent notehead set designs on page 714
Changing the notehead design of individual noteheads on page 722

Showing note names in noteheads project-wide
You can show the note name as a letter in all noteheads project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Notes in the page list.

3. In the Noteheads section, choose Note names for Notehead design.
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NOTE

This does not change the notehead design of noteheads whose design you have changed
individually.

RESULT
The notehead design of all noteheads not overridden individually is changed to show the note
name inside noteheads.

NOTE

To ensure legibility, you can increase the staff size of layouts in your project.

RELATED LINKS
Changing the notehead design of individual noteheads on page 722
Staff size on page 907
Changing the staff size in layouts on page 908

Notehead sets
A notehead set is a collection of related noteheads that together allow you to represent all the
different noteheads required for the different durations used in music notation.

A typical notehead set contains at least four noteheads:

● A black notehead for quarter notes (crotchets) and shorter

● A white notehead for half notes (minims)

● A wider white notehead for whole notes (semibreves)

● A wider white notehead with one or two vertical strokes on either side, or a square white
notehead, for double whole notes (breves)

Pitch-dependent notehead sets contain noteheads that vary according to the pitch of notes
rather than their duration.

● In pitched notehead sets, there are different noteheads for different pitches.
For example, the Pitch Names notehead set shows the letter name and any applicable
accidental of each note within its notehead.

● In scale degree notehead sets, there is a different notehead for each scale degree, relative
to the current key signature.
For example, the Aikin 7-shape notehead set uses a different notehead shape for each
pitch.

NOTE

● A single notehead can appear in multiple notehead sets. If you edit a notehead within one
notehead set, your changes affect the appearance of that notehead in all notehead sets
that contain it.

● Notehead sets can only contain noteheads of the same type. For example, you cannot use
a normal notehead in a pitched notehead set.

● You cannot change the type of an existing notehead set or an existing notehead.

RELATED LINKS
Pitch-dependent notehead set designs on page 714
Custom notehead sets on page 715
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Notehead set designs
There are a number of different notehead set designs that you can use for individual noteheads
in Dorico Pro.

● You can find the available notehead designs by choosing Edit > Notehead > [Notehead
type] > [Notehead design].

NOTE

Dorico Pro does not offer stemless noteheads. Instead, you can hide the stems of notes with any
notehead design.

Notehead set design Notehead set name

Larger Noteheads

Default Noteheads

Large Circled Noteheads

Circled Noteheads

Slashed Noteheads (Bottom Left to Top Right)

Slashed Noteheads (Top Left to Bottom Right)

Cross noteheads

Notehead set design Notehead set name

Circle X Noteheads

Large X and Diamond Noteheads
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Notehead set design Notehead set name

Ornate X Noteheads

Plus Noteheads

With X Noteheads

X Noteheads

X and Circle X Noteheads

X and Diamond Noteheads

Triangular noteheads

Notehead set design Notehead set name

Large Arrow Down Noteheads

Large Arrow Up Noteheads

Triangle Down Noteheads

Triangle Left Noteheads
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Notehead set design Notehead set name

Triangle Right Noteheads

Triangle Up Noteheads

Diamond noteheads

Notehead set design Notehead set name

Diamond Noteheads

Old-Style Diamond Noteheads

White Diamond Noteheads

Wide Diamond Noteheads

Slash noteheads

Notehead set design Notehead set name

Muted Slash Noteheads

Oversized Slash Noteheads

Slash Noteheads
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Notehead set design Notehead set name

Small Slash Noteheads

Round and square noteheads

Notehead set design Notehead set name

Moon Noteheads

Rectangular Noteheads

Round White with Dot Noteheads

RELATED LINKS
Notehead sets on page 710
Changing the notehead design of individual noteheads on page 722
Hiding stems on page 948

Pitch-dependent notehead set designs
Pitch-dependent notehead sets use different notehead designs or different notehead colors
depending on the pitch of notes. There are a number of different pitch-dependent notehead sets
available in Dorico Pro.

● You can find the available notehead designs by choosing Edit > Notehead > [Notehead
type] > [Notehead design].

TIP

You can choose to use a pitch-dependent notehead design for all noteheads project-wide on the
Notes page in Engrave > Engraving Options.

Scale degree noteheads

Notehead set design Notehead set name

Aikin 7-shape Noteheads
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Notehead set design Notehead set name

Funk 7-shape Noteheads

Walker 4-shape Noteheads

Walker 7-shape Noteheads

Pitched noteheads

Notehead set design Notehead set name

Figurenotes© Noteheads

Pitch Name Noteheads

RELATED LINKS
Notehead sets on page 710
Changing the notehead design of individual noteheads on page 722
Showing differently shaped noteheads for each scale degree project-wide on page 709
Showing note names in noteheads project-wide on page 709

Custom notehead sets
You can create and edit custom noteheads and notehead sets, for example, to create noteheads
with specific shapes that represent extended techniques.

In Dorico Pro, noteheads are grouped into sets, which allow you to customize the noteheads
used for different durations. For example, the standard notehead set uses different noteheads
for quarter notes compared to half notes.

You can create new custom notehead sets, and edit existing notehead sets, in the Edit Notehead
Sets dialog.

You can create new and edit individual noteheads within each notehead set in the Edit
Notehead dialog.

RELATED LINKS
Notehead sets on page 710
Edit Notehead dialog on page 719
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Edit Notehead Sets dialog
The Edit Notehead Sets dialog allows you to add, edit, and delete custom notehead sets. It also
allows you to change various settings relating to the appearance and function of noteheads
within each notehead set.

● You can open the Edit Notehead Sets dialog in Engrave mode by choosing Engrave >
Notehead Sets.

Edit Notehead Sets dialog

The Edit Notehead Sets dialog contains the following sections and options:

1 Category menu
Allows you to filter the list of notehead sets by selecting a category from the menu, such as
Crosses or Diamonds. This corresponds to where notehead sets are located in the menu,
for example, Edit > Notehead > Crosses > X Noteheads.

2 List of notehead sets
Contains all the notehead sets in the project within the currently selected category.
The action bar at the bottom of the list contains the following options:

● New

Adds a new notehead set. By default, new notehead sets are Normal and in the
Common category.

● New from Selection

Adds a new notehead set that is a duplicate of the notehead set currently selected.

NOTE

A single notehead can appear in multiple notehead sets. If you edit a notehead
within one notehead set, your changes affect the appearance of that notehead in all
notehead sets that contain it.

● Save as Default
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Saves the currently selected notehead set as a default in your user library, allowing
you to use it in multiple projects.

● Revert to Factory

Removes all edits you have made to the selected predefined notehead set, returning
it to its original settings and appearance.

● Delete

Deletes the selected notehead set.

NOTE

You cannot delete predefined notehead sets.

3 Notehead Set section
Displays the noteheads in the notehead set currently selected in the notehead set list, and
contains the following options that apply to the notehead set:

● Name
Allows you to enter a new name or edit the existing name for the selected notehead
set.

● Category
Allows you to select a category for the notehead set, such as Crosses. This
corresponds to where notehead sets are located in the menu, for example, Edit >
Notehead > Crosses > X Noteheads.

● Type
Displays whether the notehead set is Normal, Pitched, or Scale Degree.

NOTE

You cannot change the Type of notehead sets. If you want a new notehead set of a
particular Type, you must select an existing notehead set of that type in the
notehead set list and click New from Selection.

● Default notehead
Allows you to select which notehead within the set Dorico Pro uses if there is no
notehead in the set that exactly matches the requirements of a note, for example, if
you input a note longer than a whole note, but there is no notehead defined for this
duration in the set.

4 Notehead Set action bar
Contains the following options for changing which noteheads are included in the notehead
set:

● Add Notehead to Set

Adds a new notehead to the notehead set. You can select any notehead from the
menu.
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NOTE

A single notehead can appear in multiple notehead sets. If you edit a notehead
within one notehead set, your changes affect the appearance of that notehead in all
notehead sets that contain it.

● Remove Notehead from Set

Deletes the selected notehead from the notehead set.

5 Notehead section
Contains the following options that apply to the notehead currently selected in the
Notehead Set section:

● Name
Allows you to enter a new name or edit the existing name for the selected notehead.
This is the identifying name used in the Add Notehead to Set menu.

● Duration
Allows you to select the primary rhythmic duration for which the selected notehead
is intended. You can then specify whether the selected notehead can also be used
for shorter/longer notes.

● Use for durations shorter than and equal
Allows you to specify that the selected notehead can be used for notes of the
selected Duration and shorter notes.

● Use for durations longer than and equal
Allows you to specify that the selected notehead can be used for notes of the
selected Duration and longer notes.

● Stem direction
Allows you to specify that the selected notehead should be used for up-stem or
down-stem notes only. This is particularly important for noteheads with shapes, for
example, the triangles in triangular noteheads point in different directions
according to their stem direction.

● Double whole note
Allows you to specify whether the selected notehead is Round or Square. This
determines which notehead is used for double whole notes (breves) according to
your project-wide setting for Appearance of double whole note (breve) notehead
on the Notes page in Engrave > Engraving Options.

● Pitch
Specifies the note name and accidental for which the selected notehead is used
(Pitched type noteheads only).

● Degree
Specifies the scale degree for which the selected notehead is used, using integer
numbers from 1 to 7 (Scale Degree type noteheads only).

6 Notehead action bar
Contains the following options that allow you to edit new and existing noteheads:

● New Notehead

Creates a new Normal notehead, based on the default black notehead.

● New from Selection
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Creates a new notehead that is a duplicate of the notehead currently selected in the
Notehead Set section.

● Edit Notehead

Opens the Edit Notehead dialog, where you can change the appearance of the
notehead itself.

● Save as Default

Saves the currently selected notehead as a default in your user library, allowing you
to use it in multiple projects.

● Revert to Factory

Removes all edits you have made to the selected predefined notehead, returning it
to its original settings and appearance.

● Delete

Deletes the selected notehead.

NOTE

You cannot delete predefined noteheads or any notehead that is currently used in
your project.

RELATED LINKS
Notehead sets on page 710

Edit Notehead dialog
The Edit Notehead dialog allows you to design custom noteheads and edit the appearance and
arrangement of noteheads.

● You can open the Edit Notehead dialog from within the Edit Notehead Sets dialog, by
selecting the notehead whose design you want to edit from the Notehead Set list and
either double-clicking it or clicking Edit Notehead in the action bar in the Notehead
section.
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Edit Notehead dialog

The Edit Notehead dialog contains the following sections and options:

1 Name
Contains the saved name for predefined noteheads, or an automatically generated name
for new noteheads. You cannot change this name.

2 Component selector
Allows you to choose components to add to the notehead. You can add different types of
components by clicking the respective tab titles.

● Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting
different fonts and different ranges from the menus. Click Add Glyph to add the
selected glyph to the notehead.

NOTE

A full list of the different ranges of glyphs is available on the SMuFL website.

● Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected
text, or input text, to the notehead.

● Graphic: Allows you to load a new graphics file, or select an existing graphic from
the Select existing list, in SVG, PNG, or JPG format. You can see a preview of the
graphic in the Preview box. Click Add Graphic to add the selected graphic to the
notehead.

● Composite: Allows you to select a composite from the list. Click Add Composite to
add the selected composite to the notehead.

3 Editor
Allows you to arrange and edit the components that make up the notehead. You can
arrange and edit components by clicking and dragging them in the editor and by using the
controls at the bottom of the dialog. You can also use the handles on each component to
change their size.
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We recommend that you position the notehead in the center of the editor so that its left
edge is aligned with the thicker vertical grid line and its middle is aligned with the thicker
horizontal grid line.

4 Editor action bar
Contains selection and view options for the editor.

● Zoom
Allows you to change the zoom level in the editor.

● Select
Allows you to select the next/previous component.

● Show Attachments

Shows all the attachments on all components in the editor.

● Delete

Deletes the selected component.

5 Controls
Contains controls that allow you to edit individual components. Controls are divided into
tabs according to the aspect of the selected component they affect. For noteheads, the
Component, Stem, and Attachments tabs are available. The Cut-outs tab does not apply
to noteheads.
The Component tab contains the following options:

● Offset: Controls the position of the selected component. X moves it horizontally, Y
moves it vertically.

● Scale: Controls the size of the selected component. For graphics, X controls its
width, Y controls its height.

NOTE

Although some components scale their height and width independently, others
retain their aspect ratio, meaning only one value affects their overall size.

● Z order: Allows you to Bring Forward or Send Backward the selected component in
relation to other components when they overlap.

The Stem tab contains options controlling the position of where stems attach to the
notehead. Each notehead can have multiple stem attachment points, as stems often attach
to noteheads in different places when the note is stem up, stem down, and split for altered
unisons. Stem attachment points include an indication of the stem direction for which the
attachment is used and the part of the stem that attaches to this position, given as a
compass direction. For example, Stem up SE is where the bottom right corner of an up
stem attaches to the notehead.
Each stem attachment point in the Stem tab has the following options:

● X: Moves the attachment point horizontally.

● Y: Moves the attachment point vertically.

● Add: Adds the attachment point to the notehead.

● Delete: Removes the attachment point from the notehead.
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The Attachments tab is only available if the notehead comprises at least two separate
components. It contains the following options:

● Attachment from: Sets the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend
that you select a right edge attachment point for Attachment from.

● Attachment to: Sets the attachment point on the selected component which
attaches to the component to its left. We recommend that you select a left edge
attachment point for Attachment to.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.

The attachment points have the following names in the Edit Notehead dialog:

1 Top Left

2 Top Center

3 Top Right

4 Middle Left

5 Middle Right

6 Baseline Left (text only)

7 Baseline Center (text only)

8 Baseline Right (text only)

9 Bottom Left

10 Bottom Center

11 Bottom Right

RELATED LINKS
Altered unisons on page 491

Changing the notehead design of individual noteheads
You can change the notehead design of individual noteheads, including trill auxiliary notes. For
example, cross noteheads might be used to indicate where players should produce pitchless
sounds, such as air sounds on wind instruments.

NOTE

These steps do not apply to notes in slash voices.

PROCEDURE

1. Select the noteheads whose design you want to change. You can do this in Write mode
and Engrave mode.

2. Choose Edit > Notehead > [Notehead type] > [Notehead design]. You can also choose
these options from the context menu.
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For example, to change the notehead design of the selected notes to X noteheads, choose
Edit > Notehead > Crosses > X Noteheads.

RESULT
The notehead design of the selected notes is changed.

TIP

You can also change the notehead design for all noteheads project-wide.

RELATED LINKS
Changing the notehead design project-wide on page 708
Project-wide engraving options for rhythm slashes on page 850
Rhythm slashes on page 849
Slash voices on page 1044
Hiding stems on page 948

Changing the size of notes
You can change the size of notes individually using the default scale sizes for notes in cues or
grace notes, or you can use a custom scale size.

TIP

● You can change the size of all notes project-wide by changing the notehead design on the
Notes page in Engrave > Engraving Options. However, these options offer less flexibility
than changing the size of notes individually.

● If you want to change the size of notes because you want them to be grace notes or cues,
you can input them as either grace notes or cues instead.

PROCEDURE

1. Select the notes whose size you want to change. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate any of the following properties in the Common group:

● If you want to use a default scale size, activate Scale.

● If you want to use a custom scale size, activate Custom Scale.

● If you want to use a custom scale size based on a default scale size, activate both
Scale and Custom Scale.

3. Optional: If you activated Scale, select one of the following options from the menu:

● Normal

● Grace

● Cue

● Cue grace

4. Optional: If you want activated Custom Scale, change the value in the value field.

RESULT

● If you activated Scale, the selected notes are changed to the selected default scale size.

● If you activated Custom Scale, the selected notes are changed to the custom percentage
scale size you set.
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● If you activated both Scale and Custom Scale, the selected notes are changed to the
custom percentage scale size of the selected default scale size. For example, if you
selected Grace for Scale then set Custom Scale to 50, the size of the selected notes is half
the size of grace notes.

RELATED LINKS
Inputting grace notes on page 167
Inputting cues on page 268
Notehead set designs on page 711

Moving notes rhythmically
You can move notes, including grace notes, to different rhythmic positions along staves after
they have been input.

PROCEDURE

1. In Write mode, select the notes you want to move.

2. Move the selected notes according to the current rhythmic grid value in any of the
following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

RESULT
The selected notes are moved to new rhythmic positions according to the current rhythmic grid
value. If you selected multiple notes, they are moved together as a block.
Notes are automatically positioned according to their rhythmic duration and position relative to
other notes.

NOTE

If Chords is not activated and any of your selected notes collide with other notes in the same
staff and at the same rhythmic position that are in the same voice as your selected notes, the
existing notes are deleted and replaced with your selected notes.

RELATED LINKS
Rhythmic grid on page 144
Inputting chords on page 167
Notes toolbox on page 132
Note spacing on page 381
Creating cross-staff beams on page 544
Moving notes to other staves on page 286

Changing the width of ledger lines
You can change the width of ledger lines on individual notes, for example, to allow notes with
short durations to be spaced more tightly and still be legible.

PROCEDURE

1. In Engrave mode, select the noteheads whose ledger line width you want to change.

2. In the Properties panel, activate Ledger line in the Notes and Rests group.

3. Change the values for L and R.
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RESULT
Increasing Ledger line L makes the left side of ledger lines longer, decreasing the value makes
the left side of ledger lines shorter.
Increasing Ledger line R makes the right side of ledger lines longer, decreasing the value makes
the right side of ledger lines shorter.

TIP

You can change the width of all ledger lines project-wide on the Notes page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide engraving options for notes on page 708

Hiding/Showing ledger lines
You can hide/show ledger lines on individual notes, for example, if you want to indicate
approximate pitches using the relative vertical positions of notes.

PROCEDURE

1. In Engrave mode, select the noteheads whose ledger lines you want to hide/show.

NOTE

If you want to hide ledger lines, you must also select all other noteheads in the same voice
and voice column index.

2. In the Properties panel, activate/deactivate Hide ledger lines in the Notes and Rests
group of the Properties panel.

RESULT
Ledger lines are hidden/shown for the selected notes.
If you deactivated Hide ledger lines for only some notes in a chord, ledger lines are also shown
on all notes between the selected notes and the staff in the same voice and voice column index.

RELATED LINKS
Voice column index on page 1042

Rhythm dot consolidation
Rhythm dot consolidation controls how many rhythm dots appear at the same rhythmic position
in multiple-voice contexts. Depending on the number of notes and voices present, and their
positions on the staff, different numbers of rhythm dots can be required to appear, and in
different positions.

In the Rhythm Dots section of the Notes page in Engrave > Engraving Options, you can choose
how rhythm dots in multiple voices are consolidated project-wide. There are separate options for
the consolidation of rhythm dots generally and on unison notes in particular.
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Rhythm dot consolidation

Notes of any duration have
rhythm dots consolidated

Only notes of the same duration
have rhythm dots consolidated

No rhythm dot consolidation

Rhythm dot consolidation on unison notes

One rhythm dot shown per
notehead in unisons

Rhythm dots shown for each
notehead for unisons on lines, but
only one shown per unison in
spaces

Only one rhythm dot shown per
unison

TIP

You can also change how rhythm dots in multiple voices are consolidated individually.

RELATED LINKS
Project-wide engraving options for notes on page 708
Changing the consolidation of rhythm dots on page 726

Changing the consolidation of rhythm dots
You can change how rhythm dots in multiple voices are consolidated at individual rhythmic
positions, independently of your project-wide setting. For example, if you want to show fewer
rhythm dots for a very dense chord.

PROCEDURE

1. In Engrave mode, select the notes whose rhythm dot consolidation you want to change.

2. In the Properties panel, activate Rhythm dot consolidation in the Notes and Rests
group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
Rhythm dots for notes of any duration are consolidated when the checkbox is activated, and no
rhythm dots are consolidated when the checkbox is deactivated.
When the property is deactivated, rhythm dots follow your project-wide setting for consolidation
according to note durations.

TIP

You can change how all rhythm dots in multiple voices are consolidated project-wide on the
Notes page in Engrave > Engraving Options.
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RELATED LINKS
Rhythm dot consolidation on page 725
Project-wide engraving options for notes on page 708

Moving rhythm dots
You can move rhythm dots horizontally. However, you cannot move an individual rhythm dot
independently of other rhythm dots at the same rhythmic position.

PROCEDURE

1. In Engrave mode, select a notehead at each rhythmic position where you want to move
rhythm dots.

2. In the Properties panel, activate Rhythm dot X in the Notes and Rests group.

3. Change the value in the value field.

RESULT
Increasing the Rhythm dot X value moves all rhythm dots at the selected rhythmic positions to
the right, decreasing the value moves them to the left.

Specifying on which string individual notes are played
You can specify on which string individually selected notes are played when notes are in the
staves of string instruments, such as violins or cellos. Many notes can be played on multiple
strings, depending on where along its length the string is stopped.

Specifying the string can be useful for notes that also have glissando lines or fingering shifts, as
the string and finger position required to play the note affects the direction of these changes.
However, the string number is not shown in the music. You can instead input fingerings, which
can help string players understand the string on which they should play.

NOTE

You can only specify strings on notes belonging to string instruments.

PROCEDURE

1. Select the notes whose assigned string you want to change. You can do this in Write mode
and Engrave mode.

NOTE

If selecting multiple notes at once, select notes only in staves of the same instrument type.
For example, select multiple Cs in Violin 1 and Violin 2 staves.

2. In the Properties panel, activate String in the Notes and Rests group.

3. Select your preferred string from the menu.
The string number for the instrument is shown, followed by the fundamental pitch and the
octave number of that string in parentheses. For example, the lowest cello string is
expressed as 4 (C2).

NOTE

The options available in the menu depend on the selected pitches and the instrument
type.
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RESULT
The string on which the selected notes are played is changed.

NOTE

If you subsequently change the pitches of notes, String is automatically deactivated for all notes
that can no longer be played on their specified string.

RELATED LINKS
Glissando lines on page 753
Changing the direction of string fingering shift indicators on page 651
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Ornaments are markings that indicate multiple notes are played in addition to the notated pitch.
They are used to decorate music, such as in Baroque music, which is highly decorated with trills
and other ornaments.

Over time, specific ways of notating how performers should play notes have developed and
different ornament symbols indicate different patterns of decorative notes. Nonetheless,
ornaments give some freedom to performers to embellish music in their own way.

Dorico Pro offers a range of ornament symbols to allow you to notate different styles of
ornaments.

The term “ornaments” covers a wide range of decorative notes, including:

● Mordents

● Trills

● Turns

● Grace notes

● Acciaccaturas

● Appoggiaturas

In Dorico Pro, the term “ornaments” refers to ornament symbols and trill marks that are input
above notes.

A phrase containing a turn, short trills, and a trill with extension line

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations on page 229
Grace notes on page 657
Positions of ornaments on page 731

Project-wide engraving options for ornaments
You can find options for the project-wide appearance and position of ornaments and trills on the
Ornaments page in Engrave > Engraving Options.

The options on the Ornaments page allow you to change the position of trills relative to
accidentals, noteheads, trill extension lines. You can also change the default appearance of trill
marks on subsequent systems, the appearance and restatement of trill intervals, and set the
minimum distance between ornaments and the staff and noteheads.

Ornaments
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There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Changing ornament intervals
You can change the intervals of ornaments, both above and below the notated pitch, to indicate
which pitches are played in the ornament. The intervals of ornaments are indicated by
accidentals.

For some ornaments, you can only change the interval in one direction. For example, you can
only change the interval above short trills and below mordents.

NOTE

These steps do not apply to trills.

PROCEDURE

1. Select the ornaments whose interval you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate the appropriate properties for the selected ornaments in
the Ornaments group:

● Interval above

● Interval below

For trills, activate Interval in the Trills group of the Properties panel.

3. Change the value in the value field to the interval you want.

● 0 or 4 and above shows no accidental.

● 1 shows a flat.

● 2 shows a natural.

● 3 shows a sharp.

RESULT
The interval of the selected ornaments is changed.

NOTE

Some ornaments do not show accidentals either above or below, depending on their type.

● Some ornaments do not show accidentals either above or below, depending on their type.

● You can change the position of ornament accidentals relative to all trills project-wide on
the Ornaments page in Engrave > Engraving Options.
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EXAMPLE

No accidentals Flats above and
below

Naturals above and
below

Sharps above and
below

RELATED LINKS
Changing the intervals of existing trills on page 739
Project-wide engraving options for ornaments on page 729

Positions of ornaments
Ornaments, including trills, are placed above the notes to which they apply. They are only placed
below the staff when there are multiple voices on the staff.

Ornaments and trills are positioned outside of slurs by default. Similarly, they are positioned
further from noteheads than articulations.

The center of ornaments aligns with the center of the notehead to which they apply. Trills are
aligned differently, as the left side of trill marks aligns with the left edge of the notehead to which
the trill applies.

Dorico Pro automatically positions ornaments correctly according to their type, and attaches
them to their notehead.

You can move ornaments to different rhythmic positions in Write mode. They are positioned by
default according to your settings in Engraving Options.

You can move ornaments graphically in Engrave mode, but this does not change the rhythmic
positions to which they are attached.

You can change the default positions of all ornaments and trills project-wide on the Ornaments
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for ornaments on page 729
Moving ornaments graphically on page 732
Changing the position of ornaments relative to slurs on page 733

Moving ornaments rhythmically
You can move ornaments to new rhythmic positions.

PROCEDURE

1. In Write mode, select the ornaments you want to move.

NOTE

When using the mouse, you can only move one ornament at a time.

2. Move the ornaments in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

Ornaments
Positions of ornaments 

731
Dorico 2.2.20



● Click and drag the ornament to the right/left to snap it to different rhythmic
positions.

RESULT
A single ornament is moved to the next or previous notehead on that staff.
Multiple ornaments are moved according to the current rhythmic grid value.

Moving ornaments graphically
You can move ornaments graphically without changing the rhythmic positions to which they
apply. You can also move the start/end handles of trills independently of each other, meaning
you can lengthen/shorten trills graphically.

PROCEDURE

1. In Engrave mode, select one of the following that you want to move:

● Ornaments or trills

● Individual handles on trills

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the ornaments or handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected items are moved graphically, without affecting the rhythmic positions to which they
are attached.

TIP

Offset in the Common group of the Properties panel is activated automatically when you move
ornaments.

● Offset X moves ornaments horizontally.

● Offset Y moves ornaments vertically.

The following properties in the Trills group of the Properties panel are activated automatically
when you move trills:

● Start offset moves whole trills. X moves them horizontally, Y moves them vertically.

● End offset X moves the end of trill extension lines horizontally.

For example, if you move a whole trill to the right, both handles are moved so both properties
are activated. You can also use these properties to move ornaments/trills and lengthen/shorten
trills graphically by changing the values in the value fields.
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Deactivating the properties resets the selected ornaments and trills to their default positions.

Changing the placement of ornaments relative to the staff
Ornaments are usually placed above the staff, but they are placed below the staff for down-stem
voices when there are multiple voices on the staff. You can change the staff-relative placement of
ornaments individually.

PROCEDURE

1. Select the ornaments whose staff-relative placement you want to change. You can do this
in Write mode and Engrave mode.

2. In the Properties panel, activate Placement in the corresponding group for the selected
ornaments:

● Ornaments

● Trills

3. Choose one of the following options:

● Above

● Below

RESULT
The placement of the selected ornaments is changed.

Changing the position of ornaments relative to slurs
Ornaments are positioned outside of slurs by default. You can change the position of ornaments
relative to slurs individually.

PROCEDURE

1. In Engrave mode, select the ornaments whose slur-relative position you want to change.

2. In the Properties panel, activate Slur-relative position in the corresponding group for the
selected ornaments:

● Ornaments

● Trills

3. Choose one of the following options:

● Inside

● Outside

RESULT
The selected ornaments are positioned either inside or outside of slurs.

Changing the start position of trills
You can change whether the start position of individual trills is aligned with the notehead or with
its accidental, independently of your project-wide setting.

PROCEDURE

1. Select the trills whose start position you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Start position in the Trills group.
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3. Choose one of the following options:

● Notehead

● Accidental

RESULT
The start position of the selected trills is changed.

TIP

You can change the start position of all trills project-wide on the Ornaments page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide engraving options for ornaments on page 729

Trills
Trills are fast alternations between two notes, similar to a tremolo, that were a common
decoration in Baroque, Classical, and Romantic music. Trill marks are usually added to a single
note, to indicate the performed notes are the notated pitch and the note either a half-step or
whole step above, and can have extension lines to show the duration of the trill.

A phrase containing multiple trills with extension lines

Because of their legacy as an ornament, many performers interpret trills differently to tremolos:
some players add more emphasis to the notated pitch in a trill and less on the trilled-to note but
play both notes equally in tremolos.

The most common trills are to notes a major or minor second above, but it is also possible to
specify other trill intervals.

In Dorico Pro, you can specify any trill interval, change their appearance, and hear them in
playback.

RELATED LINKS
Trill intervals on page 737
Trill interval appearance on page 740
Trills in playback on page 742

Hiding/Showing trill marks
You can hide/show trill marks at the start of individual trills. This also hides/shows trill marks on
all systems on which the trills extend.

PROCEDURE

1. Select the trills whose trill marks you want to hide/show. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Show trill mark in the Trills group.
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3. Activate/Deactivate the corresponding checkbox.

RESULT
Trill marks are shown when the checkbox is activated, and hidden when the checkbox is
deactivated.
When the property is deactivated, trill marks follow your project-wide setting.

Changing the speed of trills
You can indicate different speeds for trills, including indicating a change of speed within a single
trill, by changing the height and frequency of wiggles in their extension lines.

PROCEDURE

1. Select the trills whose speed you want to change. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate the following properties, individually or together, in the
Trills group:

● Start speed

● End speed

3. Select one of the following options from each property menu:

● Slow

● Normal

● Fast

RESULT
The speed of the selected trills is changed. This affects both the frequency of wiggles in their
extension lines and their playback speed.
If only Start speed is activated, the speed of the whole trill extension line is changed. If only End
speed is activated, the speed of the end half of the trill extension line is changed.

EXAMPLE

A trill extension line starting slow and ending fast

AFTER COMPLETING THIS TASK
You can customize the playback speed of trills individually.

RELATED LINKS
Changing the playback speeds of trills on page 744

Hiding/Showing speed changes in trill extension lines
You can hide/show speed changes in the extension lines for individual trills, for example, if you
want to hear different speeds in playback but show extension lines with consistent wiggles.

PROCEDURE

1. Select the trills whose speed changes you want to hide/show. You can do this in Write
mode and Engrave mode.
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2. In the Properties panel, activate/deactivate Suppress drawing speed changes in the Trills
group.

RESULT
Speed changes are hidden when the property is activated, and shown when it is deactivated.

EXAMPLE

Trill speed changes shown Trill speed changes hidden

Hiding/Showing trill extension lines
You can hide/show the extension lines of individual trills.

PROCEDURE

1. Select the trills whose extension lines you want to hide/show. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, activate/deactivate Has trill line in the Trills group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
Trill extension lines are shown when the checkbox is activated, and hidden when the checkbox is
deactivated.
When the property is deactivated, trills follow your project-wide setting.

TIP

You can hide/show trill extension lines on all trills project-wide on the Ornaments page in
Engrave > Engraving Options.

RELATED LINKS
Changing the speed of trills on page 735
Changing the playback speeds of trills on page 744

Lengthening/Shortening trills rhythmically
You can lengthen/shorten trills after they have been input. Multiple ornaments can exist at the
same rhythmic position, so you can also lengthen/shorten trills to noteheads that already have
ornaments.

PROCEDURE

1. In Write mode, select the trills you want to lengthen/shorten.

NOTE

When using the mouse, you can only lengthen/shorten one trill at a time.

2. Lengthen/Shorten the trills in any of the following ways:

● To lengthen them by the current rhythmic grid value, press Shift-Alt-Right Arrow.
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● To shorten them by the current rhythmic grid value, press Shift-Alt-Left Arrow.

● To lengthen a single trill to the next notehead, press Ctrl/Cmd-Shift-Alt-
Right Arrow.

● To shorten a single trill to the previous notehead, press Ctrl/Cmd-Shift-Alt-
Left Arrow.

NOTE

● You can only lengthen/shorten trills by the current rhythmic grid value when
multiple trills are selected.

● Key commands lengthen/shorten items by moving their end only.

● Click and drag the circular handle at the start/end of the trill to noteheads to the
right/left.

RESULT
Single trills are lengthened/shortened according to the current rhythmic grid value or to the
next/previous notehead, whichever is closer.
Multiple trills are lengthened/shortened according to the current rhythmic grid value.

RELATED LINKS
Positions of ornaments on page 731
Moving ornaments rhythmically on page 731
Moving ornaments graphically on page 732

Trill intervals
Trill intervals tell performers which notes to play and also affect the pitches used in playback in
Dorico Pro. For example, a trill with a sharp accidental on an E indicates that the performer trills
between E and F♯, rather than between E and F.

The different accidentals on these trills indicate changes in the trilled-to note.

If you do not specify an interval when inputting a trill, Dorico Pro calculates an appropriate
interval based on the top note in the voice to which the trill belongs, the current key signature,
and any accidentals earlier in the bar. For example, inputting a trill on an E♮ in C major produces a
half-step/minor second trill interval to F♮. If there were a sharp accidental on the F earlier in the
bar, the trill interval produced is a whole step/major second between the E♮ and F♯.
In open/atonal key signatures, Dorico Pro produces whole step/major second trill intervals by
default.

You can specify trill intervals when inputting them with the popover, including at different
noteheads in the same trill, and you can change their intervals after they have been input.

Trills and accidentals

If required, Dorico Pro shows accidentals to clarify trill intervals. Dorico Pro also automatically
shows accidentals on other notes in the bar if they have different accidentals to any upper notes
of trills.
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By default, trill marks themselves show intervals, unless the upper note is modified by an
accidental in the key signature. If the upper note has been modified by an accidental earlier in
the bar, trills always show the interval. If trills modify pitches modified by an accidental in the key
signature, any subsequent notes of that pitch show the appropriate accidental automatically. Any
cautionary accidentals required in the current and following bars are also shown automatically.

Microtonal trill intervals

When using other tonality systems than 12-EDO, you can specify trill intervals based on diatonic
steps and the total number of divisions from the written note. In 24-EDO, you can describe trill
intervals based on their quality, such as major or minor. In tonality systems with a greater
number of divisions or an unequal number of divisions between each diatonic step, you must
specify trill intervals based on their octave divisions, as specifying only the interval quality is
insufficient in such cases.

RELATED LINKS
Trill interval appearance on page 740

Hiding/Showing trill interval accidentals
You can hide/show trill interval accidentals for individual trills.

NOTE

These steps only hide the accidentals shown in trill intervals, they do not hide auxiliary notes or
Hollywood-style markings.

PROCEDURE

1. Select the trills whose accidentals you want to hide/show. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Accidental in the Trills group.

3. Choose one of the following options:

● Hide

● Show

RESULT
Accidentals in the selected trill intervals are hidden when you choose Hide, and shown when you
choose Show.

NOTE

Trill accidentals are restated at each new pitch over which the trill extends. You can choose to
repeat or hide all Hollywood-style trill intervals on successive notes in the Trill Intervals section
of the Ornaments page in Engrave > Engraving Options.

RELATED LINKS
Changing the appearance of trill intervals on page 741
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Changing the intervals of existing trills
The default trill interval is a second, either major or minor depending on the context. In addition
to specifying the interval when inputting trills with the ornaments popover, you can change the
intervals of trills individually after they have been input.

PROCEDURE

1. Select the trills whose interval you want to change. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Interval in the Trills group.
The existing interval of the trill is shown as a number and quality.

3. Change the interval by changing the value in the value field.

4. Select one of the following interval qualities from the menu:

● Diminished

● Minor

● Major

● Augmented

RESULT
The interval of the selected trills is changed. By default, trill intervals appear as accidentals when
the interval is a second and as auxiliary notes for all other intervals.

RELATED LINKS
Ornaments popover on page 229

Changing intervals partway through trills
You can change the interval of trills multiple times within their duration, including before you
have input notes, for example, if you want a trill to change seamlessly from a minor second in
one bar to a major second in the next.

PROCEDURE

1. In Write mode, select one of the following:

● The note whose trill interval you want to change.

● An item or rest on the stave where you want to input notes and specify trill intervals.

2. Press Shift-N or Return to start note input.

3. Press Right Arrow/Left Arrow to move the caret according to the current rhythmic grid
value to the notehead where you want to change the trill interval.

NOTE

You can only change trill intervals at noteheads.

4. Press Shift-O to open the ornaments popover.

5. Enter the trill interval you want into the popover. For example, enter m3 for a minor third.

6. Press Return to close the popover.

7. Optional: Repeat steps 3 to 6 to change the trill interval at other noteheads in the trill.

8. Press Esc or Return to stop note input.
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RESULT
The trill interval is changed at the corresponding noteheads. By default, all trill intervals in the
trill appear as accidentals when the intervals are all seconds and as auxiliary notes when the trill
contains at least one trill interval with a different interval.

EXAMPLE

Trill with interval changes shown as accidentals Trill with interval changes shown as auxiliary notes

Trill interval appearance
There are different accepted ways to present trill intervals, including accidental symbols and the
Hollywood convention of showing “H.T.” for a half-step (semitone) and “W.T.” for a whole step
(tone).

In Dorico Pro, trill intervals can appear in the following ways:

Accidental
Indicates the trill interval using accidentals positioned above, below, or beside the tr
mark. This is the default trill interval appearance in Dorico Pro for major or minor
second trills.

Hollywood-style
Indicates the trill interval using text.

● H.T. for half-step/minor second trills

● W.T. for whole step/major second trills

Auxiliary note
Indicates the trill interval using a small, parenthesized, stemless notehead shown in
the staff immediately to the right of the first note to which the trill applies, and at the
correct staff position for the trilled-to pitch. Auxiliary notes are used for all trill
intervals that are not a major or minor second, but are automatically hidden for
unison trills if the notehead design of the auxiliary note has not been overridden.
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TIP

You can find options for the default appearance, position, and restatement of trill intervals on the
Ornaments page in Engrave > Engraving Options.

Changing the appearance of trill intervals
You can change the appearance of trills with a second interval individually, independently of your
project-wide setting, for example, if you want to show auxiliary notes on some trills to clarify a
change in the trilled-to pitch.

NOTE

You can only change the trill interval appearance of trills with a major/minor second interval.

PROCEDURE

1. Select the trills whose trill interval appearance you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Appearance in the Trills group.

3. Select one of the following options from the menu:

● Accidental

● Hollywood style

● Auxiliary note

RESULT
The appearance of the selected trill intervals is changed.

TIP

You can change the default appearance of all trills with a second interval project-wide in the Trill
Intervals section of the Ornaments page in Engrave > Engraving Options.

AFTER COMPLETING THIS TASK
You can change the notehead design of individual auxiliary notes, for example, to show that the
trilled-to note is a harmonic.

RELATED LINKS
Project-wide engraving options for ornaments on page 729
Changing the notehead design of individual noteheads on page 722

Changing the position of trill interval indicators
You can change where trill interval indicators, such as an accidental or W.T. marking, are
positioned relative to individual trills, independently of your project-wide setting.

PROCEDURE

1. Select the trills whose interval indicator position you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Interval position in the Trills group.

3. Select one of the following options from the menu:

● Above
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● Below

● On the right

● Superscript

RESULT
The position of interval indicators relative to the selected trills is changed.

TIP

You can change the default position of interval indicators relative to all trills project-wide in the
Trill Intervals section of the Ornaments page in Engrave > Engraving Options.

Trills in playback
Dorico Pro plays back trills by using a combination of sampled trills, when available, and
triggering multiple notes.

● You can find options for trill playback on the Trills page in Play > Playback Options.

Dorico Pro can play back sampled half-step (semitone) and whole step (tone) trills automatically if
these playing techniques are defined in the VST expression map, which is the case for a number
of instruments in HALion Symphonic Orchestra. For sample libraries that do not provide sampled
trills, or for intervals beyond a whole step, Dorico Pro generates trills. If your project contains
some trill intervals that can only be generated, you can disable sampled trills and use generated
trills throughout to produce a more consistent result.

When playing generated trills, Dorico Pro incorporates grace notes immediately before and after
trills. A single unslashed grace note on the initial trill note produces an appoggiatura, while
multiple grace notes on the initial trill note are included in the trill pattern. Grace notes on the
note immediately following a trill are also included in the trill pattern.

A trill with grace notes at both the start and end

Variable speeds within trills are included in playback. You can determine the default playback
speeds of slow, normal, and fast trills on the Trills page in Playback Options, and you can
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change the playback speed of individual trills. Additionally, you can hide trill speed changes in
trill extension lines whilst retaining the speed changes in playback.

In contemporary performance practice, trills are usually performed starting on the written note,
while in the historical performance practice of the Baroque and Classical eras, trills are usually
performed starting on the upper (trilled-to) note. You can change the default starting pitch for
trills individually and by changing the default setting.

Another common performance practice, in particular for Romantic piano music, is to perform all
trills with an acceleration, starting slowly and getting faster during the trill. You can choose this
setting on the Trills page in Playback Options. It applies to all trills whose speed has not been
changed.

RELATED LINKS
Changing the speed of trills on page 735
Hiding/Showing speed changes in trill extension lines on page 735
Changing the starting pitch of trills on page 744

Sampled vs. generated trills
Sampled trills are recorded, looped samples, whereas generated trills are produced by manually
triggering separate notes.

Because they use fixed sounds, sampled trills typically offer no parameters that allow any kind of
variation in the trill interpretation, such as different trill speeds or incorporating grace notes and
termination notes into the pattern of trilled notes. By contrast, generated trills can provide
greater flexibility but produce a less natural and realistic sound.

If your project contains some trill intervals that can only be generated, you can disable sampled
trills and use generated trills throughout to produce a more consistent result.

Enabling/Disabling trill samples in playback
You can enable/disable the use of sampled trills in your project. This can be useful if your project
contains some trill intervals that can only be generated and you want to use only generated trills
throughout, or if you want to incorporate grace notes immediately before/after trills.

NOTE

If you are using NotePerformer for playback, we recommend that you disable sampled trills to
allow Dorico Pro to send the correct notes and controllers for NotePerformer to produce its most
realistic trill playback.

PROCEDURE

1. Press Ctrl/Cmd-Shift-P to open Playback Options.

2. Click Trills in the page list.

3. Choose one of the following options for Playback approach for trills:

● Generated trills only

● Use samples if possible

4. Click Apply, then Close.

RESULT
Sampled trills are enabled when you choose Use samples if possible, and disabled when you
choose Generated trills only.
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Changing the playback speeds of trills
In addition to changing the speed of trills, which changes both the frequency of wiggles in their
extension lines and their playback speed, you can also change the playback speed of each speed
variant in individual trills, for example, if you want to make the fastest part of an individual trill
faster than your default setting.

PROCEDURE

1. Select the trills whose playback speeds you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate any of the following properties, as appropriate for your
selected trills:

● Slow trill speed

● Normal trill speed

● Fast trill speed

3. Change the values in the value fields.

RESULT
The playback speed of the selected trills is changed. The values in the value fields correspond to
the number of notes sounding per second.

TIP

You can change the default speeds for each level on the Trills page in Play > Playback Options.

RELATED LINKS
Changing the speed of trills on page 735
Hiding/Showing speed changes in trill extension lines on page 735

Changing the starting pitch of trills
By default in Dorico Pro, trills start on the lower note, which is usually the written note. However,
the accepted practice in Baroque and Classical music is to start trills on the upper note. You can
change the starting pitch of trills individually.

PROCEDURE

1. Select the trills whose starting note you want to change. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Start on upper note in the Trills group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
The selected trills start on the upper note when the checkbox is activated, and on the lower note
when the checkbox is deactivated.
When the property is deactivated, trills follow your project-wide setting for the starting pitch of
trills.

TIP

You can change the default starting pitch of all trills project-wide on the Trills page in Play >
Playback Options.
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Arpeggio signs are vertical lines that indicate chords are to be played arpeggiated, or “spread”,
so that the notes in the chord are played very quickly one after another. Arpeggio signs are
normally shown with wavy lines similar to trill extension lines.

Arpeggiated chords can be played in two directions:

● Upwards, starting from the bottom note in the chord.

● Downwards, starting from the top note in the chord.

Dorico Pro offers the following types of arpeggio signs:

Up arpeggio
A vertical wavy line that indicates chords are to be arpeggiated from the bottom note
upwards.

Down arpeggio
A vertical wavy line that indicates chords are to be arpeggiated from the top note
downwards.

Non arpeggio
A bracket with straight lines that indicates all notes in the chord are to be played
together, not arpeggiated.

Default up arpeggio Default down arpeggio Default non arpeggio

It is most common for up arpeggios to be shown with nothing at the top end, because chords
are usually arpeggiated upwards, and for down arpeggios to be shown with an arrow at the
bottom, so this is the default in Dorico Pro. However, it is also accepted practice to show up
arpeggios with an arrow at the top if down arpeggios are also used in the same piece of music.

You can show both up arpeggios and down arpeggios with one of three ends in Dorico Pro:

● Nothing

● Arrow

● Swash

Arpeggio signs
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Up arpeggio with nothing at the
end

Up arpeggio with an arrow at the
end

Up arpeggio with a swash at the
end

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations on page 229

Changing the type of arpeggio signs
You can change the type of arpeggio signs after they have been input.

PROCEDURE

1. Select the arpeggio signs whose type you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, select one of the following options from the Arpeggio type menu
in the Arpeggios group:

● Non arpeggio

● Up arpeggio

● Down arpeggio

RESULT
The type of the selected arpeggio signs is changed.

TIP

You can also change the arpeggio type by opening the ornaments popover and changing the
entry.

RELATED LINKS
Ornaments popover on page 229
Changing existing items on page 280

Changing the end appearance of arpeggio signs
Down arpeggio signs have an arrowhead at the bottom of the line by default, but up arpeggio
signs have no arrowhead by default. You can change the appearance of the ends of arpeggio
signs individually, independently of your project-wide settings.

PROCEDURE

1. Select the arpeggio signs of any direction whose ends you want to change. You can do this
in Write mode and Engrave mode.

NOTE

You cannot change the ends of non arpeggio signs.

2. In the Properties panel, activate Sign end in the Arpeggios group.

3. Select the end you want from the menu:
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● Nothing

● Arrow

● Swash

RESULT
The appearance of the ends of the selected arpeggio signs is changed.

TIP

You can change the default appearance of the ends of all arpeggio signs project-wide on the
Arpeggio Signs page in Engrave > Engraving Options.

EXAMPLE

Up arpeggio sign with nothing at
the end

Up arpeggio sign with an arrow at
the end

Up arpeggio sign with a swash at
the end

Length of arpeggio signs
Dorico Pro automatically adjusts the length of arpeggio signs when the pitches of the notes in
the voices to which the sign applies change, or when you add notes to the chords or delete notes
from the chords.

You can change how far arpeggio signs extend beyond the outer notes in all chords project-wide
on the Arpeggio Signs page in Engrave > Engraving Options. You can set different values for
when notes are on staff lines and in staff spaces.

You can also lengthen/shorten individual arpeggio signs.

RELATED LINKS
Project-wide engraving options for arpeggio signs on page 750

Lengthening/Shortening arpeggio signs
You can lengthen/shorten individual arpeggio signs manually. For example, you might lengthen
an arpeggio sign on a chord with a small pitch range so the arpeggio sign is more clearly visible.

PROCEDURE

1. In Engrave mode, select the square handles at one end of the arpeggio signs you want to
lengthen/shorten.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the handles in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.
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TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

● Click and drag them upwards/downwards.

RESULT
The selected arpeggio signs are lengthened/shortened graphically.

TIP

● The following properties in the Arpeggios group of the Properties panel are activated
automatically when you move the corresponding end of arpeggio signs:

● Top Y offset moves the handles at the top of arpeggio signs.

● Bottom Y offset moves the handles at the bottom of arpeggio signs.

For example, if you move a whole arpeggio sign, both handles are moved so both
properties are activated. You can also use these properties to lengthen/shorten arpeggio
signs graphically by changing the values in the value fields.

Deactivating the properties resets the selected arpeggio signs to their default positions.

● You can change how far arpeggio signs extend beyond the outer notes in all chords
project-wide on the Arpeggio Signs page in Engrave > Engraving Options.

RELATED LINKS
Moving arpeggio signs graphically on page 749
Project-wide engraving options for arpeggio signs on page 750

General placement conventions for arpeggio signs
Arpeggio signs are positioned to the left of the notes, including any applicable accidentals, to
which they apply, but are positioned between grace notes and normal notes. They should appear
within the same bar as the notes to which they apply, and not on the other side of the barline.

Dorico Pro makes automatic adjustments to note spacing and staff spacing to accommodate
arpeggio signs and ensure they are positioned correctly.

Arpeggio signs should cover the whole vertical range of all notes in the chord to which they
apply, and protrude slightly at each end. However, they do not need to cover the stems of notes.
Dorico Pro automatically creates the lengths of arpeggio signs to cover the notes in chords, and
adjusts their lengths if the notes in chords change or are deleted.

If an arpeggiated chord spans two staves, such as in a piano part, its arpeggio sign can extend
across both staves.

You can move arpeggio signs to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.

You can move arpeggio signs graphically in Engrave mode; however, this does not change the
rhythmic positions to which they are attached.

You can change the default position of all arpeggio signs project-wide on the Arpeggio Signs
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for arpeggio signs on page 750
Length of arpeggio signs on page 747
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Moving arpeggio signs rhythmically
You can move arpeggio signs to new rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the arpeggio signs you want to move.

2. Move the arpeggio signs in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

NOTE

You cannot move arpeggio signs rhythmically with the mouse.

RESULT
Arpeggio signs are moved to the right/left, according to the current rhythmic grid value.
If no notes exist at the next rhythmic position according to the rhythmic grid, the arpeggio sign is
not shown. If you continue moving it to the right/left, it is shown again beside the next note at a
rhythmic position that can be reached according to the current rhythmic grid value.
You can change the rhythmic grid if you want to move arpeggio signs to notes at other rhythmic
positions.

NOTE

Only one arpeggio sign can exist at each rhythmic position. If an arpeggio sign in your selection
passes over another arpeggio sign as part of its move, the existing arpeggio sign is deleted.

Moving arpeggio signs graphically
You can move arpeggio signs graphically without changing the rhythmic positions to which they
apply.

PROCEDURE

1. In Engrave mode, select the arpeggio signs you want to move.

2. Move the arpeggio signs in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected arpeggio signs are moved graphically, without affecting the rhythmic positions to
which they apply.
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TIP

The following properties in the Arpeggios group of the Properties panel are activated
automatically when you move the corresponding part of arpeggio signs:

● Top Y offset moves the top of arpeggio signs vertically.

● Bottom Y offset moves the bottom of arpeggio signs vertically.

● X offset moves whole arpeggio signs horizontally.

For example, if you move a whole arpeggio sign upwards, both handles are moved, so Top Y
offset and Bottom Y offset are both activated. You can also use all three properties to move
arpeggio signs graphically by changing the values in the value fields.

Deactivating the properties resets the selected arpeggio signs to their default position.

RELATED LINKS
Lengthening/Shortening arpeggio signs on page 747

Showing arpeggio signs before/after grace notes
You can show arpeggio signs before/after grace notes individually. By default, arpeggio signs are
positioned immediately to the left of the notes to which they apply, and so are positioned
between normal notes and grace notes.

PROCEDURE

1. Select the arpeggio signs you want to show before grace notes. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, activate/deactivate Arpeggio before grace notes in the
Arpeggios group.

RESULT
The selected arpeggio signs are shown before grace notes when the property is activated, and
after grace notes when the property is deactivated.

Project-wide engraving options for arpeggio signs
You can find options for the project-wide appearance and position of arpeggio signs on the
Arpeggio Signs page in Engrave > Engraving Options.

The options on this page allow you to change the design, appearance, and precise position of
arpeggio signs, including whether they can be shown on notes in slash voices.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Arpeggios in playback
You can find options to control the playback of all arpeggios project-wide in the Arpeggio Signs
section of the Timing page in Play > Playback Options.

For example, you can control whether arpeggiation starts on the beat or ends on the beat, and
the speed of arpeggiation.
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You can set a default arpeggio length, expressed as a fraction of a quarter note (crotchet) at
120 bpm. It can be helpful to set arpeggio lengths using this measurement instead of defining
arpeggios as a fraction of their notated rhythm, as otherwise arpeggios in very slow music would
play back much slower than most people intend.

As well as setting a default length for arpeggios, you can also set minimum and maximum values
for the length of arpeggios, expressed as a fraction of the notated value of the arpeggio. This is
to ensure all notes with arpeggio signs can be heard within their notated duration.

TIP

You can also use properties in the Arpeggios Playback group of the Properties panel to override
the default playback options for individual arpeggio signs.

Changing arpeggio playback relative to the beat individually
You can change whether individual arpeggios are played before their notated position or after
their notated position, independently of your project-wide settings.

PROCEDURE

1. Select the arpeggio signs whose playback relative to the beat you want to change. You can
do this in Write mode and Engrave mode.

2. In the Properties panel, activate Playback position in the Arpeggios Playback group.

3. Choose one of the following options:

● Start on beat

● End on beat

RESULT
The beat-relative position of the selected arpeggios in playback is changed.

TIP

You can change the playback of all arpeggios relative to the beat project-wide on the Timing
page in Play > Playback Options.

EXAMPLE

Arpeggio starting on the beat Arpeggio ending on the beat

RELATED LINKS
Arpeggios in playback on page 750
Playback Options dialog on page 405
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Changing the playback duration of arpeggios individually
You can change the duration of individual arpeggios in playback, independently of your project-
wide settings.

The duration of arpeggios is expressed as a fraction of the notated rhythm of chords. For
example, an arpeggio on a quarter note (crotchet) chord with a note offset value of 1/2 lasts an
eighth note (quaver), whereas with a note offset value of 1/8 it lasts a 32nd note.

PROCEDURE

1. Select the arpeggio signs whose playback offset you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Note offset in the Arpeggios Playback group.

3. Change the playback offset of the selected arpeggio signs by changing the value in the
value field.

4. Press Return.

RESULT
The playback duration of the selected arpeggios is changed. This overrides your project-wide
settings for the duration of arpeggios for the selected arpeggios.

EXAMPLE

Arpeggiated chord with a note offset value of 1/8 Arpeggiated chord with a note offset value of 1/2

RELATED LINKS
Arpeggios in playback on page 750

Arpeggio signs
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Glissando lines indicate a continuous transition between two notes, which can be smooth or in
chromatic steps. They can have straight lines or wiggly lines, and can be shown with a text
indication or as a line without text.

There are different conventions regarding the playing techniques for glissando and portamento.
Some people understand glissando lines to indicate a chromatic scale between the two notes,
either rising or falling in a series of semitones, and portamento lines to indicate a smooth,
continuous glide between the two notes. However, the terms glissando and portamento can be
used interchangeably in other cases.

You can input both glissando lines and portamento lines in Dorico Pro, and you can easily change
their style after they have been input.

An example glissando line with text shown and a
wiggly line

An example portamento line with text shown and a
straight line

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations on page 229

General placement conventions for glissando lines
Glissando lines are positioned between noteheads and the steepness of their angle should
reflect the interval between the notes: the steeper the angle, the greater the interval. The
endpoints of glissando lines must be directly beside noteheads but not directly touching them.

Glissando lines must not collide with accidentals, and instead must stop short so the accidental
can be clearly read. Dorico Pro automatically positions glissando lines so they do not collide with
accidentals.

Usually, glissando lines join two adjacent noteheads because they indicate a gradual but
constant change in pitch between those two notes, but they can also cross multiple notes.

Glissando lines can cross system breaks and page breaks. If text is shown for glissando lines that
span across a system break or page break, then that text is shown on every part of the glissando
line. By default, the start position and end position of each segment matches the original start
point and end point of the whole glissando line.

In Dorico Pro, you can make detailed adjustments to the default positions of glissando lines on
the Glissando Lines page in Engrave > Engraving Options. You can also adjust the start/end
positions of individual glissando lines in Engrave mode.

RELATED LINKS
Project-wide engraving options for glissando lines on page 754

Glissando lines
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Changing the default angles of glissando lines project-wide on page 757
Changing the angles of glissando lines individually on page 758

Project-wide engraving options for glissando lines
You can find options for the project-wide appearance and position of glissando lines on the
Glissando Lines page in Engrave > Engraving Options.

The options on the Glissando Lines page allow you to change the style, appearance, and
thickness of glissando lines. You can also set precise positions for the endpoints of glissando
lines relative to noteheads.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Glissando lines across empty bars
In Dorico Pro, you can input glissando lines between any two notes, even if there are rests or
other notes between them, and including between notes in different voices and notes on
different staves.

For very long glissando lines that extend across multiple bars, you might not want to show
pitches at the start of each bar, for example, to indicate that performers do not emphasize
pitches during the course of the glissando, or that performers can play the glissando at their own
speed. By default, Dorico Pro shows notes or rests in every bar.

Once you have input a glissando line between the selected notes, you can delete any rests
between them.

EXAMPLE

A glissando line across multiple bars with no rests shown between the two notes

RELATED LINKS
Inputting glissando lines with the popover on page 235
Inputting glissando lines with the panel on page 236
Hiding/Showing bar rests in empty bars on page 864
Deleting rests on page 863
Turning explicit rests into implicit rests on page 862

Changing the style of glissando lines
Glissando lines can be shown as straight lines or wiggly lines. You can change the glissando line
style of glissando lines individually, independently of your project-wide setting.

PROCEDURE

1. Select the glissando lines whose style you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Glissando style in the Glissando Lines group.

3. Choose one of the following options:

Glissando lines
Project-wide engraving options for glissando lines 
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● Straight line

● Wiggly line

RESULT
The glissando line style is changed for the selected glissando lines.

TIP

● Deactivating Glissando style returns the selected glissando lines to the default style.

● You can also change the glissando style by opening the ornaments popover and changing
the entry.

● You can change the default style for all glissando lines project-wide on the Glissando
Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for glissando lines on page 754
Ornaments popover on page 229
Changing existing items on page 280

Changing glissando line text
Glissando lines can be shown with text or without text. You can change the text of glissando lines
individually, independently of your project-wide setting.

PROCEDURE

1. Select the glissando lines whose text you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Glissando text in the Glissando Lines group.

3. Select one of the following options from the menu:

● Gliss.

● Port.

● No text

RESULT
The text shown on the selected glissando lines is changed.

TIP

You can change the text shown on all glissando lines project-wide on the Glissando Lines page
in Engrave > Engraving Options.

Glissando lines
Changing glissando line text 

755
Dorico 2.2.20



Changing when glissando line text is shown
By default, glissando text is not shown when glissando lines are too short to accommodate the
text. You can choose to show text on individual glissando lines always, or only if there is sufficient
space.

PROCEDURE

1. Select the glissando lines whose setting for when text is shown you want to change. You
can do this in Write mode and Engrave mode.

2. In the Properties panel, activate Glissando text shown in the Glissando Lines group.

3. Choose one of the following options:

● Show if sufficient space

● Always show

RESULT
If Show if sufficient space is chosen, glissando line text is not shown if the glissando line is too
short.
If Always show is chosen, glissando line text is always shown, even if the glissando line is short.
However, this can cause the glissando line text to collide with other items, such as noteheads and
stems.

TIP

You can increase the default gaps between noteheads by changing the default note spacing, and
between individual noteheads by adjusting note spacing at individual rhythmic positions in
Engrave mode.

RELATED LINKS
Note spacing on page 381
Changing the default note spacing on page 383

Moving glissando lines graphically
You can move individual glissando lines graphically without changing the rhythmic positions to
which they are attached. You can move each end of glissando lines independently, meaning you
can also adjust the angle and graphical length of individual glissando lines.

If glissando lines cross system and frame breaks, you can move each glissando line segment
independently.

NOTE

You cannot move glissando lines rhythmically. If you want to change the rhythmic positions of
glissando lines, you must delete them from their original positions and input new glissando lines
at the new positions.

PROCEDURE

1. In Engrave mode, select one of the following that you want to move:

● Whole glissando lines, or glissando line segments

● Individual handles on glissando lines

Glissando lines
Moving glissando lines graphically 
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TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the glissando lines or handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected glissando lines or handles are moved graphically, without affecting the rhythmic
positions to which they are attached.

TIP

The following properties in the Glissando Lines group of the Properties panel are activated
automatically when you move the corresponding glissando line handle:

● Start offset moves start glissando line handles. X moves them horizontally, Y moves them
vertically.

● End offset moves end glissando line handles. X moves them horizontally, Y moves them
vertically.

For example, if you move a whole glissando line, both handles are moved so both properties are
activated. You can also use these properties to move and lengthen/shorten glissando lines
graphically by changing the values in the value fields.

Deactivating the properties resets the selected glissando lines to their default positions.

RELATED LINKS
Changing the angles of glissando lines individually on page 758
Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations on page 229

Changing the default angles of glissando lines project-wide
In Dorico Pro, the endpoints of glissando lines are automatically positioned beside noteheads.
When glissando lines cover a small pitch range, the angle of the line can be quite shallow. You
can change the values for the minimum spans of glissando lines covering a small pitch range in
different contexts project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Glissando Lines in the page list.

3. In the Vertical Position section, change the values for the positions of glissando lines in
the contexts relevant to your project.
For example, you can increase the minimum span of glissando lines between notes in the
same staff space.

Glissando lines
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4. Click Apply, then Close.

RESULT
The default positions and angles of glissando lines are changed.

TIP

You can make graphical adjustments to the positions of individual glissando lines in Engrave
mode.

RELATED LINKS
Moving glissando lines graphically on page 756

Changing the angles of glissando lines individually
You can adjust the angles of individual glissando lines in Engrave mode by moving the handles at
each end of glissando lines in any direction.

PROCEDURE

1. In Engrave mode, select the square handles at the start/end of the glissando lines whose
angles you want to change.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

3. Optional: Repeat steps 1 and 2 for the other glissando line handles.

RESULT
The angles of the selected glissando lines are changed.

NOTE

You can also use the Start offset and End offset properties in the Glissando Lines group of the
Properties panel in Engrave mode to adjust the angles and graphical lengths of glissando lines.

Deactivating the properties resets the selected glissando lines to their default positions.

Glissando lines
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Jazz articulations in Dorico Pro cover a range of note ornamentations that are idiomatic to jazz
music, and brass instruments in particular.

Although they are often known as jazz “articulations”, these techniques function more like
ornaments than articulations because they change the pitch rather than the duration or attack of
notes. For this reason, they are considered ornaments in Dorico Pro. They are found in the
Ornaments panel, and you can also input them using the ornaments popover.

Jazz articulations can be shown as a curved line similar to a slur, which is called a “bend” in Dorico
Pro, and as a straight line, which can be solid, dashed, or wiggly, which is called “smooth” in
Dorico Pro.

Each note can have a single jazz articulation on each side of it, one before the note and one after.
Jazz articulations after notes can have different lengths.

The following jazz articulations can be shown before notes:

Plop
An approach into the note from above.

Plop (bend) Plop (smooth)

Scoop/Lift
An approach into the note from below. A bend approach is a scoop, a smooth
approach is a lift.

Scoop Lift (straight)

The following jazz articulations can be shown after notes:

Doit
A rise in pitch after the note.

Doit (bend) Doit (smooth)

Fall
A lowering of pitch after the note.

Jazz articulations
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Fall (bend) Fall (smooth)

Additionally, there are other jazz ornaments commonly used by brass instruments that you can
add to notes in the same ways as inputting jazz articulations.

NOTE

Jazz articulations are not currently reflected in playback.

RELATED LINKS
Ornaments popover on page 229
Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations on page 229

Jazz ornaments
Jazz ornaments are notations that are commonly used in jazz music and by brass instruments,
such as flips and smears, that are positioned outside of the staff rather than beside noteheads
like jazz articulations.

Jazz ornaments behave more like other ornaments than jazz articulations, in that they are items
separate from notes, and so can be selected independently of notes in Write mode and added to
notes in addition to jazz articulations. Because they are so commonly used alongside jazz
articulations, in Dorico Pro they are also included in the Jazz section in the Ornaments panel.

You can input jazz ornaments in the same ways as inputting other ornaments rather than jazz
articulations.

The following ornaments are considered jazz ornaments in Dorico Pro:

● Flip

● Smear

● Jazz turn/Shake

● Bend

NOTE

Jazz articulations are not currently reflected in playback.

RELATED LINKS
Ornaments on page 729
Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations on page 229
Ornaments popover on page 229
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Project-wide engraving options for jazz articulations
You can find options for the project-wide appearance and position of ornaments on the Jazz
Articulations page in Engrave > Engraving Options.

The options on the Jazz Articulations page allow you to change the default length of bends and
the default line style, design, and angle of smooth jazz articulations. You can also change the
default positions of jazz articulations relative to noteheads, staff lines, rhythm dots, and jazz
articulations belonging to other notes at the same rhythmic position.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Moving jazz articulations graphically
You can move individual jazz articulations graphically without changing the notes to which they
apply. You can move each end of smooth jazz articulations independently, meaning you can also
adjust the angle and graphical length of individual smooth jazz articulations.

Handles on a smooth doit in Engrave mode

NOTE

You cannot move jazz articulations rhythmically. If you want to change the notes to which jazz
articulations apply, you must delete them from their original notes and input new jazz
articulations on the new notes.

PROCEDURE

1. In Engrave mode, select one of the following that you want to move:

● Whole jazz articulations

● Individual handles on smooth jazz articulations

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the jazz articulations or handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

Jazz articulations
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● Click and drag them in any direction.

RESULT
The selected jazz articulations or handles are moved graphically, without affecting the notes to
which they apply.

TIP

The following properties in the Jazz Articulations group of the Properties panel are activated
automatically when you move the corresponding smooth jazz articulation handle:

● In far offset moves the start handle of jazz articulations shown before notes, that is, the
handle further from the note. X moves them horizontally, Y moves them vertically.

● In offset moves the end handle of jazz articulations shown before notes, that is, the
handle closer to the note. X moves them horizontally, Y moves them vertically.

● Out offset moves the start handle of jazz articulations shown after notes, that is, the
handle closer to the note. X moves them horizontally, Y moves them vertically.

● Out far offset moves the end handle of jazz articulations shown after notes, that is, the
handle further from the note. X moves them horizontally, Y moves them vertically.

For example, if you move a whole smooth fall, both handles are moved so both Out offset and
Out far offset are activated. You can also use these properties to move and lengthen/shorten
smooth jazz articulations graphically by changing the values in the value fields.

Deactivating the properties resets the selected smooth jazz articulations to their default
positions.

RELATED LINKS
Jazz articulations on page 759
Deleting jazz articulations on page 764
Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations on page 229

Positions of jazz articulations
In Dorico Pro, jazz articulations are automatically positioned relative to the noteheads to which
they apply, with any other notations on those notes, such as rhythm dots, accidentals, and back
notes, automatically considered.

When multiple notes in a chord have a jazz articulation, Dorico Pro considers the best way to
align them based on how close to the noteheads they can be positioned and how many jazz
articulations to show in total. Dorico Pro allows a maximum of one jazz articulation per space,
meaning fewer jazz articulations than noteheads are sometimes shown on cluster chords.

They are positioned by default according to your settings in Engraving Options.

You can change the default positions of all jazz articulations project-wide relative to other jazz
articulations and to noteheads on the Jazz Articulations page in Engrave > Engraving Options.

In Engrave mode, smooth jazz articulations have a handle at each end that you can use to move
the start and end of each smooth jazz articulation independently. You can also move whole
individual jazz articulations graphically.

RELATED LINKS
Project-wide engraving options for jazz articulations on page 761

Jazz articulations
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Changing the type/length of existing jazz articulations
You can change the type and length of jazz articulations after you have input them, for example,
if you want to change a smooth doit to a long bend doit. You can specify the type/length of jazz
articulations when using the Ornaments panel but not when using the ornaments popover.

PROCEDURE

1. In Write mode, select the notes whose jazz articulation you want to change.

2. In the Ornaments panel, click the jazz articulation you want in the Jazz section.

RESULT
The jazz articulation shown on the selected notes is changed.

TIP

You can also change the type/duration of jazz articulations using the In and Out properties in the
Jazz Articulations group in the Properties panel.

EXAMPLE

Short bend doit Medium bend doit Long bend doit

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations on page 229

Changing the line style of smooth jazz articulations
You can change the line style of smooth jazz articulations individually, independently of your
project-wide settings. For example, if you want selected smooth falls to have straight lines
instead of wavy lines.

PROCEDURE

1. Select the notes with smooth jazz articulations whose line style you want to change. You
can do this in Write mode and Engrave mode.

NOTE

You must select notes with smooth jazz articulations on the same side, for example, only
select notes with smooth jazz articulations before them.

2. In the Properties panel, select one of the following line styles from the In line style menu
and/or Out line style menu in the Jazz Articulations group:

● Straight

● Wavy

● Dashed

NOTE

In line style is available when you select notes with smooth jazz articulations before them,
and Out line style is available when you select notes with smooth jazz articulations after
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them. Both are available when you select notes with smooth jazz articulations on both
sides.

RESULT
The line style of the selected smooth jazz articulations is changed.

TIP

● You can reset jazz articulations back to their default line style by selecting them and
choosing Edit > Reset Appearance.

● You can change the default line style of each smooth jazz articulation independently on
the Jazz Articulations page in Engrave > Engraving Options.

EXAMPLE

Doit smooth with straight line Doit smooth with wavy line Doit smooth with dashed line

RELATED LINKS
Changing the type/length of existing jazz articulations on page 763
Project-wide engraving options for jazz articulations on page 761
Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations on page 229

Deleting jazz articulations
You can remove jazz articulations from notes after you have input them. However, because jazz
articulations are considered an intrinsic part of notes rather than a separate item, you must
select and delete them differently from other items.

PROCEDURE

1. In Write mode, select the notes from which you want to remove jazz articulations.

2. In the Ornaments panel, click Remove in the Jazz section.

RESULT
All jazz articulations are removed from the selected notes.

RELATED LINKS
Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations on page 229
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Page numbers are used to give each page a unique number, and indicate its position relative to
other pages. Just as in newspapers and books, musical scores and parts use page numbers to
make sure the music stays in the correct order.

Because you can have multiple flows in a single project in Dorico Pro, you do not need to change
page numbers manually in most cases. However, if you have separate files that together make
up a single piece, page number changes are necessary to make sure the page numbers continue
seamlessly from movement to movement.

In such cases, you can change the default page numbers. For example, if you want to have four
pages of front matter before the first page of music in the score, but you want the first page of
music in the score to be shown as page 1, you can insert a page number change on the first page
of music.

Page numbers are layout-specific in Dorico Pro, meaning you can change the page numbers in
each layout independently of the others. For example, you can change the page numbers in the
score but show the default page numbers in the parts.

Page numbers in Dorico Pro use a text token to ensure the number is correct.

NOTE

You must have a text frame containing the page number token on every page on which you want
page numbers to be shown.

The default master pages contain text frames with page number tokens. You can change the
position of page number text frames in the master page editor, which changes the position of
page numbers on all pages that use that master page. You can also move page number text
frames on individual pages.

You can also change the type of number used to show page numbers in each layout. For
example, if you want the front matter to use Roman numerals but the music pages to use Arabic
numerals, you can change the type of number together with the page number.

RELATED LINKS
Page Number Change dialog on page 312
Inserting page number changes on page 311
Master page overrides on page 308
Removing page number changes on page 313
Inputting frames on page 322
Text tokens on page 332

Page numbers
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Moving page numbers in master pages
In order to change where page numbers are shown, you must move the text frames that contain
page numbers. The most efficient way to do this is to move the text frames containing page
numbers in master page formats.

PROCEDURE

1. In Engrave mode, double-click a master page pair whose page number position you want
to change in the Master Pages section of the Pages panel.

2. In the master page editor, select the text frames that contain page numbers.

3. Move the text frames in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

4. Click Apply, then Close.

RESULT
The selected text frames are moved.

TIP

When you move text frames, values for Left, Top, Right, and Bottom in the Frames group of the
Properties panel are changed to reflect the distance of the corresponding edge of the frame
from the page margin, but the values are only visible if the corresponding constraint is locked.

You can also use these properties to move text frames by changing the values in the value fields.

● Right/Left move the right/left edges of frames horizontally.

● Top/Bottom move the top/bottom edges of frames vertically.

You can lock/unlock constraints for each text frame in the Frames section of the Formatting
panel.

RELATED LINKS
Frame constraints on page 340
Master pages on page 301

Page number paragraph styles
The paragraph style for page numbers controls all aspects of their appearance, including their
font, size, and horizontal alignment. You can edit the existing page number paragraph style, and
create additional page number paragraph styles, in the Paragraph Styles dialog.

● You can open the Paragraph Styles dialog in Engrave mode by choosing Engrave >
Paragraph Styles.

Dorico Pro offers a single paragraph style for page numbers by default, but you can create other
paragraph styles for page numbers. For example, if you want page numbers to appear bold and
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centered at the tops of pages in full score layouts but appear italic and on the outer edges of
pages in part layouts, you can create a new paragraph style based on the existing Page Number
paragraph style, but rename it and change the settings.

RELATED LINKS
Paragraph Styles dialog on page 366
Text editor options in Engrave mode on page 371
Changing the paragraph style of text on page 373
Creating paragraph styles on page 368

Changing the page number numeral style
Page numbers can appear as Arabic or Roman numerals. You can change the numeral style of
page numbers project-wide in each layout independently.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts whose page number numeral style you want to
change.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Page Numbers section, select one of the following options from the Use menu:

● Number

● Roman numeral

5. Click Apply, then Close.

RESULT
The page number numeral style is changed project-wide in the selected layouts.
You can change settings for other layouts before closing the dialog.

Changing the page number numeral style for individual pages
Page numbers can appear as Arabic or Roman numerals. You can change the numeral style for
individual page numbers.

PROCEDURE

1. In Engrave mode, in the music area, open the layout whose page number numeral style
you want to change.

2. In the Pages section of the Pages panel, select a page.

3. Open the Page Number Change dialog in any of the following ways:

● Right-click in the Pages section and choose Insert Page Number Change from the
context menu.

● Click Insert Page Number Change.

4. In the Page Number Change dialog, enter the number of the page from which you want
to change the page number numeral style in the From page field.

5. Select the numeral style you want from the following options for Sequence type:
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● Number

● Roman numeral

6. Click OK to save your changes and close the dialog.

RESULT
The page number numeral style is changed until the next page number change or the end of the
project, whichever comes first.

RELATED LINKS
Inserting page number changes on page 311

Hiding/Showing page numbers
You can hide/show page numbers in each layout independently, including specifying whether to
hide/show a page number on the first page. For example, you can show page numbers on every
page in the score but hide page numbers on the first page in the parts.

NOTE

To show page numbers, there must be a text frame containing the page number token on the
page. The default master page formats for first pages do not contain text frames containing
page number tokens, so you must add these if you want to show page numbers on first pages in
your project that use the default master page formats.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show page numbers.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Page Numbers section, select one of the following options from the Visibility
menu:

● Always shown

● Always hidden

● Not on first page

5. Click Apply, then Close.

RESULT

● If you select Always shown, page numbers are shown on all pages that have a text frame
containing the page number token in the selected layouts.

● If you select Always hidden, page numbers are hidden on all pages in the selected
layouts, including on pages that have a text frame containing the page number token.

● If you select Not on first page, page numbers are hidden on the first page in the selected
layouts, but shown on all other pages that have a text frame containing the page number
token.
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NOTE

Your per-layout setting for whether page numbers are hidden/shown above flow headings
affects whether page numbers are shown on pages where they are higher on the page than flow
headings.

RELATED LINKS
Page Number Change dialog on page 312
Inserting page number changes on page 311
Inputting frames on page 322
Flow headings on page 318
Hiding/Showing information in running headers above flow headings on page 348

Hiding/Showing page numbers on individual pages
You can change when page numbers are shown on individual pages, independently of your
settings for showing page numbers in each layout.

NOTE

To show page numbers, there must be a text frame containing the page number token on the
page. The default master page formats for first pages do not contain text frames containing
page number tokens, so you must add these if you want to show page numbers on first pages in
your project that use the default master page formats.

PROCEDURE

1. In the music area, open the layout in which you want to hide/show page numbers.

2. In the Pages section of the Pages panel, select a page.

3. Open the Page Number Change dialog in any of the following ways:

● Right-click in the Pages section and choose Insert Page Number Change from the
context menu.

● Click Insert Page Number Change.

4. In the From page field, enter the number of the page from which you want to hide/show
page numbers.

5. Optional: Change the value for First page number.
First page number is 1 by default. If you do not want to change the page number
together with changing the visibility of page numbers, enter the existing page number in
this field.

6. Select one of the following options from the Visibility menu:

● Always shown

● Always hidden

● Not on first page

7. Click OK to save your changes and close the dialog.

RESULT
The visibility of page numbers is changed in the layout currently open in the music area, from the
page number specified until the next page number change with a different setting or the end of
the project, whichever comes first.
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EXAMPLE
If you want to see page numbers up to page 3 but hide page numbers from page 4, enter 4 for
From page, enter 4 for First page number, and select Always hidden for Visibility.

RELATED LINKS
Page Number Change dialog on page 312
Inserting page number changes on page 311
Inputting frames on page 322
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Pedal lines indicate to performers which piano pedals to use, and can also give performance
instructions, such as how far down to depress the pedals and when to lift the pedal to clear the
resonance.

Most pianos have either two or three pedals. These pedals are:

Sustain pedal
The sustain pedal controls the dampers on the piano strings, which is why it is also
known as the “damper pedal”. It is also the most commonly used pedal. Depressing
the sustain pedal removes the dampers, allowing the strings to resonate longer.
Sustain pedals are usually on the right.

An example sustain pedal line

Sostenuto pedal
The sostenuto pedal only allows the strings of the notes currently depressed on the
keyboard to resonate. It is also known as the “middle pedal” as it is usually in the
middle of the other pedals.

An example sostenuto pedal line

Una corda pedal
The una corda pedal shifts the action inside the piano so that the hammers hit fewer
strings than normal. Historically, this caused hammers only to hit one string, not the
usual three, which is where the name comes from. Because this reduces the volume
and impact of the sound, it is also known as the “soft pedal”.

An example una corda pedal line

Dorico Pro offers comprehensive notational and playback support for piano pedal lines. You can
create pedaling for the sustain, sostenuto, and una corda pedals, with support for modern sustain
pedaling techniques, including changing the pedal level over the course of a single pedal
instruction.

In Dorico Pro, pedal lines are considered playing techniques because they alter the sound
produced by the instrument. Therefore, pedal lines are included in the Playing Techniques panel
in Write mode and you can input them using the playing techniques popover. However, pedal
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lines have additional, unique requirements that do not apply to other playing techniques, such as
retakes, pedal level changes, start signs, end signs, and continuation lines.

RELATED LINKS
Input methods for playing techniques and pedal lines on page 238
Pedal lines in playback on page 788
Pedal line start signs, hooks, and continuation lines on page 782
Pedal line start, continuation, and restorative text on page 786

Sustain pedal retakes and pedal level changes
Pedal retakes indicate where a player should lift the sustain pedal, which dampens the piano’s
strings and clears the resonance, before depressing the pedal again. Pedal level changes indicate
a change to how far the pedal is depressed.

Dorico Pro provides clear representations of pedal retakes and level changes.

NOTE

You can only add pedal retakes and level changes to sustain pedal lines.

EXAMPLE

Example pedal line with retake and level changes

1 Ped. glyph

2 Retake

3 One quarter depressed

4 Half depressed

5 Three quarters depressed

6 Fully depressed

7 Line end hook

RELATED LINKS
Removing retakes and pedal level changes on page 777
Input methods for playing techniques and pedal lines on page 238

Sustain pedal lines in Engrave mode
When you select sustain pedal lines in Engrave mode, handles appear at the start/end of each
pedal line, and on any retakes or pedal level changes on the line. These handles allow you to
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move each part of the pedal line independently, and to change the pedal levels at the start, end,
and at each retake or pedal level change.

A sustain pedal with a retake in Engrave mode

There are two handles for the start of the pedal line, three for retakes and pedal level changes,
and three for the end of the pedal line.

NOTE

Sostenuto and una corda pedal lines only have a single handle at their start/end, which allows you
to move their start/end positions graphically, but only horizontally.

You can move each handle with the keyboard, with the mouse, and using the Properties panel.
Each handle corresponds to a property in either the Pedal Lines group or the Pedal Line
Retakes group of the Properties panel.

NOTE

Pedal levels cannot be lower than 0 or higher than 1.

● 1 is fully depressed.

● 0 is not depressed.

Start of sustain pedal lines

There are two handles at the start of pedal lines.

● The left handle moves the start point of the pedal line. You can move this handle to the
right/left.

● The right handle changes the start pedal level of the pedal line. You can move this handle
upwards/downwards. This changes the angle of the pedal continuation line in relation to
the next retake or pedal level change, or the end of the pedal line.

Pedal level changes and retakes

● The left handle changes the pedal level before the retake. You can move this handle
upwards/downwards.

● The right handle changes the pedal level after the retake. You can move this handle
upwards/downwards.

● The bottom handle corresponds to the position of the pedal level change or retake. You
can move this handle to the right/left.
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End of sustain pedal lines

● The top handle changes the hook length. You can move this handle upwards/downwards.

● The right handle changes the pedal level at the end of the pedal line. You can move this
handle upwards/downwards.

● The bottom handle moves the end point of the pedal line. You can move this handle to the
right/left.

RELATED LINKS
Moving pedal lines graphically on page 779

Changing the type of pedal line retakes
You can change existing retakes on sustain pedal lines to pedal level changes and vice versa.

For example, if you do not want the pedal to be released completely between the old and new
levels, change the type to Change Level instead of Retake.

PROCEDURE

1. In Engrave mode, select the retake or pedal level change whose type you want to change.

2. In the Properties panel, activate Retake type in the Pedal Line Retakes group.

3. Choose the type you want from the following options:

● Retake

● Change Level

RESULT
The type of pedal line retake is changed.

NOTE

The appearance of the new type of pedal line retake depends on the pedal levels already set on
each side. For example, a retake notch is only shown on one side of the retake if the pedal level
on the other side is set to 0.

Changing the start level of pedal lines
You can change the start level of individual sustain pedal lines by moving start level handles
upwards/downwards.

PROCEDURE

1. In Engrave mode, select the right handles on the start signs whose start pedal levels you
want to change.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the start level handles in any of the following ways:

● Press Alt-Up Arrow to move them upwards.
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● Press Alt-Down Arrow to move them downwards.

● Press Ctrl/Cmd-Alt-Up Arrow to snap the level to 0 (not depressed).

● Press Ctrl/Cmd-Alt-Down Arrow to snap the level to 1 (fully depressed).

● Click and drag the handles upwards/downwards to the level you want.

RESULT
The start level of the selected pedal line is changed.

TIP

Start level in the Pedal Lines group of the Properties panel is activated when you change the
start level of pedal lines.

You can also use this property to change the start level of pedal lines by changing the value in
the value field. For example, 1 is fully depressed and 0 is not depressed.

Deactivating the property resets the selected pedal lines to their default start level.

RELATED LINKS
Sustain pedal lines in Engrave mode on page 772

Changing pedal levels at retakes and pedal level changes
You can change both the start level and end level of individual sustain pedal lines at retakes and
pedal level changes by moving the corresponding handles upwards/downwards.

The end level is the pedal level immediately before the retake or pedal level change occurs, and
the start level is the pedal level immediately after the retake or pedal level change occurs.

PROCEDURE

1. In Engrave mode, select one of the handles on the retakes or pedal level changes whose
start/end pedal level you want to change.

● Select the left handle to change the end pedal level.

● Select the right handle to change the start pedal level.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the start level handles in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

● Press Ctrl/Cmd-Alt-Up Arrow to snap the level to 0 (not depressed).

● Press Ctrl/Cmd-Alt-Down Arrow to snap the level to 1 (fully depressed).

● Click and drag the handles upwards/downwards to the level you want.

3. Optional: Repeat steps 1 and 2 for any other handles.

RESULT
The pedal levels of the selected retakes or pedal level changes are changed.

Pedal lines
Sustain pedal retakes and pedal level changes 

775
Dorico 2.2.20



TIP

The following properties in the Pedal Lines group of the Properties panel are activated when you
change the corresponding level at retakes and pedal level changes:

● Start level at retake

● End level at retake

You can also use these properties to change the corresponding level at retakes and pedal level
changes by changing the values in the value fields. For example, 1 is fully depressed and 0 is not
depressed.

Deactivating the properties resets the selected pedal lines to their default start/end levels.

RELATED LINKS
Sustain pedal lines in Engrave mode on page 772

Changing the end level of pedal lines
You can change the end level of individual sustain pedal lines by moving end level handles
upwards/downwards.

NOTE

You can only change the end level of pedal lines that have a hook as their end sign.

PROCEDURE

1. In Engrave mode, select the right handles on the end hooks whose end pedal levels you
want to change.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the end level handles in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

● Press Ctrl/Cmd-Alt-Up Arrow to snap the level to 0 (not depressed).

● Press Ctrl/Cmd-Alt-Down Arrow to snap the level to 1 (fully depressed).

● Click and drag the handles upwards/downwards to the level you want.

RESULT
The end levels of the selected pedal lines are changed.

TIP

End level in the Pedal Lines group of the Properties panel is activated when you change the end
level of pedal lines.

You can also use this property to change the end level of pedal lines by changing the value in the
value field. For example, 1 is fully depressed and 0 is not depressed.

Deactivating the property resets the selected pedal lines to their default end level.
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RELATED LINKS
Sustain pedal lines in Engrave mode on page 772

Removing retakes and pedal level changes
You can remove pedal retakes and level changes without deleting the sustain pedal line or
changing its rhythmic position.

PROCEDURE

1. In Write mode, select the note at the rhythmic position of the retake or pedal level change
you want to remove.

NOTE

You can only remove one retake or pedal level change at a time.

2. Remove the retake or pedal level change in any of the following ways:

● Open the playing techniques popover, enter nonotch into the popover, then press
Return.

NOTE

nonotch must be spelled as one word, without a space.

● Choose Edit > Pedal Lines > Remove Retake. You can also choose this option from
the context menu.

RESULT
The selected retake or pedal level change is removed, and the pedal line returns to its previous
level as set by either the start of the pedal line, or the retake or pedal level change immediately
preceding the one you removed.

RELATED LINKS
Playing techniques popover on page 238

Positions of pedal lines
The default placement of pedal lines is below the bottom staff, even if there are only notes in the
upper staff for the right hand. They are placed outside all other notations, including octave lines,
slurs, and articulations.

If one pedal is used, it is placed as close to the bottom of the staff as possible, while remaining
outside of all other notations.

If multiple pedals are used simultaneously, they are organized below the bottom of the staff as
follows:

1. Sustain pedal: closest to the staff

2. Sostenuto pedal: below the sustain pedal line

3. Una corda pedal: furthest from the staff

The beginning of the glyph/text that indicates the start position of pedal lines aligns with the
note to which it applies. If you are using a line end hook to indicate the end of pedal lines, the
hook aligns with the note or rhythmic position to which it applies.

You can move pedal lines to different rhythmic positions in Write mode. They are positioned by
default according to your settings in Engraving Options.
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NOTE

You cannot move retakes or pedal level changes rhythmically. You must remove them and input
a new retake or pedal level change at the position you want.

You can move pedal lines graphically in Engrave mode. However, this does not change the
rhythmic positions to which they are attached.

You can change the default positions of all pedal lines project-wide on the Pedal Lines page in
Engrave > Engraving Options. For example, you can change values for the minimum distances
between pedal lines and staves, pedal lines and other pedal lines, and the position of pedal lines
relative to noteheads and grace notes.

RELATED LINKS
Project-wide engraving options for pedal lines on page 781
Pedal line start, continuation, and restorative text on page 786
Pedal line start signs, hooks, and continuation lines on page 782
Moving pedal lines graphically on page 779
Lengthening/Shortening pedal lines on page 781
Input methods for playing techniques and pedal lines on page 238

Moving pedal lines rhythmically
You can move pedal lines to new rhythmic positions after they have been input. Any retakes or
pedal level changes on the pedal lines are also moved.

NOTE

If you want to move retakes or pedal level changes independently of the pedal line, you must
first remove them from their original positions and input new retakes or pedal level changes at
the new positions.

PROCEDURE

1. In Write mode, select the pedal lines you want to move.

NOTE

When using the mouse, you can only move one pedal line rhythmically at a time.

2. Move the pedal lines in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the pedal line to the right/left.

RESULT
A single pedal line is moved to the next/previous notehead on that staff.
Multiple pedal lines are moved according to the current rhythmic grid value.

NOTE

Pedal lines can only be moved along staves. If you want to move a pedal line across staves, you
must delete the pedal line and input a new pedal line on the other staff.

RELATED LINKS
Lengthening/Shortening pedal lines on page 781
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Sustain pedal lines in Engrave mode on page 772
Input methods for playing techniques and pedal lines on page 238

Moving pedal lines graphically
You can move pedal lines, retakes, and pedal level changes graphically without changing the
rhythmic positions to which they apply. You can also move the start/end of pedal lines
independently, meaning you can lengthen/shorten them graphically.

NOTE

You can only change the angle of pedal lines by changing the level.

PROCEDURE

1. In Engrave mode, select one of the following:

● The pedal lines you want to move.

● The start/end handles of the pedal lines whose start/end you want to move.

● The bottom handles of the retakes and pedal level changes you want to move.

NOTE

● You can show handles on all items, not just selected items, by choosing Engrave >
Show Handles > Always. This can make it easier to select individual handles on
multiple items.

● You can move multiple pedal lines together, but only upwards/downwards.

● You can move handles on multiple pedal lines together, but only to the right/left.

2. Move the pedal lines or handles in any of the following ways:

● Press Alt-Right Arrow to move pedal lines and handles to the right.

● Press Alt-Left Arrow to move pedal lines and handles to the left.

● Press Alt-Up Arrow to move whole pedal lines upwards.

● Press Alt-Down Arrow to move whole pedal lines downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected pedal lines or handles are moved to new graphical positions.

TIP

The following properties in the Pedal Lines group of the Properties panel are activated
automatically when you move pedal lines in the corresponding directions:

● Start X offset moves the start of pedal lines horizontally.

● End X offset moves the end of pedal lines horizontally.

● Y offset moves whole pedal lines vertically.

X offset in the Pedal Line Retakes group of the Properties panel is activated automatically when
you move pedal retakes or pedal level changes horizontally.
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For example, if you move a whole pedal line to the right, both handles are moved, so Start X
offset and End X offset are both activated. You can also use all of these properties to move
pedal lines, retakes, and pedal level changes, and lengthen/shorten pedal lines graphically, by
changing the values in the value fields.

Deactivating the properties resets the selected pedal lines to their default positions.

RELATED LINKS
Lengthening/Shortening pedal lines on page 781
Sustain pedal lines in Engrave mode on page 772

Changing the position of pedal lines relative to grace notes
individually

You can change the start/end positions of individual pedal lines relative to grace notes,
independently of your project-wide settings.

PROCEDURE

1. Select the pedal lines whose position relative to grace notes you want to change. You can
do this in Write mode and Engrave mode.

2. In the Properties panel, activate any of the following properties in the Pedal Lines group:

● Starts before grace notes

● Ends before grace notes

3. Activate/Deactivate the corresponding checkboxes.

RESULT
When the checkboxes are activated, the corresponding parts of the selected pedal lines are
positioned before grace notes.
When the checkboxes are deactivated, the corresponding parts of the selected pedal lines are
positioned after grace notes.

TIP

● You can adjust the precise position of pedal lines in further detail in Engrave mode.

● You can change the position of all pedal lines relative to grace notes project-wide on the
Pedal Lines page in Engrave > Engraving Options.

EXAMPLE

Pedal line starting/ending before grace notes Pedal line starting/ending after grace notes

RELATED LINKS
Project-wide engraving options for pedal lines on page 781
Moving pedal lines graphically on page 779
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Lengthening/Shortening pedal lines
You can lengthen/shorten pedal lines rhythmically after they have been input.

PROCEDURE

1. In Write mode, select the pedal lines you want to lengthen/shorten.

NOTE

When using the mouse, you can only lengthen/shorten one pedal line at a time.

2. Lengthen/Shorten the pedal lines in any of the following ways:

● To lengthen them by the current rhythmic grid value, press Shift-Alt-Right Arrow.

● To shorten them by the current rhythmic grid value, press Shift-Alt-Left Arrow.

● To snap the end of a single pedal line to the next notehead, press Ctrl/Cmd-Shift-
Alt-Right Arrow.

● To snap the end of a single pedal line to the previous notehead, press Ctrl/Cmd-
Shift-Alt-Left Arrow.

NOTE

● You can only lengthen/shorten pedal lines according to the current rhythmic
grid value when multiple pedal lines are selected.

● When using the keyboard, you can only move the end of pedal lines. You can
move the start of pedal lines by moving the whole line, or by clicking and
dragging the start handle.

● Click and drag the circular handle at the start/end to the right/left.

RESULT
Single pedal lines are lengthened/shortened according to the current rhythmic grid value or to
the next/previous notehead, whichever is closer.
Multiple pedal lines are lengthened/shortened according to the current rhythmic grid value.

TIP

You can move pedal lines graphically in Engrave mode, including changing their graphical length.

RELATED LINKS
Positions of pedal lines on page 777
Moving pedal lines rhythmically on page 778
Moving pedal lines graphically on page 779

Project-wide engraving options for pedal lines
You can find options for the project-wide appearance and position of pedal lines on the Pedal
Lines page in Engrave > Engraving Options.

The options on the Pedal Lines page allow you to change the symbol shown at the start of each
type of pedal line, the appearance of pedal line symbols on subsequent systems, the appearance
of pedal continuation lines, and the width of retake notches. You can also set precise values for
the gaps between pedal lines and the staff or other objects.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.
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RELATED LINKS
Engraving Options dialog on page 299

Pedal line start signs, hooks, and continuation lines
Pedal lines normally comprise a start sign, a continuation line, and an end hook. This indicates
clearly to performers where to depress each type of pedal, how long to keep it depressed, and
where to lift it.

In Dorico Pro, you can change the appearance of each part of pedal lines both individually and
for all pedal lines project-wide. For example, you can show all pedal lines with a glyph as their
start sign, but change the start sign of an individual pedal line to show text instead.

You can select any whole pedal line in Write mode and change most aspects of their appearance
according to the type of pedal line, such as their continuation line or start sign.

For sustain pedals only, you can select each segment of a sustain pedal independently in Engrave
mode, and set different properties for each segment. Sustain pedal lines have independent
segments on each separate system on which they appear.

TIP

If you are changing the appearance of many pedal lines, it might be easier to change the
corresponding project-wide settings on the Pedal Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for pedal lines on page 781
Sustain pedal lines in Engrave mode on page 772

Changing the start sign appearance of pedal lines
You can change the appearance of the start of pedal lines individually, independently of your
project-wide settings. Pedal line start signs can be shown as variations of the traditional pedal
line glyph, other symbols, or text.

PROCEDURE

1. Select the pedal lines whose start sign appearance you want to change. You can do this in
Write mode and Engrave mode.

NOTE

The pedal lines you select must be the same type, for example, only sustain pedal lines.

2. In the Properties panel, activate Sign appearance in the Pedal Lines group.

3. Select one of the options from the menu.
The options are different according to the type of pedal line selected.

RESULT
The start sign appearance of the selected pedal lines is changed.

TIP

● Deactivating Sign appearance returns the selected pedal lines to your default setting for
start sign appearance.

● You can change the default start sign appearance of all pedal lines project-wide on the
Pedal Lines page in Engrave > Engraving Options.
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RELATED LINKS
Project-wide engraving options for pedal lines on page 781

Changing the type of hook at the start/end of pedal lines
You can change the type of hook shown at the start/end of pedal lines individually.

NOTE

You can only change the start hook type of pedal lines that have a hook as their start sign, and
you can only change the end hook type of pedal lines that have a continuation line.

PROCEDURE

1. Select the pedal lines whose hook type you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate the following properties, individually or together, in the
Pedal Lines group:

● Line start hook

● Line end hook

3. Select one of the following options from each menu:

● No Hook

● Vertical Hook

● Slant Hook

● Inverse Hook

RESULT
The hook type at the start/end of the selected pedal lines is changed.

TIP

You can change the default appearance of all pedal lines project-wide on the Pedal Lines page in
Engrave > Engraving Options.

Lengthening/Shortening pedal line hooks
You can change the length of hooks shown at the start/end of pedal lines individually,
independently of each other and independently of your project-wide settings.

For example, if you have a pedal line with a hook at the start/end, you can make the end hook
longer without changing the length of the start hook.

NOTE

This only applies to pedal lines that have a hook as their start sign and/or end sign.

PROCEDURE

1. In Engrave mode, select the top handle at the start/end of the pedal lines whose hooks
you want to lengthen/shorten.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
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2. Move the handles in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

● Click and drag them upwards/downwards.

RESULT
The length of the selected pedal line hooks is changed.

TIP

● The following properties in the Pedal Lines group of the Properties panel are activated
automatically when you move the corresponding pedal line hook:

● Start hook length changes the length of hooks at the start of pedal lines.

● End hook length changes the length of hooks at the end of pedal lines.

You can also use these properties to lengthen/shorten pedal line hooks by changing the
values in the value fields.

Deactivating the properties resets the selected pedal lines to their default hook length.

● You can change the default hook length for all pedal lines project-wide by changing the
value for Hook length in the Design section of the Pedal Lines page in Engrave >
Engraving Options. This value applies to hooks at the start/end of pedal lines.

Changing the continuation line type of pedal lines
You can change the type of continuation line used for the different types of pedal lines
individually, independently of your project-wide settings.

PROCEDURE

1. Select the pedal lines whose continuation line type you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Continuation type in the Pedal Lines group.

3. Select one of the following continuation types from the menu:

● Line

● Sign at End

● Sign at End and Dashed Line

● None

RESULT
The continuation line type of the selected pedal lines is changed.

TIP

You can change the continuation type for all pedal lines project-wide on the Pedal Lines page in
Engrave > Engraving Options. You can choose different continuation types for each pedal type,
for example, you can have a line for sustain pedal lines and just a sign at the end for una corda
pedal lines.

Pedal lines
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Lengthening/Shortening gaps and dashes in pedal continuation lines
You can change the length of dashes and the gaps between dashes in individual dashed pedal
continuation lines, independently of your project-wide settings.

NOTE

This only applies to pedal lines with dashed continuation lines.

PROCEDURE

1. In Engrave mode, select the pedal lines whose dashes you want to change.

2. In the Properties panel, activate the following properties, individually or together, in the
Pedal Lines group.

● Dash length

● Dash gap length

3. Change the values in the value fields.

RESULT
Increasing Dash length makes dashes in pedal continuation lines longer, decreasing the value
makes dashes shorter.
Increasing Dash gap length makes gaps between dashes in pedal continuation lines longer,
decreasing the value makes gaps shorter.

TIP

You can find options that change the default dash length and default gap length for all dashed
pedal continuation lines project-wide by clicking Advanced Options in the Design section of the
Pedal Lines page in Engrave > Engraving Options.

Changing the line width of pedal lines
You can change the thickness of continuation lines individually, independently of your project-
wide settings.

PROCEDURE

1. In Engrave mode, select the pedal lines whose continuation line thickness you want to
change.

2. In the Properties panel, activate Line width in the Pedal Lines group.
The value resets to 0 automatically when you first activate the property.

3. Change the value in the value field.

RESULT
Increasing Line width makes pedal continuation lines thicker, decreasing the value makes pedal
continuation lines thinner.

TIP

You can change the default thickness for all pedal continuation lines project-wide in the Design
section of the Pedal Lines page in Engrave > Engraving Options.
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Parenthesizing pedal line continuation signs
You can show individual pedal line continuation signs with/without parentheses, independently
of your project-wide setting. Pedal line continuation signs are shown by default at the start of
new systems when pedal lines continue across system breaks.

PROCEDURE

1. Select the pedal lines whose continuation sign appearance you want to change. You can do
this in Write mode and Engrave mode.

2. In the Properties panel, activate Show continuation sign in parentheses in the Pedal
Lines group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
Continuation signs are shown with parentheses when the checkbox is activated, and without
parentheses when the checkbox is deactivated.
When the property is deactivated, pedal lines follow your project-wide setting.

TIP

You can change the default appearance of all pedal line continuation signs project-wide in the
Design section of the Pedal Lines page in Engrave > Engraving Options.

Pedal line start, continuation, and restorative text
All types of pedal lines can have text as their start signs, instead of glyphs or hooks. You can
override the text shown at the start of pedal lines that have text start signs, you can change the
continuation text shown at the start of new systems, and you can override the restorative text
shown at the end of una corda pedal lines.

You can change the design of all pedal lines project-wide according to their type in the Design
section of the Pedal Lines page in Engraving Options, and you can change the appearance of
individual pedal lines, independently of your project-wide settings.

Pedal lines that use a text indication rather than a symbol

For pedal lines such as una corda or sustain that have text for their start sign, such as Ped. Text,
rather than the more ornate symbol, you can override the text shown at the start of the pedal
line and replace it with your preferred performance direction.

Continuation sign/text

When pedal lines continue onto a new system, a continuation sign/text is shown in parentheses
by default. If the pedal line is using text for their start sign, such as Ped. Text, rather than a
symbol, you can change the text shown at the start of a new system and replace it with your
preferred performance direction.

Una corda pedal lines

The equivalent to the final pedal lift for the una corda pedal marking is the indication to return to
tre corde. You can override the tre corde text shown at the end of the pedal line and replace it with
your preferred performance direction.

Pedal lines
Pedal line start, continuation, and restorative text 

786
Dorico 2.2.20



Changing the start text shown in pedal lines
You can change the text shown at the start of individual pedal lines that use text as their start
sign.

PROCEDURE

1. Select the pedal lines whose start text you want to override. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Text in the Pedal Lines group.

3. Enter the text you want into the value field.

4. Press Return.

RESULT
The text shown at the start of the selected pedal lines is changed.
Deactivating Text restores the default start text for the selected pedal lines.

NOTE

Deactivating properties permanently deletes any custom text entered.

Changing the pedal line continuation text shown
You can change the text shown at the start of new systems when pedal lines cross system
breaks.

NOTE

This only applies to pedal lines that use text as their start sign.

PROCEDURE

1. Select the pedal lines whose continuation text you want to override. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Continuation text in the Pedal Lines group.

3. Enter the text you want into the value field.

4. Press Return.

RESULT
The continuation text shown at the start of new systems for the selected pedal lines is changed.
Deactivating Continuation text restores the default continuation text for the selected pedal
lines.

NOTE

Deactivating properties permanently deletes any custom text entered.
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Changing the restorative text shown in una corda pedal lines
The equivalent to the final pedal lift for una corda pedal lines is the indication to return to tre
corde. You can change the tre corde text shown at the end of individual una corda pedal lines.

NOTE

This only applies to una corda pedal lines that use text as their start sign.

PROCEDURE

1. Select the una corda pedal lines whose restorative text you want to override. You can do
this in Write mode and Engrave mode.

2. In the Properties panel, activate Restorative text in the Pedal Lines group.

3. Enter the text you want into the value field.

4. Press Return.

RESULT
The restorative text shown at the ends of the selected una corda pedal lines is changed.
Deactivating Restorative text restores the default restorative text for the selected pedal lines.

NOTE

Deactivating properties permanently deletes any custom text entered.

Pedal lines in playback
Pedal lines are automatically played back in Dorico Pro.

The three piano pedals send MIDI controllers as follows:

● Sustain pedal lines send MIDI controller 64 (Sustain).

● Sostenuto pedal lines send MIDI controller 66 (Sostenuto).

● Una corda pedal lines send MIDI controller 67 (Soft Pedal).

Some piano VST instruments, such as Pianoteq and Garritan CFX Concert Grand, support partial
depression of the sustain pedal. Consult the manufacturer’s documentation for more
information.

Playback Options

You can find options for how Dorico Pro plays back pedaling on the Pedal Lines page in Play >
Playback Options.

You can control the following parameters of pedal line playback:

● The length of the initial pedal depression

● The length of a retake in the middle of a pedal line

● The length of the final pedal release

● Whether initial depressions and retakes are played before or after the onset of the notes
or chords at their rhythmic positions

RELATED LINKS
Playback Options dialog on page 405
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Pedal lines imported from MusicXML files
Sustain pedal lines can be imported from MusicXML files. MusicXML can only describe the sustain
pedal, and it cannot describe changes in pedal depression level.
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The term “playing techniques” covers a wide range of instructions intended to tell performers to
modify the sound of the notes they are playing, for example, by changing their embouchure or
changing the position of their bow, or by modifying their instrument, such as adding a mute or
depressing a pedal.

In Dorico Pro, playing techniques can be expressed as symbols or as text. All available playing
techniques can be found in the Playing Techniques panel in Write mode, organized by
instrument family. For example, you can find pedal lines in the Keyboard section of the Playing
Techniques panel.

NOTE

Because pedal lines have additional, unique requirements that do not apply to other playing
techniques, such as retakes, start signs, and continuation lines, they are documented separately.
Pedal lines also have their own group in the Properties panel that is separate from the Playing
Techniques group.

Adding playing techniques can change how the instrument plays back. For example, adding
pizzicato to a violin staff activates a key switch that changes the sound produced by the VST
instrument.

Some of the playing techniques in Dorico Pro

RELATED LINKS
Input methods for playing techniques and pedal lines on page 238
Playing techniques in playback on page 803
Pedal lines on page 771

Project-wide engraving options for playing techniques
You can find options for the project-wide appearance and position of playing techniques on the
Playing Techniques page in Engrave > Engraving Options.

The options on the Playing Techniques page allow you to change the distance between playing
techniques and the staff, the arrangement of multiple text playing techniques at the same
rhythmic position, the default horizontal offset of text playing techniques, and playing technique
continuation styles.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

Playing techniques
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RELATED LINKS
Engraving Options dialog on page 299

Positions of playing techniques
Playing techniques, both as text and symbols, are placed above the staff. On vocal staves, they
are placed above the staff and below dynamics. In multiple-voice contexts, playing techniques for
the up-stem voices are placed above the staff and playing techniques for the down-stem voices
are placed below the staff.

Placement of playing techniques with two voices on the same staff

Playing technique texts use a plain font, neither bold nor italic, so they are not confused with
expressive text and dynamics.

NOTE

This does not apply to pedal lines, as they use a separate font style to other playing techniques.

You can move playing techniques to different rhythmic positions in Write mode. They are
positioned by default according to your settings in Engraving Options.

You can move playing techniques graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached.

You can change the default positions of all playing techniques project-wide on the Playing
Techniques page in Engrave > Engraving Options.

RELATED LINKS
Pedal line start, continuation, and restorative text on page 786
Project-wide engraving options for playing techniques on page 790
Moving playing techniques graphically on page 792

Moving playing techniques rhythmically
You can move playing techniques to new rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the playing techniques you want to move.

NOTE

When using the mouse, you can only move one playing technique rhythmically at a time.

2. Move the playing techniques in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the playing technique to the right/left to the notehead you want.
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RESULT
A single playing technique is moved to the next or previous notehead on that staff.
Multiple playing techniques are moved according to the current rhythmic grid value.

RELATED LINKS
Moving pedal lines rhythmically on page 778

Moving playing techniques graphically
You can move playing techniques graphically without changing the rhythmic positions to which
they apply.

NOTE

These steps do not apply to pedal lines.

PROCEDURE

1. In Engrave mode, select the playing techniques you want to move.

2. Move the playing techniques in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected playing techniques are moved to new graphical positions.

TIP

Start offset in the Playing Techniques group of the Properties panel is activated automatically
when you move playing techniques.

● Start offset X moves playing techniques horizontally.

● Start offset Y moves playing techniques vertically.

You can also use this property to move playing techniques by changing the values in the value
fields.

Deactivating the property resets the selected playing techniques to their default positions.

RELATED LINKS
Moving pedal lines graphically on page 779
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Changing the placement of playing techniques relative to the staff
You can change the placement of individual playing techniques relative to the staff.

NOTE

These steps do not apply to pedal lines.

PROCEDURE

1. Select the playing techniques whose staff-relative placement you want to change. You can
do this in Write mode and Engrave mode.

2. In the Properties panel, activate Placement in the Playing Techniques group.

3. Choose one of the following options:

● Above

● Below

RESULT
The selected playing techniques appear above/below the staff.

RELATED LINKS
Moving pedal lines graphically on page 779

Adding text to playing techniques
You can add text above or alongside playing techniques after they have been input, for example,
to clarify the intention of the playing technique.

NOTE

These steps do not apply to pedal lines.

PROCEDURE

1. Select the playing techniques to which you want to add text. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Alternative text in the Playing Techniques group.

3. Enter the text you want into the value field.

4. Press Return.

RESULT
The text you entered into the value field is shown directly after text playing techniques, and
directly above symbol playing techniques.
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EXAMPLE

Alternative text added to text playing technique Alternative text added to symbol playing technique

RELATED LINKS
Pedal line start, continuation, and restorative text on page 786

Erasing the background of text playing techniques
You can erase the background of individual text playing techniques, for example, to ensure they
remain legible when crossing barlines.

PROCEDURE

1. In Engrave mode, select the playing techniques whose backgrounds you want to erase.

2. In the Properties panel, activate Erase background in the Playing Techniques group.

RESULT
The backgrounds of the selected playing techniques erase whatever is behind them, creating a
blank area around each playing technique.
Deactivating Erase background returns the selected playing techniques to the default non-
erased background.

EXAMPLE

Text playing technique with non-erased background Text playing technique with erased background

AFTER COMPLETING THIS TASK
You can change the padding between playing techniques and each edge of their erased areas.

Changing the erasure padding of text playing techniques
You can change the erasure padding of individual playing techniques, including changing the
padding between playing techniques and each edge of their erased areas independently.

PROCEDURE

1. In Engrave mode, select the text playing techniques whose erasure padding you want to
change.

2. In the Properties panel, activate the Erasure padding properties, individually or together,
in the Playing Techniques group.

● L changes the padding between playing techniques and their left edge.
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● R changes the padding between playing techniques and their right edge.

● T changes the padding between playing techniques and their top edge.

● B changes the padding between playing techniques and their bottom edge.

3. Change the values in the value fields.

RESULT
Increasing the values increases the padding, decreasing the values decreases the padding.

TIP

You can change the default erasure padding of all playing techniques project-wide in the Design
section of the Playing Techniques page in Engrave > Engraving Options. However, this does
not allow you to change the padding of each edge independently.

Hiding/Showing playing techniques
You can hide/show playing techniques individually, for example, if your expression map requires
you to input a playing technique to trigger the correct playback but you do not want that
technique to appear in the music.

PROCEDURE

1. Select the playing techniques you want to hide or the signposts of hidden playing
techniques you want to show. You can do this in Write mode and Engrave mode.

2. In the Properties panel, activate/deactivate Hidden in the Playing Techniques group.

RESULT
The selected playing techniques are hidden when Hidden is activated, and shown when it is
deactivated.
Signposts are shown at the positions of each hidden playing technique, so you can always find
them again. However, signposts are not printed by default.

TIP

● If you do not want to show playing technique signposts, choose View > Signposts >
Playing Techniques. Playing technique signposts are shown when a tick appears beside
Playing Techniques in the menu, and hidden when no tick appears.

● You can assign a key command for Hide/Show Item on the Key Commands page in
Preferences, which applies to chord symbols, playing techniques, and time signatures.

RELATED LINKS
Expression maps on page 451
Signposts on page 281

Custom playing techniques
Custom playing techniques allow you to represent any playing technique in any way you want,
for example, if the default glyph used for a particular playing technique is not the one to which
you or the players reading the music are accustomed.

As well as designing the appearance of custom playing techniques using existing glyphs, text,
and your own graphics, you can define how they should affect playback.

You can create and edit custom playing techniques in the Edit Playing Techniques dialog and its
related dialogs. You can find your custom playing techniques in their assigned category in the
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Playing Techniques panel in Write mode. You can also input them using the popover by entering
the popover text assigned to them.

RELATED LINKS
Playing techniques in playback on page 803
Input methods for playing techniques and pedal lines on page 238

Edit Playing Techniques dialog
The Edit Playing Techniques dialog allows you to add, edit, and delete custom playing
techniques. It also allows you to change various settings relating to the appearance and function
of all playing techniques in the project.

● You can open the Edit Playing Techniques dialog in Engrave mode by choosing Engrave >
Playing Techniques, or by clicking Add Playing Technique in the action bar of any section
in the Playing Techniques panel in Write mode.
You can also open it for a specific playing technique by selecting that playing technique in
the Playing Techniques panel in Write mode and clicking Edit Playing Technique in the
action bar for that section.

Edit Playing Techniques dialog

The Edit Playing Techniques dialog contains the following sections and options:

1 Category menu
Allows you to filter the list of playing techniques by selecting a category from the menu,
such as String or Choral. This corresponds to the titles of sections in the Playing
Techniques panel.

2 List of playing techniques
Contains all the playing techniques in the project within the currently selected category.
The action bar at the bottom of the list contains the following options:
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● New

Adds a new blank playing technique.

● New from Selection

Adds a new playing technique that is a duplicate of the playing technique currently
selected.

● Save as Default

Saves the currently selected playing technique as a default in your user library,
allowing you to use it in multiple projects.

● Revert to Factory

Removes all edits you have made to the selected predefined playing technique,
returning it to its original settings and appearance.

● Delete

Deletes the selected playing technique.

NOTE

You cannot delete predefined playing techniques or any playing technique that is
currently used in your project.

3 Name
Allows you to enter a new name or edit the existing name for the selected playing
technique.

4 Preview
Displays the playing technique in its current form. If the playing technique is set to appear
the same both above and below the staff, a single preview area is shown. If the playing
technique is set to appear differently according to its staff-relative placement, the preview
is split to show both possible appearances.
Clicking Edit Composite in the action bar below the preview opens the Edit Playing
Technique dialog, where you can edit the appearance of the playing technique. This
button is only available for Glyph playing techniques.

5 Playing technique options
You can change the following options relating to the appearance and function of the
selected playing technique:

● Category
Allows you to select an instrument family category for the selected playing
technique, for example, if you duplicated a String technique but want to save your
new playing technique in the Wind category.

● Type
Allows you to choose whether the playing technique is a Glyph or Text. This affects
how the technique appears in the preview.
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If you select Text, a Text field appears beside the Type menu. You can enter any text
into the field, and select any font style from the menu beside the field. The playing
technique appears on the left of the preview.
If you select Glyph, the playing technique appears in the middle of the preview.
Selecting Glyph also allows you to edit the playing technique in the Edit Playing
Technique dialog.

● Default placement
Allows you to choose whether the playing technique is placed Above or Below the
staff by default.

● Appearance
Allows you to choose whether the playing technique appears the same on either
side of the staff, or whether it has a different appearance on each side. If you
choose Different above and below, you can edit each appearance independently.

● Popover text
Allows you to set the text you want to enter into the popover to input the playing
technique.

● Playback playing technique
Allows you to choose the playback playing technique for the playing technique, that
is, the action that changes the sample sound used.

● Duration
Allows you to set whether the playing technique Has duration, and can appear
across a range of notes, or Has no duration, and can only appear at one rhythmic
position.

NOTE

This only affects the visual duration of the playing technique. You can also change
the playback duration of a playing technique in the Edit Playback Playing
Techniques dialog.

● Shown in Cues
Allows you to choose whether the playing technique appears in cues when playing
techniques are shown in cues.

RELATED LINKS
Edit Playback Playing Techniques dialog on page 801
Playing Techniques panel on page 241

Edit Playing Technique dialog
The Edit Playing Technique dialog allows you to design custom playing techniques and edit the
appearance and arrangement of playing techniques.

● You can open the Edit Playing Technique dialog from within the Edit Playing Techniques
dialog by selecting the playing technique whose design you want to edit from the list and
clicking Edit Composite in the action bar below the preview. Its Type must be set to Glyph
in order for you to do this.
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Edit Playing Technique dialog

The Edit Playing Technique dialog contains the following sections and options:

1 Name
Contains the saved name for predefined playing techniques, or an automatically
generated name for new playing techniques. You cannot change this name.

2 Component selector
Allows you to choose components to add to the playing technique. You can add different
types of components by clicking the respective tab titles.

● Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting
different fonts and different ranges from the menus. Click Add Glyph to add the
selected glyph to the playing technique.

NOTE

A full list of the different ranges of glyphs is available on the SMuFL website.

● Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected
text, or input text, to the playing technique.

● Graphic: Allows you to load a new graphic file, or select an existing graphic from the
Select existing list, in SVG, PNG, or JPG format. You can see a preview of the graphic
in the Preview box. Click Add Graphic to add the selected graphic to the playing
technique.

● Composite: Allows you to select a composite from the list. Click Add Composite to
add the selected composite to the playing technique.

3 Editor
Allows you to arrange and edit the components that make up the playing technique. You
can arrange and edit components by clicking and dragging them in the editor and by
using the controls at the bottom of the dialog. You can also use the handles on each
component to change their size.
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4 Editor action bar
Contains selection and view options for the editor.

● Zoom
Allows you to change the zoom level in the editor.

● Select
Allows you to select the next/previous component.

● Show Attachments

Shows all the attachments on all components in the editor.

● Delete

Deletes the selected component.

5 Controls
Contains controls that allow you to edit individual components. Controls are divided into
tabs according to the aspect of the selected component they affect. For playing
techniques, only the Component and Attachments tabs are available as the other tabs do
not apply to playing techniques.
The Component tab contains the following options:

● Offset: Controls the position of the selected component. X moves it horizontally, Y
moves it vertically.

● Scale: Controls the size of the selected component. For graphics, X controls its
width, Y controls its height.

NOTE

Although some components scale their height and width independently, others
retain their aspect ratio, meaning only one value affects their overall size.

● Z order: Allows you to Bring Forward or Send Backward the selected component in
relation to other components when they overlap.

The Attachments tab is only available if the playing technique comprises at least two
separate components. It contains the following options:

● Attachment from: Sets the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend
that you select a right edge attachment point for Attachment from.

● Attachment to: Sets the attachment point on the selected component which
attaches to the component to its left. We recommend that you select a left edge
attachment point for Attachment to.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.

The attachment points have the following names in the Edit Playing Technique dialog:
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1 Top Left

2 Top Center

3 Top Right

4 Middle Left

5 Middle Right

6 Baseline Left (text only)

7 Baseline Center (text only)

8 Baseline Right (text only)

9 Bottom Left

10 Bottom Center

11 Bottom Right

RELATED LINKS
Edit Playing Techniques dialog on page 796

Edit Playback Playing Techniques dialog
The Edit Playback Playing Techniques dialog allows you to define new playback playing
techniques and edit existing ones, for example, to create a new playback playing technique with
the correct playback settings for a new custom playing technique you have designed.

● You can open the Edit Playback Playing Techniques dialog by clicking Edit beside
Playback playing technique in the Edit Playing Techniques dialog.

Edit Playback Playing Techniques dialog
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The Edit Playback Playing Techniques dialog contains the following sections and options:

1 Category menu
Allows you to filter the list of playback playing techniques by selecting a category from the
menu, such as Techniques or Dynamics.

2 List of playback playing techniques
Contains all the playback playing techniques in the project within the currently selected
category.
The action bar at the bottom of the list contains the following options:

● New

Adds a new blank playback playing technique.

● New from Selection

Adds a new playback playing technique that is a duplicate of the playback playing
technique currently selected.

● Save as Default

Saves the currently selected playback playing technique as the default, allowing you
to use it in multiple projects.

● Revert to Factory

Removes all edits you have made to the selected predefined playback playing
technique, returning it to its original settings.

● Delete

Deletes the selected playback playing technique.

NOTE

You cannot delete predefined playing techniques or any playing technique that is
currently used in your project.

3 Name
Allows you to edit or enter the name of the playback playing technique. This is the name
shown in lists in the Edit Playing Techniques, Expression Maps, and Percussion Maps
dialogs.

4 Playback options

● Alias for: Allows you to specify another playback playing technique that is
equivalent to the present one.

● Group: Sets the group in which this playback playing technique appears.

● Fallback: Allows you to specify another playback playing technique that can be used
if the present playing technique is not available.

● Articulation type: Sets the duration over which the playback playing technique
takes effect. Attribute applies only to the note at the rhythmic position where the
playing technique is found, such as a staccato articulation, while Direction applies
to all following notes until it is replaced by another playing technique, such as
pizzicato.
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RELATED LINKS
Edit Playing Techniques dialog on page 796
Edit Playing Technique dialog on page 798

Using custom playing techniques in multiple projects
By default, custom playing techniques are only available in the project in which you created
them. You can save them as default to use them in multiple projects.

PROCEDURE

1. In Engrave mode, choose Engrave > Playing Techniques to open the Edit Playing
Techniques dialog.

2. In the list on the left of the dialog, select the playing technique you want to use in multiple
projects.

3. Click Save as Default in the action bar.

4. Click OK to save your changes and close the dialog.

RESULT
The selected playing technique is saved as your default and can be used in all projects.

RELATED LINKS
Custom playing techniques on page 795
Edit Playing Techniques dialog on page 796

Playing techniques in playback
Each playing technique you can create in Write mode corresponds to a technique that you can
map in the Expression Maps dialog.

● You can open the Expression Maps dialog in Play mode by choosing Play > Expression
Maps.

In the Techniques section of the dialog, you can edit existing techniques. You can also create
new combinations of playing techniques in the Technique Combinations dialog. For example,
you can combine Pizzicato and Tremolo to allow the pizzicato and tremolo techniques to be
applied to the same note simultaneously.

When you input a playing technique in Write mode, the expression map looks for that playing
technique. If it cannot be found, the playing technique applied either remains the same as the
previous technique or reverts to the natural technique.

Custom playing techniques that use playback playing techniques that do not already exist in
expression maps do not play back automatically. In order for them to play back appropriately,
you must add them to the expression maps for each instrument for which you want to use them.
You must also assign an action for each custom playing technique that determines how the
switch required to execute the technique is controlled.

You can see which playing techniques are being applied in the Playing Techniques lane, which
you can show by expanding individual instruments in Play mode.

TIP

If you have input a playing technique but cannot hear a change in the sound, that could be
because you are using a combination of playing techniques that the expression map does not
expect. For example, if you input a new playing technique without cancelling an existing playing
technique, the expression map cannot process the two playing techniques together if the
expression map does not have an entry for those two techniques combined.

Playing techniques
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To avoid playing technique clashes, input a “naturale”, or “nat.”, playing technique to return the
software instrument to its natural state. You can then input new playing techniques without
clashes.

RELATED LINKS
Expression Maps dialog on page 452
Technique Combinations dialog on page 456
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Rehearsal marks are an ordered sequence of letters or numbers, which along with bar numbers,
provide a reference point for music that has multiple players, and make the chronological
sequence of the music clear.

They tell performers where they are in the piece, and allow performers to orient and co-ordinate
themselves easily in rehearsals and concerts. Rehearsal marks can also be used to indicate
significant changes in the music, and you can freely decide their positions.

They can also be useful when preparing parts and scores, as you can use rehearsal marks and
bar numbers to compare quickly a part to the score and check it is correct. In Dorico Pro,
rehearsal marks follow an automatic sequence, ensuring there are never duplicate rehearsal
marks.

In Dorico Pro, rehearsal marks are categorized as system objects. Therefore, rehearsal marks
follow your per-layout settings for the visibility and positioning of system objects, which you can
change on the Staves and Systems page in Setup > Layout Options.

RELATED LINKS
Inputting rehearsal marks on page 249
System objects on page 925
Changing the positions of system objects on page 926

General placement conventions for rehearsal marks
Rehearsal marks should be at noticeable positions in the score so they can be seen easily. They
should use a large, non-italic bold font, and be positioned above the system and outside the
music.

Rehearsal marks should be positioned above barlines, and not below the system. Although you
can input rehearsal marks at rhythmic positions within a bar in Dorico Pro, this is not common
practice. Depending on the style of music and the context, it can be helpful to input a double
barline beneath each rehearsal mark.

In order to ensure they are easily noticeable, and cannot be confused with bar numbers if you
are using numbers for rehearsal marks, rehearsal marks should be shown in an enclosure. You
can change the shape and size of rehearsal mark enclosures.

The placement of rehearsal marks relative to the music is discretionary, but they are most helpful
to players when they coincide with a change in the music, such as a tempo change or a change in
texture. They are also helpful when placed at a point in the music where players are likely to start

Rehearsal marks
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from in order to rehearse a specific section, such as a significant solo entry or the start of a
difficult passage.

In general, it is good practice to place rehearsal marks at regular intervals as well as at significant
moments. It is often recommended to have rehearsal marks every 5-20 bars to reduce the
amount of bars players need to count before or after a rehearsal mark.

If a rehearsal mark coincides with a tempo change, you should position the tempo text to the
right of the rehearsal mark. However, if space is tight, the text can be positioned above or below
the rehearsal mark. The position of the rehearsal mark should remain clear, so it should not be
moved away from the barline to which it applies, otherwise its position can be misunderstood.
Dorico Pro automatically adjusts staff spacing to ensure rehearsal marks are correctly positioned.

The vertical spacing between the top two staves is increased to allow room for the rehearsal mark and the
tempo marks.

RELATED LINKS
Inputting rehearsal marks on page 249
Input methods for bars and barlines on page 201
Changing the rehearsal mark enclosure type on page 806

Project-wide engraving options for rehearsal marks
You can find options for the project-wide appearance and position of rehearsal marks on the
Rehearsal Marks page in Engrave > Engraving Options.

For example, you can change the sequence type of rehearsal marks, their default positions, and
whether they are shown in enclosures.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299
Rehearsal mark enclosure size and padding values on page 807

Changing the rehearsal mark enclosure type
Rehearsal marks are usually shown in an enclosure, which can be a rectangle or a circle. You can
change the enclosure type of all rehearsal marks project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Rehearsal Marks in the page list.

3. In the Enclosure section, choose one of the following options for Enclosure type:

Rehearsal marks
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● Rectangle

● Circle

● No enclosure

RESULT
The enclosure type of all rehearsal marks in your project is changed. The default size of the
enclosure is relative to the font size of the rehearsal marks, but your padding values also
determine the size and shape of the enclosure.

EXAMPLE

Rehearsal mark with a rectangle
enclosure

Rehearsal mark with a circle
enclosure

Rehearsal mark with no enclosure

Rehearsal mark enclosure size and padding values
You can change the default shape and size of rehearsal mark enclosures on the Rehearsal
Marks page in Engraving Options. You can change the minimum dimensions, line thickness,
and padding values of rehearsal mark enclosures.

All enclosures

Enclosure line thickness
Sets the thickness of enclosure lines for both rectangle and circle enclosures. The
default is 1/8 of a space. The examples have a thickness of 1/2 a space.

Rectangle rehearsal mark enclosure

The figure shows a rectangle rehearsal mark enclosure with default settings. The minimum
height and minimum width are both 4 spaces, horizontal padding is 3/4 of a space, and
minimum bottom and minimum top padding are both 1/8 of a space.

Minimum width
Sets a minimum value for the width of enclosures. In this example, the value was
increased from 4 spaces to 8 spaces.
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Minimum height
Sets a minimum value for the height of enclosures. In this example, the value was
increased from 4 spaces to 8 spaces.

Left and right padding between text and enclosure
Sets the value for the distance between the two sides of the enclosure and the
rehearsal mark within it. In this example, the value was increased from 3/4 of a space
to 3 spaces.

Top padding between text and enclosure
Sets the value for the distance between the top line of the enclosure and the
rehearsal mark within it. In this example, the value was increased from 1/2 a space to
2 spaces.

Bottom padding between text and enclosure
Sets the value for the distance between the bottom line of the enclosure and the
rehearsal mark within it. In this example, the value was increased from 1/8 of a space
to 2 spaces.

Circle rehearsal mark enclosure

The figure shows a circle rehearsal mark enclosure with default settings. The minimum diameter
is 4 spaces, and the minimum padding is 1/4 of a space.

Minimum diameter
Sets a minimum value for the diameter of the enclosure. In this example, the value
was increased from 4 spaces to 8 spaces.

Rehearsal marks
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Minimum padding between text and enclosure
Sets the value for the distance between the enclosure line and the rehearsal mark
within it. In this example, the value was increased from 1/4 of a space to 2 spaces.

Positions of rehearsal marks
Rehearsal marks are placed above the staff and at the same positions as other system objects.

You can move rehearsal marks to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.

You can move rehearsal marks graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached.

You can change the default positions of all rehearsal marks project-wide, and set values for the
minimum distances between rehearsal marks and staves, and rehearsal marks and other items,
on the Rehearsal Marks page in Engrave > Engraving Options.

Rehearsal marks are categorized as system objects in Dorico Pro, which you can show above the
first bracket of selected instrument families. You can change the instrument families above which
system objects appear in each layout independently, if you want rehearsal marks to appear at
multiple vertical positions in each system in the full score only.

RELATED LINKS
Project-wide engraving options for rehearsal marks on page 806
Moving rehearsal marks graphically on page 810
Changing the positions of system objects on page 926

Moving rehearsal marks rhythmically
You can move rehearsal marks to new rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the rehearsal marks you want to move.

NOTE

When using the mouse, you can only move one rehearsal mark rhythmically at a time, and
you can only drag it to existing barlines.

2. Move the rehearsal marks in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the rehearsal mark to barlines to the right/left.

RESULT
A single rehearsal mark is moved to existing barlines to the right/left.
Multiple rehearsal marks are moved according to the current rhythmic grid value.

Rehearsal marks
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NOTE

Only one rehearsal mark can exist at each rhythmic position. If a rehearsal mark passes over
another rehearsal mark as part of its move, the existing rehearsal mark is deleted and replaced
by the rehearsal mark being moved.

You can undo this action, but any rehearsal marks deleted in the process are only restored if you
moved the rehearsal mark using the keyboard.

Moving rehearsal marks graphically
You can move rehearsal marks graphically, without changing the rhythmic positions to which
they are attached.

PROCEDURE

1. In Engrave mode, select the rehearsal marks you want to move.

2. Move the rehearsal marks in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The graphical positions of the selected rehearsal marks are changed.

TIP

Start offset in the Rehearsal Marks group of the Properties panel is activated automatically
when you move rehearsal marks.

● Start offset X moves rehearsal marks horizontally.

● Start offset Y moves rehearsal marks vertically.

You can also use this property to move rehearsal marks by changing the values in the value
fields.

Deactivating the property resets the selected rehearsal marks to their default positions.

Deleting rehearsal marks
You can delete rehearsal marks in full score and part layouts.

NOTE

Deleting a rehearsal mark in any layout deletes the rehearsal mark from all layouts.

PROCEDURE

1. In Write mode, select the rehearsal marks you want to delete.
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2. Press Backspace or Delete.

RESULT
The selected rehearsal marks are deleted. Any subsequent rehearsal marks are adjusted until the
next change in the sequence or the end of the flow. For example, if you delete the first rehearsal
mark, the second rehearsal mark shows either the letter A, the number 1, or the bar number,
depending on your choice of sequence type.

RELATED LINKS
Changing the rehearsal mark sequence type on page 811

Changing the order of rehearsal marks
By default, the rehearsal mark sequence resets at the start of each flow. If you want the
rehearsal mark sequence to continue across flows, for example, to avoid having multiple
rehearsal marks with the same letter in the same project, you can change the index position of a
rehearsal mark.

Changing the index position changes the shown number or letter. For example, index position 1
appears as rehearsal mark A or 1, position 2 appears as B or 2, and so on.

You can also change the index position of a rehearsal mark to avoid showing a letter that could
easily be confused with another letter or another number, such as I or O.

PROCEDURE

1. Select the rehearsal mark whose index position you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Index in the Rehearsal Marks group.

3. Change the value in the value field.

RESULT
The selected rehearsal mark changes according to the Index value and its sequence type.
Any subsequent rehearsal marks in the same sequence follow the new index automatically. For
example, if you changed a rehearsal mark from A to P, the next rehearsal mark changes from B
to Q.

NOTE

You can also change the sequence type of rehearsal marks, for example, if you want rehearsal
mark C to appear as rehearsal mark 3.

Changing the rehearsal mark sequence type
Rehearsal marks can be letters, numbers, or bar numbers. You can change the sequence type of
individual rehearsal marks, and create secondary rehearsal mark sequences.

In Dorico Pro, you can use all three available rehearsal mark sequences simultaneously. For
example, you can have the main sequence of rehearsal marks showing letters, but also have a
secondary sequence of numbers to mark different moments, perhaps entry points for a solo line,
and also highlight prominent bar numbers within those sections.

TIP

You can change the sequence type used for all rehearsal marks project-wide on the Rehearsal
Marks page in Engraving Options.
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PROCEDURE

1. Select the rehearsal mark whose sequence type you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Sequence type in the Rehearsal Marks group.

3. Select one of the following options from the menu:

● Letters

● Numbers

● Bar numbers

RESULT
The selected rehearsal mark now displays a letter, a number, or the current bar number.
If it is the first rehearsal mark in either the letters sequence or the numbers sequence in the flow,
it shows either A or 1. If there are already rehearsal marks in either the letters sequence or the
numbers sequence in the flow, it shows the next letter or number according to the index.

NOTE

You can change the index of a rehearsal mark sequence independently of other rehearsal mark
sequences. However, you cannot change the bar number sequence using this method.

RELATED LINKS
Project-wide engraving options for rehearsal marks on page 806
Adding bar number changes on page 531

Adding prefixes/suffixes to rehearsal marks
You can add both prefixes and suffixes to individual rehearsal marks.

PROCEDURE

1. Select the rehearsal marks to which you want to add a prefix or suffix. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate one of the following properties in the Rehearsal Marks
group:

● Prefix

● Suffix

3. Enter the text you want into the value field.

4. Press Return.

RESULT
The text you entered into the value field is added to the selected rehearsal marks as a prefix or a
suffix.

TIP

You can add a custom prefix/suffix to all rehearsal marks project-wide on the Rehearsal Marks
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for rehearsal marks on page 806
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Editing the rehearsal mark font style
You can edit the formatting of the font style used for all rehearsal marks project-wide.

PROCEDURE

1. In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2. Select Rehearsal Mark Font from the Font style menu.

3. Activate the following options, individually or together, to change the corresponding
aspect of the font:

● Font family

● Size

● Style

● Underlined

4. Click OK to save your changes and close the dialog.

RESULT
The formatting of the rehearsal mark font style is changed project-wide.

RELATED LINKS
Edit Font Styles dialog on page 364
Project-wide engraving options for rehearsal marks on page 806
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Markers are labels locked to a particular position in time, most commonly in relation to a video.
They typically indicate an important moment that requires musical prominence, and composers
often use them to help shape the writing process.

Markers on a timecode staff showing custom text and timecodes

By default, markers in Dorico Pro show the default text “Marker” and also include the timecode of
their fixed position in time.

In Dorico Pro, you can use markers in any project. However, because they are most commonly
used in conjunction with video, markers are included in the Video panel in Write mode. There is
also a Markers track in Play mode that displays markers, and allows you to input new ones.

You can use markers to help find suitable tempos for your project, as Dorico Pro can calculate
possible tempos between important markers so that the markers occur on strong beats in the
time signature.

Any markers you input are automatically included when you export MIDI.

RELATED LINKS
Inputting markers/timecodes on page 249
Changing the text shown in markers on page 815
Markers section of the Video panel on page 250
Markers track on page 427
Find Tempo dialog on page 251
Defining markers as important on page 818

Project-wide engraving options for markers
You can find options controlling the project-wide design, position, and appearance of markers on
the Markers page in Engrave > Engraving Options.

For example, you can change whether markers include the timecode of their position, whether
markers are shown above or below timecodes, the thickness of the enclosure line, and the
default vertical position of markers.

The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.

Markers
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RELATED LINKS
Engraving Options dialog on page 299

Changing the vertical position of markers
You can show markers above or below the system, and you can show them on a separate single-
line staff above a selected instrument family group.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the vertical position of
markers.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Markers in the page list.

4. Choose one of the following options for Vertical position:

● Above system

● Below system

● Timecode staff

5. Optional: If you chose Timecode staff, select the bracketed instrument family above which
you want to show the timecode staff from the Position timecode staff above bracket
menu.

6. Click Apply, then Close.

RESULT
The vertical position of markers is changed in the selected layouts.

NOTE

If you show markers on a timecode staff, timecodes are also shown on the staff by default. If you
only want to show markers on a separate staff and exclude timecodes, you must then change
Timecode frequency on timecode staff to Never.

RELATED LINKS
Changing the timecode frequency on page 821

Changing the text shown in markers
The default text shown in new markers is “Marker”. You can change the text shown in each
marker individually.

PROCEDURE

1. Select the markers whose text you want to change. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Marker text in the Markers group.

3. Enter the text you want.

4. Press Return.
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RESULT
The text shown in the selected markers is changed. It uses the Marker Text Font font style.

TIP

You can also enter custom text for markers when inputting them using the Add Marker dialog,
and change marker text in the Markers section of the Video panel in Write mode.

RELATED LINKS
Add Marker dialog on page 250
Markers section of the Video panel on page 250

Editing the marker/timecode font styles
You can edit the formatting of the font styles used for all markers and timecodes project-wide,
for example, if you want markers to appear bold and italic. Markers and timecodes use different
fonts, meaning you can change them independently of each other.

PROCEDURE

1. In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2. Select one of the following font styles from the Font style menu:

● Marker Text Font: Used for markers

● Marker Timecode Font: Used for timecodes

3. Activate the following options, individually or together, to change the corresponding
aspect of the font:

● Font family

● Size

● Style

● Underlined

4. Optional: If required, repeat steps 2 and 3 to change the other font.

5. Click OK to save your changes and close the dialog.

RESULT
The formatting of the selected font styles is changed project-wide.

RELATED LINKS
Edit Font Styles dialog on page 364

Moving markers rhythmically
You can move markers to new rhythmic positions. However, as markers have a fixed position in
time, moving markers relative to the notated music automatically changes the tempo on either
side of the marker.

TIP

If you want to move a marker to a new time position, for example, if you want to move it from 25
seconds to 28 seconds, you must change the timecode of the marker.
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PROCEDURE

1. In Write mode, select the marker you want to move.

NOTE

You can only move one marker at a time.

2. Move the marker according to the current rhythmic grid in any of the following ways:

● Press Alt-Right Arrow to move it to the right.

● Press Alt-Left Arrow to move it to the left.

● Click and drag it to the right/left.

RESULT
The selected marker is moved to a new rhythmic position. However, its fixed position in time is
not changed. Therefore, the tempo immediately preceding the marker automatically updates so
that the marker occurs at the correct time. For example, moving a marker to the right increases
the preceding tempo.
Any gradual tempo changes between the preceding tempo change or the start of the flow and
the marker are removed.

NOTE

The tempo change affects the positions of all other markers in the flow relative to the notated
music.

RELATED LINKS
Markers on page 814
Inputting markers/timecodes on page 249

Changing the timecodes of markers
You can change the timecode of markers, for example, if the video is edited and the marker now
occurs ten seconds later.

NOTE

Because this changes where markers occur in the project, this also moves markers relative to the
notated music.

PROCEDURE

1. In Write mode, click Video in the Notations toolbox to show the Video panel.

2. In the Markers section, double-click the timecode you want to change.

3. Enter the new timecode you want into the value field.

4. Press Return.

RESULT
The timecode of the marker is changed. The marker automatically moves relative to the music to
reflect its new time position.

RELATED LINKS
Markers section of the Video panel on page 250
Moving markers rhythmically on page 816
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Defining markers as important
You can define individual markers as important, which allows them to be considered when
finding suitable tempos in the Find Tempo dialog.

PROCEDURE

1. In Write mode, click Video in the Notations toolbox to show the Video panel.

2. In the Markers section, activate the checkbox in the Imp. column for each marker you
want to define as important.

RESULT
Markers with activated checkboxes are defined as important. The Find Tempo button at the
bottom of the Markers section becomes available.

RELATED LINKS
Find Tempo dialog on page 251

Hiding/Showing markers
By default, markers are shown in full score layouts and hidden in part layouts. You can hide and
show markers in each layout independently, for example, if markers are helpful for the
conductor to see but not for the players.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show markers.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Markers in the page list.

4. Activate/Deactivate Show markers.

5. Click Apply, then Close.

RESULT
Markers are hidden/shown in the selected layouts.

RELATED LINKS
Changing the vertical position of markers on page 815
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Timecodes indicate an exact position in time, usually in the context of a video. They allow precise
synchronization between multiple elements, such as music and moving images, and can be used
as a reference tool.

Timecodes are displayed in the format hh:mm:ss:ff, which is two-digit hours, minutes, seconds,
and frames.

A timecode on a timecode staff

In Dorico Pro, you can specify the type of timecode from the following types:

Non-drop frame timecodes
Each frame is numbered sequentially from the preceding one without skipping any
frame numbers.
Non-drop frame timecodes are shown with the suffix fps and use a colon separator
between seconds and frames, for example, 00:00:01:05.

Drop frame timecodes
Some frame numbers are skipped in order to accommodate the difference in frame
rate between 29.97 fps and 30 fps. In every minute except every tenth minute, two
timecode numbers are dropped from the frame count.
Drop frame timecodes are shown with the suffix dfps and use a semicolon separator
between the seconds and frames, for example, 00:00:01;05.

Timecodes in Dorico Pro are flow-specific, meaning you can set timecodes for each flow that are
completely independent of the timecodes for other flows. You can set timecodes in the Video
Properties dialog, including for flows without a video.

NOTE

The timecodes shown in flow cards in the Flows panel in Setup mode reflect the timecode at the
start of the flow, which can be different to the timecode you set in the Video Properties dialog.
For example, if you set the Timecode start to 02:00:00:00 but also set the Flow attachment
position to 8 quarter note beats, and the tempo is 60 bpm, the timecode shown in the flow card
is 01:59:52:00.

You can show timecodes on their own single-line staff and at different intervals. Additionally, you
can change the time displayed in the Transport window to be the timecode rather than elapsed
time, which is shown by default.

RELATED LINKS
Frame rates on page 129

Timecodes
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Video Properties dialog on page 126
Editing the marker/timecode font styles on page 816
Showing timecodes on a separate staff on page 820
Changing the timecode frequency on page 821
Changing the content shown in the transport display on page 447

Changing the initial timecode value
You can change the timecode at which each flow in your project starts, for example, if you are
using a separate project for the second reel of a film. You can also change the initial timecode in
projects without videos.

PROCEDURE

1. In Write mode, select an item in the flow whose initial timecode value you want to change.

2. In the Notations toolbox, click Video to show the Video panel.

3. In the Video panel, click Properties to open the Video Properties dialog.

4. In the Video Properties dialog, change the value for Timecode start.

5. Click OK to save your changes and close the dialog.

RESULT
The initial timecode for the flow in which you selected an item is changed.

RELATED LINKS
Timecodes on page 819
Changing the start position of videos on page 127

Showing timecodes on a separate staff
You can show timecodes on a separate single-line staff in each layout independently, as this can
make timecodes clearer in the score. You can also specify above which bracketed instrument
group the timecode staff appears.

NOTE

● If you show timecodes on a separate staff, markers are also shown on this staff.

● You cannot show timecodes on multiple staves in a system.

PREREQUISITE
Markers are shown in the selected layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to show timecodes on a separate
staff.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Markers in the page list.

4. For Vertical position, choose Timecode staff.
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5. Select the bracketed instrument family above which you want to show the timecode staff
from the Position timecode staff above bracket menu.

6. Click Apply, then Close.

RESULT
A separate timecode staff is shown above the top instrument staff that belongs to the selected
instrument family group.

TIP

You can change the default distance between timecode staves and other staves on the Vertical
Spacing page in Setup > Layout Options.

RELATED LINKS
Timecodes on page 819
Hiding/Showing markers on page 818
Changing the vertical position of markers on page 815

Hiding/Showing timecodes in markers
You can hide/show timecodes within all markers project-wide and show them above/below the
marker text, for example, to ensure the precise positions of key moments are clearly labelled.
This is in addition to your per-layout settings for showing timecodes on a separate staff.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Markers in the page list.

3. Choose one of the following options for Timecode in markers:

● Show timecode

● Do not show timecode

4. Optional: Choose one of the following options for Order of information, if timecode
shown:

● Text above timecode

● Timecode above text

5. Click Apply, then Close.

RELATED LINKS
Markers on page 814
Showing timecodes on a separate staff on page 820

Changing the timecode frequency
You can show timecodes at different intervals in layouts in which timecodes are shown on a
separate staff. For example, you can show timecodes every bar in full score layouts but only at
the start of each system in part layouts.

NOTE

We do not recommend that you show timecodes every bar in layouts with multi-bar rests, as the
result is illegible overlapping timecodes. If you want to show timecodes in part layouts with
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multi-bar rests, we recommend either showing timecodes only at the start of each system or not
showing multi-bar rests in the layout.

PREREQUISITE
Markers are shown in the selected layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the timecode frequency.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Markers in the page list.

4. Optional: If the selected layouts do not show timecodes on a separate staff, choose
Timecode staff for Vertical position.

5. Choose one of the following options for Timecode frequency on timecode staff:

● Start of system

● Every bar

● Never

6. Click Apply, then Close.

RELATED LINKS
Hiding/Showing markers on page 818
Hiding/Showing multi-bar rests on page 865

Timecodes
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For music with repeated passages, repeat endings show which bars are played at the end of each
repetition, with different endings each time if required. They are also known as “volta lines”, or as
“first and second endings”, but in this documentation, we refer to them as “repeat endings”.

Repeat endings comprise two or more segments, where each segment contains a different
possible ending. When you input repeat endings, Dorico Pro automatically inputs an end repeat
barline at the end of the first segment. Segments in repeat endings are clearly marked with solid
lines above and a number that indicates on which repeat the segment is to be played.

A repeat ending with three possible endings

Dorico Pro allows you to create repeat endings containing any number of segments, and allows
you to control which segments are used for each playthrough. For example, you might want a
repeat ending with two segments but four total playthroughs, where the first two playthroughs
use the first repeat ending segment and the final two playthroughs use the second repeat
ending segment.

In Dorico Pro, repeat endings are categorized as system objects. Therefore, repeat endings
follow your per-layout settings for the visibility and positioning of system objects, which you can
change on the Staves and Systems page in Setup > Layout Options.

RELATED LINKS
Input methods for repeats and tremolos on page 253
Dividing playthroughs across repeat ending segments on page 824
System objects on page 925
Changing the positions of system objects on page 926

Changing the total number of playthroughs in repeat
endings

By default, each segment in repeat endings is played once, so each segment shows a single digit
that indicates the playthrough for which it is used. You can increase the total number of
playthroughs for repeat endings individually so that segments are played more than once.

PROCEDURE

1. Select the repeat endings whose total number of repeats you want to change. You can do
this in Write mode and Engrave mode.

2. In the Properties panel, activate No. times played in the Repeat Endings group.

3. Change the value in the value field.

Repeat endings
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NOTE

You cannot have fewer repeats than the number of segments.

RESULT
The total number of repeats in the selected repeat endings is changed. This is updated
automatically in the layout.
By default, Dorico Pro automatically adds any repeats not already assigned to specific segments
to the final closed segment.

AFTER COMPLETING THIS TASK
Once you have set the total number of repeats, you can then change which segment is used for
each playthrough.

RELATED LINKS
Repeats in playback on page 436

Dividing playthroughs across repeat ending segments
You can control how the total number of playthroughs is divided across the different segments in
individual repeat endings.

PROCEDURE

1. In Engrave mode, select an individual segment in the repeat ending structure whose
included playthroughs you want to change.

2. In the Properties panel, activate Times played for segment in the Repeat Endings group.

3. Enter the number of each playthrough that you want to include in the selected segment.
For example, for a repeat ending with six playthroughs, enter 4,5,6 to include the 4th, 5th,
and 6th playthroughs in the second segment.

RESULT
The playthroughs included in the selected segment are changed.

EXAMPLE

Default distribution of repeats Customized distribution of repeats

Project-wide engraving options for repeat endings
You can find options controlling the project-wide design, position, and appearance of repeat
ending segments on the Repeat Endings page in Engrave > Engraving Options.

The options on the Repeat Endings page allow you to change the ends of repeat ending lines,
the appearance of numbers and hooks, and the default position of repeat endings.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

Repeat endings
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RELATED LINKS
Engraving Options dialog on page 299

Lengthening/Shortening segments in repeat endings
You can increase/decrease the number of bars included in each segment of repeat endings by
lengthening/shortening each segment independently.

PROCEDURE

1. In Write mode, select the repeat ending you want to lengthen/shorten.

NOTE

You can only lengthen/shorten one repeat ending segment at a time.

2. Select the circular handle at the end of the segment you want to lengthen/shorten.

The selected handle in the middle has a thicker line.

3. Click and drag the handle to the right/left to snap it to the next/previous barline.

NOTE

Segments must contain at least one bar.

4. Optional: Repeat steps 1 to 3 for each segment in the repeat ending.

RESULT
The selected segment is lengthened/shortened.

NOTE

● This does not automatically input or reposition repeat barlines. You must input repeat
barlines as appropriate manually.

● You can also lengthen/shorten the final segment in a single repeat ending by selecting the
repeat ending and using the following key commands:

● Press Shift-Alt-Right Arrow to lengthen the final segment.

● Press Shift-Alt-Left Arrow to shorten the final segment.

RELATED LINKS
Moving repeat endings graphically on page 826

Positions of repeat endings
Repeat endings are placed above the staff at the same positions as other system objects, and
their hooks align with barlines. They are commonly positioned outside of other notations, but
some long items, such as gradual tempo changes, can be placed above repeat endings.

You can change the positions of repeat endings individually and by changing their default
positions project-wide. For example, you can override the default position for individual repeat
endings if the musical material at those positions requires more vertical space.

You can move repeat endings to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.

Repeat endings
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You can move each repeat ending segment graphically in Engrave mode and independently of
other segments in the repeat ending; however, this does not change the rhythmic positions to
which they are attached.

You can change the default appearance and position of all repeat endings project-wide on the
Repeat Endings page in Engrave > Engraving Options.

Repeat endings are categorized as system objects in Dorico Pro, which you can show above the
first bracket of selected instrument families. You can change the instrument families above which
system objects appear in each layout independently, for example, if you want repeat endings to
appear at multiple vertical positions in each system in the full score only.

RELATED LINKS
Project-wide engraving options for repeat endings on page 824
Moving repeat endings graphically on page 826
System objects on page 925
Changing the positions of system objects on page 926

Moving repeat endings rhythmically
You can move repeat endings to different rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the repeat ending you want to move.

NOTE

You can only move one repeat ending rhythmically at a time.

2. Move the repeat ending to the next/previous bar in any of the following ways:

● Press Alt-Right Arrow to move it to the right.

● Press Alt-Left Arrow to move it to the left.

● Click and drag it to the right/left.

RESULT
The selected repeat ending is moved to the next/previous bar.

NOTE

● This does not automatically input or reposition repeat barlines. You must input repeat
barlines manually as appropriate.

● Only one repeat ending can exist at each rhythmic position. If any part of a selected repeat
ending collides with any part of another repeat ending as part of its move, the other
repeat ending is deleted. However, its repeat barlines are not deleted.

You can undo this action, but any repeat endings deleted in the process are only restored
if you moved the repeat ending using the keyboard.

Moving repeat endings graphically
You can move repeat endings graphically without changing their rhythmic positions. You can also
move the start/end of repeat ending segments independently, meaning you can lengthen/
shorten them graphically.

PROCEDURE

1. In Engrave mode, select one of the following that you want to move:

Repeat endings
Positions of repeat endings 
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● Repeat ending segments

● Individual handles on repeat ending segments

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the repeat ending segments or handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected repeat ending segments or handles are moved graphically.

TIP

The following properties in the Repeat Endings group of the Properties panel are activated
automatically when you move repeat ending segments in the corresponding directions:

● Start X offset moves start repeat ending segment handles horizontally.

● End X offset moves end repeat ending segment handles horizontally.

● Y offset moves whole repeat ending segments vertically.

For example, if you move a whole repeat ending segment to the right, both handles are moved,
so Start X offset and End X offset are both activated. You can also use all three properties to
move and lengthen/shorten repeat endings graphically by changing the values in the value
fields.

Deactivating the properties resets the selected repeat ending segments to their default
positions.

RELATED LINKS
Moving repeat endings rhythmically on page 826
Lengthening/Shortening segments in repeat endings on page 825

Repeat endings in Engrave mode
In Engrave mode, you can change the appearance of repeat endings and repeat ending
segments individually, independently of your project-wide settings on the Repeat Endings page
in Engraving Options.

In Engrave mode, each segment in repeat endings has two square handles.

You can select and move each handle independently.

Repeat endings
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TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

RELATED LINKS
Project-wide engraving options for repeat endings on page 824

Changing the text shown in repeat endings
You can replace the text shown in individual segments in repeat endings, which by default shows
the playthrough numbers for the segment, with custom text.

PROCEDURE

1. In Engrave mode, select the repeat ending segments whose text you want to change.

2. In the Properties panel, activate Custom text in the Repeat Endings group.

3. Enter the text you want into the value field.

4. Press Return.

RESULT
The text shown in the selected segments is changed.
Deactivating Custom text restores the default text for the selected repeat ending segments.

NOTE

Deactivating properties permanently deletes any custom text entered.

Changing the appearance of individual final repeat ending
segments

You can change the appearance of the line ends in the final segments of individual repeat
endings, independently of your project-wide settings.

PROCEDURE

1. Select the repeat endings whose final segment appearance you want to change. You can
do this in Write mode and Engrave mode.

NOTE

In Engrave mode, you can select any segment in the repeat ending.

2. In the Properties panel, activate End of line in the Repeat Endings group.

3. Select one of the following options from the menu:

● Open, short

● Open, full length

● Closed

RESULT
The end of the line of the final segment in the selected repeat endings is changed.

Repeat endings
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TIP

You can change the appearance of final segments in all repeat endings project-wide in the
Segments section of the Repeat Endings page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for repeat endings on page 824

Lengthening/Shortening repeat ending hooks
You can lengthen/shorten the hooks in repeat endings individually, independently of your
project-wide settings.

NOTE

You cannot change the hook length of an individual segment in a repeat ending. Changing the
hook length affects the whole repeat ending.

PROCEDURE

1. In Engrave mode, select the repeat endings whose hooks you want to lengthen/shorten.

2. In the Properties panel, activate Hook length in the Repeat Endings group.

3. Change the value in the value field.

RESULT
Increasing the value makes repeat ending hooks longer. Decreasing the value makes repeat
ending hooks shorter.

TIP

You can change the default length of all repeat ending hooks project-wide on the Repeat
Endings page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for repeat endings on page 824

Repeat endings in MusicXML files
All aspects of repeat endings can be imported from and exported in MusicXML files.

However, while MusicXML can represent this, segments in the middle of sets of endings cannot
have an open right-hand end in Dorico Pro.

Repeat endings
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Repeat markers show that musical material is to be repeated, but unlike repeat endings, repeat
markers often involve jumping to different positions and sections in the music instead of moving
through the music consecutively.

In Dorico Pro, repeat markers are divided into the following types:

Repeat jumps
Specify the position from which players or playback must jump, such as D.C. al Coda.
You can qualify the conditions under which repeat jumps are used, such as “second
time only”.
Repeat jumps are right-aligned with their rhythmic position, meaning their text or
symbol ends at that rhythmic position and extends to the left.

Repeat sections
Specify the destinations for jumps, such as segno or coda, or where the music should
end, such as Fine. In Dorico Pro, coda sections that start mid-system are
automatically separated from the preceding music with a gap.
Repeat markers are left-aligned with their rhythmic position, meaning their text or
symbol starts at that rhythmic position and extends to the right.

By default, repeat markers are shown on a single line, but you can show them on two lines
individually to reduce their horizontal length if necessary. You can also customize their
paragraph styles, including changing their font size, in the Paragraph Styles dialog and use the
options on the Repeat Markers page in Engrave > Engraving Options to customize their
appearance.

Repeat markers
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RELATED LINKS
Input methods for repeats and tremolos on page 253
Showing repeat markers on one/two lines on page 833
Paragraph Styles dialog on page 366
Repeats in playback on page 436

Project-wide engraving options for repeat markers
You can find options controlling the project-wide design, position, and appearance of repeat
markers on the Repeat Markers page in Engrave > Engraving Options.

The options on the Repeat Markers page allow you to change the appearance, design, and
length of repeat markers, the default gap before coda sections that start mid-system, and their
default position. You can also change the order of symbols and text in repeat markers, the scale
size of symbols compared to text, and the letter case for repeat marker text.

The following appearance presets are provided in the Repeat Markers Preset section:

● Standard
Based on the most commonly-used conventions in current rock/pop sheet music
publishing, which produce shorter, more abbreviated instructions.

● Gould
Based on the recommendations made in Elaine Gould’s book “Behind Bars”, which is better
suited for classical and concert music as it produces longer, more explicit instructions.

NOTE

Gould also recommends placing repeat markers below the staff instead of above it.

● Custom
A mixture of settings according to your preference. This preset is automatically selected
when you override an appearance preset by changing individual options.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299
Changing the placement of repeat markers relative to the staff on page 836

Repeat marker paragraph styles
Repeat markers use paragraph styles to format their fonts, including their size, spacing,
alignment, and other formatting options. Because the different types of repeat markers require
different formatting, they each have a separate paragraph style by default.

Dorico Pro provides the following default paragraph styles for repeat markers:

● Repeat Marker Jumps
The default paragraph style used for repeat jumps, such as D.C. al Coda.

● Repeat Marker Sections
The default paragraph style used for repeat sections, such as a coda.

By default, the formatting of these paragraph styles is the same but you can edit paragraph
styles independently of each other in the Paragraph Styles dialog, for example, if you want to
decrease the size of repeat jumps but leave repeat sections with their default size.

Repeat markers
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NOTE

The Repeat Marker Jumps paragraph style inherits settings from the Repeat Marker Sections
style. If you change the Repeat Marker Sections paragraph style, this also affects any
corresponding options for the Repeat Marker Jumps paragraph style that have not been
overridden.

RELATED LINKS
Paragraph Styles dialog on page 366
Changing the text shown in repeat markers on page 833
Showing repeat markers on one/two lines on page 833

Changing the size of coda/segno symbols
You can change the default size of all coda and segno symbols project-wide and independently of
each other. This does not affect the size of text in repeat markers.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Repeat Markers in the page list.

3. In the Design section, change the value for Scale factor for coda symbols.

4. Change the value for Scale factor for segno symbols.

5. Click Apply, then Close.

RESULT
The size of coda and segno symbols relative to repeat marker text is changed project-wide.

Changing the index for repeat markers
You can change the index of individual repeat markers, for example, if a flow requires two
different codas with different symbols so players can tell them apart.

By default, all repeat markers of the same type have the same appearance, even when there are
multiple repeat markers in the flow.

NOTE

You cannot change the index of Fine or D.C. repeat markers.

PROCEDURE

1. Select the repeat marker whose index you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate the following properties, individually or together as
appropriate for your selection, in the Repeat Markers section:

● Marker index

● ‘Jump to’ index

3. Change the values in the value fields.

NOTE

You can only enter values between 1 and 3.

Repeat markers
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RESULT
Marker index changes the order of the selected repeat marker relative to other repeat markers
of the same type.
‘Jump to’ index changes the destination of the selected repeat marker.

TIP

You can change the default appearance of all multiple repeat markers project-wide in the Repeat
Sections section of the Repeat Markers page in Engrave > Engraving Options.

EXAMPLE
If you have two codas in a flow with two different D.S. al Coda markers, you might set Marker
index to 1 for the first coda and 2 for the second, then set ‘Jump to’ index to 1 for the first D.S. al
Coda marker and 2 for the second.

D.S. al Coda marker with default indexes D.S. al Coda marker with both indexes set to 2

RELATED LINKS
Project-wide engraving options for repeat markers on page 831

Changing the text shown in repeat markers
You can change the text shown in individual repeat markers, for example, if you are typesetting a
score with an unusual repeat marker instruction.

PROCEDURE

1. Select the repeat markers whose text you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Custom text in the Repeat Markers group.

3. Enter the text you want into the value field.

4. Press Return.

RESULT
The text shown in the selected repeat markers is changed. This replaces the text in the selected
repeat markers without removing any symbols.

RELATED LINKS
Project-wide engraving options for repeat markers on page 831

Showing repeat markers on one/two lines
You can show individual repeat markers either on a single line or spread across two lines
independently of your per-layout settings, for example, if a single long repeat marker extends
beyond the page margins in one part layout.

NOTE

You can only change the word wrapping of repeat jumps, such as D.C. al Fine and D.S. al Coda,
that do not have custom text.

Repeat markers
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PROCEDURE

1. In Engrave mode, select the repeat markers whose word wrapping you want to change.

2. In the Properties panel, activate Word wrap in the Repeat Markers group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
The selected repeat markers are shown on two lines when the checkbox is activated, and on one
line when the checkbox is deactivated.
When the property is deactivated, repeat markers follow your per-layout setting for word
wrapping.

TIP

You can show all repeat markers on two lines in each layout independently in the Repeat
Markers section of the Staves and Systems page in Setup > Layout Options. For example, you
can show them on one line in the full score but on two lines in part layouts.

EXAMPLE

Repeat marker without word wrapping Repeat marker with word wrapping

RELATED LINKS
Layout Options dialog on page 90

Changing the barline shown before codas
You can change the default barline shown before all codas project-wide that are preceded by a
repeat jump, for example, if you want to show double barlines in such cases instead of normal
barlines.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Barlines in the page list.

3. In the Repeats section, choose one of the following options for Barline coinciding with
repeat jump before Coda:

● Double barline

● Single barline

4. Click Apply, then Close.

RESULT
The barline shown automatically before codas immediately preceded by a repeat jump is
changed project-wide.

Repeat markers
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Positions of repeat markers
Repeat markers are placed above the staff by default, and at the same positions as other system
objects. Coda sections are separated from the preceding music by a gap in the system.

You can move repeat markers to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.

You can move repeat markers graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached. You can adjust the size of individual mid-system
gaps before codas by adjusting the note spacing at their rhythmic positions in Engrave mode.

You can change the default positions of all repeat markers project-wide, set values for the
minimum distances between repeat markers and staves and other items, and set the default
mid-system gap preceding coda sections on the Repeat Markers page in Engrave > Engraving
Options. You can change the default placement of repeat markers relative to the staff in each
layout independently in the Repeat Markers section of the Staves and Systems page in Setup >
Layout Options.

Repeat markers are categorized as system objects in Dorico Pro, which you can show above the
first bracket of selected instrument families. You can change the instrument families above which
system objects appear in each layout independently, for example, if you want repeat markers to
appear at multiple vertical positions in each system in the full score only.

RELATED LINKS
Project-wide engraving options for repeat endings on page 824
Adjusting note spacing at individual rhythmic positions on page 388
Changing the placement of repeat markers relative to the staff on page 836
Changing the positions of system objects on page 926

Moving repeat markers rhythmically
You can move repeat markers to new rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the repeat markers you want to move.

NOTE

When using the mouse, you can only move one repeat marker rhythmically at a time.

2. Move the selected repeat markers in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag it to the right/left.

RESULT
The selected repeat markers are moved according to the current rhythmic grid value.

Moving repeat markers graphically
You can move repeat markers graphically, without changing the rhythmic positions to which they
are attached.

PROCEDURE

1. In Engrave mode, select the repeat markers you want to move.

Repeat markers
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2. Move the repeat markers in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The graphical positions of the selected repeat markers are changed.

TIP

Start offset in the Repeat Markers group of the Properties panel is activated automatically
when you move repeat markers.

● Start offset X moves repeat markers horizontally.

● Start offset Y moves repeat markers vertically.

You can also use this property to move repeat markers by changing the values in the value fields.

Deactivating the property resets the selected repeat markers to their default positions.

RELATED LINKS
Positions of repeat markers on page 835

Changing the placement of repeat markers relative to the staff
You can change the default placement of repeat markers relative to the staff in each layout
independently, including showing them both above and below the staff.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the staff-placement of
repeat markers.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Repeat Markers section, choose one of the following options for Default
placement for repeat jumps and ‘Fine’:

● Above staff

● Below staff

● Above and below bottom staff

5. Click Apply, then Close.

Repeat markers
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RESULT
The placement of all repeat markers relative to the staff is changed in the selected layouts.

Including/Excluding repeats in playback after repeat jumps
By default, Dorico Pro plays back all playthroughs in all types of repeat structures. You can
manually include/exclude repeats indicated by repeat markers, repeat endings, and repeat
barlines in playback after individual repeat jumps independently of your project-wide setting.

NOTE

You can only include/exclude repeats after repeat jumps, such as D.C. al Fine and D.S. al Coda.

PROCEDURE

1. Select the repeat jumps after which you want to include/exclude repeats in playback. You
can do this in Write mode and Engrave mode.

2. In the Properties panel, activate Replay repeats in the Repeat Markers group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
Repeats are included in playback after the selected repeat jumps when the checkbox is activated,
and excluded from playback when the checkbox is deactivated.
When the property is deactivated, repeat markers follow your project-wide setting for including
repeats in playback after repeat jumps.

TIP

You can include/exclude all repeats after all repeat jumps project-wide on the Repeats page in
Play > Playback Options.

RELATED LINKS
Playback Options dialog on page 405

Changing the number of playthroughs at repeat barlines
End repeat barlines typically indicate that the preceding music is played through twice. You can
change the number of playthroughs for each end repeat barline individually.

PROCEDURE

1. Select the end repeat barlines whose number of playthroughs you want to change. You
can do this in Write mode and Engrave mode.

2. In the Properties panel, activate Play n times in the Time Signatures group.

3. Change the value in the value field.

NOTE

The minimum value is 2.

RESULT
The number of times the music preceding the selected end repeat barlines is played through is
changed. A marker is shown at system object positions that indicates the number of
playthroughs set when this is 3 or more.

Repeat markers
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EXAMPLE

Final repeat barline with the default 2 playthroughs
set

Final repeat barline with 4 playthroughs set and
marker shown

RELATED LINKS
Including/Excluding repeats in playback after repeat jumps on page 837
Changing the total number of playthroughs in repeat endings on page 823
Repeats in playback on page 436
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Bar repeats indicate that the musical material in preceding bars must be repeated exactly, but
without notating that material again. Bar repeats can comprise groups of one, two, or four bars.

For example, a one-bar repeat indicates that the material in one bar is repeated, meaning every
bar in the region repeats the same material. A four-bar repeat indicates that the material in the
previous four bars is repeated.

One-bar repeat region Two-bar repeat region

Four-bar repeat region

This notational short-hand can make repetitive music easier to read, as performers must only
read the repeated phrase once and then simply count how many times they repeat it. Bar
repeats can also save horizontal space, as bar repeat symbols are usually narrower than the
equivalent fully written-out bars.

In Dorico Pro, bar repeat regions are used to display bar repeats, meaning as many bar repeat
symbols as necessary to fill the region are shown automatically.

By default, bar repeat regions are highlighted with a colored background, as this makes them
easier to see. As you zoom out, the highlights become more opaque, which is especially useful
when viewing full score layouts in galley view. These highlights are not printed, and you can hide
and show them at any time.

You can also show adjacent bar repeat regions, for example, if you want to use a two-bar repeat
in the first iteration of a phrase, and then a four-bar repeat to indicate the whole phrase is
repeated. When two different bar repeat regions are adjacent, they alternate highlight colors to
ensure the separate regions are always identifiable.

Phrase containing two adjacent bar repeat regions

RELATED LINKS
Inputting bar repeats on page 264
Repeats popover on page 254
Bar repeat counts on page 842
Bar repeat grouping on page 846
Hiding/Showing bar repeat region highlights on page 842
Moving bar repeat regions on page 841

Bar repeats
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Lengthening/Shortening bar repeat regions on page 841
Hiding/Showing multi-bar rests on page 865

Project-wide engraving options for bar repeats
You can find options controlling the project-wide design and appearance of bar repeats on the
Bar Repeats page in Engrave > Engraving Options.

The options on the Bar Repeats page allow you to change the frequency of bar repeat counts,
the appearance of bar repeat counts, and how bar repeats are grouped when a four-bar phrase
contains a single bar followed by a three-bar repeat.

The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.

RELATED LINKS
Engraving Options dialog on page 299

Changing the length of the repeated phrase in bar repeat
regions

You can change the number of bars that make up the repeated phrase in individual bar repeats
after you have input them, for example, if you want the region to repeat the previous two bars
rather than the previous four bars.

NOTE

You cannot repeat more bars than exist before the bar repeat region. For example, if a bar
repeat region follows the first notated bar in a flow, you cannot increase the number of bars in
the repeated phrase.

PROCEDURE

1. Select the bar repeat regions whose phrase length you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, select one of the following options from the No. bars menu in the
Bar Repeat Regions group:

● One bar

● Two bars

● Four bars

RESULT
The number of bars that make up the repeated phrase in the selected bar repeat regions is
changed. This is also reflected in playback.

TIP

● Any dynamics you add within bar repeat regions affect the playback of the repeated music.

● You can also change the length of the repeated phrase by opening the repeats popover
and changing the entry.

RELATED LINKS
Bar repeat grouping on page 846
Inputting bar repeats on page 264

Bar repeats
Project-wide engraving options for bar repeats 
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Repeats popover on page 254
Changing existing items on page 280

Moving bar repeat regions
You can move bar repeat regions to different rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the bar repeat region you want to move.

NOTE

You can only move one bar repeat region at a time.

2. Move the bar repeat region to the right/left in any of the following ways:

● Press Alt-Right Arrow to move it to the right.

● Press Alt-Left Arrow to move it to the left.

● Click and drag it to the right/left.

RESULT
The selected bar repeat region is moved to bars to the right/left.
When you move bar repeat regions using the keyboard, they are moved to the right by the
duration of their grouping, for example, two-bar repeats are moved two bars to the right.
However, when you move them to the left, they are always moved to the next bar, regardless of
their grouping.
When you move bar repeat regions using the mouse, they are always moved to the next/
previous bar.

NOTE

Only one bar repeat region can exist at each rhythmic position. If any part of a selected bar
repeat region collides with any part of another bar repeat region as part of its move, the other
bar repeat region is shortened to accommodate the one you moved. In some cases, this means
the grouping of the other bar repeat region is changed or it is deleted entirely.

You can undo this action and restore the previous length of the other bar repeat region.

Lengthening/Shortening bar repeat regions
You can lengthen/shorten bar repeat regions after they have been input.

PROCEDURE

1. In Write mode, select the bar repeat region you want to lengthen/shorten.

NOTE

You can only lengthen/shorten one bar repeat region at a time.

2. Lengthen/Shorten the bar repeat region in any of the following ways:

● Press Shift-Alt-Right Arrow to lengthen the region by the duration of its grouping.

● Press Shift-Alt-Left Arrow to shorten the region by the duration of its grouping.

NOTE

Key commands lengthen/shorten items by moving their end only.

Bar repeats
Moving bar repeat regions 
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● Click and drag the start/end handle to the next/previous bar.

RESULT
The bar repeat region is lengthened/shortened.

NOTE

● The minimum length of a bar repeat region is one bar. If you shorten regions with longer
groupings, such as every four bars, the length of the region is halved until a one-bar
repeat region remains.

● Only one bar repeat region can exist at each rhythmic position. If any part of a selected bar
repeat region collides with any part of another bar repeat region when it is lengthened/
shortened, the other bar repeat region is shortened to accommodate this. In some cases,
this means the grouping of the other bar repeat region is changed or it is deleted entirely.

You can undo this action and restore the previous lengths of all bar repeat regions
involved.

RELATED LINKS
Bar repeats on page 839
Bar repeat grouping on page 846
Hiding/Showing multi-bar rests on page 865

Hiding/Showing bar repeat region highlights
You can hide/show colored highlights for bar repeat regions at any time, for example, if you want
to show the highlights when inputting music but hide them when engraving.

PROCEDURE

● Choose View > Highlight Bar Repeat Regions.

RESULT
Highlights on bar repeat regions are shown when a tick appears beside Highlight Bar Repeat
Regions in the menu, and hidden when no tick appears.

Bar repeat counts
Bar repeat counts are numbers shown at regular intervals either above or below bar repeats, to
help players keep track of how many bars have passed. The intervals are usually based on typical
musical phrases, such as every four or eight bars.

NOTE

Bar repeat counts are only shown on one-bar repeat regions.

Because bar repeats must start with a fully notated phrase of at least one bar, the bar repeat
count starts from the notated bar rather than the first bar in the bar repeat region. For example,
the third bar in a bar repeat region shows the count number 4, as that bar is the fourth time the
original notated bar is played.

Bar repeat region with counts shown every four bars

Bar repeats
Hiding/Showing bar repeat region highlights 
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In Dorico Pro, you can change the start count of each bar repeat region, how frequently bar
repeat counts are shown, whether they are parenthesized, and customize the font style used for
bar repeat counts.

NOTE

The Bar Repeat Count font style also affects the appearance of counts on slash regions.

RELATED LINKS
Changing the bar repeat count appearance on page 844
Changing the bar repeat count frequency on page 844
Changing the bar repeat count font on page 845
Repeats popover on page 254
Inputting bar repeats on page 264
Hiding/Showing bar number ranges on multi-bar rests on page 526

Changing the start count of bar repeats
You can change the number from which individual bar repeats start, for example, if you want to
notate the first bar in a repeated phrase at the start of each system but show a continuous count
across multiple bar repeats.

NOTE

● The start count applies to the first bar in the bar repeat, which is the notated bar. For
example, changing the start count of a one-bar repeat region lasting three bars to 5, with
bar repeat counts shown every four bars, causes the count at the end of the bar repeat
region to show the number 8.

● Bar repeat counts are only shown on one-bar repeat regions.

PROCEDURE

1. Select the one-bar repeat regions whose start count you want to change. You can do this
in Write mode and Engrave mode.

2. In the Properties panel, activate Count from in the Bar Repeat Regions group.

3. Change the value in the value field.

RESULT
The number and position of bar repeat counts on the selected bar repeats is changed. For
example, changing the start count from 1 to 2, with counts shown every four bars, causes the
count to appear on the second bar in the bar repeat region instead of the third.

Bar repeats
Bar repeat counts 
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EXAMPLE

Separate bar repeats on multiple systems in the
same part layout with the default count

Separate bar repeats on multiple systems in the
same part layout with their counts changed to imply
a continuous region

RELATED LINKS
Bar repeat counts on page 842

Changing the bar repeat count frequency
You can change how often counts are shown on individual one-bar repeat regions independently
of your project-wide setting, for example, if you want to show the count after eight bars on a
single bar repeat region.

NOTE

Bar repeat counts are only shown on one-bar repeat regions.

PROCEDURE

1. Select the one-bar repeats whose count frequency you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Count frequency in the Bar Repeat Regions group.

3. Change the value in the value field.

RESULT
The count frequency is changed for the selected bar repeat regions.

TIP

You can also change the default count frequency for all bar repeat regions project-wide on the
Bar Repeats page in Engrave > Engraving Options.

RELATED LINKS
Bar repeat counts on page 842
Project-wide engraving options for bar repeats on page 840
Changing the bar repeat count appearance on page 844
Hiding/Showing bar number ranges on multi-bar rests on page 526

Changing the bar repeat count appearance
You can show individual bar repeat counts with or without parentheses, or not show any repeat
count at all, independently of your project-wide setting.

Bar repeats
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NOTE

Bar repeat counts are only shown on one-bar repeat regions.

PROCEDURE

1. Select the one-bar repeats whose count appearance you want to change. You can do this
in Write mode and Engrave mode.

2. In the Properties panel, activate Count appearance in the Bar Repeat Regions group.

3. Select one of the following options from the menu:

● Parenthesized

● No parentheses

● Don’t show

RESULT
The appearance of counts on the selected bar repeat regions is changed.

TIP

You can also change the default appearance of all bar repeat counts project-wide on the Bar
Repeats page in Engrave > Engraving Options.

RELATED LINKS
Bar repeat counts on page 842
Project-wide engraving options for bar repeats on page 840
Changing the bar repeat count frequency on page 844

Changing the bar repeat count font
You can change the font style used for all bar repeat and slash region counts project-wide in the
Edit Font Styles dialog, for example, if you want counts to appear bold and italic.

PROCEDURE

1. In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2. Select Bar Repeat Count from the Font style menu:

3. Activate the following options, individually or together, to change the corresponding
aspect of the font:

● Font family

● Size

● Style

● Underlined

4. Click OK to save your changes and close the dialog.

RESULT
The font style used for counts on bar repeats and slash regions is changed project-wide.

RELATED LINKS
Bar repeat counts on page 842
Edit Font Styles dialog on page 364
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Moving bar repeat counts
You can move individual bar repeat counts graphically without changing the rhythmic positions
to which they apply, for example, to accommodate other items at the same position better.

NOTE

If you want to move bar repeat counts because you want to change the bar to which the number
applies, you can change the start count instead.

PROCEDURE

1. In Engrave mode, select the bar repeat counts you want to move.

2. Move the selected bar repeat counts in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected bar repeat counts are moved to new graphical positions.

TIP

Number offset in the Bar Repeat Regions group of the Properties panel is activated
automatically when you move bar repeat counts in the corresponding directions:

● Number offset X moves bar repeat counts horizontally.

● Number offset Y moves bar repeat counts vertically.

You can also use this property to move bar repeat counts graphically by changing the values in
the value fields.

Deactivating the property resets the selected bar repeat counts to their default positions.

RELATED LINKS
Changing the start count of bar repeats on page 843

Bar repeat grouping
Bar repeat grouping allows you to condense longer bar repeat regions, which can be helpful in
very regular music as it can simplify the overall phrasing.

The symbols shown on the staff are different for the different groupings, and two-bar and four-
bar repeats also show a number to indicate how many bars are included in the group.

Bar repeats
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One-bar repeat symbol Two-bar repeat symbol Three-bar repeat symbol Four-bar repeat symbol

You can specify the grouping when inputting bar repeats, and you can change the grouping of
bar repeats after they have been input. Depending on where the bar repeat region starts and
ends relative to the written material, Dorico Pro automatically adjusts the displayed symbols to
achieve an accurate result. For example, an eight-bar phrase containing a single notated bar
followed by seven one-bar repeats grouped every four bars is automatically shown with a one-
bar repeat, two-bar repeat, then four-bar repeat to fill the seven bars.

Eight-bar phrase with seven one-bar repeats grouped every four bars

TIP

You can also choose to show a three-bar repeat to complete a four-bar phrase on the Bar
Repeats page in Engrave > Engraving Options; however, this is less commonly used than a
combination of one-bar and two-bar repeats.

RELATED LINKS
Repeats popover on page 254
Inputting bar repeats on page 264

Changing bar repeat grouping
You can change how bar repeats are grouped after they have been input, for example, if you
want to group a region of one-bar repeats every two bars.

PROCEDURE

1. Select the bar repeat regions whose grouping you want to change. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, select one of the following options from the Group every menu in
the Bar Repeat Regions group:

● One bar

● Two bars

● Four bars

NOTE

The options available depend on the minimum length of the selected bar repeat regions.
For example, if you select bar repeat regions that last three bars, only One bar and Two
bars are available in the menu.

RESULT
The grouping in the selected bar repeat regions is changed. Dorico Pro automatically calculates
the clearest way to group the region. For example, an eight-bar phrase containing a single
notated bar followed by seven one-bar repeats grouped every four bars is automatically shown
with a one-bar repeat, two-bar repeat, then four-bar repeat to fill the seven bars.
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RELATED LINKS
Bar repeat grouping on page 846
Inputting bar repeats on page 264
Repeats popover on page 254
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Rhythm slashes are diagonal lines positioned on staves that are used to indicate that performers
should play something, but without specifying the exact rhythms and pitches. They are often
accompanied by chord symbols to indicate the set of notes the performer should use.

There are two different types of rhythm slashes:

● Slashes with stems, which usually indicate the rhythm to be played, but not the pitches.

● Slashes without stems, which do not usually indicate either rhythms or pitches.

Slashes with stems are also known as “rhythmic notation”, and slashes without stems are also
known as “slash notation”.

In Dorico Pro, you can present both types of rhythm slashes simultaneously by using a
combination of slash regions and slash voices.

RELATED LINKS
Slash voices on page 1044
Chord symbols on page 564
Inputting slash regions on page 263
Inputting notes into slash voices on page 160

Slash regions
Slash regions automatically display rhythm slashes as appropriate for the meter throughout their
duration, for example, they show four slashes per bar in 4/4 and two slashes per bar in 6/8. A
single slash region can extend across multiple different meters.

A single slash region covering multiple different meters

Multiple slash regions can exist at the same rhythmic position. When slash regions overlap,
Dorico Pro treats this as a multiple-voice context and changes the staff position of slashes
automatically.

By default, slash regions are highlighted with a colored background, as this makes them easier to
see. As you zoom out, the highlights become more opaque, which is especially useful when
viewing full score layouts in galley view. These highlights are not printed, and you can hide and
show them at any time.

Rhythm slashes

849
Dorico 2.2.20



Each region has a handle at the start and end, which you can use to move and lengthen/shorten
regions.

When two different slash regions are adjacent, they alternate highlight colors to ensure the
separate regions are always identifiable.

Two adjacent slash regions with different highlight colors

You can use slash regions and slash voices in the same project and at the same rhythmic
positions, for example, you can input a slash region where you do not want to be specific about
the rhythm, then input notes in a slash voice for a single bar where you want to specify an exact
rhythm.

RELATED LINKS
Slash voices on page 1044
Project-wide engraving options for rhythm slashes on page 850
Slash region counts on page 855
Slashes in multiple-voice contexts on page 851
Moving slash regions on page 854
Lengthening/Shortening slash regions on page 854

Hiding/Showing slash region highlights
You can hide/show the colored highlights for slash regions at any time, for example, if you want
to show the highlights when inputting music but hide them when engraving.

PROCEDURE

● Choose View > Highlight Slash Regions.

RESULT
Highlights on slash regions are shown when a tick appears beside Highlight Slash Regions in
the menu, and hidden when no tick appears.

RELATED LINKS
Slash voices on page 1044

Project-wide engraving options for rhythm slashes
You can find options controlling the project-wide design and appearance of rhythm slashes in the
Rhythmic slashes section of the Notes page in Engrave > Engraving Options. These options
affect both slash voices and slash regions.

The options in the Rhythmic slashes section of the Notes page allow you to change the design
of slashes, both with and without stems, whether slashes are shown with rhythm dots in
compound time signatures, and the frequency, appearance, and position of slash region counts.
For example, you can choose to show slash region bar counts on every bar.

The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.

RELATED LINKS
Engraving Options dialog on page 299

Rhythm slashes
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Slashes in multiple-voice contexts
Multiple slash regions and slash voices can exist at the same rhythmic positions. In multiple-voice
contexts for slash voices and when slash regions overlap, Dorico Pro automatically changes their
staff position and offset to accommodate all slashes as legibly as possible.

Single slash region Two slash regions, one up-stem and one down-stem

You can set default per-flow settings for the position and offset of slashes relative to other
slashes at the same rhythmic positions on the Voices page in Write > Notation Options.

NOTE

These options affect all rhythm slashes, including notes in slash voices as well as slash regions.

You can also control the positions of rhythm slashes relative to each other manually by changing
their stem/voice direction and by changing their staff position.

RELATED LINKS
Note positions in multiple-voice contexts on page 1039
Changing the voice of existing notes on page 287
Changing the staff position of rhythm slashes on page 852

Changing the voice direction of slash regions
You can change the voice direction of slash regions individually. When multiple slash regions
overlap, this affects their stem directions.

PROCEDURE

1. Select any part of each slash region whose voice direction you want to change. You can do
this in Write mode and Engrave mode.

2. In the Properties panel, activate Voice direction in the Slash Regions group.

3. Choose one of the following options:

● Up

● Down

RESULT
The voice direction, and therefore stem direction, of the selected slash regions is changed.

NOTE

This only affects the direction of stems in slash regions on the middle line of the staff and when
multiple slash regions exist at the same rhythmic position. For example, if you change the voice
direction of a slash region on the bottom line of the staff to Down, its stem direction does not
change if it does not overlap with another slash region.

RELATED LINKS
Stem direction on page 943

Rhythm slashes
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Changing the staff position of rhythm slashes
You can change the staff position of rhythm slashes in both slash voices and slash regions, for
example, to accommodate other notes at the same rhythmic positions better. By default, rhythm
slashes are positioned on the middle line of the staff.

PROCEDURE

1. Select the rhythm slashes whose staff position you want to change. You can do this in
Write mode and Engrave mode.

● For notes in slash voices, you must select every note whose staff position you want
to change.

● For slash regions, you can select any part of each region whose staff position you
want to change.

2. In the Properties panel, activate Slash pos. in the corresponding group for the type of
rhythm slash whose staff position you want to change:

● Notes and Rests for notes in slash voices

● Slash Regions for slash regions

3. Change the value in the value field.

RESULT
The staff position of the selected rhythm slashes is changed. For example, changing the Slash
pos. value to 4 positions rhythm slashes on the top line of a five-line staff, while -4 positions them
on the bottom line.
If any of the rhythm slashes have stems, their stem direction is adjusted automatically.

RELATED LINKS
Stem direction on page 943

Hiding/Showing notes alongside slash regions
You can hide/show notes at the same rhythmic positions as slash regions, for example, if you
want to input notes to hear in playback but only want to show the slash region, or if you want to
notate suggested notes in addition to the slash region.

PROCEDURE

1. Select any part of each slash region alongside which you want to hide/show other notes.
You can do this in Write mode and Engrave mode.

2. In the Properties panel, activate/deactivate Show other voices in the Slash Regions
group.

RESULT
All notes in other voices present alongside the selected slash regions are shown when Show
other voices is activated, and hidden when it is deactivated.

EXAMPLE

Notes hidden alongside a slash region Notes shown alongside a slash region

Rhythm slashes
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RELATED LINKS
Slash regions on page 849
Slash voices on page 1044
Hiding/Showing slash region highlights on page 850

Hiding/Showing padding rests before/after slash regions
You can hide/show padding rests before/after slash regions that start partway through bars
individually, for example, if you have other notes at those positions and the rests would be
misleading.

By default, Dorico Pro automatically shows implicit padding rests around slash regions that
start/end partway through bars, so that the full duration of each bar is clear.

PROCEDURE

1. Select any part of each slash region whose padding rests you want to hide/show.

2. In the Properties panel, activate the following properties, individually or together, in the
Slash Regions group:

● Hide rests before start

● Hide rests after end

RESULT
Padding rests are hidden on the corresponding side of the selected slash regions. For example,
activating both properties hides padding rests both before and after the selected slash regions.

RELATED LINKS
Implicit vs. explicit rests on page 860

Splitting slash regions
You can split slash regions after they have been input, for example, if you later want to input
more precise notation in the middle of an existing slash region.

PROCEDURE

1. In Write mode, select a slash in each slash region you want to split, immediately to the
right of where you want to split them.

2. Press U.

RESULT
The slash regions are split immediately to the left of the selected slashes. Each part now has its
own start/end handles, which you can use to lengthen/shorten each part independently.

RELATED LINKS
Changing the slash region count frequency on page 856
Lengthening/Shortening slash regions on page 854
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Moving slash regions
You can move slash regions to different rhythmic positions after they have been input. Because
multiple slash regions can exist at the same rhythmic position, you can also move slash regions
so they overlap with other slash regions.

PROCEDURE

1. In Write mode, select any part of each slash region you want to move.

2. Move the selected slash regions to the right/left in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

NOTE

You cannot move slash regions rhythmically with the mouse.

RESULT
The selected slash regions are moved to the right/left according to the current rhythmic grid
value. If any part of them overlap rhythmic positions with other slash regions, the staff positions
of slashes are automatically adjusted to accommodate multiple slash regions at the same
positions.

RELATED LINKS
Slashes in multiple-voice contexts on page 851
Changing the voice direction of slash regions on page 851

Lengthening/Shortening slash regions
You can lengthen/shorten slash regions after they have been input. Because multiple slash
regions can exist at the same rhythmic position, you can also lengthen/shorten slash regions so
they overlap with other slash regions.

PROCEDURE

1. In Write mode, select any part of each slash region you want to lengthen/shorten.

NOTE

When using the mouse, you can only lengthen/shorten one slash region at a time.

2. Lengthen/Shorten the selected slash regions in any of the following ways:

● To lengthen them by the current rhythmic grid value, press Shift-Alt-Right Arrow.

● To shorten them by the current rhythmic grid value, press Shift-Alt-Left Arrow.

NOTE

Key commands lengthen/shorten items by moving their end only.

● Click and drag the circular handle at the start/end to the right/left.

RESULT
The selected slash regions are lengthened/shortened according to the current rhythmic grid
value. If any part of them overlap rhythmic positions with other slash regions, the staff positions
of slashes are automatically adjusted to accommodate multiple slash regions at the same
positions.

Rhythm slashes
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RELATED LINKS
Slashes in multiple-voice contexts on page 851
Changing the voice direction of slash regions on page 851

Hiding/Showing stems in slash regions
You can hide/show stems on slashes in individual slash regions. By default, slashes in slash
regions are shown without stems.

PROCEDURE

1. Select any part of each slash region in which you want to hide/show stems. You can do this
in Write mode and Engrave mode.

2. In the Properties panel, activate Slash type in the Slash Regions group.

3. Choose one of the following options:

● With stems

● Without stems

RESULT
Stems are hidden in the selected slash regions when you choose Without stems, and shown
when you choose With stems.

Slash region counts
Slash region counts are numbers shown at regular intervals, either above or below slash regions,
to help players keep track of how many bars have passed. The intervals are usually based on
typical musical phrases, such as every four or eight bars.

By default, slash region counts are shown every four bars and are placed below the staff.

Slash region with counts shown every two bars

In Dorico Pro, you can change the start count of each slash region, how frequently slash region
counts are shown, their staff-relative placement, whether they are parenthesized, and customize
the font style used for slash region counts.

NOTE

Slash region counts use the same font style as bar repeat counts.

RELATED LINKS
Slash regions on page 849
Project-wide engraving options for rhythm slashes on page 850
Changing the slash region count appearance on page 857
Changing the bar repeat count font on page 845
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Changing the start count of slash regions
You can change the number from which individual slash region counts start, for example, if you
want to input more precise notation between two slash regions but want the count to appear to
continue across the regions.

PROCEDURE

1. Select any part of each slash region whose start count you want to change. You can do this
in Write mode and Engrave mode.

2. In the Properties panel, activate Count from in the Slash Regions group.

3. Change the value in the value field.

RESULT
The number and position of counts on the selected slash regions is changed. For example,
changing the start count from 1 to 2, with counts shown every four bars, causes the count to
appear on the third bar in the slash region instead of the fourth.

EXAMPLE

Two separate slash regions, where the start count on the second region has been changed so it appears to
continue on from the first region.

Changing the slash region count frequency
You can change how frequently counts are shown on slash regions independently of your
project-wide setting, for example, if you want to show the count after eight bars on a single slash
region. By default, slash region counts are shown every four bars.

PROCEDURE

1. Select any part of each slash region whose count frequency you want to change. You can
do this in Write mode and Engrave mode.

2. In the Properties panel, activate Count frequency in the Slash Regions group.

3. Change the value in the value field.

RESULT
The count frequency is changed for the selected slash regions.

TIP

You can also change the default count frequency for all slash regions project-wide in the
Rhythmic slashes section of the Notes page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for rhythm slashes on page 850
Splitting slash regions on page 853
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Changing the slash region count appearance
You can show individual slash region counts with or without parentheses, or not show any count
at all, independently of your project-wide setting.

PROCEDURE

1. Select any part of each slash region whose count appearance you want to change. You can
do this in Write mode and Engrave mode.

2. In the Properties panel, activate Count appearance in the Slash Regions group.

3. Select one of the following options from the menu:

● Parenthesized

● No parentheses

● Don’t show

RESULT
The appearance of counts on the selected slash regions is changed.

TIP

You can also change the default appearance of all slash region counts project-wide in the
Rhythmic slashes section of the Notes page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for rhythm slashes on page 850

Moving slash region counts
You can move individual slash region counts graphically without changing the rhythmic positions
to which they apply, for example, to accommodate other items at the same position better.

NOTE

If you want to move slash region counts because you want to change the bar to which the
number applies, you can change the start count instead.

PROCEDURE

1. In Engrave mode, select the slash region counts you want to move.

2. Move the selected slash region counts in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected slash region counts are moved to new graphical positions.

Rhythm slashes
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TIP

Count offset in the Slash Regions group of the Properties panel is activated automatically when
you move slash region counts in the corresponding directions:

● Count offset X moves slash region counts horizontally.

● Count offset Y moves slash region counts vertically.

You can also use this property to move slash region counts graphically by changing the values in
the value fields.

Deactivating the property resets the selected slash region counts to their default positions.

RELATED LINKS
Changing the start count of slash regions on page 856

Changing the placement of slash region counts relative to the staff
You can change whether counts on individual slash regions appear above or below the staff,
independently of your project-wide setting.

NOTE

Changing the placement of slash region counts relative to the staff affects all counts on the
region. You cannot change the placement of a single count independently of other counts on the
same slash region.

PROCEDURE

1. Select any part of each slash region whose count staff-relative placement you want to
change.

2. In the Properties panel, activate Count position in the Slash Regions group.

3. Choose one of the following options:

● Above

● Below

RESULT
The placement of all counts relative to the staff on the selected slash regions is changed.

TIP

You can change the default placement of all slash region counts project-wide in the Rhythmic
slashes section of the Notes page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for rhythm slashes on page 850
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Rests are markings with a rhythmic value that indicate no note is played for that duration. Each
note duration has an equivalent rest, for example, a quarter note rest is different to a sixteenth
note rest.

All notes and rests within a bar must add up to the duration of the bar, according to the
prevailing time signature.

The table shows some examples of notes and the rests with the equivalent rhythmic value.

Duration Note Rest

Half

Quarter

Eighth

Sixteenth

During note input, Dorico Pro automatically fills the gaps between notes with implicit rests of the
appropriate duration. Therefore, it is usually not necessary to input rests in Dorico Pro.

RELATED LINKS
Implicit vs. explicit rests on page 860
Inputting rests on page 164
Deleting rests on page 863

General placement conventions for rests
Rests are positioned at the rhythmic position at the start of their duration, and not in the middle
of beats as this can cause confusion over when the rest begins and ends. Rests are aligned with
other items at the same rhythmic position.

The only exception is whole bar rests, which are positioned at the visual center of bars. This way,
they are clearly distinguishable from half note and whole note rests that are followed by notes in
the same bar.

Rests
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Rests stay within the staff wherever possible. They do not move above or below the staff when
the notes around them are very high or very low.

However, on staves with multiple voices, rests are placed higher on the staff, or above the staff,
for up-stem voices and lower on the staff, or below the staff, for down-stem voices.

Example rest positions in a multiple-voice context

Rests in multiple voices must not overlap. You can consolidate rests so that only one is shown
when multiple voices have a rest of the same duration at the same rhythmic position.

The precise vertical positioning of rests is limited, as their detailed shapes require specific
positions relative to staff lines and staff spaces.

RELATED LINKS
Deleting rests on page 863
Turning explicit rests into implicit rests on page 862

Implicit vs. explicit rests
Implicit rests are automatically shown around the notes you input, and their duration
automatically follows the time signature and their position in the bar. Explicit rests are rests that
are explicitly entered during note input by forcing their duration, or rests that were imported
from a MusicXML file.

Dorico Pro notates implicit rests according to the current time signature, for example, different
implicit rests are shown in 6/8 compared to 4/4. This also applies if you later change the time
signature for existing notes and rests.

Therefore, it is not necessary to input rests in Dorico Pro, as implicit rests are automatically
shown around the notes that you input. You can turn implicit rests into explicit rests by forcing
their duration to be fixed.

A quarter note input at the fourth eighth note of the
bar in a 6/8 time signature has a dotted quarter
implicit rest at the start of the bar.

A quarter note input at the fourth eighth note of the
bar in a 4/4 time signature has two implicit rests, a
quarter and an eighth, at the start of the bar.

Explicit rests cannot be suppressed when using the Starts voice and Ends voice properties to
hide rests before the first note in voices and after the last note in voices.

You can show rest colors to see which rests are implicit and which are explicit in your project.

RELATED LINKS
Inputting rests on page 164
Forcing the duration of notes/rests on page 158
Turning explicit rests into implicit rests on page 862
Deleting rests on page 863
Showing rest colors on page 863
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Implicit rests in multiple-voice contexts
In Dorico Pro, implicit rests are shown automatically to fill in rhythmic positions around notes,
including when there are multiple voices on the staff. However, in these contexts you might want
more control over when and where rests are shown.

Usually, rests or notes are shown for whole bars when voices contain at least one note in the bar.
This helps make the rhythmic position of every note in all voices in the bar immediately clear.

When there are multiple voices on a staff, implicit rests are shown in every bar in which there are
notes of any duration in more than one voice. However, there might be circumstances in which
you do not want to show rests either before the first note in a voice or after the last note in a
voice when there are multiple voices on the staff. For example, it can be useful to hide rests when
a voice is being used to show passing notes within a bar that otherwise contains a single melodic
line.

A second voice used to notate passing notes

TIP

By default, Dorico Pro consolidates rests when multiple voices have rests of the same duration at
the same rhythmic position.

You can show multiple rests at individual rhythmic positions by changing the vertical position of
rests.

You can also change your project-wide settings for the consolidation of rests in multiple-voice
contexts on the Rests page in Notation Options.

You can hide rests before the first note in voices and after the last note in voices individually by
activating properties in the Properties panel. You can show rests that you have hidden by
deactivating the corresponding property.

A phrase with multiple voices showing implicit rests. The same phrase without implicit rests.

You can choose when rests are shown in a number of different multiple-voice contexts project-
wide on the Rests page in Write > Notation Options.

You can also delete rests from selected passages.

RELATED LINKS
Per-flow notation options for rests on page 862
Moving rests vertically on page 866
Deleting rests on page 863
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Turning explicit rests into implicit rests
Implicit rests and explicit rests behave differently. For example, you can hide implicit rests using
the Properties panel, but you cannot hide explicit rests or rests with forced durations.

NOTE

You can only hide implicit rests using Starts voice and Ends voice in the Notes and Rests group
of the Properties panel.

PROCEDURE

1. In Write mode, select the explicit rests you want to turn into implicit rests.

2. Press Backspace or Delete.

RESULT
The selected explicit rests are now implicit rests. You can check this by showing rest colors.

RELATED LINKS
Showing rest colors on page 863
Deleting rests on page 863

Per-flow notation options for rests
You can find per-flow options controlling how rests are positioned and notated, and when rests
are shown, on the Rests page in Notation Options.

For example, you can change whether bar rests are shown in additional voices, when dotted
rests are permitted, and the default positions of rests in different contexts.

You can open Notation Options in any of the following ways:

● Press Ctrl/Cmd-Shift-N in any mode.

● Choose Write > Notation Options in Write mode or Setup > Notation Options in Setup
mode.

● Click Notation Options in the Flows panel in Setup mode.

You can then click Rests in the page list.

Project-wide engraving options for rests
You can find options for the project-wide appearance of rests on the Rests page in Engrave >
Engraving Options.

The options on the Rests page allow you to change the style, appearance, width, and precise
position of rests, including multi-bar rests during flows and multi-bar rests at the end of flows.
For example, the default appearance of multi-bar rests at the end of flows is to show “tacet al
fine”, but you can show the total bar count instead.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299
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Showing rest colors
You can show implicit rests and explicit rests in different colors.

PROCEDURE

● Choose View > Note and Rest Colors > Implicit Rests.

RESULT
Rest colors are shown when a tick appears beside Implicit Rests in the menu, and hidden when
no tick appears.
When rest colors are shown, rests in your project appear gray if they are implicit, and black if
they are explicit. For example, this can be useful to help diagnose why rests do not disappear
when you activate Starts voice and Ends voice, as these properties only hide implicit rests.
Once you have identified rests as explicit rests, you can delete them. The implicit rests that
replace them now respect the Starts voice and Ends voice properties.

EXAMPLE

Rests colored black, as they appear without implicit
rests shown

Rests colored gray to indicate implicit rests

Deleting rests
You can delete both implicit rests and explicit rests, for example, if you want to hide rests before/
after notes in another voice used to show passing notes.

NOTE

● If you want to delete rests because multiple rests of the same duration appear at the same
position in multiple-voice contexts, you can choose to consolidate these rests in the Rest
positioning section of the Rests page in Notation Options.

● You cannot delete rests from unpitched percussion instruments.

PROCEDURE

1. In Write mode, select the rests you want to delete.

TIP

You can select rests individually, or make a larger selection that contains the rests you
want to delete.

2. Choose Edit > Remove Rests.

RESULT
All rests in the selection are deleted. This is done by automatically activating Starts voice and
Ends voice in the Notes and Rests group of the Properties panel so that no rests are shown in
the selected regions.

Rests
Showing rest colors 
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TIP

You can undo deleting rests immediately.

You can also show rests again later by selecting the notes or rests immediately to the right/left of
deleted rests and deactivating the corresponding Starts voice or Ends voice properties in the
Notes and Rests group of the Properties panel.

RELATED LINKS
Rests on page 859
Per-flow notation options for rests on page 862
Implicit vs. explicit rests on page 860
Large selections on page 274
Implicit rests in multiple-voice contexts on page 861

Hiding/Showing bar rests in empty bars
You can hide/show bar rests in empty bars in each layout in your project independently of other
layouts. For example, you can hide bar rests in full score layouts but show bar rests in part
layouts.

Bar rests are usually shown in empty bars in music to indicate to performers that they have
nothing to play. However, there are contexts in which it is preferable to hide bar rests in empty
bars, and instead leave the bar completely empty.

For example, hiding bar rests in empty bars is sometimes the preferred visual aesthetic in large
scores, so that it is quicker to identify bars containing music. You can also hide bar rests in
layouts where you want to include other instructions, such as verbal indications for performers
to do something other than play notated pitches.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show bar rests in empty
bars.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Players in the page list.

4. In the Bar Rests and Multi-bar Rests section, activate/deactivate Show bar rests in
empty bars.

5. Click Apply, then Close.

RESULT
All bar rests in empty bars in the selected layouts are shown when the checkbox is activated, and
hidden when the checkbox is deactivated.

RELATED LINKS
Hiding/Showing multi-bar rests on page 865

Multi-bar rests
Multi-bar rests group two or more consecutive empty bars together into a single unit, commonly
shown with a thick horizontal line positioned on the middle staff line, known as an “H-bar”. They
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can reduce the horizontal space required by multiple empty bars and can make it easier for
players to find their place in the music.

A multi-bar rest representing four empty bars

NOTE

Multi-bar rests are split by items positioned within their range, such as system text, rehearsal
marks, and holds and pauses. This includes when the items are invisible, except for hidden
tempo marks, such as those input in the Time track in Play mode. However, if items are
positioned at the start of the first bar in a multi-bar rest, that bar remains part of the subsequent
multi-bar rest.

You can hide/show multi-bar rests in each layout independently in Dorico Pro, and you can hide/
show bar number ranges below them.

By default, the multi-bar rest bar counts only appear once between the staves of grand-staff
instruments.

You can find options controlling the project-wide appearance, design, width, and content of
multi-bar rests on the Rests page in Engrave > Engraving Options.

RELATED LINKS
Hiding/Showing bar number ranges on multi-bar rests on page 526
Time track on page 421

Hiding/Showing multi-bar rests
You can hide/show multi-bar rests in each layout in your project independently of other layouts,
and choose whether bar repeats are consolidated into multi-bar rests. For example, you can hide
multi-bar rests in full score layouts but show multi-bar rests in part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show multi-bar rests.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Players in the page list.

4. In the Bar Rests and Multi-bar rests section, choose one of the following options for
Consolidate:

● None

● Multi-bar Rests

● Multi-bar Rests and Bar Repeats

5. Click Apply, then Close.

RESULT

● When you choose None, no multi-bar rests are shown in the selected layouts. Each empty
bar is shown separately.
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● When you choose Multi-bar Rests, any adjacent empty bars are consolidated into multi-
bar rests in the selected layouts. However, bar repeats prevent the consolidation of multi-
bar rests, even if there are no other notes in those bars.

● When you choose Multi-bar Rests and Bar Repeats, any adjacent empty bars or bars that
only contain bar repeats are consolidated into multi-bar rests in the selected layouts.
Multi-bar rest counts are also shown above consolidated bar repeats.

RELATED LINKS
Bar repeats on page 839
Multi-bar rests on page 864
Hiding/Showing bar number ranges on multi-bar rests on page 526

Hiding/Showing tacet al fine on multi-bar rests at the end of flows
You can change the appearance of multi-bar rests that extend to the end of flows in all layouts
project-wide. By default, multi-bar rests that extend to the end of flows show “tacet al fine” above
the staff instead of the total bar count.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Rests in the page list.

3. In the Multi-bar Rests section, choose one of the following options for Multi-bar rests
that extend to the end of the flow:

● Show tacet al fine

● Show bar count

4. Optional: Change the value for Minimum number of bars’ rest at the end of flow to
show ‘tacet al fine’.

5. Click Apply, then Close.

RESULT
The appearance of all multi-bar rests at the end of flows is changed project-wide. Changing the
value for Minimum number of bars’ rest at the end of flow to show ‘tacet al fine’ changes
when “tacet al fine” is shown to only multi-bar rests containing the set number of bars or more.

Moving rests vertically
You can change the vertical position of rests individually, for example, if you want to change the
staff line from which a whole bar rest hangs, or you want to show rests for all voices at a
particular rhythmic position.

Moving rests vertically shows multiple rests at that rhythmic position if more than one voice on
the staff has a rest of the same duration. By default, Dorico Pro consolidates rests in multiple-
voice contexts and automatically positions rests in multiple-voice contexts to avoid collisions.

NOTE

You cannot change the vertical position of rests when using the mouse.

PROCEDURE

1. Select the rests whose vertical positions you want to change, or rests at the rhythmic
positions where you want to see rests for every voice. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Rest pos. in the Notes and Rests group.
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3. Change the value in the value field.

RESULT
Increasing the value moves rests upwards, decreasing the value moves rests downwards.
Position 0 is the middle line of the staff.
If there are multiple voices on the staff with rests of the same duration, multiple rests are now
shown.

TIP

● Deactivating Rest pos. returns the selected rests to their default positions.

● You can choose to show all rests in every voice or only show one rest for all voices in the
Rest positioning section of the Rests page in Notation Options.

● You can change the horizontal position of rests, and the spacing around them, in Engrave
mode when Note Spacing is activated, in the same ways as changing the position of
notes.

RELATED LINKS
Notation Options dialog on page 139
Note spacing on page 381
Adjusting note spacing at individual rhythmic positions on page 388
Adjusting the spacing of individual notes/items independently of their rhythmic positions on
page 389
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Slurs are tapered, curved lines that join notes to indicate legato articulation and phrasing.

Depending on the context and the instrument to which they apply, slurs can have additional
meanings to simply marking phrases. For example, for wind players, a slur indicates that all the
notes in the phrase are played in the same breath and without re-tonguing or re-articulating any
notes. For string players, a slur indicates that all the notes in the phrase are played legato and
under one bow. For singers, slurs indicate that more than one note is sung to the same syllable.

Slurs can be placed both above and below the staff, depending on the stem directions of the
notes to which they apply. In order to keep slur endpoints close to notes, slurs are placed outside
articulations on notes in the middle of slurs, but between notes and larger articulations on the
first/last notes of slurs. For example, accents and stress marks are placed outside the ends of
slurs but staccato and tenuto marks are placed inside the ends of slurs by default.

Slurs both above and below the staff, including a cross-staff slur

You can change the placement of accent, marcato, stress, and unstress articulations relative to
slurs in the Slurs section of the Articulations page in Engrave > Engraving Options.

NOTE

Slurs must not be confused with ties, which look superficially similar, but instead join notes of the
same pitch to indicate that they are played as a single note. In that sense, ties are part of
rhythmic notation, while slurs are considered articulation.

RELATED LINKS
Inputting slurs on page 265
Ties on page 966
Project-wide engraving options for articulations on page 499

Slurs
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General placement conventions for slurs
The placement of slurs relative to the staff, and therefore their curvature direction, depends on
the stem direction of the notes within the slur. Depending on whether slurs are placed on the
notehead or stem side of notes, their endpoint positions are different.

Slur direction

A slur on a single staff always curves upwards and is placed above the notes, unless all of the
notes under the slur are up-stem, in which case it curves downwards and is placed below the
notes. If a slur applies to a mixture of up-stem and down-stem notes, it is placed above the staff
and curves upwards.

Examples of the slur direction changing according to the stem direction

You can set your preference for whether slurs follow the stem direction, or always appear above
notes, on the Slurs page in Engrave > Engraving Options.

NOTE

In jazz scores, slurs are sometimes treated as an articulation and so positioning all slurs above
the staff is preferred.

Stem-side slurs between unbeamed notes

In Dorico Pro, slurs appear between the stems of unbeamed notes when placed on their stem
side, and the default setting is for them to attach a short distance from the end of the stem.

You can change where slurs attach to stems by adjusting Vertical offset from end of stem in
the Endpoint Positioning section of the Slurs page in Engrave > Engraving Options.

RELATED LINKS
Slur endpoint position relative to other items on page 872

Slur position relative to tie chains
There are different conventions for the position of slurs relative to tie chains in music for modern
use and historical editions.

Modern practice is for slurs to start on the first note in tie chains, and end on the last note in tie
chains. This makes the full length of the phrase visually clear to the performer, which helps their
performance, and is the default in Dorico Pro.

Slur ending on the last note in a tie chain Slur starting from the first note in a tie chain
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However, in historical editions, slurs might end on the first note in a tie chain, and start on the
last note in a tie chain. Both of these changes save vertical space, as shorter slurs do not extend
as far above or below a staff.

Slur ending on the first note in a tie chain Slur starting on the last note in a tie chain

You can choose whether all slurs start on the first/last note in tie chains, and end on the first/last
note in tie chains, on the Slurs page in Engrave > Engraving Options. There are different
options for slurs between normal notes and slurs starting on grace notes.

Changing the position of slurs relative to tie chains
You can change the position of individual slurs relative to tie chains, including slurs starting on
grace notes, for example, to save vertical space.

PROCEDURE

1. Select the slurs whose position relative to tie chains you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate the following properties, individually or together, in the
Slurs group:

● Start pos. in tie chain

● End pos. in tie chain

3. Choose one of the following options for each property:

● First note

● Last note

RESULT
The position of the selected slurs relative to tie chains is changed.

TIP

You can change the default position of all slurs relative to tie chains project-wide on the Slurs
page in Engrave > Engraving Options. There are different options for slurs between normal
notes and slurs starting on grace notes.

RELATED LINKS
Project-wide engraving options for slurs on page 872

Slur placement relative to grace notes
There are specific placement rules that affect slurs when they start from a grace note and end on
a normal note immediately following the grace note.

These rules are:

● Slurs connect noteheads rather than stems.

● Slurs are scaled to match the proportions of grace notes.

● Slurs must not obscure ledger lines.

● Slurs are placed above notes if they would collide with the accidental of a standard note
when placed below the notes.

Slurs
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You can adjust the values for the different parameters of the special placement rules. For
example, you can change the vertical and horizontal offsets for the right-hand end of a grace
note slur relative to the standard, full-sized notehead to which it is attached in the Grace Notes
section of the Slurs page in Engrave > Engraving Options.

NOTE

These rules do not apply when slurs attach to a standard note at any rhythmic position beyond
the note immediately following the grace note.

Due to the general placement conventions of grace notes, slurs in Dorico Pro appear below grace
notes and curve downwards by default. Slurs starting from grace notes only appear above notes
and curve upwards in up-stem voices in multiple-voice contexts.

Automatic changes to the curvature direction of slurs on grace notes in multiple-voice contexts

You can change the automatic placement of grace note slurs by changing the stem direction of a
grace note, changing the direction of a slur, and using the slur handles in Engrave mode to
adjust the position of a slur in finer detail.

RELATED LINKS
Changing the curvature direction of slurs on page 888
Changing the stem direction of notes on page 946
General placement conventions for grace notes on page 658
Slurs in Engrave mode on page 879
Moving slurs and slur handles graphically on page 881

Slur position relative to staff lines
Slur endpoints must not touch staff lines, and the high point of the arcs of slurs should not stop
on staff lines.

This is the convention because a slur whose arc peaks on a staff line can create the appearance
of a triangular wedge between the staff line and the curve of the slur. If a slur peaks on a staff
line, you can adjust its height so that it peaks either above/below the staff.

NOTE

Although Dorico Pro automatically ensures slur endpoints do not touch staff lines, manual
adjustments might be necessary to position the arcs of slurs correctly.

You can set a value for the minimum distance between slur endpoints and staff lines in the
Avoiding Collisions section of the Slurs page in Engrave > Engraving Options. The default
position of slur endpoints relative to staff lines is 1/4 space above/below, to ensure the start/end
points do not touch the staff line.

RELATED LINKS
Project-wide engraving options for slurs on page 872
Changing the height of slurs on page 885
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Slur endpoint position relative to other items
In order to avoid collisions, the default positions of slur endpoints vary depending on whether
slurs are placed on the notehead side or stem side of notes, their position relative to staff lines,
and whether articulations, ties, and other slurs exist at the same rhythmic position.

Slur endpoints relative to noteheads and stems

The default position of slur endpoints relative to noteheads is 1/2 space above a notehead in a
space on the staff, and 1/4 space above a notehead on a line on the staff.

You can change the vertical and horizontal offsets for the endpoints of slurs in the Endpoint
Positioning section of the Slurs page in Engraving Options. However, you might also need to
reduce the value for Minimum gap inside slur curvature to avoid collisions in the Avoiding
Collisions section, as endpoints cannot be closer to noteheads than this value.

NOTE

This value affects all slur collisions in your project.

Slur endpoints relative to articulations

By default, articulations of force and stress are placed outside slur endpoints, and articulations of
duration are placed inside slur endpoints, which automatically raises the endpoints.

You can position slur endpoints closer to articulations by reducing the value for Minimum gap
inside slur curvature to avoid collisions in the Avoiding Collisions section of the Slurs page in
Engraving Options.

NOTE

Changing this value affects the position of slur endpoints project-wide. You may find it more
appropriate to move slur endpoints relative to articulations individually in Engrave mode.

Slur endpoints relative to ties and other slurs

The default position of slur endpoints is 1/4 space above an existing slur that starts/ends on the
same note.

You can change this by increasing/decreasing the value for Minimum vertical gap between two
slurs starting or ending on the same note in the Avoiding Collisions section of the Slurs page
in Engraving Options.

To make slurs appear closer to tied notes, you can adjust the values for slur endpoint position
relative to noteheads.

RELATED LINKS
Slurs in Engrave mode on page 879
Moving slurs and slur handles graphically on page 881
Articulations on page 497

Project-wide engraving options for slurs
You can find options for the project-wide appearance, position, and placement of slurs on the
Slurs page in Engrave > Engraving Options.

The options on the Slurs page allow you to change the direction, style, height, and thickness of
slurs. You can also set precise values for the positions of slurs relative to noteheads, stems, grace
notes, and ties, and change the collision avoidance behavior of cross-staff slurs.
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There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Cross-staff and cross-voice slurs
Cross-staff slurs start on one staff and end on another staff, and cross-voice slurs start in one
voice and end in another voice.

Dorico Pro positions cross-staff and cross-voice slurs in the same way as it positions standard
slurs, so their appearance might be the same as standard slurs. You can move and lengthen/
shorten cross-staff and cross-voice slurs in the same ways as standard slurs; however, they do
not behave in the same way.

For example, you cannot move cross-voice slurs to notes on the same staff in other voices, and
you cannot lengthen cross-voice slurs to notes on the same staff in other voices. You also cannot
shorten cross-voice slurs if noteheads under the slur are not in one of the voices in which the slur
started/ended.

You can only move and lengthen/shorten cross-staff slurs to notes on the same staff as the
corresponding endpoint. For example, if a cross-staff slur covers a phrase that starts on the
bottom staff and ends on the upper staff, you can only shorten the cross-staff slur to the first
note on the upper staff, you cannot shorten it to any notes on the bottom staff.

The different voices can be on the same staff, or on different staves.

RELATED LINKS
Lengthening/Shortening slurs on page 876
Moving slurs rhythmically on page 875

Inputting cross-staff and cross-voice slurs
You can input cross-staff and cross-voice slurs. For example, musical phrases in grand staff
instruments, such as piano and harp, can span both staves and may need slurs to join them.

PROCEDURE

1. In Write mode, select the note from which you want the slur to start, in any voice or staff.

2. Ctrl/Cmd-click the note where you want the slur to end, in any voice and on any staff
belonging to the same instrument as the note in step 1.

NOTE

Only select those two notes.

3. Press S.

RESULT
A cross-voice or cross-staff slur is input spanning the select notes. It is placed either above or
below the notes, depending on the stem direction of the notes within the selection.

AFTER COMPLETING THIS TASK
You can change the curvature direction of individual slurs.

RELATED LINKS
Changing the curvature direction of slurs on page 888
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Nested slurs
Nested slurs are two or more slurs used simultaneously, where the overarching slur shows the
structure of the phrase and the inner slurs show the articulation within the phrase. They are also
known as “slurs within slurs”.

Depending on the stem directions within the overarching outer slur and your settings on the
Slurs page in Engrave > Engraving Options, inner slurs may appear on the opposite side of the
staff to the outer slur.

A phrase with nested slurs

If you want to change the default distance between the endpoints of nested slurs, you can
increase/decrease the project-wide value for Minimum vertical gap between two slurs
starting or ending on the same note in the Avoiding Collisions section of the Slurs page in
Engraving Options.

You can input nested slurs in the same ways as inputting standard slurs. By default, Dorico Pro
makes automatic adjustments to their positioning to avoid collisions if you have not activated
Disable auto curve adjustment in the Slurs group of the Properties panel in Engrave mode.

RELATED LINKS
Enabling/Disabling slur collision avoidance on page 892

Inputting nested slurs during step input
You can input nested slurs directly during step input, for example, if you already know how you
want to phrase the notes you are currently inputting.

PROCEDURE

1. In Write mode, start note input.

2. Press S twice to start two slurs from the currently selected note.
One slur is the inner slur, the other slur is the outer slur.

3. Input your notes.
The slurs extend automatically as you continue inputting notes, even if there are rests
between the notes you input.

4. Press Shift-S once to end the inner slur on the currently selected note.

5. Continue inputting notes.

6. Optional: Start/End other inner slurs.

7. Press Shift-S again to end the outer slur on the currently selected note.

RELATED LINKS
Nested slurs on page 874
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Adding nested slurs to existing notes
You can add multiple slurs to existing notes so that they appear as nested slurs.

PROCEDURE

1. In Write mode, select the notes you want to include in the outer slur.

2. Press S to input the outer slur.

3. Select the notes within the outer slur that you want to place under an inner slur.

4. Press S to input the inner slur.

5. Optional: Repeat steps 3 and 4 for any other inner slurs you want.

NOTE

● You can input the outer slur and inner slurs in any order as Dorico Pro automatically
adjusts slurs so that shorter slurs are positioned within longer slurs, and makes sure
they do not collide.

● Slur collisions are not automatically avoided if you activate Disable auto curve
adjustment in the Slurs group of the Properties panel for individual notes.

RELATED LINKS
Slur collision avoidance on page 892

Moving slurs rhythmically
You can move slurs to new rhythmic positions after they have been input. They are positioned
according to your project-wide settings on the Slurs page in Engraving Options.

PROCEDURE

1. In Write mode, select the slurs you want to move.

NOTE

When using the mouse, you can only move one slur rhythmically at a time.

2. Move the slurs to the next or previous noteheads on the staff in any of the following ways:

● Press Alt-Right Arrow to move them to the next notehead on the staff.

● Press Alt-Left Arrow to move them to the previous notehead on the staff.

● Click and drag the slur to the right/left.

RESULT
The slurs are moved to the next or previous noteheads on the staff.

NOTE

The rhythmic duration of slurs is usually maintained. However, depending on the rhythms they
cross as they move, slurs may cover longer/shorter durations than before they were moved.

AFTER COMPLETING THIS TASK
You can adjust the shape and position of individual slurs graphically in Engrave mode.

RELATED LINKS
Slurs in Engrave mode on page 879
Moving slurs and slur handles graphically on page 881
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Lengthening/Shortening slurs
You can change the length of slurs rhythmically after they have been input.

NOTE

You can only lengthen/shorten cross-staff slurs to notes on the same staff as the corresponding
endpoint, and you can only lengthen/shorten cross-voice slurs to notes in the same voice as the
corresponding endpoint.

PROCEDURE

1. In Write mode, select the slurs you want to lengthen/shorten.

NOTE

When using the mouse, you can only lengthen/shorten one slur at a time.

2. Lengthen/Shorten the slurs in any of the following ways:

● Press Shift-Alt-Right Arrow to lengthen the slur to the next notehead.

● Press Shift-Alt-Left Arrow to shorten the slur to the previous notehead.

NOTE

Key commands lengthen/shorten items by moving their end only. You can move the
start of slurs by moving the whole slur, or by clicking and dragging the start handle.

● Click and drag the start/end of the slur to the next/previous notehead.

RESULT
The selected slurs are lengthened/shortened.

RELATED LINKS
Moving slurs rhythmically on page 875
Slurs in Engrave mode on page 879
Cross-staff and cross-voice slurs on page 873

Slurs linked across multiple staves
Slurs of the same duration at the same rhythmic position on multiple staves can be linked
together. This happens automatically when you copy and paste slurs or material including slurs
between staves, or enter them simultaneously.

If slurs are linked, moving one slur in the linked group moves any slurs linked to it in the same
way. Similarly, lengthening or shortening a slur in a linked group lengthens or shortens any slurs
linked to it in the same way.

However, deleting one slur in a linked group only deletes the slur selected, not the whole group.

Linked slurs appear highlighted when any slur in the linked group is selected.
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Three linked slurs with the top slur selected

You can also manually link and unlink slurs.

RELATED LINKS
Inputting slurs on page 265
Unlinking slurs on page 877
Disabling automatic linking of dynamics and slurs when pasting on page 279

Linking slurs together
Dorico Pro automatically links slurs of the same duration at the same rhythmic positions
together when you copy and paste slurs or material including slurs between staves, or enter
them simultaneously. However, you can also link slurs together manually.

PROCEDURE

1. In Write mode, select the slurs you want to link together.

NOTE

Only slurs that have the same duration and start at the same position can be linked
together.

2. Choose Edit > Slurs > Link. You can also choose this option from the context menu.

RESULT
The selected slurs are linked together.

RELATED LINKS
Slurs linked across multiple staves on page 876

Unlinking slurs
You can unlink slurs manually that were automatically linked together, for example, if you want
to lengthen/shorten them independently of each other.

PROCEDURE

1. In Write mode, select a slur from each linked group you no longer want to be linked.

2. Choose Edit > Slurs > Unlink. You can also choose this option from the context menu.

RESULT
All slurs linked to the selected slurs are unlinked.
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NOTE

You cannot only unlink a single slur from the group.

Slur segments
A standard slur consists of one segment. You can make more elaborate shapes with slurs with
multiple segments, for example, to allow you to create more complex slur shapes than are
possible with a single curved segment.

Adding more segments to a slur by default creates evenly spaced waves within its length.
Therefore, having more segments makes each wave shorter.

Slur with eight segments

In Engrave mode, you can move each segment graphically, independently of the other segments
in the slur, as each segment has its own set of five square handles. These allow you to form slurs
into unusual and complicated shapes.

NOTE

You may find that you need more segments than there are curves in your planned shape, as in
many cases you need a segment for each significant change of angle. In Dorico Pro, you can
increase/decrease the number of segments in a slur at any time.

An unusual slur shape created using five segments. The same slur, showing the positions of the handles
of all five segments.

RELATED LINKS
Moving slurs and slur handles graphically on page 881
Multi-segment slurs in Engrave mode on page 880

Changing the number of segments in individual slurs
You can change the number of segments in individual slurs, for example, to allow you to create
slurs with unusual shapes.

PROCEDURE

1. In Engrave mode, select the slurs whose number of segments you want to change.

2. In the Properties panel, activate Number of segments in the Slurs group.

3. Change the value in the value field.
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RESULT
Increasing the value increases the number of slur segments. Decreasing the value decreases the
number of slur segments.

AFTER COMPLETING THIS TASK
You can adjust the shape of slur segments in more detail using their handles.

NOTE

Handles on multi-segment slurs are connected to the corresponding type of handle on adjacent
segments. Moving handles causes any connected handles to move the same amount in the
opposite direction.

RELATED LINKS
Moving slurs and slur handles graphically on page 881

Slurs in Engrave mode
In Engrave mode, each slur has five square handles that you can move independently. When
using slur handles to edit slurs in Engrave mode, each handle adjusts the corresponding part of
the slur but can also affect the positions of other handles on the slur.

Slurs have the following handles in Engrave mode:

1 Left endpoint

2 Left control point

3 Slur height

4 Right control point

5 Right endpoint

For example, moving the left endpoint moves the start of a slur, but the rest of the handles stay
in their existing positions. However, moving the right control point also causes the slur height
handle to move. This gives you fine control over the shape of slurs, while ensuring the end result
remains curved and smooth.

NOTE

Multi-segment slurs have additional links between control point handles that affect how they
move in relation to other handles moving.

You can move these handles to change the shape of slurs with the keyboard, with the mouse,
and by using properties in the Slurs group of the Properties panel.

RELATED LINKS
Slur shoulder offset on page 886
Slur height on page 884
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Multi-segment slurs in Engrave mode
In Engrave mode, each segment in multi-segment slurs, such as S-shaped slurs, has handles just
like standard slurs. This allows you to edit each segment of multi-segment slurs independently as
if they were separate slurs, but in order to maintain a consistent shape, moving certain handles
causes other handles to move simultaneously.

Multi-segment slurs have the following handles in Engrave mode:

1 Left endpoint

2 Left control point

3 Slur height

4 Right control point

5 Center control point

6 Left control point

7 Slur height

8 Right control point

9 Right endpoint

You can select and move each handle in the same ways as for standard slurs; however, handles
on multi-segment slurs are connected between adjacent segments. Moving a connected control
point causes the control point at the start/end of the next/previous segment to move the same
amount in the opposite direction. This avoids tight corners, ensuring that multi-segment slurs
are always as smoothly and symmetrically curved as possible.

In multi-segment slurs, right control points are connected to the left control point in the adjacent
segment. If there is no adjacent segment, the right/left control points next to the right/left
endpoints can be moved independently. For example, in the labelled diagram, the control point 4
is connected to control point 6, but control points 2 and 8 are not connected to another control
point.

Similarly, moving the slur height handle causes the slur height handle on any adjacent segments
to move the same amount in the opposite direction. For example, if you move the slur height
handle on the middle segment of a slur with three segments, all three slur height handles are
moved.
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EXAMPLE

The left control point is selected. Moving the selected left control point upwards and
to the left causes the right control point on the
adjacent segment to move downwards and to the
right.

Moving slurs and slur handles graphically
You can move whole slurs and individual slur handles graphically, for example, if you want to
change the shape of individual slurs or move individual slur endpoints. This only changes the
appearance of slurs, and does not change the rhythmic positions to which they are attached.

PROCEDURE

1. In Engrave mode, select the whole slurs or individual slur handles you want to move in any
of the following ways:

● Ctrl/Cmd-click multiple slurs.

● Select a whole slur and press Tab to cycle through the handles until the one you
want to move is selected.

● Click the handle you want to move.

● Ctrl/Cmd-click individual handles on multiple slurs.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the slurs or handles in any of the following ways:

● Press Alt-Right Arrow to move handles to the right.

● Press Alt-Left Arrow to move handles to the left.

● Press Alt-Up Arrow to move slurs or handles upwards.

● Press Alt-Down Arrow to move slurs or handles downwards.

TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag the slurs upwards/downwards.

● Click and drag the handles in any direction.

NOTE

You cannot move whole slurs to the right/left, you can only move them upwards/
downwards.

3. Optional: Repeat steps 1 and 2 for any other slurs or slur handles you want to move.
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RESULT
The selected slurs or slur handles are moved. Depending on the handles you selected, this can
change the shape of the corresponding slurs.

TIP

The following properties in the Slurs group of the Properties panel are activated automatically
when you move the corresponding slur handles:

● Start offset moves the left endpoints of slurs. X moves them horizontally, Y moves them
vertically.

● End offset moves the right endpoints of slurs. X moves them horizontally, Y moves them
vertically.

● Start handle offset moves the left control points of slurs. X moves them horizontally, Y
moves them vertically.

● End handle offset moves the right control points of slurs. X moves them horizontally, Y
moves them vertically.

For example, if you move a whole slur upwards and to the right, all of its handles are moved so
all properties are activated. You can also use these properties to change the shape of individual
slurs by changing the values in the value fields.

Deactivating the properties resets the corresponding handles on the selected slurs to their
default positions.

RELATED LINKS
Slur height on page 884
Slur shoulder offset on page 886

Changing the angle of slurs
You can change the angle or rotation of individual slurs without affecting their overall shape.

This is useful, for example, if you want one end of a slur to start higher after a system break than
its default position, as you can change the rotation of the slur while keeping all slur handles on
the slur in the same positions relative to each other.

PROCEDURE

1. In Engrave mode, select an endpoint on the slurs whose angle you want to change.

TIP

● You can select individual handles on multiple slurs by holding down Ctrl/Cmd and
clicking.

● You can show handles on all items, not just selected items, by choosing Engrave >
Show Handles > Always. This can make it easier to select individual handles on
multiple items.

2. Alt-click and drag the endpoints in any direction.

NOTE

You cannot use the keyboard to change the angles of individual slurs.

RESULT
The angle or rotation of the selected slurs is changed without affecting their shape.
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EXAMPLE

Endpoint moved without holding Alt Endpoint moved while holding Alt

Changing the thickness of slurs
You can change the thickness of individual slurs, including changing the thickness of the middle
of slurs independently of the ends of slurs, independently of your project-wide settings.

PROCEDURE

1. In Engrave mode, select the slurs whose thickness you want to change.

2. In the Properties panel, activate the following properties, individually or together, in the
Slurs group:

● End thickness

● Middle thickness

3. Change the values in the value fields.

RESULT
Increasing the values makes the corresponding part of the selected slurs thicker, decreasing the
values makes the corresponding part of the selected slurs thinner.

TIP

● Deactivating the properties returns the corresponding part of the selected slurs to their
default thickness.

● You can change the default thickness of all slurs project-wide on the Slurs page in
Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for slurs on page 872

Short slurs that cover large pitch ranges
When short slurs span large pitch ranges, they are significantly rotated to compensate. This can
make the ends of short slurs appear too angular.

You can move the control point handles of slurs to improve their curves.

Of the three examples, the middle slur has the smoothest curve. The handles on the slur on the
right have been moved poorly, making the curve far too angular.

In the bottom row, the positions of the handles are shown to indicate how each curve above was
created.
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Short slur spanning a large pitch
range, without adjustment

The same slur with some shape
adjustment, making the curve
smoother

The same slur again with poor
adjustment, making the curve too
angular

Default slur handle placement Slur handle placement to create
the corresponding slur

Slur handle placement to create
the corresponding slur

TIP

When adjusting slur ends, you can achieve the best results using the following guidelines:

● The control point at the lower end of the slur does not extend outside the width of the slur,
as marked by its neighboring endpoint.

● The control point at the higher end of the slur does not form an angle greater than 90
degrees relative to the endpoints. You can use the dashed lines to help you judge this.

You can adjust the shape of short slur ends in different ways:

● Project-wide, by increasing the value for Offset shoulders by fraction of half length of
short slur, which you can find by clicking Advanced Options in the Design section of the
Slurs page in Engrave > Engraving Options.

● Individually, by activating Start handle offset and End handle offset in the Properties
panel in Engrave mode, and changing their X values.

● Individually, by moving the handles of slurs in Engrave mode.

RELATED LINKS
Slurs in Engrave mode on page 879
Project-wide engraving options for slurs on page 872
Moving slurs and slur handles graphically on page 881

Slur height
The height of slurs determines how far above/below notes slurs extend vertically.

You can change values for the heights of all slurs project-wide on the Slurs page in Engraving
Options. You can also change the height of individual slurs in Engrave mode.

Increasing the height of slurs makes them extend further from the staff. This gives them a
rounder shape, which takes up more vertical space. Where vertical space is limited, there should
be a balance between how curved slurs are, which can help readability for players, and ensuring
staves do not overlap.

A long slur with default height A long slur with increased height
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A long flat slur with default height A long flat slur with increased height

TIP

You can find options that change project-wide values for the height of short slurs, short flat slurs,
long slurs, and long flat slurs by clicking Advanced Options in the Design section of the Slurs
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for slurs on page 872

Changing the height of slurs
You can change the height of individual slurs independently of your project-wide settings, for
example, to reduce the height of a particularly long slur.

PROCEDURE

1. In Engrave mode, select the slur height (middle) handle of the slurs whose height you
want to change.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the handles in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

● Click and drag them upwards/downwards.

RESULT
The height of the selected slurs is changed.

NOTE

● To maintain a visually pleasing and symmetrical curve when changing the height of slurs
manually, you may need to move slur height handles to the right/left by a small amount,
as well as upwards/downwards.

● Moving slur height handles to the right/left affects the shape of the whole slur.

● You can find options controlling the default height of all slurs project-wide by clicking
Advanced Options in the Design section of the Slurs page in Engrave > Engraving
Options. There are separate settings for short slurs and long slurs.

RELATED LINKS
Moving slurs and slur handles graphically on page 881
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Slur shoulder offset
Slur shoulders affect the angles of the curves of slurs as they taper towards an endpoint, because
the tapered ends often approach noteheads at a steeper angle than that of a slur’s arch.

Increasing the shoulder offset makes the onset of the curve shallower, whereas decreasing the
shoulder offset makes the onset steeper. The shoulder offset must therefore be balanced with
the height of the slur in order to achieve the ideal curved shape.

A long slur with default shoulder
offset of 1/5

A long slur with increased
shoulder offset of 1.5

A long slur with decreased
shoulder offset of 1/2

You can change the project-wide settings for the shoulder offset of slurs and the shoulder offset
of flat slurs by changing the values of the following options, which you can find by clicking
Advanced Options in the Design section of the Slurs page in Engraving Options.

● Offset shoulders by fraction of half length of short slur

● Offset shoulders by fraction of half length of long slur

● Offset shoulders by fraction of half length of flat slur

You can adjust the shoulders of individual slurs in Engrave mode.

RELATED LINKS
Slur height on page 884

Changing the shoulder offset of slurs
You can adjust the shoulders of individual slurs, independently of your project-wide settings, by
moving their control point handles. You can move each control point independently.

PROCEDURE

1. In Engrave mode, select one of the control point handles on each of the slurs whose
shoulders you want to adjust in any of the following ways:

● Select a whole slur and press Tab to cycle through the handles until the one you
want to move is selected.

● Click the handle you want to move.

● Ctrl/Cmd-click individual handles on multiple slurs.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.
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TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

3. Optional: Repeat steps 1 and 2 for the other control point handle on the slurs whose
shoulders you want to adjust.

RESULT
The shoulder offset of the selected slurs is changed.

TIP

● The following properties in the Slurs group of the Properties panel are activated
automatically when you move the corresponding slur handles:

● Start handle offset moves the left control points of slurs. X moves them
horizontally, Y moves them vertically.

● End handle offset moves the right control points of slurs. X moves them
horizontally, Y moves them vertically.

You can also use these properties to change the shoulder offset of individual slurs by
changing the values in the value fields.

Deactivating the properties resets the corresponding handles on the selected slurs to their
default positions.

● You can find options controlling the default shoulder offset of all slurs project-wide by
clicking Advanced Options in the Design section of the Slurs page in Engrave >
Engraving Options. There are separate settings for short slurs and long slurs.

RELATED LINKS
Project-wide engraving options for slurs on page 872

Slur curvature direction
Slurs can curve upwards, downwards, or have a multi-segment S-shape.

The following options for slur curvature direction are available when you activate Direction in
the Slurs group of the Properties panel:

Up
Forces slurs to curve upwards, and appear above notes.

Down
Forces slurs to curve downwards, and appear below notes.

Up/Down
Forces slurs to comprise two segments: the first curves upwards, the second curves
downwards to create a mirrored S-shape. It is typically used when phrases start in
the lower staff and end in the upper staff, for example, in piano parts.
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Down/Up
Forces slurs to comprise two segments: the first curves downwards, the second
curves upwards to create an S-shape. It is typically used when phrases start in the
upper staff and end in the lower staff, for example, in piano parts.

TIP

You can adjust the precise shapes of individual slurs, and each slur segment, in Engrave mode
using the square handles on each slur.

RELATED LINKS
Slurs in Engrave mode on page 879
Moving slurs and slur handles graphically on page 881

Changing the curvature direction of slurs
You can change the curvature direction of individual slurs so that they curve upwards,
downwards, or have a multi-segment S-shape, independently of your project-wide settings.

PROCEDURE

1. Select the slurs whose curvature direction you want to change. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, activate Direction in the Slurs group.

3. Choose one of the following options:

● Up

● Down

● Up/Down (mirrored S-shape)

● Down/Up (S-shape)

RESULT
The curvature direction of the selected slurs is changed.

TIP

● You can adjust the precise shapes of slurs, and each slur segment, in Engrave mode using
the handles on each slur.

● You can change the default curvature direction behavior of all slurs project-wide on the
Slurs page in Engrave > Engraving Options.

RELATED LINKS
Slurs in Engrave mode on page 879
Moving slurs and slur handles graphically on page 881

Slur styles
There are different styles of slurs available in Dorico Pro, which indicate different meanings and
have different use cases.

The following options for slur style are available when you activate Style in the Slurs group of the
Properties panel:
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Solid
This is the default style for slurs. Slurs appear as tapered solid lines: thinner at the
ends and thicker in the middle.

Dashed
Slurs appear as tapered dashed lines. Can be used to indicate an optional slur, for
example, to recommend breathing/bowing patterns.

Dotted
Slurs appear as dotted lines. The dots are the same size and the same distance apart
over the whole length of the slur.

Half-dashed start
The first halves of slurs appear as dashed lines, the second halves as solid lines. Used
to denote that a slur was written incompletely in the source in critical editions.

Half-dashed end
The first halves of slurs appear as solid lines, the second halves as dashed lines. Used
to denote that a slur was written incompletely in the source in critical editions.

Editorial
Slurs appear as solid black lines, but with a smaller vertical line intersecting them
exactly halfway along their length, perpendicular to the curve of the slur. Used to
show that a slur was added by the editor and was not present in the original source.

TIP

You can set the precise parameters of each of these options project-wide on the Slurs page in
Engrave > Engraving Options. For example, you can change the length and width of the stroke
in Editorial slurs, the diameter of dots and length of dashes, and the sizes of the gaps between
dots and dashes.

Changing the style of slurs
You can change the style of individual slurs after they have been input.

PROCEDURE

1. Select the slurs whose style you want to change. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Style in the Slurs group.

3. Select one of the following options from the menu:
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● Solid

● Dashed

● Dotted

● Half-dashed start

● Half-dashed end

● Editorial

Changing the size of dashes/dots in slurs
You can change the length of dashes and the size of dots in dashed/dotted slurs individually,
independently of your project-wide settings.

NOTE

This only applies to dashed/dotted slurs.

PROCEDURE

1. In Engrave mode, select the dashed/dotted slurs whose dash length/dot size you want to
change.

2. In the Properties panel, activate one of the following properties in the Slurs group:

● For dashed slurs, activate Dash length.

● For dotted slurs, activate Dot size.

3. Change the value in the value field.

RESULT
Increasing the value makes dashes longer and dots bigger, decreasing the value makes dashes
shorter and dots smaller.

TIP

You can find options to set the default size of dashes/dots in all dashed/dotted slurs project-wide
by clicking Advanced Options in the Design section of the Slurs page in Engrave > Engraving
Options.

RELATED LINKS
Project-wide engraving options for slurs on page 872

Changing the size of gaps in dashed/dotted slurs
You can change the length of gaps in dashed/dotted slurs individually, independently of your
project-wide settings.

PROCEDURE

1. In Engrave mode, select the dashed/dotted slurs whose gap length you want to change.

2. In the Properties panel, activate one of the following properties in the Slurs group:

● For dashed slurs, activate Dash gap length.

● For dotted slurs, activate Dot gap length.

3. Change the values in the value fields.

Slurs
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RESULT
Increasing the values makes the gaps between dashes/dots larger. Decreasing the values makes
the gaps between dashes/dots smaller.

TIP

You can find options to set the default length of the gaps between dashes/dots in all dashed/
dotted slurs project-wide by clicking Advanced Options in the Design section of the Slurs page
in Engrave > Engraving Options.

Changing individual slurs to flat slurs
Although they are not often used as standard, some publishers use flat slurs in order to reduce
the vertical space occupied by slurs. You can change individual slurs to flat slurs, independently
of your project-wide setting.

Short slurs, that is, slurs between only a few notes, can look odd as flat slurs, so it may not be
appropriate to select the flat curvature style project-wide. However, it would likewise be unusual
only to use flat slurs once or twice in a project.

NOTE

We recommend that you avoid changing the curvature style for only one or two slurs in a project.
It can be more effective to modify them rather than changing their curvature style, for example,
by making an individual slur thicker/thinner, adjusting the shoulder offset of slurs, or adjusting
their height using their slur height handles in Engrave mode.

PROCEDURE

1. Select the slurs whose curvature style you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Curvature style in the Slurs group.

3. Choose one of the following options:

● Normal (curved)

● Flat

RESULT
The curvature style of the selected slurs is changed.

TIP

You can change the curvature style of all slurs project-wide in the Design section of the Slurs
page in Engrave > Engraving Options.

RELATED LINKS
Changing the thickness of slurs on page 883
Changing the height of slurs on page 885
Changing the shoulder offset of slurs on page 886
Project-wide engraving options for slurs on page 872
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Slur collision avoidance
By default, Dorico Pro automatically adjusts the shape and position of slurs to avoid collisions
with items under their arc.

This means that if a notehead under a slur is either higher than the others under a slur curving
upwards, or lower than the others under a slur curving downwards, the curvature of the slur is
adjusted to avoid the collision and keep the notehead under the slur. You can manually disable
collision avoidance for individual slurs.

In the Avoiding Collisions section of the Slurs page in Engrave > Engraving Options, you can
choose options for how slurs are adjusted to avoid collisions, such as choosing a balance
between changing the shape of slurs to compensate or moving the endpoints of a slur, and how
asymmetrical slurs are allowed to be.

Slur with collision avoidance activated (default) Slur with collision avoidance deactivated

Collision avoidance for cross-staff slurs

In the Avoiding Collisions section of the Slurs page in Engrave > Engraving Options, you can
activate/deactivate collision avoidance for cross-staff slurs.

This avoids collisions, but due to the increased complexity in positioning slurs across staves,
further manual adjustment in Engrave mode might be required.

NOTE

This setting does not apply to S-shaped slurs between staves, which do not have any collision
avoidance.

Slurs bisecting flat accidentals

According to conventions in published music, slurs can bisect the stems of flat accidentals, but
not sharps or naturals, to save vertical space.

You can choose not to allow slurs to bisect flat signs, or alter the maximum amount of the stems
of flat signs that can protrude above slurs, on the Slurs page in Engraving Options.

RELATED LINKS
Project-wide engraving options for slurs on page 872

Enabling/Disabling slur collision avoidance
You can allow or prevent individual slurs from automatically adjusting to avoid collisions,
independently of your project-wide settings.

PROCEDURE

1. In Engrave mode, select the slurs whose collision avoidance you want to enable/disable.
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2. In the Properties panel, activate/deactivate Disable auto curve adjustment in the Slurs
group.

RESULT
The selected slurs do not avoid collisions when the property is activated, and avoid collisions
when the property is deactivated.

TIP

You can enable/disable slur collision avoidance for all cross-staff slurs project-wide in the
Avoiding Collisions section of the Slurs page in Engrave > Engraving Options.

You can also customize the default settings for the shape and endpoint positions of slurs that are
avoiding collisions in this section.

Slurs over system and frame breaks
Slurs automatically cross system breaks and frame breaks.

A system or frame break divides slurs into two parts. The end of the first part of the slur, and the
start of the second part of the slur, are both positioned 1 space vertically outside the staff by
default.

In Engrave mode, you can move and edit each slur part separately. This allows you to adjust the
start/end height of each slur part independently on each system.

If multiple slurs cross the same system break or frame break, such as if a phrase split by a break
contains nested slurs, the ends of the slurs are stacked automatically and spaced a minimum of
1/2 space apart vertically.

The end of a system showing the first slur part; the
end on the right indicates a continuation to the next
system.

The start of the next system showing the second slur
part; the end on the left indicates a continuation
from the previous system.

RELATED LINKS
Slurs in Engrave mode on page 879
Moving slurs and slur handles graphically on page 881

Slurs in playback
Slurs trigger the legato playing technique in playback. By default, this increases the length of the
MIDI notes without affecting the notation of the music.

Slurred notes sound for 105% of the length indicated by their notated rhythm, as opposed to
non-slurred notes which sound for 85% of their notated rhythm.

The final note of a slur sounds for 85% of its notated rhythm, as there is no slur after it and the
legato technique is no longer required.

You can change these values on the Timing page in Play > Playback Options.

The example shows how MIDI note length, indicated by the filled, light-colored rectangles, is
increased when slurs are used. The thin, darker rod shows the notated duration of each note.
The first three notes are non-slurred, so the MIDI length rectangle is shorter than the line of the
notated rhythm. The last four notes are slurred together, so the MIDI length is longer than the
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notated length in order to create the legato, slurred sound. However, the last note of the slurred
group is not longer, as the last note of a slurred phrase is treated like a normal, non-slurred note.

A phrase in an instrument staff The same phrase in the piano roll in Play mode

RELATED LINKS
Playback Options dialog on page 405
Played vs. notated note durations on page 466
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Staff labels are used to identify staves in music containing multiple players, and are positioned to
the left of systems, before the initial barline of each system. Staff labels indicate the instrument
or instruments currently playing the music on the staff or staves to which they apply.

It is usual to show instrument names in full in the staff labels for the first systems in each flow,
and abbreviated instrument names in the staff labels of subsequent systems. Using abbreviated
instrument names saves horizontal space, allowing you to include more music in each system.

Examples of staff labels on the first system in a flow

In Dorico Pro, staff labels use the instrument names set for each instrument in the Edit
Instrument Names dialog. In the dialog, you can specify singular and plural names for each
instrument, and singular and plural abbreviations for each instrument.

TIP

You do not need to number instruments in staff labels manually, as Dorico Pro automatically
numbers instruments when there are multiple players of the same type playing instruments of
the same type.

Part layouts by default do not show staff labels, as most parts only contain a single staff whose
identity is clear from the context and the layout name. The layout name is shown at the top left
of the first page in part layouts by default.

NOTE

Layout names are different to the instrument names used for staff labels.

For players holding multiple instruments, the staff label shows the instrument they are currently
playing. If the player changes instrument partway through a system, the name of the new
instrument is shown above the staff at its first note and the staff label is updated at the start of
the next system.

Staff labels
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NOTE

Staff labels do not show all instruments held by players, for example, in the staff label for the first
system. You should include a comprehensive instrumentation list that shows any doubling at the
front of your score.

Dorico Pro includes the instrument transposition, or instrument pitch, in staff labels for
transposing instruments by default. Transposing instruments are instruments whose sounding
pitch is different to the notated pitch.

You can change when instrument transpositions, or instrument pitches, are shown in staff labels.
You can also change whether the instrument transposition is shown before or after the
instrument name in staff labels.

Staff labels imported from MusicXML files

When exporting MusicXML files from Cubase and importing them into Dorico Pro, you can
improve the accuracy of the automatic instrument selection by changing the instrument names
in the Cubase Score Editor to the same English instrument names that Dorico Pro uses before
exporting the file.

RELATED LINKS
Player, layout, and instrument names on page 96
Instrument numbering on page 103
Edit Instrument Names dialog on page 97
Changing instrument names on page 101

Instrument names in staff labels
Staff labels use the instrument names set for each instrument, and instruments with the same
instrument names are automatically numbered. Staff labels can show full or short instrument
names.

On the Staves and Systems page in Setup > Layout Options, you can choose whether you want
to show full, short, or no instrument names in staff labels in each layout independently.

● Full staff labels use full instrument names.

● Abbreviated staff labels use short instrument names.

● None shows no staff labels.

You can change the full and short instrument names for each instrument in the Edit Instrument
Names dialog in Setup mode.

NOTE

Changing instrument names does not change the name shown at the top of each part layout, as
that uses the layout name. You can change the layout name in Setup mode.

It is usual to number instruments when there are multiple players holding the same type of
instrument. For example, if there are four horn players in an orchestra, they are usually called
Horn 1, Horn 2, Horn 3, and Horn 4.

In Dorico Pro, instruments are automatically numbered. This also applies to players holding
multiple instruments. For example, if an ensemble contains two flute players and a piccolo
player, but the second flute is also holding a piccolo, then the instruments are numbered in the
following way:

● Flute 1

● Flute 2 & Piccolo 1
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● Piccolo 2

You can move individual instruments to different players if you want to change which numbered
instruments are held by each player. For example, if you want the second flute to double second
piccolo rather than first piccolo, you can swap the piccolo instruments between the players.

RELATED LINKS
Player, layout, and instrument names on page 96
Changing the length of staff labels project-wide on page 899
Edit Instrument Names dialog on page 97
Instrument numbering on page 103
Changing instrument names on page 101
Changing layout names on page 100
Moving instruments between players on page 107

Staff label paragraph styles
Staff labels use paragraph styles to format their fonts, including their size, spacing, alignment,
and other formatting options. When staff labels contain multiple separate parts, such as when
the instrument name and instrument number have different vertical positions, you can format
each part separately.

Dorico Pro provides the following default paragraph styles for staff labels:

● Staff Labels
The default style used for staff labels that have the instrument name and number aligned
and next to each other. It is also used for the group labels on divisi staves and for
instrument names aligned between multiple identical instruments.

● Staff Labels (Inner)
Used for individual staves within divisi groups and for instrument numbers when
instrument names are aligned between multiple identical instruments.

● Staff Labels (Percussion Grid)
Used for percussion kits in layouts using the grid presentation.

You can edit each paragraph style independently of each other in the Paragraph Styles dialog,
for example, if you want outer staff labels to be left-aligned but inner staff labels to be right-
aligned.

TIP

You can make further changes to the appearance and alignment of staff labels on divisi staves at
each individual divisi change.

RELATED LINKS
Paragraph Styles dialog on page 366
Editing divisi staff labels individually on page 937

Project-wide engraving options for staff labels
You can find options for the project-wide appearance and position of staff labels on the Staff
Labels page in Engrave > Engraving Options.

For example, you can change the distance between staff labels and the systemic barline and
whether instruments are numbered using Arabic or Roman numerals. You can also determine
whether a single instrument name for adjacent identical solo instruments is grouped and shown
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justified between their staves or shown on each staff, and whether vocal staff labels are
uppercase or title case. There are also options specifically for ossia staff labels.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

TIP

You can change the length of staff labels shown on systems for each layout independently on the
Staves and Systems page in Setup > Layout Options.

RELATED LINKS
Engraving Options dialog on page 299
Changing the staff label numbering style on page 899
Showing vocal staff labels in uppercase/title case on page 899

Grouping the staff labels of adjacent identical instruments
When multiple adjacent solo players hold the same instrument, you can group them so that
there is only a single instrument name for all staves with the instrument number shown beside
each individual staff.

By default, every staff is shown with its own staff label, including the appropriate instrument
name.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Staff Labels in the page list.

3. For Staff labels for identical adjacent solo instruments, choose Group between staves.

4. Click Apply, then Close.

RESULT
A single instrument name is shown justified between all adjacent identical solo instruments in all
layouts project-wide.

EXAMPLE

Each staff shown with a separate staff label Staff labels grouped between adjacent identical solo
instruments

Staff labels
Project-wide engraving options for staff labels 

898
Dorico 2.2.20



Changing the staff label numbering style
You can change the staff label numbering style of solo and section players independently, for
example, if you want solo players to use Arabic numerals, such as “2”, and section players to use
Roman numerals, such as “II”.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Staff Labels in the page list.

3. Choose one of the following options for Numbering style for solo players:

● Arabic numerals

● Roman numerals

4. Choose one of the following options for Numbering style for section players:

● Arabic numerals

● Roman numerals

5. Click Apply, then Close.

RESULT
Instruments held by solo and section players use the selected numbering style in all layouts
project-wide.

Showing vocal staff labels in uppercase/title case
You can show the staff labels on vocal staves in uppercase letters or in title case. Many European
publishers prefer vocal staves to have staff labels with capital letters, but this is not true of all
publishers.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Staff Labels in the page list.

3. For Labels for vocal staves, choose one of the following options:

● Shown in uppercase

● Shown in title case

4. Click Apply, then Close.

RESULT
Staff labels on all vocal staves project-wide use either uppercase letters or title case.

Changing the length of staff labels project-wide
You can show full, abbreviated, or no instrument names in staff labels project-wide depending on
their context in each layout independently.

By default, full staff labels are shown on the first system of each flow and abbreviated staff labels
are shown on subsequent systems in full score layouts. In part layouts, staff labels are not shown
on any systems.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.
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2. In the Layouts list, select the layouts in which you want to change the length of
instrument names in staff labels.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Staff Labels section, select one of the following options from the Staff labels on
first system menu:

● Full

● Abbreviated

● None

5. Select one of the following options from the Staff labels on subsequent systems menu:

● Full

● Abbreviated

● None

6. Click Apply, then Close.

RESULT
The staff labels are changed project-wide in the selected layouts.

TIP

● You can change both full and short instrument names in the Edit Instrument Names
dialog.

● Your per-layout settings for staff labels apply to each flow, not the whole project. For
example, if you want to show full staff labels on the first system in the first flow in your
project, but do not want to show full staff labels on the first system of subsequent flows,
you must change the staff labels at the start of each subsequent flow individually.

RELATED LINKS
Instrument names in staff labels on page 896
Changing instrument names on page 101
Edit Instrument Names dialog on page 97
Changing the length of staff labels at specific positions on page 901

Changing the minimum indent for systems with staff labels
You can change the default minimum indent for all systems that show staff labels project-wide to
optimize horizontal space. You can have different minimum indents in each layout
independently.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts whose minimum indent for systems with staff labels
you want to change.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Staff Labels section, change the value for Minimum indent for systems with staff
labels.
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5. Click Apply, then Close.

RESULT
The minimum indent on all systems that show staff labels is changed project-wide in the selected
layouts.

RELATED LINKS
System indents on page 927
Changing the first system indent on page 927
Changing the start/end position of systems on page 390

Changing the length of staff labels at specific positions
You can change whether staff labels at specific positions show full, abbreviated, or no instrument
names, independently of your per-layout settings. For example, if you want full staff labels at the
start of the first flow but abbreviated staff labels at the start of subsequent flows, or if you want
to show staff labels in choral music only on systems that contain more complicated parts, solo
lines, or divisi lines.

PREREQUISITE

● You have inserted a system or frame break at the position from which you want to change
the length of instrument names in staff labels.

● Signposts are shown for system/frame breaks.

PROCEDURE

1. In Engrave mode, select the system/frame break signpost at the position where you want
to change the staff labels.

2. In the Properties panel, activate Staff labels in the Format group.

3. Select one of the following options from the menu:

● Full

● Abbreviated

● None

RESULT
The length of the instrument names shown in the staff labels is changed. This only affects the
system on which the system/frame break occurs. Horizontal spacing is automatically adjusted so
the system fills the width of the music frame.
Deactivating the property returns any selected system break signposts to your per-layout
settings.

EXAMPLE

Full staff labels shown No staff labels shown
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RELATED LINKS
Changing the length of staff labels project-wide on page 899
Inserting system breaks on page 359
Inserting frame breaks on page 357
Hiding/Showing system break signposts on page 360
Hiding/Showing frame break signposts on page 358

Hiding/Showing instrument change labels at the start of
flows

You can hide/show instrument change labels at the start of each flow in each layout
independently. These labels can be useful for players holding multiple instruments as a way of
clarifying the instrument required in their part layouts, which do not normally show staff labels.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show instrument change
labels at the start of flows.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Players in the page list.

4. In the Instrument Changes section, activate/deactivate Show instrument change label
at start of flow.

5. Click Apply, then Close.

RESULT
Instrument change labels are shown in the first bar of each flow in the selected layouts when
Show instrument change label at start of flow is activated, and hidden when it is deactivated.

Instrument transpositions in staff labels
Instrument transpositions indicate the interval between the note an instrument plays and the
sounding note produced. Transposing instruments, such as Horn in F and Clarinet in B♭, are
commonly shown with their transposition, also known as their “instrument pitch”, as part of their
instrument name or layout name.

Depending on the options set for Show transposition in the Edit Instrument Names dialog for
each transposing instrument, they might show transpositions in staff labels even if you have
hidden transpositions in staff labels in their layout.

Dorico Pro sets common transposing instruments, such as Clarinet in B♭ and Trumpet in B♭, to
follow your per-layout settings for hiding/showing instrument transpositions in staff labels.

To reduce the risk of confusion, uncommon transposing instruments, such as Clarinet in A or
Trumpet in E, are set to show their transposition in staff labels always, even if you have hidden
instrument transpositions in the layout.

You can change the option for Show transposition to Follow Layout Options in the Edit
Instrument Names dialog for each instrument.

RELATED LINKS
Edit Instrument Names dialog on page 97
Changing instrument names on page 101
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Transposing instruments on page 104

Hiding/Showing instrument transpositions in staff labels
You can hide/show instrument transpositions in staff labels in each layout in your project
independently. For example, you can hide instrument transpositions in staff labels in full score
layouts but show them in part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show instrument
transpositions in staff labels.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Staff Labels section, activate/deactivate the following options for Instrument pitch
or transposition:

● Show in full staff labels

● Show in abbreviated staff labels

5. Optional: Repeat steps 2 to 4 for other layouts.

6. Click Apply, then Close.

RESULT
Instrument transpositions are shown in staff labels of the corresponding length project-wide in
the selected layouts when the corresponding checkbox is activated, and hidden when the
corresponding checkbox is deactivated.

NOTE

Depending on the options set for Show transposition in the Edit Instrument Names dialog for
each transposing instrument, they might show transpositions in staff labels even if you have
hidden transpositions in staff labels in their layout.

RELATED LINKS
Changing instrument names on page 101

Changing the position of instrument transpositions in full staff
labels

You can change the position of instrument transpositions in staff labels. They can be shown
before/after instrument names in each layout independently of other layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts whose instrument transposition position you want to
change.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.
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4. In the Staff Labels section, choose one of the following options for Position of
instrument pitch in full staff labels:

● Start

● End

5. Click Apply, then Close.

RESULT
The position of instrument transpositions relative to instrument names in staff labels is changed
project-wide in the selected layouts.

Staff labels for percussion kits
The staff labels shown for percussion kit staves depend on how kits are presented in your
project. Kits can be presented as five-line staves, grids, and as single-line instruments.

Percussion kit presentation
type

Staff label Example

5-line staff Single instrument name using
the instrument name of the
percussion kit.

Grid Multiple instrument names:
one for each kit instrument,
positioned at the staff position
of the corresponding
instrument.

Staff labels for grids use a
smaller font and a different
paragraph style than used for
standard instrument staff
labels.

Single-line instruments Multiple instrument names:
one for each kit instrument,
positioned beside the
corresponding single-line
staff.

Staff labels for single-line
instruments use the same font
and paragraph style as used
for standard instrument staff
labels.

You can change the player names, layout names, and instrument names of percussion kits in the
same ways as for other players and instruments. However, to change the staff labels for
percussion kits, you must change kit instrument names in different ways for percussion kits,
depending on your percussion kit presentation type:
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● 5-line staff: Open the Edit Instrument Names dialog from the Players panel in Setup
mode, or use the Name field in the Edit Percussion Kit dialog, to change the name of the
kit.

● Grid/Single-line instruments: Open the Edit Instrument Names dialog from inside the
Edit Percussion Kit dialog in Setup mode to change the names of individual instruments.

The same instrument name fields and options are available for kit instruments as for standard
pitched instruments.

NOTE

Smaller staff labels for each line in grid presentations use the Staff Labels (Percussion Grid)
paragraph style. You can edit this paragraph style in the Paragraph Styles dialog.

RELATED LINKS
Edit Instrument Names dialog on page 97
Player, layout, and instrument names on page 96
Edit Percussion Kit dialog on page 107
Unpitched percussion on page 1019
Changing the presentation type of percussion kits on page 1026
Paragraph Styles dialog on page 366
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A staff is a line or group of lines on which musical notes are notated to indicate the pitch and
rhythm of music. Pitched instruments use the traditional five-line staff and unpitched
instruments often use a single-line staff.

Notes are positioned on the lines and in the spaces on five-line staves, and can also use ledger
lines above/below the staff to represent pitches that cannot fit on the staff.

A phrase on a five-line staff The same phrase on a single-line staff

The pitch and register of notes on five-line staves are determined by clefs, which can also be
combined with octave lines to indicate what pitches performers play.

On five-line staves for unpitched percussion instruments, the different staff positions correspond
to different percussion instruments.

Because it is often necessary to have different staff sizes in different layouts depending on their
type, such as having smaller staves in full score layouts than in part layouts, in Dorico Pro you
can change various aspects of staves in Setup > Layout Options.

RELATED LINKS
Clefs on page 580
Octave lines on page 586
Percussion kit presentation types on page 1025
Hiding/Showing empty staves on page 351

Per-layout options for staves
You can change settings that affect staves project-wide independently for each layout.

You can change the size of staves in each layout in the Space Size section of the Page Setup
page in Setup > Layout Options.

You can change other aspects of staves on the Staves and Systems page in Layout Options. For
example, you can change which staff labels are shown on systems, indent the first system of
each flow, and fix the number of bars included in each system. You can also select above which
staves system objects appear, according to their instrument families.

Staves
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NOTE

● If the size of system object font styles is set to Staff-relative, the staff size of the top staff
in each instrument family group affects the size of system objects if they are shown above
that bracketed group. Font styles that are set to Absolute are unaffected by staff size.

● System objects are only shown above bracketed groups in your project. If you have no
brackets, system objects only appear at the top of systems.

You can show system dividers between systems when systems contain a minimum number of
players. You can also change the appearance of system dividers.

RELATED LINKS
Changing the staff size in layouts on page 908
System objects on page 925
Changing the positions of system objects on page 926
Hiding/Showing empty staves on page 351
Edit Font Styles dialog on page 364
Brackets and braces on page 555

Staff size
Staff size refers to the distance between the top and bottom lines of staves, and can be
expressed as a point size or in millimeters. For individual staves, you can use a scale size of the
default staff size in the layout. The most appropriate staff size depends on the intended purpose
of the layout.

For example, full orchestral scores that are quite dense need a much smaller staff size than
individual parts, which require large enough notes so that performers can read them easily.
Staves can overlap and the music can become illegible if the staff size is too large in dense
scores.

In Dorico Pro, you can set the staff size using the rastral size and the space size, depending on
which measurement is more appropriate for the selected layouts.

● Rastral size is the size of the full staff, measured from the bottom line to the top line.

● Space size is the distance between two staff lines.

When changing the staff size of each layout in Layout Options, we recommend that you use one
of the preset rastral sizes, as these are based on traditional and generally accepted staff sizes
that are all widely used in music engraving.

NOTE

The size of staves can affect the size of system objects.

RELATED LINKS
System objects on page 925
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Changing the staff size in layouts
You can change the staff size project-wide for each layout in your project. For example, you can
have a small staff size in full score layouts but a larger staff size in part layouts.

NOTE

If the size of system object font styles is set to Staff-relative, the staff size of the top staff in each
instrument family group affects the size of system objects if they are shown above that bracketed
group. Font styles that are set to Absolute are unaffected by staff size.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts whose staff size you want to change.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Page Setup in the page list.

4. In the Space Size section, select the staff size you want from the Rastral size menu.

NOTE

If you select Custom, you can set a custom value in the Space size field, expressed in
millimeters.

You can also set a Custom value by changing the value when any Rastral size is selected.

5. Optional: Repeat steps 2 to 4 for other layouts.

6. Click Apply, then Close.

RESULT
The staff size in the selected layouts is changed project-wide.

TIP

You can also change the staff size from specific points in layouts, and change the size of
individual staves.

RELATED LINKS
Edit Font Styles dialog on page 364
Brackets and braces on page 555
System objects on page 925
Changing the size of individual staves on page 909

Changing the staff size from specific points
You can change the staff size of all staves from specific points in layouts. For example, you can
have smaller staves only on pages with more staves, and larger staves on other pages with fewer
staves.

NOTE

If the size of system object font styles is set to Staff-relative, the staff size of the top staff in each
instrument family group affects the size of system objects if they are shown above that bracketed
group. Font styles that are set to Absolute are unaffected by staff size.
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PREREQUISITE

● You have inserted a system/frame break at the position from which you want to change
the staff size.

● Signposts are shown for system/frame breaks.

PROCEDURE

1. In Engrave mode, select the signpost of the system/frame break from which you want to
change the staff size.

2. In the Properties panel, activate Space size in the Format group.

3. Change the value in the value field.

RESULT
Increasing Space size increases the staff size of all staves in the layout. Decreasing the value
decreases the staff size. This changes the staff size until the next change in staff size or the end
of the flow, whichever comes first.
By default, the next flow in your project uses your project-wide staff size for the current layout.

RELATED LINKS
Staff size on page 907
Inserting system breaks on page 359
Inserting frame breaks on page 357
Hiding/Showing system break signposts on page 360
Hiding/Showing frame break signposts on page 358
Edit Font Styles dialog on page 364
Brackets and braces on page 555
System objects on page 925

Changing the size of individual staves
You can change the size of individual staves independently of other staves and your layout
settings. For example, piano accompaniment parts often include the solo line of the instrument
the piano is accompanying on a smaller staff.

A piano part with smaller viola staff above

You can change the size of individual staves to a set scale size, expressed as a percentage of the
normal staff size in the layout, or set a custom scale.
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TIP

If you want to change the staff size to represent an alternative version of a passage, you can
instead add an ossia staff, which you can show for specific regions.

PROCEDURE

1. Select an item on the staff whose size you want to change. You can do this in Write mode
and Engrave mode.

NOTE

You can only change the size of a single staff at a time.

2. Choose Edit > Staff Size > [Staff size]. You can also choose this option from the context
menu.

3. Optional: If you choose Custom Staff Size, you must set the staff size using the Custom
Staff Size dialog that opens.

RESULT
The size of the selected staff is changed. This also works in combination with the other ways of
changing the staff size, such as changing the size of all staves in the layout or changing the size
of staves from a specific point.

NOTE

● Changing the staff size of individual staves affects the staff size of all instruments held by
that player.

● Changing the staff size of individual staves affects its size for the whole flow.

● If the size of system object font styles is set to Staff-relative, the staff size of the top staff
in each instrument family group affects the size of system objects if they are shown above
that bracketed group. Font styles that are set to Absolute are unaffected by staff size.

RELATED LINKS
Changing the staff size in layouts on page 908
Changing the staff size from specific points on page 908
Edit Font Styles dialog on page 364
Brackets and braces on page 555
System objects on page 925
Adding ossia staves on page 918

Custom Staff Size dialog
The Custom Staff Size dialog allows you to change the size of individual staves by a custom scale
factor.

● You can open the Custom Staff Size dialog by selecting an item in the music area and
choosing Edit > Staff Size > Custom Staff Size.
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Custom Staff Size dialog

The Custom Staff Size dialog contains the following options:

Default staff size
Displays the default size of staves in the current layout. This size is set on the Page
Setup page in Setup > Layout Options.
The default staff size is expressed as both a point size and in millimeters.

Rastral size
Allows you to select the rastral size on which you want to base your custom staff size.

Scale factor
Sets the custom staff size, expressed as a percentage of the selected rastral size.

New staff size
Displays the new custom staff size for the selected staff as a result of the changes
you have made in the dialog.
The new staff size is expressed as both a point size and in millimeters.

RELATED LINKS
Changing the size of individual staves on page 909

Changing the thickness of staff lines
You can change the thickness of staff lines project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Staves in the page list.

3. In the Staff Lines section, change the value for Staff line thickness.

4. Click Apply, then Close.

RESULT
The thickness of staff lines project-wide is changed. Increasing the value for Staff line thickness
makes staff lines thicker, decreasing the value makes staff lines thinner.
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Deleting staves
You can delete staves, including extra staves and ossia staves, so they no longer appear in any
layout in which the instrument appears. However, this does not automatically delete any
remaining notes on those staves, which will still play back even if the staff does not appear.

PROCEDURE

1. In Write mode, select any of the following:

● An item on the staff you want to delete, at the rhythmic position from which you
want to delete it

● The signpost of the extra staff you want to delete

NOTE

You can only delete one staff at a time.

2. Choose Edit > Staff > Remove Staff. You can also choose this option from the context
menu.

RESULT
The selected staff is deleted from the selected rhythmic position and a signpost appears
indicating the staff change. The staff is deleted until the next staff change signpost that applies
to that staff or the end of the flow, whichever comes first.

NOTE

● If you delete an extra staff without deleting the music on it, that music still exists but is not
shown, meaning it is included in playback. If you later recreate an extra staff at the same
position, the music reappears.

● You cannot delete all staves of an instrument as at least one must always appear. If you do
not want to see any staves for a particular instrument in a layout, you can instead hide
empty staves in that layout.

EXAMPLE

A three-staff piano with the bottom staff deleted in the second bar

RELATED LINKS
Hiding/Showing empty staves on page 351
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Extra staves
In Dorico Pro, you can add extra staves to any instrument, for example, to make complex
contrapuntal music easier to read because it is spread out across more staves than usual for that
instrument.

An extract of Debussy's piano prelude "Feuilles mortes" with three staves

When you add extra staves, they exist for the whole flow. However, you can control exactly where
they appear, as often extra staves are only needed for short sections. Extra staves can end
immediately, and so are followed by white space until the end of the system, or can fill the width
of the system, even if they do not contain music for part of the system.

Signposts are automatically added when you add or remove extra staves, indicating the number
of staves added or removed at that position. If multiple staff changes happen at the same
rhythmic position, they are all shown in the same signpost.

An extract of Debussy's piano prelude "Feuilles mortes" with three staff change signposts

You can use these signposts to change the start/end positions of extra staves, for example, if you
want to lengthen or shorten the region where an extra staff is shown. You can also use these
signposts to delete extra staves.

Dorico Pro also allows you to change the number of staves in different ways according to the
intended purpose of the staves, with dedicated features for each type.

● Extra staves are full-sized staves belonging to a solo player.

● Ossia staves are small staves belonging to any type of player.

● Divisi staves are full-sized staves belonging to a section player.
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RELATED LINKS
Showing extra staves across whole systems on page 916
Ossia staves on page 917

Adding extra staves
You can add extra staves both above and below instruments that belong to solo players, and
show them for both limited sections or for the entire flow. For example, some complex piano
music requires three staves rather than two to display the music clearly.

NOTE

● If you want to add extra staves to notate a divisi passage or to show an alternative
interpretation, you can use the dedicated divisi and ossia staff features instead.

● You can add as many staves above/below instruments as you like, but only one at a time.
You must also select an item on one of the original staves of the instrument to add
additional staves, not on any existing extra staves you have added.

● You can only add extra staves to instruments held by solo players. You cannot add extra
staves to instruments that belong to section players or percussion kits.

PROCEDURE

1. In Write mode, select an item on the one of the instrument’s original staves and at the
rhythmic position where you want to add an extra staff.

2. Add an extra staff in one of the following ways:

● Choose Edit > Staff > Add Staff Above.

● Choose Edit > Staff > Add Staff Below.

TIP

You can also choose these options from the context menu.

3. Optional: Repeat steps 1 and 2 as many times as you like.

RESULT
An extra full-sized staff is added either above or below the selected staff, starting at the earliest
rhythmic position you selected and lasting until the end of the flow. A signpost appears at its
start position, indicating the number of staves that have been added.

TIP

By default, extra staves do not extend to the start/end of systems, meaning they start/stop in the
middle of systems.

If you want extra staves to extend to the start/end of systems automatically regardless of their
rhythmic start/end positions, you can show extra staves across whole systems in each layout
independently.
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EXAMPLE

Piano with an extra staff added above the top staff in the second bar

RELATED LINKS
Ossia staves on page 917
Adding ossia staves on page 918
Showing extra staves across whole systems on page 916

Moving the start/end positions of extra staves
You can move the rhythmic start and end positions of extra staves after you have added them.
Because you can move the start/end of extra staves independently, you can also lengthen/
shorten extra staves.

PROCEDURE

1. In Write mode, select the staff change signposts at the start/end of the extra staves whose
start/end position you want to change.

NOTE

When using the mouse, you can only move one staff change signpost rhythmically at a
time.

2. Move the selected staff change signposts according to the current rhythmic grid value in
any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the staff change signpost to the right/left.

3. Optional: Repeat steps 1 and 2 for the signposts at the other end of the extra staves.

RESULT
The rhythmic start/end positions of the selected extra staves are changed.

NOTE

Only one staff change signpost can exist at each rhythmic position. If a staff change signpost
passes over another staff change signpost as part of its move, the existing staff change signpost
is deleted and replaced by the one being moved. For example, if you move the start signpost of
an extra staff over its end signpost, the extra staff now continues up to the next staff change on
that staff or the end of the flow, whichever comes first.

You can undo this action, but any staff change signposts deleted in the process are only restored
if you moved the staff change signpost using the keyboard.
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Showing extra staves across whole systems
By default, extra staves are only shown from where they begin and until where they end. You can
change this setting to that extra staves fill the full width of any system on which they appear
instead, in each layout independently.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to show extra staves across the full
width of systems.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Ossias and Extra Staves section, activate Show extra staves across full system
when starting or stopping.

5. Click Apply, then Close.

RESULT
Extra staves in the selected layouts always fill the full width of any system on which they appear.
Deactivating the property returns layouts to showing extra staves only for the duration specified
by their signposts.

EXAMPLE

Extra staff not shown across the full width of the
system

Extra staff shown across the full width of the system

RELATED LINKS
Extra staves on page 913
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Ossia staves
Ossia staves are smaller staves shown above/below the main staff of an instrument. They are
used to show alternative phrases that can be played instead of the original phrase, such as
suggestions for ornaments, alternative notations from other sources, or an easier version.

An ossia staff below the left-hand piano staff shows an easier alternative

In Dorico Pro, you can add ossia staves both above and below instrumental staves for specific
durations only, and their formatting is handled automatically. Vertical spacing is adjusted around
ossia staves automatically.

Signposts are automatically added when you add or remove ossia staves, indicating the number
of staves added or removed at that position. If multiple staff changes happen at the same
rhythmic position, they are all shown in the same signpost.

An ossia staff with signposts shown

By default, ossia staves are scaled to two thirds the size of a regular staff. Because this is a scale
factor rather than a fixed staff size, ossia staves automatically adjust according to the staff size,
which you can set per layout, per section, and per player.

NOTE

Music on ossia staves is not played back.

RELATED LINKS
Extra staves on page 913
Changing the size of ossia staves on page 919
Ossia staff labels on page 922
Hiding/Showing ossia staves in the preamble on page 920
Hiding/Showing ossia staves on page 921
Changing the placement of system objects relative to ossia staves on page 926
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Adding ossia staves
You can add ossia staves for solo and section players, both above and below existing staves. For
grand-staff instruments, you can add two-staff ossias.

NOTE

● You cannot add ossia staves to percussion kit instruments.

● Although instruments can show ossias both above and below staves, only one ossia can
exist on each side of the staff at a time.

PROCEDURE

1. In Write mode, select the range above/below which you want to add an ossia staff.

NOTE

If you want to add a two-staff ossia, you must select both instrumental staves.

2. Add an ossia staff in any of the following ways:

● Choose Edit > Staff > Create Ossia Above.

● Choose Edit > Staff > Create Ossia Below.

TIP

You can also choose these options from the context menu.

RESULT
An ossia is added above/below the selected staff that lasts for the selected range. One signpost
appears at the start of the ossia passage, and another appears where the ossia staff ends.

TIP

You can select these signposts and move them to change the start/end positions of ossia staves.

Moving the start/end positions of ossia staves
You can move the rhythmic start and end positions of ossia staves after you have added them.
Because you can move the start/end of ossia staves independently, you can also lengthen/
shorten ossia staves.

PROCEDURE

1. In Write mode, select the staff change signposts at the start/end of the ossias whose
start/end position or length you want to change.

NOTE

When using the mouse, you can only move one staff change signpost rhythmically at a
time.

2. Move the selected staff change signposts according to the current rhythmic grid value in
any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the ossia signpost to the right/left.

3. Optional: Repeat steps 1 and 2 for the signposts at the other end of the ossia staves.
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RESULT
The rhythmic start/end positions of the selected ossia staves are changed.

NOTE

Only one ossia signpost can exist at each rhythmic position. If an ossia signpost passes over
another ossia signpost as part of its move, the existing ossia signpost is deleted and replaced by
the one being moved. For example, if you move the start signpost of an ossia over its end
signpost, the ossia now continues up to the next ossia on the staff or the end of the flow,
whichever comes first.

You can undo this action, but any ossia signposts deleted in the process are only restored if you
moved the ossia signpost using the keyboard.

EXAMPLE

An ossia staff with signposts shown The same ossia staff after moving the start signpost
to the right and end signpost to the left

Changing the size of ossia staves
By default, ossia staves are scaled to two thirds the size of a regular staff. You can change the
scale factor of all ossia staves project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Staves in the page list.

3. In the Ossias section, change the value for Ossia scale factor.

4. Click Apply, then Close.

RESULT
The scale factor of ossia staves relative to the prevailing staff size is changed in all layouts
project-wide.

RELATED LINKS
Staff size on page 907

Changing the padding on ossias that start/end mid-bar
You can change how far staff lines extend beyond the left/right of ossia staves that begin/end in
the middle of bars. Padding such ossia staves ensures that notes, accidentals, rhythm dots, and
other items are always shown on staff lines.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.
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2. Click Staves in the page list.

3. In the Ossias section, change the values for Extend staff lines at start of ossia and/or
Extend staff lines at end of ossia.

4. Click Apply, then Close.

RESULT
The padding before and/or after ossia staves that start/end mid-bar is changed project-wide.

EXAMPLE

Ossia staff with no padding Ossia staff with padding set to 3 both at the start
and end

Hiding/Showing ossia staves in the preamble
You can include ossia staves in or exclude them from the preamble when they cross system/
frame breaks in each layout independently.

Showing ossia staves in the fixed preamble means their clefs and time signatures appear
alongside all the regular staves at the start of each system. As this can suggest the ossia staff is
an additional instrument, it is common to exclude ossia staves from the fixed preamble.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show ossia staves in the
preamble.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Ossias and Extra Staves section, choose one of the following options for Ossias
crossing a system break:

● Include in preamble

● Exclude from preamble

5. Click Apply, then Close.

RESULT
Preamble notations for ossia staves are hidden in the main preamble in the selected layouts
when you choose Exclude from preamble, and shown when you choose Include in preamble.
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EXAMPLE

Ossia included in the preamble Ossia excluded from the preamble

Hiding/Showing ossia staves
By default, ossia staves appear in all layouts. You can change the layouts in which ossia staves
are shown, for example, if you want ossia staves to appear in the part layout but not in the full
score.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show ossia staves.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Ossias and Extra Staves section, activate/deactivate Show ossias.

5. Click Apply, then Close.

RESULT
Ossias are shown in the selected layouts when Show ossias is activated, and hidden when it is
deactivated.

Deleting ossia staves
You can remove ossia staves so they are no longer shown in any layout, but without
automatically deleting the music on them.

PROCEDURE

1. In Write mode, select one of the following:

● The signposts at the start/end of the ossia staves you want to delete

● An item on each ossia stave you want to delete

2. Remove the selected ossia staves in one of the following ways:

● If you selected ossia signposts, press Backspace or Delete, or choose Edit > Delete.

● If you selected items on ossia staves, choose Edit > Staff > Remove Staff. You can
also choose this option from the context menu.
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RESULT
The selected ossia staves are removed and no longer appear in any layouts in which that player
appears.

NOTE

If you delete an ossia staff without deleting the music on it, that music still exists but is not
shown. If you later recreate an ossia at the same position, the music reappears.

RELATED LINKS
Hiding/Showing ossia staves on page 921

Barlines on ossia staves
There are different conventions for whether ossias are connected to their corresponding staves
with barlines, and if so, which type of barline should be used.

If an ossia both starts and ends at barlines, the following accepted conventions exist amongst
different publishers:

● Barlines join the ossia to the main staff at both its start and end

● A barline joins the ossia to the main staff only at its end

● The ossia does not join to the main staff at all

When an ossia is joined to the main staff, some publishers use the same kind of barline as used
for the other staves, which is typically a single barline, whereas other publishers use a dashed
barline.

Dorico Pro provides options to accommodate all of these conventions in the Ossias section of the
Barlines page in Engrave > Engraving Options.

NOTE

When an ossia appears between the main staves of an instrument, for example, below the right-
hand staff of a piano, then the ossia is joined with the same barline as the main staves,
regardless of your chosen settings on the Barlines page in Engraving Options.

RELATED LINKS
Barlines on page 509
Project-wide engraving options for barlines on page 511

Ossia staff labels
Ossias can show staff labels like normal staves, the only difference being that staff labels on ossia
staves are typically drawn within the system to the left of where the ossia starts, even if this is in
the middle of a system, rather than behind the initial barline.

Ossia staff labels use the Ossia Staff Label font style, which you can edit in the Edit Font Styles
dialog.
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An ossia staff with the default staff label

Ossia staff labels are positioned according to the distances set in the Ossias section of the
Staves page in Engrave > Engraving Options. There are separate options for labels before
single ossias and braced two-staff ossias.

RELATED LINKS
Edit Font Styles dialog on page 364

Hiding/Showing staff labels on ossia staves
You can hide/show staff labels on ossia staves in each layout independently, and you can show
the default staff label or enter a custom ossia label.

The default staff label on ossia staves is “ossia”.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show staff labels on ossia
staves.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Ossias and Extra Staves section, activate/deactivate Show label before ossia.

5. Optional: If you activated Show label before ossia, choose one of the following staff label
options:

● Default

● Custom

6. Optional: If you chose Custom, enter the staff label you want into the Custom ossia label
field.

7. Click Apply, then Close.

RESULT
Staff labels are hidden/shown in the selected layouts.

RELATED LINKS
Ossia staff labels on page 922
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System dividers
System dividers are used to clarify the separation of different systems when they appear on the
same page. They are usually shown as two thick, parallel angled lines positioned to the left of
initial barlines.

In Dorico Pro, the outer edges of system dividers are aligned with the corresponding edges of
music frames.

A system divider between two systems in a string quartet score

You can show system dividers in different circumstances and change their appearance in each
layout independently. You can also change their default insets in all layouts project-wide on the
System Dividers page in Engrave > Engraving Options.

Showing system dividers
You can change the circumstances in which system dividers are shown, including specifying the
minimum number of players required to show them, in each layout independently. For example,
if you only want to show system dividers between systems that contain different numbers of
staves.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to show system dividers.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the System Dividers section, choose one of the following options for Show system
dividers:

● When number of staves differs

● When minimum number of players present

5. Optional: If you selected When minimum number of players present, change the value
for Minimum number of players.

6. Click Apply, then Close.

RESULT
System dividers are shown between systems in all flows in the selected layouts that either
contain the minimum number of players you set or contain different numbers of staves.

RELATED LINKS
Hiding/Showing empty staves on page 351
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Changing the length of system dividers
You can change the length of system dividers in each layout independently, for example, if you
want to show longer system dividers in layouts that show full staff labels.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to show system dividers.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the System Dividers section, choose one of the following options for Appearance:

● Default

● Long

● Extra long

5. Click Apply, then Close.

System objects
System objects are items that apply to all staves in the system, but are not necessary to show on
every staff. For example, tempo marks and rehearsal marks are important for all players to see,
but would cause an orchestral full score to appear very cluttered and hard to read if they were
shown on every staff.

In Dorico Pro, the following items are considered system objects:

● Rehearsal marks

● Repeat endings

● Repeat markers

● System text

● Tempo marks

● Time signatures shown above the staff

You can show system objects at multiple positions in each system by showing them above
multiple instrument families. For example, you might show them above the woodwind, brass,
percussion, and string families. In an orchestral full score, this would ensure system objects are
spread out evenly across the page, meaning no staff is very far from these important markings.

NOTE

● System objects are only shown above instrument families that are bracketed or braced
together. You can change the bracket grouping on the Brackets and Braces page in
Engrave > Engraving Options.

● If the size of system object font styles is set to Staff-relative, the staff size of the top staff
in each instrument family group affects the size of system objects if they are shown above
that bracketed group. Font styles that are set to Absolute are unaffected by staff size.

RELATED LINKS
Changing bracket grouping according to ensemble type on page 559
Brackets according to ensemble type on page 558
Edit Font Styles dialog on page 364
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Brackets and braces on page 555
Rehearsal marks on page 805
Tempo marks on page 950
Repeat endings on page 823
Large time signatures on page 986
Inputting text on page 265

Changing the positions of system objects
You can change the positions of system objects in each layout independently by changing the
instrument families above which system objects are shown. Multiple items are categorizes as
system objects, including, rehearsal marks, tempo marks, repeat markers, and repeat endings.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the instrument families
above which system objects appear.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the System Objects section, activate the checkboxes for the instrument families above
which you want system objects to appear.

5. Optional: Activate Additionally show repeat endings below bottom staff.

6. Click Apply, then Close.

RESULT
System objects appear above the top staff in each bracketed group you select if a bracketed
group for that instrument family is included in the selected layouts. If you activate Additionally
show repeat endings below bottom staff, repeat endings additionally appear below the
bottom staff.

NOTE

System objects are only shown above instrument families that are bracketed or braced together.
You can change the bracket grouping on the Brackets and Braces page in Engrave > Engraving
Options.

RELATED LINKS
System objects on page 925
Changing bracket grouping according to ensemble type on page 559
Brackets according to project template categories on page 60

Changing the placement of system objects relative to ossia staves
You can change whether system objects are placed between main staves and their ossia staves
or above ossia staves in each layout independently.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the placement of
system objects relative to ossia staves.
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By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Ossias and Extra Staves section, choose one of the following options for Position
of system objects relative to ossia above staff:

● Inside ossia

● Outside ossia

5. Click Apply, then Close.

System indents
System indents control the distance between the left page margin and the start of systems of
music. According to tradition, the first system in part layouts is indented, but in modern use this
is not always necessary.

A violin part with the first system indented

In Dorico Pro, system indents automatically adjust to accommodate staff labels. For example, if a
system contains a staff label that is significantly longer than the minimum system indent, Dorico
Pro increases the indent on that system to ensure the staff label remains legible and is not cut off
on the left edge or collides with the music.

You can change both the minimum indent on systems with staff labels and the first system
indent in each layout independently. You can also adjust the system indent at both the start and
end of individual systems, independently of your per-layout settings.

RELATED LINKS
Changing the minimum indent for systems with staff labels on page 900
Changing the start/end position of systems on page 390

Changing the first system indent
By default in Dorico Pro, the first system in part layouts is indented. You can change the indent
for the first system in each layout independently.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts whose first system indent you want to change.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Staff Labels section, change the value for Indent first system of flow by.
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5. Click Apply, then Close.

RESULT
The indent of the first system is changed project-wide in the selected layouts. This applies to all
flows.

RELATED LINKS
System indents on page 927
Changing the minimum indent for systems with staff labels on page 900
Changing the start/end position of systems on page 390
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Divisi is when players split, or “divide”, in order to play multiple lines of music, commonly for a
limited passage, before returning to play together, or “tutti”. Divisi passages can be notated with
all lines on a single staff or across multiple staves.

Divisi is a technique most commonly used in orchestral string writing, as the string section
typically contains a large number of players compared to the number of staves. For example,
large orchestras commonly have twelve first violins all playing the same part most of the time.
Dividing those players into multiple parts allows composers to write more complex contrapuntal
music.

An example divisi change in a Violin I part, splitting it into two sections and a solo line

If the division is relatively simple, it is possible to write all parts on the same staff and label the
section, with an indication of how many players are required for each line if necessary.

However, when a section is divided into multiple parts that are too different to be clearly written
on a single staff, it is necessary to divide them onto multiple staves. In Dorico Pro, you can create
divisi changes for specific regions. This allows you not only to divide sections into any number of
parts with any number of staves, but also to include solo lines and group staves as required. You
can input divisi changes on any staff belonging to a section player.

NOTE

You cannot input divisi changes on staves belonging to solo players. If you want to notate music
for a solo player across multiple staves, you can add extra staves instead.

If divisi changes occur partway through a system, Dorico Pro automatically extends the extra
staves to the start or end of the system, and duplicates the regions where the section is tutti
automatically using unison ranges.

Divisi changes apply to both full score and part layouts.

RELATED LINKS
Unison ranges on page 934
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Extra staves on page 913

Change Divisi dialog
The Change Divisi dialog allows you to change how section players are divided and change the
appearance and grouping of staff labels.

● You can open the Change Divisi dialog by selecting an item on a section player’s staff and
choosing Edit > Staff > Change Divisi.

The Change Divisi dialog contains the following sections and options:

1 Divisions section
Shows the current divisions and groups for the selected section player at the selected
rhythmic position.

2 Groups
Shows any groups of divisions you have created. Grouping sections together gives you
more flexibility in how the staves are labelled.

3 Divisions
Shows each current individual division. Each division corresponds to a separate staff.

4 Action bar
Contains options that allow you to change the number and arrangement of divisions.

● Add Solo Division
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Adds a solo staff to the section. Dorico Pro automatically adds solo staves above
section staves.

● Add Section Division

Adds a section division to the section. Dorico Pro automatically adds new section
divisions below existing sections.

● Add Group

Groups the selected solo or section divisions together.

● Delete Division or Group

Deletes the selected section divisions or groups.

NOTE

If you delete a divisi without deleting any music on it, that music is no longer shown
but still exists. If you later recreate a division of the same type at the same position,
the music reappears.

5 Staff labels section
Displays the current staff label for the selected division or group and allows you to edit it,
independently of your default staff label paragraph style settings.

6 Editing
For groups only, this option allows you to switch between editing the Full Name and Short
Name of the selected group.
Full Name is used for Full staff labels, Short Name is used for Abbreviated staff labels.

7 Text editor options
Allows you to customize the font, size, and formatting of the staff label of the selected
division or group.

8 Text editing area
Shows the current staff label for the selected division or group. You can select any part of
the staff label and edit it independently of other parts, for example, if you want the
numbers to use a different font to the instrument name.
Divisi staff labels are right-aligned by default, so appear at the right edge of the text
editing area.

9 Staff label visibility options
Allow you to customize when the different parts of divisi staff labels are shown,
independently of your per-layout settings.

RELATED LINKS
Staff label paragraph styles on page 897
Divisi staff labels on page 937
Inputting divisi changes on page 932
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Inputting divisi changes
You can input divisi changes on any section player staff. Divisi changes can last for any duration
and include any number of staves.

NOTE

● You cannot input divisi changes on staves belonging to solo players. If you want to notate
music for a solo player across multiple staves, you can add extra staves instead.

● Divisi changes are shown in both full score and part layouts automatically.

PROCEDURE

1. In Write mode, do one of the following:

● Start note input.

● Select an item on the staff you want to divide, at the rhythmic position from which
you want the divisi to apply.

2. Choose Edit > Staff > Change Divisi to open the Change Divisi dialog. You can also
choose this option from the context menu.

3. In the Change Divisi dialog, create the divisi you want.
For example, if you want to divide the player into two sections, click Add Section Division.

4. Optional: Edit the staff labels.

5. Click OK.

RESULT
The selected staff is divided into the number and types of staves specified in the Change Divisi
dialog, either from the caret position during note input or from the selected item outside of note
input. A signpost is shown at the position of the divisi change.
The divisi change applies from the selected item until the next existing divisi change or the end
of the flow, whichever comes first. It is shown in both full score and part layouts.
If the divisi change occurs partway through a system, any extra staves are automatically shown
across the whole system. A unison range is created automatically to replicate any tutti material
onto all staves added by the divisi change.

NOTE

The number of staves in a system is defined by the first divisi change in the system. If you input a
divisi change on a system with an existing divisi change, the number of staves is not changed to
reflect the new divisi change until the next system.

AFTER COMPLETING THIS TASK
You can input further divisi changes at any position or end the divisi passage.

RELATED LINKS
Change Divisi dialog on page 930
Divisi staff labels on page 937
Ending divisi passages on page 934
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Editing existing divisi changes
You can edit divisi changes after you have input them, for example, if you want to add a solo line
in addition to an existing section division.

PROCEDURE

1. Double-click the signpost of the existing divisi change you want to edit to open the
Change Divisi dialog. You can do this in Setup, Write, and Engrave modes.

2. In the Change Divisi dialog, edit the divisi change.

3. Optional: Edit the staff labels.

4. Click OK.

RESULT
The selected divisi change is updated.
If you added extra divisions to the divisi change, those staves are added to the region to which
the divisi change applies.
If you removed divisions from the divisi change, those staves are removed from the region to
which the divisi change applies.

NOTE

Removing divisi sections does not automatically delete music previously on the staff. Even
though removed staves no longer appear, any notes left on them still play back. If you later
restore the staff, the notes are also restored.

If you do not want to hear notes on divisi staves you have removed, we recommend deleting all
music from the staves first.

RELATED LINKS
Change Divisi dialog on page 930
Divisi staff labels on page 937
Large selections on page 274

Moving divisi changes
You can move divisi changes to new rhythmic positions after you have input them. Because the
start and end of divisi passages have separate signposts that you can move independently, you
can also lengthen/shorten divisi passages.

PROCEDURE

1. In Write mode, select the divisi change signposts you want to move.

NOTE

When using the mouse, you can only move one divisi change signpost at a time.

2. Move the divisi changes according to the current rhythmic grid value in any of the
following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the divisi change signpost to the right/left.

3. Optional: Repeat steps 1 and 2 for the signposts at the other end of the divisi passages.
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RESULT
The selected divisi change signposts are moved to new rhythmic positions. Any music on divisi
staves now outside divisi passages is automatically hidden, and any unison ranges before/after
divisi passages are automatically updated according to the new start/end positions of the divisi
passages.

NOTE

Only one divisi change signpost can exist at each rhythmic position. If a divisi change signpost
passes over another divisi change signpost as part of its move, the existing divisi change
signpost is deleted and replaced by the divisi change signpost being moved. For example, if you
move the start signpost of a divisi change over its tutti restoration, the divisi passage now
continues up to the next divisi change on the staff or the end of the flow, whichever comes first.

You can undo this action, but any divisi change signposts deleted in the process are only restored
if you moved the divisi change signpost using the keyboard.

Ending divisi passages
You can end divisi passages and return to a unison section on a single staff at any position,
including partway through systems.

PROCEDURE

1. In Write mode, select an item on a divisi staff at the rhythmic position where you want the
divisi passage to end.

2. Choose Edit > Staff > Restore Unison. You can also choose this option from the context
menu.

RESULT
A default divisi change with a single unison section is input at the selected position, which ends
the previous divisi passage. A signpost is shown at the position of the unison restoration.
The unison restoration applies from the selected item until the next existing divisi change or the
end of the flow, whichever comes first. It is shown in both full score and part layouts.
If the unison restoration occurs partway through a system, all staves from the previous divisi
change automatically continue until the end of the system. A unison range is created
automatically to replicate any unison material onto all staves from the divisi change.

NOTE

The number of staves in a system is defined by the first divisi change in the system. If you input a
divisi change on a system with an existing divisi change, the number of staves is not changed to
reflect the new divisi change until the next system.

RELATED LINKS
Unison ranges on page 934

Unison ranges
Unison ranges are passages of tutti music that are replicated automatically onto all staves when
divisi passages start/end partway through systems. This ensures there is no ambiguity about
what players are expected to play at any point.

To replicate music, Dorico Pro uses the top staff in the section as a source staff, and replicates all
notes and notations on that staff onto all staves in the section.
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You cannot edit notes in unison ranges independently on each staff. When you select a note or
item on a unison range staff, that note or item is selected on all staves in the section. Therefore,
editing notes or items in unison ranges simultaneously edits those notes or items on all staves in
the section. Similarly, when you input notes onto a staff in a unison range, Dorico Pro also inputs
them on all staves in the section.

A note and slur selected simultaneously on all staves in the unison range, with unison range colors shown

NOTE

Replicating music from the source staff to other staves in the section is complex, and there are
limitations to what Dorico Pro can calculate, particularly notations that start before divisi changes
or end after divisi changes. For example, slurs that start before a divisi change and continue into
the divisi change are not replicated in unison ranges. In such cases, we recommend that you
move the divisi change to before/after the slur and manually copy unison material if required.

If staves in divisions use different clefs to the main staff at the position of the tutti restoration,
Dorico Pro automatically inputs the appropriate clefs.

NOTE

The default spacing of clef changes at the end of divisions can be small, positioning the clef
tightly beside the previous notes. In such cases, we recommend that you adjust note spacing at
that position.

RELATED LINKS
Adjusting note spacing at individual rhythmic positions on page 388

Showing unison range colors
You can show unison ranges in a different color so you can identify those passages more easily.

PROCEDURE

● Choose View > Note and Rest Colors > Divisi Unison Ranges.

RESULT
Unison range colors are shown when a tick appears beside Divisi Unison Ranges in the menu,
and hidden when no tick appears.
When unison range colors are shown, notes in unison ranges appear gray. Notes on the top staff
remain black, as Dorico Pro notates real notes in tutti sections on the top staff in the section by
default.
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EXAMPLE

A tutti passage with unison range colors not shown The same tutti passage with unison range colors
shown

RELATED LINKS
Unison ranges on page 934

Divisi on vocal staves
When vocal staves divide to show different lines on separate staves, it is common to show arrows
at the end of the system to emphasize the change, and again at the end of the division to show
the staves are rejoining.

Divide arrows indicating the staff splits into two on
the next system

Divide arrows indicating two staves rejoin into one
on the next system

Arrows at the start and end of divisi passages on vocal staves are known in Dorico Pro as divide
arrows. Dorico Pro shows these arrows on vocal staves by default, but you can also hide them on
all staves project-wide.

Hiding/Showing divide arrows on vocal staves
You can hide/show divide arrows on all vocal staves project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Divisi in the page list.

3. Choose one of the following options for Indicate divisi at end of system on vocal staves:

● Show divide arrows

● Do not show divide arrows

4. Click Apply, then Close.
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RELATED LINKS
Divisi on vocal staves on page 936

Divisi staff labels
Staff labels on divisi staves often require further detail than normal staff labels. Therefore, Dorico
Pro allows you extra control over the appearance and formatting of staff labels on divisi staves.

By default, staff labels on divisi staves use the same paragraph styles for the formatting of their
text as normal staves, and options for staff labels also apply to divisi staves. However, you can
also edit each individual staff in divisi changes independently of these settings in the Change
Divisi dialog, including changing the font, style, and alignment.

Creating custom groups of staves in divisi changes allows you to edit the group staff label
independently of each staff. You can edit both the full and abbreviated group staff labels.

Additionally, the Change Divisi dialog allows you to hide and show player/group names and
section numbers on the staves belonging to that specific divisi change independently of your
settings on the Staves and Systems page in Setup > Layout Options.

NOTE

Editing individual divisi staff labels overrides your paragraph style settings. If you later change
the staff label paragraph styles, the edited divisi staff label is not updated.

You can show additional divisi change labels above divisi staves project-wide in each layout
independently. By default, divisi change labels display the same information as divisi staff labels,
are positioned above each staff, and are aligned with the position of the divisi change. Such
labels can be particularly useful when divisi changes occur partway through systems and the
precise division of the section would otherwise be ambiguous.

RELATED LINKS
Change Divisi dialog on page 930
Staff labels on page 895
Staff label paragraph styles on page 897
Editing divisi staff labels individually on page 937
Changing the text shown in divisi change labels on page 939

Editing divisi staff labels individually
You can edit the staff labels shown at each divisi change individually, for example, if a single
division in your project is significantly different to others and needs further clarification. When
editing divisi staff labels individually, you can also customize the font of each label in the divisi
change.

NOTE

Changes made to staff labels in the Change Divisi dialog apply to all layouts. They also affect the
text shown in any corresponding divisi change labels above staves, even if you had already
changed the text shown in those labels.

PROCEDURE

1. Open the Change Divisi dialog in any of the following ways:

● Double-click the signpost of an existing divisi change whose staff labels you want to
change.

● Input a new divisi change.
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2. In the Divisions section, select the group or section whose staff label you want to edit.

3. Optional: If you selected a group, choose one of the following staff labels to edit:

● Full Name

● Short Name

4. In the Staff labels section, edit the selected staff label.

5. Choose one of the following options for Show player or group name and Show section
numbers:

● Follow Options

● Show

● Hide

6. Optional: Repeat steps 2 to 5 for other sections or groups in the divisi change.

7. Click OK.

RESULT
The appearance, length, and behavior of the staff labels in the divisi change are changed in all
applicable layouts.

RELATED LINKS
Change Divisi dialog on page 930
Editing existing divisi changes on page 933

Hiding/Showing divisi staff labels
You can hide/show section staff labels before the initial barline on each system in each layout
independently, for example, you can show divisi section names in staff labels in part layouts but
hide them in full score layouts. This is independent your per-layout settings for showing staff
labels on non-divisi staves.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show divisi staff labels.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Staff Labels section, activate/deactivate the following options:

● Show section names on first system

● Show section names on subsequent systems

5. Optional: Change the length of staff labels using the following options:

● Staff labels on first system

● Staff labels on subsequent systems

NOTE

These options affect the length of instrument and divisi group names on all staves in the
selected layouts, not just divisi staves.

6. Click Apply, then Close.
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RESULT
Section names are shown before the initial barline in the first system of each divisi passage when
Show section names on first system is activated, and hidden when it is deactivated.
Section names are shown before the initial barlines on all subsequent systems in divisi passages
when Show section names on subsequent systems is activated, and hidden when it is
deactivated.

NOTE

This is independent of either the group name or the instrument name when it is justified
between multiple identical instruments.

EXAMPLE

Viola divisi staves with section names shown in
addition to abbreviated staff labels

Viola divisi section names shown but staff labels not
shown

RELATED LINKS
Divisi staff labels on page 937
Hiding/Showing divisi change labels above staves on page 940
Changing the length of staff labels project-wide on page 899

Changing the text shown in divisi change labels
You can show custom text in individual divisi change labels shown above staves. This does not
affect the content of staff labels on divisi staves.

PROCEDURE

1. In Engrave mode, select the divisi change labels whose text you want to change.

2. In the Properties panel, activate Custom text in the Divisi group.

3. Enter the text you want into the value field.

4. Press Return.

RESULT
The text shown in the selected divisi change labels is changed.
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Hiding/Showing divisi change labels above staves
You can hide/show section names above staves in divisi sections project-wide in each layout
independently, for example, to clarify which staves correspond to sections in the divisi when
divisi changes occur partway through systems, or to show a change in weighting between staves.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to hide/show divisi change labels
above staves.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Staves and Systems in the page list.

4. In the Staff Labels section, activate/deactivate Show divisi change labels above staves.

5. Click Apply, then Close.

RESULT
Section names are shown above staves in the division when Show divisi change labels above
staves is activated, and hidden when it is deactivated.

NOTE

This does not affect whether divisi section names are shown in staff labels before the initial
barline on each system.

EXAMPLE

Divisi section names shown above each staff Divisi section names hidden above each staff

RELATED LINKS
Divisi staff labels on page 937
Hiding/Showing divisi staff labels on page 938

Divisi in playback
All notes on divisi staves play back, regardless of the number of staves. However, because divisi
staves belong to a single section player, all staves are played back through the same channel.

This means only a limited differentiation between the different sections in the divisi is possible. It
is not currently possible to play a single section player divided into sections through multiple
channels; however, this is planned for future versions.

RELATED LINKS
Play mode on page 400
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Endpoint Setup dialog on page 448
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Stems are vertical lines that extend from noteheads that are a half note or shorter in duration. In
combination with notehead design, they allow the duration of each note to be clearly identified.

For example, quarter notes (crotchets) and eighth notes (quavers) both have solid black
noteheads and stems, but eighth notes also have flags on their stems. 16th notes have two flags,
32nd notes have three flags, and so on. The length of stems is determined by default in Dorico
Pro, so stems automatically adjust their length to accommodate more/fewer flags.

Notes with stems, ranging from a half note (minim) on the left to a 128th note on the right

The stems of notes and chords can point upwards/downwards, depending on the conventions of
music engraving and the context of the music. For example, in choral music on two staves, stems
in the soprano and tenor lines point up, and stems in the alto and bass lines point down.

RELATED LINKS
Stem length on page 947
Changing the default stem direction behavior of notes on the middle line of staves on page 945

Project-wide engraving options for stems
You can find options for the project-wide appearance of stems on the Notes page in Engrave >
Engraving Options.

The options on the Notes page allow you to change the design, collision avoidance, length, and
thickness of stems. You can also set when stems are stem up or stem down, when stems are
shortened in various contexts, and change their default stem direction when on the middle line
of the staff.

Default flag design Straight flag design

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

NOTE

Stems with tremolo strokes have specific options, which you can find on the Tremolos page in
Engraving Options. For example, you can change the default distance between tremolo strokes
and the tips of stems/different stem flags.

Stems
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RELATED LINKS
Engraving Options dialog on page 299
Project-wide engraving options for tremolos on page 1004

Stem direction
In Dorico Pro, the stem direction of notes and chords follows rules that are based on the
conventions of music engraving.

Stem direction is determined automatically, but you can manually change the stem direction of
individual notes, chords, or of an entire voice. The rules that are applied depend on the following:

● How many voices are active on the staff.

● Whether notes, chords, or beamed groups of notes are affected.

● Whether notes in the same chord or notes in the same beamed group are split between
staves.

Single notes in single voices

On a five-line staff with only a single voice active, the default stem direction of a single note is
determined by its staff position.

● If the note is above the middle line, its stem points downwards.

● If the note is below the middle line, its stem points upwards.

● If the note is on the middle line of the staff, its stem direction is determined by the stem
directions of any adjacent notes, beam groups, or chords. If they both have the same stem
direction, the note matches them. If the adjacent notes, beam groups, or chords have
different stem directions, or if there are no adjacent notes, beam groups, or chords, the
note follows the default stem direction.
The default stem direction depends on the instrument type. By default, the stems of notes
on the middle lines of staves point downwards on instrumental staves and upwards on
vocal staves, to avoid lyrics.

TIP

You can change the default stem direction for notes and beam groups on the middle lines
of staves, and equally balanced chords, in the Stems section of the Notes page in
Engraving Options. You can also choose whether they follow your default stem direction
or change according to the musical context.

Notes on the middle line are stem up because the
fourth note is stem up

Notes on the middle line are stem down because the
fourth note is stem down

By default, notes are first input into an up-stem voice, and Dorico Pro treats notes as the only
voice on the staff until you input more voices.

Single notes in multiple voices

When there are multiple voices on a staff and all voices contain notes, the stem direction of notes
is determined by the stem direction of their voice. Notes in up-stem voices have up stems, and
notes in down-stem voices have down stems. This applies even when the stems of notes would
normally point in the other direction, based on their position on the staff.
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NOTE

The order in which notes appear between different up-stem voices and different down-stem
voices depends on their pitch and your settings on the Voices page in Write > Notation
Options. You can also change the voice column index of notes individually.

When there are only notes in one voice for at least a whole bar, Dorico Pro automatically changes
the directions of stems so they point in the default direction for their pitch. For example, if a staff
contains a single up-stem voice and a single down-stem voice but only the down-stem voice
contains notes or rests, then the stems of notes in the down-stem voice may point upwards,
depending on the position of the notes on the staff. However, showing rests or implicit rests in
empty voices forces the stem direction of notes to follow the stem direction of their voice.

Notes in an up-stem voice shown
in blue.

Notes in a down-stem voice shown
in purple. The stems point
upwards despite being in a down-
stem voice because there are no
other voices.

When notes in up-stem and down-
stem voices are in the same bar,
the stem direction is automatically
changed.

Chords in single voices

The stem direction for a chord in a single voice is determined by the balance of notes above/
below the middle line of the staff.

● If the note furthest from the middle line is above the middle line, the stem of the chord
points downwards.

● If the note furthest from the middle line is below the middle line, the stem of the chord
points upwards.

● If the chord is equally balanced on either side of the middle line of the staff, the stem
direction is determined by the stem directions of any adjacent notes, beam groups, or
chords. If they both have the same stem direction, the chord matches them. If the adjacent
notes, beam groups, or chords have different stem directions, equally balanced chords
follow the default stem direction.
The default stem direction depends on the instrument type. By default, the stems of notes
on the middle lines of staves point downwards on instrumental staves and upwards on
vocal staves, to avoid lyrics.

TIP

You can change the default stem direction for notes and beam groups on the middle lines
of staves, and equally balanced chords, in the Stems section of the Notes page in
Engraving Options. You can also choose whether they follow your default stem direction
or change according to the musical context.

Beam groups in single voices

The stem direction within beam groups is determined by the balance of notes within the beam
group that are above/below the middle line of the staff.

● If the majority of notes in the beam group are above the middle line, stems in the beam
group point downwards.

● If the majority of notes in the beam group are below the middle line, stems in the beam
group point upwards.
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● If the beam group contains an equal number of notes either side of the middle line of the
staff, the stem direction is determined by the stem directions of any adjacent notes, beam
groups, or chords. If they both have the same stem direction, the beam group matches
them. If the adjacent notes, beam groups, or chords have different stem directions,
equally balanced beam groups follow the default stem direction.
The default stem direction depends on the instrument type. By default, the stems of notes
on the middle lines of staves point downwards on instrumental staves and upwards on
vocal staves, to avoid lyrics.

TIP

You can change the default stem direction for notes and beam groups on the middle lines
of staves, and equally balanced chords, in the Stems section of the Notes page in
Engraving Options. You can also choose whether they follow your default stem direction
or change according to the musical context.

RELATED LINKS
Project-wide engraving options for stems on page 942
Per-flow notation options for voices on page 1040
Voice column index on page 1042
Implicit rests in multiple-voice contexts on page 861
Note positions in multiple-voice contexts on page 1039
Changing the default stem direction of voices on page 946
Removing stem direction changes on page 947
Notation Options dialog on page 139

Changing the default stem direction behavior of notes on the middle
line of staves

The stems of notes on the middle lines of staves can point upwards/downwards. You can change
their default direction, and choose whether the stem direction is determined by the stem
directions of any adjacent notes, beam groups, or chords, or always uses the default direction.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Notes in the page list.

3. In the Stems section, choose one of the following options for Stem direction for notes on
the middle line of the staff in the Stem Directions subsection:

● Determine by context

● Use default direction

4. Optional: Choose one of the following options for Default stem direction for notes on
the middle line of the staff:

● Up

● Down

5. Click Apply, then Close.
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Changing the stem direction of notes
You can manually change the stem direction of any note.

PROCEDURE

1. Select the notes whose stem direction you want to change. You can do this in Write mode
and Engrave mode.

2. Change the stem direction in one of the following ways:

● Choose Edit > Stem > Force Stem Up.

● Choose Edit > Stem > Force Stem Down.

TIP

You can also choose these options from the context menu.

RESULT
The stem direction of the selected notes is changed. The selected notes follow this stem
direction, even if you later change their pitch to one that usually requires a different stem
direction.

NOTE

This does not change the voice to which notes belong.

EXAMPLE

Stems pointing in the same direction but in different
voices

Stems in the same direction and in the same voice

RELATED LINKS
Changing the voice of existing notes on page 287

Changing the default stem direction of voices
You can change the default stem direction of voices after they have been input, including slash
voices.

NOTE

This changes the implicit stem direction of the voice, but may not change the stem direction of all
notes in single-voice contexts. Stem directions are automatically changed in Dorico Pro when
only one voice contains notes.

PROCEDURE

1. Select a note or chord in the voice whose stem direction you want to change. You can do
this in Write mode and Engrave mode.

2. Change the default stem direction of the selected voice in one of the following ways:
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● Choose Edit > Voices > Default Stems Down.

● Choose Edit > Voices > Default Stems Up.

TIP

You can also choose these options from the context menu.

RELATED LINKS
Stem direction on page 943

Removing stem direction changes
You can remove changes to the directions of stems and revert stems to their default directions.

PROCEDURE

1. Select the notes whose stem direction changes you want to remove. You can do this in
Write mode and Engrave mode.

2. Choose Edit > Stem > Remove Forced Stem. You can also choose this option from the
context menu.

RESULT
All stem direction changes are removed from the selected notes. The stems of the selected notes
revert to their default directions.

NOTE

Alternatively, you can change the stem direction to the opposite direction. However, notes with
forced stems do not change automatically if, for example, you later change their pitch.

RELATED LINKS
Changing the stem direction of notes on page 946

Stem length
The length of stems is determined by default in Dorico Pro, according to accepted standards for
the appearance of stems of notes at different positions on staves.

You can change the default settings for the length of all stems project-wide and you can
lengthen/shorten individual stems in Engrave mode.

RELATED LINKS
Project-wide engraving options for stems on page 942

Lengthening/Shortening stems
You can lengthen/shorten the stems of individual notes, independently of your project-wide
settings.

PROCEDURE

1. In Engrave mode, select the stems you want to lengthen/shorten.

2. Lengthen/Shorten the stems in any of the following ways:

● Press Alt-Up Arrow to make stems longer.

● Press Alt-Down Arrow to make stems shorter.
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NOTE

If you want to lengthen/shorten stems by larger increments, you can press
Ctrl/Cmd as well as the standard key command, for example, Ctrl/Cmd-Alt-
Up Arrow.

● Click and drag the square handles at the end of the stems upwards/downwards.

RESULT
The selected stems are lengthened/shortened, regardless of their stem direction. For example,
selecting a down-stem note and pressing Alt-Up Arrow lengthens it by moving the end of the
stem downwards, away from the notehead.

TIP

● Stem adj. in the Notes and Rests group of the Properties panel is activated when you
lengthen/shorten stems.

You can also use this property to lengthen/shorten stems by changing the value in the
value field. However, the Notes and Rests group is only available when the notehead is
selected rather than the stem.

Deactivating the property resets the selected stems to their default length.

● You can change the default length of all stems project-wide in the Stems section of the
Notes page in Engrave > Engraving Options. There are different options for stems in
different contexts.

Hiding stems
You can hide the stems on notes with any notehead design.

Dorico Pro allows you to hide stems rather than using a stemless notehead design as this allows
you to hide the stem of any notehead design.

PROCEDURE

1. In Engrave mode, select the notes whose stems you want to hide.

2. In the Properties panel, activate Hide stem in the Notes and Rests group.

RESULT
The stems and any applicable flags of the selected notes are hidden. The stems remain
completely hidden even if you later change the pitch of the notes.
If the selected notes are part of beamed groups, the beams continue to be shown as normal,
unless you have hidden the stems of all notes in the beamed group, which also hides the beam.

RELATED LINKS
Lengthening/Shortening stems on page 947

Stems
Hiding stems 

948
Dorico 2.2.20



Split stems for altered unisons
Split stems can be used in chords containing altered unisons. They show the main body of the
chord as usual, but with a stem branch coming off the main stem that connects noteheads in
altered unisons to the chord.

Split stem chord

Split stems are also known as “cherry stalks” or “trees”. This is the default presentation of altered
unisons in Dorico Pro.

You can choose to show altered unisons with split stems or with single stems in each flow
independently on the Accidentals page in Write > Notation Options.

NOTE

If a chord contains notes a second interval apart and one of those notes has an altered unison, it
is always shown with a split stem, regardless of your setting. This is to ensure clarity in clusters.

RELATED LINKS
Altered unisons on page 491
Changing how altered unisons appear on page 492
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Tempo marks indicate how fast music is played, often with a combination of text instructions and
metronome marks. They are also known as “tempo changes”, “tempo indications”, and “tempo
markings”.

A tempo mark can show text instructions, a metronome mark, or a combination of the two.

Tempo mark containing text instruction in French and metronome mark

Text instructions are traditionally expressed in Italian, such as largo or allegretto, but other
languages, such as English, French, and German, have become widely accepted. The text
instruction can express simply how fast the music is played, but can also suggest its character.
For example, grave means slow but also solemn and sad, and vivo means fast but also lively and
sprightly.

Metronome marks show the speed of the music, indicated in beats per minute, or “bpm”.
Metronome marks can show a fixed bpm or indicate a range of possible or acceptable values.

Gradual tempo changes indicate a change in tempo over a defined period of time. They can
appear differently, for example, with/without a continuation line or with the text split into
syllables and spread across their duration.

Tempo marks use a bold font with a large point size, so they are clearly noticeable on the page.
They do not usually use an italic font.

In Dorico Pro, tempo marks are categorized as system objects. Therefore, tempo marks follow
your per-layout settings for the visibility and positioning of system objects, which you can change
on the Staves and Systems page in Setup > Layout Options.

If you do not input any tempo marks into your project, the default playback tempo is 120 bpm.

RELATED LINKS
Metronome marks on page 960
Gradual tempo changes on page 962
Tempo mark components on page 958
Input methods for tempo marks on page 196
Positions of tempo marks on page 953
System objects on page 925
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Changing the positions of system objects on page 926

Types of tempo marks
Dorico Pro groups tempo marks into different types according to their function and effect on the
music.

The following tempo changes are available in the Tempo panel in Write mode, but you can also
input all types of tempo changes using the tempo popover.

Absolute Tempo Change
Indicates a defined change in tempo, and is often shown with a metronome mark.

Gradual Tempo Change
Indicates a change in tempo over a defined period of time, such as rallentando
(slowing down) or accelerando (speeding up).

Relative Tempo Change
Indicates a change in tempo that is relative to the previous tempo, such as mosso
(movement).
Relative tempo changes often include modifiers that qualify the change, such as poco
meno mosso (a little less movement), and are not defined by a metronome mark. You
can, however, set a relative metronome mark change as a percentage of the
previous metronome mark.

Reset Tempo
Returns the tempo to the previous tempo, such as A tempo, or a previously defined
tempo, such as Tempo primo (return to the first tempo of the piece).

Tempo Equation
Indicates a change in the beat unit on which metronome marks are based. For
example, if the time signature changes from 3/4 to 6/8, a tempo equation of =
indicates the same metronome mark value that applied to the quarter note beat unit
in 3/4 now applies to the dotted quarter note beat unit in 6/8.

RELATED LINKS
Tempo panel on page 198
Gradual tempo changes on page 962
Input methods for tempo marks on page 196
Tempo popover on page 196

Text in tempo marks
All types of tempo marks use text, but gradual tempo changes use a different font style to
absolute, relative, and reset tempo changes. Tempo marks can have both full and abbreviated
text, allowing you to show the one most appropriate in each layout.

This allows you to customize the same tempo mark depending on the requirements of the
different types of layouts in your project. For example, if a tempo mark extends off the page in a
part layout, you can show the abbreviated text for that tempo mark instead without affecting the
length of the tempo mark in the full score layout.

You can change the appearance of fonts used for items in Dorico Pro that use text, but are not
text objects or text frames, in the Edit Font Styles dialog.

The following fonts are used for tempo marks:

● Gradual Tempo Text Font: Used for gradual tempo changes, such as rallentando.
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● Immediate Tempo Text Font: Used for absolute tempo changes, such as “Adagio”.

● Metronome Music Text Font: Used for the note value glyphs in metronome marks, such
as .

● Metronome Text Font: Used for the equation and numbers in metronome marks, such as
“=76”.

RELATED LINKS
Edit Font Styles dialog on page 364

Changing tempo text
You can change the text of existing tempo marks individually.

PROCEDURE

1. Select the tempo marks whose tempo text you want to change. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, enter the tempo text you want into the Text field in the Tempo
group.

3. Press Return.

RESULT
The tempo text for the selected tempo marks is changed.

TIP

You can also change the tempo text by opening the tempo popover and changing the entry.

RELATED LINKS
Tempo popover on page 196
Changing existing items on page 280

Showing abbreviated tempo text
You can show individual tempo marks with custom abbreviated text, for example, if a long tempo
mark extends beyond the page boundary in some part layouts but the abbreviated version fits
within the boundary.

PROCEDURE

1. In the music area, open the layout in which you want to show abbreviated tempo text. You
can do this in Write mode and Engrave mode.

2. Select the tempo marks you want to show with abbreviated text.

3. In the Properties panel, activate Abbreviation in the Tempo group.

4. Enter the text you want into the value field.

5. Activate Abbreviate in the Tempo group.

6. Activate the corresponding checkbox.

RESULT
The selected tempo marks appear with abbreviated text. This does not affect the appearance of
the same tempo mark in layouts that show full tempo text as properties in Dorico Pro are layout-
specific.
Abbreviated tempo text is shown when Abbreviation is activated and Abbreviate is deactivated,
or when Abbreviation and both Abbreviate and its corresponding checkbox are all activated.
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This allows you to switch between showing abbreviated/full text in different layouts without
deleting your abbreviated text from the Abbreviation value field.

RELATED LINKS
Tempo mark components on page 958

Adding poco a poco text to gradual tempo changes
You can add poco a poco text immediately after individual gradual tempo changes.

NOTE

You can also enter poco a poco directly into the tempo popover. However, this means the entry is
treated as a tempo mark rather than a gradual tempo change, which changes the properties you
can use on it.

PROCEDURE

1. Select the gradual tempo changes to which you want to add poco a poco text. You can do
this in Write mode and Engrave mode.

2. In the Properties panel, activate Poco a poco in the Tempo group.

RESULT
Poco a poco text is shown immediately after the text in the selected gradual tempo changes.
Deactivating Poco a poco (little by little) removes poco a poco text from the selected gradual
tempo changes.

EXAMPLE

Rallentando with poco a poco text

Positions of tempo marks
Tempo marks are placed above the staff and at the same positions as other system objects,
because they usually apply to all staves. They are placed above notations such as slurs, ties, and
octave lines, and are often aligned with rehearsal marks to ensure clear readability.

Tempo marks should be aligned with either a time signature or the notehead/rest at the
rhythmic position to which they apply. For example, if there is a notehead with an accidental at
the rhythmic position of a tempo mark, it is convention to align the tempo mark with the
accidental.

If a repeat mark occurs mid-system and is not treated as a barline, tempo marks are aligned with
the repeat mark.

When a tempo mark includes both text and a metronome mark, the text appears first, followed
by the metronome mark. When horizontal space is tight, the metronome mark can be positioned
below the tempo mark text.

You can move tempo marks to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.
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You can move tempo marks graphically in Engrave mode, but this does not change the rhythmic
positions to which they are attached.

You can change the default positions and appearance of tempo marks project-wide on the
Tempo page in Engrave > Engraving Options.

Tempo marks are categorized as system objects in Dorico Pro, which you can show above the
first bracket of selected instrument families. You can change the instrument families above which
system objects appear in each layout independently, for example, if you want tempo marks to
appear at multiple vertical positions in each system in the full score only.

RELATED LINKS
Project-wide engraving options for tempo marks on page 958
System objects on page 925
Changing the positions of system objects on page 926

Moving tempo marks rhythmically
You can move tempo marks to new rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the tempo marks you want to move.

NOTE

When using the mouse, you can only move one tempo mark at a time.

2. Move the tempo marks according to the current rhythmic grid value in any of the following
ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Click and drag the tempo mark to the right/left.

RESULT
The selected tempo marks are moved according to the current rhythmic grid value.

NOTE

Only one tempo mark can exist at each rhythmic position. If a tempo mark in your selection
passes over another tempo mark as part of its move, the existing tempo mark is deleted.

You can undo this action, but any tempo marks deleted in the process are only restored if you
moved the tempo mark using the keyboard.

RELATED LINKS
Lengthening/Shortening gradual tempo changes on page 956

Moving tempo marks graphically
You can move tempo marks graphically without changing the rhythmic positions to which they
apply. You can move the start/end of gradual tempo changes independently, meaning you can
also lengthen/shorten individual gradual tempo changes graphically.

NOTE

You cannot change the angle of gradual tempo changes.
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PROCEDURE

1. In Engrave mode, select one of the following that you want to move:

● Tempo marks

● Individual start/end handles of gradual tempo changes

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the tempo marks or handles in any of the following ways:

● Press Alt-Right Arrow to move tempo marks or handles to the right.

● Press Alt-Left Arrow to move tempo marks or handles to the left.

● Press Alt-Up Arrow to move tempo marks or whole gradual tempo changes
upwards.

● Press Alt-Down Arrow to move tempo marks or whole gradual tempo changes
downwards.

NOTE

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected tempo marks, gradual tempo changes, or handles are moved to new graphical
positions.

TIP

The following properties in the Tempo group of the Properties panel are activated automatically
when you move tempo marks in the corresponding directions:

● Start offset moves tempo marks and the start of gradual tempo changes. X moves them
horizontally, Y moves them vertically.

● End X moves the end of gradual tempo changes horizontally.

For example, if you move a whole gradual tempo change, both handles are moved so both
properties are activated. You can also use these properties to move tempo marks and lengthen/
shorten gradual tempo changes graphically by changing the values in the value fields. However,
you cannot move absolute tempo marks and gradual tempo changes graphically at the same
time when using these properties.

Deactivating the properties resets the selected tempo marks and gradual tempo changes to their
default positions.

RELATED LINKS
Lengthening/Shortening gradual tempo changes on page 956
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Changing the end position of gradual tempo changes relative to
barlines

You can change how the ends of individual gradual tempo change continuations are positioned
relative to barlines, independently of your project-wide setting.

NOTE

This does not affect the appearance of gradual tempo changes with the text-only style.

PROCEDURE

1. In Engrave mode, select the gradual tempo changes whose end position relative to
barlines you want to change.

2. In the Properties panel, activate Barline interaction in the Tempo group.

3. Choose one of the following options:

● Stop before

● Continue

RESULT
The end position of the selected gradual tempo changes is changed.

NOTE

You can change the default position of all gradual tempo change ends project-wide in the
Horizontal Position section of the Tempo page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for tempo marks on page 958
Changing the style of gradual tempo changes on page 963

Lengthening/Shortening gradual tempo changes
You can lengthen/shorten gradual tempo changes rhythmically after they have been input.

PROCEDURE

1. In Write mode, select the gradual tempo changes you want to lengthen/shorten.

NOTE

When using the mouse, you can only lengthen/shorten one gradual tempo change at a
time.

2. Lengthen/Shorten the gradual tempo changes in any of the following ways:

● To lengthen them by the current rhythmic grid value, press Shift-Alt-Right Arrow.

● To shorten them by the current rhythmic grid value, press Shift-Alt-Left Arrow.

NOTE

Key commands lengthen/shorten items by moving their end only.

● Click and drag the circular handle at the start/end to the right/left.
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RESULT
The selected gradual tempo changes are lengthened/shortened according to the current
rhythmic grid value.

TIP

You can adjust the graphical positions of gradual tempo changes in Engrave mode.

RELATED LINKS
Moving tempo marks graphically on page 954

Hiding/Showing tempo marks
You can hide/show the different components in individual tempo marks without changing the
speed of playback. This affects their appearance in all layouts.

PROCEDURE

1. In Write mode or Engrave mode, select one of the following:

● The tempo marks you want to hide

● The signposts of tempo mark you want to show

2. In the Properties panel, activate/deactivate the following properties in the Tempo group:

● Text shown

● Metronome mark shown

RESULT
When at least one of the properties is activated, the selected tempo marks are shown. They
display components according to the properties that are activated.
When neither property is activated, the selected tempo marks are hidden. Signposts are shown
at their positions as they still affect the speed of playback.

RELATED LINKS
Tempo mark components on page 958
Changing the type and appearance of absolute tempo changes on page 959

Deleting tempo marks
You can delete tempo marks, which resets the tempo for playback to the previous tempo mark or
the default tempo if there is no previous tempo mark.

PROCEDURE

1. In Write mode, select the tempo marks or the signposts of tempo marks you want to
delete.

2. Press Backspace or Delete.

RESULT
The selected tempo marks are deleted and no longer appear in the music area or in the Time
track in Play mode. The tempo in playback follows the previous tempo mark, or the default
tempo of 120 bpm if there is no previous tempo mark.
If you delete a tempo mark that truncated the line of a gradual tempo change, the line of the
gradual tempo change automatically extends to its full length or until the next existing tempo
mark.
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Project-wide engraving options for tempo marks
You can find options for the project-wide appearance of tempo marks on the Tempo page in
Engrave > Engraving Options.

The options on the Tempo page allow you to change the appearance of tempo marks, and their
position relative to the staff, time signature changes, and other items. You can also change the
appearance, thickness, and position of continuation lines relative to barlines for gradual tempo
changes.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Tempo mark components
Tempo mark components include text, metronome marks, parentheses, and approximate
indications. Tempo marks can include different components in different combinations,
depending on your preference or the requirements for different projects.

You can change which components are shown in different types of tempo marks project-wide,
and you can change which components are shown in individual tempo marks.

You can activate properties that correspond to the different components in the Tempo group of
the Properties panel. You can activate one or more of the following tempo mark properties in any
combination for individual absolute tempo changes:

Text shown
Shows text when activated, and no text when deactivated.

Metronome mark shown
Shows metronome marks when activated, and no metronome marks when
deactivated.

Parenthesized
Shows metronome marks in parentheses when activated, and without parentheses
when deactivated. This also applies to approximate metronome marks.

Is approximate
Shows metronome marks as approximate when activated, and absolute when
deactivated.

Approximate appearance
Allows you to choose how approximate metronome marks appear, for example, c. or
circa.

NOTE

This property applies specifically to approximate tempo marks, and is only available
when Is approximate is activated.

Show equals sign
An equals sign is shown when the property and its corresponding checkbox are both
activated. No equals sign is shown when the checkbox is deactivated.

Tempo marks
Project-wide engraving options for tempo marks 

958
Dorico 2.2.20



NOTE

This property applies specifically to approximate tempo marks, and is only available
when Is approximate is activated.

Components for gradual tempo changes

The following components only apply to gradual tempo changes, such as rallentando:

Poco a poco
Poco a poco text is shown immediately after gradual tempo change text when the
checkbox beside the property is activated.

RELATED LINKS
Project-wide engraving options for tempo marks on page 958
Adding poco a poco text to gradual tempo changes on page 953

Changing the type and appearance of absolute tempo changes
You can change which components are included in individual absolute tempo changes, and how
they appear.

PROCEDURE

1. Select the absolute tempo marks whose components you want to change. You can do this
in Write mode and Engrave mode.

2. In the Properties panel, activate any of the following properties in the Tempo group:

● Text shown

● Metronome mark shown

● Parenthesized

● Is approximate

● Approximate appearance (only available if Is approximate is activated)

● Show equals sign (only available if Is approximate is activated)

RESULT
The selected tempo marks are changed to include the corresponding components.

NOTE

If you have activated none of these properties, no tempo mark is shown in the music. Instead, a
signpost indicates the position of the tempo mark.

RELATED LINKS
Tempo mark components on page 958
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Metronome marks
Tempo marks often include a metronome mark value. Metronome marks show the speed of the
music, indicated in beats per minute, or “bpm”. For example, a bpm of 60 means one beat per
second. The more beats per minute, the faster the music.

A metronome mark shown as a range

Metronome marks can be precise, such as  = 176, or can indicate an acceptable range, such as 
= 152-176. They can also be shown in parentheses, which is useful if the metronome mark is
intended as a guide rather than a fixed value.

The beat unit used in metronome marks commonly relates to the meter, for example, the
metronome mark beat unit is often a quarter note in 4/4 but a dotted quarter note in 6/8.

In Dorico Pro, metronome marks can appear as an individual value or as a range. Depending on
the type and appearance of metronome marks, the bpm value can indicate a fixed tempo or an
approximate tempo.

RELATED LINKS
Input methods for tempo marks on page 196
Changing the type and appearance of absolute tempo changes on page 959

Changing the metronome mark value
You can change the metronome mark value of individual absolute tempo marks after they have
been input, including changing the beat unit.

NOTE

These steps do not apply to gradual tempo changes or reset/relative tempo marks.

PROCEDURE

1. Select the absolute tempo marks whose metronome mark values you want to change. You
can do this in Write mode and Engrave mode.

2. In the Properties panel, change the value for Tempo (bpm) in the Tempo group.

3. Press Return.

4. Choose the appropriate note duration and rhythm dot, if applicable, for Beat unit.

RESULT
The metronome mark value and beat unit is changed for the selected absolute tempo marks.
This affects the tempo of playback, even if no metronome mark component is shown for those
tempo marks.

NOTE

● If you enter decimals, Dorico Pro automatically rounds them up/down to the nearest
whole number for the metronome mark. However, your specified value still affects the
tempo in playback.

● You can also change the metronome mark value by opening the tempo popover and
changing the entry.

Tempo marks
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RELATED LINKS
Tempo popover on page 196
Changing existing items on page 280

Showing the metronome mark value as a range
You can show the metronome mark value of individual absolute tempo marks as a range. For
example, you can use this to indicate that any speed within the given range is musically
appropriate for the piece.

NOTE

These steps do not apply to gradual tempo changes or reset/relative tempo marks.

PROCEDURE

1. Select the absolute tempo marks whose metronome mark values you want to show as a
range. You can do this in Write mode and Engrave mode.

2. In the Properties panel, activate Tempo range (bpm) in the Tempo group.

3. Change the value in the value field.

RESULT
The tempo range, expressed as beats per minute, is changed for the selected tempo marks. By
default, metronome mark ranges use a dash separator.

NOTE

● Depending on the values set for each property, both Tempo (bpm) and Tempo range
(bpm) can be the minimum/maximum tempo in the range, as Dorico Pro automatically
arranges metronome mark ranges with the lower value first. However, the metronome
mark used for playback is always Tempo (bpm), regardless of whether that is the higher/
lower value in the range.

● You can change the default separator used for metronome mark ranges in the Absolute
Changes section of the Tempo page in Engrave > Engraving Options.

RELATED LINKS
Changing the metronome mark value on page 960

Changing the relative tempo mark value
You can change the tempo of individual relative tempo marks, expressed as a percentage of the
previous tempo mark.

PROCEDURE

1. Select the relative tempo marks whose value you want to change. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, change the value for Relative % in the Tempo group.

3. Press Return.

RESULT
The tempo at the relative tempo mark is changed. For example, if the previous tempo was
100 bpm, and you change a relative tempo mark to 90, the new tempo is 90% of 100 bpm, which
is 90 bpm.
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Changing the final tempo at the end of gradual tempo changes
You can change how significantly gradual tempo changes affect the tempo in playback,
expressed as a percentage of the tempo at the start of the gradual tempo change.

PROCEDURE

1. Select the gradual tempo changes whose final tempo you want to change. You can do this
in Write mode and Engrave mode.

2. In the Properties panel, change the value for Final tempo % in the Tempo group.

3. Press Return.

RESULT
The final tempo at the end of the selected gradual tempo changes is changed.
For example, if you change the value to 20 on a gradual tempo change that started at 100 bpm,
the final tempo is 20% of 100 bpm, which is 20 bpm. If you change the value to 120 on a gradual
tempo change that started at 100 bpm, the final tempo is 120% of 100 bpm, which is 120 bpm.

Gradual tempo changes
Gradual tempo changes indicate a change in tempo over a defined period of time, such as
rallentando, which indicates slowing down, and accelerando, which indicates speeding up.

Rallentando with dashed line

Gradual tempo changes are considered a type of tempo mark in Dorico Pro, meaning you can
input them in the same ways as for tempo marks.

Because gradual tempo changes have a different metronome mark value at the start/end, you
can change the final tempo at the end of individual gradual tempo changes.

In Dorico Pro, you can show gradual tempo changes with different styles.

● rit.: Shows gradual tempo changes with text only.

● rit...: Shows gradual tempo changes with text and a continuation line.

● rit-e-nu-to: Shows gradual tempo changes with the text hyphenated and separated into
syllables.

You can also show gradual tempo changes with different line styles.

You can change both the style and line style of all gradual tempo changes project-wide on the
Tempo page in Engrave > Engraving Options, and change the style and line style of individual
gradual tempo changes independently of your project-wide settings.

RELATED LINKS
Input methods for tempo marks on page 196
Changing the line style of gradual tempo changes on page 963
Project-wide engraving options for tempo marks on page 958
Changing the final tempo at the end of gradual tempo changes on page 962

Tempo marks
Gradual tempo changes 

962
Dorico 2.2.20



Changing the style of gradual tempo changes
You can change the style of individual gradual tempo changes, independently of your project-
wide setting. Gradual tempo changes can appear as text only with no continuation line, text with
a continuation line, or with the word spread across their duration.

PROCEDURE

1. Select the gradual tempo changes whose style you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Gradual style in the Tempo group.

3. Select one of the following options from the menu:

● rit.

● rit...

● rit-e-nu-to

RESULT
The style of the selected gradual tempo changes is changed.

TIP

You can change the style of all gradual tempo changes project-wide on the Tempo page in
Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for tempo marks on page 958

Changing the line style of gradual tempo changes
You can change the line style of individual gradual tempo changes whose style includes a
continuation line, independently of your project-wide settings.

NOTE

This does not affect the appearance of gradual tempo changes with the text-only style.

PROCEDURE

1. Select the gradual tempo changes whose line style you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Line style in the Tempo group.

3. Select one of the following options from the menu:

● Solid

● Dotted

● Dashed

RESULT
The line style of the selected gradual tempo changes is changed.

TIP

You can change the default line style of all gradual tempo changes project-wide on the Tempo
page in Engrave > Engraving Options.

Tempo marks
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Lengthening/Shortening gaps and dashes in gradual tempo changes
You can change the length of dashes and the gaps between dashes in individual gradual tempo
changes, independently of your project-wide settings.

NOTE

This only applies to gradual tempo changes with dashed lines.

PROCEDURE

1. In Engrave mode, select the gradual tempo changes with dashed lines whose dash length
you want to change.

2. In the Properties panel, activate the following properties, individually or together, in the
Tempo group:

● Line dash length

● Line dash gap

3. Change the values in the value fields.

RESULT
Increasing Line dash length makes dashes in gradual tempo changes longer, decreasing the
value makes dashes shorter.
Increasing Line dash gap makes gaps between dashes in gradual tempo change lines longer,
decreasing the value makes gaps shorter.

TIP

You can find options that change the default dash length for all dashed gradual tempo changes
project-wide by clicking Advanced Options in the Gradual Changes section of the Tempo page
in Engrave > Engraving Options.

For example, you can change the default dash length for dashed lines following text and dashed
lines between hyphenated text separately.

RELATED LINKS
Project-wide engraving options for tempo marks on page 958

Changing the line thickness of gradual tempo changes
You can change the thickness of dashed and solid lines in gradual tempo changes individually,
independently of your project-wide settings.

PROCEDURE

1. In Engrave mode, select the gradual tempo changes whose thickness you want to change.

2. In the Properties panel, activate Line thickness in the Tempo group.

3. Change the value in the value field.

RESULT
Increasing the value makes dashed and solid lines thicker, decreasing the value makes dashed
and solid lines thinner.

Tempo marks
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TIP

You can change the thickness of all dashed and solid gradual tempo change lines project-wide on
the Tempo page in Engrave > Engraving Options.

Tempo equations
Tempo equations indicate a change in the beat unit on which metronome marks are based. They
are often used to maintain a consistent pulse across multiple different meters.

For example, if the time signature changes from 6/8 to 3/4, a tempo equation of  = indicates the
same metronome mark value that applied to the dotted quarter note beat unit in 6/8 now applies
to the quarter note beat unit in 3/4.

RELATED LINKS
Input methods for tempo marks on page 196
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A tie is a curved line that joins two notes of the same pitch. When multiple, adjacent notes are
joined with a sequence of ties, that is known as a tie chain.

Each sequence of tie chains, whether they join two notes together or ten notes together,
represents a single note with the duration of all the tied notes combined. A performer plays the
notes as one note, without re-striking, re-blowing, or re-bowing the note at any point within the
rhythmic duration of the tie chain.

A tie chain across several bars on the bottom piano staff

In Dorico Pro, most ties are created automatically. Rhythms are notated according to the
prevailing beat grouping, which is normally set by the time signature. Therefore, notes that
cannot be notated using a single duration are automatically drawn as separate tied notes.

RELATED LINKS
Tie chains on page 968
Inputting notes on page 149
Forcing the duration of notes/rests on page 158
Inputting ties on page 166
Splitting tie chains on page 972
Time signatures on page 981
Input methods for time signatures on page 190
Beams according to time signatures on page 539

General placement conventions for ties
Ties join two noteheads together, meaning the ends of ties are positioned close to the noteheads
to which they are attached.

Ties are curved lines, and the direction of the curve usually follows the stem direction of the
notes. If notes are stem-up, ties curve downwards, and if notes are stem-down, ties curve
upwards.

NOTE

If there are multiple voices on the staff, all ties in up-stem voices curve upwards and all ties in
down-stem voices curve downwards.

There are two main conventions for the placement of the ends of ties relative to noteheads. One
convention is to place the ends of ties outside noteheads, meaning above or below them, ideally

Ties
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positioned at the horizontal center of noteheads. The other convention is to place the ends of
ties between noteheads, ideally positioned at the vertical center of noteheads.

A tie outside noteheads A tie between noteheads

For both conventions, Dorico Pro automatically positions the ends of ties as close as possible to
the notes that they join while avoiding collisions with other notations.

The vertical placement of ties is also automatically adjusted in Dorico Pro so that neither of the
end points of ties, nor the apex of tie curves, starts or ends on a staff line. If this happens, it can
cause the shape of ties to appear distorted, which makes the music harder to read.

To avoid this, Dorico Pro changes the vertical position of ties slightly, and makes small changes to
the curvature of ties. These changes are small, but the placement of ties is subtly different
depending on the position of notes relative to staff lines.

A tie outside noteheads When transposed one note down, the tie appears
with a steeper curve to avoid reaching its apex on
the staff line.

A tie between noteheads, with the ends slightly
above the vertical center of the noteheads to avoid
the tie appearing too close to the staff line at its
ends or apex.

When transposed up, the ends of the tie are now
positioned at the vertical center of the notehead, as
there is no staff line with which it could collide.

Wherever possible, clef changes should not be positioned in the middle of tie chains. Changing
the clef changes the position of the tied note on the staff, which could easily cause a performer
to misread the tie as a slur and play two different notes.

Ties can look distorted when they are very short, and can be overlooked. You can change the
minimum length of ties when they are within a single system on the Ties page in Engrave >
Engraving Options.

NOTE

Slurs must not be confused with ties, which look superficially similar, but instead join notes of the
same pitch to indicate that they are played as a single note. In that sense, ties are part of
rhythmic notation, while slurs are considered articulation.

RELATED LINKS
Ties vs. slurs on page 968
Inputting ties on page 166
Project-wide engraving options for ties on page 968
General placement conventions for clefs on page 581

Ties
General placement conventions for ties 

967
Dorico 2.2.20



Project-wide engraving options for ties
You can find options for the project-wide appearance, position, and placement of ties on the Ties
page in Engrave > Engraving Options.

The options on the Ties page allow you to change the default curvature direction, shape, and
appearance of ties, and the position of ties relative to noteheads and other ties in tie chains.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Tie chains
When notes are longer than the maximum duration of a bar in the prevailing time signature, ties
can extend over multiple bars. In Dorico Pro, such ties are known as tie chains.

For example, if you input a note that is longer than a whole note in a 4/4 time signature, it
becomes two or more notes tied together in a chain across multiple bars.

In Write mode, you can only select whole tie chains. In Engrave mode, you can select individual
ties within tie chains. Any changes you make to tie chains in Write mode only affect the first tie in
the chain.

NOTE

Dorico Pro automatically adjusts tied notes in the following circumstances:

● If you change the pitch of a tied note, which includes adding or removing an accidental,
the change is applied to all the notes that are tied together.

● If you add or remove an articulation, the articulation is added only to the start or the end
of the tie chain as appropriate, for example, to the last note for an articulation of duration
or to the first note for an articulation of force.

Articulations relative to tie chains

The positions of articulations relative to tie chains depend on the type of articulation. You can
change the positions of articulations relative to tie chains project-wide and for individual tie
chains.

RELATED LINKS
Positions of articulations on page 499
Changing the positions of articulations on tied notes on page 500

Ties vs. slurs
Ties and slurs look superficially similar but differ in meaning.

Ties indicate that a note should not be re-struck. They are used to join notes of the same pitch
together. For example, ties can be used to extend notes across multiple bars. Although multiple
notes can be included in a single tie chain, each tie in the chain only joins one notehead to the
next notehead on the staff.

Ties can be used in conjunction with articulation, but articulation on tied notes only affects the
attack at the start of the tie chain and the release at the end of the tie chain.

Ties
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Two long notes tied together

Slurs indicate articulation, such as bowing or breathing, and normally group notes of different
pitches together. Slurs can join two noteheads together with any number of pitches in between.
They often indicate the shaping of phrases.

Slurs can also be used in conjunction with articulation. Unlike ties, articulation within slurs can
affect the sound throughout the phrase. For example, staccato articulations on repeated notes of
the same pitch within a slur indicate that notes should be played on a stringed instrument using
the same bow direction, but stopping the bow between each note.

A phrase with notes grouped together by slurs

Non-standard ties
Usually, ties join two notes of the same pitch in the same staff. However, ties can also cross
system breaks and frame breaks, clef changes, or time signature changes. These types of ties are
all positioned automatically in Dorico Pro.

Ties can also join non-adjacent notes, notes in different voices, or notes in different staves
together. In Dorico Pro, you must input these types of ties manually.

Ties across system breaks and page breaks

The ends of ties that cross system breaks are automatically positioned in Dorico Pro.

Their vertical position remains the same, as both ends are centered on the noteheads to which
they are attached. Their behavior also remains the same, as selecting one note in a tie chain that
crosses a system or frame break in Write mode selects all notes in the tie chain.

The horizontal space for the parts of ties shown to the left of notes at the start of new systems/
frames may not be sufficient to show an ideal tie curve. In such cases, you can use Note Spacing
in Engrave mode to adjust the spacing of individual notes at the start of systems/frames to give
ties more space.

The start of a tie chain before a system break The end of the same tie chain after a system break

Tied notes with accidentals across system breaks and page breaks

The ends of ties for tied notes with accidentals across system breaks and page breaks are also
automatically positioned.

As tied notes in Dorico Pro are treated as one note notated to fit in time signatures, cautionary
accidentals at the start of new systems/frames are not shown by default. If you choose to show
accidentals beside notes in tie chains at the start of new systems/frames, the position of the
notes is changed to accommodate accidentals. However, this automatic position might not leave
sufficient room for the part of the tie to the left of the notes to be shown with an ideal curve.

Ties
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The start of a tie chain before a
system break

The end of the same tie chain,
with a cautionary accidental in
parentheses

The end of the same tie chain after
adjusting note spacing to give the
tie beside the accidental more
space

Ties across time signature changes

Ties are automatically positioned between notes that span a time signature change. If ties
crossing a time signature change are joining notes in the middle of a staff, the top or bottom of
time signature changes are partially obscured by the ties. However, as ties are curved, the time
signature is unlikely to be completely obscured.

Ties across clef changes

Ties are automatically positioned between notes that span a change of clef. Ties across clef
changes are not horizontal, as the same pitch is positioned differently in each clef.

The result of cross-clef ties is likely to be visually and musically confusing, as they can be misread
as slurs. In this case, consider moving the change of clef to before/after the tied note.

Ties between non-adjacent notes

You can input ties between notes of the same pitch that are not directly beside each other. This
can be useful when inputting ties between multiple notes before a chord, for example.

Notes leading into a chord notated
as a series of tied chords

Notes leading into a chord notated
as tied non-adjacent notes

Multiple grace notes before a
chord with ties between non-
adjacent notes

Ties between different voices

You can input ties between notes of the same pitch in different voices.

Ties between notes on different staves

You can input ties between notes of the same pitch in different staves.

Laissez vibrer ties

Laissez vibrer ties are short ties that indicate a note should be left to ring, and should not be
stopped. They extend a small amount to the right of the note to which they apply, but do not
connect to another note.

You can add laissez vibrer ties to any note. You can edit laissez vibrer ties in Engrave mode like any
other tie.

RELATED LINKS
Hiding/Showing laissez vibrer ties on page 971
Hiding/Showing or parenthesizing accidentals on page 489
Note spacing on page 381
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Adjusting note spacing at individual rhythmic positions on page 388

Inputting ties between non-adjacent notes
You can manually input ties between notes of the same pitch that are not rhythmically adjacent.
You can also input ties between notes of the same pitch in different voices and different staves.

For example, you might have input a melody across multiple voices in order to accommodate
passing notes, but want to tie two notes together even though they are in different voices.
Similarly, you might have written multiple notes before a chord that are all held down and want
to reduce the number of tied notes.

PROCEDURE

1. In Write mode, select the two notes that you want to tie together.

NOTE

The second note must be the same pitch as the first note. If the second note is a different
pitch to the first note, no tie is input.

2. Press T.

RESULT
A tie is input between the two selected notes.

EXAMPLE

Spread chord with ties between all adjacent notes Spread chord with ties between non-adjacent notes

RELATED LINKS
Inputting ties on page 166

Hiding/Showing laissez vibrer ties
You can add laissez vibrer ties to any note.

PROCEDURE

1. Select the notes on which you want to add a laissez vibrer tie. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate/deactivate Laissez vibrer tie in the Notes and Rests
group.

RESULT
Laissez vibrer ties are added to the selected notes when the property is activated, and are
removed when the property is deactivated. Laissez vibrer ties are positioned automatically.

TIP

● You can edit the length and shape of laissez vibrer ties individually like any other tie in
Engrave mode.
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Non-standard ties 

971
Dorico 2.2.20



● You can assign a key command for Toggle Laissez Vibrer Tie on the Key Commands page
in Preferences.

RELATED LINKS
Changing the position/shape of ties on page 973

Deleting ties
You can delete ties without deleting the notes to which they are attached.

NOTE

Deleting ties from tie chains removes all ties in the tie chain. If you want to remove single ties
from longer tie chains, you can split the tie chain.

PROCEDURE

1. In Write mode, select the tie chains from which you want to delete all ties.

2. Press U.

RESULT
All ties in the selected tie chains are deleted. Notes previously in the tie chain remain at their
rhythmic positions.

RELATED LINKS
Changing the duration of notes on page 157

Splitting tie chains
You can split tie chains at specified positions, for example, if you want to change the pitch
halfway through a tie chain or delete individual ties within tie chains. This does not remove any
other ties in the tie chain.

PROCEDURE

1. In Write mode, select the tie chain you want to split.

2. Press Shift-N or Return to start note input.

3. Move the caret to where you want to split the tie chain.

● Press Right Arrow/Left Arrow to move the caret to the right/left, according to the
current rhythmic grid value.

● Press Space to advance the caret to the next rhythmic position, according to the
note value currently selected.

4. Press U to split the tie chain.

5. Optional: If you want to split the same tie chain in multiple places, move the caret to the
next rhythmic position where you want to split the tie chain.

6. Press Esc or Return to stop note input.

RESULT
The tie chain is split at the caret position.

RELATED LINKS
Moving the caret manually on page 148
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Changing the position/shape of ties
Each tie has five square handles that you can move separately to change the appearance and
shape of individual ties.

A tie in Engrave mode

NOTE

Moving one handle can also affect the positions of other handles.

For example, moving the left endpoint moves the start of a tie, but the rest of the handles stay in
their existing positions. However, moving the left control point also causes the tie height handle
to move. This gives you fine control over the shape of ties while ensuring that the end result
remains curved and smooth.

PROCEDURE

1. In Engrave mode, select the tie handles you want to move in any of the following ways:

● Select a whole tie and press Tab to cycle through its handles until the one you want
to move is selected.

● Click the handle you want to move.

● Ctrl/Cmd-click individual handles on multiple ties.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The positions of the selected tie handles are changed, which changes the shape of the
corresponding ties.

TIP

The following properties in the Ties group of the Properties panel are activated automatically
when you move the corresponding tie handles:

● Start offset moves the left endpoints of ties. X moves them horizontally, Y moves them
vertically.
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● End offset moves the right endpoints of ties. X moves them horizontally, Y moves them
vertically.

● Start handle offset moves the left control points of ties. X moves them horizontally, Y
moves them vertically.

● End handle offset moves the right control points of ties. X moves them horizontally, Y
moves them vertically.

You can also use these properties to change the shape of individual ties by changing the values
in the value fields.

Deactivating the properties resets the corresponding handles on the selected ties to their default
positions.

Tie shoulder offset
Tie shoulders affect the angles of the curves of ties as they taper towards an endpoint, as the
tapered ends often approach noteheads at a steeper angle than that of a tie’s arch.

Increasing the shoulder offset makes the onset of the curve shallower, whereas decreasing the
shoulder offset makes the onset steeper.

You can change the project-wide settings for the offset of tie shoulders by changing the values
for the following options, which you can find by clicking Advanced Options in the Design section
of the Ties page in Engrave > Engraving Options:

● Offset shoulders by fraction of half length of short tie

● Offset shoulders by fraction of half length of long tie

A long tie with default shoulder offset (1/10) A long tie with increased shoulder offset (7/8)

You can also change the shoulder offset of ties individually by moving their control point handles
in Engrave mode.

RELATED LINKS
Project-wide engraving options for ties on page 968

Changing the shoulder offset of ties
You can change the shoulder offset of individual ties, independently of your project-wide
settings. For example, you might want to change the shoulder offset of a few very short or very
long ties in your project to improve their shape.

PROCEDURE

1. In Engrave mode, select one of the control point handles on each of the ties whose
shoulders you want to adjust in any of the following ways:

● Select a whole tie and press Tab to cycle through the handles until the one you want
to move is selected.

● Click the handle you want to move.

● Ctrl/Cmd-click individual handles on multiple ties.

Ties
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TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

3. Optional: Repeat steps 1 and 2 for the other control point handle on the ties whose
shoulders you want to adjust.

RESULT
Moving tie offset handles further apart reduces the shoulder offset, while moving them closer
together increases the shoulder offset.

TIP

The following properties in the Ties group of the Properties panel are activated automatically
when you move the corresponding tie handles:

● Start handle offset moves the left control points of ties. X moves them horizontally, Y
moves them vertically.

● End handle offset moves the right control points of ties. X moves them horizontally, Y
moves them vertically.

You can also use these properties to change the shoulder offset of individual ties by changing the
values in the value fields.

Deactivating the properties resets the corresponding handles on the selected ties to their default
positions.

TIP

You can find options controlling the default shoulder offset of all ties project-wide by clicking
Advanced Options in the Design section of the Ties page in Engrave > Engraving Options.
There are separate settings for short ties and long ties.

RELATED LINKS
Project-wide engraving options for ties on page 968

Tie height
You can change values for the heights of all short ties and long ties project-wide. You can also
change the height of individual ties in Engrave mode.

You can find options that change the project-wide heights of ties by clicking Advanced Options
in the Design section of the Ties page in Engrave > Engraving Options. There are separate
settings for short ties and long ties.

Ties
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Increasing the height of ties makes them extend further from the staff, which gives them a
rounder shape and means they take up more vertical space. Ties generally do not need to be as
curved as slurs, as they join notes of the same pitch instead of arching over or above a range of
pitches.

Where vertical space is tight, a balance must be found between how curved ties are and ensuring
staves do not overlap.

A long tie with default height A long tie with increased height

Changing the height of ties
You can change the height of individual ties, independently of your project-wide settings, for
example, to save vertical space.

PROCEDURE

1. In Engrave mode, select the tie height (middle) handle of the ties whose height you want
to change.

TIP

You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2. Move the handles in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

● Click and drag them upwards/downwards.

RESULT
The height of the selected ties is changed.

NOTE

● To maintain a visually pleasing and symmetrical curve when changing the height of ties
manually, you may need to move tie height handles to the right/left by a small amount, as
well as upwards/downwards.

● Moving tie height handles to the right/left affects the shape of the whole tie.

● You can find options controlling the default height of all ties project-wide by clicking
Advanced Options in the Design section of the Ties page in Engrave > Engraving
Options. There are separate settings for short ties and long ties.

RELATED LINKS
Project-wide engraving options for ties on page 968
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Tie styles
There are different styles of ties available in Dorico Pro, which you can use to indicate different
meanings.

Solid
This is the default style for ties. Ties appear as tapered solid lines: thinner at the ends
and thicker in the middle.

Dashed
Ties appear as tapered dashed lines. Can be used to denote optional or suggested
ties, for example, in vocal music where some verses have more syllables than others
and therefore require more notes.

Dotted
Ties appear as dotted lines. The dots are the same size and the same distance apart
over the whole length of the tie. Can also be used to denote optional or suggested
ties.

Half-dashed start
The first halves of ties appear as dashed lines, the second halves as solid lines. Used
to denote that a tie was written incompletely in the source in critical editions.

Half-dashed end
The first halves of ties appear as solid lines, the second halves as dashed lines. Used
to denote that a tie was written incompletely in the source in critical editions.

Editorial
Ties appear as solid black lines, but with a smaller vertical line intersecting them
exactly halfway along their length. Used to show that ties were added by the editor
and were not present in the source.

Changing the style of ties
You can change the style of individual ties. By default, all ties are solid.

NOTE

You can only select whole tie chains in Write mode. Any changes to tie chains in Write mode only
affect the first tie in the tie chain.

PROCEDURE

1. Select the ties whose style you want to change. You can do this in Write mode and Engrave
mode.
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NOTE

● In Write mode, you can only select whole tie chains. In Engrave mode, you can select
individual ties within tie chains.

● Any changes to tie chains in Write mode only affect the first tie in the chain.

2. In the Properties panel, activate Style in the Ties group.

3. Select one of the following options from the menu:

● Solid

● Dashed

● Dotted

● Half-dashed start

● Half-dashed end

● Editorial

RESULT
The style of the selected ties is changed.

TIP

You can set the precise parameters of each of these options project-wide on the Ties page in
Engrave > Engraving Options. For example, you can change the length and width of the stroke
in Editorial ties, the diameter of dots and length of dashes, and the sizes of the gaps between
dots and dashes.

Changing the size of dashes/dots in ties
You can change the size of the dashes/dots in dashed/dotted ties individually, independently of
your project-wide settings.

NOTE

This only applies to dashed/dotted ties.

PROCEDURE

1. Select the dashed/dotted ties whose dash/dot size you want to change. You can do this in
Write mode and Engrave mode.

NOTE

● In Write mode, you can only select whole tie chains. In Engrave mode, you can select
individual ties within tie chains.

● Any changes to tie chains in Write mode only affect the first tie in the chain.

2. In the Properties panel, activate Dash/dot in the Ties group.

3. Change the value in the value field.

RESULT
Increasing the value makes dashes/dots bigger, decreasing the value makes dashes/dots
smaller.
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TIP

You can find options to set the default size of dashes/dots in all dashed/dotted ties project-wide
by clicking Advanced Options in the Design section of the Ties page in Engrave > Engraving
Options.

You can also change the thickness of all tie styles on this page. However, you cannot change the
thickness of ties individually.

RELATED LINKS
Project-wide engraving options for ties on page 968

Changing the size of gaps in dashed/dotted ties
You can change the size of the gaps in dashed/dotted ties individually, independently of your
project-wide settings.

PROCEDURE

1. In Engrave mode, select the individual dashed/dotted ties whose gap size you want to
change.

2. In the Properties panel, activate Gap in the Ties group.

3. Change the value in the value field.

RESULT
Increasing the value makes the gaps between dashes/dots larger. Decreasing the value makes
the gaps between dashes/dots smaller.

TIP

You can find options to set the default size of the gaps between dashes/dots in all dashed/dotted
ties project-wide by clicking Advanced Options in the Design section of the Ties page in
Engrave > Engraving Options.

Tie curvature direction
The direction of tie curvatures is determined by the stem direction of the notes/chords at each
end of the tie, the number of notes in chords at each end, and the number of voices on the staff.

Tied single notes in single-voice contexts

If a single voice is active and a tie joins two single notes, tie curvature direction is determined by
the stem directions of the notes at either end of the tie.

● If the stem directions match, the tie curves away from the notes and is positioned on the
notehead side.

● If the stem directions differ, the tie curves upwards by default.

Tied chords in single-voice contexts

If a tie joins two chords, the direction of the ties is determined by the number of tied notes in the
chords.

● For an even number, the ties are equally split between curving towards the notehead end
and curving towards the stem end.

● For an uneven number, the majority of ties curve towards the notehead end.
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Tied notes in multiple-voice contexts

Ties are positioned on the stem side and are curved as follows:

● For up-stem voices, ties curve upwards.

● For down-stem voices, ties curve downwards.

● For overlapping/interlocking pitches in multiple voices, the rules for tied chords in single-
voice contexts apply. All notes in all voices are treated as if they belong to a single voice.

TIP

You can change the default tie curvature direction of ties between notes with different stem
directions on the Ties page in Engrave > Engraving Options.

You can also change the curvature direction of ties individually.

Changing the curvature direction of ties
You can change the curvature direction of ties individually, including individual ties within tie
chains.

PROCEDURE

1. Select the ties whose curvature direction you want to change. You can do this in Write
mode and Engrave mode.

NOTE

● In Write mode, you can only select whole tie chains. In Engrave mode, you can select
individual ties within tie chains.

● Any changes to tie chains in Write mode only affect the first tie in the chain.

2. In the Properties panel, activate Direction in the Ties group.

3. Choose one of the following options:

● Up

● Down

RESULT
The curvature direction of the selected ties is changed.

TIP

You can adjust the precise shapes of tie chains, and of each tie within tie chains, in Engrave mode
using the square handles on each tie.

RELATED LINKS
Changing the position/shape of ties on page 973
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Time signatures indicate the meter of music, and apply to all bars from where they first appear
until a subsequent change of time signature. Meter describes the rhythmic pulse of music, and
its division into beats and bars.

A time signature is made up of two parts, and can be described using the same mathematical
terms used for fractions: numerator on top, and denominator underneath.

The numerator specifies the number of multiples of the duration specified by the denominator.
The denominator doubles for every halving of the beat duration: 1 is a whole note (breve), 2 is a
half note (minim), 4 is a quarter note (crotchet) and so on. Depending on your settings for time
signature style, numerators and denominators can have different appearances.

For example, a 4/4 time signature tells you the bar is made up of four beats, and each of those
beats is a quarter note in length. A time signature of 4/2 contains four half notes in each bar, and
4/8 contains four eighth notes (quavers) in each bar. Both 3/4 and 6/8 contain six eighth notes,
but it is understood that a 3/4 bar contains three quarter note beats, whereas a 6/8 bar contains
two dotted quarter note beats.

Bars are rhythmic groups, divided according to the time signature, and they make following the
music much more practical. Notes are beamed differently in different time signatures, again to
make the meter clear and easily readable.

By default, time signatures apply to all staves. However, there are some situations, such as in
polymetric music, that require some parts to have their own time signature, independently of the
rest of the ensemble. You can input time signatures that apply to all staves or only apply to single
staves in Dorico Pro.

NOTE

Beat lengths are fixed across all staves in your project, regardless of the time signature. For
example, if you have a 2/4 time signature on one staff and a 6/8 time signature on another staff,
then one quarter note in the 2/4 time signature equals one quarter note in the 6/8 time
signature, meaning their barlines do not match.

RELATED LINKS
Time signature styles on page 988
Input methods for time signatures on page 190
Conventions for beam grouping according to meter on page 553
Time Signatures (Meter) panel on page 192
Creating custom beat groupings for meters on page 554
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General conventions for time signatures
Over time, the placement and appearance of time signatures has developed conventions to
ensure that their notation is always understood. Dorico Pro follows these conventions
automatically.

Appearance conventions

Time signatures should fill the height of the staff. There is a risk they may not be noticed if they
are smaller. The size of time signatures on staves with fewer than five lines should be the same
as that of a time signature on an equivalent five-line staff.

Time signature on a five-line staff Time signature on a single-line staff

Time signatures use a unique, heavy font that ensures they stand out against staff lines, and are
instantly recognizable.

For some types of music, particularly film music, it is typical to use large time signatures that
span several staves.

Placement conventions

Time signatures should be shown at the start of a piece and at the start of subsequent
movements, if applicable, even if the music carries straight on. They should be placed after clefs
and key signatures.

If time signature changes occur during a piece or movement, it should be placed immediately
after a barline. Dorico Pro automatically inserts a barline before a time signature change if it
occurs in the middle of an existing bar. However, Dorico Pro does not override your existing
music by inserting extra beats, unless Insert mode is activated.

A 4/4 time signature interrupting a 5/8 time signature, input without Insert mode activated, leaving only
three eighth note beats in the second 5/8 bar.

A time signature applies until the next time signature change, the end of the movement, or the
end of a piece, whichever comes first.

RELATED LINKS
Inputting notes in Insert mode on page 153
Large time signatures on page 986
Changing the size and position of time signatures on page 988
Time signature font styles on page 997

Project-wide engraving options for time signatures
You can find options for the project-wide appearance of time signatures, including large time
signatures, on the Time Signatures page in Engrave > Engraving Options.

The options on this page allow you to change the appearance of all numerators and
denominators project-wide, the appearance of meterless time signatures, and how
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interchangeable time signatures are separated. You can also change the default gaps in time
signatures, for example, the gap between interchangeable time signatures and their separator.
Separate sections control the appearance and position of large time signatures when shown
once per bracketed group and when shown at system object positions, including how collisions
with other items at the same position as time signatures shown at system object positions are
avoided.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299
Time signatures on page 981
Large time signatures on page 986

Project-wide spacing gaps for time signatures
You can change the minimum gaps between objects, including time signatures, on the Spacing
Gaps page in Engrave > Engraving Options.

The following minimum values relate to time signatures:

● Gap after barline before clef, key or time signature

● Gap after key signature

● Gap after mid-system time signature

Other values may have an effect on the position of time signatures; however, they also affect
other objects.

Types of time signatures
There are different types of time signatures, which can indicate various and complex meters.

NOTE

Dorico Pro uses the definitions for meters commonly used in American English. These
definitions, such as which meters are considered simple and compound, might be different in
other languages.

Simple
In simple time signatures, each beat is divided by two into equal groups of notes.
Simple time signatures can be simple duple, such as 2/4, simple triple, such as 3/4, or
simple quadruple, such as 4/4.

Compound
In compound time signatures, each beat is divided by three into equal groups of
dotted notes, such as 6/8, which contains two dotted quarter note beats, or 9/4,
which contains three dotted half note beats.

Irregular
Irregular time signatures, such as 5/4 or 7/8, cannot be subdivided into equal beat
groups. Because the numerator is odd, these time signatures must be divided into
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unequal beat groups. For example, 5/4 usually contains a half note beat and a dotted
half note beat.

Additive
Additive time signatures show how bars are subdivided into beat groups. You can
show beat group numerators for any type of time signature. For example, instead of
7/8, you could show an additive time signature of 2+3+2/8.

Alternating
An alternating time signature indicates a regular pattern that switches every bar
between two or more time signatures, in the indicated order. For example, for a
phrase with twelve eighth notes that needs to be emphasized 3+3+2+2+2, an
alternating time signature of 6/8+3/4 might allow the two meters to be read more
clearly.

Interchangeable
An interchangeable time signature indicates a set of time signatures at the start of
the piece that can be used during the piece, such as 3/4–2/4. Unlike alternating time
signatures, interchangeable time signatures do not require a fixed pattern; any bar
in the piece can follow any of the time signatures in the set without having to restate
the time signature.

NOTE

You must manually input the appropriate time signatures where you want them, as
unlike alternating time signatures, there is no fixed pattern for them. Any time
signatures you input that are specified in the interchangeable time signature are
hidden automatically.

They can have different separator styles in Dorico Pro, which you can set project-
wide and also change individually.

Aggregate
An aggregate time signature shows two or more meters within the same bar, such as
2/4+3/8+5/4. Dorico Pro automatically inputs dashed barlines to show the divisions
between each meter.

Open
An open time signature has no restrictions on meter, beaming, or beats. Any number
of notes can be added, with any beaming. In Dorico Pro, an open time signature can
be shown with an X or N, or without any signature.
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Non-power of two
A non-power of two time signature is one such as 5/6, which indicates five sextuplet
notes lasting for a whole note (semibreve). Examples of time signatures like this can
be found in the music of Adès.

Some composers, such as Boulez, have written fractional time signatures. Dorico Pro does not
currently support these.

RELATED LINKS
Time signature styles on page 988
Large time signatures on page 986
Input methods for time signatures on page 190
Time signatures popover on page 191

Pick-up bars
Pick-up bars allow you to include music before the first full bar. They are also known as “upbeats”
or “anacrusis”. Often, pick-up bars only comprise a few beats whose main purpose is to lead in to
the start of the piece.

Pick-up bar of a single quarter note beat at the start of Chopin's Mazurka Op. 30 No. 2

Pieces that start with a pick-up bar have time signatures that are positioned at the start of the
system as normal. However, the first full bar of the time signature occurs after the first barline
and not before. Therefore, pick-up bars do not contribute to the bar number count. Bar numbers
are counted from the first full bar in the flow.

Because pick-up bars are linked to the number of notes/rests in the music, in Dorico Pro they are
linked to time signatures and so you must input pick-up bars alongside a time signature.
However, you can hide time signatures you do not want to show in the music.

RELATED LINKS
Input methods for time signatures on page 190
Hiding/Showing time signatures on page 996
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Defining partial bars as pick-up bars or irregular bars
You can change whether explicit irregular bars at the start of time signatures are defined as pick-
up bars. This affects how notes in the bars are beamed and grouped.

Notes in irregular bars defined as pick-up bars are beamed/grouped backwards from the end of
the bar, while notes in irregular bars not defined as pick-up bars are beamed/grouped forwards
from the start of the bar.

NOTE

You must input explicit irregular bars and pick-up bars as part of a time signature, such as by
entering 4/4,1.5 into the time signatures popover to input a 4/4 time signature with a pick-up bar
containing 1.5 quarter note beats, or three eighth notes.

PROCEDURE

1. Select the time signatures or the signposts of time signatures starting with an explicit
irregular bar whose pick-up definition you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Group first bar as pick-up in the Time Signatures group.

3. Activate/Deactivate the corresponding checkbox.

RESULT
Irregular bars at the start of the selected time signatures are defined as pick-up bars when
Group first bar as pick-up and its corresponding checkbox are both activated, and defined as
normal irregular bars when the corresponding checkbox is deactivated.
When the property is deactivated, Dorico Pro uses internal heuristics to define them as either
pick-up bars or normal irregular bars automatically.

EXAMPLE

Irregular bar defined as pick-up into common time Irregular bar defined as normal irregular bar, not a
pick-up

Large time signatures
Large time signatures are scaled-up time signatures that appear much larger than normal
relative to the staff size. They can be helpful in orchestral scores, as the smaller staff size in such
scores means standard time signatures are small and harder for conductors to read.

Large time signatures are also very commonly used in film scores, as conductors rarely have
much time to prepare the scores before recording sessions. Having large time signatures makes
changes in meter more visually clear on the page, especially when music contains multiple
changes in meter.

In Dorico Pro, you can show large time signatures at the following positions:

● Once per bracketed group

● Above the staff and at system object positions
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Time signatures shown once per bracketed group

Instead of showing a time signature on every staff that is the same height as the staff, you can
instead show a single large time signature on each bracketed group of staves. When shown once
per bracketed group, time signatures are scaled up in size according to the number of staves in
the bracketed group. The largest time signatures are shown on bracketed groups containing four
or more staves. When shown on single staves, they extend a small amount above and below the
staff, which is commonly used for parts for film music recording sessions.

Narrow, serif time signatures shown once per bracketed group

You can change the size of time signatures on different sizes of bracketed groups on the Time
Signatures page in Engrave > Engraving Options. You can also change whether all the staves
between the brass and string brackets, which often include percussion, harp, and piano, are
treated as a single bracket or separately for the purposes of showing large time signatures.

Large time signatures shown on bracketed groups occupy horizontal space, which can be a
significant amount when they are especially large and use the standard time signature design.
Therefore, we recommend that you use one of the narrow designs in layouts that show large
time signatures on bracketed groups.

Time signatures shown at system object positions

Similar to showing large time signatures once per bracketed group, you can also show time
signatures only at system object positions and above the staff. Therefore, its positions in each
system are controlled by the same options that control the positions of other system objects,
such as rehearsal marks and tempo marks.

Normal time signatures shown at system object positions

Time signatures shown at system object positions do not occupy horizontal space, meaning it is
less important to use a narrow font style. This also reduces the horizontal distance between
notes either side of time signatures. Because of this reduced disruption to note spacing, this
placement of time signatures has become popular in contemporary art music since the 20th
Century.

When using the note denominator style for time signatures shown at system object positions,
the note is shown to the right of the numerator rather than below.

By default, time signatures at system object positions are twice the size of normal time
signatures and force other items at the same position to appear to the right. You can change
their scale factor and the default position of other items at the same position on the Time
Signatures page in Engraving Options. You can also change their alignment relative to barlines.
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RELATED LINKS
Time signature font styles on page 997
Changing the design of time signatures on page 997
Changing the position of time signatures on bracketed groups on page 995
System objects on page 925
Changing the positions of system objects on page 926
Hiding bar numbers at time signatures shown at system object positions on page 529

Changing the size and position of time signatures
You can change the size of time signatures in each layout independently, including changing
their vertical position. For example, you can show large time signatures centered on each bracket
in full score layouts but standard-sized time signatures on each staff in part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the size of time
signatures.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Time Signatures in the page list.

4. Choose one of the following options for Time signature position and size:

● Show on every staff

● Show once per bracket

● Show at system object positions

5. Click Apply, then Close.

RESULT
The size and position of time signatures in the selected layouts is changed.
Showing large time signatures above the staff at system object positions means they do not
occupy any rhythmic or horizontal space, whereas the other options do cause time signatures to
occupy horizontal space.

AFTER COMPLETING THIS TASK
You can change whether large time signatures are placed vertically in the middle or on the top of
bracketed groups on the Time Signatures page in Engrave > Engraving Options.

RELATED LINKS
Large time signatures on page 986
Positions of time signatures on page 992
Hiding bar numbers at time signatures shown at system object positions on page 529
Project-wide engraving options for time signatures on page 982

Time signature styles
Dorico Pro allows you to show time signatures in a variety of styles. For example, you can show
denominators as a number or as a note value.

You can change the style of all time signatures project-wide according to their type on the Time
Signatures page in Engrave > Engraving Options, and you can change the style of individual
time signatures independently of your project-wide settings.
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The numerator is always one or more numbers, and can either show the total number of beats in
the bar, or show how the total duration of the bar is subdivided.

Numerator in a 7/8 time signature shown as a single
number

Numerator in a 7/8 time signature showing
subdivisions

The denominator can appear as a number, as a note indicating the equivalent duration, or not
appear at all.

Denominator shown as number Denominator shown as notehead
(beat length)

No denominator shown

If shown as a notehead, the denominator can either show the length of each beat in the bar, or
the note duration for the bar. When showing the beat length, the numerator can also be
changed. In the example, the numerator 6 in the 6/8 time signature becomes a 2 to reflect the
two dotted quarter note beats that make up a 6/8 bar.

Denominator notehead showing the beat length of a
6/8 time signature

Denominator showing the note duration of a 6/8
time signature

RELATED LINKS
Project-wide engraving options for time signatures on page 982
Changing the design of time signatures on page 997
Changing the separator style of interchangeable time signatures on page 991
Changing the open meter style of time signatures on page 990

Changing the numerator style of time signatures
You can choose whether the numerators of individual time signatures show the total number of
beats in each bar, or the subdivision of beats in each bar, independently of your project-wide
setting.

PROCEDURE

1. Select the time signatures whose numerator style you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Numerator style in the Time Signatures group.

3. Choose one of the following options:

● Number

● Beat group

RESULT
The numerator style of the selected time signatures is changed.
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TIP

You can change the numerator style of all time signatures project-wide on the Time Signatures
page in Engrave > Engraving Options.

RELATED LINKS
Time signature styles on page 988
Project-wide engraving options for time signatures on page 982

Changing the denominator style of time signatures
You can change the denominator style of individual time signatures independently of your
project-wide settings, for example, if you want to show the denominator as a note instead of a
number.

PROCEDURE

1. Select the time signatures whose denominator style you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate Denominator style in the Time Signatures group.

3. Choose one of the following options:

● Number

● Note

● None

RESULT
The denominator style of the selected time signatures is changed.

TIP

You can change the denominator style of all time signatures project-wide on the Time
Signatures page in Engrave > Engraving Options.

RELATED LINKS
Time signature styles on page 988
Project-wide engraving options for time signatures on page 982

Changing the open meter style of time signatures
You can change the open meter style of individual time signatures, independently of your
project-wide setting.

PROCEDURE

1. Select the open meter time signatures whose style you want to change. You can do this in
Write mode and Engrave mode.

NOTE

In the Properties panel, Open style in the Time Signatures group is automatically
activated for open meter time signatures.

2. In the Properties panel, choose one of the following options for Open style in the Time
Signatures group:

● No symbol
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● X

● Penderecki’s symbol

RESULT
The open meter style of the selected time signatures is changed.

TIP

You can change the style of all open meter time signatures project-wide on the Time Signatures
page in Engrave > Engraving Options.

RELATED LINKS
Time signature styles on page 988
Project-wide engraving options for time signatures on page 982

Changing the separator style of interchangeable time signatures
You can change the separator shown in interchangeable time signatures individually,
independently of your project-wide setting.

PROCEDURE

1. Select the interchangeable time signatures whose separator you want to change. You can
do this in Write mode and Engrave mode.

NOTE

In the Properties panel, Separator in the Time Signatures group is automatically
activated for interchangeable time signatures.

2. Select one of the following options from the Separator menu:

● Parentheses

● Brackets

● Equals sign

● Slash

● Space

● Hyphen
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RESULT
The separator style of the selected interchangeable time signatures is changed.

NOTE

● You can change the default separator of all interchangeable time signatures project-wide
on the Time Signatures page in Engrave > Engraving Options.

● Although they might look similar to interchangeable time signatures, aggregate time
signatures behave differently. Aggregate time signatures are separated by a + sign,
whereas interchangeable time signatures can be shown with six different separators but
not a + sign.

Therefore, although you can activate Separator and choose from the available options for
aggregate time signatures, the property only affects the appearance of interchangeable
time signature separators.

RELATED LINKS
Time signature styles on page 988
Project-wide engraving options for time signatures on page 982

Positions of time signatures
Standard time signatures are positioned on staves with the middle staff line, or only staff line for
single-line staves, passing through their center. Large time signatures can be positioned in the
middle or at the top of bracket groups, or above staves at system object positions.

You can move time signatures to different rhythmic positions in Write mode. They move
according to the current rhythmic grid value and are positioned by default according to your
settings in Engraving Options.

You can move individual time signatures graphically in Engrave mode; however, this does not
change the rhythmic positions to which they are attached.

You can change the default positions of all time signatures project-wide, including both their
horizontal and vertical positions, on the Spacing Gaps and Time Signatures pages in Engrave >
Engraving Options.

You can also change the position of time signatures in each layout independently, for example, if
you want to show time signatures above the staff and at system object positions in some layouts
but only once per bracket in other layouts.

RELATED LINKS
System objects on page 925
Changing the positions of system objects on page 926
Changing the size and position of time signatures on page 988
Moving tempo marks graphically on page 954
Moving time signatures shown at system object positions graphically on page 994
Changing the position of time signatures on bracketed groups on page 995
Project-wide engraving options for time signatures on page 982
Project-wide spacing gaps for time signatures on page 983

Moving time signatures rhythmically
You can move time signatures to new rhythmic positions after they have been input.

NOTE

● You can only move time signatures rhythmically using the keyboard.
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● Time signatures can only be moved along staves. If you want to move a time signature
across staves, you must delete the time signature and input a new time signature on the
other staff.

● If you want to adjust the default position of time signatures relative to notes or barlines,
you must change the project-wide values for spacing gaps on the Spacing Gaps page in
Engrave > Engraving Options.

PROCEDURE

1. In Write mode, select the time signatures you want to move.

2. Move the time signatures according to the current rhythmic grid value in any of the
following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

RESULT
The time signature takes effect from its new position until the next existing time signature, or the
end of the flow. Barlines are automatically updated either side of the time signature up to the
previous/next existing time signature, or the start/end of the flow.

NOTE

Only one time signature can exist at each rhythmic position, except for time signatures that only
apply to single staves. If a time signature moves to the exact rhythmic position of another time
signature as part of its move, the existing time signature is deleted.

You can undo this action which restores any time signatures deleted in the process.

Moving time signatures graphically
You can move individual time signatures to new graphical positions without affecting the
positions of any other items.

NOTE

● These steps do not apply to time signatures shown at system object positions.

● You cannot move time signatures shown at the start of systems. You can only move time
signature changes that occur partway through systems or at the end of systems.

PROCEDURE

1. In the Engrave toolbox, activate Note Spacing.

2. Select a square note spacing handle at the rhythmic position of the time signature you
want to move.

A circular handle appears beside the time signature.

3. Press Tab to select the circular handle.
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4. Move the handle in any of the following ways:

● Press Alt-Right Arrow to move it to the right.

● Press Alt-Left Arrow to move it to the left.

NOTE

● If you want to move handles by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● You cannot move note spacing handles with the mouse, you can only move
them using the keyboard.

RESULT
The time signature is moved graphically to the right/left.

TIP

You can also change the value for Spacing offset in the Time Signatures group of the Properties
panel to move time signatures horizontally. However, this also affects global note spacing
around the rhythmic position of the time signature.

The Spacing offset value is independent of note spacing changes.

RELATED LINKS
Note spacing on page 381

Moving time signatures shown at system object positions
graphically

You can move time signatures shown at system object positions graphically, in different ways to
moving other time signatures graphically.

NOTE

● These steps do not apply to time signatures shown on staves.

● If you want to move time signatures because you want to change their alignment with
barlines, you can change the default alignment of all time signatures shown at system
object positions in the Time Signatures at System Object Positions section of the Time
Signatures page in Engrave > Engraving Options.

PROCEDURE

1. In Engrave mode, select the time signatures at system object positions that you want to
move graphically.

2. Move the time signatures in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.
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TIP

If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

RESULT
The selected time signatures shown at system object positions are moved to new graphical
positions.

TIP

Offset in the Time Signatures group of the Properties panel is activated automatically when you
move time signatures shown at system object positions graphically.

● Offset X moves time signatures horizontally.

● Offset Y moves time signatures vertically.

You can also use this property to move time signatures shown at system object positions
graphically by changing the values in the value fields.

Deactivating the property resets the selected time signatures to their default positions.

RELATED LINKS
Changing the size and position of time signatures on page 988
Hiding bar numbers at time signatures shown at system object positions on page 529
System objects on page 925
Changing the positions of system objects on page 926
Moving time signatures graphically on page 993
Project-wide engraving options for time signatures on page 982

Changing the position of time signatures on bracketed groups
By default, time signatures shown once per bracket are centered on each bracketed group. You
can change their vertical position on bracketed groups for all layouts project-wide, for example, it
is common in film scores to show the top of large time signatures aligned with the top of each
bracketed group.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Time Signatures in the page list.

3. In the Time Signatures Centered on Brackets section, choose one of the following
options for Vertical alignment relative to bracket:

● Top

● Middle

4. Click Apply, then Close.

RESULT
The vertical alignment of large time signatures relative to bracketed groups is changed in all
layouts project-wide.

RELATED LINKS
Positions of time signatures on page 992

Time signatures
Positions of time signatures 

995
Dorico 2.2.20



Large time signatures on page 986
Changing the size and position of time signatures on page 988

Hiding/Showing time signatures
You can hide/show time signatures without deleting them from your project. This hides/shows
them in all layouts, not just the one currently open in the music area.

PROCEDURE

1. Select the time signatures you want to hide/show. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate/deactivate Hide time signature in the Time Signatures
group.

RESULT
The selected time signatures are hidden in all layouts when Hide time signature is activated,
and shown when it is deactivated.
Signposts are shown at the positions of each time signature so you can always find them again.
However, signposts are not printed by default.

NOTE

● Hidden time signatures do not take up any horizontal space, so hiding/showing time
signatures affects note spacing.

● You can hide/show time signature signposts by choosing View > Signposts > Time
Signatures. Time signature signposts are shown when a tick appears beside Time
Signatures in the menu, and hidden when no tick appears.

You can choose to print time signature signposts if you activate View options in the
Annotations section of the Print Options panel on the right of the window in Print mode.

● You can assign a key command for Hide/Show Item on the Key Commands page in
Preferences, which applies to chord symbols, playing techniques, and time signatures.

RELATED LINKS
Note spacing on page 381

Deleting time signatures
You can delete time signatures without affecting the relative rhythmic positions of notes.

PROCEDURE

1. In Write mode, select one of the following:

● The time signatures you want to delete.

● The signposts of hidden time signatures you want to delete.

2. Press Backspace or Delete.

RESULT
The time signatures are deleted from the score. Bars after their previous positions are re-barred
according to the previous time signature in the score, up until the next time signature or the end
of the flow.
If you delete the only time signature in the flow, your music appears in an open meter, but with
all the same rhythmic values.
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RELATED LINKS
Types of time signatures on page 983

Time signature font styles
Different time signature designs use different font styles. You can edit the formatting of fonts
used for time signatures in the Edit Font Styles dialog.

● You can open the Edit Font Styles dialog in Engrave mode by choosing Engrave > Font
Styles.

The following fonts are used for time signatures:

● Time Signature Font
Used for standard time signatures and large time signatures that use the Normal,
Narrow, serif, or Narrow, sans serif design types. Must use a SMuFL-compliant font
family.

● Time Signature Plain Font
Used for time signatures using the Plain font design type. Can use any font family, but we
recommend that you use narrow fonts for large time signatures.

NOTE

Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Edit Font Styles dialog on page 364
Large time signatures on page 986

Changing the design of time signatures
You can change the design of time signatures in each layout independently, including changing
the font style used for them, for example, if you want to use a plain font for time signatures in
full score layouts but the standard time signature font in part layouts.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the design of time
signatures.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Time Signatures in the page list.

4. Choose one of the following options for Time signature design:

● Normal

● Narrow, serif

● Narrow, sans serif

● Plain font

5. Click Apply, then Close.

RESULT
The design of time signatures in the selected layouts is changed. If you choose Plain font, time
signatures use a different font style than the one used for the other options.
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RELATED LINKS
Time signature styles on page 988
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Tremolos are thick, slanted lines that cross individual stems or are positioned between multiple
stems. They are used to indicate that notes are repeated, either individually or in sequences of
multiple notes.

Using tremolo strokes instead of notating each notehead can save horizontal space and make
fast passages easier to read.

The number of tremolo strokes indicates both how many times notes are repeated and how fast
they are. In measured tremolos, for example, one tremolo stroke on the stem of a quarter note
(crotchet) indicates two eighth notes (quavers) are played, whereas three tremolo strokes on the
stem of a quarter note indicates eight 32nd notes are played.

Quarter note with a one-stroke single-note tremolo
and its equivalent notation

Quarter note with a three-stroke single-note tremolo
and its equivalent notation

There are different types of tremolos:

Single-note tremolos
Individual notes are repeated.

Multi-note tremolos
Multiple notes, usually two, are played in sequence, similar to a trill. However, trills
usually indicate a fast alternation between two adjacent notes, such as G and A,
whereas multi-note tremolos can be between any notes, limited only by the
capabilities of the instrument.

Tuplet tremolos
Multiple notes in tuplets are repeat in the notated sequence.

Depending on the musical context, tremolos can be either measured or unmeasured. There is no
visual difference between measured/unmeasured tremolos, so composers/arrangers often
specify how they want tremolos to be played, such as an indication in the front matter of the
score or as a text instruction in the score.

Tremolos
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Measured tremolos
The number of tremolo strokes corresponds to a precise rhythm in the prevailing
tempo and meter.

Unmeasured tremolos
There is no link between the number of strokes and rhythm. Instead, unmeasured
tremolos are played as fast as possible, whatever the tempo.
Unmeasured tremolos often use three or more tremolo strokes, and can also be
accompanied by a “trem.”text indication.

RELATED LINKS
Input methods for repeats and tremolos on page 253

Tremolos in tie chains
By default, all notes in tie chains are shown with tremolo strokes when single-note tremolos are
added to tie chains. Deleting tremolo strokes from tied notes removes tremolo strokes from all
notes in tie chains.

In Dorico Pro, tremolos are considered measured by default, so the number of tremolo strokes
shown is automatically adjusted on subsequent notes in tie chains as required. For example, if an
eighth note with two tremolo strokes is tied to a quarter note, the quarter note has three
tremolo strokes. This is because tremolo strokes function like beams, so two tremolo strokes and
an eighth note stem flag is the equivalent of three tremolo strokes.

However, there might be circumstances in which you want all notes to have the same number of
tremolo strokes, whatever their duration. You can also start tremolos partway through tie chains,
or stop tremolos partway through tie chains.

You can change the number of tremolo strokes shown on individual notes independently in
Engrave mode.

Changing the number of tremolo strokes on individual notes in tie
chains

Dorico Pro automatically changes the number of tremolo strokes on subsequent notes in tie
chains according to their duration, but you can manually change the number of single-note
tremolo strokes shown on each note in tie chains individually to represent your intended rhythm.

PROCEDURE

1. In Engrave mode, select the noteheads of the notes whose number of tremolo strokes you
want to change.

2. In the Properties panel, activate Single stem tremolo in the Notes and Rests group.

3. Select one of the following options from the menu:

● None

● One stroke

● Two strokes

● Three strokes

● Four strokes

● Buzz roll

RESULT
The number of tremolo strokes shown on the selected notes is changed.

Tremolos
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EXAMPLE

The default number of tremolo strokes in a tie chain
where the second note is longer than the first.

The number of tremolo strokes on the second note
has been changed to match the first.

RELATED LINKS
Changing the speed of tremolos on page 1001

General placement conventions for tremolos
Single-note tremolos are positioned on note stems, whereas multi-note tremolos are positioned
between the stems of two or more notes. When multi-note tremolos cross three or more notes,
the tremolo strokes are positioned between all the notes.

Tremolo strokes are slightly thinner than beams, so that the gaps between strokes are large
enough and the number of strokes can be instantly recognized.

Tremolo strokes should not collide with ledger lines or stem flags. Dorico Pro automatically
positions tremolo strokes to ensure such collisions are avoided.

Tremolo strokes within the staff are positioned so that they are at least one staff space clear of
noteheads, and at valid positions relative to staff lines and staff spaces. This means that tremolo
strokes might not move every time you change the pitch of notes.

The positions of the tremolo strokes on the first two notes and the last two notes are the same, although the
pitches are all different.

In Dorico Pro, the angle of single-note tremolo strokes is always the same, no matter the
direction of the phrase. The angles of multi-note tremolo strokes are determined by the height of
the stems to which the multi-note tremolos apply. You can change the angles of multi-note
tremolo strokes individually by lengthening/shortening the stems at the start/end of the tremolo.

You can change the default positions of all tremolo strokes project-wide on the Tremolos page in
Engrave > Engraving Options.

RELATED LINKS
Moving tremolo strokes on page 1003
Project-wide engraving options for tremolos on page 1004

Changing the speed of tremolos
You can change the speed of tremolos after they have been input by changing the number of
strokes.

PROCEDURE

1. In Write mode, select the notes with tremolos whose speed you want to change.
The buttons with the number of tremolo strokes corresponding to your selection are
highlighted in the Tremolos section of the Repeat Structures panel.
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NOTE

Select single-note tremolos and multi-note tremolos separately.

2. Click the button with the number of tremolo strokes you want in the Tremolos section of
the Repeat Structures panel.
For example, click Two Strokes Single-note Tremolo to input single-note tremolos with
two strokes, or click Three Strokes Multi-note Tremolo to input multi-note tremolos with
three strokes.

Two Strokes Single-note Tremolo Three Strokes Multi-note Tremolo

RESULT
The number of tremolo strokes on the selected notes is changed, which changes the speed of
the tremolos.

RELATED LINKS
Tremolos in playback on page 1005
Changing the number of tremolo strokes on individual notes in tie chains on page 1000

Deleting tremolos
You can remove single-note tremolos and multi-note tremolos from notes separately without
affecting the notes to which they applied.

PROCEDURE

1. In Write mode, select the notes whose tremolo strokes you want to delete.

2. Click the appropriate buttons in the Tremolos section of the Repeat Structures panel for
the types of tremolos selected:

● Remove Single-note tremolo

● Remove Multi-note tremolo

RESULT
The corresponding types of tremolo strokes are deleted.

EXAMPLE

Notes with single-note tremolos
and multi-note tremolo

Notes with multi-note tremolo
deleted but single-note tremolos
remain

Notes with both multi-note
tremolo and single-note tremolos
deleted
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Rhythmic positions of notes with tremolos
You can move notes with single-note tremolos and multi-note tremolos to new rhythmic
positions in the same ways as normal notes. However, if you move multi-note tremolos across
barlines, the tremolo strokes are deleted automatically.

NOTE

You can undo moving tremolos immediately, which restores any multi-note tremolo strokes
deleted in the process.

You can move single-note tremolos to new rhythmic positions and across barlines without
affecting their tremolo strokes. The notes are automatically respelled as tie chains if required by
their new rhythmic positions and time signature, in the same ways as normal notes.

NOTE

If tie chains with single-note tremolos contain notes of different durations, the number of
tremolo strokes on each note in the tie chain is different. You can change the number of tremolo
strokes shown on each note in tie chains individually.

RELATED LINKS
Moving notes rhythmically on page 724
Changing the number of tremolo strokes on individual notes in tie chains on page 1000

Moving tremolo strokes
You can move tremolo strokes upwards/downwards graphically.

NOTE

● You cannot move tremolo strokes to the right/left.

● You cannot move tremolo strokes rhythmically, as they apply to specific notes, but you can
move notes with tremolos to different rhythmic positions. Notes with single-note tremolos
can cross barlines; however, multi-note tremolo strokes are deleted automatically when
their notes cross barlines.

PROCEDURE

1. In Engrave mode, select the tremolo strokes you want to move.

2. Move the tremolo strokes in any of the following ways:

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

● Click and drag them upwards/downwards.

RESULT
The selected tremolo strokes are moved upwards/downwards.
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NOTE

● Moving multi-note tremolo strokes also changes the length of the stems to which they are
attached.

● When you first move tremolo strokes graphically, they may appear to move in the wrong
direction or by a larger increment than you expected. This is because their positions are
reset when you override those positions by moving them.

● The following properties in the Beaming group of the Properties panel are activated
automatically when you move the start/end of multi-note tremolo strokes:

● Start Y offset moves the start of multi-note tremolo strokes vertically by moving the
end of the corresponding stem.

● End Y offset moves the end of multi-note tremolo strokes vertically by moving the
end of the corresponding stem.

Tremolo Y in the Notes and Rests group of the Properties panel is activated automatically
when you move single-note tremolo strokes. It moves single-note tremolo strokes
vertically.

For example, if you move a whole multi-note tremolo stroke upwards, both stem handles
are moved so both properties are activated. You can also use these properties to move
tremolo strokes by changing the values in the value fields. However, you must select the
noteheads rather than the tremolo strokes in order to see the relevant groups in the
Properties panel.

Deactivating the properties resets the selected stem handles, and therefore tremolo
strokes, to their default positions.

Project-wide engraving options for tremolos
You can find options for the project-wide appearance and position of tremolos on the Tremolos
page in Engrave > Engraving Options.

The options on the Tremolos page allow you to change the appearance of tremolo strokes, and
their positions relative to the ends of stems, stem flags, noteheads, and beams.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299
Project-wide engraving options for stems on page 942

Changing the appearance of multi-note half note tremolos project-
wide

There are multiple accepted ways of notating multi-note half note tremolos. You can change how
multi-note half note tremolos are notated project-wide.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Tremolos in the page list.

3. In the Multi-note Tremolos section, choose one of the following options for Appearance
of half note (minim) tremolos:

● All lines join stems

● Outermost line joins stems

Tremolos
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● No lines join stems (default)

4. Click Apply, then Close.

RESULT
The appearance of all multi-note half note tremolos project-wide is changed, according to your
preference.

Tremolos in playback
You can control the playback of unmeasured tremolos by specifying the minimum number of
tremolo strokes that are interpreted as unmeasured tremolos. This considers both the number of
tremolo strokes and the number of beam lines that would be used for the note.

You can do this on the Timing page in Play > Playback Options.

For example, if the option is set to require three tremolo strokes, an eighth note with two
tremolo strokes is played as unmeasured, because the single beam of the eighth note is included
in the calculation.

You can also specify the default length of notes in unmeasured tremolos. You express the
duration of notes as a fraction of the length of a quarter note played at 120 quarters per minute
in the Tremolos section.

The number of tremolo strokes determines the note value of the repeated notes. For example,
one stroke indicates an eighth note, two strokes indicate a 16th note, and so on.

RELATED LINKS
Playback Options dialog on page 405

Changing the duration of tremolos in playback
You can change both the default length of each note in unmeasured tremolos in playback, and
the minimum number of tremolo strokes required to indicate tremolos should be unmeasured in
playback.

For example, to change the value in the value field to set the default length to 0.5 seconds, enter
1 into the value field for Default unmeasured tremolo length in the Tremolos section on the
Timing page in Play > Playback Options.

TIP

If you hover over either of the arrows beside the Default unmeasured tremolo length value
field, a small box appears that displays the current fraction as a decimal.

PROCEDURE

1. Press Ctrl/Cmd-Shift-P to open Playback Options.

2. Click Timing in the page list.

3. Optional: In the Tremolos section, change the value for Minimum number of strokes for
playback of unmeasured tremolos.

4. Change the value for Default unmeasured tremolo length.
For example, to set the default length of unmeasured tremolo notes to 0.5 seconds,
change the value to 1.
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TIP

If you hover over either of the arrows beside the value field, a small box appears that
displays the current fraction as a decimal.

5. Click Apply, then Close.

RESULT
The sounding duration of each note in unmeasured tremolos in playback is changed project-
wide.
Changing the value for Minimum number of strokes for playback of unmeasured tremolos
changes the minimum number of tremolo strokes required for tremolos to be unmeasured in
playback.
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Tuplets indicate where a beat is divided into a different number of subdivisions than is usually
expected according to the current meter. They can be used to fit more notes or fewer notes in a
beat than usually exist in a beat, according to the usual pattern of subdivision.

A 4/4 bar with the standard subdivision of four
quarter notes

A 4/4 bar with a subdivision of six triplet quarter
notes in the space of four regular quarter notes

A 6/8 bar with the standard subdivision of six eighth
notes

A 6/8 bar with a subdivision of four duplet eighth
notes in the space of six regular eighth notes

Because these subdivisions are not standard but tuplet notes use the same rhythmic notation as
normal notes, tuplets must be clearly marked to show that their rhythmic duration is different.

In the examples, the triplet quarter notes are shown under a bracket with the number 3. The
duplet eighth notes do not need a bracket as they are joined by a beam, which has a number 2
above it.

Tuplets in Dorico Pro can be shown with just a tuplet bracket, with a tuplet bracket and a tuplet
number/ratio, or with a tuplet bracket, a tuplet number/ratio, and a note indicating the note
value of the tuplet.

RELATED LINKS
Inputting tuplets on page 169
Tuplet numbers/ratios on page 1016

General placement conventions for tuplets
Tuplet brackets and tuplet numbers/ratios are generally placed on the stem side of notes. When
tuplets are shown with a tuplet beam, a tuplet bracket is not always necessary but can be shown
in addition to a tuplet number/ratio.

According to convention, tuplet brackets and tuplet numbers/ratios are always placed above the
staff for vocal staves, so they do not come between notes and lyrics.

Tuplet brackets should be placed as close to notes as possible without colliding with other
notation, such as slurs or articulation. Slurs are usually placed inside tuplet brackets if the slur is
shorter than the tuplet bracket. If a slur is longer than a tuplet bracket, the slur can be placed
outside the tuplet bracket.

Tuplets
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The horizontal position of tuplet brackets should allow it to be immediately obvious which notes
are included in the bracket. They should not extend so far that notes following the tuplet appear
to be included.

A tuplet clearly showing the three quarter notes
included in the triplet.

With an extended tuplet bracket, the duration of the
triplet is now unclear.

Project-wide engraving options for tuplets
You can find options for the project-wide appearance of tuplets, tuplet brackets, and tuplet
numbers/ratios on the Tuplets page in Engrave > Engraving Options.

The options on the Tuplets page allow you to change the appearance and angles of tuplet
brackets, and the position of tuplet brackets, tuplet numbers/ratios relative to the staff and
noteheads.

There are musical examples for many options to demonstrate how they affect the appearance of
your music.

RELATED LINKS
Engraving Options dialog on page 299

Nested tuplets
Nested tuplets are tuplets within larger tuplets that are often used to create complex rhythms. In
Dorico Pro, there is no limit to the number of levels you can have in nested tuplets.

EXAMPLE

Nested tuplets

Inputting nested tuplets
You can input nested tuplets in new, empty staves and you can select existing tuplets and input
nested tuplets within them.

PROCEDURE

1. In Write mode, start note input.

2. Press ; to open the tuplets popover.

3. Optional: If inputting nested tuplets in an empty staff, enter the ratio for the outer tuplet
into the popover. For example, enter 3:2.

4. Optional: Press Return to close the popover and enter the outer tuplet.

NOTE

You can skip steps 3 and 4 if you are inputting nested tuplets into existing tuplets.

5. Press ; to open the tuplets popover again.
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6. Enter the ratio for the inner tuplet into the popover. For example, enter 5:4.

7. Press Return to close the popover and enter the inner tuplet.

8. Enter or play in the pitches you want.

9. Stop inputting nested tuplets in one of the following ways:

● Press Shift-; once to stop the inner tuplet and continue inputting the outer tuplet.

● Press Shift-; twice to stop both tuplets and return to inputting normal notes.

● Press Esc to stop note input completely.

● Move the caret with the arrow keys to return to inputting normal notes.

RESULT
The pitches you enter or play in are input as nested tuplets, starting from the caret position.
If multiples of the inner tuplet fit exactly inside the outer tuplet, you can continue inputting notes
as the specified nested tuplet until you stop the tuplets manually.
If multiples of the inner tuplet do not fit exactly inside the outer tuplet, the inner tuplet stops
automatically at the end of the last tuplet that fits in the outer tuplet. After that, the outer tuplet
continues until you stop it manually.

NOTE

You can also input nested triplets by clicking Tuplets in the Notes toolbox when the caret is
within an existing tuplet. However, you can only input one nested triplet at a time this way.

Notations on tuplet notes
You can add notations such as accidentals, articulations, and slurs to tuplets in the same ways as
they can be added to normal notes.

Articulations are positioned between noteheads or stems and tuplet brackets, so they are closer
to the notes than tuplet brackets or tuplet numbers/ratios.

RELATED LINKS
Inputting accidentals on page 162
Inputting articulations on page 182
Inputting slurs on page 265

Turning existing notes into tuplets
You can turn any existing notes into tuplets, for example, if you need to fit extra notes into an
existing duration.

PROCEDURE

1. In Write mode, select the notes you want to turn into tuplets.

2. Press ; to open the tuplets popover.
The popover is automatically populated with a suggested ratio based on your selection.

3. Optional: Change the ratio in the popover. For example, enter 3:2 to input triplets.

4. Press Return to close the popover.

Tuplets
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RESULT
The selected notes are turned into tuplets according to the ratio in the popover. For example, if
you select five eighth notes and enter 5:4 into the popover, the selected notes become
quintuplet eighth notes.
If the selected notes fit into a single tuplet of the specified ratio, only a single tuplet is created. If
the selected notes do not fit into a single tuplet, as many tuplets as required are created
automatically.

RELATED LINKS
Tuplets popover on page 169

Turning tuplets into normal notes
You can turn any existing tuplets notes into normal notes, for example, if you want to turn tuplet
eighth notes into standard eighth notes.

PROCEDURE

1. In Write mode, select just the tuplet brackets or tuplet numbers/ratios of the tuplets you
want to turn into normal notes.

NOTE

You must not select any of the noteheads in the tuplets.

2. Optional: If you want to retain all notes in the selected tuplets, press I to activate Insert
mode.

3. Press Backspace or Delete.

RESULT
All notes in the selected tuplets are unscaled and appear as normal notes with the same notated
duration, for example, a tuplet quarter note becomes a standard quarter note.
When Insert mode is activated, all notes in the tuplets are retained and any subsequent existing
notes are pushed to later rhythmic positions to accommodate the extra rhythmic durations
required. When Insert mode is deactivated, the earliest selected tuplets expand and overwrite
subsequent notes and tuplets.

Moving tuplets rhythmically
You can move tuplets to different rhythmic positions after they have been input.

PROCEDURE

1. In Write mode, select the tuplets you want to move.

NOTE

A tuplet number/ratio or bracket must be included in the selection if you want the notes to
stay a tuplet. If a tuplet number/ratio or tuplet bracket is not selected, the notes become
normal notes of their rhythmic value when you move them beyond the position of the
tuplet.

2. Move the selected tuplets in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.
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NOTE

You cannot move tuplets rhythmically using the mouse.

RESULT
The selected tuplets move to the right/left along the staff according to the current rhythmic grid
value.
If a tuplet number/ratio or tuplet bracket is included in the selection, the whole tuplet is moved
along the staff. If it crosses a barline, the tuplet is automatically adjusted to compensate.

NOTE

● If any of your selected notes collide with other notes in the same staff and at the same
rhythmic position that are in the same voice as your selected notes, the existing notes are
deleted and replaced with your selected notes.

You can undo moving notes immediately afterward, which restores any notes deleted in
the process.

● Tuplets are not automatically adjusted at the mid-point of bars, where it is convention to
split tuplets to show the beat division. You must enter two tuplets manually to show the
beat division at the mid-point of bars.

EXAMPLE

Deleting tuplets
You can delete tuplets, including all the tuplet notes, but you can also delete tuplet brackets and
numbers/ratios without deleting the corresponding notes.

PROCEDURE

1. In Write mode, select the tuplets you want to delete.

TIP

To delete an entire tuplet and all the notes within it, select all the noteheads and the
corresponding tuplet bracket or tuplet number/ratio.

2. Press Backspace or Delete.

RESULT
The selected tuplets are deleted.

● Selecting just the notes deletes the notes, but does not delete the tuplet.

● Selecting just the tuplet bracket or tuplet number/ratio deletes the tuplet, and the notes
that were previously within the tuplet are retained with the same notated duration. For
example, deleting the bracket from triplet quarter notes leaves the notes previously in the
triplet as three quarter notes.
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NOTE

This overrides existing notes immediately after the tuplet. However, if Insert mode is activated,
any subsequent existing notes are pushed to later rhythmic positions to accommodate the extra
rhythmic durations required.

RELATED LINKS
Turning tuplets into normal notes on page 1010

Tuplet beams
Tuplet beams join notes in tuplets that can be joined with beams just like non-tuplet beams. You
can make the same changes to tuplet beams that you can make to any other beam.

RELATED LINKS
Beaming on page 537
Tuplets within beams on page 549
Beaming notes together manually on page 537
Unbeaming notes on page 538
Splitting beam groups on page 540
Changing the direction of partial beams on page 538
Changing beam slants on page 542

Tuplet brackets
Tuplet brackets show the duration of tuplets that are not joined by beams, such as triplet quarter
notes, by showing the notes within the tuplet under a bracket.

You can change the precise positions and shapes of tuplet brackets individually in Engrave mode.

Each tuplet bracket has four handles that can be moved graphically.

The two upper handles set the position of the start/end of the tuplet bracket. These handles can
be moved independently of each other to create angled tuplet brackets, even if you have set
tuplet brackets to be Always horizontal on the Tuplets page in Engrave > Engraving Options.

The two lower handles set the length of the tuplet bracket hooks. Moving either of these handles
changes the length of both hooks.

RELATED LINKS
Changing the angles of tuplet brackets on page 1014

Moving tuplet numbers/ratios and brackets graphically
You can move tuplet numbers/ratios and tuplet brackets graphically without changing the
rhythmic positions to which they apply. You can also move the start/end handles of tuplet
brackets independently of each other, meaning you can lengthen/shorten tuplet brackets
graphically.

PROCEDURE

1. In Engrave mode, select any of the following that you want to move:

● Tuplet numbers/ratios
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● Whole tuplet brackets

● Individual handles on tuplet brackets

2. Move the tuplet brackets, tuplet numbers/ratios, or handles in any of the following ways:

● Press Alt-Right Arrow to move handles to the right.

● Press Alt-Left Arrow to move handles to the left.

● Press Alt-Up Arrow to move handles, whole brackets, and tuplet numbers/ratios
upwards.

● Press Alt-Down Arrow to move handles, whole brackets, and tuplet numbers/ratios
downwards.

TIP

If you want to move tuplet brackets, tuplet numbers/ratios, or handles by larger
increments, you can press Ctrl/Cmd as well as the standard key command, for
example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag whole tuplet brackets or tuplet numbers/ratios upwards/downwards.

● Click and drag handles on tuplet brackets in any direction.

RESULT
The selected tuplet brackets or tuplet numbers/ratios are moved to new graphical positions,
without changing the rhythmic positions to which they apply.

TIP

● The following properties in the Tuplets group of the Properties panel are activated
automatically when you move the corresponding part of tuplet brackets:

● Start offset moves the start of tuplet brackets. X moves them horizontally, Y moves
them vertically.

● End offset moves the end of tuplet brackets. X moves them horizontally, Y moves
them vertically.

● Hook length changes the length of tuplet bracket hooks.

For example, if you move a whole tuplet bracket, both handles are moved, so Start offset
and End offset are both activated. You can also use these properties to move tuplet
brackets and tuplet numbers/ratios graphically by changing the values in the value fields.

As you can change values for the properties for the start/end of tuplet brackets
independently, you can also use the properties to change the angles of tuplet brackets.

Deactivating the properties resets tuplet brackets to their default positions.

● You can change the default position of all tuplet brackets project-wide in the Horizontal
Position section of the Tuplets page in Engrave > Engraving Options.

Hiding/Showing tuplet brackets
You can hide/show tuplet brackets independently of tuplet numbers/ratios.

PROCEDURE

1. Select the tuplet brackets you want to hide/show. You can do this in Write mode and
Engrave mode.

2. In the Properties panel, activate Bracket in the Tuplets group.

3. Choose one of the following options:

● Hidden

Tuplets
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● Shown

Changing the angles of tuplet brackets
You can change the angles of individual tuplet brackets by moving the square handles on each
corner of tuplet brackets to new graphical positions independently.

PROCEDURE

1. In Engrave mode, select one of the following handles on the tuplet brackets whose angle
you want to change:

● The start corner handle

● The end corner handle

2. Move the handles in any of the following ways:

● Press Alt-Right Arrow to move them to the right.

● Press Alt-Left Arrow to move them to the left.

● Press Alt-Up Arrow to move them upwards.

● Press Alt-Down Arrow to move them downwards.

TIP

If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

● Click and drag them in any direction.

3. Optional: Repeat steps 1 and 2 for the other corner handle on the tuplet brackets whose
angle you want to change.

RELATED LINKS
Moving tuplet numbers/ratios and brackets graphically on page 1012
Forcing tuplet brackets to be horizontal on page 1016
Tuplet brackets on page 1012

Changing the placement of tuplet brackets relative to the staff
You can change the placement of individual tuplet brackets and tuplet numbers/ratios relative to
the staff.

PROCEDURE

1. Select the tuplet brackets and tuplet numbers/ratios whose staff-relative placement you
want to change. You can do this in Write mode and Engrave mode.

2. In the Properties panel, activate Placement in the Tuplets group.

3. Choose one of the following options:

● Above

● Below
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● Cross-staff above

● Cross-staff below

RESULT
The placement of the selected tuplet brackets is changed.

TIP

● Deactivating Placement returns the selected tuplets to their default placement.

● You can change the placement of all tuplet brackets relative to vocal staves project-wide in
the Placement section of the Tuplets page in Engrave > Engraving Options.

Changing the rhythmic end positions of tuplet brackets
You can change the rhythmic end positions of tuplet brackets relative to individual notes
individually.

PROCEDURE

1. Select the tuplet brackets whose end positions you want to change. You can do this in
Write mode and Engrave mode.

2. In the Properties panel, activate End position in the Tuplets group.

3. Choose one of the following options:

● End at right-hand side of final note

● End immediately before following note

● End at position of final tuplet division

RESULT
The end position for the selected tuplet brackets is changed.

TIP

● Deactivating the property returns the selected tuplets to your default settings.

● You can change the horizontal position of tuplet numbers/ratios on all tuplets project-wide
in the Horizontal Position section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Changing the angles of tuplet brackets on page 1014
Project-wide engraving options for tuplets on page 1008
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Forcing tuplet brackets to be horizontal
You can change the angle of individual tuplet brackets so that they appear horizontal,
independently of your project-wide setting.

PROCEDURE

1. Select the tuplet brackets whose angle you want to change. You can do this in Write mode
and Engrave mode.

2. In the Properties panel, activate Force horizontal in the Tuplets group.

RESULT
The selected tuplet brackets appear horizontal when the property is activated. When the
property is deactivated, the selected tuplet brackets follow your project-wide setting for angled
tuplet brackets.

TIP

You can change whether all tuplet brackets can appear angled or always appear horizontal
project-wide in the Brackets section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for tuplets on page 1008
Changing the angles of tuplet brackets on page 1014

Tuplet numbers/ratios
Tuplet numbers and ratios are very similar: both indicate the number of equal notes included in
the tuplet, such as 3 for triplets, but tuplet ratios also include the number of normal notes into
whose duration the tuplet fits, such as 3:2 for triplets.

Additionally, tuplet ratios can include a note that indicates the duration of notes in the tuplet.

A triplet with a ratio and note value indication

Tuplet numbers/ratios help performers quickly identify the type of tuplet and how they must fit
the number of notes indicated into the prevailing tempo and meter.

In Dorico Pro, you can change the appearance of all tuplet numbers/ratios project-wide on the
Tuplets page in Engrave > Engraving Options, such as changing the font used for them, and for
individual tuplets independently of this setting.

RELATED LINKS
Project-wide engraving options for tuplets on page 1008
Changing the font used for tuplet numbers/ratios on page 1018

Changing the tuplet number/ratio type
You can change which type of tuplet number/ratio is shown for individual tuplets, independently
of your project-wide setting.
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PROCEDURE

1. Select the tuplet brackets of the tuplets whose type of tuplet number/ratio you want to
change. You can do this in Write mode and Engrave mode.

NOTE

The Tuplets group of the Properties panel is only shown if you select tuplet brackets. It is
not shown if you select notes within the tuplet, or notes within the tuplet and the tuplet
bracket.

2. In the Properties panel, activate Number in the Tuplets group.

3. Choose one of the following options:

● None

● Number

● Ratio

● Ratio+note

RESULT
The tuplet number/ratio shown for the selected tuplets is changed.

TIP

● Deactivating Number returns the selected tuplets to the default setting.

● You can change which tuplet number/ratio appears on all tuplets project-wide in the
Number and Ratio section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Tuplet numbers/ratios on page 1016
Project-wide engraving options for tuplets on page 1008

Changing the position of tuplet numbers/ratios
You can change the horizontal positions of tuplet numbers and ratios in individual tuplet
brackets, independently of your project-wide setting.

PROCEDURE

1. Select the tuplet brackets whose tuplet number/ratio positions you want to change. You
can do this in Write mode and Engrave mode.

2. In the Properties panel, activate Center in the Tuplets group.

3. Choose one of the following options:

● Visual
Positions tuplet numbers/ratios at the visual center of the tuplet beam or tuplet
bracket.

● Rhythmic
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Positions tuplet numbers/ratios at the rhythmic center of the tuplet beam or tuplet
bracket, which might be visually off-center.

RESULT
The position of the tuplet numbers/ratios for the selected tuplets is changed.

TIP

● Deactivating the property returns tuplets to your project-wide setting.

● You can change the horizontal position of tuplet numbers/ratios on all tuplets project-wide
in the Number and Ratio section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Tuplet brackets on page 1012
Changing the angles of tuplet brackets on page 1014

Changing the font used for tuplet numbers/ratios
By default, tuplet numbers/ratios are drawn in a bold, italic, Arabic font that is similar in
appearance to fingerings. You can change the font used for all tuplet numbers/ratios project-
wide. This also affects the appearance of note value indications.

PROCEDURE

1. Press Ctrl/Cmd-Shift-E to open Engraving Options.

2. Click Tuplets in the page list.

3. In the Number and Ratio section, choose one of the following options for Tuplet digit
style:

● Bold weight

● Regular weight

● Plain font

4. Click Apply, then Close.

RESULT
The font used for tuplet numbers/ratios project-wide is changed.

● Bold weight and Regular weight are both based on the Tuplet Font style, which must be
SMuFL-compliant.

● Plain font uses the Tuplet Plain Font style, which can be any text font.

TIP

You can edit different aspects of the Tuplet Plain Font style, such as its font size, in the Edit Font
Styles dialog.

RELATED LINKS
Edit Font Styles dialog on page 364
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The term “unpitched percussion” covers all percussion instruments that are not tuned to specific
pitches. This includes instruments such as bass drum, guiro, maracas, cymbals, and shakers.

Dorico Pro provides comprehensive support for unpitched percussion notation, with flexible
options for combining music for multiple instruments into percussion kits that can then be
displayed differently in different layouts. You can also define percussion kits as drum sets, which
changes the default stem directions of notes.

The different percussion kit presentation types in Dorico Pro are layout-specific, meaning you can
present percussion kits in different ways in different layouts. For example, you could present a
percussion kit as a five-line staff in the full score layout but with single-line instruments in the
percussion part layout.

You can also customize and create new playing technique-specific noteheads for unpitched
percussion. This allows you to indicate how notes are played by using different noteheads for
different playing techniques on each instrument in percussion kits.

RELATED LINKS
Percussion kits on page 1020
Percussion kit presentation types on page 1025
Staff labels for percussion kits on page 904
Defining percussion kits as drum sets on page 111
Inputting notes in percussion kits on page 154
Playing techniques for unpitched percussion instruments on page 1027

Percussion kits vs. individual percussion instruments
Percussion kits allow you to show multiple unpitched percussion instruments held by a single
player at the same time in different ways. Multiple percussion instruments not combined into kits
are shown on a single line that only shows the instrument currently being played by default.

One common type of percussion kit is a drum set. A drum set consists of a number of separate
instruments mounted together on a frame, and is typically written on a regular five-line staff.
Each instrument has its own position on the staff, and sometimes its own notehead type.
Similarly, a pair of bongos is a percussion kit by default in Dorico Pro, consisting of the two
bongo drums, typically written on a grid with two lines: the smaller drum shown on the top line,
and the larger drum shown on the bottom line.

Showing individual percussion instruments separately can be appropriate if a player only has one
or two percussion instruments. However, combining percussion instruments into a kit gives you
more flexibility over the presentation of music, which you can vary in each layout independently.
Kits also give you greater control over the labelling of instruments.

If instrument changes are enabled on the Players page in Setup > Layout Options, Dorico Pro
changes from one instrument to the next, just as it does for pitched instruments.

Unpitched percussion
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NOTE

Kit instruments in player cards in the Players panel in Setup mode are colored green, whereas
individual percussion instruments not part of percussion kits are colored the same light blue as
all other instruments.

Percussion kits
A percussion kit is a collection of unpitched percussion instruments that are played by a single
player. Drum sets are a particular type of percussion kit that are often used in pop and rock
music.

In Dorico Pro, you can present percussion kits in different ways, including as a five-line staff and
as a grid. If you want percussion kits to behave as drum sets, you can define them as drum sets.

You can create percussion kits in Setup mode. You can combine existing unpitched percussion
instruments into kits and add empty kits to players, to which you can then add unpitched
percussion instruments. You can also import existing kits you have previously exported and
saved.

You can move percussion instruments between players, without affecting any music already
added to that instrument.

NOTE

If the instrument you want to move is combined into a percussion kit, you must first remove the
instrument from the kit before you can move it to another player.

You can change individual percussion instruments like any other instrument. However, you can
only change unpitched percussion instruments to other unpitched percussion instruments, and
you can only change the percussion instruments in kits within the Edit Percussion Kit dialog.

RELATED LINKS
Percussion kit presentation types on page 1025
Staff labels for percussion kits on page 904
Edit Percussion Kit dialog on page 107
Combining individual percussion instruments into kits on page 105
Defining percussion kits as drum sets on page 111
Adding instruments to percussion kits on page 110
Removing individual instruments from percussion kits on page 114
Moving instruments between players on page 107

Exporting percussion kits
You can export percussion kits as library files. This allows you to use kits again without having to
create them from scratch.

PROCEDURE

1. In the Players panel in Setup mode, expand the card of the player whose percussion kit
you want to export.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Click Export Kit at the bottom of the dialog to open the File Explorer/macOS Finder.

4. In the File Explorer/macOS Finder, specify a name and location for the library file.

5. Click Save.
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RESULT
The kit is exported and saved as a library file.

NOTE

You can later import the library file into other projects to reuse the percussion kit.

Importing percussion kits
You can import library files containing percussion kits, which allows you to use kits again without
having to create them from scratch.

PREREQUISITE
You have added a new solo player in the Players panel in Setup mode.

PROCEDURE

1. In Setup mode, open the instrument picker for your empty solo player in any of the
following ways:

● Select the empty player and press Shift-I.

● Click the plus symbol in the empty player card.

● Right-click the empty player and choose Add Instrument to Player from the
context menu.

2. Click Import Kit in the instrument picker to open the File Explorer/macOS Finder.

3. In the File Explorer/macOS Finder, locate and select the percussion kit library file you want
to import.

4. Click Open.

RESULT
The selected library file is imported as a percussion kit. It is assigned to the player from whose
card you opened the instrument picker.

Project-wide engraving options for unpitched percussion
You can find options for the project-wide appearance and position of percussion legends and
ghost notes on the Percussion page in Engrave > Engraving Options.

The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.

RELATED LINKS
Engraving Options dialog on page 299

Per-flow notation options for unpitched percussion
You can find options for how notes in percussion kits are notated in each flow independently on
the Percussion page in Notation Options.

For example, you can choose to notate all notes in a percussion kit in a single voice rather than in
multiple voices.

You can open Notation Options in any of the following ways:

● Press Ctrl/Cmd-Shift-N in any mode.
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● Choose Write > Notation Options in Write mode or Setup > Notation Options in Setup
mode.

● Click Notation Options in the Flows panel in Setup mode.

You can then click Percussion in the page list.

Changing the playing techniques of notes on percussion kit
staves

For notes on percussion kit staves that use playing technique-specific noteheads to indicate
different playing techniques, you can change their playing techniques after they have been input
by cycling through the available playing technique-specific noteheads.

NOTE

This only applies to changing playing technique-specific noteheads.

PREREQUISITE
The percussion kit instruments whose playing techniques you want to change have at least two
playing technique-specific noteheads defined in the Percussion Instrument Playing
Techniques dialog.

PROCEDURE

1. In Write mode, select the notes whose playing technique-specific notehead you want to
change.

NOTE

The current playing technique is shown above the rhythmic grid if you select a single note.
It is not shown if you select multiple notes.

2. Cycle through the available playing techniques for the selected instruments in any of the
following ways:

● Press Shift-Alt-Up Arrow to cycle upwards.

● Press Shift-Alt-Down Arrow to cycle downwards.

RESULT
The playing techniques of the selected notes are changed. Their notehead design and/or position
might be changed.

RELATED LINKS
Percussion Instrument Playing Techniques dialog on page 1027
Inputting notes in percussion kits on page 154
Defining how combinations of articulations and single-note tremolos sound in playback on page
465
Playing techniques on page 790
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Showing notes in percussion instruments as ghost notes
You can show notes in percussion instruments as ghost notes. Ghost notes are shown in
parentheses.

PROCEDURE

1. Select the unpitched percussion notes that you want to show as ghost notes. You can do
this in Write mode and Engrave mode.

2. In the Properties panel, activate Ghost note in the Notes and Rests group.

RESULT
The noteheads of the selected notes are shown in parentheses.

Moving notes to different instruments in percussion kits
You can move notes to different instruments in the same percussion kit after they have been
input, except in layouts using the single-line instruments kit presentation type.

In layouts using the single-line instruments kit presentation type, you can instead cross notes to
other staves to create cross-staff beams.

PROCEDURE

1. In Write mode, select the notes you want to move to a different instrument in the
percussion kit.

2. Move the notes to another instrument in any of the following ways:

● Press Alt-Up Arrow to move them to the instrument above.

● Press Alt-Down Arrow to move them to the instrument below.

RESULT
The notes are moved to another instrument in the kit.

AFTER COMPLETING THIS TASK
You can change the position of each instrument in the kit.

RELATED LINKS
Edit Percussion Kit dialog on page 107
Changing the positions of instruments within percussion kits on page 113
Percussion kit presentation types on page 1025
Changing the presentation type of percussion kits on page 1026
Creating cross-staff beams on page 544

Notations on notes in percussion kits
You can add notations to notes and use different rhythms in percussion kits in the same ways as
for normal notes; however, they can behave differently.

Articulations

You can add articulations to percussion instruments in all kit presentation types in the same ways
as for other instruments.

However, in grid and five-line staff presentations, any articulations you add apply to all
instruments in the same voice that have notes at that rhythmic position. For example, if both a
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snare drum and tom-tom note are at the same rhythmic position, and you add an accent, the
accent is added to both instruments because they are both shown in the same down-stem voice
by default.

You can see the accent applied to each note if you switch to the single-line instruments
presentation type.

Tuplets

When working in the grid and five-line staff kit presentation types, tuplets are added to all
instruments in the same voice.

You can switch to the single-line instruments presentation type to input cross-rhythms on each
instrument separately. When you switch back to the grid or five-line staff kit presentation types,
Dorico Pro attempts to resolve the rhythmic conflicts.

● Conflicting tuplets: One tuplet is moved into an extra voice for the duration of the conflict.

● Tuplet notes in one instrument and non-tuplet notes in another instrument starting at the
same rhythmic position: The non-tuplet note is displayed as if it were part of the tuplet.
This is because the note onset is at the same position as the start of the tuplet, so it
sounds the same as the original notation.

● Tuplet notes in one instrument and non-tuplet notes in another instrument that do not
start at the same rhythmic position, or other non-tuplet notes that start part-way through
the tuplet: Non-tuplet notes are moved into an extra voice for the duration of the conflict.

NOTE

Deleting a tuplet from grid and five-line staff kit presentation types deletes the tuplet from
all instruments whose notes contribute to the same shared voice.

Playing techniques

You can input playing techniques, such as + for closed and o for open hi-hat, during step input
and add them later to existing notes in the same ways as for other instruments. You can use the
playing techniques popover or click any of the playing techniques in the Playing Techniques
panel in Write mode.

Playing techniques are only added to the instrument to which the note you select belongs, even
if there are other instruments in the same voice.

Percussion stickings

Dorico Pro does not yet have a dedicated feature for percussion stickings. However, you can use
lyrics to represent percussion stickings in all kit presentation types:

● Grid/Five-line staff presentation types: Select a note in the instrument in which you want to
show stickings.

● Single-line instruments presentation type: Input lyrics directly into instruments in which
you want to show stickings.

RELATED LINKS
Inputting articulations on page 182
Inputting tuplets on page 169
Changing the pitch of individual notes on page 173
Input methods for playing techniques and pedal lines on page 238
Inputting lyrics on page 246
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Dynamics in percussion kits
Unlike other items, dynamics are not shared between the grid/five-line staff presentation types
and the single-line instruments presentation type. Any dynamics added to instruments in the
single-line instruments presentation type do not appear when you switch to grid/five-line
presentations.

This is due to the complexity of combining a large number of different dynamics at the same
rhythmic position, as allowed in the single-line instruments presentation, into the single position
required for both the grid and five-line staff presentations. Therefore, you can add dynamics in
the grid and five-line staff presentation types independently of the single-line instruments
presentation type.

RELATED LINKS
Input methods for dynamics on page 208

Percussion kit presentation types
You can show percussion kits in three different presentation types, which can be different in each
layout in your project.

NOTE

Dynamics are not shared between the grid/five-line staff presentation types and the single-line
instruments presentation type. Any dynamics added to instruments in the single-line
instruments presentation type do not appear when you switch to grid/five-line presentations.

You can edit the appearance/structure of each presentation type independently in the Edit
Percussion Kit dialog. For example, changing the order of instruments in the five-line staff
presentation does not affect the order of instruments in the grid presentation of the same
percussion kit.

5-line staff
Kit instruments are shown on a five-line staff. You can determine which instruments
are shown on each line and in each space of the staff. A single staff label containing
the name of the kit is shown.
The numbers down the left-hand side of the editing area in the Edit Percussion Kit
dialog correspond to staff positions. For example, position 0 is the middle line of the
five-line staff, position 1 is the space immediately above the middle staff line,
position -2 is the line below the middle staff line, and so on.
Bold black lines show the five staff lines, while gray lines above and below the staff
show nominal staff line positions. Each instrument is shown on its staff position.

Grid
Kit instruments are shown on a grid, with each instrument on its own line. You can
customize the size of the gaps between each line. Staff labels are shown for each
instrument in a smaller font than normal staff labels.
The numbers down the right-hand side of the editing area in the Edit Percussion Kit
dialog correspond to the number of staff spaces between each instrument line. By
default, all instruments in a grid are two spaces apart.
The order in which the instruments are listed matches the order in which they
appear in the score.
Each instrument in a grid shows its own staff label by default, aligned vertically with
its own line, but you can group adjacent instruments together and show a single
label for each group.
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Single-line instruments
Kit instruments are shown as individual instruments with their own lines. Normal-
sized staff labels are shown for each instrument.
The editing area in the Edit Percussion Kit dialog lists all of the instruments in the
order in which they appear in the score.

5-line staff presentation
Grid presentation

Single-line instruments
presentation

Multiple instruments held by the same player are vertically spaced according to the ideal gaps
defined on the Vertical Spacing page in Setup > Layout Options.

RELATED LINKS
Edit Percussion Kit dialog on page 107
Changing the presentation type of percussion kits on page 1026
Staff labels for percussion kits on page 904
Overriding the appearance of playing technique-specific noteheads on page 1031
Override Percussion Noteheads dialog on page 1029

Changing the presentation type of percussion kits
You can change the presentation type of percussion kits in each layout independently of other
layouts and independently of each other. For example, you can use a five-line staff in the full
score layout but a grid in the percussion part layout, and have two percussion kits with different
presentation types in the same full score layout.

PROCEDURE

1. Press Ctrl/Cmd-Shift-L to open Layout Options.

2. In the Layouts list, select the layouts in which you want to change the percussion kit
presentation type.
By default, the layout currently open in the music area is selected when you open the
dialog. You can select other layouts by using the selection options in the action bar, Shift-
clicking adjacent layouts, and Ctrl/Cmd-clicking individual layouts.

3. Click Players in the page list.

4. In the Percussion section, choose one of the following options for each percussion kit in
your project:

● 5-line Staff

● Grid

● Single-line Instruments

5. Click Apply, then Close.

RESULT
The presentation type is changed for the selected percussion kits in the selected layouts.
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RELATED LINKS
Percussion kit presentation types on page 1025

Playing techniques for unpitched percussion instruments
As well as using normal playing techniques on notes in percussion kits, you can use the design
and position of noteheads to indicate different playing techniques for unpitched percussion
instruments and percussion kits.

You can indicate playing techniques for unpitched percussion instruments in any of the following
ways:

● Use playing technique-specific noteheads

● Position notes in spaces directly above/below the line on which notes are normally written

● Add articulations or single-note tremolos

● Add playing techniques in the same ways as for pitched instruments

For example, you can add open and closed techniques for hi-hats using the playing techniques
popover, or by clicking the playing techniques you want in the Playing Techniques panel.

You can edit the set of playing technique-specific noteheads defined for each percussion
instrument in the Percussion Instrument Playing Techniques dialog.

RELATED LINKS
Edit Percussion Kit dialog on page 107
Defining how combinations of articulations and single-note tremolos sound in playback on page
465
Exporting percussion kits on page 1020
Importing percussion kits on page 1021
Input methods for playing techniques and pedal lines on page 238

Percussion Instrument Playing Techniques dialog
The Percussion Instrument Playing Techniques dialog allows you to edit the set of playing
technique-specific noteheads defined for each percussion instrument.

You can open the Percussion Instrument Playing Techniques dialog in Setup mode in the
following ways:

● For an individual percussion instrument: In the Players panel, expand the card of the
player holding the instrument, click the arrow in the instrument label, and choose Edit
Percussion Playing Techniques from the menu.

● For percussion instruments that are part of percussion kits: In the Players panel, click the
arrow in the kit instrument label, and choose Edit Percussion Kit to open the Edit
Percussion Kit dialog, select the instrument whose playing techniques you want to edit in
the main editing area, and click Edit Percussion Playing Techniques.

Unpitched percussion
Playing techniques for unpitched percussion instruments 

1027
Dorico 2.2.20



Percussion Instrument Playing Techniques dialog

1 List of playing technique-specific noteheads
Contains the main playing technique-specific noteheads currently defined for the selected
percussion instrument, showing the notehead set and the staff position corresponding to
the playing technique as applicable.
You can add new playing technique-specific noteheads for unpitched percussion
instruments. Normally, percussion instruments define at least the Natural playing
technique, which is usually shown using the default notehead set.

2 Playback of Articulations and Tremolos
Allows you to define how combinations of articulations and tremolo strokes affect or
override the playback of playing techniques.
For example, you can define an entirely different playing technique for a playing
technique-specific notehead for when an accent is added to it.

3 Overrides of articulations and tremolos list
Displays any overrides of articulations and tremolos you define.

EXAMPLE

Three different snare drum playing technique-specific noteheads followed by two clash cymbal playing
technique-specific noteheads

All of these settings are saved in the percussion instrument within your project, and you can
export them from one project and import them into others.

NOTE

Overrides for articulations and tremolos are not currently reflected in playback, but this is
planned for future versions.

Unpitched percussion
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RELATED LINKS
Creating new playing technique-specific noteheads for unpitched percussion instruments on
page 1030
Overriding the appearance of playing technique-specific noteheads on page 1031
Defining how combinations of articulations and single-note tremolos sound in playback on page
465
Exporting percussion kits on page 1020
Importing percussion kits on page 1021

Override Percussion Noteheads dialog
The Override Percussion Noteheads dialog lists the playing technique-specific noteheads
defined for the selected instrument in the Percussion Instrument Playing Techniques dialog,
shows the notehead type mapped for each technique, and allows you to override those
noteheads for five-line staff kit presentations only.

For example, the same notehead can indicate different playing techniques for different
instruments. When those instruments are presented on the same five-line staff, this can cause
confusion, so you can use the Override Percussion Noteheads dialog to disambiguate the
notes for one instrument from another in five-line staff kit presentations only.

● You can open the Override Percussion Noteheads dialog by selecting an instrument in
the Edit Percussion Kit dialog and clicking Edit Noteheads.

Override Percussion Noteheads dialog for a snare drum

The Override Percussion Noteheads dialog comprises the following:

1 Instrument name
Displays the name of the percussion instrument whose noteheads are listed in the dialog.

2 Playing techniques table
Contains the noteheads for the selected percussion instrument, arranged into the
following columns:

● Playing Technique
Displays the playing technique associated with the notehead in the corresponding
row of the table.

● Default Notehead
Displays the notehead used by default for the playing technique in the
corresponding row of the table.
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● Notehead Override
Displays the notehead override used in five-line staff presentations for the playing
technique in the corresponding row of the table. You can change the notehead
override by clicking it and selecting another notehead from the menu.

RELATED LINKS
Overriding the appearance of playing technique-specific noteheads on page 1031
Percussion kit presentation types on page 1025

Creating new playing technique-specific noteheads for unpitched
percussion instruments

You can define new playing technique-specific noteheads for unpitched percussion instruments
individually, which are saved for that type of percussion instrument in your project. You can also
export playing technique-specific noteheads from your project and import them into other
projects.

PROCEDURE

1. In Setup mode, open the Percussion Instrument Playing Techniques dialog in one of the
following ways:

● For an individual percussion instrument: In the Players panel, expand the card of
the player holding the instrument, click the arrow in the instrument label, and
choose Edit Percussion Playing Techniques from the menu.

● For percussion instruments that are part of percussion kits: In the Players panel,
click the arrow in the kit instrument label, and choose Edit Percussion Kit to open
the Edit Percussion Kit dialog, select the instrument whose playing techniques you
want to edit in the main editing area, and click Edit Percussion Playing Techniques.

2. Click Add Playing Technique.

3. Select the playing technique you want to create in the dialog that opens.

4. Click OK to add the selected playing technique to the list of playing technique-specific
noteheads.

5. Select the notehead you want for the playing technique from the Notehead set menu.

NOTE

Leave Notehead set as (Unset) to use the default notehead set as defined on the Notes
page in Engrave > Engraving Options.

6. Choose one of the following options for Staff position:

● Below

● Line

● Above

RESULT
A new playing technique-specific notehead is added to the selected unpitched percussion
instrument.

RELATED LINKS
Input methods for playing techniques and pedal lines on page 238
Defining how combinations of articulations and single-note tremolos sound in playback on page
465
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Overriding the appearance of playing technique-specific noteheads
It might be necessary to override the appearance of playing technique-specific noteheads in
order to disambiguate the notes for one instrument from another if they share a staff position in
five-line staff kit presentations.

PROCEDURE

1. In the Players panel in Setup mode, expand the card of the player holding the kit whose
playing technique-specific noteheads you want to override.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. Select the instrument whose noteheads you want to override in the main editing area of
the dialog.

4. Click Edit Noteheads to open the Override Percussion Noteheads dialog.

5. Click in the Notehead Override column for the appropriate playing technique and select a
new notehead type from the menu to override its notehead.

6. Click OK to save your changes and close the dialog.

RESULT
The playing technique-specific notehead is overridden for the selected instrument in five-line
staff kit presentations.

NOTE

This does not affect the appearance of playing technique-specific noteheads in grid and single-
line instrument kit presentation types.

RELATED LINKS
Override Percussion Noteheads dialog on page 1029
Defining how combinations of articulations and single-note tremolos sound in playback on page
465

Percussion legends
Percussion legends list the percussion instruments in use when using the five-line presentation
type. Percussion legends can include all instruments that are represented on the staff, or only
show sounding instruments in a set range to remind players which instruments to play at certain
points.

You can change the default position of percussion legends in the Percussion Legends section of
the Percussion page in Engrave > Engraving Options.

You can change the placement and appearance of percussion legends individually using
properties in the Percussion Legends group of the Properties panel.

You can change various aspects of the paragraph style for percussion legends, such as the font
size and style, in the Paragraph Styles dialog.

Percussion legends appear as signposts if there are no instruments sounding at their position, or
in layouts using the grid presentation type. Percussion legends do not appear at all in layouts
using the single-line instrument presentation type.
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TIP

You can hide/show percussion legend signposts by choosing View > Signposts > Percussion
Legends. Percussion legend signposts are shown when a tick is shown beside Percussion
Legends in the menu, and hidden when no tick is shown.

RELATED LINKS
Paragraph Styles dialog on page 366
Project-wide engraving options for unpitched percussion on page 1021
Per-flow notation options for unpitched percussion on page 1021
Staff labels for percussion kits on page 904

Adding percussion legends to five-line staff kit presentations
You can add percussion legends at specific rhythmic positions to indicate the instruments in the
kit. Percussion legends can show all instruments in the kit or only instruments sounding within
the specified range.

PROCEDURE

1. In Write mode, select one of the following:

● An item on the staff at the rhythmic position where you want to add a percussion
legend for all instruments.

● The range of notes/items for which you want to show a percussion legend for
sounding instruments.

2. Add a percussion legend in one of the following ways:

● Choose Edit > Percussion > Legend for All Instruments.

● Choose Edit > Percussion > Legend for Sounding Instruments.

TIP

You can also choose these options from the context menu.

RESULT
A percussion legend is added above the staff. It lists instruments, either all instruments or just
instruments with notes within the selected range, in the order in which they appear in the five-
line staff, from highest down to lowest.

Changing the sounding instrument percussion legend range
You can change the rhythmic range of sounding instrument percussion legends to include more/
fewer instruments in the legend, as they only show the instruments playing at the rhythmic
positions included in the range.

PROCEDURE

1. In Write mode, select the sounding instrument percussion legend whose range you want
to change.

2. Change the range in any of the following ways, according to the current rhythmic grid
value:

● To move the whole range to the right, press Alt-Right Arrow.

● To move the whole range to the left, press Alt-Left Arrow.

● To lengthen the range, press Shift-Alt-Right Arrow.

● To shorten the range, press Shift-Alt-Left Arrow.
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NOTE

Key commands lengthen/shorten items by moving their end only.

● Click and drag the circular handle at the start/end to the right/left.

RESULT
The rhythmic range covered by the selected sounding instrument percussion legend is changed
according to the current rhythmic grid value.
The instruments included in the percussion legend are automatically updated to reflect the
instruments playing within the range.

Changing the percussion legend type
You can change the type of percussion legends so they show all instruments or only sounding
instruments in five-line staff presentations.

PROCEDURE

1. Select the percussion legends whose type you want to change. You can do this in Write
mode and Engrave mode.

2. In the Properties panel, activate Legend type in the Percussion Legends group.

NOTE

The property is already activated for sounding instrument percussion legends.

3. Choose one of the following options:

● Legend

● Sounding Instruments

RESULT
The legend type of the selected legends is changed.

Showing short instrument names in percussion legends
Percussion legends use full instrument names by default, but you can choose to use short names
to save space.

PROCEDURE

1. Select the percussion legends whose instrument name lengths you want to change. You
can do this in Write mode and Engrave mode.

2. In the Properties panel, activate Use short names in the Percussion Legends group.

RESULT
Short instrument names are shown in the selected percussion legends.
Deactivating Use short names returns the selected percussion legends to showing full
instrument names.

RELATED LINKS
Staff labels for percussion kits on page 904
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Changing the text shown in percussion legends
By default, percussion legends show the instrument names of percussion instruments in five-line
staff presentations, stacked vertically. You can change the text shown in percussion legends to
show custom text.

PROCEDURE

1. In Engrave mode, select the percussion legends whose text you want to change.

2. In the Properties panel, activate Custom text in the Percussion Legends group.

3. Enter the text you want into the value field.

4. Press Return.

RESULT
The text shown in the selected percussion legends is changed.

Changing the placement of percussion legends relative to the staff
By default, percussion legends are shown above the staff but you can change their placement so
they are shown below the staff.

PROCEDURE

1. Select the percussion legends whose staff-relative placement you want to change. You can
do this in Write mode and Engrave mode.

2. In the Properties panel, activate Placement in the Percussion Legends group.

3. Choose one of the following options:

● Above

● Below

RESULT
The selected percussion legends appear above/below the staff.

TIP

● Deactivating Placement returns the selected percussion legends to their default staff-
relative placement.

● You can change the default distance between all percussion legends and other items
project-wide in the Percussion Legends section of the Percussion page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide engraving options for unpitched percussion on page 1021
Per-flow notation options for unpitched percussion on page 1021

Voices in percussion kits
Dorico Pro automatically combines music into a smaller number of voices when multiple
percussion instruments are presented in a five-line staff or as a grid, even if they contain

Unpitched percussion
Voices in percussion kits 

1034
Dorico 2.2.20



different rhythms. By default, music is combined into one up-stem voice and one down-stem
voice.

Alternatively, you can choose to notate all notes in a percussion kit in a single voice when the kit
is defined as a drum set on the Percussion page in Write > Notation Options. This convention is
used less frequently for orchestral percussion.

You can also override this option for individual percussion kits, and for individual notes in
percussion kits.

Notes in the same voice cannot be notated using different durations and are notated using ties
by default instead. You can eliminate the use of ties by choosing to truncate longer notes so that
only their onsets appear on the Percussion page in Notation Options.

If one of the instruments in a percussion kit has a tuplet rhythm, other instruments can share the
voice if their notation is compatible, such as if the tuplet structure is the same, or if they have a
single note that coincides with the start of the tuplet. In this case, the single non-tuplet note is
notated as the same duration of the first note of the tuplet.

If the music of the different instruments in the same voice is incompatible, Dorico Pro
dynamically creates another voice and notates the remaining music in that voice until the music
is compatible again.

RELATED LINKS
Notations on notes in percussion kits on page 1023
Notation Options dialog on page 139
Defining percussion kits as drum sets on page 111
Adding slash voices to percussion kits on page 1045

Changing the voice of individual notes in percussion kits
You can override the default voice for individual notes in percussion kits, including drum sets.

PROCEDURE

1. Select the notes whose voice you want to override. You can do this in Write mode and
Engrave mode.

2. Choose Edit > Percussion > Change Voice > [Voice].
For example, to change notes to the second down-stem voice, choose Edit > Percussion >
Change Voice > Down-stem Voice 2. You can also choose this option from the context
menu.

RESULT
The voice of the selected notes is changed, independently of the default voice for their
instrument and independently of your setting for voices in drum sets.

TIP

You can reset the voice of individual notes by selecting them and choosing Edit > Percussion >
Change Voice > Reset Note Destination Voice. You can also choose this option from the
context menu.
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Specifying the stem direction/voice of instruments in percussion kits
You can specify the stem direction for each instrument in individual percussion kits. You can also
set which voice they are in, allowing you to control which instruments share voices in percussion
kits.

PROCEDURE

1. In the Players panel in Setup mode, expand the card of the player holding the kit whose
instrument stem directions and voices you want to specify.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. In the dialog, select an instrument whose stem direction and voice you want to specify.

4. Choose one of the following stem directions for Stem direction and voice:

● Up-stem

● Down-stem

5. Specify a voice by changing the value for Stem direction and voice.

NOTE

You do not have to change the voice number if you are switching between up- and down-
stem voices as the number corresponds to the voice number for each stem direction.

6. Click Apply, then Close.

RESULT
The default stem direction and voice of the selected instrument is changed.

Unpitched percussion in Play mode
Unpitched percussion instruments are handled differently in Play mode than pitched
instruments. Instead of showing the usual piano roll view, the onset of each note on each
percussion instrument is shown in the drum editor.

You can expand each instrument in a kit at the left end of the track header in order to assign that
particular instrument to another playback endpoint. For example, you can assign instruments to
another channel on the same VST instrument or MIDI output device, or to a different device.

NOTE

The endpoint must have an appropriate selected percussion map.

Notes can be moved in Play mode by dragging them to the rhythmic position you want. However,
like other instruments, you cannot move notes between percussion instruments, even if they are
in the same percussion kit.

NOTE

You cannot change the duration of unpitched percussion notes within Play mode. This is planned
for future versions.

RELATED LINKS
Percussion maps on page 460
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Drum editor on page 409
Inputting notes in the event display on page 409
Moving notes in the event display on page 410

Unpitched percussion imported from MIDI files
When importing MIDI files, Dorico Pro optionally interprets music for tracks set to use channel 10
as drum sets if Interpret channel 10 as General MIDI percussion is activated in the MIDI
Import Options dialog.

NOTE

The MIDI Import Options dialog opens automatically when you open MIDI files in Dorico Pro.

This is the only condition under which Dorico Pro interprets any music in MIDI files as percussion.

Unpitched percussion imported from MusicXML files
Unpitched percussion music can be expressed in a number of ways in MusicXML. Scoring
applications take different approaches to what data is exported and how it is encoded. Therefore,
the results of importing MusicXML into Dorico Pro vary considerably.

Dorico Pro identifies each instrument in kits explicitly and then combines them dynamically onto
five-line staves. Other scoring applications and MusicXML have a different approach to how
unpitched percussion music is represented. For example, a drum set may be effectively notated
as pitched notes on a five-line staff and annotated with additional information to help identify
which instrument corresponds to each staff position.

Because of these different approaches, mapping information between the MusicXML
representation and the Dorico Pro representation can be challenging, so Dorico Pro employs
heuristics to improve the quality of results.

Typically, drum set instruments in MusicXML files exported from both Sibelius and Finale are
imported quite cleanly into Dorico Pro.

Results are particularly good, and more likely to be imported correctly, if the voicing of the drum
set is consistent, such as consistently notating the snare drum in a down-stem voice. If the
voicing changes from bar to bar, it is possible that some notes are either identified correctly or
not imported at all.

Other kinds of percussion that are notated on five-line staves produce more variable results. In
most cases, Finale includes information about which percussion instrument maps onto each staff
position, but Sibelius does not. As a result, you might find that Dorico Pro chooses different
instruments than you expected, but you can change instruments using the Edit Percussion Kit
dialog.

RELATED LINKS
Edit Percussion Kit dialog on page 107
Changing instruments in percussion kits on page 110
Adding instruments to percussion kits on page 110

Universal Indian Drum Notation
Dorico Pro supports the Universal Indian Drum Notation system developed by Keda Music Ltd.

Universal Indian Drum Notation has been designed primarily for tabla, but can also be applied to
other Indian drums with two heads, such as nagara, dhol, dholak, mridangam, and pakhawaj.
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An Indian drum clef is automatically added to the staff when you add tabla instruments to
players.

You can input Indian drum clefs by clicking Indian drum clef in the Uncommon Clefs section of
the Clefs panel.

RELATED LINKS
Adding instruments to players on page 104
Input methods for clefs and octave lines on page 219
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For many instruments, such as flute or trombone, each staff usually contains a single musical line
in a single voice that is read from left to right along the staff. When multiple, independent lines
must be shown in a single staff, each line can be a separate voice.

The most common use for showing multiple voices in a single staff is in vocal music, when the
soprano and alto lines share a single staff and the tenor and bass lines share another staff.
Showing each vocal line in its own voice helps to separate the lines, making the music easier to
read and making the shape of each melodic line clear.

In Dorico Pro, you can create as many voices as you like on each staff. Each voice has its own
color, which you can see if you show voice colors. This can help you to keep track of which notes
are in which voices if there are multiple overlapping musical lines in your project.

Voices in Dorico Pro are divided into up-stem voices and down-stem voices. Stems of notes in up-
stem voices point upwards, while stems of notes in down-stem voices point downwards.
However, in bars where only one voice contains notes, stem directions are automatically changed
to the directions they would have if there were only one voice on the staff. By default, the first
voice on the staff is up-stem.

Following most notation conventions, rests are shown in bars for all voices that have notes in the
bar. If two or more voices have a rest of the same rhythmic duration at the same rhythmic
position, that rest is consolidated: instead of showing two identical rests, only one is shown.

RELATED LINKS
Inputting notes into multiple voices on page 159
Showing voice colors on page 1041
Per-flow notation options for voices on page 1040
Per-flow notation options for rests on page 862
Adding notes above/below existing notes on page 171
Stem direction on page 943
Implicit rests in multiple-voice contexts on page 861
Moving rests vertically on page 866

Note positions in multiple-voice contexts
Notes are usually placed directly above each other and at the same horizontal position, so that it
is immediately clear which notes are played together. However, the horizontal alignment of
notes can be different in multiple-voice contexts.

When there are three or more voices in a single staff, some notes must be positioned slightly to
one side in a different voice column to ensure the division of notes across the voices is clear.

Interlocking notes in different voices can be positioned in two ways:

1. Notehead to notehead, which allows noteheads to overlap partially. This voice order often
takes up less horizontal space than positioning notes stem to stem, as notes can overlap.

Voices
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2. Stem to stem, which does not allow noteheads to overlap. This voice order keeps notes in
different voices separate.

You can choose how interlocking notes in different voices are positioned project-wide on the
Voices page in Write > Notation Options.

Dorico Pro positions notes by default with the noteheads partially overlapping, in order to
minimize the horizontal space they occupy and to maintain the clarity of the rhythm.

The order and position of notes in different voices is also automatically adjusted so that each
rhythmic position uses as little horizontal space as possible, while remaining clear and legible.
The voice column for some voices automatically changes as more voices are added, as Dorico Pro
prefers showing voices with the widest pitch range between them on the left of the rhythmic
position and voices with narrower pitch ranges to the right, as this produces the most balanced
result, especially when there are multiple accidentals.

One voice Two voices vertically
aligned

Three voices all still
vertically aligned

Four voices with
two voice columns

Five voices with two
voice columns

RELATED LINKS
Slashes in multiple-voice contexts on page 851
Stem direction on page 943
Implicit rests in multiple-voice contexts on page 861

Per-flow notation options for voices
You can find options controlling how notes in multiple voices are positioned in each flow
independently on the Voices page in Notation Options.

The options on this page allow you to change the position and order of notes in multiple-voice
contexts, and choose when noteheads in different voices can overlap.

Musical examples demonstrate how each option affects the appearance of your music.

You can open Notation Options in any of the following ways:

● Press Ctrl/Cmd-Shift-N in any mode.

● Choose Write > Notation Options in Write mode or Setup > Notation Options in Setup
mode.

● Click Notation Options in the Flows panel in Setup mode.
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You can then click Voices in the page list.

Showing voice colors
You can show notes in different colors according to their voice, for example, to check which notes
are in which voice.

PROCEDURE

● Choose View > Note and Rest Colors > Voice Colors.

RESULT
Voice colors are shown when a tick appears beside Voice Colors in the menu, and hidden when
no tick appears.
When voice colors are shown, noteheads appear with colors according to their voice. Colors are
randomly assigned, meaning colors do not refer to specific voices.

EXAMPLE

Voice colors shown

AFTER COMPLETING THIS TASK
If showing voice colors reveals some notes are not in the voice you want, you can change their
voice.

RELATED LINKS
Changing the voice of existing notes on page 287
Swapping the contents of voices on page 288
Stem direction on page 943

Unused voices
An unused voice is one that contains no notes anywhere in the project. Any unused voices are
automatically deleted when you close a project, but you cannot manually delete voices once they
have been created. You can create as many voices as you want in each staff.

NOTE

Deleting all notes in a voice does not delete the voice immediately.

If you later want to input notes in a voice that was automatically deleted when you last closed the
project, you can create a new voice at any rhythmic position.

RELATED LINKS
Inputting notes into multiple voices on page 159

Voices
Showing voice colors 
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Swapping the order of voices
Dorico Pro automatically positions notes with the noteheads partially overlapping, in order to
minimize the horizontal space they occupy and maintain the clarity of the rhythm. You can
manually swap the order in which opposing voices are positioned horizontally.

PROCEDURE

1. Select the notes whose order you want to change. You can do this in Write mode and
Engrave mode.

2. Choose Edit > Voices > Swap Voice Order. You can also choose this option from the
context menu.

RESULT
The voice order of the selected notes is changed.

NOTE

If you want to revert the selected notes to their default voice order for the current flow, we
recommend that you deactivate Voice column index in the Notes and Rests group of the
Properties panel, which is available in Engrave mode and is activated automatically when you
swap the order of voices. If you simply swap the contents of these notes again, their positions
might not appear as expected.

EXAMPLE

Interlocking notes in opposing voices positioned
notehead to notehead.

Interlocking notes in opposing voices positioned
stem to stem.

RELATED LINKS
Per-flow notation options for voices on page 1040
Stem direction on page 943
Implicit rests in multiple-voice contexts on page 861

Voice column index
The voice column index is used to determine the positions of notes when multiple columns are
needed, for example, when notes are in multiple voices and cannot be placed directly above each
other vertically, and instead must partially overlap.

The Voice column index property in the Notes and Rests group of the Properties panel is
automatically activated when you swap the order of voices manually.

NOTE

This property is available in Engrave mode only.

You can activate this property to change the index number, and therefore the horizontal order,
of individually selected notes. Deactivating the property returns the selected notes to their
default position.

Voices
Swapping the order of voices 
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TIP

● You can change the order of notes in multiple voices project-wide on the Voices page in
Write > Notation Options.

● You can also change the minimum gaps between notes in different voices in the Voices
section of the Notes page in Engrave > Engraving Options.

You can move notes graphically in Engrave mode. You can move notes individually and
independently of all other items at that rhythmic position, or move everything at the same
rhythmic position.

RELATED LINKS
Per-flow notation options for voices on page 1040
Notation Options dialog on page 139
Engraving Options dialog on page 299

Notes crossed to staves with existing notes in other voices
When you create cross-staff beams by crossing notes to staves that already contain notes, the
stem direction of the existing notes may change. This is due to how multiple voices at the same
rhythmic position are handled in Dorico Pro.

For example, if a piano part contains notes in up-stem voices on both staves, the stem direction
of notes in both voices can change if notes from the upper staff are crossed to the lower staff. In
this situation, the notes from the two staves are not combined, but are instead treated as two up-
stem voices in a multiple-voice context.

Two piano staves, each with notes in a single up-
stem voice.

When the notes in the upper staff are crossed to the
lower staff, the stem direction of the notes already in
the lower staff changes so they point upwards.

You can change the stem direction of the notes originally in the lower staff in any of the following
ways:

● Select the notes originally in the lower staff and change their voice to another voice, such
as a down-stem voice.

● Select the notes originally in the lower staff and change their stem direction.

Alternatively, you can move the notes in the upper staff permanently to the lower staff.

RELATED LINKS
Moving notes to other staves on page 286
Changing the voice of existing notes on page 287
Creating cross-staff beams on page 544
Changing the stem direction of notes on page 946
Stem direction on page 943
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Slash voices
Slash voices allow you to notate specific rhythms for rhythm slashes. They behave similarly to
normal voices as you must input notes and rhythms manually, but all notes in slash voices are
positioned by default on the middle line of the staff, regardless of the pitches you input.

If you later change the time signature, such as from 3/4 to 6/8, Dorico Pro only changes the note
grouping to fit the meter just like for other notes; it does not change the presentation of rhythm
in slash voices like it does for slash regions.

NOTE

● Because you can change notes in slash voices to normal voices and vice versa, the pitches
you input are retained.

● Notes in slash voices are not played back.

You can have multiple slash voices active at the same time. To accommodate all slash voices in
multiple-voice contexts, Dorico Pro changes their staff position automatically. However, you can
also change the staff position of rhythm slashes manually.

You can use slash regions and slash voices in the same project and at the same rhythmic
positions, for example, you can input a slash region where you do not want to be specific about
the rhythm, then input notes in a slash voice for a single bar where you want to specify an exact
rhythm.

RELATED LINKS
Rhythm slashes on page 849
Slash regions on page 849
Slashes in multiple-voice contexts on page 851
Changing the voice of existing notes on page 287
Changing the default stem direction of voices on page 946
Changing the staff position of rhythm slashes on page 852
Copying and pasting notes into different voices on page 284

Changing the slash voice type
You can change the voice type of slash voices, for example, if you want to change a slash voice
from having stems to being stemless. You can also change the type to normal notes, which
restores the original pitches you input, and change normal notes to rhythm slashes.

NOTE

This affects all notes in the same voice. If you only want to change the slash voice type of some
notes, you must change the voice of those notes instead.

PROCEDURE

1. Select a note in the voice whose slash type you want to change. You can do this in Write
mode and Engrave mode.

2. Choose Edit > Voices > Rhythmic Slashes > [Voice type].
For example, to change a whole normal voice to a stemless slash voice, choose Edit >
Voices > Rhythmic Slashes > Slashes without Stems.

TIP

You can also choose these options from the context menu.

Voices
Slash voices 

1044
Dorico 2.2.20



RESULT
The slash voice type of all notes in the same voice and flow as the selected note is changed.
If you change normal notes to a slash voice, they are all automatically positioned on a single staff
line. By default in single-voice contexts, this is the middle line of the staff.
If you change rhythm slashes to normal notes, their original pitches are restored, meaning their
staff positions reflect their pitches.

RELATED LINKS
Changing the voice of existing notes on page 287

Adding slash voices to percussion kits
You can add slash voices to percussion kits, for example, to show the desired rhythm for a
passage without specifying the instruments to be played. You can add multiple slash voices to
the same kit, including slash voices with and without stems.

NOTE

Rhythm slashes in percussion kits only appear when the five-line staff presentation is used. They
do not appear in grid or single-line instrument presentations.

PROCEDURE

1. In the Players panel in Setup mode, expand the card of the player holding the percussion
kit to which you want to add slash voices.

2. Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit to open the Edit Percussion Kit dialog.

3. In the action bar below the five-line staff editor, click the button that corresponds to the
type of slash voice you want to add.

● Slashes with stems

● Slashes without stems

4. Optional: Repeat step 3 as many times as required for the number of slash voices you want
to add.

RESULT
The slash voices are added to the kit. They are positioned on the middle line of the staff by
default.
In note input, you can move the caret to slash voices just like moving it to other instruments in
the kit, and input notes into slash voices just like inputting notes in percussion kit instruments.

AFTER COMPLETING THIS TASK
You can change the staff position of the slash voices you added to the kit.

RELATED LINKS
Percussion kits on page 1020
Percussion kit presentation types on page 1025
Voices in percussion kits on page 1034
Edit Percussion Kit dialog on page 107
Inputting notes in percussion kits on page 154
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Changing the positions of instruments within percussion kits on page 113

Voices
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A
action
The mechanism inside pianos that allows the hammers to strike the strings with different forces,
depending on the strength with which the player depresses the corresponding key. It allows
pianos to use a greater dynamic range, hence their full name “pianoforte”.

anacrusis
See pick-up bar.

articulation
(1) In music notation, symbols that indicate how a note should be played, typically affecting their
onset (attack), release, or duration. (2) In sample libraries, a term that refers to playing
techniques generally.

attachment
The rhythmic position at which an item occurs, or to which an item applies, in the music. In
Engrave mode in Dorico Pro, an attachment line is shown between a selected item and its
rhythmic position.

B
bar
A span of music comprising a specific number of beats, as defined by the prevailing time
signature, whose boundaries are indicated by bar lines. Also known as a “measure”, but this
documentation uses “bar”.

C
cancellation natural
A natural accidental positioned on the staff immediately before a change in key signature or a
single note. It indicates that the previous accidental no longer applies and can be followed
immediately by a new accidental if applicable. Showing cancellation naturals before single
accidentals that follow double accidentals is also known as “archaic cancellation”. Cancellation
naturals before a change in key signature are known as “traditional” when positioned after the
barline and “Russian” when positioned before the barline.

caret
Shown during note input, the caret is the vertical line that extends above and below the staff and
indicates the rhythmic position at which items are input. Also known as an “insertion point”. In
Dorico Pro, the caret, cursor, and pointer are related but serve different purposes. See also
rhythmic grid, note input.

casting off
The act of fixing the layout of pages of music, such as defining a set number of systems per page
or the number of bars per system.

Glossary
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cautionary accidental
A restatement of an earlier accidental to eliminate ambiguities, such as when a tied note with an
accidental continues onto another page. Also known as “courtesy accidentals”.

channel
In MIDI, a channel determines which note, controller, or other data is played by which sound on
which device. In Dorico Pro, notes on a single staff may be played by different channels,
depending on which playing techniques are provided by the patch assigned to each channel. See
also MIDI, patch.

chord
Two or more notes of the same duration that start at the same rhythmic position and share a
stem.

chord input
A variation of note input where notes are stacked on top of each other to create chords rather
than being input after the previous note in sequence. Notes are input at the caret position, which
does not advance automatically. See also caret, note input.

collision avoidance
Automatic adjustments made by Dorico Pro to ensure multiple items at the same position do not
overlap and that all remain clearly legible. Includes changing the shape of items, such as slurs,
and changing the vertical and/or horizontal position of items, such as accidentals in chords.

column
A vertical line representing the same horizontal position across all staves in the system. Used to
determine the position of notes and chords for the purposes of spacing music accurately.
Multiple columns can be used for the same rhythmic position to accommodate multiple voices,
with notes or chords in some voices being offset horizontally from notes or chords in other
voices.

concert pitch
All notes are written as they sound. Full scores are often notated in concert pitch, so that
harmonies and themes are easier to identify. Also known as “sounding pitch”. See also
transposed pitch, instrument transposition.

context menu
A menu that you can access by right-clicking on a mouse or double-tapping on a touchpad. Its
options vary by the location of the mouse pointer when you access it, but it most commonly
contains options also found on the Edit menu.

cursor
The vertical blinking line that appears when entering or editing text. See also caret.

D
disclosure arrow
A small arrow that is shown on all edges of the main window in Dorico Pro. It allows you to hide/
show the toolbar and panels individually.

divisi
Italian for “divide” or “divided”, divisi is when players split in order to play multiple lines of music.
This commonly involves a section, such as Violin I, dividing and using two staves rather than one
for a limited passage. Divisi passages can be notated all on the same staff, using multiple voices
if required, or across multiple staves. See also tutti.

E
EDO
An abbreviation for Equal Division of the Octave, it is a unit used to describe how an octave can
be divided into equal parts, often for the purpose of defining a microtonal scale or tonality
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system. Traditional Western European music uses 12-EDO, that is, each octave is divided into 12
equal semitones or half-steps. Music that uses equal quarter tones uses 24-EDO.

endpoint
The unique combination of inputs and outputs that together allow the correct sounds to be
played for each instrument.

Engrave mode
A workspace in Dorico Pro that allows you to make fine graphical adjustments and to adjust the
page layout and the format of the system. See also modes.

engraving options
Options that affect the graphical appearance of the notation, including choice of symbols, line
thicknesses, and distances. These options apply to the whole project, including all flows and
layouts, and can be set in the Engraving Options dialog.

enharmonic equivalent
An alternative spelling of a note that uses a different scale degree and accidental but produces
the same sounding pitch, such as G♯ and A♭.
ensemble
A predefined collection of players, each holding instruments that are often used together, such
as string quartet, wind quintet, brass quintet, string ensemble, and double woodwinds.

explicit rest
A rest that was deliberately input during rest input or imported from a MusicXML file. Explicit
rests cannot be suppressed between notes in a particular voice. See also implicit rest.

exploding
The process of assigning music to more instruments than it was written for originally. Exploding
music is often a key step in arranging and orchestrating music, such as when a piano piece is
arranged for string quartet. See also reducing.

F
family
Instruments of a similar kind that are typically bracketed together in a score, such as woodwind,
brass, percussion, and strings.

fermata
A notation that indicates all notes at that position are held for longer than their notated length. It
is most commonly shown as a curved line with a dot under the curve, but it can also be shown
with a pointed arch or square shape. Also known as a “pause” or a “birds’ eye”.

flow
A self-contained span of music of any scope, such as a movement in a symphony, a song in an
album, a number in a musical, or a short exercise in a music theory worksheet. A flow can
contain the same players as other flows in the project or separate players just for that flow. See
also player.

formatting
The act of determining the number of bars in a system, the number of systems on a page, and
the distances between staves and systems.

fps
A unit of measurement, short for “frames per second”, that refers to the number of video frames
occurring each second.

fragment
Part of a notation item. For example, fragments of a note include its notehead, rhythm dots,
accidentals, the tip of its stem, and beam. In Write mode, selecting any part of an item also
selects all of its fragments, so any changes you make affect the whole item. In Engrave mode,
you can select each fragment individually to tweak its position or appearance. See also item.
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frame
A rectangular container for music, text, or graphics on a page.

full score
A score comprising all of the music for all of the players and their instruments, typically laid out
in a specific order. The order used varies according to the ensemble for which the music is
written. In full scores for orchestra, the players are typically ordered from the highest wind
instrument at the top of the page, for example, piccolo, to the lowest string instrument at the
bottom of the page, for example, contrabass, with brass, keyboards, voices, and percussion in
between.

G
galley view
A viewing option that shows music laid out as a single, infinitely wide system.

grace note
A small note, often used to show an ornament or embellishment, that is not counted towards the
number of beats in the bar; instead, it steals from the duration of either the preceding or the
following rhythmic notes. Also known as an “arhythmic note”. In common practice, a grace note
with a slashed stem is an acciaccatura, which is to be played as quickly as possible, either
immediately before or at the rhythmic position of the note or chord that follows it. A grace note
with an unslashed stem is an appoggiatura, which is played as half of the written duration of the
note or chord that follows it.

group
A collection of players that comprises either a subset of the main ensemble, for example, a choir
within an orchestra, or a separate group, for example, an off-stage brass group or second
orchestra. Each group of players is labeled separately in the full score and is grouped and
numbered together in the instrument order. See also player.

H
hairpin
A notation for dynamics that uses a pair of angled lines, diverging from or converging on a single
point, to show a gradual increase or reduction in the dynamic level, that is, a crescendo or
diminuendo.

half-bar
The rhythmic position that divides bars into two equal sections when the prevailing time
signatures can be divided into four equal beats. In Dorico Pro, specific beam grouping and note
grouping settings apply to bars with a half-bar. Time signatures that have a half-bar include 4/4
and 12/8.

handle
A selectable item that marks the ends of lines, the corners of frames, and other moveable
positions, such as pedal line retakes and slur control points. In Write mode, handles are circular
and mark rhythmic positions. In Engrave mode, handles are square and mark graphical
positions.

hook
A short line that extends from other lines, most commonly at a right angle, that helps to clarify
the end position of lines. In Dorico Pro, hooks can be used at the end of pedal lines, octave lines,
repeat endings, and tuplet brackets.

horizontal justification
The alignment of musical content to the left and right edges of the frame. To ensure that all
staves in a system occupy the same width, any remaining space that is left over after the music is
spaced is distributed evenly between all of the columns in the system. Sometimes the final
system of a flow is not fully justified and is allowed to end partway across the width of the frame.
See also frame, justification.
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I
implicit rest
A rest that is automatically shown around the notes you input. Its notated duration automatically
adjusts according to the time signature and its position in the bar. Implicit rests can be
suppressed between notes in a particular voice, which hides them. See also explicit rest.

Insert mode
A way of changing how notes are input. When Insert mode is activated, new notes push all the
music that follows after the caret along by the input duration instead of overwriting existing
notes. Similarly, reducing the duration of notes with Insert mode activated pulls them closer
together without leaving rests between the notes.

instrument
Anything that requires at least one staff to represent the sounds or music it produces. Common
instruments include the violin, flute, tuba, and bass drum. However, human voices, computer
triggering samples, and tape recordings can also be instruments.

instrument transposition
The interval difference between the pitch the instrument plays and the resulting sounding pitch,
often included as part of the instrument name. For example, when a Clarinet in B♭ plays a C, the
pitch produced is a concert B♭. Instrument transposition is also known as “instrument pitch”. See
also concert pitch, transposed pitch.

item
Generic term for any note, rest, chord, notation, or other selectable object that appears in the
score in Dorico Pro. See also fragment.

J
justification
The alignment of musical content to the edges of the frame, both horizontally and vertically. See
also frame, horizontal justification, vertical justification.

K
key command
A set of keys that perform a defined task when pressed together. Also known as a “keyboard
shortcut”.

L
layout
A page-based presentation of the music for one or more players in one or more flows, for
example, a full score that contains all players or an instrumental part that contains only a single
player. See also flow, player.

layout options
Options that affect the setup of an individual layout, such as page and staff size. These options
can be set in each layout independently in the Layout Options dialog. See also layout.

lock duration
Functionality that allows you to change the pitches of existing music while retaining existing
rhythms.

lyric
Any text that is intended to be sung or spoken by an individual singer or group of singers. A lyric
can be a whole word or an individual syllable in a multi-syllabic word. Lyrics are shown at each
rhythmic position where a new word or syllable begins. Typically, lyrics are found below the staff,
but are sometimes placed above the staff, for example, in the case of a short score.
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M
measure
See bar.

MIDI
An abbreviation for Musical Instrument Digital Interface, a standard for how electronic musical
instruments, computers, and virtual instruments can connect to and communicate with each
other. In Dorico Pro, MIDI data can be sent to one of 16 channels, which allow either a specific
instrument, or a specific patch on a specific instrument, to receive and respond to the data. See
also channel, patch.

minor key
A key signatures based on a minor scale, which have a different pattern of intervals to major
scales. See also minor scale.

minor scale
A sequence of notes containing the pitches of a minor key. There are three types of minor scales:
natural, harmonic, and melodic. Natural minor scales follow the interval pattern of the Aeolian
mode, which on a keyboard is all the white notes from A-A. Harmonic minor scales also follow the
Aeolian mode interval pattern but the seventh degree of the scale is sharpened, for example, G♯
in A harmonic minor. Melodic minor scales follow different interval patterns when they are
rising/falling: when rising, melodic minor scales have sharpened sixth and seventh degrees, but
when falling, the sixth and seventh degrees are both natural. See also minor key.

modes
Selectable workspaces in the project window that represent different phases in the workflow of
preparing a score.

multi-bar rest
A consolidation of multiple adjacent empty bars into a smaller unit, typically shown as a single
bar with the total number of bars' rest written above the staff. A multi-bar rest normally shows
an H-bar symbol, which is a thick horizontal line with vertical lines at each end. In some older
published scores, a multi-bar rest of up to nine bars in length is shown using a combination of
double whole and whole rests.

music area
The main part of the window in Setup, Write, and Engrave modes where you input and edit your
music.

MusicXML
A file format designed to allow the interchange and archiving of music notation data in an open
and non-proprietary way. It is useful for exchanging scores between different music applications.

N
notation options
Options that affect the way the music is notated, particularly concerning how notes and rests are
grouped according to meter, rules for the extent of accidentals, and options for transposition.
These options can be set independently for each flow in the Notation Options dialog.

note input
The standard method of adding notes to staves in sequence that is possible when the caret is
active. The caret automatically advances to the next rhythmic position after each note is input.
During note input, it is also possible to input other items at the caret position. See also caret,
chord input, Insert mode.
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P
padding
The minimum distance/gap between two items, such as text and its enclosure. Padding values
can be independent of other set values, such as minimum height or width.

padding rest
A rest that fills the extra rhythmic space before or after cues that start or end partway through
bars. This shows clearly how the rhythm of the cue fits within the current time signature and how
it relates to the player’s existing material.

page break
The forced termination of a page of music at a particular rhythmic position, typically at a barline.
Often used to ensure a convenient page turn in a part. In Dorico Pro, page breaks can be
achieved using frame breaks, which are indicated using signposts.

page view
A viewing option that shows music laid out on a page with a fixed width and height, as it appears
when printed. See also galley view.

panel
Wide palettes of tools on the left, right, and bottom edges of the program window that are
available in all modes, but their content varies in each mode.

part
The music belonging to the instruments played by one or more players, shown on its own rather
than in a full score. Performers who do not need to see the music belonging to the whole
ensemble play from parts so they only have to read the music they play themselves. See also full
score.

patch
An older term for a discrete sound on a MIDI device or virtual instrument. See also channel,
MIDI.

pedal level change
A change to how far a piano sustain pedal is depressed, between 1 (fully depressed) and 0 (not
depressed). It is notated as a change to the height of a pedal line. Also known as a “pedal lift”.

pick-up bar
A note or notes played before the first full bar of a piece. Also known as an “upbeat” or
“anacrusis”. Pick-up bars often only comprise one or two beats whose main purpose is to lead in
to the start of the piece.

player
A musician who plays one or more instruments. Players are defined as either solo players or
section players and are assigned to flows and layouts. See also solo player, section player, flow,
layout.

playhead
A vertical line that moves alongside music during playback and when recording, showing the
current rhythmic position. Also known as a “playback line”.

Play mode
A workspace that allows you to assign VST instruments, to adjust the mix, to apply automation,
and to tweak note data. See also modes.

playthrough
A single time playing from the beginning of the piece to the end. Music that contains multiple
possible endings, such as music with repeat endings or codas, requires multiple playthroughs.

plug-in
A software program that can operate within another software program. Dorico Pro supports VST
instruments and effects and script plug-ins written in Lua.
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pointer
The symbol on the computer screen that follows movements made by the user with a mouse or
on a touchpad. It is most commonly an arrow pointing towards the top left corner of the screen.

polymeter
Music containing multiple simultaneous meters, for example, one instrument in the ensemble
plays in 6/8 and another plays in 7/4.

popover
A temporary value field that is evoked using a key command and allows you to input items using
text entries. You can open popovers in Write mode during note input or when items are selected
in the music area. There are dedicated popovers for different types of items.

preamble
The notations typically drawn before the first note or rest on each system of music. The preamble
usually includes clefs, key signatures, and time signatures. In Dorico Pro, the preamble is drawn
automatically and so you cannot select any items included in it.

Print mode
A workspace that allows you to print to your printer, export to PDF, and export to other graphics
files. See also modes.

print preview area
The main part of the window in Print mode where you can see a preview of what is going to be
printed or exported as a graphic. See also Print mode.

project
A Dorico Pro file that can contain multiple flows and layouts. See also flow and layout.

properties
The characteristics of individual items and fragments of items in your project that can be edited
via the Properties panel. Many properties are layout-specific, meaning changing the properties of
an item in one layout does not affect the same item in other layouts.

Q
quantization
In music, the act of adjusting the positions and durations of notes so they align with the nearest
defined beat. This process eliminates small variations in rhythm and duration produced naturally
by live performers, and can be useful when importing/exporting MIDI data as quantized music
produces neater notation.

R
rastral size
The size of a full five-line staff, measured from the bottom line to the top line. The term comes
from the rastra engravers historically used to draw five-line staves on blank paper. Because the
rastrum is a fixed object, people became used to their set sizes and Dorico Pro continues this
tradition by offering users a selection of rastral staff sizes.

reducing
The process of taking music for more than one instrument and assigning it to fewer instruments,
such as a keyboard reduction of a choral piece. A piece of music that has been reduced is known
as a “reduction”. See also exploding.

rhythmic grid
A unit of rhythmic duration whose value affects certain aspects of inputting and editing, such as
the amount by which items move. Its current value is shown by the note value in the status bar,
and by ruler markings indicating beat divisions and subdivisions above the staff on which the
caret is active. See also caret.
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S
score
See full score, part, project.

section player
Multiple musicians who all play the same instrument and read from the same part layout, for
example, Violin I. Section players may not play multiple different instruments, but can divide. See
also player.

Setup mode
A workspace that allows you to add players, to assign instruments to those players, to create
flows, and to assign players and flows to layouts. See also modes.

SMuFL
Short for “Standard Music Font Layout”, it is a font specification that maps all the different
symbols required for music notation onto a standard layout. Dorico Pro requires SMuFL-
compliant fonts for certain areas of the program, such as clefs and dynamic glyphs, to ensure it
can locate the correct symbol. SMuFL-compliant fonts include Bravura, Petaluma, and November
2.0.

solo player
An individual musician who can play one or more instruments, for example, a flute doubling
piccolo. See also player.

space
A unit of measurement in music engraving based on the distance between the center of two
adjacent staff lines. Practically all notation items are scaled in proportion to the size of a space,
for example, a notehead is normally one space tall.

spacing
The act of determining the horizontal distance between successive columns in order to format
the music. Horizontal spacing in Dorico Pro considers the graphical shape and size of notes and
other items, such as rhythm dots and accidentals, and the note spacing values set. Full systems
are automatically horizontally justified.

spelling
The way in which a note of a given pitch is specified by a letter name plus an accidental. For
example, assuming the conventional 12-EDO pitch system, MIDI note 61 can be spelled as C♯, D♭,
and B. The same pitch is normally spelled a certain way in a given key, for example, MIDI note 61
is normally spelled as C♯ in D major, but is spelled as D♭ in A♭ major. See also EDO, MIDI.

split stem
A way of presenting altered unisons that keeps each accidental directly beside the notehead to
which it applies. Also known as a “cherry stalk” or “tree”.

staff-relative placement
The vertical position of items relative to musical staves, that is, either above or below.

staff spacing handle
The square handle on the bottom left corner of each staff when Staff Spacing is activated in
Engrave mode. Staff spacing handles only change the vertical position of a single staff. See also
system spacing handle.

string shift indicator
An angled line that indicates the direction of movement when string players have to shift
position on the fingerboard to play a higher/lower note with the same finger as the previous
note.

stroke
The short line that bisects editorial slurs and ties. Also known as a “notch”.
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SVG
SVG stands for Scalable Vector Graphics, which is an XML-based way of displaying and modifying
graphics. Due to the way it is coded, it allows you to modify graphics very flexibly compared to
other formats.

system break
The forced termination of a system of music at a particular rhythmic position, typically at a
barline. Indicated in Dorico Pro with signposts.

system formatting
The distribution of bars into systems and systems into frames. When copying part formatting
between layouts, Dorico Pro considers the positions of system breaks, frame breaks, and note
spacing changes to be aspects of system formatting.

system fullness indicator
The highlighted region in the right page margin that is shown when Note Spacing is activated. It
combines a color (green, purple, or red) and a percentage to indicate how full the system is.

system object
An item that applies to all staves in the system, but is not necessary to show on every staff, such
as tempo marks and rehearsal marks. In Dorico Pro, you can show system objects at multiple
positions in each system by showing them above multiple instrument families.

system spacing handle
The square handle on the top left corner of each system when Staff Spacing is activated in
Engrave mode. System spacing handles change the vertical position of the top staff in systems,
which also moves all staves in the system accordingly. See also staff spacing handle.

T
tempo track
The timing-related information included in MIDI data that affects tempo, SMPTE offsets, time
signatures, timecodes, and markers, which can be imported independently of the rest of the data
in MIDI files.

token
A code used in a text string that is automatically replaced by a piece of information from
elsewhere in the project, such as the title of the current flow, the name of the player, or the page
number. Also known as a “wildcard” or “text code”.

touchpad
Any flat device with a tactile sensor that functions as an alternative to the traditional computer
mouse. Commonly built into laptop computers but can also be separate appliances connected
wirelessly or via a cable.

transport
Encompasses all options related to playback and recording.

transposed pitch
In transposed pitch, the pitches notated are the pitches that the instrument plays, rather than
the desired sounding pitch. Instrumental parts are always in transposed pitch so that players can
simply play the written notes, which is especially important for transposing instruments. See also
concert pitch, instrument transposition.

tuplet
A rhythm that is performed at a fraction of its normal written duration. For example, a triplet is
three notes of a given note value played in the time it would normally take to play two notes of
that note value. Also known as an “irrational rhythm” or a “countermetric rhythm”.

tutti
Italian for “everyone”, tutti indicates that a passage of music is to be played by all players reading
from that part or staff. It is most commonly used to indicate the end of a divisi passage, or for
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clarification when a staff can indicate both solos and tutti passages at different times. See also
divisi.

U
upbeat
See pick-up bar.

V
vertical justification
The spreading out of staves and systems across the full height of frames with as even a
distribution of space as possible. If the music in the frame requires less vertical space than is
available, the remaining space is distributed evenly between the systems, and between the
staves of the systems. See also frame, justification.

voice
In Dorico Pro, a series of notes, chords, rests, and other notations that make up a single musical
line and are normally played by the same instrument. Assigning notes and items to different
voices allows multiple lines of music to be presented on the same staff as clearly as possible,
such as in vocal music where the soprano line uses an up-stem voice and the alto line uses a
down-stem voice. Dorico Pro allows as many voices as are needed to be input onto a single staff,
and lays them out and spaces them automatically.

VST instrument
Short for “Virtual Studio Technology instrument”, it is a digital plug-in that converts MIDI data
into audio output. It can emulate an existing piece of studio hardware or can be an entirely new
creation.

W
Write mode
A workspace that allows you to input music and other notations. See also modes.
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A
abbreviated tempo text 952
absolute tempo changes 951

components 958
Academico font 365
accelerando 962

inputting 196, 200
trills 742

accents 497
inputting 182

acciaccaturas 657
inputting 167

accidental components 678
attachment points 678

accidental duration rules 493
changing 494
common practice 495
Modernist 496
Second Viennese School 496

accidental spelling 164
changing 163
disabling respelling 141, 164

accidentals 488
altered unisons, See altered unisons
appearance 489
cancellation 494, 495
cautionary 495
changing 163
chord symbols 564, 578
chords 490
collision avoidance 490
custom 677, 678
custom tonality systems 677
default settings 489
deleting 488
duration rules, See accidental duration rules
engraving options 489
enharmonic equivalents 163
filters 278
hiding 489, 495, 738
horn branch indicators 646
inputting 162, 493
kerning 491
key signatures 671, 688
ledger lines 489
microtonal 492, 493
MIDI input 164
octave divisions 674
order 489
ornaments 730, 741

accidentals (continued)
panel 134, 189
parentheses 489, 495
position 489
respelling 163, 164
restating 496
showing 489, 495, 738
signposts 281
slurs 892
spacing 491
stacking order 490
ties across breaks 489, 969
tonality systems 675
trills 737, 738, 740, 741

action
expression maps 452

activating
caret 148
chord input 132, 167
dotted notes 132
force duration 132
frames 291
grace note input 132
graphic editing 291
Insert mode 132, 153
lock to duration 132
mouse input 132, 151
note input 148, 149
note spacing 291, 388
rest input 132
scissors 132
staff spacing 291, 396
tuplet input 132

adagio 950
inputting 196, 198, 200

add intervals popover 172
adding notes 171
transposing notes 174

added notes
chord symbols 214

adding, See inputting
additional

endings 257, 259, 823
voices 159, 1039

additive time signatures 983
advanced options

hiding 41
showing 41
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advancing
caret 148
chord symbols popover 216
lyrics popover 248

aeolian chord symbols 215, 578
aggregate time signatures 983
aikin noteheads 714
alignment

arpeggio signs 748
chord symbols 575
dynamics 615, 616, 618, 632, 633
gradual dynamics 618
instrument names 97
lyrics 690, 698
octave line numerals 591
ornaments 731
page numbers 766
pedal lines 777
repeat endings 825
repeat markers 831
rests 859
staff labels 97, 897
staves 349
tempo marks 953
text 266, 338, 339, 366, 368, 369, 371
time signatures 994
trills 733
voices 1039, 1042

allegretto 950
alterations

chord symbols 214, 564
jazz ornaments 232

altered bass notes 215, 219, 564
inputting 215, 219

altered unisons 491
appearance 492
formatting 492
split stem 949

alternating time signatures 983
alto abbreviation

horn fingerings 646
anacrusis 985
angles

beams 542, 551, 552
fanned beams 551, 552
glissando lines 753, 757, 758
hairpins 627
octave lines 588, 589
slurs 882
string shift indicators 651
tremolos 1001
tuplet brackets 1014

annotations 485
aperture

hairpins 628
appearance

default settings 90, 139, 299
resetting 281

appoggiaturas 657
inputting 167

Arabic numerals
fingerings 650
page numbers 312, 767
staff labels 899

arco 790
hiding 795
inputting 238, 242, 243

areas
editing 107, 1025
music 38
print preview 39
project start 37

arpeggio signs 745
alignment 748
appearance 745, 746, 750
beat-relative playback 751
changing 280
default settings 750
deleting 283
direction 745
duration 750, 752
ends 746
engraving options 750
filter 278
formatting 378, 746
grace notes 750
handles 747, 749
inputting 229, 231, 234
length 234, 747
moving 749
muting in playback 434
panel 234
playback 750–752
popover 231, 234
position 747, 748, 750
rhythm slashes 750
spacing 748
symbols 378
types 231, 746

arrangements
accidentals in key signatures 671
flows 117
movements 117

arranging 283, 284
changing instruments 106
copying 284, 285
exploding 287
pasting 285
reducing 286
swapping staves 286
voices 284, 287, 288

arrows
disclosure 41
dividers 936
noteheads 712
vocal staves 936

articulations 497
changing 498
collision avoidance 502
copying 498
cues 605
default settings 499
deleting 498
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articulations (continued)
duration 497, 503
engraving options 499
formatting 378
gaps 503
inputting 182, 183
inverting 502, 503
jazz, See jazz articulations
key commands 183
kits 1023
moving 501
notes 500
order 500
overlapping 502
panel 134
percussion 465, 1023, 1027
placement 500, 502, 503
playback 465, 503
playing technique-specific noteheads 465
position 499–501
slur endpoints 872
slurs 500
spacing 501
stems 500
symbols 378
ties 500, 968
tremolos 465
tuplets 1009
types 497
vertical position 503

assigning
expression maps to endpoints 450
flows to layouts 93, 122
instruments to endpoints 450
key commands 55
MIDI commands 56
percussion maps to endpoints 450
players to flows 93, 118
players to layouts 93, 121

atonal key signatures 673
attachment lines

caesuras 228
dynamics 631

attachment points
accidental components 678
chord symbol components 569
noteheads 716, 719
playing techniques 798
stems 719

attack
articulations 497
dynamics 613
playback 451

audio
buffer size 180, 181
device setup 51
dialog 76
exporting 76
mixer 443
outputs in mixer 448
repeats 436
videos 129
volume 129, 443

auditioning
chords 279
MIDI devices 176
notes 176, 278, 279

augmented
chord symbols 214

auto-save 78
deleting projects 78
disabling 80
interval 79
location 79

automation lanes 418
deleting events 421
editing 420
hiding 419
inputting events 419
moving events 420
showing 419
tempo 421, 423

auxiliary notes 740
notehead design 722
position 741
showing 741

B
backgrounds

dynamics 619
erasing 377, 619, 794
playing techniques 794
text 377

backups 80
auto-save, See auto-save
location 80
number 80

bands
staff grouping 60, 558
templates 59, 60

bar numbers 519
alternative 533
appearance 519, 533, 535
changing 531
default settings 519, 520
deleting 531
enclosures 519, 522, 523
engraving options 520
excluding repeats 534
font 519, 521, 533
frequency 520
galley view 43
guide 526
hiding 526, 529
including repeats 534
layout options 519
moving 527, 529
paragraph styles 521
part layouts 525
pick-up bars 985
position 527
prefixes 535
ranges 526
repeat sections 533
returning to primary sequence 533
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bar numbers (continued)
sequence changes 530
showing 526
signposts 281
size 521
staff-relative placement 528
subordinate 532, 533
subsequent repeats 533, 535
suffixes 535
time signatures 529

bar repeats 839
bar numbers 526
casting off 355
changing 280, 840
changing number 843
consolidating 865
counts 842, 843
default settings 840
deleting 283
dynamics 840
engraving options 840
filter 278
font style 842, 845
formatting 378
frame breaks 357
frequency 844
grouping 846, 847
handles 841
hiding counts 844
highlights 839, 842
inputting 255, 256, 264
length 841
moving 841
moving counts 846
multi-bar rests 865
panel 256
parentheses 844
phrase length 280, 840
playback 280, 840
popover 255
regions 839
symbols 378, 846
system breaks 359
types 255
viewing options 842

bar rests 864
cues 139, 608, 609
hiding 864
inputting 165, 202
moving 866
multi-bar rests 865
showing 864

barline joins 515, 559
deleting 517
inputting 516
length 517
splitting 517

barlines 509
across staves 293, 515, 516
appearance 511
caesuras 228
coda 511
custom joins 515, 562

barlines (continued)
dashed 509
default settings 511
deleting 513
double 509, 834
dynamics 618, 619
end barlines 511
engraving options 511
fermatas 670
final 509
formatting 293, 378
gaps 377, 619, 794
grace notes 659
gradual tempo changes 956
hiding 377, 619, 794
hymnal-style 511
inputting 201, 203, 206, 207, 507
joins 293, 515, 558, 562
key signature changes 512
key signatures 684
moving 513, 514
notation options 511
ossia staves 922
panel 203, 207
popover 201, 203, 206
repeat 509, 511, 837
resetting 562
scale size 509
short 509
signposts 281
single 509
spacing 513
staff grouping 293, 515, 558, 559
staves 515, 516
symbols 378
systemic 512
thickness 509, 511
tick 509
time signatures 516, 994
triple 203
types 203, 509

Baroque
appoggiaturas 657
ornaments 232, 729
trills 742, 744
tuning 435

barré 790
inputting 238, 242, 243

bars 9, 504
bar rests 165, 864, 866
combining 508
count-in 180
deleting 202, 504, 505
deleting contents 506
display 446, 447
divisions 507
duration 506
fixing number per system 355
glissando lines 754
grouping 846, 847
inputting 201–205
multi-bar rests 864, 865
numbers 520
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bars (continued)
panel 203, 204
pick-up bars 985, 986
popover 201, 202, 204
repeat symbols 839
selecting 276
splitting 507
timecodes 821
width 506

Bars and Barlines panel 203, 204, 207
bass notes

altered 219
beam corners 548
beam groups 539

creating 537
default settings 139, 539
notation options 539
pick-up bars 986
resetting 540
stem directions 944

beam lines
number 548

beam slants 541
changing 542
grace notes 662

beaming 537, 539, 551
accidentals 496
centered beams 543, 544
corners 548
cross-staff 544, 546
default settings 539
direction 538, 542, 552
fanned 551, 552
grace notes 662
grouping 537, 539, 553
handles 542
hiding 948
inverting 541
large pitch ranges 662
meter 554
multiple staves 546
notation options 539
notes 537
optical cross-staff spacing 546
partial 538
primary beams 548
resetting 540, 541, 544
restating accidentals 496
secondary beams 548, 549
slants 541, 542, 662
spacing 546
splitting 139, 540
staff-relative placement 541
stem direction 541, 546
stemlets, See stemlets
ties 166
time signatures 539, 554
tuplets 549
unbeaming 538

beat groups
numerators 988
specifying 191

beat groups (continued)
ties 966
time signatures 988, 989

beat units 960
metronome marks 280, 960
setting 198
tuplets 169

beats
deleting 202, 504
display 446, 447
inputting 202, 204, 205
per minute 960
popover 202
recording latency 180
relative position 281
selecting 277

beep, See click
bends 759, 760

inputting 230, 232, 233, 237, 238
birds eyes, See fermatas
black noteheads 710, 711
blank areas, See erased backgrounds
blank pages 308

deleting 309
inserting 310
staff spacing changes 392

blue selections 633, 876
booklets 481

duplex printing 481
printing 480, 481

borders 485
padding 377
text 337, 376
thickness 338, 376

Boston chord symbols 565
bottom panel 40
bowing 790

inputting 238, 242, 243
boxes

text 376
bpm 960

swing playback 441
braces 555

appearance 557
custom grouping 559, 560
deleting 562, 563
formatting 293, 378
grouping 559
inputting 560
length 561
resetting 562, 563
secondary brackets 556
signposts 281, 560
staff spacing 350, 393
symbols 378

brackets 555
appearance 557, 558
barlines 515
custom grouping 559, 560
deleting 562, 563
ends 558
ensemble types 60, 558
formatting 293, 378
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brackets (continued)
grouping 293, 559
inputting 560
length 561
player groups 515
project templates 60
resetting 562, 563
secondary 556
signposts 281, 560
staff spacing 393
sub-brackets 293, 556
sub-sub-brackets 557
symbols 378
templates 60
time signatures 987, 988, 995
tuplets 1013
wings 558

Brandt-Roemer chord symbols 565
brass instruments

fingerings 639, 646, 649
horn branch indicators 646, 649
playing techniques 241
slide positions 650

Bravura music font 365
breaking

multi-bar rests 864
tie chains 972

breaks
frame 356
page 356
system 358

breath marks 664, 666
appearance 280
deleting 283
inputting 225, 227, 228
moving 668, 669
multiple at same position 667
placement 667
position 667
types 280, 666

breves 9, 134
Britten fermata 664
buffer

audio 180, 181

C
caesuras 664, 666

appearance 280
deleting 283
inputting 225, 227, 228
moving 668, 669
multiple at same position 667
placement 667
position 228, 667
types 280, 666

cancellation
accidentals 494, 495
double accidentals 494
key signatures 673, 686
naturals 686

candidate menus
cues popover 269
playing techniques popover 238
tempo popover 196

capitals
staff labels 899

cards
disclosure arrows 41
flows 89
layouts 86
players 83
timecodes 89

caret 146
activating 148
advancing 148
chords 27, 146, 167
deactivating 148
grace notes 146, 167
inputting vs. editing 143
Insert mode 146, 153
lock to duration 146
moving 144, 148, 1008
percussion kits 154
rhythmic grid 144, 145
slash voices 146
slashes 160
types 146
voice indicator 146, 159, 622

casting off 355
bars per system 355
copying to other layouts 360, 362
systems per frame 356

categories
templates 59, 60, 558

cautionary accidentals 495
hiding 489, 495
parentheses 495
showing 489, 495
tie chains 489

cautionary fingering 648
hiding 648
parentheses 648
showing 648

CC64
pedal lines 70, 181

centered beams 543
creating 544
removing 544

centimeters
staff spacing 392
unit of measurement 57

chains
frames 326
ties 968

Change Divisi dialog 930
channels 443

changing 450
controls 443, 445
endpoints 447
expression maps 448, 450
instruments 450
meter 443
MIDI 443
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channels (continued)
mixer 443, 445
percussion maps 448, 450
playback 447
plug-ins 448
setup 448
strips 445

character styles 363, 369
creating 370
deleting 371
dialog 369
saving as default 369

Character Styles dialog 369
cherry stalks 491, 949
choir templates 59

staff grouping 60, 558
choral

divider arrows 936
lyrics 690
playing techniques 241
verse numbers 705

chord input
activating 132, 167
arpeggio signs 234
caret 146
register selection 151

chord symbol components 564
attachment points 569
handles 566, 568, 569
inputting 213
popover 213
types 564

chord symbols 564
accidentals 564
added notes 214
alignment 575
alterations 564
altered bass notes 219
appearance 564–566, 568, 569
changing 280
components, See chord symbol components
default settings 141, 564
deleting 283
dialog 566, 568, 569
engraving options 564
enharmonic spelling 141, 578
filter 278
fonts 573
hiding 574, 577
input settings 141
inputting 213, 216–218
intervals 214
MIDI input 213, 217
MIDI navigation 56, 141
modal 215, 578
moving 575, 576
MusicXML import 579
navigation during input 216
no chord 215
omissions 214
pitch 123
playback 425, 427
polychords 215, 218

chord symbols (continued)
popover 141, 213
position 575
quality 218, 574
resetting appearance 572
root 218, 574
roots 214
saving as default 572
separators 573
showing 574, 577
signposts 281
staves 577
suspensions 214
track 425
transposing 123, 573
transposing instruments 123, 578
types 213, 564, 565

chords
accidentals 490
arpeggio signs 748
auditioning 279
caret 27, 146, 148, 167
collision avoidance 490
dense 490
inputting 27, 132, 167
register selection 151
stacking accidentals 490
stem directions 944
ties 979
track 425

chords track 425
chorus lyrics 692

changing lines to 702
popover 247

chromatic glissando 753
circle

bar number enclosures 522, 523
noteheads 711
rehearsal mark enclosures 806, 807

Classical
ornaments 232
trills 742, 744

clefs 580
cues 595, 609, 610
deleting 583
filter 278
formatting 378
grace notes 584
hiding 222
inputting 219–222
key signatures 684
moving 581, 582
panel 222
placement 581
popover 219, 220, 222
position 581, 584
signposts 281
size at clef changes 583
spacing gaps 581
symbols 378
tie chains 581
ties 970
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clefs (continued)
transposing instruments 584, 585
types 220

Clefs panel 221, 222
click 179, 446

count-in 180
MIDI recording 176
mixer 443
playback 179
settings 179

closing tabs 47
coda 830

appearance 831
barlines 511, 834
font 831
inputting 260, 261
mid-system gap 830
mid-system gaps 835
multiple 831, 832
sections 830
size 831, 832

codec 125
codes 332

time 819
col legno 790

inputting 242, 243
collapsing, See expanding
collision avoidance

articulations 502
galley view 395
slurs 874, 892
text 375
ties 966

colored regions 415
colors

bar repeats 842
cues 611, 612
graphics 478
monochrome 478
rests 863
slash regions 850
unison ranges 935
voices 1039, 1041

columns
accidentals 490
voices 1039, 1042

combined dynamics, See dynamics
combining, See consolidation
comma breath marks 666
commands

key commands 52, 55
MIDI 52, 56

common practice accidental duration rule 495
common time 671, 983

inputting 191
components

accidentals 678
articulations 499
chord symbols 213, 564, 569
noteheads 716, 719
playing techniques 798
tempo marks 958

composer 90
default master pages 653
text tokens 332

compound time signatures 983
rhythm slashes 850

compressed MusicXML 67
con sordino 790

hiding 795
inputting 238, 242, 243

concert pitch 123
clefs 584, 585, 609
cues 609
input pitch 149
instrument transpositions 902
layouts 120, 123
staff labels 895, 902
status display 42
viewing 123

concertina dragging 397
consolidation 508

bar repeats 865
bars 508
rests 139, 861, 864, 865
rhythm dots 725, 726
staff labels 897, 898

constraints
defining 341
flow headings 318
frames 340

contents
bars 506
cue labels 602
cues 601
front matter 653
table 653

continuation lines
angles 772
dynamics 613, 624
octave lines 587
pedal lines 771, 772, 782, 784, 785
slurs across breaks 893
tempo marks 956, 962, 963
thickness 785, 964

continuation signs 786
parentheses 786
text 787

control changes
expression maps 452

control points
handles 883, 886, 974
slurs 879, 880
ties 973, 974

controllers
automation 418
expression maps 451
MIDI 418

conventions
arpeggio signs 748
breath marks 667
caesuras 667
cues 595
dynamics 614
fermatas 667
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conventions (continued)
fingerings 639
glissando lines 753
grace notes 658
key signatures 671, 684
lyrics 690
ornaments 731
pauses 666
pedal lines 777
playing techniques 791
rehearsal marks 805
rests 859
tempo marks 953
ties 966
time signatures 982
tremolos 1001
trills 731
tuplets 1007
voices 1039

converting
layouts to graphic files 475
notes into tuplets 1009
PDF 475
tuplets into normal notes 1010

copies
printing multiple 472

Copy Staff Spacing dialog 398
copying 283–285

articulations 498
divisi 934
dynamics 279
exploding 287
frames 307, 325
master pages 307
notes 498
notes into voices 284
page layouts 307, 361
part formatting 362
players 96
properties 363
reducing 286
slurs 279
staff spacing 398
staves 934

corners
accidental cut-outs 678
beaming 548
crop marks 485
octave lines 588, 589

count-in
duration 180
metronome click 180

counts
bar numbers 533–535, 985
bar repeats 842–844
bars 866
frames 819
moving 846, 857
multi-bar rests 866
page numbers 334
pick-up bars 985
placement 858
repeat endings 823

counts (continued)
repeat sections 533
rests 866
rhythm slashes 855–857
staff-relative placement 858
tacet al fine 866
timecodes 819

courtesy accidentals
hiding 495
showing 495

creating, See inputting
crescendo 613, 624

flared ends 629
inputting 208, 210, 212
system breaks 628

crop marks 485
cross noteheads 711
cross-staff beams 544

placement 546
spacing 546

cross-staff slurs 873
collision avoidance 892
inputting 873
length 873, 876
moving 873, 875

cross-staff ties 970, 971
cross-voice slurs 873

inputting 873
length 873, 876
moving 873, 875

cross-voice ties 970, 971
crotchets 9, 134
Cubase

instrument names 896
staff labels 896

cue labels 602
changing 603
contents 602
moving 604
octave transpositions 596, 599
staff-relative placement 603
text 602

cues 595
appearance 601
articulations 605
bar rests 139, 609
changing to rhythmic cues 596
clefs 595, 609, 610
contents 601
default settings 601
deleting 601
dynamics 605
engraving options 601
filter 278
hiding 606
highlights 611, 612
inputting 268, 270, 271
instrument names 602
instrument transpositions 602
instruments 269
labels, See cue labels
length 600
lyrics 605
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cues (continued)
moving 597, 599, 604
multiple 607
notations included 595, 605
ornaments 605
overlapping 607
panel 269–271
placement 595, 601
playing techniques 605
popover 268, 269
position 595, 597
register 598
respelling notes 601
rests 139, 595, 608
rhythmic, See rhythmic cues
showing 606
signposts 281, 606, 611, 612
size 595
staff position 597
stem direction 607
suggestions 270
text 605
ties 608
transposing 602
unpitched instruments 596
vertical position 596, 597
viewing options 611, 612
voices 607

Cues panel 269, 270
curlew fermata 664
curvature direction

grace notes 870
slurs 869, 870, 872, 887, 888
ties 966, 968, 979, 980

custom
accidentals 677
barline joins 515–517
brace grouping 559
bracket grouping 559
flow headings 320
key signatures 681, 682
layouts 93
markers 815
master pages 304
note sizes 723
noteheads, See custom notehead sets
octave divisions 677
page size 482
paper size 482
playing techniques, See custom playing techniques
repeat endings 828
repeat markers 833
rhythmic feels 441
score layouts, See custom score layouts
staff grouping 559
staff size 910
symbols 378
tonality systems, See custom tonality systems
trill speeds 744

custom notehead sets 715
appearance 719
design 716, 719
editing 716, 719

custom playing techniques 795
design 798
editing 798
exporting 803
playback 803
saving as default 803

custom score layouts 32, 120
creating 121
empty staves 351
flows on pages 344
margins 342, 348
master pages 301
orientation 343
printing 472
renumbering 124

Custom Staff Size dialog 910
custom tonality systems 675

accidentals 677
creating 675
editing 675
key signatures 681
octave divisions 677
playback 683

cut common time 671, 983
inputting 191

cutting
slash regions 853
tie chains 972

D
da capo

al coda 830
al fine 830
al segno 830
font 831
inputting 260, 261
size 831
word wrapping 833

dal segno 830
damping 790

inputting 242, 243
dashed

barlines 203, 206, 509, 922
jazz articulations 763
octave lines 586
pedal continuation lines 785
slurs 888, 890
tempo marks 963, 964
ties 977–979

date and time
annotations 485
tokens 335

deactivating
caret 148
chord input 167
Insert mode 153
mouse input 151
mute states 434
muted tracks 443
note input 149
note respelling 164
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deactivating (continued)
solo states 434
soloed tracks 443

decorations
ornaments 729

decrescendo, See diminuendo
dedications 653, 654

text tokens 332
default flow headings 302, 318

replacing 320
default master pages 302, 304

composer 653
lyricist 653
replacing 304
title 653
tokens 653

default settings 300
accidentals 489
barlines 511
beam grouping 139, 540
changing 300
dialogs 30
dynamics 279
flow headings 318
jazz articulations 761
key commands 11, 52, 55
layouts 124
note grouping 139
note input options 141
note spacing 381, 383
overlapping notes 139
playback 405
playback template 437
slurs 279
staff grouping 558
staff spacing 391, 393
swing playback 441
text 368
text collision avoidance 375
voice order 139

deleting 283, 290
accidentals 488
arpeggio signs 283
articulations 498
auto-save projects 78
automation 421
bar number changes 531
bar repeats 283
barline joins 517
barlines 513
bars 202, 504–506
beams 538
beats 202, 504
braces 562, 563
brackets 562, 563
breath marks 283
caesuras 283
centered beams 544
clefs 583
cues 601
duplicate notes 286
dynamics 621
fermatas 283

deleting (continued)
fingerings 645
flow heading changes 317
flow headings 321
flows 120
flows from layouts 122
frame breaks 358
glissando lines 283
grace notes 283
groups from percussion kits 113
instruments 107
instruments from kits 114
jazz articulations 764
key commands 56, 57
key signatures 683
layouts 124
lyrics 701
markers 283
master page changes 314
master page sets 303
master pages 306
note spacing changes 387, 391
notes 283, 412
octave lines 592
ornaments 283
ossia staves 921
page number changes 313
pages 309, 310
paragraph styles 369
pauses 283
pedal lines 283
player groups 116
players 102
players from flows 118
players from layouts 121
playing techniques 283
reducing 286
rehearsal marks 810
repeat endings 283
repeat markers 283
rests 863
rhythm slashes 283
rhythmic feel change 440
slurs 283
staff spacing changes 397
staves 912
stem direction changes 947
stemlets 551
system breaks 360
tempo changes 425
tempo marks 957
ties 972
time signatures 996
tremolos 1002
trills 283
tuplets 1010, 1011
unison notes 286
videos 129
voices 1041

denominators
styles 988, 990
time signatures 981, 982
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dense chords 490
accidental stacking 490

depth
nested tuplets 1008

deselecting 273
design

fingerings 378, 644
grace note slashes 660
music symbols 378
noteheads 708, 711, 714–716, 719, 722
playing techniques 796, 798
rhythm slashes 850
slurs 888, 891
stem flags 378, 942
time signatures 997

destination
exporting files 476
instruments 595

devices
audio 51

diagonal
accidental stacking 490

dialogs 30
diamond noteheads 711, 713
dimensions

page size 482
paper size 482

diminished
chord symbols 214

diminuendo 613, 624
flared ends 629
inputting 208, 210, 212
system breaks 628

direction
arpeggio signs 745, 746
fanned beams 551, 552
glissando lines 727
gradual dynamics 624
hairpins 624
notes on middle line 945
paper orientation 483
partial beams 538
rhythm slashes 851
slur curvature 869, 887, 888
stems 943, 946, 947
string shift indicators 651, 727
tie curvature 966, 979, 980

disabling
auto-save 80
dynamics linking 279
MIDI devices 182
sampled trills in playback 743
slur collision avoidance 892
slurs linking 279
swing playback 440
text collision avoidance 375

disclosure arrows 41
Properties panel 42
tracks 415

display options 33, 43
drum editor 409
frames 306, 318, 326, 342
image resolution 485

display options (continued)
layouts 37
music area 38, 44
pages 342
panels 18, 40
piano roll editor 408
print preview 39
project window 37
tabs 46
time 35
transport 35

distance
bar numbers 527
brackets 556, 557
cues 597
noteheads 546
rehearsal mark enclosures 807
staff labels 897
stems 546
system indents 927
text borders 338, 377

distribution
bars per system 355
staves per frame 350
systems per frame 356

divide arrows 936
dividers, See system dividers
divisi 929

arrows 936
change labels 937, 939, 940
changing 930
colors 935
dialog 930
editing 933
ending 934
fonts 937
inputting 930, 932
inputting notes 934
lengthening 933
moving 933
playback 940
shortening 933
staff labels 930, 937, 938, 940
staff spacing 350
text 939
tutti 934
unison ranges 934, 935
vocal staves 936

doits 759
inputting 231, 237, 238

dorian chord symbols 215, 578
dotted

beat units 198
dynamics 613
noteheads 714
notes, See dotted notes
octave lines 586
rests 132, 139
slurs 888, 890
tempo marks 963
ties 977–979

Index
 

1069
Dorico 2.2.20



dotted notes 553
consolidation 725, 726
double 152
forcing 158
inputting 132, 152
moving dots 727
note grouping 553
swing playback 438
tempo equations 965
triple 152

double
accidentals 163, 494
barlines 203, 206, 509, 511, 834
dotted notes 152
whole notes 9, 134

doubling instruments 94
adding 104
labels 902
showing staves 50

down-stem voices 1039
adding 159
stem direction 943

downloads
accessing 58

dpi 485
drawing

automation 419
notes 409
tempo 421

drop frame timecodes 819
drops 759

inputting 231, 237, 238
drum editor 409, 1036

deleting notes 412
event display, See event display
inputting notes 409
moving notes 410
tracks 414
zoom 413

drum kits, See percussion kits
drum sets 107, 1019, 1020

defining kits as 111
exporting 1020
importing 1021
naming 107
voices 1034

duplets 1007
duplex printing 472, 481

booklets 481
duplicating

character styles 370
exploding 287
expression maps 457
items 284, 285
notes 284, 285
paragraph styles 368
percussion maps 463
players 96

duration
accidentals 493, 494
arpeggio signs 750, 752
articulations 497, 503
bars 506

duration (continued)
count-in for MIDI recording 180
fermatas 280
flows 334
forcing 158
jazz articulations 763
locking 174
notated 466
notes 134, 157, 411, 466
pedal lines 788
played 466
pre-roll 435
rests 157
slurs 893
terminology 9
tremolos 1005

dynamic curve 637
dynamic glyphs 613

font styles 636
dynamic modifiers 613

font styles 635
dynamics 613

aligning 618
alignment 615, 616, 618, 632, 633
appearance 614
backgrounds 619
bar repeats 840
barlines 618, 619
changing 280
combined 614
continuation lines 613, 624
conventions 614
copying 620
crescendo, See gradual dynamics
cues 605
default settings 614
deleting 621
diminuendo, See gradual dynamics
dynamic curve 637
endpoint positions 618
engraving options 614
erased backgrounds 619, 620
expressive text 208, 210, 623, 624
filters 278, 620
flared hairpins 629
font styles 635, 636
force 613
formatting 378
gradual, See gradual dynamics
grouping 632, 633
hairpins, See hairpins
handles 617, 624, 625, 627, 628
hiding 624
humanize 637
immediate 613
inputting 208, 210, 212
length 617, 625
linking 279, 633–635
moving 616, 617
muting in playback 434
niente hairpins 622
non-sustaining instruments 637
padding 620
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dynamics (continued)
panel 212
parentheses 619
percussion kits 1025
placement 614
playback 436
playback options 637
poco a poco 630
popover 208, 210
position 614, 615
repeats 436
selecting 273
signposts 281, 624
spacing 630
staff-relative placement 615
sustaining instruments 637
symbols 378
types 208, 613
ungrouping 633
unlinking 279, 635
voice-specific 210, 212, 622

Dynamics panel 210, 212

E
East Asian elision slurs 707

hiding 707
showing 707

Edit Accidental dialog 678
Edit Chord Symbol Appearance dialog 568
Edit Chord Symbol Component dialog 569
Edit Custom Key Signature dialog 682
Edit Font Styles dialog 364
Edit Instrument Names dialog 97
Edit Notehead dialog 719
Edit Notehead Sets dialog 716
Edit Percussion Kit dialog 107
Edit Playback Playing Techniques dialog 801
Edit Playing Technique dialog 798
Edit Playing Techniques dialog 796
Edit Tonality System dialog 675
editing 143, 280

area 107, 1025
flow headings 319
handles 298
inputting vs. editing 143
items 136, 280, 298
master pages 307
methods 272
mouse input 143
notes 132
tools 272

editorial
slurs 888
ties 977

editors
drum 409
flow headings 318
master pages 306
piano roll 408
text 266, 371

EDO 674

effects channels 445
mixer 443

eighth notes 9, 134
swing playback 438
tempo equations 965

elbowed beams, See centered beams
empty bars

cues 608
deleting 505
inputting 204
multi-bar rests 864
rests 864
width 506

empty pages
deleting 309, 310
inserting 310
staff spacing changes 392

empty staves
hiding 351, 393
showing 351, 393
tacets 352

empty voices 1041
enabling

chord symbol playback 427
chords playback 425
MIDI devices 182
mouse input 151
sampled trills in playback 743
slur collision avoidance 892
swing playback 439, 440
text collision avoidance 375

enclosures
bar numbers 522, 523
fingerings 644
line thickness 523, 807
padding values 523, 807
rehearsal marks 805–807
text 376, 377

end barlines 511
end repeat barlines 203, 509

inputting 206
playthroughs 837

endings
additional 257, 259
playthroughs 823
repeat 257, 258

endpoint positions
arpeggio signs 747
dynamics 618
octave lines 591
pedal lines 780
repeat endings 828
slurs 869, 871, 872, 879–881
staff lines 871
ties 966
trills 733
tuplet brackets 1015

Endpoint Setup dialog 448
endpoints 447

changing 450
expression maps 448, 450
instruments 450

Index
 

1071
Dorico 2.2.20



endpoints (continued)
percussion maps 448, 450
setup 448

Engrave mode 17, 290
casting off 355
Engraving Options dialog 299
frame breaks 356
frame chains 326
frames 322
graphics frames 340
make into frame 357
make into system 359
moving text 373
music frames 325
note spacing 381
page breaks 356
page layouts 342
panels 40, 290, 292, 295, 298
selecting items 291
signposts 281
staff spacing 391
switching 290
system breaks 358
text editor 371
text frames 331
toolbox 291

engraving options 30, 299, 300
accidentals 489
advanced options 41
arpeggio signs 750
articulations 499
bar numbers 520
bar repeats 840
barlines 511, 922
breath marks 666
caesuras 666
changing 300
chord symbols 564
cues 601
dialog 299
dynamics 614
fermatas 666
fingerings 640
glissando lines 754
holds 666
jazz articulations 761
key signatures 673
ledger lines 708
lyrics 691
markers 814, 821
music fonts 365
notes 708, 942
octave lines 587
ornaments 729
ossia staves 922
pauses 666
pedal lines 781
percussion 1021
playing techniques 790
rehearsal marks 806
repeat endings 824
repeat markers 831
rests 862

engraving options (continued)
rhythm slashes 850
saving as default 299
slurs 872
staff labels 897
stems 708, 942
tempo marks 958
text 265
ties 968
time signatures 982
timecodes 821
tremolos 1004
trills 729
tuplets 1008

Engraving Options dialog 299
enharmonic spelling

accidentals 163, 164
chord symbols 578
key signatures 688
MIDI 69, 176
modes 578
notes 163, 164
respelling 163

ensembles 83, 102
adding 85, 102, 116
brackets 60, 558, 559
divisi 929, 930
groups 115, 116
staff grouping 60, 558
templates 59

equal division of the octave 674
equalization 445
equations

tempo marks 198, 965
erased backgrounds 377

dynamics 619
padding 377, 620, 794
playing techniques 794
text 377

espressivo 613
event display 407

automation lanes 418
chords track 425
inputting notes 409
instrument tracks 416
markers track 427
player tracks 415
playing techniques lanes 417
time track 421
video track 429
zoom 413

events
automation 418–420
markers 427, 428
notes 409
tempo changes 421, 423

excluding
flows from layouts 93, 122
players from flows 93, 118
players from layouts 93, 121
playthroughs from bar numbers 534

exclusion groups
expression maps 452
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expanding 273, 429
menus 41
options 41
selections 273, 274
tracks 429

explicit rests 859, 860
colors 863
deleting 863
hiding 863
implicit rests 862
showing 863

exploding 287
exponential hairpins, See flared hairpins
Export Audio dialog 76
Export File Names dialog 477
Export Flows dialog 65
Export MIDI dialog 72
Export MusicXML dialog 67
Export Tempo Track dialog 75
exporting

annotations 485
arrangements 480
audio 76
borders 485
color graphics 478
crop marks 485
custom playing techniques 803
date 485
expression maps 459
file names 477
flows 64, 65
layouts 475
MIDI 72
MIDI files 72
monochrome graphics 478
MP3 files 76
MusicXML files 67, 829
output format 475
page ranges 474, 480
path 476
PDF 475
percussion kits 1020
percussion maps 464
PNG 475
repeats 436
signposts 485
stems 76
SVG 475
tempo tracks 75
TIFF 475
time 485
watermarks 485
WAV files 76

expression maps 451
creating 457
dialog 452, 456
endpoints 447, 450
exporting 459
hiding playing techniques 795
importing 459
MIDI 638
playing techniques 795, 803
technique combinations 456, 458

expression maps (continued)
trills 742
volume 638

Expression Maps dialog 452
expressive text 613, 623

inputting 208, 210, 624
poco a poco 630

extending, See expanding
extension lines

lyrics 248, 694, 698
trills 734–736

extra staves 913
adding 914
deleting 912
divisi, See divisi
hiding 351
moving 915
ossia staves, See ossia staves
showing 351
signposts 913
width 916

F
fader 443
falls 759

inputting 231, 237, 238
fanned beams 551

angles 552
creating 552
direction 551, 552

fast-forwarding 431
feathered beams, See fanned beams
fermatas 664

appearance 280
barlines 670
changing 668
deleting 283
duration 280
inputting 225, 227, 228
moving 668, 669
multiple at same position 667
number per staff 670
placement 667
position 667
single staves 668
staff-relative placement 669
types 280, 664, 668
voices 670

file formats 484
audio 76
backups 80
frames 340
graphics files 484
MIDI 69
MusicXML 66
videos 125

file names 477
ingredients 477
recipes 477
setting 477

Index
 

1073
Dorico 2.2.20



files 63
different Dorico versions 62
exporting 63, 475, 476
importing 63
loading into frames 340
opening 61
videos 127

filled noteheads 711
films, See videos
filters 278

accidentals 278
dynamics 278, 620
ensembles 85
flows 330
frame chains 330, 331
instruments 85
lyrics 278, 691, 692
notes 278
players 331
stem direction 278
tempo marks 278
voices 278

final barlines 203, 509, 511
inputting 206
number of times played 837

final tempo 962
gradual tempo changes 962

Find Tempo dialog 251
important markers 818

fine
d.c. al 830
font 831
inputting 260, 261
sections 830
size 831
tacet al 866

fingering 639
appearance 640, 644, 648
cautionary 648
changing 641
default settings 640
deleting 645
design 644
enclosures 644
engraving options 640
font 646, 647
font styles 646, 648
formatting 378
handles 640
hiding 645, 648
horn branch indicators 649
inputting 184
inverting 643
italics 648
moving 642
MusicXML import 652
numeral style 650
parentheses 184, 648
placement 639
popover 184
position 639, 640
resetting 642
separators 649

fingering (continued)
showing 645, 648
size 644, 647
slide positions 650
slurs 643
staff-relative placement 643
string shift indicators 651
substitution 640
symbols 378
types 184, 649
underlines 644
valved brass instruments 649

first and second endings, See repeat endings
first master pages

replacing 304
first pages

formatting 345
master pages 304, 345
page numbers 768

first steps
starting new projects 59

first systems
indents 927

fit to paper 483
five-line staff 906

noteheads 1029, 1031
percussion kits 1025, 1026
percussion legends 1032

fixed tempo mode 435
fixing

bars per system 355
frames 357
note durations 158, 166
systems 359
systems per page 356

flag design 942
flags

formatting 378
hiding 948
notes 942
stems 942
symbols 378

flared hairpins 629
size 629

flat slurs 891
flats 488

filters 278
hiding 489
inputting 162
parentheses 489
quarter tones 492
respelling 163
showing 489

flipping 280, 888
flips 760

inputting 230, 232, 233
floating windows 34
flow heading editor 318

opening 319
flow headings 302, 318

adding new 320
arrangements 319
changing 315, 319
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flow headings (continued)
constraints 318
default 318, 320
deleting 321
editing 318, 319
flow titles 348
frames 318
hiding 346
inserting 315
margins 346
master pages 345
moving 346, 396
naming 321
page numbers 348, 768
panel 295
removing changes 317
removing overrides 309
showing 346
text alignment 338, 339
titles 348

Flow Import Options dialog 63
flows 31, 93, 117

accidental duration rules 493, 494
adding 22, 118
adding players 118
adding to layouts 122
audio 76
cards 89
default settings 139
deleting 120
deleting empty bars 505
duration 334
end barlines 511
exporting 64, 65
frame chains 328, 330
hiding 122
importing 63, 66, 69
instrument change labels 902
justification 349
layouts 93
master pages 345
multiple on pages 344
MusicXML files 67
naming 119
notation options 141
numbers 334
page numbers 334, 348
panel 89
playback 435
players 93, 118
pre-roll 435
removing from layouts 122
removing players 118
selecting 274
showing 122
splitting 289
systems 349
tacets 352, 353
timecodes 89
titles 119, 348
tokens 333, 334
trimming 202, 505
videos 89, 125, 127

Flows panel 82, 89
hiding 89
showing 89

folders
auto-save 79
backups 80
export path 476

follow tempo mode 435
font styles 363, 364

bar numbers, See paragraph styles
bar repeats 842, 844, 845
changing 364
character styles 369
chord symbols 573
dedications 654
dialog 364
divisi staff labels 937
dynamics 635, 636
fingerings 646–648
glyphs 365, 636
lyrics 692, 704, 705
markers 816
music 365
notations 365
notes 365
ossia staff labels 922
page numbers 766
paragraph styles 366
PDF files 479
playing techniques 791
rehearsal marks 813
repeat markers 831
rhythm slashes 845, 855, 857
staff labels 897
SVG files 479
tempo marks 951
time signatures 982, 997
timecodes 816
tuplets 1018

force
articulations 497
dynamics 613

force duration 132, 158
activating 132
inputting notes with 158
inputting rests with 158

formats, See file formats
formatting

altered unisons 492
arpeggio signs 746
bar numbers 519, 521
bar repeats 845
barlines 293, 512
braces 293
brackets 293, 558
chord symbols 566, 568, 569
divisi changes 933
divisi staff labels 937, 938, 940
dynamics fonts 635, 636
file names 477
flow headings 318
frame constraints 340
frames 292, 294, 360
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formatting (continued)
front matter 653
glissando lines 754
handles 298
layouts 303, 360–362
markers 815, 816
master pages 301, 306, 307, 319
music symbols 378
noteheads 715, 716, 719, 722
page layouts 302, 308, 355
pages 342, 360–362, 653
pedal lines 782–785
playing techniques 795, 798
repeat markers 831
rhythm slashes 850
slurs 881, 883, 889–891
staff labels 897
symbols 378
systems 292, 360
tacets 352, 354
tempo marks 963, 964
text 266, 268, 363, 366, 368–371
ties 973, 977–979
time signatures 997
timecodes 816
tremolos 1004
tuplets 1010, 1016

Formatting panel 290, 292
forte 613

inputting 208, 210, 212
forum

accessing 58
fps 129
frame breaks 292, 342, 356

bar repeats 357
copying to other layouts 360–362
deleting 358
divisi 929
filter 278
inserting 357
signposts 281, 358
slurs 893
staff labels 901
staff size 908
staff spacing 393
ties 969

frame chains
flows 330
frames 329
layouts 327
linking 329
master pages 326
music 326
note spacing 385, 387
order 330
players 331
resetting note spacing 387
unlinking 329

frame rates 129
changing 126, 130
dialog 126
drop frame timecodes 819

frame rates (continued)
non-drop frame timecodes 819
transport window 446, 447

frames 322
borders 337
breaks 342, 356
constraints 340, 341
copying 307, 319, 325
dashed 318
editing 291, 308
flow heading editor 318
flow headings 318, 346, 348
formatting 294
graphics 340
handles 324, 331
inputting 322
making from selection 357
master page editor 306
moving 323
music 325, 348
order 330
padding 338, 342, 349
resetting 309
running headers 348
selecting 291
shape 323
size 323
systems 356
text 331, 332, 371
text alignment 339
tokens 332

frequency
auto-save 79
bar numbers 520
bar repeat counts 844
pitches in playback 435
slash region counts 856
timecodes 821
trills 735

front matter 653
dedications 654
player list 332
project information 653
running headers 655

full score layouts 32, 86, 120
accidentals 163
adding flows 122
adding players 121
bar numbers 519, 521, 535
clefs 584
concert pitch 123
copying formatting 361, 362
copying frames 325
copying properties 363
creating 121
deleting 124
divisi 929, 930
divisi staff labels 938, 940
empty staves 351
enharmonic spelling 163
exporting 475
file names 477
flow headings 346
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full score layouts (continued)
flows 122, 330
flows on pages 344
frame chains 326, 330, 331
frames 325
front matter 653
hiding ossia staves 921
instrumental order 115
justification 349, 350, 391, 393
large time signatures 986, 988
layouts panel 86
left pages 344
margins 342, 348
markers 818
master page sets 303
master pages 301, 304, 345
multi-bar rests 865
music frames 325
note spacing 383
orchestral order 101
orientation 343
ossia staff labels 923
player lists 655
players 121, 331
playthroughs 535
printing 472
removing flows 122
removing players 121
renumbering 124
repeat marker text 833
staff labels 899, 938, 940
staff size 908
staff spacing 350, 375, 391, 393
system dividers 924
system formatting 360
system justification 349
system object positions 926
system spacing 391, 393
text collision avoidance 375
time signatures 986, 988, 997
transposing 123

full screen mode 50
functions

key commands 55
removing key commands 56

funk noteheads 714
FX channels 445

G
galley view 43, 50

bar numbers 43
changing to 50
flows 289
staff labels 43
staff spacing 393, 395

gaps
articulations 503
barlines 377, 619, 794
codas 835
flow headings 315, 346
galley view 395
key signatures 685

gaps (continued)
ossia staves 393
quantization 71
slurs 890
staves 391, 393, 830
system indents 927
systems 830
tacets 354
tempo marks 964
text collision avoidance 375
ties 979
time signatures 982, 983

General MIDI 70
generated trills 742, 743

playback 743
ghost notes 1023

engraving options 1021
gli altri 929
glissando lines 753

angles 757, 758
appearance 754
changing 280
default settings 754
deleting 283
direction 727
engraving options 754
filter 278
formatting 754
handles 756, 758
hiding 756
inputting 229, 231, 235, 236, 754
length 756
line styles 754
moving 756
panel 236
placement 753
popover 231, 235
position 753
showing 756
styles 754
text 755, 756
thickness 754
types 231

glyphs
accidentals 163, 678
chord symbols 569
dynamics 636
fonts 365, 636
formatting 378
music symbols 378
noteheads 716, 719
pedal lines 782
playing techniques 798
trills 729, 731

Gould
repeat markers 831

grace notes 657
appearance 662
arpeggio signs 750
barlines 659
beams 662
caret 146, 167
clefs 584
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grace notes (continued)
default settings 658, 659
deleting 283
inputting 132, 167
inverting 658
moving 724
note spacing 659
pedal lines 780
pitch 173
placement 658
playback 435
position 658, 659
register 173
size 660, 723
slashes 658, 660, 661
slurs 658, 869, 870
stems 658, 660, 662
transposing 176
trills 742
types 660
voices 658

gradual dynamics 613, 624
alignment 618
barlines 618
end position 618, 631
flared hairpins 629
handles 625
length 625
moving 631
poco a poco 630
position 631
spacing 630
start position 631
truncated 631

gradual tempo changes 951, 962
barlines 956
components 959
continuation lines 962, 963
dashes 964
final tempo 962
formatting 963, 964
gaps 964
length 954, 956
position 956
style 963, 964
thickness 964

grand staff instruments
brackets 60
centered beams 543
chord symbols 577
cross-staff beams 544
cross-staff slurs 873
cues popover 269
dynamics 614
hiding staves 351, 393
MIDI recording 176
staff grouping 60
vertical justification 393

grand-staff instruments
multi-bar rests 864

graphics
accidentals 678
chord symbols 569

graphics (continued)
files, See graphics files
noteheads 716, 719
playing techniques 798

graphics files 475, 484
colors 478
exporting 475, 476
file names 477
fonts 479
formats 340, 484
image resolution 485
monochrome 478

graphics frames 340
file formats 340
inputting 322
loading images 340
selecting 324

grids
gaps 114
instrument groups 111
naming groups 112
percussion kits 1025, 1026
rhythmic 144, 145
staves 904, 1025

groups
bar repeats 846, 847
beams 539, 553, 554
braces 555, 559
brackets 555, 559
dynamics 632, 633
instruments, See groups of instruments
notes 553
players, See groups of players
rests 553
staff labels 897, 898
staff spacing 393
staves 515–517, 559–563
tabs 48, 49

groups of instruments 111
deleting 113
naming 112
percussion kits 111

groups of players 31, 83, 115
adding players 116
bracket grouping 515
creating 115
moving players 117
removing players 117

guide bar numbers 526

H
H-bar rests 864

width 864
hairpins 613, 618, 624

alignment 618
angles 627
aperture 628
barlines 618, 619
end position 618, 631
flared 629
handles 617, 625, 628
inputting 208, 210
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hairpins (continued)
length 625
moving 631
niente 622
poco a poco 630
position 631
rotating 627
start position 631
truncated 631
width 628

half notes 9, 134
tempo equations 965

half-step trills 737, 742
appearance 740
hiding 734, 738
position 741
showing 734, 738

HALion Sonic SE
playback template 436

HALion Symphonic Orchestra
playback template 436

hand tool 42
moving the view 43

handles 762
arpeggio signs 747, 749
bar repeats 841
beams 542
chord symbol components 566, 568, 569
dynamics 617, 624, 625, 627, 628
fingerings 640
frames 323, 324, 328, 331, 340
glissando lines 756, 758
hairpins 617, 628
jazz articulations 761
lyrics 698–700
note spacing 382
octave lines 587, 590, 593
pedal lines 772, 779, 783
percussion legends 1032
repeat endings 825–827
selecting 298, 389
slash regions 854
slurs 878–880, 883
staff spacing 392, 396
stems 947, 1003
system spacing 392, 396
tempo marks 954, 956
ties 973–976
trills 732, 736
tuplet brackets 1012, 1014

harmonics
noteheads 722

headers
chords track 425
flows 318
instrument tracks 416
running headers 655

heavy swing 438
height

enclosures 523, 807
flared hairpins 629
frames 323
handles 879, 880, 885

height (continued)
slurs 884, 885
staves 350, 391, 393
systems 350, 391, 393
ties 974–976
time signatures 982
tracks 429

hemiola
forcing note durations 158

Henze fermatas 664
inputting 225, 227, 228

hiding 35
accidentals 489, 495, 738
audio outputs in mixer 448
automation lanes 419
backgrounds 377, 619, 794
bar numbers 526, 529
bar repeat counts 844
bar rests 609, 864
barlines 377, 511, 512, 619, 794
borders 376
chord symbols 574, 577
clefs 222
cues 606
divider arrows 936
divisi change labels 940
dynamics 624
East Asian elision slurs 707
empty staves 351
fingerings 645, 648
flared hairpins 629
flow headings 346
flow page numbers 348
flow titles 348
flows 122, 352
Flows panel 89
glissando line text 756
initial page numbers 768
instrument change labels 902
instrument transpositions 903
interchangeable time signatures 983
key signatures 683
laissez vibrer ties 971
Layouts panel 86
ledger lines 725
markers 818
mixer 445
multi-bar rests 865
notes 852
octave transpositions in cue labels 599
ossia staves 921
ossia staves in preamble 920
padding rests 608, 853
page numbers 348, 768, 769
panels 18, 35, 41, 42
percussion legend signposts 1031
players 118, 121
Players panel 83
playing techniques 795
playing techniques lanes 418
quality in chord symbols 574
rests 863–865
root in chord symbols 574
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hiding (continued)
running headers 348
signposts 283, 358, 360
slash region counts 857
staff labels 899, 901, 937, 938, 940
staves 93, 118, 121, 122, 351, 912
stems 855, 948
system dividers 924
system track 276
systemic barlines 512
tabs 35
tacets 353
tempo marks 957
text borders 376
time signatures 996
timecodes 821
toolbar 34
tracks 429, 430
transport window 446
trill extension lines 735, 736
trill intervals 738
trill marks 729, 734
tuplets 1013, 1016
verse numbers 706
video window 128

highlights
bar repeats 839, 842
cues 611, 612
slash regions 849, 850

holds, See pauses
Holds and Pauses panel 228
Hollywood-style trills 740

intervals 741
position 741
showing 741

hooks
length 829, 1012
octave lines 593
pedal lines 772, 776, 782, 783
repeat endings 829
tuplets 1012

horizontal alignment
dynamics 618
ornaments 731
text 339, 368

horizontal position
arpeggio signs 748
articulations 501
bar numbers 527
chord symbols 575
dynamics 614, 615
lyrics 690
notes 381, 1039, 1042
ornaments 731
playing techniques 790
rehearsal marks 805
rests 859
rhythm dots 727
staccato 501
staves 916
systems 390
tempo marks 953
ties 966

horizontal position (continued)
time signatures 982
trills 731
tuplet numbers 1017
tuplet ratios 1017
tuplets 1007

horns
branch indicators 646, 649
fingerings 646, 649

hotkeys, See key commands
Hub 58

opening projects 61, 62
humanize

dynamics 637
hymnal-style repeat barlines 511
hyphens

lyrics 248, 694, 698–700
time signatures 991

I
illustrations

exporting 475
frames 340

image resolution 485
images

exporting 475
frames 340
inputting 340
videos 125

immediate dynamics, See dynamics
implicit rests 859, 860

colors 863
deleting 863
explicit rests 862
hiding 861, 863
showing 863
voices 861

Import Tempo Track dialog 73
important markers 251, 818
importing

expression maps 459
flows 63
MIDI files 69, 70, 1037
MusicXML files 66, 829, 1037
percussion kits 1021
percussion maps 464
tempo tracks 73
unpitched percussion 1037

inches
staff spacing 392
unit of measurement 57

indents 927
changing 927
first systems 927
staff labels 900
systems 390

Indian drum notation 1037
Indiana chord symbols 565
indicators

caret 622
fingerings 184, 649
horn branches 649
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indicators (continued)
string fingerings 651, 727
system fullness 383
thumbs 184
trill intervals 737, 741
voices 622

ingredients 477
initial pages

left-hand page 344
page numbers 344, 768

initial trill notes 742
input pitch

changing 149
inputting 143

accidentals 162
additional repeat endings 257, 259
altered bass note chord symbols 219
arpeggio signs 229, 231, 234
articulations 182, 183
automation 419
bar number changes 531
bar repeats 255, 256, 264
bar rests 165, 202
barline joins 516
barlines 201, 203, 206, 207, 516
bars 201–205
beats 202, 204, 205
braces 560
brackets 560
breath marks 225, 227, 228
caesuras 225, 227, 228
caret 146, 148
centered beams 544
chord symbols 141, 213, 216, 217
chords 132, 167
clefs 219–222
cues 268–271
divisi 932, 934
dynamics 208, 210, 212
empty pages 310
ensembles 85, 102
expressive text 208
fanned beams 552
fermatas 225, 227, 228
fingerings 184
flow heading changes 315
flow headings 320
frame breaks 357
frames 322
glissando lines 229, 231, 235, 236, 754
grace notes 167
inputting vs. editing 143
Insert mode 153
instruments 85, 95, 104
instruments in percussion kits 110
jazz articulations 229, 231, 237, 238
jazz ornaments 230, 232, 233
key signatures 186–189
lyrics 246, 248
markers 249, 250, 428
master page changes 314
master page sets 302
master pages 304

inputting (continued)
metronome marks 196, 200
microtonal accidentals 493
MIDI 176, 182, 419
mouse input 143, 151
nested slurs 874, 875
nested tuplets 1008
notes 145, 149, 153, 158, 176, 409
notes in multiple voices 159
notes in percussion kits 154, 155
notes on divisi staves 934
octave lines 219, 221, 223, 224
ornaments 229, 230, 232, 233
ossia staves 918
page number changes 311
pages 310
paragraph styles 368
pauses 225, 227, 228
pedal lines 238, 240, 243, 245
percussion kits 105
pick-up bars 191, 194, 195
player lists 655
players 95
playing techniques 238, 242, 243
position 143
register selection 151
rehearsal marks 249
repeat endings 254, 256–259
repeat markers 254, 256, 260, 261
rests 132, 158, 164
rhythm dots 149, 152
rhythm slashes 255, 256, 263
rhythmic feel changes 196, 440
rhythmic feels 441
rhythmic grid 144, 145
slash regions 255, 263
slash voices 160, 1045
slurs 265, 873–875
staves 914
stem direction 156
sub-brackets 560
sub-sub-brackets 560
system breaks 359
tempo equations 196
tempo marks 196, 198, 200, 423
text 265, 337
ties 132, 166, 971
time signatures 190, 191, 194, 195
timecodes 249
tremolos 255, 256, 261, 262
trills 230, 232
tuplets 169, 1008, 1009
unpitched percussion 409
upbeats 191
videos 127
voices 159, 160

Insert Flow Heading Change dialog 315
Insert mode 132, 153

activating 132
caret 146, 153
inputting notes 153
time signatures 507, 982
tuplets 1011
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Insert Pages dialog 310
insertion point 146
inserts 445
instrument change labels 902

hiding 902
showing 902

instrument groups 111
deleting 113
naming 112
percussion kits 111

instrument labels
percussion kits 112

instrument names 96, 895
alignment 97
changing 101
cues 602
numbering 103, 896
saving as default 97
staff labels 97, 896

instrument picker 85
instrument pitches, See instrument transpositions
instrument tracks 416

automation 418–421
collapsed 415
colored regions 415
controls 416
headers 416
piano roll editor 408
playing techniques 418

instrument transpositions 902
cue labels 602
hiding 903
showing 903
staff labels 97, 903

instrumental parts, See part layouts
instrumentation list 653
instrumentation lists 332

adding 655
instruments 30, 103

adding 85, 102, 104
adding staves 914
adding to flows 118
adding to parts 121
adding to percussion kits 110
arranging tools 283
assigning to endpoints 450
automatic numbering 103
brackets 60, 558, 559
changing existing 106, 110
chord symbols 577
clefs 584
combining into kits 105
cues popover 269
deleting 107
deleting staves 912
divisi 929, 930, 932
doubling 50, 104
dynamics 637
empty staves 351
endpoints 447, 448, 450
ensembles 102
expression maps 448
groups 31, 115

instruments (continued)
hiding 118, 121
inputting notes 149
key signatures 672, 673, 688
loading 404
MIDI 403, 404
MIDI recording 176
moving between players 107
muting 433, 434
names, See instrument names
non-sustaining 637
numbering 103
order 101, 115
order in percussion kits 113
part layouts, See part layouts
percussion 460, 1025
percussion legends 1031, 1032
percussion maps 448
Play mode 415, 416
playback 447, 451, 460
players 94
Players panel 83
removing from kits 114
removing from parts 118, 121
searching 85
showing 118, 121
showing staves 50
soloing 433, 434
staff grouping 60, 558
staff labels 97, 896–898, 903
staff size 909
staves 50, 912, 914, 916, 1025
sustaining 637
templates 59
tracks 414, 416
transposing 104, 123, 585, 684, 688, 903
VST 403, 404

interactive key commands map 54
interchangeable time signatures 983

specifying for individual bars 983
interface 33
interspersion

accidentals 490
intervals

add intervals popover 172
auto-save 79
chord symbols 214, 564
octave divisions 674
ornaments 730
transposing 172
trills 230, 737–739, 741

inverting 888
articulations 502, 503
beaming 541
fingerings 643
grace note stems 658
slurs 869, 870, 888
ties 980
tuplets 1014

ionian chord symbols 215, 578
irregular

bars as pick-up bars 986
time signatures 983
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italics
dynamics 613
fingerings 646, 648
lyrics 705

items 143, 273
changing 280
copying 284
editing 135
resetting 281
selecting 43, 143, 273, 274

J
Japanese

chord symbols 565
coda 831
segno 831

jazz
articulations, See jazz articulations
band templates 59, 60
chord symbols 565
glyphs 365
music font 365
staff grouping 60, 558

jazz articulations 759, 760
appearance 761, 763
bend 759
changing 763
default settings 761
deleting 764
duration 763
engraving options 761
handles 761
inputting 229, 231, 237, 238
length 761, 763
line styles 763
moving 761, 762
ornaments, See jazz ornaments
panel 238
playback 759
popover 231, 237
position 761, 762
smooth 759
types 231, 759, 763

jazz ornaments 760
inputting 230, 232, 233
popover 230
types 230

Jazz Standards chord symbols 565
job types 470, 480

page ranges 474
printing 480
selecting 480

joins
barlines 511, 515–517, 558, 562, 922
ossia staves 922
staves with barlines 516

JPEG files
graphics frames 340

jumps
inputting 260, 261
playback 837
repeat 830

justification
staves 349, 350, 391, 393, 916
systems 349, 350, 390, 391, 393
vertical 350, 391, 393

K
kerning 491
key clicks 790

inputting 238, 242, 243
key commands 11, 52

articulations 183
assigning 55
defining 51
finding 55
galley view 50
keyboard layouts 56
languages 56
maps 54
MIDI 56
muting 433, 434
page view 50
playback 431
removing 56
resetting 57
searching 54, 55
soloing 433, 434

key signatures 671, 981
accidentals 671, 677, 678
appearance 673
atonal 673
barlines 512, 684
cancellation style 673
cautionary 689
changes 512, 671, 684
changing 280
clefs 684
custom 675, 677, 681, 682
default settings 673
deleting 683
dialog 675, 678, 682
engraving options 673
enharmonic equivalent 688
filter 278
gaps 685
hiding 683
inputting 26, 186–189
instruments without 683, 688
major 672
minor 672
moving 686
multiple 684
none 673
octave divisions 674, 677
open 673
panel 187, 189
placement 684
playback 683
polytonality 188, 189
popover 186, 188
position 684
scales 672
signposts 281, 683
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key signatures (continued)
spacing 685
tonality systems 673–675
transposing 176, 687
transposing instruments 123, 139, 688
types 186, 672

Key Signatures, Tonality Systems, and Accidentals
panel 187, 189
key switches

expression maps 451, 452
percussion maps 460

keyboard shortcuts, See key commands
keyboards

inputting chord symbols 141
inputting notes 145
key command maps 54
layouts 56
MIDI 141

keys
major 672
minor 672
signatures, See key signatures

kits, See percussion kits
kneed beams, See centered beams

L
l.v. ties 970, 971
labels

cues 602, 603
divisi 937, 939, 940
instruments 97, 895, 896, 902
markers 814
ossia staves 922
percussion kits 904, 1025
staves 895, 940

laissez vibrer ties 970, 971
landscape orientation 483
lanes

automation 418, 419
playing techniques 417, 418

languages
key commands 54, 56

large
noteheads 713
selections 274
time signatures, See large time signatures

large time signatures 986, 988
bar numbers 529
vertical position 995

largo 950
inputting 196, 198, 200

latency
changing value 180
MIDI recording 176, 180

lattice arrangement
accidentals 490

layout cards 86
layout frame chains 327
layout names 96

changing 100
text tokens 332

layout numbers 86
order 124
renumbering 124

layout options 30, 90
bar numbers 519
changing 92
copying to other layouts 360, 362
dialog 90
saving as default 90

Layout Options dialog 90
layout selector 35

order of layouts 124
switching layouts 46

layouts 32, 93, 120
accidentals 163
adding flows 122
adding pages 310
adding players 121
bar numbers 526, 535
braces 559
brackets 559
cards 86
casting off 355
chord symbols 577
clefs 584
comparing 48
concert pitch 123
copies 472
copying formatting 360–362
copying frames 325
copying properties 363
creating 23, 121
deleting 124
deleting pages 310
divisi staff labels 938, 940
editing 308
empty pages 310
empty staves 351
enharmonic spelling 163
exporting 475, 480
file names 477
fit to paper 483
flow headings 318, 348
flows 93, 122, 330, 344
frame chains 326, 330, 331
frame order 330
frames 325
full scores 120
graphics files 475, 484
headers 655
hiding ossia staves 921
indents 927
justification 349, 350, 391, 393
keyboard 54, 56
margins 342, 348
markers 815, 818
master page sets 302, 303
master pages 301, 306, 314
multi-bar rests 865
multiple windows 20, 49
music frames 325, 326
MusicXML files 67
naming 122
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layouts (continued)
note spacing 381, 383
numbers, See layout numbers
opening 19, 37, 46
opening multiple 46, 48
order 124
orientation 343, 483
ossia staff labels 923
page numbers 765
page ranges 472, 480
page size 482
panel in Print mode 469
panel in Setup mode 86, 120
paper sizes 482
parts 120
percussion kit presentation 1026
player lists 655
players 93, 121, 331
playthroughs 535
printing 472, 480, 483
removing flows 122
removing page overrides 309
removing players 121
renumbering 124
repeat marker text 833
restoring 124
running headers 348, 655
scale size 483
selecting 35
settings 90
sorting 124
staff grouping 559
staff labels 899, 938
staff size 908
staff spacing 391, 393
switching 46
system dividers 924
system formatting 360
system justification 349
system objects 926
system spacing 391, 393
tabs 37, 46
time signatures 988, 997
timecodes 820, 821
transposing 104, 120, 123
vertical justification 350
view types 43

layouts card
disclosure arrows 41

Layouts panel 40
hiding 86
Print mode 468, 469
Setup mode 82, 86
showing 86

lead sheets
systemic barlines 512

ledger lines 708, 724
accidentals 489
hiding 725
width 724

left pages
starting from 344

left panel 40

legends
percussion 1031, 1034

length
arpeggio signs 234, 747
bar repeat phrases 280, 840
bar repeats 841
barlines 517
braces 561
brackets 561
cues 600
divisi passages 933
dynamics 617, 625
glissando lines 756
grace note slashes 661
hooks 783, 829
jazz articulations 761, 763
lyric extender lines 700
lyric hyphens 700
notated duration of notes 466
notes 157, 411, 466
octave lines 587, 590
pedal lines 779, 781, 783, 785
percussion legend names 1033
percussion legend ranges 1032
played duration of notes 466
repeat endings 825, 826, 829
slash regions 854
slurs 873, 876
staff labels 899, 937, 938
stems 942, 947
system dividers 925
tempo marks 954, 956, 964
trills 732, 736
tuplet brackets 1012

lento 950
inputting 196, 198, 200

letter paper sizes 482
level changes for pedal lines 772, 774–776

handles 772
levels

channels 443
nested tuplets 1008

lifts
jazz articulations 231, 237, 238, 759
pedal lines, See pedal retakes

light swing 438
line numbers 701

changing 702, 703
lines

arpeggio signs 745
barlines 509
divider arrows 936
drawing 423
enclosures 523, 807
fingerings 651
glissando 753, 754, 757
grace note slashes 660
gradual tempo changes 964
jazz articulations 759, 763
ledger 724
lyric extender 698–700
lyrics 690, 701
octave lines 586
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lines (continued)
pedal 771
playback 430
repeat marker text 833
secondary beams 548
slurs 890
staves 906, 911
string shift indicators 651
system dividers, See system dividers
tempo marks 421, 963
text 376
thickness 299
ties 977, 978
trills 735, 736
wiggly 735, 745

linking
dynamics 279, 633–635
flow names 119
flow titles 119
groups of dynamics 632
music to frames 329
percussion maps to VST/MIDI 450
slurs 279, 876, 877

lists
players 332, 655

loading
video files 127

locations
auto-save folder 79
backups folder 80

lock
duration, See lock to duration
frame 292
system 292

lock to duration 132, 174
activating 132

loco 221
inputting 223, 224

locrian chord symbols 215, 578
lower case

flow titles 334
repeat marker text 831
Roman numerals 334

lower notes
trills 744

lydian chord symbols 215, 578
lyric extender lines 694, 698

handles 698–700
moving 699

lyric hyphens 694, 698
handles 698–700
moving 699

lyric lines
changing 702, 703
deleting 701
numbers 701
placement 696
position 696

lyricist 90
default master pages 653
text tokens 332

lyrics 690
alignment 690, 698
appearance 691
changing 693, 695, 702
chorus 247, 692, 693, 702
cues 605
default settings 691
deleting 701
East Asian elision slurs 707
engraving options 691
extender lines 248, 694, 698–700
filters 278, 691, 692
font styles 704
handles 698–700
hyphens 248, 694, 698–700
inputting 246, 248
italics 705
line numbers 701–703
lines 247, 690, 692, 701
melismatic 246, 248, 695, 698
moving 697
note spacing 690
placement 690, 695
popover 246–248
position 690, 691, 695
selecting 273, 692
size 704
spacing 697, 698
staff-relative placement 703, 704
syllable types 248, 694
translations 247, 692, 693, 702
types 247, 692, 694
verse numbers 705, 706

M
macOS

printing 474
major

chord symbols 214
keys 672
scales 672

make into
frame 292, 357
system 292, 359

maps
expression 451
key commands 54
percussion 460

marcato 497
inputting 182

margins
changing 342
flow headings 315, 346
music frames 348
MusicXML files 66
pages 342
tacets 354

markers 814
appearance 814
default settings 814
deleting 283
dialog 250
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markers (continued)
engraving options 814
filter 278
font style 816
hiding 818
important 251, 818
inputting 249, 250, 428
moving 816, 817
panel 250
position 814
repeats 254, 830
showing 818
staff 815
staff spacing 393
text 250, 815
timecodes 250, 817, 821
track 427
vertical position 393, 814, 815, 820

marks
rehearsal, See rehearsal marks
tempo, See tempo marks
trills 729, 731, 734

marquee tool 42
using 43

master output volume 443
master page editor 306

opening 307
master page overrides

deleting pages 310
master page sets 302

applying 303
creating 302
deleting 303
flow headings 302, 318, 320
naming 303

master pages 301, 304
adding new 304
assigning to pages 314, 345
copying layouts 307
dedications 654
deleting 306
editing 306, 307
flow headings 318
frame chains 326, 329
frame constraints 340
frames 322, 323
music frames 325
naming 305
overriding 308, 309
page numbers 765, 766
panel 295
removing changes 314
removing flow heading changes 317
running headers 655
sets 302
text alignment 338, 339
types 304

measured tremolos 999
measurement

units 57
measures, See bars
medium swing 438
melismatic lyrics 248, 695, 698

merging
players 63, 66, 69
voices 286

messa di voce 624
moving 631

meter 981
beam grouping 539, 553, 554
changing 280
channel levels 443
irregular 506, 507
meterless time signatures 982
note grouping 553
open 983, 990
rest grouping 553
time signatures 983
tremolos 999
tuplets 1007

metric modulation
tuplets 1010

metronome marks 960
appearance 958, 959
beat units 280, 960
changing 280, 960
click 179
components 958, 959
equations 198, 965
fonts 951
hiding 957
inputting 196, 200
multiple positions 925
parentheses 958
playback 179, 446, 961
popover 196
range 961
selecting 273
showing 957
size 951
values 280, 960
vertical positions 925

microtones 492, 675
accidentals 677
custom tonality systems 675
EDO 674
inputting 493
key signatures 681
octave divisions 677
playback 683
transposing 172
trills 738

mid-system gaps
codas 830, 835

middle line
stem direction 943, 945

MIDI
accidental spelling 164
automation 418–420
channels 443, 448
commands 52, 56
controllers, See MIDI controllers
deleting 421
devices, See MIDI devices
dialog 70–72
editing 420
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MIDI (continued)
endpoints 447, 450
exporting 75
expression maps 451, 452, 457
fader 443
files, See MIDI files
inputting 419
instruments 403, 416
See also MIDI instruments
lanes 418
loading instruments 404
markers 427
navigation 56
note input 145, 164
note range 103
pan 443
percussion maps 450, 460, 463
piano roll editor 408
playback 416, 447, 460
ports 448
quantization 71
range 103
recording, See MIDI recording
respelling 164
slurs 893
tempo 421, 435
tempo tracks 73, 75
thru 176
time track 421
volume 638

MIDI controllers 638
automation 418, 419
dynamics 638
pedal lines 788

MIDI devices 182
chord symbols 141, 213, 217–219, 425
disabling 182
enabling 182
expression maps 451, 457
navigation 141
note spelling 141
percussion kits 155
percussion maps 460, 463
playback templates 436
polychords 218
settings 141

MIDI files 69
dialog 70, 72
exporting 72
importing 69, 70, 1037
opening 61
pedal lines 181
playback overrides 467
quantization 69, 71
repeats 436
requantizing 178
sustain pedal controllers 181
unpitched percussion 1037

MIDI Import Options dialog 70
MIDI Input Devices dialog 182
MIDI instruments 403

loading 404
MIDI Quantize Options dialog 71

MIDI recording 176
audio buffer size 180, 181
click settings 179
count-in 180
devices 182
See also MIDI devices
dialog 71
input pitch 149
latency 180
optimization 180
pedal lines 181
pitch 149
quantization 71, 176
repeats 178
requantizing 178
retrospective recording 178
setup 180
starting 176
stopping 176
sustain pedal controllers 181
tempo mode 435
time signatures 176
transport window 446

MIDI thru 176
millimeters

staff spacing 392
unit of measurement 57

mini transport 34, 35
minims 9, 134
minor

chord symbols 214
keys 672
scales 672

mixer 443
channel strips 445
hiding 445
hiding audio outputs 448
mute states 434, 443
muting tracks 432
ports 443
resetting 434
showing 445
solo states 434, 443
soloing tracks 432
soundtracks 129
videos 129
volume 434
window 33

mixolydian chord symbols 215, 578
mock-ups

exporting 76
modal chord symbols 215, 578
moderato 950

inputting 196, 198, 200
Modernist accidental duration rule 496
modes 17, 29

chords 146, 578
Engrave 290
full screen 50
functions 17
Insert 146, 153
Play 400
Print 468
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modes (continued)
Setup 82
switching 17
tempo 435
toolbar 14
Write 131

modifier keys
key commands 54
searching 54

modulation wheel dynamics 638
molto

dynamics 208, 210
tempo marks 196, 198

monochrome graphics 478
moon noteheads 714
mordents 729

intervals 730
motors 238, 790

inputting 242, 243
mouse input 143

activating 132, 151
deactivating 132, 151
settings 143

movements 31, 117
adding 22, 118
exporting 64, 65
flow headings 318
importing 63
multiple on pages 344
splitting 289
tacets 352

movies, See videos
moving

arpeggio signs 749
articulations 501
automation events 420
bar numbers 527, 529
bar repeat counts 846
bar repeats 841
bar rests 866
barlines 513, 514
cancellation naturals 686
caret 148, 169
chord symbols 575, 576
clefs 581, 582
cue labels 604
cues 597, 599
divisi 933
dynamics 616–618, 631
extra staves 915
fingerings 642
flow headings 346, 396
frames 323
glissando lines 756
grace note slashes 661
grace notes 724
instruments between players 107
jazz articulations 761, 762
key signatures 686
lyric extender lines 699
lyric hyphens 699
lyrics 697
markers 816, 817

moving (continued)
MIDI data 420
notes 286, 381, 388, 389, 410, 544, 724, 1023
octave lines 589, 590
ornaments 731, 732
ossia staves 918
page numbers 766
pauses 668, 669
pedal lines 778, 779
playhead 431
playing techniques 791, 792
rehearsal marks 809, 810
repeat endings 826
repeat markers 835
rests 381, 866
rhythm dots 727
rhythm slashes 852
slash region counts 857
slash regions 854
slurs 873, 875, 881, 882
staves 396
systems 396, 397
tabs 49
tempo marks 424, 954
text 373
time signatures 992–994
tremolos 1003
trills 732
tuplets 1010
view 43

MP3 files
exporting 76

multi-bar rests 864, 865
appearance 862, 866
bar numbers 526
end of flows 866
formatting 378
hiding 865
numbers 378
showing 865
symbols 378
tacet al fine 866
tacets 352, 353

multi-note tremolos 999
appearance 1004
deleting 1002
inputting 261, 262
moving 1003
popover 255
speed 1001
types 255

multi-pasting 285
multi-rests, See multi-bar rests
multi-segment slurs 878, 880
multi-staff instruments 913

adding staves 914
cross-staff beams 544
cross-staff slurs 873
cues popover 269
deleting staves 912
hiding staves 351, 393
width 916

Index
 

1089
Dorico 2.2.20



multiple
codas 831, 832
cues 607
flows on pages 344
movements 117
segnos 831, 832

multiple-voice contexts 1039
articulations 499
cues 607
dynamics 622
fermatas 666, 670
grace notes 658, 870
inputting notes 159
note alignment 1039
notes 1043
ornaments 731, 733
rests 859, 861
rhythm dot consolidation 725, 726
slashes 851, 852
slurs 870
stem direction 658, 943, 1043
ties 980
voice column index 1042

music
arranging 283
assigning to frames 329
editing 143
fixing into frames 357
fixing into systems 359
symbols, See music symbols

music area 15, 38
event display, See event display
flow heading editor 318
making selections 274
master page editor 306
moving music 43
multiple windows 49
opening layouts 37, 46
page arrangements 44
panels 18
selecting views 50
zoom options 45

Music Fonts dialog 365
music frame chains 326

assigning to frames 329
flows 330
layout 326, 327
master page 325, 326
players 331
propagating part formatting 360, 362
selectors 328
unlinking frames 329

music frames 325
flows 330
frame chains 326, 329
inputting 322
layouts 326
margins 348
master pages 325
order 330
overrides 325
padding 348, 349
players 331

music frames (continued)
selecting 324
selectors 328

music symbols 378
dialog 378
editing 378

MusicXML
chord symbols 579
dialog 67
exporting 67
importing 66
opening 61
pedal lines 789
percussion 1037
repeat endings 829
resetting beaming 540
staff labels 896

muted noteheads 713
mutes 790

hiding 795
inputting 242, 243
techniques 238

muting
deactivating 434, 443
instruments 433
items 434
notes 278, 434
tracks 432, 443

N
names

drum sets 107
flow headings 321
flows 119
instruments 96, 97, 101
layouts 96, 100, 122
master page sets 303
master pages 305
noteheads 709
percussion kits 107
player groups 115, 116
players 96, 100
staff labels 96, 101

naming schemes
file names 477

Nashville
chord symbols 214, 565
numbers 213

naturale 790
hiding 795
inputting 238, 242, 243

naturals
hiding 489
inputting 162
parentheses 489
showing 489

navigation
caret 148
chord symbols popover 216
fingerings popover 184
frames 324
handles 298, 324, 389, 396
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navigation (continued)
lyrics popover 248
note input 149, 151
print preview area 39
rhythmic grid 144

nested
slurs 874, 875
tuplets 1008

nested slurs
endpoints 872

new projects
starting 59
templates 58, 59

New York chord symbols 565
niente hairpins 622

changing 622
circle 622
inputting 208, 210, 212
styles 622
text 622

no chord symbols 215
non-drop frame timecodes 819
non-power of two time signatures 983
non-sustaining instruments 638
non-transposing layouts 123
nontuplets 1007
notated duration 466

played duration 466
requantizing 178

notation options 30, 139
barlines 511
beaming 539
changing 141
dialog 139
percussion kits 1021
rests 862
saving as default 139
voices 1040

Notation Options dialog 139
notation reference 487
notations

appearance 135, 298, 299
changing 280
copying 284, 285
cues 595, 605
editing 298
inputting 182
percussion kits 1023
position 298, 299
properties 135, 136
selecting 43, 273
settings 90, 92, 139, 299
stacking order 594
tucking index 594
zoom options 45

Notations panel 131, 139
Notations toolbox 137
notches

octave lines 588
note durations 134, 466

changing 157
forcing 158
hiding 134

note durations (continued)
quantization 71
rhythm dot consolidation 726
selecting 157
showing 134
tempo equations 197

note grouping 553
changing 158
hemiola 158
meter 553, 554
pick-up bars 986
ties 166

note input 145, 149, 409
adding notes 171
caret 146, 148
chord input 146
chords 167
grace notes 167
input pitch 149
inputting vs. editing 143
Insert mode 146
lock to duration 174
MIDI 176, 178, 180
mouse input 151
muting notes 278
options 30
percussion kits 154–156
pitch 149
playing notes back 278
register selection 151
repitching notes 174
rests 860
retrospective recording 178
rhythmic grid 145
starting 148
stem direction 156
ties 166
tuplets 169
voices 159

Note Input Options dialog 141
note spacing 291, 381, 384

activating 291
barlines 514
changing 381, 385, 388
copying to other layouts 362
default 383
deleting changes 387
dialog 386
filter 278
fullness 383
galley view 43
grace notes 658, 659
handles 382
justification 383
layout options 90, 384
lyrics 690
resetting 387
reverting 391
signposts 281, 381
systems 383

Note Spacing Change dialog 386
note spacing handles

selecting 389
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note spelling
disabling respelling 141

note values, See note durations
note velocities

MIDI import 70
notehead sets 710, 711

custom 716
designs 711, 714
dialog 716
ledger lines 725
pitch-dependent 714
scale degree 714
types 710

noteheads 711
aikin 714
arrows 712
articulations 502, 503
attachment points 716, 719
changing 708, 709, 722
circular 711
crosses 711
custom 715, 719
default design 708
designs 711, 714–716, 719, 722
See also notehead sets
dialog 716, 719
diamond 711, 713
dotted 714
editing 719
five-line staff 1029
funk 714
large 713
ledger lines 725
moon 714
muted 713
note names 709
percussion 1027, 1029, 1031
pitch-dependent 714
playing technique-specific 1027, 1030
playing techniques 1027, 1029
rectangular 714
sets, See notehead sets
shapes 709, 711, 714, 715, 719
slashes 849, 1044
square 714
staccato position 501
stemless 948
time signatures 990
triangular 712
types 711
unpitched percussion 1027, 1029
walker 714
wedges 712

NotePerformer
microtonal playback 683
trills 743

notes 708
accidentals 134, 162, 163
add intervals popover 172
adding to existing notes 171
alignment 616
appearance 135, 708
arpeggio signs 748

notes (continued)
articulations 134, 498, 500
auditioning 278, 279
auxiliary 740
beaming 537
brass fingerings 649
changing 174
chords 167
colors 1041
copying 284, 285, 498
crossing to other staves 286, 544
cues 595, 607
custom scale size 723
default settings 708
deleting 283, 412, 1002
dotted 152, 553
drum editor 410
durations 134, 157, 411, 466
dynamics alignment 615, 616
editing 132, 135, 298
engraving options 708
enharmonic spelling 163
filters 278
fixing duration 158
flags 378
fonts 365
formatting 378
ghost 1023
grace notes 167, 657
grouping 553
hiding 852
hiding ledger lines 725
hiding stems 948
horizontal spacing 382
horn branch indicators 649
inputting 24, 145, 149, 152–154, 158, 167, 409
Insert mode 153
jazz articulations, See jazz articulations
ledger lines 724, 725
length 157, 411
lock to duration 174
lyric alignment 698
middle line 945
moving 286, 381, 388, 389, 410, 544, 724, 1010,
1023
moving to other instruments 1023
multiple-voice contexts 1043
muting 434
notated duration 466
note spacing 383, 385, 388, 389
notehead designs 711, 715, 716, 719
notehead sets 710
order 1042
overrides 466, 467
parentheses 1023
pasting into voices 284
percussion kits 154, 1036
piano roll editor 408–412
pitch 173, 174
pitch-dependent noteheads 714
Play mode 409
playback 451
played duration 466, 467
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notes (continued)
properties 136
register 151, 173, 174
removing stem direction changes 947
repitching 174
requantizing 178
rests 860
rhythm dots 152, 725–727
rhythm slashes 1044
rhythmic grid 144
scale size 723
secondary beams 548
selecting 43, 273
showing 852
size 723
slash regions 852
slashes 849, 1044
slurs 134, 872
spacing 381
spelling 163, 164
staff spacing 393
stem direction 287, 943, 946, 1036
stem length 947
stemlets 550
stems 948
string fingerings 651, 727
swapping 286
symbols 378
terminology 9
ties 166, 500, 970, 971
time signatures 990
transposing 172–174, 176, 412, 687
tremolos 1000, 1002–1004
trill intervals 739
trills 734
tuplets 1007, 1009
types 134
unbeaming 538
unscaling 1010
voices 159, 287, 288

Notes panel 131, 134
showing more note durations 134

Notes toolbox 132
scissors 972

November music font 365
numbers

backups 80
bar repeats 842, 843
bars 519, 530
beam lines 548
fingerings 650
instruments 103
layouts 124
pages 312, 765, 767
rhythm slashes 856
slash region counts 855
slur segments 878
staff labels 899
time signatures 989
tuplets 1016
verses 705, 706

numerators
styles 988, 989
time signatures 981, 982

O
octatonic chord symbols 215
octave divisions 674

custom 677
EDO 674
playback 683
tonality systems 675, 677

octave lines 586
alignment 591
angles 588, 589
appearance 587
default settings 587
deleting 592
Engrave mode 593
engraving options 587
filter 278
formatting 378
handles 587, 590, 593
hooks 593
inputting 219, 221, 223, 224
length 587, 590
moving 589, 590
panel 224
placement 594
popover 219, 221, 223
position 587, 589, 591, 594
selecting 273
stacking order 594
staff-relative placement 592
symbols 378
tucking index 594
types 221, 586

octave transpositions 173
clefs 220, 580
cues 596, 598, 599
octave lines 221, 586

octuplets 1007
odd-numbered layouts

booklets 481
printing 472, 481

offsets
playing techniques 790
resetting 281
timecodes 126, 820
videos 126
voice columns 1042

omissions
chord symbols 214

open
key signatures 673
meter 990
style 990
time signatures 191, 983

opening
auto-saved files 78
files 61, 78
flow heading editor 319
layouts 19, 46
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opening (continued)
master page editor 307
MIDI files 61
mixer 445
MusicXML files 61
projects 59, 61, 62, 78
tabs 19, 46
templates 13, 59
video window 128
windows 20, 49

optical spacing
cross-staff beams 546

options
engraving 299
layout 90
notation 139
note input 141
page sizes 483
playback 405
preferences 51
text formatting 266, 371
toolbar 34
transport 34, 35
workspaces 34, 35
zoom 42, 45

options dialogs 30
orchestral

order 101, 115, 124
staff grouping 60, 558
templates 59, 60

orchestrating, See arranging
order

accidentals 490, 671
articulations 500
frame chains 326, 329, 330
instrument numbering 103
instruments in percussion kits 113
key signatures 671
layouts 124
notes 1042
orchestral 115
players 101
rehearsal marks 811
repeat markers 832
score 101
tabs 48
voices 139, 1042

orientation
changing 343
exporting 483
landscape 483
portrait 483
printing 472, 483

ornaments 729
acciaccaturas 657
accidentals 730, 741
alignment 731
appoggiaturas 657
changing 280
cues 605
default settings 729
deleting 283
engraving options 729

ornaments (continued)
filter 278
formatting 378
handles 732
inputting 229, 230, 232, 233
interval 730
jazz 760
See also jazz articulations
length 732, 736
moving 731, 732
panel 232, 233
placement 731
popover 229, 230, 232
position 729, 731
selecting 273
slurs 733
staff-relative placement 733
symbols 378
trills, See trills
types 230

Ornaments panel 233, 234, 236
ossia staves 917

adding 918
barlines 922
deleting 921
hiding 921
moving 918
padding 919
playback 917
preamble 920
showing 921
signposts 917
size 919
staff labels 922, 923
staff spacing 393
system objects 926
vertical spacing 391, 393

output
audio 51

output channel
mixer 443

outputs
mixer 448
plug-ins 448

overdubbing
MIDI recording 178

overlapping
accidentals 490
articulations 502
barlines 517
braces 560, 561
brackets 560, 561
cues 607
slash regions 851
slurs 892
text 375
ties 966

Override Percussion Noteheads dialog 1029
overrides

chord symbols 566, 572
flow headings 309, 318
master pages 308, 309, 331
music frames 325
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overrides (continued)
note duration 466, 467
paragraph styles 373
playback templates 436, 437
removing 339, 467
swapping 317
text 331, 373

P
padding

bar numbers 523
dynamics 620
enclosures 523, 807
frames 338, 342
music frames 348, 349
ossia staves 919
playing techniques 794
rehearsal marks 807
rests, See padding rests
text 338, 377

padding rests 608, 859
cues 608
hiding 608, 853
slash regions 853

page arrangements 43, 44
page breaks, See frame breaks
page layouts 342

bars per system 355
casting off 355
copying 398
dedications 654
divisi 929, 930
empty staves 351
fixing 355–357
flow heading changes 317
formatting 302, 308
frame constraints 340
left pages 344
make into frame 357
make into system 359
master page changes 314
master page sets 302, 303
moving systems 397
multiple flows 344
page size 343
staff spacing 375, 391, 393, 398
system spacing 393
systems 356, 390
tacets 353
text collision avoidance 375

page margins 342
changing 342, 348, 349

Page Number Change dialog 312
page numbers 312, 765

appearance 766
changing 311, 312
count 334
flow headings 348, 768
flows 334
font styles 766
hiding 348, 768, 769
horizontal alignment 766

page numbers (continued)
initial 344, 768
moving 766
numeral style 312, 767
paragraph styles 766
position on page 766
removing changes 313
sequence changes 311, 312
showing 348, 769
size 766
tokens 334
total 334

page ranges
exporting 474
printing 474
selecting 480

page size 482, 483
changing 343
layout options 90
MusicXML files 66

page turns 356
first page on the left 344

page view 43
arrangements 44
changing to 50
flows 289

pages
adding 310
arrangements 44
assigning flow headings 315
assigning master pages 314
changing view 50
deleting 309, 310
editing 308, 309
exporting 480
flow headings 318
formatting 653
frames 322, 323, 330, 340
layouts 301, 306, 342, 355, 356
making from selection 357
margins 342, 348, 349
master pages 301, 306, 314, 342
multiple flows 344
numbers, See page numbers
order 330
orientation 343
panel 295
printing 480, 483
ranges 480
setup 483
size, See page size
staff spacing 398
swapping 317
templates 301, 306, 318
text tokens 332
total number 334
view options 42

Pages panel 290, 295
pan 443
panels 16, 40

accidentals 189
arpeggio signs 234
bar repeats 256
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panels (continued)
barlines 203, 207
bars 203, 204
clefs 221, 222, 224
cues 269–271
dynamics 210, 212
Engrave mode 290
flows 82, 89
formatting 292
glissando lines 236
hiding 18, 35, 41
holds 228
jazz articulations 238
key signatures 187, 189
layouts 82, 86, 469
MIDI instruments 403
notations 139
notes 134
octave lines 224
ornaments 232–234, 236, 238
pages 295
pauses 228
pedal lines 241, 245
Play mode 400
players 82, 83
playing techniques 241, 243, 245
Print mode 468
print options 470
properties 135, 298
repeat endings 256
repeat markers 256
rhythm slashes 256
Setup mode 82
showing 18, 35, 41
tempo 198, 200
time signatures 192, 195
tonality systems 189
tremolos 256, 262
VST and MIDI Instruments 402
VST instruments 403
Write mode 131, 134, 135, 139

paper
duplex printing 481
orientation 483
size 343, 482, 483

paragraph styles 363, 366, 519
bar numbers 519, 521, 525, 533
creating 368
deleting 369
dialog 366
divisi staff labels 937
inputting text 265
overrides 373
page numbers 766
repeat markers 831
resetting 373
saving as default 366
staff labels 897
tacets 352
text frames 373

Paragraph Styles dialog 366
parent styles

paragraph styles 366, 368

parentheses
accidentals 489, 495
bar repeat counts 844
dynamics 619
fingerings 184, 648
ghost notes 1023
metronome marks 958, 959
octave line numerals 586
pedal continuation signs 786
percussion notes 1023
slash region counts 857
string shift indicators 727
tempo marks 958, 959
time signatures 191, 194, 991
trills 729

part formatting 360–362
system formatting 360

part layouts 32, 86, 120
accidentals 163
adding flows 122
adding players 121
bar numbers 519, 521, 525, 526, 535
clefs 584
concert pitch 123
copying formatting 360–362
copying frames 325
copying properties 363
creating 121
deleting 124
divisi 929, 930
divisi staff labels 938, 940
dynamics 618
enharmonic spelling 163
exporting 475
file names 477
flow headings 318, 346
flows 122, 330, 345
flows on pages 344
formatting 360, 362
frame chains 326, 330, 331
frames 325
hiding ossia staves 921
indents 927
instrument change labels 902
justification 349, 350, 391, 393
Layouts panel 86
left pages 344
margins 342, 348
markers 818
master page sets 303
master pages 301, 304, 345
multi-bar rests 526, 865, 866
music frames 325
names 96
note spacing 383
opening 46
orientation 343
ossia staff labels 923
player lists 655
players 121, 331
playthroughs 535
printing 472
propagating layouts 360, 362
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part layouts (continued)
removing flows 122
renumbering 124
repeat marker text 833
restoring 124
staff labels 899, 938, 940
staff size 908
staff spacing 350, 375, 391, 393
switching 46
system dividers 924
system formatting 360
system justification 349
system spacing 391, 393
tacet al fine 866
tacets 352–354
text collision avoidance 375
time signatures 997
transposing 123

part names 96
changing 100

partial beams 538
partial hiding

barlines 377, 619, 794
erased backgrounds 377, 619, 794

parts, See part layouts
pasting, See copying
patches

endpoints 447
playback 447, 451, 460

pauses 664
appearance 280
barlines 670
breath marks, See breath marks
caesuras, See caesuras
changing 668
default settings 666
deleting 283
duration 280
engraving options 666
fermatas 664, 670
filter 278
formatting 378
inputting 225, 227, 228
linked 668
moving 668, 669
multiple at same position 667
panel 228
playback 664
popover 225, 227
position 666
selecting 273
single staves 668
staff-relative placement 666, 669
symbols 378
types 225, 664

PDF files 484
color 478
exporting 475
fonts 479
layout numbers 124

pedal level changes 772
adding 240, 243–245
changing 774–776

pedal level changes (continued)
end level 776
removing 777
start level 774

pedal lines 771
alignment 777
appearance 782, 784, 787, 788
changing 280
continuation lines 771, 782, 784, 785
dashes 785
default settings 781
deleting 283
duration 788
Engrave mode 772
engraving options 781
filter 278
formatting 378, 782–785
gaps 785
grace notes 780
handles 772, 779, 783
hooks 782, 783
inputting 238, 240, 243, 245
length 779, 781
levels, See pedal level changes
lifts 772
MIDI import 70, 181
MIDI recording 181
moving 778, 779
MusicXML import 789
muting in playback 434
order 777
panel 241, 245
parentheses 786
percussion 790
playback 788
popover 240, 243
position 777, 780, 781
releases 782
removing retakes 777
retakes, See pedal retakes
signposts 281
staff-relative placement 777
start signs 781, 782, 786
symbols 378
text 786–788
thickness 785
types 240, 771

pedal retakes 772
adding 240, 243–245
handles 772
pedal level 775
removing 777
types 774

percussion 1019
default settings 1021
drum sets 1020
engraving options 1021
kits, See percussion kits
legends 1031, 1032
note input 409
noteheads 1027
playing techniques 465
tremolos 465
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Percussion Instrument Playing Techniques dialog 1027
percussion kits 1019, 1020

adding instruments 110
caret 154
changing instruments 110
creating 105, 110
drum sets 107, 111, 1020, 1034
dynamics 1025
editing area 107, 1025
exporting 1020
five-line staff 906, 1025
gap sizes 114
grids 111–114, 1025
groups 111–113
importing 1021
individual instruments vs. kits 1019
instrument order 113
legends 1031
moving notes 1023
naming 107, 112
notation options 1021
notations 1023
note input 156, 409
playing techniques 1022
presentation types 107, 1019, 1025, 1026
removing instruments 114
rests 139
rhythm slashes 1045
single-line instruments 1025
spacing 114
staff labels 107, 904, 1025
staff-relative legend placement 1034
staves 107, 1019, 1025, 1026
stem direction 107, 139, 156, 1034, 1036
stickings 1024
voices 139, 1034, 1035

percussion legends 1031
adding 1032
changing 1033
handles 1032
instrument names 1033
length 1032, 1033
position 1021
ranges 1031, 1032
signposts 281, 1031
sounding instruments 1032
staff-relative placement 1034
text 1034
types 1031, 1033

percussion maps 460
creating 463
custom 463
dialog 460
endpoints 447, 450
exporting 464
importing 464
linking 450

Percussion Maps dialog 460
percussion stickings 1024
performance instructions 653
Petaluma music font 365
phrases

bar repeats 280, 840

phrygian chord symbols 215, 578
piano

dynamics 208, 210, 212, 613
level changes 772, 777
pedal lines 771, 772
playback 788
retakes 772, 777
substitution fingering 640

piano roll editor 408
changing note durations 466
deleting notes 412
event display, See event display
inputting notes 409
instrument tracks 416
moving notes 410
note length 411
played vs. notated durations 466
slurred notes 893
tracks 414
transposing notes 412
zoom 413

pick-up bars 983, 985
deleting beats 202, 504, 505
inputting 191, 194, 195
turning bars into 986

pictures
frames 340
inputting 340
videos 125

pitch
accidentals 163, 488
add intervals popover 172
changing 173–175
clefs 222, 580
concert 123
cues 602
input 149
jazz articulations 759
key signatures 671
microtonal 492, 673
note input 151
noteheads 709, 710, 714
notes 174
octave lines 223, 224, 586
playback 435
transposed 123
trills 739, 741, 742, 744

pizzicato 790
hiding 795
inputting 238, 242, 243

placement
articulations 502, 503
breath marks 667
caesuras 667
changing 280
clefs 581
cues 595
dynamics 614
fermatas 667
fingerings 639
glissando lines 753
grace notes 658
lyrics 690, 695
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placement (continued)
octave lines 594
order 594
ornaments 731
pauses 666
pedal lines 777
playing techniques 791, 793
rehearsal marks 805
rests 859
slurs 869, 872
tempo marks 953
ties 966
time signatures 982
tremolos 1001
tucking index 594
tuplets 1007
voices 1039

Play mode 17, 400
channel strips 445
deleting notes 412
drum editor 409
Endpoint Setup dialog 448
event display 407
exporting expression maps 459
expression maps 451, 456
inputting notes 409
loading instruments 404
mixer 443, 445
moving notes 410
note durations 411, 466
overrides 467
panels 40, 400, 402
percussion maps 460
piano roll editor 408
playback 405, 431
playhead 430
switching 400
toolboxes 400, 401
tracks 414, 429
transport 35, 446
unpitched percussion 1036
whitelisting VST 2 plug-ins 404
window elements 400
zooming 413

Play toolbox 401
playback 431, 803

accidentals 683
arpeggio signs 750–752
articulations 503
audio buffer size 180, 181
bar repeats 840
channel strips 445
chord symbols 425, 427
chords 279
click 446
custom tonality systems 683
default settings 437
default tempo 950, 957
divisi 940
dynamic curve 637
endpoints 447, 448, 450
exporting audio 76
expression maps 451, 452

playback (continued)
fader 443
fast-forwarding 431
fixed tempo 435
follow tempo 435
hidden staves 912
hiding notes 852
instruments 451, 460
jazz articulations 759
line 430
metronome 446
microtones 683
mixer 443, 445
multiple windows 49
muting 432–434
note durations 466
notes 278, 279
number of times played 837
options 405
ossia staves 917
overrides 467
patches 447
pauses 664
pedal lines 788
percussion 450, 460, 1027, 1029
playhead 430
playing techniques 456, 458, 801, 803
playthroughs 837
plug-ins 443
pre-roll 435
preferences 51
recording notes 178
repeats 436, 837
resetting volume 434
rewinding 431
rhythmic feel 441
selections 431
silence playback template 436
slash regions 852
slurs 893
soloing 432–434
starting 431
swing 438–441
templates 403, 437, 448
tempo 446, 960–962
tempo equations 965
tremolos 1005
trills 742–744
tuning 435
volume 434, 443

playback options 30, 405
dialog 405
dynamics 637
pedal lines 788
repeats 436
saving as default 405
slurs 893
swing playback 439
timing 503, 750
tremolos 1005
trills 742

Playback Options dialog 405
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playback templates 436
changing 437
metronome click 179
overriding 436
resetting 437

played duration 466
changing 466, 467
notated duration 466
overrides 466, 467

player cards 83
disclosure arrows 41

player groups 31, 83, 115
adding players 116
creating 115
deleting 116
moving players 117
naming 116
removing players 117

player names 96
changing 100
Play mode 415
player tracks 415
text tokens 332

player tracks 415
colored regions 415

players 31, 93, 94
adding 22, 102, 104, 116
adding ossia staves 918
adding staves 914
adding to flows 118
cards 83
clefs 584
copying 96
deleting 102, 107, 116
deleting staves 912
divisi 929, 930, 932
duplicating 96
editing divisi changes 933
empty staves 351
ensembles 83, 102
extra staves 913
filters 331
flows 93, 118
frame chains 328, 331
groups 31, 82, 83, 115, 116
hiding 118, 121
importing 63
instrument change labels 902
instrument names 101
instruments 30, 50, 103, 104, 106
layout names 100
layouts 93, 121
lists 332, 655
merging 63, 66, 69
moving between groups 117
moving instruments between 107
multiple instruments 50, 104
muting 433, 434
naming 96, 100, 101
numbering instruments 103
ossia staves 917
panel 82, 83
part layouts 120

players (continued)
percussion kits 105
player names 100
position in score 101
removing from flows 118
removing from groups 117
section players 83, 94, 95
showing 118, 121
solo players 83, 94, 95
soloing 433, 434
staff labels 896
staff size 909
staves 912, 914
swing playback 440
text tokens 332
unison ranges 934, 935

Players panel 82, 83
hiding 83
showing 83

playhead 430
fast-forwarding 431
moving 431
playback 431
position 431
repeats 436
rewinding 431
transport 446, 447
zooming 413

playing technique-specific noteheads 1027, 1029
appearance 1031
articulations 465
creating 1030
playback 465

playing techniques 790
adding text 793
attachment points 798
backgrounds 794
changing 280, 1022
combinations 456, 458, 465
continuation styles 790
creating 1030
cues 605
custom 795, 796, 803
default settings 790
deleting 283
design 796, 798
dialog 798, 801
divisi 929
editing 798
engraving options 790
erased backgrounds 794
expression maps 451, 803
filter 278
hiding 795
horizontal offset 790
inputting 238, 242, 243
lanes, See playing techniques lanes
moving 791, 792
muting 434
noteheads 465, 1027, 1029–1031
padding 794
panel 241, 243
percussion 465, 1024, 1027, 1029
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playing techniques (continued)
placement 791
playback 451, 801, 803
popover 238, 242
position 790, 791
selecting 273
showing 795
signposts 795
staff-relative placement 793
tracks, See playing techniques lanes
types 238, 790

playing techniques lanes 417
hiding 418
showing 418

Playing Techniques panel 243, 245
playthroughs 823

bar numbers 533–535
changing 837
dividing 824
MIDI recording 178
repeat barlines 837
repeat endings 824
repeats 837
total number 823

plops 759
inputting 231, 237, 238

plug-ins
expression maps 452
mixer 448
playback 443
whitelisting 404

PNG files 484
color 478
exporting 475
graphics frames 340
layout numbers 124
resolution 485

poco a poco
dynamics 208, 210, 630
tempo marks 953

points
staff spacing 392
unit of measurement 57

polychord chord symbols 215
inputting 218

polymeter
time signatures 194, 195

polytonality
key signatures 188, 189

popovers
add intervals 171, 172, 174
arpeggio signs 231, 234
bar repeats 255, 264
barlines 201, 203, 204, 206
bars 201, 202, 204
beats 202
changing items 280
chord symbols 141, 213, 216
clefs 219, 220, 222
cues 268, 269
dynamics 208, 210
fingerings 184
glissando lines 231, 235

popovers (continued)
holds 225, 227
instruments, See instrument picker
jazz articulations 231, 237
key signatures 186, 188
lyrics 246–248
metronome marks 196
octave lines 219, 221, 223
ornaments 229, 230, 232, 234, 235, 237
pauses 225, 227
pedal lines 240, 243
playing techniques 238, 242, 243
repeat endings 254
repeat markers 254
repeats 254, 261, 264
rhythm slashes 255
tempo 196, 200
time signatures 191, 194
tremolos 255, 261
trills 230, 739
tuplets 169

portamento 753
portrait orientation 483
ports 416, 421, 425, 448

changing 450
chords track 425
expression maps 448, 450
instrument tracks 416
instruments 450
mixer 443
percussion maps 448, 450
setup 448
time track 421

position
arpeggio signs 748, 750
articulations 500, 501
cues 595, 597
dynamics 614
fingerings 639
glissando lines 753
grace notes 658
gradual dynamics 631
hairpins 631
inputting 143
instruments in percussion kits 113
items 281
jazz articulations 762
key signatures 684
new items 143
notes in multiple-voice contexts 1039
octave lines 591
order 594
pauses 666
pedal lines 780
resetting 281
slurs 869, 872
staccato 501
time signatures 982
trill intervals 741
tucking index 594
vertical order 594
videos 127
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possibile
dynamics 210

pre-roll 435
duration 435

preamble 653
barlines 512
ossia staves 920

preferences
key commands 52, 55
MIDI 181
mouse input 143
pedal lines 181
sustain pedal controllers 181

Preferences dialog 51
prefixes

bar numbers 535
dynamics 623, 624
fingerings 649
rehearsal marks 812

presentation types 107
changing 1026
dynamics 1025
editing area 107, 1025
percussion kits 1019, 1025

presto 950
inputting 196, 198, 200

previous versions 62
primary bar number sequence

changing 531
returning to 533

primary beams 548
Print mode 17, 468

landscape orientation 480
page setup 483
panels 40, 468–470
portrait orientation 480
printers 479
switching 468
toolboxes 468

Print Options panel 468, 470
print preview area 39

navigation 39
printers 479

selecting 472
printing 468, 472

annotations 485
arrangements 480
booklets 481
borders 485
copies 472
crop marks 485
date 485
duplex 472, 481
job types 480
landscape 480, 483
layouts 472
macOS options 474
options 470
orientation 483
page sizes 482, 483
paper sizes 482
portrait 480, 483
preview 39

printing (continued)
ranges 472, 474
scale size 472
signposts 485
spreads 480
time 485
watermarks 485

program changes
expression maps 451, 452

Project Default Chord Symbol Appearances dialog 566
Project Info dialog 90

flow titles 119
project information 90

master pages 653
text tokens 90
tokens 119, 333

project window 33
Engrave mode 290
opening multiple 49
Play mode 400
Print mode 468
Setup mode 82
splitting 48
Write mode 131

projects 29, 63
adding images 340
auto-save 78
auto-save location 79
backup location 80
backups 80
different Dorico versions 62
exporting 67, 72, 75
exporting flows 64, 65
flows 63–65, 117–119, 289
frame rates 130
full screen mode 50
importing flows 63, 66
layouts 120
MIDI files 72
movements 117
multiple windows 20, 49
MusicXML files 67
opening 49, 61, 62, 78
recent 62
recovering 78
settings 299, 300
splitting flows 289
start area 37
starting 21, 59
Steinberg Hub 58
tabs 48
templates 58–60
titles 119
tokens 333
videos 125, 127
window 33
workspaces 45

Propagate Part Formatting dialog 361
propagating

part formatting 360, 362
properties 363
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properties 135, 298
copying to other layouts 363
notations 136, 298
notes 136, 298
selected items 135
videos 126

Properties panel 40, 135
disclosure arrow 42
Engrave mode 290, 298
hiding 42
showing 42
Write mode 131

punctuation
timecodes 819
verse numbers 706

Q
qualifiers

dynamics 208, 210
quality

chord symbols 214, 218, 564, 574
quantization

changing 178
dialog 71
importing MIDI 69
MIDI recording 176
requantizing 178
tuplets 71

quarter notes 9, 134
swing playback 438
tempo equations 965

quarter tones 492, 675
accidentals 492, 677
key signatures 681
octave divisions 677
transposing 172

quartet templates 59
staff grouping 60, 558

quavers 9, 134
quintet templates 59

staff grouping 60, 558
quintuplets 1007

R
rallentando 962

inputting 196, 198, 200
ranges

arpeggio signs 748
bar numbers 526
copying notes 285
cues 595
dynamics in playback 637
flow heading changes 315
glissando lines 757
instruments 103
master page changes 314
metronome marks 960, 961
page number changes 312
pages 472, 474
percussion legends 1032
selecting 274

ranges (continued)
slurs 883
swapping 286
unison 934, 935

rastral size 907
rates

frames 129
ratios

grace notes 660
note spacing 384, 386
swing playback 438
tuplets 1016

recent projects 62
recipes 477
recording

click settings 179
count-in 180
input pitch 149
MIDI 176, 180, 435, 446
retrospective recording 178, 446
tempo 435

Recover Auto-saved Projects dialog 78
recovering 178

backups 80
files 78, 80
notes 178

rectangle
bar number enclosures 522, 523
noteheads 714
rehearsal mark enclosures 806, 807
text enclosures 376

reducing 286
regions

bar repeats 839
counts 855
engraving options 840
Play mode, See colored regions
slashes 849, 853

register
changing 173–175
clefs 222, 580, 585
cues 598, 602
note input 151
octave lines 223, 224, 586
plug-ins 404
transposing 174, 585

rehearsal marks 805
cues 270
default settings 806
deleting 810
enclosures 806, 807
engraving options 806
filter 278
font styles 813
inputting 249
moving 809, 810
multiple positions 809, 925, 926
order 811
padding values 807
placement 805
position 805, 809
prefixes 812
sequences 811
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rehearsal marks (continued)
size 813
staff-relative placement 805
suffixes 812
types 811
vertical positions 925

relative tempo changes 951
values 961

reloading
video files 127

removing, See deleting
renaming

drum sets 107
flow headings 321
flows 119
instruments 101
layout names 100
layouts 122
master page sets 303
master pages 305
percussion kits 107
player groups 116
players 100

renumbering
layouts 124

repeat barlines 509
appearance 511
exporting 436
inputting 203, 206
MIDI recording 178
number of times played 837
playback 436
playthroughs 837
popover 203, 206
start of systems 511

repeat endings 823
additional endings 257, 259
alignment 825
appearance 824, 828
bar numbers 533–535
default settings 824
deleting 283
Engrave mode 827
engraving options 824
exporting 436
final segments 828
handles 825–827
hooks 829
inputting 254, 256–259
length 825, 826
MIDI recording 178
moving 826
multiple positions 825, 925, 926
MusicXML files 829
number of playthroughs 823
panel 256, 258, 259
playback 436
playthroughs 823, 824
popover 254, 257
position 824, 825
segments 823, 825
text 828

repeat endings (continued)
types 254
vertical positions 925

repeat jumps, See repeat markers
repeat markers 830

appearance 831
bar numbers 533–535
barlines 511, 834
changing 280
default settings 831
deleting 283
engraving options 831
exporting 436
fonts 831
index 832
inputting 254, 256, 260, 261
lines 833
lower case 831
MIDI recording 178
moving 835
multiple 832
multiple positions 835, 925, 926
number of times played 837
order 832
panel 256, 261
paragraph styles 831
playback 436, 837
popover 254, 260
position 831, 835
size 831, 832
staff-relative placement 836
text 833
types 254
upper case 831
vertical positions 925
word wrapping 833

repeat sections, See repeat markers
Repeat Structures panel 256
repeats

barlines, See repeat barlines
bars 839
counts 842
endings, See repeat endings
engraving options 840
font style 845
frequency 844
grouping 846, 847
length 280, 840
markers, See repeat markers
moving counts 846
playback 837

repeats popover 254
repitching notes 174
replacing

flow headings 320
master pages 304

requantizing notes 178
resetting

appearance 281
bar numbers 531
barlines 562
beaming 540, 541, 544
beams 549
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resetting (continued)
braces 562, 563
brackets 562, 563
chord symbols 572
expression maps 452
fingerings 642
items 281
key commands 57
layouts 124
note spacing 387, 391
octave line angles 589
page numbers 313
part layouts 124
percussion maps 460
playback templates 437
position 281
secondary beams 549
staff grouping 563
staff spacing 397
tempo 951
text 373
volume 434

resolution
images 485
rhythmic grid 42

respelling
accidentals 163
chord symbols 578
notes 163, 164
notes in cues 601

rest grouping, See note grouping
restating

accidentals 496
trill intervals 729

restorative text 788
rests 859

alignment 859
bar rests, See bar rests
changing type 862
colors 863
consolidation 139, 861, 864, 865
cues 595, 608, 609
default settings 862
deleting 863
dotted 139
durations 157
empty bars 864
engraving options 862
explicit 859, 860, 862
forcing duration 158
formatting 378
grouping 553
hiding 853, 863–865
implicit 859, 860, 862
inputting 132, 158, 164, 165
moving 381, 866
multi-bar rests 862, 864–866
notation options 862
padding 608, 853
percussion kits 139
placement 859
position 859
restoring 863

rests (continued)
showing 863–865
stemlets, See stemlets
symbols 378
tacet al fine 866
voices 859, 861, 866

retakes, See pedal retakes
retrieving, See recovering

See also retrospective recording
retrospective recording 178, 446
reverb channels 445

mixer 443
rewinding 431
rhythm

locking 174
requantizing 178

rhythm dots 152
compound time signatures 850
consolidation 725, 726
inputting 149, 152
moving 727
number 152
rhythm slashes 850
voices 725, 726

rhythm section
brackets 558
chord symbols 577
staff grouping 558

rhythm slashes 657, 849, 1044
appearance 850, 851
arpeggio signs 750
caret 146, 160
changing number 856
counts 855–857
default settings 850
deleting 283
designs 850
engraving options 850
filter 278
font style 842, 845
frequency 856
hiding counts 857
hiding rests 853
highlights 850
inputting 160, 256, 263
moving 852, 854
moving counts 857
panel 256
parentheses 857
pasting notes into 284
percussion kits 107, 113, 154, 1045
placement 858
popover 255, 263
regions 849, 855
rests 853
rhythm dots 850
splitting 853
staff position 113, 852
staff-relative placement 858
stem direction 851, 946
stems 855
type 1044
vertical position 852
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rhythm slashes (continued)
viewing options 850
voices 160, 287, 851, 1044

rhythmic cues 596
changing cues into 596
moving 597
position 597
staff position 597

rhythmic feel
changing 440
default settings 438
deleting changes 440
popover 197
signposts 281, 440

Rhythmic Feel dialog 441
rhythmic grid 42, 144

changing 145
key commands 52, 55
resolution 42
selecting music 277
values 145

rhythmic notation 849
rhythmis slashes

font style 855
right panel 40
rim shots 790

inputting 242, 243
rips 759

inputting 231, 237, 238
ritardando 962

inputting 196, 200
ritenuto 962

inputting 196, 198, 200
Roman numerals

fingerings 650
flow numbers 334
page numbers 312, 767
staff labels 899
tokens 334

Romantic
trills 742

roots
chord symbols 214, 218, 564, 574

Ross chord symbols 565
rotating

hairpins 627
slurs 882

rows
dynamics 618

rulers
Play mode 407
rhythmic grid 144

running headers 655
flow headings 348
hiding 348

S
salzedo breath marks 666
sample libraries 460

percussion maps 463
playback 451, 460
trills 742

sampled trills 742, 743
disabling 743
enabling 743

saving 58, 78
audio 72, 76
auto-save, See auto-save
backups 80
character styles as default 369
chord symbols as default 572
engraving options as default 299
expression maps 459
folder location 79, 80
graphics files 475, 476
instrument names as default 97
layout options as default 90
MIDI files 72
MusicXML files 67
notation options as default 139
note input options as default 141
paragraph styles as default 366
percussion kits 1020
percussion maps 464
playback options as default 405
played notes 178

scale degrees
chord symbols 213
Nashville numbers 214
noteheads 709, 714

scale size
barlines 509
chord symbol components 566, 568, 569
clef changes 583
cues 384
fingerings 644
grace notes 384, 657, 660
note spacing 384, 385
notes 723
ossia staves 919
printing 472, 482, 483
staves 907, 909, 910

scales 673
degrees 564, 709, 714
EDO 673, 674
key signatures 671, 672
major 672
minor 672
octave divisions 673, 674

scissors 132
activating 132
slashes 853
ties 972

scoops 759
inputting 231, 237, 238

scores, See full score layouts
scrapes 790

inputting 242, 243
searching

ensembles 85
instruments 85
key commands 54, 55

Second Viennese School accidental duration rule 496
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second voices
adding 159
bar rests 165

secondary beams 548
changing 548
lines 548
resetting 549

secondary brackets 556
braces 556
sub-brackets 556
sub-sub-brackets 557

section players 94
adding 95
divisi 929, 930, 932
editing divisi changes 933
empty staves 351
ossia staves 917, 918
staff labels 895
unison ranges 934, 935

sections
coda 830
fine 830
hiding 41
repeat 830
showing 41

segments
final 828
playthroughs 824
repeat endings 824, 825, 827
slurs 878

segno 830
font 831
inputting 260, 261
multiple 831, 832
sections 830
size 831

selecting 42, 272–274
bars 276
beats 277
blue 633, 876
chords 279
everything 43, 274, 276, 277
extending selection 273, 274
filters 278
flows 274
frame handles 324
handles 298
items 143, 273, 274, 291
lyrics 692
marquee 42, 43
more 273, 274
notations 42, 43
note spacing handles 389
notes 42, 43, 273, 278, 279
staff spacing handles 396
status display 42
staves 274
system spacing handles 396
system track 275
tools 42
transposing selections 176, 687

selectors
music frames 328

semibreves 9, 134
semiquavers 9, 134
sends 445

mixer 443
sentence case

repeat marker text 831
separators

chord symbols 573
fingerings 649
systems, See system dividers
time signatures 982, 991
timecodes 819

septuplets 1007
sequences

bar numbers 530–532
page numbers 311, 312, 344
rehearsal marks 811
subordinate 532
types 811

sets
drum sets 107, 111, 1020
master pages 302

setting up
audio devices 51, 180, 181
duplex printing 472
key commands 55
MIDI recording 180
percussion kit note input 155
windows 45
workspaces 45

settings 30
audio 51
copying properties 363
default 299, 300
flow-specific 139
layout-specific 90, 92
MIDI import 70
mouse input 143
note input 141
preferences 51
project-wide 299, 300
videos 126

Setup mode 17, 82
adding players 102
ensembles 102
flows 93, 117, 118
instruments 103
layouts 93, 120, 121
panels 40, 82, 83, 86, 89
percussion 107
player groups 115
players 93–96
signposts 281
switching 82

sextuplets 1007
shakes 760

inputting 230, 232, 233
shape

bar number enclosures 522, 523
beaming 543, 548, 551
frames 323
multi-segment slurs 880
noteheads 711, 714, 715
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shape (continued)
rehearsal mark enclosures 806, 807
slurs 878–883, 886
ties 973
tuplet brackets 1012, 1014, 1016

sharps 488
filters 278
hiding 489
inputting 162
parentheses 489
quarter tones 492
respelling 163
showing 489

short
barlines 203, 206, 509
stemlets 550

shortcuts, See key commands
shoulder offset

slurs 886
ties 974

showing, See hiding
signatures

annotations 485
key signatures, See key signatures
printing 485

signposts 281
barlines 507, 559
bars 507
bracket and barline changes 559
chord symbols 574
cues 606, 611, 612
dynamics 624
exporting 485
extra staves 913
frame breaks 358
hiding 283
key signatures 683
note spacing changes 381
ossia staves 917, 918
percussion legends 1031
playing techniques 795
printing 485
showing 283
staff changes 913
staves 915
system breaks 358, 360
tempo marks 957, 959
time signatures 996

silence
hairpins 622
muting items 434
playback template 436, 437

simile
dynamics 208, 210, 623

simple time signatures 983
single barlines 509
single-line

percussion kits 1025, 1026
staves 906

single-note tremolos 999
deleting 1002
inputting 261, 262
moving 1003

single-note tremolos (continued)
playback 465
popover 255
speed 1001
types 255

single-voice contexts 1039
articulations 499
grace notes 658
stem direction 658, 943
tie curvature direction 979

sixteenth notes 9, 134
size

audio buffer 180, 181
bar numbers 521
clef changes 583
coda symbols 832
cues 595
fingerings 644, 647
flared hairpins 629
frames 323
gaps 114, 890, 979
grace notes 657, 660, 723
lyrics 704
metronome marks 951
noteheads 711
notes 723
ossia staves 919
pages 90, 343, 482
paper 482, 483
rehearsal marks 813
repeat markers 831
segno symbols 832
staff labels 897
staves 90, 908, 909
system objects 908, 909
tempo marks 951
time signatures 986, 988
tracks 413, 429
unit of measurement 57
video window 128

slants
beams 541, 662
octave lines 588, 589
pedal line hooks 783

slash notation 849
slash regions 849

counts 855, 857
default settings 850
deleting 283
engraving options 850
filter 278
font style 842, 845
handles 854
hiding other notes 852
hiding rests 853
highlights 849, 850
inputting 263
length 854
moving 852, 854
moving counts 857
multiple 851
overlapping 851
parentheses 857
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slash regions (continued)
placement 858
popover 255
rests 853
showing other notes 852
staff position 852
staff-relative placement 858
stem direction 851
stems 855
vertical position 852
viewing options 850
voices 851, 1044

slash voices 1044
caret 146, 160
default settings 850
engraving options 850
hiding stems 948
inputting 160
moving 852
multiple-voice contexts 851
percussion kits 107, 154, 1045
popover 255
regions 255, 849
staff position 852
stem direction 946
vertical position 852

slashes 657, 849
grace notes 657, 658, 660, 661
length 661
noteheads 711
notes, See tremolo strokes
regions, See slash regions
stemless 1044
stems, See tremolo strokes
time signatures 991
tremolos, See tremolo strokes
voices, See slash voices

slur segments 878, 880
number 878

slurs 868, 968
accidentals 892
angles 882
articulations 500, 872
collision avoidance 874, 892
control points 879
cross-staff 873, 892
cross-voice 873
cues 605
curvature 869, 870, 872, 887, 888, 891
dashed 888, 890
default settings 872
deleting 283
dotted 888, 890
duration 893
East Asian elision 707
editorial 888
endpoints 872, 879, 881
Engrave mode 879
engraving options 872
filter 278
fingerings 643
flat slurs 891
formatting 881, 883, 889–891

slurs (continued)
frame breaks 893
gap size 890
grace notes 658, 869, 870
handles 878–880, 883
height 884, 885
inputting 265, 873–875
inverting 869, 870, 888
large pitch ranges 883
length 876
linking 279, 876, 877
moving 875, 881, 882
multi-segment 880
muting 434
nested 872
nested slurs 874, 875
ornaments 733
overlapping 892
panel 134
placement 594, 869, 870, 888
playback 893
position 594, 869, 871, 872
ranges 883
rotating 882
segments, See slur segments
selecting 273
shape 878, 880–883, 886
short 883
shoulder offset 886
staff lines 871
styles 888, 889
system breaks 893
thickness 872, 883
ties 869, 870, 872
ties vs. slurs 968
tucking index 594
unlinking 279, 877
within slurs 874, 875

smears 760
inputting 230, 232, 233

smooth
jazz articulations 759

SMuFL 365
dynamic glyphs 636

solfège chord symbols 214
solid

slurs 888
tempo marks 963
ties 977

solo players 94
adding 22, 95
adding staves 914
empty staves 351
extra staves 913, 914
ossia staves 917, 918
staff labels 895, 897
staff size 909

soloing 443
deactivating 434, 443
instruments 433
tracks 432

Index
 

1109
Dorico 2.2.20



sordino 790
hiding 795
inputting 242, 243

sorting
layouts 124

sostenuto pedal 771
MIDI controller 788

sound libraries, See sample libraries
sounding

duration 1005
percussion legend ranges 1031, 1032
pitch, See concert pitch

sounding pitch
input pitch 149
layouts 123

sounds, See playback
soundtracks

audio 129
volume 129

source instruments 595
cue labels 602

space size 907
spacing

accidentals 491
arpeggio signs 748
articulations 501
barlines 513
caesuras 228
clefs 581
cross-staff beams 546
galley view 43
gradual dynamics 630
key signatures 685
layout options 90
lyrics 695, 697, 698
notes 381, 383–385, 388
percussion kits 114
rehearsal marks 805
staves 391, 393
system fullness 383
tacets 354
text 366, 369
time signatures 983
voice columns 1042

speed
arpeggio signs 750, 752
bpm 960
changing 424, 960, 962
frame rates 129
tempo marks 950, 960, 962
tremolos 1001
trills 735, 742, 744
videos 129

spelling
accidentals 163, 164
notes 163, 164

split point
MIDI import 70

split stems 491, 949
splitting

barline joins 517
bars 507
beams 139, 540

splitting (continued)
flows 289
multi-bar rests 864
project window 48
repeat marker text 833
slash regions 853
ties 972

spreads page arrangement 44, 480
square noteheads 714
squeezes 760

inputting 231–233
staccato 497

inputting 182
position 501

stacking order 594
accidentals 490
changing 594

staff grouping 558, 559
barline joins 515–517, 559
braces 559–561
brackets 559–561
changing 559
custom 559
default settings 60, 558, 559
ensemble types 558, 559
resetting 562, 563

staff labels 895
alignment 97
changing first system indent 927
Cubase 896
default settings 897
divisi 930, 937, 938, 940
engraving options 897
fonts 897
formatting 897
galley view 43
grouping 898
hiding 899, 901
indents 900
instrument change labels 902
instrument names 96, 97, 101, 896
length 899, 901
MusicXML import 896
numbering 103, 896
numbering style 899
ossia staves 922, 923
paragraph styles 366, 897
percussion kits 107, 904, 1025
percussion legends 1033
showing 899, 901
size 897
transposing instruments 895, 902, 903
uppercase 899

staff lines
ossia staves 919
slurs 871
thickness 911
ties 966

staff position
cues 596, 597
percussion kits 113
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staff size 907
changing 908–910
custom 910
dialog 910
individual staves 909
layouts 906
MusicXML files 66
ossia staves 919
rastral size 907
space size 907

staff spacing 291, 391
activating 291
changing 391, 393, 396
copying 398
default settings 391, 393
divisi 350
galley view 393, 395
handles 392, 396
justification 350, 391, 393
layout options 90
moving systems 397
rehearsal marks 805
reverting 397
text collision avoidance 375

staff-relative placement
articulations 502, 503
bar numbers 528
beaming 541
changing 280
cue labels 603
dynamics 614, 615
fermatas 669
fingerings 643
lyrics 703, 704
octave lines 592
ornaments 733
pedal lines 777
percussion legends 1034
playing techniques 793
rehearsal marks 805
repeat markers 836
resetting 281
slash region counts 858
slurs 888
text 374
trills 733
tuplet brackets 1014

start area 37
start position

videos 127
start repeat barlines 203, 509

inputting 206
start signs

appearance 782
pedal lines 782, 786, 787
text 787

starting 148
area 37
Hub 58
MIDI recording 176
note input 148, 149
playback 431
players 37

starting (continued)
projects 21, 37, 59
timecode values 820
workspaces 45

status bar 17, 42
selection tools 42
view types 43

status display 42
staves 9, 906

adding 913, 914
adding ossias 918
arranging tools 283
bar numbers 526, 527
bar rests 864
barlines 293, 515, 516, 922
beaming 544, 546
braces 560, 561
brackets 60, 558–561
chord symbols 123, 575, 577
clef for transposing instruments 585
copying 934
copying items 284, 285
crossing notes 544
cues 596, 597
deleting 912
dialog 910
divider arrows 936
dividers, See system dividers
divisi 929, 930, 932, 934, 937, 940
divisi labels 940
dynamics 615
dynamics linking 279, 633
editing divisi changes 933
ending divisi 934
exploding 287
extra 913
fermatas 670
five-line 904, 906, 1025
galley view 50
gaps 830
grids 904, 1025
groups 515, 558
hiding 93, 118, 121, 122, 351, 912
indents 900, 906, 927
instrument change labels 902
large time signatures 988
layout options 906
line thickness 911
markers 815, 820
moving 396
multiple voices 159
notes 286
ossia staves 917, 922
page view 50
pauses 666
percussion 1025, 1026
playback 431
preamble 920
reducing 286
rehearsal marks 925
repeat endings 925
repeat markers 836
resetting barline joins 562
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staves (continued)
resetting bracket/brace grouping 562, 563
selecting 274
showing 50, 118, 121, 351
single-line 815, 820, 821, 904, 906, 1025
size, See staff size
slurs 873, 876
slurs linking 279
spacing, See staff spacing
stem length 947
swapping contents 286
system breaks 358
system dividers 924
system objects 925, 926
tacets 352
tempo marks 925
text 265, 925
ties 966, 970, 971
time signatures 925, 987, 988, 994, 995
timecodes 815, 820, 821
unison ranges 934, 935
uppercase staff labels 899
vertical spacing, See staff spacing
vocal 936
voices 159
width 349, 916

Steinberg Hub 58
opening projects 61, 62

stem direction 943
beam groups 944
beam placement 541, 546
centered beams 544
changing 287, 607, 851, 946
chords 944
cues 607
default settings 945
filters 278
grace notes 658, 662
middle line 943, 945
multiple-voice contexts 943
notes crossed to other staves 544, 1043
notes on middle line of staff 943, 945
percussion kits 107, 139, 156, 1034, 1036
resetting 541, 947
rhythm slashes 851, 946
single-voice contexts 943, 946
slur curvature 868, 869
staff-relative placement 541
tie curvature 966
voices 287, 943, 946, 1039

stemless
noteheads 948
rhythm slashes 1044

stemlets 550
removing 551
showing 550

stems 942
altered unisons 949
articulations 502, 503
attachment points 719
audio 76
beam placement 546
beaming 538

stems (continued)
cues 607
custom noteheads 719
default settings 942
deleting tremolos 1002
direction, See stem direction
engraving options 942
flag design 942
flags 378, 942
formatting 378
grace notes 660, 662
handles 947, 1003
hiding 948
length 662, 942, 947
middle line direction 945
multi-note tremolos 1004
noteheads 719
removing direction changes 947
rhythm slashes 851, 855, 1044
slur endpoints 872
split stems 491, 949
staccato position 501
stemlets, See stemlets
symbols 378
thickness 942
tremolos 1000, 1003
tuplet placement 1007
voices 943, 946

step input, See note input
stickings 1024
stopping, See starting
straight lines

glissando lines 753
jazz articulations 763

straight playback 438
stress marks 497

inputting 182
string instruments

fingering shifts 651
playing techniques 241–243, 790
specifying string 727
substitution fingering 640
techniques 238

string shift indicators 651
angles 651
direction 651, 727
thickness 651

strokes
slurs 888
ties 977
tremolos 999–1001, 1003

styles
appearance 281
breath marks 666
caesuras 666
fermatas 664
fonts 364
glissando lines 753, 754
jazz articulations 763
margins 342
niente hairpins 622
numbering 899
page numbers 766
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styles (continued)
resetting 281
slurs 888, 889
tempo marks 951, 962
text 366, 369
ties 977
time signatures 988, 990

sub-brackets 556
custom grouping 559, 560
deleting 562, 563
formatting 293
inputting 560
length 561
resetting 562, 563
signposts 560

sub-sub-brackets 557
custom grouping 559, 560
deleting 562, 563
formatting 293
inputting 560
length 561
resetting 562, 563
signposts 560

subito
dynamics 208, 210

subordinate bar numbers 532
adding 532
appearance 533

subordinate page numbers 312
numeral style 311, 312

subsequent repeats
bar numbers 533, 535

substitution fingering 640
handles 640
position 640

suffixes
bar numbers 535
dynamics 623, 624
rehearsal marks 812
timecodes 819

suggestions
cues 270

sul ponticello 790
inputting 238, 242, 243

sul tasto 790
inputting 238, 242, 243

suspensions
chord symbols 214

sustain pedal 771
continuation lines 784
Engrave mode 772
handles 772
inputting 240, 243, 245
level changes 244, 245, 772
MIDI controller 181, 788
MusicXML import 789
popover 240, 243
removing retakes/level changes 777
retakes 244, 245, 772, 774

sustaining instruments 637
SVG files 484

color 478
exporting 475

SVG files (continued)
fonts 479
graphics frames 340
layout numbers 124

swapping
note order 1042
notes 286
pages 317
staves 286
voices 288

swing playback 438
custom rhythmic feel 441
disabling 440
editing 441
enabling 197, 439, 440
popover 197
ratios 438
rhythmic feel 441
tempo 441
triplets 438

switching
frame handles 324
handles 298
layouts 14, 34, 46
modes 17
note spacing handles 389
staff spacing handles 396
tabs 48

syllables
position 695
types 694

symbols
bar repeats 839, 846, 847
bar rests 866
caret 146
chords 564
coda 832
dialog 378
editing 378
music 378
ornaments 729
pedal lines 782
playing techniques 790
segno 832

syncing
videos to music 127

syncopation
stemlets 550

system breaks 292, 342, 358
automatic 355
bar repeats 355, 359
copying to other layouts 360–362
deleting 360
divisi 929
dynamics 628
filter 278
hairpins 628
inserting 359
make into system 359
signposts 281, 358, 360
slurs 893
staff labels 901
staff size 908
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system breaks (continued)
staff spacing 393
ties 969

system dividers 924
formatting 378
hiding 924
showing 924
symbols 378
width 925

system formatting 360
copying to other layouts 362

system fullness indicator 383
system objects 925

positions 926
rehearsal marks 805, 809
repeat endings 823, 825
repeat markers 835
size 906, 908, 909
tempo marks 950, 953
text 265
time signatures 987, 994

system spacing 291, 391, 393
changing 393, 396
default settings 391, 393
handles 382, 392, 396
justification 350, 391, 393

system text 925
backgrounds 377
borders 376
erased backgrounds 377
inputting 265
moving 373
multiple positions 926
padding 377
staff-relative placement 374
stave positions 925

system track 275
deleting music 505
hiding 276
inputting bars 205
inputting beats 205
selecting music 276, 277

systemic barlines 512
systems

bar numbers 520
barlines 512
breaks, See system breaks
casting off 355
changing indents 927
coda gap 835
dividers, See system dividers
divisi 929, 932
end position 390
fixing bars 355
fixing per page 356
formatting 292
fullness, See system fullness indicator
gaps 830
indents 390, 900, 906, 927
make into system 359
moving 396, 397
preamble 920
repeat barlines 511

systems (continued)
sections 830
selecting 273, 274
spacing, See system spacing
splitting 830
staff labels 927
staff size 908
start position 390
text, See system text
timecodes 821
tonality 673
track, See system track
trill marks 734
vertical position, See system spacing
width 349, 390

T
tabla notation 1037
tabs

bar 37
closing 47
groups 48, 49
hiding 35
layouts 46
moving 49
opening 19, 46
order 48
showing 35
showing multiple 48
switching 48
view options 46

tacet al fine 862, 866
tacets 31, 352

formatting 352
hiding 353
margins 354
paragraph style 352
removing players from flows 118
showing 353
text 354

tap tempo 198
technique combinations

creating 458
Technique Combinations dialog 456
techniques 790

percussion 460, 465, 1027, 1029
playback 801, 803

templates 59, 60
brackets 60
categories 59, 60
ensembles 85, 102
flow headings 318
master pages 301, 306
new projects 58
opening 13
pages 301, 306
playback 403, 436, 437, 448
players 85, 102
staff grouping 60, 558
staves 60, 558
titles 318
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tempo 950
bpm 960
changing 424
click settings 179
default 950, 957
deleting changes 425
drawing 421
editing 421
finding 251, 818
fixed tempo 435, 446
follow tempo 435, 446
inputting 423
metronome marks 960
MIDI recording 435
Play mode 421
range 961
recording 435
swing playback 441
tracks, See tempo tracks

tempo equations 965
inputting 197, 198
panel 198
popover 197

tempo marks 950
abbreviated 952
absolute tempo changes 198, 951
alignment 953
appearance 958, 959
barlines 956
beat units 280, 960
changing 280, 952, 959, 960
components 958, 959
continuation lines 950, 962, 963
dashes 964
default settings 958
deleting 957
engraving options 958
equations, See tempo equations
filters 278
finding 251, 818
fonts 951
formatting 378, 963, 964
gaps 964
gradual tempo changes 198, 951, 962
handles 954, 956
hiding 957
inputting 196, 198, 200
length 954, 956
metronome marks 280, 950, 960, 961
moving 424, 954
multiple positions 925, 926, 953
panel 198
parentheses 958, 959
placement 953
playback 436, 950, 957, 961, 962
poco a poco 953
popover 196
position 953, 958
relative tempo changes 198, 951, 961
repeats 436
reset tempo 198, 951
selecting 273
showing 957

tempo marks (continued)
signposts 281, 957, 959
size 951
style 963, 964
symbols 378
text 280, 951, 952
types 196, 198, 951
vertical positions 925

Tempo panel 198
tempo tracks 73, 421

dialog 73, 75
exporting 75
importing 73

tenuto 497
inputting 182

terminology
British vs. American English 9
note durations 9

text
abbreviated tempo text 952
alignment 266, 339, 368, 371
backgrounds 377
borders 337, 338, 376
character styles 369, 370
collision avoidance 375
cue labels 602
cues 605
dedications 654
default position 375
default settings 265
divisi change labels 937, 939
divisi staff labels 937
dynamics 623, 624
Edit Font Styles dialog 364
editing 268, 337
editor, See text editor
engraving options 265
erased backgrounds 377
expressive 613, 623
filter 278
fingerings 648
flow titles 119
formatting 266, 363, 371
frames, See text frames
glissando lines 755, 756
horizontal alignment 339
inputting 265
lyrics 694, 695
markers 250, 814, 815
moving 373
multiple positions 925, 926
music fonts 365
overlapping 375
padding 338, 377
paragraph styles 366, 368, 373
pedal lines 786–788
percussion legends 1034
playing techniques 790, 793
rehearsal marks 805
repeat endings 828
repeat markers 831, 833
resetting 373
staff labels 897
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text (continued)
staff-relative placement 374
system text 265, 925
tacets 354
tempo marks 280, 952
tokens, See tokens
types 371
uppercase staff labels 899
vertical alignment 338
word wrapping 833

text editor 266, 268
Engrave mode 371
Write mode 266

text frames 331
borders 337
changing text 337
entering text 337
flow headings 348
horizontal alignment 339
identifying 371
inputting 322
overrides 331
padding 338
paragraph styles 373
running headers 348
selecting 324
vertical alignment 338

text objects 371
editing 268
identifying 371

thick barlines 203, 509
inputting 206

thickness
bar number enclosure lines 523
barlines 511
borders 338, 376
glissando lines 754
grace note slashes 660
gradual tempo changes 964
lines 299
pedal lines 785
rehearsal mark enclosure lines 807
slurs 872, 883, 890
staff lines 911
stems 942
string shift indicators 651
text borders 338, 376
ties 968, 978

thru
MIDI 176

thumbs
fingerings 184

tick
barlines 203, 206, 509
breath marks 666

tie chains 966, 968
articulations 500, 968
clefs 581
deleting 972
selecting 968
slurs 869, 870, 872
splitting 972
tremolos 1000

ties 966, 968, 969
accidentals 969
appearance 977
articulations 500, 968
breaking 972
cautionary accidentals 489
chains, See tie chains
chords 979
clef changes 970
clefs 581
collision avoidance 966
cross-staff 970, 971
cross-voice 970, 971
cues 608
curvature direction 968, 979, 980
dashed 977–979
default settings 968
deleting 972
dotted 977–979
editorial 977
engraving options 968
forcing 158
formatting 973, 977–979
frame breaks 969
gap size 979
half-dashed 977
handles 973–976
height 975, 976
inputting 132, 166, 971
inverting 980
laissez vibrer 970, 971
non-adjacent notes 970, 971
non-standard types 969
note grouping 158
placement 966
position 870, 966, 968, 973
shape 973
shoulder offset 974
slurs 869, 870, 872
slurs vs. ties 968
solid 977
splitting 158, 972
staff lines 966
style 977
system breaks 969
tie chains, See tie chains
time signature changes 970
tremolos 1000
voices 966, 979

TIFF files 484
color 478
exporting 475
layout numbers 124
resolution 485

time
display 446, 447
latency 176, 180
markers 814
signatures, See time signatures
track, See time track
transport window 446, 447
videos 127
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time and date
annotations 485
tokens 335

time bars, See repeat endings
time signatures 981

above staff 987
additive 983
aggregate 983
alignment 994
alternating 983
appearance 982, 997
bar numbers 529
barlines 516, 994
beam grouping 139, 539, 553, 554
beat groups 139, 989
bracketed groups 987
changing 280, 507
click 176
compound 983
custom 983
default settings 982
deleting 996
denominators 982, 990
design 997
engraving options 982
filter 278
font 982
font styles 997
formatting 378
height 982
hiding 996
inputting 25, 190, 191, 194, 195, 507
Insert mode 507
interchangeable 983
irregular 983
large 986
MIDI recording 176
moving 992–995
multiple positions 925, 926
non-power of two 983
note grouping 553
noteheads 990
numerators 982, 989
open 983, 990
panel 192
parentheses 191, 194, 991
pick-up bars 191, 194, 195, 983, 985, 986
placement 982
polymeter 194, 195
popover 191
position 988, 992, 995
rest grouping 553
rhythm slashes 850
separators 982, 991
showing 996
signposts 281, 996
simple 983
size 988
spacing gaps 983
styles 988, 991
symbols 378
system objects 987
ties 970

time signatures (continued)
types 191, 983
upbeats 985
vertical position 986, 988, 995
vertical positions 925, 926

Time Signatures (Meter) panel 192
time track 421

changing tempo 424
collapsing 429
deleting tempo changes 425
expanding 429
inputting tempo changes 423
moving tempo changes 424

timecodes 819
changing 126, 817, 820
dialog 126
drop frame 819
flows 89
font style 816
frequency 821
hiding 821
inputting 249
markers 250, 251, 821
non-drop frame 819
offset 820
panel 250
showing 821
staff 820
staff spacing 393
start values 820
tempo 251
transport window 446, 447

times played
changing 837

title case
repeat marker text 831
staff labels 899

title pages
text tokens 332

titles
adding 90
changing 90, 119
default master pages 653
flow headings 348
flows 119, 318
hiding 346, 348
movements 318
projects 119
running headers 348
showing 346, 348
templates 318
text tokens 332

tokens 332, 371
date 335
file names, See ingredients
flow headings 318
flows 119, 333, 334
master pages 304, 653
page numbers 334
project information 90, 119, 333
Roman numerals 334
time 335
titles 119
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tonality systems 673
accidentals 677
changing 674
custom 675
key signatures 681
octave divisions 674, 677
panel 189
playback 683

tongue clicks 790
inputting 238, 242, 243

toolbar 14, 34
hiding 34
transport options 34, 35
workspace options 34, 35

toolboxes 15, 41
Engrave 291
Notations 131, 137
Notes 131, 132
Play 400, 401

tools
arranging 283
selecting 42
timecodes 819

track names
MIDI import 70

tracks 414
automation 418
chords, See chords track
collapsing 429
expanding 429
height 429
hiding 430
instruments, See instrument tracks
markers 427, 428
muting 432
piano roll editor 408
players, See player tracks
playing techniques 417
soloing 432
system 275
tempo 73, 421
time, See time track
types 414
video 429

translation lyrics 692
changing lines to 702
popover 247

transport 446
basic options 34, 35
playhead 431
playhead position 446, 447
repeats 436
window 33, 446

Transpose dialog 175, 176, 687
transposed pitch 123

chord symbols 123, 578
clefs 584, 585
instrument transpositions 902
layouts 123
note input 149
part layouts 120, 123
showing 123
staff labels 895, 902

transposed pitch (continued)
status display 42
viewing 123

transposing 175
chord symbols 123, 573
clefs 585, 609
cues 602, 609
dialog 175
expression maps 451
instruments, See transposing instruments
key signatures 176, 684, 687
layouts 120, 123
notes 172–174, 176, 412
octaves 173
pitch, See transposed pitch
popover 172
selections 176
staff labels 903

transposing instruments 104, 123, 585, 895
chord symbols 578
clefs 584, 585
cues 598
instrument transpositions 902, 903
key signatures 123, 139, 672, 684, 688
register in cues 598
staff labels 895, 902, 903

transposing layouts
input pitch 149

tre corde 771
trees

altered unisons 491
stems 949

tremblements 729
tremolo strokes 999, 1001

changing number 1000, 1001
formatting 378
moving 1003
symbols 378

tremolos 999
angles 1001
appearance 1004
articulations 465
default settings 1004
deleting 1002
duration 1005
engraving options 1004
formatting 378, 1004
inputting 255, 256, 261, 262
measured 999
moving strokes 1003
multi-note 999, 1004
number of strokes 1000
panel 256, 262
placement 1001
playback 465, 1005
playing 1005
popover 255, 261
position 1001, 1003, 1004
single-note, See single-note tremolos
speed 1001
strokes, See tremolo strokes
symbols 378
tie chains 1000
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tremolos (continued)
tuplets 999
types 255, 999
unmeasured 999

triangle noteheads 712
trill intervals 737, 738, 741

accidentals 740
appearance 729, 740, 741
auxiliary notes 740
changing 739
hiding 738
Hollywood-style 740
indicators 737
microtonal 738
position 741
restatement 729
showing 738

trill lines 735, 736
hiding 736
length 736
showing 736
speed 735

trills 729, 734
accidentals 740, 741
alignment 733
appearance 740, 741
auxiliary notes 740
deleting 283
extension lines, See trill lines
filter 278
generated 743
grace notes 742
handles 732, 736
hiding marks 734
Hollywood-style 740
inputting 230, 232
intervals 230, 737, 738, 740, 741
length 732, 736
lines, See trill lines
moving 731
NotePerformer 743
parentheses 729
pitch 744
placement 731
playback 742–744
popover 230
position 731, 733
sampled 743
speed 735, 742, 744
staff-relative placement 733
start position 733
starting pitch 744

trimming flows 201, 202, 505
triple accidentals

respelling 163
triple barlines 203, 509

inputting 206
triple-dotted notes 152
triplets 1007

inputting 132, 169
swing playback 438

tucking index 594
changing 594

tuning
playback 435

tuning systems, See tonality systems
tuplet brackets 1012

angle 1014
end position 1015
handles 1012, 1014
hiding 1013
hooks 1012
horizontal 1016
length 1012
moving 1012
position 1007
showing 1013

tuplet numbers 1016
appearance 1016, 1018
font 1018
hiding 1016
horizontal position 1017

tuplet ratios, See tuplet numbers
tuplets 1007

accidentals 1009
appearance 1008, 1013, 1016
articulations 500, 1009
beams 549, 1012
beat units 169
brackets, See tuplet brackets
default settings 1008
deleting 1010, 1011
end position 1015
engraving options 1008
filter 278
formatting 378, 1016
handles 1012, 1014
hiding 1016
hooks 1012
horizontal brackets 1016
inputting 169, 1008, 1009
inverting 1014
moving 1010, 1012, 1017
nested tuplets 1008
notes 1009
numbers 1016, 1017
percussion kits 1024
placement 594, 1007
popover 169
position 594, 1007, 1008
quantization 71
ratios 1016, 1017
showing 1016
signposts 281
slurs 1009
staff-relative placement 1014
swing playback 438
symbols 378
tremolos 999
tucking index 594
turning into normal notes 1010
turning notes into 1009
types 169, 1007
unscaling 1010

Turkish music
octave divisions 674
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turns 729
intervals 730
jazz 230, 232, 233, 760

tutti 929, 934
restoring 934

two-up page arrangement 480
types

appearance 281
arpeggio signs 231
articulations 760
bar repeats 255
barlines 509
breath marks 225, 666
caesuras 225, 666
caret 146
chord symbols 213, 564, 565
clefs 220
dynamics 208, 613
enclosures 522, 523, 806, 807
fermatas 225, 664
fingerings 184, 649
glissando lines 231
grace notes 660
holds 225, 664
jazz articulations 230, 231, 759, 760, 763
key signatures 186
lyrics 247, 692, 693
master pages 304
notehead sets 710
noteheads 711, 714, 715
notes 134
octave lines 221, 586
ornaments 230, 760
pauses 225, 664
pedal lines 240, 771
percussion legends 1033
playing techniques 238, 790
rehearsal marks 811
repeat endings 254
repeat markers 254
resetting 281
rhythm slashes 1044
syllables 694
templates 60
tempo marks 196, 198, 951
text 371
ties 977
time signatures 191, 983, 991
tracks 414
tremolos 255, 999
tuplets 169, 1007

U
una corda pedal 771

MIDI controller 788
uncompressed MusicXML 67
underlines

fingerings 644
unison ranges 934

colors 935

unisons 929
altered 949
arranging 286
deleting 286
divisi 934
restoring 934

units
beats 126, 198, 251, 280, 960
measurement 57
metronome marks 280, 960
quantization 71
rhythmic grid 144
swing playback 438
system track 275
tempo 198, 251
time 126, 446
tuplets 169
video 126

Universal Indian Drum Notation 1037
unlinking

dynamics 635
music frames 329
slurs 877

unmeasured tremolos 999
playback 1005

unpitched percussion 1019
articulations 465, 1023
cues 596
default settings 1021
drum sets 111, 1020
dynamics in kits 1025
engraving options 1021
exporting kits 1020
ghost notes 1023
grid kit presentation 111–114
groups 111
importing kits 1021
Indian drum notation 1037
individual instruments 1019
instrument order 113
kits 105, 107, 1019, 1020
legends 1031, 1032, 1034
MIDI files 1037
moving notes 1023
MusicXML files 1037
naming groups 112
notation options 1021
notations 1023
note input 154–156, 409
noteheads 1027, 1030
parentheses 1023
percussion maps 450, 460
Play mode 409, 1036
playback 450, 460, 465, 1027
playing techniques 465, 1022, 1024, 1027, 1029
presentation types 107, 1019, 1025, 1026
rhythm slashes 107, 1045
scrapes 790
staff labels 904
staves 107, 1025, 1026
stem direction 107, 156, 1034, 1036
stickings 1024
techniques 790
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unpitched percussion (continued)
tremolos 465
tuplets 1024
voices in kits 1034, 1035

unscaling tuplets 1010
up-bow breath marks 666
up-stem voices 1039

adding 159
stem direction 943

upbeats 983, 985
inputting 191

upper case
flow numbers 334
repeat marker text 831
Roman numerals 334
staff labels 899

upper notes
trills 744

user interface 14, 33
music area 15
panels 16
status bar 17
toolbar 14
toolboxes 15
transport options 35
windows 33

V
values

frame rates 126
latency compensation 180
metronome marks 280, 960
rhythmic grid 42, 145
timecodes 126, 820

valves
fingerings 649

velocity
expression maps 452
MIDI import 70

verse numbers 705
hiding 706
punctuation 706
showing 706

versions
files 62

vertical alignment
text 338

vertical justification
staves 350, 391, 393
systems 350, 391, 393

vertical position
articulations 499–503
bar numbers 527, 528
breath marks 667
caesuras 667
changing 280
chord symbols 575
cues 596, 597
dynamics 614
fermatas 667
fingerings 639
flipping items 280

vertical position (continued)
flow headings 318, 346, 348
instruments 101
layouts 124
lyrics 690, 692, 695
markers 814, 815, 820
ornaments 731
pauses 666
pedal lines 777
players 101
playing techniques 791, 793
rehearsal marks 805, 809, 925, 926
repeat endings 825, 925, 926
repeat markers 835, 836, 926
rests 859
rhythm slashes 852
slurs 869
stacking order, See vertical stacking order
staves 350, 391, 393, 396
system objects 926
system text 926
systems 350, 391, 393
tacets 354
tempo marks 925, 926, 953
text 338, 374, 375, 925
ties 966
time signatures 925, 986, 988, 992, 995
timecodes 814, 820
tremolos 1001
trills 731
tuplets 1007

vertical spacing
articulations 499, 501
ossia staves 917
percussion kits 114
staves, See staff spacing
systems, See system spacing
tacets 354

vertical stacking order 594
accidentals 490
changing 594

vibrato 790
inputting 238, 242, 243

Video Properties dialog 126
videos 125

adding 127
audio 129, 443
dialog 126
flows 89
formats 125
frame rates 129, 130
hiding 128
locating 127
markers 427, 814
mixer 443
panel 250
reloading 127
removing 129
size 128
start position 127
syncing 127
timecodes 819, 820
track 429
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videos (continued)
volume 129
window 128

Viennese accidental duration rule 496
view options 43

bar numbers 526
bar repeats 842
changing 42
chord symbol signposts 574
cues 611, 612
divisi 935
frame break signposts 358
full screen mode 50
galley view 43, 50
layouts 37, 46
mixer 445
moving music 43
music area 38, 44, 50
notes 1041
page arrangements 42, 44, 50
page view 43, 50
panels 18, 40
part layouts 46
percussion legends 1031
playhead 430, 447
rests 863
signposts 283
slash regions 850
system break signposts 360
system track 276
tabs 37, 46
time signature signposts 996
timecode 447
tracks 413, 429
transport 447
types 43
unison ranges 935
video window 128
voices 1039, 1041
windows 49
zoom 45, 413

vivace 950
inputting 196, 198, 200

vocal staves
divider arrows 936
staff grouping 60, 558
staff labels 897, 899
title case 899
uppercase 899

voice column index 1039, 1042
default settings 139
ledger lines 725
swapping order 1042

voices 1039
accidental stacking order 490
adding 159
alignment 1039
articulations 499
bar rests 165
beaming 944
caret 146, 159
changing 284, 287, 288, 1044
colors 1039, 1041

voices (continued)
column index 1042
copying 284
creating new 159
cues 607
deleting 1041
direction 851
divider arrows 936
drum sets 111
dynamics 210, 212, 622
fermatas 666, 670
filters 278
grace notes 658
hiding 852
inputting 159
ledger lines 725
merging 286
MIDI recording 178
moving notes 286
notation options 1040
order 139, 1042
pasting notes into 284
percussion kits 1034–1036
placement 1039
position 1039
rests 859, 861, 866
rhythm dots 725, 726
rhythm slashes 160, 851
selecting 273
showing 852
slash regions 852
slashes 160, 287, 851, 1044
slurs 873
stem direction 943, 946, 1034, 1036, 1039, 1043
swapping contents 288
swapping order 1042
switching between 159
ties 970, 971, 979

volta lines, See repeat endings
volume

channel meters 443
dynamics 613, 637
metronome click 179
MIDI 638
mixer 443
playback 452, 637
resetting 434
silence playback template 436
velocity 452
video audio 129

VST and MIDI Instruments panel 400, 402
VST instruments 403

endpoints 447
loading 404
microtonal playback 683
percussion maps 450
playback 447, 451, 460
playback templates 436
ports 448
whitelisting VST 2 plug-ins 404
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W
walker noteheads 714
warnings

different Dorico versions 62
watermarks 485
WAV files

exporting 76
wavy lines, See wiggly lines
wedge noteheads 712
weight

tuplet numbers/ratios 1018
Western tonality

key signatures 671
octave divisions 674

white noteheads 710, 711
whitelisting plug-ins 404
whole notes 9, 134
whole step trills 737, 742

appearance 740
hiding 734, 738
position 741
showing 734, 738

whole tone chord symbols 215
width

accidentals 491
barlines 509
braces 556
brackets 556, 557
empty bars 506
enclosures 523, 807
extra staves 916
flared hairpins 629
frames 323, 340
graphics 569, 678
H-bar rests 864
hairpin aperture 628
ledger lines 489, 724
note durations 466
noteheads 713
ossia staves 919
system dividers 925
systems 349, 390
text borders 338, 376

wiggly lines 753
glissando lines 753, 754
jazz articulations 763
trills 735, 736

wildcards 332
wind instruments

playing techniques 241
windows

floating 34
mixer 443, 445
moving tabs 49
multiple 46, 48, 49
opening 20, 49
playback 49
project 33
splitting 48
tabs 48
transport 446

windows (continued)
video 128
workspaces 45

winged brackets 558
workspaces 29

key commands 11, 55
options 34, 35
preferences 51
setting up 45

wrapping text
repeat markers 833

Write mode 17, 131
caret 148
inputting notations 182
inputting notes 145
inputting vs. editing 143
notation options 139
note input options 141
panels 40, 131, 134, 135, 139
signposts 281
switching 131
system track 275
text editor 266
toolboxes 41, 131, 132, 137
Transpose dialog 175

Z
zig-zag arrangement

accidentals 490
zoom 42

bar repeats 842
changing 45
cues 611, 612
drum editor 413
event display 413
options 42, 45
piano roll editor 413
slash regions 850

Index
 

1123
Dorico 2.2.20


	Table of Contents
	Introduction
	Platform-independent documentation
	Usage of musical terms
	Conventions
	Typographical elements
	Markup
	Key commands
	Key commands in Dorico Pro


	How you can reach us

	First steps
	Getting around
	Opening a template
	Quick tour of the user interface
	Functions of the modes
	Hiding/Showing panels
	Working with tabs and windows
	Opening a new tab
	Opening a new window


	Starting a new project
	Adding a solo player
	Creating a flow
	Creating a layout

	Writing music
	Inputting your first notes
	Adding a time signature
	Adding a key signature
	Inputting your first chord


	Dorico Pro concepts
	Design philosophy and higher-level concepts
	Key musical concepts
	Projects in Dorico Pro
	Modes in Dorico Pro
	Options dialogs in Dorico Pro
	Instruments in Dorico Pro
	Players in Dorico Pro
	Groups in Dorico Pro
	Flows in Dorico Pro
	Layouts in Dorico Pro


	User interface
	Windows
	Toolbar
	Workspace options
	Mini transport

	Tab bar
	Project start area
	Music area
	Print preview area
	Panels
	Disclosure arrows
	Toolboxes
	Status bar
	Selection tools
	Selecting multiple items using marquee selections
	Moving the view

	View types
	Page arrangements for page view
	Zoom options
	Zooming in/out of the music area



	Workspace setup
	Switching between layouts
	Opening new tabs
	Closing tabs
	Switching between tabs
	Changing the order of tabs
	Showing multiple tabs in the same project window
	Moving tabs to another tab group
	Moving tabs to other windows
	Opening multiple project windows
	Changing to full screen mode
	Switching to galley/page view

	Preferences dialog
	Key Commands page in the Preferences dialog
	Interactive Dorico Pro key commands map
	Searching for the key commands of functions
	Assigning key commands
	Assigning MIDI commands
	Changing the keyboard layout
	Removing key commands
	Resetting key commands
	Changing your preferred unit of measurement


	Project and file handling
	Hub
	Starting new projects
	Starting new projects from project templates
	Brackets according to project template categories

	Opening projects/files
	Opening recent projects from the Hub

	Projects from different versions of Dorico
	File import and export
	Importing flows
	Flow Import Options dialog

	Exporting flows
	Export Flows dialog

	Importing MusicXML files
	Exporting MusicXML files
	Export MusicXML dialog

	Importing MIDI
	MIDI Import Options dialog
	MIDI Quantize Options dialog

	Exporting MIDI
	Export MIDI dialog

	Importing tempo tracks
	Import Tempo Track dialog

	Exporting tempo tracks
	Export Tempo Track dialog

	Exporting audio
	Export Audio dialog


	Auto-save
	Recovering auto-saved projects
	Changing the auto-save frequency
	Changing the auto-save location
	Disabling auto-save

	Project backups
	Changing the number of backups per project
	Changing the backup location


	Setup mode
	Project window in Setup mode
	Players panel
	Instrument picker

	Layouts panel (Setup mode)
	Flows panel

	Project Info dialog
	Layout Options dialog
	Making layout-specific changes in Layout Options

	Players, layouts, and flows
	Players
	Adding solo/section players
	Duplicating players
	Player, layout, and instrument names
	Edit Instrument Names dialog
	Changing player names
	Changing layout names
	Changing instrument names

	Changing the orchestral order of players
	Deleting players

	Ensembles
	Adding ensembles

	Instruments
	Instrument numbering
	Transposing instruments
	Adding instruments to players
	Adding empty percussion kits to players
	Combining individual percussion instruments into kits
	Changing instruments
	Moving instruments between players
	Deleting instruments
	Edit Percussion Kit dialog
	Adding instruments to percussion kits
	Changing instruments in percussion kits
	Defining percussion kits as drum sets
	Creating groups of instruments within grid presentation percussion kits
	Renaming groups in grid presentation percussion kits
	Deleting groups within grid presentation percussion kits
	Changing the positions of instruments within percussion kits
	Changing the size of gaps between lines in percussion grids
	Removing individual instruments from percussion kits


	Player groups
	Adding groups of players
	Renaming player groups
	Deleting player groups
	Adding players to groups
	Moving players between groups
	Removing players from groups

	Flows
	Adding flows
	Changing the players assigned to flows
	Flow names and flow titles
	Renaming flows in Setup mode
	Changing flow titles in the Project Info dialog

	Deleting flows

	Layouts
	Creating layouts
	Changing the players assigned to layouts
	Changing the flows assigned to layouts
	Renaming layouts
	Making layouts transposing/concert pitch
	Concert vs. transposed pitch

	Sorting layouts
	Renumbering layouts
	Deleting layouts
	Restoring default layouts

	Videos
	Supported video formats
	Video Properties dialog
	Adding videos
	Changing the start position of videos
	Hiding/Showing the Video window
	Changing the size of the Video window
	Removing videos
	Changing the volume of video audio
	Frame rates
	Changing the project frame rate



	Write mode
	Project window in Write mode
	Notes toolbox
	Notes panel
	Properties panel (Write mode)
	Changing the properties of individual notes and items

	Notations toolbox
	Notations panel

	Notation Options dialog
	Making flow-specific changes in Notation Options

	Note Input Options dialog
	Inputting vs. editing
	Mouse input settings

	Rhythmic grid
	Changing the rhythmic grid value

	Note input
	Caret
	Activating the caret
	Moving the caret manually

	Changing the input pitch setting
	Inputting notes
	Register selection during step input
	Activating/Deactivating mouse input
	Inputting notes with rhythm dots
	Inputting notes in Insert mode
	Inputting notes in percussion kits
	Note input setup for percussion kits
	Default note selection during step input for percussion kits


	Selecting note/rest durations
	Changing the duration of notes
	Forcing the duration of notes/rests

	Inputting notes into multiple voices
	Inputting notes into slash voices

	Inputting accidentals
	Respelling accidentals
	Changing accidentals
	Accidental selection during MIDI input
	Disabling automatic accidental respelling


	Inputting rests
	Inputting bar rests during step input

	Inputting ties
	Inputting grace notes
	Inputting chords
	Inputting tuplets
	Tuplets popover

	Adding notes above/below existing notes
	Add intervals popover

	Changing the pitch of individual notes
	Transposing existing notes with the add intervals popover
	Repitching notes without changing their rhythm
	Transpose dialog
	Transposing selections


	MIDI recording
	Inputting notes using MIDI recording
	Retrieving played notes that you did not record
	Repeats in MIDI recording

	Requantizing notes
	Changing the click settings
	Changing the count-in duration
	Optimization for MIDI recording
	Changing the MIDI latency compensation value
	Changing the audio device buffer size

	Changing the sustain pedal controller settings for MIDI recording/import
	Disabling MIDI input devices

	Notations input
	Inputting articulations
	Key commands for articulations

	Inputting fingerings
	Fingerings popover

	Input methods for key signatures
	Key signatures popover
	Key Signatures, Tonality Systems, and Accidentals panel
	Inputting key signatures with the popover
	Inputting key signatures with the panel

	Input methods for time signatures
	Time signatures popover
	Time Signatures (Meter) panel
	Inputting time signatures with the popover
	Inputting time signatures with the panel

	Input methods for tempo marks
	Tempo popover
	Tempo panel
	Inputting tempo marks with the popover
	Inputting tempo marks with the panel

	Input methods for bars and barlines
	Bars and barlines popover
	Bars and Barlines panel
	Inputting bars/beats with the popover
	Inputting bars with the panel
	Inputting bars/beats with the system track
	Inputting barlines with the popover
	Inputting barlines with the panel

	Input methods for dynamics
	Dynamics popover
	Dynamics panel
	Inputting dynamics with the popover
	Inputting dynamics with the panel

	Input methods for chord symbols
	Chord symbols popover
	Navigation during chord symbol input

	Chord symbol input options for MIDI keyboards
	Inputting chord symbols
	Inputting polychord chord symbols
	Indicating root notes in chord symbols
	Indicating altered bass notes in chord symbols

	Input methods for clefs and octave lines
	Clefs and octave lines popover
	Clefs panel
	Inputting clefs with the popover
	Inputting clefs with the panel
	Inputting octave lines with the popover
	Inputting octave lines with the panel

	Input methods for holds and pauses
	Holds and pauses popover
	Holds and Pauses panel
	Inputting holds and pauses with the popover
	Inputting holds and pauses with the panel
	Correct positioning for caesura input

	Input methods for ornaments, arpeggio signs, glissando lines, and jazz articulations
	Ornaments popover
	Ornaments panel
	Inputting ornaments with the popover
	Inputting ornaments with the panel
	Inputting arpeggio signs with the popover
	Inputting arpeggio signs with the panel
	Inputting glissando lines with the popover
	Inputting glissando lines with the panel
	Inputting jazz articulations with the popover
	Inputting jazz articulations with the panel

	Input methods for playing techniques and pedal lines
	Playing techniques popover
	Playing Techniques panel
	Inputting playing techniques with the popover
	Inputting playing techniques with the panel
	Inputting pedal lines, retakes, and pedal level changes with the popover
	Adding retakes and pedal level changes to existing pedal lines with the popover

	Inputting pedal lines, retakes, and pedal level changes with the panel
	Adding retakes and pedal level changes to existing pedal lines with the panel


	Inputting lyrics
	Lyrics popover
	Navigation during lyric input

	Inputting rehearsal marks
	Inputting markers/timecodes
	Markers section of the Video panel
	Add Marker dialog

	Find Tempo dialog

	Input methods for repeats and tremolos
	Repeats popover
	Repeat Structures panel
	Inputting repeat endings with the popover
	Adding additional repeat endings with the popover

	Inputting repeat endings with the panel
	Adding additional repeat endings with the panel

	Inputting repeat markers with the popover
	Inputting repeat markers with the panel
	Inputting tremolos with the popover
	Inputting tremolos with the panel
	Inputting slash regions
	Inputting bar repeats

	Inputting slurs
	Inputting text
	Text editor options in Write mode
	Editing text

	Inputting cues
	Cues popover
	Cues panel
	Cue suggestions
	Inputting cues using cue suggestions


	Editing and selecting
	Selecting/Deselecting notes and items individually
	Selecting more items of the same type
	Large selections
	System track
	Hiding/Showing the system track
	Selecting bars with the system track
	Selecting beats with the system track

	Filters
	Playing/Muting notes during note input/selection
	Playing all/individual notes in chords during note input/selection
	Disabling automatic linking of dynamics and slurs when pasting
	Changing existing items
	Changing the staff-relative placement of items
	Resetting the appearance of items
	Resetting the position of items

	Signposts
	Hiding/Showing signposts

	Arranging tools
	Deleting notes and items
	Copying and pasting items
	Copying and pasting notes into different voices
	Copying and pasting items to multiple staves
	Copying and pasting items to fill a selected range
	Moving notes to other staves
	Swapping the contents of staves
	Reducing music onto fewer staves
	Exploding music onto multiple staves
	Changing the voice of existing notes
	Swapping the contents of voices

	Splitting flows

	Engrave mode
	Project window in Engrave mode
	Engrave toolbox
	Formatting panel
	Pages panel
	Properties panel (Engrave mode)
	Selecting handles on items


	Engraving Options dialog
	Making project-wide changes in Engraving Options

	Master pages
	Master page sets
	Creating master page sets
	Renaming master page sets
	Deleting master page sets
	Applying master page sets to layouts

	Master page types
	Adding master pages
	Renaming master pages
	Deleting master pages

	Master page editor
	Customizing master pages

	Master page overrides
	Removing master page overrides
	Inserting pages
	Deleting pages
	Inserting page number changes
	Page Number Change dialog

	Removing page number changes
	Assigning master pages to pages
	Removing master page changes
	Inserting flow heading changes
	Insert Flow Heading Change dialog

	Removing flow heading changes
	Swapping pages


	Flow headings
	Flow heading editor
	Customizing flow headings
	Adding flow headings
	Renaming flow headings
	Deleting flow headings

	Frames
	Inputting frames
	Moving frames
	Changing the size/shape of frames
	Selecting frame handles
	Copying frames
	Music frames
	Music frame chains
	Music frame selectors
	Assigning frame chains to music frames
	Unlinking music frames from frame chains
	Changing the order of music frames
	Assigning flows to frame chains
	Assigning players to frame chains


	Text frames
	Text tokens
	Entering text in text frames
	Adding borders to text frames
	Changing the thickness of text frame borders
	Changing the padding in text frames

	Changing the vertical alignment of text in text frames
	Changing the horizontal alignment of text in text frames

	Graphics frames
	Loading images into graphics frames

	Frame constraints
	Defining frame constraints


	Page layouts
	Changing page margins
	Changing the page size and orientation
	Starting layouts on left-hand pages
	Allowing/Disallowing multiple flows on the same page
	Changing when the First master page is used
	Hiding/Showing flow headings
	Changing the margins above/below flow headings
	Hiding/Showing information in running headers above flow headings
	Changing the music frame margins in layouts
	Changing the padding in music frames individually
	Changing the justification of final systems
	Changing the vertical justification of staves/systems
	Hiding/Showing empty staves
	Tacets
	Hiding/Showing tacets
	Changing the text shown in tacets
	Changing the margins above/below tacets

	Casting off
	Fixing the number of bars per system
	Fixing the number of systems per frame

	Frame breaks
	Inserting frame breaks
	Making selections into frames
	Hiding/Showing frame break signposts
	Deleting frame breaks

	System breaks
	Inserting system breaks
	Making selections into systems
	Hiding/Showing system break signposts
	Deleting system breaks

	Part formatting propagation
	Propagate Part Formatting dialog
	Copying part formatting to other layouts
	Copying property settings to other layouts


	Text formatting
	Edit Font Styles dialog
	Music Fonts dialog
	Paragraph Styles dialog
	Creating paragraph styles
	Changing the default horizontal alignment of text styles
	Deleting paragraph styles

	Character Styles dialog
	Creating character styles
	Deleting character styles

	Text objects vs. text in text frames
	Text editor options in Engrave mode
	Changing the paragraph style of text
	Paragraph style overrides

	Moving text objects graphically
	Changing the placement of text objects relative to the staff
	Enabling/Disabling text collision avoidance
	Adding borders to text objects
	Changing the thickness of text object borders
	Changing the padding around text objects

	Erasing the background of text objects

	Music symbols
	Edit Music Symbol dialog

	Note spacing
	System fullness indicator
	Changing the default note spacing
	Note Spacing page in Layout Options

	Changing note spacing from specific points
	Note Spacing Change dialog
	Resetting note spacing from specific points
	Deleting note spacing changes at specific points

	Adjusting note spacing at individual rhythmic positions
	Adjusting the spacing of individual notes/items independently of their rhythmic positions
	Changing the start/end position of systems
	Removing individual changes to note spacing


	Staff spacing
	Changing the default staff/system spacing
	Per-layout vertical spacing options

	Changing the staff spacing in galley view
	Moving individual staves/systems vertically
	Removing individual changes to staff spacing

	Moving multiple systems simultaneously
	Copying staff spacing changes to other pages
	Copy Staff Spacing dialog



	Play mode
	Project window in Play mode
	Play toolbox
	VST and MIDI Instruments panel
	Loading VST and MIDI instruments manually
	Whitelisting VST instruments


	Playback Options dialog
	Event display
	Piano roll editor
	Drum editor
	Inputting notes in the event display
	Moving notes in the event display
	Lengthening/Shortening notes in the piano roll editor
	Transposing notes in the piano roll editor
	Deleting notes in the event display
	Zooming in/out of tracks in the event display

	Tracks
	Player tracks
	Instrument tracks
	Playing techniques lanes
	Hiding/Showing playing techniques lanes

	Automation lanes
	Hiding/Showing automation lanes
	Inputting automation in automation lanes
	Moving automation events
	Deleting automation events


	Time track
	Inputting tempo changes in the Time track
	Moving tempo changes in the Time track
	Changing the tempo in the Time track
	Deleting tempo changes in the Time track

	Chords track
	Enabling chord symbol playback

	Markers track
	Inputting markers in the Markers track

	Video track
	Expanding/Collapsing tracks
	Changing the height of tracks
	Hiding/Showing tracks

	Playhead
	Moving the playhead

	Playing back music
	Muting/Soloing tracks
	Muting/Soloing instruments
	Deactivating mute/solo instrument states

	Muting notes/items individually
	Resetting changes to volume faders
	Changing the tempo mode
	Changing the pre-roll duration
	Changing the playback tuning
	Repeats in playback

	Playback templates
	Changing/Resetting the playback template

	Swing playback
	Swing ratios and rhythmic feels
	Enabling swing playback project-wide
	Enabling swing playback for specific sections/players
	Deleting rhythmic feel changes
	Creating custom rhythmic feels for swing playback
	Rhythmic Feel dialog

	Mixer
	Mixer channel strips
	Hiding/Showing the Mixer window

	Transport window
	Changing the content shown in the transport display

	Endpoints
	Endpoint Setup dialog
	Assigning instruments to endpoints
	Assigning expression/percussion maps to endpoints

	Expression maps
	Expression Maps dialog
	Technique Combinations dialog

	Creating new expression maps
	Creating playing technique combinations
	Importing expression maps
	Exporting expression maps

	Percussion maps
	Percussion Maps dialog
	Creating custom percussion maps
	Importing percussion maps
	Exporting percussion maps
	Defining how combinations of articulations and single-note tremolos sound in playback

	Played vs. notated note durations
	Changing the played duration of notes
	Removing changes to the played duration of notes


	Print mode
	Project window in Print mode
	Layouts panel (Print mode)
	Print Options panel

	Printing layouts
	Printing/Exporting a page range
	Specifying printing options (macOS only)

	Exporting layouts as graphic files
	Specifying an export path for graphics files
	Export File Names dialog
	Monochrome and color graphics processing
	Embedding of fonts in PDF and SVG files

	Printers
	Page arrangements for printing/exporting
	Booklet printing

	Duplex printing
	Page sizes and paper sizes
	Paper orientation
	Paper size and orientation setup

	Graphics file formats
	Image resolution

	Annotations

	Notation reference
	Introduction
	Accidentals
	Deleting accidentals
	Hiding/Showing or parenthesizing accidentals
	Project-wide engraving options for accidentals
	Stacking of accidentals
	Accidental stacking rules for dense chords
	Kerning of accidental columns

	Altered unisons
	Changing how altered unisons appear

	Microtonal accidentals
	Inputting microtonal accidentals

	Accidental duration rules
	Changing the accidental duration rule
	Double accidental cancellation
	Common practice accidental duration rule
	Hiding/Showing cautionary accidentals

	Second Viennese School accidental duration rule
	Modernist accidental duration rule


	Articulations
	Copying articulations
	Changing articulations
	Deleting articulations
	Project-wide engraving options for articulations
	Positions of articulations
	Order of articulations
	Changing the positions of articulations on tied notes
	Changing the horizontal position of staccato marks
	Moving individual articulations vertically
	Changing the placement of articulations individually
	Changing the default placement of articulations

	Articulations in playback

	Bars
	Deleting bars/beats
	Deleting bars/beats with the system track
	Deleting empty bars at the end of flows
	Deleting the contents of bars

	Changes to the length of bars
	Changing the width of empty bars
	Splits in bars
	Combining bars

	Barlines
	Project-wide engraving options for barlines
	Per-flow notation options for barlines
	Changing the default barline at the end of flows
	Hiding/Showing systemic barlines on single-staff systems

	Changing the barline shown at key signature changes
	Deleting barlines
	Barline spacing
	Moving barlines rhythmically
	Moving barlines graphically

	Barlines across staff groups
	Showing barlines across all staves at time signature changes
	Inputting custom barline joins
	Deleting barline joins individually
	Lengthening/Shortening custom barline joins


	Bar numbers
	Appearance of bar numbers
	Changing the bar number frequency
	Changing the bar number paragraph styles
	Changing the bar number paragraph style used in layouts
	Changing the bar number enclosure type
	Bar number enclosure size and padding values


	Bar numbers in parts
	Hiding/Showing bar number ranges on multi-bar rests
	Hiding/Showing guide bar numbers
	Positions of bar numbers
	Changing the horizontal position of bar numbers
	Changing the distance between bar numbers and the staff/other objects
	Changing the placement of bar numbers relative to the staff
	Moving bar numbers graphically
	Hiding bar numbers at time signatures shown at system object positions

	Bar number changes
	Adding bar number changes
	Deleting bar number changes

	Subordinate bar numbers
	Adding subordinate bar numbers
	Returning to the primary bar number sequence
	Changing the appearance of subordinate bar numbers

	Bar numbers and repeats
	Including/Excluding repeats from the bar number count
	Changing which playthroughs are shown in bar numbers
	Changing the appearance of bar numbers for subsequent repeats



	Beaming
	Beaming notes together manually
	Unbeaming notes

	Changing the direction of partial beams
	Beam groups
	Per-flow changes to beam grouping defaults
	Beams according to time signatures
	Splitting beam groups
	Resetting beam grouping

	Beam placement relative to the staff
	Changing the placement of beams relative to the staff
	Removing beam placement changes

	Beam slants
	Changing beam slants

	Centered beams
	Creating centered beams
	Removing centered beams

	Creating cross-staff beams
	Optical spacing for cross-staff beams
	Changing to optical cross-staff beam spacing

	Cross-staff beam placement in multiple staves

	Beam corners
	Secondary beams
	Changing the number of beam lines in secondary beams
	Resetting changes to the number of secondary beam lines

	Tuplets within beams
	Stemlets
	Showing stemlets in beam groups
	Removing stemlets from beam groups

	Fanned beams
	Creating fanned beams
	Changing the direction within fanned beams


	Note and rest grouping
	Conventions for beam grouping according to meter
	Creating custom beat groupings for meters

	Brackets and braces
	Secondary brackets
	Sub-sub-brackets
	Project-wide engraving options for brackets and braces
	Changing the appearance of bracket ends

	Brackets according to ensemble type
	Changing bracket grouping according to ensemble type

	Custom staff grouping
	Inputting custom bracket/brace groups
	Lengthening/Shortening custom brackets/braces
	Resetting bracket and barline changes
	Deleting bracket and barline changes


	Chord symbols
	Chord components
	Project-wide engraving options for chord symbols
	Chord symbol appearance presets
	Project Default Chord Symbol Appearances dialog
	Edit Chord Symbol Appearance dialog
	Edit Chord Symbol Component dialog
	Setting single chord symbol overrides as the project default
	Resetting the appearance of chord symbols with single overrides
	Changing chord symbol fonts

	Transposing chord symbols
	Hiding/Showing chord symbols
	Hiding/Showing the root and quality of chord symbols
	Positions of chord symbols
	Moving chord symbols rhythmically
	Moving chord symbols graphically
	Changing the staves above which chord symbols appear
	Changing the layouts in which chord symbols appear

	Changing the enharmonic spelling of chord symbols
	Showing chord symbols as modes
	Resetting the enharmonic spelling of chord symbols

	Chord symbols imported from MusicXML

	Clefs
	General placement conventions for clefs
	Project-wide spacing gaps for clefs
	Moving clefs rhythmically
	Moving clefs graphically

	Deleting clefs
	Default size of clef changes
	Changing the position of clefs relative to grace notes
	Setting different clefs for concert/transposed pitch
	Transposing clefs

	Octave lines
	Project-wide engraving options for octave lines
	Lengthening/Shortening octave lines
	Changing the angles of octave lines
	Resetting the angles of octave lines

	Positions of octave lines
	Moving octave lines rhythmically
	Moving octave lines graphically
	Changing the alignment of octave line numerals relative to notes
	Changing the position of octave line numerals relative to accidentals
	Changing the placement of octave lines relative to the staff

	Deleting octave lines
	Octave lines in Engrave mode
	Lengthening/Shortening octave line hooks

	Tucking index properties
	Changing the vertical stacking order of octave lines


	Cues
	General placement and notation conventions for cues
	Rhythmic cues
	Changing existing cues to rhythmic cues
	Changing the distance between rhythmic cues and the staff
	Changing the staff position of cues from unpitched percussion source instruments

	Changing the octave of cues
	Hiding/Showing octave transpositions in cue labels
	Moving cues
	Lengthening/Shortening cues
	Deleting cues
	Project-wide engraving options for cues
	Cue contents
	Cue labels
	Changing the information included in cue labels project-wide
	Changing the text shown in cue labels
	Changing the placement of cue labels relative to the staff
	Moving cue labels graphically

	Notations in cues
	Changing the notations included in cues

	Hiding/Showing cues in layouts
	Hiding cues individually

	Stem direction in cues
	Overlapping cues
	Overriding default stem directions in single-voice cues

	Ties in cues
	Rests in cues
	Hiding/Showing padding rests in cues
	Hiding/Showing bar rests in cues

	Clef changes in cues
	Changing the clef shown in cues

	Viewing options for cues
	Hiding/Showing cue highlights
	Hiding/Showing cue note colors


	Dynamics
	Types of dynamics
	Project-wide engraving options for dynamics
	Positions of dynamics
	Changing the placement of dynamics relative to the staff
	Changing the horizontal beat-relative position of dynamics
	Changing the alignment of immediate dynamics relative to noteheads
	Moving dynamics rhythmically
	Moving dynamics graphically
	Aligning dynamics
	General placement conventions for hairpins relative to barlines
	Changing the project-wide position of hairpins relative to barlines


	Showing dynamics in parentheses
	Erasing the background of dynamics
	Changing the erasure padding of dynamics

	Copying dynamics
	Deleting dynamics
	Voice-specific dynamics
	Niente hairpins
	Changing the appearance of individual niente hairpins

	Expressive text
	Adding expressive text to existing dynamics
	Hiding immediate dynamics

	Gradual dynamics
	Lengthening/Shortening gradual dynamics and groups of dynamics
	Changing the angle of hairpins
	Changing the aperture of hairpins
	Hiding/Showing flared ends on hairpins
	Changing the size of flared ends on hairpins

	Adding poco a poco text to gradual dynamics
	Gradual dynamic spacing
	Gradual dynamics that start/end partway through notes

	Gradual dynamics truncated by immediate dynamics

	Groups of dynamics
	Grouping dynamics together
	Ungrouping dynamics and removing dynamics from groups

	Dynamics linked across multiple staves
	Linking dynamics together
	Unlinking dynamics

	Dynamics font styles
	Editing the dynamic modifier font styles
	Editing the dynamic glyph font style

	Playback Options for dynamics
	Sustaining and non-sustaining instruments
	VST Expression Maps for volume types


	Fingering
	General placement conventions for fingering
	Project-wide engraving options for fingerings
	Changing fingerings to substitution fingerings
	Changing the rhythmic position of substitution fingerings

	Changing existing fingerings
	Moving fingerings graphically
	Resetting the positions of fingerings
	Changing the placement of fingerings relative to the staff
	Changing the position of individual fingerings relative to slurs, octave lines, and tuplet brackets

	Changing the size of fingerings
	Showing enclosures/underlines on fingerings
	Hiding/Showing fingering
	Deleting fingerings
	Fingering font styles
	Changing the font used for fingerings project-wide
	Editing the fingering font styles
	Showing individual fingerings in italics

	Cautionary fingerings
	Changing the appearance of cautionary fingerings

	Fingerings for valved brass instruments
	Showing horn branch indicators
	Changing the appearance of slide positions for brass instruments

	Hiding/Showing string fingering shift indicators
	Changing the direction of string fingering shift indicators

	Fingerings imported from MusicXML files

	Front matter
	Project information used in default master pages
	Adding dedications in master pages
	Adding player lists
	Changing the text in running headers in master pages

	Grace notes
	General placement conventions for grace notes
	Grace note placement in multiple-voice contexts
	Changing the position of grace notes relative to barlines

	Project-wide changes to the position of grace notes
	Grace note size
	Grace note slashes
	Changing the type of grace notes
	Moving slashes on grace note stems
	Changing the length of grace note slashes

	Grace note stems
	Grace note beams

	Holds and pauses
	Types of holds and pauses
	Types of fermatas
	Types of breath marks
	Types of caesuras

	Project-wide engraving options for holds and pauses
	Positions of holds and pauses
	Multiple holds and pauses at the same rhythmic position
	Changes to fermatas on single staves
	Moving holds and pauses rhythmically
	Moving holds and pauses graphically
	Changing the placement of fermatas relative to the staff
	Changing the number of fermatas per staff
	Positioning fermatas on barlines


	Key signatures
	Key signature arrangements
	Types of key signatures
	Project-wide engraving options for key signatures
	Tonality systems
	Equal Division of the Octave (EDO)
	Changing the tonality system
	Custom tonality systems
	Edit Tonality System dialog
	Custom divisions of the octave
	Custom accidentals
	Edit Accidental dialog

	Custom key signatures
	Edit Custom Key Signature dialog

	Playback of custom tonality systems


	Deleting key signatures
	Multiple simultaneous key signatures
	Positions of key signatures
	Project-wide spacing gaps for key signatures
	Moving key signatures rhythmically
	Moving key signatures graphically

	Transposing key signatures alongside selections
	Enharmonic equivalent key signatures
	Cautionary key signatures

	Lyrics
	General placement conventions for lyrics
	Project-wide engraving options for lyrics
	Filters for lyrics
	Selecting lyrics using filters

	Types of lyrics
	Changing the type of individual lyrics

	Types of syllables in lyrics
	Changing the syllable type of existing lyrics

	Changing the text of existing lyrics
	Positions of lyrics
	Moving lyrics rhythmically
	Moving lyrics graphically
	Changing the alignment of lyrics relative to notes

	Lyric hyphens and lyric extender lines
	Moving lyric extender lines and hyphens
	Lengthening/Shortening lyric extender lines and hyphens

	Deleting lyric lines
	Deleting lyrics individually

	Lyric line numbers
	Changing the line number and type of lyric lines
	Changing the line number of individual lyrics
	Changing the placement of lyric lines relative to the staff
	Changing the placement of individual lyrics relative to the staff

	Changing the font styles used for lyrics
	Showing lyrics in italics

	Verse numbers
	Hiding/Showing verse numbers project-wide
	Changing the punctuation of verse numbers

	Hiding/Showing verse numbers on individual lyrics

	East Asian elision slurs
	Hiding/Showing East Asian elision slurs


	Notes
	Project-wide engraving options for notes
	Changing the notehead design project-wide
	Showing differently shaped noteheads for each scale degree project-wide
	Showing note names in noteheads project-wide

	Notehead sets
	Notehead set designs
	Pitch-dependent notehead set designs
	Custom notehead sets
	Edit Notehead Sets dialog
	Edit Notehead dialog

	Changing the notehead design of individual noteheads

	Changing the size of notes
	Moving notes rhythmically
	Changing the width of ledger lines
	Hiding/Showing ledger lines

	Rhythm dot consolidation
	Changing the consolidation of rhythm dots
	Moving rhythm dots

	Specifying on which string individual notes are played

	Ornaments
	Project-wide engraving options for ornaments
	Changing ornament intervals
	Positions of ornaments
	Moving ornaments rhythmically
	Moving ornaments graphically
	Changing the placement of ornaments relative to the staff
	Changing the position of ornaments relative to slurs
	Changing the start position of trills

	Trills
	Hiding/Showing trill marks
	Changing the speed of trills
	Hiding/Showing speed changes in trill extension lines
	Hiding/Showing trill extension lines
	Lengthening/Shortening trills rhythmically

	Trill intervals
	Hiding/Showing trill interval accidentals
	Changing the intervals of existing trills
	Changing intervals partway through trills
	Trill interval appearance
	Changing the appearance of trill intervals
	Changing the position of trill interval indicators


	Trills in playback
	Sampled vs. generated trills
	Enabling/Disabling trill samples in playback
	Changing the playback speeds of trills
	Changing the starting pitch of trills


	Arpeggio signs
	Changing the type of arpeggio signs
	Changing the end appearance of arpeggio signs
	Length of arpeggio signs
	Lengthening/Shortening arpeggio signs

	General placement conventions for arpeggio signs
	Moving arpeggio signs rhythmically
	Moving arpeggio signs graphically
	Showing arpeggio signs before/after grace notes

	Project-wide engraving options for arpeggio signs
	Arpeggios in playback
	Changing arpeggio playback relative to the beat individually
	Changing the playback duration of arpeggios individually


	Glissando lines
	General placement conventions for glissando lines
	Project-wide engraving options for glissando lines
	Glissando lines across empty bars
	Changing the style of glissando lines
	Changing glissando line text
	Changing when glissando line text is shown

	Moving glissando lines graphically
	Changing the default angles of glissando lines project-wide
	Changing the angles of glissando lines individually


	Jazz articulations
	Jazz ornaments
	Project-wide engraving options for jazz articulations
	Moving jazz articulations graphically
	Positions of jazz articulations

	Changing the type/length of existing jazz articulations
	Changing the line style of smooth jazz articulations
	Deleting jazz articulations

	Page numbers
	Moving page numbers in master pages
	Page number paragraph styles
	Changing the page number numeral style
	Changing the page number numeral style for individual pages

	Hiding/Showing page numbers
	Hiding/Showing page numbers on individual pages


	Pedal lines
	Sustain pedal retakes and pedal level changes
	Sustain pedal lines in Engrave mode
	Changing the type of pedal line retakes
	Changing the start level of pedal lines
	Changing pedal levels at retakes and pedal level changes
	Changing the end level of pedal lines
	Removing retakes and pedal level changes

	Positions of pedal lines
	Moving pedal lines rhythmically
	Moving pedal lines graphically
	Changing the position of pedal lines relative to grace notes individually

	Lengthening/Shortening pedal lines
	Project-wide engraving options for pedal lines
	Pedal line start signs, hooks, and continuation lines
	Changing the start sign appearance of pedal lines
	Changing the type of hook at the start/end of pedal lines
	Lengthening/Shortening pedal line hooks

	Changing the continuation line type of pedal lines
	Lengthening/Shortening gaps and dashes in pedal continuation lines

	Changing the line width of pedal lines
	Parenthesizing pedal line continuation signs

	Pedal line start, continuation, and restorative text
	Changing the start text shown in pedal lines
	Changing the pedal line continuation text shown
	Changing the restorative text shown in una corda pedal lines

	Pedal lines in playback
	Pedal lines imported from MusicXML files

	Playing techniques
	Project-wide engraving options for playing techniques
	Positions of playing techniques
	Moving playing techniques rhythmically
	Moving playing techniques graphically
	Changing the placement of playing techniques relative to the staff

	Adding text to playing techniques
	Erasing the background of text playing techniques
	Changing the erasure padding of text playing techniques

	Hiding/Showing playing techniques
	Custom playing techniques
	Edit Playing Techniques dialog
	Edit Playing Technique dialog
	Edit Playback Playing Techniques dialog

	Using custom playing techniques in multiple projects

	Playing techniques in playback

	Rehearsal marks
	General placement conventions for rehearsal marks
	Project-wide engraving options for rehearsal marks
	Changing the rehearsal mark enclosure type
	Rehearsal mark enclosure size and padding values


	Positions of rehearsal marks
	Moving rehearsal marks rhythmically
	Moving rehearsal marks graphically

	Deleting rehearsal marks
	Changing the order of rehearsal marks
	Changing the rehearsal mark sequence type
	Adding prefixes/suffixes to rehearsal marks
	Editing the rehearsal mark font style

	Markers
	Project-wide engraving options for markers
	Changing the vertical position of markers
	Changing the text shown in markers
	Editing the marker/timecode font styles
	Moving markers rhythmically
	Changing the timecodes of markers
	Defining markers as important
	Hiding/Showing markers

	Timecodes
	Changing the initial timecode value
	Showing timecodes on a separate staff
	Hiding/Showing timecodes in markers
	Changing the timecode frequency

	Repeat endings
	Changing the total number of playthroughs in repeat endings
	Dividing playthroughs across repeat ending segments

	Project-wide engraving options for repeat endings
	Lengthening/Shortening segments in repeat endings
	Positions of repeat endings
	Moving repeat endings rhythmically
	Moving repeat endings graphically
	Repeat endings in Engrave mode


	Changing the text shown in repeat endings
	Changing the appearance of individual final repeat ending segments
	Lengthening/Shortening repeat ending hooks
	Repeat endings in MusicXML files

	Repeat markers
	Project-wide engraving options for repeat markers
	Repeat marker paragraph styles
	Changing the size of coda/segno symbols
	Changing the index for repeat markers
	Changing the text shown in repeat markers
	Showing repeat markers on one/two lines

	Changing the barline shown before codas
	Positions of repeat markers
	Moving repeat markers rhythmically
	Moving repeat markers graphically
	Changing the placement of repeat markers relative to the staff

	Including/Excluding repeats in playback after repeat jumps
	Changing the number of playthroughs at repeat barlines

	Bar repeats
	Project-wide engraving options for bar repeats
	Changing the length of the repeated phrase in bar repeat regions
	Moving bar repeat regions
	Lengthening/Shortening bar repeat regions
	Hiding/Showing bar repeat region highlights
	Bar repeat counts
	Changing the start count of bar repeats
	Changing the bar repeat count frequency
	Changing the bar repeat count appearance
	Changing the bar repeat count font
	Moving bar repeat counts

	Bar repeat grouping
	Changing bar repeat grouping


	Rhythm slashes
	Slash regions
	Hiding/Showing slash region highlights

	Project-wide engraving options for rhythm slashes
	Slashes in multiple-voice contexts
	Changing the voice direction of slash regions
	Changing the staff position of rhythm slashes
	Hiding/Showing notes alongside slash regions
	Hiding/Showing padding rests before/after slash regions

	Splitting slash regions
	Moving slash regions
	Lengthening/Shortening slash regions
	Hiding/Showing stems in slash regions
	Slash region counts
	Changing the start count of slash regions
	Changing the slash region count frequency
	Changing the slash region count appearance
	Moving slash region counts
	Changing the placement of slash region counts relative to the staff


	Rests
	General placement conventions for rests
	Implicit vs. explicit rests
	Implicit rests in multiple-voice contexts
	Turning explicit rests into implicit rests

	Per-flow notation options for rests
	Project-wide engraving options for rests
	Showing rest colors
	Deleting rests
	Hiding/Showing bar rests in empty bars
	Multi-bar rests
	Hiding/Showing multi-bar rests
	Hiding/Showing tacet al fine on multi-bar rests at the end of flows

	Moving rests vertically

	Slurs
	General placement conventions for slurs
	Slur position relative to tie chains
	Changing the position of slurs relative to tie chains

	Slur placement relative to grace notes
	Slur position relative to staff lines
	Slur endpoint position relative to other items

	Project-wide engraving options for slurs
	Cross-staff and cross-voice slurs
	Inputting cross-staff and cross-voice slurs

	Nested slurs
	Inputting nested slurs during step input
	Adding nested slurs to existing notes

	Moving slurs rhythmically
	Lengthening/Shortening slurs
	Slurs linked across multiple staves
	Linking slurs together
	Unlinking slurs

	Slur segments
	Changing the number of segments in individual slurs

	Slurs in Engrave mode
	Multi-segment slurs in Engrave mode
	Moving slurs and slur handles graphically
	Changing the angle of slurs
	Changing the thickness of slurs

	Short slurs that cover large pitch ranges
	Slur height
	Changing the height of slurs

	Slur shoulder offset
	Changing the shoulder offset of slurs

	Slur curvature direction
	Changing the curvature direction of slurs

	Slur styles
	Changing the style of slurs
	Changing the size of dashes/dots in slurs
	Changing the size of gaps in dashed/dotted slurs
	Changing individual slurs to flat slurs

	Slur collision avoidance
	Enabling/Disabling slur collision avoidance

	Slurs over system and frame breaks
	Slurs in playback

	Staff labels
	Instrument names in staff labels
	Staff label paragraph styles
	Project-wide engraving options for staff labels
	Grouping the staff labels of adjacent identical instruments
	Changing the staff label numbering style
	Showing vocal staff labels in uppercase/title case

	Changing the length of staff labels project-wide
	Changing the minimum indent for systems with staff labels

	Changing the length of staff labels at specific positions
	Hiding/Showing instrument change labels at the start of flows
	Instrument transpositions in staff labels
	Hiding/Showing instrument transpositions in staff labels
	Changing the position of instrument transpositions in full staff labels

	Staff labels for percussion kits

	Staves
	Per-layout options for staves
	Staff size
	Changing the staff size in layouts
	Changing the staff size from specific points
	Changing the size of individual staves
	Custom Staff Size dialog


	Changing the thickness of staff lines
	Deleting staves
	Extra staves
	Adding extra staves
	Moving the start/end positions of extra staves
	Showing extra staves across whole systems

	Ossia staves
	Adding ossia staves
	Moving the start/end positions of ossia staves
	Changing the size of ossia staves
	Changing the padding on ossias that start/end mid-bar
	Hiding/Showing ossia staves in the preamble
	Hiding/Showing ossia staves
	Deleting ossia staves
	Barlines on ossia staves
	Ossia staff labels
	Hiding/Showing staff labels on ossia staves


	System dividers
	Showing system dividers
	Changing the length of system dividers

	System objects
	Changing the positions of system objects
	Changing the placement of system objects relative to ossia staves

	System indents
	Changing the first system indent


	Divisi
	Change Divisi dialog
	Inputting divisi changes
	Editing existing divisi changes
	Moving divisi changes
	Ending divisi passages
	Unison ranges
	Showing unison range colors

	Divisi on vocal staves
	Hiding/Showing divide arrows on vocal staves

	Divisi staff labels
	Editing divisi staff labels individually
	Hiding/Showing divisi staff labels
	Changing the text shown in divisi change labels
	Hiding/Showing divisi change labels above staves

	Divisi in playback

	Stems
	Project-wide engraving options for stems
	Stem direction
	Changing the default stem direction behavior of notes on the middle line of staves
	Changing the stem direction of notes
	Changing the default stem direction of voices
	Removing stem direction changes

	Stem length
	Lengthening/Shortening stems

	Hiding stems
	Split stems for altered unisons

	Tempo marks
	Types of tempo marks
	Text in tempo marks
	Changing tempo text
	Showing abbreviated tempo text
	Adding poco a poco text to gradual tempo changes

	Positions of tempo marks
	Moving tempo marks rhythmically
	Moving tempo marks graphically
	Changing the end position of gradual tempo changes relative to barlines

	Lengthening/Shortening gradual tempo changes
	Hiding/Showing tempo marks
	Deleting tempo marks
	Project-wide engraving options for tempo marks
	Tempo mark components
	Changing the type and appearance of absolute tempo changes

	Metronome marks
	Changing the metronome mark value
	Showing the metronome mark value as a range
	Changing the relative tempo mark value
	Changing the final tempo at the end of gradual tempo changes

	Gradual tempo changes
	Changing the style of gradual tempo changes
	Changing the line style of gradual tempo changes
	Lengthening/Shortening gaps and dashes in gradual tempo changes
	Changing the line thickness of gradual tempo changes

	Tempo equations

	Ties
	General placement conventions for ties
	Project-wide engraving options for ties
	Tie chains
	Ties vs. slurs
	Non-standard ties
	Inputting ties between non-adjacent notes
	Hiding/Showing laissez vibrer ties

	Deleting ties
	Splitting tie chains
	Changing the position/shape of ties
	Tie shoulder offset
	Changing the shoulder offset of ties

	Tie height
	Changing the height of ties

	Tie styles
	Changing the style of ties
	Changing the size of dashes/dots in ties
	Changing the size of gaps in dashed/dotted ties

	Tie curvature direction
	Changing the curvature direction of ties


	Time signatures
	General conventions for time signatures
	Project-wide engraving options for time signatures
	Project-wide spacing gaps for time signatures
	Types of time signatures
	Pick-up bars
	Defining partial bars as pick-up bars or irregular bars

	Large time signatures
	Changing the size and position of time signatures

	Time signature styles
	Changing the numerator style of time signatures
	Changing the denominator style of time signatures
	Changing the open meter style of time signatures
	Changing the separator style of interchangeable time signatures

	Positions of time signatures
	Moving time signatures rhythmically
	Moving time signatures graphically
	Moving time signatures shown at system object positions graphically
	Changing the position of time signatures on bracketed groups

	Hiding/Showing time signatures
	Deleting time signatures
	Time signature font styles
	Changing the design of time signatures


	Tremolos
	Tremolos in tie chains
	Changing the number of tremolo strokes on individual notes in tie chains

	General placement conventions for tremolos
	Changing the speed of tremolos
	Deleting tremolos
	Rhythmic positions of notes with tremolos
	Moving tremolo strokes
	Project-wide engraving options for tremolos
	Changing the appearance of multi-note half note tremolos project-wide

	Tremolos in playback
	Changing the duration of tremolos in playback


	Tuplets
	General placement conventions for tuplets
	Project-wide engraving options for tuplets
	Nested tuplets
	Inputting nested tuplets

	Notations on tuplet notes
	Turning existing notes into tuplets
	Turning tuplets into normal notes
	Moving tuplets rhythmically
	Deleting tuplets
	Tuplet beams
	Tuplet brackets
	Moving tuplet numbers/ratios and brackets graphically
	Hiding/Showing tuplet brackets
	Changing the angles of tuplet brackets
	Changing the placement of tuplet brackets relative to the staff
	Changing the rhythmic end positions of tuplet brackets
	Forcing tuplet brackets to be horizontal

	Tuplet numbers/ratios
	Changing the tuplet number/ratio type
	Changing the position of tuplet numbers/ratios
	Changing the font used for tuplet numbers/ratios


	Unpitched percussion
	Percussion kits vs. individual percussion instruments
	Percussion kits
	Exporting percussion kits
	Importing percussion kits

	Project-wide engraving options for unpitched percussion
	Per-flow notation options for unpitched percussion
	Changing the playing techniques of notes on percussion kit staves
	Showing notes in percussion instruments as ghost notes
	Moving notes to different instruments in percussion kits
	Notations on notes in percussion kits
	Dynamics in percussion kits

	Percussion kit presentation types
	Changing the presentation type of percussion kits

	Playing techniques for unpitched percussion instruments
	Percussion Instrument Playing Techniques dialog
	Override Percussion Noteheads dialog

	Creating new playing technique-specific noteheads for unpitched percussion instruments
	Overriding the appearance of playing technique-specific noteheads

	Percussion legends
	Adding percussion legends to five-line staff kit presentations
	Changing the sounding instrument percussion legend range
	Changing the percussion legend type
	Showing short instrument names in percussion legends
	Changing the text shown in percussion legends
	Changing the placement of percussion legends relative to the staff

	Voices in percussion kits
	Changing the voice of individual notes in percussion kits
	Specifying the stem direction/voice of instruments in percussion kits

	Unpitched percussion in Play mode
	Unpitched percussion imported from MIDI files
	Unpitched percussion imported from MusicXML files

	Universal Indian Drum Notation

	Voices
	Note positions in multiple-voice contexts
	Per-flow notation options for voices
	Showing voice colors
	Unused voices
	Swapping the order of voices
	Voice column index

	Notes crossed to staves with existing notes in other voices
	Slash voices
	Changing the slash voice type
	Adding slash voices to percussion kits



	Glossary
	A
	action
	anacrusis
	articulation
	attachment

	B
	bar

	C
	cancellation natural
	caret
	casting off
	cautionary accidental
	channel
	chord
	chord input
	collision avoidance
	column
	concert pitch
	context menu
	cursor

	D
	disclosure arrow
	divisi

	E
	EDO
	endpoint
	Engrave mode
	engraving options
	enharmonic equivalent
	ensemble
	explicit rest
	exploding

	F
	family
	fermata
	flow
	formatting
	fps
	fragment
	frame
	full score

	G
	galley view
	grace note
	group

	H
	hairpin
	half-bar
	handle
	hook
	horizontal justification

	I
	implicit rest
	Insert mode
	instrument
	instrument transposition
	item

	J
	justification

	K
	key command

	L
	layout
	layout options
	lock duration
	lyric

	M
	measure
	MIDI
	minor key
	minor scale
	modes
	multi-bar rest
	music area
	MusicXML

	N
	notation options
	note input

	P
	padding
	padding rest
	page break
	page view
	panel
	part
	patch
	pedal level change
	pick-up bar
	Play mode
	player
	playhead
	playthrough
	plug-in
	pointer
	polymeter
	popover
	preamble
	Print mode
	print preview area
	project
	properties

	Q
	quantization

	R
	rastral size
	reducing
	rhythmic grid

	S
	score
	section player
	Setup mode
	SMuFL
	solo player
	space
	spacing
	spelling
	split stem
	staff spacing handle
	staff-relative placement
	string shift indicator
	stroke
	SVG
	system break
	system formatting
	system fullness indicator
	system object
	system spacing handle

	T
	tempo track
	token
	touchpad
	transport
	transposed pitch
	tuplet
	tutti

	U
	upbeat

	V
	vertical justification
	voice
	VST instrument

	W
	Write mode


	Index

