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Introduction

Thank you very much for purchasing Dorico.
We are delighted that you have chosen Steinberg's scoring application and hope that you will
enjoy using it for years to come.
Dorico is a next-generation application for producing beautiful sheet music, whether you are a
composer, arranger, music engraver, publisher, instrumentalist, teacher, or student. Whether
you want to print your music or share it in a digital format, Dorico is the most sophisticated
program available.
Like all of Steinberg's products, Dorico has been designed from the ground up by a team of
musicians who understand your needs and who are dedicated to producing a tool that is both
easy to learn and use, but also capable of results of the highest quality. Dorico also integrates
with your existing workflow and can import and export files in a variety of formats.
Dorico thinks about music the same way a human musician does and has a deeper
understanding of the elements of music and musical performance than other scoring
applications. Its unique design allows an unprecedented degree of flexibility, in music input and
editing, in score layout, in rhythmic freedom, and many other areas besides.
Most sincerely yours,
Your Steinberg Dorico Team

Platform-Independent Documentation
The documentation applies to the operating systems Windows and macOS.
Features and settings that are specific to one of these platforms are clearly indicated. In all other
cases, the descriptions and procedures in the documentation are valid for Windows and macOS.
Some points to consider:
●

The screenshots are taken from Windows.

●

Some functions that are available on the File menu on Windows can be found in the
program name menu on macOS.

Usage of musical terms
This documentation uses American terminology for musical items throughout the
documentation.
The following table lists all the notes and notations that have different names in American and
British English:
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American Name

British Name

Double whole note

Breve

Whole note

Semibreve

Half note

Minim

Quarter note

Crotchet

Eighth note

Quaver

Sixteenth note

Semiquaver

Thirty-second note

Demisemiquaver

Sixty-fourth note

Hemidemisemiquaver

Hundred twenty-eighth note

Semihemidemisemiquaver

Two hundred fifty-sixth note

Demisemihemidemisemiquaver

Staff

Stave

Bar/Measure

Bar

NOTE
This documentation only uses “bar”.

Conventions
In our documentation, we use typographical and markup elements to structure information.

Typographical Elements
The following typographical elements mark the following purposes.
PREREQUISITE
Requires you to complete an action or to fulfill a condition before starting a
procedure.
PROCEDURE
Lists the steps that you must take to achieve a specific result.
IMPORTANT
Informs you about issues that might affect the system, the connected hardware, or
that might bring a risk of data loss.
NOTE
Informs you about issues that you should consider.
EXAMPLE
Provides you with an example.
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RESULT
Shows the result of the procedure.
AFTER COMPLETING THIS TASK
Informs you about actions or tasks that you can perform after completing the
procedure.
RELATED LINKS
Lists related topics that you can find in this documentation.

Markup
Elements of the user interface are highlighted throughout the documentation.
Names of menus, options, functions, dialogs, windows, and so on, are highlighted in bold.
EXAMPLE
To open Notation Options in Write mode, choose Write > Notation Options.
If bold text is separated by a greater-than symbol, this indicates a sequence of different menus
to open.
EXAMPLE
Choose Engrave > Engraving Options.
File names and folder paths are shown in a different font.
EXAMPLE
example_file.txt

Key Commands
Many of the default key commands, also known as keyboard shortcuts, use modifier keys, some
of which are different depending on the operating system.
When key commands with modifier keys are described in this manual, they are shown with the
Windows modifier key first followed by the macOS and the key:
●

Windows modifier key/macOS modifier key-Z

EXAMPLE
Ctrl/Cmd-Z means: press Ctrl on Windows or Cmd on macOS, then press Z.

Key commands in Dorico
The default key commands in Dorico depend on your keyboard layout.
If you move the mouse over a tool or a function, the information in brackets shows the key
command that is used to activate or deactivate a tool or a function.
You can also do one of the following:
●

Choose Help > Key Commands to open the Dorico Key Commands window, which
provides an overview of all available key commands.

●

Search for key commands of specific functions or menu items in the Preferences dialog. In
this dialog, you can also assign new key commands or change default key commands.
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RELATED LINKS
Accessing the interactive Dorico key commands map on page 11
Searching for the key commands of functions on page 11
Preferences on page 53

Accessing the interactive Dorico key commands map
The Dorico Key Commands map shows a virtual computer keyboard. Depending on the selected
keyboard layout that you have selected in the Preferences dialog, it highlights the keys that have
been assigned key commands. Below the virtual computer keyboard, all key commands are
listed, divided into global and mode-specific groups.
You can open the Dorico Key Commands map in any of the following ways:
●

Choose Help > Key Commands.

●

Choose Edit > Preferences, and click Print Summary in the Key Commands section of the
Preferences dialog.

The Dorico Key Commands map opens in a web browser. You have the following options:
●

To see the available key commands, select a context. The context of a key command is the
mode in which it can be used. Key commands that have a global context work in all modes.

●

To highlight the keys that you can press in combination with the modifier key to form a key
command, press a modifier key on your computer keyboard, such as Shift. You can also
press more than one modifier key. The virtual computer keyboard shows the highlighted
keys and displays on each key to which functions it is assigned.
NOTE
You can also use the mouse to select a modifier key on the virtual computer keyboard.

●

To search for a specific key command, enter one or multiple words in the search input
field.

●

To get an overview of all available key commands, browse the key commands that are
listed below the virtual keyboard. The key commands are listed according to the context in
which they can be used.

Searching for the key commands of functions
You can search for key commands that are assigned to functions or menu items in Dorico.
NOTE
You can also search for functions in the Dorico Key Commands window.

PROCEDURE
1.

Open Preferences in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Edit > Preferences (Windows).

●

Choose Dorico > Preferences (macOS).

2.

Click Key Commands in the page list.

3.

Enter the name of a function in the Search field.
The entries that are listed below are filtered according to the words that you enter.

4.

Expand an entry and select the function for which you want to see the key command.
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RESULT
If the function has a key command, it is shown in the Assigned key commands display.
RELATED LINKS
Accessing the interactive Dorico key commands map on page 11
Preferences on page 53

Changing the keyboard layout
You can change the keyboard layout in Dorico. This allows you to use the predefined key
commands for your language.
PROCEDURE
1.

Open Preferences in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Edit > Preferences (Windows).

●

Choose Dorico > Preferences (macOS).

2.

Click Key Commands in the page list.

3.

Select a different keyboard layout from the Keyboard language menu.

4.

Click Apply, then Close.

RESULT
You can immediately use the available key commands for your language.
RELATED LINKS
Preferences on page 53

Assigning key commands
You can assign key commands to Dorico functions that have no key commands assigned. You can
also change existing key commands.
PROCEDURE
1.

Open Preferences in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Edit > Preferences (Windows).

●

Choose Dorico > Preferences (macOS).

2.

Click Key Commands in the page list.

3.

Search for the name of a function and select it.

4.

Optional: Press Remove Key Command if the function already has an assigned key
command.
NOTE
If you assign a new key command without removing an existing one, you can use either
key command.

5.

Click the New key command input field.

6.

Press the key command that you want to assign on your computer keyboard.

7.

Click Add Key Command.
The key command is shown in the Assigned key commands display.
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8.

Click Apply, then Close.

RESULT
You can immediately use the assigned key command.
RELATED LINKS
Searching for the key commands of functions on page 11
Resetting key commands on page 13
Preferences on page 53

Removing key commands
You can remove assigned key commands from a function.
PROCEDURE
1.

Open Preferences in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Edit > Preferences (Windows).

●

Choose Dorico > Preferences (macOS).

2.

Click Key Commands in the page list.

3.

Search for the name of a function and select it.

4.

Click Remove Key Command.

5.

Click Apply, then Close.

RESULT
The key command is removed from the selected function.
RELATED LINKS
Searching for the key commands of functions on page 11
Resetting key commands on page 13
Preferences on page 53

Resetting key commands
You can reset all key commands to their defaults.
PROCEDURE
1.

2.

Open Preferences in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Edit > Preferences (Windows).

●

Choose Dorico > Preferences (macOS).

Click Key Commands in the page list.

3.

Click Reset Key Commands.

4.

Click Apply, then Close.

RESULT
All custom key commands are deleted and the default key commands are reinstated.
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RELATED LINKS
Preferences on page 53

How you can reach us
On the Help menu you find items linking to additional information.
The menu contains links to various Steinberg web pages. Selecting one of these menu items
automatically launches your web browser and opens the page. On these pages, you can find
support and compatibility information, answers to frequently asked questions, information
about updates and other Steinberg products, and so on.
This requires that you have a web browser installed on your computer and a working Internet
connection.
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First steps

This chapter helps you to get started with Dorico.
When you start Dorico for the first time, we recommend that you open one of the templates first
to have a look at the user interface and the functions that Dorico provides before you start your
own projects. You are welcome to skip this part and explore the program for yourself.
The following sections inform you about the following topics:
●

Overview of the most important workspaces

●

Setting up a new project

●

Writing your music and adding notation items to your score

●

Laying out and formatting pages

●

Playing back what you created

●

Printing and exporting

Getting around
The following sections give you an overview of the user interface and introduce you to how
Dorico is structured.

Opening a template
Before you start your own project, we recommend that you familiarize yourself with the user
interface of Dorico. To prepare for this, open one of the templates that are provided with the
program.
PREREQUISITE
You have started Dorico. The Hub is open.
PROCEDURE
1.

In the Hub, select one of the listed template groups. For example, select the Choral and
Vocal templates.

2.

Select one of the listed templates.
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3.

Click New from Template.

RESULT
The template opens.
AFTER COMPLETING THIS TASK
Proceed to the following sections that provide a quick overview of the user interface and that
introduce you to the main functions of the program.
RELATED LINKS
Hub on page 35

Quick tour of the user interface
The user interface of Dorico consists of different modes that represent different phases in the
workflow of preparing a score.
The user interface has a structure that is the same in each of the application’s modes. There is
always a large area for editing your music in the center of the project window. In every mode,
there are collapsible panels on the left, right, and bottom of the project window, depending on
which mode you are using. The contents of these panels change according to the selected mode.
When you open the template, the first view shows the project window in Write mode:
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The project window contains the following areas:

Toolbar
The toolbar is located at the top of the project window.

On the left side of the toolbar, the modes are displayed. By activating a mode, you change the
workspace and the available panels. The active mode is highlighted in a different color. In the
middle of the toolbar, layout options allow you to switch between the different layouts in your
project and to show/hide panels and tabs.
On the right side of the toolbar, you can open a Mixer and activate basic transport controls that,
among other functions, allow you to play back and record your music.

Show Mixer button

Music area
The music area is the main part of the project window in Setup, Write, and Engrave modes where
you set up, input, edit and format your music. In Play mode, this area is called event display, in
which every note is displayed as an event. In Print mode, this area is called print preview area,
which shows a preview of what is going to be printed or exported as a graphic.

The music area displays the scores or the instrumental parts that you create. Above the music
area you can activate several layouts in tabs and switch between them. Layouts in Dorico allow
you to show different presentations of your music. If you have a full score with different
instrumental parts, such as a violin part and a bassoon part, you can switch between that full
score layout and the layouts of each part. To save space on the screen or to focus on a specific
layout, you can hide the tabs.

Toolboxes
In Write mode, there are additional columns at the left and right edges of the project window.
These are called toolboxes.
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Notes toolbox in Write mode

Notations toolbox in Write mode

The Notes toolbox on the left allows you to activate or deactivate various note input tools.
The Notations toolbox on the right provides tools that allow you to create and edit other
notations, such as clefs, key signatures, time signatures, and so on.

Panels
Dorico provides panels with various functions in all modes. When you open the template, there is
a panel on the left of the music area. This is the Notes panel in Write mode.

Notes panel in Write mode

The Notes panel contains all the durations, accidentals, slurs, and articulations that are most
commonly used when inputting notes.

Status Bar
At the bottom of the project window, a status bar allows you to select different views and page
arrangements for the music area.
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RELATED LINKS
Functions of the modes on page 19
User interface on page 35
Mixer on page 316
Transport window on page 318

Functions of the modes
Modes represent different phases in the workflow of preparing a score.
By switching to another mode, you change the workspace and the available panels.

Setup Mode
In Setup mode, you can create players and groups of players, and assign instruments to them.
You can define different layouts for your project that you can print or export independently. For
example, you can print or export a layout for the full score and separate layouts for each
instrumental part.
You can switch to Setup mode in any of the following ways:
●

Press Ctrl/Cmd-1.

●

Click Setup in the toolbar.

●

Choose Window > Setup.

Write Mode
In Write mode, you can input your music. The available toolboxes and panels allow you to input
all the notes and notation items that are most commonly used.
You can switch to Write mode in any of the following ways:
●

Press Ctrl/Cmd-2.

●

Click Write in the toolbar.

●

Choose Window > Write.

Engrave Mode
In Engrave mode, you can make fine adjustments to the music that you input in Write mode and
determine how the pages of your project are laid out.
You can switch to Engrave mode in any of the following ways:
●

Press Ctrl/Cmd-3.

●

Click Engrave in the toolbar.

●

Choose Window > Engrave.

Play Mode
In Play mode, you can assign virtual instruments and effects for playback to instruments and
playing techniques. You can make adjustments to how individual notes are played back in order
to produce a more realistic performance.
You can switch to Play mode in any of the following ways:
●

Press Ctrl/Cmd-4.

●

Click Play in the toolbar.

●

Choose Window > Play.
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Print Mode
In Print mode, you can print your layouts or export them as graphic files.
You can switch to Print mode in any of the following ways:
●

Press Ctrl/Cmd-5.

●

Click Print in the toolbar.

●

Choose Window > Print.

RELATED LINKS
Setup mode on page 56
Write mode on page 97
Engrave mode on page 222
Print mode on page 338
Play mode on page 299

Hiding/Showing panels
You can hide/show individual or multiple panels. This is useful if you want to see more of the
music area, for example.
PROCEDURE
●

Hide individual panels or all panels in the following ways:
●

To hide/show the left panel:
Press Ctrl/Cmd-7.
Click its disclosure arrow.
Choose Window > Show Left Panel.

●

To hide/show the right panel:
Press Ctrl/Cmd-9.
Click its disclosure arrow.
Choose Window > Show Right Panel.

●

To hide/show the bottom panel:
Press Ctrl/Cmd-8.
Click its disclosure arrow.
Choose Window > Show Bottom Panel.

●

To hide/show all panels:
Press Ctrl/Cmd-0.
Click Hide/Restore Panels.

Choose Window > Hide/Restore Panels.
You can hide/show the panel whose icon is currently selected in the Notations toolbox in
any of the following ways:
RESULT
The corresponding panels are hidden/shown. Panels are hidden when no tick is shown beside
the corresponding panel in the menu, and shown when a tick is shown in the menu.
If you hide all active panels, the button changes its look and displays which panels are hidden.
For example, the Hide/Restore Panels button in the toolbar indicates that all panels were active
and are now hidden.
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Working with tabs and windows
Dorico enables you to set up your workspace according to your working style.
Dorico allows you to open multiple tabs to display multiple layouts in the same project within the
same window. You can also open the same project in several windows.
RELATED LINKS
Setting up your workspace on page 48

Opening a new tab
You can open a new tab to display a different view or layout within the same project window.
Each tab can contain a separate layout or an additional view of a layout that is already open in
another tab or window. Whenever you open a new tab, you are prompted to select a layout that
you want to display in the tab.
You can find the tabs at the top of the music area, below the toolbar. If you do not see the tabs,
click Show Tabs in the toolbar.

PROCEDURE
●

To open a new tab, do one of the following:
●

Press Ctrl/Cmd-T.

●

To the right of the tabs, click New Tab.

RESULT
A new tab opens that shows several icons at the top and a list of layouts at the bottom.
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AFTER COMPLETING THIS TASK
You can click one of the icons or select a layout from the list at the bottom. Alternatively, you can
click Select Layout in the toolbar and choose one of the layouts from the menu. The layout that
you choose opens in the active tab.

Opening a new window
You can open another window for the same project.
This can be useful if you want to see and work on multiple layouts at the same time. You can also
open multiple project windows to show different modes of the same project.
PROCEDURE
●

Open a new project window in any of the following ways:
●

Press Ctrl/Cmd-Shift-T.

●

Choose Window > New Window.

RESULT
A duplicate of the window opens. It contains the same tabs and the same view options as the
original window.
RELATED LINKS
Opening multiple project windows on page 51

Starting a new project
After getting a first impression of the Dorico user interface you can get started with inputting
your own music. In this section, you learn how to set up a new project.
PREREQUISITE
NOTE
All inputs that are made and the images that are used to accompany the steps in this chapter are
intended merely to be helpful examples. Therefore, there is no need to make the exact same
entries in order to get the depicted results.
Close the template without saving. The Hub reopens.
PROCEDURE
●

Start a new project in any of the following ways:
●

Press Ctrl/Cmd-N.

●

Click New Empty Project.

RESULT
A new project window opens.

22

First steps
Starting a new project

Whenever you start a new project without selecting a specific project template, Setup mode is
activated. This allows you to specify players and assign instruments right from the start. The area
in the middle, the project start area, which becomes the music area once you have added a
player, allows you to start your project with different types of players. On the right, the Layouts
panel shows a Full score entry. This entry is available in every new project. At the bottom of the
window is the Flows panel where you can specify separate spans of music for your project.
AFTER COMPLETING THIS TASK
Start your project by adding an individual player or by adding a section player and assign an
instrument. You are free to assign any kind of instrument. In this chapter, only one piano player
is added as an example.
RELATED LINKS
Windows on page 38
Flows in Dorico on page 33

Adding a solo player
In this section, you learn how to add a player and assign an instrument.
PREREQUISITE
You have started a new project. You are in Setup mode.
PROCEDURE
1.

Click Add Solo Player.

The instrument picker opens.
TIP
You can also open the instrument picker at any time by clicking the plus symbol to the
right of the added empty-handed player.
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Alternatively, you can right-click the player and choose Add Instrument to Player from
the context menu.
2.

Select a piano in the instrument picker in any of the following ways:
●

Enter piano into the search box.

●

Start entering the instrument name you want, then select it from the filtered list.

●

Click an instrument family and then an instrument.

●

Press Up Arrow/Down Arrow to select an instrument family, then press Tab to
switch to the instrument column. Press Up Arrow/Down Arrow to select an
instrument.
TIP

3.

●

An enclosure line shows which instrument family or instrument is selected
when using the keyboard to navigate.

●

Press Shift-Tab to switch back to the previous column in the instrument
picker.

Click Add.

RESULT
You have added your first player. In the music area, the required piano staves including their
respective clefs are displayed.
AFTER COMPLETING THIS TASK
Save your project.
NOTE
You can save your project at any time.
Optionally, you can now edit the project title or add more players.
The following sections help you to create flows and layouts. If you want to start composing, you
can skip those sections.
RELATED LINKS
Writing music on page 25
Adding solo/section players on page 65

Creating a flow
Flows are separate spans of music within your project, for example, movements or songs. In this
section, you learn how to create a flow.
PREREQUISITE
You have added at least one player. You are in Setup mode.
PROCEDURE
●

In Setup mode, click Add Flow in the Flows panel at the bottom of the window.
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RESULT
A new flow is added to your project each time you click Add Flow. All existing players are
assigned to new flows, and new flows are automatically added to all existing full score and part
layouts.
AFTER COMPLETING THIS TASK
Rename the flow if required.
Optionally, deactivate the checkboxes of the players that you want to exclude from the flow in
the Players panel.
Optionally, deactivate the checkboxes of the layouts from which you want to exclude the flow in
the Layouts panel.
RELATED LINKS
Flows on page 88
Renaming flows in Setup mode on page 90
Adding flows on page 88
Creating a layout on page 25

Creating a layout
Layouts define how music for one or more players in one or more flows is presented, including
page size, margins, staff size, and so on. In this section, you learn how to create a new layout.
PREREQUISITE
You have added at least one player and one flow. You are in Setup mode.
Several layouts are often used in ensembles with multiple players, where each player may
require a layout of the individual instrumental part. Dorico automatically creates a full score
layout that contains all players and all flows as well as individual part layouts that each contain
one player and all flows. If you require a different combination of players and flows, for example,
a part containing the music for two players, you can create your own layouts, as follows:
PROCEDURE
●

In the Layouts panel, click Add Instrumental Part Layout.

RESULT
An empty part is created on the Layouts panel.
AFTER COMPLETING THIS TASK
Double-click the empty part to give it a name. Optionally, select the flows that you want to assign
to the layout in the Flows panel. Activate the checkboxes of the players that you want to assign
to the layout in the Players panel.
RELATED LINKS
Creating layouts on page 91

Writing music
Once you have set up your project, you can start writing music.
In Write mode, you can input notes and insert other notations into your score.
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TIP
Throughout Dorico, most tasks can be accomplished using only your computer's keyboard. You
do not need to use the mouse or touchpad. Learning key commands allows you to use Dorico
most efficiently. The fastest way to input music is using a MIDI keyboard. If you do not have a
MIDI keyboard, you can use your computer's keyboard. Of course, you can still use the mouse or
touchpad if you want.
In the following sections, you learn how to input notes and notation items.

Inputting your first notes
In this section, you learn how to input notes. You can start inputting notes without having to first
add a time signature or key signature.
PREREQUISITE
●

You have set up your MIDI keyboard.
NOTE
If you have not set up a MIDI keyboard yet, you can start inputting notes with the
computer keyboard.

●

You have added a piano player in Setup mode.

●

You are in Write mode.

PROCEDURE
1.

Select the rest that was automatically inserted next to the clef when you added a solo
player.

2.

Start note input in any of the following ways:
●

Select the staff where you want to input notes and press Shift-N or Return.

●

Select the staff where you want to input notes and choose Write > Note Input.

●

Double-click the staff where you want to input notes.

The caret is displayed.

3.

In the Notes panel, click a duration.
NOTE
By default, Dorico selects a quarter note (crotchet) for you.
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4.

Start playing notes on the MIDI keyboard, or press A, B, C, D, E, F, G on the computer
keyboard to input the corresponding pitches.
If you want higher or lower pitch for the note that Dorico inputs for you, you can force a
different register.
●

To input a note above the previously input note, press Shift-Alt as well as the letter
for the note.

●

To input a note below the previously input note, press Ctrl (macOS) or Ctrl-Alt
(Windows) as well as the letter for the note.

NOTE
You must press Ctrl on Mac, not Cmd.

RESULT
The pitches you enter or play in are input as notes.
EXAMPLE

Input notes with the caret still active after the final note

RELATED LINKS
Write mode on page 97
Register selection during step input on page 117
Key commands in Dorico on page 10
Adding a time signature on page 27

Adding a time signature
In this section, you learn how to add a time signature at the beginning of the staff. You can add a
time signature before or after inputting a melody.
PREREQUISITE
Press Esc to deactivate the caret.
PROCEDURE
1.

Select the first note on the staff.

2.

Press Shift-M.
The time signatures popover opens above the staff.

3.

Enter a typical time signature into the popover, such as 3/4.
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4.

Press Return to close the popover.

RESULT

The time signature is automatically input to the left of the note, and the required bar lines are
automatically inserted at the correct positions. If you want to insert a key signature, proceed to
the next section.
RELATED LINKS
Adding a key signature on page 28

Adding a key signature
In this section, you learn how to add a key signature. You can add a key signature at any
rhythmic position on the staff.
When you start a new project from scratch, by default, there is no key signature shown.
Depending on the kind of music you are writing, the key signature might be taken to mean C
major or an open key with no specific tonal center.
You can change the key anywhere on the staff. To add a different key signature at the beginning
of the staff, for example, D major, proceed as follows:
PROCEDURE
1.

Select the first note on the staff.

2.

Press Shift-K.
This opens the key signatures popover on top of the staff.

3.

Enter a key signature into the popover. If you want to enter D major, enter an uppercase
D.
For D minor, enter a lowercase d.

4.

Press Return.
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RESULT

The key signature is inserted between the clef and the time signature. Dorico automatically adds
accidentals where necessary.

Inputting your first chord
In this section, you learn how to input a chord with the computer keyboard, using chord mode. If
you want to use a MIDI keyboard instead, you can input the chord with your keyboard, and you
do not need to use chord mode. Dorico automatically inputs the correct notes.
PREREQUISITE
Select the last note or rest on the staff, and press Return. This shows the caret.
PROCEDURE
1.

Activate Chords in any of the following ways:
●

Press Q.

●

In the Notes toolbox, click Chords.

The caret shows a plus sign at the top.

2.

Optional: In the Notes panel, select a duration.

3.

Input the notes that you want in your chord by pressing keys from A to G, one after the
other. For example, for a C major chord, press C, E, and G.
By default, Dorico adds each new note above the previous note. You can select the register
of notes manually.
The example shows a possible result.

4.

Press Space to advance the caret to the next note position and continue with the next
chord.
Dorico expects further chord input until you deactivate it.

5.

Optional: To deactivate chord input, press Q or deactivate Chords.
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RELATED LINKS
Key commands in Dorico on page 10
Register selection during step input on page 117
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The following sections give you an overview of the design philosophy as well as concepts on
which Dorico is based.
We recommend that you familiarize yourself with these concepts as these are often returned to
throughout the documentation.

Design philosophy
If you are experienced with other scoring applications and are interested in learning more about
deep design considerations for scoring programs, you may find the following discussion
illuminating, but everybody can safely skip it.
Dorico has a forward-thinking design that is led by musical concepts rather than computational
convenience, and this provides many benefits.

Higher-level concepts
In most graphically-orientated scoring applications, the highest-level concept is the staff or the
instrument definition that creates a staff or staves. When setting up your full score, you start by
adding the correct number of staves, and you are immediately forced into making decisions
about the layout. This means that you must know in advance whether two flutes share a staff or
have their own individual staves, or whether there should be two trumpets or three. Many of
these decisions have significant effects throughout the process of inputting, editing, and
producing individual instrumental parts.
Typically, every system of a score must contain the same number of staves, even if some are
hidden on particular systems. This requires the user to manage common conventions for
themselves, such as multiple players of the same instrument sharing staves. This can be timeconsuming and is naturally error-prone.
Dorico is designed to conform more closely to how music is performed in the real world and to
make the score a flexible expression of the practical choices that go into a musical performance,
rather than to make the musical performance subservient to the way the score was initially
prepared.
To that end, the highest-level concept of Dorico is the group of human musicians that performs a
score. A score can be written for one or more groups, for example, a double choir or an orchestra
plus off-stage chamber ensemble, and so on. Each group includes one or more players which
correspond to the humans who play one or more instruments. Players may either be individuals
who can play more than one instrument, for example, an oboist doubling cor anglais, or groups
in which everyone plays only one instrument, for example, eight desks of violinists.
The actual music that is played by the group in your score belongs to one or more flows. A flow is
any span of music that stands alone, for example, a whole song, a movement of a sonata or
symphony, a number in a musical show, or even a short scale or exercise. Players might or might
not have any music to play in a given flow. For example, all the brass players might be omitted
from the slow movement of a classical symphony, or certain players might have nothing to do in
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some cues in a movie score. This is no problem as you can combine players in flows in any
combination.
Dorico provides several benefits. Chief among them is its ability to produce different score
layouts that share the same musical content. For example, in the same project you can create a
full score with each player's music on separate staves, a custom score layout containing just the
piano and vocal staves, and an instrumental part for each player that only contains the music
belonging to them.
One crucial difference between Dorico and other scoring applications is that the musical content
exists independently of the score layout in which it is viewed.

Key musical concepts
In order to work efficiently with Dorico, it is important to understand the conceptual model of the
program.
The model is closely based on the practical considerations of how music is written and performed
by real humans.
RELATED LINKS
Projects in Dorico on page 32
Modes in Dorico on page 32
Instruments in Dorico on page 33
Players in Dorico on page 33
Groups in Dorico on page 33
Flows in Dorico on page 33
Layouts in Dorico on page 34

Projects in Dorico
A project is an individual document that you create within Dorico. It can contain multiple
separate pieces of music, from very short to very long, written for any combination of
instruments and using different layouts.

Modes in Dorico
Modes represent different phases in the workflow of preparing a score.
Dorico contains the following modes:
Setup
In this mode, you can set up the players and instruments that are played in the
project. You can create and manage flows and set up layouts.
Write
In this mode, you can write your music. You can insert notes and rests, key
signatures, time signatures, and idiomatic notations.
Engrave
In this mode, you have access to fine-grain controls that allow you to manipulate and
modify every item in the project. You can also manage pages, master pages, layouts,
and formats.
Play
In this mode, you can set up your project for playback. You can assign VST
instruments, adjust the mix, and change the sounding duration of notes in playback
without affecting their notated duration.
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Print
In this mode, you can define different print jobs, such as printing full conductors
scores, study scores, individual parts, and so on. For every print job, you can specify
options for page size and duplex printing. You can also manage other output, such
as exports to various file types, such as PNG.

Instruments in Dorico
In Dorico, an instrument is an individual musical instrument, such as a piano, a flute, or a violin.
Dorico has a database of information about properties of each instrument. These include the
playable range, common and uncommon playing techniques, notational conventions,
transposition properties, tunings, clef, number of staves, type of staff, and so on.
RELATED LINKS
Instruments on page 72

Players in Dorico
In Dorico, a player can represent an individual musician or several musicians.
●

Solo players are individual musicians who can play one or more instruments, for example,
a clarinettist who doubles on alto saxophone or a percussionist who plays bass drum,
clash cymbals, and triangle.

●

Section players represent multiple musicians who all play the same instrument, for
example, a violin section player can represent eight desks of musicians, or a soprano
section player can represent the whole soprano section in a mixed voice choir.

NOTE
Section players cannot double instruments, but they can play divisi. This means that they can be
divided into smaller units, which is commonly required for strings.

Groups in Dorico
A group represents a collection of musicians that are considered together, such as a choir,
orchestra, or a chamber ensemble.
In a typical project, there might be only one group that contains all of the defined players, but
you can define as many groups as required to allow easy separation of forces in larger-scale
works. It might also be necessary to assign players to these groups for the purposes of, among
other things, properly bracketing and labelling their staves in the conductor's score.
EXAMPLE
A work for double choir and organ can define the two choirs as separate groups. This allows each
choir to have its own label in addition to the labels for each sectional player (soprano, alto, tenor,
bass) within the choir.
In a complex work, such as Elliott Carter's “A Symphony of Three Orchestras”, each of the
orchestras can be defined as a separate group.

Flows in Dorico
Flows are separate spans of music that are completely independent in musical content, for
example, a song, a movement in a sonata or symphony, a number in a stage musical, or a short
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scale or sight-reading exercise of only a few bars in length. A single project can contain one or
more flows.
Each flow can contain music for any combination of players. For example, in a Classical-period
symphony, it is not uncommon for the brass players to be tacet in the second, slow movement,
so the flow for the second movement can simply not contain any brass players. In a set of cues
for a movie, for example, specific players may not be required in particular cues, so each flow can
contain only those players who have anything to play.
The correct assignment of players to flows allows Dorico, for example, to generate tacet sheets
automatically for individual instrumental parts.

Layouts in Dorico
Layouts define how music for one or more players in one or more flows is presented, including
page size, margins, staff size, and so on.
Layouts combine musical content, as represented by flows, with rules for page layout and music
engraving. As well as part layouts for individual players, you can have layouts for multiple players
drawn from multiple different flows. You can use the layouts to produce paginated music
notation that can be printed or exported in various formats.
A typical project for an ensemble of multiple players contains several layouts. For example, a
work for string quartet in three movements contains four solo players – two violins, one viola,
and one cello – and three flows, one for each movement. Such a project might require five
layouts:
●

Four layouts each containing the music from all three flows for one of the solo players,
that is, the individual instrumental parts

●

One layout containing the music from all three flows and all four players, that is, the full
score

Each layout provides independent control over practically every aspect of the visual appearance
of the music, including independent staff size, note spacing, and system formatting.
Each layout can have independent page layout properties, such as page size, margins, running
headers, and footers. These can be defined as master pages and then be applied freely to left- or
right-hand pages or to specific pages in a layout, for example, the first or last page.
Flow frames define where music appears on each page. One or more flows are assigned to each
flow frame, in a manner analogous to how flows of text are assigned to text frames in desktop
publishing applications. Dorico also provides for text frames, which allow the presentation of
blocks of text, such as prefatory material, critical commentary, and block lyrics.
NOTE
The page layout features of Dorico allow you to have multiple flow frames and text frames on the
same page. This enables you to combine music from multiple flows on the same page.
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The user interface of Dorico is designed to be as unobtrusive as possible while keeping all of the
important tools at your fingertips.
You can explore the interface without doing any damage to your project. You can always undo
any inadvertent edits or close your project without saving it.

Hub
When you start Dorico, the Hub opens. The Hub keeps you up-to-date with the latest information
and assists you with organizing your projects. It consists of the News section and the Projects
section.

News
Displays recent Steinberg news.
Tutorials
Displays recent Dorico tutorials.
Read More
When News is selected, Read More links you to a page on the Steinberg website
with more detailed information about the news and tutorials topic that you selected.
Watch
When Tutorials is selected, Watch links you to the relevant tutorial video on the
Dorico YouTube channel.
Videos
Directs you to the Dorico YouTube channel.
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User Forum
Links you to the user forum on the Steinberg website.
Downloads
Links you to the download page on the Steinberg website.
Recent Projects
Shows a list of the projects that you worked on last. You can scroll through the list
with the Up Arrow/Down Arrow keys or with the mouse.
Orchestral, Band, Chamber, Choral and Vocal, Solo
Allow you to choose between different categories of project templates.
New Empty Project
Starts a new project.
Open Other
Allows you to open any other project file in your file system.
Open Selected Project
Opens the file that you selected in the Recent Projects list. Alternatively, you can
double-click the file name or select the file and press Return.
Project Templates only: New from Template
Creates a new project from the project template that you selected in the list of a
project template category.

Starting new projects
Dorico provides several ways to start new projects.
PROCEDURE
●

Start a new project in any of the following ways:
●

Press Ctrl/Cmd-N at any time.

●

Choose File > New at any time.

●

In the Hub, click New Empty Project.

RESULT
A new project window opens.

Starting new projects from project templates
Dorico provides multiple project templates that you can use to start a new project, for example,
multiple types of orchestras and vocal ensembles.
PROCEDURE
1.

In the Hub, select one of the following project template categories:
●

Orchestral

●

Band

●

Jazz

●

Chamber

●

Choral and Vocal

●

Solo
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2.

Select a project template from the available templates in the category.

3.

Click New from Template.

RESULT
The project template opens in a new project window.
TIP
You can also start a new project from a template at any time by choosing File > New from
Template > [Template category] > [Project template].
AFTER COMPLETING THIS TASK
You can add additional players/instruments and delete players/instruments that were included in
the template to customize your project.
RELATED LINKS
Adding solo/section players on page 65
Deleting players on page 71
Adding instruments to players on page 73
Deleting instruments on page 77

Selecting recent projects
You can open a project on which you recently worked.
PROCEDURE
●

In the Hub, select a recent project in any the following ways:
●

In the Recent Projects list, select a file name and press Up Arrow/Down Arrow to
scroll through the list of file names. To open a file, press Return.

●

In the Recent Projects list, double-click a project file name.

●

In the Recent Projects list, select a project file name and click Open Selected
Project.

●

Choose File > Open Recent > [Project file name] at any time.

Opening other files
You can open other Dorico projects that are not listed in the Recent Projects list, or you can
import MusicXML or MIDI files.
PROCEDURE
1.

2.

Open the File Explorer/macOS Finder dialog in any of the following ways:
●

In the Hub, click Open Other.

●

Choose File > Open at any time.

In the File Explorer/macOS Finder dialog, locate and select the file you want to open.
TIP
You can select multiple files to open them at the same time.

3.

Click Open.
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RESULT
The selected file is opened.
If you imported a MusicXML or a MIDI file, Dorico creates a new project file from the MusicXML
or MIDI content, which you can save as a default Dorico project.

Windows
Dorico provides a project window and floating windows.

Project window
You can open multiple project windows for the same or for different projects. The project window
consists of several areas.

Project window

1

Toolbar
Allows you to access the modes, the workspace options, the Mixer, and the basic transport
options.

2

Tab bar
Shows the tabs that are open in Setup, Write, and Engrave mode. If you split the music
area and open several tabs, tab groups are shown.

3

Project start area/Music area/Event display/Print preview area
When you set up a new empty project, this area in Setup, Write, and Engrave mode shows
the project start area that allows you to add your first players. Once you have added a
player or an ensemble, this area becomes the music area that shows the score or parts of
the score that you set up, write, edit, and format. In Play mode, this area contains an event
display that shows the effects of manipulating the playback of your score. In Print mode,
the print preview area shows a preview of how your project is going to be printed onto
paper or exported into a graphic file format.
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4

Panel
The panels provide notes and notations that you need to create and edit your music.

5

Toolbox
Write mode only: Provides access to various notation items that you can use for your
music.

6

Status bar
Allows you to choose a different view and page arrangement of the music area.

Floating windows
Dorico allows you to open floating windows, such as the Mixer and the Transport windows.
These can be hidden and shown independently of the mode that is selected in the main window.
The following options open floating windows:
Show Mixer

Opens the Mixer window.
Show Transport Bar

Opens the Transport window.
RELATED LINKS
Opening multiple project windows on page 51

Toolbar
The toolbar allows you to access the modes and workspace options as well as the Mixer and the
transport options.
The toolbar is always available independent of the mode or tool that you are using. If you must
hide the toolbar for a specific reason, click the disclosure arrow on top of the toolbar.
The toolbar consists of the following items:

1

Modes
Selectable workspaces in the project window that represent different phases in the
workflow of preparing a score.

2

Workspace options
Provide options that allow you to select different layouts to open in the music area and to
change the working environment.

3

Show Mixer button
Hides/Shows the Mixer window.

4

Basic transport options
Allow to you quickly access the main transport functions.

5

Activate Project button
Shows which project is activated for playback when you have multiple projects open.
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RELATED LINKS
Workspace options on page 40
Basic transport options on page 40

Workspace options
The workspace options in the middle of the toolbar provide options that allow you to select
different layouts and to change the working environment.
Select Layout

Allows you to switch back and forth between layouts.
Show Tabs

Shows/Hides the tab bar above the music area.
Hide/Restore Panels

Shows/Hides all open panels.

Basic transport options
The transport options to the right of the toolbar provide the main transport functions of Dorico.
Show Transport Bar

Opens the Transport window.
Time display

Shows the position of the playhead in the score relative to bars and beats. The time
display shows the units in the following order: bars, beats, 16th notes, 120ths of a
16th note.
Rewind to Beginning

Sets the playhead to the beginning of your score.
Play

Starts/Stops playback.
Activate Project

Shows which project is activated for playback when you have multiple projects open.
TIP
The Transport window contains additional transport functions.
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RELATED LINKS
Transport window on page 318

Tab bar
The tab bar in Dorico allows you to display different layouts within the same project window.
Each tab may contain a separate layout, or an additional view of a layout that is already open in
another tab or window. Each tab is labeled with the name of the selected layout.
You find the tabs aligned on the tab bar at the top of the music area, directly below the toolbar. If
the tabs are not visible, click Show Tabs on the toolbar. If Show Tabs is activated, the tabs are
always displayed, even if only a single tab is open.

Project start area
In Setup, Write, and Engrave modes, the project start area is displayed in the middle of the
project window when you set up a new empty project.

The project start area shows cards that allow you to add your first players. To add players, click
one of the cards:
Add Solo Player
Adds an individual player to whom you can assign one or more instruments.
Add Section Player
Adds a player that represents multiple players who all play the same instrument.
Add Ensemble
Adds multiple players who play different instruments. The ensembles that you can
add represent standard combinations of musicians.
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Music area
In Setup, Write, and Engrave modes, the music area shows the editable score.

Music area showing a sample of a score

The music area can be displayed in several views. The music area tab bar allows you to open
several layouts from your project and switch between them. The scroll bars to the right and to
the bottom of the music area allow you to scroll within the layout.
When panels are open on the right, left, and at the bottom of the window, the music area can be
reduced. You can hide/show panels when necessary.
RELATED LINKS
Hiding/Showing panels on page 20
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Print preview area
The print preview area in Print mode shows a preview of what is going to be printed or exported
as a graphic.

Print preview area displaying a score as a booklet

In the print preview area, you can scroll through the pages that are shown, but you cannot edit
your layouts. If you want to make changes, you must switch to Setup, Write, or Engrave mode.
If you select multiple layouts to be printed as part of the same print job, the print preview area
only displays the first layout. If you want to show the expected page arrangement for each layout
in the print preview, you must check each layout individually before you start printing.
RELATED LINKS
Project window in Print mode on page 338
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Panels
The panels in the project window provide the notes, notations, and functions that you need to set
up, write, edit, and format your music.

Notes panel (left), Notations panel (right), and Properties panel (bottom) in Write mode.

The panels have different names and functions in each mode in Dorico.
Modes and their panels
Mode

Left Panel

Right Panel

Bottom Panel

Setup

Players

Layouts

Flows

Write

Notes

Notations

Properties

Engrave

Formatting

Pages

Properties

Play

n/a

VST and MIDI
Instruments

n/a

Print

Layouts

Print Options

n/a

Some panels are displayed by default. You can hide/show each panel individually or all of them at
the same time. For a full description of each panel, refer to the documentation of the project
window in each mode.
RELATED LINKS
Modes in Dorico on page 32
Hiding/Showing panels on page 20
Project window in Setup mode on page 56
Project window in Write mode on page 97
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Project window in Engrave mode on page 222
Project window in Play mode on page 299
Project window in Print mode on page 338

Toolboxes
Toolboxes are available in Write mode. They provide the tools that allow you to input and modify
notes and notation items and to determine what notation items are shown in the Notations
panel.
RELATED LINKS
Notes toolbox on page 98
Notations toolbox on page 102

Status bar
The status bar at the bottom of the project window allows you to choose a different view and
page arrangement in the music area.
NOTE
The status bar is only available in Setup, Write, and Engrave modes. Not all options are available
in all modes.

Status bar in Write and Setup mode

1

Rhythmic Grid selector
Allows you to change the rhythmic grid value, which affects certain aspects of inputting
and editing, such as the amount by which items move.

2

Disclosure arrow
Allows you to show/hide the bottom panel in Setup, Write, and Engrave mode.

3

Selection tools
Allow you to switch between using the Marquee Tool and the Hand Tool in Write and
Engrave mode.

4

View type selector
Allows you to select one of the provided view types for the music area in Setup and Write
mode.

5

Page arrangement options
Allow you to choose between different horizontal and vertical arrangements of either
individual pages or pairs of pages, which are called spreads.

6

Zoom options
Allow you to change the zoom factor of the music area and its musical contents. There are
preset zoom levels but you can also use a custom zoom level.

RELATED LINKS
Rhythmic grid on page 105
View types on page 47
Selection tools on page 46
Page arrangements for page view on page 47
Zoom options on page 48
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Selection tools
Dorico allows you to choose a selection tool on the status bar that you can use to select or move
items within the music area.
Pressing Shift in combination with the chosen selection tool allows you to instantly use the other
tool.
You can use the following tools:
Marquee Tool
Allows you to click and drag a rectangle to select multiple notes and notations.

Hand Tool
Allows you to click and move the view within the music area.

RELATED LINKS
Status bar on page 45
Making marquee selections on page 46
Moving the view on page 46

Making marquee selections
You can use a marquee selection to select multiple notes and notations at the same time within a
specific area.
PREREQUISITE
PROCEDURE
1.

In the status bar, click Marquee Tool.

2.

In the music area, click and drag across the area where you want to select everything,
A gray rectangle is shown to indicate which notes and notations will be selected. We
recommend that you click in one corner of the area you want to select and drag diagonally
across to the other corner.

RESULT
All notes and notations in the area indicated by the gray rectangle are selected.
NOTE
Only items completely within the area are selected. However, if any part of a note/tie chain is
within the area, the whole note/tie chain is selected.

RELATED LINKS
Status bar on page 45

Moving the view
You can move the view within the music area in Write and Engrave modes.
PROCEDURE
1.

In the status bar, click Hand Tool.
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2.

Click and drag in any empty space in the music area.
The mouse pointer changes into a hand symbol during the move.

RELATED LINKS
Status bar on page 45

View types
Dorico provides different ways to view your layouts.
Dorico saves your chosen view type for each layout, so you only need to set it once. You can
change the default view types for new projects in the preferences.
The following view types are available:
Galley View
Lays out your music on a single continuous system. It also shows all of the
instruments that are included in the active layout and flow.
This view type is most useful during the process of inputting the music as it allows
you to focus on the musical content of your project.
NOTE
Note spacing in galley view is unjustified, which means that it is neither expanded
nor contracted to fit the width of a page or a music frame. However, changes made
to note spacing in galley view also apply to page view.
Page View
Displays your layout paginated exactly as it appears when you print or export it.
This view type is useful if you want to view spreads or single pages. Spreads allow
you to work out page turns, because the performer only needs to turn the page at
the end of the right-hand page of a pair. Viewing single pages can be helpful if you
want to print the layout as a series of single pages. This might be necessary if you
are using, for example, a fan-fold or concertina approach, in which case the
distinction between left- and right-hand pages is insignificant.
RELATED LINKS
Preferences on page 53
Page arrangements for page view on page 47
Changing the view type of the music area on page 52

Page arrangements for page view
You can change the way pages are arranged for display in the music area.
Spreads Horizontally

Displays pages in pairs as two-page spreads, with each pair laid out from left to right
in a row.
Spreads Vertically

Displays pages in pairs as two-page spreads, with each pair laid out from top to
bottom in a column.
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Single Pages Horizontally

Displays individual pages laid out from left to right.
Single Pages Vertically

Displays individual pages laid out from top to bottom.
RELATED LINKS
Changing the view type of the music area on page 52

Zoom options
You can change the size of notes and notations in the music area.
Zoom Out
Decreases the size of notes and notations in the music area.
Custom Zoom
Allows you to set a custom zoom percentage.
Set Zoom
Allows you to select one of the available zoom scaling factors. You can set a
permanent zoom factor in Preferences.
Zoom In
Increases the size of notes and notations in the music area.
RELATED LINKS
Preferences on page 53

Setting up your workspace
Dorico enables you to set up your workspace according to your working style.
Dorico allows you to open multiple tabs to display multiple layouts in the same project within the
same window. You can also open the same project in several windows.
RELATED LINKS
Hiding/Showing panels on page 20

Opening multiple views/layouts at the same time
You can use tabs to display multiple layouts or different views of the same layout within the same
project window. For example, you can show your full score layout in page view in one tab and in
galley view in another tab.
Each tab can contain a separate layout or an additional view of a layout that is already open in
another tab or window. Whenever you open a new tab, you are prompted to select a layout that
you want to display in the tab.
You can find the tabs at the top of the music area, below the toolbar. If you do not see the tabs,
click Show Tabs in the toolbar.
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PROCEDURE
1.

Open a new tab in any of the following ways:
●

Press Ctrl/Cmd-T.

●

To the right of the tabs, click New Tab.

●

Choose Window > New Tab.

A new tab opens that shows several icons at the top and a list of layouts at the bottom.

2.

Select a layout to open in the new tab in any of the following ways:
●

Click one of the icons.

●

Select a layout from the list at the bottom.

●

Click Select Layout on the toolbar and choose one of the layouts from the pop-up
menu.

RESULT
The layout that you choose opens in the active tab.
TIP
You can also switch between different layouts within the same tab.

RELATED LINKS
Switching between layouts on page 94

Showing multiple tabs in the same project window
You can split your project window to display two tabs at the same time. The split can be either
vertical or horizontal, allowing you to display different layouts either side by side or above one
another.
Splitting your project window divides your currently open tabs into two groups. You can move
tabs between the groups at any time, for example, to compare different layouts together or to
compare two views of the same layout.
PROCEDURE
1.

Select the tab of the layout that you want to move to a new tab group.

2.

Split the view in one of the following ways:
●

To show layouts side by side, choose Window > Vertical Split.
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●

To show layouts above one another, choose Window > Horizontal Split.

RESULT
The project window is split to show two tabs at the same time. The selected tab is moved to the
new tab group.
RELATED LINKS
Moving tabs to another tab group on page 51

Closing tabs
You can close individual tabs of layouts that you no longer need, and you can close multiple tabs
at the same time.
PROCEDURE
●

Close tabs in any of the following ways:
●

Select the tab you want to close and press Ctrl/Cmd-W.

●

Hover over the tab you want to close and click x.

●

Right-click the single tab you want to close and choose Close Tab from the context
menu.

●

Right-click the tab you do not want to close and choose Close Other Tabs from the
context menu.

NOTE
You cannot close the last tab in a window. If only one tab is open and you no longer want
to see the tabs, deactivate Show Tabs in the main toolbar. The tab is no longer displayed,
but the corresponding layout is still shown.

RESULT
If you selected a single tab and closed it, the selected tab and its corresponding layout are
closed.
If you selected a single tab and close other tabs, all open tabs except for the selected tab are
closed.

Switching between tabs
You can switch between different open tabs to show different layouts in the music area.
PROCEDURE
●

Switch tabs in any of the following ways:
●

Press Ctrl/Cmd-Tab to cycle through all open tabs in turn.

●

Press Ctrl/Cmd-Shift-Tab to cycle through all open tabs in reverse order.

●

Click the tab to which you want to switch.

●

Choose Window > Next Tab/Previous Tab.
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Changing the order of tabs
You can move tabs to a different position on the tab bar.
PROCEDURE
1.

Click and drag a tab to the new position.
The other tabs move to show where the dragged tab will be positioned.

2.

Release the mouse button.

Moving tabs to another tab group
You can move tabs to other tab groups.
NOTE
You can only move tabs to other tab groups if you have opened at least two tabs.

PROCEDURE
1.

Click and drag the tab to a blank space next to the target tab group.

2.

Release the mouse button.

Moving tabs to other windows
You can move tabs to another open window of the same project to show the corresponding
layouts in a new window.
NOTE
●

The layouts must belong to the same project. If you attempt to move a tab to a window of
a different project, a new window is created for the project to which the layout belongs.

●

You can only move tabs to other windows if you have opened at least two tabs.

PROCEDURE
●

Do one of the following:
●

To create a new window of the same project with the tab inserted, click and drag a
tab horizontally to the right/left, away from the tab bar and release it.

●

To insert the tab into the tab bar of another window of the same project, click and
drag a tab onto the tab bar.

●

Select and right-click a tab and choose Move Tab to New Window from the context
menu.

●

Select a tab and click Window > Move Tab to New Window.

Opening multiple project windows
You can open multiple project windows for the same project.
This can be useful if you want to see and work on multiple layouts at the same time. You can also
open multiple project windows to show different modes of the same project.
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Each window in a project is completely independent, so you can, for example, have one window
in Write mode and another in Engrave mode. During playback, all windows that belong to the
same project show the playhead and move the view to follow the music during playback.
PROCEDURE
●

Open a new project window in any of the following ways:
●

Press Ctrl/Cmd-Shift-T.

●

Choose Window > New Window.

RESULT
A duplicate of the window opens. It contains the same tabs and the same view options as the
original window.
RELATED LINKS
Playhead on page 313

Changing to full screen mode
You can maximize the amount of screen estate available for your music by making any project
window cover the whole screen.
You can also hide the desktop elements provided by your operating system, for example, the
task bar in Windows or the system menu bar and Dock in macOS.
Within Dorico you can also hide/show the panels on the right, left, and at the bottom of the
window.
PROCEDURE
●

Choose View > Full Screen.

AFTER COMPLETING THIS TASK
To return to the default view, choose View > Full Screen again.
RELATED LINKS
Hiding/Showing panels on page 20

Changing the view type of the music area
You can switch between several view types of the music area.
PROCEDURE
1.

In the status bar, click the view selector.

2.

Choose one of the view types from the list.

3.

●

Galley View

●

Page View

Optional: If you selected Page View, choose one of the following page arrangement
options:
●

Spreads Horizontally
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●

Spreads Vertically

●

Single Pages Horizontally

●

Single Pages Vertically

RELATED LINKS
View types on page 47
Page arrangements for page view on page 47

Preferences
In the Preferences dialog, you can make permanent settings for your workspace and define key
commands.
You can open Preferences in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Dorico > Preferences (macOS).

●

Choose Edit > Preferences (Windows).

RELATED LINKS
View types on page 47
Zoom options on page 48
Selection tools on page 46
Layout Options dialog on page 62
Key Commands on page 10

General Preferences
General
Language
Allows you to select the language that is used for text in the user interface.
Preferred unit of measurement
Helps you to convert between the internal units and points that are used in Dorico
and your own preferred units. For example, the information box to the right of Space
size in the Page Setup section of the Layout Options dialog uses your selected unit
to help you determine the staff size.

Window
Theme
Allows you to switch to different program colors.
Open new windows maximized
If you activate this option and open a new window, the window is maximized to fit
the screen. This does not affect windows that are already open.
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When the last window is closed
Allows you to specify what happens when you close the last project window.

View
Default zoom
Allows you to determine the zoom scaling factor that is used when you create a new
project.
Default view type
Allows you to select the view type for new projects.

Files
Show complete path for recent files
If you activate this option, the paths for recently used files are displayed in the Hub
and on the File menu together with the file names.

Editing
Default click-drag behavior
Allows you to select the selection tool that you want to use by default in your
projects.
Double-click in Setup or Engrave mode switches to Write mode
If you activate this option, you can switch to Write mode from either Setup mode or
Engrave mode by double-clicking.
Allow multiple items to be created with the mouse
If you activate this option, you can select items in panels and input them on multiple
notes without having to reselect items each time for each note.
Creating items with the mouse
Allows you to set your preference for mouse input. You can either input items at the
position of the note or item currently selected in the music area, or you can load
items onto the cursor and then click where you want to input them.

Play
Audio Device Setup
Opens the Device Setup dialog.
Open VST plug-in windows when opening projects
If you activate this option, the VST plug-in that you selected for your project opens in
a separate window when you open your project.
Suspend audio device in background
Allows other applications to play back via your audio hardware even though Dorico is
running. If you activate this option, the audio device that you use is suspended when
Dorico loses focus so that other applications may use it.
NOTE
Make sure that other audio applications accessing the audio hardware are set to
release the audio driver.
Enable MIDI input
If you activate this option, you can input notes using any MIDI input device, such as a
MIDI keyboard that is connected to your computer.
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Play notes during note input and selection
If you activate this option, notes are played back in the following circumstances:
●

Selecting notes

●

Inputting notes

●

Navigating through selections using the arrow keys

●

Clicking the noteheads of individual notes or a stem in a chord

Follow playhead during playback
If you activate this option, the event display in Play mode advances when the
playhead reaches the right-hand side of the display. This keeps the music being
played in view.
Show playhead when stopped
If you activate this option, the playhead is displayed during playback and when
stopped. If you deactivate this option, the playhead is only displayed during
playback.

Key Commands
Most of the main menus in Dorico have key commands for certain menu items. In addition, there
are numerous other Dorico functions that can be performed by pressings.
In the Key Commands section of the Preferences dialog, you can customize existing key
commands according to your needs and also add commands for many menu items and functions
that have no key command assigned.
Search
Allows you to search for menu items and functions to view, change, or add key
commands.
Assigned key commands
Shows if the selected menu item or function has a key command.
Keyboard language
Allows you to select the language of your keyboard.
New key command
Allows you to input a new key command by pressing the respective keys on your
computer keyboard.
Remove Key Command
Removes a key command from the selected menu item or function.
Add Key Command
Activates a key command that you have input for a function.
Reset Key Commands
Returns to the default key commands provided by Dorico.
Print Summary
Opens the Dorico Key Commands tool which shows the available key commands for
your keyboard layout.
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In Setup mode, you can determine the players and instruments for your project. You can also
create and manage flows and set up layouts.

Project window in Setup mode
The project window in Setup mode contains the default toolbar, the music area, and the status
bar. It provides panels with all the tools and functions that allow you to create players and assign
instruments as well as to specify the layouts and flows for your score.
You can switch to Setup mode in any of the following ways:
●

Press Ctrl/Cmd-1.

●

Click Setup in the toolbar.

●

Choose Window > Setup.

Panels in Setup mode

The following panels are available:
1

Players
Lists the players, instruments, and groups in your project.
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2

Layouts
Lists the layouts that are created for players.

3

Flows
Shows the flows that are created for your project.

If you select or edit items on a panel, the panel and the selected item are highlighted in a
different color. In each of the panels, you can activate/deactivate players, layouts, and flows
independently to determine the following:
●

The players included in each flow
IMPORTANT
If you exclude a player from a flow, any notes you have already input for that player in that
flow are deleted.

●

The players that you want to show/print in an instrumental part/full score layout

●

The flows that you want to show/print in instrumental parts/full score layouts

To verify that all the players and flows that you selected are shown in a layout, select the layout in
the layout selector.

Players panel
The Players panel lists the players, instruments, and groups in your project.
You can hide/show the Players panel in Setup mode in any of the following ways:
●

Press Ctrl/Cmd-7.

●

Click the disclosure arrow on the left of the window.

●

Choose Window > Show Left Panel.

Players panel in Setup mode

The Players panel lists all the groups, players, and ensembles in your project as cards. Each
player card shows the following:

1

Disclosure arrow
Expands/Collapses the player card.

2

Player type
Shows the type of player from the following options:
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3

●

Solo player

●

Section player

Player name
Shows the name of the player. Dorico automatically adds the names of the assigned
instruments to the player name. If required, you can rename the player.

4

Add instruments icon
Opens a popover from which you can select an instrument for the player.

5

Instrument list
If the player card is expanded, this shows all instruments that are assigned to the player. If
you move the mouse over an instrument name, an arrow appears that allows you to open
a context menu with further options.

At the bottom of the Players panel, the following options are available:
Add Solo Player

Adds an individual player to your project.
NOTE
For each solo player that you add, Dorico automatically adds an instrumental part
layout to the Layouts panel.
Add Section Player

Adds a player to your project that represents multiple players who all play the same
instrument.
NOTE
For each section player that you add, Dorico automatically adds an instrumental part
layout to the Layouts panel.
Add Ensemble

Adds multiple players to your project that represent standard combinations of
musical instruments.
NOTE
If you add an ensemble, Dorico automatically adds instrumental part layouts for
each player in the ensemble to the Layouts panel.
Add Group

Adds a group to your project to which you can assign all types of players.
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Delete Player

Deletes selected players or groups from the Players panel.
The order in which the players are listed in the panel is the default order in which they appear in
layouts. You can change the player order for each layout individually in the Players section of the
Players page in Setup > Layout Options.
RELATED LINKS
Players on page 65
Layouts panel (Setup mode) on page 59
Layout Options dialog on page 62

Layouts panel (Setup mode)
In Setup mode, the Layouts panel lists all the full score and instrumental part layouts.
You can hide/show the Layouts panel in Setup mode in any of the following ways:
●

Press Ctrl/Cmd-9.

●

Click the disclosure arrow on the right edge of the main window.

●

Choose Window > Show Right Panel.

The Layouts panel lists the default full score layout and all the layouts that you created for your
project as cards. Each layout card shows the following:

1

Disclosure arrow
Expands/Collapses the layout card.

2

Layout type
Shows the type of layout from the following options:
●

Full score layout

●

Instrumental part layout
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●

3

Custom score layout

Layout name
Shows the name of the layout. Dorico automatically adds default names depending on the
name of the instrument that is assigned to a player and on the type of layout that is
added. For example, if you assign a flute to a player, the instrumental part layout
automatically gets the same name. If you add an empty instrumental part layout, the
layout name shows Empty part and an incremental number if you add several empty part
layouts.

4

Space size
Shows the space size between two staff lines in points. This indicates the size of staves in
the layout.
NOTE
You can change the space size in each layout independently in Layout Options.

5

Page size and orientation
Shows the width and height of the pages of a layout and their orientation (portrait or
landscape).

At the bottom of the Layouts panel, the following options are available:
Add Full Score Layout

Adds a full score layout to your project. By default, every player and flow is
automatically included in the layout.
Add Instrumental Part Layout

Adds an empty instrumental part layout to your project. You can then add one or
multiple players to the layout. By default, a part layout contains all flows that are
created in your project.
Add Custom Score Layout

Adds a custom score layout that initially without players or flows.
Sort Layouts

Sorts all layouts in the Layouts panel according to their type in the following order:
full score layouts, instrumental part layouts, custom score layouts.
Layout Options

Opens the Layout Options dialog for one or multiple selected layouts.
Delete Layout

Deletes selected layouts from the Layouts panel.
RELATED LINKS
Layouts on page 91

60

Setup mode
Project window in Setup mode
Layout Options dialog on page 62

Flows panel
The Flows panel shows all the flows that are created for your project.
You can hide/show the Flows panel in Setup mode in any of the following ways:
●

Press Ctrl/Cmd-8.

●

Click the disclosure arrow at the bottom of the main window.

●

Choose Window > Show Bottom Panel.

The Flows panel shows the default flow and all the flows that you created for your project as
cards. Each flow card shows the following:

1

Flow name
Shows the name of the flow. If you create multiple flows without renaming them, each
flow name shows a number that increments with each new flow that you create. The
number also indicates the position of the flow in a layout.

2

Flow number
Shows the number of the flow. The number increments with each new flow that you
create. The number also indicates the position of the flow in a layout.

To the right of the Flows panel, the following options are available:
Add Flow
Adds a new flow to your project. By default, every new flow is automatically included
in all layouts, and every player is added to the new flow.

Notation Options
Opens the Notation Options dialog that provides multiple options that allow you to
make changes that affect the way music is notated for each flow.

Delete Flow
Deletes one or multiple selected flows.

RELATED LINKS
Flows on page 88
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Project Info dialog
For every project and every flow that you create in Dorico, you can specify project information in
the Project Info dialog.
●

You can open the Project Info dialog by choosing File > Project Info.

In the Project Info dialog, you can enter information for the whole project and for each flow. For
example, each flow in your project might have a different composer and lyricist.
You can use tokens in text frames to refer to the information you enter into the different fields on
the different pages in the Project Info dialog.
RELATED LINKS
Text tokens on page 254

Layout Options dialog
The Layout Options dialog provides multiple options that allow you to make changes that affect
the way the notation is laid out on pages of each layout.
You can change the physical properties of the layout, such as page size, staff size, or margins,
and the notation, such as note spacing or staff labels.
NOTE
●

You can make project-wide changes to the appearance and position of different items in
Engrave > Engraving Options.

●

You can save all options that you set in Layout Options as default values for new projects
by selecting a layout type from the Layout type menu and clicking Save as Default.

You can open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options at the bottom of the Layouts panel in Setup mode.

●

Right-click an instrumental part or a full score in the Layouts panel and choose Layout
Options from the context menu.
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Layout Options

The Layout Options dialog consists of the following items:
1

Category menu
Select a category from the Category menu to show the page containing all the relevant
options for the selected category.

2

Layouts list
Lists all the layouts in your project. You can select one, multiple, or all layouts. You can
select multiple layouts in any of the following ways:

3

●

Click one of the selection options.

●

Ctrl/Cmd-click to select multiple layouts.

●

Shift-click to select multiple adjacent layouts.

Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. The currently selected option is highlighted.
Click other options to choose them instead.

4

Selection options
Allow you to select layouts in the Layouts list according to their type.
●

5

Select All selects all layouts in the Layouts list, regardless of their type.

●

Select All Full Score Layouts selects all full score layouts in the Layouts list only.

●

Select All Part Layouts selects all part layouts in the Layouts list only.

●

Select All Custom Score Layouts selects all custom score layouts in the Layouts list
only.

Layout type
Allows you to select the layout type for which you want to save your settings as the default.
For example, you can save new default settings for part layouts without affecting the
default settings for full score layouts.
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6

Save as Default
Saves all options that you set in Layout Options as default for the selected layout type in
new projects.

7

Reset to Factory
Resets all your options to the default factory settings for the selected layout type. You can
use this to remove all changes you have made.

RELATED LINKS
Engraving Options dialog on page 228
Notation Options dialog on page 110
Playback Options dialog on page 312
Staves on page 700
Making layout-specific changes in Layout Options on page 64

Making layout-specific changes in Layout Options
You can make project-wide changes for each layout independently in Layout Options.
PROCEDURE
1.

2.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options at the bottom of the Layouts panel in Setup mode.

●

In Setup mode, right-click an instrumental part or a full score in the Layouts panel
and choose Layout Options from the context menu.

In the Layouts list, select the layouts in which you want to change options in one of the
following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select a page from the Category menu.

4.

Look through the available options, and change the options you want.

5.

Click Apply, then Close.
NOTE
If you make changes and close the dialog without clicking Apply, you are prompted to
save or discard your changes.

RESULT
The changes are applied immediately to the selected layouts.
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Players
Before you start writing music, you must specify the players that are playing one or multiple
instruments.
A player can be a solo player, which represents a single person who can play one or more
instruments. For example, a clarinettist may double alto saxophone or bass clarinet.
A player can also be a sectional player, which represents multiple people, each of whom plays the
same instrument. For example, a violin section or the soprano section of a choir.
Dorico uses this knowledge about players and their instruments to assist you in producing a
practical score efficiently, for example, by making it very easy to handle instrument doubling,
divisi, and condensing music for multiple players onto a smaller number of staves.
If you add a player in Dorico, the following happens automatically:
●

An instrumental part layout is created.

●

The player is added to any full score layouts that already exist. If no full score layouts
exists, a new full score layout is created.

●

The player is included in all existing flows.

RELATED LINKS
Flows on page 88
Layouts on page 91
Changing the players assigned to layouts on page 92
Changing the players assigned to flows on page 89

Adding solo/section players
You can add both solo and section players to your project. Solo players can hold multiple
instruments.
PREREQUISITE
The Players panel is open.
PROCEDURE
1.

In the Players panel, add an empty-handed player in any of the following ways:
●

If you have started a new project, click Add Solo Player in the project start area.

●

If you have started a new project, click Add Section Player in the project start area.

●

At the bottom of the Players panel, click Add Solo Player.

●

At the bottom of the Players panel, click Add Section Player.

The instrument picker opens.
TIP
You can also open the instrument picker at any time by clicking the plus symbol in solo
player cards.
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Alternatively, you can right-click a player and choose Add Instrument to Player.
2.

Select an instrument in the instrument picker in any of the following ways:
●

Start entering the instrument name you want, then select it from the filtered list.

●

Click an instrument family and then an instrument.

●

Press Up Arrow/Down Arrow to select an instrument family, then press Tab to
switch to the instrument column. Press Up Arrow/Down Arrow to select an
instrument.
TIP

3.

●

An enclosure line shows which instrument family or instrument is selected
when using the keyboard to navigate.

●

Press Shift-Tab to switch back to the previous column in the instrument
picker.

Add the selected instrument in any of the following ways:
●

Press Return.

●

Click Add.

RESULT
The solo/section player is automatically named after the selected instrument.
TIP
If you want to add multiple instruments to your project at the same time, you can add ensembles
or use a project template.
AFTER COMPLETING THIS TASK
If you added a solo player and you want them to hold multiple instruments, add other
instruments to the solo player.
RELATED LINKS
Player, layout, and instrument names on page 67
Changing player names on page 68
Project start area on page 41
Adding instruments to players on page 73
Adding ensembles on page 71
Starting new projects from project templates on page 36

Duplicating players
You can duplicate players. This adds another player of the same type.
PROCEDURE
●

In the Players panel, right-click the player you want to duplicate and choose Duplicate
Player from the context menu.

RESULT
A new player is added, with the same instruments as the original player. The original and new
players are automatically numbered to ensure their names are unique.
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RELATED LINKS
Player, layout, and instrument names on page 67
Changing player names on page 68
Instrument numbering on page 72

Player, layout, and instrument names
In Dorico, you can use three different names to refer to the same player in different contexts.
This allows you to show relevant information in different places in the score.
The three different names that relate to players and instruments are:
●

Player name

●

Layout name

●

Instrument name

You can change all of these names for individual players independently of other instruments of
the same type. Each name is used in different places. Player and layout names are shown using
text tokens.
Player name
Given to players in the Players panel. It is not used in the score, instead you can use
the player name as part of your own workflow, independently of what instruments
and players are called in staff labels and layout names.
Player names are automatically generated when you add instruments.
Layout name
The name for each layout in the Layouts panel. They are used at the top of individual
part layouts.
Layout names are automatically generated when you add instruments, and are
linked to the player name until you change the layout name.
Instrument names
Used in staff labels. This means that the instrument label on each staff is relevant to
the instrument currently being played by that player, rather than listing all
instruments that player is playing in the flow.
For example, if a clarinettist is doubling bass clarinet, the staff label where the player
plays clarinet automatically shows Clarinet, and the staff label automatically shows
Bass Clarinet where the player plays bass clarinet.
All instruments in Dorico come with a set of instrument names that you can change.
You can change the instrument names for individual instruments independently,
even if other players in the project are playing the same instrument.
You can save your changes to instrument names as default, so your names are used
whenever you add that instrument again in the project.
NOTE
Changing the default instruments names does not change the instrument names of
existing instruments of that type in your project.

RELATED LINKS
Instrument numbering on page 72
Edit Instrument Names dialog on page 68
Text tokens on page 254
Staff labels on page 690
Layouts on page 91
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Edit Instrument Names dialog
You can change the instrument names used in staff labels in the Edit Instrument Names dialog.
You can specify singular and plural full instrument names, and singular and plural short
instrument names for each instrument.
●

You can open the Edit Instrument Names dialog in Setup mode by clicking the arrow in
an instrument label in the Players panel and choosing Edit Names.

The Edit Instrument Names dialog includes the following options:
Singular full name
Allows you to set the name shown in staff labels whenever full instrument names are
shown and the staff contains a single player.
Singular short name
Allows you to set the name shown in staff labels whenever short instrument names
are shown and the staff contains a single player.
Plural full name
Allows you to set the name shown in staff labels whenever full instrument names are
shown and the staff contains multiple players.
Plural short name
Allows you to set the name shown in staff labels whenever short instrument names
are shown and the staff contains multiple players.
Show transposition
Allows you to choose when the transposition is shown in the instrument name for
the selected instrument. It is common to see the transposition included in the name
of transposing instruments, such as Clarinet in B♭.
You can choose when the transposition is shown from the following options:
●

Always

●

Follow Layout Options

●

Never

Save as default for instrument
Activating the checkbox saves your changes in the dialog as the default for any new
instruments of that type that you add to the project.
RELATED LINKS
Changing instrument names on page 70
Project-wide layout options for staves on page 700

Changing player names
You can change the player names of players, and reset renamed players to their default name.
NOTE
Player names are not used for staff labels in the score or for naming layouts, instead they are for
your own reference in Setup mode.
Staff labels use the name set for each instrument in the Edit Instrument Names dialog.

PROCEDURE
1.

In the Players panel, select the card of the player whose player name you want to change.

2.

Open the player name text field in any of the following ways:

68

Setup mode
Players
●

Double-click anywhere in the player card.

●

Right-click in the player card and choose Rename from the context menu.

3.

Enter a new name, or click Reset to Default to revert the name to the default name.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the text field.

RESULT
The player name of the selected player is changed.
NOTE
This does not change the staff label that appears in the score. You can change the name used for
staff labels in the Edit Instrument Names dialog, and change the layout name for the names at
the top of parts.

RELATED LINKS
Edit Instrument Names dialog on page 68

Changing layout names
Layout names are used to identify individual layouts, for example, as the name at the top of
parts. You can change the layout names of players, and reset renamed players to their default
name.
NOTE
Layout names are not used for staff labels. Staff labels use the name set for each instrument in
the Edit Instrument Names dialog.

PROCEDURE
1.

In the Layouts panel, select the name of the player whose layout name you want to
change.

2.

Open the layout name text field in any of the following ways:
●

Double-click anywhere in the layout card.

●

Right-click in the layout card and choose Rename from the context menu.

3.

Enter a new name, or click Reset to Default to revert the name to the player name.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the layout name field.

RESULT
The layout name of the selected player is changed, or reverted to the default name.
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NOTE
This does not change the staff label that appears in the score. You can change the name used for
staff labels in the Edit Instrument Names dialog, and change the layout name for the names at
the top of parts.

RELATED LINKS
Edit Instrument Names dialog on page 68

Changing instrument names
Instrument names are used in staff labels. You can change the different instrument names used
for each instrument.
NOTE
Changing instrument names does not change the name shown at the top of part layouts. If you
want to change the name used at the top of part layouts, change the layout name.

PROCEDURE
1.

In the Players panel, click the disclosure arrow in the player card containing the
instrument whose names you want to change.
This expands the card to show the instruments held by the player.

2.

Click the arrow that appears in the instrument label when you hover over it and choose
Edit Names.
The Edit Instrument Names dialog opens.

3.

Enter new names in any of the name fields.

4.

Click OK to save your changes and close the dialog.

RESULT
The instrument names for the selected instrument are changed.
If you did not save your changes as default, only the names of the selected instrument are
changed. Any instruments of the same type added later use the original default names.
If you saved your changes as default, any instruments of the same type added later use your new
instrument names. The instrument names of any other instruments of the same type already in
your score are not changed.
RELATED LINKS
Edit Instrument Names dialog on page 68
Changing layout names on page 69

Changing the orchestral order of players
You can change the order in which players appear in the score in the Players panel.
PROCEDURE
1.

In the Players panel, select the player card of the player whose position in the score you
want to change.

2.

Click and drag the player card upwards/downwards in the panel.
An insertion line indicates where the player will be positioned.
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Deleting players
You can delete players from your project.
PROCEDURE
1.

In the Players panel, select the players that you want to delete.

2.

Delete the players in any of the following ways:
●

Press Backspace or Delete.

●

Click Delete Player.

●

Right-click a single player and choose Delete Player from the context menu.
NOTE
You can only delete a single player at a time when using the context menu.

3.

Choose one of the following options in the warning message that opens:
●

Delete Player Only
Deletes the player and the music that you created for the instruments belonging to
that player.

●

Delete Player and Part Layouts
Deletes the player, the music, and all part layouts to which the player is assigned.
NOTE
The part layout cannot be deleted if it contains more than the deleted player.

Ensembles
If you add an ensemble in Dorico, multiple players are added to your project at the same time.
Dorico provides a set of predefined ensembles that you can use. Adding an ensemble is one of
the ways to achieve building up an instrumentation quickly. The predefined ensembles that you
can create with Dorico follow standard patterns, such as double woodwind which refers to two
flutes, two oboes, two clarinets, and two bassoons.

Adding ensembles
You can add multiple players at once by adding ensembles, such as a complete string section or
four-part choir.
PREREQUISITE
The Players panel is open.
PROCEDURE
1.

Do one of the following:
●

If you have started a new project, click Add Ensemble in the project start area.

●

Click Add Ensemble at the bottom of the Players panel.

71

Setup mode
Instruments
2.

In the instrument picker, select an ensemble in any of the following ways:
●

In the search field, enter the first letters of the ensemble, then select it from the
filtered list, and click Add Ensemble to Score.

●

Scroll through the popover list, select an ensemble, and click Add Ensemble to
Score.

●

Use Tab/Shift-Tab and the arrow keys on your computer keyboard to scroll through
the popover list. To select an ensemble, press Return.

RESULT
The ensemble players are added to the Players panel, either as solo or as section players.
TIP
You can also add multiple instruments to your project at the same time by using a project
template.

RELATED LINKS
Changing player names on page 68
Project start area on page 41
Starting new projects from project templates on page 36

Instruments
You can assign instruments to solo and section players as well as to ensembles.
In Dorico, you can assign multiple instruments to solo players, as solo players often play multiple
instruments, such as an oboist doubling the cor anglais.
Before you can assign instruments, you must add players or ensembles, which may in turn also
be assigned to groups if needed. If you add ensembles, it is by default not necessary to add any
instruments, since these are already included when you select the type of ensemble. However,
you can add further instruments to ensembles.
Instruments in Dorico do not have limited ranges; it is possible to notate any pitch in any register
on every instrument. However, in the piano roll editor in Play mode, only pitches that fall in the
MIDI note range 0-127 can be represented. Similarly, if you input a pitch beyond the range of
samples in the assigned VST instrument, the pitch does not sound in playback.
You can always change the initial specification and add or delete instruments.
RELATED LINKS
Piano roll editor on page 303
VST and MIDI Instruments panel on page 309

Instrument numbering
When there are multiple instruments of the same type in the same score, they are each
automatically given a number for easy and clear identification.
For example, if there is only one flute in a score, it is called Flute, but if there are three flutes, they
are called Flute 1, Flute 2, and Flute 3.
Dorico automatically numbers instruments when there are multiple instruments of the same
type in your project.
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One violin with no number

Adding a second violin automatically generates
numbers for both violins

NOTE
Instrument numbers are automatically generated for players if the following criteria are met:
●

Players are the same type, either solo or section.

●

Players have at least one instrument in common.

●

Players are in the same group.

●

Instrument names are the same.

For example, if you have two flutes in your project, but one flute is a section player and the other
flute is a solo player, they are not numbered automatically. Similarly, if the two flutes are in
different player groups, they are not numbered automatically.

RELATED LINKS
Player, layout, and instrument names on page 67
Changing instrument names on page 70
Player groups on page 86

Transposing instruments
While most instruments produce notes at concert pitch, transposing instruments produce a note
that is different to the one that is written. For example, two common orchestral transposing
instruments are clarinet in B♭ and horn in F.
When a clarinet in B♭ plays a C, the sound produced is a B♭, one tone below. When a horn in F
plays a C, the sound produced is an F, a fifth below. Other instruments that conventionally
produce a pitch different to the one notated include the piccolo (sounding an octave above
written), double bass (sounding an octave below written), and glockenspiel (sounding two
octaves above written).
Dorico stores all note information in concert pitch and automatically transposes notes as
appropriate for the transposition of the instrument. This means notes are automatically changed
in transposing layouts compared to non-transposing layouts. You can also change instruments at
any time, and the music is adjusted automatically to ensure the correct pitches are shown.
RELATED LINKS
Concert vs. transposed pitch on page 94
Changing whether layouts are transposing/non-transposing on page 93

Adding instruments to players
You can add instruments to both solo and section players. You can add multiple instruments to
solo players, but only a single instrument to section players.
PREREQUISITE
You have added a solo or section player.
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PROCEDURE
1.

2.

In the Players panel, open the instrument picker in any of the following ways:
●

Select the solo or section player and press Shift-I.

●

Click the plus symbol to the right of the added empty-handed player.

●

Right-click the player and choose Add Instrument to Player from the context
menu.

Select an instrument in the instrument picker in any of the following ways:
●

Start entering the instrument name you want, then select it from the filtered list.

●

Click an instrument family and then an instrument.

●

Press Up Arrow/Down Arrow to select an instrument family, then press Tab to
switch to the instrument column. Press Up Arrow/Down Arrow to select an
instrument.
TIP

3.

4.

●

An enclosure line shows which instrument family or instrument is selected
when using the keyboard to navigate.

●

Press Shift-Tab to switch back to the previous column in the instrument
picker.

Add the selected instrument in any of the following ways:
●

Press Return.

●

Click Add.

Optional: Repeat steps 1 to 3 to add multiple instruments to a single solo player.
NOTE
You can only add a single instrument to each section player.

RESULT
The selected instrument is added to the player. If you selected multiple players, the instrument is
only added to the first player in the Players panel.
TIP
If you want to add multiple instruments to your project at the same time, you can add ensembles
or use a project template.

RELATED LINKS
Adding ensembles on page 71
Starting new projects from project templates on page 36

Adding empty percussion kits to players
You can add empty percussion kits to players, to which you can then add unpitched percussion
instruments.

PROCEDURE
1.

In the Players panel, open the Edit Percussion Kit dialog in any of the following ways:
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2.

●

Select a solo or section player, press Shift-I, and click Create Empty Kit in the
instrument picker.

●

Click the plus symbol to the right of the added empty-handed player and click
Create Empty Kit in the instrument picker.

●

Right-click a player and choose Create Empty Kit from the context menu.

Add the percussion instruments you want to the kit in the Edit Percussion Kit dialog.

RELATED LINKS
Edit Percussion Kit dialog on page 77

Combining individual percussion instruments into kits
If a player is holding one or more individual percussion instruments, you can combine them into
a percussion kit.
PROCEDURE
1.

Right-click the card of the player whose percussion instruments you want to combine into
a kit and choose Combine Instruments into Kit from the context menu.

2.

Edit the kit in the Edit Percussion Kit dialog that opens.
For example, you can change the order in which the instruments appear in a grid or on a
five-line staff.

RESULT
A new kit is created containing all the instruments held by the player.
NOTE
If the player was already holding one or more kit instruments, all individual instruments and any
other kits are combined into the first kit.

Changing instruments
You can change the instruments held by players without affecting any music already entered
onto their staves. You can change pitched instruments and individual unpitched percussion
instruments, but you cannot change percussion kits into other instruments.
NOTE
Only unpitched percussion instruments are shown in the instrument picker when you choose
Change Instrument for an unpitched percussion instrument.

PROCEDURE
1.

In the Players panel, expand the card of the player whose instrument you want to change.
The card lists the instruments of the player.

2.

Hover over the label of the instrument you want to change, click the arrow that appears,
and choose Change Instrument.
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The instrument picker opens.
3.

Select an instrument in the instrument picker in any of the following ways:
●

Start entering the instrument name you want, then select it from the filtered list.

●

Click an instrument family and then an instrument.

●

Press Up Arrow/Down Arrow to select an instrument family, then press Tab to
switch to the instrument column. Press Up Arrow/Down Arrow to select an
instrument.
TIP

4.

●

An enclosure line shows which instrument family or instrument is selected
when using the keyboard to navigate.

●

Press Shift-Tab to switch back to the previous column in the instrument
picker.

Change to the selected instrument in any of the following ways:
●

Press Return.

●

Click Add.

RESULT
The selected instrument is changed, without affecting any music on its staff.
NOTE
Where appropriate, new clefs are input. This means that notes can appear differently so that they
are notated correctly according to the new clef.

Moving instruments between players
You can move individual instruments between players without affecting any music already input
for those instruments.
PROCEDURE
●

In the Players panel, move instruments to other players in any of the following ways:
●

Click and drag instruments individually and release them over the player card to
which you want to move them.

●

Click the arrow that appears in the instrument label when you hover over it and
choose Move Instrument to Player > [Player].
NOTE
You can only move instruments to players already added to your project.

RELATED LINKS
Adding solo/section players on page 65
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Deleting instruments
You can delete instruments from players.
IMPORTANT
If you delete an instrument from a player, any music that you have created for this instrument is
also deleted.

PROCEDURE
1.

In the Players panel, click the disclosure arrow in the player card of the player holding the
instrument you want to delete.
The player card opens.

2.

Click the arrow that appears in the instrument label when you hover over it and choose
Delete Instrument.

3.

Click OK.

RESULT
The instrument is deleted from the player.

Edit Percussion Kit dialog
You can make changes to percussion kits in the Edit Percussion Kit dialog, which opens
automatically when you create empty kits or combine existing instruments into a kit.
●

You can open the Edit Percussion Kit dialog to edit existing percussion kit instruments by
expanding the player card of the player holding the percussion kit in the Players panel in
Setup mode. Then click the arrow in its label and choose Edit Percussion Kit.

NOTE
Percussion kit instrument labels are green in the Players panel in Setup mode.
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Edit Percussion Kit dialog

1

Name
Allows you to enter the full name for the percussion kit. This is used in Full staff labels for
percussion kits that use the five-line staff presentation type.

2

Short name
Allows you to enter the abbreviated name for the percussion kit. This is used in
Abbreviated staff labels for percussion kits that use the five-line staff presentation type.

3

Drum set
Allows you to define the percussion kit as a drum set by activating the checkbox.
Percussion kits that are defined as drum sets follow your settings for drum sets on the
Percussion page in Notation Options, including for voicing and default stem directions.

4

Presentation types
Allows you to select a percussion kit presentation type in order to edit how the selected
percussion kit appears in that presentation type.
●

5-line Staff
Kit instruments are shown on a five-line staff. You can determine which instruments
are shown on each line and in each space of the staff. A single staff label containing
the name of the kit is shown.

●

Grid
Kit instruments are shown on a grid, with each instrument on its own line. You can
customize how large the gaps between each line are. Staff labels are shown for each
instrument in a smaller font than normal staff labels.

●

Single-line Instruments
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Kit instruments are shown as individual instruments with their own lines. Normalsized staff labels are shown for each instrument.
5

Displays the current arrangement of instruments in the selected percussion kit
presentation type. You can change the order of instruments, and the layout of lines and
spaces in the grid presentation type, by using the controls.

6

Controls
Allows you to change the order and stem direction of instruments in the selected
percussion kit presentation type.
You can access dialogs to change the noteheads used for each instrument in the kit by
clicking Edit Noteheads, and how combinations of noteheads and articulations and
tremolos affect playback by clicking Edit Percussion Playing Techniques.
You can also change the names of individual instruments within percussion kits. Click Edit
Names to open the Edit Instrument Names dialog.
NOTE
This changes the appearance of percussion instrument names in all presentations.
Staff labels use different information, depending on the kit presentations.

7

Action bar
The action bar at the bottom of the dialog provides other operations that apply to all
presentation types.

Edit Percussion Kit dialog action bar

1

Add New Instrument
Opens the instrument picker, allowing you to choose a new unpitched percussion
instrument to be added to the kit.

2

Add Existing Instrument From Player
Shows a menu listing the other players in your project that are holding individual
percussion instruments not in kits. You can select a percussion instrument from another
player to move to this kit, bringing its music with it.

3

Remove Instrument From Kit
Removes the selected instrument from the kit, so it appears as an individual instrument.
You can move individual instruments to other players or into other kit instruments.

4

Change Instrument
Shows the instrument picker, allowing you to choose a new unpitched instrument to
replace the selected instrument, while retaining its music.

5

Delete Instrument
Deletes the instrument from the kit, including its music.

RELATED LINKS
Percussion kits on page 783
Staff labels for percussion kits on page 698
Percussion kit presentation types on page 788
Percussion Instrument Playing Techniques dialog on page 790
Playing techniques for unpitched percussion instruments on page 790
Defining percussion kits as drum sets on page 81
Defining how combinations of articulations and single-note tremolos sound in playback on page
334
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Specifying the stem direction/voice of instruments in percussion kits on page 798

Adding instruments to percussion kits
You can add new instruments to percussion kits within the Edit Percussion Kit dialog.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit to which you want to
add instruments.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
The Edit Percussion Kit dialog opens.

3.

Click Add New Instrument.

4.

Select a percussion instrument in the instrument picker in any of the following ways:
●

Start entering the instrument name you want, then select it from the filtered list.

●

Click an instrument family and then an instrument.

●

Press Up Arrow/Down Arrow to select an instrument family, then press Tab to
switch to the instrument column. Press Up Arrow/Down Arrow to select an
instrument.
TIP

5.

6.

●

An enclosure line shows which instrument family or instrument is selected
when using the keyboard to navigate.

●

Press Shift-Tab to switch back to the previous column in the instrument
picker.

Add the selected instrument in any of the following ways:
●

Press Return.

●

Click Add.

Click Close.

RESULT
The selected instrument is added to the percussion kit.
RELATED LINKS
Edit Percussion Kit dialog on page 77

Changing instruments in percussion kits
You can change existing instruments in percussion kits while retaining any existing music for that
instrument.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit in which you want to
change instruments.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
The Edit Percussion Kit dialog opens.

3.

Click the instrument you want to change.

4.

Click Change Instrument in the action bar.
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5.

Select a percussion instrument in the instrument picker in any of the following ways:
●

Start entering the instrument name you want, then select it from the filtered list.

●

Click an instrument family and then an instrument.

●

Press Up Arrow/Down Arrow to select an instrument family, then press Tab to
switch to the instrument column. Press Up Arrow/Down Arrow to select an
instrument.
TIP

6.

7.

●

An enclosure line shows which instrument family or instrument is selected
when using the keyboard to navigate.

●

Press Shift-Tab to switch back to the previous column in the instrument
picker.

Change to the selected instrument in any of the following ways:
●

Press Return.

●

Click Change.

Click Close.

RESULT
The instrument is changed to the one selected in the instrument picker. Any music input for the
previous instrument is retained.
NOTE
Playing techniques expressed using playing technique-specific noteheads are not retained.

RELATED LINKS
Edit Percussion Kit dialog on page 77

Defining percussion kits as drum sets
You can define individual percussion kits as drum sets. Drum sets follow your project-wide
setting for voicing in drum sets with five-line staff presentations.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit you want to define as a
drum set.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
The Edit Percussion Kit dialog opens.

3.

Activate Drum set in the top right of the dialog.

4.

Click Apply, then Close.

RESULT
The selected percussion kit is defined as a drum set. The arrangement of voices for instruments
in the kit when using the five-line staff presentation type follows your project-wide setting on the
Percussion page in Write > Notation Options.
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NOTE
If you no longer want a percussion kit to be defined as a drum set, you can deactivate Drum set
in the Edit Percussion Kit dialog for that kit.

RELATED LINKS
Notation Options dialog on page 110
Edit Percussion Kit dialog on page 77
Percussion Instrument Playing Techniques dialog on page 790

Creating groups of instruments within grid presentation percussion kits
You can create groups of instruments within percussion kits that use the grid presentation type
in order to have a better overview of the instruments in the kit.
In grid presentation percussion kits, the name of each individual instrument is shown in the staff
label. You can simplify the staff label of grid presentation percussion kits by creating groups, for
example, to show Wood Blocks instead of Wood Block (High), Wood Block (Medium), and Wood
Block (Low).
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit in which you want to
create groups in the grid presentation.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
The Edit Percussion Kit dialog opens.

3.

Click Grid at the top of the dialog.

4.

Click the first instrument you want to include in the group.

5.

Shift-click the last instrument you want to include in the group.
NOTE
You can only include adjacent instruments in groups.

6.

Click Add.

RESULT
A group is created containing the selected instruments. The group is given a default name that
you can change.
RELATED LINKS
Edit Percussion Kit dialog on page 77
Renaming groups in grid presentation percussion kits on page 82

Renaming groups in grid presentation percussion kits
Group names are shown as instrument labels. You can change the names of groups in
percussion kits using grid presentation.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit in which you want to
change the names of groups in the grid presentation.
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2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
The Edit Percussion Kit dialog opens.

3.

Click Grid at the top of the dialog.

4.

Open the Edit Percussion Grid Group Names dialog in any of the following ways:
●

Double-click the group.

●

Click the group, then click Edit.

Groups are shown as colored blocks in the column to the left of the list of percussion kit
instruments.
5.

6.

Enter the names you want to give the group in the corresponding fields in the Edit
Percussion Grid Group Names dialog:
●

Full Name

●

Short Name

Click OK to save your changes and close the dialog.

RESULT
The name of the group is changed. This also changes the staff label for the group.
NOTE
Staff labels for groups in grid presentation percussion kits use a different paragraph style to the
staff labels for non-grouped instruments in grid presentation percussion kits.
EXAMPLE

Ungrouped grid presentation percussion kit

Grid presentation percussion kit with wood blocks
grouped

RELATED LINKS
Edit Percussion Kit dialog on page 77
Staff labels for percussion kits on page 698

Deleting groups within grid presentation percussion kits
You can delete groups in percussion kits using grid presentation, without deleting the
instruments within the group.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit from whose grid
presentation you want to delete groups.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
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The Edit Percussion Kit dialog opens.
3.

Click Grid at the top of the dialog.

4.

Click the group you want to delete.
Groups are shown as colored blocks in the column to the left of the list of percussion kit
instruments.

5.

Click Delete.

RESULT
The group is deleted. The individual staff labels for each instrument in the group are restored.
RELATED LINKS
Edit Percussion Kit dialog on page 77

Changing the positions of instruments within percussion kits
You can change the positions of instruments within percussion kits of all presentation types to
change the order in which the instruments appear in the score and parts.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit in which you want to
change the positions of instruments.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
The Edit Percussion Kit dialog opens.

3.

Click the kit presentation type in which you want to change the order of instruments.
For example, click Grid to change the order of instruments when the kit uses the grid
presentation type.

4.

Click a percussion instrument whose position you want to change.

5.

Change the position of the selected instrument in any of the following ways:
●

Click Move up arrow to move it upwards.

●

Click Move down arrow to move it downwards.

●

Click and drag the instrument upwards/downwards (five-line staff presentation
only).

6.

Optional: Repeat these steps for other instruments in the percussion kit, and for other kit
presentation types for the same percussion kit.

7.

Click Apply, then Close.

RESULT
The position of the selected instrument within the kit is changed. Multiple instruments can share
the same staff position, but we recommend that they use different noteheads so that the player
can tell them apart.
RELATED LINKS
Edit Percussion Kit dialog on page 77
Moving notes to different instruments in percussion kits on page 786
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Changing the size of gaps between lines in percussion grids
You can change the size of gaps between lines in percussion kits using the grid presentation
type.
PROCEDURE
1.

In the Players panel, expand the card of the player in whose percussion kit you want to
change the size of gaps in the grid presentation.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
The Edit Percussion Kit dialog opens.

3.

Click Grid at the top of the dialog.

4.

Click the instrument below which you want to change the gap size.

5.

Change the value in the Gap field in any of the following ways:

6.

●

Enter a value into the value field and press Return.

●

Click the arrows beside the value field.

Click Apply, then Close.

RESULT
The size of the gap below the selected instrument is changed.
RELATED LINKS
Edit Percussion Kit dialog on page 77

Removing individual instruments from percussion kits
You can remove individual instruments from percussion kits, for example, if you want to move
individual instruments in percussion kits to other players.
PROCEDURE
1.

In the Players panel, expand the card of the player holding the kit from which you want to
delete instruments.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
The Edit Percussion Kit dialog opens.

3.

Click the instrument you want to remove from the kit.

4.

Click Remove Instrument From Kit in the action bar.

5.

Click Close.

RESULT
The selected instrument appears as an individual instrument belonging to the same player but
separate from the percussion kit.
You can then move the instrument to other players if required.
RELATED LINKS
Edit Percussion Kit dialog on page 77
Moving instruments between players on page 76
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Player groups
Grouping players together means they are positioned together in the score, numbered
independently, and are bracketed together according to the ensemble type chosen on the
Brackets and Braces page in Engraving Options.
For example, if your project is for double choir (SATB/SATB), all voices are joined by a single
bracket by default because they are in the same family. However, if you add each choir to its own
group, they are bracketed separately. This is useful for to bracket players properly in works
containing multiple groups, such as in Britten's “War Requiem”, which has three distinct groups,
or in Walton's “Belshazzar's Feast” which requires two separate off-stage brass groups.
Similarly, you can create a group for an off-stage group of players in a large-scale work.
If the instruments were not already next to each other according to orchestral order, adding a
player group changes the order of players in the score project-wide.

Adding groups of players
You can organize players into groups, for example, if you want to bracket them together.
PREREQUISITE
The Players panel is open.
PROCEDURE
1.

Optional: In the Players panel, select the players that you want to include in the group.

2.

At the bottom of the Players panel, click Add Group.

RESULT
If you selected one or more players, they are added to the group. If no player was selected, an
empty group is added to the Players panel.
RELATED LINKS
Adding players to groups on page 87
Brackets and braces on page 422

Renaming player groups
You can change the name of player groups after you have added them.
PROCEDURE
1.

In the Players panel, double-click the name of the group.

2.

Enter the new name.

3.

Press Return.

Deleting player groups
You can delete groups of players.
NOTE
If you delete a group, you can keep the players that you added to the group.
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PROCEDURE
1.

In the Players panel, select the group that you want to delete.

2.

Delete the group in any of the following ways:

3.

●

Click Delete.

●

Press Delete.

Choose one of the following options in the warning message that opens:
●

Keep Players
Deletes the group but keeps the players.

●

Delete Players
Deletes the group and the players it contains.

Adding players to groups
You can add existing or new players to player groups.
PREREQUISITE
You have added at least one player, one ensemble, or one group.
PROCEDURE
●

In the Players panel, do one of the following:
●

Select one or more players and click Add Group.

●

Select a group, and click Add Solo Player, Add Section Player, or Add Ensemble.

RESULT
If you clicked Add Group, a new group is added for the selected players. If you clicked Add Solo
Player, Add Section Player or Add Ensemble, a new player or ensemble is added to the selected
group.
RELATED LINKS
Adding groups of players on page 86
Adding solo/section players on page 65

Moving players between groups
You can move players from one group to another.
PROCEDURE
1.

In the Players panel, select the players that you want to move to another group.

2.

Click and drag the selected players to the position you want in the other group.
An insertion line indicates where the players will be positioned.

RESULT
The players are moved to the other group.
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Removing players from groups
You can remove players from groups.
PROCEDURE
●

In the Players panel, remove players from groups in any of the following ways:
●

Click and drag multiple selected players out of the group and release the mouse
button.

●

Right-click a single player and choose Remove Player from Group from the context
menu.
NOTE
You can only remove a single player from a group at a time when using the context
menu.

RESULT
The players are removed from their groups but remain in the project as individual players.

Flows
Flows are separate spans of music within your project, for example, movements or songs.
Every project contains at least one flow, and by default, every layout includes the music from
every flow in your project. If you create a new flow in Dorico, the following happens:
●

All music that you write for the new flow is automatically included in the existing full score
and instrumental part layouts. You can exclude any flow from any layout by deactivating
the respective flow card.

●

All players are added to the new flow. You can exclude players from the flow by
deactivating the respective player card.
IMPORTANT
If you exclude a player from a flow, any notes that you have already input for that player in
that flow are deleted.

You can change certain options in each flow independently in the Notation Options dialog.
RELATED LINKS
Flows in Dorico on page 33
Flows panel on page 61
Changing options in Notation Options on page 112
Players on page 65
Layouts on page 91
Changing the players assigned to flows on page 89
Changing the flows assigned to layouts on page 92

Adding flows
If you need more than one flow in your project, you can add new flows.
PROCEDURE
1.

In the Flows panel, click Add Flow.
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2.

Optional: Repeat for as many flows as you require.

RESULT
A new flow is added to your project each time you click Add Flow. All existing players are
assigned to new flows, and new flows are automatically added to all existing full score and part
layouts.

Changing the players assigned to flows
By default, all players in your project are added to all flows. You can assign players to and remove
players from flows manually, for example, if the soloists in a choral work do not sing for an entire
flow.
IMPORTANT
If you exclude a player from a flow, any notes you have already input for that player in that flow
are deleted.

PROCEDURE
1.

In the Flows panel, select the flow whose assigned players you want to change.

2.

In the Players panel, change the players assigned to the flow in the following ways:

3.

●

Activate the checkbox in the player card of each player you want to assign to the
flow.

●

Deactivate the checkbox in the player card of each player you want to remove from
the flow.

Optional: Repeat steps 1 and 2 for other flows whose assigned players you want to
change.

RESULT
Players are assigned to the selected flow when the checkbox in their player card is activated, and
removed from the flow when the checkbox is deactivated.
RELATED LINKS
Flows on page 88
Players on page 65
Layouts on page 91
Changing the flows assigned to layouts on page 92
Changing the players assigned to layouts on page 92

Flow names and flow titles
Whenever you add a flow to a project, the default name of a flow is Flow plus an incremental
number. You can rename flows in the Project Info dialog and in the Flows panel in Setup mode.
When you enter names for flows in the Flows panel in Setup mode, those names are
automatically added in the Title field for the appropriate flow in the Project Info dialog. If you
change the name in the Flows panel again later, the flow title is updated in the Project Info
dialog.
Titles shown in scores and parts in the music area are linked to the Title field for each flow in the
Project Info dialog.
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This link is maintained until you change the names of flows in the Project Info dialog. Once you
change flow titles in the Project Info dialog, changing flow names in the Flows panel no longer
updates the Title field for that flow in the Project Info dialog.
This allows you to organize flows in Setup mode with different names to their official title.
RELATED LINKS
Project Info dialog on page 62
Text tokens on page 254

Renaming flows in Setup mode
You can change the names of flows in Setup mode. This automatically updates the title of the
corresponding flow until you change the title in the Project Info dialog.
PROCEDURE
1.

In the Flows panel, open the flow name text field in any of the following ways:
●

Double-click the name of the flow.

●

Right-click the name of the flow and choose Rename from the context menu.

2.

Enter a new name for the flow or edit the existing name.

3.

Press Return.

RESULT
The name of the flow is changed. If you have not entered a different title for the flow in the
Project Info dialog, the title shown in the music area is updated to match the new flow name.

Changing flow titles in the Project Info dialog
You can change flow titles in the Project Info dialog. Once you have done so, flow titles are no
longer changed if you change their name in the Flows panel in Setup mode.
PROCEDURE
1.

Choose File > Project Info.
The Project Info dialog opens.

2.

Select the flow whose title you want to change from the menu. Alternatively, use the arrow
buttons beside the menu to choose the flow.

3.

Enter the new title you want in the Title field.

4.

Optional: Repeat steps 2 and 3 for other flows in your project.

5.

Click OK to save your changes and close the dialog.

RESULT
The titles of the selected flows are changed to what you entered.
NOTE
This breaks the link between flow names in the Flows panel in Setup mode and the title shown in
the music area.
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Deleting flows
You can delete flows that you no longer need. This deletes all music for all instruments belonging
to all players in the flows.
PROCEDURE
1.

In the Flows panel, select the flows you want to delete.

2.

Delete the flows in any of the following ways:
●

Press Backspace or Delete.

●

Click Delete Flow.

●

Right-click the flow and choose Delete Flow from the context menu.

Layouts
Layouts allow you to present the music in your project differently for different purposes. For
example, part layouts only include the music that player needs to play whereas full score layouts
contain all staves in the project.
Dorico provides three types of layouts:
Full score
A full score layout includes by default all players and all flows in your project. You can
remove players and flows that you do not need. Full score layouts are concert pitch
by default.
Instrumental part
An instrumental part layout is automatically created when you add a player to your
project. You can add further players to the instrumental part layout. You can also
create empty instrumental part layouts and add players.
By default, instrumental part layouts contain all flows but you can exclude flows that
you do not need. They are also transposed pitch by default.
Custom score
A custom score layout initially does not contain any players or flows. This allows you
to create your score manually and to add, for example, only one flow instead of all
flows or only vocal and piano staves to create a condensed score for the chorus.
Custom score layouts are concert pitch by default.
RELATED LINKS
Page layouts on page 262
Flows on page 88
Players on page 65
Changing the flows assigned to layouts on page 92
Changing the players assigned to layouts on page 92

Creating layouts
You can create multiple layouts for full scores and instrumental parts. You can also create
multiple custom score layouts.
PROCEDURE
●

At the bottom of the Layouts panel, select one of the following layout types:
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●

Add Full Score Layout

●

Add Instrumental Part Layout

●

Add Custom Score Layout

RESULT
The layout is added to the list of layouts in the Layouts panel.
AFTER COMPLETING THIS TASK
You can assign players and flows to your layout.

Changing the players assigned to layouts
By default, all players are included in full score layouts and each player is automatically assigned
its own part layout. You can assign players to and exclude players from layouts manually, for
example, if you want to remove unnecessary players from the full score, or you want to add the
soloists’ music to the part for the accompanist.
PROCEDURE
1.

In the Layouts panel, select the layout whose assigned players you want to change.

2.

In the Players panel, change the players assigned to the layout in the following ways:

3.

●

Activate the checkbox in the player card of each player you want to assign to the
layout.

●

Deactivate the checkbox in the player card of each player you want to remove from
the layout.

Optional: Repeat steps 1 and 2 for any other layouts whose assigned players you want to
change.

RESULT
Players are assigned to the selected layout when the checkbox in their player card is activated,
and removed from the layout when the checkbox is deactivated. If you have not changed the
name of the layout, it is automatically updated to reflect the players included in the layout.
RELATED LINKS
Player, layout, and instrument names on page 67
Changing layout names on page 69
Flows on page 88
Players on page 65
Layouts on page 91
Changing the players assigned to flows on page 89
Changing the flows assigned to layouts on page 92

Changing the flows assigned to layouts
By default, all flows in your project are added to all layouts. You can exclude flows that you do not
want to show in a layout. You can assign flows to and remove flows from layouts manually, for
example, if a flow in your project contains specific performance instructions for strings that you
want to show in string part layouts but not in other part layouts.
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PROCEDURE
1.

In the Layouts panel, select the layout whose assigned flows you want to change.

2.

In the Flows panel, change the flows assigned to the selected layout in the following ways:

3.

●

Activate the checkbox in the flow card of each flow you want to assign to the layout.

●

Deactivate the checkbox in the flow card of each flow you want to remove from the
layout.

Optional: Repeat steps 1 and 2 for other layouts whose assigned flows you want to
change.

RESULT
Flows are assigned to the selected layout when the checkbox in their flow card is activated, and
removed from the layout when the checkbox is deactivated.
RELATED LINKS
Flows on page 88
Players on page 65
Layouts on page 91
Changing the players assigned to layouts on page 92
Changing the players assigned to flows on page 89

Renaming layouts
You can change the name of layouts.
If you add an instrumental part layout to project, its default name is Empty part. The default
names of full score and custom score layouts are Full score and Custom score. If you add
several layouts, an incremental number is added to the default names.
PROCEDURE
1.

In the Layouts panel, open the layout name text field in any of the following ways:
●

Double-click the name of the layout.

●

Right-click the name of the layout and choose Rename from the context menu.

2.

Enter the new name for the layout or edit the existing name.

3.

Press Return.

RELATED LINKS
Instrument numbering on page 72

Changing whether layouts are transposing/non-transposing
You can change whether each layout in your project is transposing or non-transposing. In Dorico,
full score layouts are non-transposing and part layouts are transposing by default.
For example, full scores are often non-transposing to show notes at concert pitch but part
layouts are often transposing so the player can read the notes they must play in order to achieve
the desired sounding pitch.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.
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2.

In the Layouts list, select the layouts you want to change to transposing/non-transposing
in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Players from the Category menu.

4.

In the Players section, activate/deactivate Transposing layout.

5.

Click Apply, then Close.

RESULT
The selected layouts are transposed pitch when Transposing layout is activated, and concert
pitch when it is deactivated.
TIP
You can see music at transposed pitch in any layout by choosing Edit > Transposed Pitch, and
see music at concert pitch in any layout by choosing Edit > Concert Pitch.

Concert vs. transposed pitch
Layouts in Dorico can use concert or transposed pitch. This affects the pitches and key signatures
on staves belonging to transposing instruments.
When music is in concert pitch, all notes are written as they sound. This means that players with
transposing instruments reading music in concert pitch must transpose the music themselves.
For example, if a clarinet in B♭ reads a C in concert pitch, they must play the note D on their
instrument to produce the sounding note C.
When music is in transposed pitch, the notes written are the ones each instrument must play in
order to produce the desired sounding pitch. For example, if a clarinet in B♭ reads a D in
transposed pitch, the pitch that sounds from the instrument is C.
Transposing scores and parts also transpose key signatures according to the transposition of the
instrument.
RELATED LINKS
Transposing instruments on page 73
Transposing key signatures alongside selections on page 549
Enharmonic equivalent key signatures on page 549

Switching between layouts
If you have created several layouts in your project, you can switch between which is displayed in
the music area in every mode.
NOTE
You can only switch between layouts to which players are assigned.
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PROCEDURE
●

Open another layout in any of the following ways:
●

Press Shift-Alt-] to switch to the next layout.

●

Press Shift-Alt-[ to switch to the previous layout.

●

Select an item on a staff or in the piano roll of the player whose layout you want to
open and press W.
NOTE
Implicit rests are not items.

●

Select an item on a staff or in the piano roll of the player whose layout you want to
open and choose Window > Counterpart Layout.

●

Select a layout from the menu in the middle of the toolbar.

RESULT
The selected layout is opened in the music area. It replaces the layout previously open in the tab.
RELATED LINKS
Tab bar on page 41
Opening multiple views/layouts at the same time on page 48

Sorting layouts
You can sort selected layouts in the Layouts panel.
PROCEDURE
1.

Click and drag a layout card to a different position in the panel.
An insertion line indicates where the players will be positioned.

2.

Release the mouse button.

RESULT
The layout is inserted at the selected position.

Deleting layouts
You can delete layouts from the list of layouts in the Layouts panel.
PROCEDURE
1.

Select the layouts that you want to delete.

2.

Delete the layouts in any of the following ways:
●

Press Backspace or Delete.

●

Click Delete Layout.

●

Right-click a single layout and choose Delete Layout from the context menu.
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NOTE
You can only delete a single layout at a time when using the context menu.
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Write mode

In Write mode, you can create your music. You can input notes and insert notations into your
project.

Project window in Write mode
The project window in Write mode contains the default toolbar, the music area, and the status
bar. It provides toolboxes and panels with the tools and functions that you need to write your
music.
You can switch to Write mode in any of the following ways:
●

Press Ctrl/Cmd-2.

●

Click Write in the toolbar.

●

Choose Window > Write.

Toolboxes and panels in Write mode

The following panels and toolboxes are available:
1

Notes toolbox
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Contains all tools that allow you to modify the note input.
2

Notes panel
Contains the note types, accidentals, and articulations that are most commonly used
during note input.

3

Notations panel
Contains all the notation items that you can use for your music.

4

Notations toolbox
Allows you to select tools that determine which notation items are shown in the Notations
panel.

5

Properties panel
Contains quick access properties that are required to make specific modifications to the
notation.

Notes toolbox
The tools in the Notes toolbox allow you to modify notes.
Dotted Notes

Adds rhythm dots to notes or chords, and removes rhythm dots from notes or
chords.
You can also activate/deactivate Dotted Notes by pressing . (period).
You can increase the number of dots on notes by pressing Alt-. (period).
Rests

Allows you to input rests of the duration currently selected in the Notes panel.
You can also activate/deactivate Rests by pressing , (comma).
Chords

Allows you to add several notes at the same rhythmic position in order to build a
chord. This function prevents the caret from advancing automatically after inputting
a note.
You can also activate/deactivate Chords by pressing Q
Tuplets

Inserts a triplet bracket and the respective number of rests at the specified rhythmic
position. If the notes are beamed, no brackets are used.
You can input other types of tuplet, such as quintuplets, by using the tuplets
popover.
Grace Notes

Allows you to input grace notes at the current rhythmic position.
You can also activate/deactivate Grace Notes by pressing /.
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Insert

Inserts music instead of overwriting.
You can also activate/deactivate Insert by pressing I.
Lock to Duration

Uses the duration of existing music for note input via MIDI or computer keyboard.
This tool helps you to maintain the duration of notes while you change their pitches.
You can also activate/deactivate Lock to Duration by pressing L.
Force Duration

Always creates the explicit duration that you have specified on the Notes panel. For
example, you can activate Force Duration to force the input of a dotted quarter note
on the second quarter beat of 4/4, where Dorico splits the note with a tie by default.
IMPORTANT
You can get unexpected results if you force the duration of notes and later change
the time signature or move barlines, for example.
If you activated Force Duration during input, you can remove the restrictions on
how Dorico notates the music by selecting the affected passage of music and
selecting Edit > Reset Appearance.
You can also activate/deactivate Force Duration by pressing O.
Tie

During step input, this ties the note to be input to the previous note of the same
pitch. When editing existing notes, you can use this tool to tie together notes in
different voices or to tie grace notes to rhythmic notes.
You can also activate/deactivate Tie by pressing T.
Scissors

Splits a note or chord in two at the rhythmic position where the tool is applied.
You can also activate/deactivate Scissors by pressing U.
Select

Activates/Deactivates mouse input.
RELATED LINKS
Inputting notes with rhythm dots on page 117
Inputting chords on page 129
Inputting tuplets on page 131
Inputting grace notes on page 128
Activating/Deactivating mouse input on page 140
Tuplets popover on page 132
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Notes panel
The Notes panel contains buttons that allow you to input note durations, accidentals, slurs, and
articulations.
You can hide/show the Notes panel in any of the following ways:
●

Press Ctrl/Cmd-7.

●

Click the disclosure arrow below the Notes toolbox.
/

The upper part of the Notes panel contains note durations that you can input.
NOTE
Not all the available note durations are visible by default. To see all note durations, click Show/
Hide All Notes at the top or bottom of the note durations list.
/
In the middle part of the Notes panel, you can activate accidentals and slurs.
At the bottom part of the Notes panel, you can activate articulations.

Properties panel
The Properties panel in Write mode contains quick access properties that allow you to change
notes and notations, both during note input and by changing existing notes.
The options that are available on the Properties panel depend on the item that you select in your
score. Only properties relevant to the currently selected item are displayed. If you select multiple
different types of notation items, only properties that they have in common are displayed.
For example, if you select a note with no other notations or articulations, the Common and
Notes and Rests groups are displayed. If you select a tied note with an articulation, the
Common group, the Notes and Rests group, the Ties group, and the Articulations group are
displayed. This shows you all the options that you can change for that note.
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NOTE
If you need to change parts of notations, for example, the bow of a tied note, switch to Engrave
mode.
You can hide/show the Properties panel in Write mode and Engrave mode in any of the following
ways:
●

Press Ctrl/Cmd-8.

●

Click the disclosure arrow at the bottom of the window.
/

●

Choose Window > Show Bottom Panel.

Notes and Rests group of the Properties panel in Write mode

RELATED LINKS
Changing the properties of individual items in Write mode on page 101

Changing the properties of individual items in Write mode
You can change the properties of notes and notations.
NOTE
You can only change a complete note or a complete notation. To make changes to individual
parts of notes or notations, switch to Engrave mode, for example, if you want to change the
length of a note stem. To change notes and notations project-wide for your project, you must
edit the Notation Options, by choosing Write > Notation Options or by pressing Ctrl/CmdShift-N.

PROCEDURE
1.

Select a note or notation item in the score.

2.

Open the Properties panel in any of the following ways:

3.

●

Press Ctrl/Cmd-8.

●

Click the disclosure arrow at the bottom of the window.

●

Choose Window > Show Bottom Panel.

Change the appropriate properties in the Properties panel.

RESULT
The complete note or notation item is changed. The changes are immediately displayed in the
music area.
RELATED LINKS
Properties panel on page 100
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Notations toolbox
The tools in the Notations toolbox allow you to determine what notation items are shown in the
Notations panel.
Clefs

Opens sections in the Notations panel that allow you to select different clefs and
octave lines.
Key Signatures, Tuning Systems, and Accidentals

Opens sections in the Notations panel that allow you to specify and select different
key signatures, and to select different tonality systems and accidentals.
Time Signatures (Meter)

Opens sections in the Notations panel that allow you to specify and select different
time signatures.
Tempo

Opens sections in the Notations panel that allow you specify and select different
tempos and tempo changes.
Dynamics

Opens sections in the Notations panel that allow you to specify and select different
dynamics.
Ornaments

Opens sections in the Notations panel that allow you to select different ornaments
and glissando lines.
Repeat Structures

Opens sections in the Notations panel that allow you to input different repeat ending
structures and segments, and select and remove different single-note and multi-note
tremolos.
Bars and Barlines

Opens sections in the Notations panel that allow you to insert bars and to create
barlines.
Holds and Pauses
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Opens sections in the Notations panel that allow you to insert different types of
fermatas, breath marks, and caesuras.
Playing Techniques

Opens sections in the Notations panel that allow you to insert playing techniques for
various instrument groups.
Cues

Opens sections in the Notations panel that allow you to find suitable places for cues
and input cues.
Rehearsal Marks

Inserts a rehearsal mark at the selected note.
Text

Opens the text editor which allows you to insert text at the selected rhythmic
position.
Lyrics

Opens the lyrics popover above the selected note on the staff, which allows you to
input lyrics.
Chord Symbols

Opens the chord symbols popover above the selected note on the staff, which allows
you to input chord symbols.
Fingerings

Opens the fingerings popover above the selected note on the staff, which allows you
to input fingerings.
RELATED LINKS
Lyrics popover on page 202
Chord symbols popover on page 168
Fingerings popover on page 143
Cues panel on page 218
Text editor options in Write mode on page 214

Notations panel
The Notations panel contains the notation items for your music.
Depending on your selection in the Notations toolbox, different notation options are available in
the Notations panel.
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You can hide/show the Notations panel as often as you want, for example, if you want to find a
notation to input but then want to increase the size of the music area after inputting it.
RELATED LINKS
Hiding/Showing panels on page 20

Introduction to inputting and editing
Dorico distinguishes the processes for inputting and editing music.
Whenever you see the caret, you are inputting new music. When you do not see the caret, you
are editing existing music.
You can switch back and forth between inputting and editing.
We recommend that you spend a moment to understand the difference between how Dorico
behaves if the caret is shown and if it is not. In the latter case, all editing functions operate on the
items that you have selected in the music area.
RELATED LINKS
Differentiating between inputting and editing your music on page 104
Mouse input settings on page 108
Large selections on page 109
Filters on page 109
Note input on page 112
Notations input on page 141

Differentiating between inputting and editing your music
Depending on whether you input or you edit notes, the tools in the toolboxes and the panels
behave differently.
To input notes, the caret must be activated.
If the caret is activated, selecting tools or items in the Notes toolbox and the Notes panel affects
the note or chord that you are about to input as you can specify the duration, rhythm dot,
accidentals, and articulations. Then you specify the pitch by clicking the note into the score, by
pressing the letter name of the note on your computer keyboard, or by playing the note or chord
on your MIDI keyboard.
If no notes or chords are selected in the music area and you select a duration from the Notes
panel, either by pressing its key command or by clicking it with the mouse, mouse input is
activated. If you move the mouse pointer over the music, a shadow note is displayed to indicate
where the note will be input if you click.
To edit notes, one or more items must be selected in the music area. If one or more notes or
chords are selected in the music area, the Notes toolbox and Notes panel affect the selected
notes and chords. If you select a new duration from the Notes panel, either by pressing its key
command or by clicking it with the mouse, the durations of the selected notes and chords are all
edited to match the chosen duration.
RELATED LINKS
Caret on page 112
Caret activation/deactivation on page 114
Inputting notes on page 115
Rhythmic grid on page 105
Moving notes rhythmically on page 578
Changing the pitch of individual notes on page 138
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Rhythmic grid
The rhythmic grid is a unit of rhythmic duration whose value affects certain aspects of inputting
and editing, such as the amount by which items move. However, it does not control the duration
of notes and items that you input.

Rhythmic grid set to eighth notes (quavers) shown above the staff

The current rhythmic grid value is shown by the note value in the status bar, and by ruler
markings above the staff on which the caret is active. Longer lines in the rhythmic grid indicate
beat divisions, while shorter lines indicate beat subdivisions.
The rhythmic grid helps you to identify the following:
●

The exact input position when using the caret or the mouse

●

The amount by which the caret moves when using Right Arrow/Left Arrow

●

The amount by which notes and items are lengthened/shortened

●

The amount by which notes and items move

It also allows you to control how precisely notes and items are positioned when inputting them
with the mouse or when copying and pasting. For example, setting the rhythmic grid value to
32nd notes allows you to input notes and items at a greater number of possible rhythmic
positions than when the rhythmic grid is set to quarter notes.
You can change the rhythmic grid value at any time.
RELATED LINKS
Caret on page 112
Moving the caret manually on page 115
Changing the rhythmic grid value on page 105

Changing the rhythmic grid value
You can change the value of the rhythmic grid. The value is indicated by the note value symbol in
the status bar and by the beat divisions and subdivisions in the ruler markings above the caret.
NOTE
The rhythmic grid value is set to eighth notes (quavers) by default.

PROCEDURE
●

Change the value of the rhythmic grid in any of the following ways:
●

Press Alt-] to decrease the rhythmic grid value.

●

Press Alt-[ to increase the rhythmic grid value.

●

Choose Write > Rhythmic Grid > Decrease Grid Resolution.

●

Choose Write > Rhythmic Grid > Increase Grid Resolution.

●

Choose Write > Rhythmic Grid > [Beat division].

●

Select a value from the Rhythmic Grid selector on the status bar.
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RESULT
Decreasing the rhythmic grid value makes it finer. Increasing the rhythmic grid value makes it
coarser.
RELATED LINKS
Status bar on page 45

Positions of new items
The input positions of new items depends on whether you input or edit music.
When you input music and the caret is activated, Dorico creates any note or notation at the
rhythmic position of the caret.
When you edit music and one or more notes or chords are selected in the music area, Dorico
creates a new item at the position of the first selected item in the music area. If there is no
selection, the mouse pointer is loaded with the new item. The item is then created at the location
where you click.
EXAMPLE
Adding a time signature in front of a selected note
You can add a 3/4 time signature in front of a specific note in any of the following ways:
●

Select the note, press Shift-M, enter 3/4 into the time signatures popover, and press
Return.

●

With no note selected, click Time Signatures (Meter) in the Notations toolbox. Then click
3/4 in the Common section, and click at the position where you want to insert the time
signature.

RELATED LINKS
Moving notes rhythmically on page 578

Signposts
In Dorico, signposts indicate the positions of important items that either cannot be seen in the
score, such as key signatures with no accidentals or items you have hidden.
Signposts have different colors depending on the item they mark because many items can show
signposts, such as hidden bar numbers and time signatures. They are selectable, meaning you
can use signposts to change properties of hidden/invisible items, for example, by selecting
system break signposts in order to change the staff size from that position.
Signposts include a text summary of the hidden/invisible item to help you identify it. For
example, time signature signposts include the time signature, expressed as a fraction, and its
beat subdivision.

The signpost of a hidden time signature

You can hide/show signposts for the following items:
●

Accidentals

●

Chord symbols

●

Clefs
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●

Cues

●

Dynamics

●

Frame breaks

●

Key signatures

●

Note spacing changes input using the Note Spacing Change dialog

●

Pedal lines

●

System breaks

●

Tempo marks

●

Text, both system and staff

●

Percussion legends

●

Time signatures

●

Tuplets

When multiple signposts can exist at a single rhythmic position, they stack vertically so that they
do not overlap and so remain legible.

Multiple signposts for different items at the same rhythmic position

NOTE
By default, signposts are not printed or included when you export graphics files. However, you
can include signposts and other annotations when printing/exporting layouts.

RELATED LINKS
Annotations on page 352
Hiding/Showing signposts on page 107

Hiding/Showing signposts
You can hide/show all signposts or only hide/show signposts for specific items at any time in
Setup, Write, and Engrave modes.
PROCEDURE
●

Hide/Show signposts in any of the following ways:
●

To hide/show all signposts, choose View > Signposts > Hide Signposts.

●

To hide/show signposts for specific items, choose View > Signposts > [Type of
item].
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Mouse input settings
There are a number of different settings that you can choose from to determine how mouse
input functions in Dorico.
You can set your preferences for mouse input in the Editing section of the General page in
Preferences.
You can choose between the following options for mouse input:
●

Create item at selection
Items are input at the position of selected items or notes in the music area.

●

Load cursor with item
Items are loaded onto the cursor so you can click in the music area where you want to
input the item.

You can also activate/deactivate Allow multiple items to be created with the mouse.
When Allow multiple items to be created with the mouse is activated, you can load an item
onto your cursor and input the same item in the music area multiple times without having to
reselect the item each time you input it. When this option is deactivated, you can only input an
item loaded onto your cursor once. If you want to input the item at multiple positions, you must
reselect it each time.
NOTE
Changing your preferences permanently changes the functionality in the whole application, not
just in the current project.

RELATED LINKS
Preferences on page 53

Selecting/Deselecting notes and items individually
You can select existing notes and other notation items individually in the music area, for
example, if you want to add articulations to a selection of notes or delete a short passage of
music.
NOTE
If you want to select a large number of notes/items, we recommend that you use one of the
larger selection methods.

PROCEDURE
1.

Select individual notes/items in the music area in any of the following ways:
●

2.

Ctrl/Cmd-click individual notes/items.

●

Shift-click adjacent notes/items.

●

Click a single note/item.

●

Make a marquee selection around multiple notes/items.

Deselect all currently selected items in any of the following ways:
●

Press Ctrl/Cmd-D.

●

Click outside of the staves within the music area.
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RELATED LINKS
Large selections on page 109
Making marquee selections on page 46

Large selections
You can make large selections, including selecting the contents of whole staves or the whole
flow.
Select everything in a specific area
You can use the Marquee Tool to specify an area in which you want to select
everything.
Select everything in the whole flow
●

Press Ctrl/Cmd-A.

●

Choose Edit > Select All.

Select everything on a single staff
●

Select the first note on the staff, hold down Shift, and select the last note on
the staff.

●

Select the first note on the staff and choose Edit > Select To End Of System or
Edit > Select To End Of Flow.

●

Make a marquee selection that includes the staff you want to select.

Select everything on multiple adjacent staves
●

Select one whole staff at the top/bottom of the range of staves you want to
select and press Shift-Up Arrow or Shift-Down Arrow until all the staves you
want are selected.

●

Select one whole staff at the top/bottom of the range of staves you want to
select and Shift-click the staff at the other end of the range of staves you want
to select.

●

Make a marquee selection that includes the staves you want to select.

TIP
If you want to select only a certain type of item, such as lyrics or dynamics, you can then use the
corresponding filters.

RELATED LINKS
Filters on page 109
Selecting/Deselecting notes and items individually on page 108
Making marquee selections on page 46

Filters
Filters in Dorico allow you to select only a specific type of item from a larger selection. Dorico
includes a filter for every notation item.
●

You can find the available filters by choosing Edit > Filter > [Item] > [Item type].

All significant notation items have their own filter, for example, arpeggio signs, chord symbols,
key signatures, and playing techniques. You can also filter for note spacing changes.
The following items have multiple filters because they have multiple types:
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Notes
Allows you to filter notes, including grace notes, their position in chords, and
according to their accidental and pitch.
Voices
Allows you to filter voices according to their stem-direction.
Dynamics
Allows you to filter all dynamics as well as gradual and immediate dynamics.
Tempos
Allows you to filter all tempo marks as well as absolute, relative, and gradual tempo
changes.
Lyrics
Allows you to filter all lyrics as well as by their line number, type, and placement
relative to the staff.
NOTE
There is no filter for barlines. You also cannot filter fingerings, beams, articulations, or tremolos,
as they are considered part of the notes to which they apply.

RELATED LINKS
Filters for lyrics on page 553

Notation Options dialog
The Notation Options dialog provides multiple options that allow you to make changes that
affect the way music is notated for each flow.
The changes that you can make affect the following:
●

Note and rest grouping, such as the handling of syncopated rhythms or of different
rhythms in different time signatures

●

Voices, such as the sharing of noteheads among voices or the order in which multiple
voices are tucked together

●

Accidentals, such as the handling of cautionary accidentals

●

Transposition, such as the handling of key signatures in transposing instruments

TIP
If you want to make direct changes to notes and notations, you can use the different options in
the Properties panel.
You can open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

●

Click Notation Options on the right of the Flows panel in Setup mode.
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Notation Options

The Notation Options dialog consists of the following items:
1

Category menu
Select a category from the Category menu to show the page containing all the relevant
options for the selected category.

2

Flows list
Lists all the flows in your project. You can select one, multiple, or all flows. You can select
multiple flows in any of the following ways:

3

●

Ctrl/Cmd-click to select multiple flows.

●

Shift-click to select multiple adjacent flows.

Section
Pages are divided into sections, which can contain multiple options. Sections that contain
many options are divided into subsections. The currently selected option is highlighted.
Click other options to choose them instead.

4

Select All
Allows you to select all flows in the Flows list.

5

Save as Default
Saves all options that you set in Notation Options as default for new projects.

6

Reset to Factory
Resets all your options to the default factory settings. You can use this to remove all
changes you have made.

RELATED LINKS
Flows on page 88
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Engraving Options dialog on page 228
Layout Options dialog on page 62
Playback Options dialog on page 312

Changing options in Notation Options
You can change options in the Notation Options dialog for each flow independently.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.
The Notation Options dialog opens.

2.

In the Flows list, select the flows in which you want to make changes in one of the
following ways:
●

Ctrl/Cmd-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Select a category from the Category menu.

4.

Make the changes you want to make in the area on the right.

5.

Click Apply, then Close.

Note input
There are several different ways to input notes.
You can input notes using any of the following devices, and switch between them at any time:
●

MIDI keyboard

●

Computer keyboard

●

Mouse or touchpad

TIP
A MIDI keyboard is the fastest way to input notes.

RELATED LINKS
Notes on page 571
Inputting notes on page 115

Caret
In Dorico, the caret shows the rhythmic position at which notes, chords or notation items are
input.
A caret is a mark that is commonly used in proofreading of written text to denote the position at
which something should be inserted or added, for example, a missing letter or a word. In
software, the caret shows where something is inserted. The caret can also be known as an
“insertion point” or “cursor”.
In this documentation, we use “caret” to refer to the line that appears during note input, and
“cursor” to refer to the line that appears during text input.
In Dorico, the caret is a vertical line that extends above and below the staff. If you are inputting
notes, the caret advances to the next rhythmic position automatically. If you are inputting
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chords, the caret does not move on its own, and you must move it to the next rhythmic position.
The caret has a note symbol beside it in most cases, which indicates the stem direction of the
currently selected voice. It is accompanied by a + symbol if the voice is new.

The caret

The appearance of the caret changes depending on the tool or on the number of voices that you
are using.
Insert
The caret shows V and inverted V shapes at the top and bottom. In Insert mode,
inserted notes shift all the music that follows along by the input duration instead of
replacing existing notes.

Caret in Insert mode

Chords
The caret shows a plus symbol on the left at the top. Allows you to input multiple
notes at the same rhythmic position.

Caret when inputting chords

Lock to Duration
The caret line is dashed. Allows you to repitch notes without changing their duration
or rhythm.

Caret when Lock to Duration is activated

Grace Notes
The caret is smaller than the default caret. Allows you to input grace notes at the
caret position.
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Caret when inputting grace notes

Voices
If you input multiple voices, the caret shows the following:
●

A plus symbol on the left at the bottom

●

The number of the voice into which you are about to input notes

●

An up-stem note or a down-stem note symbol to indicate the stem direction of
the voice

Caret when inputting notes into a new downstem voice

Caret when inputting notes into a new,
second up-stem voice

Percussion kits
The caret appears significantly smaller than usual when inputting notes into
percussion kits. The name of the kit instrument into which you are currently
inputting notes is shown above the rhythmic grid.

Caret when inputting notes into percussion kits

RELATED LINKS
Inputting notes in Insert mode on page 120
Inputting chords on page 129
Repitching notes without changing their rhythm on page 138
Inputting grace notes on page 128
Inputting notes into multiple voices on page 118
Inputting notes in percussion kits on page 121

Caret activation/deactivation
If you activate the caret, you can write music. If you deactivate the caret, you can edit your music.
You can activate the caret in any of the following ways:
●

Select an item and press Shift-N or Return.

●

Double-click the rhythmic position on the staff where you want to begin inputting notes.

You can deactivate the caret in any of the following ways:
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●

Press Esc.

TIP
Switching to another mode also deactivates the caret, as the caret can only be activate in Write
mode.

Moving the caret manually
The caret automatically moves as you input notes normally, but you can also move it manually.
For example, the caret does not move automatically when inputting chords.
PROCEDURE
●

Move the caret in any of the following ways:
●

Press Right Arrow/Left Arrow to move the caret according to the current rhythmic
grid value.

●

Press Space to advance the caret according to the note value currently selected.

●

Press Ctrl/Cmd-Right Arrow/Ctrl/Cmd-Left Arrow to move the caret to the next/
previous bar.

●

Press Up Arrow/Down Arrow to move the caret to the staff above/below.

●

Press Ctrl/Cmd-Up Arrow/Ctrl/Cmd-Down Arrow to move the caret to the top/
bottom staff in the system.

RELATED LINKS
Inputting chords on page 129

Inputting notes
You can input notes into your project during step input, when note input is activated. You can
input notes with a computer keyboard, by clicking with a mouse pointer, or by playing notes with
a MIDI keyboard.
NOTE
●

If you want to input notes into multiple instruments held by a single player, we
recommend that you do so in galley view, where you can see all staves at once.

●

During step input, you must specify the duration, accidentals, and articulations before
specifying the pitch. This applies to all input methods.
You can later add notations to notes after they have been input when note input is
deactivated.

PROCEDURE
1.

Optional: In the status bar, select Galley View from the view selector.

2.

Start note input in any of the following ways:

3.

●

Select the staff where you want to input notes and press Shift-N or Return.

●

Select the staff where you want to input notes and choose Write > Note Input.

●

Double-click the staff where you want to input notes.

Select a note value in any of the following ways:
●

Press the number on your computer keyboard that corresponds to the rhythmic
value you want. For example, press 6 for quarter notes (crotchets), 5 for eighth
notes (quavers), 7 for half notes (minims), and so on.
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●

Click the rhythmic value you want in the Notes panel on the left of the window.

4.

Optional: Activate a rhythm dot.

5.

Optional: Add an accidental.

6.

Optional: Add an articulation.

7.

Input the pitches you want in any of the following ways:
●

Press the letters on your keyboard that correspond to the notes you want:
A, B, C, D E, F, and G.
NOTE
Dorico automatically selects the note whose register is the smallest interval away
from the previously input note. However, you can force a different register.
●

To input a note above the previously input note, press Shift-Alt as well as the
letter for the note.

●

To input a note below the previously input note, press Ctrl (macOS) or Ctrl-Alt
(Windows) as well as the letter for the note.

You must press Ctrl on Mac, not Cmd.
●

Click the staff at the rhythmic positions where you want to input notes.
TIP
A shadow notehead appears when inputting with a mouse pointer to indicate where
the note will be input.

●
8.

Play the notes you want on a MIDI keyboard.

Press Esc or Return to stop note input.

RESULT
Notes are input with the selected duration. Notes continue to be input with a rhythm dot and any
articulations until you deactivate them. However, accidentals are only added to the first note you
input after selecting them.
Beams are automatically formed between adjacent notes that are an eighth note or shorter, as
appropriate for the time signature and their position in the bar.
TIP
●

You can change the default beam grouping in your project on the Beam Grouping page in
Notation Options.

●

You can also move the caret to other rhythmic positions without having to input notes.

RELATED LINKS
Register selection during step input on page 117
Caret on page 112
Moving the caret manually on page 115
Key commands in Dorico on page 10
Inputting notes with rhythm dots on page 117
Forcing the duration of notes/rests on page 125
Adding notes above/below existing notes on page 133
Changing the pitch of individual notes on page 138
Moving notes rhythmically on page 578
Per-flow changes to beam grouping defaults on page 403
View types on page 47
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Register selection during step input
Dorico automatically selects the register of pitches during step input, but you can override this
and select the register manually.

Register selection during step input
During step input, Dorico automatically selects the note whose register is the smallest interval
away from the previously input note. For example, if you input an F and then press A, an A is
input a third above the F, rather than a sixth below.
You can override this automatic register selection in the following ways:
●

To input a note above the previously input note, press Shift-Alt as well as the letter for the
note.

●

To input a note below the previously input note, press Ctrl (macOS) or Ctrl-Alt (Windows)
as well as the letter for the note.

NOTE
You must press Ctrl on macOS, not Cmd.

Register selection when inputting chords
When Chords is activated, Dorico automatically inputs notes above the highest note at the caret
position. For example, if you press A then E then A, a chord of A-E-A is input at the caret position.
You can input notes below the lowest note at the caret position instead by pressing Ctrl (macOS)
or Ctrl-Alt (Windows) as well as the letter for the note name.
For example, press Ctrl-F (macOS) or Ctrl-Alt-F (Windows) to input an F below the lowest note in
the chord at the caret position.
NOTE
You must press Ctrl on macOS, not Cmd.

RELATED LINKS
Inputting notes on page 115
Inputting chords on page 129
Changing the pitch of individual notes on page 138

Inputting notes with rhythm dots
The Dotted Notes tool allows you to input notes with rhythm dots and add rhythm dots to
existing notes. You can input notes with up to four rhythm dots.
PROCEDURE
1.

2.

3.

In Write mode, do one of the following:
●

Start note input.

●

Select existing notes to which you want to add rhythm dots.

Select a note value in any of the following ways:
●

Press the number on your computer keyboard that corresponds to the rhythmic
value you want. For example, press 6 for quarter notes (crotchets), 5 for eighth
notes (quavers), 7 for half notes (minims), and so on.

●

Click the rhythmic value you want in the Notes panel on the left of the window.

Add a rhythm dot in any of the following ways:
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●

Press . (period).

●

In the Notes toolbox, activate Dotted Notes.

NOTE
The tool remains activate until you either select a different note duration or deactivate it.
4.

Optional: Press Alt-. (dot) to change the number of rhythm dots.
Dotted Notes in the Notes toolbox updates to indicate the current number of rhythm
dots. You can input notes with up to four rhythm dots.

5.

Press Esc or Return to stop note input.

RESULT
During step input, notes are input as dotted notes until you deactivate Dotted Notes or change
the note duration.
If you add rhythm dots to multiple existing notes that would then overlap, Dorico adjusts the
duration of notes in the selection to avoid deleting notes at the end of the selection.
EXAMPLE

A phrase containing eighth notes

After adding rhythm dots to the whole selection

Inputting notes into multiple voices
By default, notes are input into the first up-stem voice, as indicated by the symbol of an up-stem
quarter note beside the caret. You can input notes directly into other voices during step input,
and switch between voices as often as you want.
You can also input notes into a new voice on a staff with existing notes. Once you have created a
voice somewhere on a staff, you can input notes into that voice anywhere else on the same staff.
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret on the staff on which you want to input multiple voices, at the rhythmic
position where you want the multiple voices to start.

3.

Create a new voice in any of the following ways:
●

Press Shift-V.

●

Choose Write > Create Voice.

When a new voice is added, a + sign appears beside the symbol of a quarter note beside
the caret. The quarter note symbol indicates the stem direction, and the number beside
the quarter note indicates the voice number if applicable.
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Caret when adding the first down-stem voice

4.

Caret when adding the second up-stem voice

Optional: Repeat step 3 as many times as you require.
For example, on a staff containing no notes, creating one new voice allows you to input
notes into the first down-stem voice, but you can also create another new voice
immediately if you want to input notes into the second up-stem voice on the staff.

5.

Input the notes you want.

6.

Optional: Switch between voices in any of the following ways:

7.

●

Press V.

●

Choose Write > Next Voice.

Press Esc or Return to stop note input.

RESULT
Notes are input into new voices, as indicated by the caret symbol.
NOTE
If you are inputting notes into a new voice on a staff that already contains notes in another voice,
the stem directions of existing notes at the same rhythmic position change automatically as
necessary.
The quarter note symbol beside the caret changes to indicate which voice is currently selected.
Any notes input are input into the voice indicated by this symbol.
You can switch between voices as often as you like.
NOTE
If you have three or more voices on a single staff, you must cycle through all the voices in a set
order. For example, if you have two up-stem voices and two down-stem voices, the order is: first
up-stem voice, first down-stem voice, second down-stem voice, second up-stem voice.
EXAMPLE

Caret when inputting notes into
the first up-stem voice

Caret when inputting notes into
the first down-stem voice

RELATED LINKS
Caret on page 112
Inputting notes on page 115
Adding notes above/below existing notes on page 133
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Voices on page 801

Inputting notes in Insert mode
When Insert mode is activated, you can input notes before existing notes without overriding
them. This allows you to push existing notes forwards at the same time as inputting new notes at
the previous positions of the existing notes.
PROCEDURE
1.

In Write mode, start note input.

2.

Select a note value in any of the following ways:

3.

●

Press the number on your computer keyboard that corresponds to the rhythmic
value you want. For example, press 6 for quarter notes (crotchets), 5 for eighth
notes (quavers), 7 for half notes (minims), and so on.

●

Click the rhythmic value you want in the Notes panel on the left of the window.

Activate Insert mode in any of the following ways:
●

Press I.

●

Click Insert in the Notes toolbox on the left of the window.

When Insert mode is activated, the caret shows V and inverted V shapes at the top and
bottom.

4.

Input the pitches you want in any of the following ways:
●

Press the letters on your keyboard that correspond to the notes you want.

●

Click the staff at the rhythmic positions where you want to input notes.
TIP
A gray notehead appears when inputting with a mouse pointer to indicate where
the note will be input.

●
5.

6.

Play the notes you want on a MIDI keyboard.

Deactivate Insert mode in any of the following ways:
●

Press I.

●

Click Insert in the Notes toolbox on the left of the window.

Press Esc or Return to stop note input.

RESULT
Notes are inserted before existing notes, without overriding any existing notes at rhythmic
positions after the caret. Any existing notes after the caret are pushed ahead to subsequent
rhythmic positions.
NOTE
You can deactivate Insert mode and immediately continue inputting notes as before.
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Chords cannot be activated at the same time as Insert mode.

RELATED LINKS
Caret on page 112
Inputting notes on page 115

Inputting notes in percussion kits
You can input notes on percussion instruments within kits using any presentation type in the
same ways as inputting notes on pitched instruments. However, the caret is smaller when
inputting notes in percussion kits than when inputting music on the staves of pitched
instruments.
Instead of occupying the whole height of the staff, the caret in percussion kits is positioned at a
particular staff position.
The name of the percussion instrument currently selected by the caret, and playing technique if
applicable, is shown above the staff, directly above the rhythmic grid display.

Inputting notes on instruments with five-line staff kit presentation

PROCEDURE
1.

In Write mode, select an item in the percussion kit into which you want to input notes, at
the rhythmic position from which you want to input notes.

2.

Start note input in any of the following ways:

3.

4.

●

Press Shift-N or Return.

●

Choose Write > Note Input.

●

Double-click the staff.

Move the caret up/down to input notes on different instruments in any of the the following
ways:
●

Press Up Arrow to move it up.

●

Press Down Arrow to move it down.

Select an appropriate playing technique for the instrument currently selected by the caret
before inputting notes.
●

Press Shift-Alt-Up Arrow to cycle upwards through playing techniques.

●

Press Shift-Alt-Down Arrow to cycle downwards through playing techniques.

●

Play the pitch for the playing technique you want on a MIDI keyboard.
NOTE
You can define MIDI pitches for playing techniques on the General page in
Preferences.

5.

Input notes in one of the following ways:
●

Five-line staff presentation type: Press letters on a computer keyboard or play notes
on a MIDI keyboard, corresponding to staff positions for the clef set in Preferences.
For example, press B to input notes for the instrument assigned to the middle line
of a five-line staff when Treble G clef is set.
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●

Grid and single-line instruments presentation types: Press the letter of any note
name A to G on a computer keyboard or play any note on a MIDI keyboard to input
notes for the instrument on whose line the caret is currently positioned.
NOTE
Notes played on MIDI keyboards are interpreted differently, depending on whether
Use percussion map or Use staff position is set for the different kit presentation
types on the General page in Preferences.

6.

●

Any kit presentation type: Click the staff on the lines or in the spaces where you
want to input notes, and at the rhythmic positions where you want them.

●

Any kit presentation type: Press Y to input notes for the instrument and playing
technique shown above the rhythmic grid.

Press Esc or Return to stop note input.

RELATED LINKS
Caret on page 112
Percussion kits on page 783
Note input setup for percussion kits on page 122
Changing the playing techniques of notes on percussion kit staves on page 785
Preferences on page 53

Note input setup for percussion kits
Inputting music for unpitched percussion instruments works differently than for pitched
instruments. You can use any of the usual methods for unpitched percussion input, but using a
MIDI keyboard or a computer keyboard is most efficient.
In the Note Input section of the General page in Preferences you can find options relating to
note input for percussion.
There is one set of options for input onto five-line staves, and another set of options for input
onto grids and individual instruments.
The main choice affects input via MIDI keyboards and computer keyboards.
Use percussion map
A percussion map defines which MIDI notes produce which sound for a particular
patch in a sound library. For example, in General MIDI percussion, C2 (note 36)
produces bass drum, and D2 (note 38) produces snare drum, and so on.
If you know a particular mapping well, you may find it helpful to use the mapping
directly for input.
Use staff position
This option uses the staff position defined in the Edit Percussion Kit dialog. For
example, on a drum set, the bass drum is normally positioned in the bottom space of
the staff, while the snare drum is positioned in the third space from the bottom.
You can think of staff positions relative to what they would be when using a treble G
clef (F4 and C5 respectively) or using a bass F clef (A2 and E3 respectively).
You can choose which clef is used to interpret staff positions for five-line staves:
●

Treble G clef

●

Bass F clef

When you select Use staff position, you can designate one octave of your MIDI keyboard to
input playing techniques.
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By default, the Input techniques from MIDI key option is set to MIDI note 48, which is C3, the C
one octave below middle C (C4 = MIDI note 60). You can click the MIDI learn button and then play
a note on your MIDI keyboard to change the starting pitch. Assuming a starting pitch of C3,
ascending notes operate as follows:
●

C3 (48): Previous playing technique

●

C♯3 (49): Next playing technique

●

D3 (50): First mapped playing technique

●

E♭3 (51): Second mapped playing technique

●

E3 (52): Third mapped playing technique

And so on, up to:
●

B3 (59): Tenth mapped playing technique

In general, it is recommended that you set Use staff position for percussion input.
Use percussion map is only normally useful when you are inputting notes onto a drum set and
you have already memorized the General MIDI percussion map.
RELATED LINKS
Preferences on page 53
Edit Percussion Kit dialog on page 77
Inputting notes in percussion kits on page 121
Changing the playing techniques of notes on percussion kit staves on page 785

Default note selection during step input for percussion kits
During step input in percussion kits, you can press the letters on a computer keyboard that
correspond to staff positions for kits using the five-line staff presentation type. For example, you
can press F to input a note on the F space or line.
In Preferences, you can set options for inputting notes into percussion kits in the Note Input
section of General page. For example, if you want to use staff positions to determine notes,
choose Use staff position for Input notes onto kit or grid.
If you have the staff positions set relative to Treble G clef, then F could mean either the bottom
space on the staff or the top line on the staff. In a standard drum set, this would mean either the
kick drum in the bottom space, or the ride cymbal on the top line.
When inputting notes in pitched instruments, Dorico chooses the lower or upper possible staff
position based on which is closer to the current position of the caret.
However, when inputting notes in percussion kits, Dorico chooses the staff position of the note
with the same stem direction as the last input note, rather than the staff position that is closest
to the current position of the caret. This makes it easier to input common note patterns used in
percussion kits.
For example, inputting kick drum and snare drum notes on a standard drum set is a common
pattern. The kick drum is in the bottom space, and the snare drum is two spaces above: five staff
positions away from the bottom space, and four staff positions away from the top line.
You can press F for the kick drum and C for the snare drum.
The default stem direction behavior for inputting notes in kits in Dorico means that you can
alternate pressing F and C, and the notes are input at the positions of the kick drum and snare
drum, even though the top line is the closer position after inputting a snare drum note.
This is because the kick drum uses the same stem direction, and therefore voice, as the snare
drum.
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NOTE
Dorico automatically changes the directions of stems according to the positions of notes on the
staff when only one voice on the staff contains notes, regardless of their voice.

RELATED LINKS
Preferences on page 53
Stem direction on page 711

Inputting rests
Dorico automatically shows rests as appropriate in the gaps between the notes you input.
However, you can also input rests manually.
PROCEDURE
1.

In the Notes toolbox, select Rests in any of the following ways:
●

Press , (comma).

●

Click Rests in the Notes toolbox.

2.

Optional: Click a duration in the Notes panel.

3.

Input a rest in any of the following ways:
●

Play a note on the MIDI keyboard.

●

Press Y, or any of the letters from A to G.

RESULT
A rest of the selected duration is input. If you input more than one rest, Dorico automatically
combines the rests into a rest of a different duration that makes sense in combination with the
input notes. However, you can force the duration of rests if you want rests of a specific duration.
RELATED LINKS
Rests on page 656
Implicit vs. explicit rests on page 657
Forcing the duration of notes/rests on page 125

Selecting note/rest durations
You can select durations for notes/rests either from the Notes panel or by using one of the
assigned key commands.
PREREQUISITE
If you want to change which durations are listed, click Show/Hide All Notes at the top or bottom
of the notes list.
/
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PROCEDURE
●

Do one of the following:
●

Press one of the respective key commands. For example, press 6 for quarter notes
(crotchets), 5 for eighth notes (quavers), 7 for half notes (minims), and so on.

●

Click a duration in the Notes panel.

RELATED LINKS
Notes panel on page 100
Key commands in Dorico on page 10
Inputting notes on page 115

Changing the duration of notes
You can lengthen/shorten the duration of notes after they have been input.
PROCEDURE
1.

Select the notes whose duration you want to change.

2.

Change the duration in any of the following ways:
●

Press the key command of the duration you want. For example, press 4 for a 16th
note (semiquaver).

●

Click the duration you want in the Notes panel.

●

Press Shift-Alt-Right Arrow to lengthen notes by the current rhythmic grid value.

●

Press Shift-Alt-Left Arrow to shorten notes by the current rhythmic grid value.

●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to double the length of notes.

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to halve the length of notes.

●

Choose Write > Edit Duration > Lengthen Duration by Grid Value.

●

Choose Write > Edit Duration > Shorten Duration by Grid Value.

●

Choose Write > Edit Duration > Lengthen Duration.

●

Choose Write > Edit Duration > Shorten Duration.

RESULT
The duration of the selected notes is changed.

Forcing the duration of notes/rests
Dorico automatically notates and beams notes/rests appropriately, according to the current time
signature and their position in the bar. If you want to specify how the durations of notes/rests
are notated, you can force their duration.
For example, if you input a half note at the start of a 6/8 bar, it is notated as a dotted quarter
note (crotchet) tied to an eighth note (quaver). This is because, according to convention, 6/8 bars
are subdivided into two groups of three eighth notes. To reflect this for a half note (four eighth
notes), Dorico automatically divides the note to show the correct grouping.
PROCEDURE
1.

In Write mode, start note input.

2.

Optional: If you want to force the duration of rests, select Rests in any of the following
ways:
●

Press , (comma).
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●

3.

Click Rests in the Notes toolbox.

Activate Force Duration in any of the following ways:
●

Press O.

●

Click Force Duration in the Notes toolbox.

4.

Select the duration you want.

5.

Input the notes or rests you want.

6.

Optional: Deactivate Force Duration.

RESULT
Any notes you input are notated with their whole rhythmic value, whatever their position in the
bar. If you move them later, they keep the same notation. Rests are input as explicit rests.
NOTE
Notes that cross barlines are notated as tied notes.
You can change how notes are grouped in different contexts project-wide on the Note Grouping
page in Write > Notation Options.
TIP
Force position and duration in the Notes and Rests group of the Properties panel is activated
automatically for rests input with forced durations.
You can also use this property to force the duration and positions of rests.
EXAMPLE

Default notation of notes in 6/8

Notes in the down-stem voice input with forced
durations

RELATED LINKS
Implicit vs. explicit rests on page 657
Inputting notes on page 115
Inputting rests on page 124
Selecting note/rest durations on page 124
Beams according to time signatures on page 404
Creating custom beat groupings for meters on page 421
Turning explicit rests into implicit rests on page 658
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Inputting ties
You can input ties manually to join two notes of the same pitch, both during step input and by
joining two existing notes with a tie.
In general, Dorico creates ties automatically as required. If you specify a rhythmic duration that
cannot be notated with a single note value, Dorico automatically creates chains of tied notes as
necessary for the meter.
For example, if you want to input a tie between two quarter notes across a barline, you can
simply input a half note at the rhythmic position where you want to input the first quarter note.
Dorico automatically splits the half note into two quarter notes, one on each side of the barline,
and joins them with a tie.
In the following cases, you must input ties manually:
●

If you later want to change the duration, and want to join it with a tie to the following note
to make it longer.

●

If the notes that you want to tie together are not rhythmically adjacent, for example, if the
notes are separated by intervening notes of a different pitch.

●

If the notes that you want to tie together are in different voices.

●

If you want a grace note to be tied to a note that is not a grace note.

PROCEDURE
1.

2.

3.

In Write mode, do one of the following:
●

Start note input.

●

Select the note from which you want the tie to start.

Input a tie in any of the following ways:
●

Press T.

●

Click Tie in the Notes toolbox.

Optional: During step input, input the note that you want at the end of the tie.
NOTE
The second note must be the same pitch as the first note. If the second note is a different
pitch to the first note, no tie is input.

RESULT
During step input, the two notes input are joined by a tie.
When inputting ties between existing notes, the selected note is joined by a tie to the next note
of the same pitch on the same staff.
NOTE
Depending on the current time signature and your settings on the Note Grouping page in
Write > Notation Options, inputting a tie between two notes can instead create a single note of
a different duration. For example, inputting a tie between the first two quarter notes in a 4/4
time signature creates a minim.
You can override your note grouping settings and fix your notated rhythm in any of the following
ways:
●

Press O.

●

Click Force Duration in the Notes toolbox.
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Dorico now notates your input notes with the rhythmic durations specified, as long as they can fit
inside the bar.

RELATED LINKS
Moving the caret manually on page 115
Ties on page 735
Ties vs. slurs on page 737
Tie chains on page 737

Inputting grace notes
You input grace notes in the same ways as inputting normal notes, and they can have any
rhythmic note value. You can only input grace notes during note input.
TIP
You can also add accidentals and articulations to grace notes in the same ways as for normal
notes.

PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where you want to input grace notes.

3.

Start inputting grace notes in any of the following ways:
●

Press /, and the number for the rhythmic duration you want. For example, press /
then 5 to input eighth grace notes (quaver grace notes).
TIP
You can select these in any order.

●

4.

Click the rhythmic duration you want in the Notes panel, and click Grace Notes in
the Notes toolbox, in any order.

Optional: Press Alt-/ to switch between inputting slashed/unslashed grace notes.

The Grace Notes toolbox button when inputting unslashed grace notes.

TIP
You can also change the grace note type after you have input grace notes.
5.

Enter, click, or play in the pitches you want.

6.

Stop inputting grace notes and return to inputting normal notes in any of the following
ways:
●

Press / again.

●

Click Grace Notes in the Notes toolbox.

RESULT
The pitches you enter are input as grace notes at the caret position.
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If you are inputting grace notes after previously inputting normal notes, the rhythmic duration of
the grace notes is the same as the last input normal note. You can change the rhythmic duration
in the same way as for normal notes.
There is no limit to the number of grace notes that can exist at the same rhythmic position.
TIP
You can also change the type of grace notes after they have been input.

RELATED LINKS
Grace notes on page 517
Inputting notes on page 115
Inputting accidentals on page 135
Inputting articulations on page 141
Changing the type of grace notes on page 521

Inputting chords
You can input chords during step input, when both note input and Chords are activated. You can
input notes with a computer keyboard, by clicking with a mouse pointer, or by playing notes with
a MIDI keyboard.
PROCEDURE
1.

Start note input in any of the following ways:
●

2.

3.

Select the staff where you want to input notes and press Shift-N or Return.

●

Select the staff where you want to input notes and choose Write > Note Input.

●

Double-click the staff where you want to input notes.

Select a note value in any of the following ways:
●

Press the number on your computer keyboard that corresponds to the rhythmic
value you want. For example, press 6 for quarter notes (crotchets), 5 for eighth
notes (quavers), 7 for half notes (minims), and so on.

●

Click the rhythmic value you want in the Notes panel on the left of the window.

Activate the Chords input tool in any of the following ways:
●

Press Q.

●

Click Chords in the Notes toolbox on the left of the window.

When Chords is activated, a + sign appears at the top of the caret. This allows you to input
multiple notes at the same rhythmic position, according to the current position of the
caret.

4.

Input the pitches you want in any of the following ways:
●

Press the letters on your keyboard that correspond to the notes you want to input at
the caret position.
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NOTE
Dorico automatically inputs notes above the highest note at the caret position when
Chords is activated.
You can input notes below the lowest note at the caret position instead by pressing
Ctrl (macOS) or Ctrl-Alt (Windows) as well as the letter for the note name.
●

Click the staff at the rhythmic positions where you want to input notes.
TIP
A gray notehead appears when inputting with a mouse pointer to indicate where
the note will be input.

●

Play the notes you want on a MIDI keyboard.

NOTE
When Chords is activated, notes are input at the same rhythmic position and above the
previous note until you advance the caret manually.
5.

Optional: Advance the caret to input chords at other rhythmic positions.

6.

Deactivate Chords in any of the following ways:
●

Press Q again.

●

Click Chords again in the Notes toolbox on the left of the window.

RESULT
Multiple notes are input at the caret position.
If entering pitches by clicking with the mouse, you can put the same pitch into the chord twice by
clicking again on the same line.
If entering pitches with the keyboard, repeated notes are automatically input an octave above.
You can change the register of notes by forcing the register selection during note input, or by
transposing them after they have been input.
TIP
You can deactivate Chords and immediately continue inputting notes as before, with a single
note at each rhythmic position and the caret advancing automatically to the next rhythmic
position.
NOTE
●

Chords cannot be activated at the same time as Insert mode.

●

When chords contain two pitches in the same register but with different accidentals, that is
known as an altered unison. Altered unisons are shown with either single stems or with
split stems, depending on your settings on the Accidentals page in Write > Notation
Options.

RELATED LINKS
Register selection during step input on page 117
Moving the caret manually on page 115
Inputting notes on page 115
Changing the pitch of individual notes on page 138
Adding notes above/below existing notes on page 133
Altered unisons on page 357
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Inputting tuplets
You can input all types of tuplets using the tuplets popover. Tuplets are input like normal notes,
and so can only be input during note input.
NOTE
You can also input triplets by clicking Tuplets in the Notes toolbox. However, you can only input
one triplet at a time this way.

PROCEDURE
1.

In Write mode, start note input.

2.

Select a note value in any of the following ways:

3.

●

Press the number on your computer keyboard that corresponds to the rhythmic
value you want. For example, press 6 for quarter notes (crotchets), 5 for eighth
notes (quavers), 7 for half notes (minims), and so on.

●

Click the rhythmic value you want in the Notes panel on the left of the window.

Open the tuplets popover in any of the following ways:
●

Press ;.

●

Choose Write > Create Tuplet.

●

Click Tuplets in the Notes toolbox.

4.

Enter the tuplet you want into the popover as a ratio. For example, enter 3:2 to input
triplets.

5.

Press Return to close the popover.
The tuplet is entered.

6.

Enter or play in the pitches you want.
Dorico continues inputting tuplets of the same ratio until told to stop.
TIP
You can advance the caret using Space to continue inputting tuplets of the same ratio at
later rhythmic positions.

7.

Stop inputting tuplets in any of the following ways:
●

Press Shift-; to return to inputting normal notes.

●

Press Esc to stop note input completely.

●

Move the caret with the arrow keys to return to inputting normal notes.

NOTE
If you want to input a different type of tuplet immediately after inputting tuplets, you must
stop the first type of tuplet before inputting the second type. If you do not stop the first
type, the second type is input as a nested tuplet.

RESULT
The pitches you enter or play in are input as tuplets, starting from the caret position.
RELATED LINKS
Tuplets popover on page 132
Tuplets on page 771

131

Write mode
Note input
Inputting notes on page 115

Tuplets popover
You can input tuplets with the keyboard by using the tuplets popover in Write mode. It can only
be opened during step input.
You can open the tuplets popover when note input is activate in Write mode in any of the
following ways:
●

Press ;.
Tuplets are often described in ratios, such as 3:2, so the tuplets popover uses the
semicolon key to be memorable.

●

Choose Write > Create Tuplet.

●

Click Tuplets in the Notes toolbox.

The icon on the left-hand side of the popover matches the corresponding button in the Notes
toolbox on the right of the window.

Tuplets button in the Notes toolbox

Tuplets popover with an example entry

When inputting tuplets with the keyboard, Dorico continues inputting notes as the specified
tuplet until any of the following happens:
●

You press Shift-; to return to inputting normal notes.

●

You move the caret with the arrow keys.

●

You stop note input.

The table shows some examples of what to enter into the tuplets popover, and the tuplets that
are input into the music as a result.
Type of tuplet

Popover entry

Triplet, three notes in the space of two.

3 or 3:2

Triplet, three notes in the space of four.

3:4

Quintuplet, five notes in the space of four.

5:4

Quintuplet, five notes in the space of two.

5:2

Septuplet, seven notes in the space of four.

7:4

Septuplet, seven notes in the space of two.

7:2

Duplet, two notes in the space of three. Often
used in compound meters.

2:3

Quintuplet, five notes in the space of six. Often 5:6
used in compound meters.
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NOTE
The duration of each note in the tuplet, and the total duration of the tuplet, depends on the note
value selected when you open the popover. The ratio specified relates to the selected note value.
This list is not comprehensive. It is intended to illustrate how you can structure your entry to
input different tuplets.
RELATED LINKS
Inputting tuplets on page 131
Tuplets on page 771

Adding notes above/below existing notes
You can add notes above/below existing notes. You can add multiple notes at the same time,
according to their intervals relative to the existing notes.
PROCEDURE
1.

Select the notes to which you want to add notes.

2.

Open the add intervals popover in any of the following ways:
●

Press Shift-I.

●

Choose Write > Add Intervals Popover.

3.

Enter the intervals of the notes you want, relative to your selected notes. For example,
enter -m3,4 to add notes a minor third below and a fourth above the selected notes.

4.

Press Return to close the popover.

RESULT
Notes are added to the selected notes according to the intervals you entered into the add
intervals popover.
RELATED LINKS
Add intervals popover on page 133
Changing the pitch of individual notes on page 138

Add intervals popover
The add intervals popover allows you to add notes above and below existing notes, and also
transpose existing notes.
This popover makes much of the functionality provided by the Add Notes Above or Below and
Transpose dialogs accessible directly via the keyboard.
You can open the add intervals popover in Write mode in any of the following ways:
●

Press Shift-I.

●

Choose Write > Add Intervals Popover.

The table shows some examples of how to structure your entry to transpose notes or add notes
to existing notes.
Action

Popover entry

Transpose notes upwards.

t3 or t6
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Action

Popover entry

Transpose notes downwards.

t-5 or t-3

Add notes a third above.

3 or 3rd

Add notes a fourth below.

-4 or -4th

Add multiple notes

3,6 or -3,3,4

NOTE
Separate notes with commas, not with spaces.

Add notes above or below all notes in selected
chords.

3 all or -M2,m3 to all

NOTE
Separate notes with commas, not with spaces.

Add notes only to the top notes in chords.

-3 top or dim5 top

Add notes only the to bottom notes in chords.

aug4 bottom or -2 bottom

Specify perfect interval.

p, per, or perf

Specify major interval.

M, maj, or major

Specify minor interval.

m, min, or minor

Specify diminished interval.

d, dim, or diminished

Specify augmented interval.

a, aug, or augmented

Specify diatonic interval.

diat or diatonic

Transpose notes by mictrotonal intervals.

t 3 8 qt

NOTE
The first number is the interval degree.
The second number is the number of quarter
tones.

If you do not otherwise specify it, the interval is calculated by adding or transposing notes by the
number of staff positions specified. For example, in C major, if the selected note is a D♮ and you
specify 3 to add a third above, the added note is an F♮. You can specify the quality of the interval
by including it before the interval.
If the selected material already includes chords, notes are added above the top note in the chord,
and added below the bottom note in the chord. You can add notes to all notes in selected chords
by including all or to all at the end of your entry.
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For microtonal transpositions, the first number is the interval degree, and the second number is
the number of quarter tones. For example, if you have a C natural and you enter T 3 8 qt, it
changes to an E.
RELATED LINKS
Adding notes above/below existing notes on page 133
Transposing existing notes with the popover on page 135

Transposing existing notes with the popover
You can change the pitch of notes after they have been input using the add intervals popover.
PROCEDURE
1.

Select the notes you want to transpose.

2.

Open the add intervals popover in any of the following ways:
●

Press Shift-I.

●

Choose Write > Add Intervals Popover.

3.

Enter the intervals of the transposition you want. For example, enter t3 to transpose the
notes up a third, or t-min6 to transpose the notes down a minor sixth.

4.

Press Return to close the popover.

RESULT
The selected notes are transposed by the degree specified.
RELATED LINKS
Add intervals popover on page 133

Inputting accidentals
You can input notes with accidentals, both during step input and by adding them to existing
notes.
NOTE
Accidentals that are part of the key signature are input automatically. For example, if you press F
in G major, an F♯ is input automatically. You would only need to specify an accidental if you want
to input an F♮, for example.
This also applies if you are using a MIDI keyboard, though you can respell notes if the accidentals
chosen automatically are not the ones that you expected.

PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select the existing notes to which you want to add accidentals.

Select the accidental you want to input in one of the following ways:
●

Press - for flat.

●

Press = for sharp.

●

Press 0 for natural.

●

Click the accidental you want in the Notes panel.
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TIP
You can find uncommon accidentals, such as double sharps and flats, or microtonal
accidentals, in the Accidentals section of the Key Signatures, Tuning Systems, and
Accidentals panel on the right of the window.
3.

Optional: During step input, enter the note you want with your selected accidental.
NOTE
●

Depending on the accidental duration system in place, subsequent accidentals for
the same note in the same register might not appear in the same bar.

●

If you input notes using a MIDI device, Dorico automatically shows an accidental if
necessary. It selects a sharp, flat, or natural based on key signature and context. You
can later respell accidentals.

RESULT
The accidental is added to the selected existing notes.
During step input, the selected accidental is only input on the next note you input. You must
reselect the accidental if you also want to input it on subsequent notes.
RELATED LINKS
Accidentals on page 355
Inputting notes on page 115
Respelling accidentals on page 136
Accidental selection during MIDI input on page 137

Respelling accidentals
You can change the enharmonic spelling of notes, so they are shown as their enharmonic
equivalents.
Dorico uses an algorithm that automatically decides the spelling of pitches, based on key
signature and context.
However, there are occasions when you might need to change how an accidental is spelled, such
as to show clearly the stepwise movement in a phrase, or to avoid altered unisons in a chord.
In Dorico, you can switch between each available enharmonic spelling, allowing you to see at
least three options for every pitch. There are always at least three options, as Dorico allows
enharmonic spellings to show up to two accidental glyphs.
This means the same note can be spelled four ways, if the original pitch can be spelled with the
note name either two notes below or two notes above, using a maximum of two accidental
glyphs.
For example, B is a possible enharmonic spelling of G because a triple-flat uses a single
accidental glyph, whereas an F uses two accidental glyphs.
PROCEDURE
1.

In Write mode, select the notes you want to respell.

2.

Respell the selected notes upwards/downwards in any of the following ways:
●

Press Alt-= to respell upwards.

●

Press Alt-- to respell downwards.

●

Choose Write > Respell > Respell Using Note Name Above to respell upwards.

●

Choose Write > Respell > Respell Using Note Name Below to respell downwards.
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RESULT
The enharmonic spelling of the selected notes is changed.
EXAMPLE

A G sharp

When respelled
downwards, the G sharp
becomes an F triplesharp

When respelled upwards, When respelled upwards
the G sharp becomes an again, the G sharp
A flat
becomes a B triple-flat

RELATED LINKS
Accidentals on page 355

Accidental selection during MIDI input
Dorico interprets MIDI data to create accidentals, and automatically determines the spelling of
notes according to preset rules.
Dorico automatically displays an accidental if one is required. It selects a sharp or flat based on
key signature and context.
The algorithm for this takes into account the key signature and the intervals between successive
notes and chords. Therefore Dorico prefers sharp accidentals in a key with sharps, and flats in a
key with flats. If you change the spelling of an accidental, Dorico follows your spelling preference
whenever that note is used again in the score.
If you input notes with accidentals outside the key signature, Dorico uses sharps if the figure is
rising, and flats if it is falling. The spelling is also calculated vertically, meaning a simpler interval
is produced where possible, such as a major third rather than a diminished fourth.
Dorico makes retrospective changes to how it has spelled accidentals, depending on how your
input develops. For example, in C major, if you input a sequence of pitches C-E-G♯, but then input
a G♭, the G♯ is respelled as an A♭.
You can disable this setting in Write > Note Input Options.
RELATED LINKS
Respelling accidentals on page 136
Disabling automatic accidental respelling on page 137

Disabling automatic accidental respelling
You can turn off the automatic respelling of accidentals, to prevent Dorico from making
retrospective changes to accidentals.
PROCEDURE
1.

Open Note Input Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-I in any mode.

●

Choose Write > Note Input Options in Write mode.

2.

Click MIDI Input in the page list.

3.

Deactivate Allow spelling of notes to be adjusted retrospectively.

4.

Click Apply, then Close.
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RELATED LINKS
Accidental selection during MIDI input on page 137

Changing the pitch of individual notes
You can change the pitch and register of individual notes, including grace notes, after they have
been input by scale degrees, by step, and by transposing up/down octaves.
PROCEDURE
1.

In Write mode, select the notes whose pitches you want to change.

2.

Raise/Lower the pitches of the selected notes in any of the following ways:
●

Press Alt-Up Arrow to move notes up one staff position, for example, from B to C.

●

Press Alt-Down Arrow to move notes down one staff position, for example, from C
to B.

●

Press Shift-Alt-Up Arrow to transpose notes up a single octave division. For
example, a semitone in 12-EDO or a quarter tone in 24-EDO.

●

Press Shift-Alt-Down Arrow to transpose notes down a single octave division. For
example, a semitone in 12-EDO or a quarter tone in 24-EDO.

●

Press Ctrl/Cmd-Alt-Up Arrow to transpose notes up an octave.

●

Press Ctrl/Cmd-Alt-Down Arrow to transpose notes down an octave.

RESULT
The pitch or register of the selected notes is changed.
NOTE
You can press Alt-Up Arrow and Alt-Down Arrow to change the staff positions of notes in
percussion kits using grid and five-line staff presentation types. However, this also changes the
instrument playing the note.

RELATED LINKS
Equal Division of the Octave (EDO) on page 536
Adding notes above/below existing notes on page 133
Add intervals popover on page 133

Repitching notes without changing their rhythm
You can repitch notes after you have input them while keeping their durations the same, for
example, if you want to copy notes from one staff to another and keep the same rhythm but
have different pitches.
PROCEDURE
1.

Select the first note you want to repitch.

2.

Start note input in any of the following ways:

3.

●

Press Shift-N or Return.

●

Choose Write > Note Input.

●

Double-click the staff.

Activate Lock to Duration in any of the following ways:
●

Press L.

●

Click Lock to Duration in the Notes toolbox.
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4.

Enter the pitches you want.

5.

Optional: Deactivate Lock to Duration.
NOTE
Lock to Duration automatically deactivates when you reach the last existing note on the
staff. Note input continues as usual with eighth notes (quavers) as the duration by default.

RESULT
Existing notes on the selected staff are repitched without their rhythms being changed. The caret
automatically advances from note to note, even if there are large rests between notes on the
staff.
RELATED LINKS
Caret on page 112

Transpose dialog
You can transpose a selection of notes, including key signatures, using the Transpose dialog. You
can transpose according to an interval and quality or by a set number of divisions of the octave.
●

You can open the Transpose dialog in Write mode by making a selection in the music area
and choosing Write > Transpose.

Transpose dialog

The Transpose dialog contains the following sections:
1

Transposition options
Contains options that allow you to specify the transposition you want. For example, you
can choose to transpose by an interval quality, such as a major third, or by a set number of
divisions of the octave. You can choose the direction of the transposition, whether it
includes octaves, and the interval and quality or number of divisions by which you want to
transpose your selection.
According to convention, different intervals have different possible qualities. For example,
you can specify a major third but not a major octave.
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Additional options also allow you to transpose any key signatures included in your
selection and keep relative respelled notes and chord symbols where possible.
2

Calculate interval
Allows you to set transpositions options according to a starting note and the resulting note
you want. For example, if you want to transpose a selection relative to a C natural
becoming a G♯ but you are not certain of the interval and quality required, you can enter
those two notes in the Calculate interval section, click Apply, and Dorico automatically
sets the required transposition options for you.

NOTE
The Transpose dialog does not allow transpositions that would result in impossible notations,
such as sharper than a triple sharp, or that require a microtonal accidental that does not exist in
the tonality system in place at the point of your selection.

RELATED LINKS
Add intervals popover on page 133

Transposing selections
You can transpose whole selections together, including key signatures within selections, using
the Transpose dialog.
PROCEDURE
1.

In Write mode, make a selection in the music area.

2.

Choose Write > Transpose.
The Transpose dialog opens.

3.

Change the options as applicable for the transposition you want.

4.

Click OK to save your changes and close the dialog.

RESULT
All notes in your selection are transposed according to the interval or number of divisions of the
octave specified in the Transpose dialog. If your selection included key signatures and you
activated Transpose key signatures, all key signatures in the selection are also transposed.

Activating/Deactivating mouse input
You can activate/deactivate mouse input.
PROCEDURE
●

In the Notes toolbox, activate/deactivate Select.

RESULT
Mouse input is activated in the current project when Select is deactivated. Mouse input is
deactivated in the current project when Select is activated.
TIP
You can change the default setting for whether mouse input is activated/deactivated by
activating/deactivating Enable note input using the mouse on the General page in
Preferences.
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EXAMPLE

Select when deactivated

Select when activated

RELATED LINKS
Preferences on page 53

Notations input
You can input many types of notations both during step input and by adding them to existing
notes.

Inputting articulations
You can input notes with articulations during step input and you can add articulations to notes
after they have been input.
PROCEDURE
1.

2.

3.

In Write mode, do one of the following:
●

Start note input.

●

Select the existing notes to which you want to add articulations.

Select the articulations you want to input in any of the following ways:
●

Press the key commands for the articulations you want.

●

Click the articulations you want in the Notes panel.

Optional: Enter the notes or chords you want with your selected articulations.

RESULT
The selected articulations are added to the selected notes.
During step input, the selected articulations are added to all notes that are input until the
articulations are deactivated.
NOTE
You cannot add some combinations of articulations to the same notes. For example, you cannot
have both staccato and staccatissimo marks on the same notes, as both articulations indicate
that notes are played shorter.

RELATED LINKS
Articulations on page 367
Note input on page 112
Key commands for articulations on page 141

Key commands for articulations
You can input articulations by clicking the corresponding button of the articulation you want in
the Notes panel on the left of the window in Write mode, or by pressing key commands on your
computer keyboard.
You can use the following key commands to input articulations with the keyboard:

141

Write mode
Notations input

Type of articulation

Key command

Accent: 

[

Marcato: 

'

Stressed: 

{

Unstressed: 

@ (Windows)
Shift-' (macOS)

Staccato: 

]

Tenuto: 

# (Windows)
\ (macOS)

Staccatissimo: , , or 

}

Combined tenuto and staccato: 

~ (Windows)
| (macOS)

RELATED LINKS
Articulations on page 367
Inputting articulations on page 141

Inputting fingerings
You can input fingerings on existing notes using the fingerings popover.
Fingerings are associated with individual noteheads and so you can only add fingerings to
existing noteheads. Therefore, you cannot input fingerings during step input, and the popover
does not advance automatically.
NOTE
●

You can only add fingerings to notes at one rhythmic position at a time, and you can only
input the same number of fingerings as there are notes at each rhythmic position. For
example, you can input three fingerings at the rhythmic position of a chord containing
three notes, but only one fingering at the rhythmic position of a single note.

●

Although they contain two numbers, substitution fingerings are considered one fingering,
meaning you can add substitution fingerings to single notes.

PROCEDURE
1.

In Write mode, select the notes to which you want to add fingering.
If you want to add fingerings to all notes in a chord, select all the notes in the chord.

2.

Open the fingerings popover in any of the following ways:
●

Press Shift-F.

●

Click Fingering in the Notations toolbox.
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●
3.

Choose Write > Create Fingerings.

Enter the fingerings you want into the popover.
For example, enter:

4.

●

3-2 for a substitution fingering from the third finger to the second finger.

●

1,3,5 for a chord.

●

12 to show the first two valves should be depressed on a valved brass instrument.

Press Return to close the popover.

RESULT
The fingerings are input on the selected notes.
RELATED LINKS
Fingering on page 500
Fingerings popover on page 143
Changing the rhythmic position of substitution fingerings on page 501
Fingerings for valved brass instruments on page 509
Deleting fingerings on page 505

Fingerings popover
The table shows some examples of what to enter into the fingerings popover and the fingerings
that are input into the music as a result.
You can open the fingerings popover in Write mode in any of the following ways:
●

Press Shift-F.

●

Choose Write > Create Fingerings.

●

Click Fingering in the Notations toolbox.

Type of fingering

Example popover entry

Single fingerings for individual notes, including 1, 2, 3, and so on.
for brass valve numbers and trombone slide
positions.
Valved brass instruments

12

Single fingerings for each note in chords

1,3,5

NOTE
For keyboards, Dorico automatically orders
numbers appropriately according to the hand
playing the notes. The default is:
●

Right hand for the upper staff

●

Left hand for the lower staff

Left hand fingerings

L2, G2, S5, I2, or H2

Right hand fingerings

R5, D5, or M5
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Type of fingering

Example popover entry

Multiple fingerings for individual notes. For
example, for ornaments such as mordents or
turns.

2343

Single fingerings for multiple notes: enter the
same fingering number for two adjacent
notes.

1,1

For example, in keyboard music the thumb
may depress two keys simultaneously.
2(3)

Alternative fingerings
NOTE
You must use parentheses in the popover,
even if you choose to show alternative
fingerings in square brackets.

[4]

Editorial fingerings
NOTE
You must use square brackets in the popover,
even if you choose to show alternative
fingerings in parentheses.

Finger substitutions

1-3

Thumb indicator for string instruments.

T

This list is not comprehensive as there are many possible fingerings. It is intended to illustrate
how you can structure your entries to input different types of fingerings.
NOTE
Finger substitutions are shown as immediate by default, but you can change the rhythmic
position of the substitution by changing the deferral duration.
You can change the appearance and position of each type of fingering on the Fingering page in
Engrave > Engraving Options.
RELATED LINKS
Inputting fingerings on page 142
Fingering on page 500
Project-wide engraving options for fingerings on page 505
Changing the rhythmic position of substitution fingerings on page 501
Fingerings for valved brass instruments on page 509
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Input methods for key signatures
You can input key signatures with the keyboard by using the key signatures popover, and with
the mouse by using the Key Signatures, Tuning Systems, and Accidentals panel.

Inputting key signatures with the popover
You can input key signatures with the keyboard by entering the key signature you want into the
key signatures popover.
You can open the key signatures popover in Write mode in any of the following ways:
●

Press Shift-K.

●

Choose Write > Create Key Signature.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Key signatures popover with an example entry

Key Signatures, Tuning Systems, and Accidentals
button in the Notations toolbox

Inputting key signatures with the panel
You can open the Key Signatures, Tuning Systems, and Accidentals panel by clicking Key
Signatures, Tuning Systems, and Accidentals in the Notations toolbox in Write mode.

The Key Signatures, Tuning Systems, and Accidentals panel contains the following sections:
Tonality System
Select tonality systems to use and create new tonality systems.
Used in This Flow
Contains all the key signatures currently used in the flow.
Key Signatures
Create key signatures by choosing whether it is major or minor, and changing the
number of sharps or flats.
Custom Key Signatures
Contains any custom key signatures you have created for the currently selected
tonality system.
Accidentals
Contains all accidentals available in the currently selected tonality system.
NOTE
The order in which you should follow steps for inputting key signatures with the mouse depends
on your preferences for Creating items with the mouse in the Editing section of the General
page in Preferences.
You can open Preferences in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Dorico > Preferences (macOS).

●

Choose Edit > Preferences (Windows).
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You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

RELATED LINKS
Key signatures on page 533
Key signatures popover on page 146
Key Signatures section of the Key Signatures, Tuning Systems, and Accidentals panel on page 147
Inputting key signatures with the popover on page 147
Inputting key signatures with the panel on page 148

Key signatures popover
The table shows some examples of what to enter into the key signatures popover and the key
signatures that are input into the music as a result.
You can open the key signatures popover in Write mode in any of the following ways:
●

Press Shift-K.

●

Choose Write > Create Key Signature.

Type of key signature

Popover entry

Open or atonal key signature

open or atonal

Major keys (capital letters)

C, D or Eb, Ab, and so on.

Minor keys (lowercase letters)

g, d, f#, bb, and so on.

Number of sharps

3s, 2#, and so on.

NOTE
Assumes the major key for that many sharps.

4f, 5b, and so on.

Number of flats
NOTE
Assumes the major key for that many sharps.

This list is not comprehensive as you can input every possible key signature. It is intended to
illustrate how you can structure your entry to input different types of key signatures.
RELATED LINKS
Inputting key signatures with the popover on page 147
Key signatures on page 533
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Key Signatures section of the Key Signatures, Tuning Systems, and Accidentals
panel
You can use the Key Signatures section in the Key Signatures, Tuning Systems, and Accidentals
panel to create and input custom key signatures.
You can show/hide the Key Signatures section by clicking the section title, which has a disclosure
arrow beside it.
The Key Signatures section contains the following parts:
1

Two buttons at the top, which allow you to select either Major or Minor for your key
signature.

2

Two buttons on the right.

3

●

The down button is the More Sharps/Fewer Flats button. Each time you click on
this button, one sharp accidental is added to the key signature, or one flat accidental
is removed from the key signature.

●

The up button is the Fewer Sharps/More Flats button. Each time you click on this
button, one sharp accidental is removed from the key signature, or one flat
accidental is added to the key signature.

The button showing how the key signature looks on a staff. Clicking this button inputs the
key signature it displays. If nothing in the project is selected, the key signature is loaded
onto the cursor.

The Key Signatures section of the Key Signatures, Tuning Systems, and Accidentals panel.

RELATED LINKS
Key signatures on page 533

Inputting key signatures with the popover
You can input key signatures using the key signatures popover, both during step input and by
adding them to existing music. You can also input key signatures only on single staves.
PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing barline immediately to the left of where you want to input a key
signature.

●

Select an existing notehead or rest immediately to the right of where you want to
input a key signature.

●

Select an existing key signature that you want to change.

Open the key signatures popover in any of the following ways:
●

Press Shift-K.

●

Choose Write > Create Key Signature.
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3.

Enter the key signature you want into the popover.
For example, enter g for G minor or 3s for 3 sharps.
NOTE
Entering 3s creates a key signature of A major, rather than F♯ minor.

4.

Input the key signature and close the popover in one of the following ways:
●

Press Return to input a key signature on all staves.

●

Press Alt-Return to input a key signature on a single staff.

RESULT
During step input, key signatures are input at the caret position, even if this is in the middle of a
bar.
NOTE
It is preferable to input a change of key signature at a barline. You can move it to different
rhythmic positions later.
All subsequently input notes follow the input key signature, until the next existing key signature
or the end of the flow, whichever comes first. If playing in notes using a MIDI keyboard,
accidentals are spelled according to the key signature.
When inputting key signatures to existing music, they are input immediately to the right of a
barline, or immediately to the left of a selected note, even if this is in the middle of an existing
bar. If you selected an existing key signature, the new key signature directly replaces the existing
one.
Pressing Alt when closing the popover inputs the key signature only on the selected staff.
NOTE
An individual key signature on a single staff is not intended for transposing instruments.
Transpositions of notes and key signatures are done automatically for transposing instruments,
but you can check the transpositions by choosing Edit > Transposed Pitch to see your current
layout with transposed pitches, rather than concert pitches.
You can also open the part of a transposing instrument and compare it to the concert pitch
score.

RELATED LINKS
Key signatures popover on page 146
Accidental selection during MIDI input on page 137
Key signatures on page 533
Project-wide spacing gaps for key signatures on page 546
Moving key signatures rhythmically on page 547

Inputting key signatures with the panel
You can input key signatures using the Key Signatures, Tuning Systems, and Accidentals panel,
both during step input and by adding them to existing music. You can also input key signatures
only on single staves.
NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.
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PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing barline immediately to the left of where you want to input a key
signature.

●

Select an existing notehead or rest immediately to the right of where you want to
input a key signature.

●

Select an existing key signature that you want to change.

In the Notations toolbox, click Key Signatures, Tuning Systems, and Accidentals.

The Key Signatures, Tuning Systems, and Accidentals panel opens on the right of the
window.
3.

Optional: If you have not already used the key signature you want in the current flow,
create the key signature you want using the Key Signatures design editor in the Key
Signatures, Tuning Systems, and Accidentals panel.

4.

Input the key signature you want in one of the following ways:
●

Click a key signature to input it on all staves.

●

Alt-click a key signature to input it on a single staff only.

RESULT
During step input, key signatures are input at the caret position, even if this is in the middle of a
bar.
NOTE
It is preferable to input a change of key signature at a barline. You can move it to different
rhythmic positions later.
All subsequently input notes follow the input key signature, until the next existing key signature
or the end of the flow, whichever comes first. If playing in notes using a MIDI keyboard,
accidentals are spelled according to the key signature.
When adding key signatures to existing music, they are added immediately to the right of a
barline, or immediately to the left of a selected note, even if this is in the middle of an existing
bar. If you selected an existing key signature, the new key signature directly replaces the existing
one.
Pressing Alt when clicking a key signature inputs the key signature only on the selected staff.
NOTE
An individual key signature on a single staff is not intended for transposing instruments.
Transpositions of notes and key signatures are done automatically for transposing instruments,
but you can check the transpositions by choosing Edit > Transposed Pitch to see your current
layout with transposed pitches, rather than concert pitches.
You can also open the part of a transposing instrument and compare it to the concert pitch
score.

RELATED LINKS
Key signatures on page 533
Key Signatures section of the Key Signatures, Tuning Systems, and Accidentals panel on page 147
Project-wide spacing gaps for key signatures on page 546
Accidental selection during MIDI input on page 137
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Moving key signatures rhythmically on page 547
Mouse input settings on page 108

Input methods for time signatures
You can input time signatures with the keyboard by using the time signatures popover, and with
the mouse by using the Time Signatures (Meter) panel where there are common time signatures
ready to use. There is also a Create Time Signature section to create uncommon time
signatures.
NOTE
You can create most types of custom time signatures using the Create Time Signature section
of the Time Signatures (Meter) panel, but certain time signatures are only possible using the time
signatures popover. For example, you can only specify beat subdivisions when using the time
signatures popover.

Inputting time signatures with the popover
You can input time signatures with the keyboard by entering the time signature you want into
the time signatures popover.
You can open the time signatures popover in Write mode in any of the following ways:
●

Press Shift-M.

●

Choose Write > Create Time Signature.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Time signatures popover with an example entry

Time Signatures (Meter) button in the Notations
toolbox

Inputting time signatures with the panel
You can input time signatures with the mouse by clicking the time signatures you want in the
Time Signatures (Meter) panel on the right of the window in Write mode.
You can open the Time Signatures (Meter) panel by clicking Time Signatures (Meter) in the
Notations toolbox.

The Time Signatures (Meter) panel contains the following sections:
Used In This Flow
Any time signatures already used in the current flow are shown in this section.
Common
Common time signatures, such as 4/4, 3/4, 6/8, and 7/8, are shown in this section.
Create Time Signature
Design your own time signatures in this section, including alternating time
signatures and aggregate time signatures.
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NOTE
The order in which you should follow steps for inputting time signatures with the mouse
depends on your preferences for the Creating items with the mouse option, in the Editing
section of the General page in Preferences.
You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

RELATED LINKS
Preferences on page 53
Time signatures on page 751
Types of time signatures on page 753
Time signatures popover on page 151
Create Time Signature section of the Time Signatures (Meter) panel on page 152
Inputting time signatures with the popover on page 153
Inputting time signatures with the panel on page 154

Time signatures popover
The table shows some examples of what to enter into the time signatures popover, and the time
signatures that are input into the music as a result.
You can open the time signatures popover in Write mode in any of the following ways:
●

Press Shift-M.

●

Choose Write > Create Time Signature.

Type of time signature

Popover entry

Simple time signatures.

2/4, 6/8, 3/4, 5/4, and so on.

For example, 2/4, 6/8, 3/4, 5/4 and so on.
4/4,1.5, 6/8,2, and so on.

Time signatures with a pick-up.
For example, a 4/4 bar with a dotted quarter
note pick-up, or a 6/8 bar with pick-up of two
eighth notes (quavers).
Alternating time signatures, such as 6/8+3/4.

6/8 + 3/4

NOTE
You must include spaces either side of the plus
sign.

Common time, the equivalent of 4/4

c

Cut common time, the equivalent of 2/2

cutc or ¢

Open meter

X or x
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Type of time signature

Popover entry

Additive time signature with explicit beat
grouping.

3+2+2/8, 3+2/4, and so on.

Specify beat grouping, but don’t show it in the
time signature.

[2+3+2]/8

For example, show a time signature of 7/8 but
beaming is subdivided into 2+3+2 eighth
notes.
Aggregate time signature: a dashed barline is 2/4|6/8
shown in the bar to show the division between
the different meters.
Interchangeable time signature, with different
styles: parenthesized, slash, equals sign, and
dashed.

2/4 (6/8), 2/4 / 6/8, 2/4 = 6/8, or 2/4 – 6/8

NOTE
You must include spaces either side of the
slashes, equals signs, or dashes, and between
numbers and parentheses.

This list is not comprehensive, as there are many possible time signatures. It is intended to
illustrate how you can structure your entry to input different time signatures.
RELATED LINKS
Inputting time signatures with the popover on page 153
Time signatures on page 751

Create Time Signature section of the Time Signatures (Meter) panel
In the Time Signatures (Meter) panel on the right of the window in Write mode, there is a Create
Time Signature section in which you can create uncommon time signatures. You can hide/show
this section by clicking the section title, which has a disclosure arrow.

The Create Time Signature section of the Time Signatures (Meter) panel

The Create Time Signature section contains the following parts:
1

Type of time signature menu
Allows you to choose one of the following types of time signature:
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2

●

Regular

●

Interchangeable

●

Aggregate

●

Alternating

Spaces for up to four time signatures
Allows you to combine up to four time signatures. For example, you can specify only one
time signature for a Regular time signature, but for an alternating time signature you
might want to include three time signatures.

3

Pick-up bar of
Allows you to include a pick-up bar before the time signature. A pick-up bar is not a
complete bar, and so allows you to include only a few beats before the first complete bar.
You can select one of the following options for the number of beats in a pick-up bar:

4

●

1/2 beat

●

1 beat

●

2 beats

Input time signature button
Click the button that displays the time signature to input the time signature. If nothing in
the project is selected, the time signature is loaded onto the cursor.

RELATED LINKS
Time signatures on page 751
Inputting time signatures with the panel on page 154

Inputting time signatures with the popover
You can input time signatures, including time signatures with pick-up bars, using the time
signatures popover, both during step input and by adding them to existing music. You can also
input time signatures only on single staves.
NOTE
In order to input an upbeat or pick-up bar, you must input a new time signature that includes the
upbeat you want.
For example, entering 4/4,1 into the time signatures popover creates a 4/4 time signature with
one quarter note upbeat.
The number after the comma indicates multiples of the rhythmic unit specified by the
denominator of the time signature. For example, 4/4,0.75 creates a dotted eighth note (dotted
quaver) upbeat, whereas 6/8,2 creates an upbeat of two eighth notes.

PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select a barline where you want to input a new time signature.

●

Select a notehead or rest immediately to the right of where you want to input a new
time signature.

●

Select an existing time signature that you want to change.

Open the time signatures popover in any of the following ways:
●

Press Shift-M.

●

Choose Write > Create Time Signature.
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3.

Enter the time signature you want into the popover.
For example, [2+2+3]/8 for a 7/8 time signature with a custom beat grouping, or enter
4/4,1 for a 4/4 time signature with one quarter note upbeat.

4.

Input the time signature and close the popover in one of the following ways:
●

Press Return to input a time signature on all staves.

●

Press Alt-Return to input a time signature on a single staff.

RESULT
During step input, time signatures are added at the caret position, even if this is in the middle of
an existing bar.
When adding time signatures to existing music, they are added immediately to the right of a
selected barline, a immediately to the left of a selected note, even if this is in the middle of an
existing bar.
Holding down Alt inputs time signatures only on the selected staff.
All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first. Dorico automatically inputs and moves barlines as
required so that subsequent music is barred correctly.
RELATED LINKS
Time signatures popover on page 151
Time signatures on page 751

Inputting time signatures with the panel
You can input time signatures, including time signatures with pick-up bars, using the Time
Signatures (Meter) panel, both during step input and by adding them later to existing music. You
can also input time signatures only on single staves.
PREREQUISITE
If necessary, you have created the time signature you want in the Create Time Signature section
of the Time Signatures (Meter) panel.
NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.

PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select a barline where you want to input a new time signature.

●

Select a notehead or rest immediately to the right of where you want to input a new
time signature.

●

Select an existing time signature that you want to change.

Optional: For pick-up bars, activate Pickup bar of in the Create Time Signature section
and select one of the following options:
●

1/2 beat

●

1 beat

●

2 beats
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NOTE
Not all pick-up bar lengths are possible using this method. For example, a single
eighth note upbeat in 6/8 cannot be produced by any of these three options. In such
cases, you must use the time signatures popover.
3.

Input the time signature you want in one of the following ways:
●

Click a time signature to input it for all staves.

●

Alt-click a time signature to input a it on a single staff.

RESULT
During step input, time signatures are added at the caret position, even if this is in the middle of
an existing bar.
When adding time signatures to existing music, they are added immediately to the right of a
selected barline, a immediately to the left of a selected note, even if this is in the middle of an
existing bar.
Holding down Alt inputs time signatures only on the selected staff.
All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first. Dorico automatically inputs and moves barlines as
required so that subsequent music is barred correctly.
RELATED LINKS
Time signatures on page 751
Inputting notes on page 115
Create Time Signature section of the Time Signatures (Meter) panel on page 152
Inputting time signatures with the popover on page 153
Mouse input settings on page 108

Input methods for bars and barlines
You can input both bars and barlines with the keyboard by using the bars and barlines popover,
and also with the mouse by using the available options in the Bars and Barlines panel.
Normally you do not need to create bars in Dorico, as they are created automatically as needed
when you input music. However, you can add bars in advance if, for example, you are copying or
arranging an existing piece of music.
TIP
Another way to add bars is by choosing a note value, such as a whole note when in a 4/4 time
signature, in the Notes panel in Write mode and press Space repeatedly during step input.

Inputting bars with the popover
You can input bars and barlines with the keyboard by entering an appropriate short-hand for the
number of bars or the type of barline you want into the bars and barlines popover.
You can open the bars and barlines popover in Write mode in any of the following ways:
●

Press Shift-B.

●

Choose Write > Create Bar or Barline.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.
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Bars and barlines popover with an
example entry for inputting bars

Bars and barlines popover with an
example entry for a barline

Bars and Barlines button in the
Notations toolbox

Inputting bars with the panel
You can also input bars and barlines with the mouse using the Bars and Barlines panel on the
right of the window in Write mode.
You can open the Bars and Barlines panel by clicking Bars and Barlines in the Notations toolbox
on the right of the window in Write mode.

The panel contains the following sections:
●

Insert Bars

●

Insert Bar Rest

●

Insert Barline

You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

Inputting bars/beats with the system track
Additionally, you can input bars using the system track. The system track also allows you input
other rhythmic durations, that is, a specified beat region.
The system track is shown by default in new projects.
RELATED LINKS
Bars on page 374
Barlines on page 380
Bars and barlines popover on page 156
Inputting bars with the popover on page 158
Inputting bars with the panel on page 158
Inputting barlines with the popover on page 160
Inputting barlines with the panel on page 161
Inputting bar rests during step input on page 159

Bars and barlines popover
You can input bars and barlines, and delete bars, by entering text and numbers into the bars and
barlines popover.
You can open the bars and barlines popover in Write mode in any of the following ways:
●

Press Shift-B.

●

Choose Write > Create Bar or Barline.
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Bars
Example action

Popover entry

Add two bars

+2

Add fourteen bars

+14

Delete one bar

–1

Delete six bars

–6

Add a bar rest

rest

This list is not comprehensive, as you can add and delete any number of bars using the popover.
It is intended to illustrate how you can structure your entry to input and delete bars, and input
bar rests.
Barlines
Type of barline

Popover entry

Normal (Single)

|, single, or normal

Double

|| or double

Final

|] or final

Dashed

:, dash, or dashed

Tick

‘ or tick

Short

, or short

Thick

thick

Start repeat

|: or start

End repeat

:| or end

End/start repeat

:|:, :||:, end-start, or endstart

RELATED LINKS
Inputting bars with the popover on page 158
Inputting bar rests during step input on page 159
Inputting barlines with the popover on page 160
Bars on page 374
Barlines on page 380
Deleting bars on page 374
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Inputting bars with the popover
You can input bars using the bars and barlines popover, both during step input and by adding
them to existing music.
PROCEDURE
1.

2.

3.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing barline after which you want to add new bars.

●

Select an existing note or whole bar before which you want to add new bars.

Open the bars and barlines popover in any of the following ways:
●

Press Shift-B.

●

Choose Write > Create Bar or Barline.

Enter + (plus), followed by the number of bars you want to add.
For example, enter +2 to add two bars.

4.

Press Return to close the popover.

RESULT
The number of bars specified is input.
During step input, bars are input from the caret position. If the caret is in the middle of the bar,
sufficient beats are added to ensure that the final bar created has the correct number of beats.
The caret position stays at its previous position so you can continue inputting music from the
same position.
When you add bars to existing music, bars are added after a selected barline and before any
other selected item.
RELATED LINKS
Bars and barlines popover on page 156
Bars on page 374
Inputting bars with the panel on page 158

Inputting bars with the panel
You can input bars using the Bars and Barlines panel, both during step input and by adding them
to existing music.
PROCEDURE
1.

2.

3.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing barline after which you want to add new bars.

●

Select an existing note or whole bar before which you want to add new bars.

In the Bars and Barlines panel, change the number of bars you want to input in the value
field in the Insert Bars section in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

Select one of the following options for where you want to input bars:
●

Start of Flow: bars are input at the beginning of the flow.

●

Start of Selection: bars are input from the selected note or rest.

●

End of Flow: bars are input at the end of the flow.
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NOTE
If you want to input bars from the caret position, make sure that you have selected
Start of Selection from the menu.
TIP
You can complete steps 2 and 3 in any order.
4.

Click Insert Bars.

RESULT
The number of bars specified is input.
During step input, bars are input from the caret position.
If you selected Start of Selection, bars are input directly after a selected barline, and directly
before a selected note or bar.
RELATED LINKS
Bars on page 374
Inputting bars with the popover on page 158

Inputting bar rests during step input
For music in a single voice, you do not have to input bar rests. Bar rests appear in each new bar
automatically when you advance the caret by pressing Space or Right Arrow.
When inputting music in multiple voices, rests are normally created automatically when there is a
gap in the secondary voice. However, if the music is in strict counterpoint and you want the
secondary voice to begin with an explicit bar rest, you can create a bar rest during step input
with the popover.
PROCEDURE
1.

In Write mode, start note input.

2.

Select the appropriate secondary voice by pressing V until the voice direction indicator
shows the correct voice.

3.

Open the bars and barlines popover in any of the following ways:
●

Press Shift-B.

●

Choose Write > Create Bar or Barline.

4.

Enter rest into the popover to add a bar rest.

5.

Press Return to close the popover.

6.

Press Ctrl/Cmd-Right Arrow to advance the caret to the start of the next bar after the bar
rest.

RESULT
Bar rests are input at the caret position. If the caret position is within a bar that contains notes
for the selected voice, these notes are replaced by the bar rest.
NOTE
Alternatively, you can click Insert Bar Rest in the Insert Bar Rest section of the Bars and
Barlines panel to input bar rests during step input.
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RELATED LINKS
Bars on page 374
Rests on page 656
Inputting notes into multiple voices on page 118
Caret on page 112
Hiding/Showing bar rests in empty bars on page 376

Inputting barlines with the popover
You can input barlines using the bars and barlines popover, both during step input and by
adding them to existing music. You can also use the popover to change the type of existing
barlines.
PROCEDURE
1.

2.

3.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing note or rest immediately to the right of where you want to input a
barline.

●

Select an existing barline you want to change.

Open the bars and barlines popover in any of the following ways:
●

Press Shift-B.

●

Choose Write > Create Bar or Barline.

Enter the barline you want into the popover.
For example, enter || for a double barline.

4.

Input the barline and close the popover in one of the following ways:
●

Press Return to input a barline on all staves.

●

Press Alt-Return to input a barline on a single staff.
NOTE
You can only input barlines onto single staves that already have an independent
time signature.

5.

Press Return to close the popover.

RESULT
During step input, barlines are input at the caret position.
When you add barlines to existing music, they are added immediately to the left of a selected
note or rest.
When you change existing barlines, the new barline directly replaces the selected barline.
Surrounding music automatically adjusts to accommodate the barline. For example, note
grouping, rests, and tied notes all adjust if necessary.
RELATED LINKS
Bars and barlines popover on page 156
Barlines on page 380
Inputting notes on page 115
Inputting time signatures with the popover on page 153
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Inputting barlines with the panel
You can input barlines using the Bars and Barlines panel, both during step input and by adding
them to existing music. You can also change the type of existing barlines.
NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.

PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing note or rest immediately to the right of where you want to input a
barline.

●

Select an existing barline you want to change.

Input the barline you want in one of the following ways:
●

Click a barline to input it for all staves.

●

Alt-click a barline to input it on a single staff.
NOTE
You can only input barlines onto single staves that already have an independent
time signature.

3.

In the Bars and Barlines panel, click the barline you want.

RESULT
During step input, barlines are input at the caret position.
When you add barlines to existing music, they are added immediately to the left of a selected
note or rest.
When you change existing barlines, the new barline directly replaces the selected barline.
Surrounding music automatically adjusts to accommodate the barline. For example, note
grouping, rests, and tied notes all adjust if necessary.
RELATED LINKS
Barlines on page 380
Bars and barlines popover on page 156
Inputting notes on page 115
Inputting barlines with the popover on page 160
Mouse input settings on page 108

Input methods for dynamics
You can input dynamics with the keyboard by using the dynamics popover, and with the mouse
by using the Dynamics panel.

Inputting dynamics with the popover
You can input dynamics with the keyboard by entering the dynamics you want into the dynamics
popover.
You can open the dynamics popover in Write mode in any of the following ways:
●

Press Shift-D.
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●

Choose Write > Create Dynamic.

You can enter any dynamic into the popover, during step input and by adding them to existing
notes. However, expressive text, such as “sim.”, poco, molto, or subito, must accompany a
dynamic level, such as  or .
The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Dynamics button in the Notations toolbox

Dynamics popover with an example entry

Inputting dynamics with the panel
You can input dynamics with the mouse by clicking dynamics in the Dynamics panel on the right
of the window in Write mode.
Open the Dynamics panel by clicking Dynamics in the Notations toolbox on the right of the
window in Write mode.

The Dynamics panel contains the following sections:
Immediate Dynamics
Contains dynamics such as , , molto, and possibile.
Gradual Dynamics
Contains dynamics such as , , molto, and poco.
Force/Intensity of Attack
Contains dynamics such as  and .
Combined Dynamics
Create your own combinations of dynamics. For example, .

You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

RELATED LINKS
Dynamics on page 476
Dynamics popover on page 163
Inputting dynamics with the popover on page 164
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Inputting dynamics with the panel on page 166
Niente hairpins on page 480
Adding expressive text to existing dynamics on page 482

Dynamics popover
The table shows some examples of what to enter into the dynamics popover and the dynamics
that are input into the music as a result.
You can open the dynamics popover in Write mode in any of the following ways:
●

Press Shift-D.

●

Choose Write > Create Dynamic.

Dynamic or expression

Popover entry

pianissimo: 

pp

piano: 

p

mezzo piano: 

mp

mezzo forte: 

mf

forte: 

f

fortissimo: 

ff

subito

subito, sub, or sub.

possibile

possibile, poss, or poss.

poco

poco

molto

molto

più

piu or più

meno

meno

mosso

mosso

crescendo: 

<

cresc. (text)

cresc

diminuendo: 

>

dim. (text)

dim

crescendo then diminuendo messa di voce:


<>

diminuendo then crescendo: 

><
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Dynamic or expression

Popover entry

niente hairpins that start/end with a small circle o< or >o
niente hairpins that start/end with the letter “n” n< or >n
sforzando: 

sfz

rinforzando: 

rfz

This list is not comprehensive as you can enter expressive text freely. It is intended to illustrate
how you can structure your entry to input different types of dynamics.
TIP
You can input crescendo and diminuendo hairpins directly into the score without the popover by
pressing Shift-, and Shift-..
You can change the appearance of gradual dynamics project-wide on the Dynamics page in
Engraving Options, or individually by activating Gradual style in the Dynamics group of the
Properties panel, and selecting one of the available options.

Inputting expressive text into the dynamics popover
You can enter other expressions into the dynamics popover, such as espressivo or dolce, and
they appear in the correct italic font beside the dynamic.
However, you must also enter an accompanying immediate dynamic, such as p or f, and separate
the two with a space, for example, f molto or p espressivo.
You can hide immediate dynamics if you only want to show the expressive text.
RELATED LINKS
Inputting dynamics with the popover on page 164
Dynamics on page 476
Niente hairpins on page 480
Hiding immediate dynamics on page 483

Inputting dynamics with the popover
You can input dynamics and expressive text using the dynamics popover, both during step input
and by adding them to existing notes. You can also input different dynamics into each voice
independently in multiple-voice contexts.
TIP
You can also change dynamics during step input by following these steps when the caret is at the
rhythmic position of the dynamic you want to change.

PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select existing notes across which you want to add dynamics.

Open the dynamics popover in any of the following ways:
●

Press Shift-D.
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●
3.

Choose Write > Create Dynamic.

Enter the dynamic you want into the popover.
For example, p, p<f>p, or f>.

4.

Input the dynamics and close the popover in one of the following ways:
●

Press Return to input the dynamics for all voices on the staff.

●

Press Alt-Return to input the dynamics only into the selected voice.

Open-ended dynamics, such as p<, automatically extend during step input as you continue
inputting notes, or if you advance the caret by pressing Space or the arrow keys.
5.

Optional: During step input, stop open-ended dynamics by opening the popover again and
entering another immediate dynamic. For example, enter f.

6.

Optional: During step input, input dynamics and close the popover in one of the following
ways:
●

Press Return to input dynamics for all voices on the staff.

●

Press Alt-Return to input dynamics only into the voice indicated by the quarter note
symbol beside the caret.

RESULT
The selected dynamics are input. They are positioned according to your settings on the
Dynamics page in Engrave > Engraving Options. Voice-specific dynamics are placed below the
staff by default, even if they are input into an up-stem voice.
During step input, dynamics are input at the caret position, and extend automatically if you
included an open-ended gradual dynamic. Voice-specific dynamics are input in the voice
indicated by the quarter note symbol beside the caret.
When you add dynamics to existing notes, immediate dynamics are added to the first note in the
selection and gradual dynamics are added across the selection.
TIP
You can move dynamics within dynamics phrases and change the placement of dynamics relative
to the staff later.
NOTE
●

If you entered a dynamic phrase into the popover, such as p<f>p, each dynamic and
hairpin lasts a quarter note (crotchet) by default. You can lengthen/shorten gradual
dynamics and groups of dynamics later.

●

Some expressive text, such as molto, appears before immediate dynamics rather than after
them, even if you do not enter them in that order. This follows the generally accepted
practice for expressive text placement.
You can hide immediate dynamics later if you only want to show expressive text.

RELATED LINKS
Dynamics popover on page 163
Dynamics on page 476
Groups of dynamics on page 493
Voice-specific dynamics on page 480
Moving dynamics rhythmically on page 491
Lengthening/Shortening gradual dynamics and groups of dynamics on page 484
Hiding immediate dynamics on page 483
Changing the placement of dynamics relative to the staff on page 489
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Inputting dynamics with the panel
You can input dynamics and expressive text using the Dynamics panel, both during step input
and by adding them to existing notes. You can also input different dynamics into each voice
independently in multiple-voice contexts.
TIP
You can also change dynamics during step input by following these steps when the caret is at the
rhythmic position of the dynamic you want to change.
NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.

PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select existing notes across which you want to add dynamics.

In the Notations toolbox, click Dynamics.

The Dynamics panel opens on the right of the window.
3.

Input the dynamics you want in one of the following ways:
●

Click the dynamics you want in the Dynamics panel to input them for all voices on
the staff.

●

Alt-click the dynamics you want in the Dynamics panel to input them only into the
selected voice.

Do not deselect dynamics if you want to add expressive or qualifying text to them.
When inputting voice-specific dynamics, you can release Alt once you have input the
dynamic level, such as .
NOTE
Gradual dynamics have a default duration of a quarter note. You can lengthen/shorten
gradual dynamics later.
TIP
You can also input gradual dynamics by clicking the gradual dynamic you want in the
Dynamics panel when nothing is selected in the music area. Then click and drag to input
the gradual dynamic and extend it to the length you want.
4.

Optional: In the Dynamics panel, click the expressive/qualifying texts you want in the
Immediate Dynamics and Gradual Dynamics sections.

RESULT
The selected dynamics are input. They are positioned according to your settings on the
Dynamics page in Engrave > Engraving Options. Voice-specific dynamics are placed below the
staff by default, even if they are input into an up-stem voice.
During step input, dynamics are input at the caret position. Voice-specific dynamics are input in
the voice indicated by the quarter note symbol beside the caret.
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When you add dynamics to existing notes, immediate dynamics are added to the first note in the
selection and gradual dynamics are added across the selection.
TIP
You can move dynamics within dynamics phrases and change the placement of dynamics relative
to the staff later.
NOTE
Some expressive text, such as molto, appears in the score before the dynamic rather than after it.
This follows the generally accepted practice for expressive text placement.

RELATED LINKS
Dynamics on page 476
Voice-specific dynamics on page 480
Moving dynamics rhythmically on page 491
Lengthening/Shortening gradual dynamics and groups of dynamics on page 484
Hiding immediate dynamics on page 483
Changing the placement of dynamics relative to the staff on page 489
Mouse input settings on page 108

Input methods for chord symbols
You can input chord symbols in Dorico with the computer keyboard and also with MIDI
keyboards.

Inputting chord symbols with the computer keyboard
All the different types of chord symbols can be input with the computer keyboard by using the
chord symbols popover.
You can open the chord symbols popover in Write mode in any of the following ways:
●

Press Shift-Q.

●

Choose Write > Create Chord Symbol.

●

Click Chord Symbols in the Notations toolbox.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Chord symbols popover with an example entry

Chord Symbols button in the Notations toolbox

The appearance of chord symbols project-wide is determined by the options you set on the
Chord Symbols page in Engrave > Engraving Options.
NOTE
The short-hand you use in the popover to create the chord symbol does not determine the
appearance of the resulting chord symbol.
For example, you can enter a C major chord as either C or Cmaj or CM, but in both cases the
appearance of the resulting chord symbol is the same, as specified in Engraving Options.
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Inputting chord symbols with a MIDI keyboard
You can play chords on your MIDI keyboard to input chord symbols when the chord symbol
popover is open.
Options for how Dorico interprets the notes you play on your keyboard can be found on the
Chord Symbols page in Write > Note Input Options.
The options include:
●

Whether you want Dorico to consider the inversion in which you play a given chord, or
write the chord symbol as if it had been played in root position.

●

Whether you want Dorico to notate omissions. For example, if you play C and E, it could be
notated as “C” or “C(omit5)”.

●

How you want Dorico to notate added notes and suspensions.

●

How you want Dorico to handle complex enharmonic relationships between roots and
altered bass notes.

Examine these options carefully to make sure your settings suit your needs.
RELATED LINKS
Chord symbols on page 427
Inputting chord symbols on page 173
Project-wide engraving options for chord symbols on page 427
Navigation during chord symbol input on page 171

Chord symbols popover
You can input chord symbols with different combinations of components using the chord
symbols popover. The following tables contain examples of what to enter into the chord symbols
popover for the different chord symbol components possible in Dorico.
You can open the chord symbols popover in Write mode in any of the following ways:
●

Press Shift-Q.

●

Choose Write > Create Chord Symbol.

●

Click Chord Symbols in the Notations toolbox.

NOTE
You can combine multiple types of entries to create more complex chord symbols if you enter
them one after another into the chord symbols popover without spaces between them. For
example, enter Eblocrian for the following chord symbol:

Chord symbol roots
Type of chord symbol root

Popover entry

English note names

C, Db, F#, B, and so on.

C, D♭, F♯, B, and so on.
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Type of chord symbol root

Popover entry

German note names

C, Des, Fis, H, and so on.

C, D♭, F♯, B, and so on.
do, reb, so, so#, ti, and so on.

Fixed-do solfège
C, D♭, F, F♯, B, and so on.
Nashville numbers representing scale degrees

1, 2b, 4#, 7, and so on.

Assuming C major:
C, D♭, F♯, B, and so on.
Chord symbol qualities
Chord symbol quality

Popover entry

Major

maj, M, ma, or nothing after entering the root.

Minor

m, min, or mi

Diminished

dim, di, or o

Augmented

aug, au, ag, or +

Half-diminished

half-dim, halfdim, or hd

6/9

6/9, 69, or %

Chord symbol intervals
Interval

Popover entry

Major 7th

^7 or ^

Major 9th

^9, maj9, or 9maj7

Chord symbol alterations
Type of chord symbol alteration

Popover entry

Alterations

b5, #9, and so on.

Added notes

add#11, addF#, addBb, and so on.

Suspensions

sus4, sus9, and so on.

Omissions

omit3, no7, and so on.

169

Write mode
Notations input
Chord symbols with altered bass notes
Example altered bass note chord symbols

Popover entry

G7/D

G7,D

G/B

Gmaj,B

C(♭5)/E♭

Cmajb5/Eb

Fm/D♯

Fmi/D#

Polychord symbols
Example polychord symbols

Popover entry

G7/D

G7;D

G/E

G;E

Cmaj7/D

Cmaj7|D

Fm/D♯

Fmi|D#

No chord symbols
No chord symbol

Popover entry

No chord

N.C., NC, no chord, or none

Modal chord symbols
Modal chord symbol

Popover entry

Ionian

ionian

Dorian

dorian

Phrygian

phrygian

Lydian

lydian

Mixolydian

mixolydian

Aeolian

aeolian

Locrian

locrian

Melodic minor

melodicminor

Harmonic minor

harmonicminor

170

Write mode
Notations input

Modal chord symbol

Popover entry

Whole tone

wholetone

Octatonic or diminished half-whole

diminishedhalfwhole,
diminishedsemitonetone, octatonichalfwhole,
or octatonicsemitonetone

Octatonic or diminished whole-half

diminishedwholehalf,
diminishedtonesemitone, octatonicwholehalf,
or octatonictonesemitone

NOTE
The appearance of the resulting chord symbols in your project depends on the options you have
selected on the Chord Symbols page in Engrave > Engraving Options.
This list is not comprehensive, as there are many possible chord symbols. It is intended to
illustrate the different components you can use to input different chord symbols.
RELATED LINKS
Inputting chord symbols on page 173
Chord symbols on page 427

Navigation during chord symbol input
You can input multiple chord symbols without re-opening the popover each time by navigating
through your score.

Navigating with a computer keyboard
You can move the chord symbols popover to input chord symbols on other notes without having
to close and reopen the popover on each note.
Popover navigation

Key command

Advance the popover to the next beat.

Space

Move the popover back to the previous beat.

Shift-Space

Advance the popover to the start of the next
bar.

Tab

Move the popover back to the start of the
previous bar.

Shift-Tab

Move the popover to one of the following
positions, whichever is closest:

Right Arrow/Left Arrow

●

Next/Previous note

●

Next/Previous rest

●

Next/Previous rhythmic grid position
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Popover navigation

Key command

Move the popover to the next/previous chord
symbol.

Ctrl/Cmd-Right Arrow/Ctrl/Cmd-Left Arrow

Move the popover back to the previous chord
symbol.

Backspace

Navigating with a MIDI keyboard
When inputting chord symbols using a MIDI keyboard, by default the popover advances
automatically to the next beat after you play a chord. You can change this behavior using the
Advance during chord symbol input via MIDI keyboard options on the MIDI Input page in
Write > Note Input Options.
Furthermore, you can define specific keys or buttons on your MIDI keyboard to trigger different
navigation behaviors, by using the MIDI Learn button on the Key Commands page in
Preferences to assign specific keys to the NoteInput > Advance Chord Symbol Input
commands.

The Preferences dialog, where you can set keys to command the different navigation parameters.

RELATED LINKS
Assigning navigation behaviors for chord symbols to MIDI keyboards on page 172

Assigning navigation behaviors for chord symbols to MIDI keyboards
You can assign specific keys or buttons on your MIDI keyboard to trigger different navigation
behaviors for chord symbols.
PROCEDURE
1.

2.

Open Preferences in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Edit > Preferences (Windows).

●

Choose Dorico > Preferences (macOS).

Click Key Commands in the page list on the left of the dialog.
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3.

Show the options under NoteInput > Advance Chord Symbol Input in the key command
list in any of the following ways:
●

Double-click each option.

●

Click the disclosure arrow beside each option.

4.

Click the parameter to which you want to assign a MIDI keyboard command from the
available behaviors under Advance Chord Symbol Input. For example, click Next Bar to
assign a key to move the chord symbols popover to the next bar.

5.

Click MIDI Learn.

6.

Press the key on your MIDI keyboard that you want to assign to the selected parameter.

7.

Click Add MIDI Command.

8.

Click Apply, then Close.

RELATED LINKS
Preferences on page 53

Inputting chord symbols
You input chord symbols using the chord symbols popover.
PROCEDURE
1.

In Write mode, select the note or rest where you want to input the first chord symbol.

2.

Open the chord symbols popover in any of the following ways:

3.

●

Press Shift-Q.

●

Choose Write > Create Chord Symbol.

●

Click Chord Symbols in the Notations toolbox.

Enter the chord symbol you want into the chord symbols popover in any of the following
ways:
●

Enter the appropriate letters and numbers using the computer keyboard.

●

Playing the chord you want using a MIDI keyboard.

4.

Optional: Advance the popover to continue inputting chord symbols on following notes.

5.

Press Return to close the popover.

RESULT
The chord symbol specified is input.
NOTE
The chord symbol may look different to what you entered into the popover. For example,
entering D|C7 may result in two chords placed directly above each other, or two chords placed
beside each other, depending on your settings on the Chord Symbols page in Engrave >
Engraving Options.

RELATED LINKS
Chord symbols popover on page 168
Chord symbols on page 427
Input methods for chord symbols on page 167
Navigation during chord symbol input on page 171
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Inputting polychords with a MIDI keyboard
You can input polychords when inputting chord symbols with a MIDI keyboard.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Play the first chord of the polychord with one hand.
Keep the keys of the first chord depressed.

3.

Play the second chord with the other hand.

RESULT
The two chords you played are input as a polychord symbol.
TIP
You can also input polychords by entering the two chords separated by a semicolon or pipe/
vertical line character into the chord symbols popover.

RELATED LINKS
Chord symbols on page 427
Input methods for chord symbols on page 167
Chord symbols popover on page 168
Inputting chord symbols on page 173

Indicating root notes in chord symbols with a MIDI keyboard
You can indicate the root note of chord symbols when inputting chord symbols with a MIDI
keyboard.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Indicate the root note of a chord symbol in any of the following ways when using a MIDI
keyboard:
●

First play the root with one finger, and then play the remaining notes of the chord
while still holding down the root.

●

Play all the notes of the chord together, then release them all, then replay the root
note.
TIP
To input a chord symbol that consists only of the root note, just play a single note.

RELATED LINKS
Chord symbols on page 427
Inputting chord symbols on page 173
Chord symbols popover on page 168
Input methods for chord symbols on page 167
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Indicating altered bass notes in chord symbols with a MIDI keyboard
You can indicate that chords have altered bass notes when inputting chord symbols with a MIDI
keyboard.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Indicate which note is the altered bass note of a chord in any of the following ways when
using a MIDI keyboard:
●

Play all notes of the chord together with the altered bass note at the bottom.

●

Play the chord and its altered bass note separately: hold down the keys for the
chord, then play the altered bass note while keeping the rest of the keys of the
chord depressed.

RELATED LINKS
Chord symbols on page 427
Chord symbols popover on page 168
Inputting chord symbols on page 173

Input methods for clefs and octave lines
You can input clefs and octave lines with the keyboard by using the clefs and octave lines
popover, and also with the mouse by clicking clefs and octave lines in the Clefs panel.

Inputting clefs and octave lines with the popover
You can input clefs and octave lines with the keyboard by entering an appropriate short-hand for
the clef or octave line you want into the clefs and octave lines popover. Clefs and octave lines
share the same popover, as both affect the pitch and register of notes.
You can open the clefs and octave lines popover in Write mode in any of the following ways:
●

Press Shift-C.

●

Choose Write > Create Clef.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Clefs and octave lines popover
with an example entry for a clef

Clefs and octave lines popover
with an example entry for an
octave line

Clefs button in the Notations
toolbox

Inputting clefs and octave lines with the mouse
Clefs and octave lines can be input with the mouse using the Clefs panel on the right of the
window in Write mode.
You can open the Clefs panel by clicking Clefs in the Notations toolbox on the right of the
window in Write mode.

In the Clefs panel, there are separate sections for clefs and octave lines. Clefs are divided across
multiple sections:
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Common clefs
These are the clefs you are most likely to need.
Uncommon clefs
These are less frequently used clefs, but still sometimes used.
Archaic clefs
These are clefs that are not commonly used any more.
You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

RELATED LINKS
Clefs on page 443
Octave lines on page 448
Clefs and octave lines popover on page 176
Inputting clefs with the popover on page 178
Inputting clefs with the panel on page 178

Clefs and octave lines popover
You can create different clefs and octave lines by entering text and numbers into the clefs and
octave lines popover.
You can open the clefs and octave lines popover in Write mode in any of the following ways:
●

Press Shift-C.

●

Choose Write > Create Clef.

Clefs
Type of clef

Popover entry

Treble G clef

g, G, or treble

Bass F clef

f, F, or bass

Tenor C clef

ct, CT, or tenor

Alto C clef

ca, CA, or alto

Treble G clef, octave below

g8ba, G8ba, g8d, G8d, treble8ba, or treble8d

Treble G clef, two octaves below

g15ba, G15ba, g15d, G15d, treble15ba, or
treble15d

Treble G clef, octave above

g8va, G8va, g8u, G8u, treble8va, or treble8u

Treble G clef, two octaves above

g15ma, G15ma, g15u, G15u, treble15ma, or
treble15u

Alto C clef, octave below

ca8ba, CA8ba, ca8d, CA8d, alto8ba, or alto8d
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Type of clef

Popover entry

Tenor C clef, octave below

ct8ba, CT8ba, ct8d, CT8d, tenor8ba, or tenor8d

Bass F clef, octave below

f8ba, F8ba, f8d, F8d, bass8ba, or bass8d

Bass F clef, two octaves below

f15ba, F15ba, f15d, F15d, bass15ba, or
bass15d

Bass F clef, octave above

f8va, F8va, f8u, F8u, bass8va, or bass8u

Bass F clef, two octaves above

f15ma, F15ma, f15u, F15u, bass15ma, or
bass15u

Unpitched percussion

perc

4-string tablature

tab4

6-string tablature

tab6

Baritone bass clef

baritonebass

Baritone clef

baritone

Mezzo-soprano clef

mezzo

Soprano C clef

soprano

Sub-bass clef

subbass

Invisible clef

invisible

NOTE
More clefs are available in the Clefs panel, including Indian drum clef and Percussion clef
(rectangular).
Octave lines
Function of octave line

Popover entry

Shifts notes up by 1 octave.

8va, 8, 8u, or 1u

Shifts notes up by 2 octaves.

15ma, 15, 15u, or 2u

Shifts notes up by 3 octaves.

22ma, 22, 22u, or 3u

Shifts notes down by 1 octave.

8ba, 8vb, 8d, or 1d

Shifts notes down by 2 octaves.

15ba, 15vb, 15d, or 2d

Shifts notes down by 3 octaves.

22ba, 22vb, 22d, or 3d
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Function of octave line

Popover entry

End of octave line.

| or stop

For example, enter stop to specify where an
octave line ends during step input.
RELATED LINKS
Inputting clefs with the popover on page 178
Inputting octave lines with the popover on page 179
Clefs on page 443
Octave lines on page 448

Inputting clefs with the popover
You can input clefs using the clefs and octave lines popover, both during step input and by
adding them to existing music. You can also use the popover to change the type of existing clefs.
In Dorico, you cannot hide clefs. Therefore, if you do not want to show any clef, you must input
an invisible clef.
PROCEDURE
1.

2.

3.

In Write mode, do one of the following:
●

Start note input.

●

Select the note from which you want a new clef to start.

●

Select the clef you want to change.

Open the clefs and octave lines popover in any of the following ways:
●

Press Shift-C.

●

Choose Write > Create Clef.

Enter the appropriate short-hand for the clef you want into the popover.
For example, enter bass or G8ba.

4.

Press Return to close the popover.

RESULT
During step input, clefs are input at the caret position. Note input continues after inputting the
clef, so you can continue inputting notes and clefs as required.
When you add clefs to existing music, clefs are added directly before a selected notehead, and
apply to all notes on that staff until the next clef, or the end of the flow.
When you change existing clefs, the new clef directly replaces the selected clef.
Clefs apply to all notes on the staff until the next clef, or the end of the flow.
RELATED LINKS
Clefs and octave lines popover on page 176
Clefs on page 443

Inputting clefs with the panel
You can input clefs using the Clefs panel, both during step input and by adding them to existing
music.
In Dorico, you cannot hide clefs. Therefore, if you do not want to show any clef, you must input
an invisible clef.
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NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.

PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select the note from which you want a new clef to start.

●

Select the clef you want to change.

In the Notations toolbox, click Clefs.

The Clefs panel opens on the right of the window.
3.

In the Clefs panel, click the clef you want.

RESULT
During step input, clefs are input at the caret position. Note input continues after inputting the
clef, so you can continue inputting notes and clefs as required.
When you add clefs later to existing music, clefs are added directly before a selected notehead,
and apply to all notes on that staff until the next clef, or the end of the flow.
When you change existing clefs, the new clefs directly replaces the selected clef.
Clefs apply to all notes on the staff until the next clef, or the end of the flow.
RELATED LINKS
Clefs on page 443
Input methods for clefs and octave lines on page 175
Mouse input settings on page 108

Inputting octave lines with the popover
You can input octave lines using the clefs and octave lines popover, both during step input and
by adding them to existing music.
PROCEDURE
1.

2.

3.

In Write mode, do one of the following:
●

Start note input.

●

Select the existing notes to which you want to add an octave line.

Open the clefs and octave lines popover in any of the following ways:
●

Press Shift-C.

●

Choose Write > Create Clef.

Enter the appropriate short-hand for the octave line you want into the popover.
For example, enter 8va for an octave line that shifts notes up one octave.

4.

Press Return to close the popover.

5.

Optional: During step input, press Space to advance the caret and extend the octave line.
The octave line also extends automatically as you continue inputting notes.

6.

Optional: During step input, stop any octave line by opening the clefs and octave lines
popover again and entering one of the following:
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●

|

●

stop

RESULT
During step input, octave lines are input from the caret position. When you stop octave lines,
they end at the caret position.
When you add octave lines to existing notes, they are added either above or below your
selection, depending on whether the octave line indicates that notes are played higher or lower
than notated.
TIP
You can also lengthen/shorten octave lines after they have been input.

RELATED LINKS
Clefs and octave lines popover on page 176
Octave lines on page 448
Lengthening/Shortening octave lines on page 449

Inputting octave lines with the panel
You can input octave lines using the Clefs panel, both during step input and by adding them to
existing music.
NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.

PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select the notes to which you want to add an octave line.

In the Notations toolbox, click Clefs.

The Clefs panel opens on the right of the window.
3.

In the Clefs panel, click the octave line you want.
Alternatively, when adding octave lines to existing notes, you can click the octave lines you
want in the Clefs panel first, and then click and drag to the length you want.

RESULT
During step input, octave lines are input at the caret position. However, if input using the mouse,
octave lines do not automatically extend as you continue inputting notes.
When you add octave lines to existing notes, they are added either above or below your
selection, depending on whether the octave line indicates notes are played higher or lower than
notated.
TIP
You can also lengthen/shorten octave lines after they have been input.
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RELATED LINKS
Octave lines on page 448
Lengthening/Shortening octave lines on page 449
Mouse input settings on page 108

Input methods for holds and pauses
You can input holds and pauses with the keyboard by using the holds and pauses popover in
Write mode, and with the mouse by using the Holds and Pauses panel.

Inputting holds and pauses with the popover
You can input holds and pauses with the keyboard by entering the type of hold or pause you
want into the holds and pauses popover.
You can open the holds and pauses popover in Write mode in any of the following ways:
●

Press Shift-H.

●

Choose Write > Create Hold or Pause.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Holds and pauses popover with an example entry

Holds and Pauses button in the Notations toolbox

Inputting holds and pauses with the panel
You can input holds and pauses with the mouse by clicking different holds and pauses in the
Holds and Pauses panel.
You can open the Holds and Pauses panel by clicking Holds and Pauses in the Notations toolbox
on the right of the window in Write mode.

The Holds and Pauses panel contains the following sections:
●

Fermatas

●

Breath Marks

●

Caesuras

NOTE
Holds and pauses do not currently have an effect in playback, but this is planned for future
versions.
You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

RELATED LINKS
Holds and pauses on page 524
Holds and pauses popover on page 182
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Correct positioning for caesura input on page 185
Inputting holds and pauses with the popover on page 183
Inputting holds and pauses with the panel on page 184

Holds and pauses popover
Enter the following commands or symbols into the holds and pauses popover to create the
different holds and pauses available.
You can open the holds and pauses popover in Write mode in any of the following ways:
●

Press Shift-H.

●

Choose Write > Create Hold or Pause.

Type of hold or pause

Popover entry

Fermata

fermata

Very long fermata

fermataverylong

Long fermata

fermatalong

Short fermata

fermatashort

Very short fermata

fermataveryshort

Short fermata (Henze)

fermatashorthenze

Long fermata (Henze)

fermatalonghenze

Curlew (Britten)

curlew

Caesura

caesura or //

Thick caesura

caesurathick
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Type of hold or pause

Popover entry

Curved caesura

caesuracurved

Short caesura

caesurashort

Breath mark (Comma-like)

breathmarkcomma, comma, or , (comma)

Breath mark (Tick-like)

breathmarktick

Breath mark (Upbow-like)

breathmarkupbow

Breath mark (Salzedo)

breathmarksalzedo

NOTE
The Curlew mark was originally devised by Benjamin Britten for “Curlew River”, a parable for
church performance inspired by Japanese Noh theater. It indicates that a player should hold a
note or a rest until a synchronization point in asynchronous music.

RELATED LINKS
Inputting holds and pauses with the popover on page 183
Holds and pauses on page 524
Types of fermatas on page 524
Types of caesuras on page 526
Types of breath marks on page 526

Inputting holds and pauses with the popover
You can input holds and pauses using the holds and pauses popover, both during step input and
by adding them to existing music.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing note to which you want to add a hold or pause.
NOTE
You can only add one hold or pause to one note at a time.

2.

Open the holds and pauses popover in any of the following ways:
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3.

●

Press Shift-H.

●

Choose Write > Create Hold or Pause.

Enter the hold or pause you want into the popover.
For example, enter fermata or caesura.

4.

Press Return to close the popover.

RESULT
During step input, the specified hold or pause is input at the caret position.
Fermatas appear above the selected note, and above all notes or rests at that rhythmic position,
or the rhythmic position of the note, chord, or rest that corresponds with the end of the fermata
on every staff.
Breath marks appear to the right of the caret or selected note.
Caesuras appear to the left of the caret or selected note, and appear on all staves at that same
rhythmic position.
RELATED LINKS
Holds and pauses popover on page 182
Holds and pauses on page 524

Inputting holds and pauses with the panel
You can input holds and pauses using the Holds and Pauses panel, both during step input and by
adding them to existing music.
NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing note to which you want to add a hold or pause.
NOTE
You can only add one hold or pause to one note at a time.

2.

In the Notations toolbox, click Holds and Pauses.

The Holds and Pauses panel opens on the right of the window.
3.

In the Holds and Pauses panel, click the hold or pause you want.

RESULT
During step input, the specified hold or pause is input at the caret position.
Fermatas appear above the selected note, and above all notes or rests at that rhythmic position,
or the rhythmic position of the note, chord, or rest that corresponds with the end of the fermata
on every staff.
Breath marks appear to the right of the caret or selected note.
Caesuras appear to the left of the caret or selected note, and appear on all staves at that same
rhythmic position.
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RELATED LINKS
Holds and pauses on page 524
Input methods for holds and pauses on page 181
Correct positioning for caesura input on page 185
Mouse input settings on page 108

Correct positioning for caesura input
Caesuras are commonly placed at the end of a bar, before a barline. In Dorico, caesuras must be
attached to the note immediately after the position you want it to appear, as then Dorico can
automatically position them correctly.
If you input caesuras with your mouse input preference set to Load cursor with item, you must
click the first note in the next bar for a caesura to appear before the barline. You can also click
directly on the barline.

A correctly input caesura. The dotted guidelines are
attached to the notehead after the barline, meaning
the caesura is correctly positioned before the
barline.

An incorrectly input caesura. By clicking to the left of
the barline, the caesura is attached to the last eighth
note in the bar.

When input correctly, the dotted guidelines link the caesura to the notehead immediately after
the barline.
If your dotted guidelines do not link the caesura to the notehead immediately after the barline,
delete the caesura and re-input it. Caesuras can cause spacing issues when input incorrectly.
RELATED LINKS
Holds and pauses on page 524
Types of caesuras on page 526

Input methods for ornaments, arpeggio signs, and glissando lines
You can input ornaments, including arpeggio signs and glissando lines, with the keyboard by
using the ornaments popover, and with the mouse by using the Ornaments panel.
You can input ornaments and arpeggio signs during step input and by adding them to existing
notes, but you cannot input glissando lines during step input. You can only input glissando lines
by adding them to existing notes.

Inputting ornaments with the popover
You can input ornaments with the keyboard by entering the ornament you want into the
ornaments popover.
You can open the ornaments popover in Write mode in any of the following ways:
●

Press Shift-O.

●

Choose Write > Create Ornament.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.
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Ornaments popover with an example entry

Ornaments button in the Notations toolbox

Inputting ornaments with the panel
You can open the Ornaments panel by clicking Ornaments in the Notations toolbox on the right
of the window in Write mode.

The Ornaments panel contains the following sections:
●

Baroque and Classical

●

Arpeggiation

●

Glissandi

NOTE
You cannot input arpeggio signs with the mouse during step input.
You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

RELATED LINKS
Ornaments on page 583
Arpeggio signs on page 591
Glissando lines on page 600
Ornaments popover on page 186
Inputting ornaments with the popover on page 187
Inputting ornaments with the panel on page 188

Ornaments popover
You can enter the following commands into the ornaments popover to create the different
ornaments, arpeggio signs, and glissando lines available.
You can open the ornaments popover in Write mode in any of the following ways:
●

Press Shift-O.

●

Choose Write > Create Ornament.

Ornaments
Type of ornament, glissando line, or
arpeggio sign

Popover entry

Trill: 

tr or trill

Short trill: 

shorttr
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Type of ornament, glissando line, or
arpeggio sign

Popover entry

Turn: 

turn

Mordent: 

mor or mordent

Inverted turn: 

invturn or invertedturn

Type of arpeggio sign

Popover entry

Up arpeggio sign

arp, arpup, or arpeggioup

Down arpeggio sign

arpdown or arpeggiodown

Non arpeggio sign

nonarp or nonarpeggio

Type of glissando line

Popover entry

Straight glissando line

gliss

Wavy glissando line

glisswavy

Arpeggio signs

Glissando lines

TIP
Other ornaments are available in the Ornaments panel on the right of the window in Write mode.

RELATED LINKS
Inputting ornaments with the popover on page 187
Inputting ornaments with the panel on page 188
Ornaments on page 583
Arpeggio signs on page 591
Glissando lines on page 600
Input methods for ornaments, arpeggio signs, and glissando lines on page 185

Inputting ornaments with the popover
You can input ornaments using the ornaments popover, both during step input and by adding
them to existing notes.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select a single existing note to which you want to add an ornament.

●

Select existing notes across which you want to add a trill.
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NOTE
You can only add one ornament to one note at a time.
2.

3.

Open the ornaments popover in any of the following ways:
●

Press Shift-O.

●

Choose Write > Create Ornament.

Enter the appropriate short-hand for the ornament you want into the popover.
For example, enter trill for a trill or mor for a mordent.

4.

Press Return to close the popover.

RESULT
During step input, ornaments are input at the caret position. Trills last the duration of the
rhythmic value of the note input at the caret position.
When adding ornaments to existing notes, ornaments are input above the selected note. Trills
are input above the first selected note, with an extender line across any subsequent selected
notes.
RELATED LINKS
Ornaments popover on page 186
Ornaments on page 583
Inputting notes on page 115

Inputting ornaments with the panel
You can input ornaments using the Ornaments panel, both during step input and by adding
them to existing notes.
NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select a single existing note to which you want to add an ornament.

●

Select existing notes across which you want to add a trill.
NOTE
You can only add one ornament to one note at a time.

2.

In the Notations toolbox, click Ornaments.

The Ornaments panel opens on the right of the window.
3.

In the Ornaments panel, click the ornament you want.

RESULT
During step input, ornaments are input at the caret position. Trills are input with a default
duration of a quarter note.
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When adding ornaments to existing notes, ornaments are input above the selected note. Trills
are input above the first selected note, with an extender line across any subsequent selected
notes.
RELATED LINKS
Ornaments on page 583
Inputting notes on page 115
Mouse input settings on page 108

Inputting arpeggio signs with the popover
You can input arpeggio signs using the ornaments popover, both during step input and by
adding them to existing notes. You can also input cross-staff arpeggio signs between notes in
different staves that belong to the same instrument, such as piano or harp.
NOTE
You can only add one arpeggio sign to one note or chord at a time.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select the existing notes to which you want add an arpeggio sign.

For instruments with multiples staves, such as piano and harp, you can select existing
notes in multiple staves to create cross-staff arpeggio signs.
NOTE
You cannot create cross-staff arpeggio signs between different instruments.
2.

3.

4.

Optional: During step input, activate Chords in any of the following ways:
●

Press Q.

●

In the Notes toolbox, click Chords.

Open the ornaments popover in any of the following ways:
●

Press Shift-O.

●

Choose Write > Create Ornament.

Enter the appropriate short-hand for the arpeggio sign you want into the popover.
For example, enter arpup for an up arpeggio or enter arpdown for a down arpeggio.

5.

Press Return to close the popover.

6.

Optional: During step input, input the notes you want.

RESULT
During step input, arpeggio signs are input at the caret position.
When adding arpeggio signs to existing notes, they are input to the left of the selected note or
chord.
The length of arpeggio signs is adjusted automatically so that they span the range of all notes on
the staff at that rhythmic position.
RELATED LINKS
Ornaments popover on page 186
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Input methods for ornaments, arpeggio signs, and glissando lines on page 185
Arpeggio signs on page 591
Inputting notes on page 115
Inputting chords on page 129

Inputting arpeggio signs with the panel
You can input arpeggio signs on existing notes using the Ornaments panel. You can also input
cross-staff arpeggio signs between notes in different staves that belong to the same instrument,
such as piano or harp.
NOTE
●

You can only add one arpeggio sign to one note or chord at a time, and you cannot input
arpeggio signs with the mouse during step input.

●

These steps describe inputting with the default mouse input preference of Create item at
selection.
You cannot create cross-staff and cross-voice arpeggio signs if your preference is set to
Load cursor with item.

PROCEDURE
1.

In Write mode, select the existing notes to which you want add an arpeggio sign.
For instruments with multiples staves, such as piano and harp, you can select existing
notes in multiple staves to create cross-staff arpeggio signs.
NOTE
You cannot create cross-staff arpeggio signs between different instruments.

2.

In the Notations toolbox, click Ornaments.

The Ornaments panel opens on the right of the window.
3.

In the Ornaments panel, click the arpeggio sign you want in the Arpeggiation section.

RESULT
The arpeggio sign specified is input to the left of the selected note or chord. Its length is adjusted
automatically so that it spans the range of all notes on the staff at that rhythmic position.
RELATED LINKS
Arpeggio signs on page 591
Input methods for ornaments, arpeggio signs, and glissando lines on page 185
Mouse input settings on page 108

Inputting glissando lines with the popover
You can input glissando lines between existing notes using the ornaments popover. You can
input glissando lines between both adjacent/non-adjacent notes.
NOTE
You cannot input glissando lines during step input.
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PROCEDURE
1.

In Write mode, select one of the following:
●

The note from which you want a glissando line to start.

●

Any two notes that you want to join with a glissando line.
TIP
The two notes can be in different voices.

2.

3.

4.

Open the ornaments popover in any of the following ways:
●

Press Shift-O.

●

Choose Write > Create Ornament.

Enter the appropriate short-hand for the glissando line you want into the popover.
●

Enter gliss for a straight glissando line.

●

Enter glisswavy for a wavy glissando line.

Press Return to close the popover.

RESULT
If you selected two notes, the glissando line specified is input between the selected notes.
If you selected a single note, the glissando line specified starts from the selected note and ends
at the next note on the staff, even if this crosses rests.
NOTE
You cannot input a glissando line on the last note on a staff.
NOTE
Glissando lines do not automatically adjust around any notes or rests between the selected
notes. If glissando text is shown, the text can collide with notes or rests, in which case we
recommend that you make further adjustments, such as not showing glissando text for that
glissando line.

RELATED LINKS
Ornaments popover on page 186
Input methods for ornaments, arpeggio signs, and glissando lines on page 185
Glissando lines on page 600
Changing glissando line text on page 602
Changing when glissando line text is shown on page 602

Inputting glissando lines with the panel
You can input glissando lines between existing notes using the Ornaments panel. You can input
glissando lines between both adjacent/non-adjacent notes.
NOTE
●

These steps describe inputting with the default mouse input preference of Create item at
selection.
If your preference is set to Load cursor with item, you can only input glissando lines
between the note you click on and the note immediately following it.

●

You cannot input glissando lines during step input.
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PROCEDURE
1.

In Write mode, select one of the following:
●

The note from which you want a glissando line to start.

●

Any two notes that you want to join with a glissando line.
TIP
The two notes can be in different voices.

2.

In the Notations toolbox, click Ornaments.

The Ornaments panel opens on the right of the window.
3.

In the Ornaments panel, click the style of glissando line you want.
●

Glissando (Straight)

●

Glissando (Wavy)

RESULT
If you selected two notes, the glissando line specified is input between the selected notes.
If you selected a single note, the glissando line specified starts from the selected note and ends
at the next note on the staff, even if this crosses rests.
NOTE
●

You cannot input a glissando line on the last note on a staff.

●

Glissando lines do not automatically adjust around any notes or rests between the
selected notes. If glissando text is shown, the text can collide with notes or rests, in which
case we recommend that you make further adjustments, such as not showing glissando
text for that glissando line.

RELATED LINKS
Glissando lines on page 600
Input methods for ornaments, arpeggio signs, and glissando lines on page 185
Mouse input settings on page 108

Input methods for pedal lines, retakes, and pedal level changes
You can input pedal lines, retakes, and pedal level changes with the keyboard by using the same
popover as for playing techniques, as both affect the sound that the instrument produces, and
with the mouse by using the Playing Techniques panel.

Inputting pedal lines with the popover
You can input pedal lines with the keyboard by entering the pedal line you want into the playing
techniques popover.
You can open the playing techniques popover in Write mode in any of the following ways:
●

Press Shift-P.

●

Choose Write > Create Playing Technique.
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The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Playing techniques popover with an example entry

Playing Techniques button in the Notations toolbox

Inputting pedal lines with the panel
Pedal lines are located in the Keyboard section of the Playing Techniques panel on the right of
the window in Write mode. You can input pedal lines with the mouse on existing notes or existing
staves, but not during step input.
You can open the Playing Techniques panel by clicking Playing Techniques in the Notations
toolbox.

Click the Keyboard disclosure arrow to show options for pedal lines.

The most common options for pedal lines

The buttons in the first row create new pedal lines. The buttons in the second row add retakes
and changes of pedal level to an existing pedal line. Further options in the Keyboard section
allow you to input other keyboard playing techniques.
You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

RELATED LINKS
Pedal lines on page 613
Sustain pedal retakes and pedal level changes on page 614
Playing techniques popover for pedal lines on page 193
Inputting pedal lines, retakes, and pedal level changes with the popover on page 194
Inputting pedal lines, retakes, and pedal level changes with the panel on page 195
Adding retakes and pedal level changes to existing pedal lines with the popover on page 616
Adding retakes and pedal level changes to existing pedal lines with the panel on page 617
Lengthening/Shortening pedal lines on page 624

Playing techniques popover for pedal lines
You can enter the following commands and symbols into the playing techniques popover to
create the different pedal lines available.
You can open the playing techniques popover in Write mode in any of the following ways:
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●

Press Shift-P.

●

Choose Write > Create Playing Technique.

Type of pedal line, retake, or pedal level
change

Popover entry

Sustain pedal line

ped

Set sustain pedal level to 1/4

1/4

Set sustain pedal level to 1/2

1/2

Set sustain pedal level to 3/4

3/4

Fully depress sustain pedal

1

Retake in sustain pedal line

^, notch, or retake

Remove retake in sustain pedal line

nonotch

Stop sustain pedal line

*

Sostenuto pedal line

sost

Stop sostenuto pedal line

s*

Una corda pedal line

unacorda

Stop una corda pedal line

u*

RELATED LINKS
Inputting pedal lines, retakes, and pedal level changes with the popover on page 194
Adding retakes and pedal level changes to existing pedal lines with the popover on page 616
Pedal lines on page 613
Sustain pedal retakes and pedal level changes on page 614

Inputting pedal lines, retakes, and pedal level changes with the popover
You can input pedal lines using the playing techniques popover, both during step input and by
adding them to existing music. Because the pedal line extends automatically as you input notes
during step input, you can input retakes and pedal level changes when you reach the appropriate
rhythmic position.
TIP
You can also input retakes and pedal level changes at rhythmic positions before you input pedal
lines or notes. They are shown when the pedal line passes their rhythmic position.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select the notes to which you want the pedal line to apply.
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2.

3.

Open the playing techniques popover in any of the following ways:
●

Press Shift-P.

●

Choose Write > Create Playing Technique.

Enter the appropriate short-hand for the pedal line you want into the popover.
For example, enter ped for a sustain pedal line.

4.

Press Return to close the popover.
The pedal line is input.

5.

Optional: During step input, extend the pedal line by pressing Space to advance the caret.
The pedal line also extends automatically as you continue inputting notes.

6.

Optional: During step input, input retakes or pedal level changes by opening the playing
techniques popover again when the caret is at the rhythmic position you want and enter
the appropriate short-hand for the retake or pedal level change you want into the
popover.
For example, enter ^ or retake for a retake.

7.

Optional: During step input, stop the pedal line by opening the playing techniques
popover again and enter the appropriate short-hand into the popover.
For example, enter * to stop a sustain pedal line.

8.

Press Return to close the popover.

RESULT
During step input, pedal lines start at the caret position, and end at the caret position.
When you add pedal lines to existing notes, pedal lines are added across the selected notes.
RELATED LINKS
Playing techniques popover for pedal lines on page 193
Pedal lines on page 613
Sustain pedal retakes and pedal level changes on page 614
Inputting notes on page 115
Adding retakes and pedal level changes to existing pedal lines with the popover on page 616
Positions of pedal lines on page 621

Inputting pedal lines, retakes, and pedal level changes with the panel
You can input pedal lines, retakes, and pedal level changes using the Playing Techniques panel.
NOTE
●

When using the panel, you cannot input pedal lines, retakes, or pedal level changes during
step input.

●

These steps describe inputting with the default mouse input preference of Create item at
selection.

PROCEDURE
1.

In Write mode, select the notes to which you want the pedal line to apply.

2.

In the Notations toolbox, click Playing Techniques.

The Playing Techniques panel opens on the right of the window.
3.

In the Playing Techniques panel, click the pedal line you want in the Keyboard section.
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NOTE
Alternatively, with nothing selected, click the pedal line you want in the Keyboard section
of the Playing Techniques panel, then click and drag in the score to create a pedal line and
extend it to the duration you want.
4.

Optional: Select an item at the rhythmic position where you want to input a retake or pedal
level change.

5.

Optional: In the Playing Techniques panel, click the retake or pedal level change you want
in the Keyboard section.

RELATED LINKS
Pedal lines on page 613
Sustain pedal retakes and pedal level changes on page 614
Input methods for pedal lines, retakes, and pedal level changes on page 192
Adding retakes and pedal level changes to existing pedal lines with the panel on page 617
Mouse input settings on page 108

Input methods for playing techniques
You can input playing techniques with the keyboard by using the playing techniques popover,
and with the mouse by using the Playing Techniques panel.

Inputting playing techniques with the popover
You can input playing techniques with the keyboard by entering the playing technique you want
into the playing techniques popover.
When you start entering a playing technique into the playing techniques popover, a menu
appears that shows valid playing techniques containing the letters or words you enter. You can
choose one of these playing techniques to input.
You can open the playing techniques popover in Write mode in any of the following ways:
●

Press Shift-P.

●

Choose Write > Create Playing Technique.

You can do this based either on the range of selected notes, or during step input.
The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Playing Techniques button in the Notations toolbox
Playing techniques popover with an example entry

Inputting playing techniques with the panel
Playing techniques for all instruments can be found in the Playing Techniques panel on the right
of the window in Write mode.
You can open the Playing Techniques panel by clicking Playing Techniques in the Notations
toolbox on the right of the window in Write mode.
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Each section in the Playing Techniques panel contains playing technique texts and playing
technique symbols appropriate for that instrument family. The Playing Techniques panel
contains the following sections:
●

Common

●

Wind

●

Brass

●

Unpitched Percussion

●

Pitched Percussion

●

Keyboard

●

Choral

●

Strings

●

Other

TIP
You can hover your mouse pointer over each option to show the name of each playing technique.
You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

RELATED LINKS
Playing techniques on page 633
Playing techniques popover on page 197
Inputting playing techniques with the popover on page 199
Inputting playing techniques with the panel on page 200

Playing techniques popover
The table shows some examples of what to enter into the playing techniques popover, and the
playing techniques that are input into the music as a result.
When you start entering a playing technique into the playing techniques popover, a menu
appears that shows valid playing techniques containing the letters or words you enter. You can
choose one of these playing techniques to input.
You can open the playing techniques popover in Write mode in any of the following ways:
●

Press Shift-P.

●

Choose Write > Create Playing Technique.

Playing technique

Popover entry

Vibrato

vibrato

Senza vibrato

senza vibrato

Naturale (nat.)

nat

Con sordino

con sord
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Playing technique

Popover entry

Strong air pressure

strong air pressure

Double-tongue

double-tongue

Down bow

downbow

Up bow

upbow

Sul ponticello

sul pont

Sul tasto

sul tasto

Poco sul tasto

pst

Pizzicato

pizz

Spiccato

spicc

Arco

arco

Tongue click (Stockhausen)

tongue click

Finger click (Stockhausen)

finger click

Vibraphone motor on

motor on

Vibraphone motor off

motor off

Open

open

Damp

damp

Damp (large)

damp large

Full barré

full barre

Half barré

half barre

Strum up

strum up

Strum down

strum down

Left hand

lh

Right hand

rh

This list is not comprehensive as there are many valid playing techniques. It is intended to
illustrate how you can structure your entry to input different types of common playing
techniques.
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If you do not know the correct entry for a playing technique, start entering part of the playing
technique and see if becomes available in the popover menu.
NOTE
As playing techniques correspond to specific samples, they must be input as described or
selected from the popover menu.

RELATED LINKS
Inputting playing techniques with the popover on page 199
Playing techniques on page 633

Inputting playing techniques with the popover
You can input playing techniques using the playing techniques popover, both during step input
and by adding them to existing notes.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing note to which you want to add a playing technique.
NOTE
You can only add playing techniques to one note at a time.

2.

3.

Open the playing techniques popover in any of the following ways:
●

Press Shift-P.

●

Choose Write > Create Playing Technique.

Enter the appropriate short-hand for the playing technique you want into the popover.
For example, non vibrato or tongue click.
When you start entering a playing technique into the playing techniques popover, a menu
appears that shows valid playing techniques containing the letters or words you enter,
which you can select.

4.

Press Return to close the popover.

RESULT
The playing technique is added to the selected note.
During step input, playing techniques are input at the caret position.
RELATED LINKS
Playing techniques popover on page 197
Playing techniques on page 633
Input methods for playing techniques on page 196
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Inputting playing techniques with the panel
You can input playing techniques using the Playing Techniques panel, both during step input and
by adding them to existing notes.
NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.
If you want to add the same playing technique to multiple notes, activate Allow multiple items
to be created with the mouse in the Editing section of the General page in Preferences, so
that you do not have to reselect the playing technique for each note.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing note to which you want to add a playing technique.
NOTE
You can only add playing techniques to one note at a time.

2.

In the Notations toolbox, click Playing Techniques.

The Playing Techniques panel opens on the right of the window.
3.

In the Playing Techniques panel, click the playing technique you want.

RESULT
The playing technique selected is added to the selected note.
During step input, playing techniques are input at the caret position, even if your preference is
set to Load cursor with item.
RELATED LINKS
Playing techniques on page 633
Input methods for playing techniques on page 196
Mouse input settings on page 108

Inputting lyrics
You can input lyrics by entering text into the lyrics popover, and you can advance the lyrics
popover to the next note on the staff without closing and reopening it for every note.
PROCEDURE
1.

In Write mode, select the first note to which you want to input lyrics.

2.

Open the lyrics popover in any of the following ways:
●

Press Shift-L.

●

Choose Write > Create Lyrics.

●

Click Lyrics in the Notations toolbox.

By default, the lyrics popover opens with lyric line input selected.
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3.

4.

Optional: Change the type of lyric in one of the following ways:
●

Press Down Arrow to change the lyric line number.

●

Press Shift-Up Arrow to input lyrics above the staff.

●

Press Up Arrow to input chorus lines.

●

Press Alt-Down Arrow to input lyric line translations.

Enter the word or syllable you want to add to the selected note into the popover.
●

5.

Press Shift-Alt-Space to enter multiple words on a single note.

●

Press Alt-- (hyphen) to include a hyphen within a single word or syllable.

●

Press _ (underscore) to include an elision in a lyric.

Advance the popover to the next note in one of the following ways:
●

Press Space if you entered a complete word, or the final syllable in a multi-syllabic
word.

●

Press - (hyphen) if you entered one syllable of a multi-syllabic word that is not the
final syllable.

●

Press Right Arrow if you do not want the syllable to be followed by an extension
line or hyphen.

6.

Continue entering words and syllables into the popover for the rest of the notes to which
you want to add lyrics.

7.

Press Return or Esc to close the popover.
NOTE
The popover closes automatically when you reach the last note on the staff.

RESULT
The text you entered into the popover is input as lyrics of the type indicated by the icon on the
left-hand side of the popover.
If you advanced the popover to the next note by pressing -, a hyphen appears after the last
entered lyric. This is used for multi-syllabic words across multiple notes.
If you advance the popover by pressing Space, a gap appears after the last entered lyric. This is
used for single-syllable words or for the final syllable in multi-syllabic words.
NOTE
You can later change whether a gap or a hyphen appears between lyrics by changing their
syllable type.

RELATED LINKS
Lyrics popover on page 202
Lyrics on page 552
Navigation during lyric input on page 203
Types of lyrics on page 554
Types of syllables in lyrics on page 555
Lyric line numbers on page 563
Changing the syllable type of existing lyrics on page 556
Lyric hyphens and lyric extender lines on page 560
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Lyrics popover
You input lyrics, including chorus lines and lyric line translations, using the lyrics popover. You
can use key commands to change the type of lyric being input at any time.
You can open the lyrics popover in Write mode in any of the following ways:
●

Press Shift-L.

●

Choose Write > Create Lyrics.

●

Click Lyrics in the Notations toolbox.

Lyric lines
The popover automatically opens ready to input lyrics into Line 1, except if you are
changing an existing lyric.
The number shown on the left-hand side of the lyrics popover indicates the lyric line
into which the lyric is input.

The lyrics popover with an example entry for Line 1

You can change the lyric line number by pressing Down Arrow when the lyrics
popover is open.

The lyrics popover with an example entry for Line 2

Lyric lines above the staff
You can input lyrics into lines above the staff by pressing Shift-Up Arrow when the
lyrics popover is open.
You can then press Up Arrow and Down Arrow to change the lyric line number
above the staff.
Chorus lines
You can input chorus lines by pressing Up Arrow when the lyrics popover is open.
You can do this when inputting lyrics below the staff and above the staff.
A c, for “chorus lines”, is shown on the left-hand side of the popover.

The lyrics popover with an example entry for a chorus line

Lyric line translations
You can input lyric line translations by pressing Alt-Down Arrow when the lyrics
popover is open.
An asterisk (*) is shown beside the lyric line number to which you want to add a lyric
line translation on the left-hand side of the popover.

The lyrics popover with an example entry for a lyric line translation

RELATED LINKS
Inputting lyrics on page 200
Lyrics on page 552
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Navigation during lyric input
You can move the lyrics popover to input new lyrics and edit existing lyrics without having to
close and reopen the lyrics popover.
Popover navigation

Key command

Finish the current word and advance the
popover to the next note or chord.

Space

Finish the current syllable and advance the
popover to the next note or chord.

- (hyphen)

Advance the popover to the next note without
showing an extension line or hyphen.

Right Arrow

Move the cursor to the next/previous letter. If
the next/previous letter is in another lyric, the
popover moves to that lyric.

Right Arrow/Left Arrow

Move the popover forwards/backwards from
syllable to syllable within lines of lyrics.

Alt-Right Arrow/Alt-Left Arrow

Add spaces within a word or syllable, without
advancing the popover.

Shift-Alt-Space

Add a hyphen within a single word or syllable,
without advancing the popover.

Alt-- (hyphen)

Add an elision slur within a word or syllable.

_ (underscore)

RELATED LINKS
Lyrics on page 552
Inputting lyrics on page 200

Inputting rehearsal marks
You can input rehearsal marks with the mouse and the keyboard. You can input rehearsal marks
during step input and later by adding them to existing music.
NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select an item at the rhythmic position where you want to input a rehearsal mark.
For example, a barline or a note.
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NOTE
You can only input one rehearsal mark at a time, even if multiple items are selected.
2.

Input a rehearsal mark in any of the following ways:
●

Press Shift-A.

●

Choose Write > Create Rehearsal Mark.

●

Click Rehearsal Marks in the Notations toolbox.

RESULT
A rehearsal mark is input at the selected barline, or at the rhythmic position of the start of a note,
a rest, or an object.
The order of rehearsal marks is updated automatically, meaning you can input them in any
order, including before and between existing rehearsal marks.
RELATED LINKS
Rehearsal marks on page 639
General Preferences on page 53

Inputting repeat endings
You can input repeat endings using the Repeat Structures panel. There is no popover for repeat
endings.
You can open the Repeat Structures panel by clicking Repeat Structures in the Notations
toolbox.

PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
TIP
During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow/Left Arrow.

●

Select the bars that you want to include in the first ending.

TIP
You only need to select a single note or rest in each bar to include those bars in the first
ending.
2.

In the Repeat Structures panel, click Create Repeat Ending in the Repeat Endings section.

RESULT
The repeat ending is input, with the first ending segment covering the bars in which you selected
notes, and a second ending segment created automatically in the following bar.
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An end repeat barline is created at the end of the first ending if none exists already.
RELATED LINKS
Repeat endings on page 648
Repeat Structures panel on page 207
Adding additional repeat endings on page 205

Adding additional repeat endings
You can have more than two possible endings in each repeat ending structure by adding repeats.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.
TIP
During note input, you can select additional notes before/after the last input note
without deactivating the caret by pressing Shift-Right Arrow/Left Arrow.

●

Select the bars that you want to include in the additional ending.

NOTE
Your selection must start from the first bar following the previous repeat ending segment.
2.

In the Repeat Structures panel, click Add Section To Repeat Ending in the Repeat
Endings section.

NOTE
If increasing the number of endings makes the repeat ending collide with any part of
another repeat ending, the other repeat ending is deleted. However, its repeat barlines are
not deleted.
3.

Optional: Repeat as many times as required for the number of additional endings you
want.

RESULT
A new repeat ending segment is added. The existing previous repeat ending segment now ends
with a closed line, with an end repeat barline created if necessary.
TIP
You can also add additional repeat ending segments by selecting the repeat ending and
changing the value for No. endings in the Repeat Endings group of the Properties panel.
However, No. endings only adds additional repeat ending segments that contain one bar, and
does not automatically input or reposition repeat barlines. You must input repeat barlines as
appropriate manually.
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EXAMPLE

Default repeat ending structure with two endings

Repeat ending structure with additional third ending

RELATED LINKS
Repeat endings on page 648
Repeat Structures panel on page 207

Inputting single-note tremolos
You can input single-note tremolos that indicate a single note is repeated.
PROCEDURE
1.

In Write mode, select the notes on which you want to input single-note tremolos.

2.

Click the button with the number of single-note tremolo strokes you want in the Tremolos
section of the Repeat Structures panel.
For example, click Two Strokes Single-note Tremolo to input single-note tremolos with
two strokes.

RESULT
Single-note tremolos are input on the selected notes with the number of tremolo strokes
specified.
RELATED LINKS
Tremolos on page 763
Repeat Structures panel on page 207
Deleting tremolos on page 766

Inputting multi-note tremolos
You can input multi-note tremolos that indicate notes are repeated in a pattern similar to a trill.
You can also input multi-note tremolos across more than two notes if they are tuplets, which
indicates that the notes in the tuplet are repeated in the notated sequence.
PROCEDURE
1.

In Write mode, select one of the following:
●

Pairs of adjacent notes between which you want to input multi-note tremolos

●

Individual notes on which you want to input multi-note tremolos
NOTE
You cannot input multi-note tremolos on notes that are not immediately followed by
another note.

●

Tuplets across which you want to input multi-note tremolos
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TIP
You can select whole tuplets, including their brackets, or just the noteheads in the
tuplets.
2.

Click the button with the number of multi-note tremolo strokes you want in the Tremolos
section of the Repeat Structures panel.
For example, click Three Strokes Multi-note Tremolo to input multi-note tremolos with
three strokes.

RESULT
Multi-note tremolos with the number of tremolo strokes specified are input between selected
individual notes and the notes immediately after them, or between selected pairs of notes.
When tuplets are selected, multi-note tremolos are input across the selected tuplets, with the
tremolo strokes positioned in the center of all notes in the tuplet. The tuplet bracket is hidden,
and a signpost is shown at the start of each tuplet indicating its ratio.
NOTE
The appearance of stems in multi-note half note tremolos depends on your setting on the
Tremolos page in Engrave > Engraving Options.
EXAMPLE

Multi-note tremolos with three tremolo strokes across tuplets

RELATED LINKS
Tremolos on page 763
Repeat Structures panel on page 207
Deleting tremolos on page 766
Changing the appearance of multi-note half note tremolos project-wide on page 769

Repeat Structures panel
The Repeat Structures panel allows you to input repeat endings and tremolos. Tremolos are
included in the Repeat Structures panel because they indicate that notes are repeated, either
individually as single-note tremolos or in sequences as multi-note tremolos.
NOTE
You cannot input tremolos with the keyboard.
You can open the Repeat Structures panel in Write mode by clicking Repeat Structures in the
Notations toolbox on the right of the window.

RELATED LINKS
Tremolos on page 763
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Inputting single-note tremolos on page 206
Inputting multi-note tremolos on page 206

Inputting slurs
You can input slurs, both directly during step input and later on. When adding slurs later to
existing notes, you can add slurs to notes in multiple staves at the same time.
PROCEDURE
1.

In Write mode, do one of the following:
●

Start note input.

●

Select the notes to which you want to add slurs.
TIP
You can select notes in multiple staves and input slurs on them at the same time.

If you only select a single note, the slur connects that note to the next note on the staff.
2.

Input a slur in any of the following ways:
●

Press S.

●

Click Slur in the Notes panel.

TIP
Alternatively, click Slur in the Notes panel first, and then click and drag to input a
slur and extend it to your preferred length.
3.

Optional: During step input, input the notes you want.
The slur extends automatically, even if there are rests between the notes you input.

4.

Optional: During step input, press Shift-S to end the slur on the currently selected note.

RESULT
During step input, a slur begins from the currently selected note, not from the caret position. The
slur extends automatically as you input notes, and ends on the currently selected note.
When adding slurs to existing notes, the selected notes are connected by slurs. For example, if
you select two notes in one staff and two notes in another staff, two slurs are input. They connect
the notes on each selected staff.
RELATED LINKS
Slurs on page 663
Inputting notes on page 115

Input methods for tempo marks
You can input tempo marks with the keyboard by using the tempo popover, and with the mouse
by using the Tempo panel. You can input a tempo mark containing just a text instruction,
metronome mark, or a combination of the two.

Inputting tempo marks with the popover
You can input tempo marks with the keyboard by entering the tempo mark you want into the
tempo popover.
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When you start entering a tempo into the tempo popover, a menu appears that shows
suggested tempos containing the letters or words you enter. You can choose one of these
suggestions to input, or enter your own tempo into the popover.
You can open the tempo popover in Write mode in any of the following ways:
●

Press Shift-T.

●

Choose Write > Create Tempo.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

Tempo button in the Notations toolbox
Tempo popover with an example entry

Inputting tempo marks with the panel
You can input tempo marks with the mouse by using the Tempo panel on the right of the window
in Write mode.
You can open the Tempo panel by clicking Tempo in the Notations toolbox on the right of the
window in Write mode.

NOTE
The order in which you should follow steps for inputting tempo marks with the mouse depends
on your preferences for the Creating items with the mouse option in the Editing section of the
General page in Preferences.
You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

RELATED LINKS
Tempo marks on page 719
Tempo popover on page 209
Tempo panel on page 210
Inputting tempo marks with the popover on page 212
Inputting tempo marks with the panel on page 213
Preferences on page 53

Tempo popover
The table shows examples of what to enter into the tempo popover, and the tempo marks that
are input into the music as a result.
When you start entering a tempo into the tempo popover, a menu appears that shows
suggested tempos containing the letters or words you enter. You can choose one of these
suggestions to input, or enter your own tempo into the popover.
You can open the tempo popover in Write mode in any of the following ways:
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●

Press Shift-T.

●

Choose Write > Create Tempo.

Example tempo mark

Popover entry

Adagio

Adagio

Presto  = 176

Presto q = 176 or Presto q=176

Largo ( = 52)

Largo (q = 52) or Largo (q=52)

 = 96-112

q = 96-112, q=96-112, 6 = 96-112, or 6=96-112

 = 84

q. = 84, q.=84, 6. = 84, or 6.=84

 = 60

h = 60, h=60, 7 = 60, or 7=60

 = 120

e = 120, e=120, 5 = 120, or 5=120

 = 90

e. = 90, e.=90, 5. = 90, or 5.=90

 = 240

4=240 or 4 = 240

rit.

rit. or rit

accel.

accel. or accel

più

più or piu

meno

meno

Faster, with energy

Faster, with energy

This list is not comprehensive as you can enter tempos freely. It is intended to illustrate how you
can structure your entry to input different types of tempo marks and metronome marks.
NOTE
The tempo popover is case-sensitive. If you want your tempo mark to start with a capital letter,
you must enter a capital letter into the popover.

RELATED LINKS
Inputting tempo marks with the popover on page 212
Tempo marks on page 719
Types of tempo marks on page 719

Tempo panel
You can find all the different types of tempo marks organized into sections in the Tempo panel in
Write mode.
Used in This Flow
Contains any tempo marks already used in the flow, including custom tempo marks
added using the tempo popover.
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Absolute Tempo Change
Contains a range of tempos, with both an Italian tempo indication and a metronome
mark. You can later choose to show or hide the metronome mark for individual
tempo marks.
You can narrow the range shown in the list by adjusting the sliding bar at the top.

Gradual Tempo Change
Contains tempo marks that indicate a change in tempo over a defined period of time,
such as rallentando or accelerando.
You can add modifiers to gradual tempo changes. Available modifiers are shown at
the top of the section in boxes.

Relative Tempo Change
Contains tempo marks that indicate a change in tempo that is relative to the
previous tempo, such as mosso (movement, or “with movement”). They often include
modifiers that qualify the change, such as poco meno mosso (a little less movement),
and are not defined by a metronome mark.
You can add modifiers to relative tempo changes. Available modifiers are shown at
the top of the section in boxes.
You can later set a relative metronome mark change as a percentage of the previous
metronome mark for individual tempo marks.

Reset Tempo
Contains tempo marks that indicate a return to the previous tempo, such as A tempo,
or a previously defined tempo, such as Tempo primo.
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RELATED LINKS
Tempo marks on page 719
Types of tempo marks on page 719

Inputting tempo marks with the popover
You can input tempo marks using the tempo popover, both during step input and by adding
them to existing music.
PROCEDURE
1.

2.

3.

In Write mode, do one of the following:
●

Start note input.

●

Select a barline, notehead, or rest at the rhythmic position where you want to add a
tempo mark.

●

Select multiple items that span the duration across which you want to add a gradual
tempo change.

Open the tempo popover in any of the following ways:
●

Press Shift-T.

●

Choose Write > Create Tempo.

Enter the tempo you want into the popover.
For example, q=72 or Allegretto.
When you start entering a tempo into the tempo popover, a menu appears that shows
suggested tempos containing the letters or words you enter. You can select one of these
suggestions or you can enter your own tempo into the popover.

4.

Press Return to close the popover.

RESULT
During step input, tempo marks are input at the caret position. Gradual tempo changes, such as
rallentando, are also input at the caret position with a default duration of a quarter note. Gradual
tempo changes do not extend as you input notes.
When adding tempo marks to existing music, they are added at the rhythmic position of the
selected barline, notehead, or rest. Gradual tempo changes span the duration of the selected
items.
TIP
You can lengthen/shorten gradual tempo changes later.

RELATED LINKS
Tempo popover on page 209
Tempo marks on page 719
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Input methods for tempo marks on page 208
Lengthening/Shortening gradual tempo changes on page 725

Inputting tempo marks with the panel
You can input tempo marks using the Tempo panel, both during step input and by adding them
to existing music.
NOTE
These steps describe inputting with the default mouse input preference of Create item at
selection.

PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select a barline, notehead, or rest at the rhythmic position where you want to add a
tempo mark.

●

Select multiple items that span the duration across which you want to add a gradual
tempo change.

In the Notations toolbox, click Tempo.

The Tempo panel opens on the right of the window.
3.

In the Tempo panel, click the tempo mark you want.

4.

Optional: Select a modifier from the available options.
NOTE
You can only add modifiers to a Gradual Tempo Change or a Relative Tempo Change.

RESULT
During step input, tempo marks are input at the caret position. Gradual tempo changes, such as
rallentando, are also input at the caret position but do not extend as you input notes, and are
input with a default duration of a quarter note.
When adding tempo marks to existing music, they are added at the rhythmic position of the
selected barline, notehead, or rest. Gradual tempo changes span the duration of the selected
items.
TIP
You can lengthen/shorten gradual tempo changes later.

RELATED LINKS
Tempo marks on page 719
Input methods for tempo marks on page 208
Lengthening/Shortening gradual tempo changes on page 725
Mouse input settings on page 108
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Inputting text
You can input text at specific rhythmic positions in the score. You can input text for single staves
or input system text that applies to all staves.
NOTE
If you want to insert text that is independent of rhythmic positions and attached to a particular
page, you can use text frames.

PROCEDURE
1.

2.

Select the position where you want to input text in any of the following ways:
●

Activate the caret and move it to the position where you want to add text.

●

Select a note or notation to determine a position.

Open the text editor in any of the following ways:
●

Press Shift-X to add staff text.

●

Press Shift-Alt-X to add system text.

●

Choose Write > Create Text to add staff text.

●

Click Text to add staff text.

3.

Enter the text you want.

4.

Optional: Press Return to insert a line break.

5.

Optional: Format the text using the text editor options.

6.

Close the text editor in any of the following ways:
●

Press Esc or Ctrl/Cmd-Return.

●

Click outside of the text editor.

RESULT
The text you entered into the text editor is input into the score. It is automatically placed above
the staves to which it applies, using the default paragraph style, and two and a half spaces from
the outside of the staves.
In Dorico, system text is categorized as a system object. Therefore, system text follows your perlayout settings for the visibility and positioning of system objects, which you can change on the
Staves and Systems page in Setup > Layout Options.
RELATED LINKS
Text editor options in Write mode on page 214
Text frames on page 254
Changing the placement of text relative to the staff on page 283
System objects on page 707
Changing the positions of system objects on page 708

Text editor options in Write mode
The text editor allows you to add and format text.
The text editor opens in the following circumstances:
●

You add or change text that is attached to a staff.

●

You enter text within a text frame.
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Text editor pop-up in Write mode

The text editor provides the following options:
1

Paragraph Style
Determines the appearance and alignment of the text for a whole paragraph.
NOTE
Text that is attached to a staff is always treated as a single paragraph.

2

Character Style
Determines the appearance of selected text.
NOTE
If you use one of the defined character styles in the text editor, the appearance that is
defined by the selected paragraph style is overridden.

3

Font
Allows you to change the font family of selected text.

4

Font Style
Allows you to change the font style of selected text.

5

Font Size
Allows you to change the size of selected text.

6

Font Stretch
Allows you to make selected text wider or narrower.

7

Baseline Shift
Allows you to gradually shift the baseline of selected text up or down.

8

Letter Spacing
Allows you to increase/decrease the space between the characters of selected text.

9

Word Spacing
Allows you to increase/decrease the space between the words of selected text.

10

Foreground Color
Allows you to change the foreground color of selected text.

11

Background Color
Allows you to change the background color of selected text.

12

Alignment
Allows you to choose the alignment of selected text relative to the rhythmic position of the
text in the score. For text in a text frame, the text is aligned along the left margin of a text
frame.
You can choose from the following alignments:
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13

●

Alignment Left

●

Alignment Center

●

Alignment Right

Line Types
Allows you to show any of the following types of lines, in any combination, on selected
text:

14

●

Underline

●

Overline

●

Strikethrough

Script Types
Allows you to position selected text in one of the following positions relative to the text on
the baseline:
●

Superscript

●

Subscript

RELATED LINKS
Inputting text on page 214
Entering text in text frames on page 258
Paragraph Styles dialog on page 276
Character Styles dialog on page 279

Inputting cues
You can input cues by using the cues popover.
When you start entering the name of an instrument that exists in your project into the cues
popover, a menu appears that shows candidate instruments that you can choose to show in the
cue, excluding the destination instrument.
NOTE
The cues popover uses the names of instruments as they are set in your project and language.
Each staff of grand staff instruments is listed separately, for example, Piano (a) and Piano (b).
Each unpitched percussion instrument is listed separately. If you have a drum set in your project,
each individual instrument in the drum set appears as a candidate for cueing. For example, you
can show just the kick drum in a cue.

The cues popover with an example entry showing the menu of candidate instruments.

NOTE
●

You cannot use entire percussion kits in cues.

●

If you directly input a cue at the same position as an existing cue, the new cue overrides
the existing cue, which is deleted. However, you can have multiple cues at the same
rhythmic positions if you create them in separate bars and move them or lengthen/
shorten them later.
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PROCEDURE
1.

In Write mode, select one of the following on the staff in which you want the cue to
appear:
●

A note or rest at the position you want the cue to start.

●

Multiple notes or rests spanning the duration you want the cue to last.

TIP
You can lengthen/shorten cues after they have been input.
2.

3.

Open the cues popover in any of the following ways:
●

Press Shift-U.

●

Choose Write > Create Cue.

●

Click Insert Cue in the Cues panel.

Enter the first few letters of the instrument whose music you want to show in the cue.
The candidate instrument menu appears below the popover and shows possible candidate
instruments.

4.

Select the instrument whose music you want to show in the cue in any of the following
ways:
●

Press Up Arrow/Down Arrow to highlight it in the candidate instrument menu, then
press Return.

●

Click it in the candidate instrument menu.

●

Enter the full name of the instrument into the cues popover, then press Return
twice.
NOTE
If you do not enter the name of an instrument that exists in your project, no cue is
created.
If multiple instruments of the same type exist in your project, music from the first
player is input as the cue. For example, if you have Violin I and Violin II in your
project and enter violin into the cues popover, music from the Violin I staff is shown
in the cue.

RESULT
A cue is input in the selected staff, showing the music of the instrument selected in the cues
popover.
If you are inputting cues in a full score layout in page view, the cue appears as a signpost by
default, showing the name of the source instrument.
NOTE
You can choose to show cues in full score layouts. You can also see the music in the cue in the
corresponding part layout, as cues are shown in part layouts by default.

RELATED LINKS
Cues on page 457
Hiding/Showing cues in layouts on page 469
Cue suggestions on page 218
Inputting cues using cue suggestions on page 220
Lengthening/Shortening cues on page 462
Moving cues on page 461
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Switching between layouts on page 94

Cues panel
The Cues panel allows you to input cues and find suitable places to input cues.
You can open the Cues panel by clicking Cues in the Notations toolbox in Write mode.

There are two sections in the Cues panel:
Insert Cue
Contains the Insert Cue button which you can click to open the cues popover with
the mouse.
Suggest Cues
Allows you to generate suggestions for cues based on how long players have been
resting.
You can hide/show the panel whose icon is currently selected in the Notations toolbox in any of
the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

●

Choose Window > Show Right Panel.

RELATED LINKS
Cues on page 457
Cue suggestions on page 218

Cue suggestions
The Suggest Cues section of the Cues panel helps you determine useful locations for cues in
your project. Dorico identifies places in the current flow where players in the current layout have
not played for a set span of time.
The Suggest Cues section of the Cues panel is divided into the following sections that help you
find useful places to input cues:
Resting for
Allows you to specify the resting period for players after which you want to input
cues.
The resting period is specified in absolute time rather than in bars or beats. This is
because meters and tempos can change many times throughout a flow, and music
can be partially or completely meterless, whereas one second always has the same
duration. Dorico calculates time using metronome marks in the project.
Specifying an absolute time ensures consistency in the approach to finding places
where cues might be appropriate.
Rehearsal marks
Allows you to consider/ignore rehearsal marks when determining the resting period.
Rehearsal marks often coincide with new sections or other landmarks in the music,
which can be obvious to players without needing extra cues. By default, rehearsal
marks are ignored as they do not always act as signposts for the musical structure.
Cues
Allows you to consider/ignore cues that already exist between notes played by the
destination player when determining the resting period.
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A cue that occurs immediately before an entry in the destination instrument is
always ignored and is never included as a suggested location, even if you choose to
consider cues.
However, orientation cues which serve to help the player keep their place during
extended rests, but do not immediately precede an entry, reset the timer if you
choose to consider cues.
Update
Allows you to recalculate cue suggestions based on your Resting for duration and
inclusion choices for rehearsal marks and cues after you have changed values.
The names of the flow and layout that were active when you last updated the list of
cue suggestions are shown below the Update button. This allows you to see at a
glance to which flow and layout the suggestions shown in the table apply.
Cue suggestions table
The list of suggested cues is presented in a table. The table contains the following
columns:
●

Instr.: the destination instrument that has been resting for more than your
minimum specified duration

●

Bar: the bar containing the first entry of the destination instrument after its
rest period

●

Sec.: the length of time in seconds the destination instrument has been
resting before the entry shown in the Bar column

You can click each column title to arrange the table according to the values in that
column.
●

Instr.: click to show instruments with suggested cues in the order in which
they appear in the score

●

Bar: click to show entries in ascending order, earlier bars down to later bars

●

Sec.: click to the show the length of resting period in descending order,
longest period down to shortest period

Click rows in the cue suggestions table to navigate directly to that location. By
default, an area with an equivalent rhythmic duration of 5-10 seconds prior to the
entry in the destination instrument is highlighted. The highlighted area is not a
specific recommendation for cue length, but it can be a good indication depending
on the musical context.
If you create a cue at a location suggested in the cue suggestions table, that
suggestion is automatically removed from the list.
You can click Ignore in the action bar at the bottom of the table to hide suggestions
where you do not think a cue is appropriate.
NOTE
If you later click Update and regenerate the list, hidden suggestions can reappear.
Highlight suggestions
Highlighted areas before entries in source instruments are shown Highlight
suggestions is activated, and are hidden when it is deactivated.
Playing instruments list
Contains the instruments that are playing in the 5-10 seconds prior to the entry in
the destination instrument currently selected in the cue suggestion table, to help you
determine which instrument to use as the source instrument of cues.
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RELATED LINKS
Cues on page 457

Inputting cues using cue suggestions
You can use the Suggest Cues section of the Cues panel in Write mode to find suitable places to
input cues. You can then input cues using the cues popover.
PROCEDURE
1.

In Write mode, open the layout in the music area in which you want to find suitable
locations for cues.
For example, suitable locations for cues are suggested for all instruments when the full
score layout is open in the music area, but only suitable locations for individual
instruments are suggested when a single part layout is open.

2.

Click Cues in the Notations toolbox.

The Cues panel opens.
3.

4.

5.

In the Cues panel, change Resting for in the Suggest Cues section to specify the resting
period after which you want to input cues in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

Choose one of the following options for Rehearsal marks:
●

Consider

●

Ignore

Choose one of the following options for Cues:
●

Consider

●

Ignore

6.

Click Update.

7.

Click a row in the cue suggestion table to navigate directly to that position in the layout so
you can check the context of the cue suggestion.
Cue suggestions are highlighted for the equivalent rhythmic duration of 5-10 seconds. You
can choose not to see highlighted areas by deactivating Highlight suggestions.

8.

9.

10.

Select one of the following on the staff in which you want the cue to appear:
●

A note or rest at the position where you want the cue to start.

●

Multiple notes or rests spanning the duration you want the cue to last.

Open the cues popover in any of the following ways:
●

Press Shift-U.

●

Choose Write > Create Cue.

●

Click Insert Cue in the Cues panel.

Enter the first few letters into the popover of the instrument whose music you want to
show in the cue.
The candidate instrument menu appears below the popover. You can use the Playing
instruments list to help select an appropriate source instrument for your cue.

11.

Select the instrument whose music you want to show in the cue in any of the following
ways:
●

Press Up Arrow and Down Arrow to highlight it in the candidate instrument menu,
then press Return.

●

Click it in the candidate instrument menu.
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●

Enter the full name of the instrument into the cues popover, then press Return
twice.
NOTE
If you do not enter the name of an instrument that exists in your project, no cue is
created.
If multiple instruments of the same type exist in your project, music from the first
player is input as the cue. For example, if you have Violin I and Violin II in your
project and enter violin into the cues popover, music from the Violin I staff is shown
in the cue.

RESULT
A cue is input in the selected staff, showing the music of the instrument selected in the cues
popover.
If you are inputting cues in a full score layout in page view, the cue appears as a signpost by
default, showing the name of the source instrument.
NOTE
You can show cues in full score layouts. You can also see the music in the cue in the
corresponding part layout, as cues are shown in part layouts by default.

RELATED LINKS
Cues on page 457
Cue suggestions on page 218
Lengthening/Shortening cues on page 462
Moving cues on page 461
Switching between layouts on page 94

Splitting flows
You can split flows at specific rhythmic positions.
PROCEDURE
1.

In Write mode, select a note or item at the position where you want to split the flow.

2.

Choose Write > Split Flow.

RESULT
The flow is split into two flows: the existing flow and a new flow that begins from the position of
the item you selected.
RELATED LINKS
Flows on page 88
Adding flows on page 88
Deleting flows on page 91
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Engrave mode allows you to manipulate and modify every item in your project. You can
determine how the pages of your project are formatted for printing or exporting.

Project window in Engrave mode
The project window in Engrave mode contains the default toolbar, the music area, and the status
bar. It provides panels with all the tools and functions that allow you to format the pages,
systems, and properties of individual notations in your score.
You can switch to Engrave mode in any of the following ways:
●

Press Ctrl/Cmd-3.

●

Click Engrave in the toolbar.

●

Choose Window > Engrave.

The panels are located on the left, right, and bottom of the project window and can be shown or
hidden.

Panels in Engrave mode
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The following panels are available:
1

Formatting
Allows you to insert and align different kinds of frames in pages. You can also make
changes to how a system is formatted on a page.

2

Pages
Allows you to specify how the notation is formatted on pages. The way this is done is
based on the typical techniques as they are used in desktop publishing programs.

3

Properties
Contains quick access properties that allow you to make specific modifications to
individual parts of notes and notations.

RELATED LINKS
Windows on page 38

Formatting panel
The Formatting panel in Engrave mode allows you to insert different kinds of frames into pages
and to specify how these are aligned on a page. You can also make changes to how systems and
frames are formatted on pages.
You can show/hide the Formatting panel in any of the following ways:
●

Press Ctrl/Cmd-7.

●

Click the disclosure arrow to the left of the music area.
/

The Formatting panel is divided into the following sections:

Frames
The Frames section allows you to create new frames on a page and to specify the constraints
between the frames and the page margins. Activate this section to make changes to frames.
Insert Music Frame
Allows you to insert a frame for which you can specify the layouts that you want to
show.

223

Engrave mode
Project window in Engrave mode
NOTE
To specify which parts are visible in the default frame, you must edit the master
pages of the used master page set.
Insert Text Frame
Allows you to insert a frame into which you can enter text that you can format
according to your needs.
Insert Graphics Frame
Allows you to insert an frame that can contain an image or an illustration.
Constraints
Allows you to specify which sides of the frame you want to lock to the page margin.

Format Music Frames
The Format Music Frames section allows you to change how the music in the layout currently
open in the music area is arranged into frames.
Insert Frame Break
Forces music from the selected item onwards onto the next frame, which is often on
the next page. This allows you to control what music appears on each page.
Lock Frame
Fixes the formatting of the selected frames, even if you change the formatting of
surrounding frames.
Make into Frame
Forces all music between the selected items into the same frame. You can use this
option to force music onto a single page.

Format Systems
Insert System Break
Forces music from the selected item onwards onto the next system. Depending on
your staff size and other settings, this may mean the music is forced onto the next
page.
Lock System
Fixes the formatting of the selected systems, even if you change the formatting of
surrounding musical material and other systems.
Make into System
Forces all music between the selected items into the same system.
RELATED LINKS
Frames on page 244
Master pages on page 230
Frame constraints on page 261
Frame breaks on page 270

Pages panel
The pages panel in Engrave mode provides several sections that allow you to specify how the
pages of your notation are formatted. The way this is done is based on the typical techniques as
they are used in desktop publishing programs.
You can show/hide the Pages panel in any of the following ways:
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●

Press Ctrl/Cmd-9.

●

Click the disclosure arrow to the right of the music area.
/

Pages panel in Engrave mode

The pages panel is divided into the following sections:

Pages
Pages display
Shows the pages in your layout with their page number. A highlighted page frame
indicates a selected page. Markings in the top left and the bottom right corner of the
pages indicate that a page has overrides. Additional frames at the top or left frames
of the page indicate that master page changes have been applied.
Insert Pages

Allows you to insert pages into your layout before or after existing pages, based on a
selected master page.
Insert Page Number Change

Allows you to change the page numbers for pages in your layout.
Insert Master Page Change

Allows you to assign a different master page to a selected page.
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Swap with Previous Page

Moves a selected page to the position of the previous page.
Swap with Next Page

Moves a selected page to the position of the next page.
Remove Overrides

Removes all overrides on a selected page.

Master Pages
Master Pages display
Shows the master page pairs that are used in your layout. A highlighted frame
indicates the selected master page. If you select a page in the Pages display, the
master pages display highlights the master page pair that is used for this page.
Current set
Shows the master page set that is in use and allows you to select a different master
page set.
New Master Page

Allows you to add a new master page to a master page set.
Edit Master Page

Opens the master page editor in which you can change the master page formats.
Click Close Master Page Editor to close the master page editor.
Rename Master Page

Allows you to rename a selected master page.
Delete Master Page

Deletes a selected master page.

Master Page Sets
Master Page Set list
Shows a list of available master page sets.
New Master Page Set

Creates a new master page set based on the master page set that is selected in the
list. The new master page set is automatically added to the Current set menu in the
Master Pages section.
Rename Master Page Set
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Allows you to rename the selected master page set.
Delete Master Page Set

Deletes a selected master page set from the list.

Properties panel
The Properties panel in Engrave mode provides options that allow you to edit individual notes
and notations. All the properties that are available in the Properties panel in Write mode are also
available in Engrave mode, but additional properties in Engrave mode allow you to edit items in
more detail.
You can hide/show the Properties panel in Write mode and Engrave mode in any of the following
ways:
●

Press Ctrl/Cmd-8.

●

Click the disclosure arrow at the bottom of the window.
/

●

Choose Window > Show Bottom Panel.

The Properties panel contains a section for each notation item. When you select a note or
notation, or part of a note or notation, and open the Properties panel, the Properties panel
displays the sections and all the respective options that you might require to edit the selected
item.
NOTE
If you select multiple different types of notation items, only the sections that they have in
common are displayed.
EXAMPLE
If you select a note or rest, the Common section and the Notes and Rests section are displayed.
If you select a tied note with an articulation, the following groups are displayed:
●

The Common group

●

The Notes and Rests group

●

The Ties group

●

The Articulations group

RELATED LINKS
Changing the properties of individual items in Engrave mode on page 227

Changing the properties of individual items in Engrave mode
You can view and change the properties of notes and notations.
TIP
You can change the default appearance and position of all notes and notations project-wide in
Engraving Options.

PROCEDURE
1.

Select a note, notation, or individual parts of them in the music area.
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2.

3.

Show the Properties panel in any of the following ways:
●

Press Ctrl/Cmd-8.

●

Click the disclosure arrow at the bottom of the window.

●

Choose Window > Show Bottom Panel.

Change the properties that you want.

RESULT
The changes are immediately displayed in the music area.
NOTE
Properties are layout-specific. For example, if you change the placement of an item relative to the
staff in a full score layout, this does not affect the placement of the item in the corresponding
part layout.

RELATED LINKS
Engraving Options dialog on page 228
Properties panel on page 227

Selecting handles on items
In Engrave mode, you can select individual handles on items, for example, if you want to move
the graphical end of a gradual dynamic without moving its start.
NOTE
These steps do not apply to frame, note spacing, or staff spacing handles.

PROCEDURE
1.

Select a handle in any of the following ways:
●

Select the whole item and press Tab until the handle you want is selected.

●

Click the handle you want.
TIP
You can show handles on all items, not just selected items, by choosing Engrave >
Show Handles > Always. This can make it easier to select individual handles on
multiple items.

2.

Optional: Select handles on other items as well by Ctrl/Cmd-clicking them.
NOTE
You cannot select subsequent handles on other items by selecting the items and pressing
Tab.

Engraving Options dialog
The Engraving Options dialog provides multiple options that allow you to make project-wide
changes to your project by changing the graphical appearance and position of items.
The changes that you can make may affect, for example, the following properties of notation
items:
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●

Line thickness

●

Distances

●

Positions

NOTE
You can save all options that you set in Engraving Options as the default for new projects by
clicking Save as Default.
TIP
If you want to make changes to individual notes and notations, you can use properties in the
Properties panel.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Engraving Options

The list on the left of the Engraving Options dialog contains the pages for each notation
category. All the options available for the category selected in the list are shown in the main area
of the dialog.
Pages with many options are divided into sections and subsections.
RELATED LINKS
Notation Options dialog on page 110
Layout Options dialog on page 62
Playback Options dialog on page 312
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Making project-wide changes
You can make project-wide changes to the appearance, placement, and default position of notes
and notations in Engraving Options.
PROCEDURE
1.

Open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

2.

Click a page in the page list on the left of the dialog.

3.

Look through the available options, and change the options you want.

4.

Click Apply, then Close.
NOTE
If you make changes and close the dialog without clicking Apply, you are prompted to
save or discard your changes.

RESULT
The changes are applied to all music in your project, including in all layouts and flows.

Master pages
Master pages in Dorico allow the same formatting to be applied to different pages in different
layouts.
NOTE
Page size and margins, page orientation, and staff size for full score and part layouts are
specified in Setup > Layout Options.
All pages in your score and parts inherit their layout formats from master pages. Whenever you
create or change anything on master pages, this is automatically reflected on the pages that use
these master pages. For example, if you insert a new frame on a master page, a corresponding
frame appears on all the pages that use that master frame.
In Dorico, master pages consist of page pairs. Every page pair has a left and a right master page,
so that if a page in your project falls on a left page, the formatting of the left page of the master
page pair is used, and if a page falls on a right page, the formatting of the right page of the
master page pair is used.
Dorico provides default master pages with page pairs for first (First) and subsequent (Default)
pages. This enables you to format first pages differently compared to subsequent pages. Page
pairs are contained in master page sets for full score and part layouts. Master page sets are
automatically applied to every layout that you create.
If you want to change the master page sets or to change the format of the master pages, you
can do so in any of the following ways:
●

Create new master pages and master page sets.

●

Edit the default master pages in the master page sets using the master page editor.

●

Override individual master pages.

RELATED LINKS
Master page sets on page 231
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Master page editor on page 235
Layout Options dialog on page 62

Master page sets
In Dorico, master pages are provided as parts of master page sets. Master page sets group
master page formats together, so there is a master page for all possible situations in your
project.
The default master page sets contain predefined master pages for first page pairs (First) and
subsequent page pairs (Default). This ensures there is a master page format for the first page in
each flow, whether that is on a right page or a left page, and a master page format for
subsequent pages in each flow on both right and left pages.
For every new project, the following default master page sets are available:
●

Default Full Score is the default master page set used for full score layouts.

●

Default Part is the default master page set used for part layouts.

You do not need to create or customize master page sets initially, as the default sets are applied
automatically when you create your score. If you find that you want or need to change the sets,
you can do so in any of the following ways:
●

Create new custom master page sets based on the default sets.

●

Change the default sets according to your requirements for the current project.

RELATED LINKS
Creating master page sets on page 231

Creating master page sets
You can create new master page sets. They can be based on the sets provided by Dorico and on
existing custom master page sets you have created.
PROCEDURE
1.

In the Master Page Sets section of the Pages panel, click the master page set on which
you want to base a new master page set.

2.

Click New Master Page Set.

RESULT
A new master page set is created based on the selected default master page set. It appears
immediately in the list of master page sets.
AFTER COMPLETING THIS TASK
You can rename your new master page set and add new master pages to it.
RELATED LINKS
Renaming master page sets on page 232
Adding master pages on page 233
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Renaming master page sets
You can edit the names of master page sets that you have created. You cannot rename the
default master page sets.
PROCEDURE
1.

In the Master Page Sets section of the Pages panel, double-click the master page set that
you want to rename.
Alternatively, you can select the master page set and click Rename Master Page Set.

2.

Enter the new name you want.

3.

Press Return.

Deleting master page sets
You can delete master page sets that you no longer need, including the default master page sets.
PROCEDURE
1.

In the Master Page Sets section of the Pages panel, click the master page set that you
want to delete.

2.

Click Delete Master Page Set.

Applying master page sets to layouts
You can apply a different master page set to each layout in your project.
PROCEDURE
1.

In the music area, open the layout to which you want to apply a master page set.

2.

In the Master Pages section of the Pages panel, select a master page set from the
Current set menu.

RESULT
The selected master page set is applied to the layout.
AFTER COMPLETING THIS TASK
You can make further changes to the layout, such as assigning different master pages in the
master page set to individual pages. You can also make individual master page overrides that
only apply to pages in the current layout, for example, if you need the frame padding on the first
page to be different to the master page setting.
RELATED LINKS
Assigning master pages to pages on page 242
Master page overrides on page 237
Overriding master pages on page 238

Master page types
If you add a new master page to a master page set, you must specify the type of master page
that you want to add.
You can add the following types of master pages:
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First
A page pair that is usually used for the first page of music in a layout. By default,
First master pages can display the project title, composer, and lyricist in addition to
the music.
NOTE
If you create no First page pair, the first page in your layout uses the Default page
pair.
Default
A page pair that is usually used for pages after the first page in a layout. By default,
Default master pages display the flow title and page number in addition to the
music.
Every master page set must contain a single Default master page.
Custom
A page pair that can have any layout. Custom master pages allow you to create
layouts that you want to apply to multiple pages but not all pages, for example, if
you want to show an image at the same position on only the final pages in each part
layout.
NOTE
If you insert a page to a layout using a custom master page, you create an override.
This means that if you insert a page in the middle or at the end of your layout pages
using a custom master page and then remove the override, that page is
automatically assigned the Default master page.

RELATED LINKS
Adding master pages on page 233
Master page sets on page 231
Master page overrides on page 237

Adding master pages
You can add new master pages to master page sets. Each master page set can have multiple
custom master pages, but only a single first master page and single default master page.
PROCEDURE
1.

In the Master Pages section of the Pages panel, select the master page set to which you
want to add new master pages from the Current set menu.

2.

Click New Master Page.

The New Master Page dialog opens.
3.

In the New Master Page dialog, enter a name for the new master page into the Name
field.

4.

Select the master page that you want to use as the basis from the Based on menu.
NOTE
Selecting (None) always creates a master page without any formatting but the page
margins.

5.

Choose one of the following master page types for your new master page:
●

First
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●

Default

●

Custom

NOTE
If you select First or Default, the new master page replaces that existing master page, as
each master page set can only have a single first and default master page.
If you want to create a new master page without replacing any existing master pages,
choose Custom.

RESULT
A new master page of the selected type is added to the selected master page set.
AFTER COMPLETING THIS TASK
You can apply your new master pages to individual pages in layouts that use the master page set
to which they belong.
RELATED LINKS
Applying master page sets to layouts on page 232
Master page sets on page 231

Renaming master pages
You can change the names of master pages.
PROCEDURE
1.

In the Master Pages section of the Pages panel, select the master page set containing the
master page you want to rename from the Current set menu.

2.

In the Master Pages section, click the master page pair that you want to rename.

3.

Click Rename Master Page.

The Rename Master Page dialog opens.
4.

Enter the name you want in the Name field.

5.

Click OK to save your changes and close the dialog.

Deleting master pages
You can delete master pages from master page sets.
NOTE
Master pages of the type Default cannot be deleted. Every master page set must contain at least
a Default master page.

PROCEDURE
1.

In the Master Pages section of the Pages panel, select the master page set from which
you want to delete master pages from the Current set menu.

2.

In the Master Pages section, click the master page pair that you want to delete.

3.

Click Delete Master Page.
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RESULT
The selected master page pair is deleted.
NOTE
You can undo this action immediately in any of the following ways:
●

Press Ctrl/Cmd-Z.

●

Choose Edit > Undo.

Master page editor
The master page editor allows you to view and change the format of the master pages.
You can open the master page editor in the following ways:
●

Double-click a page pair in the Master Pages section of the Pages panel.

●

Select a page pair in the Master Pages section of the Pages panel and click Edit Master
Page.

You can change master pages in the master page editor in the following ways:
●

Insert and adjust music frames, text frames, and graphics frames in relation to other
frames and the page margins.

●

Assign frames to frame chains.

●

Specify the order in which frames display the notation.

●

Assign flows and players to frames.

A pair of master pages open in the master page editor
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Customizing master pages
You can customize master pages according to your needs in the master page editor. Changing a
master page affects the appearance of all layouts that use that master page.
NOTE
If you want to edit the page size and margins, page orientation, and staff size for layouts, you
must specify these on the Page Setup page in Setup > Layout Options.

PROCEDURE
1.

In the Pages panel, double-click a master page pair in the Master Pages section.
The master page editor opens in the music area.

2.

In the master page editor, change the layout of one of the pages of the selected master
page pair. For example, you can change the size and shape of frames.

3.

Optional: If you want both the left and right pages to be the same, click one of the
following Copy Page Layout buttons at the top of the music area, depending on which
page you changed:
●

Left to Right

●

Right to Left

NOTE
This copies the master page layout exactly from one page to the other, not as a
mirror. For example, text frames for page numbers are not kept on the outside edge
automatically.
4.

Click Close Master Page Editor to save your changes.

RESULT
The selected master page pair is changed.
RELATED LINKS
Inputting frames on page 244
Moving frames on page 245
Changing the size/shape of frames on page 245
Master page editor on page 235
Overriding master pages on page 238
Layout Options dialog on page 62
Paragraph Styles dialog on page 276
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Master page overrides
All pages of a project inherit their format from the master pages that are specified in the
appropriate master page sets. In some cases, it is also possible to change the format of
individual pages without affecting the underlying master pages or master page sets.
In Dorico, you can override the format of an individual page. For example, you might want to
override the formats for one of the following reasons:
●

To change the size of a music frame on an individual page.

●

To insert an empty page.

●

To change the page numbering.

●

To include comments in the form of footnotes.

●

To include small excerpts of music to show how a passage was reproduced in another
source.

If you override the pages, they no longer automatically inherit changes that are made to the
master pages. Pages that have been overridden shown with a marking on them in the Pages
section of the Pages panel:
●

Master page overrides: marking shown in top left corner.

●

Page number changes: marking shown in bottom right corner.

To return the formatting of pages whose formats you have overridden to the master pages, you
must remove the overrides that you made.
NOTE
If you inserted a page in the middle or at the end of your layout using a custom master page and
remove the override, that page is automatically assigned the Default master page of the master
page set.
You can also change the master page used for individual pages. For example, you might want to
change the master page used for pages in a part that has a few pages with more staves than
usual. Or you might want to change the master page used for a score where the instrumentation
is significantly different for one flow and you want the format of those pages to be different.
Pages whose master page has been changed are shown with a marking on them in the Pages
section of the Pages panel.
●

Master page changes on the current page only are shown with a marking along their top
edge.

●

Master page changes from the page onwards are shown with a marking along their left
edge and top edge.

The table shows examples of how the different overrides you can make to individual pages in
layouts are shown in the Pages section of the Pages panel in Engrave mode.
Master page override Page number change Master page change
to single page only
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RELATED LINKS
Overriding master pages on page 238
Removing master page overrides on page 238

Overriding master pages
You can override master page settings on individual pages in your layout.
PROCEDURE
●

Override the master page settings in one of the following ways:
●

To edit the frames, activate Frames in the Formatting panel.
NOTE
If the Filter by Flow and the Filter by Player options cannot be edited, you must
edit the respective master page.

●

To insert, swap, and delete pages, and to change the page numbers, use the options
in the Pages section.

RESULT
As soon as a master page is overridden, the page icon in the Pages panel shows a marking in the
top left corner if you have changed an aspect of the master page, or the bottom right corner if
you have changed the page number.
RELATED LINKS
Master page overrides on page 237
Frames on page 244

Removing master page overrides
You can remove overrides that you have made to individual pages, which returns them to the
master page format.
Any pages in your layout that contain overrides are shown with a colored triangle in their top left
corner in the Pages section of the Pages panel.
Removing overrides from empty pages deletes them from the layout.
PROCEDURE
1.

In the music area, open the layout whose master page overrides you want to remove.

2.

Optional: If you want to remove overrides from individual pages, select those pages in the
Pages section of the Pages panel in any of the following ways:

3.

●

Click a single page.

●

Ctrl/Cmd-click multiple pages.

Remove master page overrides in one of the following ways:
●

To remove overrides from selected pages only, right-click in the Pages section of the
Pages panel and choose Remove Page Overrides from the context menu.

●

To remove overrides from selected pages only, click Remove Overrides in the
Pages section of the Pages panel.

●

To remove overrides from all pages, right-click in the Pages section of the Pages
panel and choose Remove All Page Overrides from the context menu.
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RESULT
Any overrides you made to the master page format are removed from either the selected pages
only or from all pages in the layout currently open in the music area. Empty pages that are
considered overrides are deleted.
If you removed overrides from selected pages only, any other pages with overrides in the layout
are unaffected.
RELATED LINKS
Master page overrides on page 237

Inserting pages
You can insert empty pages or pages that use a different master page into each layout in your
project.
PROCEDURE
1.

Open the Insert Pages dialog in any of the following ways:
●

In the Pages section of the Pages panel, right-click and choose Insert Pages from
the context menu.

●

In the Pages section of the Pages panel, click a page and click Insert Pages.

2.

Enter a page number into the Number of pages to insert field.

3.

Select where you want to insert pages. For example, select After page and enter 8 to
insert pages after page 8.

4.

Select the master page that you want to assign to the inserted pages from the Use master
page menu.

5.

Click OK to save your changes and close the dialog.

Inserting page number changes
You can change the page numbers of pages in each layout in your project. Inserting page
number changes allows you to change the page number shown, and also the page number style.
For example, you can use Roman numerals such as ii and iv for front matter pages, and numbers
such as 1 and 3 for music pages.
NOTE
If you change the first page in the layout to an even number, it automatically becomes a lefthand page. This is because convention dictates that even numbered pages are always on the lefthand page, and odd numbered pages are always on the right-hand page. Similarly, if the first
page in the layout is on the left-hand page, it cannot show as page 1, it can only show as page 2.

PROCEDURE
1.

In the music area, open the layout whose page numbers you want to change.

2.

In the Pages section of the Pages panel, select the page from which you want to change
the page numbers.

3.

Open the Page Number Change dialog in any of the following ways:
●

Right-click in the Pages section and choose Insert Page Number Change from the
context menu.

●

Click Insert Page Number Change.
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4.

In the Page Number Change dialog, enter the number of the page from which you want
the page number change to start in the From page field.
For example, if you want to change the page number of your current page 3, enter 3.

5.

Enter the new page number that you want the selected page to have in the First page
number field. For example, if you want to change your current page 3 to page 5, enter 5.

6.

Select the numeral style you want from the following options for Sequence type:

7.

●

Number

●

Roman numeral

Click OK to save your changes and close the dialog.

RESULT
The page number of the selected page is changed. All subsequent pages are changed
correspondingly until the next page number change or the end of the project, whichever comes
first.
NOTE
You can change other aspects of the appearance of page numbers in the Page Number Change
dialog. For example, you can show subordinate numbers as upper case letters or lower case
letters.

RELATED LINKS
Page Number Change dialog on page 240

Page Number Change dialog
The Page Number Change dialog allows you to change the page numbers shown on existing
pages in each layout. You can choose to show pages without page numbers or with different
numbering.
For example, you can change the number type to one of the available types:
●

Roman numeral: such as iii and iv

●

Number: such as 5 and 19

You can also change the visibility of page numbers. For example, you can hide page numbers on
introductory pages by setting their visibility to Not on first page.
You can open the Page Number Change dialog when a page is selected in the Pages section of
the Pages panel in any of the following ways:
●

Right-click in the Pages section and choose Insert Page Number Change from the
context menu.

●

Click Insert Page Number Change.

The Page Number Change dialog contains the following options:
From page
Allows you to select the page from which you want to change page numbers. The
number indicates its position within the layout.
The Displayed option shows you the number that the selected page currently has,
and how that number appears.
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First page number
Allows you to specify the new page number you want for the selected page.
Subsequent pages follow the new sequence until the next page number change or
end of the project.
Sequence type
Allows you to select the type of number that the selected page and subsequent
pages have.
Visibility
Allows you to specify if a page number is hidden or shown. You can additionally
specify that the page number is also hidden on the page where the page number
change occurs.
Subordinate number type
Allows you to add a subordinate number to the page number and to specify a type.
Subordinate number
Allows you to specify the number from which you want the subordinate numbers to
start.
When you insert page number changes, a marking is shown in the bottom right corner of the
page in the Pages section of the Pages panel. The new page number is also shown in each page
in the Pages section of the Pages panel, in the appropriate numeral style.
RELATED LINKS
Inserting page number changes on page 239
Removing page number changes on page 241
Master page overrides on page 237
Page numbers on page 607

Removing page number changes
You can remove page number changes you have made to individual pages, which reverts pages
to their default page numbers.
Any pages whose page number has been changed are shown with a colored triangle in their
bottom right corner in the Pages section of the Pages panel.
PROCEDURE
1.

In the music area, open the layout whose page number changes you want to remove.

2.

Optional: If you want to remove page number changes from individual pages, select those
pages in the Pages section of the Pages panel in any of the following ways:

3.

●

Click a single page.

●

Ctrl/Cmd-click multiple pages.

Remove page number changes in one of the following ways:
●

To remove page number changes from selected pages only, right-click in the Pages
section of the Pages panel and choose Remove Page Number Change(s) from the
context menu.

●

To remove page number changes from all pages, right-click in the Pages section of
the Pages panel and choose Remove All Page Number Changes from the context
menu.
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RESULT
Page number changes are removed from either the selected pages only or from all pages in the
layout currently open in the music area.
If you removed page number changes from all pages, all pages are restored to the default page
number sequence.
If you removed page number changes from selected pages only, the default page number is
restored from the selected pages until the next page number change or the end of the project,
whichever comes first. Any other pages with page number changes in the layout are unaffected.
RELATED LINKS
Page Number Change dialog on page 240
Inserting page number changes on page 239

Assigning master pages to pages
You can assign a different master page to each page in each layout in your project.
The selected master page set defines the master pages for every page in the layout. However,
you can change the master page assignment for one or more pages.
PROCEDURE
1.

In the Pages section of the Pages panel, click the page whose master page assignment
you want to change.

2.

Click Insert Master Page Change.

The Insert Master Page Change dialog opens.
3.

Optional: Change the start page for the master page change using the From page option.

4.

Select the master page that you want to assign from the Use master page menu.

5.

Choose one of the following options for Range:
●

Current Page Only
Only the selected page is assigned a different master page.

●

From this Page Onwards
The selected page and all subsequent pages are assigned a different master page.

6.

Click OK to save your changes and close the dialog.

Removing master page changes
You can remove master page changes you have assigned to individual pages, which reverts them
to the overall master page format applied to the layout.
Any pages whose master page has been changed are shown with a marking along their top
edge, or along their top and left edges, in the Pages section of the Pages panel.
PROCEDURE
1.

In the music area, open the layout whose master page changes you want to remove.

2.

Optional: If you want to remove master page changes from individual pages, select those
pages in the Pages section of the Pages panel in any of the following ways:

3.

●

Click a single page.

●

Ctrl/Cmd-click multiple pages.

Remove master page changes in one of the following ways:
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●

To remove master page changes from selected pages only, right-click in the Pages
section of the Pages panel and choose Remove Master Page Change(s) from the
context menu.

●

To remove master page changes from all pages, right-click in the Pages section of
the Pages panel and choose Remove All Master Page Changes from the context
menu.

RESULT
All master page changes are removed from either the selected pages only or from all pages in
the layout currently open in the music area. Pages return to the overall master page format
applied to the layout.
If you removed master page changes from selected pages only, any other pages with master
page changes in the layout are unaffected.
RELATED LINKS
Assigning master pages to pages on page 242
Master page overrides on page 237

Swapping pages
You can swap pages that have overrides with adjacent pages.
PROCEDURE
1.

In the music area, open the layout in which you want to swap pages.

2.

In the Pages section of the Pages panel, select a page with an override.
NOTE
A page with an override has a marking in the top left corner.

3.

Swap the selected page with another page in any of the following ways:
●

Right-click in the Pages section and choose Swap with Next Page from the context
menu.

●

Click Swap with Next Page.

●

Choose Swap with Previous Page from the context menu.

●

Click Swap with Previous Page.

RESULT
The selected page exchanges the position with the previous or next page within the sequence of
pages in the layout.
RELATED LINKS
Master page overrides on page 237
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Frames
Frames allow you to position your music, additional text, and graphics anywhere inside the
margins of a page.
Frames are rectangular boxes that can be positioned inside the page margins that have been
defined for a layout. In Engrave mode, you can see and adjust frames according to your needs.
For every project that you create, Dorico provides the following frames:
●

Music frames that show the music of selected players and flows

●

Text frames that allow you to enter text and text tokens

●

Graphics frames that allow you to load images or illustrations in a variety of formats

For every frame, you can specify constraints that define the relationship between the sides of the
frame and the corresponding page margins.
RELATED LINKS
Flows in Dorico on page 33
Layouts in Dorico on page 34
Frame constraints on page 261
Music frames on page 247
Text frames on page 254
Graphics frames on page 260
Text tokens on page 254

Inputting frames
You can input frames on pages manually, including on both individual pages and on master
pages in the master page editor. You can input music frames, text frames, and graphics frames.
PROCEDURE
1.

In Engrave mode, do one of the following:
●

In the music area, open the layout in which you want to insert frames.

●

In the master page editor, open the master page in which you want to insert frames.

2.

In the Formatting panel, activate Frames.

3.

Choose one of the following types of frames:

4.

●

Insert Music Frame

●

Insert Text Frame

●

Insert Graphics Frame

Click and drag in the music area.
You can draw a frame of any size and shape, as long as it fits within the page margins.

5.

Release the mouse button.

RESULT
The type of frame you chose is input on the page.
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AFTER COMPLETING THIS TASK
You can change the size of the frame or define its constraints. If you inserted a music frame, you
can determine which parts of your score you want to display in the frame. If you inserted a text
frame, you can enter text. If you inserted a graphics frame, you can load a graphic file.
RELATED LINKS
Frame constraints on page 261
Music frames on page 247
Text frames on page 254
Graphics frames on page 260
Music frame selectors on page 249
Master page editor on page 235

Moving frames
You can move individual frames around pages, including master pages, after they have been
inserted. However, you cannot move frames beyond page margins.
PROCEDURE
1.

In Engrave mode, do one of the following:
●

In the music area, open the layout in which you want to move frames.

●

In the master page editor, open the master page in which you want to move frames.

2.

In the Formatting panel, activate Frames.

3.

Select the frames you want to move.

4.

Move the frames in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RELATED LINKS
Master page editor on page 235

Changing the size/shape of frames
You can change the size and shape of individual frames on pages, including on master pages,
after they have been inserted.
PROCEDURE
1.

In Engrave mode, do one of the following:
●

Open the layout in which you want to change the size or shape of frames in the
music area.

●

Open the master page in which you want to change the size or shape of frames in
the master page editor.

245

Engrave mode
Frames
2.

In the Formatting panel, activate Frames.

3.

Select the middle handle on an edge of the frame whose size or shape you want to
change.
NOTE
You can only select a single handle on a single frame at a time.

4.

Move the handle in any of the following ways:
●

Press Alt-Right Arrow to move it to the right.

●

Press Alt-Left Arrow to move it to the left.

●

Press Alt-Up Arrow to move it upwards.

●

Press Alt-Down Arrow to move it downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the handle to the right/left or upwards/downwards.

NOTE
You can only move handles on the right/left edges of frames to the right/left. You can only
move handles on the top/bottom edges of frames upwards/downwards. For example, if
you want to make a frame wider, you can select the middle handle on the right edge of the
frame and move it to the right.
5.

Optional: Repeat steps 3 and 4 for any other edge of the frame you want to move to
achieve the size and shape you want.

RELATED LINKS
Master page editor on page 235

Selecting frame handles
You can select an individual handle on a frame, and you can switch between having a handle
selected and having the whole frame selected.
PROCEDURE
1.

Select a frame handle in any of the following ways:
●

Select any handle on the frame and press Right Arrow/Left Arrow/Up Arrow/
Down Arrow to select other handles around the edge of the frame.

●

Select the frame, press Tab to switch to having the handle in the top left corner
selected, then press Right Arrow/Left Arrow/Up Arrow/Down Arrow to select
other handles around the edge of the frame.

●

Click a handle on the frame.

NOTE
You can only select a single handle on a single frame at a time.
2.

Optional: Switch back to having the whole frame selected at any time by pressing Tab.
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Copying frames
You can copy individual frames from one page to other pages in layouts, for example, if you want
the same frame to appear on multiple pages at exactly the same position. You can also copy
frames to the same page, for example, if you want to duplicate a frame on a page.
NOTE
This does not apply to frames on master pages. You can copy frames on master pages when
customizing the master page.

PROCEDURE
1.

In the music area, open the layout in which you want to copy frames to other pages.

2.

In the Formatting panel, activate Frames.

3.

Select the frames you want to copy.
TIP
The frames can be on different pages.

4.

5.

In the Pages section of the Pages panel, select the pages to which you want to copy the
selected frames in any of the following ways:
●

Click a single page.

●

Ctrl/Cmd-click multiple pages.

Right-click in the Pages section and choose Copy Selected Frames to Selected Pages
from the context menu.

RESULT
All selected frames are coped to the selected pages at the same positions on the page. If you
copied frames to their original page, they overlay their original exactly.
RELATED LINKS
Customizing master pages on page 236

Music frames
Music frames display the music in your project in a specified order. You can control which parts
of the project are displayed using master page music frames and layout music frames.
Both types of music frames display the music and notations you have input into the project
according to their music frame selectors, such as filtering only selected players or flows.

Master page music frames
Master page music frames exist only on master pages, meaning you can only input and edit
master page music frames in the master page editor. They can only have master page frame
chains assigned to them.
By default, the master pages in the master page sets provided by Dorico include master page
music frames with a single master page frame chain assigned to them. This frame chain is set to
display all players in all flows in each layout. These master pages are set to apply to all pages in
all layouts in your project by default according to the layout type.
You can input multiple master page music frames on a single master page, and change their size
and shape to whatever you want. If you want to connect separate master page music frames on
the same page, you can assign the same frame chain to them.

247

Engrave mode
Frames

Layout music frames
Layout music frames exist only on individual pages in layouts, meaning you can only input and
edit layout music frames in individual layouts in the music area. Layout music frames can have
both master page and layout frame chains assigned to them. However, assigning a master page
frame chain to a layout frame does not affect the master page.
You can input multiple layout music frames on a single page, and change their size and shape to
whatever you want. For example, layout music frames allow you to insert small musical excerpts
from a different flow within footnotes or in an index.
If you want to connect separate layout music frames on the same page, you can assign the same
frame chain to them.
IMPORTANT
Layout music frames are considered overrides to master pages. If you remove all overrides on
layout pages, all your layout music frames are also removed.

Identifying master page music frames and layout music frames
To differentiate between master page music frames and layout music frames, you can check the
following:
●

On individual pages in layouts, master page music frames never allow you to change the
selection of flows or players. Those music frame selectors are grayed out because they can
only be edited on master pages in the master page editor.

●

If you insert a layout music frame on a page, its Frame Chain selector by default shows a
frame chain that starts with an “L”. Master page music frames by default show a frame
chain that starts with an “M”.

RELATED LINKS
Music frame chains on page 248
Music frame selectors on page 249
Master pages on page 230
Master page overrides on page 237
Master page editor on page 235

Music frame chains
A music frame chain is a collection of music frames that show the same selection of music in a
predefined order, often in sequence. Music frame chains are automatically created when you
create a music frame on a page, and can include any number of frames, including only a single
music frame.
You can control the music shown in each music frame chain by player and by flow using music
frame selectors.
In Dorico, there are different types of frame chains.

Master page frame chains
Master page frame chains can be created and fully edited only on master pages in the master
page editor; you cannot change the flow and player filters for master page frame chains in
individual layouts. Whenever you create a music frame on a master page, you automatically start
a frame chain.
Frame chains that start with an “M”, such as “MA”, are master page frame chains. You can have
multiple master page frame chains on each page, such as “MA” and “MH”.
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The default master pages contain a single frame chain that is set to display all flows and all
players in the layout. Therefore, Dorico automatically creates enough pages and frames to
display all flows in all the layouts that use those master pages.
NOTE
●

To ensure that a score continues automatically on subsequent pages, the music frame
must be created at least on the First and Default master pages.

●

All frames in the same music frame chain must display the same flows and players. For
example, you cannot have the first frame in a frame chain show just the violin but have the
second frame show all players.

●

Dorico shows flows in layouts as many times as you want, not only once. Therefore, if you
want to change the formatting of some flows in a particular layout, such as showing them
in layout frame chains instead of the master page frame chain, but do not want those
flows to appear more than once, you must remove those flows from the Filter by Flows
list on the master page frame chain. As this affects which flows are automatically displayed
in all layouts that use the same master page, we recommend that in such cases you create
a separate master page for the layout in which you want to change the formatting.

Layout frame chains
Layout frame chains can only be created and edited on pages in individual layouts. If you create a
music frame and assign it to a layout frame chain in a layout, it is only displayed on that page in
that layout and starts its own frame chain. If you want the music frame to be continued on
subsequent pages, you must create music frames on all the pages in the layout on which you
want the chain to appear and assign all of these frames to the same layout frame chain.
Frame chains that start with an “L”, such as “LA”, are layout frame chains. You can have multiple
layout frame chains on each page, such as “LA” and “LB”.
NOTE
●

All frames in the same music frame chain must display the same flows and players. For
example, you cannot have the first frame in a frame chain show just the violin but have the
second frame show all players.

●

Assigning flows to layout frame chains does not stop those flows also appearing in the
master page frame chain, if the frame chain in the master page applied to the layout is set
to include those flows; by default, master page frame chains are set to display all flows in
the project.

RELATED LINKS
Music frames on page 247
Master pages on page 230
Master page editor on page 235
Layouts in Dorico on page 34
Music frame selectors on page 249

Music frame selectors
When Frames is activated in the Formatting panel, music frames show selectors that allow you to
change the music displayed, for example, changing which flow is displayed in each frame chain.
Selectors on music frames allow you to control which flows and players are displayed in frame
chains, and the order in which the selected music is shown in frames on the page. Frame chains
can include any number of frames, including only a single music frame.
Every music frame shows the following selectors:
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1

Frame Chain
Allows you to select which frame chain the music frame follows. Frames that start with an
“M” have master page frame chains assigned to them; frames that start with an “L” have
layout frame chains assigned to them.
The second letter allows you to identify different frame chains of the same type. It is
automatically generated and reflects the order in which you created the frame chains, for
example, “LA” is the first layout frame chain you create in the layout and “LB” is the second.

2

Frame Order
If you have two or more music frames in the same frame chain on the same page, you can
use this option to specify in which order the music is flowed into the frames. For example,
when the Frame Order is 1, that frame is the first frame in the frame chain.

3

Filter by Flow
If you have several flows in your project, you can specify which flows you want to display in
this frame chain. For example, you can show only a single flow, a selection of flows, or all
flows.

4

Filter by Player
If you have several players in your project, you can specify which players you want to
display in this frame chain. For example, you can show only a single player, multiple
players, or all players.

NOTE
You can only edit the Filter by Flow and Filter by Player selectors of master page music frames
on master pages in the master page editor.
If you click the frame, handles in each corner and in the middle of each side of the frame appear.
You can use these handles to drag the frame into several directions and thus change the frame
size. While you drag, numbers next to the handle indicate the horizontal and vertical values of
the frame.
If you define constraints for the frame, you can also use the options in the Frame group of the
Properties panel to specify the value of the frame.
RELATED LINKS
Assigning frame chains to music frames on page 251
Changing the order of music frames on page 252
Assigning flows to frame chains on page 252
Assigning players to frame chains on page 253
Music frames on page 247
Music frame chains on page 248
Frame constraints on page 261
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Assigning frame chains to music frames
You can assign existing music frame chains to new music frames and change the frame chain of
an existing music frame. This applies to both master page and layout music frames.
NOTE
New music frames on a page always start a new frame chain, regardless of their type.

PROCEDURE
1.

Optional: If you want to assign music frame chains to frames on a master page, open the
master page in the master page editor.

2.

In the Formatting panel, activate Frames.
Frames is automatically activated when you open the master page editor.

3.

In the music frame whose frame chain you want to change, click Frame Chain.

4.

Select the frame chain that you want to assign to the music frame.
NOTE

5.

●

You cannot select layout frame chains for frames in the master page editor.

●

If you do not want to use any of the available frame chains, click Unlink.

Click outside of the selector.
The selector closes.

RESULT
The selected frame chains is assigned to the music frame. All settings from the frame chain are
applied to the frame, such as the players and flows displayed.
RELATED LINKS
Music frames on page 247
Music frame chains on page 248
Master page editor on page 235
Music frame selectors on page 249
Unlinking music frames from frame chains on page 251

Unlinking music frames from frame chains
You can unlink music frames from music frame chains, for example, if you want to change the
music frame to a new frame chain without deleting it.
PROCEDURE
1.

Optional: If you want to unlink frames from music frame chains on a master page, open
the master page in the master page editor.

2.

In the Formatting panel, activate Frames.
Frames is automatically activated when you open the master page editor.

3.

In the music frame you want to unlink, click Frame Chain.

4.

Click Unlink.
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RESULT
The music frame is unlinked from its previous frame chain. A new frame chain is automatically
created for the unlinked frame.
●

Unlinking a layout music frame from a layout frame chain changes it to a new layout frame
chain.

●

Unlinking a layout music frame from a master page frame chain changes it to a new layout
frame.

●

Unlinking a master page music frame from a master page frame chain changes it to a new
master page frame chain.

RELATED LINKS
Music frame chains on page 248
Music frame selectors on page 249
Assigning frame chains to music frames on page 251

Changing the order of music frames
If you have at least two music frames of the same type in the same frame chain on a page, you
can change the order in which music is displayed across the frames.
PROCEDURE
1.
2.

Optional: If you want to change the order of music frames on a master page, open the
master page in the master page editor.
In the Formatting panel, activate Frames.
Frames is automatically activated when you open the master page editor.

3.

In one of the music frames whose order you want to change, click Frame Order.

4.

Select the ordinal number for this frame from the Frame Order menu.

5.

Click outside of the selector.
The selector closes.

RESULT
The position of the selected frame in the frame chain order is changed by exchanging its order
number with the frame previously assigned that number. For example, changing the number of
the second frame in a frame chain to 1 causes the frame originally number 1 to become number
2 in the frame chain order.
RELATED LINKS
Music frame chains on page 248
Music frame selectors on page 249

Assigning flows to frame chains
You can change which flows are shown in each frame chain, for example, if you want to exclude
some flows from the master page frame chain because you want to display those flows in layout
frame chains instead.
NOTE
●

You can assign flows to both master page frame chains and layout frame chains. However,
you can only change the flows assigned to layout frame chains in individual layouts, and
you can only change the flows assigned to master page frame chains in the master page
editor.
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●

Changing the assigned flows affects all frames in the frame chain.

PROCEDURE
1.

Optional: If you want to change the flows assigned to music frame chains on a master
page, open the master page in the master page editor.

2.

In the Formatting panel, activate Frames.
Frames is automatically activated when you open the master page editor.

3.

In the music frame whose assigned flows you want to change, click Flows.

4.

Select the flows you want to be displayed in the frame chain from the Filter by Flow menu.

5.

Click outside of the selector.
The selector closes.

RESULT
The music frame shows the selected flows. If you changed the flows assigned to a master page
music frame, the number of pages in the layouts to which the master page is applied
automatically updates. For example, if you assigned an extra flow to the master page frame
chain, enough extra pages and frames to display that flow are added to the corresponding
layouts.
RELATED LINKS
Music frames on page 247
Music frame chains on page 248
Music frame selectors on page 249

Assigning players to frame chains
You can change which players are included in different frame chains, for example, if you are
writing a piano duet and only want to show one piano on left pages and the other piano on right
pages.
NOTE
●

You can assign players to both master page frame chains and layout frame chains.
However, you can only change the players assigned to layout frame chains in individual
layouts, and you can only change the players assigned to master page frame chains in the
master page editor.

●

Changing the assigned players affects all frames in the frame chain.

PROCEDURE
1.
2.

Optional: If you want to change the players assigned to music frame chains on a master
page, open the master page in the master page editor.
In the Formatting panel, activate Frames.
Frames is automatically activated when you open the master page editor.

3.

In the master page music frame, click Players.

4.

Select the players you want to be displayed in the music frame from the Filter by Player
menu.

5.

Click outside of the selector.
The selector closes.
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RESULT
Which players are displayed in the frame chain is changed.
NOTE
The staff size is not changed automatically, meaning staves can overlap in small frames in the
frame chain.

RELATED LINKS
Music frames on page 247
Music frame chains on page 248
Music frame selectors on page 249

Text frames
Text frames allow you to add text, including tokens, to your project, independently of rhythmic
positions in the score. If you add a text frame, the formatting of your layout pages is changed.

Text frame

RELATED LINKS
Inputting frames on page 244
Entering text in text frames on page 258
Text formatting on page 274
Changing the default horizontal alignment of different text styles project-wide on page 515
Changing the horizontal alignment of text in text frames on page 259

Text tokens
Text tokens, also known as “wildcards” or “text codes”, are codes that you can use as substitutes
for information stored in your project, such as titles, composers, and the time and date. This can
reduce the risk of mistakes or outdated information appearing in your project.
For example, if you use a token for the title of your project, you can change the project title in the
Project Info dialog as often as you want, and the project title in every layout in your project is
updated automatically.
Tokens can refer to the project-wide information on the Project page in the Project Info dialog,
or to individual Flow pages in the Project Info dialog. Tokens can also refer to the current time
and date and the time and date the project was last saved.
NOTE
●

You can only use text tokens in text frames. You cannot use tokens in text/system text
objects.

●

Because flow tokens refer to the first flow on the page, if you want to use tokens that refer
to flow information on pages that contain no music, such as title pages, you must specify
the flow number. For example, if you use {@flowtitle@} on a title page containing no
music frames, the token does not display any information, but {@flow1title@} displays the
title of the first flow in your project.
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Similarly, if there are multiple flows on a page, default flow tokens only refer to the first
flow. For example, if you have two flows with two titles on the same page, the second title
must use the token {@flow2title@}.
The following tokens are available in Dorico:
General tokens
Description

Token

Page number

{@page@}

Player list

{@playerlist@}

Player names

{@playernames@}

Layout name

{@layoutname@}

Project/Flow-specific information tokens
Field in the Project Info
dialog

Token for Project page

Token for Flow pages

Title

{@projecttitle@}

{@flowtitle@}

Subtitle

{@projectsubtitle@}

{@flowsubtitle@}

Dedication

{@projectdedication@}

{@flowdedication@}

Composer

{@projectcomposer@}

{@flowcomposer@}

Arranger

{@projectarranger@}

{@flowarranger@}

Lyricist

{@projectlyricist@}

{@flowlyricist@}

Artist

{@projectartist@}

{@flowartist@}

Copyist

{@projectcopyist@}

{@flowcopyist@}

Publisher

{@projectpublisher@}

{@flowpublisher@}

Editor

{@projecteditor@}

{@floweditor@}

Copyright

{@projectcopyright@}

{@flowcopyright@}

Work number

{@projectworknumber@}

{@flowworknumber@}

Composer dates

{@projectcomposerdates@}

{@flowcomposerdates@}

Composition year

{@projectcompositionyear@}

{@flowcompositionyear@}

Other information

{@projectotherinfo@}

{@flowotherinfo@}
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TIP
You can also specify the flow to which you want the token to refer. For example, {@flow2title@}.
Time/Date tokens to show when the project was last saved
Time/Date description

Time/Date example

Token

Standard date and time string
(locale dependent)

Sun Dec 31 11:10:12 2017

{@projectdate@}

Four-digit year

2017

{@projectdateyear@}

Two-digit year

17

{@projectdateyearshort@}

Full month name (locale
dependent)

October

{@projectdatemonth@}

Short month name (locale
dependent)

Oct

{@projectdatemonthshort@}

Month as a decimal number,
range 1-12

10

{@projectdatemonthnum@}

Full weekday name (locale
dependent)

Friday

{@projectdateday@}

Abbreviated weekday name
(locale dependent)

Fri

{@projectdatedayshort@}

Day of month as decimal
number, range 1-31

24

{@projectdatedaynum@}

ISO8601 date

2017-12-31

{@projectdateymd@}

Month day, year

December 31, 2017

{@projectdatemdy@}

Day month year

31 December 2017

{@projectdatedmy@}

Time representation (locale
dependent)

11:10:12

{@projectdatetime@}

Hours:minutes, hour in 24hour clock range

23:10

{@projectdatetimeHHMM@}

Hours:minutes, hour in 12hour clock range

11:10

{@projectdatetimeHHMMSS@
}

Hour in 24-hour clock range

23

{@projectdatetimehour24@}

Hour in 12-hour clock range

11

{@projectdatetimehour12@}
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Time/Date description

Time/Date example

Token

Minute as decimal number,
range 00-59

10

{@projectdatetimeminute@}

Second as decimal number,
range 00-59

44

{@projectdatetimesecond@}

Time/Date tokens to show the current time and date
Time/Date description

Time/Date example

Token

Standard date and time string
(locale dependent)

Sun Dec 31 11:10:12 2017

{@date@}

Four-digit year

2017

{@dateyear@}

Two-digit year

17

{@dateyearshort@}

Full month name (locale
dependent)

October

{@datemonth@}

Short month name (locale
dependent)

Oct

{@datemonthshort@}

Month as a decimal number,
range 1-12

10

{@datemonthnum@}

Full weekday name (locale
dependent)

Friday

{@dateday@}

Abbreviated weekday name
(locale dependent)

Fri

{@datedayshort@}

Day of month as decimal
number, range 1-31

24

{@datedaynum@}

ISO8601 date

2017-12-31

{@dateymd@}

Month day, year

December 31, 2017

{@datemdy@}

Day month year

31 December 2017

{@datedmy@}

Time representation (locale
dependent)

11:10:12

{@datetime@}

Hours:minutes, hour in 24hour clock range

23:10

{@datetimeHHMM@}

Hours:minutes, hour in 12hour clock range

11:10

{@datetimeHHMMSS@}

Hour in 24-hour clock range

23

{@datetimehour24@}
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Time/Date description

Time/Date example

Token

Hour in 12-hour clock range

11

{@datetimehour12@}

Minute as decimal number,
range 00-59

10

{@datetimeminute@}

Second as decimal number,
range 00-59

44

{@datetimesecond@}

RELATED LINKS
Inputting text on page 214
Project Info dialog on page 62
Player, layout, and instrument names on page 67

Entering text in text frames
You can enter text in text frames. You can format the text and insert separate paragraphs and
line breaks.
PROCEDURE
1.

Open the text frame into which you want to enter text in any of the following ways:
●

Activate Frames in the Formatting panel, select the text frame, and press Return.

●

Double-click within the text frame.

2.

Enter the text you want.

3.

Optional: Press Return to insert a new paragraph.

4.

Optional: Press Shift-Return to insert a line break.

5.

Optional: Format the text using the text editor options.

6.

Close the text editor in any of the following ways:
●

Press Esc or Ctrl/Cmd-Return.

●

Click outside of the text editor.

RESULT
Text is entered into the text frame.
If you insert a new paragraph or line, the cursor jumps to the beginning of the new paragraph or
line.
RELATED LINKS
Text editor options in Engrave mode on page 281

Moving text manually
In Engrave mode, you can manually move text that you added with the text editor in Write mode.
NOTE
This does not apply to text in text frames.

PROCEDURE
1.

Select the texts that you want to move.
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2.

Move the texts in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The selected texts are moved to new positions.
TIP
Offset in the Common group of the Properties panel is activated automatically when you move
text.
●

Offset X moves text horizontally.

●

Offset Y moves text vertically.

You can also use this property to move text by changing the values in the value fields.
Deactivating the property resets the selected items to their default position.

RELATED LINKS
Text editor options in Engrave mode on page 281
Moving frames on page 245

Changing the horizontal alignment of text in text frames
You can change the horizontal alignment of any text style in text frames, independently of the
paragraph style for that text.
If you change the alignment of text in text frames on master pages, the horizontal alignment of
text is changed on all pages that use those master page formats.
NOTE
Changes to text in text frames on master pages cannot be reset.
If you change the alignment of text in text frames on individual pages, this change is
independent of the paragraph style for that text and also independent of the master page
format. You can later remove any overrides made on individual pages and revert them to the
master page format.
NOTE
Removing overrides removes all changes made to individual pages, not just changes to the
alignment of text in text frames.

PROCEDURE
1.

Optional: If you want to change the horizontal alignment of text on a master page, open
the master page editor.
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2.

3.

Open the text editor for text frame in which you want to change the horizontal alignment
of text in any of the following ways:
●

Activate Frames in the Formatting panel, select the text frame, and press Return.

●

Double-click within the text frame.

Select the text in the text frame whose horizontal alignment you want to change.
TIP
You can apply different paragraph styles to separate paragraphs in the same text frame.

4.

5.

Choose one of the following horizontal alignments in the text editor:
●

Align Left

●

Align Center

●

Align Right

●

Justify

Close the text editor in any of the following ways:
●

Press Esc or Ctrl/Cmd-Return.

●

Click outside of the text editor.

RESULT
The horizontal alignment of the selected text is changed.
NOTE
You can change the horizontal alignment of text styles project-wide in the Paragraph Styles
dialog.

RELATED LINKS
Paragraph Styles dialog on page 276
Customizing master pages on page 236

Resetting changes to text in text frames on individual pages
If you override the paragraph style of text within text frames on individual pages, any changes
you later make to the paragraph style are not applied to the overridden text.
You can reset the changes you made to revert individual pages back to the master page format.
However, this removes all changes made to those pages.
NOTE
You cannot reset changes made to text in text frames on master pages.

RELATED LINKS
Removing master page overrides on page 238

Graphics frames
Graphics frames allow you to load images or illustrations into your score in a variety of formats.
You can load graphic files of the following formats:
●

.jpg or .jpeg

●

.png
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●

.svg

Graphics frame

RELATED LINKS
Loading images into graphics frames on page 261

Loading images into graphics frames
You can load images from your computer or server into your score.
PREREQUISITE
You have added a graphics frame, either to a master page or an individual layout.
PROCEDURE
1.

Double-click in the graphics frame.
The File Explorer/macOS Finder dialog opens.

2.

In the File Explorer/macOS Finder dialog, locate and select the file you want to load into
the graphics frame.

3.

Click Open.

RESULT
The selected image is loaded into the frame.
RELATED LINKS
Graphics frames on page 260

Frame constraints
In Dorico, constraints define the relationship between each of the four sides of a frame and the
corresponding page margins.
Frame constraints lock each side of frames to the corresponding page margin, meaning you can
change the page size, or the area that is defined by the page margin, while keeping the frame in
proportion. For example, a music frame that fills the entire height and width of a page has
constraints on all four sides. All sides have an inset of zero, which means that the edges of the
frames are in line with the page margins. If you change the size of the page, the frame size
changes accordingly so that it always fills the page, whatever the current page size.
NOTE
Page size and margins are set for each layout in Setup > Layout Options.
If you remove a constraint from one side of a frame, that unlocks that side of the frame from the
page margin, meaning you can determine a fixed width/height that prevents that side of the
frame from adjusting, even if the page size changes.
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EXAMPLE
If you have set a frame for a header, you might want the left and right sides to be locked to the
left and right margins of the page. For the top side of the frame, you might want to lock it to the
top margin, but want to keep the height of the header fixed. In this case, you can remove the
lock to the bottom margin and specify a fixed height by moving the side of the frame, or by
entering a value in one of the value fields in the Properties panel.
In the Frames section of the formatting panel, you can define the constraints for all types of
frames that are available in Dorico. All new frames have active constraints on all sides by default.
You can unlock two sides of a frame to specify a fixed width or height. For example, if you
remove the lock to the top margin, you can also remove the lock to the right/left margin.
RELATED LINKS
Defining frame constraints on page 262
Layout Options dialog on page 62

Defining frame constraints
You can determine on which sides of frames you want to apply constraints.
PROCEDURE
1.

Optional: If you want to define frame constraints on a master page, open the master page
in the master page editor.

2.

In the Formatting panel, activate Frames.

3.

In the music area, select the frame for which you want to edit the constraints.

4.

In the Frames section of the Formatting panel, click the constraint that corresponds to the
side of the frame that you want to change.
Locked constraint

5.

Unlocked constraint

Change the constraint in any of the following ways:
●

Move the unlocked side to the required position.

●

In the Frames group of the Properties panel, enter a fixed value for Height or
Width.

RELATED LINKS
Frame constraints on page 261
Formatting panel on page 223

Page layouts
In Dorico, the layout of pages is determined by their margins, the master page applied to them,
any casting off values applied to them, system and frame breaks, and frame padding.
Casting off, meaning the process of determining a set number of bars per system and systems
per page, allows you to fix a regular appearance across entire layouts.
System and frame breaks allow you to adjust layouts on a local level, by determining where
individual system and frame breaks occur.
Frames cannot exceed the boundaries set by the margins of the layout, which you can change on
the Page Setup page in Setup > Layout Options. You can change the size of margins in
millimeters on each edge of each page, and choose one of the following styles of margins:
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●

Same
All pages in the selected layouts have the same margins.

●

Different
Left and right pages in the selected layouts can have completely different margins.

●

Mirrored
Left and right pages in the selected layouts use the same margin values but they
correspond to inside/outside edges of pages.

Music frames in the default master pages have padding that ensures musical material displayed
within the frame remains on the page. For example, if music frames have no padding, the top
line on the top staff in the frame is positioned at the top of the frame. Any notes that require
ledger lines above the staff might then be positioned off the top of the page. You can change the
padding of all music frames in each layout in Layout Options, and change the padding of
individual music frames in Engrave mode using properties in the Properties panel.
Frame constraints are used to lock the edges of frames to edges of pages. This allows a single
master page to be applied to layouts with different paper sizes and remain consistently
proportioned.
RELATED LINKS
Frame constraints on page 261
Master pages on page 230
Master page editor on page 235
Casting off on page 268
Changing page margins on page 263
Changing the padding in music frames individually on page 266
Layouts on page 91
Flows on page 88
Players on page 65

Changing page margins
You can change the page margins of each layout independently, for example, if you want wider
margins for layouts in your project that will be spiral bound.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the page margins in
one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Page Setup from the Category menu.

4.

In the Page Margins section, choose one of the following options for Page margins:
●

Same
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5.

6.

●

Different

●

Mirrored

Optional: Change the margin values in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

Click Apply, then Close.

RESULT
The page margins in the selected layouts are changed. Any frames in the selected layouts with
fixed constraints are automatically moved or resized as required.
RELATED LINKS
Frame constraints on page 261

Changing the page size and orientation
You can change the page size and orientation of each layout independently. For example, you
can use a large, landscape page in full score layouts and a small, portrait page for part layouts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the page size and/or
orientation in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Page Setup from the Category menu.

4.

In the Page Size section, select a page size from the Size menu.
For example, you can select fixed page sizes, such as A3 or Letter, or select Custom to
define your own page size.

5.

6.

Optional: If you selected Custom, change the Width and Height of the page in any of the
following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

Choose one of the following options for Orientation:
●

Portrait

●

Landscape

7.

Optional: Repeat steps 2 to 6 for other layouts whose page size/orientation you want to
change.

8.

Click Apply, then Close.
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RESULT
The page size is changed for all the selected layouts.
NOTE
Changing the page size of layouts might not change the paper size automatically selected for
those layouts in the Print Options panel in Print mode. For example, if your default printer
cannot print the page size selected for layouts, the largest paper size the printer can handle is
selected. Similarly, if you had already set options for printing layouts before changing the page
size in Layout Options, Dorico attempts to preserve your original print options.

Allowing multiple flows on single pages
In part layouts, new flows start on a new page by default, even if the previous flow does not fill its
last page. You can allow new flows to be shown on the same page as previous flows if there is
space, for example, to reduce the number of pages requires for parts in works with multiple
movements.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to allow multiple flows to be
shown on each page in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Page Setup from the Category menu.

4.

In the Flows section, choose Allow on existing page for New flows.

5.

Click Apply, then Close.

RESULT
Flows in the selected layouts continue immediately after each other, including within the same
music frame if there is sufficient space.
NOTE
Music frames are not automatically split to divide flows into separate music frames. You must
insert frame breaks manually to divide flows into separate music frames. You must also manually
insert text frames with tokens for the title of each flow, such as {@flow2title@}.

RELATED LINKS
Text tokens on page 254
Inputting frames on page 244
Casting off on page 268
Changing the flows assigned to layouts on page 92
Changing the players assigned to flows on page 89
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Changing the music frame margins in layouts
You can change the margins in all music frames in individual layouts, for example, if you want
more padding at the top of music frames in part layouts containing lots of notes above the staff.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the music frame
margins in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Page Setup from the Category menu.

4.

In the Music Frame Margins section, change the values for Top and/or Bottom in any of
the following ways:

5.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

Click Apply, then Close.

RESULT
The margins within all music frames in the selected layouts is changed.
RELATED LINKS
Page layouts on page 262

Changing the padding in music frames individually
You can change the padding at the top/bottom of individual music frames, independently of your
setting for music frame margins for the layout.
PROCEDURE
1.

In Engrave mode, activate Frames in the Formatting panel.

2.

Select the music frames whose padding you want to change.

3.

In the Properties panel, activate the following properties, individually or together, in the
Music group:

4.

●

Top padding

●

Bottom padding

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.
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For example, entering 0 for Top padding aligns the top staff line of the top staff in the
frame with the top of the music frame.
RESULT
The padding at the top/bottom of the selected music frames is changed. This only applies to the
layout currently open in the music area.
Deactivating the properties returns the selected music frames to your settings for music frame
margins for the layout.
RELATED LINKS
Changing the music frame margins in layouts on page 266

Changing the justification of final systems
By default in Dorico, the final systems in flows only justify to the full width of the page when they
are more than half full. You can change this setting in each layout independently.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the justification of the
final systems in flows in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Note Spacing from the Category menu.

4.

Optional: If you want the final systems in flows to justify fully always, deactivate Only
justify final system in flow when more than [X] % full.

5.

Optional: If you want to change the minimum fullness of final systems before they justify,
change the value for Only justify final system in flow when more than [X] % full in any
of the following ways:

6.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Click Apply, then Close.

RESULT
The automatic justification of the final systems in flows in the selected layouts is changed.
TIP
You can also change the width of individual systems independently of your default settings by
changing their start/end positions independently.

RELATED LINKS
Changing the start/end position of systems on page 293
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Hiding/Showing empty staves
You can hide/show empty staves differently in each layout in your project. For example, you can
show all staves, including empty staves, in a full score layout for the conductor but hide empty
staves in a full score layout intended for reference only.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to hide/show empty staves in one
of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Vertical Spacing from the Category menu.

4.

In the Hide Empty Staves section, choose one of the following options for Hide empty
staves:
●

After first system

●

All systems

●

Never

5.

Activate/Deactivate Allow individual staves of multi-staff instruments to be hidden.

6.

Optional: For Players excluded from Hide Empty Staves, activate the checkbox beside
each instrument you want to be shown regardless of your choice for Hide empty staves.

7.

Click Apply, then Close.

RESULT
Empty staves in the selected layouts are hidden/shown according to your choice. If you activated
Allow individual staves of multi-staff instruments to be hidden, any single empty staves in
multi-staff instruments, such as piano or harp, can be hidden in the selected layouts.

Casting off
“Casting off” is the term used to encompass fixing the layout of pages of music, such as setting
the number of systems per page. In Dorico, you can fix both the number of bars per system and
the number of systems per music frame for each layout independently.
RELATED LINKS
Fixing the number of bars per system on page 269
Fixing the number of systems per frame on page 269
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Fixing the number of bars per system
You can define a fixed number of bars you want included in each system in each layout in your
project.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to fix the number of bars per
system in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Staves and Systems from the Category menu.

4.

In the Casting Off section, activate Fixed number of bars per system.

5.

Change the number of bars you want in each system in any of the following ways:

6.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Click Apply, then Close.

RESULT
The number of bars automatically contained in each system in the selected layouts is changed.

Fixing the number of systems per frame
You can define a fixed number of systems you want included in each music frame in each layout
in your project. Because the default master pages have a single music frame per page, fixing the
number of systems per frame usually fixes the number of systems per page.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to fix the number of systems per
frame in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Staves and Systems from the Category menu.
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4.

In the Casting Off section, activate Fixed number of systems per page.

5.

Change the number of systems you want in each frame in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

6.

Activate/Deactivate Scale number of systems by frame height.

7.

Click Apply, then Close.

RESULT
The number of systems automatically contained in each music frame in the selected layouts is
changed.
If you activated Scale number of systems by frame height, the number of systems contained in
each frame is adjusted according to the size of the music frame.

Frame breaks
In Dorico, you can use frame breaks to push musical material into the next frame, which is
usually on the next page, meaning you can use frame breaks to create page breaks. For example,
you can use frame breaks to insert page turns at specific positions in part layouts.
Frame breaks are indicated by signposts, which you can hide/show at any time.
NOTE
Frame breaks at the start of frames that were created using Make into Frame have Wait for
next frame break activated in the Format group of the Properties panel by default. When this
property is activated, Dorico creates a frame containing all material between that frame break
and the next frame break. If you later delete subsequent frame breaks, this creates very full
frames with tightly spaced, or overlapping, systems. For example, if you delete all subsequent
frame breaks, all music until the end of the flow is forced into a single frame.
TIP
You can also control the content of music frames by fixing the number of systems per music
frame in each layout.

RELATED LINKS
Inserting frame breaks on page 270
Hiding/Showing frame break signposts on page 272
Fixing the number of systems per frame on page 269

Inserting frame breaks
You can insert frame breaks that allow you to create page turns in particular places in your
music.
PROCEDURE
1.

Select a note or item at the rhythmic position where you want to insert a frame break.
For example, if you select a clef, the clef is placed at the end of the frame, and the notes
are moved to the start of the next music frame.

2.

Insert a frame break in any of the following ways:
●

Press Shift-F.

●

Choose Engrave > Format Music Frames > Frame Break.
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●

Click Insert Frame Break in the Format Music Frames section of the Formatting
panel.

RESULT
A frame break is inserted immediately before the rhythmic position of the earliest selected item.
All notations after the frame break are moved to the next music frame.
RELATED LINKS
Frame breaks on page 270

Making selections into frames
You can make frames that contain all musical material between two selected rhythmic positions.
PROCEDURE
1.

Select an item at the rhythmic position that you want to be the start of the frame.
NOTE
We recommend that you select noteheads or barlines. Selecting other items, such as slurs,
can cause frame breaks to be inserted earlier/later than you might have intended.

2.

3.

Ctrl/Cmd-click one of the following:
●

A notehead that you want to be at the end of the frame

●

An item that you want to be at the start of the next frame

In the Formatting panel, click Make into Frame in the Format Music Frames section.

RESULT
A fixed frame is created by inserting frame breaks at the start/end of your selection. The frame
contains all musical material between the two selected items.
●

If you selected items, such as barlines or slurs, the beginning your first selected item is
positioned at the start of the frame and the end of your last selected item is positioned at
the start of the next frame.

●

If you selected noteheads, the last selected notehead is also included in the frame, rather
than being positioned at the start of the next frame.

●

If you selected ties, all musical material between the first and last notes tie chains is
included in the frame, regardless of where in the tie chains you made selections.

NOTE
The frame break inserted at the start of the selection has Wait for next frame break activated in
the Format group of the Properties panel by default. Because this property tells Dorico to
include all music in the frame until the next frame break, if you later delete subsequent frame
breaks, this can create very full frames with tightly spaced, or overlapping, systems.
Deactivating Wait for next frame break allows Dorico to cast off subsequent music as normal.
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Hiding/Showing frame break signposts
You can hide/show frame break signposts at any time.
PROCEDURE
●

Choose View > Signposts > Frame Breaks.

RESULT
Frame break signposts are shown when a tick appears beside Frame Breaks in this menu, and
hidden when no tick appears beside Frame Breaks.

Deleting frame breaks
You can delete frame breaks after you have inserted them.
PREREQUISITE
Frame break signposts are shown.
PROCEDURE
1.

Select the frame break signposts of the frame breaks you want to delete.

2.

Delete the frame breaks in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RELATED LINKS
Hiding/Showing frame break signposts on page 272

System breaks
System breaks are where musical material must be split across multiple systems or pages in
order to fit on the required paper. Dorico automatically arranges music across systems so that
notes are correctly spaced and legible, but you can also control system breaks manually.
System breaks are indicated by signposts, which you can hide/show at any time.
NOTE
System breaks at the start of systems that were created using Make into System have Wait for
next system break activated in the Format group of the Properties panel by default. When this
property is activated, Dorico creates a system containing all material between that system break
and the next system break or the end of the flow, whichever comes first. If you later delete
subsequent system breaks, this creates very full, tightly spaced systems. For example, if you
delete all subsequent system breaks, all music until the end of the flow is forced into a single
system.
TIP
You can also control the content of systems by fixing the number of bars per system in each
layout.

RELATED LINKS
Inserting system breaks on page 273
Hiding/Showing system break signposts on page 274
Fixing the number of bars per system on page 269
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Inserting system breaks
You can insert system breaks at any rhythmic position.
PROCEDURE
1.

Select a note or item at the rhythmic position where you want to insert a system break.
For example, if you select a clef, the clef is placed at the end of the system, and the notes
are moved to the start of the next system.

2.

Insert a system break in any of the following ways:
●

Press Shift-S.

●

Choose Engrave > Format Systems > System Break.

●

Click Insert System Break in the Format Systems section of the Formatting panel.

RESULT
A system break is inserted immediately before the rhythmic position of the earliest selected item.
All notations after the system break are moved to the next system.
RELATED LINKS
System breaks on page 272

Making selections into systems
You can make systems that contain all musical material between two selected rhythmic positions.
PROCEDURE
1.

Select an item at the rhythmic position that you want to be the start of the system.
NOTE
We recommend that you select noteheads or barlines. Selecting other items, such as slurs,
can cause system breaks to be inserted earlier/later than you might have intended.

2.

3.

Ctrl/Cmd-click one of the following:
●

A notehead that you want to be at the end of the system

●

An item that you want to be at the start of the next system

In the Formatting panel, click Make into System in the Format Systems section.

RESULT
A fixed system is created by inserting system breaks at the start/end of your selection. The
system contains all musical material between the two selected items.
●

If you selected items, such as barlines or slurs, the start of your first selected item is
positioned at the start of the system and the end of your last selected item is positioned at
the start of the next system.

●

If you selected noteheads, the last selected notehead is also included in the system, rather
than being positioned at the start of the next system.

●

If you selected ties, all musical material between the first and last notes tie chains is
included in the system, regardless of where in the tie chains you made selections.
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NOTE
The system break inserted at the start of the selection has Wait for next system break activated
in the Format group of the Properties panel by default. Because this property tells Dorico to
include all music in the system until the next system break or the end of the flow, if you later
delete subsequent system breaks, this can create very full, tightly spaced systems.
Deactivating Wait for next system break allows Dorico to cast off subsequent music as normal.

Hiding/Showing system break signposts
You can hide/show system break signposts at any time.
PROCEDURE
●

Choose View > Signposts > System Breaks.

RESULT
System break signposts are shown when a tick appears beside System Breaks in this menu, and
hidden when no tick appears beside System Breaks.

Deleting system breaks
You can delete system breaks after you have inserted them.
PREREQUISITE
System break signposts are shown.
PROCEDURE
1.

Select the system break signposts of the system breaks you want to delete.

2.

Delete the system breaks in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RELATED LINKS
Hiding/Showing system break signposts on page 274

Text formatting
Dorico combines different settings for the appearance of text, meaning that you can format fonts
and texts in different places depending on their function.
For example, you can change the font family used for all text in your project in the Edit Font
Styles dialog, and then make specific changes for when that font is used for titles in the
Paragraph Styles dialog.
Paragraph styles apply to whole text frames or all text within a single text object. Character styles
apply to individual selections, meaning you can apply different character styles to each word
within the same text frame.
Font styles apply to items that use text but are not text frames or text objects, such as tempo
marks and dynamics.
RELATED LINKS
Edit Font Styles dialog on page 275
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Paragraph Styles dialog on page 276
Character Styles dialog on page 279
Text editor options in Engrave mode on page 281

Edit Font Styles dialog
In the Edit Font Styles dialog, you can change certain aspects of fonts used for items that you
cannot edit using the text editor, such as changing the font size of bar numbers.
●

You can open the Edit Font Styles dialog in Engrave mode by choosing Engrave > Font
Styles.

The Edit Font Styles dialog contains fonts that are used in Dorico that you cannot edit directly in
the music area, unlike text in text frames, which you can edit using the text editor.

Edit Font Styles dialog

Font style
Allows you to select different font styles in order to change aspects of the font.
Font family
Sets the overall font style.
Size
Sets the size of the font.
Staff-relative/Absolute
Allows you to choose whether the size of the font changes according to the staff size
of the layout, or whether it is always the set size.
Style
Sets the appearance of the font from the following options:
●

Regular

●

Italic

●

Bold

●

Bold Italic

Underlined
Fonts appear underlined when Underlined and the corresponding checkbox are
both activated.
NOTE
●

These options must be activated before you can change them.
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●

Changes made to font styles apply project-wide, including in part layouts.

Music Fonts dialog
In the Music Fonts dialog, you can change the font used for notations and glyphs project-wide.
However, any font you use for notations and glyphs must be SMuFL-compliant.
●

You can open the Music Fonts dialog in Engrave mode by choosing Engrave > Music
Fonts.

Music Fonts dialog

The dialog contains all available SMuFL fonts you have installed on your computer that have the
appropriate metadata for Dorico to recognize them.
Changing the music font used in the Music Fonts dialog changes the fonts used for notations,
glyphs, and other items that are not text, such as clefs, dynamics, and bold tuplet numbers/
ratios. You can change the fonts used for these items individually in the Edit Font Styles dialog.
NOTE
Certain items that are marked as optional in SMuFL fonts, such as clef changes and non-bold
tuplet numbers/ratios, are not affected when you change the music font.

RELATED LINKS
Edit Font Styles dialog on page 275

Paragraph Styles dialog
In the Paragraph Styles dialog, you can change paragraph styles for text and create new styles.
You can later use different paragraph styles in different places in your project by choosing them
in the text editor.
For example, you can customize the paragraph style for layout names and then apply your layout
name paragraph style to every text frame in which you show layout names. This allows you to
keep the presentation of different types consistent across your project.
●

You can open the Paragraph Styles dialog in Engrave mode by choosing Engrave >
Paragraph Styles.
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Paragraph Styles dialog

The Paragraph Styles dialog contains the following sections and options:
1

List of paragraph styles currently available.

2

Name
Allows you to enter a name for new paragraph styles or edit the name of existing
paragraph styles.

3

Parent
Allows you to choose a parent paragraph style from which the selected paragraph style
inherits settings.

4

Font appearance options
Allow you to change parameters of the appearance of the paragraph style font, such as
changing the font, making the font bold, changing the size of the font, and changing the
letter or word spacing. You can also make the font in paragraph styles appear underlined
or overlined.

5

Paragraph layout options
Allow you to change the layout of the paragraph style, such as indenting the first line in
each paragraph and changing the alignment of text.

6

Color options
Allow you to change the foreground and background colors of the paragraph style.

7

Controls
Allow you to make changes to the collection of paragraph styles. The following controls are
available:
●

New
Allows you to create a new paragraph style with default values.

●

New from Selection
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Creates a new style based on the selected one. Initially no values are overridden but
you can change options for your new style.
●

Save as Default
Copies the selected style to your library so that it is available in other projects.

●

Revert to Factory
Allows you to undo your local changes to predefined paragraph styles and revert the
style to its original settings.

●

Delete
Deletes the selected style.
NOTE
You cannot delete predefined paragraph styles or any paragraph style that is
currently used in your project.

Creating paragraph styles
You can create new paragraph styles that you can use in your project, for example, to format text
consistently in multiple text frames.
PROCEDURE
1.

In Engrave mode, choose Engrave > Paragraph Styles.
The Paragraph Styles dialog opens.

2.

At the bottom of the paragraph style list, click New.

3.

Enter a name for the style in the Name field.

4.

Optional: Select one of the available styles from the Parent menu.
If you select a parent style, an activated slider is shown beside all the options that the new
style can inherit from the parent style. You can deactivate these if you want.

5.

Change the options you want for the new style.

6.

Click OK to save your changes and close the dialog.

Creating paragraph styles based on other styles
You can create paragraph styles that are based on other styles.
PROCEDURE
1.

In Engrave mode, choose Engrave > Paragraph Styles.
The Paragraph Styles dialog opens.

2.

In the paragraph style list, select the style on which you want to base a new paragraph
style.

3.

Click New From Selection.

4.

Enter a name for the new style in the Name field.

5.

Optional: Select a different style from the Parent menu.
All options from parent style are set automatically for the new style. All options show
deactivated sliders, which means that they are inherited from the parent style.

6.

Activate each option that you want to override and make your changes.

7.

Click OK to save your changes and close the dialog.
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Deleting paragraph styles
You can delete paragraph styles you have created. However, you cannot delete any of the default
paragraph styles.
PROCEDURE
1.

In Engrave mode, choose Engrave > Paragraph Styles.
The Paragraph Styles dialog opens.

2.

In the paragraph style list, select the style that you want to delete.
NOTE
You cannot delete any of the default paragraph styles.

3.

Click Delete.

4.

Click OK to save your changes and close the dialog.

Character Styles dialog
In the Character Styles dialog, you can change character styles and create new styles. You can
later apply character styles to individual letters or words in different places in your project by
choosing them in the text editor.
For example, you can create a custom character style with wide letter spacing for specific words
and then apply that character style to selected words that you want to have wider letter spacing.
Unlike paragraph styles, character styles do not have to apply to whole text frames or text
objects.
●

You can open the Character Styles dialog in Engrave mode by choosing Engrave >
Character Styles.

Character Styles dialog

The Paragraph Styles dialog contains the following sections and options:
1

List of character styles currently available.

2

Name
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Allows you to enter a name for new character styles or edit the name of existing paragraph
styles.
3

Character style options
Allow you to change parameters of the character style, such as changing the font, making
the font bold, changing the size of the font, and changing the letter or word spacing. You
can also make the font in paragraph styles appear underlined or overlined, and change
the vertical alignment of characters.

4

Color options
Allow you to change the foreground and background colors of the character style.

5

Controls
Allow you to make changes to the collection of character styles. The following controls are
available:
●

New
Allows you to create a new character style with default values.

●

New from Selection
Creates a new style based on the selected one. Initially no values are overridden but
you can change options for your new style.

●

Save as Default
Copies the selected style to your library so that it is available in other projects.

●

Revert to Factory
Allows you to undo your local changes to predefined character styles and revert the
style to its original settings.

●

Delete
Deletes the selected style.
NOTE
You cannot delete predefined character styles or any character style that is currently
used in your project.

Creating character styles
You can create new character styles.
PROCEDURE
1.

In Engrave mode, choose Engrave > Character Styles.
The Character Styles dialog opens.

2.

Create a new character style in the Character Styles dialog in any of the following ways:
●

Click New.

●

Select a style in the styles list and click New From Selection.
NOTE
This copies all the options from the selected style.

3.

Enter a name for the style in the Name field.

4.

Activate each option that you want to change and make your changes.
IMPORTANT
Only activated options have an effect on the text. If you deactivate options, their settings
are deleted.
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5.

Click OK to save your changes and close the dialog.

Deleting character styles
You can delete character styles.
PROCEDURE
1.

In Engrave mode, choose Engrave > Character Styles.
The Character Styles dialog opens.

2.

Select the style that you want to delete in the styles list.

3.

Click Delete.

4.

Click OK to save your changes and close the dialog.

Text editor options in Engrave mode
The text editor allows you to add and format text.
The text editor opens in the following circumstances:
●

You add or change text that is attached to a staff.

●

You enter text within a text frame.

Text editor pop-up in Engrave mode

The text editor provides the following options:
1

Paragraph Style
Determines the appearance and alignment of the text for a whole paragraph.
NOTE
Text that is attached to a staff is always treated as a single paragraph.

2

Character Style
Determines the appearance of selected text.
NOTE
If you use one of the defined character styles in the text editor, the appearance that is
defined by the selected paragraph style is overridden.

3

Font
Allows you to change the font family of selected text.

4

Font Style
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Allows you to change the font style of selected text.
5

Font Size
Allows you to change the size of selected text.

6

Font Stretch
Allows you to make selected text wider or narrower.

7

Baseline Shift
Allows you to gradually shift the baseline of selected text up or down.

8

Letter Spacing
Allows you to increase/decrease the space between the characters of selected text.

9

Word Spacing
Allows you to increase/decrease the space between the words of selected text.

10

Foreground Color
Allows you to change the foreground color of selected text.

11

Background Color
Allows you to change the background color of selected text.

12

Alignment
Allows you to choose the alignment of selected text relative to the rhythmic position of the
text in the score. For text in a text frame, the text is aligned along the left margin of a text
frame.
You can choose from the following alignments:

13

●

Alignment Left

●

Alignment Center

●

Alignment Right

●

Justify

Line Types
Allows you to show any of the following types of lines, in any combination, on selected
text:

14

●

Underline

●

Overline

●

Strikethrough

Script Types
Allows you to position selected text in one of the following positions relative to the text on
the baseline:
●

Superscript

●

Subscript

RELATED LINKS
Inputting text on page 214
Entering text in text frames on page 258
Paragraph Styles dialog on page 276
Character Styles dialog on page 279
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Changing the paragraph style of text
You can change the paragraph style that is applied to text added to staves and within individual
text frames, including on master pages. For example, if you want to use one paragraph style for
page numbers in full score layouts and another for page numbers in part layouts.
PREREQUISITE
You have created a new paragraph style if you want to use a different paragraph style to the
ones provided by default.
PROCEDURE
1.

Optional: If you want to change the paragraph style of text on a master page, open the
master page editor.

2.

Open the text editor for the text/text frame in which you want to change the paragraph
style in any of the following ways:

3.

●

Activate Frames in the Formatting panel, select the text frame, and press Return.

●

Double-click within the text frame.

Select the text whose paragraph style you want to change.
TIP
You can apply different paragraph styles to separate paragraphs in the same text frame.

4.

In the text editor pop-up, select a paragraph style.

5.

Close the text editor in any of the following ways:
●

Press Esc or Ctrl/Cmd-Return.

●

Click outside of the text editor.

RESULT
The paragraph style of the selected paragraphs is changed. For example, if you select a single
word, the whole paragraph containing that word is changed.
RELATED LINKS
Text editor options in Engrave mode on page 281
Paragraph Styles dialog on page 276
Creating paragraph styles on page 278

Changing the placement of text relative to the staff
You can position added text above or below the staves. Text is automatically positioned to ensure
that it does not collide with other objects.
PREREQUISITE
The text editor is closed.
PROCEDURE
1.

Select the text whose placement relative to the staff you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, choose one of the following options for Position in the Text
group:
●

Above

●

Below
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RESULT
The selected texts appear above/below the staff.
AFTER COMPLETING THIS TASK
If you need to move the text to a different graphical position, you can drag the text manually in
Engrave mode.

Note spacing
The positions of notes relative to each other, and the automatic gaps between notes, are known
as note spacing.
You can change note spacing in your project in the following ways:
●

Change the default note spacing project-wide in each layout in Layout Options.

●

Change the note spacing from a specified point in individual frame chains in individual
layouts.

●

Change the note spacing at individual rhythmic positions and for individual notes.

Note spacing changes project-wide
You can change the default note spacing values for each layout independently on the Note
Spacing page in Layout Options.
The options available include changing the default space for quarter notes (crotchets) and the
scale space for grace notes and cues. You can also change the minimum percentage value for
how full final systems must be before they are justified.
You can open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options at the bottom of the Layouts panel in Setup mode.

●

Right-click an instrumental part or a full score in the Layouts panel and choose Layout
Options from the context menu.

Note spacing changes from specific points in layouts
In Engrave mode, you can open the Note Spacing Change dialog and change or reset values
affecting the spacing and scaling of notes.
Changes you make in the Note Spacing Change dialog only apply to the selected layout, and to
the frame chain containing the item selected when you made the note spacing change. The
preview in the dialog updates in real time as you change values, allowing you to see the effect
the changes will have in your project.
Signposts are shown at rhythmic positions where you have made changes to note spacing using
the Note Spacing Change dialog.

Note spacing at individual rhythmic positions and of individual notes
You can make individual spacing adjustments and move individual notes graphically when Note
Spacing is activated in the Formatting panel on the left of the window in Engrave mode. When
Note Spacing is activated, dashed lines representing spacing columns and handles for each
spacing-significant item appear.
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Handles and dashed lines are shown when Note Spacing is activated.

Each rhythmic position that contains a significant item, such as notes, grace notes, rests, clefs,
key signatures, and time signatures, can be adjusted using the square note spacing handles.
Note spacing handles allow you to adjust the spacing of the selected rhythmic position, which
changes the position of everything at that rhythmic position.
Selecting square note spacing handles above items, such as noteheads, causes a circular handle
to appear. Circular handles allow you to adjust the graphical position of that individual item,
independently of its rhythmic position.
Additionally, larger square system handles are shown at the start/end of each system when Note
Spacing is activated, allowing you to adjust the start/end horizontal position of individual
systems. System handles are positioned on the top left and bottom right corners of each system.
When note spacing handles have been moved, their color changes.
NOTE
When Note Spacing is activated, you cannot make any selections or make other types of edits to
items in the current layout. To resume normal selection and editing, deactivate Note Spacing or
return to Write mode.

RELATED LINKS
Adjusting note spacing at individual rhythmic positions on page 291
Adjusting the spacing of individual notes/items independently of their rhythmic positions on
page 292
Changing the start/end position of systems on page 293
Layout Options dialog on page 62
Note Spacing Change dialog on page 287
Removing individual changes to note spacing on page 294

Note Spacing page in Layout Options
On the Note Spacing page in Layout Options, you can change the default values for note
spacing project-wide in each layout independently. You can also change how full the final system
in flows must be before it is automatically justified.
●

You can access the Note Spacing page by opening Layout Options and selecting Note
Spacing from the Category menu.
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Options on the Note Spacing page in Layout Options

The Note Spacing page in Layout Options contains the following options:
Default space for crotchet/quarter note
Sets the default note spacing for quarter notes (crotchets). The spacing of other
durations is scaled proportionally.
The note spacing value for each duration is shown in the preview, which is updated
as you change values. Increasing the value increases note spacing, decreasing the
value decreases note spacing.
Minimum space for short notes
Sets the minimum note spacing for notes with short durations. This can be
independent of the default note spacing value.
Custom spacing ratio
Sets the spacing of notes in relation to other notes according to their rhythmic
values. For example, setting Custom spacing ratio to 2 means half notes (minims)
take up twice as much space as quarter notes, and eighth notes (quavers) take up
half as much space as quarter notes.
Scale space for grace notes by
Sets the note spacing for grace notes as a percentage of the note spacing normally
used for notes of their duration. The value cannot be greater than 100%. Increasing
the value increases the note spacing for grace notes, decreasing the value decreases
the note spacing for grace notes.
Scale space for cue notes by
Sets the note spacing for cues as a percentage of the note spacing normally used for
notes of their duration. The value cannot be greater than 100%. Increasing the value
increases the note spacing for cues, decreasing the value decreases the note spacing
for cues.
Only justify final system in flow when more than [X] % full
Allows you to change how full the final system in each flow must be before it is
justified to the full width of the frame. By default, final systems that are 50 % full or
less are not justified.
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Use optical spacing for beams between staves
When activated, stems in cross-staff beams are evenly spaced, which can mean the
noteheads are unevenly spaced. When deactivated, noteheads in cross-staff beams
are evenly spaced, which can mean stems appear unevenly spaced.
RELATED LINKS
Changing the default note spacing on page 289
Optical spacing for cross-staff beams on page 412

Note Spacing Change dialog
You can use the Note Spacing Change dialog to change or reset values affecting the spacing
and scaling of notes from specific points in layouts, including the scale factor for grace notes and
cues.
●

You can open the Note Spacing Change dialog in Engrave mode by choosing Engrave >
Note Spacing Change.

Note Spacing Change dialog

The Note Spacing Change dialog contains the following options:
Default space for crotchet/quarter note
Sets the default note spacing for quarter notes (crotchets). The spacing of other
durations is scaled proportionally.
The note spacing value for each duration is shown in the preview, which is updated
as you change values. Increasing the value increases note spacing, decreasing the
value decreases note spacing.
Minimum space for short notes
Sets the minimum note spacing for notes with short durations. This can be
independent of the default note spacing value.
Custom spacing ratio
Sets the spacing of notes in relation to other notes according to their rhythmic
values. For example, setting Custom spacing ratio to 2 means half notes (minims)
take up twice as much space as quarter notes, and eighth notes (quavers) take up
half as much space as quarter notes.
Scale space for grace notes by
Sets the note spacing for grace notes as a percentage of the note spacing normally
used for notes of their duration. The value cannot be greater than 100%. Increasing
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the value increases the note spacing for grace notes, decreasing the value decreases
the note spacing for grace notes.
Scale space for cue notes by
Sets the note spacing for cues as a percentage of the note spacing normally used for
notes of their duration. The value cannot be greater than 100%. Increasing the value
increases the note spacing for cues, decreasing the value decreases the note spacing
for cues.
Each option has an activation switch, meaning you can only change values for options that you
have chosen to change.
You can then choose one of the following options for what sort of note spacing change you want
to make:
Reset
Resets note spacing to your project-wide setting for note spacing in the layout, as set
on the Note Spacing page in Layout Options.
Change
Changes note spacing in the layout to the values set.
RELATED LINKS
Note spacing on page 284

System fullness indicator
The system fullness indicator is a highlighted region in the right page margin that is shown when
Note Spacing is activated. The system fullness indicator tells you how full the system is, using
both colors and percentages to indicate the fullness of the system.
The following colors are used in the system fullness indicator:
●

Green: the system is comfortably full. Notes have enough horizontal space to be legible
but are not too far apart. Systems that are 60-100% full are considered comfortably full.

●

Purple: the system is under-full, meaning notes might appear overly stretched. Systems
that are less than 60% full are considered under-full.

●

Red: the system is over-full, meaning notes might appear squashed with not enough
horizontal space between them. Systems that are more than 100% full are considered
over-full.

The fullness of systems is also expressed using a percentage. The percentage indicated is
calculated by dividing the number of spaces occupied in the system by the total number of
available spaces in the system, which is measured from the start of the rhythmic space to the
right of the initial clef/time signature/key signature up to the final barline in the system.
Both the color of the system fullness indicator and the fullness percentage are updated in real
time as you adjust note spacing in the system.
System comfortably full

System under-full

System over-full

RELATED LINKS
Adjusting note spacing at individual rhythmic positions on page 291
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Changing the default note spacing
You can change the default note spacing in each layout independently. For example, you can
have tighter note spacing in full score layouts compared to part layouts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change note spacing in one of
the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Note Spacing from the Category menu.

4.

Change the values for the options you want to change in any of the following ways:

5.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

Click Apply, then Close.

RESULT
The default note spacing is changed project-wide in the selected layouts.
RELATED LINKS
Note Spacing page in Layout Options on page 285

Changing note spacing from specific points
You can change note spacing values from a specified point onwards in the layout currently open
in the music area, including changing the scale factor for grace notes and cues.
PROCEDURE
1.

In the music area, open the layout in which you want to change note spacing.

2.

Select an item at the rhythmic position from which you want to change note spacing, and
in the frame chain to which you want the changes to apply.

3.

Choose Engrave > Note Spacing Change.
The Note Spacing Change dialog opens.

4.

Activate the note spacing options you want to change.

5.

Choose Change for each activated option.

6.

Change the value in the value field for each note spacing option you want to change in any
of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.
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7.

Click OK to save your changes and close the dialog.

RESULT
Note spacing is changed from the selected rhythmic position onwards. This applies to the frame
chain containing the selected item and the layout currently open in the music area.
A signpost is shown at the position of the note spacing change.
RELATED LINKS
Note spacing on page 284
Note Spacing Change dialog on page 287

Resetting note spacing from specific points
You can reset note spacing values after previously changing them in the layout using the Note
Spacing Change dialog. This applies from a specified point onwards in the layout currently open
in the music area.
PROCEDURE
1.

In the music area, open the layout in which you want to reset note spacing from a specific
point.

2.

Select an item at the rhythmic position from which you want to reset note spacing, and in
the frame chain to which you want the changes to apply.

3.

Choose Engrave > Note Spacing Change to open the Note Spacing Change dialog.

4.

Activate the note spacing options you want to reset.

5.

Choose Reset for each activated option.

6.

Click OK to save your changes and close the dialog.

RESULT
Note spacing is reset to your project-wide settings for the activated options from the selected
rhythmic position onwards. This applies to the frame chain containing the selected item and the
layout currently open in the music area.
A signpost is shown at the position of the note spacing change.
RELATED LINKS
Note spacing on page 284
Note Spacing Change dialog on page 287

Deleting note spacing changes at specific points
You can delete note spacing changes you have made using the Note Spacing Change dialog.
PROCEDURE
1.

Select the signpost of the note spacing change you want to delete.

2.

Delete the note spacing change in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The note spacing change is deleted. Note spacing returns to your project-wide settings for the
layout until the next existing note spacing change or until the end of the project, whichever first.
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Adjusting note spacing at individual rhythmic positions
You can make adjustments to the note spacing at individual rhythmic positions independently of
your project-wide settings.
NOTE
●

Moving notes far away from their intended rhythmic positions can be misleading for
players reading the music.

●

When Note Spacing is activated, you cannot make select or edit anything other than note
spacing handles. To resume normal selection and editing, deactivate Note Spacing or
return to Write mode.

PROCEDURE
1.

In the Formatting panel, activate Note Spacing.

2.

Select a square handle on the dashed line at each rhythmic position whose spacing you
want to adjust.

3.

Move the selected handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.
This increases the space to the left of the rhythmic position of each selected handle.

●

Press Alt-Left Arrow to move them to the left.
This decreases the space to the left of the rhythmic position of each selected handle.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

NOTE
You cannot move note spacing handles with the mouse, you can only move them using the
keyboard.

RESULT
The selected note spacing handles are moved, which increases/decreases the spacing to the left
of their original rhythmic position. This also affects the spacing of each selected rhythmic
position on all staves in the system.
System breaks are automatically inserted at the start/end of the system in which you adjusted
note spacing.
NOTE
You cannot select/delete system break signposts when Note Spacing is activated.
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EXAMPLE

Moving note spacing handles to the left reduces
spacing to the left of the rhythmic position
Moving note spacing handles to the right increases
spacing to the left of the rhythmic position

RELATED LINKS
Note spacing on page 284
Layout Options dialog on page 62
Project-wide engraving options for notes on page 571
Adjusting the spacing of individual notes/items independently of their rhythmic positions on
page 292
Removing individual changes to note spacing on page 294
Signposts on page 106
Hiding/Showing system break signposts on page 274

Adjusting the spacing of individual notes/items independently of their rhythmic
positions
You can change the graphical position of individual notes and some other items, such as key
signatures, time signatures, and clefs, independently of their rhythmic positions.
PROCEDURE
1.

In the Formatting panel, activate Note Spacing.

2.

Select the square handle at the rhythmic position of the note/item you want to move
graphically.

A circular handle appears beside the note/item.
3.

4.

Select the circular handle beside the note/item in any of the following ways:
●

Press Tab to switch between having the square and circular handle selected.

●

Click the circular handle.

Move the handle in any of the following ways:
●

Press Alt-Right Arrow to move it to the right.

●

Press Alt-Left Arrow to move it to the left.
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TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.
NOTE
You cannot move note spacing handles with the mouse, you can only move them using the
keyboard.

RESULT
The graphical position of the selected note/item is changed without changing the note spacing of
its rhythmic position.
EXAMPLE

RELATED LINKS
Note spacing on page 284

Changing the start/end position of systems
You can change the start/end horizontal position of each system individually, for example, if you
want to indent a single system.
NOTE
●

If you want to change the start position of systems because you want to increase the space
before staff labels, you can change the minimum indent for systems with staff labels
project-wide for each layout independently on the Staves and Systems page in Setup >
Layout Options.

●

If you want to change the end position of systems because they do not fill the entire width
of the page, you can change the minimum fullness for justification on the Note Spacing
page in Layout Options.

●

If you want to change the width of all systems on a page by the same amount, you can
change the width of the music frame.

PROCEDURE
1.

In the Formatting panel, activate Note Spacing.

2.

Select the system handle at the start/end of each system whose start/end position you
want to change.

3.

Move the system handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.
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●

Press Alt-Left Arrow to move them to the left.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

NOTE
You cannot move note spacing handles with the mouse, you can only move them using the
keyboard.

RESULT
The start/end position of the selected systems is changed. Notes on the selected systems appear
more/less tightly spaced, depending on whether moving the system handles made their system
narrower/wider.
RELATED LINKS
Changing the justification of final systems on page 267
System indents on page 709
Changing the first system indent on page 709
Changing the minimum indent for systems with staff labels on page 695

Removing individual changes to note spacing
You can remove changes you have made to the note spacing at individual rhythmic positions and
reset note spacing handles to their original default positions.
PROCEDURE
1.

In the Formatting panel, activate Note Spacing.

2.

Select the note spacing handles you want to restore to their original positions.

3.

Reset their positions in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RELATED LINKS
Note spacing on page 284

Staff spacing
The positions of staves relative to each other, and the automatic gaps between staves, are known
as staff spacing.
You can change staff spacing in your project in the following ways:
●

Change the default staff spacing project-wide in each layout in Layout Options.

●

Change the staff spacing between individual staves.

Staff spacing changes project-wide
You can change the default values between staves for each layout independently on the Vertical
Spacing page in Layout Options.
The options available include changing the default ideal gap between individual staves, between
staves and bracketed groups, between staves in a braced group, such as for piano or harp, and
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between separate systems. You can also change how full pages must be before systems are
automatically justified across the full height of the page, and change when empty staves are
hidden.
You can open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options at the bottom of the Layouts panel in Setup mode.

●

Right-click an instrumental part or a full score in the Layouts panel and choose Layout
Options from the context menu.

Individual staff spacing changes
You can make adjustments to the vertical position of individual staves when Staff Spacing is
activated in the Formatting panel on the left of the window in Engrave mode. When Staff
Spacing is activated, the following handles are shown:
●

A smaller square staff spacing handle on the bottom left corner of each staff.

●

A larger square system spacing handle on the top left corner of the top staff in each
system.

System spacing handle and staff spacing handle in Engrave mode when Staff Spacing is activated

Staff spacing handles allow you to adjust the vertical position of the selected staves. The gap
between staves in millimeters is shown, and you can click these numbers to change the gaps
between staves by a specific measurement. System handles allow you to adjust the vertical
position of whole systems.
When staff spacing handles have been moved, their color changes. If you move system handles,
both the square handle and the highlighted strip at the top of the system change color.
You can copy manual changes you have made to the staff spacing on individual pages to other
pages in the layout.
NOTE
When Staff Spacing is activated, you cannot make any selections or make other types of edits to
items in the current layout. To resume normal selection and editing, deactivate Staff Spacing or
return to Write mode.

RELATED LINKS
Staves on page 700
Brackets and braces on page 422
Moving individual staves/systems vertically on page 296
Copying staff spacing changes to other pages on page 297
Hiding/Showing empty staves on page 268
Changing the players assigned to layouts on page 92
Changing the players assigned to flows on page 89
Changing the flows assigned to layouts on page 92
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Moving individual staves/systems vertically
You can change the spacing of individual staves by changing the vertical position of individual
staves and systems independently of your project-wide settings.
PROCEDURE
1.

In the Formatting panel, activate Staff Spacing.
NOTE
When using the mouse, you can only move one staff/system at a time.

2.

Select one of the following on each staff/system you want to move vertically:
●

Staff spacing handle

●

System spacing handle

TIP
You can switch between having a staff or system spacing handle selected by pressing Tab.
3.

Move the selected staves/systems in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●

Click and drag a single staff/system spacing handle upwards/downwards.

RESULT
The vertical position of the selected staves/systems is changed. The color of the handles is
changed to indicate that you have moved them.
EXAMPLE

Staff spacing handles at their default positions

RELATED LINKS
Staff spacing on page 294
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Removing individual changes to staff spacing on page 297

Removing individual changes to staff spacing
You can remove changes you have made to the staff/system spacing and reset staff/system
spacing handles to their original default positions.
PROCEDURE
1.

In the Formatting panel, activate Staff Spacing.

2.

Select the staff/system handles you want to restore to their original positions.

3.

Reset their positions in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

Moving multiple systems equally
You can move multiple systems at the same time so that the gaps between each system remain
equal. This is also known as “concertina dragging”.
NOTE
You can only move multiple systems closer together, you cannot use this method to make them
further apart.

PROCEDURE
1.

In the Formatting panel, activate Staff Spacing.

2.

Select the system handle on the system below which you want to move systems closer
together.

●
3.

Alt-click and drag the system handle downwards.

RESULT
All systems below the selected system, until the bottom of the music frame, are moved closer
together. The gaps between each system remain equal.
RELATED LINKS
Staff spacing on page 294

Copying staff spacing changes to other pages
You can copy manual staff spacing changes you have made on individual pages to other pages in
the layout.
PROCEDURE
1.

In the music area, open the layout in which you want to copy staff spacing from one page
to other pages.

2.

In the Formatting panel, activate Staff Spacing.

3.

Click Copy Staff Spacing.
The Copy Staff Spacing dialog opens.
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4.

5.

6.

7.

Change From page in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

Change To page start in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

Change To page end in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

Click OK to save your changes and close the dialog.

RELATED LINKS
Moving individual staves/systems vertically on page 296
Copy Staff Spacing dialog on page 298

Copy Staff Spacing dialog
In the Copy Staff Spacing dialog, you can choose pages whose individual staff spacing changes
you want to copy. You can specify the pages in the layout to which you want to copy the staff
spacing changes.
●

You can open the Copy Staff Spacing dialog in Engrave mode by activating Staff Spacing
in the Formatting panel and clicking Copy Staff Spacing.

The Copy Staff Spacing dialog contains the following options:
From page
Allows you to change the page whose staff spacing you want to copy by specifying
the page number.
To page start
Sets the first page in the layout to which staff spacing changes are copied.
To page end
Sets the last page in the layout to which staff spacing changes are copied.
For example, if you wanted to copy staff spacing changes you made on the first page to the next
three pages, meaning pages two, three, and four, but not to page five and onwards, you would
set To page start to 2 and To page end to 4.
Each option shows the displayed page number beside the value field, so that if you have changed
the displayed page number of pages within the layout you can still be sure of the page to which
you are copying staff spacing changes.
RELATED LINKS
Copying staff spacing changes to other pages on page 297
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Play mode allows you to set up your project for playback. You can assign VST instruments, adjust
the mix, and change the sounding duration of notes in playback without affecting their notated
duration.

Project window in Play mode
The project window in Play mode contains the default toolbar and the event display, and also a
toolbox and panels that contain all the tools and functions that allow you to set up your project
for playback.
You can switch to Play mode in any of the following ways:
●

Press Ctrl/Cmd-4.

●

Click Play in the toolbar.

●

Choose Window > Play.

Toolbox and panels in Play mode

NOTE
There is no Properties panel in Play mode.
The following toolboxes, panels, and areas are available:
1

Play toolbox
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Contains tools that allow you to select and edit note events in the event display.
2

Tracks
Shows tracks for each instrument being played in the selected flow. You can open different
flows in the event display by selecting the one you want to open from the menu at the top
of the tracks.

3

VST and MIDI Instruments panel
Allows you to load new VST and MIDI instruments. You can also select existing VST and
MIDI instruments and edit their settings.

Play toolbox
The Play toolbox contains tools that allow you to select and edit the note events in the event
display in Play mode.
Played Durations

Allows you to change when notes start/end in playback without affecting their
notated durations. When Played Durations is selected, the played durations of notes
are shown as a lighter event, above a thinner line that shows the notated duration of
notes.
Notated Durations

Allows you to change the rhythmic duration of notes, which affects the position and
notation of those notes. When Notated Durations is selected, the full, notated
durations of notes are shown as single events in the piano roll editor.
Object Selection

Allows you to select notes in the piano roll editor. Select Object Selection to deselect
Erase.
You can also select Object Selection by pressing S.
Draw

Allows you to add and edit notes. You can click and drag in the piano roll editor to
input notes with the durations you want. The ends of the notes you draw snap to
rhythmic positions according to the current rhythmic grid value.
You can also select Draw by pressing D.
Draw Percussion

Allows you to add notes to percussion staves in the piano roll editor with one click.
You do not have to click and drag to a duration when using Draw Percussion.
Erase

Allows you to delete notes. You can make marquee selections to delete multiple
notes when Erase is selected.
You can also select Erase by pressing E.
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RELATED LINKS
Slurs in playback on page 688

Tracks
In Play mode, every instrument in your score is represented by an instrument track, and each
player is represented by a player track. There is also a chord symbols track which you can assign
to a VST or MIDI instrument in order to hear chords in playback.
The name of each player track uses the layout name given to that player in Setup mode.
Each track has two layers of disclosure arrows:
●

Clicking the first disclosure arrow reveals the instruments the player holds.

●

Clicking the disclosure arrow on each instrument shows the instrument track header and
piano roll editor or drum editor, as appropriate for that instrument.

Player tracks

Expanded player track
showing instrument tracks

Expanded instrument track

RELATED LINKS
Instrument track headers on page 301
Chords track on page 302
Playing techniques tracks on page 302
Expanding/Collapsing instrument and player tracks on page 303
Instrument names in staff labels on page 691

Instrument track headers
Each instrument in your project has its own instrument track header, including when a single
player holds multiple instruments.

Example instrument track header including Playing Techniques track header

Each instrument track header contains the following controls:
VST or MIDI Instrument menu
Allows you to select an instance of a VST or MIDI instrument to use for the
instrument track.
Slot menu
Allows you to select the slot in the selected VST or MIDI instrument that you want to
use for the instrument track.
NOTE
The same menu selects a channel for MIDI instruments.
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Mute
Mutes the track so it is not included in playback.
Solo
Solos the track so that it is the only track included in playback. All other tracks are
muted.
NOTE
You can have multiple tracks soloed simultaneously.
Edit Instrument
Opens the corresponding VST instrument dialog, allowing you to edit settings for the
slot or channel.

Chords track
A chords track is included in every project. You can use this track to hear in playback any chords
that you input into the score as chord symbols.

Example chords track

NOTE
You must assign a VST or MIDI instrument and a slot for the chords track in order for it to
playback sounds.
You can use an existing slot containing a sound already loaded in the project, or you can use a
new slot with a new sound loaded just for chords.
NOTE
If you assign an empty slot to your chords track and later add more instruments to your project,
the sounds for the new instruments overwrite the slot.

RELATED LINKS
VST and MIDI Instruments panel on page 309
Loading VST and MIDI instruments manually on page 311

Playing techniques tracks
Each instrument track has its own playing techniques track below the piano roll editor.

Example playing techniques track below note events
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This track displays where you have input playing techniques, so you can see where playing
technique changes occur. You can hover your mouse-pointer over individual playing technique
regions on the track to see the following related information:
●

Playing technique/Playing technique combination used in the expression map

●

VST or MIDI instrument used for the region

●

Channel in the VST instrument used for the region

●

Expression map used for the region

NOTE
●

Unpitched percussion instruments do not have playing technique tracks.

●

You cannot change playing techniques using this track.

Expanding/Collapsing instrument and player tracks
You can expand/collapse instrument tracks in Play mode individually, or expand/collapse all
player tracks in the current flow.
PROCEDURE
●

Expand/Collapse tracks in one of the following ways:
●

Click individual disclosure arrows to expand or collapse the corresponding player
track or instrument track.

●

Ctrl/Cmd-click any player track disclosure arrow to expand/collapse all player tracks.

Piano roll editor
The piano roll editor displays MIDI notes for pitched instruments in a continuous sequence, with
the vertical position of note events indicating their pitch.
In Dorico, pitched instruments are displayed in an individual piano roll editor for their instrument
track.
Pitched instruments are positioned in the piano roll editor according to their pitch, which is
demonstrated by a piano keyboard on the left edge of the piano roll editor.

Each instrument is automatically assigned a color when you add them in Setup mode, so that you
can tell them apart more easily in Play mode.
You can edit notes in the piano roll editor, including moving and transposing them.
NOTE
Editing the played duration of notes causes them to appear in a darker color in the piano roll
editor to notes whose played duration you have not changed.

RELATED LINKS
Played vs. notated note durations on page 335
Lengthening/Shortening notes in the piano roll editor on page 304
Moving notes in the piano roll editor on page 305
Transposing notes in the piano roll editor on page 305
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Inputting notes in the piano roll editor
You can input notes into your project in the piano roll editor.
PROCEDURE
1.

Expand the instrument track of the instruments into which you want to input notes.

2.

Select Draw in any of the following ways:

3.

●

Press D.

●

Click Draw in the Play toolbox.

In the piano roll, click and drag horizontally for the required duration at the pitch position
you want.

RESULT
Notes are input at the pitches indicated by the piano keyboard on the left of the piano roll.
You can later change both the notated and played durations of notes. You can also change the
duration of notes in the score in Write mode.
RELATED LINKS
Expanding/Collapsing instrument and player tracks on page 303
Lengthening/Shortening notes in the piano roll editor on page 304
Changing the duration of notes on page 125

Lengthening/Shortening notes in the piano roll editor
You can change the duration of notes from within the piano roll editor in Play mode. This
automatically changes the notated duration of the notes in the score.
PREREQUISITE
Object Selection is selected in the Play toolbox.
PROCEDURE
1.

In the piano roll editor, select the note events you want to lengthen/shorten.

2.

Lengthen/Shorten the notes in any of the following ways:
●

Press Shift-Alt-Right Arrow to lengthen notes by the current rhythmic grid value.

●

Press Shift-Alt-Left Arrow to shorten notes by the current rhythmic grid value.

●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to double the length of notes.

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to halve the length of notes.

●

Click and drag the right end of one of the selected notes to the length you want.
NOTE
You can only change the notated duration of notes with the mouse when Notated
Durations is selected in the Play toolbox. When Played Durations is selected, you
can click and drag notes to change their played duration.

RESULT
The notes are lengthened/shortened.
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RELATED LINKS
Played vs. notated note durations on page 335
Changing the duration of notes on page 125
Play toolbox on page 300

Moving notes in the piano roll editor
You can move notes rhythmically within the piano roll editor.
PREREQUISITE
Object Selection is selected in the Play toolbox.
PROCEDURE
1.

In the piano roll editor, select the notes you want to move rhythmically.

2.

Move the selected notes according to the current rhythmic grid value in any of the
following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag them to the right/left.

RESULT
The selected notes are moved to new rhythmic positions according to the current rhythmic grid
value. If you selected multiple notes, they are moved together as a block.
NOTE
●

This also affects how the selected notes are notated in full score layouts and any relevant
part layouts.

●

When using the keyboard, you can transpose and move notes without deselecting them
between each action. When using the mouse, you cannot move and transpose notes in the
same gesture, instead you must complete one action and release the mouse before
completing the other action.

RELATED LINKS
Transposing notes in the piano roll editor on page 305
Play toolbox on page 300

Transposing notes in the piano roll editor
You can transpose notes in the piano roll editor by moving them vertically to other pitch
positions.
PREREQUISITE
Object Selection is selected in the Play toolbox.
PROCEDURE
1.

In the piano roll editor, select the notes you want to transpose.

2.

Transpose the notes in any of the following ways:
●

Press Alt-Up Arrow to move notes up one staff position, for example, from B to C.

●

Press Alt-Down Arrow to move notes down one staff position, for example, from C
to B.

●

Press Shift-Alt-Up Arrow to transpose notes up a single octave division. For
example, a semitone in 12-EDO or a quarter tone in 24-EDO.
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●

Press Shift-Alt-Down Arrow to transpose notes down a single octave division. For
example, a semitone in 12-EDO or a quarter tone in 24-EDO.

●

Press Ctrl/Cmd-Alt-Up Arrow to transpose notes up an octave.

●

Press Ctrl/Cmd-Alt-Down Arrow to transpose notes down an octave.

●

Click and drag them upwards/downwards.

RESULT
The selected notes are transposed according to their new pitch positions in the piano roll editor.
NOTE
●

This also affects how the selected notes are notated in the score and relevant part layouts.

●

When using the keyboard, you can transpose and move notes without deselecting them
between each action. When using the mouse, you cannot move and transpose notes in the
same gesture, instead you must complete one action and release the mouse before
completing the other action.

RELATED LINKS
Moving notes in the piano roll editor on page 305
Equal Division of the Octave (EDO) on page 536
Play toolbox on page 300

Deleting notes in the piano roll editor
You can delete notes in the piano roll editor in Play mode. This also removes the notes from the
score and relevant part layouts.
PROCEDURE
1.

2.

Select Erase in any of the following ways:
●

Press E.

●

Click Erase in the Play toolbox.

Delete notes in any of the following ways:
●

Click individual notes.

●

Make a marquee selection to delete multiple notes at once.

RESULT
The notes you click or include in a marquee selection are deleted.
NOTE
You can also delete notes by selecting Object Selection in the Play toolbox, then selecting the
notes you want to delete in the piano roll editor and pressing Backspace or Delete, or choosing
Edit > Delete.

Zooming in/out of the piano roll editor
You can change the zoom level in the piano roll editor to focus on a larger/smaller section of the
flow.
PROCEDURE
●

Change the zoom in any of the following ways:
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●

Press Z to make notes appear wider.

●

Press X to make notes appear narrower.

●

Shift-click and drag upwards on the piano keyboard on the left to make notes
appear taller.

●

Shift-click and drag downwards on the piano keyboard on the left to make notes
appear shorter.

●

Spread two fingers outwards on a touchpad to make notes appear wider and taller.

●

Pinch two fingers together on a touchpad to make notes appear narrower and
shorter.

●

Click and drag upwards along the playhead in the ruler to make notes appear
narrower.

●

Click and drag downwards along the playhead in the ruler to make notes appear
wider.

Drum editor
The drum editor displays MIDI notes for unpitched percussion instruments in a continuous
sequence. The drum editor appears different to the piano roll editor and has different
functionality.
Instead of showing the piano roll view as used in the piano roll editor, in the drum editor the
onset of each note on each percussion instrument is shown. Each note is shown as an event of
the same size, unlike note events in the piano roll, whose width reflects the duration of the notes.

Drum editor

Unpitched percussion instruments have individual track headers that you can expand if you want
to make changes to the track, such as assigning the instrument to another playback endpoint.
NOTE
If you change the endpoint for an unpitched percussion instrument, that endpoint must have an
appropriate percussion map chosen, otherwise Dorico does not know how to play the music for
that instrument.
You can move notes in the drum editor to new rhythmic positions. Unpitched percussion
instruments only have one vertical position for their notes, so you cannot transpose notes in the
drum editor.
RELATED LINKS
Tracks on page 301
Expanding/Collapsing instrument and player tracks on page 303

Inputting notes in the drum editor
You can input notes into your project in the drum editor.
PROCEDURE
1.

Expand the player tracks containing the unpitched percussion instruments into which you
want to input notes.
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You do not have to expand individual unpitched percussion tracks to input notes in them.
2.

Click Draw Percussion in the Play toolbox.

3.

In the drum editor, click in the unpitched percussion tracks at the positions where you
want to input notes.

RESULT
Each time you click on a track, you input a note in the corresponding instrument. The current
rhythmic grid value determines the duration of the notes.
NOTE
●

The duration of notes is indicated by a highlighted area in the track. The shape of the note
event in the drum editor is the same for all durations.

●

You can also use the Draw tool in the drum editor just like in the piano roll editor.
However, if using the Draw tool, you must click and drag notes to input them instead of
just clicking at a position.

RELATED LINKS
Drum editor on page 307
Inputting notes in the piano roll editor on page 304
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VST and MIDI Instruments panel
You can select VST and MIDI instruments in the VST and MIDI instruments panel in Play mode
and edit their settings.

VST and MIDI Instruments panel

The VST and MIDI Instruments panel contains the following sections:
1

VST Instruments

2

MIDI Instruments

VST Instruments
The VST Instruments section of the panel contains rack slots in which you can select VST
instruments to use for playback.
NOTE
Dorico only shows VST 3 instruments by default. If you want VST 2 instruments to be available in
the VST Instruments section of the VST and MIDI Instruments panel, you must whitelist them.
Only Kontakt is available by default.
When you add instruments in your project, Dorico automatically creates a playback template
containing instances of HALion Sonic SE with sounds chosen from the HALion Sonic SE and
HALion Symphonic Orchestra libraries. Dorico also sets up expression maps and percussion
maps as required.
If you change any of these default settings, Dorico no longer makes automatic changes. For
example, you must then load sounds for new instruments manually as Dorico no longer loads
them automatically. Additionally, the HALion plug-in does not communicate changes in the plug-
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in to Dorico, meaning Dorico still tries to play back the music in your project using the expression
map for the original sounds.
You must change the expression map manually for each plug-in you change.
Therefore, we recommend that you do one of the following if you want to update the sounds
used for playback after making changes:
●

Choose Play > Load Sounds for Unassigned Instruments to change the default settings
and then add new instruments to your project. This automatically loads sounds for
instruments in your project without assigned sounds.

●

Choose Play > Apply Default Playback Template to clear the rack and reset sounds to the
default sounds originally loaded for each instrument.

You can add new slots for VST instruments and delete VST instruments by clicking the respective
button in the action bar.
●

Add

Adds a new slot for a VST instrument in the VST Instruments section of the VST and MIDI
Instruments panel.
●

Delete

Deletes the selected VST instrument from the VST Instruments section of the VST and
MIDI Instruments panel.

MIDI Instruments
The MIDI Instruments section of the panel contains rack slots in which you can select MIDI
devices to use for output during playback.
NOTE
For your MIDI device to be available for selection, you must plug it into your computer before
starting Dorico. If you plug it in after starting Dorico, you must restart the program.
On Windows, you can select any MIDI device that is plugged into your computer.
On macOS, you can select any MIDI device that is plugged into your computer, and any other
device set up in Audio MIDI Setup. For example, this allows you to use MIDI from one application
in another application.
You can add new slots for MIDI instruments and delete MIDI instruments by clicking the
respective button in the action bar.
●

Add

Adds a new slot for a MIDI instrument in the MIDI Instruments section of the VST and
MIDI Instruments panel.
●

Delete

Deletes the selected MIDI instrument from the MIDI Instruments section of the VST and
MIDI Instruments panel.
RELATED LINKS
Loading VST and MIDI instruments manually on page 311
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Loading VST and MIDI instruments manually
Dorico automatically loads enough VST slots for all the samples required for your project.
However, you can also load VST and MIDI instruments manually, either into new slots or into
existing slots to replace existing VST and MIDI instruments.
PREREQUISITE
You have any VST instruments you want to use saved on your computer.
In order for MIDI instruments to be available to load, you must plug them into your computer
before starting Dorico. If you plug them in after starting Dorico, you must restart the program.
PROCEDURE
1.

Optional: In the VST and MIDI Instruments panel, click Add.

A new VST or MIDI instrument slot loads in the corresponding section.
2.

In the slot in which you want to load a VST or MIDI instrument, select an instrument from
the menu.

Whitelisting VST instruments
You must whitelist any VST 2 instruments you want to use in Dorico. Because whitelisting works
like a preference, you must only whitelist plug-ins once for them to be available in any project.
PREREQUISITE
You have quit Dorico and all other programs.
A default vst2whitelist.txt file is included with your Dorico installation, which lists VST 2.x
plug-ins that Steinberg has qualified for use with Dorico.
You can create a second vst2whitelist.txt file in a user-specific location that is not
overwritten if you subsequently update or reinstall Dorico.
When Dorico starts up, it reads both the default whitelist file and your user-specific whitelist file
to build up the list of whitelisted plug-ins.
PROCEDURE
1.

Open a new text document in a plain text editor, such as Notepad.

2.

Enter the file names of the VST plug-ins you want to whitelist without their file extension
(.dll on Windows and .vst on macOS).
Each plug-in must have its own line in the text file.

3.

4.

Save your own vst2whitelist.txt file in one of the following places, depending on your
operating system:
●

C:\Users\username\AppData\Roaming\Steinberg\VSTAudioEngine_64
(Windows)

●

/Users/username/Library/Preferences/VSTAudioEngine (macOS)

Delete the following files from the folder:
●

Vst2xPlugin Blacklist VSTAudioEngine.xml

●

Vst2xPlugin Infos VSTAudioEngine.xml

●

Vst2xPlugin SearchPaths VSTAudioEngine.xml
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RESULT
When you next start Dorico, it considers your whitelisted VST plug-in entries, making them
available for use in the program.

Playback Options dialog
The Playback Options dialog provides options that allow you to make project-wide changes to
how the music you have written sounds when played back. These options affect playback,
regardless of expression maps and patches.
In the Playback Options dialog, you can change how dynamics, pedal lines, and different
notations are interpreted during playback.
For example, you can change how much louder notes on the first beat in each bar are compared
to other notes in the bar, change how long each pedal retake lasts, and how much different
articulations, such as staccatissimo and tenuto, affect the duration of notes.
NOTE
You can save all options that you set in Playback Options as the default for new projects by
clicking Save as Default.
You can open Playback Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-P in any mode.

●

Choose Play > Playback Options in Play mode.

Playback Options

The list on the left of the Playback Options dialog contains the available pages. All the options
available for the category selected in the page list are shown in the main area of the dialog.
Pages with many options are divided into sections.
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RELATED LINKS
Expression maps on page 319
Layout Options dialog on page 62
Notation Options dialog on page 110
Engraving Options dialog on page 228

Playhead
The playhead is a vertical line that moves during playback, showing the current rhythmic
position. It is also known as a “playback line”.
The playhead is shown at all times in Play mode, but you can also see it in other modes during
playback. You can also choose to show the playhead when playback is stopped in other modes in
the Play section of the General page in Preferences.

The playhead in Play mode

Dorico automatically keeps the playhead in view during playback by moving it along with the
music, but you can also move the playhead manually. Dorico tries to keep systems in the same
place on the screen when it scrolls along with the playhead for consistency as you follow your
music.
RELATED LINKS
Preferences on page 53
Moving the playhead on page 313

Moving the playhead
The playhead automatically moves along with the music during playback, but you can also move
the playhead manually in any mode.
You can move the playhead both when it is stopped and during playback, but not all methods of
moving the playhead work during playback.
NOTE
The playhead is only shown during playback by default. You can choose to show the playhead at
all times in the Play section of the General page in Preferences.

PROCEDURE
●

Move the playhead in any of the following ways:
●

Press + (plus) on a numeric keypad to navigate forwards.

●

Press - (minus) on a numeric keypad to navigate backwards.

●

Press . (period) on a numeric keypad to go back to the start of the flow.

●

Click Fast Forward in the transport window to navigate forwards.

●

Click Rewind in the transport window to navigate backwards.
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●

Click Rewind to Beginning of Flow in the transport window to go back to the start
of the flow.

●

In Play mode, click the ruler at any position.
NOTE
You cannot click the ruler to move the playhead during playback.

RELATED LINKS
Transport window on page 318
Preferences on page 53
Playing back music on page 314

Playing back music
You can listen to the music you have written in playback from the beginning of your project or
from a specific point.
TIP
You can also use the following key commands to play back your music in any mode.

PROCEDURE
1.

Start playback in one of the following ways:
●

Play back all instruments from the selection by selecting a single note and pressing
P.

●

Play back all instruments from the selection by selecting a single note and choosing
Play > Play From Selection.

●

Play back only a single staff by selecting multiple items on the staff and pressing P.
NOTE
This does not affect which channels are soloed or muted in Play mode.

●

Play back multiple staves by selecting items on multiple staves and pressing P.
NOTE
This does not affect which channels are soloed or muted in Play mode.

●

Continue playback from the playhead position by pressing Space.

●

Play back from the last playback start position by pressing Shift-Space, even if you
have since deselected the item at that position.

●

Play back from the start of the flow by pressing Shift-Alt-Space.

●

Click Play from Playhead in the transport window.

●

Click Play from Selection in the transport window.

●

Choose Play > Play From Playhead Position.

●

Choose Play > Play From Last Start Position.

●

Choose Play > Play From Start of Flow.

●

Choose Play > Play From Start of Project.

2.

Optional: Move the playhead during playback to later/earlier positions.

3.

Stop playback in any of the following ways:
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●

Press Space or P.

●

Press 0 on a numeric keypad.

●

Click Stop in the transport window.

RELATED LINKS
Moving the playhead on page 313
Muting/Soloing tracks on page 315

Muting/Soloing tracks
You can mute/solo individual tracks. This allows you to set fixed groups to sound in playback, for
example, if you only want to listen to certain groups of players at a time.
PROCEDURE
1.

Expand the player tracks you want to mute/solo.

2.

Click the corresponding button in each track header.
●

Mute

●

Solo

RESULT
Each track is muted/soloed and the corresponding buttons are enabled.
This affects which tracks play back until you change which tracks are muted/soloed, meaning you
do not have to reselect the tracks you want to hear each time. For example, if you have eight
tracks and solo four, only those four are played back. If you mute two tracks, those tracks are not
played back but the other six are played back.
NOTE
Soloing tracks automatically mutes all other tracks. If you solo a track that was muted, it is
automatically unmuted.
TIP
You can also play back only certain tracks/staves by selecting notes/items on each track/staff you
want to hear.

RELATED LINKS
Playing back music on page 314
Expanding/Collapsing instrument and player tracks on page 303
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Mixer
The Mixer allows you to control the sounds produced in playback, both for the master output and
on each individual channel.

1

Channel types
Allows you to hide/show channels in the Mixer according to their type, and in any
combination.

2

Channel controls
Allow you to hide/show the corresponding controls in the channel strip according to their
type, and in any combination.

3

Deactivate All Mute States/Deactivate All Solo States
Allows you to deactivate all mute/solo states by clicking the corresponding button.

4

Zoom
Allows you to make channels wider/narrower.

5

VST channels
There is a mixer channel for each stereo output from the VST instruments in your project,
and all instruments in your project are shown, even if they are spread across multiple VST
instrument instances. Channels are stereo by default.
In addition to your instrument channels, there is a single FX Send channel and an Output
channel. These channels allow you to add effects, such as reverb, to your project, and to
control the master output volume.
NOTE
The FX channel has Reverence loaded automatically by default.

6

Mute/Solo
Allows you to mute/solo individual tracks.
NOTE
These buttons have the same functionality as the Mute/Solo buttons in the track headers
in Play mode. For example, if you mute a track in the Mixer, the Mute button in the
corresponding track header is also enabled.

7

Balance panner
Allows you to position the sound of each individual track on the stereo spectrum for stereo
playback.
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8

Fader
Allows you to control the volume level of each individual track.
MIDI channels have a MIDI fader.

9

Channel meter

10

MIDI channels

Indicates the output volume of each individual channel in real time.
Every VST instrument in your project has its own MIDI channel in addition to its VST
channel. These MIDI channels allow you to change the MIDI volume and MIDI pan of each
instrument.
11

MIDI pan
Allows you to position the MIDI output of the channel on the stereo spectrum for stereo
playback.

12

MIDI fader
Allows you to change the MIDI volume of the channel.
Some plug-ins require MIDI faders, and this is often useful if you are using a MIDI device
for playback.

NOTE
In order to control the volume levels in your project, we recommend that you first input
dynamics and adjust the dynamic curve to suit your project before using the track faders.
Any changes you make in the Mixer are automatically saved and applied to the project.
RELATED LINKS
Mixer channel strips on page 317
Hiding/Showing the Mixer window on page 318
Muting/Soloing tracks on page 315

Mixer channel strips
Each channel in the Mixer has its own channel strip, which contains the channel controls. You can
hide/show each type of channel control by clicking the corresponding button at the top of the
mixer.
Each channel strip contains the following types of controls:
EQ

Each channel has four bands of EQ.
In order to make changes to the EQ bands on a channel, you must first click Enable
EQ. You can use this to bypass the EQ on a channel without losing your settings.
Inserts

Each channel has four slots into which you can load an insert. You can select an
insert from the available options in the menu.
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Sends

Each channel has four slots for sends. By default, the first slot for each channel sends
to the FX channel, which has reverb loaded on it.
RELATED LINKS
Mixer on page 316

Hiding/Showing the Mixer window
You can open and close the Mixer window at any time, for example, if you do not want it in view
when working on the music in the music area.
PROCEDURE
●

Hide/Show the Mixer window in any of the following ways:
●

Press F3.

●

Click Show Mixer in the toolbar.

●

Choose Window > Mixer.
TIP
The Mixer window is shown when a tick appears beside Mixer in the menu, and
hidden when no tick appears.

Transport window
The Transport window contains all the transport functions in Dorico. It contains more precise
versions of the transport functions available in the toolbar and additional transport functions.
You can open the Transport window in any of the following ways:
●

Press F2.

●

Click Show Transport Bar in the toolbar.

Transport window

The Transport window contains the following information and functions:
1

Bars/Beats display
Shows the position of the playhead in the score relative to bars and beats. The display
shows the units in the following order: bars, beats, 16th notes, 120ths of a 16th note.

2

Time display
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Shows the position of the playhead in units of time in the following order: hours, minutes,
seconds, milliseconds.
3

Rewind to Beginning of Flow
Moves the playhead back to the beginning of the flow.

4

Rewind
Moves the playhead back by a half note each time you click.

5

Fast Forward
Moves the playhead forwards by a half note each time you click.

6

Stop
Stops playback.

7

Play from Playhead
Plays back from the position of the playhead.

8

Play from Selection
Plays back from the position of the first selected item in the music area.
NOTE
If you select items on multiple staves, or multiple items on a single staff, only the selected
staves are played back.

RELATED LINKS
Basic transport options on page 40

Expression maps
Expression maps tell Dorico how to use appropriately the patches and sounds in the VST
instruments that you have loaded into your project.
Expressing a range of dynamics on instruments means changing the volume and attack of notes.
This is because loud sounds often require stronger attacks, and quiet sounds often require softer
attacks, which changes the character of the start of the sounds as well as its volume.
Different patches and instruments have different approaches to changing dynamics and volume
in playback. For example, some patches only change the velocity whereas others use a controller
in combination with changing the velocity.
Dorico also uses expression maps to specify the playing techniques that are supported by each
patch in your project. For example, string instruments such as the violin have different
techniques, because they can play arco, pizzicato, and col legno, and their bow position can be
anywhere between sul ponticello and sul tasto.
Dorico supports the following ways of sending information to VST instruments:
●

Key switches

●

Controllers

NOTE
Program changes are not currently supported.
You can edit individual expression maps and import/export expression maps in the Expression
Maps dialog.
RELATED LINKS
Percussion maps on page 329

319

Play mode
Expression maps
Expression Maps dialog on page 320

Expression Maps dialog
In the Expression Maps dialog, you can create new expression maps, edit existing expression
maps, and import/export expression maps. You can also import expression maps made in
Cubase.
●

You can open the Expression Maps dialog in Play mode by choosing Play > Expression
Maps.

NOTE
●

Although the format of expression maps in Dorico is similar to Cubase, Dorico does not
handle expression maps in exactly the same ways as Cubase. For example, Dorico allows
you to use more playing techniques, but Cubase can reproduce more combinations of
multiple playing techniques.

●

During playback, Dorico does not currently support all fields in the Expression Maps
dialog. This is planned for future versions.

Expression Maps dialog

The Expression Maps dialog contains the following sections and options:
1

Expression Maps list
Contains the expression maps currently available in your project.
You can add and delete expression maps using the following buttons in the action bar at
the bottom of the Expression Maps list:
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●

Add Expression Map

Allows you to add a new expression map that contains no existing settings.
●

Duplicate
Creates a copy of an existing expression map that you can then edit separately from
the original.

●

Delete Expression Map

Allows you to delete the selected expression maps.
NOTE
You can only delete custom expression maps. You cannot delete any default
expression maps.
2

Expression Map section
Allows you to specify the following identifying information for the selected expression
map:
●

Name
Allows you to set the name of the expression map that appears in the program, for
example, in the Endpoint Setup dialog.

●

ID
Allows you to set the unique ID of the expression map. You can enter any content in
the ID field.
It can be useful to include the instrument and sound library for which you created
the map, as well as your name, for example, xmap.user.paulsmith.hso.violinpizz.

●

Creator
Allows you to name the creator if you are sharing your expression map with other
users.

●

Version
Allows you to indicate later versions of an expression map so you can identify the
most recent version.

●

Plugins
Allows you to list the names of plug-ins to which the expression map applies, with
each name separated by a comma.
NOTE
You can leave this field blank.

NOTE
All fields in the Expression Map section are locked by the Lock Info button at the top
right. You must click this button in order to change the information in the fields.
3

Techniques section
The Techniques section contains the following groups:
●

Techniques list
Contains a list of techniques for the expression map currently selected.
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NOTE
Most instruments have a “natural” technique, which is the most common way of
playing the instrument. Dorico requires every instrument to have a defined natural
technique.
●

Dynamics
Allows you to choose whether the volume dynamic for the selected technique is
controlled by its Note Velocity or a Control Change.
NOTE
Control Change requires you to specify the controller by number. You can consult
the documentation for the VST instrument and/or MIDI controller you are using to
find the appropriate controller number.

●

Technique controls
Contains controls that affect the technique selected in the Techniques list, such as
Velocity.

●

Exclusion Groups
Allows you to specify techniques that are mutually exclusive. For example, players
cannot be muted and non-muted at the same time. Putting techniques into the
same exclusion group means only one can be used at a time.

NOTE
Although settings are imported into the Technique controls and Exclusion Groups from
Cubase, Dorico does not currently implement all the information. This is planned for future
versions.
In simple cases, techniques in the Techniques list are individual techniques, such as
Staccato or Accent. However, it is possible to combine multiple techniques for plug-ins
that have separate samples for different combinations of techniques. For example,
Staccato + Accent might require a separate set of switches to Staccato and Accent
individually.
Selecting a technique in the Techniques list makes it available for editing in the Actions
section. All the controls in this panel apply to the current technique.
You can add new techniques, edit existing techniques, and delete techniques using the
following buttons in the Techniques list action bar:
●

Add Technique

Allows you to add a new technique or combination of techniques to the expression
map from the available techniques in the Technique Combinations dialog.
●

Edit Technique

Allows you to edit the combination of techniques used in the selected technique in
the Technique Combinations dialog.
NOTE
You can also edit existing techniques by double-clicking them in the Techniques list.
●

Duplicate
Creates a copy of an existing technique that you can then edit separately from the
original.
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●

Delete Technique

Allows you to delete the selected technique.
NOTE
You can only select one technique at a time in the Techniques list.
4

Actions section
Allows you to determine how the switch required to execute each technique is controlled.
This section also contains the details of existing actions required to produce the selected
playing technique.
Actions can be any of the following types:
●

Key switch

●

Control change

●

Program change

NOTE
Depending on your plug-in, multiple types of actions can be required to change individual
techniques.
In the Actions section, actions are displayed in a table with three columns.

Actions table

The first column shows the type of action.
The second column controls the first parameter of the MIDI event. For note events, this
indicates the pitch. For control changes, this indicates the control change number. For
program changes, this indicates the program number.
The third column controls the second parameter of the MIDI event. For note events, this
indicates the velocity. For control changes, this indicates the amount of control change
within the range 0 to 127. Program changes do not have a second parameter so do not
use this column.
You can add new actions of each type and duplicate existing actions using the
corresponding button in the action bar.
You can delete actions by selecting them individually and clicking Delete Action in the
action bar.

The Actions section also allows you to specify which actions affect the start of notes and
which affect the end of notes. For example, you might want an event that resets the
technique back to normal to apply only to the end of notes.

5

●

On Events affects the start of notes.

●

Off Events affects the end of notes.

Reset to Library Defaults
Allows you to revert any changes you have made to the expression maps from the Default
Library.

6

Export Library
Allows you to select multiple expression maps and export them into a .doricolib file,
which you can import into other projects and share with other users.
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7

Import Library
Allows you to import expression maps from .doricolib files.

8

Import Cubase Expression Map
Allows you to import an expression map in Cubase format.
NOTE
It is not currently possible to import all combinations of techniques. Cubase expression
maps in Dorico often require some editing to function correctly.
However, switch data is preserved.

RELATED LINKS
Endpoint Setup dialog on page 327

Technique Combinations dialog
You can create combinations of techniques in the Technique Combinations dialog. You can later
assign actions to these combinations to create specific sounds in playback.
You can open the Technique Combinations dialog in the following ways:
●

In the Expression Maps dialog, click Add Technique in the Techniques action bar.

●

In the Expression Maps dialog, select an existing technique in the Techniques list and click
Edit Technique.

●

In the Expression Maps dialog, double-click an existing technique in the Techniques list.

Technique Combinations dialog

1

Techniques list
Allows you to select techniques to include in a new technique or to replace existing
techniques.
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You can select multiple techniques to combine by Ctrl/Cmd-clicking each technique.
2

Name
Displays the name of the selected technique. If you select multiple techniques, each name
is automatically separated by a + symbol.
You cannot change the name of techniques.

RELATED LINKS
Expression Maps dialog on page 320

Creating new expression maps
You can create new expression maps from scratch and you can duplicate existing expression
maps and edit the settings.
PROCEDURE
1.

Choose Play > Expression Maps.
The Expression Maps dialog opens.

2.

3.

Create a new expression map in one of the following ways:
●

Click Add Expression Map to create an empty expression map.

●

In the list on the left of the dialog, select an existing expression map on which you
want to base a new map and click Duplicate.

Click Lock Info to unlock the fields in the Expression Map section.

Locked

Unlocked

4.

In the Expression Map section, enter information for your expression map in the relevant
fields.

5.

Optional: In the Techniques list, add a new technique in one of the following ways:

6.

7.

●

Click Add Technique.

●

Select an existing technique and click Duplicate.

Optional: Open the Technique Combinations dialog to change the technique combination
for a technique in any of the following ways:
●

Double-click the technique.

●

Select the technique and click Edit Technique.

Optional: In the Technique Combinations dialog, select the techniques you want to
combine.
TIP
You can select multiple techniques, but you can also only select a single technique.

8.

Optional: Click OK.
The Technique Combinations dialog closes. Your selected technique combination is
available in the Techniques list.

9.

Optional: Repeat steps 6, 7, and 8 for any other techniques whose combination you want
to change.
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10.

In the Techniques list, select a technique.

11.

In the Techniques section, change any of the options relevant to the selected technique.
For example, choose whether the volume of the selected technique is controlled by its
Note Velocity or a Control Change.

12.

13.

In the Actions section, add an action for the currently selected technique in one of the
following ways:
●

Click Add Note Event.

●

Click Add Control Change.

●

Click Add Program Change.

●

Select an existing action and click Duplicate.

Choose the type of event from one of the following options:
●

On Event

●

Off Event

14.

Optional: Repeat steps 12 and 13 for each action you require for each technique.

15.

Optional: If you want to change the values for actions, highlight the value in the field you
want to change in any of the following ways:

16.

●

Double-click the value you want to change.

●

Select the value you want to change and press Return.

Optional: Change the values in the action value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

17.

Optional: Repeat steps 15 and 16 for all the action fields you want to change.

18.

Click OK to save your changes and close the dialog.

RELATED LINKS
Expression Maps dialog on page 320
Endpoint Setup dialog on page 327
Technique Combinations dialog on page 324

Exporting expression maps
You can export expression maps so you can use them in other projects.
PROCEDURE
1.

Choose Play > Expression Maps.
The Expression Maps dialog opens.

2.

Click Export Library.
The File Explorer/macOS Finder dialog opens.

3.

In the File Explorer/macOS Finder dialog, specify a name and location for the library file.

4.

Click Save.

RESULT
The expression map is exported and saved in the selected location.
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Importing expression maps
You can import expression maps into projects.
PROCEDURE
1.

Choose Play > Expression Maps.
The Expression Maps dialog opens.

2.

Click Import Library.
The File Explorer/macOS Finder dialog opens.

3.

In the File Explorer/macOS Finder dialog, locate and select the expression map file you
want to import.

4.

Click Open.

RESULT
The selected expression map is imported into your project. It appears in the Expression Maps list.

Endpoint Setup dialog
The Endpoint Setup dialog links expression maps to the relevant endpoint, which is a
combination of the VST instrument and its channel.
●

You can open the Endpoint Setup dialog by clicking the cog button beside each plug-in in
the VST and MIDI Instruments panel.

The dialog contains a list of the current channels used by this plugin, and the expression map
used on each channel.
1

Number of MIDI Channels
Displays the number of MIDI channels currently used by the corresponding plug-in.
Allows you to change the number of channels, for example, if you have a monotimbral
plug-in such as a piano sampler which only has one MIDI channel, or a multitimbral plugin with 16 MIDI channels and 16 audio outputs.

2

Set
Sets the plug-in to have the number of MIDI channels specified in the Number of MIDI
Channels field.

3

Channel
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Displays the channel number of the expression map and percussion map on that line.
4

Expression map
Displays the expression map currently loaded in each channel of the plug-in.
You can select other expression maps from each channel menu.

5

Percussion map
Displays the percussion map currently loaded in each channel of the plug-in.
You can select other percussion maps from each channel menu.

In addition to the HALion Symphonic Orchestra expression maps, there are four other expression
maps:
●

CC11 Dynamics
Uses MIDI controller 11 to play dynamics.
NOTE
This only applies to instruments that can change their dynamic while notes are sounding,
such as violin or flute.

●

Default
Uses note velocity to control dynamic volume.

●

Modulation Wheel Dynamics
Uses a modulation wheel to control the dynamic volume.

●

Transpose up 1 octave
Allows the bottom octave of keyboards to be used for key switches instead of notes, but is
also used by some bass instrument patches which play an octave lower than written so
that they can be played without needing a full range keyboard.

TIP
You can also create your own custom expression maps in the Expression Maps dialog.
Each instrument in your project is connected to a specific endpoint, so assigning an expression
map to each endpoint allows Dorico to translate playing technique changes and note
articulations into the key switches and controller switches required to reflect those sounds in
playback.
If you are using the Default Playback Template with HALion Sonic SE or HALion Symphonic
Orchestra, endpoints and expression maps are set up automatically. However, if you want to load
other plug-ins or change the patches within HALion Sonic SE, then you must use the Endpoint
Setup dialog.
For example, if you have a project that uses the Default Playback Template and you change one
of the sounds in HALion Sonic SE, such as changing Clarinet Combi in HALion Symphonic
Orchestra to GM Clarinet, this plays back incorrectly because the HALion Symphonic Orchestra
patch uses a modulation wheel to control volume dynamics, but the GM patch uses note velocity.
In playback, notes consequently have no dynamics and too much vibrato. You can correct this in
the Endpoint Setup dialog by changing the expression map for that channel from the HALion
Symphonic Orchestra Clarinet to Default, which uses note velocity for dynamics instead of a
modulation wheel.
RELATED LINKS
Expression Maps dialog on page 320
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Percussion maps
Unpitched percussion instruments are played back using patches that map unpitched sounds
onto different MIDI notes. The pitches required to produce different unpitched sounds vary by
device, sample library, manufacturer, and so on, and have no connection to the position of
percussion instruments on five-line staves.
The following list contains some examples of unpitched percussion instruments from the General
MIDI percussion map.
●

Bass drum: C2 (MIDI note 36, two octaves below middle C)

●

Kick drum: D2 (MIDI note 38)

●

Closed hi-hat: F♯2 (MIDI note 42)

●

Cowbell: G♯3 (MIDI note 56)

●

Open triangle: A5 (MIDI note 81)

Dorico uses percussion maps to connect the written representation of notes and playing
techniques for percussion instruments to the samples required to play those sounds back.
NOTE
A percussion map describes which unpitched percussion instruments and their playing
techniques are present in a particular patch, and how to play them back. For example, it
describes which MIDI note to play, and if another MIDI note is needed as a key switch to trigger
particular playing techniques.
A set of percussion maps for the unpitched percussion patches that are part of theHALion
Symphonic Orchestra and HALion Sonic SE factory libraries is provided with Dorico. They are
automatically chosen when you add percussion instruments to your project.
You can define custom percussion maps for third-party sound libraries or MIDI devices in the
Percussion Maps dialog, in order to obtain correct playback.
RELATED LINKS
Percussion Maps dialog on page 329
Importing percussion maps on page 333
Exporting percussion maps on page 333

Percussion Maps dialog
You can define custom percussion maps for third-party sound libraries or MIDI devices in the
Percussion Maps dialog, in order to obtain correct playback.
●

You can open the Percussion Maps dialog in Play mode by choosing Play > Percussion
Maps.
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Percussion Maps dialog

The Percussion Maps dialog is divided into the following sections:
1

Percussion Maps list
Contains the percussion maps currently available in your project.
You can add and delete percussion maps using the following buttons in the action bar at
the bottom of the Percussion Maps list:
●

Add Percussion Map

Allows you to add a new percussion map that contains no existing settings.
●

Duplicate
Creates a copy of an existing percussion map that you can then edit separately from
the original.

●

Delete Percussion Map

Allows you to delete the selected percussion maps.
NOTE
You can only delete custom percussion maps. You cannot delete any default
percussion maps.
2

Percussion Map section
Allows you to specify the following identifying information for the selected percussion
map:
●

Name
Allows you to specify the display Name for the percussion map that appears in the
Endpoint Setup dialog.

●

ID
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Allows you to set the unique ID of the percussion map. You can enter any content in
the ID field.
It can be useful to include the instrument and sound library for which you created
the map, as well as your name, for example, xmap.user.paulsmith.hso.cowbell.
NOTE
The Endpoint Setup dialog is where you set which percussion map Dorico uses for each
channel on your VST instrument or MIDI output device.
You can choose one of the options for Map defines sounds for, as appropriate for the
current percussion map:
●

Multiple Instruments
Choose this if the patch for which you are creating a map contains many different
percussion instruments, such as the General MIDI drum map.

●

Singe Instruments
Choose this if the patch for which you are creating a map contains only a single
percussion instrument, perhaps with multiple playing techniques for that
instrument. For example, a snare drumline patch in Virtual Drumline or another
specialist sample library.
This can also be useful when your VST instrument has several patches that have the
same technique mappings. For example, there are both large and small cymbal
patches in HALion Symphonic Orchestra which provide natural strike and roll
sounds. Creating a single individual instrument percussion map allows you to use
the same mapping for these sounds for multiple patches.

3

Drum Kit Note Map section
Lists all MIDI notes from 0 to 127. You can specify which combination of unpitched
instrument and playing technique is produced by each note.

4

Edit Drum Kit Note section
Allows you to specify data in the following fields for the MIDI note selected in the Drum Kit
Note Map section:
●

Name
The display name for the specific combination of instrument and technique. You
may choose to input whatever name is used in the manufacturer’s documentation
for your VST instrument or MIDI output device.

●

Instrument
Select an instrument for the MIDI note selected in the Drum Kit Note Map section
from a list of all the unpitched percussion instruments you can create in Dorico.

●

Techniques
Select a playing technique to apply to the instrument selected in the Instrument
field from a list of all the playing techniques you can create in Dorico.

●

Keyswitches
Specify the MIDI note number of the key you want to use as a key switch if this
sound requires another MIDI note to be played to trigger this specific combination
of instrument and playing techniques.
NOTE
Key switches are not compulsory.
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Defining custom percussion maps
You must define custom percussion maps in order to obtain correct playback when using thirdparty sound libraries or MIDI devices. You can create new, empty percussion maps, or create
custom percussion maps based on existing maps that you have duplicated.
PROCEDURE
1.

Choose Play > Percussion Maps.
The Percussion Maps dialog opens.

2.

3.

Create a new custom percussion map in any of the following ways:
●

Click Add Percussion Map to create an empty map.

●

In the list on the left of the dialog, select an existing percussion map on which you
want to base a new custom map and click Duplicate.

Click Lock Info to unlock fields in the Percussion Map section.

Locked

4.

Unlocked

In the Percussion Map section, enter the display name you want for the percussion map
in the Name field.
This name appears in the Endpoint Setup dialog.

5.

In the Percussion Map section, enter any unique identification name in the ID field.
It can be useful to include the instrument and sound library for which you created the
map, as well as your name, in the identification name for percussion maps, for example,
xmap.user.paulsmith.hso.cowbell.

6.

In the Percussion Map section, choose one of the following options for Map defines
sounds for, as appropriate for the current percussion map:
●

Multiple Instruments

●

Single Instruments

7.

In the Drum Kit Note Map section, click Show all to show unmapped notes.

8.

Select the row corresponding to the MIDI note for which you want to create a new
mapping.

9.

In the Edit Drum Kit Note section, click the following button beside the Instrument field.

A dialog containing a list of instruments opens.
10.

Select the instrument that corresponds to the sound produced by the selected MIDI note
from the list.

11.

Click OK.

12.

In the Edit Drum Kit Note section, click the following button beside the Techniques field.

A dialog containing a list of playing techniques opens.
13.

Select the appropriate playing techniques for the sound produced by the selected MIDI
note from the list.
For example, Ctrl/Cmd-click Buzz roll and Rim.

14.

Click OK.

15.

In the Edit Drum Kit Note section, enter the display name you want for this combination
of instrument and playing technique in the Name field.
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16.

In the Edit Drum Kit Note section, specify the MIDI note number of the key switch if this
sound requires one in the Keyswitches field.

17.

Click Apply.

18.

Optional: Repeat these steps for each MIDI note until you have created all the required
mappings for your project.

19.

Click OK to save your changes and close the dialog.

RESULT
Your new percussion map is created.
NOTE
Once you have created a percussion map, you must apply it to the VST instrument or MIDI device
that provides the patch corresponding to each percussion map.
AFTER COMPLETING THIS TASK
You can export the percussion map if you want to use it in other projects.
RELATED LINKS
Percussion Maps dialog on page 329
Percussion maps on page 329
Linking percussion maps to VST instruments and MIDI devices on page 334
Exporting percussion maps on page 333
Endpoint Setup dialog on page 327

Exporting percussion maps
You can export percussion maps so you can use them in other projects.
PROCEDURE
1.

Choose Play > Percussion Maps.
The Percussion Maps dialog opens.

2.

Click Export Library.
The File Explorer/macOS Finder dialog opens.

3.

In the File Explorer/macOS Finder dialog, specify a name and location for the library file.

4.

Click Save.

RESULT
The percussion map is exported and saved in the selected location.

Importing percussion maps
You can import percussion maps into projects.
PROCEDURE
1.

Choose Play > Percussion Maps.
The Percussion Maps dialog opens.

2.

Click Import Library.
The File Explorer/macOS Finder dialog opens.

3.

In the File Explorer/macOS Finder dialog, locate and select the percussion map file you
want to import.
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4.

Click Open.

RESULT
The selected percussion map is imported into your project. It appears in the Percussion Maps list.

Linking percussion maps to VST instruments and MIDI devices
Once you have created a percussion map, you must apply it to the VST instrument or MIDI device
that provides the patch corresponding to each percussion map.
PROCEDURE
1.

In Play mode, click the following button for the VST instrument or MIDI device to which
you want to link a percussion map.

2.

In the Endpoint Setup dialog that opens, select a percussion map in the Percussion map
column for the channel in which your percussion patch has been loaded.
TIP
You can check into which channel your percussion patch is loaded in the VST Instrument
Window, which you open by clicking the following button.

RESULT
The selected percussion map is linked to the percussion patch loaded into the corresponding
channel.

Defining how combinations of articulations and single-note
tremolos sound in playback
You can define specific playback behaviors for particular combinations of articulations and
single-note tremolos in playing technique-specific noteheads for unpitched percussion
instruments.
PROCEDURE
1.

In Setup mode, open the Edit Percussion Playing Techniques dialog in any of the
following ways:
●

For an individual percussion instrument: Expand the card of the player holding the
instrument in the Players panel in Setup mode, click the arrow in the instrument
label, and choose Edit Percussion Playing Techniques from the menu.

●

For percussion instruments that are part of percussion kits: Open the Edit
Percussion Kit dialog by clicking the arrow in the kit instrument label in the Players
panel in Setup mode, select the instrument whose playing techniques you want to
edit in the main editing area, and click Edit Percussion Playing Techniques.

2.

Select the playing technique-specific notehead whose playback behaviors you want to
define in the list at the top of the dialog.

3.

Click Add Technique in the action bar at the bottom left of the dialog.

4.

Click Choose Playing Techniques beside the Playing technique field.
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5.

Select the playing technique you want from the list in the dialog that opens.
You can select multiple playing techniques by holding down Ctrl/Cmd and clicking the
playing techniques you want.

6.

Choose one of the following options:
●

Replace
Allows you to use this playing technique instead of the default playing technique
defined for this combination of notehead and staff position.

●

Add
Allows you to add this playing technique on top of the default playing technique
defined for this combination of notehead and staff position.

7.

Choose any articulations and a tremolo stroke that you want from the available options.

8.

Click OK to save your changes and close the dialog.

RESULT
The behavior of the selected playing technique in playback is changed.
RELATED LINKS
Creating new playing technique-specific noteheads for unpitched percussion instruments on
page 792

Played vs. notated note durations
You can show notes in the piano roll editor in Play mode with their played duration or notated
duration.

Played duration
When Played Durations in the Play toolbox is selected, note events in the piano roll editor are
each shown with two components:
●

A filled, light-colored rectangle showing the played duration of the note.

●

A thin, darker rod showing the notated duration of the note.

For example, notes with staccato articulations are played for less time than their notated
duration, whereas notes under slurs are played for longer than their notated duration.
By default in Dorico, notes in the piano roll editor in Play mode are shown with their played
duration.
NOTE
Editing the played duration of notes causes them to appear in a darker color in the piano roll
editor to notes whose played duration you have not changed.

Notated duration
You can select Notated Durations in the Play toolbox to see note events as single rectangles,
which span the full width that corresponds to the notated duration of the note.
You can change the notated duration of notes in the piano roll editor when Notated Durations
is selected.
EXAMPLE
The following examples all contain the same musical phrase, shown in different ways.
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Played duration

Notated duration

Score

RELATED LINKS
Slurs in playback on page 688

Changing the played duration of notes
You can change the played duration of notes individually, both at the start and end of notes. For
example, you can make notes sound for longer or start sounding later.
PREREQUISITE
Played Durations is selected in the Play toolbox.
PROCEDURE
1.

In the piano roll editor, select the notes whose played duration you want to change.

2.

Click and drag the end of one of the notes to the right/left.
Your cursor becomes a two-way arrow when you are in the correct position.

3.

Optional: Repeat step 2 for the start of the notes.

RESULT
The played duration of the selected notes is changed.
RELATED LINKS
Played vs. notated note durations on page 335
Play toolbox on page 300

Removing changes to the played duration of notes
You can remove all changes made to the played duration of individual notes, for example, if you
change your mind about playback overrides you have made and want to revert those notes to
their default start position, length, and velocity.
Removing playback overrides also removes any offsets to the start and end position of notes
imported from MIDI files with preserved note positions.
NOTE
Note velocity is not currently displayed in Dorico, but note velocities are imported from MIDI
files. If you want dynamics you input in Write mode to take effect in playback, you must remove
playback overrides.

PROCEDURE
1.

In the piano roll editor or drum editor, select the notes whose played durations you want
to reset.

2.

Choose Play > Reset Playback Overrides.
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RESULT
All overrides to the default played duration of the selected notes are removed.
NOTE
The played duration of the selected notes appears to revert to match their notated duration.
However, starting playback or switching modes refreshes their appearance to their default
played duration. For example, if the notes are staccato, their played duration is half their notated
duration by default.
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Print mode allows you to print your layouts or to export them as graphic files, such as PDF and
SVG.

Project window in Print mode
The project window in Print mode contains the default toolbar and the print preview area as well
as panels and sections that provide all the tools and functions that allow you to prepare printing
or exporting your layouts.
You can switch to Print mode in any of the following ways:
●

Press Ctrl/Cmd-5.

●

Click Print in the toolbar.

●

Choose Window > Print.

Panels and sections in Print mode

The following panels and sections are available:
1

Layouts panel
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Shows a list of all layouts in your project and allows you to select what to print or export.
NOTE
The Select Layout menu in the toolbar is disabled in Print mode. If you want to see a
different layout in the print preview area, select it in the Layouts panel.
2

Print Options panel
Contains options for printing or exporting your layouts.

3

macOS: OS X Dialogs section
Contains macOS-specific printing options.

4

View options
Allows you to change the print preview area to show pages in one of the following views:
●

Page Width
The page fills the width of the print preview area, which might not show the whole
page depending on the orientation and format of the page.

●

Whole Page
The whole page is shown in the print preview area.

RELATED LINKS
Toolbar on page 39
Print preview area on page 43

Layouts panel (Print mode)
In Print mode, the Layouts panel shows a list of all layouts in your project and allows you to
select layouts to print or export.

1

Allows you to expand each layout to see its page size and its number of pages. This helps
you determine what kind of job type to use for each layout.
TIP
A layout with two pages might best be printed as 2-up, while a layout with five pages
might best be printed as spreads with the final page printed on a different paper size. A
layout with 12 pages might best be printed as a booklet.

2

Shows the number of copies to be printed.

The selected layouts are printed/exported when you click Print or Export.
NOTE
If you have selected some layouts set to print and some set to export graphics, the button reads
Print and Export.
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RELATED LINKS
Page arrangements for printing/exporting on page 346
Booklet printing on page 347

Print Options panel
The Print Options panel contains options for printing or exporting your layouts.

All the options that you set in the Print Options panel are saved with your project. The options
are divided into the following sections:
Destination
Allows you to select a physical printer for printing or a file location for exporting a
graphics file. If you print your work, you can choose how many copies you want to
print. If you choose to export a graphics file, you can specify the format and directory
of the saved file.
Depending on the destination that you choose, the button at the bottom of the panel
switches to either Print or Export.
NOTE
If you have selected some layouts set to print and some set to export graphics, the
button reads Print and Export.
Job Type
Allows you to choose the range of pages to be printed or exported and how they are
arranged.
Page Setup
Allows you to set the paper size and orientation. You can specify the scale factor of
the image to be printed or exported.
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Duplex Printing
Allows you to specify whether to print on one or on both sides of each sheet of
paper. This option is only available if you select Printer in the Destination section.
Annotations
Allows you to activate options that are often required by publishing houses or
printing bureaux, such as crop marks or a border around the printed image.
Print button
Allows you to print/export selected layouts according to the settings you have set in
the Print Options panel.
Depending on your selection, the print button can appear in one of the following
ways:
●

Print

●

Export

●

Print and Export

For example, if you selected layouts that are all set to print, Print is shown. If you
selected some layouts set to export graphics and some layouts set to print, Print
and Export is shown.
RELATED LINKS
Duplex printing on page 348
Page arrangements for printing/exporting on page 346

Printing layouts
You can print layouts individually or multiple layouts together. You can specify print settings for
each layout independently, for example, you can select different printers for different layouts in
the same project.
Dorico uses settings for layouts to create automatic print settings, so you might find that many
print options are already appropriate for the layouts you want to print. For example, if you are
connected to a printer that can print A3 paper and the page size of your full score layout is set to
A3 in Layout Options, Dorico automatically selects A3 in the Page Setup section of the Print
Options panel.
PROCEDURE
1.

In the Layouts panel, select the layouts that you want to print.
NOTE
The Select Layout menu in the toolbar is disabled in Print mode. If you want to see a
different layout in the print preview area, select it in the Layouts panel.

2.

Optional: Change the number of copies in any of the following ways:
●

Click - or + in each layout card.

●

In the Print Options panel, enter the number of copies into the Copies field in the
Destination section.
NOTE
Changing the Copies value changes the number of copies for all selected layouts.

3.

Optional: Activate/Deactivate Collate copies.

4.

In the Print Options panel, choose Printer in the Destination section.
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5.

Optional: Select a printer from the menu.

6.

In the Job Type section, select the page arrangement you want from the menu.

7.

In the Job Type section, choose the pages you want to print from the following options:
●

All Pages

●

Page Range

8.

Optional: If you selected Page Range, enter the first/last pages of the range into the
From/to fields.

9.

In the Page Setup section, select a paper size from the menu.

10.

Choose the paper orientation you want.

11.

Optional: If you selected Spreads or 2-up for the job type, activate/deactivate Print odd
final page on.

12.

Select a paper size for the odd final page.

13.

Choose a paper orientation for the odd final page.

14.

Choose one of the following size options:
●

Fit to Paper

●

Custom Scale

15.

Optional: If you selected Custom Scale, enter the scale factor you want into the Scale
factor field.

16.

In the Duplex Printing section, select one of the printing options from the Print on menu.

17.

Optional: If you selected a duplex printing option, use the lower menus to select how the
printed image is flipped when printing on the reverse side of the paper.

18.

In the Annotations section, activate each annotation you want to add to the selected
layouts.

19.

Click Print.

RESULT
The selected layouts are printed according to the print settings you have applied.
TIP
You can select individual layouts and set up their printing options without printing straight away.
Once you have set up the printing options you want for multiple layouts, you can then select all
the layouts you want to print and click Print, and your existing print settings are applied, even if
your selection contains layouts with different print settings.

RELATED LINKS
Printers on page 345
Page setup on page 350
Page arrangements for printing/exporting on page 346
Page size options on page 348
Print Options panel on page 340
Duplex printing on page 348
Annotations on page 352
Changing the page size and orientation on page 264
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Specifying macOS-specific printing options (macOS only)
Dorico allows you to access the standard printing options of your operating system.
NOTE
If you use the standard printing options of your operating system, the settings in the Print
Options panel are ignored. macOS-specific print settings are not saved with your project. These
must be set each time you want to print, whereas the Dorico print options are always saved with
your project.

PROCEDURE
1.

In the Layouts panel, click Page Setup in the OS X Dialogs section.
The macOS Page Setup dialog opens.

2.

In the Page Setup dialog, set the paper size.

3.

Click OK.

4.

In the OS X Dialogs section, click Print.
The macOS Print dialog opens.

5.

In the Print dialog, set up the printing options you want.

Exporting layouts as graphic files
You can export individual layouts as a variety of graphic files, such as PDF or PNG.
PREREQUISITE
PROCEDURE
1.

In the Layouts panel, select the layouts you want to export.

2.

In the Print Options panel, choose Graphics in the Destination section.

3.

Select a graphics file format from the menu.

4.

Optional: If you selected PNG or TIFF, select a resolution from the Resolution menu.
TIP
You cannot change the resolution if you select PDF or SVG. However, if you select PNG or
TIFF, change the resolution, and then select PDF or SVG, the resolution you selected still
applies.

5.

Choose a color mode.
●

Mono exports the graphic in black and white.

●

Color exports the graphic in full color.

NOTE
If you export a graphic file with a resolution of 72 dpi, it is recommended that you select
Color. If you select Mono, staff lines may disappear.
6.

Click Export.

RESULT
The selected layouts are exported as the selected graphics format. They are saved in the folder
set in the Destination folder field.
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RELATED LINKS
Specifying an export path for graphic files on page 344
Monochrome and color graphics processing on page 344
Embedding of fonts in PDF and SVG files on page 345
Graphics file formats on page 351
Image resolution on page 351

Specifying an export path for graphic files
You can specify a path to a folder in which exported graphic files are saved and add information
to each exported file.
Dorico by default exports graphic files into the same folder as your project file. If you have not
saved your project yet, graphic files are saved in the default user folder of your operating system.
You can save the exported graphics in a different folder.
PROCEDURE
1.

In the Destination section, click Choose Folder next to the Destination folder field.

The File Explorer/macOS Finder dialog opens.
2.

In the File Explorer/macOS Finder dialog, locate and select the destination folder you want.

3.

Click Open.
The new path is inserted in the Destination folder field.

4.

Optional: Activate Include date in file name to include the date and time of export in the
file names.
NOTE
Date and time are included in the ISO 8602 format, for example, 2016-05-01-143723.

RESULT
Exported files are saved in the selected destination as follows:
<project name> <layout name> <date and time>.<file extension>.
Example: MyProject Soprano 2016-05-01-143723.pdf

Monochrome and color graphics processing
Dorico applies different settings when you export monochrome and color graphics. The most
appropriate setting depends on your intended purpose for the graphics.
Most musical scores are monochrome, meaning they use only black ink and are normally printed
on white/near-white paper. Some educational books occasionally use colors to highlight
particular notations, for example, to identify clefs, or to color notes according to their pitch. If
you export graphic files and print them with your own printer, you can leave Color selected in
the Destination section.
However, if you export graphic files in PDF format for direct printing on a platesetter or for
further production work in a page layout program, select Mono, unless your layout actually
contains colored elements. If you select Mono, Dorico uses a different color space for the
resulting PDF, ensuring that the printed image only uses black ink. If you choose Color, then the
black items in your layout are exported as rich black, that is, black produced by combining
multiple colored inks. This can cause problems in production when making color separations at
the pre-press stage.
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Dorico specifies colors using the RGB color model, rather than the CMYK color model which is
used by platesetters and other professional printing machines. If you have colored objects in
your layouts and your layouts are printed professionally, you must post-process the graphic files
that are exported from Dorico in another graphics application to convert the colors from RGB to
CMYK.
RELATED LINKS
Exporting layouts as graphic files on page 343

Embedding of fonts in PDF and SVG files
How fonts are handled in PDF and SVG (Scalable Vector Graphics) files mainly depends on the
fonts that you use in the project.
PDF Files
The music and text fonts that are supplied with Dorico, these and their sub-sets are
embedded in PDF files during the export. If you open the PDF files on a different
computer, they look the same, even if that computer does not have the fonts
installed that are used in the document. If you use different fonts, make sure that
these permit embedding.
SVG Files
SVG files do not embed fonts directly: some font characters, such as note heads,
articulations, and accidentals, are converted into outlines, so that they do not
depend on the font from which they are taken. Other font characters, such as time
signature and tuplet digits, are only encoded using references to the font from which
they are taken. The latter also applies to regular text, such as staff labels, tempo
instructions, and dynamics. This means that the SVG file looks incorrect if rendered
by a web browser on a computer that does not have the fonts installed. It depends
on the browser or the rendering software, and on the fonts that are installed on the
computer, how the SVG file appears.
To ensure that the SVG file appears correctly if embedded in a web page, you can
open the SVG file in an illustration program and convert all font characters to outline
paths, then re-export the SVG file and embed that file. Alternatively, you can use web
fonts to ensure that the necessary fonts are available on the web server.
SVG graphics that are exported from Dorico conform to the SVG Tiny 1.1
specification, which defines a subset of features in the full SVG specification.
For information about using web fonts with SVG, refer to the Steinberg Help Center.

Printers
You can print layouts from Dorico projects to any printer to which your computer is connected.
You can select different printers for each layout in your project. This allows you to send layouts to
the most appropriate printer for their requirements. You can select a printer when Printer is
chosen in the Destination section of the Print Options panel.
Dorico uses the same printer as designated by the operating system by default, unless you
specify another printer. In this case, the settings in the following sections in the Print Options
panel can change:
●

In the Page Setup section, the list of available paper sizes lists only paper sizes that the
chosen printer provides.

●

In the Duplex Printing section, the option for automatic duplex printing is only available if
the chosen printer has this capability.
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NOTE
The printer menu in the Destination section only shows the name of a printer if all currently
selected layouts are set to print to the same printer. If you select a new printer from the menu,
all selected layouts are set to print to that printer.

RELATED LINKS
Print Options panel on page 340
Printing layouts on page 341

Page arrangements for printing/exporting
Dorico provides several page arrangements that you can use for printing/exporting your layouts.
In the Job Type section of the Print Options panel, you can specify how you want the layouts to
be printed/exported. You can select the following job types from the Job Type menu:
Normal
Prints one page on each sheet of paper. This produces single-sided pages, for
example, for instrumental parts that do not have regular page turns and must be
bound in a continuous line.
Spreads
Prints two pages on each sheet of paper, with odd-numbered pages on the righthand side and even-numbered pages on the left-hand side.
You can also specify a paper size on which to print odd final pages, for example, if
you are printing a layout containing five pages.
2-up
Prints two pages on each sheet of paper. The first page in the range is printed on the
left-hand side of the first sheet of paper. This can be useful for printing instrument
parts as it reduces the number of edges that must be bound, because pages can also
be folded in half.
You can also specify a paper size on which to print odd final pages, for example, if
you are printing a layout containing five pages.
Booklet
Prints two pages on each sheet of paper according to imposition requirements. This
means that if the paper is folded, the pages are laid out like a book. This can be
useful for scores and choir parts in particular as they often contain more pages than
instrumental parts.
NOTE
You can only print booklets using the complete range of pages. You cannot define
any page ranges.
NOTE
●

Depending on the job type that you choose, Dorico switches the orientation for you. The
changed orientation is immediately displayed in the music area. If this is not what you
want, you can override the orientation in the Page Setup section.

●

All of the job types allow printing either onto a single side of each sheet of paper or on
both sides of the paper.
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TIP
It is usual to print booklets, spreads, and 2-up onto paper in landscape orientation. Printing one
page to each sheet typically uses portrait orientation, unless the layout itself uses landscape
orientation.
Also in the Job Type section, you can choose which pages you want to print/export.
All Pages
Allows you to print/export all pages of the selected layouts.
Page Range
Allows you to set a range of pages to be printed. Choosing Page Range makes the
following value fields available:
●

From
Allows you to set the first page in the range you want to print/export.

●

to
Allows you to set the last page in the range you want to print/export.

RELATED LINKS
Page setup on page 350
Booklet printing on page 347

Booklet printing
When printed as a booklet, pages are reordered so that you can fold the printed pages and read
the content in the same order as they were in the project.
Printing layouts as a booklet can be much quicker than printing pages single-sided or doublesided. For example, if your full score is twenty pages long and you print it on both sides
automatically, you must then bind one edge of the printed pages in order to keep them together.
However, if you print the full score as a booklet, you can simply fold the printed pages in the
middle.
Booklet printing reorders pages so that they appear in the correct order on the printed page. For
example, a layout containing four pages printed as a booklet is laid out as follows:
●

First side: page four on the left, page one on the right

●

Reverse side: page two on the left, page three on the right

If the layout you are printing as a booklet contains an odd number of pages, Dorico
automatically places any empty last pages at the end of the booklet. This follows the convention
of showing odd-numbered pages on the right. For example, if you print a layout containing six
pages as a booklet, a total of eight pages are printed with the last two pages in the booklet left
blank. If you want the empty pages to be positioned differently, you can add extra pages to the
layout, for example, a title page.
NOTE
You can only print booklets using the complete range of pages. You cannot define any page
ranges.

RELATED LINKS
Printing layouts on page 341
Duplex printing on page 348
Page arrangements for printing/exporting on page 346
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Page size options
You can set pages to have different sizes in each layout independently.
●

Fit to Paper
The whole page is scaled to fit the paper size selected. For example, if you select a layout
with a page size of A4 and select a paper size of A3, pages in the layout are enlarged to fit
the larger paper size.

●

Custom Scale
The page is scaled to the set percentage of its original size. For example, if you are printing
a layout with a page size of A3, select a paper size of A4, and set Custom Scale to 100, the
original page remains at its original size, exceeding the boundaries of the A4 paper.

Paper orientations
Paper can have one of two possible orientations: landscape or portrait.
Instrumental parts are most often printed using a portrait orientation, as this allows two or three
pages to be spread out at a time on most music stands.
Full scores for conductors are also commonly printed using a portrait orientation, as this allows
more staves to fit on the page than when using a landscape orientation. However, full scores for
small ensembles might use a landscape orientation as not as many staves must fit on the page.
Having more horizontal room on the page allows more bars to fit on each page, reducing the
number of page turns required.
In Dorico, you can set the orientation for each layout independently. You can also separately set
the orientation of the odd final page in layouts using the Spreads and 2-up page arrangements.
RELATED LINKS
Page arrangements for printing/exporting on page 346

Printing/Exporting a page range
By default, Dorico prints/exports all pages of the selected layouts. However, you can specify a
specific page range to print/export.
NOTE
You can only print booklets using the complete range of pages. You cannot define any page
ranges.

PROCEDURE
1.

In the Job Type section, select Page Range.

2.

Specify the first and last page of the range in the From and to fields.

3.

Click Print/Export/Print and Export.

Duplex printing
Dorico allows duplex printing, which means that you can print on both sides of each sheet of
paper.
If your printer supports automatic duplex printing, Dorico can use this capability. If your printer
can only print on one side of each sheet of paper, you can still use the duplex printing function.
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The Print on menu in the Duplex Printing section of the Print Options panel contains the
following options:
One side only
Prints on one side of each sheet of paper.
Both sides manually
Prints on both sides of each sheet of paper. Use this option if you printer lacks an
automatic duplex printing capability. After all outward pages have been sent to the
printer, a message box informs you to turn over the stack of printed pages and put
them back into the printer. Then click OK to continue printing the inward pages.
NOTE
Both sides manually only works when the Job Type is set to Booklet. Therefore, we
recommend that you select Both sides automatically when printing Spreads or 2up job types.
Both sides automatically
Prints on both sides of each sheet of paper automatically. This option is only
available if your printer supports this type of printing.
The lower menus in the Duplex Printing section allow you to set how the printed image is
flipped when printing on the reverse side of the paper.
Flip image (portrait)
Determines how the image is flipped for reverse side printing in portrait orientation.
●

Flip automatically allows the printer to use its default settings for printing on
the reverse side. If you find that the printer flips on a different edge than
expected, use one of the other options to correct this.

●

Flip long side sets the printer to flip the pages on the long edge.

●

Flip short side sets the printer to flip the pages on the short edge.

Flip image (landscape)
Determines how the image is flipped for reverse side printing in landscape
orientation.
●

Flip automatically allows the printer to use its default settings for printing on
the reverse side. If you find that the printer flips on a different edge than
expected, use one of the other options to correct this.

●

Flip long side sets the printer to flip the pages on the long edge.

●

Flip short side sets the printer to flip the pages on the short edge.

RELATED LINKS
Printing layouts on page 341

Handling page sizes and paper sizes
Dorico handles page sizes and paper sizes differently.
For each layout in your project, you can define a page size on the Page Setup page in Setup >
Layout Options. This means that you define the dimensions of the layout. For printing your
layout, you must usually choose a paper size that is provided by the printer that you are using.
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Normally, the layout's page size and the printed paper size match. However, if you define a
layout with an unusual page size that is not supported by your printer, such as 10" x 13", one of
the standard page sizes for instrumental parts, you may have to print the layout onto a different
paper size. You can change the paper size in the Page Setup section of the Print Options panel
according to your needs. This has no effect on your layout's page size and therefore, does not
affect the way the music is laid out.
If you do not select a specific paper size, Dorico automatically chooses a paper size that is based
on your computer's locale settings. For example, if these are set to a European country, an
international ISO standard might be used, such as A4. If they are set to a North American
country, one of the typical standards might be used, such as US Letter.
If you have defined a page size for your layout that is larger than a typical standard, Dorico
automatically chooses the next larger paper size, provided that your printer supports this. For
example, if the layout's page size is larger than A4/US Letter, A3/Tabloid is used.
If you print to a different paper size than the layout's page size, Dorico automatically scales the
image to fit the paper. You can change this setting by specifying a custom scale factor in the
Page Setup section.
RELATED LINKS
Page setup on page 350

Page setup
You can specify different paper sizes and orientation settings for each layout you want to print/
export.
NOTE
If you have selected Graphics in the Destination section of the Print Options panel, you can only
change the paper orientation. No other options are available.
The Page Setup section of the Print Options panel contains the following options when you have
chosen Printer in the Destination section:
Paper size
Allows you to select one of the available paper sizes from the menu. The paper sizes
available depend on the capabilities of the selected printer.
You can also choose one of the following paper orientation options:
●

Portrait

●

Landscape

Print odd final page on
For Spreads and 2-up job types only: If this is activated, you can select a different
paper size or orientation for the odd final page.
NOTE
This setting is useful if your layout has an odd number of pages and you choose to
print on A3 paper in landscape orientation. The first four pages fit onto two sheets of
A3, while the fifth page would occupy only the left-hand side of a third sheet. This
setting allows you to print the odd final page on A4 paper in portrait orientation.
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Fit to Paper
Scales the layout to fit the paper.
Custom Scale
Allows you to define a different scale for the layout by entering a percentage value
into the Scale factor field.
RELATED LINKS
Page arrangements for printing/exporting on page 346

Graphics file formats
Dorico supports multiple graphics file formats as which you can export your layouts.
PDF
Stands for Portable Document Format. Exporting layouts to PDF allows you to create
a platform-independent document that contains a fixed version of each layout, for
example, to send to someone who does not have access to Dorico.
PNG
Stands for Portable Network Graphics. PNG files are losslessly compressed, meaning
they produce high quality images.
SVG
Stands for Scalable Vector Graphics. Because SVG is an XML-based text format, it can
be scaled to any size without any loss of quality.
TIFF
Stands for Tagged Image File Format. TIFF files are not compressed, which means
their file sizes can be larger than other formats and the quality of the image is not
reduced.
RELATED LINKS
Exporting layouts as graphic files on page 343

Image resolution
Image resolution refers to the number of pixels contained in an image. The larger the number of
pixels, the sharper and clearer the image appears.
In Dorico, you can export PNG and TIFF files with one of four different image resolutions. The
image resolution is measured in dots per inch, or “dpi”.
●

72

●

150

●

300

●

600

NOTE
A resolution of 72 dpi is suitable for display on screen so that you can embed the graphic in an email or on a web page. If you choose 300 or 600 dpi, a high-resolution image is saved that you
can include as an illustration in a word processing or in a desktop publishing document.

RELATED LINKS
Exporting layouts as graphic files on page 343
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Annotations
When printing/exporting your layouts for publication, you can include typical annotations.
Publishers and printing bureaux can use these to identify and register the printed image
correctly or to embed the exported graphic file into a desktop publishing application.
You can also allow Dorico to print or export any view options that you have activated in your
project.
NOTE
Crop marks and the border can only be printed if the page size is smaller than the paper size.
The Annotations section of the Print Options panel contains the following options:
Crop Marks
Adds short vertical and horizontal lines at each of the four corners of the page.
Border
Adds an outline around the edge of the page dimensions.
Date and Time
Adds the date and time of printing at the bottom of each page.
Watermark
Adds large translucent text across the middle of each page. This is useful for
indicating that this version is a draft, proof, or perusal score.
In the Watermark Text field at the bottom of the section, you can enter the text that
you want to show on each page.
View options
Adds all active view options, such as signposts and note colors, to the printout or
exported graphic.
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Introduction

This notation reference contains information about the accepted conventions for presenting
different notations and how to change their appearance and placement in Dorico, both for
individual items and by changing project-wide settings.
It also contains instructions for inputting more complex notations, such as cross-staff glissando
lines, which are described in the corresponding chapter.
Tasks in the notation reference can outline project-wide changes you can make in Engrave >
Engraving Options, such as changing spacing gaps or the project-wide appearance of pedal
lines, or the individual changes you can make to items, which often involve using properties in
the Properties panel.
You can find basic input methods for notations in the Write mode chapter.
RELATED LINKS
Write mode on page 97
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Accidentals show that the pitch of a note has been altered so that it does not conform to the
current prevailing key signature.
In music that has no key signatures, some or all notes might require accidentals, depending on
the notation convention in use.
Dorico provides comprehensive duration rules that determine when accidentals are shown, and
also allows you to control how accidentals are arranged in complex chords.
RELATED LINKS
Inputting accidentals on page 135

Changing accidentals
You can change the accidentals of notes after they have been input.
PROCEDURE
1.

In Write mode, select the notes whose accidentals you want to change.

2.

Change the accidentals in one of the following ways:
●

Press 0 to change the accidentals to a natural.

●

Press - to change the accidentals to a flat.

●

Press = to change the accidentals to a sharp.

●

Click the type of accidental that you want in the Notes panel.

RESULT
All selected notes are changed to have the accidental you selected, even if notes in your selection
originally had different accidentals.
RELATED LINKS
Inputting accidentals on page 135
Key commands in Dorico on page 10

Deleting accidentals
You can delete accidentals according to their type.
PROCEDURE
1.

In Write mode, select the note whose accidental you want to delete.

2.

Deactivate the accidental in any of the following ways:
●

Press 0 to delete naturals.

●

Press - to delete flats.
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●

Press = to delete sharps.

●

Click the button of the accidental in the Notes panel.

NOTE
If a note of the same pitch appears with an accidental earlier in the bar, but that accidental
has not been deleted, any subsequent notes of the same pitch assume that accidental
even if it does not appear by every notehead.

RELATED LINKS
Key commands in Dorico on page 10

Deleting accidentals from multiple notes
Deleting accidentals from multiple notes works in a similar way to deleting an accidental from an
individual note, but more information is required for a selection that includes different types of
accidentals.
PROCEDURE
1.

2.

3.

In Write mode, select the group of notes whose accidentals you want to delete.
●

If the notes are adjacent, select the first note of the group, then Shift-click the last
note of the group.

●

If the notes are separated by other notes, Ctrl/Cmd-click each note from which you
want to remove an accidental individually.

Optional: For a selection including just one type of accidental, deactivate that accidental in
one of the following ways:
●

Press 0 to delete naturals.

●

Press - to delete flats.

●

Press = to delete sharps.

●

Click the accidental in the Notes panel.

Optional: For a selection including multiple types of accidentals, click Natural in the Notes
panel, or press 0.
NOTE
Re-inputting an accidental over a selection of notes, where multiple accidentals are being
used, adds the accidental you choose to every note in the selection. For example, two G♯s
followed by two G♭s become four G♯s if you re-input a sharp. If you click Sharp, or press =,
twice more, all accidentals are deleted.
Therefore, to delete accidentals from a selection with multiple accidentals, we recommend
that you input a natural by clicking Natural in the Notes panel, or by pressing 0.

Showing accidentals in parentheses
You can show individual accidentals in parentheses, and also hide/show accidentals individually.
For example, you can show an accidental in parentheses on subsequent notes in tie chains that
cross system/frame breaks.
PROCEDURE
1.

Select the notes whose accidental appearance you want to change, or beside which you
want to show cautionary accidentals. You can do this in Write mode and Engrave mode.
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NOTE
You can only select individual noteheads within tie chains in Engrave mode.
2.

In the Properties panel, activate Accidental in the Notes and Rests group.

3.

Select one of the following options from the menu:
●

Show

●

Hide

●

Parenthesize
NOTE
Hiding accidentals does not affect the pitch of notes in playback.

RESULT
Accidentals on the selected notes are shown, hidden, or shown in parentheses.
NOTE
If you are hiding/showing many accidentals, it might be easier to change the accidental duration
rule for the project.

RELATED LINKS
Accidental duration rules on page 360

Project-wide engraving options for accidentals
You can find options for the project-wide appearance and position of accidentals on the
Accidentals page in Engraving Options.
The options on the Accidentals page allow you to change the order of accidentals in chords and
the precise positioning of accidentals relative to noteheads and parentheses.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Accidentals in the page list on the left of the dialog.

Altered unisons
Altered unisons occur when two or more notes of the same name in the same octave have
different accidentals in the same chord, such as D♯ and D♭.
In Dorico, this is notated with a split stem, sometimes known as a “cherry stalk” or a “tree”, which
allows both notes to appear with their corresponding accidental directly beside them.
You can also have altered unisons appear with a single stem, meaning noteheads appear directly
beside each other, and the two accidentals are shown beside each other to the left of the chord.
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EXAMPLE

A single stem altered unison

A split stem altered unison

RELATED LINKS
Changing how altered unisons appear individually on page 358
Changing how altered unisons appear project-wide on page 358
Inputting chords on page 129

Changing how altered unisons appear individually
You can change how individual altered unisons appear, independently of your project-wide
settings and independently of other altered unisons in chords.
PROCEDURE
1.

Select the altered unison notes whose appearance you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Split stem in the Notes and Rests group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
The selected altered unison notes are shown with split stems when the checkbox is activated,
and with single stems when the checkbox is deactivated.
NOTE
Split stem applies to individual notes. You can have altered unisons appear differently within the
same chord by setting their properties independently.

Changing how altered unisons appear project-wide
You can change how altered unisons appear project-wide. They can appear either beside each
other or as split stems.
You can also change how chords containing multiple altered unisons appear project-wide. Notes
can be shown on only one side of the original stem or on both sides of the original stem.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.
The Notation Options dialog opens.

2.

In the Flows list, select the flows in which you want to make changes in one of the
following ways:
●

Ctrl/Cmd-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Select Accidentals from the Category menu.
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4.

5.

6.

In the Altered unisons section, choose one of the following options for Appearance of
altered unisons:
●

Single stem

●

Split stem

Optional: In the Altered unisons section, choose one of the following options for Chords
with multiple altered unisons:
●

Allocate only to the left

●

Alternate between right and left

Click Apply, then Close.

Microtonal accidentals
Microtonal accidentals indicate pitches beyond the standard accepted chromatic scale in Western
tonality, such as a quarter sharp. You can customize microtonal accidentals in Dorico.
The default tonality system can be found in the Key Signatures, Tuning Systems, and Accidentals
panel on the right of the window. In Write mode, the default is Equal temperament (12-EDO).
When this option is selected, the accidentals available at the bottom of the menu are half-step
(semitone) accidentals, such as sharp, flat, double flat, and so on.
You can use microtonal accidentals, such as quarter sharp or quarter flat, when you have
selected a tonality system that includes microtonal accidentals in the Tonality Systems section
of the Key Signatures, Tuning Systems, and Accidentals panel. For example, Equal temperament
(24-EDO).
NOTE
Even if you do not want to use a conventional key signature, you must create an open or atonal
key signature in order to use the microtonal accidentals.
TIP
You can also define your own tonality systems with custom octave divisions, key signatures, and
accidentals.

RELATED LINKS
Inputting microtonal accidentals on page 359
Tonality systems on page 536
Custom tonality systems on page 537
Custom divisions of the octave on page 539
Custom key signatures on page 543
Custom accidentals on page 540

Inputting microtonal accidentals
You can input microtonal accidentals, such as quarter tone flat or three quarter tones sharp, into
your project.
PREREQUISITE
You have input a key signature and selected a tonality system for that key signature that allows
microtonal accidentals, such as Equal temperament (24-EDO), for the section of your project
where you want to input microtonal accidentals.
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PROCEDURE
1.

In Write mode, select the note or notes to which you want to apply a microtonal accidental.

2.

In the Key Signatures, Tuning Systems, and Accidentals panel, click the microtonal
accidental you want in the Accidentals section.

RESULT
The selected microtonal accidental appears beside the selected note or notes.
NOTE
You can only input one type of accidental at a time.

RELATED LINKS
Tonality systems on page 536
Changing the tonality system on page 537
Input methods for key signatures on page 145

Accidental duration rules
Accidental duration rules determine how long accidentals apply, such as within a bar, at a
different octave, or just for a single note.
Dorico allows you to use different accidental duration rules.
Common practice
In Dorico, this is the default accidental duration rule. In common practice, an
accidental applies for the duration of a bar and only to the pitch at which it is written;
each octave requires a separate accidental.
Second Viennese School
The Second Viennese School accidental duration rule requires writing every note with
an accidental, including naturals.
Modernist
The Modernist accidental duration rule states that only notes that have been altered
from the key signature show accidentals; naturals are not shown.
RELATED LINKS
Common practice accidental duration rule on page 361
Second Viennese School accidental duration rule on page 363
Modernist accidental duration rule on page 364

Changing the accidental duration rule
You can change the accidental duration rule to the one most appropriate for your project.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.
The Notation Options dialog opens.

2.

In the Flows list, select the flows in which you want to change the accidental duration rule
in one of the following ways:
●

Ctrl/Cmd-click individual flows.

●

Shift-click adjacent flows.
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●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Select Accidentals from the Category menu.

4.

In the Basic section, choose one of the following options for Accidental duration rule:

5.

●

Common Practice

●

Second Viennese School

●

Modernist

Click Apply, then Close.

RELATED LINKS
Common practice accidental duration rule on page 361
Second Viennese School accidental duration rule on page 363
Modernist accidental duration rule on page 364

Double accidental cancellation
There are two generally accepted practices for the cancellation of double accidentals, which are
archaic and modern. You can use either practice in each flow independently in Dorico.
By default, Dorico uses modern cancellation. This means that if a double sharp is cancelled by a
single sharp, or a double flat is cancelled by a single flat, then no natural sign is shown in front of
the single sharp or single flat, as these accidentals are unambiguous.
You can change how double accidentals are cancelled project-wide in the Basic section of the
Accidentals page in Write > Notation Options.
●

If you choose Use archaic cancellation, natural signs are shown before new accidentals
that come after double accidentals.

●

If you choose Use modern cancellation, double accidentals are replaced immediately
with a new accidental without showing a natural sign first.

EXAMPLE

Archaic cancellation

Modern cancellation

RELATED LINKS
Notation Options dialog on page 110

Common practice accidental duration rule
In common practice, an accidental affects all notes of the same pitch in the same octave within
the same bar, unless it is cancelled by another accidental. If it is not cancelled, it is automatically
cancelled in the following bar.
NOTE
To ensure that the cancellation is unambiguous, it is customary to add a cautionary accidental to
the first note of the same pitch in the following bar.
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In Dorico, the common practice accidental duration rule is used by default. You can change the
accidental duration rule on the Accidentals page in Write > Notation Options.

Common practice rules
In common practice, the accidental of a note in one bar is automatically cancelled in the
following bar. For example, in the key of G major, if an F♮ is in one bar, an F in the following bar
shows a sharp sign, even though the sharp is already implied by the key signature.
When using the common practice accidental duration rule by default, Dorico also displays
cautionary accidentals. Cautionary accidentals, also known as “courtesy accidentals”, are
restatements of an earlier accidental. They are considered optional; that is, they are neither
explicit confirmations nor cancellations, but help to eliminate ambiguities.
Cautionary accidentals are shown in the following circumstances:
●

Subsequent notes within the same bar have the same note name in different octaves.

●

Subsequent notes in the following bar have the same note name in the same octave.

●

The first occurring note in the following bar has the same note name in any octave.

●

Augmented/Diminished or double-diminished/augmented intervals are identified within
the same bar.

For each of these situations, you can choose whether cautionary accidentals are shown in
parentheses, shown without parentheses, or not shown at all.
RELATED LINKS
Changing the accidental duration rule on page 360
Hiding/Showing cautionary accidentals on page 363
Cancelling double accidentals (Common practice) on page 362

Cancelling double accidentals (Common practice)
You can change the way double accidentals are cancelled if you use the common practice
accidental duration rule.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.
The Notation Options dialog opens.

2.

In the Flows list, select the flows in which you want to change the cancellation rule for
double accidentals in one of the following ways:
●

Ctrl/Cmd-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Select Accidentals from the Category menu.

4.

In the Basic section, choose one of the following options for Single accidentals
cancelling double accidentals:
●

Use archaic cancellation
Double accidentals are cancelled by a natural-sharp or a natural-flat sign.

●

Use modern cancellation
Double accidentals are cancelled by a single sharp or a single flat sign.

5.

Click Apply, then Close.
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Hiding/Showing cautionary accidentals
You can hide/show cautionary accidentals if you use the common practice accidental duration
rule.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.
The Notation Options dialog opens.

2.

In the Flows list, select the flows in which you want to hide/show cautionary accidentals in
one of the following ways:
●

Ctrl/Cmd-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Select Accidentals from the Category menu.

4.

In the Cautionary (courtesy) accidentals section, choose the options that you want to
apply to your project.

5.

Click Apply, then Close.

RELATED LINKS
Common practice accidental duration rule on page 361

Second Viennese School accidental duration rule
The accidental duration rule of the Second Viennese School states that an accidental applies only
to the note on which it is written. All notes show an accidental regardless of key signature,
including unaltered notes which show naturals.
This accidental duration rule was used by Schoenberg and other composers of the Second
Viennese School.
You can change the accidental duration rule on the Accidentals page in Notation Options.

Restating accidentals after intervening change of pitch (Second Viennese
School)
If you use the Second Viennese School accidental duration rule, you can allow that an immediate
repetition of the same note, including those on either side of an intervening rest, within the
same bar does not require the accidental to be restated.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.
The Notation Options dialog opens.

2.

In the Flows list, select the flows in which you want to change the Second Viennese School
rule for restating accidentals in one of the following ways:
●

Ctrl/Cmd-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Select Accidentals from the Category menu.
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4.

In the Second Viennese School options section, choose Restate after intervening
change of pitch for Accidentals on immediate repetitions of the same note within a
bar.

5.

Click Apply, then Close.

Modernist accidental duration rule
The Modernist accidental duration rule states that only notes that have been altered from the
key signature show accidentals. Naturals are not shown. However, accidentals that are shown
only apply to the notes on which they are written, as with the Second Viennese School.
You can change the accidental duration rule on the Accidentals page in Notation Options.
RELATED LINKS
Second Viennese School accidental duration rule on page 363

Restating accidentals after intervening change of pitch (Modernist)
If you use the Modernist accidental duration rule, you can prevent accidentals from being shown
on an immediate repetition of a note of the same pitch within a bar.
NOTE
Charles Ives and Robert Crumb used this variation.

PROCEDURE
1.

In Write mode, choose Write > Notation Options.
The Notation Options dialog opens.

2.

In the Flows list, select the flows in which you want to change the Modernist rule for
restating accidentals in one of the following ways:
●

Ctrl/Cmd-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Select Accidentals from the Category menu.

4.

In the Basic section, choose one of the following options for Accidental duration rule:
●

Common Practice

●

Second Viennese School

●

Modernist

5.

In the Modernist options section, choose Restate after intervening change of pitch for
Accidentals on immediate repetitions of the same note within a bar.

6.

Click Apply, then Close.

Preventing restatements of accidentals on repetitions of notes in beamed
groups
If you use the Modernist accidental duration rule, you can prevent accidentals from being shown
on a repetition of a note of the same pitch within the same beam group.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.
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The Notation Options dialog opens.
2.

In the Flows list, select the flows in which you want to change the Modernist rule for
restating accidentals in one of the following ways:
●

Ctrl/Cmd-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Select Accidentals from the Category menu.

4.

In the Modernist options section, choose Do not restate within a beamed group for
Accidentals on repetitions of the same note within a beamed group.

5.

Click Apply, then Close.

Stacking of accidentals
If multiple accidentals are required for a chord in a single voice, or for notes in multiple voices at
the same rhythmic position, they are stacked to the left of the chord in columns.
For chords with multiple accidentals, accidentals are generally stacked as follows:
1.

The highest accidental is inserted in the first column immediately to the left of the notes.

2.

The lowest accidental is added to the same column, provided that it does not collide with
the first accidental.

3.

The remaining highest and lowest accidentals are alternated in successive columns located
further left from the chord.

In Dorico, additional rules help to produce a stack of accidentals that uses as few columns as
possible. The following list contains some of the rules that are applied:
●

Columns closer to the notes contain more accidentals than columns further from the
notes.

●

Accidentals on notes that are an octave apart are stacked in the same column. This also
applies to accidentals that are a sixth or more apart, depending on the combination of
accidentals.

●

Accidentals in the same column never collide. The minimum interval between accidentals
that is required to prevent collisions depends on the types of accidentals.

●

Accidentals that are a second apart are arranged in adjacent columns, with the higher
accidental in the right-hand column.

These rules minimize the amount of extra space that is required between successive notes or
chords and ensure that accidentals appear as close as possible to the noteheads to which they
apply. At the same time, they produce a contour that resembles a C-curve on the left-hand side of
the chord.

Stacking rules for dense chords
For dense chords with six or more accidentals within the span of an octave, accidentals are
stacked as follows:
1.

The highest accidental is inserted in the first column to the left of the notes.

2.

The next accidental on a note that is located at least a seventh below the highest note is
stacked into the same column. This continues with the remaining notes until no more
accidentals fit into the first column.

3.

Steps 1 and 2 are repeated for the following columns until all accidentals are stacked.
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4.

The columns are grouped, interspersed, and re-stacked. This results in a stack with
alternating accidentals, reminiscent of the way accidentals are arranged in a key signature.

Stacking accidentals without interspersion
You can allow accidentals to be stacked without interspersion, so that the accidentals in the
columns describe a diagonal line sloping downwards to the left.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Accidentals in the page list.

3.

In the Stacking section, choose Arrange stacks high to low for Order of accidental
stacks in lattice arrangement.

4.

Click Apply, then Close.

Changing the stacking rule for accidentals in dense chords
You can change the accidental stacking rule used for all dense chords project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Accidentals in the page list.

3.

In the Stacking section, choose one of the following options for Arrangement for dense
chords with many accidentals:

4.

●

Use lattice arrangement

●

Use zig-zag arrangement

Click Apply, then Close.

RESULT
The arrangement of accidentals in dense chords is changed project-wide.
NOTE
The lattice arrangement is wider and uses more columns than the default zig-zag arrangement
that is used in Dorico for dense chords.

Kerning of accidental columns
Dorico applies kerning to accidental columns to ensure that the columns to the left of a chord
occupy as little horizontal space as possible.
In typography, kerning adjusts the space between individual characters to increase legibility. In
Dorico, as well as in music engraving in general, kerning allows accidentals to interlock.
EXAMPLE
If a low note is followed by a high note with an accidental, the accidental can be tucked above the
low note to prevent the note spacing from being distorted.
Similarly, in the case of multiple columns of accidentals on a chord, the overall width of the stack
of accidentals is reduced if, for example, a flat in the second column is kerned underneath a
sharp in the first column belonging to a note a third higher. This also reduces the need to distort
note spacing to accommodate accidentals.
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Articulations are markings that are drawn above or below notes and chords. Articulations tell a
performer how to attack a note or how long to play a note relative to its notated duration.
In Dorico, articulations are defined as something that alters the way a note is played, in a way
that is consistent across all instruments.
As instructions like bowing directions, harmonics, or tonguing apply to different instrument
groups, in Dorico such directions are defined as playing techniques, and can be found in the
Notations panel on the right of the window.
Articulations are categorized into the following types:
●

Articulations of force
Indicate a stronger attack at the start of notes, and include articulations such as accent
and marcato, which is sometimes called a strong accent. Dorico shows these articulations
at the start of a note or tie chain by default.

●

Articulations of duration
Indicate a shorter duration than notated, and include articulations such as staccatissimo,
staccato, tenuto, and staccato-tenuto, which is sometimes called louré. If a note includes
ties, Dorico shows articulations of duration above the last note in the chain by default.

●

Articulations of stress
Indicate notes that should be emphasized or not emphasized where that contradicts the
prevailing meter, using stressed and unstressed marks. Dorico shows these articulations
at the start of a note or tie chain by default.

You can find the articulations at the bottom of the Notes panel in Write mode.

Dorico positions articulations automatically on the notehead or stem side of notes and chords,
according to the musical context. A note or chord can display one of each of the three types of
articulations.
You can change the effect of articulations on playback, based both on the type of instrument and
the playback devices in use in the Note Dynamics section of the Dynamics page in Playback
Options.
You can open Playback Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-P in any mode.

●

Choose Play > Playback Options in Play mode.
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RELATED LINKS
Inputting articulations on page 141

Copying articulations
Articulations are automatically included if you copy notes, but they cannot be copied and pasted
independently of notes.
PROCEDURE
1.

In Write mode, select the notes with articulations you want to copy.

2.

Copy the notes in one of the following ways:
●

Press R to repeat the material directly after itself.

●

Choose Edit > Copy, select the position where you want to copy the selected notes,
and choose Edit > Paste.
NOTE
You can also use the standard key commands of your operating system for copying
and pasting: usually Ctrl/Cmd-C for copy, and Ctrl/Cmd-V for paste.

●

Hold down Alt, then click at the position where you want to copy the selected notes
with articulations.

Changing articulations
You can change the articulations on notes after they have been input.
PROCEDURE
1.

In Write mode, select the note whose articulation you want to change.

2.

Change the articulation in any of the following ways:
●

Press the key command of the articulation you want. For example, press ] for
staccato.

●

Click the new articulation you want in the Notes panel.

RESULT
The new articulation is added. This replaces any existing articulation of the same type.
RELATED LINKS
Inputting articulations on page 141
Key commands for articulations on page 141

Deleting articulations
Individual articulation markings cannot be selected and deleted separately from their notehead
in Write mode, so articulations must be deleted by selecting the note or notes to which they are
attached, and deselecting the articulation.
PROCEDURE
1.

In Write mode, select the notes whose articulations you want to delete.

2.

Deselect the articulations in any of the following ways:
●

Press the key commands of the articulations you want to delete.
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●

Click the articulations you want to delete in the Notes panel.

RELATED LINKS
Key commands for articulations on page 141

Project-wide engraving options for articulations
You can find options for the appearance and placement of articulations project-wide on the
Articulations page in Engraving Options.
The options on this page allow you to change the positions of articulations in detail, including
whether different articulations are shown above the staff or by the notehead, the positions of
articulations relative to ties and slurs, and the vertical gaps between articulations and notes/
other articulations.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Articulations in the page list on the left of the dialog.

Positions of articulations
There are established conventions for the position and placement of articulations relative to
notes, the staff, and staff lines, which ensure articulations are always clearly visible. For the
smallest articulations, such as staccato marks, correct placement relative to staff lines in
particular is vital.
Articulations are placed on the notehead side by default, with the following exceptions:
●

In single-voice contexts, marcato is always placed above the staff, regardless of the stem
direction of the note or chord on which it is used. In multiple-voice contexts, marcato can
also be placed below the staff.

●

If multiple voices are active, articulations are placed at the end of the stem side of a note
or chord. This clarifies which articulations belong to the up-stemmed notes and which to
the down-stemmed notes.

●

If a note is placed on the middle staff line or on the space immediately on either side,
articulations that are less than a space in height are centered in the next unoccupied
space. This normally only applies to staccato and tenuto. If a note in the middle of the staff
has a staccato-tenuto articulation, the component parts of the articulation are split up and
placed in separate spaces.

●

If an articulation cannot fit within a staff space, or if the note is placed high or low on the
staff, the articulation is placed outside the staff.

●

If a note or chord is tied and the tie is placed above or below the notehead, articulations
that are placed on the notehead side of a note or chord are offset by an additional 1/4
space in order to avoid the end of the tie.

Articulations on the notehead side are always centered horizontally on the notehead. This also
applies to articulations on the stem side, except if the only articulation is a staccato or
staccatissimo. In this case, the articulation is centered on the stem.
RELATED LINKS
Project-wide engraving options for articulations on page 369
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Changing the horizontal position of staccato marks on page 371
Moving individual articulations vertically on page 371
Changing the placement of articulations on page 372
Changing the positions of articulations on tied notes on page 370

Order of articulations
If there are multiple articulations on the same notes, their vertical position and proximity to
noteheads/stems depends on their type.
Articulations are positioned in the following order:
1.

Articulations of duration are positioned closest to notehead/stems.

2.

Articulations of force are positioned outside articulations of duration.

3.

Articulations of stress are positioned furthest from noteheads/stems.

Order of articulations in relation to slurs
Articulations of duration are positioned as follows:
●

Inside slurs that start/end on a note or chord with an articulation.

●

Inside the curvature of a slur.

●

Inside tuplet brackets.

Articulations of force are positioned as follows:
●

Outside slurs that start/end on a note or chord with an articulation, except if they can be
positioned within the staff.

●

Inside the curvature of a slur if they fit between the slur and the note or stem, to which
they belong, without colliding.

●

Outside tuplet brackets.

Force and stress articulations outside the ends of the Duration articulations inside the ends of the slur
slur

Changing the positions of articulations on tied notes
You can change where in tie chains articulations appear individually, independently of your
project-wide settings. By default, articulations of force and stress are shown on the first note/
chord in tie chains, while articulations of duration are shown on the last note/chord.
PROCEDURE
1.

Select the tied notes whose articulation position you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Articulations group of the Properties panel, activate Pos. in tie chain under the
corresponding heading for the articulation whose position you want to change.
For example, activate Pos. in tie chain under the Articulations of force heading to
change the position of accents.

3.

Choose one of the following options:
●

First note
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●

Last note

RESULT
The position of articulations in the selected tie chains is changed.
TIP
You can change the default position of each type of articulation relative to all tie chains projectwide in the Ties section of the Articulations page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for articulations on page 369

Changing the horizontal position of staccato marks
You can change the default horizontal position of all staccato and staccatissimo articulations
when they are placed on the stem side of notes project-wide. By default, staccato and
staccatissimo articulations are centered on the stem when on the stem side.
The horizontal position of most articulations is centered on a stem or a notehead. However, if a
staccato or staccatissimo is the only articulation, its horizontal position can also be half-centered
when they are placed on the stem side.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Articulations in the page list.

3.

In the Horizontal Position section, choose one of the following options for Horizontal
position of staccato on stem side:

4.

●

Center on notehead

●

Center on stem

●

Half-center

Click Apply, then Close.

RESULT
Staccato marks are positioned project-wide according to the option selected.
RELATED LINKS
Project-wide engraving options for articulations on page 369

Moving individual articulations vertically
You can move individual articulations graphically upwards/downwards so they are closer to/
further away from notes.
PROCEDURE
1.

In Engrave mode, select the articulations that you want to move.

2.

Move the articulations in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
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TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.
●

Click and drag them upwards/downwards.

RESULT
The selected articulations are moved vertically.
TIP
●

When you move articulations vertically, Offset Y in the Articulations group of the
Properties panel is activated for the corresponding type of articulation. For example,
Offset Y under the Articulations of force heading is activated when you move accents.
You can also use these properties to move articulations vertically by changing the value in
the value field.
Deactivating the properties resets the selected articulations to their default positions.

●

You can change the default gaps between all articulations and their noteheads and other
articulations on the Articulations page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for articulations on page 369

Changing the placement of articulations
You can change whether individual articulations are placed on the notehead side or stem side of
notes.
PROCEDURE
1.

Select the notes or chords whose articulation placement you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Placement in the Articulations group.

3.

Select one of the following options from the menu:
●

Notehead side

●

Stem side

RESULT
The articulation is placed on the selected side of the notes or chords. If this creates a collision
with other markings, such as playing techniques, Dorico automatically makes adjustments to
make sure all markings are clear and legible.
RELATED LINKS
Moving individual articulations vertically on page 371

Articulations in playback
Adding articulations to your score affects how notes sound in playback.
If you do not have a sample library, Dorico still changes how a note sounds in playback if you
have put an articulation on it. For example, a staccato mark causes a note to sound shorter than
normal, and an accent causes a note to sound louder than normal.
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The Timing page in Playback Options provides options for the default effect of articulations of
duration. The Dynamics page contains options for articulations of force.
If you do have a sample library, Dorico loads the specific sample for an articulation if such a
sample is included in your sample library for that instrument.
As the articulation applies to the whole note, the sample is triggered at the start of a note. This
includes notes that are tie chains.
You can open Playback Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-P in any mode.

●

Choose Play > Playback Options in Play mode.
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Bars indicate a usually regular segment of time according to the number of beats, which is
usually determined by the prevailing time signature. Bars are separated from other bars to the
left and the right by vertical barlines.
Bars are usually the same length and at the same position for all players, but in some music, bars
of different lengths may coincide, and there are situations where some players may have no bars
indicated at all.
Each bar has a number, allowing players to keep track of their place in the music and aiding
rehearsal. This is especially important in music for multiple players.
RELATED LINKS
Bar numbers on page 388
Input methods for bars and barlines on page 155

Deleting bars
You can delete bars from your project completely by using the bars and barlines popover.
PROCEDURE
1.

In Write mode, select the first bar you want to delete, or the first note or rest in that bar.

2.

Open the bars and barlines popover in any of the following ways:

3.

●

Press Shift-B.

●

Choose Write > Create Bar or Barline.

Enter – (minus), followed by the number of bars you want to delete into the popover.
For example, enter –1 to delete just the selected bar, or –6 to delete six bars, meaning the
bar you selected and the subsequent five bars.

4.

Press Return to close the popover.

RESULT
The number of bars specified is deleted.

Deleting empty bars at the end of flows
You can delete any empty bars left at the ends of flows.
PROCEDURE
●

In Write mode, choose Write > Trim Flow.

RESULT
Empty bars at the end of the current flow are deleted.
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Deleting the contents of bars
You can delete just the contents of bars without deleting barlines or the bars themselves.
PROCEDURE
1.

In Write mode, select the bars whose contents you want to delete.
TIP
Notes, rests, and other objects are highlighted orange when selected.

2.

Delete the selected contents in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The contents of the selected bars are deleted.
RELATED LINKS
Selecting/Deselecting notes and items individually on page 108
Large selections on page 109
Filters on page 109

Changes to the length of bars
You can change the length of a bar so that its duration is longer or shorter.
You can change the length of a bar by changing its time signature. You can later hide the time
signature, for example, if you are writing music with an irregular meter and you require barlines
only to group material together, but not to imply any sense of meter.
RELATED LINKS
Inputting time signatures with the popover on page 153
Inputting time signatures with the panel on page 154
Hiding/Showing time signatures on page 761

Changing the width of empty bars
You can change the width of empty bars individually by activating Note Spacing in Engrave
mode.
PROCEDURE
1.

In Engrave mode, activate Note Spacing in the Formatting panel.

2.

Select a square handle at the rhythmic position of a barline at the start/end of an empty
bar whose width you want to change.

3.

Adjust the spacing in any of the following ways:
●

Press Alt-Right Arrow to increase the space to the left of the selected handle.

●

Press Alt-Left Arrow to decrease the space to the left of the selected handle.
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TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

RESULT
The width of the empty bar is changed.
For example, if you select the handle of the barline on the right of a bar and nudge the handle to
the left, the bar appears narrower. If you select the barline on the right of a bar and nudge the
handle to the right, the bar appears wider.
RELATED LINKS
Note spacing on page 284

Hiding/Showing bar rests in empty bars
You can hide/show bar rests in empty bars in each layout in your project independently of other
layouts. For example, you can hide bar rests in full score layouts but show bar rests in part
layouts.
Bar rests are usually shown in empty bars in music to indicate to performers that they have
nothing to play. However, there are contexts in which it is preferable to hide bar rests in empty
bars, and instead leave the bar completely empty.
For example, hiding bar rests in empty bars is sometimes the preferred visual aesthetic in large
scores, so that it is quicker to identify bars containing music. You can also hide bar rests in
layouts where you want to include other instructions, such as verbal indications for performers
to do something other than play notated pitches.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to hide/show bar rests in empty
bars in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Players from the Category menu.

4.

In the Bar Rests and Multi-bar Rests section, activate/deactivate Show bar rests in
empty bars.

RESULT
All bar rests in empty bars in the selected layouts are shown when the checkbox is activated, and
hidden when the checkbox is deactivated.
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Hiding/Showing multi-bar rests
You can hide/show multi-bar rests in each layout in your project independently of other layouts.
For example, you can hide multi-bar rests in full score layouts but show multi-bar rests in part
layouts.
Multi-bar rests group two or more consecutive empty bars together.

A multi-bar rest representing four empty bars

PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to hide/show multi-bar rests in
one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Players from the Category menu.

4.

In the Bar Rests and Multi-bar rests section, activate/deactivate Show multi-bar rests.

RESULT
Multi-bar rests are shown in the selected layouts when the checkbox is activated, and hidden
when the checkbox is deactivated.

Moving bar rest symbols
Although Dorico automatically positions rests in multiple-voice contexts to avoid collisions, you
can also move bar rests vertically.
PROCEDURE
1.

Select the bar rest symbol you want to move. You can do this in Write mode and Engrave
mode.
NOTE
You can only change the position of one bar rest symbol at a time.

2.

In the Properties panel, activate Rest pos. in the Notes and Rests group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.
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●

Click the arrows beside the value field.

RESULT
Position 0 is the middle line of the staff. The bar rest moves upwards when you increase the
value, and downwards when you decrease the value.
Deactivating Rest pos. returns the selected rests to their default positions.

Splits in bars
You can split bars rhythmically by changing the number of beats in each bar. You can split bars
visually across systems or frame breaks, which might be required in music with an irregular
meter or in passages of polymeter.

Splitting bars by inputting new time signatures
You can split bars into two or more bars by changing the time signature.
The new time signature you input applies until the next existing time signature or the end of the
flow, whichever comes first.
If the new time signature does not fit completely into the given space, for example, if you wanted
to replace two 4/4 bars (eight quarter notes) with either two 3/4 bars or three 3/4 bars (either six
or nine quarter notes), then Dorico does not override your existing time signature. Instead, the
final bar is made shorter.
For example, replacing a 4/4 time signature with a 3/4 time signature two bars before an existing
time signature creates two 3/4 bars and the equivalent of a 2/4 bar, as shown in this example.

However, if you activate Insert mode, then Dorico inserts time at the end of the final bar of the
new time signature to make sure the final bar is the correct length. For example, in the same
scenario as above but with Insert mode activated, two 4/4 bars become three 3/4 bars, with the
extra beat required to fill the third 3/4 bar added at the end of the phrase.

Splitting bars by inputting new barlines
You can also split bars by inputting new barlines that are not normal (single) barlines anywhere
within a bar without affecting the time signature.
However, inputting a normal (single) barline anywhere within an existing bar resets the pattern
of the time signature from that point onwards.
For example, selecting the third quarter note (crotchet) in a 4/4 bar and inserting a new barline
causes a new 4/4 bar to start from the added barline. This leaves the equivalent of a 2/4 bar
without a time signature to the left of the barline, but the bars to the right of the added barline
are in 4/4 and continue to be in 4/4 until the next time signature or the end of the flow,
whichever comes first.
After a normal (single) barline is added, a signpost appears to show how it affects the time
signature.
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Two 4/4 bars with quarter notes

Adding a normal barline halfway through the first
4/4 bar restarts the time signature from that point.

RELATED LINKS
Input methods for time signatures on page 150
Input methods for bars and barlines on page 155
Inserting system breaks on page 273
Inserting frame breaks on page 270
Inputting notes in Insert mode on page 120

Combining bars
You can combine two or more bars into one, longer bar by deleting the barline between them.
PROCEDURE
1.

In Write mode, select the barline you want to delete.

2.

Delete the barline in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The bars on either side of the deleted barline combine into one bar. If required, the notes inside
are automatically re-beamed appropriately.
NOTE
Deleting a barline does not automatically change the time signature. To avoid confusion, you can
add a new time signature to reflect the new rhythmic duration of the bar.

RELATED LINKS
Deleting barlines on page 382
Input methods for time signatures on page 150
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Barlines are vertical lines that cross staves in order to show how music is divided into bars,
according to the time signature.
There are a number of different types of barlines that are used in different contexts:
Normal (Single)
A standard single barline that spans the entire height of the staff. For single-line
staves, the barline extends one space above and below the staff line by default.

Double
A double barline consists of two lines, both the width of single barlines, positioned
half a space apart by default. It is often used to denote significant changes in the
music, or to mark the placement of rehearsal marks, key signature changes, and
tempo changes.

Final
A final barline consists of two lines: one of normal width, the other thick. It marks
where the music ends.

Dashed
A dashed barline has the same thickness as a normal barline, but has gaps within it
to give it a dashed appearance. It is used to subdivide bars to make complex time
signatures easier to read, and to differentiate editorial barlines from ones originally
in the manuscript.

Tick
A tick barline is a short line that spans only the top line of the staff. It is useful when
notating plainsong, in which context it denotes a breath or short gap between
phrases, or other music with an unusual metrical structure.
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Short
A short barline spans the middle of the staff, which on a five-line staff is between the
second and fourth lines. On staves with fewer than fives lines, the short barline is
scaled proportionally. It is useful when notating plainsong, in which context it
denotes a longer gap between phrases than a tick barline.

Thick
A thick barline is half a space wide by default, so it is noticeably thicker than a normal
barline. This gives it a greater visual impact.

Start repeat
A start repeat line consists of a thick barline, followed by a normal barline, followed
by one of the following arrangements of dots:
●

Two dots, one each in the middle two spaces of a five-line staff

●

Four dots, one each in all four spaces of a five-line staff

It shows the start of a repeated section. It is used alongside end repeat lines, which
show the end of a repeated section.

End repeat
An end repeat line is the mirror of a start repeat line, so it consists of either two or
four dots, followed by a normal barline, followed by a thick barline. It shows the end
of a repeated section. It is used alongside start repeat lines, which show the start of a
repeated section.

End/Start repeat
This line combines the start repeat and end repeat barlines, with either two single
barlines with a single shared thick barline in the middle, or two thick barlines and no
single barlines. On either side, there are either two or four repeat dots. It is used
when a repeated section is immediately followed by another, separate repeated
section.

RELATED LINKS
Input methods for bars and barlines on page 155
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Deleting barlines
You can delete barlines without affecting the rhythmic positions of notes.
PROCEDURE
1.

In Write mode, select the barlines you want to delete.

2.

Delete the barlines in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The barline is deleted. The two bars either side of the barline combine into one bar, containing
the same number of beats but without changing the time signature.
To avoid confusion, you can add a new time signature to reflect the new rhythmic duration of the
bar.
RELATED LINKS
Inputting time signatures with the popover on page 153
Inputting time signatures with the panel on page 154

Barline spacing
You can find options for the default spacing of all barlines project-wide on the Spacing Gaps
page in Engraving Options.
On the Spacing Gaps page in Engraving Options, you can change project-wide values for the
spaces before and after barlines, and between barlines and other staff objects, such as clefs,
time signatures, or key signatures.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Spacing Gaps in the page list on the left of the dialog.
RELATED LINKS
Project-wide engraving options for barlines on page 385

Moving barlines rhythmically
You can only move barlines to new rhythmic positions after they have been input by inputting
new barlines at the positions you want.
PROCEDURE
1.

In Write mode, input a new barline of your preferred type at the position you want.

2.

Delete the barline from the old position.
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NOTE
You can complete these steps in any order. However, deleting barlines can cause note and
beam groupings to change. If you are choosing a new barline position based on particular
phrases, this might make it harder to find the new position you want.

RELATED LINKS
Inputting barlines with the popover on page 160
Inputting barlines with the panel on page 161
Deleting barlines on page 382

Moving barlines graphically
You can adjust the spacing between barlines and neighboring notes, time signatures, key
signatures, or rests.
PROCEDURE
1.

In Engrave mode, activate Note Spacing in the Formatting panel.

2.

Select a note spacing handle at the rhythmic position of the barline.

3.

Move the handle in any of the following ways:
●

Press Alt-Right Arrow to move it to the right.

●

Press Alt-Left Arrow to move it to the left.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

NOTE
You cannot move note spacing handles using the mouse. You can only move them using
the keyboard.

RESULT
The spacing to the right/left of the barline is increased/decreased.
EXAMPLE

The new position of the barline after decreasing the space to its left
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Changing the barline shown at key signature changes
You can change the default barline shown at all key signature changes that occur at barlines
project-wide. By default, Dorico shows double barlines at key signature changes.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Barlines in the page list.

3.

In the Key Signatures section, choose one of the following options for Changes of key
signature at the start of the bar:

4.

●

Draw double barline

●

Draw single barline

Click Apply, then Close.

RESULT
The barline shown at all key signature changes that occur at the start of bars is changed projectwide.

Barlines across staff groups
In order to make it easier to find a particular instrument within a score, barlines can extend
across instrumental and staff groups.

Using default staff groups
When a barline only appears on individual staves, it is much harder to locate individual lines at a
glance. However, when barlines continue across instrumental groups in the score, instrument
families are shown as blocks, which makes finding an instrument much easier.

Barlines on individual staves

Barlines across instrumental groups

Barlines extend across staff groups when they are joined by a bracket. Which staves are included
in a bracket depends on the instrumentation and context, but usually staves for instruments
from the same family, such as woodwind or strings, are bracketed together.
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By default, Dorico brackets staves according to their instrument family. This means that in
projects with only a few instruments, barlines do not extend across the whole ensemble, because
all the instruments are from different families.
You can change the bracketing style according to the ensemble type in your project on the
Brackets and Braces page in Engrave > Engraving Options.

Making custom staff groups
You can also manually arrange your players into groups, which have their own bracket and
barline groupings.
If one or more players included in your group were previously in another group, any remaining
instruments in their previous group remain grouped.
You can select a single player and add it to its own group in order to have it appear separately,
which could be useful for showing a soloist separately from the remainder of the ensemble, such
as in a concerto.
RELATED LINKS
Changing bracket grouping according to ensemble type on page 424
Adding groups of players on page 86
Adding players to groups on page 87
Deleting player groups on page 86

Showing barlines across all staves at time signature changes
You can join all staves with a barline at time signature changes in individual layouts, regardless of
your bracketing style.
PROCEDURE
1.

Select the time signature changes where you want to join all staves with a barline. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Barline joins all staves in the Time Signatures group.

RESULT
All staves in the layout currently open in the music area are joined by a barline at the selected
time signature changes.
RELATED LINKS
Barlines across staff groups on page 384

Project-wide engraving options for barlines
You can find options for the project-wide appearance of barlines on the Barlines page in
Engraving Options.
The options on the Barlines page allow you to change the appearance and thickness of barlines,
and which barlines are used in different contexts.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.
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You can then click Barlines in the page list on the left of the dialog.
RELATED LINKS
Barline spacing on page 382

Per-flow notation options for barlines
You can set the appearance of barlines in each flow in your project independently on the
Barlines page in Engraving Options.
On the Barlines page, you can change which barline is shown by default at the end of each flow,
and choose whether barlines join all staves at the end of each system and at the end of the final
system in a flow.
You can open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

●

Click Notation Options on the right of the Flows panel in Setup mode.

You can then select Barlines from the Category menu.

Changing the default barline at the end of flows
You can choose which type of barline is placed automatically at the end of each flow.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.
The Notation Options dialog opens.

2.

In the Flows list, select the flows in which you want to change the default barline in one of
the following ways:
●

Ctrl/Cmd-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Select Barlines from the Category menu.

4.

Choose one of the following options for Automatic barline at end of flow:
●

Final barline

●

Double barline

●

Normal barline

●

Dashed barline

●

Thick barline

●

No barline

RESULT
The default final barline at the end of the selected flows is changed.
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TIP
You can override individual final barlines by changing their type, but you cannot delete individual
final barlines.

RELATED LINKS
Inputting barlines with the popover on page 160
Inputting barlines with the panel on page 161
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Bar numbers provide a crucial reference point for music that has multiple players, and make the
chronological sequence of the music clear. They indicate where players are in the piece, which
allows them to co-ordinate themselves easily in rehearsals and concerts.
Bar numbers can also be useful when preparing parts and scores, as you can use bar numbers
and rehearsal marks to help you quickly compare a part to the score and check it is correct.
In Dorico, bar numbers appear automatically, following the most common practice of showing a
bar number at the start of each system in scores and parts by default.
However, sometimes it is useful to show a bar number for every bar, which is frequently done for
film music scores. You can also show bar numbers at a regular interval, such as every five bars,
but this can be misleading as it can give the impression that those bars are significant,
particularly if bar numbers are shown within an enclosure.
RELATED LINKS
Changing the bar number frequency on page 389
Changing the bar number enclosure type on page 391

Changes to the appearance of bar numbers
You can change different aspects of the appearance, frequency, and position of bar numbers in
three places in Dorico.
You can change the appearance of bar numbers in the following places:
●

On the Bar Numbers page in Setup > Layout Options.

●

On the Bar Numbers page in Engrave > Engraving Options.

●

In the Edit Font Styles dialog.

Layout Options
On the Bar Numbers page in Layout Options, you can change the following aspects of the
appearance and position of bar numbers:
●

Bar number frequency

●

Placement above/below the staff

●

Distance from the staff and from other objects

●

Horizontal position

●

Enclosure type

●

Hiding/Showing bar numbers at rehearsal marks

●

Hiding/Showing the first bar number when bar numbers are shown every bar

You can change options for bar numbers for each instrument layout and full score layouts
independently of each other within the dialog. For example, you can show bar numbers every
bar in full score layouts but only at the start of each system in part layouts.
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You can open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options at the bottom of the Layouts panel in Setup mode.

●

Right-click an instrumental part or a full score in the Layouts panel and choose Layout
Options from the context menu.

Engraving Options
On the Bar Numbers page in Engraving Options you can change the case of letters in
subordinate bar numbers and the thickness and padding values for bar number enclosures.
This affects all layouts that show bar numbers in enclosures.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Edit Font Styles dialog
You can change different aspects of the bar number font style, such as their font size, in the Edit
Font Styles dialog.
●

You can open the Edit Font Styles dialog in Engrave mode by choosing Engrave > Font
Styles.

NOTE
Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Changing the bar number frequency on page 389
Changing the bar number font style on page 390
Changing the bar number enclosure type on page 391
Edit Font Styles dialog on page 275

Changing the bar number frequency
You can change how frequently bar numbers appear in each layout independently of other
layouts. For example, you can have bar numbers appear with different frequencies in full score
layouts compared to individual part layouts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the bar number
frequency in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.
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●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Bar Numbers from the Category menu.

4.

Choose one of the following options for Show bar numbers:
●

Every system

●

Every n bars

●

Every bar

●

None

Selecting Every n bars activates the Interval value field.
5.

Optional: Change the value for Interval in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
The frequency of bar numbers in the selected layouts is changed.
Changing the Interval value changes how frequently bar numbers are shown. For example,
setting an interval value of ten means that bar numbers are shown every tenth bar.
RELATED LINKS
Changes to the appearance of bar numbers on page 388

Changing the bar number font style
You can change the font style used for all bar numbers project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles.
The Edit Font Styles dialog opens.

2.

Select Bar Number Font from the Font style menu.

3.

Activate the following options, individually or together, to change the corresponding
aspect of the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The bar number font style is changed project-wide.
RELATED LINKS
Changes to the appearance of bar numbers on page 388
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Changing the bar number enclosure type
If you want bar numbers to be clearly distinguished, you can enclose them in a rectangular or
circular enclosure. You can change the bar number enclosure type in each layout independently
of other layouts.
For example, you can have bar numbers appear with different enclosures in full score layouts
compared to individual part layouts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the bar number
enclosure type in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Bar Numbers from the Category menu.

4.

Choose one of the following options for Enclosure type:

5.

●

None

●

Rectangle

●

Circle

Click Apply, then Close.

RESULT
Bar numbers in the selected layouts are shown within your selected enclosure type. The size of
the enclosure is relative to the font size of the bar numbers, but the size and shape of the
enclosure are also determined by your padding values.
EXAMPLE

Bar number with no enclosure

Bar number with a rectangle
enclosure

RELATED LINKS
Layout Options dialog on page 62
Bar number enclosure size and padding values on page 392
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Bar number enclosure size and padding values
In the Enclosure section of the Bar Numbers page in Engrave > Engraving Options, there are a
number of options to control the shape and size of bar number enclosures.

Rectangle bar number enclosure
The figure shows a rectangle bar number enclosure with default settings. The minimum height
and minimum width are both 2 spaces, horizontal padding is half a space, and minimum bottom
and minimum top padding are both 1/8 of a space.

Adjusting the minimum values can help make bar number enclosures more consistent projectwide, as the default values can allow their size to vary significantly, depending on the size and
shape of the bar number inside. This might make a narrow bar number less obvious to a
conductor. Increasing Minimum width to reduce the difference in size can create a more
consistent visual effect.

Bar numbers with rectangle enclosures, default
minimum width

Bar numbers with rectangle enclosures, minimum
width increased to 5

Minimum width
Sets a minimum value for the width of enclosures. In this example, the value was
increased from 2 spaces to 6 spaces.

Minimum height
Sets a minimum value for the height of enclosures. In this example, the value was
increased from 2 spaces to 6 spaces.

Minimum horizontal padding
Sets a minimum value for the distance between the two sides of the enclosure and
the bar number within it. In this example, the value was increased from 1/2 a space
to 4 spaces.
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Minimum bottom padding
Sets a minimum value for the distance between the bottom line of the enclosure and
the bar number within it. In this example, the value was increased from 1/8 of a
space to 2 spaces.

Minimum top padding
Sets a minimum value for the distance between the top line of the enclosure and the
bar number within it. In this example, the value was increased from 1/8 of a space to
2 spaces.

Circle bar number enclosure
The figure shows a circle bar number enclosure with default settings. The minimum diameter is 2
spaces, and the minimum padding is 1/6 of a space.

Minimum diameter
Sets a minimum value for the diameter of the enclosure. In this example, the value
was increased from 2 spaces to 8 spaces.

Minimum padding
Sets a minimum value for the distance between the enclosure line and the bar
number within it. In this example, the value was increased from 1/6 of a space to 1
space.
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All enclosures
Enclosure line thickness
Sets the thickness of enclosure lines for both rectangle and circle enclosure types.
The default is 1/8 of a space. The examples have a thickness of 1/2 a space.

NOTE
Changing the Enclosure line thickness changes the thickness of bar number
enclosures in all layouts in the project. Changing any padding values for rectangle
enclosures affects all layouts with rectangle enclosures, and changing any padding
values for circle enclosures affects all layouts with circle enclosures.

Positions of bar numbers
You can change the default positions of all bar numbers project-wide on the Bar Numbers page
in Layout Options, and you can move individual bar numbers in Engrave mode.
NOTE
Bar numbers can only be shown at one position per system. You cannot show bar numbers
above/below multiple staves in a single system.

RELATED LINKS
Changing the horizontal position of bar numbers on page 394
Changing the distance between bar numbers and the staff on page 395
Changing the position of bar numbers relative to other objects on page 396
Changing the placement of bar numbers relative to the staff on page 396

Changing the horizontal position of bar numbers
You can change the horizontal position of bar numbers in each layout independently of other
layouts. For example, you can have bar numbers at a different horizontal position in full score
layouts compared to individual part layouts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the horizontal position
of bar numbers in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.
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By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Bar Numbers from the Category menu.

4.

Choose one of the following options for Horizontal position:
●

Centered on barline

●

Centered on bar

RESULT
Centered on barline shows bar numbers above barlines, at the top left of the bar.
Centered on bar shows bar numbers above the staff, in the middle of the bar.

Changing the distance between bar numbers and the staff
You can change the minimum value for how far away from the staff bar numbers appear in each
layout independently of other layouts. For example, you can position bar numbers differently in
full score layouts compared to individual part layouts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the minimum distance
of bar numbers from the staff in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Bar Numbers from the Category menu.

4.

Change the value for Minimum distance from staff in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

The default value is 2 spaces.
RESULT
If you increase the value, bar numbers are positioned further away from the staff, either above
or below depending on your setting for Placement relative to staff. If you decrease the value,
bar numbers are positioned closer to the staff.
NOTE
This affects the minimum distance away from the staff, so bar numbers might be positioned
further away than this to avoid collisions.

RELATED LINKS
Changing the placement of bar numbers relative to the staff on page 396
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Changing the position of bar numbers relative to other objects
You can change the minimum value for how far away from other objects bar numbers are
positioned in each layout independently of other layouts. For example, you can have bar
numbers appear closer to objects in individual parts than in the score.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the minimum distance
of bar numbers relative to other objects in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Bar Numbers from the Category menu.

4.

Change the value for Minimum distance from other objects in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

The default value is 3/4 of a space.
RESULT
If you increase the value, bar numbers are positioned further away from other objects, either
above or below depending on your setting for Placement relative to staff.
If you decrease the value, bar numbers are positioned closer to other objects.
RELATED LINKS
Changing the placement of bar numbers relative to the staff on page 396

Changing the placement of bar numbers relative to the staff
You can change the side of the staff on which bar numbers appear for each layout independently
of other layouts. For example, bar numbers can appear below the staff in full score layouts but
above the staff in individual part layouts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the bar number
placement in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.
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●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Bar Numbers from the Category menu.

4.

Choose one of the following options for Placement relative to staff:
●

Above

●

Below

Moving bar numbers graphically
You can move individual bar numbers graphically without changing the rhythmic positions to
which they apply.
PROCEDURE
1.

In Engrave mode, select the bar numbers you want to move.

2.

Move the bar numbers in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

RESULT
The selected bar numbers are moved graphically.
TIP
The following properties in the Time Signatures group of the Properties panel are activated
automatically when you move bar numbers in the corresponding directions:
●

Bar number X moves bar numbers horizontally.

●

Bar number Y moves bar numbers vertically.

You can also use these properties to move bar numbers graphically by changing the values in the
value fields.
Deactivating the properties resets the selected bar numbers to their default positions.

RELATED LINKS
Adding bar number changes on page 398
Changing the horizontal position of bar numbers on page 394
Changing the distance between bar numbers and the staff on page 395
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Bar number changes
Bar numbers follow a continuous sequence, with each bar having a unique bar number that
follows on from the previous bar number. However, you can make manual changes to the bar
number sequence, including changing to a subordinate sequence.
In Dorico, you can make the following types of changes to bar number sequences using the
Insert Bar Number Change dialog:
Primary
The main bar number sequence, which bars in your project follow by default.
Subordinate
A secondary bar number sequence that uses letters rather than numbers to indicate
the sequence. This can be useful in situations where a new version of a piece has
been created with more bars inserted, but the original bar numbers are required.
Don’t Include
Excludes the selected bar from the current bar number sequence. If bar numbers are
shown every bar, no bar number is shown in bars in which you have chosen Don’t
Include.
Continue Primary
Returns the bar number sequence to the Primary sequence without counting
intervening bars, for example, after a section of bars following the Subordinate bar
number sequence.
RELATED LINKS
Adding bar number changes on page 398
Subordinate bar numbers on page 399

Adding bar number changes
You can manually add bar number changes to bar number sequences, for example, if you want
bar numbers in the second flow in your project to appear to continue the sequence from the
first, rather than start again from bar one.
PROCEDURE
1.

Select one of the following:
●

An item in the bar from the beginning of which you want to change the bar number
sequence.

●

An existing bar number or barline from which you want to change the bar number
sequence.

You can do this in Write mode and Engrave mode.
2.

Choose Edit > Bar Numbers > Add Bar Number Change. You can also choose this option
from the context menu.
The Insert Bar Number Change dialog opens.

3.

Choose one of the following options for Type:
●

Primary

●

Subordinate

●

Don’t Include

●

Continue Primary
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4.

5.

Optional: If you chose Primary or Subordinate, change the value with which you want the
bar number sequence change to start in the corresponding value field in any of the
following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

Click OK to save your changes and close the dialog.

RESULT
The bar number sequence changes, starting from the beginning of the bar in which you selected
an item, or from the position of a selected bar number or barline.
This affects the corresponding bar number sequence from the changed bar number until the
next bar number change, or until the end of the flow.
RELATED LINKS
Bar number changes on page 398

Deleting bar number changes
You can delete any bar number changes you have added.
PROCEDURE
1.

In Write mode, select the bar number changes you want to delete.

2.

Delete the bar number changes in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The bar number changes are deleted. Subsequent bars follow the previous bar number
sequence until the next bar number change, or until the end of the flow.

Subordinate bar numbers
Subordinate bar numbers are useful for organizing repeat endings, and for situations when the
music is being altered, but the original bar numbers cannot be changed.
For example, you can use subordinate bar numbers to show where music has been added if a
previous, shorter version has already been rehearsed. In this situation, players have likely started
to associate certain parts of the piece with particular bar numbers, so if four bars need to be
added after bar 10, they would be numbered 10a to 10d, after which the bar number continues
from 11 exactly as it did before the new bars were added.
They might also be useful if you want different bar numbers for a repeat ending.
Subordinate bar numbers can be presented as either upper case letters or lower case letters.

Lower case subordinate bar number

Upper case subordinate bar number

RELATED LINKS
Changing the appearance of subordinate bar numbers on page 401
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Adding subordinate bar numbers
You can create a subordinate bar number sequence that is independent of your primary bar
number sequence. This can be useful if you want to insert new bars without changing the bar
numbers of existing subsequent bars.
PROCEDURE
1.

Select one of the following:
●

An item in the bar from the beginning of which you want subordinate bar numbers
to start.

●

An existing bar number or barline from which you want subordinate bar numbers to
start.

You can do this in Write mode and Engrave mode.
2.

Choose Edit > Bar Numbers > Add Bar Number Change. You can also choose this option
from the context menu.
The Insert Bar Number Change dialog opens.

3.

Choose Subordinate for Type.
This activates the Subordinate value field.

4.

Change the value in the value field in any of the following ways:
●

Enter a number into the value field.

●

Click the arrows beside the value field.

The corresponding alphabetical letter is shown to the right of the value field. For example,
entering 1 into the value field is shown as a, 2 appears as b, and so on.
5.

Click OK to save your changes and close the dialog.

RESULT
The subordinate bar number sequence starts from the bar in which you selected an item, or from
the position of a selected bar number or barline. It has the same bar number as the bar
immediately before, but with subordinate alphabetical letters.
For example, if you start a subordinate bar number sequence from what was originally bar 5, the
sequence starts from 4a and continues until the next specified bar number change, or until the
end of the flow.

Returning to the primary bar number sequence
You can specify the point where you want to return to the primary bar number sequence after a
section of subordinate bar numbers.
PROCEDURE
1.

Select one of the following:
●

An item in the bar from the beginning of which you want to return to the primary
bar number sequence.

●

An existing bar number or barline from which you want to return to the primary bar
number sequence.

You can do this in Write mode and Engrave mode.
2.

Choose Edit > Bar Numbers > Add Bar Number Change. You can also choose this option
from the context menu.
The Insert Bar Number Change dialog opens.

3.

Choose Continue Primary for Type.
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Text appears below the value fields for Primary and Subordinate. For example, Primary
sequence will continue from bar 5.
4.

Click OK to save your changes and close the dialog.

RESULT
The primary bar number sequence resumes from the bar in which you selected an item, or from
the position of a selected bar number or barline.
TIP
You do not have to add subordinate bar number changes in chronological order. You can enter a
return to the primary bar number sequence first, before adding the subordinate bar number
sequence.

Changing the appearance of subordinate bar numbers
You can show subordinate bar numbers as either lower case or upper case letters.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Bar Numbers in the page list.

3.

In the Sequence section, select how you want subordinate numbers to appear:
●

Lower case (default)

●

Upper case

Bar numbers in parts
You can show bar numbers differently in each layout independently. For example, you can show
bar numbers every bar in full score layouts but only at the start of each system in the part
layouts.
You can change the following aspects of the appearance of bar numbers independently in each
layout:
●

Bar number frequency

●

Minimum distance from staff and other objects

●

Horizontal position

●

Enclosure type

NOTE
●

You cannot change the size of bar numbers in each layout independently. One bar number
font size applies to all layouts in your project.

●

Changing values for enclosure sizes, padding values, and line thickness changes the
corresponding aspect of bar number enclosures in all layouts in the project.

RELATED LINKS
Changing the bar number font style on page 390
Changing the bar number frequency on page 389
Changing the distance between bar numbers and the staff on page 395
Changing the position of bar numbers relative to other objects on page 396
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Changing the bar number enclosure type on page 391
Bar number enclosure size and padding values on page 392

Bar numbers in repeat endings
By default in Dorico, bar numbers continue through repeat endings.
For example, in a repeat section ending at the end of bar 10, the bar number at the start of the
second time section is bar 11.
You can manually change bar numbers so that bar numbers in repeat endings reflect the total
number of bars played, rather than the number of bars written on the page. For example, in a
repeat section starting at the beginning of the piece and ending at the end of bar 10, you might
want the bar number at the start of the second time section to be 20 rather than 11.
You can do this by adding a bar number change at the start of the second time section.
EXAMPLE

Default bar numbers in a repeat ending

Bar numbers changed to reflect the total number of
bars played

RELATED LINKS
Adding bar number changes on page 398
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A beam is a line that connects notes with tails to show rhythmic grouping, which varies according
to the metrical structure of the current time signature.
This way of grouping notes helps performers calculate quickly exactly how to play their given
rhythm and helps them follow both their part and, if applicable, the conductor.
If appropriate for the current meter and position in the bar, beams are automatically formed in
Dorico when you input two or more adjacent notes or chords that are an eighth note (quaver) or
shorter in duration.
There are many different accepted standards for how to present beams, so Dorico offers a
number of customizing options. You can find these options on the Beams page in Engrave >
Engraving Options.
You can find options that control how notes are grouped into beam groups by default in each
flow on the Beam Grouping page in Write > Notation Options.
RELATED LINKS
Inputting notes on page 115
Beaming notes together manually on page 404
Per-flow changes to beam grouping defaults on page 403
Engraving Options dialog on page 228
Notation Options dialog on page 110

Beam groups
You can control how notes are beamed in several different ways in Dorico.
You can set beam grouping defaults in each flow in your project independently in Notation
Options.
You can set beam groups by controlling subdivisions of time signatures.
You can change beam groups individually using properties in the Properties panel, and by
choosing Edit > Beaming and selecting one of the available options.
RELATED LINKS
Per-flow changes to beam grouping defaults on page 403
Beaming notes together manually on page 404
Beams according to time signatures on page 404

Per-flow changes to beam grouping defaults
You can change the default beam grouping rules for each flow independently on the Beam
Grouping page in Notation Options.
Dorico has sophisticated underlying rules for producing beam groupings that follow the
accepted conventions of music theory, including crossing the half-bar in time signatures like 4/4,
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beaming all eighth notes together in 3/4, beam groups that include tuplets, and many other
situations.
There are alternative conventions for some of these rules, so you can change your default beam
grouping rules for each flow in your project independently on the Beam Grouping page in
Notation Options.
You can open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

●

Click Notation Options on the right of the Flows panel in Setup mode.

Beams according to time signatures
Default beam groupings are determined by the time signature, which you can customize by
specifying the subdivision of beats within bars and changing your per-flow beam grouping
settings in Notation Options.
Dorico has default beaming settings for common time signatures, based on general conventions
and your chosen settings. For example, phrases are beamed in quarter notes (crotchets) when in
3/4, but in dotted quarter notes when in 6/8.
For situations where you want to control the beam grouping in more detail, you can input a
custom time signature with an explicit rhythmic subdivision. Dorico then automatically beams
phrases according to this subdivision. For example, entering [7]/8 into the time signatures
popover means all seven eighth notes (quavers) are beamed together, whereas entering
[2+2+3]/8 subdivides the seven eighth notes into two, then two, then three.
NOTE
The duration of beam groups in Dorico depends on the beat grouping in the current time
signature and your per-flow beam grouping settings in Write > Notation Options.

RELATED LINKS
Note and rest grouping on page 420
Creating custom beat groupings for meters on page 421

Beaming notes together manually
You can beam notes together manually, including notes across barlines as well as system breaks
and frame breaks.
For example, if you want to change individual beam groups independently of your default beam
grouping settings for the current flow.
Beams by default stay within bars and systems, so to have beams cross barlines, system breaks,
and frame breaks, you must force the phrase to beam together.
PROCEDURE
1.

Select the notes you want to beam together. You can do this in Write mode and Engrave
mode.

2.

Choose Edit > Beaming > Beam Together. You can also choose this option from the
context menu.
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RESULT
The selected notes are beamed together, even if they cross barlines, system breaks, or frame
breaks.
If there are notes either side of the new beam group that were previously beamed to part or all
of your selection, they either beam together as separate beams, or appear unbeamed. This
depends on how many notes are left either side in the bar, and on the beam grouping settings
for the flow.
NOTE
Even if part of the beamed group previously had a centered beam, the new beam is not centered.

RELATED LINKS
Creating fanned beams on page 418

Splitting beam groups
You can split beams and secondary beams into two beam groups at specific rhythmic positions.
You can also split secondary beams within beamed groups.
PROCEDURE
1.

Select the noteheads to the right of where you want to split beams. You can do this in
Write mode and Engrave mode.

2.

Split the beam or secondary beam in one of the following ways:
●

Choose Edit > Beaming > Split Beam.

●

Choose Edit > Beaming > Split Secondary Beam.

TIP
You can also choose these options from the context menu.

RESULT
The beam or secondary beam is split to the left of the selected note, but the notes either side of
the split remain grouped if there are at least two beamed notes on each side that can be in a
beam group.
NOTE
To unbeam the entire selection and give all notes in the group individual tails, you can make all
notes unbeamed.

RELATED LINKS
Unbeaming notes on page 406

Changing the direction of partial beams
Dorico automatically inputs a partial beam if one is required. You can change on which side of
stems individual partial beams appear.
PROCEDURE
1.

Select a note with a partial beam. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Partial beam direction in the Beaming group.

3.

Choose one of the following options:
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●

Left

●

Right

RESULT
The partial beam appears on the corresponding side of the stem.
EXAMPLE

Partial beam direction Left

Partial beam direction Right

Unbeaming notes
You can separate all notes in a beamed group so that each note shows its own tail.
This can be useful when setting syllabic text with a fast rhythm.
PROCEDURE
1.

Select the notes you want to make unbeamed. You can do this in Write mode and Engrave
mode.

2.

Choose Edit > Beaming > Make Unbeamed. You can also choose this option from the
context menu.

Resetting beam grouping
You can remove all changes made to the beam grouping of notes and chords.
PROCEDURE
1.

Select the notes or chords whose beaming you want to reset. You can do this in Write
mode and Engrave mode.

2.

Choose Edit > Beaming > Reset Beaming. You can also choose this option from the
context menu.

RESULT
Beam grouping is reset to your default settings in Notation Options for the current flow and
time signature.

Beam placement relative to the staff
You can change the placement relative to the staff of the stems within beams, so that beams
appear on the other side of the staff to their default placement.
The default placement of beams relative to the staff is determined by the staff positions of the
notes within the beamed group.
This means that the note furthest from the middle line of the staff determines the placement of
the beam, although there are exceptions to this rule and other considerations that can influence
the placement of beams relative to the staff.
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Changing the placement of beams relative to the staff involves changing the direction of the
stems in the beam. Therefore, Dorico categorizes changing the placement of beams relative to
the staff as a stem change.
RELATED LINKS
Changing the placement of beams relative to the staff on page 407

Changing the placement of beams relative to the staff
You can change on which side of the staff a beam appears by forcing the stem direction to
change.
PROCEDURE
1.

Select one or more notes in the beamed phrases whose placement relative to the staff you
want to change. You can do this in Write mode and Engrave mode.

2.

Force the stem direction of notes in the selected beams in any of the following ways:
●

Choose Edit > Stem > Force Stem Up.

●

Choose Edit > Stem > Force Stem Down.

TIP
You can also choose these options from the context menu.

RESULT
The beam appears on the side of the staff that corresponds to its forced stem direction.

Removing beam placement changes
You can undo changes to the placement of beams relative to the staff in order to remove the
stem direction change. This reverts selected beams to their default placement.
PROCEDURE
1.

Select one or more notes in the beamed phrases whose placement change relative to the
staff you want to remove. You can do this in Write mode and Engrave mode.

2.

Choose Edit > Stem > Remove Forced Stem. You can also choose this option from the
context menu.

RESULT
The selected beams revert to their default placement relative to the staff.

Beam slants
The slant of a beam controls how steeply the beam deviates from horizontal, according to the
pitches of the notes within the beamed group.
●

When the last note of the phrase is higher than the first, the beam slants upwards.

●

When the last note of the phrase is lower than the first, the beam slants downwards.

If the group makes a concave shape, where inner notes are closer to the beam than the outer
ones at either end of the beam, then the beaming is horizontal by default.
Beams are also horizontal if all the pitches are the same, or for certain patterns of repeated
pitches.

407

Beaming
Beam slants
When a beam is drawn inside the staff, each end of the beam, meaning the end of the stem of
the note at either end of the beam, must be snapped to a staff line position. A beam line may sit
on a staff line, be centered on a staff line, or hang from a staff line. Ted Ross describes these
three positions as “sit”, “straddle”, and “hang” respectively in “Teach Yourself the Art and Practice
of Music Engraving”.
The amount by which a beam slants is typically determined by the interval between the first and
last note in the beamed group, provided the pattern of notes in the beam does not dictate a
horizontal beam instead. Smaller intervals require a shallower slant and larger intervals require a
steeper one.
However, the desired amount of slant is not the only factor that must be considered. The
innermost beam line should not come too close to the innermost notehead, and the beam itself,
if possible, should be positioned relative to the staff lines such that it does not form a wedge. A
wedge is a tiny triangle formed by the horizontal staff line, the vertical stem, and the angled line
of the slanted beam, which can be visually confusing.
Determination of the amount of slant for a beam is therefore a balancing act that must weigh up
several factors: the desired amount of slant, valid snapping positions for each end of the beam,
ensuring a minimum distance between the note closest to the beam and the innermost beam
line, and avoiding wedges where possible.
You can change the default settings for how beams appear project-wide.
●

You can specify the minimum stem length for notes of different durations on the Notes
page in Engrave > Engraving Options.

●

You can set ideal beam slants on the Beams page in Engrave > Engraving Options.

You can also change the beam slants of individual beams.
RELATED LINKS
Changing beam slants on page 408

Changing beam slants
You can change the slants, or angles, of individual beams.
PROCEDURE
1.

In Engrave mode, select the square handles on the beam corners of the beams whose
slants you want to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
You can also select the beams first, and then select the handles.

2.

Move the handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●
3.

Click and drag them upwards/downwards.

Optional: Repeat steps 1 and 2 to move the other end of the selected beams.
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RESULT
The slants of the selected beams are changed.
TIP
You can also use Beam direction in the Beaming group of the Properties panel to change the
slant of beams. The property is available when you select noteheads within the beam group, and
has the following beam slant options:
●

Flat

●

Up

●

Down

These options all ensure that beam ends are positioned correctly relative to staff lines.

Centered beams
Centered beams are positioned between high and low notes within the same beamed group,
typically drawn in the middle of the staff.
Centered beams are also known as “kneed” or “elbowed” beams due to their often angular
shape.

When a beamed phrase spans a large pitch range, normal beams are often positioned very close
to some notes in the phrase but very far from other notes in the phrase, making some stems
very long. Having a centered beam in a phrase that spans a large pitch range can reduce the
maximum distance between noteheads and the beam, but can also place the beam within the
staff, which can obscure staff lines.

A phrase with high and low notes with default
beaming

The same phrase with high and low notes, but with a
centered beam

RELATED LINKS
Creating centered beams on page 410
Changing the placement of beams relative to the staff on page 407
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Creating centered beams
You can make beams appear in the middle of staves, with high notes above the beam and lower
notes below the beam.
NOTE
As this action requires changing the direction of some stems in order to appear correctly, it is
located in the Stem submenu rather than Beaming in the Edit menu.

PROCEDURE
1.

Select notes in the beams you want to center. You can do this in Write mode and Engrave
mode.
TIP
You do not have to select all notes in the beam.

2.

Choose Edit > Stem > Force Centered Beam. You can also choose this option from the
context menu.

RESULT
Beams are centered between the notes in the selected beam groups.
If you select notes in multiple beams, each beam is centered separately. If you want to create a
single centered beam, you can beam the notes in those beam groups together. You can do this
both before/after centering the beams.
NOTE
Dorico automatically angles the beam based on the shape of the phrase, but you can change the
angles or slants of beams manually in Engrave mode.

RELATED LINKS
Beaming notes together manually on page 404
Changing beam slants on page 408

Removing centered beams
You can remove centered beams and revert beams to their default placements either above or
below the phrase.
PROCEDURE
1.

Select one or more notes within the centered beams that you want to revert to their
default placement. You can do this in Write mode and Engrave mode.

2.

Choose Edit > Stem > Remove Centered Beam. You can also choose this option from the
context menu.

RESULT
The centered beams are removed.
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Creating cross-staff beams
Cross-staff beams work in a similar way to normal beams, but allow a phrase that covers a wide
pitch range to be shown on two staves. You can create cross-staff beams by inputting all notes in
the phrase on one staff and crossing some notes to appear on another staff.
PREREQUISITE
You have input a phrase in one staff.
PROCEDURE
1.

Select the notes you want to cross to another staff. You can do this in Write mode and
Engrave mode.
NOTE
You can only cross notes to other staves in grand staff instruments.

2.

Cross the notes to other staves in any of the following ways:
●

To cross notes to the staff above, press N.

●

To cross notes to the staff below, press M.

●

Choose Edit > Cross Staff > Cross to Staff Above.

●

Choose Edit > Cross Staff > Cross to Staff Below.

RESULT
The selected notes are shown on a different staff, with a cross-staff beam shown if the notes are
part of a beam group. This does not change the staff to which the notes belong.
NOTE
●

When crossing notes to a staff that already contains notes, the stem direction of the
existing notes on the staff can change. This is due to how multiple voices at the same
rhythmic position are handled. Therefore, you may have to change the stem direction of
notes manually.

●

You can reset notes to appear on their default staff by selecting them and choosing Edit >
Cross Staff > Reset to Original Staff.

●

If you want notes to belong to a different staff, you can move them to another staff.

EXAMPLE

Notes all in the upper staff of a grand staff
instrument

Notes spanning both staves of a grand staff
instrument

RELATED LINKS
Creating cross-staff beams on page 411
Notes crossed to staves with existing notes in other voices on page 807
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Note positions in multiple-voice contexts on page 801
Changing the stem direction of notes on page 714

Optical spacing for cross-staff beams
Normally, the human eye perceives the evenness of rhythmic spacing according to the distance
between noteheads. However, for cross-staff beams we consider the distance between stems,
rather than the noteheads, to be even/uneven.
You can make stems, rather than noteheads, evenly spaced by activating Use optical spacing for
beams between staves for layouts in your project that contain cross-staff beams on the Note
Spacing page in Setup > Layout Options.

Default spacing: The distance between noteheads is
optimized.

Optical spacing for cross-staff beaming: the distance
between stems is optimized.

You can open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options at the bottom of the Layouts panel in Setup mode.

●

Right-click an instrumental part or a full score in the Layouts panel and choose Layout
Options from the context menu.

RELATED LINKS
Note Spacing page in Layout Options on page 285

Cross-staff beam placement in multiple staves
When instruments have three or more staves, cross-staff beams can be placed in multiple ways.
For example, the beam can be placed between the top and the middle staves, and also between
the middle and bottom staves.
If a beam only crosses two staves, the cross-staff beam goes between those two staves.
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A cross-staff beam across the upper two staves on
an instrument with three staves

A cross-staff beam across the lower two staves on an
instrument with three staves

If a beam group contains notes on all three staves, the placement of the beam depends on the
stem directions of the notes in each staff.

1

If all notes in the beam group are stem-up, the beam is placed above the top staff.

2

If all notes in the beam group are stem-down, the beam is placed below the bottom staff.

3

If notes are stem-down on the top staff and stem-up on the bottom two staves, the beam
is placed between the top and middle staves.

4

If notes are stem-down on the top two staves and stem-up on the bottom staff, the beam
is placed between the bottom and middle staves.

NOTE
If you have not specified stem directions, Dorico might place the beam above/below the staff into
which the notes were originally input, even if the stem directions mean it should be placed
between other staves.
If you want the beam to be placed between specific staves, you can change the stem directions
of notes in the beam group.

RELATED LINKS
Changing the stem direction of notes on page 714
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Beam corners
Beam corners can occur when a change of stem direction within a beam is combined with a
break in the secondary beam group. This can be at the end of a subdivision or at a change in
rhythmic speed.
Beam corners do not follow accepted rules regarding the order and rhythmic meaning of
secondary beams, and can be confusing for the reader.

Dorico avoids beam corners by analyzing the pitches and stems within a phrase, and
implementing stem directions that avoid a beam corner.

Secondary beams
Secondary beams are the lines that are added between the primary beam and the notehead as
the rhythmic division gets smaller.
The primary beam is the outermost beam line that joins all of the notes in the beamed group.
Depending on the durations of the notes in the beamed group, the primary beam may in fact be
two or more lines; that is, for notes of a 16th or shorter in duration.
Secondary beams are additional beam lines that join only some of the notes in the group,
creating subdivisions of the beam in order to make the metrical groupings of the beam clearer.

A phrase of 64th notes, with secondary beams subdivided to show 16th and eighth note groups

You can set per-flow options for how secondary beams appear on the Beam Grouping page in
Write > Notation Options.

Changing the number of beam lines in secondary beams
You can change the number of beam lines shown in secondary beams individually,
independently of your default setting for the current flow.
PROCEDURE
1.

Select the notes to the right of where you want to change the number of secondary
beaming lines. You can do this in Write mode and Engrave mode.

2.

Optional: If the note you selected does not immediately follow an existing split in the
secondary beam, split the secondary beam in any of the following ways:
●

In the Properties panel, activate Split secondary beam in the Beaming group.
NOTE
The Beaming group is only shown in the Properties panel if your selection consists
only of notes.
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●
3.

Choose Edit > Beaming > Split Secondary Beam. You can also choose this option
from the context menu.

In the Properties panel, select the note value that corresponds to the number of beam
lines you want shown from the Split secondary beam menu.

RESULT
The number of beam lines shown immediately to the left of each selected note is changed.
NOTE
●

The number of beam lines shown at a split in the secondary beam cannot be the same or
greater than the number of beam lines in the secondary beam. For example, if you split a
secondary beam containing 64th notes, the maximum number of beam lines shown at the
split in that beam is three, the equivalent of 32nd notes.

●

You can change the default number of secondary beam lines shown in each flow
independently on the Beam Grouping page in Write > Notation Options.

Resetting changes to the number of secondary beam lines
You can reset any changes you have made to the number of beam lines shown in secondary
beams and return them to their default appearance.
PROCEDURE
1.

Select the notes to the right of where you want to reset the number of secondary beam
lines. You can do this in Write mode and Engrave mode.

2.

Reset your changes to the number of secondary beam lines in any of the following ways:
●

In the Properties panel, deactivate Split secondary beam in the Beaming group.

●

Choose Edit > Beaming > Reset Beaming. You can also choose this option from the
context menu.

Tuplets within beams
Tuplets that contain notes that produce beams are also beamed together, but special beam
grouping rules apply to tuplets within beams that also contain non-tuplet notes.
The default setting for a tuplet in a beamed group with secondary beams is to split the secondary
beam and to show the tuplet with a bracket. The primary beam is not split.
You can alter the appearance of the bracket by selecting the bracket and changing relevant
properties in the Tuplets group of the Properties panel.

Tuplets in beam groups with secondary beams are beamed together with a split secondary beam by default.

The default setting for a tuplet in a beamed group with only a primary beam is to separate the
tuplet entirely. However, you can change this setting on the Beam Grouping page in Notation
Options.

Eighth note (quaver) tuplets are not beamed together with subsequent non-tuplet eighth notes by default.
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RELATED LINKS
Tuplets on page 771
Tuplet brackets on page 775
Tuplet numbers/ratios on page 779

Stemlets
Stemlets are short stems that extend from beams to rests within beam groups. They can help
make music easier to read, as they help to maintain a regular pattern of stems within beams.
In the examples, beaming all notes and rests together to show the boundaries of quarter note
(crotchet) beats makes the syncopation of the notes easier to read. The stemlets on the rests
help make clear where within the quarter note beats each note occurs.

A syncopated phrase without stemlets

The same phrase with stemlets

You can change the default appearance of stemlets in each flow, and you can show stemlets in
individual beams.
RELATED LINKS
Showing stemlets in beam groups on page 416

Showing stemlets in beam groups
You can show stemlets on rests in beam groups individually, independently of your default
setting for showing stemlets in the current flow.
PROCEDURE
1.

Select the notes you want to beam together with stemlets shown on rests.
For example, to show a stemlet on a rest between two notes, select both notes. To show a
stemlet on a rest at the end of a beamed phrase, select all notes in the beam and the rest.

2.

Choose Edit > Beaming > Stemlets > Force Stemlet Beam. You can also choose this
option from the context menu.

RESULT
The selected notes are beamed together with stemlets shown on rests within the beam group.
NOTE
●

If you later reset the beaming of the selected group, stemlets revert to your default setting
for the flow.

●

You can choose to show stemlets on rests in all beamed groups in each flow on the Beam
Grouping page in Write > Notation Options.
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EXAMPLE

Stemlet with only the rest selected Stemlet with notes either side
selected

Stemlets shown with all notes and
rests in beam group selected

Removing stemlets from beam groups
You can remove stemlets from rests in beam groups individually, independently of your default
setting for showing stemlets in the current flow.
PROCEDURE
1.

Select a note in the beam groups from which you want to remove stemlets on rests.

2.

Choose Edit > Beaming > Stemlets > Suppress Stemlet Beam. You can also choose this
option from the context menu.

RESULT
Stemlets are removed from all rests in the selected beams.
NOTE
●

Removing stemlets from beams does not reset the selected beams to your default beam
grouping for the flow.

●

You can choose not to show stemlets on rests in all beam groups in each flow on the Beam
Grouping page in Write > Notation Options.

EXAMPLE

Beam group showing stemlets

Beam group with suppressed stemlets

RELATED LINKS
Resetting beam grouping on page 406

Fanned beams
Fanned, or “feathered”, beams show either an accelerando or rallentando by having multiple
beam lines either converging on, or diverging from, a single beam line at the other end.
A single beam can have multiple changes of direction within it.
The grouping can use either two or three beams, with three beams indicating a greater change
of speed than two beams.
The slowest part of the phrase is where the beams converge, and the fastest is where the beams
are the most spread out.
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EXAMPLE
Fanned beam accelerando with three lines

Fanned beam accelerando with two lines

Fanned beam rallentando with three lines

Fanned beam rallentando with two lines

Creating fanned beams
You can create fanned beams across a group of any notes that can be beamed, such as eighth
notes (quavers), 16th notes (semiquavers), and 32nd notes.
PROCEDURE
1.

Select the notes you want to include in a fanned beam. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Beaming > Create Fanned Beam > [Direction and number of lines].
For example, choose Edit > Beaming > Create Fanned Beam > Accelerando (Three
Lines) for an accelerando fanned beam with three lines.
TIP
You can also choose these options from the context menu.

RESULT
The selected notes are joined with a fanned beam with a single slope.
NOTE
The durations of the notes you select are ignored when showing a fanned beam.
AFTER COMPLETING THIS TASK
You can change the direction within the fanned beam in multiple places.
RELATED LINKS
Changing the direction within fanned beams on page 418

Changing the direction within fanned beams
You can change the direction of fanned beams within phrases to indicate tempo changes.
PROCEDURE
1.

In Engrave mode, select the notehead at each rhythmic position where you want to
change the direction of the fanned beam slope.
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NOTE
You can select multiple positions within phrases.
2.

In the Properties panel, activate Change fanned beam direction in the Beaming group.

EXAMPLE

Fanned beam with multiple changes of direction
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There are generally accepted conventions for how notes and rests of different durations are
notated and grouped in different contexts.
In Dorico, notes are automatically notated to fit within bars and are grouped according to your
per-flow settings.
Depending on the prevailing time signature, there can be many different ways to beam notes
together. For example, you might want to beam all notes in the bar together in time signatures
that cannot be divided in half and are often not divided at all, such as 3/4.
Tied notes are affected by your note and rest grouping settings, as there are different
conventions for how the notes within tie chains should be divided to indicate significant beat
boundaries within bars, and in which contexts they can cross beat boundaries.
Similar options apply to dotted notes, which are often notated as a single dotted note if they
start at the beginning of bars, but as a tie chain that shows significant beat boundaries in the bar
if they start part-way through bars.
You can change the default note grouping and beam grouping settings for your project on the
Note Grouping and Beam Grouping pages in Write > Notation Options.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
RELATED LINKS
Notation Options dialog on page 110

Conventions for beam grouping according to meter
According to accepted conventions, notes are beamed differently in different time signatures to
make the meter clear and easily readable.
For example, music in 3/4 is beamed in one group of six eighth notes (quavers), whereas music in
6/8 is beamed in two groups, each the value of a dotted quarter note (crotchet). Although these
two time signatures describe the same rhythmic value, the implicit meter within them is
different, and so the beam grouping is different.

Default beam grouping in 6/8

Default beam grouping in 3/4

For irregular time signatures, such as 5/8 or 7/8, Dorico beams notes by default according to the
most common practices for those time signatures.
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Default beam grouping in 5/8

Default beam grouping in 7/8

Creating custom beat groupings for meters
If your music requires a different beat grouping for a particular meter than the default setting
for that time signature, you can specify your preferred beat grouping within the time signature.
You can choose whether or not the time signature shows this custom beat grouping.
NOTE
The duration of beam groups in Dorico depends on the beat grouping in the current time
signature and your per-flow beam grouping settings in Write > Notation Options. For example,
entering [1+1+1+1]/4 into the time signatures popover inputs a time signature with four quarter
note (crotchet) groups. Because this creates a time signature with a half-bar, beam grouping
options for time signatures with a half-bar apply.

PROCEDURE
1.

In Write mode, select an item at the rhythmic position where you want to input a time
signature with a custom beam grouping.

2.

Open the time signatures popover in any of the following ways:

3.

●

Press Shift-M.

●

Choose Write > Create Time Signature.

Enter the division you want in square brackets into the popover.
For example, to divide a 7/8 time signature into 2+3+2, enter [2+3+2]/8 into the popover.
To divide a 5/4 time signature into 2+3 rather than 3+2, enter [2+3]/4 into the popover.

4.

Press Return to close the popover.

RESULT
The time signature appears either as a single number, such as 7/8, or showing the beat groups,
such as 2+3+2/8, depending on your setting on the Time Signatures page in Engrave >
Engraving Options.
TIP
You can change the appearance of numerators in individual time signatures so that they show a
single number or beat groups independently of your project-wide settings.

RELATED LINKS
Notation Options dialog on page 110
Project-wide engraving options for time signatures on page 752
Time signature styles on page 755
Changing the numerator style of time signatures on page 756

421

Brackets and braces

Brackets and braces are thick straight and curved lines in the left-hand margin that show
instrument groupings.

Brackets
A bracket is a thick black line, the width of a beam, that groups staves together, most commonly
according to instrument family. It often has winged ends that point inwards towards the score.
It is always positioned directly to the left of a systemic barline. If secondary brackets are used in
addition to a bracket, they are positioned further away from the start of the system to allow
space for the bracket.

An example of a bracket, connecting instruments in the string family. A sub-bracket connects the two violin
lines.

In Dorico, barlines join the same staves that are joined by brackets and braces, meaning that a
bracketed group of staves or a braced pair of staves appears with barlines extending across the
group.

Braces
A brace is a wavy or curly line that joins multiple staves belonging to the same instrument, such
as the piano or harp. If necessary, a brace can extend to three or more staves, although two is
most common.
The brace is also sometimes used instead of a sub-bracket to show groupings of identical
instruments within a family whose staves are joined by a bracket.
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It is positioned outside the systemic barline, and if used in place of a sub-bracket, outside of the
bracket as well.

A brace connecting two piano staves

RELATED LINKS
Barlines across staff groups on page 384
Player groups on page 86
Adding groups of players on page 86
Secondary brackets on page 425

Brackets according to ensemble type
You can bracket staves together according to their ensemble type in Dorico.
The following ensemble types are available on the Brackets and Braces page in Engrave >
Engraving Options:
No brackets
All staves appear separately, with no brackets.
Orchestral
Staves are bracketed according to their instrument family. This is the default setting.
Small ensemble
All staves in the project are bracketed together.
Wind band
Staves are bracketed according to their instrument type. For example, Flute 1 and
Flute 2 are bracketed together, but separately from the other woodwind
instruments.
Big band
Staves are bracketed according to their instrument family, except for brass
instruments, which are all bracketed according to their instrument type.
Rhythm section instruments are bracketed together.
Percussion and timpani are bracketed together.
British brass band
Brass instruments are bracketed according to their instrument type, except for horns
and trumpets, which are bracketed together.
Any other instruments in the score are bracketed according to their instrument
family.
Percussion and timpani are bracketed separately.
RELATED LINKS
Changing bracket grouping according to ensemble type on page 424
Project-wide engraving options for brackets and braces on page 424
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Changing bracket grouping according to ensemble type
You can change which staves are included in brackets by changing the project-wide setting for
ensemble type.
The default setting is Orchestral. We recommend that you change this setting for projects
containing small ensembles.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Brackets and Braces in the page list.

3.

In the Approach section, choose one of the following options for Ensemble type:
●

No brackets

●

Orchestral

●

Small ensemble

●

Wind band

●

Big band

●

British brass band

RELATED LINKS
Brackets according to ensemble type on page 423
Barlines across staff groups on page 384

Project-wide engraving options for brackets and braces
You can find options for the project-wide appearance of brackets and braces on the Brackets
and Braces page in Engraving Options.
The options on the Brackets and Braces page allow you to change which instruments are
bracketed together, and change the design of brackets.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Brackets and Braces in the page list on the left of the dialog.

Changing the appearance of bracket ends project-wide
You can change the appearance of all bracket ends project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Brackets and Braces in the page list.

3.

In the Design section, choose one of the following options for Bracket end design:
●

Wings (default)
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●

Horizontal line

●

None

Secondary brackets
Secondary brackets extend beyond brackets, allowing you to mark groups of staves within a
bracketed group. You can show secondary brackets as a brace positioned outside the bracket or
as a sub-bracket in Dorico.

Secondary bracket as a sub-bracket
By default, secondary brackets appear as sub-brackets: thin lines with square corners that extend
beyond the bracket.

You can change how thick the lines of sub-brackets are, and the distance between sub-brackets
and the systemic barline, in the Sub-brackets subsection of the Design section of the Brackets
and Braces page in Engrave > Engraving Options.

Secondary bracket as a brace
Secondary brackets can also appear as a brace instead of a sub-bracket.
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You can change the distance between braces and brackets in the Sub-brackets subsection of the
Design section of the Brackets and Braces page in Engraving Options.
RELATED LINKS
Project-wide engraving options for brackets and braces on page 424
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Chord symbols describe the vertical harmony of the music at a specific moment. They are
frequently used in jazz and pop music, where players often improvise around chord
progressions.
Depending on the style of music, there are different conventions regarding how to present chord
names.
RELATED LINKS
Input methods for chord symbols on page 167

Chord components
Chord symbols consist of a root and a quality, with intervals, alterations, and an altered bass note
included if required.
Root
The root note of the chord, expressed either as a note name or as a specific degree
of a scale.
Quality
Defines the type of chord, such as major, minor, diminished, augmented, halfdiminished, or with added note, such as six or nine.
Interval
Chord symbols can include one or more added intervals, such as a major seventh or
ninth. Intervals in chord symbols are also known as “extensions”.
Alterations
Define notes in chords that are different to what is normally expected of that chord.
For example, a sharpened fifth, flattened ninth, suspensions, or omissions.
Altered bass note
A chord symbol has an altered bass note if the lowest pitch of a chord is not its root
note, such as Cm7♭5/E♭.

Project-wide engraving options for chord symbols
You can find options for the project-wide appearance and position of chord symbols on the
Chord Symbols page in Engraving Options.
The options on the Chord Symbols page in Engraving Options allow you to change the
appearance of different types of chords and their default positions.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.
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You can then click Chord Symbols in the page list on the left of the dialog.

Chord symbol appearance presets
There are many conventions for the appearance of chord symbols, so Dorico provides a choice of
preset conventions that you can use and edit.
For example, you can edit default preset chord symbols, you can edit individual chord symbols
without changing the default appearance for that chord symbol, and you can edit individual
components within chord symbols.
You can find chord symbol presets at the top of the Chord Symbols page in Engraving Options.
Chord symbol preset example

Chord symbol preset name
Default

Boston

Brandt-Roemer

Indiana

New York

Nashville

Jazz Standards

Ross

Japanese

These presets use specific combinations of the options on the Chord Symbols page.
You can also adjust these options individually to suit your requirements.
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Default uses a set of symbols intended to be as unambiguous as possible. For example, Default
avoids the use of symbols for major seventh, augmented, diminished, and half-diminished. This
is the default preset for new projects.
Custom is automatically selected when you change any of the preset options on the Chord
Symbols page.
RELATED LINKS
Project Default Chord Symbol Appearances dialog on page 429
Edit Chord Symbol Appearance dialog on page 431
Edit Composite Component dialog on page 432

Project Default Chord Symbol Appearances dialog
You can edit the default appearance of chord symbols in the Project Default Chord Symbol
Appearances dialog. This changes the appearance of chord symbols project-wide.
●

You can open the Project Default Chord Symbol Appearances dialog by clicking Edit in
the Project Default Appearances section of the Chord Symbols page in Engrave >
Engraving Options.

Project Default Chord Symbol Appearances dialog

The Project Default Chord Symbol Appearances dialog contains the following sections:
1

Enter a chord symbol
Allows you to enter the chord symbol whose default project-wide appearance you want to
edit. Click Add Project Default or press Return to add the chord symbol to the Project
Default Appearances list, which allows you to edit the chord symbol in the editor.

2

Project Default Appearances list
Contains the chord symbols whose project default appearance you have edited in the
project.
You can delete changes to the project default appearance of chord symbols by clicking
Delete in the action bar.
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3

Single Overrides list
Contains the chord symbols whose individual appearance you have overridden in the
project.
You can promote your edits to individual chord symbols to be the project default
appearance for that chord symbol by clicking Promote to Project Default in the action
bar.

You can reset single overrides to the project default appearance for that chord symbol by
clicking Remove Overrides in the action bar.

4

Editor
Allows you to arrange and edit the components that make up the chord symbol. You can
use the controls at the bottom of the dialog, and you can also move individual components
in any of the following ways after selecting them in the editor:
●

Press the standard key commands for moving items. For example, press AltRight Arrow to move components to the right, or press Ctrl/Cmd-Alt-Right Arrow
to move components to the right by larger increments.

●

Click and drag each component.

NOTE
You cannot move the first component in chord symbols.
In addition to using Scale, you can also change the size of components by clicking and
dragging the square handle in the top right corner after selecting a component in the
editor.
5

6

Controls
●

X offset moves components horizontally. Increasing the value moves components
to the right, decreasing the value moves components to the left.

●

Y offset moves components vertically. Increasing the value moves components
upwards, decreasing the value moves components downwards.

●

Scale changes the size of components. Increasing the value increases the size of
components proportionally, decreasing the value decreases the size of components
proportionally.

●

Reset X offset resets the horizontal position of the selected component.

●

Reset Y offset resets the vertical position of the selected component.

●

Reset Scale resets the size of the selected component.

Alternative component presentations
Contains alternative ways of presenting the component selected in the editor.
Allows you to create new components and edit existing components by clicking the
respective button in the action bar.
●

Add Component

●

Edit Component

Clicking either button opens the Edit Composite Component dialog, in which you can
create new chord symbol components and edit existing chord symbol components.
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RELATED LINKS
Chord symbol appearance presets on page 428
Edit Chord Symbol Appearance dialog on page 431
Edit Composite Component dialog on page 432

Edit Chord Symbol Appearance dialog
You can use the Edit Chord Symbol Appearance dialog to edit the appearance and arrangement
of individual chord symbols, without changing the project default appearance of that chord
symbol.
You can open the Edit Chord Symbol Appearance dialog in the following ways:
●

In Engrave mode, select a chord symbol and press Return.

●

In Engrave mode, double-click a chord symbol.

Edit Chord Symbol Appearance dialog

The Edit Chord Symbol Appearance dialog contains the following sections:
1

Editor
Allows you to arrange and edit the components that make up the chord symbol.
As well as using the controls at the bottom of the dialog, you can move individual
components in any of the following ways after selecting them in the editor:
●

Press the standard key commands for moving items. For example, press AltRight Arrow to move components to the right, or press Ctrl/Cmd-Alt-Right Arrow
to move components to the right by larger increments.

●

Click and drag each component.
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NOTE
You cannot move the first component in chord symbols.
In addition to using Scale, you can also change the size of components by clicking and
dragging the square handle in the top right corner after selecting a component in the
editor.
2

Controls
Allow you to move individual components and change their size. You can also reset their
position and size.

3

●

X offset moves components horizontally. Increasing the value moves components
to the right, decreasing the value moves components to the left.

●

Y offset moves components vertically. Increasing the value moves components
upwards, decreasing the value moves components downwards.

●

Scale changes the size of components. Increasing the value increases the size of
components proportionally, decreasing the value decreases the size of components
proportionally.

●

Reset X offset resets the horizontal position of the selected component.

●

Reset Y offset resets the vertical position of the selected component.

●

Reset Scale resets the size of the selected component.

Alternative component presentations
You can create new components and edit existing components by clicking the respective
button in the action bar.
●

Add Component

●

Edit Component

Clicking either button opens the Edit Composite Component dialog, in which you can
create new components and edit existing components.
RELATED LINKS
Chord symbol appearance presets on page 428
Edit Composite Component dialog on page 432

Edit Composite Component dialog
You can create custom components and edit existing components for both individual chord
symbols and for project default chord symbols in the Edit Composite Component dialog.
You can open the Edit Composite Component dialog by clicking either Add Component or Edit
Component in the alternative component presentations action bar in the following dialogs:
●

Project Default Chord Symbol Appearances dialog

●

Edit Chord Symbol Appearance dialog
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Edit Composite Component dialog

The Edit Composite Component dialog contains the following sections:
1

Name
Contains an automatically generated name for the chord symbol component. You cannot
change this name.

2

Component selector
Allows you to choose components to add to your chord symbol component. You can add
different types of components by clicking the respective tab titles.
●

Glyph, for example, ♮ or ♯. You can use different styles of glyphs by selecting
different fonts and different ranges from the menus. Click Add Glyph to add the
selected glyph to the chord symbol component.
NOTE
A full list of the different ranges of glyphs is available on the SMuFL website.

3

●

Text, including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected
text, or input text, to the chord symbol component.

●

Graphic: Allows you to load a new graphic file, or select an existing graphic from the
Select existing list. Most image formats are supported. You can see a preview of the
graphic in the Preview box. Click Add Graphic to add the selected graphic to the
chord symbol component.

●

Composite: Allows you to select a composite from the list. Click Add Composite to
add the selected composite to the chord symbol component.

Editor
Allows you to arrange and edit the components that make up your chord symbol
component. You can arrange and edit components using the controls at the bottom of the
dialog.

4

Controls
●

X offset moves components horizontally. Increasing the value moves components
to the right, decreasing the value moves components to the left.
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●

Y offset moves components vertically. Increasing the value moves components
upwards, decreasing the value moves components downwards.

●

X scale changes the width of graphics only. Increasing the value makes graphics
wider, decreasing the value makes graphics narrower.

●

Y scale changes the size of components. Increasing the value makes components
larger, decreasing the value makes components smaller. For graphics only,
increasing the value makes graphics taller, decreasing the value makes graphics
shorter.

●

Attachment from: Select the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend
that you select a right edge attachment point for Attachment from.

●

Attachment to: Select the attachment point on the selected component which
attaches to the component to its left. We recommend that you select a left edge
attachment point for Attachment to.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that extend below the baseline. The example diagram helps you
visualize how these points relate to components.

The attachment points have the following names in the Edit Composite Component dialog:
1

Top Left

2

Top Middle

3

Top Right

4

Left Middle

5

Right Middle

6

Baseline Left (text only)

7

Baseline Middle (text only)

8

Baseline Right (text only)

9

Bottom Left

10

Bottom Middle

11

Bottom Right

RELATED LINKS
Chord symbol appearance presets on page 428
Project Default Chord Symbol Appearances dialog on page 429
Edit Chord Symbol Appearance dialog on page 431

Setting single chord symbol overrides as the project default
You can set single overrides you have made to individual chord symbols as the project default
appearance for that chord symbol.
PROCEDURE
1.

Open the Project Default Chord Symbol Appearances dialog.
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2.

Select the single override that you want to set as project default in the Single Overrides
list.

3.

Click Promote to Project Default.

RESULT
The selected single chord symbol override becomes the default appearance for that chord
symbol.
NOTE
This cannot be undone. If you want to revert your changes, you must delete the chord symbol
from the Project Default Appearances list.

RELATED LINKS
Project Default Chord Symbol Appearances dialog on page 429

Resetting the appearance of chord symbols with single overrides
You can reset the appearance of chord symbols you have overridden individually to the project
default appearance for that chord symbol.
PROCEDURE
1.

Open the Project Default Chord Symbol Appearances dialog.

2.

Select the single override that you want to reset in the Single Overrides list.

3.

Click Remove Overrides.

RESULT
All individual changes to the chord symbol are removed. It now follows the project default
appearance for that chord symbol.
RELATED LINKS
Project Default Chord Symbol Appearances dialog on page 429

Changing chord symbol fonts
You can change the text fonts used for chord symbols project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles.
The Edit Font Styles dialog opens.

2.

Select one of the following fonts from the Font style menu:
●

Chord Symbols Altered Bass Separator Font

●

Chord Symbols Font

●

Chord Symbols Music Text Font
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TIP
When using the option to show the word “on” instead of a slash or line to separate a
chord from its altered bass note, you can edit the font used for that word by editing
Chord Symbols Altered Bass Separator Font.
NOTE
We recommend that you do not edit Chord Symbols Music Text Font, which is set
to Bravura Text by default. This can only be set to a SMuFL-compliant font intended
for use in text-based applications.
3.

4.

Activate the following options, individually or together, to change the corresponding
aspect of the font:
●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

Changing existing chord symbols
You can change chord symbols after they have been input.
PROCEDURE
1.

In Write mode, select the chord symbol you want to change.

2.

Open the chord symbols popover in any of the following ways:
●

Press Return.

●

Double-click the chord symbol.

The existing short-hand for the chord symbol is shown inside the popover.
3.

4.

Change the existing chord symbol in one of the following ways:
●

Change the existing short-hand in the popover or enter an entirely new chord
symbol.

●

Play in a new chord symbol using your MIDI keyboard.

Press Return to close the popover.

RESULT
The chord symbol is changed to what you entered or played into the popover.

Transposing chord symbols
Chord symbols can be transposed, and appear at the appropriate transposed pitch when shown
on transposing instruments.
PROCEDURE
1.

In Write mode, select the chord symbols you want to transpose.

2.

Choose Write > Transpose.
The Transpose dialog opens.

3.

Change the transposition using the options in the dialog.
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4.

Click OK to save your changes and close the dialog.

Showing instruments and chord symbols at transposed pitch
You can show chord symbols at the appropriate transposed pitch for transposing instruments,
rather than at concert pitch.
PROCEDURE
●

Choose Edit > Transposed Pitch.
IMPORTANT
This changes the shown transposition for all transposing instruments in the layout.

Hiding/Showing chord symbols
You can hide/show chord symbols in the current layout without deleting them.
PROCEDURE
1.

Select the chord symbols or chord symbol signposts you want to hide/show. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Hidden in the Chord Symbols group.

RESULT
Chord symbols are hidden when the property is activated, and shown when the property is
deactivated.
Signposts are shown at the positions of each chord symbol so you can always find them again.
However, signposts are not printed by default.
TIP
If you do not want to show chord symbol signposts, choose View > Signposts > Chord Symbols.
Chord symbol signposts are shown when a tick appears beside Chord Symbols in the menu, and
hidden when no tick appears.

RELATED LINKS
Signposts on page 106

Hiding/Showing the root and quality of chord symbols
You can hide the root and quality of chord symbols if they follow another chord symbol with the
same root and quality, but have a different altered bass note.
PROCEDURE
1.

Select the chord symbols whose root and quality you want to hide. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Hide root and quality in the Chord Symbols group.

3.

Activate/Deactivate the corresponding checkbox.
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RESULT
The root and quality of the selected chord symbols are hidden when the checkbox is activated,
and shown when the checkbox is deactivated.
When the property is deactivated, chord symbols follow your project-wide setting.
TIP
You can choose to show the root and quality of chord symbols always, even if successive chord
symbols have the same root and quality, in the Altered Bass Notes section of the Chord
Symbols page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for chord symbols on page 427

Positions of chord symbols
By default, chord symbols are centered horizontally on the middle of the front notehead in the
first voice column, at the rhythmic position to which they are attached.
NOTE
The front notehead is the notehead on the correct side of the stem at that rhythmic position.
Their vertical positions in full scores is determined by the staves above which they are set to
appear. This also affects in which part layouts chord symbols appear.

Alignment of chord symbols relative to notes and chords
You can change whether chord symbol text is left-aligned above the notehead, center-aligned
above the notehead, or right-aligned above the notehead, although right-aligned typically
produces unclear results.
You can change the horizontal alignment of chord symbols by choosing an option for Horizontal
alignment relative to note, chord or rest in the Position section of the Chord Symbols page in
Engraving Options.
You can also override this for an individually selected chord symbol by activating Alignment in
the Chord Symbols group of the Properties panel and selecting an option from the menu.

Alignment of chord symbols across the system
Chord symbols are aligned at the same vertical position across the width of the system by
default. You can deactivate Align chord symbols across width of system in the Position section
of the Chord Symbols page in Engraving Options if you want each chord symbol to be
positioned above the staff independently.
RELATED LINKS
Project-wide engraving options for chord symbols on page 427
Moving chord symbols rhythmically on page 439
Moving chord symbols graphically on page 439
Changing the staves above which chord symbols appear on page 440
Changing the layouts in which chord symbols appear on page 441
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Moving chord symbols rhythmically
You can move chord symbols to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the chord symbols you want to move.
NOTE
When using the mouse, you can only move one chord symbol rhythmically at a time.

2.

Move the chord symbols according to the current rhythmic grid value in any of the
following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the chord symbol to the right/left.

RESULT
The selected chord symbols are moved to new rhythmic positions.
NOTE
Only one chord symbol can exist at each rhythmic position. If a chord symbol passes over
another chord symbol as part of its move, the existing chord symbol is deleted.
You can undo this action, but any chord symbols deleted in the process are only restored if you
moved the chord symbol using the keyboard.

Moving chord symbols graphically
You can move chord symbols graphically without affecting the rhythmic positions to which they
apply.
PROCEDURE
1.

In Engrave mode, select the chord symbols you want to move.

2.

Move the chord symbols in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The selected chord symbols are moved graphically, without affecting the rhythmic positions to
which they are attached.
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TIP
Start offset in the Chord Symbols group of the Properties panel is activated automatically when
you move chord symbols.
●

Start offset X moves chord symbols horizontally.

●

Start offset Y moves chord symbols vertically.

You can also use this property to move chord symbols graphically by changing the values in the
value fields.
Deactivating the property resets the selected chord symbols to their default positions.

Changing the staves above which chord symbols appear
You can change the players above whose staves chord symbols appear.
By default, chord symbols appear above the staves belonging to rhythm section instruments,
such as keyboards, guitars, and bass guitars.
PROCEDURE
1.

In Setup mode, select a player in the Players panel above which you want to hide/show
chord symbols.

2.

Right-click the player and choose one of the following options from the context menu:
●

Chord Symbols > Show For All Instruments
Chord symbols are shown above the staff of the selected player.

●

Chord Symbols > Show For Rhythm Section Instruments
Chord symbols are shown above the staff of the selected player if it is a rhythm
section instrument.

●

Chord Symbols > Hide For All Instruments
Chord symbols are not shown above the staff of the selected player.

RESULT
Chord symbols are hidden/shown above the staff of the selected player. For example, if you
choose Show For All Instruments, chord symbols can now appear above the selected player in
the full score and any corresponding part layouts, depending on the layouts in which chord
symbols are shown in your project.
TIP
You can show chord symbols between the two staves of grand staff instruments, such as piano.
In Engraving Options, choose Between staves for Position of chord symbols on grand staff
instruments in the Position section of the Chord Symbols page.

RELATED LINKS
Changing the layouts in which chord symbols appear on page 441
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Changing the layouts in which chord symbols appear
You can change which layouts show chord symbols. By default, chord symbols appear both in full
score and part layouts for rhythm section instruments.
NOTE
If chord symbols are not set to appear for any instrument in the current layout, signposts are
shown above the top staff.

PROCEDURE
1.

In Setup mode, select a player in the Players panel.

2.

Right-click the player and choose one of the following options from the context menu:
●

Chord Symbols > Show in Full Score and Parts
Chord symbols are shown above the staff of the selected player in all layouts that
include the player.

●

Chord Symbols > Show in Full Score Only
Chord symbols are only shown above the staff of the selected player in full score
layouts and not in any part layouts.

●

Chord Symbols > Show in Parts Only
Chord symbols are only shown above the staff of the selected player in part layouts
and not in full score layouts.

Changing the enharmonic spelling of chord symbols
You can respell a chord symbol for a transposing instrument in a transposing layout by editing
the chord symbol.
PROCEDURE
1.

In Write mode, select the chord symbol you want to respell.

2.

Open the chord symbols popover for the selected chord symbol in any of the following
ways:
●

Press Return.

●

Double-click the chord symbol.

The existing short-hand for the chord symbol is shown inside the popover.
3.

Change the root name of the chord, but leave other details as they were, such as quality,
interval, or alterations.
For example, change just the root of D♭maj13 from Db to C#.

RESULT
The spelling of the chord symbol is altered for all instruments with the same transposition.

Resetting the enharmonic spelling of chord symbols
You can remove enharmonic spelling overrides for chord symbols. You can remove overrides for
the current instrument only, or for all instruments to which the chord symbol applies.
PROCEDURE
1.

In Write mode, select the chord symbol you want to respell.
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2.

Open the chord symbols popover for the selected chord symbol in any of the following
ways:
●

Press Return.

●

Double-click the chord symbol.

The existing short-hand for the chord symbol is shown inside the popover.
3.

Reset the enharmonic spelling of the chord symbol in any of the following ways:
●

To remove the enharmonic spelling override for a chord symbol for the instrument
above which the popover appears, enter Alt-S into the chord symbol popover.

●

To remove all enharmonic spelling overrides for a chord symbol for all instruments,
enter Shift-Alt-S into the popover.

Playing back chord symbols
Chord symbols are played back as sustained chords, with their duration taken from the gap
between one chord symbol and the next.
If the chord symbol was input using a MIDI keyboard, the chord plays back using the voicing that
was used to input the chord symbol.
PROCEDURE
1.

Expand the chord track at the top of the event display in Play mode.

2.

Choose the playback device (VST instrument or MIDI device) that you want to use, and
choose the channel or slot containing the desired sound.
You can also load a new sound manually.

3.

Activate the speaker icon to enable playback.

Chord symbols imported from MusicXML
Chord symbols are imported from MusicXML files. However, chords that specify Neapolitan,
Italian, French, German, Pedal, Tristan, and Other values for the kind of element are ignored
during import, as there is no information to specify what notes these chord symbols are meant
to describe.
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Clefs and octave lines provide crucial information about the pitch and register of notes.
Clefs define which staff line or space corresponds to which scale degree, and also help to
communicate the register of the notes on the staff. Octave lines allow notes to be written within
the staff when they would otherwise require many ledger lines due to their register.
In Dorico, clefs and octave lines are grouped together because they both affect the meaning of
note positions on the staff. In this way, octave lines could be considered to be temporary clef
changes.

Clefs
Clefs are the symbol at the start of every system that give the notes on the staff context; that is,
the clef tells you which note of the scale applies to each line or space of the staff.
For example, the treble clef is also known as a “G clef”, because the spiral shape in the middle
centers around G, normally the one above middle C.

The other common clefs are:
●

The bass clef, or F clef, in which two dots are shown either side of the line corresponding
to F, normally the F below middle C.
Middle C uses one ledger line below staves with treble clefs, and one ledger line above
staves with bass clefs.

●

The C clef, in which the center of the bracket to the right of the clef’s thick vertical line is
positioned on the line that corresponds to C, normally middle C.

The C clef today is commonly used at two positions on the staff:
●

On the middle line of the staff, commonly called the alto clef.

●

On the line above the middle line of the staff, commonly called the tenor clef.

To minimize the number of ledger lines required, these clefs are used to match the register of
the instrument for which they are used.

The E below middle C
shown in a treble clef

The E below middle C
shown in a bass clef
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The E below middle C
shown in a C (alto) clef

The E below middle C
shown in a C (tenor) clef
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In Dorico, clefs and octave lines are both contained in the Clefs panel on the right of the window.
Three sections of the panel apply to clefs:
●

Common Clefs, including treble clef, bass clef, alto clef, and tenor clef.

●

Uncommon Clefs, including tab, French violin clef, treble clef octave above, treble clef
octave below, and so on.

●

Archaic Clefs, including baritone bass clef, mezzo-soprano clef, and soprano clef, which
are not commonly used any more.

RELATED LINKS
Input methods for clefs and octave lines on page 175

General placement conventions for clefs
Clefs are placed at the start of every system, with a small gap between the start of the staff and
the left edge of the clef. Their vertical placement must be precise, as this signifies which pitches
are intended by the subsequent notes on the staff.
Clef changes that occur during a piece are usually smaller than the clefs shown at the start of
each system. If clef changes occur at the start of a new system or page, a cautionary clef is
shown at the end of the previous system to ensure the performer notices the change of clef.
Wherever possible, clef changes should not be positioned in the middle of tie chains. Changing
the clef changes the position of the tied note on the staff, which could easily cause a performer
to misread the tie as a slur and play two different notes. You can input clef changes in the middle
of tie chains in Dorico, but we recommend that you position clef changes either before or after
tie chains.
RELATED LINKS
Ties on page 735
Tie chains on page 737
Ties vs. slurs on page 737
Input methods for clefs and octave lines on page 175

Project-wide spacing gaps for clefs
You can change the minimum gaps between objects, including clefs, on the Spacing Gaps page
in Engraving Options.
The options are accompanied by diagrams to help you visualize how they affect the appearance
of your music.
The following minimum values directly relate to clefs:
●

Gap after barline before clef, key or time signature

●

Gap after initial clef

●

Gap to the left of clef, cancellation naturals or grace notes before note or barline

●

Gap after clef change

Other values may have an effect on the position of clefs, however they also affect other objects.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Spacing Gaps in the page list on the left of the dialog.
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Moving clefs rhythmically
You can move clefs to new rhythmic positions after they have been input.
TIP
You can change the default positions of clefs relative to notes or barlines by changing the
project-wide values for spacing gaps on the Spacing Gaps page in Engrave > Engraving
Options.

PROCEDURE
1.

In Write mode, select the clefs you want to move.
NOTE

2.

●

You cannot select an initial clef at the start of the flow or clefs shown automatically
at the start of each system.

●

When using the mouse, you can only move one clef rhythmically at a time.

Move the clefs according to the current rhythmic grid value in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the clef to the right/left.

RESULT
The selected clefs are moved to new rhythmic positions. They take effect from their new
positions until the next clef, or the end of the flow, whichever comes first.
NOTE
●

You can only move clefs along staves. If you want to move a clef across staves, you must
delete the clef and input a new clef on the other staff.

●

Only one clef can exist at each rhythmic position, except for clefs that only apply to single
staves. If a clef passes over another clef as part of its move, the existing clef is deleted.
You can undo this action, but any clefs deleted in the process are only restored if you
moved the clef using the keyboard.

RELATED LINKS
Inputting clefs with the popover on page 178
Inputting clefs with the panel on page 178

Moving clefs graphically
You can move individual clefs graphically without affecting the positions of any other items.
PROCEDURE
1.

In Engrave mode, activate Note Spacing in the Formatting panel.

2.

Select the square handle above the clef you want to move.

A circular handle appears beside the clef.
3.

Select the circular handle.
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4.

Move the handle in any of the following ways:
●

Press Alt-Right Arrow to move it to the right.

●

Press Alt-Left Arrow to move it to the left.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

NOTE
You cannot move note spacing handles with the mouse, you can only move them using the
keyboard.

RESULT
The clef is moved graphically to the right/left, without affecting other items at the same rhythmic
position.
TIP
You can also change Spacing Offset in the Clefs group of the Properties panel to move clefs
horizontally. However, this also affects global note spacing around the rhythmic position of the
clef.
NOTE
The Spacing Offset property in the Clefs group of the Properties panel is not available when
Note Spacing is activated.

RELATED LINKS
Note spacing on page 284

Deleting clefs
You can delete clefs without affecting the pitches of notes. Notes are automatically respelled
according to the previous clef on the staff.
NOTE
You cannot delete an initial clef at the start of the flow or clefs shown automatically at the start of
each system. If you do not want any clef to appear on a staff, you can input an invisible clef.

PROCEDURE
1.

In Write mode, select the clefs you want to delete.

2.

Delete the clefs in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.
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RESULT
The selected clefs are deleted. Any music on the staff is respelled according to the previous clef,
up until the next existing clef or the end of the flow.
RELATED LINKS
Clefs and octave lines popover on page 176
Inputting clefs with the popover on page 178
Inputting clefs with the panel on page 178

Default size of clef changes
You can change the default scale factor of all clef changes project-wide.
The default Clef change scale factor is 2/3. You can change the default clef change size on the
Clefs page in Engraving Options.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Increasing the scale factor makes clef changes appear larger, decreasing the scale factor makes
clef changes appear smaller. This does not affect the size of clefs at the start of each system.
The smallest scale factor that you can input is 1/8. There is no maximum limit. However, for
example, a scale factor of more than 30 causes a single clef to take up most of an A4 page, which
is rarely beneficial.

Changing the position of clefs relative to grace notes
By default, clefs are not positioned between a note and its grace note. Dorico automatically
positions clefs correctly and updates their position according to what you input. However, in
some circumstances you might want to position clefs between a note and its grace note.
PROCEDURE
1.

Select the clef whose position you want to change. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Clef Position > After Grace Notes. You can also choose this option from the
context menu.

RESULT
The clef is positioned between a note and its grace note.
NOTE
You can reset the position of clefs relative to grace notes by selecting the clefs whose position
you want to reset and choosing Edit > Clef Position > Reset Clef Position. You can also choose
this option from the context menu.

Transposing clefs
Transposing clefs indicate that notes are played in a different register to the one notated. A
number above the clef indicates that notes are played higher than notated, while a number
below the clef indicates that notes are played lower than notated.
Of these clefs, only the treble clef 8 below is still commonly used for tenor vocal parts.
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RELATED LINKS
Transposing instruments on page 73
Changing whether layouts are transposing/non-transposing on page 93
Concert vs. transposed pitch on page 94

Octave lines
Octave lines indicate where notes are played higher/lower than they appear in the score or part.
Octave lines are dashed or dotted horizontal lines with an italic numeral at the start. The numeral
indicates the number of pitches by which the phrase is changed, such as 8 for one octave and 15
for two octaves.
Octave lines that indicate notes are played higher than notated are placed above the staff, while
octave lines that indicate notes are played lower than notated are placed below the staff.

A treble clef phrase notated at
pitch

The treble clef phrase with an
octave above line

A bass clef phrase notated at pitch The bass clef phrase with an
octave below line

The treble clef phrase with a two
octaves above line

The bass clef phrase with a two
octaves below line

In Dorico, pitches are adjusted automatically when an octave line is present. You do not have to
change the register of the notes within the line.
You can use octave lines across a few notes, a single phrase, or multiple phrases, but they must
not confuse the contour of the music. If used excessively and for inappropriate sections, octave
lines can mask the shape of the original melody. However, careful usage of octave lines can make
music easier to read quickly as the performer has fewer ledger lines to count.

An angular phrase with no octave
lines

The same phrase with many
octave lines, which distort the
overall shape of the phrase.
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The same phrase with just two
octave lines to reduce ledger lines.
They do not change the overall
shape of the phrase.
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It is generally best to use a different clef for a whole phrase if appropriate for that instrument, or
to input an octave line for the whole phrase in order to ensure the shape and register are clear to
the performer.
Octave lines should be horizontal, meaning they can take up significant vertical space, as octave
lines are usually placed outside all other notations. However, they can be placed within slurs and
tuplet brackets if the slur or tuplet bracket is longer than the octave line.
Octave lines can continue across system and page breaks. It is customary to show the numeral
again at the start of each system as a reminder. Cautionary octave line numerals are usually
parenthesized and the suffix is optional.
RELATED LINKS
Input methods for clefs and octave lines on page 175

Lengthening/Shortening octave lines
You can lengthen/shorten octave lines after they have been input.
PROCEDURE
1.

In Write mode, select the octave lines you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one octave line at a time.

2.

Lengthen/Shorten the selected octave lines in any of the following ways:
●

Press Shift-Alt-Right Arrow to lengthen them by the current rhythmic grid value.

●

Press Shift-Alt-Left Arrow to shorten them by the current rhythmic grid value.

●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to snap the end of a single octave line to the
next notehead.

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to snap the end of a single octave line to the
previous notehead.
NOTE

●

●

You can only lengthen/shorten octave lines by the current rhythmic grid value
when multiple octave lines are selected.

●

When using the keyboard, you can only move the end of octave lines. You can
move the start of octave lines by moving the whole line, or by clicking and
dragging the start handle.

Click and drag the circular handle at the start/end of a single octave line to
noteheads to the right/left.

RESULT
Single octave lines are lengthened/shortened according to the current rhythmic grid value or to
the next/previous notehead, whichever is closer.
Multiple octave lines are lengthened/shortened according to the current rhythmic grid value.
RELATED LINKS
Positions of octave lines on page 450
Moving octave lines rhythmically on page 450
Moving octave lines graphically on page 451
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Positions of octave lines
You can change the default position of all octave lines project-wide and move octave lines
individually. For example, you can override the default position of individual octave lines where
the notes to which they apply require more/less vertical space.
You can move octave lines to new rhythmic positions in Write mode. They are positioned by
default according to your settings in Engraving Options. You can move octave lines graphically
in Engrave mode, however this does not change the rhythmic positions to which they apply.
You can change the default positions of all octave lines project-wide on the Octave Lines page in
Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for octave lines on page 455
Moving octave lines rhythmically on page 450
Moving octave lines graphically on page 451

Moving octave lines rhythmically
You can move octave lines to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the octave lines you want to move.
NOTE
When using the mouse, you can only move one octave line rhythmically at a time.

2.

Move the octave lines to the next or previous notehead on the staff, while maintaining
their total durations, in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the octave line to the right/left.

RESULT
The octave lines are moved to noteheads to the right/left along the staff. The octave lines now
apply to the notes at their new positions. If an octave line passes over another octave line as part
of its move, the existing line is unaffected as multiple octave lines can exist at the same rhythmic
position.
NOTE
Octave lines can only be moved along staves. If you want to move an octave line across staves,
you must delete the octave line and input a new octave line on the other staff.

RELATED LINKS
Inputting octave lines with the popover on page 179
Inputting octave lines with the panel on page 180
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Moving octave lines graphically
You can move octave lines graphically without changing the rhythmic positions to which they
apply. You can move each end of octave lines independently, meaning you can also adjust the
graphical lengths of individual octave lines.
NOTE
You cannot change the angle of octave lines.

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Whole octave lines

●

The start/end handles of octave lines

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the octave lines or handles in any of the following ways:
●

Press Alt-Right Arrow to move octave lines and handles to the right.

●

Press Alt-Left Arrow to move octave lines and handles to the left.

●

Press Alt-Up Arrow to move octave lines and start handles upwards.

●

Press Alt-Down Arrow to move octave lines and start handles downwards.
NOTE
You cannot move the end handles on octave lines upwards/downwards, you can
only move them to the right/left.
You can move the start handles on octave lines upwards/downwards but this also
moves the whole octave line.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag whole octave lines upwards/downwards.

●

Click and drag handles on octave lines to the right/left.

RESULT
The selected octave lines or handles are moved to new graphical positions.
TIP
The following properties in the Octave Lines group of the Properties panel are activated
automatically when you move octave lines in the corresponding directions:
●

Start X offset moves the start of octave lines horizontally.

●

End X offset moves the end hooks of octave lines horizontally.

●

Y offset moves whole octave lines vertically.

For example, if you move a whole octave line to right, both handles are moved, so Start X offset
and End X offset are both activated. You can also use all three properties to move and lengthen/
shorten octave lines graphically by changing the values in the value fields.
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Deactivating the properties resets the selected octave lines to their default positions.

Changing the alignment of octave line numerals relative to notes
You can change whether the left edge, center, or right edge of individual octave line numerals is
aligned with the first note to which each octave line applies.
PROCEDURE
1.

Select the octave lines whose numeral alignment relative to notes you want to change. You
can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate L alignment in the Octave Lines group.

3.

Select one of the following options from the menu:
●

Left

●

Center

●

Right

RESULT
The alignment of the numerals of the selected octave lines is changed. For example, if you select
Right, the right edge of the selected octave line numerals is aligned with the first noteheads to
which the octave lines apply.

Changing the position of octave line numerals relative to accidentals
You can change whether the numerals at the start of individual octave lines are positioned on
noteheads or accidentals, independently of your project-wide setting.
PROCEDURE
1.

Select the octave lines whose numeral alignment relative to accidentals you want to
change. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate L position in the Octave Lines group.

3.

Choose one of the following options:
●

Notehead

●

Accidental

RESULT
The alignment of the numerals of the selected octave lines is changed. For example, if you
choose Accidental, the octave line numerals are aligned with the accidental on the first
noteheads to which the octave lines apply.
TIP
You can change the default alignment of all octave line numerals project-wide in the Horizontal
Position section of the Octave Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for octave lines on page 455
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Changing the placement of octave lines relative to the staff
You can change the side of the staff on which individual octave lines appear.
PROCEDURE
1.

Select the octave lines whose placement relative to the staff you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Placement in the Octave Lines group.

3.

Choose one of the following options:
●

Above

●

Below

RESULT
The selected octave lines appear above/below the staff.

Deleting octave lines
You can delete octave lines without deleting notes and other items.
PROCEDURE
1.

In Write mode, select the octave lines you want to delete.

2.

Delete the octave lines in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The selected octave lines are deleted. Any notes to which the deleted octave lines previously
applied are shown at either concert pitch or transposed pitch, depending on your current setting
for the layout.
RELATED LINKS
Clefs and octave lines popover on page 176
Input methods for clefs and octave lines on page 175
Changing whether layouts are transposing/non-transposing on page 93

Octave lines in Engrave mode
In Engrave mode, each octave line has three square handles. You can use these handles to move
the start/end of octave lines graphically, and to lengthen/shorten octave line hooks.

An octave line in Engrave mode

●

The start handle moves the start of octave lines graphically. You can move this handle to
the right/left.
NOTE
When using the keyboard, you can also move this handle upwards/downwards. This moves
the whole octave line.

●

The top end handle moves the end of octave lines graphically. You can move this handle to
the right/left.
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●

The bottom end handle changes the length of the hook. You can move this handle
upwards/downwards.

Lengthening/Shortening octave line hooks
You can change the length of individual octave line hooks, independently of your project-wide
setting.
PROCEDURE
1.

In Engrave mode, select the hook handles on the octave lines whose hooks you want to
lengthen/shorten.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the hook handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●

Click and drag them upwards/downwards.

RESULT
The length of the selected octave line hooks is changed.
TIP
Hook length in the Octave Lines group of the Properties panel is activated automatically when
you move octave line hooks. You can also use this property to lengthen/shorten octave line
hooks by changing the value in the value field.
Deactivating the property resets the selected octave lines to their default hook length.
TIP
You can change the default hook length for all octave lines project-wide by changing the value
for Octave line hook length, which you can find by clicking Advanced Options in the
Appearance section of the Octave Lines page in Engrave > Engraving Options.

RELATED LINKS
Octave lines in Engrave mode on page 453

Tucking index properties
The tucking index of notations determines their position relative to other notations in the vertical
stacking order when multiple notations exist at the same rhythmic positions.
In most published music, the order in which items appear relative to each other is consistent.
Dorico uses established conventions to determine the position and placement of notations
automatically. For example, where slurs and tuplet brackets exist at the same positions, Dorico
calculates their placement based on their relative lengths. If the slur is longer than the tuplet
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bracket, the slur is placed outside the tuplet bracket; if the tuplet bracket is longer than the slur,
the slur is placed inside the tuplet bracket.
However, rules for the order and placement of articulations, slurs, tuplets, and octave lines
frequently vary, based on their lengths and musical context. Therefore, you can override the
automatic order and manually change the order in which they appear in specific contexts.
To allow you this flexibility, slurs, octave lines, and tuplets all have Tucking Index properties in
their respective Properties panel groups.
NOTE
Articulations are considered alongside these notations when calculating the stacking order, but
do not have a tucking index property.
A Tucking Index value of 0 positions items closest to notes. The higher the number, the further
away the item is positioned from notes in the stacking order.
RELATED LINKS
Changing the vertical stacking order of octave lines on page 455

Changing the vertical stacking order of octave lines
You can change the placement of individual octave lines relative to other objects in the vertical
stack by changing their tucking index value.
According to general convention, octave lines are placed outside all other objects, but there are
some instances where they can go inside other objects, for example, inside a slur if that slur is
longer than the octave line.
PROCEDURE
1.

In Engrave mode, select the octave lines whose placement in the vertical stack you want to
change.

2.

In the Properties panel, activate Tucking index in the Octave Lines group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

0 positions items closest to notes. The higher the number, the further the item is
positioned from notes in the stacking order.
RESULT
The placement of the selected octave lines in the vertical stacking order is changed.
RELATED LINKS
Tucking index properties on page 454

Project-wide engraving options for octave lines
You can find options for the project-wide appearance of octave lines on the Octave Lines page in
Engrave > Engraving Options.
The options on this page allow you to change the appearance of continuation lines, continuation
labels, the numeral at the start of octave lines, the position of octave lines relative to accidentals
and noteheads, and their placement relative to the staff.
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There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Octave Lines in the page list on the left of the dialog.
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Cues are passages of music shown in instrumental parts that are played by a different player,
usually to help orientate players before entries or solos following a significant passage of rests.
Cues can also be used to assist with co-ordination or tuning between players, or to indicate
material that the player might be asked to double.
In Dorico, you can input correctly formatted cues quickly using the cues popover. Cues are
automatically input into a new voice, with bar rests shown alongside cues to make sure the
player reading the cue understands that they do not play the cued music. Clefs are automatically
input in cues as required, including restorative clefs.

A cue in a violin part showing music from a Bassoon 1 part

Dorico features dynamic cues that are linked to the original source material, meaning cues are
updated in real time if the source material changes.
The instrument whose music is included in a cue is known as the source instrument. The
instrument whose part contains a cue from another instrument is known as the destination
instrument.
RELATED LINKS
Inputting cues on page 216
Individual changes to the content of cues on page 464
Note spacing on page 284
Changing note spacing from specific points on page 289

General placement and notation conventions for cues
Cues are usually notated using notes of a smaller size than normal notes, with the name of the
cued instrument indicated at the start of the passage.
It is generally accepted that full-sized rests are shown above/below cues to reinforce that the
player reading the cue does not play these notes.
Cues might exclude some notations that are present in the source instrument. However, cues
normally include slurs, articulations, and dynamics, as these often help the player reading the
cue to identify passages.
Depending on the register of the cued instrument and the range of each cue passage, clef
changes might also be needed at the start of cues.
RELATED LINKS
Cue labels on page 464
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Clef changes in cues on page 473
Notations in cues on page 467
Changing the notations included in cues on page 468

Rhythmic cues
Rhythmic cues only show the rhythm in the source instrument, whether it is pitched or
unpitched, and are positioned above the staff by default. Cues from unpitched percussion source
instruments are positioned on the middle line of the staff by default.
Rhythmic cues do not show clef changes, accidentals, or ledger lines. Their default position
outside staff lines ensures they can never be misread as containing pitched material.
You can change existing cues into rhythmic cues and vice versa. Changing cues from pitched
source instruments into rhythmic cues shows only the rhythm, which can be helpful when
multiple instruments play the same rhythm together but each instrument plays a different note,
such as in big band music with large unison chords. In this context, showing the pitches of a
single instrument in the group could be misleading as the destination instrument might think
this indicates a distinctive melody. You can then change the cue label to include information
about the instruments playing the rhythm in the cue.
By default, cues from unpitched percussion source instruments are input as rhythmic cues. If you
want to save vertical space, you can change them to cues from unpitched percussion source
instruments. This positions them on the middle line of the staff by default.
You can change the default staff positions for rhythmic cues and cues from unpitched percussion
source instruments in the Rhythmic Cues and Unpitched Instruments sections of the Cues
page in Engrave > Engraving Options.
You can also change the staff position of rhythmic cues and cues from unpitched percussion
source instruments individually.

A rhythmic cue

A cue from an unpitched percussion source

RELATED LINKS
Changing existing cues to rhythmic cues on page 458
Changing the text shown in cue labels on page 465
Changing the staff position of cues from unpitched percussion source instruments on page 459

Changing existing cues to rhythmic cues
Cues normally show pitched material played by a specific instrument. However, you can change
existing cues showing pitched material into rhythmic cues that only show the rhythm of the cued
music. This can be helpful for passages where many instruments play the same distinctive
rhythm together.
PROCEDURE
1.

Select the cues you want to change into rhythmic cues. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Rhythmic cue in the Cues group.
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RESULT
The selected cues are shown as rhythmic cues. They are automatically positioned above the staff
according to your setting for Distance from space above staff in the Rhythmic Cues section of
the Cues page in Engrave > Engraving Options.
NOTE
Deactivating Rhythmic cue returns the selected cues back to normal cues. This includes cues
from unpitched percussion instruments that are automatically input as rhythmic cues.
If you deactivate Rhythmic cue for cues from unpitched percussion instruments, the cues are
positioned on the middle line of the staff by default.

RELATED LINKS
Rhythmic cues on page 458
Inputting cues on page 216
Changing the text shown in cue labels on page 465
Changing the distance between rhythmic cues and the staff on page 459

Changing the distance between rhythmic cues and the staff
You can change the distance between individual rhythmic cues and the staff, independently of
your project-wide setting.
PROCEDURE
1.

Select the cue label of the rhythmic cues whose distance from the staff you want to
change. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Distance in the Cues group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
The position of the selected cues is changed according to the new value.
For example, entering 0 positions rhythmic cues in the space immediately above the top line on
the staff. Higher values increase the distance between rhythmic cues and the staff.
TIP
You can change the default distance between all rhythmic cues and the top line of the staff
project-wide on the Cues page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for cues on page 463

Changing the staff position of cues from unpitched percussion
source instruments
You can change the staff position of cues from unpitched percussion source instruments
individually, independently of your project-wide setting.
By default, cues from unpitched percussion source instruments that are not rhythmic cues are
positioned on the middle line of staves.
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PROCEDURE
1.

Select the cue label of the cues from unpitched percussion source instruments whose staff
position you want to change. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Unpitched notes pos. in the Cues group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
The staff position of the selected cues is changed according to the new value. For example, 0 is
the middle line of the staff, 4 is the top line of the staff, and -4 is the bottom line of the staff.
TIP
You can change the default staff position of all cues from unpitched percussion source
instruments project-wide on the Cues page in Engrave > Engraving Options.
EXAMPLE

Unpitched cue on the middle line of the staff
(default)

Unpitched cue at a higher staff position

RELATED LINKS
Project-wide engraving options for cues on page 463

Changing the octave of cues
You can change the octave in which cues are shown so the cue fits better on the staff of the
destination instrument. This can be useful if the source instrument plays in a significantly
different octave to the destination instrument.
PROCEDURE
1.

In the music area, open the layout in which you want to change the octave of cues.

2.

Select the cues whose octave you want to change. You can do this in Write mode and
Engrave mode.

3.

In the Properties panel, activate Octave shift in the Cues group.

4.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

For example, 1 shifts the cue up one octave, and -1 shifts the cue down one octave.
RESULT
The octave of the selected cues is changed.
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NOTE
If octave transpositions are shown in the cue labels, they are automatically updated.
EXAMPLE

Cue with no octave change

Cue with an octave above line

Hiding/Showing octave transpositions in cue labels
By default, octave transpositions are included in cue labels when you shift the octaves at which
cues are shown. You can hide/show octave transpositions in cue labels individually,
independently of your project-wide setting.
PROCEDURE
1.

Select the cue labels in which you want to hide/show octave transpositions. You can do this
in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Show octave transposition in the Cues group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Octave transpositions are shown in the selected cue labels when the checkbox is activated, and
hidden when the checkbox is deactivated.
Deactivating the property returns cue labels to your project-wide setting.
TIP
You can show/hide octave transpositions in all cue labels project-wide on the Cues page in
Engrave > Engraving Options.

RELATED LINKS
Changing the information included in cue labels project-wide on page 465

Moving cues
You can move cues to new rhythmic positions after they have been input. This changes the
material shown in cues to reflect the material at the corresponding rhythmic positions in the
source instrument.
PROCEDURE
1.

In Write mode, select the cues you want to move.
NOTE
When using the mouse, you can only move one cue at a time.

2.

Move the cues, while maintaining their total durations, in any of the following ways:
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●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the cue to the right/left, according to the rhythm in the source
instrument.

RESULT
If a single cue is selected, it is moved to the right/left, depending on the rhythm in the source
instrument.
If multiple cues are selected, they are moved to the right/left, according to the current rhythmic
grid value.
RELATED LINKS
Overlapping cues on page 470
Hiding/Showing cues in layouts on page 469

Lengthening/Shortening cues
You can change the length of cues after they have been input. This changes the material shown
in cues to reflect the material at the corresponding rhythmic positions in the source instrument.
PROCEDURE
1.

In Write mode, select the cues you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one cue at a time.

2.

Lengthen/Shorten the cues in any of the following ways:
●

Press Shift-Alt-Right Arrow to lengthen cues by the current rhythmic grid value.

●

Press Shift-Alt-Left Arrow to shorten cues by the current rhythmic grid value.

●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to lengthen a single cue to the next notehead
of the source instrument.

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to shorten a single cue to the previous
notehead of the source instrument.
NOTE
When multiple cues are selected, you can only lengthen/shorten cues by the current
rhythmic grid value.

●

Click and drag the circular handle at the start/end of a single cue to the right/left.

RESULT
The selected cues are lengthened/shortened.
NOTE
Key commands lengthen/shorten items by moving their end only.
NOTE
You can lengthen cues so that they overlap with other existing cues, as multiple cues can exist at
the same rhythmic position. However, their stem directions are not automatically adjusted so you
might have to change them manually.
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RELATED LINKS
Overlapping cues on page 470
Overriding default stem directions in single-voice cues on page 471
Moving cues on page 461

Deleting cues
You can delete individual cues without deleting the corresponding notes in the source
instrument or other instruments containing the same cue.
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The cues you want to delete.

●

The signposts of cues you want to delete that are not shown in the current layout.

Delete the cues in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The selected cues are deleted from all the layouts containing the affected instruments. For
example, deleting a cue in a piano part also deletes the cue from the piano staff in
corresponding full score layouts.

Project-wide engraving options for cues
You can find options for the project-wide appearance, content, and position of cues on the Cues
page in Engraving Options.
The options on the Cues page allow you to change the size, appearance, placement, and precise
position of cues. You can also decide which notations are included in all cues, set the default
spacing of cues, and set the default staff position of rhythmic cues and cues from unpitched
percussion source instruments.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Cues in the page list on the left of the dialog.
RELATED LINKS
Note spacing on page 284
Changing existing cues to rhythmic cues on page 458
Rhythmic cues on page 458
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Individual changes to the content of cues
The content of individual cues can appear differently in each layout, independently of other
layouts and without changing the source material, if you make changes in a layout that does not
contain the source instrument.
Music in cues is dynamically linked to the music in the source instrument. Any changes you make
to the source music are automatically shown in the cue, but you cannot change the pitch or
duration of notes within the cue. This ensures that cues are an accurate reflection of the notes
being played by the cued instrument.
You can make graphical changes to the music in cues without affecting the corresponding music
in the source instrument. For example, you can adjust the placement of slurs and the angles of
glissando lines, lengthen/shorten stems in cues, and respell accidentals. You can also change the
note spacing scale factor of cues for whole layouts and from specific points in individual layouts.
NOTE
Graphical changes to cues are layout-specific. For example, if you make changes to a cue within a
full score layout that also contains the source instrument, your changes to the cue affect the
corresponding material in the source instrument and other instruments with the same cue in the
layout. However, if you make changes to a cue in a part layout that only contains the destination
instrument, the corresponding material in the part layout of the source instrument is not
affected.
It is also possible to change the enharmonic spelling of notes in cues in Engrave mode in the
same way as changing the enharmonic spelling of normal notes. If you respell notes in cues in
the part layout of the destination instrument, the spelling of notes in the source instrument is
not affected. For example, you can change the enharmonic spelling of notes in cues in
transposing instrument layouts to avoid double accidentals.
IMPORTANT
If you respell notes in cues in a layout that also contains the source instrument, the enharmonic
spelling is also changed in the source instrument.

RELATED LINKS
Respelling accidentals on page 136
Slurs in Engrave mode on page 675
Lengthening/Shortening stems on page 717
Note spacing on page 284
Note Spacing Change dialog on page 287
Changing note spacing from specific points on page 289

Cue labels
Cue labels usually indicate the source instrument from which the music is taken, but can also
include other information, such as the transposition interval for transposing instruments. This
information can help players identify both where the sound is coming from in the ensemble and
the type of sound to listen for.
By default, cue labels in Dorico use abbreviated instrument names, exclude instrument
transpositions, include octave transpositions, and do not show an additional label at the end of
cues to indicate where players enter after cues. Additional labels showing “Play” at the end of
cues are sometimes used in jazz scores, where it is customary not to show bar rests alongside
cues. Showing additional labels at the ends of cues can also be useful in film music, where cues
are often included in parts as an option that the player might be asked to play.
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You can change the information and text shown in cue labels both project-wide and on an
individual basis in Dorico.
NOTE
If you want to hide/show cue labels at the start/end of cues individually, you can use the
following properties in the Cues group of the Properties panel:
●

Start text applies to labels at the start of cues.

●

End text applies to labels at the end of cues.

RELATED LINKS
Changing the information included in cue labels project-wide on page 465
Changing the text shown in cue labels on page 465

Changing the information included in cue labels project-wide
You can change the information included as text in cue labels project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Cues in the page list.

3.

In the Cue Labels section, change any of the following options:

4.

●

Instrument name in label

●

Instrument pitch or transposition

●

Octave transposition

●

Additional label at end of cue

Click Apply, then Close.

RESULT
The information included in cue labels is changed project-wide.
TIP
You can also change cue labels individually. For example, if two instruments are playing in
unison, you can change the cue label that shows the name of one of the instruments to include
both instrument names.

RELATED LINKS
Changing the text shown in cue labels on page 465

Changing the text shown in cue labels
You can override the text shown in cue labels individually. For example, if two instruments are
playing in unison, you can change the cue label that shows the name of one of the instruments
to include both instrument names.
You can also show additional labels at the ends of individual cues, even if your project-wide
setting is to show no additional labels.
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PROCEDURE
1.

Select the cue labels whose text you want to override. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Cues group:

3.

●

Start text

●

End text

Enter the text you want to be shown in the corresponding cue labels into each value field.
For example, to indicate that two violinists are playing the same material but an octave
apart, you might enter Vln.I & Vln.II coll’ottava in the value field for Start text.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The cue labels of the selected cues are changed to show the text you entered.
Deactivating the properties returns the corresponding cue labels of the selected cues to their
default text.
NOTE
Deactivating properties permanently deletes any custom text entered.

RELATED LINKS
Changing the information included in cue labels project-wide on page 465

Changing the placement of cue labels relative to the staff
You can change the placement of individual cue labels relative to the staff, independently of your
project-wide setting.
PROCEDURE
1.

Select the cue labels whose placement relative to the staff you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Placement in the Cues group.

3.

Choose one of the following options:
●

Above

●

Below

RESULT
The selected cue labels appear above/below the staff.
TIP
●

Deactivating Placement returns the selected cue labels to their default placement.

●

You can change the default placement of all cue labels relative to the staff project-wide on
the Cues page in Engrave > Engraving Options.
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Moving cue labels graphically
You can move individual cue labels graphically without affecting the rhythmic positions of the
cue. You can move cue labels at the start and end of cues independently of each other.
PROCEDURE
1.

In Engrave mode, select the cue labels you want to move.

2.

Move the cue labels in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The selected cue labels are moved to new graphical positions.
TIP
Offset in the Cues group of the Properties panel is activated automatically when you move cue
labels.
●

Offset X moves cue labels horizontally.

●

Offset Y moves cue labels vertically.

You can also use this property to move cue labels by changing the values in the value fields. The
same property applies to cue labels both at the start and end of cues.
Deactivating the property resets the selected cue labels to their default positions.

Notations in cues
It is beneficial to include musically significant notations from the source instrument in cues, as
they can help players identify the cued music more easily. However, only certain notations are
included in cues to avoid overloading players with too much information.
By default, Dorico includes the following notations in cues:
●

Slurs

●

Articulations

●

Ornaments

●

Playing techniques

●

Lyrics (for vocal music)

You can also include dynamics and text in cues, but these are not included by default as this
information is not usually required to help identify the cued material.
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NOTE
Playing techniques that only indicate important information for the source instrument, such as
bowing marks for string players, are not included in cues.
To be included in cues, playing techniques must exist within the range of the cued material. For
example, slurs must begin and end within the cued material to be included in cues.
Similarly, pizzicato markings are not shown in cues if they are input before the first cued note.
However, pizzicato strings sound significantly different to bowed strings, so omitting this
information could prevent the player reading the cue from identifying it.
NOTE
If important playing technique information does not exist within the range of cued material, we
recommend that you include this information in the corresponding cue labels.

RELATED LINKS
Changing the notations included in cues on page 468
Changing the text shown in cue labels on page 465

Changing the notations included in cues
You can change the notations included in individual cues, independently of your project-wide
settings.
PROCEDURE
1.

Select the cue labels of the cues whose included notations you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate the property for each notation that you want to include in,
or exclude from, the selected cues in the Cues group:

3.

●

Show articulations

●

Show slurs

●

Show dynamics

●

Show lyrics

●

Show playing techniques

●

Show ornaments

●

Show text

Activate/Deactivate the corresponding checkboxes.

RESULT
Notations are included in cues when the checkboxes are activated, and excluded from cues when
the checkboxes are deactivated.
NOTE
Playing techniques that only indicate important information for the source instrument, such as
bowing marks for string players, are not included in cues.
TIP
You can change which notations are included in all cues project-wide on the Cues page in
Engrave > Engraving Options.
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RELATED LINKS
Project-wide engraving options for cues on page 463
Changing the text shown in cue labels on page 465

Hiding/Showing cues in layouts
You can input cues in any layout, but by default cues do not appear in full score layouts, as cues
are normally only shown in instrumental parts. You can hide/show cues in each layout in your
project independently of other layouts.
Cue signposts are shown in full score layouts by default in page view. In galley view, the cued
music appears in addition to cue signposts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to hide/show cues in one of the
following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Players from the Category menu.

4.

In the Cues section, activate/deactivate Show cues.

RESULT
All cues in the selected layouts are shown when the checkbox is activated, and hidden when the
checkbox is deactivated.
If cues are hidden, signposts show where they begin.
NOTE
You can hide individual cues in layouts where cues are shown, but you cannot show individual
cues in layouts where cues are hidden.

RELATED LINKS
Hiding cues individually on page 469

Hiding cues individually
You can hide individual cues in layouts in which cues are shown, but you cannot show individual
cues in layouts where cues are hidden.
PROCEDURE
1.

In the music area, open the layout in which you want to hide individual cues.

2.

Select the cues you want to hide. You can do this in Write mode and Engrave mode.
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3.

In the Properties panel, activate Hide in the Cues group.

RESULT
The selected cues are hidden when Hide is activated. Signposts are shown at the positions of
each cue so you can always find them again. However, signposts are not printed by default.
Deactivating Hide shows the selected cues again.
RELATED LINKS
Hiding/Showing cues in layouts on page 469

Stem direction in cues
Notes in cues normally have the same stem direction, as cues usually highlight lines containing
only one voice. Cues are shown by default with bar rests alongside them to indicate that the
player reading the cue does not play those notes.
If cues contain music in multiple voices, the original stem directions of the source music are
used. For single-voice cues, Dorico determines the default stem direction depending on the
pitches in the cue. Stems point downwards when most notes in the cue are at positions below
the middle line of the staff, and upwards when most notes in the cue are at positions above the
middle line of the staff.
TIP
You can override the stem directions of notes in single-voice cues individually.

RELATED LINKS
Overriding default stem directions in single-voice cues on page 471

Overlapping cues
Sometimes it is helpful to give players multiple consecutive cues so they can follow passages of
music more easily. Dorico allows cues to overlap in order to give you flexibility over how to give
useful information in cues to players.
However, the stem directions of cues are not automatically adjusted when they exist at the same
rhythmic position as other cues. For example, if you want to show a melody passing from Violin 1
to Violin 2 that requires the two cues to overlap, and both instruments are shown in up-stem
voices by default, then the two cues appear with up-stem notes.
You can override the default stem directions of cues individually to make overlapping cues easier
to read.

Default stem directions in two overlapping cues

Overridden stem directions in the cue containing
lower notes so that its notes are down-stem

RELATED LINKS
Overriding default stem directions in single-voice cues on page 471
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Overriding default stem directions in single-voice cues
You can override the default stem directions of individual single-voice cues.
PROCEDURE
1.

In the music area, open the layout in which you want to override the default stem direction
of selected cues.

2.

Select the cue labels or cue signposts of the cues whose stem direction you want to
change. You can do this in Write mode and Engrave mode.

3.

In the Properties panel, activate Voice direction in the Cues group.

4.

Choose one of the following options:
●

Force stems up

●

Force stems down

RESULT
The stem direction of all notes in the selected cues is changed.
Deactivating Voice direction returns the selected cues back to their default stem direction.
RELATED LINKS
Stem direction in cues on page 470

Ties in cues
If cues begin in the middle of sustained notes, ties are shown joining to the first note in cues.
Similarly, if cues end in the middle of sustained notes, ties are shown proceeding from the final
notes in cues.
For monophonic instruments, these ties are normally positioned correctly by default. However, in
complex cases, such as cues involving chords, the positions of these ties can require some
adjustment.
You can edit ties that start before/end after cues in the same way as normal ties in Engrave
mode.
RELATED LINKS
Changing the position/shape of ties on page 742

Rests in cues
If cues start/end partway through bars, they are padded with cue-sized rests up to bar
boundaries or up to the next played entry, whichever comes first. This ensures it is clear to the
player how the rhythm of the cue fits within the current time signature and how it relates to their
existing material.
By default, full-sized bar rests also appear throughout cued passages. This makes it clear that the
performer does not play the cued notes.
Full-sized bar rests are automatically positioned according to the stem direction of the notes in
the cue. If cues use up-stem notes, bar rests are positioned below cued notes. If cues use downstem notes, bar rests are positioned above the cued notes.
You can choose not to show bar rests alongside cues. For example, this can be appropriate in
some jazz scores, or in scores where the cues are provided as potential passages for doubling.
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TIP
You can adjust the vertical position of full-sized bar rests individually using Rest pos. in the
Notes and Rests group of the Properties panel.

RELATED LINKS
Hiding/Showing padding rests in cues on page 472
Hiding/Showing bar rests in cues on page 472
Moving individual rests vertically on page 661

Hiding/Showing padding rests in cues
You can hide/show padding rests around individual cues. Padding rests fill up bars when cues
start/end partway through bars, so that the full duration of each bar is clear.
PROCEDURE
1.

Select the cue labels or cue signposts of the cues whose padding rests you want to hide/
show. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Hide rests around cue in the Cues group.

RESULT
Padding rests around the selected cues are hidden when Hide rests around cue is activated, and
shown when it is deactivated.
RELATED LINKS
Rests in cues on page 471
Implicit vs. explicit rests on page 657

Hiding/Showing bar rests in cues
You can hide/show bar rests alongside all cues in each flow in your project.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.
The Notation Options dialog opens.

2.

In the Flows list, select the flows in which you want to hide/show bar rests in cues in one of
the following ways:
●

Ctrl/Cmd-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
3.

Select Rests from the Category menu.

4.

In the Rests in additional voices section, choose one of the following options for Bar
rests in cues:

5.

●

Show bar rests

●

Omit bar rests

Click Apply, then Close.

RESULT
Bar rests alongside cues are hidden/shown in all layouts in the selected flows in your project.
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RELATED LINKS
Rests in cues on page 471
Moving individual rests vertically on page 661

Clef changes in cues
If the music for the source instrument is in a different clef from the destination instrument,
Dorico automatically inputs a clef change at the start of cues to match the clef used by the source
instrument, and a restorative clef change at the end of cues to match the original clef used by
the destination instrument.
Clef changes at the start of cues are positioned differently to normal clef changes.
Cues starting at the beginning of bars
Clef changes appear to the right of barlines.
Restorative clef changes at the ends of cues are positioned like normal clef changes.
Cues crossing system breaks
Original clefs of destination parts are shown in their usual positions at the start of
new systems.
Clefs required for cues appear immediately before the first note of the new system,
to the right of key signatures and time signatures.
When there are multiple adjacent cues, clef changes are created as needed:
●

If two adjacent cues use the same clef that is different than the clef in the destination
instrument, a single clef change appears at the start of the first cue, with a restorative clef
at the end of the second cue.

●

If cues overlap, and the second cue requires a different clef than the first, Dorico creates a
clef change at the start of the second cue.

●

If there are two adjacent cues, the first of which uses a different clef than the destination
instrument, and the clef property for the second cue is set to None, then the clef change
that restores the destination instrument’s original clef appears at the end of the first cue.

You can override this automatic behavior for individual clefs using one of the following
properties in the Cues group of the Properties panel:
●

Concert clef

●

Transposed clef

The property available depends on whether the layout currently open in the music area uses
concert or transposed pitch.
Dorico can show the following clefs in cues:
●

None

●

Treble

●

Alto

●

Tenor

●

Bass

NOTE
●

If you select None, the clef of the destination instrument is used instead of the clef of the
source instrument.

●

Any clef changes that occur in the source instrument in the middle of cued passages are
not included in the cue in the destination instrument.
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RELATED LINKS
Changing the clef shown in cues on page 474

Changing the clef shown in cues
You can change the clef shown in individual cues, independently of your project-wide settings.
You can show different clefs for the same cue in each layout in which it appears. For example,
you can show a cue with a treble clef in a full score layout but with a bass F clef in the
corresponding part layout.
PROCEDURE
1.

In the music area, open the layout in which you want to change the clef shown in cues.

2.

Select the cues whose clef you want to change. You can do this in Write mode and Engrave
mode.

3.

In the Properties panel, activate one of the following properties in the Cues group:

4.

●

Concert clef: shown if the layout uses concert pitch

●

Transposed clef: shown if the layout uses transposed pitch

Select one of the following clefs from the menu:
●

None
NOTE
None uses the clef of the destination instrument instead of the clef of the source
instrument.

●

Treble

●

Alto

●

Tenor

●

Bass

The same clefs are available for each property.
RESULT
The clef shown in the selected cues is changed.
TIP
You can change whether the clef of the source instrument or destination instrument is used in all
cues project-wide on the Cues page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for cues on page 463

Viewing options for cues
You can highlight cues and/or show cued material in a different color to normal notes in your
project to help you identify cues more easily as you are working.
Choosing View > Highlight Cues shows bars containing cues with a translucent yellow highlight
behind them, and a translucent blue highlight behind the bars that are used as the sources for
cues.
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As you zoom out, the highlights become more opaque, allowing you to get an overview both of
where cues have already been added, and which instruments are being used as cues. This is
especially useful when viewing full score layouts in galley view.
Choosing View > Note and Rest Colors > Cues shows cued material in gray, which indicates that
this material cannot be edited directly.
In layouts where cues are not shown, cues are indicated by signposts. You can hide/show cue
signposts by choosing View > Signposts > Cues. Cue signposts are shown when a tick appears
beside Cues in the menu, and hidden when no tick appears.
RELATED LINKS
Hiding/Showing cues in layouts on page 469
Signposts on page 106
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Dynamics indicate the loudness of the music, and can be combined with other instructions to
give the performer a detailed understanding of how to perform the music, while also leaving
room for interpretation.
Dynamics can indicate an immediate change in volume or a gradual change over a specified
duration. By default, they are placed below the staff for instruments and above the staff for
voices.
You can add qualifying and expressive text to dynamics that can give stylistic direction context
alongside the volume level, for example,  espressivo indicates that a passage is played loudly but
also with expressive feeling.
While almost all expression text is written in italics, dynamics such as  and  use a bold italic
font.
RELATED LINKS
Input methods for dynamics on page 161
General placement conventions for dynamics on page 477

Types of dynamics
Dorico categorizes dynamics into four groups.

Immediate dynamics
Immediate dynamics apply to the note to which they are attached until the next dynamic
marking, and indicate an immediate change from any previous dynamic. Immediate dynamics
include dynamic symbols, such as  or , and qualifying text, such as subito or molto.

Gradual dynamics and hairpins
Gradual dynamics are often shown as hairpins but can also be shown using text. In Dorico, you
can show gradual dynamic text in the following ways:
●

cresc. or dim.: abbreviated text with no continuation line

●

cresc... or dim...: abbreviated text with a dotted continuation line

●

cre-scen-do or di-mi-nuen-do: the full word spread out across the duration of the gradual
dynamic

Gradual dynamics can also have qualifying text, such as poco, molto, poco a poco, and niente.
In Dorico, a hairpin can be shown as messa di voce, which shows a pair of hairpins. In some cases,
this is easier than having separate lines for each half of the pair.

Force/Intensity of attack
These dynamics, such as  and , indicate that a note has a stronger attack than is usually
expected for the dynamic, similar to an accent articulation.
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Combined dynamics
Combined dynamics, such as  or –, specify a sudden change of dynamic.
You can create custom combined dynamics in Dorico, and control the intensity of each dynamic
in the pair, in the Combined Dynamics section of the Dynamics panel. For example, you can
make dynamics such as , –, and .
RELATED LINKS
Gradual dynamics on page 483

General placement conventions for dynamics
Dynamics are placed below the staff for instruments, where they can be read alongside the
notes, and above the staff for voices. This way, they do not clash with lyrics placed below the
staff, and are still close enough to the notes to be read simultaneously.
Immediate dynamics, such as  or , are centered on the notehead to which they apply. The
beginnings of gradual dynamics are centered on the notehead from which they begin, or
immediately after an immediate dynamic at the same position. The ends of gradual dynamics are
centered on the notehead at which they end, or immediately before an immediate dynamic at
the same position.
In Dorico, dynamics are positioned automatically relative to noteheads. You can change projectwide settings for how dynamics appear on the Dynamics page in Engraving Options, and you
can move individual dynamics graphically in Engrave mode.
RELATED LINKS
Project-wide engraving options for dynamics on page 496
Positions of dynamics on page 490
Moving dynamics graphically on page 492

General placement conventions for hairpins relative to barlines
In Dorico, the ends of hairpins align with the left edge of the note to their right.
Hairpins that end on the first note of a bar extend across the preceding barline in certain cases.
●

If there is not an immediate dynamic on the first note in the next bar.

●

If there is a time signature or key signature change at the barline which increases the gap
between the end of the current bar and the first note in the new bar.

Dorico avoids hairpins overlapping barlines by a small amount, as this is less visually clear.
However, this means that the same dynamic phrase on two different staves can appear
differently if one of the staves does not have the barline extending below it.
You can change this default behavior and stop all hairpins project-wide from crossing barlines if
the hairpin ends on the first note in the next bar. This ensures all applicable hairpins appear the
same length. You can also change the minimum distance before hairpins are allowed to extend
beyond barlines.
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The ends of the two hairpins are not aligned despite their duration being identical, as the barline does not
extend to the bottom staff of the system.

RELATED LINKS
Changing the project-wide position of hairpins relative to barlines on page 478

Changing the project-wide position of hairpins relative to barlines
You can change whether all hairpins cross barlines when they end on the first note in the next
bar project-wide. You can also change the minimum distance before hairpins are allowed to
extend beyond barlines.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Dynamics in the page list.

3.

In the Gradual Dynamics section, click Advanced Options.

4.

Choose one of the following options for Hairpins ending at beginning of note at start of
bar:

5.

6.

●

Do not cross barline

●

Allow to cross barline

Optional: In the Horizontal Position section, change the value for Minimum distance to
right of barline to allow dynamic to cross barline in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

Click Apply, then Close.

Showing dynamics in parentheses
You can show individual dynamics in parentheses, for example, to show editorial dynamics that
were not in the original manuscript.
PROCEDURE
1.

Select the dynamics you want to appear parenthesized. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Parenthesized in the Dynamics group.

RESULT
Each of the selected dynamics is shown in parentheses individually.
Deactivating Parenthesized removes parentheses from the selected dynamics.
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Copying dynamics
You can copy dynamics to other rhythmic positions after they have been input. You can select
dynamics on a single staff to copy to another single staff, or you can select dynamics across
multiple staves to copy across the same number of staves.
PROCEDURE
1.

2.

In Write mode, select the dynamics you want to copy in one of the following ways:
●

Ctrl/Cmd-click each dynamic.

●

Select a passage and choose Edit > Filter > All Dynamics.

●

Select a passage and choose Edit > Filter > Gradual Dynamics.

●

Select a passage and choose Edit > Filter > Immediate Dynamics.

Copy the dynamics in any of the following ways:
●

Press Ctrl/Cmd-C.

●

Choose Edit > Copy.

3.

Select the notehead at the rhythmic position to which you want to copy the dynamics.

4.

Paste the dynamics in any of the following ways:
●

Press Ctrl/Cmd-V.

●

Choose Edit > Paste.

RESULT
The selected dynamics are pasted to new rhythmic positions. If you copied dynamics to other
staves at the same rhythmic position as the original dynamics, the dynamics on all staves are
automatically linked.
If you selected multiple dynamics at different rhythmic positions, their new positions reflect their
original rhythmic spacing.
TIP
●

You can also copy dynamics without adding them to your clipboard by selecting them and
Alt-clicking each notehead to which you want to copy the selected dynamics.

●

If you want to copy dynamic phrases immediately after where they were originally input,
you can select them and press R. If you select a single immediate dynamic, it is copied to
the same position.

RELATED LINKS
Dynamics linked across multiple staves on page 494

Deleting dynamics
You can delete dynamics from your project. If you delete a dynamic that is linked to dynamics on
other staves, all equivalent linked dynamics are also deleted.
PROCEDURE
1.

In Write mode, select the dynamics you want to delete.

2.

Delete the dynamics in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.
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RESULT
The selected dynamics are deleted. If you delete immediate dynamics immediately before/after
hairpins, the length of hairpins can adjust automatically, depending on the context.
NOTE
Deleting dynamics that are linked to other staves can cause the selected dynamics to be deleted
from all linked staves as well. If you do not select and delete all dynamics in the group, the
selected dynamics are also deleted from all linked staves. However, if you select and delete the
whole group of dynamics from a single staff, those dynamics are not deleted from other staves.

RELATED LINKS
Groups of dynamics on page 493
Dynamics linked across multiple staves on page 494

Voice-specific dynamics
You can input different dynamics into each voice independently in multiple-voice contexts.
Inputting voice-specific dynamics allows you to show different dynamics for multiple voices on a
staff, or to highlight an inner melody voice in a piano texture. They change the dynamics of each
voice in playback.
During step input, voice-specific dynamics are added to the voice indicated by the stem direction
of the quarter note symbol beside the caret.
By default, dynamics apply to all voices on a staff if input without pressing Alt. If you want each
voice to have their own dynamic in playback as well as in the score, press Alt when inputting
dynamics for every voice on a staff.
RELATED LINKS
Inputting dynamics with the popover on page 164
Inputting dynamics with the panel on page 166

Niente hairpins
Niente markings at the start/end of gradual dynamics indicate that the dynamic either increases
from, or decreases to, silence.
This effect works very well on strings and singers with vowels, but it cannot always be played
literally. For example, singers with words beginning with consonants cannot begin from silence,
nor can reed and brass instruments, as they have to achieve a certain air pressure before a note
sounds.
Niente markings can be shown in two ways: as a circle at the end of a hairpin, and as text directly
before or after a hairpin. You can input both types of niente markings in Dorico using the
dynamics popover and by clicking niente in the Gradual Dynamics section of the Dynamics
panel.
TIP
You can turn existing hairpins into niente hairpins by selecting them and clicking niente in the
Gradual Dynamics section of the Dynamics panel, or by activating Niente in the Dynamics
group of the Properties panel.
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EXAMPLE

A niente shown as Circle on hairpin

A niente shown as Text

RELATED LINKS
Changing the appearance of individual niente hairpins on page 481
Lengthening/Shortening gradual dynamics and groups of dynamics on page 484
Input methods for dynamics on page 161

Changing the appearance of individual niente hairpins
You can show niente hairpins in two ways in Dorico, and you can change how they appear
individually, independently of your project-wide setting.
PROCEDURE
1.

Select the hairpins whose niente style you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Niente style in the Dynamics group.

3.

Choose one of the following options:
●

Circle on hairpin

●

Text

RESULT
The niente style of the selected hairpins is changed.
TIP
You can change how all niente hairpins appear project-wide in the Gradual Dynamics section of
the Dynamics page in Engrave > Engraving Options.
EXAMPLE

A niente shown as Circle on hairpin

A niente shown as Text

RELATED LINKS
Project-wide engraving options for dynamics on page 496
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Expressive text
Expressive text adds further detail to a dynamic than simply its volume level, and can help guide
how a player performs a note or phrase.
In Dorico, expressive text, such as “sim.”, poco, molto, or subito, must accompany a dynamic level,
such as  or .
NOTE
You cannot input expressive text on its own. However, you can hide the immediate dynamic that
follows/precedes it.
You can input expressive text by entering it into the dynamics popover alongside an immediate
dynamic or by clicking available options in the Immediate Dynamics section of the Dynamics
panel. You can also add it to existing dynamics by entering the expressive text you want into one
of the following properties in the Dynamics group of the Properties panel:
●

Prefix adds expressive text before existing dynamics.

●

Suffix adds expressive text after existing dynamics.

RELATED LINKS
Hiding immediate dynamics on page 483
Adding expressive text to existing dynamics on page 482

Adding expressive text to existing dynamics
You can add expressive text to dynamics after they have been input, for example, if you want to
add “sim.” instead of repeating dynamics across multiple phrases.
PROCEDURE
1.

Select the dynamics to which you want to add expressive text. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Dynamics group:
●

Prefix adds expressive text before the existing dynamic.

●

Suffix adds expressive text after the existing dynamic.

3.

Enter the expressive text you want to add into the corresponding value field.

4.

Save your text in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The text you entered is added to the selected dynamics as expressive text.
Deactivating the properties removes the corresponding expressive text from the selected
dynamics.
NOTE
Deactivating properties permanently deletes any custom text entered.

RELATED LINKS
Niente hairpins on page 480
Inputting dynamics with the popover on page 164

482

Dynamics
Gradual dynamics
Inputting dynamics with the panel on page 166

Hiding immediate dynamics
You can hide immediate dynamics such as  and , for example, if you only want to show an
expressive text, such as “sim.”, without the immediate dynamic that accompanies it.
PROCEDURE
1.

Select the immediate dynamics you want to hide. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Hide intensity marking in the Dynamics group.

RESULT
The selected immediate dynamics are hidden. If no other dynamic exists at their rhythmic
position, they are indicated by signposts so you can always find them again. However, signposts
are not printed by default.
Deactivating Hide intensity marking shows the selected immediate dynamics again.
RELATED LINKS
Adding expressive text to existing dynamics on page 482

Gradual dynamics
Gradual dynamics indicate a change in volume that happens incrementally over the specified
duration. By default, gradual dynamics appear either as hairpins or as text instructions, such as
cresc. or dim..
You can change the appearance and placement of gradual dynamics individually, independently
of your project-wide settings, using properties in the Dynamics group of the Properties panel.
For example, you can change the type of gradual dynamics so that they are shown as a hairpin
with a single direction or as a messa di voce pair of hairpins with two directions.
You can change the style of gradual dynamics to show them in any of the following ways:
Hairpin

cresc./dim.

cresc….

cre-scen-do

TIP
You can also change the line style of hairpins using Hairpin line style in the Dynamics group of
the Properties panel.
If you enter two or more consecutive hairpins of the same direction separated by immediate
dynamics into the dynamics popover, you can show them as a single, continuous hairpin across
the immediate dynamics by activating Hairpin shown as continuation and the corresponding
checkbox in the Dynamics group of the Properties panel in Engrave mode.

Hairpin shown as continuation

Hairpin not shown as continuation
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You can also change the style of diminuendo text of gradual dynamics using the cresc./dim.
style, and you can change the continuation line style of gradual dynamics using the cresc…. style.
In Engrave mode, hairpins have three square handles at the start/end:
●

The middle handles at the start/end change the offset position of the start/end of the
hairpin.

●

The pair of outer handles at the start/end adjusts the aperture of the start/end of the
hairpin.

A hairpin with the start middle handle selected in Engrave mode

You can use these handles to change the angle of hairpins.
RELATED LINKS
Types of dynamics on page 476
Changing the angle of hairpins on page 485
Changing the aperture of hairpins on page 486

Lengthening/Shortening gradual dynamics and groups of dynamics
You can change the length of gradual dynamics and groups of dynamics after they have been
input.
NOTE
You can only lengthen/shorten one gradual dynamic or group of dynamics at a time.

PROCEDURE
1.

2.

In Write mode, select one of the following that you want to lengthen/shorten:
●

A single gradual dynamic

●

A single gradual dynamic in a group of dynamics

Lengthen/Shorten the gradual dynamic or groups of dynamics in any of the following
ways:
●

Press Shift-Alt-Right Arrow to lengthen them by the current rhythmic grid value or
to the next notehead, whichever is closer.

●

Press Shift-Alt-Left Arrow to shorten them by the current rhythmic grid value or to
the previous notehead, whichever is closer.

●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to lengthen them to the next notehead.

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to shorten them to the previous notehead.
NOTE
When using the keyboard, you can only move the end of dynamics. You can move
the start of dynamics by moving the whole dynamic, or by clicking and dragging the
start handle.

●

Click and drag the circular handle at the start/end.

RESULT
Individual gradual dynamics are lengthened/shortened either according to the rhythmic grid or
to next/previous noteheads.

484

Dynamics
Gradual dynamics
Dynamic groups are lengthened/shortened proportionally by lengthening/shortening the
gradual dynamics and moving any other type of dynamic in the group. This retains the relative
durations of the gradual dynamics in the group.
In the example, the  at the end moves two quarter notes to the right, but the  in the middle
only moves one quarter note to the right. This keeps the lengths of the gradual dynamics equal.
EXAMPLE

Original dynamic phrase

Lengthened dynamic phrase

RELATED LINKS
Groups of dynamics on page 493
Positions of dynamics on page 490
Ungrouping dynamics and removing dynamics from groups on page 494

Changing the angle of hairpins
By default, hairpins are horizontal and are automatically adjusted to avoid collisions with other
objects, such as noteheads and slurs. You can change the angle of individual hairpins as required
for your music.
NOTE
Changing only the start offset position with the keyboard or activating Start offset only changes
the position of the hairpin relative to the staff, not its angle. You must change the end offset
position or activate End offset as well to change the angle of hairpins.
Dragging handles with the mouse changes the angle straight away.

PROCEDURE
1.

In Engrave mode, select the middle handles of the hairpins whose angle you want to
change.
TIP

2.

●

The hairpins you select do not have to be the same direction, or on the same staff.

●

You can show handles on all items, not just selected items, by choosing Engrave >
Show Handles > Always. This can make it easier to select individual handles on
multiple items.

Move the handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●

Click and drag them upwards/downwards.
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RESULT
The angle of the selected hairpins is changed. Each end can be moved independently of the
other.
TIP
The following properties in the Dynamics group of the Properties panel are activated
automatically when you move the corresponding handles on hairpins vertically:
●

Start offset Y moves the start handles of hairpins vertically.

●

End offset Y moves the end handles of hairpins vertically.

For example, if you move a whole hairpin upwards, both handles are moved so both properties
are activated. You can also use these properties to change the angles of hairpins by changing the
values in the value fields.
Deactivating the properties resets the selected hairpins to their default positions.

Changing the aperture of hairpins
The change in volume indicated by individual hairpins is shown in the distance between the two
lines that make up hairpins at their apertures. You can change the aperture of hairpins
individually.
Hairpins typically have a closed end and an open end. If the hairpin crosses a system or frame
break, the closed end can appear with a small gap so that the hairpin is not misread as two
separate hairpins.
In Dorico, you can use the pair of outer handles at the start/end of hairpins in Engrave mode to
change the aperture. These handles are linked and mirror each other: moving one handle also
moves the other handle by the same amount, but in the opposite direction. This ensures that
hairpins remain symmetrical.

A hairpin with the outer handle selected in Engrave mode

PROCEDURE
1.

In Engrave mode, select one of the outer handles of the hairpins whose aperture you want
to change.
TIP

2.

●

The hairpins you select do not have to be the same direction, or on the same staff.

●

You can show handles on all items, not just selected items, by choosing Engrave >
Show Handles > Always. This can make it easier to select individual handles on
multiple items.

Change the distance between the handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.
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●

Click and drag them upwards/downwards.

RESULT
The apertures of the selected hairpins are changed.
TIP
●

You can also change the aperture of individual hairpins by activating Hairpin open
aperture and/or Hairpin closed aperture in the Dynamics group of the Properties panel.
Increasing the value makes the corresponding aperture wider. Decreasing the value
makes the corresponding aperture narrower.

●

You can find options to set minimum and maximum values for the width of hairpin
apertures project-wide, including for hairpins across system and page breaks, by clicking
Advanced Options in the Hairpins subsection of the Gradual Dynamics section of the
Dynamics page in Engrave > Engraving Options.

EXAMPLE

A diminuendo that goes across a system break:
aperture at the start is open, aperture at the end is
closed. It appears slightly open to indicate the
diminuendo continues after the system break.

The diminuendo continues onto a new system:
aperture at the start is open, aperture at the end is
closed.

Adding poco a poco text to gradual dynamics
You can add poco a poco text to individual gradual dynamics after they have been input.
PROCEDURE
1.

Select the gradual dynamics to which you want to add poco a poco. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Poco a poco (little by little) in the Dynamics group.

RESULT
Poco a poco is shown immediately after gradual dynamic text, below hairpins placed below the
staff, and above hairpins placed above the staff.
Deactivating Poco a poco (little by little) removes poco a poco text from the selected gradual
dynamics.
EXAMPLE

Text gradual dynamic with poco a poco

Hairpin gradual dynamic with poco a poco
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Gradual dynamic spacing
Dorico ensures that hairpins can always be clearly distinguished by giving hairpins a minimum
default length. However, this can affect note spacing.
The default minimum hairpin length is three spaces. When hairpins are shorter than this, they
can sometimes be confused with the accent articulation mark. Therefore, if you add a hairpin to a
note which would make the hairpin less than three spaces long, the spacing of the note is
changed to ensure the hairpin meets the minimum length.
You can change the minimum length of hairpins by changing the value for Minimum length for
hairpins, which you can find by clicking Advanced Options in the Hairpins subsection of the
Gradual Dynamics section of the Dynamics page in Engrave > Engraving Options.

Gradual dynamics that start/end partway through notes
If the start/end of a gradual dynamic is not attached to a note, there are restrictions on how you
can move the start/end position.
For example, if you enter two hairpins separated by a space into the dynamics popover, pair of
hairpins that looks like a messa di voce is created but containing two separate hairpins, rather
than the combined option. Neither of the open ends of the hairpins is attached to a specific
notehead, and you cannot move the center of the pair of hairpins rhythmically. You can
lengthen/shorten the two hairpins as a group but you cannot lengthen/shorten each hairpin
individually.

However, if you enter two hairpins without a space between them into the dynamics popover,
you can move the center of the pair of hairpins and each hairpin rhythmically, but only to
noteheads. You can lengthen/shorten each hairpin separately according to the current rhythmic
grid value.
You can move individual hairpins in Engrave mode to any graphical position. If you input hairpins
separated by a space into the popover, you can move each hairpin independently, for example, if
you want to adjust the graphical peak of the pair of hairpins. You cannot move the graphical
peak of messa di voce hairpins, except by adjusting the note spacing. However, moving dynamics
graphically does not affect dynamics in playback.
RELATED LINKS
Lengthening/Shortening gradual dynamics and groups of dynamics on page 484
Moving dynamics graphically on page 492
Note spacing on page 284
Adjusting note spacing at individual rhythmic positions on page 291

Gradual dynamics truncated by immediate dynamics
A hairpin is automatically truncated if an immediate dynamic is positioned within its range, either
before or after the hairpin is input.
The hairpin remains tied to its originally designated rhythmic positions, even if graphically it
appears shorter. This means that if the immediate dynamic that truncated it is ever deleted, the
hairpin extends up to its end or the next immediate dynamic within its range.
The examples demonstrate a crescendo hairpin that is truncated by two dynamics, but the
hairpin extends to its total length as they are deleted. The dotted guideline shows the link
between the hairpin and the rhythmic position to which its end is attached.
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A long hairpin truncated by a p

After deleting the p, the hairpin is
now truncated by the f

Deleting both immediate
dynamics allows the hairpin to
extend to its full length

RELATED LINKS
Lengthening/Shortening gradual dynamics and groups of dynamics on page 484

Placement of dynamics
Default settings for the vertical placement of dynamics and their placement relative to the staff in
Dorico are designed to ensure that dynamics are clear and legible and follow general placement
conventions.
The placement of dynamics relative to the staff varies, depending on their function and the type
of player. For example, dynamics are placed below instrumental staves and above vocal staves by
default. This ensures dynamics are kept as close to the staff as possible for legibility but are not
placed between noteheads and lyrics on vocal staves. For grand staff instruments, such as piano
or harp, dynamics are usually placed between the two staves, but can be placed both above and
below when each staff requires separate dynamics.
In general, dynamics are not placed within the staff, as hairpins in particular become very hard to
read. They are also not usually placed within tuplet brackets.
Dynamics are placed outside of notations such as slurs, which must be kept close to noteheads,
but inside pedal lines, which can be placed further from noteheads and still be clearly
understood.
You can change how far above/below staves dynamics are placed on the Dynamics page in
Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for dynamics on page 496

Changing the placement of dynamics relative to the staff
By default, dynamics are placed below the staff for instruments and above the staff for voices.
In some circumstances, however, it is necessary to change the placement of individual dynamics
relative to the staff. For example, you can have different dynamics above and below the staff in
multiple-voice contexts.
PROCEDURE
1.

Select the dynamics whose placement relative to the staff you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Placement in the Dynamics group.

3.

Choose one of the following options:
●

Above

●

Below

RESULT
The placement of the selected dynamics is changed.
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Positions of dynamics
You can change the positions of dynamics individually and their default positions project-wide.
For example, you can override the default position of individual dynamics if you want to spread a
dynamic phrase out wider so each dynamic is more legible.
You can move dynamics to different rhythmic positions in Write mode. They snap to noteheads
and are positioned by default according to your settings in Engraving Options.
You can move dynamics graphically in Engrave mode, however, this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all dynamics project-wide, and their horizontal positions
relative to beats, barlines, and system ends on the Dynamics page in Engrave > Engraving
Options.
RELATED LINKS
Project-wide engraving options for dynamics on page 496
Moving dynamics rhythmically on page 491
Moving dynamics graphically on page 492

Changing the horizontal beat-relative position of dynamics
You can position individual dynamics before or after the beat.
PROCEDURE
1.

Select the dynamics whose position relative to the beat you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Beat-relative position in the Dynamics group.

3.

Choose one of the following options:
●

Before

●

After

EXAMPLE

A dynamic positioned before the beat

A dynamic positioned after the beat

Changing the alignment of immediate dynamics relative to
noteheads
Immediate dynamics, such as  and , are usually horizontally aligned with the optical center
of noteheads. However, you can change the horizontal alignment of immediate dynamics
individually, independently of your project-wide setting.
PROCEDURE
1.

Select the dynamics whose alignment relative to noteheads you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Text alignment in the Dynamics group.
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3.

Choose one of the following options:
●

Align optical center with notehead

●

Left-align with notehead

●

Align optical center with left of notehead

RESULT
The alignment of the selected immediate dynamics is changed.
TIP
You can change the default alignment of all immediate dynamics relative to noteheads projectwide in the Horizontal Position section of the Dynamics page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for dynamics on page 496

Moving dynamics rhythmically
You can move dynamics to new rhythmic positions after they have been input.
NOTE
●

You can only move dynamics to existing noteheads.

●

If you want to move a single dynamic within a group, you must click and drag it with the
mouse. If you use the key commands, the whole group is moved.

PROCEDURE
1.

In Write mode, select the dynamics you want to move.
NOTE
When using the mouse, you can only move one dynamic rhythmically at a time.

2.

Move the dynamics to the next/previous notehead on the staff in any of the following
ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the dynamic to the right/left.

RESULT
The selected dynamics are moved to noteheads to the right/left along the staff.
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Moving dynamics graphically
You can move dynamics graphically, without changing the rhythmic positions to which they
apply. When you select hairpins in Engrave mode, three adjustment handles appear at each end.
You can use these handles to lengthen/shorten gradual dynamics graphically.
PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Immediate dynamics or whole gradual dynamics

●

Individual handles on gradual dynamics

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the dynamics or handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The selected dynamics or handles are moved graphically, without affecting the rhythmic
positions to which they are attached.
TIP
The following properties in the Dynamics group of the Properties panel are activated
automatically when you move dynamics in the corresponding directions:
●

Start offset moves immediate dynamics and the start of gradual dynamics. X moves them
horizontally, Y moves them vertically.

●

End offset moves the end of gradual dynamics. X moves them horizontally, Y moves them
vertically.

For example, if you move a whole gradual dynamic upwards, both handles are moved so both
properties are activated. You can also use these properties to move dynamics graphically by
changing the values in the value fields.
Deactivating the properties resets the selected dynamics to their default positions.

RELATED LINKS
Lengthening/Shortening gradual dynamics and groups of dynamics on page 484
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Groups of dynamics
When dynamics are grouped together, they are automatically aligned in a row and can be moved
and edited as a group. For example, you can move the  in the middle of the example within the
group, and the hairpins either side automatically adjust to compensate.
A single dynamic, either immediate or gradual, is considered a group on its own.
Two or more dynamics are automatically grouped together if they immediately follow each other
horizontally on the staff, were input together or in sequence, and have gradual dynamics
between the immediate dynamics.

A group of dynamics

The same group of dynamics adjusts to compensate
when the f moves position.

All of the dynamics in a group are highlighted when any of the dynamics in the group are
selected.

As well as horizontal groups of dynamics, you can also link groups of dynamics across staves if
you want the same dynamics to appear on multiple staves. This can be useful when multiple
instruments play the same dynamics simultaneously and you want to make the same change in
all staves, for example, moving the peak of a crescendo to a later beat, or changing a  to a .
RELATED LINKS
Dynamics linked across multiple staves on page 494

Grouping dynamics together
You can manually group dynamics together that were not automatically grouped when they were
input. Grouped dynamics are automatically aligned in a row and can be moved and edited as a
group.
PROCEDURE
1.

In Write mode, select the dynamics you want to group together.

2.

Choose Edit > Dynamics > Group Dynamics. You can also choose this option from the
context menu.

RESULT
The selected dynamics are grouped together. If the first dynamic in the group is linked to other
staves, all dynamics in the group are added to those staves.
RELATED LINKS
Groups of dynamics on page 493
Dynamics linked across multiple staves on page 494
Ungrouping dynamics and removing dynamics from groups on page 494
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Ungrouping dynamics and removing dynamics from groups
You can ungroup dynamics so that all dynamics in the group become ungrouped, and you can
remove only selected dynamics from groups while leaving dynamics that were not selected in the
group.
PROCEDURE
1.

In Write mode, select the dynamics you want to ungroup or remove from groups.

2.

Do one of the following:
●

Choose Edit > Dynamics > Ungroup Dynamics.

●

Choose Edit > Dynamics > Remove from Group.

TIP
You can also choose these options from the context menu.

RESULT
If you ungroup dynamics, all dynamics in the group are ungrouped. This includes dynamics in
the group that were not included in your selection.
If you remove dynamics from groups, only the selected dynamics are removed from their groups.
Any unselected dynamics in the group remain grouped.

Dynamics linked across multiple staves
Identical dynamics at the same rhythmic position on multiple staves are linked together
automatically when you copy and paste dynamics between staves.
If you select one dynamic in a linked group, all other dynamics in the linked group appear
highlighted. If one linked dynamic is moved to a new rhythmic position, all linked dynamics
move.

Two linked dynamics with only the top dynamic
selected

Moving just the top dynamic of the linked group
automatically moves the other to match its new
position.

Similarly, if you change one linked dynamic, for example, from  to , all dynamics linked to the
changed dynamic are also changed.
If you group other dynamics to one of the linked dynamics, such as a hairpin, the hairpin is
added at the same position in all linked staves.
If one staff has another immediate dynamic before the end of a hairpin, the hairpin is truncated
automatically. If you delete such a dynamic, the hairpin extends automatically up to the next
immediate dynamic or to its full length, whichever comes first.
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Three linked dynamics, where a hairpin added to the
top staff and grouped with the dynamics on that
staff has been automatically added to the staves
below.

Deleting the f at the end of the first bar in the third
staff causes the hairpin to extend to match the range
of the top staff.

IMPORTANT
Deleting one dynamic that is linked to other dynamics also deletes all the linked dynamics.
As well as vertically linked dynamics, you can also group dynamics horizontally. This
automatically aligns the dynamics in a row and allows them to be moved and edited as a group.
RELATED LINKS
Groups of dynamics on page 493
Linking dynamics together on page 495
Unlinking dynamics on page 496

Linking dynamics together
When you copy and paste identical dynamics to the same rhythmic position on other staves,
those dynamics are linked together automatically. You can also manually link dynamics and
groups of dynamics together that are not automatically linked to allow simultaneous editing.
However, the groups of dynamics must be the same in order to link them together. For example,
you can link two  dynamics together if neither is part of a group, but you cannot link them
together if one is grouped with a hairpin.
PROCEDURE
1.

In Write mode, select the dynamics you want to link together.

2.

Choose Edit > Dynamics > Link. You can also choose this option from the context menu.

RESULT
The selected dynamics are linked together. If you later change one of the linked dynamics, all
linked dynamics are changed to match.
RELATED LINKS
Dynamics linked across multiple staves on page 494
Copying dynamics on page 479
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Unlinking dynamics
You can unlink dynamics, including dynamics that were linked automatically.
PROCEDURE
1.

In Write mode, select a dynamic in each linked group that you want to unlink.

2.

Choose Edit > Dynamics > Unlink. You can also choose this option from the context
menu.

RESULT
All dynamics in the linked groups are unlinked.
RELATED LINKS
Dynamics linked across multiple staves on page 494

Project-wide engraving options for dynamics
You can find options for the project-wide appearance and position of dynamics on the Dynamics
page in Engraving Options.
The options on the Dynamics page allow you to change the appearance of dynamics and
gradual dynamics, and their default positions relative to noteheads, barlines, and the ends of
systems.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Dynamics in the page list on the left of the dialog.

Dynamics font styles
You can change different aspects of the fonts used for dynamics in the Edit Font Styles dialog.
●

You can open the Edit Font Styles dialog in Engrave mode by choosing Engrave > Font
Styles.

The following fonts affect the appearance of dynamics:
●

Default Text Font: The parent font for all font styles in the project, including dynamic
modifiers.

●

Dynamic Music Text Font: Used for dynamic glyphs, such as  and .

●

Dynamic Text Font: Used for dynamic modifiers, including expressive text.

NOTE
Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Edit Font Styles dialog on page 275
Changing the dynamic modifier font styles on page 497
Changing the dynamic glyph font style on page 497
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Changing the dynamic modifier font styles
You can change two fonts that affect the appearance of dynamic modifiers. One font only affects
dynamic modifiers and the other affects the entire project.
The Default Text Font is the parent font for the whole project, so any changes you make to this
font affect all fonts that are linked to the font. This includes dynamic modifiers, but also many
other fonts.
The Dynamic Text Font is used for dynamic modifiers. Any changes you make to this font affect
all dynamic modifiers, including expressive text, but do not affect any other font style.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles.
The Edit Font Styles dialog opens.

2.

3.

Select one of the following fonts from the Font style menu:
●

Default Text Font

●

Dynamic Text Font

Activate the following options, individually or together, to change the corresponding
aspect of the font:
●

Font family

●

Size

●

Style

●

Underlined

4.

Optional: If required, repeat steps 2 and 3 to change the other font.

5.

Click OK to save your changes and close the dialog.

RESULT
The default font used for dynamic modifiers or all fonts in your project is changed.
RELATED LINKS
Dynamics font styles on page 496

Changing the dynamic glyph font style
You can change the font used for dynamic glyphs. However, only specific fonts are compatible.
Any font used for dynamic glyphs, such as  or , has to be SMuFL-compliant. SMuFL stands
for Standard Music Font Layout.
These fonts are specifically designed to map thousands of the different symbols required for
music notation onto a standard layout. Therefore, Dorico looks for a particular symbol in a
specific place within the font, and if a non-SMuFL font is used, Dorico cannot find the correct one.
SMuFL-compliant fonts include Bravura and November 2.0.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles.
The Edit Font Styles dialog opens.

2.

Select Dynamic Music Text Font from the Font style menu.

3.

Activate the following options, individually or together, to change the corresponding
aspect of the font:
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4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The font used for dynamic glyphs is changed project-wide.
RELATED LINKS
Dynamics font styles on page 496

Playback Options for dynamics
You can change settings for how dynamics are interpreted in playback by making adjustments to
the scale of the graphical curve on the Dynamics page in Playback Options.
You can open Playback Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-P in any mode.

●

Choose Play > Playback Options in Play mode.

You can then click Dynamics in the page list on the left of the dialog.

Dynamic Curve
The graph at the top of the Dynamics page in Playback Options maps a continuous curve. This
curve determines how the volume of dynamics increases across the range  to .
A dynamic curve power of 1 creates a straight line, producing a steady dynamic increase. The
difference between  and  is the same as between  and .
A dynamic curve power higher than 2 creates a curved line, producing a faster dynamic increase
in the middle of the range. The difference between  and  is much smaller than the
difference between  and .
The higher the dynamic curve power, the greater the contrast between dynamics in the middle of
the range, and the smaller the contrast between dynamics at the ends of the range.
If your project uses a wide range of dynamics, including dynamics such as  and , you
might want a lower curve power with larger differences between the extremes of the range.
If your project has a smaller range of dynamics, such as a minimum of  to a maximum of ,
you might prefer a higher curve power, so the differences between the dynamics in the middle of
the range are more discernible.
NOTE
Changing the dynamic curve affects the playback of all instruments in the project.

Note Dynamics
In the Note Dynamics section of the Dynamics page, you can set how much the volume of notes
in playback is affected by stresses and articulation marks.

Humanize
Humanize allows dynamics to vary randomly by the degree you set to mimic the natural
fluctuations in a live performance.
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Sustaining and non-sustaining instruments
The volume settings for sustaining instruments and non-sustaining instruments vary in terms of
their control of gradual dynamics.
You can control settings for each software instrument by choosing Play > Expression Maps and
selecting software instruments from the list on the left.

Sustaining instruments
Sustaining instruments include string, wind, and brass instruments, because they can hold a
note while being in control of its volume throughout.
Dorico applies gradual dynamics to these instruments in playback. You can control settings for
each software instrument by choosing Play > Expression Maps and selecting software
instruments from the list on the left.

Non-sustaining instruments
Non-sustaining instruments, such as piano, harp, marimba, and most percussion instruments,
have no further control of the dynamic of notes after they have been struck. For this reason, nonsustaining software instruments often use note velocity for dynamics, because this is set at the
start of the note.

VST Expression Maps for volume types
If you are using a third-party sound library, you may need to change or edit the expression map
to make instruments respond to gradual dynamics. Otherwise, the sound library uses velocity by
default.
The setup of the expression map for dynamics depends on how the instrument is configured.
Consult the documentation for the sound library for further information.
Dorico provides the following default expression maps:
●

CC11 Dynamics: dynamics produced by changing MIDI channel expression

●

Modulation Wheel Dynamics: dynamics produced by changing MIDI controller 1

You can edit expression maps in the Expression Maps dialog, which you can open by choosing
Play > Expression Maps.
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Fingerings can be added to music to recommend which fingers players should use for notes. This
can be useful for music aimed at players learning the instrument and for difficult musical
passages where certain fingering patterns make the notes much easier to play.
They are often used in keyboard music, as players can use all ten fingers to play notes, and in
guitar music, where fingerings are often used alongside fret positions. However, fingerings can
also be useful for other instruments, for example, to indicate that string players should change
the finger used to stop the string while holding the note, or to instruct wind players to use
uncommon fingerings for particular notes in order to create a special sonic effect.
Dorico also provides fingerings for brass instruments. For example, you can specify which valves
players should depress for instruments such as trumpet and horn, and you can specify the horn
branch you want players to use for double horns.
Fingerings in Dorico use a bold roman font by default, following accepted conventions for the
appearance of fingerings. You can change the font used for fingerings project-wide on the
Fingering page in Engrave > Engraving Options.
RELATED LINKS
Inputting fingerings on page 142
Fingerings popover on page 143
Changing the font used for fingerings project-wide on page 507

General placement conventions for fingering
Fingerings are placed as close as possible to the notes to which they apply, so the performer can
read them easily and clearly.
In music for grand staff instruments, such as the piano and harp, it is accepted to place
fingerings for the right hand above the top staff, and fingerings for the left hand below the
bottom staff. However, in dense contrapuntal music for these instruments, fingerings can be
placed between the staves to follow the direction of the voices to which they apply.

Changing fingerings to substitution fingerings
Substitution fingerings indicate where players should change the finger used for the note. You
can change existing fingerings to substitution fingerings.
PROCEDURE
1.

Select the fingerings you want to change to substitution fingerings. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Substitution in the Fingering and Positions group.

3.

Enter the fingering you want for the substitution into the value field.

4.

Save your change in any of the following ways:
●

Press Return.
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●

Click outside of the value field.

RESULT
The selected fingerings are now shown as substitution fingerings. The deferred position of the
substitution is the same as the original fingering by default, but you can change the rhythmic
position of substitution fingerings.
RELATED LINKS
Changing the rhythmic position of substitution fingerings on page 501

Changing the rhythmic position of substitution fingerings
Substitution fingerings are shown as immediate by default, meaning that the substitution takes
place on the same note, but you can change the rhythmic position at which individual
substitutions take place.
PROCEDURE
1.

Select the substitution fingering whose deferred rhythmic position you want to change.
You can do this in Write mode and Engrave mode.

2.

Change the rhythmic position of the substitution fingering in any of the following ways:
●

In Write mode, click and drag the circular handle to the right/left.

●

In Write mode and Engrave mode, activate Substitution offset in the Fingering
and Positions group of the Properties panel.
Change the rhythmic position of substitutions as fractions of a quarter note
(crotchet) by entering a value into the left value field, or by clicking the arrows
beside the value field. Increasing the value moves substitutions to later positions,
decreasing the value moves them to earlier positions.
NOTE
The right value field is for the grace note position at which substitutions occur, if
applicable.

RESULT
The rhythmic position of the substitution fingering is changed.
Dorico automatically arranges deferred substitutions so they are ordered appropriately
alongside any fingerings that coincide with the substitution.
NOTE
You can only change the position of single substitution fingerings when dragging their handles
with the mouse. However, you can change the positions of multiple substitution fingerings with
Substitution offset in the Fingering and Positions group of the Properties panel.
Deferred substitutions are always shown with horizontal lines, even if you have chosen to show
immediate substitutions with slurs.

RELATED LINKS
Fingerings popover on page 143
Project-wide engraving options for fingerings on page 505
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Changing existing fingerings
You can change existing fingerings using the Properties panel. Alternatively, you can replace
existing fingerings using the fingerings popover in the same way as adding new fingerings.
PROCEDURE
1.

Select the fingerings you want to change. You can do this in Write mode and Engrave
mode.

2.

In the Properties panel, enter the new fingering you want into the Finger or position
value field in the Fingering and Positions group.

3.

Save your change in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The selected fingerings are changed.
RELATED LINKS
Inputting fingerings on page 142

Moving fingerings graphically
You can move fingerings graphically, independently of the noteheads to which they apply.
NOTE
You cannot move fingerings to different rhythmic positions as they are intrinsic parts of notes. If
you want to move fingerings to other noteheads, you must delete the existing fingerings and reinput them on the noteheads to which you wanted to move them.

PROCEDURE
1.

In Engrave mode, select the fingerings you want to move graphically.

2.

Move the fingerings in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The fingerings are moved to new graphical positions.
TIP
Offset in the Fingering and Positions group of the Properties panel is activated automatically
when you move fingerings.
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●

Offset X moves fingerings horizontally.

●

Offset Y moves fingerings vertically.

You can also use this property to move fingerings by changing the values in the value fields.
Deactivating the property resets the selected fingerings to their default positions.

RELATED LINKS
Resetting the positions of fingerings on page 503

Resetting the positions of fingerings
You can reset the positions of individual fingerings whose graphical positions you have moved.
PROCEDURE
1.

In Engrave mode, select the fingerings whose positions you want to reset.

2.

Reset their positions in any of the following ways:
●

Choose Edit > Reset Position.

●

In the Properties panel, deactivate Offset in the Fingering and Positions group.

Changing the placement of fingerings relative to the staff
Dorico automatically follows conventions for fingering placement, but you can change the
placement of fingerings relative to the staff individually, independently of your project-wide
setting.
According to conventions, keyboard instrument fingering is positioned above the right-hand
staff, and below the left-hand staff. String and brass instrument fingering is always positioned
above the staff.
PROCEDURE
1.

Select the fingerings whose position relative to the staff you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Staff-relative position in the Fingering and Positions
group.

3.

Choose one of the following options:
●

Above

●

Below

RESULT
The selected fingerings appear above/below the staff.
TIP
You can change the placement of all fingerings relative to the staff project-wide to follow voice
directions on the Fingering page in Engrave > Engraving Options.
This can be useful in complex contrapuntal music where fingering may not be clear if it is only
placed above the top staff and below the bottom staff.

RELATED LINKS
Project-wide engraving options for fingerings on page 505

503

Fingering
Hiding/Showing fingering

Changing the position of individual fingerings relative to slurs,
octave lines, and tuplet brackets
By default, fingerings are positioned inside the arcs of slurs, but outside the start/end of slurs.
You can change the position of fingerings relative to individual slurs, independently of your
project-wide settings.
PROCEDURE
1.

In Engrave mode, select the fingerings whose position relative to slurs you want to
change.

2.

In the Properties panel, activate Slur-relative position in the Fingering and Positions
group.

3.

Choose one of the following options:
●

Inside

●

Outside

RESULT
The position of the selected fingerings relative to slurs, octave lines, and tuplet brackets is
changed.
NOTE
If fingerings also coincide with the first note or last note of slurs, fingerings are positioned
outside all of these notations.
TIP
You can change the position of all fingerings relative to slurs, octave lines, and tuplet brackets
project-wide on the Fingering page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for fingerings on page 505

Hiding/Showing fingering
You can hide/show fingering in each layout in your project independently of other layouts. For
example, you can show fingering in part layouts but hide fingering in full score layouts as
conductors rarely require fingering information.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to hide/show fingering in one of
the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.
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By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Players from the Category menu.

4.

In the Fingering section, activate/deactivate Show fingering.

RESULT
All fingerings in the selected layouts are shown when the checkbox is activated, and hidden when
the checkbox is deactivated.

Deleting fingerings
You can remove fingerings from notes after you have input them. However, because fingerings
are considered an intrinsic part of notes rather than a separate item, you cannot select and
delete them as you would for other items.
PROCEDURE
1.

2.

Select the fingerings you want to remove in any of the following ways:
●

In Write mode, Ctrl/Cmd-click or Shift-click the notes to which the fingerings apply.

●

In Engrave mode, Ctrl/Cmd-click fingerings.

●

In Write mode, make a marquee selection and choose Edit > Filter > Notes and
Chords.

In the Properties panel, deactivate Finger or position in the Fingering and Positions
group.

RESULT
All fingerings are removed from the selected notes.

Project-wide engraving options for fingerings
You can find options for the project-wide appearance and position of fingerings on the Fingering
page in Engraving Options.
The options on the Fingering page allow you to change the font, size, appearance, placement,
and precise position of fingerings on standard notes and grace notes, including fine adjustments
for the different instrument groups. You can also change the position of fingerings relative to
slurs, octave lines, and tuplets.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Fingering in the page list on the left of the dialog.

Changing the appearance of cautionary fingerings project-wide
Cautionary fingerings remind players that fingerings specified at previous rhythmic positions
continue to apply to notes that are still sounding. Dorico automatically shows cautionary
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fingerings when you add other fingerings at rhythmic positions where notes with existing
fingerings are still sounding.
By default, cautionary fingerings are shown enclosed in parentheses. You can choose to show
cautionary fingerings without parentheses or not to show cautionary fingerings at all projectwide.

Cautionary fingering shown in parentheses (default)

NOTE
You cannot change the appearance of cautionary fingerings individually.

PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Fingering in the page list.

3.

In the Alternative, Editorial and Cautionary section, choose one of the following options
for Cautionary fingering appearance:

4.

●

Do not show

●

Show fingering only

●

Show fingering in parentheses

Click Apply, then Close.

RESULT
The appearance of cautionary fingerings is changed project-wide.

Changing the appearance of slide positions for brass instruments
You can use Arabic or Roman numerals to indicate slide positions for slide brass instruments,
such as trombones. By default, Dorico uses Arabic numerals for slide positions.
NOTE
You must enter slide positions using Arabic numerals into the fingerings popover, even if you
have chosen to show slide positions with Roman numerals in your project.

PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Fingering in the page list.

3.

In the Brass section, choose one of the following options for Trombone slide position
appearance:
●

Arabic numerals

●

Roman numerals
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4.

Click Apply, then Close.

RESULT
The numeral style used for slide positions on slide brass instruments is changed project-wide.
RELATED LINKS
Inputting fingerings on page 142

Fingering font styles
Bold and plain fingerings use different fonts. You can change different aspects of the font styles
used for fingering in the Edit Font Styles dialog.
●

You can open the Edit Font Styles dialog in Engrave mode by choosing Engrave > Font
Styles.

The following fonts are used for fingering:
●

Fingering Font: Used for bold fingerings.

●

Fingering Text Font: Used for plain fingerings.

●

Fingering Text Italic Font: Used for italic fingerings.

●

Fingering Horn Branch Accidental Font

●

Fingering Horn Branch Alto Text Font

●

Fingering Horn Branch Text Font

NOTE
Changes made to font styles apply to the entire project, including part layouts.

RELATED LINKS
Edit Font Styles dialog on page 275
Project-wide engraving options for fingerings on page 505
Changing the fingering font styles on page 508
Changing the font used for fingerings project-wide on page 507

Changing the font used for fingerings project-wide
By default, fingerings are drawn in a bold, Arabic font that is similar in appearance to the digits in
time signatures.
You can change the font used for fingerings project-wide on the Fingering page in Engraving
Options. This changes the font style used to draw fingering numbers, parentheses, and brackets.
NOTE
The font used for thumb indicator, substitution lines and slurs, and brass valve separators is not
changed.

PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Fingering in the page list.

3.

In the Design section, choose one of the following options for Fingering appearance:
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4.

●

Bold font

●

Plain font

Click Apply, then Close.

RESULT
The font style used for fingerings project-wide is changed.
NOTE
You can change different aspects of the font style used in the Edit Font Styles dialog.
Bold fingerings use Fingering Font. Plain fingerings use Fingering Text Font.

RELATED LINKS
Changing the fingering font styles on page 508

Changing the fingering font styles
You can change the font styles used for all fingerings project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles.
The Edit Font Styles dialog opens.

2.

3.

Select the fingering font style you want to change from the Font style menu:
●

Fingering Font

●

Fingering Text Font

●

Fingering Text Italic Font

●

Fingering Horn Branch Accidental Font

●

Fingering Horn Branch Alto Text Font

●

Fingering Horn Branch Text Font

Activate the following options, individually or together, to change the corresponding
aspect of the font:
●

Font family

●

Size

●

Style

●

Underlined

4.

Optional: Repeat steps 2 and 3 for any other font style you want to change.

5.

Click OK to save your changes and close the dialog.

RESULT
The selected fingering font styles are changed project-wide.
RELATED LINKS
Fingering font styles on page 507
Project-wide engraving options for fingerings on page 505
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Showing individual fingerings in italics
Fingerings are normally shown in a bold, non-italic font, but you can show individual fingerings in
italics.
PROCEDURE
1.

In Engrave mode, select the fingerings you want to show in italics.

2.

In the Properties panel, activate Italic in the Fingering and Positions group.

RESULT
The selected fingerings are shown in a bold italic font if your project-wide setting for fingerings is
a bold font, and in a plain italic font if your project-wide setting for fingerings is a plain font.
NOTE
Bold italic fingerings look very similar to tuplet numbers, which can be confusing.

Fingerings for valved brass instruments
For instruments like trumpet and horn, fingering is used to show which valves must be
depressed to produce a specific note.
You can enter fingerings for valved brass instruments into the fingerings popover as numbers
without any separation. For example, enter 12 for a C♯ on a trumpet to indicate that the first two
valves must be depressed.
By default, Dorico automatically stacks fingerings added to notes on brass instrument staves
vertically. They are shown with no separator by default.
You can change the appearance of fingerings for valved brass instruments in the Brass section of
the Fingering page in Engrave > Engraving Options.
For example, you can show fingerings for valved brass instruments in a single row or stacked
vertically. You can also change the appearance of the separator or show no separator.
RELATED LINKS
Fingerings popover on page 143
Inputting fingerings on page 142

Showing horn branch indicators
You can indicate the branch on which notes are played for double horns and triple horns by
adding branch indicators as prefixes to horn fingerings. Some publications simply indicate “T” for
thumb, while others more explicitly indicate which branch is to be used by specifying its pitch.
NOTE
You can only add branch indicators to notes belonging to horns in F.

PROCEDURE
1.

Select the horn fingerings to which you want to add branch indicators. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Horn branch in the Fingering and Positions group.

3.

Select one of the following horn branches from the menu:
●

F
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●

B flat

●

F alto

●

E flat alto

●

Thumb trigger

RESULT
Branch indicators are added to the selected fingerings.
TIP
You can change the appearance of branch indicators in the Brass section of the Fingering page
in Engrave > Engraving Options.

RELATED LINKS
Inputting fingerings on page 142
Project-wide engraving options for fingerings on page 505

Hiding/Showing fingering shifts for string instruments
An angled line can be used to indicate the direction of movement when string players must shift
their finger position on the fingerboard to play a higher/lower note with the same finger as the
previous note.
NOTE
Shift indicators are shown whether the notes at each end have explicit fingerings or not.

PROCEDURE
1.

Select the notes or fingerings on string instrument staves from which you want to indicate
a fingering shift. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Indicate shift to next note in the Fingering
and Positions group.

RESULT
Shift indicators are shown when the property is activated, and hidden when the property is
deactivated.
Shift indicators are positioned between the selected notes and the notes that immediately follow
them.
TIP
You can change the length, thickness, angle, and placement of shift indicators in the String
Fingering Shifts section of the Fingering page in Engrave > Engraving Options.

RELATED LINKS
Specifying on which string individual notes are played on page 581
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Changing the direction of string fingering shift indicators
You can change the direction of individual string fingering shift indicators if they do not point in
the direction required.
PROCEDURE
1.

Select the shift indicators whose direction you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Shift direction in the Fingering and Positions group.

3.

Choose one of the following options:
●

Up

●

Down

RESULT
The selected shift indicators are angled up/down.
NOTE
You can also affect the direction of string shift indicators by specifying the strings on which notes
are played.

RELATED LINKS
Specifying on which string individual notes are played on page 581

Fingerings imported from MusicXML files
Dorico imports fingerings that are specified using the fingering element in MusicXML files.
MusicXML files exported from Finale typically represent fingerings in the correct way. However,
because Sibelius does not use the fingering element, Dorico cannot import fingerings from
MusicXML files exported by Sibelius.
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Front matter in Dorico is a broad term that covers all information included before the first bar of
music in scores.
Front matter includes musical information often added on pages before the first pages of scores,
such as:
●

Performance instructions

●

Contents

●

Instrumentation list

Front matter also includes information above the music on the first page of scores and parts,
such as:
●

Dedications

●

Titles

●

Subtitles

●

Composers

All information in your project that is not the music must be added within frames, which you can
input and edit in Engrave mode.

Master pages in Engrave mode
Master pages in Dorico allow the same formatting to be applied to different pages in different
layouts.
You can customize the default master pages and master page sets in your project. You can also
create new master pages based on existing master pages or create new master pages.

Master page sets in Engrave mode
Master page sets group master page formats together, so there is a master page for all possible
situations in your project. For example, if you are creating parts in a project that contains
multiple flows and you want to have two flows on a single page, you can create a master page
format that contains two text frames for flow titles and two music frames for the two flows. You
can then apply that master page only to pages in parts that can fit two flows on a single page.
RELATED LINKS
Master pages on page 230
Master page sets on page 231
Master page types on page 232
Paragraph Styles dialog on page 276
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Project information used in default master pages
An efficient way of ensuring all text information in the different layouts in your project is
consistent is to use tokens that link to information for the current project entered in the Project
Info dialog.
NOTE
Tokens are codes that refer to text elsewhere, meaning they are updated automatically if the
source text is changed.
The default master pages include tokens, so that any information you include for each flow in the
Project Info dialog is automatically shown. For example, the Default Full Score master page set
shows the following information for each flow:
●

Composer

●

Lyricist

●

Title

NOTE
These tokens are linked to the project information for each flow by default. If you only enter
information for Project in the Project Info dialog, no text is shown.

Multiple flows on a single page
If there are multiple music frames on a single page, the title at the top of the page is taken from
the flow in the music frame at the top of the page. For example, if you have Flow 1 followed by
Flow 2 on the same page, the title at the top is Flow 1.
If you want to specify the flow title at the top of the page, change the title token to, for example,
{@Flow2Title@}.
You can see the flow number of each flow in the Flows panel in Setup mode.
RELATED LINKS
Project Info dialog on page 62
Flow names and flow titles on page 89
Text tokens on page 254

Adding dedications in master pages
You can show dedications in multiple layouts by adding them to master pages. Dedications are
usually shown above titles in scores, use a smaller font size than titles, and are shown in italics.
PREREQUISITE
You have entered a dedication in one of the Dedication fields in the Project Info dialog.
TIP
In the Project Info dialog, you can enter different dedications for the whole project and for each
flow individually.
Optional: You have created a paragraph style for dedications in the Paragraph Styles dialog.
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PROCEDURE
1.

In Engrave mode, select the master page set containing the master page format to which
you want to add a dedication from the Current set menu in the Master Pages section of
the Pages panel.
For example, if you want to add a dedication above titles in full score layouts, select
Default Full Score.

2.

Double-click the master page to which you want to add a dedication. For example, if you
are using the default master pages, double-click First.
The master page editor opens.

3.

Open the text editor for the title text frame in any of the following ways:
●

Activate Frames in the Formatting panel, select the text frame, and press Return.

●

Double-click within the text frame.

4.

Position the cursor at the start of the title token.

5.

Press Return to input a new line above the title token.

6.

Enter one of the following tokens in the new line above the title token:
●

{@flowDedication@} shows the dedication for the flow.

●

{@projectDedication@} shows the dedication for the whole project.

7.

Optional: Change the appearance of the dedication text using the text editor options.

8.

Close the text editor in any of the following ways:
●

Press Esc or Ctrl/Cmd-Return.

●

Click outside of the text editor.

RESULT
A dedication is shown above the title of all pages that use the selected master page format if a
dedication is entered into the appropriate field in the Project Info dialog.
RELATED LINKS
Project Info dialog on page 62
Creating paragraph styles on page 278
Text editor options in Engrave mode on page 281
Edit Font Styles dialog on page 275

Changing the text in running headers in master pages
The Default Part master page set shows the part name at the top left of the first pages in flows,
and also shows the part name centered at the top of subsequent pages as a running header.
You can change the text shown in running headers, for example, if you want to include the flow
title as well.
PROCEDURE
1.

In Engrave mode, select the master page set containing the master page whose running
header text you want to change from the Current set menu in the Master Pages section
of the Pages panel.
For example, if you want to change the running header text in parts, select Default Part.

2.

Double-click the master page whose running header text you want to change. For
example, if you are using the default master pages, double-click Default.
The master page editor opens.

3.

Open the text editor for the header text frame in any of the following ways:
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4.

●

Activate Frames in the Formatting panel, select the text frame, and press Return.

●

Double-click within the text frame.

Change or delete the header text.
For example, to show both the part name and the flow title in the header text separated by
a dash, enter - {@flowTitle@} after the part name token in the text frame.

5.

Close the text editor in any of the following ways:
●

Press Esc or Ctrl/Cmd-Return.

●

Click outside of the text editor.

RESULT
The running header text is changed for all layouts that use the selected master page format.
EXAMPLE

Token text added to a text frame

Token text in a part layout

RELATED LINKS
Master page editor on page 235

Individual changes to the formatting of pages
You can add new frames, and change the shape and size of existing frames, on individual pages
independently of master page formats.
For example, you can include project information on the first page of the first flow in the project,
but not on the first pages of subsequent flows.
RELATED LINKS
Frames on page 244
Inputting frames on page 244
Moving frames on page 245
Changing the size/shape of frames on page 245

Changing the default horizontal alignment of different text
styles project-wide
You can change the default horizontal alignment of text styles. This changes the horizontal
alignment of the corresponding text style wherever it is used in the project.
PROCEDURE
1.

In Engrave mode, choose Engrave > Paragraph Styles.
The Paragraph Styles dialog opens.

2.

In the paragraph style list, select the text style whose default alignment you want to
change.

3.

Choose one of the following Alignment options:
●

Left-align

●

Center-align
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●

Right-align

●

Justify

●

Inside Edge

●

Outside Edge

RESULT
The default alignment of the selected text style is changed.
TIP
●

You can change other aspects of text styles in the Paragraph Styles dialog.

●

You can also override the horizontal alignment of text in individual text frames.

RELATED LINKS
Paragraph Styles dialog on page 276
Changing the horizontal alignment of text in text frames on page 259

Changing the vertical alignment of text in text frames
You can change the vertical alignment of text in text frames. You can do this on master pages,
which changes the alignment of the selected text on all pages that use the master page format,
and on individual pages, which only changes the alignment of the selected text on that page.
PREREQUISITE
If you want to change the vertical alignment of text on master pages, first open the master page
editor.
PROCEDURE
1.

In Engrave mode, activate Frames in the Formatting panel.

2.

Select the frames whose text vertical alignment you want to change.

3.

In the Properties panel, select one of the following options from the Vertical alignment
menu in the Text group:
●

Top

●

Center

●

Bottom

RESULT
The vertical alignment of text in the selected text frames is changed.
NOTE
Changing the vertical alignment of text does not override its paragraph style. Any changes you
make later to the paragraph styles of text whose vertical alignment has been changed are
applied to the text.

RELATED LINKS
Customizing master pages on page 236
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Grace notes are notes without a fixed duration, which are intended to be played quickly. They are
scaled-down versions of normal notes, and are commonly shown with a slash through their
stem.
Grace notes with slashed stems are known as acciaccaturas and are often played very fast. Grace
notes without slashed stems are known as appoggiaturas and are often played slower than
acciaccaturas.
In Baroque music, appoggiaturas are often understood to last for a specific duration, based on
the rhythmic value of the notehead to which they are attached and the meter.
Grace notes do not take up space rhythmically, as they are intended to be fitted into the space
before the notehead to which they are attached, which is the notehead immediately to their
right.
There can be multiple grace notes before a notehead. If there are two or more grace notes
attached to the same notehead, and they have a rhythmic value that shows a flag on the stem,
such as eighth notes (quavers) and 16th notes (semiquavers), they can be beamed together.
In Dorico, grace notes are scaled to 3/5 the size of a normal notehead by default.
You can add notations, such as slurs and articulations, to grace notes in the same ways as to
normal notes, and you can transpose grace notes after they have been input.
RELATED LINKS
Inputting grace notes on page 128
Slur placement relative to grace notes on page 665
Changing the pitch of individual notes on page 138
Inputting articulations on page 141
Inputting slurs on page 208

General placement conventions for grace notes
Grace notes function like normal notes in many ways, but there are some specific conventions
about their stem direction, position relative to noteheads, and the placement of stem slashes.
Grace notes appear stem up by default, except when there are multiple voices with grace notes
in a single staff, in which case grace notes in the lower voices appear stem down. This affects the
placement of slurs relative to grace notes.
Grace notes are always positioned before a notehead, even if they are intended to be played on
the beat rather than before the beat. They are normally placed after a barline so they can be
positioned directly before the notehead to which they are attached. However, groups of three or
more grace notes can be placed before the barline so that the note of the first beat in the bar is
not pushed too far from the barline.
Grace note stem slashes appear at the beginning of a grace note beam if multiple grace notes
can be joined by a single beam at the same rhythmic position. If there is a single grace note, the
slash appears across the stem, and its flag if applicable, and extends either side of the stem.
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Adding accidentals causes their spacing to readjust so that the accidentals are clearly legible,
similar to normal notes. Articulations can be added to grace notes wherever it is most clearly
legible, which is most likely outside the staff. Dorico automatically places articulations on the
stem-side of grace notes, and outside the staff if the stem or beam is within the staff.
RELATED LINKS
Changing the position of grace notes relative to barlines on page 518
Slur placement relative to grace notes on page 665

Grace note placement in multiple-voice contexts
According to accepted notation convention, grace notes appear stem up by default when there is
only one voice on a staff, even if the notehead to which they are attached is stem down.
However, when there are multiple voices on the staff, all notes in the upper voices appear stem
up and all notes in the lower voices appear stem down, including all grace notes. This adjustment
happens automatically in Dorico.

NOTE
You can also override the stem direction of grace notes in multiple voices and change their
directions individually if necessary.

RELATED LINKS
Changing the stem direction of notes on page 714
Slur placement relative to grace notes on page 665

Changing the position of grace notes relative to barlines
You can change the position of individual grace notes so they appear before/after barlines.
By default, grace notes are positioned after barlines and directly before the notehead to which
they apply, including for the first note in a bar.
However, you can position individual grace notes before barlines so that the note on the first
beat in the bar is not pushed too far from the barline when the note has multiple grace notes, or
to indicate that the grace notes are played before the beat.
PROCEDURE
1.

Select the grace notes whose position relative to barlines you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Grace note before barline in the Grace Notes
group.
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RESULT
The selected grace notes are repositioned before barlines when the property is activated, and
after barlines when the property is deactivated.

Project-wide changes to the position of grace notes
You can change the default position of grace notes relative to the notehead to which they apply
in the Grace Notes section of the Notes page in Engraving Options.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Increasing the value for the minimum distance to the right of the rightmost grace note moves
grace notes further from the notehead to which they apply. Decreasing the value moves them
closer to the notehead to which they apply.

A grace note with the default minimum value of half
a space between it and the notehead to its right

A grace note with an increased value of 1.5 spaces
between it and the notehead to its right

You can also adjust the position of grace notes in each layout independently by changing the
note spacing scale factor for grace notes on the Note Spacing page in Layout Options.
You can open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options at the bottom of the Layouts panel in Setup mode.

●

Right-click an instrumental part or a full score in the Layouts panel and choose Layout
Options from the context menu.

Decreasing the note spacing scale value for grace notes decreases the gap between multiple
grace notes at the same rhythmic position.

Three grace notes with long durations, with the
default note spacing scale of 70%

Three grace notes with long durations, with a
decreased note spacing scale of 20%

Position of slurs relative to grace notes
You can set the position of slurs relative to grace notes in the Grace Notes section of the Slurs
page in Engraving Options.
Included in this section are options for the position of slurs relative to grace notes in multiple
voices.
RELATED LINKS
Slur placement relative to grace notes on page 665
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Project-wide changes to the position of grace note beams
You can make project-wide changes to the position of grace note beams on the staff.

Position of grace note beams on the staff
Like all beams, grace note beams ideally follow the accepted standards for beam placement
relative to staff lines, in order to avoid wedges. However, because grace notes are smaller than
normal notes, this can lead to extreme slants in grace note beams.
In Dorico, you can change how grace note beam slants are positioned project-wide in the
Vertical Position section of the Beams page in Engraving Options.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Beam slants in two-note groups of beamed grace notes
If there are two grace notes that cover a wide pitch range joined by a beam at the same rhythmic
position, the angle of the beam can appear very steep.
You can choose whether the beam slant in such cases is left unchanged, or whether shallower
slants are used, in the Slants section of the Beams page in Engraving Options.

Project-wide changes to the appearance of grace notes
You can make project-wide changes to the appearance of grace notes in terms of their size, stem
length, and slash design.

Grace note size
Grace notes are smaller versions of normal notes, and are scaled down by a ratio that is set by
default to 3/5 of a normal note.
You can change this ratio by increasing/decreasing the value for Grace note scale factor in the
Grace Notes section of the Notes page in Engrave > Engraving Options.

Grace note stem length
Grace notes are scaled-down notes, so the default stem length of grace notes is determined by
your project-wide settings for the stem length of all notes. You can change these in the Stems
section of the Notes page in Engraving Options.

Grace note slash design
The precise measurements of each part of grace note stem slashes can be set in the Grace
Notes section of the Notes page in Engraving Options.
In this section you can change the following:
●

Thickness of grace note stem slashes

●

Default length of grace note stem slashes

●

Position of grace note stem slashes relative to the end of the stem

520

Grace notes
Individual changes to the appearance of grace notes

Individual changes to the appearance of grace notes
You can make changes to the appearance of grace notes individually, such as changing the
appearance of grace note stems and changing their stem direction.
You can change the appearance of grace notes using properties in the Grace Notes group of the
Properties panel. More properties are available in Engrave mode than in Write mode.
For beamed grace note groups, you can also change the grace note beam using properties in the
Beaming group of the Properties panel.
Following accepted conventions, grace notes in Dorico are stem up by default in any clef,
regardless of the stem direction of the note to which they apply. The stem directions of grace
notes are changed automatically when there are multiple voices on a staff, but you can change
the stem direction of individual grace notes manually. You can also lengthen/shorten grace note
stems in the same ways as for normal stems.
RELATED LINKS
Beaming on page 403
Beam groups on page 403
Changing the stem direction of notes on page 714
Lengthening/Shortening stems on page 717

Changing the type of grace notes
You can change the type of individual grace notes after they have been input. Grace notes can
have slashed stems or unslashed stems.
Grace notes with slashed stems are known as acciaccaturas and are often played very fast. Grace
notes without slashed stems are known as appoggiaturas and are often played slower than
acciaccaturas.
In Dorico, grace notes appear with slashed stems by default.
PROCEDURE
1.

Select the grace notes whose type you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, choose one of the following options for Grace note type in the
Grace Notes group:
●

Slashed stem

●

Unslashed stem

RESULT
The selected grace notes are shown with slashed/unslashed stems.
TIP
You can also change the grace note type during step input.

RELATED LINKS
Inputting grace notes on page 128
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Moving slashes on grace note stems
You can change the vertical position of individual grace note slashes, independently of your
project-wide settings.
PROCEDURE
1.

In Engrave mode, select the grace notes whose slash positions you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Grace Notes group:

3.

●

Slash inset from stem tip

●

Slash offset to right

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

RESULT
Increasing Slash inset from stem tip moves grace note slashes further from the tips of stems,
decreasing the value moves them closer to the tips of stems.
Increasing Slash offset to right moves grace note slashes to the right, decreasing the value
moves them to the left.
TIP
You can change the default position of all grace note slashes project-wide in the Grace Notes
section of the Notes page in Engrave > Engraving Options.

Changing the length of grace note slashes
You can change the length of slashes on grace note stems individually, independently of your
project-wide setting.
PROCEDURE
1.

In Engrave mode, select the grace notes whose slash length you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Grace Notes group.
●

Slash length

●

Slash protrusion from beam (beamed grace notes only)

NOTE
Grace note slashes seem to disappear when you activate Slash length. This is because
activating the property resets the value to 0.
3.

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

RESULT
Increasing Slash length lengthens grace note slashes on both single grace notes and grace note
beams, decreasing the value shortens grace note slashes.
Increasing Slash protrusion from beam increases how far slashes extend beyond grace note
beams, decreasing the value decreases how far slashes extend beyond grace note beams.
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TIP
You can change the default appearance of all grace note slashes project-wide in the Grace Notes
section of the Notes page in Engrave > Engraving Options.

RELATED LINKS
Moving slashes on grace note stems on page 522
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Different notations are used to show where the established rhythmic flow of the music is
interrupted, either with a moment of repose or a short silence, before continuing. The most
subtle effect is produced by a tenuto mark, with more significant effects denoted with holds and
pauses.
The duration of the break in the music intended by the hold or pause does not need to be
specified. This leaves significant room for interpretation, even though the different styles of
holds and pauses normally indicate larger or smaller breaks.
NOTE
Holds and pauses do not currently have an effect in playback, but this is planned for future
versions.

RELATED LINKS
Input methods for holds and pauses on page 181

Types of holds and pauses
There are three types of holds and pauses in Dorico, and they can all be input, moved, and
deleted in the same ways.
Fermatas
Fermatas indicate that a note is held for longer than its notated length, which applies
to the whole ensemble.
They are also known as “pauses” and informally sometimes called “birds’ eyes”.
Breath marks
Breath marks show suitable places for players to breathe, or suggest how the music
is phrased to create a similar effect.
Caesuras
Caesuras indicate that a note is sustained for its full value and is followed by a break
in sound before continuing.

Types of fermatas
There are different types of fermatas available in Dorico. Each fermata indicates a suggested
pause duration whilst leaving room for interpretation.
Fermata

Description

Very short fermata

Indicates that a note is held only a fraction
longer than the rhythm indicates.

524

Holds and pauses
Types of holds and pauses

Fermata

Description

Short fermata

Indicates that a note is held a little bit longer
than the rhythm indicates.

Short fermata (Henze)

Indicates that a note is held a little bit longer
than the rhythm indicates, as used by Hans
Werner Henze.

Fermata

Indicates that a note is held for longer than the
rhythm indicates.

Long fermata

Indicates that a note is held quite a lot longer
than the rhythm indicates.

Long fermata (Henze)

Indicates that a note is held quite a lot longer
than the rhythm indicates, as used by Hans
Werner Henze.

Very long fermata

Indicates that a note is held for much longer
than the rhythm indicates.

Curlew (Britten)

Indicates that a note or rest is held until the
next synchronization point in asynchronous
music, as used by Benjamin Britten.

Fermatas can be divided into two styles. Because their meanings overlap, it can be confusing for
players if both styles are used in a single project.
Style

Very short
fermata

Short
fermata

Fermata

Long fermata Very long
fermata

Normal
Henze

N/A

N/A

RELATED LINKS
Holds and pauses popover on page 182
Changing the appearance/duration of existing holds and pauses on page 527
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Types of breath marks
There are different types of breath marks available in Dorico. Breath marks indicate a suitable
place for a player to take a breath, or create a musical effect like a breath.
Comma-like

Tick-like

Upbow-like

Salzedo

RELATED LINKS
Holds and pauses popover on page 182
Changing the appearance/duration of existing holds and pauses on page 527

Types of caesuras
There are different types of caesuras available in Dorico. All caesuras indicate a break in sound,
but different types are often needed for different styles of musical scores.
Caesura

Thick caesura

Short caesura

Curved caesura

Two diagonal slashes

Two thick diagonal
slashes

Two straight, vertical
slashes

Two curved diagonal
slashes

If you intend to communicate a specific length of hold or gap with each type of caesura, we
recommend that you consider adding a legend, as different players may interpret these symbols
differently.
RELATED LINKS
Holds and pauses popover on page 182
Changing the appearance/duration of existing holds and pauses on page 527

General placement conventions for holds and pauses
Holds and pauses are placed above the staff. For staves with multiple voices, fermatas can be
placed inverted below the staff.

Fermatas
Fermatas are positioned horizontally so that they are centered on noteheads, regardless of the
stem direction of notes.

Fermatas affect the overall tempo of the piece, so all players must be able to see where they
occur. Therefore, fermatas are shown on all staves at the same rhythmic position, or the
rhythmic position of the note, chord, or rest that corresponds with the end of the fermata,
including over a bar rest if a staff has no notes in that bar.
You can change the minimum distance between fermatas and the staff on the Holds and Pauses
page in Engrave > Engraving Options.
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Breath marks
Breath marks are placed above the top line of the staff, at the end of the note to which they
apply; that is, they appear just before the following note.
Breath marks apply only to the staff to which they were added, as they do not affect the overall
tempo, but instead only indicate to a single player or group of players a suitable place to break
their line in order to breathe.
You can change the minimum distance between breath marks and the staff, and between breath
marks and the next note or rest, on the Holds and Pauses page in Engraving Options.

Caesuras
Caesuras are positioned at the top of the staff, with the top staff line passing through the middle
of the caesura and the bottom of the caesura resting on the second staff line. They are
commonly placed at the end of a bar, before the barline.
Caesuras are automatically added to all staves at the same rhythmic position, immediately to the
left of the notehead or barline to which they were input. They are not linked to noteheads, and
adjust note spacing to create a clear gap.
You can change the size of the gap to the right of caesuras on the Holds and Pauses page in
Engraving Options.

Multiple holds and pauses at the same rhythmic position
Because fermatas apply to all staves, only one type of fermata can exist at the same rhythmic
position. For example, you cannot have a short fermata on one staff and a long fermata at the
same rhythmic position on another staff.
A Britten curlew can be used at the same rhythmic position as another kind of fermata, but it
cannot exist simultaneously with any breath mark. This is the only exception in Dorico.
Caesuras can co-exist with any type of breath mark, but you cannot have a caesura and a fermata
at the same rhythmic position.

Changing the appearance/duration of existing holds and
pauses
You can change the appearance/duration of existing holds and pauses, including changing their
type. For example, you can change a short fermata into a long fermata, and change a fermata
into a caesura.
PROCEDURE
1.

In Write mode, select the hold or pause whose appearance/duration or type you want to
change.
NOTE
You can only change the appearance/duration or type of one hold or pause at a time,
except when using properties in the Holds and Pauses group of the Properties panel.

2.

Change the appearance/duration or type of the holds or pauses in any of the following
ways:
●

Open the holds and pauses popover by pressing Shift-H and enter a hold or pause
into the popover.

●

Click a hold or pause in the Holds and Pauses panel.
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●

Select a type of hold or pause from the appropriate menu for your selected holds or
pauses in the Holds and Pauses group of the Properties panel: Fermata duration,
Caesura appearance, or Breath mark appearance.
NOTE
These menus only appear when the corresponding type of hold or pause is selected.
If your selection includes different types of holds and pauses, for example, fermatas
and caesuras, no menu is shown.
The Curlew (Britten) fermata is not included in the Fermata duration menu, as it
only applies to individually selected notes.

RESULT
The appearance/duration or type of the selected hold or pause is changed.
NOTE
If you change a fermata to a breath mark, only the fermata on the top staff is changed to a
breath mark. If you change a caesura to a breath mark, a breath mark is input on the top staff at
the end of the bar to which the caesura is attached. However, the existing caesura also remains
on all staves.

RELATED LINKS
Holds and pauses popover on page 182
Input methods for holds and pauses on page 181
Types of fermatas on page 524
Types of caesuras on page 526
Types of breath marks on page 526

Changes to fermatas on single staves
Changing the type of fermata or caesura on one staff automatically changes the type on all
staves at that rhythmic position, as a pause at one particular rhythmic position can only be of
one duration.
However, if you override a particular fermata on one staff, for example, by changing it to a
Britten curlew or a breath mark, changing the existing fermata on another staff does not change
the marking on the overridden staff. Deleting the marking on the overridden staff reverts that
marking to match the fermata on the other staves.
For example, changing a fermata to a breath mark changes the marking for only that staff. That
note is not affected when the type of fermata on the other staves at that rhythmic position is
changed.
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The bottom staff is overridden to
show a breath mark instead of a
fermata.

The fermata is changed to a very
short fermata, but the bottom
staff is exempt as it was
overridden to show a breath mark.

Deleting the breath mark from the
bottom staff returns it to showing
the fermata currently chosen for
that rhythmic position.

Positions of holds and pauses
You can change the positions of holds and pauses individually and by changing their default
positions project-wide. For example, you can override the default position of an individual breath
mark to accommodate other items at the same position.
You can move holds and pauses to different rhythmic positions in Write mode. They are
positioned by default according to your settings in Engraving Options.
You can move holds and pauses graphically in Engrave mode, however, this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all holds and pauses project-wide, and values for the
minimum gaps around holds and pauses, on the Holds and Pauses page in Engrave >
Engraving Options.
RELATED LINKS
Project-wide engraving options for holds and pauses on page 532

Moving holds and pauses rhythmically
You can move holds and pauses to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the holds and pauses you want to move.
NOTE
When using the mouse, you can only move one hold or pause rhythmically at a time.

2.

Move the holds and pauses according to the current rhythmic grid value in any of the
following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the hold or pause to the right/left.

RESULT
The selected holds and pauses are moved to new rhythmic positions on each staff where they
appear, even if their position does not appear to move. For example, if one staff has a bar rest,
the rhythmic position of the hold or pause moves, but the hold or pause still appears above the
rest.
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NOTE
Only one type of hold or pause can exist at each rhythmic position. If a hold or pause passes over
another hold or pause as part of its move, the existing hold or pause is deleted.
You can undo this action, but any holds and pauses deleted in the process are only restored if
you moved the hold or pause using the keyboard.

Moving holds and pauses graphically
You can move holds and pauses graphically without changing the rhythmic positions to which
they are attached.
PROCEDURE
1.

In Engrave mode, select the holds and pauses you want to move.

2.

Move the holds and pauses in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The holds and pauses are moved to new graphical positions.
TIP
Start offset in the Holds and Pauses group of the Properties panel is activated automatically
when you move fermatas and breath marks. You can use this property to move fermatas and
breath marks by changing the values in the value fields. However, you cannot move caesuras
using this property.
●

Offset X moves fermatas and breath marks horizontally.

●

Offset Y moves fermatas and breath marks vertically.

Deactivating the property resets the selected fermatas and breath marks to their default
positions.

Changing the placement of fermatas relative to the staff
Fermatas are normally placed above the staff, but you can change their placement relative to the
staff individually.
PROCEDURE
1.

In Engrave mode, select the fermatas whose placement relative to the staff you want to
change.

2.

In the Properties panel, activate Placement in the Holds and Pauses group.

3.

Choose one of the following options:
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●

Above

●

Below

RESULT
The selected fermatas appear above/below the staff.

Changing the number of fermatas per staff
You can change the maximum number of fermatas that appear in each staff at individual
positions when there are multiple voices on a staff.
PROCEDURE
1.

Select a fermata or multiple fermatas. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Max. fermatas per staff in the Holds and Pauses group.

3.

Select one of the following options from the menu:
●

One per voice

●

One per each side of staff

●

One per staff

RESULT
The number of fermatas shown at the selected positions is changed.
TIP
You can change the maximum number of fermatas that can appear on a single staff project-wide
on the Holds and Pauses page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for holds and pauses on page 532

Positioning fermatas on barlines
You can position individual fermatas over a barline instead of over a note to indicate a gap
before the start of the following bar.
NOTE
Fermatas cannot be positioned on barlines if Max. fermatas per staff is also activated.

PROCEDURE
1.

Select the fermatas you want to position over barlines.

2.

In the Properties panel, activate Attach to barline in the Holds and Pauses group.

RESULT
The selected fermatas are positioned above the barline at the end of the bars they were in
originally, appearing only above staves that are not joined by the barline. Depending on the
instrumentation, this may mean they only appear at the top of the system.
Deactivating Attach to barline returns the selected fermatas to their default positions.
RELATED LINKS
Changing the number of fermatas per staff on page 531
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Project-wide engraving options for holds and pauses
You can find options for the project-wide positions of holds and pauses on the Holds and Pauses
page in Engraving Options.
The options on the Holds and Pauses page allow you to change the default positions and
placement of holds and pauses, including the placement of fermatas in multiple-voice contexts.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Holds and Pauses in the page list on the left of the dialog.
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Key signatures are the markings that show the current key of music by indicating which notes in
the scale for that key are sharpened or flattened. They are shown at the start of each system on
every applicable staff.
Using key signatures saves space, as by indicating which notes are generally going to be sharp or
flat in the music in one group at the start of each system, these notes do not need an accidental
beside them every time they occur.
By default, key signatures apply to the whole score. However, there are certain situations where
some parts require their own key signature, independently of the rest of the ensemble. You can
input key signatures that apply to all staves or only apply to single staves in Dorico.
Traditionally, accidentals are organized following the pattern of the circle of fifths, which is
different for sharp keys and flat keys.
In Dorico, key signatures exist within the overarching tonality system for your project. The two
tonality systems that come as standard in Dorico are 12-EDO and 24-EDO.
Once you have selected or created a tonality system for your project, you can create custom key
signatures and custom accidentals within that tonality system.
RELATED LINKS
General placement conventions for key signatures on page 533
Tonality systems on page 536
Input methods for key signatures on page 145

General placement conventions for key signatures
Dorico automatically follows conventions for the placement and appearance of key signatures,
such as showing accidentals in the accepted circle of fifths order and positioning key signatures
between clefs and time signatures.
The order in which accidentals are shown in key signatures is different for sharp keys and flat
keys.
●

For sharps: F♯, C♯, G♯, D♯, A♯, E♯, B♯

●

For flats: B♭, E♭, A♭, D♭, G♭, C♭, F♭

Accidentals are arranged automatically in these orders in Dorico for all standard Western key
signatures. There is an accepted pattern for the placement of accidentals in a key signature, so
that they fit inside the staff according to the current clef. The pattern of accidentals is the same in
all clefs, apart from the tenor clef, which requires sharp key signatures to follow a different,
ascending pattern to ensure the accidentals fit on the staff.
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Clef

Arrangement of sharps

Arrangement of flats

Treble

Bass

Alto

Tenor

NOTE
For custom, non-standard key signatures, you can determine the order in which accidentals
appear in the Edit Custom Key Signature dialog.
Key signatures are shown at the start of a piece and at the start of subsequent movements, even
if the music carries straight on and in the same key. They are positioned between clefs and time
signatures. Unlike time signatures, key signatures appear at the start of every system in full score
and part layouts, even if the key signature has not changed. They are shown on every staff that
requires the key signature, but are not shown on staves for unpitched instruments.

The correct position for key signatures is between clefs and time signatures.

If a key signature change occurs during a piece or movement, it should be placed immediately
after a barline. It is customary to have a double barline where a key signature change takes
place, which is the default setting in Dorico. However, you can change the default barline shown
at key signature changes.

Examples of key signatures positioned after double barlines

A key signature applies until the end of a movement, the end of a piece, or until a key signature
change if one occurs before the end of a movement or the end of a piece.
RELATED LINKS
Custom key signatures on page 543
Changing the barline shown at key signature changes on page 384
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Types of key signatures
There are four types of key signatures in Dorico, which can all be input, moved, and deleted in
the same ways.
The four types are:
●

Major

●

Minor

●

Open key, or atonal

●

No key signature (for specific instruments, such as horn or percussion)

Major/Minor key signatures
The key signature for a major key appears the same as the key signature for its relative minor,
and vice versa. For example, B♭ major has two flats in its key signature. This is the same number
of flats as for G minor, which is the relative minor key to B♭ major. The difference is that music in
G minor usually has sharpened Fs, as the seventh degree of the scale is raised in minor keys.
Therefore, if you input an F♯/G♭ after a G minor key signature, Dorico prefers to spell it as F♯ in
most cases, in order to follow the convention of harmonic minor keys.

A B flat major scale following a B flat major key
signature

A G minor scale following a G minor key signature

Open key signature
Although open, or atonal, key signatures appear the same as C major or A minor key signatures
because none shows any accidentals, open key signatures behave differently.
In an open key signature, the spelling of accidentals is based on the current direction of the
music. If the music is rising, sharps are preferred, whereas if the music is falling, flats are
preferred. There is no hierarchy of pitches in an open key signature, so the same pitch might be
spelled differently each time it appears depending on its context, even within a few bars.
In a C major or A minor key signature, accidentals are spelled based on the context of the major
or minor tonality implied. For example, in C major, sharps in general are preferred, whether the
music is going up or going down. Similarly, in A minor, G♯ in particular is preferred, whether the
music is going up or going down, as G♯ is the leading note in A minor.

No key signature
Some instruments are accustomed to seeing no key signatures in their parts, no matter the
overall key of the piece. These instruments include timpani, percussion, horn, trumpet, and
sometimes the harp. If you have added the No key sig version of these instruments, then no key
signature is shown in their parts, even if they are a transposing instrument, such as horn or
trumpet.
Any pitch can be input into these instruments, and they show accidentals if needed.
RELATED LINKS
Adding instruments to players on page 73
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Tonality systems
The term “tonality system” is used in Dorico to encompass three crucial elements that together
make up the concept of tonality.
The three elements that make up tonality systems are:
●

A number of equal divisions of the octave. For example, standard Western scales with
semitone steps have 12-EDO.

●

A set of accidentals. This allows you to notate how a note is raised or lowered. This can be
a traditional set of accidentals, a set selected from the wide variety available, or a custom
set of accidentals of your own design.

●

A key signature. This can be a traditional Western key signature, or a custom key signature
of your own design.

RELATED LINKS
Custom tonality systems on page 537
Changing the tonality system on page 537

Equal Division of the Octave (EDO)
EDO stands for Equal Division of the Octave: the number of equal pieces into which an octave is
divided. In Dorico, you can create any number of divisions of an octave and design custom key
signatures and custom accidentals for each tonality system.
Traditional Western harmony is based on equal temperament, another method used to describe
tonality systems, or 12-EDO, as the traditional scale from C-C is made up of twelve steps spread
across the seven notes in the scale.
The 12-EDO Edit Tonality System dialog shows how these steps are divided across the intervals
in the scale. There, you can see how many steps are given to each interval. For example, between
the notes A and B there are two steps, but between B and C there is one step. This is because in
12-EDO, each step represents a semitone, and there are two semitones between A and B
according to standard equal temperament, but only one semitone between B and C.
To have the smallest step in the tonality system be a quarter tone rather than a semitone, the
octave must be divided into twice as many equal divisions as 12-EDO. Therefore, to be able to use
quarter tone accidentals in a project, you must choose the Equal temperament (24-EDO)
tonality system for the project.
Although you can divide the octave into any number of divisions, to be able to show a standard
Western key signature, the number of equal divisions in the octave must be divisible by 12.
EDO also allows you to map non-conventional Western pitches on to the seven note names A-G,
and create a coherent notation to express that, because there is no limit to how you can divide
the octave. For example, Turkish music is traditionally divided in 53-EDO, the division of which is
usually spread across the notes A-A with the following number of divisions for each interval:
9-4-9-9-9-4-9.
RELATED LINKS
Custom tonality systems on page 537
Edit Tonality System dialog on page 538
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Changing the tonality system
You can change the tonality system used in your project at key signature changes, including
changing to a custom tonality system you have created.
PREREQUISITE
If you want to use a tonality system other than Equal temperament (12-EDO) or Equal
temperament (24-EDO), you have created a custom tonality system.
PROCEDURE
1.

In Write mode, select an item at the position from which you want to change the tonality
system.

2.

Without deselecting the item, select the tonality system you want from the menu in the
Tonality System section of the Key Signatures, Tuning Systems, and Accidentals panel.

3.

Input a new key signature.

RESULT
The tonality system is changed from the key signature you input until the next key signature with
a tonality system change or the end of the flow.
If you selected a tonality system that allows microtonal accidentals, such as Equal temperament
(24-EDO), microtonal accidentals become available in the Accidentals section of the Key
Signatures, Tuning Systems, and Accidentals panel.
RELATED LINKS
Custom tonality systems on page 537
Input methods for key signatures on page 145
Inputting microtonal accidentals on page 359

Custom tonality systems
Custom tonality systems allow you to specify a unique number of divisions of the octave for your
project. This can be useful for music not based on traditional Western harmony. In Dorico, you
can also design your own custom accidentals and combine them into custom key signatures as
appropriate for your project.
You can find existing tonality systems in your project in the Tonality System section of the Key
Signatures, Tuning Systems, and Accidentals panel. You can open this panel by clicking Key
Signatures, Tuning Systems, and Accidentals in the Notations toolbox in Write mode.

Dorico provides two tonality systems in each project by default: Equal temperament (12-EDO)
and Equal temperament (24-EDO).

The Tonality System section of the Key Signatures, Tuning Systems, and Accidentals panel

You can create custom tonality systems and edit existing tonality systems in the Edit Tonality
System dialog, which you can open by clicking either of the following buttons in the Tonality
System action bar:

537

Key signatures
Tonality systems
●

New Tuning System

Allows you to create a new tonality system.
●

Edit Tuning System

Allows you to edit the selected existing tonality system.
RELATED LINKS
Edit Tonality System dialog on page 538
Custom divisions of the octave on page 539
Custom accidentals on page 540
Custom key signatures on page 543

Edit Tonality System dialog
You can create custom tonality systems and edit existing tonality systems in the Edit Tonality
System dialog.
●

You can open the Edit Tonality System dialog by clicking either New Tuning System or
Edit Tuning System in the action bar in the Tonality System section of the Key
Signatures, Tuning Systems, and Accidentals panel.

The Edit Tonality System dialog contains the following sections:
1

Name
Allows you to enter a name for a new tonality system, or edit the name of an existing
custom tonality system you created.

2

Divisions
Allows you to specify how many divisions of the octave you want assigned to each interval.

3

Accidentals
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Displays the accidentals currently available for the selected tonality system. The two
buttons at the bottom allow you to edit existing accidentals, and to create new accidentals.
4

Custom Key Signatures
Displays the key signatures currently available for the selected tonality system. The two
buttons at the bottom allow you to edit existing key signatures, and to create new key
signatures.

New Accidental/New Key Signature button

Edit Accidental/Edit Key Signature button

Once you have decided on the number of divisions your octave has, and how many divisions are
assigned to each interval, in the Divisions section of the dialog, you can assign existing and
create custom accidentals for each raising/lowering pitch delta you want to notate in the Edit
Accidental dialog.
You can arrange these accidentals into a custom key signature in the Edit Custom Key
Signature dialog.
RELATED LINKS
Custom tonality systems on page 537
Edit Accidental dialog on page 541
Edit Custom Key Signature dialog on page 543

Custom divisions of the octave
You can change the number of divisions of the octave for an existing tonality system, or create a
new tonality system with as many divisions of the octave as you like.
In the Divisions section of the Edit Tonality System dialog, you can change the number of
divisions assigned to each interval. The total number of divisions of an octave, which is shown at
the top of the section, is updated automatically as you change the number of divisions.

The Divisions section of the Edit Tonality System dialog, as it appears when editing the existing 12-EDO
tonality system.
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In Equal temperament, or 12-EDO, the total number of divisions is 12. There are 2 divisions
between A and B, 1 division between B and C, and so on. This follows the standard Western
pattern which you can also see in the pattern of white and black keys on a keyboard.
Although you can divide the octave into any number of divisions, the number of equal divisions
in the octave must be divisible by 12 to be able to show a standard Western key signature in
Dorico.
RELATED LINKS
Custom accidentals on page 540
Custom key signatures on page 543
Edit Tonality System dialog on page 538

Custom accidentals
Custom accidentals can contain traditional accidental glyphs but also other musical symbols,
text, and graphics. This allows you to design custom accidentals that express specific pitch deltas
in your custom tonality systems.
You can find all accidentals available in the current tonality system in the Accidentals section of
the Edit Tonality System dialog.

The Accidentals section of the Edit Tonality System dialog, as it appears when editing the existing 12-EDO
tonality system.

You can create new and edit existing custom accidentals in the Edit Accidental dialog.
NOTE
You can edit any accidental that is included in either of the default tonality systems that come
with Dorico. New tonality systems start with a natural accidental, which you can edit or delete.

RELATED LINKS
Edit Accidental dialog on page 541
Edit Tonality System dialog on page 538
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Edit Accidental dialog
You can create new and edit existing custom accidentals in the Edit Accidental dialog.
●

You can open the Edit Accidental dialog by clicking either New Accidental or Edit
Accidental in the action bar at the bottom of the Accidentals section of the Edit Tonality
System dialog.

The Edit Accidental dialog contains the following sections:
1

Name
Allows you to enter a name for your accidental.

2

Pitch delta
Allows you to set a value for what effect this accidental has on notes to which it is added.
For example, a pitch delta of 2 raises notes by two equal divisions of the octave.

3

Accidental component selector
Allows you to choose components to add to your accidental. You can add different types of
components by clicking the respective tab titles.
●

Glyph includes symbols such as ♮ and ♯. You can use different styles of glyphs by
selecting different fonts and different ranges from the menus. Click Add Glyph to
add the selected glyph to the accidental.
NOTE
A full list of the different ranges of glyphs is available on the SMuFL website.

4

●

Text includes numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
preferred text into the text box at the bottom. Click Add Text to add the selected
text, or input text, to the accidental.

●

Graphic: Load a new graphic file, or select an existing graphic from the Select
existing list. You can see a preview of the graphic in the Preview box. Click Add
Graphic to add the selected graphic to the accidental.

Editor
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Allows you to arrange and edit the components that make up your accidental. You can use
the controls at the bottom of the dialog to edit and arrange accidental components.
5

Controls
●

X offset moves components horizontally. Increasing the value moves components
to the right, decreasing the value moves components to the left.

●

Y offset moves components vertically. Increasing the value moves components
upwards, decreasing the value moves components downwards.

●

X scale changes the width of graphics only. Increasing the value makes graphics
wider, decreasing the value makes graphics narrower.

●

Y scale changes the size of components and the height of graphics. Increasing the
value makes components larger, decreasing the value makes components smaller.
For graphics only, increasing the value makes graphics taller, decreasing the value
makes graphics shorter.

●

Attachment from: Select the attachment point on the component to the left of the
selected component to which the selected component attaches. We recommend
that you select a right edge attachment point for Attachment from.

●

Attachment to: Select the attachment point on the selected component which
attaches to the component to its left. We recommend that you select a left edge
attachment point for Attachment to.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that go below the baseline. The example diagram helps you visualize
how these points relate to accidental components.

The attachment points have the following names in the Edit Accidental dialog:
1

Top Left

2

Top Middle

3

Top Right

4

Left Middle

5

Right Middle

6

Baseline Left (text only)

7

Baseline Middle (text only)

8

Baseline Right (text only)

9

Bottom Left

10

Bottom Middle

11

Bottom Right

RELATED LINKS
Edit Tonality System dialog on page 538
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Custom key signatures
Custom key signatures can comprise traditional accidentals in a different order, or custom
accidentals you have designed in a specific order for your requirements.
You can find all key signatures available in the current tonality system in the Custom Key
Signatures section of the Edit Tonality System dialog.

The Custom Key Signatures section of the Edit Tonality System dialog, as it appears when creating or
editing custom tonality systems.

NOTE
If you edit one of the default tonality systems that come with Dorico, no key signatures are
available to edit in this section. However, you can create new key signatures within one of the
default tonality systems.
You can create new and edit existing custom key signatures for both new and existing tonality
systems in the Edit Custom Key Signature dialog.
RELATED LINKS
Edit Custom Key Signature dialog on page 543
Edit Tonality System dialog on page 538

Edit Custom Key Signature dialog
You can create new and edit existing custom key signatures in the Edit Custom Key Signature
dialog.
●

You can open the Edit Custom Key Signature dialog by clicking either New Key
Signature or Edit Key Signature in the action bar in the Custom Key Signatures section
of the Edit Tonality System dialog.
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Edit Custom Key Signature dialog

The Edit Custom Key Signature dialog contains the following sections:
1

Name
Allows you to enter a name for your key signature.

2

Clef
Shows how your key signature appears in treble clef, bass clef, alto clef, and tenor clef. You
can edit your key signature in any of these clefs.

3

Root
Allows you to select the base note of your key signature from the menu.

4

Accidentals
Allows you to add accidentals from your tonality system to the key signature, including
custom accidentals you have created in the Edit Accidental dialog. Click Add Accidental
to Key Signature to add the selected accidental to the key signature.

5

Editor
Allows you to arrange accidentals in your preferred order using the Order arrow buttons,
and change their position on the staff using the Note arrow buttons and Octave arrow
buttons.

RELATED LINKS
Edit Tonality System dialog on page 538
Edit Accidental dialog on page 541
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Deleting key signatures
You can delete key signatures without affecting the pitches of notes. Where appropriate, pitches
are shown with accidentals after you have deleted a key signature.
NOTE
You cannot hide key signatures as they provide crucial information about the pitch of notes. If
you do not want to see a key signature, you can input an open key signature or delete all key
signatures from the flow or project.
TIP
Instruments that do not usually have key signatures, such as timpani or horn, have a No key sig
version in Dorico which ensures no key signature is shown for those instruments. You can select
No key sig versions of instruments when adding/changing instruments in Setup mode.

PROCEDURE
1.

2.

In Write mode, select any of the following that you want to delete:
●

Key signatures

●

Key signature signposts of key signatures with no accidentals in the current layout

Delete the key signatures in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The selected key signatures are deleted from the score. The pitches of notes in the bars following
the deleted key signatures are not changed, but the notes are shown with accidentals if the
deleted key signature indicated an accidental for them, up until the next existing key signature or
the end of the flow.
NOTE
If you delete the only key signature in the flow, your music appears without a key signature, with
accidentals shown as necessary. This is treated as if there were an open key signature rather
than a key signature of A minor or C major.

RELATED LINKS
Deleting key signatures on page 545
Input methods for key signatures on page 145
Adding instruments to players on page 73
Changing instruments on page 75

Multiple key signatures
You can have multiple key signatures simultaneously by inputting each one onto a single staff.
NOTE
You do not have to input multiple simultaneous key signatures if you have transposing
instruments in your score. Dorico handles instrument transpositions automatically.
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You can check the transposition of transposing instruments by choosing Edit > Transposed
Pitch to see the music in your layout at written pitch rather than concert pitch.
Alternatively, you can open the individual part layout of a transposing instrument and compare it
to the full score.
RELATED LINKS
Inputting key signatures with the popover on page 147
Inputting key signatures with the panel on page 148

Positions of key signatures
You can change the positions of key signatures individually and by changing their default
position project-wide.
You can move key signatures to new rhythmic positions in Write mode. They are positioned
according to your settings on the Key Signatures and Spacing Gaps pages in Engrave >
Engraving Options.
Key signatures in Dorico appear in the correct position by default. You can move key signatures
graphically in Engrave mode, but this does not change their rhythmic positions.
If you want to adjust the default position of key signatures relative to notes or barlines, you must
change the project-wide values for spacing gaps on the Spacing Gaps page in Engraving
Options.
RELATED LINKS
Project-wide spacing gaps for key signatures on page 546
Moving key signatures graphically on page 547

Project-wide spacing gaps for key signatures
You can change the minimum gaps between objects, including key signatures.
Among the available values on the Spacing Gaps page in Engraving Options, the following
minimum values directly relate to key signatures:
●

Gap after barline before clef, key or time signature

●

Gap after cancellation naturals

●

Gap after key signature

●

Gap after end repeat barline

NOTE
Other values may have an effect on the position of key signatures, but they also affect other
objects.
On the Key Signatures page in Engraving Options, you can change the following gaps:
●

Gap between accidentals in key signatures

●

Gap between cancellation naturals

You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.
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Moving key signatures rhythmically
You can move key signatures to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the key signatures you want to move.
NOTE
When using the mouse, you can only move one key signature rhythmically at a time.

2.

Move the selected key signatures according to the current rhythmic grid value in any of
the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the key signature to the right/left.

RESULT
The key signatures are moved to new rhythmic positions. They take effect from their new
positions until the next key signature, or the end of the flow, whichever comes first.
NOTE
●

Key signatures can only be moved along the staff. If you want to move a key signature
across staves, you must delete the key signature and input a new key signature on the
other staff.

●

Only one key signature can exist at each rhythmic position, except for key signatures that
only apply to single staves. If a key signature passes over another key signature as part of
its move, the existing key signature is deleted and replaced by the key signature being
moved.
You can undo this action, but any key signatures deleted in the process are only restored if
you moved the key signature using the keyboard.

RELATED LINKS
Inputting key signatures with the popover on page 147
Inputting key signatures with the panel on page 148

Moving key signatures graphically
You can make individual changes to the graphical position of key signatures without affecting the
positions of any other items.
PROCEDURE
1.

In Engrave mode, activate Note Spacing in the Formatting panel.

2.

Select the square handle above the key signature you want to move.

A smaller circular handle appears beside the key signature.
3.

Select the circular handle.
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4.

Move the handle in any of the following ways:
●

Press Alt-Right Arrow to move it to the right.

●

Press Alt-Left Arrow to move it to the left.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

NOTE
You cannot move note spacing handles with the mouse, you can only move them using the
keyboard.

RESULT
The key signature is moved graphically to the right/left.
TIP
When Note Spacing is deactivated, you can also change Spacing Offset in the Key Signatures
group of the Properties panel to move key signatures horizontally. However, this also affects
global note spacing at the rhythmic position of the key signature, including moving cancellation
naturals.
You can also move cancellation naturals graphically, independently of the subsequent key
signature and without affecting the spacing of any other item using the Cancellation naturals X
offset property.

RELATED LINKS
Note spacing on page 284

Project-wide engraving options for key signatures
You can find options for the project-wide appearance of key signatures on the Key Signatures
page in Engraving Options.
The options on the Key Signatures page allow you to change the key signature cancellation style
and the spacing gaps between accidentals in key signatures.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Key Signatures in the page list on the left of the dialog.
TIP
If you want to change the barline shown at key signature changes, you can find this option on
the Barlines page in Engraving Options.

RELATED LINKS
Changing the barline shown at key signature changes on page 384
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Transposing key signatures alongside selections
You can transpose key signatures at the same time as transposing notes, which transposes both
key signatures and notes by the same degree.
PROCEDURE
1.

In Write mode, make a selection that includes both a key signature change and notes.

2.

Choose Write > Transpose.
The Transpose dialog opens.

3.

Adjust the parameters required for your transposition, such as interval and quality.

4.

Activate Transpose key signatures.
It is activated automatically if your selection includes a key signature.

5.

Click OK to save your changes and close the dialog.

RESULT
All notes and key signatures within the selection are transposed by the degree you set in the
dialog.
NOTE
If a key signature included in the transposed selection applies to all staves, then it is transposed
on all staves in the layout, even if your selection did not include all staves.
Individual key signatures, that is, key signatures added only to single staves using the Alt key, are
transposed if included in a selection, but this does not affect any other staff in the layout.

RELATED LINKS
Selecting/Deselecting notes and items individually on page 108
Large selections on page 109
Transpose dialog on page 139

Enharmonic equivalent key signatures
Enharmonic equivalent key signatures are keys with different names that include the same
pitches, such as C♯ major and D♭ major. Dorico follows the convention for transposing to keys
with the same type of accidental as the previous key, except where the enharmonic equivalent
key signature has fewer accidentals.
When transposing selections of notes, Dorico prefers keys with the same type of accidental as
the previous key signature. When choosing key signatures for transposing instruments, Dorico
prefers key signatures with the same type of accidental as the current concert pitch key.
However, there are some instances where you might prefer to transpose to a key with a different
type of accidental as it has fewer accidentals than the enharmonic equivalent key. For example,
C♯ major has seven sharps, whereas the enharmonic equivalent key of D♭ major only has five
flats. This means the player has to remember the accidentals for fewer notes.
Transposing to an enharmonic equivalent key with fewer accidentals can have the added benefit
of improving readability by avoiding double sharps or double flats. For example, transposing
music from F♯ to G♯ requires the leading note to be spelled as an F, but transposing to A♭ instead
means the leading note is G♮.
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G♯ major requires a double sharp leading note

A♭ major, the enharmonic equivalent to G♯, does not
require a double sharp leading note

By default, Dorico selects an enharmonic equivalent key signature if it has fewer accidentals.
However, you can change this setting by deactivating Prefer enharmonic equivalent key
signatures with fewer accidentals in the Transposition section of the Accidentals page in
Notation Options.
You can open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

●

Click Notation Options on the right of the Flows panel in Setup mode.

How key signatures affect transposing instruments
If there is a key signature in the full score, it is transposed for a transposing instrument by the
same degree as the transposing interval for the instrument. For example, in a project in E major,
a B♭ clarinet part has a key of F♯ major, as a B♭ clarinet sounds a whole tone below its notated
pitch.

Instruments that do not show a key signature
Some instruments are accustomed to seeing no key signatures in their parts, no matter the
overall key of the piece. These instruments include timpani, percussion, horn, trumpet, and
sometimes the harp. If you have input the No key sig version of these instruments, then no key
signature is shown in their parts, even if they are a transposing instrument, such as horn or
trumpet.
You can still transpose music in the staves of these instruments, but they show accidentals as
necessary, instead of showing a key signature.
RELATED LINKS
Transpose dialog on page 139
Transposing selections on page 140
Adding instruments to players on page 73

Cautionary key signatures
When a key signature change occurs at a system break, either in the score or in a part, the new
key signature is shown at the end of the first system as well as at the start of the new system.
This is sometimes considered a “cautionary key signature”, as players become used to seeing the
key signature at the start of the system and therefore may miss a change of key signature if it is
not conspicuously shown at the end of systems.
In Dorico, as key signature changes occur immediately after barlines, the key signature at the
end of a system is the key signature itself, rather than a cautionary key signature.
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If the music is separate enough that you do not want to see a key signature at the end of a
system and you cannot change where the system break occurs, you can separate the music by
creating a new flow at the point of the system break.
RELATED LINKS
Flows on page 88
Splitting flows on page 221
Formatting panel on page 223
Inserting system breaks on page 273
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In Dorico, the term lyrics is used for all text that is sung by singers.
To differentiate sung text from any other forms of text that often appear in musical scores, other
forms of text are referred to as performance instructions, tempos, dynamics, and so on.
In Dorico, lyrics were designed so that it is simple to make changes to existing lyrics without
having to re-input new lyrics each time. For example, you can change the syllable type of lyrics so
that they are either followed or not followed by a hyphen.
Lyrics are organized into lines to ensure consistent horizontal alignment and to make showing
verse numbers simple and accurate. There are different types of lyric lines for lyrics with different
purposes, and the appearance of lyrics changes depending on their line type. For example, lyrics
in a chorus line are shown in an italic font.
When inputting lyrics, you can use key commands to switch between lyric lines, to change on
which side of the staff lyrics are input, and to switch the lyric style between normal lyrics, chorus
lyrics, and translation lyrics. You can also change the type of lyrics after they have been input.
You can input multiple lines of lyrics, chorus lyrics, and translations, both above or below staves.
You can filter lyrics according to their type and lyric line by choosing Edit > Filter > Lyrics and
choosing a lyric type or lyric line from the menu.
RELATED LINKS
Types of lyrics on page 554
Lyric line numbers on page 563
Filters for lyrics on page 553
Inputting lyrics on page 200
Changing the syllable type of existing lyrics on page 556

General placement conventions for lyrics
Lyrics are generally placed below the staff to which they apply, and are positioned so that they
align horizontally with their corresponding notehead.
A plain font is generally used for normal lyrics, and an italic font is generally used for chorus
lyrics and translation lyrics in order to differentiate them.
The horizontal spacing of lyrics must be wide enough so that words or syllables do not overlap
with the words or syllables on either side. For this reason, note spacing must sometimes be
adjusted to accommodate lyrics.
To reduce how severely the note spacing is changed to accommodate lyrics, which can distort the
appearance of rhythms, Dorico allows the alignment of some lyrics to be adjusted relative to
their corresponding notes. For example, if a long, single-syllable word on a long note follows
another long, single-syllable word on a short note, the second word is moved a little to the right
to give both words enough space.
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A short note followed by a long note, where the horizontal position of the lyrics is automatically adjusted for
legibility

RELATED LINKS
Positions of lyrics on page 557
Changing the font styles used for lyrics on page 567

Filters for lyrics
In Dorico, lyrics filters allow you to select all lyrics of a specified type across your project or across
a specific selection.
The following filters are available in the menu when you choose Edit > Filter > Lyrics:
All Lyrics
Selects all types of lyrics in the current selection, with any lyric line number and
placement above/below the staff.
Line 1
Selects only Line 1 lyrics and translation lyrics for Line 1 in the current selection,
including Line 1 below the staff and Line 1 above the staff.
Line 2
Selects only Line 2 lyrics and translation lyrics for Line 2 in the current selection,
including Line 2 below the staff and Line 2 above the staff.
Line 3
Selects only Line 3 lyrics and translation lyrics for Line 3 in the current selection,
including Line 3 below the staff and Line 3 above the staff.
Line 4
Selects only Line 4 lyrics and translation lyrics for Line 4 in the current selection,
including Line 4 below the staff and Line 4 above the staff.
Line 5
Selects only Line 5 lyrics and translation lyrics for Line 5 in the current selection,
including Line 5 below the staff and Line 5 above the staff.
Above Staff
Selects all lyrics above the staff in the current selection. You can use this filter in
addition to the other filters. For example, you can filter first by line number, and then
filter again by placement relative to the staff.
Below Staff
Selects all lyrics below the staff in the current selection. You can use this filter in
addition to the other filters. For example, you can filter first by line number, and then
filter again by placement relative to the staff.
Chorus
Selects all chorus lyrics in the current selection.
Translations
Selects all translation lyrics in the current selection.
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RELATED LINKS
Large selections on page 109

Selecting lyrics using filters
You can use lyric filters to select all lyrics of a specified type across your project or across a
specific selection.
PREREQUISITE
You filter setting is set to Select Only. You can check this by choosing Edit > Filter > Select Only.
PROCEDURE
1.

In the music area, make a selection that includes all the lyrics you want to select.
For example, press Ctrl/Cmd-A to select the whole flow.

2.

Choose Edit > Filter > Lyrics > [Lyrics type].

RESULT
All lyrics of the selected type in your selection are selected. For example, if you choose Edit >
Filter > Lyrics > Chorus, all chorus lyrics in your selection are selected.
RELATED LINKS
Filters for lyrics on page 553
Large selections on page 109

Types of lyrics
Lyrics are divided into different lyric types in Dorico.
Lyric lines
Lyric lines contain normal lyrics and can be shown with verse numbers.
Chorus lines
Chorus lines contain lyrics in an italic font and are placed between lyric lines. For
example, if there are two lyric lines, the chorus line appears between Line 1 and Line
2.
Chorus lines do not have verse numbers.
Lyric line translations
Lyric line translations show the text in lyric lines or chorus lines in different
languages. They are placed directly below the lyric line or chorus line of which they
are a translation. They are shown in an italic font.
Each lyric line can have its own lyric line translation, including chorus lines.
Lyric line translations do not have verse numbers, as they are part of the line of
which they are a translation.
You can input all types of lyrics using the lyrics popover. The icon shown on the left-hand side of
the popover indicates the type of lyric currently being input.
RELATED LINKS
Lyric line numbers on page 563
Changing the line number and type of lyric lines on page 564
Lyrics popover on page 202
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Changing the type of individual lyrics
You can change the type of individual lyrics after they have been input. For example, you can
change lyrics into chorus lyrics or translation lyrics.
PROCEDURE
1.

Select the individual lyrics whose type you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate/deactivate the following properties, individually or
together, in the Lyrics group:
●

Chorus

●

Is translation

RESULT
If you activate Chorus, the selected individual lyrics are changed to chorus lyrics.
If you activate Is translation, the selected lyrics are changed to translation lyrics of the same
lyric line number. For example, selecting lyrics in Line 2 and activating Is translation turns them
into translation lyrics for Line 2.
If you activate both properties, the selected lyrics are changed to translation lyrics of the chorus.
If you deactivate both properties, the selected lyrics are changed to normal lyrics. Their line
number is indicated by the number in Line number in the Lyrics group of the Properties panel.
NOTE
If other chorus lines exist at the same position on the side of the staff where you want to change
your current selection to chorus lines, the two lines collide. To avoid this, change the type of the
whole lyric line, which automatically avoids collisions.

RELATED LINKS
Lyric line numbers on page 563
Showing lyrics in italics on page 567
Changing the line number and type of lyric lines on page 564

Types of syllables in lyrics
There are different types of syllables in lyrics, depending on their position in words. The key you
press to advance the popover indicates the syllable type for each lyric.
Dorico defines lyrics as different syllables depending on how you advance the popover when
inputting lyrics.
Whole Word
Lyrics are considered a whole word if the lyric comes after a gap and is followed by a
gap or a period.
No hyphens are shown either side of whole word lyrics. Extender lines can be shown
after lyrics.
Start
Lyrics are considered the start syllable in a multi-syllabic word if the lyric comes after
a gap, but is followed by a hyphen.
Hyphens are shown after start lyrics, which can be continuation hyphens depending
on the distance before the next lyric in the same lyric line.
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Middle
Lyrics are considered the middle syllable in a multi-syllabic word if the lyric comes
after a hyphen, and is followed by a hyphen.
Hyphens are shown after middle lyrics, which can be continuation hyphens
depending on the distance before the next lyric in the same lyric line.
End
Lyrics are considered the end syllable in a multi-syllabic word if the lyric comes after
a hyphen but is followed by a gap or a period.
Extender lines can be shown after end lyrics.
RELATED LINKS
Changing the syllable type of existing lyrics on page 556
Inputting lyrics on page 200

Changing the syllable type of existing lyrics
You can change the syllable type of lyrics after they have been input.
For example, if you advanced the lyrics popover to the next note by pressing Space but you later
want it to be followed by a hyphen, you can change its syllable type.
NOTE
Changing the syllable type changes whether a hyphen is shown after the selected lyrics, not
before them. Therefore, if you want to show a hyphen before lyrics, you must change the syllable
type of the lyrics immediately preceding them.

PROCEDURE
1.

Select the lyrics whose syllable type you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, select one of the following options from the Syllable type menu in
the Lyrics group:
●

Whole Word

●

Start

●

Middle

●

End

RESULT
Lyrics with a syllable type of Whole Word or End are followed by a space.
Lyrics with a syllable type of Start or Middle are followed by a hyphen.
RELATED LINKS
Types of syllables in lyrics on page 555
Inputting lyrics on page 200

Changing the text of existing lyrics
You can change the text of lyrics after they have been input.
PROCEDURE
1.

In Write mode, select the lyric you want to change.
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NOTE
You can only change one lyric at a time.
2.

Open the lyrics popover in any of the following ways:
●

Press Shift-L.

●

Double-click the lyric you want to change.

●

Choose Write > Create Lyrics.

●

Click Lyrics in the Notations toolbox.

●

Choose Write > Create Lyrics.

3.

Replace the existing text in the lyrics popover.

4.

Optional: If you want to change other existing lyrics as well, advance the popover in one of
the following ways:
●

Press Space to advance the popover to the next note if you entered a complete
word, or the final syllable in a multi-syllabic word.
NOTE
Existing lyrics are automatically selected in the popover when you press Space.

●

Press - to advance the popover to the next note if you entered one syllable of a
multi-syllabic word.

●

Press Right Arrow to move the cursor to the right.

●

Press Left Arrow to move the cursor to the left.
NOTE
The cursor automatically moves to the next or previous lyric or note if you keep
pressing the arrow keys.

5.

Press Return or Esc to close the popover when you have finished changing lyrics.
NOTE
The popover closes automatically when you reach the last note on the staff.

RELATED LINKS
Lyric line numbers on page 563
Inputting lyrics on page 200

Positions of lyrics
Dorico automatically positions lyrics and makes adjustments to accommodate variations in the
length of lyrics, including adjusting the horizontal alignment of lyrics in melismatic music.
However, you can also move lyrics manually and also change their default positions project-wide.
You can move lyrics to different rhythmic positions in Write mode. They are positioned by default
according to your chosen options on the Lyrics page in Engrave > Engraving Options.
You can move individual lyrics graphically in Engrave mode, but this does not change the
rhythmic positions to which they are attached.
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NOTE
The horizontal position of lyrics is automatically adjusted in Dorico to minimize changes to the
note spacing. Syllables are moved by small amounts either left or right to accommodate longer
syllables without distorting the appearance of note rhythms.
Moving lyrics graphically in Engrave mode overrides the automatic spacing for the selected lyrics.
If you move a lyric whose position was automatically readjusted, the note spacing at that
rhythmic position might change.
You can change the default positions of lyrics project-wide on the Lyrics page in Engraving
Options.
The default settings for lyrics on the Lyrics page in Engraving Options are optimized for scores
with comfortable spacing. If your project requires note spacing to be narrower, with less room
for each note, change these settings to achieve a clearly legible result without the need for lots of
editing in Engrave mode.
For scores that have less horizontal space, the following changes often improve the appearance
of lyrics and rhythmic space:
●

Make minimum gaps smaller, such as the minimum gap between lyrics and hyphens, in
the Hyphens section of the Lyrics page in Engraving Options.

●

Increase the amount that lyrics can be adjusted by in the Spacing section of the Lyrics
page in Engraving Options.

Positions of syllables
The number of notes sung on syllables or words determines how the lyrics are positioned:
●

Single syllables, which are whole words or parts of longer words that are sung on only one
note, are centered on their corresponding note.

●

Melismata, which are syllables or words that are sung on more than one note, are leftaligned with the left side of the first note to which they apply.

Placement of lyric lines
Lyrics are placed relative to other lyric lines according to their line number. For example, lyrics in
Line 1 are placed at the top, including when there are multiple lyric lines above the staff.
If a line of lyrics is missing across the width of a whole system, no additional gap is left between
the remaining lines of lyrics.
EXAMPLE
You have three lines of lyrics, but one system does not have a second line of lyrics. On this
system, the third line of lyrics is moved upwards, closer to the first line of lyrics.
If a subsequent system does not have a first line, but does have the second and third lines, then
the second and third lines of lyrics are moved upwards. The second line of lyrics takes the place
of the first line.
RELATED LINKS
Project-wide engraving options for lyrics on page 570
Moving lyrics rhythmically on page 559
Moving lyrics graphically on page 559
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Moving lyrics rhythmically
You can move lyrics to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the lyrics you want to move.

2.

Move the lyrics according to the current rhythmic grid value in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

NOTE
You cannot move lyrics rhythmically with the mouse, you can only move them using the
keyboard.

RESULT
The selected lyrics are moved to the right/left according to the current rhythmic grid value.
RELATED LINKS
Moving lyrics graphically on page 559

Moving lyrics graphically
You can move individual lyrics graphically without changing the rhythmic positions to which they
apply.
NOTE
Moving lyrics graphically in Engrave mode overrides the automatic spacing of the selected lyrics.
If you move a lyric whose position was automatically readjusted, the spacing at that rhythmic
position might change.

PROCEDURE
1.

In Engrave mode, select the lyrics you want to move.

2.

Move the selected lyrics in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them to the right/left.

RESULT
The selected lyrics are moved to the right/left.
NOTE
You cannot move lyrics upwards/downwards, as their vertical position is determined by their lyric
line number and your project-wide settings in Engrave > Engraving Options.
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TIP
You can change the line number of whole lyric lines, and the placement of whole lyric lines
relative to the staff. You can also change the position of lyrics relative to the staff, other lyric
lines, and to other objects for all lyrics project-wide in the Vertical Position section of the Lyrics
page in Engraving Options.

RELATED LINKS
Changing the line number and type of lyric lines on page 564
Changing the placement of lyric lines relative to the staff on page 565

Changing the alignment of lyrics relative to notes
By default, the center of lyrics is aligned horizontally with noteheads, but you can change the
horizontal alignment of individual lyrics.
You cannot change the alignment of lyrics relative to notes project-wide, as the horizontal
position of lyrics is automatically adjusted in Dorico to minimize changes to the note spacing.
NOTE
Changing the alignment of lyrics manually overrides the automatic spacing for the selected
lyrics. If you change the alignment of a lyric whose position was automatically readjusted, the
note spacing at that rhythmic position might change.

PROCEDURE
1.

Select the lyrics whose alignment you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Lyric text alignment in the Lyrics group.

3.

Select one of the following alignment options from the menu:
●

Left

●

Center

●

Right

RESULT
The alignment of the selected lyrics is changed.
RELATED LINKS
Moving lyrics rhythmically on page 559
Moving lyrics graphically on page 559

Lyric hyphens and lyric extender lines
Lyric hyphens indicate that individual lyrics are syllables within multi-syllabic words, for example,
“Hal-le-lu-jah”. Lyric extender lines indicate that individual lyrics extend across multiple notes.
Dorico automatically inputs and positions lyric hyphens when you advance the lyrics popover by
pressing - between syllables, and lyric extender lines when you advance the lyrics popover by
pressing Space multiple times after an entry.
In Engrave mode, lyric hyphens and lyric extender lines have two square handles, one at the start
and one at the end. You can move whole lyric hyphens and lyric extenders lines, and you can also
move their handles independently of each other. This allows you to lengthen/shorten lyric
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hyphens and extender lines, which for lyric hyphens means increasing/decreasing the length of
the space in which lyric hyphens are shown.

Lyric extender line with handles shown

Lyric hyphen with handles shown

RELATED LINKS
Moving lyric extender lines and hyphens on page 561
Lengthening/Shortening lyric extender lines and hyphens on page 562

Moving lyric extender lines and hyphens
You can move lyric extender lines and hyphens horizontally.
NOTE
You cannot move lyric extender lines or hyphens upwards/downwards, as their vertical position
is determined by their lyric line number and your project-wide settings in Engrave > Engraving
Options.

PROCEDURE
1.

In Engrave mode, select the lyric extender lines or hyphens that you want to move.

2.

Move the lyric extender lines or hyphens in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them to the right/left.

RESULT
The selected lyric extender lines or hyphens are moved to the right/left.
NOTE
●

The start handles of lyric extender lines are attached to the lyrics from which they extend,
and the start handles and end handles of lyric hyphens are attached to the lyrics on each
side. If you move either of those lyrics, the corresponding lyric extender line or hyphen
handles also move.

●

You can change the position of lyric extender lines and hyphens relative to lyrics, to the
ends of systems, and to other extender lines and hyphens for all lyric extender lines and
hyphens project-wide in the Extender Lines and Hyphens sections of the Lyrics page in
Engraving Options.

RELATED LINKS
Lyric hyphens and lyric extender lines on page 560
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Lengthening/Shortening lyric extender lines and hyphens on page 562

Lengthening/Shortening lyric extender lines and hyphens
You can lengthen/shorten individual lyric extender lines and lyric hyphens. Lengthening/
Shortening lyric hyphens increases/decreases the space in which lyric hyphens are shown.
NOTE
The start handles of lyric extender lines and hyphens are attached to the lyrics from which they
extend. If you move those lyrics, the start handles also move.

PROCEDURE
1.

In Engrave mode, select the square handles at one of the following positions on the lyric
extender lines or hyphens you want to lengthen/shorten:
●

The start of lyric extender lines or hyphens

●

The end of lyric extender lines or hyphens

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●
3.

Click and drag them to the right/left.

Optional: Repeat steps 1 and 2 for the other handle of the lyric extender lines or hyphens.

RESULT
The length of the selected lyric extender lines is changed. For example, moving the start handle
of a lyric extender line to the right without moving the end handle makes the line shorter.
Lengthening/Shortening lyric hyphens does not change the size or shape of the hyphens
themselves. Instead, you increase/decrease the distance between the handles in which hyphens
can appear.
NOTE
Depending on your settings for the size of gaps relating to hyphens in the Hyphens section of
the Lyrics page in Engrave > Engraving Options, more/fewer hyphens can appear in the space
when you lengthen/shorten lyric hyphens.
TIP
The following properties in the Lyrics group of the Properties panel are activated if you move the
corresponding handle on lyric extender lines and hyphens:
●

Line Start X moves the start handles of lyric extender lines and hyphens horizontally.

●

Line End X moves the end handles of lyric extender lines and hyphens horizontally.
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For example, if you move a whole lyric extender line to the right, both handles are moved so both
properties are activated. You can also use these properties to move lyric extender lines and
hyphens graphically by changing the values in the value fields.
Deactivating the properties resets the selected lyric extender lines and hyphens to their default
positions.

RELATED LINKS
Lyric hyphens and lyric extender lines on page 560

Deleting lyric lines
You can delete whole lines of lyrics.
PROCEDURE
1.

In Write mode, select the staves from which you want to delete a whole lyric line.

2.

Select just the lyric line you want to delete by choosing Edit > Filter > Lyrics > [Lyrics
type].

3.

Delete the lyric line in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
All lyrics in the selected lyric line are deleted.
RELATED LINKS
Filters for lyrics on page 553
Selecting lyrics using filters on page 554
Large selections on page 109

Deleting lyrics individually
You can delete individually selected lyrics without deleting other lyrics in the same lyric line.
PROCEDURE
1.

In Write mode, select the lyrics you want to delete.

2.

Delete the lyrics in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected lyrics are deleted.

Lyric line numbers
Lyric line numbers are used to organize lyrics when a single musical passage can have different
lyrics sung to it, such as music that contains multiple verses. In Dorico, you can specify the line
number of lyrics as you input them and by changing the line number of existing lyrics.
For example, if you input lyrics in Line 3 but later want to change those lyrics to Line 4 because
you want to input different lyrics as Line 3, you can change your current Line 3 into Line 4, and
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then input a new line of lyrics as Line 3. The spacing is automatically adjusted to show lyric lines
in the correct order.
In Dorico, you can have multiple lines of lyrics both above and below the same staff. Turning lyric
lines into chorus lyric lines or lyric line translations changes both their placement and
appearance as chorus lyrics generally use an italic font.
RELATED LINKS
Verse numbers on page 568
Filters for lyrics on page 553
Changing the line number and type of lyric lines on page 564
Changing the line number of individual lyrics on page 565
Showing lyrics in italics on page 567

Changing the line number and type of lyric lines
You can change the lyric line number of whole lyric lines after they have been input. You can also
change whole lyric lines to chorus lines and lyric line translations.
For example, you can change the existing Line 1 into a lyric translation of Line 4, or change Line 2
into a chorus line.
TIP
To identify which line you are working on, select a syllable in the line of lyrics and check the
number in the Line number value field in the Lyrics group of the Properties panel. Alternatively,
you can activate verse numbers on the Lyrics page in Engrave > Engraving Options.

PROCEDURE
1.

In Write mode, select a lyric in the line whose lyric line type you want to change. The lyric
line can be above or below the staff.
NOTE
You can also make a selection and use the lyric filters to select different lyric lines
according to their line numbers.

2.

Change the line type of the selected lyric line in one of the following ways:
●

Choose Edit > Lyrics > Line > [Line number].

●

Choose Edit > Lyrics > Line > Chorus.

●

Choose Edit > Lyrics > Translations > [Line number Translation].

●

Choose Edit > Lyrics > Translations > Chorus Translation.

TIP
You can also choose these options from the context menu.

RESULT
The line number or type of the whole lyric line of the selected lyric is changed.
NOTE
The position of the selected lyric line relative to other lyric lines at the same position might be
changed. For example, if there were two lyric lines and you changed Line 1 to Line 3, it now
appears below Line 2.
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If a lyric line with the same number already exists at the same position on the same side of the
staff, the two lines switch. For example, if there is already a Line 1 at the rhythmic position where
you want to change Line 2 to Line 1, then the existing Line 1 becomes Line 2 to accommodate
your most recent preference. The same applies to chorus lines and lyric line translations.

RELATED LINKS
Lyric line numbers on page 563
Types of lyrics on page 554
Filters for lyrics on page 553
Selecting lyrics using filters on page 554

Changing the line number of individual lyrics
You can change the lyric line number of individually selected lyrics after they have been input.
PROCEDURE
1.

Select the individual lyrics whose line number you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, change the value for Lyric number in the Lyrics group in any of
the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
The line number of the selected lyrics is changed to match the value in the value field.
NOTE
The position of the selected lyrics relative to other lyric lines might be changed. For example, if
there were two lyric lines and you changed lyrics in Line 1 to Line 3, they now appear below Line
2.

RELATED LINKS
Lyric line numbers on page 563

Changing the placement of lyric lines relative to the staff
You can change the placement of whole lyric lines relative to the staff after they have been input.
PROCEDURE
1.

In Write mode, select a lyric in each line whose placement relative to the staff you want to
change.
NOTE
You can also make a selection and use the lyric filters to select different lyric lines
according to their line numbers, and to select lyric lines according to their position relative
to the staff.

2.

Select the placement relative to the staff you want in one of the following ways:
●

Choose Edit > Lyrics > Placement > Above.

●

Choose Edit > Lyrics > Placement > Below.
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TIP
You can also choose these options from the context menu.

RESULT
The placement relative to the staff of the whole lyric lines in which you selected lyrics is changed.
NOTE
If other lyric lines with the same lyric line number exist at the same position on the side of the
staff to which you want to change your current selection, the two lines switch sides. For example,
if there is already a Line 2 above the staff at the position where you want to change the
placement of Line 2 below the staff, then the existing Line 2 above the staff is placed below the
staff to accommodate your most recent preference.

RELATED LINKS
Lyric line numbers on page 563
Filters for lyrics on page 553
Selecting lyrics using filters on page 554
Changing the line number and type of lyric lines on page 564

Changing the placement of individual lyrics relative to the staff
You can change the placement of individual lyrics relative to the staff after they have been input.
PROCEDURE
1.

Select the lyrics whose placement relative to the staff you want to change. You can do this
in Write mode and Engrave mode.

2.

In the Properties panel, choose one of the following options for Line placement in the
Lyrics group:
●

Above

●

Below

RESULT
The placement relative to the staff of the selected individual lyrics is changed.
NOTE
If other lyric lines with the same lyric line number already exist at the same position on the same
side of the staff, the two lines collide. To avoid this, change the lyric line number of one of the
lyric lines, or change their placement relative to the staff by choosing Edit > Lyrics > Placement
and selecting an option from the menu, which avoids collisions.

RELATED LINKS
Lyric line numbers on page 563
Changing the placement of lyric lines relative to the staff on page 565
Changing the line number and type of lyric lines on page 564
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Changing the font styles used for lyrics
You can change aspects of the fonts used for the available types of lyrics project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles.
The Edit Font Styles dialog opens.

2.

3.

Select the font you want to change from the Font style menu:
●

Lyrics Font

●

Lyrics translation Font

●

Lyrics verse numbers Font

●

Chorus lyrics Font

●

Chorus lyrics translation Font

Activate the following options, individually or together, to change the corresponding
aspect of the font:
●

Font family

●

Size

●

Style

●

Underlined

4.

Optional: Repeat steps 2 and 3 for each font whose style you want to change.

5.

Click OK to save your changes and close the dialog.

RESULT
The font style for the selected lyrics type is changed project-wide.
RELATED LINKS
Edit Font Styles dialog on page 275

Showing lyrics in italics
You can show individual lyrics in an italic font without changing their font style, lyric type, or
placement relative to the staff.
PROCEDURE
1.

Select the lyrics you want to show in an italic font. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Italic in the Lyrics group.

RESULT
The selected lyrics are shown in an italic font.
TIP
If you want to show lyrics in an italic font because they are intended to be either chorus lyrics or
translation lyrics, you can change their lyric type instead.
If you want all normal lyric lines to appear in an italic font project-wide, you can change the font
style of the Lyrics Font.
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RELATED LINKS
Changing the line number and type of lyric lines on page 564
Changing the type of individual lyrics on page 555
Changing the font styles used for lyrics on page 567

Verse numbers
Verse numbers indicate the order in which lyrics are sung when multiple lines of lyrics share the
same musical passage. They are commonly used in hymns and song sheets.
Depending on the type of music you are writing, verse numbers might not be appropriate.
Therefore, hiding/showing verse numbers in Dorico is optional. You can hide/show verse
numbers on all lines of lyrics project-wide and on individually selected lyrics.
In Dorico, verse numbers are only shown before the first lyric in the line by default. Therefore, if
you want to show the verse number at the start of subsequent systems, you must show verse
numbers on those individual lyrics.
NOTE
Lyric line translations are part of the lyric line of which they are a translation so do not have their
own verse number.

RELATED LINKS
Hiding/Showing verse numbers project-wide on page 568
Hiding/Showing verse numbers on individual lyrics on page 569

Hiding/Showing verse numbers project-wide
You can hide/show verse numbers project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Lyrics in the page list.

3.

In the Verse Numbers section, choose one of the following options for Verse numbers
for each line of lyrics:

4.

●

Show verse numbers

●

Do not show verse numbers

Click Apply, then Close.

RESULT
Verse numbers are either shown or hidden project-wide.

Changing the punctuation of verse numbers
You can change how verse numbers are punctuated project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Lyrics in the page list.

568

Lyrics
East Asian elision slurs
3.

4.

In the Verse Numbers section, choose one of the following options for Punctuation for
verse numbers:
●

Append period (full stop)

●

Do not append period (full stop)

Click Apply, then Close.

RESULT
Verse numbers are shown with/without a period project-wide.

Hiding/Showing verse numbers on individual lyrics
You can hide/show verse numbers on individual lyrics, independently of your project-wide
setting, for example, if you want to show the verse number at the start of every system.
PROCEDURE
1.

Select the lyrics before which you want to hide/show verse numbers. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Show verse number in the Lyrics group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Verse numbers are shown before the selected lyrics when both the property and the
corresponding checkbox are activated. Verse numbers are not shown when the property is
activated but the checkbox is deactivated.
When the property is deactivated, lyrics follow your project-wide setting for hiding/showing verse
numbers.
RELATED LINKS
Hiding/Showing verse numbers project-wide on page 568

East Asian elision slurs
East Asian elision slurs are used to show that two or more characters in East Asian languages are
part of the same lyric.

A phrase containing an East Asian elision slur

In Dorico, you can hide/show East Asian elision slurs on all applicable lyrics project-wide and on
individually selected lyrics.
RELATED LINKS
Hiding/Showing East Asian elision slurs on page 570
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Hiding/Showing East Asian elision slurs
You can hide/show East Asian elision slurs for individually selected lyrics, independently of your
project-wide setting.
PROCEDURE
1.

Select the lyrics on which you want to show East Asian elision slurs. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Show East Asian elision slur in the Lyrics
group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
East Asian elision slurs are shown on the selected lyrics when Show East Asian elision slur and
the corresponding checkbox are both activated, and hidden when the property is activated but
the checkbox is deactivated.
When the property is deactivated, lyrics follow your project-wide setting.
TIP
You can choose to hide/show East Asian elision slurs on all applicable lyrics project-wide on the
Lyrics page in Engrave > Engraving Options.

RELATED LINKS
East Asian elision slurs on page 569

Project-wide engraving options for lyrics
You can find options for the project-wide appearance and placement of lyrics on the Lyrics page
in Engraving Options.
The options on the Lyrics page allow you to change the default appearance, spacing, and
position of lyrics, and the appearance and position of lyric hyphens and lyric extender lines.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Lyrics in the page list on the left of the dialog.
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Notes are shapes that are positioned on staves to indicate musical pitches. Notes are most
commonly shown with oval-shaped, round noteheads that are either filled or void depending on
their duration, however there are many different designs of noteheads that you can use.
Depending on their duration, notes can have stems that help indicate their duration.
RELATED LINKS
Inputting notes on page 115
Project-wide engraving options for notes on page 571
Note spacing on page 284
Stems on page 711
Changing the notehead design project-wide on page 571
Changing the notehead design of individual noteheads on page 578
Add intervals popover on page 133
Adding notes above/below existing notes on page 133

Project-wide engraving options for notes
There are a number of options for the appearance of notes and noteheads project-wide that you
can choose from on the Notes page in Engraving Options.
The options on this page allow you to change the design, appearance, and position of noteheads,
ledger lines, stem flags, and rhythm dots. You can also change the appearance of double whole
notes (breves) and the size of grace notes relative to normal notes.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Notes in the page list on the left of the dialog.

Changing the notehead design project-wide
You can change the notehead design of all noteheads project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Notes in the page list.

3.

In the Noteheads section, select one of the following options for Notehead design:
●

Default noteheads (smaller than Larger noteheads)
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●

Larger noteheads (Default)

●

Note names

●

Figurenotes© colors

NOTE
This does not change the notehead design of noteheads whose design you have changed
individually.

RESULT
The notehead design of all notes project-wide is changed.
NOTE
You can also change the notehead design of individual noteheads, for example, so that selected
notes appear with slash noteheads or diamond noteheads.

RELATED LINKS
Changing the notehead design of individual noteheads on page 578

Showing differently shaped noteheads for each scale degree projectwide
You can show each degree of the scale with a different notehead design project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Notes in the page list.

3.

In the Noteheads section, select one of the following options for Shaped noteheads
based on scale degree:
●

Walker 4-shape

●

Walker 7-shape

●

Funk 7-shape

●

Aikin 7-shape

RESULT
The notehead design of all noteheads project-wide is changed to show a different notehead
design for each degree of the scale, depending on your selection.
NOTE
This does not override the notehead design of noteheads whose design you have changed
individually.

RELATED LINKS
Pitch-dependent notehead designs on page 577
Changing the notehead design of individual noteheads on page 578
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Showing note names in noteheads project-wide
You can show the note name as a letter in all noteheads project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Notes in the page list.

3.

In the Noteheads section, choose Note names for Notehead design.
NOTE
This does not change the notehead design of noteheads whose design you have changed
individually.

RESULT
The notehead design of all noteheads not overridden individually is changed to show the note
name inside noteheads.
NOTE
To ensure legibility, you can increase the staff size of layouts in your project.

RELATED LINKS
Changing the notehead design of individual noteheads on page 578
Staff size on page 702
Changing the staff size in layouts on page 702

Notehead designs
There are a number of different notehead designs that you can use for individual noteheads in
Dorico.
●

You can find the available notehead designs by choosing Edit > Notehead > [Notehead
type] > [Notehead design].

Notehead design appearance

Notehead design name
Larger Noteheads

Default Noteheads

Large Circled Noteheads
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Notehead design appearance

Notehead design name
Circled Noteheads

Slashed Noteheads (Bottom Left to Top Right)

Slashed Noteheads (Top Left to Bottom Right)

Cross noteheads
Notehead design appearance

Notehead design name
Circle X Noteheads

Large X and Diamond Noteheads

Ornate X Noteheads

Plus Noteheads

With X Noteheads

X Noteheads

X and Circle X Noteheads
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Notehead design appearance

Notehead design name
X and Diamond Noteheads

Triangular noteheads
Notehead design appearance

Notehead design name
Large Arrow Down Noteheads

Large Arrow Up Noteheads

Triangle Down Noteheads

Triangle Left Noteheads

Triangle Right Noteheads

Triangle Up Noteheads

Diamond noteheads
Notehead design appearance

Notehead design name
Diamond Noteheads

Old-Style Diamond Noteheads
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Notehead design appearance

Notehead design name
White Diamond Noteheads

Wide Diamond Noteheads

Slash noteheads
Notehead design appearance

Notehead design name
Muted Slash Noteheads

Oversized Slash Noteheads

Slash Noteheads

Small Slash Noteheads

Round and square noteheads
Notehead design appearance

Notehead design name
Moon Noteheads

Rectangular Noteheads

Round White with Dot Noteheads

RELATED LINKS
Pitch-dependent notehead designs on page 577
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Pitch-dependent notehead designs
Pitch-dependent noteheads use different notehead designs or different notehead colors
depending on the pitch of notes. There are a number of different pitch-dependent notehead
designs available in Dorico.
●

You can find the available notehead designs by choosing Edit > Notehead > [Notehead
type] > [Notehead design].

TIP
You can choose to use a pitch-dependent notehead design for all noteheads project-wide on the
Notes page in Engrave > Engraving Options.
Scale degree noteheads
Notehead design appearance

Notehead design name
Aikin 7-shape Noteheads

Funk 7-shape Noteheads

Walker 4-shape Noteheads

Walker 7-shape Noteheads

Pitched noteheads
Notehead design appearance

Notehead design name
Figurenotes© noteheads

Pitch name noteheads

RELATED LINKS
Changing the notehead design of individual noteheads on page 578
Showing differently shaped noteheads for each scale degree project-wide on page 572
Showing note names in noteheads project-wide on page 573
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Changing the notehead design of individual noteheads
You can change the notehead design of individual noteheads. For example, cross noteheads
might be used to indicate where players should produce pitchless sounds, such as air sounds on
wind instruments.
PROCEDURE
1.

Select the noteheads whose design you want to change. You can do this in Write mode
and Engrave mode.

2.

Choose Edit > Notehead > [Notehead type] > [Notehead design].
For example, to change the notehead design of the selected notes to X noteheads, choose
Edit > Notehead > Crosses > X Noteheads.
TIP
You can also choose these options from the context menu.

RESULT
The notehead design of the selected notes is changed.
NOTE
You can also change the notehead design for all noteheads project-wide.

RELATED LINKS
Changing the notehead design project-wide on page 571

Moving notes rhythmically
You can move notes, including grace notes, to different rhythmic positions along staves after
they have been input.
PROCEDURE
1.

In Write mode, select the notes you want to move.

2.

Move the selected notes according to the current rhythmic grid value in any of the
following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

RESULT
The selected notes are moved to new rhythmic positions according to the current rhythmic grid
value. If you selected multiple notes, they are moved together as a block.
Notes are automatically positioned according to their rhythmic duration and position relative to
other notes.
NOTE
If Chords is not activated and any of your selected notes collide with other notes in the same
staff and at the same rhythmic position that are in the same voice as your selected notes, the
existing notes are deleted and replaced with your selected notes.

RELATED LINKS
Rhythmic grid on page 105
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Inputting chords on page 129
Notes toolbox on page 98
Note spacing on page 284
Creating cross-staff beams on page 411

Changing the size of notes
You can change the size of notes individually using the default sizes for notes in cues or grace
notes.
TIP
●

You can change the size of all notes project-wide by changing the notehead design on the
Notes page in Engrave > Engraving Options. However, these options offer less flexibility
than changing the size of notes individually.

●

If you want to change the size of notes because you want them to be grace notes, or
because you want them to be cues, you can input them as either grace notes or cues
instead.

PROCEDURE
1.

Select the notes whose size you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Scale in the Common group.

3.

Select one of the following options from the menu:
●

Normal

●

Grace

●

Cue

●

Cue grace

RELATED LINKS
Inputting grace notes on page 128
Inputting cues on page 216
Notehead designs on page 573

Changing the custom scale size of notes
You can change the size of notes according to a custom scale if you want to change the size of
notes to a size other than those available from the Scale menu in the Common group of the
Properties panel.
NOTE
If you want to change the size of notes because you want them to be grace notes, or because
you want them to be cues, you can input them as either grace notes or cues instead.

PROCEDURE
1.

Select the notes whose custom scale size you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Custom Scale in the Common group.

3.

Change the Custom Scale percentage value in any of the following ways:
●

Enter a value into the value field.
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●

Click the arrows beside the value field.

RESULT
The size of the notes is changed according to the percentage change.
NOTE
If you have also activated Scale, the percentage change for Custom Scale is based on the
selected size option for Scale.

RELATED LINKS
Inputting grace notes on page 128
Inputting cues on page 216
Notehead designs on page 573

Changing the width of ledger lines
You can change the width of ledger lines on individual notes, for example, to allow notes with
short durations to be spaced more tightly and still be legible.
PROCEDURE
1.

In Engrave mode, select the notes whose ledger line width you want to change.

2.

In the Properties panel, activate Ledger line in the Notes and Rests group.

3.

Change the values in the Ledger line L and R value fields in any of the following ways:
●

Enter values in the value fields.

●

Click the arrows beside the value fields.

RESULT
The width of the ledger lines is changed in the following ways:
●

Increasing Ledger line L makes the left side of ledger lines longer, decreasing the value
makes the left side of ledger lines shorter.

●

Increasing Ledger line R makes the right side of ledger lines longer, decreasing the value
makes the right side of ledger lines shorter.

TIP
You can change the width of all ledger lines project-wide on the Notes page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide engraving options for notes on page 571

Changing the consolidation of rhythm dots
You can change how rhythm dots in multiple voices are consolidated at individual rhythmic
positions, independently of your project-wide setting.
PROCEDURE
1.

In Engrave mode, select the notes whose rhythm dot consolidation you want to change.

2.

In the Properties panel, activate Rhythm dot consolidation in the Notes and Rests
group.
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3.

Select one of the following options from the menu:
●

None

●

Allowed

●

Unisons only

●

Aggressive

RESULT
The consolidation of rhythm dots for the selected notes is changed.
TIP
You can change how rhythm dots in multiple voices are consolidated project-wide on the Notes
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for notes on page 571
Rhythm dot consolidation on page 809

Specifying on which string individual notes are played
You can specify on which string individually selected notes are played when notes are in the
staves of string instruments, such as violins or cellos. Many notes can be played on multiple
strings, depending on where along its length the string is stopped.
Specifying the string can be useful for notes that also have glissando lines or fingering shifts, as
the string and finger position required to play the note affects the direction of these changes.
However, the string number is not shown in the music. You can instead input fingerings, which
can help string players understand the string on which they should play.
NOTE
You can only specify strings on notes belonging to string instruments.

PROCEDURE
1.

Select the notes whose assigned string you want to change. You can do this in Write mode
and Engrave mode.
NOTE
If selecting multiple notes at once, select notes only in staves of the same instrument type.
For example, select multiple Cs in Violin 1 and Violin 2 staves.

2.

In the Properties panel, activate String in the Notes and Rests group.

3.

Select your preferred string from the menu.
The string number for the instrument is shown, followed by the fundamental pitch and the
octave number of that string in parentheses. For example, the lowest cello string is
expressed as 4 (C2).
NOTE
The options available in the menu depend on the selected pitches and the instrument
type.
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RESULT
The string on which the selected notes are played is changed.
NOTE
If you subsequently change the pitches of notes, String is automatically deactivated for all notes
that can no longer be played on their specified string.

RELATED LINKS
Glissando lines on page 600
Changing the direction of string fingering shift indicators on page 511

Deleting notes
You can delete notes from your project without deleting other items, such as dynamics, octave
lines, or playing techniques.
PROCEDURE
1.

In Write mode, select the notes you want to delete.

2.

Delete the notes in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The selected notes are deleted from your project and are replaced by implicit rests as
appropriate.
If a slur began or ended on a deleted note, the slur is automatically repositioned to the next/
previous notehead. If only one note is left under a slur, the slur is automatically deleted.
Holds and pauses are not deleted. They are positioned above the note/rest closest to their
rhythmic position, or over whole bar rests if you delete all notes in a bar.
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Ornaments are markings that indicate multiple notes are played in addition to the notated pitch.
They are used to decorate music, such as in Baroque music, which is highly decorated with trills
and other ornaments.
Over time, specific ways of notating how performers should play notes have developed and
different ornament symbols indicate different patterns of decorative notes. Nonetheless,
ornaments give some freedom to performers to embellish music in their own way.
Dorico offers a range of ornament symbols to allow you to notate different styles of ornaments.
The term “ornaments” covers a wide range of decorative notes, including:
●

Mordents

●

Trills

●

Turns

●

Grace notes

●

Acciaccaturas

●

Appoggiaturas

In Dorico, the term “ornaments” refers to ornament symbols and trill glyphs that are input above
notes.

Some of the ornaments available in Dorico

RELATED LINKS
Input methods for ornaments, arpeggio signs, and glissando lines on page 185
Grace notes on page 517

General placement conventions for ornaments
Ornaments, including trills, are placed above the notes to which they apply. They are only placed
below the staff when there are multiple voices on the staff.
Ornaments and trills are positioned outside of slurs by default. Similarly, they are positioned
further from noteheads than articulations.
The center of ornaments should align with the center of the notehead to which they apply.
Trills are aligned differently, as the left side of trill glyphs should align with the left edge of the
notehead to which the trill applies.
Dorico automatically positions ornaments correctly according to their type, and attaches them to
their notehead.
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Changing the intervals of ornaments
You can change the default positions and styles of ornaments and trills on the Ornaments page
in Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for ornaments on page 590
Changing the position of ornaments relative to slurs on page 589

Changing the intervals of ornaments
You can change the intervals of ornaments, both above and below the notated pitch, to indicate
which pitches are played in the ornament. The intervals of ornaments are indicated by
accidentals.
For some ornaments, you can only change the interval in one direction. For example, you can
only change the interval above short trills and below mordents.
PROCEDURE
1.

Select the ornaments whose intervals you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate the appropriate properties for the selected ornaments in
the Ornaments group:
●

Interval above

●

Interval below

For trills, activate Interval in the Trills group of the Properties panel.
3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
The properties change the interval of the selected ornaments in the following ways:
●

0 or 4 and above shows no accidental.

●

1 shows a flat.

●

2 shows a natural.

●

3 shows a sharp.

NOTE
●

Some ornaments do not show accidentals either above or below, depending on their type.

●

You can change the position of ornament accidentals relative to all trills project-wide on
the Ornaments page in Engrave > Engraving Options.

EXAMPLE
No accidentals

Flats above and
below
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RELATED LINKS
Project-wide engraving options for ornaments on page 590

Changing the position of ornament accidentals relative to trills
You can change where ornament accidentals are positioned relative to individual trills,
independently of your project-wide setting.
Ornament accidentals indicate the interval of trills by telling the performer which notes to
include in the ornament. For example, a trill on an E with a sharp ornament accidental indicates
the performer trills between E and F♯, rather than between E and F.
PROCEDURE
1.

Select the trills whose ornament accidental position you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Accidental position in the Trills group.

3.

Select one of the following options from the menu:
●

Above

●

Below

●

On the right

RESULT
The position of ornament accidentals relative to the selected trills is changed.
TIP
You can change the default position of ornament accidentals relative to all trills project-wide on
the Ornaments page in Engrave > Engraving Options.

Changing the speed of trills
You can indicate different speeds for trills, and indicate a change of speed within a single trill by
changing the height and frequency of the waves in their extension lines.
PROCEDURE
1.

Select the trills whose speed you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Trills group:

3.

●

Start speed

●

End speed

Select one of the following options from each property menu:
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●

Slow

●

Normal

●

Fast

RESULT
The speed of the selected trills is changed.
If only Start speed is activated, the speed of the whole trill extension line is changed.
If only End speed is activated, the speed of the end half of the trill extension line is changed.
EXAMPLE

A trill extension line starting slow and ending fast

Lengthening/Shortening trills rhythmically
You can lengthen/shorten trills after they have been input. Multiple ornaments can exist at the
same rhythmic position, so you can also lengthen/shorten trills to noteheads that already have
ornaments.
PROCEDURE
1.

In Write mode, select the trills you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one trill at a time.

2.

Lengthen/Shorten the trills in any of the following ways:
●

Press Shift-Alt-Right Arrow to lengthen them by the current rhythmic grid value.

●

Press Shift-Alt-Left Arrow to shorten them by the current rhythmic grid value.

●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to lengthen a single trill to the next
notehead.

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to shorten a single trill to the previous
notehead.
NOTE

●

●

You can only lengthen/shorten trills by the current rhythmic grid value when
multiple trills are selected.

●

When using the keyboard, you can only move the end of trills. You can move
the start of trills by moving the whole trill, or by clicking and dragging the
start handle.

Click and drag the circular handle at the start/end of the trill to noteheads to the
right/left.

RESULT
Single trills are lengthened/shortened according to the current rhythmic grid value or to the
next/previous notehead, whichever is closer.
Multiple trills are lengthened/shortened according to the current rhythmic grid value.

586

Ornaments
Hiding/Showing trill extension lines
NOTE
Key commands lengthen/shorten items by moving their end only.

RELATED LINKS
Positions of ornaments on page 587
Moving ornaments rhythmically on page 588
Moving ornaments graphically on page 588

Hiding/Showing trill extension lines
You can hide/show the extension lines of individual trills.
PROCEDURE
1.

Select the trills whose extension lines you want to hide/show. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Has trill line in the Trills group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Trill extension lines are shown when the checkbox is activated, and hidden when the checkbox is
deactivated.
When the property is deactivated, trills follow your project-wide setting.
TIP
You can hide/show trill extension lines on all trills project-wide on the Ornaments page in
Engrave > Engraving Options.

Positions of ornaments
You can change the positions of ornaments individually and by changing their default positions
project-wide. For example, you can override the default position for individual ornaments if you
want them to be positioned higher or lower at certain positions.
You can move ornaments to different rhythmic positions in Write mode. They are positioned by
default according to your settings in Engraving Options.
You can move ornaments graphically in Engrave mode, however this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all ornaments project-wide on the Ornaments page in
Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for ornaments on page 590
Moving ornaments rhythmically on page 588
Moving ornaments graphically on page 588
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Moving ornaments rhythmically
You can move ornaments to new rhythmic positions.
PROCEDURE
1.

In Write mode, select the ornaments you want to move.
NOTE
When using the mouse, you can only move one ornament at a time.

2.

Move the ornaments in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the ornament to the right/left to snap it to different rhythmic
positions.

RESULT
A single ornament is moved to the next or previous notehead on that staff.
Multiple ornaments are moved according to the current rhythmic grid value.
RELATED LINKS
Moving ornaments graphically on page 588

Moving ornaments graphically
You can move ornaments graphically without changing the rhythmic positions to which they
apply. You can also move the start/end handles of trills independently of each other, meaning
you can lengthen/shorten trills graphically.
PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Ornaments or trills

●

Individual handles on trills

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the ornaments or handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.
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RESULT
The selected items are moved graphically, without affecting the rhythmic positions to which they
are attached.
TIP
Offset in the Common group of the Properties panel is activated automatically when you move
ornaments.
●

Offset X moves ornaments horizontally.

●

Offset Y moves ornaments vertically.

The following properties in the Trills group of the Properties panel are activated automatically
when you move trills:
●

Start offset moves whole trills. X moves them horizontally, Y moves them vertically.

●

End offset X moves the end of trill extension lines horizontally.

For example, if you move a whole trill to the right, both handles are moved so both properties
are activated. You can also use these properties to move ornaments/trills and lengthen/shorten
trills graphically by changing the values in the value fields.
Deactivating the properties resets the selected ornaments and trills to their default positions.

Changing the placement of ornaments relative to the staff
Ornaments are usually placed above the staff, but they are placed below the staff for down-stem
voices when there are multiple voices on the staff. You can change the placement of ornaments
individually.
PROCEDURE
1.

Select the ornaments whose placement relative to the staff you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Placement in the corresponding group for the selected
ornaments:

3.

●

Ornaments

●

Trills

Choose one of the following options:
●

Above

●

Below

RESULT
The placement of the selected ornaments is changed.

Changing the position of ornaments relative to slurs
Ornaments are positioned outside of slurs by default. You can change the position of ornaments
relative to slurs individually.
PROCEDURE
1.

In Engrave mode, select the ornaments whose slur-relative position you want to change.

2.

In the Properties panel, activate Slur-relative position in the corresponding group for the
selected ornaments:
●

Ornaments
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●
3.

Trills

Choose one of the following options:
●

Inside

●

Outside

RESULT
The selected ornaments are positioned either inside or outside of slurs.

Changing the start position of trills
You can change whether the start position of individual trills is aligned with the notehead or with
its accidental, independently of your project-wide setting.
PROCEDURE
1.

Select the trills whose start position you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Start position in the Trills group.

3.

Choose one of the following options:
●

Notehead

●

Accidental

RESULT
The start position of the selected trills is changed.
TIP
You can change the start position of all trills project-wide on the Ornaments page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide engraving options for ornaments on page 590

Project-wide engraving options for ornaments
You can find options for the project-wide appearance and position of ornaments on the
Ornaments page in Engraving Options.
The options on the Ornaments page allow you to change the position of trills relative to
accidentals, noteheads, and trill extension lines. You can also set the minimum distance between
ornaments and the staff and noteheads.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Ornaments in the page list on the left of the dialog.
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Arpeggio signs are vertical lines that indicate chords are to be played arpeggiated, or “spread”,
so that the notes in the chord are played very quickly one after another. Arpeggio signs are
normally shown with wavy lines similar to trill extension lines.
Arpeggiated chords can be played in two directions:
●

Upwards, starting from the bottom note in the chord.

●

Downwards, starting from the top note in the chord.

Dorico offers the following types of arpeggio signs:
Up arpeggio
A vertical wavy line that indicates chords are to be arpeggiated from the bottom note
upwards.
Down arpeggio
A vertical wavy line that indicates chords are to be arpeggiated from the top note
downwards.
Non arpeggio
A bracket with straight lines that indicates all notes in the chord are to be played
together, not arpeggiated.

Default up arpeggio

Default down arpeggio

Default non arpeggio

It is most common for up arpeggios to be shown with nothing at the top end, because chords
are usually arpeggiated upwards, and for down arpeggios to be shown with an arrow at the
bottom, so this is the default in Dorico. However, it is also accepted practice to show up
arpeggios with an arrow at the top if down arpeggios are also used in the same piece of music.
You can show both up arpeggios and down arpeggios with one of three ends in Dorico:
●

Nothing

●

Arrow

●

Swash
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Up arpeggio with nothing at the
end

Up arpeggio with an arrow at the
end

Up arpeggio with a swash at the
end

RELATED LINKS
Input methods for ornaments, arpeggio signs, and glissando lines on page 185

General placement conventions for arpeggio signs
Arpeggio signs are positioned to the left of the notes, including any applicable accidentals, to
which they apply, but are positioned between grace notes and normal notes. They should appear
within the same bar as the notes to which they apply, and not on the other side of the barline.
Dorico makes automatic adjustments to note spacing and staff spacing to accommodate
arpeggio signs and ensure they are positioned correctly.
Arpeggio signs should cover the whole vertical range of all notes in the chord to which they
apply, and protrude slightly at each end. However, they do not need to cover the stems of notes.
Dorico automatically creates the lengths of arpeggio signs to cover the notes in chords, and
adjusts their lengths if the notes in chords change or are deleted.
If an arpeggiated chord spans two staves, such as in a piano part, its arpeggio sign can extend
across both staves.
RELATED LINKS
Project-wide engraving options for arpeggio signs on page 597

Changing the type of arpeggio signs
You can change the type of arpeggio signs after they have been input.
PROCEDURE
1.

Select the arpeggio signs whose type you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, select one of the following options from the Arpeggio type menu
in the Arpeggios group:
●

Non arpeggio

●

Up arpeggio

●

Down arpeggio

RESULT
The type of the selected arpeggio signs is changed.
RELATED LINKS
Arpeggio signs on page 591
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Changing the end appearance of arpeggio signs
Down arpeggio signs have an arrowhead at the bottom of the line by default, but up arpeggio
signs have no arrowhead by default. You can change the appearance of the ends of arpeggio
signs individually, independently of your project-wide settings.
PROCEDURE
1.

Select the arpeggio signs of any direction whose ends you want to change. You can do this
in Write mode and Engrave mode.
NOTE
You cannot change the ends of non arpeggio signs.

2.

In the Properties panel, activate Sign end in the Arpeggios group.

3.

Select the end you want from the menu:
●

Nothing

●

Arrow

●

Swash

RESULT
The appearance of the ends of the selected arpeggio signs is changed.
TIP
You can change the default appearance of the ends of all arpeggio signs project-wide on the
Arpeggio Signs page in Engrave > Engraving Options.
EXAMPLE

Up arpeggio sign with nothing at
the end

Up arpeggio sign with an arrow at
the end

Up arpeggio sign with a swash at
the end

RELATED LINKS
Arpeggio signs on page 591

Length of arpeggio signs
Dorico automatically adjusts the length of arpeggio signs when the pitches of the notes in the
voices to which the sign applies change, or when you add notes to the chords or delete notes
from the chords.
You can change how far arpeggio signs extend beyond the outer notes in all chords project-wide
on the Arpeggio Signs page in Engrave > Engraving Options. You can set different values for
when notes are on staff lines and in staff spaces.
You can also lengthen/shorten individual arpeggio signs.
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RELATED LINKS
Project-wide engraving options for arpeggio signs on page 597
Lengthening/Shortening arpeggio signs on page 594

Lengthening/Shortening arpeggio signs
You can lengthen/shorten individual arpeggio signs manually. For example, you might lengthen
an arpeggio sign on a chord with a small pitch range so the arpeggio sign is more clearly visible.
PROCEDURE
1.

In Engrave mode, select the square handles at one end of the arpeggio signs you want to
lengthen/shorten.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Lengthen/Shorten the arpeggio signs by moving the handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●

Click and drag them upwards/downwards.

RESULT
The selected arpeggio signs are lengthened/shortened graphically.
TIP
The following properties in the Arpeggios group of the Properties panel are activated
automatically when you move the corresponding end of arpeggio signs:
●

Top Y offset moves the handles at the top of arpeggio signs.

●

Bottom Y offset moves the handles at the bottom of arpeggio signs.

For example, if you move a whole arpeggio sign, both handles are moved so both properties are
activated. You can also use these properties to lengthen/shorten arpeggio signs graphically by
changing the values in the value fields.
Deactivating the properties resets the selected arpeggio signs to their default positions.
TIP
You can change how far arpeggio signs extend beyond the outer notes in all chords project-wide
on the Arpeggio Signs page in Engrave > Engraving Options.

RELATED LINKS
Moving arpeggio signs graphically on page 595
Project-wide engraving options for arpeggio signs on page 597

594

Arpeggio signs
Positions of arpeggio signs

Positions of arpeggio signs
You can change the position of arpeggio signs individually and by changing their default
positions project-wide. For example, you can make individual arpeggio signs extend further than
the default length if they appear too short at certain positions.
You can move arpeggio signs to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.
You can move arpeggio signs graphically in Engrave mode, however, this does not change the
rhythmic positions to which they are attached.
You can change the default position of all arpeggio signs project-wide on the Arpeggio Signs
page in Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for arpeggio signs on page 597
Length of arpeggio signs on page 593
Moving arpeggio signs rhythmically on page 595
Moving arpeggio signs graphically on page 595

Moving arpeggio signs rhythmically
You can move arpeggio signs to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the arpeggio signs you want to move.

2.

Move the arpeggio signs in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

NOTE
You cannot move arpeggio signs rhythmically with the mouse.

RESULT
Arpeggio signs are moved to the right/left, according to the current rhythmic grid value.
If no notes exist at the next rhythmic position according to the rhythmic grid, the arpeggio sign is
not shown. If you continue moving it to the right/left, it is shown again beside the next note at a
rhythmic position that can be reached according to the current rhythmic grid value.
You can change the rhythmic grid if you want to move arpeggio signs to notes at other rhythmic
positions.
NOTE
Only one arpeggio sign can exist at each rhythmic position. If an arpeggio sign in your selection
passes over another arpeggio sign as part of its move, the existing arpeggio sign is deleted.

Moving arpeggio signs graphically
You can move arpeggio signs graphically without changing the rhythmic positions to which they
apply.
PROCEDURE
1.

In Engrave mode, select the arpeggio signs you want to move.
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2.

Move the arpeggio signs in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The selected arpeggio signs are moved graphically, without affecting the rhythmic positions to
which they apply.
TIP
The following properties in the Arpeggios group of the Properties panel are activated
automatically when you move the corresponding part of arpeggio signs:
●

Top Y offset moves the top of arpeggio signs vertically.

●

Bottom Y offset moves the bottom of arpeggio signs vertically.

●

X offset moves whole arpeggio signs horizontally.

For example, if you move a whole arpeggio sign upwards, both handles are moved, so Top Y
offset and Bottom Y offset are both activated. You can also use all three properties to move
arpeggio signs graphically by changing the values in the value fields.
Deactivating the properties resets the selected arpeggio signs to their default position.

RELATED LINKS
Lengthening/Shortening arpeggio signs on page 594

Showing arpeggio signs before/after grace notes
You can show arpeggio signs before/after grace notes individually. By default, arpeggio signs are
positioned immediately to the left of the notes to which they apply, and so are positioned
between normal notes and grace notes.
PROCEDURE
1.

Select the arpeggio signs you want to show before grace notes. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Arpeggio before grace notes in the
Arpeggios group.

RESULT
The selected arpeggio signs are shown before grace notes when the property is activated, and
after grace notes when the property is deactivated.

596

Arpeggio signs
Project-wide engraving options for arpeggio signs

Project-wide engraving options for arpeggio signs
You can find options for the project-wide appearance and position of arpeggio signs on the
Arpeggio Signs page in Engraving Options.
The options on this page allow you to change the design, appearance, and precise position of
arpeggio signs.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Arpeggio Signs in the page list on the left of the dialog.

Arpeggios in playback
You can find options to control the playback of all arpeggios project-wide in the Arpeggio Signs
section of the Timing page in Playback Options.
For example, you can control whether arpeggiation starts on the beat or ends on the beat, and
the speed of arpeggiation.
You can set a default arpeggio length, expressed as a fraction of a quarter note (crotchet) at
120 bpm. It can be helpful to set arpeggio lengths using this measurement instead of defining
arpeggios as a fraction of their notated rhythm, as otherwise arpeggios in very slow music would
play back much slower than most people intend.
As well as setting a default length for arpeggios, you can also set minimum and maximum values
for the length of arpeggios, expressed as a fraction of the notated value of the arpeggio. This is
to ensure all notes with arpeggio signs can be heard within their notated duration.
You can open Playback Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-P in any mode.

●

Choose Play > Playback Options in Play mode.

NOTE
You can also use properties in the Arpeggios Playback group of the Properties panel to override
the default playback options for individual arpeggio signs.

RELATED LINKS
Changing arpeggio playback relative to the beat individually on page 597

Changing arpeggio playback relative to the beat individually
You can change whether individual arpeggios are played before their notated position or after
their notated position, independently of your project-wide settings.
PROCEDURE
1.

Select the arpeggio signs whose playback relative to the beat you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Playback position in the Arpeggios Playback group.

3.

Choose one of the following options:
●

Start on beat
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●

Ends on beat

RESULT
The beat-relative position of the selected arpeggios in playback is changed.
TIP
You can change the playback of all arpeggios relative to the beat project-wide on the Timing
page in Play > Playback Options.
EXAMPLE

Arpeggio starting on the beat

Arpeggio ending on the beat

RELATED LINKS
Arpeggios in playback on page 597
Playback Options dialog on page 312

Changing the playback duration of arpeggios individually
You can change the duration of individual arpeggios in playback, independently of your projectwide settings.
The duration of arpeggios is expressed as a fraction of the notated rhythm of chords. For
example, an arpeggio on a quarter note (crotchet) chord with a note offset value of 1/2 lasts an
eighth note (quaver), whereas with a note offset value of 1/8 it lasts a 32nd note.
PROCEDURE
1.

Select the arpeggio signs whose playback offset you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Note offset in the Arpeggios Playback group.

3.

Change the value in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Save the new value in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The playback duration of the selected arpeggios is changed. This overrides your project-wide
settings for the duration of arpeggios for the selected arpeggios.
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EXAMPLE

Arpeggiated chord with a note offset value of 1/8

RELATED LINKS
Arpeggios in playback on page 597
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Arpeggiated chord with a note offset value of 1/2

Glissando lines

Glissando lines indicate a continuous transition between two notes, which can be smooth or in
chromatic steps. They can have straight lines or wavy lines, and can be shown with a text
indication or as a line without text.
There are different conventions regarding the playing techniques for glissando and portamento.
Some people understand glissando lines to indicate a chromatic scale between the two notes,
either rising or falling in a series of semitones, and portamento lines to indicate a smooth,
continuous glide between the two notes. However, the terms glissando and portamento can be
used interchangeably in other cases.
You can input both glissando lines and portamento lines in Dorico, and you can easily change
their style after they have been input.

An example glissando line with text shown and a
wavy line

An example portamento line with text shown and a
straight line

RELATED LINKS
Input methods for ornaments, arpeggio signs, and glissando lines on page 185

General placement conventions for glissando lines
Glissando lines are positioned between noteheads and the steepness of their angle should
reflect the interval between the notes: the steeper the angle, the greater the interval. The
endpoints of glissando lines must be directly beside noteheads but not directly touching them.
Glissando lines must not collide with accidentals, and instead must stop short so the accidental
can be clearly read. Dorico automatically positions glissando lines so they do not collide with
accidentals.
Usually, glissando lines join two adjacent noteheads because they indicate a gradual but
constant change in pitch between those two notes, but they can also cross multiple notes.
Glissando lines can cross system breaks and page breaks. If text is shown for glissando lines that
span across a system break or page break, then that text is shown on every part of the glissando
line. By default, the start position and end position of each segment matches the original start
point and end point of the whole glissando line.
In Dorico, you can make detailed adjustments to the default positions of glissando lines on the
Glissando Lines page in Engrave > Engraving Options. You can also adjust the start/end
positions of individual glissando lines in Engrave mode.
RELATED LINKS
Project-wide engraving options for glissando lines on page 605
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Glissando lines across empty bars
In Dorico, you can input glissando lines between any two notes, even if there are rests or other
notes between them, and including between notes in different voices and notes on different
staves.
For very long glissando lines that extend across multiple bars, you might not want to show
pitches at the start of each bar, for example, to indicate that performers do not emphasize
pitches during the course of the glissando, or that performers can play the glissando at their own
speed. By default, Dorico shows notes or rests in every bar.
Once you have input a glissando line between the selected notes, you can hide/show any implicit
rests between them.
NOTE
If there are any explicit rests between the notes at each end of the glissando line, you must first
turn them into implicit rests.
EXAMPLE

A glissando line across multiple bars with no rests shown between the two notes

RELATED LINKS
Inputting glissando lines with the popover on page 190
Inputting glissando lines with the panel on page 191
Hiding/Showing bar rests in empty bars on page 376
Hiding/Showing rests after the last note in voices on page 809
Hiding/Showing rests before the first note in voices on page 808
Turning explicit rests into implicit rests on page 658

Changing the style of glissando lines
Glissando lines can be shown as straight lines or wiggly lines. You can change the glissando line
style of glissando lines individually, independently of your project-wide setting.
PROCEDURE
1.

Select the glissando lines whose style you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Glissando style in the Glissando Lines group.

3.

Choose one of the following options:
●

Straight line

●

Wavy line
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RESULT
The glissando line style is changed for the selected glissando lines.
TIP
●

Deactivating Glissando style returns the selected glissando lines to the default style.

●

You can change the default style for all glissando lines project-wide on the Glissando
Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for glissando lines on page 605

Changing glissando line text
Glissando lines can be shown with text or without text. You can change the text of glissando lines
individually, independently of your project-wide setting.
PROCEDURE
1.

Select the glissando lines whose text you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Glissando text in the Glissando Lines group.

3.

Select one of the following options from the menu:
●

Gliss

●

Port

●

No text

RESULT
The text shown on the selected glissando lines is changed.
TIP
You can change the text shown on all glissando lines project-wide on the Glissando Lines page
in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for glissando lines on page 605

Changing when glissando line text is shown
By default, glissando text is not shown when glissando lines are too short to accommodate the
text. You can choose to show text on individual glissando lines always, or only if there is sufficient
space.
PROCEDURE
1.

Select the glissando lines whose setting for when text is shown you want to change. You
can do this in Write mode and Engrave mode.
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2.

In the Properties panel, activate Glissando text shown in the Glissando Lines group.

3.

Choose one of the following options:
●

Show if sufficient space

●

Always show

RESULT
If Show if sufficient space is chosen, glissando line text is not shown if the glissando line is too
short.
If Always show is chosen, glissando line text is always shown, even if the glissando line is short.
However, this can cause the glissando line text to collide with other items, such as noteheads and
stems.
TIP
You can increase the gaps between individual noteheads by adjusting note spacing in Engrave
mode.

RELATED LINKS
Adjusting note spacing at individual rhythmic positions on page 291
Adjusting the spacing of individual notes/items independently of their rhythmic positions on
page 292

Moving glissando lines graphically
You can move individual glissando lines graphically without changing the rhythmic positions to
which they are attached. You can move each end of glissando lines independently, meaning you
can also adjust the angle and graphical length of individual glissando lines.
If glissando lines cross system and frame breaks, you can move each glissando line segment
independently.
NOTE
You cannot move glissando lines rhythmically. If you want to change the rhythmic positions of
glissando lines, you must delete them from their original positions and input new glissando lines
at the new positions.

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Whole glissando lines, or glissando line segments

●

Individual handles on glissando lines

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the glissando lines or handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
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TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.
●

Click and drag them in any direction.

RESULT
The selected glissando lines or handles are moved graphically, without affecting the rhythmic
positions to which they are attached.
TIP
The following properties in the Glissando Lines group of the Properties panel are activated
automatically when you move the corresponding glissando line handle:
●

Start offset moves start glissando line handles. X moves them horizontally, Y moves them
vertically.

●

End offset moves end glissando line handles. X moves them horizontally, Y moves them
vertically.

For example, if you move a whole glissando line, both handles are moved so both properties are
activated. You can also use these properties to move and lengthen/shorten glissando lines
graphically by changing the values in the value fields.
Deactivating the properties resets the selected glissando lines to their default positions.

RELATED LINKS
Changing the angles of glissando lines individually on page 605
Input methods for ornaments, arpeggio signs, and glissando lines on page 185

Changing the default angles of glissando lines project-wide
In Dorico, the endpoints of glissando lines are automatically positioned beside noteheads. When
glissando lines cover a small pitch range, the angle of the line can be quite shallow. You can
change the values for the minimum spans of glissando lines covering a small pitch range in
different contexts project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Glissando Lines in the page list.

3.

In the Vertical Position section, change the values for the positions of glissando lines in
the contexts relevant to your project.
For example, you can increase the minimum span of glissando lines between notes in the
same staff space.

4.

Click Apply, then Close.

RESULT
The default positions and angles of glissando lines are changed.
TIP
You can make graphical adjustments to the positions of individual glissando lines in Engrave
mode.
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RELATED LINKS
Moving glissando lines graphically on page 603

Changing the angles of glissando lines individually
You can adjust the angles of individual glissando lines in Engrave mode by moving the handles at
each end of glissando lines in any direction.
PROCEDURE
1.

In Engrave mode, select the square handles at the start/end of the glissando lines whose
angles you want to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●
3.

Click and drag them in any direction.

Optional: Repeat steps 1 and 2 for the other glissando line handles.

RESULT
The angles of the selected glissando lines are changed.
NOTE
You can also use the Start offset and End offset properties in the Glissando Lines group of the
Properties panel in Engrave mode to adjust the angles and graphical lengths of glissando lines.
Deactivating the properties resets the selected glissando lines to their default positions.

Project-wide engraving options for glissando lines
You can find options for the project-wide appearance and position of glissando lines on the
Glissando Lines page in Engraving Options.
The options on the Glissando Lines page allow you to change the style, appearance, and
thickness of glissando lines. You can also set precise positions for the endpoints of glissando
lines relative to noteheads.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.
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You can then click Glissando Lines in the page list on the left of the dialog.
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Page numbers are used to give each page a unique number, and indicate its position relative to
other pages. Just as in newspapers and books, musical scores and parts use page numbers to
make sure the music stays in the correct order.
Because you can have multiple flows in a single project in Dorico, you do not need to change
page numbers manually in most cases. However, if you have separate files that together make
up a single piece, page number changes are necessary to make sure the page numbers continue
seamlessly from movement to movement.
In such cases, you can change the default page numbers. For example, if you want to have four
pages of front matter before the first page of music in the score, but you want the first page of
music in the score to be shown as page 1, you can insert a page number change on the first page
of music.
Page numbers are layout-specific in Dorico, meaning you can change the page numbers in each
layout independently of the others. For example, you can change the page numbers in the score
but show the default page numbers in the parts.
Page numbers in Dorico use a text token to ensure the number is correct.
NOTE
You must have a text frame containing the page number token on every page on which you want
page numbers to be shown.
The default master pages contain text frames with page number tokens. You can change the
position of page number text frames in the master page editor, which changes the position of
page numbers on all pages that use that master page. You can also move page number text
frames on individual pages.
You can also change the type of number used to show page numbers in each layout. For
example, if you want the front matter to use Roman numerals but the music pages to use Arabic
numbers, you can change the type of number together with the page number.
RELATED LINKS
Page Number Change dialog on page 240
Inserting page number changes on page 239
Master page overrides on page 237
Removing page number changes on page 241
Inputting frames on page 244
Text tokens on page 254
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Moving page numbers in master pages
In order to change where page numbers are shown, you must move the text frames that contain
page numbers. The most efficient way to do this is to move the text frames containing page
numbers in master page formats.
PROCEDURE
1.

In Engrave mode, double-click a master page pair whose page number position you want
to change in the Master Pages section of the Pages panel.

2.

In the master page editor, select the text frames that contain page numbers.

3.

Move the text frames in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●
4.

Click and drag them in any direction.

Click Close Master Page Editor to save your changes.

RESULT
The selected text frames are moved.
TIP
When you move text frames, values for Left, Top, Right, and Bottom in the Frames group of the
Properties panel are changed to reflect the distance of the corresponding edge of the frame
from the page margin, but the values are only visible if the corresponding constraint is locked.
You can also use these properties to move text frames by changing the values in the value fields.
●

Right/Left move the right/left edges of frames horizontally.

●

Top/Bottom move the top/bottom edges of frames vertically.

You can lock/unlock constraints for each text frame in the Frames section of the Formatting
panel.

RELATED LINKS
Frame constraints on page 261
Master pages on page 230

Page number paragraph styles
The paragraph style for page numbers controls all aspects of their appearance, including their
font, size, and horizontal alignment. You can edit the existing page number paragraph style, and
create additional page number paragraph styles, in the Paragraph Styles dialog.
●

You can open the Paragraph Styles dialog in Engrave mode by choosing Engrave >
Paragraph Styles.

Dorico offers a single paragraph style for page numbers by default, but you can create other
paragraph styles for page numbers. For example, if you want page numbers to appear bold and
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centered at the tops of pages in full score layouts but appear italic and on the outer edges of
pages in part layouts, you can create a new paragraph style based on the existing Page Number
paragraph style, but rename it and change the settings.
RELATED LINKS
Paragraph Styles dialog on page 276
Text editor options in Engrave mode on page 281
Changing the paragraph style of text on page 283
Creating paragraph styles based on other styles on page 278

Changing the page number numeral style
Page numbers can appear as Arabic numbers or Roman numerals. You can change the numeral
style of page numbers project-wide in each layout independently.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts whose page number numeral style you want to
change in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Page Setup from the Category menu.

4.

In the Initial Page Number section, select one of the following options from the Use
menu:

5.

●

Number

●

Roman numeral

Click Apply, then Close.

RESULT
The page number numeral style is changed project-wide in the selected layouts.
You can change settings for other layouts before closing the dialog.

Changing the page number numeral style for individual pages
Page numbers can appear as Arabic numbers or Roman numerals. You can change the numeral
style for individual page numbers.
PROCEDURE
1.

In Engrave mode, in the music area, open the layout whose page number numeral style
you want to change.

2.

In the Pages section of the Pages panel, select a page.

3.

Open the Page Number Change dialog in any of the following ways:
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●

Right-click in the Pages section and choose Insert Page Number Change from the
context menu.

●

Click Insert Page Number Change.

4.

In the Page Number Change dialog, enter the number of the page from which you want
to change the page number numeral style in the From page field.

5.

Select the numeral style you want from the following options for Sequence type:

6.

●

Number

●

Roman numeral

Click OK to save your changes and close the dialog.

RESULT
The page number numeral style is changed until the next page number change or the end of the
project, whichever comes first.
RELATED LINKS
Inserting page number changes on page 239

Changing when initial page numbers are shown
You can change when initial page numbers are shown for each layout independently of other
layouts. For example, you can show page numbers on every page in the score but hide page
numbers on the first page in the parts.
NOTE
To show page numbers, there must be a text frame containing the page number token on the
page. The default master page formats for first pages do not contain text frames containing
page number tokens, so you must add these if you want to show page numbers on first pages in
your project that use the default master page formats.

PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change when initial page
numbers are shown in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Page Setup from the Category menu.

4.

In the Initial Page Number section, select one of the following options from the Visibility
menu:
●

Always shown
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5.

●

Always hidden

●

Not on first page

Click Apply, then Close.

RESULT
The visibility of page numbers is changed project-wide in the selected layouts.
TIP
You can change settings for other layouts before closing the dialog.

RELATED LINKS
Page Number Change dialog on page 240
Inserting page number changes on page 239
Inputting frames on page 244

Showing page numbers on individual pages
You can change when page numbers are shown on individual pages, independently of your
project-wide setting for showing page numbers for each layout.
NOTE
To show page numbers, there must be a text frame containing the page number token on the
page. The default master page formats for first pages do not contain text frames containing
page number tokens, so you must add these if you want to show page numbers on first pages in
your project that use the default master page formats.

PROCEDURE
1.

In the music area, open the layout in which you want to change when page numbers are
shown.

2.

In the Pages section of the Pages panel, select a page.

3.

Open the Page Number Change dialog in any of the following ways:
●

Right-click in the Pages section and choose Insert Page Number Change from the
context menu.

●

Click Insert Page Number Change.

4.

In the Page Number Change dialog, enter the number of the page from which you want
to change the visibility of page numbers in the From page field.

5.

Optional: Change the value for First page number.
First page number is 1 by default. If you do not want to change the page number
together with changing the visibility of page numbers, enter the existing page number in
this field.

6.

7.

Select one of the following options from the Visibility menu:
●

Always shown

●

Always hidden

●

Not on first page

Click OK to save your changes and close the dialog.
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RESULT
The visibility of page numbers is changed from the page number specified until the next page
number change with a different setting or the end of the project, whichever comes first.
For example, if you want to see page numbers up to page 3 but hide page numbers from page 4,
enter 4 for From page, enter 4 for First page number, and select Always hidden for Visibility.
RELATED LINKS
Page Number Change dialog on page 240
Inserting page number changes on page 239
Inputting frames on page 244
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Pedal lines indicate to performers which piano pedals to use, and can also give performance
instructions, such as how far down to depress the pedals and when to lift the pedal to clear the
resonance.
Most pianos have either two or three pedals. These pedals are:
Sustain pedal
The sustain pedal controls the dampers on the piano strings, which is why it is also
known as the “damper pedal”. It is also the most commonly used pedal. Depressing
the sustain pedal removes the dampers, allowing the strings to resonate longer.
Sustain pedals are usually on the right.

An example sustain pedal line

Sostenuto pedal
The sostenuto pedal only allows the strings of the notes currently depressed on the
keyboard to resonate. It is also known as the “middle pedal” as it is usually in the
middle of the other pedals.

An example sostenuto pedal line

Una corda pedal
The una corda pedal shifts the action inside the piano so that the hammers hit fewer
strings than normal. Historically, this caused hammers only to hit one string, not the
usual three, which is where the name comes from. Because this reduces the volume
and impact of the sound, it is also known as the “soft pedal”.

An example una corda pedal line

Dorico offers comprehensive notational and playback support for piano pedal lines. You can
create pedaling for the sustain, sostenuto, and una corda pedals, with support for modern sustain
pedaling techniques, including changing the pedal level over the course of a single pedal
instruction.
In Dorico, pedal lines are considered playing techniques because they alter the sound produced
by the instrument. Therefore, pedal lines are included in the Playing Techniques panel in Write
mode and you can input them using the playing techniques popover. However, pedal lines have
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additional, unique requirements that do not apply to other playing techniques, such as retakes,
pedal level changes, start signs, hooks, and continuation lines.
RELATED LINKS
Input methods for pedal lines, retakes, and pedal level changes on page 192
Pedal lines in playback on page 632
Sustain pedal retakes and pedal level changes on page 614
Pedal line start signs, hooks, and continuation lines on page 625
Pedal line start, continuation, and restorative text on page 630

General placement conventions for pedal lines
The default placement of pedal lines is below the bottom staff, even if there are only notes in the
upper staff for the right hand. They are placed outside all other notations, including octave lines,
slurs, and articulations.
If one pedal is used, it is placed as close to the bottom of the staff as possible, while remaining
outside of all other notations.
If multiple pedals are used simultaneously, they are organized below the bottom of the staff as
follows:
1.

Sustain pedal: closest to the staff

2.

Sostenuto pedal: below the sustain pedal line

3.

Una corda pedal: furthest from the staff

The beginning of the glyph/text that indicates the start position of pedal lines aligns with the
note to which it applies. If you are using a line end hook to indicate the end of pedal lines, the
hook aligns with the note or rhythmic position to which it applies.
You can change how pedal lines appear project-wide on the Pedal Lines page in Engrave >
Engraving Options.
RELATED LINKS
Project-wide engraving options for pedal lines on page 625
Pedal line start, continuation, and restorative text on page 630
Pedal line start signs, hooks, and continuation lines on page 625

Sustain pedal retakes and pedal level changes
Pedal retakes indicate where a player should lift the sustain pedal, which dampens the piano’s
strings and clears the resonance, before depressing the pedal again. Pedal level changes indicate
a change to how far the pedal is depressed.
Dorico provides clear representations of pedal retakes and level changes.
NOTE
You can only add pedal retakes and level changes to sustain pedal lines.
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EXAMPLE

Example pedal line with retake and level changes

1

Ped. glyph

2

Retake

3

One quarter depressed

4

Half depressed

5

Three quarters depressed

6

Fully depressed

7

Line end hook

RELATED LINKS
Sustain pedal lines in Engrave mode on page 615
Removing retakes and pedal level changes on page 620
Input methods for pedal lines, retakes, and pedal level changes on page 192

Sustain pedal lines in Engrave mode
When you select sustain pedal lines in Engrave mode, handles appear at the start/end of each
pedal line, and on any retakes or pedal level changes on the line. These handles allow you to
move each part of the pedal line independently, and to change the pedal levels at the start, end,
and at each retake or pedal level change.

A sustain pedal with a retake in Engrave mode

There are two handles for the start of the pedal line, three for retakes and pedal level changes,
and three for the end of the pedal line.
NOTE
Sostenuto and una corda pedal lines only have a single handle at their start/end, which allows you
to move their start/end positions graphically, but only horizontally.
You can move each handle with the keyboard, with the mouse, and using the Properties panel.
Each handle corresponds to a property in either the Pedal Lines group or the Pedal Line
Retakes group of the Properties panel.
NOTE
Pedal levels cannot be lower than 0 or higher than 1.
●

1 is fully depressed.

●

0 is not depressed.
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Start of sustain pedal lines
There are two handles at the start of pedal lines.

●

The left handle moves the start point of the pedal line. You can move this handle to the
right/left.

●

The right handle changes the start pedal level of the pedal line. You can move this handle
upwards/downwards. This changes the angle of the pedal continuation line in relation to
the next retake or pedal level change, or the end of the pedal line.

Pedal level changes and retakes

●

The left handle changes the pedal level before the retake. You can move this handle
upwards/downwards.

●

The right handle changes the pedal level after the retake. You can move this handle
upwards/downwards.

●

The bottom handle corresponds to the position of the pedal level change or retake. You
can move this handle to the right/left.

End of sustain pedal lines

●

The top handle changes the hook length. You can move this handle upwards/downwards.

●

The right handle changes the pedal level at the end of the pedal line. You can move this
handle upwards/downwards.

●

The bottom handle moves the end point of the pedal line. You can move this handle to the
right/left.

RELATED LINKS
Moving pedal lines graphically on page 622

Adding retakes and pedal level changes to existing pedal lines with
the popover
You can add retakes and pedal level changes to existing sustain pedal lines using the playing
techniques popover.
PREREQUISITE
You have input a sustain pedal line.
NOTE
You cannot add retakes and pedal level changes to sostenuto or una corda pedal lines.

616

Pedal lines
Sustain pedal retakes and pedal level changes

PROCEDURE
1.

In Write mode, select an item at the rhythmic position where you want the retake or pedal
level change to apply.

2.

Open the playing techniques popover in any of the following ways:
●

Press Shift-P.

●

Choose Write > Create Playing Technique.

3.

Enter the appropriate short-hand for the retake or pedal level change you want into the
popover. For example, enter ^ or retake for a retake.

4.

Press Return to close the popover.

RESULT
The retake or pedal level change is input at the selected rhythmic position.
RELATED LINKS
Sustain pedal retakes and pedal level changes on page 614
Playing techniques popover for pedal lines on page 193

Adding retakes and pedal level changes to existing pedal lines with
the panel
You can add retakes and pedal level changes to existing sustain pedal lines using the Playing
Techniques panel.
PREREQUISITE
You have input a sustain pedal line.
NOTE
You cannot add retakes and pedal level changes to sostenuto or una corda pedal lines.

PROCEDURE
1.

In Write mode, select an item at the rhythmic position where you want the retake or pedal
level change to apply.

2.

Input the retake or pedal level change you want in one of the following ways:
●

Click the retake or pedal level change you want in the Keyboard section of the
Playing Techniques panel.

●

Choose Edit > Pedal Lines > [Retake or pedal level change]. You can also choose
this option from the context menu.

RESULT
The retake or pedal level change is input at the selected rhythmic position.
NOTE
If nothing is selected in the score, you can click a retake or pedal level change in the Keyboard
section of the Playing Techniques panel, and then click at the rhythmic position where you want
to input the retake or pedal level change.

RELATED LINKS
Sustain pedal retakes and pedal level changes on page 614
Input methods for pedal lines, retakes, and pedal level changes on page 192
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Changing the type of pedal line retakes
You can change existing retakes on sustain pedal lines to pedal level changes and vice versa.
For example, if you do not want the pedal to be released completely between the old and new
levels, change the type to Change Level instead of Retake.
PROCEDURE
1.

In Engrave mode, select the retake or pedal level change whose type you want to change.

2.

In the Properties panel, activate Retake type in the Pedal Line Retakes group.

3.

Choose the type you want from the following options:
●

Retake

●

Change Level

RESULT
The type of pedal line retake is changed.
NOTE
The appearance of the new type of pedal line retake depends on the pedal levels already set on
each side. For example, a retake notch is only shown on one side of the retake if the pedal level
on the other side is set to 0.

Changing the start level of pedal lines
You can change the start level of individual sustain pedal lines by moving start level handles
upwards/downwards.
PROCEDURE
1.

In Engrave mode, select the right handles on the start signs whose start pedal levels you
want to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the start level handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.

●

Press Ctrl/Cmd-Alt-Up Arrow to snap the level to 0 (not depressed).

●

Press Ctrl/Cmd-Alt-Down Arrow to snap the level to 1 (fully depressed).

●

Click and drag the handles upwards/downwards to the level you want.

RESULT
The start level of the selected pedal line is changed.
TIP
Start level in the Pedal Lines group of the Properties panel is activated when you change the
start level of pedal lines.
You can also use this property to change the start level of pedal lines by changing the value in
the value field. For example, 1 is fully depressed and 0 is not depressed.
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Deactivating the property resets the selected pedal lines to their default start level.

RELATED LINKS
Sustain pedal lines in Engrave mode on page 615

Changing pedal levels at retakes and pedal level changes
You can change both the start level and end level of individual sustain pedal lines at retakes and
pedal level changes by moving the corresponding handles upwards/downwards.
The end level is the pedal level immediately before the retake or pedal level change occurs, and
the start level is the pedal level immediately after the retake or pedal level change occurs.
PROCEDURE
1.

In Engrave mode, select one of the handles on the retakes or pedal level changes whose
start/end pedal level you want to change.
●

Select the left handle to change the end pedal level.

●

Select the right handle to change the start pedal level.

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

3.

Move the start level handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.

●

Press Ctrl/Cmd-Alt-Up Arrow to snap the level to 0 (not depressed).

●

Press Ctrl/Cmd-Alt-Down Arrow to snap the level to 1 (fully depressed).

●

Click and drag the handles upwards/downwards to the level you want.

Optional: Repeat steps 1 and 2 for any other handles.

RESULT
The pedal levels of the selected retakes or pedal level changes are changed.
TIP
The following properties in the Pedal Lines group of the Properties panel are activated when you
change the corresponding level at retakes and pedal level changes:
●

Start level at retake

●

End level at retake

You can also use these properties to change the corresponding level at retakes and pedal level
changes by changing the values in the value fields. For example, 1 is fully depressed and 0 is not
depressed.
Deactivating the properties resets the selected pedal lines to their default start/end levels.

RELATED LINKS
Sustain pedal lines in Engrave mode on page 615

619

Pedal lines
Sustain pedal retakes and pedal level changes

Changing the end level of pedal lines
You can change the end level of individual sustain pedal lines by moving end level handles
upwards/downwards.
PROCEDURE
1.

In Engrave mode, select the right handles on the end hooks whose end pedal levels you
want to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the end level handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.

●

Press Ctrl/Cmd-Alt-Up Arrow to snap the level to 0 (not depressed).

●

Press Ctrl/Cmd-Alt-Down Arrow to snap the level to 1 (fully depressed).

●

Click and drag the handles upwards/downwards to the level you want.

RESULT
The end levels of the selected pedal lines are changed.
TIP
End level in the Pedal Lines group of the Properties panel is activated when you change the end
level of pedal lines.
You can also use this property to change the end level of pedal lines by changing the value in the
value field. For example, 1 is fully depressed and 0 is not depressed.
Deactivating the property resets the selected pedal lines to their default end level.

RELATED LINKS
Sustain pedal lines in Engrave mode on page 615

Removing retakes and pedal level changes
You can remove pedal retakes and level changes without deleting the sustain pedal line or
changing its rhythmic position.
PROCEDURE
1.

In Write mode, select the note at the rhythmic position of the retake or pedal level change
you want to remove.
NOTE
You can only remove one retake or pedal level change at a time.

2.

Remove the retake or pedal level change in any of the following ways:
●

Open the playing techniques popover, enter nonotch into the popover, then press
Return.
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NOTE
nonotch must be spelled as one word, without a space.
●

Choose Edit > Pedal Lines > Remove Retake. You can also choose this option from
the context menu.

RESULT
The selected retake or pedal level change is removed, and the pedal line returns to its previous
level as set by either the start of the pedal line, or the retake or pedal level change immediately
preceding the one you removed.
RELATED LINKS
Playing techniques popover for pedal lines on page 193

Positions of pedal lines
You can change the positions of pedal lines individually and by changing their default positions
project-wide. For example, you can override the default position for individual pedal lines to be
further away from the staff if notes at those positions require more vertical space below the staff.
You can move pedal lines to different rhythmic positions in Write mode. They are positioned by
default according to your settings in Engraving Options.
You can move pedal lines graphically in Engrave mode. However, this does not change the
rhythmic positions to which they are attached.
NOTE
You cannot move retakes or pedal level changes rhythmically. You must remove them and input
a new retake or pedal level change at the position you want.
You can change the default positions of all pedal lines project-wide on the Pedal Lines page in
Engrave > Engraving Options. For example, you can change values for the minimum distances
between pedal lines and staves, pedal lines and other pedal lines, and the position of pedal lines
relative to noteheads and grace notes.
RELATED LINKS
Project-wide engraving options for pedal lines on page 625
Moving pedal lines rhythmically on page 621
Moving pedal lines graphically on page 622
Lengthening/Shortening pedal lines on page 624
Input methods for pedal lines, retakes, and pedal level changes on page 192
Adding retakes and pedal level changes to existing pedal lines with the popover on page 616
Adding retakes and pedal level changes to existing pedal lines with the panel on page 617

Moving pedal lines rhythmically
You can move pedal lines to new rhythmic positions after they have been input. Any retakes or
pedal level changes on the pedal lines are also moved.
NOTE
If you want to move retakes or pedal level changes independently of the pedal line, you must
first remove them from their original positions and input new retakes or pedal level changes at
the new positions.
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PROCEDURE
1.

In Write mode, select the pedal lines you want to move.
NOTE
When using the mouse, you can only move one pedal line rhythmically at a time.

2.

Move the pedal lines in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the pedal line to the right/left.

RESULT
A single pedal line is moved to the next/previous notehead on that staff.
Multiple pedal lines are moved according to the current rhythmic grid value.
NOTE
Pedal lines can only be moved along staves. If you want to move a pedal line across staves, you
must delete the pedal line and input a new pedal line on the other staff.

RELATED LINKS
Lengthening/Shortening pedal lines on page 624
Sustain pedal lines in Engrave mode on page 615
Input methods for pedal lines, retakes, and pedal level changes on page 192
Adding retakes and pedal level changes to existing pedal lines with the popover on page 616
Adding retakes and pedal level changes to existing pedal lines with the panel on page 617

Moving pedal lines graphically
You can move pedal lines, retakes, and pedal level changes graphically without changing the
rhythmic positions to which they apply. You can also move the start/end of pedal lines
independently, meaning you can lengthen/shorten them graphically.
NOTE
You can only change the angle of pedal lines by changing the level.

PROCEDURE
1.

In Engrave mode, select one of the following:
●

The pedal lines you want to move.

●

The start/end handles of the pedal lines whose start/end you want to move.

●

The bottom handles of the retakes and pedal level changes you want to move.

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
NOTE
●

You can move multiple pedal lines together, but only upwards/downwards.

●

You can move handles on multiple pedal lines together, but only to the right/left.

622

Pedal lines
Positions of pedal lines
2.

Move the pedal lines or handles in any of the following ways:
●

Press Alt-Right Arrow to move pedal lines and handles to the right.

●

Press Alt-Left Arrow to move pedal lines and handles to the left.

●

Press Alt-Up Arrow to move whole pedal lines upwards.

●

Press Alt-Down Arrow to move whole pedal lines downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The selected pedal lines or handles are moved to new graphical positions.
TIP
The following properties in the Pedal Lines group of the Properties panel are activated
automatically when you move pedal lines in the corresponding directions:
●

Start X offset moves the start of pedal lines horizontally.

●

End X offset moves the end hooks of pedal lines horizontally.

●

Y offset moves whole pedal lines vertically.

X offset in the Pedal Line Retakes group of the Properties panel is activated automatically when
you move pedal retakes or pedal level changes horizontally.
For example, if you move a whole pedal line to the right, both handles are moved, so Start X
offset and End X offset are both activated. You can also use all of these properties to move
pedal lines, retakes, and pedal level changes, and lengthen/shorten pedal lines graphically, by
changing the values in the value fields.
Deactivating the properties resets the selected pedal lines to their default positions.

RELATED LINKS
Lengthening/Shortening pedal lines on page 624
Sustain pedal lines in Engrave mode on page 615

Changing the position of pedal lines relative to grace notes
individually
You can change the start/end positions of individual pedal lines relative to grace notes,
independently of your project-wide settings.
PROCEDURE
1.

Select the pedal lines whose position relative to grace notes you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Properties panel, activate any of the following properties in the Pedal Lines group:

3.

●

Starts before grace notes

●

Ends before grace notes

Activate/Deactivate the corresponding checkboxes.
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RESULT
When the checkboxes are activated, the corresponding parts of the selected pedal lines are
positioned before grace notes.
When the checkboxes are deactivated, the corresponding parts of the selected pedal lines are
positioned after grace notes.
TIP
●

You can adjust the precise position of pedal lines in further detail in Engrave mode.

●

You can change the position of all pedal lines relative to grace notes project-wide on the
Pedal Lines page in Engrave > Engraving Options.

EXAMPLE

Pedal line starting/ending before grace notes

Pedal line starting/ending after grace notes

RELATED LINKS
Project-wide engraving options for pedal lines on page 625
Moving pedal lines graphically on page 622

Lengthening/Shortening pedal lines
You can lengthen/shorten pedal lines rhythmically after they have been input.
PROCEDURE
1.

In Write mode, select the pedal lines you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one pedal line at a time.

2.

Lengthen/Shorten the pedal lines in any of the following ways:
●

Press Shift-Alt-Right Arrow to lengthen them by the current rhythmic grid value.

●

Press Shift-Alt-Left Arrow to shorten them by the current rhythmic grid value.

●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to snap the end of a single pedal line to the
next notehead.

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to snap the end of a single pedal line to the
previous notehead.
NOTE

●

●

You can only lengthen/shorten pedal lines according to the current rhythmic
grid value when multiple pedal lines are selected.

●

When using the keyboard, you can only move the end of pedal lines. You can
move the start of pedal lines by moving the whole line, or by clicking and
dragging the start handle.

Click and drag the circular handle at the start/end of the pedal line to the right/left.
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RESULT
Single pedal lines are lengthened/shortened according to the current rhythmic grid value or to
the next/previous notehead, whichever is closer.
Multiple pedal lines are lengthened/shortened according to the current rhythmic grid value.
TIP
You can move pedal lines graphically in Engrave mode, including changing their graphical length.

RELATED LINKS
Positions of pedal lines on page 621
Moving pedal lines rhythmically on page 621
Moving pedal lines graphically on page 622

Project-wide engraving options for pedal lines
You can find options for the project-wide appearance and position of pedal lines on the Pedal
Lines page in Engraving Options.
The options on the Pedal Lines page allow you to change the symbol shown at the start of each
type of pedal line, the appearance of pedal line symbols on subsequent systems, the appearance
of pedal continuation lines, and the width of retake notches. You can also set precise values for
the gaps between pedal lines and the staff or other objects.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Pedal Lines in the page list on the left of the dialog.

Pedal line start signs, hooks, and continuation lines
Pedal lines normally comprise a start sign, a continuation line, and an end hook. This indicates
clearly to performers where to depress each type of pedal, how long to keep it depressed, and
where to lift it.
In Dorico, you can change the appearance of each part of pedal lines both individually and for all
pedal lines project-wide. For example, you can show all pedal lines with a glyph as their start
sign, but change the start sign of an individual pedal line to show text instead.
You can select any whole pedal line in Write mode and change most aspects of their appearance
according to the type of pedal line, such as their continuation line or start sign.
For sustain pedals only, you can select each segment of a sustain pedal independently in Engrave
mode, and set different properties for each segment. Sustain pedal lines have independent
segments on each separate system on which they appear.
TIP
If you are changing the appearance of many pedal lines, it might be easier to change the
corresponding project-wide settings on the Pedal Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for pedal lines on page 625
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Sustain pedal lines in Engrave mode on page 615

Changing the start sign appearance of pedal lines
You can change the appearance of the start of pedal lines individually, independently of your
project-wide settings. Pedal lines can show variations of the traditional pedal line glyph, use
other symbols, or show text.
PROCEDURE
1.

Select the pedal lines whose start sign appearance you want to change. You can do this in
Write mode and Engrave mode.
NOTE
The pedal lines you select must be the same type, for example, only sustain pedal lines.

2.

In the Properties panel, activate Sign appearance in the Pedal Lines group.

3.

Select one of the options from the menu.
The options are different according to the type of pedal line selected.

RESULT
The start sign appearance of the selected pedal lines is changed.
TIP
●

Deactivating Sign appearance returns the selected pedal lines to your default setting for
start sign appearance.

●

You can change the default start sign appearance of all pedal lines project-wide on the
Pedal Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for pedal lines on page 625

Changing the type of hook at the start/end of pedal lines
You can change the type of hook shown at the start/end of pedal lines individually.
NOTE
You can only change the start hook type of pedal lines that have a hook as their start sign, and
you can only change the end hook type of pedal lines that have a continuation line.

PROCEDURE
1.

Select the pedal lines whose hook type you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Pedal Lines group:

3.

●

Line start hook

●

Line end hook

Select one of the following options from each menu:
●

No Hook

●

Vertical Hook

●

Slant Hook
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●

Inverse Hook

RESULT
The hook type at the start/end of the selected pedal lines is changed.
TIP
You can change the default appearance of all pedal lines project-wide on the Pedal Lines page in
Engrave > Engraving Options.

Lengthening/Shortening pedal line hooks
You can change the length of hooks shown at the start/end of pedal lines individually,
independently of each other and independently of your project-wide settings.
For example, if you have a pedal line with a hook at the start/end, you can make the end hook
longer without changing the length of the start hook.
NOTE
This only applies to pedal lines that have a hook as their start sign and/or end sign.

PROCEDURE
1.

In Engrave mode, select the top handle at the start/end of the pedal lines whose hooks
you want to lengthen/shorten.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the hook handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●

Click and drag them upwards/downwards.

RESULT
The length of the selected pedal line hooks is changed.
TIP
The following properties in the Pedal Lines group of the Properties panel are activated
automatically when you move the corresponding pedal line hook:
●

Start hook length changes the length of hooks at the start of pedal lines.

●

End hook length changes the length of hooks at the end of pedal lines.

You can also use these properties to lengthen/shorten pedal line hooks by changing the values in
the value fields.
Deactivating the properties resets the selected pedal lines to their default hook length.
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TIP
You can change the default hook length for all pedal lines project-wide by changing the value for
Hook length in the Design section of the Pedal Lines page in Engrave > Engraving Options.
This value applies to hooks at the start/end of pedal lines.

Changing the continuation line type of pedal lines
You can change the type of continuation line used for the different types of pedal lines
individually, independently of your project-wide settings.
PROCEDURE
1.

Select the pedal lines whose continuation line type you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Continuation type in the Pedal Lines group.

3.

Select one of the following continuation types from the menu:
●

Line

●

Sign at End

●

Sign at End and Dashed Line

●

None

RESULT
The continuation line type of the selected pedal lines is changed.
NOTE
You can change the continuation type for all pedal lines project-wide on the Pedal Lines page in
Engrave > Engraving Options. You can choose different continuation types for each pedal type,
for example, you can have a line for sustain pedal lines and just a sign at the end for una corda
pedal lines.

Lengthening/Shortening gaps and dashes in pedal continuation lines
You can change the length of dashes and the gaps between dashes in individual dashed pedal
continuation lines, independently of your project-wide settings.
NOTE
This only applies to pedal lines with dashed continuation lines.

PROCEDURE
1.

In Engrave mode, select the pedal lines whose dashes you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Pedal Lines group.

3.

●

Dash length

●

Dash gap length

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.
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RESULT
Increasing Dash length makes dashes in pedal continuation lines longer, decreasing the value
makes dashes shorter.
Increasing Dash gap length makes gaps between dashes in pedal continuation lines longer,
decreasing the value makes gaps shorter.
TIP
You can find options that change the default dash length and default gap length for all dashed
pedal continuation lines project-wide by clicking Advanced Options in the Design section of the
Pedal Lines page in Engrave > Engraving Options.

Changing the line width of pedal lines
You can change the thickness of continuation lines individually, independently of your projectwide settings.
PROCEDURE
1.

In Engrave mode, select the pedal lines whose continuation line thickness you want to
change.

2.

In the Properties panel, activate Line width in the Pedal Lines group.
The value resets to 0 automatically when you first activate the property.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increasing Line width makes pedal continuation lines thicker, decreasing the value makes pedal
continuation lines thinner.
TIP
You can change the default thickness for all pedal continuation lines project-wide in the Design
section of the Pedal Lines page in Engrave > Engraving Options.

Parenthesizing pedal line continuation signs
You can show individual pedal line continuation signs with/without parentheses, independently
of your project-wide setting. Pedal line continuation signs are shown by default at the start of
new systems when pedal lines continue across system breaks.
PROCEDURE
1.

Select the pedal lines whose continuation sign appearance you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Show continuation sign in parentheses in the Pedal
Lines group.

3.

Activate/Deactivate the corresponding checkbox.

RESULT
Continuation signs are shown with parentheses when the checkbox is activated, and without
parentheses when the checkbox is deactivated.
When the property is deactivated, pedal lines follow your project-wide setting.
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TIP
You can change the default appearance of all pedal line continuation signs project-wide in the
Design section of the Pedal Lines page in Engrave > Engraving Options.

Pedal line start, continuation, and restorative text
All types of pedal lines can have text as their start signs, instead of glyphs or hooks. You can
override the text shown at the start of pedal lines that have text start signs, you can change the
continuation text shown at the start of new systems, and you can override the restorative text
shown at the end of una corda pedal lines.
You can change the design of all pedal lines project-wide according to their type in the Design
section of the Pedal Lines page in Engraving Options, and you can change the appearance of
individual pedal lines, independently of your project-wide settings.

Pedal lines that use a text indication rather than a symbol
For pedal lines such as una corda or sustain that have text for their start sign, such as Ped. Text,
rather than the more ornate symbol, you can override the text shown at the start of the pedal
line and replace it with your preferred performance direction.

Continuation sign/text
When pedal lines continue onto a new system, a continuation sign/text is shown in parentheses
by default. If the pedal line is using text for their start sign, such as Ped. Text, rather than a
symbol, you can change the text shown at the start of a new system and replace it with your
preferred performance direction.

Una corda pedal lines
The equivalent to the final pedal lift for the una corda pedal marking is the indication to return to
tre corde. You can override the tre corde text shown at the end of the pedal line and replace it with
your preferred performance direction.
RELATED LINKS
Changing the start text shown in pedal lines on page 630
Changing the pedal line continuation text shown on page 631
Changing the restorative text shown in una corda pedal lines on page 631

Changing the start text shown in pedal lines
You can change the text shown at the start of individual pedal lines that use text as their start
sign.
PROCEDURE
1.

Select the pedal lines whose start text you want to override. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Text in the Pedal Lines group.

3.

Enter the text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.
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RESULT
The text shown at the start of the selected pedal lines is changed.
Deactivating Text restores the default start text for the selected pedal lines.
NOTE
Deactivating properties permanently deletes any custom text entered.

Changing the pedal line continuation text shown
You can change the text shown at the start of new systems when pedal lines cross system
breaks.
NOTE
This only applies to pedal lines that use text as their start sign.

PROCEDURE
1.

Select the pedal lines whose continuation text you want to override. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Continuation text in the Pedal Lines group.

3.

Enter the text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The continuation text shown at the start of new systems for the selected pedal lines is changed.
Deactivating Continuation text restores the default continuation text for the selected pedal
lines.
NOTE
Deactivating properties permanently deletes any custom text entered.

Changing the restorative text shown in una corda pedal lines
The equivalent to the final pedal lift for una corda pedal lines is the indication to return to tre
corde. You can change the tre corde text shown at the end of individual una corda pedal lines.
NOTE
This only applies to una corda pedal lines that use text as their start sign.

PROCEDURE
1.

Select the una corda pedal lines whose restorative text you want to override. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Restorative text in the Pedal Lines group.

3.

Enter the text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.
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●

Click outside of the value field.

RESULT
The restorative text shown at the ends of the selected una corda pedal lines is changed.
Deactivating Restorative text restores the default restorative text for the selected pedal lines.
NOTE
Deactivating properties permanently deletes any custom text entered.

Pedal lines in playback
Pedal lines are automatically played back in Dorico.
The three piano pedals send MIDI controllers as follows:
●

Sustain pedal lines send MIDI controller 64 (Sustain).

●

Sostenuto pedal lines send MIDI controller 66 (Sostenuto).

●

Una corda pedal lines send MIDI controller 67 (Soft Pedal).

Some piano VST instruments, such as Pianoteq and Garritan CFX Concert Grand, support partial
depression of the sustain pedal. Consult the manufacturer’s documentation for more
information.

Playback Options
You can find options for how Dorico plays back pedaling on the Pedal Lines page in Playback
Options.
You can open Playback Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-P in any mode.

●

Choose Play > Playback Options in Play mode.

You can control the following parameters of pedal line playback:
●

The length of the initial pedal depression

●

The length of a retake in the middle of a pedal line

●

The length of the final pedal release

●

Whether initial depressions and retakes are played before or after the onset of the notes
or chords at their rhythmic positions

Pedal lines imported from MusicXML files
Sustain pedal lines can be imported from MusicXML files. MusicXML can only describe the sustain
pedal, and it cannot describe changes in pedal depression level.
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The term “playing techniques” covers a wide range of instructions intended to tell performers to
modify the sound of the notes they are playing, for example, by changing their embouchure or
changing the position of their bow, or by modifying their instrument, such as adding a mute or
depressing a pedal.
In Dorico, playing techniques can be expressed as symbols or as text. All available playing
techniques can be found in the Playing Techniques panel in Write mode, organized by
instrument family. For example, you can find pedal lines in the Keyboard section of the Playing
Techniques panel.
NOTE
Because pedal lines have additional, unique requirements that do not apply to other playing
techniques, such as retakes, start signs, and continuation lines, they are documented separately.
Pedal lines also have their own group in the Properties panel that is separate from the Playing
Techniques group.
Adding playing techniques can change how the instrument plays back. For example, adding
pizzicato to a violin staff activates a key switch that changes the sound produced by the VST
instrument.

Some of the playing techniques in Dorico

RELATED LINKS
Input methods for playing techniques on page 196
Project-wide engraving options for playing techniques on page 637
Playing techniques in playback on page 637
Pedal lines on page 613

General placement conventions for playing techniques
Playing techniques, both as text and symbols, are placed above the staff. On vocal staves, they
are placed above the staff and below dynamics.
In multiple-voice contexts, playing techniques for the up-stem voices are placed above the staff
and playing techniques for the down-stem voices are placed below the staff.
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Placement of playing techniques with two voices on the same staff

Playing technique texts use a plain font, neither bold nor italic, so they are not confused with
expressive text and dynamics.
NOTE
This does not apply to pedal lines, as they use a separate font style to other playing techniques.

RELATED LINKS
Pedal lines on page 613
Pedal line start, continuation, and restorative text on page 630

Positions of playing techniques
You can change the positions of playing techniques individually and by changing their default
positions project-wide. For example, you can override the default position for individual playing
techniques if you want extra space for other instructions at those positions.
You can move playing techniques to different rhythmic positions in Write mode. They are
positioned by default according to your settings in Engraving Options.
You can move playing techniques graphically in Engrave mode, however this does not change
the rhythmic positions to which they are attached.
You can change the default positions of all playing techniques project-wide on the Playing
Techniques page in Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for playing techniques on page 637
Moving playing techniques rhythmically on page 634
Moving playing techniques graphically on page 635

Moving playing techniques rhythmically
You can move playing techniques to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the playing techniques you want to move.
NOTE
When using the mouse, you can only move one playing technique rhythmically at a time.

2.

Move the playing techniques in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the playing technique to the right/left to the notehead you want.
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RESULT
A single playing technique is moved to the next or previous notehead on that staff.
Multiple playing techniques are moved according to the current rhythmic grid value.
RELATED LINKS
Moving pedal lines rhythmically on page 621

Moving playing techniques graphically
You can move playing techniques graphically without changing the rhythmic positions to which
they apply.
NOTE
These steps do not apply to pedal lines.

PROCEDURE
1.

In Engrave mode, select the playing techniques you want to move.

2.

Move the playing techniques in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The selected playing techniques are moved to new graphical positions.
TIP
Start offset in the Playing Techniques group of the Properties panel is activated automatically
when you move playing techniques.
●

Start offset X moves playing techniques horizontally.

●

Start offset Y moves playing techniques vertically.

You can also use this property to move playing techniques by changing the values in the value
fields.
Deactivating the property resets the selected playing techniques to their default positions.

RELATED LINKS
Moving pedal lines graphically on page 622
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Changing the placement of playing techniques relative to the staff
You can change the placement of individual playing techniques relative to the staff.
NOTE
These steps do not apply to pedal lines.

PROCEDURE
1.

Select the playing techniques whose placement relative to the staff you want to change.
You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Placement in the Playing Techniques group.

3.

Choose one of the following options:
●

Above

●

Below

RESULT
The selected playing techniques appear above/below the staff.
RELATED LINKS
Moving playing techniques graphically on page 635
Moving pedal lines graphically on page 622

Adding text to playing techniques
You can add text above or alongside playing techniques after they have been input, for example,
to clarify the intention of the playing technique.
NOTE
These steps do not apply to pedal lines.

PROCEDURE
1.

Select the playing techniques to which you want to add text. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Alternative text in the Playing Techniques group.

3.

Enter the text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The text you entered into the value field is shown directly after text playing technique, and
directly above symbol playing techniques.
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EXAMPLE

Alternative text added to text playing technique

Alternative text added to symbol playing technique

RELATED LINKS
Pedal line start, continuation, and restorative text on page 630

Project-wide engraving options for playing techniques
You can find options for the project-wide appearance and position of playing techniques on the
Playing Techniques page in Engraving Options.
The options on the Playing Techniques page allow you to change the distance between playing
techniques and the staff, the arrangement of multiple text playing techniques at the same
rhythmic position, and playing technique continuation styles.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Playing Techniques in the page list on the left of the dialog.

Playing techniques in playback
Each playing technique you can create in Write mode corresponds to a technique that you can
map in the Expression Maps editor.
●

You can open the Expression Maps dialog in Play mode by choosing Play > Expression
Maps.

The Expression Maps dialog shows you which playing techniques, shown in a list on the left of
the dialog, you can apply to each software instrument. This list includes combined playing
techniques, which allows multiple playing techniques to be applied to notes simultaneously.
In the Techniques section of the dialog, you can edit existing techniques. You can also create
new combinations of playing techniques in the Technique Combinations dialog. For example,
you can combine Pizzicato and Tremolo to allow the pizzicato and tremolo techniques to be
applied to the same note simultaneously.
When you input a playing technique in Write mode, the expression map looks for that playing
technique. If it cannot be found, the playing technique applied either remains the same as the
previous technique or reverts to the natural technique.
You can see which playing techniques are being applied in the Playing Techniques lane, which
you can show by expanding individual instruments in Play mode.
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TIP
If you have input a playing technique but cannot hear a change in the sound, that could be
because you are using a combination of playing techniques that the expression map does not
expect. For example, if you input a new playing technique without cancelling an existing playing
technique, the expression map cannot process the two playing techniques together if the
expression map does not have an entry for those two techniques combined.
To avoid playing technique clashes, input a “naturale”, or “nat.”, playing technique to return the
software instrument to its natural state. You can then input new playing techniques without
clashes.

RELATED LINKS
Expression Maps dialog on page 320
Technique Combinations dialog on page 324
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Rehearsal marks are an ordered sequence of letters or numbers, which along with bar numbers,
provide a reference point for music that has multiple players, and make the chronological
sequence of the music clear.
They tell performers where they are in the piece, and allow performers to orient and co-ordinate
themselves easily in rehearsals and concerts. Rehearsal marks can also be used to indicate
significant changes in the music, and you can freely decide their positions.
They can also be useful when preparing parts and scores, as you can use rehearsal marks and
bar numbers to compare quickly a part to the score and check it is correct. In Dorico, rehearsal
marks follow an automatic sequence, ensuring there are never duplicate rehearsal marks.
In Dorico, rehearsal marks are categorized as system objects. Therefore, rehearsal marks follow
your per-layout settings for the visibility and positioning of system objects, which you can change
on the Staves and Systems page in Setup > Layout Options.
RELATED LINKS
Inputting rehearsal marks on page 203
System objects on page 707
Changing the positions of system objects on page 708

General placement conventions for rehearsal marks
Rehearsal marks should be at noticeable positions in the score so they can be seen easily. They
should use a large, non-italic bold font, and be positioned above the system and outside the
music.

Rehearsal marks should be positioned above barlines, and not below the system. Although you
can input rehearsal marks at rhythmic positions within a bar in Dorico, this is not common
practice. Depending on the style of music and the context, it can be helpful to input a double
barline beneath each rehearsal mark.
In order to ensure they are easily noticeable, and cannot be confused with bar numbers if you
are using numbers for rehearsal marks, rehearsal marks should be shown in an enclosure. You
can change the shape and size of rehearsal mark enclosures.
The placement of rehearsal marks relative to the music is discretionary, but they are most helpful
to players when they coincide with a change in the music, such as a tempo change or a change in
texture. They are also helpful when placed at a point in the music where players are likely to start
from in order to rehearse a specific section, such as a significant solo entry or the start of a
difficult passage.
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Positions of rehearsal marks
In general, it is good practice to place rehearsal marks at regular intervals as well as at significant
moments. It is often recommended to have rehearsal marks every 5-20 bars to reduce the
amount of bars players need to count before or after a rehearsal mark.
If a rehearsal mark coincides with a tempo change, you should position the tempo text to the
right of the rehearsal mark. However, if space is tight, the text can be positioned above or below
the rehearsal mark. The position of the rehearsal mark should remain clear, so it should not be
moved away from the barline to which it applies, otherwise its position can be misunderstood.
Dorico automatically adjusts staff spacing to ensure rehearsal marks are correctly positioned.

The vertical spacing between the top two staves is increased to allow room for the rehearsal mark and the
tempo marks.

RELATED LINKS
Inputting rehearsal marks on page 203
Input methods for bars and barlines on page 155
Changing the rehearsal mark enclosure type on page 645

Positions of rehearsal marks
You can change the positions of rehearsal marks individually and by changing their default
positions project-wide. For example, you can override the default position for individual rehearsal
marks when other items at those positions require extra space.
You can move rehearsal marks to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.
You can move rehearsal marks graphically in Engrave mode, however this does not change the
rhythmic positions to which they are attached.
You can change the default positions of all rehearsal marks project-wide, and set values for the
minimum distances between rehearsal marks and staves, and rehearsal marks and other items,
on the Rehearsal Marks page in Engrave > Engraving Options.
Rehearsal marks are categorized as system objects in Dorico, which you can show above the first
bracket of selected instrument families. You can change the instrument families above which
system objects appear in each layout in your project independently of other layouts, for example,
if you want rehearsal marks to appear at multiple vertical positions in each system.
RELATED LINKS
Project-wide engraving options for rehearsal marks on page 644
Moving rehearsal marks rhythmically on page 641
Moving rehearsal marks graphically on page 641
Changing the positions of system objects on page 708
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Moving rehearsal marks rhythmically
You can move rehearsal marks to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the rehearsal marks you want to move.
NOTE
When using the mouse, you can only move one rehearsal mark rhythmically at a time, and
you can only drag it to existing barlines.

2.

Move the rehearsal marks in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the rehearsal mark to barlines to the right/left.

RESULT
A single rehearsal mark is moved to existing barlines to the right/left.
Multiple rehearsal marks are moved according to the current rhythmic grid value.
NOTE
Only one rehearsal mark can exist at each rhythmic position. If a rehearsal mark passes over
another rehearsal mark as part of its move, the existing rehearsal mark is deleted and replaced
by the rehearsal mark being moved.
You can undo this action, but any rehearsal marks deleted in the process are only restored if you
moved the rehearsal mark using the keyboard.

Moving rehearsal marks graphically
You can move rehearsal marks graphically, without changing the rhythmic positions to which
they are attached.
PROCEDURE
1.

In Engrave mode, select the rehearsal marks you want to move.

2.

Move the rehearsal marks in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The graphical positions of the selected rehearsal marks are changed.
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TIP
Start offset in the Rehearsal Marks group of the Properties panel is activated automatically
when you move rehearsal marks.
●

Start offset X moves rehearsal marks horizontally.

●

Start offset Y moves rehearsal marks vertically.

You can also use this property to move rehearsal marks by changing the values in the value
fields.
Deactivating the property resets the selected rehearsal marks to their default positions.

Deleting rehearsal marks
You can delete rehearsal marks in full score and part layouts.
NOTE
Deleting a rehearsal mark in any layout deletes the rehearsal mark from all layouts.

PROCEDURE
1.

In Write mode, select the rehearsal marks you want to delete.

2.

Delete the rehearsal marks in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The selected rehearsal marks are deleted. Any subsequent rehearsal marks are adjusted until the
next change in the sequence or the end of the flow. For example, if you delete the first rehearsal
mark, the second rehearsal mark shows either the letter A, the number 1, or the bar number,
depending on your choice of sequence type.
RELATED LINKS
Changing the rehearsal mark sequence type on page 643

Changing the order of rehearsal marks
By default, the rehearsal mark sequence resets at the start of each flow. If you want the
rehearsal mark sequence to continue across flows, for example, to avoid having multiple
rehearsal marks with the same letter in the same project, you can change the index position of a
rehearsal mark.
Changing the index position changes the shown number or letter. For example, index position 1
appears as rehearsal mark A or 1, position 2 appears as B or 2, and so on.
You can also change the index position of a rehearsal mark to avoid showing a letter that could
easily be confused with another letter or another number, such as I or O.
PROCEDURE
1.

Select the rehearsal mark whose index position you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Index in the Rehearsal Marks group.

3.

Change the value in the value field in any of the following ways:

642

Rehearsal marks
Changing the rehearsal mark sequence type
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
The selected rehearsal mark changes according to the Index value and its sequence type.
Any subsequent rehearsal marks in the same sequence follow the new index automatically. For
example, if you changed a rehearsal mark from A to P, the next rehearsal mark changes from B
to Q.
NOTE
You can also change the sequence type of rehearsal marks, for example, if you want rehearsal
mark C to appear as rehearsal mark 3.

RELATED LINKS
Changing the rehearsal mark sequence type on page 643

Changing the rehearsal mark sequence type
Rehearsal marks can be letters, numbers, or bar numbers. You can change the sequence type of
individual rehearsal marks, and create secondary rehearsal mark sequences.
In Dorico, you can use all three available rehearsal mark sequences simultaneously. For example,
you can have the main sequence of rehearsal marks showing letters, but also have a secondary
sequence of numbers to mark different moments, perhaps entry points for a solo line, and also
highlight prominent bar numbers within those sections.
NOTE
You can change which type of sequence is used project-wide on the Rehearsal Marks page in
Engraving Options.

PROCEDURE
1.

Select the rehearsal mark whose sequence type you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Sequence type in the Rehearsal Marks group.

3.

Select one of the following options from the menu:
●

Letters

●

Numbers

●

Bar numbers

RESULT
The selected rehearsal mark now displays a letter, a number, or the current bar number.
If it is the first rehearsal mark in either the letters sequence or the numbers sequence in the flow,
it shows either A or 1. If there are already rehearsal marks in either the letters sequence or the
numbers sequence in the flow, it shows the next letter or number according to the index.
NOTE
You can change the index of a rehearsal mark sequence independently of other rehearsal mark
sequences. However, you cannot change the bar number sequence using this method.
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RELATED LINKS
Project-wide engraving options for rehearsal marks on page 644
Adding bar number changes on page 398

Adding prefixes/suffixes to rehearsal marks
You can add both prefixes and suffixes to individual rehearsal marks.
PROCEDURE
1.

Select the rehearsal marks to which you want to add a prefix or suffix. You can do this in
Write mode or Engrave mode.

2.

In the Properties panel, activate one of the following properties in the Rehearsal Marks
group:
●

Prefix

●

Suffix

3.

Enter the text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The text you entered into the value field is added to the selected rehearsal marks as a prefix or a
suffix.
TIP
You can add a custom prefix/suffix to all rehearsal marks project-wide on the Rehearsal Marks
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for rehearsal marks on page 644

Project-wide engraving options for rehearsal marks
You can find options for the project-wide appearance and position of rehearsal marks on the
Rehearsal Marks page in Engraving Options.
For example, you can change the sequence type of rehearsal marks, their default positions, and
whether they are shown in enclosures.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Rehearsal Marks in the page list on the left of the dialog.
RELATED LINKS
Rehearsal mark enclosure size and padding values on page 645
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Changing the rehearsal mark enclosure type
Rehearsal marks are usually shown in an enclosure, which can be a rectangle or a circle. You can
change the enclosure type of all rehearsal marks project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Rehearsal Marks in the page list.

3.

In the Enclosure section, choose one of the following options for Enclosure type:
●

Rectangle

●

Circle

●

No enclosure

RESULT
The enclosure type of all rehearsal marks in your project is changed. The default size of the
enclosure is relative to the font size of the rehearsal marks, but your padding values also
determine the size and shape of the enclosure.
EXAMPLE

Rehearsal mark with a rectangle
enclosure

Rehearsal mark with a circle
enclosure

Rehearsal mark with no enclosure

Rehearsal mark enclosure size and padding values
You can change the default shape and size of rehearsal mark enclosures on the Rehearsal
Marks page in Engraving Options. You can change the minimum dimensions, line thickness,
and padding values of rehearsal mark enclosures.

All enclosures
Enclosure line thickness
Sets the thickness of enclosure lines for both rectangle and circle enclosures. The
default is 1/8 of a space. The examples have a thickness of 1/2 a space.

Rectangle rehearsal mark enclosure
The figure shows a rectangle rehearsal mark enclosure with default settings. The minimum
height and minimum width are both 4 spaces, horizontal padding is 3/4 of a space, and
minimum bottom and minimum top padding are both 1/8 of a space.
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Minimum width
Sets a minimum value for the width of enclosures. In this example, the value was
increased from 4 spaces to 8 spaces.

Minimum height
Sets a minimum value for the height of enclosures. In this example, the value was
increased from 4 spaces to 8 spaces.

Left and right padding between text and enclosure
Sets the value for the distance between the two sides of the enclosure and the
rehearsal mark within it. In this example, the value was increased from 3/4 of a space
to 3 spaces.

Top padding between text and enclosure
Sets the value for the distance between the top line of the enclosure and the
rehearsal mark within it. In this example, the value was increased from 1/2 a space to
2 spaces.

Bottom padding between text and enclosure
Sets the value for the distance between the bottom line of the enclosure and the
rehearsal mark within it. In this example, the value was increased from 1/8 of a space
to 2 spaces.

Circle rehearsal mark enclosure
The figure shows a circle rehearsal mark enclosure with default settings. The minimum diameter
is 4 spaces, and the minimum padding is 1/4 of a space.
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Minimum diameter
Sets a minimum value for the diameter of the enclosure. In this example, the value
was increased from 4 spaces to 8 spaces.

Minimum padding between text and enclosure
Sets the value for the distance between the enclosure line and the rehearsal mark
within it. In this example, the value was increased from 1/4 of a space to 2 spaces.

Changing the rehearsal mark font style
You can change the font style used for all rehearsal marks project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles.
The Edit Font Styles dialog opens.

2.

Select Rehearsal Mark Font from the Font style menu.

3.

Activate the following options, individually or together, to change the corresponding
aspect of the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The rehearsal mark font style is changed project-wide.
RELATED LINKS
Edit Font Styles dialog on page 275
Project-wide engraving options for rehearsal marks on page 644
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For music with repeated passages, repeat endings show which bars are played at the end of each
repetition, with different endings each time if required. They are also known as “volta lines”, or as
“first and second endings”, but in this documentation, we refer to them as “repeat endings”.
Repeat endings comprise two or more segments, where each segment contains a different
possible ending. When you input repeat endings, Dorico automatically inputs an end repeat
barline at the end of the first segment. Segments in repeat endings are clearly marked with solid
lines above and a number that indicates on which repeat the segment is to be played.

A repeat ending with three possible endings

Dorico allows you to create repeat endings containing any number of segments, and allows you
to control which segments are used for each playthrough. For example, you might want a repeat
ending with two segments but four total playthroughs, where the first two playthroughs use the
first repeat ending segment and the final two playthroughs use the second repeat ending
segment.
In Dorico, repeat endings are categorized as system objects. Therefore, repeat endings follow
your per-layout settings for the visibility and positioning of system objects, which you can change
on the Staves and Systems page in Setup > Layout Options.
RELATED LINKS
Inputting repeat endings on page 204
Adding additional repeat endings on page 205
Dividing playthroughs across repeat ending segments on page 649
System objects on page 707
Changing the positions of system objects on page 708

Changing the total number of playthroughs in repeat
endings
By default, each segment in repeat endings is played once, so each segment shows a single digit
that indicates the playthrough for which it is used. You can increase the total number of
playthroughs for repeat endings individually so that segments are played more than once.
PROCEDURE
1.

Select the repeat endings whose total number of repeats you want to change. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate No. times played in the Repeat Endings group.

3.

Change the value in the value field in any of the following ways:
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●

Enter a value into the value field.

●

Click the arrows beside the value field.

NOTE
You cannot have fewer repeats than the number of segments.

RESULT
The total number of repeats in the selected repeat endings is changed. This is updated
automatically in the layout.
By default, Dorico automatically adds any repeats not already assigned to specific segments to
the final closed segment.
AFTER COMPLETING THIS TASK
Once you have set the total number of repeats, you can then change which segment is used for
each playthrough.
RELATED LINKS
Dividing playthroughs across repeat ending segments on page 649

Dividing playthroughs across repeat ending segments
You can control how the total number of playthroughs is divided across the different segments in
individual repeat endings.
PROCEDURE
1.

In Engrave mode, select an individual segment in the repeat ending structure whose
included playthroughs you want to change.

2.

In the Properties panel, activate Times played for segment in the Repeat Endings group.

3.

Enter the number of each playthrough that you want to include in the selected segment.
For example, for a repeat ending with six playthroughs, enter 4,5,6 to include the 4th, 5th,
and 6th playthroughs in the second segment.

RESULT
The playthroughs included in the selected segment are changed.
EXAMPLE

Default distribution of repeats

Customized distribution of repeats

Project-wide engraving options for repeat endings
You can find options controlling the project-wide design, position, and appearance of repeat
ending segments on the Repeat Endings page in Engraving Options.
The options on the Repeat Endings page allow you to change the ends of repeat ending lines,
the appearance of numbers and hooks, and the default position of repeat endings.
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There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Repeat Endings in the page list on the left of the dialog.

Lengthening/Shortening segments in repeat endings
You can increase/decrease the number of bars included in each segment of repeat endings by
lengthening/shortening each segment independently.
PROCEDURE
1.

In Write mode, select the repeat ending you want to lengthen/shorten.
NOTE
You can only lengthen/shorten one repeat ending segment at a time.

2.

Select the circular handle at the end of the segment you want to lengthen/shorten.

The selected handle in the middle has a thicker line.

3.

Click and drag the handle to the right/left to snap it to the next/previous barline.
NOTE
Segments must contain at least one bar.

4.

Optional: Repeat steps 1 to 3 for each segment in the repeat ending.

RESULT
The selected segment is lengthened/shortened.
NOTE
This does not automatically input or reposition repeat barlines. You must input repeat barlines as
appropriate manually.
TIP
You can also lengthen/shorten the final segment in a single repeat ending by selecting the
repeat ending and using the following key commands:
●

Press Shift-Alt-Right Arrow to lengthen the final segment.

●

Press Shift-Alt-Left Arrow to shorten the final segment.

RELATED LINKS
Moving repeat endings graphically on page 652
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Positions of repeat endings
Repeat endings are placed above the staff at the same positions as other system objects, and
their hooks align with barlines. They are commonly positioned outside of other notations, but
some long items, such as gradual tempo changes, can be placed above repeat endings.
You can change the positions of repeat endings individually and by changing their default
positions project-wide. For example, you can override the default position for individual repeat
endings if the musical material at those positions requires more vertical space.
You can move repeat endings to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.
You can move each repeat ending segment graphically in Engrave mode and independently of
other segments in the repeat ending, however, this does not change the rhythmic positions to
which they are attached.
You can change the default appearance and position of all repeat endings project-wide on the
Repeat Endings page in Engrave > Engraving Options.
Repeat endings are categorized as system objects in Dorico, which you can show above the first
bracket of selected instrument families. You can change the instrument families above which
system objects appear in each layout in your project independently of other layouts, for example,
if you want repeat endings to appear at multiple vertical positions in each system.
RELATED LINKS
Project-wide engraving options for repeat endings on page 649
Moving repeat endings rhythmically on page 651
Moving repeat endings graphically on page 652
System objects on page 707
Changing the positions of system objects on page 708

Moving repeat endings rhythmically
You can move repeat endings to different rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the repeat ending you want to move.
NOTE
You can only move one repeat ending rhythmically at a time.

2.

Move the repeat ending to the next/previous bar in any of the following ways:
●

Press Alt-Right Arrow to move it to the right.

●

Press Alt-Left Arrow to move it to the left.

●

Click and drag it to the right/left.

RESULT
The selected repeat ending is moved to the next/previous bar.
NOTE
●

This does not automatically input or reposition repeat barlines. You must input repeat
barlines manually as appropriate.

●

Only one repeat ending can exist at each rhythmic position. If any part of a selected repeat
ending collides with any part of another repeat ending as part of its move, the other
repeat ending is deleted. However, its repeat barlines are not deleted.
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You can undo this action, but any repeat endings deleted in the process are only restored
if you moved the repeat ending using the keyboard.
RELATED LINKS
Positions of repeat endings on page 651

Moving repeat endings graphically
You can move repeat endings graphically without changing their rhythmic positions. You can also
move the start/end of repeat ending segments independently, meaning you can lengthen/
shorten them graphically.
PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Repeat ending segments

●

Individual handles on repeat ending segments

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the repeat ending segments or handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The selected repeat ending segments or handles are moved graphically.
TIP
The following properties in the Repeat Endings group of the Properties panel are activated
automatically when you move repeat ending segments in the corresponding directions:
●

Start X offset moves start repeat ending segment handles horizontally.

●

End X offset moves end repeat ending segment handles horizontally.

●

Y offset moves whole repeat ending segments vertically.

For example, if you move a whole repeat ending segment to the right, both handles are moved,
so Start X offset and End X offset are both activated. You can also use all three properties to
move and lengthen/shorten repeat endings graphically by changing the values in the value
fields.
Deactivating the properties resets the selected repeat ending segments to their default
positions.
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RELATED LINKS
Moving repeat endings rhythmically on page 651
Lengthening/Shortening segments in repeat endings on page 650
Repeat endings in Engrave mode on page 653

Repeat endings in Engrave mode
In Engrave mode, you can change the appearance of repeat endings and repeat ending
segments individually, independently of your project-wide settings on the Repeat Endings page
in Engraving Options.
In Engrave mode, each segment in repeat endings has two square handles.

You can select and move each handle independently.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

RELATED LINKS
Project-wide engraving options for repeat endings on page 649
Moving repeat endings graphically on page 652

Deleting repeat endings
You can delete repeat endings without deleting notes and other items to which they apply.
PROCEDURE
1.

In Write mode, select the repeat endings you want to delete.

2.

Delete the repeat endings in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The selected repeat endings are deleted.
NOTE
Any repeat barlines input as part of the deleted repeat endings are not deleted automatically.

RELATED LINKS
Deleting barlines on page 382

Changing the text shown in repeat endings
You can replace the text shown in individual segments in repeat endings, which by default shows
the playthrough numbers for the segment, with custom text.
PROCEDURE
1.

In Engrave mode, select the repeat ending segments whose text you want to change.
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2.

In the Properties panel, activate Custom text in the Repeat Endings group.

3.

Enter the text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The text shown in the selected segments is changed.
Deactivating Custom text restores the default text for the selected repeat ending segments.
NOTE
Deactivating properties permanently deletes any custom text entered.

Changing the appearance of individual final repeat ending
segments
You can change the appearance of the line ends in the final segments of individual repeat
endings, independently of your project-wide settings.
PROCEDURE
1.

Select the repeat endings whose final segment appearance you want to change. You can
do this in Write mode and Engrave mode.
NOTE
In Engrave mode, you can select any segment in the repeat ending.

2.

In the Properties panel, activate End of line in the Repeat Endings group.

3.

Select one of the following options from the menu:
●

Open, short

●

Open, full length

●

Closed

RESULT
The end of the line of the final segment in the selected repeat endings is changed.
TIP
You can change the appearance of final segments in all repeat endings project-wide in the
Segments section of the Repeat Endings page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for repeat endings on page 649
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Lengthening/Shortening repeat ending hooks
You can lengthen/shorten the hooks in repeat endings individually, independently of your
project-wide settings.
NOTE
You cannot change the hook length of an individual segment in a repeat ending. Changing the
hook length affects the whole repeat ending.

PROCEDURE
1.

In Engrave mode, select the repeat endings whose hooks you want to lengthen/shorten.

2.

In the Properties panel, activate Hook length in the Repeat Endings group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increasing the value makes repeat ending hooks longer. Decreasing the value makes repeat
ending hooks shorter.
TIP
You can change the default length of all repeat ending hooks project-wide on the Repeat
Endings page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for repeat endings on page 649

Repeat endings in MusicXML files
All aspects of repeat endings can be imported from and exported in MusicXML files.
However, while MusicXML can represent this, segments in the middle of sets of endings cannot
have an open right-hand end in Dorico.
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Rests are markings with a rhythmic value that indicate no note is played for that duration. Each
note duration has an equivalent rest, for example, a quarter note rest is different to a sixteenth
note rest.
All notes and rests within a bar must add up to the duration of the bar, according to the
prevailing time signature.
The table shows some examples of notes and the rests with the equivalent rhythmic value.
Duration

Note

Rest

Half

Quarter

Eighth

Sixteenth

During note input, Dorico automatically fills the gaps between notes with implicit rests of the
appropriate duration. Therefore, it is usually not necessary to input rests in Dorico.
RELATED LINKS
Implicit vs. explicit rests on page 657
Inputting rests on page 124
Hiding/Showing rests after the last note in voices on page 809
Hiding/Showing rests before the first note in voices on page 808

General placement conventions for rests
Rests are positioned at the rhythmic position at the start of their duration, and not in the middle
of beats as this can cause confusion over when the rest begins and ends. Rests are aligned with
other items at the same rhythmic position.
The only exception is whole bar rests, which are positioned at the visual center of bars. This way,
they are clearly distinguishable from half note and whole note rests that are followed by notes in
the same bar.
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Implicit vs. explicit rests
Rests stay within the staff wherever possible. They do not move above or below the staff when
the notes around them are very high or very low.
However, on staves with multiple voices, rests are placed higher on the staff, or above the staff,
for up-stem voices and lower on the staff, or below the staff, for down-stem voices.

Example rest positions in a multiple-voice context

Rests in multiple voices must not overlap. You can consolidate rests so that only one is shown
when multiple voices have a rest of the same duration at the same rhythmic position.
The precise vertical positioning of rests is limited, as their detailed shapes require specific
positions relative to staff lines and staff spaces.
RELATED LINKS
Deleting rests on page 660
Turning explicit rests into implicit rests on page 658

Implicit vs. explicit rests
Implicit rests are automatically shown around the notes you input, and their duration
automatically follows the time signature and their position in the bar. Explicit rests are rests that
are explicitly entered during note input by forcing their duration, or rests that were imported
from a MusicXML file.
Dorico notates implicit rests according to the current time signature, for example, different
implicit rests are shown in 6/8 compared to 4/4. This also applies if you later change the time
signature for existing notes and rests.
Therefore, it is not necessary to input rests in Dorico, as implicit rests are automatically shown
around the notes that you input. You can turn implicit rests into explicit rests by forcing their
duration to be fixed.

A quarter note input at the fourth eighth note of the
bar in a 6/8 time signature has a dotted quarter
implicit rest at the start of the bar.

A quarter note input at the fourth eighth note of the
bar in a 4/4 time signature has two implicit rests, a
quarter and an eighth, at the start of the bar.

Explicit rests cannot be suppressed when using the Starts voice and Ends voice properties to
hide rests before the first note in voices and after the last note in voices.
You can show rest colors to see which rests are implicit and which are explicit in your project.
RELATED LINKS
Inputting rests on page 124
Forcing the duration of notes/rests on page 125
Turning explicit rests into implicit rests on page 658
Hiding/Showing rests after the last note in voices on page 809
Hiding/Showing rests before the first note in voices on page 808
Showing rest colors on page 659
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Turning explicit rests into implicit rests
Implicit rests and explicit rests behave differently. For example, you can hide implicit rests using
the Properties panel, but you cannot hide explicit rests or rests with forced durations.
NOTE
You can only hide implicit rests using Starts voice and Ends voice in the Notes and Rests group
of the Properties panel.

PROCEDURE
1.

In Write mode, select the explicit rests you want to turn into implicit rests.

2.

Turn the selected explicit rests into implicit rests in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The selected explicit rests are now implicit rests. You can check this by showing rest colors.
RELATED LINKS
Showing rest colors on page 659
Hiding/Showing rests after the last note in voices on page 809
Hiding/Showing rests before the first note in voices on page 808

Per-flow notation options for rests
There are a number of options for how rests are positioned and notated, and when rests are
shown project-wide that you can choose from on the Rests page in Notation Options.
For example, you can change whether bar rests are shown in additional voices, when dotted
rests are permitted, and the default positions of rests in different contexts.
You can open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

●

Click Notation Options on the right of the Flows panel in Setup mode.

You can then select Rests from the Category menu.

Project-wide engraving options for rests
You can find options for the project-wide appearance of rests on the Rests page in Engraving
Options.
The options on the Rests page allow you to change the style, appearance, and precise position of
rests, including multi-bar rests during flows and multi-bar rests at the end of flows. For example,
the default appearance of multi-bar rests at the end of flows is to show “tacet al fine”, but you
can show the total bar count instead.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
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Showing rest colors
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Rests in the page list on the left of the dialog.
RELATED LINKS
Changing the appearance of multi-bar rests at the end of flows project-wide on page 659

Changing the appearance of multi-bar rests at the end of flows
project-wide
You can change the appearance of multi-bar rests that extend to the end of flows in all layouts
project-wide. By default, multi-bar rests that extend to the end of flows show “tacet al fine” above
the staff instead of the total bar count.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Rests in the page list.

3.

In the Multi-bar Rests section, choose one of the following options for Multi-bar rests
that extend to the end of the flow:

4.

●

Show tacet al fine

●

Show bar count

Click Apply, then Close.

Showing rest colors
You can show implicit rests and explicit rests in different colors.
PROCEDURE
●

Choose View > Note and Rest Colors > Implicit Rests.
●

A tick is shown beside Implicit Rests in the menu when rest colors are shown.

●

No tick is shown beside Implicit Rests in the menu when rest colors are not shown.

RESULT
Rests in your project appear gray if they are implicit, and black if they are explicit. For example,
this can be useful to help diagnose why rests do not disappear when you activate Starts voice
and Ends voice, as these properties only hide implicit rests.
Once you have identified rests as explicit rests, you can delete them. The implicit rests that
replace them now respect the Starts voice and Ends voice properties.
EXAMPLE

Rests colored black, as they appear without implicit
rests shown
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Hiding/Showing rests
RELATED LINKS
Deleting rests on page 660

Hiding/Showing rests
You can hide/show implicit rests by suppressing all rests before/after notes, up to the start/end
of the flow.
PROCEDURE
1.

Select the notes before/after which you want to hide/show rests. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate/deactivate the following properties, individually or
together, in the Notes and Rests group:
●

Starts voice

●

Ends voice

RESULT
Implicit rests are hidden before/after the selected notes when the properties are activated, and
shown when the properties are deactivated.
If rests are not hidden when you activate either property, it might be because there are explicit
rests in the bar. You must turn explicit rests into implicit rests before you can hide them.
TIP
You can also suppress implicit rests in any gaps between different voices that might occur in the
middle of a flow.
This requires you to set Ends voice on the last note of the first voice, and Starts voice on the first
note of the second voice, if the gap between those notes spans multiple barlines.

RELATED LINKS
Implicit vs. explicit rests on page 657
Hiding/Showing bar rests in empty bars on page 376
Turning explicit rests into implicit rests on page 658
Hiding/Showing rests before the first note in voices on page 808
Hiding/Showing rests after the last note in voices on page 809

Deleting rests
You can delete both implicit rests and explicit rests.
NOTE
If you want to delete rests because multiple rests of the same duration appear at the same
position in multiple-voice contexts, you can choose to consolidate these rests in the Rest
positioning section of the Rests page in Notation Options.

PROCEDURE
1.

In Write mode, select the rests you want to delete.
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TIP
You can select rests individually, or make a larger selection that contains the rests you
want to delete.
2.

Choose Edit > Remove Rests.

RESULT
All rests in the selection are deleted. This is done by automatically setting the properties for
Starts voice and Ends voice in the Notes and Rests group of the Properties panel so that no
rests are shown where you removed them.
TIP
You can undo deleting rests immediately.
You can also show rests again later by selecting the notes or rests immediately to the right/left of
deleted rests and deactivating the corresponding Starts voice or Ends voice properties in the
Notes and Rests group of the Properties panel.

RELATED LINKS
Rests on page 656
Large selections on page 109
Showing rest colors on page 659
Hiding/Showing rests on page 660
Implicit rests in multiple-voice contexts on page 807
Hiding/Showing rests before the first note in voices on page 808
Hiding/Showing rests after the last note in voices on page 809
Per-flow notation options for rests on page 658

Moving individual rests vertically
You can change the vertical position of rests individually, for example, if you want to change the
staff line from which a whole bar rest hangs.
Moving rests vertically shows multiple rests at that rhythmic position if more than one voice on
the staff has a rest of the same duration.
By default, Dorico consolidates rests in multiple-voice contexts.
NOTE
You cannot change the vertical position of rests when using the mouse.

PROCEDURE
1.

Select the rests whose vertical positions you want to change, or rests at the rhythmic
positions where you want to see rests for every voice. You can do this in Write mode and
Engrave mode.

2.

Activate Rest pos..

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.
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RESULT
Increasing the value moves rests upwards. Decreasing the value moves rests downwards.
If there are multiple voices on the staff with rests of the same duration, multiple rests are now
shown.
TIP
●

You can choose to show all rests in every voice or only show one rest for all voices in the
Rest positioning section of the Rests page in Notation Options.

●

You can change the horizontal position of rests, and the spacing around them, in Engrave
mode when Note Spacing is activated, in the same ways as changing the position of
notes.

RELATED LINKS
Notation Options dialog on page 110
Note spacing on page 284
Adjusting note spacing at individual rhythmic positions on page 291
Adjusting the spacing of individual notes/items independently of their rhythmic positions on
page 292
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Slurs are tapered, curved lines that join notes to indicate legato articulation and phrasing.
Depending on the context and the instrument to which they apply, slurs can have additional
meanings to simply marking phrases. For example, for wind players, a slur indicates that all the
notes in the phrase are played in the same breath and without re-tonguing or re-articulating any
notes. For string players, a slur indicates that all the notes in the phrase are played legato and
under one bow. For singers, slurs indicate that more than one note is sung to the same syllable.
Slurs can be placed both above and below the staff, depending on the stem directions of the
notes to which they apply. In order to keep slur endpoints close to notes, slurs are placed outside
articulations on notes in the middle of slurs, but between notes and larger articulations on the
first/last notes of slurs. For example, accents and stress marks are placed outside the ends of
slurs but staccato and tenuto marks are placed inside the ends of slurs by default.
TIP
You can change the placement of accent, marcato, stress, and unstress articulations relative to
slurs in the Slurs section of the Articulations page in Engrave > Engraving Options.
NOTE
Slurs must not be confused with ties, which look superficially similar, but instead join notes of the
same pitch to indicate that they are played as a single note. In that sense, ties are part of
rhythmic notation, while slurs are considered articulation.

RELATED LINKS
General placement conventions for slurs on page 663
Inputting slurs on page 208
Ties on page 735
Project-wide engraving options for articulations on page 369

General placement conventions for slurs
The placement of slurs relative to the staff, and therefore their curvature direction, depends on
the stem direction of the notes within the slur. Depending on whether slurs are placed on the
notehead or stem side of notes, their endpoint positions are different.

Slur direction
A slur on a single staff always curves upwards and is placed above the notes, unless all of the
notes under the slur are up-stem, in which case it curves downwards and is placed below the
notes. If a slur applies to a mixture of up-stem and down-stem notes, it is placed above the staff
and curves upwards.
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Examples of the slur direction changing according to the stem direction

You can set your preference for whether slurs follow the stem direction, or always appear above
notes, on the Slurs page in Engrave > Engraving Options.
NOTE
In jazz scores, slurs are sometimes treated as an articulation and so positioning all slurs above
the staff is preferred.

Stem-side slurs between unbeamed notes
In Dorico, slurs appear between the stems of unbeamed notes when placed on their stem side,
and the default setting is for them to attach a short distance from the end of the stem.

You can change where slurs attach to stems by adjusting Vertical offset from end of stem in
the Endpoint Positioning section of the Slurs page in Engrave > Engraving Options.
RELATED LINKS
Slur endpoint position relative to other items on page 667

Slur position relative to tie chains
There are different conventions for the position of slurs relative to tie chains in music for modern
use and historical editions.
Modern practice is for slurs to start on the first note in tie chains, and end on the last note in tie
chains. This makes the full length of the phrase visually clear to the performer, which helps their
performance.

Slur ending on the last note in a tie chain

Slur starting from the first note in a tie chain

However, in historical editions, slurs might end on the first note in a tie chain, and start on the
last note in a tie chain. Both of these changes save vertical space, as shorter slurs do not extend
as far above or below a staff.

Slur ending on the first note in a tie chain

Slur starting on the last note in a tie chain
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You can choose whether all slurs start on the first/last note in tie chains, and end on the first/last
note in tie chains, on the Slurs page in Engrave > Engraving Options. There are different
options for slurs between normal notes and slurs starting on grace notes.
RELATED LINKS
Changing the position of slurs relative to tie chains on page 665

Changing the position of slurs relative to tie chains
You can change the position of individual slurs relative to tie chains, including slurs starting on
grace notes, independently of your project-wide settings, for example, to save vertical space.
PROCEDURE
1.

Select the slurs whose position relative to tie chains you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate the following properties, individually or together, in the
Slurs group:

3.

●

Start pos. in tie chain

●

End pos. in tie chain

Choose one of the following options for each property:
●

First note

●

Last note

RESULT
The position of the selected slurs relative to tie chains is changed.
TIP
You can change the default position of all slurs relative to tie chains project-wide on the Slurs
page in Engrave > Engraving Options. There are different options for slurs between normal
notes and slurs starting on grace notes.

RELATED LINKS
Project-wide engraving options for slurs on page 667
Slur position relative to tie chains on page 664

Slur placement relative to grace notes
There are specific placement rules that affect slurs when they start from a grace note and end on
a normal note immediately following the grace note.
These rules are:
●

Slurs connect noteheads rather than stems.

●

Slurs are scaled to match the proportions of grace notes.

●

Slurs must not obscure ledger lines.

●

Slurs are placed above notes if they would collide with the accidental of a standard note
when placed below the notes.

You can adjust the values for the different parameters of the special placement rules. For
example, you can change the vertical and horizontal offsets for the right-hand end of a grace
note slur relative to the standard, full-sized notehead to which it is attached in the Grace Notes
section of the Slurs page in Engrave > Engraving Options.
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NOTE
These rules do not apply when slurs attach to a standard note at any rhythmic position beyond
the note immediately following the grace note.
Due to the general placement conventions of grace notes, slurs in Dorico appear below grace
notes and curve downwards by default. Slurs starting from grace notes only appear above notes
and curve upwards in up-stem voices in multiple-voice contexts.

Automatic changes to the curvature direction of slurs on grace notes in multiple-voice contexts

You can change the automatic placement of grace note slurs by changing the stem direction of a
grace note, changing the direction of a slur, and using the slur handles in Engrave mode to
adjust the position of a slur in finer detail.
RELATED LINKS
Changing the curvature direction of slurs on page 684
Changing the stem direction of notes on page 714
General placement conventions for grace notes on page 517
Slurs in Engrave mode on page 675
Moving slurs and slur handles graphically on page 677

Slur position relative to staff lines
Slur endpoints must not touch staff lines, and the high point of the arcs of slurs should not stop
on staff lines.
This is the convention because a slur whose arc peaks on a staff line can create the appearance
of a triangular wedge between the staff line and the curve of the slur. If a slur peaks on a staff
line, you can adjust its height so that it peaks either above/below the staff.
NOTE
Although Dorico automatically ensures slur endpoints do not touch staff lines, manual
adjustments might be necessary to position the arcs of slurs correctly.
You can set a value for the minimum distance between slur endpoints and staff lines in the
Avoiding Collisions section of the Slurs page in Engrave > Engraving Options. The default
position of slur endpoints relative to staff lines is 1/4 space above/below, to ensure the start/end
points do not touch the staff line.
RELATED LINKS
Project-wide engraving options for slurs on page 667
Changing the height of slurs on page 681
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Slur endpoint position relative to other items
In order to avoid collisions, the default positions of slur endpoints vary depending on whether
slurs are placed on the notehead side or stem side of notes, their position relative to staff lines,
and whether articulations, ties, and other slurs exist at the same rhythmic position.

Slur endpoints relative to noteheads and stems
The default position of slur endpoints relative to noteheads is 1/2 space above a notehead in a
space on the staff, and 1/4 space above a notehead on a line on the staff.
You can change the vertical and horizontal offsets for the endpoints of slurs in the Endpoint
Positioning section of the Slurs page in Engraving Options. However, you might also need to
reduce the value for Minimum gap inside slur curvature to avoid collisions in the Avoiding
Collisions section, as endpoints cannot be closer to noteheads than this value.
NOTE
This value affects all slur collisions in your project.

Slur endpoints relative to articulations
By default, articulations of force and stress are placed outside slur endpoints, and articulations of
duration are placed inside slur endpoints, which automatically raises the endpoints.
You can position slur endpoints closer to articulations by reducing the value for Minimum gap
inside slur curvature to avoid collisions in the Avoiding Collisions section of the Slurs page in
Engraving Options.
NOTE
Changing this value affects the position of slur endpoints project-wide. You may find it more
appropriate to move slur endpoints relative to articulations individually in Engrave mode.

Slur endpoints relative to ties and other slurs
The default position of slur endpoints is 1/4 space above an existing slur that starts/ends on the
same note.
You can change this by increasing/decreasing the value for Minimum vertical gap between two
slurs starting or ending on the same note in the Avoiding Collisions section of the Slurs page
in Engraving Options.
To make slurs appear closer to tied notes, you can adjust the values for slur endpoint position
relative to noteheads.
RELATED LINKS
Project-wide engraving options for slurs on page 667
Slurs in Engrave mode on page 675
Moving slurs and slur handles graphically on page 677
Articulations on page 367

Project-wide engraving options for slurs
You can find options for the project-wide appearance, position, and placement of slurs on the
Slurs page in Engraving Options.
The options on the Slurs page allow you to change the direction, style, height, and thickness of
slurs. You can also set precise values for the positions of slurs relative to noteheads, stems, grace
notes, and ties, and change the collision avoidance behavior of cross-staff slurs.
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There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Slurs in the page list on the left of the dialog.
RELATED LINKS
Cross-staff and cross-voice slurs on page 668

Cross-staff and cross-voice slurs
Cross-staff slurs start on one staff and end on another staff, and cross-voice slurs start in one
voice and end in another voice.
Dorico positions cross-staff and cross-voice slurs in the same way as it positions standard slurs,
so their appearance might be the same as standard slurs. You can move and lengthen/shorten
cross-staff and cross-voice slurs in the same ways as standard slurs, however, they do not behave
in the same way.
For example, you cannot move cross-voice slurs to notes on the same staff in other voices, and
you cannot lengthen cross-voice slurs to notes on the same staff in other voices. You also cannot
shorten cross-voice slurs if noteheads under the slur are not in one of the voices in which the slur
started/ended.
You can only move and lengthen/shorten cross-staff slurs to notes on the same staff as the
corresponding endpoint. For example, if a cross-staff slur covers a phrase that starts on the
bottom staff and ends on the upper staff, you can only shorten the cross-staff slur to the first
note on the upper staff, you cannot shorten it to any notes on the bottom staff.
The different voices can be on the same staff, or on different staves.
RELATED LINKS
Inputting cross-staff and cross-voice slurs on page 668
Lengthening/Shortening slurs on page 671
Moving slurs rhythmically on page 670

Inputting cross-staff and cross-voice slurs
You can input cross-staff and cross-voice slurs. For example, musical phrases in grand staff
instruments, such as piano and harp, can span both staves and may need slurs to join them.
PROCEDURE
1.

In Write mode, select the note from which you want the slur to start, in any voice or staff.

2.

Ctrl/Cmd-click the note where you want the slur to end, in any voice and on any staff
belonging to the same instrument as the note in step 1.
NOTE
Only select those two notes.

3.

Input a slur in any of the following ways:
●

Press S.

●

Click Slur in the Notes panel.
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RESULT
A cross-voice or cross-staff slur is input spanning the select notes. It is placed either above or
below the notes, depending on the stem direction of the notes within the selection.
TIP
You can change the curvature direction of individual slurs.

RELATED LINKS
Cross-staff and cross-voice slurs on page 668
Changing the curvature direction of slurs on page 684

Nested slurs
Nested slurs are two or more slurs used simultaneously, where the overarching slur shows the
structure of the phrase and the inner slurs show the articulation within the phrase. They are also
known as “slurs within slurs”.
Depending on the stem directions within the overarching outer slur and your settings on the
Slurs page in Engrave > Engraving Options, inner slurs may appear on the opposite side of the
staff to the outer slur.

A phrase with nested slurs

If you want to change the default distance between the endpoints of nested slurs, you can
increase/decrease the project-wide value for Minimum vertical gap between two slurs
starting or ending on the same note in the Avoiding Collisions section of the Slurs page in
Engraving Options.
You can input nested slurs in the same ways as inputting standard slurs, and Dorico makes
automatic adjustments to their positioning to avoid collisions if you have not activated Disable
auto curve adjustment in the Slurs group of the Properties panel in Engrave mode.
RELATED LINKS
Inputting nested slurs during step input on page 669
Adding nested slurs to existing notes on page 670
Disabling slur collision avoidance for individual slurs on page 688

Inputting nested slurs during step input
You can input nested slurs directly during step input, for example, if you already know how you
want to phrase the notes you are currently inputting.
PROCEDURE
1.

In Write mode, start note input.

2.

Start two slurs from the currently selected note in any of the following ways:
●

Press S twice.
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●

Click Slur twice in the Notes panel.

One slur is the inner slur, the other slur is the outer slur.
3.

Input your notes.
The slurs extend automatically as you continue inputting notes, even if there are rests
between the notes you input.

4.

Press Shift-S once.
The inner slur ends on the currently selected note.

5.

Continue inputting notes.

6.

Optional: Start/End other inner slurs.

7.

Press Shift-S again.
The outer slur ends on the currently selected note.

RELATED LINKS
Nested slurs on page 669

Adding nested slurs to existing notes
You can add multiple slurs to existing notes so that they appear as nested slurs.
PROCEDURE
1.

In Write mode, select the notes you want to include in the outer slur.

2.

Press S.

3.

Select the notes within the outer slur that you want to place under an inner slur.

4.

Press S.

5.

Optional: Repeat steps 3 and 4 for any other inner slurs you want.
NOTE
●

You can input the outer slur and inner slurs in any order as Dorico automatically
adjusts slurs so that shorter slurs are positioned within longer slurs, and makes sure
they do not collide.

●

Slur collisions are not automatically avoided if you activate Disable auto curve
adjustment in the Slurs group of the Properties panel for individual notes.

RELATED LINKS
Slur collision avoidance on page 687

Moving slurs rhythmically
You can move slurs to new rhythmic positions after they have been input. They are positioned
according to your project-wide settings on the Slurs page in Engraving Options.
PROCEDURE
1.

In Write mode, select the slurs you want to move.
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NOTE
When using the mouse, you can only move one slur rhythmically at a time.
2.

Move the slurs to the next or previous noteheads on the staff in any of the following ways:
●

Press Alt-Right Arrow to move them to the next notehead on the staff.

●

Press Alt-Left Arrow to move them to the previous notehead on the staff.

●

Click and drag the slur to the right/left.

RESULT
The slurs are moved to the next or previous noteheads on the staff.
NOTE
The rhythmic duration of slurs is usually maintained. However, depending on the rhythms they
cross as they move, slurs may cover longer/shorter durations than before they were moved.
You can adjust the shape and position of individual slurs graphically in Engrave mode.

RELATED LINKS
Slurs in Engrave mode on page 675
Moving slurs and slur handles graphically on page 677

Lengthening/Shortening slurs
You can change the length of slurs rhythmically after they have been input.
NOTE
You can only lengthen/shorten cross-staff slurs to notes on the same staff as the corresponding
endpoint, and you can only lengthen/shorten cross-voice slurs to notes in the same voice as the
corresponding endpoint.

PROCEDURE
1.

In Write mode, select the slurs you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one slur at a time.

2.

Lengthen/Shorten the slurs in any of the following ways:
●

Press Shift-Alt-Right Arrow to lengthen the slur to the next notehead.

●

Press Shift-Alt-Left Arrow to shorten the slur to the previous notehead.
NOTE
Key commands lengthen/shorten items by moving their end only. You can move the
start of slurs by moving the whole slur, or by clicking and dragging the start handle.

●

Click and drag the start/end of the slur to the next/previous notehead.

RESULT
The slur is lengthened/shortened.
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RELATED LINKS
Moving slurs rhythmically on page 670
Slurs in Engrave mode on page 675
Cross-staff and cross-voice slurs on page 668

Linked slurs across multiple staves
Slurs of the same duration at the same rhythmic position on multiple staves are linked together
automatically. This happens only when you copy and paste slurs or material including slurs
between staves, or enter them simultaneously.
If slurs are linked, moving one slur in the linked group moves any slurs linked to it in the same
way. Similarly, lengthening or shortening a slur in a linked group lengthens or shortens any slurs
linked to it in the same way.
However, deleting one slur in a linked group only deletes the slur selected, not the whole group.
Linked slurs appear highlighted when any slur in the linked group is selected.

Three linked slurs with the top slur selected

You can also manually link and unlink slurs.
RELATED LINKS
Inputting slurs on page 208
Linking slurs together on page 672
Unlinking slurs on page 673

Linking slurs together
Dorico automatically links slurs of the same duration at the same rhythmic positions together
when you copy and paste slurs or material including slurs between staves, or enter them
simultaneously. However, you can also link slurs together manually.
PROCEDURE
1.

In Write mode, select the slurs you want to link together.
NOTE
Only slurs that have the same duration and start at the same position can be linked
together.

2.

Choose Edit > Slurs > Link. You can also choose this option from the context menu.
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RESULT
The selected slurs are linked together.
RELATED LINKS
Linked slurs across multiple staves on page 672

Unlinking slurs
You can unlink slurs manually that were automatically linked together, for example, if you want
to lengthen/shorten them independently of each other.
PROCEDURE
1.

In Write mode, select a slur from each linked group you no longer want to be linked.

2.

Choose Edit > Slurs > Unlink. You can also choose this option from the context menu.

RESULT
All slurs linked to the selected slurs are unlinked.
NOTE
You cannot only unlink a single slur from the group.

RELATED LINKS
Linked slurs across multiple staves on page 672

Slur segments
A standard slur consists of one segment. You can make more elaborate shapes with slurs with
multiple segments, for example, to allow you to create more complex slur shapes than are
possible with a single curved segment.
Adding more segments to a slur by default creates evenly spaced waves within its length.
Therefore, having more segments makes each wave shorter.

Slur with eight segments

In Engrave mode, you can move each segment graphically, independently of the other segments
in the slur, as each segment has its own set of five square handles. These allow you to form slurs
into unusual and complicated shapes.
NOTE
You may find that you need more segments than there are curves in your planned shape, as in
many cases you need a segment for each significant change of angle. In Dorico, you can
increase/decrease the number of segments in a slur at any time.
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An unusual slur shape created using five segments.

The same slur, showing the positions of the handles
of all five segments.

RELATED LINKS
Changing the number of segments in individual slurs on page 674
Moving slurs and slur handles graphically on page 677
Slurs in Engrave mode on page 675
Multi-segment slurs in Engrave mode on page 675

Changing the number of segments in individual slurs
You can change the number of segments in individual slurs, for example, to allow you to create
slurs with unusual shapes.
PROCEDURE
1.

In Engrave mode, select the slurs whose number of segments you want to change.

2.

In the Properties panel, activate Number of segments in the Slurs group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increasing the value increases the number of slur segments. Decreasing the value decreases the
number of slur segments.
AFTER COMPLETING THIS TASK
You can adjust the shape of slur segments in more detail using their handles.
NOTE
Handles on multi-segment slurs are connected to the corresponding type of handle on adjacent
segments. Moving handles causes any connected handles to move the same amount in the
opposite direction.

RELATED LINKS
Slur segments on page 673
Multi-segment slurs in Engrave mode on page 675
Moving slurs and slur handles graphically on page 677
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Slurs in Engrave mode
In Engrave mode, each slur has five square handles that you can move independently. When
using slur handles to edit slurs in Engrave mode, each handle adjusts the corresponding part of
the slur but can also affect the positions of other handles on the slur.

Slurs have the following handles in Engrave mode:
1

Left endpoint

2

Left control point

3

Slur height

4

Right control point

5

Right endpoint

For example, moving the left endpoint moves the start of a slur, but the rest of the handles stay
in their existing positions. However, moving the right control point also causes the slur height
handle to move. This gives you fine control over the shape of ties, while ensuring the end result
remains curved and smooth.
NOTE
Multi-segment slurs have additional links between control point handles that affect how they
move in relation to other handles moving.
You can move these handles to change the shape of slurs with the keyboard, with the mouse,
and by using properties in the Slurs group of the Properties panel.
RELATED LINKS
Slur shoulder offset on page 682
Slur height on page 680
Multi-segment slurs in Engrave mode on page 675

Multi-segment slurs in Engrave mode
In Engrave mode, each segment in multi-segment slurs, such as S-shaped slurs, has handles just
like standard slurs. This allows you to edit each segment of multi-segment slurs independently as
if they were separate slurs, but in order to maintain a consistent shape, moving certain handles
causes other handles to move simultaneously.
Multi-segment slurs have the following handles in Engrave mode:
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1

Left endpoint

2

Left control point

3

Slur height

4

Right control point

5

Center control point

6

Left control point

7

Slur height

8

Right control point

9

Right endpoint

You can select and move each handle in the same ways as for standard slurs, however, handles
on multi-segment slurs are connected between adjacent segments. Moving a connected control
point causes the control point at the start/end of the next/previous segment to move the same
amount in the opposite direction. This avoids tight corners, ensuring that multi-segment slurs
are always as smoothly and symmetrically curved as possible.
In multi-segment slurs, right control points are connected to the left control point in the adjacent
segment. If there is no adjacent segment, the right/left control points next to the right/left
endpoints can be moved independently. For example, in the labelled diagram, the control point 4
is connected to control point 6, but control points 2 and 8 are not connected to another control
point.
Similarly, moving the slur height handle causes the slur height handle on any adjacent segments
to move the same amount in the opposite direction. For example, if you move the slur height
handle on the middle segment of a slur with three segments, all three slur height handles are
moved.
EXAMPLE

Moving the selected left control point upwards and
to the left causes the right control point on the
adjacent segment to move downwards and to the
right.

The left control point is selected.
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Moving slurs and slur handles graphically
You can move whole slurs and individual slur handles graphically, for example, if you want to
change the shape of individual slurs or move individual slur endpoints. This only changes the
appearance of slurs, and does not change the rhythmic positions to which they are attached.
PROCEDURE
1.

In Engrave mode, select the whole slurs or individual slur handles you want to move in any
of the following ways:
●

Ctrl/Cmd-click multiple slurs.

●

Select a whole slur and press Tab to cycle through the handles until the one you
want to move is selected.

●

Click the handle you want to move.

●

Ctrl/Cmd-click individual handles on multiple slurs.

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the slurs or handles in any of the following ways:
●

Press Alt-Right Arrow to move handles to the right.

●

Press Alt-Left Arrow to move handles to the left.

●

Press Alt-Up Arrow to move slurs or handles upwards.

●

Press Alt-Down Arrow to move slurs or handles downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the slurs upwards/downwards.

●

Click and drag the handles in any direction.

NOTE
You cannot move whole slurs to the right/left, you can only move them upwards/
downwards.
3.

Optional: Repeat steps 1 and 2 for any other slurs or slur handles you want to move.

RESULT
The selected slurs or slur handles are moved. Depending on the handles you selected, this can
change the shape of the corresponding slurs.
TIP
The following properties in the Slurs group of the Properties panel are activated automatically
when you move the corresponding slur handles:
●

Start offset moves the left endpoints of slurs. X moves them horizontally, Y moves them
vertically.

●

End offset moves the right endpoints of slurs. X moves them horizontally, Y moves them
vertically.

●

Start handle offset moves the left control points of slurs. X moves them horizontally, Y
moves them vertically.
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●

End handle offset moves the right control points of slurs. X moves them horizontally, Y
moves them vertically.

For example, if you move a whole slur upwards and to the right, all of its handles are moved so
all properties are activated. You can also use these properties to change the shape of individual
slurs by changing the values in the value fields.
Deactivating the properties resets the corresponding handles on the selected slurs to their
default positions.

RELATED LINKS
Slur height on page 680
Slur shoulder offset on page 682

Changing the angle of slurs
You can change the angle or rotation of individual slurs without affecting their overall shape.
This is useful, for example, if you want one end of a slur to start higher after a system break than
its default position, as you can change the rotation of the slur while keeping all slur handles on
the slur in the same positions relative to each other.
PROCEDURE
1.

In Engrave mode, select an endpoint on the slurs whose angle you want to change.
TIP

2.

●

You can select individual handles on multiple slurs by holding down Ctrl/Cmd and
clicking.

●

You can show handles on all items, not just selected items, by choosing Engrave >
Show Handles > Always. This can make it easier to select individual handles on
multiple items.

Alt-click and drag the endpoints in any direction.
NOTE
You cannot use the keyboard to change the angles of individual slurs.

RESULT
The angle or rotation of the selected slurs is changed without affecting their shape.
EXAMPLE

Endpoint moved without holding Alt

Endpoint moved while holding Alt
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Changing the thickness of slurs
You can change the thickness of individual slurs, independently of your project-wide settings.
You can also change the thickness of the middle of slurs independently of the ends of slurs.
PROCEDURE
1.

In Engrave mode, select the slurs whose thickness you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Slurs group:

3.

●

End thickness

●

Middle thickness

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

RESULT
Increasing the values makes the corresponding part of the selected slurs thicker, decreasing the
values makes the corresponding part of the selected slurs thinner.
TIP
●

Deactivating the properties returns the corresponding part of the selected slurs to their
default thickness.

●

You can change the default thickness of all slurs project-wide on the Slurs page in
Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for slurs on page 667

Short slurs that cover large pitch ranges
When short slurs span large pitch ranges, they are significantly rotated to compensate. This can
make the ends of short slurs appear too angular.
You can move the control point handles of slurs to improve their curves.
Of the three examples, the middle slur has the smoothest curve. The handles on the slur in the
example have been moved poorly, making the curve far too angular.
In the bottom row, the positions of the handles are shown to indicate how the curve above was
created.

Short slur spanning a large pitch
range, without adjustment

The same slur with some shape
adjustment, making the curve
smoother
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The same slur again with poor
adjustment, making the curve too
angular
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Default slur handle placement

Slur handle placement to create
the corresponding slur

Slur handle placement to create
the corresponding slur

TIP
When adjusting slur ends, you can achieve the best results using the following guidelines:
●

The control point at the lower end of the slur does not extend outside the width of the slur,
as marked by its neighboring endpoint.

●

The control point at the higher end of the slur does not form an angle greater than 90
degrees relative to the endpoints. You can use the dashed lines to help you judge this.

You can adjust the shape of short slur ends in different ways:
●

Project-wide, by increasing the value for Offset shoulders by fraction of half length of
short slur, which you can find by clicking Advanced Options in the Design section of the
Slurs page in Engrave > Engraving Options.

●

Individually, by activating Start handle offset and End handle offset in the Properties
panel in Engrave mode, and changing their X values.

●

Individually, by moving the handles of slurs in Engrave mode.

RELATED LINKS
Slurs in Engrave mode on page 675
Project-wide engraving options for slurs on page 667
Moving slurs and slur handles graphically on page 677

Slur height
The height of slurs determines how far above/below notes slurs extend vertically.
You can change values for the heights of all slurs project-wide on the Slurs page in Engraving
Options. You can also change the height of individual slurs in Engrave mode.
Increasing the height of slurs makes them extend further from the staff. This gives them a
rounder shape, which takes up more vertical space. Where vertical space is limited, there should
be a balance between how curved slurs are, which can help readability for players, and ensuring
staves do not overlap.

A long slur with default height

A long slur with increased height

A long flat slur with default height

A long flat slur with increased height
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TIP
You can find options that change project-wide values for the height of short slurs, short flat slurs,
long slurs, and long flat slurs by clicking Advanced Options in the Design section of the Slurs
page in Engrave > Engraving Options.

RELATED LINKS
Changing the height of slurs on page 681
Project-wide engraving options for slurs on page 667

Changing the height of slurs
You can change the height of individual slurs independently of your project-wide settings, for
example, to reduce the height of a particularly long slur.
PROCEDURE
1.

In Engrave mode, select the slur height (middle) handle of the slurs whose height you
want to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.

2.

Move the slur height handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●

Click and drag them upwards/downwards.

RESULT
The height of the selected slurs is changed.
NOTE
●

To maintain a visually pleasing and symmetrical curve when changing the height of slurs
manually, you may need to move slur height handles to the right/left by a small amount,
as well as upwards/downwards.

●

Moving slur height handles to the right/left affects the shape of the whole slur.

●

You can find options controlling the default height of all slurs project-wide by clicking
Advanced Options in the Design section of the Slurs page in Engrave > Engraving
Options. There are separate settings for short slurs and long slurs.

RELATED LINKS
Slur height on page 680
Moving slurs and slur handles graphically on page 677
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Slur shoulder offset
Slur shoulders affect the angles of the curves of slurs as they taper towards an endpoint, because
the tapered ends often approach noteheads at a steeper angle than that of a slur’s arch.
Increasing the shoulder offset makes the onset of the curve shallower, whereas decreasing the
shoulder offset makes the onset steeper. The shoulder offset must therefore be balanced with
the height of the slur in order to achieve the ideal curved shape.

A long slur with default shoulder
offset of 1/5

A long slur with increased
shoulder offset of 1.5

A long slur with decreased
shoulder offset of 1/2

You can change the project-wide settings for the shoulder offset of slurs and the shoulder offset
of flat slurs by changing the values of the following options, which you can find by clicking
Advanced Options in the Design section of the Slurs page in Engraving Options.
●

Offset shoulders by fraction of half length of short slur

●

Offset shoulders by fraction of half length of long slur

●

Offset shoulders by fraction of half length of flat slur

You can adjust the shoulders of individual slurs in Engrave mode.
RELATED LINKS
Slur height on page 680
Changing the shoulder offset of slurs on page 682

Changing the shoulder offset of slurs
You can adjust the shoulders of individual slurs, independently of your project-wide settings, by
moving their control point handles. You can move each control point independently.
PROCEDURE
1.

In Engrave mode, select one of the control point handles on each of the slurs whose
shoulders you want to adjust in any of the following ways:
●

Select a whole slur and press Tab to cycle through the handles until the one you
want to move is selected.

●

Click the handle you want to move.

●

Ctrl/Cmd-click individual handles on multiple slurs.

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
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TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.
●
3.

Click and drag them in any direction.

Optional: Repeat steps 1 and 2 for the other control point handle on the slurs whose
shoulders you want to adjust.

RESULT
The shoulder offset of the selected slurs is changed.
TIP
The following properties in the Slurs group of the Properties panel are activated automatically
when you move the corresponding slur handles:
●

Start handle offset moves the left control points of slurs. X moves them horizontally, Y
moves them vertically.

●

End handle offset moves the right control points of slurs. X moves them horizontally, Y
moves them vertically.

You can also use these properties to change the shoulder offset of individual slurs by changing
the values in the value fields.
Deactivating the properties resets the corresponding handles on the selected slurs to their
default positions.
TIP
You can find options controlling the default shoulder offset of all slurs project-wide by clicking
Advanced Options in the Design section of the Slurs page in Engrave > Engraving Options.
There are separate settings for short slurs and long slurs.

RELATED LINKS
Slur shoulder offset on page 682
Project-wide engraving options for slurs on page 667

Slur curvature direction
Slurs can curve upwards, downwards, or have a multi-segment S-shape.
The following options for slur curvature direction are available when you activate Direction in
the Slurs group of the Properties panel:
Up
Forces slurs to curve upwards, and appear above notes.

Down
Forces slurs to curve downwards, and appear below notes.
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Up/Down
Forces slurs to comprise two segments: the first curves upwards, the second curves
downwards to create a mirrored S-shape. It is typically used when phrases start in
the lower staff and end in the upper staff, for example, in piano parts.

Down/Up
Forces slurs to comprise two segments: the first curves downwards, the second
curves upwards to create an S-shape. It is typically used when phrases start in the
upper staff and end in the lower staff, for example, in piano parts.

NOTE
You can adjust the precise shapes of individual slurs, and each slur segment, in Engrave mode
using the square handles on each slur.

RELATED LINKS
Slurs in Engrave mode on page 675
Moving slurs and slur handles graphically on page 677

Changing the curvature direction of slurs
You can change the curvature direction of individual slurs so that they curve upwards,
downwards, or have a multi-segment S-shape, independently of your project-wide settings.
PROCEDURE
1.

Select the slurs whose curvature direction you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Direction in the Slurs group.

3.

Choose one of the following options:
●

Up

●

Down

●

Up/Down (mirrored S-shape)

●

Down/Up (S-shape)

RESULT
The curvature direction of the selected slurs is changed.
TIP
●

You can adjust the precise shapes of slurs, and each slur segment, in Engrave mode using
the handles on each slur.

●

You can change the default curvature direction behavior of all slurs project-wide on the
Slurs page in Engrave > Engraving Options.

RELATED LINKS
Slur curvature direction on page 683
Slurs in Engrave mode on page 675
Moving slurs and slur handles graphically on page 677
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Slur styles
There are different styles of slurs available in Dorico, which indicate different meanings and have
different use cases.
The following options for slur style are available when you activate Style in the Slurs group of the
Properties panel:
Solid
This is the default style for slurs. Slurs appear as tapered solid lines: thinner at the
ends and thicker in the middle.

Dashed
Slurs appear as tapered dashed lines. Can be used to indicate an optional slur, for
example, to recommend breathing/bowing patterns.

Dotted
Slurs appear as dotted lines. The dots are the same size and the same distance apart
over the whole length of the slur.

Half-dashed start
The first halves of slurs appear as dashed lines, the second halves as solid lines. Used
to denote that a slur was written incompletely in the source in critical editions.

Half-dashed end
The first halves of slurs appear as solid lines, the second halves as dashed lines. Used
to denote that a slur was written incompletely in the source in critical editions.

Editorial
Slurs appear as solid black lines, but with a smaller vertical line intersecting them
exactly halfway along their length. Used to show that slurs were added by the editor
and was not present in the original source.

NOTE
You can set the precise parameters of each of these options project-wide on the Slurs page in
Engrave > Engraving Options. For example, you can change the length and width of the stroke
in Editorial slurs, the diameter of dots and length of dashes, and the sizes of the gaps between
dots and dashes.

RELATED LINKS
Changing the style of slurs on page 686
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Changing the style of slurs
You can change the style of individual slurs after they have been input.
PROCEDURE
1.

Select the slurs whose style you want to change. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Style in the Slurs group.

3.

Select one of the following options from the menu:
●

Solid

●

Dashed

●

Dotted

●

Half-dashed start

●

Half-dashed end

●

Editorial

RELATED LINKS
Slur styles on page 685

Changing individual slurs to flat slurs
Although they are not often used as standard, some publishers use flat slurs in order to reduce
the vertical space occupied by slurs. You can change individual slurs to flat slurs, independently
of your project-wide setting.
Short slurs, that is, slurs between only a few notes, can look odd as flat slurs, so it may not be
appropriate to select the flat curvature style project-wide. However, it would likewise be unusual
only to use flat slurs once or twice in a project.
NOTE
We recommend that you avoid changing the curvature style for only one or two slurs in a project.
It can be more effective to modify them rather than changing their curvature style, for example,
by making an individual slur thicker/thinner, adjusting the shoulder offset of slurs, or adjusting
their height using their slur height handles in Engrave mode.

PROCEDURE
1.

Select the slurs whose curvature style you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Curvature style in the Slurs group.

3.

Choose one of the following options:
●

Curved

●

Flat

RESULT
The curvature style of the selected slurs is changed.
TIP
You can change the curvature style of all slurs project-wide in the Design section of the Slurs
page in Engrave > Engraving Options.
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RELATED LINKS
Changing the thickness of slurs on page 679
Changing the height of slurs on page 681
Changing the shoulder offset of slurs on page 682
Project-wide engraving options for slurs on page 667

Slur collision avoidance
By default, Dorico automatically adjusts the shape and position of slurs to avoid collisions with
items under their arc.
This means that if a notehead under a slur is either higher than the others under a slur curving
upwards, or lower than the others under a slur curving downwards, the curvature of the slur is
adjusted to avoid the collision and keep the notehead under the slur. You can manually disable
collision avoidance for individual slurs.
In the Avoiding Collisions section of the Slurs page in Engrave > Engraving Options, you can
choose options for how slurs are adjusted to avoid collisions, such as choosing a balance
between changing the shape of slurs to compensate or moving the endpoints of a slur, and how
asymmetrical slurs are allowed to be.

Slur with collision avoidance activated (default)

Slur with collision avoidance deactivated

Collision avoidance for cross-staff slurs
In the Avoiding Collisions section of the Slurs page in Engrave > Engraving Options, you can
activate/deactivate collision avoidance for cross-staff slurs.
This avoids collisions, but due to the increased complexity in positioning slurs across staves,
further manual adjustment in Engrave mode might be required.
NOTE
This setting does not apply to S-shaped slurs between staves, which do not have any collision
avoidance.

Slurs bisecting flat accidentals
According to conventions in published music, slurs can bisect the stems of flat accidentals, but
not sharps or naturals, to save vertical space.

You can choose not to allow slurs to bisect flat signs, or alter the maximum amount of the stems
of flat signs that can protrude above slurs, on the Slurs page in Engraving Options.
RELATED LINKS
Disabling slur collision avoidance for individual slurs on page 688
Project-wide engraving options for slurs on page 667
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Disabling slur collision avoidance for individual slurs
You can stop individual slurs from automatically adjusting to avoid collisions, independently of
your project-wide settings.
PROCEDURE
1.

In Engrave mode, select the slurs for which you want to deactivate collision avoidance.

2.

In the Properties panel, activate Disable auto curve adjustment in the Slurs group.

RESULT
Slurs do not avoid collisions when the property is activated.
Deactivating Disable auto curve adjustment allows the selected slurs to avoid collisions again.
RELATED LINKS
Slur collision avoidance on page 687

Slurs over system and frame breaks
Slurs automatically cross system breaks and frame breaks.
A system or frame break divides slurs into two parts. The end of the first part of the slur, and the
start of the second part of the slur, are both positioned 1 space vertically outside the staff by
default.
In Engrave mode, you can move and edit each slur part separately. This allows you to adjust the
start/end height of each slur part independently on each system.
If multiple slurs cross the same system break or frame break, such as if a phrase split by a break
contains nested slurs, the ends of the slurs are stacked automatically and spaced a minimum of
1/2 space apart vertically.

The end of a system showing the first slur part; the
end on the right indicates a continuation to the next
system.

The start of the next system showing the second slur
part; the end on the left indicates a continuation
from the previous system.

RELATED LINKS
Slurs in Engrave mode on page 675
Moving slurs and slur handles graphically on page 677

Slurs in playback
Slurs trigger the legato playing technique in playback. By default, this increases the length of the
MIDI notes without affecting the notation of the music.
Slurred notes sound for 105 % of the length indicated by their notated rhythm, as opposed to
non-slurred notes which sound for 85 % of their notated rhythm.
The final note of a slur sounds for 85 % of its notated rhythm, as there is no slur after it and the
legato technique is no longer required.
You can change these values on the Timing page in Play > Playback Options.
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The example shows how MIDI note length, indicated by the filled, light-colored rectangles, is
increased when slurs are used. The thin, darker rod shows the notated duration of each note.
The first three notes are non-slurred, so the MIDI length rectangle is shorter than the line of the
notated rhythm. The last four notes are slurred together, so the MIDI length is longer than the
notated length in order to create the legato, slurred sound. However, the last note of the slurred
group is not longer, as the last note of a slurred phrase is treated like a normal, non-slurred note.

A phrase in an instrument staff

The same phrase in the piano roll in Play mode

RELATED LINKS
Playback Options dialog on page 312
Played vs. notated note durations on page 335
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Staff labels are used to identify staves in music containing multiple players, and are positioned to
the left of systems, before the initial barline of each system. Staff labels indicate the instrument
or instruments currently playing the music on the staff or staves to which they apply.
It is usual to show instrument names in full in the staff labels for the first systems in each flow,
and abbreviated instrument names in the staff labels of subsequent systems. Using abbreviated
instrument names saves horizontal space, allowing you to include more music in each system.

Examples of staff labels on the first system in a flow

In Dorico, staff labels use the instrument names set for each instrument in the Edit Instrument
Names dialog. In the dialog, you can specify singular and plural names for each instrument, and
singular and plural abbreviations for each instrument.
TIP
You do not need to number instruments in staff labels manually, as Dorico automatically
numbers instruments when there are multiple players of the same type playing instruments of
the same type.
Part layouts by default do not show staff labels, as most parts only contain a single staff whose
identity is clear from the context and the layout name, which is shown at the top left of the first
pages in part layouts by default.
NOTE
Layout names are different to the instrument names used for staff labels.
For players holding multiple instruments, the staff label shows the instrument they are currently
playing automatically. If the player changes instrument partway through a system, the name of
the new instrument is shown at its entry and the staff label is updated at the start of the next
system.
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NOTE
Staff labels do not show all instruments held by players, for example, in the staff label for the first
system. You should include a comprehensive instrumentation list that shows any doubling at the
front of your score.
Dorico includes the instrument transposition, or instrument pitch, in staff labels for transposing
instruments by default. Transposing instruments are instruments whose sounding pitch is
different to the notated pitch.
You can change when instrument transpositions, or instrument pitches, are shown in staff labels.
You can also change whether the instrument transposition is shown before or after the
instrument name in staff labels.

Staff labels imported from MusicXML files
When exporting MusicXML files from Cubase and importing them into Dorico, you can improve
the accuracy of the automatic instrument selection by changing instrument names in the Cubase
score editor to the same English instrument names that Dorico uses before exporting the file.
RELATED LINKS
Instrument names in staff labels on page 691
Player, layout, and instrument names on page 67
Instrument numbering on page 72
Edit Instrument Names dialog on page 68
Changing instrument names on page 70

Instrument names in staff labels
Staff labels use the instrument names set for each instrument, and instruments with the same
instrument names are automatically numbered. Staff labels can show full or short instrument
names.
On the Staves and Systems page in Setup > Layout Options, you can choose whether you want
to show full or short instrument names in each layout independently.
●

Full staff labels use full instrument names.

●

Abbreviated staff labels use short instrument names.

You can change the full and short instrument names for each instrument in the Edit Instrument
Names dialog in Setup mode.
NOTE
Changing instrument names does not change the name shown at the top of each part layout, as
that uses the layout name of the player. You can change the layout name in Setup mode.
It is usual to number instruments when there are multiple players holding the same type of
instrument. For example, if there are four horn players in an orchestra, they are usually called
Horn 1, Horn 2, Horn 3, and Horn 4.
In Dorico, instruments are automatically numbered. This also applies to players holding multiple
instruments. For example, if an ensemble contains two flute players and a piccolo player, but the
second flute is also holding a piccolo, then the instruments are numbered in the following way:
●

Flute 1

●

Flute 2 & Piccolo 1

●

Piccolo 2
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You can move individual instruments to different players if you want to change which numbered
instruments are held by each player. For example, if you wanted the second flute to double
second piccolo rather than first piccolo, you can swap the piccolo parts so that the player holding
Flute 2 also holds Piccolo 2.
RELATED LINKS
Player, layout, and instrument names on page 67
Changing the length of staff labels project-wide on page 694
Instrument numbering on page 72
Changing instrument names on page 70
Edit Instrument Names dialog on page 68
Changing layout names on page 69
Moving instruments between players on page 76

Staff label fonts
Staff label use paragraph styles to format their fonts, including their alignment and formatting.
When staff labels are split, such as when the instrument name and instrument number have
different vertical positions, you can format each part separately.
In Dorico, there are three default paragraph styles for staff labels:
●

Staff Labels
The default style used for staff labels that have the instrument name and number aligned
and together. It is also used for the group labels on divisi staves and for instrument names
aligned between multiple identical instruments.

●

Staff Labels (Inner)
Used for individual staves within divisi groups and for instrument numbers when
instrument names are aligned between multiple identical instruments.

●

Staff Labels (Percussion Grid)
Used for percussion kits in layouts using the grid presentation.

You can edit each paragraph style independently of each other, for example, if you want outer
staff labels to be left-aligned but inner staff labels to be right-aligned, in the Paragraph Styles
dialog.
TIP
You can further edit the appearance and alignment of staff labels on divisi staves at each
individual divisi change.

RELATED LINKS
Paragraph Styles dialog on page 276

Project-wide engraving options for staff labels
You can find options for the project-wide appearance and position of staff labels on the Staff
Labels page in Engraving Options.
For example, you can change the distance between staff labels and the systemic barline, whether
instruments are numbered using Arabic or Roman numerals, and whether vocal staff labels are
uppercase or title case.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
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●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Staff Labels in the page list on the left of the dialog.
NOTE
You can change the length of staff labels shown on systems for each layout independently on the
Staves and Systems page in Setup > Layout Options.

RELATED LINKS
Changing the staff label numbering style on page 693
Showing vocal staff labels in uppercase/title case on page 693

Changing the staff label numbering style
You can change the staff label numbering style of solo and section players independently, for
example, if you want solo players to use Arabic numbers, such as “2”, and section players to use
Roman numerals, such as “II”.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Staff Labels in the page list.

3.

Choose one of the following options for Numbering style for solo players:

4.

5.

●

Arabic numerals

●

Roman numerals

Choose one of the following options for Numbering style for section players:
●

Arabic numerals

●

Roman numerals

Click Apply, then Close.

RESULT
Instruments held by solo and section players use the selected numbering style in all layouts
project-wide.

Showing vocal staff labels in uppercase/title case
You can show the staff labels on vocal staves entirely in uppercase or in title case.
Many European publishers prefer vocal staves to have entirely uppercase staff labels, but this is
not true of all publishers.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Staff Labels in the page list.

3.

For Labels for vocal staves, choose one of the following options:
●

Shown in uppercase

●

Shown in title case
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4.

Click Apply, then Close.

RESULT
Staff labels on all vocal staves project-wide use either uppercase or title case letters.

Changing the length of staff labels project-wide
You can show full, abbreviated, or no instrument names in staff labels project-wide depending on
their context in each layout independently.
By default in full score layouts, full staff labels are shown on the first system of each flow and
abbreviated staff labels are shown on subsequent systems. By default in part layouts, staff labels
are not shown on any systems.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the length of
instrument names in staff labels in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Staves and Systems from the Category menu.

4.

Select one of the following options from the Staff labels on first system menu:

5.

6.

●

Full

●

Abbreviated

●

None

Select one of the following options from the Staff labels on subsequent systems menu:
●

Full

●

Abbreviated

●

None

Click Apply, then Close.

RESULT
The staff labels are changed project-wide in the selected layouts.
TIP
You can change both full and short instrument names in the Edit Instrument Names dialog.
NOTE
Your per-layout settings for staff labels apply to each flow, not the whole project. For example, if
you want to show full staff labels on the first system in the first flow in your project, but do not
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want to show full staff labels on the first system of subsequent flows, you must change the staff
labels at the start of each subsequent flow individually.

RELATED LINKS
Instrument names in staff labels on page 691
Changing instrument names on page 70
Edit Instrument Names dialog on page 68
Changing the length of staff labels at specific positions on page 695

Changing the minimum indent for systems with staff labels
You can change the default minimum indent for all systems that show staff labels project-wide to
optimize horizontal space. You can have different minimum indents in each layout
independently.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts whose minimum indent for systems with staff labels
you want to change in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Staves and Systems from the Category menu.

4.

In the Staff Labels section, change the value for Minimum indent for systems with staff
labels in any of the following ways:

5.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Click Apply, then Close.

RESULT
The minimum indent on all systems that show staff labels is changed project-wide in the selected
layouts.
RELATED LINKS
System indents on page 709
Changing the first system indent on page 709
Changing the start/end position of systems on page 293

Changing the length of staff labels at specific positions
You can change whether staff labels at specific points show full, abbreviated, or no instrument
names, independently of your per-layout settings. For example, if you want full staff labels at the
start of the first flow but abbreviated staff labels at the start of subsequent flows, or if you want
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to show staff labels in choral music only on systems that contain more complicated parts, solo
lines, or divisi lines.
PREREQUISITE
You have inserted a system/frame break at the position from which you want to change the
length of instrument names in staff labels.
Signposts are shown for system/frame breaks.
PROCEDURE
1.

In Engrave mode, select the system/frame break signpost at the position where you want
to change the staff labels.

2.

In the Properties panel, activate Staff labels in the Format group.

3.

Select one of the following options from the menu:
●

Full

●

Abbreviated

●

None

RESULT
The length of the instrument names shown in the staff labels at the system break is changed.
Horizontal spacing is automatically adjusted so the system fills the width of the music frame.
Deactivating the property returns any selected system break signposts to your per-layout
settings.
EXAMPLE

Full staff labels shown

No staff labels shown

RELATED LINKS
Changing the length of staff labels project-wide on page 694
Inserting system breaks on page 273
Inserting frame breaks on page 270
Hiding/Showing system break signposts on page 274
Hiding/Showing frame break signposts on page 272

Instrument transpositions in staff labels
Instrument transpositions indicate the interval between the note an instrument plays and the
sounding note produced. Transposing instruments, such as Horn in F and Clarinet in B♭, are
commonly shown with their transposition, also known as their “instrument pitch”, as part of their
instrument name or layout name.
Depending on the options set for Show transposition in the Edit Instrument Names dialog for
each transposing instrument, they might show transpositions in staff labels even if you have
hidden transpositions in staff labels in their layout.
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Dorico sets common transposing instruments, such as Clarinet in B♭ and Trumpet in B♭, to follow
your per-layout settings for hiding/showing instrument transpositions in staff labels.
To reduce the risk of confusion, uncommon transposing instruments, such as Clarinet in A or
Trumpet in E, are set to show their transposition in staff labels always, even if you have hidden
instrument transpositions in the layout.
You can change the option for Show transposition to Follow Layout Options in the Edit
Instrument Names dialog for each instrument.
RELATED LINKS
Edit Instrument Names dialog on page 68
Changing instrument names on page 70
Hiding/Showing instrument transpositions in staff labels on page 697

Hiding/Showing instrument transpositions in staff labels
You can hide/show instrument transpositions in staff labels in each layout in your project
independently. For example, you can hide instrument transpositions in staff labels in full score
layouts but show them in part layouts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to hide/show instrument
transpositions in staff labels in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Staves and Systems from the Category menu.

4.

Activate/Deactivate the following options for Instrument pitch or transposition:
●

Show in full staff labels

●

Show in abbreviated staff labels

5.

Optional: Repeat steps 2 to 4 for other layouts.

6.

Click Apply, then Close.

RESULT
Instrument transpositions are shown in staff labels of the corresponding length project-wide in
the selected layouts when the corresponding checkbox is activated, and hidden when the
corresponding checkbox is deactivated. For example, if you want to show instrument
transpositions in full staff labels but hide them in abbreviated staff labels, you can activate Show
in full staff labels and deactivate Show in abbreviated staff labels.
RELATED LINKS
Instrument transpositions in staff labels on page 696
Changing instrument names on page 70
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Edit Instrument Names dialog on page 68

Changing the position of instrument transpositions in full staff
labels
You can change the position of instrument transpositions in staff labels. They can be shown
before/after instrument names in each layout independently of other layouts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts whose instrument transposition position you want to
change in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Staves and Systems from the Category menu.

4.

Choose one of the following options for Position of instrument pitch in full staff labels:

5.

●

Start

●

End

Click Apply, then Close.

RESULT
The position of instrument transpositions relative to instrument names in staff labels is changed
project-wide in the selected layouts.
TIP
You can change settings for other layouts before closing the dialog.

RELATED LINKS
Edit Instrument Names dialog on page 68

Staff labels for percussion kits
The staff labels shown for percussion kit staves depend on how kits are presented in your
project. Kits can be presented as five-line staves, grids, and as single-line instruments.
Percussion kit presentation
type

Staff label

5-line staff

Single instrument name using
the instrument name of the
percussion kit.
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Percussion kit presentation
type

Staff label

Grid

Multiple instrument names:
one for each kit instrument,
positioned at the staff position
of the corresponding
instrument.

Example

Staff labels for grids use a
smaller font and a different
paragraph style than normal
staff labels.
Single-line instruments

Multiple instrument names:
one for each kit instrument,
positioned beside the
corresponding single-line
staff.
Staff labels for single-line
instruments use the same font
as for normal staff labels.

You can change the player names, layout names, and instrument names of percussion kits in the
same ways as for other players and instruments. However, to change the staff labels for
percussion kits, you must change kit instrument names in different ways for percussion kits,
depending on your percussion kit presentation type:
●

5-line staff: Open the Edit Instrument Names dialog from the Players panel in Setup
mode, or use the Name field in the Edit Percussion Kit dialog, to change the name of the
kit.

●

Grid and single-line instruments: Open the Edit Instrument Names dialog from inside the
Edit Percussion Kit dialog in Setup mode to change the names of individual instruments.

The same instrument name fields and options are available for kit instruments as for normal
instruments.
NOTE
Smaller staff labels for each line in grid presentations use the Staff Labels (Percussion Grid)
paragraph style. You can edit this paragraph style in the Paragraph Styles dialog.

RELATED LINKS
Edit Instrument Names dialog on page 68
Changing instrument names on page 70
Changing layout names on page 69
Changing player names on page 68
Edit Percussion Kit dialog on page 77
Unpitched percussion on page 782
Changing the presentation type of percussion kits on page 789
Paragraph Styles dialog on page 276

699

Staves

A staff is a line or group of lines on which musical notes are notated to indicate the pitch and
rhythm of music. Pitched instruments use the traditional five-line staff and unpitched
instruments often use a single-line staff.
Notes are positioned on the lines and in the spaces on five-line staves, and can also use ledger
lines above/below the staff to represent pitches higher/lower than can fit on the staff.

A phrase on a five-line staff

The same phrase on a single-line staff

The pitch and register of notes on five-line staves are determined by clefs, which can also be
combined with octave lines to indicate what pitches performers play.
On five-line staves for unpitched percussion instruments, the different staff positions correspond
to different percussion instruments.
Because it is often necessary to have different staff sizes in different layouts depending on their
type, such as having smaller staves in full score layouts than in part layouts, in Dorico you can
change various aspects of staves in Setup > Layout Options.
RELATED LINKS
Project-wide layout options for staves on page 700
Clefs on page 443
Octave lines on page 448
Percussion kit presentation types on page 788

Project-wide layout options for staves
You can change settings that affect staves project-wide independently for each layout.
You can change the size of staves in each layout in the Space Size section of the Page Setup
page in Setup > Layout Options.
You can change other aspects of staves on the Staves and Systems page in Layout Options. For
example, you can change which staff labels are shown on systems, indent the first system of
each flow, and fix the number of bars included in each system. You can also select above which
staves system objects appear, according to their instrument families.
NOTE
●

If the size of system object font styles is set to Staff-relative, the staff size of the top staff
in each instrument family group affects the size of system objects if they are shown above
that bracketed group. Font styles that are set to Absolute are unaffected by staff size.
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●

System objects are only shown above bracketed groups in your project. If you have no
brackets, system objects only appear at the top of systems.

You can show system dividers between systems when systems contain a minimum number of
players. You can also change the appearance of system dividers.
RELATED LINKS
Changing the staff size in layouts on page 702
System objects on page 707
Changing the positions of system objects on page 708
Hiding/Showing empty staves on page 268
Showing system dividers on page 701
Edit Font Styles dialog on page 275
Brackets and braces on page 422

Showing system dividers
You can show system dividers between systems in flows that include a set minimum number of
players. You can change whether system dividers are shown, and change the minimum number
of players for which system dividers are shown, in each layout independently.

A system divider between two systems in a string quartet

PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to show system dividers in one of
the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

3.

Select Staves and Systems from the Category menu.

4.

In the System Dividers section, activate Show system dividers for flows with at least [X]
players.

5.

Optional: Change the minimum number of players for which you want to show system
dividers in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.
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6.

7.

Optional: Choose one of the following options for Appearance:
●

Default

●

Long

●

Extra long

Click Apply, then Close.

RESULT
System dividers are shown between systems in the selected layouts in every flow that contains
the minimum number of players you set.

Staff size
Staff size refers to the distance between the top and bottom lines of staves, and can be
expressed as a point size or in millimeters. For individual staves, you can use a scale size of the
default staff size in the layout. The most appropriate staff size depends on the intended purpose
of the layout.
For example, full orchestral scores that are quite dense need a much smaller staff size than
individual parts, which require large enough notes so that performers can read them easily.
Staves can overlap and the music can become illegible if the staff size is too large in dense
scores.
In Dorico, you can set the staff size using the rastral size and the space size, depending on which
measurement is more appropriate for the selected layouts.
●

Rastral size is the size of the full staff, measured from the bottom line to the top line.

●

Space size is the distance between two staff lines.

When changing the staff size of each layout in Layout Options, we recommend that you use one
of the preset rastral sizes, as these are based on traditional and generally accepted staff sizes
that are all widely used in music engraving.
NOTE
The size of staves can affect the size of system objects.

RELATED LINKS
System objects on page 707

Changing the staff size in layouts
You can change the staff size project-wide for each layout in your project. For example, you can
have a small staff size in full score layouts but a larger staff size in part layouts.
NOTE
If the size of system object font styles is set to Staff-relative, the staff size of the top staff in each
instrument family group affects the size of system objects if they are shown above that bracketed
group. Font styles that are set to Absolute are unaffected by staff size.

PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts whose staff size you want to change in one of the
following ways:
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●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Page Setup from the Category menu.

4.

In the Space Size section, select one of the following values from the Rastral size menu:
●

Size 0 (9.2 mm)

●

Size 1 (7.9 mm)

●

Size 2 (7.4 mm)

●

Size 3 (7.0 mm)

●

Size 4 (6.5 mm)

●

Size 5 (6.0 mm)

●

Size 6 (5.5 mm)

●

Size 7 (4.8 mm)

●

Size 8 (3.7 mm)

●

Custom
NOTE
If you select Custom, you can set a custom value in the Space size field, expressed
in millimeters. You can change the value in the value field in any of the following
ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

You can also set a Custom value by changing the value when any Rastral size is
selected.
5.

Optional: Repeat steps 2 to 4 for other layouts.

6.

Click Apply, then Close.

RESULT
The staff size in the selected layouts is changed project-wide.
TIP
You can also change the staff size from specific points in layouts, and change the size of
individual staves.

RELATED LINKS
Edit Font Styles dialog on page 275
Brackets and braces on page 422
System objects on page 707
Changing the staff size from specific points on page 704
Changing the size of individual staves on page 705
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Changing the staff size from specific points
You can change the staff size of all staves from specific points in layouts. For example, you can
have smaller staves only on pages with more staves, and larger staves on other pages with fewer
staves.
PREREQUISITE
You have inserted a system/frame break at the position from which you want to change the staff
size.
Signposts are shown for system/frame breaks.
NOTE
If the size of system object font styles is set to Staff-relative, the staff size of the top staff in each
instrument family group affects the size of system objects if they are shown above that bracketed
group. Font styles that are set to Absolute are unaffected by staff size.

PROCEDURE
1.

In Engrave mode, select the signpost of the system/frame break from which you want to
change the staff size.

2.

In the Properties panel, activate Space size in the Format group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increasing Space size increases the staff size of all staves in the layout. Decreasing the value
decreases the staff size.
The staff size is changed until the next change in staff size or the end of the flow, whichever
comes first.
By default, the next flow in your project uses your project-wide staff size for the current layout.
RELATED LINKS
Staff size on page 702
Inserting system breaks on page 273
Inserting frame breaks on page 270
Hiding/Showing system break signposts on page 274
Hiding/Showing frame break signposts on page 272
Edit Font Styles dialog on page 275
Brackets and braces on page 422
System objects on page 707
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Changing the size of individual staves
You can change the staff size of individual staves independently of other staves and your layout
settings. For example, piano accompaniment parts often include the solo line of the instrument
the piano is accompanying on a smaller staff.

A piano part with smaller viola staff above

You can change the size of individual staves to a set scale size, expressed as a percentage of the
normal staff size in the layout, or set a custom scale.
NOTE
●

Changing the staff size of individual staves affects the staff size of all instruments held by
that player.

●

Changing the staff size of individual staves affects its size for the whole flow.

●

If the size of system object font styles is set to Staff-relative, the staff size of the top staff
in each instrument family group affects the size of system objects if they are shown above
that bracketed group. Font styles that are set to Absolute are unaffected by staff size.

PROCEDURE
1.

Select an item on the staff whose size you want to change. You can do this in Write mode
and Engrave mode.
NOTE
You can only change the size of a single staff at a time.

2.

Change the staff size in any of the following ways:
●

Choose Edit > Staff Size > 60%.

●

Choose Edit > Staff Size > 75%.

●

Choose Edit > Staff Size > 100%.

●

Choose Edit > Staff Size > Custom Staff Size.

TIP
You can also choose these options from the context menu.
3.

Optional: If you choose Custom Staff Size, you must set the staff size using the Custom
Staff Size dialog that opens.
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RESULT
The staff size of the selected staff is changed. This can be used in combination with the other
ways of changing staff size, such as changing the size of all staves in the layout or changing the
size of staves from a specific point.
RELATED LINKS
Custom Staff Size dialog on page 706
Changing the staff size in layouts on page 702
Changing the staff size from specific points on page 704
Edit Font Styles dialog on page 275
Brackets and braces on page 422
System objects on page 707

Custom Staff Size dialog
In the Custom Staff Size dialog, you can change the size of individual staves by a custom scale
factor.
●

You can open the Custom Staff Size dialog by selecting an item in the music area and
choosing Edit > Staff Size > Custom Staff Size.

Custom Staff Size dialog

The Custom Staff Size dialog contains the following options:
Default staff size
Displays the default size of staves in the current layout. This size is set on the Page
Setup page in Setup > Layout Options.
The default staff size is expressed as both a point size and in millimeters.
Rastral size
Allows you to select the rastral size on which you want to base your custom staff size.
Scale factor
Sets the custom staff size, expressed as a percentage of the selected rastral size.
New staff size
Displays the new custom staff size for the selected staff as a result of the changes
you have made in the dialog.
The new staff size is expressed as both a point size and in millimeters.
RELATED LINKS
Changing the size of individual staves on page 705
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Changing the thickness of staff lines
You can change the thickness of staff lines project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Staves in the page list.

3.

Change the value for Staff line thickness in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Click Apply, then Close.

RESULT
The thickness of staff lines project-wide is changed. Increasing the value for Staff line thickness
makes staff lines thicker, decreasing the value makes staff lines thinner.

System objects
System objects are items that apply to all staves in the system, but are not necessary to show on
every staff. For example, tempo marks and rehearsal marks are important for all players to see,
but would cause an orchestral full score to appear very cluttered and hard to read if they were
shown on every staff.
In Dorico, the following items are considered system objects:
●

Rehearsal marks

●

Tempo marks

●

Repeat endings

●

System text

●

Time signatures shown above the staff

You can show system objects at multiple positions in each system by showing them above
multiple instrument families. For example, if you want to show system objects at different
positions in the system, you might show them above the woodwind, brass, percussion, and
string families. In an orchestral full score, this would ensure system objects are spread out evenly
across the page, meaning no staff is very far from these important markings.
NOTE
●

System objects are only shown above instrument families that are bracketed or braced
together. You can change the bracket grouping on the Brackets and Braces page in
Engrave > Engraving Options.

●

If the size of system object font styles is set to Staff-relative, the staff size of the top staff
in each instrument family group affects the size of system objects if they are shown above
that bracketed group. Font styles that are set to Absolute are unaffected by staff size.

RELATED LINKS
Changing bracket grouping according to ensemble type on page 424
Changing the positions of system objects on page 708
Edit Font Styles dialog on page 275
Brackets and braces on page 422
Rehearsal marks on page 639
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Tempo marks on page 719
Repeat endings on page 648
Inputting text on page 214

Changing the positions of system objects
You can change the positions of system objects in each layout independently by changing the
instrument families above which system objects are shown. System objects include rehearsal
marks, tempo marks, and repeat endings.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the instrument families
above which system objects appear in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Staves and Systems from the Category menu.

4.

In the System Objects section, activate the checkboxes for the instrument families above
which you want system objects to appear.

5.

Optional: Activate Additionally show repeat endings below bottom staff.

6.

Click Apply, then Close.

RESULT
System objects appear above the top staff in each bracketed group you select if a bracketed
group for that instrument family is included in the selected layouts.
If you activate Additionally show repeat endings below bottom staff, repeat endings appear
below the bottom staff in the system in addition to appearing above the selected instrument
families.
NOTE
System objects are only shown above instrument families that are bracketed or braced together.
You can change the bracket grouping on the Brackets and Braces page in Engrave > Engraving
Options.

RELATED LINKS
System objects on page 707
Changing bracket grouping according to ensemble type on page 424
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System indents
Systems indents control the distance between the left page margin and the start of systems of
music. According to tradition, the first system in part layouts is indented, however, in modern
use this is not always necessary.
In Dorico, system indents automatically adjust to accommodate staff labels. For example, if a
system contains a staff label that is significantly longer than the minimum system indent, Dorico
increases the indent on that system to ensure the staff label remains legible and is not cut off on
the left edge or collide with the music.
You can change both the minimum indent on systems with staff labels and the first system
indent in each layout independently. You can also adjust the system indent at both the start and
end of individual systems, independently of your per-layout settings.
RELATED LINKS
Changing the minimum indent for systems with staff labels on page 695
Changing the first system indent on page 709
Changing the start/end position of systems on page 293

Changing the first system indent
By default in Dorico, the first system in part layouts is indented. You can change the indent for
the first system in each layout independently.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts whose first system indent you want to change in one
of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Staves and Systems from the Category menu.

4.

In the Staff Labels section, change the value for Indent first system of flow by in any of
the following ways:

5.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Click Apply, then Close.

RESULT
The indent of the first system is changed project-wide in the selected layouts. This applies to all
flows.
RELATED LINKS
System indents on page 709
Changing the minimum indent for systems with staff labels on page 695
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Changing the start/end position of systems on page 293
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Stems are vertical lines that extend from noteheads that are a half note or shorter in duration. In
combination with notehead design, they allow the duration of each note to be clearly identified.
For example, quarter notes (crotchets) and eighth notes (quavers) both have solid black
noteheads and stems, but eighth notes also have flags on their stems. 16th notes have two flags,
32nd notes have three flags, and so on. The length of stems is determined by default in Dorico,
so stems automatically adjust their length to accommodate more/fewer flags.

Notes with stems, ranging from a half note (minim) on the left to a 128th note on the right

The stems of notes and chords can point upwards/downwards, depending on the conventions of
music engraving and the context of the music. For example, in choral music on two staves, stems
in the soprano and tenor lines point up, and stems in the alto and bass lines point down.
RELATED LINKS
Stem direction on page 711
Stem length on page 716
Changing the default stem direction behavior of notes on the middle line of staves on page 714

Stem direction
In Dorico, the stem direction of notes and chords follows rules that are based on the conventions
of music engraving.
Stem direction is determined automatically, but you can manually change the stem direction of
individual notes, chords, or of an entire voice. The rules that are applied depend on the following:
●

How many voices are active on the staff.

●

Whether notes, chords, or beamed groups of notes are affected.

●

Whether notes in the same chord or notes in the same beamed group are split between
staves.

Single notes in single voices
On a five-line staff with only a single voice active, the default stem direction of a single note is
determined by its staff position.
●

If the note is above the middle line, its stem points downwards.

●

If the note is below the middle line, its stem points upwards.

●

If the note is on the middle line of the staff, its stem direction is determined by the stem
directions of any adjacent notes, beam groups, or chords. If they both have the same stem
direction, the note matches them. If the adjacent notes, beam groups, or chords have
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different stem directions, or if there are no adjacent notes, beam groups, or chords, the
note follows the default stem direction.
The default stem direction depends on the instrument type. By default, the stems of notes
on the middle lines of staves point downwards on instrumental staves and upwards on
vocal staves, to avoid lyrics.
TIP
You can change the default stem direction for notes and beam groups on the middle lines
of staves, and equally balanced chords, in the Stems section of the Notes page in
Engraving Options. You can also choose whether they follow your default stem direction
or change according to the musical context.

Notes on the middle line are stem up because the
fourth note is stem up

Notes on the middle line are stem down because the
fourth note is stem down

By default, notes are first input into an up-stem voice, and Dorico treats notes as the only voice
on the staff until you input more voices.

Single notes in multiple voices
When there are multiple voices on a staff and all voices contain notes, the stem direction of notes
is determined by the stem direction of their voice. Notes in up-stem voices have up stems, and
notes in down-stem voices have down stems. This applies even when the stems of notes would
normally point in the other direction, based on their position on the staff.
NOTE
The order in which notes appear between different up-stem voices and different down-stem
voices depends on their pitch and your settings on the Voices page in Write > Notation
Options. You can also change the voice column index of notes individually.
When there are only notes in one voice for at least a whole bar, Dorico automatically changes the
directions of stems so they point in the default direction for their pitch. For example, if a staff
contains a single up-stem voice and a single down-stem voice but only the down-stem voice
contains notes or rests, then the stems of notes in the down-stem voice may point upwards,
depending on the position of the notes on the staff. However, showing rests or implicit rests in
empty voices forces the stem direction of notes to follow the stem direction of their voice.

Notes in an up-stem voice shown
in blue.

Notes in a down-stem voice shown
in purple. The stems point
upwards despite being in a downstem voice because there are no
other voices.

When notes in up-stem and downstem voices are in the same bar,
the stem direction is automatically
changed.

Chords in single voices
The stem direction for a chord in a single voice is determined by the balance of notes above/
below the middle line of the staff.
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●

If the note furthest from the middle line is above the middle line, the stem of the chord
points downwards.

●

If the note furthest from the middle line is below the middle line, the stem of the chord
points upwards.

●

If the chord is equally balanced on either side of the middle line of the staff, the stem
direction is determined by the stem directions of any adjacent notes, beam groups, or
chords. If they both have the same stem direction, the chord matches them. If the adjacent
notes, beam groups, or chords have different stem directions, equally balanced chords
follow the default stem direction.
The default stem direction depends on the instrument type. By default, the stems of notes
on the middle lines of staves point downwards on instrumental staves and upwards on
vocal staves, to avoid lyrics.
TIP
You can change the default stem direction for notes and beam groups on the middle lines
of staves, and equally balanced chords, in the Stems section of the Notes page in
Engraving Options. You can also choose whether they follow your default stem direction
or change according to the musical context.

Beam groups in single voices
The stem direction within beam groups is determined by the balance of notes within the beam
group that are above/below the middle line of the staff.
●

If the majority of notes in the beam group are above the middle line, stems in the beam
group point downwards.

●

If the majority of notes in the beam group are below the middle line, stems in the beam
group point upwards.

●

If the beam group contains an equal number of notes either side of the middle line of the
staff, the stem direction is determined by the stem directions of any adjacent notes, beam
groups, or chords. If they both have the same stem direction, the beam group matches
them. If the adjacent notes, beam groups, or chords have different stem directions,
equally balanced beam groups follow the default stem direction.
The default stem direction depends on the instrument type. By default, the stems of notes
on the middle lines of staves point downwards on instrumental staves and upwards on
vocal staves, to avoid lyrics.
TIP
You can change the default stem direction for notes and beam groups on the middle lines
of staves, and equally balanced chords, in the Stems section of the Notes page in
Engraving Options. You can also choose whether they follow your default stem direction
or change according to the musical context.

RELATED LINKS
Project-wide engraving options for stems on page 716
Per-flow notation options for voices on page 802
Voice column index on page 806
Implicit rests in multiple-voice contexts on page 807
Note positions in multiple-voice contexts on page 801
Changing the stem direction of notes on page 714
Changing the default stem direction behavior of notes on the middle line of staves on page 714
Changing the default stem direction of voices on page 715
Removing stem direction changes on page 715
Notation Options dialog on page 110
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Changing the default stem direction behavior of notes on the middle
line of staves
The stems of notes on the middle lines of staves can point upwards/downwards. You can change
their default direction, and choose whether the stem direction is determined by the stem
directions of any adjacent notes, beam groups, or chords, or always uses the default direction.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Notes in the page list.

3.

In the Stems section, choose one of the following options for Stem direction for notes on
the middle line of the staff in the Stem Directions subsection:

4.

5.

●

Determine by context

●

Use default direction

Optional: Choose one of the following options for Default stem direction for notes on
the middle line of the staff:
●

Up

●

Down

Click Apply, then Close.

RELATED LINKS
Stem direction on page 711

Changing the stem direction of notes
You can manually change the stem direction of any note.
PROCEDURE
1.

Select the notes whose stem direction you want to change. You can do this in Write mode
and Engrave mode.

2.

Change the stem direction in one of the following ways:
●

Choose Edit > Stem > Force Stem Up.

●

Choose Edit > Stem > Force Stem Down.

TIP
You can also choose these options from the context menu.

RESULT
The stem direction of the selected notes is changed. The selected notes follow this stem
direction, even if you later change their pitch to one that usually requires a different stem
direction.
NOTE
This does not change the voice to which notes belong.
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EXAMPLE

Stems pointing in the same direction but in different
voices

Stems in the same direction and in the same voice

RELATED LINKS
Changing the voice of existing notes on page 803
Removing stem direction changes on page 715

Changing the default stem direction of voices
You can change the default stem direction of voices after they have been input.
NOTE
This changes the implicit stem direction of the voice, but may not change the stem direction of all
notes in single-voice contexts. Stem directions are automatically changed in Dorico when only
one voice contains notes.

PROCEDURE
1.

Select a note or chord in the voice whose stem direction you want to change. You can do
this in Write mode and Engrave mode.

2.

Change the default stem direction of the selected voice in one of the following ways:
●

Choose Edit > Voices > Default Stems Down.

●

Choose Edit > Voices > Default Stems Up.

TIP
You can also choose these options from the context menu.

RELATED LINKS
Stem direction on page 711

Removing stem direction changes
You can remove changes to the directions of stems and revert stems to their default directions.
PROCEDURE
1.

Select the notes whose stem direction changes you want to remove. You can do this in
Write mode and Engrave mode.

2.

Choose Edit > Stem > Remove Forced Stem. You can also choose this option from the
context menu.
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RESULT
All stem direction changes are removed from the selected notes. The stems of the selected notes
revert to their default directions.
NOTE
Alternatively, you can change the stem direction to the opposite direction. However, notes with
forced stems do not change automatically if, for example, you later change their pitch.

RELATED LINKS
Changing the stem direction of notes on page 714

Project-wide engraving options for stems
You can find options for the project-wide appearance of stems on the Notes page in Engraving
Options.
The options on the Notes page allow you to change the design, collision avoidance, length, and
thickness of stems. You can also set when stems are stem up or stem down, when stems are
shortened in various contexts, and change their default stem direction when on the middle line
of the staff.

Default flag design

Straight flag design

There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Notes in the page list on the left of the dialog.
NOTE
Stems with tremolo strokes have specific options, which you can find on the Tremolos page in
Engraving Options. For example, you can change the default distance between tremolo strokes
and the tips of stems/different stem flags.

RELATED LINKS
Project-wide engraving options for tremolos on page 768

Stem length
The length of stems is determined by default in Dorico, according to accepted standards for the
appearance of stems of notes at different positions on staves.
You can change the default settings for the length of all stems project-wide and you can
lengthen/shorten individual stems in Engrave mode.
RELATED LINKS
Project-wide engraving options for stems on page 716
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Lengthening/Shortening stems
You can lengthen/shorten the stems of individual notes, independently of your project-wide
settings.
PROCEDURE
1.

In Engrave mode, select the stems you want to lengthen/shorten.

2.

Lengthen/Shorten the stems in any of the following ways:
●

Press Alt-Up Arrow to make stems longer.

●

Press Alt-Down Arrow to make stems shorter.
NOTE
If you want to lengthen/shorten stems by larger increments, you can press
Ctrl/Cmd as well as the standard key command, for example, Ctrl/Cmd-AltUp Arrow.

●

Click and drag the square handles at the end of the stems upwards/downwards.

RESULT
The selected stems are lengthened/shortened, regardless of their stem direction. For example,
selecting a down-stem note and pressing Alt-Up Arrow lengthens it by moving the end of the
stem downwards, away from the notehead.
TIP
●

Stem adj. in the Notes and Rests group of the Properties panel is activated when you
lengthen/shorten stems.
You can also use this property to lengthen/shorten stems by changing the value in the
value field. However, the Notes and Rests group is only available when the notehead is
selected rather than the stem.
Deactivating the property resets the selected stems to their default length.

●

You can change the default length of all stems project-wide in the Stems section of the
Notes page in Engrave > Engraving Options. There are different options for stems in
different contexts.

Hiding stems
You can shorten stems to achieve the effect of stemless noteheads.
NOTE
Stemless noteheads are not currently available in Dorico. They are planned for future versions.

PROCEDURE
1.

2.

In Engrave mode, select one of the following, depending on how you want to hide stems:
●

If using the keyboard or mouse, select the stems you want to hide.

●

If using the Properties panel, select the noteheads whose stems you want to hide.

Hide the stems in one of the following ways:
●

Press Alt-Down Arrow until the stems cannot be seen.
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TIP
To shorten the stem by larger increments, press Ctrl/Cmd as well, for example, Ctrl/
Cmd-Alt-Down Arrow.
●

Click and drag the stem tips to the notehead.

●

In the Properties panel, activate Stem adj. in the Notes and Rests group, and set
the value to -3.

RESULT
Stems are shortened so that they do not extend beyond the notehead.
NOTE
If you later change the pitch of notes whose stems you have hidden using this method, their
stems can become partially visible, because stem length is automatically adjusted depending on
the position of notes on the staff.

RELATED LINKS
Lengthening/Shortening stems on page 717

Split stems for altered unisons
Split stems can be used in chords containing altered unisons. They show the main body of the
chord as usual, but with a stem branch coming off the main stem that connects noteheads in
altered unisons to the chord.

Split stem chord

Split stems are also known as “cherry stalks” or “trees”.
You can choose to show altered unisons with split stems or with single stems project-wide on the
Accidentals page in Notation Options.
You can open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

●

Click Notation Options on the right of the Flows panel in Setup mode.

RELATED LINKS
Altered unisons on page 357
Changing how altered unisons appear project-wide on page 358
Changing how altered unisons appear individually on page 358
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Tempo marks indicate how fast music is played, often with a combination of text instructions and
metronome marks. They are also known as “tempo changes”, “tempo indications”, and “tempo
markings”.
A tempo mark can show text instructions, a metronome mark, or a combination of the two.
Text instructions are traditionally expressed in Italian, such as largo or allegretto, but other
languages, such as English, French, and German, have become widely accepted. The text
instruction can express simply how fast the music is played, but can also suggest its character.
For example, grave means slow but also solemn and sad, and vivo means fast but also lively and
sprightly.
Metronome marks show the speed of the music, indicated in beats per minute, or “bpm”.
Metronome marks can show a fixed bpm or indicate a range of possible or acceptable values.
Gradual tempo changes indicate a change in tempo over a defined period of time. They can
appear differently, for example, with/without a continuation line or with the text split into
syllables and spread across their duration.
Tempo marks use a bold font with a large point size, so they are clearly noticeable on the page.
They do not usually use an italic font.
In Dorico, tempo marks are categorized as system objects. Therefore, tempo marks follow your
per-layout settings for the visibility and positioning of system objects, which you can change on
the Staves and Systems page in Setup > Layout Options.
If you do not input any tempo marks into your project, the default playback tempo is 120 bpm.
RELATED LINKS
Types of tempo marks on page 719
Metronome marks on page 728
Gradual tempo changes on page 731
Tempo mark components on page 727
Input methods for tempo marks on page 208
Positions of tempo marks on page 722
System objects on page 707
Changing the positions of system objects on page 708

Types of tempo marks
Dorico groups tempo marks into four types according to their function and effect on the music.
The following tempo changes are available in the Tempo panel in Write mode, but you can also
input all types of tempo changes using the tempo popover.
Absolute Tempo Change
Indicates a defined change in tempo, and is often shown with a metronome mark.
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Gradual Tempo Change
Indicates a change in tempo over a defined period of time, such as rallentando
(slowing down) or accelerando (speeding up).
Relative Tempo Change
Indicates a change in tempo that is relative to the previous tempo, such as mosso
(movement).
Relative tempo changes often include modifiers that qualify the change, such as poco
meno mosso (a little less movement), and are not defined by a metronome mark. You
can, however, set a relative metronome mark change as a percentage of the
previous metronome mark.
Reset Tempo
Returns the tempo to the previous tempo, such as A tempo, or a previously defined
tempo, such as Tempo primo (return to the first tempo of the piece).
RELATED LINKS
Tempo panel on page 210
Gradual tempo changes on page 731
Input methods for tempo marks on page 208
Tempo popover on page 209

General placement conventions for tempo marks
Tempo marks usually apply to all players and therefore to all staves. They always appear above
the top staff in the score, but because they are system objects, they can also be shown at
multiple positions in the score.
Tempo marks are placed above notations such as slurs, ties, and octave lines, and are often
aligned with rehearsal marks to ensure clear readability.
Tempo marks should be aligned with either a time signature, or the notehead or rest at the
rhythmic position to which they apply. For example, if there is a notehead with an accidental at
the rhythmic position of a tempo mark, it is convention to align the tempo mark with the
accidental.
If a repeat mark occurs mid-system and is not treated as a barline, tempo marks are aligned with
the repeat mark.
When a tempo mark includes both text and a metronome mark, the text appears first, followed
by the metronome mark. When horizontal space is tight, the metronome mark can be positioned
below the tempo mark text.
RELATED LINKS
System objects on page 707

Text in tempo marks
All types of tempo marks use text, but gradual tempo changes use a different font style to
absolute, relative, and reset tempo changes. Tempo marks can have both full and abbreviated
text, allowing you to show the one most appropriate in each layout.
This allows you to customize the same tempo mark depending on the requirements of the
different types of layouts in your project. For example, if a tempo mark extends off the page in a
part layout, you can show the abbreviated text for that tempo mark instead without affecting the
length of the tempo mark in the full score layout.
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You can change the appearance of fonts used for items in Dorico that use text, but are not text
objects or text frames, in the Edit Font Styles dialog.
The following fonts are used for tempo marks:
●

Gradual Tempo Text Font: Used for gradual tempo changes, such as rallentando.

●

Immediate Tempo Text Font: Used for absolute tempo changes, such as Adagio.

RELATED LINKS
Edit Font Styles dialog on page 275
Changing tempo text on page 721
Showing abbreviated tempo text on page 721

Changing tempo text
You can change the text of existing tempo marks individually.
PROCEDURE
1.

Select the tempo marks whose tempo text you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, enter the tempo text you want into the Text value field in the
Tempo group.

3.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The tempo text for the selected tempo marks is changed.

Showing abbreviated tempo text
You can show individual tempo marks with custom abbreviated text, which you can change at
any time, for example, if a long tempo mark extends beyond the page boundary in some part
layouts but the abbreviated version fits within the boundary.
PROCEDURE
1.

In the music area, open the layout in which you want to show abbreviated tempo text. You
can do this in Write mode and Engrave mode.

2.

Select the tempo marks you want to show with abbreviated text.

3.

In the Properties panel, activate Abbreviation in the Tempo group.

4.

Enter the text you want into the value field.

5.

Activate Abbreviate in the Tempo group.

6.

Activate the corresponding checkbox.

RESULT
The selected tempo marks appear with abbreviated text. This does not affect the appearance of
the same tempo mark in layouts that show full tempo text as properties in Dorico are layoutspecific.
Abbreviated tempo text is shown when Abbreviation is activated and Abbreviate is deactivated,
or when Abbreviation and both Abbreviate and its corresponding checkbox are all activated.
This allows you to switch between showing abbreviated/full text in different layouts without
deleting your abbreviated text from the Abbreviation value field.
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RELATED LINKS
Tempo mark components on page 727

Adding poco a poco text to gradual tempo changes
You can add poco a poco text immediately after individual gradual tempo changes.
NOTE
You can also enter poco a poco directly into the tempo popover. However, this means the entry is
treated as a tempo mark rather than a gradual tempo change, which changes the properties you
can use on it.

PROCEDURE
1.

Select the gradual tempo changes to which you want to add poco a poco text. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Poco a poco in the Tempo group.

RESULT
Poco a poco text is shown immediately after the text in the selected gradual tempo changes.
Deactivating Poco a poco (little by little) removes poco a poco text from the selected gradual
tempo changes.
EXAMPLE

Rallentando with poco a poco text

Positions of tempo marks
You can change the positions of tempo marks individually and by changing their default
positions project-wide. For example, you can override the default position for individual tempo
marks if notes at those positions require more vertical space.
You can move tempo marks to different rhythmic positions in Write mode. They are positioned
by default according to your settings in Engraving Options.
You can move tempo marks graphically in Engrave mode, but this does not change the rhythmic
positions to which they are attached.
You can change the default positions and appearance of tempo marks project-wide on the
Tempo page in Engrave > Engraving Options.
RELATED LINKS
Project-wide engraving options for tempo marks on page 726
Moving tempo marks rhythmically on page 723
Moving tempo marks graphically on page 723
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Moving tempo marks rhythmically
You can move tempo marks to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the tempo marks you want to move.
NOTE
When using the mouse, you can only move one tempo mark at a time.

2.

Move the tempo marks according to the current rhythmic grid value in any of the following
ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the tempo mark to the right/left.

RESULT
The selected tempo marks are moved according to the current rhythmic grid value.
NOTE
Only one tempo mark can exist at each rhythmic position. If a tempo mark in your selection
passes over another tempo mark as part of its move, the existing tempo mark is deleted.
You can undo this action, but any tempo marks deleted in the process are only restored if you
moved the tempo mark using the keyboard.

RELATED LINKS
Lengthening/Shortening gradual tempo changes on page 725

Moving tempo marks graphically
You can move tempo marks graphically without changing the rhythmic positions to which they
apply. You can move the start/end of gradual tempo changes independently, meaning you can
also lengthen/shorten individual gradual tempo changes graphically.
NOTE
You cannot change the angle of gradual tempo changes.

PROCEDURE
1.

In Engrave mode, select one of the following that you want to move:
●

Tempo marks

●

Individual start/end handles of gradual tempo changes

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the tempo marks or handles in any of the following ways:
●

Press Alt-Right Arrow to move tempo marks or handles to the right.

●

Press Alt-Left Arrow to move tempo marks or handles to the left.
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●

Press Alt-Up Arrow to move tempo marks or whole gradual tempo changes
upwards.

●

Press Alt-Down Arrow to move tempo marks or whole gradual tempo changes
downwards.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The selected tempo marks, gradual tempo changes, or handles are moved to new graphical
positions.
TIP
The following properties in the Tempo group of the Properties panel are activated automatically
when you move tempo marks in the corresponding directions:
●

Start offset moves tempo marks and the start of gradual tempo changes. X moves them
horizontally, Y moves them vertically.

●

End X moves the end of gradual tempo changes horizontally.

For example, if you move a whole gradual tempo change, both handles are moved so both
properties are activated. You can also use these properties to move tempo marks and lengthen/
shorten gradual tempo changes graphically by changing the values in the value fields. However,
you cannot move absolute tempo marks and gradual tempo changes graphically at the same
time when using these properties.
Deactivating the properties resets the selected tempo marks and gradual tempo changes to their
default positions.

RELATED LINKS
Lengthening/Shortening gradual tempo changes on page 725

Changing the end position of gradual tempo changes relative to
barlines
You can change how the ends of individual gradual tempo change lines are positioned relative to
barlines, independently of your project-wide setting.
NOTE
This does not affect the appearance of gradual tempo changes with the text-only style.

PROCEDURE
1.

In Engrave mode, select the gradual tempo changes whose end position relative to
barlines you want to change.

2.

In the Properties panel, activate Barline interaction in the Tempo group.

3.

Choose one of the following options:
●

Stop before

●

Continue
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RESULT
The end position of the selected gradual tempo changes is changed.
NOTE
You can change the default position of all gradual tempo change ends project-wide in the
Horizontal Position section of the Tempo page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for tempo marks on page 726
Changing the style of gradual tempo changes on page 731

Lengthening/Shortening gradual tempo changes
You can lengthen/shorten gradual tempo changes rhythmically after they have been input.
PROCEDURE
1.

In Write mode, select the gradual tempo changes you want to lengthen/shorten.
NOTE
When using the mouse, you can only lengthen/shorten one gradual tempo change at a
time.

2.

Lengthen/Shorten the gradual tempo changes in any of the following ways:
●

Press Shift-Alt-Right Arrow to lengthen them.

●

Press Shift-Alt-Left Arrow to shorten them.
NOTE
When using the keyboard, you can only move the end of gradual tempo changes.
You can move the start of gradual tempo changes by moving the whole gradual
tempo change, or by clicking and dragging the start handle.

●

Click and drag the circular handle at the start/end to the right/left.

RESULT
The selected gradual tempo changes are lengthened/shortened according to the current
rhythmic grid value.
NOTE
You can adjust the graphical positions of gradual tempo changes in Engrave mode.

Hiding/Showing tempo marks
You can hide/show individual tempo marks in each layout independently without changing the
speed of playback, for example, if you want to show tempo marks in the full score layout but
want to hide them in part layouts.
PROCEDURE
1.

Select one of the following:
●

The tempo marks you want to hide

●

The signposts of tempo mark you want to show
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You can do this in Write mode and Engrave mode.
2.

In the Properties panel, activate/deactivate the following properties in the Tempo group:
●

Text shown

●

Metronome mark shown

RESULT
When at least one of the properties is activated, the selected tempo marks are shown. It displays
components according to the properties that are activated.
When neither property is activated, the selected tempo marks are hidden. Signposts are shown
at their positions as they still affect the speed of playback.
RELATED LINKS
Tempo mark components on page 727
Changing the type and appearance of absolute tempo changes on page 728

Deleting tempo marks
PROCEDURE
1.

In Write mode, select the tempo marks you want to delete.

2.

Delete the tempo marks in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The selected tempo marks are deleted. The tempo in playback follows the previous tempo, or the
default tempo of 120 bpm if there is no previous tempo.
If you delete a tempo mark that truncated the line of a gradual tempo change, the line of the
gradual tempo change automatically extends to its full length or until the next existing tempo
mark.

Project-wide engraving options for tempo marks
You can find options for the project-wide appearance of tempo marks on the Tempo page in
Engraving Options.
The options on the Tempo page allow you to change the appearance of tempo marks, and their
position relative to the staff, time signature changes, and other items. You can also change the
appearance, thickness, and position of continuation lines relative to barlines for gradual tempo
changes.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Tempo in the page list on the left of the dialog.
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Tempo mark components
Tempo mark components include text, metronome marks, parentheses, and approximate
indications. Tempo marks can include different components in different combinations,
depending on your preference or the requirements for different projects.
You can change which components are shown in different types of tempo marks project-wide,
and you can change which components are shown in individual tempo marks.
You can activate properties that correspond to the different components in the Tempo group of
the Properties panel. You can activate one or more of the following tempo mark properties in any
combination for individual absolute tempo changes:
Text shown
Shows text when activated, and no text when deactivated.
Metronome mark shown
Shows metronome marks when activated, and no metronome marks when
deactivated.
Parenthesized
Shows metronome marks in parentheses when activated, and without parentheses
when deactivated. This also applies to approximate metronome marks.
Is approximate
Shows metronome marks as approximate when activated, and absolute when
deactivated.
Approximate appearance
Allows you to choose how approximate metronome marks appear, for example, c. or
circa.
NOTE
This property applies specifically to approximate tempo marks, and is only available
when Is approximate is activated.
Show equals sign
An equals sign is shown when both the property and its corresponding checkbox are
activated. No equals sign is shown when the checkbox is deactivated.
NOTE
This property applies specifically to approximate tempo marks, and is only available
when Is approximate is activated.

Components for gradual tempo changes
The following components only apply to gradual tempo changes, such as rallentando:
Poco a poco
Poco a poco text is shown immediately after gradual tempo change text when the
checkbox beside the property is activated.
RELATED LINKS
Project-wide engraving options for tempo marks on page 726
Changing the type and appearance of absolute tempo changes on page 728
Adding poco a poco text to gradual tempo changes on page 722
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Changing the type and appearance of absolute tempo changes
You can change which components are included in individual absolute tempo changes, and how
they appear.
PROCEDURE
1.

Select the absolute tempo marks whose components you want to change. You can do this
in Write mode and Engrave mode.

2.

In the Properties panel, activate any of the following properties in the Tempo group:
●

Text shown

●

Metronome mark shown

●

Parenthesized

●

Is approximate

●

Approximate appearance (only available if Is approximate is activated)

●

Show equals sign (only available if Is approximate is activated)

RESULT
The selected tempo marks are changed to include the corresponding components.
NOTE
If you have activated none of these properties, no tempo mark is shown in the music. Instead, a
signpost indicates the position of the tempo mark.

RELATED LINKS
Tempo mark components on page 727

Metronome marks
Tempo marks often include a metronome mark value. Metronome marks show the speed of the
music, indicated in beats per minute, or “bpm”. For example, a bpm of 60 means one beat per
second. The more beats per minute, the faster the music.

A metronome mark shown as a range

Metronome marks can be precise, such as  = 176, or can indicate an acceptable range, such as 
= 152-176. They can also be shown in parentheses, which is useful if the metronome mark is
intended as a guide rather than a fixed value.
In Dorico, metronome marks can appear as an individual value or as a range. Depending on the
type and appearance of metronome marks, the bpm value can indicate a fixed tempo or an
approximate tempo.
RELATED LINKS
Input methods for tempo marks on page 208
Changing the metronome mark value on page 729
Showing the metronome mark value as a range on page 729
Changing the type and appearance of absolute tempo changes on page 728
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Changing the metronome mark value
You can change the metronome mark value of individual absolute tempo marks after they have
been input.
NOTE
These steps do not apply to gradual tempo changes or reset/relative tempo marks.

PROCEDURE
1.

Select the absolute tempo marks whose metronome mark values you want to change. You
can do this in Write mode and Engrave mode.

2.

In the Properties panel, change the value for Tempo (bpm) in the Tempo group in any of
the following ways:

3.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The metronome mark value is changed for the selected absolute tempo marks. This affects the
tempo of playback, even if no metronome mark component is shown for those tempo marks.
NOTE
If you enter decimals, Dorico automatically rounds them up/down to the nearest whole number
for the metronome mark. However, your specified value still affects the tempo in playback.

RELATED LINKS
Changing the type and appearance of absolute tempo changes on page 728

Showing the metronome mark value as a range
You can show the metronome mark value of individual absolute tempo marks as a range. For
example, you can use this to indicate that any speed within the given range is musically
appropriate for the piece.
NOTE
These steps do not apply to gradual tempo changes or reset/relative tempo marks.

PROCEDURE
1.

Select the absolute tempo marks whose metronome mark values you want to show as a
range. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Tempo range (bpm) in the Tempo group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.
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RESULT
The tempo range, expressed as beats per minute, is changed for the selected tempo marks.
NOTE
Depending on the values set for each property, both Tempo (bpm) and Tempo range (bpm) can
be the minimum/maximum tempo in the range, as Dorico automatically arranges metronome
mark ranges with the lower value first. However, the metronome mark used for playback is
always Tempo (bpm), regardless of whether that is the higher/lower value in the range.

RELATED LINKS
Changing the metronome mark value on page 729

Changing the relative tempo mark value
You can change the tempo of individual relative tempo marks, expressed as a percentage of the
previous tempo mark.
PROCEDURE
1.

Select the relative tempo marks whose value you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, change the value for Relative % in the Tempo group in any of the
following ways:

3.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The tempo at the relative tempo mark is changed. For example, if the previous tempo was
100 bpm, and you change a relative tempo mark to 90, the new tempo is 90% of 100 bpm, which
is 90 bpm.

Changing the final tempo at the end of gradual tempo changes
You can change how significantly gradual tempo changes affect the tempo in playback,
expressed as a percentage of the tempo at the start of the gradual tempo change.
PROCEDURE
1.

Select the gradual tempo changes whose final tempo you want to change. You can do this
in Write mode and Engrave mode.

2.

In the Properties panel, change the value for Final tempo % in the Tempo group in any of
the following ways:

3.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.
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RESULT
The final tempo at the end of the selected gradual tempo changes is changed.
For example, if you change the value to 20 on a gradual tempo change that started at 100 bpm,
the final tempo is 20% of 100 bpm, which is 20 bpm. If you change the value to 120 on a gradual
tempo change that started at 100 bpm, the final tempo is 120% of 100 bpm, which is 120 bpm.

Gradual tempo changes
Gradual tempo changes indicate a change in tempo over a defined period of time, such as
rallentando, which indicates slowing down, and accelerando, which indicates speeding up.

Rallentando with dashed line

Gradual tempo changes are considered a type of tempo mark in Dorico, meaning you can input
them in the same ways as for tempo marks.
Because gradual tempo changes have a different metronome mark value at the start/end, you
can change the final tempo at the end of individual gradual tempo changes.
In Dorico, you can show gradual tempo changes with different styles.
●

rit.: Shows gradual tempo changes with text only.

●

rit...: Shows gradual tempo changes with text and a continuation line.

●

rit-e-nu-to: Shows gradual tempo changes with the text hyphenated and separated into
syllables.

You can also show gradual tempo changes with different line styles.
You can change both the style and line style of all gradual tempo changes project-wide on the
Tempo page in Engrave > Engraving Options, and change the style and line style of individual
gradual tempo changes independently of your project-wide settings.
RELATED LINKS
Input methods for tempo marks on page 208
Changing the style of gradual tempo changes on page 731
Changing the line style of gradual tempo changes on page 732
Project-wide engraving options for tempo marks on page 726
Changing the final tempo at the end of gradual tempo changes on page 730

Changing the style of gradual tempo changes
You can change the style of individual gradual tempo changes, independently of your projectwide setting. Gradual tempo changes can appear as text only with no continuation line, text with
a continuation line, or with the word spread across their duration.
PROCEDURE
1.

Select the gradual tempo changes whose style you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Gradual style in the Tempo group.

3.

Select one of the following options from the menu:
●

rit.

●

rit...
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●

rit-e-nu-to

RESULT
The style of the selected gradual tempo changes is changed.
TIP
You can change the style of all gradual tempo changes project-wide on the Tempo page in
Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for tempo marks on page 726

Changing the line style of gradual tempo changes
You can change the line style of individual gradual tempo changes whose style includes a
continuation line, independently of your project-wide settings.
NOTE
This does not affect the appearance of gradual tempo changes with the text-only style.

PROCEDURE
1.

Select the gradual tempo changes whose line style you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Line style in the Tempo group.

3.

Select one of the following options from the menu:
●

Solid

●

Dotted

●

Dashed

RESULT
The line style of the selected gradual tempo changes is changed.
TIP
You can change the default line style of all gradual tempo changes project-wide on the Tempo
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for tempo marks on page 726
Changing the style of gradual tempo changes on page 731

Lengthening/Shortening gaps and dashes in gradual tempo changes
You can change the length of dashes and the gaps between dashes in individual gradual tempo
changes, independently of your project-wide settings.
NOTE
This only applies to gradual tempo changes with dashed lines.
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PROCEDURE
1.

In Engrave mode, select the gradual tempo changes with dashed lines whose dash length
you want to change.

2.

In the Properties panel, activate the following properties, individually or together, in the
Tempo group:

3.

●

Line dash length

●

Line dash gap

Change the values in the value fields in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increasing Line dash length makes dashes in gradual tempo changes longer, decreasing the
value makes dashes shorter.
Increasing Line dash gap makes gaps between dashes in gradual tempo change lines longer,
decreasing the value makes gaps shorter.
TIP
You can find options that change the default dash length for all dashed gradual tempo changes
project-wide by clicking Advanced Options in the Gradual Changes section of the Tempo page
in Engrave > Engraving Options.
For example, you can change the default dash length for dashed lines following text and dashed
lines between hyphenated text separately.

RELATED LINKS
Project-wide engraving options for tempo marks on page 726

Changing the line thickness of gradual tempo changes
You can change the thickness of dashed and solid lines in gradual tempo changes individually,
independently of your project-wide settings.
PROCEDURE
1.

In Engrave mode, select the gradual tempo changes whose thickness you want to change.

2.

In the Properties panel, activate Line thickness in the Tempo group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increasing the value makes dashed and solid lines thicker, decreasing the value makes dashed
and solid lines thinner.
TIP
You can change the thickness of all dashed and solid gradual tempo change lines project-wide on
the Tempo page in Engrave > Engraving Options.
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RELATED LINKS
Project-wide engraving options for tempo marks on page 726
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A tie is a curved line that joins two notes of the same pitch. When multiple, adjacent notes are
joined with a sequence of ties, that is known as a tie chain.
Each sequence of tie chains, whether they join two notes together or ten notes together,
represents a single note with the duration of all the tied notes combined. A performer plays the
notes as one note, without re-striking, re-blowing, or re-bowing the note at any point within the
rhythmic duration of the tie chain.
In Dorico, most ties are created automatically. Rhythms are notated according to the prevailing
beat grouping, which is normally set by the time signature. Therefore, notes that cannot be
notated using a single duration are automatically drawn as separate tied notes.
RELATED LINKS
Tie chains on page 737
Inputting notes on page 115
Forcing the duration of notes/rests on page 125
Inputting ties on page 127
Splitting tie chains on page 741
Time signatures on page 751
Input methods for time signatures on page 150
Beams according to time signatures on page 404

General placement conventions for ties
Ties join two noteheads together, meaning the ends of ties are positioned close to the noteheads
to which they are attached.
Ties are curved lines, and the direction of the curve usually follows the stem direction of the
notes. If notes are stem-up, ties curve downwards, and if notes are stem-down, ties curve
upwards.
NOTE
If there are multiple voices on the staff, all ties in up-stem voices curve upwards and all ties in
down-stem voices curve downwards.
There are two main conventions for the placement of the ends of ties relative to noteheads. One
convention is to place the ends of ties outside noteheads, meaning above or below them, ideally
positioned at the horizontal center of noteheads. The other convention is to place the ends of
ties between noteheads, ideally positioned at the vertical center of noteheads.
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A tie outside noteheads

A tie between noteheads

For both conventions, Dorico automatically positions the ends of ties as close as possible to the
notes that they join while avoiding collisions with other notations.
The vertical placement of ties is also automatically adjusted in Dorico so that neither of the end
points of ties, nor the apex of tie curves, starts or ends on a staff line. If this happens, it can
cause the shape of ties to appear distorted, which makes the music harder to read.
To avoid this, Dorico changes the vertical position of ties slightly, and makes small changes to the
curvature of ties. These changes are small, but the placement of ties is subtly different
depending on the position of notes relative to staff lines.

A tie outside noteheads

When transposed one note down, the tie appears
with a steeper curve to avoid reaching its apex on
the staff line.

A tie between noteheads, with the ends slightly
above the vertical center of the noteheads to avoid
the tie appearing too close to the staff line at its
ends or apex.

When transposed up, the ends of the tie are now
positioned at the vertical center of the notehead, as
there is no staff line with which it could collide.

Wherever possible, clef changes should not be positioned in the middle of tie chains. Changing
the clef changes the position of the tied note on the staff, which could easily cause a performer
to misread the tie as a slur and play two different notes.
Ties can look distorted when they are very short, and can be overlooked. You can change the
minimum length of ties when they are within a single system on the Ties page in Engrave >
Engraving Options.
NOTE
Slurs must not be confused with ties, which look superficially similar, but instead join notes of the
same pitch to indicate that they are played as a single note. In that sense, ties are part of
rhythmic notation, while slurs are considered articulation.

RELATED LINKS
Ties vs. slurs on page 737
Inputting ties on page 127
Project-wide engraving options for ties on page 742
General placement conventions for clefs on page 444
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Tie chains
When notes are longer than the maximum duration of a bar in the prevailing time signature, ties
can extend over multiple bars. In Dorico, such ties are known as tie chains.
For example, if you input a note that is longer than a whole note in a 4/4 time signature, it
becomes two or more notes tied together in a chain across multiple bars.
In Write mode, you can only select whole tie chains. In Engrave mode, you can select individual
ties within tie chains. Any changes you make to tie chains in Write mode only affect the first tie in
the chain.
NOTE
Dorico automatically adjusts tied notes in the following circumstances:
●

If you change the pitch of a tied note, which includes adding or removing an accidental,
the change is applied to all the notes that are tied together.

●

If you add or remove an articulation, the articulation is added only to the start or the end
of the tie chain as appropriate, for example, to the last note for an articulation of duration
or to the first note for an articulation of force.

Articulations relative to tie chains
The positions of articulations relative to tie chains depend on the type of articulation. You can
change the positions of articulations relative to tie chains project-wide and for individual tie
chains.
RELATED LINKS
Positions of articulations on page 369
Changing the positions of articulations on tied notes on page 370

Ties vs. slurs
Ties and slurs look superficially similar but differ in meaning.
Ties indicate that a note should not be re-struck. They are used to join notes of the same pitch
together. For example, ties can be used to extend notes across multiple bars. Although multiple
notes can be included in a single tie chain, each tie in the chain only joins one notehead to the
next notehead on the staff.
Ties can be used in conjunction with articulation, but articulation on tied notes only affects the
attack at the start of the tie chain and the release at the end of the tie chain.

Two long notes tied together

Slurs indicate articulation, such as bowing or breathing, and normally group notes of different
pitches together. Slurs can join two noteheads together with any number of pitches in between.
They often indicate the shaping of phrases.
Slurs can also be used in conjunction with articulation. Unlike ties, articulation within slurs can
affect the sound throughout the phrase. For example, staccato articulations on repeated notes of
the same pitch within a slur indicate that notes should be played on a stringed instrument using
the same bow direction, but stopping the bow between each note.
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A phrase with notes grouped together by slurs

Non-standard ties
Usually, ties join two notes of the same pitch in the same staff. However, ties can also cross
system breaks and frame breaks, clef changes, or time signature changes. These types of ties are
all positioned automatically in Dorico.
Ties can also join non-adjacent notes, notes in different voices, or notes in different staves
together. In Dorico, you must input these types of ties manually.

Ties across system breaks and page breaks
The ends of ties that cross system breaks are automatically positioned in Dorico.
Their vertical position remains the same, as both ends are centered on the noteheads to which
they are attached. Their behavior also remains the same, as selecting one note in a tie chain that
crosses a system or frame break in Write mode selects all notes in the tie chain.
The horizontal space for the parts of ties shown to the left of notes at the start of new systems/
frames may not be sufficient to show an ideal tie curve. In such cases, you can use Note Spacing
in Engrave mode to adjust the spacing of individual notes at the start of systems/frames to give
ties more space.

The start of a tie chain before a system break

The end of the same tie chain after a system break

Tied notes with accidentals across system breaks and page breaks
The ends of ties for tied notes with accidentals across system breaks and page breaks are also
automatically positioned.
As tied notes in Dorico are treated as one note notated to fit in time signatures, cautionary
accidentals at the start of new systems/frames are not shown by default. If you choose to show
accidentals beside notes in tie chains at the start of new systems/frames, the position of the
notes is changed to accommodate accidentals. However, this automatic position might not leave
sufficient room for the part of the tie to the left of the notes to be shown with an ideal curve.

The start of a tie chain before a
system break

The end of the same tie chain,
with a cautionary accidental in
parentheses

The end of the same tie chain after
adjusting note spacing to give the
tie beside the accidental more
space

Ties across time signature changes
Ties are automatically positioned between notes that span a time signature change. If ties
crossing a time signature change are joining notes in the middle of a staff, the top or bottom of

738

Ties
Non-standard ties
time signature changes are partially obscured by the ties. However, as ties are curved, the time
signature is unlikely to be completely obscured.

Ties across clef changes
Ties are automatically positioned between notes that span a change of clef. Ties across clef
changes are not horizontal, as the same pitch is positioned differently in each clef.
The result of cross-clef ties is likely to be visually and musically confusing, as they can be misread
as slurs. In this case, consider moving the change of clef to before/after the tied note.

Ties between non-adjacent notes
You can input ties between notes of the same pitch that are not directly beside each other. This
can be useful when inputting ties between multiple notes before a chord, for example.

Notes leading into a chord notated Notes leading into a chord notated Multiple grace notes before a
as a series of tied chords
as tied non-adjacent notes
chord with ties between nonadjacent notes

Ties between different voices
You can input ties between notes of the same pitch in different voices.

Ties between notes on different staves
You can input ties between notes of the same pitch in different staves.

Laissez vibrer ties
Laissez vibrer ties are short ties that indicate a note should be left to ring, and should not be
stopped. They extend a small amount to the right of the note to which they apply, but do not
connect to another note.
You can add laissez vibrer ties to any note. You can edit laissez vibrer ties in Engrave mode like any
other tie.
RELATED LINKS
Inputting ties between non-adjacent notes on page 739
Hiding/Showing laissez vibrer ties on existing notes on page 740
Showing accidentals in parentheses on page 356
Note spacing on page 284
Adjusting note spacing at individual rhythmic positions on page 291

Inputting ties between non-adjacent notes
You can manually input ties between notes of the same pitch that are not rhythmically adjacent.
You can also input ties between notes of the same pitch in different voices and different staves.
For example, you might have input a melody across multiple voices in order to accommodate
passing notes, but want to tie two notes together even though they are in different voices.
Similarly, you might have written multiple notes before a chord that are all held down and want
to reduce the number of tied notes.
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PROCEDURE
1.

In Write mode, select the two notes that you want to tie together.
NOTE
The second note must be the same pitch as the first note. If the second note is a different
pitch to the first note, no tie is input.

2.

Input a tie in any of the following ways:
●

Press T.

●

Click Tie in the Notes toolbox.

RESULT
A tie is input between the two selected notes.
EXAMPLE

Spread chord with ties between all adjacent notes

Spread chord with ties between non-adjacent notes

RELATED LINKS
Inputting ties on page 127

Hiding/Showing laissez vibrer ties on existing notes
You can add laissez vibrer ties to any note.
PROCEDURE
1.

Select the notes on which you want to add a laissez vibrer tie. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate/deactivate Laissez vibrer tie in the Notes and Rests
group.

RESULT
Laissez vibrer ties are added to the selected notes when the property is activated, and are
removed when the property is deactivated. Laissez vibrer ties are positioned automatically.
TIP
You can edit the length and shape of laissez vibrer ties individually like any other tie in Engrave
mode.

RELATED LINKS
Changing the position/shape of ties on page 742
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Deleting ties
You can delete ties without deleting the notes to which they are attached.
NOTE
Deleting ties from tie chains removes all ties in the tie chain. If you want to remove single ties
from longer tie chains, you can split the tie chain.

PROCEDURE
1.

In Write mode, select the tie chains from which you want to delete all ties.

2.

Delete all ties in the tie chain in any of the following ways:
●

Press U.

●

Click Scissors in the Notes toolbox.

RESULT
All ties in the selected tie chains are deleted. Notes previously in the tie chain remain at their
rhythmic positions.
RELATED LINKS
Splitting tie chains on page 741
Changing the duration of notes on page 125

Splitting tie chains
You can split tie chains at specified positions, for example, if you want to change the pitch
halfway through a tie chain or delete individual ties within tie chains. This does not remove any
other ties in the tie chain.
PROCEDURE
1.

In Write mode, select the tie chain you want to split.

2.

Start note input in any of the following ways:

3.

4.

5.

●

Press Shift-N or Return.

●

Choose Write > Note Input.

●

Double-click the tie chain.

Position the caret at the rhythmic position where you want to split the tie chain.
●

Press Right Arrow/Left Arrow to move the caret to the right/left, according to the
current rhythmic grid value.

●

Press Space to advance the caret to the next rhythmic position, according to the
note value currently selected.

Split the tie chain in any of the following ways:
●

Press U.

●

Click Scissors in the Notes toolbox.

Optional: If you want to split the same tie chain in multiple places, move the caret to the
next rhythmic position where you want to split the tie chain.
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6.

Press Esc or Return to stop note input.

RESULT
The tie chain is split at the caret position.
RELATED LINKS
Moving the caret manually on page 115

Project-wide engraving options for ties
You can find options for the project-wide appearance, position, and placement of ties on the Ties
page in Engraving Options.
The options on the Ties page allow you to change the default curvature direction, shape, and
appearance of ties, and the position of ties relative to noteheads and other ties in tie chains.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Ties in the page list on the left of the dialog.

Changing the position/shape of ties
Each tie has five square handles that you can move separately to change the appearance and
shape of individual ties.

A tie in Engrave mode

NOTE
Moving one handle can also affect the positions of other handles.
For example, moving the left endpoint moves the start of a tie, but the rest of the handles stay in
their existing positions. However, moving the left control point also causes the tie height handle
to move. This gives you fine control over the shape of ties while ensuring that the end result
remains curved and smooth.
PROCEDURE
1.

In Engrave mode, select the tie handles you want to move in any of the following ways:
●

Select a whole tie and press Tab to cycle through its handles until the one you want
to move is selected.

●

Click the handle you want to move.

●

Ctrl/Cmd-click individual handles on multiple ties.
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TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction.

RESULT
The positions of the selected tie handles are changed, which changes the shape of the
corresponding ties.
TIP
The following properties in the Ties group of the Properties panel are activated automatically
when you move the corresponding tie handles:
●

Start offset moves the left endpoints of ties. X moves them horizontally, Y moves them
vertically.

●

End offset moves the right endpoints of ties. X moves them horizontally, Y moves them
vertically.

●

Start handle offset moves the left control points of ties. X moves them horizontally, Y
moves them vertically.

●

End handle offset moves the right control points of ties. X moves them horizontally, Y
moves them vertically.

You can also use these properties to change the shape of individual ties by changing the values
in the value fields.
Deactivating the properties resets the corresponding handles on the selected ties to their default
positions.

Tie shoulder offset
Tie shoulders affect the angles of the curves of ties as they taper towards an endpoint, as the
tapered ends often approach noteheads at a steeper angle than that of a tie’s arch.
Increasing the shoulder offset makes the onset of the curve shallower, whereas decreasing the
shoulder offset makes the onset steeper.
You can change the project-wide settings for the offset of tie shoulders by changing the values
for the following options, which you can find by clicking Advanced Options in the Design section
of the Ties page in Engrave > Engraving Options:
●

Offset shoulders by fraction of half length of short tie

●

Offset shoulders by fraction of half length of long tie
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A long tie with default shoulder offset (1/10)

A long tie with increased shoulder offset (7/8)

You can also change the shoulder offset of ties individually by moving their control point handles
in Engrave mode.
RELATED LINKS
Project-wide engraving options for ties on page 742
Changing the shoulder offset of ties on page 744

Changing the shoulder offset of ties
You can change the shoulder offset of individual ties, independently of your project-wide
settings. For example, you might want to change the shoulder offset of a few very short or very
long ties in your project to improve their shape.
PROCEDURE
1.

In Engrave mode, select one of the control point handles on each of the ties whose
shoulders you want to adjust in any of the following ways:
●

Select a whole tie and press Tab to cycle through the handles until the one you want
to move is selected.

●

Click the handle you want to move.

●

Ctrl/Cmd-click individual handles on multiple ties.

TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
2.

Move the handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●
3.

Click and drag them in any direction.

Optional: Repeat steps 1 and 2 for the other control point handle on the ties whose
shoulders you want to adjust.

RESULT
Moving tie offset handles further apart reduces the shoulder offset, while moving them closer
together increases the shoulder offset.
TIP
The following properties in the Ties group of the Properties panel are activated automatically
when you move the corresponding tie handles:
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●

Start handle offset moves the left control points of ties. X moves them horizontally, Y
moves them vertically.

●

End handle offset moves the right control points of ties. X moves them horizontally, Y
moves them vertically.

You can also use these properties to change the shoulder offset of individual ties by changing the
values in the value fields.
Deactivating the properties resets the corresponding handles on the selected ties to their default
positions.
TIP
You can find options controlling the default shoulder offset of all ties project-wide by clicking
Advanced Options in the Design section of the Ties page in Engrave > Engraving Options.
There are separate settings for short ties and long ties.

RELATED LINKS
Project-wide engraving options for ties on page 742
Tie shoulder offset on page 743

Tie height
You can change values for the heights of all short ties and long ties project-wide. You can also
change the height of individual ties in Engrave mode.
You can find options that change the project-wide heights of ties by clicking Advanced Options
in the Design section of the Ties page in Engrave > Engraving Options. There are separate
settings for short ties and long ties.
Increasing the height of ties makes them extend further from the staff, which gives them a
rounder shape and means they take up more vertical space. Ties generally do not need to be as
curved as slurs, as they join notes of the same pitch instead of arching over or above a range of
pitches.
Where vertical space is tight, a balance must be found between how curved ties are and ensuring
staves do not overlap.

A long tie with increased height

A long tie with default height

Changing the height of ties
You can change the height of individual ties, independently of your project-wide settings, for
example, to save vertical space.
PROCEDURE
1.

In Engrave mode, select the tie height (middle) handle of the ties whose height you want
to change.
TIP
You can show handles on all items, not just selected items, by choosing Engrave > Show
Handles > Always. This can make it easier to select individual handles on multiple items.
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2.

Move the tie height handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●

Click and drag them upwards/downwards.

RESULT
The height of the selected ties is changed.
NOTE
●

To maintain a visually pleasing and symmetrical curve when changing the height of ties
manually, you may need to move tie height handles to the right/left by a small amount, as
well as upwards/downwards.

●

Moving tie height handles to the right/left affects the shape of the whole tie.

●

You can find options controlling the default height of all ties project-wide by clicking
Advanced Options in the Design section of the Ties page in Engrave > Engraving
Options. There are separate settings for short ties and long ties.

RELATED LINKS
Project-wide engraving options for ties on page 742

Tie styles
There are different styles of ties available in Dorico, which you can use to indicate different
meanings.
Solid
This is the default style for ties. Ties appear as tapered solid lines: thinner at the ends
and thicker in the middle.

Dashed
Ties appear as tapered dashed lines. Can be used to denote optional or suggested
ties, for example, in vocal music where some verses have more syllables than others
and therefore require more notes.

Dotted
Ties appear as dotted lines. The dots are the same size and the same distance apart
over the whole length of the tie. Can also be used to denote optional or suggested
ties.

Half-dashed start
The first halves of ties appear as dashed lines, the second halves as solid lines. Used
to denote that a tie was written incompletely in the source in critical editions.

746

Ties
Tie styles

Half-dashed end
The first halves of ties appear as solid lines, the second halves as dashed lines. Used
to denote that a tie was written incompletely in the source in critical editions.

Editorial
Ties appear as solid black lines, but with a smaller vertical line intersecting them
exactly halfway along their length. Used to show that ties were added by the editor
and were not present in the source.

RELATED LINKS
Changing the style of ties on page 747

Changing the style of ties
You can change the style of individual ties. By default, all ties are solid.
PROCEDURE
1.

Select the ties whose style you want to change. You can do this in Write mode and in
Engrave mode.
NOTE
●

In Write mode, you can only select whole tie chains. In Engrave mode, you can select
individual ties within tie chains.

●

Any changes to tie chains in Write mode only affect the first tie in the chain.

2.

In the Properties panel, activate Style in the Ties group.

3.

Select one of the following options from the menu:
●

Solid

●

Dashed

●

Dotted

●

Half-dashed start

●

Half-dashed end

●

Editorial

RESULT
The style of the selected ties is changed.
TIP
You can set the precise parameters of each of these options project-wide on the Ties page in
Engrave > Engraving Options. For example, you can change the length and width of the stroke
in Editorial ties, the diameter of dots and length of dashes, and the sizes of the gaps between
dots and dashes.

RELATED LINKS
Tie styles on page 746
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Changing the size of dashes/dots in ties
You can change the size of the dashes/dots in dashed/dotted ties individually, independently of
your project-wide settings.
NOTE
This only applies to dashed/dotted ties.

PROCEDURE
1.

Select the dashed/dotted ties whose dash/dot size you want to change. You can do this in
Write mode and Engrave mode.
NOTE
Any changes to tie chains in Write mode only affect the first tie in the chain.

2.

In the Properties panel, activate Dash/dot in the Ties group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increasing the value makes dashes/dots bigger, decreasing the value makes dashes/dots
smaller.
TIP
You can find options to set the default size of dashes/dots in all dashed/dotted ties project-wide
by clicking Advanced Options in the Design section of the Ties page in Engrave > Engraving
Options.
You can also change the thickness of all tie styles on this page. However, you cannot change the
thickness of ties individually.

RELATED LINKS
Project-wide engraving options for ties on page 742

Changing the size of gaps in dashed/dotted ties
You can change the size of the gaps in dashed/dotted ties individually, independently of your
project-wide settings.
PROCEDURE
1.

Select the dashed/dotted tie chains whose gap size you want to change. You can do this in
Write mode and Engrave mode.
NOTE
Any changes to tie chains in Write mode only affect the first tie in the chain.

2.

In the Properties panel, activate Gap in the Ties group.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.
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RESULT
Increasing the value makes the gaps between dashes/dots larger. Decreasing the value makes
the gaps between dashes/dots smaller.
TIP
You can find options to set the default size of the gaps between dashes/dots in all dashed/dotted
ties project-wide by clicking Advanced Options in the Design section of the Ties page in
Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for ties on page 742

Tie curvature direction
The direction of tie curvatures is determined by the stem direction of the notes/chords at each
end of the tie, the number of notes in chords at each end, and the number of voices on the staff.

Tied single notes in single-voice contexts
If a single voice is active and a tie joins two single notes, tie curvature direction is determined by
the stem directions of the notes at either end of the tie.
●

If the stem directions match, the tie curves away from the notes and is positioned on the
notehead side.

●

If the stem directions differ, the tie curves upwards by default.

Tied chords in single-voice contexts
If a tie joins two chords, the direction of the ties is determined by the number of tied notes in the
chords.
●

For an even number, the ties are equally split between curving towards the notehead end
and curving towards the stem end.

●

For an uneven number, the majority of ties curve towards the notehead end.

Tied notes in multiple-voice contexts
Ties are positioned on the stem side and are curved as follows:
●

For up-stem voices, ties curve upwards.

●

For down-stem voices, ties curve downwards.

●

For overlapping/interlocking pitches in multiple voices, the rules for tied chords in singlevoice contexts apply. All notes in all voices are treated as if they belong to a single voice.

TIP
You can change the default tie curvature direction of ties between notes with different stem
directions on the Ties page in Engrave > Engraving Options.
You can also change the curvature direction of ties individually.

RELATED LINKS
Changing the curvature direction of ties on page 750
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Changing the curvature direction of ties
You can change the curvature direction of ties individually, including individual ties within tie
chains.
PROCEDURE
1.

Select the ties whose curvature direction you want to change. You can do this in Write
mode and Engrave mode.
NOTE
●

In Write mode, you can only select whole tie chains. In Engrave mode, you can select
individual ties within tie chains.

●

Any changes to tie chains in Write mode only affect the first tie in the chain.

2.

In the Properties panel, activate Direction in the Ties group.

3.

Choose one of the following options:
●

Up

●

Down

RESULT
The curvature direction of the selected ties is changed.
TIP
You can adjust the precise shapes of tie chains, and of each tie within tie chains, in Engrave mode
using the square handles on each tie.

RELATED LINKS
Changing the position/shape of ties on page 742
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Time signatures indicate the meter, and apply to all bars from where they first appear until a
subsequent change of time signature. Meter describes the rhythmic pulse of music, and its
division into beats and bars.
A time signature is made up of two parts, and can be described using the same mathematical
terms used for fractions: numerator on top, and denominator underneath.
The numerator specifies the number of multiples of the duration specified by the denominator.
The denominator doubles for every halving of the beat duration: 1 is a whole note (breve), 2 is a
half note (minim), 4 is a quarter note (crotchet) and so on. Depending on your settings for time
signature style, numerators and denominators can have different appearances.
For example, a 4/4 time signature tells you the bar is made up of four beats, and each of those
beats is a quarter note in length. A time signature of 4/2 contains four half notes in each bar, and
4/8 contains four eighth notes (quavers) in each bar. Both 3/4 and 6/8 contain six eighth notes,
but it is understood that a 3/4 bar contains three quarter note beats, whereas a 6/8 bar contains
two dotted quarter note beats.
Bars are rhythmic groups, divided according to the time signature, and they make following the
music much more practical. Notes are beamed differently in different time signatures, again to
make the meter clear and easily readable.
By default, time signatures apply to all staves. However, there are some situations, such as in
polymetric music, that require some parts to have their own time signature, independently of the
rest of the ensemble. You can input time signatures that apply to all staves or only apply to single
staves in Dorico.
NOTE
Beat lengths are fixed across all staves in your project, regardless of the time signature. For
example, if you have a 2/4 time signature on one staff and a 6/8 time signature on another staff,
then one quarter note in the 2/4 time signature equals one quarter note in the 6/8 time
signature, meaning their barlines do not match.

RELATED LINKS
Time signature styles on page 755
Input methods for time signatures on page 150
Conventions for beam grouping according to meter on page 420
Create Time Signature section of the Time Signatures (Meter) panel on page 152
Creating custom beat groupings for meters on page 421
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General conventions for time signatures
Over time, the placement and appearance of time signatures has developed conventions to
ensure that their notation is always understood. Dorico follows these conventions automatically.

Appearance conventions
Time signatures should fill the height of the staff. There is a risk they may not be noticed if they
are smaller. The size of time signatures on staves with fewer than five lines should be the same
as that of a time signature on an equivalent five-line staff.

Time signature on a five-line staff

Time signature on a single-line staff

Time signatures use a unique, heavy font that ensures they stand out against staff lines, and are
instantly recognizable.
For some types of music, particularly film music, it is typical to use large time signatures that
span several staves. Dorico does not yet support large time signatures, but this is planned for
future versions. However, you can change the scale size of time signatures individually.

Placement conventions
Time signatures should be shown at the start of a piece and at the start of subsequent
movements, if applicable, even if the music carries straight on. They should be placed after clefs
and key signatures.
If time signature changes occur during a piece or movement, it should be placed immediately
after a barline. Dorico automatically inserts a barline before a time signature change if it occurs
in the middle of an existing bar. However, Dorico does not override your existing music by
inserting extra beats, unless Insert mode is activated.

A 4/4 time signature interrupting a 5/8 time signature, input without Insert mode activated, leaving only
three eighth note beats in the second 5/8 bar.

A time signature applies until the next time signature change, the end of the movement, or the
end of a piece, whichever comes first.
RELATED LINKS
Inputting notes in Insert mode on page 120
Changing the size of time signatures on page 761

Project-wide engraving options for time signatures
You can find options for the project-wide appearance of time signatures on the Time Signatures
page in Engraving Options.
The options on this page allow you to change the appearance of all numerators and
denominators project-wide, the appearance of meterless time signatures, and how
interchangeable time signatures are separated. You can also change the default gaps in time
signatures, for example, the gap between interchangeable time signatures and their separator.
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There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Time Signatures in the page list on the left of the dialog.
RELATED LINKS
Time signatures on page 751

Types of time signatures
There are different types of time signatures, which can indicate various and complex meters.
NOTE
Dorico uses the definitions for meters commonly used in American English. These definitions,
such as which meters are considered simple and compound, might be different in other
languages.
Simple
In simple time signatures, each beat is divided by two into equal groups of notes.
Simple time signatures can be simple duple, such as 2/4, simple triple, such as 3/4, or
simple quadruple, such as 4/4.

Compound
In compound time signatures, each beat is divided by three into equal groups of
dotted notes, such as 6/8, which contains two dotted quarter note beats, or 9/4,
which contains three dotted half note beats.

Irregular
Irregular time signatures, such as 5/4 or 7/8, cannot be subdivided into equal beat
groups. Because the numerator is odd, these time signatures must be divided into
unequal beat groups. For example, 5/4 usually contains a half note beat and a dotted
half note beat.

Additive
Additive time signatures show how bars are subdivided into beat groups. You can
show beat group numerators for any type of time signature. For example, instead of
7/8, you could show an additive time signature of 2+3+2/8.

Alternating
An alternating time signature indicates a regular pattern that switches every bar
between two or more time signatures, in the indicated order. For example, for a
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phrase with twelve eighth notes that needs to be emphasized 3+3+2+2+2, an
alternating time signature of 6/8+3/4 might allow the two meters to be read more
clearly.

Interchangeable
An interchangeable time signature indicates a set of time signatures at the start of
the piece that can be used during the piece, such as 3/4–2/4. Unlike alternating time
signatures, interchangeable time signatures do not require a fixed pattern; any bar
in the piece can follow any of the time signatures in the set without having to restate
the time signature. They can have different separator styles in Dorico, which you can
set project-wide and also change individually.

Aggregate
An aggregate time signature shows two or more meters within the same bar, such as
2/4+3/8+5/4. Dorico automatically inputs dashed barlines to show the divisions
between each meter.

Open
An open time signature has no restrictions on meter, beaming, or beats. Any number
of notes can be added, with any beaming. In Dorico, an open time signature can be
shown with an X or N, or without any signature.

Non-power of two
A non-power of two time signature is one such as 5/6, which indicates five sextuplet
notes lasting for a whole note (semibreve). Examples of time signatures like this can
be found in the music of Adès.

Some composers, such as Boulez, have written fractional time signatures. Dorico does not
currently support these.
RELATED LINKS
Time signature styles on page 755
Input methods for time signatures on page 150
Time signatures popover on page 151
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Pick-up bars
Pick-up bars, also known as “upbeats” or “anacrusis”, allow you to include music before the first
full bar. Often, pick-up bars only comprise a few beats whose main purpose is to lead in to the
start of the piece.

Pick-up bar of a single quarter note beat at the start of Chopin's Mazurka Op. 30 No. 2

Pieces that start with a pick-up bar have time signatures that are positioned at the start of the
system as normal. However, the first full bar of the time signature occurs after the first barline
and not before. Therefore, pick-up bars do not contribute to the bar number count. Bar numbers
are counted from the first full bar in the flow.
Because pick-up bars are linked to the number of notes/rests in the music, in Dorico they are
linked to time signatures and so you must input pick-up bars alongside a time signature.
However, you can hide time signatures you do not want to show in the music.
RELATED LINKS
Input methods for time signatures on page 150
Hiding/Showing time signatures on page 761

Time signature styles
Dorico allows you to show time signatures in a variety of styles. For example, you can show
denominators as a number or as a note value.
You can change the style of all time signatures project-wide according to their type on the Time
Signatures page in Engrave > Engraving Options, and you can change the style of individual
time signatures independently of your project-wide settings.
The numerator is always one or more numbers, and can either show the total number of beats in
the bar, or show how the total duration of the bar is subdivided.

Numerator in a 7/8 time signature shown as a single
number

Numerator in a 7/8 time signature showing
subdivisions

The denominator can appear as a number, as a note indicating the equivalent duration, or not
appear at all.

Denominator shown as number

Denominator shown as notehead
(beat length)
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If shown as a notehead, the denominator can either show the length of each beat in the bar, or
the note duration for the bar. When showing the beat length, the numerator can also be
changed. In the example, the numerator 6 in the 6/8 time signature becomes a 2 to reflect the
two dotted quarter note beats that make up a 6/8 bar.

Denominator notehead showing the beat length of a Denominator showing the note duration of a 6/8
6/8 time signature
time signature

RELATED LINKS
Project-wide engraving options for time signatures on page 752
Changing the numerator style of time signatures on page 756
Changing the denominator style of time signatures on page 756
Changing the separator style of interchangeable time signatures on page 758
Changing the open meter style of time signatures on page 757

Changing the numerator style of time signatures
You can choose whether the numerators of individual time signatures show the total number of
beats in each bar, or the subdivision of beats in each bar, independently of your project-wide
setting.
PROCEDURE
1.

Select the time signatures whose numerator style you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate Numerator style in the Time Signatures group.

3.

Choose one of the following options:
●

Number

●

Beat group

RESULT
The numerator style of the selected time signatures is changed.
TIP
You can change the numerator style of all time signatures project-wide on the Time Signatures
page in Engrave > Engraving Options.

RELATED LINKS
Time signature styles on page 755
Project-wide engraving options for time signatures on page 752

Changing the denominator style of time signatures
You can change the denominator style of individual time signatures independently of your
project-wide settings, for example, if you want to show the denominator as a note instead of a
number.
PROCEDURE
1.

Select the time signatures whose denominator style you want to change. You can do this in
Write mode and Engrave mode.
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2.

In the Properties panel, activate Denominator style in the Time Signatures group.

3.

Choose one of the following options:
●

Number

●

Note

●

None

RESULT
The denominator style of the selected time signatures is changed.
TIP
You can change the denominator style of all time signatures project-wide on the Time
Signatures page in Engrave > Engraving Options.

RELATED LINKS
Time signature styles on page 755
Project-wide engraving options for time signatures on page 752

Changing the open meter style of time signatures
You can change the open meter style of individual time signatures, independently of your
project-wide setting.
PROCEDURE
1.

Select the open meter time signatures whose style you want to change. You can do this in
Write mode and Engrave mode.
NOTE
In the Properties panel, Open style in the Time Signatures group is automatically
activated for open meter time signatures.

2.

In the Properties panel, choose one of the following options for Open style in the Time
Signatures group:
●

Empty (none)

●

X

●

N (Penderecki’s symbol)

RESULT
The open meter style of the selected time signatures is changed.
TIP
You can change the style of all open meter time signatures project-wide on the Time Signatures
page in Engrave > Engraving Options.
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RELATED LINKS
Time signature styles on page 755
Project-wide engraving options for time signatures on page 752

Changing the separator style of interchangeable time signatures
You can change the separator shown in interchangeable time signatures individually,
independently of your project-wide setting.
PROCEDURE
1.

Select the interchangeable time signatures whose separator you want to change. You can
do this in Write mode and Engrave mode.
NOTE
In the Properties panel, Separator in the Time Signatures group is automatically
activated for interchangeable time signatures.

2.

Select one of the following options from the Separator menu:
●

Parentheses

●

Brackets

●

Equals sign

●

Slash

●

Space

●

Hyphen

RESULT
The separator style of the selected interchangeable time signatures is changed.
TIP
You can change the default separator of all interchangeable time signatures project-wide on the
Time Signatures page in Engrave > Engraving Options.
NOTE
Although they might look similar to interchangeable time signatures, aggregate time signatures
behave differently. Aggregate time signatures are separated by a + sign, whereas
interchangeable time signatures can be shown with six different separators but not a + sign.
Therefore, although you can activate Separator and choose from the available options for
aggregate time signatures, the property only affects the appearance of interchangeable time
signature separators.
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RELATED LINKS
Time signature styles on page 755
Project-wide engraving options for time signatures on page 752

Project-wide spacing gaps for time signatures
You can change the minimum gaps between objects, including time signatures, on the Spacing
Gaps page in Engraving Options.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

The following minimum values relate to time signatures:
●

Gap after barline before clef, key or time signature

●

Gap after key signature

●

Gap after mid-system time signature

Other values may have an effect on the position of time signatures, however, they also affect
other objects.

Moving time signatures rhythmically
You can move time signatures to new rhythmic positions after they have been input.
NOTE
●

You can only move time signatures rhythmically using the keyboard.

●

Time signatures can only be moved along staves. If you want to move a time signature
across staves, you must delete the time signature and input a new time signature on the
other staff.

If you want to adjust the default position of time signatures relative to notes or barlines, you
must change the project-wide values for spacing gaps on the Spacing Gaps page in Engrave >
Engraving Options.
PROCEDURE
1.

In Write mode, select the time signatures you want to move.

2.

Move the time signatures according to the current rhythmic grid value in any of the
following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

RESULT
The time signature takes effect from its new position until the next existing time signature, or the
end of the flow.
NOTE
Only one time signature can exist at each rhythmic position, except for time signatures that only
apply to single staves. If the time signature passes over another time signature as part of its
move, the selected time signature that you are moving is replaced by the existing time signature.
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You can undo this action, but any time signatures deleted in the process are only restored if you
moved the time signature using the keyboard.

RELATED LINKS
Project-wide spacing gaps for time signatures on page 759
Moving time signatures graphically on page 760

Moving time signatures graphically
You can move individual time signatures to new graphical positions without affecting the
positions of any other items.
NOTE
You cannot move time signatures shown at the start of systems. You can only move time
signature changes that occur partway through systems or at the end of systems.

PROCEDURE
1.

In Engrave mode, activate Note Spacing in the Formatting panel.

2.

Select the square note spacing handle at the top left of the time signature you want to
move.

A circular handle appears beside the time signature.
3.

Select the circular handle.

4.

Move the handle in any of the following ways:
●

Press Alt-Right Arrow to move it to the right.

●

Press Alt-Left Arrow to move it to the left.
TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

NOTE
You cannot move Note Spacing handles using the mouse, you can only move them using
the keyboard.

RESULT
The time signature is moved graphically to the right/left.
TIP
You can also change the value for Spacing Offset in the Time Signatures group of the
Properties panel to move time signatures horizontally. However, this also affects global note
spacing around the rhythmic position of the time signature.
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The Spacing Offset value is independent of note spacing changes.

RELATED LINKS
Note spacing on page 284

Hiding/Showing time signatures
You can hide/show time signatures without deleting them from your project.
PROCEDURE
1.

Select the time signatures you want to hide/show. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate/deactivate Hide time signature in the Time Signatures
group.

RESULT
The selected time signatures are hidden when Hide time signature is activated, and shown
when it is deactivated.
NOTE
Hidden time signatures do not take up any rhythmic space, so hiding/showing time signatures
affects note spacing.
Signposts are shown at the positions of each time signature so you can always find them again.
However, signposts are not printed by default.
TIP
You can hide/show time signature signposts by choosing View > Signposts > Time Signatures.
Time signature signposts are shown when a tick appears beside Time Signatures in this menu.
You can choose to print time signature signposts if you activate View options in the
Annotations section of the Print Options panel on the right of the window in Print mode.

RELATED LINKS
Note spacing on page 284

Changing the size of time signatures
You can change the size of individual time signatures in each layout independently.
PREREQUISITE
PROCEDURE
1.

In the music area, open the layout in which you want to change the size of time signatures.
You can do this in Write mode and Engrave mode.

2.

Select the time signatures you want to resize.

3.

In the Properties panel, activate one of the following properties in the Common group:

4.

●

If you want to resize time signatures by a set scale, activate Scale.

●

If you want to resize time signatures by a custom scale, activate Custom Scale.

Change the size of the selected time signatures in one of the following ways, according to
the property you activated:
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●

If you activated Scale, select a set scale option from the menu.

●

If you activated Custom Scale, enter the percentage by which you want to resize the
selected time signatures.

Deleting time signatures
You can delete time signatures without affecting the relative rhythmic positions of notes.
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The time signatures you want to delete.

●

The signposts of hidden time signatures you want to delete.

Delete the time signatures in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The time signatures are deleted from the score. Bars after their previous positions are re-barred
according to the previous time signature in the score, up until the next time signature or the end
of the flow.
If you delete the only time signature in the flow, your music appears in an open meter, but with
all the same rhythmic values.
RELATED LINKS
Types of time signatures on page 753
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Tremolos are thick, slanted lines that cross individual stems or are positioned between multiple
stems. They are used to indicate that notes are repeated, either individually or in sequences of
multiple notes.
Using tremolo strokes instead of notating each notehead can save horizontal space and make
fast passages easier to read.
The number of tremolo strokes indicates both how many times notes are repeated and how fast
they are. In measured tremolos, for example, one tremolo stroke on the stem of a quarter note
(crotchet) indicates two eighth notes (quavers) are played, whereas three tremolo strokes on the
stem of a quarter note indicates eight 32nd notes are played.

Quarter note with a one-stroke single-note tremolo
and its equivalent notation

Quarter note with a three-stroke single-note tremolo
and its equivalent notation

There are different types of tremolos:
Single-note tremolos
Individual notes are repeated.

Multi-note tremolos
Multiple notes, usually two, are played in sequence, similar to a trill. However, trills
usually indicate a fast alternation between two adjacent notes, such as G and A,
whereas multi-note tremolos can be between any notes, limited only by the
capabilities of the instrument.

Tuplet tremolos
Multiple notes in tuplets are played in sequence.

Depending on the musical context, tremolos can be either measured or unmeasured. There is no
visual difference between measured/unmeasured tremolos, so composers/arrangers often
specify how they want tremolos to be played, such as an indication in the front matter of the
score or as a text instruction in the score.
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Measured tremolos
The number of tremolo strokes corresponds to a precise rhythm in the prevailing
tempo and meter.
Unmeasured tremolos
There is no link between the number of strokes and rhythm. Instead, unmeasured
tremolos are played as fast as possible, whatever the tempo.
Unmeasured tremolos often use three or more tremolo strokes, and can also be
accompanied by a “trem.”text indication.
RELATED LINKS
Inputting single-note tremolos on page 206
Inputting multi-note tremolos on page 206

Tremolos in tie chains
By default, all notes in tie chains are shown with tremolo strokes when single-note tremolos are
added to tie chains. Deleting tremolo strokes from tied notes removes tremolo strokes from all
notes in tie chains.
In Dorico, tremolos are considered measured by default, so the number of tremolo strokes
shown is automatically adjusted on subsequent notes in tie chains as required. For example, if an
eighth note with two tremolo strokes is tied to a quarter note, the quarter note has three
tremolo strokes. This is because tremolo strokes function like beams, so two tremolo strokes and
an eighth note stem flag is the equivalent of three tremolo strokes.
However, there might be circumstances in which you want all notes to have the same number of
tremolo strokes, whatever their duration. You can also start tremolos partway through tie chains,
or stop tremolos partway through tie chains.
You can change the number of tremolo strokes shown on individual notes independently in
Engrave mode.
RELATED LINKS
Changing the number of tremolo strokes on individual notes in tie chains on page 764

Changing the number of tremolo strokes on individual notes in tie
chains
Dorico automatically changes the number of tremolo strokes on subsequent notes in tie chains
according to their duration, but you can manually change the number of single-note tremolo
strokes shown on each note in tie chains individually to represent your intended rhythm.
PROCEDURE
1.

In Engrave mode, select the noteheads of the notes whose number of tremolo strokes you
want to change.

2.

In the Properties panel, activate Single stem tremolo in the Notes and Rests group.

3.

Select one of the following options from the menu:
●

None

●

One stroke

●

Two strokes

●

Three strokes

●

Four strokes
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●

Buzz roll

RESULT
The number of tremolo strokes shown on the selected notes is changed.
EXAMPLE

The default number of tremolo strokes in a tie chain
where the second note is longer than the first.

The number of tremolo strokes on the second note
has been changed to match the first.

RELATED LINKS
Tremolos in tie chains on page 764
Changing the speed of tremolos on page 766

General placement conventions for tremolos
Single-note tremolos are positioned on note stems, whereas multi-note tremolos are positioned
between the stems of two or more notes.
When multi-note tremolos cross three or more notes, the tremolo strokes are positioned
between all the notes.
Tremolo strokes are slightly thinner than beams, so that the gaps between strokes are large
enough and the number of strokes can be instantly recognized.
Tremolo strokes should not collide with ledger lines or stem flags. Dorico automatically positions
tremolo strokes to ensure such collisions are avoided.
Tremolo strokes within the staff are positioned so that they are at least one staff space clear of
noteheads, and at valid positions relative to staff lines and staff spaces. This means that tremolo
strokes might not move every time you change the pitch of notes.

The positions of the tremolo strokes on the first two notes and the last two notes are the same, although the
pitches are all different.

In Dorico, the angle of single-note tremolo strokes is always the same, no matter the direction of
the phrase.
The angles of multi-note tremolo strokes are determined by the height of the stems to which the
multi-note tremolos apply. You can change the angles of multi-note tremolo strokes individually
by lengthening/shortening the stems at the start/end of the tremolo.
You can change the default positions of all tremolo strokes project-wide on the Tremolos page in
Engrave > Engraving Options.
RELATED LINKS
Moving tremolo strokes on page 767
Project-wide engraving options for tremolos on page 768
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Changing the speed of tremolos
You can change the speed of tremolos after they have been input by changing the number of
strokes.
PROCEDURE
1.

In Write mode, select the notes with tremolos whose speed you want to change.
The buttons with the number of tremolo strokes corresponding to your selection are
highlighted in the Tremolos section of the Repeat Structures panel.
NOTE
Select single-note tremolos and multi-note tremolos separately.

2.

Click the button with the number of tremolo strokes you want in the Tremolos section of
the Repeat Structures panel.
For example, click Two Strokes Single-note Tremolo to input single-note tremolos with
two strokes, or click Three Strokes Multi-note Tremolo to input multi-note tremolos with
three strokes.

Two Strokes Single-note Tremolo

Three Strokes Multi-note Tremolo

RESULT
The number of tremolo strokes on the selected notes is changed, which changes the speed of
the tremolos. This affects all notes in tie chains.
RELATED LINKS
Tremolos in playback on page 769
Changing the number of tremolo strokes on individual notes in tie chains on page 764
Deleting tremolos on page 766

Deleting tremolos
You can remove single-note tremolos and multi-note tremolos from notes separately without
affecting the notes to which they applied.
PROCEDURE
1.

In Write mode, select the notes whose tremolo strokes you want to delete.

2.

Click the appropriate buttons in the Tremolos section of the Repeat Structures panel for
the types of tremolos selected:
●

Remove Single-note tremolo

●

Remove Multi-note tremolo

RESULT
The corresponding types of tremolo strokes are deleted.
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EXAMPLE

Notes with single-note tremolos
and multi-note tremolo

Notes with multi-note tremolo
deleted but single-note tremolos
remain

Notes with both multi-note
tremolo and single-note tremolos
deleted

Rhythmic positions of notes with tremolos
You can move notes with single-note tremolos and multi-note tremolos to new rhythmic
positions in the same ways as normal notes. However, if you move multi-note tremolos across
barlines, the tremolo strokes are deleted automatically.
NOTE
You can undo moving tremolos immediately, which restores any multi-note tremolo strokes
deleted in the process.
You can move single-note tremolos to new rhythmic positions and across barlines without
affecting their tremolo strokes. The notes are automatically respelled as tie chains if required by
their new rhythmic positions and time signature, in the same ways as normal notes.
NOTE
If tie chains with single-note tremolos contain notes of different durations, the number of
tremolo strokes on each note in the tie chain is different. You can change the number of tremolo
strokes shown on each note in tie chains individually.

RELATED LINKS
Moving notes rhythmically on page 578
Changing the number of tremolo strokes on individual notes in tie chains on page 764

Moving tremolo strokes
You can move tremolo strokes upwards/downwards graphically.
NOTE
●

You cannot move tremolo strokes to the right/left.

●

You cannot move tremolo strokes rhythmically, as they apply to specific notes, but you can
move notes with tremolos to different rhythmic positions. Notes with single-note tremolos
can cross barlines, however, multi-note tremolo strokes are deleted automatically when
their notes cross barlines.

PROCEDURE
1.

In Engrave mode, select the tremolo strokes you want to move.

2.

Move the tremolo strokes in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
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TIP
If you want to move items by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.
●

Click and drag them upwards/downwards.

RESULT
The selected tremolo strokes are moved upwards/downwards.
NOTE
●

Moving multi-note tremolo strokes also changes the length of the stems to which they are
attached.

●

When you first move tremolo strokes graphically, they may appear to move in the wrong
direction or by a larger increment than you expected. This is because their positions are
reset when you override those positions by moving them.

TIP
The following properties in the Beaming group of the Properties panel are activated
automatically when you move the start/end of multi-note tremolo strokes:
●

Start Y offset moves the start of multi-note tremolo strokes vertically by moving the end
of the corresponding stem.

●

End Y offset moves the end of multi-note tremolo strokes vertically by moving the end of
the corresponding stem.

Tremolo Y in the Notes and Rests group of the Properties panel is activated automatically when
you move single-note tremolo strokes. It moves single-note tremolo strokes vertically.
For example, if you move a whole multi-note tremolo stroke upwards, both stem handles are
moved so both properties are activated. You can also use these properties to move tremolo
strokes by changing the values in the value fields. However, you must select the noteheads
rather than the tremolo strokes in order to see the relevant groups in the Properties panel.
Deactivating the properties resets the selected stem handles, and therefore tremolo strokes, to
their default positions.

RELATED LINKS
Project-wide engraving options for tremolos on page 768

Project-wide engraving options for tremolos
You can find options for the project-wide appearance and position of tremolos on the Tremolos
page in Engraving Options.
The options on the Tremolos page allow you to change the appearance of tremolo strokes, and
their positions relative to the ends of stems, stem flags, noteheads, and beams.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Tremolos in the page list on the left of the dialog.
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RELATED LINKS
Project-wide engraving options for stems on page 716

Changing the appearance of multi-note half note tremolos projectwide
There are multiple accepted ways of notating multi-note half note tremolos. You can change how
multi-note half note tremolos are notated project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
The Engraving Options dialog opens.

2.

Click Tremolos in the page list.

3.

In the Multi-note Tremolos section, choose one of the following options for Appearance
of half note (minim) tremolos:

4.

●

All lines join stems

●

Outermost line joins stems

●

No lines join stems (default)

Click Apply, then Close.

RESULT
The appearance of all multi-note half note tremolos project-wide is changed, according to your
preference.

Tremolos in playback
You can control the playback of unmeasured tremolos by specifying the minimum number of
tremolo strokes that are interpreted as unmeasured tremolos. This considers both the number of
tremolo strokes and the number of beam lines that would be used for the note.
You can do this on the Timing page in Playback Options.
For example, if the option is set to require three tremolo strokes, an eighth note with two
tremolo strokes is played as unmeasured, because the single beam of the eighth note is included
in the calculation.
You can also specify the default length of notes in unmeasured tremolos. You express the
duration of notes as a fraction of the length of a quarter note played at 120 quarters per minute
in the Tremolos section on the Timing page in Playback Options.
The number of tremolo strokes determines the note value of the repeated notes. For example,
one stroke indicates an eighth note, two strokes indicate a 16th note, and so on.
You can open Playback Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-P in any mode.

●

Choose Play > Playback Options in Play mode.

You can then click Timing in the page list on the left of the dialog.
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Changing the duration of tremolos in playback
You can change both the default length of each note in unmeasured tremolos in playback, and
the minimum number of tremolo strokes required to indicate tremolos should be unmeasured in
playback.
For example, to change the value in the value field to set the default length to 0.5 seconds, enter
1 into the value field, or click the arrows beside the value field to change the value, for Default
unmeasured tremolo length in the Tremolos section on the Timing page in Playback Options.
TIP
If you hover over either of the arrows beside the Default unmeasured tremolo length value
field, a small box appears that displays the current fraction as a decimal.

PROCEDURE
1.

In Play mode, choose Play > Playback Options.
The Playback Options dialog opens.

2.

Click Timing in the page list.

3.

Optional: In the Tremolos section, change the value for Minimum number of strokes for
playback of unmeasured tremolos in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Change the value for Default unmeasured tremolo length in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

For example, to set the default length of unmeasured tremolo notes to 0.5 seconds,
change the value to 1.
TIP
If you hover over either of the arrows beside the value field, a small box appears that
displays the current fraction as a decimal.
5.

Click Apply, then Close.

RESULT
The sounding duration of each note in unmeasured tremolos in playback is changed projectwide.
Changing the value for Minimum number of strokes for playback of unmeasured tremolos
changes the minimum number of tremolo strokes required for tremolos to be unmeasured in
playback.
RELATED LINKS
Tremolos in playback on page 769
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Tuplets indicate where a beat is divided into a different number of subdivisions than is usually
expected according to the current meter. They can be used to fit more notes or fewer notes in a
beat than usually exist in a beat, according to the usual pattern of subdivision.

A 4/4 bar with the standard subdivision of four
quarter notes

A 4/4 bar with a subdivision of six triplet quarter
notes in the space of four regular quarter notes

A 6/8 bar with the standard subdivision of six eighth
notes

A 6/8 bar with a subdivision of four duplet eighth
notes in the space of six regular eighth notes

Because these subdivisions are not standard but tuplet notes use the same rhythmic notation as
normal notes, tuplets must be clearly marked to show that their rhythmic duration is different.
In the examples, the triplet quarter notes are shown under a bracket with the number 3. The
duplet eighth notes do not need a bracket as they are joined by a beam, which has a number 2
above it.
Tuplets in Dorico can be shown with just a tuplet bracket, with a tuplet bracket and a tuplet
number/ratio, or with a tuplet bracket, a tuplet number/ratio, and a note indicating the note
value of the tuplet.
RELATED LINKS
Inputting tuplets on page 131
Tuplet numbers/ratios on page 779

General placement conventions for tuplets
Tuplet brackets and tuplet numbers/ratios are generally placed on the stem side of notes. When
tuplets are shown with a tuplet beam, a tuplet bracket is not always necessary but can be shown
in addition to a tuplet number/ratio.
According to convention, tuplet brackets and tuplet numbers/ratios are always placed above the
staff for vocal staves, so they do not come between notes and lyrics.
Tuplet brackets should be placed as close to notes as possible without colliding with other
notation, such as slurs or articulation. Slurs are usually placed inside tuplet brackets if the slur is
shorter than the tuplet bracket. If a slur is longer than a tuplet bracket, the slur can be placed
outside the tuplet bracket.
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The horizontal position of tuplet brackets should allow it to be immediately obvious which notes
are included in the bracket. They should not extend so far that notes following the tuplet appear
to be included.

A tuplet clearly showing the three quarter notes
included in the triplet.

With an extended tuplet bracket, the duration of the
triplet is now unclear.

Nested tuplets
Nested tuplets are tuplets within larger tuplets.
Nested tuplets can be used to create complex rhythms.
EXAMPLE

Nested tuplets

Inputting nested tuplets
You can input nested tuplets in new, empty staves and you can select existing tuplets and input
nested tuplets within them.
PROCEDURE
1.

In Write mode, start note input.

2.

Open the tuplets popover in any of the following ways:
●

Press ;.

●

Choose Write > Create Tuplet.

3.

Optional: If inputting nested tuplets in an empty staff, enter the ratio for the outer tuplet
into the popover. For example, 3:2.

4.

Optional: Press Return to close the popover and enter the outer tuplet.
NOTE
You can skip steps 3 and 4 if you are inputting nested tuplets into existing tuplets.

5.

Open the tuplets popover again.

6.

Enter the ratio for the inner tuplet into the popover. For example, 5:4.

7.

Press Return to close the popover and enter the inner tuplet.

8.

Enter or play in the pitches you want.

9.

Stop inputting tuplets in one of the following ways:
●

Press Shift-; to return to inputting normal notes.

●

Press Esc to stop note input completely.

●

Move the caret with the arrow keys to return to inputting normal notes.
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RESULT
The pitches you enter or play in are input as nested tuplets, starting from the caret position.
If multiples of the inner tuplet fit exactly inside the outer tuplet, you can continue inputting notes
as the specified nested tuplet until you stop the tuplets manually.
If multiples of the inner tuplet do not fit exactly inside the outer tuplet, the inner tuplet stops
automatically at the end of the last tuplet that fits in the outer tuplet. After that, the outer tuplet
continues until you stop it manually.
NOTE
You can also input nested triplets by clicking Tuplets in the Notes toolbox when the caret is
within an existing tuplet. However, you can only input one nested triplet at a time this way.

Notations on tuplet notes
You can add notations such as accidentals, articulations, and slurs to tuplets in the same ways as
they can be added to normal notes.
Articulations are positioned between noteheads or stems and tuplet brackets, so they are closer
to the notes than tuplet brackets or tuplet numbers/ratios.
RELATED LINKS
Inputting accidentals on page 135
Inputting articulations on page 141
Inputting slurs on page 208

Moving tuplets rhythmically
You can move tuplets to different rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the tuplets you want to move.
NOTE
A tuplet number/ratio or bracket must be included in the selection if you want the notes to
stay a tuplet. If a tuplet number/ratio or tuplet bracket is not selected, the notes become
normal notes of their rhythmic value when you move them beyond the position of the
tuplet.

2.

Move the selected tuplets in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

NOTE
You cannot move tuplets rhythmically using the mouse.

RESULT
The selected tuplets move to the right/left along the staff according to the current rhythmic grid
value.
If a tuplet number/ratio or tuplet bracket is included in the selection, the whole tuplet is moved
along the staff. If it crosses a barline, the tuplet is automatically adjusted to compensate.
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NOTE
●

If any of your selected notes collide with other notes in the same staff and at the same
rhythmic position that are in the same voice as your selected notes, the existing notes are
deleted and replaced with your selected notes.
You can undo moving notes immediately afterward, which restores any notes deleted in
the process.

●

Tuplets are not automatically adjusted at the mid-point of bars, where it is convention to
split tuplets to show the beat division. You must enter two tuplets manually to show the
beat division at the mid-point of bars.

EXAMPLE

Deleting tuplets
You can delete tuplets, including all the tuplet notes, but you can also delete tuplet brackets and
numbers/ratios without deleting the corresponding notes.
PROCEDURE
1.

In Write mode, select the tuplets you want to delete.
TIP
To delete an entire tuplet and all the notes within it, select all the noteheads and the
corresponding tuplet bracket or tuplet number/ratio.

2.

Delete the tuplets in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete. You can also choose this option from the context menu.

RESULT
The selected tuplets are deleted.
Selecting just the notes deletes the notes, but does not delete the tuplet.
Selecting just the tuplet bracket or tuplet number/ratio deletes the tuplet, and the notes that
were previously within the tuplet are retained with the same notated duration. For example,
deleting the bracket from triplet quarter notes leaves the notes previously in the triplet as three
quarter notes.
NOTE
This overrides existing notes immediately after the tuplet.
However, if Insert mode is activated, any subsequent existing notes are pushed to later rhythmic
positions to accommodate the extra rhythmic durations required.
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Tuplet beams
Tuplet beams join notes in tuplets that can be joined with beams just like non-tuplet beams. You
can make the same changes to tuplet beams that you can make to any other beam.
RELATED LINKS
Beaming on page 403
Tuplets within beams on page 415
Beaming notes together manually on page 404
Unbeaming notes on page 406
Splitting beam groups on page 405
Changing the direction of partial beams on page 405
Changing beam slants on page 408

Tuplet brackets
Tuplet brackets show the duration of tuplets that are not joined by beams, such as triplet quarter
notes, by showing the notes within the tuplet under a bracket.
You can change the precise positions and shapes of tuplet brackets individually in Engrave mode.
Each tuplet bracket has four handles that can be moved graphically.

The two upper handles set the position of the start/end of the tuplet bracket. These handles can
be moved independently of each other to create angled tuplet brackets, even if you have set
tuplet brackets to be Always horizontal on the Tuplets page in Engrave > Engraving Options.
The two lower handles set the length of the tuplet bracket hooks. Moving either of these handles
changes the length of both hooks.
RELATED LINKS
Moving tuplet numbers/ratios and brackets graphically on page 775
Changing the angles of tuplet brackets on page 777

Moving tuplet numbers/ratios and brackets graphically
You can move tuplet numbers/ratios and tuplet brackets graphically without changing the
rhythmic positions to which they apply. You can also move the start/end handles of tuplet
brackets independently of each other, meaning you can lengthen/shorten tuplet brackets
graphically.
PROCEDURE
1.

2.

In Engrave mode, select any of the following that you want to move:
●

Tuplet numbers/ratios

●

Whole tuplet brackets

●

Individual handles on tuplet brackets

Move the tuplet brackets, tuplet numbers/ratios, or handles in any of the following ways:
●

Press Alt-Right Arrow to move handles to the right.

●

Press Alt-Left Arrow to move handles to the left.

●

Press Alt-Up Arrow to move handles, whole brackets, and tuplet numbers/ratios
upwards.
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●

Press Alt-Down Arrow to move handles, whole brackets, and tuplet numbers/ratios
downwards.
TIP
If you want to move tuplet brackets, tuplet numbers/ratios, or handles by larger
increments, you can press Ctrl/Cmd as well as the standard key command, for
example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag whole tuplet brackets or tuplet numbers/ratios upwards/downwards.

●

Click and drag handles on tuplet brackets in any direction.

RESULT
The selected tuplet brackets or tuplet numbers/ratios are moved to new graphical positions,
without changing the rhythmic positions to which they apply.
TIP
The following properties in the Tuplets group of the Properties panel are activated automatically
when you move the corresponding part of tuplet brackets:
●

Start offset moves the start of tuplet brackets. X moves them horizontally, Y moves them
vertically.

●

End offset moves the end of tuplet brackets. X moves them horizontally, Y moves them
vertically.

●

Hook length changes the length of tuplet bracket hooks.

For example, if you move a whole tuplet bracket, both handles are moved, so Start offset and
End offset are both activated. You can also use these properties to move tuplet brackets and
tuplet numbers/ratios graphically by changing the values in the value fields.
As you can change values for the properties for the start/end of tuplet brackets independently,
you can also use the properties to change the angles of tuplet brackets.
Deactivating the properties resets tuplet brackets to their default positions.

Hiding/Showing tuplet brackets
You can hide/show tuplet brackets independently of tuplet numbers/ratios.
PROCEDURE
1.

Select the tuplet brackets you want to hide/show. You can do this in Write mode and
Engrave mode.

2.

In the Properties panel, activate Bracket in the Tuplets group.

3.

Choose one of the following options:
●

Hidden

●

Shown
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Changing the angles of tuplet brackets
You can change the angles of individual tuplet brackets by moving the square handles on each
corner of tuplet brackets to new graphical positions independently.
PROCEDURE
1.

2.

In Engrave mode, select one of the following handles on the tuplet brackets whose angle
you want to change:
●

The start corner handle

●

The end corner handle

Move the handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●
3.

Click and drag them in any direction.

Optional: Repeat steps 1 and 2 for the other corner handle on the tuplet brackets whose
angle you want to change.

RELATED LINKS
Moving tuplet numbers/ratios and brackets graphically on page 775
Forcing tuplet brackets to be horizontal on page 779
Tuplet brackets on page 775

Changing the placement of tuplet brackets relative to the staff
You can change the placement of individual tuplet brackets and tuplet numbers/ratios relative to
the staff.
PROCEDURE
1.

Select the tuplet brackets and tuplet numbers/ratios whose placement relative to the staff
you want to change. You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Placement in the Tuplets group.

3.

Choose one of the following options:
●

Above

●

Below

●

Cross-stave above

●

Cross-stave below
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RESULT
The placement of the selected tuplet brackets is changed.
TIP
●

Deactivating Placement returns the selected tuplets to their default placement.

●

You can change the placement of all tuplet brackets relative to vocal staves project-wide in
the Placement section of the Tuplets page in Engrave > Engraving Options.

Changing the rhythmic end positions of tuplet brackets
You can change the rhythmic end positions of tuplet brackets relative to individual notes
individually.
PROCEDURE
1.

Select the tuplet brackets whose end positions you want to change. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate End position in the Tuplets group.

3.

Select one of the following options:
●

End at right-hand side of final note

●

End immediately before following note

●

End at position of final tuplet division

RESULT
The end position for the selected tuplet brackets is changed.
TIP
●

Deactivating the property returns the selected tuplets to your default settings.

●

You can change the horizontal position of tuplet numbers/ratios on all tuplets project-wide
in the Horizontal Position section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Changing the angles of tuplet brackets on page 777
Project-wide engraving options for tuplets on page 781
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Forcing tuplet brackets to be horizontal
You can change the angle of individual tuplet brackets so that they appear horizontal,
independently of your project-wide setting.
PROCEDURE
1.

Select the tuplet brackets whose angle you want to change. You can do this in Write mode
and Engrave mode.

2.

In the Properties panel, activate Force horizontal in the Tuplets group.

RESULT
The selected tuplet brackets appear horizontal when the property is activated. When the
property is deactivated, the selected tuplet brackets follow your project-wide setting for angled
tuplet brackets.
TIP
You can change whether all tuplet brackets can appear angled or always appear horizontal
project-wide in the Brackets section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Project-wide engraving options for tuplets on page 781
Changing the angles of tuplet brackets on page 777

Tuplet numbers/ratios
Tuplet numbers and ratios are very similar: both indicate the number of equal notes included in
the tuplet, such as 3 for triplets, but tuplet ratios also include the number of normal notes into
whose duration the tuplet fits, such as 3:2 for triplets.
Additionally, tuplet ratios can include a note that indicates the duration of notes in the tuplet.

A triplet with a ratio and note value indication

Tuplet numbers/ratios help performers quickly identify the type of tuplet and how they must fit
the number of notes indicated into the prevailing tempo and meter.
In Dorico, you can change the appearance of all tuplet numbers/ratios project-wide on the
Tuplets page in Engrave > Engraving Options, and for individual tuplets independently of this
setting.
RELATED LINKS
Project-wide engraving options for tuplets on page 781

Changing the appearance of tuplet numbers/ratios
You can change which type of tuplet number/ratio is shown for individual tuplets, independently
of your project-wide setting.
PROCEDURE
1.

Select the tuplet brackets of the tuplets whose type of tuplet number/ratio you want to
change. You can do this in Write mode and Engrave mode.
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NOTE
The Tuplets group of the Properties panel is only shown if you select tuplet brackets. It is
not shown if you select notes within the tuplet, or notes within the tuplet and the tuplet
bracket.
2.

In the Properties panel, activate Number in the Tuplets group.

3.

Choose one of the following options:
●

None

●

Number

●

Ratio

●

Ratio+note

RESULT
The tuplet number/ratio shown for the selected tuplets is changed.
TIP
●

Deactivating Number returns the selected tuplets to the default setting.

●

You can change which tuplet number/ratio appears on all tuplets project-wide in the
Number and Ratio section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Tuplet numbers/ratios on page 779
Project-wide engraving options for tuplets on page 781

Changing the position of tuplet numbers/ratios
You can change the horizontal positions of tuplet numbers and ratios in individual tuplet
brackets, independently of your project-wide setting.
PROCEDURE
1.

Select the tuplet brackets whose tuplet number/ratio positions you want to change. You
can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Center in the Tuplets group.

3.

Select one of the following options:
●

Visual
Positions tuplet numbers/ratios at the visual center of the tuplet beam or tuplet
bracket.

●

Rhythmic
Positions tuplet numbers/ratios at the rhythmic center of the tuplet beam or tuplet
bracket, which might be visually off-center.
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RESULT
The position of the tuplet numbers/ratios for the selected tuplets is changed.
TIP
●

Deactivating the property returns tuplets to your project-wide setting.

●

You can change the horizontal position of tuplet numbers/ratios on all tuplets project-wide
in the Number and Ratio section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Tuplet brackets on page 775
Changing the angles of tuplet brackets on page 777

Project-wide engraving options for tuplets
You can find options for the project-wide appearance of tuplets, tuplet brackets, and tuplet
numbers/ratios on the Tuplets page in Engraving Options.
The options on the Tuplets page allow you to change the appearance and angles of tuplet
brackets, and the position of tuplet brackets, tuplet numbers/ratios relative to the staff and
noteheads.
There are musical examples for many options to demonstrate how they affect the appearance of
your music.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Tuplets in the page list on the left of the dialog.
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The term “unpitched percussion” covers all percussion instruments that are not tuned to specific
pitches. This includes instruments such as bass drum, guiro, maracas, cymbals, and shakers.
Dorico provides comprehensive support for unpitched percussion notation, with flexible options
for combining music for multiple instruments into percussion kits that can then be displayed
differently in different layouts. You can also define percussion kits as drum sets, which changes
the default stem directions of notes.
The different percussion kit presentation types in Dorico are layout-specific, meaning you can
present percussion kits in different ways in different layouts. For example, you could present a
percussion kit as a five-line staff in the full score layout but with single-line instruments in the
percussion part layout.
You can also customize and create new playing technique-specific noteheads for unpitched
percussion. This allows you to indicate how notes are played by using different noteheads for
different playing techniques on each instrument in percussion kits.
RELATED LINKS
Percussion kits on page 783
Defining percussion kits as drum sets on page 81
Inputting notes in percussion kits on page 121
Percussion kits vs. individual percussion instruments on page 782
Percussion kit presentation types on page 788
Playing techniques for unpitched percussion instruments on page 790
Staff labels for percussion kits on page 698

Percussion kits vs. individual percussion instruments
Percussion kits allow you to show multiple unpitched percussion instruments held by a single
player at the same time in different ways. Multiple percussion instruments not combined into kits
are shown on a single line that only shows the instrument currently being played by default.
One common type of percussion kit is a drum set. A drum set consists of a number of separate
instruments mounted together on a frame, and is typically written on a regular five-line staff.
Each instrument has its own position on the staff, and sometimes its own notehead type.
Similarly, a pair of bongos is a percussion kit by default in Dorico, consisting of the two bongo
drums, typically written on a grid with two lines: the smaller drum shown on the top line, and the
larger drum shown on the bottom line.
Showing individual percussion instruments separately can be appropriate if a player only has one
or two percussion instruments. However, combining percussion instruments into a kit gives you
more flexibility over the presentation of music, which you can vary in each layout independently.
Kits also give you greater control over the labelling of instruments.
If instrument changes are enabled on the Players page in Setup > Layout Options, Dorico
changes from one instrument to the next, just as it does for pitched instruments.
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NOTE
Kit instruments in player cards in the Players panel in Setup mode are colored green, whereas
individual percussion instruments not part of percussion kits are colored the same light blue as
all other instruments.

RELATED LINKS
Percussion kits on page 783

Percussion kits
A percussion kit is a collection of unpitched percussion instruments that are played by a single
player. Drum sets are a particular type of percussion kit that are often used in pop and rock
music.
In Dorico, you can present percussion kits in different ways, including as a five-line staff and as a
grid. If you want percussion kits to behave as drum sets, you can define them as drum sets.
You can create percussion kits in Setup mode. You can combine existing unpitched percussion
instruments into kits and add empty kits to players, to which you can then add unpitched
percussion instruments. You can also import existing kits you have previously exported and
saved.
You can move percussion instruments between players, without affecting any music already
added to that instrument.
NOTE
If the instrument you want to move is combined into a percussion kit, you must first remove the
instrument from the kit before you can move it to another player.
You can change individual percussion instruments like any other instrument. However, you can
only change unpitched percussion instruments to other unpitched percussion instruments, and
you can only change the percussion instruments in kits within the Edit Percussion Kit dialog.
RELATED LINKS
Percussion kit presentation types on page 788
Edit Percussion Kit dialog on page 77
Combining individual percussion instruments into kits on page 75
Adding instruments to percussion kits on page 80
Importing percussion kits on page 784
Removing individual instruments from percussion kits on page 85
Moving instruments between players on page 76
Staff labels for percussion kits on page 698
Defining percussion kits as drum sets on page 81

Exporting percussion kits
You can export percussion kits as library files. This allows you to use kits again without having to
create them from scratch.
PROCEDURE
1.

In the Players panel in Setup mode, expand the card of the player whose percussion kit
you want to export.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
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The Edit Percussion Kit dialog opens.
3.

Click Export Kit at the bottom of the dialog.
The File Explorer/macOS Finder dialog opens.

4.

In the File Explorer/macOS Finder dialog, specify a name and location for the library file.

5.

Click Save.

RESULT
The kit is exported and saved as a library file.
NOTE
You can later import the library file into other projects to reuse the percussion kit.

Importing percussion kits
You can import library files containing percussion kits, which allows you to use kits again without
having to create them from scratch.
PREREQUISITE
You have added a new solo player in the Players panel in Setup mode.
PROCEDURE
1.

2.

In Setup mode, open the instrument picker for your empty solo player in any of the
following ways:
●

Select the empty player and press Shift-I.

●

Click the plus symbol in the empty player card.

●

Right-click the empty player and choose Add Instrument to Player from the
context menu.

Click Import Kit in the instrument picker.
The File Explorer/macOS Finder dialog opens.

3.

In the File Explorer/macOS Finder dialog, locate and select the percussion kit library file
you want to import.

4.

Click Open.

RESULT
The selected library file is imported as a percussion kit. It is assigned to the player from whose
card you opened the instrument picker.
RELATED LINKS
Exporting percussion kits on page 783

Project-wide engraving options for unpitched percussion
You can find options for the project-wide appearance and position of percussion legends and
ghost notes on the Percussion page in Engraving Options.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.
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You can then click Percussion in the page list on the left of the dialog.

Per-flow notation options for unpitched percussion
You can find options for how notes in percussion kits are notated project-wide on the Percussion
page in Notation Options.
For example, you can choose to notate all notes in a percussion kit in a single voice rather than in
multiple voices.
You can open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

●

Click Notation Options on the right of the Flows panel in Setup mode.

You can then select Percussion from the Category menu.

Changing the playing techniques of notes on percussion kit
staves
For notes on percussion kit staves that use playing technique-specific noteheads to indicate
different playing techniques, you can change their playing techniques after they have been input
by cycling through the available playing technique-specific noteheads.
PREREQUISITE
The percussion kit instruments whose playing techniques you want to change have at least two
playing technique-specific noteheads defined in the Percussion Instrument Playing
Techniques dialog.
NOTE
This only applies to changing playing technique-specific noteheads.

PROCEDURE
1.

In Write mode, select the notes whose playing technique-specific notehead you want to
change.
NOTE
The current playing technique is shown above the rhythmic grid if you select a single note.
It is not shown if you select multiple notes.

2.

Cycle through the available playing techniques for the selected instruments in any of the
following ways:
●

Press Shift-Alt-Up Arrow to cycle upwards.

●

Press Shift-Alt-Down Arrow to cycle downwards.

RESULT
The playing techniques of the selected notes are changed. Their notehead design and/or position
might be changed.
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RELATED LINKS
Percussion Instrument Playing Techniques dialog on page 790
Inputting notes in percussion kits on page 121
Defining how combinations of articulations and single-note tremolos sound in playback on page
334
Playing techniques on page 633

Showing notes in percussion instruments as ghost notes
You can show notes in percussion instruments as ghost notes. Ghost notes are shown in
parentheses.
PROCEDURE
1.

Select the unpitched percussion notes that you want to show as ghost notes. You can do
this in Write mode and Engrave mode.

2.

In the Properties panel, activate Ghost note in the Notes and Rests group.

RESULT
The noteheads of the selected notes are shown in parentheses.

Moving notes to different instruments in percussion kits
You can move notes to different instruments in the same percussion kit after they have been
input, except in layouts using the single-line instruments kit presentation type.
In layouts using the single-line instruments kit presentation type, you can instead cross notes to
other staves to create cross-staff beams.
PROCEDURE
1.

In Write mode, select the notes you want to move to a different instrument in the
percussion kit.

2.

Move the notes to another instrument in any of the following ways:
●

Press Alt-Up Arrow to move them to the instrument above.

●

Press Alt-Down Arrow to move them to the instrument below.

NOTE
You can change the positions of instruments in the kit in the Edit Percussion Kit dialog for
that percussion kit.

RESULT
The notes are moved to another instrument in the kit.
RELATED LINKS
Edit Percussion Kit dialog on page 77
Changing the positions of instruments within percussion kits on page 84
Percussion kit presentation types on page 788
Changing the presentation type of percussion kits on page 789
Creating cross-staff beams on page 411
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Notations on notes in percussion kits
You can add notations to notes and use different rhythms in percussion kits in the same ways as
for normal notes, however, they can behave differently.

Articulations
You can add articulations to percussion instruments in all kit presentation types in the same ways
as for other instruments.
However, in grid and five-line staff presentations, any articulations you add apply to all
instruments in the same voice that have notes at that rhythmic position. For example, if both a
snare drum and tom-tom note are at the same rhythmic position, and you add an accent, the
accent is added to both instruments because they are both shown in the same down-stem voice
by default.
You can see the accent applied to each note if you switch to the single-line instruments
presentation type.

Tuplets
When working in the grid and five-line staff kit presentation types, tuplets are added to all
instruments in the same voice.
You can switch to the single-line instruments presentation type to input cross-rhythms on each
instrument separately. When you switch back to the grid or five-line staff kit presentation types,
Dorico attempts to resolve the rhythmic conflicts.
●

Conflicting tuplets: One tuplet is moved into an extra voice for the duration of the conflict.

●

Tuplet notes in one instrument and non-tuplet notes in another instrument starting at the
same rhythmic position: The non-tuplet note is displayed as if it were part of the tuplet.
This is because the note onset is at the same position as the start of the tuplet, so it
sounds the same as the original notation.

●

Tuplet notes in one instrument and non-tuplet notes in another instrument that do not
start at the same rhythmic position, or other non-tuplet notes that start part-way through
the tuplet: Non-tuplet notes are moved into an extra voice for the duration of the conflict.
NOTE
Deleting a tuplet from grid and five-line staff kit presentation types deletes the tuplet from
all instruments whose notes contribute to the same shared voice.

Playing techniques
You can input playing techniques, such as + for closed and o for open hi-hat, during step input
and add them later to existing notes in the same ways as for other instruments. You can use the
playing techniques popover or click any of the playing techniques in the Playing Techniques
panel in Write mode.
Playing techniques are only added to the instrument to which the note you select belongs, even
if there are other instruments in the same voice.

Percussion stickings
Dorico does not yet have a dedicated feature for percussion stickings. However, you can use
lyrics to represent percussion stickings in all kit presentation types:
●

Grid/Five-line staff presentation types: Select a note in the instrument in which you want to
show stickings.

●

Single-line instruments presentation type: Input lyrics directly into instruments in which
you want to show stickings.

787

Unpitched percussion
Percussion kit presentation types
RELATED LINKS
Inputting articulations on page 141
Inputting tuplets on page 131
Changing the pitch of individual notes on page 138
Input methods for playing techniques on page 196
Inputting lyrics on page 200

Dynamics in percussion kits
Unlike other items, dynamics are not shared between the grid/five-line staff presentation types
and the single-line instruments presentation type. Any dynamics added to instruments in the
single-line instruments presentation type do not appear when you switch to grid/five-line
presentations.
This is due to the complexity of combining a large number of different dynamics at the same
rhythmic position, as allowed in the single-line instruments presentation, into the single position
required for both the grid and five-line staff presentations. Therefore, you can add dynamics in
the grid and five-line staff presentation types independently of the single-line instruments
presentation type.
RELATED LINKS
Input methods for dynamics on page 161

Percussion kit presentation types
You can show percussion kits in three different presentation types, which can be different in each
layout in your project.
NOTE
Dynamics are not shared between the grid/five-line staff presentation types and the single-line
instruments presentation type. Any dynamics added to instruments in the single-line
instruments presentation type do not appear when you switch to grid/five-line presentations.
You can edit the appearance/structure of each presentation type independently in the Edit
Percussion Kit dialog. For example, changing the order of instruments in the five-line staff
presentation does not affect the order of instruments in the grid presentation of the same
percussion kit.
5-line staff
Kit instruments are shown on a five-line staff. You can determine which instruments
are shown on each line and in each space of the staff. A single staff label containing
the name of the kit is shown.
The numbers down the left-hand side of the editing area in the Edit Percussion Kit
dialog correspond to staff positions. For example, position 0 is the middle line of the
five-line staff, position 1 is the space immediately above the middle staff line,
position -2 is the line below the middle staff line, and so on.
Bold black lines show the five staff lines, while gray lines above and below the staff
show nominal staff line positions. Each instrument is shown on its staff position.
Grid
Kit instruments are shown on a grid, with each instrument on its own line. You can
customize the size of the gaps between each line. Staff labels are shown for each
instrument in a smaller font than normal staff labels.
The numbers down the right-hand side of the editing area in the Edit Percussion Kit
dialog correspond to the number of staff spaces between each instrument line. By
default, all instruments in a grid are two spaces apart.
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The order in which the instruments are listed matches the order in which they
appear in the score.
Each instrument in a grid shows its own staff label by default, aligned vertically with
its own line, but you can group adjacent instruments together and show a single
label for each group.
Single-line instruments
Kit instruments are shown as individual instruments with their own lines. Normalsized staff labels are shown for each instrument.
The editing area in the Edit Percussion Kit dialog lists all of the instruments in the
order in which they appear in the score.

5-line staff presentation

Grid presentation

Single-line instruments
presentation

Multiple instruments held by the same player are vertically spaced according to the ideal gaps
defined on the Vertical Spacing page in Setup > Layout Options.
RELATED LINKS
Edit Percussion Kit dialog on page 77
Changing the presentation type of percussion kits on page 789
Staff labels for percussion kits on page 698

Changing the presentation type of percussion kits
You can change the presentation type of percussion kits in each layout independently of other
layouts and independently of each other. For example, you can use a five-line staff in the full
score layout but a grid in the percussion part layout, and have two percussion kits with different
presentation types in the same full score layout.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.
The Layout Options dialog opens.

2.

In the Layouts list, select the layouts in which you want to change the percussion kit
presentation type in one of the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl/Cmd-click individual layouts.

●

Shift-click adjacent layouts.

By default, the layout currently open in the music area is selected when you open the
dialog.
3.

Select Players from the Category menu.
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4.

5.

In the Percussion section, choose one of the following options for each percussion kit in
your project:
●

5-line Staff

●

Grid

●

Single-line Instruments

Click Apply, then Close.

RESULT
The presentation type is changed for the selected percussion kits in the selected layouts.
RELATED LINKS
Percussion kit presentation types on page 788

Playing techniques for unpitched percussion instruments
As well as using normal playing techniques on notes in percussion kits, you can use the design
and position of noteheads to indicate different playing techniques for unpitched percussion
instruments and percussion kits.
You can indicate playing techniques for unpitched percussion instruments in any of the following
ways:
●

Use playing technique-specific noteheads

●

Position notes in spaces directly above/below the line on which notes are normally written

●

Add articulations or single-note tremolos

●

Add playing techniques in the same ways as for pitched instruments

For example, you can add open and closed techniques for hi-hats using the playing techniques
popover, or by clicking the playing techniques you want in the Playing Techniques panel.
You can edit the set of playing technique-specific noteheads defined for each percussion
instrument in the Percussion Instrument Playing Techniques dialog.
RELATED LINKS
Percussion Instrument Playing Techniques dialog on page 790
Edit Percussion Kit dialog on page 77
Defining how combinations of articulations and single-note tremolos sound in playback on page
334
Exporting percussion kits on page 783
Importing percussion kits on page 784
Input methods for playing techniques on page 196

Percussion Instrument Playing Techniques dialog
You can edit the set of playing technique-specific noteheads defined for each percussion
instrument in the Percussion Instrument Playing Techniques dialog.
You can open the Percussion Instrument Playing Techniques dialog in Setup mode in the
following ways:
●

For an individual percussion instrument: Expand the card of the player holding the
instrument in the Players panel, click the arrow in the instrument label, and choose Edit
Percussion Playing Techniques.

●

For percussion instruments that are part of percussion kits: Open the Edit Percussion Kit
dialog by clicking the arrow in the kit instrument label in the Players panel, select the
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instrument whose playing techniques you want to edit in the main editing area, and click
Edit Percussion Playing Techniques.

Percussion Instrument Playing Techniques dialog

1

List of playing technique-specific noteheads
Contains the main playing technique-specific noteheads currently defined for the selected
percussion instrument, showing the notehead set and the staff position corresponding to
the playing technique as applicable.
You can add new playing technique-specific noteheads for unpitched percussion
instruments. Normally, percussion instruments define at least the Natural playing
technique, which is usually shown using the default notehead set.

2

Playback of Articulations and Tremolos
Allows you to define how combinations of articulations and tremolo strokes affect or
override the playback of playing techniques.
For example, you can define an entirely different playing technique for a playing
technique-specific notehead for when an accent is added to it.

3

Overrides of articulations and tremolos list
Displays any overrides of articulations and tremolos you define.

EXAMPLE

Three different snare drum playing technique-specific noteheads followed by two clash cymbal playing
technique-specific noteheads

All of these settings are saved in the percussion instrument within your project, and you can
export them from one project and import them into others.
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NOTE
Overrides for articulations and tremolos are not currently reflected in playback, but this is
planned for future versions.

RELATED LINKS
Creating new playing technique-specific noteheads for unpitched percussion instruments on
page 792
Overriding the appearance of playing technique-specific noteheads on page 793
Defining how combinations of articulations and single-note tremolos sound in playback on page
334
Exporting percussion kits on page 783
Importing percussion kits on page 784

Creating new playing technique-specific noteheads for unpitched
percussion instruments
You can define new playing technique-specific noteheads for unpitched percussion instruments
individually, which are saved for that type of percussion instrument in your project. You can also
export playing technique-specific noteheads from your project and import them into other
projects.
PROCEDURE
1.

In Setup mode, open the Percussion Instrument Playing Techniques dialog in one of the
following ways:
●

For an individual percussion instrument: Expand the card of the player holding the
instrument in the Players panel, click the arrow in the instrument label, and choose
Edit Percussion Playing Techniques.

●

For percussion instruments that are part of percussion kits: Open the Edit
Percussion Kit dialog by clicking the arrow in the kit instrument label in the Players
panel, select the instrument whose playing techniques you want to edit in the main
editing area, and click Edit Percussion Playing Techniques.

2.

Click Add Playing Technique.

3.

Select the playing technique you want to create in the dialog that opens.

4.

Click OK.
The selected playing technique is added to the list of playing technique-specific noteheads.

5.

Select the notehead you want for the playing technique from the Notehead set menu.
NOTE
Leave Notehead set as (Unset) to use the default notehead set as defined on the Notes
page in Engrave > Engraving Options.

6.

Choose one of the following options for Staff position:
●

Below

●

Line

●

Above

RESULT
A new playing technique-specific notehead is added to the selected unpitched percussion
instrument.
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RELATED LINKS
Input methods for playing techniques on page 196
Defining how combinations of articulations and single-note tremolos sound in playback on page
334

Overriding the appearance of playing technique-specific noteheads
It might be necessary to override the appearance of playing technique-specific noteheads in
order to disambiguate the notes for one instrument from another if they share a staff position in
five-line staff kit presentations.
PROCEDURE
1.

In the Players panel in Setup mode, expand the card of the player holding the kit whose
playing technique-specific noteheads you want to override.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
The Edit Percussion Kit dialog opens.

3.

Select the instrument whose noteheads you want to override in the main editing area of
the dialog.

4.

Click Edit Noteheads.
The Override Percussion Noteheads dialog opens. It lists the playing technique-specific
noteheads defined for the selected instrument in the Percussion Instrument Playing
Techniques dialog, and shows which notehead type is mapped for each technique.

Override Percussion Noteheads dialog for a snare drum

5.

Click in the Notehead Override column for the appropriate playing technique and select a
new notehead type from the menu to override its notehead.

6.

Click OK to save your changes and close the dialog.

RESULT
The playing technique-specific notehead is overridden for the selected instrument in five-line
staff kit presentations.
NOTE
This does not affect the appearance of playing technique-specific noteheads in grid and singleline instrument kit presentation types.

RELATED LINKS
Defining how combinations of articulations and single-note tremolos sound in playback on page
334
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Percussion legends
Percussion legends list the percussion instruments in use when using the five-line presentation
type. Percussion legends can include all instruments that are represented on the staff, or only
show sounding instruments in a set range to remind players which instruments to play at certain
points.
You can change the default position of percussion legends in the Percussion Legends section of
the Percussion page in Engrave > Engraving Options.
You can change the placement and appearance of percussion legends individually using
properties in the Percussion Legend group of the Properties panel.
You can change various aspects of the paragraph style for percussion legends, such as the font
size and style, in the Paragraph Styles dialog.
Percussion legends appear as signposts if there are no instruments sounding at their position, or
in layouts using the grid presentation type. Percussion legends do not appear at all in layouts
using the single-line instrument presentation type.
TIP
You can hide/show percussion legend signposts by choosing View > Signposts > Percussion
Legends. Percussion legend signposts are shown when a tick is shown beside Percussion
Legends in the menu, and hidden when no tick is shown.

RELATED LINKS
Adding percussion legends to five-line staff kit presentations on page 794
Paragraph Styles dialog on page 276
Project-wide engraving options for unpitched percussion on page 784
Per-flow notation options for unpitched percussion on page 785
Staff labels for percussion kits on page 698

Adding percussion legends to five-line staff kit presentations
You can add percussion legends at specific rhythmic positions to indicate the instruments in the
kit. Percussion legends can show all instruments in the kit or only instruments sounding within
the specified range.
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

An item on the staff at the rhythmic position where you want to add a percussion
legend for all instruments.

●

The range of notes/items for which you want to show a percussion legend for
sounding instruments.

Add a percussion legend in one of the following ways:
●

Choose Edit > Percussion > Legend for All Instruments.

●

Choose Edit > Percussion > Legend for Sounding Instruments.

TIP
You can also choose these options from the context menu.
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RESULT
A percussion legend is added above the staff. It lists instruments, either all instruments or just
instruments with notes within the selected range, in the order in which they appear in the fiveline staff, from highest down to lowest.

Changing the sounding instrument percussion legend range
You can change the rhythmic range of sounding instrument percussion legends to include more/
fewer instruments in the legend, as they only show the instruments playing at the rhythmic
positions included in the range.
PROCEDURE
1.

In Write mode, select the sounding instrument percussion legend whose range you want
to change.

2.

Change the range in any of the following ways, according to the current rhythmic grid
value:
●

Press Alt-Right Arrow to move the whole range to the right.

●

Press Alt-Left Arrow to move the whole range to the left.

●

Press Shift-Alt-Right Arrow to lengthen the range.

●

Press Shift-Alt-Left Arrow to shorten the range.
NOTE
When using the keyboard, you can only lengthen/shorten percussion legend ranges
by moving the end of the range. You can move the start of the range by moving the
whole range or by clicking and dragging the start handle.

●

Click and drag the circular handle at the start/end of the percussion legend to the
right/left.

RESULT
The rhythmic range covered by the selected sounding instrument percussion legend is changed
according to the current rhythmic grid value.
The instruments included in the percussion legend are automatically updated to reflect the
instruments playing within the range.

Changing the percussion legend type
You can change the type of percussion legends so they show all instruments or only sounding
instruments in five-line staff presentations.
PROCEDURE
1.

Select the percussion legends whose type you want to change. You can do this in Write
mode and Engrave mode.

2.

In the Properties panel, activate Legend Type in the Percussion Legend group.
NOTE
The property is already activated for sounding instrument percussion legends.

3.

Choose one of the following options:
●

Legend

●

Sounding Instruments
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RESULT
The legend type of the selected legends is changed.

Showing short instrument names in percussion legends
Percussion legends use full instrument names by default, but you can choose to use short names
to save space.
PROCEDURE
1.

Select the percussion legends whose instrument name lengths you want to change. You
can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Use short names in the Percussion Legend group.

RESULT
Short instrument names are shown in the selected percussion legends.
Deactivating Use short names returns the selected percussion legends to showing full
instrument names.
RELATED LINKS
Staff labels for percussion kits on page 698

Changing the text shown in percussion legends
By default, percussion legends show the instrument names of percussion instruments in five-line
staff presentations, stacked vertically. You can change the text shown in percussion legends to
show custom text.
PROCEDURE
1.

In Engrave mode, select the percussion legends whose text you want to change.

2.

In the Properties panel, activate Custom Text in the Percussion Legend group.

3.

Enter the text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The text shown in the selected percussion legends is changed.

Changing the placement of percussion legends relative to the staff
By default, percussion legends are shown above the staff but you can change their placement so
they are shown below the staff.
PROCEDURE
1.

Select the percussion legends whose placement relative to the staff you want to change.
You can do this in Write mode and Engrave mode.

2.

In the Properties panel, activate Placement in the Percussion Legend group.

3.

Choose one of the following options:
●

Above
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●

Below

RESULT
The selected percussion legends appear above/below the staff.
TIP
●

Deactivating Placement returns the selected percussion legends to their default
placement relative to the staff.

●

You can change the default distance between all percussion legends and other items
project-wide in the Percussion Legends section of the Percussion page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide engraving options for unpitched percussion on page 784
Per-flow notation options for unpitched percussion on page 785

Voices in percussion kits
Dorico automatically combines music into a smaller number of voices when multiple percussion
instruments are presented in a five-line staff or as a grid, even if they contain different rhythms.
By default, music is combined into one up-stem voice and one down-stem voice.
Alternatively, you can choose to notate all notes in a percussion kit in a single voice when the kit
is defined as a drum set on the Percussion page in Write > Notation Options. This convention is
used less frequently for orchestral percussion.
You can also override this option for individual percussion kits, and for individual notes in
percussion kits.
Notes in the same voice cannot be notated using different durations and are notated using ties
by default instead. You can eliminate the use of ties by choosing to truncate longer notes so that
only their onsets appear on the Percussion page in Notation Options.
If one of the instruments in a percussion kit has a tuplet rhythm, other instruments can share the
voice if their notation is compatible, such as if the tuplet structure is the same, or if they have a
single note that coincides with the start of the tuplet. In this case, the single non-tuplet note is
notated as the same duration of the first note of the tuplet.
If the music of the different instruments in the same voice is incompatible, Dorico dynamically
creates another voice and notates the remaining music in that voice until the music is compatible
again.
RELATED LINKS
Notations on notes in percussion kits on page 787
Notation Options dialog on page 110
Defining percussion kits as drum sets on page 81

Changing the voice of individual notes in percussion kits
You can override the default voice for individual notes in percussion kits, including drum sets.
PROCEDURE
1.

Select the notes whose voice you want to override. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Percussion > Change Voice > [Voice].
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For example, to change notes to the second down-stem voice, choose Edit > Percussion >
Change Voice > Down-stem Voice 2. You can also choose this option from the context
menu.
RESULT
The voice of the selected notes is changed, independently of the default voice for their
instrument and independently of your setting for voices in drum sets.
TIP
You can reset the voice of individual notes by selecting them and choosing Edit > Percussion >
Change Voice > Reset Note Destination Voice. You can also choose this option from the
context menu.

Specifying the stem direction/voice of instruments in percussion kits
You can specify the stem direction for each instrument in individual percussion kits. You can also
set which voice they are in, allowing you to control which instruments share voices in percussion
kits.
PROCEDURE
1.

In the Players panel in Setup mode, expand the card of the player holding the kit whose
instrument stem directions and voices you want to specify.

2.

Click the arrow that appears in the kit instrument label when you hover over it and choose
Edit Percussion Kit.
The Edit Percussion Kit dialog opens.

3.

In the dialog, select an instrument whose stem direction and voice you want to specify.

4.

Choose one of the following stem directions for Stem direction and voice:

5.

●

Up-stem

●

Down-stem

Specify a voice by changing the value for Stem direction and voice in any of the following
ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

NOTE
You do not have to change the voice number if you are switching between up- and downstem voices as the number corresponds to the voice number for each stem direction.
6.

Click Apply, then Close.

RESULT
The default stem direction and voice of the selected instrument is changed.
TIP
You can change the stem direction and voice of all instruments in the kit before closing the
dialog.
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Unpitched percussion in Play mode
Unpitched percussion instruments are handled differently in Play mode than pitched
instruments. Instead of showing the usual piano roll view, the onset of each note on each
percussion instrument is shown in the drum editor.
You can expand each instrument in a kit at the left end of the track header in order to assign that
particular instrument to another playback endpoint. For example, you can assign instruments to
another channel on the same VST instrument or MIDI output device, or to a different device.
NOTE
The endpoint must have an appropriate selected percussion map.
Notes can be moved in Play mode by dragging them to the rhythmic position you want. However,
like other instruments, you cannot move notes between percussion instruments, even if they are
in the same percussion kit.
NOTE
You cannot change the duration of unpitched percussion notes within Play mode. This is planned
for future versions.

RELATED LINKS
Percussion maps on page 329
Drum editor on page 307
Inputting notes in the drum editor on page 307
Moving notes in the piano roll editor on page 305
Transposing notes in the piano roll editor on page 305

Unpitched percussion imported from MIDI files
When importing MIDI files, Dorico optionally interprets music for tracks set to use channel 10 as
drum sets if Interpret channel 10 as General MIDI percussion is activated in the MIDI Import
Options dialog.
NOTE
The MIDI Import Options dialog opens automatically when you open MIDI files in Dorico.
This is the only condition under which Dorico interprets any music in MIDI files as percussion.

Unpitched percussion imported from MusicXML files
Unpitched percussion music can be expressed in a number of ways in MusicXML, and all scoring
applications take different approaches to what data is exported, and how it is encoded.
Therefore, the results of importing MusicXML into Dorico varies considerably.
Dorico identifies each instrument in kits explicitly, and then combines them dynamically onto
five-line staves. Other scoring applications and MusicXML have a different approach to how
unpitched percussion music is represented. For example, a drum set may be effectively notated
as pitched notes on a five-line staff, and annotated with additional information to help identify
which instrument corresponds to each staff position.
Because of these different approaches, mapping information between the MusicXML
representation and the Dorico representation can be challenging, so Dorico employs heuristics
to improve the quality of results.
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Typically, drum set instruments in MusicXML files exported from both Sibelius and Finale are
imported quite cleanly into Dorico.
Results are particularly good, and more likely to be imported correctly, if the voicing of the drum
set is consistent, such as consistently notating the snare drum in a down-stem voice. If the
voicing changes from bar to bar, it is possible that some notes are not identified correctly, or not
imported at all.
Other kinds of percussion that are notated on five-line staves produce more variable results. In
most cases, Finale includes information about which percussion instrument maps onto each staff
position, but Sibelius does not. As a result, you might find that Dorico chooses different
instruments than you expected, but you can change instruments using the Edit Percussion Kit
dialog.
RELATED LINKS
Edit Percussion Kit dialog on page 77
Changing instruments in percussion kits on page 80
Adding instruments to percussion kits on page 80

Universal Indian Drum Notation
Dorico supports the Universal Indian Drum Notation system developed by Keda Music Ltd.
Universal Indian Drum Notation has been designed primarily for tabla, but can also be applied to
other Indian drums with two heads, such as nagara, dhol, dholak, mridangam, and pakhawaj.
An Indian drum clef is automatically added to the staff when you add tabla instruments to
players.

You can input Indian drum clefs by clicking Indian drum clef in the Uncommon Clefs section of
the Clefs panel.
RELATED LINKS
Adding instruments to players on page 73
Input methods for clefs and octave lines on page 175
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For many instruments, such as flute or trombone, each staff usually contains a single musical line
in a single voice that is read from left to right along the staff. When multiple, independent lines
must be shown in a single staff, each line can have its own voice.
The most common use for showing multiple voices in a single staff is in vocal music, when the
soprano and alto lines share a single staff and the tenor and bass lines share another staff.
Showing each vocal line in its own voice helps to separate the lines, making the music easier to
read and making the shape of each melodic line clear.
In Dorico, you can create as many voices as you like on each staff. Each voice has its own color,
which you can see if you show voice colors. This can help you to keep track of which notes are in
which voices if there are multiple overlapping musical lines in your project.
Voices in Dorico are divided into up-stem voices and down-stem voices. Stems of notes in upstem voices point upwards, while stems of notes in down-stem voices point downwards.
However, in bars where only one voice contains notes, stem directions are automatically changed
to the directions they would have if there were only one voice on the staff. By default, the first
voice on the staff is up-stem.
Following most notation conventions, rests are shown in bars for all voices that have notes in the
bar. If two or more voices have a rest of the same rhythmic duration at the same rhythmic
position, that rest is consolidated: instead of showing two identical rests, only one is shown.
RELATED LINKS
Inputting notes into multiple voices on page 118
Showing voice colors on page 803
Stem direction on page 711
Per-flow notation options for voices on page 802
Per-flow notation options for rests on page 658
Adding notes above/below existing notes on page 133
Implicit rests in multiple-voice contexts on page 807
Moving individual rests vertically on page 661

Note positions in multiple-voice contexts
Notes are usually placed directly above each other and at the same horizontal position, so that it
is immediately clear which notes are played together. However, the horizontal alignment of
notes can be different in multiple-voice contexts.
When there are three or more voices in a single staff, some notes must be positioned slightly to
one side in a different voice column to ensure the division of notes across the voices is clear.
Interlocking notes in different voices can be positioned in two ways:
1.

Notehead to notehead, which allows noteheads to overlap partially. This voice order often
takes up less horizontal space than positioning notes stem to stem, as notes can overlap.
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2.

Stem to stem, which does not allow noteheads to overlap. This voice order keeps notes in
different voices separate.

You can choose how interlocking notes in different voices are positioned project-wide on the
Voices page in Write > Notation Options.
Dorico positions notes by default with the noteheads partially overlapping, in order to minimize
the horizontal space they occupy and maintain the clarity of the rhythm.
The order and position of notes in different voices is also automatically adjusted so that each
rhythmic position uses as little horizontal space as possible, while remaining clear and legible.
The voice column for some voices automatically changes as more voices are added, as Dorico
prefers showing voices with the widest pitch range between them on the left of the rhythmic
position and voices with narrower pitch ranges to the right, as this produces the most balanced
result, especially when there are multiple accidentals.

One voice

Two voices vertically Three voices all still
aligned
vertically aligned

Four voices with
two voice columns

Five voices with two
voice columns

RELATED LINKS
Per-flow notation options for voices on page 802

Per-flow notation options for voices
There are a number of options for how notes in multiple voices are positioned project-wide on
the Voices page in Notation Options.
The options on this page allow you to change the position and order of notes in multiple-voice
contexts, and choose when noteheads in different voices can overlap.
Musical examples demonstrate how each option affects the appearance of your music.
You can open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

●

Click Notation Options on the right of the Flows panel in Setup mode.

You can then select Voices from the Category menu.
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Showing voice colors
You can show notes in different colors according to their voice, for example, to check which notes
are in which voice.
PROCEDURE
●

Choose View > Note and Rest Colors > Voice Colors.
●

A tick is shown beside Voice Colors in the menu when voice colors are shown.

●

No tick is shown beside Voice Colors in the menu when voice colors are not shown.

RESULT
Noteheads appear with colors according to their voice. Colors are randomly assigned, meaning
colors do not refer to specific voices.
EXAMPLE

Voice colors shown

AFTER COMPLETING THIS TASK
If showing voice colors reveals some notes are not in the voice you want, you can change their
voice.
RELATED LINKS
Changing the voice of existing notes on page 803

Changing the voice of existing notes
You can change the voice of notes after they have been input. For example, you can change
notes in an up-stem voice to a down-stem voice.
PROCEDURE
1.

In Write mode, select the notes whose voice you want to change.
TIP
You can use large selections and filters to select many notes in the same voice quickly.

2.

Choose Edit > Voices > Change Voice and select an existing voice, or a new voice if there
is only one voice on the staff. You can also choose this option from the context menu.

RESULT
The voice of the selected notes is changed.
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NOTE
As a result of changing the voice, Dorico might automatically change the stem directions of the
selected notes and other notes on the staff, and add implicit rests to ensure correct notation
based on convention.
You can later hide implicit rests and change the stem direction of notes manually.

RELATED LINKS
Showing voice colors on page 803
Large selections on page 109
Filters on page 109
Implicit rests in multiple-voice contexts on page 807
Hiding/Showing rests before the first note in voices on page 808
Hiding/Showing rests after the last note in voices on page 809
Changing the stem direction of notes on page 714

Pasting notes into different voices
You can copy and paste notes into voices that are different to their original voices. For example,
you can copy notes from an up-stem voice on one staff into a down-stem voice on another staff.
PROCEDURE
1.

In Write mode, select the notes you want to copy.

2.

Copy the notes in any of the following ways:
●

Press Ctrl/Cmd-C.

●

Choose Edit > Copy. You can also choose this option from the context menu.

3.

Select the staff to which you want to paste the notes, at the position where you want the
selection to start.

4.

Choose Edit > Paste Into Voice > [Existing or new voice]. You can also choose this option
from the context menu.

RESULT
The selected notes are copied to the selected staff and into the selected voice.

Deleting unused voices
You can create as many voices as you want in each staff. To delete an entire voice from your
project, you must delete all notes from the voice.
NOTE
Deleting all notes in a voice does not delete the voice immediately.
Any unused voices are automatically deleted when you close a project, but you cannot manually
delete voices once they have been created.
If you later want to input notes in a voice that was automatically deleted when you last closed the
project, you can create a new voice at any rhythmic position.
RELATED LINKS
Inputting notes into multiple voices on page 118
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Swapping the contents of voices
You can swap the contents of two voices that contain musical material.
PROCEDURE
1.

In Write mode, select the notes in two voices that you want to swap.
NOTE
You must select notes in two voices. You cannot select notes in just one voice, or in three
or more voices.

2.

Choose Edit > Voices > Swap Voice Contents. You can also choose this option from the
context menu.

RESULT
The contents of the voices are swapped. For example, the notes previously in an up-stem voice
are now in a down-stem voice, and the notes previously in a down-stem voice are now in an upstem voice.
NOTE
Depending on the pitches involved in the swap and their stem directions, the notes might
overlap. Dorico automatically positions notes with the noteheads partially overlapping, in order
to minimize the horizontal space they occupy and maintain the clarity of the rhythm. However, if
you want to change this arrangement, you can change the order of voices or change the voice
column index.
EXAMPLE

An E is in the up-stem voice, an F in the down-stem
voice.

After swapping their voice contents, the E is in the
down-stem voice, and the F is in the up-stem voice.

RELATED LINKS
Swapping the order of voices on page 805
Voice column index on page 806

Swapping the order of voices
Dorico automatically positions notes with the noteheads partially overlapping, in order to
minimize the horizontal space they occupy and maintain the clarity of the rhythm.
You can manually swap the order in which opposing voices are positioned horizontally.
PROCEDURE
1.

Select the notes whose order you want to change. You can do this in Write mode and
Engrave mode.

2.

Choose Edit > Voices > Swap Voice Order. You can also choose this option from the
context menu.
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RESULT
The order of the selected notes is changed.
NOTE
Swapping the order of notes automatically activates Voice column index in the Notes and Rests
group of the Properties panel, which you can see in Engrave mode. If you swap the contents of
these notes again, their positions might not appear as expected.
Deactivating Voice column index reverts notes to your project-wide settings for note order.
EXAMPLE

Interlocking notes in opposing voices positioned
notehead to notehead.

Interlocking notes in opposing voices positioned
stem to stem.

RELATED LINKS
Voice column index on page 806

Voice column index
The voice column index is used to determine the positions of notes when multiple columns are
needed, for example, when notes are in multiple voices and cannot be placed directly above each
other vertically, and instead must partially overlap.
The Voice column index property in the Notes and Rests group of the Properties panel is
automatically activated when you swap the order of voices manually.
NOTE
This property is available in Engrave mode only.
You can activate this property to change the index number, and therefore the horizontal order,
of individually selected notes. Deactivating the property returns the selected notes to their
default position.
TIP
●

You can change the order of notes in multiple voices project-wide on the Voices page in
Write > Notation Options.

●

You can also change the minimum gaps between notes in different voices in the Voices
section of the Notes page in Engrave > Engraving Options.

You can move notes graphically in Engrave mode. You can move notes individually and
independently of all other items at that rhythmic position, or move everything at the same
rhythmic position.
RELATED LINKS
Swapping the order of voices on page 805
Per-flow notation options for voices on page 802
Notation Options dialog on page 110
Engraving Options dialog on page 228
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Notes crossed to staves with existing notes in other voices
When you cross notes to staves that already contain notes, the stem direction of the existing
notes may change. This is due to how multiple voices at the same rhythmic position are handled
in Dorico.
For example, if a piano part contains notes in up-stem voices on both staves, the stem direction
of notes in both voices can change if notes from the upper staff are crossed to the lower staff. In
this situation, the notes from the two staves are not combined, but are instead treated as two upstem voices in a multiple-voice context.

Two piano staves, each with notes in a single upstem voice.

When the notes in the upper staff are crossed to the
lower staff, the stem direction of the notes already in
the lower staff changes so they point upwards.

You can change the stem direction of the notes originally in the lower staff in any of the following
ways:
●

Select the notes originally in the lower staff and change their voice to another voice, such
as a down-stem voice.

●

Select the notes originally in the lower staff and change their stem direction.

Alternatively, you can move the notes in the upper staff permanently to the lower staff by
copying them, then pasting them into the lower staff in a different voice to the notes already in
the lower staff.
RELATED LINKS
Changing the voice of existing notes on page 803
Pasting notes into different voices on page 804
Creating cross-staff beams on page 411
Changing the stem direction of notes on page 714
Stem direction on page 711

Implicit rests in multiple-voice contexts
In Dorico, implicit rests are shown automatically to fill in rhythmic positions around notes.
The same applies when there are multiple voices on the staff. However, in these contexts you
might want more control over when and where rests are shown.
Usually, rests or notes are shown for whole bars when voices contain at least one note in the bar.
This helps make the rhythmic position of every note in all voices in the bar immediately clear.
When there are multiple voices on a staff, implicit rests are shown in every bar in which there are
notes of any duration in more than one voice. However, there might be circumstances in which
you do not want to show rests either before the first note in a voice or after the last note in a
voice when there are multiple voices on the staff. For example, it can be useful to hide rests when
a voice is being used to show passing notes within a bar that otherwise contains a single melodic
line.
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Implicit rests in multiple-voice contexts

A second voice used to notate passing notes

NOTE
By default, Dorico consolidates rests when multiple voices have rests of the same duration at the
same rhythmic position.
You can show multiple rests at individual rhythmic positions by changing the vertical position of
rests.
You can also change your project-wide settings for the consolidation of rests in multiple-voice
contexts on the Rests page in Notation Options.
You can hide rests before the first note in voices and after the last note in voices individually by
activating properties in the Properties panel. You can show rests that you have hidden by
deactivating the corresponding property.

A phrase with multiple voices showing implicit rests.

The same phrase without implicit rests.

You can choose when rests are shown in a number of different multiple-voice contexts projectwide on the Rests page in Notation Options.
You can open Notation Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

●

Click Notation Options on the right of the Flows panel in Setup mode.

You can also delete rests from selected passages.
RELATED LINKS
Per-flow notation options for rests on page 658
Moving individual rests vertically on page 661
Hiding/Showing rests before the first note in voices on page 808
Hiding/Showing rests after the last note in voices on page 809
Deleting rests on page 660

Hiding/Showing rests before the first note in voices
You can manually hide/show rests before the first note in voices from the previous barline.
NOTE
You cannot hide rests before notes that are not the first note in a voice in the selected staff, or if
the previous note in the same voice does not have rests hidden after it.

808

Voices
Rhythm dot consolidation

PROCEDURE
1.

Select the first note in the voices before which you want to hide rests. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Starts voice in the Notes and Rests group.

RESULT
Rests are hidden before the selected notes from the previous barline when Starts voice is
activated, and shown when it is deactivated.
TIP
Alternatively, you can delete rests from passages of music. Deleting rests sets the Starts voice
and Ends voice properties on notes at the start/end of rest passages so that no implicit rests are
shown.

RELATED LINKS
Deleting rests on page 660
Hiding/Showing rests after the last note in voices on page 809

Hiding/Showing rests after the last note in voices
You can manually hide/show rests after the last note in voices until the next barline.
NOTE
You cannot hide rests after notes that are immediately followed by another note in the same
voice on the selected staff.

PROCEDURE
1.

Select the last note in the voices after which you want to hide rests. You can do this in
Write mode and Engrave mode.

2.

In the Properties panel, activate/deactivate Ends voice in the Notes and Rests group.

3.

Optional: Select the rhythmic position at which point the selected voices end from the
following options:
●

Immediately

●

After barline

RESULT
Rests are hidden after the selected notes when Ends voice is activated, and shown when it is
deactivated.
RELATED LINKS
Deleting rests on page 660

Rhythm dot consolidation
You can change how rhythm dots in multiple voices are consolidated project-wide.
In the Rhythm Dots section of the Notes page in Engrave > Engraving Options, you can choose
how rhythm dots in multiple voices are consolidated project-wide from the following options:
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Preferred

Allowed

Allowed only for unisons

Disallowed

TIP
You can also change how rhythm dots in multiple voices are consolidated individually.

RELATED LINKS
Project-wide engraving options for notes on page 571
Changing the consolidation of rhythm dots on page 580

810

Glossary

A
action
The mechanism inside pianos that allows the hammers to strike the strings with different forces,
depending on the strength with which the player depresses the corresponding key. It allows
pianos to use a greater dynamic range, hence their full name “pianoforte”.
anacrusis
Note or notes played before the first full bar of a piece, also known as an “upbeat”. See also pickup bar.
articulation
(1) In music notation, symbols that indicate how a note should be played, typically affecting their
onset (attack), release, or duration. (2) In sample libraries, a term that refers to playing
techniques generally.
attachment
The rhythmic position at which an item occurs, or to which an item applies, in the music. In
Engrave mode in Dorico, an attachment line is shown between a selected item and its rhythmic
position.

B
bar
A span of music comprising a specific number of beats, as defined by the prevailing time
signature, whose boundaries are indicated by bar lines. Also known as a “measure”, but this
documentation uses “bar”.

C
caret
Shown during note input, it is the vertical line that extends above and below the staff and
indicates the rhythmic position at which items are input. Also known as an “insertion point”. In
Dorico, the caret, cursor, and pointer are related but serve different purposes. See also rhythmic
grid.
casting off
The act of fixing the layout of pages of music, such as defining a set number of systems per page
or the number of bars per system.
cautionary accidental
A restatement of an earlier accidental, such as when a tied note with an accidental continues
onto another page, to eliminate ambiguities. Also known as “courtesy accidentals”.
channel
In MIDI, a channel determines which note, controller, or other data is played by which sound on
which device. In Dorico, notes on a single staff may be played by different channels, depending
on which playing techniques are provided by the patch assigned to each channel. See also MIDI,
patch.
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chord
Two or more notes of the same duration that start at the same rhythmic position and share a
stem.
collision avoidance
Automatic adjustments made by Dorico to ensure multiple items at the same position do not
overlap and that all remain clearly legible. Includes changing the shape of items, such as slurs,
and changing the vertical and/or horizontal position of items, such as accidentals in chords.
column
A vertical line representing the same horizontal position across all staves in the system. Used to
determine the position of notes and chords for the purposes of spacing music accurately.
Multiple columns can be used for the same rhythmic position to accommodate multiple voices,
with notes or chords in some voices being offset horizontally from notes or chords in other
voices.
concert pitch
All notes are written as they sound. Full scores are often notated in concert pitch, so that
harmonies and themes are easier to identify. Also known as “sounding pitch”. See also
transposed pitch.
cursor
The vertical blinking line that appears when entering or editing text. See also caret.

D
disclosure arrow
A small arrow that is shown on all edges of the main window in Dorico. It allows you to hide/
show the toolbar and panels individually.

E
EDO
An abbreviation for Equal Division of the Octave, it is a unit used to describe how an octave can
be divided into equal parts, often for the purpose of defining a microtonal scale or tonality
system. Traditional Western European music uses 12-EDO, that is, each octave is divided into 12
equal semitones or half-steps. Music that uses equal quarter tones uses 24-EDO.
Engrave mode
A workspace that allows you to make fine graphical adjustments and to adjust the page layout
and the format of the system. See also modes.
engraving options
Options that affect the graphical appearance of the notation, including choice of symbols, line
thicknesses, and distances. These options apply to the whole project, including all flows and
layouts, and can be set in the Engraving Options dialog.
ensemble
A predefined collection of players, each holding instruments that are often used together, such
as string quartet, wind quintet, brass quintet, string ensemble, and double woodwinds.

F
family
Instruments of a similar kind that are typically bracketed together in a score, such as woodwind,
brass, percussion, and strings.
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fermata
A notation that indicates all notes at that position are held for longer than their notated length.
Most commonly shown as a curved line with a dot under the curve, it can also be shown with a
pointed arch or square shape. Also known as a “pause” or a “birds’ eye”.
flow
A complete span of music of any scope, for example, a movement, song, piece, scene, number,
act, cue, example, or exercise that contains music assigned to players.
formatting
The act of determining the number of bars in a system, the number of systems on a page, and
the distances between staves and systems.
fragment
Part of a notation item. For example, fragments of a note include its notehead, rhythm dots,
accidentals, the tip of its stem, and beam. In Write mode, selecting any part of an item also
selects all of its fragments, so any changes you make affect the whole item. In Engrave mode,
you can select each fragment individually to tweak its position or appearance. See also item.
frame
A rectangular container for music, text, or graphics on a page.
full score
A score comprising all of the music for all of the players and their instruments, typically laid out
in a specific order. The order used varies according to the ensemble for which the music is
written. In full scores for orchestra, the players are typically ordered from the highest wind
instrument at the top of the page, for example, piccolo, to the lowest string instrument at the
bottom of the page, for example, contrabass, with brass, keyboards, voices, and percussion in
between.

G
galley view
A viewing option that shows music laid out as a single, infinitely wide system.
grace note
A small note, often used to show an ornament or embellishment, that is not counted towards the
number of beats in the bar; when performed, it steals from the duration of either the preceding
or the following rhythmic notes. Also known as “arhythmic notes”. In common practice, a grace
note with a slashed stem is an acciaccatura, which is to be played as quickly as possible, either
immediately before or at the rhythmic position of the note or chord that follows it; a grace note
with an unslashed stem is an appoggiatura, which is played as half of the written duration of the
note or chord that follows it.
group
A collection of players that comprises either a subset of the main ensemble, for example, a choir
within an orchestra, or a separate group, for example, an off-stage brass group or second
orchestra. Each group of players is labeled separately in the full score and is grouped and
numbered together in the instrument order. See also player.

H
hairpin
A notation for dynamics that uses a pair of angled lines, diverging from or converging on a single
point, to show a gradual increase or reduction in the dynamic level, that is, a crescendo or
diminuendo.
half-bar
The rhythmic position that divides bars into two equal sections when the prevailing time
signatures can be divided into four equal beats. In Dorico, specific beam grouping and note
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grouping settings apply to bars with a half-bar. Time signatures that have a half-bar include 4/4
and 12/8.
handle
A circular or square selectable item that marks the ends of lines, the corners of frames, and other
moveable positions, such as pedal line retakes and slur control points. In Write mode, handles
are circular and mark rhythmic positions. In Engrave mode, handles are square and mark
graphical positions.
hook
A short line that extends from other lines, most commonly at a right angle, that helps to clarify
the end position of lines. In Dorico, hooks can be used at the end of pedal lines, octave lines,
repeat endings, and tuplet brackets.
horizontal justification
The alignment of musical content to the left and right edges of the frame. To ensure that all
staves in a system occupy the same width, any remaining space that is left over after the music is
spaced is distributed evenly between all of the columns in the system. Sometimes the final
system of a flow is not fully justified and is allowed to end midway across the width of the frame.
See also frame, justification.

I
instrument
Anything that requires at least one staff to represent the sounds or music it produces. Common
instruments include the violin, flute, tuba, and bass drum. However, human voices, computer
triggering samples, and tape recordings can also be instruments.
instrument transposition
The interval difference between the pitch the instrument plays and the resulting sounding pitch,
often included as part of the instrument name. For example, when a Clarinet in B♭ plays a C, the
pitch produced is a concert B♭. Instrument transposition is also known as “instrument pitch”.
item
Generic term for any note, rest, chord, notation, or other selectable object that appears in the
score in Dorico. See also fragment.

J
justification
The alignment of musical content to the edges of the frame, both horizontally and vertically. See
also frame, horizontal justification, vertical justification.

K
key command
A set of keys that perform a defined task when pressed together. Also known as a “keyboard
shortcut”.

L
layout
A page-based presentation of the music for one or more players in one or more flows, for
example, a full score or an instrumental part.
layout options
Options that affect the setup of an individual layout, such as page and staff size. These options
can be set in each layout independently in the Layout Options dialog.See also layout.
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lock duration
Functionality that allows you to change the pitches of existing music while retaining existing
rhythms.
lyric
Any text that is intended to be sung or spoken by an individual singer or group of singers. A lyric
can be a whole word or an individual syllable in a multi-syllabic word. Lyrics are shown at each
rhythmic position where a new word or syllable begins. Typically, lyrics are found below the staff,
but are sometimes placed above the staff, for example, in the case of a short score.

M
measure
See bar.
MIDI
An abbreviation for Musical Instrument Digital Interface, a standard for how electronic musical
instruments, computers, and virtual instruments can connect to and communicate with each
other. In Dorico, MIDI data can be sent to one of 16 channels, which allow either a specific
instrument, or a specific patch on a specific instrument, to receive and respond to the data. See
also channel, patch.
minor key
A key signatures based on a minor scale, which have a different pattern of intervals to major
scales. See also minor scale.
minor scale
A sequence of notes containing the pitches of a minor key. There are three types of minor scales:
natural, harmonic, and melodic. Natural minor scales follow the interval pattern of the Aeolian
mode, which on a keyboard is all the white notes from A-A. Harmonic minor scales also follow the
Aeolian mode interval pattern but the seventh degree of the scale is sharpened, for example, G♯
in A harmonic minor. Melodic minor scales follow different interval patterns when they are
rising/falling: when rising, melodic minor scales have sharpened sixth and seventh degrees, but
when falling, the sixth and seventh degrees are both natural. See also minor key.
modes
Selectable workspaces in the project window that represent different phases in the workflow of
preparing a score.
multi-bar rest
A consolidation of multiple adjacent empty bars into a smaller unit, typically shown as a single
bar with the total number of bars' rest written above the staff. A multi-bar rest normally shows
an H-bar symbol, which is a thick horizontal line with vertical lines at each end. In some older
published scores, a multi-bar rest of up to nine bars in length is shown using a combination of
double whole and whole rests.
music area
The main part of the window in Setup, Write, and Engrave mode where you input and edit your
music.
MusicXML
A file format designed to allow the interchange and archiving of music notation data in an open
and non-proprietary way. It is useful for exchanging scores between different music applications.

N
notation options
Options that affect the way the music is notated, particularly concerning how notes and rests are
grouped according to meter, rules for the extent of accidentals, and options for transposition.
These options can be set independently for each flow in the Notation Options dialog.
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P
padding
The minimum distance/gap between two items, such as text and its enclosure. Padding values
can be independent of other set values, such as minimum height or width.
page break
The forced termination of a page of music at a particular rhythmic position, typically at a barline.
Often used to ensure a convenient page turn in a part. In Dorico, page breaks can be achieved
using frame breaks, which are indicated using signposts.
page view
A viewing option that shows music laid out on a page with a fixed width and height, as it appears
when printed. See also galley view.
panel
Wide palettes of tools on the left, right, and bottom edges of the program window that are
available in all modes, but their content varies in each mode.
part
The music belonging to the instruments played by one or more players, shown on its own rather
than in a full score. Performers who do not need to see the music belonging to the whole
ensemble play from parts so they only have to read the music they play themselves. See also full
score.
patch
An older term for a discrete sound on a MIDI device or virtual instrument. See also channel,
MIDI.
pedal level change
A change to how far a piano sustain pedal is depressed, between 1 (fully depressed) and 0 (not
depressed), notated as change to the height of a pedal line. Also known as a “pedal lift”.
pick-up bar
Note or notes played before the first full bar of a piece, also known as an “upbeat” or “anacrusis”.
Often pick-up bars only comprise one or two beats whose main purpose is to lead in to the start
of the piece.
player
A musician who plays one or more instruments. Players are defined as either solo players or
section players. See also solo player, section player.
playhead
A vertical line that moves alongside music during playback and when recording, showing the
current rhythmic position. Also known as a “playback line”.
Play mode
A workspace that allows you to assign VST instruments, to adjust the mix, to apply automation,
and to tweak note data. See also modes.
playthrough
A single time playing from the beginning of the piece to the end. Music that contains multiple
possible endings, such as music with repeat endings or codas, requires multiple playthroughs.
plug-in
A software program that can operate within another software program. Dorico supports VST
instruments and effects and script plug-ins written in Lua.
pointer
The symbol on the computer screen that follows movements made by the user with a mouse or
on a touchpad. It is most commonly an arrow pointing towards the top left corner of the screen.
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polymeter
Music containing multiple simultaneous meters, for example, one instrument in the ensemble
plays in 6/8 and another plays in 7/4.
Print mode
A workspace that allows you to print to your printer, export to PDF, and export to other graphics
files. See also modes.
print preview area
The main part of the window in Print mode where you can see a preview of what is going to be
printed or exported as a graphic. See also Print mode.
project
A Dorico file that can contain multiple flows and layouts. See also flow and layout.
properties
The characteristics of individual items and fragments of items in your project that can be edited
via the Properties panel. Properties are layout-specific, meaning changing the properties of an
item in one layout does not affect the same item in other layouts.

R
rastral size
The size of a full five-line staff, measured from the bottom line to the top line. The term comes
from the rastra engravers historically used to draw five-line staves on blank paper. Because the
rastrum is a fixed object, people became used to their set sizes and Dorico continues this
tradition by offering users a selection of rastral staff sizes.
rhythmic grid
A unit of rhythmic duration whose value affects certain aspects of inputting and editing, such as
the amount by which items move. Its current value is shown by the note value in the status bar,
and by ruler markings indicating beat divisions and subdivisions above the staff on which the
caret is active. See also caret.

S
score
See full score, part, project.
section player
Multiple musicians who all play the same instrument and read from the same part layout, for
example, Violin I. Section players may not play multiple different instruments, but can divide. See
also player.
Setup mode
A workspace that allows you to add players, to assign instruments to those players, to create
flows, and to assign players and flows to layouts. See also modes.
solo player
An individual musician who can play one or more instruments, for example, a flute doubling
piccolo. See also player.
space
A unit of measurement in music engraving based on the distance between the center of two
adjacent staff lines. Practically all notation items are scaled in proportion to the size of a space,
for example, a notehead is normally one space tall.
spacing
The act of determining the horizontal distance between successive columns in order to format
the music. Horizontal spacing in Dorico considers the graphical shape and size of notes and
other items, such as rhythm dots and accidentals, and the note spacing values set. Full systems
are automatically horizontally justified.
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spelling
The way in which a note of a given pitch is specified by a letter name plus an accidental. For
example, assuming the conventional 12-EDO pitch system, MIDI note 61 can be spelled as C♯, D♭,
and B. The same pitch is normally spelled a certain way in a given key, for example, MIDI note 61
is normally spelled as C♯ in D major, but is spelled as D♭ in A♭ major. See also EDO, MIDI.
split stem
A way of presenting altered unisons that keeps each accidental directly beside the notehead to
which it applies. Also known as a “cherry stalk” or “tree”.
staff spacing handle
The square handle on the bottom left corner of each staff when Staff Spacing is activated in
Engrave mode. Staff spacing handles only change the vertical position of a single staff. See also
system spacing handle.
string shift indicator
An angled line that indicates the direction of movement when string players have to shift
position on the fingerboard to play a higher/lower note with the same finger as the previous
note.
stroke
The short line that bisects editorial slurs and ties. Also known as a “notch”.
SVG
SVG stands for Scalable Vector Graphics, which is an XML-based way of displaying and modifying
graphics. Due to the way it is coded, it allows you to modify graphics very flexibly compared to
other formats.
system break
The forced termination of a system of music at a particular rhythmic position, typically at a
barline. Indicated in Dorico with signposts.
system fullness indicator
The highlighted region in the right page margin that is shown when Note Spacing is activated. It
combines a color (green, purple, or red) and a percentage to indicate how full the system is.
system object
An item that applies to all staves in the system, but is not necessary to show on every staff, such
as tempo marks and rehearsal marks. In Dorico, you can show system objects at multiple
positions in each system by showing them above multiple instrument families.
system spacing handle
The square handle on the top left corner of each system when Staff Spacing is activated in
Engrave mode. System spacing handles change the vertical position of the top staff in systems,
which also moves all staves in the system accordingly. See also staff spacing handle.

T
token
A code used in a text string that is automatically replaced by a piece of information from
elsewhere in the project, such as the title of the current flow, the name of the player, or the page
number. Also known as a “wildcard” or “text code”.
touchpad
Any flat device with a tactile sensor that functions as an alternative to the traditional computer
mouse. Commonly built into laptop computers but can also be separate appliances connected
wirelessly or via a cable.
transport
Encompasses all options related to playback and recording.
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transposed pitch
The pitches notated are the pitches that are played by each instrument, which are different to the
pitches heard as a result when played by transposing instruments. See also concert pitch.
tuplet
A rhythm is performed at a fraction of its normal written duration. For example, a triplet is three
notes of a given note value played in the time it would normally take to play two notes of that
note value. Also known as an “irrational rhythm” or a “countermetric rhythm”.

U
upbeat
Note or notes played before the first full bar of a piece. See also pick-up bar.

V
vertical justification
The alignment of musical content to the top and bottom edges of the frame. Typically, a music
frame is laid out such that the top line of the top staff of the top system is positioned at or near
the top of the page. If the ideal height of the music in the frame is less than the available height,
the remainder is distributed evenly between the systems, and between the staves of the systems.
See also frame, justification.
voice
In Dorico, a series of notes, chords, rests, and other notations that make up a single musical line
and are normally played by the same instrument. Assigning notes and items to different voices
allows multiple lines of music to be presented on the same staff as clearly as possible, such as in
vocal music where the soprano line uses an up-stem voice and the alto line uses a down-stem
voice. Dorico allows as many voices as are needed to be input onto a single staff, and lays them
out and spaces them automatically.
VST instrument
Short for “Virtual Studio Technology instrument”, it is a digital plug-in that converts MIDI data
into audio output. It can emulate an existing piece of studio hardware or can be an entirely new
creation.

W
Write mode
A workspace that allows you to input music and other notations. See also modes.
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A

accidentals (continued)
tonality systems 537
trills 585
activating
chord input 129
Insert mode 120
mouse input 140
note input 115
adagio 719
inputting 209, 210, 212, 213
add intervals popover 133
adding notes 133
transposing notes 135
adding, See inputting
additional
endings 205, 648
voices 118, 801
additive time signatures 753
advancing
caret 115
chord symbols popover 171
lyrics popover 203
aggregate time signatures 753
aikin
noteheads 577
alignment
arpeggio signs 592
chord symbols 438
dynamics 490, 493, 494
gradual dynamics 477
lyrics 552, 560
octave line numerals 452
ornaments 583
page numbers 608
pedal lines 614
repeat endings 651
rests 656
staff labels 692
staves 266
tempo marks 720
text 214, 259, 276, 279, 281, 515, 516
trills 590
voices 801
allegretto 719
altered bass notes 175
altered unisons 357
appearance 358
formatting 358
split stem 718
alternating time signatures 753
anacrusis 755

abbreviated tempo text 721
absolute tempo changes 719
components 727
accelerando 731
inputting 209, 212, 213
accents 367
inputting 141
acciaccaturas 517
inputting 128
accidental components 541
attachment points 541
accidental duration rules 360
changing 360
common practice 361
Modernist 364
Second Viennese School 363
accidental spelling 137
changing 136
disabling respelling 137
accidentals 355
altered unisons 357, 358
appearance 356
cancellation 361, 362
cautionary 361, 363
changing 355
chords 366
collision avoidance 365, 366
custom 540, 541
custom tonality systems 540
deleting 355, 356
duration rules, See accidental duration rules
hiding 356, 363
inputting 135, 359
kerning 366
key signatures 533, 549
microtonal 359
MIDI input 137
octave divisions 536
ornaments 585
panel 148
parentheses 356, 361
respelling 136, 137
showing 356, 363
signposts 106
slurs 687
spacing 366
stacking order 365, 366
ties across breaks 356, 738
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articulations (continued)
inverting 372
key commands 141
kits 787
moving 371
notes 370
order 370
overlapping 372
percussion 334, 787, 790
placement 370, 372
playback 334, 372
playing technique-specific noteheads 334
position 369–372
slur endpoints 667
slurs 370
spacing 371
stems 370
ties 370, 737
tuplets 773
types 367
assigning
flows to layouts 92
players to flows 89
players to layouts 92
atonal key signatures 535
attachment points
accidental components 541
chord symbol components 432
attack
articulations 367
dynamics 476
playback 319
audio device setup 53

angles
beams 408, 417, 418
fanned beams 417, 418
glissando lines 600, 604, 605
hairpins 485
slurs 678
string shift indicators 510
tremolos 765
tuplet brackets 777
annotations 352
aperture
hairpins 486
appoggiaturas 517
inputting 128
Arabic numbers
fingerings 506
page numbers 240, 609
staff labels 693
arco 633
inputting 197, 199, 200
areas
editing 77, 788
music 42
print preview 43
project start 41
arpeggio signs 591
alignment 592
appearance 591–593, 597
beat-relative playback 597
default settings 597
direction 591
duration 597, 598
ends 593
engraving options 597
filter 109
formatting 592, 593
grace notes 596
handles 594, 595
inputting 185, 189, 190
length 189, 190, 593, 594
moving 595
panel 190
playback 597, 598
popover 186, 189
position 592, 593, 595–597
spacing 592
types 186, 592
arrangements
accidentals in key signatures 533
flows 88
movements 88
arrows
noteheads 575
articulations 367
changing 368
collision avoidance 372
copying 368
cues 467, 468
default settings 369
deleting 368
duration 367, 372
engraving options 369
inputting 141

B
bar numbers 388
appearance 388
changing 398
default settings 388, 389
deleting 399
enclosures 388, 391, 392
engraving options 389
font styles 388, 390
frequency 389
layout options 388
moving 397
part layouts 401
pick-up bars 755
position 394–396
repeat endings 402
returning to primary sequence 400
sequence changes 398
signposts 106
staff-relative placement 396
subordinate 399, 400
bar rests 376
cues 471
hiding 376, 472
inputting 156, 159
moving 377
multi-bar rests 377
showing 376, 472
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beam lines
number 414
beam slants 407
changing 408
grace notes 520
beaming 403, 404, 417
centered beams 409, 410
corners 414
cross-staff 411, 412
default settings 403
direction 405, 408, 418
fanned 417, 418
grace notes 520, 521
grouping 403, 404, 420
handles 408
inverting 406, 407
large pitch ranges 520
meter 421
multiple staves 412
notation options 403
notes 404
optical cross-staff spacing 412
partial 405
resetting 406, 407, 410
secondary beams 414, 415
slants 407, 408, 520
spacing 412
splitting 405
staff-relative placement 406, 407
stem direction 406, 412
stemlets 416, 417
ties 127
time signatures 404, 421
tuplets 415
unbeaming 406
beat groups
numerators 755
specifying 151
ties 735
time signatures 755, 756
beats
display 318
beats per minute 728
booklets 347
printing 346, 347
borders 352
Boston chord symbols 428
bowing 633
inputting 197, 199, 200
bpm 728
braces 422
appearance 424
secondary brackets 425
brackets 422
appearance 424
barlines 384
custom 385
ends 424
ensemble types 423
grouping 424
secondary 425
sub-brackets 425

barlines 380
across staves 384, 385
appearance 385
caesuras 185
dashed 380
default settings 385, 386
deleting 382
double 380
dynamics 477, 478
end barlines 386
engraving options 385
fermatas 531
final 380
grace notes 518
gradual tempo changes 724
inputting 155, 160, 161, 378
key signature changes 384
moving 382, 383
notation options 386
panel 161
popover 160
repeat 380
scale size 380
short 380
single 380
spacing 382
staff groups 385
staves 384, 385
thickness 380, 385
tick 380
time signatures 385
types 380
barré 633
inputting 197, 199, 200
bars 8, 374
bar rests 159, 376, 377
combining 379
deleting 156, 374
deleting contents 375
display 318
divisions 378
duration 375
fixing number per system 269
glissando lines 601
inputting 155, 156, 158
multi-bar rests 377
numbers 389
panel 158
pick-up bars 755
popover 156, 158
splitting 378
width 375
Bars and Barlines panel 158, 161
bass notes
altered 175
beam corners 414
beam groups 403
creating 404
default settings 403
notation options 403
resetting 406
stem directions 713
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brackets (continued)
tuplets 776
wings 424
Brandt-Roemer chord symbols 428
brass instruments
fingerings 500, 509
horn branch indicators 509
slide positions 506
breaking
tie chains 741
breaks
frame 270
page 270
system 272
breath marks 524, 526
appearance 527
inputting 182–184
moving 529, 530
multiple at same position 527
placement 527
position 527
types 526, 527
breves 8

categories
templates 36
cautionary accidentals 361
hiding 356, 363
parentheses 361
showing 356, 363
tie chains 356
cautionary fingering 505
hiding 505
parentheses 505
showing 505
centered beams 409
creating 410
removing 410
chains
frames 248
ties 737
channels 316
controls 316, 317
expression maps 327
meter 316
MIDI 316
mixer 316, 317
percussion maps 327
setting up 327
strips 317
character styles 274
creating 280
deleting 281
dialog 279
saving as default 279
Character Styles dialog 279
cherry stalks 357, 718
choir templates 36
choral
verse numbers 568
chord symbol components 427
attachment points 432
handles 429, 431, 432
types 427
chord symbols 427
alignment 438
altered bass notes 175
appearance 427–429, 431, 432
changing 436
components 168, 427, 429, 431, 432
default settings 427
dialog 429, 431, 432
engraving options 427
enharmonic spelling 441
filter 109
fonts 435
hiding 437, 441
inputting 167, 171, 173, 174
MIDI navigation 172
moving 439
MusicXML import 442
navigation during input 171
pitch 437
playback 442
polychords 174
popover 168
position 438

C
caesuras 524, 526
appearance 527
inputting 182–185
moving 529, 530
multiple at same position 527
placement 527
position 185, 527
types 526, 527
cancellation
accidentals 361
double accidentals 362
key signatures 547, 548
naturals 547
capitals
staff labels 693
cards
flows 61
layouts 59
players 57
caret 104, 112
activating 114
advancing 115
chords 29, 112, 129
deactivating 114
grace notes 112, 128
inputting vs. editing 104
Insert mode 112, 120
lock to duration 112
moving 105, 115, 772
percussion kits 121
rhythmic grid 105
types 112
voice indicator 112, 118, 480
casting off 268
bars per system 269
systems per frame 269
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chord symbols (continued)
quality 174, 437
resetting appearance 435
root 174, 437
saving as default 434
separators 435
showing 437, 440, 441
signposts 106
staves 440
track 302
tracks 301
transposing 436, 437
transposing instruments 437, 441
types 168, 427, 428
chords
accidentals 365, 366
arpeggio signs 592
caret 29, 112, 115, 129
collision avoidance 365, 366
inputting 29, 129
register selection 117
stem directions 712
ties 749
track 302
chords track 302
chorus lyrics 554
changing lines to 564
popover 202
chromatic glissando 600
circle
bar number enclosures 391, 392
noteheads 573
rehearsal mark enclosures 645
clefs 443
cues 457, 473, 474
deleting 446
filter 109
grace notes 447
hiding 178
inputting 175, 178
moving 445
panel 178
placement 444
popover 176, 178
position 447
signposts 106
size at clef changes 447
spacing gaps 444
tie chains 444
ties 739
transposing instruments 447
types 176
Clefs panel 178, 180
closing tabs 50
codes 254
col legno 633
inputting 199, 200
collision avoidance
articulations 372
slurs 687, 688
ties 735

colors
cues 474
graphics 344
monochrome 344
rests 659
voices 801, 803
columns
accidentals 365, 366
voices 806
combined dynamics, See dynamics
components
accidentals 541
articulations 369
chord symbols 168, 427
tempo marks 727
composer 62
text tokens 254
compound time signatures 753
con sordino 633
inputting 197, 199, 200
concert pitch 94, 690, 696
clefs 447, 473
cues 473
layouts 91, 93
viewing 93
concertina dragging 297
consolidation
rests 377, 807
rhythm dots 580, 809
staff labels 692
constraints
defining 262
frames 261
contents
bars 375
cue labels 464, 465
front matter 512
table 512
continuation lines
angles 615
dynamics 476, 483
octave lines 455
pedal lines 613, 615, 625, 628, 629
slurs across breaks 688
tempo marks 731, 732
thickness 629, 733
continuation signs 630
parentheses 629
text 631
control points
handles 679, 682, 744
slurs 675
ties 742, 743
conventions
arpeggio signs 592
breath marks 527
caesuras 527
cues 457
dynamics 477
fermatas 526
fingerings 500
glissando lines 600
grace notes 517
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conventions (continued)
key signatures 533
lyrics 552
ornaments 583
pauses 526
pedal lines 614
playing techniques 633
rehearsal marks 639
rests 656
tempo marks 720
ties 735
time signatures 752
tremolos 765
trills 583
tuplets 771
voices 801
Copy Staff Spacing dialog 298
copying
articulations 368
frames 236, 247
master pages 236
notes 368
notes into voices 804
page layouts 236
players 66
staff spacing 297
corners
beaming 414
counts
bar numbers 755
bars 659
multi-bar rests 659
pick-up bars 755
repeat endings 648
rests 659
courtesy accidentals
hiding 363
showing 363
Create Time Signatures panel 152
creating
paragraph styles 278
crescendo 476, 483
inputting 163, 164, 166
system breaks 486
crop marks 352
cross-staff beams 411
placement 412
spacing 412
cross-staff slurs 668
collision avoidance 687
inputting 668
length 668, 671
moving 668, 670
cross-staff ties 739
cross-voice slurs 668
inputting 668
length 668, 671
moving 668, 670
cross-voice ties 739
crosses
noteheads 574
crotchets 8

Cubase
instrument names 691
staff labels 691
cue labels 464
changing 465
contents 465
moving 467
octave transpositions 461
staff-relative placement 466
text 465
cues 457
appearance 464
articulations 468
bar rests 472
changing to rhythmic cues 458
clefs 457, 473, 474
contents 464
default settings 463
deleting 463
dynamics 468
engraving options 463
filter 109
hiding 469
highlights 474
inputting 216, 218, 220
instrument names 464
instrument transpositions 464
labels, See cue labels
length 462
lyrics 468
moving 459, 461, 467
notations included 457, 467, 468
ornaments 468
overlapping 470
panel 218, 220
placement 457, 464
playing techniques 468
popover 216
position 457, 459
register 460
respelling notes 464
rests 457, 471, 472
rhythmic, See rhythmic cues
showing 469
signposts 106, 469, 474
size 457
staff position 459
stem direction 470, 471
suggestions 218
text 468
ties 471
transposing 464
unpitched instruments 458
vertical position 459
viewing options 474
voices 470
Cues panel 218
curvature direction
grace notes 665
slurs 663, 665, 667, 683, 684
ties 735, 742, 749, 750
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deleting (continued)
clefs 446
cues 463
dynamics 479
fingerings 505
flows 91
flows from layouts 92
frame breaks 272
groups from percussion kits 83
instruments 77
instruments from kits 85
key commands 13
key signatures 545
layouts 95
lyrics 563
master page changes 242
master page sets 232
master pages 234
notes 306, 582
octave lines 453
page number changes 241
pages 238
paragraph styles 279
player groups 86
players 71
players from flows 89
players from layouts 92
rehearsal marks 642
repeat endings 653
rests 660
stemlets 417
system breaks 274
tempo marks 726
ties 741
time signatures 762
tremolos 766
tuplets 774
voices 804
denominators
styles 755, 756
time signatures 751, 752
deselecting 108
design
grace note slashes 520
noteheads 573, 577, 578
slurs 685, 686
stem flags 716
diamond
noteheads 574, 575
diminuendo 476, 483
inputting 163, 164, 166
system breaks 486
direction
arpeggio signs 591, 592
fanned beams 417, 418
glissando lines 581
gradual dynamics 483
hairpins 483
notes on middle line 714
partial beams 405
slur curvature 663, 683, 684
stems 711, 714, 715

custom
accidentals 540
key signatures 543
master pages 232
octave divisions 539
repeat endings 653
tonality systems, See custom tonality systems
custom score layouts 91
creating 91
empty staves 268
flows on pages 265
margins 263, 266
master pages 230
orientation 264
printing 341
Custom Staff Size dialog 706
custom tonality systems 537
accidentals 540
creating 537, 538
editing 537, 538
key signatures 543
octave divisions 539
cutting
tie chains 741

D
damping 633
inputting 199, 200
dashed
barlines 380
octave lines 448
pedal continuation lines 628
slurs 685
tempo marks 732
ties 746, 748
date and time
annotations 352
tokens 256
deactivating
chord input 129
Insert mode 120
mouse input 140
muted tracks 316
note input 115
note respelling 137
slur collision avoidance 688
soloed tracks 316
dedications 512, 513
text tokens 254
default master pages 232
default settings 230
barlines 386
changing 230
key commands 10
deleting
accidentals 355, 356
articulations 368
bar number changes 399
barlines 382
bars 156, 374, 375
beams 406
centered beams 410
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duplicating (continued)
percussion maps 332
players 66
duration
accidentals 360
arpeggio signs 597, 598
articulations 367, 372
bars 375
fermatas 527
forcing 125
locking 138
notated 335
notes 100, 124, 125, 304, 335
pedal lines 632
played 335
rests 124
slurs 688
terminology 8
tremolos 769, 770
dynamic curve 498
dynamic glyphs 476
font styles 497
dynamic modifiers 476
font styles 496, 497
dynamics 476
alignment 477, 490, 493, 494
appearance 496
barlines 477, 478
combined 477
continuation lines 476, 483
conventions 477
copying 479
crescendo, See gradual dynamics
cues 467, 468
default settings 496
deleting 479
diminuendo, See gradual dynamics
dynamic curve 498
endpoint positions 477
engraving options 496
expressive text 482
filters 109, 479
font styles 496, 497
force 476
gradual, See gradual dynamics
grouping 493, 494
hairpins, See hairpins
handles 483–486, 492
hiding 483
humanize 498
immediate 476
inputting 161, 164, 166
length 484, 492
linking 494–496
moving 491, 492
niente hairpins 480
non-sustaining instruments 499
panel 166
parentheses 478
percussion kits 788
placement 477, 489
playback options 498
poco a poco 487

direction (continued)
string shift indicators 511, 581
tie curvature 735, 749, 750
disclosure arrows
Properties panel 45
tracks 301
display options 38, 47
drum editor 307
frames 235, 248, 262
image resolution 351
layouts 41
music area 42, 47
pages 262
panels 20, 44
piano roll editor 303
print preview 43
project window 41
tabs 48
time 40
transport 40
distance
brackets 425
cues 459
noteheads 412
rehearsal mark enclosures 645
staff labels 692
stems 412
system indents 709
dividers 701
dotted
dynamics 476
noteheads 576
notes, See dotted notes
octave lines 448
slurs 685
tempo marks 732
ties 746, 748
dotted notes 420
consolidation 580, 809
double 117
forcing 125
inputting 117
note grouping 420
triple 117
double
accidentals 361, 362
barlines 380
dotted notes 117
whole notes 8
drum editor 307, 799
inputting notes 307
drum kits, See percussion kits
drum sets 77, 782, 783
defining kits as 81
exporting 783
importing 784
naming 77
voices 797
duplets 771
duplex printing 341, 348
duplicating
expression maps 325
paragraph styles 278
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dynamics (continued)
popover 163, 164
position 477, 490, 496
signposts 106, 483
spacing 488
staff-relative placement 489
sustaining instruments 499
types 163, 476
ungrouping 494
unlinking 496
voice-specific 164, 166, 480
Dynamics panel 166

endpoint positions
arpeggio signs 593
dynamics 477
octave lines 452
pedal lines 623
repeat endings 654
slurs 664, 666, 667, 675, 677
staff lines 666
ties 735
trills 590
Endpoint Setup dialog 327
Engrave mode 222
casting off 268
Engraving Options dialog 228
frame breaks 270
frame chains 248
frames 244
graphics frames 260
make into frame 271
make into system 273
moving text 258
music frames 247
note spacing 284
page breaks 270
page layouts 262
panels 44, 222–224, 227
signposts 106
staff spacing 294
switching 222
system breaks 272
text editor 281
text frames 254
engraving options 228, 230
arpeggio signs 597
articulations 369
bar numbers 389
barlines 385
breath marks 532
caesuras 532
changing 230
chord symbols 427
cues 463
dialog 228
dynamics 496
fermatas 532
fingerings 505
glissando lines 605
holds 532
key signatures 548
ledger lines 571
lyrics 570
notes 571, 716
octave lines 455
ornaments 590
pauses 532
pedal lines 625
percussion 784
playing techniques 637
rehearsal marks 644
repeat endings 649
rests 658
saving as default 228
slurs 667

E
East Asian elision slurs 569
hiding 570
showing 570
Edit Accidental dialog 541
Edit Chord Symbol Appearance dialog 431
Edit Composite Component dialog 432
Edit Custom Key Signature dialog 543
Edit Font Styles dialog 275
Edit Instrument Names dialog 68
Edit Percussion Kit dialog 77
Edit Tonality System dialog 538
editing 104
area 77, 788
handles 228
inputting vs. editing 104
items 227, 228
master pages 236
notes 98
editorial
slurs 685
ties 746
editors
drum 307
master pages 235
piano roll 303
text 214, 281
EDO 536
effects channels 317
eighth notes 8
empty bars
cues 471
inputting 158
rests 376
width 375
empty staves
hiding 268
showing 268
enclosures
bar numbers 391, 392
line thickness 392, 645
padding values 392, 645
rehearsal marks 639, 645
end barlines 386
end positions
tuplet brackets 778
endings
playthroughs 648
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engraving options (continued)
staff labels 692
stems 571, 716
tempo marks 726
ties 742
time signatures 752
tremolos 768
tuplets 781
Engraving Options dialog 228
enharmonic equivalent
accidentals 136
key signatures 549
enharmonic spelling
chord symbols 441
notes 136
respelling 136
ensembles 57, 71
adding 71, 87
brackets 423, 424
groups 86, 87
templates 36
equal division of the octave 536
equalization 317
espressivo 476
excluding
flows from layouts 92
players from flows 89
players from layouts 92
explicit rests 656, 657
colors 659
deleting 660
hiding 660
implicit rests 658
showing 660
exporting
annotations 352
arrangements 346
borders 352
color graphics 344
crop marks 352
date 352
expression maps 326
monochrome graphics 344
MusicXML files 655
output format 343
page ranges 346, 348
path 344
percussion kits 783
percussion maps 333
signposts 352
time 352
watermarks 352
expression maps 319
creating 325
dialog 320, 324
exporting 326
importing 327
technique combinations 324
Expression Maps dialog 320
expressive text 476, 482
inputting 482
poco a poco 487

extension lines
lyrics 203, 555, 560
trills 585, 587

F
fader 316
fanned beams 417
angles 418
creating 418
direction 417, 418
fast-forwarding 313
feathered beams, See fanned beams
fermatas 524
appearance 527
barlines 531
changing 528
duration 527
inputting 182–184
moving 529, 530
multiple at same position 527
number per staff 531
placement 526
position 526
single staves 528
staff-relative placement 530
types 524, 527, 528
voices 531
file formats 351
frames 260
graphics files 351
files
exporting 343
loading into frames 261
opening 37
filters 109
dynamics 109, 479
flows 252
frame chains 252, 253
lyrics 109, 553, 554
notes 109
players 253
stem direction 109
tempo marks 109
voices 109
final barlines 380, 386
final tempo 730
gradual tempo changes 730
fine
tacet al 659
fingering 500
appearance 505
cautionary 505
changing 502
default settings 505
deleting 505
engraving options 505
font styles 505, 507, 508
font used 507
handles 501
hiding 504
horn branch indicators 509
inputting 142, 143
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flows (continued)
removing from layouts 92
removing players 89
selecting 109
showing 92
splitting 221
systems 267
titles 89, 90
tokens 255, 513
Flows panel 56, 61
hiding 61
showing 61
font styles 274
bar numbers 388, 390
changing 275
character styles 279
chord symbols 435
dedications 513
dialog 275
dynamics 496, 497
fingerings 507–509
glyphs 276, 497
lyrics 554, 567
music 276
notations 276
notes 276
page numbers 608
paragraph styles 276
PDF files 345
playing techniques 633
rehearsal marks 647
staff labels 692
SVG files 345
tempo marks 720
time signatures 752
force
articulations 367
dynamics 476
note durations 125
rest durations 125
formats, See file formats
formatting
altered unisons 358
arpeggio signs 592, 593
barlines 384
brackets 424
dynamics fonts 497
frame constraints 261
glissando lines 601
handles 228
layouts 232
master pages 230, 236
noteheads 578
page layouts 231, 237, 268
pages 262
pedal lines 626, 628, 629
slurs 677, 679, 686
staff labels 692
tempo marks 731–733
text 214, 274, 281
ties 742, 747, 748
tremolos 769
tuplets 779

fingering (continued)
inverting 503
italics 509
moving 502
MusicXML import 511
numeral style 506
parentheses 142, 143, 505
placement 500
popover 142, 143
position 500, 505
separators 509
showing 504
slide positions 506
slurs 504
staff-relative placement 503
string shift indicators 510, 511
substitution 500, 501
types 143, 509
valved brass instruments 509
fingerings
resetting 503
first and second endings, See repeat endings
first pages
master pages 232
page numbers 610
first systems
indents 709
five-line staff 700
percussion kits 788, 789
percussion legends 794
fixing
bars per system 269
frames 271
note durations 125, 127
systems 273
systems per page 269
flag design 716
flags
hiding 717
notes 711
stems 711
flat slurs 686
flats 355
inputting 135
quarter tones 359
flipping, See inverting
floating windows 39
flows 33, 88
adding 24, 88
adding players 89
adding to layouts 92
cards 61
default settings 110
deleting 91
end barlines 386
frame chains 249, 252
hiding 92
justification 267
multiple on pages 265
naming 89, 90
notation options 112
panel 61
players 89
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full score layouts (continued)
margins 263, 266
master page sets 232
master pages 230
music frames 247
orchestral order 70
orientation 264
players 92, 253
printing 341
removing flows 92
removing players 92
system justification 267
system object positions 708
transposing 94
full screen mode 52
functions
key commands 11
removing key commands 13
funk
noteheads 577
FX channels 317

Formatting panel 222, 223
forte 476
inputting 163, 164, 166
frame breaks 262, 270
deleting 272
filter 109
inserting 270
signposts 106, 272
slurs 688
staff labels 695
ties 738
frame chains
flows 252
frames 251
layouts 249
linking 251
master pages 248
music 248
order 252
players 253
unlinking 251
frame rates
transport window 318
frames 244
breaks 262, 270
constraints 261, 262
copying 236, 247
editing 238
graphics 260, 261
handles 246, 254
inputting 244
making from selection 271
moving 245
music 247, 266
order 252
padding 262
shape 245
size 245
systems 269
text 254
tokens 254
frequency
bar numbers 389
trills 585
front matter 512
dedications 513
project information 513
running headers 514
full score layouts 59, 91
adding flows 92
adding players 92
concert pitch 94
copying frames 247
creating 91
empty staves 268
flows 92, 252
flows on pages 265
frame chains 248, 252, 253
frames 247
front matter 512
instrumental order 86
justification 267
layouts panel 59

G
galley view 47, 52
gaps
key signatures 546
staves 294
tempo marks 732
time signatures 752, 759
ghost notes 786
engraving options 784
glissando lines 600
angles 604, 605
appearance 605
default settings 605
direction 581
engraving options 605
filter 109
formatting 601
handles 603, 605
hiding 602
inputting 185, 190, 191, 601
length 603
moving 603
panel 191
placement 600
popover 186, 190
position 600
showing 602
styles 601
text 602
thickness 605
types 186
glyphs
accidentals 136, 541
chord symbols 432
dynamics 497
fonts 276, 497
pedal lines 625
trills 583
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grids (continued)
rhythmic 105
staves 698, 788
groups
beams 403, 420, 421
dynamics 493, 494
instruments 82
See also groups of instruments
notes 420
players 86
See also groups of players
rests 420
staff labels 692
tabs 49, 51
groups of instruments
deleting 83
naming 82
percussion kits 82
groups of players 33, 57, 86
adding players 87
creating 86
moving players 87
removing players 88
guidelines
caesuras 185
dynamics 488

grace notes 517
appearance 520, 521
arpeggio signs 596
barlines 518
beams 520
caret 112, 128
clefs 447
inputting 128
inverting 518
moving 578
pedal lines 623
pitch 138
placement 517
position 517–519
register 138
size 520, 579
slashes 517, 520, 522
slurs 517, 664, 665
stems 517, 518, 520, 521
transposing 140
types 521
voices 518
gradual dynamics 476, 483
alignment 477
barlines 477
end position 477, 488
handles 484
length 484
moving 488
poco a poco 487
position 488
spacing 488
start position 488
truncated 488
gradual tempo changes 719, 731
barlines 724
components 727
continuation lines 731, 732
dashes 732
final tempo 730
formatting 731–733
gaps 732
length 723, 725
position 724
style 731, 733
thickness 733
graphics files 343
colors 344
exporting 343, 344
fonts 345
formats 260, 351
image resolution 351
monochrome 344
graphics frames 260
file formats 260
inputting 244
loading images 261
grids
gaps 85
instrument groups 82
naming groups 82
percussion kits 788, 789

H
hairpins 476, 477, 483
alignment 477
angles 485
aperture 486
barlines 477, 478
end position 477, 488
handles 484, 486, 492
inputting 164
length 484
moving 488
niente 480
poco a poco 487
position 488
rotating 485
start position 488
truncated 488
width 486
half notes 8
hand tool 46
moving music 46
handles
arpeggio signs 594, 595
beams 408
chord symbol components 429, 431, 432
dynamics 483–486, 492
fingerings 501
frames 245, 246, 249, 254, 261
glissando lines 603, 605
hairpins 486, 492
lyrics 560–562
note spacing 284
octave lines 449, 451, 453, 454
pedal lines 615, 622, 627
percussion legends 795
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handles (continued)
repeat endings 650, 652, 653
selecting 228, 292
slurs 673, 675, 679
staff spacing 295, 296
stems 717, 767
system spacing 295, 296
tempo marks 723, 725
ties 742, 743, 745
trills 586, 588
tuplet brackets 775, 777
headers 514
height
enclosures 392, 645
frames 245
handles 675, 681
slurs 680, 681
ties 743, 745
time signatures 752
Henze fermatas 524
inputting 182–184
hiding 40
accidentals 356, 363
bar rests 376, 472
chord symbols 437, 441
clefs 178
cues 469
dynamics 483
East Asian elision slurs 570
empty staves 268
fingerings 504
flows 92
Flows panel 61
glissando line text 602
initial page numbers 610
instrument transpositions 697
key signatures 545
laissez vibrer ties 740
Layouts panel 59
mixer 318
multi-bar rests 377
octave transpositions in cue labels 461
padding rests 472
panels 20, 40, 45
percussion legend signposts 794
players 89, 92
Players panel 57
quality in chord symbols 437
rests 376, 377, 660, 808, 809
root in chord symbols 437
signposts 107, 272, 274
staff labels 694, 695
staves 89, 92
stems 717
tabs 40
tempo marks 725
time signatures 761
trill extension lines 587
tuplets 776, 779
verse numbers 568, 569
highlights
cues 474
holds, See pauses

Holds and Pauses panel 184
hooks
length 655, 775
octave lines 454
pedal lines 625–627
repeat endings 655
tuplets 775
horizontal position
arpeggio signs 592
articulations 371
dynamics 477, 490
lyrics 552
notes 284, 801, 805
ornaments 583
rehearsal marks 639
rests 656
staccato 371
systems 293
tempo marks 720
ties 735
time signatures 752
trills 583
tuplet numbers 780
tuplet ratios 780
tuplets 771
horns
branch indicators 509
fingerings 509
hotkeys, See key commands
hub 35
humanize
dynamics 498
hyphens
lyrics 203, 555, 560–562
time signatures 758

I
illustrations
exporting 343
frames 260
image resolution 351
images
exporting 343
frames 260
inputting 261
immediate dynamics, See dynamics
implicit rests 656, 657
colors 659
deleting 660
explicit rests 658
hiding 660, 807
showing 660
voices 807
importing
expression maps 327
MIDI files 37, 799
MusicXML files 37, 655, 799
percussion kits 784
percussion maps 333
unpitched percussion 799
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inputting (continued)
system breaks 273
tempo marks 208, 212, 213
ties 127, 739
time signatures 150, 153, 154
tremolos 206, 207
tuplets 131, 772
unpitched percussion 307
voices 118
Insert mode 120
caret 112, 120
time signatures 378, 752
tuplets 774
Insert Pages dialog 239
insertion point 112
inserts 317
instrument groups 82
deleting 83
naming 82
percussion kits 82
instrument labels
percussion kits 82
instrument names 67, 690
changing 70
cues 464
numbering 72, 691
saving as default 68
staff labels 691
instrument pitches, See instrument transpositions
instrument tracks 301
controls 301
headers 301
instrument transpositions 696
cue labels 464
hiding 697
showing 697
staff labels 68, 698
instrumental parts, See part layouts
instrumentation list 512
instruments 33, 72
adding 71, 73
adding to flows 89
adding to parts 92
adding to percussion kits 80
automatic numbering 72
brackets 423, 424
changing existing 75, 80
combining into kits 75
deleting 77
dynamics 499
ensembles 71
groups 33, 86
hiding 89, 92
inputting notes 115
key signatures 535, 549, 550
loading 311
MIDI 310, 311
moving between players 76
names 67, 70
non-sustaining 499
numbering 72
order 70, 86
order in percussion kits 84

indents 709
changing 709
first systems 709
staff labels 695
systems 293
Indian drum notation 800
Indiana chord symbols 428
initial pages
page numbers 610
inputting 104
accidentals 135
additional repeat endings 205
arpeggio signs 185, 189
articulations 141
bar number changes 398
bar rests 156
barlines 155, 160, 161
bars 155, 156, 158
breath marks 181–184
caesuras 181–184
caret 112
centered beams 410
chord symbols 167, 171, 173
chords 129
clefs 175, 178
cues 216, 218, 220
dynamics 161, 164, 166
fanned beams 418
fermatas 181–184
fingerings 142
frame breaks 270
frames 244
glissando lines 185, 190, 191, 601
grace notes 128
inputting vs. editing 104
Insert mode 120
instruments in percussion kits 80
key signatures 145, 147, 148
lyrics 200, 203
master page sets 231
master pages 233
metronome marks 208, 212, 213
microtonal accidentals 359
mouse input 140
nested slurs 669, 670
nested tuplets 772
notes 112, 115, 120, 125, 304, 307
notes in multiple voices 118
octave lines 175, 179, 180
ornaments 185, 187, 188
pauses 181–184
pedal lines 192, 194, 195
percussion kits 74, 75
pick-up bars 151, 153, 154
playing techniques 196, 199, 200
register selection 117
rehearsal marks 203
repeat endings 204, 205
rests 124, 125
rhythm dots 115, 117
rhythmic grid 105
slurs 208, 668–670
stem direction 123
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key commands (continued)
keyboard layouts 12
languages 12
maps 11
resetting 13
searching 11
key signatures 533
accidentals 533, 540, 541
appearance 548
atonal 535
barlines 384, 533
cancellation style 548
cautionary 550
changes 384, 533
custom 537, 539, 540, 543
default settings 548
deleting 545
dialog 538, 541, 543
engraving options 548
enharmonic equivalent 549
filter 109
gaps 546
hiding 545
inputting 28, 145, 147, 148
instruments without 545, 550
major 535
minor 535
moving 547
multiple 545
none 535
octave divisions 536, 539
open 535
panel 147, 148
placement 533
popover 146, 147
position 533, 546
scales 535
signposts 106, 545
spacing 546
tonality systems 536–538
transposing 140, 549
transposing instruments 94, 550
types 146, 535
Key Signatures, Tuning systems, and Accidentals panel
147, 148
keyboard shortcuts, See key commands
keyboards
inputting notes 112
key command maps 11
layouts 12
keys
major 535
minor 535
signatures 533
kits, See percussion kits

instruments (continued)
part layouts, See part layouts
percussion 329, 788
percussion legends 794, 795
playback 319, 329
players 65
Players panel 57
removing from kits 85
removing from parts 89, 92
showing 89, 92
staff labels 68, 691, 692, 698
staff size 705
staves 788
sustaining 499
templates 36
transposing 73, 94, 437, 447, 545, 550, 698
VST 309, 311
interchangeable time signatures 753
interface 35
intervals
add intervals popover 133
transposing 133
trills 585
inverting 684
articulations 372
beaming 406, 407
fingerings 503
grace note stems 518
slurs 663, 665, 684
ties 750
tuplets 777
irregular time signatures 753
italics
dynamics 476
fingerings 509
lyrics 567
items 104, 108
editing 100
selecting 46, 104, 108

J
Japanese chord symbols 428
jazz band templates 36
Jazz Standards chord symbols 428
job types
printing 346
selecting 346
joins
staves with barlines 385
justification
systems 267, 293

K
kerning 366
key clicks 633
inputting 197, 199, 200
key commands 10
articulations 141
assigning 12
defining 53
finding 11

L
labels
cues 464, 465
instruments 68, 690, 691
percussion kits 698, 788
staves 690
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layouts (continued)
percussion kit presentation 789
players 92, 253
printing 341, 346, 350
removing flows 92
removing players 92
running headers 514
scale size 350
selecting 40
settings 62
sorting 95
staff size 702
switching 94
system justification 267
system objects 708
tabs 41, 48
transposing 73, 91, 93, 94
view types 47
Layouts panel 44
hiding 59
Print mode 338, 339
Setup mode 56, 59
showing 59
ledger lines 571, 580
legends
percussion 794, 796
length
arpeggio signs 189, 190, 593, 594
cues 462
dynamics 484, 492
glissando lines 603
grace note slashes 522
hooks 627, 655
lyric extender lines 562
lyric hyphens 562
notated duration of notes 335
notes 125, 304, 335, 336
octave lines 449, 451
pedal lines 622, 624, 627, 628
percussion legend ranges 795
percussion legends 796
played duration of notes 335, 336
repeat endings 650, 652, 655
slurs 668, 671
staff labels 694
stems 717
tempo marks 723, 725, 732
trills 586, 588
tuplet brackets 775
lento 719
inputting 209, 210, 212, 213
level changes for pedal lines 614, 618–620
handles 615
levels
channels 316
lifts
pedal lines, See pedal retakes
line numbers 563
changing 564, 565
lines
arpeggio signs 591
barlines 380
enclosures 392, 645

laissez vibrer ties 739, 740
landscape orientation 350
languages
key commands 12
large
noteheads 576
selections 109
largo 719
inputting 209, 210, 212, 213
layout frame chains 249
layout names 67
changing 69
text tokens 254
layout options 62
bar numbers 388
changing 64
dialog 62
saving as default 62
Layout Options dialog 62
layouts 34, 91
adding flows 92
adding pages 239
adding players 92
cards 59
casting off 268
chord symbols 441
comparing 49
concert pitch 94
copies 341
copying frames 247
creating 25, 91
deleting 95
editing 238
empty pages 239
empty staves 268
exporting 343, 346
fit to paper 350
flows 92, 252, 265
frame chains 248, 252, 253
frame order 252
frames 247
full scores 91
graphics files 343, 351
headers 514
indents 709
justification 267
keyboards 12
margins 263, 266
master page sets 231, 232
master pages 230, 242
multiple windows 22, 51
music frames 247, 248
naming 93
note spacing 284
opening 21, 41, 94
opening multiple 48, 49
order in Layouts panel 95
orientation 264, 348, 350
page numbers 607
page ranges 341, 346
panel in Print mode 339
panel in Setup mode 59, 91
parts 91
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lines (continued)
fingerings 510
glissando 600, 601, 604, 605
grace note slashes 520
gradual tempo changes 733
ledger 580
lyric extender 560–562
lyrics 552, 563
octave lines 448
pedal 613
playback 313
secondary beams 414
staves 700, 707
string shift indicators 511
tempo marks 732
thickness 228
ties 746, 748
trills 585
wavy 585, 591
linking
dynamics 494–496
flow names 89
flow titles 89
groups of dynamics 493
music to frames 251
percussion maps to VST/MIDI 334
slurs 672, 673
lock to duration 138
lyric extender lines 555, 560
handles 560–562
moving 561
lyric hyphens 555, 560
handles 560–562
moving 561
lyric lines
changing 564, 565
deleting 563
numbers 563
placement 558
position 558
lyricist 62
text tokens 254
lyrics 552
alignment 552, 560
appearance 570
changing 555, 556, 564
chorus 202, 554, 555, 564
cues 467, 468
default settings 570
deleting 563
East Asian elision slurs 569, 570
engraving options 570
extender lines 203, 555, 560–562
filters 109, 553, 554
font styles 567
handles 560–562
hyphens 203, 555, 560–562
inputting 200, 203
italics 567
line numbers 563–565
lines 202, 552, 554, 563
melismatic 200, 203, 557, 560
moving 559

lyrics (continued)
note spacing 552
placement 552, 557
popover 200, 202, 203
position 552, 557, 570
selecting 554
spacing 559, 560
staff-relative placement 565, 566
syllable types 203, 555, 556
translations 202, 554, 555, 564
types 202, 554, 555
verse numbers 568, 569

M
macOS
printing 343
major
keys 535
scales 535
make into
frame 271
system 273
maps
expression 319
key commands 11
percussion 329
marcato 367
inputting 141
margins
changing 263
music frames 266
pages 262, 263
marks
rehearsal, See rehearsal marks
tempo, See tempo marks
marquee tool 46
using 46
master page editor 235
opening 236
master page sets 231
applying 232
creating 231
deleting 232
front matter 512
naming 232
master pages 230, 232
adding new 233
assigning to pages 242
copying layouts 236
dedications 513
deleting 234
editing 235, 236
frame chains 248, 251
front matter 512
music frames 247
naming 234
overriding 237, 238
page numbers 607, 608
removing changes 242
running headers 514
sets 231
types 232
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modes (continued)
Setup 56
switching 19
toolbar 17
Write 97
monochrome graphics 344
moon
noteheads 576
mordents 583
motors 197, 633
inputting 199, 200
mouse input 104
activating 140
deactivating 140
settings 108
movements 88
adding 24, 88
multiple on pages 265
splitting 221
moving
arpeggio signs 595
articulations 371
bar numbers 397
bar rests 377
barlines 382, 383
cancellation naturals 547
caret 115, 131
chord symbols 439
clefs 445
cue labels 467
cues 459, 461
dynamics 488, 491, 492
fingerings 502
frames 245
glissando lines 603
grace note slashes 522
grace notes 578
instruments between players 76
key signatures 547
lyric extender lines 561
lyric hyphens 561
lyrics 559
notes 284, 291, 292, 305, 411, 578, 786
octave lines 450, 451
ornaments 587, 588
page numbers 608
pauses 529, 530
pedal lines 621, 622
playhead 313
playing techniques 634, 635
rehearsal marks 641
repeat endings 651, 652
rests 284, 661
slurs 668, 670, 677, 678
staves 296
systems 296, 297
tabs 51
tempo marks 723
text 258
time signatures 759, 760
tremolos 767
trills 588

measured tremolos 763
measures, See bars
melismatic lyrics 203, 557, 560
messa di voce 483
moving 488
meter 751
beam grouping 404, 420, 421
channel levels 316
irregular 375, 378
meterless time signatures 752
note grouping 420
open 753, 757
rest grouping 420
time signatures 753
tremolos 763
tuplets 771
metronome marks 728
appearance 727, 728
components 727, 728
hiding 725
inputting 208, 212, 213
parentheses 727
playback 729
popover 209
range 729
showing 725
values 729
microtones 359, 537
accidentals 540
inputting 359
key signatures 543
octave divisions 539
transposing 133
middle line
stem direction 711, 714
MIDI
accidental spelling 137
channels 316
fader 316
importing 37, 799
instruments 310
loading instruments 311
navigation 172
note input 112, 137
pan 316
percussion maps 329, 334
playback 329
unpitched percussion 799
minims 8
minor
keys 535
scales 535
mixer 316
channel strips 317
hiding 318
showing 318
window 38
moderato 719
inputting 209, 210, 212, 213
modes 19, 32
Engrave 222
Play 299
Print 338
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MusicXML (continued)
pedal lines 632
percussion 799
repeat endings 655
staff labels 691
muted
noteheads 576
mutes 633
inputting 199, 200
techniques 197
muting
deactivating 316
tracks 315, 316

moving (continued)
tuplets 773
view 46
multi-bar rests
appearance 658, 659
end of flows 659
hiding 377
showing 377
multi-note tremolos 763
appearance 769
deleting 766
inputting 206
moving 767
multi-segment slurs 673–675
multiple
flows on pages 265
movements 88
multiple-voice contexts 801
articulations 369
cues 470
dynamics 480
fermatas 526, 531
grace notes 517, 518, 665
inputting notes 118
note alignment 801
notes 807
ornaments 583, 589
rests 656, 807
rhythm dot consolidation 580, 809
slurs 665
stem direction 517, 518, 712, 807
ties 749
voice column index 806
music
assigning to frames 251
editing 104
fixing into frames 271
fixing into systems 273
music area 17, 42
making selections 109
moving music 46
multiple windows 51
opening layouts 41, 94
page arrangements 47
panels 20
selecting views 52
zoom options 48
Music Fonts dialog 276
music frames 247
flows 252
frame chains 248, 251
inputting 244
layouts 248
margins 266
master pages 247
order 252
overrides 247
padding 266
players 253
selectors 249
MusicXML
chord symbols 442
importing 37

N
names
drum sets 77
flows 89, 90
instruments 67, 68, 70
layouts 67, 69, 93
master page sets 232
master pages 234
noteheads 573
percussion kits 77
player groups 86
players 67, 68
staff labels 67, 70
Nashville
chord symbols 428
numbers 168
naturale 633
inputting 197, 199, 200
navigation
caret 115
chord symbols popover 171
dynamics popover 164
fingerings popover 142
frames 246
handles 228, 246, 292, 296
lyrics popover 203
note input 115, 117
rhythmic grid 105
nested
slurs 669, 670
tuplets 772
nested slurs
endpoints 667
New York chord symbols 428
niente hairpins 480
circle 480
inputting 163, 164, 166
text 480
non-power of two time signatures 753
non-sustaining instruments 499
non-transposing layouts 93
nontuplets 771
notated duration 335, 336
notation options 110
barlines 386
beaming 403
changing 112
dialog 110
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notation options (continued)
percussion kits 785
rests 658
saving as default 110
voices 802
Notation Options dialog 110
notation reference 354
notations
appearance 100, 227, 228
cues 457, 467, 468
editing 227
percussion kits 787
position 227, 228
properties 100, 227
selecting 46
settings 62, 64, 110, 228
stacking order 454
tucking index 454
zoom options 48
Notations panel 97, 103
Notations toolbox 102
note grouping 420
changing 125
meter 420, 421
ties 127
note input 104, 112, 115, 307
adding notes 133
caret 112
lock to duration 138
mouse input 140
percussion kits 121–123
register selection 117
repitching notes 138
rests 657
rhythmic grid 105
starting 114
stem direction 123
ties 127
voices 118
note spacing 284, 285
barlines 383
changing 284, 289, 291
default 289
dialog 287
filter 109
fullness 288
galley view 47
handles 284
justification 288
layout options 62, 285
lyrics 552
signposts 106, 284
systems 288
Note Spacing Change dialog 287
note spacing handles
selecting 292
note values 335, 336
forcing 125
selecting 124
notehead sets
designs 577
pitch-dependent 577
scale degree 577

noteheads 573
aikin 577
arrows 575
articulations 372
changing 571–573, 578
circular 573
crosses 574
designs 573, 577
See also notehead sets
diamond 575
diamonds 574
dotted 576
funk 577
large 576
moon 576
muted 576
note names 573
percussion 790
pitch-dependent 577
playing technique-specific 790, 792
rectangular 576
shapes 572, 573, 577
square 576
staccato position 371
stemless 717
time signatures 756
triangular 575
types 573
walker 577
wedges 575
notes 571
accidentals 100, 135, 355
add intervals popover 133
adding to existing notes 133
alignment 490
appearance 100, 571
arpeggio signs 592
articulations 100, 368, 370
beaming 403, 404
brass fingerings 509
changing 138
chords 129
colors 803
copying 368, 804
crossing to other staves 411
cues 457, 470
custom scale size 579
default settings 571
deleting 306, 582, 766
dotted 117, 420
durations 100, 124, 125, 335
dynamics alignment 490
editing 98, 100, 227
engraving options 571
enharmonic spelling 136
filters 109
fixing duration 125
ghost 786
grace notes 128, 517
grouping 420
horizontal spacing 284
horn branch indicators 509
inputting 26, 112, 115, 117, 120, 121, 125, 129, 307
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numbers (continued)
tuplets 779
verses 568
numerators
styles 755, 756
time signatures 751, 752

notes (continued)
Insert mode 120
ledger lines 580
length 125, 304
lock to duration 138
lyric alignment 560
middle line 714
moving 284, 291, 292, 305, 411, 578, 773, 786
moving to other instruments 786
multiple-voice contexts 807
notated duration 335
note spacing 289, 291, 292
notehead designs 573
order 805
overrides 336
parentheses 786
pasting into voices 804
percussion kits 121, 798
piano roll editor 303–305
pitch 138
pitch-dependent noteheads 577
Play mode 304, 307
playback 319
played duration 335, 336
properties 227
register 117, 138
removing stem direction changes 715
repitching 138
rests 657
rhythm dots 117, 580, 809
rhythmic grid 105
scale size 579
secondary beams 414
selecting 46, 108
size 579
slurs 100, 667
spacing 284
spelling 136, 137
stem direction 711, 714, 715, 798, 803
stemlets 416
string fingerings 510, 511, 581
terminology 8
ties 127, 370, 739
time signatures 756
transposing 133, 135, 138, 140, 305, 549
tremolos 764, 766, 767, 769
tuplets 771
types 100
unbeaming 406
voices 118, 803
Notes panel 97, 100
Notes toolbox 98
scissors 741
numbers
bars 388, 398
beam lines 414
fingerings 506
instruments 72
pages 240, 607, 609
slur segments 674
staff labels 693
time signatures 756

O
octave divisions 536
custom 539
EDO 536
tonality systems 537, 539
octave lines 443, 448
alignment 452
appearance 455
default settings 455
deleting 453
Engrave mode 453
engraving options 455
filter 109
handles 449, 451, 453, 454
hooks 454
inputting 175, 179, 180
length 449, 451
moving 450, 451
panel 180
placement 454
popover 176, 179
position 450, 452, 454, 455
stacking order 455
staff-relative placement 453
tucking index 454
types 176, 448
octave transpositions 138
clefs 176, 443
cues 460, 461
octave lines 176, 448
octuplets 771
odd-numbered layouts
booklets 347
printing 341, 347
open
key signatures 535
meter 757
style 757
time signatures 753
opening
files 37
layouts 21, 94
master page editor 236
mixer 318
projects 36, 37
tabs 21
templates 15, 36
windows 22, 51
optical spacing
cross-staff beams 412
options
engraving 228
layout 62
notation 110
page sizes 348
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options (continued)
playback 312
preferences 53
text formatting 214, 281
toolbar 39
transport 39, 40
workspaces 39, 40
zoom 45, 48
orchestral
order 70, 86
templates 36
order
accidentals 365, 366, 533
articulations 370
frame chains 248, 251, 252
instrument numbering 72
instruments in percussion kits 84
key signatures 533
layouts 95
notes 805
orchestral 86
players 70
rehearsal marks 642
score 70
tabs 51
voices 806
orientation
changing 264
exporting 350
landscape 348, 350
portrait 348, 350
printing 341, 350
ornaments 583
acciaccaturas 517
accidentals 584, 585
alignment 583
appoggiaturas 517
cues 467, 468
default settings 590
engraving options 590
filter 109
handles 588
inputting 185, 187, 188
interval 584
length 586, 588
moving 587, 588
panel 188
placement 583
popover 186, 187
position 583, 587, 590
slurs 589
staff-relative placement 589
trills, See trills
types 186
Ornaments panel 188, 190, 191
overlapping
accidentals 365, 366
articulations 372
cues 470
slurs 687
ties 735

overrides
chord symbols 429, 434, 435
master pages 237, 238
music frames 247
note duration 336
removing 259, 336
swapping 243

P
padding
bar numbers 392
enclosures 392, 645
frames 262
music frames 266
rehearsal marks 645
rests, See padding rests
padding rests 471, 656
cues 472
hiding 472
page arrangements 47
page breaks, See frame breaks
page layouts 262
bars per system 269
casting off 268
dedications 513
empty staves 268
fixing 268, 269, 271
formatting 231, 237
frame constraints 261
make into frame 271
make into system 273
master page changes 242
master page sets 231, 232
moving systems 297
multiple flows 265
page size 264
staff spacing 294, 297
systems 269, 293
page margins 262
changing 263, 266
Page Number Change dialog 240
page numbers 240, 607
appearance 608
changing 239, 240
font styles 608
horizontal alignment 608
initial 610
moving 608
numeral style 240, 609
paragraph styles 608
position on page 608
removing changes 241
sequence changes 239, 240
showing 611
size 608
page ranges
exporting 348
printing 348
selecting 346
page size 348–350
changing 264
layout options 62
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panels (continued)
tempo 210, 213
time signatures 152, 154
tremolos 207
tuning systems 148
VST and MIDI Instruments 309
VST instruments 309
Write mode 97, 100, 103
paper
duplex printing 348
orientation 348
size 264, 349, 350
paragraph styles 274
creating 278
deleting 279
dialog 276
page numbers 608
saving as default 276
staff labels 692
text frames 283
Paragraph Styles dialog 276
parentheses
accidentals 356, 361
dynamics 478
fingerings 142, 143, 505
ghost notes 786
metronome marks 727, 728
octave line numerals 448
pedal continuation signs 629, 630
percussion notes 786
string shift indicators 581
tempo marks 727, 728
time signatures 151, 153, 758
part layouts 59, 91
adding flows 92
adding players 92
bar numbers 401
concert pitch 94
copying frames 247
creating 91
flows 92, 252
flows on pages 265
frame chains 248, 252, 253
frames 247
indents 709
justification 267
Layouts panel 59
margins 263, 266
master page sets 232
master pages 230
multi-bar rests 659
music frames 247
names 67
opening 94
orientation 264
players 92, 253
printing 341
removing flows 92
switching 94
system justification 267
transposing 93, 94
part names 67
changing 69

page turns 270
page view 47
arrangements 47
changing 52
pages
adding 239
arrangements 47
changing view 52
deleting empty 238
editing 238
exporting 346
formatting 515
frames 244, 245, 252, 261
layouts 262, 268, 269
making from selection 271
margins 262, 263, 266
master pages 230, 242, 262
multiple flows 265
order 252
orientation 264
panel 224
printing 346, 348
ranges 346
setup 350
size, See page size
staff spacing 297
swapping 243
view options 45
Pages panel 222, 224
pan 316
panels 18, 44
accidentals 148
arpeggio signs 190
barlines 161
bars 158
clefs 178, 180
cues 218, 220
dynamics 166
Engrave mode 222
flows 56, 61
formatting 223
glissando lines 191
hiding 20, 40
holds 184
key signatures 147, 148
layouts 56, 59, 339
MIDI instruments 310
notations 103
notes 100
octave lines 180
ornaments 188, 190, 191
pages 224
pauses 184
pedal lines 195
Play mode 299
players 56, 57
playing techniques 195, 200
Print mode 338
print options 340
properties 100, 227
repeat endings 207
Setup mode 56
showing 20, 40
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pedal lines (continued)
position 614, 621, 623, 625
releases 625
removing retakes 620
retakes, See pedal retakes
signposts 106
staff-relative placement 614
start signs 625, 626, 630
text 630, 631
thickness 629
types 193, 613
pedal retakes 614
adding 616, 617
handles 615
pedal level 619
removing 620
types 618
percussion 782
default settings 784
drum sets 783
engraving options 784
kits, See percussion kits
legends 794
note input 307
noteheads 790
playing techniques 334
Percussion Instrument Playing Techniques dialog 790
percussion kits 782, 783
adding instruments 80
caret 121
changing instruments 80
creating 74, 75, 80
drum sets 77, 81, 783, 797
dynamics 788
editing area 77, 788
exporting 783
five-line staff 788
gap sizes 85
grids 82, 83, 85, 788
groups 82, 83
importing 784
individual instruments vs. kits 782
instrument order 84
legends 794
moving notes 786
naming 77, 82
notation options 785
notations 787
note input 123, 307
playing techniques 785
presentation types 77, 782, 788, 789
removing instruments 85
single-line instruments 788
spacing 85
staff labels 77, 698, 788
staff-relative legend placement 796
staves 77, 782, 788, 789
stem direction 77, 123, 797, 798
stickings 787
voices 797
percussion legends 794
adding 794
changing 795

partial beams 405
parts, See part layouts
patches
playback 319, 329
pauses 524
appearance 527
barlines 531
breath marks, See breath marks
caesuras, See caesuras
changing 528
default settings 529, 532
duration 527
engraving options 532
fermatas 524, 531
filter 109
inputting 181–184
linked 528
moving 529, 530
multiple at same position 527
panel 184
playback 524
popover 182, 183
position 526, 529, 532
single staves 528
staff-relative placement 526, 530
types 182, 524
PDF files 351
exporting 343, 351
fonts 345
pedal level changes 614
adding 616, 617
changing 618–620
end level 620
removing 620
start level 618
pedal lines 613
alignment 614
appearance 625, 626, 628, 630, 631
continuation lines 613, 625, 628, 629
dashes 628
default settings 625
duration 632
Engrave mode 615
engraving options 625
filter 109
formatting 626, 628, 629
gaps 628
grace notes 623
handles 615, 622, 627
hooks 625–627
inputting 192, 194, 195
length 622, 624
levels 614, 615
lifts 614
moving 621, 622
MusicXML import 632
order 614
panel 195
parentheses 629
percussion 633
placement 614
playback 632
popover 193, 194
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placement (continued)
clefs 444
cues 457
dynamics 477
fermatas 526
fingerings 500
glissando lines 600
grace notes 517
key signatures 533
lyrics 552, 557
octave lines 455
order 454
ornaments 583
pauses 526
pedal lines 614
playing techniques 633, 636
rehearsal marks 639
rests 656
slurs 663, 667
tempo marks 720
ties 735
time signatures 752
tremolos 765
tucking index 454, 455
tuplets 771
voices 801
Play mode 299
channel strips 317
deleting notes 306
drum editor 307
Endpoint Setup dialog 327
exporting expression maps 326
expression maps 319, 324
inputting notes 304, 307
loading instruments 311
mixer 316, 317
moving notes 305
note durations 304, 335, 336
overrides 336
panels 44, 299, 309
percussion maps 329
piano roll editor 303
playback 312, 314
playhead 313
switching 299
toolboxes 299, 300
tracks 301, 303
transport 40, 318
unpitched percussion 799
whitelisting VST 2 plug-ins 311
window elements 299
zooming 306
Play toolbox 300
playback 314
arpeggio signs 597, 598
articulations 372
channel strips 317
default tempo 719, 726
dynamic curve 498
expression maps 319, 320
fast-forwarding 313
instruments 319, 329
line 313

percussion legends (continued)
handles 795
instrument names 796
length 795, 796
position 784
ranges 794, 795
signposts 106, 794
sounding instruments 795
staff-relative placement 796
text 796
types 794, 795
percussion maps 329
creating 332
custom 332
dialog 329
exporting 333
importing 333
linking 334
Percussion Maps dialog 329
percussion stickings 787
performance instructions 512
piano
dynamics 163, 476
level changes 614, 620
pedal lines 613, 614
playback 632
retakes 614, 620
substitution fingering 500
piano roll editor 303
changing note durations 336
deleting notes 306
inputting notes 304
moving notes 305
note length 304
played vs. notated durations 335
slurred notes 688
transposing notes 305
zoom 306
pick-up bars 753, 755
inputting 151, 153, 154
pictures
frames 260
inputting 261
pitch
accidentals 355
add intervals popover 133
changing 135, 138, 139
clefs 178, 443
concert 94
cues 464
key signatures 533
microtonal 359, 536
note input 117
noteheads 572, 577
notes 135
octave lines 179, 180, 443, 448
transposed 94
pizzicato 633
inputting 197, 199, 200
placement
articulations 372
breath marks 527
caesuras 527
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playback (continued)
mixer 316, 317
note durations 335
options 312
overrides 336
pauses 524
pedal lines 632
percussion 329
playhead 313
playing techniques 637
preferences 53
rewinding 313
selections 314
slurs 688
starting 314
templates 309, 327
tempo 729, 730
tremolos 769, 770
playback options 312
dialog 312
dynamics 498
pedal lines 632
saving as default 312
slurs 688
timing 372, 597
tremolos 769
Playback Options dialog 312
played duration 335
changing 336
overrides 336
player groups 33, 57, 86
adding players 87
creating 86
deleting 86
moving players 87
naming 86
removing players 88
player names 67
changing 68
text tokens 254
players 33, 65
adding 23, 71, 73, 87
adding to flows 89
cards 57
copying 66
deleting 71, 77
duplicating 66
ensembles 57, 71
filters 253
flows 89
frame chains 249, 253
groups 33, 56, 57, 86, 87
hiding 89, 92
instrument names 70
instruments 33, 72, 73, 75
layout names 69
layouts 92
moving between groups 87
moving instruments between 76
multiple instruments 73
naming 67–70
numbering instruments 72
panel 56, 57

players (continued)
part layouts 91
percussion kits 75
player names 68
position in score 70
removing from flows 89
removing from groups 88
section players 57, 65
showing 89, 92
solo players 57, 65
staff size 705
text tokens 254
Players panel 56, 57
hiding 57
showing 57
playhead 313
fast-forwarding 313
moving 313
playback 314
position 314
rewinding 313
transport 318
zooming 306
playing technique-specific noteheads 790
appearance 793
articulations 334
creating 792
playback 334
playing techniques 633
adding text 636
changing 785
combinations 334
creating 792
cues 467, 468
default settings 637
engraving options 637
expression maps 319
filter 109
inputting 196, 199, 200
moving 634, 635
noteheads 334, 790, 792, 793
panel 200
percussion 787, 790
placement 633
playback 319, 637
popover 197, 199
position 633, 634, 637
staff-relative placement 636
tracks 301
types 197, 633
Playing Techniques panel 195, 200
playing techniques tracks 302
playthroughs 648
dividing 649
repeat endings 649
total number 648
plug-ins
whitelisting 311
PNG files 351
exporting 343, 351
poco a poco
dynamics 487
tempo marks 722
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polychord symbols
inputting 174
popovers
add intervals 133, 135
arpeggio signs 186, 189
barlines 156, 158, 160
bars 156, 158, 160
chord symbols 168, 171
clefs 176, 178
cues 216
dynamics 163, 164
fingerings 142, 143
glissando lines 186, 190
holds 182, 183
key signatures 146, 147
lyrics 200, 202, 203
metronome marks 209
octave lines 176, 179
ornaments 186, 187, 189, 190
pauses 182, 183
pedal lines 194
playing techniques 193, 194, 197, 199
tempo 209, 212
time signatures 151, 153
tuplets 131, 132
portamento 600
portrait orientation 350
position
arpeggio signs 592, 596
articulations 370, 371
cues 457, 459
dynamics 477
fingerings 500
glissando lines 600
grace notes 517
gradual dynamics 488
hairpins 488
instruments in percussion kits 84
key signatures 533
notes in multiple-voice contexts 801
octave lines 452
order 454
pauses 526
pedal lines 623
slurs 663, 667
staccato 371
time signatures 752
tucking index 454
vertical order 454
preamble 512
Preferences dialog 53
prefixes
dynamics 482
fingerings 509
rehearsal marks 644
presentation types 77
changing 789
dynamics 788
editing area 77, 788
percussion kits 782, 788
presto 719
inputting 209, 210, 212, 213

Print mode 338
landscape orientation 346
page setup 350
panels 44, 338–340
portrait orientation 346
printers 345
switching 338
toolboxes 338
Print Options panel 338, 340
print preview area 43
printers 345
selecting 341
printing
annotations 352
arrangements 346
booklets 347
borders 352
copies 341
crop marks 352
date 352
duplex 341, 348
job types 346
landscape 346, 348
layouts 341
macOS options 343
orientation 348
page sizes 348
portrait 346, 348
preview 43
ranges 341, 348
scale size 341
signposts 352
spreads 346
time 352
watermarks 352
Project Default Chord Symbol Appearances dialog 429
Project Info dialog 62
flow titles 89
project information 62
master pages 513
tokens 62, 89, 255
project window 38
Engrave mode 222
opening multiple 51
Play mode 299
Print mode 338
Setup mode 56
splitting 49
Write mode 97
projects 32
adding images 261
flows 88, 90
full screen mode 52
layouts 91
movements 88
multiple windows 22, 51
opening 37, 51
recent 37
settings 228, 230
start area 41
starting 22, 36
Steinberg Hub 35
tabs 49
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projects (continued)
templates 36
titles 90
tokens 255
window 38
workspaces 48
properties 100, 227
notations 227
notes 227
selected items 100
Properties panel 44, 100
disclosure arrow 45
Engrave mode 222, 227
hiding 45
showing 45
Write mode 97
punctuation
verse numbers 568

register (continued)
octave lines 179, 180, 443, 448
transposing 135, 447
rehearsal marks 639
cues 218
default settings 644
deleting 642
enclosures 645
engraving options 644
filter 109
font styles 647
inputting 203
moving 641
order 642
padding values 645
placement 639
position 639, 640
prefixes 644
sequences 642, 643
showing at multiple positions 640
staff-relative placement 639
suffixes 644
types 643
relative tempo changes 719
values 730
renaming
drum sets 77
flows 89
instruments 70
layout names 69
layouts 93
master page sets 232
master pages 234
percussion kits 77
player groups 86
players 68
repeat barlines 380
repeat endings 648
additional endings 205
alignment 651
appearance 649, 654
default settings 649
deleting 653
Engrave mode 653
engraving options 649
final segments 654
handles 650, 652, 653
hooks 655
inputting 204, 205
length 650, 652
moving 651, 652
multiple positions 651
MusicXML files 655
number of playthroughs 648
playthroughs 648, 649
position 649, 651
segments 648, 651
showing 651
text 653
Repeat Structures panel 207
repitching notes 138

Q
quality
chord symbols 174, 437
quarter notes 8
quarter tones 359, 537
accidentals 359, 540
key signatures 543
octave divisions 539
quartet templates 36
quavers 8
quintet templates 36
quintuplets 771

R
rallentando 731
inputting 209, 210, 212, 213
ranges
arpeggio signs 592
cues 457
dynamics in playback 498
glissando lines 604
instruments 72
metronome marks 728, 729
pages 341, 348
percussion legends 795
selecting 109
slurs 679
rastral size 702
ratios
grace notes 520
note spacing 285, 287
tuplets 779
recent projects 37
rectangle
bar number enclosures 391, 392
noteheads 576
rehearsal mark enclosures 645
register
changing 135, 138, 139
clefs 178, 443, 447
cues 460, 464
note input 117
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rhythmic grid 45, 105
resolution 45
values 105
rim shots 633
inputting 199, 200
ritardando 731
ritenuto 731
inputting 209, 210, 212, 213
Roman numerals
fingerings 506
page numbers 240, 609
staff labels 693
root
chord symbols 174, 437
Ross chord symbols 428
rotating
hairpins 485
slurs 678
rulers
rhythmic grid 105
running headers 514

resetting
bar numbers 399
beaming 406, 407, 410
beams 415
chord symbols 435
fingerings 503
key commands 13
page numbers 241
secondary beams 415
tempo 719
resolution
images 351
rhythmic grid 45
respelling
accidentals 136
notes 136, 137
notes in cues 464
rest grouping, See note grouping
restorative text 631
rests 656
alignment 656
bar rests, See bar rests
changing type 658
colors 659
consolidation 377, 807
cues 457, 471, 472
default settings 658
deleting 660
durations 124
empty bars 376
engraving options 658
explicit 656, 658
forcing duration 125
grouping 420
hiding 376, 377, 660, 808, 809
implicit 656, 658
implicit vs. explicit 657
inputting 124, 125, 159
moving 284, 377, 661
multi-bar rests 377, 658, 659
notation options 658
padding 471, 472
placement 656
position 656
showing 376, 377, 660, 808, 809
tacet al fine 659
voices 656, 661, 807
retakes, See pedal retakes
reverb channels 317
rewinding 313
rhythm
locking 138
rhythm dots 117
consolidation 580, 809
inputting 115, 117
number 117
voices 580, 809
rhythmic cues 458
changing cues into 458
moving 459
position 459
staff position 459

S
sample libraries 329
playback 319, 329
saving
character styles as default 279
chord symbols as default 434
engraving options as default 228
expression maps 326
graphics files 343, 344
instrument names as default 68
layout options as default 62
notation options as default 110
paragraph styles as default 276
percussion kits 783
percussion maps 333
playback options as default 312
scale degrees
chord symbols 168
noteheads 572, 577
scale size
barlines 380
chord symbol components 429, 431, 432
clef changes 447
cues 285
grace notes 285, 517, 520
note spacing 285, 289
notes 579
printing 341, 350
staves 702, 705, 706
time signatures 761
scales 536
degrees 427, 443, 572, 577
EDO 536
key signatures 533, 535
major 535
minor 535
octave divisions 536
scissors 741
scores, See full score layouts
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settings
default 230
flow-specific 110
layout-specific 62, 64
mouse input 108
preferences 53
project-wide 228
Setup mode 56
adding players 71
ensembles 71
flows 88
instruments 72
layouts 91
panels 44, 56, 57, 59, 61
percussion 77
player groups 86
players 65, 66
signposts 106
switching 56
sextuplets 771
shape
bar number enclosures 391, 392
beaming 409, 414, 417
frames 245
multi-segment slurs 675
noteheads 573, 577
rehearsal mark enclosures 645
slurs 673, 675, 677–679, 682
ties 742
tuplet brackets 775, 777, 779
sharps 355
inputting 135
quarter tones 359
short
barlines 380
stemlets 416
shortcuts, See key commands
shoulder offset
slurs 682
ties 743, 744
showing, See hiding
signposts 106
barlines 378
bars 378
chord symbols 437
cues 469, 474
dynamics 483
exporting 352
frame breaks 272
hiding 107
key signatures 545
note spacing changes 284
percussion legends 794
printing 352
showing 107
system breaks 272, 274
tempo marks 725, 728
time signatures 761
silence
hairpins 480
simile
dynamics 161, 482
simple time signatures 753

scrapes 633
inputting 199, 200
second voices
adding 118
secondary beams 414
changing 414
lines 414
resetting 415
secondary brackets 425
braces 425
sub-brackets 425
section players 65
adding 65
staff labels 690
segments
final 654
playthroughs 649
repeat endings 649, 650, 653
slurs 673, 674
selecting 45, 46, 108, 109
everything 109
filters 109
flows 109
frame handles 246
handles 228
items 104, 108, 109
lyrics 554
marquee 46
marquee selections 46
notations 46
note spacing handles 292
notes 46, 108
staff spacing handles 296
staves 109
system spacing handles 296
tools 45, 46
transposing selections 140, 549
selectors
music frames 249
semibreves 8
semiquavers 8
sends 317
separators
chord symbols 435
fingerings 509
systems 701
time signatures 752, 758
septuplets 771
sequences
bar numbers 398, 399
page numbers 239, 240
rehearsal marks 642
subordinate 399
types 643
sets
drum sets 77, 81, 783
master pages 231
setting up
duplex printing 341
key commands 12
percussion kit note input 122
windows 48
workspaces 48
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slurs (continued)
flat slurs 686
formatting 677, 679, 686
frame breaks 688
grace notes 664, 665
handles 673, 675, 679
height 680, 681
inputting 208, 668–670
inverting 663, 665, 684
large pitch ranges 679
length 671
linking 672
moving 670, 677, 678
multi-segment 675
nested 667
nested slurs 669, 670
ornaments 589
overlapping 687, 688
placement 454, 663, 665
playback 688
position 454, 663, 666, 667
ranges 679
rotating 678
segments, See slur segments
shape 673–675, 677–679, 682
short 679
shoulder offset 682
staff lines 666
styles 685, 686
system breaks 688
thickness 667, 679
ties 664, 665, 667
ties vs. slurs 737
tucking index 454
unlinking 673
within slurs 669, 670
solid
slurs 685
tempo marks 732
ties 746
solo players 65
adding 23, 65
staff labels 690, 692
staff size 705
soloing tracks 315, 316
deactivating 316
sordino 633
inputting 199, 200
sostenuto pedal 613
sound libraries, See sample libraries
sounding
duration 770
percussion legend ranges 794, 795
pitch 94, 690, 696
source instruments
cue labels 464
space size 702
spacing
accidentals 366
arpeggio signs 592
articulations 371
barlines 382
caesuras 185

single barlines 380
single-line
percussion kits 788, 789
staves 700
single-note tremolos 763
deleting 766
inputting 206
moving 767
playback 334
single-voice contexts 801
articulations 369
grace notes 517
stem direction 517, 711
tie curvature direction 749
sixteenth notes 8
size
clef changes 447
cues 457
frames 245
gaps 85, 748
grace notes 517, 520, 579
noteheads 573
notes 579
pages 62, 264
paper 350
staves 62, 702, 704, 705
system objects 702, 704, 705
time signatures 761
tracks 303, 306
slants
beams 407, 520
pedal line hooks 626
slashes
grace notes 517, 522
length 522
noteheads 573
notes, See tremolo strokes
stems, See tremolo strokes
time signatures 758
tremolos 763, 766
slur segments 673, 675
number 674
slurs 663, 737
accidentals 687
angles 678
articulations 370, 667
collision avoidance 687, 688
control points 675
cross-staff 668, 687
cross-voice 668
cues 467
curvature 663, 665, 667, 683, 684, 686
dashed 685
default settings 667
dotted 685
duration 688
East Asian elision 569
editorial 685
endpoints 667, 675, 677
Engrave mode 675
engraving options 667
filter 109
fingerings 504
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spacing (continued)
clefs 444
cross-staff beams 412
galley view 47
gradual dynamics 488
key signatures 546
layout options 62
lyrics 557, 559, 560
notes 284, 285, 289, 291
percussion kits 85
rehearsal marks 639
staves 294
system fullness 288
text 276, 279
time signatures 759
speed
arpeggio signs 597, 598
bpm 728
changing 729, 730
tempo marks 719, 729–731
tremolos 766
trills 585
spelling
accidentals 136, 137
notes 136, 137
split stems 357, 718
splitting
bars 378
beams 405
flows 221
project window 49
ties 741
spreads page arrangement 47, 346
square
noteheads 576
staccato 367
inputting 141
position 371
stacking order 454
accidentals 365, 366
changing 455
staff labels 690
changing first system indent 709
Cubase 691
default settings 692
engraving options 692
fonts 692
formatting 692
hiding 694, 695
indents 695
instrument names 67, 68, 70, 691
length 694, 695
MusicXML import 691
numbering 72, 691
numbering style 693
paragraph styles 692
percussion kits 77, 698, 788
showing 694, 695
transposing instruments 690, 696–698
uppercase 693

staff lines
slurs 666
thickness 707
ties 735
staff position
cues 459
staff size 702
changing 702, 704, 705
individual staves 705
layouts 700
rastral size 702
space size 702
staff spacing 294
changing 294, 296
copying 297, 298
default 294
handles 295, 296
layout options 62
moving systems 297
rehearsal marks 639
staff-relative placement
articulations 372
bar numbers 396
beaming 406, 407
cue labels 466
dynamics 489
fermatas 530
fingerings 503
lyrics 565, 566
octave lines 453
ornaments 589
pedal lines 614
percussion legends 796
playing techniques 636
rehearsal marks 639
text 283
trills 589
tuplet brackets 777
start area 41
start signs
appearance 626
pedal lines 625, 630
text 630
starting
area 41
hub 35
note input 114, 115
players 41
projects 22, 36, 41
workspaces 48
status bar 18, 45
selection tools 46
view types 47
staves 8, 700
barlines 384, 385
beaming 411, 412
brackets 423, 424
chord symbols 437, 440
clef for transposing instruments 447
crossing notes 411
cues 459
dialog 706
dividers 701
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staves (continued)
dynamic linking 494
dynamics 489
fermatas 531
first system indents 709
five-line 698, 700, 788
grids 698, 788
groups 385
hiding 89, 92, 268
indents 695, 700, 709
layout options 700
line thickness 707
moving 296
multiple voices 118
percussion 788
percussion kit presentation 789
playback 314
selecting 109
showing 89, 92, 268
single-line 698, 700, 788
size 702, 704–706
slurs 668, 672
system breaks 272
system dividers 701
system objects 707
text 214
ties 735, 739
uppercase staff labels 693
voices 118
Steinberg Hub 35
stem direction 711
beam groups 713
beam placement 406, 412
centered beams 410
changing 471, 714, 803
chords 712
cues 470, 471
default settings 714
filters 109
grace notes 517, 518, 521
middle line 711, 714
multiple-voice contexts 712
notes crossed to other staves 411, 807
notes on middle line of staff 711, 714
percussion kits 77, 123, 797, 798
resetting 407, 715
single-voice contexts 711, 715
slur curvature 663
staff-relative placement 407
tie curvature 735
voices 711, 715, 801, 803
stem length 716
stemless noteheads 717
stemlets 416
removing 417
showing 416
stems 711
altered unisons 718
articulations 372
beam placement 412
beaming 406
cues 470
default settings 716

stems (continued)
deleting tremolos 766
direction 470, 711, 714, 715
engraving options 716
flag design 716
flags 711
grace notes 520, 521
handles 717, 767
hiding 717
length 520, 716, 717
middle line direction 714
multi-note tremolos 769
removing direction changes 715
slur endpoints 667
split stems 357, 718
staccato position 371
stemlets, See stemlets
thickness 716
tremolos 764, 766, 767
tuplet placement 771
voices 711, 715
step input, See note input
stickings 787
stress marks 367
inputting 141
string instruments
fingering shifts 510
playing techniques 199, 200, 633
specifying string 581
substitution fingering 500
techniques 197
string shift indicators 510
angles 510
direction 511, 581
thickness 510
strokes
slurs 685
ties 746
tremolos 763–767
styles
breath marks 526
caesuras 526
fermatas 524
fonts 275
glissando lines 600, 601
margins 262
numbering 693
page numbers 608
slurs 685, 686
tempo marks 719, 731
text 276, 279
ties 746, 747
time signatures 755, 756
sub-brackets 425
secondary brackets 425
subordinate bar numbers 399
adding 400
substitution fingering 500
handles 501
position 501
suffixes
dynamics 482
rehearsal marks 644
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system spacing 294
changing 296
handles 284, 295, 296
system text 707
inputting 214
systems
bar numbers 389
breaks 262, 272
casting off 269
changing indents 709
dividers 701
end position 293
fixing bars 269
fixing per page 269
fullness 288
indents 293, 695, 700, 709
make into system 273
moving 296, 297
selecting 109
staff labels 709
start position 293
text 214
tonality 536
width 267, 293

suggestions
cues 218
sul ponticello 633
inputting 197, 199, 200
sul tasto 633
inputting 197, 199, 200
sustain pedal 613
continuation lines 628
Engrave mode 615
handles 615
level changes 614, 616, 617
MusicXML import 632
removing retakes/level changes 620
retakes 614, 616–618
sustaining instruments 499
SVG files 351
exporting 343, 351
fonts 345
swapping
note order 805
pages 243
voices 805
switching
frame handles 246
handles 228
layouts 16, 39, 94
modes 19
note spacing handles 292
staff spacing handles 296
tabs 50
syllables
position 557
types 555, 556
symbols
bar rests 377
caret 112
chords 427
ornaments 583
pedal lines 625
playing techniques 633
syncopation
stemlets 416
system breaks 262, 272
deleting 274
dynamics 486
filter 109
hairpins 486
inserting 273
make into system 273
signposts 106, 272, 274
slurs 688
staff labels 695
ties 738
system dividers 701
system fullness indicator 288
system objects 707
positions 708
rehearsal marks 639
repeat endings 648
size 700, 702, 704, 705
tempo marks 719, 720
text 214

T
tabla notation 800
tabs
bar 41
closing 50
groups 49, 51
hiding 40
layouts 48
moving 51
opening 21
order 51
showing 40
showing multiple 49
switching 50
view options 48
tacet al fine 659
Technique Combinations dialog 324
techniques 633
playback 637
templates 36
categories 36
opening 15
playback 309, 327
tempo 719
bpm 728
default 719, 726
metronome marks 728
range 729
tempo marks 719
abbreviated 721
absolute tempo changes 210, 719
alignment 720
appearance 726, 728
barlines 724
components 727, 728
continuation lines 719, 731, 732
dashes 732
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tempo marks (continued)
default settings 726
deleting 726
engraving options 726
filters 109
fonts 720
formatting 731–733
gaps 732
gradual tempo changes 210, 719, 730, 731
handles 723, 725
hiding 725
inputting 208, 212, 213
length 723, 725
metronome marks 719, 728, 729
moving 723
panel 210
parentheses 727, 728
placement 720
playback 719, 726, 729, 730
poco a poco 722
popover 209
position 720, 722, 726
relative tempo changes 210, 719, 730
reset tempo 210, 719
showing 725
signposts 106, 725, 728
style 731, 733
text 720, 721
types 209, 210, 719
Tempo panel 210
tenuto 367
inputting 141
terminology
British vs. American English 8
note durations 8
text
abbreviated tempo text 721
alignment 214, 259, 281, 515
character styles 279, 280
cue labels 465
cues 467, 468
dedications 513
dynamics 482
Edit Font Styles dialog 275
editor 214, 281
expressive 476, 482
filter 109
fingerings 509
flow titles 90
formatting 214, 274, 281
frames 254, 259
glissando lines 602
horizontal alignment 259
inputting 214
lyrics 555, 556
moving 258
paragraph styles 276, 283
pedal lines 630, 631
percussion legends 796
playing techniques 633, 636
rehearsal marks 639
repeat endings 653
staff labels 692

text (continued)
staff-relative placement 283
system text 214, 707
tokens 62, 254
uppercase staff labels 693
vertical alignment 516
text editor
Engrave mode 281
Write mode 214
text frames 254
entering text 258
horizontal alignment 259
inputting 244
paragraph styles 283
vertical alignment 516
text tokens 254
thickness
bar number enclosure lines 392
barlines 380, 385
glissando lines 605
grace note slashes 520
gradual tempo changes 733
lines 228
pedal lines 629
rehearsal mark enclosure lines 645
slurs 667, 679
staff lines 707
stems 716
string shift indicators 510
ties 742, 748
tick barlines 380
tie chains 735, 737
articulations 370, 737
clefs 444
deleting 741
selecting 737
slurs 664, 665, 667
splitting 741
tremolos 764
ties 735, 737, 738
accidentals 738
appearance 746
articulations 370, 737
breaking 741
cautionary accidentals 356
chains 741
chords 749
clef changes 739
clefs 444
collision avoidance 735
cross-staff 739
cross-voice 739
cues 471
curvature direction 742, 749, 750
dashed 746, 748
default settings 742
deleting 741
dotted 746, 748
editorial 746
engraving options 742
forcing 125
formatting 742, 747, 748
frame breaks 738
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time signatures (continued)
open 753, 757
panel 152
parentheses 151, 153, 758
pick-up bars 151, 153, 154, 753, 755
placement 752
popover 151
rest grouping 420
separators 752, 758
showing 761
signposts 106, 761
simple 753
size 761
spacing gaps 759
styles 755, 758
ties 738
types 151, 753
upbeats 755
title case
staff labels 693
titles
adding 62
changing 62, 90
flows 89, 90
projects 89
text tokens 254
tokens 254
date 256
flows 89, 255, 513
master pages 513
project information 62, 89, 255
time 256
titles 89
tonality systems 536
accidentals 540
changing 537
custom 537
key signatures 543
octave divisions 536, 539
panel 148
tongue clicks 633
inputting 197, 199, 200
toolbar 17, 39
transport options 39, 40
workspace options 39, 40
toolboxes 17, 45
Notations 97, 102
Notes 97, 98
Play 299, 300
tools
selecting 45, 46
tracks 301
chords 301
collapsing 303
expanding 303
muting 315
piano roll editor 303
playing techniques 301, 302
soloing 315
translation lyrics 554
changing lines to 564
popover 202

ties (continued)
gap size 748
half-dashed 746
handles 742, 743, 745
height 745
inputting 127, 739
inverting 750
laissez vibrer 739, 740
non-adjacent notes 739
non-standard types 738
note grouping 125
placement 735
position 665, 735, 742
shape 742
shoulder offset 743, 744
slurs 664, 665, 667
slurs vs. ties 737
solid 746
splitting 125, 741
staff lines 735
style 746, 747
system breaks 738
tie chains 737, 741
time signature changes 738
tremolos 764
voices 735, 749
TIFF files 351
exporting 343, 351
time
display 318
transport window 318
time and date
annotations 352
tokens 256
time bars, See repeat endings
time signatures 751
additive 753
aggregate 753
alternating 753
appearance 752
barlines 385
beam grouping 404, 420, 421
beat groups 756
changing 378
compound 753
custom 753
default settings 752
deleting 762
denominators 752, 756
engraving options 752
filter 109
font 752
height 752
hiding 761
inputting 27, 150, 153, 154, 378
Insert mode 378
interchangeable 753
irregular 753
moving 759, 760
non-power of two 753
note grouping 420
noteheads 756
numerators 752, 756
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tremolos (continued)
types 763
unmeasured 763
triangle
noteheads 575
trill lines 585, 587
hiding 587
length 586
showing 587
speed 585
trills 583
accidentals 584, 585
alignment 590
extension lines, See trill lines
filter 109
handles 586, 588
interval 584
length 586, 588
lines, See trill lines
moving 587, 588
placement 583
position 583, 590
speed 585
staff-relative placement 589
start position 590
triplets 771
tucking index 454
changing 455
tuning systems, See tonality systems
tuplet brackets 775
angle 777
end position 778
handles 775, 777
hiding 776
hooks 775
horizontal 779
length 775
moving 775
position 771
showing 776
tuplet numbers 779
tuplet ratios, See tuplet numbers
tuplets 771
accidentals 773
appearance 776, 779, 781
articulations 370, 773
beams 415, 775
brackets, See tuplet brackets
default settings 781
deleting 774
end position 778
engraving options 781
filter 109
formatting 779
handles 775, 777
hiding 779
hooks 775
horizontal brackets 779
inputting 131, 772
inverting 777
moving 773, 775, 780
nested tuplets 772
numbers 779, 780

transport
basic options 39, 40
playhead 313, 318
window 38, 318
Transpose dialog 139, 140, 549
transposed pitch 94, 690, 696
chord symbols 437, 441
clefs 447
layouts 93
part layouts 91, 93
showing 437
viewing 93
transposing 139
chord symbols 437
clefs 447, 473
cues 464, 473
dialog 139
instruments, See transposing instruments
key signatures 140, 545, 549
layouts 91, 93
notes 133, 135, 138, 140, 305
octaves 138
pitch, See transposed pitch
popover 133
selections 140
staff labels 697
transposing instruments 73, 437, 447
chord symbols 441
clefs 447
cues 460
instrument transpositions 696–698
key signatures 94, 535, 545, 550
register in cues 460
staff labels 690, 696–698
trees
altered unisons 718
stems 357
tremblements 583
tremolo strokes 763, 766
changing number 764, 766
moving 767
tremolos 763
angles 765
appearance 768, 769
default settings 768
deleting 766
duration 769
engraving options 768
formatting 769
inputting 206, 207
measured 763
moving strokes 767
multi-note 206, 763, 769
number of strokes 764, 766
placement 765
playback 769
playing 770
position 765, 767, 768
single-note 206, 763
speed 766
strokes, See tremolo strokes
tie chains 764
tuplets 763

857

Index

unpitched percussion (continued)
default settings 784
drum sets 81, 783
dynamics in kits 788
engraving options 784
exporting kits 783
ghost notes 786
grid kit presentation 82, 83, 85
groups 82
importing kits 784
Indian drum notation 800
individual instruments 782
instrument order 84
kits 75, 77, 782, 783
legends 794–796
MIDI files 799
moving notes 786
MusicXML files 799
naming groups 82
notation options 785
notations 787
note input 121–123, 307
noteheads 790, 792
parentheses 786
percussion maps 329
Play mode 307, 799
playback 329, 334, 790
playing techniques 334, 785, 787, 790
presentation types 77, 782, 788, 789
scrapes 633
staff labels 698
staves 77, 788, 789
stem direction 77, 123, 797, 798
stickings 787
techniques 633
tuplets 787
voices in kits 797
upbeats 753, 755
uppercase
staff labels 693
user interface 16, 35
music area 17
panels 18
status bar 18
toolbar 17
toolboxes 17
transport options 40
windows 38

tuplets (continued)
percussion kits 787
placement 454, 771
popover 131, 132
position 454, 771, 781
ratios 779, 780
showing 779
signposts 106
slurs 773
staff-relative placement 777
tremolos 763
tucking index 454
types 132, 771
Turkish music
octave divisions 536
turns 583
types
arpeggio signs 186
barlines 380
breath marks 182, 526
caesuras 182, 526
caret 112
chord symbols 168, 427, 428
clefs 176
dynamics 163, 476
enclosures 391, 392, 645
fermatas 182, 524
fingerings 143, 509
grace notes 521
holds 182, 524
key signatures 146, 535
lyrics 202, 554, 555
master pages 232
noteheads 573, 577
notes 100
octave lines 176, 448
pauses 182, 524
pedal lines 193, 613
percussion legends 795
playing techniques 197, 633
rehearsal marks 643
syllables 555, 556
tempo marks 209, 210, 719
ties 746
time signatures 151, 753, 758
tremolos 763
tuplets 132, 771

U

V

una corda pedal 613
unisons
altered 718
Universal Indian Drum Notation 800
unlinking
dynamics 496
music frames 251
slurs 673
unmeasured tremolos 763
playback 770
unpitched percussion 782
articulations 334, 787
cues 458

values
metronome marks 729
rhythmic grid 45
valves
fingerings 509
verse numbers 568
hiding 568, 569
punctuation 568
showing 568, 569
vertical position
articulations 372
breath marks 527
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vertical position (continued)
caesuras 527
cues 459
dynamics 477
fermatas 526
fingerings 500
instruments 70
lyrics 552, 554, 557
ornaments 583
pauses 526
pedal lines 614
players 70
playing techniques 633, 636
rehearsal marks 639
rests 656
slurs 663
tempo marks 720
text 283, 516
ties 735
tremolos 765
trills 583
tuplets 771
vertical spacing
articulations 371
percussion kits 85
staves 294, 296
vertical stacking order 454
changing 455
vibrato 633
inputting 197, 199, 200
view options 47
changing 45
chord symbol signposts 437
cues 474
frame break signposts 272
full screen mode 52
galley view 47
layouts 41
mixer 318
moving music 46
music area 42, 47, 52
notes 803
page arrangements 45, 47, 52
page view 47
panels 20, 44
percussion legends 794
rests 659
signposts 107
system break signposts 274
tabs 41, 48
time signature signposts 761
tracks 303, 306
types 47
voices 801, 803
windows 51
zoom options 48
vivace 719
inputting 209, 210, 212, 213
vocal staves
staff labels 692, 693
title case 693
uppercase 693

voice column index 806
swapping order 805
voices 801
accidental stacking order 365, 366
alignment 801
articulations 369
beaming 713
caret 118
changing 803, 804
colors 801, 803
column index 806
copying 804
cues 470, 471
deleting 804
drum sets 81
dynamics 164, 166, 480
fermatas 526, 531
filters 109
grace notes 517, 518
inputting 118
notation options 802
order 806
pasting notes into 804
percussion kits 797, 798
placement 801
position 801
rests 656, 661, 807–809
rhythm dots 580, 809
slurs 668
stem direction 711, 715, 797, 798, 801, 807
swapping contents 805
swapping order 805
switching 118
ties 739, 749
volta lines, See repeat endings
volume
channel meters 316
dynamics 476, 498
playback 498
VST and MIDI Instruments panel 299, 309
VST instruments 309
loading 311
percussion maps 334
playback 319, 329
whitelisting VST 2 plug-ins 311

W
walker
noteheads 577
watermarks 352
wedges
noteheads 575
Western tonality
key signatures 533
octave divisions 536
whitelisting plug-ins 311
whole notes 8
width
accidentals 366
barlines 380
empty bars 375
enclosures 392, 645
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width (continued)
frames 245, 261
graphics 432, 541
hairpin aperture 486
ledger lines 580
note durations 335
noteheads 575
systems 267, 293
wildcards 254
windows
floating 39
mixer 316, 318
moving tabs 51
multiple 48, 49, 51
opening 22, 51
project 38
splitting 49
tabs 49
transport 318
workspaces 48
wings
brackets 424
workspaces 32
key commands 10, 12
options 39, 40
preferences 53
setting up 48
Write mode 97
inputting notations 141
inputting notes 112
inputting vs. editing 104
notation options 110
panels 44, 97, 100, 103
signposts 106
switching 97
text editor 214
toolboxes 45, 97, 98, 102
Transpose dialog 139

Z
zoom 45
cues 474
options 45, 48
piano roll editor 306

860

